Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

What is FormFix

FormFix®, Version 3 is a forms registration and OMR (Optical Mark Recognition) component. Its primary purpose is to identify, register and drop out forms, as well as perform OMR, also known as MarkSense.

Primary Features Include:

General

  • Configurable settings to control the level of effort in completing form matching.
  • Selection and return of a best match.
  • Return of a configurable number of additional potential matches.
  • Return of a confidence value for each match performed.
  • Ability to identify and register forms even when exhibiting these characteristics:
    • Skew.
    • Smaller image size than the template.
    • Forms scanned at different resolutions than the template resolution.
    • Rotated from the template.
    • Warped images.
    • Printing variations.
  • Support of simple form registration.
  • Ability to limit a recognition operation to a subset of the available templates.

Drop-Out

  • Ability to reconstruct hand or machine printed characters that may have crossed the lines or guide text defining the form and were subsequently dropped out.
  • Configurable application of stroke restoration across areas of the image where the form was removed.
  • Support for form drop-out within specified regions of interest or the entire image.

OMR

  • The evaluation of MarkSense forms.
  • Algorithms for advanced recognition and accuracy of multi-mark fields.
  • Support of confidence analysis calculations.
  • Drop-out processing prior to mark detection.

FormFix Editions:

FormFix version 3 is offered in two editions, Standard and Professional, as listed below. FormFix Professional is the default edition which has the maximum functionality available.

  • FormFix Standard: includes ImagXpress Standard with TwainPRO, and ScanFix Xpress Standard in addition to FormDirector and a speed throttled edition of FormFix.
  • FormFix Professional: includes ImagXpress Standard with TwainPRO, and ScanFix Xpress Professional in addition to FormDirector and a full-speed edition of FormFix.

Additional Pegasus Imaging components in FormFix™ include:

  • FormDirector™ for form and form set definition.
  • ImagXpress™ for advanced image enhancement and clean up.
  • NotateXpress™ for adding image annotations.
  • PrintPRO™ for printing.
  • ScanFix® Xpress for image cleanup.
  • ThumbnailXpress™ to view thumbnail images.
  • TwainPRO™ to acquire images from TWAIN devices.

Additional Pegasus Imaging components in FormSuite™ include:

The FormFix component may be part of a larger suite of Pegasus forms processing components, called FormSuite™. FormFix will typically be used in conjunction with at least the FormDirector and ScanFix components, with a customer's application managing the relationship between them.

  • FormDirector™ for form and form set definition.
  • ImagXpress™ for advanced image enhancement and clean up.
  • NotateXpress™ for adding image annotations.
  • PrintPRO™ for printing.
  • ScanFix® Xpress for image cleanup.
  • SmartZone™ for zonal OCR recognition processing.
  • ThumbnailXpress™ to view thumbnail images.
  • TwainPRO™ to acquire images from TWAIN devices.

Note: Only binary images are supported in this release. The component will return an error when asked to act on a color or gray image. Conversion from color or grayscale images is available by using the included ImagXpress or ScanFix components.

For information on how to register and license all your Pegasus Imaging components, see Licensing.

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Getting Support and Samples

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#
  • HTML

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | FormFix| Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at:

http://www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page ( PegasusImaging.com/faq.htm ) for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.comare available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Send e-mail to Sales@JPG.com for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require runtime licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost.Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Send e-mail to Sales@JPG.com for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. E-mail Sales@JPG.com for more information.

To determine if you have the latest version of a Pegasus Imaging development toolkit, please download the PegConnect utility program. Please note that a Help File for each product may be found on the Start bar under Pegasus or in C:\Windows\Help.

For the latest and most up-to-date support information, access PegasusImaging.com/contactsupport.htm


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.pegasusimaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Fax: 813-875-7705

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ImagXpress, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Operating Requirements

FormFix Operating Requirements

Operating Systems

FormFix runs on 32-bit Microsoft Windows operating systems: 2000 Professional and Server, XP Home and Professional and Server 2003. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server and 2003 Server. Although it may run, it is not supported on previous Windows versions (for example, Windows 95 and Windows 98).

Threading

FormFix can perform as a synchronous thread-safe control.

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development environment

Microsoft .NET 1.0

Microsoft Visual Studio .NET 2002

Microsoft Visual Studio .NET 2003

Microsoft Visual Studio 2005

Microsoft Visual Basic 6

Microsoft Visual C++ 6

Delphi 7 and 8


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Installing on a Development Machine

To Install FormFix Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start|Programs|Pegasus Imaging|FomFix menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic 'Distributing with Your .NET Application' to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use FormFix Help Files

Stand-alone Help file "PegasusImaging.ActiveX.FormFix3.chm"

Access the FormFix stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | FormFix

The stand-alone complied Help chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 4 or higher
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, compiled collection help file "PegasusImaging.WinForms.FormFix3.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When FormFix installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging FormFix Help into Visual Studio

FormFix Help 2 files integrate within the Help system in Visual Studio .NET. To access FormFix Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the FormFix Help file to view Help content.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing FormFix in trial mode provides you with access to all features and functionality of the FormFix product. E-mail support is available with the trial license.

When using the trial version of FormFix, an evaluation dialog box displays periodically. Applications built with a trial license can only be run on a computer that has FormFix Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of FormFix in evaluation mode as follows:

  • To facilitate server/service mode evaluations, you can choose to halt the component processing after 1 minute in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the Licensing.EvaluationMode property.

Changing FormFix Edition

Installing FormFix in trial mode enables you to try out all the editions and add ons associated with FormFix, by setting the Licensing.LicenseEditionChoice property. Any edition for which you do not have paid licensing will display the evaluation dialog box or timeout. For example, if you have paid licensing for the FormFix Standard and you would like to evaluate FormFix Professional, you can change Licensing.LicenseEditionChoice property from Standard to Professional and use the functionality of Professional with evaluation dialog boxes displayed periodically.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Development Mode

To suppress the evaluation dialog box and attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the FormFix development kit.

1. Purchase Development Kit(s)

To purchase licensing of the FormFix development kit, use one of the following options:

  • Purchase online at http://www.PegasusImaging.com/. Contact Sales@PegasusImaging.com.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the FormFix Product

When you purchase FormFix online or through Sales@JPG.com, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at http://www.PegasusImaging.com/registration.htm.

If your registration information should change, visit http://www.PegasusImaging.com/contactsupport.htm for forms to update registration information.

3. Update Your FormFix product version from trial to paid licensing

Updating your FormFix from trial to paid licensing will suppress the evaluation dialog box or watermark. This must be done for each component within the FormFix toolkit that you are using (for example, FormDirector, FormFix, add ons).

To update components from trial to paid licensing

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.
  • Rebuild any applications that used the components with trial licensing

To distribute FormFix in an application, you must acquire runtime unlock codes (See Distributing with Your .NET Application).


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Runtime Licensing

Runtime & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

FormFix contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of FormFix. Prior to distributing an application that utilizes FormFix, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Runtime licensing, see the Pegasus Imaging website for more detailed information regarding Runtimes and Deployment Licensing.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does not grant any runtime licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Runtime Licensing information, please visit our web site (http://www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com or by fax at: 813-875-7705).

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Verify You're Using the Latest Service Pack

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Pegasus Imaging | Common | Utilities

PegConnect allows you to:

1) Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates

2) Update to the latest version automatically with your permission

3) Determine if a control is registered or unregistered on the machine

4) Easily change the registration status from registered to non-registered, or non-registered to registered

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Distributing with Your .NET Application

Distributing FormFix

Check for Proper Licensing and Unlock Codes

FormFix contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of FormFix. Prior to distributing an application that utilizes FormFix, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the FormFix Product.

PegasusImaging.WinForms.FormFix.dll - .NET component - Needed for Form Drop-out, Identification, Registration and OMR processing.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Definitions, Acronyms and Abbreviations

Pegasus Imaging Definitions:

Accuracy Rate: the percent of the text which was recognized correctly. It will be stated in percent and never be greater than 100%.

Alternate Results: when more than one possible result can be returned by the recognition algorithms, each with an associated confidence setting. The initial result is called the result, and any additional character results are called the alternate results. They generally have confidence settings lower than the initial result.

Blob: an isolated connected group of pixels.

Drop-out: a process whereby the pre-printed content on an image is removed, leaving only the data that was added to a form. When filled and template data overlap, the filled data will be reconstructed as accurately as possible.

Edit Distance: the minimum number of insertions, deletions, and replacements of characters needed to change the recognized text to the correct text.

Extraction: a synonym for form drop-out. FormFix v2 uses this term instead of drop-out. FormFix v3 will discontinue use of the term, extraction. Instead, it will refer to the process as drop-out.

Field: a single rectangular region on a form defined by pixels, along with a type and various other attributes. Frequently, a field will wholly contain a single user-filled item, such as a last name or phone number.

Filled data: data, either hand-written or machine-printed, that is added to a form. Reading filled data is usually the primary goal of a forms-processing system.

Form: a single template image, along with various attributes and properties of the form. Forms contain zero or more fields and are part of a single form set. Form will generally refer to a single side of a single sheet although it is possible to have multiple logical form pages on a single form. For example, a 4-page, 8.5 x 11 form could be unfolded and scanned at 11 x 17 as two forms.

Form Document: a customer-defined, logical document comprised of one or more related sheets, with information on one or both sides of each sheet. Some examples would be a one-sheet, front and back credit application, a six-page front-only mortgage application or a 32-page student test booklet. The FormFix component will have no explicit support for form documents.

Form Definition File: a file which defines a single form and all of it's fields read and written by this component. The form definition files will be wholly contained, including a template image with no references to external files. The extension of .frd will be used for all files of this type.

Form Document: a customer-defined, logical document, comprised of one or more related sheets, with information on one or both sides of each sheet.

Form Set: a collection of zero or more forms. The FormFix component will have explicit support for form sets, in order to support identification of a form within the set.

Form Set File: a file which defines a collection of form sets and/or form definitions including all the data that defines them. The extension of .frs will be used for all files of this type.

OMR (Optical Mark Recognition): the process of capturing data by contrasting pixel densities at predetermined positions on a form. In the context of Pegasus document processing, it specifically refers to the process of discriminating between marked and unmarked circular, oval, square or rectangular bubble or bubble's typically arranged in a row and column grid on a form.

OMR Bubble: a circle, oval, square, or rectangle used on a business forms to delineate areas that are to be hand filled or marked to indicate a choice.

OMR Bubble Value: a string associated with a bubble. If the bubble is determined to be marked, this string is then the result value of the segment that bubble resides in.

OMR Mark-box: a specific type of field that contains a single bubble. The concept of orientation is meaningless for a Mark-box.

OMR Marked Threshold: a mark recognition image pixel density user settable adjustment value that specifies a minimum normalized pixel density threshold for determining a marked bubble.

OMR Multi-mark: A multi-mark field expects that more than one bubble may be marked per segment and processes accordingly but at the cost of reduced recognition accuracy. The default behavior for OMR field processing is that a maximum of one bubble per segment is expected to be marked.

OMR Unmarked value: a string associated with a field that specifies the result value for any segments in the field determined to have no bubbles marked.

OMR Multi-segment field: a field that contains a grouping of multiple related segments in order to facilitate recognition processing and the retrieval of result values in a grouped manner. An example of a Multi-segment field on an OMR form would be a Social Security number field, with a segment comprising each digit Recognition result values can be retrieved concatenated on a per field basis or one by one on a per segment basis

OMR Orientation: relationship of a segment or segments in a bubble grid to the top edge of a form image. If the bubbles of a segment run parallel to the top edge, the orientation is Horizontal. If the bubbles of a segment run perpendicular to the top edge, the orientation is Vertical. For multi-segment fields, orientation also provides a concept of a result order. By default, the result order for a horizontally oriented field is left to right. However, orientation can be specified as Horizontal with a result order of right to left. By default, the result order for a vertically oriented field is top to bottom. However, orientation can be specified as Vertical with a result order of bottom to top.

OMR Segment: A set of one or more bubbles that after recognition provides a discrete result value, it is the base unit of OMR recognition in FormFix. An example of segments on an OMR form would be the individual digit selection bubble groups of a Social Security number field. A segment’s bubbles in a non-Multi mark field are expected to be marked in a mutually exclusive manner. Initial FormFix releases may limit a segment to spanning either a single bubble row or column.

OMR Unmarked threshold: a mark recognition image pixel density user settable adjustment value that specifies a maximum normalized pixel density threshold for determining that a bubble is unmarked.

Persistent data: data that is created by the FormFix component and stored for use by a future process. Persistent data should also be made available to other components. Persistent data is always tied to a specific form or form set.

PIC: Pegasus Imaging Corporation

Semi-structured form: a form, whose layout changes from instance to instance or whose layout is not precisely known in advance. Examples are a set of invoices from unknown vendors and a set of phone bills from a single vendor (with each having a different number of pages).

Structured form: a form, whose layout does not change from instance to instance and whose layout is known in advance. Structured forms are usually developed by the same organization who must process them or are printed to meet a formally-defined standard. Examples are credit card applications, 2000 census forms, tax forms, and medical forms.

Successful registration: production of transform parameters which result in registration of all parts of an image to a specific tolerance.

For testing purposes, you can only measure successful registration on certain images. Those images are ones that can be brought into precise registration (within 2 pixels) to a template using an affine transform. Common examples that would not meet that definition are images that are unevenly distorted due to scanning or printing and images that are curled.

Registration: to create registration parameters, not necessarily to move the pixels within an image to new, registered, locations.

Template: a full image of the original form, without any additional data added to it. Also called a "blank form", a template comprises all the content that is common to all images of a given form, and only the content that is common to all images of a given form.

Thread-safe: an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Unknown image: an image containing a form of unknown identification. During processing, all images of forms are referred to as unknown images, until after the image has been recognized as a form.

Industry Terms:

Electronic Document: A document that has been scanned, or was originally created on a computer.

Forms Processing: An imaging application for handling printed forms. Forms processing systems often use OCR engines and data validation routines to extract hand-written or printed information from forms that go into a database.

ICR (Intelligent Character Recognition): machine recognition of hand-printed characters as well as machine printing that is difficult to recognize.

MICR (Magnetic Ink Character text Recognition): It consists of 14 characters. The ten digits and four control characters defined as A, B, C, and D. It is used mostly in the banking industry. It is the numbers on checks that describe the routing and account information.

Noise: irrelevant or meaningless data

OCR (Optical Character Recognition): reading text from paper and translating the images into a form that the computer can manipulate.

OMR (Optical Mark Recognition): the technology of electronically extracting intended data from marked fields, such as check-boxes and fill-infields, on printed forms.

Unicode: A character set that can support a wide range of international characters. Unicode requires 16-bits to encode a character, unlike ASCII, which requires only 8 but supports only a small subset of characters beyond latin.

UI (User Interface): the controls or API provided for user interaction with an application or component.


Glossary Item Box

Interaction with Other Pegasus Imaging Components | Perform Drop-Out | Identify and Register Images

See Also

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Overview

FormFix can be used in several different types of applications as follows:

Form Processing

In a typical form processing system, your goal is to take images of various forms, recognize them, extract data from them and save that data in a database.

You will want to use the following components in this scenario:

  • FormDirector to define the forms and fields.
  • FormFix to identify the images and drop out the form and to perform OMR if necessary.
  • SmartZone to read machine and hand-printed data.
  • ScanFix to perform some image clean-up at certain stages of the operation.

Identification

In some cases, you may want to use a different method to identify your forms. For example, if you control the layout of your forms, you may be able to get faster and more reliable recognition by placing a different barcode on each type of form. Even in this case, you will probably still want to use FormFix's identification process since it also precisely registers your images. Simply use the provided mechanism to limit identification to the single, correct template. You should also investigate FormFix's registration mark functionality as it may be faster and more reliable.

Drop-out

There are alternates to using FormFix's drop-out algorithm, which are better in some cases.

Many forms-processing applications achieve very good results using a drop-out bulb on each scanner. You must match the color of the bulb to the color of the form and you must be careful not to allow your user's to enter filled data using the drop-out color. Although the drop-out performance is excellent, identification and registration can be quite difficult unless you can use a barcode or other technique for identification and some form of registration marks for registration. FormFix has functionality to help you register your images using registration marks.

Use ScanFix in place of Drop-out

ScanFix has line and comb removal technology that you can use in place of FormFix's drop-out in some cases. Unlike using color drop-out bulbs on a scanner, you can select between ScanFix and FormFix on a field-by-field basis to get the best performance in every case.

The most common uses of ScanFix are to deskew images before identification and to remove noise on field clips before extracting data from them.

Single-Form Processing

A common simplification of general forms processing is a similar system that accepts only a single form. This is common in very low volume applications where a user scans and interactively processes a batch of pages with a consistent form. It is also common in a few high-volume applications, when a company sends out a single form to be filled out and returned for processing.

Although this scenario differs from the one above because form identification is not necessary, you can treat it the same as general-purpose form processing with an alternate form identification method, such as barcode.

Image Sorting

In an image sorting application, your goal is to take images of various forms, sort them by type, then archive the result.

Typically, little or no data is captured in this type of system.

Use these components in this scenario:

  • FormDirector to define the set of candidate forms.
  • FormFix to identify the images.
  • ScanFix to perform some image clean-up.

If you want to align your archived images to match your template images, you should use FormFix to align them before you save them to disk and archive them.

You should consider other options in the following situations:

Unstructured Form Processing

FormFix is designed to work with forms that have a consistent layout and can be prepared in advance. If you wish to process free-form documents, FormFix will not be very helpful. FormFix works best when processing semi-structured documents (such as invoices) and dealing with thousands of different forms.

See Also

Interaction with Other Pegasus Imaging Components | Perform Drop-Out | Identify and Register Images


Glossary Item Box

Getting Support and Samples | Overview

See Also

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Interaction with Other Pegasus Imaging Components

Pegasus Imaging Forms Processing Suite

Although you can use FormFix on its own, it is most powerful when you use it in conjunction with our other forms processing suite of components including FormDirector, ScanFix and SmartZone.

Along with FormDirector, FormFix forms the foundation for a strong form-processing system. FormDirector manages the definition of form sets, forms and fields, then provides that information to the FormFix component as necessary. FormFix then identifies, registers and creates field clips from which other components, such as FormFix can extract data. ScanFix provides various image enhancements of either whole images or field clips.

At no time does FormFix automatically and directly interact with another Pegasus Imaging Corporation component. You must always manage that interaction. While this seems a little less convenient, it allows Pegasus Imaging to deliver flexible and quality components while allowing the freedom to mix and match component versions and vendors to create the best possible solution for your product. Sample code for all interaction between our components and knowledgeable technical support are provided in case you have issues of any kind.

See Also

Getting Support and Samples | Overview


Glossary Item Box

FormModel Class | IdentificationProcessor Class | OMRProcessor Class | DropOutProcessor Class | Handle FormFix Events

See Also

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Form Sets, Forms and Fields

Processor Classes Provide Form Objects

FormFix works with form sets, forms and fields but it does not have classes that directly represent form sets and fields. Instead, it relies on several "processor" classes for that purpose.

FormModel and Forms

FormModel objects directly correspond to forms. As opposed to the more traditional approach of setting properties of a FormModel object to specify its attributes, you specify the properties whenever a FormModel requests them. Each FormModel has a set of events it will raise whenever it needs some information about a form.

The FormModel events include:

  • ReadChecksum - An event for retrieving a checksum for the persistent state of a form.
  • ReadDataItem - An event for reading a data item from the persistent storage.
  • ReadFormImage - An event for reading a form model image.
  • WriteDataItem - An event for writing a data item to the persistent storage.

IdentificationProcessor and Form Sets

IdentificationProcessor objects most closely match form sets. In essence, they serve to both define a collection of forms and to recognize unknown images.

DropOutProcessor, OMRProcessor and Fields

FormFix has no class that closely represents a field. Instead, it has a DropOutProcessor object that can create field clips and an OmrProcessor that can capture information from clips of OMR fields.

See Also

FormModel Class | IdentificationProcessor Class | OMRProcessor Class | DropOutProcessor Class | Handle FormFix Events


Glossary Item Box

Handle FormFix Events

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Private Data and Image Handling

Managing Resources

The FormFix architecture is structured to balance access to template images, the need to limit memory consumption, the need to carefully examine template images and the need to identify images quickly as explained below.

Templates

For most of its operation, FormFix requires a copy of template images. A straight forward approach to providing template images to FormFix would be to simply have a property or method that lets you provide the template for a FormModel object. Unfortunately, that approach is not viable if you have thousands or hundreds (or perhaps even dozens) of forms due to the amount of memory that is required. Instead, FormFix implements the ReadFormImage event mechanism whereby it can request a template image whenever it needs one.

The FormModel object also includes the ReleaseCachedData method that allows you to force the object to discard the template image it might contain.

Template Analysis

In order to spend sufficient time analyzing template images prior to form identification and still operate quickly, FormFix allows access to persistent storage using the WriteDataItem event to save the result of template analysis. This analysis is rather time-consuming and subsequent runs of identification will run much faster if FormFix can save the result of the analysis for use at a later date. FormFix's FormModel and IdentificationProcessor both have a pair of events, WriteDataItem and ReadDataItem that FormFix will use to save and retrieve the results of it's form analysis. Unless you have a very small number of forms or run your forms-processing application for weeks at a time, you will get a substantial performance boost by properly saving and restoring the data items as FormFix requests.

Normally, you will save the data items in form definition and form set files using FormDirector. Simply save them in the OtherDataItems property of a FormSet or FormDefinition using FormDirector. See the FormDirector help files for more information.

See Also

Handle FormFix Events


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

OMR Objects

Introduction

FormFix uses an OMR model or template to define an OMR field bubble, a processor to perform analysis, streaming and define properties, and a few resulting objects to store and perform OMR on forms, fields and form sets.

Models and Templates

OmrBubbleModel - The OMRBubbleModel is used as a template to define the OMR field bubble for analysis.

  • Value - Specifies a character or string of characters to define the Bubble Value object. If the bubble is determined to be marked by analysis, this value will return in the result. The value size cannot be greater than 512 bytes in size or unfavorable results may occur.

OmrSegmentModel - The OmrSegmentModel is used as a template to define the OMR field segment for analysis.

  • Bubbles - Contains a collection of OmrBubbleModel objects.

OMR Processor

OmrProcessor - The OmrProcessor is the backbone of the OMR analysis. With this object you can analyze your field, Read and Write to and from a stream, perform analysis comparisons and define and store many of the necessary properties. These methods and properties are further defined below:

  • AnalyzeField - Perform OMR analysis on an image.
  • Dispose - Remove unnecessary resources.
  • ReadFromStream - Read a pre-defined stream which contains values and properties for forms processing and analysis.
  • WriteToStream - Writes to a stream to store values and properties for forms processing and analysis
  • AnalysisComparisonMethod - Defines the image comparison method to be used from the OmrAnalysisComparisonMethod enumeration.
  • Area - Defines the rectangular area of the OMR field in pixels.

Example of a defined area outlined for OMR analysis.

  • BubbleShape - Defines the geometric shape of the bubbles in a field. Options are taken from the OmrBubbleShape enumeration.

Example Bubble Shape, Circle.

Example Bubble Shape, Rectangle.

  • FormModel - The FormModel used for comparison processing during analysis.
  • MarkedBubbleThreshold - Defines the marked bubble analysis threshold value of the field segment. Threshold values should vary depending on the Bubble Shape. See Analyze OMR Fields for more information.
  • MarkScheme - Defines the bubble mark scheme. Options are taken from the OmrMarkScheme enumeration.

Example showing a five column single-mark field:

          Example of a multi-mark field:

          • MultiMarkDelimiter - Defines the delimiter to use to separate result values.
          • MultiSegmentReadDirection - Defines the read direction used for determining field results. Options are taken from the OmrMultiSegmentReadDirection enumeration.

          Example Horizontal, left to right, top to bottom.

          Note: This direction is enabled when the OmrOrientation is set to HorizontalSegments and the OmrMultiSegmentReadDirection is Normal.

          Example Vertical, top to bottom, left to right.

          Note: This direction is enabled when the OmrOrientation is set to Vertical and the OmrMultiSegmentReadDirection is Reversed.

          • Orientation - The orientation of a field's one or more segments to the top edge of a form image. Values are obtained from the OmrOrientation enumeration.
          • OriginOfClip - Defines the origin coordinates for a clipped image if CompareClipToFormModel analysis comparison is requested.
          • Segments - Defines the OmrSegmentModelCollection which represent the core bubble grid dimension and result value data for field analysis.
          • UnmarkedBubbleThreshold - Defines the unmarked bubble analysis threshold value of the field.
          • UnmarkedSegmentResult - Defines the unmarked segment result value of the field.

          OMR Results

          OmrBubbleResult - The bubble result of OMR analysis processing.

          • Area - The rectangular coordinates in pixels which define the bubble result.

          OmrFieldResult - The OMRFieldResult object is the result of OMR analysis on a field.

          • Confidence - Defines the result analysis confidence value for the field.
          • Segments - A collection of OMRSegmentResult objects that contains the field segment level analysis result data.
          • Text - The text string result from the field analysis.

          OmrSegmentResult - The OMRSegmentResult object contains the result of OMR analysis on a field segment.

          • Bubbles - A collection of OMRBubbleResult objects which contain the segment's one or more bubble analysis result data.
          • Confidence - Defines the result analysis confidence value for the segment.
          • MultiMarkValues - A collection of strings which contain the segment's Multi-mark analysis result text data.
          • Text - The text string result from analysis on a segment.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Identify and Register Images

Supplemental Identification

There are many ways to perform identification apart from using the IdentificationProcessor. For example, your forms may have a bar code that uniquely identifies the matching template, or your forms may have a revision number printed in one corner. IRS forms have data printed in the top left and right corners that can be used to identify each form. You may be able to constrain the template choices based on whether you are processing the front or back of a sheet. In very unusual situations, you may be able to hand-sort your forms.

Two ways to insert supplemental identification are:

  • Perform identification on your own and then run the identification with an IdentificationProcessor, constrained to the form you selected. In this case, the identification stage is simply performing registration. See the LimitIdentificationToSubset property.

If you are certain that you will need to supplement identification and you can reliably perform identification before your images are precisely registered, this is the best approach. A good example is a case where all forms have a barcode that can easily be found and read and that uniquely identifies the matching template.

  • Attempt identification with an IdentificationProcessor, and then use a supplementary algorithm to handle problems. The confidence values produced by identification can be very useful in selecting the correct form. Once you have narrowed the list of templates down to a single template, you can continue processing using the registration information available using GetRegistrationResult.

This is the best approach so you do not always need to supplement identification or when you cannot use your supplemental identification process without performing registration first. A good example is processing a 16-page form where pages 13 and 14 are identical except for the page number. The IdentificationProcessor can very precisely indicate what part of the page needs to be recognized to accurately determine which page is being processed.

Identification Quality

Many identification problems can be resolved by increasing the IdentificationQuality property. The default value is 50 and works in many instances. Increasing the value will dramatically improve the abilities and quality of the identification process at a significant increase in CPU time needed for each image.

Template Selection

If you plan to use the drop-out feature of FormFix, the templates should be blank. However, if you will only perform identification, the templates can contain filled data. the filled data generally has no impact on the accuracy or speed of identification.

Registration

Registration errors are often identification errors and may be treated as false negatives. See Correct Image False Negatives and Positives for some techniques that may correct registration errors.


Glossary Item Box

Improve Performance | IdentificationProcessor Class | FormImage Class

See Also

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Enhance Images

Image Capture

The quality of the images has a dramatic affect on all aspects of form processing.

To increase processing performance, try the following:

  • Increase the resolution (300 DPI is a good minimum and 400 DPI is often better).
  • Adjust the brightness or use an automatic setting
  • Different scanners may provide different results.

Note: Consider using the ScanFix component for advanced image clean up functions. See Improve Performance for more information on processing performance issues.

Image Enhancement

When enhancing images, it is important to remember that the term "enhancement" is subjective. An enhancement that makes an image look good may reduce the identification accuracy. For example, changing the brightness or contrast may produce a better-looking image, but can easily reduce identification accuracy. It may also reduce the effectiveness of drop-out and OMR.

Enhancements to possibly avoid:

  • Brightness
  • Contrast
  • Line Removal
  • Shade Removal

Enhancements to consider:

  • Scanner - The best place to start improving the quality of the images is at the scanner. IF that is not possible or doesn't help enough, use the ScanFix's powerful image enhancement capabilities.
  • Deskew - Template images should be deskewed if possible. While deskew is not necessary for filled forms, if they are commonly skewed, deskewing them before sending them to identification can improve accuracy and reduce processing time.
  • Cropping - another enhancement to consider is cropping. If images have a large border, removing it may improve identification.

Note: If image enhancement is planned for the filled images, you should consider performing the same enhancements on the template images.

Image Resolution

One of the most common causes for identification failure, is missing or inaccurate image resolutions.

Possible causes of this are:

  • The file format.
  • The method used to load images from disk.
  • The method used to transfer images into FormFix. Several common image-editing packages do not correctly store the resolution in the file.

An IdentificationProcessor relies heavily on the resolution of both the templates and filled forms. If the resolution of the images is incorrect or missing, identification usually fails. If the resolution of your images is incorrect, you can correct it after importing it into FormFix by using the resolution properties of the FormImage object.

See Also

Improve Performance | IdentificationProcessor Class | FormImage Class


Glossary Item Box

Identify and Register Images | Enhance Images

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Perform Drop-Out

Drop-out is a process whereby the pre-printed content on an image is removed, leaving only the data that was added to a form. When filled and template data overlap, the filled data will be reconstructed as accurately as possible. Because drop-out is an important part of forms processing, it's important to follow certain guidelines as described below.

Improving the Quality of Drop-Out

Drop-out problems are usually caused by poor registration, but some may also be due to distortion of the form.

If drop-out leaves pieces of the form across the entire page, the problem is probably poor registration. Please refer to the sections on identifying images for more information. If drop-out leaves pieces of the form in only one or a few areas, the problem is probably distortion of the images.

When resolving distortion problems, the first thing to consider is the possibility that two separate revisions of the same form are being processed. Sometimes this can be caused by the creator of the form making a change without recording it, or the form's revision number having been changed. This can also be caused by differences in printers. The same form printed by separate printers can contain font changes that cause drop-out to fail. If this is the case, see the section on handling similar forms during identification for additional suggestions.

Possible Methods to Improve Drop-Out Performance

  • Turn off PerformReconstruction if you do not need it.
  • Try reducing the value of AllowableMisRegistration, but setting that value too small may cause some forms to drop-out poorly.
  • With overlapping fields, consider using one larger field instead of multiple overlapping ones. The number of pixels contained in each field is the dominant factor in performance and each pixel that is part of two separate fields takes twice as long to extract.
  • In the case of several very small fields that are near each other, assess the use of one large field that covers all the desired pixels. There is a small amount of fixed time used for each field and for very small fields that time can be higher than the time spent processing each pixel.
  • If the field is large, but not all the pixels within it are used, study the possibility of using several smaller fields. this will eliminate time spent processing pixels that you will not use.

Alternatives

Form drop-out is very similar to the line-removal and comb-removal within ScanFix. In some cases, you will get better results by using those technologies.

Comb Removal in ScanFix

See Also

Identify and Register Images | Enhance Images


Glossary Item Box

OMR Objects | OMRProcessor Class

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Analyze OMR Fields

Define OMR Bubbles, Segments and Fields

Bubbles

  • An OMR bubble is defined in this document as a circle, oval, square, or rectangle used on business forms to delineate areas that are to be hand filled or marked to indicate a choice.
  • Use the OmrBubbleModel to define a bubble model or template and pass in the Value of a character or string which contains the value used for OMR analysis.
  • The OmrBubbleModelCollection which contains many OmrBubbleModel objects can then used in the OmrSegmentModel object for further OMR analysis.
  • The OmrBubbleResult will give the result of the OMR bubble analysis and the Area defined in that analysis.

MarkBox

  • A MarkBox is essentially a single OMR bubble used to determine checkboxes on forms.

  • This type of bubble is defined using a regular bubble model except the MarkedBubbleThreshold value should be lower. This is due to an expectation that a check mark will contain a lower pixel density than a filled OMR bubble.

  • This type of analysis is supported through the use of the OmrBubbleModel objects.

  • The example MarkBox image below would ideally be processed as a single mark segment allowing multiple marks.

The preferred method of handling this case would be to process it as a single mark to enable the algorithm to determine the boundaries of each mark, and produce better accuracy.

The next option, is to process it as four single bubbles. In this case, the bounding area coordinates need to be closely defined around the bubble, and the marked threshold should provide the anticipated pixel density of the marking, around 15%.

As is always the case, application developers are encouraged to test with their data to understand how to obtain their best results.

Example Single Mark segment for MarkBox type

Segments

  • An OMR segment is defined as a rectangle containing a specified number of columns and rows of bubbles to be evaluated.
  • Use the OmrSegmentModel to define a segment model or template and define the Bubbles to be analyzed.
  • Based on the bubble shape specified by the BubbleShape property, the discrete areas of the bubbles, counting dark pixels to determine which bubble areas qualify as "filled in". Threshold values can be set using the MarkedBubbleThreshold and UnmarkedBubbleThreshold properties, to specify the percentage of fill required to constitute a “filled in” bubble. The pixels that make up the bubbles themselves are counted in this process.

  • The appropriate text and confidence score is returned in the results for the filled-in bubbles.

Signature Detection

  • Signature detection is provided by selecting the area around the signature and creating a single bubble field to detect it.
  • This type of analysis is supported through the use of the OmrBubbleModel objects.

Fields

  • A field contains the OmrSegmentModelCollection with their bubble analysis data.
  • Define a field through the properties and methods in the OmrProcessor object.
  • Field results including the Confidence, Segments and Text are obtained within the OmrFieldResult object.

Guidelines and Adjustments for Marked/Unmarked Analysis

OMR is the process of comparing a filled form to a blank form and determining if data has been added. The result is marked or unmarked areas of interest on forms, fields, segments and bubbles. This determination provides feedback if a check-box has been selected, if a number has been circled, or if a form has been signed. The size and shape of the selection area should not hinder the ability of the mark analysis to determine if it's marked or not.

The following guidelines should be used to obtain the optimal OMR analysis.

Unmarked Bubble Threshold

  • UnmarkedBubbleThreshold specifies the minimum percentage of pixel density difference between bubbles that must occur in order for the 'position' to be considered to contain a marked bubble. Put another way, a position having a bubble density difference equal to or less than the percentage specified by the UnmarkedBubbleThreshold will be considered an unmarked position and will return in the results for that position the character specified by UnmarkedSegmentResult.
  • UnmarkedBubbleThreshold adjustments will at times be required, typically to adjust for unmarked positions being incorrectly identified as marked.
  • The lower the UnmarkedBubbleThreshold value, the better the recognition engine will be able to identify marginally marked bubbles. However, raising this value enhances the recognition engine's ability to correctly identify unmarked positions. If unmarked positions in an OMR field are being incorrectly identified as marked, raise the UnmarkedBubbleThreshold value a percent or two at a time until testing reflects accurate results. In summary, the UnmarkedBubbleThreshold should be set to as low as possible a value that will still allow the correct identification of unmarked positions.
  • The value of MarkScheme (single or multi mark) determines the typical values of UnmarkedBubbleThreshold.

    • SingleMark — If set to this value, 9 is the general value to use with UnmarkedBubbleThreshold.

    • MultiMark — If set to this value, 15 is the value to use.

Marked Threshold Guidelines

  • MarkedBubbleThreshold specifies a pixel density percentage that is used to determine the accuracy confidence value of (any) marked bubbles in a 'position'. Basically, a marked bubble whose density exceeds the FieldOmrMarkedThreshold value has the potential to receive a 100% confidence rating depending on the density proximity of the other bubbles in the position. Put another way, marked bubbles having a pixel density of less than the FieldOmrMarkedThreshold will always have a confidence value of less than 100%.
  • OMR confidence is calculated per OMR field and represents the averaged confidence value of all positions in the field. The confidence value per position is calculated by comparing the most densely marked a bubbles' pixel density against the MarkedBubbleThreshold value and against the marked density of the other bubbles in the position. The higher the ratio in these comparisons the higher the confidence.

MarkScheme Adjustment Guidelines

The value of MarkScheme (single or multi mark) determines the typical values of MarkedBubbleThreshold. These values are selected from the OmrMarkScheme enumeration.

  • SingleMark — A lower value for MarkedBubbleThreshold will raise relative confidence values and a higher value vice versa. Typically however, to adjust the sensitivity of the recognition engine, the MinimumConfidence value (see below) should be used rather than the MarkedBubbleThreshold for the SingleMark field. The MarkedBubbleThreshold value has a larger role in fields with a MarkScheme of multi-mark due to the relative confidence being more difficult to determine for these types of fields.

  • MultiMark — the MarkedBubbleThreshold value will need to be raised from the default value to typically somewhere in the 55 to 65 range. To reduce the number of unmarked bubbles identified as marked raise the value (at a cost of sensitivity to marginally marked bubbles). If the opposite is desired lower the value. MarkedBubbleThreshold adjustments should be infrequent for field MarkScheme of single-mark, but will be required for field MarkScheme of multi-mark.

See Also

OMR Objects | OMRProcessor Class


Glossary Item Box

OmrProcessor Class

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Process OMR

Typical OMR processing steps

  1. Instantiate an OmrProcessor object.
  2. Modify any OmrProcessor properties whose default values are not appropriate for the recognition task at hand.
  3. Instantiate an OmrSegmentModel object for each segment the field contains.
  4. Instantiate an OmrBubbleModel object for each bubble in a segment. Set each bubbles' OMRBubbleModel value property with its representative string or character value. Add the OmrBubbleModel objects to the segments' OmrSegmentModel.Bubbles collection property.
  5. Add all the instantiated OmrSegmentModel objects belonging to the field to the OmrProcessor.Segments collection property.
  6. Instantiate a FormImage object and set it to the image to be OMR analyzed. Typically this image will be the result of a registration or deskew operation and have undergone image "clean-up" processing.
  7. Call the OmrProcessor.AnalyzeField method, passing the FormImage as a parameter.
  8. On successful completion, the OmrProcessor.AnalyzeField method returns an OmrFieldResult object. The OMRFieldResult object contains field level analysis results such as text and confidence values. If finer detailed analysis results are desired the OmrFieldResult.Segments property allows access to a collection of OmrSegmentResult objects that contain analysis results on the segment level. Additionally the OmrSegmentResult.Bubbles property contains analysis results on a bubble level.
See Also

OmrProcessor Class


Glossary Item Box

Handle Similar Templates, Drop-Out and Faxed Images | Enhance Images | IdentificationProcessor Class

See Also

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Correct Image False Negatives and Positives

Correcting False Negatives

Poor quality images are a common cause of false negatives (for more information, see Enhance Images. Images with specks or borders may identify slightly less accurately than clean images. Distorted images, such as bad faxes, will rarely pass identification. For more information, see Handle Similar Templates, Drop-Out and Faxed Images.

Adjust IdentificationQuality

Increasing the IdentificationQuality property corrects most false negatives. Check the resolution of both the filled form and the template to verify that both are set, and set to the correct value.

Template Adjustments

  • Rarely recognized - If a particular template is rarely recognized, there may be some problem with that template. Templates should never be skewed and should be free of borders and specks. If the template looks good, it may not have enough content to reliably be identified. For example, the "form" portion of a credit card slip may consist of a box and a few words. That may not provide enough content to be recognized.
  • Similar Templates - If a filled image matches a template with a high confidence (greater than 80), but still fails to identify, there is a high probability that another template in your form set is very similar to the first template. The IdentificationProcessor may have trouble distinguishing between these similar forms. See Handling Similar Templates for more information.
  • Low confidence - If filled images consistently match a template with a low confidence (less than 70), it is very likely that those filled images represent a variant that should be added to the form set. For more information, see Handling Similar Templates.

Correcting False Positives

There are two types of false positives.

  • The first is a filled image that should not have matched any templates.

If a false positive should not have matched any templates, reduce IdentificationCertainty or increase IdentificationQuality. If the confidence for the false positive is low (less than about 75), you may want to increase MinimumIdentificationConfidence.

  • The second is a filled image that should have matched a different template.

If a false positive should have matched a different template, increase IdentificationQuality. If the false positive is due to the presence of nearly identical templates, see the section on Handling Similar Templates.

See Also

Handle Similar Templates, Drop-Out and Faxed Images | Enhance Images | IdentificationProcessor Class


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Improve Performance

Improving Performance

When examining performance, remember that the most important measures are the speed and cost of the whole system. If the quality setting is increased, this may cause identification to run 10 times slower. But if manual data entry is reduced by half, this may be a very cost-effective solution.

Batch Processing

The FormFix component was designed to perform batch processing. One way that this design demonstrates itself is that the IdentificationProcessor does extra processing during the first identification. This allows it to identify subsequent forms much faster. While this is good for normal operation, it makes identification appear slow if only one form is identified. Exercise care when measuring the performance of identification to ignore the first form. Also, time several runs (preferably over 100 identification) to reduce the impact of the one-time processing at the start.

Possible steps to improve performance

  • The quickest and easiest thing that can be done to improve performance is to reduce IdentificationQuality. However, if that causes an increase in identification failures, it is rarely worth the improvement in performance.
  • The content of images identified have an affect on performance. Large images take longer to identify than small images. High-resolution images take longer than low-resolution images. Images with shaded areas or a lot of noise take longer to identify than other images.
  • The number of templates in a set affects the time required to perform identification. Prizm IP relies on a number of techniques to reduce the impact of a large number of unique forms, but fewer forms will always be faster. Changing the order of templates has no impact on performance.
  • Even if an IdentificationProcessor is able to accurately identify all the forms, sometimes an alternate method can be faster using specialized knowledge of specific forms. For example, forms with a bar code may be identified faster by using the bar code. Each page used in the 2000 US Census had a barcode printed on it that uniquely identified the matching template. These forms will still need to run through the identification stage in order to perform the first part of the registration stage. However, IdentificationQuality can be reduced, and the identification search restricted to only the proven single template that matches (for more information, see Enhance Images).


Glossary Item Box

IdentificationProcessor Class | Enhance Images

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Handle Similar Templates, Drop-Out and Faxed Images

Similar Templates

Try Adjusting IdentificationQuality

Sometimes an IdentificationProcessor has difficulty distinguishing between two or more similar forms. The most common examples are standard forms that have been printed by different companies (such as HCFS-1500's) or a single form that is revised in some small way. If this problem occurs, first try increasing IdentificationQuality.

Try Other Methods

If the difference is small enough, no amount to coaxing will get an IdentificationProcessor to identify the images. In these cases, either process the images as one form type (if the forms are close enough to be a problem, they often are close enough to be treated as the same form) or find a supplemental method such as OCR or barcode to help identify the image. For more information, see Enhance Images.

Note: It may be tempting to try putting certain templates first in the table, but this is not a reliable solution because Prizm IP rarely looks at the templates in sequential order.

Drop-Out Forms

Although you can process images whose form is dropped by a scanner using a "drop-out bulb" and get good drop-out results, the identification and registration stages perform poorly on them.

When processing drop-out images, the template images must be filled, not blank, and IdentificationQuality should be increased to at least 75 and IdentificationCertainty to 100. You should consider defining several different copies of each form type.

Faxed Images

Faxed images can be very difficult to process. Pegasus Imaging Corporation does not recommend processing faxed forms. Clean faxed images will generally identify just fine. However OCR results are usually low and distorted faxes often cannot even be identified.

See Also

IdentificationProcessor Class | Enhance Images


Glossary Item Box

FormModel Class | IdentificationProcessor Class

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Handle FormFix Events

Events, Methods and Properties

In order to conserve memory, especially when working with a large number of templates, FormFix relies on an event system to acquire much of its data.

Two FormFix objects expose events:

  1. FormModel
  2. IdentificationProcessor

The above events support three types of data:

  1. Checksums - A value used as a redundancy check.
  2. Template Images - a full image of the original form, without any additional data added to it. Also called a “blank form”, a template comprises all the content that is common to all images of a given form, and only the content that is common to all images of a given form
  3. DataItem objects - Used to get or store operations data for an object.

Drop-Out Processing

One of the simplest interactions occurs during drop-out processing. Drop-out works by comparing a filled image to a template image. The filled image is a parameter to the CreateImageOfField method, but there is no template image. Instead, you provide a FormModel object and FormFix relies on that object to acquire a template image.

The sequence diagram below shows two drop-out operations. In the first, the FormModel object does not have a template image, so it must request one. When it requests a template image, it saves a copy internally. In the second drop-out operation, the FormModel object already has an internal copy of the template image, so it can return it immediately. Your application must handle the ReadFormImage event and it will normally rely on the FormDirector component (as shown) to acquire that image.

A RegistrationProcessor object will operate much the same as a DropOutProcessor object, relying on a FormModel object to provide a template image when needed.

Identification

The events raised during form identification are much more complex because form identification will raise events on an IdentificationProcessor and one or more FormModel objects. In some cases, it will raise all four FormModel and all three IdentificationProcessor events. there are also several different modes of operation, where drop-out only has two (template image is not cached).

The sequence diagram below shows the sequence of events for a "normal" run of form identification. Note that the events involving the FormModel object will be repeated, once for each FormModel. This diagram shows two form identification operations. The first one causes the IdentificationProcessor to load the checksums and analysis results. The second identification operation relies on the data that the first operation loaded.

In order to function properly in this case, your code must handle the following events:

  • ReadChecksum - An event for retrieving a checksum for the persistent state of a form.
  • ReadDataItem - An event for reading a data item from persistent storage.
  • ReadChecksum - An event for retrieving a checksum for the persistent state of a form set.
  • ReadDataItem - An event for reading a data item from persistent storage.

Normally, you should let FormDirector handle the requests as shown in the diagram below.

Form Model Analysis

The above diagram is accurate if FormFix has already analyzed each FormModel and the set of FormModel objects, successfully saved the result of that analysis, and the form set has not changed since that analysis. That will not always be the case and the next two diagrams delve deeper into event handling in other cases.

The most common exception to the diagram above is the very first run of form identification, where FormFix has not yet analyzed the template images or the form set.

The sequence diagram below shows how FormFix will analyze a template image and save the results. The sequence focuses on the ReadDataItem event, which was shown in the diagram above, except that in this case no data item is present in the form definition file. Instead, formFix will request a copy of the template image, analyze it, save the results to the form definition file, and return the result of the analysis to the IdentificationProcessor.

Note: In order to handle this case, you must handle the ReadFormImage event, just like you have to do for drop-out processing. You must also handle the WriteDataItem event and make sure that it places the data item in the same location that your handler for ReadDataItem expects to find it. Normally you will save the data item as an independent entry in FormDirector's FormDefinition.OtherDataItems collection.

One other case merits mention here because it is not uncommon and the events are nearly identical. When it creates the data item holding the result of template analysis, FormFix includes the checksum that the ReadChecksum event returned. If you change your form definition in some meaningful way (in particular if you modify the template), the checksum of the form will not match the checksum in the data item and FormFix will automatically reanalyze the template image and re-save the data item.

Form Set Analysis

Like form models, the IdentificationProcessor will need to analyze a form set if it has not already analyzed it and successfully saved the result of that analysis, or the form set has changed since that analysis. The sequence diagram below shows the events that the IdentificationProcessor raises when a form set has not yet been analyzed.

To properly handle this event, you simply need to handle the WriteDataItem event and save the data item to the location that the ReadDataItem event expects to find it. Normally, you will save the data item as an independent entry in FormDirector's FormSet.OtherDataItems collection.

Again similar to handling of form models, the IdentificationProcessor will automatically detect changes to the form set using the checksum and regenerate the data item if necessary.

See Also

FormModel Class | IdentificationProcessor Class


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Debug Your Application

Because debugging and writting debug information to a log file is time consuming and expensive, FormFix provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the objects below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • ErrorLevel - Controls the amount of information that is written to the debug log file.

Note: When ErrorLevel is set to Detailed FormFix will log most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Event Handling

Because event handling is critical to optimal operation of FormFix, we have implemented several functions that let you test your event-handling code. These are:

  • TestReadChecksumEvent - Tests ReadChecksum event handler.
  • TestReadDataItemEvent - Tests ReadDataItem event.
  • TestWriteDataItemEvent - Tests WriteDataItem event.
  • ConstructTestDataItems - Creates test data items in preparation for a more extensive test.
  • VerifyTestDataItems - Tests data items that you created using ConstructTestDataItems.
  • TestReadFormImageEvent - Tests the ReadChecksum event.
  • TestReadDataItemEvent - Tests the ReadDataItem event.
  • TestWriteDataItemEvent - Tests the WriteDataItem event.
  • ConstructTestDataItems - Creates test data items in preparation for a more extensive test.
  • VerifyTestDataItems - Tests data items that you created using ConstuctTestDataItems.

Memory Consumption

FormFix relies on an event system and some caching to optimize its use of memory. While this allows FormFix to use as little memory as possible and allows you to manage FormFix's usage of memory, it can result in significant waste of memory if you are not careful.

There are two things to be especially careful of.

  1. The first is to properly dispose of objects you are not using anymore by using Dispose() when you are finished using objects. See the IDispose topic below for more information.
  2. The second issue to be careful of is the template image caching done by FormModel objects. To avoid frequent reloading of template images, FormModel objects often keep an internal copy of template images. If your application works with more than a few FormModel objects and uses RegistrationProcessor or DropOutProcessor objects, you must periodically instruct FormFix to discard the cashed template images. You do this by calling the ReleaseCachedData method. The easiest way to handle this is to call ReleaseCachedData immediately after you finish processing each filled image. That way, you get the benefit of the cached image when processing a bunch of drop-out fields, yet never have more than one cached template image in memory at a time.

A better, but more complex alternative is to keep track of some number of recent forms and release the cached data of forms as you remove them from the recently-used list. This allows you to avoid reloading template images for frequently-processed forms and it still keeps memory usage to a reasonable limit.

IDispose

One of the most common problems you will run into is proper handling of objects that require explicit disposal. Many of the objects in this component implement the IDisposable interface and you will get best memory utilization if you call each object's Dispose function when you are finished with it. If you have multiple FormFix objects that you need to Dispose of, you can call their Dispose methods in any order. The objects themselves will properly handle all dependencies.

The following Dispose methods are available:

  • FormFix.Dispose
  • FormImage.Dispose
  • FormModel.Dispose
  • IdentificationProcessor.Dispose
  • IdentificationResult.Dispose
  • OMRProcessor.Dispose
  • RegistrationProcessor.Dispose
  • RegistrationResult.Dispose

The best way to double-check your use of FormFix's disposable objects is to turn on the debug log when your application starts up, then look at the debug log file after your application quits. If you forgot to call a Dispose method, you will see an entry in the debug log like this: "4ec53a8 - 6:51:56:453 - FormImage: Object is being finalized, but should have been Disposed."

Note: This message relies on the .NET framework to run each object's finalizer. Since that can vary depending on the environment your application runs in, you should intentionally not call Dispose on at least one object to ensure that Dispose problems are being accurately reported. You may be able to force the finalizers to run by executing this code: "System.GC.Collect(); System.GC.WaitForPendingFinalizers();"

You can call any of FormFix's Dispose methods multiple times. The first call will dispose of the resources the object holds and the subsequent calls will be ignored. If you attempt to use an object after you call its Dispose method, it will raise a DisposeException exception.

Error Codes

Listed below is a cross reference of error codes and their corresponding descriptions. These are also listed in the ErrorNumber enumeration.

Error Codes | Error | Description
17000 | NullArgument | An argument was NULL.
17001 | ParmRange | An argument was out of range.
17002 | NullImage | An image was NULL.
17003 | BadEnumeration | An enumeration had a bad value.
17004 | OutOfMemory | Out of memory exception.
17005 | FrameworkException | An error occurred during an event.
17100 | ImageType | Unsupported image type.
17200 | OmrNoBubblesDetected | No OMR bubbles were found.
17201 | OmrMinimumConfidenceNotAttained | The confidence did not exceed the minimum value.
17202 | OmrNoCoordinateData | No coordinate data is available.
17203 | OmrNoSegmentCountData | No segment count data is available.
17204 | OmrNoBubbleCountData | No bubble count data is available.
17205 | OmrInvalidImageData | The image data is invalid.
17206 | OmrInvalidImageBitDepth | The image has the wrong bit depth.
17207 | OmrInvalidFieldHeight | The field has an invalid height.
17208 | OmrInvalidFieldWidth | The field has an invalid width.
17209 | OmrBubbleGridPerimeter | There is a problem with the perimeter of the bubble grid.
17301 | RegNoFormModelProvided | No FormModel object was provided.
17500 | License | Licensing error.
17887 | ImageResolution | The image resolution is invalid.
17888 | ComponentInitialization | The component encountered problems while initializing.
17889 | NotInitialized | An operation is being requested before the object is initialized or after it has been disposed.
17890 | UnableToOpenFile | An error occurred while opening a file.
17891 | Validation | An error occurred while validating operation of a user-supplied callback/event.
17892 | ImportImage | An error occurred while attempting to import an image.
17893 | ExportImage | An error occurred while attempting to export an image.
17894 | EventHandler | An event is either not being handled or is being handled by multiple, separate methods.
17895 | UnsupportedStreamVersion | The stream is corrupt and cannot be parsed.
17896 | CorruptStream | The stream is corrupt and cannot be parsed.
17897 | Internal | An internal error occurred.
17898 | Unknown | An unknown error occurred.
17899 | NotImplemented | This operation is not implemented. This should not occur in a release product.
17901 | InvalidPointerParameter | A pointer was NULL.
17902 | ComError | A COM error occurred.
17903 | BadCollectionIndex | An invalid index was provided for an array or list.
17904 | UnsupportedVariantType | An unsupported type of variant was provided.
17905 | EventHandlerNoImageReturned | An event handler did not provide an image as requested.


%%ItemTitle%%

PegasusImaging.WinForms.FormFix3 Assembly

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

PegasusImaging.WinForms.FormFix3 Namespace

Inheritance Hierarchy

Classes

Class | Description
DataItemEventArgs | Arguments for the read data item and write data item events.
DisposeException | An exception that indicates that you tried to use an object after it had been disposed.
DropOutProcessor | Performs form drop-out.
DropOutResult | A class that represents the result of form drop-out.
FormFix | The main object for this toolkit.
FormFixException | The base class for FormFix exceptions.
FormImage | Represents an image.
FormModel | A model for a form.
FormModelCollection | A collection of FormModel objects.
IdentificationMatch | A simple object that contains information about a form comparison and the orientation of that comparison.
IdentificationMatchCollection | A collection of IdentificationMatch objects.
IdentificationProcessor | A class for comparing unknown images to form models and determining which is the correct match.
IdentificationResult | The result of an identification process.
IntegerCollection | Represents a collection of integers.
Licensing | Provides methods for setting the license information for the toolkit.
OmrBubbleModel | A model for an OMR field bubble.
OmrBubbleModelCollection | A collection of OmrBubbleModel objects.
OmrBubbleResult | A class that represents a bubble result of OMR analysis processing.
OmrBubbleResultCollection | A collection of OmrBubbleResult objects.
OmrFieldResult | A class that represents the result of OMR analysis processing.
OmrProcessor | Performs OMR field recognition analysis.
OmrSegmentModel | A model for an OMR field segment.
OmrSegmentModelCollection | A collection of OmrSegmentModel objects.
OmrSegmentResult | A class that represents a segment result of OMR analysis processing.
OmrSegmentResultCollection | A collection of OmrSegmentResult objects.
ReadChecksumEventArgs | Arguments for a read checksum event.
ReadFormImageEventArgs | Arguments for a read form image event.
RegistrationProcessor | An object that registers two images.
RegistrationResult | Holds information allowing you to align an image to a model image.

Enumerations

Enumeration | Description
DropOutMethod | The method used to drop out a form.
ErrorLevel | The error level of items to place into the debug log.
ErrorNumber | A specific type of error.
EvaluationMode | The evaluation mode of the component.
IdentificationOrientation | The orientation of a form comparison.
IdentificationState | The final state of an identification process.
LicenseEditionType | The edition of the component.
OmrAnalysisComparisonMethod | The OMR analysis image comparison processing method desired.
OmrBubbleShape | The geometric shape of an OMR field's bubble(s).
OmrMarkScheme | The OMR field's bubble mark scheme.
OmrMultiSegmentReadDirection | The multi-segment read direction for assembling a field summation of segment analysis results
OmrOrientation | The orientation of an OMR field's segment(s) with respect to the top of a form image.
RegistrationState | The state of a registration operation.

Delegates

Delegate | Description
DataItemEventHandler | A delegate for events that read or write data items in persistent storage.
ReadChecksumEventHandler | A delegate for events that return a checksum of data in persistent storage.
ReadFormImageEventHandler | A delegate for events that read a form image from persistent storage.

See Also

PegasusImaging.WinForms.FormFix3 Assembly


%%PageItemTitle%%

DataItemEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DataItemEventArgs Class

PegasusImaging.WinForms.FormFix3 Namespace : DataItemEventArgs Class

Arguments for the read data item and write data item events.

For a list of all members of this type, see DataItemEventArgs members.

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.FormFix3.DataItemEventArgs

Syntax

[Visual Basic]
Public Class DataItemEventArgs
   Inherits EventArgs
[C#]
public class DataItemEventArgs : EventArgs
[C++]
public __gc class DataItemEventArgs : public EventArgs
[C++/CLI]
public ref class DataItemEventArgs : public EventArgs

Remarks

This class provides the communication between the object that issued a read or write data item event and the object that handles the event.

The object that issues this event will always set the Type field to the type of the data item that it wishes to read or write. For a write data item event, the object that issues the event will also set the Content property to the content that it wishes to write.

For a read data item event, the event handler should set the Content property of this object to the content of the data item that it read.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

DataItemEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

DataItemEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DataItemEventArgs Class Members

PegasusImaging.WinForms.FormFix3 Namespace : DataItemEventArgs Class

DataItemEventArgs overview

Public Constructors

Public Constructor DataItemEventArgs Constructor

Public Properties

Public Property Content | The content of the data item to read or write. A string representing the content of the data item.
Public Property Type | The type of the data item to read or write. A string representing the type of data item.

See Also

DataItemEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DataItemEventArgs Class | DataItemEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DataItemEventArgs Constructor

PegasusImaging.WinForms.FormFix3 Namespace > DataItemEventArgs Class : DataItemEventArgs Constructor (DataItemEventArgs)
[Visual Basic]
Public Function New()
[C#]
public DataItemEventArgs();
[C++]
public: DataItemEventArgs();
[C++/CLI]
public:
DataItemEventArgs();

Requirements

Platforms: See Getting Started section

See Also

DataItemEventArgs Class | DataItemEventArgs Members


%%PageItemTitle%% $$Properties$$

DataItemEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DataItemEventArgs Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : DataItemEventArgs Class

For a list of all members of this type, see DataItemEventArgs members.

Public Properties

Public Property Content | The content of the data item to read or write. A string representing the content of the data item.
Public Property Type | The type of the data item to read or write. A string representing the type of data item.

See Also

DataItemEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DataItemEventArgs Class | DataItemEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Content Property

PegasusImaging.WinForms.FormFix3 Namespace > DataItemEventArgs Class : Content Property

The content of the data item to read or write. A string representing the content of the data item.

[Visual Basic]
Public Property Content As String
[C#]
public string Content {get; set;}
[C++]
public: __property string* get_Content();
public: __property void set_Content(
   string* value
);
[C++/CLI]
public:
property String^ Content {
   String^ get();
   void set (String^ value);
}

Remarks

For a read data item event, the object that handles the event should place the content into this property. For a write data item event, the object that issues the event will place the content into this property.

Requirements

Platforms: See Getting Started section

See Also

DataItemEventArgs Class | DataItemEventArgs Members


%%PageItemTitle%%

DataItemEventArgs Class | DataItemEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Type Property

PegasusImaging.WinForms.FormFix3 Namespace > DataItemEventArgs Class : Type Property (DataItemEventArgs)

The type of the data item to read or write. A string representing the type of data item.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
[C++/CLI]
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Remarks

The object that issues a read or write data item event will place the type of that data item into this property before it issues the event.

Requirements

Platforms: See Getting Started section

See Also

DataItemEventArgs Class | DataItemEventArgs Members


%%PageItemTitle%%

DisposeException Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Class

PegasusImaging.WinForms.FormFix3 Namespace : DisposeException Class

An exception that indicates that you tried to use an object after it had been disposed.

For a list of all members of this type, see DisposeException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.FormFix3.FormFixException
PegasusImaging.WinForms.FormFix3.DisposeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class DisposeException
   Inherits FormFixException
[C#]
[SerializableAttribute()]
public class DisposeException : FormFixException
[C++]
[SerializableAttribute()]
public __gc class DisposeException : public FormFixException
[C++/CLI]
[SerializableAttribute()]
public ref class DisposeException : public FormFixException

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

DisposeException Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Class Members

PegasusImaging.WinForms.FormFix3 Namespace : DisposeException Class

DisposeException overview

Public Constructors

Public Constructor DisposeException Constructor Overloaded. Initializes a new instance of the DisposeException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from FormFixException) | Gets the last error from the FormFix component.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DisposeException Class | DisposeException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Constructor

PegasusImaging.WinForms.FormFix3 Namespace > DisposeException Class : DisposeException Constructor (DisposeException)

Initializes a new instance of the DisposeException class.

Overload List

Initializes a new instance of the DisposeException class.

[Visual Basic] Public Sub New()

[C#] public DisposeException();

[C++] public DisposeException();

[C++/CLI] public DisposeException();

Initializes a new instance of the DisposeException class.

[Visual Basic] Public Sub New(String)

[C#] public DisposeException(string);

[C++] public DisposeException(string*);

[C++/CLI] public DisposeException(String^);

Initializes a new instance of the DisposeException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public DisposeException(string,Exception);

[C++] public DisposeException(string*,Exception*);

[C++/CLI] public DisposeException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

DisposeException Class | DisposeException Members


%%PageItemTitle%%

DisposeException Class | DisposeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Constructor()

PegasusImaging.WinForms.FormFix3 Namespace > DisposeException Class > DisposeException Constructor : DisposeException Constructor()

Initializes a new instance of the DisposeException class.

[Visual Basic]
Public Function New()
[C#]
public DisposeException();
[C++]
public: DisposeException();
[C++/CLI]
public:
DisposeException();

Requirements

Platforms: See Getting Started section

See Also

DisposeException Class | DisposeException Members | Overload List


%%PageItemTitle%%

DisposeException Class | DisposeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Constructor(String)

PegasusImaging.WinForms.FormFix3 Namespace > DisposeException Class > DisposeException Constructor : DisposeException Constructor(String)

Initializes a new instance of the DisposeException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public DisposeException(
   string message
);
[C++]
public: DisposeException(
   string* message
)
[C++/CLI]
public:
DisposeException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

DisposeException Class | DisposeException Members | Overload List


%%PageItemTitle%%

DisposeException Class | DisposeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
inner
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Constructor(String,Exception)

PegasusImaging.WinForms.FormFix3 Namespace > DisposeException Class > DisposeException Constructor : DisposeException Constructor(String,Exception)

Initializes a new instance of the DisposeException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public DisposeException(
   string message,
   Exception inner
);
[C++]
public: DisposeException(
   string* message,
   Exception* inner
)
[C++/CLI]
public:
DisposeException(
   String^ message,
   Exception^ inner
)

Parameters

message
inner

Requirements

Platforms: See Getting Started section

See Also

DisposeException Class | DisposeException Members | Overload List


%%PageItemTitle%%

DropOutProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutProcessor Class

PegasusImaging.WinForms.FormFix3 Namespace : DropOutProcessor Class

Performs form drop-out.

For a list of all members of this type, see DropOutProcessor members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.DropOutProcessor

Syntax

[Visual Basic]
Public Class DropOutProcessor
[C#]
public class DropOutProcessor
[C++]
public __gc class DropOutProcessor
[C++/CLI]
public ref class DropOutProcessor

Remarks

This class performs form drop-out on fields. Form drop-out is the first step in processing a field. Subsequent steps often include image enhancement, OCR, ICR, or barcode.

You must register an image before you can use this object. You can use the IdentificationProcessor or RegistrationProcessor classes for that purpose.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

DropOutProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutProcessor Class Members

PegasusImaging.WinForms.FormFix3 Namespace : DropOutProcessor Class

DropOutProcessor overview

Public Constructors

Public Constructor DropOutProcessor Constructor Initializes a new instance of the class.

Public Properties

Public Property AllowableMisRegistration | The maximum allowed deviation from proper registration in pixels.
Public Property Area | Gets and sets the rectangular area that defines the field.
Public Property DropOutMethod | Gets and sets the DropOutMethod to use to drop out the form.
Public Property PerformReconstruction | Instructs this object to reconstruct filled data that overlaps with form data.

Public Methods

Public Method CreateImageOfField | Creates and returns a dropped-out image for a field.
Public Method Dispose | Deletes the image contained within this object.
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

See Also

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A new instance of the FormFix class.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutProcessor Constructor

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : DropOutProcessor Constructor (DropOutProcessor)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As FormFix _
)
[C#]
public DropOutProcessor(
   FormFix workspace
);
[C++]
public: DropOutProcessor(
   FormFix* workspace
)
[C++/CLI]
public:
DropOutProcessor(
   FormFix^ workspace
)

Parameters

workspace
A new instance of the FormFix class.

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

filledImage
The filled image that contains the source pixels for the field.
registrationInformation
The registration information you created using a IdentificationProcessor or RegistrationProcessor object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CreateImageOfField Method

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : CreateImageOfField Method

Creates and returns a dropped-out image for a field.

[Visual Basic]
Public Function CreateImageOfField( _
   ByVal filledImage As FormImage, _
   ByVal registrationInformation As RegistrationResult _
) As DropOutResult
[C#]
public DropOutResult CreateImageOfField(
   FormImage filledImage,
   RegistrationResult registrationInformation
);
[C++]
public: DropOutResult* CreateImageOfField(
   FormImage* filledImage,
   RegistrationResult* registrationInformation
)
[C++/CLI]
public:
DropOutResult^ CreateImageOfField(
   FormImage^ filledImage,
   RegistrationResult^ registrationInformation
)

Parameters

filledImage
The filled image that contains the source pixels for the field.
registrationInformation
The registration information you created using a IdentificationProcessor or RegistrationProcessor object.

Return Type

A DropOutResult object. The principle component of this object is the field image.

Remarks

This method will create an image that represents the field. You can control the exact process this method uses by setting the properties of this object. In order to create the correct field image, you must register the image before you call this method. You can use the IdentificationProcessor or RegistrationProcessor objects to register the image.

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : Dispose Method (DropOutProcessor)

Deletes the image contained within this object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM.

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members | WriteToStream Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
A stream that the WriteToStream method created.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFromStream Method

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : ReadFromStream Method (DropOutProcessor)

Reads a specially-formatted stream and places the values into properties of this object.

[Visual Basic]
Public Sub ReadFromStream( _
   ByVal stream As String _
)
[C#]
public void ReadFromStream(
   string stream
);
[C++]
public: void ReadFromStream(
   string* stream
)
[C++/CLI]
public:
void ReadFromStream(
   String^ stream
)

Parameters

stream
A stream that the WriteToStream method created.

Remarks

This method reads a stream, which contains the values of properties for this object. It provides a convenient way to store and retrieve the values and preserves as much future compatibility as possible.

This method should read any stream that the WriteToStream method created, even if an older version of this toolkit created it. This method will fail to read a stream that a newer version of this toolkit created.

Note: You should retrieve the value for the stream from the Construction property of a FormDirector FormDefinition object. When the Type property of that object is "FormFix/DropOut", the Content property contains a string that you should send to this method.

The properties that this method reads from the stream are:

  • DropOutMethod
  • AllowableMisRegistration
  • PerformReconstruction

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members | WriteToStream Method


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

WriteToStream Method

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : WriteToStream Method (DropOutProcessor)

Writes some properties of this object to a specially-formatted stream.

[Visual Basic]
Public Function WriteToStream() As String
[C#]
public string WriteToStream();
[C++]
public: string* WriteToStream();
[C++/CLI]
public:
String^ WriteToStream();

Return Type

A stream that can be reloaded using ReadFromStream.

Remarks

This method writes certain properties of this object to a stream. The stream is intended for use only by the ReadFromStream method and its format may change in a future release of this toolkit. However, even if the format changes, future versions of this toolkit will be able to read strings that this method generates.

Note: You should save the stream in the Construction property of a FormDirector FormDefinition object. You should set the Type to "FormFix/DropOut" and the Content to the value that this method returns.

The properties that this method writes to the stream are:

  • DropOutMethod
  • AllowableMisRegistration
  • PerformReconstruction

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%% $$Properties$$

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutProcessor Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : DropOutProcessor Class

For a list of all members of this type, see DropOutProcessor members.

Public Properties

Public Property AllowableMisRegistration | The maximum allowed deviation from proper registration in pixels.
Public Property Area | Gets and sets the rectangular area that defines the field.
Public Property DropOutMethod | Gets and sets the DropOutMethod to use to drop out the form.
Public Property PerformReconstruction | Instructs this object to reconstruct filled data that overlaps with form data.

See Also

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

AllowableMisRegistration Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : AllowableMisRegistration Property

The maximum allowed deviation from proper registration in pixels.

[Visual Basic]
Public Property AllowableMisRegistration As Integer
[C#]
public int AllowableMisRegistration {get; set;}
[C++]
public: __property int get_AllowableMisRegistration();
public: __property void set_AllowableMisRegistration(
   int value
);
[C++/CLI]
public:
property int AllowableMisRegistration {
   int get();
   void set (int value);
}

Remarks

This property represents the amount of refinement that this object will perform before dropping a field. It provides a final opportunity for the object to refine the registration of a field. As it is dropping the form for a field, this object will try to refine the registration of the filled image to the model. You must set this value before you call the CreateImageOfField method.

The drop-out process requires additional registration for a variety of common reasons. Many printing processes do not perfectly align all parts of a page. For example, a laser printer may print some parts of a page slightly higher or lower than they should be. Scanners will also do the same thing, but will shift parts of a page left or right if you scan the page in landscape mode. Even paper handling and humidity can affect the relative locations of individual fields.

Note: This property has no effect when DropOutMethod is DropOutMethod.Clip.

Valid range: 0 - 20

Default value: 5

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Area Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : Area Property (DropOutProcessor)

Gets and sets the rectangular area that defines the field.

[Visual Basic]
Public Property Area As Rectangle
[C#]
public Rectangle Area {get; set;}
[C++]
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
   void set (Rectangle value);
}

Remarks

This property contains the coordinates, in pixels, of the field. You must set this value before you call the CreateImageOfField method. If the width and height of this rectangle is zero, this object will treat the entire image as a single field. If this rectangle exceeds the bounds of the template image, CreateImageOfField will return white pixels in the non-overlapping area instead of returning an error.

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutMethod Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : DropOutMethod Property (DropOutProcessor)

Gets and sets the DropOutMethod to use to drop out the form.

[Visual Basic]
Public Property DropOutMethod As DropOutMethod
[C#]
public DropOutMethod DropOutMethod {get; set;}
[C++]
public: __property DropOutMethod get_DropOutMethod();
public: __property void set_DropOutMethod(
   DropOutMethod value
);
[C++/CLI]
public:
property DropOutMethod DropOutMethod {
   DropOutMethod get();
   void set (DropOutMethod value);
}

Remarks

This property tells the object how to drop out the form. You must set this value before you call the CreateImageOfField method.

There are two methods for creating field images: DropOut and Clip.

Normally, you should use the DropOut method, which will compare the filled and model images, then create an output image that contains the content that was added to the form. Ideally, the output image will not contain any part of the form model; however it is sometimes impossible to determine what is part of the form and what was added by a user.

In a few situations, you should use the Clip method:

  • You are processing OMR fields. The OmrProcessor object requires its input images to contain both the marks and the original bubbles.
  • There is no form content near the field. In this case, the Clip method will run faster.
  • Comparison to the model form is useless. For example, a form may have a region reserved for a stick-on barcode label. In this case, the model has text instructions for attaching the label and the filled image has a barcode. Using the DropOut method will probably leave holes in the barcode wherever a character was present in the model image.
  • You wish to include part of the form. For example, you may wish to double-check form identification by reading a page number or form revision number. The DropOut method would discard the data you wish to process.

If your images do not drop well, you should try using the line removal and comb removal feature in ScanFix. Make sure you set this property to Clip before you use line or comb removal.

Note: when you set this property to Clip, the resulting confidence of the operation will always be 100.

Default value: Clip

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutProcessor Class | DropOutProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

PerformReconstruction Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutProcessor Class : PerformReconstruction Property

Instructs this object to reconstruct filled data that overlaps with form data.

[Visual Basic]
Public Property PerformReconstruction As Boolean
[C#]
public bool PerformReconstruction {get; set;}
[C++]
public: __property bool get_PerformReconstruction();
public: __property void set_PerformReconstruction(
   bool value
);
[C++/CLI]
public:
property bool PerformReconstruction {
   bool get();
   void set (bool value);
}

Remarks

This property controls optional reconstruction during the drop-out process. It only affects the output image where filled data and form data overlap. When you set this property to true, the DropOutMethod method will try to guess which form data pixels overlap with filled data pixels and which do not overlap with filled data pixels. It will retain the pixels that it decides are overlapping and discard the form data pixels that do not appear to overlap. You must set this value before you call the CreateImageOfField method.

In many cases, it is impossible to accurately decide which pixels overlap and which do not.

Note: This property has no effect when DropOutMethod is DropOutMethod.Clip.

Default value: true

Requirements

Platforms: See Getting Started section

See Also

DropOutProcessor Class | DropOutProcessor Members


%%PageItemTitle%%

DropOutResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutResult Class

PegasusImaging.WinForms.FormFix3 Namespace : DropOutResult Class

A class that represents the result of form drop-out.

For a list of all members of this type, see DropOutResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.DropOutResult

Syntax

[Visual Basic]
Public Class DropOutResult
[C#]
public class DropOutResult
[C++]
public __gc class DropOutResult
[C++/CLI]
public ref class DropOutResult

Remarks

An instance of this class represents the result of form drop-out on a field. Normally you will call CreateImageOfField to create an instance of this class.

Note: This class does not implement the IDisposable interface, but its instances do contain an object, Image, that implements IDisposable. You should be careful to call the FormImage.Dispose method when you are finished using the image. If you do not, your process may very quickly run out of RAM and begin to run very slowly.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

DropOutResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

DropOutResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : DropOutResult Class

DropOutResult overview

Public Constructors

Public Constructor DropOutResult Constructor Initializes a new instance of the class.

Public Properties

Public Property Confidence | Gets or sets the confidence of the drop-out result.
Public Property Image | Gets and sets the resulting image containing the field data with the form dropped out.

See Also

DropOutResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DropOutResult Class | DropOutResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutResult Constructor

PegasusImaging.WinForms.FormFix3 Namespace > DropOutResult Class : DropOutResult Constructor (DropOutResult)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public DropOutResult();
[C++]
public: DropOutResult();
[C++/CLI]
public:
DropOutResult();

Requirements

Platforms: See Getting Started section

See Also

DropOutResult Class | DropOutResult Members


%%PageItemTitle%% $$Properties$$

DropOutResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : DropOutResult Class

For a list of all members of this type, see DropOutResult members.

Public Properties

Public Property Confidence | Gets or sets the confidence of the drop-out result.
Public Property Image | Gets and sets the resulting image containing the field data with the form dropped out.

See Also

DropOutResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

DropOutResult Class | DropOutResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutResult Class : Confidence Property (DropOutResult)

Gets or sets the confidence of the drop-out result.

[Visual Basic]
Public ReadOnly Property Confidence As Integer
[C#]
public int Confidence {get;}
[C++]
public: __property int get_Confidence();
[C++/CLI]
public:
property int Confidence {
   int get();
}

Remarks

This read-only property indicates the confidence of the drop-out process. The CreateImageOfField method will set this value before it returns. A value near 100 indicates that the drop-out result is probably correct, while a value near 0 indicates that the drop-out image likely has some kind of error. Normally, you can ignore this value and let subsequent processing steps (like OCR) discern the presence of a real error.

Valid range: 0 to 100

Requirements

Platforms: See Getting Started section

See Also

DropOutResult Class | DropOutResult Members


%%PageItemTitle%%

DropOutResult Class | DropOutResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Image Property

PegasusImaging.WinForms.FormFix3 Namespace > DropOutResult Class : Image Property

Gets and sets the resulting image containing the field data with the form dropped out.

[Visual Basic]
Public ReadOnly Property Image As FormImage
[C#]
public FormImage Image {get;}
[C++]
public: __property FormImage* get_Image();
[C++/CLI]
public:
property FormImage^ Image {
   FormImage^ get();
}

Remarks

This image contains the dropped-out field and is the primary result of form drop-out. The actual content of this image depends on the settings you provided when you called the CreateImageOfField method.

Note: FormImage implements the IDisposable interface and you should always call its Dispose method when you are finished using the image.

Requirements

Platforms: See Getting Started section

See Also

DropOutResult Class | DropOutResult Members


%%PageItemTitle%%

FormFix Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Class

PegasusImaging.WinForms.FormFix3 Namespace : FormFix Class

The main object for this toolkit.

For a list of all members of this type, see FormFix members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.FormFix3.FormFix

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class FormFix
   Inherits Component
[C#]
[ToolboxBitmapAttribute()]
public class FormFix : Component
[C++]
[ToolboxBitmapAttribute()]
public __gc class FormFix : public Component
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class FormFix : public Component

Remarks

This object is the primary place to perform toolkit-level operations, such as setting licensing information, controlling the debug log, and displaying the toolkit about box.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

FormFix Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Class Members

PegasusImaging.WinForms.FormFix3 Namespace : FormFix Class

FormFix overview

Public Constructors

Public Constructor FormFix Constructor Overloaded. Initializes a new instance of this class.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Controls whether the toolkit writes information to a debug log file or not.
Public Property DebugLogFile | The filename of the debug log file.
Public Property ErrorLevel | The error level of items that the toolkit should write to the debug log file.
Public Property Licensing | Provides access to an object you can use to provide licensing information to the toolkit.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Clean up any resources being used. Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Constructor

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : FormFix Constructor (FormFix)

Initializes a new instance of this class.

Overload List

Initializes a new instance of this class.

[Visual Basic] Public Sub New(IContainer)

[C#] public FormFix(IContainer);

[C++] public FormFix(IContainer);

[C++/CLI] public FormFix(IContainer);

Initializes a new instance of the class.

[Visual Basic] Public Sub New()

[C#] public FormFix();

[C++] public FormFix();

[C++/CLI] public FormFix();

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%%

FormFix Class | FormFix Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Constructor()

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class > FormFix Constructor : FormFix Constructor()

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public FormFix();
[C++]
public: FormFix();
[C++/CLI]
public:
FormFix();

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members | Overload List


%%PageItemTitle%%

FormFix Class | FormFix Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Constructor(IContainer)

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class > FormFix Constructor : FormFix Constructor(IContainer)

Initializes a new instance of this class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public FormFix(
   IContainer container
);
[C++]
public: FormFix(
   IContainer container
)
[C++/CLI]
public:
FormFix(
   IContainer container
)

Parameters

container

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members | Overload List


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : AboutBox Method

Displays the toolkit about box.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

Remarks

This method displays an about box for the toolkit. It includes useful information, such as the name and version of the toolkit, copyright dates, and links to Pegasus Imaging Corporation's web site.

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%% $$Properties$$

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : FormFix Class

For a list of all members of this type, see FormFix members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Controls whether the toolkit writes information to a debug log file or not.
Public Property DebugLogFile | The filename of the debug log file.
Public Property ErrorLevel | The error level of items that the toolkit should write to the debug log file.
Public Property Licensing | Provides access to an object you can use to provide licensing information to the toolkit.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

See Also

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : Debug Property

Controls whether the toolkit writes information to a debug log file or not.

[Visual Basic]
Public Property Debug As Boolean
[C#]
public bool Debug {get; set;}
[C++]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Remarks

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this is true, the toolkit will write items to the debug log file, as specified by the DebugLogFile and ErrorLevel properties.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : DebugLogFile Property

The filename of the debug log file.

[Visual Basic]
Public Property DebugLogFile As String
[C#]
public string DebugLogFile {get; set;}
[C++]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Remarks

This property allows you to control the location of the debug log file.

The default value for this property is suitable for interactive use. If you are using the component in a service or other type of system that runs in the background, you should set the filename to a more suitable value.

Valid value: Any valid filename.

Default value: "[My Documents]\FormFix3.log"

Note: This property will have no effect if you set the Debug property to false.

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ErrorLevel Property

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : ErrorLevel Property (FormFix)

The error level of items that the toolkit should write to the debug log file.

[Visual Basic]
Public Property ErrorLevel As ErrorLevel
[C#]
public ErrorLevel ErrorLevel {get; set;}
[C++]
public: __property ErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevel value
);
[C++/CLI]
public:
property ErrorLevel ErrorLevel {
   ErrorLevel get();
   void set (ErrorLevel value);
}

Remarks

This property allows you to control the amount of information that the toolkit places into a debug log file. Since it takes some amount of time to generate and write debug log items, you should set this to write the least amount of information that you will find useful.

Valid values: Production, Development, and Detailed.

Default value: Production

Note: This property will have no effect if you set the Debug property to false.

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%%

FormFix Class | FormFix Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Licensing Property

PegasusImaging.WinForms.FormFix3 Namespace > FormFix Class : Licensing Property (FormFix)

Provides access to an object you can use to provide licensing information to the toolkit.

[Visual Basic]
Public ReadOnly Property Licensing As Licensing
[C#]
public Licensing Licensing {get;}
[C++]
public: __property Licensing* get_Licensing();
[C++/CLI]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the toolkit.

Requirements

Platforms: See Getting Started section

See Also

FormFix Class | FormFix Members


%%PageItemTitle%%

FormFixException Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Class

PegasusImaging.WinForms.FormFix3 Namespace : FormFixException Class

The base class for FormFix exceptions.

For a list of all members of this type, see FormFixException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.FormFix3.FormFixException
PegasusImaging.WinForms.FormFix3.DisposeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class FormFixException
   Inherits ApplicationException
[C#]
[SerializableAttribute()]
public class FormFixException : ApplicationException
[C++]
[SerializableAttribute()]
public __gc class FormFixException : public ApplicationException
[C++/CLI]
[SerializableAttribute()]
public ref class FormFixException : public ApplicationException

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

FormFixException Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Class Members

PegasusImaging.WinForms.FormFix3 Namespace : FormFixException Class

FormFixException overview

Public Constructors

Public Constructor FormFixException Constructor Overloaded. Creates an instance of the exception class with the given message.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | Gets the last error from the FormFix component.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormFixException Class | FormFixException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Constructor

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class : FormFixException Constructor (FormFixException)

Creates an instance of the exception class with the given message.

Overload List

Creates an instance of the exception class with the given message.

[Visual Basic] Public Sub New()

[C#] public FormFixException();

[C++] public FormFixException();

[C++/CLI] public FormFixException();

Initializes a new instance of the FormFixException class.

[Visual Basic] Public Sub New(ErrorNumber,String)

[C#] public FormFixException(ErrorNumber,string);

[C++] public FormFixException(ErrorNumber,string*);

[C++/CLI] public FormFixException(ErrorNumber,String^);

Creates an instance of the exception class with the given message.

[Visual Basic] Public Sub New(String)

[C#] public FormFixException(string);

[C++] public FormFixException(string*);

[C++/CLI] public FormFixException(String^);

Creates an instance of the exception class with the given message and inner.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FormFixException(string,Exception);

[C++] public FormFixException(string*,Exception*);

[C++/CLI] public FormFixException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members


%%PageItemTitle%%

FormFixException Class | FormFixException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Constructor()

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class > FormFixException Constructor : FormFixException Constructor()

Creates an instance of the exception class with the given message.

[Visual Basic]
Public Function New()
[C#]
public FormFixException();
[C++]
public: FormFixException();
[C++/CLI]
public:
FormFixException();

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members | Overload List


%%PageItemTitle%%

FormFixException Class | FormFixException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

number
message
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Constructor(ErrorNumber,String)

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class > FormFixException Constructor : FormFixException Constructor(ErrorNumber,String)

Initializes a new instance of the FormFixException class.

[Visual Basic]
Public Function New( _
   ByVal number As ErrorNumber, _
   ByVal message As String _
)
[C#]
public FormFixException(
   ErrorNumber number,
   string message
);
[C++]
public: FormFixException(
   ErrorNumber number,
   string* message
)
[C++/CLI]
public:
FormFixException(
   ErrorNumber number,
   String^ message
)

Parameters

number
message

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members | Overload List


%%PageItemTitle%%

FormFixException Class | FormFixException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string representing the error explanation.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Constructor(String)

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class > FormFixException Constructor : FormFixException Constructor(String)

Creates an instance of the exception class with the given message.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FormFixException(
   string message
);
[C++]
public: FormFixException(
   string* message
)
[C++/CLI]
public:
FormFixException(
   String^ message
)

Parameters

message
A string representing the error explanation.

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members | Overload List


%%PageItemTitle%%

FormFixException Class | FormFixException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string representing the error explanation.
inner
An internal Exception.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Constructor(String,Exception)

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class > FormFixException Constructor : FormFixException Constructor(String,Exception)

Creates an instance of the exception class with the given message and inner.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public FormFixException(
   string message,
   Exception inner
);
[C++]
public: FormFixException(
   string* message,
   Exception* inner
)
[C++/CLI]
public:
FormFixException(
   String^ message,
   Exception^ inner
)

Parameters

message
A string representing the error explanation.
inner
An internal Exception.

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members | Overload List


%%PageItemTitle%% $$Properties$$

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : FormFixException Class

For a list of all members of this type, see FormFixException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | Gets the last error from the FormFix component.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormFixException Class | FormFixException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ErrorNumber Property

PegasusImaging.WinForms.FormFix3 Namespace > FormFixException Class : ErrorNumber Property (FormFixException)

Gets the last error from the FormFix component.

[Visual Basic]
Public ReadOnly Property ErrorNumber As ErrorNumber
[C#]
public ErrorNumber ErrorNumber {get;}
[C++]
public: __property ErrorNumber get_ErrorNumber();
[C++/CLI]
public:
property ErrorNumber ErrorNumber {
   ErrorNumber get();
}

Remarks

This property holds an error number that you can use to determine the specific type of error that occurred.

Requirements

Platforms: See Getting Started section

See Also

FormFixException Class | FormFixException Members


%%PageItemTitle%%

FormImage Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormImage Class

PegasusImaging.WinForms.FormFix3 Namespace : FormImage Class (PegasusImaging.WinForms.FormFix3)

Represents an image.

For a list of all members of this type, see FormImage members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.FormImage

Syntax

[Visual Basic]
Public Class FormImage
[C#]
public class FormImage
[C++]
public __gc class FormImage
[C++/CLI]
public ref class FormImage

Remarks

Instances of this class contain one image. Normally, that image will be a model image for a form, a filled image that you will process, or an image of a single field.

You cannot directly create instances of this class. Instead, you must use one of the static functions (FromBitmap, FromHbitmap, FromHdib, or FromHdib.) In addition, several properties and methods in this component will return objects of this class.

Note: this class implements the IDisposable interface and you must be careful to call Dispose when you are finished using it. If you forget to call Dispose, your process may run out of RAM and begin to run very slowly.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

FormImage Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormImage Class Members

PegasusImaging.WinForms.FormFix3 Namespace : FormImage Class (PegasusImaging.WinForms.FormFix3)

FormImage overview

Public Properties

Public Property Height | Gets the height of the image in pixels.
Public Property HorizontalResolution | Gets and sets the horizontal, or X coordinate of the resolution of the image.
Public Property ResolutionUnit | Gets or sets the measuring unit for the horizontal and vertical resolution of the image.
Public Property VerticalResolution | Gets and sets the vertical, or Y coordinate, resolution of the image.
Public Property Width | Gets the width of the image in pixels.

Public Methods

Public Method Dispose | Deletes the image contained within this object.
Public Method static (Shared in Visual Basic) FromBitmap | Creates a new object and places a copy of the given image into it.
Public Method static (Shared in Visual Basic) FromHbitmap | Creates a new object and places a copy of the given image into it.
Public Method static (Shared in Visual Basic) FromHdib | Overloaded. Creates a new object and places a copy of the given hdib into it.
Public Method ToBitmap | Returns a new Bitmap object containing a copy of the image in this object.
Public Method ToHbitmap | Returns a new WIN32 HBITMAP handle containing a copy of the image in this object.
Public Method ToHdib | Returns a new WIN32 HDIB handle containing a copy of the image in this object.

See Also

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : Dispose Method (FormImage)

Deletes the image contained within this object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitmap
The image to copy into the new object.
workspace
A reference to the FormFix workspace object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FromBitmap Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : FromBitmap Method

Creates a new object and places a copy of the given image into it.

[Visual Basic]
Public Shared Function FromBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal workspace As FormFix _
) As FormImage
[C#]
public static FormImage FromBitmap(
   Bitmap bitmap,
   FormFix workspace
);
[C++]
public: static FormImage* FromBitmap(
   Bitmap bitmap,
   FormFix* workspace
)
[C++/CLI]
public:
static FormImage^ FromBitmap(
   Bitmap bitmap,
   FormFix^ workspace
)

Parameters

bitmap
The image to copy into the new object.
workspace
A reference to the FormFix workspace object.

Return Type

A new FormImage object that contains a copy of the original image.

Remarks

This method accepts a System.Drawing.Bitmap (or a System.Drawing.Image which has been cast to a System.Drawing.Bitmap) and creates a new FormImage object that contains a copy of that image. The bitmap must contain a binary (1 bit per pixel) image.

The FromHdib and FromHdib methods are the fastest way to transfer images between Pegasus Imaging Corporation's components.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

hbitmap
The WIN32 HBITMAP handle to copy into the new object.
workspace
A reference to the FormFix workspace object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FromHbitmap Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : FromHbitmap Method

Creates a new object and places a copy of the given image into it.

[Visual Basic]
Public Shared Function FromHbitmap( _
   ByVal hbitmap As IntPtr, _
   ByVal workspace As FormFix _
) As FormImage
[C#]
public static FormImage FromHbitmap(
   IntPtr hbitmap,
   FormFix workspace
);
[C++]
public: static FormImage* FromHbitmap(
   IntPtr hbitmap,
   FormFix* workspace
)
[C++/CLI]
public:
static FormImage^ FromHbitmap(
   IntPtr hbitmap,
   FormFix^ workspace
)

Parameters

hbitmap
The WIN32 HBITMAP handle to copy into the new object.
workspace
A reference to the FormFix workspace object.

Return Type

A new FormImage object that contains a copy of the original image.

Remarks

This method accepts a handle to a WIN32 HBITMAP and creates a new FormImage object that contains a copy of that image. The bitmap must contain a binary (1 bit per pixel) image.

Note: HBITMAP objects usually do not have a resolution. Since most of the operations this component performs require a valid resolution, you should generally avoid using this method of importing an image. If you must use it, you should always set the correct resolution immediately after importing the image. You can set the resolution using the HorizontalResolution and VerticalResolution properties of this object.

The FromHdib and FromHdib methods are the fastest way to transfer images between Pegasus Imaging Corporation's components.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FromHdib Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : FromHdib Method

Creates a new object and places a copy of the given hdib into it.

Overload List

Creates a new object and places a copy of the given image into it.

[Visual Basic] Overloads Public Shared Function FromHdib(IntPtr,FormFix) As FormImage

[C#] public static FormImage FromHdib(IntPtr,FormFix);

[C++] public static FormImage* FromHdib(IntPtr,FormFix*);

[C++/CLI] public static FormImage^ FromHdib(IntPtr,FormFix^);

Creates a new object and places the given handle into it.

[Visual Basic] Overloads Public Shared Function FromHdib(IntPtr,Boolean,FormFix) As FormImage

[C#] public static FormImage FromHdib(IntPtr,bool,FormFix);

[C++] public static FormImage* FromHdib(IntPtr,bool,FormFix*);

[C++/CLI] public static FormImage^ FromHdib(IntPtr,bool,FormFix^);

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormImage Class | FormImage Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

hdib
The WIN32 HDIB handle to copy into the new object.
workspace
A reference to the FormFix workspace object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FromHdib(IntPtr,FormFix) Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class > FromHdib Method : FromHdib(IntPtr,FormFix) Method

Creates a new object and places a copy of the given image into it.

[Visual Basic]
Overloads Public Shared Function FromHdib( _
   ByVal hdib As IntPtr, _
   ByVal workspace As FormFix _
) As FormImage
[C#]
public static FormImage FromHdib(
   IntPtr hdib,
   FormFix workspace
);
[C++]
public: static FormImage* FromHdib(
   IntPtr hdib,
   FormFix* workspace
)
[C++/CLI]
public:
static FormImage^ FromHdib(
   IntPtr hdib,
   FormFix^ workspace
)

Parameters

hdib
The WIN32 HDIB handle to copy into the new object.
workspace
A reference to the FormFix workspace object.

Return Type

A new FormImage object that contains a copy of the original image.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | Overload List


%%PageItemTitle%%

FormImage Class | FormImage Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

hdib
The WIN32 HDIB handle to place into the new object.
ownDib
Indicates whether the new object should delete the handle to the DIB when you call its Dispose method. If you set this to true, this object will automatically delete the handle when it is finished using it. If you set it to false, this object will never delete the handle and you must delete it yourself.
workspace
A reference to the FormFix workspace object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FromHdib(IntPtr,Boolean,FormFix) Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class > FromHdib Method : FromHdib(IntPtr,Boolean,FormFix) Method

Creates a new object and places the given handle into it.

[Visual Basic]
Overloads Public Shared Function FromHdib( _
   ByVal hdib As IntPtr, _
   ByVal ownDib As Boolean, _
   ByVal workspace As FormFix _
) As FormImage
[C#]
public static FormImage FromHdib(
   IntPtr hdib,
   bool ownDib,
   FormFix workspace
);
[C++]
public: static FormImage* FromHdib(
   IntPtr hdib,
   bool ownDib,
   FormFix* workspace
)
[C++/CLI]
public:
static FormImage^ FromHdib(
   IntPtr hdib,
   bool ownDib,
   FormFix^ workspace
)

Parameters

hdib
The WIN32 HDIB handle to place into the new object.
ownDib
Indicates whether the new object should delete the handle to the DIB when you call its Dispose method. If you set this to true, this object will automatically delete the handle when it is finished using it. If you set it to false, this object will never delete the handle and you must delete it yourself.
workspace
A reference to the FormFix workspace object.

Return Type

A new FormImage object that contains the original image.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | Overload List


%%PageItemTitle%%

FormImage Class | FormImage Members | ToHbitmap Method | ToHdib Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ToBitmap Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : ToBitmap Method

Returns a new Bitmap object containing a copy of the image in this object.

[Visual Basic]
Public Function ToBitmap( _
   ByVal release As Boolean _
) As Bitmap
[C#]
public Bitmap ToBitmap(
   bool release
);
[C++]
public: Bitmap ToBitmap(
   bool release
)
[C++/CLI]
public:
Bitmap ToBitmap(
   bool release
)

Parameters

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.

Return Type

A new Bitmap object that contains a copy of this image.

Remarks

This method takes the image contained in this object, makes a copy of it, and returns it in the form of a Bitmap object. It can optionally release the image contained in this object at the same time.

The ToHdib method is the fastest way to transfer images between Pegasus Imaging Corporation's components.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | ToHbitmap Method | ToHdib Method


%%PageItemTitle%%

FormImage Class | FormImage Members | ToBitmap Method | ToHdib Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ToHbitmap Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : ToHbitmap Method

Returns a new WIN32 HBITMAP handle containing a copy of the image in this object.

[Visual Basic]
Public Function ToHbitmap( _
   ByVal release As Boolean _
) As IntPtr
[C#]
public IntPtr ToHbitmap(
   bool release
);
[C++]
public: IntPtr ToHbitmap(
   bool release
)
[C++/CLI]
public:
IntPtr ToHbitmap(
   bool release
)

Parameters

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.

Return Type

A new WIN32 HBITMAP handle that contains a copy of this image.

Remarks

This method takes the image contained in this object, makes a copy of it, and returns it in the form of a WIN32 HBITMAP handle. It can optionally release the image contained in this object at the same time.

The ToHdib method is the fastest way to transfer images between Pegasus Imaging Corporation's components.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | ToBitmap Method | ToHdib Method


%%PageItemTitle%%

FormImage Class | FormImage Members | ToBitmap Method | ToHbitmap Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ToHdib Method

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : ToHdib Method

Returns a new WIN32 HDIB handle containing a copy of the image in this object.

[Visual Basic]
Public Function ToHdib( _
   ByVal release As Boolean _
) As IntPtr
[C#]
public IntPtr ToHdib(
   bool release
);
[C++]
public: IntPtr ToHdib(
   bool release
)
[C++/CLI]
public:
IntPtr ToHdib(
   bool release
)

Parameters

release
Indicates whether this method should also release the image that this object contains. Set it to true if you want this method to delete the image and to false otherwise.

Return Type

A new WIN32 HDIB handle that contains a copy of this image.

Remarks

This method takes the image contained in this object, makes a copy of it, and returns it in the form of a WIN32 HDIB handle. It can optionally release the image contained in this object at the same time.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | ToBitmap Method | ToHbitmap Method


%%PageItemTitle%% $$Properties$$

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormImage Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : FormImage Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see FormImage members.

Public Properties

Public Property Height | Gets the height of the image in pixels.
Public Property HorizontalResolution | Gets and sets the horizontal, or X coordinate of the resolution of the image.
Public Property ResolutionUnit | Gets or sets the measuring unit for the horizontal and vertical resolution of the image.
Public Property VerticalResolution | Gets and sets the vertical, or Y coordinate, resolution of the image.
Public Property Width | Gets the width of the image in pixels.

See Also

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Height Property

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : Height Property (FormImage)

Gets the height of the image in pixels.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[C++/CLI]
public:
property int Height {
   int get();
}

Remarks

This property is the height, in pixels, of the image that this object contains. You cannot change this value. Instead, you must create a new FormImage object using an image of the desired size.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormImage Class | FormImage Members | ResolutionUnit Property | VerticalResolution Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

HorizontalResolution Property

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : HorizontalResolution Property (FormImage)

Gets and sets the horizontal, or X coordinate of the resolution of the image.

[Visual Basic]
Public Property HorizontalResolution As Single
[C#]
public float HorizontalResolution {get; set;}
[C++]
public: __property float get_HorizontalResolution();
public: __property void set_HorizontalResolution(
   float value
);
[C++/CLI]
public:
property float HorizontalResolution {
   float get();
   void set (float value);
}

Remarks

This property represents the horizontal resolution of the image. Many aspects of form processing depend on accurate resolutions, so it is important that this property has the correct value. To handle cases where the original image had the wrong resolution, we have made this property writeable and you should set it to the correct value.

Valid range: 0.0 to 100,000.0

Default value: The resolution contained in the original image.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | ResolutionUnit Property | VerticalResolution Property


%%PageItemTitle%%

FormImage Class | FormImage Members | HorizontalResolution Property | VerticalResolution Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ResolutionUnit Property

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : ResolutionUnit Property (FormImage)

Gets or sets the measuring unit for the horizontal and vertical resolution of the image.

[Visual Basic]
Public Property ResolutionUnit As GraphicsUnit
[C#]
public GraphicsUnit ResolutionUnit {get; set;}
[C++]
public: __property GraphicsUnit get_ResolutionUnit();
public: __property void set_ResolutionUnit(
   GraphicsUnit value
);
[C++/CLI]
public:
property GraphicsUnit ResolutionUnit {
   GraphicsUnit get();
   void set (GraphicsUnit value);
}

Remarks

This property contains the units for the horizontal and vertical resolution of the image. Many aspects of form processing depend on accurate resolutions, so it is important that this property has the correct value. To handle cases where the original image had the wrong resolution, we have made this property writeable and you should set it to the correct value.

Valid values: The following values from the System.Drawing.GraphicsUnit enumeration: Document, Inch, Millimeter, and Point.

Default value: System.Drawing.GraphicsUnit.Inch

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | HorizontalResolution Property | VerticalResolution Property


%%PageItemTitle%%

FormImage Class | FormImage Members | ResolutionUnit Property | HorizontalResolution Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

VerticalResolution Property

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : VerticalResolution Property (FormImage)

Gets and sets the vertical, or Y coordinate, resolution of the image.

[Visual Basic]
Public Property VerticalResolution As Single
[C#]
public float VerticalResolution {get; set;}
[C++]
public: __property float get_VerticalResolution();
public: __property void set_VerticalResolution(
   float value
);
[C++/CLI]
public:
property float VerticalResolution {
   float get();
   void set (float value);
}

Remarks

This property represents the vertical resolution of the image. Many aspects of form processing depend on accurate resolutions, so it is important that this property has the correct value. To handle cases where the original image had the wrong resolution, we have made this property writeable and you should set it to the correct value.

Valid range: 0.0 to 100,000.0

Default value: The resolution contained in the original image.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members | ResolutionUnit Property | HorizontalResolution Property


%%PageItemTitle%%

FormImage Class | FormImage Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Width Property

PegasusImaging.WinForms.FormFix3 Namespace > FormImage Class : Width Property (FormImage)

Gets the width of the image in pixels.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}
[C++]
public: __property int get_Width();
[C++/CLI]
public:
property int Width {
   int get();
}

Remarks

This property is the width, in pixels, of the image that this object contains. You cannot change this value. Instead, you must create a new FormImage object using an image of the desired size.

Requirements

Platforms: See Getting Started section

See Also

FormImage Class | FormImage Members


%%PageItemTitle%%

FormModel Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Class

PegasusImaging.WinForms.FormFix3 Namespace : FormModel Class (PegasusImaging.WinForms.FormFix3)

A model for a form.

For a list of all members of this type, see FormModel members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.FormModel

Syntax

[Visual Basic]
Public Class FormModel
[C#]
public class FormModel
[C++]
public __gc class FormModel
[C++/CLI]
public ref class FormModel

Remarks

This object represents a model or template for a form. Although it does not contain an image, it includes a mechanism whereby it can acquire an image of the form at any time. This object is one of the foundations for the toolkit, but does not have a significant of functionality on its own. It exposes several events that it uses to read and write persistent data and it exposes a series of methods that you can use to test your event handlers.

Note: This object may retain a cached copy of the image for some time. If you are processing multiple different types of forms, you should call the ReleaseCachedData method when you finish processing a form of this type.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

FormModel Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Class Members

PegasusImaging.WinForms.FormFix3 Namespace : FormModel Class (PegasusImaging.WinForms.FormFix3)

FormModel overview

Public Constructors

Public Constructor FormModel Constructor Initializes a new instance of the class.

Public Properties

Public Property Height | Gets the height of the form model image in pixels.
Public Property HorizontalResolution | Gets the horizontal resolution of the form model image.
Public Property Name | The name of the form.
Public Property ResolutionUnit | Gets or sets the measuring unit for the horizontal and vertical resolution of the form model image.
Public Property Tag | Gets or sets an object that contains additional data about this object.
Public Property VerticalResolution | Gets the vertical resolution of the form model image.
Public Property Width | Gets the width of the form model image in pixels.

Public Methods

Public Method ConstructDataItems | Causes the object to create as many of its data items as possible.
Public Method ConstructTestDataItems | Creates test data items in preparation for a more extensive test.
Public Method Dispose | Disposes of resources that this object is holding
Public Method ReleaseCachedData | Releases any cached data that this object holds in RAM.
Public Method TestReadChecksumEvent | Tests a ReadChecksum event.
Public Method TestReadDataItemEvent | Tests a ReadDataItem event.
Public Method TestReadFormImageEvent | Tests a ReadFormImage event.
Public Method TestWriteDataItemEvent | Tests a WriteDataItem event.
Public Method VerifyTestDataItems | Tests data items that you created using ConstructTestDataItems.

Public Events

Public Event ReadChecksum | An event for retrieving a checksum for the persistent state of a form.
Public Event ReadDataItem | An event for reading a data item from the persistent storage.
Public Event ReadFormImage | An event for reading a form model image.
Public Event WriteDataItem | An event for writing a data item to the persistent storage.

See Also

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A reference to the FormFix workspace object.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Constructor

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : FormModel Constructor (FormModel)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As FormFix _
)
[C#]
public FormModel(
   FormFix workspace
);
[C++]
public: FormModel(
   FormFix* workspace
)
[C++/CLI]
public:
FormModel(
   FormFix^ workspace
)

Parameters

workspace
A reference to the FormFix workspace object.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ConstructDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ConstructDataItems Method (FormModel)

Causes the object to create as many of its data items as possible.

[Visual Basic]
Public Sub ConstructDataItems()
[C#]
public void ConstructDataItems();
[C++]
public: void ConstructDataItems();
[C++/CLI]
public:
void ConstructDataItems();

Remarks

This method analyzes the model form image and saves the result of that analysis as data items for the form. This object also has the ability to do that same analysis and storage on demand. However, in some cases, you may want to control when the object spends its time. For example, if you have a large number of forms, you may want to have your system do its time-consuming analysis at night or on a weekend. This method allows you to control when the object does that analysis.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | VerifyTestDataItems Method | TestReadDataItemEvent Method | TestWriteDataItemEvent Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

uniqueIdentifier
A number which this method will place into various data items.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ConstructTestDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ConstructTestDataItems Method (FormModel)

Creates test data items in preparation for a more extensive test.

[Visual Basic]
Public Sub ConstructTestDataItems( _
   ByVal uniqueIdentifier As Integer _
)
[C#]
public void ConstructTestDataItems(
   int uniqueIdentifier
);
[C++]
public: void ConstructTestDataItems(
   int uniqueIdentifier
)
[C++/CLI]
public:
void ConstructTestDataItems(
   int uniqueIdentifier
)

Parameters

uniqueIdentifier
A number which this method will place into various data items.

Remarks

This method creates various data items, raising the WriteDataItem event for each one, to test various aspects of data item storage. After you call this method, you should call the VerifyTestDataItems method to verify that your data item event handlers store and retrieve data items correctly. This is a more extensive test than TestReadDataItemEvent and TestWriteDataItemEvent. It verifies that your data item event handlers can store large data items, small data items, and multiple data items. It also verifies that your event handlers overwrite an existing data item of the same type. Most of the data items that this method creates will include the uniqueIdentifier given. You must provide that same number to the VerifyTestDataItems method so it can test the content of the data items it reads. Some of the data items will include Unicode characters outside of the 0-255 common range. For an even more extensive test, see the ConstructTestDataItems method.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | VerifyTestDataItems Method | TestReadDataItemEvent Method | TestWriteDataItemEvent Method


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : Dispose Method (FormModel)

Disposes of resources that this object is holding

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReleaseCachedData Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ReleaseCachedData Method

Releases any cached data that this object holds in RAM.

[Visual Basic]
Public Sub ReleaseCachedData()
[C#]
public void ReleaseCachedData();
[C++]
public: void ReleaseCachedData();
[C++/CLI]
public:
void ReleaseCachedData();

Remarks

In order to improve performance, this object holds some information in RAM. When you call this method, the object will release all that data. It will reload that data whenever it needs it (using the ReadDataItem and ReadFormImage events.)

Normally, you will only want to call this method when you need to limit the amount of RAM consumed by your application. For the very best memory usage, you can call this method whenever you have finished processing a filled image. However, that may cause your system to run slowly as this object constantly reloads information that it discarded. A more balanced approach is to keep a list of a few most-recently-used FormModel objects. Whenever you replace an object in the list, you would call this method to release its memory.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestReadChecksumEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : TestReadChecksumEvent Method (FormModel)

Tests a ReadChecksum event.

[Visual Basic]
Public Function TestReadChecksumEvent() As Integer
[C#]
public int TestReadChecksumEvent();
[C++]
public: int TestReadChecksumEvent();
[C++/CLI]
public:
int TestReadChecksumEvent();

Return Type

The integer checksum that the ReadChecksum event handler returned.

Remarks

This method raises a ReadChecksum event and returns the checksum that the event handler returns. You can use this method as a simple way to test your ReadChecksum event handler.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | TestWriteDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The type of the data item to return. This method will place the type into the DataItemEventArgs object that it sends to the ReadDataItem event handler.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestReadDataItemEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : TestReadDataItemEvent Method (FormModel)

Tests a ReadDataItem event.

[Visual Basic]
Public Function TestReadDataItemEvent( _
   ByVal type As String _
) As String
[C#]
public string TestReadDataItemEvent(
   string type
);
[C++]
public: string* TestReadDataItemEvent(
   string* type
)
[C++/CLI]
public:
String^ TestReadDataItemEvent(
   String^ type
)

Parameters

type
The type of the data item to return. This method will place the type into the DataItemEventArgs object that it sends to the ReadDataItem event handler.

Return Type

The content string that the event handler returned.

Remarks

This method raises a ReadDataItem event, passes it the given type, and returns the content string that the event handler returns. You can use this method as a simple way to test your ReadDataItem event handler.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | TestWriteDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The type of the FormImage to return. This method will place the type into the ReadFormImageEventArgs object that it sends to the ReadFormImage event handler.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestReadFormImageEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : TestReadFormImageEvent Method

Tests a ReadFormImage event.

[Visual Basic]
Public Function TestReadFormImageEvent( _
   ByVal type As String _
) As FormImage
[C#]
public FormImage TestReadFormImageEvent(
   string type
);
[C++]
public: FormImage* TestReadFormImageEvent(
   string* type
)
[C++/CLI]
public:
FormImage^ TestReadFormImageEvent(
   String^ type
)

Parameters

type
The type of the FormImage to return. This method will place the type into the ReadFormImageEventArgs object that it sends to the ReadFormImage event handler.

Return Type

The FormImage object that the event handler returned.

Remarks

This method raises a ReadFormImage event, passes it the given type, and returns the image that the event handler returns. You can use this method as a simple way to test your ReadFormImage event handler.

Note: Normally this object will call the Dispose method for the FormImage object. However, in this case, the object is returning the FormImage object to you, so you must call the Dispose method when you are finished with the object.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | TestReadDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The type of the data item. This method will place the type into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
content
The content of the data item. This method will place the content into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestWriteDataItemEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : TestWriteDataItemEvent Method (FormModel)

Tests a WriteDataItem event.

[Visual Basic]
Public Sub TestWriteDataItemEvent( _
   ByVal type As String, _
   ByVal content As String _
)
[C#]
public void TestWriteDataItemEvent(
   string type,
   string content
);
[C++]
public: void TestWriteDataItemEvent(
   string* type,
   string* content
)
[C++/CLI]
public:
void TestWriteDataItemEvent(
   String^ type,
   String^ content
)

Parameters

type
The type of the data item. This method will place the type into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
content
The content of the data item. This method will place the content into the DataItemEventArgs object that it sends to the WriteDataItem event handler.

Remarks

This method raises a WriteDataItem event, and passes it the given type and content strings. You can use this method as a simple way to test your WriteDataItem event handler.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | TestReadDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method


%%PageItemTitle%%

FormModel Class | FormModel Members | TestReadDataItemEvent Method | TestWriteDataItemEvent Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

uniqueIdentifier
The same number you provided to ConstructTestDataItems.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

VerifyTestDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : VerifyTestDataItems Method (FormModel)

Tests data items that you created using ConstructTestDataItems.

[Visual Basic]
Public Sub VerifyTestDataItems( _
   ByVal uniqueIdentifier As Integer _
)
[C#]
public void VerifyTestDataItems(
   int uniqueIdentifier
);
[C++]
public: void VerifyTestDataItems(
   int uniqueIdentifier
)
[C++/CLI]
public:
void VerifyTestDataItems(
   int uniqueIdentifier
)

Parameters

uniqueIdentifier
The same number you provided to ConstructTestDataItems.

Remarks

This method reads various data items that you created using ConstructTestDataItems and verifies that they have the correct content. It will raise an exception if any data items appear to have not been saved and retrieved correctly.

For an even more extensive test, see the IdentificationProcessor.ConstructTestDataItems method.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | TestReadDataItemEvent Method | TestWriteDataItemEvent Method


%%PageItemTitle%% $$Properties$$

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : FormModel Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see FormModel members.

Public Properties

Public Property Height | Gets the height of the form model image in pixels.
Public Property HorizontalResolution | Gets the horizontal resolution of the form model image.
Public Property Name | The name of the form.
Public Property ResolutionUnit | Gets or sets the measuring unit for the horizontal and vertical resolution of the form model image.
Public Property Tag | Gets or sets an object that contains additional data about this object.
Public Property VerticalResolution | Gets the vertical resolution of the form model image.
Public Property Width | Gets the width of the form model image in pixels.

See Also

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Height Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : Height Property (FormModel)

Gets the height of the form model image in pixels.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}
[C++]
public: __property int get_Height();
[C++/CLI]
public:
property int Height {
   int get();
}

Remarks

This property contains the height of the form model image, in pixels. You cannot change this value since this object always derives it from the form model image. If you want to change this value, you must change it during the ReadFormImage event.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | VerticalResolution Property | ResolutionUnit Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

HorizontalResolution Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : HorizontalResolution Property (FormModel)

Gets the horizontal resolution of the form model image.

[Visual Basic]
Public ReadOnly Property HorizontalResolution As Single
[C#]
public float HorizontalResolution {get;}
[C++]
public: __property float get_HorizontalResolution();
[C++/CLI]
public:
property float HorizontalResolution {
   float get();
}

Remarks

This property contains the horizontal, or X, resolution of the form model image. You cannot change this value since this object always derives it from the form model image. If you want to change this value, you must change it during the ReadFormImage event.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | VerticalResolution Property | ResolutionUnit Property


%%PageItemTitle%%

FormModel Class | FormModel Members | Tag Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Name Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : Name Property

The name of the form.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Remarks

This property contains the name of the form. It is strictly optional and provided for your convenience. If you set this property, FormFix will place the name of the form in all debug log entries related to this object. Other than that use, FormFix will ignore the value of this property.

FormDirector does not require that forms have unique names, so you should not rely on this property to uniquely identify a form. Instead, you should use the Tag property.

Default value: ""

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | Tag Property


%%PageItemTitle%%

FormModel Class | FormModel Members | HorizontalResolution Property | VerticalResolution Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ResolutionUnit Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ResolutionUnit Property (FormModel)

Gets or sets the measuring unit for the horizontal and vertical resolution of the form model image.

[Visual Basic]
Public Property ResolutionUnit As GraphicsUnit
[C#]
public GraphicsUnit ResolutionUnit {get; set;}
[C++]
public: __property GraphicsUnit get_ResolutionUnit();
public: __property void set_ResolutionUnit(
   GraphicsUnit value
);
[C++/CLI]
public:
property GraphicsUnit ResolutionUnit {
   GraphicsUnit get();
   void set (GraphicsUnit value);
}

Remarks

This property contains the units for the horizontal and vertical resolution of the form model image.

Valid values: The following values from the System.Drawing.GraphicsUnit enumeration: Document, Inch, Millimeter, and Point.

Default value: System.Drawing.GraphicsUnit.Inch

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | HorizontalResolution Property | VerticalResolution Property


%%PageItemTitle%%

FormModel Class | FormModel Members | Name Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Tag Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : Tag Property (FormModel)

Gets or sets an object that contains additional data about this object.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Remarks

You can assign any Object derived type to this property. This component does not use it and you can use it for any purpose you see fit. Normally, you would store a reference to a FormDirector FormDefinition object.

Valid value: A reference to any object. You can store values, such as integers and strings, in this property using .NET's boxing facility.

Default value: null

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | Name Property


%%PageItemTitle%%

FormModel Class | FormModel Members | VerticalResolution Property | ResolutionUnit Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

VerticalResolution Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : VerticalResolution Property (FormModel)

Gets the vertical resolution of the form model image.

[Visual Basic]
Public ReadOnly Property VerticalResolution As Single
[C#]
public float VerticalResolution {get;}
[C++]
public: __property float get_VerticalResolution();
[C++/CLI]
public:
property float VerticalResolution {
   float get();
}

Remarks

This property contains the vertical, or Y, resolution of the form model image. You cannot change this value since this object always derives it from the form model image. If you want to change this value, you must change it during the ReadFormImage event.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | VerticalResolution Property | ResolutionUnit Property


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Width Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : Width Property (FormModel)

Gets the width of the form model image in pixels.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}
[C++]
public: __property int get_Width();
[C++/CLI]
public:
property int Width {
   int get();
}

Remarks

This property contains the width of the form model image, in pixels. You cannot change this value since this object always derives it from the form model image. If you want to change this value, you must change it during the ReadFormImage event.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%% $$Events$$

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Class Events

PegasusImaging.WinForms.FormFix3 Namespace : FormModel Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see FormModel members.

Public Events

Public Event ReadChecksum | An event for retrieving a checksum for the persistent state of a form.
Public Event ReadDataItem | An event for reading a data item from the persistent storage.
Public Event ReadFormImage | An event for reading a form model image.
Public Event WriteDataItem | An event for writing a data item to the persistent storage.

See Also

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksum Event

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ReadChecksum Event (FormModel)

An event for retrieving a checksum for the persistent state of a form.

[Visual Basic]
Public Event ReadChecksum() As ReadChecksumEventHandler
[C#]
public event ReadChecksumEventHandler ReadChecksum();
[C++]
public: __event ReadChecksumEventHandler* ReadChecksum();
[C++/CLI]
public:
event ReadChecksumEventHandler^ ReadChecksum();

Event Data

The event handler receives an argument of type ReadChecksumEventArgs containing data related to this event. The following ReadChecksumEventArgs properties provide information specific to this event.

Property | Description
Checksum | Gets or sets the checksum that the event handler is returning back to the issuer of the event.

Remarks

This object uses this event to retrieve a checksum of the persistent state of a form. That checksum should change whenever the form model changes.

This object has numerous optimizations to save processing time. One of those is the ability to save the results of analysis of the form model and reuse that analysis at a later date. The object relies on a checksum of the image to recognize when it must re-analyze the form model.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | WriteDataItem Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadDataItem Event

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ReadDataItem Event (FormModel)

An event for reading a data item from the persistent storage.

[Visual Basic]
Public Event ReadDataItem() As DataItemEventHandler
[C#]
public event DataItemEventHandler ReadDataItem();
[C++]
public: __event DataItemEventHandler* ReadDataItem();
[C++/CLI]
public:
event DataItemEventHandler^ ReadDataItem();

Event Data

The event handler receives an argument of type DataItemEventArgs containing data related to this event. The following DataItemEventArgs properties provide information specific to this event.

Property | Description
Content | The content of the data item to read or write. A string representing the content of the data item.
Type | The type of the data item to read or write. A string representing the type of data item.

Remarks

This object uses this event to read a data item from persistent storage. A data item will generally represent the saved result of analyzing a model form image.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | WriteDataItem Event


%%PageItemTitle%%

FormModel Class | FormModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImage Event

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : ReadFormImage Event

An event for reading a form model image.

[Visual Basic]
Public Event ReadFormImage() As ReadFormImageEventHandler
[C#]
public event ReadFormImageEventHandler ReadFormImage();
[C++]
public: __event ReadFormImageEventHandler* ReadFormImage();
[C++/CLI]
public:
event ReadFormImageEventHandler^ ReadFormImage();

Event Data

The event handler receives an argument of type ReadFormImageEventArgs containing data related to this event. The following ReadFormImageEventArgs properties provide information specific to this event.

Property | Description
FormImage | The T returned to the issuer of the event. Gets or sets an object which represents a form image.
Type | The type of the form image to read. Gets or sets a string which represents the type of the data item.

Remarks

This object uses this event to retrieve a copy of the form model image. The object will only retrieve the form model image when it needs to analyze it or compare it to another image.

Note: When this object raises this event and the handler returns a FormImage object as a result, this object assumes it is the only owner of that image and it will eventually call Dispose to release the memory associated with the image.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members


%%PageItemTitle%%

FormModel Class | FormModel Members | ReadDataItem Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

WriteDataItem Event

PegasusImaging.WinForms.FormFix3 Namespace > FormModel Class : WriteDataItem Event (FormModel)

An event for writing a data item to the persistent storage.

[Visual Basic]
Public Event WriteDataItem() As DataItemEventHandler
[C#]
public event DataItemEventHandler WriteDataItem();
[C++]
public: __event DataItemEventHandler* WriteDataItem();
[C++/CLI]
public:
event DataItemEventHandler^ WriteDataItem();

Event Data

The event handler receives an argument of type DataItemEventArgs containing data related to this event. The following DataItemEventArgs properties provide information specific to this event.

Property | Description
Content | The content of the data item to read or write. A string representing the content of the data item.
Type | The type of the data item to read or write. A string representing the type of data item.

Remarks

This object uses this event to write a data item to the persistent storage. This generally only happens when the object was unable to read the data item that it desired (because this object had not previously created and written it) or because this object refreshed the data item for some reason. This object will reconstruct data items whenever the form model checksum changes, when the data item is a different version than this toolkit, or when the data item is corrupted.

Requirements

Platforms: See Getting Started section

See Also

FormModel Class | FormModel Members | ReadDataItem Event


%%PageItemTitle%%

FormModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : FormModelCollection Class

A collection of FormModel objects.

For a list of all members of this type, see FormModelCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.FormModelCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class FormModelCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class FormModelCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class FormModelCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class FormModelCollection : public CollectionBase

Remarks

This object represents zero-based array of FormModel objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

FormModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : FormModelCollection Class

FormModelCollection overview

Public Constructors

Public Constructor FormModelCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : FormModelCollection Constructor (FormModelCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public FormModelCollection();
[C++]
public: FormModelCollection();
[C++/CLI]
public:
FormModelCollection();

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : Add Method (FormModelCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As FormModel _
) As Integer
[C#]
public int Add(
   FormModel value
);
[C++]
public: int Add(
   FormModel* value
)
[C++/CLI]
public:
int Add(
   FormModel^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members | Insert Method


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : Contains Method (FormModelCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As FormModel _
) As Boolean
[C#]
public bool Contains(
   FormModel value
);
[C++]
public: bool Contains(
   FormModel* value
)
[C++/CLI]
public:
bool Contains(
   FormModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members | IndexOf Method


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : CopyTo Method (FormModelCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As FormModel, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   FormModel[] array,
   int index
);
[C++]
public: void CopyTo(
   FormModel*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   FormModel^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : IndexOf Method (FormModelCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As FormModel _
) As Integer
[C#]
public int IndexOf(
   FormModel value
);
[C++]
public: int IndexOf(
   FormModel* value
)
[C++/CLI]
public:
int IndexOf(
   FormModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members | Contains Method


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : Insert Method (FormModelCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As FormModel _
)
[C#]
public void Insert(
   int index,
   FormModel value
);
[C++]
public: void Insert(
   int index,
   FormModel* value
)
[C++/CLI]
public:
void Insert(
   int index,
   FormModel^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members | Add Method


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : Remove Method (FormModelCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As FormModel _
)
[C#]
public void Remove(
   FormModel value
);
[C++]
public: void Remove(
   FormModel* value
)
[C++/CLI]
public:
void Remove(
   FormModel^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : FormModelCollection Class

For a list of all members of this type, see FormModelCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

See Also

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

FormModelCollection Class | FormModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > FormModelCollection Class : Item Property (FormModelCollection)

Gets or sets the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As FormModel
[C#]
public FormModel this[
   int index
]; {get; set;}
[C++]
public: __property FormModel* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   FormModel* value
);
[C++/CLI]
public:
 property FormModel^ default [int] {
   FormModel^ get(int index);
   void set (int index, FormModel^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

FormModelCollection Class | FormModelCollection Members


%%PageItemTitle%%

IdentificationMatch Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatch Class

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatch Class

A simple object that contains information about a form comparison and the orientation of that comparison.

For a list of all members of this type, see IdentificationMatch members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.IdentificationMatch

Syntax

[Visual Basic]
Public Class IdentificationMatch
[C#]
public class IdentificationMatch
[C++]
public __gc class IdentificationMatch
[C++/CLI]
public ref class IdentificationMatch

Remarks

The IdentificationResult object uses this object to represent a single comparison in its list of best matches. It contains a reference to a specific FormModel and the orientation of the comparison.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

IdentificationMatch Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

IdentificationMatch Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatch Class Members

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatch Class

IdentificationMatch overview

Public Constructors

Public Constructor IdentificationMatch Constructor Initializes a new instance of the class.

Public Properties

Public Property FormModelIndex | Gets or sets the zero-based index of a FormModel.
Public Property Orientation | Gets or sets the orientation of a form comparison operation.

See Also

IdentificationMatch Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationMatch Class | IdentificationMatch Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatch Constructor

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatch Class : IdentificationMatch Constructor (IdentificationMatch)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public IdentificationMatch();
[C++]
public: IdentificationMatch();
[C++/CLI]
public:
IdentificationMatch();

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatch Class | IdentificationMatch Members


%%PageItemTitle%% $$Properties$$

IdentificationMatch Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatch Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatch Class

For a list of all members of this type, see IdentificationMatch members.

Public Properties

Public Property FormModelIndex | Gets or sets the zero-based index of a FormModel.
Public Property Orientation | Gets or sets the orientation of a form comparison operation.

See Also

IdentificationMatch Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationMatch Class | IdentificationMatch Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelIndex Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatch Class : FormModelIndex Property (IdentificationMatch)

Gets or sets the zero-based index of a FormModel.

[Visual Basic]
Public Property FormModelIndex As Integer
[C#]
public int FormModelIndex {get; set;}
[C++]
public: __property int get_FormModelIndex();
public: __property void set_FormModelIndex(
   int value
);
[C++/CLI]
public:
property int FormModelIndex {
   int get();
   void set (int value);
}

Remarks

This property contains the zero-based index of a FormModel. This indicates the FormModel that the IdentificationProcessor object compared the unknown image to.

Valid range: from 0 to one less than the number of form models.

Default value: -1

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatch Class | IdentificationMatch Members


%%PageItemTitle%%

IdentificationMatch Class | IdentificationMatch Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Orientation Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatch Class : Orientation Property (IdentificationMatch)

Gets or sets the orientation of a form comparison operation.

[Visual Basic]
Public Property Orientation As IdentificationOrientation
[C#]
public IdentificationOrientation Orientation {get; set;}
[C++]
public: __property IdentificationOrientation get_Orientation();
public: __property void set_Orientation(
   IdentificationOrientation value
);
[C++/CLI]
public:
property IdentificationOrientation Orientation {
   IdentificationOrientation get();
   void set (IdentificationOrientation value);
}

Remarks

This property contains the orientation of a form comparison operation.

Valid values: NoRotation, Rotate90, Rotate180, and Rotate270

Default value: NoRotation

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatch Class | IdentificationMatch Members


%%PageItemTitle%%

IdentificationMatchCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatchCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatchCollection Class

A collection of IdentificationMatch objects.

For a list of all members of this type, see IdentificationMatchCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.IdentificationMatchCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class IdentificationMatchCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class IdentificationMatchCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class IdentificationMatchCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class IdentificationMatchCollection : public CollectionBase

Remarks

This object represents a zero-based array of IdentificationMatch objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

IdentificationMatchCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatchCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatchCollection Class

IdentificationMatchCollection overview

Public Constructors

Public Constructor IdentificationMatchCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the IdentificationMatch which corresponds to the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatchCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : IdentificationMatchCollection Constructor (IdentificationMatchCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public IdentificationMatchCollection();
[C++]
public: IdentificationMatchCollection();
[C++/CLI]
public:
IdentificationMatchCollection();

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : Add Method (IdentificationMatchCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As IdentificationMatch _
) As Integer
[C#]
public int Add(
   IdentificationMatch value
);
[C++]
public: int Add(
   IdentificationMatch* value
)
[C++/CLI]
public:
int Add(
   IdentificationMatch^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Insert Method


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : Contains Method (IdentificationMatchCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As IdentificationMatch _
) As Boolean
[C#]
public bool Contains(
   IdentificationMatch value
);
[C++]
public: bool Contains(
   IdentificationMatch* value
)
[C++/CLI]
public:
bool Contains(
   IdentificationMatch^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members | IndexOf Method


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : CopyTo Method (IdentificationMatchCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As IdentificationMatch, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   IdentificationMatch[] array,
   int index
);
[C++]
public: void CopyTo(
   IdentificationMatch*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   IdentificationMatch^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : IndexOf Method (IdentificationMatchCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As IdentificationMatch _
) As Integer
[C#]
public int IndexOf(
   IdentificationMatch value
);
[C++]
public: int IndexOf(
   IdentificationMatch* value
)
[C++/CLI]
public:
int IndexOf(
   IdentificationMatch^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Contains Method


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : Insert Method (IdentificationMatchCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As IdentificationMatch _
)
[C#]
public void Insert(
   int index,
   IdentificationMatch value
);
[C++]
public: void Insert(
   int index,
   IdentificationMatch* value
)
[C++/CLI]
public:
void Insert(
   int index,
   IdentificationMatch^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members | Add Method


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : Remove Method (IdentificationMatchCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As IdentificationMatch _
)
[C#]
public void Remove(
   IdentificationMatch value
);
[C++]
public: void Remove(
   IdentificationMatch* value
)
[C++/CLI]
public:
void Remove(
   IdentificationMatch^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatchCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatchCollection Class

For a list of all members of this type, see IdentificationMatchCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the IdentificationMatch which corresponds to the given index.

See Also

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationMatchCollection Class | IdentificationMatchCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationMatchCollection Class : Item Property (IdentificationMatchCollection)

Gets or sets the IdentificationMatch which corresponds to the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As IdentificationMatch
[C#]
public IdentificationMatch this[
   int index
]; {get; set;}
[C++]
public: __property IdentificationMatch* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   IdentificationMatch* value
);
[C++/CLI]
public:
 property IdentificationMatch^ default [int] {
   IdentificationMatch^ get(int index);
   void set (int index, IdentificationMatch^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This property allows you to get or set any IdentificationMatch object within the collection by the given index.

Requirements

Platforms: See Getting Started section

See Also

IdentificationMatchCollection Class | IdentificationMatchCollection Members


%%PageItemTitle%%

IdentificationProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Class

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationProcessor Class (PegasusImaging.WinForms.FormFix3)

A class for comparing unknown images to form models and determining which is the correct match.

For a list of all members of this type, see IdentificationProcessor members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.IdentificationProcessor

Syntax

[Visual Basic]
Public Class IdentificationProcessor
[C#]
public class IdentificationProcessor
[C++]
public __gc class IdentificationProcessor
[C++/CLI]
public ref class IdentificationProcessor

Remarks

This class is identifies unknown images and registers them to a form model. It also includes some methods for testing event handlers and for some administrative tasks.

Normally, you will want to associate an instance of this class with an instance of a FormDirector FormSet class. You can do that by assigning a reference to a FormSet object to the Tag property of an IdentificationProcessor object. You should then add event handlers to the IdentificationProcessor object. Event handlers that need to read data can read that data from the FormDirector FormSet object and event handlers that need to write data can write that data to the FormDirector FormSet object.

In order to identify forms, you need to perform several steps. First, you should prepare the set of forms. To do that, you must create a FormModel object for each form and add it to the FormModels property of this class.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

IdentificationProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Class Members

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationProcessor Class (PegasusImaging.WinForms.FormFix3)

IdentificationProcessor overview

Public Constructors

Public Constructor IdentificationProcessor Constructor Initializes a new instance of the class.

Public Properties

Public Property EnableIdentificationAdaptation | Gets and sets the controls run-time adaptation of the identification process.
Public Property FormModels | Gets the FormModelCollection that are candidates for matching.
Public Property IdentificationCertainty | Indicates if an unknown form might match a form in the FormModels collection.
Public Property IdentificationQuality | Gets or sets the amount of effort this object expends in the identification process.
Public Property IdentificationSubset | Gets a subset of the forms in FormModels to compare unknown images to.
Public Property IdentifyRotated180 | Gets or sets if images are rotated 180 degrees counter-clockwise from the matching FormModels.
Public Property IdentifyRotated270 | Gets or sets if images are rotated 270 degrees counter-clockwise from the matching FormModels.
Public Property IdentifyRotated90 | Gets or sets if images are rotated 90 degrees counter-clockwise from the matching FormModels.
Public Property LimitIdentificationToSubset | Indicates whether this object should use a subset of the forms in the P collection.
Public Property MaximumIdentificationBestMatches | Gets or sets the maximum number of matches to return in the BestMatches collection.
Public Property MinimumIdentificationConfidence | Gets or sets the minimum confidence for a successful match.
Public Property Tag | Gets or sets an object that contains additional data about this object.

Public Methods

Public Method ConstructDataItems | Causes the object to create as many of its data items as possible.
Public Method ConstructTestDataItems | Creates test data items in preparation for a more extensive test.
Public Method Dispose | Disposes of unneeded resources.
Public Method GetSimilarFormModels | Gets a list of the forms that are similar to the given one.
Public Method Identify | Identifies a form.
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method TestReadChecksumEvent | Tests a ReadChecksum event.
Public Method TestReadDataItemEvent | Tests a ReadDataItem event.
Public Method TestWriteDataItemEvent | Tests a WriteDataItem event.
Public Method VerifyTestDataItems | Tests data items that you created using ConstructTestDataItems.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

Public Events

Public Event ReadChecksum | An event for retrieving a checksum for the persistent state of a form set.
Public Event ReadDataItem | An event for reading a data item from the persistent storage.
Public Event WriteDataItem | An event for writing a data item to the persistent storage.

See Also

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A new instance of the FormFix class.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Constructor

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentificationProcessor Constructor (IdentificationProcessor)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As FormFix _
)
[C#]
public IdentificationProcessor(
   FormFix workspace
);
[C++]
public: IdentificationProcessor(
   FormFix* workspace
)
[C++/CLI]
public:
IdentificationProcessor(
   FormFix^ workspace
)

Parameters

workspace
A new instance of the FormFix class.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ConstructDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : ConstructDataItems Method (IdentificationProcessor)

Causes the object to create as many of its data items as possible.

[Visual Basic]
Public Sub ConstructDataItems()
[C#]
public void ConstructDataItems();
[C++]
public: void ConstructDataItems();
[C++/CLI]
public:
void ConstructDataItems();

Remarks

This method analyzes the form set and all its FormModel objects and saves the result of that analysis as data items for the forms and form set. This object also has the ability to do that same analysis and storage on demand. However, in some cases, you may want to control when the object spends its time. For example, if you have a large number of forms, you may want to have your system do its time-consuming analysis at night or on a weekend. This method allows you to control when the object does that analysis.

Since analysis of a form set is dependent on the analysis of individual forms in the set, this method also calls FormModel.ConstructDataItems for each FormModel in the set.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | VerifyTestDataItems Method | TestReadDataItemEvent Method | TestWriteDataItemEvent Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

uniqueIdentifier
A number which this method will place into various data items.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ConstructTestDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : ConstructTestDataItems Method (IdentificationProcessor)

Creates test data items in preparation for a more extensive test.

[Visual Basic]
Public Sub ConstructTestDataItems( _
   ByVal uniqueIdentifier As Integer _
)
[C#]
public void ConstructTestDataItems(
   int uniqueIdentifier
);
[C++]
public: void ConstructTestDataItems(
   int uniqueIdentifier
)
[C++/CLI]
public:
void ConstructTestDataItems(
   int uniqueIdentifier
)

Parameters

uniqueIdentifier
A number which this method will place into various data items.

Remarks

This method creates various data items, raising the WriteDataItem event for each one, to test various aspects of data item storage. After you call this method, you should call the VerifyTestDataItems method to verify that your data item event handlers store and retrieve data items correctly.

This is a more extensive test than TestReadDataItemEvent and TestWriteDataItemEvent. It verifies that your data item event handlers can store large data items, small data items, and multiple data items. It also verifies that your event handlers overwrite an existing data item of the same type. Most of the data items that this method creates will include the uniqueIdentifier you provide. You must provide that same number to the VerifyTestDataItems method so it can test the content of the data items it reads. Some of the data items will include Unicode characters outside of the 0-255 common range.

This test is also more extensive than the FormModel.ConstructTestDataItems method since it will call that method for each FormModel, passing a different uniqueIdentifier to each model.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | VerifyTestDataItems Method | TestReadDataItemEvent Method | TestWriteDataItemEvent Method


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : Dispose Method (IdentificationProcessor)

Disposes of unneeded resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

indexOfModel
The zero-based index of a form in the FormModels collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

GetSimilarFormModels Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : GetSimilarFormModels Method

Gets a list of the forms that are similar to the given one.

[Visual Basic]
Public Function GetSimilarFormModels( _
   ByVal indexOfModel As Integer _
) As IntegerCollection
[C#]
public IntegerCollection GetSimilarFormModels(
   int indexOfModel
);
[C++]
public: IntegerCollection* GetSimilarFormModels(
   int indexOfModel
)
[C++/CLI]
public:
IntegerCollection^ GetSimilarFormModels(
   int indexOfModel
)

Parameters

indexOfModel
The zero-based index of a form in the FormModels collection.

Return Type

A collection of integers, each of which is a zero-based index of a form that is similar to the given form.

Remarks

This method returns a list of the forms that are similar to the given one. You can use this to help in maintain a large set of forms. If your system depends on a large number of forms (more than 20 or 30) that change periodically, there is some risk that multiple copies of a form will get added. You can use this method to find all the similar forms and decide if you should remove one of them. The simplest way to apply this method is to call it once for each form in your form set and present each list to a user and let them choose which are duplicates.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

unknownImage
The image that you want this method to identify.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Identify Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : Identify Method

Identifies a form.

[Visual Basic]
Public Function Identify( _
   ByVal unknownImage As FormImage _
) As IdentificationResult
[C#]
public IdentificationResult Identify(
   FormImage unknownImage
);
[C++]
public: IdentificationResult* Identify(
   FormImage* unknownImage
)
[C++/CLI]
public:
IdentificationResult^ Identify(
   FormImage^ unknownImage
)

Parameters

unknownImage
The image that you want this method to identify.

Return Type

An IdentificationResult object with identification and registration information.

Remarks

This method compares an unknown image to the FormModel objects that this object represents and determines which FormModel is the best match.

This object has a number of properties that control the identification process. The most important one is IdentificationQuality.

You can limit the candidates to a subset of the full list of FormModel objects using the LimitIdentificationToSubset and IdentificationSubset properties.

By default, this object will not rotate the unknown image, but you can change that behavior using the IdentifyRotated90, IdentifyRotated180, and IdentifyRotated270 properties.

In three cases, an identification operation will take longer than the normal amount of time. The very first time that you try to identify an image against a set of FormModel objects, this method will perform some analysis of all the FormModel objects. This process may take several seconds for each FormModel. After this method has analyzed each FormModel, it will perform some additional analysis of all the FormModel objects. If you have less than 100 FormModel objects, this analysis will take very little time. If you have thousands of FormModel objects in your set, this analysis could take hours to perform. This method will save the results of its analysis using the WriteDataItem and FormModel.WriteDataItem events.

The second case where an identification operation would take longer than normal is when you change one of the FormModel objects in your set or when you change which FormModel objects comprise your set. This method will rerun any analysis that depends on the change.

The final case where an identification operation would take longer than normal is the first time you use an IdentificationProcessor. The associated FormModel objects will fire their ReadDataItem events, requesting the result of their initial analysis of the form. Also, this object will fire its ReadDataItem event, requesting the result of its initial analysis of the full set of forms. It will normally take the event handlers some time to acquire and return that information, increasing the time spent in this first identification operation.

Note: The identification algorithm uses the resolution of the images (both the unknown image and the model), so you must set it to the correct value for best operation. Not every method of reading an image from a file will preserve the resolution and not all image editing tools will preserve the resolution. This method will fail if the resolution of the unknown image or the model is zero. If you see that error, you should look at the debug log (see Debug) for more information about exactly which image failed.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | WriteToStream Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
A stream that the WriteToStream method created.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFromStream Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : ReadFromStream Method (IdentificationProcessor)

Reads a specially-formatted stream and places the values into properties of this object.

[Visual Basic]
Public Sub ReadFromStream( _
   ByVal stream As String _
)
[C#]
public void ReadFromStream(
   string stream
);
[C++]
public: void ReadFromStream(
   string* stream
)
[C++/CLI]
public:
void ReadFromStream(
   String^ stream
)

Parameters

stream
A stream that the WriteToStream method created.

Remarks

This method reads a stream, which contains the values of properties for this object. It provides a convenient way to store and retrieve the values and preserves as much future compatibility as possible.

This method should read any stream that the WriteToStream method created, even if an older version of this toolkit created it. This method will fail to read a stream that a newer version of this toolkit created.

Note: You should retrieve the value for the stream from the Identification property of a FormDirector FormSet object. When the Type property of that object is "FormFix/Identification", the Content property contains a string that you should send to this method.

The properties that this method reads from the stream are:

  • IdentificationQuality
  • IdentificationCertainty
  • MinimumIdentificationConfidence
  • IdentifyRotated90
  • IdentifyRotated180
  • IdentifyRotated270

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | WriteToStream Method


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestReadChecksumEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : TestReadChecksumEvent Method (IdentificationProcessor)

Tests a ReadChecksum event.

[Visual Basic]
Public Function TestReadChecksumEvent() As Integer
[C#]
public int TestReadChecksumEvent();
[C++]
public: int TestReadChecksumEvent();
[C++/CLI]
public:
int TestReadChecksumEvent();

Return Type

The integer checksum that the ReadChecksum event handler returned.

Remarks

This method raises a ReadChecksum event and returns the checksum that the event handler returns. You can use this method as a simple way to test your ReadChecksum event handler.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | TestWriteDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The type of the data item to return. This method will place the type into the DataItemEventArgs object that it sends to the ReadDataItem event handler.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestReadDataItemEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : TestReadDataItemEvent Method (IdentificationProcessor)

Tests a ReadDataItem event.

[Visual Basic]
Public Function TestReadDataItemEvent( _
   ByVal type As String _
) As String
[C#]
public string TestReadDataItemEvent(
   string type
);
[C++]
public: string* TestReadDataItemEvent(
   string* type
)
[C++/CLI]
public:
String^ TestReadDataItemEvent(
   String^ type
)

Parameters

type
The type of the data item to return. This method will place the type into the DataItemEventArgs object that it sends to the ReadDataItem event handler.

Return Type

The content string that the event handler returned.

Remarks

This method raises a ReadDataItem event, passes it the given type, and returns the content string that the event handler returns. You can use this method as a simple way to test your ReadDataItem event handler.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | TestWriteDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | TestReadDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

type
The type of the data item. This method will place the type into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
content
The content of the data item. This method will place the content into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

TestWriteDataItemEvent Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : TestWriteDataItemEvent Method (IdentificationProcessor)

Tests a WriteDataItem event.

[Visual Basic]
Public Sub TestWriteDataItemEvent( _
   ByVal type As String, _
   ByVal content As String _
)
[C#]
public void TestWriteDataItemEvent(
   string type,
   string content
);
[C++]
public: void TestWriteDataItemEvent(
   string* type,
   string* content
)
[C++/CLI]
public:
void TestWriteDataItemEvent(
   String^ type,
   String^ content
)

Parameters

type
The type of the data item. This method will place the type into the DataItemEventArgs object that it sends to the WriteDataItem event handler.
content
The content of the data item. This method will place the content into the DataItemEventArgs object that it sends to the WriteDataItem event handler.

Remarks

This method raises a WriteDataItem event, and passes it the given type and content strings. You can use this method as a simple way to test your WriteDataItem event handler.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | TestReadDataItemEvent Method | ConstructTestDataItems Method | VerifyTestDataItems Method


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | TestReadDataItemEvent Method | TestWriteDataItemEvent Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

uniqueIdentifier
The same number you provided to ConstructTestDataItems.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

VerifyTestDataItems Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : VerifyTestDataItems Method (IdentificationProcessor)

Tests data items that you created using ConstructTestDataItems.

[Visual Basic]
Public Sub VerifyTestDataItems( _
   ByVal uniqueIdentifier As Integer _
)
[C#]
public void VerifyTestDataItems(
   int uniqueIdentifier
);
[C++]
public: void VerifyTestDataItems(
   int uniqueIdentifier
)
[C++/CLI]
public:
void VerifyTestDataItems(
   int uniqueIdentifier
)

Parameters

uniqueIdentifier
The same number you provided to ConstructTestDataItems.

Remarks

This method reads various data items that you created using ConstructTestDataItems and verifies that they have the correct content. It will raise an exception if any data items appear to have not been saved and retrieved correctly.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | TestReadDataItemEvent Method | TestWriteDataItemEvent Method


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

WriteToStream Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : WriteToStream Method (IdentificationProcessor)

Writes some properties of this object to a specially-formatted stream.

[Visual Basic]
Public Function WriteToStream() As String
[C#]
public string WriteToStream();
[C++]
public: string* WriteToStream();
[C++/CLI]
public:
String^ WriteToStream();

Return Type

A stream that can be reloaded using ReadFromStream.

Remarks

This method writes certain properties of this object to a stream. The stream is intended for use only by the ReadFromStream method and its format may change in a future release of this toolkit. However, even if the format changes, future versions of this toolkit will be able to read strings that this method generates.

Note: You should save the stream in the Identification property of a FormDirector FormSet object. You should set the Type to "FormFix/Identification" and the Content to the value that this method returns.

The properties that this method writes to the stream are:

  • IdentificationQuality
  • IdentificationCertainty
  • MinimumIdentificationConfidence
  • IdentifyRotated90
  • IdentifyRotated180
  • IdentifyRotated270

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%% $$Properties$$

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationProcessor Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see IdentificationProcessor members.

Public Properties

Public Property EnableIdentificationAdaptation | Gets and sets the controls run-time adaptation of the identification process.
Public Property FormModels | Gets the FormModelCollection that are candidates for matching.
Public Property IdentificationCertainty | Indicates if an unknown form might match a form in the FormModels collection.
Public Property IdentificationQuality | Gets or sets the amount of effort this object expends in the identification process.
Public Property IdentificationSubset | Gets a subset of the forms in FormModels to compare unknown images to.
Public Property IdentifyRotated180 | Gets or sets if images are rotated 180 degrees counter-clockwise from the matching FormModels.
Public Property IdentifyRotated270 | Gets or sets if images are rotated 270 degrees counter-clockwise from the matching FormModels.
Public Property IdentifyRotated90 | Gets or sets if images are rotated 90 degrees counter-clockwise from the matching FormModels.
Public Property LimitIdentificationToSubset | Indicates whether this object should use a subset of the forms in the P collection.
Public Property MaximumIdentificationBestMatches | Gets or sets the maximum number of matches to return in the BestMatches collection.
Public Property MinimumIdentificationConfidence | Gets or sets the minimum confidence for a successful match.
Public Property Tag | Gets or sets an object that contains additional data about this object.

See Also

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

EnableIdentificationAdaptation Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : EnableIdentificationAdaptation Property

Gets and sets the controls run-time adaptation of the identification process.

[Visual Basic]
Public Property EnableIdentificationAdaptation As Boolean
[C#]
public bool EnableIdentificationAdaptation {get; set;}
[C++]
public: __property bool get_EnableIdentificationAdaptation();
public: __property void set_EnableIdentificationAdaptation(
   bool value
);
[C++/CLI]
public:
property bool EnableIdentificationAdaptation {
   bool get();
   void set (bool value);
}

Remarks

This property enables or disables run-time adaptation of the identification process. When this property is true, this object will use information it gains from previous matches to improve future matches. While that will improve both the accuracy and speed of form identification, it will also lead to inconsistent results. For example, if you identify image A, followed by image B, followed by image C, and then re-identify them in the reverse order, the confidences and registration of the matches will often be slightly different. Occasionally, you will even see cases where an image fails to identify in one situation, but succeeds if you identify the images in a different order. Often, the list of best matches in BestMatches will vary when this is true.

If you wish to see consistent results, especially when debugging a problem, you should set this property to false; however your overall speed and accuracy will be lower.

Default value: true

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModels Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : FormModels Property

Gets the FormModelCollection that are candidates for matching.

[Visual Basic]
Public ReadOnly Property FormModels As FormModelCollection
[C#]
public FormModelCollection FormModels {get;}
[C++]
public: __property FormModelCollection* get_FormModels();
[C++/CLI]
public:
property FormModelCollection^ FormModels {
   FormModelCollection^ get();
}

Remarks

This collection holds a list of FormModel objects and represent the core data for this object. Each FormModel object is a candidate for the form identification process.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationCertainty Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentificationCertainty Property

Indicates if an unknown form might match a form in the FormModels collection.

[Visual Basic]
Public Property IdentificationCertainty As Integer
[C#]
public int IdentificationCertainty {get; set;}
[C++]
public: __property int get_IdentificationCertainty();
public: __property void set_IdentificationCertainty(
   int value
);
[C++/CLI]
public:
property int IdentificationCertainty {
   int get();
   void set (int value);
}

Remarks

This property indicates the probability that an unknown form is a match for a form in the FormModels collection. In most situations, you should set this property to 100, indicating that every unknown image should match a form in the FormModels collection. However, if you are processing mixed documents and some of the images do not represent forms, you should decrease this value. For example, if 15 of your images are cover letters or handwritten notes and 85 are forms, you should set this property to a value near 85. The precise value of this property is not very important.

Valid range: 0 to 100

Default value: 100

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationQuality Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentificationQuality Property

Gets or sets the amount of effort this object expends in the identification process.

[Visual Basic]
Public Property IdentificationQuality As Integer
[C#]
public int IdentificationQuality {get; set;}
[C++]
public: __property int get_IdentificationQuality();
public: __property void set_IdentificationQuality(
   int value
);
[C++/CLI]
public:
property int IdentificationQuality {
   int get();
   void set (int value);
}

Remarks

This property controls amount of effort that this object expends identifying an unknown image. Large values cause the identification process to explore more options in order to produce a more accurate and reliable result. Small values cause the identification process to take short-cuts in order to more quickly produce a result. There is no single, best value for this parameter. Instead, it depends on the values you place on accuracy and speed. In most cases, the value of accuracy is directly related to the cost of a human to review and correct problems.

Some situations warrant a higher than normal value for this property. For example, if your form set includes many similar forms, you should increase this value. If your forms are small or have little form content, you should increase this value.

Likewise, a few situations warrant a lower than normal value for this property. If your forms are all 8.5 x 11, with at least a dozen lines, and all substantially different from each other, you can lower this value and still get accurate results.

Valid range: 0 to 100

Default value: 50

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationSubset Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentificationSubset Property

Gets a subset of the forms in FormModels to compare unknown images to.

[Visual Basic]
Public ReadOnly Property IdentificationSubset As IntegerCollection
[C#]
public IntegerCollection IdentificationSubset {get;}
[C++]
public: __property IntegerCollection* get_IdentificationSubset();
[C++/CLI]
public:
property IntegerCollection^ IdentificationSubset {
   IntegerCollection^ get();
}

Remarks

This collection holds one integer for each candidate FormModel in the subset. This object will ignore this collection unless LimitIdentificationToSubset is true. Each integer should be the zero-based index of a form in the FormModels collection. This object will ignore duplicates.

Default value: an empty list.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentifyRotated180 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentifyRotated180 Property

Gets or sets if images are rotated 180 degrees counter-clockwise from the matching FormModels.

[Visual Basic]
Public Property IdentifyRotated180 As Boolean
[C#]
public bool IdentifyRotated180 {get; set;}
[C++]
public: __property bool get_IdentifyRotated180();
public: __property void set_IdentifyRotated180(
   bool value
);
[C++/CLI]
public:
property bool IdentifyRotated180 {
   bool get();
   void set (bool value);
}

Remarks

This property controls comparison of rotated images. When this is true, this object will rotate unknown images 180 degrees clockwise and check for a match against FormModels.

Note that this rotated comparison is in addition to the normal, un-rotated comparison. If you know that your images are always rotated at a certain angle, you should go ahead and un-rotate the images before you try to identify them.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentifyRotated270 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentifyRotated270 Property

Gets or sets if images are rotated 270 degrees counter-clockwise from the matching FormModels.

[Visual Basic]
Public Property IdentifyRotated270 As Boolean
[C#]
public bool IdentifyRotated270 {get; set;}
[C++]
public: __property bool get_IdentifyRotated270();
public: __property void set_IdentifyRotated270(
   bool value
);
[C++/CLI]
public:
property bool IdentifyRotated270 {
   bool get();
   void set (bool value);
}

Remarks

This property controls comparison of rotated images. When this is true, this object will rotate unknown images 270 degrees clockwise and check for a match against FormModels.

Note that this rotated comparison is in addition to the normal, un-rotated comparison. If you know that your images are always rotated at a certain angle, you should go ahead and un-rotate the images before you try to identify them.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentifyRotated90 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : IdentifyRotated90 Property

Gets or sets if images are rotated 90 degrees counter-clockwise from the matching FormModels.

[Visual Basic]
Public Property IdentifyRotated90 As Boolean
[C#]
public bool IdentifyRotated90 {get; set;}
[C++]
public: __property bool get_IdentifyRotated90();
public: __property void set_IdentifyRotated90(
   bool value
);
[C++/CLI]
public:
property bool IdentifyRotated90 {
   bool get();
   void set (bool value);
}

Remarks

This property controls comparison of rotated images. When this is true, this object will rotate unknown images 90 degrees clockwise and check for a match against FormModels.

Note that this rotated comparison is in addition to the normal, un-rotated comparison. If you know that your images are always rotated at a certain angle, you should go ahead and un-rotate the images before you try to identify them.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | IdentificationSubset Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

LimitIdentificationToSubset Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : LimitIdentificationToSubset Property

Indicates whether this object should use a subset of the forms in the P collection.

[Visual Basic]
Public Property LimitIdentificationToSubset As Boolean
[C#]
public bool LimitIdentificationToSubset {get; set;}
[C++]
public: __property bool get_LimitIdentificationToSubset();
public: __property void set_LimitIdentificationToSubset(
   bool value
);
[C++/CLI]
public:
property bool LimitIdentificationToSubset {
   bool get();
   void set (bool value);
}

Remarks

This property allows you to limit identification to a subset of the forms in the FormModels collection. Set this property to true when you know that an unknown image cannot match some of your forms. For example, if you are processing 3 multi-page forms and you just recognized page 1 of form A, you may choose to exclude forms B and C from consideration until you have found all the pages of form A.

Two alternates to using this property are to maintain separate IdentificationProcessor objects for the subsets or to change the FormModels collection of a single IdentificationProcessor object. Both are poor alternatives due to memory and performance issues. Each IdentificationProcessor object consumes a certain amount of RAM and having multiple copies will consume more RAM than having a single one. Using a single IdentificationProcessor object also provides that object with more opportunities to learn about your forms and improve future results. Finally, changing the FormModels collection is an especially bad idea because this object will have to repeat its analysis of the forms and that can be very expensive if you have a lot of forms.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | IdentificationSubset Property


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | IdentificationResult.BestMatches

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MaximumIdentificationBestMatches Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : MaximumIdentificationBestMatches Property

Gets or sets the maximum number of matches to return in the BestMatches collection.

[Visual Basic]
Public Property MaximumIdentificationBestMatches As Integer
[C#]
public int MaximumIdentificationBestMatches {get; set;}
[C++]
public: __property int get_MaximumIdentificationBestMatches();
public: __property void set_MaximumIdentificationBestMatches(
   int value
);
[C++/CLI]
public:
property int MaximumIdentificationBestMatches {
   int get();
   void set (int value);
}

Remarks

This property controls the maximum number of matches that this object will place into the IdentificationResult.BestMatches collection. Normally, you should leave this value set to 0. If you want to refine the identification process after it completes, you can set this to a value larger than 0 (values of 3-10 are the most useful) and then use an independent identification algorithm to determine which of the best matches is the true match.

There are many approaches you can take to refine the identification process. You may be able to perform OCR on a page number, read a bar code, or use some other application-specific technique.

Valid range: 0 to 100

Default value: 0

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | IdentificationResult.BestMatches


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MinimumIdentificationConfidence Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : MinimumIdentificationConfidence Property

Gets or sets the minimum confidence for a successful match.

[Visual Basic]
Public Property MinimumIdentificationConfidence As Integer
[C#]
public int MinimumIdentificationConfidence {get; set;}
[C++]
public: __property int get_MinimumIdentificationConfidence();
public: __property void set_MinimumIdentificationConfidence(
   int value
);
[C++/CLI]
public:
property int MinimumIdentificationConfidence {
   int get();
   void set (int value);
}

Remarks

This property sets a minimum confidence for a successful match. If the best match for an unknown image has a confidence lower than this value, this object will never consider it a match.

This object maintains a separate and independent internal minimum confidence and will also reject all matches that are lower than that value. This object bases that internal minimum confidence on several attributes, such as the IdentificationCertainty property, the IdentificationQuality, and the type of forms present in FormModels.

Valid range: 1 to 101

Default value: 70

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Tag Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : Tag Property (IdentificationProcessor)

Gets or sets an object that contains additional data about this object.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
[C++/CLI]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^ value);
}

Remarks

You can assign any Object derived type to this property. This component does not use it and you can use it for any purpose you see fit. Normally, you would store a reference to a FormDirector FormSet object.

Valid value: A reference to any object. You can store values, such as integers and strings, in this property using .NET's boxing facility.

Default value: null

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%% $$Events$$

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Class Events

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationProcessor Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see IdentificationProcessor members.

Public Events

Public Event ReadChecksum | An event for retrieving a checksum for the persistent state of a form set.
Public Event ReadDataItem | An event for reading a data item from the persistent storage.
Public Event WriteDataItem | An event for writing a data item to the persistent storage.

See Also

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksum Event

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : ReadChecksum Event (IdentificationProcessor)

An event for retrieving a checksum for the persistent state of a form set.

[Visual Basic]
Public Event ReadChecksum() As ReadChecksumEventHandler
[C#]
public event ReadChecksumEventHandler ReadChecksum();
[C++]
public: __event ReadChecksumEventHandler* ReadChecksum();
[C++/CLI]
public:
event ReadChecksumEventHandler^ ReadChecksum();

Event Data

The event handler receives an argument of type ReadChecksumEventArgs containing data related to this event. The following ReadChecksumEventArgs properties provide information specific to this event.

Property | Description
Checksum | Gets or sets the checksum that the event handler is returning back to the issuer of the event.

Remarks

This object uses this event to retrieve a checksum of the persistent state of a form set. That checksum should change whenever the form set changes.

This object has numerous optimizations to save processing time. One of those is the ability to save the results of analysis of the form set and reuse that analysis at a later date. The object relies on a checksum of the form set to recognize when it must re-analyze the form set.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | WriteDataItem Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadDataItem Event

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : ReadDataItem Event (IdentificationProcessor)

An event for reading a data item from the persistent storage.

[Visual Basic]
Public Event ReadDataItem() As DataItemEventHandler
[C#]
public event DataItemEventHandler ReadDataItem();
[C++]
public: __event DataItemEventHandler* ReadDataItem();
[C++/CLI]
public:
event DataItemEventHandler^ ReadDataItem();

Event Data

The event handler receives an argument of type DataItemEventArgs containing data related to this event. The following DataItemEventArgs properties provide information specific to this event.

Property | Description
Content | The content of the data item to read or write. A string representing the content of the data item.
Type | The type of the data item to read or write. A string representing the type of data item.

Remarks

This object uses this event to read a data item from persistent storage. A data item will generally represent the saved result of analyzing a form set.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | WriteDataItem Event


%%PageItemTitle%%

IdentificationProcessor Class | IdentificationProcessor Members | ReadDataItem Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

WriteDataItem Event

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationProcessor Class : WriteDataItem Event (IdentificationProcessor)

An event for writing a data item to the persistent storage.

[Visual Basic]
Public Event WriteDataItem() As DataItemEventHandler
[C#]
public event DataItemEventHandler WriteDataItem();
[C++]
public: __event DataItemEventHandler* WriteDataItem();
[C++/CLI]
public:
event DataItemEventHandler^ WriteDataItem();

Event Data

The event handler receives an argument of type DataItemEventArgs containing data related to this event. The following DataItemEventArgs properties provide information specific to this event.

Property | Description
Content | The content of the data item to read or write. A string representing the content of the data item.
Type | The type of the data item to read or write. A string representing the type of data item.

Remarks

This object uses this event to write a data item to the persistent storage. This generally only happens when the object was unable to read the data item that it desired (because this object had not previously created and written it) or because this object refreshed the data item for some reason. This object will reconstruct data items whenever the form set checksum changes, when the data item is a different version than this toolkit, or when the data item is corrupted.

Requirements

Platforms: See Getting Started section

See Also

IdentificationProcessor Class | IdentificationProcessor Members | ReadDataItem Event


%%PageItemTitle%%

IdentificationResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationResult Class

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationResult Class

The result of an identification process.

For a list of all members of this type, see IdentificationResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.IdentificationResult

Syntax

[Visual Basic]
Public Class IdentificationResult
[C#]
public class IdentificationResult
[C++]
public __gc class IdentificationResult
[C++/CLI]
public ref class IdentificationResult

Remarks

IdentificationProcessor objects will return instances of this class whenever you call Identify.

Identify also registers an image to a model and this object also contains that registration information.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

IdentificationResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationResult Class

IdentificationResult overview

Public Properties

Public Property BestMatches | Gets a list of the best matches including the single and best match.
Public Property ComparedRotated180 | Gets the true or false which Indicates if the IdentificationProcessor compared images are rotated 180 degrees.
Public Property ComparedRotated270 | Indicates whether the T compared images rotated 270 degrees.
Public Property ComparedRotated90 | Gets the value which indicates if the IdentificationProcessor compared images are rotated 90 degrees.
Public Property CountOfFormModels | Gets the number of FormModel objects that the IdentificationProcessor object referenced.
Public Property DetectedOrientation | The orientation used to match the template.
Public Property FormModel | Gets the matching FormModel object.
Public Property FormModelIndex | Gets the zero-based index of the matching FormModel.
Public Property IdentificationProcessor | Gets the IdentificationProcessor object that constructed this object.
Public Property RegistrationResult | Gets the registration information for the matching form model.
Public Property State | Gets the final state of the identification process.

Public Methods

Public Method Dispose | Disposes of unneeded resources.
Public Method GetConfidence | Retrieve the confidence of a specific match.
Public Method GetOtherRegistrationResult | Retrieve the registration information for a specific match.

See Also

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : Dispose Method (IdentificationResult)

Disposes of unneeded resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | GetOtherRegistrationResult Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

formModelIndex
The index of the FormModel that the IdentificationProcessor object may have compared the unknown image to.
orientation
The orientation of the unknown image during the comparison.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

GetConfidence Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : GetConfidence Method

Retrieve the confidence of a specific match.

[Visual Basic]
Public Function GetConfidence( _
   ByVal formModelIndex As Integer, _
   ByVal orientation As IdentificationOrientation _
) As Integer
[C#]
public int GetConfidence(
   int formModelIndex,
   IdentificationOrientation orientation
);
[C++]
public: int GetConfidence(
   int formModelIndex,
   IdentificationOrientation orientation
)
[C++/CLI]
public:
int GetConfidence(
   int formModelIndex,
   IdentificationOrientation orientation
)

Parameters

formModelIndex
The index of the FormModel that the IdentificationProcessor object may have compared the unknown image to.
orientation
The orientation of the unknown image during the comparison.

Return Type

A confidence from 0 to 100.

Remarks

This method returns the confidence of a match between a specified FormModel and the unknown image with a specific orientation. Confidence values range from 0 to 100, with 100 indicating a very good match and 0 indicating either a very poor match or that the IdentificationProcessor object did not attempt a comparison. The IdentificationProcessor object has many techniques for avoiding unnecessary comparisons and it is very common for most of the possible comparisons to have a confidence of 0.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | GetOtherRegistrationResult Method


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | GetConfidence Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

formModelIndex
The index of the FormModel that the IdentificationProcessor object may have compared the unknown image to.
orientation
The orientation of the unknown image during the comparison.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

GetOtherRegistrationResult Method

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : GetOtherRegistrationResult Method

Retrieve the registration information for a specific match.

[Visual Basic]
Public Function GetOtherRegistrationResult( _
   ByVal formModelIndex As Integer, _
   ByVal orientation As IdentificationOrientation _
) As RegistrationResult
[C#]
public RegistrationResult GetOtherRegistrationResult(
   int formModelIndex,
   IdentificationOrientation orientation
);
[C++]
public: RegistrationResult* GetOtherRegistrationResult(
   int formModelIndex,
   IdentificationOrientation orientation
)
[C++/CLI]
public:
RegistrationResult^ GetOtherRegistrationResult(
   int formModelIndex,
   IdentificationOrientation orientation
)

Parameters

formModelIndex
The index of the FormModel that the IdentificationProcessor object may have compared the unknown image to.
orientation
The orientation of the unknown image during the comparison.

Return Type

A RegistrationResult object containing registration information for the match.

Remarks

This method returns the registration information for a match between a specified FormModel and the unknown image with a specific orientation.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | GetConfidence Method


%%PageItemTitle%% $$Properties$$

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationResult Class

For a list of all members of this type, see IdentificationResult members.

Public Properties

Public Property BestMatches | Gets a list of the best matches including the single and best match.
Public Property ComparedRotated180 | Gets the true or false which Indicates if the IdentificationProcessor compared images are rotated 180 degrees.
Public Property ComparedRotated270 | Indicates whether the T compared images rotated 270 degrees.
Public Property ComparedRotated90 | Gets the value which indicates if the IdentificationProcessor compared images are rotated 90 degrees.
Public Property CountOfFormModels | Gets the number of FormModel objects that the IdentificationProcessor object referenced.
Public Property DetectedOrientation | The orientation used to match the template.
Public Property FormModel | Gets the matching FormModel object.
Public Property FormModelIndex | Gets the zero-based index of the matching FormModel.
Public Property IdentificationProcessor | Gets the IdentificationProcessor object that constructed this object.
Public Property RegistrationResult | Gets the registration information for the matching form model.
Public Property State | Gets the final state of the identification process.

See Also

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

BestMatches Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : BestMatches Property

Gets a list of the best matches including the single and best match.

[Visual Basic]
Public ReadOnly Property BestMatches As IdentificationMatchCollection
[C#]
public IdentificationMatchCollection BestMatches {get;}
[C++]
public: __property IdentificationMatchCollection* get_BestMatches();
[C++/CLI]
public:
property IdentificationMatchCollection^ BestMatches {
   IdentificationMatchCollection^ get();
}

Remarks

This collection includes the indices of a limited number of the best matches. This property is most helpful when the identification process finds multiple matches. You can also use it in testing to help diagnose identification problems. Each object in this collection refers to a specific FormModel and orientation.

You control how many indices go into this collection using the IdentificationProcessor.MaximumIdentificationBestMatches property.

The IdentificationProcessor object will arranged the best matches in order, with the best match at the start of the list (index 0) and the worst match at the end of the list.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | ComparedRotated90 Property | ComparedRotated270 Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ComparedRotated180 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : ComparedRotated180 Property

Gets the true or false which Indicates if the IdentificationProcessor compared images are rotated 180 degrees.

[Visual Basic]
Public ReadOnly Property ComparedRotated180 As Boolean
[C#]
public bool ComparedRotated180 {get;}
[C++]
public: __property bool get_ComparedRotated180();
[C++/CLI]
public:
property bool ComparedRotated180 {
   bool get();
}

Remarks

This property will be true if the IdentificationProcessor object compared images rotated 180 degrees and false otherwise.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | ComparedRotated90 Property | ComparedRotated270 Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | ComparedRotated90 Property | ComparedRotated180 Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ComparedRotated270 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : ComparedRotated270 Property

Indicates whether the T compared images rotated 270 degrees.

[Visual Basic]
Public ReadOnly Property ComparedRotated270 As Boolean
[C#]
public bool ComparedRotated270 {get;}
[C++]
public: __property bool get_ComparedRotated270();
[C++/CLI]
public:
property bool ComparedRotated270 {
   bool get();
}

Remarks

This property will be true if the IdentificationProcessor object compared images rotated 270 degrees and false otherwise.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | ComparedRotated90 Property | ComparedRotated180 Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | ComparedRotated180 Property | ComparedRotated270 Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ComparedRotated90 Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : ComparedRotated90 Property

Gets the value which indicates if the IdentificationProcessor compared images are rotated 90 degrees.

[Visual Basic]
Public ReadOnly Property ComparedRotated90 As Boolean
[C#]
public bool ComparedRotated90 {get;}
[C++]
public: __property bool get_ComparedRotated90();
[C++/CLI]
public:
property bool ComparedRotated90 {
   bool get();
}

Remarks

This property will be true if the IdentificationProcessor object compared images rotated 90 degrees and false otherwise.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | ComparedRotated180 Property | ComparedRotated270 Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CountOfFormModels Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : CountOfFormModels Property

Gets the number of FormModel objects that the IdentificationProcessor object referenced.

[Visual Basic]
Public ReadOnly Property CountOfFormModels As Integer
[C#]
public int CountOfFormModels {get;}
[C++]
public: __property int get_CountOfFormModels();
[C++/CLI]
public:
property int CountOfFormModels {
   int get();
}

Remarks

This property indicates how many FormModel objects participated in the original identification process. It will be equal to the number of models in the IdentificationProcessor.FormModels collection.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | GetConfidence Method | GetOtherRegistrationResult Method | ComparedRotated90 Property | ComparedRotated180 Property | ComparedRotated270 Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DetectedOrientation Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : DetectedOrientation Property

The orientation used to match the template.

[Visual Basic]
Public ReadOnly Property DetectedOrientation As IdentificationOrientation
[C#]
public IdentificationOrientation DetectedOrientation {get;}
[C++]
public: __property IdentificationOrientation get_DetectedOrientation();
[C++/CLI]
public:
property IdentificationOrientation DetectedOrientation {
   IdentificationOrientation get();
}

Remarks

This property indicates the orientation the identication process used to match the image to a template. You will need this information if you call GetConfidence or GetOtherRegistrationResult

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | GetConfidence Method | GetOtherRegistrationResult Method | ComparedRotated90 Property | ComparedRotated180 Property | ComparedRotated270 Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | State Property | FormModelIndex Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : FormModel Property (IdentificationResult)

Gets the matching FormModel object.

[Visual Basic]
Public ReadOnly Property FormModel As FormModel
[C#]
public FormModel FormModel {get;}
[C++]
public: __property FormModel* get_FormModel();
[C++/CLI]
public:
property FormModel^ FormModel {
   FormModel^ get();
}

Remarks

This property contains the FormModel object that best matches the unknown image. If the IdentificationProcessor decides that the best match is not good enough, it will set this property to null.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | State Property | FormModelIndex Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | State Property | FormModel Property | BestMatches Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelIndex Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : FormModelIndex Property (IdentificationResult)

Gets the zero-based index of the matching FormModel.

[Visual Basic]
Public ReadOnly Property FormModelIndex As Integer
[C#]
public int FormModelIndex {get;}
[C++]
public: __property int get_FormModelIndex();
[C++/CLI]
public:
property int FormModelIndex {
   int get();
}

Remarks

This property contains the zero-based index of the FormModel that best matches the unknown image. If the IdentificationProcessor decides that the best match is not good enough, it will set this property to -1.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | State Property | FormModel Property | BestMatches Property


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : IdentificationProcessor Property (IdentificationResult)

Gets the IdentificationProcessor object that constructed this object.

[Visual Basic]
Public ReadOnly Property IdentificationProcessor As IdentificationProcessor
[C#]
public IdentificationProcessor IdentificationProcessor {get;}
[C++]
public: __property IdentificationProcessor* get_IdentificationProcessor();
[C++/CLI]
public:
property IdentificationProcessor^ IdentificationProcessor {
   IdentificationProcessor^ get();
}

Remarks

This property is a convenient way to access the IdentificationProcessor object that constructed this object. You can use this property to retrieve the list of FormModel objects or to read private data that you may have attached to the IdentificationProcessor object.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | GetOtherRegistrationResult Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : RegistrationResult Property (IdentificationResult)

Gets the registration information for the matching form model.

[Visual Basic]
Public ReadOnly Property RegistrationResult As RegistrationResult
[C#]
public RegistrationResult RegistrationResult {get;}
[C++]
public: __property RegistrationResult* get_RegistrationResult();
[C++/CLI]
public:
property RegistrationResult^ RegistrationResult {
   RegistrationResult^ get();
}

Remarks

This property contains the registration information for the matching model (if any.) You will need this information if you want to use the DropOutProcessor or RegistrationProcessor objects. If the IdentificationProcessor object did not find a match, this property will be null.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | GetOtherRegistrationResult Method


%%PageItemTitle%%

IdentificationResult Class | IdentificationResult Members | FormModelIndex Property | FormModel Property | BestMatches Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

State Property

PegasusImaging.WinForms.FormFix3 Namespace > IdentificationResult Class : State Property (IdentificationResult)

Gets the final state of the identification process.

[Visual Basic]
Public ReadOnly Property State As IdentificationState
[C#]
public IdentificationState State {get;}
[C++]
public: __property IdentificationState get_State();
[C++/CLI]
public:
property IdentificationState State {
   IdentificationState get();
}

Remarks

This property indicates the final state of the identification process. Similar information is available in the FormModelIndex and FormModel properties.

This property will have one of three possible values: MatchFound, NoMatchFound, MultipleMatchesFound. If it is set to NoMatchFound, then FormModelIndex will be -1 and FormModel will be null. Otherwise, both FormModelIndex and FormModel will refer to the same, best match.

Although the MatchFound and MultipleMatchesFound states both represent a successful identification, you may want to treat them differently. You can use the BestMatches property to help deal with multiple matches.

Requirements

Platforms: See Getting Started section

See Also

IdentificationResult Class | IdentificationResult Members | FormModelIndex Property | FormModel Property | BestMatches Property


%%PageItemTitle%%

IntegerCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IntegerCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : IntegerCollection Class

Represents a collection of integers.

For a list of all members of this type, see IntegerCollection members.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.IntegerCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class IntegerCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class IntegerCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class IntegerCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class IntegerCollection : public CollectionBase

Remarks

An IntegerCollection object enables you to maintain a list of integers. You can easily add, remove, and find integers in the list.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

IntegerCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IntegerCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : IntegerCollection Class

IntegerCollection overview

Public Constructors

Public Constructor IntegerCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IntegerCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : IntegerCollection Constructor (IntegerCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public IntegerCollection();
[C++]
public: IntegerCollection();
[C++/CLI]
public:
IntegerCollection();

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : Add Method (IntegerCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As Integer _
) As Integer
[C#]
public int Add(
   int value
);
[C++]
public: int Add(
   int value
)
[C++/CLI]
public:
int Add(
   int value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members | Insert Method


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : Contains Method (IntegerCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As Integer _
) As Boolean
[C#]
public bool Contains(
   int value
);
[C++]
public: bool Contains(
   int value
)
[C++/CLI]
public:
bool Contains(
   int value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members | IndexOf Method


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : CopyTo Method (IntegerCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Integer, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   int[] array,
   int index
);
[C++]
public: void CopyTo(
   int[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   intarray<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : IndexOf Method (IntegerCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Integer _
) As Integer
[C#]
public int IndexOf(
   int value
);
[C++]
public: int IndexOf(
   int value
)
[C++/CLI]
public:
int IndexOf(
   int value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members | Contains Method


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : Insert Method (IntegerCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Integer _
)
[C#]
public void Insert(
   int index,
   int value
);
[C++]
public: void Insert(
   int index,
   int value
)
[C++/CLI]
public:
void Insert(
   int index,
   int value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members | Add Method


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : Remove Method (IntegerCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Integer _
)
[C#]
public void Remove(
   int value
);
[C++]
public: void Remove(
   int value
)
[C++/CLI]
public:
void Remove(
   int value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IntegerCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : IntegerCollection Class

For a list of all members of this type, see IntegerCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

See Also

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

IntegerCollection Class | IntegerCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > IntegerCollection Class : Item Property (IntegerCollection)

Gets or sets the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Integer
[C#]
public int this[
   int index
]; {get; set;}
[C++]
public: __property int get_Item(
   int index
);
public: __property void set_Item(
   int index,
   int value
);
[C++/CLI]
public:
 property int default [int] {
   int get(int index);
   void set (int index, int value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

IntegerCollection Class | IntegerCollection Members


%%PageItemTitle%%

Licensing Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.FormFix3 Namespace : Licensing Class (PegasusImaging.WinForms.FormFix3)

Provides methods for setting the license information for the toolkit.

For a list of all members of this type, see Licensing members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

Licensing Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.FormFix3 Namespace : Licensing Class (PegasusImaging.WinForms.FormFix3)

Licensing overview

Public Properties

Public Property EvaluationMode | Gets or sets the way in which this component is limited in evaluation mode.no
Public Property LicenseEdition | Indicates the License Edition for the component.

Public Methods

Public Method UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method UnlockWeb | Unlocks the component for use in web servers.

See Also

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

Licensing Class | Licensing Members | UnlockWeb Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1

One of the unlock codes.

code2

One of the unlock codes.

code3

One of the unlock codes.

code4

One of the unlock codes.

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.FormFix3 Namespace > Licensing Class : UnlockRuntime Method

Unlocks the component for use in runtime environments.

[Visual Basic]
Public Sub UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
[C#]
public void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1

One of the unlock codes.

code2

One of the unlock codes.

code3

One of the unlock codes.

code4

One of the unlock codes.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock codes, you can retrieve them on our website:

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members | UnlockWeb Method


%%PageItemTitle%%

Licensing Class | Licensing Members | UnlockRuntime Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

code
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.FormFix3 Namespace > Licensing Class : UnlockWeb Method

Unlocks the component for use in web servers.

[Visual Basic]
Public Sub UnlockWeb( _
   ByVal code As String _
)
[C#]
public void UnlockWeb(
   string code
);
[C++]
public: void UnlockWeb(
   string* code
)
[C++/CLI]
public:
void UnlockWeb(
   String^ code
)

Parameters

code
The element to search for in the collection.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock string, you can retrieve it on our website:

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members | UnlockRuntime Method


%%PageItemTitle%% $$Properties$$

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : Licensing Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see Licensing members.

Public Properties

Public Property EvaluationMode | Gets or sets the way in which this component is limited in evaluation mode.no
Public Property LicenseEdition | Indicates the License Edition for the component.

See Also

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.FormFix3 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Gets or sets the way in which this component is limited in evaluation mode.no

[Visual Basic]
Public Property EvaluationMode As EvaluationMode
[C#]
public EvaluationMode EvaluationMode {get; set;}
[C++]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Remarks

The default value is TrialDialog.

Note: If the Timeout evaluation mode is selected, the FormFix component will no longer function after 1 minute.

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

LicenseEdition Property

PegasusImaging.WinForms.FormFix3 Namespace > Licensing Class : LicenseEdition Property

Indicates the License Edition for the component.

[Visual Basic]
Public Property LicenseEdition As LicenseEditionType
[C#]
public LicenseEditionType LicenseEdition {get; set;}
[C++]
public: __property LicenseEditionType get_LicenseEdition();
public: __property void set_LicenseEdition(
   LicenseEditionType value
);
[C++/CLI]
public:
property LicenseEditionType LicenseEdition {
   LicenseEditionType get();
   void set (LicenseEditionType value);
}

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%%

OmrBubbleModel Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModel Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModel Class

A model for an OMR field bubble.

For a list of all members of this type, see OmrBubbleModel members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrBubbleModel

Syntax

[Visual Basic]
Public Class OmrBubbleModel
[C#]
public class OmrBubbleModel
[C++]
public __gc class OmrBubbleModel
[C++/CLI]
public ref class OmrBubbleModel

Remarks

This object represents a model or template for an OMR field bubble.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrBubbleModel Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrBubbleModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModel Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModel Class

OmrBubbleModel overview

Public Constructors

Public Constructor OmrBubbleModel Constructor Initializes a new instance of this class.

Public Properties

Public Property Value Gets or sets the value of the OMR bubble.

See Also

OmrBubbleModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleModel Class | OmrBubbleModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

strValue
A string which contains a character or string value used for OMR analysis.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModel Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModel Class : OmrBubbleModel Constructor (OmrBubbleModel)

Initializes a new instance of this class.

[Visual Basic]
Public Function New( _
   ByVal strValue As String _
)
[C#]
public OmrBubbleModel(
   string strValue
);
[C++]
public: OmrBubbleModel(
   string* strValue
)
[C++/CLI]
public:
OmrBubbleModel(
   String^ strValue
)

Parameters

strValue
A string which contains a character or string value used for OMR analysis.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModel Class | OmrBubbleModel Members


%%PageItemTitle%% $$Properties$$

OmrBubbleModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModel Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModel Class

For a list of all members of this type, see OmrBubbleModel members.

Public Properties

Public Property Value Gets or sets the value of the OMR bubble.

See Also

OmrBubbleModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleModel Class | OmrBubbleModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Value Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModel Class : Value Property

Gets or sets the value of the OMR bubble.

[Visual Basic]
Public Property Value As String
[C#]
public string Value {get; set;}
[C++]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
[C++/CLI]
public:
property String^ Value {
   String^ get();
   void set (String^ value);
}

Remarks

The default value is an empty string, "".

Valid values are any valid string character or characters limited in size by 512 bytes.

This property contains the character or string result value should analysis determine that the bubble is marked.

Warning: A string value greater than 512 bytes in size may have unfavorable results.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModel Class | OmrBubbleModel Members


%%PageItemTitle%%

OmrBubbleModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModelCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModelCollection Class

A collection of OmrBubbleModel objects.

For a list of all members of this type, see OmrBubbleModelCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.OmrBubbleModelCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class OmrBubbleModelCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class OmrBubbleModelCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class OmrBubbleModelCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class OmrBubbleModelCollection : public CollectionBase

Remarks

This object represents zero-based array of OmrBubbleModel objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrBubbleModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModelCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModelCollection Class

OmrBubbleModelCollection overview

Public Constructors

Public Constructor OmrBubbleModelCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModelCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : OmrBubbleModelCollection Constructor (OmrBubbleModelCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public OmrBubbleModelCollection();
[C++]
public: OmrBubbleModelCollection();
[C++/CLI]
public:
OmrBubbleModelCollection();

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : Add Method (OmrBubbleModelCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As OmrBubbleModel _
) As Integer
[C#]
public int Add(
   OmrBubbleModel value
);
[C++]
public: int Add(
   OmrBubbleModel* value
)
[C++/CLI]
public:
int Add(
   OmrBubbleModel^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Insert Method


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : Contains Method (OmrBubbleModelCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As OmrBubbleModel _
) As Boolean
[C#]
public bool Contains(
   OmrBubbleModel value
);
[C++]
public: bool Contains(
   OmrBubbleModel* value
)
[C++/CLI]
public:
bool Contains(
   OmrBubbleModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | IndexOf Method


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : CopyTo Method (OmrBubbleModelCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OmrBubbleModel, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OmrBubbleModel[] array,
   int index
);
[C++]
public: void CopyTo(
   OmrBubbleModel*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   OmrBubbleModel^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : IndexOf Method (OmrBubbleModelCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As OmrBubbleModel _
) As Integer
[C#]
public int IndexOf(
   OmrBubbleModel value
);
[C++]
public: int IndexOf(
   OmrBubbleModel* value
)
[C++/CLI]
public:
int IndexOf(
   OmrBubbleModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Contains Method


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : Insert Method (OmrBubbleModelCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OmrBubbleModel _
)
[C#]
public void Insert(
   int index,
   OmrBubbleModel value
);
[C++]
public: void Insert(
   int index,
   OmrBubbleModel* value
)
[C++/CLI]
public:
void Insert(
   int index,
   OmrBubbleModel^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | Add Method


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : Remove Method (OmrBubbleModelCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As OmrBubbleModel _
)
[C#]
public void Remove(
   OmrBubbleModel value
);
[C++]
public: void Remove(
   OmrBubbleModel* value
)
[C++/CLI]
public:
void Remove(
   OmrBubbleModel^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModelCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModelCollection Class

For a list of all members of this type, see OmrBubbleModelCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

See Also

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleModelCollection Class : Item Property (OmrBubbleModelCollection)

Gets or sets the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As OmrBubbleModel
[C#]
public OmrBubbleModel this[
   int index
]; {get; set;}
[C++]
public: __property OmrBubbleModel* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   OmrBubbleModel* value
);
[C++/CLI]
public:
 property OmrBubbleModel^ default [int] {
   OmrBubbleModel^ get(int index);
   void set (int index, OmrBubbleModel^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleModelCollection Class | OmrBubbleModelCollection Members


%%PageItemTitle%%

OmrBubbleResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResult Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResult Class

A class that represents a bubble result of OMR analysis processing.

For a list of all members of this type, see OmrBubbleResult members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrBubbleResult

Syntax

[Visual Basic]
Public Class OmrBubbleResult
[C#]
public class OmrBubbleResult
[C++]
public __gc class OmrBubbleResult
[C++/CLI]
public ref class OmrBubbleResult

Remarks

An instance of this class represents the result of OMR analysis on a field segment. Normally you will call Bubbles to access a collection of instances of this class.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrBubbleResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrBubbleResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResult Class

OmrBubbleResult overview

Public Properties

Public Property Area Gets the analysis result rectangle for a bubble in pixels.

See Also

OmrBubbleResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Properties$$

OmrBubbleResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResult Class

For a list of all members of this type, see OmrBubbleResult members.

Public Properties

Public Property Area Gets the analysis result rectangle for a bubble in pixels.

See Also

OmrBubbleResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleResult Class | OmrBubbleResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Area Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResult Class : Area Property (OmrBubbleResult)

Gets the analysis result rectangle for a bubble in pixels.

[Visual Basic]
Public ReadOnly Property Area As Rectangle
[C#]
public Rectangle Area {get;}
[C++]
public: __property Rectangle get_Area();
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
}

Remarks

This read-only property contains the analysis result rectangular coordinates in pixels for a bubble.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResult Class | OmrBubbleResult Members


%%PageItemTitle%%

OmrBubbleResultCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResultCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResultCollection Class

A collection of OmrBubbleResult objects.

For a list of all members of this type, see OmrBubbleResultCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.OmrBubbleResultCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class OmrBubbleResultCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class OmrBubbleResultCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class OmrBubbleResultCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class OmrBubbleResultCollection : public CollectionBase

Remarks

This object represents zero-based array of OmrBubbleResult objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrBubbleResultCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResultCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResultCollection Class

OmrBubbleResultCollection overview

Public Constructors

Public Constructor OmrBubbleResultCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResultCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : OmrBubbleResultCollection Constructor (OmrBubbleResultCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public OmrBubbleResultCollection();
[C++]
public: OmrBubbleResultCollection();
[C++/CLI]
public:
OmrBubbleResultCollection();

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : Add Method (OmrBubbleResultCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As OmrBubbleResult _
) As Integer
[C#]
public int Add(
   OmrBubbleResult value
);
[C++]
public: int Add(
   OmrBubbleResult* value
)
[C++/CLI]
public:
int Add(
   OmrBubbleResult^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Insert Method


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : Contains Method (OmrBubbleResultCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As OmrBubbleResult _
) As Boolean
[C#]
public bool Contains(
   OmrBubbleResult value
);
[C++]
public: bool Contains(
   OmrBubbleResult* value
)
[C++/CLI]
public:
bool Contains(
   OmrBubbleResult^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | IndexOf Method


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : CopyTo Method (OmrBubbleResultCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OmrBubbleResult, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OmrBubbleResult[] array,
   int index
);
[C++]
public: void CopyTo(
   OmrBubbleResult*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   OmrBubbleResult^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : IndexOf Method (OmrBubbleResultCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As OmrBubbleResult _
) As Integer
[C#]
public int IndexOf(
   OmrBubbleResult value
);
[C++]
public: int IndexOf(
   OmrBubbleResult* value
)
[C++/CLI]
public:
int IndexOf(
   OmrBubbleResult^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Contains Method


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : Insert Method (OmrBubbleResultCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OmrBubbleResult _
)
[C#]
public void Insert(
   int index,
   OmrBubbleResult value
);
[C++]
public: void Insert(
   int index,
   OmrBubbleResult* value
)
[C++/CLI]
public:
void Insert(
   int index,
   OmrBubbleResult^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | Add Method


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : Remove Method (OmrBubbleResultCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As OmrBubbleResult _
)
[C#]
public void Remove(
   OmrBubbleResult value
);
[C++]
public: void Remove(
   OmrBubbleResult* value
)
[C++/CLI]
public:
void Remove(
   OmrBubbleResult^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResultCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResultCollection Class

For a list of all members of this type, see OmrBubbleResultCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

See Also

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrBubbleResultCollection Class : Item Property (OmrBubbleResultCollection)

Gets or sets the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As OmrBubbleResult
[C#]
public OmrBubbleResult this[
   int index
]; {get; set;}
[C++]
public: __property OmrBubbleResult* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   OmrBubbleResult* value
);
[C++/CLI]
public:
 property OmrBubbleResult^ default [int] {
   OmrBubbleResult^ get(int index);
   void set (int index, OmrBubbleResult^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

OmrBubbleResultCollection Class | OmrBubbleResultCollection Members


%%PageItemTitle%%

OmrFieldResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrFieldResult Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrFieldResult Class

A class that represents the result of OMR analysis processing.

For a list of all members of this type, see OmrFieldResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrFieldResult

Syntax

[Visual Basic]
Public Class OmrFieldResult
[C#]
public class OmrFieldResult
[C++]
public __gc class OmrFieldResult
[C++/CLI]
public ref class OmrFieldResult

Remarks

An instance of this class represents the result of OMR analysis on a field. You must call AnalyzeField to create an instance of this class.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrFieldResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrFieldResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrFieldResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrFieldResult Class

OmrFieldResult overview

Public Properties

Public Property Confidence | Gets the result analysis confidence for the field.
Public Property Segments | The OMRSegmentResult objects that contain a field's segment and bubble analysis results data
Public Property Text | Gets the analysis result text string for the field.

See Also

OmrFieldResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Properties$$

OmrFieldResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrFieldResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrFieldResult Class

For a list of all members of this type, see OmrFieldResult members.

Public Properties

Public Property Confidence | Gets the result analysis confidence for the field.
Public Property Segments | The OMRSegmentResult objects that contain a field's segment and bubble analysis results data
Public Property Text | Gets the analysis result text string for the field.

See Also

OmrFieldResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrFieldResult Class | OmrFieldResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrFieldResult Class : Confidence Property (OmrFieldResult)

Gets the result analysis confidence for the field.

[Visual Basic]
Public ReadOnly Property Confidence As Integer
[C#]
public int Confidence {get;}
[C++]
public: __property int get_Confidence();
[C++/CLI]
public:
property int Confidence {
   int get();
}

Remarks

This read-only property containing a value between 0 and 100 that represents the averaged analysis confidence value for all segments in the field.

Requirements

Platforms: See Getting Started section

See Also

OmrFieldResult Class | OmrFieldResult Members


%%PageItemTitle%%

OmrFieldResult Class | OmrFieldResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Segments Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrFieldResult Class : Segments Property (OmrFieldResult)

The OMRSegmentResult objects that contain a field's segment and bubble analysis results data

[Visual Basic]
Public ReadOnly Property Segments As OmrSegmentResultCollection
[C#]
public OmrSegmentResultCollection Segments {get;}
[C++]
public: __property OmrSegmentResultCollection* get_Segments();
[C++/CLI]
public:
property OmrSegmentResultCollection^ Segments {
   OmrSegmentResultCollection^ get();
}

Remarks

This collection holds a list of OmrSegmentResult objects that contain the field's segment level analysis result data.

This collection is populated by the component when the OmrFieldResult object is created in response to an analysis request. The number of OmrSegmentResult objects in the collection corresponds to the number of OmrSegmentModel objects presented for analysis.

Requirements

Platforms: See Getting Started section

See Also

OmrFieldResult Class | OmrFieldResult Members


%%PageItemTitle%%

OmrFieldResult Class | OmrFieldResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Text Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrFieldResult Class : Text Property (OmrFieldResult)

Gets the analysis result text string for the field.

[Visual Basic]
Public ReadOnly Property Text As String
[C#]
public string Text {get;}
[C++]
public: __property string* get_Text();
[C++/CLI]
public:
property String^ Text {
   String^ get();
}

Remarks

This read-only property gets the sum analysis result text string for all segment(s) in the field.

For multi-segment fields, the MultiSegmentReadDirection property specifies the direction in which segment results are read to build the result text string.

Requirements

Platforms: See Getting Started section

See Also

OmrFieldResult Class | OmrFieldResult Members


%%PageItemTitle%%

OmrProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrProcessor Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrProcessor Class

Performs OMR field recognition analysis.

For a list of all members of this type, see OmrProcessor members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrProcessor

Syntax

[Visual Basic]
Public Class OmrProcessor
[C#]
public class OmrProcessor
[C++]
public __gc class OmrProcessor
[C++/CLI]
public ref class OmrProcessor

Remarks

This class encapsulates the functionality to perform OMR recognition analysis on form fields. Class properties expose operational parameters that are expected to be initialized (although many properties can be left at default values) before the AnalyzeField method is called to perform analysis. If successfull, analysis returns a populated OmrFieldResult object which can be queried for analysis result details

OMR analysis embraces two concepts to model the OMR fields typically found on forms.

The first concept is a Bubble, which represents a circle, oval, square, or rectangle used on business forms to delineate areas that are to be hand filled or marked to indicate a choice.

The second concept is a Segment, which represents a group of one or more bubbles that after recognition provides a discrete result value. An example of segments on an OMR form would be the individual digit selection bubble groups of a Social Security number field. Segment indexes are 0 based and a field always contains at least one segment. For fields that contain more than one segment, the 0 segment is the topmost for horizontally oriented fields or the leftmost for vertically oriented fields

OMR analysis requires a properly registered and a relatively clean image. Typically the form image will need to be pre-processed with registration/deskew and despeckle operations.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrProcessor Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrProcessor Class

OmrProcessor overview

Public Constructors

Public Constructor OmrProcessor Constructor Initializes a new instance of this class.

Public Properties

Public Property AnalysisComparisonMethod | Gets or sets the image comparison method to be used during OMR analysis.
Public Property Area | Gets or sets the rectangular area of the OMR field in pixels.
Public Property BubbleShape | Gets or sets the geometric shape of one or more bubbles in the field.
Public Property FormModel | Gets or sets the FormModel that is used for comparison processing during analysis
Public Property MarkedBubbleThreshold | Gets or sets the marked bubble analysis threshold value of the field.
Public Property MarkScheme | Gets or sets the bubble mark scheme of the field.
Public Property MultiMarkDelimiter | Gets or sets the multi-mark result delimeter value of the field.
Public Property MultiSegmentReadDirection | Gets or sets the read direction used for determining field results for a multi-segment field.
Public Property Orientation | Gets or sets the orientation of a field's one or more segments to the top edge of a form image.
Public Property OriginOfClip | Gets or sets the origin coordinates for a clipped image if OMRAnalysisComparisonMethod.CompareClipToFormModel analysis comparison is requested.
Public Property Segments | Gets the OMRSegmentModel objects that models a field's segment and bubble data.
Public Property UnmarkedBubbleThreshold | Gets or sets the unmarked bubble analysis threshold value of the field.
Public Property UnmarkedSegmentResult | Gets or sets the unmarked segment result value of the field.

Public Methods

Public Method AnalyzeField | Perform OMR analysis on a field.
Public Method Dispose | Disposes of resources that this object is holding
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

See Also

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

formFix
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrProcessor Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : OmrProcessor Constructor (OmrProcessor)

Initializes a new instance of this class.

[Visual Basic]
Public Function New( _
   ByVal formFix As FormFix _
)
[C#]
public OmrProcessor(
   FormFix formFix
);
[C++]
public: OmrProcessor(
   FormFix* formFix
)
[C++/CLI]
public:
OmrProcessor(
   FormFix^ formFix
)

Parameters

formFix

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

formImage
The registered and aligned image that you want this method to perform OMR analysis on.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

AnalyzeField Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : AnalyzeField Method

Perform OMR analysis on a field.

[Visual Basic]
Public Function AnalyzeField( _
   ByVal formImage As FormImage _
) As OmrFieldResult
[C#]
public OmrFieldResult AnalyzeField(
   FormImage formImage
);
[C++]
public: OmrFieldResult* AnalyzeField(
   FormImage* formImage
)
[C++/CLI]
public:
OmrFieldResult^ AnalyzeField(
   FormImage^ formImage
)

Parameters

formImage
The registered and aligned image that you want this method to perform OMR analysis on.

Return Type

An OmrFieldResult object with analysis results information.

Remarks

This method analyzes a field of a form image to determine individual bubbles' marked/unmarked status and to calculate a confidence value for that status

This object has a number of properties that control the analysis process. The most important are Area and Segments.

This method requires an input image whose pixels match the location of a template. This is especially critical if you use the CompareClipToFormModel or CompareFullImageToFormModel methods. Preparing the input image is one of the most error-prone parts of using this function. A typical scanned image will rarely line up with the template; you must use either an IdentificationProcessor or RegistrationProcessor object to register your scanned images to the template (and the coordinates of your fields.) Either of these objects will determine how your image should be aligned and will place that information into a RegistrationResult object. You can then use that RegistrationResult object or a DropOutProcessor object to align the pixels of your scanned image to match the template.

Figure 1 below shows the exact steps you would take to register an image to the template. If you do not need to identify your image and they have suitable registration marks in the corners, you can use the right-most path, which will use a RegistrationProcessor object to produce the RegistrationResult object you need prior to OMR. If you must identify your images or they do not have suitable registration marks, you must use the left-most path, which will use an IdentificationProcessor object.

Figure 1 - Registering an image prior to OMR

Once you have registered your images, you still have to align the pixels in your scanned image to match your field coordinates. Again, you have two choices. At this point, the path you take depends on how you want to process all of your fields. The normal processing method is to create individual clips of each of your fields and process them individually. That is the path on the left of figure 2. If you wish to clean your fields (i.e. remove lines), you can easily process them just before the OMR step. Processing the fields individually also allows you to use different options for cleaning each field.

Alternately, you can align your entire image once and then process field information from that whole image. That is the path on the right of figure 2.

Figure 2 - Processing an image after registration

When you are processing individual images of fields, you must make sure that you set DropOutMethod to Clip, not DropOut.

Typical OMR analysis scenarios:

The whole filled form image is passed to OMRProcessor.AnalyzeField

  • The OmrProcessor Area properties must be set to specify the coordinates of the desired field within the filled form image
  • If Drop-Out processing is desired, the OmrProcessor.AnalysisComparisonMethod must be set to "CompareFullImageToFormModel". The OmrProcessor.OriginOfClip values are ignored and do not need to be set.

Only a clip from the whole filled form image is passed to OMRProcessor.AnalyzeField.

This clip image represents an individual field of the filled form to be analyzed.

  • The OmrProcessor Area properties must be set/reset to zero. Note that zero is the default value for these properties.
  • If Drop-Out processing is desired, the OmrProcessor.AnalysisComparisonMethod must be set to "CompareClipToFormModel". The OmrProcessor.OriginOfClip values must be set to the X and Y offset of the clipped field image relative to the full form template image.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : Dispose Method (OmrProcessor)

Disposes of resources that this object is holding

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members | WriteToStream Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
A stream that the WriteToStream method created.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFromStream Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : ReadFromStream Method (OmrProcessor)

Reads a specially-formatted stream and places the values into properties of this object.

[Visual Basic]
Public Sub ReadFromStream( _
   ByVal stream As String _
)
[C#]
public void ReadFromStream(
   string stream
);
[C++]
public: void ReadFromStream(
   string* stream
)
[C++/CLI]
public:
void ReadFromStream(
   String^ stream
)

Parameters

stream
A stream that the WriteToStream method created.

Remarks

This method reads a stream, which contains the values of properties for this object. It provides a convenient way to store and retrieve the values and preserves as much future compatibility as possible.

This method should read any stream that the WriteToStream method created, even if an older version of this toolkit created it. This method will fail to read a stream that a newer version of this toolkit created.

Note: You should retrieve the value for the stream from the Operations collection of a FormDirector FormDefinition object. When the Type property of that object is "FormFix/OMR", the Content property contains a string that you should send to this method.

The properties that this method reads from the stream are:

  • AnalysisComparisonMethod
  • MultiSegmentReadDirection
  • UnmarkedBubbleThreshold
  • MarkedBubbleThreshold
  • UnmarkedSegmentResult
  • MarkScheme
  • MultiMarkDelimiter
  • BubbleShape
  • Orientation
  • Segments

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members | WriteToStream Method


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

WriteToStream Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : WriteToStream Method (OmrProcessor)

Writes some properties of this object to a specially-formatted stream.

[Visual Basic]
Public Function WriteToStream() As String
[C#]
public string WriteToStream();
[C++]
public: string* WriteToStream();
[C++/CLI]
public:
String^ WriteToStream();

Return Type

A stream that can be reloaded using ReadFromStream.

Remarks

This method writes certain properties of this object to a stream. The stream is intended for use only by the ReadFromStream method and its format may change in a future release of this toolkit. However, even if the format changes, future versions of this toolkit will be able to read strings that this method generates.

Note: You should save the stream in the Operations Collection of a FormDirector FormDefinition object. You should set the Type to "FormFix/OMR" and the Content to the value that this method returns.

The properties that this method writes to the string are:

  • AnalysisComparisonMethod
  • MultiSegmentReadDirection
  • UnmarkedBubbleThreshold
  • MarkedBubbleThreshold
  • UnmarkedSegmentResult
  • MarkScheme
  • MultiMarkDelimiter
  • BubbleShape
  • Orientation
  • Segments

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%% $$Properties$$

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrProcessor Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrProcessor Class

For a list of all members of this type, see OmrProcessor members.

Public Properties

Public Property AnalysisComparisonMethod | Gets or sets the image comparison method to be used during OMR analysis.
Public Property Area | Gets or sets the rectangular area of the OMR field in pixels.
Public Property BubbleShape | Gets or sets the geometric shape of one or more bubbles in the field.
Public Property FormModel | Gets or sets the FormModel that is used for comparison processing during analysis
Public Property MarkedBubbleThreshold | Gets or sets the marked bubble analysis threshold value of the field.
Public Property MarkScheme | Gets or sets the bubble mark scheme of the field.
Public Property MultiMarkDelimiter | Gets or sets the multi-mark result delimeter value of the field.
Public Property MultiSegmentReadDirection | Gets or sets the read direction used for determining field results for a multi-segment field.
Public Property Orientation | Gets or sets the orientation of a field's one or more segments to the top edge of a form image.
Public Property OriginOfClip | Gets or sets the origin coordinates for a clipped image if OMRAnalysisComparisonMethod.CompareClipToFormModel analysis comparison is requested.
Public Property Segments | Gets the OMRSegmentModel objects that models a field's segment and bubble data.
Public Property UnmarkedBubbleThreshold | Gets or sets the unmarked bubble analysis threshold value of the field.
Public Property UnmarkedSegmentResult | Gets or sets the unmarked segment result value of the field.

See Also

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

AnalysisComparisonMethod Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : AnalysisComparisonMethod Property

Gets or sets the image comparison method to be used during OMR analysis.

[Visual Basic]
Public Property AnalysisComparisonMethod As OmrAnalysisComparisonMethod
[C#]
public OmrAnalysisComparisonMethod AnalysisComparisonMethod {get; set;}
[C++]
public: __property OmrAnalysisComparisonMethod get_AnalysisComparisonMethod();
public: __property void set_AnalysisComparisonMethod(
   OmrAnalysisComparisonMethod value
);
[C++/CLI]
public:
property OmrAnalysisComparisonMethod AnalysisComparisonMethod {
   OmrAnalysisComparisonMethod get();
   void set (OmrAnalysisComparisonMethod value);
}

Remarks

This property specifies if OMR analysis image comparison processing is desired. Requesting comparison will, in most cases, improve recognitiona accuracy at a moderate cost to speed. See OmrAnalysisComparisonMethod for possible analysis comparison methods.

Default value: OmrAnalysisComparisonMethod.None

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Area Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : Area Property (OmrProcessor)

Gets or sets the rectangular area of the OMR field in pixels.

[Visual Basic]
Public Property Area As Rectangle
[C#]
public Rectangle Area {get; set;}
[C++]
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
   void set (Rectangle value);
}

Remarks

This property contains the coordinates, in pixels, of the OMR field. An Area specified as System.Drawing.Rectangle.Empty indicates that the image contains only an OMR field and the image should be examined in its entirety

Default value: System.Drawing.Rectangle.Empty

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

BubbleShape Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : BubbleShape Property

Gets or sets the geometric shape of one or more bubbles in the field.

[Visual Basic]
Public Property BubbleShape As OmrBubbleShape
[C#]
public OmrBubbleShape BubbleShape {get; set;}
[C++]
public: __property OmrBubbleShape get_BubbleShape();
public: __property void set_BubbleShape(
   OmrBubbleShape value
);
[C++/CLI]
public:
property OmrBubbleShape BubbleShape {
   OmrBubbleShape get();
   void set (OmrBubbleShape value);
}

Remarks

This property specifies the geometric shape of the bubbles in the OMR field to be analyzed. See OmrBubbleShape for possible shape values.

Default value is OmrBubbleShape.Circular.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : FormModel Property (OmrProcessor)

Gets or sets the FormModel that is used for comparison processing during analysis

[Visual Basic]
Public Property FormModel As FormModel
[C#]
public FormModel FormModel {get; set;}
[C++]
public: __property FormModel* get_FormModel();
public: __property void set_FormModel(
   FormModel* value
);
[C++/CLI]
public:
property FormModel^ FormModel {
   FormModel^ get();
   void set (FormModel^ value);
}

Remarks

This property contains the FormModel to be used for comparison processing during OMR analysis. This property is ignored if the AnalysisComparisonMethod property is not set to OmrAnalysisComparisonMethod.CompareClipToFormModel or OmrAnalysisComparisonMethod.CompareFullImageToFormModel.

Default value: null

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MarkedBubbleThreshold Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : MarkedBubbleThreshold Property

Gets or sets the marked bubble analysis threshold value of the field.

[Visual Basic]
Public Property MarkedBubbleThreshold As Integer
[C#]
public int MarkedBubbleThreshold {get; set;}
[C++]
public: __property int get_MarkedBubbleThreshold();
public: __property void set_MarkedBubbleThreshold(
   int value
);
[C++/CLI]
public:
property int MarkedBubbleThreshold {
   int get();
   void set (int value);
}

Remarks

The default value is 25.

Valid values are a range from 0 to 100.

This property specifies a percentage between 0 and 100 that one or more bubbles in a field segment must achieve in normalized mark density before the segment can be considered to contain a marked bubble.

Recommended threshold values are as follows:

Using drop out should eliminate much of the pixel density. Because of this, drop out is encouraged and threshold values should be modified as appropriate.

Using Drop-Out:

  • Single mark = a value of 13
  • Multi mark = a value of 25

Not using Drop-Out:

  • Single mark = a value of 25
  • Multi mark = a value of 55

See the Analyze OMR Fields topic for more information.

For MarkBox, or other similar type of single bubble fields, set the threshold lower to analyze the area for a single check rather than a filled-in bubble which would contain more pixel density.

The recommended values are as follows:

  • Using Drop-Out = a value of 10
  • Not using Drop-Out = a value of 30

Note: If the MarkScheme property is set to MultiMark, this MarkedBubbleThreshold value should be adjusted and field recognition accuracy may decrease.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MarkScheme Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : MarkScheme Property

Gets or sets the bubble mark scheme of the field.

[Visual Basic]
Public Property MarkScheme As OmrMarkScheme
[C#]
public OmrMarkScheme MarkScheme {get; set;}
[C++]
public: __property OmrMarkScheme get_MarkScheme();
public: __property void set_MarkScheme(
   OmrMarkScheme value
);
[C++/CLI]
public:
property OmrMarkScheme MarkScheme {
   OmrMarkScheme get();
   void set (OmrMarkScheme value);
}

Remarks

The default value is OMRMarkScheme.SingleMark.

This property specifies whether there is expected to be a maximum of a single bubble per segment marked. See the OMRMarkScheme enumeration for possible type values.

In most cases, setting this property to MultiMark will require an adjustment to the MarkedBubbleThreshold property value and tends to decrease field recognition accurracy.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MultiMarkDelimiter Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : MultiMarkDelimiter Property

Gets or sets the multi-mark result delimeter value of the field.

[Visual Basic]
Public Property MultiMarkDelimiter As String
[C#]
public string MultiMarkDelimiter {get; set;}
[C++]
public: __property string* get_MultiMarkDelimiter();
public: __property void set_MultiMarkDelimiter(
   string* value
);
[C++/CLI]
public:
property String^ MultiMarkDelimiter {
   String^ get();
   void set (String^ value);
}

Remarks

This property specifies the delimeter string or character for a Multi-mark field that is used to separate multiple result values in a field's or segment's result

Default value is a comma character.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members | OMR Objects

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MultiSegmentReadDirection Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : MultiSegmentReadDirection Property

Gets or sets the read direction used for determining field results for a multi-segment field.

[Visual Basic]
Public Property MultiSegmentReadDirection As OmrMultiSegmentReadDirection
[C#]
public OmrMultiSegmentReadDirection MultiSegmentReadDirection {get; set;}
[C++]
public: __property OmrMultiSegmentReadDirection get_MultiSegmentReadDirection();
public: __property void set_MultiSegmentReadDirection(
   OmrMultiSegmentReadDirection value
);
[C++/CLI]
public:
property OmrMultiSegmentReadDirection MultiSegmentReadDirection {
   OmrMultiSegmentReadDirection get();
   void set (OmrMultiSegmentReadDirection value);
}

Remarks

The default value is OmrMultiSegmentReadDirection.Normal.

This property specifies the direction in which individual segment analysis results are evaluated when building a sum result for a multi-segment field. See the OmrMultiSegmentReadDirection enumeration for read direction options.

For a multi-segment field with an OmrMultiSegmentReadDirection.Normal read direction specified, those fields with an OmrOrientation.HorizontalSegments orientation will have its segments read top to bottom. Those fields with an OmrOrientation.VerticalSegments orientation, will have its segments read left to right.

For a multi-segment field with an OmrMultiSegmentReadDirection.Reversed read direction specified, those fields with an OmrOrientation.HorizontalSegments orientation will have its segments read bottom to top. Those fields fields with an OmrOrientation.VerticalSegments orientation will have its segments read right to left.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members | OMR Objects


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Orientation Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : Orientation Property (OmrProcessor)

Gets or sets the orientation of a field's one or more segments to the top edge of a form image.

[Visual Basic]
Public Property Orientation As OmrOrientation
[C#]
public OmrOrientation Orientation {get; set;}
[C++]
public: __property OmrOrientation get_Orientation();
public: __property void set_Orientation(
   OmrOrientation value
);
[C++/CLI]
public:
property OmrOrientation Orientation {
   OmrOrientation get();
   void set (OmrOrientation value);
}

Remarks

The default value is OmrOrientation.HorizontalSegments.

Valid values are selected from the OmrOrientation enumeration.

This property specifies the relationship of one or more segments in a bubble grid to the top edge of a form image. If the bubbles of a segment run parallel to the top edge, the field orientation is OmrOrientation.HorizontalSegments. If the bubbles of a segment run perpendicular to the top edge, the orientation is OmrOrientation.VerticalSegments.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OriginOfClip Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : OriginOfClip Property

Gets or sets the origin coordinates for a clipped image if OMRAnalysisComparisonMethod.CompareClipToFormModel analysis comparison is requested.

[Visual Basic]
Public Property OriginOfClip As Point
[C#]
public Point OriginOfClip {get; set;}
[C++]
public: __property Point get_OriginOfClip();
public: __property void set_OriginOfClip(
   Point value
);
[C++/CLI]
public:
property Point OriginOfClip {
   Point get();
   void set (Point value);
}

Remarks

This property contains the origin coordinates, in pixels, for a clipped image that is passed as the image data to the AnalyzeField function. The origin is relative to the image specified by the FormModel property. This property is ignored if the AnalysisComparisonMethod property is not to set to OmrAnalysisComparisonMethod.CompareClipToFormModel.

Default value: System.Drawing.Point.Empty

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Segments Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : Segments Property (OmrProcessor)

Gets the OMRSegmentModel objects that models a field's segment and bubble data.

[Visual Basic]
Public ReadOnly Property Segments As OmrSegmentModelCollection
[C#]
public OmrSegmentModelCollection Segments {get;}
[C++]
public: __property OmrSegmentModelCollection* get_Segments();
[C++/CLI]
public:
property OmrSegmentModelCollection^ Segments {
   OmrSegmentModelCollection^ get();
}

Remarks

This collection holds a list of OmrSegmentModel objects that represent the core bubble grid dimension and result value data required for field analysis.

You must populate this collection before calling the AnalyzeField method. The number of OmrSegmentModel objects in the collection must correspond to the number of segments in the form field. Each OmrSegmentModel object must contain a number of OmrBubbleModel objects corresponding to the number of bubbles in the form field segment.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

UnmarkedBubbleThreshold Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : UnmarkedBubbleThreshold Property

Gets or sets the unmarked bubble analysis threshold value of the field.

[Visual Basic]
Public Property UnmarkedBubbleThreshold As Integer
[C#]
public int UnmarkedBubbleThreshold {get; set;}
[C++]
public: __property int get_UnmarkedBubbleThreshold();
public: __property void set_UnmarkedBubbleThreshold(
   int value
);
[C++/CLI]
public:
property int UnmarkedBubbleThreshold {
   int get();
   void set (int value);
}

Remarks

The default value is 8.

Valid values are a range from 0 to 100.

This property specifies a percentage between 0 and 100 that bubbles in a field segment must differ in normalized mark density before the segment can be considered to contain a marked bubble.

Recommended threshold values are as follows:

Using drop out should eliminate much of the pixel density. Because of this, drop out is encouraged and threshold values should be modified as appropriate.

Using Drop-Out:

  • Single mark = a value of 5
  • Multi mark = a value of 8

Not using Drop-Out:

  • Single mark = a value of 9
  • Multi mark = a value of 15

See the Analyze OMR Fields topic for more information.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrProcessor Class | OmrProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

UnmarkedSegmentResult Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrProcessor Class : UnmarkedSegmentResult Property

Gets or sets the unmarked segment result value of the field.

[Visual Basic]
Public Property UnmarkedSegmentResult As String
[C#]
public string UnmarkedSegmentResult {get; set;}
[C++]
public: __property string* get_UnmarkedSegmentResult();
public: __property void set_UnmarkedSegmentResult(
   string* value
);
[C++/CLI]
public:
property String^ UnmarkedSegmentResult {
   String^ get();
   void set (String^ value);
}

Remarks

The default value is an empty string "".

Valid values are any valid string.

This property specifies a result string or character value for a field's segment that was determined to have no bubbles marked.

Requirements

Platforms: See Getting Started section

See Also

OmrProcessor Class | OmrProcessor Members


%%PageItemTitle%%

OmrSegmentModel Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModel Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModel Class

A model for an OMR field segment.

For a list of all members of this type, see OmrSegmentModel members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrSegmentModel

Syntax

[Visual Basic]
Public Class OmrSegmentModel
[C#]
public class OmrSegmentModel
[C++]
public __gc class OmrSegmentModel
[C++/CLI]
public ref class OmrSegmentModel

Remarks

This object represents a model or template for an OMR field segment.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrSegmentModel Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrSegmentModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModel Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModel Class

OmrSegmentModel overview

Public Constructors

Public Constructor OmrSegmentModel Constructor Initializes a new instance of this class.

Public Properties

Public Property Bubbles Gets the OMRBubbleModel objects that models a field segment's bubbles.

See Also

OmrSegmentModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentModel Class | OmrSegmentModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModel Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModel Class : OmrSegmentModel Constructor (OmrSegmentModel)

Initializes a new instance of this class.

[Visual Basic]
Public Function New()
[C#]
public OmrSegmentModel();
[C++]
public: OmrSegmentModel();
[C++/CLI]
public:
OmrSegmentModel();

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModel Class | OmrSegmentModel Members


%%PageItemTitle%% $$Properties$$

OmrSegmentModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModel Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModel Class

For a list of all members of this type, see OmrSegmentModel members.

Public Properties

Public Property Bubbles Gets the OMRBubbleModel objects that models a field segment's bubbles.

See Also

OmrSegmentModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentModel Class | OmrSegmentModel Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Bubbles Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModel Class : Bubbles Property (OmrSegmentModel)

Gets the OMRBubbleModel objects that models a field segment's bubbles.

[Visual Basic]
Public ReadOnly Property Bubbles As OmrBubbleModelCollection
[C#]
public OmrBubbleModelCollection Bubbles {get;}
[C++]
public: __property OmrBubbleModelCollection* get_Bubbles();
[C++/CLI]
public:
property OmrBubbleModelCollection^ Bubbles {
   OmrBubbleModelCollection^ get();
}

Remarks

This collection holds a list of OMRBubbleModel objects and represent the core bubble grid dimension and result value data required for field analysis. You must populate this collection before you call the AnalyzeField method. The number of OMRBubbleModel objects in the collection must correspond to the number of bubbles in the form fields's segment.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModel Class | OmrSegmentModel Members


%%PageItemTitle%%

OmrSegmentModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModelCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModelCollection Class

A collection of OmrSegmentModel objects.

For a list of all members of this type, see OmrSegmentModelCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.OmrSegmentModelCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class OmrSegmentModelCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class OmrSegmentModelCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class OmrSegmentModelCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class OmrSegmentModelCollection : public CollectionBase

Remarks

This object represents zero-based array of OmrSegmentModel objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrSegmentModelCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModelCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModelCollection Class

OmrSegmentModelCollection overview

Public Constructors

Public Constructor OmrSegmentModelCollection Constructor Initializes a new instance of the class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the the element at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModelCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : OmrSegmentModelCollection Constructor (OmrSegmentModelCollection)

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public OmrSegmentModelCollection();
[C++]
public: OmrSegmentModelCollection();
[C++/CLI]
public:
OmrSegmentModelCollection();

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : Add Method (OmrSegmentModelCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As OmrSegmentModel _
) As Integer
[C#]
public int Add(
   OmrSegmentModel value
);
[C++]
public: int Add(
   OmrSegmentModel* value
)
[C++/CLI]
public:
int Add(
   OmrSegmentModel^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Insert Method


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : Contains Method (OmrSegmentModelCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As OmrSegmentModel _
) As Boolean
[C#]
public bool Contains(
   OmrSegmentModel value
);
[C++]
public: bool Contains(
   OmrSegmentModel* value
)
[C++/CLI]
public:
bool Contains(
   OmrSegmentModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | IndexOf Method


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : CopyTo Method (OmrSegmentModelCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OmrSegmentModel, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OmrSegmentModel[] array,
   int index
);
[C++]
public: void CopyTo(
   OmrSegmentModel*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   OmrSegmentModel^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : IndexOf Method (OmrSegmentModelCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As OmrSegmentModel _
) As Integer
[C#]
public int IndexOf(
   OmrSegmentModel value
);
[C++]
public: int IndexOf(
   OmrSegmentModel* value
)
[C++/CLI]
public:
int IndexOf(
   OmrSegmentModel^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Contains Method


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : Insert Method (OmrSegmentModelCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OmrSegmentModel _
)
[C#]
public void Insert(
   int index,
   OmrSegmentModel value
);
[C++]
public: void Insert(
   int index,
   OmrSegmentModel* value
)
[C++/CLI]
public:
void Insert(
   int index,
   OmrSegmentModel^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | Add Method


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : Remove Method (OmrSegmentModelCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As OmrSegmentModel _
)
[C#]
public void Remove(
   OmrSegmentModel value
);
[C++]
public: void Remove(
   OmrSegmentModel* value
)
[C++/CLI]
public:
void Remove(
   OmrSegmentModel^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModelCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModelCollection Class

For a list of all members of this type, see OmrSegmentModelCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the the element at the given index.

See Also

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentModelCollection Class : Item Property (OmrSegmentModelCollection)

Gets or sets the the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As OmrSegmentModel
[C#]
public OmrSegmentModel this[
   int index
]; {get; set;}
[C++]
public: __property OmrSegmentModel* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   OmrSegmentModel* value
);
[C++/CLI]
public:
 property OmrSegmentModel^ default [int] {
   OmrSegmentModel^ get(int index);
   void set (int index, OmrSegmentModel^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentModelCollection Class | OmrSegmentModelCollection Members


%%PageItemTitle%%

OmrSegmentResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResult Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResult Class

A class that represents a segment result of OMR analysis processing.

For a list of all members of this type, see OmrSegmentResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.OmrSegmentResult

Syntax

[Visual Basic]
Public Class OmrSegmentResult
[C#]
public class OmrSegmentResult
[C++]
public __gc class OmrSegmentResult
[C++/CLI]
public ref class OmrSegmentResult

Remarks

An instance of this class represents the result of OMR analysis on a field segment. Normally you will call Segments to access a collection of instances of this class.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrSegmentResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrSegmentResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResult Class

OmrSegmentResult overview

Public Properties

Public Property Bubbles | Gets the OMRBubbleResult objects that contain bubble analysis results data.
Public Property Confidence | Gets the analysis result confidence value for the segment.
Public Property MultiMarkValues | Gets a string objects collection that represent segment analysis multi-mark results text data.
Public Property Text | Gets the analysis result text string for a segment.

See Also

OmrSegmentResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Properties$$

OmrSegmentResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResult Class

For a list of all members of this type, see OmrSegmentResult members.

Public Properties

Public Property Bubbles | Gets the OMRBubbleResult objects that contain bubble analysis results data.
Public Property Confidence | Gets the analysis result confidence value for the segment.
Public Property MultiMarkValues | Gets a string objects collection that represent segment analysis multi-mark results text data.
Public Property Text | Gets the analysis result text string for a segment.

See Also

OmrSegmentResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentResult Class | OmrSegmentResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Bubbles Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResult Class : Bubbles Property (OmrSegmentResult)

Gets the OMRBubbleResult objects that contain bubble analysis results data.

[Visual Basic]
Public ReadOnly Property Bubbles As OmrBubbleResultCollection
[C#]
public OmrBubbleResultCollection Bubbles {get;}
[C++]
public: __property OmrBubbleResultCollection* get_Bubbles();
[C++/CLI]
public:
property OmrBubbleResultCollection^ Bubbles {
   OmrBubbleResultCollection^ get();
}

Remarks

This collection holds a list of OmrBubbleResult objects that contain the segment's bubble(s) analysis result data.

This collection is populated by the component when the OmrFieldResult object is created in response to an analysis request. The number of OmrBubbleResult objects in the collection corresponds to the number of OmrBubbleModel objects presented for analysis.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResult Class | OmrSegmentResult Members


%%PageItemTitle%%

OmrSegmentResult Class | OmrSegmentResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResult Class : Confidence Property (OmrSegmentResult)

Gets the analysis result confidence value for the segment.

[Visual Basic]
Public ReadOnly Property Confidence As Integer
[C#]
public int Confidence {get;}
[C++]
public: __property int get_Confidence();
[C++/CLI]
public:
property int Confidence {
   int get();
}

Remarks

This read-only property contains a value between 0 and 100 that represents the analysis confidence value for the OMR segment.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResult Class | OmrSegmentResult Members


%%PageItemTitle%%

OmrSegmentResult Class | OmrSegmentResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

MultiMarkValues Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResult Class : MultiMarkValues Property

Gets a string objects collection that represent segment analysis multi-mark results text data.

[Visual Basic]
Public ReadOnly Property MultiMarkValues As StringCollection
[C#]
public StringCollection MultiMarkValues {get;}
[C++]
public: __property StringCollection get_MultiMarkValues();
[C++/CLI]
public:
property StringCollection MultiMarkValues {
   StringCollection get();
}

Remarks

This collection holds a list of string objects that contain the segments's Multi-mark analysis result text data.

This collection is populated by the component when the OmrFieldResult object is created in response to an analysis request. The number of String objects in the collection corresponds to the number of bubbles that analysis determined were marked. If no bubbles were determined to be marked the collection is empty. The collection is always empty for processing not designated with a MarkScheme of OmrMarkScheme.MultiMark.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResult Class | OmrSegmentResult Members


%%PageItemTitle%%

OmrSegmentResult Class | OmrSegmentResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Text Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResult Class : Text Property (OmrSegmentResult)

Gets the analysis result text string for a segment.

[Visual Basic]
Public ReadOnly Property Text As String
[C#]
public string Text {get;}
[C++]
public: __property string* get_Text();
[C++/CLI]
public:
property String^ Text {
   String^ get();
}

Remarks

This read-only property contains the analysis result text string for a segment.

For fields with a MarkScheme of OmrMarkScheme.MultiMark, the result text string will contain values for each bubble determined to be marked separated by the MultiMarkDelimiter string or character.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResult Class | OmrSegmentResult Members


%%PageItemTitle%%

OmrSegmentResultCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResultCollection Class

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResultCollection Class

A collection of OmrSegmentResult objects.

For a list of all members of this type, see OmrSegmentResultCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.OmrSegmentResultCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class OmrSegmentResultCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class OmrSegmentResultCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class OmrSegmentResultCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class OmrSegmentResultCollection : public CollectionBase

Remarks

This object represents zero-based array of OmrSegmentResult objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

OmrSegmentResultCollection Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResultCollection Class Members

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResultCollection Class

OmrSegmentResultCollection overview

Public Constructors

Public Constructor OmrSegmentResultCollection Constructor Initializes a new instance of this class.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the OMRSegmentResult at the given index.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResultCollection Constructor

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : OmrSegmentResultCollection Constructor (OmrSegmentResultCollection)

Initializes a new instance of this class.

[Visual Basic]
Public Function New()
[C#]
public OmrSegmentResultCollection();
[C++]
public: OmrSegmentResultCollection();
[C++/CLI]
public:
OmrSegmentResultCollection();

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Insert Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element that this method will add to the end of the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Add Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : Add Method (OmrSegmentResultCollection)

Adds an element to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As OmrSegmentResult _
) As Integer
[C#]
public int Add(
   OmrSegmentResult value
);
[C++]
public: int Add(
   OmrSegmentResult* value
)
[C++/CLI]
public:
int Add(
   OmrSegmentResult^ value
)

Parameters

value
The element that this method will add to the end of the collection.

Return Type

The zero-based index of the newly added element.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will make the collection one element longer, and then place the given element into the last index. It will not change the rest of the collection.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Insert Method


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : Contains Method (OmrSegmentResultCollection)

Determines whether the specified element is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As OmrSegmentResult _
) As Boolean
[C#]
public bool Contains(
   OmrSegmentResult value
);
[C++]
public: bool Contains(
   OmrSegmentResult* value
)
[C++/CLI]
public:
bool Contains(
   OmrSegmentResult^ value
)

Parameters

value
The element to search for in the collection.

Return Type

true if the given element is in the collection; false otherwise.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return true. If it cannot find a reference to it, this method will return false.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | IndexOf Method


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : CopyTo Method (OmrSegmentResultCollection)

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As OmrSegmentResult, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   OmrSegmentResult[] array,
   int index
);
[C++]
public: void CopyTo(
   OmrSegmentResult*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   OmrSegmentResult^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Contains Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : IndexOf Method (OmrSegmentResultCollection)

Determines whether the specified element is in the collection and returns its index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As OmrSegmentResult _
) As Integer
[C#]
public int IndexOf(
   OmrSegmentResult value
);
[C++]
public: int IndexOf(
   OmrSegmentResult* value
)
[C++/CLI]
public:
int IndexOf(
   OmrSegmentResult^ value
)

Parameters

value
The element to search for in the collection.

Return Type

If the element is present in the collection, this method will return the zero-based index of the first occurrence of it; otherwise this method will return -1.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will return its index. If it cannot find a reference to it, this method will return -1. If the element is present more than once in the collection, this method will return the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Contains Method


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Add Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : Insert Method (OmrSegmentResultCollection)

Inserts an element into the collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OmrSegmentResult _
)
[C#]
public void Insert(
   int index,
   OmrSegmentResult value
);
[C++]
public: void Insert(
   int index,
   OmrSegmentResult* value
)
[C++/CLI]
public:
void Insert(
   int index,
   OmrSegmentResult^ value
)

Parameters

index
The zero-based index where this method will place the element. If the value of this parameter is equal to the original number of elements in the collection, this method will perform the same operation as the Add method.
value
The element to search for in the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the element is null. This method will not add null to the collection.

Remarks

This method implements a standard collection operation. It will insert an element into the collection at the given index. It will move all elements (if any) that follow the newly added element back one place (their indices will be one greater than they were.)

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | Add Method


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | IndexOf Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
The element to remove from the collection.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : Remove Method (OmrSegmentResultCollection)

Removes an element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As OmrSegmentResult _
)
[C#]
public void Remove(
   OmrSegmentResult value
);
[C++]
public: void Remove(
   OmrSegmentResult* value
)
[C++/CLI]
public:
void Remove(
   OmrSegmentResult^ value
)

Parameters

value
The element to remove from the collection.

Exceptions

Exception | Description
!MISSING Scrap '__TITLE'! | Indicates that the specified element is not present in the collection.

Remarks

This method implements a standard collection operation. It searches the collection for a reference to the given element. If it finds a reference to it, it will delete it from the collection. If there are any elements following that one, this method will move them up (their indices will be one less than they were.)

If the specified element is present more than once in the collection, this method will remove the one with the lowest index.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members | IndexOf Method


%%PageItemTitle%% $$Properties$$

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResultCollection Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResultCollection Class

For a list of all members of this type, see OmrSegmentResultCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the OMRSegmentResult at the given index.

See Also

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Item Property

PegasusImaging.WinForms.FormFix3 Namespace > OmrSegmentResultCollection Class : Item Property (OmrSegmentResultCollection)

Gets or sets the OMRSegmentResult at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As OmrSegmentResult
[C#]
public OmrSegmentResult this[
   int index
]; {get; set;}
[C++]
public: __property OmrSegmentResult* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   OmrSegmentResult* value
);
[C++/CLI]
public:
 property OmrSegmentResult^ default [int] {
   OmrSegmentResult^ get(int index);
   void set (int index, OmrSegmentResult^ value);
}

Parameters

index
The zero-based index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

OmrSegmentResultCollection Class | OmrSegmentResultCollection Members


%%PageItemTitle%%

ReadChecksumEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksumEventArgs Class

PegasusImaging.WinForms.FormFix3 Namespace : ReadChecksumEventArgs Class

Arguments for a read checksum event.

For a list of all members of this type, see ReadChecksumEventArgs members.

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.FormFix3.ReadChecksumEventArgs

Syntax

[Visual Basic]
Public Class ReadChecksumEventArgs
   Inherits EventArgs
[C#]
public class ReadChecksumEventArgs : EventArgs
[C++]
public __gc class ReadChecksumEventArgs : public EventArgs
[C++/CLI]
public ref class ReadChecksumEventArgs : public EventArgs

Remarks

This class provides the communication between the object that issues a read checksum event and the object that handles the event.

None of the properties in this object convey information from the issuer of the event to the handler. Normally, the handler of the event will use the sender parameter of the event to determine what it needs to do.

An event handler for this event should set the Checksum property of this object.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

ReadChecksumEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

ReadChecksumEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksumEventArgs Class Members

PegasusImaging.WinForms.FormFix3 Namespace : ReadChecksumEventArgs Class

ReadChecksumEventArgs overview

Public Constructors

Public Constructor ReadChecksumEventArgs Constructor Initializes a new instance of this class.

Public Properties

Public Property Checksum Gets or sets the checksum that the event handler is returning back to the issuer of the event.

See Also

ReadChecksumEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

ReadChecksumEventArgs Class | ReadChecksumEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksumEventArgs Constructor

PegasusImaging.WinForms.FormFix3 Namespace > ReadChecksumEventArgs Class : ReadChecksumEventArgs Constructor (ReadChecksumEventArgs)

Initializes a new instance of this class.

[Visual Basic]
Public Function New()
[C#]
public ReadChecksumEventArgs();
[C++]
public: ReadChecksumEventArgs();
[C++/CLI]
public:
ReadChecksumEventArgs();

Requirements

Platforms: See Getting Started section

See Also

ReadChecksumEventArgs Class | ReadChecksumEventArgs Members


%%PageItemTitle%% $$Properties$$

ReadChecksumEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksumEventArgs Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : ReadChecksumEventArgs Class

For a list of all members of this type, see ReadChecksumEventArgs members.

Public Properties

Public Property Checksum Gets or sets the checksum that the event handler is returning back to the issuer of the event.

See Also

ReadChecksumEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

ReadChecksumEventArgs Class | ReadChecksumEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Checksum Property

PegasusImaging.WinForms.FormFix3 Namespace > ReadChecksumEventArgs Class : Checksum Property

Gets or sets the checksum that the event handler is returning back to the issuer of the event.

[Visual Basic]
Public Property Checksum As Integer
[C#]
public int Checksum {get; set;}
[C++]
public: __property int get_Checksum();
public: __property void set_Checksum(
   int value
);
[C++/CLI]
public:
property int Checksum {
   int get();
   void set (int value);
}

Remarks

The object that issues a read checksum event expects the event handler to place the checksum into this property. After the event handler completes, the event issuer will read this property to acquire the checksum.

Requirements

Platforms: See Getting Started section

See Also

ReadChecksumEventArgs Class | ReadChecksumEventArgs Members


%%PageItemTitle%%

ReadFormImageEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImageEventArgs Class

PegasusImaging.WinForms.FormFix3 Namespace : ReadFormImageEventArgs Class

Arguments for a read form image event.

For a list of all members of this type, see ReadFormImageEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.FormFix3.ReadFormImageEventArgs

Syntax

[Visual Basic]
Public Class ReadFormImageEventArgs
   Inherits EventArgs
[C#]
public class ReadFormImageEventArgs : EventArgs
[C++]
public __gc class ReadFormImageEventArgs : public EventArgs
[C++/CLI]
public ref class ReadFormImageEventArgs : public EventArgs

Remarks

This class provides the communication between the object that issued a read form event and the object that handles the event.

The Type property in this object conveys information from the issuer of the event to the handler. Normally, the handler of the event will use the sender parameter of the event to gain additional information about what it needs to do.

An event handler for this event should set the FormImage property of this object.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

ReadFormImageEventArgs Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

ReadFormImageEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImageEventArgs Class Members

PegasusImaging.WinForms.FormFix3 Namespace : ReadFormImageEventArgs Class

ReadFormImageEventArgs overview

Public Constructors

Public Constructor ReadFormImageEventArgs Constructor Initializes a new instance of this class.

Public Properties

Public Property FormImage | The T returned to the issuer of the event. Gets or sets an object which represents a form image.
Public Property Type | The type of the form image to read. Gets or sets a string which represents the type of the data item.

See Also

ReadFormImageEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImageEventArgs Constructor

PegasusImaging.WinForms.FormFix3 Namespace > ReadFormImageEventArgs Class : ReadFormImageEventArgs Constructor (ReadFormImageEventArgs)

Initializes a new instance of this class.

[Visual Basic]
Public Function New()
[C#]
public ReadFormImageEventArgs();
[C++]
public: ReadFormImageEventArgs();
[C++/CLI]
public:
ReadFormImageEventArgs();

Requirements

Platforms: See Getting Started section

See Also

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members


%%PageItemTitle%% $$Properties$$

ReadFormImageEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImageEventArgs Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : ReadFormImageEventArgs Class

For a list of all members of this type, see ReadFormImageEventArgs members.

Public Properties

Public Property FormImage | The T returned to the issuer of the event. Gets or sets an object which represents a form image.
Public Property Type | The type of the form image to read. Gets or sets a string which represents the type of the data item.

See Also

ReadFormImageEventArgs Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormImage Property

PegasusImaging.WinForms.FormFix3 Namespace > ReadFormImageEventArgs Class : FormImage Property (ReadFormImageEventArgs)

The T returned to the issuer of the event. Gets or sets an object which represents a form image.

[Visual Basic]
Public Property FormImage As FormImage
[C#]
public FormImage FormImage {get; set;}
[C++]
public: __property FormImage* get_FormImage();
public: __property void set_FormImage(
   FormImage* value
);
[C++/CLI]
public:
property FormImage^ FormImage {
   FormImage^ get();
   void set (FormImage^ value);
}

Remarks

This property holds the FormImage that the issuer requested. The object that handles this event must create a new image and assign it to the property before returning.

Requirements

Platforms: See Getting Started section

See Also

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members


%%PageItemTitle%%

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Type Property

PegasusImaging.WinForms.FormFix3 Namespace > ReadFormImageEventArgs Class : Type Property (ReadFormImageEventArgs)

The type of the form image to read. Gets or sets a string which represents the type of the data item.

[Visual Basic]
Public Property Type As String
[C#]
public string Type {get; set;}
[C++]
public: __property string* get_Type();
public: __property void set_Type(
   string* value
);
[C++/CLI]
public:
property String^ Type {
   String^ get();
   void set (String^ value);
}

Remarks

This property holds the type of the form image that the issuer wants to read. The object that issues the event will set this property and the object that handles the event must read it to choose which image to return.

Requirements

Platforms: See Getting Started section

See Also

ReadFormImageEventArgs Class | ReadFormImageEventArgs Members


%%PageItemTitle%%

RegistrationProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationProcessor Class

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationProcessor Class

An object that registers two images.

For a list of all members of this type, see RegistrationProcessor members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.RegistrationProcessor

Syntax

[Visual Basic]
Public Class RegistrationProcessor
[C#]
public class RegistrationProcessor
[C++]
public __gc class RegistrationProcessor
[C++/CLI]
public ref class RegistrationProcessor

Remarks

Instances of this class compare two images and return information you can use to align one to match the other. It does not identify the form and assumes that you are providing the correct model. If you do not know which model matches your image, you should use the IdentificationProcessor class instead of this one.

Unlike IdentificationProcessor.Identify, this class relies on the presence of specially-constructed registration marks in each corner of both images. Figure 1 below shows the approximate shape and location of the registration marks.

Figure 1 - Location of Registration Marks on a Form

Each of the four marks must be shaped like an "L", with the corner of the mark pointing toward the corner of the image. The straight parts of the mark must be parallel to the edges of the image. Each of the straight parts of the mark should be between 1/6 and 1/2 inch long and up to 1/12 inch thick. The marks must be less than two inches from the corner of each image.

Note: The registration algorithm use the resolution of the images (both the unknown image and the model), so you must set it to the correct value for best operation. Not every method of reading an image from a file will preserve the resolution and not all image editing tools will preserve the resolution. Registration will fail if the resolution of the image to register or the model is zero. If you see that error, you can look at the debug log (see Debug) for more information about exactly which image failed.

This class has two separate methods which perform roughly the same operation. RegisterToModel accepts a FormImage and a FormModel. RegisterToImage accepts two FormImage objects.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

RegistrationProcessor Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

RegistrationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationProcessor Class Members

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationProcessor Class

RegistrationProcessor overview

Public Constructors

Public Constructor RegistrationProcessor Constructor Initializes a new instance of the class.

Public Methods

Public Method Dispose | Disposes of resources that this object is holding
Public Method RegisterToImage | Compares two images and returns information which you can use to align them.
Public Method RegisterToModel | Compares an image and a FormModel and returns information which you can use to align them.

See Also

RegistrationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

RegistrationProcessor Class | RegistrationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A new instance of the FormFix class.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationProcessor Constructor

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationProcessor Class : RegistrationProcessor Constructor (RegistrationProcessor)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As FormFix _
)
[C#]
public RegistrationProcessor(
   FormFix workspace
);
[C++]
public: RegistrationProcessor(
   FormFix* workspace
)
[C++/CLI]
public:
RegistrationProcessor(
   FormFix^ workspace
)

Parameters

workspace
A new instance of the FormFix class.

Requirements

Platforms: See Getting Started section

See Also

RegistrationProcessor Class | RegistrationProcessor Members


%%PageItemTitle%%

RegistrationProcessor Class | RegistrationProcessor Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationProcessor Class : Dispose Method (RegistrationProcessor)

Disposes of resources that this object is holding

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

RegistrationProcessor Class | RegistrationProcessor Members


%%PageItemTitle%%

RegistrationProcessor Class | RegistrationProcessor Members | RegisterToImage Method | WriteDataItem Event | ReadFormImage Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

imageToRegister
The FormImage object containing one of the images that this method will compare. Normally, this is a filled form.
modelImage
The FormImage object that represents the form model.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegisterToImage Method

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationProcessor Class : RegisterToImage Method

Compares two images and returns information which you can use to align them.

[Visual Basic]
Public Function RegisterToImage( _
   ByVal imageToRegister As FormImage, _
   ByVal modelImage As FormImage _
) As RegistrationResult
[C#]
public RegistrationResult RegisterToImage(
   FormImage imageToRegister,
   FormImage modelImage
);
[C++]
public: RegistrationResult* RegisterToImage(
   FormImage* imageToRegister,
   FormImage* modelImage
)
[C++/CLI]
public:
RegistrationResult^ RegisterToImage(
   FormImage^ imageToRegister,
   FormImage^ modelImage
)

Parameters

imageToRegister
The FormImage object containing one of the images that this method will compare. Normally, this is a filled form.
modelImage
The FormImage object that represents the form model.

Return Type

A RegistrationResult object. You can use this object to align the imageToRegister to match the modelImage.

Remarks

This method compares two images and attempts to register them using special registration marks.

Each of the four marks must be shaped like an "L", with the corner of the mark pointing toward the corner of the image. The straight parts of the mark must be parallel to the edges of the image. Each of the straight parts of the mark should be between 1/6 and 1/2 inch long and up to 1/12 inch thick. The marks must be less than two inches from the corner of each image.

This method will not throw an exception if it is unable to register the images. Instead, it will set RegistrationResult.State to Failure.

Requirements

Platforms: See Getting Started section

See Also

RegistrationProcessor Class | RegistrationProcessor Members | RegisterToImage Method | WriteDataItem Event | ReadFormImage Event


%%PageItemTitle%%

RegistrationProcessor Class | RegistrationProcessor Members | RegisterToImage Method | WriteDataItem Event | ReadFormImage Event

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

imageToRegister
The FormImage object containing one of the images that this method will compare. Normally, this is a filled form.
model
The FormModel object that represents the form model.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegisterToModel Method

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationProcessor Class : RegisterToModel Method

Compares an image and a FormModel and returns information which you can use to align them.

[Visual Basic]
Public Function RegisterToModel( _
   ByVal imageToRegister As FormImage, _
   ByVal model As FormModel _
) As RegistrationResult
[C#]
public RegistrationResult RegisterToModel(
   FormImage imageToRegister,
   FormModel model
);
[C++]
public: RegistrationResult* RegisterToModel(
   FormImage* imageToRegister,
   FormModel* model
)
[C++/CLI]
public:
RegistrationResult^ RegisterToModel(
   FormImage^ imageToRegister,
   FormModel^ model
)

Parameters

imageToRegister
The FormImage object containing one of the images that this method will compare. Normally, this is a filled form.
model
The FormModel object that represents the form model.

Return Type

A RegistrationResult object. You can use this object to align the imageToRegister to match the model.

Remarks

This method compares two images and attempts to register them by using special registration marks.

Each of the four marks must be shaped like an "L", with the corner of the mark pointing toward the corner of the image. The straight parts of the mark must be parallel to the edges of the image. Each of the straight parts of the mark should be between 1/6 and 1/2 inch long and up to 1/12 inch thick. The marks must be less than two inches from the corner of each image.

If you cannot represent the model image using a FormModel object or if you will only register a single image to this model, you should consider using the RegisterToImage method.

This method will not throw an exception if it is unable to register the images. Instead, it will set RegistrationResult.State to Failure.

Requirements

Platforms: See Getting Started section

See Also

RegistrationProcessor Class | RegistrationProcessor Members | RegisterToImage Method | WriteDataItem Event | ReadFormImage Event


%%PageItemTitle%%

RegistrationResult Members | PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Class

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationResult Class (PegasusImaging.WinForms.FormFix3)

Holds information allowing you to align an image to a model image.

For a list of all members of this type, see RegistrationResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.RegistrationResult

Syntax

[Visual Basic]
Public Class RegistrationResult
[C#]
public class RegistrationResult
[C++]
public __gc class RegistrationResult
[C++/CLI]
public ref class RegistrationResult

Remarks

This class represents registration information for aligning an image to a model image. The IdentificationProcessor.Identify, RegistrationProcessor.RegisterToModel, and RegistrationProcessor.RegisterToImage methods create objects of this type.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

RegistrationResult Members | PegasusImaging.WinForms.FormFix3 Namespace

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Class Members

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationResult Class (PegasusImaging.WinForms.FormFix3)

RegistrationResult overview

Public Constructors

Public Constructor RegistrationResult Constructor Initializes a new instance of the class.

Public Properties

Public Property State Gets the state of the registration operation.

Public Methods

Public Method AlignImage | Aligns an image using the registration information contained within this object.
Public Method Dispose | Disposes of resources that this object is holding

See Also

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

RegistrationResult Class | RegistrationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
A new instance of the FormFix class.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Constructor

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationResult Class : RegistrationResult Constructor (RegistrationResult)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As FormFix _
)
[C#]
public RegistrationResult(
   FormFix workspace
);
[C++]
public: RegistrationResult(
   FormFix* workspace
)
[C++/CLI]
public:
RegistrationResult(
   FormFix^ workspace
)

Parameters

workspace
A new instance of the FormFix class.

Requirements

Platforms: See Getting Started section

See Also

RegistrationResult Class | RegistrationResult Members


%%PageItemTitle%%

RegistrationResult Class | RegistrationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

unalignedImage
The original image that this method will align. This method will not change this image, but will make a copy, align the copy, and return it.
See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

AlignImage Method

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationResult Class : AlignImage Method

Aligns an image using the registration information contained within this object.

[Visual Basic]
Public Function AlignImage( _
   ByVal unalignedImage As FormImage _
) As FormImage
[C#]
public FormImage AlignImage(
   FormImage unalignedImage
);
[C++]
public: FormImage* AlignImage(
   FormImage* unalignedImage
)
[C++/CLI]
public:
FormImage^ AlignImage(
   FormImage^ unalignedImage
)

Parameters

unalignedImage
The original image that this method will align. This method will not change this image, but will make a copy, align the copy, and return it.

Return Type

A new image that is aligned to match the reference image.

Remarks

This method accepts an input image and returns an aligned copy of that image. The new image will be equal in size to the model image, which may have a different size than unalignedImage. This method will not change unalignedImage.

Requirements

Platforms: See Getting Started section

See Also

RegistrationResult Class | RegistrationResult Members


%%PageItemTitle%%

RegistrationResult Class | RegistrationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationResult Class : Dispose Method (RegistrationResult)

Disposes of resources that this object is holding

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

Remarks

This method is an implementation of the IDisposable.Dispose method. You should call it whenever you are finished using the image to avoid wasting RAM. If you are concerned that you may not be calling it correctly, you should turn on the debug log and look for entries such as, "Object is being finalized, but should have been Disposed." or "FormFix: Object was not freed and has # references." Please note that FormFix will not place the latter message into the debug log until your application exits. If you call this method too early, you will receive a DisposeException when you try to reuse the object.

Requirements

Platforms: See Getting Started section

See Also

RegistrationResult Class | RegistrationResult Members


%%PageItemTitle%% $$Properties$$

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationResult Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see RegistrationResult members.

Public Properties

Public Property State Gets the state of the registration operation.

See Also

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

RegistrationResult Class | RegistrationResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

State Property

PegasusImaging.WinForms.FormFix3 Namespace > RegistrationResult Class : State Property (RegistrationResult)

Gets the state of the registration operation.

[Visual Basic]
Public ReadOnly Property State As RegistrationState
[C#]
public RegistrationState State {get;}
[C++]
public: __property RegistrationState get_State();
[C++/CLI]
public:
property RegistrationState State {
   RegistrationState get();
}

Remarks

This property represents the state of the registration operation which returned this object. Normally, this property will be equal to Success, but it will be Failure if the registration operation could not register the image to the model.

Requirements

Platforms: See Getting Started section

See Also

RegistrationResult Class | RegistrationResult Members


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutMethod Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : DropOutMethod Enumeration (PegasusImaging.WinForms.FormFix3)

The method used to drop out a form.

Members

Member | Description
Clip | Clips the field out of the filled image without change, instead of dropping the form.
DropOut | Clips the field out of the filled image and drops out the form.

Remarks

This enumeration represents the major approaches that the DropOutProcessor object can take to create a field image.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ErrorLevel Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : ErrorLevel Enumeration (PegasusImaging.WinForms.FormFix3)

The error level of items to place into the debug log.

Members

Member | Description
Production | Place minimal information into the debug log file.
Development | Place information into the debug log file that is useful during normal development using this toolkit.
Detailed | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.

Remarks

This enumeration allows you to specify the amount of detail to place into the debug log file.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ErrorNumber Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : ErrorNumber Enumeration (PegasusImaging.WinForms.FormFix3)

A specific type of error.

Members

Member | Description
NullArgument | An argument was NULL.
ParmRange | An argument was out of range.
NullImage | An image was NULL.
BadEnumeration | An enumeration had a bad value.
OutOfMemory | Out of memory.
FrameworkException | An error occurred during an event.
ImageType | Unsupported image type.
OmrNoBubblesDetected | No OMR bubbles were found.
OmrMinimumConfidenceNotAttained | The confidence did not exceed the minimum value.
OmrNoCoordinateData | No coordinate data is available.
OmrNoSegmentCountData | No segment count data is available.
OmrNoBubbleCountData | No bubble count data is available.
OmrInvalidImageData | The image data is invalid.
OmrInvalidImageBitDepth | The image has the wrong bit depth.
OmrInvalidFieldHeight | The field has an invalid height.
OmrInvalidFieldWidth | The field has an invalid width.
OmrBubbleGridPerimeter | There is a problem with the perimeter of the bubble grid.
RegNoFormModelProvided | No FormModel object was provided.
License | Licensing error.
ImageResolution | The image resolution is invalid.
ComponentInitialization | The component encountered problems while initializing.
NotInitialized | An operation is being requested before the object is initialized or after it has been disposed.
UnableToOpenFile | An error occurred while opening a file.
Validation | An error occurred while validating operation of a user-supplied callback/event.
ImportImage | An error occurred while attempting to import an image.
ExportImage | An error occurred while attempting to export an image.
EventHandler | An event is either not being handled or is being handled by multiple, separate methods.
UnsupportedStreamVersion | The stream was created by a more recent version of the product than this build.
CorruptStream | The stream is corrupt and cannot be parsed.
Internal | An internal error occurred.
Unknown | An unknown error occurred.
NotImplemented | This operation is not implemented. This should not occur in a release product.
InvalidPointerParameter | A pointer was NULL.
ComError | A COM error occurred.
BadCollectionIndex | An invalid index was provided for an array or list.
UnsupportedVariantType | An unsupported type of variant was provided.
EventHandlerNoImageReturned | An event handler did not provide an image as requested.

Remarks

This enumeration contains values that indicate specifically which error occurred.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace | EvaluationMode Property

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.FormFix3)

The evaluation mode of the component.

Members

Member | Description
Automatic | Automatic evaluation mode. When possible, this component will automatically detect that it is running without a user interface and switch to another evaluation mode. Otherwise, it will display the evaluation mode dialog box.
Timeout | Timeout evaluation mode. When running in timeout evaluation mode, this component will timeout after 5 minutes of operation. This is the appropriate evaluation mode for applications that have no user interface.

Remarks

To simplify your evaluation of this component, Pegasus Imaging Corporation has implemented an evaluation mode. Normally, this mode will display a dialog box reminding you that you are using evaluation mode. In certain environments with no user interface, such as services, displaying a dialog box will cause the application to stop and you must change the evaluation mode to avoid that problem.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace | EvaluationMode Property


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationOrientation Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationOrientation Enumeration

The orientation of a form comparison.

Members

Member | Description
NoRotation | The IdentificationProcessor did not rotate the image before it compared it to the model.
Rotate90 | The IdentificationProcessor rotated the image clockwise 90 degrees before it compared it to the model.
Rotate180 | The IdentificationProcessor rotated the image clockwise 180 degrees before it compared it to the model.
Rotate270 | The IdentificationProcessor rotated the image clockwise 270 degrees before it compared it to the model.

Remarks

This enumeration represents the orientation of a single form comparison.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationState Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationState Enumeration

The final state of an identification process.

Members

Member | Description
MatchFound | The identification process found a match.
NoMatchFound | The identification process failed to find a match.
MultipleMatchesFound | The identification process found multiple matches.

Remarks

This enumeration represents the final state of an identification process.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace | LicenseEdition Property

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

LicenseEditionType Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : LicenseEditionType Enumeration

The edition of the component.

Members

Member | Description
Standard | The standard version of the component.
Professional | The professional edition of the component.

Remarks

This component can run in different modes, depending on which edition you purchased.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace | LicenseEdition Property


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrAnalysisComparisonMethod Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : OmrAnalysisComparisonMethod Enumeration

The OMR analysis image comparison processing method desired.

Members

Member | Description
None | No comparison analysis processing performed.
CompareClipToFormModel | Perform comparison analysis processing on the clipped image specified for OMR analysis. The FormModel property and the OriginOfClip property must be set for this method option.
CompareFullImageToFormModel | Perform comparison analysis processing on the full image specified for OMR analysis. The FormModel property must be set for this method option.

Remarks

This enumeration represents the OMR analysis image comparison processing method desired. Requesting comparison analysis will in most cases improve recognitiona accuracy at a moderate cost to speed. Note that comparison analysis requires the FormModel property be set and for certain comparisons the OriginOfClip property to be set.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleShape Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleShape Enumeration

The geometric shape of an OMR field's bubble(s).

Members

Member | Description
Circle | The bubble(s) in the OMR field are circular.
Rectangle | The bubble(s) in the OMR field are rectangular.
OpenRectangle | The bubble(s) in the OMR field are an open rectangle.

Remarks

This enumeration represents the geometric shape of an OMR field's bubble(s).

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrMarkScheme Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : OmrMarkScheme Enumeration

The OMR field's bubble mark scheme.

Members

Member | Description
SingleMark | A maximum of one bubble per segment may be marked.
MultiMark | More than one bubble per segment may be marked.

Remarks

This enumeration represents the OMR field's bubble mark scheme indicating the maximum expected number of marked bubbles per segment.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrMultiSegmentReadDirection Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : OmrMultiSegmentReadDirection Enumeration

The multi-segment read direction for assembling a field summation of segment analysis results

Members

Member | Description
Normal | Multi-segment fields with an OmrOrientation of HorizontalSegments are read top to bottom and multi-segment fields with an OmrOrientation of VerticalSegments are read left to right.
Reversed | Multi-segment fields with an OmrOrientation of HorizontalSegments are read bottom to top and multi-segment fields with an OmrOrientation of VerticalSegments are read right to left.

Remarks

This enumeration represents the OMR multi-segment read direction and specifies the direction in which individual segment analysis results are read when building a sum result for the field

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrOrientation Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : OmrOrientation Enumeration

The orientation of an OMR field's segment(s) with respect to the top of a form image.

Members

Member | Description
HorizontalSegments | The segment(s) in the OMR field are parallel to the top of the form image.
VerticalSegments | The segment(s) in the OMR field are perpendicular to the top of the form image.

Remarks

This enumeration represents the orientation of an OMR field's segment(s) with respect to the top of a form image.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace | RegistrationResult Class | RegistrationProcessor.RegisterToModel | RegistrationProcessor.RegisterToImage | IdentificationProcessor.Identify

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationState Enumeration

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationState Enumeration

The state of a registration operation.

Members

Member | Description
Success | The registration operation succeeded and you can use the RegistrationResult object to align your image to the model.
Failure | The registration operation failed and you cannot use the RegistrationResult object to align your image to the model.

Remarks

This enumeration represents the state of a registration operation. When a registration operation fails, this component will not throw an exception. Instead, it will return a RegistrationResult object with RegistrationResult.State equal to RegistrationState.Failed.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace | RegistrationResult Class | RegistrationProcessor.RegisterToModel | RegistrationProcessor.RegisterToImage | IdentificationProcessor.Identify


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
The object that issued the event to read or write a data item.
e
Arguments for the read and write events. This object has properties for the data that the object that raises the event and the code that handles the event pass to each other.
See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DataItemEventHandler Delegate

PegasusImaging.WinForms.FormFix3 Namespace : DataItemEventHandler Delegate

A delegate for events that read or write data items in persistent storage.

[Visual Basic]
Public Delegate Sub DataItemEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataItemEventArgs _
)
[C#]
public delegate void DataItemEventHandler(
   object sender,
   DataItemEventArgs e
);
[C++]
public: __gc __delegate void DataItemEventHandler(
   Object* sender,
   DataItemEventArgs* e
)
[C++/CLI]
public delegate void DataItemEventHandler(
   Object^ sender,
   DataItemEventArgs^ e
)

Parameters

sender
The object that issued the event to read or write a data item.
e
Arguments for the read and write events. This object has properties for the data that the object that raises the event and the code that handles the event pass to each other.

Remarks

This is the delegate for events that read or write data items in persistent storage. The IdentificationProcessor and FormModel classes uses this delegate whenever they need to read a data item from persistent storage and when they need to write a data item to persistent storage.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
The object that issued the event to read a checksum.
e
Arguments for the read event. This object has a property where the event handler must store the checksum.
See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadChecksumEventHandler Delegate

PegasusImaging.WinForms.FormFix3 Namespace : ReadChecksumEventHandler Delegate

A delegate for events that return a checksum of data in persistent storage.

[Visual Basic]
Public Delegate Sub ReadChecksumEventHandler( _
   ByVal sender As Object, _
   ByVal e As ReadChecksumEventArgs _
)
[C#]
public delegate void ReadChecksumEventHandler(
   object sender,
   ReadChecksumEventArgs e
);
[C++]
public: __gc __delegate void ReadChecksumEventHandler(
   Object* sender,
   ReadChecksumEventArgs* e
)
[C++/CLI]
public delegate void ReadChecksumEventHandler(
   Object^ sender,
   ReadChecksumEventArgs^ e
)

Parameters

sender
The object that issued the event to read a checksum.
e
Arguments for the read event. This object has a property where the event handler must store the checksum.

Remarks

This is the delegate for events that read checksum for data in persistent storage. The IdentificationProcessor and FormModel classes uses this delegate whenever they need to know if some relevant aspect of a form or form set has changed.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.FormFix3 Namespace

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
The object that issued the event to read a form image.
e
Arguments for the read event. This object contains the type of the image to read and has a property where the event handler must store the form image.
See Also Requirements Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

ReadFormImageEventHandler Delegate

PegasusImaging.WinForms.FormFix3 Namespace : ReadFormImageEventHandler Delegate

A delegate for events that read a form image from persistent storage.

[Visual Basic]
Public Delegate Sub ReadFormImageEventHandler( _
   ByVal sender As Object, _
   ByVal e As ReadFormImageEventArgs _
)
[C#]
public delegate void ReadFormImageEventHandler(
   object sender,
   ReadFormImageEventArgs e
);
[C++]
public: __gc __delegate void ReadFormImageEventHandler(
   Object* sender,
   ReadFormImageEventArgs* e
)
[C++/CLI]
public delegate void ReadFormImageEventHandler(
   Object^ sender,
   ReadFormImageEventArgs^ e
)

Parameters

sender
The object that issued the event to read a form image.
e
Arguments for the read event. This object contains the type of the image to read and has a property where the event handler must store the form image.

Remarks

This is the delegate for events that read a form image. The FormModel class uses this delegate whenever it needs to look at the model image for the form.

Requirements

Namespace: PegasusImaging.WinForms.FormFix3

Assembly: PegasusImaging.WinForms.FormFix3 (in PegasusImaging.WinForms.FormFix3.dll)

See Also

PegasusImaging.WinForms.FormFix3 Namespace


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Empty Index Entry

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Topic Not Found

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


Glossary Item Box

PegasusImaging.WinForms.FormFix3

 Send comments on this topic.

Define a Form for Recognition

Form Identification

A "form" is a data structure that describes an area (position and size) of an image, the preprocessing actions to perform on the area and the description of one or more fields or segments. FormFix can manage multiple forms concurrently through the IdentificationProcessor object.

A "field" is a data structure that describes an area (position and size), the preprocessing actions to perform on the area as well as the type of analysis to perform on it (OCR, OMR, ICR, Markbox or Image as set by FieldType). Fields are referred to by either name or index. When a field is created (by AddFormField) it is added to the current form. Only one field is addressed at a time; it is considered the current field and the current field can be changed by SelectFormField or SelectFormFieldIndex.

A "form set" is a collection of zero or more forms. The FormFix component will have explicit support for form sets in order to support identification of a form within the set.

Each form must include at least one field. A form typically contains many fields and they can be of different types.

A form may be defined programmatically by specifying the fields, their positions and attributes in the application code. The data that constitutes a form may then be saved to disk as a Form Definition Language (FDL) file which are then parsed by the FormDirector component.


%%Variable%%

Glossary Item Box

PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


%%phrase%%

PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.FormFix3 |


$$GETTING_STARTED$$ - %%projecttitle%%

PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Getting Started

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.


$$INTRODUCTION$$ - %%projecttitle%%

PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Introduction

© 1997 - 2006, Pegasus Imaging Corporation, All Rights Reserved.


%%PageItemTitle%% $$Methods$$

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : DisposeException Class

For a list of all members of this type, see DisposeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Properties$$

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DisposeException Class Properties

PegasusImaging.WinForms.FormFix3 Namespace : DisposeException Class

For a list of all members of this type, see DisposeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from FormFixException) | Gets the last error from the FormFix component.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

DisposeException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

DropOutProcessor Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : DropOutProcessor Class

For a list of all members of this type, see DropOutProcessor members.

Public Methods

Public Method CreateImageOfField | Creates and returns a dropped-out image for a field.
Public Method Dispose | Deletes the image contained within this object.
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

See Also

DropOutProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Events$$

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Class Events

PegasusImaging.WinForms.FormFix3 Namespace : FormFix Class

For a list of all members of this type, see FormFix members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFix Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : FormFix Class

For a list of all members of this type, see FormFix members.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Clean up any resources being used. Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

FormFix Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormFixException Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : FormFixException Class

For a list of all members of this type, see FormFixException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FormFixException Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormImage Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : FormImage Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see FormImage members.

Public Methods

Public Method Dispose | Deletes the image contained within this object.
Public Method static (Shared in Visual Basic) FromBitmap | Creates a new object and places a copy of the given image into it.
Public Method static (Shared in Visual Basic) FromHbitmap | Creates a new object and places a copy of the given image into it.
Public Method static (Shared in Visual Basic) FromHdib | Overloaded. Creates a new object and places a copy of the given hdib into it.
Public Method ToBitmap | Returns a new Bitmap object containing a copy of the image in this object.
Public Method ToHbitmap | Returns a new WIN32 HBITMAP handle containing a copy of the image in this object.
Public Method ToHdib | Returns a new WIN32 HDIB handle containing a copy of the image in this object.

See Also

FormImage Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModel Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : FormModel Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see FormModel members.

Public Methods

Public Method ConstructDataItems | Causes the object to create as many of its data items as possible.
Public Method ConstructTestDataItems | Creates test data items in preparation for a more extensive test.
Public Method Dispose | Disposes of resources that this object is holding
Public Method ReleaseCachedData | Releases any cached data that this object holds in RAM.
Public Method TestReadChecksumEvent | Tests a ReadChecksum event.
Public Method TestReadDataItemEvent | Tests a ReadDataItem event.
Public Method TestReadFormImageEvent | Tests a ReadFormImage event.
Public Method TestWriteDataItemEvent | Tests a WriteDataItem event.
Public Method VerifyTestDataItems | Tests data items that you created using ConstructTestDataItems.

See Also

FormModel Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

FormModelCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : FormModelCollection Class

For a list of all members of this type, see FormModelCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

FormModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationMatchCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationMatchCollection Class

For a list of all members of this type, see IdentificationMatchCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

IdentificationMatchCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationProcessor Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationProcessor Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see IdentificationProcessor members.

Public Methods

Public Method ConstructDataItems | Causes the object to create as many of its data items as possible.
Public Method ConstructTestDataItems | Creates test data items in preparation for a more extensive test.
Public Method Dispose | Disposes of unneeded resources.
Public Method GetSimilarFormModels | Gets a list of the forms that are similar to the given one.
Public Method Identify | Identifies a form.
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method TestReadChecksumEvent | Tests a ReadChecksum event.
Public Method TestReadDataItemEvent | Tests a ReadDataItem event.
Public Method TestWriteDataItemEvent | Tests a WriteDataItem event.
Public Method VerifyTestDataItems | Tests data items that you created using ConstructTestDataItems.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

See Also

IdentificationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IdentificationResult Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : IdentificationResult Class

For a list of all members of this type, see IdentificationResult members.

Public Methods

Public Method Dispose | Disposes of unneeded resources.
Public Method GetConfidence | Retrieve the confidence of a specific match.
Public Method GetOtherRegistrationResult | Retrieve the registration information for a specific match.

See Also

IdentificationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

IntegerCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : IntegerCollection Class

For a list of all members of this type, see IntegerCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

IntegerCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : Licensing Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see Licensing members.

Public Methods

Public Method UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method UnlockWeb | Unlocks the component for use in web servers.

See Also

Licensing Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.FormFix3 Send comments on this topic.

LicenseEditionChoice Property

PegasusImaging.WinForms.FormFix3 Namespace > Licensing Class : LicenseEditionChoice Property

Gets or sets the license edition of the component.

[Visual Basic]
Public Property LicenseEditionChoice As LicenseEditionType
[C#]
public LicenseEditionType LicenseEditionChoice {get; set;}
[C++]
public: __property LicenseEditionType get_LicenseEditionChoice();
public: __property void set_LicenseEditionChoice(
   LicenseEditionType value
);
[C++/CLI]
public:
property LicenseEditionType LicenseEditionChoice {
   LicenseEditionType get();
   void set (LicenseEditionType value);
}

Remarks

The default value is generally the highest edition which is set during evaluation mode.

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%% $$Methods$$

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleModelCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleModelCollection Class

For a list of all members of this type, see OmrBubbleModelCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrBubbleModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrBubbleResultCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : OmrBubbleResultCollection Class

For a list of all members of this type, see OmrBubbleResultCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrBubbleResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrProcessor Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : OmrProcessor Class

For a list of all members of this type, see OmrProcessor members.

Public Methods

Public Method AnalyzeField | Perform OMR analysis on a field.
Public Method Dispose | Disposes of resources that this object is holding
Public Method ReadFromStream | Reads a specially-formatted stream and places the values into properties of this object.
Public Method WriteToStream | Writes some properties of this object to a specially-formatted stream.

See Also

OmrProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentModelCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentModelCollection Class

For a list of all members of this type, see OmrSegmentModelCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrSegmentModelCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

OmrSegmentResultCollection Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : OmrSegmentResultCollection Class

For a list of all members of this type, see OmrSegmentResultCollection members.

Public Methods

Public Method Add | Adds an element to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines whether the specified element is in the collection.
Public Method CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines whether the specified element is in the collection and returns its index.
Public Method Insert | Inserts an element into the collection.
Public Method Remove | Removes an element from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

OmrSegmentResultCollection Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

RegistrationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationProcessor Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationProcessor Class

For a list of all members of this type, see RegistrationProcessor members.

Public Methods

Public Method Dispose | Disposes of resources that this object is holding
Public Method RegisterToImage | Compares two images and returns information which you can use to align them.
Public Method RegisterToModel | Compares an image and a FormModel and returns information which you can use to align them.

See Also

RegistrationProcessor Class | PegasusImaging.WinForms.FormFix3 Namespace


%%PageItemTitle%% $$Methods$$

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

RegistrationResult Class Methods

PegasusImaging.WinForms.FormFix3 Namespace : RegistrationResult Class (PegasusImaging.WinForms.FormFix3)

For a list of all members of this type, see RegistrationResult members.

Public Methods

Public Method AlignImage | Aligns an image using the registration information contained within this object.
Public Method Dispose | Disposes of resources that this object is holding

See Also

RegistrationResult Class | PegasusImaging.WinForms.FormFix3 Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

PegasusImaging.WinForms.FormFix3 Assembly

See Also PegasusImaging.WinForms.FormFix3 Send comments on this topic.

PegasusImaging.WinForms.FormFix3 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.FormFix3.DropOutProcessor
PegasusImaging.WinForms.FormFix3.DropOutResult
PegasusImaging.WinForms.FormFix3.FormImage
PegasusImaging.WinForms.FormFix3.FormModel
PegasusImaging.WinForms.FormFix3.IdentificationMatch
PegasusImaging.WinForms.FormFix3.IdentificationProcessor
PegasusImaging.WinForms.FormFix3.IdentificationResult
PegasusImaging.WinForms.FormFix3.Licensing
PegasusImaging.WinForms.FormFix3.OmrBubbleModel
PegasusImaging.WinForms.FormFix3.OmrBubbleResult
PegasusImaging.WinForms.FormFix3.OmrFieldResult
PegasusImaging.WinForms.FormFix3.OmrProcessor
PegasusImaging.WinForms.FormFix3.OmrSegmentModel
PegasusImaging.WinForms.FormFix3.OmrSegmentResult
PegasusImaging.WinForms.FormFix3.RegistrationProcessor
PegasusImaging.WinForms.FormFix3.RegistrationResult
System.Collections.CollectionBase
PegasusImaging.WinForms.FormFix3.FormModelCollection
PegasusImaging.WinForms.FormFix3.IdentificationMatchCollection
PegasusImaging.WinForms.FormFix3.IntegerCollection
PegasusImaging.WinForms.FormFix3.OmrBubbleModelCollection
PegasusImaging.WinForms.FormFix3.OmrBubbleResultCollection
PegasusImaging.WinForms.FormFix3.OmrSegmentModelCollection
PegasusImaging.WinForms.FormFix3.OmrSegmentResultCollection
System.EventArgs
PegasusImaging.WinForms.FormFix3.DataItemEventArgs
PegasusImaging.WinForms.FormFix3.ReadChecksumEventArgs
PegasusImaging.WinForms.FormFix3.ReadFormImageEventArgs
System.Exception
System.ApplicationException
PegasusImaging.WinForms.FormFix3.FormFixException
PegasusImaging.WinForms.FormFix3.DisposeException
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.FormFix3.FormFix

See Also

PegasusImaging.WinForms.FormFix3 Namespace | PegasusImaging.WinForms.FormFix3 Assembly