%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java User Assistance Dashboard
Send Feedback |

Glossary Item Box

Welcome

  • Overview
  • About ImageGear for Java

Installing & Licensing

  • System Requirements
  • Installing ImageGear for Java
  • Directory Structure
  • Licensing and Distributing ImageGear for Java
  • Software License Agreement
  • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • Getting Started
  • Using ImageGear for Java
  • ImageGear Supported File Formats Reference
  • API Reference Guide

Additional Resources

  • Online Demo & Video Tutorial
  • White papers & Case Studies
  • FAQs
  • Customer Support

Provide Feedback

  • Email us
  • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java User Guide
Send Feedback |

Glossary Item Box

This online help user guide is categorized into:

  • Introduction
  • Installing and Distributing ImageGear
  • Getting Started
  • Using ImageGear for Java
  • ImageGear Imaging Formats Reference
  • Software License Agreement
  • Software Support and Maintenance Policy

See ImageGear Java API Reference for information about the ImageGear for Java public API.


%%ItemTitle%%

ImageGear for Java | Accusoft
Introduction
Send Feedback |
ImageGear for Java User Guide > Introduction

Glossary Item Box

This section contains the following information:

  • About ImageGear for Java
  • Overview
  • In This Guide
  • Supported Formats and Compressions
  • ImageGear for Java JAR Files
  • ImageGear for Java Packages
  • About Customer Support
  • Copyright


%%ItemTitle%%

ImageGear for Java | Accusoft
About ImageGear for Java
Send Feedback |
ImageGear for Java User Guide > Introduction > About ImageGear for Java

Glossary Item Box

ImageGear® for Java is the most advanced way to create, control, and deliver more secure, high-quality imaging applications. Using ImageGear, you can easily add powerful imaging capability to your applications. ImageGear supports all of the most commonly used graphics file formats and many more, providing complete compatibility when developing Java solutions across multiple platforms.

ImageGear for Java features include:

  • Reading and writing 100+ file formats
  • File format conversion
  • Multi-page images support
  • In-memory access to image pixel data
  • Access to image metadata
  • Export to bitmap for display and printing
  • Comprehensive image processing
  • Analysis/correction/manipulation of computer-generated images
  • Color processing: reduction/promotion/dithering
  • ICC color profiles support
  • Thumbnail read and write support
  • Alpha channels support
  • Pantone channels support
  • ROI processing
  • Annotations support
  • Annotations marks statistics gathered by the area and linear measurements
  • Medical/DICOM format support
  • DICOM image processing
  • DICOM 2009 metadata support
  • Unlimited product evaluation licensing

The toolkit has native support for all color spaces and bit depths, provides comprehensive handling of color channels, and supports the following bit depths internally: 1, 4, 8-bit gray level, 8i, 9-16-bit gray level, 24, 32, 48, 64. The toolkit can also read all the additional bit depths possible for the file formats ImageGear supports.

With ImageGear for Java, you are assured of the high quality and performance you expect from Accusoft, the industry leader in image processing toolkits.


%%ItemTitle%%

ImageGear for Java | Accusoft
Overview
Send Feedback |
ImageGear for Java User Guide > Introduction > Overview

Glossary Item Box

ImageGear Java provides the most comprehensive set of imaging features available. It provides a complete set of methods and fields focused on the following features:

Show All Show All
Hide All Hide All

  • Show Image Loading and Saving

    IGJava supports over 50 raster file formats. See the ImageGear Imaging Formats Reference for more information.

  • Show Image Processing

    IGJava has the following Image Processing functionality, among others:

    • Region of interest (ROI) support for basic rectangles as well as ellipses, polygons and other shapes.
    • The most complete color space support, including color space conversions, color separation and combination, support for any color space found in any of the 50+ supported formats, and support for color spaces such as CMYK, without conversion to RGB, for perfect fidelity
    • Powerful color reduction for maximum quality and minimum size
    • Encryption and decryption for entire image or any part of image
    • Matrix convolutions of any size with pre-defined or user-supplied matrix values

    See com.accusoft.imagegear.processing and Using the com.accusoft.imagegear.processing Package for more information.

  • Show Pixel Access

    ImageGear is equipped with several methods that will allow you to get and set the values of individual pixels, rows or columns of pixels, and rectangular groups of pixels. This family of methods is referred to as the "pixel access" methods. For each kind of pixel access, you can obtain (get) the value(s) of a pixel or group of pixels, or set the value(s) of a pixel or group of pixels.

  • Show Compression

    ImageGear supports all industry-standard compression algorithms. See the ImageGear Imaging Formats Reference for more information.

  • Show Native CMYK Support for All Color Spaces and Bit Depths

    • Images stored in CMYK format can be loaded into ImageGear without being converted to RGB, ensuring the original color information is maintained with perfect fidelity
    • Images can be saved to formats that support CMYK color space
    • Images stored in CMYK can be optionally converted to RGB when loaded (default for STD), or converted to RGB at any time after loading
    • Basic image processing, image access, display and other functions work with native CMYK image data
    • CMYK images can be color separated or converted to several other color spaces
      CMYK is only supported in Windows.

  • Show ROI Processing

    • Specify rectangular ROI for nearly all image processing functions
    • Specify arbitrary ROI for most image processing functions (i.e., ellipse, polygon and freehand)
    • Create 1-bit mask image for identifying which pixels to include/exclude from image processing algorithms

    See ImGearROI class, ImGearROIMask class, and ImGearROIRectangle class for more information.


%%ItemTitle%%

ImageGear for Java | Accusoft
In This Guide
Send Feedback |
ImageGear for Java User Guide > Introduction > In This Guide

Glossary Item Box

This online help is organized as follows:

  • ImageGear for Java User Guide
    • The Introduction includes information about ImageGear features, ImageGear package structure, plus information about Accusoft's Product Support Services and descriptions of Accusoft's other products.
    • The Installing and Distributing ImageGear chapter explains how to install ImageGear, and how to develop, deploy, and distribute your ImageGear imaging application using ImageGear licensing functionality and data sources.
    • The Getting Started chapter demonstrates how to incorporate ImageGear's imaging capabilities into your own applications by using the sample source imaging programs provided with your toolkit. It also provides you with information about ImageGear for Java Samples.
    • The UsingImageGear chapter explains how to call an ImageGear function, including setting up the variables and structures passed as arguments, and details which functions to use to perform a variety of imaging tasks.
    • The ImageGear Imaging Formats Reference chapter provides detailed information on each of the file formats supported by ImageGear for Java, plus "at-a-glance" tables that describe the features supported by each format, and provides guidelines on which formats may be most suitable when speed, storage space, or similar considerations are important.
    • Software License Agreement
    • Software Support and Maintenance Policy

The ImageGear API Reference provides detailed information about each class, interface, field, method, and enumeration of the following ImageGear Packages:

  • com.accusoft.imagegear.core
  • com.accusoft.imagegear.formats
  • com.accusoft.imagegear.formats.dicom
  • com.accusoft.imagegear.formats.exif
  • com.accusoft.imagegear.formats.iptc
  • com.accusoft.imagegear.formats.jpg
  • com.accusoft.imagegear.formats.tif
  • com.accusoft.imagegear.formats.xmp
  • com.accusoft.imagegear.formats.xmp.adobepdf
  • com.accusoft.imagegear.formats.xmp.basic
  • com.accusoft.imagegear.formats.xmp.basicjobticket
  • com.accusoft.imagegear.formats.xmp.cameraraw
  • com.accusoft.imagegear.formats.xmp.dublincore
  • com.accusoft.imagegear.formats.xmp.dynamicmedia
  • com.accusoft.imagegear.formats.xmp.exif
  • com.accusoft.imagegear.formats.xmp.exifaux
  • com.accusoft.imagegear.formats.xmp.iptc
  • com.accusoft.imagegear.formats.xmp.mediamanagement
  • com.accusoft.imagegear.formats.xmp.microsoftphoto
  • com.accusoft.imagegear.formats.xmp.pagedtext
  • com.accusoft.imagegear.formats.xmp.photoshop
  • com.accusoft.imagegear.formats.xmp.rightsmanagement
  • com.accusoft.imagegear.formats.xmp.tiff
  • com.accusoft.imagegear.processing
  • com.accusoft.imagegear.processing.layers


%%ItemTitle%%

ImageGear for Java | Accusoft
Supported Formats and Compressions
Send Feedback |
ImageGear for Java User Guide > Introduction > Supported Formats and Compressions

Glossary Item Box

ImageGear for Java supports the most popular graphics file formats, preventing compatibility problems before they arise. You can see the complete list of supported formats and compressions as well as references for them in ImageGear Imaging Formats Reference Chapter.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java JAR Files
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files

Glossary Item Box

The following table lists the ImageGear for Java JAR Files, corresponding packages, and dependencies. Please also see Using Multiple JARs for more information.

JAR Name | Package | Dependencies | Description
imagegear2.core.jar | com.accusoft.imagegear.core com.accusoft.imagegear.display com.accusoft.imagegear.formats com.accusoft.imagegear.formats.jpg com.accusoft.imagegear.formats.tif com.accusoft.imagegear.processing com.accusoft.imagegear.processing.layers | <none> | Core ImageGear API and enumerations. File format manager, general metadata API. Metadata dictionary API for the file formats. Image processing API available in ImGearProcessing class. See ImGearRasterProcessing class.
imagegear2.art.jar | com.accusoft.imagegear.art | imagegear2.core.jar | Annotation API.
imagegear2.evaluation.jar | com.accusoft.imagegear.core | imagegear2.core.jar | Provides the evaluation manager used for product evaluation in watermarks mode.
imagegear2.formats.advanced.jar | com.accusoft.imagegear.formats | imagegear2.core.jar imagegear2.formats.common.jar | The following raster file formats: Adobe PSD, PCX, DCX, PCD, PBM, RAS, MSP, Scitex CT, SGI, IFF, WPG, CAL, BTR, IMR, IMT, KFX, LV, NCR, GEM, WBMP, XWD, XBM, XPM, IBM IOCA, IBM MO:DCA, TGA, CUT.
imagegear2.formats.common.jar | com.accusoft.imagegear.formats com.accusoft.imagegear.formats.exif com.accusoft.imagegear.formats.tif | imagegear2.core.jar | BMP, ICO, CUR, CLP, PNG, GIF, TIFF and JFIF file formats. CCITT, Deflate, LZW, JPEG compressions. EXIF metadata.
imagegear2.formats.dicom.jar | com.accusoft.imagegear.core com.accusoft.imagegear.formats.dicom | imagegear2.core.jar imagegear2.formats.common.jar | DICOM file format.
imagegear2.formats.simplifiedmetadata.jar | com.accusoft.imagegear.formats com.accusoft.imagegear.formats.exif com.accusoft.imagegear.formats.iptc com.accusoft.imagegear.formats.tif com.accusoft.imagegear.formats.xmp com.accusoft.imagegear.formats.xmp.basic com.accusoft.imagegear.formats.xmp.basicjobticket com.accusoft.imagegear.formats.xmp.cameraraw com.accusoft.imagegear.formats.xmp.dublincore com.accusoft.imagegear.formats.xmp.dynamicmedia com.accusoft.imagegear.formats.xmp.exif com.accusoft.imagegear.formats.xmp.exifaux com.accusoft.imagegear.formats.xmp.iptc com.accusoft.imagegear.formats.xmp.mediamanagement com.accusoft.imagegear.formats.xmp.microsoftphoto com.accusoft.imagegear.formats.xmp.pagedtext com.accusoft.imagegear.formats.xmp.photoshop com.accusoft.imagegear.formats.xmp.rightsmanagement com.accusoft.imagegear.formats.xmp.tiff | imagegear2.core.jar imagegear2.formats.common.jar | Simplified EXIF, IPTC and XMP Metadata API.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.core.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.core.jar Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.core | The com.accusoft.imagegear.core package is the basis of the ImageGear for Java toolkit. This package contains classes to operate with graphics primitives, to license the product and, most importantly, it contains primary ImageGear entities like page and document.
com.accusoft.imagegear.display | The com.accusoft.imagegear.display package provides support for drawing and the com.accusoft.imagegear.art package.
com.accusoft.imagegear.formats | The com.accusoft.imagegear.formats package provides the ImageGear for Java API for working with formats filters, thumbnails and formats metadata.
com.accusoft.imagegear.formats.jpg | This package provides enumerations values for JPEG format filter control parameters.
com.accusoft.imagegear.formats.tif | This package provides public API for TIFF format metadata operating and for TIFF filter control parameters.
com.accusoft.imagegear.processing | This package represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize and crop images and provides image transformation methods such as contrast adjustment, deskew, filtering, despeckle, and morphological operations.
com.accusoft.imagegear.processing.layers | The com.accusoft.imagegear.processing.layers package provides API for creating and editing image layers. It includes ImGearLayeredPage class, which contains a raster composition image and an array of layers.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.art.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.art.jar Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.art | The com.accusoft.imagegear.art package allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read or write images, with the com.accusoft.imaggear.art package, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images. This chapter provides the com.accusoft.imagegear.art package API reference.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.evaluation.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.evaluation.jar Archive

Glossary Item Box

Package | Description
com::accusoft::imagegear::evaluation | The com.accusoft.imagegear.evaluation package provides the evaluation manager used for product evaluation.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.formats.advanced.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.formats.advanced.jar Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.formats | The com.accusoft.imagegear.formats package provides the ImageGear for Java API with support for working with formats filters, thumbnails and formats metadata.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.formats.common Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.formats.common Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.formats | The com.accusoft.imagegear.formats package provides the ImageGear for Java API for working with formats filters, thumbnails and formats metadata.
com.accusoft.imagegear.formats.exif | This package provides the API for operating with EXIF non-image data.
com.accusoft.imagegear.formats.tif | This package provides public API for TIFF format metadata operating and for TIFF filter control parameters.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.formats.dicom.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.formats.dicom.jar Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.core | The com.accusoft.imagegear.core package is the basis of the ImageGear for Java toolkit.
com.accusoft.imagegear.formats.dicom | The com.accusoft.imagegear.formats.dicom package provides features that are used with medical and DICOM images. This chapter provides you with com.accusoft.imagegear.formats.dicom package API reference.


%%ItemTitle%%

ImageGear for Java | Accusoft
imagegear2.formats.simplifiedmetadata.jar Archive
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java JAR Files > imagegear2.formats.simplifiedmetadata.jar Archive

Glossary Item Box

Package | Description
com.accusoft.imagegear.formats | This package provides the ImageGear for Java API for working with formats filters, thumbnails and formats metadata.
com.accusoft.imagegear.formats.exif | This package provides the API for operating with EXIF non-image data.
com.accusoft.imagegear.formats.iptc | This package contains classes, structures, and enumerations that provide simplified access to IPTC metadata.
com.accusoft.imagegear.formats.tif | This package provides public API for TIFF format metadata operating and for TIFF filter control parameters.
com.accusoft.imagegear.formats.xmp | This package provides the API for XMP format.
com.accusoft.imagegear.formats.pdf | This package provides the API for XMP.AdobePDF format.
com.accusoft.imagegear.formats.xmp.basic | This package provides the API for XMP.Basic format.
com.accusoft.imagegear.formats.xmp.basicjobticket | This package provides the API for XMP.BasicJobTicket format.
com.accusoft.imagegear.formats.xmp.cameraraw | This package provides the API for XMP.CameraRaw format.
com.accusoft.imagegear.formats.xmp.dublincore | This package provides the API for XMP.DublinCore format.
com.accusoft.imagegear.formats.xmp.dynamicmedia | This package provides the API for XMP.DynamicMedia format.
com.accusoft.imagegear.formats.xmp.exif | This package provides the API for XMP.EXIF format.
com.accusoft.imagegear.formats.xmp.exifaux | This package provides the API for XMP.EXIFAux format.
com.accusoft.imagegear.formats.xmp.iptc | This package provides the API for XMP.IPTC format.
com.accusoft.imagegear.formats.xmp.mediamanagement | This package provides the API for XMP.MediaManagement format.
com.accusoft.imagegear.formats.xmp.microsoftphoto | This package provides the API for XMP.MicrosoftPhoto format.
com.accusoft.imagegear.formats.xmp.pagedtext | This package provides the API for XMP.PagedText format.
com.accusoft.imagegear.formats.xmp.photoshop | This package provides the API for XMP.Photoshop format.
com.accusoft.imagegear.formats.xmp.rightsmanagement | This package provides the API for XMP.RightsManagement format.
com.accusoft.imagegear.formats.xmp.tiff | This package provides the API for XMP.TIFF format.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java Packages
Send Feedback |
ImageGear for Java User Guide > Introduction > ImageGear for Java Packages

Glossary Item Box

ImageGear functionality is divided into JAR files. This provides flexibility in licensing ImageGear technology. Each JAR file encapsulates a particular functionality of the product. All JAR files are enabled when you evaluate or purchase the product (there is an expiration date for the evaluation version). However, different licensing fees may be associated with different JAR files for deployment of your application. Please contact your Accusoft sales representative for more information about deployment licensing fees.

You will need to initialize a JAR file (except for the core JAR file) before using it. See the Samples for a demonstration of initializing the JAR files. The sample code has been provided so that you can cut and paste the initializing package code into your own application.

Refer to ImageGear for Java JAR Files for information on JAR files.

Please see Installing and Distributing ImageGear for information about ImageGear and the JAR file licensing process.

This section provides an ImageGear Packages Availability table, indicating which packages are available on which platforms, and also an ImageGear Packages Descriptions section, which describes each package.

ImageGear Packages Availability

The ImageGear for Java documentation provides information for all platforms. The following table describes which ImageGear for Java packages are available for which platforms (Windows 32-bit, Windows 64-bit, Linux 32-bit, Linux 64-bit, Mac 32-bit, and Mac 64-bit).

Package | Win 32-bit | Win 64-bit | Linux 32-bit | Linux 64-bit | Mac 32-bit | Mac 64-bit
com.accusoft.imagegear.core | x | x | x | x | x | x
com.accusoft.imagegear.art | x | x | x | x | x | x
com.accusoft.imagegear.display | x | x | x | x | x | x
com.accusoft.imagegear.formats | x | x | x | x | x | x
com.accusoft.imagegear.formats.dicom | x | x | x | x | x | x
com.accusoft.imagegear.formats.exif | x | x | x | x | x | x
com.accusoft.imagegear.formats.iptc | x | x | x | x | x | x
com.accusoft.imagegear.formats.jpg | x | x | x | x | x | x
com.accusoft.imagegear.formats.tif | x | x | x | x | x | x
com.accusoft.imagegear.formats.xmp | x | x | x | x | x | x
com.accusoft.imagegear.processing | x | x | x | x | x | x
com.accusoft.imagegear.processing.layers | x | x | x | x | x | x

com.accusoft.imagegear.core Package

The com.accusoft.imagegear.core package is the foundation for all other packages and contains shared classes used in other packages such as ImGearPage class and ImGearDocument class, and global attributes such as error handling classes and licensing.

The com.accusoft.imagegear.core package is split between the following JAR files:

  • imagegear2.core.jar
  • imagegear2.formats.dicom.jar

com.accusoft.imagegear.art Package

Using the com.accusoft.imagegear.art package, you can annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Mark objects are created by using their constructors, but their actual life starts when they are added into an ImGearARTPage object. An ART page can be associated with one or more ImGearPage objects. The association is done by using ImGearPageDisplay methods: setPage and setARTPage. Your application can save an image with marks into a separate file in legacy .ART file format or .XML file format. Any time the image is reloaded, the ART marks can be reloaded with a simple method call.

The com.accusoft.imagegear.art Namespace belongs to the imagegear2.art.jar.

com.accusoft.imagegear.display Package

The com.accusoft.imagegear.display package provides access to ImageGear display API and contains shared types used for image drawing. This package supports some functionality the com.accusoft.imagegear.art package.

com.accusoft.imagegear.formats Package

The com.accusoft.imagegear.formats package provides image loading/saving operations for all other ImageGear packages. The com.accusoft.imagegear.formats package is split among the following JAR files:

  • imagegear2.core.jar
  • imagegear2.formats.advanced.jar
  • imagegear2.formats.common.jar
  • imagegear2.formats.simplifiedmetadata.jar

com.accusoft.imagegear.formats.dicom Package

The com.accusoft.imagegear.formats.dicom package provides features that are used with medical and DICOM images. DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images. Today DICOM is the standard for medical imaging throughout the world.

The com.accusoft.imagegear.formats.dicom package "Imagegear.Formats.DICOM" is a full-featured ImageGear component. It supports the DICOM format, contains a custom API, and includes expanded image processing capabilities beyond those of the baseline ImageGear library. The com.accusoft.imagegear.formats.dicom package belongs to the imagegear2.formats.dicom.jar archive.

The format support of the package includes loading and saving monochrome, palettized, and true color medical images using the following file formats:

  • DICOM 3.0 Part 10-compliant images
  • DICOM 3.0 Raw Format (non-Part 10-compliant)

The com.accusoft.imagegear.formats.dicom package provides DICOM Presentation State objects that allow you to display images on various devices and media, to store specific settings for display (contrast transformations, geometric transformations), to store annotations, and to display multi-frame images.

In addition, your application will continue to support all ImageGear-supported file formats, allowing you to convert an image of a different format to a medical image format, and vice-versa.

com.accusoft.imagegear.formats.exif Package

The com.accusoft.imagegear.formats.exif package provides the API for operating with EXIF non-image data, and is split between the following JAR files:

  • imagegear2.formats.common.jar
  • imagegear2.formats.simplifiedmetadata.jar

com.accusoft.imagegear.formats.iptc Package

The com.accusoft.imagegear.formats.iptc package contains classes, structures, and enumerations that provide simplified access to IPTC metadata, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.jpg Package

The com.accusoft.imagegear.formats.jpg package provides enumeration values for JPEG format filter control parameters, and belongs to the imagegear2.core.jar archive.

com.accusoft.imagegear.formats.tif Package

The com.accusoft.imagegear.formats.tif package provides public API for TIFF format metadata operating and for TIFF filter control parameters. The com.accusoft.imagegear.formats.tif package is split among the following JAR files:

  • imagegear2.core.jar
  • imagegear2.formats.common.jar
  • imagegear2.formats.simplifiedmetadata.jar

com.accusoft.imagegear.formats.xmp Package

The com.accusoft.imagegear.formats.xmp package provides the API for XMP format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.adobepdf Package

The com.accusoft.imagegear.formats.xmp.adobepdf package provides the API for XMP.AdobePDF format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.basic Package

The com.accusoft.imagegear.formats.xmp.basic package provides the API for XMP.Basic format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.basicjobticket Package

The com.accusoft.imagegear.formats.xmp.basicjobticket package provides the API for XMP.BasicJobTicket format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.cameraraw Package

The com.accusoft.imagegear.formats.xmp.cameraraw package provides the API for XMP.CameraRaw format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.dublincore Package

The com.accusoft.imagegear.formats.xmp.dublincore package provides the API for XMP.DublinCore format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.dynamicmedia Package

The com.accusoft.imagegear.formats.xmp.dynamicmedia package provides the API for XMP.DynamicMedia format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.exif Package

The com.accusoft.imagegear.formats.xmp.exif package provides the API for XMP.EXIF format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.exifaux Package

The com.accusoft.imagegear.formats.xmp.exifaux package provides the API for XMP.EXIFAux format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.iptc Package

The com.accusoft.imagegear.formats.xmp.iptc package provides the API for XMP.IPTC4XMPCore format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.mediamanagement Package

The com.accusoft.imagegear.formats.xmp.mediamanagement package provides the API for XMP.MediaManagement format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.microsoftphoto Package

The com.accusoft.imagegear.formats.xmp.microsoftphoto package provides the API for XMP.MicrosoftPhoto format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.pagedtext Package

The com.accusoft.imagegear.formats.xmp.pagedtext package provides the API for XMP.PagedText format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.photoshop Package

The com.accusoft.imagegear.formats.xmp.photoshop package provides the API for XMP.Photoshop format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.rightsmanagement Package

The com.accusoft.imagegear.formats.xmp.rightsmanagement package provides the API for XMP.RightsManagement format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.formats.xmp.tiff Package

The com.accusoft.imagegear.formats.xmp.tiff package provides the API for XMP.TIFF format, and belongs to the imagegear2.formats.simplifiedmetadata.jar archive.

com.accusoft.imagegear.processing Package

The com.accusoft.imagegear.processing package is responsible for the image processing functionality. It provides the capability to resize, rotate, adjust brightness and contrast, reduce or promote bit depth, and perform many other image processing operations. The ImageGear.Processing package belongs to the imagegear2.core.jar archive.

com.accusoft.imagegear.processing.layers Package

The com.accusoft.imagegear.processing.layers package provides an API for creating and editing image layers. It includes ImGearLayeredPage Class, which contains a raster composition image and an array of layers. The ImageGear.Processing.Layers package belongs to the imagegear2.core.jar archive.


%%ItemTitle%%

ImageGear for Java | Accusoft
About Customer Support
Send Feedback |
ImageGear for Java User Guide > Introduction > About Customer Support

Glossary Item Box

If you are unable to find an answer to your questions in the help, refer to the Release Notes, which provide release-specific information, including changes made to the product since the last update. If you need additional assistance, please read the procedures below:

  • Check the Manual provided with this product or the on-line documentation.
  • Check the Release Notes files for updated information.
  • Refer to Getting Started and Using ImageGear. These chapters contain a great deal of information on both programming your application and identifying image problems.
  • Take a look at the sample programs included with your product.
  • Visit www.accusoft.com/imaging-support.htm. Our Web site provides access to a wealth of product information, including:
    • Product Information and Specifications
    • Product Downloads
    • Customer Support
    • Demonstrations and Tutorials
    • On-line Documentation

If you still need technical support assistance, please follow the instructions provided in the Software Support and Maintenance Policy.


%%ItemTitle%%

ImageGear for Java | Accusoft
Software Support and Maintenance Policy
Send Feedback |
ImageGear for Java User Guide > Introduction > About Customer Support > Software Support and Maintenance Policy

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.


%%ItemTitle%%

ImageGear for Java | Accusoft
Accusoft Corporation Copyrights & Trademarks
Send Feedback |
ImageGear for Java User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©2011-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

Accusoft Patents

ImageGear Java utilizes technology owned by Accusoft Corporation that is protected by U.S. Patents and U.S. Patents Pending.


%%ItemTitle%%

ImageGear for Java | Accusoft
Installing and Distributing ImageGear
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear

Glossary Item Box

This section provides the following information:

  • System Requirements
  • Installing ImageGear for Java
  • Directory Structure
  • Licensing and Distributing ImageGear for Java


%%ItemTitle%%

ImageGear for Java | Accusoft
System Requirements
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > System Requirements

Glossary Item Box

This section provides information about the system requirements for ImageGear for Java in the following sub-sections:

  • Supported Operating Systems
  • Disk Space
  • Java Runtime Environment

Supported Operating Systems

Windows Operating Systems:

  • Windows 2000 Service Pack 4
  • Windows Server 2003 32-bit and 64-bit Editions
  • Windows XP Professional 32-bit and 64-bit Editions, Service Pack 2
  • Windows Vista 32-bit and 64-bit Editions
  • Windows Server 2008 32-bit and 64-bit Editions
  • Windows 7 32-bit and 64-bit Editions

Linux Distributions:

  • Ubuntu 8.04 LTS Desktop Edition (32-bit)
  • Red Hat Enterprise Linux 5.0 or Later (32- and 64-bit)
  • SUSE 8 or Later (32- and 64-bit)

Mac Operating Systems:

  • OS X 10.6 (Snow Leopard) 32- and 64-bit
  • OS X 10.5 (Leopard) 32-bit

Disk Space

The Installation program will tell you exactly how much disk space you need in order to install ImageGear for Java. The disk space used will vary, depending upon the options you select during installation, but will be up to 300 Mbytes.

Java Runtime Environment

Windows:

  • All OSes: Oracle JavaSE 1.6.0.23 or Later

Linux:

  • All Distributions: Oracle JavaSE 1.6.0.23 or Later

Mac:

  • Snow Leopard: Java for Mac OS X 10.6 Update 4
  • Leopard: Java for Mac OS X 10.5 Update 9


%%ItemTitle%%

ImageGear for Java | Accusoft
Installing ImageGear for Java
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Installing ImageGear for Java

Glossary Item Box

Before installing ImageGear for Java, make sure that your system complies with the requirements detailed in the System Requirements section.

To install ImageGear, perform the following steps:

  1. Start the installer.
    1. Download the installer from the web. After the download finishes, run the installer.
  2. Click the "Next" button to continue past the welcome dialog.
  3. Carefully read the information contained in the "License Agreement" form before making a decision to accept the terms of the agreement. Choose "I accept the terms of the License Agreement" to accept the conditions outlined in the License Agreement, and then click the "Next" button to continue the installation, or click "Cancel" to exit the installation process.
  4. After clicking "Next" the Choose Install Folder form is displayed. Choose the destination folder where the ImageGear product should be installed or choose the default installation destination folder. Then click "Next".

  5. Once you click the "Next" button, the "Choose Shortcut Folder" form is displayed. On this page you can choose where to place shortcuts to product features. Once you have selected the desired option, click "Next".

  6. The last page presented to you is the "Pre-Installation Summary" checklist. Review the items on this page. You can change installation options by clicking the "Previous" button, or cancel the installation by clicking the "Cancel" button. To proceed with installation, click the "Install" button.
  7. Once installation is complete you will be presented with the License Manager dialog. Using this dialog you can select the type of license you wish to obtain, an evaluation license or a development license.


%%ItemTitle%%

ImageGear for Java | Accusoft
Directory Structure
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Directory Structure

Glossary Item Box

The installation program creates the directory structure listed below. The install path depends on the installer and operating system and is also subject to change by the user during the installation process.

Directory | Description | Note
"[install path]\bin" | ImageGear for Java native JAR files, dependencies, and resources. | Windows installations only.
"[install path]\config" | License files. |
"[install path]\docs" | ImageGear for Java Documentation. |
"[install path]\install" | Files supporting modification of the installation, including uninstallation. |
"[install path]\jre" | The Java Runtime Environment. |
"[install path]\lib" | ImageGear for Java JAR files. |
"[install path]\samples" | ImageGear for Java sample projects source and compiled binaries. |
"[install path]\util" | ImageGear for Java Utilities. |


%%ItemTitle%%

ImageGear for Java | Accusoft
Licensing and Distributing ImageGear for Java
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java

Glossary Item Box

During the ImageGear for Java installation, you need to obtain a license key using the Accusoft License Manager that is run automatically at the end of the installation. If you need to change your license in the future (for instance when upgrading from an evaluation license to a development license), you can run the license utility manually. If you chose to create shortcuts during installation, a shortcut will be installed for the License Manager. Otherwise, the License Manager is located in the ImageGear for Java install path under the "util" directory.

The License Manager utility requires an Internet connection in order to manage the license keys. If you don't have an Internet connection, please contact Accusoft Customer Service at www.accusoft.com/imaging-support.htm.

This section provides the following information:

  • ImageGear for Java Evaluation License
  • ImageGear for Java Development License
  • ImageGear for Java Deployment License
  • Distributing ImageGear for Java Application


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java Evaluation License
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java > ImageGear for Java Evaluation License

Glossary Item Box

If you are evaluating the product, please select the ImageGear evaluation license option from the initial screen of the License Manager utility. Your license key will be automatically obtained and stored on your computer.

The License Manager utility stores the Evaluation license key in the config folder and product samples are configured to use the license in that folder.

An Evaluation license enables you to use any features of the product on your machine, however a watermark will be displayed.

When you evaluate the product, you have to initialize the evaluation manager provided by the com.accusoft.imagegear.evaluation package by calling the initialize() method of the ImGearEvaluationManager class, and then call the setSolutionName() method of the ImGearLicense class object that is provided by the com.accusoft.imagegear.core package. While you are evaluating the ImageGear product, you should specify the value "AccuSoft 21-32-2" (or "AccuSoft 21-33-2" if using a 64-bit Java Runtime) on the setSolutionName method() call:

Java Example Copy Code
// Initialize evaluation manager.
ImGearEvaluationManager.initialize();

if((System.getProperty("os.arch").contains("64")))
    ImGearLicense.setSolutionName("AccuSoft 21-33-2");
else
    ImGearLicense.setSolutionName("AccuSoft 21-32-2");


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java Development License
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java > ImageGear for Java Development License

Glossary Item Box

If you bought the Development copy of ImageGear for Java, please do the following:

  1. Select the ImageGear development license option from the initial screen of the License Manager utility.
  2. You will be prompted to log in using e-mail and password you have registered with on the Accusoft Web site.
  3. Upon login, you will be presented with the combo-box containing different access keys for the Accusoft products you have bought. Please select ImageGear access key and click "Get Key". Your license key will be automatically obtained and stored on your computer.

If you had an Evaluation license previously, it will be overwritten with the new Development license. A Development license enables you to use any of the ImageGear features. You need to run the License Manager utility for each machine where you need to use the product.

The License Manager utility stores the Development license key in the config folder and product samples are configured to use the license in that folder.

When you develop your application using ImageGear, you have to call the setSolutionName() method of the ImGearLicense class object that is provided by the com.accusoft.imagegear.core package. While you are developing, you should specify the value "AccuSoft 21-32-2" (or "AccuSoft 21-33-2" if using a 64-bit Java Runtime) on the setSolutionName() call:

Java Example Copy Code
if ((System.getProperty("os.arch").contains("64")))
    // 64bit eval and development solution name
    ImGearLicense.setSolutionName("AccuSoft 21-33-2");
else
    // 32bit eval and development solution name
    ImGearLicense.setSolutionName("AccuSoft 21-32-2");


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java Deployment License
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java > ImageGear for Java Deployment License

Glossary Item Box

When you are ready to deploy your application, you need to change licensing calls to specify the Solution Name, Solution Key, and OEM License Key that Accusoft will provide for you. Distribution is per Accusoft's agreement for quarterly reporting (LDR).

This section specifies the steps you need to follow to properly license and install your end product on the end users machine when deploying your product to a client machine.

Accusoft will email the necessary parameters to you: Solution Name, Solution Key, and License Key for the deployment of your application. Using these parameters, you can then modify the code of your application to specify the Solution Name, Solution Key, and License Key using the following ImageGear API:

  • To specify the Solution Name, you call ImGearLicense.setSolutionName method.

    When you are ready to deploy your ImageGear-based application, you need to replace the generic solution name used to license the product for evaluation and development with the unique solution name assigned to your application by Accusoft Corporation.

  • To specify the Solution Key, you call ImGearLicense.setSolutionKey method.
  • To specify the License Key for your application, you call ImGearLicense.setOEMLicenseKey method.
Java Example Copy Code
ImGearLicense.setSolutionName("Your Solution Name");
ImGearLicense.setSolutionKey(12345, 12345, 12345, 12345);
ImGearLicense.setOEMLicenseKey("1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation...");


%%ItemTitle%%

ImageGear for Java | Accusoft
Distributing ImageGear for Java Application
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java > Distributing ImageGear for Java Application

Glossary Item Box

An application using ImageGear for Java can be targeted for Windows, Linux, and Mac 32- and 64-bit operating systems. Depending on the targeted platform and the packages used, you must distribute specific JAR files and in some cases native binary files.

In all cases you must distribute your application along with the ImageGear for Java JAR - imagegear2.core.jar, but you will not need to distribute imagegear2.evaluation.jar. Then, depending on what features or packages your application uses, other JAR files and native binaries must also be distributed.

  • To determine the JAR files that need to be distributed, cross-check the packages and features used against the JAR files listed in the table in ImageGear For Java JAR Files.
  • When distributing an application targeting Windows, the following dlls need to be distributed. To get the Java code to find these native Windows dlls, see ImGearNativePath.
    • igjcommonnative2.dll
    • igjlicensing.dll
    • igjcolormgmt2.dll


%%ItemTitle%%

ImageGear for Java | Accusoft
Software License Agreement
Send Feedback |
ImageGear for Java User Guide > Installing and Distributing ImageGear > Licensing and Distributing ImageGear for Java > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112


%%ItemTitle%%

ImageGear for Java | Accusoft
Getting Started
Send Feedback |
ImageGear for Java User Guide > Getting Started

Glossary Item Box

This chapter provides tutorials that demonstrate how to create and build the ImageGear for Java Core sample applications using both the Eclipse IDE and NetBeans IDE.

The Core sample is a GUI application that was built with NetBeans. Therefore, the GUI can be modified using the NetBeans GUI Builder (a WYSIWYG editor). However, if you are using the Eclipse IDE, you can edit the source for the UI, but you will not have the WYSIWYG editor available to you, without installing a plugin.

  • Building the Core Sample with NetBeans
  • Building the Core Sample with Eclipse
  • Setting the Path to the Native Libraries


%%ItemTitle%%

ImageGear for Java | Accusoft
Building the Core Sample with NetBeans
Send Feedback |
ImageGear for Java User Guide > Getting Started > Building the Core Sample with NetBeans

Glossary Item Box

nThis section will walk through the process of building the ImageGear for Java Core sample. NetBeans 7.0.1 is used, but this tutorial may provide guidance for building with other versions of NetBeans.

Create Library

We'll start by creating a Library containing all ImageGear for Java JAR files. This is not required but is helpful when building multiple samples.

  1. Select Tools > Libraries to open up the Library Manager.

  2. Click the button Add JAR/Folder and browse to the lib folder within the ImageGear for Java installation directory.
    Select all *.jar files in the lib folder. If you know that you will not need some of the JAR files, then they don't have to be selected.

  3. Click Add JAR/Folder to accept the JAR files you have selected. Then in the Library Manager, click OK to exit.

Create the Core Sample Project

We will create a project for the Core sample application. This sample will use the Shared sample, but we will not build the Shared sample, instead we will use the pre-built imagegear2.shared.jar that installs with ImageGear for Java.

  1. Click File > New Project to open the New Project dialog, and then select project category Java and project type Java Project with Existing Sources. Then click Next.

  2. Give the project a name, "igsample.core", and select an appropriate project folder and click Next.

  3. Select Source Package Folders containing the source code for the Core project that installed into the samples folder within the ImageGear for Java installation directory. It is best to select the src folder, at "[IG Java install path]\samples\Core\src\" so that the package naming is maintained.

  4. After selecting the "...\core\src" folder, click Finish to exit the New Project dialog and create the project.

    The Projects Window in the NetBeans IDE should now contain the igsample.core project, and the project tree should contain the files in the com.imagegear.core source package.

  5. Next, add the ImageGearJava library that we created at the beginning of this walkthrough.

    Right click the Libraries node on under igsample.core in the Project Window and select Add Library.

  6. In the Add Library dialog, select the ImageGearJava library and click Add Library.

  7. Now, add the imagegear2.shared.jar file.

    Again, right click the Libraries node under igsample.com in the Project Window, but this time select Add JAR/Folder.

  8. In the Add JAR/Folder dialog, browse to the samples folder within the ImageGear for Java installation directory. Select the file imagegear2.shared.jar and click Open.

    At this point, the Projects Window should be updated and should no longer contain any icons with red exclamations, as shown in the image below.

  9. Now, set a Main Class for your project. To do this,

    1. select File > Project Properties (igsample.core), which will open the Project Properties dialog.
    2. Select the Run set of categories from the tree, and for the Main Class field, click the Browse button to open the Browse Main Classes dialog.
    3. Then select the com.imagegear.core.ImageViewerUI and click Select Main Class.

  10. Click OK to close the Project Properties dialog.

  11. If you're building the sample on a Linux or Mac OS X machine, you can skip to building and running the application. However, if you're working on a Windows machine you will now need to set the path to the native libraries (for JPEG2K and PDF support), refer to Setting the Path to the Native Libraries for instructions.

  12. You can now build the project (F11) and run (F6).
    If you have any compile-time or run-time errors, retrace your steps to determine if something was configured differently from the instructions in this walk-through.
    For help resolving runtime issues see the Warnings and Errors section of the ImageGear for Java User Guide If you cannot resolve an issue, you may contact Accusoft's Support department for more help.


%%ItemTitle%%

ImageGear for Java | Accusoft
Building the Core Sample with Eclipse
Send Feedback |
ImageGear for Java User Guide > Getting Started > Building the Core Sample with Eclipse

Glossary Item Box

This section will walk through the process of building the ImageGear for Java Core sample. Eclipse IDE 1.4.1 is used, but this tutorial may provide guidance for building with other versions of Eclipse.

Create User Library

First, we will set up a User Library containing all ImageGear for Java JAR files. This is not required but is helpful when building multiple samples.

  1. Select Window > Preferences to open up the Preferences window. Then navigate to the Java > Build Path > User Libraries panel. Within the User Libraries panel, click the New button.

  2. Give the new library the name "ImageGearJava" and click OK.

  3. Back in the User Libraries panel, select the new library and click Add JARs.

  4. In the JAR Selection dialog, browse to the lib folder within the ImageGear for Java installation directory. Select all *.jar files in the lib folder. If you know that you will not need some of the JAR files, then they don't have to be selected.

  5. Click Open to accept the JAR files you have selected. Then in the Preferences window, click OK to exit.

Create the Sample Project

In this section we will create a project for the Core sample application. This sample will use the Shared sample, but we will not build the Shared sample, instead we will use the pre-built imagegear2.shared.jar that installs with ImageGear for Java.

  1. Select File > New > Java Project to open the New Java Project dialog. Give the project a name, "igsample.core", and select an appropriate project location.

  2. Click Next.

    Now the Java Settings page will be displayed. Select the Source tab and in the tree right click on the igsample.core node and click "Link Source".

  3. Select the Linked folder location as the folder containing the source code for the Core project that has been installed into the samples folder within the ImageGear for Java installation directory. It is best to select the src folder, at "[IG Java install path]\samples\Core\src\" so that the package naming is maintained.

  4. Change the folder name to something other than src, for example use "coresrc". Click Finish to return to the Java Settings page.

  5. Next select the Libraries tab on the Java Settings page.

  6. Add the ImageGearJava user library that we created at the beginning of this tutorial but clicking the Add Library button. In the Add Library dialog, specify that you want to add a User Library and click Next. Then check the ImageGearJava library and click Finish.

  7. Then, add the imagegear2.shared.jar. Click the Add External JARs button and navigate to the samples folder within the ImageGear for Java install directory. Select the imagegear2.shared.jar and click Open.

  8. Now, exit the New Java Project dialog by clicking the Finish button.

    The Package Explorer in the Eclipse IDE should now contain the igsample.core project, and the project tree should contain the files in the com.imagegear.core source package, the ImageGearJava User Library, and the imagegear2.shared.jar, like shown in the image below.

  9. Now we'll create a launch configuration for the application. Open the Properties dialog for the project (File > Properties) and then select the Run/Debug Settings page.

  10. Click the New button, select the Java Application configuration, and then click OK.

  11. This brings you to the Edit Configuration dialog. Under the Main tab, we need to specify a main class. Click the "Search" button to bring up the Select Main Type dialog. Select the ImageViewerUI class and click "OK".

  12. Click OK to close the Edit Configuration dialog, and again click OK to clise the project's Properties dialog.

  13. If you're building the sample on a Linux or Mac OS X machine, you can skip to building and running the application. However, if you're working on a Windows machine you will now need to set the path to the native libraries (for JPEG2K and PDF support), refer to Setting the Path to the Native Libraries for instructions.

  14. You can now build the project (Ctrl-B, if automatic building is disabled) and run (Ctrl-F11).
    If you have any compile-time or run-time errors, retrace your steps to determine if something was configured differently from the instructions in this walk-through.
    For help resolving runtime issues see the Warnings and Errors section of the ImageGear for Java User Guide If you cannot resolve an issue, you may contact Accusoft's Support department for more help.


%%ItemTitle%%

ImageGear for Java | Accusoft
Setting the Path to the Native Libraries
Send Feedback |
ImageGear for Java User Guide > Getting Started > Setting the Path to the Native Libraries

Glossary Item Box

The paths mentioned here are for Windows. They will vary in other operating systems.

Licensing (enforcement) code in ImageGear for Java reads licenses from files. These license files are installed to the config folder by the Accusoft License Client; normally this utility is run at the end of installation. If you keep the installation folder structure intact and load the SDK jars from their lib folder, the licensing code will find the license files in the config folder on its own, when it needs to authorize the application to execute various features of the SDK (for example, when calling the ImGearCommonFormats.Initialize method).

If, however, you need to move either the SDK jars, the license files, or both, so that they no longer have the same parent, you must tell the ImageGear for Java licensing code where the license files are. This can be done by setting the environment variable IMAGE_GEAR_LICENSE_DIR to have the value of the directory containing the license files. If license files are not found in this directory or this envrionment variable is not set, then the licensing code will default to looking in the path relative to the lib folder.

License files use the naming convention "accusoft.<solution name>.imagegear", where <solution name>=""> has the same string value as the argument to the ImGearLicense.SetSolutionName method. For evaluation and development licenses, the solution name will be "AccuSoft 21-33-2" or "AccuSoft 21-32-2" depending on whether the license is for a 64- or 32-bit environment.

The Windows version of ImageGear for Java may need to use native libraries that are installed in the bin folder. If you keep the installation folder structure intact and load the SDK jars from their lib folder, they will find the dlls in their peer bin folder on their own, at the time the ImGearLicense class is loaded. (For example, when calling ImGearLicense.SetSolutionName()).

If, however, you need to move either the jars, the entire contents of bin, or both, so that they no longer have the same parent, you must tell the SDK jars where the dlls are. There are several ways to do this without the SDK jars first looking for a peer bin folder. To communicate the location programmatically, call ImGearNativePath.setPath(<String value of fully qualified path to native libraries>) before the ImGearLicense class is loaded (which kicks off an automatic search) or afterwards, if the automatic search has not already found them.

The automatic search will first determine the architecture running the Java Virtual Machine, and look for the environment variable, IMAGE_GEAR_64BIT_PATH on 64 bits, and IMAGE_GEAR_32BIT_PATH on 32 bits, for fully qualified paths to the libraries. If the variable does not exist, it looks in the components of the java.library.path System property. You can set this property to contain the path to the native libraries in two ways:

  1. adding the path to the operating system's path environment variable

    Setting the operating system's path this way will prevent you from using the 32 and 64 bit SDKs simultaneously, since it will always find the version that is first.

  2. invoking the Java Virtual Machine with the argument -Djava.library.path=<path to="" native="" binaries>="">

The last place it looks is in a bin peer folder of the one the SDK jars were loaded from.


%%ItemTitle%%

ImageGear for Java | Accusoft
Using ImageGear for Java
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java

Glossary Item Box

ImageGear for Java is implemented as safe and managed code and offers the hierarchy of classes, structures, interfaces, and enumerations. It is structured into several packages, providing APIs in the following categories: Core Functionality, Formats, Processing, and Display. Below you will find a description of the product architecture as well as the information regarding using each of the provided packages.

  • Architecture
  • Using Multiple Packages
  • Image and ImGearPage
  • Loading/Saving Pages and Documents
  • Processing Images
  • Working with Color Profiles
  • Working with Spot Colors
  • Working with Transparent Color
  • Non-Image Data Processing
  • Warnings and Errors
  • Using com.accusoft.imagegear.art Package
  • Using the com.accusoft.imagegear.formats.dicom Package
  • Using the com.accusoft.imagegear.processing Package
  • Using the com.accusoft.imagegear.processing.layers Package


%%ItemTitle%%

ImageGear for Java | Accusoft
Architecture
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Architecture

Glossary Item Box

The ImageGear for Java library is logically divided into five major parts, encapsulated into following packages a Core, Processing, Formats, Display and extensions. An example of their relationship is shown in the following diagram:

com.accusoft.imagegear.core package is the basis of ImageGear for Java toolkit. This package contains classes to operate with graphics primitives, to license product, and most importantly, primary ImageGear entities like page and document. Page is implemented in the ImGearPage Class and represents an image in memory. It contains image attributes, pixels, and offers functions for basic operating like access to stored pixels or metadata assignment.

Since the most persistent form of storage for images is files, ImageGear offers the ImGearFileFormats Class, located in com.accusoft.imagegear.formats package, to handle them. Using this class, it is possible to load and store single pages from local and network files, obtain properties like width and height without loading an entire image, and operate with multi-image documents (ImGearDocument Class) like TIFF. The toolkit also contains classes like ImGearLoadOptions Class and interfaces like the ImGearControlParameter Class to control image loading and saving processes (including saving the format and its characteristics).

Once an image (in its representation as ImGearPage Class) is created or obtained from a file or scanner, it is possible to process it using the ImGearProcessing Class. It defines a series of members that can be applied to any ImGearPage Class instance. Adjusting brightness/contrast, flipping, inverting, rotating and other operations are available for developers. Additionally, an export to managed BufferedImage class is also available through ImGearProcessing Class.

The ImGearPageDisplay Class serves to represent an image on the computer's screen. It is a member of the com.accusoft.imagegear.display package and allows drawing the attached ImGearPage Class onto a Windows Form with an impressive variety of options.

If your application requires additional ImageGear functionality, you can simply interact directly with ImageGear.


%%ItemTitle%%

ImageGear for Java | Accusoft
Using Multiple Packages
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using Multiple Packages

Glossary Item Box

ImageGear for Java is distributed as multiple JAR files. An application built on ImageGear for Java can use a subset of the JAR files, according to its needs. The section ImageGear for Java JAR Files provides a complete list of JAR files, their corresponding packages, and their dependencies.

Important aspects related to the usage of multiple JAR files and packages are discussed in the following sections:

  • File Format Support Initialization
  • Resolving JAR File Cross-Dependencies


%%ItemTitle%%

ImageGear for Java | Accusoft
File Format Support Initialization
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using Multiple Packages > File Format Support Initialization

Glossary Item Box

ImageGear for Java requires that support for reading, writing, and processing some file formats is explicitly initialized at application startup. This is not true of all file formats supported by ImageGear for Java, only file formats implemented in the JARs listed in the following table require explicit initialization. All file formats implemented in the JARs will be initialized when calling the format initialization method listed in the table.

JAR File | File Format Initialization Method
imagegear2.formats.advanced.jar | ImGearAdvancedFormats.Initialize Method
imagegear2.formats.common.jar | ImGearCommonFormats.Initialize Method
imagegear2.formats.simplifiedmetadata.jar | ImGearSimplifiedMetadata.Initialize Method

Some file formats require both initialization and termination.

The order in which file format support is initialized is important, because it defines format detection priority.

Advanced formats should usually be initialized last, to allow for faster detection of Common formats.

The following initialization order is recommended:

Java Example Copy Code
ImGearCommonFormats.Initialize();
ImGearAdvancedFormats.Initialize();

CUT format (supported in ImageGear2.Formats.Advanced JAR) doesn't have a specific signature in the file's header, which makes its detection less reliable. Detection of this format in ImageGear is disabled by default, but can be enabled through the IImGearFormat.setDetectionEnabled method.

The order in which simplified metadata formats support is initialized in relation to other format support is not important.

Support for detection of JPEG2000, JPEG2000 Extensions, and Motion JPEG2000 can be added. The order in which these formats are added to the format filter list is important.

Support for detection of DICOM images can be added with the following lines of code. The order in which this format is added to the format filter list is important.

Example Copy Code
// Adds support for DICOM files.
try
{
        ImGearFileFormats.getFilters().Insert(0, ImGearDICOM.CreateDICOMFormat());
}
catch(ImGearException ex)
{
        // dicom is not licensed.
        // Continue running, the sample can run without dicom
}


%%ItemTitle%%

ImageGear for Java | Accusoft
Resolving JAR File Cross-Dependencies
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using Multiple Packages > Resolving JAR File Cross-Dependencies

Glossary Item Box

ImageGear provides the following interfaces and abstract classes to help avoid cross-dependencies between JAR files.

  • IImGearDICOMDisplaySettings Interface
  • ImGearAnnotationPage Class
  • ImGearFormatMetadata Class

IImGearDICOMDisplaySettings Interface

The getDICOMDisplaySettings and setDICOMDisplaySettings methods of the ImGearRasterPage Class, as well as the ImGearPageDisplay Class, use the IImGearDICOMDisplaySettings Interface type. IImGearDICOMDisplaySettings Interface has a small set of public members that are used for displaying a DICOM image. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings Interface to the actual class ImGearDICOMDisplaySettings Class, which is defined in the imagegear2.formats.dicom.jar. The following two examples demonstrate this:

Java Example Copy Code
ImGearRasterPage rasterPage;

// Load an image into rasterPage.
// If the image does not have a DICOMDisplaySettings object attached, create and add one.

if (rasterPage.getDICOMDisplaySettings() == null) {
        rasterPage.setDICOMDisplaySettings(new ImGearDICOMDisplaySettings());
}
ImGearDICOMDisplaySettings displaySettings = (ImGearDICOMDisplaySettings) rasterPage.getDICOMDisplaySettings();

ImGearAnnotationPage Class

ImGearAnnotationPage Class is an abstract class that does not have any public members. If the application works with annotations, it shall cast an ImGearAnnotationPage to the actual class ImGearARTPage Class, defined in the imagegear2.art.jar archive.

ImGearFormatMetadata Class

The getTIFF, setTIFF, getEXIF, setEXIF, getIPTC, setIPTC, getDICOM, setDICOM, getXMP, and setXMP methods of ImGearMetadataHead Class, defined in the imagegear2.core.jar file, use ImGearFormatMetadata Class type. ImGearFormatMetadata Class does not have any public members. If the application uses Simplified Metadata API, it shall cast the results of getTIFF, getEXIF, getIPTC, getDICOM and getXMP properties to actual classes ImGearTIFFMetadata class, ImGearEXIFMetadata class, ImGearIPTCMetadata class, ImGearDICOMMetadata class and ImGearXMPMetadataRoot class, respectively. These classes are defined in the imagegear2.formats.simplifiedmetadata.jar file. The following two examples demonstrate this:

Java Example Copy Code
ImGearPage imGearPage;

// Load an image into ImGearPage

String description = "<Empty>";
if (imGearPage.getMetadata().getXMP() != null) {
       ImGearXMPMetadataRoot xmp = (ImGearXMPMetadataRoot) imGearPage.getMetadata().getXMP();
       if ((xmp.getDublinCore() != null)
            && (xmp.getDublinCore().getDescription() != null)
            && (xmp.getDublinCore().getDescription().getDefault() != null))
       {
            description = xmp.getDublinCore().getDescription().getDefault();
       }
}


%%ItemTitle%%

ImageGear for Java | Accusoft
Image and ImGearPage
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Image and ImGearPage

Glossary Item Box

One of the primary entities in the ImageGear for Java toolkit is page and its implementation as the ImGearPage Class.

ImGearPage Class consists of three main parts: image data, metadata, and region of interest.

Image data (or simply, image) is available for manipulations through the getDIB method, which returns an object of type ImGearDIB. Color space, channels, width, and height are major attributes which define image structure.

ImageGear for Java considers an image as a collection of channels, each of which gives some single piece of information about the pixels in a whole image. Channels are defined as an array of depths for each channel. Depth specifies the quantity of different values for a particular channel. This data is constant for the page until image processing functions are applied. It may be accessed through the ImGearDIB.getChannelDepths method.

The ImGearColorSpace class (returned by the ImGearDIB.getColorSpace method) defines the semantics of the information stored in all channels (i.e., whether the second channel is the green component of RGB color, magenta of CMYK, or alpha value of a grayscale image). This information may be formed from ImGearColorSpaceIDs Enumeration flags and placed into a constructor of ImGearPage Class via an ImGearColorSpace object.

Pixels in ImGearDIB class may be accessed as both individual pixels or groups of pixels. GetPixelCopy method and UpdateColumnFrom method are examples of such members. An important note is that the routines to get pixels return copies of the data stored in an image as an object of the ImGearPixel class or the ImGearPixelArray class. None of these members allows direct access to the pixel store.

To gain direct access to image data, the GetImage method or GetRaster method of the ImGearDIB class should be used. This is an efficient way to implement image processing routines, since all changes made to the objects (returned by these functions) will be reflected in the image. Users of the GetImage method or GetRaster method should completely understand the structure of the internal pixel store to avoid producing ill-formed images.

The following example creates an RGB image and then swaps the red and blue channel values for diagonal pixels.

Example Copy Code
// Creates page with RGB colorspace and 8 bits channels.
ImGearPage igPage = new ImGearRasterPage(pageSize, pageSize,
    new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
    new int[] { 8, 8, 8 },
    true);

// Iterates all rows in created page.
for (int row = 0; row < igPage.getDIB().getHeight(); ++row)
{
    // Obtains reference to raster store.
    ImGearArrayRef igArrayRef = igPage.getDIB().GetRaster(row);
    // Casts content to byte[] since all channels are 8 bit.
    byte[] raster = igArrayRef.Content.getBytes();
    // Offset of diagonal pixel in raster.
    int pixelOffset = igArrayRef.Offset + row * igPage.getDIB().getChannelCount();
    // Swaps red & blue.
    byte red = raster[pixelOffset + redChannel];
    raster[pixelOffset + redChannel] = raster[pixelOffset + blueChannel];
    raster[pixelOffset + blueChannel] = red;
}

Metadata is non-image data, often available in some complex formats like TIFF or PNG. It may have complexity and is completely dependent on the nature of the file format. To provide a way of manipulating such data, ImageGear for Java offers a set of classes composed from ImGearMetadataNode Class, ImGearMetadataNodeList Class and ImGearMetadataTree Class and their descendants. For a particular ImGearPage instance, metadata may be accessed through the getMetadata method.

Region of interest (ImGearROI Class) represents a free-shape image area (rectangular, non-rectangluar, or entire space) and specifies a meaningful part of an image. For example, a region of interest may be established to define an area where some image processing functions should be applied.


%%ItemTitle%%

ImageGear for Java | Accusoft
Loading/Saving Pages and Documents
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Loading/Saving Pages and Documents

Glossary Item Box

ImGearFileFormats Class should be used to load/save images. It offers the LoadPage, SavePage, LoadDocument and SaveDocument methods for these purposes. Each of these members loads or saves an image from or to an IGStream object.

ImageGear only supports saving to streams that have the seek ability.

The following example demonstrates how to load a single page from a local file:

Example Copy Code
ImGearFileStream fileStream = null;
ImGearPage page = null;
try {
    fileStream = new ImGearFileStream("photo.jpg", "r");
    page = ImGearFileFormats.LoadPage(fileStream, 0);
} finally {
    if (fileStream != null) {
        fileStream.close();
    }
}

The next examples demonstrates how to load an image from a URL.

Example Copy Code
URLConnection connection = null;
URL serverAddress = null;
InputStream inputStream = null;
IGMemoryStream igms = null;

try {
    serverAddress = new URL("http://www.google.com/intl/en_ALL/images/logo.gif");
    connection = (URLConnection) serverAddress.openConnection();

    inputStream = connection.getInputStream();

    igms = new IGMemoryStream();

    byte[] buffer = new byte[1024];
    int bytesRead;
    while ((bytesRead = inputStream.read(buffer, 0, buffer.length)) != -1) {
        igms.Write(buffer, 0, bytesRead);
    }

    igms.setPosition(0);

    ImGearPage page = ImGearFileFormats.LoadPage(igms, 0);

    if (page != null) {
        // do something with the image
    }

} finally {
    if (inputStream != null) {
        inputStream.close();
    }
}

The next example demonstrates how to save a particular page of a multipage document into a separate file:

Example Copy Code
ImGearDocument igDocument;
ImGearFileStream localFile = null;
ImGearFileStream output = null;

try {
    localFile = new ImGearFileStream("multipage.tif", "r");

    int pageCount = ImGearFileFormats.GetPageCount(localFile, ImGearFormats.UNKNOWN);
    igDocument = ImGearFileFormats.LoadDocument(localFile, 0, pageCount);

    if (igDocument != null) {
        output = new ImGearFileStream("firstPage.tif", "rw");
             ImGearFileFormats.SavePage(igDocument.getPages().getItem(0), output, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.TIF_G4);
    }
} finally {
    if (localFile != null) {
        localFile.close();
    }

    if (output != null) {
        output.close();
    }
}

Also refer to the following sections:

  • Pixel Format Conversion during Image Saving
  • Using Filter Control Parameters


%%ItemTitle%%

ImageGear for Java | Accusoft
Pixel Format Conversion during Image Saving
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Loading/Saving Pages and Documents > Pixel Format Conversion during Image Saving

Glossary Item Box

ImageGear supports a variety of pixel formats (color spaces and channel depths). However, most image file formats support only a limited set of pixel formats. For example, PNG format does not support CMYK color space, and JPEG Lossy format does not support storing 16-bit per channel pixel values. ImageGear provides conversion from a source image's pixel format into one of the pixel formats supported by the destination image file format.

Availability of a specific pixel format for saving depends on the requested compression, saving options, and filter control parameters.

ImageGear uses the following logic to select the pixel format for saving:

  • If the format filter directly supports saving of the image's pixel format, ImageGear uses this pixel format;
  • Otherwise, if the format filter supports saving of pixel formats that exceed the image's pixel format (so no image quality degradation occurs), ImageGear uses the one that takes least storage space;
  • Otherwise, ImageGear uses the pixel format that results in least degradation of image quality.

A special case is when the image color space has to be converted, and multiple choices of channel depths are available. In that case, ImageGear selects channel depths that are equal to the image's channel depths, rather than larger channel depths. This results in a slightly worse quality degradation, but avoids an unexpected increase in image size. For example, PNG format does not support CMYK color space, but it supports storing 8- or 16-bits per channel. ImageGear saves a 32-bit CMYK to PNG as 24-bit RGB rather than 48-bit RGB.

ImageGear does not support conversion from multichannel truecolor color spaces (RGB, CMYK, etc.) into an indexed color space during saving.

Use ImGearSaveOptions.ConversionMode Property to specify the acceptability of image quality degradation or bit depth promotion during saving.

Use ImGearSaveOptions.ForceColorspace Property to make ImageGear use a specific color space for saving.


%%ItemTitle%%

ImageGear for Java | Accusoft
Using Filter Control Parameters
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Loading/Saving Pages and Documents > Using Filter Control Parameters

Glossary Item Box

Many format filters in ImageGear have control parameters that effect filter operations, such as image reading and writing. Those parameters may be declared by the format specification, or they may be specific to the format implementation by ImageGear.

There are two ways to specify filter control parameters:

  • Specify parameters globally - This affects all format reading and writing operations, and threads in the process. Use the Filters static property of the ImGearFileFormats Class to set parameters globally.
  • Specify parameters locally - This effects only one reading or writing operation, and thus can be used for setting different parameters in different threads. To specify the local parameters, create an instance of ImGearFileFilters Class, assign it to ImGearLoadOptions.Filters property or ImGearSaveOptions.Filters property, and pass the Load or Save options object to the reading or writing method, correspondingly.

    The following example sets a global control parameter:

    Example

             Copy Code
    IImGearFormat JpgFormat = ImGearFileFormats.getFilters().Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.getParameters().GetByName("SaveType");
Param.setValue(0); // Lossy
ImGearFileStream output = null;

try {
    output = new ImGearFileStream("lossy.jpg", "rw");
    ImGearFileFormats.SavePage(igPage, output, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG);
} finally {
    output.close();
}

    The following example sets a local control parameter:

    Example Copy Code
    ImGearFileFilters localFilters = new ImGearFileFilters();
IImGearFormat JpgFormat = localFilters.Get(ImGearFormats.JPG);
ImGearControlParameter Param = JpgFormat.getParameters().GetByName("SaveType");
Param.setValue(0); // Lossy
ImGearFileStream output = null;
ImGearSaveOptions SaveOptions = new ImGearSaveOptions();
SaveOptions.setFilters(localFilters);

try {
    output = new ImGearFileStream("lossyLocal.jpg", "rw");
    ImGearFileFormats.SavePage(igPage, output, 0, ImGearSavingModes.OVERWRITE, ImGearSavingFormats.JPG, SaveOptions);
} finally {
    output.close();
}


%%ItemTitle%%

ImageGear for Java | Accusoft
Processing Images
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Processing Images

Glossary Item Box

Using the ImGearProcessing Class and the ImGearRasterProcessing Class it is possible to manipulate an image in different ways:

  • Resize, crop, rotate and flip may be done with the identical members of the ImGearProcessing class.
  • Change of contrast, brightness and/or gamma correction are available through InvertContrast method, AdjustContrast method and other members of the ImGearRasterProcessing class.
  • To convert from one color representation to another (e.g., from RGB to CYMK, or RGBA to Grayscale, or 8-bit color to 32-bit color) ConvertColorSpace and ChangeChannelDepths methods of the ImGearRasterProcessing class can be used.
  • A combination of two images into a new one may be created using the Merge, CombineChannels, and Blend methods.
  • The alpha channel may be utilized though the BlendWithAlpha and ConvertColorSpace methods.


%%ItemTitle%%

ImageGear for Java | Accusoft
Working with Color Profiles
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Color Profiles

Glossary Item Box

ImageGear for Java supports color profiles while performing color conversion operations. ImageGear can apply the embedded image profile as well as the global color profile for display. See ImGearRasterPage.getColorProfile and ImGearRasterPage.setColorProfile methods and the ImGearColorProfileManager class.

Detailed information about color processing based on profiles can be found at www.color.org.

The following sections describe how color profiles can be used with ImageGear:

  • Color Profile Basic Concepts
  • ImageGear Color Profile API
  • Saving Image Files with Embedded Color Profiles


%%ItemTitle%%

ImageGear for Java | Accusoft
Color Profile Basic Concepts
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Color Profiles > Color Profile Basic Concepts

Glossary Item Box

It is often necessary to use color profiles in order to obtain desirable results when converting image data between color spaces such as CMYK and RGB. Different color spaces have different gamuts, or sets of colors that can be represented. Color profiles contain complex mappings that make it possible to carefully manage the translations of colors between different color spaces and gamuts.

A color profile defines instructions for how to map colors from a particular color space to and from a special intermediate color space known as the PCS a profile connection space. There are different ways to do this mapping, representing different tradeoffs and processes, so it is possible to use a wide variety of color profiles. Color profiles typically exist for different input and output devices, such as scanners, cameras, monitors, and printers. Their mappings take into account the physical device characteristics.

When performing color space conversion using color profiles, it is necessary to define a source color profile whose color space matches the color space of the image being converted, as well as a destination color profile whose color space matches the color space to which the image is to be converted.

In addition to source and destination color profiles, a rendering intent is also specified. The rendering intent allows additional control over the conversion process by indicating how certain tradeoffs should be made. For more information, see the ImGearRenderingIntents Enumeration and the ICC color profile specifications at www.color.org.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Color Profile API
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Color Profiles > ImageGear Color Profile API

Glossary Item Box

ImageGear for Java offers two ways to specify color profiles to use for color conversion operations.

  • The first way is a global profile storage system that allows implicit use of color profiles throughout ImageGear.
  • The second way involves explicit specification of profiles when calling certain overloads of methods such as ImGearRasterProcessing.ConvertColorSpace Method.

Both ways are easy to use, and you should use whichever one suits your particular application's needs.

To enable implicit or "automatic" usage of color profiles for color conversion operations, use the ImGearColorProfileManager Class. The ImGearColorProfileManager Class and its methods allow enabling and disabling the automatic use of global color profiles for color space conversion and display operations. You can enable or disable global profiles using the setEnableProfiles method, and specify global color profiles via the setCmykProfile method and setRgbProfile method. Once you have done this, these profiles will be used for the color space conversion. If a profile is associated with a particular image via the ImGearRasterPage.setColorProfile method, that profile will be used instead of a global profile as the source profile in a color space conversion. For example, the following code sets the global profiles and converts an image from CMYK to RGB:

Example Copy Code
ImGearColorProfileManager.setEnableProfiles(true);
IGStream igStream = null;

try {
    igStream = new ImGearFileStream("ig_cmyk_profile.icm", "r");
    ImGearColorProfile cmyk = new ImGearColorProfile(igStream);
    ImGearColorProfileManager.setCmykProfile(cmyk);
} finally {
    if (igStream != null) {
        igStream.close();
        igStream = null;
    }
}

try {
    igStream = new ImGearFileStream("ig_rgb_profile.icm", "r");
    ImGearColorProfile rgb = new ImGearColorProfile(igStream);
    ImGearColorProfileManager.setRgbProfile(rgb);
} finally {
    if (igStream != null) {
        igStream.close();
        igStream = null;
    }
}

ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage) igPage,
        new ImGearColorSpace(ImGearColorSpaceIDs.RGB));

To use explicit specification of color profiles, call the method ImGearRasterProcessing.ConvertColorSpace Method or overload it. The conversion operation will use the color profiles specified by the parameters, ignoring any settings of the ImGearColorProfileManager Class object. For example, the following code converts an image from CMYK to RGB by explicitly specifying color profiles:

Example Copy Code
ImGearColorProfileManager.setEnableProfiles(true);
IGStream igStream = null;

ImGearColorProfile igColorProfileSource, igColorProfileDest;

try {
    igStream = new ImGearFileStream("ig_cmyk_profile.icm", "r");
    igColorProfileSource = new ImGearColorProfile(igStream);
} finally {
    if (igStream != null) {
        igStream.close();
        igStream = null;
    }
}

try {
    igStream = new ImGearFileStream("ig_rgb_profile.icm", "r");
    igColorProfileDest = new ImGearColorProfile(igStream);
} finally {
    if (igStream != null) {
        igStream.close();
        igStream = null;
    }
}

ImGearRasterProcessing.ConvertColorSpace((ImGearRasterPage) igPage,
        new ImGearColorSpace(ImGearColorSpaceIDs.RGB),
        igColorProfileSource, igColorProfileDest, ImGearRenderingIntents.PERCEPTUAL);


%%ItemTitle%%

ImageGear for Java | Accusoft
Saving Image Files with Embedded Color Profiles
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Color Profiles > Saving Image Files with Embedded Color Profiles

Glossary Item Box

ImageGear supports saving color profiles when saving image files. Currently, ImageGear embeds color profiles in the following file formats:

  • JPEG
  • PNG
  • TIFF

Use the setEmbedColorProfile method of ImGearSaveOptions Class to enable or disable embedding of color profiles in image files. By default embedding of color profiles in image files is enabled. When embedding of color profiles in image files is enabled (default), ImageGear saves the color profile to the file being saved. If the destination format supports the image color space, ImageGear saves the color profile attached to the image, or global color profile selected in ImageGear for this color space. If the color space selected for saving does not match the (in-memory) image color space, ImageGear converts the image to the destination color space, using the global color profile for the destination color space, and saves global color profile to the file.

When embedding of color profiles in image files is disabled, ImageGear does not save the color profile to the destination file. It converts the image to the global color profile during saving. ImageGear also uses this logic for formats that do not support embedded color profiles.


%%ItemTitle%%

ImageGear for Java | Accusoft
Working with Spot Colors
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Spot Colors

Glossary Item Box

This section provides information about working with Spot Colors.

  • Color Channels
  • ImageGear Support


%%ItemTitle%%

ImageGear for Java | Accusoft
Color Channels
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Spot Colors > Color Channels

Glossary Item Box

The following types of color channels are currently supported by ImageGear for reading, writing, and display:

  • Alpha Channel
  • Extra Channel

Alpha Channel

An Alpha channel defines opacity/transparency of an image. Only one Alpha channel per image can exist. Color space with Alpha channel can be pre-multiplied or non-pre-multiplied. This is the common definition of an Alpha channel, used by most file formats, such as TIFF, PNG, SGI, TGA, etc.

Extra Channel

An Extra channel is any channel besides regular color channels or Alpha. There can be any number of Extra channels per image. Extra channels may have some defined semantics, such as Mask or Spot channels, or can be "Unknown", meaning that ImageGear does not know how to display or process them.

Mask Channel

A Mask channel specifies a mask or selection in the image. There can be any number of mask channels per image. Images are never pre-multiplied by mask channels. In ImageGear, a Mask channel is a subtype of Extra channel.

Spot Channel

A Spot channel uses a specific color. The color can be specified using a standard color space, such as RGB or CMYK, or using a custom color, such as Pantone, TRUMATCH, etc. The custom spot color is defined by its Vendor ID and Color ID.

Existing Vendor IDs:

  • 3000 (ANPA)
  • 3001 (Focoltone)
  • 3002 (PantoneCoated)
  • 3003 (PantoneProcess)
  • 3004 (PantoneProSlim)
  • 3005 (PantoneUncoated)
  • 3006 (Toyo)
  • 3007 (Trumatch)
  • 3008 (HKSE)
  • 3009 (HKSK)
  • 3010 (HKSN)
  • 3011 (HKSZ)
  • 3012 (DIC)
  • 3013 (PantoneMatte)
  • 3020 (PantonePastelCoated)
  • 3021 (PantonePastelUncoated)
  • 3022 (PantoneMetallic)
  • 3024 (HKSEProcess)
  • 3025 (HKSKProcess)
  • 3026 (HKSNProcess)
  • 3027 (HKSZProcess)
  • 3028 (PantoneProSlimEuro)
  • 3029 (PantoneProcessUncoated)

In ImageGear, a Spot channel is a subtype of Extra channel.

Unknown Channel

Unknown channel is an additional channel whose purpose is unknown to ImageGear. In ImageGear, Unknown channel is a subtype of Extra channel.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Support
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Spot Colors > ImageGear Support

Glossary Item Box

This section provides information about the ImageGear support of Spot colors.

  • Extra Color Space
  • Reader, Writer and Format Converter
  • Color Books

Extra Color Space

An image may contain multiple Extra channels. An Extra channel can belong to one of the following subtypes: Mask, Spot, or Unknown. These channels can be mixed in arbitrary order. ImageGear does not use separate values from the ImGearColorSpaceIDs Enumeration for Mask and Spot channels. Instead, it uses the ImGearColorSpaceIDs.Ex and ImGearColorSpaceIDs.Unknown values to specify presence of any of these channels in an image.

ImageGear stores an array of ImGearExtraChannelInfo Classes in ImGearDIB Class. The length of this array must always be equal to the number of extra channels in the DIB. DIB constructors, color space and channel manipulation functions must ensure this.

If an entry of the info array is ImGearSpotChannelInfo Class, then the corresponding Extra channel is a Spot channel. The ImGearSpotChannelInfo Class contains information that is necessary for displaying the spot channel. ImageGear uses spot color channels for display and color space conversions, and saves them to output files when supported by the format. If the output format does not allow storing additional channels, ImageGear converts Spot channels, together with regular color channels, to the destination color space.

If an entry of the info array is ImGearMaskColorChannelInfo or ImGearMaskSpotChannelInfo then the corresponding Extra channel is a Mask channel. ImageGear uses Mask channels for display and saves them to output files when supported by format. However, it does not use them in color space conversions. If the output format does not allow storing additional channels, ImageGear ignores Mask channels in conversion to the destination color space.

If an entry is ImGearExtraChannelInfo Class, then the corresponding Extra channel is unknown. It is not used in display and color conversions, but preserved and saved to output files when possible.

Spot Color, Mask, and Extra channels can be appended after any regular color channels, in any order, including color spaces that contain an Alpha or Pre-multiplied Alpha channel.

Reader, Writer and Format Converter

ImageGear for Java can load extra channels from TIFF and PSD file formats. The extra channels are internally stored as specified above and saved back as extra channels when the output format is either TIFF or PSD. Spot color support is added to the raster color conversion mechanism, so when saving an image to a format that does not support extra channels the image spot channels are get blended to the base channels. The alpha channels are skipped in this case.

Color Books

ImageGear for Java can load Adobe Color Books and apply the loaded colors for displaying spot channels. Color books API allows loading color books from file, enumerates loaded books and colors within a book, and retrieves info on the specific spot color. Processing code uses color books to convert spot colors to regular colors such as CMYK, RGB, etc.


%%ItemTitle%%

ImageGear for Java | Accusoft
Working with Transparent Color
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Working with Transparent Color

Glossary Item Box

Reading and writing of transparent color is supported for GIF, PNG, and XPM file formats.

Transparent color is automatically extracted from the image file and attached to ImGearPage.Transparency Field. This color will be transparent on display.


%%ItemTitle%%

ImageGear for Java | Accusoft
Non-Image Data Processing
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Non-Image Data Processing

Glossary Item Box

Such complex file formats as EXIF, TIFF, JPEG-JFIF, PNG and some others contain a lot of non-image data generally referred to as metadata. ImageGear provides functionality to read the metadata during image loading, to store it with the image in memory, and modify metadata during image saving.

ImageGear for Java provides two sets of API for working with non-image data:

  • General Metadata API - This set of API provides unified access to metadata of all supported image formats. Non-image data itself can be of any possible complex type and completely depends on the nature of the file format itself. ImageGear processes this complex data through a single interface and provides uniform processing that does not depend on the actual data format and varies from information fields of such simple formats as BMP and PCX, up to the complex EXIF and IPTC metadata support in such filters as TIFF and JPEG.
  • Simplified Metadata API - This set of API provides access to standard tags of specific complex formats, such as TIFF, EXIF, and IPTC. It takes care of the location of particular tags in the metadata tree, decodes and encodes complex metadata values, and provides structures and enumerations for data types according to the metadata standard.

ImageGear for Java is responsible for translating this format-dependent data into a standard uniform format. As soon as an image is loaded, its metadata is accessible through ImGearPage.Metadata Property and ImGearDocument.Metadata Property objects.

You do not need to load image pixels to obtain the non-image data. Use the ImGearFileFormats.LoadPageHeader method to load DIB info and metadata without loading pixel data.

This section provides information about the following:

  • Common Non-Image Data
  • Accessing Non-Image Data
  • Metadata Dictionary
  • Updating File Metadata without Updating its Pixel Data

Common Non-Image Data

ImageGear for Java uses its Metadata API to provide information that is common for all image file formats, such as compression of file page from which the image was loaded.

Use the ImGearMetadataHead.getCommon method to access common metadata.

Accessing Non-Image Data

ImageGear for Java uses different storage for Document level metadata and Page level metadata:

Document level metadata is only used with file formats that are capable of storing multiple pages. This metadata includes only values that are common for all pages of the image. Page level metadata is available for all file formats. It includes data that describes an image page. Different file formats use different metadata structures and tags. When saving an image to a file format that differs from the format of metadata attached to the image, the image's metadata is ignored, and default metadata is created instead.

ImageGear uses a tree structure to store format metadata. All nodes of the metadata use a common parent class: ImGearMetadataNode Class. The two following classes are derived from it:

ImGearMetadataLeaf Class can only contain data and no nested nodes; ImGearMetadataTree Class can contain the nested nodes, but cannot contain the data values. A special node of type ImGearMetadataHead Class is always present in every ImGearPage Class and ImGearDocument Class as a class instance. It cannot be attached to any metadata node, and it can only have one child. If the page or document has metadata, then a metadata tree is attached to this Head node. Otherwise, the Head does not have child nodes.

A node can be un-referenced or referenced from the one parent, but it cannot be referenced from multiple parents. The node cannot reference itself directly or indirectly. ImageGear checks this when the node is attached to another node. A metadata tree cannot be shared between multiple pages or documents.

Every metadata node has Format Field of ImGearMetadataFormats Enumeration type. This allows you to store, for example, EXIF metadata under TIFF metadata. A Format Field value of ImGearMetadataFormats.UNKNOWN can be used to indicate a custom/unknown format.

The actual data in ImGearMetadataLeaf Class uses the System.Object type. The NativeType Field of the ImGearMetadataLeaf Class object specifies the type of data that is used by a file format.

Several leaves can reference the same object. ImageGear does not check or maintain consistency between an image and the metadata attached to it. For example, if an image loaded from a TIF file is resized, ImageGear does not update ImageWidth and ImageHeight tags in the image metadata. However, when you save this image, the correct values will be written to the file.

Metadata Dictionary

ImageGear provides a metadata dictionary that stores necessary information for all known metadata tags of all supported formats.

The application can obtain an information record for any tag that is present in the dictionary, using ImGearMetadataDictionary.LookUp Method.

All tag information records implement the IImGearMetadataDictRecord Interface. This interface provides minimal information for a tag, its name. This is sufficient for most ImageGear supported formats. These formats use ImGearCommonMetadataDictRecord Structure for storing tag information. This structure only contains the tag and its name.

Dictionary records for DICOM tags contain the additional fields ValueRepresentation and MaxMultiplicity. ImageGear uses ImGearDICOMMetadataDictRecord Class to store DICOM tag information.

ImageGear contains an expansive set of predefined dictionary records. In addition, the dictionary allows adding new records for new or custom tags that are not present in the predefined dictionary. The dictionary also allows overwriting predefined information for a tag with a custom one. Use this ImGearMetadataDictionary.AddRecord method for this.

Use the ImGearMetadataDictionary.Reset method to reset the dictionary to its initial state. This method removes all records that were added by the AddRecord method, and leaves only predefined records.

The metadata dictionary only affects the General Metadata API. It does not affect the Simplified Metadata API.

Updating File Metadata without Updating its Pixel Data

There are cases when an application needs to update the metadata of an image file while leaving its pixel data unchanged. For example, if the image is compressed using a Lossy compression scheme, this avoids degradation of image quality.

Use ImGearFileFormats.UpdatePageMetadata Method to update metadata in an image file without changing its pixel data.

Currently, the method only supports updating metadata in the DICOM file format.


%%ItemTitle%%

ImageGear for Java | Accusoft
Warnings and Errors
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Warnings and Errors

Glossary Item Box

ImageGear for Java uses the Java exception handling model and reports exceptional conditions and errors by throwing an exception containing specific information about the condition or error. It is important to note that not only can instances of ImageGear for Java exception classes can be thrown from ImageGear for Java code, but instances of exception classes defined by the Java language can be thrown.

ImageGear defines the ImGearException class to represent errors and exceptional conditions during execution of its code. Although this class has a public constructor, the ThrowError member may also be used to create and throw an exception, providing it with an appropriate value from the ImGearErrorCodes Enumeration.

The ImGearException Class is used to report critical errors (i.e., when incorrect parameters are specified or internal errors occur). However, to report minor and non-critical mistakes (i.e., an inconsistency of the metadata or image attributes in ImGearPage Class entered into the SavePage Method of the ImGearFileFormats Class), the toolkit uses two other types, the ImGearWarning class and the ImGearAddWarning interface. To use this functionality, the developer should create a class that implements the ImGearAddWarning interface and override the invoke method. Then, the developer should use the ImGearWarning.setAddWarning method to specify an instance of their ImGearAddWarning implementation will be used when a warning is reported. When a warning is reported, the invoke method of the ImGearAddWarning object will be invoked.


%%ItemTitle%%

ImageGear for Java | Accusoft
Using com.accusoft.imagegear.art Package
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using com.accusoft.imagegear.art Package

Glossary Item Box

Using the com.accusoft.imagegear.art package, you can annotate any image that your application loads into ImageGear. The annotations are called "ART marks", or "marks" for short. Marks objects are created using their constructors, but their actual life starts when they are added into the ImGearARTPage Class. ART page can be associated with one or more ImGearPage Class objects. The association is done by using ImGearPageDisplay Class properties: setPage method and setARTPage method. Your application can save an image with the marks into a separate file in legacy .ART file format or .XML file format. Any time the image is reloaded, the ART marks can be reloaded with a simple function-call.

The com.accusoft.imagegear.art package consists of the marks objects as well as the objects for handling marks.

To enable the com.accusoft.imagegear.art package in your project, specify the following directive:

Java Example Copy Code
import com.accusoft.imagegear.art.*;

This section provides information about the following:

  • Annotation and Redlining
  • Creating, Saving, Loading, Modifying, and Deleting ART Marks
  • Operating with ART Marks
  • WANG Annotation Marks


%%ItemTitle%%

ImageGear for Java | Accusoft
Annotation and Redlining
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using com.accusoft.imagegear.art Package > Annotation and Redlining

Glossary Item Box

ImageGear ART helps developers to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read and write images, with the com.accusoft.imagegear.art package enabled, you can add marking capabilities, such as lines, arrows, and highlighting to document images.

The fundamental "unit" of annotation is called an "ART Mark", or "mark" for short (the original name of ImageGear ART was the "Annotation and Redlining Toolkit"). When the end-user uses your application to annotate an image, (s)he is creating marks. Each mark is defined by some geometry ((x,y) position on the image, height and width, etc.), and (for some marks) textual information (a text string, a date, etc.). While the rest of ImageGear typically works with raster (pixel-based) images, ImageGear ART marks are vector objects and they can be moved, resized, and deleted.

While the marks are vector objects, they typically are intended to be related to some part of the raster image. For example, one of the marks is a digital version of a "PostIt" note (called an "Attach A Note" mark):

Since ImageGear for Java does not offer the same display and viewing features as other versions of ImageGear (e.g. ImageGear for .NET), there are some limitations on the usage of the annotation and redlining support.

ImageGear for Java does not implement graphical components that would allow an end user to apply marks to an image or display marks associated with an ImGearPage. If your application will implement this feature, then it must implement the logic to capture user input (mouse and keyboard events), call the ART API to add marks to an ImGearPage, burn the marks into an in memory copy of the image, and then display the updated image with marks burned in.

Furthermore, ImageGear for Java does not support any interaction with the marks in a graphical user interface, as other versions of ImageGear do. Because of this, some marks like Button, Audio, Encryption, and others may have less utility in an application built with ImageGear for Java than in an application built with ImageGear for .NET or ImageGear Pro. ImageGear for Java can still create these marks and save them to a file, which can be read by an application based on another version of ImageGear. And, the opposite is also true.

Once the marks are added to an image, they can be saved. ART marks can be saved in the following ways:

Save the annotations in a separate .ART or .XML file. "Burn in" the annotations permanently (making them part of the image file). Save the legacy annotations in the image format that supports storing annotations (for example, TIFF files). You may also combine these methods. You can, for example, leave classified information in an ART file and "burn in" non-classified information into the image. The various marks that can be created with ImageGear ART are described in the following table. Please refer to the com.accusoft.imagegear.art package for complete descriptions of the features it supports.

ART 3.0/ART 2.0 Mark | Example
Text |
Line |
Freehand Polyline |
Rectangle |
Ellipse |
Polygon |
Polyline |
Polyline Ruler |
AudioTD> |
Image (your application provides the image used, the one shown here is the one used in the sample program) |
Ruler (when a mark is created the label's numeric value is set according to the image resolution and the chosen measurement unit) |
Protractor |
Encryption (visually looks like a filled rectangle). Can be made transparent when unlocked with a password. |
Button |
Hotspot |
ART 2.0 Mark | Example
Arrow |
Filled Rectangle |
Hollow Rectangle |
Filled Ellipse |
Hollow Ellipse |
Filled Polygon |
Hollow Polygon |
Redaction (looks just like a filled rectangle, but cannot be moved after the marks are written to a file) |
Highlighter Rectangle |
Typed Text |
Text Stamp (automatically set to date and/ore time the mark was created) |
Attach-A-Note |
Text From File (a text file on disk is read, and the text displayed in the mark) |
Pin-Up Text |
Embedded Image (your application provides an image, the one shown here is the one used in the sample program) |
Image Reference (an image file on disk is read and the image in the file is displayed for the mark, the one shown here is just a sample) |


%%ItemTitle%%

ImageGear for Java | Accusoft
Creating, Saving, Loading, Modifying, and Deleting ART Marks
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using com.accusoft.imagegear.art Package > Creating, Saving, Loading, Modifying, and Deleting ART Marks

Glossary Item Box

This section provides information about the following:

  • Creating a Mark via Function Calls
  • Saving ART Marks
  • Loading ART Marks
  • Deleting Marks

Creating a Mark via Function Calls

ART marks are created by using their constructors. For example, a rectangle mark can be created as follows:

Java Example Copy Code
ImGearRGBQuad igRGBQuad = new ImGearRGBQuad(255, 0, 0);
ImGearRectangle igRectangle = new ImGearRectangle(0, 0, 100, 100);
ImGearARTRectangle igARTRectangle = new ImGearARTRectangle(igRectangle, igRGBQuad);

Once it is created, it should be added to the ART page:

Java Example Copy Code
int markID;
ImGearARTPage igARTPage = new ImGearARTPage();
markID = igARTPage.AddMark(igARTRectangle, ImGearARTCoordinatesType.IMAGE_COORD);

Mark attributes can be edited at any time:

Java Example Copy Code
// Get the mark we just added.
igARTRectangle = (ImGearARTRectangle)igARTPage.MarkGet(markID);
igARTRectangle.setOpacity(128);

Saving ART Marks

Once your application has created some marks, they may want to save them somewhere. Your application has the following choices of where to save them:

  • Save them to a separate .ART file. This is a legacy ART storage format supported in old versions of ImageGear for .NET and ImageGear Professional. Using this method, your application will have to keep track of which .ART file goes with which image file, and load them together. Use ImGearART.SavePage methods with ImGearARTSaveType.LEGACY parameter to do this.
  • Save them to a separate .XML file. This is a more flexible and extendable storage format highly recommended for using. Using this method, your application will have to keep track of which .XML file goes with which image file, and load them together. Use ImGearART.SavePage methods with ImGearARTSaveType.XML parameter to do this.
  • Save the ART marks as tags or objects inside the image file. This option is only available for the raster file formats that support storing annotations, like TIFF files. Use the ImGearART.SavePage method that takes an ImGearPage object to do this.
  • Save the ART marks as annotations inside the PDF file. This option is only available for PDF format. Use the ImGearART.SavePage method that takes an ImGearPage object to do this.
  • "Burn In" the ART marks. This converts the ART marks from their native representation to the format of the raster image file. This method usually destroys a lot of their functionality (for instance, once a mark is burned in to a JPEG image, it cannot be moved, resized or hidden). Use the ImGearART.BurnIn method to do this.

.ART files can be read by any other application developed with ImageGear.

Loading ART Marks

Once ART marks have been saved, they can be reloaded (by the same user or a different user, using the same program or using any other ImageGear-enabled application). The way that the marks were saved will determine how they must be reloaded:

  • .ART / .XML / image file / PDF file : Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods and then loads ART page using the appropriate ImGearART.LoadPage Method.
  • Burned In: Your application loads the image using any of the ImGearFileFormats Class Loadxxx methods. The burned-in remains of the marks are loaded as part of the image.

Deleting Marks

Marks are deleted by using ImGearARTPage.MarkRemove methods or RemoveMarks methods.

Marks that are burned-in cannot be deleted.


%%ItemTitle%%

ImageGear for Java | Accusoft
Operating with ART Marks
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using com.accusoft.imagegear.art Package > Operating with ART Marks

Glossary Item Box

This section provides information about the following:

  • Clipboard Operations
  • Iterating Through Marks
  • Mark Groups
  • Statistics

Clipboard Operations

ART marks can be cut from and copied to the clipboard as well as pasted into an image individually or in groups. The ImGearARTPage Class provides the methods to perform clipboard operations.

Iterating Through Marks

Sometimes your application will need to iterate through the marks in an ImGearARTPage Class object. This can be done by using a "foreach" mechanism:

For example, to delete all selected marks, your application would do the following:

Java Example Copy Code
// Build a list of selected marks.
ArrayList<ImGearARTMark> igARTMarks = new ArrayList<ImGearARTMark>();
for (ImGearARTMark igARTMark : igARTPage)
{
    if (igARTPage.MarkIsSelected(igARTMark))
        igARTMarks.add(igARTMark);
}
// Delete the marks.
igARTPage.RemoveMarks(igARTMarks);

Mark Groups

ImGearARTPage Class provides a facility called "mark groups" (or just "groups", for short) that provides a powerful mechanism for implementing application features. Every mark belongs to one and only one group; by default all marks belong to a group with index 0 and named "[Untitled]". Your application can create as many groups as needed - each group is given a unique index. ImGearARTPage Class provides a set of methods that manipulate all of the marks in a group (hide them all, make them all visible, etc.). Your application could use groups to provide annotation layers (each "layer" would simply be a group), so that the user could choose which layer, and thus which set of annotations to view. Alternatively, your application could use groups to provide private annotations (each person would only be able to see "their" annotations).

The various methods that operate on groups are provided by ImGearARTGroup Class and ImGearARTGroupArray Class objects.

Statistics

ImGearARTMark Class provides statistics that characterize a mark; they are values such as Length, Area, and Perimeter and are represented by the ImGearARTMarkStatistics class. Statistics can be accessed through the ImGearARTMark.getStatistics method. These measurements are available in different measurement units, like feet, meters, inches, or in user-defined measurement units. Users can select a needed measurement unit with the ImGearARTMarkStatistics.setUnit method.

To calculate lengths and areas correctly, statistics needs to have resolution values of the current image, which can be set using the ImGearARTMarkStatistics.setResolution method.


%%ItemTitle%%

ImageGear for Java | Accusoft
WANG Annotation Marks
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using com.accusoft.imagegear.art Package > WANG Annotation Marks

Glossary Item Box

The following WANG compatible annotations are supported by ImageGear ART:

  • Image embedded
  • Image reference
  • Straight line
  • Freehand line
  • Hollow rectangle
  • Filled rectangle
  • Typed text
  • Text from file
  • Text stamp
  • Attach-a-Note


%%ItemTitle%%

ImageGear for Java | Accusoft
Using the com.accusoft.imagegear.formats.dicom Package
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.formats.dicom Package

Glossary Item Box

The com.accusoft.imagegear.formats.dicom package provides features that are used with medical and DICOM images. The following sections discuss various aspects of working with these images:

  • Loading and Saving DICOM Images
  • Overlays
  • DICOM Metadata Support


%%ItemTitle%%

ImageGear for Java | Accusoft
Loading and Saving DICOM Images
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.formats.dicom Package > Loading and Saving DICOM Images

Glossary Item Box

Load DICOM images in the same way as you load images of other formats. Use DICOM format options to set specific features for image loading.

Save DICOM images in the same way as you save images of other formats. However, there are a few items that need to be discussed about saving DICOM images. This section provides information about the following:

  • Transfer Syntaxes
  • Saving DICOM Images Using JPEG Compression
  • Saving DICOM Images Using RLE Compression
  • Saving Non-DICOM Images to DICOM Format
  • Saving Multiframe Images

Transfer Syntaxes

There are two ways to specify transfer syntax (compression) for DICOM image saving: SaveFormat parameter, and TransferSyntax DICOM format option. SaveFormat is an easy-to-use shortcut, while TransferSytnax option provides the full selection of transfer syntaxes for image saving.

ImGearSavingFormats | ImGearCompressions | Transfer Syntax
DICOM | AUTO | Defined by SaveSyntax option
DICOM_UNCOMP | NONE | ImplicitLittleEndian
DICOM_RLE | RLE | RLE
DICOM_JPEG | JPEG | JPEG Lossy
DICOM_JPEG2K | JPEG2K | JPEG2K Lossy

Saving DICOM Images Using JPEG Compression

The supported modes are:

  • JPEG Lossy Baseline or Extended
  • JPEG Lossy Baseline Only
  • JPEG Lossless

JPEG Lossy Baseline or Extended

This is the default mode for saving DICOM images with JPEG compression in ImageGear. In this mode:

  • ImageGear saves grayscale images as either 8 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax, or as 9..12 bits per pixel, using "JPEG Extended (Process 2 &amp; 4)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.

If the source image colorspace is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See PixelFormat ConversionduringImageSaving for more details.

As part of JPEG Lossy compression process, ImageGear converts RGB rasters into YCbCr colorspace (or YCC in DICOM terminology) during saving. This conversion is fully encapsulated into the ImageGear JPEG codec; the application should not convert images to YCbCr before saving them to JPEG or DICOM JPEG.

Use one of these ways to save an image as DICOM JPEG Baseline or Extended:

  • Save the image as ImGearSavingFormats.DICOM_JPEG (SaveSyntax parameter is ignored)
  • Save the image as ImGearSavingFormats.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSY
  • Save the image as ImGearSavingFormats.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_2_4

JPEG Lossy Baseline Only

This mode provides compatibility with viewers that do not support JPEG Extended coding process (12-bit images). In this mode:

  • ImageGear saves grayscale images as 8 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Baseline (Process 1)" transfer syntax.

If the source image colorspace is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See Pixel Format Conversion during Image Saving for more details.

As part of the JPEG Lossy compression process, ImageGear converts RGB rasters into YCbCr colorspace (or YCC in DICOM terminology) during saving. This conversion is fully encapsulated into the ImageGear JPEG codec; the application should not convert images to YCbCr before saving them to JPEG or DICOM JPEG.

To save an image as DICOM JPEG Baseline, use ImGearSavingFormats.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_BASELINE_PR_1.

JPEG Lossless

In this mode:

  • ImageGear saves grayscale images as 8-16 bits per pixel, using "JPEG Lossless, Non-Hierarchical (Process 14)" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "JPEG Lossless, Non-Hierarchical (Process 14)" transfer syntax.
JPEG Lossless compression does not involve internal conversion or RGB rasters into YCbCr colorspace (YCC in DICOM terminology).

To save an image as DICOM JPEG Lossless, use ImGearSavingFormats.DICOM saving format, and set SaveSyntax to ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS or ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_14.

Saving DICOM Images Using RLE Compression

DICOM provides a mechanism for supporting the use of Run Length Encoding (RLE) Compression, which is a byte oriented lossless compression scheme.

  • ImageGear saves grayscale images as 8-16 bits per pixel, using "RLE Lossless" transfer syntax.
  • ImageGear saves RGB images as 24 bits per pixel, using "RLE Lossless" transfer syntax.

If the source image color space is different from RGB or grayscale, or the bit depth is greater, ImageGear automatically converts image rasters to one of the supported pixel formats on saving. See Pixel Format Conversion during Image Saving for more details.

Use one of the following to save an image as DICOM RLE:

  • Save the image as ImGearSavingFormats.DICOM_RLE (SaveSyntax parameter is ignored).
  • Save the image as ImGearSavingFormats.DICOM and set SaveSyntax to ImGearDICOMTransferSyntaxes.RLE

Saving Non-DICOM Images to DICOM Format

ImageGear for Java allows saving of non-DICOM images to DICOM format. A default Secondary Capture DataSet is created for such images.

Saving Multiframe Images

The DICOM format is not designed for an easy insertion of pages. The following issues exist:

  • Pages are stored sequentially rather than in arbitrary order. If the image is compressed, replacing a page requires rewriting all subsequent pages.
  • "Number of pages" tag is stored as "Integer string". If, for example, tag is equal to "99", adding a page requires to increase length of this tag, and thus requires rewriting of the whole image.
  • All pages in the file must have the same dimensions and compression.
  • Some DICOM modalities support multiframe images, while others don't.

According to the above issues, DICOM format filter in ImageGear for Java has the following limitations:

  • Only APPEND and OVERWRITE saving modes are supported (see ImGearSavingModes).
  • ImageGear for Java allows appending a page to a DICOM file only if the file already has the "Number Of Pages" tag, and this tag has maximum possible length for an Integer String: 12 bytes.
  • The page being saved must have the same dimensions and compression as existing pages in the file.
  • ImageGear does not check if the image's modality allows multipage images.

If any of the limitations are encountered, ImageGear throws an exception.

To save a multipage image:

  1. Load an image into an ImGearPage.
  2. Save image to a new file (or use OVERWRITE mode).
  3. Load the next image into an ImGearPage.
  4. Save the image to the existing file, using APPEND mode.
  5. Repeat steps 3 and 4 for all pages to be written.

Alternatively, create an ImGearDocument object, loading all images as ImGearPage objects in the document, and save the ImGearDocument as DICOM using the SaveDocument method.


%%ItemTitle%%

ImageGear for Java | Accusoft
Overlays
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.formats.dicom Package > Overlays

Glossary Item Box

An Overlay Plane describes graphics or bit-mapped text that is associated with an Image. It may also describe a Region of Interest in an Image. Each Overlay Plane is one bit deep. Sixteen separate Overlay Planes may be associated with an Image. Overlay data is stored in Overlay Data (60xx,3000).

Use the ImGearDICOM.LoadOverlay method to load graphic overlays from a DICOM DataSet to ART annotations. Use the ImGearDICOM.SaveOverlay to save ART annotations into a DICOM DataSet as overlay data.

DICOM overlays are monochrome images (see DICOM specification PS 3.3 - 2008, C.9.2 Overlay plane module) - pixels from overlay data with a zero value (i.e., black) will not be displayed; pixels with a non-zero value will be displayed.

Upon saving of ART annotations, all non-black pixels of annotations will be saved as overlay data. As a result, a text annotation that has a non-null or non-black fill color will be displayed as a square. To save the text only as an overlay, it is necessary to set the fill color of the annotation to null or black.


%%ItemTitle%%

ImageGear for Java | Accusoft
DICOM Metadata Support
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.formats.dicom Package > DICOM Metadata Support

Glossary Item Box

ImageGear for Java uses its general metadata engine for all file formats, including DICOM. When ImageGear loads a DICOM image, it builds a metadata tree structure and attached it to the new ImGearPage object. Use ImageGear's metadata support classes to access data items in this tree.

A DICOM file includes one header with metadata, and zero, one, or multiple images. Metadata applies to all images in the file. ImageGear loads a copy of DICOM metadata into every loaded page (ImGearPage). DICOM metadata is not loaded into the ImGearDocument object.

See the DICOM section in the ImageGear Imaging Formats Reference chapter information about the detailed structure of the DICOM Metadata tree.

DICOM tags map to ImageGear metadata members as follows:

Tag group number, element number | ImGearMetadataNode.tag Field
Value Representation | ImGearMetadataLeaf.nativeType Field
Value Length | Not stored explicitly. Application can use string and array lengths instead.
Value Multiplicity (Item count) | Not stored explicitly. For values of OB/OW/OF it is always 1. For other Value Representations, if data is singular it is 1, otherwise it is equal to the length of the data array.
Data | ImGearMetadataLeaf.getData and ImGearMetadataLeaf.setData methods

"Sequence" (SQ) tags are represented by nested metadata trees. SQ contains one or more Sequence Items, and cannot contain normal DICOM tags. A Sequence Item contains a set of DICOM tags.

The following tags are read from the file, but not added to the metadata tree:

Group lengths Sequence Delimitation items Item delimitation items The following table lists the mapping between DICOM Value Representations and Java types:

VR | Meaning | System type to which it converts on reading | Allowed system types on writing
AE | Application Entity | String | String
AS | Age String | String | String
AT | Attribute Tag | String | String
CS | Code String | String | String
DA | Date | String | String
DS | Decimal String | double | all numeric primitive types, String
DT | Date Time | String | String
FL | Floating Point Single | float | all numeric types, String
FD | Floating Point Double | double | all numeric types, String
IS | Integer String | long (64-bit) | all integer types, String
LO | Long String | String | String
LT | Long Text | String | String
OB | Other Byte String | byte[] | byte[]
OW | Other Word String | short[] | short[]
PN | Person Name | String | String
SH | Short String | String | String
SL | Signed Long | int | all integer types, String
SQ | Sequence | - | -
SS | Signed Short | short | all integer types, String
ST | Short Text | String | String
TM | Time | String | String
UI | Unique Identifier | String | String
UL | Unsigned Long | int | all integer types, String
UN | Unknown | byte[] | byte[]
US | Unsigned Short | short | all integer types, String
UT | Unlimited Text | String | String
OF | Other Float String | float[] | float[], double[]

For types other than OB, OW and OF, if the sy

For types other than OB, OW and OF, if the system type is an array, a multivalued data element is saved.

Example of conversion on metadata reading:

VR | Tag value | Metadata leaf data type | Metadata leaf value
US | 0x0001 | short | 1
OW | 0x0001 0x0002 0x0003 | short[] | {1, 2, 3}
DS | "0.12345\0.6789" | double[] | {0.12345, 0.6789}
CS | "MR" | string | "MR"
CS | "ORIGINAL\PRIMARY" | string[] | {"ORIGINAL", "PRIMARY"}


%%ItemTitle%%

ImageGear for Java | Accusoft
Using the com.accusoft.imagegear.processing Package
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.processing Package

Glossary Item Box

The com.accusoft.imagegear.processing package API provides various image processing capabilities, including the following image correction, advanced image processing, and image effects methods:

Show All Show All
Hide All Hide All

  • Show Background Correction

    You can add, remove, or find the tilt for a specified image. These methods can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

    Adding Tilt

    The ImGearRasterProcessing.AddTilt method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with the slope of the plane in X direction and the slope of the plane in Y direction, as specified in the arguments.

    Removing Tilt

    The ImGearRasterProcessing.RemoveTilt method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output. This is very handy for correcting illumination gradients in a poorly digitized image.

    Finding Tilt The ImGearRasterProcessing.FindTilt Method computes the least-squares best fit plane for an image. The plane will be given by formula: f(x, y) = SlopeX * x + SlopeY * y + Piston.

  • Show Bi-Linear and Bi-Cubic Interpolation

    ImageGear's implementation of bilinear and bicubic interpolation for image resize is designed for high image quality, especially when resizing large images down to small sizes (e.g., for thumbnail generation). Fine-tuning the sharpness of the resulting image can be done through the ImGearBilinearInterpolationOptions.setSharpness method and the ImGearBicubicInterpolationOptions.setSharpness method.

  • Show Image Enhancement

    This ImGearRasterProcessing.EnhanceLocal method enhances sharpness of an image using the local standard deviation and mean.

    It transforms the input image f(x, y) to a new image g(x, y) based on the following formula,

    g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

    where,

    A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

    To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

    Can be applied only to 8-bit grayscale images with one channel.

  • Mathematical Morphology

  • Show Speckle Removal

    • The ImGearRasterPage.Despeckle method removes the noise from a 1-bit image. For each pixel in the input image, it computes the average value of the neighboring pixels, and then uses the average value as the new value of that pixel in the output image. ImageGear allows you to specify the size of the neighborhood.
    • The ImGearRasterPage.GeomDespeckle method is used to reduce speckle noise from an image by using the Crimmins algorithm. It reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique. The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image. It can be applied only to 8-bit grayscale images with one channel.
  • Gaussian Blur Effect

... and many more.


%%ItemTitle%%

ImageGear for Java | Accusoft
Mathematical Morphology
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.processing Package > Mathematical Morphology

Glossary Item Box

The field of mathematical morphology contributes a wide range of operators to image processing, all based around a few simple mathematical concepts from set theory. The operators are particularly useful for the analysis of binary images. Common usages include edge detection, noise removal, image enhancement, and image segmentation.

The two fundamental operations in mathematical morphology are Erosion and Dilation. Both of these operators take two pieces of data as input: an image to be eroded or dilated, and a structuring element (also known as a kernel). The two pieces of input data are each treated as representing sets of coordinates in a way that is slightly different for binary and grayscale images.

For a binary image, white pixels are normally taken to represent foreground regions, while black pixels denote background. (Note that, in some implementations, this convention is reversed. It is very important to set up input images with the correct polarity for the implementation being used.) The set of coordinates corresponding to that image is simply the set of two-dimensional Euclidean coordinates of all the foreground pixels in the image, with an origin normally taken in one of the corners so that all coordinates have positive elements.

For a grayscale image, the intensity value is taken to represent height above a base plane, so that the grayscale image represents a surface in three-dimensional Euclidean space. The set of coordinates associated with this image surface is simply the set of three-dimensional Euclidean coordinates of all the points within this surface, as well as all points below the surface, down to the base plane. Note that even when we are only considering points with integer coordinates, this is a lot of points, so usually algorithms are employed that do not need to consider all the points.

The structuring element is already just a set of point coordinates (although it is often represented as a binary image). It differs from the input image coordinate set in that it is normally much smaller, and its coordinate origin is often not in a corner, so that some coordinate elements will have negative values. Note that in many implementations of morphological operators, the structuring element is assumed to be a particular shape (e.g., a 3A3 square) and so is hardwired into the algorithm.

Binary morphology can be seen as a special case of grayscale morphology in which the input image has only two gray levels at values 0 and 1.

Erosion and dilation work (at least conceptually) by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image.

Virtually all other mathematical morphology operators can be defined in terms of combinations of erosion and dilation together with set operators such as intersection and union. Some of the more important are Opening and Closing.

Erosion

Erosion is one of the fundamental operations in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to erode away the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels shrink in size, and holes within those areas become larger. Applying this to the grayscale image will make bright objects smaller, that is, the image will be darker.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of dilation, the effect is the opposite.

For more information, see the ImGearRasterProcessing.Erode method.

Dilation

Dilation is one of the fundamental operators in the mathematical morphology. It is usually applied to black and white images, but can also be applicable to grayscale ones. The basic effect of the operation is to gradually enlarge the boundaries of regions of foreground pixels (white pixels). Thus, areas of foreground pixels grow in size while holes within those regions become smaller. Applying this to the grayscale image will make bright objects larger, that is, the image will be lighter.

Both erosion and dilation work by translating the structuring element to various points in the input image, and examining the intersection between the translated kernel coordinates and the input image coordinates. For example, in the case of erosion, the output coordinate set consists of just those points to which the origin of the structuring element can be translated, while the element still remains entirely "within" the input image. In the case of erosion, the effect is the opposite.

For more information, see the ImGearRasterProcessing.Dilate method.

Opening

Opening is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. The basic effect of an opening is somewhat like erosion in that it tends to remove some of the foreground (bright) pixels from the edges of regions of foreground pixels. However it is less destructive than erosion in general. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve foreground regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of foreground pixels.

For more information, see the ImGearRasterProcessing.Open method.

Closing

Closing is another operation from mathematical morphology that is derived from the fundamental operations of erosion and dilation. Like those operators it is usually applied to black and white images, but can be applicable to grayscale images as well. Closing is similar in some ways to dilation in that it tends to enlarge the boundaries of foreground (bright) regions in an image (and shrink background color holes in such regions), but it is less destructive of the original boundary shape. As with other morphological operators, the exact operation is determined by a structuring element. The effect of the operator is to preserve background regions that have a similar shape to this structuring element, or that can completely contain the structuring element, while eliminating all other regions of background pixels.

For more information, see the ImGearRasterProcessing.Close method.


%%ItemTitle%%

ImageGear for Java | Accusoft
Gaussian Blur Effect
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.processing Package > Gaussian Blur Effect

Glossary Item Box

The ImGearRasterProcessing.GaussianBlur method will smooth the images using Gaussian transform. It makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening, and take more processing time. The width of the area considered for each pixel is approximately 6 * radius.


%%ItemTitle%%

ImageGear for Java | Accusoft
Using the com.accusoft.imagegear.processing.layers Package
Send Feedback |
ImageGear for Java User Guide > Using ImageGear for Java > Using the com.accusoft.imagegear.processing.layers Package

Glossary Item Box

ImageGear allows users to load layered image files and retain image layers for editing. Users can also create new layers and delete existing ones, as well as flatten and display the selected layers.

ImageGear currently supports layers for Adobe PSD and large PSD (Adobe PSB) file formats.

The com.accusoft.imagegear.processing.layers package provides a set of API for working with layers.

Layer

Layers are used to specify different elements of an image. There are different types of layers. They represent a part of an image either as image pixels or as adjustment instructions. They are stacked on top of each other producing the resulting appearance of the image. ImageGear supports the image layers described in the next section.

Image Layer

Image Layer is a type of layer containing image pixels which can be applied/blended with other layers. The image from the Image Layer can cover the same area as the resulting image or just a part, specified by its rectangle. The Image Layer is associated with a certain opacity and other properties.

Layered Page

An ImageGear layered page is a raster image page containing the composition of layers. Layers associated with an image page can be blended in the order in which they appear to provide the resulting page. The result of such blending represents the final image view and is stored in the page's DIB.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Imaging Formats Reference
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference

Glossary Item Box

This chapter provides information about the image formats that ImageGear supports. Before you begin, please refer to the Encoding vs. Compressing section below to familiarize yourself with the terms used in this Chapter.

The Format Suitability at a Glance section briefly delineated which formats best support various types of images. This section provides you with a starting point for deciding which file formats to use in your application.

The section ImageGear Support for Graphics File Formats describes the types of imaging file formats supported by ImageGear and provides useful information about support for some specific formats:

  • Support for Adobe PDF/PS Formats
  • Support for DICOM File Format
  • Support for JPEG2000 File Formats
  • Support for Metafile Formats
  • Support for Multi-Page File Formats

ImageGear Supported Bit Depths section describes the bit depths, and the read/write capabilities of the supported formats. Using this table, you can easily find out whether an image can be converted to a particular format.

If you are going to use ImageGear alpha channels support, please review the section ImageGear Alpha Channel Support.

Detailed information about every ImageGear supported imaging file format or compression can be found in the following sections:

  • ImageGear Supported Compressions Reference - here you will find information for every ImageGear supported imaging compression.
  • ImageGear Supported File Formats Reference - provides detailed information about every ImageGear supported format, its ID, versions, encoding type, multi-page and alpha channel support, supported compressions, color spaces and bit depths for read and write, as well as information about ImageGear supported features and filter control parameters.

The section ImageGear Supported Non-Image Data provides detailed information about ImageGear supported metadata.

Encoding vs. Compressing

These two words are often used interchangeably in discussions of graphics file formats. Encoding is actually a broad term under which compression falls. For the sake of clarity, use these terms separately with the following intended meanings:

  • Encoding - The manner that data is stored when uncompressed (binary, ASCII, etc.), how it is packed (e.g., 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.
  • Compressing - A "physical" rewriting of the graphics data so that it is represented by a smaller set of data.


%%ItemTitle%%

ImageGear for Java | Accusoft
Format Suitability at a Glance
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > Format Suitability at a Glance

Glossary Item Box

The following table contains the formats that Accusoft considers most practical for the listed type of data, and can be used as a starting point. You can use a format with the appropriate character depth and one that provides either the most efficient use of space, or the fastest loading and saving capabilities.

Bear in mind that the following table represents recommendations only. To make an informed choice, read about each format in more detail in the section ImageGear Supported File Formats Reference.

Image Type | Recommended
Colors | JPEG, TIFF, PNG
grayscale/many shades | TGA, TIFF, JPEG, DICOM
Monochrome / high resolution | TIFF (CCITT Group 3 Compression), TIFF (CCITT Group 4 Compression)
Banking data | IBM IOCA
Noisy | Color: PNG, TIFF, JPEG
Lossless | GIF, TIFF, PNG, JPEG (Lossless JPEG Compression)
Lossy | TIFF (JPEG Compression), JPEG
Extra data to store | TIFF
Iconic images | ICO
Multimedia | PNG, GIF, JPEG
Photographic images | Adobe PSB, Adobe PSD, PCD, JPEG
Internet images | GIF, JPEG, PNG, JPEG2000, WBMP
PC paint programs and/or graphics arts | PCX, GEM, TIFF, BMP
X Windows | XBM, XPM, XWD
Medical data | DICOM
Document processing | TIFF, Adobe PDF, Adobe PS, PTOCA


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Support for Graphics File Formats
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Support for Graphics File Formats

Glossary Item Box

Every application that deals with images has specific kinds of data to store and interchange, from icons to photographs. The various hardware devices used to record and store the graphics data, and the hardware intended to display or print the data also effect the design of the format. This leads to a diversity of file formats. To add to this diversity, different groups of people have different ideas about how to structure and access an image, and what kind of additional information should be stored with an image. Even formats designed to store the same kind of data can differ. Other factors that effect the outcome of the design include memory considerations, storage size, accuracy, and portability.

National and international standardization organizations, such as the American National Standards Institute (ANSI) and the International Standards Organization (ISO), seek to create standards of storage for graphics data. One example is the Joint Photographic Experts Group's (JPEG) creation of the JPEG file format. Some of its intended goals were good image quality, user-chosen compression ratio, and cross-platform flexibility. When an image is called a JPEG, it is assumed to precisely follow the standardized JPEG format.

Formats known as "de facto standards" are those that begin as proprietary formats, but by the forces of the market and sometimes by good quality, become widely supported. Some examples of de facto standards are BMP, GIF, and PCD.

A third group of file formats falls somewhere between officially recognized standards and the strictly proprietary formats. These formats are created by groups of individuals with a common interest who come together to form a more unofficial standards organization. These formats are usually intended to provide an end-all industry standard so that data with the same or similar origins can be shared across different applications or platforms. One example is the TIFF format. TIFF was designed by eight computer technology companies (headed by Aldus Corporation) with the common goal of providing a standard format for storing scanned images.

ImageGear supports graphics file formats from all of these genres, providing you with a complete range of imaging capabilities, including the capture and processing of scanned images.

In addition, ImageGear functionality enable you to exchange data easily from one format to another, and to make improvements in images using powerful image-processing API.

ImageGear list of supported formats includes all of the popular raster formats, including recognized standards that best utilize the latest imaging technologies.

Supported imaging file formats:

  • Support for DICOM File Format
  • Support for Metafile Formats
  • Support for Multi-Page File Formats

Support for DICOM File Format

ImageGear provides comprehensive support for DICOM formats using its com.accusoft.imagegear.formats.dicom package.

To use the support for DICOM format as well as manipulate, transform, and process DICOM images, add the DICOM format to ImageGear's global formats list, as follows:

Java Example Copy Code
ImGearFileFormats.getFilters().Insert(0, ImGearDICOM.CreateDICOMFormat());

Support for Metafile Formats

Metafiles contain vector (or geometric) specifications and bitmap pixel data. ImageGear supports the WPG metafile format. Vector data is ignored; only the bitmap data is read and/or written.

Support for Multi-Page File Formats

  • BMP (OS/2 BMP only)
  • CUR
  • DCX
  • DICOM
  • GIF
  • IBM IOCA
  • IBM MO:DCA
  • ICO
  • IFF
  • PCD
  • PTOCA
  • TIFF


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Supported Bit Depths
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Bit Depths

Glossary Item Box

You may want to convert a file from one format to another. You can do this by saving the original file to its desired format by setting the nFormatType parameter to the appropriate value in the saving function. For more information on converting issues, see the section Loading/Saving Pages and Documents.

When saving a file to another format, remember to ensure that the desired file format is supported for that image. For example, you cannot convert an 8-bit DCX file to an 8-bit CAL file, because the CAL format does not support 8-bit files.

In the tables on the following pages, the columns underneath the numbers indicated size in bits that can actually be saved (written). The columns underneath the letters "R" and "W" indicate that the ImageGear reads and writes, respectively, the corresponding file format.

Format | R | W | 1 | 4 | 8 | 9-16G | 24 | 32 | 36 | 48 | 64
Adobe PSB 1 | + | + | + | + | + | + | + | + |  | + | +
Adobe PSD 2 | + | + | + | + | + | + | + | + |  | + | +
BMP | + | + | + | + | + | + | + | + 3 |  |  |
BTR | + | + | + |  |  |  |  |  |  |  |
CAL | + | + | + |  |  |  |  |  |  |  |
CLP | + | + | + | + | + |  | + |  |  |  |
CUR 4 | + | + | + | + | + |  |  | + |  |  |
CUT | + | + |  |  | + |  |  |  |  |  |
DCX | + | + | + | + | + |  | + |  |  |  |
DIB | + | + | + | + | + | + 5 | + | + 6 |  |  |
DICOM | + | + | + |  | + | + | + | + |  | + |
GEM | + |  | + | + | + |  |  |  |  |  |
GIF | + | + | + | + | + |  |  |  |  |  |
IBM IOCA | + | + 7 | + | + | + |  | + |  |  |  |
IBM MO:DCA | + | + 8 | + | + | + |  | + |  |  |  |
ICO | + | + | + | + | + |  |  | + |  |  |
IFF | + | + | + | + | + |  | + |  |  |  |
IMG | + |  | + |  | + |  |  |  |  |  |
IMR | + |  | + |  |  |  |  |  |  |  |
IMT | + | + | + |  |  |  |  |  |  |  |
JPEG | + | + |  |  | + 9 | + | + | + | + | + |
KFX | + |  | + |  |  |  |  |  |  |  |
LV | + |  | + |  |  |  |  |  |  |  |
MSP | + |  | + |  |  |  |  |  |  |  |
NCR | + | + | + | + 10 |  |  |  |  |  |  |
PBM | + | + | + |  | + | + | + |  |  | + |
PCD | + |  |  |  |  |  | + |  |  |  |
PCX | + | + | + | + | + |  | + |  |  |  |
PGM 11 | + | + |  |  | + | + |  |  |  |  |
PNG 12 | + | + | + | + | + | + | + | + |  | + | +
PNM 13 | + | + | + |  | + | + | + |  |  | + |
PPM | + | + |  |  |  |  | + |  |  | + |
PTOCA | + |  |  |  | + |  |  |  |  |  |
RAS | + | + | + | + 14 | + |  | + |  |  |  |
Scitex CT 15 | + | + |  |  |  |  |  | + |  |  |
SGI | + | + |  |  | + | + | + | + |  |  |
TGA | + | + | + |  | + | + | + | + |  |  |
TIFF 16 | + | + | + | + | + | + | + | + | + | + | +
WBMP | + | + | + |  |  |  |  |  |  |  |
WPG | + |  | + | + | + |  |  |  |  |  |
XBM | + | + | + |  |  |  |  |  |  |  |
XPM | + | + | + | + | + |  | + 17 |  |  |  |
XWD | + | + | + | + | + |  | + |  |  |  |

Table Footnotes:

  1. 48- and 64-bit images support is Read only.
  2. 48- and 64-bit images support is Read only.
  3. Read only support.
  4. Supports Extra ((1, 3, 4, 8)*2)-bit images also.
  5. Read only support.
  6. Read only support.
  7. Write support for 1-bit images only.
  8. Write support for 1-bit images only.
  9. 8-bit grayscale.
  10. Read only support.
  11. Supports 16-bit grayscale images also.
  12. Supports 48(RGB)- and 64(RGB+alpha)-bit images.
  13. Supports 16-bit grayscale and 48-bit color images also.
  14. Read only support.
  15. The native format is CMYK. With full CMYK support enabled, you can use 32-bit images.
  16. Read only supports also 3- and 6 bpp for RGB and LAB color spaces for Deflate Compression, LZW (Lempel-Ziv-Welch) Compression, Packbits Compression compressions and uncompressed.
  17. 24-bit has Read only support.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Alpha Channel Support
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Alpha Channel Support

Glossary Item Box

ImageGear provides alpha channel support for the following file format filters:

Format | Support
Adobe PSB | Supports single Alpha channel for Read only. Supports additional Alpha channels as ImageGear Extra channels for Read only.
Adobe PSD | Supports single Alpha channel for Read only. Supports additional Alpha channels as ImageGear Extra channels for Read only.
CUR | Supports single 8-bit alpha channel for read/write. Supports single 1-bit alpha channel for read only.
ICO | Supports single 8-bit alpha channel for read/write. Supports single 1-bit alpha channel for read only.
JPEG | Supports single Alpha channel for Read/write.
PNG | Supports single Alpha channel for read/write.
SGI | Supports single alpha channel for read and write.
TGA | Supports single alpha channel for read and write.
TIFF

Supports single Alpha channel for read and write. Supports additional Alpha channels as ImageGear Extra channels for read and write. The following compressions are supported with alpha channel:

  • Uncompressed
  • Packed Bits
  • LZW
  • Deflate


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Supported Compressions Reference
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Compressions Reference

Glossary Item Box

All imaging files compressions can be divided on three basic types:

  • One-dimensional compression - the raster data is treated as one continuous data stream. Each byte read is compared to the previous byte. This compression method is not concerned with delineating lines of data.
  • 2D compression can be thought of as "Differencing Compression", where the data stored is a representation of the differences in data values from previous data values. In 2-D compression, the encoding of one line is determined by the contents of the previous line. This method of compression is best used for black-and-white images where the black pixels tend to fall into groups.
  • 3D compression is a new branch of data compression aimed at the 3D models and other geometric datasets used in computer graphics, virtual reality, video games, CAD/CAM, and many scientific, engineering, and medical applications. Existing 3D compression algorithms use both techniques adapted from the 1D and 2D cases (like wavelets, entropy coding, and predictive coding), and completely different approaches that take advantage of the properties of 3D surfaces (like Edgebreaker, Subdivision Surfaces, and triangle strips).

ImageGear supports the following compressions:

Show All Show All
Hide All Hide All

  • Show ASCII Compression

    Full Name | American Standard Code for Information Interchange (ASCII)
    Compression ID | ImGearCompressions.ASCII = 23
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
    File Formats | PBM, PGM, PNM, PPM
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    Acronym for the American Standard Code for Information Interchange. ASCII is a code for representing English characters as numbers, with each letter assigned a number from 0 to 127. For example, the ASCII code for uppercase M is 77. Most computers use ASCII codes to represent text, which makes it possible to transfer data from one computer to another.

    Text files stored in ASCII format are sometimes called ASCII files. Text editors and word processors are usually capable of storing data in ASCII format, although ASCII format is not always the default storage format. Most data files, particularly if they contain numeric data, are not stored in ASCII format. Executable programs are never stored in ASCII format.

  • Show CCITT Group 3 Compression

    Full Name | CCITT Group 3
    Compression ID | ImGearCompressions.CCITT_G3 = 3
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1
    File Formats | BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    This is a 1-D version of the CCITT Group 3 compression scheme. It uses a static table of values to assign codes to run lengths. Frequently occurring run lengths are given smaller codes. (The most frequent are usually black runs of 2 or 4 pixels).

  • Show CCITT Group 3 2D Compression

    Full Name | CCITT Group 3 2D
    Compression ID | ImGearCompressions.CCITT_G32D = 5
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1
    File Formats | BTR, IBM IOCA, IBM MO:DCA, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    This is a 2-D version of the CCITT Group 3 compression scheme. It includes an error recovery algorithm for error transmissions; an error in one line does not translate to garbage output for the rest of the file. All modern fax machines support this format.

  • Show CCITT Group 4 Compression

    Full Name | CCITT Group 4
    Compression ID | ImGearCompressions.CCITT_G4 = 4
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1
    File Formats | CAL, IMR, KFX, BTR, IBM IOCA, IBM MO:DCA, IMT, LV, NCR, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    The G4 compression is two-dimensional by default. It is very similar to the G3 2D compression, but it can produce compressed images that are half the size of a G3-compressed file.

    It is slower, however, and does not have the same error recovery built in that the G3 format has. The decrease in speed occurs because G4 was designed specifically for encoding disk data. For this reason, it may be advisable to use the G3-Fax compression scheme if final compression size is not crucial, but speed is.

  • Show Deflate Compression

    Full Name | Deflate compression
    Compression ID | ImGearCompressions.DEFLATE = 14
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1, 2, 4, 8, 16 bpc
    File Formats | TIFF, PNG
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    "Zip-in-TIFF" compression. Deflate compression, sometime known as "zip" compression, uses another variant of the LZW compression method and so gives similar results, but is not restricted by any licenses.

  • Show Huffman Compression

    Full Name | Huffman encoding
    Compression ID | ImGearCompressions.HUFFMAN = 2
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | Any
    File Formats | NCR, PCD, TIFF, NEF, PEF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    Developed in 1952 by David Huffman, this is one of the older compression methods. The encoding and decoding processes are complex relative to todayas standards, but the compression ratio can be high if the image contains many repeat data values. It is best used for images with little or no pixel noise, e.g., cartoons or drawings with large areas of the same color and intensity (like a monotone sky). This compression scheme is often used by other compression algorithms for extra compression.

    The Huffman method uses a conversion table to assign codes for each value, based on frequency of occurrence. The file is scanned for all of its values, with the values and their frequency of occurrence tallied. Using a binary tree, values are paired off by frequency of occurrence, beginning with the least frequent values. As the tree progresses upward, the least occurring values at the bottom of the tree continue to be incremented a bit at a time, with one bit added for each new branch added to the tree. In the end, the values that occur the most (at the top of the tree) have the shortest codes.

    A potential problem with this compression method is decoding; the fileas variable-length codes can cause the dropping or adding of a bit to the end of a line, thereby throwing off subsequent lines of data.

  • Show IBM MMR Compression

    Full Name | IBM Modified Modified Read
    Compression ID | ImGearCompressions.IBM_MMR = 15
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1
    File Formats | IBM IOCA, IBM MO:DCA
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    Compression for black and white documents, similar to CCITT Group 4.

  • Show JPEG Compression

    Full Name | JPEG compression
    Compression ID | ImGearCompressions.JPEG = 6
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
    File Formats | JPEG, DICOM, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    This file compression method obtains a high compression ratio when used with detailed photographic images (its intended use). It is not a good compression choice for images with a small number of colors and high contrast edges, or for color-mapped data. Part of JPEGs success in high compression is due to the fact that it is a "lossy" compression method, meaning that the compression results in the loss of some data that is determined to be unimportant or unnecessary. This does not necessarily result in a visible reduction of image quality.

    JPEG is highly flexible - it allows you to make a "quality" setting that determines the amount of loss that occurs and effects the size of the resulting compressed file.

    The JPEG algorithm takes into account that the human eye is more sensitive to changes in brightness than to number of colors. Rather than saving the color data from each pixel in an image, it saves information on the rate of change of color, or "frequency information." More loss is allowed in the color data than in the brightness data. Some of the compression of the color is achieved by converting the RGB values to YCbCr color scheme. ImageGear supports two other JPEG compression modes--Lossless JPEG and Progressive JPEG.

    • Show Lossless JPEG Compression

      Full Name | Lossless JPEG compression
      Compression ID | ImGearCompressions.JPEG = 6
      ImageGear JAR File | imagegear2.core.jar
      Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 48 bpp
      File Formats | JPEG, DICOM, TIFF
      IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

      Comments

      Lossless JPEG is an extension to the normal JPEG standard. One of the main algorithmic differences between the two is that the lossless JPEG does not apply a Discrete Cosine Transform. Rather, it uses a Predictive scheme. For each pixel, the values of one or several neighboring pixels are added to the value of the original pixel and then subtracted from the value of the original pixel. This method yields smaller values that require fewer bits per pixel to store.

      ImageGear allows you to set the number of neighboring pixels to use in calculating the "predictor value".

    • Show Progressive JPEG Compression

      Full Name | Progressive JPEG compression
      Compression ID | ImGearCompressions.JPEG = 6
      ImageGear JAR File | imagegear2.core.jar
      Bit Depth | Gray level: 8, 16 bpp; RGB: 24, 36 bpp; CMYK: 32 bpp; RGB+Alpha: 32 bpp
      File Formats | JPEG
      IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

      Comments

      Progressive JPEG is considered an extension to the JPEG standard. It produces the same kind of lossy compression as normal JPEG compression (see above), except that it saves multiple copies of the same image using different levels of quality. There is no hard limit on the number of "scans" that may be stored.

      When a Progressive JPEG-compressed image is decompressed, the filter decompresses the lowest quality image first. This can be helpful for quickly displaying a version of the image that you are loading. The benefit of this compression is the fast display of an image that is recognizable. The downside is that a JPEG decompression is performed more than once.

  • Show LZW (Lempel-Ziv-Welch) Compression

    Full Name | Lempel-Zif-Welch (LZW) compression
    Compression ID | ImGearCompressions.LZW = 8
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1, 4, 8, 16 bpc
    File Formats | GIF, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    LZW compression works by finding patterns of data and assigning codes. It works best on highly-patterned images. Images with irregular patterning, or "noise," are not good candidates for this type of compression.

    This compression scheme is "dictionary-based". This refers to the array of codes that identify each data pattern found in the image. The "dictionary" begins with a table that contains a code for each possible value in the image. If LZW compression is used on 8-bit images, a LZW "dictionary" is initialized with codes for 256 (28) values. As the file data is read, new values are added to the table for each unique pattern of data found. In the interest of saving space, the dictionary is not saved with the compressed file. The same dictionary is actually rebuilt when the data is decoded.

  • Show Packbits Compression

    Full Name | Packed bits compression
    Compression ID | ImGearCompressions.PACKED_BITS = 1
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1, 4, 8, 16 bpc
    File Formats | Adobe PSD, TIFF
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    Packbits compression seeks repeated data values. Packbits is considered an RLE (run-length encoding) compression scheme because it looks for "runs" or repeated values, and tallies their number, or "length". While its name implies that runs of bits are "packed" together, it is actually runs of bytes. It is very similar to the Macintosh Packbits compression used by Macpaint, except that the Packbits compression used for a TIFF allows the dimensions of the image to vary.

    Packbits works by reducing repeated strings of the same characters into two components: the "run count" and the "run value". The count and value are stored in one byte each. Each two-byte grouping is referred to as an RLE packet. It is not a good compression scheme for images with large color ranges, as these do not tend to have many runs of the same color.

  • Show RAW Compression

    Full Name | RAW compression (Uncompressed binary compression)
    Compression ID | ImGearCompressions.RAW = 2
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | Gray level: 1, 8, 16 bpp; RGB 24, 48 bpp
    File Formats | PBM, PGM, PNM, PPM
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    Uncompressed binary compression. PBM, PGM, PNM, PPM formats use the term "RAW" for uncompressed binary compression, as opposed to ASCII compression.

  • Show RLE Compression

    Full Name | Run length encoding compression
    Compression ID | ImGearCompressions.RLE = 7
    ImageGear JAR File | imagegear2.core.jar
    Bit Depth | 1, 4, 8, 16 bpc
    File Formats | BMP, CLP, CUT, DCX, DICOM, GEM, IFF, MSP, PCX, RAS, SGI, TGA, WPG
    IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

    Comments

    RLE (Run Length Encoding) is normally a 1-dimensional compression scheme. Working sequentially from left to right and top to bottom, it compares the value of each byte with the value of the previous byte. Each data value is recorded into a "packet" of two bytes where the first byte contains the number of times the value is repeated, and the second packet contains the actual value. The bytes in the pocket are called the "run count" and the "run value". When an image contains many repeat values, the compression ratio is very high (for example, if every byte in a 100 byte image were the same, its size could be reduced to 2 bytes giving a 50:1 ratio). A very noisy image, or a plain ASCII text file typically does not compress well, and in fact could become larger for example, if all bytes in image are different from the ones next to them, the image doubles, because 2 bytes are used to store each byte in the image.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Supported File Formats Reference
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference

Glossary Item Box

This section represents the reference for every imaging file format supported by ImageGear.

The following are the characteristic features for file format description:

  • Full Name - Full name of the File Format
  • Format ID - ImageGear constant that determines the File Format ID used for loading this file in ImageGear-based application.
  • File Extension(s) - The used extensions of the File Format
  • Data Type - The type of the File Format (raster, vector, metafile)
  • Data Encoding - The type of data encoding. Please see the section Encoding vs. Compressing.
  • IG Multipage Support - Shows if ImageGear supports the File Format as multipage or singlepage. Please see also the section Support for Multi-Page File Formats.
  • IG Alpha Channel Support - Shows if ImageGear supports the alpha channel for the File Format or not. Please see also the section ImageGear Alpha Channel Support.
  • IG Platforms Support - Shows ImageGear platform versions that support the File Format.
  • ImageGear Supported versions - Shows the versions of the File Format supported by ImageGear.
  • ImageGear Supported Features - Shows the ImageGear Format Filter features supported by ImageGear for this format.
  • ImageGear Read Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format reading.
  • ImageGear Write Support - Provides all compressions, color spaces, channels and bit depths supported by ImageGear for the file format writing.
  • ImageGear Filter Control Parameters - Provides all filter control parameters supported by ImageGear for this format filter.
  • Comments - Some general information about format encoding and compression structure.
  • References Used - References to the information sources for the File Format.

Currently ImageGear supports the following File Formats:

Format | Read/Write | Description
Adobe PSB | Read/Write | Adobe Photoshop Big
Adobe PSD | Read/Write | Adobe Photoshop
BMP | Read/Write | Standard Windows format including OS/2 bitmap format
BTR | Read/Write | Brooktrout FAX format, Group III or Group III 2D or 301
CAL | Read/Write | CALS raster, Type I
CLP | Read/Write | Windows Clipboard format for raster images
CUR | Read/Write | For reading Windows 3.x and Windows95 mouse cursor display
CUT | Read/Write | Dr. Halo CUT format
DCX | Read/Write | Intel multi-page FAX format
DIB | Read/Write | DIB (Microsoft Windows Device Independent Bitmap)
DICOM | Read/Write | DICOM is a public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images. Requires ImageGear.Formats.DICOM package.
GEM | Read | GEM Paint Raster format
GIF | Read/Write | Graphic Image Format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm
IBM IOCA | Read/Write | Image Object Content Architecture, Group III, Group III 2D, Group IV, IBM MMR, uncompressed
IBM MO:DCA | Read/Write | Mixed Object Document Content Architecture format, Group III, Group III 2D, Group IV, IBM MMR, uncompressed
ICO | Read/Write | Windows ICON format
IFF | Read/Write | Electronic Arts format
IMG | Read | Xerox raster format, Group IV
IMR | Read | IMRS-Raster image format
IMT | Read | IMNET format, Groups III and IV
JPEG | Read/Write | ANSI-standard, full-color image format; IG supports all aspects of this format including lossless and progressive; JFIF - industry standard header for JPEG compressed images
KFX | Read | Kofax format, Group IV
LV | Read | LaserView, LaserData, Group IV
MSP | Read | Microsoft Paint format
NCR | Read/Write | NCR Group IV format
PBM | Read/Write | Portable BitMap (UNIX graphic file format)
PCD | Read | Kodak format for high resolution photographs
PCX | Read/Write | PC Paintbrush format
PGM | Read/Write | Portable BitMap (UNIX graphic file format)
PNG | Read/Write | Portable Network Graphics, intended as successor to GIF
PNM | Read/Write | Portable BitMap (UNIX graphic file format)
PPM | Read/Write | Portable BitMap (UNIX graphic file format)
PTOCA | Read | Presentation Text Object Content Architecture support for IBM's AFP printer architecture
RAS | Read/Write | SUN raster format
Scitex CT | Read/Write | For electronic pre-press and visual communications systems, part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols
SGI | Read/Write | Silicon Graphics raster format
TGA | Read/Write | Targa file format. ImageGear supports many aspects of this format including alpha channel
TIFF | Read/Write | Tagged Image File Format; IG supports every aspect of this format
WBMP | Read/Write | Optimized to support mobile computing devices that use the Wireless Application Protocol (WAP)
WPG | Read | Wordperfect Graphic Format. IG reads bitmaps stored in this format
XBM | Read/Write | X Windows Bitmap format
XPM | Read/Write | X Windows Pixmap format
XWD | Read/Write | X Windows Dump format


%%ItemTitle%%

ImageGear for Java | Accusoft
Adobe PSB
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > Adobe PSB

Glossary Item Box

Full Name | PSB (Adobe Photoshop Big)
Format ID | ImGearFormats.PSB
File Extension(s) | *.psb
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Supports pre-multiplied Alpha and additional Alpha mask channels as ImageGear Extra channels.
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
LoadFirstExtraChannelAsAlpha boolean false false, true

This parameter specifies how ImageGear should load the first extra channel of a PSB image. If false , ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel.

If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.

ReadLayerIndex | int | -1 | Any integer, but no more than number of layers | When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure

Adobe PSB/PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSB/PSD metadata design allows reading and writing the following non-image data:

Tag name | Tag ID | Description
Signature | ImGearPSDTagIDs.SIGNATURE | Adobe Photoshop Signature: always equal to '8BPS'.
Version | ImGearPSDTagIDs.VERSION | Version: always equal to 1.
Rows | ImGearPSDTagIDs.ROWS | The height of the image in pixels. Supported range is 1 to 30,000.
Cols | ImGearPSDTagIDs.COLS | The width of the image in pixels. Supported range is 1 to 30,000.
Depth | ImGearPSDTagIDs.DEPTH | Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode | ImGearPSDTagIDs.MODE | The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength | ImGearPSDTagIDs.MODE_LEN | The length of the following color data provided by tag ColorData.
ColorData | ImGearPSDTagIDs.COLOR_DATA | The color data.
PhotoshopResources | ImGearPSDTagIDs.PHOTOSHOP_RESOURCES | Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers | ImGearPSDTagIDs.LAYERS | Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount | ImGearPSDTagIDs.LAYER_COUNT | Number of layers in the Photoshop Image.
Header | ImGearPSDTagIDs.HEADER | This section contains the basic properties of the image.
RESERVED_HDR | ImGearPSDTagIDs.RESERVED_HDR | Reserved: must be zero.
Channels | ImGearPSDTagIDs.CHANNELS | The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA | ImGearPSDTagIDs.IPTC_NAA | File information (IPTC-NAA record 2).

Comments

The PSB (Photoshop Big), or Large Document format, is a newer version of PSD designed for files over 2 gigabytes, supporting up to 300,000 pixels in any dimension. The PSB format is identical to the Photoshop native format (PSD) in many ways.

The PSB/PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSB/PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSB/PSD file.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: OaReilly & Associates, Inc., 1996.


%%ItemTitle%%

ImageGear for Java | Accusoft
Adobe PSD
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > Adobe PSD

Glossary Item Box

Full Name | PSD (Adobe Photoshop)
Format ID | ImGearFormats.PSD
File Extension(s) | *.psd
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Supports pre-multiplied Alpha and additional Alpha mask channels as ImageGear Extra channels.
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 2.0
  • Version 2.5
  • Version 3.0
  • Version 8.0

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha + Extra: 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpc;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp;
    • RGB + Alpha: + Extra 8, 16 bpc;
    • RGB + Extra: 8, 16 bpc;
    • CMYK: 32, 64 bpp;
    • CMYK + Alpha: 40, 80 bpp;
    • CMYK + Alpha + Extra: 8, 16 bpc;
    • CMYK + Extra: 8, 16 bpc;
    • LAB + Alpha: 32, 64 bpp;
    • Lab + Alpha + Extra: 8, 16 bpc;
    • Lab + Extra: 8, 16 bpc;
    • HSL + Alpha: 32, 64 bpp;
    • HSL + Alpha + Extra: 8, 16 bpc;
    • HSL + Extra: 8, 16 bpc;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 8 bpp;
    • Grayscale: 8 bpp;
    • Grayscale + Extra: 8 bpp;
    • Grayscale + Alpha: 8 bpp;
    • Grayscale + Alpha + Extra: 8 bpp;
    • RGB: 24 bpp;
    • RGB + Extra: 8 bpc;
    • CMYK: 32 bpp;
    • CMYK + Extra: 8 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
LoadFirstExtraChannelAsAlpha boolean false false, true

This parameter specifies how ImageGear should load the first extra channel of a PSD image. If false , ImageGear loads all extra channels according to their descriptors in the file header. If the channel contains transparency information, ImageGear loads it as Alpha channel. Otherwise IG loads it as Extra channel.

If true, IG loads first extra channel as Alpha channel. This mode provides backward compatibility with previous versions of ImageGear.

ReadLayerIndex | int | -1 | Any integer, but no more than the number of layers | When > -1 specifies a zero based index of layer mask image to load, otherwise reads the composition image.

Non-Image Data Structure

Adobe PSD file format has different non-image data that can be stored before and after an image data. The Adobe PSD metadata design allows reading and writing the following non-image data.

Tag Name | Tag ID | Description
Signature | ImGearPSDTagIDs.SIGNATURE | Adobe Photoshop Signature: always equal to '8BPS'.
Version | ImGearPSDTagIDs.VERSION | Version: always equal to 1.
Rows | ImGearPSDTagIDs.ROWS | The height of the image in pixels. Supported range is 1 to 30,000.
Cols | ImGearPSDTagIDs.COLS | The width of the image in pixels. Supported range is 1 to 30,000.
Depth | ImGearPSDTagIDs.DEPTH | Depth: the number of bits per channel. Supported values are 1, 8, and 16.
ColorMode | ImGearPSDTagIDs.MODE | The color mode of the file. Supported values are: Bitmap = 0; Grayscale = 1; Indexed = 2; RGB = 3; CMYK = 4; Multichannel = 7; Duotone = 8; Lab = 9.
ColorModeLength | ImGearPSDTagIDs.MODE_LEN | The length of the following color data provided by tag ColorData.
ColorData | ImGearPSDTagIDs.COLOR_DATA | The color data.
PhotoshopResources | ImGearPSDTagIDs.PHOTOSHOP_RESOURCES | Photoshop Image Resource metadata group. Image resources are used to store non-pixel data associated with images.
Layers | ImGearPSDTagIDs.LAYERS | Photoshop Image Layer Info metadata group. Represents high-level organization of the layers information.
LayerCount | ImGearPSDTagIDs.LAYER_COUNT | Number of layers in the Photoshop Image.
Header | ImGearPSDTagIDs.HEADER | This section contains the basic properties of the image.
RESERVED_HDR | ImGearPSDTagIDs.RESERVED_HDR | Reserved: must be zero.
Channels | ImGearPSDTagIDs.CHANNELS | The number of channels in the image, including any alpha channels. Supported range is 1 to 56.
IPTC_NAA | ImGearPSDTagIDs.IPTC_NAA | File information (IPTC-NAA record 2).

Comments

The PSD file is considered by many in the computer graphics arts community as an industry standard.

The PSD is organized into 5 major segments of data: the header, 3 informational blocks, and the bitmap data. The short header always contains a "signature" of 8PPS, as well as these fields: width, height, and bit depth of the bitmap.

The first block of informational data is called the "Color Mode Data Block". It begins with a value for the length of the block. If the image has a palette, it is located here.

The next block is called the "Image Resources Block". Like the previous block, it first gives the length of the block. An ID field is filled with one of many possible values that indicate the structure where the data is stored. It may contain such parameters as resolution.

The last informational block is called the "Layer and Mask Instruction Block". After a value for the length of the block, it tells how many "layer records" follow. There is a record for each layer in the image. Each record begins with a channel ID and the length of the data in the record. After the records, a "Layer Mask" section may be stored, if applicable.

The bitmap data represents the last segment of a PSD file.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: OaReilly & Associates, Inc., 1996.


%%ItemTitle%%

ImageGear for Java | Accusoft
BMP
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > BMP

Glossary Item Box

Full Name | Microsoft Windows Bitmap
Format ID | ImGearFormats.BMP
File Extension(s) | *.bmp, *dib
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Only for OS/2 BMP
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Windows Bitmap version 5 (created for Windows 98, Windows 2000)
  • Windows Bitmap version 4 (created for Windows 95, Windows NT 4.0)
  • Windows Bitmap version 3 (created for Windows 3.x)
  • Windows Bitmap version 2 (created for Windows 2.x)
  • OS/2 Bitmap version 2
  • OS/2 Bitmap version 1

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

Filter Control Parameter | Type | Default Value | Available Values | Description
UpsideDown | boolean | false | false, true | If true then the images will be saved upside-down
Type | int | 1 (BMI, MS Windows format) | 0 (BMC, OS/2 1.x format), 1 (BMI, MS Windows format), 2 (BMI2, OS/2 2.x format). | BMP type to use for saving.
Scanner16GrayEnabbled | boolean | false | false, true | Vidar 12-bit scanner options
Scanner16GrayType | int | 0 | 0, 1 | Vidar 12-bit scanner options: 0 a no particular scanner is specified. 1 a old VXR 12 scanner.

Comments

The BMP format for versions 2.x - 4.x contains two headers. All Windows bitmap files begin with the same first header. They proceed with a data structure containing image information (the Bitmap Information Header), and end with the actual image data. If there is a palette (1, 4, 8-bit images), it is located between the bitmap information and the bitmap image data.

The first header identifies the format as BMP, and stores the file size and the address of the image. Two additional fields, Reserved1 and Reserved2, are not used and are set to 0.

The second header, known as the "bitmap information header", varies across the versions of Windows bitmaps. The second header for all bitmaps from version 2.x to 5.x have in common the following basic set of information: size of the secondary header in bytes, height and width of the image in pixels, the number of bit planes, the number of bits per pixel, compression scheme (0 = uncompressed, 1 = 4-bit RLE compression, 2 = 8-bit RLE compression, 3 = bitfields encoding was used), size of image in bytes, horizontal and vertical resolution in pixels per meter, the number of colors in the image, and the minimum number of important colors.

If the image is 16 or 32-bits per pixel in resolution, the compression field equals 3, and following the header are values for RedMask, GreenMask and BlueMask, rather than a palette. If the file is 4.x, there are values for an alpha component, color space type, x and y coordinates of red, green or blue endpoints, and gamma values for red, green, and blue coordinate scale values. The "ColorsImportant" field accommodates hardware that supports fewer colors than are contained by the image palette. The most significant colors are determined by counting their frequency of appearance. A value of zero means that all the colors in the image are significant.

The palette, or color table, varies in size depending on the number of colors in the image. This value is stored in the "ColorsUsed" field of the Bitmap Information Header. In the BMP format v. 3, the palette's structure is in "RGBQUAD" format. See the section entitled "Palettes" in for more information. 24-bit images do not use a palette, but rather store the color information directly in the image data.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.


%%ItemTitle%%

ImageGear for Java | Accusoft
BTR
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > BTR

Glossary Item Box

Full Name | Brooktrout
Format ID | ImGearFormats.BRK
File Extension(s) | *.brk, *.301,
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

Version 1

ImageGear Supported Features

  • DETECTSUPPORT - autodetect
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G32D - Indexed RGB: 1 bpp

When saving an image, the image must have horizontal resolution of 200 DPI and vertical resolution of 100 or 200 DPI.

ImageGear Filter Control Parameters

None

Comments

A Brooktrout file consists of a CCITT Group 3 (G3) compressed file with a 128-byte header designed by Brooktrout Technology. The header fields include a constant that identifies the file as Brooktrout, a version number, the horizontal and vertical resolutions of the image in dots/mm, the number of bits per pixel, and the number of pixels per line.


%%ItemTitle%%

ImageGear for Java | Accusoft
CAL
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > CAL

Glossary Item Box

Full Name | CALS Raster
Format ID | ImGearFormats.CAL
File Extension(s) | *.cal, *.ras, *.cals
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Type II (Tiles made possible)
  • Type I

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Write Support

ImGearCompressions.CCITT_G4 - Indexed RGB : 1 bpp

ImageGear Filter Control Parameters

None

Comments

The CALS file format was created as a graphics format specification by The Department of Defense to standardize the data exchange of logistics support operations across the military branches and military contractors. It is mandatory for most military document-handling applications. It is no longer used solely by the military and its contractors; other government agencies and commercial businesses have also adopted this format, including the aerospace, commercial computer, and medical industries.

There are two types of CALS files: Type I, and a newer, significantly more complicated Type II. Type II supports the use of tiles. Sometimes it acts a repository for a group of Type I files. Whether or not a Type II contains Type I images determines what kind of compression scheme is used. Type I is supported by ImageGear.

Type I and Type II files begin with a header that has the same format and size. It includes information about the source and destination documents, as well as image characteristics data. The data storage units under the header are each 128 bytes in length, and are referred to as records. These are written with 7-bit ASCII characters, making it more "human-readable" than most file format headers.

The image data follows the header. In a Type II file, if the data is a series of Type I images, the images are encoded with CCITT Group 4 compression. If they are Type II files, the data may either be uncompressed or encoded with CCITT Group 4. In addition, Type II data may be stored in tiles, wherein some, all, or none of the tiles may be compressed.

The Type II file contains several more substructures than Type I. Between the header and the image data are three groups of document formatting data. Other data preceding each image (or images), are "layout information" and a "Tile Index", that contains the address of each tile stored for the image.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
CLP
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > CLP

Glossary Item Box

Full Name | Windows Clipboard
Format ID | ImGearFormats.CLP
File Extension(s) | *.clp
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters

None

Comments

The CLP file format represents a subset of a file format called Pictor PC Paint. The use for PC Paint format is to display images created by the PC Paint application to IBM display hardware (CGA, EGA, VGA, etc.).

The header of a CLP file is fairly short and simple, containing the file size (in bytes), and the height, width, and address of the image. The image data may be compressed or uncompressed. If it is compressed, the header contains two additional fields to give the number of bits per pixel of the packed data, and the address of the beginning of the packed run.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
CUR
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > CUR

Glossary Item Box

Full Name | Windows cursor
Format ID | ImGearFormats.CUR
File Extension(s) | *.cur
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | Single alpha channel for read/write (see Comments).
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

Windows 3.x

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

None

Comments

Cursor files consist of a file header (that is repeated several times), info headers, and cursor data. Cursor data contains an XOR mask bitmap and a monochrome AND mask bitmap. Whenever Windows draws a cursor, the AND bitmap is applied to whatever is on the screen. After that, the XOR bitmap is applied.

Files must be 255x255 pixels or less.

References Used

A Jorn Daub EDV-Beratung - Glashutter Weg 105 - D-22889 Tangstedt

fileformats@daubnet.com


%%ItemTitle%%

ImageGear for Java | Accusoft
CUT
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > CUT

Glossary Item Box

Full Name | Dr. Halo
Format ID | ImGearFormats.CUT
File Extension(s) | *.cut, *.pal (for the separately stored palette)
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Write Support

ImGearCompressions.RLE - Indexed RGB: 8 bpp

ImageGear Filter Control Parameters

None

Comments

The Dr. Halo file format is associated with the HALO Image File Format Library, the Dr. Halo III paint program, and other applications created by Media Cybernetics.

This format consists of two separate files, one with an extension of .CUT and the other with an extension of .PAL. The .CUT file contains the image data and the .PAL file contains the color palette.

The .CUT file begins with a simple header of just three data fields: width and height of the image data (pixels by scan lines), and a reserved field intended for use with any future expansions of the header. The image data is always RLE-encoded and follows the header.

The palette file (.PAL) contains a header, with information about the type of palette used, and the size and maximum values of the Red, Green, and Blue components. The palette can be hardware-specific, in which case it contains additional data.

When a CUT image is loaded into ImageGear, the palette is initialized to a grayscale ramp. In order to achieve the original colors of the palette (PAL file), it must be loaded separately into the ImGearPage image.

When saving an image into the Dr. Halo format, ImageGear creates a .CUT file. In order to save the palette (PAL file), it must be saved separately.

See the RLE Compression (ImageGear Supported Compressions Reference) for more information.

Auto-detection of CUT format (Dr. Halo CUT) is disabled by default. The format is not popular and has unreliable detection. An application can enable auto-detection of the format if needed, using IImGearFormat.setDetectionEnabled method.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
DCX
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > DCX

Glossary Item Box

Full Name | Paintbrush (Intel multi-page FAX format)
Format ID | ImGearFormats.DCX
File Extension(s) | *.dcx
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

This file format was designed to allow multiple PCX files to be stored in one file. This is especially desirable for multi-page faxes (for which the PCX format is often used). Up to 1024 PCX images can be stored in one DCX file.

The DCX construct begins with a simple header, then the PCX files are simply stored end-to-end, complete with their individual headers and palettes. An array in the header called "Pagetable" contains offsets to each PCX. The one piece of vital information not stored with the PCX files under a DCX is their original filenames. See the PCX section of this manual for more about PCX files.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
DIB
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > DIB

Glossary Item Box

Full Name | DIB (Microsoft Windows Device Independent Bitmap)
Format ID | ImGearFormats.DIB
File Extension(s) | *.dib
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

See BMP format description.

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 16, 24 bpp;
    • RGB + Alpha: 32 bpp.
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 15, 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 4, 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
UpsideDown | boolean | false | false, true | If true then the images will be saved upside-down
Type | int | 1 (BMI, MS Windows format) | 0 (BMC, OS/2 1.x format), 1 (BMI, MS Windows format), 2 (BMI2, OS/2 2.x format). | BMP type to use for saving.
Scanner16GrayEnabled | boolean | false | false, true | Vidar 12-bit scanner options
Scanner16GrayType | int | 0 | 0, 1 | Vidar 12-bit scanner options: 0 a no particular scanner is specified. 1 a old VXR 12 scanner.

Comments

DIB is a synonym for the BMP format.


%%ItemTitle%%

ImageGear for Java | Accusoft
DICOM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > DICOM

Glossary Item Box

Full Name | DICOM (Digital Imaging & Communication in Medicine)
Format ID | ImGearFormats.DICOM
File Extension(s) | *.dicm, *.dcm
Data Type | Raster or vector image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

To support DICOM format, import the com.accusoft.imagegear.formats.dicom package along with com.accusoft.imagegear.core.

ImageGear Supported Versions

  • DICOM 3.0, 1991 - 2006

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • PAGEDELETESUPPORT - page deleting from multi-page file (only deletion of the last page is supported)
  • MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1, 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp
    • Vector/waveform data
  • ImGearCompressions.JPEG (lossy):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp, 16 bpp (converted to 24-bit RGB during loading);
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Grayscale: 8, 9-16, 32 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossy - baseline / process 1):
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossy - extended / process 2&4):
    • Grayscale: 8, 9-12 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.JPEG (lossless):
    • Grayscale: 8, 9-16 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8, 9-16 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 24 bpp

  • ImageGear Filter Control Parameters

    Filter Control Parameter | Type | Default Value | Available Values | Description
    DetectContinuousRLE | boolean | true | false, true | Set to true for ImageGear to detect and load images where RLE runs across row boundaries. This parameter specifies what to do with RLE compressed images where RLE runs across row boundaries. If it is set to true , ImageGear tries to detect and load images where RLE runs across row boundaries. Otherwise, ImageGear truncates any row overruns and decodes each row separately. This parameter does not affect the loading of properly encoded images, where each row is encoded separately.
    LoadConcatenateRepeatedDE | boolean | false | false, true | Set to true to concatenate repeated data elements into one data element during loading. **
    LoadDetectSkipDIMSE | boolean | false | false, true | Set to false if files may contain DIMSE commands - that could throw off the format detection
    LoadSavePixdataTag | boolean | false | false, true | Set to true to allow loading and saving pixel data to/from the metadata tree rather than to/from ImageGear DIB.***
    LoadSyntax | ImGearDICOMTransferSyntaxes Enumeration | ImGearDICOMTransferSyntaxes.AUTODETECT | ImGearDICOMTransferSyntaxes Enumeration | Transfer Syntax to load DCM image with.
    LoadWithoutDetection boolean false

    true,

    false

             Set to true to skip detection phase before loading a DICOM image.*
    SaveAsPart10 boolean true

    true,

    false

             true will cause the Header to be saved
    SaveGroupLengths | boolean | true | true, false | true =include; false =exclude
    SavePlanarConfig | ImGearDICOMPlanarConfigurations Enumeration | ImGearDICOMPlanarConfigurations.PIXEL_BY_PIXEL | ImGearDICOMPlanarConfigurations Enumeration | Planar configuration for image saving.
    SaveSyntax | ImGearDICOMTransferSyntaxes Enumeration | ImGearDICOMTransferSyntaxes.DEFAULT | Some ImGearDICOMTransferSyntaxes Enumeration values. **** | Transfer Syntax to save DCM image with.

    *) LoadWithoutDetection parameter effects loading of DICOM images that do not have File Meta Info (Part10) header. If false (default), the DICOM filter checks that the first several Data Elements are well formed, and if they are not, stops the reading. If true, the filter skips checking the first tags, and attempts to read the image, using the Transfer Syntax specified in the LoadSyntax parameter. LoadSyntax parameter should be set to a specific syntax, rather than AUTODETECT, PART10 or UNKNOWN. When loading the file, set the format to ImGearFormats.DICOM using the ImGearLoadOptions.setFormat method. Use this mode if you know for sure the file is a DICOM, and you know its transfer syntax.

    **) Parameter LoadConcatenateRepeatedDE allows you to load incompliant DICOM images where some data elements are cut into several repeated data elements. Instead of one data element containing an array of values, the data set contains several data elements, with the same group/element numbers pair, containing portions of the array. Specifically, there are images with look up tables and palettes stored in this way. Set LoadConcatenateRepeatedDE parameter to true to concatenate repeated data elements into one data element during loading. Otherwise by default, ImageGear loads all of the repeated elements in the same way as they are located in the file. Note that ImageGear does not allow saving of repeated data elements. If a data set contains repeated data elements, ImageGear will only write the first repeated element to the file.

    ***) When LoadSavePixdataTag is true during image loading, ImageGear does not read pixel data into a DIB, but instead creates an empty DIB and loads pixel data into Metadata Tree, so the image will not be displayed. ImageGear represents the PixelData tag in the metadata tree as either byte array or short array, according to Value Representation of PixelData Tag (OB or OW).

    In uncompressed images this array contains uncompressed pixel data. If the image has multiple pages (frames), pixel data of all frames is concatenated in this array.

    In compressed images pixel data always has value representation of OB, so ImageGear represents it as a byte array. Content of this array has rich internal structure, similar to DICOM Sequence of Items. The first item is the Basic Offset Table, which is either empty, or contains offsets to image frames within the array. The rest of items contain compressed frames. At the end of the pixel data there is the sequence delimitation item. ImageGear does not expose this structure to the application. If the application needs to access individual frames, it shall parse this byte array. See DICOM PS 3.5 - 2008, Annex A.4 "TRANSFER SYNTAXES FOR ENCAPSULATION OF ENCODED PIXEL DATA" for additional details.

    If LoadSavePixdataTag parameter is true during image saving, ImageGear uses pixel data from the PixelData tag of the DICOM metadata tree, instead of the ImGearPage DIB. When saving an image in this mode, make sure that saving Transfer Syntax exactly matches the Transfer Syntax of PixelData element. If it is not so, saved image will be incompatible with the standard and most probably unreadable, because transfer syntax of the pixel data will not match transfer syntax specified in file header.

    ****) Currently, the following values of ImGearDICOMTransferSyntaxes Enumeration values are supported:

    ImGearDICOMTransferSyntaxes.DEFAULT

    ImGearDICOMTransferSyntaxes.IMPLICIT_VR_LE

    ImGearDICOMTransferSyntaxes.EXPLICIT_VR_LE

    ImGearDICOMTransferSyntaxes.EXPLICIT_VR_BE

    ImGearDICOMTransferSyntaxes.JPEG_BASELINE_PR_1

    ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_2_4

    ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_PR_3_5

    ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_NONH_PR_6_8

    ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_NONH_PR_7_9

    ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_NONH_PR_10_12

    ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_NONH_PR_11_13

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_14

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_PR_15

    ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_HIER_PR_16_18

    ImGearDICOMTransferSyntaxes.JPEG_EXTENDED_HIER_PR_17_19

    ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_HIER_PR_20_22

    ImGearDICOMTransferSyntaxes.JPEG_SPECTRAL_HIER_PR_21_23

    ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_HIER_PR_24_26

    ImGearDICOMTransferSyntaxes.JPEG_FULL_PROG_HIER_PR_25_27

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_HIER_PR_28

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_HIER_PR_29

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS_NONH_FIRSTORDER_PR_14

    ImGearDICOMTransferSyntaxes.JPEG_LOSSY

    ImGearDICOMTransferSyntaxes.JPEG_LOSSLESS

    ImGearDICOMTransferSyntaxes.JPEG_2K_LOSSLESS_ONLY

    ImGearDICOMTransferSyntaxes.JPEG_2K

    ImGearDICOMTransferSyntaxes.RLE

    Comments

    DICOM is a public standard created to provide a flexible and expandable means for storing, sharing, and transporting digital medical images. Today DICOM is the standard for medical imaging throughout the world.

    DICOM image (alternately called Data Set) contains an ordered collection of attributes referred to as "Data Elements" that are related to one or more images. Each Data Element (DE) describes a single attribute of the image, patient, or study. The images themselves are also stored in DEs.

    Each DICOM Data Set is transported through the Network, and consequently, stored in a file, using one of the defined Transfer Syntaxes. The Transfer Syntax of the DICOM file indicates whether the file uses Big Endian or Little Endian byte order, whether the image data is compressed or uncompressed, and if the DICOM Data Set uses Explicit or Implicit Value Representation (VR).

    The Data Element (DE) is made up of the following parts:

    • Tag
    • Value Representation (optional)
    • Value Length
    • Value

    Tag field identifies the type of information that is contained in the Value field (where the actual data is stored). The DICOM Data Dictionary (Part 6 of the specification) defines all possible public Data Element Tags that may be used. DICOM also allows applications to define and use private Tags and thus define their own Data Elements. Value Representation (VR) specifies the format of the Data Element Value, such as UL (unsigned long), ST (Short Text) or PN (Person Name). If Implicit Transfer Syntax is used, the VR field is omitted. It can be obtained from the standard or private Data Dictionary. Value Length is the length of the Data field, measured in bytes.

    DICOM also allows embedding (nesting) Data Sets within Data Sets. Nested Data Sets are implemented using a "Sequence of Items" (SQ), which is a special type of Data Element.

    A special group of tags at the beginning of the file allows application to recognize the file as a DICOM image file, and includes information needed to decode the file (Transfer Syntax), and serial numbers to help locate and keep track of each field. This header is referred to as "File Meta Information Header", or "Part 10 Header" (since it is defined in Part 10 of the DICOM standard). While the standard clearly states that all DICOM image files must include a Part 10 Header, in reality one finds that many do not. Instead, the average DICOM image file is a simple data stream capture of the data into a file. This is called a "Raw Data" DICOM image file. In order to read a Raw DICOM the Transfer Syntax must be guessed at using a Transfer Syntax detection algorithm.

    The actual pixel data for a DICOM image is stored in a Data Element, just like any other DICOM information. Image parameters, such as dimensions, bit depth, photometric interpretation etc., are also stored in Data Elements. The Tag for Pixel Data is called "Pixel Data" and has the Tag Number 7FE0, 0010. The Data Field in this Data Element contains all pixels for the image. Depending on the image's Transfer Syntax, the Pixel Data can be compressed or uncompressed.

    References Used

    Digital Imaging and Communication in Medicine (DICOM). Published by: National Electrical Manufacturers Association: http://medical.nema.org/dicom.html.


%%ItemTitle%%

ImageGear for Java | Accusoft
GEM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > GEM

Glossary Item Box

Full Name | GEM Raster
Format ID | ImGearFormats.GEM
File Extension(s) | *.gem
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

ImGearCompressions.RLE - 1, 4, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

A deal with the creators of Ventura Publisher made this a significant format in the desktop publishing arena. It was also distributed by PC systems manufacturers and was the native bitmap format of the Atari ST system.

The structure of a GEM Raster image file begins with a fixed-length header and is followed by the bitmap data.

The data fields of the header include the version number (always 1), image width (in pixels), and image height (in scan lines). A field named "Headerlength" contains a value of either 8 or 9, where 9 indicates that an optional field appears at the end, called "BitImageFlag". This field is directly tied with a "NumberOfPlanes" field. If "NumberOfPlanes" is greater than 1, the BitImageFlag indicates whether the image is color or grayscale. (BitImageFlag = 0 = color, BitImageFlag = 1 = grayscale).

Two fields in the header that are a little unusual among bitmap formats are the width and height of the pixels (in microns), and a field called "PatternLength". PatternLength is the length of any pattern that will be decoded. It is used by the RLE compression scheme, which assigns one of four different kinds of codes to store each of the four different types of repeat data in the image. The "pattern code" indicates that a pattern is available. The pattern and repeat count are decoded while reading the file.

See RLE Compression (ImageGear Supported Compressions Reference).

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
GIF
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > GIF

Glossary Item Box

Full Name | CompuServe Graphics Interchange Format (GIF)
Format ID | ImGearFormats.GIF
File Extension(s) | *.gif
Data Type | Raster image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 89a, 1989: added ability to store both text and graphics in same file.
  • Version 87a, 1987: first version; still read by major applications supporting GIF.

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • MPAGEREADPSUPPORT - multi-page file reading
  • MPAGEWRITEPSUPPORT - multipage file writing

ImageGear Read Support

ImGearCompressions.LZW - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support

ImGearCompressions.LZW - Indexed RGB: 1, 2, 3, 4, 5, 6, 7, 8 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Version | int | 89 | 87; 89 | Sets version of GIF file to be saved.
Interlace | boolean | false | true, false | Sets GIF interlace mode to be used on saving.

Comments

This is a very popular format for storing graphics images on Web pages. It is also supported by most applications that handle graphical image data.

Unisys, the owner of the LZW compression used on all GIF files, declared at the end of 1995 that it will charge a royalty fee to all developers wishing to use this compression scheme. (This drove many developers to search for a replacement file format. A new file format called PNG ("Ping") was created. The PNG format is supported by ImageGear; see the See PNG. section of this chapter for more information.) However, worldwide GIF-related patents expired in 2004 and the format is once again free to use without the need to pay royalties to Unisys.

While the GIF format is designed to store multiple images, few GIF format viewers support this. For this reason, it is not advisable to store more than one image in a GIF file.

The GIF layout is fairly complex; it can include several categories of "blocks" under which subcategories of blocks may occur. For both the 89a and 87a versions, the first three blocks are the header, the Logical Source Descriptor, and the Global Color Table. The header simply identifies the file as a GIF and gives the version number. The Logical Source Descriptor is very similar to a header, and is sometimes stored within the header. It contains information about the display screen and color table.

GIFs contain two kinds of color tables: a "Global Color Table" and "Local Color Table." The Global Color Table is used as a table for the pixel values of all images contained within the GIF file. Optionally, the Local Color Table block that is provided for each image can contain data specific to an individual image.

In addition to a local color table, each image is associated with another block of data, the Local Image Descriptor, provides the size and location of the image, and data about its color table.

GIF89a is equipped with four new types of blocks called "Control Extensions". The most significant group of these are the "Graphics Control Extension Blocks" that enable the simultaneous storing and displaying of textual and graphical data, including multiple images, resulting in a "multimedia presentation". The functions provided by these blocks include setting the transparency or opacity of the images, restoring or deleting images, and overlaying captions (that are not part of the actual bitmap) on images.

GIF image data is always stored in LZW-compressed form. The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
IBM IOCA
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IBM IOCA

Glossary Item Box

Full Name | IBM IOCA (Image Object Content Architecture)
Format ID | ImGearFormats.ICA
File Extension(s) | *.ica, *.mod
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

IOCA files are most often used for document storage. They are not so unusual from most file formats, except for their naming conventions, which tend to be IBM-specific.

The general structure of an IOCA image file includes a "beginning segment", an "end segment", a header component called "Image Data Parameters", a palette, and the actual image data. Most IOCA images (less than 24-bit) contain a palette. The elements of the bitmap image are referred to as Image Data Elements (IDEs), that are called pixels by most other formats. The "Object Content" refers to the combination of the header and the image data.

IBM uses fields in the header called "self-defining fields". They each contain a type code, the length of the parameter, and then the actual parameter data. They include information as resolution, size, encoding scheme, and bit depth.

There are many optional parameters. Subsets of IOCA parameters are referred to as "function sets" and define different flavors of the IOCA, one being the IBM MO:DCA, also supported by ImageGear. Examples of optional parameters include a tiling parameter, if the image is tiled, and a Band Image parameter, which signifies that the image is saved in "bands" ("bit planes" in other formats).

References Used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
IBM MODCA
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IBM MODCA

Glossary Item Box

Full Name | IBM MO:DCA (Mixed Object Document Content Architecture)
Format ID | ImGearFormats.MOD
File Extension(s) | *.mod, *.ica
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • MPAGEREADPSUPPORT - multi-page file reading
  • MPAGEWRITEPSUPPORT - multipage file writing
  • PAGEINSERTSUPPORT - single-page file writing
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp
  • ImGearCompressions.IBM_MMR:
    • Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The MO:DCA header allows the storage of multiple IOCA images in one file. The MO:DCA format is an IOCA "wrapper". It is considered by IBM to be a "data stream controlling environment" for a group of IOCA images.

There are many optional parameters. Subsets of IOCA parameters are referred to as "function sets" and define different flavors of the IOCA, for example, the MO:DCA. The MO:DCA incorporates function sets "10" and "11".

Please see the description of See IBM IOCA. in this chapter for further description.

References Used

Image Object Content Architecture Reference, 2d ed., copyright International Business Machines Corporation, August 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
ICO
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > ICO

Glossary Item Box

Full Name | ICO (Windows icon)
Format ID | ImGearFormats.ICO
File Extension(s) | *.ico
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | Single alpha channel for read/write (see Comments).
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Windows 3.1
  • Windows NT/95

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Indexed + Extra: 4+1, 8+1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed + Extra: 1+1, 4+1, 8+1 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ReadAsRGBA | boolean | false | true, false | If true, ImageGear reads ICO format as RGBA (RGB with alpha channel).

Comments

More than one representation of the icon bitmap is stored in order to offer a choice of icons; the version most compatible to the output device is used. Support for read-write transparency masks has been added to the ICO filter. Transparency masks are placed into an alpha channel when the image is created. These masks can subsequently be set and applied to the main image.

The structure of an ICO file consists of four data sections: the header, the Resource Descriptor, and two representations of the image data per each icon (the color bitmap and the 1-bit masking bitmap).

The header identifies the file as an ICO and stores the number of icon images that are stored in the file.

The Resource Descriptor stores the image width and height, the number of colors used, and the offset from the beginning of the file to the image data.

The 1-bit masking bitmap defines the transparent portion of the bitmap.

ReadAsRGBA control parameter determines how ImageGear reads the 1-bit AND masks. If ReadAsRGBA is false, ImageGear reads AND mask into "Extra" channel. This mode preserves unchanged pixel values from the file. However, in this mode ImageGear displays only the XOR mask and ignores AND mask (Extra channel) during display, i.e., display is not transparent. If ReadAsRGBA is true, ImageGear reads ICO files as 32 bpp RGB + Alpha. This allows transparent display.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.


%%ItemTitle%%

ImageGear for Java | Accusoft
IFF
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IFF

Glossary Item Box

Full Name | Interchange File Format
Format ID | ImGearFormats.IFF
File Extension(s) | *.iff
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 1, 1985

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp
  • ImGearCompressions.RLE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp
  • ImGearCompressions.RLE:
  • Indexed RGB: 1, 4, 8 bpp;
  • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

This type of file format is referred to as a "wrapper" because it can include any type of data that is encoded in any manner.

The basic organization of the IFF file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (that identifies the chunk size and type). This makes it easy for an IFF viewer to identify chunks and to skip over the ones that are not necessary.

The Header Chunk contains 17 fields, including the size of the header chunk, the identification of the chunk as a header, the size and origin of the image, data encoding (yes or no), and aspect ratio.

A "CMG Chunk" may follow, containing data specific to Amiga display hardware.

A "CMAP Chunk" contains the RGB palette for the image.

The "Body Chunk" (also called the ILBM or "interleaved bitmap"), is the image data itself. It is stored in an "interleaved" format, by bit plane. Interleaving allows for data with different resolutions to be neatly stored together. The data may be uncompressed or compressed using an RLE scheme. See See RLE Compression. section at the beginning of this chapter for more information.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
IMG
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IMG

Glossary Item Box

Full Name | Xerox 9700 graphic image (IMG)
Format ID | ImGearFormats.IMG
File Extension(s) | *.img
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 1.0
  • Version 2.0

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 1, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

The IMG header contains the width, height and resolution of the image. Following the header is compressed data. The sample values of a binary image are compressed and then encoded into a sequence of bits. Compression is achieved by predicting a pixel value based on pixel values that have already been computed. For example, the predicted value of a pixel may be that of the corresponding pixel on the previous scan line. Up to fifteen different compression techniques are used, each designed to remove redundancy from a certain kind of image - text characters, line art, and halftones of various screen frequencies. The algorithm adapts to the properties of the image by selecting the technique that will perform the best.

References Used

Xerox System Integration Standard. Raster Encoding Standard. Xerox, XNSS 178506, June 1990.


%%ItemTitle%%

ImageGear for Java | Accusoft
IMR
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IMR

Glossary Item Box

Full Name | IMRS-Raster image
Format ID | ImGearFormats.IMR
File Extension(s) | *.ima
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


%%ItemTitle%%

ImageGear for Java | Accusoft
IMT
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > IMT

Glossary Item Box

Full Name | IMNET (Medical Image Format)
Format ID | ImGearFormats.IMT
File Extension(s) | *.imt
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - Indexed RGB: 1 bpp
  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None


%%ItemTitle%%

ImageGear for Java | Accusoft
JPEG
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > JPEG

Glossary Item Box

Full Name | JPEG File Interchange Format
Format ID | ImGearFormats.JPG
File Extension(s) | *.ipg, *jpeg
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Read/write
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 1.01 - 1991
  • Version 1.02 - Added ability for thumbnails to be color-mapped and JPEG compressed.

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.JPEG (Progressive JPEG):
    • Grayscale: 8, 12 bpp;
    • RGB: 24 bpp;
    • CMYK: 32 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support

  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
    • RGB + Alpha: 32 bpp (RGBA saving is disabled by default. Set AllowRGBASaving control parameter to true to enable it.)
    • CMYK: 32 bpp2 (CMYK saving is enabled by default. You can disable it by setting AllowCMYKSaving control parameter to false.)
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
AllowLossy12bpcSaving | boolean | true | true, false | Controls the saving to Lossy JPEG format. If true, saving of 12 bits per channel Lossy JPEG is allowed. This is the maximum channel depth supported by Lossy JPEG format. If source image's depth is more than 8 bits per channel, it will be saved to a 12 bpc JPEG. For example, 48-bit RGB image will be saved to 36-bit JPEG. Note that many viewers do not support 12 bpc JPEG. If False, all images are saved to 8 bpc JPEG, regardless of their channel depth.
AllowRGBASaving | boolean | true | true, false | Set this parameter to true to enable RGBA JPEG saving. Note, that there is no official standard for RGBA JPEG. This format is recognized as CMYK rather than RGBA by most third-party software.
Quality | int | 70 | Possible value in range [1,100] | Gets/Sets quality value for Lossy and Progressive JPEG compression. See See JPEG Quality. Section for details.
DecimationType | ImGearDecimationTypes Enumeration | Decim_2x2_1x1_1x1 | ImGearDecimationTypes Enumeration values | Get/Set decimation value. For all available values see the ImGearDecimationTypes Enumeration.
Predictor | int | 1 |  | Gets/Sets predictor for lossless JPEG. See Lossless JPEG Predictor Settings section for details.
SaveType | int | 0 (Lossy compression) | 0 (Lossy compression), 1 (Lossless compression), 2 (Progressive compression) | Get/Set type for output JPEG format. See Loading and Saving JPEG-Compressed Images. Section for details.
AllowCMYKSaving | boolean | true | true, false | Set to true (default) to allow saving JPEG CMYK images. Set to false to save CMYK images to JPEG as RGB.
SaveEXIFMetadata | boolean | false | true, false | If true, EXIF metadata is saved.
SaveExistingEXIFMetadata | boolean | true | true, false | This parameter controls the saving of existing EXIF metadata. By default (SaveEXIFMetadata = False, SaveExistingEXIFMetadata = True), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata | SaveExistingEXIFMetadata | Source Page has EXIF Metadata | ImageGear Action
False | False | No | Does not save EXIF metadata
False | False | Yes | Does not save EXIF metadata
False | True | No | Does not save EXIF metadata
False | True | Yes | Saves existing EXIF metadata
True | False | No | Saves default EXIF metadata
True | False | Yes | Ignores existing and saves default EXIF metadata
True | True | No | Saves default EXIF metadata
True | True | Yes | Saves existing EXIF metadata

Comments

JPEG is normally associated with the JPEG compression scheme, but it is also implemented into the JFIF file format. This format was developed to store JPEG-encoded data, and to exchange it between applications or operating systems that are normally incompatible.

The JPEG compression scheme was developed by the Joint Photographic Experts Group (created by the joining of a subgroup of the International Standards Organizations, called PEG (Photographic Experts Group) and a subgroup of the CCITT). Their common goal was to produce a standard for the transmission of graphics image data over networks and through color facsimile systems.

The header of the JFIF contains the version number, the image dots per inch (DPI), or dots per centimeter, and an optional thumbnail (miniature) RGB representation of the main image. Version 1.02 handles thumbnails differently by storing them separately, rather than in the identification marker of the header.

The raw JPEG data is surrounded by two markers, an "SOI" (start of image) marker, and an "EOI" (end of image) marker. See JPEG Compression (ImageGear Supported Compressions Reference) for more about JPEG compression.

JFIF is considered a non-proprietary file format. Many proprietary file formats contain JPEG data, incorporating their own application-specific data structures. Another non-proprietary format that uses JPEG-encoded data is TIFF file format, version 6.0.

Loading and Saving JPEG-Compressed Images

ImageGear supports the reading and writing of three types of JPEG compression: baseline JPEG (Lossy), Progressive JPEG, and Lossless JPEG. When you load a JPEG-compressed file, ImageGear detects the type of JPEG compression and decompress the image automatically. But if you want to save an image with a JPEG compression scheme other than baseline JPEG, you must use the "SaveType" parameter to specify the type of JPEG compression.

JPEG Thumbnails

The JPEG format can store thumbnails, which are small representations of the original image. These images are stored in uncompressed form and can significantly decrease your overall compression ratio. (Uncompressed thumbnails sometimes occupy more space than the original JPEG image when compressed). Use this option carefully.

The JPEG format does not allow the storage of "large" thumbnails. This is due to the marker segment length, which cannot be greater than 65,536 bytes. The maximum size of a color thumbnail is about 100x200 or 200x100 pixels, and the maximum size of a grayscale thumbnail is about 300x200 or 200x300 pixels.

Lossless JPEG Predictor Settings

The Lossless JPEG scheme is "predictive" in nature--it uses the values of surrounding pixels in addition to the value of the original pixel to calculate a predictor value, which it then subtracts from the value of the original pixel. The resulting pixel value will be reduced such that it can be compressed more than the original value. The higher the number of neighboring pixels used, the higher the compression will be.

Regardless of the predictor value setting, the quality of the image will remain the same. The difference is that if you choose to optimize for space by setting a high predictor value, you will have to give up some speed, as the decompression will take longer to perform.

ImageGear lets you set the predictor value using Predictor control parameter. The ImageGear default for this setting is 1. The allowed range is 1--7. The graphic below shows a predictor (x) and three reconstructed samples (a,b,c) immediately to the left, immediately above, and diagonally to the left of the current sample.

Lossless JPEG does not apply DCT for an image as per the Lossy JPEG compression. Instead, it uses a DPCM difference coding, which can be carried out with any one of seven different prediction modes. Correspondingly, the Predictor control parameter can be set to a value between 0 and 7. In Table 4, you will see what algorithm your setting of 1--7 will use, where Pr Px is the predictor, and Ra, Rb, and Rc are the reconstructed samples:

Value | JPEG DIS Prediction
0 | no prediction
1 | Px = Ra
2 | Px = Rb
3 | Px = Rc
4 | Px = Ra + Rb - Rc
5 | Px = Ra + ((Rb-Rc)/2)
6 | Px = Rb + ((Ra-Rc)/2)
7 | Px = (Ra + Rb)/2

JPEG Quality

The baseline JPEG specification calls for a quality setting. The lower the setting, the greater the number of original pixels lost, and therefore the smaller the resulting compressed file will be. ImageGear lets you set the quality of compression with values of type INT between 1-100, where 100 provides the highest retention of original pixel values. A setting of 100 does not mean that the image includes 100% of all original pixel values. With Lossy JPEG, there is no such thing as "no loss". Control parameter for setting Lossy JPEG quality is Quality.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
KFX
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > KFX

Glossary Item Box

Full Name | KFX (Kofax Group4 image)
Format ID | ImGearFormats.KFX
File Extension(s) | *.kfx
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 3

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


%%ItemTitle%%

ImageGear for Java | Accusoft
LV
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > LV

Glossary Item Box

Full Name | LV (Lazer View format)
Format ID | ImGearFormats.LV
File Extension(s) | *.lv
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.CCITT_G3 - 1bpp
  • ImGearCompressions.CCITT_G4 - 1bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None


%%ItemTitle%%

ImageGear for Java | Accusoft
MSP
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > MSP

Glossary Item Box

Full Name | MSP (MS Paint)
Format ID | ImGearFormats.MSP
File Extension(s) | *.msp
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 2.0
  • Version 1.0

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.NONE: Indexed RGB: 1 bpp
  • ImGearCompressions.RLE: Indexed RGB: 1 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

This was a popular format for storing line drawing and clip art images created with Windows applications, but has been replaced by the Windows bitmap format (also supported by ImageGear BMP).

For versions earlier than 2.0, the format begins with a 32-byte header and immediately proceeds with the bitmap data. The header information includes: the version of the file, the size and aspect ratio of the bitmap, and the width and height and aspect ratio (in pixels) of the output device used to render the bitmapped image. The bitmap data is uncompressed.

Files made with Version 2.0 and later always use RLE compression. In these files a "scan-line map" follows the header and precedes the data. It gives offsets to each scan line for instances when a particular scan line needs to be examined. All previous lines can remain compressed, while the needed line is located.

See RLE Compression for more information.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
NCR
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > NCR

Glossary Item Box

Full Name | NCR
Format ID | ImGearFormats.NCR
File Extension(s) | *.ncr
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp
  • ImGearCompressions.NONE - Indexed RGB: 1, 4 bpp

ImageGear Write Support

  • ImGearCompressions.CCITT_G4 - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

NCR is the black and white image compression format.


%%ItemTitle%%

ImageGear for Java | Accusoft
PBM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PBM

Glossary Item Box

Full Name | PBM (Portable Bitmap File Format)
Format ID | ImGearFormats.PBM
File Extension(s) | *.pbm
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

This is useful for quick and easy transfer of monochrome bitmap images, although the encoding scheme is not efficient in terms of storage space. This format, as well as the PGM, PNM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. Among other things, these formats serve as intermediary storage methods for the conversion of other file formats.

The Portable Bitmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of bits is equal to the width * height. A pixel value of 0 indicates white, and a value of 1 indicates black.

The magic number of the header can have one of two values: either P1 or P4. P1 indicates that the bitmap data are to be read as ASCII decimal values. P4 indicates that the bitmap data are stored as plain bytes. Because 8 pixel values (1 bit each) are stored in one byte, the file is 8 times smaller than in the ASCII decimal format. White spaces are permitted in the P1 format but not permitted in the P4 format.

ImageGear uses PBM filter to handle the whole family of formats: PBM (1-bit), PGM (grayscale), PPM (truecolor) and PNM (collective name for all of above). When saving image as ImGearFormats.PBM format, ImageGear chooses particular format (PBM, PGM, PNM or PPM) depending on image bit depth.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM Specification by Jef Poskanzer, copyright A 1989, 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
PCD
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PCD

Glossary Item Box

Full Name | PCD (Kodak Photo CD)
Format ID | ImGearFormats.PCD
File Extension(s) | *.pcd
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

All valid PCD files in 5 different resolutions:

  • Resolution 1: 768x512
  • Resolution 2: 384x256
  • Resolution 3: 192x128
  • Resolution 4: 1536x1024
  • Resolution 5: 3072x2048

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - RGB: 24 bpp
  • ImGearCompressions.HUFFMAN - RGB: 24 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter Type Default Value Available Values Description
Resolution int 0 0..4

Resolution level to load:

  • 0 = load last (largest) resolution (Resolution 5: 3072x2048)
  • 1 = load second to last resolution (Resolution 4: 1536x1024)
  • 2 = load middle resolution (Resolution 3: 192x128)
  • 3 = load second resolution (Resolution 2: 384x256)
  • 4 or higher = load first (smallest) resolution (Resolution 1: 768x512)

Comments

"Photo CD" is the informally adopted name for files created using the Photo CD-ROM-based storage and retrieval system created by Kodak. The images are digitized versions of photographic images. Using a Photo CD player, images can be viewed on television. Although intended for photographic images, the data source does not necessarily have to be film.

Images and their associated information are stored in groups called "sessions". Originally, they were stored at the rate of one session per CD, but later versions allowed multiple sessions per disc.

For each stored image, there are up to 5 bitmaps, each representing the image at a different resolution. The bitmaps at the lowest resolution are intended for such purposes as displaying thumbnails and previewing an image.

To find out the number of resolutions in a PCD image, load image header using a ImGearFileFormats.LoadPageHeader Method, and then check for the number of resolutions using the ImGearPage.getMetadata().getCommon().getResolutionLayersCount() methods.

Note that resolutions in a PCD image are not ordered by size. See the list of resolutions and their sizes in the format description above.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
PCX
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PCX

Glossary Item Box

Full Name | PCX (PC Paintbrush File Format)
Format ID | ImGearFormats.PCX
File Extension(s) | *.pcx
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 5.0 1991, Supports 24-bit RGB
  • Version 3.0
  • Version 2.8 Included color palette
  • Version 2.5

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None.

Comments

PCX is one of the oldest PC-based bitmap formats. It became well-known when Microsoft used it for their Paintbrush for Windows application and distributed it with every copy of Windows. This format is popular for fax documents because it allows them to be viewed within many popular paint and image display programs. If multiple images are desired in a PCX format, the format known as DCX, designed for this purpose, (and supported by ImageGear), may be used. Please see DCX file format for more information.

The main components of the PCX file format are the fixed length header, the image data, and if it is written for VGA display technology, the palette for the image (this appears as the last structure in the file). The header includes fields including the PCX version, the image size, resolution and position, and an encoding field that always has a value of 1; PCX data is always RLE. (For complex images, this may actually cause the bitmap data to increase in size).

The size and location of the palette associated with the image depends on the version of the PCX. When it was first developed, the limitations of the EGA card led to a palette that contained just 16 colors. PCX also supported CGA, so that the palette contained only 4 colors. Both of these palettes were stored in the palette array structure of the header. When the PCX was modified to display VGA, there was not enough room to store the palette in the header; subsequently, it was located at the end of the file.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
PGM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PGM

Glossary Item Box

Full Name | PGM (Portable Graymap File Format)
Format ID | ImGearFormats.PBM (see the Note below)
File Extension(s) | *.pgm
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear supports PGM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PGM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Write Support

  • ImGearCompressions.RAW - Grayscale: 8, 16 bpp
  • ImGearCompressions.ASCII - Grayscale: 8, 16 bpp

ImageGear Filter Control Parameters

None

Comments

This format quickly and easily transfers grayscale bitmap images. This format, as well as PBM, PNM, and PPM, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as an intermediary storage methods for the conversion of other file formats.

The Portable Graymap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum gray value", and perhaps a comment line identifying the filename. The bitmap data follows white space (usually a carriage return). The number of pixels is equal to width * height. A pixel value of 0 indicates black, and a "maximum gray value" is equivalent to white.

The magic number of the header can have one of two values: either P2 or P5. P2 indicates that the bitmap data is read as ASCII decimal values. P5 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value does not exceed 255 (28 = 256 gray values from 0 to 255), each pixel is represented by a 8-bit sample. ImageGear loads such images as 8-bit grayscale. Otherwise, each pixel is represented by a 16-bit sample. ImageGear loads these images as 16-bit grayscale.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PGM Specification by Jef Poskanzer, copyright A 1989, 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
PNG
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PNG

Glossary Item Box

Full Name | PNG (Portable Network Graphics)
Format ID | ImGearFormats.PNG
File Extension(s) | *.png
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Supports single alpha channel for read/write.
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • 10th draft (future drafts will be backward-compatible)
  • PNG v2

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 2, 4, 8 bpp;
    • Grayscale: 1, 2, 4, 8, 16 bpp;
    • Grayscale + Alpha: 8, 16 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Write Support

  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 4, 8 bpp;
    • Grayscale: 1, 4, 8, 16 bpp;
    • Grayscale + Alpha: 16, 32 bpp;
    • RGB: 24, 48 bpp;
    • RGB + Alpha: 32, 64 bpp

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
StripConfig int 0 (fixed count)

0 (fixed count),

1 (fixed buffer)

 Format of PNG strip, see ImGearPNGStrip constants.
BufferSize | int | 0 | Any value | Size of the buffer for strip if StripConfig is 1 (fixed buffer).
StripCount | int | 0 | Any value | Number of lines in one strip if StripConfig is 0 (fixed count).
CompLevel | int | 6 (default compression) | Any integer in range 0..9 | Compression level. It must be between 0 (No compression) and 9 (max compression). Better compression takes more time for compression. See ImGearPNGCompLevel.
KeepAlpha boolean true

true,

false

When loading: if this parameter is true, then the alpha channel is loaded into Alpha DIB. Otherwise, the image is transformed into RGB, by compositing over the background supplied in the bKGD chunk, if it is present, or over the default background.

When saving:

if this parameter is true, and an alpha DIB is present, it will be written to the file.

Comments

The PNG (pronounced "Ping") format was created out of reaction to Unisys's announcement that it would begin requiring royalty fees for use of its LZW compression scheme. This was the compression scheme for the widely-used GIF format (found in Web pages and online library images).

Thomas Boutell and a host of other programmers began working to devise a new file format to eliminate the need for payment of royalty fees. The result was a file format that offers better compression than GIF, and adds features GIF doesn't offer, including truecolor, and full alpha channel and gamma correction.

The basic organization of the PNG file format utilizes storage structures known as "chunks". A chunk is a block of data that contains its own header (identifying the chunk size and type). This makes it easy for a PNG viewer to identify chunks and to skip over the ones that are not necessary.

The first entry in a PNG file is the "PNG signature" that identifies the format as PNG. The file then proceeds with a series of chunks.

The IHDR Image Header, or IHDR Chunk, contains a number of fields including the height, width, depth, color type, and compression type of the image. The only valid compression value is 0, which indicates the PNG's custom compression scheme, a deflate/inflate compression with a 32k sliding window. This is a derivative of ZZ77, the precursor to LZW. ZZ77 is the compression scheme used by pkzip software.

The "PLTE Palette Chunk" contains 1 to 256 palette entries. This is present if the type field of the header chunk is set to 3. The number of colors cannot exceed the range provided by the bit depth.

The image data is stored in "IDAT Image Data Chunks". These are subdivided into chunks whose size is usually determined by the size of the encoder's buffer. The data may be stored in "interlaced order" allowing the image to be "faded in". The data may also be interlaced. Interlacing helps the appearance of an image as it displays while being decompressed, so that it "fades in". In a non-interlaced file, the presentation of the image data begins with row 1 and works downward to the last row of data. This method of display does not allow a quick preview of the whole image. When the data is interlaced, the lines are saved and displayed out of sequence. Every fourth row is displayed first and then filled in with every remaining fourth row, until all of the lines are displayed. This allows the eye to perceive the basic subject of the whole image before it is completely displayed.

"Ancillary Chunks" are optional. They must appear before the first IDAT and after the PLTE. One chunk is the "bKGD chunk" that sets the default background color for the image. Two of the other ancillary chunks are the "hHist Chunk" or histogram chunk, and the "tEXt" chunk. The histogram chunk appears if there is a palette. It stores the frequency of each color of the palette as it occurs in the image data. If the application doesn't support all of the colors in the palette, the histogram can be used to choose a subset of colors. There may be any number of text chunks. They can vary in length from 0 to the maximum chunk size. They include the image author, copyright information, and any desired comments.

Questions about PNG can be e-mailed to: png-info@uunet.uu.net

References Used

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

PNG (Portable Network Graphics), tenth draft. Page 5, copyright Thomas Boutell, May 1995.

Wegner, Tim. "Coding for PNG Graphics", "PC Techniques", Feb/Mar 1996, pp 32-38.


%%ItemTitle%%

ImageGear for Java | Accusoft
PNM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PNM

Glossary Item Box

Full Name | PNM (Portable Any-Map File Format)
Format ID | ImGearFormats.PBM (See the Note below)
File Extension(s) | *.pnm
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear supports PNM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PNM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp
  • ImGearCompressions.ASCII:
    • Indexed RGB: 1 bpp;
    • Grayscale: 8, 16 bpp;
    • RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

The PNM format is useful for quick and easy transfer of uncomplicated monochrome, grayscale, or color bitmap images. This format, as well as the PBM, PGM, and PPM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a function called gifftoppm translates a GIF file to a PPM, from where it can be then translated to a TIFF using the pnmtotiff.

The Portable Anymap File Format structure is very simple. The "Anymap" portion of its name refers to the fact that it can be one of three types of UNIX bitmap file formats: the Portable Bitmap File Format (PBM), the Portable Graymap File Format (PGM), or the Portable Pixelmap File Format (PPM). A PNM begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value" if it is a PPM, a "maximum gray value" if it is a PGM, and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. For PGM and PPM files, the number of pixels is equal to width * height (whereas, in a PBM file, this calculation gives you the number of bits).

The magic number of the header can have one of six values depending on whether the bitmap is in PBM, PGM, or PPM format. Each format can have one of two magic numbers depending on whether the pixel data is stored in ASCII decimal or plain bytes. See the descriptions for the individual formats (these are all supported by ImageGear) for more details.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PBM, PGM, PPM, PNM Specifications by Jef Poskanzer, copyright A 1989, 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
PPM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PPM

Glossary Item Box

Full Name | PPM (Portable Pixmap File Format)
Format ID | ImGearFormats.PBM (See the Note below)
File Extension(s) | *.ppm
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear supports PPM file format via its PBM format filter. Use ImGearFormats.PBM to save images to PPM format.

ImageGear Supported Versions

October 1991 - last release

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Write Support

  • ImGearCompressions.RAW - RGB: 24, 48 bpp
  • ImGearCompressions.ASCII - RGB: 24, 48 bpp

ImageGear Filter Control Parameters

None

Comments

The PPM format is useful for quick and easy transfer of color bitmap images. This format, as well as the PBM, PGM, and PNM formats, are at the core of a set of utility programs also written by Jef Poskanzer. These formats serve as intermediary storage methods for the conversion of other file formats. For example, a function called gifftoppm translates a GIF file to a PPM, where it can translate to a TIFF using the pnmtotiff.

The Portable Pixmap File Format structure is very simple. It begins with a short ASCII header that contains the file type identifier (magic number), the width and height of the image, a "maximum color-component value", and perhaps a comment line identifying the filename. Following white space (usually a carriage return) is the bitmap data. The number of pixels is equal to width * height, with each pixel being represented by three bytes: one each for Red, Green, and Blue color components, respectively.

The magic number of the header can have one of two values: either P3 or P6. P3 indicates that the bitmap data is read as ASCII decimal values. P6 indicates that the bitmap data is stored as plain bytes. This makes for a smaller and faster-to-read file.

If the maximum gray value exceeds 255 (28 = 256 gray values from 0 to 255), each pixel is represented by three 16-bit RGB samples, making a total of 48 bits per pixel. ImageGear loads such images to 24-bit RGB.

References Used

Kay, David C. and John R. Levine. Graphics File Formats, 2nd ed. Windcrest /McGraw-Hill, 1995.

PPM Specification by Jef Poskanzer, copyright A 1989, 1991.


%%ItemTitle%%

ImageGear for Java | Accusoft
PTOCA
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > PTOCA

Glossary Item Box

Full Name | PTOCA (Presentation Text Object Content Architecture)
Format ID | ImGearFormats.PTOCA
File Extension(s) | *.pto, *.mod
Data Type | Metafile
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Format 2

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
Factor | double | 1.0 |  | Linear DIB size Factor.

Comments

ImageGear can read PTOCA files as content of multi- and single-page MOD:CA files, ensuring better compatibility with IBM's AFP (Advanced Function Presentation) printer architecture.

The PT object structure starts with the "Begin Presentation Text" structure field and finishes with the "End Presentation Text" structure field. Text data is placed between these fields and consists of graphic characters and control sequences that describe how the text will be shown on the presentation surface. The PT object can include some other optional structured fields that define initial presentation text values. If PTOCA is included in the MOD:CA content, some presentation text parameters (like code page, font, an initial values) can be defined on the MOD:CA level.

References Used

IBM BookManager BookServer, Copyright 1989, 1999, IBM Corporation.


%%ItemTitle%%

ImageGear for Java | Accusoft
RAS
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > RAS

Glossary Item Box

Full Name | RAS (Sun Raster Data Format)
Format ID | ImGearFormats.RAS
File Extension(s) | *.ras
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.RLE:
    • Indexed RGB: 1, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

Bitmap images used under the SunOS system and UNIX imaging applications are usually stored in Sun Raster form.

The Sun Raster header contains image data (size and type), and the type and size of the colormap, if present. It also contains a Sun Raster identifying tag called "MagicNumber," which always contains the same value. A type field identifies the version of Sun Raster, the most common are called "Old" and "Standard". These are actually the same format and indicate that the image is not compressed. Other possible versions of Sun Raster files include TIFF and IFF, meaning that the image data was converted from one of these formats.

Following the header is a colormap, if applicable. Most 24 or 32-bit raster images do not use a colormap, but rather store the color values directly with the image data. This is known as "truecolor".

The last element of the Sun Raster file is the image data itself. It is usually in 2D raster format.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java
RAW
Send Feedback
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > RAW

Glossary Item Box

Full Name | RAW (Header-less image)
Format ID | ImGearFormats.RAW
File Extension(s) | *.*
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Supports single alpha channel for read.
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1, 4, 8, 12, 16 bpp;
    • RGB: 24,48 bpp;
    • RGB + Alpha: 32,64 bpp
    • CMYK: 32, 64 bpp
  • ImGearCompressions.LZW:
    • Grayscale: 1, 4, 8, 12, 16 bpp;
    • RGB: 24,48 bpp;
    • RGB + Alpha: 32, 64 bpp
    • CMYK: 32, 64 bpp
  • ImGearCompressions.CCITT_G3:
    • Grayscale: 1 bpp
  • ImGearCompressions.CCITT_G4:
    • Grayscale: 1 bpp
  • ImGearCompressions.CCITT_G32D:
    • Grayscale: 1 bpp

ImageGear Write Support

RAW images writing is not supported.

Comments

A raw image file contains no header or identifying information. ImageGear can load images of proprietary or unsupported formats as raw data. Since ImageGear cannot obtain parameters, such as width, height or bits per pixel from the file, the application should specify them. This can be done by using the ImGearRawLoadOptions class derived from the ImGearLoadOptions, to specify loading options for header-less RAW formats and passing them to the LoadPage method.


%%ItemTitle%%

ImageGear for Java | Accusoft
Scitex CT
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > Scitex CT

Glossary Item Box

Full Name | SciTex (Scitex CT)
Format ID | ImGearFormats.SCI
File Extension(s) | *.sct
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Write Support

  • ImGearCompressions.NONE - CMYK: 32 bpp

ImageGear Filter Control Parameters

None

Comments

ImageGear has read and write support for Scitex HandShake Continuous Tone Picture files. This is the native format used by Scitex scanners and printers for high-end image processing and color separation.

Scitex CT files store uncompressed, CMYK true-color raster data. They contain a Control Block, a Parameters Block, and the image data. Scitex CT images are typically four-color separation, CMYK, line-interleaved raster data. The separations are always stored by scan line and in the order C-M-Y-K (cyan-magenta-yellow-black). A color pixel value have up to 16 separations (128 bits) in size. Separations 1 through 4 are defined in order (C-M-Y-K). Separations 5 through 16 are reserved for future expansion of the format, as shown below.

Each row or Scitex CT image data is stored in separated color. The first separation's row data is followed by the second, and so forth, up to the number of separations specified by NumColorSeparations. Only the data for the separations defined by the SeparationsBitMask field is actually stored in the CT file. Each pixel can contain up to 16 separation components and each component is one byte in size. A CMYK pixel contains four components and is of a 32-bit size. Remember that the data is not stored by pixel, but by separation. If rows contain odd numbers of bytes, the zero padding byte will be added to the end of each separation to preserve word alignment.

References Used

CopyrightA 1994, 1996, O'Reilly & Associates, Inc.


%%ItemTitle%%

ImageGear for Java | Accusoft
SGI
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > SGI

Glossary Item Box

Full Name | SGI (Silicon Graphics Image)
Format ID | ImGearFormats.SGI
File Extension(s) | *.sgi, *.bw, *.rgb, *.rgba
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Supports single alpha channel for read and write.
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

N/A

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp
  • ImGearCompressions.RLE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp;
    • Grayscale + Alpha: 16 bpp;
    • RGB + Alpha: 32 bpp

ImageGear Filter Control Parameters

None

Comments

This format was developed for use with the SGI image library included on most Silicon Graphics computers. Most SGI images are black and white.

The major components of an SGI file are the 512-byte header, a "scan-line offset table", and the bitmap header. SGI is one of the few formats to use a scan-line offset table.

The fields of the header structure include a compression flag (1 = compressed), the height and width (in pixels) of the image, the number of bit planes, the highest pixel value and the lowest pixel value, the name of the image, and pixel format. Pixel format can indicate the number of color channels, whether the image is dithered to a single channel, and whether the bitmap image is actually a color map for other images.

The bitmap data is stored up-side-down--the first scan line is at the bottom of the bitmap. If the data is RLE, a scan-line offset table is present, following the header and preceding the bitmap. This increases compression further by allowing repeated offsets to the same scan line, if several scan lines have the same value. A grayscale image may even refer to the same scan line from three different bit fields. For this reason, and because SGI data that is compressed can be stored in any scan-line order, the offset table must not be ignored.

References Used

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats, 2d ed. Sebastopol, CA: O'Reilly & Associates, Inc., 1996.


%%ItemTitle%%

ImageGear for Java | Accusoft
TGA
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > TGA

Glossary Item Box

Full Name | TGA (Truevision Targa)
Format ID | ImGearFormats.TGA
File Extension(s) | *.tga, *.tpic
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | Single alpha channel for read/write
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 2.0, 1991
  • Version 1.0, 1984

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;
  • ImGearCompressions.RLE:
    • Grayscale: 1 bpp;
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Premultiplied Alpha 1 bpp;
    • RGB 24 bpp + Premultiplied Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;
  • ImGearCompressions.RLE:
    • Indexed RGB: 8 bpp;
    • RGB: 15, 24 bpp;
    • RGB 15 bpp + Alpha 1 bpp;
    • RGB 24 bpp + Alpha 8 bpp;
    • RGB 15 bpp + Extra 1 bpp;
    • RGB 24 bpp + Extra 8 bpp;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
ImageID | byte[] | Empty array |  | Image ID

Comments

This file format was originally developed by AT&T for use with its image capture boards. The format was taken over by Truevision when it acquired the product line from AT&T.

It became a popular file format mainly because it was the first 24-bit truecolor format to come to the PC market. There are several varieties of Targa files; the most commonly used are the Targa 16, Targa 24, and Targa 32. The names are derived from the type of hardware used to create them.

The fixed-sized header information of the Targa format includes: the existence (or not) and colormap, location, size, pixel depth, image location, colormap (if it exists), and finally the image data itself.

Version 2.0 introduced a file footer that identifies it as the newest version and contains pointers to additional fields in two main structures: the "extension area" and the "developer directory". The extension area contains the addresses of many optional fields, one of the most popular being the "postage stamp image" (miniature of the main image).

The developer directory can be used to store proprietary information. Developers can register their own private fields with Truevision. A null-terminated ASCII string containing "TRUEVISION-XFILE.", and positioned at the end of the file, indicates that the footer is valid.

Targa defines 3 color methods: pseudo color, direct color, and truecolor. Pseudo color uses an index to a color palette. Direct color is like pseudo color except that the RGB components are looked up separately. In truecolor files, the color information is stored directly in the image data. The palettes used by Targa files are variable in size; they do not necessarily correlate to the bit depth of the image. The presence of a palette does not always mean that it is used to display the image.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
TIFF
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > TIFF

Glossary Item Box

Full Name | TIFF (Tagged Image File Format)
Format ID | ImGearFormats.TIF
File Extension(s) | *.tif, *.tiff
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | Yes
IG Alpha Channel Support | Yes
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 6.0 - Added support for CMYK and YCbCr color images, and JPEG compression. Ability to store pixels in "tiles"
  • Version 5.0 - Added ability to store palette color images and support for LZW compression. This version featured TIFF "classes."
  • Version 4.0 - Added support for uncompressed RGB color images.
  • Version 3.0 - First public release.

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • MPAGEREADPSUPPORT - multi-page file reading
  • PAGEINSERTSUPPORT - single-page file writing
  • MPAGEWRITEPSUPPORT - multipage file writing
  • PAGEDELETESUPPORT - page deleting from multi-page file
  • PAGESWAPSUPPORT - page swaping in multi-page files
  • MPDATASUPPORT - faster multi-page access by storing private format data.

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
    • Grayscale: 1 bpp;
  • ImGearCompressions.JPEG:
    • Grayscale: 8 bpp;
    • RGB: 24 bpp
  • ImGearCompressions.DEFLATE:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.
  • ImGearCompressions.LZW:
    • Indexed RGB - 1, 2, 4, 8 bpp;
    • Grayscale - 1, 2, 4, 8, 12, 16, 32 bpp;
    • RGB: 3, 6, 12, 24, 36, 48 bpp;
    • Lab: 3, 6, 12, 24, 36, 48 bpp;
    • CMYK: 4, 8, 16, 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 2, 4, 8, 12, 16, 32 bpp;
    • RGB + Premultiplied Alpha: 4, 8, 16, 32, 48, 64 bpp;
    • Indexed RGB + Extra: 1, 2, 4, 8 bpc;
    • Lab + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • CMYK + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 1, 2, 4, 8, 12, 16 bpc.

To use LZW (Lempel-Ziv-Welch) Compression compression scheme com.accusoft.imagegear.formats package should be attached.

ImageGear Write Support

TIFF writer requires read/write access to the output stream.
  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.PACKED_BITS:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.HUFFMAN:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G3:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G4:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.CCITT_G32D:
    • Indexed RGB: 1 bpp;
  • ImGearCompressions.JPEG (Lossy):
    • Grayscale: 8, 12 bpp;
    • RGB: 24, 36 bpp;
  • ImGearCompressions.JPEG (Lossless):
    • Grayscale: 8, 16 bpp;
    • RGB: 24 bpp;
  • ImGearCompressions.DEFLATE:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
  • ImGearCompressions.LZW:
    • Indexed RGB: 1, 4, 8 bpp;
    • Grayscale: 8, 12, 16 bpp;
    • RGB: 24, 36, 48 bpp;
    • Lab: 24, 36, 48 bpp;
    • CMYK: 32, 48, 64 bpp;
    • Grayscale + Premultiplied Alpha: 16, 24, 32 bpp;
    • RGB + Premultiplied Alpha: 32, 48, 64 bpp;
    • Lab + Extra: 8, 12, 16 bpc;
    • CMYK + Extra: 8, 12, 16 bpc;
    • Grayscale + Premultiplied Alpha + Extra: 8, 12, 16 bpc;
    • RGB + Premultiplied Alpha + Extra: 8, 12, 16 bpc;

ImageGear Filter Control Parameters

Filter Control Parameter | Type | Default Value | Available Values | Description
BigEndian | boolean | false | false, true | If true , big endian order is used for write operation ("MM"), in other case little endian is used ("II").
BitonalPaletteMode | ImGearTIFFBitonalPaletteMode Enumeration | ImGearTIFFBitonalPaletteMode.LEGACY | An ImGearTIFFBitonalPaletteMode Enumeration value | Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
FillOrder | ImGearFillOrder Enumeration | ImGearFillOrder.MSB | An ImGearFillOrder Enumeration value | Specifies fill order (most significant bit first, less significant bit first) to use for writing the TIFF file.
ImageBeforeIFD | boolean | false | false, true | This flag specifies physical location of raster data inside TIFF file relatively to IFD record. If this value is true then image data is to be written before IFD record.
IncludePageNumber | booleane | true | false, true | If this parameter is true then include tag 297 into TIFF image with real value of page number.
LoadFirstUnknownChannelAsPAlpha | boolan | true | true, false | This parameter specifies how to load first extra channel if ExtraSamples tag is missing. If LoadFirstUnknownChannelAsPAlpha is True, IG loads first extra channel as Premultiplied Alpha channel. This mode provides support for RGBPA TIFF images written by earlier versions of ImageGear. If LoadFirstUnknownChannelAsPAlpha is False, IG loads all extra channels as extra channels.
MissingCompression | ImGearCompressions Enumeration | ImGearCompressions.AUTO | An ImGearCompressions Enumeration value | Compression to use for image loading, if compression tag is missing in the image.
Save70 | boolean | true | false, true | If this value is true then output TIFF-JPEG image will be produced in TIFF 7.0 compatible format but in other case it will be compatible with TIFF 6.0.
SaveClassF | boolean | false | false, true | If this value is true then image to be written in TIFF format compatible with class F requirements.
SaveEXIFMetadata | boolean | false | true, false | If this parameter is true EXIF metadata is saved with TIFF file.
SaveExistingEXIFMetadata | boolean | true | true, false | This parameter controls the saving of existing EXIF metadata. By default (SaveEXIFMetadata = false, SaveExistingEXIFMetadata = true), ImageGear saves EXIF metadata if it exists in the source page, and does not save EXIF metadata if it does not exist in the source page.
SavePlanar | boolean | false | false, true | Specifies tag value 284 for output image.
StripBufferSize | int | 32768 | Any positive value | If StripMode is ImGearStripModes.FIXED_BUFFER, this specifies the buffer size to be used for writing of each strip.
StripCount | int | 1 | Any positive int value, not greater than image height. | If StripMode is ImGearStripModes.FIXED_COUNT, this specifies the number of strips for saving the TIFF image.
StripMode | ImGearStripModes Enumeration | ImGearStripModes.FIXED_COUNT | An ImGearStripModes Enumeration value | Specifies strip or tile saving mode for the TIFF image. By default, ImageGear saves TIFF files with one strip.
SubIFDPath | String | Empty string | Any string value | Path of the SubIFD to load the image from. If set to empty string (default), load image from root IFD.
TileHCount | int | 10 | Any positive int value, not greater than image width. | If StripMode is ImGearStripModes.TILED_FIXED_COUNT, this specifies the number of tiles in horizontal dimension.
TileHeight | int | 64 | Any positive int value, not greater than image height | If StripMode is ImGearStripModes.TILED_FIXED_SIZE, this specifies the height of each tile.
TileVCount | int | 10 | Any positive int value, not greater than image height | If StripMode is ImGearStripModes.TILED_FIXED_COUNT, this specifies the number of tiles in vertical dimension.
TileWidth | int | 64 | Any positive int value, not greater than image width | If StripMode equals ImGearStripModes.TILED_FIXED_SIZE, this specifies the width of each tile.

SaveExistingEXIFMetadata works in combination with SaveEXIFMetadata parameter, as shown in the table below:

SaveEXIFMetadata | SaveExistingEXIFMetadata | Source Page has EXIF metadata | ImageGear Action
false | false | No | Does not save EXIF metadata
false | false | Yes | Does not save EXIF metadata
false | true | No | Does not save EXIF metadata
false | true | Yes | Saves existing EXIF metadata
true | false | No | Saves default EXIF metadata
true | false | Yes | Ignores existing and saves default EXIF metadata
true | true | No | Saves default EXIF metadata
true | true | Yes | Saves existing EXIF metadata

Comments

TIFF was developed for use in storing black-and-white images from scanners and desktop publishing applications. Now, in its fourth release (version 6.0), it is one of the most detailed and versatile bitmap formats in use. It is supported by most art, imaging, and word-processing applications. It supports several compression schemes. Aside from saving image data in bitmap form, it can also contain vector or text-based images.

Containing just three fields, the TIFF header is simple and one of the shortest of all the graphics file format headers. But, the structure of a TIFF is complicated, with variable length fields, variable number of fields, and the ability to store information (other than the header) in any order desired.

The other two major components of the TIFF format are "Image File Directories" (IFDs) and the image or images themselves. There is one IFD per image stored. The combination of an IFD and an image is referred to as a "subfile". The header contains an offset pointer to the first IFD. If there are multiple IFDs, each contains an offset to the next. The last IFD contains a value that signifies the end of the file.

IFDs closely resemble a header structure, and the information stored in them is often referred to as "TIFF Header Information". Unlike a header, however, they contain a variable number of "tags" (pointers or fields). In addition, each tag can point to data with a variable length. TIFFs are notorious for the number of tags that they can contain, up to a maximum of 65,535 tags of nearly 100 different types (version 6.0). Tags are listed in order by code number so that a TIFF reader can easily determine what fields are present. While ImageGear reads and stores all TIFF tags, it utilizes a subset of all of the possible tags. See note on previous page.

In version 5.0, the presence of certain subgroups of tags determined what "class" the TIFF belonged to. The classes are: TIFF-B-monochrome, TIFF-F-fascimile, TIFF-G-grayscale, TIFF-P-palette based, TIFF-R-RGB color, TIFF-X-any class, TIFF-Y-can use JPEG compression. Version 6.0 uses tags to divide the TIFF type into different file configurations, leaving behind the class concept. Version 6.0 configurations are: Bilevel, palette color, RGB, grayscale, YCbCr, and Class F (facsimile).

TIFF bitmap data can be stored in one of two configurations: strips or tiles. Strips are groups of adjoining rows of bitmap data, and can be found in version 5.0 and 6.0 files. Tiles were new to TIFF version 6.0. They are rectangular or square sections of bitmap data. The method of storage is determined in part by what kind of compression (if any) is used. JPEG compression can handle tiled images. Due to the need for padding with tile storage, tiling is not usually efficient for small images.

ImageGear supports the following compression schemes for TIFF:

  • Uncompressed
  • CCITT Group 3 Compression
  • CCITT Group 3 2D Compression
  • CCITT Group 4 Compression
  • Huffman Compression
  • JPEG Compression
  • Lossless JPEG Compression
  • LZW (Lempel-Ziv-Welch) Compression
  • Packbits Compression
  • Progressive JPEG Compression
  • Deflate Compression (both the 'normal' deflate compression and the Planar/Adobe-style deflate compression are supported)

See the ImageGear Supported Compressions Reference for descriptions of these compression types. The compression tag of the IFD tells whether the image is compressed, and by what method. (Not all TIFF files can use JPEG compression. It is supported by version 6.0, but in version 5.0, only a "Y" class TIFF can use JPEG).

TIFF/EP

TIFF/EP format was designed to provide a means for storing "raw" (unprocessed) image from digital camera's sensor.

TIFF/EP allows you to store several versions of the same image in one file. Typically, TIFF/EP image includes a small preview and a raw image. It can also include a larger or full-size preview, or some other variations of the image.

TIFF/EP uses IFD trees for storing different versions of image. This is different from IFD chains that are used in baseline TIFF to store multiple pages.

ImageGear does not detect TIFF/EP as a separate file format. In ImageGear for Java, a TIFF/EP file is detected as TIFF file. However, in ImageGear for Java, a TIFF/EP file can be recognized as a known Raw format and loaded as DCRAW or AdobeDNG.

Most of digital cameras store pixels in "mosaic" format. At a given pixel location either a Red, Green, Blue, Cyan, or some other color sample value is recorded. Such images are referred to as "Color Filter Array" type. TIFF/EP format uses a two-dimensional matrix called "Color Filter Array pattern" to describe positions of pixels of particular color in the mosaic image. In order to recreate the full color values in each pixel, it is necessary to interpolate intensities of neighboring pixels.

Note:
ImageGear for Java does not support color reconstruction of TIFF/EP images. ImageGear for Java can however reconstruct TIFF/EP image, if they are detected to be a DCRAW or Adobe DNG image.

To enable loading images from TIFF SubIFDs, a new control parameter is added to TIFF filter: "SUBIFD_PATH". This parameter has the type of String, and its default value is "" (empty string). By default, ImageGear loads the image in the root IFD (thumbnail). If "SUBIFD_PATH" string begins with a number, then ImageGear loads the image from the corresponding SubIFD of the root IFD. For example, if SUBIFD_PATH is set to "3", ImageGear will load the image from the 3rd SubIFD.

SUBIFD_PATH parameter also affects metadata reading. Metadata is loaded starting from the IFD specified by SUBIFD_PATH.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
WBMP
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > WBMP

Glossary Item Box

Full Name | WBMP (Wireless Bit-Map)
Format ID | ImGearFormats.WBMP
File Extension(s) | *.wbmp,
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 1.1

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.NONE - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The WBMP (Wireless Bit-Map) read/write format is optimized to support mobile computing devices that use the Wireless Application Protocol (WAP).

The file contains a small header with image parameters and an array of pixels in uncompressed form.

References Used

WAP WAE Specification Version, 24 May 1999.


%%ItemTitle%%

ImageGear for Java | Accusoft
WPG
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > WPG

Glossary Item Box

Full Name | WPG (WordPerfect Graphics Metafile)
Format ID | ImGearFormats.WPG
File Extension(s) | *.wpg
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • WPG for WP 5.1 and up can store bitmap and vector graphics in the same file.
  • WPG for WP 5.0 and prior can store only bitmap or vector graphic, but not both in same file.

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading

ImageGear Read Support

  • ImGearCompressions.RLE - Indexed RGB: 1, 4, 8 bpp

ImageGear Write Support

No

ImageGear Filter Control Parameters

None

Comments

This format was created specifically for use with WordPerfect software products. WPG files for WordPerfect versions 5.1 and up can store both bitmap and vector image data in the same file.

The WordPerfect Graphics Metafile contains a short header or "prefix" (as WordPerfect Corporation referred to it). The header is followed by a record area, that is a sequence of objects and their attributes. The first record is called the "Start WPG Data" record and contains information on the size of the images and the version number of the .WPG file. The next record is usually a color map, unless the image is black and white. The next record is a bitmap record. If there are multiple images, there is a bitmap record for each image. The last record in a .WPG file contains a NULL body to signify the end of the file. These files may also contain Encapsulated PostScript (EPS) data.

References Used

Murray, James D. "Graphic Image Format FAQ 3-4". James D. Murray, 1994-1996.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
XBM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > XBM

Glossary Item Box

Full Name | XBM (X BitMap)
Format ID | ImGearFormats.XBM
File Extension(s) | *.xbm
Data Type | Raster Image
Data Encoding | ASCII
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 11, data stored as 1-byte character, 1986
  • Version 10, data stored as 2-byte "short" integers

ImageGear Supported Features

  • IGFilterFormatFlags.DETECTSUPPORT - autodetection
  • IGFilterFormatFlags.PAGEREADSUPPORT - single page file reading
  • IGFilterFormatFlags.PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Write Support

  • ImGearCompressions.ASCII - Indexed RGB: 1 bpp

ImageGear Filter Control Parameters

None

Comments

The XBM format is intended as a convenient storage method for small monochrome images, for example, cursor and icon bitmaps. It can, however, support images of any size, but since it supports no native compression scheme, an exterior compression program is used when compacting is desired. The bitmap data is stored as ASCII data with C language syntax, making the file easy to insert into C program code. XBM data can be stored as a standalone graphics file, or within a C program header file. See also XPM, XWD.

XBM files begin with two to four #define statements in substitution of a header. These identify the image width and height, and optionally, the coordinates of a Hotspot, if one exists.

The image data follows and is more free-form than the other bitmap data formats described in this chapter. It consists of one variable-length static array of pixel values. Each value (in version 11) consists of one byte of data, and therefore represents 8 1-bit pixels. The first pixel (0,0) is represented by the high bit of the first byte in the array. Due to this one-array format, there is nothing in the data that explicitly marks the rows of the bitmap.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
XPM
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > XPM

Glossary Item Box

Full Name | XPM (X PixMap)
Format ID | ImGearFormats.XPM
File Extension(s) | *.xpm
Data Type | Raster Image
Data Encoding | ASCII (in C language syntax)
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 3.2g, April 1993

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp

ImageGear Filter Control Parameters

None

Comments

The XPM format was created as an extended version of the XBM file format. It is the informal standard for storing X Window pixmap data, including Hotspot information for cursor bitmaps. The image data is stored in ASCII text characters that are formatted as a standard C array of character strings. It is intended to be human-readable, is readily inserted into C/C++ program code, and can contain any number of comment lines. It therefore does not support a native compression scheme. If compacting is desired, an external compression program may be used. See also XBM, XWD.

All XPM files begin with a C language comment line containing "XPM". Following this are three sections of data: values, colors, and pixels, and an optional fourth section: extensions. The "values" section is the equivalent of the header structure typically found in a graphics file. It gives the size of the pixmap, as well as its number of colors, characters per pixel, the location of the Hotspot (if any), and an indicator of whether the file contains an extension section. Each section is set off with a comment-line title.

The colors section contains codes for the pixmap data characters. All pixels that make up the pixmap are assigned to one or more ASCII characters and one or more colors. (e.g. the character "X" may be assigned to the color red). There are several different conventions for identifying a color. If the string "None" appears as the color to be applied to a specific character, the character(s) symbolizes a transparent pixel.

The "pixels" section contains the bitmap data that appear as an array of character strings, where one row of bitmap data is represented by one array element. Each row is a group of characters set off by quotation marks. Each character is defined in the previous "colors" section.

If indicated by the values section, an extension section appears. It can contain one or more subsections that conform to one of two syntactical formats. An "XPMENDEXT" marker is always used to mark the end of the extension section.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
XWD
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported File Formats Reference > XWD

Glossary Item Box

Full Name | XWD (X Window Dump)
Format ID | ImGearFormats.XWD
File Extension(s) | *.xwd, *.wd (for Unix)
Data Type | Raster Image
Data Encoding | Binary
IG Multipage Support | No
IG Alpha Channel Support | No
IG Platforms Support | WIN32, WIN64, Linux32, Linux64, MAC32, MAC64

ImageGear Supported Versions

  • Version 7 for X11, June 1987 (X10 grayscale and palette only)

ImageGear Supported Features

  • DETECTSUPPORT - autodetection
  • PAGEREADSUPPORT - single page file reading
  • PAGEINSERTSUPPORT - single-page file writing

ImageGear Read Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Write Support

  • ImGearCompressions.NONE:
    • Indexed RGB: 1, 4, 8 bpp;
    • RGB: 24 bpp

ImageGear Filter Control Parameters

None

Comments

An XWD file can contain a representation of the window, the background, or the entire screen display. It has been designed to be a very versatile, device-independent format. See also XBM, XPM.

The general structure of the XWD graphics format begins with a long header, that is sometimes followed by a palette and contains the bitmap data. The header contains integer data and stores the header size, the XWD version, the size and location of the bitmap, the window size, location, and border width. A ByteOrder field indicates whether the bytes are stored in big-endian or little-endian order.

In the interest of making this format device-independent, the XWD supports six "visual classes" and three image formats. The visual class code is stored in the visual_class field of the header, and represents the following categories:

  • Static Gray, for most monochrome screens and using a fixed device-dependent color map;
  • GrayScale, for monochrome screens and using a software-supplied palette;
  • StaticColor, which uses a fixed device-dependent palette;
  • Pseudocolor, which uses a software-supplied palette and is intended for VGA screens;
  • TrueColor, with fixed device-dependent mapping of RGB values to screen colors;
  • DirectColor, with software-supplied mapping of RGB values to screen values.

The image-format categories, whose codes are stored in the pixmap_format field of the header, are called XYBitmap (1-bit), XYPixmap (single plane), and ZPixmap (two or more planes).

Where the value of pixmap_format indicates GrayScale, PseudoColor or DirectColor, a palette follows the header.

The image data is the last structure in the file. The bytes are stored in rows with groupings called "units", whose lengths are determined by the bitmap_unit field of the header.

If the pixmap_format field is 1, indicating an XYPixmap, there are multiple representations of the bitmap data, one for each color plane, where the first bitmap represents the highest bit of the data; the second bitmap represents the second-highest bit, and so on. An image with a bit depth of 4 yields a file with four bitmaps.

References Used

Brown, C. Wayne, and Barry J. Shepherd. Graphics File Formats: Reference and Guide. Greenwich, CT.: Manning Publications, 1992.

Kay, David C. and John R. Levine. Graphics File Formats. Windcrest Books, 1992.

Murray, James D. and William vanRyper. Encyclopedia of Graphics File Formats. Sebastopol, CA: O'Reilly & Associates, Inc., 1994.


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear Supported Non-Image Data
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data

Glossary Item Box

This section provides you with the detailed information about the following structures of supported by ImageGear for Java metadata:

  • TIFF Non-Image Data Structure
  • Photoshop Image Resource Metadata Structure
  • JPEG Non-Image Data Structure
  • EXIF Non-Image Data Structure
  • IPTC Non-Image Data Structure
  • PNG Non-Image Data Structure
  • GIF Non-Image Data Structure
  • DICOM Non-Image Data Structure
  • CIFF Non-Image Data Structure
  • XMP Non-Image Data Structure


%%ItemTitle%%

ImageGear for Java | Accusoft
TIFF Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > TIFF Non-Image Data Structure

Glossary Item Box

As with all multipage image formats, ImageGear for Java uses separate metadata trees for TIFF document-level metadata and TIFF page-level metadata:

  • Document level metadata:
    Name | Id | Type | Value Type | Value | Value Length | Ignored on save
    ByteOrder 59936 Leaf UINT16

    0x4949 or

    0x4D4D

            1 TRUE
    Identifier | 59937 | Leaf | UINT16 | 42 | 1 | TRUE

  • Page level metadata:

TIFF page level metadata corresponds to a TIFF IFD.

Tags

Most of TIFF tags are passed through metadata callback as

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<TagName> | <TagId> | VALUE_ITEM | <ValueType> | <TagValue> | <TagCount> | <R.o.>

The valid values of <TagName>, <TagId> and "Read Only" attributes are available in See Description of TIFF tags (ImGearTIFTagIDs). Table.

Note:
It is possible to use tag identifier and value of nonstandard tag (user defined tag).

The <TagCount> is real tag count value that is read/written in file.

The < ValueType > value is the metadata type constant that matches TIFF tag type as described in the table below:

TIFF tag type | Metadata type (ImGearNativeDataTypes)
BYTE | UINT8
SBYTE | INT8
SHORT | UINT16
SSHORT | INT16
LONG | UINT32
SLONG | INT32
RATIONAL | RATIONAL_UINT32
SRATIONAL | RATIONAL_INT32
FLOAT | FLOAT
DOUBLE | DOUBLE
ASCII | STRING
UNDEFINED | AM_TID_RAW_DATA

Description of TIFF tags (ImGearTIFTagIDs)

Item Name | Item Id | Ignored on save
"NewSubfileType" | 254 | TRUE
"SubfileType" | 255 | TRUE
"ImageWidth" | 256 | TRUE
"ImageLength" | 257 | TRUE
"BitsPerSample" | 258 | TRUE
"Compression" | 259 | TRUE
"PhotometricInterpretation" | 262 | TRUE
"Threshholding" | 263 | FALSE
"CellWidth" | 264 | TRUE
"CellLength" | 265 | TRUE
"FillOrder" | 266 | FALSE
"DocumentName" | 269 | FALSE
"ImageDescription" | 270 | FALSE
"Make" | 271 | FALSE
"Model" | 272 | FALSE
"StripOffsets" | 273 | TRUE
"Orientation" | 274 | FALSE
"SamplesPerPixel" | 277 | TRUE
"RowsPerStrip" | 278 | TRUE
"StripByteCounts" | 279 | TRUE
"MinSampleValue" | 280 | FALSE
"MaxSampleValue" | 281 | FALSE
"XResolution" | 282 | FALSE
"YResolution" | 283 | FALSE
"PlanarConfiguration" | 284 | TRUE
"PageName" | 285 | FALSE
"XPosition" | 286 | FALSE
"YPosition" | 287 | FALSE
"FreeOffsets" | 288 | TRUE
"FreeByteCounts" | 289 | TRUE
"GrayResponseUnit" | 290 | FALSE
"GrayResponseCurve" | 291 | FALSE
"T4Options" | 292 | TRUE
"T6Options" | 293 | TRUE
"ResolutionUnit" | 296 | FALSE
"PageNumber" | 297 | TRUE
"TransferFunction" | 301 | FALSE
"Software" | 305 | FALSE
"DateTime" | 306 | FALSE
"Artist" | 315 | FALSE
"HostComputer" | 316 | FALSE
"Predictor" | 317 | TRUE
"WhitePoint" | 318 | FALSE
"PrimaryChromaticities" | 319 | FALSE
"ColorMap" | 320 | TRUE
"HalftoneHints" | 321 | FALSE
"TileWidth" | 322 | TRUE
"TileLength" | 323 | TRUE
"TileOffsets" | 324 | TRUE
"TileByteCounts" | 325 | TRUE
"InkSet" | 332 | FALSE
"InkNames" | 333 | FALSE
"NumberOfInks" | 334 | FALSE
"DotRange" | 336 | FALSE
"TargetPrinter" | 337 | FALSE
"ExtraSamples" | 338 | TRUE
"SampleFormat" | 339 | FALSE
"SMinSampleValue" | 340 | FALSE
"SMaxSampleValue" | 341 | FALSE
"TransferRange" | 342 | FALSE
"JPEGTables" | 347 | TRUE
"JPEGProc" | 512 | TRUE
"JPEGInterchangeFormat" | 513 | TRUE
"JPEGInterchangeFormatLngth" | 514 | TRUE
"JPEGRestartInterval" | 515 | TRUE
"JPEGLosslessPredictors" | 517 | TRUE
"JPEGPointTransforms" | 518 | TRUE
"JPEGQTables" | 519 | TRUE
"JPEGDCTables" | 520 | TRUE
"JPEGACTables" | 521 | TRUE
"YCbCrCoefficients" | 529 | FALSE
"YCbCrSubSampling" | 530 | TRUE
"YCbCrPositioning" | 531 | FALSE
"ReferenceBlackWhite" | 532 | FALSE
"Copyright" | 33432 | FALSE
"PhotoshopResources" | 34377 | FALSE
"ExifIFDPointer" | 34665 | TRUE
"GPSInfoIFDPointer" | 34675 | TRUE
Note:
Please see file ImGearTIFTagIDs enum for the full list of TIFF Metadata Item Id constants.

TIFF Complex Data Tags

Some tags, which value is a complex data, can be passed in parsed form as a tree. In this case, a single metadata item is replaced with a tree that uses one of the specialized metadata formats, such as Photoshop (PhotoshopImageResources) or IPTC.

EXIF metadata

ExifIFDPointer tag in a TIFF file points to an IFD which contains tags defined in the EXIF image file format specification. ImageGear replaces this tag with EXIF metadata tree.

EXIF metadata usually contains nested IFDs as well.

SubIFDs

TIFF images can contain "SubIFDs" - nested sets of tags. A SubIFD usually contains a special version of image, such as a thumbnail, or a Raw image taken from a digital camera sensor.

ImageGear represents SubIFDs as subtrees of the root TIFF IFD.


%%ItemTitle%%

ImageGear for Java | Accusoft
Photoshop Image Resource Metadata Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > Photoshop Image Resource Metadata Structure

Glossary Item Box

PhotoshopResources Level

This level can contain arbitrary number of PhotoshopImageResource subtrees:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
PhotoshopImageResource | <Res. Id> | Tree | N/A | N/A | N/A | N/A
Or in case the data is parsed
ResolutionInfo | ImGearPHOTOSHOPTagIDs.ResolutionInfo | Tree | N/A | N/A | N/A | N/A
AlphaNames | ImGearPHOTOSHOPTagIDs.AlphaNames | Tree | N/A | N/A | N/A | N/A
DisplayInfo | ImGearPHOTOSHOPTagIDs.DisplayInfo | Tree | N/A | N/A | N/A | N/A
Caption | ImGearPHOTOSHOPTagIDs.Caption | Tree | N/A | N/A | N/A | N/A
IPTC | ImGearPHOTOSHOPTagIDs.IPTC | Tree | N/A | N/A | N/A | N/A
Thumbnail | ImGearPHOTOSHOPTagIDs.Thumbnail | Tree | N/A | N/A | N/A | N/A
ICCProfile | ImGearPHOTOSHOPTagIDs.ICCProfile | Tree | N/A | N/A | N/A | N/A
UnicodeAlphaNames | ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames | Tree | N/A | N/A | N/A | N/A
TransparencyIndex | ImGearPHOTOSHOPTagIDs.TransparencyIndex | Tree | N/A | N/A | N/A | N/A
AlphaIdentifiers | ImGearPHOTOSHOPTagIDs.AlphaIdentifiers | Tree | N/A | N/A | N/A | N/A
VersionInfo | ImGearPHOTOSHOPTagIDs.VersionInfo | Tree | N/A | N/A | N/A | N/A

PhotoShopImageResource Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"PhotoshopImageResourceSize" | <Res. Id> | Leaf | UINT16 |  | 1 | True
Resource data
"Data" | ImGearPHOTOSHOPTagID s.SEGMENTDATA | Leaf | RAW_DATA |  |  | False
Or in case the data are parsed (currently it happens only for IPTC data)
"ResolutionInfo" | ImGearPHOTOSHOPTagIDs.ResolutionInfo | Tree | N/A | N/A | N/A | False
"AlphaNames" | ImGearPHOTOSHOPTagIDs.AlphaNames | Tree | N/A | N/A | N/A | False
DisplayInfo" | ImGearPHOTOSHOPTagIDs.DisplayInfo | Tree | N/A | N/A | N/A | False
"Caption" | ImGearPHOTOSHOPTagIDs.Caption | Tree | N/A | N/A | N/A | False
"IPTC" | ImGearPHOTOSHOPTagIDs.IPTC | Tree | N/A | N/A | N/A | False
"Thumbnail" | ImGearPHOTOSHOPTagIDs.Thumbnail | Tree | N/A | N/A | N/A | False
"ICCProfile" | ImGearPHOTOSHOPTagIDs.ICCProfile | Tree | N/A | N/A | N/A | False
"UnicodeAlphaNames" | ImGearPHOTOSHOPTagIDs.UnicodeAlphaNames | Tree | N/A | N/A | N/A | False
"TransparencyIndex" | ImGearPHOTOSHOPTagIDs.TransparencyIndex | Tree | N/A | N/A | N/A | False
"AlphaIdentifiers" | ImGearPHOTOSHOPTagIDs.AlphaIdentifiers | Tree | N/A | N/A | N/A | False
"VersionInfo" | ImGearPHOTOSHOPTagIDs.VersionInfo | Tree | N/A | N/A | N/A | False


%%ItemTitle%%

ImageGear for Java | Accusoft
JPEG Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > JPEG Non-Image Data Structure

Glossary Item Box

JPEG metadata structure is framed in several levels:

  • See JPEG level. containing all JPEG metadata,
  • See JPEG marker segment levels. containing metadata of each particular JPEG marker segment.

JPEG Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"JPEG-JFIF" | ImGearFormats.JPG | Tree |  |  |  |
JPEG marker segment levels

JPEG Marker Segment Levels

The following JPEG marker segments metadata are supported:

  • See Frame marker segment level. - SOF0, SOF1, SOF2 and SOF3 (read only)
  • See Frame component level.
  • See Scan marker segment level. - SOS (read only)
  • See Scan component level.
  • See Define-quantization-table marker segment level. - DQT (read only)
  • See Define-quantization-table table level.
  • See Define-Huffman-tables marker segment level. - DHT (read only)
  • See Define-Huffman-table table level.
  • See Comment marker segment level. - COM (read/write),
  • See Application marker segment level. - APP0-APP15 (read/write).

Segment level markers are described in the tables below.

Frame Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Precision" | ImGearJPEGTagIDs. FRAME_PRECISION | Leaf | UINT8 |  | 1 | TRUE
"Lines" | ImGearJPEGTagIDs. FRAME_LINES | Leaf | UINT16 |  | 1 | TRUE
"SamplesPerLine" | ImGearJPEGTagIDs. FRAME_SAMPLES_PER_LINE | Leaf | UINT16 |  | 1 | TRUE
"NumberOfComponents" | ImGearJPEGTagIDs. FRAME_NUMBER_OF_COMPONENTS | Leaf | UINT8 | <n> | 1 | TRUE
Frame component level 1 | ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC | Tree |  |  |  |
...
Frame component level <n> | ImGearJPEGTagIDs. FRAME_COMPONENT_SPEC | Tree |  |  |  |

Frame Component Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Identifier" | ImGearJPEGTagIDs. FRAME_COMPONENT_ID | Leaf | UINT | <Component No.> | 1 | TRUE
HVSamplingFactors | ImGearJPEGTagIDs. FRAME_COMPONENT_HV_SAMPLING | Leaf | UINT |  | 1 | TRUE
"QuantizationNumber" | ImGearJPEGTagIDs. FRAME_COMPONENT_QUANT_SELECTOR | Leaf | UINT |  | 1 | TRUE

Note:
<Component No.> is frame component identifier of appropriate component.

Scan Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"ComponentNumber" | ImGearJPEGTagIDs. SCAN_COMPONENT_NUMBER | Leaf | UINT8 | <n> | 1 | TRUE
Scan component level 1 | ImGearJPEGTagIDs.SCAN_COMPONENT | Tree |  |  |  |
Scan component level <n> | ImGearJPEGTagIDs.SCAN_COMPONENT | Tree |  |  |  |
"SpectralStart" | ImGearJPEGTagIDs.SCAN_SP_START | Leaf | UINT8 |  | 1 | TRUE
"SpectralEnd" | ImGearJPEGTagIDs.SCAN_SP_END | Leaf | UINT8 |  |  | TRUE
"AH_AL" | ImGearJPEGTagIDs.SCAN_AH_AL | Leaf | UINT8 |  |  | TRUE

Scan Component Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Selector" | ImGearJPEGTagIDs. SCAN_SELECTOR | Leaf | UINT8 |  | 1 | TRUE
"DC_AC" | ImGearJPEGTagIDs. SCAN_DC_AC | Leaf | UINT8 |  | 1 | TRUE

Define-Quantization-Table Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"QuantizationTable" | ImGearJPEGTagIDs.QUANT_TABLE | Tree |  |  |  |
"QuantizationTable" | ImGearJPEGTagIDs.QUANT_TABLE | Tree |  |  |  |

Define-Quantization-Table Table Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Descriptor" | ImGearJPEGTagIDs. QUANT_TABLE_DESCRIPTOR | Leaf | UINT8 |  |  | TRUE
"Elements" | ImGearJPEGTagIDs. QUANT_TABLE_ELEMENTS | Leaf | UINT8 or UINT16 |  |  | TRUE

Define-Huffman-Tables Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"HuffmanTable" | ImGearJPEGTagIDs.HUFFMAN_TABLE | Tree |  |  |  |
"HuffmanTable" | ImGearJPEGTagIDs.HUFFMAN_TABLE | Tree |  |  |  |

Define-Huffman-Table Table Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Descriptor" | ImGearJPEGTagIDs. HUFFMAN_TABLE_DESCRIPTOR | Leaf | UINT8 |  |  | TRUE
"Lengths" | ImGearJPEGTagIDs. HUFFMAN_TABLE_LENGTH | Leaf | UINT8 |  |  | TRUE
"Values" | ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES | Leaf | UINT8 |  |  | TRUE
"Values" | ImGearJPEGTagIDs. HUFFMAN_TABLE_VALUES | Leaf | UINT8 |  |  | TRUE

Comment Marker Segment Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Comment" | ImGearJPEGTagIDs. COMMENT | Leaf | STRING |  | <ValueSize> | FALSE

Application Marker Segment Level

There are several application marker segments, which data structure is well known. These segments are parsed and their data are passed in special format.

These marker segments are:

  • See JFIF APP0 segment.
  • JFIF extension (JFXX) APP0 segment (read only)
  • EXIF APP1 segment
  • See Photoshop Image Resource APP13 marker segment. (it includes some IPTC data and another See Photoshop Image Resource metadata structure. )
  • See Other application marker segment levels.

JFIF APP0 Segment

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"JFIF_HEADER" | ImGearJPEGTagIDs. JFIF_ID | Leaf | STRING | JFIF | 5 | TRUE
"Version" | ImGearJPEGTagIDs. JFIF_VERSION | Leaf | UINT16 |  | 1 | FALSE
"ResolutionUnits" | ImGearJPEGTagIDs. JFIF_UNITS | Leaf | UINT8 |  | 1 | FALSE
"ResolutionX" | ImGearJPEGTagIDs. JFIF_X_RES | Leaf | UINT16 |  | 1 | FALSE
"ResolutionY" | ImGearJPEGTagIDs. JFIF_Y_RES | Leaf | UINT16 |  | 1 | FALSE
"ThumbnailWidth"18 | ImGearJPEGTagIDs. JFIF_THUMB_WIDTH | Leaf | UINT8 |  | 1 | TRUE
"ThumbnailHeight"19 | ImGearJPEGTagIDs. JFIF_THUMB_HEIGHT | Leaf | UINT8 |  | 1 | TRUE

Photoshop Image Resource APP13 Marker Segment

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"PHOTOSHOP_HEADER" | ImGearJPEGTagIDs. PHOTOSHOP_HEADER | Leaf | STRING | "Photoshop 3.0" | 14 | FALSE
Photoshop Image Resource level 1
...
Photoshop Image Resource level n

Note:
For "Photoshop Image Resource" metadata structure see Photoshop Image Resource metadata structure Table.

Other Application Marker Segment Levels

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"DATA" | ImGearJPEGTagIDs. BINARY_DATA | Leaf | RAW_DATA |  | <ValueSize> | FALSE


%%ItemTitle%%

ImageGear for Java | Accusoft
EXIF Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > EXIF Non-Image Data Structure

Glossary Item Box

ImageGear for Java processes EXIF as a metadata format, rather than as a separate image file format.

EXIF Level Metadata

EXIF level metadata uses the following structure.

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF subIFD tags> | <EXIF subIFD tag ids> |  |  |  |  |
"Interoperability" | ImGearMetadataFormats.INTEROPERABILITYIFD | Tree |  |  |  |
"GPS" | ImGearMetadataFormats.INTEROPERABILITYIFD | Tree |  |  |  |

Interoperability and GPS IFDs are optional.

See See Exif subIFD tags. for the list of Exif subIFD tag names and Ids.

EXIF GPS Level Metadata

EXIF GPS level metadata uses the following structure:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF GPS tags> | <EXIF GPS tag ids> |  |  |  |  |

See See GPS subIFD tags. for the list of EXIF GPS tag names and Ids.

EXIF Interoperability Level Metadata

EXIF Interoperability level metadata uses the following structure:

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<EXIF Interoperability tags> | <EXIF Interoperability tag ids> |  |  |  |  |

See See Interoperability subIFD tags. for the list of EXIF Interoperability tag names and Ids.

Description of Tags Used in EXIF

The following types of EXIF tags are described below:

  • See Exif subIFD tags.
  • See GPS subIFD tags.
  • See Interoperability subIFD tags.

Exif subIFD Tags

Item Name | Item Id | Ignored on save
"ExposureTime" | 33434 | FALSE
"Fnumber" | 33437 | FALSE
"ExposureProgram" | 34850 | FALSE
"SpectralSensitivity" | 34852 | FALSE
"ISOSpeedRatings" | 34855 | FALSE
"OECF" | 34856 | FALSE
"ExifVersion" | 36864 | FALSE
"DateTimeOriginal" | 36867 | FALSE
"DateTimeDigitized" | 36868 | FALSE
"ComponentsConfiguration" | 37121 | FALSE
"CompressedBitsPerPixel" | 37122 | FALSE
"ShutterSpeedValue" | 37377 | FALSE
"ApertureValue" | 37378 | FALSE
"BrightnessValue" | 37379 | FALSE
"ExposureBiasValue" | 37380 | FALSE
"MaxApertureValue" | 37381 | FALSE
"SubjectDistance" | 37382 | FALSE
"MeteringMode" | 37383 | FALSE
"LightSource" | 37384 | FALSE
"Flash" | 37385 | FALSE
"FocalLength" | 37386 | FALSE
"SubjectArea" | 37396 | FALSE
"MakerNote" | 37500 | FALSE
"UserComment" | 37510 | FALSE
"SubSecTime" | 37520 | FALSE
"SubSecTimeOriginal" | 37521 | FALSE
"SubSecTimeDigitized" | 37522 | FALSE
"FlashPixVersion" | 40960 | FALSE
"ColorSpace" | 40961 | FALSE
"PixelXDimension" | 40962 | TRUE
"PixelYDimension" | 40963 | TRUE
"RelatedSoundFile" | 40964 | FALSE
"InteroperabilityIFDPointer" | 40965 | TRUE
"FlashEnergy" | 41483 | FALSE
"SpatialFrequencyResponse" | 41484 | FALSE
"FocalPlaneXResolution" | 41486 | FALSE
"FocalPlaneYResolution" | 41487 | FALSE
"FocalPlaneResolutionUnit" | 41488 | FALSE
"SubjectLocation" | 41492 | FALSE
"ExposureIndex" | 41493 | FALSE
"SensingMethod" | 41495 | FALSE
"FileSource" | 41728 | FALSE
"SceneType" | 41729 | FALSE
"CFAPattern" | 41730 | FALSE
"CustomRendered" | 41985 | FALSE
"ExposureMode" | 41986 | FALSE
"WhiteBalance" | 41987 | FALSE
"DigitalZoomRatio" | 41988 | FALSE
"FocalLengthIn35mmFilm" | 41989 | FALSE
"SceneCaptureType" | 41990 | FALSE
"GainControl" | 41991 | FALSE
"Contrast" | 41992 | FALSE
"Saturation" | 41993 | FALSE
"Sharpness" | 41994 | FALSE
"DeviceSettingDescription" | 41995 | FALSE
"SubjectDistanceRange" | 41996 | FALSE
"ImageUniqueID" | 42016 | FALSE

GPS subIFD Tags

Item Name | Item Id | Ignored on save
"GPSVersionID" | 0 | FALSE
"GPSLatitudeRef" | 1 | FALSE
"GPSLatitude" | 2 | FALSE
"GPSLongitudeRef" | 3 | FALSE
"GPSLongitude" | 4 | FALSE
"GPSAltitudeRef" | 5 | FALSE
"GPSAltitude" | 6 | FALSE
"GPSTimeStamp" | 7 | FALSE
"GPSSatellites" | 8 | FALSE
"GPSStatus" | 9 | FALSE
"GPSMeasureMode" | 10 | FALSE
"GPSDOP" | 11 | FALSE
"GPSSpeedRef" | 12 | FALSE
"GPSSpeed" | 13 | FALSE
"GPSTrackRef" | 14 | FALSE
"GPSTrack" | 15 | FALSE
"GPSImgDirectionRef" | 16 | FALSE
"GPSImgDirection" | 17 | FALSE
"GPSMapDatum" | 18 | FALSE
"GPSDestLatitudeRef" | 19 | FALSE
"GPSDestLatitude" | 20 | FALSE
"GPSDestLongitudeRef" | 21 | FALSE
"GPSDestLongitude" | 22 | FALSE
"GPSDestBearingRef" | 23 | FALSE
"GPSDestBearing" | 24 | FALSE
"GPSDestDistanceRef" | 25 | FALSE
"GPSDestDistance" | 26 | FALSE
"GPSProcessingMethod" | 27 | FALSE
"GPSAreaInformation" | 28 | FALSE
"GPSDateStamp" | 29 | FALSE
"GPSDifferential" | 30 | FALSE

Interoperability subIFD Tags

Item Name | Item Id | Read Only
"InteroperabilityIndex " | 1 | FALSE
"InteroperabilityVersion " | 2 | FALSE
"RelatedImageFileFormat" | 4096 | FALSE
"RelatedImageWidth " | 4097 | FALSE
"RelatedImageLength" | 4098 | FALSE


%%ItemTitle%%

ImageGear for Java | Accusoft
IPTC Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > IPTC Non-Image Data Structure

Glossary Item Box

International Press and Telecommunications Council Standards (IPTC) have been created for exchanging different type of information.

IPTC is a metadata format rather than a image file format. It can be stored within JPEG and TIFF image files as Adobe Photoshop Image Resource (see See Photoshop Image Resource metadata structure. ). In TIFF files the IPTC data is stored in TIFF tag with Id = 34377 (see See TIFF Non-Image Data Structure. for metadata structure of the tag). In JPEG files, the IPTC data is stored in Photoshop Image Resource APP13 marker segment (see JPEG Non-Image Data Structure).

ImageGear IPTC metadata structure is framed in two levels:

  • See IPTC level. containing all IPTC data
  • See Record level. containing value items of a record.

IPTC Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
Record level 1 | <Record#> | Tree |  |  |  |
Record level n | <Record#> | Tree |  |  |  |

The <Record#> tag is the primary identifier of IPTC record. Its value is the number of appropriate IPTC record described in IPTC - NAA IIM4 specification. Record levels must follow in numerical order within IPTC level.

Record Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
Dataset value item | <DataSet ID> | Leaf | <Value Type> | <Data> | <Item Count> | FALSE
Dataset value item | <DataSet ID> | Leaf | <Value Type> | <Data> | <Item Count> | FALSE

The available <Dataset name>, <Dataset Id>, <Item Count> and <Value Type> values are described below for each IPTC record according to IPTC-NAA IIM4 specification. Dataset value item can follow in any order within appropriate record level.

In the tables below, the last column lists the maximum item count for non-string types, and string length for string types. Item count for string types in IPTC metadata is always 1.

Dataset Value Items Description for IPTC Envelope Record (Record #1)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "ModelVersion" | UINT16 | 1
5 | "Destination" | STRING | 1024
20 | "FileFormat" | UINT16 | 1
22 | "FileFormatVersion" | UINT16 | 1
30 | "ServiceIdentifier" | STRING | 10
40 | "EnvelopeNumber" | STRING | 8
50 | "ProductID" | STRING | 32
60 | "EnvelopePriority" | STRING | 1
70 | "DateSent" | STRING | 8
80 | "TimeSent" | STRING | 11
90 | "CodedCharacterSet" | STRING | 32
100 | "UNO" | STRING | 80
120 | "ARMIdentifier" | UINT16 | 1
122 | "ARMVersion" | UINT16 | 1

Dataset Value Items Description for IPTC Application Record (Record #2)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "RecordVersion" | UINT16 | 1
3 | "ObjectTypeReference" | STRING | 67
4 | "ObjectAttributeReference" | STRING | 68
5 | "ObjectName" | STRING | 64
7 | "EditStatus" | STRING | 64
8 | "EditorialUpdate" | STRING | 2
10 | "Urgency" | STRING | 1
12 | "SubjectReference" | STRING | 236
15 | "Category" | STRING | 3
20 | "SupplementalCategory" | STRING | 32
22 | "FixtureIdentifier" | STRING | 32
25 | "Keywords" | STRING | 64
26 | "ContentLocationCode" | STRING | 3
27 | "ContentLocationName" | STRING | 64
30 | "ReleaseDate" | STRING | 8
35 | "ReleaseTime" | STRING | 11
37 | "ExpirationDate" | STRING | 8
38 | "ExpirationTime" | STRING | 11
40 | "SpecialInstructions" | STRING | 256
42 | "ActionAdvised" | STRING | 2
45 | "ReferenceService" | STRING | 10
47 | "ReferenceDate" | STRING | 8
50 | "ReferenceNumber" | STRING | 8
55 | "DateCreated" | STRING | 8
60 | "TimeCreated" | STRING | 11
62 | "DigitalCreationDate" | STRING | 8
63 | "DigitalCreationTime" | STRING | 11
65 | "OriginatingProgram" | STRING | 32
70 | "ProgramVersion" | STRING | 10
75 | "ObjectCycle" | STRING | 1
80 | "By-line" | STRING | 32
85 | "By-lineTitle" | STRING | 32
90 | "City" | STRING | 32
92 | "Sublocation" | STRING | 32
95 | "Province/State" | STRING | 32
100 | "Country/ <P></P>PrimaryLocationCode" | STRING | 3
101 | "Country/ <P></P>PrimaryLocationName" | STRING | 64
103 | "OriginalTransmission <P></P>Reference" | STRING | 32
105 | "Headline" | STRING | 256
110 | "Credit" | STRING | 32
115 | "Source" | STRING | 32
116 | "CopyrightNotice" | STRING | 128
118 | "Contact" | STRING | 128
120 | "Caption/Abstract" | STRING | 2000
122 | "Writer/Editor" | STRING | 32
125 | "RasterizedCaption" | UINT8 | 7360
130 | "ImageType" | STRING | 2
131 | "ImageOrientation" | STRING | 1
135 | "LanguageIdentifier" | STRING | 3
150 | "AudioType" | STRING | 2
151 | "AudioSamplingRate" | STRING | 6
152 | "AudioSamplingResolution" | STRING | 2
153 | "AudioDuration" | STRING | 6
154 | "AudioOutcue" | STRING | 64
200 | "ObjectDataPreview <P></P>FileFormat" | UINT16 | 1
201 | "ObjectDataPreview <P></P>FileFormatVersion" | UINT16 | 1
202 | "ObjectDataPreviewData" | UINT8 | Undefined

Dataset Value Items Description for IPTC Digital News Photo Parameter Record (Record #3)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
0 | "RecordVersion" | UINT16 | 1
10 | "PictureNumber" | RAW_DATA | 16
20 | "PixelsPerLine" | UINT16 | 1
30 | "NumberOfLine" | UINT16 | 1
40 | "PixelSizeInScanningDirection" | UINT16 | 1
50 | "PixelSizePerpendicularTo <P></P>ScanningDirection" | UINT16 | 1
55 | "SupplementType" | UINT8 | 1
60 | "ColourRepresentation" | UINT8 | 2
64 | "InterchangeColourSpace" | UINT8 | 1
65 | "ColourSequence" | UINT8 | 4
66 | "ICCInputColourProfile" | RAW_DATA | Undefined
70 | "ColourCalibrationMatrixTable" | RAW_DATA | Undefined
80 | "LookupTable" | RAW_DATA | 131072
84 | "NumberOfIndexEntries" | UINT16 | 1
85 | "ColourPalette" | RAW_DATA | Undefined
86 | "NumberOfBitsPerSample" | UINT8 | 1
90 | "SamplingStructure" | UINT8 | 1
100 | "ScanningDirection" | UINT8 | 1
102 | "ImageRotation" | UINT8 | 1
110 | "DataCompressionMethod" | RAW_DATA | 4
120 | "QuantisationMethod" | UINT8 | 1
125 | "EndPoints" | UINT8 | Undefined
130 | "ExcursionTolerance" | UINT8 | 1
135 | "BitsPerComponent" | UINT8 | Undefined
140 | "MaximumDensityRange" | UINT16 | 1
145 | "GammaCompensatedValue" | UINT16 | 1

Dataset Value Items Description for IPTC Pre-Object Descriptor Record (Record #7)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "SizeMode" | UINT8 | 1
20 | "MaxSubfileSize" | UINT8 or UINT16 or UINT32 | 1
90 | "ObjectDataSizeAnnounced" | UINT8 or UINT16 or UINT32 | 1
95 | "MaximumObjectDataSize" | UINT8 or UINT16 or UINT32 | 1

Dataset Value Items Description for IPTC Object Record (Record #8)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "Subfile" | RAW_DATA | Undefined

Dataset Value Items Description for IPTC Post-Object Descriptor Record (Record #9)

Item Identifier | Item Name | Value Type | Max. Value Length (for String last NULL is not counted)
10 | "ConfirmedObjectDataSize" | UINT8 or UINT16 or UINT32 | 1


%%ItemTitle%%

ImageGear for Java | Accusoft
PNG Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > PNG Non-Image Data Structure

Glossary Item Box

PNG format groups non-image data in "Chunks". ImageGear represents simpler chunks by single metadata items, and more complex chunks by subtrees. Thus, there are two main PNG metadata levels in ImageGear:

  • See PNG metadata level.
  • See PNG chunks metadata level.

PNG Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
<PNG chunk names> | <PNG chunk ids> | <PNG chunk type> |  |  |  |

For <PNG chunk names >, <PNG chunk ids> and <PNG Chunk types> see See PNG chunks metadata level. section.

PNG Chunks Metadata Level

The following PNG non-image chunk levels are supported by ImageGear:

  • See PNG header chunk metadata.
  • See Physical dimension chunk metadata.
  • See Transparency chunk metadata.
  • See Gamma chunk metadata.
  • See Primary chromaticities chunk metadata.
  • See sRGB chunk metadata.
  • See ICC profile chunk metadata.
  • See Background chunk metadata.
  • See Significant bits chunk metadata.
  • See Suggested palette chunk metadata.
  • See Palette histogram chunk metadata.
  • See Modified time chunk metadata.
  • See Text chunk metadata.
  • See Compressed textual data chunk metadata.
  • See International textual data chunk metadata.
  • See Calibration of pixel values chunk metadata.
  • See Physical scale chunk metadata.
  • See GIF application extension chunk metadata.
  • See GIF Graphic Control Extension chunk metadata.
  • See Image offset chunk metadata.
  • See The rest chunk metadata.

PNG Header Chunk Metadata PNG Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"IHDR" | 0x49484452 | Tree |  |  |  |

Header Chunk Level

Name | Id | Type | Value Type | Value | Value Length | Ignored on save
"Width" | 0x49484452 | Leaf | UINT32 |  | 1 | TRUE
"Height" | 0x49484452 | Leaf | UINT32 |  | 1 | TRUE
"BitDepth" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"ColorType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"CompressionType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"FilterType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE
"InterlaceType" | 0x49484452 | Leaf | UINT8 |  | 1 | TRUE

Physical Dimension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"pHYs" | 0x70485973 | Tree |  |  |  |

Physical Dimension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"XAxis" | 0x70485973 | Leaf | UINT32 |  | 1 | FALSE
"YAxis" | 0x70485973 | Leaf | UINT32 |  | 1 | FALSE
"UnitSpecifier" | 0x70485973 | Leaf | UINT8 |  | 1 | FALSE

Transparency Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tRNS" | 0x74524e53 | Leaf | UINT8 or UINT16 |  | Variable | FALSE

Gamma Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gAMA" | 0x67414d41 | Leaf | UINT32 |  | 1 | FALSE

Primary Chromaticities Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"cHRM" | 0x6348524d | Tree |  |  |  |

Primary Chromaticities Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"WhitePoint" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Red" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Green" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"Blue" | 0x6348524d | Tree |  |  |  |
"x" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE
"y" | 0x6348524d | Leaf | UINT32 |  | 1 | FALSE

sRGB Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sRGB" | 0x73524742 | Leaf | UINT32 |  | 1 | FALSE

ICC Profile Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"iCCP" | 0x70485973 | Tree |  |  |  |

ICC Profile Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"ProfileName" | 0x70485973 | Leaf | STRING |  | Variable | FALSE
"ProfileData" | 0x70485973 | Leaf | RAW_DATA |  | Variable | FALSE

Background Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"bKGD" | 0x624b4744 | Leaf | UINT8 or UINT16 |  | Variable | FALSE

Significant Bits Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sBIT" | 0x73424954 | Leaf | UINT8 |  | Variable | FALSE

Suggested Palette Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sPLT" | 0x73504c54 | Tree |  |  |  |

Suggested Palette Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"PaletteName" | 0x73504c54 | Leaf | STRING |  | Variable | TRUE
"SampleDepth" | 0x73504c54 | Leaf | UINT8 |  | 1 | FALSE
"PaletteEntryCount" | 0x73504c54 | Leaf | UINT16 | <N> | 1 | FALSE
Palette entry level 0 | <Entry No.> | Tree |  |  |  |
...
Palette entry level n | <Entry No.> | Tree |  |  |  |

Palette Entry Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Red" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Green" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Blue" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Alpha" | <Entry No.> | Leaf | UINT8 or UINT16 |  | 1 | FALSE
"Frequency" | <Entry No.> | Leaf | UINT16 |  | 1 | FALSE

Palette Histogram Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"hIST" | 0x68495354 | Leaf | UINT16 |  | Variable | FALSE

Modified Time Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tIME" | 0x74494d45 | Tree |  |  |  |

Modified Time Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Year" | 0x74494d45 | Leaf | UINT16 |  | 1 | FALSE
"Month" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Day" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Hour" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Minute" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE
"Second" | 0x74494d45 | Leaf | UINT8 |  | 1 | FALSE

Text Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"tEXt" | 0x74455874 | Tree |  |  |  |

Text Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x74455874 | Leaf | STRING |  | Variable | FALSE
"Text" | 0x74455874 | Leaf | STRING |  | Variable | FALSE

Compressed Textual Data Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"zTXt" | 0x7a545874 | Tree |  |  |  |

Compressed Textual Data Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x7a545874 | Leaf | STRING |  | Variable | FALSE
"CompressionMethod" | 0x7a545874 | Leaf | UINT8 |  | 1 | FALSE
"Text" | 0x7a545874 | Leaf | STRING |  | Variable | FALSE

International Textual Data Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"zTXt" | 0x69545874 | Tree |  |  |  |

International Textual Data Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"Keyword" | 0x69545874 | Leaf | STRING |  | Variable | FALSE
"CompressionFlag" | 0x69545874 | Leaf | BOOL |  |  |
"CompressionMethod" | 0x69545874 | Leaf | UINT8 |  | 1 | FALSE
"LanguageTag" | 0x69545874 | Leaf | STRING |  |  |
"TranslatedKeyword" | 0x69545874 | Leaf | RAW_DATA |  |  |
"Text" | 0x69545874 | Leaf | RAW_DATA |  | Variable | FALSE

Calibration of Pixel Values Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"pCAL" | 0x7043414c | Tree |  |  |  |

Calibration of Pixel Values Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"CalibrationName" | 0x7043414c | Leaf | STRING |  | Variable | FALSE
"OriginalZero(x0)" | 0x7043414c | Leaf | INT32 |  | 1 | FALSE
"OriginalMax(x1)" | 0x7043414c | Leaf | INT32 |  | 1 | FALSE
"EquationType" | 0x7043414c | Leaf | UINT8 |  | 1 | FALSE
"NumberOfParameters" | 0x7043414c | Leaf | UINT8 | <N> | Variable | FALSE
"UnitName" | 0x7043414c | Leaf | STRING |  | Variable | FALSE
"CalibrationParameter" | 0 | Leaf | STRING |  | Variable | FALSE
...
"CalibrationParameter" | <N> - 1 | Leaf | STRING |  | Variable | FALSE

Physical Scale Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"sCAL" | 0x7343414c | Tree |  |  |  |

Physical Scale Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"UnitSpecifier" | 0x7343414c | Leaf | UINT8 |  | 1 | FALSE
"PixelWidth" | 0x7343414c | Leaf | STRING |  | Variable | FALSE
"PixelHeigt" | 0x7343414c | Leaf | STRING |  | Variable | FALSE

GIF Application Extension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gIFx" | 0x67494678 | Tree |  |  |  |

GIF Application Extension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"ApplicationIdentifier" | 0x67494678 | Leaf | STRING |  | Variable | FALSE
"AuthenticationCode" | 0x67494678 | Leaf | UINT8 |  | 1 | FALSE
"ApplicationData" | 0x67494678 | Leaf | RAW_DATA |  | Variable | FALSE

GIF Graphic Control Extension Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"gIFg" | 0x67494674 | Tree |  |  |  |

GIF Graphic Control Extension Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"DisposalMethod" | 0x67494674 | Leaf | UINT8 |  | 1 | FALSE
"UserInputFlag" | 0x67494674 | Leaf | UINT8 |  | 1 | FALSE
"DelayTime" | 0x67494674 | Leaf | UINT16 |  | 1 | FALSE

Image Offset Chunk Metadata PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"oFFs" | 0x6f464673 | Tree |  |  |  |

Image Offset Chunk Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
"XPosition" | 0x6f464673 | Leaf | UINT32 |  | 1 | FALSE
"YPosition" | 0x6f464673 | Leaf | UINT32 |  | 1 | FALSE
"UnitSpecifier" | 0x6f464673 | Leaf | UINT8 |  | 1 | FALSE

The Rest Chunk Metadata

The rest chunk data are passed as raw data

PNG Level

Name | ID | Type | Value Type | Value | Value Length | Read Only
<Chunk Name> | <Chunk ID> | Leaf | RAW_DATA |  | Variable | FALSE

<Chunk Name> is a string representation of the chunk type value.

<Chunk ID> is a binary representation of the chunk type value.


%%ItemTitle%%

ImageGear for Java | Accusoft
GIF Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > GIF Non-Image Data Structure

Glossary Item Box

GIF file format is complex and has different non-image data that can be stored before and after an image data. The GIF metadata design allows you to read/write any GIF non-image data and prevents from misunderstanding with GIF extensions storing order.

The following metadata are always saved before an image data:

  • See GIF Logical Screen Descriptor metadata. level
  • See GIF Image Descriptor metadata. level
  • See GIF Global Color Table metadata. level
  • See GIF Local Color Table metadata. level

All other GIF Extensions Metadata are saved before an image data.

ImageGear represents simpler GIF metadata by single metadata items, and more complex metadata by subtrees. Thus, there are two main GIF metadata levels in ImageGear:

  • See GIF metadata level.
  • See GIF Extensions Metadata.

GIF Metadata Level

Name Id Type Value Type Value Value Length Read Only
GIF header level
GIF Logical Screen Descriptor level
GIF Image Descriptor level

optional Global and/or Local Color Tables and

optional GIF Extensions levels (extensions before image)

GIF Header Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GIFHeader" | 0x10 | Tree | 0 | NULL | 0 | TRUE

GIF header Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"Signature" | 0x101 | Leaf | STRING | "GIF" | 3 | TRUE
"Version" | 0x102 | Leaf | STRING |  | 3 | TRUE

GIF Logical Screen Descriptor Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LogicalScreenDescriptor" | 0x20 | Tree |  |  |  |

GIF Logical Screen Descriptor Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LogicalScreenWidth" | 0x201 | Leaf | UINT16 |  | 1 | FALSE
"LogicalScreenHeight" | 0x202 | Leaf | UINT16 |  | 1 | FALSE
"Fields" | 0x205 | Tree |  |  |  |
"GlobalColorTableFlag" | 0x206 | Leaf | BOOL |  | 1 | FALSE
"ColorResolution" | 0x207 | Leaf | UINT8 |  | 1 | FALSE
"SortFlag" | 0x208 | Leaf | BOOL |  | 1 | FALSE
"GlobalColorTableSize" | 0x209 | Leaf | UINT8 |  | 1 | FALSE
"Fields" | 0x205 | Tree |  |  |  |
"BackgroundColorIndex" | 0x203 | Leaf | UINT8 |  |  | FALSE
"PixelAspectRatio" | 0x204 | Leaf | UINT8 |  |  | FALSE

GIF Global Color Table Metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GlobalColorTable" | 0x30 | Leaf | RAW_DATA |  | Variable | TRUE

GIF Image Descriptor Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ImageDescriptor" | 0x2C | Tree |  |  |  |

GIF Image Descriptor Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ImageLeftPosition" | 0x2C1 | Leaf | UINT16 |  | 1 | FALSE
"ImageTopPosition" | 0x2C2 | Leaf | UINT16 |  | 1 | FALSE
"ImageWidth" | 0x2C3 | Leaf |  |  | 1 | FALSE
"ImageHeight" | 0x2C4 | Leaf |  |  | 1 | FALSE
"Fields" | 0x2C5 | Tree |  |  |  |

GIF Image Descriptor Fields Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LocalColorTableFlag" | 0x2C6 | Leaf | BOOL |  | 1 | FALSE
"InterlaceFlag" | 0x2C7 | Leaf | BOOL |  | 1 | FALSE
"SortFlag" | 0x2C8 | Leaf | BOOL |  | 1 | FALSE
"LocalColorTableSize" | 0x2C9 | Leaf | UINT8 |  | 1 | FALSE

GIF Local Color Table metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"LocalColorTable" | 0x40 | Leaf | RAW_DATA |  | Variable | TRUE

GIF Extensions Metadata GIF Graphic Control Extension Metadata

GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"GraphicControlExtension" | 0xF9 | Tree |  |  |  |

GIF Graphic Control Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"Fields" | 0xF91 | Tree |  |  |  |
"DisposalMethod" | 0xF92 | Leaf | UINT8 |  | 1 | FALSE
"UserInputFlag" | 0xF93 | Leaf | BOOL |  | 1 | FALSE
"TransparentColorFlag" | 0xF94 | Leaf | BOOL |  | 1 | FALSE
"Fields" | 0xF91 | Tree |  |  |  |
"DelayTime" | 0xF95 | Leaf | UINT16 |  | 1 | FALSE
"TransparentColorIndex" | 0xF96 | Leaf | UINT8 |  | 1 | FALSE

GIF Comment Extension Metadata

Name | Id | Type | Value Type | Value | Value Length | Read Only
"CommentExtension" | 0xFE | Leaf | STRING |  | Variable | TRUE

GIF Application Extension MetadataGIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ApplicationExtension" | 0xFF | Tree |  |  |  |

GIF Application Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"ApplicationIdentifier" | 0xFF1 | Leaf | STRING |  | 8 | FALSE
"Appl.AuthenticationCode" | 0xFF2 | Leaf | UINT8 |  | 4 | FALSE
"ApplicationData" | 0xFF3 | Leaf | RAW_DATA |  | Variable | FALSE

GIF Plain Text Extension Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"PlainTextExtension" | 0x01 | Tree | 0 | NULL | 0 | TRUE

GIF Plain Text Extension Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"TextGridLeftPosition" | 0x11 | Leaf | UINT16 |  | 1 | FALSE
"TextGridTopPosition" | 0x12 | Leaf | UINT16 |  | 1 | FALSE
"TextGridWidth" | 0x13 | Leaf | UINT16 |  | 1 | FALSE
"TextGridHeight" | 0x14 | Leaf | UINT16 |  | 1 | FALSE
"CharacterCellWidth" | 0x15 | Leaf | UINT8 |  | 1 | FALSE
"CharacterCellHeight" | 0x16 | Leaf | UINT8 |  | 1 | FALSE
"TextForegroundColorIndex" | 0x17 | Leaf | UINT8 |  | 1 | FALSE
"TextBackgroundColorIndex" | 0x18 | Leaf | UINT8 |  | 1 | FALSE
"PlainTextData" | 0x19 | Leaf | STRING |  | Variable | FALSE

GIF Extensions After Image Metadata GIF Metadata Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
"AfterImageExtensions" | 0xFFF | Tree |  |  |  |

GIF Extensions After Image Level

Name Id Type Value Type Value Value Length Read Only
One or more GIF extension levels


%%ItemTitle%%

ImageGear for Java | Accusoft
DICOM Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > DICOM Non-Image Data Structure

Glossary Item Box

DICOM files contain one header and zero, one, or several image pages. Image header applies to all pages in the image. ImageGear for Java loads the same metadata tree for each page in the image, and attaches this tree to the corresponding page. ImageGear for .NET does not put any tags to document level metadata for DICOM images.

DICOM Metadata Root Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
Preamble | Preamble | Leaf | Byte[] |  | 128 | No
MetaInfoHeader | MetaInfoHeader | Tree |  |  |  |
DataSet | DataSet | Tree |  |  |  |

MetaInfoHeader Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |

DataSet may contain subtrees, corresponding to DICOM tags that have "Sequence" (SQ) type. Sequences can non contain normal tags (leafs). Instead, each Sequence contains one or more "Items". Items can contain normal tags including Sequences. All items within one Sequence must have the same set of tags, but tag values can be different.

DataSet Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |
... |  |  |  |  |  |
<SQ tag name> | <SQ tag id> | Tree |  |  |  |
... |  |  |  |  |  |

Sequence Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
Item | Item | Tree |  |  |  |
... |  |  |  |  |  |

Item Level

Name | Id | Type | Value Type | Value | Value Length | Read Only
<tag name> | <tag id> | Leaf |  |  |  |
... |  |  |  |  |  |
<SQ tag name> | <SQ tag id> | Tree |  |  |  |
... |  |  |  |  |  |

When ImageGear saves images, it overwrites the following tags:

Id | Location | Type
FileMetaInformationVersion | MetaInfoHeader | Leaf
TransferSyntaxUID | MetaInfoHeader | Leaf
SamplesPerPixel | DataSet | Leaf
PhotometricInterpretation | DataSet | Leaf
Rows | DataSet | Leaf
Columns | DataSet | Leaf
BitsAllocated | DataSet | Leaf
BitsStored | DataSet | Leaf
HighBit | DataSet | Leaf
PixelRepresentation | DataSet | Leaf
PlanarConfiguration | DataSet | Leaf
Red Palette Color Look Up Table Descriptor | DataSet | Leaf
Green Palette Color Look Up Table Descriptor | DataSet | Leaf
Blue Palette Color Look Up Table Descriptor | DataSet | Leaf
Red Palette Color Look Up Table Data | DataSet | Leaf
Green Palette Color Look Up Table Data | DataSet | Leaf
Blue Palette Color Look Up Table Data | DataSet | Leaf
PixelData | DataSet | Leaf


%%ItemTitle%%

ImageGear for Java | Accusoft
CIFF Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > CIFF Non-Image Data Structure

Glossary Item Box

CIFF metadata uses multiple nested IFDs, structured as a tree.

Brief information on CIFF metadata levels is provided in the set of tables below.

CIFF Level

Name | Id | Type
ImageProps level | ImGearCIFFTagIDs.IMAGE_PROPS | Tree
CIFF root tags | <Tag ID> | Leaf

ImageProps Level

Name | Id | Type
ImageInfo level | ImGearCIFFTagIDs.IMAGE_INFO | Tree
ImageDescription level | ImGearCIFFTagIDs.IMAGE_DESCRIPTION | Tree
CameraObject level | ImGearCIFFTagIDs.CAMERA_OBJECT | Tree
ShootingRecord level | ImGearCIFFTagIDs.SHOOTING_RECORD | Tree
MeasuredInfo level | ImGearCIFFTagIDs.MEASURED_INFO | Tree
ExifInformation level | ImGearCIFFTagIDs.EXIF_INFORMATION | Tree
ImageProps tags | <Tag ID> | Leaf

ImageInfo Level

Name | Id | Type
ImageInfo tags | <Tag ID> | Leaf

ImageDescription Level

Name | Id | Type
ImageDescription tags | <Tag ID> | Leaf

CameraObject Level

Name | Id | Type
CameraSpecification level | ImGearCIFFTagIDs.CAMERA_SPECIFICATION | Tree
CameraObject tags | <Tag ID> | Leaf

ShootingRecord Level

Name | Id | Type
ShootingRecord tags | <Tag ID> | Leaf

MeasuredInfo Level

Name | Id | Type
MeasuredInfo tags | <Tag ID> | Leaf

ExifInformation Level

Name | Id | Type
FocalLength level | ImGearCIFFTagIDs.FOCAL_LENGTH | Tree
CanonShotInfo level | ImGearCIFFTagIDs.CANON_SHOT_INFO | Tree
CanonCameraSettings level | ImGearCIFFTagIDs.CANON_CAMERA_SETTINGS | Tree
SensorInfo level | ImGearCIFFTagIDs.SENSOR_INFO | Tree
CanonCustomFunctions level | ImGearCIFFTagIDs.CANON_CUSTOM_FUNCTIONS | Tree
CanonPictureInfo level | ImGearCIFFTagIDs.CANON_PICTURE_INFO | Tree
ExifInformation tags | <Tag ID> | Leaf

CameraSpecification Level

Name | Id | Type
CameraSpecification tags | <Tag ID> | Leaf

FocalLength Level

Name | Id | Type
FocalLength tags | <Tag ID> | Leaf

CanonShotInfo Level

Name | Id | Type
CanonShotInfo tags | <Tag ID> | Leaf

CanonCameraSettings Level

Name | Id | Type
CanonCameraSettings tags | <Tag ID> | Leaf

SensorInfo Level

Name | Id | Type
SensorInfo tags | <Tag ID> | Leaf

CanonCustomFunctions Level

Name | Id | Type
CanonCustomFunctions tags | <Tag ID> | Leaf

CanonPictureInfo Level

Name | Id | Type
CanonPictureInfo tags | <Tag ID> | Leaf


%%ItemTitle%%

ImageGear for Java | Accusoft
XMP Non-Image Data Structure
Send Feedback |
ImageGear for Java User Guide > ImageGear Imaging Formats Reference > ImageGear Supported Non-Image Data > XMP Non-Image Data Structure

Glossary Item Box

XMP Root Level

Name | Id | Type | Level Type | Value Type
<Schema package URI 1> | ImGearXMPTagIDs.Description | Tree | XMP Schema | N/A
<Schema package URI 1> | ImGearXMPTagIDs.Description | Tree | XMP Schema | N/A
... |  |  |  |

XMP Schema Level

Name | Id | Type | Level Type | Value Type
About | ImGearXMPTagIDs.About | Leaf | N/A | String
package | ImGearXMPCommonTagIDs. package | Tree | XMP package | N/A
package URI | ImGearXMPCommonTagIDs.packageURI | Leaf | N/A | String
Properties | ImGearXMPCommonTagIDs.Properties | Tree | XMP Property Collection | N/A

XMP package Level

Name | Id | Type | Level Type | Value Type
Prefix | ImGearXMPTagIDs.Prefix | Leaf | N/A | String
URI | ImGearXMPTagIDs.URI | Leaf | N/A | String

XMP Property Collection Level

Name | Id | Type | Level Type | Value Type
<Property 1 name> | ImGearXMPTagIDs.Property | Tree | XMP Simple Property / XMP Array / XMP Structure | N/A
<Property 2 name> | ImGearXMPTagIDs.Property | Tree | XMP Simple Property, XMP Array/Structure property | N/A
... |  |  |  |

XMP Simple Property Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPropertyTagIDs.Value | Leaf | N/A | <Value type>
Qualifiers | ImGearXMPropertyTagIDs.Qualifiers | Tree | XMP Qualifiers collection | N/A

XMP Array Level

Name | Id | Type | Level Type | Value Type
Bag / Seq / Alt | ImGearXMPropertyTagIDs.Bag / ImGearXMPropertyTagIDs.Seq / ImGearXMPropertyTagIDs.Alt | Tree | XMP Array items level | N/A

XMP Array Items Level

Name | Id | Type | Level Type | Value Type
Item | ImGearXMPropertyTagIDs.Item | Tree | XMP Simple Property / XMP Language Alternative Property / XMP Structure | <N/A>
Item | ImGearXMPropertyTagIDs.Item | Tree | XMP Simple Property / XMP Language Alternative Property / XMP Structure | <N/A>
... |  |  |  |

XMP Language Alternative Property Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPropertyTagIDs.Value | Leaf | N/A | <Value type>
Lang | ImGearXMPropertyTagIDs.Lang | Leaf | N/A | String

XMP Structure Level

Name | Id | Type | Level Type | Value Type
Struct | ImGearXMPropertyTagIDs.Struct | Tree | XMP Structure items level | N/A

XMP Structure Items Level

Name | Id | Type | Level Type | Value Type
<Field 1 name 1> | ImGearXMPropertyTagIDs.Property | Tree | XMP Simple Property | <N/A>
<Field 2 name> | ImGearXMPropertyTagIDs. Property | Tree | XMP Simple Property | <N/A>
... |  |  |  |

XMP Qualifiers Level

Name | Id | Type | Level Type | Value Type
<Qualifier 1 name> | ImGearXMPropertyTagIDs. Qualifier | Tree | XMP Qualifier | <N/A>
<Qualifier 2 name> | ImGearXMPropertyTagIDs. Qualifier | Tree | XMP Qualifier | <N/A>
... |  |  |  |

XMP Qualifier Level

Name | Id | Type | Level Type | Value Type
Value | ImGearXMPCommonTagIDs. Value | Leaf | N/A | <Value type>


%%Phrase%%

ImageGear for Java Accusoft Pegasus
Glossary
Send Feedback

Glossary Item Box

1 | 2 | 4 | 8 | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

1

1-bit image
An image comprised of pixels that contain only a single bit of information. Each pixel is either on or off. Normally, "on" is white and "off" is black.

2

24-bit image
A 24-bit image contains pixels made from RGB triplets.

4

4-bit image
An image file format that allows 4-bits per pixel. This image can contain up to 16 (24) different colors or levels of gray.

8

8-bit gray level
This indicates 8-bit grayscale. 8-bit gray level is used to distinguish between 8-bit indexed color (8i) and 8 bit grayscale. An 8-bit gray level DIB image is one where each pixel in the bitmap is unchanged by its palette when displayed. Each palette entry is the same as its index.

8-bit image
An image where each pixel has 8-bits of information. An 8-bit pixel contains one of 256 possible values. There are two common types of 8-bit images: grayscale and indexed color.

In a grayscale image, each pixel takes one of 256 shades of gray and the shades are linearly distributed from 0 (black) to 256 (white). An 8-bit grayscale image does not require a palette but may have one.

An indexed color image is always a palette image. Each pixel is used as an index to the palette. These images can have up to 256 different colors. This includes hues as well as shades. Indexed 8-bit images are good for low color resolution images that do not need processing. They are 3 times smaller than full-color RGB images, but because the pixel values are not linear, many image-processing algorithms cannot work with them. They must be promoted to 24-bit for image processing.

8-bit indexed
This indicates 8-bit indexed color. 8i is used throughout this manual to distinguish between 8-bit grayscale (8-bit gray level) and 8-bit indexed color. An 8-bit indexed color DIB is one where each 8-bit pixel value in the bitmap is used as an index to the palette.

The palette dictates which RGB color the pixel displays. These images are compact ways of storing color images. However they are difficult to process because the bytes that make up the pixel can no longer be ordered with any certainty.

A

Absolute coordinates
Absolute coordinates refer to a common origin, for example, the upper left corner of a display screen. This is the opposite of relative coordinates.

ACCUAPI
Accusoft Application Program Interface.

Additive primary colors
Red, Green, Blue - the 3 colors used to create all other colors when direct, or transmitted light is used (as in a video monitor). They are called additive primaries, because when these three colors are superimposed they produce white.

Anti-aliasing
A method of filling in data that is missing due to under-sampling. In imaging, this usually involves the process of removing jagged edges by interpolating values in-between pixels of contrast. These methods are most often used to remove or reduce the stair-stepping artifact found in digital high contrast images.

AOI

Area Of Interest. An area of interest is a rectangle within an image defined as two points within the image. An AOI can be written as (x1,y1)-(x2,y2). All AOIs are parallel with the image's axes.

API

Application Programmer's Interface. The set of routines that make up a library or toolkit. Some times called a binding.

Aspect ratio

The proportion of an image's size given in terms of the horizontal length verses the vertical height. An aspect ratio of 4:3 indicates that the image is 4/3 times as wide as it is high.

B

Bezier curve

A curve created from endpoints and two or more control points that serve as positions for the shape of the curve. Originated by P. Bezier (~1962) for the use in car body descriptions.

Bit block transfer

A raster operation that moves a block of bits representing a portion of an image or scene from one location in the frame buffer to another. Usually written as "bit blt".

Bit plane

A hypothetical 2-D plane containing a single bit of memory for each pixel in a image. If each 8-bit pixel is thought of as a stack of 8 coins, and an image as many rows and columns of these stacked coins then the 3rd bit plane would be the plane consisting of the 3rd coin from each stack.

Bitmap

An image is a bitmap if it contains a value for each of its pixels. This is the opposite of vector images where a small set of values generate an object.

Bounding rectangle

The smallest rectangle that fits around a given object. In imaging, the rectangle is usually rotationally restricted to be parallel to both image axes.

C

C.I.E

Commission Internationale de l'Eclairage. (International Commission of Illumination). A standards organization which provides specifications for the description of device independent color.

Call-back function

A function that is passed to another function as a parameter. The function receiving the call-back function can call this function. This is used to change the behavior of a given routine without knowing beforehand what it is expected to do.

Cartesian coordinates

A 2-dimensional equally spaced grid iron that uniquely assigns every point in the plane, (one and only one), co-ordinate pair; (x, y). In imaging, each point is usually referred to as a pixel and the x and y values take on integer values. Most images use the top-left as the (0,0), or origin.

Chroma-key

An image blending function that replaces pixels of a specified hue range with pixels from a second image. This is often referred to the weatherman effect because most weather forecasters use a solid blue or green background to make it look as if they are standing in front of a huge weather map. It is important to remember that it is the hue that is used in the blending function and not the intensity or saturation.

Clipboard

The clipboard is a windows data structure used to exchanged data between applications. It is a common area where applications place data and others can access it. These operations are usually referred to as Cut (place data in) and Paste (take data out).

CMY & CMYK

Cyan, Magenta, Yellow, (K) black. Computer monitors are additive, but color printers are subtractive. Instead of combining light from monitor phosphors, printers coat paper with colored pigment that removes specific colors from the illumination light.

CMY is the subtractive color model that corresponds to the additive RGB model. Cyan, magenta, and yellow are the color complements of red, green, and blue. Due to the difficulties of manufacturing pigments that produce black when mixed together, a separate black ink is often used and is referred to as K (`B' is already used for blue).

color space

A mathematical coordinate system (space) for assigning numerical values to colors. There are many ways to define such spaces, each with its own benefits and problems.

Compression

An image processing method for saving valuable disk and memory space by reducing the amount of space required to save a digital image. The graphics data is rewritten allowing it to be represented by a smaller set of data. Do not confuse this with encoding.

Compression ratio

The ratio of a file's uncompressed size over its compressed size.

Concave

A 2-dimensional blob, for example, a region of interest (ROI), where at least one tangent is drawn that touches the blob at two different locations, and there is a point on the tangent between the two contacts that does not touch the blob.

In simpler words, if a rubber band could be snugly wrapped around a concave blob there would be places where the rubber band lifts off and does not touch the blob. Concave is the opposite of convex.

Convex

A 2-dimensional blob, for example, a region of interest (ROI), where every tangent that can be drawn touches the blob at a continuous stretch of the blob's surface with no gaps.

In simpler words, if a rubber band could be snugly wrapped around a convex blob there would be no places where the rubber band lifts off and is not touching the blob. Convex is the opposite of concave.

Convolution

An image processing operation that is used to spatially filter an image. A convolution is defined by a kernel that is a small matrix of fixed numbers. The size of the kernel, the numbers within it, and a single normalizer value define the operation that is applied to the image. The kernel is applied to the image by placing the kernel over the image to be convolved and sliding it around to center it over every pixel in the original image.

At each placement the numbers (pixel values) from the original image are multiplied by the kernel number that is currently aligned above it. The sum of all these products is tabulated and divided by the kernel's normalizer. This result is placed into the new image at the position of the kernel's center. The kernel is translated to the next pixel position and the process repeats until all image pixels have been processed.

As an example, a 3x3 kernel holding all `1's with a normalizer of 9 performs a neighborhood averaging operation. Each pixel in the new image is the average of its 9 neighbors from the original.

Coordinates

A pair of numbers that represent a specific location in a two-dimensional plane, for example, an image or on a map.

Crop

An image processing method for removing the region near the edge of the image, but keeping the central area.

D

DDB

Device Dependent Bitmap. A Window image specification that depends on the capabilities of a specific graphics display controller. Since a DDB is matched to the current graphics controller, it is fast and easy to display since large blocks of memory need only be copied to the controller.

Decompression

When an image or other digital data set is compressed and stored, it is not usable until it is decompressed into it original form.

Device coordinates

The co-ordinates of the coordinate system that describe the physical units that defines the computer screen.

Device dependent

Software written to work on a specific set of hardware platforms. Since these routines make use of physical device attributes, they may behave differently on other devices, although they will most often not work on other devices.

Device driver

A set of low-level software routines that work with and control a specific hardware device. The names and functions are often standardized across many similar devices. This allows higher level software to use the hardware as a generic device. This frees the higher-level software from dealing with the particulars of specific devices and allows devices to be interchanged.

Device independent

Software or data structures that are designed to work with or on a wide set of hardware platforms.

DIB

Device Independent Bitmap is a Windows-defined image format specification. It is called device-independent because of its straightforward, common-denominator, format. It has all the information that a basic digital image needs and is laid out in a simple specification. Its simplicity makes it an ideal format for holding images that need to be shared by several programs.

Dithering

The method of using neighborhoods of display pixels to represent one image intensity or color. This method allows low-intensity resolution display devices to simulate higher resolution images. For example, a binary laser printer can use block patterns to display grayscale images.

DLL

Dynamic Linked Library. A compiled and linked collection of computer functions that are not directly bound to an executable. These libraries are linked at run-time by Windows. Since Windows is in charge of managing (loading, linking, and removing) the DLLs, they are available to all executables currently running. Each executable links to a shared DLL saving memory by avoiding redundant functions from co-existing. DLLs allow a new level of modularity by providing a means to modify and update executables without re-linking. Just copy a new version of the DLL to the correct disk directory.

DPI

Dots Per Inch. The number of printer dots that can be printed in one inch. The printer's resolution is defined by the number of dots per inch: lower resolution = less dots per inch, higher resolution = more dots per inch.

E

Edge

In an image, an edge is a region of contrast or color change. Edges are useful in machine vision since optical edges often mark the boundary of physical objects.

Edge detection

A method that isolates and locates an optical edge in a digital image.

Edge map

An edge map is the output of an image-processing filter that transforms an image into an image where intensity represents a change in the contrast (optical edge) of the original image.

Encoding

The format for storing uncompressed data (binary, ASCII, etc.), how it is packed (e.g. 4-bit pixels may be packed at a rate of two pixels per byte), and the unique set of symbols used to represent the range of data items.

Equalize

An image-processing algorithm that redistributes the frequency of image pixel values allowing equal representation for any given continuous range of values. In an ideal world, an equalized image has the same number of pixels in the range from 10-20 as it does from 200-210. However, since digital images have quantized intensity values, the range totals are rarely identical but usually close.

F

File format

A specification for holding computer data in a disk file. The format dictates what information is present in the file and how it is organized.

Filter

An image-processing filter is a transform that removes a specified quantity from an image. For instance a spatial filter removes high, medium or low spatial frequencies from an image.

Frame

A single picture, usually taken from a collection of images for example, a movie or video stream.

Frame buffer

A computer peripheral that stores and sometimes manipulating digital images.

Frame processes

Image-processing algorithms that operate on a single image.

G

Gain & level

Gain and level are image-processing terms that correspond to the brightness and contrast control on a television. The gain is the "contrast", and the level is the "brightness." By changing the level, the entire range of pixel values are linearly shifted brighter or darker. Gain on the other hand linearly stretches or shrinks the intensity range, altering the contrast.

Gamma correction

A non-linear function that is used to correct the inherent non-linearities of cameras and monitors. The intensity of the luminescent phosphor on the raster display is non-linear. Gamma correction is an adjustment to the pixel intensity values that make up for this inherent non-linearity.

Geometric transform

A class of image processing transforms that alter the location of pixels. This class includes rotates and warps.

Graphics library

A collection of software routines that work on digital images. These collections usually contain routines for drawing various graphical objects, for example, lines, circles, and rectangles.

Gray level

A shade of gray assigned to a pixel. The shades are usually positive integer values taken from the grayscale. In an 8-bit image a gray level can have a value from 0 to 255.

Grayscale

A range of gray levels. Zero is usually black and higher numbers indicate brighter pixels.

Group III Fax

A CCITT standard for transmission of facsimile data. It compresses black and white images using a combination of differential, run length and Huffman coding.

GUI

Graphical User Interface. A computer-user interface that uses graphical objects and a mouse for user interaction, for example Microsoft Windows.

H

Halftone

The reproduction of a continuous-tone image on a device that does not directly support continuous output. This is done by displaying or printing a pattern of small dots that simulate the desired output color or intensity. These methods are used extensively in magazines and newspapers.

Handle

A handle references a data object. A handle is a type of pointer but it usually contains, internally, more information about the referenced object.

Histogram

A tabulation of pixel value populations displayed as a bar chart where the x-axis represents all the possible pixel values and the y-axis is the total image count of each given pixel value. A histogram counts how many pixels in the image have a given intensity value or range of values.

Each histogram intensity value or range of values is called a bin. Each bin contains a positive number that represents the number of pixels in the image that fall within the bin's range. A typical 8-bit grayscale histogram contains 256 bins. Each bin has a range of a single intensity value. Bin 0 contains the number of pixels in the image that have a grayscale value of 0 or black; bin 255 contains the number of white (255) pixels. When the collection of bins are sorted (0-255) and charted, the graph displays the intensity distributions of all the images pixels.

HLS

Hue Saturation, and Lightness. A method that describes any color as a triplet of real values. The hue represents the color or wavelength of the color. It is sometimes called tone and is commonly known as color. The hue is taken from the standard color wheel and is calibrated in degrees.

Saturation is the depth of the color. It states how gray the color is. It is a real valued parameter from 0.0 to 1.0 with 0.0 indicating full gray and 1.0 representing pure hue.

Lightness determines how black or white a color is. It ranges from 0.0 to 1.0 but with 0.0 representing black and 1.0 white. A lightness of 0.5 is a pure hue.

HSV

Hue, Saturation, and Value.

Huffman coding

A method of encoding symbols that varies the length of the code in proportion to its information content. Groups of pixels that appear frequently in a image are coded with fewer bits than those of lower occurrence.

I

Image format

There are many digital image formats. Some of these are: TIFF, DIB, GIF, and JPEG. The image format specification dictates which image information is present and how it is organized in memory. Many formats support various sub-formats or `flavors'.

Image processing

The general term "image processing" refers to a computer discipline wherein digital images are the main data object. This type of processing can be broken down into several sub-categories: compression, image enhancement, image filtering, image distortion, image display and coloring, and image editing.

Indexed color image

An image where each pixel value is used as an index to a palette for interpretation before the pixel is displayed. These images contain a palette that is initialized specifically for a given image. The pixel values are usually 8-bit and the palette 24-bit (8-red, 8-green, and 8-blue).

Invert intensity

An image processing operation where each pixel is subtracted from the maximum pixel value allowed. This produces a photographic negative of the original. For an 8-bit image the inverse function is:

invert(pix) = 255-pix;

For an 8-bit RGB image the function is:

invert(Rpix) = 255-Rpix;

invert(Gpix) = 255-Gpix;

invert(Bpix) = 255-Bpix;

J

Jaggies

A term used to describe the visual appearance of lines and shapes in raster pictures that results from a grid of insufficient spatial resolution.

JPEG JFIF

Joint Photographic Experts Group. A collaborative specification of the CCITT and the ISO for image compression. The standard JPEG compression algorithm, which is used by ImageGear, is a lossy compression scheme - it loses data.

K

Kernel

A small matrix of pixels, usually no bigger that 9x9, that is used as an operator during image convolution. The kernel is set prior to the convolution in a fashion that emphasizes a particular feature of the image. Kernels are often used as spatial filters, each one tuned to a specific spatial frequency that the convolution is intended to highlight.

L

Lempel Ziff Welch

A dictionary-based image compression method with lossless performance that results in fair compression ratios. Most files are compressed at 2:1.

Library

A collection of software functions that can be called upon by a higher level program. Most libraries are collections of similar routines, for example, those used for graphical or image processing.

Look-Up-Table

A look-up-table or LUT is a continuous block of computer memory that computes the values of a function for one variable. The LUT is set up for the function's variable to be used as an address or offset into the memory block. The value that resides at this memory location becomes the function's output. Because the LUT values need only be initialized once, LUTs are very useful for image processing due to their inherent high speed.

LUT[pixel_value] = f(pixel_value)

LUTs come in various widths, usually in units of bits. An nxm bit LUT has 2n addresses or 256 stored values. Each value is 2m bits wide.

If the second dimension is left off it can be assumed to be equal to the first. In grayscale image processing, LUTs are commonly 8x8, and the bit widths are usually assumed.

A linear LUT, sometimes called a NOP LUT or pass through, is a LUT that is initialized to output the same values as the input. NOP_LUT[pixel_value] = pixel_value.

Lossless

A method of image compression where there is no loss in quality when the image is uncompressed. The uncompressed image is mathematically identical to its original. Lossless compression is usually lower in compression ratio than lossy compression.

Lossy

A method of image compression where some image quality is sacrificed in exchange for higher compression ratios. The amount of quality degradation depends on the compression algorithm used and by a user-selected quality variable.

LUT

Look-Up-Table.

LUT transform

A LUT transform is an image processing method that takes an image and passes each pixel, one at a time, through a pre-set LUT. Each new pixel is a function of one and only one pixel from the original image and is arranged in the same location.

Any image-processing algorithm that transforms a single pixel into another single pixel, both from the same location, can be performed quickly using a LUT.

Square_root_LUT[pixel_value] = sqrt(pixel_value)

M

Machine vision

A sub-discipline of artificial intelligence that uses video cameras or scanners to obtain information about a given environment. Machine vision processes extract information from digital images about objects in the image. This is the opposite of computer graphics that takes various data describing objects in and produces an output image. Machine vision takes an image in and outputs some level of description about the objects in it, (i.e. color, size, brightness).

Median filter

An image spatial filtering operation based on an input pixel and its 8 neighbors. The resulting value is the median (5th from the sorted values). A median filter is often used to reduce spike or speckling noise from a grayscale image. It has the advantage over convolution smoothing - it better preserves edges.

Morphing

An imaging process where one image is gradually transformed into a second image, where both images previously existed. The result is a sequence of in-between images when played sequentially, as in a film loop show, give the appearance of the starting image being transformed to the second image.

Morphing is made up of a collection of image processing algorithms. The two major groups are: warps and blends. Do not confuse this with morphology.

Morphology

A neighborhood image-processing algorithm similar to image convolution except that Boolean logic is applied instead of arithmetic. There are two types of morphology, binary and grayscale. Both have similar operation but are carried out differently because of the data width. The four major operations are:

Erode - a filter that makes bright objects smaller. Dilation - a filter that makes bright objects larger. Opening - erosion followed by dilation. Closing - dilation followed by rosion. Do not confuse with morphing.

MPEG

Motion Pictures Experts Group. An ISO specification for the compression of digital-broadcast quality full-motion video and sound.

N

Neighborhood process

A class of image-processing routines that works on neighborhoods of pixels. Each pixel in the new image is computed as a function of the neighborhood of the pixel from the original pixel. The neighborhood ID is defined by a kernel that is set once for each image to be processed.

O

Overlay

An image or sub-image that can be placed over a given image. The pixels from the original image are not altered but the overlay can be viewed as if they had been. Usually used to place temporary text and annotation marks, for example, arrows on a image.

P

Packed bits

A binary image is usually stored in computer memory (8 pixels per byte). In this case each byte is referred to as being filled with packed bits. This saves space but makes reading and writing any individual pixel harder since most computers cannot directly access memory in chunks smaller than a byte.

Palette

A digital image palette is a collection of 3 look-up-tables or "LUTs" that are used to define a given pixel's display color. One LUT is for red, one for green and one for blue. The number of entries in the LUTs depend on the width (in bits) of the image's pixels. A palette image requires its palette in order to be displayed in a fashion that makes sense to the viewer. This is often the case for color 8-bit images. Without a palette describing what color each pixel needs for display, this type of image would most likely be displayed as randomly selected noise. A grayscale palette is one where each of the 3 LUTs are linear. The output is whatever is input to them. Since each color component (R, G, B) is an equal value, any pixels input to them are displayed in a varying shade of gray.

Pattern recognition

A sub-discipline of machine vision where images are searched for specific patterns. Optical character recognition or "OCR" is one type of pattern recognition, where images are searched for the letters of the alphabet.

Pixel

An abbreviated version of the term PIcture (X) ELement. This is the most fundamental element of a digital image. A digital image is made up of rows and columns of points of light. Each indivisible point of light is a pixel. Each pixel in an image is addressed by its column (x) and its row (y) usually written as the coordinate pair (x, y). An 8-bit pixel can take on one of 256 values. A 24-bit pixel has 3, 8-bit components for each of the primary colors, red, green, and blue.

Point process

A class of image processing transforms where every pixel is taken, one at a time from an image, and mathematically transformed into a new value with no input from any other pixel in the image. A point process is a degenerative neighborhood process where the kernel is a matrix of pixels that is 1x1 or in other words a single pixel.

Polar coordinates

An alternative to the usual Cartesian method of addressing image pixels. Polar coordinates use the coordinate pair, angle and radius from an origin instead of column and row.

Posterize

A special effect that decreases the number of colors or grayscales in an image. The default image pixel contains 256 levels of gray or 256 levels of red, green, and blue. Using this effect reduces these numbers.

Pseudocolor

A method of assigning color to ranges of a grayscale image's pixel values. Most often used to highlight subtle contrast gradients or for visually quantifying pixel values. The applied color usually has no correspondence to the original scene. The colors are used only as a guide or highlight.

R

Raster

A term that describes a single row of a digital image. A raster image is made up of rows of pixels. This is opposed to vector images, where an image is made up of a list of polygon nodes. A raster is sometimes called a scan-line.

Relative coordinates

Relative coordinates refer to position, as identified as the distance from a local origin.

Render

The process of displaying an image. The final and actual displayed image is said to be rendered.

Resolution

There are two types of resolution in digital images; spatial and intensity. Spatial resolution is the number of pixels per unit of length along the x and y axis. Intensity resolution is the number of quantized levels that a pixel can have.

RGB

Red, Green, Blue. A triplet of numeric values that describe a color.

RGBQUAD

Red, Green, Blue, Quad. A set of four numbers used to describe a color. The forth number is always set to zero. This creates an efficient color LUT or palette. It is more efficient because most computers find multiplying by 4 easier then by 3, as is the case in an RGB triplet.

ROI

Region Of Interest. A region of interest or ROI is a specification and date structure that allows for the definition of arbitrarily shaped regions within a given image, often called sub-images. A ROI can be thought of as a place holder which remembers a location within an image. ROIs are of several types, each defined in a manor that makes sense for its type.

ROIs are either a rectangle (also called an AOI), square, circle, or a segment list. A rectangle is defined by any two points in the image. From these two points one and only one rectangle can be drawn. A square is defined by a single point and a single length. A circle is defined by its center and radius. A segment list is an arbitrary list of triplets (x, y, xlen); a single point and a length to the right.

Every point in an image is either inside or outside of a given ROI.

Most image processing functions in this package work only within a given ROI. The ROI can encompass the entire image.

S

Screen coordinates

Screen coordinates are those of the actual graphics display controller. The origin is almost always at the upper left-hand corner of the display.

Segment

A contiguous section of a raster line. It is defined in physical coordinates by the triplet of its left most point and length (x, y, length).

Skew

A skew is image distortion that often occurs when a scanner is sampling an image and the image slides to either side before the scan is complete. This has the effect of transforming squares into rhombuses.

Special effects

Any image processing transform that is applied mostly for its artistic value. Special effects include, wipes, transitions, barn doors, etc.

Stretch intensity

An image processing method that takes a given image and assures that the intensity distribution fills the entire range of possible values. An 8-bit image that is stretched always has at least one pixel with a value of zero and one of 255. The term comes from the before and after histogram of the given image. A stretch operation linearly stretches a histogram so that is ranges from the minimum pixel value to the maximum pixel value.

T

Thumbnail

A small copy of an image. Thumbnails are used to display many images on the screen at once.

Transform

An algorithm that takes an image, alters it, and outputs a new image. Sometimes written as `xform'.

Triplet

Three numbers used together to represent a single quantity or location, for example, RGB or (x, y, z).

V

Video stream

A sequence of still images that are transmitted and displayed in synchronous order that give the appearance of live motion.

W

Warp

A geometric image processing routine that distorts an image by spatially compressing and stretching regions.

World coordinates

The real valued coordinates that make sense for the object, treating it as if it really exists. The world coordinates of a house on a map would be in miles or longitude and latitude. This is the opposite of screen, device or model coordinates.

X

x, y

A mathematical method for referring to a pixel from a digital image. Since most digital images are maintained as a Cartesian matrix of pixels, each pixel has a unique address that can be described as an x or horizontal displacement from the origin and a y or vertical displacement from the origin.

Xform

Shorthand for transform.

Y

YIQ

(Y) luminance, (I), (Q). YIQ is the color model used for U.S. commercial television. It was designed to be backwards compatible with the old black and white television sets. "Y" or luminance is a weighted average of the red, green, and blue that gives more weight to red and green than to blue. The I and Q contain the color components. Together they are called chromoticity.

Z

Z
A mathematical method that refers to a pixel's intensity from a digital image. An image can be written as: I(x,y)=z


%%ItemTitle%%

ImageGear for Java | Accusoft
ImageGear for Java API Reference
Send Feedback |

Glossary Item Box

This API Reference Guide provides information about all ImageGear for Java public API. For information about how this API Reference Guide is organized, please see In This Guide.


%%phrase%%

ImageGear for Java Project

Glossary Item Box

Packages

Package | Description
com.accusoft.imagegear.art | The ImageGear ART package allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, then with ImageGear ART package enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper.
com.accusoft.imagegear.callbackinterfaces | Interfaces used to notify clients of certain events.
com.accusoft.imagegear.core | This package is the basis of the ImageGear for Java toolkit. This package contains classes to operate with graphics primitives, license the product and, most importantly, primary ImageGear entities like page and document.
com.accusoft.imagegear.core.shapes | This package provides the various shape and point types available.
com.accusoft.imagegear.display | This package provides the ImageGear for Java API for annotation and presentation state support.
com.accusoft.imagegear.formats | This package provides the ImageGear for Java API for working with formats filters, thumbnails and formats metadata.
com.accusoft.imagegear.formats.dicom | This package provides features that are used with medical and DICOM images.
com.accusoft.imagegear.formats.exif | This package provides the API for operating with EXIF non-image data.
com.accusoft.imagegear.formats.iptc | This package contains classes, structures, and enumerations that provide simplified access to IPTC metadata.
com.accusoft.imagegear.formats.jpg | This package provides enumerations values for JPEG format filter control parameters.
com.accusoft.imagegear.formats.tif | This package provides public API for TIFF format metadata operating and for TIFF filter control parameters.
com.accusoft.imagegear.formats.xmp | This package provides the API for XMP format.
com.accusoft.imagegear.formats.xmp.adobepdf | This package provides the API for XMP AdobePDF format.
com.accusoft.imagegear.formats.xmp.basic | This package provides the API for XMP Basic format.
com.accusoft.imagegear.formats.xmp.basicjobticket | This package provides the API for XMP BasicJobTicket format.
com.accusoft.imagegear.formats.xmp.dublincore | This package provides the API for XMP DublinCore format.
com.accusoft.imagegear.formats.xmp.dynamicmedia | This package provides the API for XMP DynamicMedia format.
com.accusoft.imagegear.formats.xmp.exif | This package provides the API for XMP EXIF format.
com.accusoft.imagegear.formats.xmp.exifaux | This package provides the API for XMP EXIFAux format.
com.accusoft.imagegear.formats.xmp.iptc | This package provides the API for XMP IPTC4XMPCore format.
com.accusoft.imagegear.formats.xmp.mediamanagement | This package provides the API for XMP MediaManagement format.
com.accusoft.imagegear.formats.xmp.microsoftphoto | This package provides the API for XMP MicrosoftPhoto format.
com.accusoft.imagegear.formats.xmp.pagedtext | This package provides the API for XMP PagedText format.
com.accusoft.imagegear.formats.xmp.photoshop | This package provides the API for XMP Photoshop format.
com.accusoft.imagegear.formats.xmp.rightsmanagement | This package provides the API for XMP RightsManagement format.
com.accusoft.imagegear.formats.xmp.tiff | This package provides the API for XMP TIFF format.
com.accusoft.imagegear.processing | This package represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize, and crop images and provides image transformation methods, such as, remove red eye, perspective, solarize, warp, wave, etc.
com.accusoft.imagegear.processing.layers | This package provides an API for creating and editing image layers. It also introduces a new type of ImGearLayeredPage class, which consists of two parts: raster composition image and array of layers.
com.accusoft.imagegear.utility | This is the package for infrastructure classes.
com.accusoft.imagegear.utility.events | This is the package for event handling.


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started

Glossary Item Box


$$INTRODUCTION$$ - %%projecttitle%%

Introduction

Glossary Item Box


%%ItemTitle%%

com.accusoft.imagegear.art Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

The ImageGear ART package allows you to add redlining and annotation capabilities to any application built with ImageGear. If you have an application that can read, display, and print images, then with ImageGear ART package enabled, you can add marking capabilities, such as lines, arrows, highlighting, and sticky notes to document images, and use them as though you were working on printed sheets of paper.

Classes

Class | Description
ImGearART | Provides general ART functionality and access to the global properties and methods.
ImGearARTArrow | Represents legacy ART Arrow mark.
ImGearARTAudio Represents ART Audio mark.

ImGearARTBorder Provides mark's border attributes.

ImGearARTButton Represents ART Button mark.

ImGearARTCallout | Provides text mark's callout attributes. Callout is the shape object that points to the object it tells about.
ImGearARTCurve | Represents ART Curve mark.
ImGearARTDroppedAttributeEventArgs Provides data for the DroppedAttribute event.

The DroppedAttribute event occurs only when you call the loadPage method and the unsupported annotation mark attribute is being dropped.

ImGearARTDroppedMarkEventArgs Provides data for the DroppedMark event.

The DroppedMark event occurs only when you call the loadPage method and the unsupported annotation mark is being dropped.

ImGearARTEllipse | Represents ART Ellipse mark.
ImGearARTEncryption | Represents ART Encryption mark.
ImGearARTFilledEllipse Represents legacy ART Filled Ellipse mark.

ImGearARTFilledPolygon Represents legacy ART Filled Polygon mark.

ImGearARTFilledRectangle Represents legacy ART Filled Rectangle mark.

ImGearARTFreeLine Represents legacy ART Freehand line mark.

ImGearARTGroup Represents a collection of annotation marks united into a single group.

This class provides methods and properties generic for the annotation group.

ImGearARTGroupArray Represents an array of annotation groups.

ImGearARTGroupEnumerator Provides marks iteration capabilities over the annotation group.

Group enumerator is used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.

ImGearARTHighlighter Represents legacy ART Highlighter mark.

ImGearARTHollowEllipse | Represents legacy ART Hollow Ellipse mark.
ImGearARTHollowPolygon Represents legacy ART Hollow Polygon mark.

ImGearARTHollowRectangle Represents legacy ART Hollow Rectangle mark.

ImGearARTHotSpot Represents ART Hot Spot mark.

ImGearARTImage Represents ART Image mark.

ImGearARTImageEmb Represents legacy ART Embedded Image mark.

ImGearARTImageRef Represents legacy ART Image Reference mark.

ImGearARTLine | Represents ART Line mark.
ImGearARTLoadEvents | Contains fields that can be used to pass event delegates to loadPage method of the ImGearART.
ImGearARTMark | Provides the abstract base class for all annotation marks. Clients can register for notifications of property changes through this class's IImGearNotifyPropertyChanged interface.
ImGearARTMarkStatistics | Represent specific statistics information about ART marks.
ImGearARTMeasurementUnit Represents a measurement unit, such as Meter, Inch etc.

Measurement unit is defined by its name, abbreviation, and aspect values. Several most commonly used measurement units are available as static properties.

ImGearARTNote Represents legacy ART Attach-A-Note mark.

ImGearARTPage Represents a collection of annotation groups.

This class provides methods and properties for accessing to annotation groups and individual marks on the page.

ImGearARTPage is completely independent from com.accusoft.imagegear.core.ImGearPage class and can be associated with one or more com.accusoft.imagegear.core.ImGearPage class objects.

ImGearARTPageEnumerator Provides marks iteration capabilities over the annotation page.

Page enumerator class is used for ImGearARTPage class to iterate through the collection of marks by using foreach statement.

ImGearARTPin Provides text mark's pin attirbutes.

ImGearARTPinUpText Represents legacy ART Pin-Up-Text mark.

ImGearARTPoint Represents ART Point mark.

ImGearARTPolygon Represents ART Polygon mark.

ImGearARTMark

ImGearARTPolyline Represents ART Polyline mark.

ImGearARTPolyRuler | Represents ART Polyline Ruler mark.
ImGearARTProtractor Represents ART Protractor mark.

ImGearARTRectangle Represents ART Rectangle mark.

ImGearARTRedaction Represents legacy ART Redaction mark.

ImGearARTRuler Represents ART Ruler mark.

ImGearARTSelection | Provides the abstract class that defines mark selection interface.
ImGearARTText Represents ART Text mark.

ImGearARTTextCallout | Represents legacy ART Callout Text mark.
ImGearARTTextFromFile Represents legacy ART Text From File mark.

ImGearARTTextStamp Represents legacy ART Text Stamp mark.

ImGearARTTypedText Represents legacy ART Typed Text mark.

ImGearMarkEventArgs | Provides data for the mark events.
ImGearMarkPointEventArgs | Provides data for the mark point events.

Interfaces

Interface | Description
IImGearARTCurve | Defines ART Curve mark interface.
IImGearARTEllipse | Defines ART Ellipse mark interface.
IImGearARTLine | Defines ART Line mark interface.
IImGearARTPoint | Defines ART Point mark interface.
IImGearARTPolygon | Defines ART Polygon mark interface.
IImGearARTPolyline | Defines ART Polyline mark interface.
IImGearARTPolyRuler | Defines ART Polyline Ruler mark interface.
IImGearARTProtractor | Defines ART Protractor mark interface.
IImGearARTRectangle | Defines ART Rectangle mark interface.
IImGearARTRuler | Defines ART Ruler mark interface.
IImGearARTText | Defines ART Text mark interface.

Enumerations

Enumeration | Description
ImGearARTAccess | Specifies annotations group access level.
ImGearARTBurnInOptions | Specifies options to burn in annotations.
ImGearARTButtonState | Specifies button mark's state options.
ImGearARTCalloutType | Specifies callout types.
ImGearARTCoordinatesType | Specifies mark's coordinate types.
ImGearARTFontStyles | Specifies text font style information. Normal text is represented by an empty EnumSet<ImGearARTFontStyles>
ImGearARTLineHeadType | Specifies line mark's head types.
ImGearARTMarkHitTest | Specifies hit test results.
ImGearARTMarkType | Specifies types of annotations.
ImGearARTPenStyle | Specifies pen styles.
ImGearARTPinAlignment | Specifies an alignment of the pin icon.
ImGearARTSaveType | Specifies annotations save formats.
ImGearARTTextType | Specifies a type of string in the text mark's "Text" property.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.art Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.art.ImGearART
com.accusoft.imagegear.art.ImGearARTGroup
com.accusoft.imagegear.art.ImGearARTGroupArray
com.accusoft.imagegear.art.ImGearARTGroupEnumerator
com.accusoft.imagegear.art.ImGearARTLoadEvents
com.accusoft.imagegear.art.ImGearARTMeasurementUnit
com.accusoft.imagegear.art.ImGearARTPageEnumerator
com.accusoft.imagegear.display.ImGearAnnotationPage
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedAttributeEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedMarkEventArgs
com.accusoft.imagegear.art.ImGearMarkEventArgs
com.accusoft.imagegear.art.ImGearMarkPointEventArgs

See Also

Reference

ImageGear for Java Project


Base class for many event types passed to client handlers.

Full documentation

Represents an event with no event data.

Full documentation


%%PageItemTitle%%

ImGearART Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearART Class

Glossary Item Box

Provides general ART functionality and access to the global properties and methods.

Object Model

ImGearART ClassImGearPage ClassImGearARTPage Class

Syntax

public class ImGearART
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearART

See Also

Reference

ImGearART Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearART Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearART Class

Glossary Item Box

The following tables list the members exposed by ImGearART.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | burnIn | Merges marks permanently into com.accusoft.imagegear.core.ImGearPage class.
static (Shared in Visual Basic) | isLegacyFontScalingEnabled | Gets a value indicating whether the legacy mode is Enabled. Boolean value. This ART control option sets the way ImageGear scales the text fonts for ART annotations. True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false. The default value is false.
static (Shared in Visual Basic) | isPpmDisabled | Gets a value indicating whether the PPM control option is disabled in font pointSize calculations. Boolean value. This ART control option allows to disable use of image resolution for adjusting text fonts. True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false. The default value is false.
static (Shared in Visual Basic) | loadPage | Overloaded. Loads ART marks from an XML stream.
static (Shared in Visual Basic) | savePage | Overloaded. Saves ART marks to a stream.
static (Shared in Visual Basic) | setDisablePPM | Sets a value indicating whether the PPM control option is disabled in font pointSize calculations. Boolean value. This ART control option allows to disable use of image resolution for adjusting text fonts. True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false. The default value is false.
static (Shared in Visual Basic) | setLegacyFontScalingEnabled | Sets a value indicating whether the legacy mode is Enabled. Boolean value. This ART control option sets the way ImageGear scales the text fonts for ART annotations. True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false. The default value is false.
Top

See Also

Reference

ImGearART Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearART Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearART Class

Glossary Item Box

For a list of all members of this type, see ImGearART members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | burnIn | Merges marks permanently into com.accusoft.imagegear.core.ImGearPage class.
static (Shared in Visual Basic) | isLegacyFontScalingEnabled | Gets a value indicating whether the legacy mode is Enabled. Boolean value. This ART control option sets the way ImageGear scales the text fonts for ART annotations. True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false. The default value is false.
static (Shared in Visual Basic) | isPpmDisabled | Gets a value indicating whether the PPM control option is disabled in font pointSize calculations. Boolean value. This ART control option allows to disable use of image resolution for adjusting text fonts. True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false. The default value is false.
static (Shared in Visual Basic) | loadPage | Overloaded. Loads ART marks from an XML stream.
static (Shared in Visual Basic) | savePage | Overloaded. Saves ART marks to a stream.
static (Shared in Visual Basic) | setDisablePPM | Sets a value indicating whether the PPM control option is disabled in font pointSize calculations. Boolean value. This ART control option allows to disable use of image resolution for adjusting text fonts. True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false. The default value is false.
static (Shared in Visual Basic) | setLegacyFontScalingEnabled | Sets a value indicating whether the legacy mode is Enabled. Boolean value. This ART control option sets the way ImageGear scales the text fonts for ART annotations. True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false. The default value is false.
Top

See Also

Reference

ImGearART Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

burnIn Method
com.accusoft.imagegear.art Package > ImGearART Class : burnIn Method
page
com.accusoft.imagegear.core.ImGearPage class to burn marks in.
artPage
ART page to get marks from.
burnOptions
burnIn options.
groupIndexes
List of group indexes to apply burn in to, null - all groups.

Glossary Item Box

Merges marks permanently into com.accusoft.imagegear.core.ImGearPage class.

Syntax

public static ImGearPage burnIn(
   ImGearPage page,
   ImGearARTPage artPage,
   java.util.EnumSet<ImGearARTBurnInOptions> burnOptions,
   int[] groupIndexes
)

Parameters

page
com.accusoft.imagegear.core.ImGearPage class to burn marks in.
artPage
ART page to get marks from.
burnOptions
burnIn options.
groupIndexes
List of group indexes to apply burn in to, null - all groups.

Return Value

com.accusoft.imagegear.core.ImGearPage class object.

The marks are converted from vector-format constructs into raster-format. The image may be temporarily promoted to a higher bit-depth for the purpose of the merge (see ImGearARTBurnInOptions enumeration).

com.accusoft.imagegear.core.ImGearPageT:com.accusoft.imagegear.art.ImGearARTBurnInOptions

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

isLegacyFontScalingEnabled Method
com.accusoft.imagegear.art Package > ImGearART Class : isLegacyFontScalingEnabled Method

Glossary Item Box

Gets a value indicating whether the legacy mode is Enabled.

Boolean value.

This ART control option sets the way ImageGear scales the text fonts for ART annotations.

True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false.

The default value is false.

Syntax

public static boolean isLegacyFontScalingEnabled()

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

isPpmDisabled Method
com.accusoft.imagegear.art Package > ImGearART Class : isPpmDisabled Method

Glossary Item Box

Gets a value indicating whether the PPM control option is disabled in font pointSize calculations.

Boolean value.

This ART control option allows to disable use of image resolution for adjusting text fonts.

True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false.

The default value is false.

Syntax

public static boolean isPpmDisabled()

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

loadPage Method
com.accusoft.imagegear.art Package > ImGearART Class : loadPage Method

Glossary Item Box

Loads ART marks from an XML stream.

Overload List

Overload | Description
loadPage(ImGearStream,int) | Loads ART marks from an XML stream.
loadPage(ImGearStream,int,ImGearARTLoadEvents) | Loads ART marks from a stream and allows the use of events that occur during loading.
loadPage(ImGearPage) | Loads ART marks from com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

loadPage(ImGearStream,int) Method
com.accusoft.imagegear.art Package > ImGearART Class > loadPage Method : loadPage(ImGearStream,int) Method
stream
ImGearFileStream from which to load marks. The loadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.

Glossary Item Box

Loads ART marks from an XML stream.

Syntax

public static ImGearARTPage loadPage(
   ImGearStream stream,
   int pageNumber
)

Parameters

stream
ImGearFileStream from which to load marks. The loadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.

Return Value

ImGearARTPage class.

See Also

Reference

ImGearART Class
ImGearART Members
Overload List


%%PageItemTitle%%

loadPage(ImGearStream,int,ImGearARTLoadEvents) Method
com.accusoft.imagegear.art Package > ImGearART Class > loadPage Method : loadPage(ImGearStream,int,ImGearARTLoadEvents) Method
stream
ImGearFileStream from which to load marks. The loadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.
events
An instance of the ImGearARTLoadEvents class.

Glossary Item Box

Loads ART marks from a stream and allows the use of events that occur during loading.

Syntax

public static ImGearARTPage loadPage(
   ImGearStream stream,
   int pageNumber,
   ImGearARTLoadEvents events
)

Parameters

stream
ImGearFileStream from which to load marks. The loadPage method works from the current stream position, so if you are indexing pages from the beginning of the multi-page annotations file, you need to reset the stream position to the beginning.
pageNumber
Zero-based page number. First page is 0.
events
An instance of the ImGearARTLoadEvents class.

Return Value

ImGearARTPage class. ImGearARTPage

See Also

Reference

ImGearART Class
ImGearART Members
Overload List


%%PageItemTitle%%

loadPage(ImGearPage) Method
com.accusoft.imagegear.art Package > ImGearART Class > loadPage Method : loadPage(ImGearPage) Method
page
Page to load marks from.

Glossary Item Box

Loads ART marks from com.accusoft.imagegear.core.ImGearPage class.

Syntax

public static ImGearARTPage loadPage(
   ImGearPage page
)

Parameters

page
Page to load marks from.

Return Value

ImGearARTPage class.

This method can be used to load ART marks from TIF or PDF page.

ImGearARTPage com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearART Class
ImGearART Members
Overload List


%%PageItemTitle%%

savePage Method
com.accusoft.imagegear.art Package > ImGearART Class : savePage Method

Glossary Item Box

Saves ART marks to a stream.

Overload List

Overload | Description
savePage(ImGearARTPage,ImGearStream,int,ImGearSavingModes,ImGearARTSaveType) | Saves ART marks to a stream.
savePage(ImGearARTPage,ImGearPage) | Saves ART marks into com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

savePage(ImGearARTPage,ImGearStream,int,ImGearSavingModes,ImGearARTSaveType) Method
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearART Class > savePage Method : savePage(ImGearARTPage,ImGearStream,int,ImGearSavingModes,ImGearARTSaveType) Method
artPage
ART page with marks to save.
stream
ImGearStream to which to save annotation marks. The savePage method works from the current stream position, so if you are intending to re-write the stream, you need to reset the stream position to the beginning.
pageNumber
Page number to save. First page is 1.
saveMode
Saving mode.
type
Saving type.

This method saves annotation marks to XML stream.

Saving a multipage ART XML file with com.accusoft.imagegear.formats.ImGearSavingModes.APPEND for the 4th parameter is a special case that requires seeking to the start of the stream before the savePage call. Otherwise an attempt to save several ART pages to one XML file could result in an improperly formatted file from which only the annotations for the 1st page will be loaded, being saved. See the Sample Code below.

ImGearARTPage ImGearARTSaveType

Glossary Item Box

Saves ART marks to a stream.

Syntax

public static void savePage(
   ImGearARTPage artPage,
   ImGearStream stream,
   int pageNumber,
   ImGearSavingModes saveMode,
   ImGearARTSaveType type
)

Parameters

artPage
ART page with marks to save.
stream
ImGearStream to which to save annotation marks. The savePage method works from the current stream position, so if you are intending to re-write the stream, you need to reset the stream position to the beginning.
pageNumber
Page number to save. First page is 1.
saveMode
Saving mode.
type
Saving type.

This method saves annotation marks to XML stream.

Saving a multipage ART XML file with com.accusoft.imagegear.formats.ImGearSavingModes.APPEND for the 4th parameter is a special case that requires seeking to the start of the stream before the savePage call. Otherwise an attempt to save several ART pages to one XML file could result in an improperly formatted file from which only the annotations for the 1st page will be loaded, being saved. See the Sample Code below.

ImGearARTPage ImGearARTSaveType

See Also

Reference

ImGearART Class
ImGearART Members
Overload List


%%PageItemTitle%%

savePage(ImGearARTPage,ImGearPage) Method
com.accusoft.imagegear.art Package > ImGearART Class > savePage Method : savePage(ImGearARTPage,ImGearPage) Method
artPage
ART page with marks to save.
page
com.accusoft.imagegear.core.ImGearPage class to save to.

Saves ART 2.0 & 3.0 marks into igPage. This method can be used to export ART 2.0 marks to TIF page and ART 3.0 marks to PDF page.

ImGearARTPage com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

Saves ART marks into com.accusoft.imagegear.core.ImGearPage class.

Syntax

public static void savePage(
   ImGearARTPage artPage,
   ImGearPage page
)

Parameters

artPage
ART page with marks to save.
page
com.accusoft.imagegear.core.ImGearPage class to save to.

Saves ART 2.0 & 3.0 marks into igPage. This method can be used to export ART 2.0 marks to TIF page and ART 3.0 marks to PDF page.

ImGearARTPage com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearART Class
ImGearART Members
Overload List


%%PageItemTitle%%

setDisablePPM Method
com.accusoft.imagegear.art Package > ImGearART Class : setDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM control option is disabled in font pointSize calculations.

Boolean value.

This ART control option allows to disable use of image resolution for adjusting text fonts.

True if the PPM control option is disabled in font pointSize calculations for all text marks displayed; otherwise, false.

The default value is false.

Syntax

public static void setDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

setLegacyFontScalingEnabled Method
com.accusoft.imagegear.art Package > ImGearART Class : setLegacyFontScalingEnabled Method
value

Glossary Item Box

Sets a value indicating whether the legacy mode is Enabled.

Boolean value.

This ART control option sets the way ImageGear scales the text fonts for ART annotations.

True if the legacy scale mode for compatibility with previous versions is enabled; otherwise, false.

The default value is false.

Syntax

public static void setLegacyFontScalingEnabled(
   boolean value
)

Parameters

value

See Also

Reference

ImGearART Class
ImGearART Members


%%PageItemTitle%%

ImGearARTArrow Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTArrow Class

Glossary Item Box

Represents legacy ART Arrow mark.

Object Model

ImGearARTArrow ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearPoint ClassImGearARTLineHeadType EnumerationImGearRectangle ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTArrow
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTArrow

See Also

Reference

ImGearARTArrow Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTArrow Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTArrow Class

Glossary Item Box

The following tables list the members exposed by ImGearARTArrow.

Public Constructors

 | Name | Description
public Constructor | ImGearARTArrow Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the arrow color. IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getEndPoint | Gets the end point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getHeadAngle | Gets the angle of the arrow head. Integer value. The default value is 0.
public Method | getHeadLength | Gets the length of the arrow head. Integer value.
public Method | getHeadType | Gets the type of the arrow head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | getHighlight | Gets a value indicating whether the arrow is highlighted. Boolean value.
public Method | getStartPoint | Gets the start point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType.ARROW enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the arrow line. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the arrow color. IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setEndPoint | Sets the end point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setHeadAngle | Sets the angle of the arrow head. Integer value. The default value is 0.
public Method | setHeadLength | Sets the length of the arrow head. Integer value.
public Method | setHeadType | Sets the type of the arrow head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | setHighlight | Sets a value indicating whether the arrow is highlighted. Boolean value.
public Method | setStartPoint | Sets the start point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the arrow line. Integer value.
Top

See Also

Reference

ImGearARTArrow Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTArrow Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTArrow Class

Glossary Item Box

For a list of all members of this type, see ImGearARTArrow members.

See Also

Reference

ImGearARTArrow Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTArrow Constructor
com.accusoft.imagegear.art Package > ImGearARTArrow Class : ImGearARTArrow Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTArrow class object.
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean) | Initializes a new instance of the ImGearARTArrow class object.
ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean,ImGearARTLineHeadType,int,int) | Initializes a new instance of the ImGearARTArrow class object.

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Arrow color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTArrow class object.

Syntax

public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Arrow color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean)
startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTArrow

Glossary Item Box

Initializes a new instance of the ImGearARTArrow class object.

Syntax

public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   int width,
   boolean isHighlighted
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTArrow

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List


%%PageItemTitle%%

ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean,ImGearARTLineHeadType,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTArrow Class > ImGearARTArrow Constructor : ImGearARTArrow Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,int,boolean,ImGearARTLineHeadType,int,int)
startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not.
headType
Type of the arrow head.
headAngle
Angle of the arrow head.
headLength
Length of the arrow head. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTLineHeadType

Glossary Item Box

Initializes a new instance of the ImGearARTArrow class object.

Syntax

public ImGearARTArrow(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   int width,
   boolean isHighlighted,
   ImGearARTLineHeadType headType,
   int headAngle,
   int headLength
)

Parameters

startPoint
Start point of the arrow.
endPoint
End point of the arrow.
color
Color of the arrow.
width
Width of the arrow.
isHighlighted
Specifies whether the arrow is highlighted or not.
headType
Type of the arrow head.
headAngle
Angle of the arrow head.
headLength
Length of the arrow head. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTLineHeadType

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTArrow Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTArrow Class

Glossary Item Box

For a list of all members of this type, see ImGearARTArrow members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the arrow color. IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getEndPoint | Gets the end point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getHeadAngle | Gets the angle of the arrow head. Integer value. The default value is 0.
public Method | getHeadLength | Gets the length of the arrow head. Integer value.
public Method | getHeadType | Gets the type of the arrow head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | getHighlight | Gets a value indicating whether the arrow is highlighted. Boolean value.
public Method | getStartPoint | Gets the start point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType.ARROW enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the arrow line. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the arrow color. IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setEndPoint | Sets the end point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setHeadAngle | Sets the angle of the arrow head. Integer value. The default value is 0.
public Method | setHeadLength | Sets the length of the arrow head. Integer value.
public Method | setHeadType | Sets the type of the arrow head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | setHighlight | Sets a value indicating whether the arrow is highlighted. Boolean value.
public Method | setStartPoint | Sets the start point of the arrow. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the arrow line. Integer value.
Top

See Also

Reference

ImGearARTArrow Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getColor Method

Glossary Item Box

Gets the arrow color.

IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getEndPoint Method

Glossary Item Box

Gets the end point of the arrow.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint getEndPoint()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getHeadAngle Method

Glossary Item Box

Gets the angle of the arrow head.

Integer value.

The default value is 0.

Syntax

public int getHeadAngle()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getHeadLength Method

Glossary Item Box

Gets the length of the arrow head.

Integer value.

Syntax

public int getHeadLength()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getHeadType Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getHeadType Method

Glossary Item Box

Gets the type of the arrow head.

ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType

Syntax

public ImGearARTLineHeadType getHeadType()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the arrow is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getStartPoint Method

Glossary Item Box

Gets the start point of the arrow.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint getStartPoint()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType.ARROW enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : getWidth Method

Glossary Item Box

Gets the width of the arrow line.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setColor Method
value

Glossary Item Box

Sets the arrow color.

IImGearRGBQuad value. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setEndPoint Method
value

Glossary Item Box

Sets the end point of the arrow.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setHeadAngle Method
value

Glossary Item Box

Sets the angle of the arrow head.

Integer value.

The default value is 0.

Syntax

public void setHeadAngle(
   int value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setHeadLength Method
value

Glossary Item Box

Sets the length of the arrow head.

Integer value.

Syntax

public void setHeadLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setHeadType Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setHeadType Method
value

Glossary Item Box

Sets the type of the arrow head.

ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType

Syntax

public void setHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the arrow is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setStartPoint Method
value

Glossary Item Box

Sets the start point of the arrow.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : setWidth Method
value

Glossary Item Box

Sets the width of the arrow line.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTArrow Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTArrow Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTArrow Class
ImGearARTArrow Members


%%PageItemTitle%%

ImGearARTAudio Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTAudio Class

Glossary Item Box

Represents ART Audio mark.

Object Model

ImGearARTAudio ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTAudio
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTAudio

See Also

Reference

ImGearARTAudio Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTAudio Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTAudio Class

Glossary Item Box

The following tables list the members exposed by ImGearARTAudio.

Public Constructors

 | Name | Description
public Constructor | ImGearARTAudio Constructor | Initializes a new instance of the ImGearARTAudio class object.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the sound file name. String value. The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType.AUDIO enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFileName | Sets the sound file name. String value. The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTAudio Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTAudio Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTAudio Class

Glossary Item Box

For a list of all members of this type, see ImGearARTAudio members.

See Also

Reference

ImGearARTAudio Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTAudio Constructor
com.accusoft.imagegear.art Package > ImGearARTAudio Class : ImGearARTAudio Constructor
rect
The mark rectangle.
fileName
The filename of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTAudio class object.

Syntax

public ImGearARTAudio(
   IImGearRectangle rect,
   java.lang.String fileName
)

Parameters

rect
The mark rectangle.
fileName
The filename of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTAudio Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTAudio Class

Glossary Item Box

For a list of all members of this type, see ImGearARTAudio members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the sound file name. String value. The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType.AUDIO enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFileName | Sets the sound file name. String value. The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTAudio Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getFileName Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getFileName Method

Glossary Item Box

Gets the sound file name.

String value.

The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.

Syntax

public java.lang.String getFileName()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType.AUDIO enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getX Method

Glossary Item Box

Gets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : getY Method

Glossary Item Box

Gets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setFileName Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setFileName Method
value

Glossary Item Box

Sets the sound file name.

String value.

The sound specified by this parameter must fit into available physical memory and be playable by an installed waveform-audio device driver.

Syntax

public void setFileName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTAudio Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTAudio Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTAudio Class
ImGearARTAudio Members


%%PageItemTitle%%

ImGearARTBorder Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTBorder Class

Glossary Item Box

Provides mark's border attributes.

Object Model

ImGearARTBorder ClassIImGearRGBQuad InterfaceImGearARTPenStyle Enumeration

Syntax

public class ImGearARTBorder
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTBorder

See Also

Reference

ImGearARTBorder Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTBorder Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTBorder Class

Glossary Item Box

The following tables list the members exposed by ImGearARTBorder.

Public Constructors

 | Name | Description
public Constructor | ImGearARTBorder Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getColor | Gets the border color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getStyle | Gets the border style. ImGearARTPenStyle enumeration value.
public Method | getWidth | Gets the width of the border line. Integer value.
public Method | setColor | Sets the border color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setStyle | Sets the border style. ImGearARTPenStyle enumeration value.
public Method | setWidth | Sets the width of the border line. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTBorder Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTBorder Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTBorder Class

Glossary Item Box

For a list of all members of this type, see ImGearARTBorder members.

See Also

Reference

ImGearARTBorder Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTBorder Constructor
com.accusoft.imagegear.art Package > ImGearARTBorder Class : ImGearARTBorder Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTBorder Constructor(IImGearRGBQuad,int) | Initializes a new instance of the ImGearARTBorder class object.
ImGearARTBorder Constructor(IImGearRGBQuad,int,ImGearARTPenStyle) | Initializes a new instance of the ImGearARTBorder class object.

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

ImGearARTBorder Constructor(IImGearRGBQuad,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTBorder Class > ImGearARTBorder Constructor : ImGearARTBorder Constructor(IImGearRGBQuad,int)
color
The border color.
width
The border width. com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTBorder class object.

Syntax

public ImGearARTBorder(
   IImGearRGBQuad color,
   int width
)

Parameters

color
The border color.
width
The border width. com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List


%%PageItemTitle%%

ImGearARTBorder Constructor(IImGearRGBQuad,int,ImGearARTPenStyle)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTBorder Class > ImGearARTBorder Constructor : ImGearARTBorder Constructor(IImGearRGBQuad,int,ImGearARTPenStyle)
color
The border color.
width
The border width.
style
The border style. com.accusoft.imagegear.core.ImGearRGBQuad ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTBorder class object.

Syntax

public ImGearARTBorder(
   IImGearRGBQuad color,
   int width,
   ImGearARTPenStyle style
)

Parameters

color
The border color.
width
The border width.
style
The border style. com.accusoft.imagegear.core.ImGearRGBQuad ImGearARTPenStyle

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTBorder Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTBorder Class

Glossary Item Box

For a list of all members of this type, see ImGearARTBorder members.

Public Methods

 | Name | Description
public Method | getColor | Gets the border color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getStyle | Gets the border style. ImGearARTPenStyle enumeration value.
public Method | getWidth | Gets the width of the border line. Integer value.
public Method | setColor | Sets the border color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setStyle | Sets the border style. ImGearARTPenStyle enumeration value.
public Method | setWidth | Sets the width of the border line. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTBorder Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : getColor Method

Glossary Item Box

Gets the border color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : getStyle Method

Glossary Item Box

Gets the border style.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : getWidth Method

Glossary Item Box

Gets the width of the border line.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : setColor Method
value

Glossary Item Box

Sets the border color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : setStyle Method
value

Glossary Item Box

Sets the border style.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : setWidth Method
value

Glossary Item Box

Sets the width of the border line.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTBorder Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTBorder Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTBorder Class
ImGearARTBorder Members


%%PageItemTitle%%

ImGearARTButton Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTButton Class

Glossary Item Box

Represents ART Button mark.

Object Model

ImGearARTButton ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTButton
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTButton

See Also

Reference

ImGearARTButton Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTButton Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTButton Class

Glossary Item Box

The following tables list the members exposed by ImGearARTButton.

Public Constructors

 | Name | Description
public Constructor | ImGearARTButton Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | state | The state of the button. ImGearARTButtonState enumeration value. ImGearARTButtonState
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the button. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the button's text. Name string.
public Method | getFontSize | Gets the pointSize of the font in points. Any float positive value.
public Method | getFontStyleART | Gets the font style of the button's text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the button. Integer value.
public Method | getOpacity | Gets the opacity of the button. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getText | Gets the button text. Text string.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the button. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the button. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the button's text. Name string.
public Method | setFontSize | Sets the pointSize of the font in points. Any float positive value.
public Method | setFontStyleART | Sets the font style of the button's text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the button. Integer value.
public Method | setOpacity | Sets the opacity of the button. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setText | Sets the button text. Text string.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the button. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTButton Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTButton Constructor
com.accusoft.imagegear.art Package > ImGearARTButton Class : ImGearARTButton Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTButton Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTButton class object.
ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,int,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTButton class object.

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

ImGearARTButton Constructor(IImGearRectangle,String)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTButton Class > ImGearARTButton Constructor : ImGearARTButton Constructor(IImGearRectangle,String)
rect
The mark rectangle.
text
Button text. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTButton class object.

Syntax

public ImGearARTButton(
   IImGearRectangle rect,
   java.lang.String text
)

Parameters

rect
The mark rectangle.
text
Button text. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Overload List


%%PageItemTitle%%

ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,int,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTButton Class > ImGearARTButton Constructor : ImGearARTButton Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,int,String,float,EnumSet<ImGearARTFontStyles>)
rect
The mark rectangle.
text
Button text.
textColor
Button text color.
fillColor
The fill color of the button.
opacity
Button opacity.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTButton class object.

Syntax

public ImGearARTButton(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor,
   int opacity,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

rect
The mark rectangle.
text
Button text.
textColor
Button text color.
fillColor
The fill color of the button.
opacity
Button opacity.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTButton Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTButton Class

Glossary Item Box

For a list of all members of this type, see ImGearARTButton members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the button. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the button's text. Name string.
public Method | getFontSize | Gets the pointSize of the font in points. Any float positive value.
public Method | getFontStyleART | Gets the font style of the button's text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the button. Integer value.
public Method | getOpacity | Gets the opacity of the button. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getText | Gets the button text. Text string.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the button. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the button. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the button's text. Name string.
public Method | setFontSize | Sets the pointSize of the font in points. Any float positive value.
public Method | setFontStyleART | Sets the font style of the button's text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the button. Integer value.
public Method | setOpacity | Sets the opacity of the button. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setText | Sets the button text. Text string.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the button. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTButton Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getFillColor Method

Glossary Item Box

Gets the fill color of the button.

com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

System.Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getFontName Method

Glossary Item Box

Gets the font name of the button's text.

Name string.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getFontSize Method

Glossary Item Box

Gets the pointSize of the font in points.

Any float positive value.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the button's text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getHeight Method

Glossary Item Box

Gets the height of the button.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getOpacity Method

Glossary Item Box

Gets the opacity of the button.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getText Method

Glossary Item Box

Gets the button text.

Text string.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getTextColor Method

Glossary Item Box

Gets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getWidth Method

Glossary Item Box

Gets the width of the button.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getX Method

Glossary Item Box

Gets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : getY Method

Glossary Item Box

Gets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the button.

com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

System.Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setFontName Method
value

Glossary Item Box

Sets the font name of the button's text.

Name string.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setFontSize Method
value

Glossary Item Box

Sets the pointSize of the font in points.

Any float positive value.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the button's text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setHeight Method
value

Glossary Item Box

Sets the height of the button.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the button.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setText Method
value

Glossary Item Box

Sets the button text.

Text string.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setTextColor Method
value

Glossary Item Box

Sets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setWidth Method
value

Glossary Item Box

Sets the width of the button.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTButton Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTButton Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTButton Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTButton Class

Glossary Item Box

For a list of all members of this type, see ImGearARTButton members.

Public Fields

 | Name | Description
public Field | state | The state of the button. ImGearARTButtonState enumeration value. ImGearARTButtonState
Top

See Also

Reference

ImGearARTButton Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

state Field
com.accusoft.imagegear.art Package > ImGearARTButton Class : state Field

Glossary Item Box

The state of the button.

ImGearARTButtonState enumeration value. ImGearARTButtonState

Syntax

public ImGearARTButtonState state

Return Value

ImGearARTButtonState enumeration value.

See Also

Reference

ImGearARTButton Class
ImGearARTButton Members


%%PageItemTitle%%

ImGearARTCallout Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCallout Class

Glossary Item Box

Provides text mark's callout attributes. Callout is the shape object that points to the object it tells about.

Object Model

ImGearARTCallout ClassImGearARTBorder ClassImGearARTCalloutType Enumeration

Syntax

public class ImGearARTCallout
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTCallout

See Also

Reference

ImGearARTCallout Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTCallout Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCallout Class

Glossary Item Box

The following tables list the members exposed by ImGearARTCallout.

Public Constructors

 | Name | Description
public Constructor | ImGearARTCallout Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getLine | Gets the callout line attributes. ImGearARTBorder class.
public Method | getType | Gets the callout type. ImGearARTCalloutType enumeration value. ImGearARTCalloutType
public Method | getX | Gets the callout pointer X location. Integer value. The coordinate is relative to the left edge of the text mark.
public Method | getY | Gets the callout pointer Y location. Integer value. The coordinate is relative to the top edge of the text mark.
public Method | setLine | Sets the callout line attributes. ImGearARTBorder class.
public Method | setType | Gets the callout type. ImGearARTCalloutType enumeration value. ImGearARTCalloutType
public Method | setX | Sets the callout pointer X location. Integer value. The coordinate is relative to the left edge of the text mark.
public Method | setY | Sets the callout pointer Y location. Integer value. The coordinate is relative to the top edge of the text mark.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTCallout Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCallout Class

Glossary Item Box

For a list of all members of this type, see ImGearARTCallout members.

See Also

Reference

ImGearARTCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTCallout Constructor
com.accusoft.imagegear.art Package > ImGearARTCallout Class : ImGearARTCallout Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTCallout Constructor(ImGearARTCalloutType,int,int) | Initializes a new instance of the ImGearARTCalloutType class object.
ImGearARTCallout Constructor(ImGearARTCalloutType,int,int,ImGearARTBorder) | Initializes a new instance of the ImGearARTCalloutType class object.

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

ImGearARTCallout Constructor(ImGearARTCalloutType,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTCallout Class > ImGearARTCallout Constructor : ImGearARTCallout Constructor(ImGearARTCalloutType,int,int)
type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.

Glossary Item Box

Initializes a new instance of the ImGearARTCalloutType class object.

Syntax

public ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY
)

Parameters

type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List


%%PageItemTitle%%

ImGearARTCallout Constructor(ImGearARTCalloutType,int,int,ImGearARTBorder)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTCallout Class > ImGearARTCallout Constructor : ImGearARTCallout Constructor(ImGearARTCalloutType,int,int,ImGearARTBorder)
type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.
line
Callout line attributes. ImGearARTCalloutType ImGearARTBorder

Glossary Item Box

Initializes a new instance of the ImGearARTCalloutType class object.

Syntax

public ImGearARTCallout(
   ImGearARTCalloutType type,
   int pointX,
   int pointY,
   ImGearARTBorder line
)

Parameters

type
The callout type.
pointX
Callout pointer X location.
pointY
Callout pointer Y location.
line
Callout line attributes. ImGearARTCalloutType ImGearARTBorder

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTCallout Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCallout Class

Glossary Item Box

For a list of all members of this type, see ImGearARTCallout members.

Public Methods

 | Name | Description
public Method | getLine | Gets the callout line attributes. ImGearARTBorder class.
public Method | getType | Gets the callout type. ImGearARTCalloutType enumeration value. ImGearARTCalloutType
public Method | getX | Gets the callout pointer X location. Integer value. The coordinate is relative to the left edge of the text mark.
public Method | getY | Gets the callout pointer Y location. Integer value. The coordinate is relative to the top edge of the text mark.
public Method | setLine | Sets the callout line attributes. ImGearARTBorder class.
public Method | setType | Gets the callout type. ImGearARTCalloutType enumeration value. ImGearARTCalloutType
public Method | setX | Sets the callout pointer X location. Integer value. The coordinate is relative to the left edge of the text mark.
public Method | setY | Sets the callout pointer Y location. Integer value. The coordinate is relative to the top edge of the text mark.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getLine Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : getLine Method

Glossary Item Box

Gets the callout line attributes.

ImGearARTBorder class.

Syntax

public ImGearARTBorder getLine()

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : getType Method

Glossary Item Box

Gets the callout type.

ImGearARTCalloutType enumeration value. ImGearARTCalloutType

Syntax

public ImGearARTCalloutType getType()

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : getX Method

Glossary Item Box

Gets the callout pointer X location.

Integer value.

The coordinate is relative to the left edge of the text mark.

Syntax

public int getX()

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : getY Method

Glossary Item Box

Gets the callout pointer Y location.

Integer value.

The coordinate is relative to the top edge of the text mark.

Syntax

public int getY()

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

setLine Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : setLine Method
value

Glossary Item Box

Sets the callout line attributes.

ImGearARTBorder class.

Syntax

public void setLine(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

setType Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : setType Method
value

Glossary Item Box

Gets the callout type.

ImGearARTCalloutType enumeration value. ImGearARTCalloutType

Syntax

public void setType(
   ImGearARTCalloutType value
)

Parameters

value

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : setX Method
value

Glossary Item Box

Sets the callout pointer X location.

Integer value.

The coordinate is relative to the left edge of the text mark.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : setY Method
value

Glossary Item Box

Sets the callout pointer Y location.

Integer value.

The coordinate is relative to the top edge of the text mark.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTCallout Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTCallout Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTCallout Class
ImGearARTCallout Members


%%PageItemTitle%%

ImGearARTCurve Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCurve Class

Glossary Item Box

Represents ART Curve mark.

Object Model

ImGearARTCurve ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTCurve
    extends ImGearARTMark
    implements IImGearARTCurve

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTCurve

See Also

Reference

ImGearARTCurve Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTCurve Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCurve Class

Glossary Item Box

The following tables list the members exposed by ImGearARTCurve.

Public Constructors

 | Name | Description
public Constructor | ImGearARTCurve Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTCurve method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 127.
public Method | getPoint | Gets the point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | getTension | Gets the tension of the curve. Float value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 127.
public Method | setPoint | Sets the point with the specified index.
public Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | setTension | Sets the tension of the curve. Float value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTCurve Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTCurve Constructor
com.accusoft.imagegear.art Package > ImGearARTCurve Class : ImGearARTCurve Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTCurve class object.
ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,float,int) | Initializes a new instance of the ImGearARTCurve class object.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTCurve Class > ImGearARTCurve Constructor : ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad)
points
Raw points array.
color
Color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Initializes a new instance of the ImGearARTCurve class object.

Syntax

public ImGearARTCurve(
   ImGearPoint[] points,
   IImGearRGBQuad color
)

Parameters

points
Raw points array.
color
Color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Overload List


%%PageItemTitle%%

ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,float,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTCurve Class > ImGearARTCurve Constructor : ImGearARTCurve Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,float,int)
points
Raw points array.
color
Color of the mark.
style
style of the mark.
width
Width of the mark.
tension
Tension of the curve.
opacity
Opacity of the mark. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTCurve class object.

Syntax

public ImGearARTCurve(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   float tension,
   int opacity
)

Parameters

points
Raw points array.
color
Color of the mark.
style
style of the mark.
width
Width of the mark.
tension
Tension of the curve.
opacity
Opacity of the mark. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTCurve Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCurve Class

Glossary Item Box

For a list of all members of this type, see ImGearARTCurve members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTCurve method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 127.
public Method | getPoint | Gets the point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | getTension | Gets the tension of the curve. Float value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 127.
public Method | setPoint | Sets the point with the specified index.
public Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | setTension | Sets the tension of the curve. Float value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTCurve Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTCurve method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value.

The default value is 127.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getPoint Method
index
Index of the point.

Glossary Item Box

Gets the point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getStyle Method

Glossary Item Box

Gets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getTension Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getTension Method

Glossary Item Box

Gets the tension of the curve.

Float value.

Syntax

public float getTension()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

onPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : onPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void onPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

onPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : onPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void onPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

onPointsRemoved Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : onPointsRemoved Method
e
Event arguments.

Glossary Item Box

Occurs when points are removed.

Syntax

protected void onPointsRemoved(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

removePoints Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : removePoints Method
index
The index of the first point to remove.
count
The number of points to remove.

Glossary Item Box

Removes the specified number of points, starting at the specified index.

An error will occur if the specified index or specified number of points to remove is out of range.

Syntax

public void removePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value.

The default value is 127.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets the point with the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setStyle Method
value

Glossary Item Box

Sets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setTension Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setTension Method
value

Glossary Item Box

Sets the tension of the curve.

Float value.

Syntax

public void setTension(
   float value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTCurve Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTCurve Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTCurve Class

Glossary Item Box

For a list of all members of this type, see ImGearARTCurve members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTCurve Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTCurve Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTCurve Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

pointsRemoved Field
com.accusoft.imagegear.art Package > ImGearARTCurve Class : pointsRemoved Field

Glossary Item Box

Occurs when points are removed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> pointsRemoved

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTCurve Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTCurve Class
ImGearARTCurve Members


%%PageItemTitle%%

ImGearARTDroppedAttributeEventArgs Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedAttributeEventArgs Class

Glossary Item Box

Provides data for the DroppedAttribute event.

The DroppedAttribute event occurs only when you call the loadPage method and the unsupported annotation mark attribute is being dropped.

Object Model

ImGearARTDroppedAttributeEventArgs ClassImGearARTMark Class

Syntax

public class ImGearARTDroppedAttributeEventArgs
    extends com.accusoft.imagegear.utility.events.ImGearEventArgs

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedAttributeEventArgs

See Also

Reference

ImGearARTDroppedAttributeEventArgs Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTDroppedAttributeEventArgs Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedAttributeEventArgs Class

Glossary Item Box

The following tables list the members exposed by ImGearARTDroppedAttributeEventArgs.

Public Methods

 | Name | Description
public Method | getAttributeData | Gets the XML formatted string representing the attribute data that was dropped. String value.
public Method | getMark | Gets the annotation mark object whose attribute was dropped. ImGearARTMark class object.
Top

See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTDroppedAttributeEventArgs Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedAttributeEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearARTDroppedAttributeEventArgs members.

See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTDroppedAttributeEventArgs Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedAttributeEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearARTDroppedAttributeEventArgs members.

Public Methods

 | Name | Description
public Method | getAttributeData | Gets the XML formatted string representing the attribute data that was dropped. String value.
public Method | getMark | Gets the annotation mark object whose attribute was dropped. ImGearARTMark class object.
Top

See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAttributeData Method
com.accusoft.imagegear.art Package > ImGearARTDroppedAttributeEventArgs Class : getAttributeData Method

Glossary Item Box

Gets the XML formatted string representing the attribute data that was dropped.

String value.

Syntax

public java.lang.String getAttributeData()

See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImGearARTDroppedAttributeEventArgs Members


%%PageItemTitle%%

getMark Method
com.accusoft.imagegear.art Package > ImGearARTDroppedAttributeEventArgs Class : getMark Method

Glossary Item Box

Gets the annotation mark object whose attribute was dropped.

ImGearARTMark class object.

Syntax

public ImGearARTMark getMark()

See Also

Reference

ImGearARTDroppedAttributeEventArgs Class
ImGearARTDroppedAttributeEventArgs Members


%%PageItemTitle%%

ImGearARTDroppedMarkEventArgs Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedMarkEventArgs Class

Glossary Item Box

Provides data for the DroppedMark event.

The DroppedMark event occurs only when you call the loadPage method and the unsupported annotation mark is being dropped.

Object Model

ImGearARTDroppedMarkEventArgs ClassImGearARTGroup ClassImGearARTPage Class

Syntax

public class ImGearARTDroppedMarkEventArgs
    extends com.accusoft.imagegear.utility.events.ImGearEventArgs

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedMarkEventArgs

See Also

Reference

ImGearARTDroppedMarkEventArgs Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTDroppedMarkEventArgs Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedMarkEventArgs Class

Glossary Item Box

The following tables list the members exposed by ImGearARTDroppedMarkEventArgs.

Public Methods

 | Name | Description
public Method | getGroup | Gets the parent group of the mark that was dropped. ImGearARTGroup class object.
public Method | getMarkData | Gets the XML formatted string representing the mark data that was dropped. String value.
public Method | getPage | Gets the parent page of the mark that was dropped. ImGearARTPage class object.
Top

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTDroppedMarkEventArgs Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedMarkEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearARTDroppedMarkEventArgs members.

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTDroppedMarkEventArgs Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTDroppedMarkEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearARTDroppedMarkEventArgs members.

Public Methods

 | Name | Description
public Method | getGroup | Gets the parent group of the mark that was dropped. ImGearARTGroup class object.
public Method | getMarkData | Gets the XML formatted string representing the mark data that was dropped. String value.
public Method | getPage | Gets the parent page of the mark that was dropped. ImGearARTPage class object.
Top

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getGroup Method
com.accusoft.imagegear.art Package > ImGearARTDroppedMarkEventArgs Class : getGroup Method

Glossary Item Box

Gets the parent group of the mark that was dropped.

ImGearARTGroup class object.

Syntax

public ImGearARTGroup getGroup()

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


%%PageItemTitle%%

getMarkData Method
com.accusoft.imagegear.art Package > ImGearARTDroppedMarkEventArgs Class : getMarkData Method

Glossary Item Box

Gets the XML formatted string representing the mark data that was dropped.

String value.

Syntax

public java.lang.String getMarkData()

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


%%PageItemTitle%%

getPage Method
com.accusoft.imagegear.art Package > ImGearARTDroppedMarkEventArgs Class : getPage Method

Glossary Item Box

Gets the parent page of the mark that was dropped.

ImGearARTPage class object.

Syntax

public ImGearARTPage getPage()

See Also

Reference

ImGearARTDroppedMarkEventArgs Class
ImGearARTDroppedMarkEventArgs Members


%%PageItemTitle%%

ImGearARTEllipse Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEllipse Class

Glossary Item Box

Represents ART Ellipse mark.

Object Model

ImGearARTEllipse ClassImGearARTMark ClassImGearARTMark ClassImGearARTBorder ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTEllipse
    extends ImGearARTMark
    implements IImGearARTEllipse

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTEllipse

See Also

Reference

ImGearARTEllipse Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTEllipse Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEllipse Class

Glossary Item Box

The following tables list the members exposed by ImGearARTEllipse.

Public Constructors

 | Name | Description
public Constructor | ImGearARTEllipse Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTEllipse Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTEllipse members.

See Also

Reference

ImGearARTEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTEllipse Constructor
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : ImGearARTEllipse Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTEllipse class object.
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int) | Initializes a new instance of the ImGearARTEllipse class object.
ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int) | Initializes a new instance of the ImGearARTEllipse class object.

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
rect
The mark rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTEllipse class object.

Syntax

public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
The mark rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int)
rect
The mark rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Width of the border line. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTEllipse class object.

Syntax

public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

rect
The mark rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Width of the border line. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List


%%PageItemTitle%%

ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTEllipse Class > ImGearARTEllipse Constructor : ImGearARTEllipse Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
rect
The mark rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTEllipse class object.

Syntax

public ImGearARTEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

rect
The mark rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.ImGearRGBQuadT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTEllipse Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTEllipse members.

Public Methods

 | Name | Description
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the left-top point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the left-top point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the left-top point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the left-top point of the mark. Integer value.
Top

See Also

Reference

ImGearARTEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object. ImGearARTBorder

Syntax

public ImGearARTBorder getBorder()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value.

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getX Method

Glossary Item Box

Gets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : getY Method

Glossary Item Box

Gets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setBorder Method
value
Value to set.

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object.

Syntax

public void setBorder(
   ImGearARTBorder value
)

Parameters

value
Value to set.

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value.

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the left-top point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTEllipse Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTEllipse Class
ImGearARTEllipse Members


%%PageItemTitle%%

ImGearARTEncryption Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEncryption Class

Glossary Item Box

Represents ART Encryption mark.

Object Model

ImGearARTEncryption ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTEncryption
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTEncryption

See Also

Reference

ImGearARTEncryption Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTEncryption Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEncryption Class

Glossary Item Box

The following tables list the members exposed by ImGearARTEncryption.

Public Constructors

 | Name | Description
public Constructor | ImGearARTEncryption Constructor | Initializes a new instance of the ImGearARTEncryption class object.
Top

Public Methods

 | Name | Description
public Method | decrypt | This method decrypts the raster page that was encrypted previously. encrypt ()}
public Method | encrypt | This method encrypts specified raster page in the document.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.
public Method | getHeight | Gets the height of the encryption. Integer value.
public Method | getPassword | Gets the encryption password. String value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the encryption. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the encryption mark. Integer value.
public Method | getY | Sets the Y coordinate of the top-left point of the encryption mark. Integer value.
public Method | isApplied | Gets a value indicating whether the encryption is applied or not. Boolean value. If true, encryption is applied, false - otherwise. The default value is true.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setHeight | Sets the height of the encryption. Integer value.
public Method | setPassword | Sets the encryption password. String value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the encryption. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the encryption mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the encryption mark. Integer value.
Top

See Also

Reference

ImGearARTEncryption Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTEncryption Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEncryption Class

Glossary Item Box

For a list of all members of this type, see ImGearARTEncryption members.

See Also

Reference

ImGearARTEncryption Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTEncryption Constructor
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : ImGearARTEncryption Constructor
rect
The mark rectangle.
password
Encryption password. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTEncryption class object.

Syntax

public ImGearARTEncryption(
   IImGearRectangle rect,
   java.lang.String password
)

Parameters

rect
The mark rectangle.
password
Encryption password. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTEncryption Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTEncryption Class

Glossary Item Box

For a list of all members of this type, see ImGearARTEncryption members.

Public Methods

 | Name | Description
public Method | decrypt | This method decrypts the raster page that was encrypted previously. encrypt ()}
public Method | encrypt | This method encrypts specified raster page in the document.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.
public Method | getHeight | Gets the height of the encryption. Integer value.
public Method | getPassword | Gets the encryption password. String value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the encryption. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the encryption mark. Integer value.
public Method | getY | Sets the Y coordinate of the top-left point of the encryption mark. Integer value.
public Method | isApplied | Gets a value indicating whether the encryption is applied or not. Boolean value. If true, encryption is applied, false - otherwise. The default value is true.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setHeight | Sets the height of the encryption. Integer value.
public Method | setPassword | Sets the encryption password. String value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the encryption. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the encryption mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the encryption mark. Integer value.
Top

See Also

Reference

ImGearARTEncryption Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

decrypt Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : decrypt Method

Glossary Item Box

This method decrypts the raster page that was encrypted previously.

encrypt ()}

Syntax

public void decrypt()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

encrypt Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : encrypt Method
page
Page to encrypt. decrypt

Glossary Item Box

This method encrypts specified raster page in the document.

Syntax

public void encrypt(
   ImGearPage page
)

Parameters

page
Page to encrypt. decrypt

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getHeight Method

Glossary Item Box

Gets the height of the encryption.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getPassword Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getPassword Method

Glossary Item Box

Gets the encryption password.

String value.

Syntax

public java.lang.String getPassword()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getWidth Method

Glossary Item Box

Gets the width of the encryption.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the encryption mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : getY Method

Glossary Item Box

Sets the Y coordinate of the top-left point of the encryption mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

isApplied Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : isApplied Method

Glossary Item Box

Gets a value indicating whether the encryption is applied or not.

Boolean value.

If true, encryption is applied, false - otherwise. The default value is true.

Syntax

public boolean isApplied()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setHeight Method
value

Glossary Item Box

Sets the height of the encryption.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setPassword Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setPassword Method
value

Glossary Item Box

Sets the encryption password.

String value.

Syntax

public void setPassword(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setWidth Method
value

Glossary Item Box

Sets the width of the encryption.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the encryption mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the encryption mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTEncryption Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTEncryption Class
ImGearARTEncryption Members


%%PageItemTitle%%

ImGearARTFilledEllipse Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledEllipse Class

Glossary Item Box

Represents legacy ART Filled Ellipse mark.

Object Model

ImGearARTFilledEllipse ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTFilledEllipse
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTFilledEllipse

See Also

Reference

ImGearARTFilledEllipse Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTFilledEllipse Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledEllipse Class

Glossary Item Box

The following tables list the members exposed by ImGearARTFilledEllipse.

Public Constructors

 | Name | Description
public Constructor | ImGearARTFilledEllipse Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark. Integer value.
public Method | isHighlighted | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | isVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTFilledEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTFilledEllipse Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledEllipse members.

See Also

Reference

ImGearARTFilledEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : ImGearARTFilledEllipse Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledEllipse class object.
ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,boolean) | Initializes a new instance of the ImGearARTFilledEllipse class object.

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class > ImGearARTFilledEllipse Constructor : ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
rect
The mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledEllipse class object.

Syntax

public ImGearARTFilledEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Overload List


%%PageItemTitle%%

ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class > ImGearARTFilledEllipse Constructor : ImGearARTFilledEllipse Constructor(IImGearRectangle,IImGearRGBQuad,boolean)
rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledEllipse class object.

Syntax

public ImGearARTFilledEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   boolean isHighlighted
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTFilledEllipse Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledEllipse members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark. Integer value.
public Method | isHighlighted | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | isVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTFilledEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

isHighlighted Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : isHighlighted Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean isHighlighted()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : isVisible Method

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTFilledEllipse Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTFilledEllipse Class
ImGearARTFilledEllipse Members


%%PageItemTitle%%

ImGearARTFilledPolygon Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledPolygon Class

Glossary Item Box

Represents legacy ART Filled Polygon mark.

Object Model

ImGearARTFilledPolygon ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTFilledPolygon
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTFilledPolygon

See Also

Reference

ImGearARTFilledPolygon Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTFilledPolygon Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledPolygon Class

Glossary Item Box

The following tables list the members exposed by ImGearARTFilledPolygon.

Public Constructors

 | Name | Description
public Constructor | ImGearARTFilledPolygon Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value. The default value is false.
public Method | getNumberOfPoints | Gets the actual number of points. Integer number.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value. The default value is false.
public Method | setNumberOfPoints | Sets the actual number of points. Integer number.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFilledPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : ImGearARTFilledPolygon Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledPolygon class object.
ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,boolean) | Initializes a new instance of the ImGearARTFilledPolygon class object.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class > ImGearARTFilledPolygon Constructor : ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
points
Raw points array to create a polygon from.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledPolygon class object.

Syntax

public ImGearARTFilledPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor
)

Parameters

points
Raw points array to create a polygon from.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Overload List


%%PageItemTitle%%

ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class > ImGearARTFilledPolygon Constructor : ImGearARTFilledPolygon Constructor(ImGearPoint[],IImGearRGBQuad,boolean)
points
Raw points array to create a polygon from.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledPolygon class object.

Syntax

public ImGearARTFilledPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor,
   boolean isHighlighted
)

Parameters

points
Raw points array to create a polygon from.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTFilledPolygon Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledPolygon members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value. The default value is false.
public Method | getNumberOfPoints | Gets the actual number of points. Integer number.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value. The default value is false.
public Method | setNumberOfPoints | Sets the actual number of points. Integer number.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFilledPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

The default value is false.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of points.

Integer number.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getPoint Method
index
Actual index of the point to get.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
Actual index of the point to get.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

onPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : onPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void onPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

onPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : onPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void onPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

The default value is false.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of points.

Integer number.

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : setPoint Method
index
Index to set at.
point
Point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index to set at.
point
Point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTFilledPolygon Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledPolygon members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFilledPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTFilledPolygon Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTFilledPolygon Class
ImGearARTFilledPolygon Members


%%PageItemTitle%%

ImGearARTFilledRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledRectangle Class

Glossary Item Box

Represents legacy ART Filled Rectangle mark.

Object Model

ImGearARTFilledRectangle ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTFilledRectangle
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTFilledRectangle

See Also

Reference

ImGearARTFilledRectangle Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTFilledRectangle Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearARTFilledRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearARTFilledRectangle Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTFilledRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTFilledRectangle Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledRectangle members.

See Also

Reference

ImGearARTFilledRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : ImGearARTFilledRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTFilledRectangle class object.
ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,boolean) | Initializes a new instance of the ImGearARTFilledRectangle class object.

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class > ImGearARTFilledRectangle Constructor : ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
rect
The mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledRectangle class object.

Syntax

public ImGearARTFilledRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Overload List


%%PageItemTitle%%

ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class > ImGearARTFilledRectangle Constructor : ImGearARTFilledRectangle Constructor(IImGearRectangle,IImGearRGBQuad,boolean)
rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFilledRectangle class object.

Syntax

public ImGearARTFilledRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   boolean isHighlighted
)

Parameters

rect
The mark's rectangle.
fillColor
Fill color of the mark.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTFilledRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFilledRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFilledRectangle members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTFilledRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTFilledRectangle Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTFilledRectangle Class
ImGearARTFilledRectangle Members


%%PageItemTitle%%

ImGearARTFreeLine Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFreeLine Class

Glossary Item Box

Represents legacy ART Freehand line mark.

Object Model

ImGearARTFreeLine ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTFreeLine
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTFreeLine

See Also

Reference

ImGearARTFreeLine Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTFreeLine Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFreeLine Class

Glossary Item Box

The following tables list the members exposed by ImGearARTFreeLine.

Public Constructors

 | Name | Description
public Constructor | ImGearARTFreeLine Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the line. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getNumberOfPoints | Gets the actual number of points on the line mark. Integer value.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the line. Integer value.
public Method | isClosed | Gets a value indicating whether the line is closed. Boolean value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setClosed | Sets a value indicating whether the line is closed. Boolean value.
public Method | setColor | Sets the color of the line. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setNumberOfPoints | Sets the actual number of points on the line mark. Integer value.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the line. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFreeLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTFreeLine Constructor
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : ImGearARTFreeLine Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTFreeLine class object.
ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,int,boolean,boolean) | Initializes a new instance of the ImGearARTFreeLine class object.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class > ImGearARTFreeLine Constructor : ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad)
points
The mark's points.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFreeLine class object.

Syntax

public ImGearARTFreeLine(
   ImGearPoint[] points,
   IImGearRGBQuad color
)

Parameters

points
The mark's points.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Overload List


%%PageItemTitle%%

ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,int,boolean,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class > ImGearARTFreeLine Constructor : ImGearARTFreeLine Constructor(ImGearPoint[],IImGearRGBQuad,int,boolean,boolean)
points
The mark's points.
color
Color of the mark.
width
Width of the line.
isHighlighted
Specifies whether the mark is highlighted or not.
isClosed
Specifies whether the mark is closed or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTFreeLine class object.

Syntax

public ImGearARTFreeLine(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   int width,
   boolean isHighlighted,
   boolean isClosed
)

Parameters

points
The mark's points.
color
Color of the mark.
width
Width of the line.
isHighlighted
Specifies whether the mark is highlighted or not.
isClosed
Specifies whether the mark is closed or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTFreeLine Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFreeLine Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFreeLine members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the line. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getNumberOfPoints | Gets the actual number of points on the line mark. Integer value.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the line. Integer value.
public Method | isClosed | Gets a value indicating whether the line is closed. Boolean value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setClosed | Sets a value indicating whether the line is closed. Boolean value.
public Method | setColor | Sets the color of the line. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setNumberOfPoints | Sets the actual number of points on the line mark. Integer value.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the line. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFreeLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getColor Method

Glossary Item Box

Gets the color of the line.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of points on the line mark.

Integer value.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getPoint Method
index
Index of the point.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : getWidth Method

Glossary Item Box

Gets the width of the line.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

isClosed Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : isClosed Method

Glossary Item Box

Gets a value indicating whether the line is closed.

Boolean value.

Syntax

public boolean isClosed()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

onPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : onPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void onPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

onPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : onPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void onPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setClosed Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setClosed Method
value

Glossary Item Box

Sets a value indicating whether the line is closed.

Boolean value.

Syntax

public void setClosed(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setColor Method
value

Glossary Item Box

Sets the color of the line.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of points on the line mark.

Integer value.

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setPoint Method
index
Index to set the point at.
point
Point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index to set the point at.
point
Point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : setWidth Method
value

Glossary Item Box

Sets the width of the line.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTFreeLine Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTFreeLine Class

Glossary Item Box

For a list of all members of this type, see ImGearARTFreeLine members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTFreeLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTFreeLine Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTFreeLine Class
ImGearARTFreeLine Members


%%PageItemTitle%%

ImGearARTGroup Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroup Class

Glossary Item Box

Represents a collection of annotation marks united into a single group.

This class provides methods and properties generic for the annotation group.

Object Model

ImGearARTGroup ClassImGearARTAccess EnumerationImGearARTMark Class

Syntax

public class ImGearARTGroup
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTGroup

See Also

Reference

ImGearARTGroup Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTGroup Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroup Class

Glossary Item Box

The following tables list the members exposed by ImGearARTGroup.

Public Constructors

 | Name | Description
public Constructor | ImGearARTGroup Constructor | Initializes a new instance of the ImGearARTGroup class object.
Top

Public Methods

 | Name | Description
public Method | bringToFront | Moves the group of marks to the top of Z-Order.
public Method | copy | Copies the group of marks to the Windows clipboard.
public Method | cut | Cuts the group of marks to the Windows clipboard.
public Method | getAccess | Gets the access to the group. ImGearARTAccess enumeration value.
public Method | getCount | Gets the marks count in the group. Integer value.
public Method | getDescription | Gets the group description. String value.
public Method | getItem | Gets a mark by index.
public Method | getName | Gets the group name. String value.
public Method | iterator | Returns an iterator over the elements in this group.
public Method | removeAll | Removes all marks from the group.
public Method | removeAt | Removes a mark specified by index from the group.
public Method | select | Selects or deselects all marks in the group.
public Method | sendToBack | Moves the group of marks to the bottom of Z-Order.
public Method | setAccess | Sets the access to the group. ImGearARTAccess enumeration value.
public Method | setDescription | Sets the group description. String value.
public Method | setItem | Sets a mark by index.
public Method | setName | Sets the group name. String value.
Top

See Also

Reference

ImGearARTGroup Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTGroup Constructor
com.accusoft.imagegear.art Package > ImGearARTGroup Class : ImGearARTGroup Constructor
name
Group name.
description
Group description.

Glossary Item Box

Initializes a new instance of the ImGearARTGroup class object.

Syntax

public ImGearARTGroup(
   java.lang.String name,
   java.lang.String description
)

Parameters

name
Group name.
description
Group description.

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTGroup Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroup Class

Glossary Item Box

For a list of all members of this type, see ImGearARTGroup members.

Public Methods

 | Name | Description
public Method | bringToFront | Moves the group of marks to the top of Z-Order.
public Method | copy | Copies the group of marks to the Windows clipboard.
public Method | cut | Cuts the group of marks to the Windows clipboard.
public Method | getAccess | Gets the access to the group. ImGearARTAccess enumeration value.
public Method | getCount | Gets the marks count in the group. Integer value.
public Method | getDescription | Gets the group description. String value.
public Method | getItem | Gets a mark by index.
public Method | getName | Gets the group name. String value.
public Method | iterator | Returns an iterator over the elements in this group.
public Method | removeAll | Removes all marks from the group.
public Method | removeAt | Removes a mark specified by index from the group.
public Method | select | Selects or deselects all marks in the group.
public Method | sendToBack | Moves the group of marks to the bottom of Z-Order.
public Method | setAccess | Sets the access to the group. ImGearARTAccess enumeration value.
public Method | setDescription | Sets the group description. String value.
public Method | setItem | Sets a mark by index.
public Method | setName | Sets the group name. String value.
Top

See Also

Reference

ImGearARTGroup Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

bringToFront Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : bringToFront Method

Glossary Item Box

Moves the group of marks to the top of Z-Order.

Syntax

public void bringToFront()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

copy Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : copy Method

Glossary Item Box

Copies the group of marks to the Windows clipboard.

Syntax

public void copy()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

cut Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : cut Method

Glossary Item Box

Cuts the group of marks to the Windows clipboard.

Syntax

public void cut()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

getAccess Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : getAccess Method

Glossary Item Box

Gets the access to the group.

ImGearARTAccess enumeration value.

Syntax

public ImGearARTAccess getAccess()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : getCount Method

Glossary Item Box

Gets the marks count in the group.

Integer value.

Syntax

public int getCount()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : getDescription Method

Glossary Item Box

Gets the group description.

String value.

Syntax

public java.lang.String getDescription()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : getItem Method
index
Index of a mark. ImGearARTMark class object.

Indexed method for accessing individual marks from the group.

Glossary Item Box

Gets a mark by index.

Syntax

public ImGearARTMark getItem(
   int index
)

Parameters

index
Index of a mark. ImGearARTMark class object.

Indexed method for accessing individual marks from the group.

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : getName Method

Glossary Item Box

Gets the group name.

String value.

Syntax

public java.lang.String getName()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : iterator Method

Glossary Item Box

Returns an iterator over the elements in this group.

Syntax

public java.util.Iterator<ImGearARTMark> iterator()

Return Value

An iterator over the elements in this group

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

removeAll Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : removeAll Method

Glossary Item Box

Removes all marks from the group.

Syntax

public void removeAll()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

removeAt Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : removeAt Method
index
Index of a mark in the group to remove.

Glossary Item Box

Removes a mark specified by index from the group.

Syntax

public void removeAt(
   int index
)

Parameters

index
Index of a mark in the group to remove.

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

select Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : select Method
state
Pass true to select all marks in the group, false to deselect.

Glossary Item Box

Selects or deselects all marks in the group.

Syntax

public void select(
   boolean state
)

Parameters

state
Pass true to select all marks in the group, false to deselect.

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

sendToBack Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : sendToBack Method

Glossary Item Box

Moves the group of marks to the bottom of Z-Order.

Syntax

public void sendToBack()

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

setAccess Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : setAccess Method
value

Glossary Item Box

Sets the access to the group.

ImGearARTAccess enumeration value.

Syntax

public void setAccess(
   ImGearARTAccess value
)

Parameters

value

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

setDescription Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : setDescription Method
value

Glossary Item Box

Sets the group description.

String value.

Syntax

public void setDescription(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : setItem Method
index
Index of a mark. ImGearARTMark class object.

Indexed method for accessing individual marks from the group.

value

Glossary Item Box

Sets a mark by index.

Syntax

public void setItem(
   int index,
   ImGearARTMark value
)

Parameters

index
Index of a mark. ImGearARTMark class object.

Indexed method for accessing individual marks from the group.

value

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.art Package > ImGearARTGroup Class : setName Method
value

Glossary Item Box

Sets the group name.

String value.

Syntax

public void setName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTGroup Class
ImGearARTGroup Members


%%PageItemTitle%%

ImGearARTGroupArray Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupArray Class

Glossary Item Box

Represents an array of annotation groups.

Object Model

ImGearARTGroupArray ClassImGearARTGroup ClassImGearARTGroup ClassImGearARTGroup Class

Syntax

public class ImGearARTGroupArray
    extends Object
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTGroupArray

See Also

Reference

ImGearARTGroupArray Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTGroupArray Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupArray Class

Glossary Item Box

The following tables list the members exposed by ImGearARTGroupArray.

Public Constructors

 | Name | Description
public Constructor | ImGearARTGroupArray Constructor |
Top

Public Methods

 | Name | Description
public Method | add | Adds an annotation group to the array.
public Method | find | Finds a group specified by the name in the array.
public Method | getCount | Gets number of ART groups in the array. Integer number.
public Method | getGroup | Gets a group specified by the name.
public Method | getItem | Overloaded. Gets a group by index.
public Method | iterator | To iterate over the collection.
public Method | remove | Overloaded. Removes the specified group from the array.
public Method | removeAll | Removes all groups from the array.
public Method | removeAt | Removes a group specified by index from the array.
public Method | setItem | Sets a group by index.
Top

See Also

Reference

ImGearARTGroupArray Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTGroupArray Constructor
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : ImGearARTGroupArray Constructor
ParentPage

Glossary Item Box

Syntax

public ImGearARTGroupArray(
   ImGearARTPage ParentPage
)

Parameters

ParentPage

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTGroupArray Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupArray Class

Glossary Item Box

For a list of all members of this type, see ImGearARTGroupArray members.

Public Methods

 | Name | Description
public Method | add | Adds an annotation group to the array.
public Method | find | Finds a group specified by the name in the array.
public Method | getCount | Gets number of ART groups in the array. Integer number.
public Method | getGroup | Gets a group specified by the name.
public Method | getItem | Overloaded. Gets a group by index.
public Method | iterator | To iterate over the collection.
public Method | remove | Overloaded. Removes the specified group from the array.
public Method | removeAll | Removes all groups from the array.
public Method | removeAt | Removes a group specified by index from the array.
public Method | setItem | Sets a group by index.
Top

See Also

Reference

ImGearARTGroupArray Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : add Method
group
Group to add.

Glossary Item Box

Adds an annotation group to the array.

Syntax

public int add(
   ImGearARTGroup group
)

Parameters

group
Group to add.

Return Value

Integer value. ImGearARTGroup

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

find Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : find Method
name
Name of the group to find.

Glossary Item Box

Finds a group specified by the name in the array.

Syntax

public ImGearARTGroup find(
   java.lang.String name
)

Parameters

name
Name of the group to find.

Return Value

ImGearARTGroup class object. ImGearARTGroup

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : getCount Method

Glossary Item Box

Gets number of ART groups in the array.

Integer number.

Syntax

public int getCount()

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

getGroup Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : getGroup Method
name
Name of the group to get.

Glossary Item Box

Gets a group specified by the name.

Syntax

public ImGearARTGroup getGroup(
   java.lang.String name
)

Parameters

name
Name of the group to get.

Return Value

ImGearARTGroup class object. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTGroup

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : getItem Method

Glossary Item Box

Gets a group by index.

Overload List

Overload | Description
getItem(int) | Gets a group by index.
getItem(String) | Gets a group by name.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

getItem(int) Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class > getItem Method : getItem(int) Method
index
Index of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by index.

Glossary Item Box

Gets a group by index.

Syntax

public ImGearARTGroup getItem(
   int index
)

Parameters

index
Index of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by index.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List


%%PageItemTitle%%

getItem(String) Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class > getItem Method : getItem(String) Method
name
Name of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by name.

ImGearARTGroup

Glossary Item Box

Gets a group by name.

Syntax

public ImGearARTGroup getItem(
   java.lang.String name
)

Parameters

name
Name of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by name.

ImGearARTGroup

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : iterator Method

Glossary Item Box

To iterate over the collection.

Syntax

public java.util.Iterator<ImGearARTGroup> iterator()

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : remove Method

Glossary Item Box

Removes the specified group from the array.

Overload List

Overload | Description
remove(ImGearARTGroup) | Removes the specified group from the array.
remove(String) | Removes a group with the specified name from the array.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

remove(ImGearARTGroup) Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class > remove Method : remove(ImGearARTGroup) Method
group
The group to remove. ImGearARTGroup

Glossary Item Box

Removes the specified group from the array.

Syntax

public void remove(
   ImGearARTGroup group
)

Parameters

group
The group to remove. ImGearARTGroup

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List


%%PageItemTitle%%

remove(String) Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class > remove Method : remove(String) Method
name
Name of the group to remove.

Glossary Item Box

Removes a group with the specified name from the array.

Syntax

public void remove(
   java.lang.String name
)

Parameters

name
Name of the group to remove.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members
Overload List


%%PageItemTitle%%

removeAll Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : removeAll Method

Glossary Item Box

Removes all groups from the array.

Syntax

public void removeAll()

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

removeAt Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : removeAt Method
index
Index of a group in array to remove.

Glossary Item Box

Removes a group specified by index from the array.

Syntax

public void removeAt(
   int index
)

Parameters

index
Index of a group in array to remove.

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.art Package > ImGearARTGroupArray Class : setItem Method
index
Index of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by index.

value

Glossary Item Box

Sets a group by index.

Syntax

public void setItem(
   int index,
   ImGearARTGroup value
)

Parameters

index
Index of a group. ImGearARTGroup class object.

Indexed method for accessing individual groups by index.

value

See Also

Reference

ImGearARTGroupArray Class
ImGearARTGroupArray Members


%%PageItemTitle%%

ImGearARTGroupEnumerator Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupEnumerator Class

Glossary Item Box

Provides marks iteration capabilities over the annotation group.

Group enumerator is used for ImGearARTGroup to iterate through the collection of marks by using foreach statement.

Object Model

ImGearARTGroupEnumerator ClassImGearARTMark Class

Syntax

public class ImGearARTGroupEnumerator
    extends Object
    implements java.util.Iterator

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTGroupEnumerator

See Also

Reference

ImGearARTGroupEnumerator Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTGroupEnumerator Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupEnumerator Class

Glossary Item Box

The following tables list the members exposed by ImGearARTGroupEnumerator.

Public Constructors

 | Name | Description
public Constructor | ImGearARTGroupEnumerator Constructor | Initializes a new instance of the ImGearARTGroupEnumerator class object.
Top

Public Methods

 | Name | Description
public Method | hasNext | Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)
public Method | next | Returns the next element in the iteration.
public Method | remove | This is a read-only iterator so calling this has no effect.
Top

See Also

Reference

ImGearARTGroupEnumerator Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTGroupEnumerator Constructor
com.accusoft.imagegear.art Package > ImGearARTGroupEnumerator Class : ImGearARTGroupEnumerator Constructor
artGroup
ART group to enumerate the marks from. ImGearARTGroup ImGearARTGroupEnumerator

Glossary Item Box

Initializes a new instance of the ImGearARTGroupEnumerator class object.

Syntax

public ImGearARTGroupEnumerator(
   ImGearARTGroup artGroup
)

Parameters

artGroup
ART group to enumerate the marks from. ImGearARTGroup ImGearARTGroupEnumerator

See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTGroupEnumerator Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTGroupEnumerator Class

Glossary Item Box

For a list of all members of this type, see ImGearARTGroupEnumerator members.

Public Methods

 | Name | Description
public Method | hasNext | Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)
public Method | next | Returns the next element in the iteration.
public Method | remove | This is a read-only iterator so calling this has no effect.
Top

See Also

Reference

ImGearARTGroupEnumerator Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

hasNext Method
com.accusoft.imagegear.art Package > ImGearARTGroupEnumerator Class : hasNext Method

Glossary Item Box

Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)

Syntax

public boolean hasNext()

Return Value

true if the iterator has more elements.

See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members


%%PageItemTitle%%

next Method
com.accusoft.imagegear.art Package > ImGearARTGroupEnumerator Class : next Method

Glossary Item Box

Returns the next element in the iteration.

Syntax

public ImGearARTMark next()

Return Value

the next element in the iteration.

Exceptions

Exception | Description
java.util.NoSuchElementException |

See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.art Package > ImGearARTGroupEnumerator Class : remove Method

Glossary Item Box

This is a read-only iterator so calling this has no effect.

Syntax

public void remove()

See Also

Reference

ImGearARTGroupEnumerator Class
ImGearARTGroupEnumerator Members


%%PageItemTitle%%

ImGearARTHighlighter Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHighlighter Class

Glossary Item Box

Represents legacy ART Highlighter mark.

Object Model

ImGearARTHighlighter ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTHighlighter
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTHighlighter

See Also

Reference

ImGearARTHighlighter Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTHighlighter Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHighlighter Class

Glossary Item Box

The following tables list the members exposed by ImGearARTHighlighter.

Public Constructors

 | Name | Description
public Constructor | ImGearARTHighlighter Constructor | Initializes a new instance of the ImGearARTHighlighter class object.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using %com.accusoft.imagegear.art.ImGearARTPage.addMark(com.accusoft.imagegear.art.ARTMarkCoord, int)% method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the Highlighter mark rectangle. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the Highlighter mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of top-left point of mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the Highlighter mark rectangle. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the Highlighter mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of top-left point of mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTHighlighter Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTHighlighter Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHighlighter Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHighlighter members.

See Also

Reference

ImGearARTHighlighter Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTHighlighter Constructor
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : ImGearARTHighlighter Constructor
rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTHighlighter class object.

Syntax

public ImGearARTHighlighter(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTHighlighter Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHighlighter Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHighlighter members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using %com.accusoft.imagegear.art.ImGearARTPage.addMark(com.accusoft.imagegear.art.ARTMarkCoord, int)% method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the Highlighter mark rectangle. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the Highlighter mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of top-left point of mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the Highlighter mark rectangle. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the Highlighter mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of top-left point of mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTHighlighter Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using %com.accusoft.imagegear.art.ImGearARTPage.addMark(com.accusoft.imagegear.art.ARTMarkCoord, int)% method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getHeight Method

Glossary Item Box

Gets the height of the Highlighter mark rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getWidth Method

Glossary Item Box

Gets the width of the Highlighter mark rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getX Method

Glossary Item Box

Gets the X coordinate of top-left point of mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : getY Method

Glossary Item Box

Gets the Y coordinate of top-left point of mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setHeight Method
value

Glossary Item Box

Sets the height of the Highlighter mark rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setWidth Method
value

Glossary Item Box

Sets the width of the Highlighter mark rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setX Method
value

Glossary Item Box

Sets the X coordinate of top-left point of mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of top-left point of mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTHighlighter Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTHighlighter Class
ImGearARTHighlighter Members


%%PageItemTitle%%

ImGearARTHollowEllipse Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowEllipse Class

Glossary Item Box

Represents legacy ART Hollow Ellipse mark.

Object Model

ImGearARTHollowEllipse ClassImGearARTMark ClassImGearARTMark ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTHollowEllipse
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTHollowEllipse

See Also

Reference

ImGearARTHollowEllipse Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTHollowEllipse Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowEllipse Class

Glossary Item Box

The following tables list the members exposed by ImGearARTHollowEllipse.

Public Constructors

 | Name | Description
public Constructor | ImGearARTHollowEllipse Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTHollowEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTHollowEllipse Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowEllipse members.

See Also

Reference

ImGearARTHollowEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : ImGearARTHollowEllipse Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowEllipse class object.
ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,int,boolean) | Initializes a new instance of the ImGearARTHollowEllipse class object.

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class > ImGearARTHollowEllipse Constructor : ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad)
rect
Mark's rectangle.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHollowEllipse class object.

Syntax

public ImGearARTHollowEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Overload List


%%PageItemTitle%%

ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,int,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class > ImGearARTHollowEllipse Constructor : ImGearARTHollowEllipse Constructor(IImGearRectangle,IImGearRGBQuad,int,boolean)
rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHollowEllipse class object.

Syntax

public ImGearARTHollowEllipse(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   int borderWidth,
   boolean isHighlighted
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTHollowEllipse Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowEllipse members.

Public Methods

 | Name | Description
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTHollowEllipse Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getBorderColor Method

Glossary Item Box

Gets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getBorderColor()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getBorderWidth Method

Glossary Item Box

Gets the border width of the mark.

Integer value.

Syntax

public int getBorderWidth()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getX Method

Glossary Item Box

Gets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : getY Method

Glossary Item Box

Gets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setBorderColor Method
value

Glossary Item Box

Sets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setBorderColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setBorderWidth Method
value

Glossary Item Box

Sets the border width of the mark.

Integer value.

Syntax

public void setBorderWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setX Method
value

Glossary Item Box

Sets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTHollowEllipse Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTHollowEllipse Class
ImGearARTHollowEllipse Members


%%PageItemTitle%%

ImGearARTHollowPolygon Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowPolygon Class

Glossary Item Box

Represents legacy ART Hollow Polygon mark.

Object Model

ImGearARTHollowPolygon ClassImGearARTMark ClassImGearARTMark ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearRectangle ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTMarkType EnumerationImGearPoint Class

Syntax

public class ImGearARTHollowPolygon
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTHollowPolygon

See Also

Reference

ImGearARTHollowPolygon Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTHollowPolygon Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowPolygon Class

Glossary Item Box

The following tables list the members exposed by ImGearARTHollowPolygon.

Public Constructors

 | Name | Description
public Constructor | ImGearARTHollowPolygon Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getNumberOfPoints | Gets the number of points of the mark. Integer value.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setNumberOfPoints | Sets the number of points of the mark. Integer value.
public Method | setPoint | Overloaded. Gets mark's point with the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | OnPointAdded | Occurs when a point is added to the mark.
protected Method | OnPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTHollowPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : ImGearARTHollowPolygon Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowPolygon class object.
ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,int,boolean) | Initializes a new instance of the ImGearARTHollowPolygon class object.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class > ImGearARTHollowPolygon Constructor : ImGearARTHollowPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
points
Mark's points.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHollowPolygon class object.

Syntax

public ImGearARTHollowPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad borderColor
)

Parameters

points
Mark's points.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List


%%PageItemTitle%%

ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,int,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class > ImGearARTHollowPolygon Constructor : ImGearARTHollowPolygon Constructor(ImGearPoint[],ImGearRGBQuad,int,boolean)
points
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHollowPolygon class object.

Syntax

public ImGearARTHollowPolygon(
   ImGearPoint[] points,
   ImGearRGBQuad borderColor,
   int borderWidth,
   boolean isHighlighted
)

Parameters

points
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTHollowPolygon Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowPolygon members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getNumberOfPoints | Gets the number of points of the mark. Integer value.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setNumberOfPoints | Sets the number of points of the mark. Integer value.
public Method | setPoint | Overloaded. Gets mark's point with the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | OnPointAdded | Occurs when a point is added to the mark.
protected Method | OnPointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTHollowPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getBorderColor Method

Glossary Item Box

Gets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getBorderColor()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getBorderWidth Method

Glossary Item Box

Gets the border width of the mark.

Integer value.

Syntax

public int getBorderWidth()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getNumberOfPoints Method

Glossary Item Box

Gets the number of points of the mark.

Integer value.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

OnPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : OnPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void OnPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

OnPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : OnPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void OnPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setBorderColor Method
value

Glossary Item Box

Sets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setBorderColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setBorderWidth Method
value

Glossary Item Box

Sets the border width of the mark.

Integer value.

Syntax

public void setBorderWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the number of points of the mark.

Integer value.

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setPoint Method

Glossary Item Box

Gets mark's point with the specified index.

Overload List

Overload | Description
setPoint(int) | Gets mark's point with the specified index.
setPoint(int,ImGearPoint) | Sets mark's point at the specified index.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

setPoint(int) Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class > setPoint Method : setPoint(int) Method
index
Index of the point in the mark points array.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint setPoint(
   int index
)

Parameters

index
Index of the point in the mark points array.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List


%%PageItemTitle%%

setPoint(int,ImGearPoint) Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class > setPoint Method : setPoint(int,ImGearPoint) Method
index
Index of the point in the mark points array.
point
The point to be set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point in the mark points array.
point
The point to be set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members
Overload List


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTHollowPolygon Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowPolygon members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
Top

See Also

Reference

ImGearARTHollowPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTHollowPolygon Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTHollowPolygon Class
ImGearARTHollowPolygon Members


%%PageItemTitle%%

ImGearARTHollowRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowRectangle Class

Glossary Item Box

Represents legacy ART Hollow Rectangle mark.

Object Model

ImGearARTHollowRectangle ClassImGearARTMark ClassImGearARTMark ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTHollowRectangle
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTHollowRectangle

See Also

Reference

ImGearARTHollowRectangle Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTHollowRectangle Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearARTHollowRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearARTHollowRectangle Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTHollowRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTHollowRectangle Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowRectangle members.

See Also

Reference

ImGearARTHollowRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : ImGearARTHollowRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad) | Initializes a new instance of the ImGearARTHollowRectangle class object.
ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,int,boolean) | Initializes a new instance of the ImGearARTHollowRectangle class object.

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class > ImGearARTHollowRectangle Constructor : ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad)
rect
Mark's rectangle.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHollowRectangle class object.

Syntax

public ImGearARTHollowRectangle(
   IImGearRectangle rect,
   ImGearRGBQuad borderColor
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Overload List


%%PageItemTitle%%

ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,int,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class > ImGearARTHollowRectangle Constructor : ImGearARTHollowRectangle Constructor(IImGearRectangle,ImGearRGBQuad,int,boolean)
rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not.

Glossary Item Box

Initializes a new instance of the ImGearARTHollowRectangle class object.

Syntax

public ImGearARTHollowRectangle(
   IImGearRectangle rect,
   ImGearRGBQuad borderColor,
   int borderWidth,
   boolean isHighlighted
)

Parameters

rect
Mark's rectangle.
borderColor
Border color of the mark.
borderWidth
Width of the mark's border.
isHighlighted
Specifies whether the mark is highlighted or not.

Return Value

The new instance of ImGearARTHollowRectangle class object. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTHollowRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHollowRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHollowRectangle members.

Public Methods

 | Name | Description
public Method | getBorderColor | Gets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getBorderWidth | Gets the border width of the mark. Integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHeight | Gets the height of the mark. Integer value.
public Method | getHighlight | Gets a value indicating whether the mark is highlighted. Boolean value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorderColor | Sets the border color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setBorderWidth | Sets the border width of the mark. Integer value.
public Method | setHeight | Sets the height of the mark. Integer value.
public Method | setHighlight | Sets a value indicating whether the mark is highlighted. Boolean value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTHollowRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getBorderColor Method

Glossary Item Box

Gets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getBorderColor()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getBorderWidth Method

Glossary Item Box

Gets the border width of the mark.

Integer value.

Syntax

public int getBorderWidth()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getHeight Method

Glossary Item Box

Gets the height of the mark.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getHighlight Method

Glossary Item Box

Gets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public boolean getHighlight()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getX Method

Glossary Item Box

Gets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : getY Method

Glossary Item Box

Gets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setBorderColor Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setBorderColor Method
value

Glossary Item Box

Sets the border color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setBorderColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setBorderWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setBorderWidth Method
value

Glossary Item Box

Sets the border width of the mark.

Integer value.

Syntax

public void setBorderWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setHighlight Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setHighlight Method
value

Glossary Item Box

Sets a value indicating whether the mark is highlighted.

Boolean value.

Syntax

public void setHighlight(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setX Method
value

Glossary Item Box

Sets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTHollowRectangle Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTHollowRectangle Class
ImGearARTHollowRectangle Members


%%PageItemTitle%%

ImGearARTHotSpot Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHotSpot Class

Glossary Item Box

Represents ART Hot Spot mark.

Object Model

ImGearARTHotSpot ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTHotSpot
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTHotSpot

See Also

Reference

ImGearARTHotSpot Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTHotSpot Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHotSpot Class

Glossary Item Box

The following tables list the members exposed by ImGearARTHotSpot.

Public Constructors

 | Name | Description
public Constructor | ImGearARTHotSpot Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTHotSpot Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTHotSpot Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHotSpot Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHotSpot members.

See Also

Reference

ImGearARTHotSpot Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTHotSpot Constructor
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : ImGearARTHotSpot Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the ImGearARTHotSpot class object.
ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,int) | Initializes a new instance of the ImGearARTHotSpot class object.

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class > ImGearARTHotSpot Constructor : ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad)
rect
Rectangle of the mark.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHotSpot class object.

Syntax

public ImGearARTHotSpot(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
Rectangle of the mark.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Overload List


%%PageItemTitle%%

ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class > ImGearARTHotSpot Constructor : ImGearARTHotSpot Constructor(IImGearRectangle,IImGearRGBQuad,int)
rect
Rectangle of the mark.
fillColor
Fill color of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTHotSpot class object.

Syntax

public ImGearARTHotSpot(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   int opacity
)

Parameters

rect
Rectangle of the mark.
fillColor
Fill color of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTHotSpot Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTHotSpot Class

Glossary Item Box

For a list of all members of this type, see ImGearARTHotSpot members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value. The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value. The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTHotSpot Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getHeight Method

Glossary Item Box

Gets the height of the mark's rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value.

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark's rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value.

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTHotSpot Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTHotSpot Class
ImGearARTHotSpot Members


%%PageItemTitle%%

ImGearARTImage Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImage Class

Glossary Item Box

Represents ART Image mark.

Object Model

ImGearARTImage ClassImGearARTImage ClassImGearARTMark ClassImGearAlignmentHModes EnumerationImGearAlignmentVModes EnumerationImGearRectangle ClassImGearFitModes EnumerationImGearRectangle ClassImGearOrientationModes EnumerationImGearPage ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTImage
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTImage

See Also

Reference

ImGearARTImage Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTImage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImage Class

Glossary Item Box

The following tables list the members exposed by ImGearARTImage.

Public Constructors

 | Name | Description
public Constructor | ImGearARTImage Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | clone | This method clones ImGearARTImageEmb class object.
public Method | getAlignmentH | Gets the horizontal alignment of the image. The default value is ImGearAlignmentHModes.LEFT. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of the image. The default value is ImGearAlignmentVModes.TOP. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | getAspectRatio | Gets the aspect ratio of the image. Any positive double number. The default value is 1.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the file name of the image reference. String value.
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. The default value is ImGearFitModes.FIT_TO_DEVICE. com.accusoft.imagegear.display.ImGearFitModes
public Method | getHeight | Gets the height of the rectangle. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | getPage | Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getViewBkColor | The method gets the current background color of the view.
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. The default value is ImGearAlignmentHModes.LEFT. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of the image. The default value is ImGearAlignmentVModes.TOP. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | setAspectRatio | Sets the aspect ratio of the image. Any positive double number. The default value is 1.
public Method | setFileName | Sets the file name of the image reference. String value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. The default value is ImGearFitModes.FIT_TO_DEVICE. com.accusoft.imagegear.display.ImGearFitModes
public Method | setHeight | Sets the height of the rectangle. Integer value.
public Method | setOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | setPage | Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTImage Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImage Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImage members.

See Also

Reference

ImGearARTImage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTImage Constructor
com.accusoft.imagegear.art Package > ImGearARTImage Class : ImGearARTImage Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTImage Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImageEmb class object.
ImGearARTImage Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTImageEmb class object.
ImGearARTImage Constructor(IImGearRectangle,ImGearPage) | Initializes a new instance of the ImGearARTImageEmb class object.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle)
rect
Image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageEmb class object.

Syntax

public ImGearARTImage(
   IImGearRectangle rect
)

Parameters

rect
Image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle,String)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle,String)
rect
Image rectangle.
fileName
File name of the image. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageEmb class object.

Syntax

public ImGearARTImage(
   IImGearRectangle rect,
   java.lang.String fileName
)

Parameters

rect
Image rectangle.
fileName
File name of the image. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List


%%PageItemTitle%%

ImGearARTImage Constructor(IImGearRectangle,ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImage Class > ImGearARTImage Constructor : ImGearARTImage Constructor(IImGearRectangle,ImGearPage)
rect
The image rectangle.
page
The page to create a mark from. com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageEmb class object.

Syntax

public ImGearARTImage(
   IImGearRectangle rect,
   ImGearPage page
)

Parameters

rect
The image rectangle.
page
The page to create a mark from. com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTImage Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImage Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImage members.

Public Methods

 | Name | Description
public Method | clone | This method clones ImGearARTImageEmb class object.
public Method | getAlignmentH | Gets the horizontal alignment of the image. The default value is ImGearAlignmentHModes.LEFT. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of the image. The default value is ImGearAlignmentVModes.TOP. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | getAspectRatio | Gets the aspect ratio of the image. Any positive double number. The default value is 1.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the file name of the image reference. String value.
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. The default value is ImGearFitModes.FIT_TO_DEVICE. com.accusoft.imagegear.display.ImGearFitModes
public Method | getHeight | Gets the height of the rectangle. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | getPage | Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getViewBkColor | The method gets the current background color of the view.
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. The default value is ImGearAlignmentHModes.LEFT. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of the image. The default value is ImGearAlignmentVModes.TOP. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | setAspectRatio | Sets the aspect ratio of the image. Any positive double number. The default value is 1.
public Method | setFileName | Sets the file name of the image reference. String value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. The default value is ImGearFitModes.FIT_TO_DEVICE. com.accusoft.imagegear.display.ImGearFitModes
public Method | setHeight | Sets the height of the rectangle. Integer value.
public Method | setOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | setPage | Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : clone Method

Glossary Item Box

This method clones ImGearARTImageEmb class object.

Syntax

public ImGearARTImage clone()

Return Value

The new instance of ImGearARTImageEmb class.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getAlignmentH Method

Glossary Item Box

Gets the horizontal alignment of the image.

The default value is ImGearAlignmentHModes.LEFT.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public ImGearAlignmentHModes getAlignmentH()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getAlignmentV Method

Glossary Item Box

Gets the vertical alignment of the image.

The default value is ImGearAlignmentVModes.TOP.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes

Syntax

public ImGearAlignmentVModes getAlignmentV()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getAspectRatio Method

Glossary Item Box

Gets the aspect ratio of the image.

Any positive double number. The default value is 1.

Syntax

public double getAspectRatio()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getFileName Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getFileName Method

Glossary Item Box

Gets the file name of the image reference.

String value.

Syntax

public java.lang.String getFileName()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getFitMode Method

Glossary Item Box

Gets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value.

The default value is ImGearFitModes.FIT_TO_DEVICE.

com.accusoft.imagegear.display.ImGearFitModes

Syntax

public ImGearFitModes getFitMode()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getOrientation Method

Glossary Item Box

Gets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT.

Syntax

public ImGearOrientationModes getOrientation()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getPage Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getPage Method

Glossary Item Box

Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image.

com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public ImGearPage getPage()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getViewBkColor Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getViewBkColor Method

Glossary Item Box

The method gets the current background color of the view.

Syntax

public int getViewBkColor()

Return Value

Integer value.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getWidth Method

Glossary Item Box

Gets the width of the image.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setAlignmentH Method
value

Glossary Item Box

Sets the horizontal alignment of the image.

The default value is ImGearAlignmentHModes.LEFT.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public void setAlignmentH(
   ImGearAlignmentHModes value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setAlignmentV Method
value

Glossary Item Box

Sets the vertical alignment of the image.

The default value is ImGearAlignmentVModes.TOP.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes

Syntax

public void setAlignmentV(
   ImGearAlignmentVModes value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setAspectRatio Method
value

Glossary Item Box

Sets the aspect ratio of the image.

Any positive double number. The default value is 1.

Syntax

public void setAspectRatio(
   double value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setFileName Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setFileName Method
value

Glossary Item Box

Sets the file name of the image reference.

String value.

Syntax

public void setFileName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setFitMode Method
value

Glossary Item Box

Sets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value.

The default value is ImGearFitModes.FIT_TO_DEVICE.

com.accusoft.imagegear.display.ImGearFitModes

Syntax

public void setFitMode(
   ImGearFitModes value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setHeight Method
value

Glossary Item Box

Sets the height of the rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setOrientation Method
value

Glossary Item Box

Gets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT.

Syntax

public void setOrientation(
   ImGearOrientationModes value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setPage Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setPage Method
value

Glossary Item Box

Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image.

com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public void setPage(
   ImGearPage value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setWidth Method
value

Glossary Item Box

Sets the width of the image.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImage Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTImage Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTImage Class
ImGearARTImage Members


%%PageItemTitle%%

ImGearARTImageEmb Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageEmb Class

Glossary Item Box

Represents legacy ART Embedded Image mark.

Object Model

ImGearARTImageEmb ClassImGearARTMark ClassImGearARTMark ClassImGearAlignmentHModes EnumerationImGearAlignmentVModes EnumerationImGearRectangle ClassImGearFitModes EnumerationImGearRectangle ClassImGearOrientationModes EnumerationImGearPage ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTImageEmb
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTImageEmb

See Also

Reference

ImGearARTImageEmb Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTImageEmb Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageEmb Class

Glossary Item Box

The following tables list the members exposed by ImGearARTImageEmb.

Public Constructors

 | Name | Description
public Constructor | ImGearARTImageEmb Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getAlignmentH | Gets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | getAspectRatio | Gets the aspect ratio. Any positive double value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value.
public Method | getHeight | Gets the height of the image. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes
public Method | getPage | Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | setAspectRatio | Sets the aspect ratio. Any positive double value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value.
public Method | setHeight | Sets the height of the image. Integer value.
public Method | setOrientation | Sets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes
public Method | setPage | Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImageEmb Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTImageEmb Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageEmb Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImageEmb members.

See Also

Reference

ImGearARTImageEmb Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTImageEmb Constructor
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : ImGearARTImageEmb Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTImageEmb Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImageEmb class object.
ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage) | Initializes a new instance of the ImGearARTImageEmb class object.

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

ImGearARTImageEmb Constructor(IImGearRectangle)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class > ImGearARTImageEmb Constructor : ImGearARTImageEmb Constructor(IImGearRectangle)
rect
The image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageEmb class object.

Syntax

public ImGearARTImageEmb(
   IImGearRectangle rect
)

Parameters

rect
The image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Overload List


%%PageItemTitle%%

ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class > ImGearARTImageEmb Constructor : ImGearARTImageEmb Constructor(IImGearRectangle,ImGearPage)
rect
The image rectangle.
page
The page to create a mark from. com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageEmb class object.

Syntax

public ImGearARTImageEmb(
   IImGearRectangle rect,
   ImGearPage page
)

Parameters

rect
The image rectangle.
page
The page to create a mark from. com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTImageEmb Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageEmb Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImageEmb members.

Public Methods

 | Name | Description
public Method | getAlignmentH | Gets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | getAspectRatio | Gets the aspect ratio. Any positive double value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value.
public Method | getHeight | Gets the height of the image. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes
public Method | getPage | Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes
public Method | setAspectRatio | Sets the aspect ratio. Any positive double value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value.
public Method | setHeight | Sets the height of the image. Integer value.
public Method | setOrientation | Sets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes
public Method | setPage | Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image. com.accusoft.imagegear.core.ImGearPage class object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImageEmb Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getAlignmentH Method

Glossary Item Box

Gets the horizontal alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public ImGearAlignmentHModes getAlignmentH()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getAlignmentV Method

Glossary Item Box

Gets the vertical alignment of image.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.

Syntax

public ImGearAlignmentVModes getAlignmentV()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getAspectRatio Method

Glossary Item Box

Gets the aspect ratio.

Any positive double value.

Syntax

public double getAspectRatio()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getFitMode Method

Glossary Item Box

Gets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value.

Syntax

public ImGearFitModes getFitMode()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getHeight Method

Glossary Item Box

Gets the height of the image.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getOrientation Method

Glossary Item Box

Gets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes

Syntax

public ImGearOrientationModes getOrientation()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getPage Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getPage Method

Glossary Item Box

Gets the com.accusoft.imagegear.core.ImGearPage class object that contains the image.

com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public ImGearPage getPage()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getWidth Method

Glossary Item Box

Gets the width of the image.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setAlignmentH Method
value

Glossary Item Box

Sets the horizontal alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public void setAlignmentH(
   ImGearAlignmentHModes value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setAlignmentV Method
value

Glossary Item Box

Sets the vertical alignment of image.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. com.accusoft.imagegear.display.ImGearAlignmentVModes

Syntax

public void setAlignmentV(
   ImGearAlignmentVModes value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setAspectRatio Method
value

Glossary Item Box

Sets the aspect ratio.

Any positive double value.

Syntax

public void setAspectRatio(
   double value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setFitMode Method
value

Glossary Item Box

Sets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value.

Syntax

public void setFitMode(
   ImGearFitModes value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setHeight Method
value

Glossary Item Box

Sets the height of the image.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setOrientation Method
value

Glossary Item Box

Sets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. com.accusoft.imagegear.core.ImGearOrientationModes

Syntax

public void setOrientation(
   ImGearOrientationModes value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setPage Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setPage Method
value

Glossary Item Box

Sets the com.accusoft.imagegear.core.ImGearPage class object that contains the image.

com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public void setPage(
   ImGearPage value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setWidth Method
value

Glossary Item Box

Sets the width of the image.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTImageEmb Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTImageEmb Class
ImGearARTImageEmb Members


%%PageItemTitle%%

ImGearARTImageRef Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageRef Class

Glossary Item Box

Represents legacy ART Image Reference mark.

Object Model

ImGearARTImageRef ClassImGearARTMark ClassImGearARTMark ClassImGearAlignmentHModes EnumerationImGearAlignmentVModes EnumerationImGearRectangle ClassImGearFitModes EnumerationImGearRectangle ClassImGearOrientationModes EnumerationImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTImageRef
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTImageRef

See Also

Reference

ImGearARTImageRef Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTImageRef Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageRef Class

Glossary Item Box

The following tables list the members exposed by ImGearARTImageRef.

Public Constructors

 | Name | Description
public Constructor | ImGearARTImageRef Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getAlignmentH | Gets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | getAspectRatio | Gets the aspect ratio of the image. Any positive integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the file name of the image reference. String value.
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes
public Method | getHeight | Gets the height of the image. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | setAspectRatio | Sets the aspect ratio of the image. Any positive integer value.
public Method | setFileName | Sets the file name of the image reference. String value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes
public Method | setHeight | Sets the height of the image. Integer value.
public Method | setOrientation | Sets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImageRef Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTImageRef Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageRef Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImageRef members.

See Also

Reference

ImGearARTImageRef Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTImageRef Constructor
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : ImGearARTImageRef Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTImageRef Constructor(IImGearRectangle) | Initializes a new instance of the ImGearARTImageRef class object.
ImGearARTImageRef Constructor(IImGearRectangle,String) | Initializes a new instance of the ImGearARTImageRef class object.

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

ImGearARTImageRef Constructor(IImGearRectangle)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImageRef Class > ImGearARTImageRef Constructor : ImGearARTImageRef Constructor(IImGearRectangle)
rect
Image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageRef class object.

Syntax

public ImGearARTImageRef(
   IImGearRectangle rect
)

Parameters

rect
Image rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Overload List


%%PageItemTitle%%

ImGearARTImageRef Constructor(IImGearRectangle,String)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTImageRef Class > ImGearARTImageRef Constructor : ImGearARTImageRef Constructor(IImGearRectangle,String)
rect
The image rectangle.
fileName
The file name of the image reference. com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Initializes a new instance of the ImGearARTImageRef class object.

Syntax

public ImGearARTImageRef(
   IImGearRectangle rect,
   java.lang.String fileName
)

Parameters

rect
The image rectangle.
fileName
The file name of the image reference. com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTImageRef Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTImageRef Class

Glossary Item Box

For a list of all members of this type, see ImGearARTImageRef members.

Public Methods

 | Name | Description
public Method | getAlignmentH | Gets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | getAlignmentV | Gets the vertical alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | getAspectRatio | Gets the aspect ratio of the image. Any positive integer value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFileName | Gets the file name of the image reference. String value.
public Method | getFitMode | Gets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes
public Method | getHeight | Gets the height of the image. Integer value.
public Method | getOrientation | Gets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the image. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the image. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the image. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setAlignmentH | Sets the horizontal alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.
public Method | setAlignmentV | Sets the vertical alignment of the image. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.
public Method | setAspectRatio | Sets the aspect ratio of the image. Any positive integer value.
public Method | setFileName | Sets the file name of the image reference. String value.
public Method | setFitMode | Sets the fitting mode of the image. com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes
public Method | setHeight | Sets the height of the image. Integer value.
public Method | setOrientation | Sets the image orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the image. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the image. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the image. Integer value.
Top

See Also

Reference

ImGearARTImageRef Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getAlignmentH Method

Glossary Item Box

Gets the horizontal alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public ImGearAlignmentHModes getAlignmentH()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getAlignmentV Method

Glossary Item Box

Gets the vertical alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.

Syntax

public ImGearAlignmentVModes getAlignmentV()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getAspectRatio Method

Glossary Item Box

Gets the aspect ratio of the image.

Any positive integer value.

Syntax

public double getAspectRatio()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getFileName Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getFileName Method

Glossary Item Box

Gets the file name of the image reference.

String value.

Syntax

public java.lang.String getFileName()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getFitMode Method

Glossary Item Box

Gets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes

Syntax

public ImGearFitModes getFitMode()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getHeight Method

Glossary Item Box

Gets the height of the image.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getOrientation Method

Glossary Item Box

Gets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

Syntax

public ImGearOrientationModes getOrientation()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getWidth Method

Glossary Item Box

Gets the width of the image.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setAlignmentH Method
value

Glossary Item Box

Sets the horizontal alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

Syntax

public void setAlignmentH(
   ImGearAlignmentHModes value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setAlignmentV Method
value

Glossary Item Box

Sets the vertical alignment of the image.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.

Syntax

public void setAlignmentV(
   ImGearAlignmentVModes value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setAspectRatio Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setAspectRatio Method
value

Glossary Item Box

Sets the aspect ratio of the image.

Any positive integer value.

Syntax

public void setAspectRatio(
   double value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setFileName Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setFileName Method
value

Glossary Item Box

Sets the file name of the image reference.

String value.

Syntax

public void setFileName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setFitMode Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setFitMode Method
value

Glossary Item Box

Sets the fitting mode of the image.

com.accusoft.imagegear.display.ImGearFitModes enumeration value. com.accusoft.imagegear.display.ImGearFitModes

Syntax

public void setFitMode(
   ImGearFitModes value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setHeight Method
value

Glossary Item Box

Sets the height of the image.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setOrientation Method
value

Glossary Item Box

Sets the image orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

Syntax

public void setOrientation(
   ImGearOrientationModes value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setWidth Method
value

Glossary Item Box

Sets the width of the image.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the image.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the image.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTImageRef Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTImageRef Class
ImGearARTImageRef Members


%%PageItemTitle%%

ImGearARTLine Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLine Class

Glossary Item Box

Represents ART Line mark.

Object Model

ImGearARTLine ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearARTLineHeadType EnumerationImGearPoint ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTLineHeadType EnumerationImGearPoint ClassImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTLine
    extends ImGearARTMark
    implements IImGearARTLine

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTLine

See Also

Reference

ImGearARTLine Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTLine Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLine Class

Glossary Item Box

The following tables list the members exposed by ImGearARTLine.

Public Constructors

 | Name | Description
public Constructor | ImGearARTLine Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndHeadAngle | Gets the angle of the line's end head. Integer value.
public Method | getEndHeadLength | Gets the length of the line's end head. Integer value.
public Method | getEndHeadType | Gets the type of the line's end head. ImGearARTLineHeadType enumeration value.
public Method | getEndPoint | Gets the end point of the line. ` com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getOpacity | Gets the line opacity. Integer value. The default value is 255.
public Method | getStartHeadAngle | Gets the angle of the line's start head. Integer value.
public Method | getStartHeadLength | Gets the length of the line's start head. Integer value.
public Method | getStartHeadType | Gets the type of the line's start head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | getStartPoint | Gets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getStyle | Gets the style of the line. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the line width. Integer value. The default value is 1.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setEndHeadAngle | Sets the angle of the line's end head. Integer value.
public Method | setEndHeadLength | Sets the length of the line's end head. Integer value.
public Method | setEndHeadType | Sets the type of the line's end head. ImGearARTLineHeadType enumeration value.
public Method | setEndPoint | Sets the end point of the line. ` com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setOpacity | Sets the line opacity. Integer value. The default value is 255.
public Method | setStartHeadAngle | Sets the angle of the line's start head. Integer value.
public Method | setStartHeadLength | Sets the length of the line's start head. Integer value.
public Method | setStartHeadType | Sets the type of the line's start head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | setStartPoint | Sets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setStyle | Sets the style of the line. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the line width. Integer value. The default value is 1.
Top

See Also

Reference

ImGearARTLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTLine Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLine Class

Glossary Item Box

For a list of all members of this type, see ImGearARTLine members.

See Also

Reference

ImGearARTLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTLine Constructor
com.accusoft.imagegear.art Package > ImGearARTLine Class : ImGearARTLine Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTLine class object.
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int) | Initializes a new instance of the ImGearARTLine class object.
ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int) | Initializes a new instance of the ImGearARTLine class object.

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTLine class object.

Syntax

public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int)
startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTLine class object.

Syntax

public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List


%%PageItemTitle%%

ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTLine Class > ImGearARTLine Constructor : ImGearARTLine Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int)
startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line.
headFillColor
Fill color of the line's head.
startHeadType
The type of the line's start head.
startHeadAngle
The angle of the line's start head.
startHeadLength
The length of the line's start head.
endHeadType
The type of the line's end head.
endHeadAngle
The angle of the line's end head.
endHeadLength
The length of the line's end head. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTLineHeadType

Glossary Item Box

Initializes a new instance of the ImGearARTLine class object.

Syntax

public ImGearARTLine(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   IImGearRGBQuad headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)

Parameters

startPoint
The start point of the line.
endPoint
The end point of the line.
color
The color of the line.
style
The line style.
width
The width of the line.
opacity
Opacity of the line.
headFillColor
Fill color of the line's head.
startHeadType
The type of the line's start head.
startHeadAngle
The angle of the line's start head.
startHeadLength
The length of the line's start head.
endHeadType
The type of the line's end head.
endHeadAngle
The angle of the line's end head.
endHeadLength
The length of the line's end head. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTLineHeadType

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTLine Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLine Class

Glossary Item Box

For a list of all members of this type, see ImGearARTLine members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndHeadAngle | Gets the angle of the line's end head. Integer value.
public Method | getEndHeadLength | Gets the length of the line's end head. Integer value.
public Method | getEndHeadType | Gets the type of the line's end head. ImGearARTLineHeadType enumeration value.
public Method | getEndPoint | Gets the end point of the line. ` com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getOpacity | Gets the line opacity. Integer value. The default value is 255.
public Method | getStartHeadAngle | Gets the angle of the line's start head. Integer value.
public Method | getStartHeadLength | Gets the length of the line's start head. Integer value.
public Method | getStartHeadType | Gets the type of the line's start head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | getStartPoint | Gets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getStyle | Gets the style of the line. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the line width. Integer value. The default value is 1.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setEndHeadAngle | Sets the angle of the line's end head. Integer value.
public Method | setEndHeadLength | Sets the length of the line's end head. Integer value.
public Method | setEndHeadType | Sets the type of the line's end head. ImGearARTLineHeadType enumeration value.
public Method | setEndPoint | Sets the end point of the line. ` com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setOpacity | Sets the line opacity. Integer value. The default value is 255.
public Method | setStartHeadAngle | Sets the angle of the line's start head. Integer value.
public Method | setStartHeadLength | Sets the length of the line's start head. Integer value.
public Method | setStartHeadType | Sets the type of the line's start head. ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType
public Method | setStartPoint | Sets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setStyle | Sets the style of the line. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the line width. Integer value. The default value is 1.
Top

See Also

Reference

ImGearARTLine Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getColor Method

Glossary Item Box

Gets the line color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getEndHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getEndHeadAngle Method

Glossary Item Box

Gets the angle of the line's end head.

Integer value.

Syntax

public int getEndHeadAngle()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getEndHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getEndHeadLength Method

Glossary Item Box

Gets the length of the line's end head.

Integer value.

Syntax

public int getEndHeadLength()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getEndHeadType Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getEndHeadType Method

Glossary Item Box

Gets the type of the line's end head.

ImGearARTLineHeadType enumeration value.

Syntax

public ImGearARTLineHeadType getEndHeadType()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getEndPoint Method

Glossary Item Box

Gets the end point of the line. `

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint getEndPoint()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getHeadFillColor Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getHeadFillColor Method

Glossary Item Box

Gets the fill color of the line's head.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getHeadFillColor()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getOpacity Method

Glossary Item Box

Gets the line opacity.

Integer value.

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getStartHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getStartHeadAngle Method

Glossary Item Box

Gets the angle of the line's start head.

Integer value.

Syntax

public int getStartHeadAngle()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getStartHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getStartHeadLength Method

Glossary Item Box

Gets the length of the line's start head.

Integer value.

Syntax

public int getStartHeadLength()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getStartHeadType Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getStartHeadType Method

Glossary Item Box

Gets the type of the line's start head.

ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType

Syntax

public ImGearARTLineHeadType getStartHeadType()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getStartPoint Method

Glossary Item Box

Gets the start point of the line.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public ImGearPoint getStartPoint()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getStyle Method

Glossary Item Box

Gets the style of the line.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : getWidth Method

Glossary Item Box

Gets the line width.

Integer value.

The default value is 1.

Syntax

public int getWidth()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setColor Method
value

Glossary Item Box

Sets the line color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setEndHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setEndHeadAngle Method
value

Glossary Item Box

Sets the angle of the line's end head.

Integer value.

Syntax

public void setEndHeadAngle(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setEndHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setEndHeadLength Method
value

Glossary Item Box

Sets the length of the line's end head.

Integer value.

Syntax

public void setEndHeadLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setEndHeadType Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setEndHeadType Method
value

Glossary Item Box

Sets the type of the line's end head.

ImGearARTLineHeadType enumeration value.

Syntax

public void setEndHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setEndPoint Method
value

Glossary Item Box

Sets the end point of the line. `

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setHeadFillColor Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setHeadFillColor Method
value

Glossary Item Box

Sets the fill color of the line's head.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setHeadFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setOpacity Method
value

Glossary Item Box

Sets the line opacity.

Integer value.

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setStartHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setStartHeadAngle Method
value

Glossary Item Box

Sets the angle of the line's start head.

Integer value.

Syntax

public void setStartHeadAngle(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setStartHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setStartHeadLength Method
value

Glossary Item Box

Sets the length of the line's start head.

Integer value.

Syntax

public void setStartHeadLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setStartHeadType Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setStartHeadType Method
value

Glossary Item Box

Sets the type of the line's start head.

ImGearARTLineHeadType enumeration value. ImGearARTLineHeadType

Syntax

public void setStartHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setStartPoint Method
value

Glossary Item Box

Sets the start point of the line.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setStyle Method
value

Glossary Item Box

Sets the style of the line.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : setWidth Method
value

Glossary Item Box

Sets the line width.

Integer value.

The default value is 1.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTLine Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTLine Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTLine Class
ImGearARTLine Members


%%PageItemTitle%%

ImGearARTLoadEvents Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLoadEvents Class

Glossary Item Box

Contains fields that can be used to pass event delegates to loadPage method of the ImGearART.

Object Model

ImGearARTLoadEvents Class

Syntax

public sealed class ImGearARTLoadEvents
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTLoadEvents

See Also

Reference

ImGearARTLoadEvents Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTLoadEvents Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLoadEvents Class

Glossary Item Box

The following tables list the members exposed by ImGearARTLoadEvents.

Public Constructors

 | Name | Description
public Constructor | ImGearARTLoadEvents Constructor | Default constructor.
Top

Public Methods

 | Name | Description
public Method | getDroppedAttribute | Gets the event handler that handles DroppedAttribute event. EventHandler value. ImGearARTDroppedAttributeEventArgs
public Method | getDroppedMark | Gets the event handler that handles DroppedMark event. EventHandler value. ImGearARTDroppedMarkEventArgs
public Method | setDroppedAttribute | Sets the event handler that handles DroppedAttribute event. EventHandler value. ImGearARTDroppedAttributeEventArgs
public Method | setDroppedMark | Sets the event handler that handles DroppedMark event. EventHandler value. ImGearARTDroppedMarkEventArgs
Top

See Also

Reference

ImGearARTLoadEvents Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTLoadEvents Constructor
com.accusoft.imagegear.art Package > ImGearARTLoadEvents Class : ImGearARTLoadEvents Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearARTLoadEvents()

See Also

Reference

ImGearARTLoadEvents Class
ImGearARTLoadEvents Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTLoadEvents Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTLoadEvents Class

Glossary Item Box

For a list of all members of this type, see ImGearARTLoadEvents members.

Public Methods

 | Name | Description
public Method | getDroppedAttribute | Gets the event handler that handles DroppedAttribute event. EventHandler value. ImGearARTDroppedAttributeEventArgs
public Method | getDroppedMark | Gets the event handler that handles DroppedMark event. EventHandler value. ImGearARTDroppedMarkEventArgs
public Method | setDroppedAttribute | Sets the event handler that handles DroppedAttribute event. EventHandler value. ImGearARTDroppedAttributeEventArgs
public Method | setDroppedMark | Sets the event handler that handles DroppedMark event. EventHandler value. ImGearARTDroppedMarkEventArgs
Top

See Also

Reference

ImGearARTLoadEvents Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getDroppedAttribute Method
com.accusoft.imagegear.art Package > ImGearARTLoadEvents Class : getDroppedAttribute Method

Glossary Item Box

Gets the event handler that handles DroppedAttribute event.

EventHandler value. ImGearARTDroppedAttributeEventArgs

Syntax

public com.accusoft.imagegear.utility.events.IImGearEventHandler<ImGearARTDroppedAttributeEventArgs> getDroppedAttribute()

See Also

Reference

ImGearARTLoadEvents Class
ImGearARTLoadEvents Members


%%PageItemTitle%%

getDroppedMark Method
com.accusoft.imagegear.art Package > ImGearARTLoadEvents Class : getDroppedMark Method

Glossary Item Box

Gets the event handler that handles DroppedMark event.

EventHandler value. ImGearARTDroppedMarkEventArgs

Syntax

public com.accusoft.imagegear.utility.events.IImGearEventHandler<ImGearARTDroppedMarkEventArgs> getDroppedMark()

See Also

Reference

ImGearARTLoadEvents Class
ImGearARTLoadEvents Members


%%PageItemTitle%%

setDroppedAttribute Method
com.accusoft.imagegear.art Package > ImGearARTLoadEvents Class : setDroppedAttribute Method
value

Glossary Item Box

Sets the event handler that handles DroppedAttribute event.

EventHandler value. ImGearARTDroppedAttributeEventArgs

Syntax

public void setDroppedAttribute(
   com.accusoft.imagegear.utility.events.IImGearEventHandler<ImGearARTDroppedAttributeEventArgs> value
)

Parameters

value

See Also

Reference

ImGearARTLoadEvents Class
ImGearARTLoadEvents Members


%%PageItemTitle%%

setDroppedMark Method
com.accusoft.imagegear.art Package > ImGearARTLoadEvents Class : setDroppedMark Method
value

Glossary Item Box

Sets the event handler that handles DroppedMark event.

EventHandler value. ImGearARTDroppedMarkEventArgs

Syntax

public void setDroppedMark(
   com.accusoft.imagegear.utility.events.IImGearEventHandler<ImGearARTDroppedMarkEventArgs> value
)

Parameters

value

See Also

Reference

ImGearARTLoadEvents Class
ImGearARTLoadEvents Members


%%PageItemTitle%%

ImGearARTMark Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMark Class

Glossary Item Box

Provides the abstract base class for all annotation marks. Clients can register for notifications of property changes through this class's IImGearNotifyPropertyChanged interface.

Object Model

ImGearARTMark ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public abstract class ImGearARTMark
    extends ImGearARTSelection

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTArrow
com.accusoft.imagegear.art.ImGearARTAudio
com.accusoft.imagegear.art.ImGearARTButton
com.accusoft.imagegear.art.ImGearARTCurve
com.accusoft.imagegear.art.ImGearARTEllipse
com.accusoft.imagegear.art.ImGearARTEncryption
com.accusoft.imagegear.art.ImGearARTFilledEllipse
com.accusoft.imagegear.art.ImGearARTFilledPolygon
com.accusoft.imagegear.art.ImGearARTFilledRectangle
com.accusoft.imagegear.art.ImGearARTFreeLine
com.accusoft.imagegear.art.ImGearARTHighlighter
com.accusoft.imagegear.art.ImGearARTHollowEllipse
com.accusoft.imagegear.art.ImGearARTHollowPolygon
com.accusoft.imagegear.art.ImGearARTHollowRectangle
com.accusoft.imagegear.art.ImGearARTHotSpot
com.accusoft.imagegear.art.ImGearARTImage
com.accusoft.imagegear.art.ImGearARTImageEmb
com.accusoft.imagegear.art.ImGearARTImageRef
com.accusoft.imagegear.art.ImGearARTLine
com.accusoft.imagegear.art.ImGearARTNote
com.accusoft.imagegear.art.ImGearARTPinUpText
com.accusoft.imagegear.art.ImGearARTPoint
com.accusoft.imagegear.art.ImGearARTPolygon
com.accusoft.imagegear.art.ImGearARTPolyline
com.accusoft.imagegear.art.ImGearARTPolyRuler
com.accusoft.imagegear.art.ImGearARTProtractor
com.accusoft.imagegear.art.ImGearARTRectangle
com.accusoft.imagegear.art.ImGearARTRedaction
com.accusoft.imagegear.art.ImGearARTRuler
com.accusoft.imagegear.art.ImGearARTText
com.accusoft.imagegear.art.ImGearARTTextCallout
com.accusoft.imagegear.art.ImGearARTTextFromFile
com.accusoft.imagegear.art.ImGearARTTextStamp
com.accusoft.imagegear.art.ImGearARTTypedText

See Also

Reference

ImGearARTMark Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTMark Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMark Class

Glossary Item Box

The following tables list the members exposed by ImGearARTMark.

Public Methods

 | Name | Description
public Method | clone | Creates new object that is an exact copy of the current mark.
static (Shared in Visual Basic) | fromLegacyMark | Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
public Method | getBounds | Gets the mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHitTestBounds | Gets the mark's boundling rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getStatistics | Gets an object representing specific statistics information about the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.
public Method | getType | Gets the mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark's visibility state. Boolean value. The default value is true.
public Method | move | Moves the mark by specified offset.
public Method | setVisible | Sets a value indicating whether the mark's visibility state. Boolean value. The default value is true.
Top

See Also

Reference

ImGearARTMark Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTMark Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMark Class

Glossary Item Box

For a list of all members of this type, see ImGearARTMark members.

See Also

Reference

ImGearARTMark Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTMark Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMark Class

Glossary Item Box

For a list of all members of this type, see ImGearARTMark members.

Public Methods

 | Name | Description
public Method | clone | Creates new object that is an exact copy of the current mark.
static (Shared in Visual Basic) | fromLegacyMark | Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.
public Method | getBounds | Gets the mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getHitTestBounds | Gets the mark's boundling rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getStatistics | Gets an object representing specific statistics information about the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.
public Method | getType | Gets the mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark's visibility state. Boolean value. The default value is true.
public Method | move | Moves the mark by specified offset.
public Method | setVisible | Sets a value indicating whether the mark's visibility state. Boolean value. The default value is true.
Top

See Also

Reference

ImGearARTMark Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : clone Method

Glossary Item Box

Creates new object that is an exact copy of the current mark.

Syntax

public ImGearARTMark clone()

Return Value

The copy of the current mark.

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

fromLegacyMark Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : fromLegacyMark Method
legacyMark
Legacy ART 2.0 mark to convert.

Glossary Item Box

Converts legacy ART2.0 mark into the appropriate ART 3.0 mark.

Syntax

public static ImGearARTMark fromLegacyMark(
   ImGearARTMark legacyMark
)

Parameters

legacyMark
Legacy ART 2.0 mark to convert.

Return Value

Resulted ART 3.0 mark.

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : getBounds Method

Glossary Item Box

Gets the mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public abstract ImGearRectangle getBounds()

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

getHitTestBounds Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : getHitTestBounds Method

Glossary Item Box

Gets the mark's boundling rectangle used for hit test.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getHitTestBounds()

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

getStatistics Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : getStatistics Method

Glossary Item Box

Gets an object representing specific statistics information about the mark.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Syntax

public ImGearARTMarkStatistics getStatistics()

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : getType Method

Glossary Item Box

Gets the mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public abstract ImGearARTMarkType getType()

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark's visibility state.

Boolean value.

The default value is true.

Syntax

public abstract boolean isVisible()

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public abstract void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark's visibility state.

Boolean value.

The default value is true.

Syntax

public abstract void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTMark Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTMark Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTMark Class
ImGearARTMark Members


%%PageItemTitle%%

ImGearARTMarkStatistics Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMarkStatistics Class

Glossary Item Box

Represent specific statistics information about ART marks.

Object Model

ImGearARTMarkStatistics ClassIImGearResolution InterfaceImGearARTMeasurementUnit Class

Syntax

public class ImGearARTMarkStatistics
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTMarkStatistics

See Also

Reference

ImGearARTMarkStatistics Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTMarkStatistics Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMarkStatistics Class

Glossary Item Box

The following tables list the members exposed by ImGearARTMarkStatistics.

Public Methods

 | Name | Description
public Method | getArea | Gets the area of the mark. If the mark does not have an area (for example, Line or Protractor mark), this method will return 0. Double value.
public Method | getBoundsArea | Gets the area of the marks' bounds rectangle. Double value. Gets the area of the marks' bounds rectangle. Double value.
public Method | getBoundsPerimeter | Gets the perimeter of the marks' bounds rectangle. Double value.
public Method | getLength | Gets the total length of the line mark. If the mark does not have a Length (for example, Ellipse mark), this method will return 0. Double value.
public Method | getPerimeter | Gets the perimeter of the mark. Double value.
public Method | getResolution | Sets an image resolution. An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used. com.accusoft.imagegear.core.ImGearResolution structure object.
public Method | getUnit | Sets a measurement unit that is used to calculate statistics information. ImGearARTMeasurementUnit class object.
public Method | setResolution | Gets an image resolution. An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used. com.accusoft.imagegear.core.ImGearResolution structure object.
public Method | setUnit | Gets a measurement unit that is used to calculate statistics information. ImGearARTMeasurementUnit class object.
Top

Protected Methods

 | Name | Description
protected Method | polygonArea | Internal API.
Top

See Also

Reference

ImGearARTMarkStatistics Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTMarkStatistics Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMarkStatistics Class

Glossary Item Box

For a list of all members of this type, see ImGearARTMarkStatistics members.

See Also

Reference

ImGearARTMarkStatistics Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTMarkStatistics Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMarkStatistics Class

Glossary Item Box

For a list of all members of this type, see ImGearARTMarkStatistics members.

Public Methods

 | Name | Description
public Method | getArea | Gets the area of the mark. If the mark does not have an area (for example, Line or Protractor mark), this method will return 0. Double value.
public Method | getBoundsArea | Gets the area of the marks' bounds rectangle. Double value. Gets the area of the marks' bounds rectangle. Double value.
public Method | getBoundsPerimeter | Gets the perimeter of the marks' bounds rectangle. Double value.
public Method | getLength | Gets the total length of the line mark. If the mark does not have a Length (for example, Ellipse mark), this method will return 0. Double value.
public Method | getPerimeter | Gets the perimeter of the mark. Double value.
public Method | getResolution | Sets an image resolution. An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used. com.accusoft.imagegear.core.ImGearResolution structure object.
public Method | getUnit | Sets a measurement unit that is used to calculate statistics information. ImGearARTMeasurementUnit class object.
public Method | setResolution | Gets an image resolution. An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used. com.accusoft.imagegear.core.ImGearResolution structure object.
public Method | setUnit | Gets a measurement unit that is used to calculate statistics information. ImGearARTMeasurementUnit class object.
Top

Protected Methods

 | Name | Description
protected Method | polygonArea | Internal API.
Top

See Also

Reference

ImGearARTMarkStatistics Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getArea Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getArea Method

Glossary Item Box

Gets the area of the mark.

If the mark does not have an area (for example, Line or Protractor mark), this method will return 0.

Double value.

Syntax

public double getArea()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getBoundsArea Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getBoundsArea Method

Glossary Item Box

Gets the area of the marks' bounds rectangle.

Double value.

Gets the area of the marks' bounds rectangle.

Double value.

Syntax

public double getBoundsArea()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getBoundsPerimeter Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getBoundsPerimeter Method

Glossary Item Box

Gets the perimeter of the marks' bounds rectangle.

Double value.

Syntax

public double getBoundsPerimeter()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getLength Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getLength Method

Glossary Item Box

Gets the total length of the line mark.

If the mark does not have a Length (for example, Ellipse mark), this method will return 0.

Double value.

Syntax

public double getLength()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getPerimeter Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getPerimeter Method

Glossary Item Box

Gets the perimeter of the mark.

Double value.

Syntax

public double getPerimeter()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getResolution Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getResolution Method

Glossary Item Box

Sets an image resolution.

An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used.

com.accusoft.imagegear.core.ImGearResolution structure object.

Syntax

public IImGearResolution getResolution()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

getUnit Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : getUnit Method

Glossary Item Box

Sets a measurement unit that is used to calculate statistics information.

ImGearARTMeasurementUnit class object.

Syntax

public ImGearARTMeasurementUnit getUnit()

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

polygonArea Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : polygonArea Method
points
Points of the mark.

Glossary Item Box

Internal API.

Syntax

protected double polygonArea(
   ImGearPoint[] points
)

Parameters

points
Points of the mark.

Return Value

Double value.

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

setResolution Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : setResolution Method
value

Glossary Item Box

Gets an image resolution.

An image resolution is needed to calculate areas and lengths correctly when measurement unit other than Pixel is used.

com.accusoft.imagegear.core.ImGearResolution structure object.

Syntax

public void setResolution(
   IImGearResolution value
)

Parameters

value

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

setUnit Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : setUnit Method
value

Glossary Item Box

Gets a measurement unit that is used to calculate statistics information.

ImGearARTMeasurementUnit class object.

Syntax

public void setUnit(
   ImGearARTMeasurementUnit value
)

Parameters

value

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTMarkStatistics Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTMarkStatistics Class
ImGearARTMarkStatistics Members


%%PageItemTitle%%

ImGearARTMeasurementUnit Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMeasurementUnit Class

Glossary Item Box

Represents a measurement unit, such as Meter, Inch etc.

Measurement unit is defined by its name, abbreviation, and aspect values. Several most commonly used measurement units are available as static properties.

Object Model

ImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit ClassImGearARTMeasurementUnit Class

Syntax

public sealed class ImGearARTMeasurementUnit
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTMeasurementUnit

See Also

Reference

ImGearARTMeasurementUnit Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTMeasurementUnit Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMeasurementUnit Class

Glossary Item Box

The following tables list the members exposed by ImGearARTMeasurementUnit.

Public Constructors

 | Name | Description
public Constructor | ImGearARTMeasurementUnit Constructor | Initializes a new instance of the ImGearARTMeasurementUnit struct.
Top

Public Methods

 | Name | Description
public Method | equals | Overrides an Equal operator.
public Method | getAbbreviation | Gets an abbreviation of the unit. String value.
public Method | getAspectDenominator | Gets a denominator value, relative to PPM. For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000. Integer value.
public Method | getAspectNumerator | Gets a numerator value, relative to PPM. For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000. Integer value.
static (Shared in Visual Basic) | getCentimeter | Gets a predefined Centimeter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getDecimeter | Gets a predefined Decimeter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getDekameter | Gets a predefined Dekameter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getFoot | Gets a predefined Foot measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getInch | Gets a predefined Inch measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getKilometer | Gets a predefined Kilometer measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMeter | Gets a predefined Meter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMicrometer | Gets a predefined Micrometer measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMile | Gets a predefined Mile measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMillimeter | Gets a predefined Millimeter measurement unit. ImGearARTMeasurementUnit class object.
public Method | getName | Gets a full name of the unit. String value.
static (Shared in Visual Basic) | getPixel | Gets a predefined Pixel measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getYard | Gets a predefined Yard measurement unit. ImGearARTMeasurementUnit class object.
public Method | hashCode | Returns a hash code.
static (Shared in Visual Basic) | opEquality | Returns true if its two operands are equal.
static (Shared in Visual Basic) | opInequality | Returns true if its two operands are not equal.
public Method | toString | Returns a String that represents the current measurement unit.
Top

See Also

Reference

ImGearARTMeasurementUnit Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTMeasurementUnit Constructor
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : ImGearARTMeasurementUnit Constructor
name
Measurement unit name, such as 'Kilometer'.
abbreviation
Measurement unit abbreviation, such as 'km'.
aspectNumerator
Measurement unit numerator value, relative to PPM.
aspectDenominator
Measurement unit denominator value, relative to PPM.

Glossary Item Box

Initializes a new instance of the ImGearARTMeasurementUnit struct.

Syntax

public ImGearARTMeasurementUnit(
   java.lang.String name,
   java.lang.String abbreviation,
   int aspectNumerator,
   int aspectDenominator
)

Parameters

name
Measurement unit name, such as 'Kilometer'.
abbreviation
Measurement unit abbreviation, such as 'km'.
aspectNumerator
Measurement unit numerator value, relative to PPM.
aspectDenominator
Measurement unit denominator value, relative to PPM.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTMeasurementUnit Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTMeasurementUnit Class

Glossary Item Box

For a list of all members of this type, see ImGearARTMeasurementUnit members.

Public Methods

 | Name | Description
public Method | equals | Overrides an Equal operator.
public Method | getAbbreviation | Gets an abbreviation of the unit. String value.
public Method | getAspectDenominator | Gets a denominator value, relative to PPM. For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000. Integer value.
public Method | getAspectNumerator | Gets a numerator value, relative to PPM. For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000. Integer value.
static (Shared in Visual Basic) | getCentimeter | Gets a predefined Centimeter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getDecimeter | Gets a predefined Decimeter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getDekameter | Gets a predefined Dekameter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getFoot | Gets a predefined Foot measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getInch | Gets a predefined Inch measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getKilometer | Gets a predefined Kilometer measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMeter | Gets a predefined Meter measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMicrometer | Gets a predefined Micrometer measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMile | Gets a predefined Mile measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getMillimeter | Gets a predefined Millimeter measurement unit. ImGearARTMeasurementUnit class object.
public Method | getName | Gets a full name of the unit. String value.
static (Shared in Visual Basic) | getPixel | Gets a predefined Pixel measurement unit. ImGearARTMeasurementUnit class object.
static (Shared in Visual Basic) | getYard | Gets a predefined Yard measurement unit. ImGearARTMeasurementUnit class object.
public Method | hashCode | Returns a hash code.
static (Shared in Visual Basic) | opEquality | Returns true if its two operands are equal.
static (Shared in Visual Basic) | opInequality | Returns true if its two operands are not equal.
public Method | toString | Returns a String that represents the current measurement unit.
Top

See Also

Reference

ImGearARTMeasurementUnit Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

equals Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : equals Method
other
An object to compare.

Glossary Item Box

Overrides an Equal operator.

Syntax

public boolean equals(
   java.lang.Object other
)

Parameters

other
An object to compare.

Return Value

True if objects are equal.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getAbbreviation Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getAbbreviation Method

Glossary Item Box

Gets an abbreviation of the unit.

String value.

Syntax

public java.lang.String getAbbreviation()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getAspectDenominator Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getAspectDenominator Method

Glossary Item Box

Gets a denominator value, relative to PPM.

For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000.

Integer value.

Syntax

public int getAspectDenominator()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getAspectNumerator Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getAspectNumerator Method

Glossary Item Box

Gets a numerator value, relative to PPM.

For Meter, both numerator and denominator are equal to 1. For Kilometer, numerator is 1, denominator is 1000.

Integer value.

Syntax

public int getAspectNumerator()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getCentimeter Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getCentimeter Method

Glossary Item Box

Gets a predefined Centimeter measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getCentimeter()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getDecimeter Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getDecimeter Method

Glossary Item Box

Gets a predefined Decimeter measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getDecimeter()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getDekameter Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getDekameter Method

Glossary Item Box

Gets a predefined Dekameter measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getDekameter()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getFoot Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getFoot Method

Glossary Item Box

Gets a predefined Foot measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getFoot()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getInch Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getInch Method

Glossary Item Box

Gets a predefined Inch measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getInch()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getKilometer Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getKilometer Method

Glossary Item Box

Gets a predefined Kilometer measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getKilometer()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getMeter Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getMeter Method

Glossary Item Box

Gets a predefined Meter measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getMeter()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getMicrometer Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getMicrometer Method

Glossary Item Box

Gets a predefined Micrometer measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getMicrometer()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getMile Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getMile Method

Glossary Item Box

Gets a predefined Mile measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getMile()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getMillimeter Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getMillimeter Method

Glossary Item Box

Gets a predefined Millimeter measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getMillimeter()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getName Method

Glossary Item Box

Gets a full name of the unit.

String value.

Syntax

public java.lang.String getName()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getPixel Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getPixel Method

Glossary Item Box

Gets a predefined Pixel measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getPixel()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

getYard Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : getYard Method

Glossary Item Box

Gets a predefined Yard measurement unit.

ImGearARTMeasurementUnit class object.

Syntax

public static ImGearARTMeasurementUnit getYard()

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

hashCode Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : hashCode Method

Glossary Item Box

Returns a hash code.

Syntax

public int hashCode()

Return Value

Integer value.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

opEquality Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : opEquality Method
a
First object to compare.
b
Second object to compare.

Glossary Item Box

Returns true if its two operands are equal.

Syntax

public static boolean opEquality(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)

Parameters

a
First object to compare.
b
Second object to compare.

Return Value

True if objects are equal.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

opInequality Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : opInequality Method
a
First object to compare.
b
Second object to compare.

Glossary Item Box

Returns true if its two operands are not equal.

Syntax

public static boolean opInequality(
   ImGearARTMeasurementUnit a,
   ImGearARTMeasurementUnit b
)

Parameters

a
First object to compare.
b
Second object to compare.

Return Value

True if objects are not equal.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.art Package > ImGearARTMeasurementUnit Class : toString Method

Glossary Item Box

Returns a String that represents the current measurement unit.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearARTMeasurementUnit Class
ImGearARTMeasurementUnit Members


%%PageItemTitle%%

ImGearARTNote Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTNote Class

Glossary Item Box

Represents legacy ART Attach-A-Note mark.

Object Model

ImGearARTNote ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTNote
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTNote

See Also

Reference

ImGearARTNote Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTNote Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTNote Class

Glossary Item Box

The following tables list the members exposed by ImGearARTNote.

Public Constructors

 | Name | Description
public Constructor | ImGearARTNote Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getFontName | Gets the font name of the text of the mark. String value.
public Method | getFontSize | Gets the font pointSize of the text of the mark. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text of the mark. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getText | Gets the text of the note mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isFontPpmDisabled | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setFontDisablePpm | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text of the mark. String value.
public Method | setFontSize | Sets the font pointSize of the text of the mark. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text of the mark. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setText | Ð«ets the text of the note mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTNote Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTNote Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTNote Class

Glossary Item Box

For a list of all members of this type, see ImGearARTNote members.

See Also

Reference

ImGearARTNote Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTNote Constructor
com.accusoft.imagegear.art Package > ImGearARTNote Class : ImGearARTNote Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad) | Initializes a new instance of the ImGearARTNote class object.
ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTNote class object.

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTNote Class > ImGearARTNote Constructor : ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad)
rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTNote class object.

Syntax

public ImGearARTNote(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor
)

Parameters

rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Overload List


%%PageItemTitle%%

ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTNote Class > ImGearARTNote Constructor : ImGearARTNote Constructor(IImGearRectangle,String,IImGearRGBQuad,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTNote class object.

Syntax

public ImGearARTNote(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   IImGearRGBQuad fillColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

rect
The mark rectangle.
text
The text of the mark.
textColor
The color of the text.
fillColor
The fill color of the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTNote Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTNote Class

Glossary Item Box

For a list of all members of this type, see ImGearARTNote members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getFontName | Gets the font name of the text of the mark. String value.
public Method | getFontSize | Gets the font pointSize of the text of the mark. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text of the mark. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getText | Gets the text of the note mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isFontPpmDisabled | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setFontDisablePpm | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text of the mark. String value.
public Method | setFontSize | Sets the font pointSize of the text of the mark. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text of the mark. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setText | Ð«ets the text of the note mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTNote Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.IImGearScrollableView com.accusoft.imagegear.display.ImGearPageDisplay

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getFontName Method

Glossary Item Box

Gets the font name of the text of the mark.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text of the mark.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text of the mark.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getHeight Method

Glossary Item Box

Gets the height of the mark's rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getText Method

Glossary Item Box

Gets the text of the note mark.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getTextColor Method

Glossary Item Box

Gets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

isFontPpmDisabled Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : isFontPpmDisabled Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean isFontPpmDisabled()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setFontDisablePpm Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setFontDisablePpm Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePpm(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text of the mark.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text of the mark.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text of the mark.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark's rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setText Method
value

Glossary Item Box

Ð«ets the text of the note mark.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setTextColor Method
value

Glossary Item Box

Sets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTNote Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTNote Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTNote Class
ImGearARTNote Members


%%PageItemTitle%%

ImGearARTPage Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPage Class

Glossary Item Box

Represents a collection of annotation groups.

This class provides methods and properties for accessing to annotation groups and individual marks on the page.

ImGearARTPage is completely independent from com.accusoft.imagegear.core.ImGearPage class and can be associated with one or more com.accusoft.imagegear.core.ImGearPage class objects.

Object Model

ImGearARTPage ClassIImGearRectangle InterfaceImGearARTGroupArray ClassIImGearOrientation InterfaceImGearARTMark Class

Syntax

public class ImGearARTPage
    extends com.accusoft.imagegear.display.ImGearAnnotationPage
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearAnnotationPage
com.accusoft.imagegear.art.ImGearARTPage

See Also

Reference

ImGearARTPage Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPage Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPage.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPage Constructor | Initializes a new instance of the ImGearARTPage class object.
Top

Public Fields

 | Name | Description
public Field | markAdded | Occurs when a mark is added.
public Field | markChanged | Occurs when a mark is changed.
public Field | markRemoved | Occurs when a mark is removed.
public Field | markSelectionChanged | Occurs when a mark's selection is changed.
public Field | markZOrderChanged | Occurs when a mark's Z-Order is changed.
Top

Public Methods

 | Name | Description
public Method | addMark | Overloaded. Adds the specified mark into the annotation page group specified by name.
public Method | applyToImage | Applies the encryption marks from the annotation page to the image.
public Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
public Method | copyMarks | Overloaded. Copies collection of specified marks to the Windows clipboard.
public Method | cutMarks | Overloaded. Cuts collection of specified marks from the annotation page to the Windows clipboard.
public Method | getBounds | Gets the bounding rectangle of the annotation page. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This is a rectangle that encloses all annotation marks on the page. This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this method is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used. The default value is null. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getGroups | Gets an array of annotation groups in the page. ImGearARTGroupArray class object. ImGearARTGroupArray
public Method | getMarkCount | Gets the marks count in the page. Integer value.
public Method | getMarkIDiterator | Returns an iterator over the mark IDs.
public Method | getOrientation | Gets the orientation of the annotation page layout. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle. com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes
public Method | getPasteCount | Gets the number of marks currently in the Windows clipboard. Integer value.
public Method | getStartIndex | Gets the start index of the marks enumeration on the page. Integer value.
public Method | hitTest | Returns the index of topmost annotation mark of a hit test.
public Method | iterator | Gets the page enumerator class.
public Method | markBringToFront | Overloaded. Moves the specified mark to the top of Z-Order.
public Method | markCopy | Overloaded. Copies the specified mark to the Windows clipboard.
public Method | markCut | Overloaded. Cuts the specified mark from the annotation page to the Windows clipboard.
public Method | markGet | Gets a mark by its ID.
public Method | markIsSelected | Overloaded. Checks if the specified mark is selected.
public Method | markIsValid | Overloaded. Checks if the mark is valid.
public Method | markRemove | Overloaded. Deletes the mark.
public Method | markSelect | Overloaded. Selects or deselects the specified mark.
public Method | markSendToBack | Overloaded. Moves the specified mark to the bottom of Z-Order.
public Method | markSetCoordType | Overloaded. Sets new type of the coordinates system for the specified mark.
public Method | pasteMarks | Pastes all marks from the Windows clipboard to the annotation page.
public Method | removeMarks | Overloaded. Deletes all marks from the annotation page.
public Method | selectMarks | Selects or deselects all marks in the annotation page.
public Method | setBounds | Sets the bounding rectangle of the annotation page. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This is a rectangle that encloses all annotation marks on the page. This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this property is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used. The default value is null. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | setCoordType | Sets new type of the coordinates system for the entire mark collection.
public Method | setOrientation | Sets the orientation of the annotation page layout. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle. com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes
public Method | setStartIndex | Sets the start index of the marks enumeration on the page. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onMarkAdded | Occurs when a mark is added.
protected Method | onMarkChanged | Occurs when a mark is changed.
protected Method | onMarkRemoved | Occurs when a mark is removed.
protected Method | onMarkSelectionChanged | Occurs when a mark's selection is changed.
protected Method | onMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top

See Also

Reference

ImGearARTPage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPage Constructor
com.accusoft.imagegear.art Package > ImGearARTPage Class : ImGearARTPage Constructor

Glossary Item Box

Initializes a new instance of the ImGearARTPage class object.

Syntax

public ImGearARTPage()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPage Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPage Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPage members.

Public Methods

 | Name | Description
public Method | addMark | Overloaded. Adds the specified mark into the annotation page group specified by name.
public Method | applyToImage | Applies the encryption marks from the annotation page to the image.
public Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems.
public Method | copyMarks | Overloaded. Copies collection of specified marks to the Windows clipboard.
public Method | cutMarks | Overloaded. Cuts collection of specified marks from the annotation page to the Windows clipboard.
public Method | getBounds | Gets the bounding rectangle of the annotation page. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This is a rectangle that encloses all annotation marks on the page. This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this method is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used. The default value is null. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getGroups | Gets an array of annotation groups in the page. ImGearARTGroupArray class object. ImGearARTGroupArray
public Method | getMarkCount | Gets the marks count in the page. Integer value.
public Method | getMarkIDiterator | Returns an iterator over the mark IDs.
public Method | getOrientation | Gets the orientation of the annotation page layout. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle. com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes
public Method | getPasteCount | Gets the number of marks currently in the Windows clipboard. Integer value.
public Method | getStartIndex | Gets the start index of the marks enumeration on the page. Integer value.
public Method | hitTest | Returns the index of topmost annotation mark of a hit test.
public Method | iterator | Gets the page enumerator class.
public Method | markBringToFront | Overloaded. Moves the specified mark to the top of Z-Order.
public Method | markCopy | Overloaded. Copies the specified mark to the Windows clipboard.
public Method | markCut | Overloaded. Cuts the specified mark from the annotation page to the Windows clipboard.
public Method | markGet | Gets a mark by its ID.
public Method | markIsSelected | Overloaded. Checks if the specified mark is selected.
public Method | markIsValid | Overloaded. Checks if the mark is valid.
public Method | markRemove | Overloaded. Deletes the mark.
public Method | markSelect | Overloaded. Selects or deselects the specified mark.
public Method | markSendToBack | Overloaded. Moves the specified mark to the bottom of Z-Order.
public Method | markSetCoordType | Overloaded. Sets new type of the coordinates system for the specified mark.
public Method | pasteMarks | Pastes all marks from the Windows clipboard to the annotation page.
public Method | removeMarks | Overloaded. Deletes all marks from the annotation page.
public Method | selectMarks | Selects or deselects all marks in the annotation page.
public Method | setBounds | Sets the bounding rectangle of the annotation page. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This is a rectangle that encloses all annotation marks on the page. This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this property is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used. The default value is null. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | setCoordType | Sets new type of the coordinates system for the entire mark collection.
public Method | setOrientation | Sets the orientation of the annotation page layout. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle. com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes
public Method | setStartIndex | Sets the start index of the marks enumeration on the page. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onMarkAdded | Occurs when a mark is added.
protected Method | onMarkChanged | Occurs when a mark is changed.
protected Method | onMarkRemoved | Occurs when a mark is removed.
protected Method | onMarkSelectionChanged | Occurs when a mark's selection is changed.
protected Method | onMarkZOrderChanged | Occurs when a mark's Z-Order is changed.
Top

See Also

Reference

ImGearARTPage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addMark Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : addMark Method

Glossary Item Box

Adds the specified mark into the annotation page group specified by name.

Overload List

Overload | Description
addMark(ImGearARTMark,ImGearARTCoordinatesType,String) | Adds the specified mark into the annotation page group specified by name.
addMark(ImGearARTMark,ImGearARTCoordinatesType,int) | Adds the specified mark into the annotation page group specified by index.
addMark(ImGearARTMark,ImGearARTCoordinatesType) | Adds the specified mark into default annotation page group.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

addMark(ImGearARTMark,ImGearARTCoordinatesType,String) Method
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPage Class > addMark Method : addMark(ImGearARTMark,ImGearARTCoordinatesType,String) Method
mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupName
Name of the group to add the mark to.

Glossary Item Box

Adds the specified mark into the annotation page group specified by name.

Syntax

public int addMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type,
   java.lang.String groupName
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupName
Name of the group to add the mark to.

Return Value

Integer value.

You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

ImGearARTMark ImGearARTCoordinatesType

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

addMark(ImGearARTMark,ImGearARTCoordinatesType,int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > addMark Method : addMark(ImGearARTMark,ImGearARTCoordinatesType,int) Method
mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupIndex
Index of the group to add the mark to.

Glossary Item Box

Adds the specified mark into the annotation page group specified by index.

Syntax

public int addMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type,
   int groupIndex
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.
groupIndex
Index of the group to add the mark to.

Return Value

Integer value.

You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

ImGearARTMark ImGearARTCoordinatesType

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

addMark(ImGearARTMark,ImGearARTCoordinatesType) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > addMark Method : addMark(ImGearARTMark,ImGearARTCoordinatesType) Method
mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.

Glossary Item Box

Adds the specified mark into default annotation page group.

Syntax

public int addMark(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type
)

Parameters

mark
Reference to the mark to add.
type
Type of the coordinate system the mark coordinates are specified in.

Return Value

Integer value.

You must specify the type of the mark's coordinate system. The mark will be drawn according to the type of its coordinate system.

ImGearARTMark ImGearARTCoordinatesType

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

applyToImage Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : applyToImage Method
image
Image page to apply the encryption marks to.

Glossary Item Box

Applies the encryption marks from the annotation page to the image.

Syntax

public void applyToImage(
   ImGearPage image
)

Parameters

image
Image page to apply the encryption marks to.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

convertCoordinates Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : convertCoordinates Method

Glossary Item Box

Translates coordinates between image and device coordinate systems.

Overload List

Overload | Description
convertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems.
convertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPage Class > convertCoordinates Method : convertCoordinates(IImGearScrollableView,ImGearPageDisplay,Graphics,ImGearCoordConvModes,ImGearArray) Method
pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
graphics
CSGraphics object used for drawing.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.

The conversion depends on mode parameter and taks into account the annotation page orientation.

com.accusoft.imagegear.display.IImGearScrollableViewT:com.accusoft.imagegear.display.ImGearCoordConvModes

Glossary Item Box

Translates coordinates between image and device coordinate systems.

Syntax

public void convertCoordinates(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay,
   java.awt.Graphics graphics,
   ImGearCoordConvModes mode,
   ImGearArray points
)

Parameters

pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
graphics
CSGraphics object used for drawing.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.

The conversion depends on mode parameter and taks into account the annotation page orientation.

com.accusoft.imagegear.display.IImGearScrollableViewT:com.accusoft.imagegear.display.ImGearCoordConvModes

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPage Class > convertCoordinates Method : convertCoordinates(IImGearScrollableView,IImGearPageDisplay,ImGearCoordConvModes,ImGearArray) Method
pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.

The conversion depends on mode parameter and taks into account the annotation page orientation.

com.accusoft.imagegear.display.IImGearScrollableViewT:com.accusoft.imagegear.display.ImGearCoordConvModes

Glossary Item Box

Translates coordinates between image and device coordinate systems.

Syntax

public void convertCoordinates(
   IImGearScrollableView pageView,
   IImGearPageDisplay pageDisplay,
   ImGearCoordConvModes mode,
   ImGearArray points
)

Parameters

pageView
IImGearScrollableView interface of the page view control.
pageDisplay
PageDisplay associated with the page view control.
mode
Translation mode, either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
points
Array of ImGearPoint or ImGearDoublePoint elements to convert.

The conversion depends on mode parameter and taks into account the annotation page orientation.

com.accusoft.imagegear.display.IImGearScrollableViewT:com.accusoft.imagegear.display.ImGearCoordConvModes

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

copyMarks Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : copyMarks Method

Glossary Item Box

Copies collection of specified marks to the Windows clipboard.

Overload List

Overload | Description
copyMarks(List<ImGearARTMark>) | Copies collection of specified marks to the Windows clipboard.
copyMarks(int[]) | Copies array of specified marks to the Windows clipboard.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

copyMarks(List<ImGearARTMark>) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > copyMarks Method : copyMarks(List<ImGearARTMark>) Method
marks
Collection of marks to copy.

Glossary Item Box

Copies collection of specified marks to the Windows clipboard.

Syntax

public void copyMarks(
   java.util.List<ImGearARTMark> marks
)

Parameters

marks
Collection of marks to copy.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

copyMarks(int[]) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > copyMarks Method : copyMarks(int[]) Method
marksIds
Array of mark IDs to copy.

Glossary Item Box

Copies array of specified marks to the Windows clipboard.

Syntax

public void copyMarks(
   int[] marksIds
)

Parameters

marksIds
Array of mark IDs to copy.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

cutMarks Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : cutMarks Method

Glossary Item Box

Cuts collection of specified marks from the annotation page to the Windows clipboard.

Overload List

Overload | Description
cutMarks(List<ImGearARTMark>) | Cuts collection of specified marks from the annotation page to the Windows clipboard.
cutMarks(int[]) | Cuts array of specified marks from the annotation page to the Windows clipboard.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

cutMarks(List<ImGearARTMark>) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > cutMarks Method : cutMarks(List<ImGearARTMark>) Method
marks
Collection of marks to cut.

Glossary Item Box

Cuts collection of specified marks from the annotation page to the Windows clipboard.

Syntax

public void cutMarks(
   java.util.List<ImGearARTMark> marks
)

Parameters

marks
Collection of marks to cut.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

cutMarks(int[]) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > cutMarks Method : cutMarks(int[]) Method
markIds
Array of mark IDs to cut.

Glossary Item Box

Cuts array of specified marks from the annotation page to the Windows clipboard.

Syntax

public void cutMarks(
   int[] markIds
)

Parameters

markIds
Array of mark IDs to cut.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getBounds Method

Glossary Item Box

Gets the bounding rectangle of the annotation page.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

This is a rectangle that encloses all annotation marks on the page.

This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this method is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used.

The default value is null.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public IImGearRectangle getBounds()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getGroups Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getGroups Method

Glossary Item Box

Gets an array of annotation groups in the page.

ImGearARTGroupArray class object. ImGearARTGroupArray

Syntax

public ImGearARTGroupArray getGroups()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getMarkCount Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getMarkCount Method

Glossary Item Box

Gets the marks count in the page.

Integer value.

Syntax

public int getMarkCount()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getMarkIDiterator Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getMarkIDiterator Method

Glossary Item Box

Returns an iterator over the mark IDs.

Syntax

public java.util.Iterator<int> getMarkIDiterator()

Return Value

An iterator over the mark IDs.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getOrientation Method

Glossary Item Box

Gets the orientation of the annotation page layout.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle.

com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes

Syntax

public IImGearOrientation getOrientation()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getPasteCount Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getPasteCount Method

Glossary Item Box

Gets the number of marks currently in the Windows clipboard.

Integer value.

Syntax

public int getPasteCount()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

getStartIndex Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : getStartIndex Method

Glossary Item Box

Gets the start index of the marks enumeration on the page.

Integer value.

Syntax

public int getStartIndex()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

hitTest Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : hitTest Method
devicePoint
Screen point to test.
pageView
PageView control that contains the marks.
pageDisplay
PageDisplay associated with PageView control.
graphics
System graphics.
offsetLeft
Offset from left.
offsetTop
Offset from top.

Glossary Item Box

Returns the index of topmost annotation mark of a hit test.

Syntax

public int hitTest(
   ImGearPoint devicePoint,
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay,
   java.awt.Graphics graphics,
   int offsetLeft,
   int offsetTop
)

Parameters

devicePoint
Screen point to test.
pageView
PageView control that contains the marks.
pageDisplay
PageDisplay associated with PageView control.
graphics
System graphics.
offsetLeft
Offset from left.
offsetTop
Offset from top.

Return Value

Integer value.

Returns the index of the mark located at the screen position [x, y]. If there are no marks at [x,y], the return value from this method is -1.

com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.display.ImGearPageDisplay

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : iterator Method

Glossary Item Box

Gets the page enumerator class.

Syntax

public java.util.Iterator<ImGearARTMark> iterator()

Return Value

ImGearARTPageEnumerator class object. ImGearARTPageEnumerator

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markBringToFront Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markBringToFront Method

Glossary Item Box

Moves the specified mark to the top of Z-Order.

Overload List

Overload | Description
markBringToFront(ImGearARTMark) | Moves the specified mark to the top of Z-Order.
markBringToFront(int) | Moves the mark specified by ID to the top of Z-Order.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markBringToFront(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markBringToFront Method : markBringToFront(ImGearARTMark) Method
mark
Mark to move. ImGearARTMark

Glossary Item Box

Moves the specified mark to the top of Z-Order.

Syntax

public void markBringToFront(
   ImGearARTMark mark
)

Parameters

mark
Mark to move. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markBringToFront(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markBringToFront Method : markBringToFront(int) Method
markId
ID of the mark to move.

Glossary Item Box

Moves the mark specified by ID to the top of Z-Order.

Syntax

public void markBringToFront(
   int markId
)

Parameters

markId
ID of the mark to move.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markCopy Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markCopy Method

Glossary Item Box

Copies the specified mark to the Windows clipboard.

Overload List

Overload | Description
markCopy(ImGearARTMark) | Copies the specified mark to the Windows clipboard.
markCopy(int) | Copies the specified mark to the Windows clipboard.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markCopy(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markCopy Method : markCopy(ImGearARTMark) Method
mark
Mark to copy. ImGearARTMark

Glossary Item Box

Copies the specified mark to the Windows clipboard.

Syntax

public void markCopy(
   ImGearARTMark mark
)

Parameters

mark
Mark to copy. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markCopy(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markCopy Method : markCopy(int) Method
markId
ID of the mark to copy.

Glossary Item Box

Copies the specified mark to the Windows clipboard.

Syntax

public void markCopy(
   int markId
)

Parameters

markId
ID of the mark to copy.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markCut Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markCut Method

Glossary Item Box

Cuts the specified mark from the annotation page to the Windows clipboard.

Overload List

Overload | Description
markCut(ImGearARTMark) | Cuts the specified mark from the annotation page to the Windows clipboard.
markCut(int) | Cuts the mark specified by ID from the annotation page to the Windows clipboard.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markCut(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markCut Method : markCut(ImGearARTMark) Method
mark
Mark to cut. ImGearARTMark

Glossary Item Box

Cuts the specified mark from the annotation page to the Windows clipboard.

Syntax

public void markCut(
   ImGearARTMark mark
)

Parameters

mark
Mark to cut. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markCut(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markCut Method : markCut(int) Method
markId
ID of the mark to cut.

Glossary Item Box

Cuts the mark specified by ID from the annotation page to the Windows clipboard.

Syntax

public void markCut(
   int markId
)

Parameters

markId
ID of the mark to cut.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markGet Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markGet Method
markId
Mark's ID.

Glossary Item Box

Gets a mark by its ID.

Syntax

public ImGearARTMark markGet(
   int markId
)

Parameters

markId
Mark's ID.

Return Value

ImGearARTMark class object. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markIsSelected Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markIsSelected Method

Glossary Item Box

Checks if the specified mark is selected.

Overload List

Overload | Description
markIsSelected(ImGearARTMark) | Checks if the specified mark is selected.
markIsSelected(int) | Checks if the mark specified by ID is selected.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markIsSelected(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markIsSelected Method : markIsSelected(ImGearARTMark) Method
mark
The mark to check.

Glossary Item Box

Checks if the specified mark is selected.

Syntax

public boolean markIsSelected(
   ImGearARTMark mark
)

Parameters

mark
The mark to check.

Return Value

Returns true if the mark is selected, false - otherwise. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markIsSelected(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markIsSelected Method : markIsSelected(int) Method
markId
ID of the mark to check.

Glossary Item Box

Checks if the mark specified by ID is selected.

Syntax

public boolean markIsSelected(
   int markId
)

Parameters

markId
ID of the mark to check.

Return Value

Returns true if the mark is selected, false - otherwise.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markIsValid Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markIsValid Method

Glossary Item Box

Checks if the mark is valid.

Overload List

Overload | Description
markIsValid(int) | Checks if the mark is valid.
markIsValid(ImGearARTMark) | Checks if the mark is valid.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markIsValid(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markIsValid Method : markIsValid(int) Method
markId
ID of the mark to check.

Glossary Item Box

Checks if the mark is valid.

Syntax

public boolean markIsValid(
   int markId
)

Parameters

markId
ID of the mark to check.

Return Value

Returns true if the mark is valid, false - otherwise.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markIsValid(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markIsValid Method : markIsValid(ImGearARTMark) Method
mark
Mark to check.

Glossary Item Box

Checks if the mark is valid.

Syntax

public boolean markIsValid(
   ImGearARTMark mark
)

Parameters

mark
Mark to check.

Return Value

Returns true if the mark is valid, false - otherwise.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markRemove Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markRemove Method

Glossary Item Box

Deletes the mark.

Overload List

Overload | Description
markRemove(int) | Deletes the mark.
markRemove(ImGearARTMark) | Deletes the mark.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markRemove(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markRemove Method : markRemove(int) Method
markId
ID of the mark to delete.

Glossary Item Box

Deletes the mark.

Syntax

public void markRemove(
   int markId
)

Parameters

markId
ID of the mark to delete.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markRemove(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markRemove Method : markRemove(ImGearARTMark) Method
mark
Mark to delete. ImGearARTMark

Glossary Item Box

Deletes the mark.

Syntax

public void markRemove(
   ImGearARTMark mark
)

Parameters

mark
Mark to delete. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSelect Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markSelect Method

Glossary Item Box

Selects or deselects the specified mark.

Overload List

Overload | Description
markSelect(int,boolean) | Selects or deselects the specified mark.
markSelect(ImGearARTMark,boolean) | Selects or deselects the specified mark.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markSelect(int,boolean) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSelect Method : markSelect(int,boolean) Method
markId
Mark ID to select or deselect.
state
Pass true to select the mark, false to deselect.

Glossary Item Box

Selects or deselects the specified mark.

Syntax

public void markSelect(
   int markId,
   boolean state
)

Parameters

markId
Mark ID to select or deselect.
state
Pass true to select the mark, false to deselect.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSelect(ImGearARTMark,boolean) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSelect Method : markSelect(ImGearARTMark,boolean) Method
mark
Mark to select or deselect.
state
Pass true to select the mark, false to deselect. ImGearARTMark

Glossary Item Box

Selects or deselects the specified mark.

Syntax

public void markSelect(
   ImGearARTMark mark,
   boolean state
)

Parameters

mark
Mark to select or deselect.
state
Pass true to select the mark, false to deselect. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSendToBack Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markSendToBack Method

Glossary Item Box

Moves the specified mark to the bottom of Z-Order.

Overload List

Overload | Description
markSendToBack(ImGearARTMark) | Moves the specified mark to the bottom of Z-Order.
markSendToBack(int) | Moves the mark specified by ID to the bottom of Z-Order.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markSendToBack(ImGearARTMark) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSendToBack Method : markSendToBack(ImGearARTMark) Method
mark
Mark to move. ImGearARTMark

Glossary Item Box

Moves the specified mark to the bottom of Z-Order.

Syntax

public void markSendToBack(
   ImGearARTMark mark
)

Parameters

mark
Mark to move. ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSendToBack(int) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSendToBack Method : markSendToBack(int) Method
markId
ID of the mark to move.

Glossary Item Box

Moves the mark specified by ID to the bottom of Z-Order.

Syntax

public void markSendToBack(
   int markId
)

Parameters

markId
ID of the mark to move.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSetCoordType Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : markSetCoordType Method

Glossary Item Box

Sets new type of the coordinates system for the specified mark.

Overload List

Overload | Description
markSetCoordType(int,ImGearARTCoordinatesType) | Sets new type of the coordinates system for the specified mark.
markSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) | Sets new type of the coordinates system for the specified mark.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markSetCoordType(int,ImGearARTCoordinatesType) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSetCoordType Method : markSetCoordType(int,ImGearARTCoordinatesType) Method
markId
Index of the mark whose coordinates type is changed.
type
New type of the coordinate system. ImGearARTCoordinatesType

Glossary Item Box

Sets new type of the coordinates system for the specified mark.

Syntax

public void markSetCoordType(
   int markId,
   ImGearARTCoordinatesType type
)

Parameters

markId
Index of the mark whose coordinates type is changed.
type
New type of the coordinate system. ImGearARTCoordinatesType

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

markSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) Method
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPage Class > markSetCoordType Method : markSetCoordType(ImGearARTMark,ImGearARTCoordinatesType) Method
mark
Mark whose coordinates type is changed.
type
New type of the coordinate system. ImGearARTCoordinatesType ImGearARTMark

Glossary Item Box

Sets new type of the coordinates system for the specified mark.

Syntax

public void markSetCoordType(
   ImGearARTMark mark,
   ImGearARTCoordinatesType type
)

Parameters

mark
Mark whose coordinates type is changed.
type
New type of the coordinate system. ImGearARTCoordinatesType ImGearARTMark

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

onMarkAdded Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : onMarkAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a mark is added.

Syntax

protected void onMarkAdded(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

onMarkChanged Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : onMarkChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a mark is changed.

Syntax

protected void onMarkChanged(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

onMarkRemoved Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : onMarkRemoved Method
e
Event arguments.

Glossary Item Box

Occurs when a mark is removed.

Syntax

protected void onMarkRemoved(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

onMarkSelectionChanged Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : onMarkSelectionChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a mark's selection is changed.

Syntax

protected void onMarkSelectionChanged(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

onMarkZOrderChanged Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : onMarkZOrderChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a mark's Z-Order is changed.

Syntax

protected void onMarkZOrderChanged(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

pasteMarks Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : pasteMarks Method

Glossary Item Box

Pastes all marks from the Windows clipboard to the annotation page.

Syntax

public void pasteMarks()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

removeMarks Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : removeMarks Method

Glossary Item Box

Deletes all marks from the annotation page.

Overload List

Overload | Description
removeMarks() | Deletes all marks from the annotation page.
removeMarks(ArrayList<ImGearARTMark>) | Deletes collection of specified marks from the annotation page.
removeMarks(int[]) | Deletes array of specified marks from the annotation page.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

removeMarks() Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > removeMarks Method : removeMarks() Method

Glossary Item Box

Deletes all marks from the annotation page.

Syntax

public void removeMarks()

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

removeMarks(ArrayList<ImGearARTMark>) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > removeMarks Method : removeMarks(ArrayList<ImGearARTMark>) Method
marks
Collection of marks to delete.

Glossary Item Box

Deletes collection of specified marks from the annotation page.

Syntax

public void removeMarks(
   java.util.ArrayList<ImGearARTMark> marks
)

Parameters

marks
Collection of marks to delete.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

removeMarks(int[]) Method
com.accusoft.imagegear.art Package > ImGearARTPage Class > removeMarks Method : removeMarks(int[]) Method
marksIds
Array of mark IDs to delete.

Glossary Item Box

Deletes array of specified marks from the annotation page.

Syntax

public void removeMarks(
   int[] marksIds
)

Parameters

marksIds
Array of mark IDs to delete.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members
Overload List


%%PageItemTitle%%

selectMarks Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : selectMarks Method
state
Pass true to select all marks in the page, false to deselect.

Glossary Item Box

Selects or deselects all marks in the annotation page.

Syntax

public void selectMarks(
   boolean state
)

Parameters

state
Pass true to select all marks in the page, false to deselect.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

setBounds Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : setBounds Method
value

Glossary Item Box

Sets the bounding rectangle of the annotation page.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

This is a rectangle that encloses all annotation marks on the page.

This method can be used if you want to change the default bounding rectangle or when the marks' coordinates are specified in device units. If this property is set to null and ART page is associated with com.accusoft.imagegear.core.ImGearPage class the com.accusoft.imagegear.core.ImGearPage class's rectangle is used.

The default value is null.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public void setBounds(
   IImGearRectangle value
)

Parameters

value

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

setCoordType Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : setCoordType Method
type
New type of the coordinate system. ImGearARTCoordinatesType

Glossary Item Box

Sets new type of the coordinates system for the entire mark collection.

Syntax

public void setCoordType(
   ImGearARTCoordinatesType type
)

Parameters

type
New type of the coordinate system. ImGearARTCoordinatesType

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : setOrientation Method
value

Glossary Item Box

Sets the orientation of the annotation page layout.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT. 1 for XML objects. See getBounds method for more information about the page layout rectangle.

com.accusoft.imagegear.core.ImGearOrientation com.accusoft.imagegear.core.ImGearOrientationModes

Syntax

public void setOrientation(
   IImGearOrientation value
)

Parameters

value

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

setStartIndex Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : setStartIndex Method
value

Glossary Item Box

Sets the start index of the marks enumeration on the page.

Integer value.

Syntax

public void setStartIndex(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPage Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPage Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPage Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPage members.

Public Fields

 | Name | Description
public Field | markAdded | Occurs when a mark is added.
public Field | markChanged | Occurs when a mark is changed.
public Field | markRemoved | Occurs when a mark is removed.
public Field | markSelectionChanged | Occurs when a mark's selection is changed.
public Field | markZOrderChanged | Occurs when a mark's Z-Order is changed.
Top

See Also

Reference

ImGearARTPage Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

markAdded Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : markAdded Field

Glossary Item Box

Occurs when a mark is added.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> markAdded

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markChanged Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : markChanged Field

Glossary Item Box

Occurs when a mark is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> markChanged

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markRemoved Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : markRemoved Field

Glossary Item Box

Occurs when a mark is removed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> markRemoved

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markSelectionChanged Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : markSelectionChanged Field

Glossary Item Box

Occurs when a mark's selection is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> markSelectionChanged

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

markZOrderChanged Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : markZOrderChanged Field

Glossary Item Box

Occurs when a mark's Z-Order is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> markZOrderChanged

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPage Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPage Class
ImGearARTPage Members


%%PageItemTitle%%

ImGearARTPageEnumerator Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPageEnumerator Class

Glossary Item Box

Provides marks iteration capabilities over the annotation page.

Page enumerator class is used for ImGearARTPage class to iterate through the collection of marks by using foreach statement.

Object Model

ImGearARTPageEnumerator ClassImGearARTMark Class

Syntax

public class ImGearARTPageEnumerator
    extends Object
    implements java.util.Iterator

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTPageEnumerator

See Also

Reference

ImGearARTPageEnumerator Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPageEnumerator Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPageEnumerator Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPageEnumerator.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPageEnumerator Constructor | Initializes a new instance of the ImGearARTPageEnumerator class object.
Top

Public Methods

 | Name | Description
public Method | hasNext | Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)
public Method | next | Gets the next element in the collection. ImGearARTMark class object. ImGearARTMark
public Method | remove | This is a read only enumerator, and remove will only call an com.accusoft.imagegear.core.IImGearAddWarning instance if it had been "registered" via com.accusoft.imagegear.core.ImGearWarning.setAddWarning.
Top

See Also

Reference

ImGearARTPageEnumerator Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPageEnumerator Constructor
com.accusoft.imagegear.art Package > ImGearARTPageEnumerator Class : ImGearARTPageEnumerator Constructor
artPage
Annotation page to enumerate the marks from. ImGearARTPage

Glossary Item Box

Initializes a new instance of the ImGearARTPageEnumerator class object.

Syntax

public ImGearARTPageEnumerator(
   ImGearARTPage artPage
)

Parameters

artPage
Annotation page to enumerate the marks from. ImGearARTPage

See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPageEnumerator Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPageEnumerator Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPageEnumerator members.

Public Methods

 | Name | Description
public Method | hasNext | Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)
public Method | next | Gets the next element in the collection. ImGearARTMark class object. ImGearARTMark
public Method | remove | This is a read only enumerator, and remove will only call an com.accusoft.imagegear.core.IImGearAddWarning instance if it had been "registered" via com.accusoft.imagegear.core.ImGearWarning.setAddWarning.
Top

See Also

Reference

ImGearARTPageEnumerator Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

hasNext Method
com.accusoft.imagegear.art Package > ImGearARTPageEnumerator Class : hasNext Method

Glossary Item Box

Returns true if the iteration has more elements. (In other words, returns true if next would return an element rather than throwing an exception.)

Syntax

public boolean hasNext()

Return Value

true if the iterator has more elements.

See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members


%%PageItemTitle%%

next Method
com.accusoft.imagegear.art Package > ImGearARTPageEnumerator Class : next Method

Glossary Item Box

Gets the next element in the collection.

ImGearARTMark class object. ImGearARTMark

Syntax

public ImGearARTMark next()

See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.art Package > ImGearARTPageEnumerator Class : remove Method

Glossary Item Box

This is a read only enumerator, and remove will only call an com.accusoft.imagegear.core.IImGearAddWarning instance if it had been "registered" via com.accusoft.imagegear.core.ImGearWarning.setAddWarning.

Syntax

public void remove()

See Also

Reference

ImGearARTPageEnumerator Class
ImGearARTPageEnumerator Members


%%PageItemTitle%%

ImGearARTPin Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPin Class

Glossary Item Box

Provides text mark's pin attirbutes.

Object Model

ImGearARTPin ClassImGearARTPinAlignment EnumerationIImGearRGBQuad Interface

Syntax

public class ImGearARTPin
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTPin

See Also

Reference

ImGearARTPin Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPin Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPin Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPin.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPin Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getAlignment | Gets the alignment of the pin icon. ImGearARTPinAlignment enumeration value. The default value is ImGearARTPinAlignment.LEFT_TOP. ImGearARTPinAlignment
public Method | getColor | Gets the color of the pin icon. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setAlignment | Sets the alignment of the pin icon. ImGearARTPinAlignment enumeration value. The default value is ImGearARTPinAlignment.LEFT_TOP. ImGearARTPinAlignment
public Method | setColor | Sets the color of the pin icon. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTPin Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPin Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPin Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPin members.

See Also

Reference

ImGearARTPin Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPin Constructor
com.accusoft.imagegear.art Package > ImGearARTPin Class : ImGearARTPin Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPin Constructor(IImGearRGBQuad) | Initializes a new instance of the ImGearARTPin class object.
ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment) | Initializes a new instance of the ImGearARTPin class object.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

ImGearARTPin Constructor(IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPin Class > ImGearARTPin Constructor : ImGearARTPin Constructor(IImGearRGBQuad)
color
Color of the pin icon.

com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPin class object.

Syntax

public ImGearARTPin(
   IImGearRGBQuad color
)

Parameters

color
Color of the pin icon.

com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List


%%PageItemTitle%%

ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPin Class > ImGearARTPin Constructor : ImGearARTPin Constructor(IImGearRGBQuad,ImGearARTPinAlignment)
color
Color of the pin icon.
alignment
Pin icon alignment.

com.accusoft.imagegear.core.ImGearRGBQuad ImGearARTPinAlignment

Glossary Item Box

Initializes a new instance of the ImGearARTPin class object.

Syntax

public ImGearARTPin(
   IImGearRGBQuad color,
   ImGearARTPinAlignment alignment
)

Parameters

color
Color of the pin icon.
alignment
Pin icon alignment.

com.accusoft.imagegear.core.ImGearRGBQuad ImGearARTPinAlignment

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPin Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPin Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPin members.

Public Methods

 | Name | Description
public Method | getAlignment | Gets the alignment of the pin icon. ImGearARTPinAlignment enumeration value. The default value is ImGearARTPinAlignment.LEFT_TOP. ImGearARTPinAlignment
public Method | getColor | Gets the color of the pin icon. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setAlignment | Sets the alignment of the pin icon. ImGearARTPinAlignment enumeration value. The default value is ImGearARTPinAlignment.LEFT_TOP. ImGearARTPinAlignment
public Method | setColor | Sets the color of the pin icon. com.accusoft.imagegear.core.ImGearRGBQuad structure object. com.accusoft.imagegear.core.ImGearRGBQuad
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearARTPin Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAlignment Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : getAlignment Method

Glossary Item Box

Gets the alignment of the pin icon.

ImGearARTPinAlignment enumeration value.

The default value is ImGearARTPinAlignment.LEFT_TOP.

ImGearARTPinAlignment

Syntax

public ImGearARTPinAlignment getAlignment()

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : getColor Method

Glossary Item Box

Gets the color of the pin icon.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

setAlignment Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : setAlignment Method
value

Glossary Item Box

Sets the alignment of the pin icon.

ImGearARTPinAlignment enumeration value.

The default value is ImGearARTPinAlignment.LEFT_TOP.

ImGearARTPinAlignment

Syntax

public void setAlignment(
   ImGearARTPinAlignment value
)

Parameters

value

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : setColor Method
value

Glossary Item Box

Sets the color of the pin icon.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPin Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPin Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPin Class
ImGearARTPin Members


%%PageItemTitle%%

ImGearARTPinUpText Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPinUpText Class

Glossary Item Box

Represents legacy ART Pin-Up-Text mark.

Object Model

ImGearARTPinUpText ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTPinUpText
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTPinUpText

See Also

Reference

ImGearARTPinUpText Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPinUpText Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPinUpText Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPinUpText.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPinUpText Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text font. String value.
public Method | getFontSize | Gets the font pointSize of the text font. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getPinColor | Gets the pin color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getText | Gets the text of the mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. The color of the mark's text.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text font. String value.
public Method | setFontSize | Sets the font pointSize of the text font. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setPinColor | Sets the pin color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setText | Sets the text of the mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. The color of the mark's text.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark rectangle. Integer value.
Top

See Also

Reference

ImGearARTPinUpText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPinUpText Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPinUpText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPinUpText members.

See Also

Reference

ImGearARTPinUpText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPinUpText Constructor
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : ImGearARTPinUpText Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPinUpText class object.
ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPinUpText class object.

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class > ImGearARTPinUpText Constructor : ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad)
rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPinUpText class object.

Syntax

public ImGearARTPinUpText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor
)

Parameters

rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Overload List


%%PageItemTitle%%

ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class > ImGearARTPinUpText Constructor : ImGearARTPinUpText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,IImGearRGBQuad)
rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color.
fontName
The mark's text font name.
fontSize
The mark's text font pointSize.
fontStyle
The mark's text font style.
pinColor
The mark's pin color. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTPinUpText class object.

Syntax

public ImGearARTPinUpText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle,
   IImGearRGBQuad pinColor
)

Parameters

rect
Rectangle of the mark.
text
The mark's text string.
textColor
The mark's text color.
fontName
The mark's text font name.
fontSize
The mark's text font pointSize.
fontStyle
The mark's text font style.
pinColor
The mark's pin color. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPinUpText Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPinUpText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPinUpText members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text font. String value.
public Method | getFontSize | Gets the font pointSize of the text font. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getPinColor | Gets the pin color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getText | Gets the text of the mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. The color of the mark's text.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text font. String value.
public Method | setFontSize | Sets the font pointSize of the text font. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setPinColor | Sets the pin color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setText | Sets the text of the mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. The color of the mark's text.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark rectangle. Integer value.
Top

See Also

Reference

ImGearARTPinUpText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getHeight Method

Glossary Item Box

Gets the height of the mark's rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getPinColor Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getPinColor Method

Glossary Item Box

Gets the pin color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getPinColor()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getText Method

Glossary Item Box

Gets the text of the mark.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getTextColor Method

Glossary Item Box

Gets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

The color of the mark's text.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark's rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setPinColor Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setPinColor Method
value

Glossary Item Box

Sets the pin color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setPinColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setText Method
value

Glossary Item Box

Sets the text of the mark.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setTextColor Method
value

Glossary Item Box

Sets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

The color of the mark's text.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPinUpText Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPinUpText Class
ImGearARTPinUpText Members


%%PageItemTitle%%

ImGearARTPoint Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPoint Class

Glossary Item Box

Represents ART Point mark.

Object Model

ImGearARTPoint ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTPoint
    extends ImGearARTMark
    implements IImGearARTPoint

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTPoint

See Also

Reference

ImGearARTPoint Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPoint Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPoint Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPoint.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPoint Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure.
public Method | getOpacity | Gets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure.
public Method | setOpacity | Ð«ets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the mark. Integer value.
Top

See Also

Reference

ImGearARTPoint Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPoint Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPoint Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPoint members.

See Also

Reference

ImGearARTPoint Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPoint Constructor
com.accusoft.imagegear.art Package > ImGearARTPoint Class : ImGearARTPoint Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTPoint class object.
ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,int,int) | Initializes a new instance of the ImGearARTPoint class object.

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPoint Class > ImGearARTPoint Constructor : ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad)
point
The point mark.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPoint class object.

Syntax

public ImGearARTPoint(
   IImGearPoint point,
   IImGearRGBQuad color
)

Parameters

point
The point mark.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Overload List


%%PageItemTitle%%

ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPoint Class > ImGearARTPoint Constructor : ImGearARTPoint Constructor(IImGearPoint,IImGearRGBQuad,int,int)
point
The point mark.
color
Color of the mark.
width
Width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPoint class object.

Syntax

public ImGearARTPoint(
   IImGearPoint point,
   IImGearRGBQuad color,
   int width,
   int opacity
)

Parameters

point
The point mark.
color
Color of the mark.
width
Width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPoint Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPoint Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPoint members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure.
public Method | getOpacity | Gets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | getX | Gets the X coordinate of the mark. Integer value.
public Method | getY | Gets the Y coordinate of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure.
public Method | setOpacity | Ð«ets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
public Method | setX | Sets the X coordinate of the mark. Integer value.
public Method | setY | Sets the Y coordinate of the mark. Integer value.
Top

See Also

Reference

ImGearARTPoint Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Any integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getX Method

Glossary Item Box

Gets the X coordinate of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : getY Method

Glossary Item Box

Gets the Y coordinate of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setOpacity Method
value

Glossary Item Box

Ð«ets the opacity of the mark.

Any integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPoint Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPoint Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPoint Class
ImGearARTPoint Members


%%PageItemTitle%%

ImGearARTPolygon Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolygon Class

Glossary Item Box

Represents ART Polygon mark.

ImGearARTMark

Object Model

ImGearARTPolygon ClassImGearARTMark ClassImGearARTMark ClassImGearARTBorder ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTPolygon
    extends ImGearARTMark
    implements IImGearARTPolygon

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTPolygon

See Also

Reference

ImGearARTPolygon Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPolygon Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolygon Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPolygon.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPolygon Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getNumberOfPoints | Gets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getOpacity | Gets the mark opacity. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setNumberOfPoints | Sets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setOpacity | Sets the mark opacity. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPolygon Constructor
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : ImGearARTPolygon Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolygon class object.
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int) | Initializes a new instance of the ImGearARTPolygon class object.
ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int) | Initializes a new instance of the ImGearARTPolygon class object.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad)
points
The mark's points.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPolygon class object.

Syntax

public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor
)

Parameters

points
The mark's points.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int)
points
The mark's points.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTPolygon class object.

Syntax

public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

points
The mark's points.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List


%%PageItemTitle%%

ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolygon Class > ImGearARTPolygon Constructor : ImGearARTPolygon Constructor(ImGearPoint[],IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
points
The mark's points.
fillColor
Fill color of the mark.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTPolygon class object.

Syntax

public ImGearARTPolygon(
   ImGearPoint[] points,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

points
The mark's points.
fillColor
Fill color of the mark.
borderColor
The border color of the mark.
borderStyle
The border style of the mark.
borderWidth
The border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPolygon Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolygon members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getNumberOfPoints | Gets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getOpacity | Gets the mark opacity. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setNumberOfPoints | Sets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | setOpacity | Sets the mark opacity. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object.

Syntax

public ImGearARTBorder getBorder()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of points on the mark.

Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getOpacity Method

Glossary Item Box

Gets the mark opacity.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getPoint Method
index
The index of the point to get.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
The index of the point to get.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

onPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : onPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void onPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

onPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : onPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void onPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

onPointsRemoved Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : onPointsRemoved Method
e
Event arguments.

Glossary Item Box

Occurs when points are removed.

Syntax

protected void onPointsRemoved(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

removePoints Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : removePoints Method
index
The index of the first point to remove.
count
The number of points to remove.

Glossary Item Box

Removes the specified number of points, starting at the specified index.

An error will occur if the specified index or specified number of points to remove is out of range.

Syntax

public void removePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setBorder Method
value

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object.

Syntax

public void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of points on the mark.

Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setOpacity Method
value

Glossary Item Box

Sets the mark opacity.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPolygon Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolygon members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolygon Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

pointsRemoved Field
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : pointsRemoved Field

Glossary Item Box

Occurs when points are removed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> pointsRemoved

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPolygon Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPolygon Class
ImGearARTPolygon Members


%%PageItemTitle%%

ImGearARTPolyline Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyline Class

Glossary Item Box

Represents ART Polyline mark.

Object Model

ImGearARTPolyline ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearARTLineHeadType EnumerationIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTLineHeadType EnumerationImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTPolyline
    extends ImGearARTMark
    implements IImGearARTPolyline

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTPolyline

See Also

Reference

ImGearARTPolyline Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPolyline Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyline Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPolyline.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPolyline Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndHeadAngle | Gets the end head angle of the mark. Integer value.
public Method | getEndHeadLength | Gets the end head length of the mark. Integer value.
public Method | getEndHeadType | Gets the end head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStartHeadAngle | Gets the start head angle of the mark. Integer value.
public Method | getStartHeadLength | Gets the start head length of the mark. Integer value.
public Method | getStartHeadType | Gets the start head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | isClosed | Gets a value indicating whether the polyline is closed. Boolean value. The default value is false.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setClosed | Sets a value indicating whether the polyline is closed. Boolean value. The default value is false.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setEndHeadAngle | Sets the end head angle of the mark. Integer value.
public Method | setEndHeadLength | Sets the end head length of the mark. Integer value.
public Method | setEndHeadType | Sets the end head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setStartHeadAngle | Sets the start head angle of the mark. Integer value.
public Method | setStartHeadLength | Sets the start head length of the mark. Integer value.
public Method | setStartHeadType | Sets the start head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolyline Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPolyline Constructor
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : ImGearARTPolyline Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolyline class object.
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean) | Initializes a new instance of the ImGearARTPolyline class object.
ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int) | Initializes a new instance of the ImGearARTPolyline class object.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad)
points
The mark's points.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPolyline class object.

Syntax

public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color
)

Parameters

points
The mark's points.
color
Color of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean)
points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTPolyline class object.

Syntax

public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   boolean isClosed
)

Parameters

points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List


%%PageItemTitle%%

ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyline Class > ImGearARTPolyline Constructor : ImGearARTPolyline Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,boolean,IImGearRGBQuad,ImGearARTLineHeadType,int,int,ImGearARTLineHeadType,int,int)
points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not.
headFillColor
Fill color of the line's head.
startHeadType
Start head type.
startHeadAngle
Start head angle.
startHeadLength
Start head length.
endHeadType
End head type.
endHeadAngle
End head angle.
endHeadLength
End head length. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTLineHeadType

Glossary Item Box

Initializes a new instance of the ImGearARTPolyline class object.

Syntax

public ImGearARTPolyline(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   boolean isClosed,
   IImGearRGBQuad headFillColor,
   ImGearARTLineHeadType startHeadType,
   int startHeadAngle,
   int startHeadLength,
   ImGearARTLineHeadType endHeadType,
   int endHeadAngle,
   int endHeadLength
)

Parameters

points
The mark's points.
color
Color of the mark.
style
The line style.
width
The line width.
opacity
Opacity of the mark.
isClosed
Specifies whether the line is closed or not.
headFillColor
Fill color of the line's head.
startHeadType
Start head type.
startHeadAngle
Start head angle.
startHeadLength
Start head length.
endHeadType
End head type.
endHeadAngle
End head angle.
endHeadLength
End head length. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTLineHeadType

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPolyline Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyline Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolyline members.

Public Methods

 | Name | Description
public Method | addPoint | Adds the specified point.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndHeadAngle | Gets the end head angle of the mark. Integer value.
public Method | getEndHeadLength | Gets the end head length of the mark. Integer value.
public Method | getEndHeadType | Gets the end head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPoint | Gets mark's point with the specified index.
public Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStartHeadAngle | Gets the start head angle of the mark. Integer value.
public Method | getStartHeadLength | Gets the start head length of the mark. Integer value.
public Method | getStartHeadType | Gets the start head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark. Integer value.
public Method | isClosed | Gets a value indicating whether the polyline is closed. Boolean value. The default value is false.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | removePoints | Removes the specified number of points, starting at the specified index. An error will occur if the specified index or specified number of points to remove is out of range.
public Method | setClosed | Sets a value indicating whether the polyline is closed. Boolean value. The default value is false.
public Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setEndHeadAngle | Sets the end head angle of the mark. Integer value.
public Method | setEndHeadLength | Sets the end head length of the mark. Integer value.
public Method | setEndHeadType | Sets the end head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPoint | Sets mark's point at the specified index.
public Method | setStartHeadAngle | Sets the start head angle of the mark. Integer value.
public Method | setStartHeadLength | Sets the start head length of the mark. Integer value.
public Method | setStartHeadType | Sets the start head type of the mark. ImGearARTLineHeadType enumeration value.
public Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark. Integer value.
Top

Protected Methods

 | Name | Description
protected Method | onPointAdded | Occurs when a point is added to the mark.
protected Method | onPointChanged | Occurs when a point is changed.
protected Method | onPointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolyline Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

addPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : addPoint Method
point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Adds the specified point.

Syntax

public void addPoint(
   ImGearPoint point
)

Parameters

point
The point to add. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getEndHeadAngle Method

Glossary Item Box

Gets the end head angle of the mark.

Integer value.

Syntax

public int getEndHeadAngle()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getEndHeadLength Method

Glossary Item Box

Gets the end head length of the mark.

Integer value.

Syntax

public int getEndHeadLength()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadType Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getEndHeadType Method

Glossary Item Box

Gets the end head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

public ImGearARTLineHeadType getEndHeadType()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getHeadFillColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getHeadFillColor Method

Glossary Item Box

Gets the fill color of the line's head.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getHeadFillColor()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getPoint Method
index
Index of the point.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getStartHeadAngle Method

Glossary Item Box

Gets the start head angle of the mark.

Integer value.

Syntax

public int getStartHeadAngle()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getStartHeadLength Method

Glossary Item Box

Gets the start head length of the mark.

Integer value.

Syntax

public int getStartHeadLength()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadType Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getStartHeadType Method

Glossary Item Box

Gets the start head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

public ImGearARTLineHeadType getStartHeadType()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getStyle Method

Glossary Item Box

Gets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

isClosed Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : isClosed Method

Glossary Item Box

Gets a value indicating whether the polyline is closed.

Boolean value.

The default value is false.

Syntax

public boolean isClosed()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

onPointAdded Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : onPointAdded Method
e
Event arguments.

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

protected void onPointAdded(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

onPointChanged Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : onPointChanged Method
e
Event arguments.

Glossary Item Box

Occurs when a point is changed.

Syntax

protected void onPointChanged(
   ImGearMarkPointEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

onPointsRemoved Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : onPointsRemoved Method
e
Event arguments.

Glossary Item Box

Occurs when points are removed.

Syntax

protected void onPointsRemoved(
   ImGearMarkEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

removePoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : removePoints Method
index
The index of the first point to remove.
count
The number of points to remove.

Glossary Item Box

Removes the specified number of points, starting at the specified index.

An error will occur if the specified index or specified number of points to remove is out of range.

Syntax

public void removePoints(
   int index,
   int count
)

Parameters

index
The index of the first point to remove.
count
The number of points to remove.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setClosed Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setClosed Method
value

Glossary Item Box

Sets a value indicating whether the polyline is closed.

Boolean value.

The default value is false.

Syntax

public void setClosed(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setEndHeadAngle Method
value

Glossary Item Box

Sets the end head angle of the mark.

Integer value.

Syntax

public void setEndHeadAngle(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setEndHeadLength Method
value

Glossary Item Box

Sets the end head length of the mark.

Integer value.

Syntax

public void setEndHeadLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadType Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setEndHeadType Method
value

Glossary Item Box

Sets the end head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

public void setEndHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setHeadFillColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setHeadFillColor Method
value

Glossary Item Box

Sets the fill color of the line's head.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setHeadFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of mark's points.

Integer value.

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadAngle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setStartHeadAngle Method
value

Glossary Item Box

Sets the start head angle of the mark.

Integer value.

Syntax

public void setStartHeadAngle(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setStartHeadLength Method
value

Glossary Item Box

Sets the start head length of the mark.

Integer value.

Syntax

public void setStartHeadLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadType Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setStartHeadType Method
value

Glossary Item Box

Sets the start head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

public void setStartHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setStyle Method
value

Glossary Item Box

Sets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPolyline Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyline Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolyline members.

Public Fields

 | Name | Description
public Field | pointAdded | Occurs when a point is added to the mark.
public Field | pointChanged | Occurs when a point is changed.
public Field | pointsRemoved | Occurs when points are removed.
Top

See Also

Reference

ImGearARTPolyline Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

pointAdded Field
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : pointAdded Field

Glossary Item Box

Occurs when a point is added to the mark.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointAdded

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

pointChanged Field
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : pointChanged Field

Glossary Item Box

Occurs when a point is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkPointEventArgs> pointChanged

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

pointsRemoved Field
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : pointsRemoved Field

Glossary Item Box

Occurs when points are removed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearMarkEventArgs> pointsRemoved

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPolyline Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPolyline Class
ImGearARTPolyline Members


%%PageItemTitle%%

ImGearARTPolyRuler Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyRuler Class

Glossary Item Box

Represents ART Polyline Ruler mark.

Object Model

ImGearARTPolyRuler ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearPoint ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTPolyRuler
    extends ImGearARTMark
    implements IImGearARTPolyRuler

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTPolyRuler

See Also

Reference

ImGearARTPolyRuler Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTPolyRuler Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyRuler Class

Glossary Item Box

The following tables list the members exposed by ImGearARTPolyRuler.

Public Constructors

 | Name | Description
public Constructor | ImGearARTPolyRuler Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method getAspectDenominatorX Gets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method getAspectDenominatorY Gets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorX Gets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorY Gets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getBounds Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

public Method getColor Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method getEndLineLength Gets the length of the mark's end line.

Integer value.

The default value is 20.

public Method getFontDisablePPM Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method getFontName Gets the font name of the text font.

String value.

The default value is "Arial".

public Method getFontSize Gets the font pointSize of the text font.

Any positive float value.

public Method getFontStyleART Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method getLabel Gets the mark label.

String value.

The default value is "%d mm".

public Method getNumberOfPoints Gets the actual number of mark's points.

Integer value.

public Method getOpacity Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method | getPoint | Gets mark's point with the specified index.
public Method getPoints Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

public Method getPrecision Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method getStartLineLength Gets the length of the mark's start line.

Integer value.

The default value is 20.

public Method getStyle Gets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method getType Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

public Method getWidth Gets the mark's line width.

Integer value.

public Method isVisible Gets a value indicating whether the mark is visible or not.

Boolean value.

public Method | move | Moves the mark by specified offset.
public Method setAspectDenominatorX Sets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method setAspectDenominatorY Sets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorX Sets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorY Sets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setColor Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method setEndLineLength Sets the length of the mark's end line.

Integer value.

The default value is 20.

public Method setFontDisablePPM Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method setFontName Sets the font name of the text font.

String value.

The default value is "Arial".

public Method setFontSize Sets the font pointSize of the text font.

Any positive float value.

public Method setFontStyleART Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method setLabel Sets the mark label.

String value.

The default value is "%d mm".

public Method setNumberOfPoints Sets the actual number of mark's points.

Integer value.

public Method setOpacity Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method | setPoint | Sets mark's point at the specified index.
public Method setPrecision Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method setStartLineLength Sets the length of the mark's start line.

Integer value.

The default value is 20.

public Method setStyle Sets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method setVisible Sets a value indicating whether the mark is visible or not.

Boolean value.

public Method setWidth Sets the mark's line width.

Integer value.

Top

See Also

Reference

ImGearARTPolyRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTPolyRuler Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyRuler Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolyRuler members.

See Also

Reference

ImGearARTPolyRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPolyRuler Constructor
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : ImGearARTPolyRuler Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad) | Initializes a new instance of the ImGearARTPolyRuler class object.
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution) | Initializes a new instance of the ImGearARTPolyRuler class object using start and end points, color and image resolution.
ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTPolyRuler class object.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad)
points
The mark's points.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTPolyRuler class object.

Syntax

public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color
)

Parameters

points
The mark's points.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,IImGearResolution)
points
The mark's points.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.

Glossary Item Box

Initializes a new instance of the ImGearARTPolyRuler class object using start and end points, color and image resolution.

Syntax

public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   IImGearResolution resolution
)

Parameters

points
The mark's points.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List


%%PageItemTitle%%

ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class > ImGearARTPolyRuler Constructor : ImGearARTPolyRuler Constructor(ImGearPoint[],IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>)
points
The mark's points.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTPolyRuler class object.

Syntax

public ImGearARTPolyRuler(
   ImGearPoint[] points,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   java.lang.String label,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

points
The mark's points.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTPolyRuler Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTPolyRuler Class

Glossary Item Box

For a list of all members of this type, see ImGearARTPolyRuler members.

Public Methods

Name | Description
public Method getAspectDenominatorX Gets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method getAspectDenominatorY Gets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorX Gets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorY Gets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getBounds Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

public Method getColor Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method getEndLineLength Gets the length of the mark's end line.

Integer value.

The default value is 20.

public Method getFontDisablePPM Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method getFontName Gets the font name of the text font.

String value.

The default value is "Arial".

public Method getFontSize Gets the font pointSize of the text font.

Any positive float value.

public Method getFontStyleART Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method getLabel Gets the mark label.

String value.

The default value is "%d mm".

public Method getNumberOfPoints Gets the actual number of mark's points.

Integer value.

public Method getOpacity Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method | getPoint | Gets mark's point with the specified index.
public Method getPoints Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

public Method getPrecision Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method getStartLineLength Gets the length of the mark's start line.

Integer value.

The default value is 20.

public Method getStyle Gets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method getType Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

public Method getWidth Gets the mark's line width.

Integer value.

public Method isVisible Gets a value indicating whether the mark is visible or not.

Boolean value.

public Method | move | Moves the mark by specified offset.
public Method setAspectDenominatorX Sets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method setAspectDenominatorY Sets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorX Sets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorY Sets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setColor Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method setEndLineLength Sets the length of the mark's end line.

Integer value.

The default value is 20.

public Method setFontDisablePPM Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method setFontName Sets the font name of the text font.

String value.

The default value is "Arial".

public Method setFontSize Sets the font pointSize of the text font.

Any positive float value.

public Method setFontStyleART Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method setLabel Sets the mark label.

String value.

The default value is "%d mm".

public Method setNumberOfPoints Sets the actual number of mark's points.

Integer value.

public Method setOpacity Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method | setPoint | Sets mark's point at the specified index.
public Method setPrecision Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method setStartLineLength Sets the length of the mark's start line.

Integer value.

The default value is 20.

public Method setStyle Sets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method setVisible Sets a value indicating whether the mark is visible or not.

Boolean value.

public Method setWidth Sets the mark's line width.

Integer value.

Top

See Also

Reference

ImGearARTPolyRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

Syntax

public int getAspectDenominatorX()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectDenominatorY()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectNumeratorX()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getAspectNumeratorY Method

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectNumeratorY()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getEndLineLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getEndLineLength Method

Glossary Item Box

Gets the length of the mark's end line.

Integer value.

The default value is 20.

Syntax

public int getEndLineLength()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

The default value is "Arial".

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getLabel Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getLabel Method

Glossary Item Box

Gets the mark label.

String value.

The default value is "%d mm".

Syntax

public java.lang.String getLabel()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

public int getNumberOfPoints()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getPoint Method
index
Index of the point.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

public ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint[] getPoints()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public int getPrecision()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getStartLineLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getStartLineLength Method

Glossary Item Box

Gets the length of the mark's start line.

Integer value.

The default value is 20.

Syntax

public int getStartLineLength()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getStyle Method

Glossary Item Box

Gets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : getWidth Method

Glossary Item Box

Gets the mark's line width.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

Syntax

public void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setAspectNumeratorY Method
value

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

ART Poly Ruler object is designed to display the distance between points on the image. Point's coordinates are specified in image pixel units, and the Polyline Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setEndLineLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setEndLineLength Method
value

Glossary Item Box

Sets the length of the mark's end line.

Integer value.

The default value is 20.

Syntax

public void setEndLineLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

The default value is "Arial".

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setLabel Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setLabel Method
value

Glossary Item Box

Sets the mark label.

String value.

The default value is "%d mm".

Syntax

public void setLabel(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of mark's points.

Integer value.

Syntax

public void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

public void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public void setPrecision(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setStartLineLength Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setStartLineLength Method
value

Glossary Item Box

Sets the length of the mark's start line.

Integer value.

The default value is 20.

Syntax

public void setStartLineLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setStyle Method
value

Glossary Item Box

Sets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : setWidth Method
value

Glossary Item Box

Sets the mark's line width.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTPolyRuler Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTPolyRuler Class
ImGearARTPolyRuler Members


%%PageItemTitle%%

ImGearARTProtractor Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTProtractor Class

Glossary Item Box

Represents ART Protractor mark.

Object Model

ImGearARTProtractor ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearPoint ClassImGearPoint ClassImGearRectangle ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTProtractor
    extends ImGearARTMark
    implements IImGearARTProtractor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTProtractor

See Also

Reference

ImGearARTProtractor Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTProtractor Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTProtractor Class

Glossary Item Box

The following tables list the members exposed by ImGearARTProtractor.

Public Constructors

 | Name | Description
public Constructor | ImGearARTProtractor Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getArcRadius | Gets the radius of the arc drawn in the mark. Integer value. The radius is measured in pixels. The default value is 0.
public Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value. The default value is 1.
public Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value. The default value is 1.
public Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value. The default value is 1.
public Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value. The default value is 1.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the mark color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndPoint | Gets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text font. String value.
public Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
public Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeadPoint | Gets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value. The default value is 1.
public Method | getStartPoint | Gets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStyle | Gets the style of the mark's line. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value.
public Method | getWidth | Gets the width of the mark's line. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setArcRadius | Sets the radius of the arc drawn in the mark. Integer value. The radius is measured in pixels. The default value is 0.
public Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value. The default value is 1.
public Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value. The default value is 1.
public Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value. The default value is 1.
public Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value. The default value is 1.
public Method | setColor | Sets the mark color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setEndPoint | Sets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text font. String value.
public Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
public Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeadPoint | Sets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value. The default value is 1.
public Method | setStartPoint | Sets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setStyle | Sets the style of the mark's line. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's line. Integer value.
Top

See Also

Reference

ImGearARTProtractor Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTProtractor Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTProtractor Class

Glossary Item Box

For a list of all members of this type, see ImGearARTProtractor members.

See Also

Reference

ImGearARTProtractor Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTProtractor Constructor
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : ImGearARTProtractor Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTProtractor class object.
ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTProtractor class object.

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTProtractor Class > ImGearARTProtractor Constructor : ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad)
startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTProtractor class object.

Syntax

public ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)

Parameters

startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Overload List


%%PageItemTitle%%

ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTProtractor Class > ImGearARTProtractor Constructor : ImGearARTProtractor Constructor(ImGearPoint,ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,String,float,EnumSet<ImGearARTFontStyles>)
startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
arcRadius
The radius, in pixels, of the arc drawn in the mark.
precision
The number of decimal digits displayed for the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTProtractor class object.

Syntax

public ImGearARTProtractor(
   ImGearPoint startPoint,
   ImGearPoint headPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int arcRadius,
   int precision,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

startPoint
Start point of the mark.
headPoint
Head point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
arcRadius
The radius, in pixels, of the arc drawn in the mark.
precision
The number of decimal digits displayed for the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTProtractor Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTProtractor Class

Glossary Item Box

For a list of all members of this type, see ImGearARTProtractor members.

Public Methods

 | Name | Description
public Method | getArcRadius | Gets the radius of the arc drawn in the mark. Integer value. The radius is measured in pixels. The default value is 0.
public Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value. The default value is 1.
public Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value. The default value is 1.
public Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value. The default value is 1.
public Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value. The default value is 1.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getColor | Gets the mark color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getEndPoint | Gets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text font. String value.
public Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
public Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeadPoint | Gets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value. The default value is 1.
public Method | getStartPoint | Gets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
public Method | getStyle | Gets the style of the mark's line. ImGearARTPenStyle enumeration value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value.
public Method | getWidth | Gets the width of the mark's line. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setArcRadius | Sets the radius of the arc drawn in the mark. Integer value. The radius is measured in pixels. The default value is 0.
public Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value. The default value is 1.
public Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value. The default value is 1.
public Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value. The default value is 1.
public Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value. The default value is 1.
public Method | setColor | Sets the mark color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
public Method | setEndPoint | Sets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text font. String value.
public Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
public Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeadPoint | Sets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value. The default value is 1.
public Method | setStartPoint | Sets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
public Method | setStyle | Sets the style of the mark's line. ImGearARTPenStyle enumeration value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's line. Integer value.
Top

See Also

Reference

ImGearARTProtractor Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getArcRadius Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getArcRadius Method

Glossary Item Box

Gets the radius of the arc drawn in the mark.

Integer value.

The radius is measured in pixels. The default value is 0.

Syntax

public int getArcRadius()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

The default value is 1.

Syntax

public int getAspectDenominatorX()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

The default value is 1.

Syntax

public int getAspectDenominatorY()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

The default value is 1.

Syntax

public int getAspectNumeratorX()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getAspectNumeratorY Method

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

The default value is 1.

Syntax

public int getAspectNumeratorY()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getColor Method

Glossary Item Box

Gets the mark color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getEndPoint Method

Glossary Item Box

Gets the end point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public ImGearPoint getEndPoint()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getHeadPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getHeadPoint Method

Glossary Item Box

Gets the head point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public ImGearPoint getHeadPoint()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public int getPrecision()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getStartPoint Method

Glossary Item Box

Gets the start point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

public ImGearPoint getStartPoint()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getStyle Method

Glossary Item Box

Gets the style of the mark's line.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value.

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : getWidth Method

Glossary Item Box

Gets the width of the mark's line.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setArcRadius Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setArcRadius Method
value

Glossary Item Box

Sets the radius of the arc drawn in the mark.

Integer value.

The radius is measured in pixels. The default value is 0.

Syntax

public void setArcRadius(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

The default value is 1.

Syntax

public void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

The default value is 1.

Syntax

public void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

The default value is 1.

Syntax

public void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setAspectNumeratorY Method
value

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

The default value is 1.

Syntax

public void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setColor Method
value

Glossary Item Box

Sets the mark color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setEndPoint Method
value

Glossary Item Box

Sets the end point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setHeadPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setHeadPoint Method
value

Glossary Item Box

Sets the head point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setHeadPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public void setPrecision(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setStartPoint Method
value

Glossary Item Box

Sets the start point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setStyle Method
value

Glossary Item Box

Sets the style of the mark's line.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's line.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTProtractor Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTProtractor Class
ImGearARTProtractor Members


%%PageItemTitle%%

ImGearARTRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRectangle Class

Glossary Item Box

Represents ART Rectangle mark.

Object Model

ImGearARTRectangle ClassImGearARTMark ClassImGearARTMark ClassImGearARTBorder ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTRectangle
    extends ImGearARTMark
    implements IImGearARTRectangle

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTRectangle

See Also

Reference

ImGearARTRectangle Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTRectangle Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearARTRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearARTRectangle Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the rectangle. Integer value.
public Method | getOpacity | Gets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the rectangle. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the rectangle. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTRectangle Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRectangle members.

See Also

Reference

ImGearARTRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTRectangle Constructor
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : ImGearARTRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad) | Initializes a new instance of the class object.
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int) | Initializes a new instance of the ImGearARTRectangle class object.
ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int) | Initializes a new instance of the class object.

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad)
rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the class object.

Syntax

public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,ImGearARTPenStyle,int)
rect
The mark's rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the ImGearARTRectangle class object.

Syntax

public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth
)

Parameters

rect
The mark's rectangle.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List


%%PageItemTitle%%

ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRectangle Class > ImGearARTRectangle Constructor : ImGearARTRectangle Constructor(IImGearRectangle,IImGearRGBQuad,IImGearRGBQuad,ImGearARTPenStyle,int,int)
rect
Mark's rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTPenStyle

Glossary Item Box

Initializes a new instance of the class object.

Syntax

public ImGearARTRectangle(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor,
   IImGearRGBQuad borderColor,
   ImGearARTPenStyle borderStyle,
   int borderWidth,
   int opacity
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark.
borderColor
Border color of the mark.
borderStyle
Border style of the mark.
borderWidth
Border width of the mark.
opacity
Opacity of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRectangle members.

Public Methods

 | Name | Description
public Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the rectangle. Integer value.
public Method | getOpacity | Gets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the rectangle. Integer value.
public Method | getX | Gets the X coordinate of top-left point of the mark. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque). The default value is 255.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the rectangle. Integer value.
public Method | setX | Sets the X coordinate of top-left point of the mark. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark. Integer value.
Top

See Also

Reference

ImGearARTRectangle Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object.

Syntax

public ImGearARTBorder getBorder()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getOpacity Method

Glossary Item Box

Gets the opacity of the rectangle.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getWidth Method

Glossary Item Box

Gets the width of the rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getX Method

Glossary Item Box

Gets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : getY Method

Glossary Item Box

Gets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setBorder Method
value

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object.

Syntax

public void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setHeight Method
value

Glossary Item Box

Sets the height of the rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the rectangle.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setWidth Method
value

Glossary Item Box

Sets the width of the rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setX Method
value

Glossary Item Box

Sets the X coordinate of top-left point of the mark.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of top-left point of the mark.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTRectangle Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTRectangle Class
ImGearARTRectangle Members


%%PageItemTitle%%

ImGearARTRedaction Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRedaction Class

Glossary Item Box

Represents legacy ART Redaction mark.

Object Model

ImGearARTRedaction ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearARTMarkStatistics ClassImGearARTMarkType Enumeration

Syntax

public class ImGearARTRedaction
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTRedaction

See Also

Reference

ImGearARTRedaction Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTRedaction Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRedaction Class

Glossary Item Box

The following tables list the members exposed by ImGearARTRedaction.

Public Constructors

 | Name | Description
public Constructor | ImGearARTRedaction Constructor | Initializes a new instance of the ImGearARTRedaction class object.
Top

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTRedaction Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTRedaction Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRedaction Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRedaction members.

See Also

Reference

ImGearARTRedaction Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTRedaction Constructor
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : ImGearARTRedaction Constructor
rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTRedaction class object.

Syntax

public ImGearARTRedaction(
   IImGearRectangle rect,
   IImGearRGBQuad fillColor
)

Parameters

rect
Mark's rectangle.
fillColor
Fill color of the mark. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTRedaction Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRedaction Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRedaction members.

Public Methods

 | Name | Description
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTRedaction Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getHeight Method

Glossary Item Box

Gets the height of the mark's rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark's rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTRedaction Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTRedaction Class
ImGearARTRedaction Members


%%PageItemTitle%%

ImGearARTRuler Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRuler Class

Glossary Item Box

Represents ART Ruler mark.

Object Model

ImGearARTRuler ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassIImGearRGBQuad InterfaceImGearPoint ClassImGearRectangle ClassImGearPoint ClassImGearARTMarkStatistics ClassImGearARTPenStyle EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTRuler
    extends ImGearARTMark
    implements IImGearARTRuler

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTRuler

See Also

Reference

ImGearARTRuler Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTRuler Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRuler Class

Glossary Item Box

The following tables list the members exposed by ImGearARTRuler.

Public Constructors

 | Name | Description
public Constructor | ImGearARTRuler Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method getAspectDenominatorX Gets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method getAspectDenominatorY Gets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorX Gets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorY Gets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getBounds Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

public Method getColor Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method getEndLineLength Gets the length of the mark's end line.

Integer value.

The default value is 20.

public Method getEndPoint Gets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method getFontDisablePPM Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method getFontName Gets the font name of the text font.

String value.

The default value is "Arial".

public Method getFontSize Gets the font pointSize of the text font.

Any positive float value.

public Method getFontStyleART Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method getLabel Gets the mark label.

String value.

The default value is "%d mm".

public Method getOpacity Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method getPrecision Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method getStartLineLength Gets the length of the mark's start line.

Integer value.

The default value is 20.

public Method getStartPoint Gets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method getStyle Gets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method getType Gets mark's type.

ImGearARTMarkType enumeration value.

public Method getWidth Gets the mark's line width.

Integer value.

public Method isVisible Gets a value indicating whether the mark is visible or not.

Boolean value.

public Method | move | Moves the mark by specified offset.
public Method setAspectDenominatorX Sets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method setAspectDenominatorY Sets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorX Sets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorY Sets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setColor Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method setEndLineLength Sets the length of the mark's end line.

Integer value.

The default value is 20.

public Method setEndPoint Sets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method setFontDisablePPM Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method setFontName Sets the font name of the text font.

String value.

The default value is "Arial".

public Method setFontSize Sets the font pointSize of the text font.

Any positive float value.

public Method setFontStyleART Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method setLabel Sets the mark label.

String value.

The default value is "%d mm".

public Method setOpacity Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method setPrecision Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method setStartLineLength Sets the length of the mark's start line.

Integer value.

The default value is 20.

public Method setStartPoint Sets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method setStyle Sets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method setVisible Sets a value indicating whether the mark is visible or not.

Boolean value.

public Method setWidth Sets the mark's line width.

Integer value.

Top

See Also

Reference

ImGearARTRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTRuler Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRuler Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRuler members.

See Also

Reference

ImGearARTRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTRuler Constructor
com.accusoft.imagegear.art Package > ImGearARTRuler Class : ImGearARTRuler Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad) | Initializes a new instance of the ImGearARTRuler class object.
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution) | Initializes a new instance of the ImGearARTRuler class object using start and end points, color and image resolution.
ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTRuler class object.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad)
startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTRuler class object.

Syntax

public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color
)

Parameters

startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color. com.accusoft.imagegear.core.shapes.ImGearPoint com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,IImGearResolution)
startPoint
Start point of the ruler.
endPoint
End point of the ruler.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.

Glossary Item Box

Initializes a new instance of the ImGearARTRuler class object using start and end points, color and image resolution.

Syntax

public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   IImGearResolution resolution
)

Parameters

startPoint
Start point of the ruler.
endPoint
End point of the ruler.
color
Ruler color.
resolution
Image resolution required to initialize ruler's aspect parameters used to calculate physical measurement units. In case of NO_ABS units, vertical resolution in set to 72 DPI and horizontal is calculated based on the resolution aspect ratio.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List


%%PageItemTitle%%

ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTRuler Class > ImGearARTRuler Constructor : ImGearARTRuler Constructor(ImGearPoint,ImGearPoint,IImGearRGBQuad,ImGearARTPenStyle,int,int,int,int,int,int,int,int,int,String,String,float,EnumSet<ImGearARTFontStyles>)
startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTRuler class object.

Syntax

public ImGearARTRuler(
   ImGearPoint startPoint,
   ImGearPoint endPoint,
   IImGearRGBQuad color,
   ImGearARTPenStyle style,
   int width,
   int opacity,
   int aspectNumeratorX,
   int aspectDenominatorX,
   int aspectNumeratorY,
   int aspectDenominatorY,
   int startLineLength,
   int endLineLength,
   int precision,
   java.lang.String label,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

startPoint
Start point of the mark.
endPoint
End point of the mark.
color
Mark color.
style
Mark's line style.
width
Mark's line width.
opacity
Opacity of the mark.
aspectNumeratorX
Mark's X aspect numerator value.
aspectDenominatorX
Mark's X aspect denominator value.
aspectNumeratorY
Mark's Y aspect numerator value.
aspectDenominatorY
Mark's Y aspect denominator value.
startLineLength
Length of the start line of the mark.
endLineLength
Length of the end line of the mark.
precision
The number of decimal digits displayed for the mark.
label
Mark's label.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearPointT:com.accusoft.imagegear.art.ImGearARTPenStyle ImGearARTFontStyles

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTRuler Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTRuler Class

Glossary Item Box

For a list of all members of this type, see ImGearARTRuler members.

Public Methods

Name | Description
public Method getAspectDenominatorX Gets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method getAspectDenominatorY Gets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorX Gets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getAspectNumeratorY Gets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method getBounds Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

public Method getColor Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method getEndLineLength Gets the length of the mark's end line.

Integer value.

The default value is 20.

public Method getEndPoint Gets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method getFontDisablePPM Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method getFontName Gets the font name of the text font.

String value.

The default value is "Arial".

public Method getFontSize Gets the font pointSize of the text font.

Any positive float value.

public Method getFontStyleART Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method getLabel Gets the mark label.

String value.

The default value is "%d mm".

public Method getOpacity Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method getPrecision Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method getStartLineLength Gets the length of the mark's start line.

Integer value.

The default value is 20.

public Method getStartPoint Gets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method getStyle Gets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method getType Gets mark's type.

ImGearARTMarkType enumeration value.

public Method getWidth Gets the mark's line width.

Integer value.

public Method isVisible Gets a value indicating whether the mark is visible or not.

Boolean value.

public Method | move | Moves the mark by specified offset.
public Method setAspectDenominatorX Sets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

public Method setAspectDenominatorY Sets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorX Sets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setAspectNumeratorY Sets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

public Method setColor Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

public Method setEndLineLength Sets the length of the mark's end line.

Integer value.

The default value is 20.

public Method setEndPoint Sets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method setFontDisablePPM Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

public Method setFontName Sets the font name of the text font.

String value.

The default value is "Arial".

public Method setFontSize Sets the font pointSize of the text font.

Any positive float value.

public Method setFontStyleART Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

public Method setLabel Sets the mark label.

String value.

The default value is "%d mm".

public Method setOpacity Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

public Method setPrecision Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

public Method setStartLineLength Sets the length of the mark's start line.

Integer value.

The default value is 20.

public Method setStartPoint Sets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

public Method setStyle Sets the mark's line style.

ImGearARTPenStyle enumeration value.

public Method setVisible Sets a value indicating whether the mark is visible or not.

Boolean value.

public Method setWidth Sets the mark's line width.

Integer value.

Top

See Also

Reference

ImGearARTRuler Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

Syntax

public int getAspectDenominatorX()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectDenominatorY()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectNumeratorX()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getAspectNumeratorY Method

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public int getAspectNumeratorY()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getColor()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getEndLineLength Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getEndLineLength Method

Glossary Item Box

Gets the length of the mark's end line.

Integer value.

The default value is 20.

Syntax

public int getEndLineLength()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getEndPoint Method

Glossary Item Box

Gets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public ImGearPoint getEndPoint()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

The default value is "Arial".

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getLabel Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getLabel Method

Glossary Item Box

Gets the mark label.

String value.

The default value is "%d mm".

Syntax

public java.lang.String getLabel()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public int getPrecision()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getStartLineLength Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getStartLineLength Method

Glossary Item Box

Gets the length of the mark's start line.

Integer value.

The default value is 20.

Syntax

public int getStartLineLength()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getStartPoint Method

Glossary Item Box

Gets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public ImGearPoint getStartPoint()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getStyle Method

Glossary Item Box

Gets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

public ImGearARTPenStyle getStyle()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value.

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : getWidth Method

Glossary Item Box

Gets the mark's line width.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurment units like meters or inches.

The default value is 1.

Syntax

public void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setAspectNumeratorY Method
value

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

ART Ruler object is designed to display the distance between 2 points on the image. Point's coordinates are specified in image pixel units, and the Ruler displays the distance measured in these units.

AspectDenominator/AspectNumerator properties help to change measurement units from image pixels to more convenient measurement units, like meters or inches.

The default value is 1.

Syntax

public void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setEndLineLength Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setEndLineLength Method
value

Glossary Item Box

Sets the length of the mark's end line.

Integer value.

The default value is 20.

Syntax

public void setEndLineLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setEndPoint Method
value

Glossary Item Box

Sets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

The default value is "Arial".

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setLabel Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setLabel Method
value

Glossary Item Box

Sets the mark label.

String value.

The default value is "%d mm".

Syntax

public void setLabel(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

The default value is 1.

Syntax

public void setPrecision(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setStartLineLength Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setStartLineLength Method
value

Glossary Item Box

Sets the length of the mark's start line.

Integer value.

The default value is 20.

Syntax

public void setStartLineLength(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setStartPoint Method
value

Glossary Item Box

Sets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

public void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setStyle Method
value

Glossary Item Box

Sets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

public void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : setWidth Method
value

Glossary Item Box

Sets the mark's line width.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTRuler Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTRuler Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTRuler Class
ImGearARTRuler Members


%%PageItemTitle%%

ImGearARTSelection Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTSelection Class

Glossary Item Box

Provides the abstract class that defines mark selection interface.

Object Model

ImGearARTSelection Class

Syntax

public abstract class ImGearARTSelection
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark

See Also

Reference

ImGearARTSelection Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTSelection Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTSelection Class

Glossary Item Box

The following tables list the members exposed by ImGearARTSelection.

See Also

Reference

ImGearARTSelection Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTSelection Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTSelection Class

Glossary Item Box

For a list of all members of this type, see ImGearARTSelection members.

See Also

Reference

ImGearARTSelection Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTSelection Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTSelection Class

Glossary Item Box

For a list of all members of this type, see ImGearARTSelection members.

See Also

Reference

ImGearARTSelection Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTSelection Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTSelection Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTSelection Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTSelection Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTSelection Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTSelection Class
ImGearARTSelection Members


%%PageItemTitle%%

ImGearARTText Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTText Class

Glossary Item Box

Represents ART Text mark.

Object Model

ImGearARTText ClassImGearARTMark ClassImGearARTMark ClassImGearAlignmentHModes EnumerationImGearAlignmentVModes EnumerationImGearARTBorder ClassImGearRectangle ClassImGearARTCallout ClassIImGearRGBQuad InterfaceImGearRectangle ClassImGearOrientationModes EnumerationImGearARTPin ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTTextType EnumerationImGearARTMarkType Enumeration

Syntax

public class ImGearARTText
    extends ImGearARTMark
    implements IImGearARTText

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTText

See Also

Reference

ImGearARTText Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTText Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTText Class

Glossary Item Box

The following tables list the members exposed by ImGearARTText.

Public Constructors

 | Name | Description
public Constructor | ImGearARTText Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins the text editing process.
public Method | endEdit | Ends the text editing process.
public Method | getActualText | Gets the actual text you can see on display. String value. This method behaves exactly as the ImGearARTTextFromFile.getText. ImGearARTTextFromFile.getText
public Method | getAlignmentH | Gets the horizontal text alignment. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value. The default value is ImGearAlignmentHModes.LEFT.
public Method | getAlignmentV | Gets the vertical text alignment. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. The default value is ImGearAlignmentVModes.TOP.
public Method | getBorder | Gets the mark border. ImGearARTBorder class object.
public Method | getBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getCallout | Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object. ImGearARTCallout
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the mark text. String name.
public Method | getFontSize | Gets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getHitTestBounds | Gets the mark's boundling rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.
public Method | getOrientation | Gets the text orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | getPin | Gets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object. ImGearARTPin
public Method | getText | Gets the text of the mark. Text string. ImGearARTTextFromFile
public Method | getTextColor | Gets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getTextOpacity | Gets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the method provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.
public Method | getTextTrimming | Gets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
public Method | getTextType | Gets the text type. ImGearARTTextType enumeration value. The default value is ImGearARTTextType.DIRECT_TEXT. ImGearARTTextType
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setActualText | Sets the actual text you can see on display. String value. This method behaves exactly as the ImGearARTTextFromFile.getText. ImGearARTTextFromFile.getText
public Method | setAlignmentH | Sets the horizontal text alignment. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value. The default value is ImGearAlignmentHModes.LEFT.
public Method | setAlignmentV | Sets the vertical text alignment. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. The default value is ImGearAlignmentVModes.TOP.
public Method | setBorder | Sets the mark border. ImGearARTBorder class object.
public Method | setBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
public Method | setCallout | Sets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object. ImGearARTCallout
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the mark text. String name.
public Method | setFontSize | Sets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity method is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.
public Method | setOrientation | Sets the text orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | setPin | Sets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object. ImGearARTPin
public Method | setText | Sets the text of the mark. Text string. getActualText
public Method | setTextColor | Sets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setTextOpacity | Sets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.
public Method | setTextTrimming | Sets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
public Method | setTextType | Sets the text type. ImGearARTTextType enumeration value. The default value is ImGearARTTextType.DIRECT_TEXT. ImGearARTTextType
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTText Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTText members.

See Also

Reference

ImGearARTText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTText Constructor
com.accusoft.imagegear.art Package > ImGearARTText Class : ImGearARTText Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTText class object.
ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,int,IImGearRGBQuad,ImGearARTBorder,boolean,int,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTPin,ImGearARTCallout) | Initializes a new instance of the ImGearARTTextFromFile class object.

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTText Class > ImGearARTText Constructor : ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTText class object.

Syntax

public ImGearARTText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTText Class
ImGearARTText Members
Overload List


%%PageItemTitle%%

ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,int,IImGearRGBQuad,ImGearARTBorder,boolean,int,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTPin,ImGearARTCallout)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTText Class > ImGearARTText Constructor : ImGearARTText Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTTextType,int,IImGearRGBQuad,ImGearARTBorder,boolean,int,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTPin,ImGearARTCallout)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
textType
Text type.
textOpacity
Text opacity.
fillColor
Fill color of the mark.
border
Border of the mark.
isBorderShaded
Specifies whether the mark's border is shaded or not.
opacity
Opacity of the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font.
pin
ImGearARTPin class object that specifies mark's pin icon attributes.
callout
ImGearARTCallout class object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTTextTypeT:com.accusoft.imagegear.art.ImGearARTPin ImGearARTCallout

Glossary Item Box

Initializes a new instance of the ImGearARTTextFromFile class object.

Syntax

public ImGearARTText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   ImGearARTTextType textType,
   int textOpacity,
   IImGearRGBQuad fillColor,
   ImGearARTBorder border,
   boolean isBorderShaded,
   int opacity,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle,
   ImGearARTPin pin,
   ImGearARTCallout callout
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
textType
Text type.
textOpacity
Text opacity.
fillColor
Fill color of the mark.
border
Border of the mark.
isBorderShaded
Specifies whether the mark's border is shaded or not.
opacity
Opacity of the mark.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font.
pin
ImGearARTPin class object that specifies mark's pin icon attributes.
callout
ImGearARTCallout class object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTTextTypeT:com.accusoft.imagegear.art.ImGearARTPin ImGearARTCallout

See Also

Reference

ImGearARTText Class
ImGearARTText Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTText Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTText members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins the text editing process.
public Method | endEdit | Ends the text editing process.
public Method | getActualText | Gets the actual text you can see on display. String value. This method behaves exactly as the ImGearARTTextFromFile.getText. ImGearARTTextFromFile.getText
public Method | getAlignmentH | Gets the horizontal text alignment. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value. The default value is ImGearAlignmentHModes.LEFT.
public Method | getAlignmentV | Gets the vertical text alignment. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. The default value is ImGearAlignmentVModes.TOP.
public Method | getBorder | Gets the mark border. ImGearARTBorder class object.
public Method | getBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getCallout | Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object. ImGearARTCallout
public Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the mark text. String name.
public Method | getFontSize | Gets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark's rectangle. Integer value.
public Method | getHitTestBounds | Gets the mark's boundling rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.
public Method | getOrientation | Gets the text orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | getPin | Gets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object. ImGearARTPin
public Method | getText | Gets the text of the mark. Text string. ImGearARTTextFromFile
public Method | getTextColor | Gets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getTextOpacity | Gets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the method provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.
public Method | getTextTrimming | Gets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
public Method | getTextType | Gets the text type. ImGearARTTextType enumeration value. The default value is ImGearARTTextType.DIRECT_TEXT. ImGearARTTextType
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setActualText | Sets the actual text you can see on display. String value. This method behaves exactly as the ImGearARTTextFromFile.getText. ImGearARTTextFromFile.getText
public Method | setAlignmentH | Sets the horizontal text alignment. com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value. The default value is ImGearAlignmentHModes.LEFT.
public Method | setAlignmentV | Sets the vertical text alignment. com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value. The default value is ImGearAlignmentVModes.TOP.
public Method | setBorder | Sets the mark border. ImGearARTBorder class object.
public Method | setBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
public Method | setCallout | Sets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object. ImGearARTCallout
public Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the mark text. String name.
public Method | setFontSize | Sets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark's rectangle. Integer value.
public Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity method is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.
public Method | setOrientation | Sets the text orientation. com.accusoft.imagegear.core.ImGearOrientationModes enumeration value. The default value is ImGearOrientationModes.TOP_LEFT.
public Method | setPin | Sets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object. ImGearARTPin
public Method | setText | Sets the text of the mark. Text string. getActualText
public Method | setTextColor | Sets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setTextOpacity | Sets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.
public Method | setTextTrimming | Sets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
public Method | setTextType | Sets the text type. ImGearARTTextType enumeration value. The default value is ImGearARTTextType.DIRECT_TEXT. ImGearARTTextType
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTText Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins the text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.ImGearPageDisplay com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTText Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTText Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends the text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getActualText Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getActualText Method

Glossary Item Box

Gets the actual text you can see on display.

String value.

This method behaves exactly as the ImGearARTTextFromFile.getText.

ImGearARTTextFromFile.getText

Syntax

public java.lang.String getActualText()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getAlignmentH Method

Glossary Item Box

Gets the horizontal text alignment.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

The default value is ImGearAlignmentHModes.LEFT.

Syntax

public ImGearAlignmentHModes getAlignmentH()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getAlignmentV Method

Glossary Item Box

Gets the vertical text alignment.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.

The default value is ImGearAlignmentVModes.TOP.

Syntax

public ImGearAlignmentVModes getAlignmentV()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getBorder Method

Glossary Item Box

Gets the mark border.

ImGearARTBorder class object.

Syntax

public ImGearARTBorder getBorder()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getBorderShading Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getBorderShading Method

Glossary Item Box

Sets a value indicating whether the border is shaded or not.

Boolean value.

Syntax

public boolean getBorderShading()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getCallout Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getCallout Method

Glossary Item Box

Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object. ImGearARTCallout

Syntax

public ImGearARTCallout getCallout()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getFillColor()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getFontName Method

Glossary Item Box

Gets the font name of the mark text.

String name.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the mark text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getHeight Method

Glossary Item Box

Gets the height of the mark's rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getHitTestBounds Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getHitTestBounds Method

Glossary Item Box

Gets the mark's boundling rectangle used for hit test.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getHitTestBounds()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.

Syntax

public int getOpacity()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getOrientation Method

Glossary Item Box

Gets the text orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT.

Syntax

public ImGearOrientationModes getOrientation()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getPin Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getPin Method

Glossary Item Box

Gets the ImGearARTPin object that specifies mark's pin icon attributes.

ImGearARTPin class object. ImGearARTPin

Syntax

public ImGearARTPin getPin()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getText Method

Glossary Item Box

Gets the text of the mark.

Text string. ImGearARTTextFromFile

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getTextColor Method

Glossary Item Box

Gets the color of the mark text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getTextOpacity Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getTextOpacity Method

Glossary Item Box

Gets a separate opacity used for text string.

Integer value from 0 (transparent) to 255 (opaque).

When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the method provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.

Syntax

public int getTextOpacity()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getTextTrimming Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getTextTrimming Method

Glossary Item Box

Gets the text trimming behavior to employ when content overflows the content area.

ImGearARTTextTrimming enumeration value.

Syntax

public ImGearARTTextTrimming getTextTrimming()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getTextType Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getTextType Method

Glossary Item Box

Gets the text type.

ImGearARTTextType enumeration value.

The default value is ImGearARTTextType.DIRECT_TEXT.

ImGearARTTextType

Syntax

public ImGearARTTextType getTextType()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTText Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTText Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTText Class : move Method
offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Glossary Item Box

Moves mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTText Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setActualText Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setActualText Method
value

Glossary Item Box

Sets the actual text you can see on display.

String value.

This method behaves exactly as the ImGearARTTextFromFile.getText.

ImGearARTTextFromFile.getText

Syntax

public void setActualText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setAlignmentH Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setAlignmentH Method
value

Glossary Item Box

Sets the horizontal text alignment.

com.accusoft.imagegear.display.ImGearAlignmentHModes enumeration value.

The default value is ImGearAlignmentHModes.LEFT.

Syntax

public void setAlignmentH(
   ImGearAlignmentHModes value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setAlignmentV Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setAlignmentV Method
value

Glossary Item Box

Sets the vertical text alignment.

com.accusoft.imagegear.display.ImGearAlignmentVModes enumeration value.

The default value is ImGearAlignmentVModes.TOP.

Syntax

public void setAlignmentV(
   ImGearAlignmentVModes value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setBorder Method
value

Glossary Item Box

Sets the mark border.

ImGearARTBorder class object.

Syntax

public void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setBorderShading Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setBorderShading Method
value

Glossary Item Box

Sets a value indicating whether the border is shaded or not.

Boolean value.

Syntax

public void setBorderShading(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setCallout Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setCallout Method
value

Glossary Item Box

Sets a value of the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object. ImGearARTCallout

Syntax

public void setCallout(
   ImGearARTCallout value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setFontName Method
value

Glossary Item Box

Sets the font name of the mark text.

String name.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the mark text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark's rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

This Opacity method is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use ImGearARTTextFromFile method. The default value is 255.

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setOrientation Method
value

Glossary Item Box

Sets the text orientation.

com.accusoft.imagegear.core.ImGearOrientationModes enumeration value.

The default value is ImGearOrientationModes.TOP_LEFT.

Syntax

public void setOrientation(
   ImGearOrientationModes value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setPin Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setPin Method
value

Glossary Item Box

Sets the ImGearARTPin object that specifies mark's pin icon attributes.

ImGearARTPin class object. ImGearARTPin

Syntax

public void setPin(
   ImGearARTPin value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setText Method
value

Glossary Item Box

Sets the text of the mark.

Text string. getActualText

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setTextColor Method
value

Glossary Item Box

Sets the color of the mark text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setTextOpacity Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setTextOpacity Method
value

Glossary Item Box

Sets a separate opacity used for text string.

Integer value from 0 (transparent) to 255 (opaque).

When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the ImGearARTTextFromFile method used to set the opacity for the entire mark. The default value is 255.

Syntax

public void setTextOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setTextTrimming Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setTextTrimming Method
value

Glossary Item Box

Sets the text trimming behavior to employ when content overflows the content area.

ImGearARTTextTrimming enumeration value.

Syntax

public void setTextTrimming(
   ImGearARTTextTrimming value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setTextType Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setTextType Method
value

Glossary Item Box

Sets the text type.

ImGearARTTextType enumeration value.

The default value is ImGearARTTextType.DIRECT_TEXT.

ImGearARTTextType

Syntax

public void setTextType(
   ImGearARTTextType value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTText Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTText Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTText Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTText Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTText Class
ImGearARTText Members


%%PageItemTitle%%

ImGearARTTextCallout Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextCallout Class

Glossary Item Box

Represents legacy ART Callout Text mark.

Object Model

ImGearARTTextCallout ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearARTCallout ClassImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTTextCallout
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTTextCallout

See Also

Reference

ImGearARTTextCallout Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTTextCallout Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextCallout Class

Glossary Item Box

The following tables list the members exposed by ImGearARTTextCallout.

Public Constructors

 | Name | Description
public Constructor | ImGearARTTextCallout Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getCallout | Gets the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Integer value.
public Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value. The default value is 1.
public Method | getHitTestBounds | Gets the mark's bounding rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getText | Gets the text string. String value.
public Method | getTextColor | Gets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value.
public Method | getWidth | Gets the width of the mark rectangle. Integer value. The default value is 1.
public Method | getX | Gets the X coordinate of top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setCallout | Sets the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Integer value.
public Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value. The default value is 1.
public Method | setText | Sets the text string. String value.
public Method | setTextColor | Sets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value. The default value is 1.
public Method | setX | Sets the X coordinate of top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTTextCallout Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextCallout Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextCallout members.

See Also

Reference

ImGearARTTextCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTTextCallout Constructor
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : ImGearARTTextCallout Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout) | Initializes a new instance of the ImGearARTTextCallout class object.
ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTCallout) | Initializes a new instance of the ImGearARTTextCallout class object.

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class > ImGearARTTextCallout Constructor : ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,ImGearARTCallout)
rect
Mark's rectangle.
text
Text string.
textColor
Color of the text.
callout
ImGearARTCallout object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTCallout

Glossary Item Box

Initializes a new instance of the ImGearARTTextCallout class object.

Syntax

public ImGearARTTextCallout(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   ImGearARTCallout callout
)

Parameters

rect
Mark's rectangle.
text
Text string.
textColor
Color of the text.
callout
ImGearARTCallout object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTCallout

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Overload List


%%PageItemTitle%%

ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTCallout)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class > ImGearARTTextCallout Constructor : ImGearARTTextCallout Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>,ImGearARTCallout)
rect
Mark's rectangle.
text
Text string.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font.
callout
ImGearARTCallout object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles ImGearARTCallout

Glossary Item Box

Initializes a new instance of the ImGearARTTextCallout class object.

Syntax

public ImGearARTTextCallout(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle,
   ImGearARTCallout callout
)

Parameters

rect
Mark's rectangle.
text
Text string.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font.
callout
ImGearARTCallout object that specifies mark's callout attributes. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles ImGearARTCallout

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTTextCallout Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextCallout Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextCallout members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getCallout | Gets the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Integer value.
public Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value. The default value is 1.
public Method | getHitTestBounds | Gets the mark's bounding rectangle used for hit test. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getText | Gets the text string. String value.
public Method | getTextColor | Gets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value.
public Method | getWidth | Gets the width of the mark rectangle. Integer value. The default value is 1.
public Method | getX | Gets the X coordinate of top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves the mark by specified offset.
public Method | setCallout | Sets the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. System.Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Integer value.
public Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value. The default value is 1.
public Method | setText | Sets the text string. String value.
public Method | setTextColor | Sets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value. The default value is 1.
public Method | setX | Sets the X coordinate of top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextCallout Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.ImGearPageDisplay com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getCallout Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getCallout Method

Glossary Item Box

Gets the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object.

Syntax

public ImGearARTCallout getCallout()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

System.Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getFontName Method

Glossary Item Box

Gets the font name of the text.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text.

Integer value.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getHeight Method

Glossary Item Box

Gets the height of the mark rectangle.

Integer value.

The default value is 1.

Syntax

public int getHeight()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getHitTestBounds Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getHitTestBounds Method

Glossary Item Box

Gets the mark's bounding rectangle used for hit test.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

This rectangle adds a callout point to the mark's bounding rectangle. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getHitTestBounds()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getText Method

Glossary Item Box

Gets the text string.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getTextColor Method

Glossary Item Box

Gets the color of the text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value.

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getWidth Method

Glossary Item Box

Gets the width of the mark rectangle.

Integer value.

The default value is 1.

Syntax

public int getWidth()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getX Method

Glossary Item Box

Gets the X coordinate of top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : getY Method

Glossary Item Box

Gets the Y coordinate of top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : move Method
offsetX
X offset to move.
offsetY
Y offset to move.

Glossary Item Box

Moves the mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset to move.
offsetY
Y offset to move.

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setCallout Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setCallout Method
value

Glossary Item Box

Sets the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object.

Syntax

public void setCallout(
   ImGearARTCallout value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

System.Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text.

Integer value.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark rectangle.

Integer value.

The default value is 1.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setText Method
value

Glossary Item Box

Sets the text string.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setTextColor Method
value

Glossary Item Box

Sets the color of the text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark rectangle.

Integer value.

The default value is 1.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setX Method
value

Glossary Item Box

Sets the X coordinate of top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTTextCallout Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTTextCallout Class
ImGearARTTextCallout Members


%%PageItemTitle%%

ImGearARTTextFromFile Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextFromFile Class

Glossary Item Box

Represents legacy ART Text From File mark.

Object Model

ImGearARTTextFromFile ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTTextFromFile
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTTextFromFile

See Also

Reference

ImGearARTTextFromFile Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTTextFromFile Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextFromFile Class

Glossary Item Box

The following tables list the members exposed by ImGearARTTextFromFile.

Public Constructors

 | Name | Description
public Constructor | ImGearARTTextFromFile Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the path to the text file. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the path to the text file. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextFromFile Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTTextFromFile Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextFromFile Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextFromFile members.

See Also

Reference

ImGearARTTextFromFile Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTTextFromFile Constructor
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : ImGearARTTextFromFile Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTextFromFile class object.
ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTTextFromFile class object.

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class > ImGearARTTextFromFile Constructor : ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad)
rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTTextFromFile class object.

Syntax

public ImGearARTTextFromFile(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor
)

Parameters

rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Overload List


%%PageItemTitle%%

ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class > ImGearARTTextFromFile Constructor : ImGearARTTextFromFile Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTTextFromFile class object.

Syntax

public ImGearARTTextFromFile(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

rect
Mark's rectangle.
text
Path to the file to load text from.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTTextFromFile Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextFromFile Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextFromFile members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the path to the text file. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the path to the text file. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextFromFile Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.ImGearPageDisplay com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getFontName Method

Glossary Item Box

Gets the font name of the text.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getHeight Method

Glossary Item Box

Gets the height of the mark rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getText Method

Glossary Item Box

Gets the path to the text file.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getTextColor Method

Glossary Item Box

Gets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getWidth Method

Glossary Item Box

Gets the width of the mark rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : move Method
offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Glossary Item Box

Moves mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setText Method
value

Glossary Item Box

Sets the path to the text file.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setTextColor Method
value

Glossary Item Box

Sets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTTextFromFile Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTTextFromFile Class
ImGearARTTextFromFile Members


%%PageItemTitle%%

ImGearARTTextStamp Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextStamp Class

Glossary Item Box

Represents legacy ART Text Stamp mark.

Object Model

ImGearARTTextStamp ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTTextStamp
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTTextStamp

See Also

Reference

ImGearARTTextStamp Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTTextStamp Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextStamp Class

Glossary Item Box

The following tables list the members exposed by ImGearARTTextStamp.

Public Constructors

 | Name | Description
public Constructor | ImGearARTTextStamp Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the stamp text. String value.
public Method | getTextColor | Gets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the stamp text. String value.
public Method | setTextColor | Sets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextStamp Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTTextStamp Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextStamp Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextStamp members.

See Also

Reference

ImGearARTTextStamp Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTTextStamp Constructor
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : ImGearARTTextStamp Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTextStamp class object.
ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTTextStamp class object.

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class > ImGearARTTextStamp Constructor : ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTTextStamp class object.

Syntax

public ImGearARTTextStamp(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Overload List


%%PageItemTitle%%

ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class > ImGearARTTextStamp Constructor : ImGearARTTextStamp Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTTextStamp class object.

Syntax

public ImGearARTTextStamp(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTTextStamp Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTextStamp Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTextStamp members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the stamp text. String value.
public Method | getTextColor | Gets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the stamp text. String value.
public Method | setTextColor | Sets the color of the text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTextStamp Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.ImGearPageDisplay com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getFontName Method

Glossary Item Box

Gets the font name.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getHeight Method

Glossary Item Box

Gets the height of the mark rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getText Method

Glossary Item Box

Gets the stamp text.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getTextColor Method

Glossary Item Box

Gets the color of the text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getWidth Method

Glossary Item Box

Gets the width of the mark rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : move Method
offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Glossary Item Box

Moves mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setFontName Method
value

Glossary Item Box

Sets the font name.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setText Method
value

Glossary Item Box

Sets the stamp text.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setTextColor Method
value

Glossary Item Box

Sets the color of the text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTTextStamp Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTTextStamp Class
ImGearARTTextStamp Members


%%PageItemTitle%%

ImGearARTTypedText Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTypedText Class

Glossary Item Box

Represents legacy ART Typed Text mark.

Object Model

ImGearARTTypedText ClassImGearARTMark ClassImGearARTMark ClassImGearRectangle ClassImGearRectangle ClassImGearARTMarkStatistics ClassIImGearRGBQuad InterfaceImGearARTMarkType Enumeration

Syntax

public class ImGearARTTypedText
    extends ImGearARTMark

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.art.ImGearARTSelection
com.accusoft.imagegear.art.ImGearARTMark
com.accusoft.imagegear.art.ImGearARTTypedText

See Also

Reference

ImGearARTTypedText Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearARTTypedText Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTypedText Class

Glossary Item Box

The following tables list the members exposed by ImGearARTTypedText.

Public Constructors

 | Name | Description
public Constructor | ImGearARTTypedText Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the text string of the mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the text string of the mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTypedText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearARTTypedText Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTypedText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTypedText members.

See Also

Reference

ImGearARTTypedText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTTypedText Constructor
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : ImGearARTTypedText Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad) | Initializes a new instance of the ImGearARTTypedText class object.
ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>) | Initializes a new instance of the ImGearARTTypedText class object.

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTypedText Class > ImGearARTTypedText Constructor : ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

Glossary Item Box

Initializes a new instance of the ImGearARTTypedText class object.

Syntax

public ImGearARTTypedText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text. com.accusoft.imagegear.core.shapes.ImGearRectangle com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Overload List


%%PageItemTitle%%

ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
See Also Send Feedback
com.accusoft.imagegear.art Package > ImGearARTTypedText Class > ImGearARTTypedText Constructor : ImGearARTTypedText Constructor(IImGearRectangle,String,IImGearRGBQuad,String,float,EnumSet<ImGearARTFontStyles>)
rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

Glossary Item Box

Initializes a new instance of the ImGearARTTypedText class object.

Syntax

public ImGearARTTypedText(
   IImGearRectangle rect,
   java.lang.String text,
   IImGearRGBQuad textColor,
   java.lang.String fontName,
   float fontSize,
   java.util.EnumSet<ImGearARTFontStyles> fontStyle
)

Parameters

rect
Mark's rectangle.
text
Text of the mark.
textColor
Color of the mark's text.
fontName
The name of the font.
fontSize
The pointSize of the font in points.
fontStyle
The style of the font. com.accusoft.imagegear.core.shapes.ImGearRectangleT:com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearARTTypedText Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearARTTypedText Class

Glossary Item Box

For a list of all members of this type, see ImGearARTTypedText members.

Public Methods

 | Name | Description
public Method | beginEdit | Begins text editing process.
public Method | endEdit | Ends text editing process.
public Method | getBounds | Gets mark's bounding rectangle in abstract coordinates. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | getFontName | Gets the font name of the text. String value.
public Method | getFontSize | Gets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | getFontStyleART | Gets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | getHeight | Gets the height of the mark rectangle. Integer value.
public Method | getText | Gets the text string of the mark. String value.
public Method | getTextColor | Gets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | getType | Gets mark's type. ImGearARTMarkType enumeration value. ImGearARTMarkType
public Method | getWidth | Gets the width of the mark's rectangle. Integer value.
public Method | getX | Gets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | getY | Gets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | isVisible | Gets a value indicating whether the mark is visible or not. Boolean value.
public Method | move | Moves mark by specified offset.
public Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.
public Method | setFontName | Sets the font name of the text. String value.
public Method | setFontSize | Sets the font pointSize of the text. Any positive float value. The font pointSize is measured in points.
public Method | setFontStyleART | Sets the font style of the text. Aggregates of ImGearARTFontStyles enumeration value.
public Method | setHeight | Sets the height of the mark rectangle. Integer value.
public Method | setText | Sets the text string of the mark. String value.
public Method | setTextColor | Sets the text color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
public Method | setVisible | Sets a value indicating whether the mark is visible or not. Boolean value.
public Method | setWidth | Sets the width of the mark's rectangle. Integer value.
public Method | setX | Sets the X coordinate of the top-left point of the mark's rectangle. Integer value.
public Method | setY | Sets the Y coordinate of the top-left point of the mark's rectangle. Integer value.
Top

See Also

Reference

ImGearARTTypedText Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

beginEdit Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : beginEdit Method
pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Glossary Item Box

Begins text editing process.

Syntax

public boolean beginEdit(
   IImGearScrollableView pageView,
   ImGearPageDisplay pageDisplay
)

Parameters

pageView
PageView control that contains text mark.
pageDisplay
PageDisplay of the PageView control.

Return Value

True if the editing has begun; otherwise, false. com.accusoft.imagegear.display.ImGearPageDisplay com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

endEdit Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : endEdit Method
pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

Glossary Item Box

Ends text editing process.

Syntax

public void endEdit(
   IImGearScrollableView pageView
)

Parameters

pageView
PageView control that contains text mark. com.accusoft.imagegear.display.IImGearScrollableView

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getBounds Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getBounds Method

Glossary Item Box

Gets mark's bounding rectangle in abstract coordinates.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBounds()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public boolean getFontDisablePPM()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getFontName Method

Glossary Item Box

Gets the font name of the text.

String value.

Syntax

public java.lang.String getFontName()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public float getFontSize()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getFontStyleART Method

Glossary Item Box

Gets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getHeight Method

Glossary Item Box

Gets the height of the mark rectangle.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getText Method

Glossary Item Box

Gets the text string of the mark.

String value.

Syntax

public java.lang.String getText()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getTextColor Method

Glossary Item Box

Gets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public IImGearRGBQuad getTextColor()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getType Method

Glossary Item Box

Gets mark's type.

ImGearARTMarkType enumeration value. ImGearARTMarkType

Syntax

public ImGearARTMarkType getType()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getWidth Method

Glossary Item Box

Gets the width of the mark's rectangle.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getX Method

Glossary Item Box

Gets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getX()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : getY Method

Glossary Item Box

Gets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public int getY()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : isVisible Method

Glossary Item Box

Gets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public boolean isVisible()

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

move Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : move Method
offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

Glossary Item Box

Moves mark by specified offset.

Syntax

public void move(
   int offsetX,
   int offsetY
)

Parameters

offsetX
X offset in abstract coordinates.
offsetY
Y offset in abstract coordinates.

Type of the mark's coordinate system is specifying when using ImGearARTPage.addMark method.

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations. The default value is false.

Syntax

public void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setFontName Method
value

Glossary Item Box

Sets the font name of the text.

String value.

Syntax

public void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text.

Any positive float value.

The font pointSize is measured in points.

Syntax

public void setFontSize(
   float value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

public void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setHeight Method
value

Glossary Item Box

Sets the height of the mark rectangle.

Integer value.

Syntax

public void setHeight(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setText Method
value

Glossary Item Box

Sets the text string of the mark.

String value.

Syntax

public void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setTextColor Method
value

Glossary Item Box

Sets the text color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

public void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setVisible Method
value

Glossary Item Box

Sets a value indicating whether the mark is visible or not.

Boolean value.

Syntax

public void setVisible(
   boolean value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setWidth Method
value

Glossary Item Box

Sets the width of the mark's rectangle.

Integer value.

Syntax

public void setWidth(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setX Method
value

Glossary Item Box

Sets the X coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : setY Method
value

Glossary Item Box

Sets the Y coordinate of the top-left point of the mark's rectangle.

Integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.art Package > ImGearARTTypedText Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearARTTypedText Class
ImGearARTTypedText Members


%%PageItemTitle%%

ImGearMarkEventArgs Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkEventArgs Class

Glossary Item Box

Provides data for the mark events.

Object Model

ImGearMarkEventArgs ClassImGearARTMark Class

Syntax

public class ImGearMarkEventArgs
    extends com.accusoft.imagegear.utility.events.ImGearEventArgs

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearMarkEventArgs

See Also

Reference

ImGearMarkEventArgs Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMarkEventArgs Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkEventArgs Class

Glossary Item Box

The following tables list the members exposed by ImGearMarkEventArgs.

Public Methods

 | Name | Description
public Method | getMark | Gets the mark in which the event fired. A copy of the mark that was removed is returned if the markRemoved event fired. ImGearARTMark value.
Top

See Also

Reference

ImGearMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMarkEventArgs Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearMarkEventArgs members.

See Also

Reference

ImGearMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMarkEventArgs Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearMarkEventArgs members.

Public Methods

 | Name | Description
public Method | getMark | Gets the mark in which the event fired. A copy of the mark that was removed is returned if the markRemoved event fired. ImGearARTMark value.
Top

See Also

Reference

ImGearMarkEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getMark Method
com.accusoft.imagegear.art Package > ImGearMarkEventArgs Class : getMark Method

Glossary Item Box

Gets the mark in which the event fired.

A copy of the mark that was removed is returned if the markRemoved event fired.

ImGearARTMark value.

Syntax

public ImGearARTMark getMark()

See Also

Reference

ImGearMarkEventArgs Class
ImGearMarkEventArgs Members


%%PageItemTitle%%

ImGearMarkPointEventArgs Class
See Also Members Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkPointEventArgs Class

Glossary Item Box

Provides data for the mark point events.

Object Model

ImGearMarkPointEventArgs ClassImGearARTMark ClassImGearPoint Class

Syntax

public class ImGearMarkPointEventArgs
    extends com.accusoft.imagegear.utility.events.ImGearEventArgs

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearMarkPointEventArgs

See Also

Reference

ImGearMarkPointEventArgs Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMarkPointEventArgs Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkPointEventArgs Class

Glossary Item Box

The following tables list the members exposed by ImGearMarkPointEventArgs.

Public Methods

 | Name | Description
public Method | getMark | Gets the mark in which the event fired. ImGearARTMark value.
public Method | getPoint | Gets the point that was added or changed. ImGearPoint value.
Top

See Also

Reference

ImGearMarkPointEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMarkPointEventArgs Class Fields
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkPointEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearMarkPointEventArgs members.

See Also

Reference

ImGearMarkPointEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMarkPointEventArgs Class Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : ImGearMarkPointEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearMarkPointEventArgs members.

Public Methods

 | Name | Description
public Method | getMark | Gets the mark in which the event fired. ImGearARTMark value.
public Method | getPoint | Gets the point that was added or changed. ImGearPoint value.
Top

See Also

Reference

ImGearMarkPointEventArgs Class
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getMark Method
com.accusoft.imagegear.art Package > ImGearMarkPointEventArgs Class : getMark Method

Glossary Item Box

Gets the mark in which the event fired.

ImGearARTMark value.

Syntax

public ImGearARTMark getMark()

See Also

Reference

ImGearMarkPointEventArgs Class
ImGearMarkPointEventArgs Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > ImGearMarkPointEventArgs Class : getPoint Method

Glossary Item Box

Gets the point that was added or changed.

ImGearPoint value.

Syntax

public ImGearPoint getPoint()

See Also

Reference

ImGearMarkPointEventArgs Class
ImGearMarkPointEventArgs Members


%%PageItemTitle%%

ImGearARTAccess Enumeration
com.accusoft.imagegear.art Package : ImGearARTAccess Enumeration

Glossary Item Box

Specifies annotations group access level.

Members

Member | Description
LOCKED | Access denied.
UNLOCKED | Access granted.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTAccess

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTBurnInOptions Enumeration
com.accusoft.imagegear.art Package : ImGearARTBurnInOptions Enumeration

Glossary Item Box

Specifies options to burn in annotations.

Members

Member | Description
ALL | Burn in all annotation marks.
DELETE_MARKS | Delete affected annotation marks after burning them in.
SELECTED | Burn in all selected annotation marks.
VISIBLE | Burn in all visible annotation marks.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTBurnInOptions

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTButtonState Enumeration
com.accusoft.imagegear.art Package : ImGearARTButtonState Enumeration

Glossary Item Box

Specifies button mark's state options.

Members

Member | Description
NORMAL | Button is unpressed.
PRESSED | Button is pressed.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTButtonState

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTCalloutType Enumeration
com.accusoft.imagegear.art Package : ImGearARTCalloutType Enumeration

Glossary Item Box

Specifies callout types.

Members

Member | Description
LINE | Linear callout.
TRIANGLE | Triangular callout.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTCalloutType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTCoordinatesType Enumeration
com.accusoft.imagegear.art Package : ImGearARTCoordinatesType Enumeration

Glossary Item Box

Specifies mark's coordinate types.

Members

Member | Description
DEVICE_COORD | Device coordinate system.
IMAGE_COORD | Image coordinate system.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTCoordinatesType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTFontStyles Enumeration
com.accusoft.imagegear.art Package : ImGearARTFontStyles Enumeration

Glossary Item Box

Specifies text font style information. Normal text is represented by an empty EnumSet<ImGearARTFontStyles>

Members

Member | Description
Bold | Bold text.
Italic | Italic text.
Strikeout | Text with a line through the middle.
Underline | Underlined text.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTFontStyles

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTLineHeadType Enumeration
com.accusoft.imagegear.art Package : ImGearARTLineHeadType Enumeration

Glossary Item Box

Specifies line mark's head types.

Members

Member | Description
NONE | Without head.
OPEN | Open pointer head.
POINTER | Regular pointer head.
POINTER_SOLID | Solid pointer head.
SOLID | Solid head.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTLineHeadType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTMarkHitTest Enumeration
com.accusoft.imagegear.art Package : ImGearARTMarkHitTest Enumeration

Glossary Item Box

Specifies hit test results.

Members

Member | Description
INBOUNDARY | Within the mark's boundary, but not on the mark.
ONMARK | On the mark.
OUTSIDE | Outside of the mark's boundary.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTMarkHitTest

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTMarkType Enumeration
com.accusoft.imagegear.art Package : ImGearARTMarkType Enumeration

Glossary Item Box

Specifies types of annotations.

Members

Member | Description
ARROW | Legacy ART 2.0 Arrow mark.
ATTACH_A_NOTE | Legacy ART 2.0 Attach-A-Note mark.
AUDIO | ART 3.0/2.0 Audio mark.
BUTTON | ART 3.0/2.0 Button mark.
CALLOUT | Legacy ART 2.0 Callout mark.
CURVE | ART 3.0/2.0 Curve mark.
CUSTOM | ART 3.0 Custom mark.
ELLIPSE | ART 3.0 Ellipse mark.
ENCRYPTION | ART 3.0/2.0 Encryption mark.
FILLED_ELLIPSE | Legacy ART 2.0 Filled Ellipse mark.
FILLED_POLYGON | Legacy ART 2.0 Filled Polygon mark.
FILLED_RECTANGLE | Legacy ART 2.0 Filled Rectangle mark.
FREEHAND_LINE | ART 3.0/2.0 Freehand Line mark.
HIGHLIGHTER | Legacy ART 2.0 Highlighter mark.
HOLLOW_ELLIPSE | Legacy ART 2.0 Hollow Ellipse mark.
HOLLOW_POLYGON | Legacy ART 2.0 Hollow Polygon mark.
HOLLOW_RECTANGLE | Legacy ART 2.0 Hollow Rectangle mark.
HOTSPOT | ART 3.0/2.0 HotSpot mark.
IMAGE | ART 3.0 Image mark.
IMAGE_EMBEDDED | Legacy ART 2.0 Embedded Image mark.
IMAGE_REFERENCE | Legacy ART 2.0 Image Reference mark.
LINE | ART 3.0/2.0 Line mark.
PIN_UP_TEXT | Legacy ART 2.0 Pin-Up Text mark.
POINT | ART 3.0/2.0 Point mark.
POLYGON | ART 3.0 Polygon mark.
POLYLINE | ART 3.0/2.0 Polyline mark.
POLYRULER | ART 3.0/2.0 PolyRuler mark.
PROTRACTOR | ART 3.0/2.0 Protractor mark.
RECTANGLE | ART 3.0 Rectangle mark.
REDACTION | Legacy ART 2.0 Redaction mark.
RICH_TEXT | ART 3.0/2.0 Rich Text mark.
RULER | ART 3.0/2.0 Ruler mark.
SELECT | Mark selector.
TEXT | ART 3.0 Text mark.
TEXT_FROM_FILE | Legacy ART 2.0 Text From File mark.
TEXT_STAMP | Legacy ART 2.0 Text Stamp mark.
TYPED_TEXT | Legacy ART 2.0 Typed Text mark.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTMarkType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPenStyle Enumeration
com.accusoft.imagegear.art Package : ImGearARTPenStyle Enumeration

Glossary Item Box

Specifies pen styles.

Members

Member | Description
DASH | Line consisting of dashes.
DASHDOT | Line consisting of a repeating pattern of dash-dot.
DASHDOTDOT | Line consisting of a repeating pattern of dash-dot-dot.
DOT | Line consisting of dots.
PDFDASH1 | Dash pattern compatible with Adobe Acrobat's "Dashed 1" style.
PDFDASH2 | Dash pattern compatible with Adobe Acrobat's "Dashed 2" style.
PDFDASH3 | Dash pattern compatible with Adobe Acrobat's "Dashed 3" style.
PDFDASH4 | Dash pattern compatible with Adobe Acrobat's "Dashed 4" style.
PDFDASH5 | Dash pattern compatible with Adobe Acrobat's "Dashed 5" style.
PDFDASH6 | Dash pattern compatible with Adobe Acrobat's "Dashed 6" style.
SOLID | Solid line.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTPenStyle

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTPinAlignment Enumeration
com.accusoft.imagegear.art Package : ImGearARTPinAlignment Enumeration

Glossary Item Box

Specifies an alignment of the pin icon.

Members

Member | Description
LEFT_BOTTOM | Left bottom alignment.
LEFT_TOP | Left top alignment.
RIGHT_BOTTOM | Right bottom alignment.
RIGHT_BOTTON | Right bottom alignment.
RIGHT_TOP | Right top alignment.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTPinAlignment

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTSaveType Enumeration
com.accusoft.imagegear.art Package : ImGearARTSaveType Enumeration

Glossary Item Box

Specifies annotations save formats.

Members

Member | Description
LEGACY | Legacy ART 2.0 storage format.
WANG | WANG storage format.
XML | XML storage format.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTSaveType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

ImGearARTTextType Enumeration
com.accusoft.imagegear.art Package : ImGearARTTextType Enumeration

Glossary Item Box

Specifies a type of string in the text mark's "Text" property.

Members

Member | Description
DIRECT_TEXT | Text is stored directly in the mark.
FILE_NAME | Text is stored in the file specified by mark's "Text" property.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.art.ImGearARTTextType

See Also

Reference

com.accusoft.imagegear.art Package


%%PageItemTitle%%

IImGearARTCurve Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTCurve Interface

Glossary Item Box

Defines ART Curve mark interface.

Syntax

public interface IImGearARTCurve

See Also

Reference

IImGearARTCurve Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTCurve Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTCurve Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTCurve.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value.
Method | getPoint | Gets the point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array.
Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
Method | getTension | Gets the tension of the curve. Float value.
Method | getWidth | Gets the width of the mark. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | setOpacity | Sets the opacity of the mark. Integer value.
Method | setPoint | Sets the point with the specified index.
Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
Method | setTension | Sets the tension of the curve. Float value.
Method | setWidth | Sets the width of the mark. Integer value.
Top

See Also

Reference

IImGearARTCurve Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTCurve Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTCurve Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTCurve members.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value.
Method | getPoint | Gets the point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array.
Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
Method | getTension | Gets the tension of the curve. Float value.
Method | getWidth | Gets the width of the mark. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | setOpacity | Sets the opacity of the mark. Integer value.
Method | setPoint | Sets the point with the specified index.
Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
Method | setTension | Sets the tension of the curve. Float value.
Method | setWidth | Sets the width of the mark. Integer value.
Top

See Also

Reference

IImGearARTCurve Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

int getNumberOfPoints()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value.

Syntax

int getOpacity()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getPoint Method
index
Index of the point.

Glossary Item Box

Gets the point with the specified index.

Syntax

ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure.

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array.

Syntax

ImGearPoint[] getPoints()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getStyle Method

Glossary Item Box

Gets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getTension Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getTension Method

Glossary Item Box

Gets the tension of the curve.

Float value.

Syntax

float getTension()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value.

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets the point with the specified index.

Syntax

void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setStyle Method
value

Glossary Item Box

Sets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setTension Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setTension Method
value

Glossary Item Box

Sets the tension of the curve.

Float value.

Syntax

void setTension(
   float value
)

Parameters

value

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTCurve Interface : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTCurve Interface
IImGearARTCurve Members


%%PageItemTitle%%

IImGearARTEllipse Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTEllipse Interface

Glossary Item Box

Defines ART Ellipse mark interface.

Syntax

public interface IImGearARTEllipse

See Also

Reference

IImGearARTEllipse Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTEllipse Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTEllipse Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTEllipse.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | getOpacity | Gets the opacity of the mark. Integer value.
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | setOpacity | Sets the opacity of the mark. Integer value.
Top

See Also

Reference

IImGearARTEllipse Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTEllipse Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTEllipse Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTEllipse members.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object.
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | getOpacity | Gets the opacity of the mark. Integer value.
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object.
Method | setOpacity | Sets the opacity of the mark. Integer value.
Top

See Also

Reference

IImGearARTEllipse Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object.

Syntax

ImGearARTBorder getBorder()

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

IImGearRGBQuad getFillColor()

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value.

Syntax

int getOpacity()

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : setBorder Method
value

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object.

Syntax

void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object.

Syntax

void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTEllipse Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value.

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTEllipse Interface
IImGearARTEllipse Members


%%PageItemTitle%%

IImGearARTLine Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTLine Interface

Glossary Item Box

Defines ART Line mark interface.

Syntax

public interface IImGearARTLine

See Also

Reference

IImGearARTLine Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTLine Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTLine Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTLine.

Public Methods

 | Name | Description
Method | getColor | Gets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
Method | getEndHeadAngle | Gets the angle of the line's end head. Integer value.
Method | getEndHeadLength | Gets the length of the line's end head. Integer value.
Method | getEndHeadType | Gets the type of the line's end head. ImGearARTLineHeadType enumeration value.
Method | getEndPoint | Gets the end point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getOpacity | Gets the line opacity. Integer value.
Method | getStartHeadAngle | Gets the angle of the line's start head. Integer value.
Method | getStartHeadLength | Gets the length of the line's start head. Integer value.
Method | getStartHeadType | Gets the type of the line's start head. ImGearARTLineHeadType enumeration value.
Method | getStartPoint | Gets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | getStyle | Gets the style of the line. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the line width. Integer value.
Method | setColor | Sets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
Method | setEndHeadAngle | Sets the angle of the line's end head. Integer value.
Method | setEndHeadLength | Sets the length of the line's end head. Integer value.
Method | setEndHeadType | Sets the type of the line's end head. ImGearARTLineHeadType enumeration value.
Method | setEndPoint |
Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setOpacity | Sets the line opacity. Integer value.
Method | setStartHeadAngle | Sets the angle of the line's start head. Integer value.
Method | setStartHeadLength | Sets the length of the line's start head. Integer value.
Method | setStartHeadType | Sets the type of the line's start head.
Method | setStartPoint | Sets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | setStyle | Sets the style of the line. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the line width. Integer value.
Top

See Also

Reference

IImGearARTLine Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTLine Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTLine Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTLine members.

Public Methods

 | Name | Description
Method | getColor | Gets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
Method | getEndHeadAngle | Gets the angle of the line's end head. Integer value.
Method | getEndHeadLength | Gets the length of the line's end head. Integer value.
Method | getEndHeadType | Gets the type of the line's end head. ImGearARTLineHeadType enumeration value.
Method | getEndPoint | Gets the end point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getOpacity | Gets the line opacity. Integer value.
Method | getStartHeadAngle | Gets the angle of the line's start head. Integer value.
Method | getStartHeadLength | Gets the length of the line's start head. Integer value.
Method | getStartHeadType | Gets the type of the line's start head. ImGearARTLineHeadType enumeration value.
Method | getStartPoint | Gets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | getStyle | Gets the style of the line. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the line width. Integer value.
Method | setColor | Sets the line color. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad
Method | setEndHeadAngle | Sets the angle of the line's end head. Integer value.
Method | setEndHeadLength | Sets the length of the line's end head. Integer value.
Method | setEndHeadType | Sets the type of the line's end head. ImGearARTLineHeadType enumeration value.
Method | setEndPoint |
Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setOpacity | Sets the line opacity. Integer value.
Method | setStartHeadAngle | Sets the angle of the line's start head. Integer value.
Method | setStartHeadLength | Sets the length of the line's start head. Integer value.
Method | setStartHeadType | Sets the type of the line's start head.
Method | setStartPoint | Sets the start point of the line. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | setStyle | Sets the style of the line. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the line width. Integer value.
Top

See Also

Reference

IImGearARTLine Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getColor Method

Glossary Item Box

Gets the line color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getEndHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getEndHeadAngle Method

Glossary Item Box

Gets the angle of the line's end head.

Integer value.

Syntax

int getEndHeadAngle()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getEndHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getEndHeadLength Method

Glossary Item Box

Gets the length of the line's end head.

Integer value.

Syntax

int getEndHeadLength()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getEndHeadType Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getEndHeadType Method

Glossary Item Box

Gets the type of the line's end head.

ImGearARTLineHeadType enumeration value.

Syntax

ImGearARTLineHeadType getEndHeadType()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getEndPoint Method

Glossary Item Box

Gets the end point of the line.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint getEndPoint()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getHeadFillColor Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getHeadFillColor Method

Glossary Item Box

Gets the fill color of the line's head.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getHeadFillColor()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getOpacity Method

Glossary Item Box

Gets the line opacity.

Integer value.

Syntax

int getOpacity()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getStartHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getStartHeadAngle Method

Glossary Item Box

Gets the angle of the line's start head.

Integer value.

Syntax

int getStartHeadAngle()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getStartHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getStartHeadLength Method

Glossary Item Box

Gets the length of the line's start head.

Integer value.

Syntax

int getStartHeadLength()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getStartHeadType Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getStartHeadType Method

Glossary Item Box

Gets the type of the line's start head.

ImGearARTLineHeadType enumeration value.

Syntax

ImGearARTLineHeadType getStartHeadType()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getStartPoint Method

Glossary Item Box

Gets the start point of the line.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

ImGearPoint getStartPoint()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getStyle Method

Glossary Item Box

Gets the style of the line.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : getWidth Method

Glossary Item Box

Gets the line width.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setColor Method
value

Glossary Item Box

Sets the line color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setEndHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setEndHeadAngle Method
value

Glossary Item Box

Sets the angle of the line's end head.

Integer value.

Syntax

void setEndHeadAngle(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setEndHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setEndHeadLength Method
value

Glossary Item Box

Sets the length of the line's end head.

Integer value.

Syntax

void setEndHeadLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setEndHeadType Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setEndHeadType Method
value

Glossary Item Box

Sets the type of the line's end head.

ImGearARTLineHeadType enumeration value.

Syntax

void setEndHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setEndPoint Method
value

Glossary Item Box

Syntax

void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setHeadFillColor Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setHeadFillColor Method
value

Glossary Item Box

Sets the fill color of the line's head.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

void setHeadFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setOpacity Method
value

Glossary Item Box

Sets the line opacity.

Integer value.

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setStartHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setStartHeadAngle Method
value

Glossary Item Box

Sets the angle of the line's start head.

Integer value.

Syntax

void setStartHeadAngle(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setStartHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setStartHeadLength Method
value

Glossary Item Box

Sets the length of the line's start head.

Integer value.

Syntax

void setStartHeadLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setStartHeadType Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setStartHeadType Method
value
ImGearARTLineHeadType value to set.

Glossary Item Box

Sets the type of the line's start head.

Syntax

void setStartHeadType(
   ImGearARTLineHeadType value
)

Parameters

value
ImGearARTLineHeadType value to set.

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setStartPoint Method
value

Glossary Item Box

Sets the start point of the line.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setStyle Method
value

Glossary Item Box

Sets the style of the line.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTLine Interface : setWidth Method
value

Glossary Item Box

Sets the line width.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTLine Interface
IImGearARTLine Members


%%PageItemTitle%%

IImGearARTPoint Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPoint Interface

Glossary Item Box

Defines ART Point mark interface.

Syntax

public interface IImGearARTPoint

See Also

Reference

IImGearARTPoint Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTPoint Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPoint Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTPoint.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure.
Method | getOpacity | Gets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque).
Method | getWidth | Gets the width of the mark. Integer value.
Method | getX | Gets the X coordinate of the mark. Integer value.
Method | getY | Gets the Y coordinate of the mark. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure.
Method | setOpacity | Sets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque).
Method | setWidth | Sets the width of the mark. Integer value.
Method | setX | Sets the X coordinate of the mark. Integer value.
Method | setY | Sets the Y coordinate of the mark. Integer value.
Top

See Also

Reference

IImGearARTPoint Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTPoint Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPoint Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTPoint members.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure.
Method | getOpacity | Gets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque).
Method | getWidth | Gets the width of the mark. Integer value.
Method | getX | Gets the X coordinate of the mark. Integer value.
Method | getY | Gets the Y coordinate of the mark. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure.
Method | setOpacity | Sets the opacity of the mark. Any integer value from 0 (transparent) to 255 (opaque).
Method | setWidth | Sets the width of the mark. Integer value.
Method | setX | Sets the X coordinate of the mark. Integer value.
Method | setY | Sets the Y coordinate of the mark. Integer value.
Top

See Also

Reference

IImGearARTPoint Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure.

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Any integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : getX Method

Glossary Item Box

Gets the X coordinate of the mark.

Integer value.

Syntax

int getX()

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : getY Method

Glossary Item Box

Gets the Y coordinate of the mark.

Integer value.

Syntax

int getY()

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure.

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Any integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : setX Method
value

Glossary Item Box

Sets the X coordinate of the mark.

Integer value.

Syntax

void setX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.art Package > IImGearARTPoint Interface : setY Method
value

Glossary Item Box

Sets the Y coordinate of the mark.

Integer value.

Syntax

void setY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPoint Interface
IImGearARTPoint Members


%%PageItemTitle%%

IImGearARTPolygon Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolygon Interface

Glossary Item Box

Defines ART Polygon mark interface.

Syntax

public interface IImGearARTPolygon

See Also

Reference

IImGearARTPolygon Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTPolygon Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolygon Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTPolygon.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getNumberOfPoints | Gets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getOpacity | Gets the mark opacity. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setNumberOfPoints | Sets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setOpacity | Sets the mark opacity. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Top

See Also

Reference

IImGearARTPolygon Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTPolygon Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolygon Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTPolygon members.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getNumberOfPoints | Gets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getOpacity | Gets the mark opacity. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setNumberOfPoints | Sets the actual number of points on the mark. Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setOpacity | Sets the mark opacity. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Top

See Also

Reference

IImGearARTPolygon Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object. ImGearARTBorder

Syntax

ImGearARTBorder getBorder()

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

IImGearRGBQuad getFillColor()

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of points on the mark.

Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

int getNumberOfPoints()

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getOpacity Method

Glossary Item Box

Gets the mark opacity.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getPoint Method
index
The index of the point to get.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

ImGearPoint getPoint(
   int index
)

Parameters

index
The index of the point to get.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint[] getPoints()

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : setBorder Method
value

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object.

Syntax

void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of points on the mark.

Integer value. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : setOpacity Method
value

Glossary Item Box

Sets the mark opacity.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolygon Interface : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolygon Interface
IImGearARTPolygon Members


%%PageItemTitle%%

IImGearARTPolyline Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyline Interface

Glossary Item Box

Defines ART Polyline mark interface.

Syntax

public interface IImGearARTPolyline

See Also

Reference

IImGearARTPolyline Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTPolyline Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyline Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTPolyline.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getEndHeadAngle | Gets the end head angle of the mark. Integer value.
Method | getEndHeadLength | Gets the end head length of the mark. Integer value.
Method | getEndHeadType | Gets the end head type of the mark. ImGearARTLineHeadType enumeration value.
Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getStartHeadAngle | Gets the start head angle of the mark. Integer value.
Method | getStartHeadLength | Gets the start head length of the mark. Integer value.
Method | getStartHeadType | Gets the start head type of the mark. ImGearARTLineHeadType enumeration value.
Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the width of the mark. Integer value.
Method | isClosed | Gets a value indicating whether the polyline is closed. Boolean value.
Method | setClosed | Sets a value indicating whether the polyline is closed. Boolean value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setEndHeadAngle | Sets the end head angle of the mark. Integer value.
Method | setEndHeadLength | Sets the end head length of the mark. Integer value.
Method | setEndHeadType | Sets the end head type of the mark. ImGearARTLineHeadType enumeration value.
Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Method | setStartHeadAngle | Sets the start head angle of the mark. Integer value.
Method | setStartHeadLength | Sets the start head length of the mark. Integer value.
Method | setStartHeadType | Sets the start head type of the mark. ImGearARTLineHeadType enumeration value.
Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the width of the mark. Integer value.
Top

See Also

Reference

IImGearARTPolyline Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTPolyline Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyline Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTPolyline members.

Public Methods

 | Name | Description
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getEndHeadAngle | Gets the end head angle of the mark. Integer value.
Method | getEndHeadLength | Gets the end head length of the mark. Integer value.
Method | getEndHeadType | Gets the end head type of the mark. ImGearARTLineHeadType enumeration value.
Method | getHeadFillColor | Gets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getStartHeadAngle | Gets the start head angle of the mark. Integer value.
Method | getStartHeadLength | Gets the start head length of the mark. Integer value.
Method | getStartHeadType | Gets the start head type of the mark. ImGearARTLineHeadType enumeration value.
Method | getStyle | Gets the style of the mark. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the width of the mark. Integer value.
Method | isClosed | Gets a value indicating whether the polyline is closed. Boolean value.
Method | setClosed | Sets a value indicating whether the polyline is closed. Boolean value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setEndHeadAngle | Sets the end head angle of the mark. Integer value.
Method | setEndHeadLength | Sets the end head length of the mark. Integer value.
Method | setEndHeadType | Sets the end head type of the mark. ImGearARTLineHeadType enumeration value.
Method | setHeadFillColor | Sets the fill color of the line's head. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Method | setStartHeadAngle | Sets the start head angle of the mark. Integer value.
Method | setStartHeadLength | Sets the start head length of the mark. Integer value.
Method | setStartHeadType | Sets the start head type of the mark. ImGearARTLineHeadType enumeration value.
Method | setStyle | Sets the style of the mark. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the width of the mark. Integer value.
Top

See Also

Reference

IImGearARTPolyline Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getEndHeadAngle Method

Glossary Item Box

Gets the end head angle of the mark.

Integer value.

Syntax

int getEndHeadAngle()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getEndHeadLength Method

Glossary Item Box

Gets the end head length of the mark.

Integer value.

Syntax

int getEndHeadLength()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getEndHeadType Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getEndHeadType Method

Glossary Item Box

Gets the end head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

ImGearARTLineHeadType getEndHeadType()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getHeadFillColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getHeadFillColor Method

Glossary Item Box

Gets the fill color of the line's head.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getHeadFillColor()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

int getNumberOfPoints()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getPoint Method
index
Index of the point.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint[] getPoints()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getStartHeadAngle Method

Glossary Item Box

Gets the start head angle of the mark.

Integer value.

Syntax

int getStartHeadAngle()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getStartHeadLength Method

Glossary Item Box

Gets the start head length of the mark.

Integer value.

Syntax

int getStartHeadLength()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getStartHeadType Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getStartHeadType Method

Glossary Item Box

Gets the start head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

ImGearARTLineHeadType getStartHeadType()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getStyle Method

Glossary Item Box

Gets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : getWidth Method

Glossary Item Box

Gets the width of the mark.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

isClosed Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : isClosed Method

Glossary Item Box

Gets a value indicating whether the polyline is closed.

Boolean value.

Syntax

boolean isClosed()

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setClosed Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setClosed Method
value

Glossary Item Box

Sets a value indicating whether the polyline is closed.

Boolean value.

Syntax

void setClosed(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setEndHeadAngle Method
value

Glossary Item Box

Sets the end head angle of the mark.

Integer value.

Syntax

void setEndHeadAngle(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setEndHeadLength Method
value

Glossary Item Box

Sets the end head length of the mark.

Integer value.

Syntax

void setEndHeadLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setEndHeadType Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setEndHeadType Method
value

Glossary Item Box

Sets the end head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

void setEndHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setHeadFillColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setHeadFillColor Method
value

Glossary Item Box

Sets the fill color of the line's head.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

void setHeadFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of mark's points.

Integer value.

Syntax

void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadAngle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setStartHeadAngle Method
value

Glossary Item Box

Sets the start head angle of the mark.

Integer value.

Syntax

void setStartHeadAngle(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setStartHeadLength Method
value

Glossary Item Box

Sets the start head length of the mark.

Integer value.

Syntax

void setStartHeadLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setStartHeadType Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setStartHeadType Method
value

Glossary Item Box

Sets the start head type of the mark.

ImGearARTLineHeadType enumeration value.

Syntax

void setStartHeadType(
   ImGearARTLineHeadType value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setStyle Method
value

Glossary Item Box

Sets the style of the mark.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTPolyline Interface : setWidth Method
value

Glossary Item Box

Sets the width of the mark.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyline Interface
IImGearARTPolyline Members


%%PageItemTitle%%

IImGearARTPolyRuler Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyRuler Interface

Glossary Item Box

Defines ART Polyline Ruler mark interface.

Syntax

public interface IImGearARTPolyRuler

See Also

Reference

IImGearARTPolyRuler Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTPolyRuler Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyRuler Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTPolyRuler.

Public Methods

 | Name | Description
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getEndLineLength | Gets the length of the mark's end line. Integer value.
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | getLabel | Gets the mark label. String value.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartLineLength | Gets the length of the mark's start line. Integer value.
Method | getStyle | Gets the mark's line style. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the mark's line width. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setEndLineLength | Sets the length of the mark's end line. Integer value.
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | setLabel | Sets the mark label. String value.
Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartLineLength | Sets the length of the mark's start line. Integer value.
Method | setStyle | Sets the mark's line style. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the mark's line width. Integer value.
Top

See Also

Reference

IImGearARTPolyRuler Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTPolyRuler Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTPolyRuler Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTPolyRuler members.

Public Methods

 | Name | Description
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getEndLineLength | Gets the length of the mark's end line. Integer value.
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | getLabel | Gets the mark label. String value.
Method | getNumberOfPoints | Gets the actual number of mark's points. Integer value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPoint | Gets mark's point with the specified index.
Method | getPoints | Gets the raw points array. com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartLineLength | Gets the length of the mark's start line. Integer value.
Method | getStyle | Gets the mark's line style. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the mark's line width. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setEndLineLength | Sets the length of the mark's end line. Integer value.
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | setLabel | Sets the mark label. String value.
Method | setNumberOfPoints | Sets the actual number of mark's points. Integer value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPoint | Sets mark's point at the specified index.
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartLineLength | Sets the length of the mark's start line. Integer value.
Method | setStyle | Sets the mark's line style. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the mark's line width. Integer value.
Top

See Also

Reference

IImGearARTPolyRuler Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorX()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorY()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorX()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getAspectNumeratorY Method

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorY()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getEndLineLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getEndLineLength Method

Glossary Item Box

Gets the length of the mark's end line.

Integer value.

Syntax

int getEndLineLength()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

boolean getFontDisablePPM()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

Syntax

java.lang.String getFontName()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

Syntax

float getFontSize()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getLabel Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getLabel Method

Glossary Item Box

Gets the mark label.

String value.

Syntax

java.lang.String getLabel()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getNumberOfPoints Method

Glossary Item Box

Gets the actual number of mark's points.

Integer value.

Syntax

int getNumberOfPoints()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getPoint Method
index
Index of the point.

Glossary Item Box

Gets mark's point with the specified index.

Syntax

ImGearPoint getPoint(
   int index
)

Parameters

index
Index of the point.

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getPoints Method

Glossary Item Box

Gets the raw points array.

com.accusoft.imagegear.core.shapes.ImGearPoint structure array. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint[] getPoints()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

Syntax

int getPrecision()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getStartLineLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getStartLineLength Method

Glossary Item Box

Gets the length of the mark's start line.

Integer value.

Syntax

int getStartLineLength()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getStyle Method

Glossary Item Box

Gets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : getWidth Method

Glossary Item Box

Gets the mark's line width.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setAspectNumeratorY Method
value

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setEndLineLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setEndLineLength Method
value

Glossary Item Box

Sets the length of the mark's end line.

Integer value.

Syntax

void setEndLineLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

Syntax

void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

Syntax

void setFontSize(
   float value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setLabel Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setLabel Method
value

Glossary Item Box

Sets the mark label.

String value.

Syntax

void setLabel(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setNumberOfPoints Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setNumberOfPoints Method
value

Glossary Item Box

Sets the actual number of mark's points.

Integer value.

Syntax

void setNumberOfPoints(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setPoint Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setPoint Method
index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

Glossary Item Box

Sets mark's point at the specified index.

Syntax

void setPoint(
   int index,
   ImGearPoint point
)

Parameters

index
Index of the point.
point
The point to set. com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

Syntax

void setPrecision(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setStartLineLength Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setStartLineLength Method
value

Glossary Item Box

Sets the length of the mark's start line.

Integer value.

Syntax

void setStartLineLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setStyle Method
value

Glossary Item Box

Sets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTPolyRuler Interface : setWidth Method
value

Glossary Item Box

Sets the mark's line width.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTPolyRuler Interface
IImGearARTPolyRuler Members


%%PageItemTitle%%

IImGearARTProtractor Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTProtractor Interface

Glossary Item Box

Defines ART Protractor mark interface.

Syntax

public interface IImGearARTProtractor

See Also

Reference

IImGearARTProtractor Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTProtractor Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTProtractor Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTProtractor.

Public Methods

 | Name | Description
Method | getArcRadius | Gets the radius of the arc drawn in the mark. Integer value.
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the mark color. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getEndPoint | Gets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any Float positive value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration.
Method | getHeadPoint | Gets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartPoint | Gets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | getStyle | Gets the style of the mark's line. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the width of the mark's line. Integer value.
Method | setArcRadius | Sets the radius of the arc drawn in the mark. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the mark color. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setEndPoint | Sets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any Float positive value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration.
Method | setHeadPoint | Sets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartPoint | Sets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | setStyle | Sets the style of the mark's line. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the width of the mark's line. Integer value.
Top

See Also

Reference

IImGearARTProtractor Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTProtractor Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTProtractor Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTProtractor members.

Public Methods

 | Name | Description
Method | getArcRadius | Gets the radius of the arc drawn in the mark. Integer value.
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the mark color. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getEndPoint | Gets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any Float positive value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration.
Method | getHeadPoint | Gets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartPoint | Gets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | getStyle | Gets the style of the mark's line. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the width of the mark's line. Integer value.
Method | setArcRadius | Sets the radius of the arc drawn in the mark. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the mark color. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setEndPoint | Sets the end point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any Float positive value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration.
Method | setHeadPoint | Sets the head point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartPoint | Sets the start point of the protractor. com.accusoft.imagegear.core.shapes.ImGearPoint structure object.
Method | setStyle | Sets the style of the mark's line. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the width of the mark's line. Integer value.
Top

See Also

Reference

IImGearARTProtractor Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getArcRadius Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getArcRadius Method

Glossary Item Box

Gets the radius of the arc drawn in the mark.

Integer value.

Syntax

int getArcRadius()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorX()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorY()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorX()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getAspectNumeratorY Method

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorY()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getColor Method

Glossary Item Box

Gets the mark color.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getEndPoint Method

Glossary Item Box

Gets the end point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint getEndPoint()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

boolean getFontDisablePPM()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

Syntax

java.lang.String getFontName()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any Float positive value.

Syntax

float getFontSize()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration.

Syntax

java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getHeadPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getHeadPoint Method

Glossary Item Box

Gets the head point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint getHeadPoint()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

Syntax

int getPrecision()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getStartPoint Method

Glossary Item Box

Gets the start point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

ImGearPoint getStartPoint()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getStyle Method

Glossary Item Box

Gets the style of the mark's line.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : getWidth Method

Glossary Item Box

Gets the width of the mark's line.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setArcRadius Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setArcRadius Method
value

Glossary Item Box

Sets the radius of the arc drawn in the mark.

Integer value.

Syntax

void setArcRadius(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setAspectNumeratorY Method
value

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setColor Method
value

Glossary Item Box

Sets the mark color.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setEndPoint Method
value

Glossary Item Box

Sets the end point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

Syntax

void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any Float positive value.

Syntax

void setFontSize(
   float value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration.

Syntax

void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setHeadPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setHeadPoint Method
value

Glossary Item Box

Sets the head point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

void setHeadPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

Syntax

void setPrecision(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setStartPoint Method
value

Glossary Item Box

Sets the start point of the protractor.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object.

Syntax

void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setStyle Method
value

Glossary Item Box

Sets the style of the mark's line.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTProtractor Interface : setWidth Method
value

Glossary Item Box

Sets the width of the mark's line.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTProtractor Interface
IImGearARTProtractor Members


%%PageItemTitle%%

IImGearARTRectangle Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRectangle Interface

Glossary Item Box

Defines ART Rectangle mark interface.

Syntax

public interface IImGearARTRectangle

See Also

Reference

IImGearARTRectangle Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTRectangle Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRectangle Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTRectangle.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getOpacity | Gets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque).
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setOpacity | Sets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque).
Top

See Also

Reference

IImGearARTRectangle Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTRectangle Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRectangle Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTRectangle members.

Public Methods

 | Name | Description
Method | getBorder | Gets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | getOpacity | Gets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque).
Method | setBorder | Sets the border of the mark. ImGearARTBorder class object. ImGearARTBorder
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.
Method | setOpacity | Sets the opacity of the rectangle. Integer value from 0 (transparent) to 255 (opaque).
Top

See Also

Reference

IImGearARTRectangle Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : getBorder Method

Glossary Item Box

Gets the border of the mark.

ImGearARTBorder class object. ImGearARTBorder

Syntax

ImGearARTBorder getBorder()

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getFillColor()

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the rectangle.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : setBorder Method
value

Glossary Item Box

Sets the border of the mark.

ImGearARTBorder class object. ImGearARTBorder

Syntax

void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface.

Syntax

void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTRectangle Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the rectangle.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRectangle Interface
IImGearARTRectangle Members


%%PageItemTitle%%

IImGearARTRuler Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRuler Interface

Glossary Item Box

Defines ART Ruler mark interface.

Syntax

public interface IImGearARTRuler

See Also

Reference

IImGearARTRuler Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTRuler Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRuler Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTRuler.

Public Methods

 | Name | Description
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getEndLineLength | Gets the length of the mark's end line. Integer value.
Method | getEndPoint | Gets the end point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | getLabel | Gets the mark label. String value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartLineLength | Gets the length of the mark's start line. Integer value.
Method | getStartPoint | Gets the start point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getStyle | Gets the mark's line style. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the mark's line width. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setEndLineLength | Sets the length of the mark's end line. Integer value.
Method | setEndPoint | Sets the end point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | setLabel | Sets the mark label. String value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartLineLength | Sets the length of the mark's start line. Integer value.
Method | setStartPoint | Sets the start point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setStyle | Sets the mark's line style. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the mark's line width. Integer value.
Top

See Also

Reference

IImGearARTRuler Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTRuler Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTRuler Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTRuler members.

Public Methods

 | Name | Description
Method | getAspectDenominatorX | Gets the mark's X aspect denominator value. Integer value.
Method | getAspectDenominatorY | Gets the Mark's Y aspect denominator value. Integer value.
Method | getAspectNumeratorX | Gets the mark's X aspect numerator value. Integer value.
Method | getAspectNumeratorY | Gets the mark's Y aspect numerator value. Integer value.
Method | getColor | Gets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | getEndLineLength | Gets the length of the mark's end line. Integer value.
Method | getEndPoint | Gets the end point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the text font. String value.
Method | getFontSize | Gets the font pointSize of the text font. Any positive float value.
Method | getFontStyleART | Gets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | getLabel | Gets the mark label. String value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | getPrecision | Gets the number of decimal digits displayed for the mark. Integer value.
Method | getStartLineLength | Gets the length of the mark's start line. Integer value.
Method | getStartPoint | Gets the start point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | getStyle | Gets the mark's line style. ImGearARTPenStyle enumeration value.
Method | getWidth | Gets the mark's line width. Integer value.
Method | setAspectDenominatorX | Sets the mark's X aspect denominator value. Integer value.
Method | setAspectDenominatorY | Sets the Mark's Y aspect denominator value. Integer value.
Method | setAspectNumeratorX | Sets the mark's X aspect numerator value. Integer value.
Method | setAspectNumeratorY | Sets the mark's Y aspect numerator value. Integer value.
Method | setColor | Sets the color of the mark. com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad
Method | setEndLineLength | Sets the length of the mark's end line. Integer value.
Method | setEndPoint | Sets the end point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the text font. String value.
Method | setFontSize | Sets the font pointSize of the text font. Any positive float value.
Method | setFontStyleART | Sets the font style of the text font. Aggregates of ImGearARTFontStyles enumeration value.
Method | setLabel | Sets the mark label. String value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque).
Method | setPrecision | Sets the number of decimal digits displayed for the mark. Integer value.
Method | setStartLineLength | Sets the length of the mark's start line. Integer value.
Method | setStartPoint | Sets the start point of the mark. com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint
Method | setStyle | Sets the mark's line style. ImGearARTPenStyle enumeration value.
Method | setWidth | Sets the mark's line width. Integer value.
Top

See Also

Reference

IImGearARTRuler Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getAspectDenominatorX Method

Glossary Item Box

Gets the mark's X aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorX()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getAspectDenominatorY Method

Glossary Item Box

Gets the Mark's Y aspect denominator value.

Integer value.

Syntax

int getAspectDenominatorY()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getAspectNumeratorX Method

Glossary Item Box

Gets the mark's X aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorX()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getAspectNumeratorY Method

Glossary Item Box

Gets the mark's Y aspect numerator value.

Integer value.

Syntax

int getAspectNumeratorY()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getColor Method

Glossary Item Box

Gets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getEndLineLength Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getEndLineLength Method

Glossary Item Box

Gets the length of the mark's end line.

Integer value.

Syntax

int getEndLineLength()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getEndPoint Method

Glossary Item Box

Gets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint getEndPoint()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

boolean getFontDisablePPM()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getFontName Method

Glossary Item Box

Gets the font name of the text font.

String value.

Syntax

java.lang.String getFontName()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getFontSize Method

Glossary Item Box

Gets the font pointSize of the text font.

Any positive float value.

Syntax

float getFontSize()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getFontStyleART Method

Glossary Item Box

Gets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getLabel Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getLabel Method

Glossary Item Box

Gets the mark label.

String value.

Syntax

java.lang.String getLabel()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

int getOpacity()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getPrecision Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getPrecision Method

Glossary Item Box

Gets the number of decimal digits displayed for the mark.

Integer value.

Syntax

int getPrecision()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getStartLineLength Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getStartLineLength Method

Glossary Item Box

Gets the length of the mark's start line.

Integer value.

Syntax

int getStartLineLength()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getStartPoint Method

Glossary Item Box

Gets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

ImGearPoint getStartPoint()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getStyle Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getStyle Method

Glossary Item Box

Gets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

ImGearARTPenStyle getStyle()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : getWidth Method

Glossary Item Box

Gets the mark's line width.

Integer value.

Syntax

int getWidth()

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setAspectDenominatorX Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setAspectDenominatorX Method
value

Glossary Item Box

Sets the mark's X aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setAspectDenominatorY Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setAspectDenominatorY Method
value

Glossary Item Box

Sets the Mark's Y aspect denominator value.

Integer value.

Syntax

void setAspectDenominatorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setAspectNumeratorX Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setAspectNumeratorX Method
value

Glossary Item Box

Sets the mark's X aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorX(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setAspectNumeratorY Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setAspectNumeratorY Method
value

Glossary Item Box

Sets the mark's Y aspect numerator value.

Integer value.

Syntax

void setAspectNumeratorY(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setColor Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setColor Method
value

Glossary Item Box

Sets the color of the mark.

com.accusoft.imagegear.core.IImGearRGBQuad structure object interface. com.accusoft.imagegear.core.IImGearRGBQuad

Syntax

void setColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setEndLineLength Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setEndLineLength Method
value

Glossary Item Box

Sets the length of the mark's end line.

Integer value.

Syntax

void setEndLineLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setEndPoint Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setEndPoint Method
value

Glossary Item Box

Sets the end point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

void setEndPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setFontName Method
value

Glossary Item Box

Sets the font name of the text font.

String value.

Syntax

void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the text font.

Any positive float value.

Syntax

void setFontSize(
   float value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the text font.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setLabel Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setLabel Method
value

Glossary Item Box

Sets the mark label.

String value.

Syntax

void setLabel(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setPrecision Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setPrecision Method
value

Glossary Item Box

Sets the number of decimal digits displayed for the mark.

Integer value.

Syntax

void setPrecision(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setStartLineLength Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setStartLineLength Method
value

Glossary Item Box

Sets the length of the mark's start line.

Integer value.

Syntax

void setStartLineLength(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setStartPoint Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setStartPoint Method
value

Glossary Item Box

Sets the start point of the mark.

com.accusoft.imagegear.core.shapes.ImGearPoint structure object. com.accusoft.imagegear.core.shapes.ImGearPoint

Syntax

void setStartPoint(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setStyle Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setStyle Method
value

Glossary Item Box

Sets the mark's line style.

ImGearARTPenStyle enumeration value.

Syntax

void setStyle(
   ImGearARTPenStyle value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.art Package > IImGearARTRuler Interface : setWidth Method
value

Glossary Item Box

Sets the mark's line width.

Integer value.

Syntax

void setWidth(
   int value
)

Parameters

value

See Also

Reference

IImGearARTRuler Interface
IImGearARTRuler Members


%%PageItemTitle%%

IImGearARTText Interface
See Also Members Send Feedback
com.accusoft.imagegear.art Package : IImGearARTText Interface

Glossary Item Box

Defines ART Text mark interface.

Syntax

public interface IImGearARTText

See Also

Reference

IImGearARTText Members
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearARTText Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.art Package : IImGearARTText Interface

Glossary Item Box

The following tables list the members exposed by IImGearARTText.

Public Methods

 | Name | Description
Method | getActualText | Gets the actual text you can see on display. String value. getText
Method | getBorder | Gets the mark border. ImGearARTBorder class object.
Method | getBorderShading | Gets a value indicating whether the border is shaded or not. Boolean value.
Method | getCallout | Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the mark text. String value.
Method | getFontSize | Gets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a different opacity value for text element, please use setTextOpacity method.
Method | getPin | Gets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object.
Method | getText | Gets the text of the mark. String value. getActualText
Method | getTextColor | Gets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | getTextOpacity | Gets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.
Method | getTextTrimming | Gets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
Method | getTextType | Gets the text type. ImGearARTTextType enumeration value. getText getActualText
Method | setActualText | Sets the actual text you can see on display. String value. getText
Method | setBorder | Sets the mark border. ImGearARTBorder class object.
Method | setBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
Method | setCallout | Sets of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the mark text. String value.
Method | setFontSize | Sets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use setTextOpacity method.
Method | setPin | Sets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object.
Method | setText | Sets the text of the mark. String value. getActualText
Method | setTextColor | Sets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | setTextOpacity | Sets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.
Method | setTextTrimming | Sets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
Method | setTextType | Sets the text type. ImGearARTTextType enumeration value. getText getActualText
Top

See Also

Reference

IImGearARTText Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearARTText Interface Methods
See Also Send Feedback
com.accusoft.imagegear.art Package : IImGearARTText Interface

Glossary Item Box

For a list of all members of this type, see IImGearARTText members.

Public Methods

 | Name | Description
Method | getActualText | Gets the actual text you can see on display. String value. getText
Method | getBorder | Gets the mark border. ImGearARTBorder class object.
Method | getBorderShading | Gets a value indicating whether the border is shaded or not. Boolean value.
Method | getCallout | Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
Method | getFillColor | Gets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | getFontDisablePPM | Gets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | getFontName | Gets the font name of the mark text. String value.
Method | getFontSize | Gets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
Method | getFontStyleART | Gets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
Method | getOpacity | Gets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a different opacity value for text element, please use setTextOpacity method.
Method | getPin | Gets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object.
Method | getText | Gets the text of the mark. String value. getActualText
Method | getTextColor | Gets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | getTextOpacity | Gets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.
Method | getTextTrimming | Gets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
Method | getTextType | Gets the text type. ImGearARTTextType enumeration value. getText getActualText
Method | setActualText | Sets the actual text you can see on display. String value. getText
Method | setBorder | Sets the mark border. ImGearARTBorder class object.
Method | setBorderShading | Sets a value indicating whether the border is shaded or not. Boolean value.
Method | setCallout | Sets of the ImGearARTCallout class object that specifies mark's callout attributes. ImGearARTCallout class object.
Method | setFillColor | Sets the fill color of the mark. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | setFontDisablePPM | Sets a value indicating whether the PPM option is disabled in font pointSize calculations. Boolean value. True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.
Method | setFontName | Sets the font name of the mark text. String value.
Method | setFontSize | Sets the font pointSize of the mark text. Any positive float value. The font pointSize is measured in points.
Method | setFontStyleART | Sets the font style of the mark text. Aggregates of ImGearARTFontStyles enumeration value.
Method | setOpacity | Sets the opacity of the mark. Integer value from 0 (transparent) to 255 (opaque). This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use setTextOpacity method.
Method | setPin | Sets the ImGearARTPin object that specifies mark's pin icon attributes. ImGearARTPin class object.
Method | setText | Sets the text of the mark. String value. getActualText
Method | setTextColor | Sets the color of the mark text. com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.
Method | setTextOpacity | Sets a separate opacity used for text string. Integer value from 0 (transparent) to 255 (opaque). When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.
Method | setTextTrimming | Sets the text trimming behavior to employ when content overflows the content area. ImGearARTTextTrimming enumeration value.
Method | setTextType | Sets the text type. ImGearARTTextType enumeration value. getText getActualText
Top

See Also

Reference

IImGearARTText Interface
com.accusoft.imagegear.art Package


%%PageItemTitle%%

getActualText Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getActualText Method

Glossary Item Box

Gets the actual text you can see on display.

String value.

getText

Syntax

java.lang.String getActualText()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getBorder Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getBorder Method

Glossary Item Box

Gets the mark border.

ImGearARTBorder class object.

Syntax

ImGearARTBorder getBorder()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getBorderShading Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getBorderShading Method

Glossary Item Box

Gets a value indicating whether the border is shaded or not.

Boolean value.

Syntax

boolean getBorderShading()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getCallout Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getCallout Method

Glossary Item Box

Gets a value of the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object.

Syntax

ImGearARTCallout getCallout()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getFillColor Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getFillColor Method

Glossary Item Box

Gets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getFillColor()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getFontDisablePPM Method

Glossary Item Box

Gets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

boolean getFontDisablePPM()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getFontName Method

Glossary Item Box

Gets the font name of the mark text.

String value.

Syntax

java.lang.String getFontName()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getFontSize Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getFontSize Method

Glossary Item Box

Gets the font pointSize of the mark text.

Any positive float value.

The font pointSize is measured in points.

Syntax

float getFontSize()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getFontStyleART Method

Glossary Item Box

Gets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

java.util.EnumSet<ImGearARTFontStyles> getFontStyleART()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getOpacity Method

Glossary Item Box

Gets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

This Opacity is used for all elements of the mark by default. If you need to set a different opacity value for text element, please use setTextOpacity method.

Syntax

int getOpacity()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getPin Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getPin Method

Glossary Item Box

Gets the ImGearARTPin object that specifies mark's pin icon attributes.

ImGearARTPin class object.

Syntax

ImGearARTPin getPin()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getText Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getText Method

Glossary Item Box

Gets the text of the mark.

String value.

getActualText

Syntax

java.lang.String getText()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getTextColor Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getTextColor Method

Glossary Item Box

Gets the color of the mark text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

IImGearRGBQuad getTextColor()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getTextOpacity Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getTextOpacity Method

Glossary Item Box

Gets a separate opacity used for text string.

Integer value from 0 (transparent) to 255 (opaque).

When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.

Syntax

int getTextOpacity()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getTextTrimming Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getTextTrimming Method

Glossary Item Box

Gets the text trimming behavior to employ when content overflows the content area.

ImGearARTTextTrimming enumeration value.

Syntax

ImGearARTTextTrimming getTextTrimming()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

getTextType Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : getTextType Method

Glossary Item Box

Gets the text type.

ImGearARTTextType enumeration value.

getText
getActualText

Syntax

ImGearARTTextType getTextType()

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setActualText Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setActualText Method
value

Glossary Item Box

Sets the actual text you can see on display.

String value.

getText

Syntax

void setActualText(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setBorder Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setBorder Method
value

Glossary Item Box

Sets the mark border.

ImGearARTBorder class object.

Syntax

void setBorder(
   ImGearARTBorder value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setBorderShading Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setBorderShading Method
value

Glossary Item Box

Sets a value indicating whether the border is shaded or not.

Boolean value.

Syntax

void setBorderShading(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setCallout Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setCallout Method
value

Glossary Item Box

Sets of the ImGearARTCallout class object that specifies mark's callout attributes.

ImGearARTCallout class object.

Syntax

void setCallout(
   ImGearARTCallout value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setFillColor Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setFillColor Method
value

Glossary Item Box

Sets the fill color of the mark.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

void setFillColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setFontDisablePPM Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setFontDisablePPM Method
value

Glossary Item Box

Sets a value indicating whether the PPM option is disabled in font pointSize calculations.

Boolean value.

True - disables PPM and display parameters in font pointSize calculations for the current mark, False - enables font pointSize calculations.

Syntax

void setFontDisablePPM(
   boolean value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setFontName Method
value

Glossary Item Box

Sets the font name of the mark text.

String value.

Syntax

void setFontName(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setFontSize Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setFontSize Method
value

Glossary Item Box

Sets the font pointSize of the mark text.

Any positive float value.

The font pointSize is measured in points.

Syntax

void setFontSize(
   float value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setFontStyleART Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setFontStyleART Method
value

Glossary Item Box

Sets the font style of the mark text.

Aggregates of ImGearARTFontStyles enumeration value.

Syntax

void setFontStyleART(
   java.util.EnumSet<ImGearARTFontStyles> value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setOpacity Method
value

Glossary Item Box

Sets the opacity of the mark.

Integer value from 0 (transparent) to 255 (opaque).

This Opacity is used for all elements of the mark by default. If you need to set a differ opacity value for text element, please use setTextOpacity method.

Syntax

void setOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setPin Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setPin Method
value

Glossary Item Box

Sets the ImGearARTPin object that specifies mark's pin icon attributes.

ImGearARTPin class object.

Syntax

void setPin(
   ImGearARTPin value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setText Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setText Method
value

Glossary Item Box

Sets the text of the mark.

String value.

getActualText

Syntax

void setText(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setTextColor Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setTextColor Method
value

Glossary Item Box

Sets the color of the mark text.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface.

Syntax

void setTextColor(
   IImGearRGBQuad value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setTextOpacity Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setTextOpacity Method
value

Glossary Item Box

Sets a separate opacity used for text string.

Integer value from 0 (transparent) to 255 (opaque).

When set to non-negative value, specifies separate opacity used for text string only, otherwise text is displayed with the opacity provided by the getOpacity method used to set the opacity for the entire mark.

Syntax

void setTextOpacity(
   int value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setTextTrimming Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setTextTrimming Method
value

Glossary Item Box

Sets the text trimming behavior to employ when content overflows the content area.

ImGearARTTextTrimming enumeration value.

Syntax

void setTextTrimming(
   ImGearARTTextTrimming value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%PageItemTitle%%

setTextType Method
com.accusoft.imagegear.art Package > IImGearARTText Interface : setTextType Method
value

Glossary Item Box

Sets the text type.

ImGearARTTextType enumeration value.

getText
getActualText

Syntax

void setTextType(
   ImGearARTTextType value
)

Parameters

value

See Also

Reference

IImGearARTText Interface
IImGearARTText Members


%%ItemTitle%%

com.accusoft.imagegear.callbackinterfaces Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Interfaces used to notify clients of certain events.

Interfaces

Interface | Description
IImGearNotifyPropertyChanged | Implemented by Image Gear for Java SDK classes. They notify subscribers, i.e. IImGearPropertyChangedListeners that a property has changed by calling IImGearPropertyChangedListener.propertyChanged
IImGearPropertyChangedListener | To be implemented by clients wishing to be notified of property changes. Subscribe and unsubscribe for notifications in classes implementing IImGearNotifyPropertyChanged.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.callbackinterfaces Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

IImGearNotifyPropertyChanged Interface
See Also Members Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearNotifyPropertyChanged Interface

Glossary Item Box

Implemented by Image Gear for Java SDK classes.

They notify subscribers, i.e. IImGearPropertyChangedListeners that a property has changed by calling IImGearPropertyChangedListener.propertyChanged

Syntax

public interface IImGearNotifyPropertyChanged

See Also

Reference

IImGearNotifyPropertyChanged Members
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearNotifyPropertyChanged Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearNotifyPropertyChanged Interface

Glossary Item Box

The following tables list the members exposed by IImGearNotifyPropertyChanged.

Public Methods

 | Name | Description
Method | subscribeToPropertyChangeNotifications | Allows clients to add their listener implementation to be notified of changes.
Method | unsubscribeToPropertyChangeNotifications | Allows clients to remove their listeners.
Top

See Also

Reference

IImGearNotifyPropertyChanged Interface
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearNotifyPropertyChanged Interface Methods
See Also Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearNotifyPropertyChanged Interface

Glossary Item Box

For a list of all members of this type, see IImGearNotifyPropertyChanged members.

Public Methods

 | Name | Description
Method | subscribeToPropertyChangeNotifications | Allows clients to add their listener implementation to be notified of changes.
Method | unsubscribeToPropertyChangeNotifications | Allows clients to remove their listeners.
Top

See Also

Reference

IImGearNotifyPropertyChanged Interface
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.callbackinterfaces Package > IImGearNotifyPropertyChanged Interface : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

IImGearNotifyPropertyChanged Interface
IImGearNotifyPropertyChanged Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.callbackinterfaces Package > IImGearNotifyPropertyChanged Interface : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

IImGearNotifyPropertyChanged Interface
IImGearNotifyPropertyChanged Members


%%PageItemTitle%%

IImGearPropertyChangedListener Interface
See Also Members Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearPropertyChangedListener Interface

Glossary Item Box

To be implemented by clients wishing to be notified of property changes. Subscribe and unsubscribe for notifications in classes implementing IImGearNotifyPropertyChanged.

Syntax

public interface IImGearPropertyChangedListener

See Also

Reference

IImGearPropertyChangedListener Members
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearPropertyChangedListener Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearPropertyChangedListener Interface

Glossary Item Box

The following tables list the members exposed by IImGearPropertyChangedListener.

Public Methods

 | Name | Description
Method | propertyChanged | Notification callback implemented by client.
Top

See Also

Reference

IImGearPropertyChangedListener Interface
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearPropertyChangedListener Interface Methods
See Also Send Feedback
com.accusoft.imagegear.callbackinterfaces Package : IImGearPropertyChangedListener Interface

Glossary Item Box

For a list of all members of this type, see IImGearPropertyChangedListener members.

Public Methods

 | Name | Description
Method | propertyChanged | Notification callback implemented by client.
Top

See Also

Reference

IImGearPropertyChangedListener Interface
com.accusoft.imagegear.callbackinterfaces Package


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.callbackinterfaces Package > IImGearPropertyChangedListener Interface : propertyChanged Method
sender
Object invoking the callback.
property
Name of the property that has changed.

Glossary Item Box

Notification callback implemented by client.

Syntax

void propertyChanged(
   java.lang.Object sender,
   java.lang.String property
)

Parameters

sender
Object invoking the callback.
property
Name of the property that has changed.

See Also

Reference

IImGearPropertyChangedListener Interface
IImGearPropertyChangedListener Members


%%ItemTitle%%

com.accusoft.imagegear.core Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package is the basis of the ImageGear for Java toolkit. This package contains classes to operate with graphics primitives, license the product and, most importantly, primary ImageGear entities like page and document.

Classes

Class | Description
ImGearArray | Container of an array of arbitrary type.
ImGearArrayRef | Represents a reference to a particular location in an array.
ImGearChannelRange Describes channels to be processed with com.accusoft.imagegear.processing.ImGearProcessing class methods.

This structure is passed to some processing methods such as com.accusoft.imagegear.processing.ImGearRasterProcessing.adjustContrast.

com.accusoft.imagegear.processing.ImGearRasterProcessing

ImGearColorBook | Represents a color book.
ImGearColorBookColor | Represents a color in the color book.
ImGearColorBooks | Represents a static collection of color books.
ImGearColorChannelInfo | Spot channel class that uses regular color space like RGB, CMYK, etc.
ImGearColorProfile Represents a color profile.

ImGearColorProfileManager

ImGearColorProfileManager | Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.
ImGearColorSpace | Defines semantics of information, stored in all image channels.
ImGearCommonMetadataDictRecord Contains data for a common metadata dictionary record.

This structure is used with most ImageGear supported formats.

ImGearDIB Encapsulates an image, which consists of the pixel data and its attributes.

This class does not have public constructors. Instances of ImGearDIB exist only as a member objects of ImGearPage or ImGearROIMask classes.

ImGearDICOMMetadataDictRecord Represents basic information about DICOM Data Element.

See PS 3.6 2008, Registry of DICOM data elements table. The names of properties are equivalents to corresponding columns of the table.

ImGearDisplayChannel | Represents display attributes for individual channel.
ImGearDisplayChannels | Represents a collection of ImGearDisplayChannel class objects.
ImGearDocument Represents a collection of ImGearPage objects.

In addition to pages the object provides access to document level metadata.

In case of PDF or PS, ImGearDocument object may be associated with an external file.

ImGearDocumentPageArray Represents a collection of pages within ImGearDocument object.

On adding pages, checks that the new page is not attached to any other document. The remove(Object) method detaches a page from the document. If it is referenced from anywhere else, it remains a valid stand-alone page.

Well-formed page array may contain any number of null entries. An exception is made for the formats where pages are physically continuous (i.e., PDF). Note that setting a page to null is different from removing a page from the document - the former does not change page count, whereas the latter does.

ImGearEvaluationManager Provides an evaluation licensing manager.

This class must be initialized prior to using any other licensing call when the product is running in evaluation mode.

ImGearException Base class for all exceptions thrown by the ImageGear for Java library. Contains error codes and optionally supplied data.

Contains detailed information about the error that occurred.

This class does not have any public constructors. All instances are created implicitly by overloads of throwError static method.

ImGearExtraChannelInfo This is a general extra channel class.

Each extra channel in image has ImGearExtraChannelInfo object associated with it.

ImGearFullLUT Represents a lookup table that contains a full table of values for each possible input index.

Lookup table contains values for entire input range. Table of values can be accessed directly.

ImGearLicense | Manages licensing data (i.e., license type and key).
ImGearLinearLUT This class represents a lookup table that does not store the actual LUT values, but calculates output values dynamically using a linear formula.

Such LUTs can be used for window levelling of 17-32 bit per channel images.

ImGearLUT Provides a base for lookup tables (LUTs) that are used in ImageGear.

A LUT is characterized by input depth and output depth; both input and output of the LUT can be signed or unsigned.

ImGearMaskColorChannelInfo Represents mask color channel info.

Class uses regular color space like RGB, CMYK, etc.

ImGearMaskSpotChannelInfo | Represents a mask spot channel that uses a special (like Pantone) color.
ImGearMemoryStream | Basic in-memory stream functionality
ImGearMetadataDictionary | Provides access to Metadata Dictionary that is used in ImageGear.
ImGearMetadataHead Head of metadata tree.

ImGearMetadataHead is a special kind of metadata node with a null Parent field and not more than one child. It is present in every instance of ImGearPage class and ImGearDocument class as class member.

If the page or document has metadata, an instance of ImGearMetadataTree class is attached to the head as a child node. Otherwise, child is null.

ImGearMetadataHead may only be the root of metadata tree. Attempting to attach this class to any node causes ImageGear to throw an exception.

ImGearMetadataLeaf | Represents metadata node that contains a data value and cannot reference other metadata nodes.
ImGearMetadataNode Provides generic functionality for the ImageGear metadata objects.

An ImGearMetadataNode can be referenced from one parent node or can be unreferenced. It cannot however be referenced from multiple parents. A node can never refer to itself either directly or indirectly.

ImGearMetadataNodeList Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.

Represents container (list) of ImGearMetadataNode instances and provides additional verifications for stored objects. For example, on adding, new MetadataNode is checked to be non-null, stand-alone ( ImGearMetadataNode.getParent == null) and not the same as the top node of the tree to which it is added.

Nodes with different Format values are allowed to be present in the same list. Multiple nodes with the same Tag value are also allowed. The list is not sorted automatically because the order of items may be significant for a particular format.

This class does not have any public constructor. Instances exist only as members of ImGearMetadataTree objects.

ImGearMetadataTree Encapsulates entity of file format metadata tree.

Represents metadata tree with structure of any complexity. Similar to ImGearMetadataHead, ImGearMetadataTree, this is a special case of metadata node when getParent() returns null.

ImGearMultichannelLUT Represents a multichannel lookup table (LUT).

An ImGearMultichannelLUT object contains an array of single-channel ImGearLUT class objects.

ImGearNativePath This class obtains a path and manages the loading of native libraries associated with ImageGear Java on Windows systems.

At the first use of ImGearLicense it automatically looks for a path containing ImageGear Java's igjcommonnative2 native library. It does this by first finding the operating system architecture and then looking for either the environment variable, IMAGE_GEAR_64BIT_PATH, for 64 bits, or IMAGE_GEAR_32BIT_PATH, for 32 bits. These are expected to contain paths to the appropriate folder of native libraries.

If the variable does not exist, it looks in the components of the java.library.path System property. You can set the path to the native libraries to appear in this property in two ways:

  1. by adding the path to the operating system's path environment variable
  2. by invoking the Java Virtual Machine with the argument -D java.library.path=<path to native binaries>

Setting the operating system's path in the first way will prevent you from using the 32 and 64 bit SDKs simultaneously, since it will always find the version that is first.

The last place it looks is in a bin peer folder of the one the SDK jars were loaded from.

You can specify the native library location programmatically by calling the method, setPath before calling any licensing code, like ImGearLicense.setSolutionName, or after, if the search above does not find a path.

ImGearOrientation Specifies orientation of page or display.

This structure defines the orientation of an image. It works on the image representation and thus allows you to flip and rotate an image without modification of its data (pixels).

It is useful to manipulate the orientation of scanned black-and-white images. Since ImageGear for Java stores such images using lossless compression, this may avoid significant expansion of memory usage while operating on these images.

ImGearARTMark file formats support orientation natively and this allows you to save flipped or rotated images without loss of pixel data or file size enlargement when using compression.

ImGearPage Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.

Represents the image and consists of three main parts:

  • Image data (pixels)
  • Metadata (non-image data)
  • Region of interest

The page can be either stand-alone (not referenced from any ImGearDocument classinstance) or attached to a document.

Region of interest ( ImGearROI class) represents free-shape image area (rectangular, non-rectangular or entire space) and specifies a meaningful part of an image. For example, it may be set up for some image processing functions to define the area to which the filter should be applied.

Metadata is non-image data. It is available for most image file formats. In some formats, such as TIFF or PNG, it can be very complex. It can include data of various types and can use a complex structure. ImageGear for Java offers a set of classes designed specifically to manipulate this data consisting of ImGearMetadataNode class, ImGearMetadataNodeList class, ImGearMetadataTree class and their descendants. The metadata for each instance of com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata may be accessed through its getMetadata method.

The Image data (or simply, image) is available through the getDIB method. Color Space, channels, width and height are among the major attributes that define the image structure.

ImGearPixel Encapsulates all attributes and operations for an image pixel.

This class encapsulates an image pixel and represents the color store for each channel value.

For simplicity, com.accusoft.imagegear.processing.ImGearPixelateFillMethod does not contain any information about channels depths and color space. Therefore pixels that are identical in structure ( ImGearPixel constructor parameters) may belong to images with significantly different channels, structure and color space.

ImGearPixelArray | One dimensional array of image pixels.
ImGearRasterPage The class represents a raster image.

ImGearPage

ImGearRationalInt | Specifies rational fraction as an indicated division of Numerator/Denominator.
ImGearRationalUInt | Specifies rational fraction as an indicated division of Numerator/Denominator. The 4 most significant bytes of Numerator and Denominator are assumed to be 0.
ImGearResolution Stores ImageGear resolution data.

Specifies image resolution attributes.

ImGearRGBLUT | Represents RGB lookup table (LUT).
ImGearRGBQuad | Specifies an RGB value.
ImGearROI Region of interest associated with an ImGearPage instance.

The region of interest (ROI) represents freely shaped image area (rectangular, non-rectangular or entire space) that specifies the meaningful part of an image. For example - it may be used to define the area of an image to which an image processing method's filter should be applied.

ImGearROIMask 1-bit (binary) raster image that specifies a free shaped region of interest.

You can create an ImGearROIMask class object from a binary raster image or from a shape. If the mask is created from a shape, it represents a rasterized version of the shape.

ImGearROIRectangle | Rectangular region of interest.
ImGearSize | Implements a relative coordinate or position.
ImGearSpotChannelInfo Spot channel class that uses a special color, such as Pantone.

This class does not store a color name, but looks it up from the loaded color books when necessary.

ImGearStream | Basic stream functionality.
ImGearStreams Factory for stream implementations.

The memory streams are always readable, until ImGearStream.close is called.

ImGearTransparency | Specifies image transparency attributes like transparent color for display.
ImGearVersion | This class provides static properties to retrieve version info for the product package.
ImGearWarning | Base class for all warnings handled by the ImageGear for Java library. Contains error code and optionally supplied data.

Interfaces

Interface | Description
IImGearAddWarning | Specifies the warning processing routine to be called when the warning is added.
IImGearColorBook | Defines color book interface.
IImGearColorBookColor | Defines color book color interface.
IImGearDICOMDisplaySettings | Specifies baseline features for DICOM display settings. This interface specifies baseline features for DICOM display settings. This interface is declared in the Core package, allowing you to attach DICOM Display settings to ImGearPage class and com.accusoft.imagegear.display.ImGearPageDisplay class. However, DICOM Display Settings are only available when the DICOM component is attached. Cast IImGearDICOMDisplaySettings interface to com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class to access its features. com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings
IImGearMetadataDictRecord | Specifies baseline features for a metadata dictionary record.
IImGearOrientation | Defines Orientation interface.
IImGearResolution | Represents image resolution interface.
IImGearRGBQuad | Defines palette entry interface.
IImGearSize | Defines Size interface.

Enumerations

Enumeration | Description
ImGearColorSpaceIDs Specifies ImageGear color space IDs.

Specifies color space IDs. All colorspaces listed in this enumeration are supported for internal image storage.

ImageGear also supports colorspaces corresponding to valid combinations of ImGearColorSpaceIDs identifiers. Valid values are composed of a color identifier, such as RGB, Gy, Lab, etc, an optional Alpha and premulultiplied Alpha channel identifiers, and an optional Extra channel identifier. If Premultiplied Alpha bit is set, Alpha bit shall also be set. Only RGB and Gy colorspaces are currently allowed to be combined with Alpha or Premultiplied Alpha.

ImGearErrorCodes | Specifies ImageGear error codes.
ImGearEvaluationMode Gets or sets the product evaluation mode.

Currently, only allows Watermark.

ImGearExtraChannelType | Specifies all the supported types of extra channels.
ImGearFlipModes | Specifies ImageGear flip modes.
ImGearMaskChannelModes | Specifies whether the color indicates masked or selected area.
ImGearOrientationModes | Specifies ImageGear orientation modes.
ImGearRenderingIntents | Lists identifiers that controls how colors are transformed during color space conversion using color profiles.
ImGearResolutionUnits | Specifies the measurements of image resolution units.
ImGearRotationValues | Specifies the value of the rotation angle.
ImGearSeekOrigin | Provides the fields that represent reference points in streams for seeking.
ImGearSpotColorVendorID | Specifies all supported vendor IDs.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.core Package Inheritance Hierarchy

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.core.ImGearArray
com.accusoft.imagegear.core.ImGearArrayRef
com.accusoft.imagegear.core.ImGearChannelRange
com.accusoft.imagegear.core.ImGearColorBook
com.accusoft.imagegear.core.ImGearColorBookColor
com.accusoft.imagegear.core.ImGearColorBooks
com.accusoft.imagegear.core.ImGearColorProfile
com.accusoft.imagegear.core.ImGearColorProfileManager
com.accusoft.imagegear.core.ImGearColorSpace
com.accusoft.imagegear.core.ImGearCommonMetadataDictRecord
com.accusoft.imagegear.core.ImGearDIB
com.accusoft.imagegear.core.ImGearDICOMMetadataDictRecord
com.accusoft.imagegear.core.ImGearDocument
com.accusoft.imagegear.core.ImGearDocumentPageArray
com.accusoft.imagegear.core.ImGearEvaluationManager
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearLicense
com.accusoft.imagegear.core.ImGearMetadataDictionary
com.accusoft.imagegear.core.ImGearMetadataNode
com.accusoft.imagegear.core.ImGearMetadataNodeList
com.accusoft.imagegear.core.ImGearNativePath
com.accusoft.imagegear.core.ImGearPage
com.accusoft.imagegear.core.ImGearPixel
com.accusoft.imagegear.core.ImGearPixelArray
com.accusoft.imagegear.core.ImGearRationalInt
com.accusoft.imagegear.core.ImGearRationalUInt
com.accusoft.imagegear.core.ImGearResolution
com.accusoft.imagegear.core.ImGearROI
com.accusoft.imagegear.core.ImGearSize
com.accusoft.imagegear.core.ImGearStream
com.accusoft.imagegear.core.ImGearStreams
com.accusoft.imagegear.core.ImGearTransparency
com.accusoft.imagegear.core.ImGearVersion
com.accusoft.imagegear.core.ImGearWarning
java.lang.RuntimeException
java.lang.Exception
java.lang.Throwable
com.accusoft.imagegear.core.ImGearException

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearArray Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearArray Class

Glossary Item Box

Container of an array of arbitrary type.

Object Model

ImGearArray Class

Syntax

public sealed class ImGearArray
    extends Object
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearArray

See Also

Reference

ImGearArray Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearArray Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearArray Class

Glossary Item Box

The following tables list the members exposed by ImGearArray.

Public Constructors

 | Name | Description
public Constructor | ImGearArray Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getData | Returns the reference passed to the constructor.
public Method | getLength | Gets length of array.
public Method | getValue | Gets the element at index i of the array. Boxes if it is a primitive type. Only recognizes primitive types used in the SDK.
Top

See Also

Reference

ImGearArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearArray Constructor
com.accusoft.imagegear.core Package > ImGearArray Class : ImGearArray Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearArray Constructor(char[]) | Constructs instance from char[]
ImGearArray Constructor(int[]) | Constructs instance from int[]
ImGearArray Constructor(long[]) | Constructs instance from long[]
ImGearArray Constructor(short[]) | Constructs instance from short[]
ImGearArray Constructor(byte[]) | Constructs instance from byte[]
ImGearArray Constructor(double[]) | Constructs instance from double[]
ImGearArray Constructor(float[]) | Constructs instance from float[]
ImGearArray Constructor(Object) | This takes any array. If any other Object is passed in, except another instance of this class, this instance will not be initialized.

See Also

Reference

ImGearArray Class
ImGearArray Members


%%PageItemTitle%%

ImGearArray Constructor(char[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(char[])
data

Glossary Item Box

Constructs instance from char[]

Syntax

public ImGearArray(
   char[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(int[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(int[])
data

Glossary Item Box

Constructs instance from int[]

Syntax

public ImGearArray(
   int[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(long[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(long[])
data

Glossary Item Box

Constructs instance from long[]

Syntax

public ImGearArray(
   long[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(short[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(short[])
data

Glossary Item Box

Constructs instance from short[]

Syntax

public ImGearArray(
   short[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(byte[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(byte[])
data

Glossary Item Box

Constructs instance from byte[]

Syntax

public ImGearArray(
   byte[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(double[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(double[])
data

Glossary Item Box

Constructs instance from double[]

Syntax

public ImGearArray(
   double[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(float[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(float[])
data

Glossary Item Box

Constructs instance from float[]

Syntax

public ImGearArray(
   float[] data
)

Parameters

data

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%%

ImGearArray Constructor(Object)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArray Class > ImGearArray Constructor : ImGearArray Constructor(Object)
o
an array or another instance of this class.

Glossary Item Box

This takes any array. If any other Object is passed in, except another instance of this class, this instance will not be initialized.

Syntax

public ImGearArray(
   java.lang.Object o
)

Parameters

o
an array or another instance of this class.

See Also

Reference

ImGearArray Class
ImGearArray Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearArray Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearArray Class

Glossary Item Box

For a list of all members of this type, see ImGearArray members.

Public Methods

 | Name | Description
public Method | getData | Returns the reference passed to the constructor.
public Method | getLength | Gets length of array.
public Method | getValue | Gets the element at index i of the array. Boxes if it is a primitive type. Only recognizes primitive types used in the SDK.
Top

See Also

Reference

ImGearArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getData Method
com.accusoft.imagegear.core Package > ImGearArray Class : getData Method

Glossary Item Box

Returns the reference passed to the constructor.

Syntax

public java.lang.Object getData()

Return Value

the array reference the instance was initialized with.

See Also

Reference

ImGearArray Class
ImGearArray Members


%%PageItemTitle%%

getLength Method
com.accusoft.imagegear.core Package > ImGearArray Class : getLength Method

Glossary Item Box

Gets length of array.

Syntax

public int getLength()

Return Value

Length of array.

See Also

Reference

ImGearArray Class
ImGearArray Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.core Package > ImGearArray Class : getValue Method
i
Index to get.

Glossary Item Box

Gets the element at index i of the array. Boxes if it is a primitive type. Only recognizes primitive types used in the SDK.

Syntax

public java.lang.Object getValue(
   int i
)

Parameters

i
Index to get.

Return Value

Possibly boxed version of the element.

Exceptions

Exception | Description
java.lang.ArrayIndexOutOfBoundsException |
ImGearException | Base class for all exceptions thrown by the ImageGear for Java library. Contains error codes and optionally supplied data. Contains detailed information about the error that occurred. This class does not have any public constructors. All instances are created implicitly by overloads of throwError static method.

See Also

Reference

ImGearArray Class
ImGearArray Members


%%PageItemTitle%%

ImGearArrayRef Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearArrayRef Class

Glossary Item Box

Represents a reference to a particular location in an array.

Object Model

ImGearArrayRef Class

Syntax

public sealed class ImGearArrayRef
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearArrayRef

See Also

Reference

ImGearArrayRef Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearArrayRef Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.core Package : ImGearArrayRef Class

Glossary Item Box

The following tables list the members exposed by ImGearArrayRef.

Public Constructors

 | Name | Description
public Constructor | ImGearArrayRef Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | content | Specifies structure content.
public Field | offset | Specifies structure offset.
Top

See Also

Reference

ImGearArrayRef Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearArrayRef Constructor
com.accusoft.imagegear.core Package > ImGearArrayRef Class : ImGearArrayRef Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearArrayRef Constructor(ImGearArray,int) | Initializes a new instance of the ImGearArrayRef structure.
ImGearArrayRef Constructor(ImGearArray) | Initializes a new instance of the ImGearArrayRef structure.
ImGearArrayRef Constructor() | Default constructor.

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members


%%PageItemTitle%%

ImGearArrayRef Constructor(ImGearArray,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArrayRef Class > ImGearArrayRef Constructor : ImGearArrayRef Constructor(ImGearArray,int)
cntnt
Structure content.
off
Offset value.

Glossary Item Box

Initializes a new instance of the ImGearArrayRef structure.

Syntax

public ImGearArrayRef(
   ImGearArray cntnt,
   int off
)

Parameters

cntnt
Structure content.
off
Offset value.

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members
Overload List


%%PageItemTitle%%

ImGearArrayRef Constructor(ImGearArray)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArrayRef Class > ImGearArrayRef Constructor : ImGearArrayRef Constructor(ImGearArray)
cntnt
Structure content.

Glossary Item Box

Initializes a new instance of the ImGearArrayRef structure.

Syntax

public ImGearArrayRef(
   ImGearArray cntnt
)

Parameters

cntnt
Structure content.

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members
Overload List


%%PageItemTitle%%

ImGearArrayRef Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearArrayRef Class > ImGearArrayRef Constructor : ImGearArrayRef Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearArrayRef()

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members
Overload List


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearArrayRef Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearArrayRef Class

Glossary Item Box

For a list of all members of this type, see ImGearArrayRef members.

Public Fields

 | Name | Description
public Field | content | Specifies structure content.
public Field | offset | Specifies structure offset.
Top

See Also

Reference

ImGearArrayRef Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

content Field
com.accusoft.imagegear.core Package > ImGearArrayRef Class : content Field

Glossary Item Box

Specifies structure content.

Syntax

public ImGearArray content

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members


%%PageItemTitle%%

offset Field
com.accusoft.imagegear.core Package > ImGearArrayRef Class : offset Field

Glossary Item Box

Specifies structure offset.

Syntax

public int offset

See Also

Reference

ImGearArrayRef Class
ImGearArrayRef Members


%%PageItemTitle%%

ImGearChannelRange Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearChannelRange Class

Glossary Item Box

Describes channels to be processed with com.accusoft.imagegear.processing.ImGearProcessing class methods.

This structure is passed to some processing methods such as com.accusoft.imagegear.processing.ImGearRasterProcessing.adjustContrast.

com.accusoft.imagegear.processing.ImGearRasterProcessing

Object Model

ImGearChannelRange ClassImGearChannelRange Class

Syntax

public sealed class ImGearChannelRange
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearChannelRange Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearChannelRange Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearChannelRange Class

Glossary Item Box

The following tables list the members exposed by ImGearChannelRange.

Public Constructors

 | Name | Description
public Constructor | ImGearChannelRange Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | count | Channel count in the range (-1 indicates from Start to last channel of the DIB). Integer value in range [0 .. maximum channel count] or -1.
public Field | start | Start channel in the channel range. Integer value in the range of 0 .. maximum channel number.
Top

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Top

See Also

Reference

ImGearChannelRange Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearChannelRange Constructor
com.accusoft.imagegear.core Package > ImGearChannelRange Class : ImGearChannelRange Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearChannelRange Constructor(int,int) | Initializes a new instance of the ImGearChannelRange structure with start channel number and channel count.
ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups) | Initializes a new instance of the ImGearChannelRange structure with color space and channel group identifier.

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members


%%PageItemTitle%%

ImGearChannelRange Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearChannelRange Class > ImGearChannelRange Constructor : ImGearChannelRange Constructor(int,int)
strt
Start channel number.
cnt
Channel count.

Glossary Item Box

Initializes a new instance of the ImGearChannelRange structure with start channel number and channel count.

Syntax

public ImGearChannelRange(
   int strt,
   int cnt
)

Parameters

strt
Start channel number.
cnt
Channel count.

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members
Overload List


%%PageItemTitle%%

ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearChannelRange Class > ImGearChannelRange Constructor : ImGearChannelRange Constructor(ImGearColorSpace,ImGearChannelGroups)
colorSpace
Color Space for which the channel range structure is created.
group
Channel group constant. ImGearColorSpace com.accusoft.imagegear.processing.ImGearChannelGroups

Glossary Item Box

Initializes a new instance of the ImGearChannelRange structure with color space and channel group identifier.

Syntax

public ImGearChannelRange(
   ImGearColorSpace colorSpace,
   ImGearChannelGroups group
)

Parameters

colorSpace
Color Space for which the channel range structure is created.
group
Channel group constant. ImGearColorSpace com.accusoft.imagegear.processing.ImGearChannelGroups

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearChannelRange Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearChannelRange Class

Glossary Item Box

For a list of all members of this type, see ImGearChannelRange members.

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Top

See Also

Reference

ImGearChannelRange Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearChannelRange Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearChannelRange clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members
java.lang.Cloneable


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearChannelRange Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearChannelRange Class

Glossary Item Box

For a list of all members of this type, see ImGearChannelRange members.

Public Fields

 | Name | Description
public Field | count | Channel count in the range (-1 indicates from Start to last channel of the DIB). Integer value in range [0 .. maximum channel count] or -1.
public Field | start | Start channel in the channel range. Integer value in the range of 0 .. maximum channel number.
Top

See Also

Reference

ImGearChannelRange Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

count Field
com.accusoft.imagegear.core Package > ImGearChannelRange Class : count Field

Glossary Item Box

Channel count in the range (-1 indicates from Start to last channel of the DIB).

Integer value in range [0 .. maximum channel count] or -1.

Syntax

public int count

Return Value

Integer value in range [0 .. maximum channel count] or -1.

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members


%%PageItemTitle%%

start Field
com.accusoft.imagegear.core Package > ImGearChannelRange Class : start Field

Glossary Item Box

Start channel in the channel range.

Integer value in the range of 0 .. maximum channel number.

Syntax

public int start

Return Value

Integer value in the range of 0 .. maximum channel number.

See Also

Reference

ImGearChannelRange Class
ImGearChannelRange Members


%%PageItemTitle%%

ImGearColorBook Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBook Class

Glossary Item Box

Represents a color book.

Object Model

ImGearColorBook ClassImGearColorBook ClassImGearColorBookColor ClassImGearColorBookColor ClassImGearSpotColorVendorID Enumeration

Syntax

public sealed class ImGearColorBook
    extends Object
    implements IImGearColorBook, java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorBook

See Also

Reference

ImGearColorBook Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorBook Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBook Class

Glossary Item Box

The following tables list the members exposed by ImGearColorBook.

Public Constructors

 | Name | Description
public Constructor | ImGearColorBook Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | add | Adds a color to the color book.
static (Shared in Visual Basic) | create | Creates and initializes an instance of ImGearColorBooks class.
public Method | get | Returns a color with the specified ID from the color book.
public Method | getColors | Gets the array of individual color records held by the color book. ImGearColorBookColor class object. ImGearColorBookColor
public Method | getColorsPerPage | Gets the maximum number of colors that can appear on a page. Integer value. The maximum number of colors per page must be less than or equal to 9.
public Method | getColorType | Gets the color space value used for displaying all the colors from the color book. ImGearColorSpaceIDs enumeration value. This value can be RGB, CMYK or Lab. ImGearColorSpaceIDs
public Method | getDescription | Gets the color book copyright information. String value.
public Method | getFileName | Gets the color book file name. String value.
public Method | getKeyColorPage | Gets the key color on the page. Integer value. Key color on the page must be less than or equal to colors per page.
public Method | getNumberOfColors | Gets the number of colors in the color book. Integer value. The number of colors in the color book must be less than or equal to 8000.
public Method | getPostfix | Gets the color book postfix string value. String value.
public Method | getPrefix | Gets the color book prefix string value. String value.
public Method | getTitle | Gets the color book title. String value.
public Method | getVendorID | Gets the color book vendor ID value. ImGearSpotColorVendorID enumeration. ImGearSpotColorVendorID
public Method | iterator | Returns IEnumerator interface used for enumeration all the colors in the color book.
Top

See Also

Reference

ImGearColorBook Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearColorBook Constructor
com.accusoft.imagegear.core Package > ImGearColorBook Class : ImGearColorBook Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearColorBook Constructor(String) | Initializes a new instance of the ImGearColorBooks class from specified file name.
ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,int,int,EnumSet<ImGearColorSpaceIDs>) | Initializes a new instance of the ImGearColorBooks class with specified parameters.

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

ImGearColorBook Constructor(String)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorBook Class > ImGearColorBook Constructor : ImGearColorBook Constructor(String)
fileName
File name to load color book from.

Glossary Item Box

Initializes a new instance of the ImGearColorBooks class from specified file name.

Syntax

public ImGearColorBook(
   java.lang.String fileName
)

Parameters

fileName
File name to load color book from.

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
Overload List


%%PageItemTitle%%

ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,int,int,EnumSet<ImGearColorSpaceIDs>)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorBook Class > ImGearColorBook Constructor : ImGearColorBook Constructor(ImGearSpotColorVendorID,String,String,String,String,String,int,int,EnumSet<ImGearColorSpaceIDs>)
vendorId
Color book vendor ID.
fileName
Color book file name.
title
Color book title.
prefix
Color book prefix.
postfix
Color book postfix.
description
Color book description.
numberOfColors
Number of colors in color book.
colorsPerPage
Number of colors per page in color book.
colorType
Color type.

Glossary Item Box

Initializes a new instance of the ImGearColorBooks class with specified parameters.

Syntax

public ImGearColorBook(
   ImGearSpotColorVendorID vendorId,
   java.lang.String fileName,
   java.lang.String title,
   java.lang.String prefix,
   java.lang.String postfix,
   java.lang.String description,
   int numberOfColors,
   int colorsPerPage,
   java.util.EnumSet<ImGearColorSpaceIDs> colorType
)

Parameters

vendorId
Color book vendor ID.
fileName
Color book file name.
title
Color book title.
prefix
Color book prefix.
postfix
Color book postfix.
description
Color book description.
numberOfColors
Number of colors in color book.
colorsPerPage
Number of colors per page in color book.
colorType
Color type.

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorBook Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBook Class

Glossary Item Box

For a list of all members of this type, see ImGearColorBook members.

Public Methods

 | Name | Description
public Method | add | Adds a color to the color book.
static (Shared in Visual Basic) | create | Creates and initializes an instance of ImGearColorBooks class.
public Method | get | Returns a color with the specified ID from the color book.
public Method | getColors | Gets the array of individual color records held by the color book. ImGearColorBookColor class object. ImGearColorBookColor
public Method | getColorsPerPage | Gets the maximum number of colors that can appear on a page. Integer value. The maximum number of colors per page must be less than or equal to 9.
public Method | getColorType | Gets the color space value used for displaying all the colors from the color book. ImGearColorSpaceIDs enumeration value. This value can be RGB, CMYK or Lab. ImGearColorSpaceIDs
public Method | getDescription | Gets the color book copyright information. String value.
public Method | getFileName | Gets the color book file name. String value.
public Method | getKeyColorPage | Gets the key color on the page. Integer value. Key color on the page must be less than or equal to colors per page.
public Method | getNumberOfColors | Gets the number of colors in the color book. Integer value. The number of colors in the color book must be less than or equal to 8000.
public Method | getPostfix | Gets the color book postfix string value. String value.
public Method | getPrefix | Gets the color book prefix string value. String value.
public Method | getTitle | Gets the color book title. String value.
public Method | getVendorID | Gets the color book vendor ID value. ImGearSpotColorVendorID enumeration. ImGearSpotColorVendorID
public Method | iterator | Returns IEnumerator interface used for enumeration all the colors in the color book.
Top

See Also

Reference

ImGearColorBook Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : add Method
color
Color book color object. ImGearColorBookColor

Glossary Item Box

Adds a color to the color book.

Syntax

public void add(
   ImGearColorBookColor color
)

Parameters

color
Color book color object. ImGearColorBookColor

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

create Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : create Method
vendorId
Color book vendor ID.
title
Color book title.
colorType
Color type.

Glossary Item Box

Creates and initializes an instance of ImGearColorBooks class.

Syntax

public static ImGearColorBook create(
   ImGearSpotColorVendorID vendorId,
   java.lang.String title,
   java.util.EnumSet<ImGearColorSpaceIDs> colorType
)

Parameters

vendorId
Color book vendor ID.
title
Color book title.
colorType
Color type.

Return Value

ImGearColorBooks class object. ImGearSpotColorVendorID ImGearColorSpaceIDs

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

get Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : get Method
id
ID of the requested color.

Glossary Item Box

Returns a color with the specified ID from the color book.

Syntax

public ImGearColorBookColor get(
   long id
)

Parameters

id
ID of the requested color.

Return Value

ImGearColorBookColor class object. ImGearColorBookColor

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getColors Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getColors Method

Glossary Item Box

Gets the array of individual color records held by the color book.

ImGearColorBookColor class object. ImGearColorBookColor

Syntax

public ImGearColorBookColor[] getColors()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getColorsPerPage Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getColorsPerPage Method

Glossary Item Box

Gets the maximum number of colors that can appear on a page.

Integer value.

The maximum number of colors per page must be less than or equal to 9.

Syntax

public int getColorsPerPage()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getColorType Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getColorType Method

Glossary Item Box

Gets the color space value used for displaying all the colors from the color book.

ImGearColorSpaceIDs enumeration value.

This value can be RGB, CMYK or Lab.

ImGearColorSpaceIDs

Syntax

public java.util.EnumSet<ImGearColorSpaceIDs> getColorType()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getDescription Method

Glossary Item Box

Gets the color book copyright information.

String value.

Syntax

public java.lang.String getDescription()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getFileName Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getFileName Method

Glossary Item Box

Gets the color book file name.

String value.

Syntax

public java.lang.String getFileName()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getKeyColorPage Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getKeyColorPage Method

Glossary Item Box

Gets the key color on the page.

Integer value.

Key color on the page must be less than or equal to colors per page.

Syntax

public int getKeyColorPage()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getNumberOfColors Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getNumberOfColors Method

Glossary Item Box

Gets the number of colors in the color book.

Integer value.

The number of colors in the color book must be less than or equal to 8000.

Syntax

public int getNumberOfColors()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getPostfix Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getPostfix Method

Glossary Item Box

Gets the color book postfix string value.

String value.

Syntax

public java.lang.String getPostfix()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getPrefix Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getPrefix Method

Glossary Item Box

Gets the color book prefix string value.

String value.

Syntax

public java.lang.String getPrefix()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getTitle Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getTitle Method

Glossary Item Box

Gets the color book title.

String value.

Syntax

public java.lang.String getTitle()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

getVendorID Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : getVendorID Method

Glossary Item Box

Gets the color book vendor ID value.

ImGearSpotColorVendorID enumeration. ImGearSpotColorVendorID

Syntax

public ImGearSpotColorVendorID getVendorID()

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.core Package > ImGearColorBook Class : iterator Method

Glossary Item Box

Returns IEnumerator interface used for enumeration all the colors in the color book.

Syntax

public java.util.Iterator<ImGearColorBookColor> iterator()

Return Value

System.Collections.IEnumerator interface..

See Also

Reference

ImGearColorBook Class
ImGearColorBook Members


%%PageItemTitle%%

ImGearColorBookColor Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBookColor Class

Glossary Item Box

Represents a color in the color book.

Object Model

ImGearColorBookColor ClassImGearColorSpace ClassImGearPixel Class

Syntax

public sealed class ImGearColorBookColor
    extends Object
    implements IImGearColorBookColor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorBookColor

See Also

Reference

ImGearColorBookColor Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorBookColor Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBookColor Class

Glossary Item Box

The following tables list the members exposed by ImGearColorBookColor.

Public Constructors

 | Name | Description
public Constructor | ImGearColorBookColor Constructor | Initializes a new instance of the ImGearColorBookColor class.
Top

Public Methods

 | Name | Description
public Method | getColorSpace | Gets the color space of the color used for display. ImGearColorSpace structure. ImGearColorSpace
public Method | getColorValueCopy | Returns a copy of the color value used for display.
public Method | getID | Gets the catalog code of the color. Long value.
public Method | getName | Gets the full name of the color. String value.
Top

See Also

Reference

ImGearColorBookColor Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearColorBookColor Constructor
com.accusoft.imagegear.core Package > ImGearColorBookColor Class : ImGearColorBookColor Constructor
name
Name of the color.
id
ID of the color.
color
ImGearPixel value of the color.
colorType
Color space. ImGearPixel ImGearColorSpaceIDs

Glossary Item Box

Initializes a new instance of the ImGearColorBookColor class.

Syntax

public ImGearColorBookColor(
   java.lang.String name,
   long id,
   ImGearPixel color,
   java.util.EnumSet<ImGearColorSpaceIDs> colorType
)

Parameters

name
Name of the color.
id
ID of the color.
color
ImGearPixel value of the color.
colorType
Color space. ImGearPixel ImGearColorSpaceIDs

See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorBookColor Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBookColor Class

Glossary Item Box

For a list of all members of this type, see ImGearColorBookColor members.

Public Methods

 | Name | Description
public Method | getColorSpace | Gets the color space of the color used for display. ImGearColorSpace structure. ImGearColorSpace
public Method | getColorValueCopy | Returns a copy of the color value used for display.
public Method | getID | Gets the catalog code of the color. Long value.
public Method | getName | Gets the full name of the color. String value.
Top

See Also

Reference

ImGearColorBookColor Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.core Package > ImGearColorBookColor Class : getColorSpace Method

Glossary Item Box

Gets the color space of the color used for display.

ImGearColorSpace structure. ImGearColorSpace

Syntax

public ImGearColorSpace getColorSpace()

See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%%

getColorValueCopy Method
com.accusoft.imagegear.core Package > ImGearColorBookColor Class : getColorValueCopy Method

Glossary Item Box

Returns a copy of the color value used for display.

Syntax

public ImGearPixel getColorValueCopy()

Return Value

A new instance of ImGearPixel class. ImGearPixel

See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%%

getID Method
com.accusoft.imagegear.core Package > ImGearColorBookColor Class : getID Method

Glossary Item Box

Gets the catalog code of the color.

Long value.

Syntax

public long getID()

See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > ImGearColorBookColor Class : getName Method

Glossary Item Box

Gets the full name of the color.

String value.

Syntax

public java.lang.String getName()

See Also

Reference

ImGearColorBookColor Class
ImGearColorBookColor Members


%%PageItemTitle%%

ImGearColorBooks Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBooks Class

Glossary Item Box

Represents a static collection of color books.

Object Model

ImGearColorBooks ClassImGearColorBook ClassImGearColorBook ClassImGearColorBook ClassImGearSpotColorVendorID Enumeration

Syntax

public sealed class ImGearColorBooks
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorBooks

See Also

Reference

ImGearColorBooks Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorBooks Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBooks Class

Glossary Item Box

The following tables list the members exposed by ImGearColorBooks.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | add | Adds a new color book to the collection.
static (Shared in Visual Basic) | addBookFromFile | Adds a new color book to the collection from the specified file name.
static (Shared in Visual Basic) | copyTo | Copies a range of elements to the specified array.
static (Shared in Visual Basic) | get | Retrieves a color book for the specified vendor ID.
static (Shared in Visual Basic) | getAllBooks | Retrieves the entire collection of color books.
static (Shared in Visual Basic) | getByIndex | Retrieves a color book with the specified index.
static (Shared in Visual Basic) | getCount | Gets the number of color books in the collection. Integer value.
static (Shared in Visual Basic) | getEnumerator | Returns IEnumerator interface used for enumeration all the color books in the collection.
static (Shared in Visual Basic) | getSynonyms | Returns an array of vendor IDs associated with the specified ID.
static (Shared in Visual Basic) | initialize | Loads the color book collection from the list of file paths.
static (Shared in Visual Basic) | remove | Removes color book for the specified vendor ID.
static (Shared in Visual Basic) | removeAt | Removes color book with the specified index.
Top

See Also

Reference

ImGearColorBooks Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorBooks Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorBooks Class

Glossary Item Box

For a list of all members of this type, see ImGearColorBooks members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | add | Adds a new color book to the collection.
static (Shared in Visual Basic) | addBookFromFile | Adds a new color book to the collection from the specified file name.
static (Shared in Visual Basic) | copyTo | Copies a range of elements to the specified array.
static (Shared in Visual Basic) | get | Retrieves a color book for the specified vendor ID.
static (Shared in Visual Basic) | getAllBooks | Retrieves the entire collection of color books.
static (Shared in Visual Basic) | getByIndex | Retrieves a color book with the specified index.
static (Shared in Visual Basic) | getCount | Gets the number of color books in the collection. Integer value.
static (Shared in Visual Basic) | getEnumerator | Returns IEnumerator interface used for enumeration all the color books in the collection.
static (Shared in Visual Basic) | getSynonyms | Returns an array of vendor IDs associated with the specified ID.
static (Shared in Visual Basic) | initialize | Loads the color book collection from the list of file paths.
static (Shared in Visual Basic) | remove | Removes color book for the specified vendor ID.
static (Shared in Visual Basic) | removeAt | Removes color book with the specified index.
Top

See Also

Reference

ImGearColorBooks Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : add Method
newColorBook
New color book to add.

Glossary Item Box

Adds a new color book to the collection.

Syntax

public static int add(
   ImGearColorBook newColorBook
)

Parameters

newColorBook
New color book to add.

Return Value

Integer value. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

addBookFromFile Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : addBookFromFile Method
fileName
Color book file.

Glossary Item Box

Adds a new color book to the collection from the specified file name.

Syntax

public static int addBookFromFile(
   java.lang.String fileName
)

Parameters

fileName
Color book file.

Return Value

Integer value. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

copyTo Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : copyTo Method
array
ImGearColorBook array to copy the color elements to.
index
The zero-based index in array at which copying begins. ImGearColorBook

Glossary Item Box

Copies a range of elements to the specified array.

Syntax

public static void copyTo(
   ImGearArray array,
   int index
)

Parameters

array
ImGearColorBook array to copy the color elements to.
index
The zero-based index in array at which copying begins. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

get Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : get Method
vendorId
Vendor ID for which to get the color book.

Glossary Item Box

Retrieves a color book for the specified vendor ID.

Syntax

public static ImGearColorBook get(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID for which to get the color book.

Return Value

ImGearColorBook class object. ImGearColorBook ImGearSpotColorVendorID

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

getAllBooks Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : getAllBooks Method

Glossary Item Box

Retrieves the entire collection of color books.

Syntax

public static ImGearColorBook[] getAllBooks()

Return Value

ImGearColorBook class object. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

getByIndex Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : getByIndex Method
index
Index of the color book to get.

Glossary Item Box

Retrieves a color book with the specified index.

Syntax

public static ImGearColorBook getByIndex(
   int index
)

Parameters

index
Index of the color book to get.

Return Value

ImGearColorBook class object. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : getCount Method

Glossary Item Box

Gets the number of color books in the collection.

Integer value.

Syntax

public static int getCount()

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

getEnumerator Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : getEnumerator Method

Glossary Item Box

Returns IEnumerator interface used for enumeration all the color books in the collection.

Syntax

public static java.util.Iterator<ImGearColorBook> getEnumerator()

Return Value

System.Collections.IEnumerator interface.

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

getSynonyms Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : getSynonyms Method
vendorId
Vendor ID.

Glossary Item Box

Returns an array of vendor IDs associated with the specified ID.

Syntax

public static ImGearSpotColorVendorID[] getSynonyms(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID.

Return Value

ImGearSpotColorVendorID array. ImGearColorBook ImGearSpotColorVendorID

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : initialize Method
colorBookFiles
List of color book paths. ImGearColorBook

Glossary Item Box

Loads the color book collection from the list of file paths.

Syntax

public static void initialize(
   java.lang.String[] colorBookFiles
)

Parameters

colorBookFiles
List of color book paths. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : remove Method
vendorId
Vendor ID. ImGearColorBook ImGearSpotColorVendorID

Glossary Item Box

Removes color book for the specified vendor ID.

Syntax

public static void remove(
   ImGearSpotColorVendorID vendorId
)

Parameters

vendorId
Vendor ID. ImGearColorBook ImGearSpotColorVendorID

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

removeAt Method
com.accusoft.imagegear.core Package > ImGearColorBooks Class : removeAt Method
index
Color book index. ImGearColorBook

Glossary Item Box

Removes color book with the specified index.

Syntax

public static void removeAt(
   int index
)

Parameters

index
Color book index. ImGearColorBook

See Also

Reference

ImGearColorBooks Class
ImGearColorBooks Members


%%PageItemTitle%%

ImGearColorChannelInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorChannelInfo Class

Glossary Item Box

Spot channel class that uses regular color space like RGB, CMYK, etc.

Object Model

ImGearColorChannelInfo ClassImGearExtraChannelInfo ClassImGearColorSpace ClassImGearPixel ClassImGearPixel ClassImGearPixel ClassImGearExtraChannelType Enumeration

Syntax

public class ImGearColorChannelInfo
    extends ImGearExtraChannelInfo

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearColorChannelInfo
com.accusoft.imagegear.core.ImGearMaskColorChannelInfo

See Also

Reference

ImGearColorChannelInfo Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorChannelInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorChannelInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearColorChannelInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearColorChannelInfo Constructor | Initializes a new instance of the ImGearColorChannelInfo class by using color space and color value.
Top

Public Methods

 | Name | Description
public Method | getColorSpace | Gets color channel's color space. ImGearColorSpace structure. ImGearColorSpace
public Method | getColorValueCopy | Returns a copy of the color value.
public Method | getColorValueCopy16 | Returns a copy of the color value in 16-bit format.
public Method | getColorValueCopy8 | Returns a copy of the color value in 8-bit format.
public Method | getOpacity | Returns opacity of the color channel. Integer value in range [0...100].
public Method | setOpacity | Sets opacity of the color channel. Integer value in range [0...100].
Top

See Also

Reference

ImGearColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearColorChannelInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearColorChannelInfo members.

See Also

Reference

ImGearColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearColorChannelInfo Constructor
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : ImGearColorChannelInfo Constructor
colorSpace
Color space object.
colorValue
Color value. ImGearColorSpace ImGearPixel

Glossary Item Box

Initializes a new instance of the ImGearColorChannelInfo class by using color space and color value.

Syntax

public ImGearColorChannelInfo(
   ImGearColorSpace colorSpace,
   ImGearPixel colorValue
)

Parameters

colorSpace
Color space object.
colorValue
Color value. ImGearColorSpace ImGearPixel

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : clone Method

Glossary Item Box

Syntax

public ImGearExtraChannelInfo clone()

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorChannelInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearColorChannelInfo members.

Public Methods

 | Name | Description
public Method | getColorSpace | Gets color channel's color space. ImGearColorSpace structure. ImGearColorSpace
public Method | getColorValueCopy | Returns a copy of the color value.
public Method | getColorValueCopy16 | Returns a copy of the color value in 16-bit format.
public Method | getColorValueCopy8 | Returns a copy of the color value in 8-bit format.
public Method | getOpacity | Returns opacity of the color channel. Integer value in range [0...100].
public Method | setOpacity | Sets opacity of the color channel. Integer value in range [0...100].
Top

See Also

Reference

ImGearColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : getColorSpace Method

Glossary Item Box

Gets color channel's color space.

ImGearColorSpace structure. ImGearColorSpace

Syntax

public ImGearColorSpace getColorSpace()

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

getColorValueCopy Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : getColorValueCopy Method

Glossary Item Box

Returns a copy of the color value.

Syntax

public ImGearPixel getColorValueCopy()

Return Value

A new instance of ImGearPixel class. ImGearPixel

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

getColorValueCopy16 Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : getColorValueCopy16 Method

Glossary Item Box

Returns a copy of the color value in 16-bit format.

Syntax

public ImGearPixel getColorValueCopy16()

Return Value

ImGearPixel class value with 16 bits per channel. ImGearPixel

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

getColorValueCopy8 Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : getColorValueCopy8 Method

Glossary Item Box

Returns a copy of the color value in 8-bit format.

Syntax

public ImGearPixel getColorValueCopy8()

Return Value

ImGearPixel class object with 8 bits per channel. ImGearPixel

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : getOpacity Method

Glossary Item Box

Returns opacity of the color channel.

Integer value in range [0...100].

Syntax

public int getOpacity()

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.core Package > ImGearColorChannelInfo Class : setOpacity Method
value

Glossary Item Box

Sets opacity of the color channel.

Integer value in range [0...100].

Syntax

public void setOpacity(
   int value
)

Parameters

value

See Also

Reference

ImGearColorChannelInfo Class
ImGearColorChannelInfo Members


%%PageItemTitle%%

ImGearColorProfile Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfile Class

Glossary Item Box

Represents a color profile.

ImGearColorProfileManager

Object Model

ImGearColorProfile ClassImGearRenderingIntents Enumeration

Syntax

public sealed class ImGearColorProfile
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorProfile

See Also

Reference

ImGearColorProfile Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorProfile Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfile Class

Glossary Item Box

The following tables list the members exposed by ImGearColorProfile.

Public Constructors

 | Name | Description
public Constructor | ImGearColorProfile Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getColorSpace | Gets the color space of the color profile. ImGearColorSpaceIDs enumeration value. Returns color space of the color profile, typically RGB or CMYK. ImGearColorSpaceIDs
public Method | getProfileData | Gets the color profile data. Array of bytes. Provides read-only access to color profile data. Color profiles are not updated through this method; create a new ImGearColorProfile class object instead.
public Method | getRenderingIntent | Gets the rendering intent type associated with the color profile. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. ImGearRenderingIntents
Top

See Also

Reference

ImGearColorProfile Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearColorProfile Constructor
com.accusoft.imagegear.core Package > ImGearColorProfile Class : ImGearColorProfile Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearColorProfile Constructor(byte[]) | Initializes a new instance of the ImGearColorProfile class.
ImGearColorProfile Constructor(ImGearStream) | Initializes a new instance of the ImGearColorProfile class.

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


%%PageItemTitle%%

ImGearColorProfile Constructor(byte[])
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorProfile Class > ImGearColorProfile Constructor : ImGearColorProfile Constructor(byte[])
profileStore
Profile data to read.

This constructor reads profile data from a byte array. Profile data must be in standard ICC color profile format.

Glossary Item Box

Initializes a new instance of the ImGearColorProfile class.

Syntax

public ImGearColorProfile(
   byte[] profileStore
)

Parameters

profileStore
Profile data to read.

This constructor reads profile data from a byte array. Profile data must be in standard ICC color profile format.

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
Overload List


%%PageItemTitle%%

ImGearColorProfile Constructor(ImGearStream)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorProfile Class > ImGearColorProfile Constructor : ImGearColorProfile Constructor(ImGearStream)
profileStore
Profile data.

This constructor reads profile data from a stream. Profile data must be in standard ICC color profile format.

Glossary Item Box

Initializes a new instance of the ImGearColorProfile class.

Syntax

public ImGearColorProfile(
   ImGearStream profileStore
)

Parameters

profileStore
Profile data.

This constructor reads profile data from a stream. Profile data must be in standard ICC color profile format.

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorProfile Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfile Class

Glossary Item Box

For a list of all members of this type, see ImGearColorProfile members.

Public Methods

 | Name | Description
public Method | getColorSpace | Gets the color space of the color profile. ImGearColorSpaceIDs enumeration value. Returns color space of the color profile, typically RGB or CMYK. ImGearColorSpaceIDs
public Method | getProfileData | Gets the color profile data. Array of bytes. Provides read-only access to color profile data. Color profiles are not updated through this method; create a new ImGearColorProfile class object instead.
public Method | getRenderingIntent | Gets the rendering intent type associated with the color profile. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. ImGearRenderingIntents
Top

See Also

Reference

ImGearColorProfile Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.core Package > ImGearColorProfile Class : getColorSpace Method

Glossary Item Box

Gets the color space of the color profile.

ImGearColorSpaceIDs enumeration value.

Returns color space of the color profile, typically RGB or CMYK.

ImGearColorSpaceIDs

Syntax

public java.util.EnumSet<ImGearColorSpaceIDs> getColorSpace()

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


%%PageItemTitle%%

getProfileData Method
com.accusoft.imagegear.core Package > ImGearColorProfile Class : getProfileData Method

Glossary Item Box

Gets the color profile data.

Array of bytes.

Provides read-only access to color profile data. Color profiles are not updated through this method; create a new ImGearColorProfile class object instead.

Syntax

public byte[] getProfileData()

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


%%PageItemTitle%%

getRenderingIntent Method
com.accusoft.imagegear.core Package > ImGearColorProfile Class : getRenderingIntent Method

Glossary Item Box

Gets the rendering intent type associated with the color profile.

ImGearRenderingIntents enumeration value.

Rendering intent controls how color matching is performed during color space conversion.

ImGearRenderingIntents

Syntax

public ImGearRenderingIntents getRenderingIntent()

See Also

Reference

ImGearColorProfile Class
ImGearColorProfile Members


%%PageItemTitle%%

ImGearColorProfileManager Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfileManager Class

Glossary Item Box

Provides global profile storage and allows enabling and disabling the automatic use of global color profiles for color space conversion and display operations.

Object Model

ImGearColorProfileManager ClassImGearColorProfile ClassImGearColorProfile ClassImGearColorProfile ClassImGearColorProfile ClassImGearRenderingIntents EnumerationImGearColorProfile Class

Syntax

public sealed class ImGearColorProfileManager
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorProfileManager

See Also

Reference

ImGearColorProfileManager Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorProfileManager Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfileManager Class

Glossary Item Box

The following tables list the members exposed by ImGearColorProfileManager.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | areProfilesEnabled | Gets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled. Boolean value. If this profiles are enabled, global color profiles (specified by other properties of this object such as getCmykProfile method and method) and local color profiles ( ImGearRasterPage.getColorProfile method) will be used to perform color space conversions. The default value is false.
static (Shared in Visual Basic) | assignProfile | Associates a given instance of a color profile with the specified color space.
static (Shared in Visual Basic) | enableProfiles | Sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled. Boolean value. If this method receives true, global color profiles (specified by other properties of this object such as getCmykProfile method and getRgbProfile method) and local color profiles ( ImGearRasterPage.getColorProfile} method) will be used to perform color space conversions. The default value is false.
static (Shared in Visual Basic) | getCmykProfile | Gets global CMYK color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | getGrayProfile | Gets a color profile for Grayscale color space. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | getLabProfile | Gets a color profile for Lab color space. The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes. ImGearColorProfile class object. ImGearColorProfile
static (Shared in Visual Basic) | getProfile | Returns an instance of a color profile associated with the given color space.
static (Shared in Visual Basic) | getRenderingIntent | Gets rendering intent to use for implicit color space conversions when global profiles are enabled. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.
static (Shared in Visual Basic) | getRgbProfile | Gets global RGB color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setCmykProfile | Sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setGrayProfile | Sets a color profile for Grayscale color space. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setLabProfile | Sets a color profile for Lab color space. The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes. ImGearColorProfile class object. ImGearColorProfile
static (Shared in Visual Basic) | setRenderingIntent | Sets rendering intent to use for implicit color space conversions when global profiles are enabled. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.
static (Shared in Visual Basic) | setRgbProfile | Sets global RGB color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null. ImGearColorProfile
Top

See Also

Reference

ImGearColorProfileManager Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorProfileManager Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorProfileManager Class

Glossary Item Box

For a list of all members of this type, see ImGearColorProfileManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | areProfilesEnabled | Gets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled. Boolean value. If this profiles are enabled, global color profiles (specified by other properties of this object such as getCmykProfile method and method) and local color profiles ( ImGearRasterPage.getColorProfile method) will be used to perform color space conversions. The default value is false.
static (Shared in Visual Basic) | assignProfile | Associates a given instance of a color profile with the specified color space.
static (Shared in Visual Basic) | enableProfiles | Sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled. Boolean value. If this method receives true, global color profiles (specified by other properties of this object such as getCmykProfile method and getRgbProfile method) and local color profiles ( ImGearRasterPage.getColorProfile} method) will be used to perform color space conversions. The default value is false.
static (Shared in Visual Basic) | getCmykProfile | Gets global CMYK color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | getGrayProfile | Gets a color profile for Grayscale color space. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | getLabProfile | Gets a color profile for Lab color space. The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes. ImGearColorProfile class object. ImGearColorProfile
static (Shared in Visual Basic) | getProfile | Returns an instance of a color profile associated with the given color space.
static (Shared in Visual Basic) | getRenderingIntent | Gets rendering intent to use for implicit color space conversions when global profiles are enabled. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.
static (Shared in Visual Basic) | getRgbProfile | Gets global RGB color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setCmykProfile | Sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setGrayProfile | Sets a color profile for Grayscale color space. ImGearColorProfile class object. The default value is null.
static (Shared in Visual Basic) | setLabProfile | Sets a color profile for Lab color space. The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes. ImGearColorProfile class object. ImGearColorProfile
static (Shared in Visual Basic) | setRenderingIntent | Sets rendering intent to use for implicit color space conversions when global profiles are enabled. ImGearRenderingIntents enumeration value. Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.
static (Shared in Visual Basic) | setRgbProfile | Sets global RGB color profile to use for implicit color space conversions when global profiles are enabled. ImGearColorProfile class object. The default value is null. ImGearColorProfile
Top

See Also

Reference

ImGearColorProfileManager Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

areProfilesEnabled Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : areProfilesEnabled Method

Glossary Item Box

Gets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled.

Boolean value.

If this profiles are enabled, global color profiles (specified by other properties of this object such as getCmykProfile method and method) and local color profiles ( ImGearRasterPage.getColorProfile method) will be used to perform color space conversions. The default value is false.

Syntax

public static boolean areProfilesEnabled()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

assignProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : assignProfile Method
colorSpace
Color space.
colorProfile
Color profile.

Represents an alternative way of assigning global profiles with color spaces. In particular, to assign a global profile with a gray color space, either getGrayProfile method or assignProfile(ImGearColorSpaceIDs.Gy)call could be used.

ImGearColorProfile ImGearColorSpaceIDs

Glossary Item Box

Associates a given instance of a color profile with the specified color space.

Syntax

public static void assignProfile(
   java.util.EnumSet<ImGearColorSpaceIDs> colorSpace,
   ImGearColorProfile colorProfile
)

Parameters

colorSpace
Color space.
colorProfile
Color profile.

Represents an alternative way of assigning global profiles with color spaces. In particular, to assign a global profile with a gray color space, either getGrayProfile method or assignProfile(ImGearColorSpaceIDs.Gy)call could be used.

ImGearColorProfile ImGearColorSpaceIDs

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

enableProfiles Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : enableProfiles Method
value

Glossary Item Box

Sets a value indicating whether the automatic use of color profiles for color space conversion operations is enabled.

Boolean value.

If this method receives true, global color profiles (specified by other properties of this object such as getCmykProfile method and getRgbProfile method) and local color profiles ( ImGearRasterPage.getColorProfile} method) will be used to perform color space conversions. The default value is false.

Syntax

public static void enableProfiles(
   boolean value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getCmykProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getCmykProfile Method

Glossary Item Box

Gets global CMYK color profile to use for implicit color space conversions when global profiles are enabled.

ImGearColorProfile class object.

The default value is null.

Syntax

public static ImGearColorProfile getCmykProfile()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getGrayProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getGrayProfile Method

Glossary Item Box

Gets a color profile for Grayscale color space.

ImGearColorProfile class object.

The default value is null.

Syntax

public static ImGearColorProfile getGrayProfile()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getLabProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getLabProfile Method

Glossary Item Box

Gets a color profile for Lab color space.

The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes.

ImGearColorProfile class object. ImGearColorProfile

Syntax

public static ImGearColorProfile getLabProfile()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getProfile Method
colorSpace
Color space.

Glossary Item Box

Returns an instance of a color profile associated with the given color space.

Syntax

public static ImGearColorProfile getProfile(
   java.util.EnumSet<ImGearColorSpaceIDs> colorSpace
)

Parameters

colorSpace
Color space.

Return Value

ImGearColorProfile class object.

Represents an alternative way of obtaining profiles associated with color spaces. In particular, the profile associated with the gray color space could be obtained using getGrayProfile method or calling getProfile method with ImGearColorSpaceIDs .Gy parameter.

ImGearColorProfile ImGearColorSpaceIDs

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getRenderingIntent Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getRenderingIntent Method

Glossary Item Box

Gets rendering intent to use for implicit color space conversions when global profiles are enabled.

ImGearRenderingIntents enumeration value.

Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.

Syntax

public static ImGearRenderingIntents getRenderingIntent()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

getRgbProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : getRgbProfile Method

Glossary Item Box

Gets global RGB color profile to use for implicit color space conversions when global profiles are enabled.

ImGearColorProfile class object.

The default value is null.

Syntax

public static ImGearColorProfile getRgbProfile()

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

setCmykProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : setCmykProfile Method
value

Glossary Item Box

Sets global CMYK color profile to use for implicit color space conversions when global profiles are enabled.

ImGearColorProfile class object.

The default value is null.

Syntax

public static void setCmykProfile(
   ImGearColorProfile value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

setGrayProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : setGrayProfile Method
value

Glossary Item Box

Sets a color profile for Grayscale color space.

ImGearColorProfile class object.

The default value is null.

Syntax

public static void setGrayProfile(
   ImGearColorProfile value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

setLabProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : setLabProfile Method
value

Glossary Item Box

Sets a color profile for Lab color space.

The default value is the identity profile. It means that input Lab values are directly used as Lab Profile Connection Space values in the ICC conversion processes.

ImGearColorProfile class object. ImGearColorProfile

Syntax

public static void setLabProfile(
   ImGearColorProfile value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

setRenderingIntent Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : setRenderingIntent Method
value

Glossary Item Box

Sets rendering intent to use for implicit color space conversions when global profiles are enabled.

ImGearRenderingIntents enumeration value.

Rendering intent controls how color matching is performed during color space conversion. The default value is ImGearRenderingIntents.PERCEPTUAL.

Syntax

public static void setRenderingIntent(
   ImGearRenderingIntents value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

setRgbProfile Method
com.accusoft.imagegear.core Package > ImGearColorProfileManager Class : setRgbProfile Method
value

Glossary Item Box

Sets global RGB color profile to use for implicit color space conversions when global profiles are enabled.

ImGearColorProfile class object.

The default value is null.

ImGearColorProfile

Syntax

public static void setRgbProfile(
   ImGearColorProfile value
)

Parameters

value

See Also

Reference

ImGearColorProfileManager Class
ImGearColorProfileManager Members


%%PageItemTitle%%

ImGearColorSpace Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearColorSpace Class

Glossary Item Box

Defines semantics of information, stored in all image channels.

Object Model

ImGearColorSpace Class

Syntax

public sealed class ImGearColorSpace
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearColorSpace

See Also

Reference

ImGearColorSpace Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorSpace Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearColorSpace Class

Glossary Item Box

The following tables list the members exposed by ImGearColorSpace.

Public Constructors

 | Name | Description
public Constructor | ImGearColorSpace Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | containsAlpha | Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not. Boolean value. ImGearColorSpaceIDs
public Method | containsExtra | Gets a value indicating whether the colorspace contains extra (unknown) channels. Boolean value. ImGearColorSpaceIDs
public Method | getAlphaChannelCount | Gets the number of alpha channels in the color space. Any positive integer value.
public Method | getAlphaIndex | Gets the Index of the alpha channel in the color space. Any positive integer value.
public Method | getColor | Gets color part of value identifier. ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs
public Method | getColorChannelCount | Gets quantity of color channels. It does not include Alpha and Extra channels. Non-negative value that represents quantity of color channels.
public Method | getExtraChannelCount | Overloaded. Calculates quantity of extra channels in color space with given total channels quantity.
public Method | getExtraStartIndex | Gets the index of the first extra channel in the color space. Any positive integer value.
public Method | getValue | Gets the color space identifier. Well-formed combination of ImGearColorSpaceIDs enumeration values. See ImGearColorSpaceIDs for information on valid combinations of flags. Set accessor throws ImGearException if invalid value is passed.
public Method | isPremultiplied | Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not. Boolean value. ImGearColorSpaceIDs
static (Shared in Visual Basic) | isWellFormed | Verifies whether color space combination is valid (supported). See ImGearColorSpaceIDs for information on valid combinations of flags.
public Method | setValue | Sets the color space identifier. Well-formed combination of ImGearColorSpaceIDs enumeration values. See ImGearColorSpaceIDs for information on valid combinations of flags. Set accessor throws ImGearException if invalid value is passed.
Top

See Also

Reference

ImGearColorSpace Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearColorSpace Constructor
com.accusoft.imagegear.core Package > ImGearColorSpace Class : ImGearColorSpace Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearColorSpace Constructor(ImGearColorSpaceIDs) | Initializes a new instance of the ImGearColorSpaceIDs struct.
ImGearColorSpace Constructor(EnumSet<ImGearColorSpaceIDs>) | Initializes a new instance of the ImGearColorSpaceIDs struct.
ImGearColorSpace Constructor(int) | Constructor taking the bitwise "or" of the ImGearColorSpaceIDs values.

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

ImGearColorSpace Constructor(ImGearColorSpaceIDs)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorSpace Class > ImGearColorSpace Constructor : ImGearColorSpace Constructor(ImGearColorSpaceIDs)
value
Well-formed ImGearColorSpaceIDs flags.

Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit. See ImGearColorSpaceIDs for information on valid combinations of flags.

ImGearColorSpaceIDs

Glossary Item Box

Initializes a new instance of the ImGearColorSpaceIDs struct.

Syntax

public ImGearColorSpace(
   ImGearColorSpaceIDs value
)

Parameters

value
Well-formed ImGearColorSpaceIDs flags.

Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit. See ImGearColorSpaceIDs for information on valid combinations of flags.

ImGearColorSpaceIDs

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members
Overload List


%%PageItemTitle%%

ImGearColorSpace Constructor(EnumSet<ImGearColorSpaceIDs>)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorSpace Class > ImGearColorSpace Constructor : ImGearColorSpace Constructor(EnumSet<ImGearColorSpaceIDs>)
value
Well-formed combination of ImGearColorSpaceIDs flags.

Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit. See ImGearColorSpaceIDs for information on valid combinations of flags.

ImGearColorSpaceIDs

Glossary Item Box

Initializes a new instance of the ImGearColorSpaceIDs struct.

Syntax

public ImGearColorSpace(
   java.util.EnumSet<ImGearColorSpaceIDs> value
)

Parameters

value
Well-formed combination of ImGearColorSpaceIDs flags.

Initializes instance from combination of ImGearColorSpaceIDs flags. Pefroms verification of incoming value and throws ImGearException exception in case of any misfit. See ImGearColorSpaceIDs for information on valid combinations of flags.

ImGearColorSpaceIDs

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members
Overload List


%%PageItemTitle%%

ImGearColorSpace Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearColorSpace Class > ImGearColorSpace Constructor : ImGearColorSpace Constructor(int)
value
The bitwise "or" of the ImGearColorSpaceIDs values.

Glossary Item Box

Constructor taking the bitwise "or" of the ImGearColorSpaceIDs values.

Syntax

public ImGearColorSpace(
   int value
)

Parameters

value
The bitwise "or" of the ImGearColorSpaceIDs values.

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorSpace Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearColorSpace Class

Glossary Item Box

For a list of all members of this type, see ImGearColorSpace members.

Public Methods

 | Name | Description
public Method | containsAlpha | Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not. Boolean value. ImGearColorSpaceIDs
public Method | containsExtra | Gets a value indicating whether the colorspace contains extra (unknown) channels. Boolean value. ImGearColorSpaceIDs
public Method | getAlphaChannelCount | Gets the number of alpha channels in the color space. Any positive integer value.
public Method | getAlphaIndex | Gets the Index of the alpha channel in the color space. Any positive integer value.
public Method | getColor | Gets color part of value identifier. ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs
public Method | getColorChannelCount | Gets quantity of color channels. It does not include Alpha and Extra channels. Non-negative value that represents quantity of color channels.
public Method | getExtraChannelCount | Overloaded. Calculates quantity of extra channels in color space with given total channels quantity.
public Method | getExtraStartIndex | Gets the index of the first extra channel in the color space. Any positive integer value.
public Method | getValue | Gets the color space identifier. Well-formed combination of ImGearColorSpaceIDs enumeration values. See ImGearColorSpaceIDs for information on valid combinations of flags. Set accessor throws ImGearException if invalid value is passed.
public Method | isPremultiplied | Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not. Boolean value. ImGearColorSpaceIDs
static (Shared in Visual Basic) | isWellFormed | Verifies whether color space combination is valid (supported). See ImGearColorSpaceIDs for information on valid combinations of flags.
public Method | setValue | Sets the color space identifier. Well-formed combination of ImGearColorSpaceIDs enumeration values. See ImGearColorSpaceIDs for information on valid combinations of flags. Set accessor throws ImGearException if invalid value is passed.
Top

See Also

Reference

ImGearColorSpace Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

containsAlpha Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : containsAlpha Method

Glossary Item Box

Gets a value indicating whether the colorspace contains an alpha channel. It does not take into account whether the color channels are pre-multiplied by alpha channel or not.

Boolean value. ImGearColorSpaceIDs

Syntax

public boolean containsAlpha()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

containsExtra Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : containsExtra Method

Glossary Item Box

Gets a value indicating whether the colorspace contains extra (unknown) channels.

Boolean value. ImGearColorSpaceIDs

Syntax

public boolean containsExtra()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getAlphaChannelCount Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getAlphaChannelCount Method

Glossary Item Box

Gets the number of alpha channels in the color space.

Any positive integer value.

Syntax

public int getAlphaChannelCount()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getAlphaIndex Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getAlphaIndex Method

Glossary Item Box

Gets the Index of the alpha channel in the color space.

Any positive integer value.

Syntax

public int getAlphaIndex()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getColor Method

Glossary Item Box

Gets color part of value identifier.

ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs

Syntax

public java.util.EnumSet<ImGearColorSpaceIDs> getColor()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getColorChannelCount Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getColorChannelCount Method

Glossary Item Box

Gets quantity of color channels. It does not include Alpha and Extra channels.

Non-negative value that represents quantity of color channels.

Syntax

public int getColorChannelCount()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getExtraChannelCount Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getExtraChannelCount Method

Glossary Item Box

Calculates quantity of extra channels in color space with given total channels quantity.

Overload List

Overload | Description
getExtraChannelCount(int) | Calculates quantity of extra channels in color space with given total channels quantity.
getExtraChannelCount(int[]) | Calculates quantity of extra channels in color space with given channels array.

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getExtraChannelCount(int) Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class > getExtraChannelCount Method : getExtraChannelCount(int) Method
totalChannelCount
Total quantity of channels in the image.

Glossary Item Box

Calculates quantity of extra channels in color space with given total channels quantity.

Syntax

public int getExtraChannelCount(
   int totalChannelCount
)

Parameters

totalChannelCount
Total quantity of channels in the image.

Return Value

Quantity of extra channels or zero in case if color-space value doesn't contain ImGearColorSpaceIDs.Ex bit. ImGearColorSpaceIDs

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members
Overload List


%%PageItemTitle%%

getExtraChannelCount(int[]) Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class > getExtraChannelCount Method : getExtraChannelCount(int[]) Method
channels
Array of channels in the image.

Glossary Item Box

Calculates quantity of extra channels in color space with given channels array.

Syntax

public int getExtraChannelCount(
   int[] channels
)

Parameters

channels
Array of channels in the image.

Return Value

Quantity of extra channels or zero in case if color-space value doesn't contain ImGearColorSpaceIDs.Ex bit. ImGearColorSpaceIDs

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members
Overload List


%%PageItemTitle%%

getExtraStartIndex Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getExtraStartIndex Method

Glossary Item Box

Gets the index of the first extra channel in the color space.

Any positive integer value.

Syntax

public int getExtraStartIndex()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : getValue Method

Glossary Item Box

Gets the color space identifier.

Well-formed combination of ImGearColorSpaceIDs enumeration values.

See ImGearColorSpaceIDs for information on valid combinations of flags.

Set accessor throws ImGearException if invalid value is passed.

Syntax

public java.util.EnumSet<ImGearColorSpaceIDs> getValue()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

isPremultiplied Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : isPremultiplied Method

Glossary Item Box

Gets a value indicating whether colorspace color channels are pre-multiplied by alpha values or not.

Boolean value. ImGearColorSpaceIDs

Syntax

public boolean isPremultiplied()

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

isWellFormed Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : isWellFormed Method
value
Color space ID.

Glossary Item Box

Verifies whether color space combination is valid (supported).

See ImGearColorSpaceIDs for information on valid combinations of flags.

Syntax

public static boolean isWellFormed(
   java.util.EnumSet<ImGearColorSpaceIDs> value
)

Parameters

value
Color space ID.

Return Value

Boolean value. ImGearColorSpaceIDs

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.core Package > ImGearColorSpace Class : setValue Method
value

Glossary Item Box

Sets the color space identifier.

Well-formed combination of ImGearColorSpaceIDs enumeration values.

See ImGearColorSpaceIDs for information on valid combinations of flags.

Set accessor throws ImGearException if invalid value is passed.

Syntax

public void setValue(
   java.util.EnumSet<ImGearColorSpaceIDs> value
)

Parameters

value

See Also

Reference

ImGearColorSpace Class
ImGearColorSpace Members


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearCommonMetadataDictRecord Class

Glossary Item Box

Contains data for a common metadata dictionary record.

This structure is used with most ImageGear supported formats.

Object Model

ImGearCommonMetadataDictRecord Class

Syntax

public sealed class ImGearCommonMetadataDictRecord
    extends Object
    implements IImGearMetadataDictRecord

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearCommonMetadataDictRecord

See Also

Reference

ImGearCommonMetadataDictRecord Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearCommonMetadataDictRecord Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearCommonMetadataDictRecord Class

Glossary Item Box

The following tables list the members exposed by ImGearCommonMetadataDictRecord.

Public Constructors

 | Name | Description
public Constructor | ImGearCommonMetadataDictRecord Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getName | Sets the tag name. Any string. The default value is "".
public Method | getTag | Gets the tag ID value. Any integer number. The default value is 0.
public Method | setName | Sets the tag name. Any string. The default value is "".
public Method | setTag | Sets the tag ID value. Any integer number. The default value is 0.
Top

See Also

Reference

ImGearCommonMetadataDictRecord Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Constructor
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class : ImGearCommonMetadataDictRecord Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearCommonMetadataDictRecord Constructor() | Default constructor.
ImGearCommonMetadataDictRecord Constructor(int,String) | Initializes a new instance of the ImGearCommonMetadataDictRecord class.

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class > ImGearCommonMetadataDictRecord Constructor : ImGearCommonMetadataDictRecord Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearCommonMetadataDictRecord()

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members
Overload List


%%PageItemTitle%%

ImGearCommonMetadataDictRecord Constructor(int,String)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class > ImGearCommonMetadataDictRecord Constructor : ImGearCommonMetadataDictRecord Constructor(int,String)
tag
tag ID value.
name
tag name value.

Glossary Item Box

Initializes a new instance of the ImGearCommonMetadataDictRecord class.

Syntax

public ImGearCommonMetadataDictRecord(
   int tag,
   java.lang.String name
)

Parameters

tag
tag ID value.
name
tag name value.

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearCommonMetadataDictRecord Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearCommonMetadataDictRecord Class

Glossary Item Box

For a list of all members of this type, see ImGearCommonMetadataDictRecord members.

Public Methods

 | Name | Description
public Method | getName | Sets the tag name. Any string. The default value is "".
public Method | getTag | Gets the tag ID value. Any integer number. The default value is 0.
public Method | setName | Sets the tag name. Any string. The default value is "".
public Method | setTag | Sets the tag ID value. Any integer number. The default value is 0.
Top

See Also

Reference

ImGearCommonMetadataDictRecord Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class : getName Method

Glossary Item Box

Sets the tag name.

Any string.

The default value is "".

Syntax

public java.lang.String getName()

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

getTag Method
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class : getTag Method

Glossary Item Box

Gets the tag ID value.

Any integer number.

The default value is 0.

Syntax

public int getTag()

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class : setName Method
value

Glossary Item Box

Sets the tag name.

Any string.

The default value is "".

Syntax

public void setName(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

setTag Method
com.accusoft.imagegear.core Package > ImGearCommonMetadataDictRecord Class : setTag Method
value

Glossary Item Box

Sets the tag ID value.

Any integer number.

The default value is 0.

Syntax

public void setTag(
   int value
)

Parameters

value

See Also

Reference

ImGearCommonMetadataDictRecord Class
ImGearCommonMetadataDictRecord Members


%%PageItemTitle%%

ImGearDIB Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDIB Class

Glossary Item Box

Encapsulates an image, which consists of the pixel data and its attributes.

This class does not have public constructors. Instances of ImGearDIB exist only as a member objects of ImGearPage or ImGearROIMask classes.

Object Model

ImGearDIB ClassImGearDIB ClassImGearPixelArray ClassImGearColorSpace ClassImGearPixelArray ClassImGearExtraChannelInfo ClassImGearArrayRef ClassIImGearResolution InterfaceImGearPixelArray ClassImGearRGBQuad ClassImGearPixel ClassImGearArrayRef ClassImGearPixelArray Class

Syntax

public abstract class ImGearDIB
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDIB

See Also

Reference

ImGearDIB Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDIB Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDIB Class

Glossary Item Box

The following tables list the members exposed by ImGearDIB.

Protected Fields

 | Name | Description
protected Field | bitDepth | Total quantity of bits used to represent a single pixel.
protected Field | bitsPerChannel | Allocated (actual) size of store for each channel in bits.
protected Field | channelDepths | Depth of image channels.
protected Field | colorSpace | Color space attribute.
protected Field | extraChannelInfo | Information on image Extra channels. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
protected Field | height | Image heigth in pixels.
protected Field | imageResolution | Image resolution information.
protected Field | palette | Image palette, for images that have Indexed colorspace. Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects. Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.
protected Field | signed | Specifies whether the image is signed.
protected Field | width | Image width in pixels.
Top

Public Methods

Name | Description
public Method allocateImage Allocates pixel data based on the DIB header information.

Allocates store for pixel data based on the DIB header information. Previous store will be lost if any allocation was made before.

public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getAreaCopy | Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
public Method getBitDepth Gets total quantity of bits used to store a single pixel.

Positive value that represents size of a single pixel in bits.

public Method getBitsPerChannel Gets allocated (actual) size of store for each channel in bits.

Positive number that specifies the actual size of channel in bits.

Returns allocated (actual) size of any image channel in bits. The values 8, 16 and 32 are used as a basis for the array allocation.

Value returned by this method is correct for uncompressed DIBs only. Compressed DIBs have a different channel structure. For these sorts of DIBs this method always returns 8, although this value has no real meaning.

public Method getChannelCount Gets total quantity of channels in image.

Non-zero channels quantity.

Returns the same value as ChannelDepth.Length.

public Method getChannelDepths Gets the bit depth of each color channel in the image.

Integer array.

public Method getColorSpace Gets color Space of current image.

ImGearColorSpace structure. ImGearColorSpace

public Method | getColumnCopy | Returns an array of pixels that are exact copies of pixels located in requested column part.
public Method getExtraChannelInfo Returns extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

public Method getHeight Gets height of image in pixels.

Integer value.

public Method | getImage | Returns a reference to raw image store. Should be used to gain direct access to image pixels.
public Method getImageResolution Returns image resolution.

IImGearResolution

public Method | getLineCopy | Returns an array of pixels that are exact copies of pixels located in the requested area of image.
public Method getPalette Returns image palette, for images that have Indexed colorspace.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

public Method | getPixelCopy | Returns exact copy of requested pixel.
public Method | getRaster | Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
public Method | getRowCopy | Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.
public Method getWidth Gets width of image in pixels.

Integer value.

public Method isEmpty Tells whether store for the pixels has been allocated.

Pixel store can be allocated during DIB (page) creation or by allocateImage method.

public Method isSigned Returns a value indicating whether image is signed or not.

public Method setExtraChannelInfo Sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

public Method setImageResolution Sets image resolution.

IImGearResolution

public Method setPalette Sets image palette, for images that have Indexed colorspace.

Array of ImGearRGBQuad structure objects or null.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

public Method setSigned Sets a value indicating whether image is signed or not.

public Method | updateAreaFrom | Updates the pixels of the specified rectangular area.
public Method | updateColumnFrom | Updates part of column with new pixels.
public Method | updateLineFrom | Exchanges the pixels of the specified line with new pixels.
public Method | updatePixelFrom | Updates single pixel with new value.
public Method | updateRowFrom | Updates part of row with new pixels.
Top

Protected Methods

 | Name | Description
protected Method | copyImageTo | Copies internal image data to incoming dib.
Top

See Also

Reference

ImGearDIB Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDIB Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDIB Class

Glossary Item Box

For a list of all members of this type, see ImGearDIB members.

Public Methods

Name | Description
public Method allocateImage Allocates pixel data based on the DIB header information.

Allocates store for pixel data based on the DIB header information. Previous store will be lost if any allocation was made before.

public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getAreaCopy | Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.
public Method getBitDepth Gets total quantity of bits used to store a single pixel.

Positive value that represents size of a single pixel in bits.

public Method getBitsPerChannel Gets allocated (actual) size of store for each channel in bits.

Positive number that specifies the actual size of channel in bits.

Returns allocated (actual) size of any image channel in bits. The values 8, 16 and 32 are used as a basis for the array allocation.

Value returned by this method is correct for uncompressed DIBs only. Compressed DIBs have a different channel structure. For these sorts of DIBs this method always returns 8, although this value has no real meaning.

public Method getChannelCount Gets total quantity of channels in image.

Non-zero channels quantity.

Returns the same value as ChannelDepth.Length.

public Method getChannelDepths Gets the bit depth of each color channel in the image.

Integer array.

public Method getColorSpace Gets color Space of current image.

ImGearColorSpace structure. ImGearColorSpace

public Method | getColumnCopy | Returns an array of pixels that are exact copies of pixels located in requested column part.
public Method getExtraChannelInfo Returns extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

public Method getHeight Gets height of image in pixels.

Integer value.

public Method | getImage | Returns a reference to raw image store. Should be used to gain direct access to image pixels.
public Method getImageResolution Returns image resolution.

IImGearResolution

public Method | getLineCopy | Returns an array of pixels that are exact copies of pixels located in the requested area of image.
public Method getPalette Returns image palette, for images that have Indexed colorspace.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

public Method | getPixelCopy | Returns exact copy of requested pixel.
public Method | getRaster | Returns reference to raw raster store. Should be used to gain direct access to raster pixels.
public Method | getRowCopy | Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.
public Method getWidth Gets width of image in pixels.

Integer value.

public Method isEmpty Tells whether store for the pixels has been allocated.

Pixel store can be allocated during DIB (page) creation or by allocateImage method.

public Method isSigned Returns a value indicating whether image is signed or not.

public Method setExtraChannelInfo Sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

public Method setImageResolution Sets image resolution.

IImGearResolution

public Method setPalette Sets image palette, for images that have Indexed colorspace.

Array of ImGearRGBQuad structure objects or null.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

public Method setSigned Sets a value indicating whether image is signed or not.

public Method | updateAreaFrom | Updates the pixels of the specified rectangular area.
public Method | updateColumnFrom | Updates part of column with new pixels.
public Method | updateLineFrom | Exchanges the pixels of the specified line with new pixels.
public Method | updatePixelFrom | Updates single pixel with new value.
public Method | updateRowFrom | Updates part of row with new pixels.
Top

Protected Methods

 | Name | Description
protected Method | copyImageTo | Copies internal image data to incoming dib.
Top

See Also

Reference

ImGearDIB Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

allocateImage Method
com.accusoft.imagegear.core Package > ImGearDIB Class : allocateImage Method

Glossary Item Box

Allocates pixel data based on the DIB header information.

Allocates store for pixel data based on the DIB header information. Previous store will be lost if any allocation was made before.

Syntax

public abstract void allocateImage()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearDIB Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearDIB clone()

Return Value

Non-null instance of ImGearDIB class.

In contrast to MemberwiseClone, this member provides deep copy of object (i.e., all internal objects are cloned as well).

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

copyImageTo Method
com.accusoft.imagegear.core Package > ImGearDIB Class : copyImageTo Method
dib
Dib for copy to.

Glossary Item Box

Copies internal image data to incoming dib.

Syntax

protected abstract void copyImageTo(
   ImGearDIB dib
)

Parameters

dib
Dib for copy to.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getAreaCopy Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getAreaCopy Method
startColumn
X coordinate of top-left point of rectangular area.
startRow
Y coordinate of top-left point of rectangular area.
endColumn
X coordinate of bottom-right point of rectangular area.
endRow
Y coordinate of bottom-right point of rectangular area.

Glossary Item Box

Returns an array of pixels that are exact copies of pixels in the requested rectangular part of the image.

Syntax

public abstract ImGearPixelArray getAreaCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)

Parameters

startColumn
X coordinate of top-left point of rectangular area.
startRow
Y coordinate of top-left point of rectangular area.
endColumn
X coordinate of bottom-right point of rectangular area.
endRow
Y coordinate of bottom-right point of rectangular area.

Return Value

ImGearPixelArray class object.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getBitDepth Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getBitDepth Method

Glossary Item Box

Gets total quantity of bits used to store a single pixel.

Positive value that represents size of a single pixel in bits.

Syntax

public int getBitDepth()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getBitsPerChannel Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getBitsPerChannel Method

Glossary Item Box

Gets allocated (actual) size of store for each channel in bits.

Positive number that specifies the actual size of channel in bits.

Returns allocated (actual) size of any image channel in bits. The values 8, 16 and 32 are used as a basis for the array allocation.

Value returned by this method is correct for uncompressed DIBs only. Compressed DIBs have a different channel structure. For these sorts of DIBs this method always returns 8, although this value has no real meaning.

Syntax

public int getBitsPerChannel()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getChannelCount Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getChannelCount Method

Glossary Item Box

Gets total quantity of channels in image.

Non-zero channels quantity.

Returns the same value as ChannelDepth.Length.

Syntax

public int getChannelCount()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getChannelDepths Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getChannelDepths Method

Glossary Item Box

Gets the bit depth of each color channel in the image.

Integer array.

Syntax

public int[] getChannelDepths()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getColorSpace Method

Glossary Item Box

Gets color Space of current image.

ImGearColorSpace structure. ImGearColorSpace

Syntax

public ImGearColorSpace getColorSpace()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getColumnCopy Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getColumnCopy Method
column
Number of column in image.
row
Y offset in requested column.
pixelsQty
Quantity of pixels to be retrieved.

Glossary Item Box

Returns an array of pixels that are exact copies of pixels located in requested column part.

Syntax

public abstract ImGearPixelArray getColumnCopy(
   int column,
   int row,
   int pixelsQty
)

Parameters

column
Number of column in image.
row
Y offset in requested column.
pixelsQty
Quantity of pixels to be retrieved.

Return Value

ImGearPixelArray class instance.

Throws exception if specified points are outside image bounds.

ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getExtraChannelInfo Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getExtraChannelInfo Method

Glossary Item Box

Returns extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

Syntax

public ImGearExtraChannelInfo[] getExtraChannelInfo()

Return Value

Array of ImGearExtraChannelInfo class objects.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getHeight Method

Glossary Item Box

Gets height of image in pixels.

Integer value.

Syntax

public int getHeight()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getImage Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getImage Method

Glossary Item Box

Returns a reference to raw image store. Should be used to gain direct access to image pixels.

Syntax

public abstract ImGearArrayRef getImage()

Return Value

ImGearArrayRef structure instance.

May be used to obtain direct access to the entire image store.

Structure of image store depends on channels structure and may differ for different DIBs.

Rasters in ImageGear for Java pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for Java can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

Note that the +31 and & ~31 indicate DWORD alignment.

ImGearArrayRef

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getImageResolution Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getImageResolution Method

Glossary Item Box

Returns image resolution.

IImGearResolution

Syntax

public IImGearResolution getImageResolution()

Return Value

ImGearResolution structure object.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getLineCopy Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getLineCopy Method
startColumn
X dimension of line start point.
startRow
Y dimension of line start point.
endColumn
X dimension of line end point.
endRow
Y dimension of line end point.

Glossary Item Box

Returns an array of pixels that are exact copies of pixels located in the requested area of image.

Syntax

public abstract ImGearPixelArray getLineCopy(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow
)

Parameters

startColumn
X dimension of line start point.
startRow
Y dimension of line start point.
endColumn
X dimension of line end point.
endRow
Y dimension of line end point.

Return Value

ImGearPixelArray class instance.

Incoming coordinates must not exceed the image area bounds. Otherwise, an exception will be thrown.

ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getPalette Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getPalette Method

Glossary Item Box

Returns image palette, for images that have Indexed colorspace.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

Syntax

public ImGearRGBQuad[] getPalette()

Return Value

Array of ImGearRGBQuad structure objects or null.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getPixelCopy Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getPixelCopy Method
column
X coordinate of requested pixel.
row
Y coordinate of requested pixel.

Glossary Item Box

Returns exact copy of requested pixel.

Syntax

public abstract ImGearPixel getPixelCopy(
   int column,
   int row
)

Parameters

column
X coordinate of requested pixel.
row
Y coordinate of requested pixel.

Return Value

ImGearPixel class instance.

Throws an exception if the coordinates of the requested pixel are outside of the image bounds.

ImGearPixel

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getRaster Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getRaster Method
row
Number of requested row.

Glossary Item Box

Returns reference to raw raster store. Should be used to gain direct access to raster pixels.

Syntax

public abstract ImGearArrayRef getRaster(
   int row
)

Parameters

row
Number of requested row.

Return Value

ImGearArrayRef structure instance that refers to the raster raw store.

May be used to obtain direct access to the pixels in the raster.

In ImageGear for Java, all rasters are kept and indexed in the normal form: the first raster is the top raster, the last raster is the bottom raster. This differs from BMP and older ImageGear versions, where rasters are stored in reverse mode: from bottom to top.

Rasters in ImageGear for Java pixel storage are DWORD-aligned.

Raster size for standard DIBs (not run-ends) in ImageGear for Java can be calculated using the following formula:

((Width * BitsPerChannel * ChannelCount + 31) & ~31) / BitsPerChannel

The +31 and & ~31 indicate DWORD alignment. The raster size is in terms of channel values. To calculate the raster size in terms of bytes, divide by 8 instead of BitsPerChannel.

ImGearArrayRef

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getRowCopy Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getRowCopy Method
column
X offset in requested row.
row
Number of row in image.
pixelsQty
Quantity of pixels to be retrieved.

Glossary Item Box

Returns an array of pixels that are exact copies of the pixels located in requested row part of the row.

Syntax

public abstract ImGearPixelArray getRowCopy(
   int column,
   int row,
   int pixelsQty
)

Parameters

column
X offset in requested row.
row
Number of row in image.
pixelsQty
Quantity of pixels to be retrieved.

Return Value

Non-null reference to ImGearPixelArray class.

Throws an exception if the specified points are outside of the image area.

ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.core Package > ImGearDIB Class : getWidth Method

Glossary Item Box

Gets width of image in pixels.

Integer value.

Syntax

public int getWidth()

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core Package > ImGearDIB Class : isEmpty Method

Glossary Item Box

Tells whether store for the pixels has been allocated.

Pixel store can be allocated during DIB (page) creation or by allocateImage method.

Syntax

public abstract boolean isEmpty()

Return Value

Boolean value. allocateImage

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

isSigned Method
com.accusoft.imagegear.core Package > ImGearDIB Class : isSigned Method

Glossary Item Box

Returns a value indicating whether image is signed or not.

Syntax

public boolean isSigned()

Return Value

Boolean value.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

setExtraChannelInfo Method
com.accusoft.imagegear.core Package > ImGearDIB Class : setExtraChannelInfo Method
value

Glossary Item Box

Sets extra channel info. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

ImGearExtraChannelInfo

Syntax

public void setExtraChannelInfo(
   ImGearExtraChannelInfo[] value
)

Parameters

value

Return Value

Array of ImGearExtraChannelInfo class objects.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

setImageResolution Method
com.accusoft.imagegear.core Package > ImGearDIB Class : setImageResolution Method
value
ImGearResolution structure object.

Glossary Item Box

Sets image resolution.

IImGearResolution

Syntax

public void setImageResolution(
   IImGearResolution value
)

Parameters

value
ImGearResolution structure object.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

setPalette Method
com.accusoft.imagegear.core Package > ImGearDIB Class : setPalette Method
value
Array of ImGearRGBQuad structure objects or null.

Glossary Item Box

Sets image palette, for images that have Indexed colorspace.

Array of ImGearRGBQuad structure objects or null.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

ImGearRGBQuad

Syntax

public void setPalette(
   ImGearRGBQuad[] value
)

Parameters

value
Array of ImGearRGBQuad structure objects or null.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

setSigned Method
com.accusoft.imagegear.core Package > ImGearDIB Class : setSigned Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether image is signed or not.

Syntax

public void setSigned(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

updateAreaFrom Method
com.accusoft.imagegear.core Package > ImGearDIB Class : updateAreaFrom Method
startColumn
X coordinate of top-left point of area to be updated.
startRow
Y coordinate of top-left point of area to be updated.
endColumn
X coordinate of bottom-right point of area to be updated.
endRow
Y coordinate of bottom-right point of area to be updated.
pixels
New values for the pixels being updated. ImGearPixelArray

Glossary Item Box

Updates the pixels of the specified rectangular area.

Syntax

public abstract void updateAreaFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray pixels
)

Parameters

startColumn
X coordinate of top-left point of area to be updated.
startRow
Y coordinate of top-left point of area to be updated.
endColumn
X coordinate of bottom-right point of area to be updated.
endRow
Y coordinate of bottom-right point of area to be updated.
pixels
New values for the pixels being updated. ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

updateColumnFrom Method
com.accusoft.imagegear.core Package > ImGearDIB Class : updateColumnFrom Method
column
Number of column to update.
row
Y offset in column.
pixels
New values for pixels being updated. ImGearPixelArray

Glossary Item Box

Updates part of column with new pixels.

Syntax

public abstract void updateColumnFrom(
   int column,
   int row,
   ImGearPixelArray pixels
)

Parameters

column
Number of column to update.
row
Y offset in column.
pixels
New values for pixels being updated. ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

updateLineFrom Method
com.accusoft.imagegear.core Package > ImGearDIB Class : updateLineFrom Method
startColumn
X coordinate of line start.
startRow
Y coordinate of line start.
endColumn
X coordinate of line end.
endRow
Y coordinate of line end.
pixels
New values for pixels being updated. ImGearPixelArray

Glossary Item Box

Exchanges the pixels of the specified line with new pixels.

Syntax

public abstract void updateLineFrom(
   int startColumn,
   int startRow,
   int endColumn,
   int endRow,
   ImGearPixelArray pixels
)

Parameters

startColumn
X coordinate of line start.
startRow
Y coordinate of line start.
endColumn
X coordinate of line end.
endRow
Y coordinate of line end.
pixels
New values for pixels being updated. ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

updatePixelFrom Method
com.accusoft.imagegear.core Package > ImGearDIB Class : updatePixelFrom Method
column
X coordinate of pixel.
row
Y coordinate of pixel.
pixel
New value for the pixel. ImGearPixel

Glossary Item Box

Updates single pixel with new value.

Syntax

public abstract void updatePixelFrom(
   int column,
   int row,
   ImGearPixel pixel
)

Parameters

column
X coordinate of pixel.
row
Y coordinate of pixel.
pixel
New value for the pixel. ImGearPixel

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

updateRowFrom Method
com.accusoft.imagegear.core Package > ImGearDIB Class : updateRowFrom Method
column
X offset in row.
row
Number of row to be updated.
pixels
New values for the pixels being updated.

Updates the pixels of the specified row area.

ImGearPixelArray

Glossary Item Box

Updates part of row with new pixels.

Syntax

public abstract void updateRowFrom(
   int column,
   int row,
   ImGearPixelArray pixels
)

Parameters

column
X offset in row.
row
Number of row to be updated.
pixels
New values for the pixels being updated.

Updates the pixels of the specified row area.

ImGearPixelArray

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDIB Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDIB Class

Glossary Item Box

For a list of all members of this type, see ImGearDIB members.

Protected Fields

 | Name | Description
protected Field | bitDepth | Total quantity of bits used to represent a single pixel.
protected Field | bitsPerChannel | Allocated (actual) size of store for each channel in bits.
protected Field | channelDepths | Depth of image channels.
protected Field | colorSpace | Color space attribute.
protected Field | extraChannelInfo | Information on image Extra channels. Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.
protected Field | height | Image heigth in pixels.
protected Field | imageResolution | Image resolution information.
protected Field | palette | Image palette, for images that have Indexed colorspace. Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects. Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.
protected Field | signed | Specifies whether the image is signed.
protected Field | width | Image width in pixels.
Top

See Also

Reference

ImGearDIB Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

bitDepth Field
com.accusoft.imagegear.core Package > ImGearDIB Class : bitDepth Field

Glossary Item Box

Total quantity of bits used to represent a single pixel.

Syntax

protected int bitDepth

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

bitsPerChannel Field
com.accusoft.imagegear.core Package > ImGearDIB Class : bitsPerChannel Field

Glossary Item Box

Allocated (actual) size of store for each channel in bits.

Syntax

protected int bitsPerChannel

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

channelDepths Field
com.accusoft.imagegear.core Package > ImGearDIB Class : channelDepths Field

Glossary Item Box

Depth of image channels.

Syntax

protected int[] channelDepths

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

colorSpace Field
com.accusoft.imagegear.core Package > ImGearDIB Class : colorSpace Field

Glossary Item Box

Color space attribute.

Syntax

protected ImGearColorSpace colorSpace

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

extraChannelInfo Field
com.accusoft.imagegear.core Package > ImGearDIB Class : extraChannelInfo Field

Glossary Item Box

Information on image Extra channels.

Always non-null, length is always equal to number of extra channels in the image. Has zero length if the image contains no extra channels.

Syntax

protected ImGearExtraChannelInfo[] extraChannelInfo

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

height Field
com.accusoft.imagegear.core Package > ImGearDIB Class : height Field

Glossary Item Box

Image heigth in pixels.

Syntax

protected int height

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

imageResolution Field
com.accusoft.imagegear.core Package > ImGearDIB Class : imageResolution Field

Glossary Item Box

Image resolution information.

Syntax

protected IImGearResolution imageResolution

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

palette Field
com.accusoft.imagegear.core Package > ImGearDIB Class : palette Field

Glossary Item Box

Image palette, for images that have Indexed colorspace.

Provides full access to the DIB's palette represented as an array of ImGearRGBQuad structure objects.

Palette must be present in images that have ImGearColorSpaceIDs.I colorspace. Palette is ignored in images that have other colorspaces.

Syntax

protected ImGearRGBQuad[] palette

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

signed Field
com.accusoft.imagegear.core Package > ImGearDIB Class : signed Field

Glossary Item Box

Specifies whether the image is signed.

Syntax

protected boolean signed

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

width Field
com.accusoft.imagegear.core Package > ImGearDIB Class : width Field

Glossary Item Box

Image width in pixels.

Syntax

protected int width

See Also

Reference

ImGearDIB Class
ImGearDIB Members


%%PageItemTitle%%

ImGearDICOMMetadataDictRecord Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDICOMMetadataDictRecord Class

Glossary Item Box

Represents basic information about DICOM Data Element.

See PS 3.6 2008, Registry of DICOM data elements table. The names of properties are equivalents to corresponding columns of the table.

Object Model

ImGearDICOMMetadataDictRecord Class

Syntax

public class ImGearDICOMMetadataDictRecord
    extends Object
    implements IImGearMetadataDictRecord

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDICOMMetadataDictRecord

See Also

Reference

ImGearDICOMMetadataDictRecord Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDICOMMetadataDictRecord Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDICOMMetadataDictRecord Class

Glossary Item Box

The following tables list the members exposed by ImGearDICOMMetadataDictRecord.

Public Constructors

 | Name | Description
public Constructor | ImGearDICOMMetadataDictRecord Constructor | Initializes a new instance of the ImGearDICOMMetadataDictRecord class object.
Top

Public Fields

 | Name | Description
public Field | maxMultiplicity | Provides access to max value multiplicity.
public Field | valueRepresentation | Provides access to value representation.
Top

Public Methods

 | Name | Description
public Method | getName | Gets DICOM tag name.
public Method | getTag | Gets DICOM tag ID.
public Method | setName | Sets DICOM tag name.
public Method | setTag | Sets DICOM tag ID.
Top

See Also

Reference

ImGearDICOMMetadataDictRecord Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearDICOMMetadataDictRecord Constructor
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : ImGearDICOMMetadataDictRecord Constructor
tag
DICOM tag ID.
name
DICM tag name.
valueRepresentation
Value representation.
maxValueMultiplicity
Maximal value multiplicity.

Glossary Item Box

Initializes a new instance of the ImGearDICOMMetadataDictRecord class object.

Syntax

public ImGearDICOMMetadataDictRecord(
   int tag,
   java.lang.String name,
   ImGearDICOMValueRepresentations valueRepresentation,
   int maxValueMultiplicity
)

Parameters

tag
DICOM tag ID.
name
DICM tag name.
valueRepresentation
Value representation.
maxValueMultiplicity
Maximal value multiplicity.

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDICOMMetadataDictRecord Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDICOMMetadataDictRecord Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMMetadataDictRecord members.

Public Methods

 | Name | Description
public Method | getName | Gets DICOM tag name.
public Method | getTag | Gets DICOM tag ID.
public Method | setName | Sets DICOM tag name.
public Method | setTag | Sets DICOM tag ID.
Top

See Also

Reference

ImGearDICOMMetadataDictRecord Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : getName Method

Glossary Item Box

Gets DICOM tag name.

Syntax

public java.lang.String getName()

Return Value

Any string value.

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%%

getTag Method
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : getTag Method

Glossary Item Box

Gets DICOM tag ID.

Syntax

public int getTag()

Return Value

Any valid DICOM tag ID.

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : setName Method
value
Any string value.

Glossary Item Box

Sets DICOM tag name.

Syntax

public void setName(
   java.lang.String value
)

Parameters

value
Any string value.

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%%

setTag Method
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : setTag Method
value
Any valid DICOM tag ID.

Glossary Item Box

Sets DICOM tag ID.

Syntax

public void setTag(
   int value
)

Parameters

value
Any valid DICOM tag ID.

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDICOMMetadataDictRecord Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDICOMMetadataDictRecord Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMMetadataDictRecord members.

Public Fields

 | Name | Description
public Field | maxMultiplicity | Provides access to max value multiplicity.
public Field | valueRepresentation | Provides access to value representation.
Top

See Also

Reference

ImGearDICOMMetadataDictRecord Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

maxMultiplicity Field
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : maxMultiplicity Field

Glossary Item Box

Provides access to max value multiplicity.

Syntax

public int maxMultiplicity

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%%

valueRepresentation Field
com.accusoft.imagegear.core Package > ImGearDICOMMetadataDictRecord Class : valueRepresentation Field

Glossary Item Box

Provides access to value representation.

Syntax

public ImGearDICOMValueRepresentations valueRepresentation

See Also

Reference

ImGearDICOMMetadataDictRecord Class
ImGearDICOMMetadataDictRecord Members


%%PageItemTitle%%

ImGearDisplayChannel Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannel Class

Glossary Item Box

Represents display attributes for individual channel.

Object Model

ImGearDisplayChannel Class

Syntax

public class ImGearDisplayChannel
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDisplayChannel

See Also

Reference

ImGearDisplayChannel Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDisplayChannel Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannel Class

Glossary Item Box

The following tables list the members exposed by ImGearDisplayChannel.

Public Constructors

 | Name | Description
public Constructor | ImGearDisplayChannel Constructor | Initializes a new instance of the ImGearDisplayChannels class object.
Top

Public Methods

 | Name | Description
public Method | isVisible | Returns a value indicating whether the display channel is visibile.
public Method | setVisible | Sets a value indicating whether the display channel is visibile.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearDisplayChannel Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDisplayChannel Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannel Class

Glossary Item Box

For a list of all members of this type, see ImGearDisplayChannel members.

See Also

Reference

ImGearDisplayChannel Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearDisplayChannel Constructor
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : ImGearDisplayChannel Constructor

Glossary Item Box

Initializes a new instance of the ImGearDisplayChannels class object.

Syntax

public ImGearDisplayChannel()

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDisplayChannel Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannel Class

Glossary Item Box

For a list of all members of this type, see ImGearDisplayChannel members.

Public Methods

 | Name | Description
public Method | isVisible | Returns a value indicating whether the display channel is visibile.
public Method | setVisible | Sets a value indicating whether the display channel is visibile.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearDisplayChannel Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : isVisible Method

Glossary Item Box

Returns a value indicating whether the display channel is visibile.

Syntax

public boolean isVisible()

Return Value

Boolean value.

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

setVisible Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : setVisible Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether the display channel is visibile.

Syntax

public void setVisible(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearDisplayChannel Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearDisplayChannel Class
ImGearDisplayChannel Members


%%PageItemTitle%%

ImGearDisplayChannels Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannels Class

Glossary Item Box

Represents a collection of ImGearDisplayChannel class objects.

Object Model

ImGearDisplayChannels ClassImGearDisplayChannel Class

Syntax

public class ImGearDisplayChannels
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDisplayChannels

See Also

Reference

ImGearDisplayChannels Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDisplayChannels Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannels Class

Glossary Item Box

The following tables list the members exposed by ImGearDisplayChannels.

Public Methods

 | Name | Description
public Method | copyTo | Copies a range of elements to the specified array.
public Method | getCount | Gets the number of ImGearDisplayChannel class objects in the collection. Integer value. ImGearDisplayChannel
public Method | getItem | Gets the collection member with specified index.
public Method | iterator | Returns Iterator<ImGearDisplayChannel> interface used for enumeration over all ImGearDisplayChannel classes. objects in the collection.
public Method | setItem | Sets the collection member with specified index.
Top

See Also

Reference

ImGearDisplayChannels Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDisplayChannels Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannels Class

Glossary Item Box

For a list of all members of this type, see ImGearDisplayChannels members.

See Also

Reference

ImGearDisplayChannels Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDisplayChannels Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDisplayChannels Class

Glossary Item Box

For a list of all members of this type, see ImGearDisplayChannels members.

Public Methods

 | Name | Description
public Method | copyTo | Copies a range of elements to the specified array.
public Method | getCount | Gets the number of ImGearDisplayChannel class objects in the collection. Integer value. ImGearDisplayChannel
public Method | getItem | Gets the collection member with specified index.
public Method | iterator | Returns Iterator<ImGearDisplayChannel> interface used for enumeration over all ImGearDisplayChannel classes. objects in the collection.
public Method | setItem | Sets the collection member with specified index.
Top

See Also

Reference

ImGearDisplayChannels Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

copyTo Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : copyTo Method
array
ImGearDisplayChannel array to copy the color elements to.
index
The zero-based index in array at which copying begins.

Glossary Item Box

Copies a range of elements to the specified array.

Syntax

public void copyTo(
   ImGearArray array,
   int index
)

Parameters

array
ImGearDisplayChannel array to copy the color elements to.
index
The zero-based index in array at which copying begins.

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : getCount Method

Glossary Item Box

Gets the number of ImGearDisplayChannel class objects in the collection.

Integer value. ImGearDisplayChannel

Syntax

public int getCount()

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : getItem Method
index
The zero-based index.

Glossary Item Box

Gets the collection member with specified index.

Syntax

public ImGearDisplayChannel getItem(
   int index
)

Parameters

index
The zero-based index.

Return Value

ImGearDisplayChannel class object.

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : iterator Method

Glossary Item Box

Returns Iterator<ImGearDisplayChannel> interface used for enumeration over all ImGearDisplayChannel classes. objects in the collection.

Syntax

public java.util.Iterator<ImGearDisplayChannel> iterator()

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : setItem Method
index
The zero-based index.
value
ImGearDisplayChannel class object.

Glossary Item Box

Sets the collection member with specified index.

Syntax

public void setItem(
   int index,
   ImGearDisplayChannel value
)

Parameters

index
The zero-based index.
value
ImGearDisplayChannel class object.

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearDisplayChannels Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearDisplayChannels Class
ImGearDisplayChannels Members


%%PageItemTitle%%

ImGearDocument Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDocument Class

Glossary Item Box

Represents a collection of ImGearPage objects.

In addition to pages the object provides access to document level metadata.

In case of PDF or PS, ImGearDocument object may be associated with an external file.

Object Model

ImGearDocument ClassImGearDocument ClassImGearMetadataHead ClassImGearDocumentPageArray Class

Syntax

public class ImGearDocument
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDocument

See Also

Reference

ImGearDocument Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDocument Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDocument Class

Glossary Item Box

The following tables list the members exposed by ImGearDocument.

Public Constructors

 | Name | Description
public Constructor | ImGearDocument Constructor | Initializes a new instance of the ImGearDocumentPageArray class from list of pages and metadata tree.
Top

Protected Fields

 | Name | Description
protected Field | metadata | Document-level metadata tree. ImGearMetadataHead
protected Field | pages | List of pages available in the document. ImGearDocumentPageArray
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is the exact copy of the current instance.
public Method | getMetadata | Gets document-level metadata tree. ImGearMetadataHead class object. ImGearMetadataHead
public Method | getPages | Gets the list of pages available in the document. ImGearDocumentPageArray class object. Returns a modifiable list of pages available in the document. ImGearDocumentPageArray
Top

See Also

Reference

ImGearDocument Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearDocument Constructor
com.accusoft.imagegear.core Package > ImGearDocument Class : ImGearDocument Constructor

Glossary Item Box

Initializes a new instance of the ImGearDocumentPageArray class from list of pages and metadata tree.

Syntax

public ImGearDocument()

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDocument Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDocument Class

Glossary Item Box

For a list of all members of this type, see ImGearDocument members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is the exact copy of the current instance.
public Method | getMetadata | Gets document-level metadata tree. ImGearMetadataHead class object. ImGearMetadataHead
public Method | getPages | Gets the list of pages available in the document. ImGearDocumentPageArray class object. Returns a modifiable list of pages available in the document. ImGearDocumentPageArray
Top

See Also

Reference

ImGearDocument Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearDocument Class : clone Method

Glossary Item Box

Creates a new object that is the exact copy of the current instance.

Syntax

public ImGearDocument clone()

Return Value

A new instance of ImGearDocumentPageArray class.

In contrast to MemberwiseClone, this method performs a deep copy (i.e., all objects, including contained pages, are cloned as well).

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%%

getMetadata Method
com.accusoft.imagegear.core Package > ImGearDocument Class : getMetadata Method

Glossary Item Box

Gets document-level metadata tree.

ImGearMetadataHead class object. ImGearMetadataHead

Syntax

public ImGearMetadataHead getMetadata()

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%%

getPages Method
com.accusoft.imagegear.core Package > ImGearDocument Class : getPages Method

Glossary Item Box

Gets the list of pages available in the document.

ImGearDocumentPageArray class object.

Returns a modifiable list of pages available in the document.

ImGearDocumentPageArray

Syntax

public ImGearDocumentPageArray getPages()

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDocument Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDocument Class

Glossary Item Box

For a list of all members of this type, see ImGearDocument members.

Protected Fields

 | Name | Description
protected Field | metadata | Document-level metadata tree. ImGearMetadataHead
protected Field | pages | List of pages available in the document. ImGearDocumentPageArray
Top

See Also

Reference

ImGearDocument Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

metadata Field
com.accusoft.imagegear.core Package > ImGearDocument Class : metadata Field

Glossary Item Box

Document-level metadata tree.

ImGearMetadataHead

Syntax

protected ImGearMetadataHead metadata

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%%

pages Field
com.accusoft.imagegear.core Package > ImGearDocument Class : pages Field

Glossary Item Box

List of pages available in the document.

ImGearDocumentPageArray

Syntax

protected ImGearDocumentPageArray pages

See Also

Reference

ImGearDocument Class
ImGearDocument Members


%%PageItemTitle%%

ImGearDocumentPageArray Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearDocumentPageArray Class

Glossary Item Box

Represents a collection of pages within ImGearDocument object.

On adding pages, checks that the new page is not attached to any other document. The remove(Object) method detaches a page from the document. If it is referenced from anywhere else, it remains a valid stand-alone page.

Well-formed page array may contain any number of null entries. An exception is made for the formats where pages are physically continuous (i.e., PDF). Note that setting a page to null is different from removing a page from the document - the former does not change page count, whereas the latter does.

Object Model

ImGearDocumentPageArray ClassImGearDocumentPageArray ClassImGearPage ClassImGearPage Class

Syntax

public class ImGearDocumentPageArray
    extends Object
    implements java.util.List

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearDocumentPageArray

See Also

Reference

ImGearDocumentPageArray Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDocumentPageArray Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearDocumentPageArray Class

Glossary Item Box

The following tables list the members exposed by ImGearDocumentPageArray.

Public Methods

Name | Description
public Method | add | Overloaded. Adds a new ImGearPage to the end of the array of pages.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | clear | Removes all of the elements from this list (optional operation). The list will be empty after this call returns.
public Method | clone | Performs a deep copy of the page array (i.e., clones the pages as well.).
public Method | contains | Returns true if this list contains the specified element. More formally, returns true if and only if this list contains at least one element e such that (o==null ? e==null : o.equals(e)).
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | get | Gets the page at the specified index.
public Method | indexOf | Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | remove | Overloaded. Removes the first occurrence of the specified element from this list, if it is present (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))) (if such an element exists). Returns true if this list contained the specified element (or equivalently, if this list changed as a result of the call).
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Sets the page at the specified index.
public Method | size | Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Top

See Also

Reference

ImGearDocumentPageArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDocumentPageArray Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearDocumentPageArray Class

Glossary Item Box

For a list of all members of this type, see ImGearDocumentPageArray members.

Public Methods

Name | Description
public Method | add | Overloaded. Adds a new ImGearPage to the end of the array of pages.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | clear | Removes all of the elements from this list (optional operation). The list will be empty after this call returns.
public Method | clone | Performs a deep copy of the page array (i.e., clones the pages as well.).
public Method | contains | Returns true if this list contains the specified element. More formally, returns true if and only if this list contains at least one element e such that (o==null ? e==null : o.equals(e)).
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | get | Gets the page at the specified index.
public Method | indexOf | Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | remove | Overloaded. Removes the first occurrence of the specified element from this list, if it is present (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))) (if such an element exists). Returns true if this list contained the specified element (or equivalently, if this list changed as a result of the call).
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Sets the page at the specified index.
public Method | size | Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Top

See Also

Reference

ImGearDocumentPageArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : add Method

Glossary Item Box

Adds a new ImGearPage to the end of the array of pages.

Overload List

Overload | Description
add(ImGearPage) | Adds a new ImGearPage to the end of the array of pages.
add(int,ImGearPage) |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

add(ImGearPage) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > add Method : add(ImGearPage) Method
page
Page to be added.

Glossary Item Box

Adds a new ImGearPage to the end of the array of pages.

Syntax

public boolean add(
   ImGearPage page
)

Parameters

page
Page to be added.

Return Value

Whether the new page is added.

The method throws an exception if the page is already attached to another document.

ImGearPage

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

add(int,ImGearPage) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > add Method : add(int,ImGearPage) Method
index
page

Glossary Item Box

Syntax

public void add(
   int index,
   ImGearPage page
)

Parameters

index
page

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

addAll Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : addAll Method

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Overload List

Overload | Description
addAll(Collection<?>) | Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
addAll(int,Collection<?>) | Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

addAll(Collection<?>) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > addAll Method : addAll(Collection<?>) Method
c
collection containing elements to be added to this list

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List
java.util.List.add(E)


%%PageItemTitle%%

addAll(int,Collection<?>) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > addAll Method : addAll(int,Collection<?>) Method
index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Glossary Item Box

Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   int index,
   java.util.Collection<?> c
)

Parameters

index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

clear Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : clear Method

Glossary Item Box

Removes all of the elements from this list (optional operation). The list will be empty after this call returns.

Syntax

public void clear()

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : clone Method

Glossary Item Box

Performs a deep copy of the page array (i.e., clones the pages as well.).

Syntax

public ImGearDocumentPageArray clone()

Return Value

Copy of ImGearDocumentPageArray.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : contains Method
o
element whose presence in this list is to be tested

Glossary Item Box

Returns true if this list contains the specified element. More formally, returns true if and only if this list contains at least one element e such that (o==null ? e==null : o.equals(e)).

Syntax

public boolean contains(
   java.lang.Object o
)

Parameters

o
element whose presence in this list is to be tested

Return Value

true if this list contains the specified element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

containsAll Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : containsAll Method
c
collection to be checked for containment in this list

Glossary Item Box

Returns true if this list contains all of the elements of the specified collection.

Syntax

public boolean containsAll(
   java.util.Collection<?> c
)

Parameters

c
collection to be checked for containment in this list

Return Value

true if this list contains all of the elements of the specified collection

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
contains Method


%%PageItemTitle%%

get Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : get Method
index
Index of the page to get or set.

Glossary Item Box

Gets the page at the specified index.

Syntax

public ImGearPage get(
   int index
)

Parameters

index
Index of the page to get or set.

Return Value

ImGearPage class object. ImGearPage

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

indexOf Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : indexOf Method
o
element to search for

Glossary Item Box

Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.

Syntax

public int indexOf(
   java.lang.Object o
)

Parameters

o
element to search for

Return Value

the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : isEmpty Method

Glossary Item Box

Returns true if this list contains no elements.

Syntax

public boolean isEmpty()

Return Value

true if this list contains no elements

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : iterator Method

Glossary Item Box

Returns an iterator over the elements in this list in proper sequence.

Syntax

public java.util.Iterator<ImGearPage> iterator()

Return Value

an iterator over the elements in this list in proper sequence

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

lastIndexOf Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : lastIndexOf Method
o
element to search for

Glossary Item Box

Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.

Syntax

public int lastIndexOf(
   java.lang.Object o
)

Parameters

o
element to search for

Return Value

the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

listIterator Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : listIterator Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Overload List

Overload | Description
listIterator() | Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) | Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to java.util.ListIterator.next(). An initial call to java.util.ListIterator.previous() would return the element with the specified index minus one.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

listIterator() Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > listIterator Method : listIterator() Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Syntax

public java.util.ListIterator<ImGearPage> listIterator()

Return Value

a list iterator over the elements in this list (in proper sequence)

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

listIterator(int) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > listIterator Method : listIterator(int) Method
index
index of first element to be returned from the list iterator (by a call to the next method)

Glossary Item Box

Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to java.util.ListIterator.next(). An initial call to java.util.ListIterator.previous() would return the element with the specified index minus one.

Syntax

public java.util.ListIterator<ImGearPage> listIterator(
   int index
)

Parameters

index
index of first element to be returned from the list iterator (by a call to the next method)

Return Value

a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : remove Method

Glossary Item Box

Removes the first occurrence of the specified element from this list, if it is present (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))) (if such an element exists). Returns true if this list contained the specified element (or equivalently, if this list changed as a result of the call).

Overload List

Overload | Description
remove(Object) | Removes the first occurrence of the specified element from this list, if it is present (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))) (if such an element exists). Returns true if this list contained the specified element (or equivalently, if this list changed as a result of the call).
remove(int) | Removes the element at the specified position in this list (optional operation). Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

remove(Object) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > remove Method : remove(Object) Method
o
element to be removed from this list, if present

Glossary Item Box

Removes the first occurrence of the specified element from this list, if it is present (optional operation). If this list does not contain the element, it is unchanged. More formally, removes the element with the lowest index i such that (o==null ? get(i)==null : o.equals(get(i))) (if such an element exists). Returns true if this list contained the specified element (or equivalently, if this list changed as a result of the call).

Syntax

public boolean remove(
   java.lang.Object o
)

Parameters

o
element to be removed from this list, if present

Return Value

true if this list contained the specified element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.UnsupportedOperationException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

remove(int) Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > remove Method : remove(int) Method
index
the index of the element to be removed

Glossary Item Box

Removes the element at the specified position in this list (optional operation). Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

Syntax

public ImGearPage remove(
   int index
)

Parameters

index
the index of the element to be removed

Return Value

the element previously at the specified position

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

removeAll Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : removeAll Method
c
collection containing elements to be removed from this list

Glossary Item Box

Removes from this list all of its elements that are contained in the specified collection (optional operation).

Syntax

public boolean removeAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be removed from this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
remove(Object) Method
contains Method


%%PageItemTitle%%

retainAll Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : retainAll Method
c
collection containing elements to be retained in this list

Glossary Item Box

Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.

Syntax

public boolean retainAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be retained in this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
remove(Object) Method
contains Method


%%PageItemTitle%%

set Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : set Method
index
Index of the page to get or set.
page
ImGearPage class object.

Glossary Item Box

Sets the page at the specified index.

Syntax

public ImGearPage set(
   int index,
   ImGearPage page
)

Parameters

index
Index of the page to get or set.
page
ImGearPage class object.

Return Value

ImGearPage class object. ImGearPage

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

size Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : size Method

Glossary Item Box

Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.

Syntax

public int size()

Return Value

the number of elements in this list

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

subList Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : subList Method
fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Glossary Item Box

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

Syntax

public java.util.List<ImGearPage> subList(
   int fromIndex,
   int toIndex
)

Parameters

fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Return Value

a view of the specified range within this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

toArray Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class : toArray Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Overload List

Overload Description
toArray() Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

toArray<T>(T[]) Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members


%%PageItemTitle%%

toArray() Method
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > toArray Method : toArray() Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Syntax

public java.lang.Object[] toArray()

Return Value

an array containing all of the elements in this list in proper sequence

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

T
toArray<T>(T[]) Method
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearDocumentPageArray Class > toArray Method : toArray<T>(T[]) Method
a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

Syntax

public <T> T[] toArray(
   T[] a
)

Parameters

a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Type Parameters

T

Return Value

an array containing the elements of this list

Exceptions

Exception | Description
java.lang.ArrayStoreException |
java.lang.NullPointerException |

See Also

Reference

ImGearDocumentPageArray Class
ImGearDocumentPageArray Members
Overload List


%%PageItemTitle%%

ImGearEvaluationManager Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearEvaluationManager Class

Glossary Item Box

Provides an evaluation licensing manager.

This class must be initialized prior to using any other licensing call when the product is running in evaluation mode.

Object Model

ImGearEvaluationManager ClassImGearEvaluationMode Enumeration

Syntax

public class ImGearEvaluationManager
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearEvaluationManager

See Also

Reference

ImGearEvaluationManager Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEvaluationManager Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearEvaluationManager Class

Glossary Item Box

The following tables list the members exposed by ImGearEvaluationManager.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getMode | Gets the product evaluation mode.
static (Shared in Visual Basic) | initialize | Initializes the evaluation jar. This method initializes the evaluation licensing and must be called prior to using any other licensing call.
static (Shared in Visual Basic) | setMode | Sets the product evaluation mode. Currently only works with Watermark}.
Top

See Also

Reference

ImGearEvaluationManager Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEvaluationManager Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearEvaluationManager Class

Glossary Item Box

For a list of all members of this type, see ImGearEvaluationManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getMode | Gets the product evaluation mode.
static (Shared in Visual Basic) | initialize | Initializes the evaluation jar. This method initializes the evaluation licensing and must be called prior to using any other licensing call.
static (Shared in Visual Basic) | setMode | Sets the product evaluation mode. Currently only works with Watermark}.
Top

See Also

Reference

ImGearEvaluationManager Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.core Package > ImGearEvaluationManager Class : getMode Method

Glossary Item Box

Gets the product evaluation mode.

Syntax

public static ImGearEvaluationMode getMode()

See Also

Reference

ImGearEvaluationManager Class
ImGearEvaluationManager Members


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.core Package > ImGearEvaluationManager Class : initialize Method

Glossary Item Box

Initializes the evaluation jar.

This method initializes the evaluation licensing and must be called prior to using any other licensing call.

Syntax

public static void initialize()

See Also

Reference

ImGearEvaluationManager Class
ImGearEvaluationManager Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.core Package > ImGearEvaluationManager Class : setMode Method
value
enumeration value.

Glossary Item Box

Sets the product evaluation mode.

Currently only works with Watermark}.

Syntax

public static void setMode(
   ImGearEvaluationMode value
)

Parameters

value
enumeration value.

See Also

Reference

ImGearEvaluationManager Class
ImGearEvaluationManager Members


%%PageItemTitle%%

ImGearException Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearException Class

Glossary Item Box

Base class for all exceptions thrown by the ImageGear for Java library. Contains error codes and optionally supplied data.

Contains detailed information about the error that occurred.

This class does not have any public constructors. All instances are created implicitly by overloads of throwError static method.

Object Model

ImGearException ClassImGearErrorCodes Enumeration

Syntax

public sealed class ImGearException
    extends java.lang.RuntimeException

Inheritance Hierarchy

java.lang.Object
java.lang.Throwable
java.lang.Exception
java.lang.RuntimeException
com.accusoft.imagegear.core.ImGearException

See Also

Reference

ImGearException Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearException Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearException Class

Glossary Item Box

The following tables list the members exposed by ImGearException.

Public Methods

 | Name | Description
public Method | getErrorCode | Returns error code from ImGearErrorCodes enumeration. Returns or updates the code of the error that occured. ImGearErrorCodes
public Method | getValue1 | Returns integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | getValue2 | Gets integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | setErrorCode | Sets error code from ImGearErrorCodes enumeration. Returns or updates the code of the error that occured. ImGearErrorCodes
public Method | setValue1 | Sets integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | setValue2 | Sets integer data supplied to error code. Value meaning depends on the reason of exception.
static (Shared in Visual Basic) | throwError | Overloaded. Throws exception of ImGearException class.
Top

See Also

Reference

ImGearException Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearException Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearException Class

Glossary Item Box

For a list of all members of this type, see ImGearException members.

Public Methods

 | Name | Description
public Method | getErrorCode | Returns error code from ImGearErrorCodes enumeration. Returns or updates the code of the error that occured. ImGearErrorCodes
public Method | getValue1 | Returns integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | getValue2 | Gets integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | setErrorCode | Sets error code from ImGearErrorCodes enumeration. Returns or updates the code of the error that occured. ImGearErrorCodes
public Method | setValue1 | Sets integer data supplied to error code. Value meaning depends on the reason of exception.
public Method | setValue2 | Sets integer data supplied to error code. Value meaning depends on the reason of exception.
static (Shared in Visual Basic) | throwError | Overloaded. Throws exception of ImGearException class.
Top

See Also

Reference

ImGearException Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getErrorCode Method
com.accusoft.imagegear.core Package > ImGearException Class : getErrorCode Method

Glossary Item Box

Returns error code from ImGearErrorCodes enumeration.

Returns or updates the code of the error that occured.

ImGearErrorCodes

Syntax

public ImGearErrorCodes getErrorCode()

Return Value

ImGearErrorCodes enumeration value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

getValue1 Method
com.accusoft.imagegear.core Package > ImGearException Class : getValue1 Method

Glossary Item Box

Returns integer data supplied to error code.

Value meaning depends on the reason of exception.

Syntax

public int getValue1()

Return Value

Integer value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

getValue2 Method
com.accusoft.imagegear.core Package > ImGearException Class : getValue2 Method

Glossary Item Box

Gets integer data supplied to error code.

Value meaning depends on the reason of exception.

Syntax

public int getValue2()

Return Value

Integer value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

setErrorCode Method
com.accusoft.imagegear.core Package > ImGearException Class : setErrorCode Method
value
ImGearErrorCodes enumeration value.

Glossary Item Box

Sets error code from ImGearErrorCodes enumeration.

Returns or updates the code of the error that occured.

ImGearErrorCodes

Syntax

public void setErrorCode(
   ImGearErrorCodes value
)

Parameters

value
ImGearErrorCodes enumeration value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

setValue1 Method
com.accusoft.imagegear.core Package > ImGearException Class : setValue1 Method
value
Integer value.

Glossary Item Box

Sets integer data supplied to error code.

Value meaning depends on the reason of exception.

Syntax

public void setValue1(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

setValue2 Method
com.accusoft.imagegear.core Package > ImGearException Class : setValue2 Method
value
Integer value.

Glossary Item Box

Sets integer data supplied to error code.

Value meaning depends on the reason of exception.

Syntax

public void setValue2(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

throwError Method
com.accusoft.imagegear.core Package > ImGearException Class : throwError Method

Glossary Item Box

Throws exception of ImGearException class.

Overload List

Overload | Description
throwError(ImGearErrorCodes,String,int,int) | Throws exception of ImGearException class.
throwError(ImGearErrorCodes,String,int) | Throws exception of ImGearException class.
throwError(ImGearErrorCodes,Exception) | Throws exception of ImGearException class.
throwError(ImGearErrorCodes,String) | Throws exception of ImGearException class.
throwError(ImGearErrorCodes) | Throws exception of ImGearException class.

See Also

Reference

ImGearException Class
ImGearException Members


%%PageItemTitle%%

throwError(ImGearErrorCodes,String,int,int) Method
com.accusoft.imagegear.core Package > ImGearException Class > throwError Method : throwError(ImGearErrorCodes,String,int,int) Method
errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data of the Value1 supplied to error code. Its meaning depends on reason of exception.
value2
Integer data of the Value2 supplied to error code. Its meaning depends on reason of exception. ImGearErrorCodes

Glossary Item Box

Throws exception of ImGearException class.

Syntax

public static void throwError(
   ImGearErrorCodes errorCode,
   java.lang.String description,
   int value1,
   int value2
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data of the Value1 supplied to error code. Its meaning depends on reason of exception.
value2
Integer data of the Value2 supplied to error code. Its meaning depends on reason of exception. ImGearErrorCodes

See Also

Reference

ImGearException Class
ImGearException Members
Overload List


%%PageItemTitle%%

throwError(ImGearErrorCodes,String,int) Method
com.accusoft.imagegear.core Package > ImGearException Class > throwError Method : throwError(ImGearErrorCodes,String,int) Method
errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data supplied to error code. Its meaning depends on reason of exception. ImGearErrorCodes

Glossary Item Box

Throws exception of ImGearException class.

Syntax

public static void throwError(
   ImGearErrorCodes errorCode,
   java.lang.String description,
   int value1
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception.
value1
Integer data supplied to error code. Its meaning depends on reason of exception. ImGearErrorCodes

See Also

Reference

ImGearException Class
ImGearException Members
Overload List


%%PageItemTitle%%

throwError(ImGearErrorCodes,Exception) Method
com.accusoft.imagegear.core Package > ImGearException Class > throwError Method : throwError(ImGearErrorCodes,Exception) Method
errorCode
Numeric code of error from ImGearErrorCodes enumeration.
e
Rethrown exception.

Glossary Item Box

Throws exception of ImGearException class.

Syntax

public static void throwError(
   ImGearErrorCodes errorCode,
   java.lang.Exception e
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
e
Rethrown exception.

See Also

Reference

ImGearException Class
ImGearException Members
Overload List


%%PageItemTitle%%

throwError(ImGearErrorCodes,String) Method
com.accusoft.imagegear.core Package > ImGearException Class > throwError Method : throwError(ImGearErrorCodes,String) Method
errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception. ImGearErrorCodes

Glossary Item Box

Throws exception of ImGearException class.

Syntax

public static void throwError(
   ImGearErrorCodes errorCode,
   java.lang.String description
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration.
description
Human readable information about reason of exception. ImGearErrorCodes

See Also

Reference

ImGearException Class
ImGearException Members
Overload List


%%PageItemTitle%%

throwError(ImGearErrorCodes) Method
com.accusoft.imagegear.core Package > ImGearException Class > throwError Method : throwError(ImGearErrorCodes) Method
errorCode
Numeric code of error from ImGearErrorCodes enumeration. ImGearErrorCodes

Glossary Item Box

Throws exception of ImGearException class.

Syntax

public static void throwError(
   ImGearErrorCodes errorCode
)

Parameters

errorCode
Numeric code of error from ImGearErrorCodes enumeration. ImGearErrorCodes

See Also

Reference

ImGearException Class
ImGearException Members
Overload List


%%PageItemTitle%%

ImGearExtraChannelInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearExtraChannelInfo Class

Glossary Item Box

This is a general extra channel class.

Each extra channel in image has ImGearExtraChannelInfo object associated with it.

Object Model

ImGearExtraChannelInfo ClassImGearExtraChannelType Enumeration

Syntax

public class ImGearExtraChannelInfo
    extends Object
    implements java.lang.Cloneable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearColorChannelInfo
com.accusoft.imagegear.core.ImGearSpotChannelInfo

See Also

Reference

ImGearExtraChannelInfo Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearExtraChannelInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearExtraChannelInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearExtraChannelInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearExtraChannelInfo Constructor | Initializes a new instance of the ImGearExtraChannelInfo class object.
Top

Protected Fields

 | Name | Description
protected Field | type | Gets the type of extra channel. ImGearExtraChannelType enumeration value.
Top

Public Methods

 | Name | Description
public Method | getName | Returns the name of extra channel.
public Method | getType | Gets the type of extra channel. ImGearExtraChannelType enumeration value. ImGearExtraChannelType
public Method | setName | Sets the name of extra channel.
Top

See Also

Reference

ImGearExtraChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearExtraChannelInfo Constructor
com.accusoft.imagegear.core Package > ImGearExtraChannelInfo Class : ImGearExtraChannelInfo Constructor

Glossary Item Box

Initializes a new instance of the ImGearExtraChannelInfo class object.

Syntax

public ImGearExtraChannelInfo()

See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearExtraChannelInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearExtraChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearExtraChannelInfo members.

Public Methods

 | Name | Description
public Method | getName | Returns the name of extra channel.
public Method | getType | Gets the type of extra channel. ImGearExtraChannelType enumeration value. ImGearExtraChannelType
public Method | setName | Sets the name of extra channel.
Top

See Also

Reference

ImGearExtraChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > ImGearExtraChannelInfo Class : getName Method

Glossary Item Box

Returns the name of extra channel.

Syntax

public java.lang.String getName()

Return Value

String value.

See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.core Package > ImGearExtraChannelInfo Class : getType Method

Glossary Item Box

Gets the type of extra channel.

ImGearExtraChannelType enumeration value. ImGearExtraChannelType

Syntax

public ImGearExtraChannelType getType()

See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.core Package > ImGearExtraChannelInfo Class : setName Method
value
String value.

Glossary Item Box

Sets the name of extra channel.

Syntax

public void setName(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearExtraChannelInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearExtraChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearExtraChannelInfo members.

Protected Fields

 | Name | Description
protected Field | type | Gets the type of extra channel. ImGearExtraChannelType enumeration value.
Top

See Also

Reference

ImGearExtraChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

type Field
com.accusoft.imagegear.core Package > ImGearExtraChannelInfo Class : type Field

Glossary Item Box

Gets the type of extra channel.

ImGearExtraChannelType enumeration value.

Syntax

protected ImGearExtraChannelType type

Return Value

ImGearExtraChannelType enumeration value.

See Also

Reference

ImGearExtraChannelInfo Class
ImGearExtraChannelInfo Members


%%PageItemTitle%%

ImGearFullLUT Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearFullLUT Class

Glossary Item Box

Represents a lookup table that contains a full table of values for each possible input index.

Lookup table contains values for entire input range. Table of values can be accessed directly.

Object Model

ImGearFullLUT ClassImGearFullLUT ClassImGearFullLUT Class

Syntax

public class ImGearFullLUT
    extends ImGearLUT

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearLUT
com.accusoft.imagegear.core.ImGearFullLUT

See Also

Reference

ImGearFullLUT Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearFullLUT Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearFullLUT Class

Glossary Item Box

The following tables list the members exposed by ImGearFullLUT.

Public Constructors

 | Name | Description
public Constructor | ImGearFullLUT Constructor | Initializes a new instance of the ImGearFullLUT class.
Top

Public Fields

Name Description
public Field table Provides direct access to the LUT table.

byte[ ], Int16[ ] or Int32[ ]

Actual type of the array depends on the output depth of the LUT:

  • If output depth is between 1 and 8, Table is byte[ ]
  • If output depth is between 9 and 16, Table is Int16[ ]
  • If output depth is between 17 and 32, Table is Int32[ ]

Length of the table depends on the input depth, as follows:

Length = 2 ^ inputDepth.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.
public Method | getInputDepth | Specifies input depth of the LUT. Any integer number.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Specifies output depth of the LUT. Any integer number.
public Method | getTableIndex | Overloaded. Obtains index in the table corresponding to Int32 input value.
public Method | isInputSigned | Specifies whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Specifies whether LUT output values are signed. Boolean value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to index.
Top

See Also

Reference

ImGearFullLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearFullLUT Constructor
com.accusoft.imagegear.core Package > ImGearFullLUT Class : ImGearFullLUT Constructor
inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.

This constructor creates a new instance of ImGearFullLUT object and allocates the internal table, according to input and output depths.

Glossary Item Box

Initializes a new instance of the ImGearFullLUT class.

Syntax

public ImGearFullLUT(
   int inputDepth,
   boolean inputIsSigned,
   int outputDepth,
   boolean outputIsSigned
)

Parameters

inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.

This constructor creates a new instance of ImGearFullLUT object and allocates the internal table, according to input and output depths.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearFullLUT Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearFullLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearFullLUT members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.
public Method | getInputDepth | Specifies input depth of the LUT. Any integer number.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Specifies output depth of the LUT. Any integer number.
public Method | getTableIndex | Overloaded. Obtains index in the table corresponding to Int32 input value.
public Method | isInputSigned | Specifies whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Specifies whether LUT output values are signed. Boolean value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to index.
Top

See Also

Reference

ImGearFullLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public ImGearFullLUT clone()

Return Value

The new instance of ImGearLUT class object.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

concatenate Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : concatenate Method
lookupTable
LUT to be concatenated.

Glossary Item Box

Concatenates the content of the instance of the ImGearFullLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.

Syntax

public ImGearFullLUT concatenate(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object. ImGearLUT

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : copyFrom Method
lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class this method is called from.

Glossary Item Box

Duplicates the content of the specified lookupTable into the instance of the ImGearFullLUT class that this method is called from.

Syntax

public void copyFrom(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class this method is called from.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

getInputDepth Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : getInputDepth Method

Glossary Item Box

Specifies input depth of the LUT.

Any integer number.

Syntax

public int getInputDepth()

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : getItem Method

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Overload List

Overload | Description
getItem(int) | Returns LUT output value corresponding to Int32 input value.
getItem(long) | Returns LUT output value corresponding to Int64 input value.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

getItem(int) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > getItem Method : getItem(int) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Syntax

public int getItem(
   int index
)

Parameters

index
Index of the LUT to get.

Return Value

Integer number.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

getItem(long) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > getItem Method : getItem(long) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int64 input value.

Syntax

public long getItem(
   long index
)

Parameters

index
Index of the LUT to get.

Return Value

Long number.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

getOutputDepth Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : getOutputDepth Method

Glossary Item Box

Specifies output depth of the LUT.

Any integer number.

Syntax

public int getOutputDepth()

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

getTableIndex Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : getTableIndex Method

Glossary Item Box

Obtains index in the table corresponding to Int32 input value.

Overload List

Overload | Description
getTableIndex(int) | Obtains index in the table corresponding to Int32 input value.
getTableIndex(long) | Obtains index in the table corresponding to Int64 input value.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

getTableIndex(int) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > getTableIndex Method : getTableIndex(int) Method
inputValue
LUT input value.

Glossary Item Box

Obtains index in the table corresponding to Int32 input value.

Syntax

public long getTableIndex(
   int inputValue
)

Parameters

inputValue
LUT input value.

Return Value

Integer number.

This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

getTableIndex(long) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > getTableIndex Method : getTableIndex(long) Method
inputValue
LUT input value.

Glossary Item Box

Obtains index in the table corresponding to Int64 input value.

Syntax

public long getTableIndex(
   long inputValue
)

Parameters

inputValue
LUT input value.

Return Value

Integer number.

This method returns table index corresponding to input value. If LUT input is signed, and input value is negative, table index is calculated as 2's complement to number of table entries. Otherwise, table index is equal to input value.

For example, if input depth is 12, and input value is -1, table index is 4096 - 1 = 4095.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

isInputSigned Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : isInputSigned Method

Glossary Item Box

Specifies whether LUT input values are signed.

Boolean value.

Syntax

public boolean isInputSigned()

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

isOutputSigned Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : isOutputSigned Method

Glossary Item Box

Specifies whether LUT output values are signed.

Boolean value.

Syntax

public boolean isOutputSigned()

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : setItem Method

Glossary Item Box

Sets LUT output value corresponding to index.

Overload List

Overload | Description
setItem(int,int) | Sets LUT output value corresponding to index.
setItem(long,long) | Sets LUT output value corresponding to index.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

setItem(int,int) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > setItem Method : setItem(int,int) Method
index
Index to set.
value
LUT output value to set.

Glossary Item Box

Sets LUT output value corresponding to index.

Syntax

public void setItem(
   int index,
   int value
)

Parameters

index
Index to set.
value
LUT output value to set.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

setItem(long,long) Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class > setItem Method : setItem(long,long) Method
index
Index to set.
value
LUT output value to set.

Glossary Item Box

Sets LUT output value corresponding to index.

Syntax

public void setItem(
   long index,
   long value
)

Parameters

index
Index to set.
value
LUT output value to set.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members
Overload List


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearFullLUT Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearFullLUT Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearFullLUT Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearFullLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearFullLUT members.

Public Fields

Name Description
public Field table Provides direct access to the LUT table.

byte[ ], Int16[ ] or Int32[ ]

Actual type of the array depends on the output depth of the LUT:

  • If output depth is between 1 and 8, Table is byte[ ]
  • If output depth is between 9 and 16, Table is Int16[ ]
  • If output depth is between 17 and 32, Table is Int32[ ]

Length of the table depends on the input depth, as follows:

Length = 2 ^ inputDepth.
Top

See Also

Reference

ImGearFullLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

table Field
com.accusoft.imagegear.core Package > ImGearFullLUT Class : table Field

Glossary Item Box

Provides direct access to the LUT table.

byte[ ], Int16[ ] or Int32[ ]

Actual type of the array depends on the output depth of the LUT:

  • If output depth is between 1 and 8, Table is byte[ ]
  • If output depth is between 9 and 16, Table is Int16[ ]
  • If output depth is between 17 and 32, Table is Int32[ ]

Length of the table depends on the input depth, as follows:

Length = 2 ^ inputDepth.

Syntax

public ImGearArray table

Return Value

byte[ ], Int16[ ] or Int32[ ]

See Also

Reference

ImGearFullLUT Class
ImGearFullLUT Members


%%PageItemTitle%%

ImGearLicense Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearLicense Class

Glossary Item Box

Manages licensing data (i.e., license type and key).

Object Model

ImGearLicense Class

Syntax

public sealed class ImGearLicense
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearLicense

See Also

Reference

ImGearLicense Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLicense Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearLicense Class

Glossary Item Box

The following tables list the members exposed by ImGearLicense.

Public Constructors

 | Name | Description
public Constructor | ImGearLicense Constructor | Initializes a new instance of the ImGearLicense class object.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | setOEMLicenseKey | Sets the licensing OEM key. Use this method for deployment licensing only. Solution name and solution key must be set up in addition to the OEM license key.
static (Shared in Visual Basic) | setSolutionKey | Sets the licensing solution key. Use this method for deployment licensing only. Solution name must be set up in addition to the solution key.
static (Shared in Visual Basic) | setSolutionName | Sets the licensing solution name. When this method is used for deployment licensing, the solution key must be set up in addition to the name. For OEM deployment licensing, the OEM license key must be set up in addition to the solution name and key.
Top

See Also

Reference

ImGearLicense Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearLicense Constructor
com.accusoft.imagegear.core Package > ImGearLicense Class : ImGearLicense Constructor

Glossary Item Box

Initializes a new instance of the ImGearLicense class object.

Syntax

public ImGearLicense()

See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLicense Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearLicense Class

Glossary Item Box

For a list of all members of this type, see ImGearLicense members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | setOEMLicenseKey | Sets the licensing OEM key. Use this method for deployment licensing only. Solution name and solution key must be set up in addition to the OEM license key.
static (Shared in Visual Basic) | setSolutionKey | Sets the licensing solution key. Use this method for deployment licensing only. Solution name must be set up in addition to the solution key.
static (Shared in Visual Basic) | setSolutionName | Sets the licensing solution name. When this method is used for deployment licensing, the solution key must be set up in addition to the name. For OEM deployment licensing, the OEM license key must be set up in addition to the solution name and key.
Top

See Also

Reference

ImGearLicense Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

setOEMLicenseKey Method
com.accusoft.imagegear.core Package > ImGearLicense Class : setOEMLicenseKey Method
licenseKey
Obtained from Accusoft OEM license key.

Glossary Item Box

Sets the licensing OEM key.

Use this method for deployment licensing only. Solution name and solution key must be set up in addition to the OEM license key.

Syntax

public static void setOEMLicenseKey(
   java.lang.String licenseKey
)

Parameters

licenseKey
Obtained from Accusoft OEM license key.

See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%%

setSolutionKey Method
com.accusoft.imagegear.core Package > ImGearLicense Class : setSolutionKey Method
key1
Key1 part of solution key.
key2
Key2 part of solution key.
key3
Key3 part of solution key.
key4
Key4 part of solution key.

Glossary Item Box

Sets the licensing solution key.

Use this method for deployment licensing only. Solution name must be set up in addition to the solution key.

Syntax

public static void setSolutionKey(
   int key1,
   int key2,
   int key3,
   int key4
)

Parameters

key1
Key1 part of solution key.
key2
Key2 part of solution key.
key3
Key3 part of solution key.
key4
Key4 part of solution key.

See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%%

setSolutionName Method
com.accusoft.imagegear.core Package > ImGearLicense Class : setSolutionName Method
solutionName
Name of solution.

Glossary Item Box

Sets the licensing solution name.

When this method is used for deployment licensing, the solution key must be set up in addition to the name. For OEM deployment licensing, the OEM license key must be set up in addition to the solution name and key.

Syntax

public static void setSolutionName(
   java.lang.String solutionName
)

Parameters

solutionName
Name of solution.

See Also

Reference

ImGearLicense Class
ImGearLicense Members


%%PageItemTitle%%

ImGearLinearLUT Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearLinearLUT Class

Glossary Item Box

This class represents a lookup table that does not store the actual LUT values, but calculates output values dynamically using a linear formula.

Such LUTs can be used for window levelling of 17-32 bit per channel images.

Object Model

ImGearLinearLUT ClassImGearLinearLUT ClassImGearLinearLUT Class

Syntax

public class ImGearLinearLUT
    extends ImGearLUT

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearLUT
com.accusoft.imagegear.core.ImGearLinearLUT

See Also

Reference

ImGearLinearLUT Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLinearLUT Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearLinearLUT Class

Glossary Item Box

The following tables list the members exposed by ImGearLinearLUT.

Public Constructors

 | Name | Description
public Constructor | ImGearLinearLUT Constructor | Initializes a new instance of the ImGearLinearLUT class.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.
public Method | getInputDepth | Gets input depth of the LUT. Any integer number.
public Method | getIntercept | Returns LUT Intercept value.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Gets output depth of the LUT. Any integer number.
public Method | getSlope | Returns LUT Slope value.
public Method | isInputSigned | Gets a value whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Gets a value whether LUT output values are signed. Boolean value.
public Method | setIntercept | Sets LUT Intercept value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to Int32 input value.
public Method | setSlope | Sets LUT Slope value.
Top

See Also

Reference

ImGearLinearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearLinearLUT Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearLinearLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearLinearLUT members.

See Also

Reference

ImGearLinearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearLinearLUT Constructor
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : ImGearLinearLUT Constructor
inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.

Slope and Intercept will be initialized to default values of 1.0 and 0.0. They should be initialized later, if necessary, via corresponding set properties.

Glossary Item Box

Initializes a new instance of the ImGearLinearLUT class.

Syntax

public ImGearLinearLUT(
   int inputDepth,
   boolean inputIsSigned,
   int outputDepth,
   boolean outputIsSigned
)

Parameters

inputDepth
Specifies input depth of the LUT.
inputIsSigned
Specifies whether LUT input is signed.
outputDepth
Specifies output depth of the LUT.
outputIsSigned
Specifies whether LUT output is signed.

Slope and Intercept will be initialized to default values of 1.0 and 0.0. They should be initialized later, if necessary, via corresponding set properties.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLinearLUT Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearLinearLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearLinearLUT members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.
public Method | getInputDepth | Gets input depth of the LUT. Any integer number.
public Method | getIntercept | Returns LUT Intercept value.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Gets output depth of the LUT. Any integer number.
public Method | getSlope | Returns LUT Slope value.
public Method | isInputSigned | Gets a value whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Gets a value whether LUT output values are signed. Boolean value.
public Method | setIntercept | Sets LUT Intercept value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to Int32 input value.
public Method | setSlope | Sets LUT Slope value.
Top

See Also

Reference

ImGearLinearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public ImGearLinearLUT clone()

Return Value

The new instance of ImGearLinearLUT class object.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

concatenate Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : concatenate Method
lookupTable
LUT to be concatenated.

Glossary Item Box

Concatenates the content of the instance of the ImGearLinearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.

Syntax

public ImGearLinearLUT concatenate(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object.

If the lookupTable parameter is not an ImGearLinearLUT class object, the method throws ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

ImGearLUT

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : copyFrom Method
lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class from which this method is called.

Glossary Item Box

Duplicates the content of the specified lookupTable into the instance of the ImGearLinearLUT class that this method is called from.

Syntax

public void copyFrom(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class from which this method is called.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

getInputDepth Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : getInputDepth Method

Glossary Item Box

Gets input depth of the LUT.

Any integer number.

Syntax

public int getInputDepth()

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

getIntercept Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : getIntercept Method

Glossary Item Box

Returns LUT Intercept value.

Syntax

public double getIntercept()

Return Value

Double value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : getItem Method

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Overload List

Overload | Description
getItem(int) | Returns LUT output value corresponding to Int32 input value.
getItem(long) | Returns LUT output value corresponding to Int64 input value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

getItem(int) Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class > getItem Method : getItem(int) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Syntax

public int getItem(
   int index
)

Parameters

index
Index of the LUT to get.

Return Value

Integer value.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members
Overload List


%%PageItemTitle%%

getItem(long) Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class > getItem Method : getItem(long) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int64 input value.

Syntax

public long getItem(
   long index
)

Parameters

index
Index of the LUT to get.

Return Value

Long number.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members
Overload List


%%PageItemTitle%%

getOutputDepth Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : getOutputDepth Method

Glossary Item Box

Gets output depth of the LUT.

Any integer number.

Syntax

public int getOutputDepth()

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

getSlope Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : getSlope Method

Glossary Item Box

Returns LUT Slope value.

Syntax

public double getSlope()

Return Value

Double value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

isInputSigned Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : isInputSigned Method

Glossary Item Box

Gets a value whether LUT input values are signed.

Boolean value.

Syntax

public boolean isInputSigned()

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

isOutputSigned Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : isOutputSigned Method

Glossary Item Box

Gets a value whether LUT output values are signed.

Boolean value.

Syntax

public boolean isOutputSigned()

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

setIntercept Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : setIntercept Method
value
Double value.

Glossary Item Box

Sets LUT Intercept value.

Syntax

public void setIntercept(
   double value
)

Parameters

value
Double value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : setItem Method

Glossary Item Box

Sets LUT output value corresponding to Int32 input value.

Overload List

Overload | Description
setItem(int,int) | Sets LUT output value corresponding to Int32 input value.
setItem(long,long) | Sets LUT output value corresponding to Int64 input value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

setItem(int,int) Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class > setItem Method : setItem(int,int) Method
index
Index of the LUT to get.
value
Integer value.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

Glossary Item Box

Sets LUT output value corresponding to Int32 input value.

Syntax

public void setItem(
   int index,
   int value
)

Parameters

index
Index of the LUT to get.
value
Integer value.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members
Overload List


%%PageItemTitle%%

setItem(long,long) Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class > setItem Method : setItem(long,long) Method
index
Index of the LUT to get.
value
Long number.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

Glossary Item Box

Sets LUT output value corresponding to Int64 input value.

Syntax

public void setItem(
   long index,
   long value
)

Parameters

index
Index of the LUT to get.
value
Long number.

LUT output value the formula is: result = input_value * Slope + Intercept + 0.5.

Set accessor throws exception, because such operation is invalid for this type of LUT.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members
Overload List


%%PageItemTitle%%

setSlope Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : setSlope Method
value
Double value.

Glossary Item Box

Sets LUT Slope value.

Syntax

public void setSlope(
   double value
)

Parameters

value
Double value.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearLinearLUT Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearLinearLUT Class
ImGearLinearLUT Members


%%PageItemTitle%%

ImGearLUT Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearLUT Class

Glossary Item Box

Provides a base for lookup tables (LUTs) that are used in ImageGear.

A LUT is characterized by input depth and output depth; both input and output of the LUT can be signed or unsigned.

Object Model

ImGearLUT ClassImGearLUT ClassImGearLUT Class

Syntax

public abstract class ImGearLUT
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearLUT
com.accusoft.imagegear.core.ImGearFullLUT
com.accusoft.imagegear.core.ImGearLinearLUT

See Also

Reference

ImGearLUT Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLUT Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearLUT Class

Glossary Item Box

The following tables list the members exposed by ImGearLUT.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.
public Method | getInputDepth | Gets input depth of the LUT. Any integer number.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Gets output depth of the LUT. Any integer number.
public Method | isInputSigned | Gets a value indicating whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Gets a value indicating whether LUT output values are signed. Boolean value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to int input value.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearLUT Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearLUT members.

See Also

Reference

ImGearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLUT Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearLUT members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | concatenate | Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.
public Method | copyFrom | Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.
public Method | getInputDepth | Gets input depth of the LUT. Any integer number.
public Method | getItem | Overloaded. Returns LUT output value corresponding to Int32 input value.
public Method | getOutputDepth | Gets output depth of the LUT. Any integer number.
public Method | isInputSigned | Gets a value indicating whether LUT input values are signed. Boolean value.
public Method | isOutputSigned | Gets a value indicating whether LUT output values are signed. Boolean value.
public Method | setItem | Overloaded. Sets LUT output value corresponding to int input value.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearLUT Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public abstract ImGearLUT clone()

Return Value

A new instance of ImGearLUT class object.

This method clones ImGearLUT object.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearLUT Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

concatenate Method
com.accusoft.imagegear.core Package > ImGearLUT Class : concatenate Method
lookupTable
LUT to be concatenated.

Glossary Item Box

Concatenates the content of the instance of the ImGearLUT (that this method is called from) and the content of the specified lookupTable into the resulting output lookup table.

Syntax

public abstract ImGearLUT concatenate(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be concatenated.

Return Value

ImGearLUT class object.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core Package > ImGearLUT Class : copyFrom Method
lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class this method is called from.

Glossary Item Box

Duplicates the content of the specified LUT into the instance of the ImGearLUT class that this method is called from.

Syntax

public abstract void copyFrom(
   ImGearLUT lookupTable
)

Parameters

lookupTable
LUT to be copied.

LUT type and depths attributes must be compatible with the class this method is called from.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

getInputDepth Method
com.accusoft.imagegear.core Package > ImGearLUT Class : getInputDepth Method

Glossary Item Box

Gets input depth of the LUT.

Any integer number.

Syntax

public abstract int getInputDepth()

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearLUT Class : getItem Method

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Overload List

Overload | Description
getItem(int) | Returns LUT output value corresponding to Int32 input value.
getItem(long) | Returns LUT output value corresponding to Int64 input value.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

getItem(int) Method
com.accusoft.imagegear.core Package > ImGearLUT Class > getItem Method : getItem(int) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int32 input value.

Syntax

public abstract int getItem(
   int index
)

Parameters

index
Index of the LUT to get.

Return Value

Integer number.

See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


%%PageItemTitle%%

getItem(long) Method
com.accusoft.imagegear.core Package > ImGearLUT Class > getItem Method : getItem(long) Method
index
Index of the LUT to get.

Glossary Item Box

Returns LUT output value corresponding to Int64 input value.

Syntax

public abstract long getItem(
   long index
)

Parameters

index
Index of the LUT to get.

Return Value

Long number.

See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


%%PageItemTitle%%

getOutputDepth Method
com.accusoft.imagegear.core Package > ImGearLUT Class : getOutputDepth Method

Glossary Item Box

Gets output depth of the LUT.

Any integer number.

Syntax

public abstract int getOutputDepth()

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

isInputSigned Method
com.accusoft.imagegear.core Package > ImGearLUT Class : isInputSigned Method

Glossary Item Box

Gets a value indicating whether LUT input values are signed.

Boolean value.

Syntax

public abstract boolean isInputSigned()

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

isOutputSigned Method
com.accusoft.imagegear.core Package > ImGearLUT Class : isOutputSigned Method

Glossary Item Box

Gets a value indicating whether LUT output values are signed.

Boolean value.

Syntax

public abstract boolean isOutputSigned()

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.core Package > ImGearLUT Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearLUT Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearLUT Class : setItem Method

Glossary Item Box

Sets LUT output value corresponding to int input value.

Overload List

Overload | Description
setItem(int,int) | Sets LUT output value corresponding to int input value.
setItem(long,long) | Sets LUT output value corresponding to long input value.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

setItem(int,int) Method
com.accusoft.imagegear.core Package > ImGearLUT Class > setItem Method : setItem(int,int) Method
index
Index of the LUT to set.
value
Value of LUT output to set.

Glossary Item Box

Sets LUT output value corresponding to int input value.

Syntax

public abstract void setItem(
   int index,
   int value
)

Parameters

index
Index of the LUT to set.
value
Value of LUT output to set.

See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


%%PageItemTitle%%

setItem(long,long) Method
com.accusoft.imagegear.core Package > ImGearLUT Class > setItem Method : setItem(long,long) Method
index
Index of the LUT to set.
value
Value of LUT output to set.

Glossary Item Box

Sets LUT output value corresponding to long input value.

Syntax

public abstract void setItem(
   long index,
   long value
)

Parameters

index
Index of the LUT to set.
value
Value of LUT output to set.

See Also

Reference

ImGearLUT Class
ImGearLUT Members
Overload List


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearLUT Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearLUT Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearLUT Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearLUT Class
ImGearLUT Members


%%PageItemTitle%%

ImGearMaskColorChannelInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskColorChannelInfo Class

Glossary Item Box

Represents mask color channel info.

Class uses regular color space like RGB, CMYK, etc.

Object Model

ImGearMaskColorChannelInfo ClassImGearExtraChannelInfo ClassImGearColorSpace ClassImGearPixel ClassImGearPixel ClassImGearPixel ClassImGearMaskChannelModes EnumerationImGearExtraChannelType Enumeration

Syntax

public class ImGearMaskColorChannelInfo
    extends ImGearColorChannelInfo

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearColorChannelInfo
com.accusoft.imagegear.core.ImGearMaskColorChannelInfo

See Also

Reference

ImGearMaskColorChannelInfo Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMaskColorChannelInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskColorChannelInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearMaskColorChannelInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearMaskColorChannelInfo Constructor | Initializes a new instance of the ImGearMaskColorChannelInfo class using the supplied color channel mode, color space and color value.
Top

Public Methods

 | Name | Description
public Method | getMode | Returns mask channel mode. ImGearMaskChannelModes
public Method | setMode | Sets mask channel mode. ImGearMaskChannelModes
Top

See Also

Reference

ImGearMaskColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMaskColorChannelInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskColorChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearMaskColorChannelInfo members.

See Also

Reference

ImGearMaskColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMaskColorChannelInfo Constructor
com.accusoft.imagegear.core Package > ImGearMaskColorChannelInfo Class : ImGearMaskColorChannelInfo Constructor
mode
Color channel mode.
colorSpace
Color space.
colorValue
Color value. com.accusoft.imagegear.core.ImGearMaskChannelModesT:com.accusoft.imagegear.core.ImGearPixel

Glossary Item Box

Initializes a new instance of the ImGearMaskColorChannelInfo class using the supplied color channel mode, color space and color value.

Syntax

public ImGearMaskColorChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearColorSpace colorSpace,
   ImGearPixel colorValue
)

Parameters

mode
Color channel mode.
colorSpace
Color space.
colorValue
Color value. com.accusoft.imagegear.core.ImGearMaskChannelModesT:com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMaskColorChannelInfo Class : clone Method

Glossary Item Box

Syntax

public ImGearExtraChannelInfo clone()

See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMaskColorChannelInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskColorChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearMaskColorChannelInfo members.

Public Methods

 | Name | Description
public Method | getMode | Returns mask channel mode. ImGearMaskChannelModes
public Method | setMode | Sets mask channel mode. ImGearMaskChannelModes
Top

See Also

Reference

ImGearMaskColorChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.core Package > ImGearMaskColorChannelInfo Class : getMode Method

Glossary Item Box

Returns mask channel mode.

ImGearMaskChannelModes

Syntax

public ImGearMaskChannelModes getMode()

Return Value

ImGearMaskChannelModes enumeration value.

See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.core Package > ImGearMaskColorChannelInfo Class : setMode Method
value
ImGearMaskChannelModes enumeration value.

Glossary Item Box

Sets mask channel mode.

ImGearMaskChannelModes

Syntax

public void setMode(
   ImGearMaskChannelModes value
)

Parameters

value
ImGearMaskChannelModes enumeration value.

See Also

Reference

ImGearMaskColorChannelInfo Class
ImGearMaskColorChannelInfo Members


%%PageItemTitle%%

ImGearMaskSpotChannelInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskSpotChannelInfo Class

Glossary Item Box

Represents a mask spot channel that uses a special (like Pantone) color.

Object Model

ImGearMaskSpotChannelInfo ClassImGearExtraChannelInfo ClassImGearMaskChannelModes EnumerationImGearExtraChannelType EnumerationImGearSpotColorVendorID Enumeration

Syntax

public class ImGearMaskSpotChannelInfo
    extends ImGearSpotChannelInfo

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearSpotChannelInfo
com.accusoft.imagegear.core.ImGearMaskSpotChannelInfo

See Also

Reference

ImGearMaskSpotChannelInfo Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMaskSpotChannelInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskSpotChannelInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearMaskSpotChannelInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearMaskSpotChannelInfo Constructor | Initializes a new instance of the ImGearMaskSpotChannelInfo class by using mode, color space and color value.
Top

Public Methods

 | Name | Description
public Method | getMode | Returns mask channel mode. ImGearMaskChannelModes
public Method | setMode | Sets mask channel mode. ImGearMaskChannelModes
Top

See Also

Reference

ImGearMaskSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMaskSpotChannelInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskSpotChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearMaskSpotChannelInfo members.

See Also

Reference

ImGearMaskSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMaskSpotChannelInfo Constructor
com.accusoft.imagegear.core Package > ImGearMaskSpotChannelInfo Class : ImGearMaskSpotChannelInfo Constructor
mode
ImGearMaskChannelModes value.
vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book. ImGearMaskChannelModes ImGearSpotColorVendorID

Glossary Item Box

Initializes a new instance of the ImGearMaskSpotChannelInfo class by using mode, color space and color value.

Syntax

public ImGearMaskSpotChannelInfo(
   ImGearMaskChannelModes mode,
   ImGearSpotColorVendorID vendorId,
   long colorId
)

Parameters

mode
ImGearMaskChannelModes value.
vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book. ImGearMaskChannelModes ImGearSpotColorVendorID

See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMaskSpotChannelInfo Class : clone Method

Glossary Item Box

Syntax

public ImGearExtraChannelInfo clone()

See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMaskSpotChannelInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMaskSpotChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearMaskSpotChannelInfo members.

Public Methods

 | Name | Description
public Method | getMode | Returns mask channel mode. ImGearMaskChannelModes
public Method | setMode | Sets mask channel mode. ImGearMaskChannelModes
Top

See Also

Reference

ImGearMaskSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.core Package > ImGearMaskSpotChannelInfo Class : getMode Method

Glossary Item Box

Returns mask channel mode.

ImGearMaskChannelModes

Syntax

public ImGearMaskChannelModes getMode()

Return Value

ImGearMaskChannelModes enumeration value.

See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.core Package > ImGearMaskSpotChannelInfo Class : setMode Method
value
ImGearMaskChannelModes enumeration value.

Glossary Item Box

Sets mask channel mode.

ImGearMaskChannelModes

Syntax

public void setMode(
   ImGearMaskChannelModes value
)

Parameters

value
ImGearMaskChannelModes enumeration value.

See Also

Reference

ImGearMaskSpotChannelInfo Class
ImGearMaskSpotChannelInfo Members


%%PageItemTitle%%

ImGearMemoryStream Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMemoryStream Class

Glossary Item Box

Basic in-memory stream functionality

Object Model

ImGearMemoryStream Class

Syntax

public abstract class ImGearMemoryStream
    extends ImGearStream

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearStream
com.accusoft.imagegear.core.ImGearMemoryStream

See Also

Reference

ImGearMemoryStream Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMemoryStream Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMemoryStream Class

Glossary Item Box

The following tables list the members exposed by ImGearMemoryStream.

Public Methods

 | Name | Description
public Method | getBuffer | Returns the array of bytes "backing" this stream. The bytes from the element at ImGearStream.getLength length onwards are not valid.
public Method | toArray | Returns a copy of the bytes accessed. Copies the first ImGearStream.getLength length bytes of this stream's internal buffer, which is available from getBuffer.
Top

See Also

Reference

ImGearMemoryStream Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMemoryStream Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMemoryStream Class

Glossary Item Box

For a list of all members of this type, see ImGearMemoryStream members.

Public Methods

 | Name | Description
public Method | getBuffer | Returns the array of bytes "backing" this stream. The bytes from the element at ImGearStream.getLength length onwards are not valid.
public Method | toArray | Returns a copy of the bytes accessed. Copies the first ImGearStream.getLength length bytes of this stream's internal buffer, which is available from getBuffer.
Top

See Also

Reference

ImGearMemoryStream Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getBuffer Method
com.accusoft.imagegear.core Package > ImGearMemoryStream Class : getBuffer Method

Glossary Item Box

Returns the array of bytes "backing" this stream.

The bytes from the element at getLength length onwards are not valid.

Syntax

public abstract byte[] getBuffer()

Return Value

the array of bytes "backing" this stream.

See Also

Reference

ImGearMemoryStream Class
ImGearMemoryStream Members


%%PageItemTitle%%

toArray Method
com.accusoft.imagegear.core Package > ImGearMemoryStream Class : toArray Method

Glossary Item Box

Returns a copy of the bytes accessed.

Copies the first getLength length bytes of this stream's internal buffer, which is available from getBuffer.

Syntax

public abstract byte[] toArray()

Return Value

a copy of the bytes accessed.

See Also

Reference

ImGearMemoryStream Class
ImGearMemoryStream Members


%%PageItemTitle%%

ImGearMetadataDictionary Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataDictionary Class

Glossary Item Box

Provides access to Metadata Dictionary that is used in ImageGear.

Object Model

ImGearMetadataDictionary ClassIImGearMetadataDictRecord Interface

Syntax

public class ImGearMetadataDictionary
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataDictionary

See Also

Reference

ImGearMetadataDictionary Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataDictionary Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataDictionary Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataDictionary.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | addRecord | This method adds a new record to the dictionary.
static (Shared in Visual Basic) | lookUp | Looks up a record in the dictionary, based on metadata format and tag ID.
static (Shared in Visual Basic) | reset | Resets the dictionary to its default state, i.e. removes all user added data.
Top

See Also

Reference

ImGearMetadataDictionary Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataDictionary Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataDictionary Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataDictionary members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | addRecord | This method adds a new record to the dictionary.
static (Shared in Visual Basic) | lookUp | Looks up a record in the dictionary, based on metadata format and tag ID.
static (Shared in Visual Basic) | reset | Resets the dictionary to its default state, i.e. removes all user added data.
Top

See Also

Reference

ImGearMetadataDictionary Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

addRecord Method
com.accusoft.imagegear.core Package > ImGearMetadataDictionary Class : addRecord Method
format
Metadata format associated with the record.
record
New record.

Glossary Item Box

This method adds a new record to the dictionary.

Syntax

public static void addRecord(
   ImGearMetadataFormats format,
   IImGearMetadataDictRecord record
)

Parameters

format
Metadata format associated with the record.
record
New record.

See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members


%%PageItemTitle%%

lookUp Method
com.accusoft.imagegear.core Package > ImGearMetadataDictionary Class : lookUp Method
format
Metadata format.
tag
Tag ID value.

Glossary Item Box

Looks up a record in the dictionary, based on metadata format and tag ID.

Syntax

public static IImGearMetadataDictRecord lookUp(
   ImGearMetadataFormats format,
   int tag
)

Parameters

format
Metadata format.
tag
Tag ID value.

Return Value

IImGearMetadataDictRecord interface object.

See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members


%%PageItemTitle%%

reset Method
com.accusoft.imagegear.core Package > ImGearMetadataDictionary Class : reset Method

Glossary Item Box

Resets the dictionary to its default state, i.e. removes all user added data.

Syntax

public static void reset()

See Also

Reference

ImGearMetadataDictionary Class
ImGearMetadataDictionary Members


%%PageItemTitle%%

ImGearMetadataHead Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataHead Class

Glossary Item Box

Head of metadata tree.

ImGearMetadataHead is a special kind of metadata node with a null Parent field and not more than one child. It is present in every instance of ImGearPage class and ImGearDocument class as class member.

If the page or document has metadata, an instance of ImGearMetadataTree class is attached to the head as a child node. Otherwise, child is null.

ImGearMetadataHead may only be the root of metadata tree. Attempting to attach this class to any node causes ImageGear to throw an exception.

Object Model

ImGearMetadataHead ClassImGearMetadataHead ClassImGearFormatMetadata ClassImGearMetadataNode ClassImGearCommonMetadata ClassImGearFormatMetadata ClassImGearFormatMetadata ClassImGearMetadataNode ClassImGearFormats EnumerationImGearFormatMetadata ClassImGearFormatMetadata Class

Syntax

public sealed class ImGearMetadataHead
    extends ImGearMetadataNode

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataNode
com.accusoft.imagegear.core.ImGearMetadataHead

See Also

Reference

ImGearMetadataHead Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataHead Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataHead Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataHead.

Public Constructors

 | Name | Description
public Constructor | ImGearMetadataHead Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getAccessor | get accessor to Simplified Metadata for specified metadata Format.
public Method getChild Returns reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

public Method getCommon Gets access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata class object.

This method provides access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata

public Method getEXIF Returns simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

public Method getIPTC Returns simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

public Method | getTargetFormat | Returns target format of the page metadata.
public Method getTIFF Returns simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

public Method getXMP Returns simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

public Method | setAccessor | Set accessor to Simplified Metadata for spesified metadata Format.
public Method setChild Sets reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

public Method setEXIF Sets simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

public Method setIPTC Sets simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

public Method | setTargetFormat | Sets target format of the page metadata.
public Method setTIFF Sets simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

public Method setXMP Sets simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

Top

See Also

Reference

ImGearMetadataHead Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMetadataHead Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataHead Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataHead members.

See Also

Reference

ImGearMetadataHead Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMetadataHead Constructor
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : ImGearMetadataHead Constructor

Glossary Item Box

Overload List

Overload Description
ImGearMetadataHead Constructor(ImGearMetadataFormats) Initializes a new instance of the ImGearMetadataHead class for the specified format.

ImGearMetadataHead Constructor() Initializes a new instance of the ImGearMetadataHead class.

Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

ImGearMetadataHead Constructor(ImGearMetadataFormats)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataHead Class > ImGearMetadataHead Constructor : ImGearMetadataHead Constructor(ImGearMetadataFormats)
frmt
com.accusoft.imagegear.formats.ImGearMetadataFormats enum value to specify metadata format.

Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Glossary Item Box

Initializes a new instance of the ImGearMetadataHead class for the specified format.

Syntax

public ImGearMetadataHead(
   ImGearMetadataFormats frmt
)

Parameters

frmt
com.accusoft.imagegear.formats.ImGearMetadataFormats enum value to specify metadata format.

Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
Overload List


%%PageItemTitle%%

ImGearMetadataHead Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataHead Class > ImGearMetadataHead Constructor : ImGearMetadataHead Constructor()

Glossary Item Box

Initializes a new instance of the ImGearMetadataHead class.

Constructor initializes node with empty metadata tree (null child) with specified format. Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Parent field is always null for the instances of this class. Trying to insert ImGearMetadataHead object as a Child to any node causes exception.

Syntax

public ImGearMetadataHead()

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members
Overload List


%%PageItemTitle%%

attach Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : attach Method
parent

Glossary Item Box

Syntax

public void attach(
   ImGearMetadataNode parent
)

Parameters

parent

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataHead Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataHead Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataHead members.

Public Methods

Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getAccessor | get accessor to Simplified Metadata for specified metadata Format.
public Method getChild Returns reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

public Method getCommon Gets access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata class object.

This method provides access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata

public Method getEXIF Returns simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

public Method getIPTC Returns simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

public Method | getTargetFormat | Returns target format of the page metadata.
public Method getTIFF Returns simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

public Method getXMP Returns simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

public Method | setAccessor | Set accessor to Simplified Metadata for spesified metadata Format.
public Method setChild Sets reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

public Method setEXIF Sets simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

public Method setIPTC Sets simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

public Method | setTargetFormat | Sets target format of the page metadata.
public Method setTIFF Sets simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

public Method setXMP Sets simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

Top

See Also

Reference

ImGearMetadataHead Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearMetadataHead clone()

Return Value

ImGearMetadataNode class object that is a copy of the current instance. ImGearMetadataNode

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

detach Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : detach Method

Glossary Item Box

Syntax

public void detach()

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getAccessor Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getAccessor Method
metadataFormat
Metadata format ID to get accessor.

Glossary Item Box

get accessor to Simplified Metadata for specified metadata Format.

Syntax

public ImGearFormatMetadata getAccessor(
   ImGearMetadataFormats metadataFormat
)

Parameters

metadataFormat
Metadata format ID to get accessor.

Return Value

com.accusoft.imagegear.formats.ImGearFormatMetadata class object to simplified metadata access.

This method throws ImGearException if the metadata format does not allow access to simplified metadata.

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot com.accusoft.imagegear.formats.ImGearMetadataFormats

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getChild Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getChild Method

Glossary Item Box

Returns reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

Syntax

public ImGearMetadataNode getChild()

Return Value

ImGearMetadataNode class object. May be null.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getCommon Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getCommon Method

Glossary Item Box

Gets access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata class object.

This method provides access to metadata that is common for all format filters.

com.accusoft.imagegear.formats.ImGearCommonMetadata

Syntax

public ImGearCommonMetadata getCommon()

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getEXIF Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getEXIF Method

Glossary Item Box

Returns simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

Syntax

public ImGearFormatMetadata getEXIF()

Return Value

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getIPTC Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getIPTC Method

Glossary Item Box

Returns simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

Syntax

public ImGearFormatMetadata getIPTC()

Return Value

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getTargetFormat Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getTargetFormat Method

Glossary Item Box

Returns target format of the page metadata.

Syntax

public ImGearFormats getTargetFormat()

Return Value

com.accusoft.imagegear.formats.ImGearFormats enumeration object that is a copy of the current instance.

The target format is the file format to which the current metadata tree can be saved. For example, if ImGearPage has been loaded from a JFIF JPEG image, its target format is JPEG. The application can modify metadata tags and save the image back to JPEG; modified metadata will be saved to the resultant file. However, if target format is JPEG, and the image is saved to BMP, metadata modifications will not be saved to the result file, because of incompatibilities with the metadata formats.

The target format can affect the functionality of the Simplified Metadata API. A simplified metadata accessor can be initialized for the metadata tree only if it has a compatible target format. For example, if the target format is TIFF or JPEG, the application can initialize an IPTC accessor for the metadata tree and add IPTC tags. But if target format is BMP, adding an IPTC accessor will result in an exception.

com.accusoft.imagegear.formats.ImGearFormats

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getTIFF Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getTIFF Method

Glossary Item Box

Returns simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

Syntax

public ImGearFormatMetadata getTIFF()

Return Value

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

getXMP Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : getXMP Method

Glossary Item Box

Returns simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

Syntax

public ImGearFormatMetadata getXMP()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class value.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setAccessor Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setAccessor Method
metadataFormat
Metadata format ID to set accessor.
accessor
An instance of com.accusoft.imagegear.formats.ImGearFormatMetadata accessor to set.

This method throws ImGearException if the metadata format does not allow access to simplified metadata.

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot com.accusoft.imagegear.formats.ImGearMetadataFormats

Glossary Item Box

Set accessor to Simplified Metadata for spesified metadata Format.

Syntax

public void setAccessor(
   ImGearMetadataFormats metadataFormat,
   ImGearFormatMetadata accessor
)

Parameters

metadataFormat
Metadata format ID to set accessor.
accessor
An instance of com.accusoft.imagegear.formats.ImGearFormatMetadata accessor to set.

This method throws ImGearException if the metadata format does not allow access to simplified metadata.

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot com.accusoft.imagegear.formats.ImGearMetadataFormats

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setChild Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setChild Method
value
ImGearMetadataNode class object. May be null.

Glossary Item Box

Sets reference to child node.

Value being assigned must be stand-alone ( ImGearMetadataNode.getParent == null) and not an instance of ImGearMetadataHead class.

ImGearMetadataNode

Syntax

public void setChild(
   ImGearMetadataNode value
)

Parameters

value
ImGearMetadataNode class object. May be null.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setEXIF Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setEXIF Method
value
com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class object.

Glossary Item Box

Sets simplified access to EXIF metadata.

The user does not need to know exact location of EXIF metadata in the metadata tree. If EXIF metadata doesn't exist in the metadata tree, the method returns null.

You can add EXIF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class and assigning it using setEXIF method. However, this only allowed if metadata tree's target format is compatible with EXIF. Currently, two target formats support EXIF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

Syntax

public void setEXIF(
   ImGearFormatMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setIPTC Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setIPTC Method
value
com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class object.

Glossary Item Box

Sets simplified access to IPTC metadata.

The user does not need to know exact location of IPTC metadata in the metadata tree. If IPTC metadata doesn't exist in the metadata tree, the method returns null.

You can add IPTC metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class and assigning it using setIPTC method. However, this only allowed if metadata tree's target format is compatible with IPTC. Currently, two target formats support IPTC metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

Syntax

public void setIPTC(
   ImGearFormatMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setTargetFormat Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setTargetFormat Method
frmt
com.accusoft.imagegear.formats.ImGearFormats enumeration value.

If the new target format is the same as current target format, no action is taken. If the new format is different from the current format, the existing metadata is discarded and a new empty tree with specified target format is created.

See getTargetFormat for details on target format usage.

com.accusoft.imagegear.formats.ImGearFormats enumeration.

Glossary Item Box

Sets target format of the page metadata.

Syntax

public void setTargetFormat(
   ImGearFormats frmt
)

Parameters

frmt
com.accusoft.imagegear.formats.ImGearFormats enumeration value.

If the new target format is the same as current target format, no action is taken. If the new format is different from the current format, the existing metadata is discarded and a new empty tree with specified target format is created.

See getTargetFormat for details on target format usage.

com.accusoft.imagegear.formats.ImGearFormats enumeration.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setTIFF Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setTIFF Method
value
com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class object.

Glossary Item Box

Sets simplified access to TIFF metadata.

The user does not need to know exact location of TIFF metadata in the metadata tree. If TIFF metadata doesn't exist in the metadata tree, the method returns null.

You can add TIFF metadata to a metadata tree, if it was not present, by creating a new instance of com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class and assigning it using setTIFF method. However, this only allowed if metadata tree's target format is compatible with TIFF. Currently, two target formats support TIFF metadata: TIFF and JPEG.

com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

Syntax

public void setTIFF(
   ImGearFormatMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata class object.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

setXMP Method
com.accusoft.imagegear.core Package > ImGearMetadataHead Class : setXMP Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class value.

Glossary Item Box

Sets simplified access to XMP metadata.

The method returns null if XMP metadata doesn't exist in the metadata tree.

You can add XMP metadata to a metadata tree, if it is not present, by creating a new instance of com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class and assigning it using setXMP method. However, this is only allowed if metadata tree's target format is compatible with XMP. Currently, the following target formats support XMP metadata: TIFF, JPEG, PSD, PDF, PS

com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

Syntax

public void setXMP(
   ImGearFormatMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot class value.

See Also

Reference

ImGearMetadataHead Class
ImGearMetadataHead Members


%%PageItemTitle%%

ImGearMetadataLeaf Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataLeaf Class

Glossary Item Box

Represents metadata node that contains a data value and cannot reference other metadata nodes.

Object Model

ImGearMetadataLeaf ClassImGearMetadataLeaf ClassImGearMetadataNode Class

Syntax

public sealed class ImGearMetadataLeaf
    extends ImGearMetadataNode

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataNode
com.accusoft.imagegear.core.ImGearMetadataLeaf

See Also

Reference

ImGearMetadataLeaf Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataLeaf Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataLeaf Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataLeaf.

Public Constructors

 | Name | Description
public Constructor | ImGearMetadataLeaf Constructor | Overloaded.
Top

Public Fields

Name Description
public Field nativeType Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.

com.accusoft.imagegear.formats.ImGearNativeDataTypes or com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations enumeration value, passed as System.Object.

When metadata is loaded from a file, all leaves have this field set to explicit values.

When the application creates a leaf, it can either specify an explicit NativeType value or use the default value com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN.

At the time of image saving, most file formats ignore this field and use the file format's standard types for metadata tags. Two file formats take NativeType field into account:

  • TIFF format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, TIFF filter skips the tag.
  • DICOM format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, DICOM filter looks up the native type from its Data Dictionary. If the value is not found, it saves the tag as com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations.Unknown.
Top

Public Methods

Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method getData Returns reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

public Method isIgnoredOnSave Gets a value indicating whether current node should be ignored during page/document saving or not.

Boolean value.

If this method returns true, data contained in ImGearMetadataLeaf is ignored during image saving and data from the medatada container (page or document) will be used instead.

static (Shared in Visual Basic) | isValidDataObject | Indicates whether the data type of an object is valid (supported by metadata leaf).
public Method setData Sets reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

Top

See Also

Reference

ImGearMetadataLeaf Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMetadataLeaf Constructor
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : ImGearMetadataLeaf Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearMetadataLeaf Constructor() | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum. It is good for several leaves to refer to the same data object.
ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean,String) | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum.
ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean) | Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

ImGearMetadataLeaf Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor()

Glossary Item Box

Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum.

It is good for several leaves to refer to the same data object.

Syntax

public ImGearMetadataLeaf()

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%%

ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean,String)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean,String)
frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
ntvTp
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.
nm
Name of the leaf.

Glossary Item Box

Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum.

Syntax

public ImGearMetadataLeaf(
   ImGearMetadataFormats frmt,
   int tg,
   java.lang.Object data,
   java.lang.Object ntvTp,
   boolean ignoredOnSave,
   java.lang.String nm
)

Parameters

frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
ntvTp
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.
nm
Name of the leaf.

Return Value

A new instance of ImGearMetadataLeaf class.

It is good for several leaves to refer to the same data object.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%%

ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class > ImGearMetadataLeaf Constructor : ImGearMetadataLeaf Constructor(ImGearMetadataFormats,int,Object,Object,boolean)
frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
ntvTp
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.

It is good for several leaves to refer to the same data object.

Glossary Item Box

Initializes a new instance of the ImGearMetadataLeaf class with data attached to the node and its type as value of com.accusoft.imagegear.formats.ImGearNativeDataTypes enum.

Syntax

public ImGearMetadataLeaf(
   ImGearMetadataFormats frmt,
   int tg,
   java.lang.Object data,
   java.lang.Object ntvTp,
   boolean ignoredOnSave
)

Parameters

frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Represents identifier of metadata for particular file format.
data
Actual data to be stored in metadata node.
ntvTp
Identifier of attached data type.
ignoredOnSave
Specifies whether node should be ignored during page (document) saving or not.

It is good for several leaves to refer to the same data object.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members
Overload List


%%PageItemTitle%%

attach Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : attach Method
parent

Glossary Item Box

Syntax

public void attach(
   ImGearMetadataNode parent
)

Parameters

parent

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataLeaf Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataLeaf Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataLeaf members.

Public Methods

Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method getData Returns reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

public Method isIgnoredOnSave Gets a value indicating whether current node should be ignored during page/document saving or not.

Boolean value.

If this method returns true, data contained in ImGearMetadataLeaf is ignored during image saving and data from the medatada container (page or document) will be used instead.

static (Shared in Visual Basic) | isValidDataObject | Indicates whether the data type of an object is valid (supported by metadata leaf).
public Method setData Sets reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

Top

See Also

Reference

ImGearMetadataLeaf Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearMetadataLeaf clone()

Return Value

ImGearMetadataNode class object that is a copy of the current instance.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

detach Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : detach Method

Glossary Item Box

Syntax

public void detach()

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

getData Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : getData Method

Glossary Item Box

Returns reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

Syntax

public java.lang.Object getData()

Return Value

Object value.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

isIgnoredOnSave Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : isIgnoredOnSave Method

Glossary Item Box

Gets a value indicating whether current node should be ignored during page/document saving or not.

Boolean value.

If this method returns true, data contained in ImGearMetadataLeaf is ignored during image saving and data from the medatada container (page or document) will be used instead.

Syntax

public boolean isIgnoredOnSave()

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

isValidDataObject Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : isValidDataObject Method
value
The data to be validated.

Glossary Item Box

Indicates whether the data type of an object is valid (supported by metadata leaf).

Syntax

public static boolean isValidDataObject(
   java.lang.Object value
)

Parameters

value
The data to be validated.

Return Value

Boolean value.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

setData Method
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : setData Method
value
Object value.

Glossary Item Box

Sets reference to opaque data stored in leaf. Type of object returned by this method depends on value of nativeType field.

Represents (meta) data assigned to metadata node as Object. The following types of objects are allowed to be stored:

  • Number subclass
  • Enum subclass
  • String
  • ImGearArray or native array
  • ImGearRationalInt

Otherwise, an exception will be thrown.

Syntax

public void setData(
   java.lang.Object value
)

Parameters

value
Object value.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMetadataLeaf Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataLeaf Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataLeaf members.

Public Fields

Name Description
public Field nativeType Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.

com.accusoft.imagegear.formats.ImGearNativeDataTypes or com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations enumeration value, passed as System.Object.

When metadata is loaded from a file, all leaves have this field set to explicit values.

When the application creates a leaf, it can either specify an explicit NativeType value or use the default value com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN.

At the time of image saving, most file formats ignore this field and use the file format's standard types for metadata tags. Two file formats take NativeType field into account:

  • TIFF format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, TIFF filter skips the tag.
  • DICOM format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, DICOM filter looks up the native type from its Data Dictionary. If the value is not found, it saves the tag as com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations.Unknown.
Top

See Also

Reference

ImGearMetadataLeaf Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

nativeType Field
com.accusoft.imagegear.core Package > ImGearMetadataLeaf Class : nativeType Field

Glossary Item Box

Specifies the type of data stored in a leaf, as it was stored in the image file or should be saved to the image file.

com.accusoft.imagegear.formats.ImGearNativeDataTypes or com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations enumeration value, passed as System.Object.

When metadata is loaded from a file, all leaves have this field set to explicit values.

When the application creates a leaf, it can either specify an explicit NativeType value or use the default value com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN.

At the time of image saving, most file formats ignore this field and use the file format's standard types for metadata tags. Two file formats take NativeType field into account:

  • TIFF format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, TIFF filter skips the tag.
  • DICOM format filter saves tags according to the value specified by the NativeType field. If NativeType of a tag is com.accusoft.imagegear.formats.ImGearNativeDataTypes.UNKNOWN, DICOM filter looks up the native type from its Data Dictionary. If the value is not found, it saves the tag as com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations.Unknown.

Syntax

public java.lang.Object nativeType

Return Value

com.accusoft.imagegear.formats.ImGearNativeDataTypes or com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations enumeration value, passed as System.Object.

See Also

Reference

ImGearMetadataLeaf Class
ImGearMetadataLeaf Members


%%PageItemTitle%%

ImGearMetadataNode Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNode Class

Glossary Item Box

Provides generic functionality for the ImageGear metadata objects.

An ImGearMetadataNode can be referenced from one parent node or can be unreferenced. It cannot however be referenced from multiple parents. A node can never refer to itself either directly or indirectly.

Object Model

ImGearMetadataNode ClassImGearMetadataNode ClassImGearMetadataNode Class

Syntax

public abstract class ImGearMetadataNode
    extends Object
    implements java.lang.Comparable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataNode
com.accusoft.imagegear.core.ImGearMetadataHead
com.accusoft.imagegear.core.ImGearMetadataLeaf
com.accusoft.imagegear.core.ImGearMetadataTree

See Also

Reference

ImGearMetadataNode Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataNode Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNode Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataNode.

Public Fields

 | Name | Description
public Field | format | Identifier of the File format to which the metadata belongs. com.accusoft.imagegear.formats.ImGearMetadataFormats enumeration It is possible for a metadata tree to contain subtrees defined in another metadata format. For example, JPEG metadata tree may contain subtrees containing EXIF or IPTC metadata. com.accusoft.imagegear.formats.ImGearFormats.UNKNOWN means custom (unknown) format. com.accusoft.imagegear.formats.ImGearMetadataFormats
public Field | tag | Represents identifier of metadata node for particular file format. Integer value Identifies what kind of data is stored in metadata node. Specific for particular file format. Values for the tags are taken from tag list of file formats, represented in ImageGear for Java as ImGearFORMATTagIDs (where FORMAT is BMP, TIFF, etc.) enumerations.
Top

Protected Fields

 | Name | Description
protected Field | name | Returns string name of tag.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | compareTo | Compares the current instance with another object of the same type.
public Method | getFormatName | Gets the name of the type of the file format to which metadata belongs. Any string name of format.
public Method | getName | Returns returns string name of tag. Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.
public Method | getParent | Gets reference to parent node. ImGearMetadataNodeList class object. Specifies reference to parent node in metadata tree. This method may return null. Accordingly, the instance is stand-alone (not attached), or otherwise, has special type like ImGearMetadataHead.
public Method | setName | Sets returns string name of tag. Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.
Top

See Also

Reference

ImGearMetadataNode Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataNode Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNode Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataNode members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | compareTo | Compares the current instance with another object of the same type.
public Method | getFormatName | Gets the name of the type of the file format to which metadata belongs. Any string name of format.
public Method | getName | Returns returns string name of tag. Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.
public Method | getParent | Gets reference to parent node. ImGearMetadataNodeList class object. Specifies reference to parent node in metadata tree. This method may return null. Accordingly, the instance is stand-alone (not attached), or otherwise, has special type like ImGearMetadataHead.
public Method | setName | Sets returns string name of tag. Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.
Top

See Also

Reference

ImGearMetadataNode Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public abstract ImGearMetadataNode clone()

Return Value

ImGearMetadataNodeList class that is a copy of the current instance.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

compareTo Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : compareTo Method
obj
An object to compare with this instance.

Glossary Item Box

Compares the current instance with another object of the same type.

Syntax

public int compareTo(
   ImGearMetadataNode obj
)

Parameters

obj
An object to compare with this instance.

Return Value

Following values defined:
  • -1 - This instance is less than obj.
  • 0 - This instance is equal to obj.
  • 1 - This instance is greater than obj.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

getFormatName Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : getFormatName Method

Glossary Item Box

Gets the name of the type of the file format to which metadata belongs.

Any string name of format.

Syntax

public java.lang.String getFormatName()

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : getName Method

Glossary Item Box

Returns returns string name of tag.

Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.

Syntax

public java.lang.String getName()

Return Value

String identifier of medatada tag.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

getParent Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : getParent Method

Glossary Item Box

Gets reference to parent node.

ImGearMetadataNodeList class object.

Specifies reference to parent node in metadata tree. This method may return null. Accordingly, the instance is stand-alone (not attached), or otherwise, has special type like ImGearMetadataHead.

Syntax

public ImGearMetadataNode getParent()

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : setName Method
value
String identifier of medatada tag.

Glossary Item Box

Sets returns string name of tag.

Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.

Syntax

public void setName(
   java.lang.String value
)

Parameters

value
String identifier of medatada tag.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMetadataNode Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNode Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataNode members.

Public Fields

 | Name | Description
public Field | format | Identifier of the File format to which the metadata belongs. com.accusoft.imagegear.formats.ImGearMetadataFormats enumeration It is possible for a metadata tree to contain subtrees defined in another metadata format. For example, JPEG metadata tree may contain subtrees containing EXIF or IPTC metadata. com.accusoft.imagegear.formats.ImGearFormats.UNKNOWN means custom (unknown) format. com.accusoft.imagegear.formats.ImGearMetadataFormats
public Field | tag | Represents identifier of metadata node for particular file format. Integer value Identifies what kind of data is stored in metadata node. Specific for particular file format. Values for the tags are taken from tag list of file formats, represented in ImageGear for Java as ImGearFORMATTagIDs (where FORMAT is BMP, TIFF, etc.) enumerations.
Top

Protected Fields

 | Name | Description
protected Field | name | Returns string name of tag.
Top

See Also

Reference

ImGearMetadataNode Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

format Field
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : format Field

Glossary Item Box

Identifier of the File format to which the metadata belongs.

com.accusoft.imagegear.formats.ImGearMetadataFormats enumeration

It is possible for a metadata tree to contain subtrees defined in another metadata format. For example, JPEG metadata tree may contain subtrees containing EXIF or IPTC metadata.

com.accusoft.imagegear.formats.ImGearFormats.UNKNOWN means custom (unknown) format.

com.accusoft.imagegear.formats.ImGearMetadataFormats

Syntax

public ImGearMetadataFormats format

Return Value

com.accusoft.imagegear.formats.ImGearMetadataFormats enumeration

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

name Field
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : name Field

Glossary Item Box

Returns string name of tag.

Syntax

protected java.lang.String name

Return Value

String identifier of medatada tag.

Returns tag name from the internal dictionary, or empty string if tag is unknown in ImageGear for Java.

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

tag Field
com.accusoft.imagegear.core Package > ImGearMetadataNode Class : tag Field

Glossary Item Box

Represents identifier of metadata node for particular file format.

Integer value

Identifies what kind of data is stored in metadata node. Specific for particular file format.

Values for the tags are taken from tag list of file formats, represented in ImageGear for Java as ImGearFORMATTagIDs (where FORMAT is BMP, TIFF, etc.) enumerations.

Syntax

public int tag

Return Value

Integer value

See Also

Reference

ImGearMetadataNode Class
ImGearMetadataNode Members


%%PageItemTitle%%

ImGearMetadataNodeList Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNodeList Class

Glossary Item Box

Collection of metadata nodes. Processes additional verifications concerning collection structure. Used as a part of ImGearMetadataTree.

Represents container (list) of ImGearMetadataNode instances and provides additional verifications for stored objects. For example, on adding, new MetadataNode is checked to be non-null, stand-alone ( ImGearMetadataNode.getParent == null) and not the same as the top node of the tree to which it is added.

Nodes with different Format values are allowed to be present in the same list. Multiple nodes with the same Tag value are also allowed. The list is not sorted automatically because the order of items may be significant for a particular format.

This class does not have any public constructor. Instances exist only as members of ImGearMetadataTree objects.

Object Model

ImGearMetadataNodeList ClassImGearMetadataNodeList ClassImGearMetadataNode ClassImGearMetadataNode ClassImGearMetadataLeaf ClassImGearMetadataNode Class

Syntax

public sealed class ImGearMetadataNodeList
    extends Object
    implements java.util.List

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataNodeList

See Also

Reference

ImGearMetadataNodeList Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataNodeList Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNodeList Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataNodeList.

Public Methods

Name | Description
public Method | add | Overloaded. Adds a node to the list.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | addOrdered | Adds a node to the list.
public Method | clear | Clears the list.
public Method | clone | Clones the list.
public Method | contains | Checks whether or not the list contains the specified node.
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | get | Provides access to single node within the node list.
public Method | indexOf | Returns index of the node.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | lookUp | Overloaded. Searches the node list for a node which Tag is equal to the specified tag ID.
public Method lookUpLeaf Overloaded. This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

public Method | recursiveSort | Sorts the list items recursively so that items within each level are sorted.
public Method | remove | Overloaded. Removes the specified node.
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | removeName | Removes the node whose name is equal to the specified string value.
public Method | removeTag | Removes the node with the specified ID.
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Replaces the element at the specified position in this list with the specified element (optional operation).
public Method size Gets the number of elements contained in the List.

Any integer value.

public Method | sort | Sorts the list items.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

public Method toString Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character ' @', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

 getClass().getName() + '@' + Integer.toHexString(hashCode())
Top

See Also

Reference

ImGearMetadataNodeList Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataNodeList Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataNodeList Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataNodeList members.

Public Methods

Name | Description
public Method | add | Overloaded. Adds a node to the list.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | addOrdered | Adds a node to the list.
public Method | clear | Clears the list.
public Method | clone | Clones the list.
public Method | contains | Checks whether or not the list contains the specified node.
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | get | Provides access to single node within the node list.
public Method | indexOf | Returns index of the node.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | lookUp | Overloaded. Searches the node list for a node which Tag is equal to the specified tag ID.
public Method lookUpLeaf Overloaded. This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

public Method | recursiveSort | Sorts the list items recursively so that items within each level are sorted.
public Method | remove | Overloaded. Removes the specified node.
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | removeName | Removes the node whose name is equal to the specified string value.
public Method | removeTag | Removes the node with the specified ID.
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Replaces the element at the specified position in this list with the specified element (optional operation).
public Method size Gets the number of elements contained in the List.

Any integer value.

public Method | sort | Sorts the list items.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

public Method toString Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character ' @', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

 getClass().getName() + '@' + Integer.toHexString(hashCode())
Top

See Also

Reference

ImGearMetadataNodeList Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : add Method

Glossary Item Box

Adds a node to the list.

Overload List

Overload | Description
add(ImGearMetadataNode) | Adds a node to the list.
add(int,ImGearMetadataNode) | Adds a node at the specified position.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

add(ImGearMetadataNode) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > add Method : add(ImGearMetadataNode) Method
node
The ImGearMetadataNode to add.

Glossary Item Box

Adds a node to the list.

Syntax

public boolean add(
   ImGearMetadataNode node
)

Parameters

node
The ImGearMetadataNode to add.

Return Value

true

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

add(int,ImGearMetadataNode) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > add Method : add(int,ImGearMetadataNode) Method
index
The specified position.
node
The node to insert. ImGearMetadataNode

Glossary Item Box

Adds a node at the specified position.

Syntax

public void add(
   int index,
   ImGearMetadataNode node
)

Parameters

index
The specified position.
node
The node to insert. ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

addAll Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : addAll Method

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Overload List

Overload | Description
addAll(Collection<?>) | Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
addAll(int,Collection<?>) | Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

addAll(Collection<?>) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > addAll Method : addAll(Collection<?>) Method
c
collection containing elements to be added to this list

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List
java.util.List.add(E)


%%PageItemTitle%%

addAll(int,Collection<?>) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > addAll Method : addAll(int,Collection<?>) Method
index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Glossary Item Box

Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   int index,
   java.util.Collection<?> c
)

Parameters

index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

addOrdered Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : addOrdered Method
node
The node to add.

Glossary Item Box

Adds a node to the list.

Syntax

public int addOrdered(
   ImGearMetadataNode node
)

Parameters

node
The node to add.

Return Value

Index of added node.

This method adds a node to the end of the list. If there are already tags with this ID, put new tag after existing ones.

ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

clear Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : clear Method

Glossary Item Box

Clears the list.

Syntax

public void clear()

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : clone Method

Glossary Item Box

Clones the list.

Syntax

public ImGearMetadataNodeList clone()

Return Value

ImGearMetadataNodeList class object.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : contains Method
o

Glossary Item Box

Checks whether or not the list contains the specified node.

Syntax

public boolean contains(
   java.lang.Object o
)

Parameters

o

Return Value

Boolean value. ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

containsAll Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : containsAll Method
c
collection to be checked for containment in this list

Glossary Item Box

Returns true if this list contains all of the elements of the specified collection.

Syntax

public boolean containsAll(
   java.util.Collection<?> c
)

Parameters

c
collection to be checked for containment in this list

Return Value

true if this list contains all of the elements of the specified collection

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
contains Method


%%PageItemTitle%%

get Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : get Method
index
Index of the node to get.

Glossary Item Box

Provides access to single node within the node list.

Syntax

public ImGearMetadataNode get(
   int index
)

Parameters

index
Index of the node to get.

Return Value

ImGearMetadataNode class object.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

indexOf Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : indexOf Method
node
The specified node.

Glossary Item Box

Returns index of the node.

Syntax

public int indexOf(
   java.lang.Object node
)

Parameters

node
The specified node.

Return Value

Integer value. ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : isEmpty Method

Glossary Item Box

Returns true if this list contains no elements.

Syntax

public boolean isEmpty()

Return Value

true if this list contains no elements

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : iterator Method

Glossary Item Box

Returns an iterator over the elements in this list in proper sequence.

Syntax

public java.util.Iterator<ImGearMetadataNode> iterator()

Return Value

an iterator over the elements in this list in proper sequence

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

lastIndexOf Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : lastIndexOf Method
o
element to search for

Glossary Item Box

Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.

Syntax

public int lastIndexOf(
   java.lang.Object o
)

Parameters

o
element to search for

Return Value

the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

listIterator Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : listIterator Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Overload List

Overload | Description
listIterator() | Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) | Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to ListIterator.next(). An initial call to ListIterator.previous() would return the element with the specified index minus one.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

listIterator() Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > listIterator Method : listIterator() Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Syntax

public java.util.ListIterator<ImGearMetadataNode> listIterator()

Return Value

a list iterator over the elements in this list (in proper sequence)

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

listIterator(int) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > listIterator Method : listIterator(int) Method
index
index of first element to be returned from the list iterator (by a call to the next method)

Glossary Item Box

Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to ListIterator.next(). An initial call to ListIterator.previous() would return the element with the specified index minus one.

Syntax

public java.util.ListIterator<ImGearMetadataNode> listIterator(
   int index
)

Parameters

index
index of first element to be returned from the list iterator (by a call to the next method)

Return Value

a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : lookUp Method

Glossary Item Box

Searches the node list for a node which Tag is equal to the specified tag ID.

Overload List

Overload | Description
lookUp(int) | Searches the node list for a node which Tag is equal to the specified tag ID.
lookUp(Enum<?>) | Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.
lookUp(String) | Searches the node list for a node whose Name is equal to the specified string value.
lookUp(Enum<?>[]) | Searches the node list recursively for a node, according to the path parameter.
lookUp(int[]) | Searches the node list recursively for a node, according to the path parameter.
lookUp(String[]) | This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a node is not present, the method returns null. The method does not search in the subtrees of the node list.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

lookUp(int) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(int) Method
tag
Tag ID to search for.

Glossary Item Box

Searches the node list for a node which Tag is equal to the specified tag ID.

Syntax

public ImGearMetadataNode lookUp(
   int tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataNode class object.

If the list contains several nodes with this tag ID, the method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp(Enum<?>) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(Enum<?>) Method
tag
Tag ID to search for.

Glossary Item Box

Searches the node list for a node which Tag is equal to the numerical value of the specified tag ID.

Syntax

public ImGearMetadataNode lookUp(
   java.lang.Enum<?> tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataNode class object.

If the list contains several nodes with this tag ID, method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp(String) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(String) Method
name
Tag Name for which to search.

Glossary Item Box

Searches the node list for a node whose Name is equal to the specified string value.

Syntax

public ImGearMetadataNode lookUp(
   java.lang.String name
)

Parameters

name
Tag Name for which to search.

Return Value

ImGearMetadataNode class object.

If the list contains several nodes with this Name, method returns the first record. If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp(Enum<?>[]) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(Enum<?>[]) Method
path
Path to a data element in the metadata structure.

Glossary Item Box

Searches the node list recursively for a node, according to the path parameter.

Syntax

public ImGearMetadataNode lookUp(
   java.lang.Enum<?>[] path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataNode class object.

Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

IImGearMetadataDictRecord

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp(int[]) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(int[]) Method
path
Path to a data element in the metadata structure.

Glossary Item Box

Searches the node list recursively for a node, according to the path parameter.

Syntax

public ImGearMetadataNode lookUp(
   int[] path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataNode class object.

Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

IImGearMetadataDictRecord

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUp(String[]) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUp Method : lookUp(String[]) Method
path
Path to a data element in the metadata structure.

Glossary Item Box

This method searches the node list recursively for a node, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a node is not present, the method returns null.

The method does not search in the subtrees of the node list.

Syntax

public ImGearMetadataNode lookUp(
   java.lang.String[] path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataNode class object. IImGearMetadataDictRecord

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUpLeaf Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : lookUpLeaf Method

Glossary Item Box

This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

Overload List

Overload | Description
lookUpLeaf(String[]) | This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located. If a leaf is not present, the method returns null. The method does not search in the subtrees of the node list.
lookUpLeaf(int) | Searches the leaf list for a node which Tag is equal to the specified tag ID.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

lookUpLeaf(String[]) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUpLeaf Method : lookUpLeaf(String[]) Method
path
Path to a data element in the metadata structure.

Glossary Item Box

This method searches the node list recursively for a leaf, according to the path parameter. Length of the path should correspond to the metadata structure depth, at which the desired node is located.

If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

Syntax

public ImGearMetadataLeaf lookUpLeaf(
   java.lang.String[] path
)

Parameters

path
Path to a data element in the metadata structure.

Return Value

Instanse of ImGearMetadataLeaf class object. IImGearMetadataDictRecord

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

lookUpLeaf(int) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > lookUpLeaf Method : lookUpLeaf(int) Method
tag
Tag ID to search for.

Glossary Item Box

Searches the leaf list for a node which Tag is equal to the specified tag ID.

Syntax

public ImGearMetadataLeaf lookUpLeaf(
   int tag
)

Parameters

tag
Tag ID to search for.

Return Value

ImGearMetadataLeaf class object.

If the list contains several leafs with this tag ID, the method returns the first leaf. If a leaf is not present, the method returns null.

The method does not search in the subtrees of the node list.

ImGearMetadataNode

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

recursiveSort Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : recursiveSort Method

Glossary Item Box

Sorts the list items recursively so that items within each level are sorted.

Syntax

public void recursiveSort()

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : remove Method

Glossary Item Box

Removes the specified node.

Overload List

Overload | Description
remove(Object) | Removes the specified node.
remove(int) | Removes the node at the specified index.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

remove(Object) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > remove Method : remove(Object) Method
node
The node to remove. ImGearMetadataNode

Glossary Item Box

Removes the specified node.

Syntax

public boolean remove(
   java.lang.Object node
)

Parameters

node
The node to remove. ImGearMetadataNode

Return Value

Whether the node was removed.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

remove(int) Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > remove Method : remove(int) Method
index
The specified index. ImGearMetadataNode

Glossary Item Box

Removes the node at the specified index.

Syntax

public ImGearMetadataNode remove(
   int index
)

Parameters

index
The specified index. ImGearMetadataNode

Return Value

The old node

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

removeAll Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : removeAll Method
c
collection containing elements to be removed from this list

Glossary Item Box

Removes from this list all of its elements that are contained in the specified collection (optional operation).

Syntax

public boolean removeAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be removed from this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
remove(Object) Method
contains Method


%%PageItemTitle%%

removeName Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : removeName Method
name
The name of the node to remove.

Glossary Item Box

Removes the node whose name is equal to the specified string value.

Syntax

public void removeName(
   java.lang.String name
)

Parameters

name
The name of the node to remove.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

removeTag Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : removeTag Method
id
The ID of the node to remove.

Glossary Item Box

Removes the node with the specified ID.

Syntax

public void removeTag(
   int id
)

Parameters

id
The ID of the node to remove.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

retainAll Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : retainAll Method
c
collection containing elements to be retained in this list

Glossary Item Box

Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.

Syntax

public boolean retainAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be retained in this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
remove(Object) Method
contains Method


%%PageItemTitle%%

set Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : set Method
index
index of the element to replace
node
Element to be stored at the specified position

Glossary Item Box

Replaces the element at the specified position in this list with the specified element (optional operation).

Syntax

public ImGearMetadataNode set(
   int index,
   ImGearMetadataNode node
)

Parameters

index
index of the element to replace
node
Element to be stored at the specified position

Return Value

the element previously at the specified position

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

size Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : size Method

Glossary Item Box

Gets the number of elements contained in the List.

Any integer value.

Syntax

public int size()

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

sort Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : sort Method

Glossary Item Box

Sorts the list items.

Syntax

public void sort()

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

subList Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : subList Method
fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Glossary Item Box

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

Syntax

public java.util.List<ImGearMetadataNode> subList(
   int fromIndex,
   int toIndex
)

Parameters

fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Return Value

a view of the specified range within this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

toArray Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : toArray Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Overload List

Overload Description
toArray() Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

toArray<T>(T[]) Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

toArray() Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > toArray Method : toArray() Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Syntax

public java.lang.Object[] toArray()

Return Value

an array containing all of the elements in this list in proper sequence

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

T
toArray<T>(T[]) Method
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class > toArray Method : toArray<T>(T[]) Method
a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

Syntax

public <T> T[] toArray(
   T[] a
)

Parameters

a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Type Parameters

T

Return Value

an array containing the elements of this list

Exceptions

Exception | Description
java.lang.ArrayStoreException |
java.lang.NullPointerException |

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members
Overload List


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.core Package > ImGearMetadataNodeList Class : toString Method

Glossary Item Box

Returns a string representation of the object. In general, the toString method returns a string that "textually represents" this object. The result should be a concise but informative representation that is easy for a person to read. It is recommended that all subclasses override this method.

The toString method for class Object returns a string consisting of the name of the class of which the object is an instance, the at-sign character ' @', and the unsigned hexadecimal representation of the hash code of the object. In other words, this method returns a string equal to the value of:

 getClass().getName() + '@' + Integer.toHexString(hashCode())

Syntax

public java.lang.String toString()

Return Value

a string representation of the object.

See Also

Reference

ImGearMetadataNodeList Class
ImGearMetadataNodeList Members


%%PageItemTitle%%

ImGearMetadataTree Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataTree Class

Glossary Item Box

Encapsulates entity of file format metadata tree.

Represents metadata tree with structure of any complexity. Similar to ImGearMetadataHead, ImGearMetadataTree, this is a special case of metadata node when getParent() returns null.

Object Model

ImGearMetadataTree ClassImGearMetadataTree ClassImGearMetadataNodeList ClassImGearMetadataNode Class

Syntax

public sealed class ImGearMetadataTree
    extends ImGearMetadataNode

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMetadataNode
com.accusoft.imagegear.core.ImGearMetadataTree

See Also

Reference

ImGearMetadataTree Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMetadataTree Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataTree Class

Glossary Item Box

The following tables list the members exposed by ImGearMetadataTree.

Public Constructors

 | Name | Description
public Constructor | ImGearMetadataTree Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getChildren | Gets array of child nodes. ImGearMetadataNodeList class instance or null. List of children nodes as ImGearMetadataNodeList class. ImGearMetadataNodeList
Top

See Also

Reference

ImGearMetadataTree Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMetadataTree Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataTree Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataTree members.

See Also

Reference

ImGearMetadataTree Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMetadataTree Constructor
com.accusoft.imagegear.core Package > ImGearMetadataTree Class : ImGearMetadataTree Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearMetadataTree Constructor() | Initializes a new instance of the ImGearMetadataTree class.
ImGearMetadataTree Constructor(ImGearMetadataFormats,int) | Initializes a new instance of the ImGearMetadataTree class.
ImGearMetadataTree Constructor(ImGearMetadataFormats,int,String) | Initializes a new instance of the ImGearMetadataTree class.

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%%

ImGearMetadataTree Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor()

Glossary Item Box

Initializes a new instance of the ImGearMetadataTree class.

Syntax

public ImGearMetadataTree()

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List


%%PageItemTitle%%

ImGearMetadataTree Constructor(ImGearMetadataFormats,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor(ImGearMetadataFormats,int)
frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Identifies type of metadata node for file format. com.accusoft.imagegear.formats.ImGearMetadataFormats

Glossary Item Box

Initializes a new instance of the ImGearMetadataTree class.

Syntax

public ImGearMetadataTree(
   ImGearMetadataFormats frmt,
   int tg
)

Parameters

frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Identifies type of metadata node for file format. com.accusoft.imagegear.formats.ImGearMetadataFormats

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List


%%PageItemTitle%%

ImGearMetadataTree Constructor(ImGearMetadataFormats,int,String)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMetadataTree Class > ImGearMetadataTree Constructor : ImGearMetadataTree Constructor(ImGearMetadataFormats,int,String)
frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Identifies type of metadata node for file format.
nm
Name of the tag. com.accusoft.imagegear.formats.ImGearMetadataFormats

Glossary Item Box

Initializes a new instance of the ImGearMetadataTree class.

Syntax

public ImGearMetadataTree(
   ImGearMetadataFormats frmt,
   int tg,
   java.lang.String nm
)

Parameters

frmt
Type of file format to which metadata belongs. This allows you to store JPEG metadata under TIFF metadata.
tg
Identifies type of metadata node for file format.
nm
Name of the tag. com.accusoft.imagegear.formats.ImGearMetadataFormats

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members
Overload List


%%PageItemTitle%%

attach Method
com.accusoft.imagegear.core Package > ImGearMetadataTree Class : attach Method
parent

Glossary Item Box

Syntax

public void attach(
   ImGearMetadataNode parent
)

Parameters

parent

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMetadataTree Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMetadataTree Class

Glossary Item Box

For a list of all members of this type, see ImGearMetadataTree members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getChildren | Gets array of child nodes. ImGearMetadataNodeList class instance or null. List of children nodes as ImGearMetadataNodeList class. ImGearMetadataNodeList
Top

See Also

Reference

ImGearMetadataTree Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMetadataTree Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearMetadataTree clone()

Return Value

ImGearMetadataTree class that is a copy of the current instance.

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%%

detach Method
com.accusoft.imagegear.core Package > ImGearMetadataTree Class : detach Method

Glossary Item Box

Syntax

public void detach()

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%%

getChildren Method
com.accusoft.imagegear.core Package > ImGearMetadataTree Class : getChildren Method

Glossary Item Box

Gets array of child nodes.

ImGearMetadataNodeList class instance or null.

List of children nodes as ImGearMetadataNodeList class.

ImGearMetadataNodeList

Syntax

public ImGearMetadataNodeList getChildren()

See Also

Reference

ImGearMetadataTree Class
ImGearMetadataTree Members


%%PageItemTitle%%

ImGearMultichannelLUT Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearMultichannelLUT Class

Glossary Item Box

Represents a multichannel lookup table (LUT).

An ImGearMultichannelLUT object contains an array of single-channel ImGearLUT class objects.

Object Model

ImGearMultichannelLUT ClassImGearMultichannelLUT ClassImGearLUT Class

Syntax

public class ImGearMultichannelLUT
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMultichannelLUT
com.accusoft.imagegear.core.ImGearRGBLUT

See Also

Reference

ImGearMultichannelLUT Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMultichannelLUT Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearMultichannelLUT Class

Glossary Item Box

The following tables list the members exposed by ImGearMultichannelLUT.

Public Constructors

 | Name | Description
public Constructor | ImGearMultichannelLUT Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
protected Field | luts | Array of single channel LUTs.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | getChannelCount | Gets number of single channel LUTs in the multi-channel LUT. Any integer number.
public Method | getItem | Provides access to single channel LUTs within the multichannel LUT.
public Method | setItem | Provides access to single channel LUTs within the multichannel LUT.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearMultichannelLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMultichannelLUT Constructor
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : ImGearMultichannelLUT Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearMultichannelLUT Constructor(int) | Initializes a new instance of the ImGearMultichannelLUT class with the specified number of single-channel LUTs. This constructor allocates the array of channel LUTs and initializes its elements with nulls.
ImGearMultichannelLUT Constructor(int,int,int) | Initializes a new instance of the ImGearMultichannelLUT class and allocates its elements with default single-channel LUTs.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

ImGearMultichannelLUT Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class > ImGearMultichannelLUT Constructor : ImGearMultichannelLUT Constructor(int)
channelCount
Specifies number of channels in the multichannel LUT.

Glossary Item Box

Initializes a new instance of the ImGearMultichannelLUT class with the specified number of single-channel LUTs.

This constructor allocates the array of channel LUTs and initializes its elements with nulls.

Syntax

public ImGearMultichannelLUT(
   int channelCount
)

Parameters

channelCount
Specifies number of channels in the multichannel LUT.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members
Overload List


%%PageItemTitle%%

ImGearMultichannelLUT Constructor(int,int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class > ImGearMultichannelLUT Constructor : ImGearMultichannelLUT Constructor(int,int,int)
channelCount
Specifies number of channels in the multichannel LUT.
inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.

Glossary Item Box

Initializes a new instance of the ImGearMultichannelLUT class and allocates its elements with default single-channel LUTs.

Syntax

public ImGearMultichannelLUT(
   int channelCount,
   int inputDepth,
   int outputDepth
)

Parameters

channelCount
Specifies number of channels in the multichannel LUT.
inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMultichannelLUT Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMultichannelLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearMultichannelLUT members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
public Method | getChannelCount | Gets number of single channel LUTs in the multi-channel LUT. Any integer number.
public Method | getItem | Provides access to single channel LUTs within the multichannel LUT.
public Method | setItem | Provides access to single channel LUTs within the multichannel LUT.
Top

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearMultichannelLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public ImGearMultichannelLUT clone()

Return Value

The new instance of ImGearMultichannelLUT class object.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

getChannelCount Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : getChannelCount Method

Glossary Item Box

Gets number of single channel LUTs in the multi-channel LUT.

Any integer number.

Syntax

public int getChannelCount()

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : getItem Method
index
Index of the LUT to get.

Glossary Item Box

Provides access to single channel LUTs within the multichannel LUT.

Syntax

public ImGearLUT getItem(
   int index
)

Parameters

index
Index of the LUT to get.

Return Value

ImGearLUT class object.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : setItem Method
index
Index of the LUT to set.
value
ImGearLUT instance to set.

Glossary Item Box

Provides access to single channel LUTs within the multichannel LUT.

Syntax

public void setItem(
   int index,
   ImGearLUT value
)

Parameters

index
Index of the LUT to set.
value
ImGearLUT instance to set.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMultichannelLUT Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearMultichannelLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearMultichannelLUT members.

Protected Fields

 | Name | Description
protected Field | luts | Array of single channel LUTs.
Top

See Also

Reference

ImGearMultichannelLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

luts Field
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : luts Field

Glossary Item Box

Array of single channel LUTs.

Syntax

protected ImGearLUT[] luts

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearMultichannelLUT Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearMultichannelLUT Class
ImGearMultichannelLUT Members


%%PageItemTitle%%

ImGearNativePath Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearNativePath Class

Glossary Item Box

This class obtains a path and manages the loading of native libraries associated with ImageGear Java on Windows systems.

At the first use of ImGearLicense it automatically looks for a path containing ImageGear Java's igjcommonnative2 native library. It does this by first finding the operating system architecture and then looking for either the environment variable, IMAGE_GEAR_64BIT_PATH, for 64 bits, or IMAGE_GEAR_32BIT_PATH, for 32 bits. These are expected to contain paths to the appropriate folder of native libraries.

If the variable does not exist, it looks in the components of the java.library.path System property. You can set the path to the native libraries to appear in this property in two ways:

  1. by adding the path to the operating system's path environment variable
  2. by invoking the Java Virtual Machine with the argument -D java.library.path=<path to native binaries>

Setting the operating system's path in the first way will prevent you from using the 32 and 64 bit SDKs simultaneously, since it will always find the version that is first.

The last place it looks is in a bin peer folder of the one the SDK jars were loaded from.

You can specify the native library location programmatically by calling the method, setPath before calling any licensing code, like ImGearLicense.setSolutionName, or after, if the search above does not find a path.

Object Model

ImGearNativePath Class

Syntax

public class ImGearNativePath
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearNativePath

See Also

Reference

ImGearNativePath Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearNativePath Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearNativePath Class

Glossary Item Box

The following tables list the members exposed by ImGearNativePath.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | isSet | Tests whether the path to native binaries has been successfully set.
static (Shared in Visual Basic) | setPath | sets native library search path if it could not be set at start-up
Top

See Also

Reference

ImGearNativePath Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearNativePath Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearNativePath Class

Glossary Item Box

For a list of all members of this type, see ImGearNativePath members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | isSet | Tests whether the path to native binaries has been successfully set.
static (Shared in Visual Basic) | setPath | sets native library search path if it could not be set at start-up
Top

See Also

Reference

ImGearNativePath Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

isSet Method
com.accusoft.imagegear.core Package > ImGearNativePath Class : isSet Method

Glossary Item Box

Tests whether the path to native binaries has been successfully set.

Syntax

public static boolean isSet()

Return Value

result of test if native path has been set successfully

See Also

Reference

ImGearNativePath Class
ImGearNativePath Members


%%PageItemTitle%%

setPath Method
com.accusoft.imagegear.core Package > ImGearNativePath Class : setPath Method
path
- the fully qualified path containing the native libraries

Glossary Item Box

sets native library search path if it could not be set at start-up

Syntax

public static boolean setPath(
   java.lang.String path
)

Parameters

path
- the fully qualified path containing the native libraries

Return Value

whether successful

See Also

Reference

ImGearNativePath Class
ImGearNativePath Members


%%PageItemTitle%%

ImGearOrientation Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearOrientation Class

Glossary Item Box

Specifies orientation of page or display.

This structure defines the orientation of an image. It works on the image representation and thus allows you to flip and rotate an image without modification of its data (pixels).

It is useful to manipulate the orientation of scanned black-and-white images. Since ImageGear for Java stores such images using lossless compression, this may avoid significant expansion of memory usage while operating on these images.

ImGearARTMark file formats support orientation natively and this allows you to save flipped or rotated images without loss of pixel data or file size enlargement when using compression.

Object Model

ImGearOrientation ClassImGearOrientation ClassImGearOrientationModes Enumeration

Syntax

public sealed class ImGearOrientation
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements IImGearOrientation

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearOrientation

See Also

Reference

ImGearOrientation Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearOrientation Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearOrientation Class

Glossary Item Box

The following tables list the members exposed by ImGearOrientation.

Public Constructors

 | Name | Description
public Constructor | ImGearOrientation Constructor | Initializes a new instance of the ImGearOrientation struct.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | combine | Overloaded. Returns orientation that is super-imposition of two values.
public Method | flip | Changes orientation to flip image.
public Method | getValue | Gets orientation identifier. Represents orientation as numeric value. ImGearOrientationModes
public Method | rotate | Changes orientation to rotate image.
public Method | setToDefault | Resets orientation to default (top-left) state.
public Method | setValue | Sets orientation identifier. Any of ImGearOrientationModes enumeration values. Represents orientation as numeric value. ImGearOrientationModes
Top

See Also

Reference

ImGearOrientation Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearOrientation Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearOrientation Class

Glossary Item Box

For a list of all members of this type, see ImGearOrientation members.

See Also

Reference

ImGearOrientation Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearOrientation Constructor
com.accusoft.imagegear.core Package > ImGearOrientation Class : ImGearOrientation Constructor
newValue
ImGearOrientationModes enum value.

Glossary Item Box

Initializes a new instance of the ImGearOrientation struct.

Syntax

public ImGearOrientation(
   ImGearOrientationModes newValue
)

Parameters

newValue
ImGearOrientationModes enum value.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearOrientation Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearOrientation Class

Glossary Item Box

For a list of all members of this type, see ImGearOrientation members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | combine | Overloaded. Returns orientation that is super-imposition of two values.
public Method | flip | Changes orientation to flip image.
public Method | getValue | Gets orientation identifier. Represents orientation as numeric value. ImGearOrientationModes
public Method | rotate | Changes orientation to rotate image.
public Method | setToDefault | Resets orientation to default (top-left) state.
public Method | setValue | Sets orientation identifier. Any of ImGearOrientationModes enumeration values. Represents orientation as numeric value. ImGearOrientationModes
Top

See Also

Reference

ImGearOrientation Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

combine Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : combine Method

Glossary Item Box

Returns orientation that is super-imposition of two values.

Overload List

Overload | Description
combine(IImGearOrientation,IImGearOrientation) | Returns orientation that is super-imposition of two values.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

combine(IImGearOrientation,IImGearOrientation) Method
com.accusoft.imagegear.core Package > ImGearOrientation Class > combine Method : combine(IImGearOrientation,IImGearOrientation) Method
orientation1
First orientation value to be combined.
orientation2
Second orientation value to be combined.

Glossary Item Box

Returns orientation that is super-imposition of two values.

Syntax

public static ImGearOrientation combine(
   IImGearOrientation orientation1,
   IImGearOrientation orientation2
)

Parameters

orientation1
First orientation value to be combined.
orientation2
Second orientation value to be combined.

Return Value

New ImGearOrientation structure value.

Returns super-imposition of two orientations. Returned value equals to sequential application of two given orientations onto one source.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members
Overload List


%%PageItemTitle%%

flip Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : flip Method
flipMode
Specifies how to flip orientation. ImGearFlipModes

Glossary Item Box

Changes orientation to flip image.

Syntax

public void flip(
   ImGearFlipModes flipMode
)

Parameters

flipMode
Specifies how to flip orientation. ImGearFlipModes

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : getValue Method

Glossary Item Box

Gets orientation identifier.

Represents orientation as numeric value.

ImGearOrientationModes

Syntax

public ImGearOrientationModes getValue()

Return Value

Any of ImGearOrientationModes enumeration values.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

rotate Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : rotate Method
rotationValue
Specifies how to rotate orientation. ImGearRotationValues

Glossary Item Box

Changes orientation to rotate image.

Syntax

public void rotate(
   ImGearRotationValues rotationValue
)

Parameters

rotationValue
Specifies how to rotate orientation. ImGearRotationValues

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

setToDefault Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : setToDefault Method

Glossary Item Box

Resets orientation to default (top-left) state.

Syntax

public void setToDefault()

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : setValue Method
value
Any of ImGearOrientationModes enumeration values.

Glossary Item Box

Sets orientation identifier.

Any of ImGearOrientationModes enumeration values.

Represents orientation as numeric value.

ImGearOrientationModes

Syntax

public void setValue(
   ImGearOrientationModes value
)

Parameters

value
Any of ImGearOrientationModes enumeration values.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearOrientation Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearOrientation Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearOrientation Class
ImGearOrientation Members


%%PageItemTitle%%

ImGearPage Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearPage Class

Glossary Item Box

Represents single-page image. In addition to image pixels, contains other attributes like ROI and metadata.

Represents the image and consists of three main parts:

  • Image data (pixels)
  • Metadata (non-image data)
  • Region of interest

The page can be either stand-alone (not referenced from any ImGearDocument classinstance) or attached to a document.

Region of interest ( ImGearROI class) represents free-shape image area (rectangular, non-rectangular or entire space) and specifies a meaningful part of an image. For example, it may be set up for some image processing functions to define the area to which the filter should be applied.

Metadata is non-image data. It is available for most image file formats. In some formats, such as TIFF or PNG, it can be very complex. It can include data of various types and can use a complex structure. ImageGear for Java offers a set of classes designed specifically to manipulate this data consisting of ImGearMetadataNode class, ImGearMetadataNodeList class, ImGearMetadataTree class and their descendants. The metadata for each instance of com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata may be accessed through its getMetadata method.

The Image data (or simply, image) is available through the getDIB method. Color Space, channels, width and height are among the major attributes that define the image structure.

Object Model

ImGearPage ClassImGearPage ClassImGearDIB ClassImGearDocument ClassImGearMetadataHead Class

Syntax

public abstract class ImGearPage
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearPage
com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearPage Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearPage Class

Glossary Item Box

The following tables list the members exposed by ImGearPage.

Public Fields

 | Name | Description
public Field | orientation | Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees. Non-null reference to an instance of ImGearOrientation structure. This field defines the orientation of an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata instance. It works on the image representation and thus allows the manipulation of page orientation without modifying the pixel data. ImGearOrientation
public Field | transparency | Specifies image transparency attributes like transparent color for display. ImGearTransparency class object. ImGearTransparency
Top

Public Methods

 | Name | Description
public Method | clone | Creates new object that is exact copy of current instance.
public Method | getDIB | Gets a reference to the ImGearDIB class object. This object contains the page's pixel data. Non-null reference to an instance of ImGearDIB class. Provides access to image properties and image pixel data. The getDIB method always returns a non-null reference. However, an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata object can also be used without allocating its DIB's pixel store. The method ImGearDIB.isEmpty is available to detect whether the pixel store has been allocated. ImGearDIB
public Method | getDocument | Gets the document to which the page belongs, or null if the page is stand-alone. ImGearDocument class instance or null, if page is stand-alone.
public Method | getMetadata | Gets the head, ImGearMetadataHead, of the page's metadata tree. Non-null reference to ImGearMetadataHead class object.
Top

See Also

Reference

ImGearPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPage Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearPage Class

Glossary Item Box

For a list of all members of this type, see ImGearPage members.

Public Methods

 | Name | Description
public Method | clone | Creates new object that is exact copy of current instance.
public Method | getDIB | Gets a reference to the ImGearDIB class object. This object contains the page's pixel data. Non-null reference to an instance of ImGearDIB class. Provides access to image properties and image pixel data. The getDIB method always returns a non-null reference. However, an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata object can also be used without allocating its DIB's pixel store. The method ImGearDIB.isEmpty is available to detect whether the pixel store has been allocated. ImGearDIB
public Method | getDocument | Gets the document to which the page belongs, or null if the page is stand-alone. ImGearDocument class instance or null, if page is stand-alone.
public Method | getMetadata | Gets the head, ImGearMetadataHead, of the page's metadata tree. Non-null reference to ImGearMetadataHead class object.
Top

See Also

Reference

ImGearPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearPage Class : clone Method

Glossary Item Box

Creates new object that is exact copy of current instance.

Syntax

public abstract ImGearPage clone()

Return Value

com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class object that is a copy of the current instance.

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%%

getDIB Method
com.accusoft.imagegear.core Package > ImGearPage Class : getDIB Method

Glossary Item Box

Gets a reference to the ImGearDIB class object. This object contains the page's pixel data.

Non-null reference to an instance of ImGearDIB class.

Provides access to image properties and image pixel data.

The getDIB method always returns a non-null reference. However, an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata object can also be used without allocating its DIB's pixel store. The method ImGearDIB.isEmpty is available to detect whether the pixel store has been allocated.

ImGearDIB

Syntax

public ImGearDIB getDIB()

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%%

getDocument Method
com.accusoft.imagegear.core Package > ImGearPage Class : getDocument Method

Glossary Item Box

Gets the document to which the page belongs, or null if the page is stand-alone.

ImGearDocument class instance or null, if page is stand-alone.

Syntax

public ImGearDocument getDocument()

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%%

getMetadata Method
com.accusoft.imagegear.core Package > ImGearPage Class : getMetadata Method

Glossary Item Box

Gets the head, ImGearMetadataHead, of the page's metadata tree.

Non-null reference to ImGearMetadataHead class object.

Syntax

public ImGearMetadataHead getMetadata()

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPage Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearPage Class

Glossary Item Box

For a list of all members of this type, see ImGearPage members.

Public Fields

 | Name | Description
public Field | orientation | Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees. Non-null reference to an instance of ImGearOrientation structure. This field defines the orientation of an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata instance. It works on the image representation and thus allows the manipulation of page orientation without modifying the pixel data. ImGearOrientation
public Field | transparency | Specifies image transparency attributes like transparent color for display. ImGearTransparency class object. ImGearTransparency
Top

See Also

Reference

ImGearPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

orientation Field
com.accusoft.imagegear.core Package > ImGearPage Class : orientation Field

Glossary Item Box

Specifies the image orientation attribute which allows for viewing the image flipped and/or rotated by a factor of 90 degrees.

Non-null reference to an instance of ImGearOrientation structure.

This field defines the orientation of an com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata instance. It works on the image representation and thus allows the manipulation of page orientation without modifying the pixel data.

ImGearOrientation

Syntax

public IImGearOrientation orientation

Return Value

Non-null reference to an instance of ImGearOrientation structure.

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%%

transparency Field
com.accusoft.imagegear.core Package > ImGearPage Class : transparency Field

Glossary Item Box

Specifies image transparency attributes like transparent color for display.

ImGearTransparency class object. ImGearTransparency

Syntax

public ImGearTransparency transparency

Return Value

ImGearTransparency class object.

See Also

Reference

ImGearPage Class
ImGearPage Members


%%PageItemTitle%%

ImGearPixel Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearPixel Class

Glossary Item Box

Encapsulates all attributes and operations for an image pixel.

This class encapsulates an image pixel and represents the color store for each channel value.

For simplicity, com.accusoft.imagegear.processing.ImGearPixelateFillMethod does not contain any information about channels depths and color space. Therefore pixels that are identical in structure ( ImGearPixel constructor parameters) may belong to images with significantly different channels, structure and color space.

Object Model

ImGearPixel ClassImGearPixel Class

Syntax

public sealed class ImGearPixel
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

ImGearPixel Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPixel Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearPixel Class

Glossary Item Box

The following tables list the members exposed by ImGearPixel.

Public Constructors

 | Name | Description
public Constructor | ImGearPixel Constructor | Initializes a new instance of the com.accusoft.imagegear.processing.ImGearPixelateFillMethod class.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBitsPerChannel | Gets the number of bits per color channel. Any integer value.
public Method | getChannelCount | Gets quantity of channels in pixel. Non-zero value.
public Method | getItem | Channels indexing method.
public Method | setItem | Channels indexing method.
Top

See Also

Reference

ImGearPixel Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearPixel Constructor
com.accusoft.imagegear.core Package > ImGearPixel Class : ImGearPixel Constructor
channelCount
Quantity of channels in image.
bitsPerChannel
Actual size of store to contain color of each image channel.

Glossary Item Box

Initializes a new instance of the com.accusoft.imagegear.processing.ImGearPixelateFillMethod class.

Syntax

public ImGearPixel(
   int channelCount,
   int bitsPerChannel
)

Parameters

channelCount
Quantity of channels in image.
bitsPerChannel
Actual size of store to contain color of each image channel.

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPixel Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearPixel Class

Glossary Item Box

For a list of all members of this type, see ImGearPixel members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBitsPerChannel | Gets the number of bits per color channel. Any integer value.
public Method | getChannelCount | Gets quantity of channels in pixel. Non-zero value.
public Method | getItem | Channels indexing method.
public Method | setItem | Channels indexing method.
Top

See Also

Reference

ImGearPixel Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearPixel Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearPixel clone()

Return Value

com.accusoft.imagegear.processing.ImGearPixelateFillMethod class object that is a copy of the current instance.

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

getBitsPerChannel Method
com.accusoft.imagegear.core Package > ImGearPixel Class : getBitsPerChannel Method

Glossary Item Box

Gets the number of bits per color channel.

Any integer value.

Syntax

public int getBitsPerChannel()

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

getChannelCount Method
com.accusoft.imagegear.core Package > ImGearPixel Class : getChannelCount Method

Glossary Item Box

Gets quantity of channels in pixel.

Non-zero value.

Syntax

public int getChannelCount()

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearPixel Class : getItem Method
index
Channel index. Value from 0 to 2^(ChannelDepth) - 1 range.

Accesses the color value using channel index.

Glossary Item Box

Channels indexing method.

Syntax

public int getItem(
   int index
)

Parameters

index
Channel index. Value from 0 to 2^(ChannelDepth) - 1 range.

Accesses the color value using channel index.

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearPixel Class : setItem Method
index
Channel index.
value
Color value from 0 to 2^(ChannelDepth) - 1 range.

Sets the color value using channel index.

Glossary Item Box

Channels indexing method.

Syntax

public void setItem(
   int index,
   int value
)

Parameters

index
Channel index.
value
Color value from 0 to 2^(ChannelDepth) - 1 range.

Sets the color value using channel index.

See Also

Reference

ImGearPixel Class
ImGearPixel Members


%%PageItemTitle%%

ImGearPixelArray Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearPixelArray Class

Glossary Item Box

One dimensional array of image pixels.

Object Model

ImGearPixelArray Class

Syntax

public sealed class ImGearPixelArray
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearPixelArray

See Also

Reference

ImGearPixelArray Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPixelArray Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearPixelArray Class

Glossary Item Box

The following tables list the members exposed by ImGearPixelArray.

Public Constructors

 | Name | Description
public Constructor | ImGearPixelArray Constructor | Initializes a new instance of the ImGearPixelArray class.
Top

Public Methods

 | Name | Description
public Method | getChannelCount | Gets quantity of channels in each pixel contained in the array. Non-zero quantity of channels.
public Method | getItem | Indexed method for direct access to contained pixels.
public Method | getPixelCount | Gets quantity of pixels in array. Array length. Obtains the number of ImGearPixel elements in the array. ImGearPixel
public Method | setItem | Indexed method for direct access to contained pixels.
Top

See Also

Reference

ImGearPixelArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearPixelArray Constructor
com.accusoft.imagegear.core Package > ImGearPixelArray Class : ImGearPixelArray Constructor
pixelCount
Quantity of pixels to be stored in array.
channelCount
Quantity of channels in an image whose pixels are stored in array.
bitsPerChannel
Actual size of store to contain color value for each image channel.

Initializes the pixel store using the pixel's defining attributes and the length of the array.

Glossary Item Box

Initializes a new instance of the ImGearPixelArray class.

Syntax

public ImGearPixelArray(
   int pixelCount,
   int channelCount,
   int bitsPerChannel
)

Parameters

pixelCount
Quantity of pixels to be stored in array.
channelCount
Quantity of channels in an image whose pixels are stored in array.
bitsPerChannel
Actual size of store to contain color value for each image channel.

Initializes the pixel store using the pixel's defining attributes and the length of the array.

See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPixelArray Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearPixelArray Class

Glossary Item Box

For a list of all members of this type, see ImGearPixelArray members.

Public Methods

 | Name | Description
public Method | getChannelCount | Gets quantity of channels in each pixel contained in the array. Non-zero quantity of channels.
public Method | getItem | Indexed method for direct access to contained pixels.
public Method | getPixelCount | Gets quantity of pixels in array. Array length. Obtains the number of ImGearPixel elements in the array. ImGearPixel
public Method | setItem | Indexed method for direct access to contained pixels.
Top

See Also

Reference

ImGearPixelArray Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getChannelCount Method
com.accusoft.imagegear.core Package > ImGearPixelArray Class : getChannelCount Method

Glossary Item Box

Gets quantity of channels in each pixel contained in the array.

Non-zero quantity of channels.

Syntax

public int getChannelCount()

See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.core Package > ImGearPixelArray Class : getItem Method
pixel
Index of pixel in the array.
channel
Channel number in particular pixel. Color value of requested channel in requested pixel.

Provides access to color values of stored pixels and their channels.

Glossary Item Box

Indexed method for direct access to contained pixels.

Syntax

public int getItem(
   int pixel,
   int channel
)

Parameters

pixel
Index of pixel in the array.
channel
Channel number in particular pixel. Color value of requested channel in requested pixel.

Provides access to color values of stored pixels and their channels.

See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%%

getPixelCount Method
com.accusoft.imagegear.core Package > ImGearPixelArray Class : getPixelCount Method

Glossary Item Box

Gets quantity of pixels in array.

Array length.

Obtains the number of ImGearPixel elements in the array.

ImGearPixel

Syntax

public int getPixelCount()

See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.core Package > ImGearPixelArray Class : setItem Method
pixel
Index of pixel in the array.
channel
Channel number in particular pixel.
value
Color value of requested channel in requested pixel.

Provides access to color values of stored pixels and their channels.

Glossary Item Box

Indexed method for direct access to contained pixels.

Syntax

public void setItem(
   int pixel,
   int channel,
   int value
)

Parameters

pixel
Index of pixel in the array.
channel
Channel number in particular pixel.
value
Color value of requested channel in requested pixel.

Provides access to color values of stored pixels and their channels.

See Also

Reference

ImGearPixelArray Class
ImGearPixelArray Members


%%PageItemTitle%%

ImGearRasterPage Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearRasterPage Class

Glossary Item Box

The class represents a raster image.

ImGearPage

Object Model

ImGearRasterPage ClassImGearRasterPage ClassImGearRasterPage ClassImGearRasterPage ClassImGearRasterPage ClassImGearColorProfile ClassImGearDIB ClassIImGearDICOMDisplaySettings InterfaceImGearDocument ClassImGearMetadataHead ClassImGearROI Class

Syntax

public class ImGearRasterPage
    extends ImGearPage

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearPage
com.accusoft.imagegear.core.ImGearRasterPage
com.accusoft.imagegear.processing.layers.ImGearLayeredPage

See Also

Reference

ImGearRasterPage Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRasterPage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearRasterPage Class

Glossary Item Box

The following tables list the members exposed by ImGearRasterPage.

Public Constructors

 | Name | Description
public Constructor | ImGearRasterPage Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method | clone | Creates new object that is an exact copy of the current instance.
static (Shared in Visual Basic) | createFromDIB | Creates new page with same image data as given DIB.
static (Shared in Visual Basic) | createFromImage | Creates a new ImGearRasterPage using the image data from incoming Image.
public Method | duplicateRect | Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.
public Method getColorProfile Returns a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

public Method getDICOMDisplaySettings Returns DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes getDICOMDisplaySettings() method of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If IImGearDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearRasterPage method returns null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings value, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

setDICOMDisplaySettings/setDICOMDisplaySettings methods can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this method is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings For more information about multiple JAR components, see 'Using Multiple Packages'.

public Method getROI Returns region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

public Method setColorProfile Sets a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

public Method setDICOMDisplaySettings Sets DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings property of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If com.accusoft.imagegear.display.ImGearPageDisplay.getDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearPageDisplay.DICOMDisplaySettings property is null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

DICOMDisplaySettings property can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this property is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings

public Method setROI Sets region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

Top

See Also

Reference

ImGearRasterPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRasterPage Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRasterPage Class

Glossary Item Box

For a list of all members of this type, see ImGearRasterPage members.

See Also

Reference

ImGearRasterPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRasterPage Constructor
com.accusoft.imagegear.core Package > ImGearRasterPage Class : ImGearRasterPage Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRasterPage Constructor() | Default constructor.
ImGearRasterPage Constructor(int,int,ImGearColorSpace,int[],boolean) | Initializes a new instance of the ImGearRasterPage class.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

ImGearRasterPage Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRasterPage Class > ImGearRasterPage Constructor : ImGearRasterPage Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearRasterPage()

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
Overload List


%%PageItemTitle%%

ImGearRasterPage Constructor(int,int,ImGearColorSpace,int[],boolean)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRasterPage Class > ImGearRasterPage Constructor : ImGearRasterPage Constructor(int,int,ImGearColorSpace,int[],boolean)
width
Width of page in pixels.
height
Height of page in pixels.
colorSpace
Pixel's color space.
channelDepths
Channels depths of new page.
allocatePixels
Indicates whether the pixel store should be allocated.

The ImGearPage is initialized with a set of image defining attributes. Optionally a store for pixels may also be allocated.

An exception may be thrown while constructing the page instance if incompatible image attributes are passed (e.g., ChannelDepths has length smaller than colors channels quantity in specified color space).

This constructor does not allocate a palette. After creating an indexed image the user should allocate a palette, initialize its entries, and attach it to the ImGearRasterPage's DIB. The Palette's length should be equal to 2^depth, where depth is bit depth of the indexed image.

Glossary Item Box

Initializes a new instance of the ImGearRasterPage class.

Syntax

public ImGearRasterPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   boolean allocatePixels
)

Parameters

width
Width of page in pixels.
height
Height of page in pixels.
colorSpace
Pixel's color space.
channelDepths
Channels depths of new page.
allocatePixels
Indicates whether the pixel store should be allocated.

The ImGearPage is initialized with a set of image defining attributes. Optionally a store for pixels may also be allocated.

An exception may be thrown while constructing the page instance if incompatible image attributes are passed (e.g., ChannelDepths has length smaller than colors channels quantity in specified color space).

This constructor does not allocate a palette. After creating an indexed image the user should allocate a palette, initialize its entries, and attach it to the ImGearRasterPage's DIB. The Palette's length should be equal to 2^depth, where depth is bit depth of the indexed image.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members
Overload List


%%PageItemTitle%%

BackgroundAllowed Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : BackgroundAllowed Method

Glossary Item Box

Syntax

public boolean BackgroundAllowed()

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRasterPage Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRasterPage Class

Glossary Item Box

For a list of all members of this type, see ImGearRasterPage members.

Public Methods

Name | Description
public Method | clone | Creates new object that is an exact copy of the current instance.
static (Shared in Visual Basic) | createFromDIB | Creates new page with same image data as given DIB.
static (Shared in Visual Basic) | createFromImage | Creates a new ImGearRasterPage using the image data from incoming Image.
public Method | duplicateRect | Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.
public Method getColorProfile Returns a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

public Method getDICOMDisplaySettings Returns DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes getDICOMDisplaySettings() method of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If IImGearDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearRasterPage method returns null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings value, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

setDICOMDisplaySettings/setDICOMDisplaySettings methods can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this method is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings For more information about multiple JAR components, see 'Using Multiple Packages'.

public Method getROI Returns region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

public Method setColorProfile Sets a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

public Method setDICOMDisplaySettings Sets DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings property of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If com.accusoft.imagegear.display.ImGearPageDisplay.getDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearPageDisplay.DICOMDisplaySettings property is null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

DICOMDisplaySettings property can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this property is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings

public Method setROI Sets region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

Top

See Also

Reference

ImGearRasterPage Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : clone Method

Glossary Item Box

Creates new object that is an exact copy of the current instance.

Syntax

public ImGearRasterPage clone()

Return Value

ImGearRasterPage class object that is a copy of the current instance.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

createFromDIB Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : createFromDIB Method
dib
Non-null reference to ImGearDIB instance.

Glossary Item Box

Creates new page with same image data as given DIB.

Syntax

public static ImGearRasterPage createFromDIB(
   ImGearDIB dib
)

Parameters

dib
Non-null reference to ImGearDIB instance.

Return Value

A new instance of ImGearRasterPage class. ImGearDIB

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

createFromImage Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : createFromImage Method
image
Non-null reference to a Image.

Glossary Item Box

Creates a new ImGearRasterPage using the image data from incoming Image.

Syntax

public static ImGearRasterPage createFromImage(
   java.awt.image.RenderedImage image
)

Parameters

image
Non-null reference to a Image.

Return Value

A new instance of ImGearRasterPage class.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

duplicateRect Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : duplicateRect Method
rect
Non null instance of com.accusoft.imagegear.core.shapes.ImGearRectangle.

Glossary Item Box

Returns a new raster page object representing a part of the ImGearRasterPage object limited by the specified rectangle.

Syntax

public ImGearRasterPage duplicateRect(
   ImGearRectangle rect
)

Parameters

rect
Non null instance of com.accusoft.imagegear.core.shapes.ImGearRectangle.

Return Value

A new instance of ImGearRasterPage class.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

getColorProfile Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : getColorProfile Method

Glossary Item Box

Returns a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

Syntax

public ImGearColorProfile getColorProfile()

Return Value

ImGearColorProfile class object.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

getDICOMDisplaySettings Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : getDICOMDisplaySettings Method

Glossary Item Box

Returns DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes getDICOMDisplaySettings() method of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If IImGearDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearRasterPage method returns null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings value, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

setDICOMDisplaySettings/setDICOMDisplaySettings methods can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this method is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings For more information about multiple JAR components, see 'Using Multiple Packages'.

Syntax

public IImGearDICOMDisplaySettings getDICOMDisplaySettings()

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

getROI Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : getROI Method

Glossary Item Box

Returns region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

Syntax

public ImGearROI getROI()

Return Value

ImGearROI class instance or null.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

OffscreenAllowed Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : OffscreenAllowed Method

Glossary Item Box

Syntax

public boolean OffscreenAllowed()

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

setColorProfile Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : setColorProfile Method
value
ImGearColorProfile class object.

Glossary Item Box

Sets a local color profile associated with the image.

If a color profile is set here, and profiles are enabled in ImGearColorProfileManager class, the local color profile will be used for color space conversions (instead of a global color profile). The default value is null.

Syntax

public void setColorProfile(
   ImGearColorProfile value
)

Parameters

value
ImGearColorProfile class object.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

setDICOMDisplaySettings Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : setDICOMDisplaySettings Method
value

Glossary Item Box

Sets DICOM specific display contrast settings.

IImGearDICOMDisplaySettings interface.

The DICOM specification defines several contrast transformations including Modality LUT, VOI LUT... When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings property of ImGearRasterPage class with the settings found in the file. During display, ImageGear checks for the presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows the user to load and display DICOM images with proper contrast, without the need for extra application code.

DICOMDisplaySettings can be attached to an ImGearRasterPage class or to a com.accusoft.imagegear.display.ImGearPageDisplay class. If com.accusoft.imagegear.display.ImGearPageDisplay.getDICOMDisplaySettings property is not null, ImageGear uses it for display. If ImGearPageDisplay.DICOMDisplaySettings property is null, ImageGear checks ImGearRasterPage class for presence of DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings property attached to ImGearPageDisplay class has higher priority than DICOMDisplaySettings property attached to ImGearRasterPage class.

DICOMDisplaySettings property can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images.

This property affects grayscale images with bit depths from 2 to 31.

The type of this property is an interface with only the members necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class.

The default value is null.

IImGearDICOMDisplaySettings

Syntax

public void setDICOMDisplaySettings(
   IImGearDICOMDisplaySettings value
)

Parameters

value

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

setInternalDIB Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : setInternalDIB Method
value

Glossary Item Box

Syntax

public void setInternalDIB(
   ImGearDIB value
)

Parameters

value

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

setROI Method
com.accusoft.imagegear.core Package > ImGearRasterPage Class : setROI Method
value
ImGearROI class instance or null.

Glossary Item Box

Sets region of interest.

The region of interest may have either rectangular or non-rectangular shape. If the ROI is null the region of interest is assumed to be the entire image area.

ImGearROI

Syntax

public void setROI(
   ImGearROI value
)

Parameters

value
ImGearROI class instance or null.

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

Annotations Field
com.accusoft.imagegear.core Package > ImGearRasterPage Class : Annotations Field

Glossary Item Box

Syntax

public java.lang.Object Annotations

See Also

Reference

ImGearRasterPage Class
ImGearRasterPage Members


%%PageItemTitle%%

ImGearRationalInt Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalInt Class

Glossary Item Box

Specifies rational fraction as an indicated division of Numerator/Denominator.

Object Model

ImGearRationalInt ClassImGearRationalInt ClassImGearRationalInt Class

Syntax

public sealed class ImGearRationalInt
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearRationalInt

See Also

Reference

ImGearRationalInt Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRationalInt Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalInt Class

Glossary Item Box

The following tables list the members exposed by ImGearRationalInt.

Public Constructors

 | Name | Description
public Constructor | ImGearRationalInt Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | denominator | Denominator value. Any integer value.
public Field | numerator | Numerator value. Any integer value.
Top

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | fromString | Creates a ImGearRationalInt from the specified string.
public Method toDouble Converts the value of this instance to its equivalent double representation.
toString
public Method toString Converts the value of this instance to its equivalent string representation.
toDouble
Top

See Also

Reference

ImGearRationalInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRationalInt Constructor
com.accusoft.imagegear.core Package > ImGearRationalInt Class : ImGearRationalInt Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRationalInt Constructor(int) | Initializes a new instance of the ImGearRationalInt class.
ImGearRationalInt Constructor(int,int) | Initializes a new instance of the ImGearRationalInt class.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%%

ImGearRationalInt Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRationalInt Class > ImGearRationalInt Constructor : ImGearRationalInt Constructor(int)
numratr
Integer that represents the numerator of a fraction. Must be nonnegative.

Glossary Item Box

Initializes a new instance of the ImGearRationalInt class.

Syntax

public ImGearRationalInt(
   int numratr
)

Parameters

numratr
Integer that represents the numerator of a fraction. Must be nonnegative.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members
Overload List


%%PageItemTitle%%

ImGearRationalInt Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRationalInt Class > ImGearRationalInt Constructor : ImGearRationalInt Constructor(int,int)
numratr
Integer that represents the numerator of a fraction. Must be nonnegative.
denomnatr
Integer that represents the denominator of a fraction. Must be nonnegative.

Glossary Item Box

Initializes a new instance of the ImGearRationalInt class.

Syntax

public ImGearRationalInt(
   int numratr,
   int denomnatr
)

Parameters

numratr
Integer that represents the numerator of a fraction. Must be nonnegative.
denomnatr
Integer that represents the denominator of a fraction. Must be nonnegative.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRationalInt Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalInt Class

Glossary Item Box

For a list of all members of this type, see ImGearRationalInt members.

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | fromString | Creates a ImGearRationalInt from the specified string.
public Method toDouble Converts the value of this instance to its equivalent double representation.
toString
public Method toString Converts the value of this instance to its equivalent string representation.
toDouble
Top

See Also

Reference

ImGearRationalInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearRationalInt Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearRationalInt clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members
java.lang.Cloneable


%%PageItemTitle%%

fromString Method
com.accusoft.imagegear.core Package > ImGearRationalInt Class : fromString Method
value
The string to parse.

Glossary Item Box

Creates a ImGearRationalInt from the specified string.

Syntax

public static ImGearRationalInt fromString(
   java.lang.String value
)

Parameters

value
The string to parse.

Return Value

A new ImGearRationalInt structure.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%%

toDouble Method
com.accusoft.imagegear.core Package > ImGearRationalInt Class : toDouble Method

Glossary Item Box

Converts the value of this instance to its equivalent double representation.
toString

Syntax

public double toDouble()

Return Value

Double value.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.core Package > ImGearRationalInt Class : toString Method

Glossary Item Box

Converts the value of this instance to its equivalent string representation.
toDouble

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRationalInt Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalInt Class

Glossary Item Box

For a list of all members of this type, see ImGearRationalInt members.

Public Fields

 | Name | Description
public Field | denominator | Denominator value. Any integer value.
public Field | numerator | Numerator value. Any integer value.
Top

See Also

Reference

ImGearRationalInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

denominator Field
com.accusoft.imagegear.core Package > ImGearRationalInt Class : denominator Field

Glossary Item Box

Denominator value.

Any integer value.

Syntax

public int denominator

Return Value

Any integer value.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%%

numerator Field
com.accusoft.imagegear.core Package > ImGearRationalInt Class : numerator Field

Glossary Item Box

Numerator value.

Any integer value.

Syntax

public int numerator

Return Value

Any integer value.

See Also

Reference

ImGearRationalInt Class
ImGearRationalInt Members


%%PageItemTitle%%

ImGearRationalUInt Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalUInt Class

Glossary Item Box

Specifies rational fraction as an indicated division of Numerator/Denominator. The 4 most significant bytes of Numerator and Denominator are assumed to be 0.

Object Model

ImGearRationalUInt ClassImGearRationalUInt Class

Syntax

public sealed class ImGearRationalUInt
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearRationalUInt Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRationalUInt Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalUInt Class

Glossary Item Box

The following tables list the members exposed by ImGearRationalUInt.

Public Constructors

 | Name | Description
public Constructor | ImGearRationalUInt Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | denominator | Denominator value. Any unsigned integer value.
public Field | numerator | Numerator value. Any unsigned integer value.
Top

Public Methods

Name | Description
public Method equals Indicates whether some other object is "equal to" this one.

The equals method implements an equivalence relation on non-null object references:

  • It is reflexive: for any non-null reference value x, x.equals(x) should return true.
  • It is symmetric: for any non-null reference values x and y, x.equals(y) should return true if and only if y.equals(x) returns true.
  • It is transitive: for any non-null reference values x, y, and z, if x.equals(y) returns true and y.equals(z) returns true, then x.equals(z) should return true.
  • It is consistent: for any non-null reference values x and y, multiple invocations of x.equals(y) consistently return true or consistently return false, provided no information used in equals comparisons on the objects is modified.
  • For any non-null reference value x, x.equals(null) should return false.

The equals method for class Object implements the most discriminating possible equivalence relation on objects; that is, for any non-null reference values x and y, this method returns true if and only if x and y refer to the same object ( x == y has the value true).

Note that it is generally necessary to override the hashCode method whenever this method is overridden, so as to maintain the general contract for the hashCode method, which states that equal objects must have equal hash codes.

static (Shared in Visual Basic) | fromString | Creates a ImGearRationalUInt from the specified string.
public Method hashCode Returns a hash code value for the object. This method is supported for the benefit of hashtables such as those provided by java.util.Hashtable.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the Object.equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hashtables.

As much as is reasonably practical, the hashCode method defined by class Object does return distinct integers for distinct objects. (This is typically implemented by converting the internal address of the object into an integer, but this implementation technique is not required by the Java programming language.)

public Method | toDouble | Converts the value of this instance to its equivalent double representation.
public Method | toString | Converts the value of this instance to its equivalent string representation.
Top

See Also

Reference

ImGearRationalUInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRationalUInt Constructor
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : ImGearRationalUInt Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRationalUInt Constructor(int) | Initializes a new instance of the ImGearRationalUInt structure.
ImGearRationalUInt Constructor(int,int) | Initializes a new instance of the ImGearRationalUInt structure.
ImGearRationalUInt Constructor(long,long) | Initializes a new instance of the ImGearRationalUInt structure.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%%

ImGearRationalUInt Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRationalUInt Class > ImGearRationalUInt Constructor : ImGearRationalUInt Constructor(int)
numratr
int value that represents the numerator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.

Glossary Item Box

Initializes a new instance of the ImGearRationalUInt structure.

Syntax

public ImGearRationalUInt(
   int numratr
)

Parameters

numratr
int value that represents the numerator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members
Overload List


%%PageItemTitle%%

ImGearRationalUInt Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRationalUInt Class > ImGearRationalUInt Constructor : ImGearRationalUInt Constructor(int,int)
numratr
int value that represents the numerator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.
denomnatr
int value that represents the denominator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.

Glossary Item Box

Initializes a new instance of the ImGearRationalUInt structure.

Syntax

public ImGearRationalUInt(
   int numratr,
   int denomnatr
)

Parameters

numratr
int value that represents the numerator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.
denomnatr
int value that represents the denominator of a fraction. Converted to nonnegative long with 4 most significant bytes 0.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members
Overload List


%%PageItemTitle%%

ImGearRationalUInt Constructor(long,long)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRationalUInt Class > ImGearRationalUInt Constructor : ImGearRationalUInt Constructor(long,long)
numratr
long value that represents the numerator of a fraction. Assume it is nonnegative, with 4 most significant bytes 0.
denomnatr
long value that represents the denominator of a fraction. Assume it is nonnegative, with 4 most significant bytes 0.

Glossary Item Box

Initializes a new instance of the ImGearRationalUInt structure.

Syntax

public ImGearRationalUInt(
   long numratr,
   long denomnatr
)

Parameters

numratr
long value that represents the numerator of a fraction. Assume it is nonnegative, with 4 most significant bytes 0.
denomnatr
long value that represents the denominator of a fraction. Assume it is nonnegative, with 4 most significant bytes 0.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRationalUInt Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalUInt Class

Glossary Item Box

For a list of all members of this type, see ImGearRationalUInt members.

Public Methods

Name | Description
public Method equals Indicates whether some other object is "equal to" this one.

The equals method implements an equivalence relation on non-null object references:

  • It is reflexive: for any non-null reference value x, x.equals(x) should return true.
  • It is symmetric: for any non-null reference values x and y, x.equals(y) should return true if and only if y.equals(x) returns true.
  • It is transitive: for any non-null reference values x, y, and z, if x.equals(y) returns true and y.equals(z) returns true, then x.equals(z) should return true.
  • It is consistent: for any non-null reference values x and y, multiple invocations of x.equals(y) consistently return true or consistently return false, provided no information used in equals comparisons on the objects is modified.
  • For any non-null reference value x, x.equals(null) should return false.

The equals method for class Object implements the most discriminating possible equivalence relation on objects; that is, for any non-null reference values x and y, this method returns true if and only if x and y refer to the same object ( x == y has the value true).

Note that it is generally necessary to override the hashCode method whenever this method is overridden, so as to maintain the general contract for the hashCode method, which states that equal objects must have equal hash codes.

static (Shared in Visual Basic) | fromString | Creates a ImGearRationalUInt from the specified string.
public Method hashCode Returns a hash code value for the object. This method is supported for the benefit of hashtables such as those provided by java.util.Hashtable.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the Object.equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hashtables.

As much as is reasonably practical, the hashCode method defined by class Object does return distinct integers for distinct objects. (This is typically implemented by converting the internal address of the object into an integer, but this implementation technique is not required by the Java programming language.)

public Method | toDouble | Converts the value of this instance to its equivalent double representation.
public Method | toString | Converts the value of this instance to its equivalent string representation.
Top

See Also

Reference

ImGearRationalUInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

equals Method
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : equals Method
o
the reference object with which to compare.

Glossary Item Box

Indicates whether some other object is "equal to" this one.

The equals method implements an equivalence relation on non-null object references:

  • It is reflexive: for any non-null reference value x, x.equals(x) should return true.
  • It is symmetric: for any non-null reference values x and y, x.equals(y) should return true if and only if y.equals(x) returns true.
  • It is transitive: for any non-null reference values x, y, and z, if x.equals(y) returns true and y.equals(z) returns true, then x.equals(z) should return true.
  • It is consistent: for any non-null reference values x and y, multiple invocations of x.equals(y) consistently return true or consistently return false, provided no information used in equals comparisons on the objects is modified.
  • For any non-null reference value x, x.equals(null) should return false.

The equals method for class Object implements the most discriminating possible equivalence relation on objects; that is, for any non-null reference values x and y, this method returns true if and only if x and y refer to the same object ( x == y has the value true).

Note that it is generally necessary to override the hashCode method whenever this method is overridden, so as to maintain the general contract for the hashCode method, which states that equal objects must have equal hash codes.

Syntax

public boolean equals(
   java.lang.Object o
)

Parameters

o
the reference object with which to compare.

Return Value

true if this object is the same as the o argument; false otherwise.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members
hashCode Method
java.util.Hashtable


%%PageItemTitle%%

fromString Method
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : fromString Method
value
The string to parse.

Glossary Item Box

Creates a ImGearRationalUInt from the specified string.

Syntax

public static ImGearRationalUInt fromString(
   java.lang.String value
)

Parameters

value
The string to parse.

Return Value

A new ImGearRationalUInt structure.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%%

hashCode Method
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : hashCode Method

Glossary Item Box

Returns a hash code value for the object. This method is supported for the benefit of hashtables such as those provided by java.util.Hashtable.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals(Object) method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the Object.equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hashtables.

As much as is reasonably practical, the hashCode method defined by class Object does return distinct integers for distinct objects. (This is typically implemented by converting the internal address of the object into an integer, but this implementation technique is not required by the Java programming language.)

Syntax

public int hashCode()

Return Value

a hash code value for this object.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members
java.util.Hashtable


%%PageItemTitle%%

toDouble Method
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : toDouble Method

Glossary Item Box

Converts the value of this instance to its equivalent double representation.

Syntax

public double toDouble()

Return Value

Double value. toString

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : toString Method

Glossary Item Box

Converts the value of this instance to its equivalent string representation.

Syntax

public java.lang.String toString()

Return Value

String value. toDouble

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRationalUInt Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRationalUInt Class

Glossary Item Box

For a list of all members of this type, see ImGearRationalUInt members.

Public Fields

 | Name | Description
public Field | denominator | Denominator value. Any unsigned integer value.
public Field | numerator | Numerator value. Any unsigned integer value.
Top

See Also

Reference

ImGearRationalUInt Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

denominator Field
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : denominator Field

Glossary Item Box

Denominator value.

Any unsigned integer value.

Syntax

public long denominator

Return Value

Any unsigned integer value.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%%

numerator Field
com.accusoft.imagegear.core Package > ImGearRationalUInt Class : numerator Field

Glossary Item Box

Numerator value.

Any unsigned integer value.

Syntax

public long numerator

Return Value

Any unsigned integer value.

See Also

Reference

ImGearRationalUInt Class
ImGearRationalUInt Members


%%PageItemTitle%%

ImGearResolution Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearResolution Class

Glossary Item Box

Stores ImageGear resolution data.

Specifies image resolution attributes.

Object Model

ImGearResolution ClassImGearResolution ClassImGearResolutionUnits Enumeration

Syntax

public sealed class ImGearResolution
    extends Object
    implements IImGearResolution

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearResolution

See Also

Reference

ImGearResolution Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearResolution Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearResolution Class

Glossary Item Box

The following tables list the members exposed by ImGearResolution.

Public Constructors

 | Name | Description
public Constructor | ImGearResolution Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method | convertUnits | Converts resolution data into new units.
public Method getUnits Returns resolution units.

ImGearResolutionUnits

public Method getXDenominator Returns the denominator of the X component of the resolution.

public Method getXNumerator Returns the numerator of the X component of the resolution.

public Method getYDenominator Returns the denominator of the Y component of the resolution.

public Method getYNumerator Returns the numerator of the Y component of the resolution.

public Method setUnits Sets resolution units.

ImGearResolutionUnits

public Method setXDenominator Sets the denominator of the X component of the resolution.

public Method setXNumerator Sets the numerator of the X component of the resolution.

public Method setYDenominator Sets the denominator of the Y component of the resolution.

public Method setYNumerator Sets the numerator of the Y component of the resolution.

Top

See Also

Reference

ImGearResolution Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearResolution Constructor
com.accusoft.imagegear.core Package > ImGearResolution Class : ImGearResolution Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearResolution Constructor(ImGearResolutionUnits) | Initializes a new instance of the com.accusoft.imagegear.formats.ImGearResolutionInfoTagIDs structure.
ImGearResolution Constructor(int,int,int,int,ImGearResolutionUnits) | Initializes a new instance of the com.accusoft.imagegear.formats.ImGearResolutionInfoTagIDs structure.
ImGearResolution Constructor() | Default constructor.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

ImGearResolution Constructor(ImGearResolutionUnits)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearResolution Class > ImGearResolution Constructor : ImGearResolution Constructor(ImGearResolutionUnits)
units
Resolution units. ImGearResolutionUnits

Glossary Item Box

Initializes a new instance of the com.accusoft.imagegear.formats.ImGearResolutionInfoTagIDs structure.

Syntax

public ImGearResolution(
   ImGearResolutionUnits units
)

Parameters

units
Resolution units. ImGearResolutionUnits

See Also

Reference

ImGearResolution Class
ImGearResolution Members
Overload List


%%PageItemTitle%%

ImGearResolution Constructor(int,int,int,int,ImGearResolutionUnits)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearResolution Class > ImGearResolution Constructor : ImGearResolution Constructor(int,int,int,int,ImGearResolutionUnits)
numeratorX
Numerator of the X component of the resolution.
denominatorX
Denominator of the X component of the resolution.
numeratorY
Numerator of the Y component of the resolution.
denominatorY
Denominator of the Y component of the resolution.
units
Resolution units. ImGearResolutionUnits

Glossary Item Box

Initializes a new instance of the com.accusoft.imagegear.formats.ImGearResolutionInfoTagIDs structure.

Syntax

public ImGearResolution(
   int numeratorX,
   int denominatorX,
   int numeratorY,
   int denominatorY,
   ImGearResolutionUnits units
)

Parameters

numeratorX
Numerator of the X component of the resolution.
denominatorX
Denominator of the X component of the resolution.
numeratorY
Numerator of the Y component of the resolution.
denominatorY
Denominator of the Y component of the resolution.
units
Resolution units. ImGearResolutionUnits

See Also

Reference

ImGearResolution Class
ImGearResolution Members
Overload List


%%PageItemTitle%%

ImGearResolution Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearResolution Class > ImGearResolution Constructor : ImGearResolution Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearResolution()

See Also

Reference

ImGearResolution Class
ImGearResolution Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearResolution Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearResolution Class

Glossary Item Box

For a list of all members of this type, see ImGearResolution members.

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method | convertUnits | Converts resolution data into new units.
public Method getUnits Returns resolution units.

ImGearResolutionUnits

public Method getXDenominator Returns the denominator of the X component of the resolution.

public Method getXNumerator Returns the numerator of the X component of the resolution.

public Method getYDenominator Returns the denominator of the Y component of the resolution.

public Method getYNumerator Returns the numerator of the Y component of the resolution.

public Method setUnits Sets resolution units.

ImGearResolutionUnits

public Method setXDenominator Sets the denominator of the X component of the resolution.

public Method setXNumerator Sets the numerator of the X component of the resolution.

public Method setYDenominator Sets the denominator of the Y component of the resolution.

public Method setYNumerator Sets the numerator of the Y component of the resolution.

Top

See Also

Reference

ImGearResolution Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearResolution Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearResolution clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearResolution Class
ImGearResolution Members
java.lang.Cloneable


%%PageItemTitle%%

convertUnits Method
com.accusoft.imagegear.core Package > ImGearResolution Class : convertUnits Method
newUnits
New resolution data units. ImGearResolutionUnits

Glossary Item Box

Converts resolution data into new units.

Syntax

public void convertUnits(
   ImGearResolutionUnits newUnits
)

Parameters

newUnits
New resolution data units. ImGearResolutionUnits

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

getUnits Method
com.accusoft.imagegear.core Package > ImGearResolution Class : getUnits Method

Glossary Item Box

Returns resolution units.

ImGearResolutionUnits

Syntax

public ImGearResolutionUnits getUnits()

Return Value

ImGearResolutionUnits enumeration values.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

getXDenominator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : getXDenominator Method

Glossary Item Box

Returns the denominator of the X component of the resolution.

Syntax

public int getXDenominator()

Return Value

Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

getXNumerator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : getXNumerator Method

Glossary Item Box

Returns the numerator of the X component of the resolution.

Syntax

public int getXNumerator()

Return Value

Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

getYDenominator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : getYDenominator Method

Glossary Item Box

Returns the denominator of the Y component of the resolution.

Syntax

public int getYDenominator()

Return Value

Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

getYNumerator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : getYNumerator Method

Glossary Item Box

Returns the numerator of the Y component of the resolution.

Syntax

public int getYNumerator()

Return Value

Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

setUnits Method
com.accusoft.imagegear.core Package > ImGearResolution Class : setUnits Method
value
ImGearResolutionUnits enumeration values.

Glossary Item Box

Sets resolution units.

ImGearResolutionUnits

Syntax

public void setUnits(
   ImGearResolutionUnits value
)

Parameters

value
ImGearResolutionUnits enumeration values.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

setXDenominator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : setXDenominator Method
value
Any integer value.

Glossary Item Box

Sets the denominator of the X component of the resolution.

Syntax

public void setXDenominator(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

setXNumerator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : setXNumerator Method
value
Any integer value.

Glossary Item Box

Sets the numerator of the X component of the resolution.

Syntax

public void setXNumerator(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

setYDenominator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : setYDenominator Method
value
Any integer value.

Glossary Item Box

Sets the denominator of the Y component of the resolution.

Syntax

public void setYDenominator(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

setYNumerator Method
com.accusoft.imagegear.core Package > ImGearResolution Class : setYNumerator Method
value
Any integer value.

Glossary Item Box

Sets the numerator of the Y component of the resolution.

Syntax

public void setYNumerator(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearResolution Class
ImGearResolution Members


%%PageItemTitle%%

ImGearRGBLUT Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBLUT Class

Glossary Item Box

Represents RGB lookup table (LUT).

Object Model

ImGearRGBLUT ClassImGearMultichannelLUT ClassImGearLUT ClassImGearLUT ClassImGearLUT ClassImGearLUT Class

Syntax

public class ImGearRGBLUT
    extends ImGearMultichannelLUT

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearMultichannelLUT
com.accusoft.imagegear.core.ImGearRGBLUT

See Also

Reference

ImGearRGBLUT Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRGBLUT Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBLUT Class

Glossary Item Box

The following tables list the members exposed by ImGearRGBLUT.

Public Constructors

 | Name | Description
public Constructor | ImGearRGBLUT Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBlueLUT | Returns the single-channel LUT for the Blue channel. The default value is null.
public Method | getGreenLUT | Returns the single-channel LUT for the Green channel. The default value is null.
public Method | getRedLUT | Returns the single-channel LUT for the Red channel. The default value is null.
public Method | setBlueLUT | Sets the single-channel LUT for the Blue channel. The default value is null.
public Method | setGreenLUT | Sets the single-channel LUT for the Green channel. The default value is null.
public Method | setRedLUT | Sets the single-channel LUT for the Red channel. The default value is null.
Top

See Also

Reference

ImGearRGBLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRGBLUT Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearRGBLUT members.

See Also

Reference

ImGearRGBLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRGBLUT Constructor
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : ImGearRGBLUT Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRGBLUT Constructor() | Initializes a new instance of the ImGearRGBLUT class.
ImGearRGBLUT Constructor(int,int) | Initializes a new instance of the ImGearRGBLUT class and allocates its single-channel LUTs.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

ImGearRGBLUT Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBLUT Class > ImGearRGBLUT Constructor : ImGearRGBLUT Constructor()

Glossary Item Box

Initializes a new instance of the ImGearRGBLUT class.

Syntax

public ImGearRGBLUT()

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members
Overload List


%%PageItemTitle%%

ImGearRGBLUT Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBLUT Class > ImGearRGBLUT Constructor : ImGearRGBLUT Constructor(int,int)
inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.

Glossary Item Box

Initializes a new instance of the ImGearRGBLUT class and allocates its single-channel LUTs.

Syntax

public ImGearRGBLUT(
   int inputDepth,
   int outputDepth
)

Parameters

inputDepth
Specifies input depth for single-channel LUTs.
outputDepth
Specifies output depth for single-channel LUTs.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRGBLUT Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBLUT Class

Glossary Item Box

For a list of all members of this type, see ImGearRGBLUT members.

Public Methods

 | Name | Description
public Method | getBlueLUT | Returns the single-channel LUT for the Blue channel. The default value is null.
public Method | getGreenLUT | Returns the single-channel LUT for the Green channel. The default value is null.
public Method | getRedLUT | Returns the single-channel LUT for the Red channel. The default value is null.
public Method | setBlueLUT | Sets the single-channel LUT for the Blue channel. The default value is null.
public Method | setGreenLUT | Sets the single-channel LUT for the Green channel. The default value is null.
public Method | setRedLUT | Sets the single-channel LUT for the Red channel. The default value is null.
Top

See Also

Reference

ImGearRGBLUT Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getBlueLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : getBlueLUT Method

Glossary Item Box

Returns the single-channel LUT for the Blue channel.

The default value is null.

Syntax

public ImGearLUT getBlueLUT()

Return Value

ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

getGreenLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : getGreenLUT Method

Glossary Item Box

Returns the single-channel LUT for the Green channel.

The default value is null.

Syntax

public ImGearLUT getGreenLUT()

Return Value

ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

getRedLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : getRedLUT Method

Glossary Item Box

Returns the single-channel LUT for the Red channel.

The default value is null.

Syntax

public ImGearLUT getRedLUT()

Return Value

ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

setBlueLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : setBlueLUT Method
value
ImGearLUT class object.

Glossary Item Box

Sets the single-channel LUT for the Blue channel.

The default value is null.

Syntax

public void setBlueLUT(
   ImGearLUT value
)

Parameters

value
ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

setGreenLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : setGreenLUT Method
value
ImGearLUT class object.

Glossary Item Box

Sets the single-channel LUT for the Green channel.

The default value is null.

Syntax

public void setGreenLUT(
   ImGearLUT value
)

Parameters

value
ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

setRedLUT Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : setRedLUT Method
value
ImGearLUT class object.

Glossary Item Box

Sets the single-channel LUT for the Red channel.

The default value is null.

Syntax

public void setRedLUT(
   ImGearLUT value
)

Parameters

value
ImGearLUT class object.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearRGBLUT Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearRGBLUT Class
ImGearRGBLUT Members


%%PageItemTitle%%

ImGearRGBQuad Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBQuad Class

Glossary Item Box

Specifies an RGB value.

Object Model

ImGearRGBQuad ClassImGearRGBQuad Class

Syntax

public sealed class ImGearRGBQuad
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements IImGearRGBQuad

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearRGBQuad Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRGBQuad Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBQuad Class

Glossary Item Box

The following tables list the members exposed by ImGearRGBQuad.

Public Constructors

 | Name | Description
public Constructor | ImGearRGBQuad Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getBlue Returns blue value.

public Method getGreen Returns green value.

public Method getRed Returns red value.

public Method getReserved Returns reserved value.

This value should be 0.

public Method | isGray | Overloaded. Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
public Method setBlue Sets blue value.

public Method setGreen Sets green value.

public Method setRed Sets red value.

public Method setReserved Sets reserved value.

This value should be 0.

Top

See Also

Reference

ImGearRGBQuad Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRGBQuad Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBQuad Class

Glossary Item Box

For a list of all members of this type, see ImGearRGBQuad members.

See Also

Reference

ImGearRGBQuad Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRGBQuad Constructor
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : ImGearRGBQuad Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRGBQuad Constructor() | Default constructor.
ImGearRGBQuad Constructor(int) | Initializes a new instance of the ImGearRGBQuad structure with specified gray value.
ImGearRGBQuad Constructor(IImGearRGBQuad) | Initializes a new instance of the @see ImGearRGBQuad structure from the specified
ImGearRGBQuad Constructor(int,int,int) | Initializes a new instance of the ImGearRGBQuad structure with specified red, green and blue color values.
ImGearRGBQuad Constructor(int,int,int,int) | Initializes a new instance of the ImGearRGBQuad structure with specified red, green, blue and reserved color values.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

ImGearRGBQuad Constructor()
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearRGBQuad()

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(int)
gray
Gray color value.

Glossary Item Box

Initializes a new instance of the ImGearRGBQuad structure with specified gray value.

Syntax

public ImGearRGBQuad(
   int gray
)

Parameters

gray
Gray color value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(IImGearRGBQuad)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(IImGearRGBQuad)
color
@see IImGearRGBQuad interface.

Glossary Item Box

Initializes a new instance of the @see ImGearRGBQuad structure from the specified

Syntax

public ImGearRGBQuad(
   IImGearRGBQuad color
)

Parameters

color
@see IImGearRGBQuad interface.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List
IImGearRGBQuad Interface


%%PageItemTitle%%

ImGearRGBQuad Constructor(int,int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(int,int,int)
red
Red color value.
green
Green color value.
blue
Blue color value.

Glossary Item Box

Initializes a new instance of the ImGearRGBQuad structure with specified red, green and blue color values.

Syntax

public ImGearRGBQuad(
   int red,
   int green,
   int blue
)

Parameters

red
Red color value.
green
Green color value.
blue
Blue color value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

ImGearRGBQuad Constructor(int,int,int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > ImGearRGBQuad Constructor : ImGearRGBQuad Constructor(int,int,int,int)
red
Red color value.
green
Green color value.
blue
Blue color value.
reserved
Reserved value.

Glossary Item Box

Initializes a new instance of the ImGearRGBQuad structure with specified red, green, blue and reserved color values.

Syntax

public ImGearRGBQuad(
   int red,
   int green,
   int blue,
   int reserved
)

Parameters

red
Red color value.
green
Green color value.
blue
Blue color value.
reserved
Reserved value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRGBQuad Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearRGBQuad Class

Glossary Item Box

For a list of all members of this type, see ImGearRGBQuad members.

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getBlue Returns blue value.

public Method getGreen Returns green value.

public Method getRed Returns red value.

public Method getReserved Returns reserved value.

This value should be 0.

public Method | isGray | Overloaded. Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
public Method setBlue Sets blue value.

public Method setGreen Sets green value.

public Method setRed Sets red value.

public Method setReserved Sets reserved value.

This value should be 0.

Top

See Also

Reference

ImGearRGBQuad Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearRGBQuad clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
java.lang.Cloneable


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

getBlue Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : getBlue Method

Glossary Item Box

Returns blue value.

Syntax

public short getBlue()

Return Value

Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

getGreen Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : getGreen Method

Glossary Item Box

Returns green value.

Syntax

public short getGreen()

Return Value

Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

getRed Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : getRed Method

Glossary Item Box

Returns red value.

Syntax

public short getRed()

Return Value

Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

getReserved Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : getReserved Method

Glossary Item Box

Returns reserved value.

This value should be 0.

Syntax

public short getReserved()

Return Value

Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

isGray Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : isGray Method

Glossary Item Box

Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.

Overload List

Overload | Description
isGray() | Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.
isGray(byte) | This method checks whether the RGB value is both grayscale and equal to specified value, i.e., Red = Green = Blue = value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

isGray() Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > isGray Method : isGray() Method

Glossary Item Box

Checks whether or not the RGB value is grayscale, i.e., Red = Green = Blue.

Syntax

public boolean isGray()

Return Value

Boolean value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

isGray(byte) Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class > isGray Method : isGray(byte) Method
value
Gray color value.

Glossary Item Box

This method checks whether the RGB value is both grayscale and equal to specified value, i.e., Red = Green = Blue = value.

Syntax

public boolean isGray(
   byte value
)

Parameters

value
Gray color value.

Return Value

Boolean value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members
Overload List


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

setBlue Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : setBlue Method
value
Byte value.

Glossary Item Box

Sets blue value.

Syntax

public void setBlue(
   short value
)

Parameters

value
Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

setGreen Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : setGreen Method
value
Byte value.

Glossary Item Box

Sets green value.

Syntax

public void setGreen(
   short value
)

Parameters

value
Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

setRed Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : setRed Method
value
Byte value.

Glossary Item Box

Sets red value.

Syntax

public void setRed(
   short value
)

Parameters

value
Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

setReserved Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : setReserved Method
value
Byte value.

Glossary Item Box

Sets reserved value.

This value should be 0.

Syntax

public void setReserved(
   short value
)

Parameters

value
Byte value.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core Package > ImGearRGBQuad Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearRGBQuad Class
ImGearRGBQuad Members


%%PageItemTitle%%

ImGearROI Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearROI Class

Glossary Item Box

Region of interest associated with an ImGearPage instance.

The region of interest (ROI) represents freely shaped image area (rectangular, non-rectangular or entire space) that specifies the meaningful part of an image. For example - it may be used to define the area of an image to which an image processing method's filter should be applied.

Object Model

ImGearROI ClassImGearROI ClassImGearRectangle ClassImGearROI Class

Syntax

public abstract class ImGearROI
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearROI
com.accusoft.imagegear.core.ImGearROIMask
com.accusoft.imagegear.core.ImGearROIRectangle

See Also

Reference

ImGearROI Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearROI Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearROI Class

Glossary Item Box

The following tables list the members exposed by ImGearROI.

Public Fields

 | Name | Description
public Field | left | X offset of region in the image. Integer value Specifies left side of rectangle in case of ImGearROIRectangle, and reference point in case of ImGearROIMask.
public Field | top | Y offset of region in the image. Integer value Specifies top side of rectangle in case of ImGearROIRectangle, and the reference point in case of ImGearROIMask.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
static (Shared in Visual Basic) | intersect | Creates a new ImGearROIRectangle instance that is calculated as an intersection of specified ROI and image rectangles.
public Method | pointInRegion | Checks whether or not the specified point is in the ROI.
Top

See Also

Reference

ImGearROI Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearROI Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROI Class

Glossary Item Box

For a list of all members of this type, see ImGearROI members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
static (Shared in Visual Basic) | intersect | Creates a new ImGearROIRectangle instance that is calculated as an intersection of specified ROI and image rectangles.
public Method | pointInRegion | Checks whether or not the specified point is in the ROI.
Top

See Also

Reference

ImGearROI Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearROI Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public abstract ImGearROI clone()

Return Value

ImGearROIRectangle class object that is a copy of the current instance.

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

getBoundRectangle Method
com.accusoft.imagegear.core Package > ImGearROI Class : getBoundRectangle Method

Glossary Item Box

Gets the bounding rectangle.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public abstract ImGearRectangle getBoundRectangle()

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

intersect Method
com.accusoft.imagegear.core Package > ImGearROI Class : intersect Method
region1
First ROI to merge.
imageRect1
First image rectangle.
region2
Second ROI to merge.
imageRect2
Second image rectangle.
offsetX
Horisontal offset of the second ROI and image rectangle.
offsetY
Vertical offset of the second ROI and image rectangle.

Glossary Item Box

Creates a new ImGearROIRectangle instance that is calculated as an intersection of specified ROI and image rectangles.

Syntax

public static ImGearROI intersect(
   ImGearROI region1,
   ImGearRectangle imageRect1,
   ImGearROI region2,
   ImGearRectangle imageRect2,
   int offsetX,
   int offsetY
)

Parameters

region1
First ROI to merge.
imageRect1
First image rectangle.
region2
Second ROI to merge.
imageRect2
Second image rectangle.
offsetX
Horisontal offset of the second ROI and image rectangle.
offsetY
Vertical offset of the second ROI and image rectangle.

Return Value

ImGearROIRectangle class object.

This method calculate an intersection of regions of interest from two images. Images can have different dimensions, and second image may be positioned at a specified offset relative to the first one. Coordinates of result ROI are relative to the left top corner of the first image.

com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

pointInRegion Method
com.accusoft.imagegear.core Package > ImGearROI Class : pointInRegion Method
coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Glossary Item Box

Checks whether or not the specified point is in the ROI.

Syntax

public abstract boolean pointInRegion(
   int coordinateX,
   int coordinateY
)

Parameters

coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Return Value

Boolean value.

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearROI Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROI Class

Glossary Item Box

For a list of all members of this type, see ImGearROI members.

Public Fields

 | Name | Description
public Field | left | X offset of region in the image. Integer value Specifies left side of rectangle in case of ImGearROIRectangle, and reference point in case of ImGearROIMask.
public Field | top | Y offset of region in the image. Integer value Specifies top side of rectangle in case of ImGearROIRectangle, and the reference point in case of ImGearROIMask.
Top

See Also

Reference

ImGearROI Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

left Field
com.accusoft.imagegear.core Package > ImGearROI Class : left Field

Glossary Item Box

X offset of region in the image.

Integer value

Specifies left side of rectangle in case of ImGearROIRectangle, and reference point in case of ImGearROIMask.

Syntax

public int left

Return Value

Integer value

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

top Field
com.accusoft.imagegear.core Package > ImGearROI Class : top Field

Glossary Item Box

Y offset of region in the image.

Integer value

Specifies top side of rectangle in case of ImGearROIRectangle, and the reference point in case of ImGearROIMask.

Syntax

public int top

Return Value

Integer value

See Also

Reference

ImGearROI Class
ImGearROI Members


%%PageItemTitle%%

ImGearROIMask Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearROIMask Class

Glossary Item Box

1-bit (binary) raster image that specifies a free shaped region of interest.

You can create an ImGearROIMask class object from a binary raster image or from a shape. If the mask is created from a shape, it represents a rasterized version of the shape.

Object Model

ImGearROIMask ClassImGearROIMask ClassImGearRectangle ClassImGearDIB ClassImGearROI Class

Syntax

public sealed class ImGearROIMask
    extends ImGearROI

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearROI
com.accusoft.imagegear.core.ImGearROIMask

See Also

Reference

ImGearROIMask Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearROIMask Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearROIMask Class

Glossary Item Box

The following tables list the members exposed by ImGearROIMask.

Public Constructors

 | Name | Description
public Constructor | ImGearROIMask Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | dilate | Dilates ROI mask on the specified pixel count.
public Method | erode | Erodes ROI mask on the specified pixel count.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getMask | Gets 1-bit image that defines region shape. ImGearDIB class object. Region of interest is represented by a binary (1-bit) image. ImGearDIB
public Method | pointInRegion | Checks whether the specified point is in the ROI.
Top

See Also

Reference

ImGearROIMask Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearROIMask Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROIMask Class

Glossary Item Box

For a list of all members of this type, see ImGearROIMask members.

See Also

Reference

ImGearROIMask Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearROIMask Constructor
com.accusoft.imagegear.core Package > ImGearROIMask Class : ImGearROIMask Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearROIMask Constructor(ImGearPage) | Initializes a new instance of the ImGearROIMask class, using the specified bitonal image.
ImGearROIMask Constructor(int,int,ImGearPage) | Initializes a new instance of the ImGearROIMask class, using the specified offset and a bitonal image.
ImGearROIMask Constructor(int,int,IImGearShape) | Initializes a new instance of the ImGearROIMask class from an com.accusoft.imagegear.core.shapes.IImGearShape object.
ImGearROIMask Constructor(ImGearPage,ImGearPixel,boolean) | Initializes a new instance of the ImGearROIMask class, corresponding to an area in the specified page that is filled with the specified color.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

ImGearROIMask Constructor(ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(ImGearPage)
mask
1-bit image that defines ROI shape.

Initializes mask from an ( ImGearPage) class object.

This constructor clones incoming image and assigns it as a ROI mask, positioned at zero offset.

Glossary Item Box

Initializes a new instance of the ImGearROIMask class, using the specified bitonal image.

Syntax

public ImGearROIMask(
   ImGearPage mask
)

Parameters

mask
1-bit image that defines ROI shape.

Initializes mask from an ( ImGearPage) class object.

This constructor clones incoming image and assigns it as a ROI mask, positioned at zero offset.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(int,int,ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(int,int,ImGearPage)
lft
X coordinate of the left top corner of the region.
tp
Y coordinate of the left top corner of the region.
mask
1-bit image that defines ROI shape. Must not be null.

This constructor clones incoming image ( mask) and assigns to the ROI mask.

Glossary Item Box

Initializes a new instance of the ImGearROIMask class, using the specified offset and a bitonal image.

Syntax

public ImGearROIMask(
   int lft,
   int tp,
   ImGearPage mask
)

Parameters

lft
X coordinate of the left top corner of the region.
tp
Y coordinate of the left top corner of the region.
mask
1-bit image that defines ROI shape. Must not be null.

This constructor clones incoming image ( mask) and assigns to the ROI mask.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(int,int,IImGearShape)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(int,int,IImGearShape)
left
X coordinate of the left top corner of the region.
top
Y coordinate of the left top corner of the region.
shape
Shape from which the mask will be generated.

This constructor generates mask image from the shape with minimal possible dimensions. The shape is rasterized (drawn) onto the mask image at the time of the mask creation. Left member is set to the sum of left parameter and x coordinate of left-most point of the Shape. The Top member is set to the sum of the top parameter and the y coordinate of the topmost point of the Shape.

Glossary Item Box

Initializes a new instance of the ImGearROIMask class from an com.accusoft.imagegear.core.shapes.IImGearShape object.

Syntax

public ImGearROIMask(
   int left,
   int top,
   IImGearShape shape
)

Parameters

left
X coordinate of the left top corner of the region.
top
Y coordinate of the left top corner of the region.
shape
Shape from which the mask will be generated.

This constructor generates mask image from the shape with minimal possible dimensions. The shape is rasterized (drawn) onto the mask image at the time of the mask creation. Left member is set to the sum of left parameter and x coordinate of left-most point of the Shape. The Top member is set to the sum of the top parameter and the y coordinate of the topmost point of the Shape.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%%

ImGearROIMask Constructor(ImGearPage,ImGearPixel,boolean)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIMask Class > ImGearROIMask Constructor : ImGearROIMask Constructor(ImGearPage,ImGearPixel,boolean)
page
The page used to construct the ROI mask. Binary (1-bit) pages are not supported.
maskColor
Mask color.
invertSelection
Set to true to build mask according to area not filled with MaskColor.

Creates an instance of ImGearROIMask object corresponding to area in the page that is filled with maskColor. If invertSelection is true, the mask is created for the area that is not filled with maskColor.

The ImGearPixel passed as maskColor should correspond to page's number of channels and bit depth.

This constructor can be used to create an ROI Mask based on the DICOM Pixel Padding Value.

Glossary Item Box

Initializes a new instance of the ImGearROIMask class, corresponding to an area in the specified page that is filled with the specified color.

Syntax

public ImGearROIMask(
   ImGearPage page,
   ImGearPixel maskColor,
   boolean invertSelection
)

Parameters

page
The page used to construct the ROI mask. Binary (1-bit) pages are not supported.
maskColor
Mask color.
invertSelection
Set to true to build mask according to area not filled with MaskColor.

Creates an instance of ImGearROIMask object corresponding to area in the page that is filled with maskColor. If invertSelection is true, the mask is created for the area that is not filled with maskColor.

The ImGearPixel passed as maskColor should correspond to page's number of channels and bit depth.

This constructor can be used to create an ROI Mask based on the DICOM Pixel Padding Value.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearROIMask Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROIMask Class

Glossary Item Box

For a list of all members of this type, see ImGearROIMask members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | dilate | Dilates ROI mask on the specified pixel count.
public Method | erode | Erodes ROI mask on the specified pixel count.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | getMask | Gets 1-bit image that defines region shape. ImGearDIB class object. Region of interest is represented by a binary (1-bit) image. ImGearDIB
public Method | pointInRegion | Checks whether the specified point is in the ROI.
Top

See Also

Reference

ImGearROIMask Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearROIMask clone()

Return Value

ImGearROIMask class that is a copy of the current instance. ImGearROIMask

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

dilate Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : dilate Method
pixCount
The pixel count. erode

Glossary Item Box

Dilates ROI mask on the specified pixel count.

Syntax

public void dilate(
   int pixCount
)

Parameters

pixCount
The pixel count. erode

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

erode Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : erode Method
pixCount
The pixel count. dilate

Glossary Item Box

Erodes ROI mask on the specified pixel count.

Syntax

public void erode(
   int pixCount
)

Parameters

pixCount
The pixel count. dilate

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

getBoundRectangle Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : getBoundRectangle Method

Glossary Item Box

Gets the bounding rectangle.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBoundRectangle()

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

getMask Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : getMask Method

Glossary Item Box

Gets 1-bit image that defines region shape.

ImGearDIB class object.

Region of interest is represented by a binary (1-bit) image.

ImGearDIB

Syntax

public ImGearDIB getMask()

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

pointInRegion Method
com.accusoft.imagegear.core Package > ImGearROIMask Class : pointInRegion Method
coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Glossary Item Box

Checks whether the specified point is in the ROI.

Syntax

public boolean pointInRegion(
   int coordinateX,
   int coordinateY
)

Parameters

coordinateX
The x coordinate of the point.
coordinateY
The y coordinate of the point.

Return Value

Boolean value.

See Also

Reference

ImGearROIMask Class
ImGearROIMask Members


%%PageItemTitle%%

ImGearROIRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearROIRectangle Class

Glossary Item Box

Rectangular region of interest.

Object Model

ImGearROIRectangle ClassImGearROI ClassImGearRectangle ClassImGearROI Class

Syntax

public sealed class ImGearROIRectangle
    extends ImGearROI

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearROI
com.accusoft.imagegear.core.ImGearROIRectangle

See Also

Reference

ImGearROIRectangle Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearROIRectangle Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearROIRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearROIRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearROIRectangle Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | height | Height of rectangle in pixels. Integer value width
public Field | width | Width of rectangle in pixels. Integer value height
Top

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | pointInRegion | Checks whether or not the specified point is in the ROI.
Top

See Also

Reference

ImGearROIRectangle Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearROIRectangle Constructor
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : ImGearROIRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearROIRectangle Constructor(int,int) | Initializes a new instance of the ImGearROIRectangle class with zero offset and specified size.
ImGearROIRectangle Constructor(int,int,int,int) | Initializes a new instance of the @see ImGearROIRectangle class with specified offset and size.

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

ImGearROIRectangle Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIRectangle Class > ImGearROIRectangle Constructor : ImGearROIRectangle Constructor(int,int)
wdth
Width of rectangle.
hgt
Height of rectangle.

Glossary Item Box

Initializes a new instance of the ImGearROIRectangle class with zero offset and specified size.

Syntax

public ImGearROIRectangle(
   int wdth,
   int hgt
)

Parameters

wdth
Width of rectangle.
hgt
Height of rectangle.

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Overload List


%%PageItemTitle%%

ImGearROIRectangle Constructor(int,int,int,int)
See Also Send Feedback
com.accusoft.imagegear.core Package > ImGearROIRectangle Class > ImGearROIRectangle Constructor : ImGearROIRectangle Constructor(int,int,int,int)
lft
Left side of rectangle.
tp
Top side of rectangle.
wdth
Width of rectangle.
hgt
Height of rectangle.

Glossary Item Box

Initializes a new instance of the @see ImGearROIRectangle class with specified offset and size.

Syntax

public ImGearROIRectangle(
   int lft,
   int tp,
   int wdth,
   int hgt
)

Parameters

lft
Left side of rectangle.
tp
Top side of rectangle.
wdth
Width of rectangle.
hgt
Height of rectangle.

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearROIRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROIRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearROIRectangle members.

Public Methods

 | Name | Description
public Method | clone | Creates a new object that is a copy of the current instance.
public Method | getBoundRectangle | Gets the bounding rectangle. com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle
public Method | pointInRegion | Checks whether or not the specified point is in the ROI.
Top

See Also

Reference

ImGearROIRectangle Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : clone Method

Glossary Item Box

Creates a new object that is a copy of the current instance.

Syntax

public ImGearROI clone()

Return Value

ImGearROI class that is a copy of the current instance. ImGearROI

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

getBoundRectangle Method
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : getBoundRectangle Method

Glossary Item Box

Gets the bounding rectangle.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure. com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

public ImGearRectangle getBoundRectangle()

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

pointInRegion Method
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : pointInRegion Method
coordinateX
The x value of the point.
coordinateY
The y value of the point.

Glossary Item Box

Checks whether or not the specified point is in the ROI.

Syntax

public boolean pointInRegion(
   int coordinateX,
   int coordinateY
)

Parameters

coordinateX
The x value of the point.
coordinateY
The y value of the point.

Return Value

Boolean value. ImGearROIMask

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearROIRectangle Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearROIRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearROIRectangle members.

Public Fields

 | Name | Description
public Field | height | Height of rectangle in pixels. Integer value width
public Field | width | Width of rectangle in pixels. Integer value height
Top

See Also

Reference

ImGearROIRectangle Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

height Field
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : height Field

Glossary Item Box

Height of rectangle in pixels.

Integer value width

Syntax

public int height

Return Value

Integer value

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

width Field
com.accusoft.imagegear.core Package > ImGearROIRectangle Class : width Field

Glossary Item Box

Width of rectangle in pixels.

Integer value height

Syntax

public int width

Return Value

Integer value

See Also

Reference

ImGearROIRectangle Class
ImGearROIRectangle Members


%%PageItemTitle%%

ImGearSize Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearSize Class

Glossary Item Box

Implements a relative coordinate or position.

Object Model

ImGearSize ClassImGearSize Class

Syntax

public sealed class ImGearSize
    extends Object
    implements IImGearSize, java.lang.Cloneable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearSize

See Also

Reference

ImGearSize Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearSize Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearSize Class

Glossary Item Box

The following tables list the members exposed by ImGearSize.

Public Constructors

 | Name | Description
public Constructor | ImGearSize Constructor | Default constructor
Top

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getcX Returns the rectangle's width.

public Method getcY Returns the rectangle's height.

public Method setcX Sets the rectangle's width.

public Method setcY Sets the rectangle's height.

Top

See Also

Reference

ImGearSize Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearSize Constructor
com.accusoft.imagegear.core Package > ImGearSize Class : ImGearSize Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearSize()

See Also

Reference

ImGearSize Class
ImGearSize Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearSize Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearSize Class

Glossary Item Box

For a list of all members of this type, see ImGearSize members.

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getcX Returns the rectangle's width.

public Method getcY Returns the rectangle's height.

public Method setcX Sets the rectangle's width.

public Method setcY Sets the rectangle's height.

Top

See Also

Reference

ImGearSize Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearSize Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearSize clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearSize Class
ImGearSize Members
java.lang.Cloneable


%%PageItemTitle%%

getcX Method
com.accusoft.imagegear.core Package > ImGearSize Class : getcX Method

Glossary Item Box

Returns the rectangle's width.

Syntax

public int getcX()

Return Value

Any integer value.

See Also

Reference

ImGearSize Class
ImGearSize Members


%%PageItemTitle%%

getcY Method
com.accusoft.imagegear.core Package > ImGearSize Class : getcY Method

Glossary Item Box

Returns the rectangle's height.

Syntax

public int getcY()

Return Value

Any integer value.

See Also

Reference

ImGearSize Class
ImGearSize Members


%%PageItemTitle%%

setcX Method
com.accusoft.imagegear.core Package > ImGearSize Class : setcX Method
value
Any integer value.

Glossary Item Box

Sets the rectangle's width.

Syntax

public void setcX(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearSize Class
ImGearSize Members


%%PageItemTitle%%

setcY Method
com.accusoft.imagegear.core Package > ImGearSize Class : setcY Method
value
Any integer value.

Glossary Item Box

Sets the rectangle's height.

Syntax

public void setcY(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearSize Class
ImGearSize Members


%%PageItemTitle%%

ImGearSpotChannelInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearSpotChannelInfo Class

Glossary Item Box

Spot channel class that uses a special color, such as Pantone.

This class does not store a color name, but looks it up from the loaded color books when necessary.

Object Model

ImGearSpotChannelInfo ClassImGearExtraChannelInfo ClassImGearExtraChannelType EnumerationImGearSpotColorVendorID Enumeration

Syntax

public class ImGearSpotChannelInfo
    extends ImGearExtraChannelInfo

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearExtraChannelInfo
com.accusoft.imagegear.core.ImGearSpotChannelInfo
com.accusoft.imagegear.core.ImGearMaskSpotChannelInfo

See Also

Reference

ImGearSpotChannelInfo Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearSpotChannelInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearSpotChannelInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearSpotChannelInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearSpotChannelInfo Constructor | Initializes a new instance of the ImGearSpotChannelInfo class by using spot color vendor ID and color ID.
Top

Public Methods

 | Name | Description
public Method | getColorID | Gets ID of the spot color. Long value.
public Method | getColorName | Gets color name from internal color books. String value.
public Method | getOpacity | Returns opacity of the spot color.
public Method | getVendorID | Gets vendor ID of the spot color. ImGearSpotColorVendorID enumeration value.
public Method | setOpacity | Sets opacity of the spot color.
Top

See Also

Reference

ImGearSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearSpotChannelInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearSpotChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearSpotChannelInfo members.

See Also

Reference

ImGearSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearSpotChannelInfo Constructor
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : ImGearSpotChannelInfo Constructor
vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book.

Glossary Item Box

Initializes a new instance of the ImGearSpotChannelInfo class by using spot color vendor ID and color ID.

Syntax

public ImGearSpotChannelInfo(
   ImGearSpotColorVendorID vendorId,
   long colorId
)

Parameters

vendorId
Vendor ID of the spot color.
colorId
Spot color ID in Vendor's color book.

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : clone Method

Glossary Item Box

Syntax

public ImGearExtraChannelInfo clone()

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearSpotChannelInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearSpotChannelInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearSpotChannelInfo members.

Public Methods

 | Name | Description
public Method | getColorID | Gets ID of the spot color. Long value.
public Method | getColorName | Gets color name from internal color books. String value.
public Method | getOpacity | Returns opacity of the spot color.
public Method | getVendorID | Gets vendor ID of the spot color. ImGearSpotColorVendorID enumeration value.
public Method | setOpacity | Sets opacity of the spot color.
Top

See Also

Reference

ImGearSpotChannelInfo Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColorID Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : getColorID Method

Glossary Item Box

Gets ID of the spot color.

Long value.

Syntax

public long getColorID()

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

getColorName Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : getColorName Method

Glossary Item Box

Gets color name from internal color books.

String value.

Syntax

public java.lang.String getColorName()

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : getOpacity Method

Glossary Item Box

Returns opacity of the spot color.

Syntax

public int getOpacity()

Return Value

Integer value in range [0...100].

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

getVendorID Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : getVendorID Method

Glossary Item Box

Gets vendor ID of the spot color.

ImGearSpotColorVendorID enumeration value.

Syntax

public ImGearSpotColorVendorID getVendorID()

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.core Package > ImGearSpotChannelInfo Class : setOpacity Method
value
Integer value in range [0...100].

Glossary Item Box

Sets opacity of the spot color.

Syntax

public void setOpacity(
   int value
)

Parameters

value
Integer value in range [0...100].

See Also

Reference

ImGearSpotChannelInfo Class
ImGearSpotChannelInfo Members


%%PageItemTitle%%

ImGearStream Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearStream Class

Glossary Item Box

Basic stream functionality.

Object Model

ImGearStream Class

Syntax

public abstract class ImGearStream
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearStream
com.accusoft.imagegear.core.ImGearMemoryStream

See Also

Reference

ImGearStream Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearStream Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearStream Class

Glossary Item Box

The following tables list the members exposed by ImGearStream.

Public Methods

Name | Description
public Method close Closes stream and releases any system resources associated with it.

Has no effect if stream is already closed.

public Method | flush | Flushes streams implementing a buffer.
public Method | getLength | Returns the length of this stream.
public Method | isReadable | Returns whether you can read from this stream.
public Method | isWritable | Returns whether you can write to this stream.
public Method | position | Returns the current offset in this stream.
public Method | read | Reads up to len bytes of data from this stream into an array of bytes.
public Method | readByte | Reads the next byte from the stream.
public Method | seek | Sets the position within this stream.
public Method setLength Sets the length of this stream.

If the present length of the stream as returned by the getLength method is greater than the newLength argument then the stream will be truncated. In this case, if the stream offset as returned by the position method is greater than newLength then after this method returns the offset will be equal to newLength.

If the present length of the stream as returned by the getLength method is smaller than the newLength argument then the stream will be extended. In this case, the contents of the extended portion of the stream are not defined.

public Method | write | Writes len bytes from the specified byte array starting at offset off to this stream.
public Method | writeByte | Writes a byte to the stream.
Top

See Also

Reference

ImGearStream Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearStream Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearStream Class

Glossary Item Box

For a list of all members of this type, see ImGearStream members.

Public Methods

Name | Description
public Method close Closes stream and releases any system resources associated with it.

Has no effect if stream is already closed.

public Method | flush | Flushes streams implementing a buffer.
public Method | getLength | Returns the length of this stream.
public Method | isReadable | Returns whether you can read from this stream.
public Method | isWritable | Returns whether you can write to this stream.
public Method | position | Returns the current offset in this stream.
public Method | read | Reads up to len bytes of data from this stream into an array of bytes.
public Method | readByte | Reads the next byte from the stream.
public Method | seek | Sets the position within this stream.
public Method setLength Sets the length of this stream.

If the present length of the stream as returned by the getLength method is greater than the newLength argument then the stream will be truncated. In this case, if the stream offset as returned by the position method is greater than newLength then after this method returns the offset will be equal to newLength.

If the present length of the stream as returned by the getLength method is smaller than the newLength argument then the stream will be extended. In this case, the contents of the extended portion of the stream are not defined.

public Method | write | Writes len bytes from the specified byte array starting at offset off to this stream.
public Method | writeByte | Writes a byte to the stream.
Top

See Also

Reference

ImGearStream Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

close Method
com.accusoft.imagegear.core Package > ImGearStream Class : close Method

Glossary Item Box

Closes stream and releases any system resources associated with it.

Has no effect if stream is already closed.

Syntax

public abstract void close()

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

flush Method
com.accusoft.imagegear.core Package > ImGearStream Class : flush Method

Glossary Item Box

Flushes streams implementing a buffer.

Syntax

public abstract void flush()

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

getLength Method
com.accusoft.imagegear.core Package > ImGearStream Class : getLength Method

Glossary Item Box

Returns the length of this stream.

Syntax

public abstract long getLength()

Return Value

the length of this stream, measured in bytes.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

isReadable Method
com.accusoft.imagegear.core Package > ImGearStream Class : isReadable Method

Glossary Item Box

Returns whether you can read from this stream.

Syntax

public abstract boolean isReadable()

Return Value

whether you can read from this stream.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

isWritable Method
com.accusoft.imagegear.core Package > ImGearStream Class : isWritable Method

Glossary Item Box

Returns whether you can write to this stream.

Syntax

public abstract boolean isWritable()

Return Value

whether you can write to this stream.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

position Method
com.accusoft.imagegear.core Package > ImGearStream Class : position Method

Glossary Item Box

Returns the current offset in this stream.

Syntax

public abstract long position()

Return Value

the offset from the beginning of the stream, in bytes, at which the next read or write occurs.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

read Method
com.accusoft.imagegear.core Package > ImGearStream Class : read Method
b
- the buffer into which the data is read.
off
- the start offset in array b at which the data is written.
len
- the maximum number of bytes read.

Glossary Item Box

Reads up to len bytes of data from this stream into an array of bytes.

Syntax

public abstract int read(
   byte[] b,
   int off,
   int len
)

Parameters

b
- the buffer into which the data is read.
off
- the start offset in array b at which the data is written.
len
- the maximum number of bytes read.

Return Value

the total number of bytes read into the buffer, or -1 if there is no more data because the end of the stream has been reached.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

readByte Method
com.accusoft.imagegear.core Package > ImGearStream Class : readByte Method

Glossary Item Box

Reads the next byte from the stream.

Syntax

public abstract byte readByte()

Return Value

the next byte.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

seek Method
com.accusoft.imagegear.core Package > ImGearStream Class : seek Method
offset
- A byte offset relative to the origin.
origin
- The reference point of type ImGearSeekOrigin ImGearSeekOrigin} used to obtain the new position.

Glossary Item Box

Sets the position within this stream.

Syntax

public abstract long seek(
   long offset,
   ImGearSeekOrigin origin
)

Parameters

offset
- A byte offset relative to the origin.
origin
- The reference point of type ImGearSeekOrigin ImGearSeekOrigin} used to obtain the new position.

Return Value

The new position within the current stream.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

setLength Method
com.accusoft.imagegear.core Package > ImGearStream Class : setLength Method
newLength
- new length for stream

Glossary Item Box

Sets the length of this stream.

If the present length of the stream as returned by the getLength method is greater than the newLength argument then the stream will be truncated. In this case, if the stream offset as returned by the position method is greater than newLength then after this method returns the offset will be equal to newLength.

If the present length of the stream as returned by the getLength method is smaller than the newLength argument then the stream will be extended. In this case, the contents of the extended portion of the stream are not defined.

Syntax

public abstract void setLength(
   long newLength
)

Parameters

newLength
- new length for stream

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

write Method
com.accusoft.imagegear.core Package > ImGearStream Class : write Method
b
- the data.
off
- the start offset in the data.
len
- the number of bytes to write.

Glossary Item Box

Writes len bytes from the specified byte array starting at offset off to this stream.

Syntax

public abstract void write(
   byte[] b,
   int off,
   int len
)

Parameters

b
- the data.
off
- the start offset in the data.
len
- the number of bytes to write.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

writeByte Method
com.accusoft.imagegear.core Package > ImGearStream Class : writeByte Method
val
- the byte to write.

Glossary Item Box

Writes a byte to the stream.

Syntax

public abstract void writeByte(
   byte val
)

Parameters

val
- the byte to write.

See Also

Reference

ImGearStream Class
ImGearStream Members


%%PageItemTitle%%

ImGearStreams Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearStreams Class

Glossary Item Box

Factory for stream implementations.

The memory streams are always readable, until ImGearStream.close is called.

Object Model

ImGearStreams ClassImGearStream ClassImGearMemoryStream Class

Syntax

public sealed class ImGearStreams
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearStreams

See Also

Reference

ImGearStreams Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearStreams Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearStreams Class

Glossary Item Box

The following tables list the members exposed by ImGearStreams.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | fileStream | Creates a stream with the file "backing" specified by fileName. If it is created for writing and the file does not exist, this call will try to create one.
static (Shared in Visual Basic) | memoryStream | Overloaded. Creates a resizable and writable memory stream.
Top

See Also

Reference

ImGearStreams Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearStreams Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearStreams Class

Glossary Item Box

For a list of all members of this type, see ImGearStreams members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | fileStream | Creates a stream with the file "backing" specified by fileName. If it is created for writing and the file does not exist, this call will try to create one.
static (Shared in Visual Basic) | memoryStream | Overloaded. Creates a resizable and writable memory stream.
Top

See Also

Reference

ImGearStreams Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

fileStream Method
com.accusoft.imagegear.core Package > ImGearStreams Class : fileStream Method
fileName
- the system-dependent file name
rw
- either "r" for reading only or "rw" for reading and writing

Glossary Item Box

Creates a stream with the file "backing" specified by fileName.

If it is created for writing and the file does not exist, this call will try to create one.

Syntax

public static ImGearStream fileStream(
   java.lang.String fileName,
   java.lang.String rw
)

Parameters

fileName
- the system-dependent file name
rw
- either "r" for reading only or "rw" for reading and writing

Return Value

an ImGearStream instance.

See Also

Reference

ImGearStreams Class
ImGearStreams Members


%%PageItemTitle%%

memoryStream Method
com.accusoft.imagegear.core Package > ImGearStreams Class : memoryStream Method

Glossary Item Box

Creates a resizable and writable memory stream.

Overload List

Overload | Description
memoryStream() | Creates a resizable and writable memory stream.
memoryStream(byte[],int,int,boolean,boolean) | Creates a memory stream from an array of bytes.
memoryStream(int) | Creates a memory stream capable of writing initialCapacity bytes without resizing. This stream is resizable and writable.

See Also

Reference

ImGearStreams Class
ImGearStreams Members


%%PageItemTitle%%

memoryStream() Method
com.accusoft.imagegear.core Package > ImGearStreams Class > memoryStream Method : memoryStream() Method

Glossary Item Box

Creates a resizable and writable memory stream.

Syntax

public static ImGearMemoryStream memoryStream()

Return Value

an ImGearMemoryStream instance.

See Also

Reference

ImGearStreams Class
ImGearStreams Members
Overload List


%%PageItemTitle%%

memoryStream(byte[],int,int,boolean,boolean) Method
com.accusoft.imagegear.core Package > ImGearStreams Class > memoryStream Method : memoryStream(byte[],int,int,boolean,boolean) Method
bytes
array to read from or write to. If resizable and writable are true, the internal reference initialized with bytes may subsequently be reassigned to a larger array.
offset
offset >= 0. offset into bytes to begin I/O from.
len
getLength will initially return offset + len.
writable
whether you can write to the stream.
resizable
whether the stream can be resized.

Glossary Item Box

Creates a memory stream from an array of bytes.

Syntax

public static ImGearMemoryStream memoryStream(
   byte[] bytes,
   int offset,
   int len,
   boolean writable,
   boolean resizable
)

Parameters

bytes
array to read from or write to. If resizable and writable are true, the internal reference initialized with bytes may subsequently be reassigned to a larger array.
offset
offset >= 0. offset into bytes to begin I/O from.
len
getLength will initially return offset + len.
writable
whether you can write to the stream.
resizable
whether the stream can be resized.

Return Value

an ImGearMemoryStream instance.

See Also

Reference

ImGearStreams Class
ImGearStreams Members
Overload List


%%PageItemTitle%%

memoryStream(int) Method
com.accusoft.imagegear.core Package > ImGearStreams Class > memoryStream Method : memoryStream(int) Method
initialCapacity
- initial size of internal byte array "backing". initialCapacity is initial value of getLength

Glossary Item Box

Creates a memory stream capable of writing initialCapacity bytes without resizing.

This stream is resizable and writable.

Syntax

public static ImGearMemoryStream memoryStream(
   int initialCapacity
)

Parameters

initialCapacity
- initial size of internal byte array "backing". initialCapacity is initial value of getLength

Return Value

an ImGearMemoryStream instance.

See Also

Reference

ImGearStreams Class
ImGearStreams Members
Overload List


%%PageItemTitle%%

ImGearTransparency Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearTransparency Class

Glossary Item Box

Specifies image transparency attributes like transparent color for display.

Object Model

ImGearTransparency Class

Syntax

public class ImGearTransparency
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearTransparency

See Also

Reference

ImGearTransparency Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearTransparency Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.core Package : ImGearTransparency Class

Glossary Item Box

The following tables list the members exposed by ImGearTransparency.

Public Constructors

 | Name | Description
public Constructor | ImGearTransparency Constructor | Initializes a new instance of the ImGearTransparency class by specifying a transparent color for display in RGB format.
Top

Public Fields

 | Name | Description
public Field | displayColor | Specifies transparent color for display. ImGearRGBQuad structure. ImGearRGBQuad
Top

See Also

Reference

ImGearTransparency Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearTransparency Constructor
com.accusoft.imagegear.core Package > ImGearTransparency Class : ImGearTransparency Constructor
redDisplayColor
Red value of the transparent color for display.
greenDisplayColor
Green value of the transparent color for display.
blueDisplayColor
Blue value of the transparent color for display.

Glossary Item Box

Initializes a new instance of the ImGearTransparency class by specifying a transparent color for display in RGB format.

Syntax

public ImGearTransparency(
   byte redDisplayColor,
   byte greenDisplayColor,
   byte blueDisplayColor
)

Parameters

redDisplayColor
Red value of the transparent color for display.
greenDisplayColor
Green value of the transparent color for display.
blueDisplayColor
Blue value of the transparent color for display.

See Also

Reference

ImGearTransparency Class
ImGearTransparency Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearTransparency Class Fields
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearTransparency Class

Glossary Item Box

For a list of all members of this type, see ImGearTransparency members.

Public Fields

 | Name | Description
public Field | displayColor | Specifies transparent color for display. ImGearRGBQuad structure. ImGearRGBQuad
Top

See Also

Reference

ImGearTransparency Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

displayColor Field
com.accusoft.imagegear.core Package > ImGearTransparency Class : displayColor Field

Glossary Item Box

Specifies transparent color for display.

ImGearRGBQuad structure.

ImGearRGBQuad

Syntax

public IImGearRGBQuad displayColor

Return Value

ImGearRGBQuad structure.

See Also

Reference

ImGearTransparency Class
ImGearTransparency Members


%%PageItemTitle%%

ImGearVersion Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearVersion Class

Glossary Item Box

This class provides static properties to retrieve version info for the product package.

Object Model

ImGearVersion Class

Syntax

public sealed class ImGearVersion
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearVersion

See Also

Reference

ImGearVersion Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearVersion Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearVersion Class

Glossary Item Box

The following tables list the members exposed by ImGearVersion.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getBuild | Gets the build number.
static (Shared in Visual Basic) | getCopyright | Gets the copyright.
static (Shared in Visual Basic) | getMajor | Gets major version.
static (Shared in Visual Basic) | getMinor | Gets the minor version.
static (Shared in Visual Basic) | getRevision | Gets the revision.
static (Shared in Visual Basic) | getVersionString | Gets product version in the string format. String value.
Top

See Also

Reference

ImGearVersion Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearVersion Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearVersion Class

Glossary Item Box

For a list of all members of this type, see ImGearVersion members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getBuild | Gets the build number.
static (Shared in Visual Basic) | getCopyright | Gets the copyright.
static (Shared in Visual Basic) | getMajor | Gets major version.
static (Shared in Visual Basic) | getMinor | Gets the minor version.
static (Shared in Visual Basic) | getRevision | Gets the revision.
static (Shared in Visual Basic) | getVersionString | Gets product version in the string format. String value.
Top

See Also

Reference

ImGearVersion Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getBuild Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getBuild Method

Glossary Item Box

Gets the build number.

Syntax

public static int getBuild()

Return Value

The build number.

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

getCopyright Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getCopyright Method

Glossary Item Box

Gets the copyright.

Syntax

public static java.lang.String getCopyright()

Return Value

the copyright.

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

getMajor Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getMajor Method

Glossary Item Box

Gets major version.

Syntax

public static int getMajor()

Return Value

The major version.

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

getMinor Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getMinor Method

Glossary Item Box

Gets the minor version.

Syntax

public static int getMinor()

Return Value

The minor version.

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

getRevision Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getRevision Method

Glossary Item Box

Gets the revision.

Syntax

public static int getRevision()

Return Value

The revision.

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

getVersionString Method
com.accusoft.imagegear.core Package > ImGearVersion Class : getVersionString Method

Glossary Item Box

Gets product version in the string format.

String value.

Syntax

public static java.lang.String getVersionString()

See Also

Reference

ImGearVersion Class
ImGearVersion Members


%%PageItemTitle%%

ImGearWarning Class
See Also Members Send Feedback
com.accusoft.imagegear.core Package : ImGearWarning Class

Glossary Item Box

Base class for all warnings handled by the ImageGear for Java library. Contains error code and optionally supplied data.

Object Model

ImGearWarning ClassIImGearAddWarning InterfaceImGearErrorCodes Enumeration

Syntax

public sealed class ImGearWarning
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearWarning

See Also

Reference

ImGearWarning Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearWarning Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : ImGearWarning Class

Glossary Item Box

The following tables list the members exposed by ImGearWarning.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getAddWarning | Returns reference to the AddWarning callback.
public Method | getDescription | Returns warning description.
public Method | getErrorCode | Returns warning code. ImGearErrorCodes
static (Shared in Visual Basic) | setAddWarning | Sets reference to the AddWarning callback.
public Method | setDescription | Sets warning description.
public Method | setErrorCode | Sets warning code. ImGearErrorCodes
Top

See Also

Reference

ImGearWarning Class
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearWarning Class Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : ImGearWarning Class

Glossary Item Box

For a list of all members of this type, see ImGearWarning members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getAddWarning | Returns reference to the AddWarning callback.
public Method | getDescription | Returns warning description.
public Method | getErrorCode | Returns warning code. ImGearErrorCodes
static (Shared in Visual Basic) | setAddWarning | Sets reference to the AddWarning callback.
public Method | setDescription | Sets warning description.
public Method | setErrorCode | Sets warning code. ImGearErrorCodes
Top

See Also

Reference

ImGearWarning Class
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getAddWarning Method
com.accusoft.imagegear.core Package > ImGearWarning Class : getAddWarning Method

Glossary Item Box

Returns reference to the AddWarning callback.

Syntax

public static IImGearAddWarning getAddWarning()

Return Value

IImGearAddWarning callback.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.core Package > ImGearWarning Class : getDescription Method

Glossary Item Box

Returns warning description.

Syntax

public java.lang.String getDescription()

Return Value

String value.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

getErrorCode Method
com.accusoft.imagegear.core Package > ImGearWarning Class : getErrorCode Method

Glossary Item Box

Returns warning code.

ImGearErrorCodes

Syntax

public ImGearErrorCodes getErrorCode()

Return Value

ImGearErrorCodes enumeration value.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

setAddWarning Method
com.accusoft.imagegear.core Package > ImGearWarning Class : setAddWarning Method
value
IImGearAddWarning callback.

Glossary Item Box

Sets reference to the AddWarning callback.

Syntax

public static void setAddWarning(
   IImGearAddWarning value
)

Parameters

value
IImGearAddWarning callback.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

setDescription Method
com.accusoft.imagegear.core Package > ImGearWarning Class : setDescription Method
value
String value.

Glossary Item Box

Sets warning description.

Syntax

public void setDescription(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

setErrorCode Method
com.accusoft.imagegear.core Package > ImGearWarning Class : setErrorCode Method
value
ImGearErrorCodes enumeration value.

Glossary Item Box

Sets warning code.

ImGearErrorCodes

Syntax

public void setErrorCode(
   ImGearErrorCodes value
)

Parameters

value
ImGearErrorCodes enumeration value.

See Also

Reference

ImGearWarning Class
ImGearWarning Members


%%PageItemTitle%%

ImGearColorSpaceIDs Enumeration
com.accusoft.imagegear.core Package : ImGearColorSpaceIDs Enumeration

Glossary Item Box

Specifies ImageGear color space IDs.

Specifies color space IDs. All colorspaces listed in this enumeration are supported for internal image storage.

ImageGear also supports colorspaces corresponding to valid combinations of ImGearColorSpaceIDs identifiers. Valid values are composed of a color identifier, such as RGB, Gy, Lab, etc, an optional Alpha and premulultiplied Alpha channel identifiers, and an optional Extra channel identifier. If Premultiplied Alpha bit is set, Alpha bit shall also be set. Only RGB and Gy colorspaces are currently allowed to be combined with Alpha or Premultiplied Alpha.

Members

Member | Description
A | Image has alpha channel; color channels are not pre-multiplied by Alpha channel.
CMY | CMY color space.
CMYK | CMYK color space.
COLORMASK | To remove bits containing channel information. Removes contribution from A, P, and Ex in integral representation of aggregation of enum constants as returned by enumSetToInt.
Ex | Extra channel.
Gy | Grayscale color space.
HLS | HLS color space.
I | Indexed RGB color space. Has RGBQuad palette and one channel. Channel depth is <= 8; the number of palette entries is 2^<channel depth>. No other color space can have non-null palette.
IHS | IHS color space.
LAB | LAB color space.
P | Premultiplied channel.
RGB | RGB color space.
YCbCr | YCbCr color space.
YIQ | YIQ color space.
YUV | YUV color space.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearColorSpaceIDs

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearErrorCodes Enumeration
com.accusoft.imagegear.core Package : ImGearErrorCodes Enumeration

Glossary Item Box

Specifies ImageGear error codes.

Members

Member | Description
BARCODE_FAILURE | The barcode generic failure.
CANT_ADD_COLOR_TO_COLORBOOK | Cannot add color to color book.
CANT_CREATE_COLORBOOK | Cannot create new color book.
CANT_DETECT_FORMAT | Cannot detect format.
CANT_FIND_FORMAT | Cannot find format.
CANT_LOAD_LIBRARY | Cannot load a specified library.
CANT_READ_PIXELS | Cannot read image pixels.
CANT_READ_PROFILE | Cannot read profile.
CANT_SAVE_FORMAT | Cannot save format.
CLIPBOARD_DATA_ERROR | Clipboard data error
CMS_LIBRARY_NOT_LOADED | CMS library not loaded
CYCLIC_REFERENCE | Cyclic reference.
DATA_STREAM_INCOMPLETE | Data stream incomplete.
EOF_EXCEPTION | End of stream exception
FFTW_NOT_INITIALIZED | Support for FFTW is not initialized.
FORMAT_ALREADY_ADDED | The specified format is already in the collection.
INTERNAL_FAILURE | Internal failure.
INVALID_BITCOUNT_FOR_FORMAT | Invalid bit depth for the specified format.
INVALID_COMPLEX_OBJECT | Invalid complex object.
INVALID_COMPRESSED_DATA | Invalid compression data.
INVALID_COMPRESSION | Invalid compression.
INVALID_HEADER_FOR_FORMAT | Invalid header for the format.
INVALID_IMAGE_DIMENSIONS | Invalid image dimensions.
INVALID_IMAGE_TILE_DIMENSIONS | Invalid image tile dimensions.
INVALID_LOOK_UP_TABLE | Invalid lookup table.
INVALID_RESOLUTION_VALUE_FOR_FORMAT | Invalid resolution for using format.
INVALID_TYPE | Invalid type.
IO_EXCEPTION | IO exception
IP_FUNCTION_NOT_APPLICABLE_TO_DIB | The IP method is not supported for the specified DIB.
JPEG2K_FAILURE | The JPEG 2000 failure.
MEDC_FAILURE | MedC specific error code.
NOT_IMPLEMENTED_YET | The API is not yet implemented.
NOT_LICENSED | The product of feature are not licensed.
NOT_SUPPORTED_EXCEPTION | Unsupported operation.
OWNER_ALREADY_ASSIGNED | Owner has already been assigned.
OWNER_NOT_ASSIGNED | Owner has not been assigned.
PAGE_NOT_PRESENT | The specified page is not present.
PARAMETER_HAS_INVALID_VALUE | The parameter has an invalid value.
PDF_FAILURE | The PDF failure.
PROFILE_CONVERSION_FAILED | Profile conversion failed.
REC_ENGINE_FAILURE | The recognition engine failure.
REC_FAILURE | The recognition generic failure.
REC_ZERO_RESOLUTION | Image is with zero resolution.
REQUIRE_8_16_32BIT_GRAYSCALE_1CHANNEL | Require 8, 16 or 32bit gray-scale image with one channel.
REQUIRE_8BIT_GRAYSCALE_1CHANNEL | Require 8bit gray-scale image with one channel.
SPOT_COLOR_IS_UNKNOWN | Spot color is absent and cannot be displayed.
SUCCESS | No errors have been reported.
THUMBNAIL_NOT_PRESENT | This image does not contain a thumbnail.
TILE_NOT_PRESENT | The specified tile is not present.
TWAIN_FAILURE | The TWAIN failure.
TWAIN_OPERATION_CANCELED | The TWAIN operation is canceled.
TWAIN_OPERATION_CANCELED_BY_EVENT | The TWAIN operation is canceled by event handler.
VALUES_ARE_INCOMPATIBLE | The specified values are incompatible.
WRONG_ARGUMENT | Wrong argument
WRONG_METADATA_FORMAT | Wrong metadata format.
XML_ERROR | Something with XML

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearErrorCodes

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearEvaluationMode Enumeration
com.accusoft.imagegear.core Package : ImGearEvaluationMode Enumeration

Glossary Item Box

Gets or sets the product evaluation mode.

Currently, only allows Watermark.

Members

Member | Description
TrialDialog | Always displays the evaluation dialog on initial licensing validation and periodically afterwards, as well as when save operation is performed. Always displays the evaluation dialog on initial licensing validation and periodically afterwards, as well as when save operation is performed.
Watermark | Causes a watermark to be applied to images displayed on screen, saved to stream and sent to a printer. Causes a watermark to be applied to images displayed on screen, saved to stream and sent to a printer.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearEvaluationMode

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearExtraChannelType Enumeration
com.accusoft.imagegear.core Package : ImGearExtraChannelType Enumeration

Glossary Item Box

Specifies all the supported types of extra channels.

Members

Member | Description
Mask | Mask channel.
Spot | Spot channel.
Unknown | Unknown channel.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearExtraChannelType

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearFlipModes Enumeration
com.accusoft.imagegear.core Package : ImGearFlipModes Enumeration

Glossary Item Box

Specifies ImageGear flip modes.

Members

Member | Description
HORIZONTAL | flip around horizontal axis.
VERTICAL | flip around vertical axis.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearFlipModes

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearMaskChannelModes Enumeration
com.accusoft.imagegear.core Package : ImGearMaskChannelModes Enumeration

Glossary Item Box

Specifies whether the color indicates masked or selected area.

Members

Member | Description
ColorIndicatesMaskedArea | Specifies that color indicates masked area.
ColorIndicatesSelectedArea | Specifies that color indicates selected area.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearMaskChannelModes

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearOrientationModes Enumeration
com.accusoft.imagegear.core Package : ImGearOrientationModes Enumeration

Glossary Item Box

Specifies ImageGear orientation modes.

Members

Member | Description
BOTTOM_LEFT | Bottom to the Left orientation.
BOTTOM_RIGHT | Bottom to the Right orientation.
LEFT_BOTTOM | Left to the Bottom orientation.
LEFT_TOP | Left to the Top orientation.
RIGHT_BOTTOM | Right to the Bottom orientation.
RIGHT_TOP | Right to the Top orientation.
TOP_LEFT | Top to the Left orientation.
TOP_RIGHT | Top to the Right orientation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearOrientationModes

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRenderingIntents Enumeration
com.accusoft.imagegear.core Package : ImGearRenderingIntents Enumeration

Glossary Item Box

Lists identifiers that controls how colors are transformed during color space conversion using color profiles.

Members

Member | Description
ABSOLUTE_COLORIMETRIC | Absolute colorimetric, also known as Match intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is preserved.
PERCEPTUAL | Perceptual intent, also known as Picture intent, is the most commonly used intent. It scales all colors in the gamut to fit the new color space, preserving gray balance at the possible expense of colorimetric accuracy.
RELATIVE_COLORIMETRIC | Relative colorimetric intent, also known as Proof intent, changes only the colors that cannot be represented in the new gamut. They are changed to the nearest colors in the new gamut. The white point is not preserved.
SATURATION | Saturation intent, also known as Graphic intent, preserves the saturation of the image at the possible expense of hue and lightness. It is intended for graphics such as charts.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearRenderingIntents

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearResolutionUnits Enumeration
com.accusoft.imagegear.core Package : ImGearResolutionUnits Enumeration

Glossary Item Box

Specifies the measurements of image resolution units.

Members

Member | Description
CENTIMETERS | Centimeters resolution unit.
INCHES | Inches resolution unit.
METERS | Meters resolution unit.
NO_ABS | No absolute resolution unit.
TEN_CENTIMETERS | Ten centimeters resolution unit.
TEN_INCHES | Ten inches resolution unit.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearResolutionUnits

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearRotationValues Enumeration
com.accusoft.imagegear.core Package : ImGearRotationValues Enumeration

Glossary Item Box

Specifies the value of the rotation angle.

Members

Member | Description
VALUE_0 | No rotation.
VALUE_180 | Rotation on 180 grades.
VALUE_270 | Rotation on 270 grades.
VALUE_90 | Rotation on 90 grades.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearRotationValues

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearSeekOrigin Enumeration
com.accusoft.imagegear.core Package : ImGearSeekOrigin Enumeration

Glossary Item Box

Provides the fields that represent reference points in streams for seeking.

Members

Member | Description
BEGIN | To seek from the start of the stream. Accompanied by a positive offset.
CURRENT | To seek from the current position in the stream.
END | To seek from the end of the stream. Accompanied by a negative offset.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearSeekOrigin

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

ImGearSpotColorVendorID Enumeration
com.accusoft.imagegear.core Package : ImGearSpotColorVendorID Enumeration

Glossary Item Box

Specifies all supported vendor IDs.

Members

Member | Description
ANPA | ANPA vendor ID.
DIC | DIC vendor ID.
Focoltone | Focoltone vendor ID.
HKSE | HKSE vendor ID.
HKSEProcess | HKSEProcess vendor ID.
HKSK | HKSK vendor ID.
HKSKProcess | HKSKProcess vendor ID.
HKSN | HKSN vendor ID.
HKSNProcess | HKSNProcess vendor ID.
HKSZ | HKSZ vendor ID.
HKSZProcess | HKSZProcess vendor ID.
PantoneCoated | PantoneCoated vendor ID.
PantoneMatte | PantoneMatte vendor ID.
PantoneMetallic | PantoneMetallic vendor ID.
PantonePastelCoated | PantonePastelCoated vendor ID.
PantonePastelUncoated | PantonePastelUncoated vendor ID.
PantoneProcess | PantoneProcess vendor ID.
PantoneProcessUncoated | PantoneProcessUncoated vendor ID.
PantoneProSlim | PantoneProSlim vendor ID.
PantoneProSlimEuro | PantoneProSlimEuro vendor ID.
PantoneUncoated | PantoneUncoated vendor ID.
SynDIC | DIC group (synonym) vendor ID.
SynFocoltone | Focoltone group (synonym) vendor ID.
SynHKS | HKS group (synonym) vendor ID.
SynPantone | Pantone group (synonym) vendor ID.
SynToyo | Toyo group (synonym) vendor ID.
SynTrumatch | Trumatch group (synonym) vendor ID.
Toyo | Toyo vendor ID.
Trumatch | Trumatch vendor ID.
UserColorBook | Vendor ID reserved for user color books.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.core.ImGearSpotColorVendorID

See Also

Reference

com.accusoft.imagegear.core Package


%%PageItemTitle%%

IImGearAddWarning Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearAddWarning Interface

Glossary Item Box

Specifies the warning processing routine to be called when the warning is added.

Syntax

public interface IImGearAddWarning

See Also

Reference

IImGearAddWarning Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearAddWarning Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearAddWarning Interface

Glossary Item Box

The following tables list the members exposed by IImGearAddWarning.

Public Methods

 | Name | Description
Method | invoke | Override this to handle a warning.
Top

See Also

Reference

IImGearAddWarning Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearAddWarning Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearAddWarning Interface

Glossary Item Box

For a list of all members of this type, see IImGearAddWarning members.

Public Methods

 | Name | Description
Method | invoke | Override this to handle a warning.
Top

See Also

Reference

IImGearAddWarning Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

invoke Method
com.accusoft.imagegear.core Package > IImGearAddWarning Interface : invoke Method
warning
being made.

Glossary Item Box

Override this to handle a warning.

Syntax

void invoke(
   ImGearWarning warning
)

Parameters

warning
being made.

See Also

Reference

IImGearAddWarning Interface
IImGearAddWarning Members


%%PageItemTitle%%

IImGearColorBook Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBook Interface

Glossary Item Box

Defines color book interface.

Syntax

public interface IImGearColorBook

See Also

Reference

IImGearColorBook Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearColorBook Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBook Interface

Glossary Item Box

The following tables list the members exposed by IImGearColorBook.

Public Methods

 | Name | Description
Method | getColors | Gets the array of individual color records held by the color book. Array instances of ImGearColorBookColor class. IImGearColorBookColor
Method | getColorsPerPage | Gets the maximum number of colors that can appear on a page. Integer value.
Method | getColorType | Gets the color space value used for displaying all the colors from the color book. ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs
Method | getDescription | Gets the color book copyright information. String value.
Method | getFileName | Gets the color book file name. String value.
Method | getKeyColorPage | Gets the key color on the page. Integer value.
Method | getNumberOfColors | Gets the number of colors in the color book. Integer value.
Method | getPostfix | Gets the color book postfix string value. String value.
Method | getPrefix | Gets the color book prefix string value. String value.
Method | getTitle | Gets the color book title. String value.
Method | getVendorID | Gets the color book vendor ID value. ImGearSpotColorVendorID enumeration value.
Top

See Also

Reference

IImGearColorBook Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearColorBook Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBook Interface

Glossary Item Box

For a list of all members of this type, see IImGearColorBook members.

Public Methods

 | Name | Description
Method | getColors | Gets the array of individual color records held by the color book. Array instances of ImGearColorBookColor class. IImGearColorBookColor
Method | getColorsPerPage | Gets the maximum number of colors that can appear on a page. Integer value.
Method | getColorType | Gets the color space value used for displaying all the colors from the color book. ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs
Method | getDescription | Gets the color book copyright information. String value.
Method | getFileName | Gets the color book file name. String value.
Method | getKeyColorPage | Gets the key color on the page. Integer value.
Method | getNumberOfColors | Gets the number of colors in the color book. Integer value.
Method | getPostfix | Gets the color book postfix string value. String value.
Method | getPrefix | Gets the color book prefix string value. String value.
Method | getTitle | Gets the color book title. String value.
Method | getVendorID | Gets the color book vendor ID value. ImGearSpotColorVendorID enumeration value.
Top

See Also

Reference

IImGearColorBook Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColors Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getColors Method

Glossary Item Box

Gets the array of individual color records held by the color book.

Array instances of ImGearColorBookColor class. IImGearColorBookColor

Syntax

ImGearColorBookColor[] getColors()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getColorsPerPage Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getColorsPerPage Method

Glossary Item Box

Gets the maximum number of colors that can appear on a page.

Integer value.

Syntax

int getColorsPerPage()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getColorType Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getColorType Method

Glossary Item Box

Gets the color space value used for displaying all the colors from the color book.

ImGearColorSpaceIDs enumeration value. ImGearColorSpaceIDs

Syntax

java.util.EnumSet<ImGearColorSpaceIDs> getColorType()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getDescription Method

Glossary Item Box

Gets the color book copyright information.

String value.

Syntax

java.lang.String getDescription()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getFileName Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getFileName Method

Glossary Item Box

Gets the color book file name.

String value.

Syntax

java.lang.String getFileName()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getKeyColorPage Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getKeyColorPage Method

Glossary Item Box

Gets the key color on the page.

Integer value.

Syntax

int getKeyColorPage()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getNumberOfColors Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getNumberOfColors Method

Glossary Item Box

Gets the number of colors in the color book.

Integer value.

Syntax

int getNumberOfColors()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getPostfix Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getPostfix Method

Glossary Item Box

Gets the color book postfix string value.

String value.

Syntax

java.lang.String getPostfix()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getPrefix Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getPrefix Method

Glossary Item Box

Gets the color book prefix string value.

String value.

Syntax

java.lang.String getPrefix()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getTitle Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getTitle Method

Glossary Item Box

Gets the color book title.

String value.

Syntax

java.lang.String getTitle()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

getVendorID Method
com.accusoft.imagegear.core Package > IImGearColorBook Interface : getVendorID Method

Glossary Item Box

Gets the color book vendor ID value.

ImGearSpotColorVendorID enumeration value.

Syntax

ImGearSpotColorVendorID getVendorID()

See Also

Reference

IImGearColorBook Interface
IImGearColorBook Members


%%PageItemTitle%%

IImGearColorBookColor Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBookColor Interface

Glossary Item Box

Defines color book color interface.

Syntax

public interface IImGearColorBookColor

See Also

Reference

IImGearColorBookColor Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearColorBookColor Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBookColor Interface

Glossary Item Box

The following tables list the members exposed by IImGearColorBookColor.

Public Methods

 | Name | Description
Method | getColorValueCopy | Returns a copy of the color value used for display.
Method | getID | Gets the catalog code of the color. Long value.
Method | getName | Gets the full name of the color. String value.
Top

See Also

Reference

IImGearColorBookColor Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearColorBookColor Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearColorBookColor Interface

Glossary Item Box

For a list of all members of this type, see IImGearColorBookColor members.

Public Methods

 | Name | Description
Method | getColorValueCopy | Returns a copy of the color value used for display.
Method | getID | Gets the catalog code of the color. Long value.
Method | getName | Gets the full name of the color. String value.
Top

See Also

Reference

IImGearColorBookColor Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getColorValueCopy Method
com.accusoft.imagegear.core Package > IImGearColorBookColor Interface : getColorValueCopy Method

Glossary Item Box

Returns a copy of the color value used for display.

Syntax

ImGearPixel getColorValueCopy()

Return Value

ImGearPixel class object.

See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


%%PageItemTitle%%

getID Method
com.accusoft.imagegear.core Package > IImGearColorBookColor Interface : getID Method

Glossary Item Box

Gets the catalog code of the color.

Long value.

Syntax

long getID()

See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > IImGearColorBookColor Interface : getName Method

Glossary Item Box

Gets the full name of the color.

String value.

Syntax

java.lang.String getName()

See Also

Reference

IImGearColorBookColor Interface
IImGearColorBookColor Members


%%PageItemTitle%%

IImGearDICOMDisplaySettings Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearDICOMDisplaySettings Interface

Glossary Item Box

Specifies baseline features for DICOM display settings.

This interface specifies baseline features for DICOM display settings. This interface is declared in the Core package, allowing you to attach DICOM Display settings to ImGearPage class and com.accusoft.imagegear.display.ImGearPageDisplay class. However, DICOM Display Settings are only available when the DICOM component is attached. Cast IImGearDICOMDisplaySettings interface to com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class to access its features.

com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

public interface IImGearDICOMDisplaySettings

See Also

Reference

IImGearDICOMDisplaySettings Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearDICOMDisplaySettings Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearDICOMDisplaySettings Interface

Glossary Item Box

The following tables list the members exposed by IImGearDICOMDisplaySettings.

Public Methods

Name | Description
Method | buildSummaryLUT | Builds a standalone ImGearLUT class object based on the transforms that are present in the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class object.
Method | clone | Creates a deep copy of the object.
Method getDisplaySummaryLUT Gets summary LUT based on all settings of the object.

ImGearLUT class object.

This method concatenates all transforms that are present in a object that implements IImGearDICOMDisplaySettings interface, and builds a summary LUT. Display code does not check any other transforms of the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, it will call method to allow the display to use the changed settings.

ImGearLUT

Method isInverted Gets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Method setInverted Sets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Method | updateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the members.
Top

See Also

Reference

IImGearDICOMDisplaySettings Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearDICOMDisplaySettings Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearDICOMDisplaySettings Interface

Glossary Item Box

For a list of all members of this type, see IImGearDICOMDisplaySettings members.

Public Methods

Name | Description
Method | buildSummaryLUT | Builds a standalone ImGearLUT class object based on the transforms that are present in the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class object.
Method | clone | Creates a deep copy of the object.
Method getDisplaySummaryLUT Gets summary LUT based on all settings of the object.

ImGearLUT class object.

This method concatenates all transforms that are present in a object that implements IImGearDICOMDisplaySettings interface, and builds a summary LUT. Display code does not check any other transforms of the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, it will call method to allow the display to use the changed settings.

ImGearLUT

Method isInverted Gets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Method setInverted Sets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Method | updateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the members.
Top

See Also

Reference

IImGearDICOMDisplaySettings Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

buildSummaryLUT Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : buildSummaryLUT Method
dib
DIB for which the DisplaySummaryLUT is to be built.

Glossary Item Box

Builds a standalone ImGearLUT class object based on the transforms that are present in the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class object.

Syntax

ImGearLUT buildSummaryLUT(
   ImGearDIB dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

Return Value

ImGearLUT object. ImGearDIB ImGearLUT

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

IImGearDICOMDisplaySettings clone()

Return Value

A new instance of com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class object.

This method creates a deep copy of an object that implements IImGearDICOMDisplaySettings interface.

com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

getDisplaySummaryLUT Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : getDisplaySummaryLUT Method

Glossary Item Box

Gets summary LUT based on all settings of the object.

ImGearLUT class object.

This method concatenates all transforms that are present in a object that implements IImGearDICOMDisplaySettings interface, and builds a summary LUT. Display code does not check any other transforms of the com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class, it will call method to allow the display to use the changed settings.

ImGearLUT

Syntax

ImGearLUT getDisplaySummaryLUT()

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

isInverted Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : isInverted Method

Glossary Item Box

Gets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Syntax

boolean isInverted()

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

setInverted Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : setInverted Method
value

Glossary Item Box

Sets a value indicating whether image contrast is inverted.

Boolean value.

This method tells whether the image shall be displayed with inverted contrast. ImageGear sets this method to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this method into account when it builds the summary LUT.

Syntax

void setInverted(
   boolean value
)

Parameters

value

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

updateDisplaySummaryLUT Method
com.accusoft.imagegear.core Package > IImGearDICOMDisplaySettings Interface : updateDisplaySummaryLUT Method
dib
DIB for which the DisplaySummaryLUT is to be built.

This method updates DisplaySummaryLUT based on the transforms that are present in the object that implements IImGearDICOMDisplaySettings interface.

ImGearDIB com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Glossary Item Box

Updates DisplaySummaryLUT with current settings of the members.

Syntax

void updateDisplaySummaryLUT(
   ImGearDIB dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

This method updates DisplaySummaryLUT based on the transforms that are present in the object that implements IImGearDICOMDisplaySettings interface.

ImGearDIB com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

See Also

Reference

IImGearDICOMDisplaySettings Interface
IImGearDICOMDisplaySettings Members


%%PageItemTitle%%

IImGearMetadataDictRecord Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearMetadataDictRecord Interface

Glossary Item Box

Specifies baseline features for a metadata dictionary record.

Syntax

public interface IImGearMetadataDictRecord

See Also

Reference

IImGearMetadataDictRecord Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearMetadataDictRecord Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearMetadataDictRecord Interface

Glossary Item Box

The following tables list the members exposed by IImGearMetadataDictRecord.

Public Methods

 | Name | Description
Method | getName | Gets the Tag name. Any string. The default value is "".
Method | getTag | Gets the Tag ID value. Any integer number. The default value is 0.
Method | setName | Sets the Tag name. Any string. The default value is "".
Method | setTag | Sets the Tag ID value. Any integer number. The default value is 0.
Top

See Also

Reference

IImGearMetadataDictRecord Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearMetadataDictRecord Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearMetadataDictRecord Interface

Glossary Item Box

For a list of all members of this type, see IImGearMetadataDictRecord members.

Public Methods

 | Name | Description
Method | getName | Gets the Tag name. Any string. The default value is "".
Method | getTag | Gets the Tag ID value. Any integer number. The default value is 0.
Method | setName | Sets the Tag name. Any string. The default value is "".
Method | setTag | Sets the Tag ID value. Any integer number. The default value is 0.
Top

See Also

Reference

IImGearMetadataDictRecord Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.core Package > IImGearMetadataDictRecord Interface : getName Method

Glossary Item Box

Gets the Tag name.

Any string.

The default value is "".

Syntax

java.lang.String getName()

See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


%%PageItemTitle%%

getTag Method
com.accusoft.imagegear.core Package > IImGearMetadataDictRecord Interface : getTag Method

Glossary Item Box

Gets the Tag ID value.

Any integer number.

The default value is 0.

Syntax

int getTag()

See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.core Package > IImGearMetadataDictRecord Interface : setName Method
value

Glossary Item Box

Sets the Tag name.

Any string.

The default value is "".

Syntax

void setName(
   java.lang.String value
)

Parameters

value

See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


%%PageItemTitle%%

setTag Method
com.accusoft.imagegear.core Package > IImGearMetadataDictRecord Interface : setTag Method
value

Glossary Item Box

Sets the Tag ID value.

Any integer number.

The default value is 0.

Syntax

void setTag(
   int value
)

Parameters

value

See Also

Reference

IImGearMetadataDictRecord Interface
IImGearMetadataDictRecord Members


%%PageItemTitle%%

IImGearOrientation Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearOrientation Interface

Glossary Item Box

Defines Orientation interface.

Syntax

public interface IImGearOrientation
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged

See Also

Reference

IImGearOrientation Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearOrientation Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearOrientation Interface

Glossary Item Box

The following tables list the members exposed by IImGearOrientation.

Public Methods

 | Name | Description
Method | flip | Changes orientation to flip image.
Method | getValue | Gets orientation identifier. Any of ImGearOrientationModes enumerationvalues.
Method | rotate | Changes orientation to rotate image.
Method | setToDefault | Resets orientation to default (top-left) state.
Method | setValue | Sets orientation identifier. Any of ImGearOrientationModes enumerationvalues.
Top

See Also

Reference

IImGearOrientation Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearOrientation Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearOrientation Interface

Glossary Item Box

For a list of all members of this type, see IImGearOrientation members.

Public Methods

 | Name | Description
Method | flip | Changes orientation to flip image.
Method | getValue | Gets orientation identifier. Any of ImGearOrientationModes enumerationvalues.
Method | rotate | Changes orientation to rotate image.
Method | setToDefault | Resets orientation to default (top-left) state.
Method | setValue | Sets orientation identifier. Any of ImGearOrientationModes enumerationvalues.
Top

See Also

Reference

IImGearOrientation Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

flip Method
com.accusoft.imagegear.core Package > IImGearOrientation Interface : flip Method
flipMode
Specifies how to flip orientation. ImGearFlipModes

Glossary Item Box

Changes orientation to flip image.

Syntax

void flip(
   ImGearFlipModes flipMode
)

Parameters

flipMode
Specifies how to flip orientation. ImGearFlipModes

See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.core Package > IImGearOrientation Interface : getValue Method

Glossary Item Box

Gets orientation identifier.

Any of ImGearOrientationModes enumerationvalues.

Syntax

ImGearOrientationModes getValue()

See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%%

rotate Method
com.accusoft.imagegear.core Package > IImGearOrientation Interface : rotate Method
rotationValue
Specifies how to rotate orientation. ImGearRotationValues

Glossary Item Box

Changes orientation to rotate image.

Syntax

void rotate(
   ImGearRotationValues rotationValue
)

Parameters

rotationValue
Specifies how to rotate orientation. ImGearRotationValues

See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%%

setToDefault Method
com.accusoft.imagegear.core Package > IImGearOrientation Interface : setToDefault Method

Glossary Item Box

Resets orientation to default (top-left) state.

Syntax

void setToDefault()

See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.core Package > IImGearOrientation Interface : setValue Method
value

Glossary Item Box

Sets orientation identifier.

Any of ImGearOrientationModes enumerationvalues.

Syntax

void setValue(
   ImGearOrientationModes value
)

Parameters

value

See Also

Reference

IImGearOrientation Interface
IImGearOrientation Members


%%PageItemTitle%%

IImGearResolution Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearResolution Interface

Glossary Item Box

Represents image resolution interface.

Syntax

public interface IImGearResolution

See Also

Reference

IImGearResolution Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearResolution Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearResolution Interface

Glossary Item Box

The following tables list the members exposed by IImGearResolution.

Public Methods

 | Name | Description
Method | convertUnits | Converts resolution data into new units.
Method | getUnits | Gets resolution units. ImGearResolutionUnits enumeration.
Method | getXDenominator | Gets denominator of the X component of the resolution. Int32 value.
Method | getXNumerator | Gets numerator of the X component of the resolution. Int32 value.
Method | getYDenominator | Gets denominator of the Y component of the resolution. Int32 value.
Method | getYNumerator | Gets numerator of the Y component of the resolution. Int32 value.
Method | setUnits | Ð«ets resolution units. ImGearResolutionUnits enumeration.
Method | setXDenominator | Sets denominator of the X component of the resolution. Int32 value.
Method | setXNumerator | Sets numerator of the X component of the resolution. Int32 value.
Method | setYDenominator | Sets denominator of the Y component of the resolution. Int32 value.
Method | setYNumerator | Sets numerator of the Y component of the resolution. Int32 value.
Top

See Also

Reference

IImGearResolution Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearResolution Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearResolution Interface

Glossary Item Box

For a list of all members of this type, see IImGearResolution members.

Public Methods

 | Name | Description
Method | convertUnits | Converts resolution data into new units.
Method | getUnits | Gets resolution units. ImGearResolutionUnits enumeration.
Method | getXDenominator | Gets denominator of the X component of the resolution. Int32 value.
Method | getXNumerator | Gets numerator of the X component of the resolution. Int32 value.
Method | getYDenominator | Gets denominator of the Y component of the resolution. Int32 value.
Method | getYNumerator | Gets numerator of the Y component of the resolution. Int32 value.
Method | setUnits | Ð«ets resolution units. ImGearResolutionUnits enumeration.
Method | setXDenominator | Sets denominator of the X component of the resolution. Int32 value.
Method | setXNumerator | Sets numerator of the X component of the resolution. Int32 value.
Method | setYDenominator | Sets denominator of the Y component of the resolution. Int32 value.
Method | setYNumerator | Sets numerator of the Y component of the resolution. Int32 value.
Top

See Also

Reference

IImGearResolution Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

convertUnits Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : convertUnits Method
newUnits
New resolution units.

Glossary Item Box

Converts resolution data into new units.

Syntax

void convertUnits(
   ImGearResolutionUnits newUnits
)

Parameters

newUnits
New resolution units.

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

getUnits Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : getUnits Method

Glossary Item Box

Gets resolution units.

ImGearResolutionUnits enumeration.

Syntax

ImGearResolutionUnits getUnits()

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

getXDenominator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : getXDenominator Method

Glossary Item Box

Gets denominator of the X component of the resolution.

Int32 value.

Syntax

int getXDenominator()

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

getXNumerator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : getXNumerator Method

Glossary Item Box

Gets numerator of the X component of the resolution.

Int32 value.

Syntax

int getXNumerator()

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

getYDenominator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : getYDenominator Method

Glossary Item Box

Gets denominator of the Y component of the resolution.

Int32 value.

Syntax

int getYDenominator()

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

getYNumerator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : getYNumerator Method

Glossary Item Box

Gets numerator of the Y component of the resolution.

Int32 value.

Syntax

int getYNumerator()

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

setUnits Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : setUnits Method
value

Glossary Item Box

Ð«ets resolution units.

ImGearResolutionUnits enumeration.

Syntax

void setUnits(
   ImGearResolutionUnits value
)

Parameters

value

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

setXDenominator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : setXDenominator Method
value

Glossary Item Box

Sets denominator of the X component of the resolution.

Int32 value.

Syntax

void setXDenominator(
   int value
)

Parameters

value

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

setXNumerator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : setXNumerator Method
value

Glossary Item Box

Sets numerator of the X component of the resolution.

Int32 value.

Syntax

void setXNumerator(
   int value
)

Parameters

value

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

setYDenominator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : setYDenominator Method
value

Glossary Item Box

Sets denominator of the Y component of the resolution.

Int32 value.

Syntax

void setYDenominator(
   int value
)

Parameters

value

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

setYNumerator Method
com.accusoft.imagegear.core Package > IImGearResolution Interface : setYNumerator Method
value

Glossary Item Box

Sets numerator of the Y component of the resolution.

Int32 value.

Syntax

void setYNumerator(
   int value
)

Parameters

value

See Also

Reference

IImGearResolution Interface
IImGearResolution Members


%%PageItemTitle%%

IImGearRGBQuad Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearRGBQuad Interface

Glossary Item Box

Defines palette entry interface.

Syntax

public interface IImGearRGBQuad
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged

See Also

Reference

IImGearRGBQuad Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearRGBQuad Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearRGBQuad Interface

Glossary Item Box

The following tables list the members exposed by IImGearRGBQuad.

Public Methods

 | Name | Description
Method | getBlue | Gets blue value. Blue color value.
Method | getGreen | Gets green value. Green color value.
Method | getRed | Gets red value. Red color value.
Method | getReserved | Gets reserved value. Reserved color value.
Method | setBlue | Sets blue value. Blue color value.
Method | setGreen | Sets green value. Green color value.
Method | setRed | Sets red value. Red color value.
Method | setReserved | Sets reserved value. Reserved color value.
Top

See Also

Reference

IImGearRGBQuad Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearRGBQuad Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearRGBQuad Interface

Glossary Item Box

For a list of all members of this type, see IImGearRGBQuad members.

Public Methods

 | Name | Description
Method | getBlue | Gets blue value. Blue color value.
Method | getGreen | Gets green value. Green color value.
Method | getRed | Gets red value. Red color value.
Method | getReserved | Gets reserved value. Reserved color value.
Method | setBlue | Sets blue value. Blue color value.
Method | setGreen | Sets green value. Green color value.
Method | setRed | Sets red value. Red color value.
Method | setReserved | Sets reserved value. Reserved color value.
Top

See Also

Reference

IImGearRGBQuad Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getBlue Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : getBlue Method

Glossary Item Box

Gets blue value.

Blue color value.

Syntax

short getBlue()

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

getGreen Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : getGreen Method

Glossary Item Box

Gets green value.

Green color value.

Syntax

short getGreen()

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

getRed Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : getRed Method

Glossary Item Box

Gets red value.

Red color value.

Syntax

short getRed()

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

getReserved Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : getReserved Method

Glossary Item Box

Gets reserved value.

Reserved color value.

Syntax

short getReserved()

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

setBlue Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : setBlue Method
value

Glossary Item Box

Sets blue value.

Blue color value.

Syntax

void setBlue(
   short value
)

Parameters

value

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

setGreen Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : setGreen Method
value

Glossary Item Box

Sets green value.

Green color value.

Syntax

void setGreen(
   short value
)

Parameters

value

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

setRed Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : setRed Method
value

Glossary Item Box

Sets red value.

Red color value.

Syntax

void setRed(
   short value
)

Parameters

value

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

setReserved Method
com.accusoft.imagegear.core Package > IImGearRGBQuad Interface : setReserved Method
value

Glossary Item Box

Sets reserved value.

Reserved color value.

Syntax

void setReserved(
   short value
)

Parameters

value

See Also

Reference

IImGearRGBQuad Interface
IImGearRGBQuad Members


%%PageItemTitle%%

IImGearSize Interface
See Also Members Send Feedback
com.accusoft.imagegear.core Package : IImGearSize Interface

Glossary Item Box

Defines Size interface.

Syntax

public interface IImGearSize

See Also

Reference

IImGearSize Members
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearSize Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core Package : IImGearSize Interface

Glossary Item Box

The following tables list the members exposed by IImGearSize.

Public Methods

 | Name | Description
Method | getcX | Gets the X size. Any integer value.
Method | getcY | Gets the Y size. Any integer value.
Method | setcX | Sets the X size. Any integer value.
Method | setcY | Sets the X size. Any integer value.
Top

See Also

Reference

IImGearSize Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearSize Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core Package : IImGearSize Interface

Glossary Item Box

For a list of all members of this type, see IImGearSize members.

Public Methods

 | Name | Description
Method | getcX | Gets the X size. Any integer value.
Method | getcY | Gets the Y size. Any integer value.
Method | setcX | Sets the X size. Any integer value.
Method | setcY | Sets the X size. Any integer value.
Top

See Also

Reference

IImGearSize Interface
com.accusoft.imagegear.core Package


%%PageItemTitle%%

getcX Method
com.accusoft.imagegear.core Package > IImGearSize Interface : getcX Method

Glossary Item Box

Gets the X size.

Any integer value.

Syntax

int getcX()

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

getcY Method
com.accusoft.imagegear.core Package > IImGearSize Interface : getcY Method

Glossary Item Box

Gets the Y size.

Any integer value.

Syntax

int getcY()

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

setcX Method
com.accusoft.imagegear.core Package > IImGearSize Interface : setcX Method
value

Glossary Item Box

Sets the X size.

Any integer value.

Syntax

void setcX(
   int value
)

Parameters

value

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

setcY Method
com.accusoft.imagegear.core Package > IImGearSize Interface : setcY Method
value

Glossary Item Box

Sets the X size.

Any integer value.

Syntax

void setcY(
   int value
)

Parameters

value

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%ItemTitle%%

com.accusoft.imagegear.core.shapes Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the various shape and point types available.

Classes

Class | Description
ImGearDoublePoint | Stores a set of two double precision numbers that represent the point.
ImGearDoubleRectangle | Stores a set of four double precision numbers that represent the location and size of a rectangle.
ImGearEllipse | Stores a set of two ImGear values that represent the location and size of an ellipse. The center of the ellipse is the center of the specified bounding rectangle.
ImGearPoint | Encapsulates a point in a 2-D coordinate system.
ImGearPolygon | Defines a polygon shape. Represents a polygon, i.e., a 2D shape defined by two or more points sequentilly connected by straight lines.
ImGearRect | Stores a set of four integer numbers that represent the location and size of the rectangle.
ImGearRectangle | Stores a set of four integer numbers that represent the location and size of a rectangle. Stores a set of API that represent the rectangle.
ImGearRoundedRectangle | This structure represents a rounded rectangle.

Interfaces

Interface | Description
IImGearDoublePoint | Defines DoublePoint interface.
IImGearDoubleRectangle | Defines DoubleRectangle interface.
IImGearEllipse | Defines Ellipse interface.
IImGearPoint | Defines Point interface.
IImGearRectangle | Defines IImGearRectangle interface.
IImGearRoundedRectangle | Represents a rounded rectangle.
IImGearShape | Defines Shape interface.
IImGearSize | Defines Size interface.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.core.shapes Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.core.shapes.ImGearDoublePoint
com.accusoft.imagegear.core.shapes.ImGearDoubleRectangle
com.accusoft.imagegear.core.shapes.ImGearEllipse
com.accusoft.imagegear.core.shapes.ImGearPoint
com.accusoft.imagegear.core.shapes.ImGearPolygon
com.accusoft.imagegear.core.shapes.ImGearRect
com.accusoft.imagegear.core.shapes.ImGearRoundedRectangle

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearDoublePoint Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoublePoint Class

Glossary Item Box

Stores a set of two double precision numbers that represent the point.

Object Model

ImGearDoublePoint Class

Syntax

public sealed class ImGearDoublePoint
    extends Object
    implements IImGearDoublePoint

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearDoublePoint

See Also

Reference

ImGearDoublePoint Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDoublePoint Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoublePoint Class

Glossary Item Box

The following tables list the members exposed by ImGearDoublePoint.

Public Constructors

 | Name | Description
public Constructor | ImGearDoublePoint Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getX | Gets X coordinate of the point. Any double value. The default value is 0.
public Method | getY | Gets Y coordinate of the point. Any double value. The default value is 0.
public Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
public Method | setX | Sets X coordinate of the point. Any double value. The default value is 0.
public Method | setY | Sets Y coordinate of the point. Any double value. The default value is 0.
Top

See Also

Reference

ImGearDoublePoint Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearDoublePoint Constructor
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : ImGearDoublePoint Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearDoublePoint Constructor(IImGearDoublePoint) | Initializes a new instance of the ImGearDoublePoint struct.
ImGearDoublePoint Constructor(double,double) | Initializes a new instance of the ImGearDoublePoint struct.

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

ImGearDoublePoint Constructor(IImGearDoublePoint)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class > ImGearDoublePoint Constructor : ImGearDoublePoint Constructor(IImGearDoublePoint)
point
IImGearDoublePoint interface.

Glossary Item Box

Initializes a new instance of the ImGearDoublePoint struct.

Syntax

public ImGearDoublePoint(
   IImGearDoublePoint point
)

Parameters

point
IImGearDoublePoint interface.

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members
Overload List


%%PageItemTitle%%

ImGearDoublePoint Constructor(double,double)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class > ImGearDoublePoint Constructor : ImGearDoublePoint Constructor(double,double)
pointX
X coordinate.
pointY
Y coordinate.

Glossary Item Box

Initializes a new instance of the ImGearDoublePoint struct.

Syntax

public ImGearDoublePoint(
   double pointX,
   double pointY
)

Parameters

pointX
X coordinate.
pointY
Y coordinate.

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDoublePoint Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoublePoint Class

Glossary Item Box

For a list of all members of this type, see ImGearDoublePoint members.

Public Methods

 | Name | Description
public Method | getX | Gets X coordinate of the point. Any double value. The default value is 0.
public Method | getY | Gets Y coordinate of the point. Any double value. The default value is 0.
public Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
public Method | setX | Sets X coordinate of the point. Any double value. The default value is 0.
public Method | setY | Sets Y coordinate of the point. Any double value. The default value is 0.
Top

See Also

Reference

ImGearDoublePoint Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : getX Method

Glossary Item Box

Gets X coordinate of the point.

Any double value.

The default value is 0.

Syntax

public double getX()

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : getY Method

Glossary Item Box

Gets Y coordinate of the point.

Any double value.

The default value is 0.

Syntax

public double getY()

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : offset Method
offsetX
X coordinate.
offsetY
Y coordinate.

Glossary Item Box

Shifts the points coordinates by the specified coordinateX and coordinateY values.

Syntax

public void offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
X coordinate.
offsetY
Y coordinate.

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : setX Method
value

Glossary Item Box

Sets X coordinate of the point.

Any double value.

The default value is 0.

Syntax

public void setX(
   double value
)

Parameters

value

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.core.shapes Package > ImGearDoublePoint Class : setY Method
value

Glossary Item Box

Sets Y coordinate of the point.

Any double value.

The default value is 0.

Syntax

public void setY(
   double value
)

Parameters

value

See Also

Reference

ImGearDoublePoint Class
ImGearDoublePoint Members


%%PageItemTitle%%

ImGearDoubleRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoubleRectangle Class

Glossary Item Box

Stores a set of four double precision numbers that represent the location and size of a rectangle.

Object Model

ImGearDoubleRectangle Class

Syntax

public sealed class ImGearDoubleRectangle
    extends Object
    implements IImGearDoubleRectangle

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearDoubleRectangle

See Also

Reference

ImGearDoubleRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDoubleRectangle Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoubleRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearDoubleRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearDoubleRectangle Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | copyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
public Method | empty | Sets all numeric properties of the rectangle to their initial values.
public Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | getHeight | Gets the height of the rectangle. Any double precision number. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | getWidth | Gets the width of the rectangle. Any double precision number. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
public Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
public Method | isWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
public Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
public Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Top

See Also

Reference

ImGearDoubleRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearDoubleRectangle Constructor
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : ImGearDoubleRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearDoubleRectangle Constructor(double,double) | Initializes a new instance of the ImGearDoubleRectangle struct.
ImGearDoubleRectangle Constructor(double,double,double,double) | Initializes a new instance of the ImGearDoubleRectangle struct.
ImGearDoubleRectangle Constructor(IImGearDoubleRectangle) | Initializes a new instance of the ImGearDoubleRectangle struct.
ImGearDoubleRectangle Constructor() | Default constructor.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(double,double)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(double,double)
width
Width of the rectangle.
height
Height of the rectangle.

Glossary Item Box

Initializes a new instance of the ImGearDoubleRectangle struct.

Syntax

public ImGearDoubleRectangle(
   double width,
   double height
)

Parameters

width
Width of the rectangle.
height
Height of the rectangle.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(double,double,double,double)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(double,double,double,double)
left
X coordinate of left-top rectangular point.
top
Y coordinate of left-top rectangular point.
width
Width of the rectangle.
height
Height of the rectangle.

Glossary Item Box

Initializes a new instance of the ImGearDoubleRectangle struct.

Syntax

public ImGearDoubleRectangle(
   double left,
   double top,
   double width,
   double height
)

Parameters

left
X coordinate of left-top rectangular point.
top
Y coordinate of left-top rectangular point.
width
Width of the rectangle.
height
Height of the rectangle.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%%

ImGearDoubleRectangle Constructor(IImGearDoubleRectangle)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor(IImGearDoubleRectangle)
rect
IImGearDoubleRectangle interface.

Glossary Item Box

Initializes a new instance of the ImGearDoubleRectangle struct.

Syntax

public ImGearDoubleRectangle(
   IImGearDoubleRectangle rect
)

Parameters

rect
IImGearDoubleRectangle interface.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%%

ImGearDoubleRectangle Constructor()
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class > ImGearDoubleRectangle Constructor : ImGearDoubleRectangle Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearDoubleRectangle()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDoubleRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearDoubleRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearDoubleRectangle members.

Public Methods

 | Name | Description
public Method | copyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
public Method | empty | Sets all numeric properties of the rectangle to their initial values.
public Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | getHeight | Gets the height of the rectangle. Any double precision number. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | getWidth | Gets the width of the rectangle. Any double precision number. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
public Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
public Method | isWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
public Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
public Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
public Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
public Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Top

See Also

Reference

ImGearDoubleRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : copyFrom Method
rect
Rectangle to copy.

Glossary Item Box

This method copies rectangle from IImGearDoubleRectangle interface.

Syntax

public void copyFrom(
   IImGearDoubleRectangle rect
)

Parameters

rect
Rectangle to copy.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

empty Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : empty Method

Glossary Item Box

Sets all numeric properties of the rectangle to their initial values.

Syntax

public void empty()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getBottom Method

Glossary Item Box

Gets the y-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

public double getBottom()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Any double precision number.

Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Syntax

public double getHeight()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getLeft Method

Glossary Item Box

Gets the x-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

public double getLeft()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getRight Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

public double getRight()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getTop Method

Glossary Item Box

Gets the y-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

public double getTop()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : getWidth Method

Glossary Item Box

Gets the width of the rectangle.

Any double precision number.

Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth return value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Syntax

public double getWidth()

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

intersect Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : intersect Method
rect
Double rectangle.

Glossary Item Box

Checks whether or not the rectangle is intersected with the specified rectangle.

Syntax

public boolean intersect(
   IImGearDoubleRectangle rect
)

Parameters

rect
Double rectangle.

Return Value

Boolean value.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : isEmpty Method

Glossary Item Box

Tests whether all numeric properties of the rectangle have their initial values.

Syntax

public boolean isEmpty()

Return Value

Boolean value.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

isWellFormed Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : isWellFormed Method

Glossary Item Box

Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.

Syntax

public boolean isWellFormed()

Return Value

Boolean value.

This method checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : offset Method
offsetX
The X shift value.
offsetY
The Y shift value.

Glossary Item Box

Shifts the rectangle points by the specified shiftX and shiftY values.

Syntax

public void offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

setBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : setBottom Method
value

Glossary Item Box

Sets the y-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

public void setBottom(
   double value
)

Parameters

value

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

setLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : setLeft Method
value

Glossary Item Box

Sets the x-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

public void setLeft(
   double value
)

Parameters

value

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

setRight Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : setRight Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

public void setRight(
   double value
)

Parameters

value

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

setTop Method
com.accusoft.imagegear.core.shapes Package > ImGearDoubleRectangle Class : setTop Method
value

Glossary Item Box

Sets the y-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

public void setTop(
   double value
)

Parameters

value

See Also

Reference

ImGearDoubleRectangle Class
ImGearDoubleRectangle Members


%%PageItemTitle%%

ImGearEllipse Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearEllipse Class

Glossary Item Box

Stores a set of two ImGear values that represent the location and size of an ellipse.

The center of the ellipse is the center of the specified bounding rectangle.

Object Model

ImGearEllipse ClassImGearPoint ClassImGearPoint Class

Syntax

public sealed class ImGearEllipse
    extends Object
    implements IImGearEllipse

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearEllipse

See Also

Reference

ImGearEllipse Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEllipse Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearEllipse Class

Glossary Item Box

The following tables list the members exposed by ImGearEllipse.

Public Constructors

 | Name | Description
public Constructor | ImGearEllipse Constructor | Default constructor.
Top

Public Methods

 | Name | Description
public Method | getLeftTop | Gets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint structure.
public Method | getRightBottom | Gets the coordinate of the lower-right corner of the bounding rectangle. ImGearPoint structure.
public Method | setLeftTop | Sets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint structure.
public Method | setRightBottom | Sets the coordinate of the lower-right corner of the bounding rectangle. ImGearPoint structure.
Top

See Also

Reference

ImGearEllipse Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearEllipse Constructor
com.accusoft.imagegear.core.shapes Package > ImGearEllipse Class : ImGearEllipse Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearEllipse()

See Also

Reference

ImGearEllipse Class
ImGearEllipse Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEllipse Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearEllipse Class

Glossary Item Box

For a list of all members of this type, see ImGearEllipse members.

Public Methods

 | Name | Description
public Method | getLeftTop | Gets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint structure.
public Method | getRightBottom | Gets the coordinate of the lower-right corner of the bounding rectangle. ImGearPoint structure.
public Method | setLeftTop | Sets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint structure.
public Method | setRightBottom | Sets the coordinate of the lower-right corner of the bounding rectangle. ImGearPoint structure.
Top

See Also

Reference

ImGearEllipse Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getLeftTop Method
com.accusoft.imagegear.core.shapes Package > ImGearEllipse Class : getLeftTop Method

Glossary Item Box

Gets the coordinate of the upper-left corner of the bounding rectangle.

ImGearPoint structure.

Syntax

public ImGearPoint getLeftTop()

See Also

Reference

ImGearEllipse Class
ImGearEllipse Members


%%PageItemTitle%%

getRightBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearEllipse Class : getRightBottom Method

Glossary Item Box

Gets the coordinate of the lower-right corner of the bounding rectangle.

ImGearPoint structure.

Syntax

public ImGearPoint getRightBottom()

See Also

Reference

ImGearEllipse Class
ImGearEllipse Members


%%PageItemTitle%%

setLeftTop Method
com.accusoft.imagegear.core.shapes Package > ImGearEllipse Class : setLeftTop Method
value

Glossary Item Box

Sets the coordinate of the upper-left corner of the bounding rectangle.

ImGearPoint structure.

Syntax

public void setLeftTop(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearEllipse Class
ImGearEllipse Members


%%PageItemTitle%%

setRightBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearEllipse Class : setRightBottom Method
value

Glossary Item Box

Sets the coordinate of the lower-right corner of the bounding rectangle.

ImGearPoint structure.

Syntax

public void setRightBottom(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearEllipse Class
ImGearEllipse Members


%%PageItemTitle%%

ImGearPoint Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPoint Class

Glossary Item Box

Encapsulates a point in a 2-D coordinate system.

Object Model

ImGearPoint ClassImGearPoint Class

Syntax

public sealed class ImGearPoint
    extends Object
    implements IImGearPoint

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearPoint

See Also

Reference

ImGearPoint Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPoint Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPoint Class

Glossary Item Box

The following tables list the members exposed by ImGearPoint.

Public Constructors

 | Name | Description
public Constructor | ImGearPoint Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getX | Gets the x-coordinate of the point. Any integer value.
public Method | getY | Gets the y-coordinate of the point. Any integer value.
public Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
public Method | setX | Sets the x-coordinate of the point. Any integer value.
public Method | setY | Sets the y-coordinate of the point. Any integer value.
static (Shared in Visual Basic) | vectorAsPoint | Produces a point that can be treated as a vector from p1 to p2.
Top

See Also

Reference

ImGearPoint Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearPoint Constructor
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : ImGearPoint Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearPoint Constructor(IImGearPoint) | Initializes a new instance of the ImGearPoint struct.
ImGearPoint Constructor() | Default constructor.
ImGearPoint Constructor(int,int) | Initializes a new instance of the ImGearPoint struct.

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

ImGearPoint Constructor(IImGearPoint)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class > ImGearPoint Constructor : ImGearPoint Constructor(IImGearPoint)
point
An IImGearPoint interface to copy.

Glossary Item Box

Initializes a new instance of the ImGearPoint struct.

Syntax

public ImGearPoint(
   IImGearPoint point
)

Parameters

point
An IImGearPoint interface to copy.

See Also

Reference

ImGearPoint Class
ImGearPoint Members
Overload List


%%PageItemTitle%%

ImGearPoint Constructor()
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class > ImGearPoint Constructor : ImGearPoint Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearPoint()

See Also

Reference

ImGearPoint Class
ImGearPoint Members
Overload List


%%PageItemTitle%%

ImGearPoint Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class > ImGearPoint Constructor : ImGearPoint Constructor(int,int)
pointX
X coordinate.
pointY
Y coordinate.

Glossary Item Box

Initializes a new instance of the ImGearPoint struct.

Syntax

public ImGearPoint(
   int pointX,
   int pointY
)

Parameters

pointX
X coordinate.
pointY
Y coordinate.

See Also

Reference

ImGearPoint Class
ImGearPoint Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPoint Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPoint Class

Glossary Item Box

For a list of all members of this type, see ImGearPoint members.

Public Methods

 | Name | Description
public Method | getX | Gets the x-coordinate of the point. Any integer value.
public Method | getY | Gets the y-coordinate of the point. Any integer value.
public Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
public Method | setX | Sets the x-coordinate of the point. Any integer value.
public Method | setY | Sets the y-coordinate of the point. Any integer value.
static (Shared in Visual Basic) | vectorAsPoint | Produces a point that can be treated as a vector from p1 to p2.
Top

See Also

Reference

ImGearPoint Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : getX Method

Glossary Item Box

Gets the x-coordinate of the point.

Any integer value.

Syntax

public int getX()

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : getY Method

Glossary Item Box

Gets the y-coordinate of the point.

Any integer value.

Syntax

public int getY()

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : offset Method
offsetX
The x coordinate value.
offsetY
The y coordinate value.

This method shifts the points coordinates by the specified dx and dy values.

Glossary Item Box

Shifts the points coordinates by the specified coordinateX and coordinateY values.

Syntax

public void offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The x coordinate value.
offsetY
The y coordinate value.

This method shifts the points coordinates by the specified dx and dy values.

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : setX Method
value

Glossary Item Box

Sets the x-coordinate of the point.

Any integer value.

Syntax

public void setX(
   int value
)

Parameters

value

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : setY Method
value

Glossary Item Box

Sets the y-coordinate of the point.

Any integer value.

Syntax

public void setY(
   int value
)

Parameters

value

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

vectorAsPoint Method
com.accusoft.imagegear.core.shapes Package > ImGearPoint Class : vectorAsPoint Method
p1
Starting point.
p2
End point.

Glossary Item Box

Produces a point that can be treated as a vector from p1 to p2.

Syntax

public static ImGearPoint vectorAsPoint(
   ImGearPoint p1,
   ImGearPoint p2
)

Parameters

p1
Starting point.
p2
End point.

Return Value

Point instance.

See Also

Reference

ImGearPoint Class
ImGearPoint Members


%%PageItemTitle%%

ImGearPolygon Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPolygon Class

Glossary Item Box

Defines a polygon shape.

Represents a polygon, i.e., a 2D shape defined by two or more points sequentilly connected by straight lines.

Object Model

ImGearPolygon Class

Syntax

public class ImGearPolygon
    extends Object
    implements IImGearShape

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearPolygon

See Also

Reference

ImGearPolygon Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPolygon Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPolygon Class

Glossary Item Box

The following tables list the members exposed by ImGearPolygon.

Public Constructors

 | Name | Description
public Constructor | ImGearPolygon Constructor | Initializes a new instance of the ImGearPolygon class object.
Top

Public Fields

 | Name | Description
public Field | points | Array of points that define polygon structure. Array of ImGearPoint structure objects or null.
Top

See Also

Reference

ImGearPolygon Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearPolygon Constructor
com.accusoft.imagegear.core.shapes Package > ImGearPolygon Class : ImGearPolygon Constructor

Glossary Item Box

Initializes a new instance of the ImGearPolygon class object.

Syntax

public ImGearPolygon()

See Also

Reference

ImGearPolygon Class
ImGearPolygon Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPolygon Class Fields
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearPolygon Class

Glossary Item Box

For a list of all members of this type, see ImGearPolygon members.

Public Fields

 | Name | Description
public Field | points | Array of points that define polygon structure. Array of ImGearPoint structure objects or null.
Top

See Also

Reference

ImGearPolygon Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

points Field
com.accusoft.imagegear.core.shapes Package > ImGearPolygon Class : points Field

Glossary Item Box

Array of points that define polygon structure.

Array of ImGearPoint structure objects or null.

Syntax

public ImGearPoint[] points

Return Value

Array of ImGearPoint structure objects or null.

See Also

Reference

ImGearPolygon Class
ImGearPolygon Members


%%PageItemTitle%%

ImGearRect Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRect Class

Glossary Item Box

Stores a set of four integer numbers that represent the location and size of the rectangle.

Object Model

ImGearRect ClassImGearRect Class

Syntax

public sealed class ImGearRect
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearRect

See Also

Reference

ImGearRect Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRect Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRect Class

Glossary Item Box

The following tables list the members exposed by ImGearRect.

Public Constructors

 | Name | Description
public Constructor | ImGearRect Constructor | Default constructor.
Top

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getBottom Gets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method getLeft Gets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method getRight Gets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method getTop Returns the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method setBottom Sets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method setLeft Sets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method setRight Sets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method setTop Sets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Top

See Also

Reference

ImGearRect Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearRect Constructor
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : ImGearRect Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearRect()

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRect Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRect Class

Glossary Item Box

For a list of all members of this type, see ImGearRect members.

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

public Method getBottom Gets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method getLeft Gets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method getRight Gets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method getTop Returns the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method setBottom Sets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method setLeft Sets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

public Method setRight Sets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

public Method setTop Sets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Top

See Also

Reference

ImGearRect Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearRect clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearRect Class
ImGearRect Members
java.lang.Cloneable


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : getBottom Method

Glossary Item Box

Gets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public IntPtr getBottom()

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : getLeft Method

Glossary Item Box

Gets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public IntPtr getLeft()

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : getRight Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public IntPtr getRight()

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : getTop Method

Glossary Item Box

Returns the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public IntPtr getTop()

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

setBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : setBottom Method
value

Glossary Item Box

Sets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public void setBottom(
   IntPtr value
)

Parameters

value

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

setLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : setLeft Method
value

Glossary Item Box

Sets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public void setLeft(
   IntPtr value
)

Parameters

value

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

setRight Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : setRight Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public void setRight(
   IntPtr value
)

Parameters

value

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

setTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRect Class : setTop Method
value

Glossary Item Box

Sets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public void setTop(
   IntPtr value
)

Parameters

value

See Also

Reference

ImGearRect Class
ImGearRect Members


%%PageItemTitle%%

ImGearRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRectangle Class

Glossary Item Box

Stores a set of four integer numbers that represent the location and size of a rectangle.

Stores a set of API that represent the rectangle.

Object Model

ImGearRectangle Class

Syntax

public sealed class ImGearRectangle
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements IImGearRectangle

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRectangle Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearRectangle Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | contains | Checks if the specified point's coordinates are inside of the rectangle.
public Method | copyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
public Method | empty | Sets all numeric properties of the rectangle to their initial values.
public Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | getHeight | Gets the height of the rectangle. Any integer value. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | getWidth | Gets the width of the rectangle. Any integer value. Note: The Height and Width properties assume that the rectangle is being used with endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | intersect | Replaces this rectangle with the intersection of itself and another rectangle.
public Method | isEmpty | Tests whether all numeric properties of the rectangle are set to their initial values.
public Method | isWellFormed | Tests whether the rectangle is valid.
public Method | join | Changes the rectangle's points to contain the specified point.
public Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
public Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Top

See Also

Reference

ImGearRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRectangle Class Fields
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearRectangle members.

See Also

Reference

ImGearRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearRectangle Constructor
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : ImGearRectangle Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRectangle Constructor() | Default constructor.
ImGearRectangle Constructor(int,int) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(int,int,int,int) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(IImGearRectangle) | Initializes a new instance of the ImGearRectangle struct.
ImGearRectangle Constructor(IImGearPoint,IImGearPoint) | Initializes a new instance of the ImGearRectangle struct.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

ImGearRectangle Constructor()
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class > ImGearRectangle Constructor : ImGearRectangle Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearRectangle()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class > ImGearRectangle Constructor : ImGearRectangle Constructor(int,int)
width
Width of a rectangle.
height
Height of a rectangle.

Glossary Item Box

Initializes a new instance of the ImGearRectangle struct.

Syntax

public ImGearRectangle(
   int width,
   int height
)

Parameters

width
Width of a rectangle.
height
Height of a rectangle.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(int,int,int,int)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class > ImGearRectangle Constructor : ImGearRectangle Constructor(int,int,int,int)
left
X-coordinate of the upper-left corner of a rectangle.
top
Y-coordinate of the upper-left corner of a rectangle.
width
X-coordinate of the lower-right corner of a rectangle.
height
Y-coordinate of the lower-right corner of a rectangle.

Glossary Item Box

Initializes a new instance of the ImGearRectangle struct.

Syntax

public ImGearRectangle(
   int left,
   int top,
   int width,
   int height
)

Parameters

left
X-coordinate of the upper-left corner of a rectangle.
top
Y-coordinate of the upper-left corner of a rectangle.
width
X-coordinate of the lower-right corner of a rectangle.
height
Y-coordinate of the lower-right corner of a rectangle.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(IImGearRectangle)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class > ImGearRectangle Constructor : ImGearRectangle Constructor(IImGearRectangle)
rect
A rectangle object.

Glossary Item Box

Initializes a new instance of the ImGearRectangle struct.

Syntax

public ImGearRectangle(
   IImGearRectangle rect
)

Parameters

rect
A rectangle object.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members
Overload List


%%PageItemTitle%%

ImGearRectangle Constructor(IImGearPoint,IImGearPoint)
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class > ImGearRectangle Constructor : ImGearRectangle Constructor(IImGearPoint,IImGearPoint)
leftTop
Used to initialize Left and Top points of the rectangle.
rightBottom
Used to initialize Right and Bottom points of the rectangle.

Glossary Item Box

Initializes a new instance of the ImGearRectangle struct.

Syntax

public ImGearRectangle(
   IImGearPoint leftTop,
   IImGearPoint rightBottom
)

Parameters

leftTop
Used to initialize Left and Top points of the rectangle.
rightBottom
Used to initialize Right and Bottom points of the rectangle.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members
Overload List


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearRectangle members.

Public Methods

 | Name | Description
public Method | contains | Checks if the specified point's coordinates are inside of the rectangle.
public Method | copyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
public Method | empty | Sets all numeric properties of the rectangle to their initial values.
public Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | getHeight | Gets the height of the rectangle. Any integer value. Note: The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | getWidth | Gets the width of the rectangle. Any integer value. Note: The Height and Width properties assume that the rectangle is being used with endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.
public Method | intersect | Replaces this rectangle with the intersection of itself and another rectangle.
public Method | isEmpty | Tests whether all numeric properties of the rectangle are set to their initial values.
public Method | isWellFormed | Tests whether the rectangle is valid.
public Method | join | Changes the rectangle's points to contain the specified point.
public Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
public Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
public Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
public Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Top

See Also

Reference

ImGearRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : contains Method
point
The point.

Glossary Item Box

Checks if the specified point's coordinates are inside of the rectangle.

Syntax

public boolean contains(
   IImGearPoint point
)

Parameters

point
The point.

Return Value

Boolean value. ImGearPoint

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : copyFrom Method
rect
A rectangle object.

Glossary Item Box

Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.

Syntax

public void copyFrom(
   IImGearRectangle rect
)

Parameters

rect
A rectangle object.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

empty Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : empty Method

Glossary Item Box

Sets all numeric properties of the rectangle to their initial values.

Syntax

public void empty()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getBottom Method

Glossary Item Box

Gets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public int getBottom()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Any integer value.

Note:

The Height and Width properties assume that the rectangle is being used with the endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Syntax

public int getHeight()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getLeft Method

Glossary Item Box

Gets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public int getLeft()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getRight Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public int getRight()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getTop Method

Glossary Item Box

Gets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public int getTop()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : getWidth Method

Glossary Item Box

Gets the width of the rectangle.

Any integer value.

Note:

The Height and Width properties assume that the rectangle is being used with endpoint-inclusive semantics. Using endpoint-inclusive semantics, a rectangle with left, top, right, and bottom coordinates all equal to 0 is one pixel wide and one pixel tall. So, for example, the getWidth() value is calculated as Right - Left + 1. ImGearARTMarktimes rectangles are used with endpoint-exclusive semantics, in which the width of the rectangle should be calculated as Right - Left. In this case, the Width and Height properties should not be used.

Syntax

public int getWidth()

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

intersect Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : intersect Method
rect
A rectangle object.

Glossary Item Box

Replaces this rectangle with the intersection of itself and another rectangle.

Syntax

public boolean intersect(
   IImGearRectangle rect
)

Parameters

rect
A rectangle object.

Return Value

Boolean value.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : isEmpty Method

Glossary Item Box

Tests whether all numeric properties of the rectangle are set to their initial values.

Syntax

public boolean isEmpty()

Return Value

Boolean value.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

isWellFormed Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : isWellFormed Method

Glossary Item Box

Tests whether the rectangle is valid.

Syntax

public boolean isWellFormed()

Return Value

Boolean value.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

join Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : join Method
point
The point. ImGearPoint

Glossary Item Box

Changes the rectangle's points to contain the specified point.

Syntax

public void join(
   IImGearPoint point
)

Parameters

point
The point. ImGearPoint

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : offset Method
offsetX
The X shift value.
offsetY
The Y shift value.

Glossary Item Box

Shifts the rectangle points by the specified shiftX and shiftY values.

Syntax

public void offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

setBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : setBottom Method
value

Glossary Item Box

Sets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public void setBottom(
   int value
)

Parameters

value

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

setLeft Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : setLeft Method
value

Glossary Item Box

Sets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public void setLeft(
   int value
)

Parameters

value

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

setRight Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : setRight Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

public void setRight(
   int value
)

Parameters

value

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

setTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : setTop Method
value

Glossary Item Box

Sets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

public void setTop(
   int value
)

Parameters

value

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.core.shapes Package > ImGearRectangle Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearRectangle Class
ImGearRectangle Members


%%PageItemTitle%%

ImGearRoundedRectangle Class
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRoundedRectangle Class

Glossary Item Box

This structure represents a rounded rectangle.

Object Model

ImGearRoundedRectangle ClassImGearPoint ClassImGearPoint Class

Syntax

public sealed class ImGearRoundedRectangle
    extends Object
    implements IImGearRoundedRectangle

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.shapes.ImGearRoundedRectangle

See Also

Reference

ImGearRoundedRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRoundedRectangle Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRoundedRectangle Class

Glossary Item Box

The following tables list the members exposed by ImGearRoundedRectangle.

Public Constructors

 | Name | Description
public Constructor | ImGearRoundedRectangle Constructor | Default constructor.
Top

Public Methods

 | Name | Description
public Method | getLeftTop | Gets coordinates of the upper-left corner of the rectangle. ImGearPoint structure.
public Method | getRadius | Gets the radius for the rounded edges. Integer value.
public Method | getRightBottom | Gets coordinates of the right-bottom corner of the rectangle. ImGearPoint structure.
public Method | setLeftTop | Sets coordinates of the upper-left corner of the rectangle. ImGearPoint structure.
public Method | setRadius | Sets the radius for the rounded edges. Integer value.
public Method | setRightBottom | Sets coordinates of the right-bottom corner of the rectangle. ImGearPoint structure.
Top

See Also

Reference

ImGearRoundedRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

ImGearRoundedRectangle Constructor
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : ImGearRoundedRectangle Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearRoundedRectangle()

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRoundedRectangle Class Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : ImGearRoundedRectangle Class

Glossary Item Box

For a list of all members of this type, see ImGearRoundedRectangle members.

Public Methods

 | Name | Description
public Method | getLeftTop | Gets coordinates of the upper-left corner of the rectangle. ImGearPoint structure.
public Method | getRadius | Gets the radius for the rounded edges. Integer value.
public Method | getRightBottom | Gets coordinates of the right-bottom corner of the rectangle. ImGearPoint structure.
public Method | setLeftTop | Sets coordinates of the upper-left corner of the rectangle. ImGearPoint structure.
public Method | setRadius | Sets the radius for the rounded edges. Integer value.
public Method | setRightBottom | Sets coordinates of the right-bottom corner of the rectangle. ImGearPoint structure.
Top

See Also

Reference

ImGearRoundedRectangle Class
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getLeftTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : getLeftTop Method

Glossary Item Box

Gets coordinates of the upper-left corner of the rectangle.

ImGearPoint structure.

Syntax

public ImGearPoint getLeftTop()

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

getRadius Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : getRadius Method

Glossary Item Box

Gets the radius for the rounded edges.

Integer value.

Syntax

public int getRadius()

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

getRightBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : getRightBottom Method

Glossary Item Box

Gets coordinates of the right-bottom corner of the rectangle.

ImGearPoint structure.

Syntax

public ImGearPoint getRightBottom()

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

setLeftTop Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : setLeftTop Method
value

Glossary Item Box

Sets coordinates of the upper-left corner of the rectangle.

ImGearPoint structure.

Syntax

public void setLeftTop(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

setRadius Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : setRadius Method
value

Glossary Item Box

Sets the radius for the rounded edges.

Integer value.

Syntax

public void setRadius(
   int value
)

Parameters

value

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

setRightBottom Method
com.accusoft.imagegear.core.shapes Package > ImGearRoundedRectangle Class : setRightBottom Method
value

Glossary Item Box

Sets coordinates of the right-bottom corner of the rectangle.

ImGearPoint structure.

Syntax

public void setRightBottom(
   ImGearPoint value
)

Parameters

value

See Also

Reference

ImGearRoundedRectangle Class
ImGearRoundedRectangle Members


%%PageItemTitle%%

IImGearDoublePoint Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoublePoint Interface

Glossary Item Box

Defines DoublePoint interface.

Syntax

public interface IImGearDoublePoint

See Also

Reference

IImGearDoublePoint Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearDoublePoint Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoublePoint Interface

Glossary Item Box

The following tables list the members exposed by IImGearDoublePoint.

Public Methods

 | Name | Description
Method | getX | Gets X coordinate of the point. Any double value.
Method | getY | Gets Y coordinate of the point. Any double value.
Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Method | setX | Sets X coordinate of the point. Any double value.
Method | setY | Sets Y coordinate of the point. Any double value.
Top

See Also

Reference

IImGearDoublePoint Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearDoublePoint Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoublePoint Interface

Glossary Item Box

For a list of all members of this type, see IImGearDoublePoint members.

Public Methods

 | Name | Description
Method | getX | Gets X coordinate of the point. Any double value.
Method | getY | Gets Y coordinate of the point. Any double value.
Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Method | setX | Sets X coordinate of the point. Any double value.
Method | setY | Sets Y coordinate of the point. Any double value.
Top

See Also

Reference

IImGearDoublePoint Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.core.shapes Package > IImGearDoublePoint Interface : getX Method

Glossary Item Box

Gets X coordinate of the point.

Any double value.

Syntax

double getX()

See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.core.shapes Package > IImGearDoublePoint Interface : getY Method

Glossary Item Box

Gets Y coordinate of the point.

Any double value.

Syntax

double getY()

See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > IImGearDoublePoint Interface : offset Method
offsetX
X coordinate value.
offsetY
Y coordinate value.

Glossary Item Box

Shifts the points coordinates by the specified coordinateX and coordinateY values.

Syntax

void offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
X coordinate value.
offsetY
Y coordinate value.

See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.core.shapes Package > IImGearDoublePoint Interface : setX Method
value

Glossary Item Box

Sets X coordinate of the point.

Any double value.

Syntax

void setX(
   double value
)

Parameters

value

See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.core.shapes Package > IImGearDoublePoint Interface : setY Method
value

Glossary Item Box

Sets Y coordinate of the point.

Any double value.

Syntax

void setY(
   double value
)

Parameters

value

See Also

Reference

IImGearDoublePoint Interface
IImGearDoublePoint Members


%%PageItemTitle%%

IImGearDoubleRectangle Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoubleRectangle Interface

Glossary Item Box

Defines DoubleRectangle interface.

Syntax

public interface IImGearDoubleRectangle
    implements IImGearShape

See Also

Reference

IImGearDoubleRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearDoubleRectangle Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoubleRectangle Interface

Glossary Item Box

The following tables list the members exposed by IImGearDoubleRectangle.

Public Methods

 | Name | Description
Method | copyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Method | empty | Sets all numeric properties of the rectangle to their initial values.
Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | getHeight | Gets the height of the rectangle. Any double precision number.
Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | getWidth | Gets the width of the rectangle. Any double precision number.
Method | intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | isWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Top

See Also

Reference

IImGearDoubleRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearDoubleRectangle Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearDoubleRectangle Interface

Glossary Item Box

For a list of all members of this type, see IImGearDoubleRectangle members.

Public Methods

 | Name | Description
Method | copyFrom | This method copies rectangle from IImGearDoubleRectangle interface.
Method | empty | Sets all numeric properties of the rectangle to their initial values.
Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | getHeight | Gets the height of the rectangle. Any double precision number.
Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | getWidth | Gets the width of the rectangle. Any double precision number.
Method | intersect | Checks whether or not the rectangle is intersected with the specified rectangle.
Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | isWellFormed | Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.
Method | offset | Shifts the rectangle points by the specified shiftX and shiftY values.
Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any double precision number.
Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any double precision number.
Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any double precision number.
Top

See Also

Reference

IImGearDoubleRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : copyFrom Method
rect
Rectangle interface.

Glossary Item Box

This method copies rectangle from IImGearDoubleRectangle interface.

Syntax

void copyFrom(
   IImGearDoubleRectangle rect
)

Parameters

rect
Rectangle interface.

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

empty Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : empty Method

Glossary Item Box

Sets all numeric properties of the rectangle to their initial values.

Syntax

void empty()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getBottom Method

Glossary Item Box

Gets the y-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

double getBottom()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Any double precision number.

Syntax

double getHeight()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getLeft Method

Glossary Item Box

Gets the x-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

double getLeft()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getRight Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

double getRight()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getTop Method

Glossary Item Box

Gets the y-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

double getTop()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : getWidth Method

Glossary Item Box

Gets the width of the rectangle.

Any double precision number.

Syntax

double getWidth()

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

intersect Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : intersect Method
rect
Double rectangle interface.

Glossary Item Box

Checks whether or not the rectangle is intersected with the specified rectangle.

Syntax

boolean intersect(
   IImGearDoubleRectangle rect
)

Parameters

rect
Double rectangle interface.

Return Value

Boolean value.

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : isEmpty Method

Glossary Item Box

Tests whether all numeric properties of the rectangle have their initial values.

Syntax

boolean isEmpty()

Return Value

Boolean value.

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

isWellFormed Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : isWellFormed Method

Glossary Item Box

Checks if rectangle's width is greater than or equal to zero and if its height is greater than or equal to zero.

Syntax

boolean isWellFormed()

Return Value

Boolean value.

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : offset Method
offsetX
The X shift value.
offsetY
The Y shift value.

Glossary Item Box

Shifts the rectangle points by the specified shiftX and shiftY values.

Syntax

void offset(
   double offsetX,
   double offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

setBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : setBottom Method
value

Glossary Item Box

Sets the y-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

void setBottom(
   double value
)

Parameters

value

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

setLeft Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : setLeft Method
value

Glossary Item Box

Sets the x-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

void setLeft(
   double value
)

Parameters

value

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

setRight Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : setRight Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the rectangle.

Any double precision number.

Syntax

void setRight(
   double value
)

Parameters

value

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

setTop Method
com.accusoft.imagegear.core.shapes Package > IImGearDoubleRectangle Interface : setTop Method
value

Glossary Item Box

Sets the y-coordinate of the upper-left corner of the rectangle.

Any double precision number.

Syntax

void setTop(
   double value
)

Parameters

value

See Also

Reference

IImGearDoubleRectangle Interface
IImGearDoubleRectangle Members


%%PageItemTitle%%

IImGearEllipse Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearEllipse Interface

Glossary Item Box

Defines Ellipse interface.

Syntax

public interface IImGearEllipse
    implements IImGearShape

See Also

Reference

IImGearEllipse Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearEllipse Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearEllipse Interface

Glossary Item Box

The following tables list the members exposed by IImGearEllipse.

Public Methods

 | Name | Description
Method | getLeftTop | Gets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | getRightBottom | Gets the x-coordinate of the lower-right corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | setLeftTop | Sets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | setRightBottom | Sets the x-coordinate of the lower-right corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Top

See Also

Reference

IImGearEllipse Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearEllipse Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearEllipse Interface

Glossary Item Box

For a list of all members of this type, see IImGearEllipse members.

Public Methods

 | Name | Description
Method | getLeftTop | Gets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | getRightBottom | Gets the x-coordinate of the lower-right corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | setLeftTop | Sets the coordinate of the upper-left corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Method | setRightBottom | Sets the x-coordinate of the lower-right corner of the bounding rectangle. ImGearPoint class object. IImGearPoint
Top

See Also

Reference

IImGearEllipse Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getLeftTop Method
com.accusoft.imagegear.core.shapes Package > IImGearEllipse Interface : getLeftTop Method

Glossary Item Box

Gets the coordinate of the upper-left corner of the bounding rectangle.

ImGearPoint class object. IImGearPoint

Syntax

ImGearPoint getLeftTop()

See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members


%%PageItemTitle%%

getRightBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearEllipse Interface : getRightBottom Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the bounding rectangle.

ImGearPoint class object. IImGearPoint

Syntax

ImGearPoint getRightBottom()

See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members


%%PageItemTitle%%

setLeftTop Method
com.accusoft.imagegear.core.shapes Package > IImGearEllipse Interface : setLeftTop Method
value

Glossary Item Box

Sets the coordinate of the upper-left corner of the bounding rectangle.

ImGearPoint class object. IImGearPoint

Syntax

void setLeftTop(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members


%%PageItemTitle%%

setRightBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearEllipse Interface : setRightBottom Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the bounding rectangle.

ImGearPoint class object. IImGearPoint

Syntax

void setRightBottom(
   ImGearPoint value
)

Parameters

value

See Also

Reference

IImGearEllipse Interface
IImGearEllipse Members


%%PageItemTitle%%

IImGearPoint Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearPoint Interface

Glossary Item Box

Defines Point interface.

Syntax

public interface IImGearPoint

See Also

Reference

IImGearPoint Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearPoint Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearPoint Interface

Glossary Item Box

The following tables list the members exposed by IImGearPoint.

Public Methods

 | Name | Description
Method | getX | Gets the x-coordinate of the point. Any integer value.
Method | getY | Gets the y-coordinate of the point. Any integer value.
Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Method | setX | Sets the x-coordinate of the point. Any integer value.
Method | setY | Sets the y-coordinate of the point. Any integer value.
Top

See Also

Reference

IImGearPoint Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearPoint Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearPoint Interface

Glossary Item Box

For a list of all members of this type, see IImGearPoint members.

Public Methods

 | Name | Description
Method | getX | Gets the x-coordinate of the point. Any integer value.
Method | getY | Gets the y-coordinate of the point. Any integer value.
Method | offset | Shifts the points coordinates by the specified coordinateX and coordinateY values.
Method | setX | Sets the x-coordinate of the point. Any integer value.
Method | setY | Sets the y-coordinate of the point. Any integer value.
Top

See Also

Reference

IImGearPoint Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getX Method
com.accusoft.imagegear.core.shapes Package > IImGearPoint Interface : getX Method

Glossary Item Box

Gets the x-coordinate of the point.

Any integer value.

Syntax

int getX()

See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

getY Method
com.accusoft.imagegear.core.shapes Package > IImGearPoint Interface : getY Method

Glossary Item Box

Gets the y-coordinate of the point.

Any integer value.

Syntax

int getY()

See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > IImGearPoint Interface : offset Method
offsetX
The x coordinate value.
offsetY
The y coordinate value.

Glossary Item Box

Shifts the points coordinates by the specified coordinateX and coordinateY values.

Syntax

void offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The x coordinate value.
offsetY
The y coordinate value.

See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

setX Method
com.accusoft.imagegear.core.shapes Package > IImGearPoint Interface : setX Method
value

Glossary Item Box

Sets the x-coordinate of the point.

Any integer value.

Syntax

void setX(
   int value
)

Parameters

value

See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

setY Method
com.accusoft.imagegear.core.shapes Package > IImGearPoint Interface : setY Method
value

Glossary Item Box

Sets the y-coordinate of the point.

Any integer value.

Syntax

void setY(
   int value
)

Parameters

value

See Also

Reference

IImGearPoint Interface
IImGearPoint Members


%%PageItemTitle%%

IImGearRectangle Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRectangle Interface

Glossary Item Box

Defines IImGearRectangle interface.

Syntax

public interface IImGearRectangle
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearShape

See Also

Reference

IImGearRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearRectangle Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRectangle Interface

Glossary Item Box

The following tables list the members exposed by IImGearRectangle.

Public Methods

 | Name | Description
Method | contains | Checks if the specified point's coordinates are inside of the rectangle.
Method | copyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Method | empty | Sets all numeric properties of the rectangle to their initial values.
Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | getHeight | Gets the height of the rectangle. Any integer value.
Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | getWidth | Gets the width of the rectangle. Any integer value.
Method | intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | isWellFormed | Tests whether the rectangle is valid.
Method | join | Changes the rectangle's points to contain the specified point.
Method | offset | Shifts the rectangle points by the specified xShift and yShift values.
Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Top

See Also

Reference

IImGearRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearRectangle Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRectangle Interface

Glossary Item Box

For a list of all members of this type, see IImGearRectangle members.

Public Methods

 | Name | Description
Method | contains | Checks if the specified point's coordinates are inside of the rectangle.
Method | copyFrom | Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.
Method | empty | Sets all numeric properties of the rectangle to their initial values.
Method | getBottom | Gets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | getHeight | Gets the height of the rectangle. Any integer value.
Method | getLeft | Gets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | getRight | Gets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | getTop | Gets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | getWidth | Gets the width of the rectangle. Any integer value.
Method | intersect | Replaces this rectangle with the intersection of itself and another rectangle.
Method | isEmpty | Tests whether all numeric properties of the rectangle have their initial values.
Method | isWellFormed | Tests whether the rectangle is valid.
Method | join | Changes the rectangle's points to contain the specified point.
Method | offset | Shifts the rectangle points by the specified xShift and yShift values.
Method | setBottom | Sets the y-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | setLeft | Sets the x-coordinate of the upper-left corner of the rectangle. Any integer value.
Method | setRight | Sets the x-coordinate of the lower-right corner of the rectangle. Any integer value.
Method | setTop | Sets the y-coordinate of the upper-left corner of the rectangle. Any integer value.
Top

See Also

Reference

IImGearRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : contains Method
point
The point interface.

Glossary Item Box

Checks if the specified point's coordinates are inside of the rectangle.

Syntax

boolean contains(
   IImGearPoint point
)

Parameters

point
The point interface.

Return Value

Boolean value. IImGearPoint

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : copyFrom Method
rect
A rectangle interface.

Glossary Item Box

Copies the specified ImGearRectangle object into this instance of the ImGearRectangle class.

Syntax

void copyFrom(
   IImGearRectangle rect
)

Parameters

rect
A rectangle interface.

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

empty Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : empty Method

Glossary Item Box

Sets all numeric properties of the rectangle to their initial values.

Syntax

void empty()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getBottom Method

Glossary Item Box

Gets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

int getBottom()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getHeight Method

Glossary Item Box

Gets the height of the rectangle.

Any integer value.

Syntax

int getHeight()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getLeft Method

Glossary Item Box

Gets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

int getLeft()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getRight Method

Glossary Item Box

Gets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

int getRight()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getTop Method

Glossary Item Box

Gets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

int getTop()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : getWidth Method

Glossary Item Box

Gets the width of the rectangle.

Any integer value.

Syntax

int getWidth()

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

intersect Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : intersect Method
rect
A rectangle interface.

Glossary Item Box

Replaces this rectangle with the intersection of itself and another rectangle.

Syntax

boolean intersect(
   IImGearRectangle rect
)

Parameters

rect
A rectangle interface.

Return Value

Boolean value.

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : isEmpty Method

Glossary Item Box

Tests whether all numeric properties of the rectangle have their initial values.

Syntax

boolean isEmpty()

Return Value

Boolean value.

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

isWellFormed Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : isWellFormed Method

Glossary Item Box

Tests whether the rectangle is valid.

Syntax

boolean isWellFormed()

Return Value

Boolean value.

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

join Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : join Method
point
The point interface. IImGearPoint

Glossary Item Box

Changes the rectangle's points to contain the specified point.

Syntax

void join(
   IImGearPoint point
)

Parameters

point
The point interface. IImGearPoint

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

offset Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : offset Method
offsetX
The X shift value.
offsetY
The Y shift value.

Glossary Item Box

Shifts the rectangle points by the specified xShift and yShift values.

Syntax

void offset(
   int offsetX,
   int offsetY
)

Parameters

offsetX
The X shift value.
offsetY
The Y shift value.

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

setBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : setBottom Method
value

Glossary Item Box

Sets the y-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

void setBottom(
   int value
)

Parameters

value

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

setLeft Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : setLeft Method
value

Glossary Item Box

Sets the x-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

void setLeft(
   int value
)

Parameters

value

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

setRight Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : setRight Method
value

Glossary Item Box

Sets the x-coordinate of the lower-right corner of the rectangle.

Any integer value.

Syntax

void setRight(
   int value
)

Parameters

value

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

setTop Method
com.accusoft.imagegear.core.shapes Package > IImGearRectangle Interface : setTop Method
value

Glossary Item Box

Sets the y-coordinate of the upper-left corner of the rectangle.

Any integer value.

Syntax

void setTop(
   int value
)

Parameters

value

See Also

Reference

IImGearRectangle Interface
IImGearRectangle Members


%%PageItemTitle%%

IImGearRoundedRectangle Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRoundedRectangle Interface

Glossary Item Box

Represents a rounded rectangle.

Syntax

public interface IImGearRoundedRectangle

See Also

Reference

IImGearRoundedRectangle Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearRoundedRectangle Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRoundedRectangle Interface

Glossary Item Box

The following tables list the members exposed by IImGearRoundedRectangle.

Public Methods

 | Name | Description
Method | getLeftTop | Gets coordinates of the upper-left corner of the rectangle.
Method | getRadius | Gets the radius for the rounded edges.
Method | getRightBottom | Gets coordinates of the right-bottom corner of the rectangle.
Method | setLeftTop | Sets coordinates of the upper-left corner of the rectangle.
Method | setRadius | Sets the radius for the rounded edges.
Method | setRightBottom | Sets coordinates of the right-bottom corner of the rectangle.
Top

See Also

Reference

IImGearRoundedRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearRoundedRectangle Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearRoundedRectangle Interface

Glossary Item Box

For a list of all members of this type, see IImGearRoundedRectangle members.

Public Methods

 | Name | Description
Method | getLeftTop | Gets coordinates of the upper-left corner of the rectangle.
Method | getRadius | Gets the radius for the rounded edges.
Method | getRightBottom | Gets coordinates of the right-bottom corner of the rectangle.
Method | setLeftTop | Sets coordinates of the upper-left corner of the rectangle.
Method | setRadius | Sets the radius for the rounded edges.
Method | setRightBottom | Sets coordinates of the right-bottom corner of the rectangle.
Top

See Also

Reference

IImGearRoundedRectangle Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getLeftTop Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : getLeftTop Method

Glossary Item Box

Gets coordinates of the upper-left corner of the rectangle.

Syntax

ImGearPoint getLeftTop()

Return Value

upper left corner

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

getRadius Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : getRadius Method

Glossary Item Box

Gets the radius for the rounded edges.

Syntax

int getRadius()

Return Value

the radius

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

getRightBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : getRightBottom Method

Glossary Item Box

Gets coordinates of the right-bottom corner of the rectangle.

Syntax

ImGearPoint getRightBottom()

Return Value

right bottom corner.

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

setLeftTop Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : setLeftTop Method
top
upper left corner

Glossary Item Box

Sets coordinates of the upper-left corner of the rectangle.

Syntax

void setLeftTop(
   ImGearPoint top
)

Parameters

top
upper left corner

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

setRadius Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : setRadius Method
radius
the radius

Glossary Item Box

Sets the radius for the rounded edges.

Syntax

void setRadius(
   int radius
)

Parameters

radius
the radius

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

setRightBottom Method
com.accusoft.imagegear.core.shapes Package > IImGearRoundedRectangle Interface : setRightBottom Method
bottom
right bottom corner.

Glossary Item Box

Sets coordinates of the right-bottom corner of the rectangle.

Syntax

void setRightBottom(
   ImGearPoint bottom
)

Parameters

bottom
right bottom corner.

See Also

Reference

IImGearRoundedRectangle Interface
IImGearRoundedRectangle Members


%%PageItemTitle%%

IImGearShape Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearShape Interface

Glossary Item Box

Defines Shape interface.

Syntax

public interface IImGearShape

See Also

Reference

IImGearShape Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearShape Interface Members
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearShape Interface

Glossary Item Box

The following tables list the members exposed by IImGearShape.

See Also

Reference

IImGearShape Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

IImGearSize Interface
See Also Members Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearSize Interface

Glossary Item Box

Defines Size interface.

Syntax

public interface IImGearSize

See Also

Reference

IImGearSize Members
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearSize Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearSize Interface

Glossary Item Box

The following tables list the members exposed by IImGearSize.

Public Methods

 | Name | Description
Method | getcX | Gets the X size. Any integer value.
Method | getcY | Gets the Y size. Any integer value.
Method | setcX | Sets the X size. Any integer value.
Method | setcY | Sets the Y size. Any integer value.
Top

See Also

Reference

IImGearSize Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearSize Interface Methods
See Also Send Feedback
com.accusoft.imagegear.core.shapes Package : IImGearSize Interface

Glossary Item Box

For a list of all members of this type, see IImGearSize members.

Public Methods

 | Name | Description
Method | getcX | Gets the X size. Any integer value.
Method | getcY | Gets the Y size. Any integer value.
Method | setcX | Sets the X size. Any integer value.
Method | setcY | Sets the Y size. Any integer value.
Top

See Also

Reference

IImGearSize Interface
com.accusoft.imagegear.core.shapes Package


%%PageItemTitle%%

getcX Method
com.accusoft.imagegear.core.shapes Package > IImGearSize Interface : getcX Method

Glossary Item Box

Gets the X size.

Any integer value.

Syntax

int getcX()

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

getcY Method
com.accusoft.imagegear.core.shapes Package > IImGearSize Interface : getcY Method

Glossary Item Box

Gets the Y size.

Any integer value.

Syntax

int getcY()

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

setcX Method
com.accusoft.imagegear.core.shapes Package > IImGearSize Interface : setcX Method
value

Glossary Item Box

Sets the X size.

Any integer value.

Syntax

void setcX(
   int value
)

Parameters

value

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%PageItemTitle%%

setcY Method
com.accusoft.imagegear.core.shapes Package > IImGearSize Interface : setcY Method
value

Glossary Item Box

Sets the Y size.

Any integer value.

Syntax

void setcY(
   int value
)

Parameters

value

See Also

Reference

IImGearSize Interface
IImGearSize Members


%%ItemTitle%%

com.accusoft.imagegear.display Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the ImageGear for Java API for annotation and presentation state support.

Classes

Class | Description
ImGearAnnotationPage | Abstract class used by the ImGearPageDisplay.getARTPage method of ImGearPageDisplay class. This class does not expose any public members. ImGearPageDisplay
ImGearContrastSettings | Contrast settings class used by ImGearPageDisplay.updateLUT method
ImGearPageDisplay | Main class, implementing the entire ImageGear for Java display API.
ImGearScrollComponentInfo | Implements state of one scrollbar and uses pass scrolling information to and from ImageGear display code.
ImGearScrollInfo | Represents scrolling state of the image.
ImGearZoomComponentInfo | Stores information about image zoom in one dimension (vertical or horizontal).
ImGearZoomInfo | Represents complete image zoom information.

Interfaces

Interface | Description
IImGearAlignment | Provides access to display alignment modes.
IImGearAntiAlias | Provides access to bitonal anti-aliasing attributes.
IImGearAspectRatio | Provides access to display aspect ratio attributes.
IImGearBackground | Provides access to display background attributes. There are no objects implementing this interface. It is accessed via ImGearPageDisplay.getBackground method of ImGearPageDisplay class.
IImGearColorAntiAlias | Provides access to color anti-aliasing attributes.
IImGearContrastSettings | Contrast settings interface used by ImGearPageDisplay.updateLUT method
IImGearDisplayObject | Base interface for display API objects. Implemented in several display code structures.
IImGearLayout | Provides access to display layout attributes. There are no objects implementing this interface. It is accessed via getLayout() method of ImGearPageDisplay object.
IImGearPageDisplay | Defines interface for page display.
IImGearResample | Provides access to re-sampling attributes.
IImGearScrollableView | Obtains all information required by IG display code and modifies some attributes of underlying window (scrollbars state). This interface is designed to separate IG display API from Java windows and forms. Any object implementing this interface can be used. A null value can also be specified. In this case all required information will be obtained from CSGraphics object. In all display API calls IImGearScrollableView parameter is accompanied with CSGraphics object. To draw on a printer, null value should be passed to IImGearScrollableView parameter.

Enumerations

Enumeration | Description
ImGearAliasModes | Identifies different types of image aliasing. Applicable only if a 1-bit-per-pixel image is to be drawn and only if the destination image has a lower resolution than the original one.
ImGearAlignmentHModes | Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
ImGearAlignmentVModes | Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).
ImGearBackgroundModes | Specifies ImageGear background modes.
ImGearColorAliasModes | Specifies color anti-aliasing mode.
ImGearCoordConvModes | Identifies coordinate translation methods.
ImGearFitModes | Identifies how an image fits to the device rectangle.
ImGearResampleModes | Specifies re-sampling mode.
ImGearScrollBarModes | Identifies scroll bar visibility methods.
ImGearScrollBarType | Identifies scrollbar types.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.display Package Inheritance Hierarchy

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.display.ImGearContrastSettings
com.accusoft.imagegear.display.ImGearScrollComponentInfo
com.accusoft.imagegear.display.ImGearScrollInfo
com.accusoft.imagegear.display.ImGearZoomComponentInfo
com.accusoft.imagegear.display.ImGearZoomInfo

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearAnnotationPage Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearAnnotationPage Class

Glossary Item Box

Abstract class used by the ImGearPageDisplay.getARTPage method of ImGearPageDisplay class.

This class does not expose any public members.

ImGearPageDisplay

Object Model

ImGearAnnotationPage Class

Syntax

public abstract class ImGearAnnotationPage
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearAnnotationPage
com.accusoft.imagegear.art.ImGearARTPage

See Also

Reference

ImGearAnnotationPage Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearAnnotationPage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.display Package : ImGearAnnotationPage Class

Glossary Item Box

The following tables list the members exposed by ImGearAnnotationPage.

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearAnnotationPage Class
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearAnnotationPage Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearAnnotationPage Class

Glossary Item Box

For a list of all members of this type, see ImGearAnnotationPage members.

See Also

Reference

ImGearAnnotationPage Class
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearAnnotationPage Class Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearAnnotationPage Class

Glossary Item Box

For a list of all members of this type, see ImGearAnnotationPage members.

Protected Methods

 | Name | Description
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.
Top

See Also

Reference

ImGearAnnotationPage Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListeners are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.display Package > ImGearAnnotationPage Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearAnnotationPage Class
ImGearAnnotationPage Members


%%PageItemTitle%%

ImGearContrastSettings Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearContrastSettings Class

Glossary Item Box

Contrast settings class used by ImGearPageDisplay.updateLUT method

Object Model

ImGearContrastSettings ClassImGearContrastSettings Class

Syntax

public class ImGearContrastSettings
    extends Object
    implements IImGearContrastSettings

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearContrastSettings

See Also

Reference

ImGearContrastSettings Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearContrastSettings Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : ImGearContrastSettings Class

Glossary Item Box

The following tables list the members exposed by ImGearContrastSettings.

Public Constructors

 | Name | Description
public Constructor | ImGearContrastSettings Constructor | Default constructor.
Top

Public Methods

 | Name | Description
public Method | copyFrom | Initializes the object from existing instance.
static (Shared in Visual Basic) | createDefault | Creates ImGearContrastSettings instance with default attributes.
public Method | getBrightness | Gets brightness attribute.
public Method | getContrast | Gets contrast attribute.
public Method | getGamma | Gets gamma attribute.
public Method | setBrightness | Sets brightness attribute.
public Method | setContrast | Sets contrast attribute.
public Method | setGamma | Sets gamma attribute.
Top

See Also

Reference

ImGearContrastSettings Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearContrastSettings Constructor
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : ImGearContrastSettings Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearContrastSettings()

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearContrastSettings Class Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearContrastSettings Class

Glossary Item Box

For a list of all members of this type, see ImGearContrastSettings members.

Public Methods

 | Name | Description
public Method | copyFrom | Initializes the object from existing instance.
static (Shared in Visual Basic) | createDefault | Creates ImGearContrastSettings instance with default attributes.
public Method | getBrightness | Gets brightness attribute.
public Method | getContrast | Gets contrast attribute.
public Method | getGamma | Gets gamma attribute.
public Method | setBrightness | Sets brightness attribute.
public Method | setContrast | Sets contrast attribute.
public Method | setGamma | Sets gamma attribute.
Top

See Also

Reference

ImGearContrastSettings Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : copyFrom Method
value
Value to copy from.

Glossary Item Box

Initializes the object from existing instance.

Syntax

public void copyFrom(
   IImGearContrastSettings value
)

Parameters

value
Value to copy from.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

createDefault Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : createDefault Method

Glossary Item Box

Creates ImGearContrastSettings instance with default attributes.

Syntax

public static ImGearContrastSettings createDefault()

Return Value

An instance of this class.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

getBrightness Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : getBrightness Method

Glossary Item Box

Gets brightness attribute.

Syntax

public double getBrightness()

Return Value

Brightness attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

getContrast Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : getContrast Method

Glossary Item Box

Gets contrast attribute.

Syntax

public double getContrast()

Return Value

Contrast attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

getGamma Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : getGamma Method

Glossary Item Box

Gets gamma attribute.

Syntax

public double getGamma()

Return Value

Gamma attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

setBrightness Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : setBrightness Method
value
Brightness attribute.

Glossary Item Box

Sets brightness attribute.

Syntax

public void setBrightness(
   double value
)

Parameters

value
Brightness attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

setContrast Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : setContrast Method
value
Contrast attribute.

Glossary Item Box

Sets contrast attribute.

Syntax

public void setContrast(
   double value
)

Parameters

value
Contrast attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

setGamma Method
com.accusoft.imagegear.display Package > ImGearContrastSettings Class : setGamma Method
value
Gamma attribute.

Glossary Item Box

Sets gamma attribute.

Syntax

public void setGamma(
   double value
)

Parameters

value
Gamma attribute.

See Also

Reference

ImGearContrastSettings Class
ImGearContrastSettings Members


%%PageItemTitle%%

ImGearPageDisplay Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearPageDisplay Class

Glossary Item Box

Main class, implementing the entire ImageGear for Java display API.

Object Model

ImGearPageDisplay ClassImGearPageDisplay ClassIImGearAntiAlias InterfaceImGearAnnotationPage ClassIImGearBackground InterfaceImGearDisplayChannels ClassIImGearColorAntiAlias InterfaceIImGearDICOMDisplaySettings InterfaceIImGearLayout InterfaceImGearMultichannelLUT ClassIImGearOrientation InterfaceImGearPage ClassIImGearResample InterfaceImGearScrollInfo ClassImGearZoomInfo ClassImGearScrollInfo Class

Syntax

public class ImGearPageDisplay
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements IImGearPageDisplay

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearPageDisplay

See Also

Reference

ImGearPageDisplay Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPageDisplay Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.display Package : ImGearPageDisplay Class

Glossary Item Box

The following tables list the members exposed by ImGearPageDisplay.

Public Constructors

 | Name | Description
public Constructor | ImGearPageDisplay Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | lutUpdated | Occurs when the lookup table is updated.
public Field | pageScrolled | Occurs when a pages is scrolled.
public Field | pageZoomed | Occurs when a page is zoomed.
Top

Public Methods

Name | Description
public Method | clone | Copies ImGearPageDisplay class object.
public Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
public Method | draw | Draws image on Java Graphics.
public Method | drawEx | Draws image on Java Graphics.
public Method getAntiAliasing Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

public Method getARTPage Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in 30a1ae8f-6542-4e86-a23b-2e6716e8f244 package.

ImGearAnnotationPage class.

public Method getBackground Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

public Method getBrightness Gets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
public Method getChannels Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

public Method getColorAntiAliasing Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

public Method getContrast Returns the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

public Method getDICOMDisplaySettings Returns the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

public Method getGamma Gets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
public Method getLayout Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

public Method getLUT Returns a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

public Method getOrientation Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

com.accusoft.imagegear.core.ImGearOrientation structure. com.accusoft.imagegear.core.ImGearOrientation

public Method getPage Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

public Method getResampling Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

public Method | getScrollInfo | Returns new instance of image scrolling attributes object.
public Method | getZoomInfo | Returns a new instance of an object containing current zoom settings.
public Method handleScroll Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

public Method | internalUseOnly | Gets the ImGearPageDisplay.
public Method | print | Draws the image on Java Graphics for printing. Call to Print(hdc) is equal to call drawEx(null, hdc, true).
public Method scrollTo Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

public Method setARTPage Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

public Method setBrightness Sets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
public Method setContrast Sets the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

public Method setDICOMDisplaySettings Sets the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

public Method setGamma Sets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
public Method setLUT Sets a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

public Method setPage Sets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

public Method | updateLUT | Updates the ImGearPageDisplay lookup table.
public Method | updateScrollFrom | Updates image scroll attributes with new values.
public Method | updateZoomFrom | Updates image zoom attributes.
public Method zoomToRectangle Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Top

Protected Methods

 | Name | Description
protected Method | onLutUpdated | Occurs when the lookup table is updated.
protected Method | onPageScrolled | Occurs when a page is scrolled.
protected Method | onPageZoomed | Occurs when a page is zoomed.
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListener are subsequently notified.
Top

See Also

Reference

ImGearPageDisplay Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearPageDisplay Constructor
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : ImGearPageDisplay Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearPageDisplay Constructor() | Initializes a new instance of the ImGearPageDisplay class.
ImGearPageDisplay Constructor(ImGearPage) | Initializes a new instance of the ImGearPageDisplay class.
ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage) | Initializes a new instance of the ImGearPageDisplay class using the specified com.accusoft.imagegear.core.ImGearPage and ImGearAnnotationPage objects.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

ImGearPageDisplay Constructor()
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor()

Glossary Item Box

Initializes a new instance of the ImGearPageDisplay class.

Syntax

public ImGearPageDisplay()

Return Value

A new instance of ImGearPageDisplay class.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%%

ImGearPageDisplay Constructor(ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor(ImGearPage)
page
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.

com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

Initializes a new instance of the ImGearPageDisplay class.

Syntax

public ImGearPageDisplay(
   ImGearPage page
)

Parameters

page
Specifies the ImGearPage object to associate with new ImGearPageDisplay instance.

com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%%

ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearPageDisplay Class > ImGearPageDisplay Constructor : ImGearPageDisplay Constructor(ImGearPage,ImGearAnnotationPage)
page
Specifies the com.accusoft.imagegear.core.ImGearPage object to associate with new ImGearPageDisplay instance.
artPage
com.accusoft.imagegear.art.ImGearARTPage object to associate with com.accusoft.imagegear.core.ImGearPage for display.

Glossary Item Box

Initializes a new instance of the ImGearPageDisplay class using the specified com.accusoft.imagegear.core.ImGearPage and ImGearAnnotationPage objects.

Syntax

public ImGearPageDisplay(
   ImGearPage page,
   ImGearAnnotationPage artPage
)

Parameters

page
Specifies the com.accusoft.imagegear.core.ImGearPage object to associate with new ImGearPageDisplay instance.
artPage
com.accusoft.imagegear.art.ImGearARTPage object to associate with com.accusoft.imagegear.core.ImGearPage for display.

Return Value

A new instance of ImGearPageDisplay class. com.accusoft.imagegear.core.ImGearPage ImGearAnnotationPage

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPageDisplay Class Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearPageDisplay Class

Glossary Item Box

For a list of all members of this type, see ImGearPageDisplay members.

Public Methods

Name | Description
public Method | clone | Copies ImGearPageDisplay class object.
public Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
public Method | draw | Draws image on Java Graphics.
public Method | drawEx | Draws image on Java Graphics.
public Method getAntiAliasing Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

public Method getARTPage Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in 30a1ae8f-6542-4e86-a23b-2e6716e8f244 package.

ImGearAnnotationPage class.

public Method getBackground Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

public Method getBrightness Gets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
public Method getChannels Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

public Method getColorAntiAliasing Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

public Method getContrast Returns the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

public Method getDICOMDisplaySettings Returns the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

public Method getGamma Gets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
public Method getLayout Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

public Method getLUT Returns a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

public Method getOrientation Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

com.accusoft.imagegear.core.ImGearOrientation structure. com.accusoft.imagegear.core.ImGearOrientation

public Method getPage Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

public Method getResampling Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

public Method | getScrollInfo | Returns new instance of image scrolling attributes object.
public Method | getZoomInfo | Returns a new instance of an object containing current zoom settings.
public Method handleScroll Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

public Method | internalUseOnly | Gets the ImGearPageDisplay.
public Method | print | Draws the image on Java Graphics for printing. Call to Print(hdc) is equal to call drawEx(null, hdc, true).
public Method scrollTo Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

public Method setARTPage Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

public Method setBrightness Sets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.
public Method setContrast Sets the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

public Method setDICOMDisplaySettings Sets the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

public Method setGamma Sets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.
public Method setLUT Sets a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

public Method setPage Sets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

public Method | updateLUT | Updates the ImGearPageDisplay lookup table.
public Method | updateScrollFrom | Updates image scroll attributes with new values.
public Method | updateZoomFrom | Updates image zoom attributes.
public Method zoomToRectangle Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Top

Protected Methods

 | Name | Description
protected Method | onLutUpdated | Occurs when the lookup table is updated.
protected Method | onPageScrolled | Occurs when a page is scrolled.
protected Method | onPageZoomed | Occurs when a page is zoomed.
protected Method | onPropertyChanged | Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListener are subsequently notified.
Top

See Also

Reference

ImGearPageDisplay Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : clone Method

Glossary Item Box

Copies ImGearPageDisplay class object.

Syntax

public ImGearPageDisplay clone()

Return Value

New instance of ImGearPageDisplay class object.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

convertCoordinates Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : convertCoordinates Method

Glossary Item Box

Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.

Overload List

Overload | Description
convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearPageDisplay Class > convertCoordinates Method : convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) Method
pageView
IImGearScrollableView interface; represents Java context to draw the image on.
g
mode
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
array
Array with point coordinates. IImGearScrollableView ImGearCoordConvModes

Glossary Item Box

Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.

Syntax

public void convertCoordinates(
   IImGearScrollableView pageView,
   java.awt.Graphics g,
   ImGearCoordConvModes mode,
   ImGearArray array
)

Parameters

pageView
IImGearScrollableView interface; represents Java context to draw the image on.
g
mode
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
array
Array with point coordinates. IImGearScrollableView ImGearCoordConvModes

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearPageDisplay Class > convertCoordinates Method : convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) Method
pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates ( com.accusoft.imagegear.core.shapes.ImGearPoint or com.accusoft.imagegear.core.shapes.ImGearDoublePoint).

Glossary Item Box

Translates coordinates between image and device coordinate systems.

Syntax

public void convertCoordinates(
   IImGearScrollableView pageView,
   ImGearCoordConvModes mode,
   ImGearArray array
)

Parameters

pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates ( com.accusoft.imagegear.core.shapes.ImGearPoint or com.accusoft.imagegear.core.shapes.ImGearDoublePoint).

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members
Overload List


%%PageItemTitle%%

draw Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : draw Method
pageView
IImGearScrollableView interface; represents Java context to draw the image on.
graphics
Graphics object to draw image on. IImGearScrollableView

Glossary Item Box

Draws image on Java Graphics.

Syntax

public void draw(
   IImGearScrollableView pageView,
   java.awt.Graphics graphics
)

Parameters

pageView
IImGearScrollableView interface; represents Java context to draw the image on.
graphics
Graphics object to draw image on. IImGearScrollableView

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

drawEx Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : drawEx Method
pageView
IImGearScrollableView interface, represents Java context to draw the image in.
graphics
Graphics object to draw the image on.
doPrint
Boolean flag indicating whether the drawing is performed for printer Graphics or not. IImGearScrollableView

Glossary Item Box

Draws image on Java Graphics.

Syntax

public void drawEx(
   IImGearScrollableView pageView,
   java.awt.Graphics graphics,
   boolean doPrint
)

Parameters

pageView
IImGearScrollableView interface, represents Java context to draw the image in.
graphics
Graphics object to draw the image on.
doPrint
Boolean flag indicating whether the drawing is performed for printer Graphics or not. IImGearScrollableView

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getAntiAliasing Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getAntiAliasing Method

Glossary Item Box

Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

Syntax

public IImGearAntiAlias getAntiAliasing()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getARTPage Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getARTPage Method

Glossary Item Box

Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in 30a1ae8f-6542-4e86-a23b-2e6716e8f244 package.

ImGearAnnotationPage class.

Syntax

public ImGearAnnotationPage getARTPage()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getBackground Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getBackground Method

Glossary Item Box

Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

Syntax

public IImGearBackground getBackground()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getBrightness Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getBrightness Method

Glossary Item Box

Gets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.

Syntax

public double getBrightness()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getChannels Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getChannels Method

Glossary Item Box

Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Syntax

public ImGearDisplayChannels getChannels()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getColorAntiAliasing Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getColorAntiAliasing Method

Glossary Item Box

Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

Syntax

public IImGearColorAntiAlias getColorAntiAliasing()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getContrast Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getContrast Method

Glossary Item Box

Returns the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

Syntax

public double getContrast()

Return Value

Double value.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getDICOMDisplaySettings Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getDICOMDisplaySettings Method

Glossary Item Box

Returns the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

public IImGearDICOMDisplaySettings getDICOMDisplaySettings()

Return Value

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getGamma Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getGamma Method

Glossary Item Box

Gets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

Syntax

public double getGamma()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getLayout Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getLayout Method

Glossary Item Box

Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

Syntax

public IImGearLayout getLayout()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getLUT Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getLUT Method

Glossary Item Box

Returns a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

Syntax

public ImGearMultichannelLUT getLUT()

Return Value

com.accusoft.imagegear.core.ImGearMultichannelLUT class.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getOrientation Method

Glossary Item Box

Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

com.accusoft.imagegear.core.ImGearOrientation structure. com.accusoft.imagegear.core.ImGearOrientation

Syntax

public IImGearOrientation getOrientation()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getPage Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getPage Method

Glossary Item Box

Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

Syntax

public ImGearPage getPage()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getResampling Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getResampling Method

Glossary Item Box

Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

Syntax

public IImGearResample getResampling()

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getScrollInfo Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getScrollInfo Method
pageView
IImGearScrollableView interface, represents Java context to draw image in.

Glossary Item Box

Returns new instance of image scrolling attributes object.

Syntax

public ImGearScrollInfo getScrollInfo(
   IImGearScrollableView pageView
)

Parameters

pageView
IImGearScrollableView interface, represents Java context to draw image in.

Return Value

New instance of ImGearScrollInfo structure object. ImGearScrollInfo IImGearScrollableView

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

getZoomInfo Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : getZoomInfo Method
pageView
IImGearScrollableView interface, represents Java context to draw image in.

Glossary Item Box

Returns a new instance of an object containing current zoom settings.

Syntax

public ImGearZoomInfo getZoomInfo(
   IImGearScrollableView pageView
)

Parameters

pageView
IImGearScrollableView interface, represents Java context to draw image in.

Return Value

New instance of ImGearZoomInfo structure object. ImGearZoomInfo IImGearScrollableView

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

handleScroll Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : handleScroll Method
pageView
IImGearScrollableView interface, represents Java context to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position. IImGearScrollableView ImGearScrollBarType

Glossary Item Box

Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

Syntax

public void handleScroll(
   IImGearScrollableView pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)

Parameters

pageView
IImGearScrollableView interface, represents Java context to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position. IImGearScrollableView ImGearScrollBarType

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

internalUseOnly Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : internalUseOnly Method

Glossary Item Box

Gets the ImGearPageDisplay.

Syntax

public java.lang.Object internalUseOnly()

Return Value

ImGearPageDisplay object.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

onLutUpdated Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : onLutUpdated Method
e
Event arguments.

Glossary Item Box

Occurs when the lookup table is updated.

Syntax

protected void onLutUpdated(
   ImGearEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

onPageScrolled Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : onPageScrolled Method
e
Event arguments.

Glossary Item Box

Occurs when a page is scrolled.

Syntax

protected void onPageScrolled(
   ImGearEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

onPageZoomed Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : onPageZoomed Method
e
Event arguments.

Glossary Item Box

Occurs when a page is zoomed.

Syntax

protected void onPageZoomed(
   ImGearEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Can be called by subclasses when their properties change. Subscribers, com.accusoft.imagegear.callbackinterfaces.IImGearPropertyChangedListener are subsequently notified.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

print Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : print Method
graphics
Graphics object to draw the image on.

Glossary Item Box

Draws the image on Java Graphics for printing. Call to Print(hdc) is equal to call drawEx(null, hdc, true).

Syntax

public void print(
   java.awt.Graphics graphics
)

Parameters

graphics
Graphics object to draw the image on.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

scrollTo Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : scrollTo Method
pageView
IImGearScrollableView interface; represents Java context to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Glossary Item Box

Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

Syntax

public ImGearScrollInfo scrollTo(
   IImGearScrollableView pageView,
   int positionX,
   int positionY
)

Parameters

pageView
IImGearScrollableView interface; represents Java context to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Return Value

Instance of ImGearScrollInfo structure object. ImGearScrollInfo IImGearScrollableView

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setARTPage Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setARTPage Method
value

Glossary Item Box

Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Syntax

public void setARTPage(
   ImGearAnnotationPage value
)

Parameters

value

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setBrightness Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setBrightness Method
value

Glossary Item Box

Sets the brightness level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 0.

Syntax

public void setBrightness(
   double value
)

Parameters

value

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setContrast Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setContrast Method
value

Glossary Item Box

Sets the contrast level of the displayed image.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

Syntax

public void setContrast(
   double value
)

Parameters

value

Return Value

Double value.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setDICOMDisplaySettings Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setDICOMDisplaySettings Method
value
com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

Glossary Item Box

Sets the DICOM specific display contrast settings.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.DICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast IImGearDICOMDisplaySettings interface to the actual class ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

public void setDICOMDisplaySettings(
   IImGearDICOMDisplaySettings value
)

Parameters

value
com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setGamma Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setGamma Method
value

Glossary Item Box

Sets the gamma level of the displayed image.

Double value.

Changing this property does not permanently affect the loaded image in memory.

The default value is 1.

Syntax

public void setGamma(
   double value
)

Parameters

value

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setLUT Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setLUT Method
value
com.accusoft.imagegear.core.ImGearMultichannelLUT class.

Glossary Item Box

Sets a display lookup table.

This property only supports com.accusoft.imagegear.core.ImGearRGBLUT class objects.

com.accusoft.imagegear.core.ImGearMultichannelLUT

Syntax

public void setLUT(
   ImGearMultichannelLUT value
)

Parameters

value
com.accusoft.imagegear.core.ImGearMultichannelLUT class.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

setPage Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : setPage Method
value

Glossary Item Box

Sets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null.

Syntax

public void setPage(
   ImGearPage value
)

Parameters

value

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

updateLUT Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : updateLUT Method
colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.

The ImGearPageDisplay lookup table is updated as follows:

  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.

com.accusoft.imagegear.core.ImGearMultichannelLUT IImGearContrastSettings

Glossary Item Box

Updates the ImGearPageDisplay lookup table.

Syntax

public void updateLUT(
   ImGearMultichannelLUT colorLUT,
   IImGearContrastSettings contrastSettings
)

Parameters

colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.

The ImGearPageDisplay lookup table is updated as follows:

  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.

com.accusoft.imagegear.core.ImGearMultichannelLUT IImGearContrastSettings

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

updateScrollFrom Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : updateScrollFrom Method
pageView
IImGearScrollableView interface; represents Java context to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars. IImGearScrollableView ImGearScrollInfo

Glossary Item Box

Updates image scroll attributes with new values.

Syntax

public void updateScrollFrom(
   IImGearScrollableView pageView,
   ImGearScrollInfo scrollInfo
)

Parameters

pageView
IImGearScrollableView interface; represents Java context to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars. IImGearScrollableView ImGearScrollInfo

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

updateZoomFrom Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : updateZoomFrom Method
zoomInfo
ImGearZoomInfo object with new zoom attributes. ImGearZoomInfo

Glossary Item Box

Updates image zoom attributes.

Syntax

public void updateZoomFrom(
   ImGearZoomInfo zoomInfo
)

Parameters

zoomInfo
ImGearZoomInfo object with new zoom attributes. ImGearZoomInfo

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

zoomToRectangle Method
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : zoomToRectangle Method
pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle. IImGearScrollableView com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Syntax

public void zoomToRectangle(
   IImGearScrollableView pageView,
   ImGearRectangle rect
)

Parameters

pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle. IImGearScrollableView com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPageDisplay Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearPageDisplay Class

Glossary Item Box

For a list of all members of this type, see ImGearPageDisplay members.

Public Fields

 | Name | Description
public Field | lutUpdated | Occurs when the lookup table is updated.
public Field | pageScrolled | Occurs when a pages is scrolled.
public Field | pageZoomed | Occurs when a page is zoomed.
Top

See Also

Reference

ImGearPageDisplay Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

lutUpdated Field
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : lutUpdated Field

Glossary Item Box

Occurs when the lookup table is updated.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearEventArgs> lutUpdated

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

pageScrolled Field
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : pageScrolled Field

Glossary Item Box

Occurs when a pages is scrolled.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearEventArgs> pageScrolled

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

pageZoomed Field
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : pageZoomed Field

Glossary Item Box

Occurs when a page is zoomed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearEventArgs> pageZoomed

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.display Package > ImGearPageDisplay Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearPageDisplay Class
ImGearPageDisplay Members


%%PageItemTitle%%

ImGearScrollComponentInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollComponentInfo Class

Glossary Item Box

Implements state of one scrollbar and uses pass scrolling information to and from ImageGear display code.

Object Model

ImGearScrollComponentInfo Class

Syntax

public sealed class ImGearScrollComponentInfo
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearScrollComponentInfo

See Also

Reference

ImGearScrollComponentInfo Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearScrollComponentInfo Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollComponentInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearScrollComponentInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearScrollComponentInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | max | Specifies maximim scrolling position. Integer value. ImGearScrollComponentInfo
public Field | min | Specifies minimum scrolling position. Integer value. ImGearScrollComponentInfo
public Field | mode | Specifies the scrollbar visibility mode. ImGearScrollBarModes enumeration values. ImGearScrollBarModes
public Field | page | Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box. Integer value. ImGearScrollComponentInfo
public Field | pos | Specifies current image scrolling position. Integer value. ImGearScrollComponentInfo
Top

See Also

Reference

ImGearScrollComponentInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearScrollComponentInfo Constructor
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : ImGearScrollComponentInfo Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearScrollComponentInfo Constructor(int,int,int,int,ImGearScrollBarModes) | Constructor to set all fields.
ImGearScrollComponentInfo Constructor() | Default constructor.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

ImGearScrollComponentInfo Constructor(int,int,int,int,ImGearScrollBarModes)
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class > ImGearScrollComponentInfo Constructor : ImGearScrollComponentInfo Constructor(int,int,int,int,ImGearScrollBarModes)
mx
mn
pg
pstn
md

Glossary Item Box

Constructor to set all fields.

Syntax

public ImGearScrollComponentInfo(
   int mx,
   int mn,
   int pg,
   int pstn,
   ImGearScrollBarModes md
)

Parameters

mx
mn
pg
pstn
md

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members
Overload List


%%PageItemTitle%%

ImGearScrollComponentInfo Constructor()
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class > ImGearScrollComponentInfo Constructor : ImGearScrollComponentInfo Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearScrollComponentInfo()

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members
Overload List


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearScrollComponentInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollComponentInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearScrollComponentInfo members.

Public Fields

 | Name | Description
public Field | max | Specifies maximim scrolling position. Integer value. ImGearScrollComponentInfo
public Field | min | Specifies minimum scrolling position. Integer value. ImGearScrollComponentInfo
public Field | mode | Specifies the scrollbar visibility mode. ImGearScrollBarModes enumeration values. ImGearScrollBarModes
public Field | page | Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box. Integer value. ImGearScrollComponentInfo
public Field | pos | Specifies current image scrolling position. Integer value. ImGearScrollComponentInfo
Top

See Also

Reference

ImGearScrollComponentInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

max Field
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : max Field

Glossary Item Box

Specifies maximim scrolling position.

Integer value. ImGearScrollComponentInfo

Syntax

public int max

Return Value

Integer value.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

min Field
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : min Field

Glossary Item Box

Specifies minimum scrolling position.

Integer value. ImGearScrollComponentInfo

Syntax

public int min

Return Value

Integer value.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

mode Field
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : mode Field

Glossary Item Box

Specifies the scrollbar visibility mode.

ImGearScrollBarModes enumeration values. ImGearScrollBarModes

Syntax

public ImGearScrollBarModes mode

Return Value

ImGearScrollBarModes enumeration values.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

page Field
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : page Field

Glossary Item Box

Specifies the page size. A scrollbar uses this value to determine the appropriate size of the proportional scroll box.

Integer value. ImGearScrollComponentInfo

Syntax

public int page

Return Value

Integer value.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

pos Field
com.accusoft.imagegear.display Package > ImGearScrollComponentInfo Class : pos Field

Glossary Item Box

Specifies current image scrolling position.

Integer value. ImGearScrollComponentInfo

Syntax

public int pos

Return Value

Integer value.

See Also

Reference

ImGearScrollComponentInfo Class
ImGearScrollComponentInfo Members


%%PageItemTitle%%

ImGearScrollInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollInfo Class

Glossary Item Box

Represents scrolling state of the image.

Object Model

ImGearScrollInfo Class

Syntax

public sealed class ImGearScrollInfo
    extends Object
    implements IImGearDisplayObject

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearScrollInfo

See Also

Reference

ImGearScrollInfo Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearScrollInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearScrollInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearScrollInfo Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | horizontal | Stores information about horizontal image scrolling state. ImGearScrollComponentInfo structure object. ImGearScrollComponentInfo
public Field | vertical | Stores information about vertical image scrolling state. ImGearScrollComponentInfo structure. ImGearScrollComponentInfo
Top

Public Methods

Name | Description
public Method | copyFrom | Initializes the object from existing ImGearScrollInfo structure object.
public Method initToDefault Initializes the object with default valid values.

Default scroll values for both vertical and horizontal directions are following:

  • Scrollbar mode is set to ImGearScrollBarModes.SCROLLBAR_AUTO
  • Min, Max, Pos and Page properties are set to 0

ImGearScrollBarModes

Top

See Also

Reference

ImGearScrollInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearScrollInfo Constructor
com.accusoft.imagegear.display Package > ImGearScrollInfo Class : ImGearScrollInfo Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearScrollInfo()

See Also

Reference

ImGearScrollInfo Class
ImGearScrollInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearScrollInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearScrollInfo members.

Public Methods

Name | Description
public Method | copyFrom | Initializes the object from existing ImGearScrollInfo structure object.
public Method initToDefault Initializes the object with default valid values.

Default scroll values for both vertical and horizontal directions are following:

  • Scrollbar mode is set to ImGearScrollBarModes.SCROLLBAR_AUTO
  • Min, Max, Pos and Page properties are set to 0

ImGearScrollBarModes

Top

See Also

Reference

ImGearScrollInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.display Package > ImGearScrollInfo Class : copyFrom Method
value
An ImGearScrollInfo structure object to copy. IImGearDisplayObject

Glossary Item Box

Initializes the object from existing ImGearScrollInfo structure object.

Syntax

public void copyFrom(
   IImGearDisplayObject value
)

Parameters

value
An ImGearScrollInfo structure object to copy. IImGearDisplayObject

See Also

Reference

ImGearScrollInfo Class
ImGearScrollInfo Members


%%PageItemTitle%%

initToDefault Method
com.accusoft.imagegear.display Package > ImGearScrollInfo Class : initToDefault Method

Glossary Item Box

Initializes the object with default valid values.

Default scroll values for both vertical and horizontal directions are following:

  • Scrollbar mode is set to ImGearScrollBarModes.SCROLLBAR_AUTO
  • Min, Max, Pos and Page properties are set to 0

ImGearScrollBarModes

Syntax

public void initToDefault()

See Also

Reference

ImGearScrollInfo Class
ImGearScrollInfo Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearScrollInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearScrollInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearScrollInfo members.

Public Fields

 | Name | Description
public Field | horizontal | Stores information about horizontal image scrolling state. ImGearScrollComponentInfo structure object. ImGearScrollComponentInfo
public Field | vertical | Stores information about vertical image scrolling state. ImGearScrollComponentInfo structure. ImGearScrollComponentInfo
Top

See Also

Reference

ImGearScrollInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

horizontal Field
com.accusoft.imagegear.display Package > ImGearScrollInfo Class : horizontal Field

Glossary Item Box

Stores information about horizontal image scrolling state.

ImGearScrollComponentInfo structure object. ImGearScrollComponentInfo

Syntax

public ImGearScrollComponentInfo horizontal

Return Value

ImGearScrollComponentInfo structure object.

See Also

Reference

ImGearScrollInfo Class
ImGearScrollInfo Members


%%PageItemTitle%%

vertical Field
com.accusoft.imagegear.display Package > ImGearScrollInfo Class : vertical Field

Glossary Item Box

Stores information about vertical image scrolling state.

ImGearScrollComponentInfo structure. ImGearScrollComponentInfo

Syntax

public ImGearScrollComponentInfo vertical

Return Value

ImGearScrollComponentInfo structure.

See Also

Reference

ImGearScrollInfo Class
ImGearScrollInfo Members


%%PageItemTitle%%

ImGearZoomComponentInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomComponentInfo Class

Glossary Item Box

Stores information about image zoom in one dimension (vertical or horizontal).

Object Model

ImGearZoomComponentInfo Class

Syntax

public sealed class ImGearZoomComponentInfo
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearZoomComponentInfo

See Also

Reference

ImGearZoomComponentInfo Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearZoomComponentInfo Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomComponentInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearZoomComponentInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearZoomComponentInfo Constructor | Default constructor.
Top

Public Fields

 | Name | Description
public Field | fixed | Specifies fixed or non-fixed zoom mode. Fixed zoom value (true) indicates that Value field is in use. With non-fixed zoom value (false), actual zoom factor is calculated without Value field information. Boolean value.
public Field | value | Specifies zoom value. When zoom mode ( fixed field) is set to false, this field is ignored. Any positive double value.
Top

See Also

Reference

ImGearZoomComponentInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearZoomComponentInfo Constructor
com.accusoft.imagegear.display Package > ImGearZoomComponentInfo Class : ImGearZoomComponentInfo Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearZoomComponentInfo()

See Also

Reference

ImGearZoomComponentInfo Class
ImGearZoomComponentInfo Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearZoomComponentInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomComponentInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearZoomComponentInfo members.

Public Fields

 | Name | Description
public Field | fixed | Specifies fixed or non-fixed zoom mode. Fixed zoom value (true) indicates that Value field is in use. With non-fixed zoom value (false), actual zoom factor is calculated without Value field information. Boolean value.
public Field | value | Specifies zoom value. When zoom mode ( fixed field) is set to false, this field is ignored. Any positive double value.
Top

See Also

Reference

ImGearZoomComponentInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

fixed Field
com.accusoft.imagegear.display Package > ImGearZoomComponentInfo Class : fixed Field

Glossary Item Box

Specifies fixed or non-fixed zoom mode.

Fixed zoom value (true) indicates that Value field is in use. With non-fixed zoom value (false), actual zoom factor is calculated without Value field information.

Boolean value.

Syntax

public boolean fixed

Return Value

Boolean value.

See Also

Reference

ImGearZoomComponentInfo Class
ImGearZoomComponentInfo Members


%%PageItemTitle%%

value Field
com.accusoft.imagegear.display Package > ImGearZoomComponentInfo Class : value Field

Glossary Item Box

Specifies zoom value.

When zoom mode ( fixed field) is set to false, this field is ignored.

Any positive double value.

Syntax

public double value

Return Value

Any positive double value.

See Also

Reference

ImGearZoomComponentInfo Class
ImGearZoomComponentInfo Members


%%PageItemTitle%%

ImGearZoomInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomInfo Class

Glossary Item Box

Represents complete image zoom information.

Object Model

ImGearZoomInfo Class

Syntax

public sealed class ImGearZoomInfo
    extends Object
    implements IImGearDisplayObject

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.display.ImGearZoomInfo

See Also

Reference

ImGearZoomInfo Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearZoomInfo Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearZoomInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearZoomInfo Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | horizontal | Scecifies horizontal zoom information. ImGearZoomComponentInfo structure ImGearZoomComponentInfo
public Field | vertical | Specifies vertical zoom information. ImGearZoomComponentInfo structure ImGearZoomComponentInfo
Top

Public Methods

 | Name | Description
public Method | copyFrom | Initializes the object from existing ImGearZoomInfo structure object.
public Method | initToDefault | Initializes the object with default valid values. Default zoom value is 1 and non-fixed mode (for both vertical and horizontal directions).
Top

See Also

Reference

ImGearZoomInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearZoomInfo Constructor
com.accusoft.imagegear.display Package > ImGearZoomInfo Class : ImGearZoomInfo Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearZoomInfo Constructor(double,double,boolean,boolean) | Initializes a new instance of the ImGearZoomInfo structure using the specified values.
ImGearZoomInfo Constructor(ImGearZoomComponentInfo,ImGearZoomComponentInfo) | Initialize fields.
ImGearZoomInfo Constructor() | Default constructor.

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members


%%PageItemTitle%%

ImGearZoomInfo Constructor(double,double,boolean,boolean)
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearZoomInfo Class > ImGearZoomInfo Constructor : ImGearZoomInfo Constructor(double,double,boolean,boolean)
horizontalZoomValue
Horizontal zoom value.
verticalZoomValue
Vertical zoom value.
isHorizontalZoomFixed
A value indicating whether horizontal zoom is fixed.
isVerticalZoomFixed
A value indicating whether vertical zoom is fixed.

Glossary Item Box

Initializes a new instance of the ImGearZoomInfo structure using the specified values.

Syntax

public ImGearZoomInfo(
   double horizontalZoomValue,
   double verticalZoomValue,
   boolean isHorizontalZoomFixed,
   boolean isVerticalZoomFixed
)

Parameters

horizontalZoomValue
Horizontal zoom value.
verticalZoomValue
Vertical zoom value.
isHorizontalZoomFixed
A value indicating whether horizontal zoom is fixed.
isVerticalZoomFixed
A value indicating whether vertical zoom is fixed.

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members
Overload List


%%PageItemTitle%%

ImGearZoomInfo Constructor(ImGearZoomComponentInfo,ImGearZoomComponentInfo)
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearZoomInfo Class > ImGearZoomInfo Constructor : ImGearZoomInfo Constructor(ImGearZoomComponentInfo,ImGearZoomComponentInfo)
hrzntl
The horizontal zoom information.
vrtcl
The vertical zoom information.

Glossary Item Box

Initialize fields.

Syntax

public ImGearZoomInfo(
   ImGearZoomComponentInfo hrzntl,
   ImGearZoomComponentInfo vrtcl
)

Parameters

hrzntl
The horizontal zoom information.
vrtcl
The vertical zoom information.

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members
Overload List


%%PageItemTitle%%

ImGearZoomInfo Constructor()
See Also Send Feedback
com.accusoft.imagegear.display Package > ImGearZoomInfo Class > ImGearZoomInfo Constructor : ImGearZoomInfo Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearZoomInfo()

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearZoomInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearZoomInfo members.

Public Methods

 | Name | Description
public Method | copyFrom | Initializes the object from existing ImGearZoomInfo structure object.
public Method | initToDefault | Initializes the object with default valid values. Default zoom value is 1 and non-fixed mode (for both vertical and horizontal directions).
Top

See Also

Reference

ImGearZoomInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.display Package > ImGearZoomInfo Class : copyFrom Method
value
An ImGearZoomInfo structure object to copy. IImGearDisplayObject

Glossary Item Box

Initializes the object from existing ImGearZoomInfo structure object.

Syntax

public void copyFrom(
   IImGearDisplayObject value
)

Parameters

value
An ImGearZoomInfo structure object to copy. IImGearDisplayObject

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members


%%PageItemTitle%%

initToDefault Method
com.accusoft.imagegear.display Package > ImGearZoomInfo Class : initToDefault Method

Glossary Item Box

Initializes the object with default valid values.

Default zoom value is 1 and non-fixed mode (for both vertical and horizontal directions).

Syntax

public void initToDefault()

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearZoomInfo Class Fields
See Also Send Feedback
com.accusoft.imagegear.display Package : ImGearZoomInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearZoomInfo members.

Public Fields

 | Name | Description
public Field | horizontal | Scecifies horizontal zoom information. ImGearZoomComponentInfo structure ImGearZoomComponentInfo
public Field | vertical | Specifies vertical zoom information. ImGearZoomComponentInfo structure ImGearZoomComponentInfo
Top

See Also

Reference

ImGearZoomInfo Class
com.accusoft.imagegear.display Package


%%PageItemTitle%%

horizontal Field
com.accusoft.imagegear.display Package > ImGearZoomInfo Class : horizontal Field

Glossary Item Box

Scecifies horizontal zoom information.

ImGearZoomComponentInfo structure ImGearZoomComponentInfo

Syntax

public ImGearZoomComponentInfo horizontal

Return Value

ImGearZoomComponentInfo structure

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members


%%PageItemTitle%%

vertical Field
com.accusoft.imagegear.display Package > ImGearZoomInfo Class : vertical Field

Glossary Item Box

Specifies vertical zoom information.

ImGearZoomComponentInfo structure ImGearZoomComponentInfo

Syntax

public ImGearZoomComponentInfo vertical

Return Value

ImGearZoomComponentInfo structure

See Also

Reference

ImGearZoomInfo Class
ImGearZoomInfo Members


%%PageItemTitle%%

ImGearAliasModes Enumeration
com.accusoft.imagegear.display Package : ImGearAliasModes Enumeration

Glossary Item Box

Identifies different types of image aliasing.

Applicable only if a 1-bit-per-pixel image is to be drawn and only if the destination image has a lower resolution than the original one.

Members

Member | Description
NONE | Anti-aliasing is not used.
PRESERVE_BLACK | This mode directs ImageGear to preserve black pixels while drawing.
PRESERVE_WHITE | This mode directs ImageGear to preserve white pixels while drawing.
SCALE_TO_GRAY | The scale-to-gray algorithm is used. The output is in 8 bits per pixel format.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearAliasModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearAlignmentHModes Enumeration
com.accusoft.imagegear.display Package : ImGearAlignmentHModes Enumeration

Glossary Item Box

Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).

Members

Member | Description
CENTER | The image is centered horizontally.
LEFT | The image is aligned to the left border of the device rectangle.
RIGHT | The image is aligned to the right border of the device rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearAlignmentHModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearAlignmentVModes Enumeration
com.accusoft.imagegear.display Package : ImGearAlignmentVModes Enumeration

Glossary Item Box

Identifies the different types of image display alignment modes (i.e., identifies how the displayed image is aligned relative to the device rectangle).

Members

Member | Description
BOTTOM | The image is aligned to the bottom border of the device rectangle.
CENTER | The image is centered vertically.
TOP | The image is aligned to the top border of the device rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearAlignmentVModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearBackgroundModes Enumeration
com.accusoft.imagegear.display Package : ImGearBackgroundModes Enumeration

Glossary Item Box

Specifies ImageGear background modes.

Members

Member | Description
BEYOND_IMAGE | Fill device rectangle beyond the image area with background color.
NONE | Do not draw background.
UNDER_IMAGE | Fill the area under the image with background color. This mode has effect if image has transparent color or alpha channel.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearBackgroundModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearColorAliasModes Enumeration
com.accusoft.imagegear.display Package : ImGearColorAliasModes Enumeration

Glossary Item Box

Specifies color anti-aliasing mode.

Members

Member | Description
INTERPOLATE | Interpolation anti-aliasing is used for color images.
NONE | Anti-aliasing is not used for color images.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearColorAliasModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearCoordConvModes Enumeration
com.accusoft.imagegear.display Package : ImGearCoordConvModes Enumeration

Glossary Item Box

Identifies coordinate translation methods.

Members

Member | Description
DEVICE_TO_IMAGE | Convert coordinates from device to image.
IMAGE_TO_DEVICE | Convert coordinates from image to device.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearCoordConvModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearFitModes Enumeration
com.accusoft.imagegear.display Package : ImGearFitModes Enumeration

Glossary Item Box

Identifies how an image fits to the device rectangle.

Members

Member | Description
ACTUAL_SIZE | The device rectangle is ignored, and the image is scaled 1:1.
FIT_TO_DEVICE | The image is scaled to fit both the width and height of the device rectangle.
FIT_TO_HEIGHT | The image is scaled to fit the height of the device rectangle.
FIT_TO_WIDTH | The image is scaled to fit the width of the device rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearFitModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearResampleModes Enumeration
com.accusoft.imagegear.display Package : ImGearResampleModes Enumeration

Glossary Item Box

Specifies re-sampling mode.

Members

Member | Description
BILINEAR | Bilinear re-sampling is used.
NONE | Re-sampling is not used.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearResampleModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearScrollBarModes Enumeration
com.accusoft.imagegear.display Package : ImGearScrollBarModes Enumeration

Glossary Item Box

Identifies scroll bar visibility methods.

Members

Member | Description
SCROLLBAR_AUTO | Automatically show and hide scrollbar when required according to image zoom.
SCROLLBAR_DISABLE | Always hide scrollbar.
SCROLLBAR_ENABLE | Always show scrollbar.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearScrollBarModes

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

ImGearScrollBarType Enumeration
com.accusoft.imagegear.display Package : ImGearScrollBarType Enumeration

Glossary Item Box

Identifies scrollbar types.

Members

Member | Description
HORIZONTAL | Horizontal scrollbar.
VERTICAL | Vertical scrollbar.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.display.ImGearScrollBarType

See Also

Reference

com.accusoft.imagegear.display Package


%%PageItemTitle%%

IImGearAlignment Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearAlignment Interface

Glossary Item Box

Provides access to display alignment modes.

Syntax

public interface IImGearAlignment
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearAlignment Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearAlignment Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearAlignment Interface

Glossary Item Box

The following tables list the members exposed by IImGearAlignment.

Public Methods

 | Name | Description
Method | getHorizontal | Gets image horizontal alignment mode. ImGearAlignmentHModes enumeration values.
Method | getVertical | Gets image vertical alignment mode. ImGearAlignmentVModes enumeration values.
Method | setHorizontal | Sets image horizontal alignment mode. ImGearAlignmentHModes enumeration values.
Method | setVertical | Sets image vertical alignment mode. ImGearAlignmentVModes enumeration values.
Top

See Also

Reference

IImGearAlignment Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearAlignment Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearAlignment Interface

Glossary Item Box

For a list of all members of this type, see IImGearAlignment members.

Public Methods

 | Name | Description
Method | getHorizontal | Gets image horizontal alignment mode. ImGearAlignmentHModes enumeration values.
Method | getVertical | Gets image vertical alignment mode. ImGearAlignmentVModes enumeration values.
Method | setHorizontal | Sets image horizontal alignment mode. ImGearAlignmentHModes enumeration values.
Method | setVertical | Sets image vertical alignment mode. ImGearAlignmentVModes enumeration values.
Top

See Also

Reference

IImGearAlignment Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getHorizontal Method
com.accusoft.imagegear.display Package > IImGearAlignment Interface : getHorizontal Method

Glossary Item Box

Gets image horizontal alignment mode.

ImGearAlignmentHModes enumeration values.

Syntax

ImGearAlignmentHModes getHorizontal()

See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members


%%PageItemTitle%%

getVertical Method
com.accusoft.imagegear.display Package > IImGearAlignment Interface : getVertical Method

Glossary Item Box

Gets image vertical alignment mode.

ImGearAlignmentVModes enumeration values.

Syntax

ImGearAlignmentVModes getVertical()

See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members


%%PageItemTitle%%

setHorizontal Method
com.accusoft.imagegear.display Package > IImGearAlignment Interface : setHorizontal Method
hMds

Glossary Item Box

Sets image horizontal alignment mode.

ImGearAlignmentHModes enumeration values.

Syntax

void setHorizontal(
   ImGearAlignmentHModes hMds
)

Parameters

hMds

See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members


%%PageItemTitle%%

setVertical Method
com.accusoft.imagegear.display Package > IImGearAlignment Interface : setVertical Method
vMds

Glossary Item Box

Sets image vertical alignment mode.

ImGearAlignmentVModes enumeration values.

Syntax

void setVertical(
   ImGearAlignmentVModes vMds
)

Parameters

vMds

See Also

Reference

IImGearAlignment Interface
IImGearAlignment Members


%%PageItemTitle%%

IImGearAntiAlias Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearAntiAlias Interface

Glossary Item Box

Provides access to bitonal anti-aliasing attributes.

Syntax

public interface IImGearAntiAlias
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearAntiAlias Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearAntiAlias Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearAntiAlias Interface

Glossary Item Box

The following tables list the members exposed by IImGearAntiAlias.

Public Methods

 | Name | Description
Method | getMethod | Gets an image anti-aliasing method to use. This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one. ImGearAliasModes enumeration value. ImGearAliasModes
Method | getThreshold | Gets an image aliasing threshold attribute. Integer in range [0..100]. Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50. ImGearAliasModes getMethod
Method | setMethod | Sets an image anti-aliasing method to use. This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one. ImGearAliasModes enumeration value. ImGearAliasModes
Method | setThreshold | Sets an image aliasing threshold attribute. Integer in range [0..100]. Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50. ImGearAliasModes getMethod
Top

See Also

Reference

IImGearAntiAlias Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearAntiAlias Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearAntiAlias Interface

Glossary Item Box

For a list of all members of this type, see IImGearAntiAlias members.

Public Methods

 | Name | Description
Method | getMethod | Gets an image anti-aliasing method to use. This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one. ImGearAliasModes enumeration value. ImGearAliasModes
Method | getThreshold | Gets an image aliasing threshold attribute. Integer in range [0..100]. Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50. ImGearAliasModes getMethod
Method | setMethod | Sets an image anti-aliasing method to use. This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one. ImGearAliasModes enumeration value. ImGearAliasModes
Method | setThreshold | Sets an image aliasing threshold attribute. Integer in range [0..100]. Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50. ImGearAliasModes getMethod
Top

See Also

Reference

IImGearAntiAlias Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getMethod Method
com.accusoft.imagegear.display Package > IImGearAntiAlias Interface : getMethod Method

Glossary Item Box

Gets an image anti-aliasing method to use.

This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one.

ImGearAliasModes enumeration value. ImGearAliasModes

Syntax

ImGearAliasModes getMethod()

See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members


%%PageItemTitle%%

getThreshold Method
com.accusoft.imagegear.display Package > IImGearAntiAlias Interface : getThreshold Method

Glossary Item Box

Gets an image aliasing threshold attribute.

Integer in range [0..100].

Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50.

ImGearAliasModes getMethod

Syntax

int getThreshold()

See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members


%%PageItemTitle%%

setMethod Method
com.accusoft.imagegear.display Package > IImGearAntiAlias Interface : setMethod Method
value

Glossary Item Box

Sets an image anti-aliasing method to use.

This mode is applicable only if a 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one.

ImGearAliasModes enumeration value. ImGearAliasModes

Syntax

void setMethod(
   ImGearAliasModes value
)

Parameters

value

See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members


%%PageItemTitle%%

setThreshold Method
com.accusoft.imagegear.display Package > IImGearAntiAlias Interface : setThreshold Method
value

Glossary Item Box

Sets an image aliasing threshold attribute.

Integer in range [0..100].

Its meaning depends on the Method value: If Method is set to ImGearAliasModes.SCALE_TO_GRAY, Threshold determines the number of black and white pixels in the destination gray pixel value. A value of 100 directs ImageGear to take 100% of white pixels. A value of 0 directs ImageGear to take 100% of black pixels. The default value, which is 50, directs ImageGear to take 50% white and 50% black pixels. If Method is set to ImGearAliasModes.PRESERVE_BLACK, Threshold determines the number of black pixels to preserve. A value of 100 means that 100% of the black pixels are preserved. The default value is 50. If Method is set to ImGearAliasModes.PRESERVE_WHITE, Threshold determines the number of white pixels to preserve. A value of 100 means that 100% of white pixels are preserved. The default value is 50.

ImGearAliasModes getMethod

Syntax

void setThreshold(
   int value
)

Parameters

value

See Also

Reference

IImGearAntiAlias Interface
IImGearAntiAlias Members


%%PageItemTitle%%

IImGearAspectRatio Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearAspectRatio Interface

Glossary Item Box

Provides access to display aspect ratio attributes.

Syntax

public interface IImGearAspectRatio
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearAspectRatio Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearAspectRatio Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearAspectRatio Interface

Glossary Item Box

The following tables list the members exposed by IImGearAspectRatio.

Public Methods

 | Name | Description
Method | getValue | Gets image's display aspect ratio (i.e., width-to-height ratio). Double value. When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored. IImGearAspectRatio
Method | isFixed | Gets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle. Boolean value. This value identifies the different types of image display aspect ratio (i.e., width-to-height ratio). getValue
Method | setFixed | Sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle. Boolean value. This method identifies the different types of image display aspect ratio (i.e., width-to-height ratio). Calling this method with true argument ratio is specified by getValue field parameter. Setting it to false indicates that the aspect ratio is specified by the device rectangle. getValue
Method | setValue | Sets image's display aspect ratio (i.e., width-to-height ratio). Double value. When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored. IImGearAspectRatio
Top

See Also

Reference

IImGearAspectRatio Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearAspectRatio Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearAspectRatio Interface

Glossary Item Box

For a list of all members of this type, see IImGearAspectRatio members.

Public Methods

 | Name | Description
Method | getValue | Gets image's display aspect ratio (i.e., width-to-height ratio). Double value. When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored. IImGearAspectRatio
Method | isFixed | Gets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle. Boolean value. This value identifies the different types of image display aspect ratio (i.e., width-to-height ratio). getValue
Method | setFixed | Sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle. Boolean value. This method identifies the different types of image display aspect ratio (i.e., width-to-height ratio). Calling this method with true argument ratio is specified by getValue field parameter. Setting it to false indicates that the aspect ratio is specified by the device rectangle. getValue
Method | setValue | Sets image's display aspect ratio (i.e., width-to-height ratio). Double value. When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored. IImGearAspectRatio
Top

See Also

Reference

IImGearAspectRatio Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.display Package > IImGearAspectRatio Interface : getValue Method

Glossary Item Box

Gets image's display aspect ratio (i.e., width-to-height ratio).

Double value.

When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored.

IImGearAspectRatio

Syntax

double getValue()

See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members


%%PageItemTitle%%

isFixed Method
com.accusoft.imagegear.display Package > IImGearAspectRatio Interface : isFixed Method

Glossary Item Box

Gets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle.

Boolean value.

This value identifies the different types of image display aspect ratio (i.e., width-to-height ratio). getValue

Syntax

boolean isFixed()

See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members


%%PageItemTitle%%

setFixed Method
com.accusoft.imagegear.display Package > IImGearAspectRatio Interface : setFixed Method
fxd

Glossary Item Box

Sets a value indicating whether the aspect ratio is specified by Value field parameter or by the device rectangle.

Boolean value.

This method identifies the different types of image display aspect ratio (i.e., width-to-height ratio). Calling this method with true argument ratio is specified by getValue field parameter. Setting it to false indicates that the aspect ratio is specified by the device rectangle.

getValue

Syntax

void setFixed(
   boolean fxd
)

Parameters

fxd

See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.display Package > IImGearAspectRatio Interface : setValue Method
value

Glossary Item Box

Sets image's display aspect ratio (i.e., width-to-height ratio).

Double value.

When IImGearAspectRatio is set to true, specifies image aspect ratio. Otherwise, it is ignored.

IImGearAspectRatio

Syntax

void setValue(
   double value
)

Parameters

value

See Also

Reference

IImGearAspectRatio Interface
IImGearAspectRatio Members


%%PageItemTitle%%

IImGearBackground Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearBackground Interface

Glossary Item Box

Provides access to display background attributes.

There are no objects implementing this interface. It is accessed via ImGearPageDisplay.getBackground method of ImGearPageDisplay class.

Syntax

public interface IImGearBackground
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearBackground Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearBackground Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearBackground Interface

Glossary Item Box

The following tables list the members exposed by IImGearBackground.

Public Methods

Name Description
Method getColor Gets a background color of displayed image. Area on screen not covered by image is filled with this color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Method getMode Gets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes
Method setMode Sets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes
Top

See Also

Reference

IImGearBackground Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearBackground Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearBackground Interface

Glossary Item Box

For a list of all members of this type, see IImGearBackground members.

Public Methods

Name Description
Method getColor Gets a background color of displayed image. Area on screen not covered by image is filled with this color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Method getMode Gets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes
Method setMode Sets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes
Top

See Also

Reference

IImGearBackground Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getColor Method
com.accusoft.imagegear.display Package > IImGearBackground Interface : getColor Method

Glossary Item Box

Gets a background color of displayed image. Area on screen not covered by image is filled with this color.

com.accusoft.imagegear.core.ImGearRGBQuad structure object interface. com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

IImGearRGBQuad getColor()

See Also

Reference

IImGearBackground Interface
IImGearBackground Members


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.display Package > IImGearBackground Interface : getMode Method

Glossary Item Box

Gets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes

Syntax

ImGearBackgroundModes getMode()

See Also

Reference

IImGearBackground Interface
IImGearBackground Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.display Package > IImGearBackground Interface : setMode Method
value

Glossary Item Box

Sets a background drawing mode.

  • ImGearBackgroundModes.NONE - do not draw background
  • ImGearBackgroundModes.BEYOND_IMAGE - fill device rectangle with background color before image drawing.
ImGearBackgroundModes

Syntax

void setMode(
   ImGearBackgroundModes value
)

Parameters

value

See Also

Reference

IImGearBackground Interface
IImGearBackground Members


%%PageItemTitle%%

IImGearColorAntiAlias Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearColorAntiAlias Interface

Glossary Item Box

Provides access to color anti-aliasing attributes.

Syntax

public interface IImGearColorAntiAlias
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearColorAntiAlias Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearColorAntiAlias Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearColorAntiAlias Interface

Glossary Item Box

The following tables list the members exposed by IImGearColorAntiAlias.

Public Methods

 | Name | Description
Method | getMethod | Gets a color anti-aliasing method to use. ImGearColorAliasModes enumeration value. This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out. ImGearColorAliasModes
Method | setMethod | Sets a color anti-aliasing method to use. ImGearColorAliasModes enumeration value. This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out. ImGearColorAliasModes
Top

See Also

Reference

IImGearColorAntiAlias Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearColorAntiAlias Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearColorAntiAlias Interface

Glossary Item Box

For a list of all members of this type, see IImGearColorAntiAlias members.

Public Methods

 | Name | Description
Method | getMethod | Gets a color anti-aliasing method to use. ImGearColorAliasModes enumeration value. This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out. ImGearColorAliasModes
Method | setMethod | Sets a color anti-aliasing method to use. ImGearColorAliasModes enumeration value. This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out. ImGearColorAliasModes
Top

See Also

Reference

IImGearColorAntiAlias Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getMethod Method
com.accusoft.imagegear.display Package > IImGearColorAntiAlias Interface : getMethod Method

Glossary Item Box

Gets a color anti-aliasing method to use.

ImGearColorAliasModes enumeration value.

This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out.

ImGearColorAliasModes

Syntax

ImGearColorAliasModes getMethod()

See Also

Reference

IImGearColorAntiAlias Interface
IImGearColorAntiAlias Members


%%PageItemTitle%%

setMethod Method
com.accusoft.imagegear.display Package > IImGearColorAntiAlias Interface : setMethod Method
value

Glossary Item Box

Sets a color anti-aliasing method to use.

ImGearColorAliasModes enumeration value.

This mode is applicable only if a non 1-bit-per-pixel image is to be drawn and if the destination image has a lower resolution than the original one, i.e., when the image is zoomed out.

ImGearColorAliasModes

Syntax

void setMethod(
   ImGearColorAliasModes value
)

Parameters

value

See Also

Reference

IImGearColorAntiAlias Interface
IImGearColorAntiAlias Members


%%PageItemTitle%%

IImGearContrastSettings Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearContrastSettings Interface

Glossary Item Box

Contrast settings interface used by ImGearPageDisplay.updateLUT method

Syntax

public interface IImGearContrastSettings

See Also

Reference

IImGearContrastSettings Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearContrastSettings Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearContrastSettings Interface

Glossary Item Box

The following tables list the members exposed by IImGearContrastSettings.

Public Methods

 | Name | Description
Method | getBrightness | Gets brightness attribute.
Method | getContrast | Gets contrast attribute.
Method | getGamma | Gets gamma attribute.
Method | setBrightness | Sets brightness attribute.
Method | setContrast | Sets contrast attribute.
Method | setGamma | Sets gamma attribute.
Top

See Also

Reference

IImGearContrastSettings Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearContrastSettings Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearContrastSettings Interface

Glossary Item Box

For a list of all members of this type, see IImGearContrastSettings members.

Public Methods

 | Name | Description
Method | getBrightness | Gets brightness attribute.
Method | getContrast | Gets contrast attribute.
Method | getGamma | Gets gamma attribute.
Method | setBrightness | Sets brightness attribute.
Method | setContrast | Sets contrast attribute.
Method | setGamma | Sets gamma attribute.
Top

See Also

Reference

IImGearContrastSettings Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getBrightness Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : getBrightness Method

Glossary Item Box

Gets brightness attribute.

Syntax

double getBrightness()

Return Value

Brightness attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

getContrast Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : getContrast Method

Glossary Item Box

Gets contrast attribute.

Syntax

double getContrast()

Return Value

Contrast attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

getGamma Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : getGamma Method

Glossary Item Box

Gets gamma attribute.

Syntax

double getGamma()

Return Value

Gamma attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

setBrightness Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : setBrightness Method
value
Brightness attribute.

Glossary Item Box

Sets brightness attribute.

Syntax

void setBrightness(
   double value
)

Parameters

value
Brightness attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

setContrast Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : setContrast Method
value
Contrast attribute.

Glossary Item Box

Sets contrast attribute.

Syntax

void setContrast(
   double value
)

Parameters

value
Contrast attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

setGamma Method
com.accusoft.imagegear.display Package > IImGearContrastSettings Interface : setGamma Method
value
Gamma attribute.

Glossary Item Box

Sets gamma attribute.

Syntax

void setGamma(
   double value
)

Parameters

value
Gamma attribute.

See Also

Reference

IImGearContrastSettings Interface
IImGearContrastSettings Members


%%PageItemTitle%%

IImGearDisplayObject Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearDisplayObject Interface

Glossary Item Box

Base interface for display API objects. Implemented in several display code structures.

Syntax

public interface IImGearDisplayObject

See Also

Reference

IImGearDisplayObject Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearDisplayObject Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearDisplayObject Interface

Glossary Item Box

The following tables list the members exposed by IImGearDisplayObject.

Public Methods

 | Name | Description
Method | copyFrom | Initializes IImGearDisplayObject object from existing object of the same type. Source and destination objects must be of the same type and implements IImGearDisplayObject interface.
Method | initToDefault | Initializes object to default value. This method has been introduced to complement default structure constructor (that cannot be overloaded).
Top

See Also

Reference

IImGearDisplayObject Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearDisplayObject Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearDisplayObject Interface

Glossary Item Box

For a list of all members of this type, see IImGearDisplayObject members.

Public Methods

 | Name | Description
Method | copyFrom | Initializes IImGearDisplayObject object from existing object of the same type. Source and destination objects must be of the same type and implements IImGearDisplayObject interface.
Method | initToDefault | Initializes object to default value. This method has been introduced to complement default structure constructor (that cannot be overloaded).
Top

See Also

Reference

IImGearDisplayObject Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

copyFrom Method
com.accusoft.imagegear.display Package > IImGearDisplayObject Interface : copyFrom Method
value
Source object to copy.

Glossary Item Box

Initializes IImGearDisplayObject object from existing object of the same type.

Source and destination objects must be of the same type and implements IImGearDisplayObject interface.

Syntax

void copyFrom(
   IImGearDisplayObject value
)

Parameters

value
Source object to copy.

See Also

Reference

IImGearDisplayObject Interface
IImGearDisplayObject Members


%%PageItemTitle%%

initToDefault Method
com.accusoft.imagegear.display Package > IImGearDisplayObject Interface : initToDefault Method

Glossary Item Box

Initializes object to default value.

This method has been introduced to complement default structure constructor (that cannot be overloaded).

Syntax

void initToDefault()

See Also

Reference

IImGearDisplayObject Interface
IImGearDisplayObject Members


%%PageItemTitle%%

IImGearLayout Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearLayout Interface

Glossary Item Box

Provides access to display layout attributes.

There are no objects implementing this interface. It is accessed via getLayout() method of ImGearPageDisplay object.

Syntax

public interface IImGearLayout
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearLayout Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearLayout Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearLayout Interface

Glossary Item Box

The following tables list the members exposed by IImGearLayout.

Public Methods

 | Name | Description
Method | getAlignment | Gets image alignment attributes. IImGearAlignment interface. IImGearAlignment
Method | getAspectRatio | Gets image aspect ratio attributes. IImGearAspectRatio interface. IImGearAspectRatio
Method | getClipRect | Gets image clip rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getDeviceRect | Gets device rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getFitMode | Gets image fit mode. ImGearFitModes enumerationvalues. ImGearFitModes
Method | getImageRect | Gets image rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | setFitMode | Sets image fit mode. ImGearFitModes enumerationvalues. ImGearFitModes
Method | setUseImageResolution | Sets a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout
Method | usesImageResolution | Returns a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout
Top

See Also

Reference

IImGearLayout Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearLayout Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearLayout Interface

Glossary Item Box

For a list of all members of this type, see IImGearLayout members.

Public Methods

 | Name | Description
Method | getAlignment | Gets image alignment attributes. IImGearAlignment interface. IImGearAlignment
Method | getAspectRatio | Gets image aspect ratio attributes. IImGearAspectRatio interface. IImGearAspectRatio
Method | getClipRect | Gets image clip rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getDeviceRect | Gets device rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getFitMode | Gets image fit mode. ImGearFitModes enumerationvalues. ImGearFitModes
Method | getImageRect | Gets image rectangle attribute. com.accusoft.imagegear.core.shapes.ImGearRectangle object interface. Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | setFitMode | Sets image fit mode. ImGearFitModes enumerationvalues. ImGearFitModes
Method | setUseImageResolution | Sets a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout
Method | usesImageResolution | Returns a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout
Top

See Also

Reference

IImGearLayout Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getAlignment Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getAlignment Method

Glossary Item Box

Gets image alignment attributes.

IImGearAlignment interface. IImGearAlignment

Syntax

IImGearAlignment getAlignment()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

getAspectRatio Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getAspectRatio Method

Glossary Item Box

Gets image aspect ratio attributes.

IImGearAspectRatio interface. IImGearAspectRatio

Syntax

IImGearAspectRatio getAspectRatio()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

getClipRect Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getClipRect Method

Glossary Item Box

Gets image clip rectangle attribute.

com.accusoft.imagegear.core.shapes.ImGearRectangle object interface.

Value returned is a reference to ImGearRectangle internal object.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

IImGearRectangle getClipRect()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

getDeviceRect Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getDeviceRect Method

Glossary Item Box

Gets device rectangle attribute.

com.accusoft.imagegear.core.shapes.ImGearRectangle object interface.

Value returned is a reference to ImGearRectangle internal object.

com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

IImGearRectangle getDeviceRect()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

getFitMode Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getFitMode Method

Glossary Item Box

Gets image fit mode.

ImGearFitModes enumerationvalues. ImGearFitModes

Syntax

ImGearFitModes getFitMode()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

getImageRect Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : getImageRect Method

Glossary Item Box

Gets image rectangle attribute.

com.accusoft.imagegear.core.shapes.ImGearRectangle object interface.

Value returned is a reference to ImGearRectangle internal object. com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

IImGearRectangle getImageRect()

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

setFitMode Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : setFitMode Method
fm

Glossary Item Box

Sets image fit mode.

ImGearFitModes enumerationvalues. ImGearFitModes

Syntax

void setFitMode(
   ImGearFitModes fm
)

Parameters

fm

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

setUseImageResolution Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : setUseImageResolution Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout

Syntax

void setUseImageResolution(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

usesImageResolution Method
com.accusoft.imagegear.display Package > IImGearLayout Interface : usesImageResolution Method

Glossary Item Box

Returns a value indicating whether or not the image resolution attribute affects displaying. IImGearLayout

Syntax

boolean usesImageResolution()

Return Value

Boolean value.

See Also

Reference

IImGearLayout Interface
IImGearLayout Members


%%PageItemTitle%%

IImGearPageDisplay Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearPageDisplay Interface

Glossary Item Box

Defines interface for page display.

Syntax

public interface IImGearPageDisplay

See Also

Reference

IImGearPageDisplay Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearPageDisplay Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearPageDisplay Interface

Glossary Item Box

The following tables list the members exposed by IImGearPageDisplay.

Public Methods

Name | Description
Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Method getAntiAliasing Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

Method getARTPage Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Method getBackground Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

Method getChannels Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

Method getColorAntiAliasing Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

Method getDICOMDisplaySettings Gets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Method getLayout Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null. com.accusoft.imagegear.core.ImGearPage

Method getLUT Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Method getOrientation Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Method getPage Gets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Method getResampling Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

Method | getScrollInfo | Returns new instance of image scrolling attributes object.
Method | getZoomInfo | Returns a new instance of an object containing current zoom settings.
Method handleScroll Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

Method | internalUseOnly | This method is used by ImageGear internally.
Method scrollTo Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

Method setARTPage Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Method setDICOMDisplaySettings Sets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class ImGearPageDisplay.getDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Method setLUT Sets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Method setPage Sets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Method | updateLUT | Updates the ImGearPageDisplay lookup table.
Method | updateScrollFrom | Updates image scroll attributes with new values.
Method | updateZoomFrom | Updates image zoom attributes. ImGearZoomInfo
Method zoomToRectangle Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Top

See Also

Reference

IImGearPageDisplay Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearPageDisplay Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearPageDisplay Interface

Glossary Item Box

For a list of all members of this type, see IImGearPageDisplay members.

Public Methods

Name | Description
Method | convertCoordinates | Overloaded. Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
Method getAntiAliasing Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

Method getARTPage Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Method getBackground Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

Method getChannels Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

Method getColorAntiAliasing Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

Method getDICOMDisplaySettings Gets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Method getLayout Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null. com.accusoft.imagegear.core.ImGearPage

Method getLUT Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Method getOrientation Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Method getPage Gets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Method getResampling Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

Method | getScrollInfo | Returns new instance of image scrolling attributes object.
Method | getZoomInfo | Returns a new instance of an object containing current zoom settings.
Method handleScroll Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

Method | internalUseOnly | This method is used by ImageGear internally.
Method scrollTo Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

Method setARTPage Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Method setDICOMDisplaySettings Sets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class ImGearPageDisplay.getDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Method setLUT Sets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Method setPage Sets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Method | updateLUT | Updates the ImGearPageDisplay lookup table.
Method | updateScrollFrom | Updates image scroll attributes with new values.
Method | updateZoomFrom | Updates image zoom attributes. ImGearZoomInfo
Method zoomToRectangle Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Top

See Also

Reference

IImGearPageDisplay Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

convertCoordinates Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : convertCoordinates Method

Glossary Item Box

Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.

Overload List

Overload | Description
convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.
convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) | Translates coordinates between image and device coordinate systems.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface > convertCoordinates Method : convertCoordinates(IImGearScrollableView,Graphics,ImGearCoordConvModes,ImGearArray) Method
pageView
IImGearScrollableView interface; represents Java form to draw the image on.
g
mode
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
array
Array with point coordinates. IImGearScrollableView ImGearCoordConvModes

Glossary Item Box

Translates coordinates between image and device coordinate systems (depending on the value of the "Mode" parameter). The array parameter can point to array of points or double points.

Syntax

void convertCoordinates(
   IImGearScrollableView pageView,
   java.awt.Graphics g,
   ImGearCoordConvModes mode,
   ImGearArray array
)

Parameters

pageView
IImGearScrollableView interface; represents Java form to draw the image on.
g
mode
Specifies translation direction; either IMAGE_TO_DEVICE or DEVICE_TO_IMAGE.
array
Array with point coordinates. IImGearScrollableView ImGearCoordConvModes

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
Overload List


%%PageItemTitle%%

convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) Method
See Also Send Feedback
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface > convertCoordinates Method : convertCoordinates(IImGearScrollableView,ImGearCoordConvModes,ImGearArray) Method
pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates ( com.accusoft.imagegear.core.shapes.ImGearPoint or com.accusoft.imagegear.core.shapes.ImGearDoublePoint).

Device coordinates are expressed in pixels.

IImGearScrollableView ImGearCoordConvModes

Glossary Item Box

Translates coordinates between image and device coordinate systems.

Syntax

void convertCoordinates(
   IImGearScrollableView pageView,
   ImGearCoordConvModes mode,
   ImGearArray array
)

Parameters

pageView
Represents the scrollable view object on which the image is drawn.
mode
Specifies translation direction.
array
Array with point coordinates ( com.accusoft.imagegear.core.shapes.ImGearPoint or com.accusoft.imagegear.core.shapes.ImGearDoublePoint).

Device coordinates are expressed in pixels.

IImGearScrollableView ImGearCoordConvModes

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members
Overload List


%%PageItemTitle%%

getAntiAliasing Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getAntiAliasing Method

Glossary Item Box

Gets color anti-aliasing attributes.

IImGearAntiAlias interface. IImGearAntiAlias

Syntax

IImGearAntiAlias getAntiAliasing()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getARTPage Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getARTPage Method

Glossary Item Box

Gets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Syntax

ImGearAnnotationPage getARTPage()

Return Value

The ImGearAnnotationPage.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getBackground Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getBackground Method

Glossary Item Box

Gets image display layout settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearLayout interface. IImGearLayout

Syntax

IImGearBackground getBackground()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getChannels Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getChannels Method

Glossary Item Box

Gets bitonal anti-aliasing settings.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearAntiAlias interface. IImGearAntiAlias

Syntax

ImGearDisplayChannels getChannels()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getColorAntiAliasing Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getColorAntiAliasing Method

Glossary Item Box

Gets re-sampling attributes.

IImGearResample interface object. IImGearResample

Syntax

IImGearColorAntiAlias getColorAntiAliasing()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getDICOMDisplaySettings Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getDICOMDisplaySettings Method

Glossary Item Box

Gets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

IImGearDICOMDisplaySettings getDICOMDisplaySettings()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getLayout Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getLayout Method

Glossary Item Box

Gets ImGearPage object associated with this display page.

Valid com.accusoft.imagegear.core.ImGearPage class object or null. com.accusoft.imagegear.core.ImGearPage

Syntax

IImGearLayout getLayout()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getLUT Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getLUT Method

Glossary Item Box

Gets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Syntax

ImGearMultichannelLUT getLUT()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getOrientation Method

Glossary Item Box

Gets image orientation attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

Syntax

IImGearOrientation getOrientation()

Return Value

An com.accusoft.imagegear.core.ImGearOrientation instance.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getPage Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getPage Method

Glossary Item Box

Gets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Syntax

ImGearPage getPage()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getResampling Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getResampling Method

Glossary Item Box

Gets background drawing attributes.

Value returned is a reference to ImGearPageDisplay internal object. Accordingly, its modification affects parent ImGearPageDisplay.

IImGearBackground interface. IImGearBackground

Syntax

IImGearResample getResampling()

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getScrollInfo Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getScrollInfo Method
pageView
IImGearScrollableView interface, represents Java Form to draw image in.

Glossary Item Box

Returns new instance of image scrolling attributes object.

Syntax

ImGearScrollInfo getScrollInfo(
   IImGearScrollableView pageView
)

Parameters

pageView
IImGearScrollableView interface, represents Java Form to draw image in.

Return Value

New instance of ImGearScrollInfo structure object. ImGearScrollInfo IImGearScrollableView

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

getZoomInfo Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : getZoomInfo Method
pageView
IImGearScrollableView interface, represents Java Form to draw image in.

Glossary Item Box

Returns a new instance of an object containing current zoom settings.

Syntax

ImGearZoomInfo getZoomInfo(
   IImGearScrollableView pageView
)

Parameters

pageView
IImGearScrollableView interface, represents Java Form to draw image in.

Return Value

New instance of ImGearZoomInfo structure object. ImGearZoomInfo IImGearScrollableView

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

handleScroll Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : handleScroll Method
pageView
IImGearScrollableView interface, represents Java Form to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position. IImGearScrollableView ImGearScrollBarType

Glossary Item Box

Handles scrolling events.

Use this method only to handle scrolling events. To scroll image to particular position, use scrollTo method instead.

Syntax

void handleScroll(
   IImGearScrollableView pageView,
   ImGearScrollBarType scrollBarType,
   int scrollValue
)

Parameters

pageView
IImGearScrollableView interface, represents Java Form to draw image in.
scrollBarType
Type of scrolling event: horizontal or vertical. Possible values are: ImGearScrollBarType.HORIZONTAL and ImGearScrollBarType.VERTICAL.
scrollValue
Scroll value. Specifies new scrolling position. IImGearScrollableView ImGearScrollBarType

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

internalUseOnly Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : internalUseOnly Method

Glossary Item Box

This method is used by ImageGear internally.

Syntax

java.lang.Object internalUseOnly()

Return Value

An object.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

scrollTo Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : scrollTo Method
pageView
IImGearScrollableView interface; represents Java form to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Glossary Item Box

Scrolls the image to the specified position and updates the scrollbars accordingly.

This method can be used whether the actual scrollbar controls are visible in the Form object or not. X_Pos and Y_Pos both should be in the valid ranges that can be retrieved with getScrollInfo method.

Syntax

ImGearScrollInfo scrollTo(
   IImGearScrollableView pageView,
   int positionX,
   int positionY
)

Parameters

pageView
IImGearScrollableView interface; represents Java form to draw the image in.
positionX
New horizontal scroll position.
positionY
New vertical scroll position.

Return Value

Instance of ImGearScrollInfo structure object. ImGearScrollInfo IImGearScrollableView

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

setARTPage Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : setARTPage Method
value
The ImGearAnnotationPage.

Glossary Item Box

Sets ImGearAnnotationPage object associated with this display page.

Type of this property is an abstract class that has no public members. If the application works with annotations, it will cast ImGearPageDisplay.getARTPage() to the actual ImGearARTPage class, defined in art jar.

Syntax

void setARTPage(
   ImGearAnnotationPage value
)

Parameters

value
The ImGearAnnotationPage.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

setDICOMDisplaySettings Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : setDICOMDisplaySettings Method
value

Glossary Item Box

Sets the DICOM specific display contrast settings.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface.

DICOM specification defines several contrast transformations, such as Modality LUT, VOI LUT, etc. When ImageGear loads a DICOM image, it initializes DICOMDisplaySettings field of com.accusoft.imagegear.core.ImGearRasterPage class with settings found in the file. During display, ImageGear checks for presence of DICOMDisplaySettings, and if it is present, uses it in display processing pipeline. This allows you to load and display DICOM images with proper contrast, without the need for extra application code. An com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface object can be attached to an com.accusoft.imagegear.core.ImGearRasterPage class object or to an ImGearPageDisplay class object. If ImGearPageDisplay.getDICOMDisplaySettings is not null, ImageGear uses it for display. Otherwise, ImageGear checks com.accusoft.imagegear.core.ImGearRasterPage for presence of .DICOMDisplaySettings, and if it is not null, uses it for display. In other words, DICOMDisplaySettings attached to Display has higher priority than DICOMDisplaySettings attached to ImGearRasterPage. DICOMDisplaySettings can be also used if the image was not loaded from a DICOM file. It can be useful for non-medical images as well. This value affects grayscale images with bit depths from 2 to 16. Type of this value is an interface, which has a small set of members that are necessary for displaying the page with specific DICOM display settings. If the application needs to retrieve or modify DICOM Display Settings, it shall cast com.accusoft.imagegear.core.IImGearDICOMDisplaySettings interface to the actual class ImGearPageDisplay.getDICOMDisplaySettings class. The default value is null.

com.accusoft.imagegear.core.IImGearDICOMDisplaySettings com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

void setDICOMDisplaySettings(
   IImGearDICOMDisplaySettings value
)

Parameters

value

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

setLUT Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : setLUT Method
value

Glossary Item Box

Sets the list of extra channels and their display options.

com.accusoft.imagegear.core.ImGearDisplayChannels class object. com.accusoft.imagegear.core.ImGearDisplayChannels

Syntax

void setLUT(
   ImGearMultichannelLUT value
)

Parameters

value

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

setPage Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : setPage Method
value

Glossary Item Box

Sets ImGearAnnotationPage object associated with this display page.

Type of this value is an abstract class that has no public members. If the application works with annotations, it shall cast ImGearPageDisplay.ARTPage to the actual class com.accusoft.imagegear.art.ImGearARTPage class, defined in the com.accusoft.imagegear.art package.

ImGearAnnotationPage class.

Syntax

void setPage(
   ImGearPage value
)

Parameters

value

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

updateLUT Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : updateLUT Method
colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.

The ImGearPageDisplay lookup table is updated as follows:

  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.

com.accusoft.imagegear.core.ImGearMultichannelLUT IImGearContrastSettings

Glossary Item Box

Updates the ImGearPageDisplay lookup table.

Syntax

void updateLUT(
   ImGearMultichannelLUT colorLUT,
   IImGearContrastSettings contrastSettings
)

Parameters

colorLUT
Multichannel lookup table.
contrastSettings
Contrast settings.

The ImGearPageDisplay lookup table is updated as follows:

  • If colorLUT is not null, it is duplicated into ImGearPageDisplay's LUT. colorLUT type and depths attributes must be compatible with ImGearPageDisplay's LUT.
  • If contrastSettings is not null, its values are used to update ImGearPageDisplay's LUT.

com.accusoft.imagegear.core.ImGearMultichannelLUT IImGearContrastSettings

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

updateScrollFrom Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : updateScrollFrom Method
pageView
IImGearScrollableView interface; represents Java form to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars. IImGearScrollableView ImGearScrollInfo

Glossary Item Box

Updates image scroll attributes with new values.

Syntax

void updateScrollFrom(
   IImGearScrollableView pageView,
   ImGearScrollInfo scrollInfo
)

Parameters

pageView
IImGearScrollableView interface; represents Java form to draw image in.
scrollInfo
ImGearScrollInfo object with new attributes for vertical and horizontal scrollbars. IImGearScrollableView ImGearScrollInfo

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

updateZoomFrom Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : updateZoomFrom Method
zoomInfo
ImGearZoomInfo object with new zoom attributes.

Glossary Item Box

Updates image zoom attributes. ImGearZoomInfo

Syntax

void updateZoomFrom(
   ImGearZoomInfo zoomInfo
)

Parameters

zoomInfo
ImGearZoomInfo object with new zoom attributes.

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

zoomToRectangle Method
com.accusoft.imagegear.display Package > IImGearPageDisplay Interface : zoomToRectangle Method
pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle. IImGearScrollableView com.accusoft.imagegear.core.shapes.ImGearRectangle

Glossary Item Box

Performs zooming to specified device rectangle and returns new zoom information.

This method calculates the zoom and scroll values, so that the specified rectangle is fitted to ClipRect and zoom image is fitted to the rectangle calculated. For both horizontal and vertical zoom attributes, it sets ImGearZoomComponentInfo. Fixed field to true, calculates and modifies ImGearZoomComponentInfo. Value field, the horizontal and vertical scroll positions, and returns new instance of ImGearZoomInfo object with new zoom attributes.

Syntax

void zoomToRectangle(
   IImGearScrollableView pageView,
   ImGearRectangle rect
)

Parameters

pageView
ImGearZoomInfo object with new zoom attributes.
rect
Specified device rectangle. IImGearScrollableView com.accusoft.imagegear.core.shapes.ImGearRectangle

See Also

Reference

IImGearPageDisplay Interface
IImGearPageDisplay Members


%%PageItemTitle%%

IImGearResample Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearResample Interface

Glossary Item Box

Provides access to re-sampling attributes.

Syntax

public interface IImGearResample
    implements com.accusoft.imagegear.callbackinterfaces.IImGearNotifyPropertyChanged, IImGearDisplayObject

See Also

Reference

IImGearResample Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearResample Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearResample Interface

Glossary Item Box

The following tables list the members exposed by IImGearResample.

Public Methods

 | Name | Description
Method | getMethod | Gets a re-sampling method to use. ImGearResampleModes enumeration value. This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in. ImGearResampleModes
Method | setMethod | Sets a re-sampling method to use. ImGearResampleModes enumeration value. This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in. ImGearResampleModes
Top

See Also

Reference

IImGearResample Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearResample Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearResample Interface

Glossary Item Box

For a list of all members of this type, see IImGearResample members.

Public Methods

 | Name | Description
Method | getMethod | Gets a re-sampling method to use. ImGearResampleModes enumeration value. This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in. ImGearResampleModes
Method | setMethod | Sets a re-sampling method to use. ImGearResampleModes enumeration value. This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in. ImGearResampleModes
Top

See Also

Reference

IImGearResample Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

getMethod Method
com.accusoft.imagegear.display Package > IImGearResample Interface : getMethod Method

Glossary Item Box

Gets a re-sampling method to use.

ImGearResampleModes enumeration value.

This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in.

ImGearResampleModes

Syntax

ImGearResampleModes getMethod()

See Also

Reference

IImGearResample Interface
IImGearResample Members


%%PageItemTitle%%

setMethod Method
com.accusoft.imagegear.display Package > IImGearResample Interface : setMethod Method
value

Glossary Item Box

Sets a re-sampling method to use.

ImGearResampleModes enumeration value.

This mode is applicable for all bit depths if the destination image has a higher resolution than the original one, i.e., when the image is zoomed in.

ImGearResampleModes

Syntax

void setMethod(
   ImGearResampleModes value
)

Parameters

value

See Also

Reference

IImGearResample Interface
IImGearResample Members


%%PageItemTitle%%

IImGearScrollableView Interface
See Also Members Send Feedback
com.accusoft.imagegear.display Package : IImGearScrollableView Interface

Glossary Item Box

Obtains all information required by IG display code and modifies some attributes of underlying window (scrollbars state).

This interface is designed to separate IG display API from Java windows and forms. Any object implementing this interface can be used. A null value can also be specified. In this case all required information will be obtained from CSGraphics object. In all display API calls IImGearScrollableView parameter is accompanied with CSGraphics object. To draw on a printer, null value should be passed to IImGearScrollableView parameter.

Syntax

public interface IImGearScrollableView

See Also

Reference

IImGearScrollableView Members
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearScrollableView Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.display Package : IImGearScrollableView Interface

Glossary Item Box

The following tables list the members exposed by IImGearScrollableView.

Public Methods

 | Name | Description
Method | enableScrollBar | Enables or disables the scrollbars associated with window.
Method | getClientRectangle | Gets a rectangle of the client area. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getScrollBarDimensions | Returns width and height dimensions of the windows scroll bar.
Method | getScrollParams | Obtains the attributes of the scrollbar specified.
Method | isScrollBarVisible | Returns a value indicating whether the scrollbar is visible.
Method | setScrollParams | Updates the state of specified scrollbar with new values.
Method | showScrollBar | Changes visibility state of scrollbars associated with window.
Top

See Also

Reference

IImGearScrollableView Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearScrollableView Interface Methods
See Also Send Feedback
com.accusoft.imagegear.display Package : IImGearScrollableView Interface

Glossary Item Box

For a list of all members of this type, see IImGearScrollableView members.

Public Methods

 | Name | Description
Method | enableScrollBar | Enables or disables the scrollbars associated with window.
Method | getClientRectangle | Gets a rectangle of the client area. com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. com.accusoft.imagegear.core.shapes.ImGearRectangle
Method | getScrollBarDimensions | Returns width and height dimensions of the windows scroll bar.
Method | getScrollParams | Obtains the attributes of the scrollbar specified.
Method | isScrollBarVisible | Returns a value indicating whether the scrollbar is visible.
Method | setScrollParams | Updates the state of specified scrollbar with new values.
Method | showScrollBar | Changes visibility state of scrollbars associated with window.
Top

See Also

Reference

IImGearScrollableView Interface
com.accusoft.imagegear.display Package


%%PageItemTitle%%

enableScrollBar Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : enableScrollBar Method
scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Enable (true) or disable (false) scrollbar. ImGearScrollBarType

Glossary Item Box

Enables or disables the scrollbars associated with window.

Syntax

void enableScrollBar(
   ImGearScrollBarType scrollBarType,
   boolean state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Enable (true) or disable (false) scrollbar. ImGearScrollBarType

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

getClientRectangle Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : getClientRectangle Method

Glossary Item Box

Gets a rectangle of the client area.

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object. com.accusoft.imagegear.core.shapes.ImGearRectangle

Syntax

ImGearRectangle getClientRectangle()

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

getScrollBarDimensions Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : getScrollBarDimensions Method
scrollBarType
Specifies the scrollbar whose attributes are requested.

Glossary Item Box

Returns width and height dimensions of the windows scroll bar.

Syntax

ImGearSize getScrollBarDimensions(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

com.accusoft.imagegear.core.ImGearSize structure. ImGearScrollBarType com.accusoft.imagegear.core.ImGearSize

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

getScrollParams Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : getScrollParams Method
scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
Output parameter; horizontal or vertical field of this parameter is updated with requested information.

ImGearScrollBarType ImGearScrollInfo

Glossary Item Box

Obtains the attributes of the scrollbar specified.

Syntax

void getScrollParams(
   ImGearScrollBarType scrollBarType,
   com.accusoft.imagegear.utility.ImGearRefObject<ImGearScrollInfo> scrollInfo
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
Output parameter; horizontal or vertical field of this parameter is updated with requested information.

ImGearScrollBarType ImGearScrollInfo

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

isScrollBarVisible Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : isScrollBarVisible Method
scrollBarType
Specifies the scrollbar whose attributes are requested.

Glossary Item Box

Returns a value indicating whether the scrollbar is visible.

Syntax

boolean isScrollBarVisible(
   ImGearScrollBarType scrollBarType
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.

Return Value

Boolean value. ImGearScrollBarType

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

setScrollParams Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : setScrollParams Method
scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
New scrollbar state.
redraw
Specifies whether or not to redraw image in window. ImGearScrollBarType ImGearScrollInfo

Glossary Item Box

Updates the state of specified scrollbar with new values.

Syntax

void setScrollParams(
   ImGearScrollBarType scrollBarType,
   ImGearScrollInfo scrollInfo,
   boolean redraw
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are requested.
scrollInfo
New scrollbar state.
redraw
Specifies whether or not to redraw image in window. ImGearScrollBarType ImGearScrollInfo

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%PageItemTitle%%

showScrollBar Method
com.accusoft.imagegear.display Package > IImGearScrollableView Interface : showScrollBar Method
scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Show (true) or hide (false) scrollbar. ImGearScrollBarType

Glossary Item Box

Changes visibility state of scrollbars associated with window.

Syntax

void showScrollBar(
   ImGearScrollBarType scrollBarType,
   boolean state
)

Parameters

scrollBarType
Specifies the scrollbar whose attributes are changed.
state
Show (true) or hide (false) scrollbar. ImGearScrollBarType

See Also

Reference

IImGearScrollableView Interface
IImGearScrollableView Members


%%ItemTitle%%

com.accusoft.imagegear.formats Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the ImageGear for Java API for working with formats filters, thumbnails and formats metadata.

Classes

Class | Description
ImGearAdvancedFormats Initializes the ImageGear Advanced Formats JAR.

This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

ImGearCommonFormats Initializes the ImageGear Common Formats jar.

This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

ImGearCommonMetadata | Provides access to metadata that is common for all format filters.
ImGearControlParameter Provides access to the attributes of a control parameter.

Control parameters affect the way images are loaded and saved.

ImGearFileFilters Provides access to formats settings.

This class allows you to manage file formats and provides access to their settings. It contains a list of formats ImageGear is working with and provides an API for accessing and editing this list. When the format of an image is being detected, the formats are called in the order in which they are contained in the list.

The majority of file formats are added to the list automatically during class initialization. However, you need to add optional formats such as PDF, PostScript, and JPEG 2000 explicitly. If you do not need a particular format, you can remove it from the list. Re-ordering formats in the list allows you to optimize the format detection process. You can control a format's settings by getting a format from the list and accessing it via the IImGearformat interface.

ImGearFileFormats Main class for working with file formats.

This is the main class for working with file formats. It contains an API for loading, detecting and saving images, getting image information, and provides access to format's settings class. The image is read from and written to an ImGearStream. In order for ImageGear to work with the stream, it must be seekable.

ImGearFormatMetadata | This is the base class for the Simplified Metadata API accessor classes.
ImGearFormatParameters | Allows you to manage format's control parameters.
ImGearLoadOptions Specifies additional loading options, such as thumbnail loading or loading an image specifying its format explicitly.

Pass an instance of this class to image loading methods, such as ImGearFileFormats.loadPage

ImGearNativeDataTypeHelper | Helps to work with ImageGear native data types associated with file formats metadata.
ImGearRawLoadOptions Specifies loading options for header-less RAW formats.

Use this class with ImGearFileFormats.loadPage.

ImGearSaveOptions Specifies additional saving options.

Pass an instance of this class to image saving methods, such as ImGearFileFormats.savePage

ImGearSaveThumbnailOptions | Specifies thumbnail attributes such as width and height to be used when saving a thumbnail.
ImGearSimplifiedMetadata | This class initializes the imagegear2.formats.simplifiedmetadata.jar. It adds formats that are implemented by the component to the ImageGearJava's global formats list, enabling their detection, reading, and writing.

Interfaces

Interface | Description
IImGearFormat | Base interface for all file format filters. This interface provides access to format filters' settings.

Enumerations

Enumeration | Description
ImGearBMPTagIDs | Lists all BMP tag identifiers.
ImGearBTRTagIDs | Lists all BTR tag identifiers.
ImGearCALTagIDs | Lists all CAL tag identifiers.
ImGearCIFFAFInfoTagIDs | Lists all CIFF AF Info tag identifiers.
ImGearCIFFCanonCameraSettingsTagIDs | Lists all CIFF Canon Camera Settings tag identifiers.
ImGearCIFFFocalLengthTagIDs | Lists all CIFF Focal Length tag identifiers.
ImGearCIFFImageInfoTagIDs | Lists all CIFF Image Info tag identifiers.
ImGearCIFFShotInfoTagIDs | Lists all CIFF Shot Info tag identifiers.
ImGearCIFFTagIDs Lists all CIFF tag identifiers.

ImGearCLPTagIDs | Lists all CLP tag identifiers.
ImGearCompressions Lists all ImageGear supported compressions.

ImGearCUTTagIDs | Lists all CUT tag identifiers.
ImGearDCRAWTagIDs | Lists all Digital Camera RAW tag identifiers.
ImGearDCXTagIDs | Lists all DCX tag identifiers.
ImGearDisplayInfoTagIDs | Lists all Photoshop Display Info tag identifiers.
ImGearEXIFFPXRTagIDs | Lists all EXIF FPXR tag identifiers.
ImGearEXIFGPSTagIDs | Lists all EXIF GPS tag identifiers.
ImGearEXIFInterOpTagIDs | Lists all EXIF Interoperability tag identifiers.
ImGearEXIFMakerNoteFujiTagIDs Lists all Fujifilm EXIF MakerNote tag identifiers.

ImGearEXIFMakerNoteNikonType1TagIDs | Lists all Nikon EXIF MakerNote Type 1 tag identifiers.
ImGearEXIFMakerNoteNikonType2TagIDs | Lists all Nikon EXIF MakerNote Type 2 tag identifiers.
ImGearEXIFMakerNoteOlympusTagIDs Lists all Olympus EXIF MakerNote tag identifiers.

ImGearEXIFMakerNotePentaxTagIDs Lists all Pentax EXIF MakerNote tag identifiers.

ImGearEXIFMakerNoteTagIDs | Lists all general EXIF MakerNote tag identifiers.
ImGearEXIFMakerNoteType | Lists all EXIF MakerNote types.
ImGearEXIFTagIDs | Lists all EXIF tag identifiers.
ImGearFillOrder Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).

This enumeration specifies fill order that is used for saving some file formats, like TIFF, CCITT Group3/Group4, etc., or for loading raw CCITT data.

ImGearFormats Lists all ImageGear supported file formats.

ImGearGEMTagIDs | Lists all GEM tag identifiers.
ImGearGIFTagIDs Lists all GIF tag identifiers.

ImGearHDPhotoTagIDs | Lists all HD Photo tag identifiers.
ImGearICATagIDs Lists all ICA tag identifiers.

This enumeration lists all IOCA tag identifiers.

ImGearICOTagIDs | Lists all ICO tag identifiers.
ImGearIFFTagIDs | Lists all IFF tag identifiers.
ImGearIMGTagIDs | Lists all IMG tag identifiers.
ImGearIMTTagIDs | Lists all IMT tag identifiers.
ImGearIPTCAppObjAttrTags | Lists IPTC Application Object Attributes.
ImGearIPTCAppObjTypeTags | Lists IPTC Application Object Types.
ImGearIPTCRecord1EnvDatasetTags | Lists all IPTC Record 1 (Envelope) DataSet tags.
ImGearIPTCRecord2AppDatasetTags | Lists all IPTC Record 2 (Application) DataSet tags.
ImGearIPTCRecord3PhotoDatasetTags | Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags.
ImGearIPTCRecord7PreObjDatasetTags | Lists all IPTC Record 7 (Pre-Object) DataSet tags.
ImGearIPTCRecord8ObjDatasetTags | Lists all IPTC Record 8 (Object) DataSet tags.
ImGearIPTCRecord9PostObjDatasetTags | Lists all IPTC Record 9 (Post-Object) DataSet tags.
ImGearIPTCRecordTags | Lists all IPTC Record tags.
ImGearIPTCTags | Lists all general IPTC tags.
ImGearJPEGTagIDs Lists all JPEG tag identifiers.

ImGearKFXTagIDs | Lists all KFX tag identifiers.
ImGearLVTagIDs | Lists all LV tag identifiers.
ImGearMakerNoteOlympusApplicationModeIFD2TagIDs | Lists all Olympus application mode IFD 2 MakerNote types.
ImGearMakerNoteOlympusApplicationModeIFDTagIDs | Lists all Olympus application mode IFD MakerNote types.
ImGearMakerNoteOlympusCameraModeIFDTagIDs | Lists all Olympus camera mode IFD MakerNote types.
ImGearMakerNoteOlympusCSerieSettingsTagIDs | Lists all Olympus C-models serie settings IFD MakerNote types.
ImGearMakerNoteOlympusDebugIFDTagIDs | Lists all Olympus debug IFD MakerNote types.
ImGearMakerNoteOlympusHardwareIFDTagIDs Lists all Olympus hardware IFD MakerNote types.

ImGearMakerNoteOlympusImageProcessorTagIDs Lists all Olympus image processor IFD MakerNote types.

ImGearMetadataFormats Lists all ImageGear supported metadata formats.

This enumeration lists all formats that are used for storing file format metadata. Most of the members of this enum correspond to members of ImGearFormats. However, some file formats allow storing complex metadata, or metadata structures of various types. ImGearMetadataFormats enum has special members for such metadata structures.

For example, a TIFF image can have metadata of ImGearMetadataFormats.TIF, which in turn can have a subtree with metadata of type ImGearMetadataFormats.EXIF

ImGearMJ2TagIDs | Lists all MJ2 tag identifiers.
ImGearMSPTagIDs | Lists all MSP tag identifiers.
ImGearNativeDataTypes | Specifies the data types that file formats use to store metadata values.
ImGearNCRTagIDs | Lists all NCR tag identifiers.
ImGearPBMTagIDs | Lists all PBM tag identifiers.
ImGearPCDTagIDs | Lists all PCD tag identifiers.
ImGearPCXTagIDs | Lists all PCX tag identifiers.
ImGearPDFTagIDs | Lists all PDF tag identifiers.
ImGearPhotoshopAdditionalLayerInfoTagIDs | Lists all Photoshop Additional Layer Info tag identifiers.
ImGearPhotoshopLayerInfoTagIDs | Lists all Photoshop Layer Info tag identifiers.
ImGearPhotoshopLayerMaskInfoTagIDs | Lists all Photoshop Layer Mask Info tag identifiers.
ImGearPhotoshopResourceGenericTagIDs | Lists all Photoshop Resource Generic tag identifiers.
ImGearPHOTOSHOPTagIDs Lists all Photoshop tag identifiers.

This enumeration lists all general Photoshop tag identifiers.

ImGearPhotoshopVersionInfoTagIDs | Lists all Photoshop Version Info tag identifiers.
ImGearPNGCompLevel | Lists all PNG compression levels.
ImGearPNGStrip | Lists all PNG strip modes.
ImGearPNGTagIDs Lists all PNG tag identifiers.

ImGearPSDTagIDs | Lists all PSD tag identifiers.
ImGearPSTagIDs | Lists all PostScript tag identifiers.
ImGearPTOCATagIDs | Lists all PTOCA tag identifiers.
ImGearRASTagIDs | Lists all RAS tag identifiers.
ImGearRasterConversionModes | Lists all raster conversion modes for image saving.
ImGearRawAlignment | Represents alignment of bytes in raster line.
ImGearRectangleInfoTagIDs | Lists all Photoshop Rectangle Info tag ids.
ImGearResolutionInfoTagIDs | Lists all Photoshop Resolution Info tag ids.
ImGearSavingFormats Lists all ImageGear saving formats.

Each saving format is a combination of a file format and a compression (e.g., TIF_G4 specifies TIF file format and CCITT Group4 compression). ImGearCompressions.AUTO specifies default compression for the format.

ImGearSavingModes Lists all saving modes.

This enumeration specifies available saving modes, such as overwrite image, insert page, etc.

ImGearSCITagIDs Lists all SCI tag identifiers.

This enumeration lists all Scitex CT tag identifiers.

ImGearSGITagIDs | Lists all SGI tag identifiers.
ImGearTGATagIDs | Lists all TGA tag identifiers.
ImGearThumbnailInfoTagIDs | Lists all Photoshop Thumbnail Info tag identifiers.
ImGearTIFTagIDs | Lists all TIF tag identifiers.
ImGearWBMPTagIDs | Lists all WBMP tag identifiers.
ImGearWPGTagIDs | Lists all WPG tag identifiers.
ImGearXBMTagIDs | Lists all XBM tag identifiers.
ImGearXMPTagIDs Lists all XMP tag identifiers.

These identifiers represent structural types of XMP metadata, such as Value, Sequence, Bag, Qualifier, etc. ImageGear does not provide enumerations for particilar properties of XMP schemes.

ImGearXPMTagIDs | Lists all XPM tag identifiers.
ImGearXPSTagIDs | Lists all XPS tag identifiers.
ImGearXWDTagIDs | Lists all XWD tag identifiers.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats Package Inheritance Hierarchy

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.ImGearAdvancedFormats
com.accusoft.imagegear.formats.ImGearCommonFormats
com.accusoft.imagegear.formats.ImGearControlParameter
com.accusoft.imagegear.formats.ImGearFileFilters
com.accusoft.imagegear.formats.ImGearFileFormats
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatParameters
com.accusoft.imagegear.formats.ImGearLoadOptions
com.accusoft.imagegear.formats.ImGearNativeDataTypeHelper
com.accusoft.imagegear.formats.ImGearSaveOptions
com.accusoft.imagegear.formats.ImGearSaveThumbnailOptions
com.accusoft.imagegear.formats.ImGearSimplifiedMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearAdvancedFormats Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearAdvancedFormats Class

Glossary Item Box

Initializes the ImageGear Advanced Formats JAR.

This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

Object Model

ImGearAdvancedFormats Class

Syntax

public sealed class ImGearAdvancedFormats
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearAdvancedFormats

See Also

Reference

ImGearAdvancedFormats Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearAdvancedFormats Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearAdvancedFormats Class

Glossary Item Box

The following tables list the members exposed by ImGearAdvancedFormats.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | Initializes the ImageGear Advanced Formats JAR. This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.
Top

See Also

Reference

ImGearAdvancedFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearAdvancedFormats Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearAdvancedFormats Class

Glossary Item Box

For a list of all members of this type, see ImGearAdvancedFormats members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | Initializes the ImageGear Advanced Formats JAR. This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.
Top

See Also

Reference

ImGearAdvancedFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.formats Package > ImGearAdvancedFormats Class : initialize Method

Glossary Item Box

Initializes the ImageGear Advanced Formats JAR.

This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

Syntax

public static void initialize()

See Also

Reference

ImGearAdvancedFormats Class
ImGearAdvancedFormats Members


%%PageItemTitle%%

ImGearCommonFormats Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonFormats Class

Glossary Item Box

Initializes the ImageGear Common Formats jar.

This class adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

Object Model

ImGearCommonFormats Class

Syntax

public sealed class ImGearCommonFormats
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearCommonFormats

See Also

Reference

ImGearCommonFormats Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearCommonFormats Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonFormats Class

Glossary Item Box

The following tables list the members exposed by ImGearCommonFormats.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | Initializes the ImageGear Common Formats jar. This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.
Top

See Also

Reference

ImGearCommonFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearCommonFormats Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonFormats Class

Glossary Item Box

For a list of all members of this type, see ImGearCommonFormats members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | Initializes the ImageGear Common Formats jar. This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.
Top

See Also

Reference

ImGearCommonFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.formats Package > ImGearCommonFormats Class : initialize Method

Glossary Item Box

Initializes the ImageGear Common Formats jar.

This method adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing.

Syntax

public static void initialize()

See Also

Reference

ImGearCommonFormats Class
ImGearCommonFormats Members


%%PageItemTitle%%

ImGearCommonMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonMetadata Class

Glossary Item Box

Provides access to metadata that is common for all format filters.

Object Model

ImGearCommonMetadata ClassImGearCompressions Enumeration

Syntax

public class ImGearCommonMetadata
    extends ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.ImGearCommonMetadata

See Also

Reference

ImGearCommonMetadata Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearCommonMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearCommonMetadata.

Public Methods

 | Name | Description
public Method | getColorProfile | Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles. Byte array value. This method returns the color profile data of the file page from which the image was loaded. It returns null if the file page did not contain a profile or if the format filter does not support the loading of color profiles. This method also returns null (source file page color profile is undefined) if the page was created using a com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function. Note:This method is not updated during image conversions such as profile or colorspace conversions. On image writing, ImageGear ignores this value, and uses the profile attached to the image DIB.
public Method | getCompression | Gets compression of the file page from which the image was loaded. Nullable (boxed) ImGearCompressions enumeration value. If the page was created using com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function, this method returns null (source file page compression is undefined). com.accusoft.imagegear.formats.ImGearCompressionsT:com.accusoft.imagegear.core.ImGearVectorPage
public Method | getResolutionLayersCount | Gets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions. Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class. Currently, only PCD format uses this value.
public Method | setCompression | Sets compression of the file page from which the image was loaded. ImGearCompressions com.accusoft.imagegear.core.ImGearRasterPage
public Method | setResolutionLayersCount | Sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions. Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class. Currently, only PCD format uses this value.
Top

See Also

Reference

ImGearCommonMetadata Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearCommonMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearCommonMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearCommonMetadata members.

Public Methods

 | Name | Description
public Method | getColorProfile | Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles. Byte array value. This method returns the color profile data of the file page from which the image was loaded. It returns null if the file page did not contain a profile or if the format filter does not support the loading of color profiles. This method also returns null (source file page color profile is undefined) if the page was created using a com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function. Note:This method is not updated during image conversions such as profile or colorspace conversions. On image writing, ImageGear ignores this value, and uses the profile attached to the image DIB.
public Method | getCompression | Gets compression of the file page from which the image was loaded. Nullable (boxed) ImGearCompressions enumeration value. If the page was created using com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function, this method returns null (source file page compression is undefined). com.accusoft.imagegear.formats.ImGearCompressionsT:com.accusoft.imagegear.core.ImGearVectorPage
public Method | getResolutionLayersCount | Gets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions. Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class. Currently, only PCD format uses this value.
public Method | setCompression | Sets compression of the file page from which the image was loaded. ImGearCompressions com.accusoft.imagegear.core.ImGearRasterPage
public Method | setResolutionLayersCount | Sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions. Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class. Currently, only PCD format uses this value.
Top

See Also

Reference

ImGearCommonMetadata Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getColorProfile Method
com.accusoft.imagegear.formats Package > ImGearCommonMetadata Class : getColorProfile Method

Glossary Item Box

Gets color profile data of the file page from which the image was loaded, or null if the format filter does not support loading of color profiles.

Byte array value.

This method returns the color profile data of the file page from which the image was loaded. It returns null if the file page did not contain a profile or if the format filter does not support the loading of color profiles. This method also returns null (source file page color profile is undefined) if the page was created using a com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function.

Note:This method is not updated during image conversions such as profile or colorspace conversions.

On image writing, ImageGear ignores this value, and uses the profile attached to the image DIB.

Syntax

public byte[] getColorProfile()

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

getCompression Method
com.accusoft.imagegear.formats Package > ImGearCommonMetadata Class : getCompression Method

Glossary Item Box

Gets compression of the file page from which the image was loaded.

Nullable (boxed) ImGearCompressions enumeration value.

If the page was created using com.accusoft.imagegear.core.ImGearRasterPage class or com.accusoft.imagegear.core.ImGearVectorPage class constructor, or using an image processing function, this method returns null (source file page compression is undefined).

com.accusoft.imagegear.formats.ImGearCompressionsT:com.accusoft.imagegear.core.ImGearVectorPage

Syntax

public ImGearCompressions getCompression()

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

getResolutionLayersCount Method
com.accusoft.imagegear.formats Package > ImGearCommonMetadata Class : getResolutionLayersCount Method

Glossary Item Box

Gets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions.

Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class.

Currently, only PCD format uses this value.

Syntax

public java.lang.int getResolutionLayersCount()

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

setCompression Method
com.accusoft.imagegear.formats Package > ImGearCommonMetadata Class : setCompression Method
value

Glossary Item Box

Sets compression of the file page from which the image was loaded. ImGearCompressions com.accusoft.imagegear.core.ImGearRasterPage

Syntax

public void setCompression(
   ImGearCompressions value
)

Parameters

value

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

setResolutionLayersCount Method
com.accusoft.imagegear.formats Package > ImGearCommonMetadata Class : setResolutionLayersCount Method
value

Glossary Item Box

Sets the number of resolution layers in the image page from which ImGearPage object was loaded, or null if the format filter does not support the loading of different resolutions.

Integer value. See Also: com.accusoft.imagegear.core.ImGearPage class.

Currently, only PCD format uses this value.

Syntax

public void setResolutionLayersCount(
   java.lang.int value
)

Parameters

value

See Also

Reference

ImGearCommonMetadata Class
ImGearCommonMetadata Members


%%PageItemTitle%%

ImGearControlParameter Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearControlParameter Class

Glossary Item Box

Provides access to the attributes of a control parameter.

Control parameters affect the way images are loaded and saved.

Object Model

ImGearControlParameter Class

Syntax

public sealed class ImGearControlParameter
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearControlParameter

See Also

Reference

ImGearControlParameter Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearControlParameter Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearControlParameter Class

Glossary Item Box

The following tables list the members exposed by ImGearControlParameter.

Public Methods

 | Name | Description
public Method | getDefaultValue | Gets default value of the parameter.
public Method | getName | Gets the name of the parameter. String containing parameter's name.
public Method | getValue | Returns current value of the parameter.
public Method | setToDefault | Sets parameter to its default value.
public Method | setValue | Sets current value of the parameter. When setting this value, please make sure that the type of the object representing a new value is the same as that of the old value. Otherwise an exception will be thrown.
Top

See Also

Reference

ImGearControlParameter Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearControlParameter Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearControlParameter Class

Glossary Item Box

For a list of all members of this type, see ImGearControlParameter members.

Public Methods

 | Name | Description
public Method | getDefaultValue | Gets default value of the parameter.
public Method | getName | Gets the name of the parameter. String containing parameter's name.
public Method | getValue | Returns current value of the parameter.
public Method | setToDefault | Sets parameter to its default value.
public Method | setValue | Sets current value of the parameter. When setting this value, please make sure that the type of the object representing a new value is the same as that of the old value. Otherwise an exception will be thrown.
Top

See Also

Reference

ImGearControlParameter Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getDefaultValue Method
com.accusoft.imagegear.formats Package > ImGearControlParameter Class : getDefaultValue Method

Glossary Item Box

Gets default value of the parameter.

Syntax

public java.lang.Object getDefaultValue()

Return Value

Object containing parameter's value.

See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.formats Package > ImGearControlParameter Class : getName Method

Glossary Item Box

Gets the name of the parameter.

String containing parameter's name.

Syntax

public java.lang.String getName()

See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats Package > ImGearControlParameter Class : getValue Method

Glossary Item Box

Returns current value of the parameter.

Syntax

public java.lang.Object getValue()

Return Value

Object containing parameter's value.

See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

setToDefault Method
com.accusoft.imagegear.formats Package > ImGearControlParameter Class : setToDefault Method

Glossary Item Box

Sets parameter to its default value.

Syntax

public void setToDefault()

See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.formats Package > ImGearControlParameter Class : setValue Method
value
Object containing parameter's value.

Glossary Item Box

Sets current value of the parameter.

When setting this value, please make sure that the type of the object representing a new value is the same as that of the old value. Otherwise an exception will be thrown.

Syntax

public void setValue(
   java.lang.Object value
)

Parameters

value
Object containing parameter's value.

See Also

Reference

ImGearControlParameter Class
ImGearControlParameter Members


%%PageItemTitle%%

ImGearFileFilters Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFilters Class

Glossary Item Box

Provides access to formats settings.

This class allows you to manage file formats and provides access to their settings. It contains a list of formats ImageGear is working with and provides an API for accessing and editing this list. When the format of an image is being detected, the formats are called in the order in which they are contained in the list.

The majority of file formats are added to the list automatically during class initialization. However, you need to add optional formats such as PDF, PostScript, and JPEG 2000 explicitly. If you do not need a particular format, you can remove it from the list. Re-ordering formats in the list allows you to optimize the format detection process. You can control a format's settings by getting a format from the list and accessing it via the IImGearformat interface.

Object Model

ImGearFileFilters ClassIImGearFormat Interface

Syntax

public sealed class ImGearFileFilters
    extends Object
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFileFilters

See Also

Reference

ImGearFileFilters Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearFileFilters Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFilters Class

Glossary Item Box

The following tables list the members exposed by ImGearFileFilters.

Public Constructors

 | Name | Description
public Constructor | ImGearFileFilters Constructor | Initializes a new instance of the ImGearFileFilters class. Use this constructor if you need to pass a local copy of filter control parameters to a specific image loading or saving method, rather than change control parameters globally. ImGearLoadOptions ImGearSaveOptions
Top

Public Methods

 | Name | Description
public Method | add | Adds a new format to the end of the list of formats.
public Method | contains | Tells whether a particular format is in the list of formats.
public Method | get | Gets a format in the list based on the format ID.
public Method | getCount | Gets the total number of formats currently in the collection. Any integer value.
public Method | indexOf | Gets an index of a format in the list based on the format ID.
public Method | insert | Inserts a new format to the list of formats at the specified position.
public Method | insertAfter | Inserts a new format to the list of formats after the specified format.
public Method | iterator | Returns an iterator for the collection.
public Method | remove | Removes a format from the list based on the format ID.
public Method | removeAt | Removes a format from the list at the specified position.
Top

See Also

Reference

ImGearFileFilters Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearFileFilters Constructor
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : ImGearFileFilters Constructor

Glossary Item Box

Initializes a new instance of the ImGearFileFilters class.

Use this constructor if you need to pass a local copy of filter control parameters to a specific image loading or saving method, rather than change control parameters globally.

ImGearLoadOptions ImGearSaveOptions

Syntax

public ImGearFileFilters()

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearFileFilters Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFilters Class

Glossary Item Box

For a list of all members of this type, see ImGearFileFilters members.

Public Methods

 | Name | Description
public Method | add | Adds a new format to the end of the list of formats.
public Method | contains | Tells whether a particular format is in the list of formats.
public Method | get | Gets a format in the list based on the format ID.
public Method | getCount | Gets the total number of formats currently in the collection. Any integer value.
public Method | indexOf | Gets an index of a format in the list based on the format ID.
public Method | insert | Inserts a new format to the list of formats at the specified position.
public Method | insertAfter | Inserts a new format to the list of formats after the specified format.
public Method | iterator | Returns an iterator for the collection.
public Method | remove | Removes a format from the list based on the format ID.
public Method | removeAt | Removes a format from the list at the specified position.
Top

See Also

Reference

ImGearFileFilters Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : add Method
newFormat
New format to be added.

Glossary Item Box

Adds a new format to the end of the list of formats.

Syntax

public int add(
   IImGearFormat newFormat
)

Parameters

newFormat
New format to be added.

Return Value

A place in the list where new format is placed.

If the list contains the format with the same ID as the new one, the new format is not added, and the index of the existing format is returned instead.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : contains Method
formatId
ID of the format.

Glossary Item Box

Tells whether a particular format is in the list of formats.

Syntax

public boolean contains(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format.

Return Value

Boolean value.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

get Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : get Method
formatId
The ID of the format.

Glossary Item Box

Gets a format in the list based on the format ID.

Syntax

public IImGearFormat get(
   ImGearFormats formatId
)

Parameters

formatId
The ID of the format.

Return Value

The IImGearFormat interface of a format in the list.

This method gets a format from the list, allowing you to access format's settings.

Use this method to manage format's control parameters and access the format's attributes (i.e., name, default file extension, etc.). If a format is not in the list, an exception is thrown.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : getCount Method

Glossary Item Box

Gets the total number of formats currently in the collection.

Any integer value.

Syntax

public int getCount()

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

indexOf Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : indexOf Method
formatId
ID of the format.

Glossary Item Box

Gets an index of a format in the list based on the format ID.

Syntax

public int indexOf(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format.

Return Value

The index of a format in the list, or -1 if the format is not in the list.

The formats are called in the order in which they are kept in the list when the format of an image is detected during loading. Therefore, this method can be used to learn the place of a format in the detection process.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

insert Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : insert Method
index
Position where to insert a new format.
newFormat
New format to be inserted.

Use this method instead of add if you want to control the detection process. If the format with the same ID exists in the list, an exception is thrown. You can use the contains method to check if a format is already added, and call remove or removeAt methods to remove a format.

Glossary Item Box

Inserts a new format to the list of formats at the specified position.

Syntax

public void insert(
   int index,
   IImGearFormat newFormat
)

Parameters

index
Position where to insert a new format.
newFormat
New format to be inserted.

Use this method instead of add if you want to control the detection process. If the format with the same ID exists in the list, an exception is thrown. You can use the contains method to check if a format is already added, and call remove or removeAt methods to remove a format.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

insertAfter Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : insertAfter Method
formatId
ID of the format after which to insert a new format.
newFormat
New format to be inserted.

Use this method if you want a new format to be called after a particular format during format detection. If a format with the same ID as the new one exists in the list, an exception is thrown. You can use contains method to check if a format is already added, and call remove/ removeAt methods to remove a format.

Glossary Item Box

Inserts a new format to the list of formats after the specified format.

Syntax

public void insertAfter(
   ImGearFormats formatId,
   IImGearFormat newFormat
)

Parameters

formatId
ID of the format after which to insert a new format.
newFormat
New format to be inserted.

Use this method if you want a new format to be called after a particular format during format detection. If a format with the same ID as the new one exists in the list, an exception is thrown. You can use contains method to check if a format is already added, and call remove/ removeAt methods to remove a format.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : iterator Method

Glossary Item Box

Returns an iterator for the collection.

Syntax

public java.util.Iterator<IImGearFormat> iterator()

Return Value

An Iterator that can be used to iterate through the collection.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : remove Method
formatId
ID of the format to be removed.

Use this method if you do not need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can invoke IImGearFormat.setDetectionEnabled with parameter set to false . If the format is not in the list, nothing is done.

ImGearFormats

Glossary Item Box

Removes a format from the list based on the format ID.

Syntax

public void remove(
   ImGearFormats formatId
)

Parameters

formatId
ID of the format to be removed.

Use this method if you do not need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can invoke IImGearFormat.setDetectionEnabled with parameter set to false . If the format is not in the list, nothing is done.

ImGearFormats

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

removeAt Method
com.accusoft.imagegear.formats Package > ImGearFileFilters Class : removeAt Method
index
Location (index) of an item to be removed.

Use this method if you don't need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can invoke IImGearFormat.setDetectionEnabled } with false argument. If the index is out of boundaries, an exception is thrown.

Glossary Item Box

Removes a format from the list at the specified position.

Syntax

public void removeAt(
   int index
)

Parameters

index
Location (index) of an item to be removed.

Use this method if you don't need a particular format. This will exclude it from all ImageGear operations.

Note: If you just need to exclude a format from the auto-detection process, you can invoke IImGearFormat.setDetectionEnabled } with false argument. If the index is out of boundaries, an exception is thrown.

See Also

Reference

ImGearFileFilters Class
ImGearFileFilters Members


%%PageItemTitle%%

ImGearFileFormats Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFormats Class

Glossary Item Box

Main class for working with file formats.

This is the main class for working with file formats. It contains an API for loading, detecting and saving images, getting image information, and provides access to format's settings class. The image is read from and written to an ImGearStream. In order for ImageGear to work with the stream, it must be seekable.

Object Model

ImGearFileFormats ClassIImGearFormat InterfaceImGearFileFilters ClassImGearSavingFormats EnumerationImGearDocument ClassImGearPage ClassImGearPage Class

Syntax

public sealed class ImGearFileFormats
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFileFormats

See Also

Reference

ImGearFileFormats Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearFileFormats Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFormats Class

Glossary Item Box

The following tables list the members exposed by ImGearFileFormats.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | detect | Detects the format of an image.
static (Shared in Visual Basic) | exportToImage | Exports a BufferedImage, in 24bpp RGB format.
static (Shared in Visual Basic) | getFilters | Gets access to the file formats settings. Instance of class for managing file formats. Use this method to get access to the ImGearFileFilters class instance that enables you to manage file formats and their settings. ImGearFileFilters
static (Shared in Visual Basic) | getPageCount | Overloaded. Calculates the number of pages in an image. If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown. ImGearFormats
static (Shared in Visual Basic) | getSavingFilter | Overloaded. Returns the saving filter for a particular format. This method comes handy when you need to populate the filter for the Save File dialog with different saving formats. ImGearSavingFormats
static (Shared in Visual Basic) | getSavingFormats | Overloaded. Returns an array of all file saving formats compatible with a particular ImGearPage. This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object. ImGearSavingFormats com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | loadDocument | Overloaded. Loads a range of pages from an image. This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.
static (Shared in Visual Basic) | loadPage | Overloaded. Loads a single page from an image. This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown. com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | loadPageHeader | Overloaded. Loads image metadata for a particular page without decoding pixel data. This method loads image metadata for a particular page without decoding pixel data. This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data. com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | saveDocument | Saves document to an image.
static (Shared in Visual Basic) | savePage | Overloaded. Saves page to an image.
static (Shared in Visual Basic) | updatePageMetadata | Overloaded. Creates a new file with exact copy of source file's pixel data and with new metadata.
Top

See Also

Reference

ImGearFileFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearFileFormats Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearFileFormats Class

Glossary Item Box

For a list of all members of this type, see ImGearFileFormats members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | detect | Detects the format of an image.
static (Shared in Visual Basic) | exportToImage | Exports a BufferedImage, in 24bpp RGB format.
static (Shared in Visual Basic) | getFilters | Gets access to the file formats settings. Instance of class for managing file formats. Use this method to get access to the ImGearFileFilters class instance that enables you to manage file formats and their settings. ImGearFileFilters
static (Shared in Visual Basic) | getPageCount | Overloaded. Calculates the number of pages in an image. If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown. ImGearFormats
static (Shared in Visual Basic) | getSavingFilter | Overloaded. Returns the saving filter for a particular format. This method comes handy when you need to populate the filter for the Save File dialog with different saving formats. ImGearSavingFormats
static (Shared in Visual Basic) | getSavingFormats | Overloaded. Returns an array of all file saving formats compatible with a particular ImGearPage. This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object. ImGearSavingFormats com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | loadDocument | Overloaded. Loads a range of pages from an image. This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.
static (Shared in Visual Basic) | loadPage | Overloaded. Loads a single page from an image. This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown. com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | loadPageHeader | Overloaded. Loads image metadata for a particular page without decoding pixel data. This method loads image metadata for a particular page without decoding pixel data. This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data. com.accusoft.imagegear.core.ImGearPage
static (Shared in Visual Basic) | saveDocument | Saves document to an image.
static (Shared in Visual Basic) | savePage | Overloaded. Saves page to an image.
static (Shared in Visual Basic) | updatePageMetadata | Overloaded. Creates a new file with exact copy of source file's pixel data and with new metadata.
Top

See Also

Reference

ImGearFileFormats Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

detect Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : detect Method
stream
The data stream containing an image.

Glossary Item Box

Detects the format of an image.

Syntax

public static IImGearFormat detect(
   ImGearStream stream
)

Parameters

stream
The data stream containing an image.

Return Value

The format from the list of formats.

If an image cannot be detected, an exception is thrown.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

exportToImage Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : exportToImage Method
page
Page to export

Glossary Item Box

Exports a BufferedImage, in 24bpp RGB format.

Syntax

public static java.awt.image.BufferedImage exportToImage(
   ImGearPage page
)

Parameters

page
Page to export

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

getFilters Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : getFilters Method

Glossary Item Box

Gets access to the file formats settings.

Instance of class for managing file formats.

Use this method to get access to the ImGearFileFilters class instance that enables you to manage file formats and their settings.

ImGearFileFilters

Syntax

public static ImGearFileFilters getFilters()

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

getPageCount Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : getPageCount Method

Glossary Item Box

Calculates the number of pages in an image.

If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown.

ImGearFormats

Overload List

Overload | Description
getPageCount(ImGearStream,ImGearFormats) | Calculates the number of pages in an image. If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown. ImGearFormats
getPageCount(ImGearStream,ImGearFormats,ImGearLoadOptions) | Calculates the number of pages in an image. If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown. ImGearFormats ImGearLoadOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

getPageCount(ImGearStream,ImGearFormats) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getPageCount Method : getPageCount(ImGearStream,ImGearFormats) Method
stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.

Glossary Item Box

Calculates the number of pages in an image.

If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown.

ImGearFormats

Syntax

public static int getPageCount(
   ImGearStream stream,
   ImGearFormats formatId
)

Parameters

stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.

Return Value

Number of pages in the image.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getPageCount(ImGearStream,ImGearFormats,ImGearLoadOptions) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getPageCount Method : getPageCount(ImGearStream,ImGearFormats,ImGearLoadOptions) Method
stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.
options
The loading options.

Glossary Item Box

Calculates the number of pages in an image.

If format ID is not ImGearFormats.UNKNOWN and image format cannot be detected, an exception is thrown.

ImGearFormats ImGearLoadOptions

Syntax

public static int getPageCount(
   ImGearStream stream,
   ImGearFormats formatId,
   ImGearLoadOptions options
)

Parameters

stream
The data stream containing an image.
formatId
Format ID: if ImGearFormats.UNKNOWN is specified, image format is auto-detected.
options
The loading options.

Return Value

Number of pages in the image.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getSavingFilter Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : getSavingFilter Method

Glossary Item Box

Returns the saving filter for a particular format.

This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.

ImGearSavingFormats

Overload List

Overload | Description
getSavingFilter(ImGearSavingFormats) | Returns the saving filter for a particular format. This method comes handy when you need to populate the filter for the Save File dialog with different saving formats. ImGearSavingFormats
getSavingFilter(ImGearSavingFormats,ImGearSaveOptions) | Returns the saving filter for a particular format. This method comes handy when you need to populate the filter for the Save File dialog with different saving formats. ImGearSavingFormats ImGearSaveOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

getSavingFilter(ImGearSavingFormats) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getSavingFilter Method : getSavingFilter(ImGearSavingFormats) Method
saveFormat
A format for which to return a filter.

Glossary Item Box

Returns the saving filter for a particular format.

This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.

ImGearSavingFormats

Syntax

public static java.lang.String getSavingFilter(
   ImGearSavingFormats saveFormat
)

Parameters

saveFormat
A format for which to return a filter.

Return Value

Saving filter for a particular format.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getSavingFilter(ImGearSavingFormats,ImGearSaveOptions) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getSavingFilter Method : getSavingFilter(ImGearSavingFormats,ImGearSaveOptions) Method
saveFormat
A format for which to return a filter.
options
Additional saving options such as allowed color conversions.

Glossary Item Box

Returns the saving filter for a particular format.

This method comes handy when you need to populate the filter for the Save File dialog with different saving formats.

ImGearSavingFormats ImGearSaveOptions

Syntax

public static java.lang.String getSavingFilter(
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions options
)

Parameters

saveFormat
A format for which to return a filter.
options
Additional saving options such as allowed color conversions.

Return Value

Saving filter for a particular format.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getSavingFormats Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : getSavingFormats Method

Glossary Item Box

Returns an array of all file saving formats compatible with a particular ImGearPage.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

ImGearSavingFormats com.accusoft.imagegear.core.ImGearPage

Overload List

Overload Description
getSavingFormats(ImGearPage) Returns an array of all file saving formats compatible with a particular ImGearPage.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

ImGearSavingFormats com.accusoft.imagegear.core.ImGearPage

getSavingFormats(ImGearPage,ImGearRasterConversionModes) Returns an array of all file saving formats compatible with a particular com.accusoft.imagegear.core.ImGearPage and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

com.accusoft.imagegear.formats.ImGearSavingFormatsT:com.accusoft.imagegear.formats.ImGearRasterConversionModes

getSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) Returns an array of all file saving formats compatible with a particular com.accusoft.imagegear.core.ImGearPage class oblect and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the com.accusoft.imagegear.core.ImGearPage class object.

If options parameter is not null, rasterConversionModes supersedes options.ConversionMode field.

com.accusoft.imagegear.formats.ImGearSavingFormatsT:com.accusoft.imagegear.formats.ImGearRasterConversionModes ImGearSaveOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

getSavingFormats(ImGearPage) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getSavingFormats Method : getSavingFormats(ImGearPage) Method
page
ImGearPage object to get saving formats for.

Glossary Item Box

Returns an array of all file saving formats compatible with a particular ImGearPage.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

ImGearSavingFormats com.accusoft.imagegear.core.ImGearPage

Syntax

public static ImGearSavingFormats[] getSavingFormats(
   ImGearPage page
)

Parameters

page
ImGearPage object to get saving formats for.

Return Value

ImGearSavingFormats enumeration value.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getSavingFormats(ImGearPage,ImGearRasterConversionModes) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getSavingFormats Method : getSavingFormats(ImGearPage,ImGearRasterConversionModes) Method
page
com.accusoft.imagegear.core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.

Glossary Item Box

Returns an array of all file saving formats compatible with a particular com.accusoft.imagegear.core.ImGearPage and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the ImGearPage object.

com.accusoft.imagegear.formats.ImGearSavingFormatsT:com.accusoft.imagegear.formats.ImGearRasterConversionModes

Syntax

public static ImGearSavingFormats[] getSavingFormats(
   ImGearPage page,
   ImGearRasterConversionModes rasterConversionModes
)

Parameters

page
com.accusoft.imagegear.core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.

Return Value

ImGearSavingFormats enumerationarray.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

getSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > getSavingFormats Method : getSavingFormats(ImGearPage,ImGearRasterConversionModes,ImGearSaveOptions) Method
page
com.accusoft.imagegear.core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.
options
Additional saving options and filter control parameters.

Glossary Item Box

Returns an array of all file saving formats compatible with a particular com.accusoft.imagegear.core.ImGearPage class oblect and the conversion mode.

This method comes handy when you need to initialize Save File dialog with all saving formats applicable to the com.accusoft.imagegear.core.ImGearPage class object.

If options parameter is not null, rasterConversionModes supersedes options.ConversionMode field.

com.accusoft.imagegear.formats.ImGearSavingFormatsT:com.accusoft.imagegear.formats.ImGearRasterConversionModes ImGearSaveOptions

Syntax

public static ImGearSavingFormats[] getSavingFormats(
   ImGearPage page,
   ImGearRasterConversionModes rasterConversionModes,
   ImGearSaveOptions options
)

Parameters

page
com.accusoft.imagegear.core.ImGearPage object to get saving formats for.
rasterConversionModes
Raster converter mode.
options
Additional saving options and filter control parameters.

Return Value

ImGearSavingFormats enumerationarray.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadDocument Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : loadDocument Method

Glossary Item Box

Loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

Overload List

Overload Description
loadDocument(ImGearStream,int,int) Loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

loadDocument(ImGearStream,int,int,ImGearLoadOptions) Loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

ImGearLoadOptions com.accusoft.imagegear.core.ImGearDocument

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

loadDocument(ImGearStream,int,int) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadDocument Method : loadDocument(ImGearStream,int,int) Method
stream
startPageNumber
count

Glossary Item Box

Loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

Syntax

public static ImGearDocument loadDocument(
   ImGearStream stream,
   int startPageNumber,
   int count
)

Parameters

stream
startPageNumber
count

Return Value

A new instance of com.accusoft.imagegear.core.ImGearDocument class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadDocument(ImGearStream,int,int,ImGearLoadOptions) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadDocument Method : loadDocument(ImGearStream,int,int,ImGearLoadOptions) Method
stream
The data stream containing an image.
startPageNumber
The number of the first page to load.
count
Total number of pages to load.
options
The loading options.

Glossary Item Box

Loads a range of pages from an image.

This method allows you to load several pages in a single call and get access to the document level metadata of an image. It is recommended to use this method when working with PDF format since pages inside a PDF file depend on each other, and thus, loading them at once (as a document) is preferable to loading pages individually. If the format of an image cannot be detected, an exception is thrown.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

ImGearLoadOptions com.accusoft.imagegear.core.ImGearDocument

Syntax

public static ImGearDocument loadDocument(
   ImGearStream stream,
   int startPageNumber,
   int count,
   ImGearLoadOptions options
)

Parameters

stream
The data stream containing an image.
startPageNumber
The number of the first page to load.
count
Total number of pages to load.
options
The loading options.

Return Value

A new instance of com.accusoft.imagegear.core.ImGearDocument class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadPage Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : loadPage Method

Glossary Item Box

Loads a single page from an image.

This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown.

com.accusoft.imagegear.core.ImGearPage

Overload List

Overload | Description
loadPage(ImGearStream,int) | Loads a single page from an image. This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown. com.accusoft.imagegear.core.ImGearPage
loadPage(ImGearStream,int,ImGearLoadOptions) | Loads a single page from an image. This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly). ImGearLoadOptions com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

loadPage(ImGearStream,int) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadPage Method : loadPage(ImGearStream,int) Method
stream
The data stream containing an image.
pageNumber
The number of page to load; this is a 0-based index.

Glossary Item Box

Loads a single page from an image.

This is the simplest method for loading an image into ImageGear. If the format of an image cannot be detected, an exception is thrown.

com.accusoft.imagegear.core.ImGearPage

Syntax

public static ImGearPage loadPage(
   ImGearStream stream,
   int pageNumber
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load; this is a 0-based index.

Return Value

A new instance of com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadPage(ImGearStream,int,ImGearLoadOptions) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadPage Method : loadPage(ImGearStream,int,ImGearLoadOptions) Method
stream
The data stream containing an image.
pageNumber
The number of page to load.
loadOptions
The loading options.

Glossary Item Box

Loads a single page from an image.

This method provides more flexibility for loading images (i.e., the ability to load image thumbnail and specify image format explicitly).

ImGearLoadOptions com.accusoft.imagegear.core.ImGearPage

Syntax

public static ImGearPage loadPage(
   ImGearStream stream,
   int pageNumber,
   ImGearLoadOptions loadOptions
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load.
loadOptions
The loading options.

Return Value

A new instance of com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadPageHeader Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : loadPageHeader Method

Glossary Item Box

Loads image metadata for a particular page without decoding pixel data.

This method loads image metadata for a particular page without decoding pixel data.

This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

com.accusoft.imagegear.core.ImGearPage

Overload List

Overload | Description
loadPageHeader(ImGearStream,int) | Loads image metadata for a particular page without decoding pixel data. This method loads image metadata for a particular page without decoding pixel data. This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data. com.accusoft.imagegear.core.ImGearPage
loadPageHeader(ImGearStream,int,ImGearLoadOptions) | Loads image metadata for a particular page without decoding pixel data. This method returns an com.accusoft.imagegear.core.ImGearPage class containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data. com.accusoft.imagegear.core.ImGearPage ImGearLoadOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

loadPageHeader(ImGearStream,int) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadPageHeader Method : loadPageHeader(ImGearStream,int) Method
stream
The data stream containing an image.
pageNumber
The number of page to load header from.

Glossary Item Box

Loads image metadata for a particular page without decoding pixel data.

This method loads image metadata for a particular page without decoding pixel data.

This method returns an ImGear page containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

com.accusoft.imagegear.core.ImGearPage

Syntax

public static ImGearPage loadPageHeader(
   ImGearStream stream,
   int pageNumber
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load header from.

Return Value

A new instance of com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

loadPageHeader(ImGearStream,int,ImGearLoadOptions) Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > loadPageHeader Method : loadPageHeader(ImGearStream,int,ImGearLoadOptions) Method
stream
The data stream containing an image.
pageNumber
The number of page to load header from.
options
The loading options.

Glossary Item Box

Loads image metadata for a particular page without decoding pixel data.

This method returns an com.accusoft.imagegear.core.ImGearPage class containing DIB, metadata, image resolution and all other attributes except for pixel data and the palette. This is useful when you need to look up a particular tag in the metadata or get information about image dimensions while avoiding time consuming operation of decoding the pixel data.

com.accusoft.imagegear.core.ImGearPage ImGearLoadOptions

Syntax

public static ImGearPage loadPageHeader(
   ImGearStream stream,
   int pageNumber,
   ImGearLoadOptions options
)

Parameters

stream
The data stream containing an image.
pageNumber
The number of page to load header from.
options
The loading options.

Return Value

A new instance of com.accusoft.imagegear.core.ImGearPage class.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

saveDocument Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : saveDocument Method
document
ImageGear document to save.
stream
ImGearStream to write an image to.
startPageInFile
The number of a start page in the image file where document pages are saved.
mode
Specifies how new pages should be saved to an image; replace pages, insert pages, append pages, or overwrite the entire image.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
Additional saving options such as thumbnail dimensions.

This method allows you to save the entire document in a single call. Both page pixel data and page metadata are saved. If a new image is created (or overwritten), document level metadata is saved as well, otherwise, it is ignored.

com.accusoft.imagegear.core.ImGearDocumentT:com.accusoft.imagegear.formats.ImGearSavingModesT:com.accusoft.imagegear.formats.ImGearSaveOptions

Glossary Item Box

Saves document to an image.

Syntax

public static void saveDocument(
   ImGearDocument document,
   ImGearStream stream,
   int startPageInFile,
   ImGearSavingModes mode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions saveOptions
)

Parameters

document
ImageGear document to save.
stream
ImGearStream to write an image to.
startPageInFile
The number of a start page in the image file where document pages are saved.
mode
Specifies how new pages should be saved to an image; replace pages, insert pages, append pages, or overwrite the entire image.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
saveOptions
Additional saving options such as thumbnail dimensions.

This method allows you to save the entire document in a single call. Both page pixel data and page metadata are saved. If a new image is created (or overwritten), document level metadata is saved as well, otherwise, it is ignored.

com.accusoft.imagegear.core.ImGearDocumentT:com.accusoft.imagegear.formats.ImGearSavingModesT:com.accusoft.imagegear.formats.ImGearSaveOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

savePage Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : savePage Method

Glossary Item Box

Saves page to an image.

Overload List

Overload | Description
savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats) | Saves page to an image.
savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) | Saves page to an image.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > savePage Method : savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats) Method
page
ImageGear page to save.
stream
ImGearFileStream to write an image to.
pageNum
saveMode
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).

Both page pixel data and page metadata are saved by this method.

Note: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

com.accusoft.imagegear.core.ImGearPageT:com.accusoft.imagegear.formats.ImGearSavingFormats

Glossary Item Box

Saves page to an image.

Syntax

public static void savePage(
   ImGearPage page,
   ImGearStream stream,
   int pageNum,
   ImGearSavingModes saveMode,
   ImGearSavingFormats saveFormat
)

Parameters

page
ImageGear page to save.
stream
ImGearFileStream to write an image to.
pageNum
saveMode
Specifies how new page should be saved to an image; replace page, insert page, append page, or overwrite the entire image.Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).

Both page pixel data and page metadata are saved by this method.

Note: Any time SavePage is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.

com.accusoft.imagegear.core.ImGearPageT:com.accusoft.imagegear.formats.ImGearSavingFormats

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > savePage Method : savePage(ImGearPage,ImGearStream,int,ImGearSavingModes,ImGearSavingFormats,ImGearSaveOptions) Method
page
ImageGear page to save.
stream
ImGearStream to write an image to.
pageNum
saveMode
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
options

Glossary Item Box

Saves page to an image.

Syntax

public static void savePage(
   ImGearPage page,
   ImGearStream stream,
   int pageNum,
   ImGearSavingModes saveMode,
   ImGearSavingFormats saveFormat,
   ImGearSaveOptions options
)

Parameters

page
ImageGear page to save.
stream
ImGearStream to write an image to.
pageNum
saveMode
saveFormat
The format to save new pages in. This is a combination of a file format and a compresison (e.g., TIFF-G4).
options

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

updatePageMetadata Method
com.accusoft.imagegear.formats Package > ImGearFileFormats Class : updatePageMetadata Method

Glossary Item Box

Creates a new file with exact copy of source file's pixel data and with new metadata.

Overload List

Overload | Description
updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead) | Creates a new file with exact copy of source file's pixel data and with new metadata.
updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead,ImGearLoadOptions) | Creates a new file with exact copy of source file's pixel data and with new metadata.

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members


%%PageItemTitle%%

updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > updatePageMetadata Method : updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead) Method
sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.

This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

com.accusoft.imagegear.core.ImGearMetadataHead

Glossary Item Box

Creates a new file with exact copy of source file's pixel data and with new metadata.

Syntax

public static void updatePageMetadata(
   ImGearStream sourceStream,
   ImGearStream destinationStream,
   ImGearMetadataHead metadata
)

Parameters

sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.

This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

com.accusoft.imagegear.core.ImGearMetadataHead

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead,ImGearLoadOptions) Method
See Also Send Feedback
com.accusoft.imagegear.formats Package > ImGearFileFormats Class > updatePageMetadata Method : updatePageMetadata(ImGearStream,ImGearStream,ImGearMetadataHead,ImGearLoadOptions) Method
sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.
options
The loading options.

This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

com.accusoft.imagegear.core.ImGearMetadataHead ImGearLoadOptions

Glossary Item Box

Creates a new file with exact copy of source file's pixel data and with new metadata.

Syntax

public static void updatePageMetadata(
   ImGearStream sourceStream,
   ImGearStream destinationStream,
   ImGearMetadataHead metadata,
   ImGearLoadOptions options
)

Parameters

sourceStream
The data stream, containing source image.
destinationStream
The data stream to which to write result image.
metadata
Metadata to be saved to result file.
options
The loading options.

This method creates a new file with an exact copy of the source file's pixel data and with new metadata. Pixel data is not decoded but copied directly from source to destination file.

This method can be used for updating metadata in an image file without modifying the pixel data. To achieve this, delete the source file after calling this method, and rename result file to the source file name.

Tags that affect decoding of pixel data are transferred from the source file, and not replaced with tags from metadata.

Currently, the method only supports metadata updating in the DICOM file format.

com.accusoft.imagegear.core.ImGearMetadataHead ImGearLoadOptions

See Also

Reference

ImGearFileFormats Class
ImGearFileFormats Members
Overload List


%%PageItemTitle%%

ImGearFormatMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearFormatMetadata Class

Glossary Item Box

This is the base class for the Simplified Metadata API accessor classes.

Object Model

ImGearFormatMetadata Class

Syntax

public class ImGearFormatMetadata
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFInteropMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata
com.accusoft.imagegear.formats.ImGearCommonMetadata
com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata
com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

See Also

Reference

ImGearFormatMetadata Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearFormatMetadata Class Members
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearFormatMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearFormatMetadata.

See Also

Reference

ImGearFormatMetadata Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearFormatParameters Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearFormatParameters Class

Glossary Item Box

Allows you to manage format's control parameters.

Object Model

ImGearFormatParameters ClassImGearControlParameter ClassImGearControlParameter Class

Syntax

public sealed class ImGearFormatParameters
    extends Object
    implements java.lang.Iterable

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatParameters

See Also

Reference

ImGearFormatParameters Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearFormatParameters Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearFormatParameters Class

Glossary Item Box

The following tables list the members exposed by ImGearFormatParameters.

Public Methods

 | Name | Description
public Method | getByName | Gets control parameter by name.
public Method | getCount | Gets the total number of control parameters for the format. Any non-negative integer value.
public Method | getItem | Gets control parameter by index. The ImGearControlParameter class interface of the control parameter from the collection of parameters.
public Method | iterator | Gets read only iterator for the collection.
public Method | setToDefault | Sets all control parameters to their default values.
Top

See Also

Reference

ImGearFormatParameters Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearFormatParameters Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearFormatParameters Class

Glossary Item Box

For a list of all members of this type, see ImGearFormatParameters members.

Public Methods

 | Name | Description
public Method | getByName | Gets control parameter by name.
public Method | getCount | Gets the total number of control parameters for the format. Any non-negative integer value.
public Method | getItem | Gets control parameter by index. The ImGearControlParameter class interface of the control parameter from the collection of parameters.
public Method | iterator | Gets read only iterator for the collection.
public Method | setToDefault | Sets all control parameters to their default values.
Top

See Also

Reference

ImGearFormatParameters Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getByName Method
com.accusoft.imagegear.formats Package > ImGearFormatParameters Class : getByName Method
name
The name of the parameter.

Glossary Item Box

Gets control parameter by name.

Syntax

public ImGearControlParameter getByName(
   java.lang.String name
)

Parameters

name
The name of the parameter.

Return Value

The ImGearControlParameter control parameter from the collection of parameters. ImGearControlParameter

See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.formats Package > ImGearFormatParameters Class : getCount Method

Glossary Item Box

Gets the total number of control parameters for the format.

Any non-negative integer value.

Syntax

public int getCount()

See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.formats Package > ImGearFormatParameters Class : getItem Method
index
Index of control parameter to get.

Glossary Item Box

Gets control parameter by index.

The ImGearControlParameter class interface of the control parameter from the collection of parameters.

Syntax

public ImGearControlParameter getItem(
   int index
)

Parameters

index
Index of control parameter to get.

Return Value

The ImGearControlParameter control parameter from the collection of parameters. ImGearControlParameter

See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.formats Package > ImGearFormatParameters Class : iterator Method

Glossary Item Box

Gets read only iterator for the collection.

Syntax

public java.util.Iterator<ImGearControlParameter> iterator()

See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%%

setToDefault Method
com.accusoft.imagegear.formats Package > ImGearFormatParameters Class : setToDefault Method

Glossary Item Box

Sets all control parameters to their default values.

Syntax

public void setToDefault()

See Also

Reference

ImGearFormatParameters Class
ImGearFormatParameters Members


%%PageItemTitle%%

ImGearLoadOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearLoadOptions Class

Glossary Item Box

Specifies additional loading options, such as thumbnail loading or loading an image specifying its format explicitly.

Pass an instance of this class to image loading methods, such as ImGearFileFormats.loadPage

Object Model

ImGearLoadOptions ClassImGearFileFilters ClassImGearFormats EnumerationImGearRectangle Class

Syntax

public class ImGearLoadOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearLoadOptions
com.accusoft.imagegear.formats.ImGearRawLoadOptions

See Also

Reference

ImGearLoadOptions Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLoadOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearLoadOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearLoadOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearLoadOptions Constructor | Initializes a new instance of the ImGearLoadOptions class object.
Top

Public Methods

Name Description
public Method getFilters Returns filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

The default value is null.

ImGearFileFilters

public Method getFormat Returns the file format of an image to load, or enables format autodetection.

public Method getParseXMP Returns a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

public Method getThumbnailLoading Returns a value indicating whether to load image thumbnail instead of the actual image.

Use this value if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

public Method getTilesToStitch Returns the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

public Method setFilters Sets filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method setFormat Sets the file format of an image to load, or enables format autodetection.

Use this method when you need to bypass auto-detection and specify image format explicitly. Specifying ImGearFormats.UNKNOWN will force auto-detection.

The default value is ImGearFormats.UNKNOWN.

ImGearFormats

public Method setParseXMP Sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

public Method setThumbnailLoading Sets a value indicating whether to load image thumbnail instead of the actual image.

Use this property if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

public Method setTilesToStitch Sets the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

Top

See Also

Reference

ImGearLoadOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearLoadOptions Constructor
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : ImGearLoadOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearLoadOptions class object.

Syntax

public ImGearLoadOptions()

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLoadOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearLoadOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearLoadOptions members.

Public Methods

Name Description
public Method getFilters Returns filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

The default value is null.

ImGearFileFilters

public Method getFormat Returns the file format of an image to load, or enables format autodetection.

public Method getParseXMP Returns a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

public Method getThumbnailLoading Returns a value indicating whether to load image thumbnail instead of the actual image.

Use this value if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

public Method getTilesToStitch Returns the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

public Method setFilters Sets filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method setFormat Sets the file format of an image to load, or enables format autodetection.

Use this method when you need to bypass auto-detection and specify image format explicitly. Specifying ImGearFormats.UNKNOWN will force auto-detection.

The default value is ImGearFormats.UNKNOWN.

ImGearFormats

public Method setParseXMP Sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

public Method setThumbnailLoading Sets a value indicating whether to load image thumbnail instead of the actual image.

Use this property if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

public Method setTilesToStitch Sets the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

Top

See Also

Reference

ImGearLoadOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getFilters Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : getFilters Method

Glossary Item Box

Returns filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

The default value is null.

ImGearFileFilters

Syntax

public ImGearFileFilters getFilters()

Return Value

ImGearFileFilters class object.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

getFormat Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : getFormat Method

Glossary Item Box

Returns the file format of an image to load, or enables format autodetection.

Syntax

public ImGearFormats getFormat()

Return Value

Any member of ImGearFormats enumeration value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

getParseXMP Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : getParseXMP Method

Glossary Item Box

Returns a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

Syntax

public boolean getParseXMP()

Return Value

Boolean value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

getThumbnailLoading Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : getThumbnailLoading Method

Glossary Item Box

Returns a value indicating whether to load image thumbnail instead of the actual image.

Use this value if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

Syntax

public boolean getThumbnailLoading()

Return Value

Boolean value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

getTilesToStitch Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : getTilesToStitch Method

Glossary Item Box

Returns the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

Syntax

public ImGearRectangle getTilesToStitch()

Return Value

com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

setFilters Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : setFilters Method
value
ImGearFileFilters class object.

Glossary Item Box

Sets filter settings to be used in a particular image loading operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

Syntax

public void setFilters(
   ImGearFileFilters value
)

Parameters

value
ImGearFileFilters class object.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

setFormat Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : setFormat Method
value
Any member of ImGearFormats enumeration value.

Glossary Item Box

Sets the file format of an image to load, or enables format autodetection.

Use this method when you need to bypass auto-detection and specify image format explicitly. Specifying ImGearFormats.UNKNOWN will force auto-detection.

The default value is ImGearFormats.UNKNOWN.

ImGearFormats

Syntax

public void setFormat(
   ImGearFormats value
)

Parameters

value
Any member of ImGearFormats enumeration value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

setParseXMP Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : setParseXMP Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether ImageGear shall parse XMP stream or provide it to the application as a single binary tag.

The default value is true.

Syntax

public void setParseXMP(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

setThumbnailLoading Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : setThumbnailLoading Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether to load image thumbnail instead of the actual image.

Use this property if you need to load an image thumbnail. This will only work for file formats that support storing a thumbnail, and when thumbnail is actually stored as a part of an image. Otherwise, ImageGear will throw ImGearException with error code com.accusoft.imagegear.core.ImGearErrorCodes.THUMBNAIL_NOT_PRESENT. In this case, load the entire image and create a thumbnail using com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail method.

The default value is false.

Syntax

public void setThumbnailLoading(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

setTilesToStitch Method
com.accusoft.imagegear.formats Package > ImGearLoadOptions Class : setTilesToStitch Method
value
com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

Glossary Item Box

Sets the tiles to be stitched.

The default value is an empty com.accusoft.imagegear.core.shapes.ImGearRectangle object.

Syntax

public void setTilesToStitch(
   ImGearRectangle value
)

Parameters

value
com.accusoft.imagegear.core.shapes.ImGearRectangle structure object.

See Also

Reference

ImGearLoadOptions Class
ImGearLoadOptions Members


%%PageItemTitle%%

ImGearNativeDataTypeHelper Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearNativeDataTypeHelper Class

Glossary Item Box

Helps to work with ImageGear native data types associated with file formats metadata.

Object Model

ImGearNativeDataTypeHelper Class

Syntax

public class ImGearNativeDataTypeHelper
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearNativeDataTypeHelper

See Also

Reference

ImGearNativeDataTypeHelper Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearNativeDataTypeHelper Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearNativeDataTypeHelper Class

Glossary Item Box

The following tables list the members exposed by ImGearNativeDataTypeHelper.

Public Constructors

 | Name | Description
public Constructor | ImGearNativeDataTypeHelper Constructor | Initializes a new instance of the ImGearNativeDataTypeHelper class object.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getValueSize | Returns the value size in bytes for the specified data type.
Top

See Also

Reference

ImGearNativeDataTypeHelper Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearNativeDataTypeHelper Constructor
com.accusoft.imagegear.formats Package > ImGearNativeDataTypeHelper Class : ImGearNativeDataTypeHelper Constructor

Glossary Item Box

Initializes a new instance of the ImGearNativeDataTypeHelper class object.

Syntax

public ImGearNativeDataTypeHelper()

See Also

Reference

ImGearNativeDataTypeHelper Class
ImGearNativeDataTypeHelper Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearNativeDataTypeHelper Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearNativeDataTypeHelper Class

Glossary Item Box

For a list of all members of this type, see ImGearNativeDataTypeHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getValueSize | Returns the value size in bytes for the specified data type.
Top

See Also

Reference

ImGearNativeDataTypeHelper Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getValueSize Method
com.accusoft.imagegear.formats Package > ImGearNativeDataTypeHelper Class : getValueSize Method
typeId
Data type for which to get the size.

Glossary Item Box

Returns the value size in bytes for the specified data type.

Syntax

public static int getValueSize(
   ImGearNativeDataTypes typeId
)

Parameters

typeId
Data type for which to get the size.

Return Value

Value size for the data type. ImGearNativeDataTypes

See Also

Reference

ImGearNativeDataTypeHelper Class
ImGearNativeDataTypeHelper Members


%%PageItemTitle%%

ImGearRawLoadOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearRawLoadOptions Class

Glossary Item Box

Specifies loading options for header-less RAW formats.

Use this class with ImGearFileFormats.loadPage.

Object Model

ImGearRawLoadOptions ClassImGearRawAlignment EnumerationImGearColorSpace ClassImGearCompressions EnumerationImGearFillOrder EnumerationImGearFileFilters ClassImGearFormats EnumerationImGearRectangle Class

Syntax

public class ImGearRawLoadOptions
    extends ImGearLoadOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearLoadOptions
com.accusoft.imagegear.formats.ImGearRawLoadOptions

See Also

Reference

ImGearRawLoadOptions Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRawLoadOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearRawLoadOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearRawLoadOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearRawLoadOptions Constructor | Initializes a new instance of the ImGearRawLoadOptions class object. Use this class with ImGearFileFormats.loadPage.
Top

Public Methods

 | Name | Description
public Method | getAlignment | Gets alignment of bytes in raster line. For additional information see ImGearRawAlignment.
public Method | getBitsPerChannel | Gets the number of bits per color channel.
public Method | getColorSpace | Gets image color space. For additional information see com.accusoft.imagegear.core.ImGearColorSpace.
public Method | getCompression | Gets image compression. For additional information see ImGearCompressions.
public Method | getFillOrder | Gets fill order of pixels in byte. For additional information see ImGearFillOrder.
public Method | getHeight | Gets image height in pixels.
public Method | getOffset | Gets image data offset in the stream.
public Method | getWidth | Gets image width in pixels.
public Method | isRasterPacked | Gets a value indicating whether the raster bits are packed.
public Method | setAlignment | Sets alignment of bytes in raster line. For additional information see ImGearRawAlignment.
public Method | setBitsPerChannel | Sets the number of bits per color channel.
public Method | setColorSpace | Sets image color space. For additional information see com.accusoft.imagegear.core.ImGearColorSpace.
public Method | setCompression | Sets image compression. For additional information see ImGearCompressions.
public Method | setFillOrder | Sets fill order of pixels in byte. For additional information see ImGearFillOrder.
public Method | setHeight | Sets image height in pixels.
public Method | setOffset | Sets image data offset in the stream.
public Method | setRasterPacked | Sets a value indicating whether the raster bits are packed.
public Method | setWidth | Sets image width in pixels.
Top

See Also

Reference

ImGearRawLoadOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearRawLoadOptions Constructor
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : ImGearRawLoadOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearRawLoadOptions class object.

Use this class with ImGearFileFormats.loadPage.

Syntax

public ImGearRawLoadOptions()

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRawLoadOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearRawLoadOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearRawLoadOptions members.

Public Methods

 | Name | Description
public Method | getAlignment | Gets alignment of bytes in raster line. For additional information see ImGearRawAlignment.
public Method | getBitsPerChannel | Gets the number of bits per color channel.
public Method | getColorSpace | Gets image color space. For additional information see com.accusoft.imagegear.core.ImGearColorSpace.
public Method | getCompression | Gets image compression. For additional information see ImGearCompressions.
public Method | getFillOrder | Gets fill order of pixels in byte. For additional information see ImGearFillOrder.
public Method | getHeight | Gets image height in pixels.
public Method | getOffset | Gets image data offset in the stream.
public Method | getWidth | Gets image width in pixels.
public Method | isRasterPacked | Gets a value indicating whether the raster bits are packed.
public Method | setAlignment | Sets alignment of bytes in raster line. For additional information see ImGearRawAlignment.
public Method | setBitsPerChannel | Sets the number of bits per color channel.
public Method | setColorSpace | Sets image color space. For additional information see com.accusoft.imagegear.core.ImGearColorSpace.
public Method | setCompression | Sets image compression. For additional information see ImGearCompressions.
public Method | setFillOrder | Sets fill order of pixels in byte. For additional information see ImGearFillOrder.
public Method | setHeight | Sets image height in pixels.
public Method | setOffset | Sets image data offset in the stream.
public Method | setRasterPacked | Sets a value indicating whether the raster bits are packed.
public Method | setWidth | Sets image width in pixels.
Top

See Also

Reference

ImGearRawLoadOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getAlignment Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getAlignment Method

Glossary Item Box

Gets alignment of bytes in raster line. For additional information see ImGearRawAlignment.

Syntax

public ImGearRawAlignment getAlignment()

Return Value

ImGearRawAlignment enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getBitsPerChannel Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getBitsPerChannel Method

Glossary Item Box

Gets the number of bits per color channel.

Syntax

public int getBitsPerChannel()

Return Value

Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getColorSpace Method

Glossary Item Box

Gets image color space.

For additional information see com.accusoft.imagegear.core.ImGearColorSpace.

Syntax

public ImGearColorSpace getColorSpace()

Return Value

ImGearColorSpace class.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getCompression Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getCompression Method

Glossary Item Box

Gets image compression.

For additional information see ImGearCompressions.

Syntax

public ImGearCompressions getCompression()

Return Value

ImGearCompressions enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getFillOrder Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getFillOrder Method

Glossary Item Box

Gets fill order of pixels in byte.

For additional information see ImGearFillOrder.

Syntax

public ImGearFillOrder getFillOrder()

Return Value

ImGearFillOrder enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getHeight Method

Glossary Item Box

Gets image height in pixels.

Syntax

public int getHeight()

Return Value

Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getOffset Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getOffset Method

Glossary Item Box

Gets image data offset in the stream.

Syntax

public int getOffset()

Return Value

Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : getWidth Method

Glossary Item Box

Gets image width in pixels.

Syntax

public int getWidth()

Return Value

Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

isRasterPacked Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : isRasterPacked Method

Glossary Item Box

Gets a value indicating whether the raster bits are packed.

Syntax

public boolean isRasterPacked()

Return Value

True if the raster bits are packed (the raster bits are not aligned in this case), False - otherwise.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setAlignment Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setAlignment Method
value
ImGearRawAlignment enumeration value.

Glossary Item Box

Sets alignment of bytes in raster line. For additional information see ImGearRawAlignment.

Syntax

public void setAlignment(
   ImGearRawAlignment value
)

Parameters

value
ImGearRawAlignment enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setBitsPerChannel Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setBitsPerChannel Method
value
Integer value.

Glossary Item Box

Sets the number of bits per color channel.

Syntax

public void setBitsPerChannel(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setColorSpace Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setColorSpace Method
value
the color space to set.

Glossary Item Box

Sets image color space.

For additional information see com.accusoft.imagegear.core.ImGearColorSpace.

Syntax

public void setColorSpace(
   ImGearColorSpace value
)

Parameters

value
the color space to set.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setCompression Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setCompression Method
value
ImGearCompressions enumeration value.

Glossary Item Box

Sets image compression.

For additional information see ImGearCompressions.

Syntax

public void setCompression(
   ImGearCompressions value
)

Parameters

value
ImGearCompressions enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setFillOrder Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setFillOrder Method
value
ImGearFillOrder enumeration value.

Glossary Item Box

Sets fill order of pixels in byte.

For additional information see ImGearFillOrder.

Syntax

public void setFillOrder(
   ImGearFillOrder value
)

Parameters

value
ImGearFillOrder enumeration value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setHeight Method
value
Integer value.

Glossary Item Box

Sets image height in pixels.

Syntax

public void setHeight(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setOffset Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setOffset Method
value
Integer value.

Glossary Item Box

Sets image data offset in the stream.

Syntax

public void setOffset(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setRasterPacked Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setRasterPacked Method
value
True if the raster bits are packed (the raster bits are not aligned in this case), False - otherwise.

Glossary Item Box

Sets a value indicating whether the raster bits are packed.

Syntax

public void setRasterPacked(
   boolean value
)

Parameters

value
True if the raster bits are packed (the raster bits are not aligned in this case), False - otherwise.

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.formats Package > ImGearRawLoadOptions Class : setWidth Method
value
the width to set

Glossary Item Box

Sets image width in pixels.

Syntax

public void setWidth(
   int value
)

Parameters

value
the width to set

See Also

Reference

ImGearRawLoadOptions Class
ImGearRawLoadOptions Members


%%PageItemTitle%%

ImGearSaveOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveOptions Class

Glossary Item Box

Specifies additional saving options.

Pass an instance of this class to image saving methods, such as ImGearFileFormats.savePage

Object Model

ImGearSaveOptions ClassImGearRasterConversionModes EnumerationImGearFileFilters ClassImGearSaveThumbnailOptions Class

Syntax

public sealed class ImGearSaveOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearSaveOptions

See Also

Reference

ImGearSaveOptions Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearSaveOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearSaveOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearSaveOptions Constructor | Initializes a new instance of the ImGearSaveOptions class object.
Top

Public Methods

Name Description
public Method getConversionMode Returns raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

public Method getEmbedColorProfile Returns a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles.
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

public Method getFilters Returns filter settings to be used in a particular image saving operation.

If return value is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

Return value can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method getForceColorspace Returns the value indicating that images should only be saved in the specified color space.

The default value is com.accusoft.imagegear.core.ImGearColorSpaceIDs.NONE.

com.accusoft.imagegear.core.ImGearErrorCodes com.accusoft.imagegear.core.ImGearColorSpaceIDs

public Method getThumbnail Gets access to thumbnail saving options.

ImGearSaveThumbnailOptions class object. ImGearSaveThumbnailOptions

public Method setConversionMode Sets raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

public Method setEmbedColorProfile Sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles .
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

public Method setFilters Sets filter settings to be used in a particular image saving operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method setForceColorspace Sets the value indicating that images should only be saved in the specified color space.

Invoke this method to set specific color space to tell ImageGear use only this color space for image saving. If the file format supports this color space for saving, and other settings and control parameters allow saving to this color space, the image will be saved with the specified color space. Otherwise, ImageGear will throw an exception with com.accusoft.imagegear.core.ImGearErrorCodes.CANT_SAVE_FORMAT error code.

This mode can be used for conversion of image files from one color space to another, without having to store converted image in memory. To convert an image, load it into ImageGear, set ForceColorspace to desired color space, and save the image.

The default value is EnumSet.noneOf(ImGearColorSpaceIDs.class).

com.accusoft.imagegear.core.ImGearErrorCodes

Top

See Also

Reference

ImGearSaveOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearSaveOptions Constructor
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : ImGearSaveOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearSaveOptions class object.

Syntax

public ImGearSaveOptions()

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearSaveOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearSaveOptions members.

Public Methods

Name Description
public Method getConversionMode Returns raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

public Method getEmbedColorProfile Returns a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles.
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

public Method getFilters Returns filter settings to be used in a particular image saving operation.

If return value is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

Return value can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method getForceColorspace Returns the value indicating that images should only be saved in the specified color space.

The default value is com.accusoft.imagegear.core.ImGearColorSpaceIDs.NONE.

com.accusoft.imagegear.core.ImGearErrorCodes com.accusoft.imagegear.core.ImGearColorSpaceIDs

public Method getThumbnail Gets access to thumbnail saving options.

ImGearSaveThumbnailOptions class object. ImGearSaveThumbnailOptions

public Method setConversionMode Sets raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

public Method setEmbedColorProfile Sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles .
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

public Method setFilters Sets filter settings to be used in a particular image saving operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

public Method setForceColorspace Sets the value indicating that images should only be saved in the specified color space.

Invoke this method to set specific color space to tell ImageGear use only this color space for image saving. If the file format supports this color space for saving, and other settings and control parameters allow saving to this color space, the image will be saved with the specified color space. Otherwise, ImageGear will throw an exception with com.accusoft.imagegear.core.ImGearErrorCodes.CANT_SAVE_FORMAT error code.

This mode can be used for conversion of image files from one color space to another, without having to store converted image in memory. To convert an image, load it into ImageGear, set ForceColorspace to desired color space, and save the image.

The default value is EnumSet.noneOf(ImGearColorSpaceIDs.class).

com.accusoft.imagegear.core.ImGearErrorCodes

Top

See Also

Reference

ImGearSaveOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getConversionMode Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : getConversionMode Method

Glossary Item Box

Returns raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

Syntax

public ImGearRasterConversionModes getConversionMode()

Return Value

ImGearRasterConversionModes enumeration value.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

getEmbedColorProfile Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : getEmbedColorProfile Method

Glossary Item Box

Returns a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles.
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

Syntax

public boolean getEmbedColorProfile()

Return Value

Boolean value.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

getFilters Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : getFilters Method

Glossary Item Box

Returns filter settings to be used in a particular image saving operation.

If return value is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

Return value can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

Syntax

public ImGearFileFilters getFilters()

Return Value

ImGearFileFilters class object.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

getForceColorspace Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : getForceColorspace Method

Glossary Item Box

Returns the value indicating that images should only be saved in the specified color space.

The default value is com.accusoft.imagegear.core.ImGearColorSpaceIDs.NONE.

com.accusoft.imagegear.core.ImGearErrorCodes com.accusoft.imagegear.core.ImGearColorSpaceIDs

Syntax

public java.util.EnumSet<ImGearColorSpaceIDs> getForceColorspace()

Return Value

com.accusoft.imagegear.core.ImGearColorSpaceIDs enumeration.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

getThumbnail Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : getThumbnail Method

Glossary Item Box

Gets access to thumbnail saving options.

ImGearSaveThumbnailOptions class object. ImGearSaveThumbnailOptions

Syntax

public ImGearSaveThumbnailOptions getThumbnail()

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

setConversionMode Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : setConversionMode Method
value
ImGearRasterConversionModes enumeration value.

Glossary Item Box

Sets raster converter's conversion mode for saving.

The default value is ImGearRasterConversionModes.ANY.

ImGearRasterConversionModes

Syntax

public void setConversionMode(
   ImGearRasterConversionModes value
)

Parameters

value
ImGearRasterConversionModes enumeration value.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

setEmbedColorProfile Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : setEmbedColorProfile Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether the color profile associated with image (or with image color space) shall be embedded into file being saved.

This option has effect only if:

  • ImageGear color profile support is activated through com.accusoft.imagegear.core.ImGearColorProfileManager.enableProfiles .
  • Destination file format supports profile embedding.

The default value is true.

com.accusoft.imagegear.core.ImGearColorProfileManager

Syntax

public void setEmbedColorProfile(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

setFilters Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : setFilters Method
value
ImGearFileFilters class object.

Glossary Item Box

Sets filter settings to be used in a particular image saving operation.

If this property is not null, it overrides the global settings specified by ImGearFileFormats.getFilters.

This property can be used in a multithreaded application, in order to use different filter control parameters in different threads.

The default value is null.

ImGearFileFilters

Syntax

public void setFilters(
   ImGearFileFilters value
)

Parameters

value
ImGearFileFilters class object.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

setForceColorspace Method
com.accusoft.imagegear.formats Package > ImGearSaveOptions Class : setForceColorspace Method
value
EnumSet<com.accusoft.imagegear.core.ImGearColorSpaceIDs>.

Glossary Item Box

Sets the value indicating that images should only be saved in the specified color space.

Invoke this method to set specific color space to tell ImageGear use only this color space for image saving. If the file format supports this color space for saving, and other settings and control parameters allow saving to this color space, the image will be saved with the specified color space. Otherwise, ImageGear will throw an exception with com.accusoft.imagegear.core.ImGearErrorCodes.CANT_SAVE_FORMAT error code.

This mode can be used for conversion of image files from one color space to another, without having to store converted image in memory. To convert an image, load it into ImageGear, set ForceColorspace to desired color space, and save the image.

The default value is EnumSet.noneOf(ImGearColorSpaceIDs.class).

com.accusoft.imagegear.core.ImGearErrorCodes

Syntax

public void setForceColorspace(
   java.util.EnumSet<ImGearColorSpaceIDs> value
)

Parameters

value
EnumSet<com.accusoft.imagegear.core.ImGearColorSpaceIDs>.

See Also

Reference

ImGearSaveOptions Class
ImGearSaveOptions Members


%%PageItemTitle%%

ImGearSaveThumbnailOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveThumbnailOptions Class

Glossary Item Box

Specifies thumbnail attributes such as width and height to be used when saving a thumbnail.

Object Model

ImGearSaveThumbnailOptions Class

Syntax

public sealed class ImGearSaveThumbnailOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearSaveThumbnailOptions

See Also

Reference

ImGearSaveThumbnailOptions Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearSaveThumbnailOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveThumbnailOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearSaveThumbnailOptions.

Public Methods

 | Name | Description
public Method | getCompressed | Returns a value indicating whether the thumbnail should be compressed. The default value is false.
public Method | getEnabled | Returns a value indicating whether thumbnail saving is enabled or not.
public Method | getHeight | Returns the height of the thumbnail. The default value is 64.
public Method | getWidth | Returns the width of the thumbnail. The default value is 64.
public Method | setCompressed | Sets a value indicating whether the thumbnail should be compressed. The default value is false.
public Method | setEnabled | Sets a value indicating whether thumbnail saving is enabled or not. Setting this value to true will enable saving a thumbnail. The default value is false.
public Method | setHeight | Sets the height of the thumbnail. The default value is 64.
public Method | setWidth | Sets the width of the thumbnail. The default value is 64.
Top

See Also

Reference

ImGearSaveThumbnailOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearSaveThumbnailOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearSaveThumbnailOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearSaveThumbnailOptions members.

Public Methods

 | Name | Description
public Method | getCompressed | Returns a value indicating whether the thumbnail should be compressed. The default value is false.
public Method | getEnabled | Returns a value indicating whether thumbnail saving is enabled or not.
public Method | getHeight | Returns the height of the thumbnail. The default value is 64.
public Method | getWidth | Returns the width of the thumbnail. The default value is 64.
public Method | setCompressed | Sets a value indicating whether the thumbnail should be compressed. The default value is false.
public Method | setEnabled | Sets a value indicating whether thumbnail saving is enabled or not. Setting this value to true will enable saving a thumbnail. The default value is false.
public Method | setHeight | Sets the height of the thumbnail. The default value is 64.
public Method | setWidth | Sets the width of the thumbnail. The default value is 64.
Top

See Also

Reference

ImGearSaveThumbnailOptions Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getCompressed Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : getCompressed Method

Glossary Item Box

Returns a value indicating whether the thumbnail should be compressed.

The default value is false.

Syntax

public boolean getCompressed()

Return Value

Boolean value.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

getEnabled Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : getEnabled Method

Glossary Item Box

Returns a value indicating whether thumbnail saving is enabled or not.

Syntax

public boolean getEnabled()

Return Value

Boolean value.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : getHeight Method

Glossary Item Box

Returns the height of the thumbnail.

The default value is 64.

Syntax

public int getHeight()

Return Value

Any integer value greater than 0.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : getWidth Method

Glossary Item Box

Returns the width of the thumbnail.

The default value is 64.

Syntax

public int getWidth()

Return Value

Any integer value greater than 0.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

setCompressed Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : setCompressed Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether the thumbnail should be compressed.

The default value is false.

Syntax

public void setCompressed(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

setEnabled Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : setEnabled Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether thumbnail saving is enabled or not.

Setting this value to true will enable saving a thumbnail.

The default value is false.

Syntax

public void setEnabled(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : setHeight Method
value
Any integer value greater than 0.

Glossary Item Box

Sets the height of the thumbnail.

The default value is 64.

Syntax

public void setHeight(
   int value
)

Parameters

value
Any integer value greater than 0.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.formats Package > ImGearSaveThumbnailOptions Class : setWidth Method
value
Any integer value greater than 0.

Glossary Item Box

Sets the width of the thumbnail.

The default value is 64.

Syntax

public void setWidth(
   int value
)

Parameters

value
Any integer value greater than 0.

See Also

Reference

ImGearSaveThumbnailOptions Class
ImGearSaveThumbnailOptions Members


%%PageItemTitle%%

ImGearSimplifiedMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : ImGearSimplifiedMetadata Class

Glossary Item Box

This class initializes the imagegear2.formats.simplifiedmetadata.jar. It adds formats that are implemented by the component to the ImageGearJava's global formats list, enabling their detection, reading, and writing.

Object Model

ImGearSimplifiedMetadata Class

Syntax

public sealed class ImGearSimplifiedMetadata
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearSimplifiedMetadata

See Also

Reference

ImGearSimplifiedMetadata Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearSimplifiedMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : ImGearSimplifiedMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearSimplifiedMetadata.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | This method initializes SimplifiedMetadata module. It adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing jar files, see File Format Support Initialization.
Top

See Also

Reference

ImGearSimplifiedMetadata Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearSimplifiedMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : ImGearSimplifiedMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearSimplifiedMetadata members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | initialize | This method initializes SimplifiedMetadata module. It adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing jar files, see File Format Support Initialization.
Top

See Also

Reference

ImGearSimplifiedMetadata Class
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.formats Package > ImGearSimplifiedMetadata Class : initialize Method

Glossary Item Box

This method initializes SimplifiedMetadata module. It adds formats that are implemented by the component to the ImageGear's global formats list, enabling their detection, reading, and writing. For more information about initializing jar files, see File Format Support Initialization.

Syntax

public static void initialize()

See Also

Reference

ImGearSimplifiedMetadata Class
ImGearSimplifiedMetadata Members


%%PageItemTitle%%

ImGearBMPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearBMPTagIDs Enumeration

Glossary Item Box

Lists all BMP tag identifiers.

Members

Member | Description
BITCOUNT | Image bit count.
CLRIMPORTANT | Number of color indexes required for displaying the bitmap.
CLRUSED | Number of color indexes in the color table that are actually used by the bitmap.
COLORENCODING | Color model used in bitmap (IBM OS/2 2.x).
COMPRESSION | Image compression type.
FORMAT | BMP metadata format identifier.
HEIGHT | Image height.
IDENTIFIER | Reserved for application use (IBM OS/2 2.x).
PLANES | Number of color planes.
RECORDING | Recording algorithm (IBM OS/2 2.x).
RENDERING | Halftoning algorithm used (IBM OS/2 2.x).
SIZE | Image size.
SIZE1 | Reserved for halftoning algorithm use (IBM OS/2 2.x).
SIZE2 | Reserved for halftoning algorithm use (IBM OS/2 2.x).
TYPE | BMP format type.
UNITS | Type of units used to measure resolution (IBM OS/2 2.x).
WIDTH | Image width.
XPELSPERMETER | Horizontal resolution in pixels per meter.
YPELSPERMETER | Vertical resolution in pixels per meter.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearBMPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearBTRTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearBTRTagIDs Enumeration

Glossary Item Box

Lists all BTR tag identifiers.

Members

Member | Description
BITSPERPIXEL | Bits per pixel.
FORMAT | BTR metadata format identifier.
HORZRES | Horizontal resolution.
IMAGETYPE | Image type.
MANUFACTURER | Manufacturer value.
NEXTPAGE | Next page.
NUMLINES | Number of lines.
PIXELSPERLINE | Pixels per line.
PREVPAGE | Previous page.
STORAGEFMT | Storage format.
TRANSFMT | Trans format.
VERSION | Version value.
VERTRES | Vertical resolution.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearBTRTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCALTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCALTagIDs Enumeration

Glossary Item Box

Lists all CAL tag identifiers.

Members

Member | Description
DOCCLS | Document security lable.
DSTDOCID | Destination system document identifier.
FIGID | Figure or table identifier. This is the number by which the image page figure is referenced.
FORMAT | CAL metadata format identifier.
FOSIPUBID | PUBLIC identifier of an associated FOSI.
NOTES | Notes information that is not applicable to any of the other records in the CALS raster file header.
RDENSITY | Raster image density.
RORIENT | Raster image orientation.
RPELCNT | Raster image pel count.
RTYPE | Raster data type. This is the format of raster image data that follows the header record data block in this file.
SPECVERSION | Spec version.
SRCDOCID | Source system document identifier.
SRCGPH | Source system graphics filename.
TXTFILID | Text file identifier. This record contains a string indicating the document page that this image page contains.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCALTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFAFInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFAFInfoTagIDs Enumeration

Glossary Item Box

Lists all CIFF AF Info tag identifiers.

Members

Member | Description
AF_AREA_HEIGHT | AF area height.
AF_AREA_WIDTH | AF area width.
AF_AREA_X_POSITIONS | AF area X position.
AF_AREA_Y_POSITIONS | AF area Y position.
AF_IMAGE_HEIGHT | AF image height.
AF_IMAGE_WIDTH | AF image width.
AF_POINTS_IN_FOCUS | AF points in focus.
AFPOINTS_USED | AF points used.
AFPOINTS_USED1 | AF points used1.
CANON_IMAGE_HEIGHT | Canon image height.
CANON_IMAGE_WIDTH | Canon image width.
FORMAT | CIFF AF Info metadata format identifier.
NUM_AF_POINTS | Number of AF points.
PRIMARY_AF_POINT | Primary AF point.
PRIMARY_AF_POINT_or_AFInfo | Primary AF point or AFInfo.
VALID_AF_POINTS | Valid AF points.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFAFInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFCanonCameraSettingsTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFCanonCameraSettingsTagIDs Enumeration

Glossary Item Box

Lists all CIFF Canon Camera Settings tag identifiers.

Members

Member | Description
AE_SETTING | AE setting.
AFPOINT | AF point setting.
CANON_EXPOSURE_MODE | Canon exposure mode.
CANON_FLASH_MODE | Canon flash mode.
CANON_IMAGE_SIZE | Canon image size.
COLOR_TONE | Color tone.
CONTINUOUS_DRIVE | Continuous drive.
CONTRAST | Contrast setting.
DIGITAL_ZOOM | Digital zoom.
DISPLAY_APERTURE | Display aperture.
EASY_MODE | Easy mode.
FLASH_ACTIVITY | Flash activity.
FLASH_BITS | Flash bits.
FOCAL_UNITS | Focal units.
FOCUS_CONTINUOUS | Focus continuous.
FOCUS_MODE | Focus mode.
FOCUS_TYPE | Focus type.
FORMAT | CIFFCanonCameraSettings metadata format identifier.
IMAGE_STABILIZATION | Image stabilization.
ISO | Camera ISO.
LENS_TYPE | Lens type.
LONG_FOCAL | Long focal.
MACRO_MODE | Macro mode.
MANUAL_FLASH_OUTPUT | Manual flash output.
MAX_APERTURE | Max aperture.
METERING_MODE | Metering mode.
MIN_APERTURE | Min aperture.
PHOTO_EFFECT | Photo effec.
QUALITY | Quality setting.
RECORD_MODE | Record mode.
SATURATION | Saturation setting.
SELF_TIMER | Self-timer value.
SHARPNESS | Sharpness setting.
SHORT_FOCAL | Short focal.
ZOOMED_RESOLUTION | Zoomed resolution.
ZOOMED_RESOLUTION_BASE | Zoomed resolution base.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFCanonCameraSettingsTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFFocalLengthTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFFocalLengthTagIDs Enumeration

Glossary Item Box

Lists all CIFF Focal Length tag identifiers.

Members

Member | Description
FORMAT | CIFFFocalLength metadata format identifier.
LENGTH | Focal length.
PLANE_XSIZE | Focal plane X size.
PLANE_YSIZE | Focal plane Y size.
TYPE | Focal length type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFFocalLengthTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFImageInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFImageInfoTagIDs Enumeration

Glossary Item Box

Lists all CIFF Image Info tag identifiers.

Members

Member | Description
COLOR_BIT_DEPTH | Color bit depth.
COLOR_BW | Color BW information.
COMPONENT_BIT_DEPTH | Component bit depth.
FORMAT | CIFF image Info metadata format identifier.
HEIGHT | Height CIFF image Info.
PIXEL_ASPECT_RATIO | Pixel aspect ratio.
ROTATION | Rotation CIFF image Info.
WIDTH | Width CIFF image Info.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFImageInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFShotInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFShotInfoTagIDs Enumeration

Glossary Item Box

Lists all CIFF Shot Info tag identifiers.

Members

Member | Description
AEBBRACKET_VALUE | AEB bracket value.
AUTO_EXPOSURE_BRACKETING | Auto exposure bracketing.
AUTO_ISO | Auto ISO value.
AUTO_ROTATE | Auto rotate.
BULB_DURATION | Bulb duration.
CAMERA_TYPE | Camera type.
EXPOSURE_COMPENSATION | Exposure compensation.
EXPOSURE_TIME | Exposure time.
FLASH_EXPOSURE_COMP | Flash exposure comp.
FLASH_GUIDE_NUMBER | Flash GUIDE number.
FLASH_OUTPUT | Flash output.
FNUMBER | F number value.
FOCUS_DISTANCE_LOWER | Focus distance lower.
FOCUS_DISTANCE_UPPER | Focus distance upper.
FORMAT | CIFF Shot Info metadata format identifier.
ISO | Base ISO value.
IXUS_AFPOINT | Ixus AF point.
MEASURED_EV | Measured EV.
ND_FILTER | No filter.
OPTICAL_ZOOM_CODE | Optical zoom code.
SELF_TIMER2 | Self-timer 2.
SEQUENCE_NUMBER | Sequence number.
SLOW_SHUTTER | Slow shutter.
TARGET_APERTURE | Target aperture.
TARGET_EXPOSURETIME | Target exposition.
WHITE_BALANCE | White balance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFShotInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCIFFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCIFFTagIDs Enumeration

Glossary Item Box

Lists all CIFF tag identifiers.

Members

Member | Description
BASE_ISO | Base ISO number.
CAMERA_OBJECT | Camera object.
CAMERA_SPECIFICATION | Camera specification.
CANON_CAMERA_SETTINGS | Canon camera settings.
CANON_COLOR_INFO1 | Canon color info 1.
CANON_COLOR_INFO2 | Canon color info 2.
CANON_CUSTOM_FUNCTIONS | Canon custom functions.
CANON_FILE_DESCRIPTION | Canon file description.
CANON_FIRMWARE_VERSION | Canon firmware version.
CANON_IMAGE_TYPE | Canon image type.
CANON_PICTURE_INFO | Canon picture info.
CANON_RAW_MAKE_MODEL | Canon raw make model.
CANON_SHOT_INFO | Canon shot info.
COLOR_SPACE | Color space.
COLOR_TEMPERATURE | Color temperature.
COMPONENT_VERSION | Component version.
DECODER_TABLE | Decoder table.
EXIF_INFORMATION | Exif information.
EXPOSURE_INFO | Exposure info.
FILE_NUMBER | File number.
FLASH_INFO | Flash info.
FOCAL_LENGTH | Focal length.
FORMAT | CIFF metadata format identifier.
FREE_BYTES | Free bytes.
IMAGE_DESCRIPTION | Image description.
IMAGE_FORMAT | Image format.
IMAGE_INFO | Image info.
IMAGE_PROPS | Image props.
JPG_FROM_RAW | Jpg from raw.
MEASURED_EV | Measured EV.
MEASURED_INFO | Measured info.
NULL_RECORD | Null record.
ORIGINAL_FILE_NAME | Original file name.
OWNER_NAME | Owner name.
RAW_DATA | The raw data.
RECORD_ID | Record ID.
RELEASE_SETTING | Release setting.
ROM_OPERATION_MODE | ROM operation mode.
SELF_TIMER_TIME | Self timer time.
SENSOR_INFO | Sensor info.
SERIAL_NUMBER | Serial number.
SHOOTING_RECORD | Shooting record.
SHUTTER_RELEASE_METHOD | Shutter release method.
SHUTTER_RELEASE_TIMING | Shutter release timing.
TARGET_DISTANCE_SETTING | Target distance setting.
TARGET_IMAGE_TYPE | Target image type.
THUMBNAIL_FILE_NAME | Thumbnail file name.
THUMBNAIL_IMAGE | Thumbnail image.
TIME_STAMP | Time stamp.
USER_COMMENT | User comment.
WHITE_BALANCE_TABLE | White balance table.
WHITE_SAMPLE | White sample.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCIFFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCLPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCLPTagIDs Enumeration

Glossary Item Box

Lists all CLP tag identifiers.

Members

Member | Description
FILE_ID | File magic id value.
FORMAT | CLP metadata format identifier.
FORMAT_COUNT | Format count.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCLPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCompressions Enumeration
com.accusoft.imagegear.formats Package : ImGearCompressions Enumeration

Glossary Item Box

Lists all ImageGear supported compressions.

Members

Member | Description
ABIC | IBM ABIC compression.
ABIC_BW | IBM ABIC Bilevel compression.
ABIC_GRAY | IBM ABIC Concatenated compression.
ASCII | ASCII compression.
AUTO | On loading: compression is unknown. On saving: compression is selected by file format.
CANON_CRW | Canon CRW compression.
CCITT_G3 | CCITT Group 3 compression.
CCITT_G32D | CCITT Group 3 2D compression.
CCITT_G4 | CCITT Group 4.compression.
DEFLATE | Deflate compression.
HDPhoto | HD Photo compression.
HUFFMAN | Huffman compression.
IBM_MMR | IBM MMR compression.
JBIG | JBIG compression.
JBIG2 | JBIG2 compression.
JPEG | JPEG compression.
JPEG2K | JPEG 2000 compression.
KODAK_RAW | Kodak RAW compression.
LZW | LZW compression.
NONE | No compression.
PACKED_BITS | Packed bits compression.
RAW | Raw compression.
RLE | Run Length Encoding compression.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCompressions

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearCUTTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearCUTTagIDs Enumeration

Glossary Item Box

Lists all CUT tag identifiers.

Members

Member | Description
FORMAT | CUT metadata format identifier.
HEIGHT | Image height.
RESERVED | Reserved value.
WIDTH | Image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearCUTTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearDCRAWTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearDCRAWTagIDs Enumeration

Glossary Item Box

Lists all Digital Camera RAW tag identifiers.

Members

Member | Description
AS_SHOT_WHITEXY | As shot white XY.
ASSHOTNEUTRAL | As shot neutral.
BASELINEEXPOSURE | Baseline exposure.
BITSPERSAMPLE | Bits per sample.
BLACKLEVEL | Black level.
BLACKLEVELREPEATDIM | Black level repeat dim.
CALIBRATIONILLUMINANT1 | Calibration illuminant 1.
CALIBRATIONILLUMINANT2 | Calibration illuminant 2.
CFAPATTERN | CFA pattern.
CFAREPEATPATTERNDIM | CFA repeat pattern dim.
COLORMATRIX1 | Color matrix 1.
COLORMATRIX2 | Color matrix 2.
COLORPLANES | Color planes.
COMMON | Common metadata section.
FORMAT | DCRAW metadata format identifier.
IMAGEHEIGHT | Image height.
IMAGEWIDTH | Image width.
MAKE | Camera producer.
MODEL | Camera model.
PHOTOMETRICINTERPRETATION | Photometric interpretation.
RAWHEIGHT | Raw height.
RAWLEFT | Actual raw image start left position.
RAWTOP | Actual raw image start top position.
RAWWIDTH | Raw width.
SAMPLESPERPIXEL | Samples per pixel.
STATISTICS | Statistics metadata section.
TIMESTAMP | Time stamp.
UNIQUECAMERAMODEL | Unique camera model.
WHITELEVEL | White level.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearDCRAWTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearDCXTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearDCXTagIDs Enumeration

Glossary Item Box

Lists all DCX tag identifiers.

Members

Member | Description
FORMAT | DCX metadata format identifier.
MAGIC | Magic value.
PAGE_LIST | Page list.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearDCXTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearDisplayInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearDisplayInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Display Info tag identifiers.

Members

Member | Description
DATA | Display data.
FORMAT | Display info metadata format identifier.
LENGTH | Display length.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearDisplayInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFFPXRTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFFPXRTagIDs Enumeration

Glossary Item Box

Lists all EXIF FPXR tag identifiers.

Members

Member | Description
EXTENSIONID | FPXR extension ID.
FORMAT | EXIF_FPXR metadata format identifier.
HEADER | FPXR header.
INDEXTOCONTENTSLIST | FPXR index to contents list.
INTEROPERABILITYCOUNT | FPXR interoperability count.
OFFSETTOSTREAM | FPXR offset to stream.
RESERVEDDATA | FPXR reserved data.
STREAMDATA | FPXR stream data.
VERSION | FPXR version.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFFPXRTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFGPSTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFGPSTagIDs Enumeration

Glossary Item Box

Lists all EXIF GPS tag identifiers.

Members

Member | Description
ALTITUDE | GPS altitude.
ALTITUDEREF | GPS altitude ref.
AREAINFORMATION | GPS area information.
DATESTAMP | GPS date stamp.
DESTBEARING | GPS dest bearing.
DESTBEARINGREF | GPS dest bearing ref.
DESTDISTANCE | GPS dest distance.
DESTDISTANCEREF | GPS dest distance ref.
DESTLATITUDE | GPS dest latitude.
DESTLATITUDEREF | GPS dest latitude ref.
DESTLONGITUDE | GPS dest longitude.
DESTLONGITUDEREF | GPS dest longitude ref.
DIFFERENTIAL | GPS differential.
DOP | Measurement precision.
FORMAT | EXIF_GPS metadata format identifier.
IMGDIRECTION | GPS img direction.
IMGDIRECTIONREF | GPS img direction ref.
LATITUDE | GPS latitude.
LATITUDEREF | GPS latitude ref.
LONGITUDE | GPS longitude.
LONGITUDEREF | GPS longitude ref.
MAPDATUM | GPS map datum.
MEASUREMODE | GPS measure mode.
PROCESSINGMETHOD | GPS processing method.
SATELLITES | GPS satellites.
SPEED | GPS speed.
SPEEDREF | GPS speed ref.
STATUS | GPS status.
TIMESTAMP | GPS time stamp.
TRACK | GPS track.
TRACKREF | GPS track ref.
VERSIONID | GPS version ID.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFGPSTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFInterOpTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFInterOpTagIDs Enumeration

Glossary Item Box

Lists all EXIF Interoperability tag identifiers.

Members

Member | Description
FORMAT | EXIF_Interoperability metadata format identifier.
INTEROPERABILITYINDEX | Interoperability index.
INTEROPERABILITYVERSION | Interoperability version.
RELATEDIMAGEFILEFORMAT | Related image file format.
RELATEDIMAGELENGTH | Related image length.
RELATEDIMAGEWIDTH | Related image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFInterOpTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteFujiTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteFujiTagIDs Enumeration

Glossary Item Box

Lists all Fujifilm EXIF MakerNote tag identifiers.

Members

Member | Description
AUTOEXPOSUREWARNING | Auto exposure warning.
BLURWARNING | Blur warning.
COLOUR | Chroma saturation setting.
CONTINUOUSTAKINGORAUTOBRACKETINGMODE | Continuous taking or auto bracketting mode.
FLASHMODE | Flash mode.
FLASHSTRENGTH | Flash strength.
FOCUSMODE | Focus mode.
FOCUSWARNING | Focus warning.
FORMAT | EXIF_MakerNote_Fuji metadata format identifier.
MACRO | Macro mode setting.
PICTUREMODE | Picture mode.
QUALITY | Image quality setting.
SHARPNESS | Sharpness setting.
SLOWSYNCMODE | Slow synchro mode.
TONE | Contrast setting.
VERSION | Makernote version.
WHITEBALANCE | White balance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteFujiTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteNikonType1TagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteNikonType1TagIDs Enumeration

Glossary Item Box

Lists all Nikon EXIF MakerNote Type 1 tag identifiers.

Members

Member | Description
CCDSENSITIVITY | CCD sensitivity.
COLOURMODE | Colour mode.
CONVERTER | Converter info.
DIGITALZOOM | Digital zoom.
FORMAT | EXIF_MakerNote_NikonType metadata format identifier.
IMAGEADJUSTMENT | Image adjustment.
QUALITY | Image quality setting.
WHITEBALANCE | White balance.
WHITEBALANCELOOKUP | White balance lookup.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteNikonType1TagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteNikonType2TagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteNikonType2TagIDs Enumeration

Glossary Item Box

Lists all Nikon EXIF MakerNote Type 2 tag identifiers.

Members

Member | Description
AEBRACKETCOMPENSATIONAPPLIED | AE bracket compensation applied.
AUTOFLASHMODE | Auto flash mode.
AUTOFOCUSAREA | Auto focus area.
AUXILIARYLENS | Auxiliary lens.
BRACKETINGANDSHOOTINGMODE | Bracketing and shooting mode.
COLOURMODE1 | Colour mode.
COLOURMODE2 | Colour mode.
DIGITALVARIPROGRAM | Digital vari program.
DIGITALZOOMFACTOR | Digital zoom factor.
FLASHBRACKETCOMPENSATIONAPPLIED | Flash bracket compensation applied.
FLASHCOMPENSATION | Flash compensation.
FLASHSETTING | Flash setting.
FLASHUSED | Flash used.
FOCUSMODE | Focus mode.
FORMAT | EXIF_MakerNote_NikonType2 metadata format identifier.
HUEADJUSTMENT | Hue adjustment.
IMAGEADJUSTMENT | Image adjustment.
IMAGEOPTIMIZATION | Image optimization.
ISOSELECTION | ISO selection.
ISOSPEEDREQUESTED | ISO speed requested.
ISOSPEEDUSED | ISO speed used.
LENSMINMAXFOCALLENGTHMAXAPERTURE | Lens min/Max focal length max aperture.
LENSTYPE | Lens type.
LIGHTINGTYPE | Lighting type.
MANUALFOCUSDISTANCE | Manual focus distance.
NIKONMAKERNOTEVERSION | Nikon makernote version.
NOISEREDUCTION | Noise reduction.
PHOTOCORNERCOORDINATES | Photo corner coordinates.
QUALITY | Image quality setting.
SATURATION | Saturation setting.
SATURATIONLOOKUP | Saturation numeric lookup value.
SCENEMODE | Scene mode.
SHARPNING | Image sharpening setting.
TONECOMPENSATION | Tone compensation.
TOTALNUMBEROFSHUTTERRELEASESFORCAMERA | Total numberof shutter releasesfor camera.
WHITEBALANCE | White balance.
WHITEBALANCEBIASVALUE | White balance bias value.
WHITEBALANCEREDBLUECOEFFISIENTS | White balance red blue coefficients.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteNikonType2TagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteOlympusTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteOlympusTagIDs Enumeration

Glossary Item Box

Lists all Olympus EXIF MakerNote tag identifiers.

Members

Member | Description
APETUREVALUE | Aperture value.
APPLICATIONMODEIFD | Application IFD.
APPLICATIONMODEIFD2 | Application IFD2.
BLACKLEVEL | Black level.
BLUEBALANCE | Blue balance.
BODYFIRMWARE | Body firmware.
BRACKET | Exposure compensation value.
BRIGHTNESSVALUE | Brightness value.
BWMODE | Black and white mode.
CAMERAID | Camera ID.
CAMERAMODEIFD | Camera model IFD.
COLORCONTROL | Color control.
COLORMATRIX | Color matrix.
CONTRAST | Contrast setting.
CORINGFILTER | Coring filter.
DATADUMP | Data dump.
DEBUGIFD | Debug IFD.
DIAGNOSTICINFO | Diagnostic info.
DIAGNOSTICINFO2 | Diagnostic info2.
DIAGNOSTICINFO3 | Diagnostic info3.
DIGITALZOOM | Digital zoom ratio.
FIRMWARE | Firmware value.
FIRMWAREVERSION | Firmware version.
FLASHBIAS | Flash bias.
FLASHDEVICE | Flash device.
FLASHMODE | Flash mode.
FOCALPLANEDIAGONAL | Focal plane diagonal.
FOCUSDISTANCE | Focus distance.
FOCUSMODE | Focus mode.
FOCUSRANGE | Focus range.
FORMAT | EXIF_MakerNote_Olympus metadata format identifier.
HARDWAREIFD | Hardware IFD.
IMAGEHEIGHT | Image height.
IMAGEPROCESSORIFD | Imageprocessor IFD.
IMAGEWIDTH | Image width.
LENSTEMPERATURE | Lens temperature.
LIGHTCONDITION | Light condition.
MACROFOCUS | Macro focus step count.
MAKRO | Macro mode.
MCS | MCS value.
ONETOUCHWB | One touch white balance.
PICTUREINFO | Picture info.
PRECAPTUREFRAMES | Pre capture frames.
PRINTMACHING | Print maching.
QUALITY | Image quality setting.
REDBALANCE | Red balance.
SCENEMODE | Scene mode.
SENSITIVEVALUE | Sensitive value.
SENSORTEMPERATURE | Sensor temperature.
SERIALNUMBER | Serial number.
SHARPNESS | Sharpness factor.
SHARPNESSFACTOR | Sharpness factor.
SPECIALMODE | Special mode.
THUMBNAILFILE | Thumbnail file.
TIMEVALUE | Time value.
VALIDBITS | Valid bits.
WBBLUEVALUE | WB blue value.
WBBRACKET | WB bracket.
WHITEBALANCE | White balance.
WHITEBOARD | White board.
ZOOM | Zoom step count.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteOlympusTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNotePentaxTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNotePentaxTagIDs Enumeration

Glossary Item Box

Lists all Pentax EXIF MakerNote tag identifiers.

Members

Member | Description
CAPTUREMODE | Capture mode.
COLOUR | Colour information.
CONTRAST | Pentax MakerNote ï¿½ontrast.
DAYLIGHTSAVINGS | Daylight savings.
DIGITALZOOM | Digital zoom.
FLASHMODE | Flash mode.
FOCUSMODE | Focus mode.
FORMAT | EXIF_MakerNote_Pentax metadata format identifier.
ISOSPEED | ISO speed.
PRINTIMAGEMMATCHINGINFO | Print image matching info.
QUALITYLEVEL | Quality level.
SATURATION | Pentax MakerNote ï¿½aturation.
SHARPNESS | Pentax MakerNote ï¿½harpness.
TIMEZONE | Time zone.
WHITEBALANCE | White balance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNotePentaxTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteTagIDs Enumeration

Glossary Item Box

Lists all general EXIF MakerNote tag identifiers.

Members

Member | Description
BINARY | Binary data.
DATA_IFD | Makernote data IFD.
FORMAT | EXIF_Maker note metadata format identifier.
PREFIX | Makernote prefix.
TYPE | Makernote type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFMakerNoteType Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFMakerNoteType Enumeration

Glossary Item Box

Lists all EXIF MakerNote types.

Members

Member | Description
IFD | TIFF IFD. Makernote is a valid TIF IFD.
IFD_PREFIXED | Prefixed TIFF IFD. Same as IFD, but with a short prefix before the IFD. The prefix is also preserved, so the whole Makernote is preserved when writing to a file.
IFD_PREFIXED_OFFSET_II | Makernote starts with a prefix, then goes offset to the IFD, then IFD itself. Makernote IFD uses Intel byte ordering (II), even though the whole file uses Motorola ordering.
IG_MAKERNOTE_TYPES_MAX | Keep the number identical to the last makernote type.
TIF_HEADER_PREFIXED | Makernote starts with a prefix, then goes TIF image header, which points to an IFD.
UNKNOWN | Unknown. This is the default type. This type means that ImageGear can't decect Makernote as any other type. Preserving such makernote and saving it with the file, most likely, does not make any sence, because IFD offsets will be corrupted.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFMakerNoteType

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearEXIFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearEXIFTagIDs Enumeration

Glossary Item Box

Lists all EXIF tag identifiers.

Members

Member | Description
APERTUREVALUE | Aperture value.
BRIGHTNESSVALUE | Brightness value.
CFAPATTERN | CFA pattern.
COLORSPACE | Color space.
COMPONENTCONFIGURATION | Components configuration.
COMPRESSEDBITSPERPIXEL | Compressed bits per pixel.
CONTRAST | Indicates the direction of contrast processing applied by the camera when the image was shot.
CUSTOMRENDERED | Custom rendered.
DATETIMEDIGITIZED | Date time digitized.
DATETIMEORIGINAL | Date time original.
DEVICESETTINGDESCRIPTION | Device setting description.
DIGITALZOOMRATIO | Digital zoom ratio.
EXPOSUREBIASVALUE | Exposure bias value.
EXPOSUREINDEX | Exposure index.
EXPOSUREMODE | Exposure mode.
EXPOSUREPROGRAM | Exposure program.
EXPOSURETIME | Exposure time.
FILESOURCE | File source.
FLASH | Indicates weither or not flash used when the image was captured.
FLASHENERGY | Flash energy.
FLASHPIXVERSION | Flash pix version.
FNUMBER | F number value.
FOCALLENGTH | Focal length.
FOCALLENGTHIN35MMFILM | Focal length in 35mm film.
FOCALPLANERESOLUTIONUNIT | Focal plane resolution unit.
FOCALPLANEXRESOLUTION | Focal plane X resolution.
FOCALPLANEYRESOLUTION | Focal plane Y resolution.
FORMAT | EXIF metadata format identifier.
GAINCONTROL | Gain control.
HEADER | This enumeration value is for internal use only.
IMAGEUNIQUEID | Indicates an identifier assigned uniquely to each image.
INTEROPERABILITYIFD | Interoperability IFD pointer.
ISOSPEEDRATING | ISO speed ratings.
LIGHTSOURCE | Light source.
MAKERNOTE | Maker note.
MAXAPERTUREVALUE | Max aperture value.
METERINGMODE | Metering mode.
OECF | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524.
PIXELXDIMENSION | Pixel X dimension.
PIXELYDIMENSION | Pixel Y dimension.
RELATEDSOUNDFILE | Related sound file.
SATURATION | Indicates the direction of saturation processing applied by the camera when the image was shot.
SCENECAPTURETYPE | Scene capture type.
SCENETYPE | Scene type.
SENSINGMETHOD | Sensing method.
SHARPNESS | Indicates the direction of sharpness processing applied by the camera when the image was shot.
SHUTTERSPEEDVALUE | Shutter speed value.
SPATIALFREQUENCYRESPONSE | Spatial frequency response.
SPECTRALSENSITIVITY | Spectral sensitivity.
SUBJECTAREA | Subject area.
SUBJECTDISTANCE | Subject distance.
SUBJECTDISTANCERANGE | Subject distance range.
SUBJECTLOCATION | Subject location.
SUBSECTIME | Sub sec time.
SUBSECTIMEDIGITIZED | Sub sec time digitized.
SUBSECTIMEORIGINAL | Sub sec time original.
USERCOMMENT | User comment.
VERSION | Exif version.
WHITEBALANCE | White balance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearEXIFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearFillOrder Enumeration
com.accusoft.imagegear.formats Package : ImGearFillOrder Enumeration

Glossary Item Box

Specifies fill order that is used for saving some file formats (e.g., TIFF, etc.).

This enumeration specifies fill order that is used for saving some file formats, like TIFF, CCITT Group3/Group4, etc., or for loading raw CCITT data.

Members

Member | Description
LSB | Least significant bit is stored first.
MSB | Most significant bit is stored first.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearFillOrder

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearFormats Enumeration
com.accusoft.imagegear.formats Package : ImGearFormats Enumeration

Glossary Item Box

Lists all ImageGear supported file formats.

Members

Member | Description
BMP | Standard Windows format including OS/2 bitmap format.
BTR | Brooktrout FAX format.
CAL | CALS raster, Type I.
CGM | Computer CSGraphics Metafile.
CLP | Windows Clipboard format for raster images.
CR2 | Canon CR2 digital camera RAW format.
CRW | Canon CRW digital camera RAW format.
CUR | Windows mouse cursor format.
CUT | Dr. Halo CUT format.
DCRAW | Common identifier for Digital Camera RAW formats.
DCX | Intel multi-page FAX format.
DGN | MicroStation Drawing (Drawing format used by MicroStation construction design software).
DICOM | DICOM file format. Public standard that provides a flexible and expandable means for storing, sharing, and transporting digital medical images.
DNG | Digital Negative file format.
DWF | Autodesk Design Web Format.
DWG | DWG (AutoDesk AutoCAD) format.
DXF | DXF (AutoDesk AutoCAD) format.
GEM | GEM Paint Raster format.
GIF | Graphic Image format developed originally in accommodate the transmission of images via a modem; uses LZW compression algorithm.
HDPHOTO | HD Photo (Windows Media Photo) format.
HeaderlessRaw | Headerless digital camera RAW format.
HPGL | Hewlett-Packard CSGraphics Language format.
ICA | IBM Image Object Content Architecture.
ICO | Windows ICON format.
IFF | Electronic Arts Interchange File Format.
Imacon | Imacon digital camera RAW format.
IMG | Xerox raster format.
IMR | IMRS-Raster image format.
IMT | IMNET format.
JP2 | JPEG 2000 file format.
JPG | JPEG File Interchange Format.
JPX | JPX file format (JPEG2000 extensions).
KDC | Kodak digital camera RAW format.
KFX | Kofax format.
LeicaRaw | Leica/Panasonic digital camera RAW format.
LV | LaserView (LaserData) format.
MEF | Mamiya digital camera RAW format.
MJ2 | Motion JPEG2000 file format.
MODCA | IBM Mixed Object Document Content Architecture format.
MOS | Leaf digital camera RAW format.
MRW | Konica-Minolta digital camera RAW format.
MSP | Microsoft Paint format.
NCR | NCR format.
NEF | Nikon digital camera RAW format.
ORF | Olympus digital camera RAW format.
PBM | Portable BitMap (UNIX graphic file format).
PCD | Kodak format for high resolution photographs.
PCX | PC Paintbrush format.
PDF | Adobe Portable Document Format.
PEF | Pentax/Samsung digital camera RAW format.
PNG | Portable Network CSGraphics.
PS | PostScript language files.
PSB | Adobe Photoshop Big file format.
PSD | Adobe Photoshop file format.
PTOCA | IBM Presentation Text Object Content Architecture format for IBM's AFP printer architecture.
RAF | FujiFilm digital camera RAW format.
RAS | SUN raster format.
RAW | Headerless RAW format.
SCI | SCITEX file format. It is used for electronic pre-press and visual communications systems, is a part of the HandShake Foreign File Transfer Protocol, a standard for defining storage formats and data interchange protocols.
SGI | Silicon CSGraphics raster format.
SonyRaw | Sony digital camera RAW format.
SVG | Scalable Vector CSGraphics format.
TGA | Targa file format.
TIF | Tagged Image File Format.
U3D | Universal 3D format.
UNKNOWN | Unknown format.
WBMP | Wireless BMP format.
WPG | WordPerfect Graphic Format.
XBM | X Window Bitmap format.
XPM | X Window Pixmap format.
XPS | XML Paper Specification format.
XWD | X Window Dump format.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearFormats

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearGEMTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearGEMTagIDs Enumeration

Glossary Item Box

Lists all GEM tag identifiers.

Members

Member | Description
FORMAT | GEM metadata format identifier.
HEADERSIZE | Header size.
HEIGHT | Image height.
PATTERNLENGTH | Pattern length.
PLANES | Color map ID.
VERSION | Version valie.
WIDTH | Image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearGEMTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearGIFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearGIFTagIDs Enumeration

Glossary Item Box

Lists all GIF tag identifiers.

Members

Member | Description
AFTER_IMAGE_EXT | After image extensions.
APP_AUTH_CODE | Application authentication code.
APP_DATA | Application data.
APP_EXTENSION | Application extension.
APP_IDENTIFIER | Application identifier.
COMMENT_EXTENSION | Comment extension.
FORMAT | GIF metadata format identifier.
GCE_DELAY_TIME | Delay time.
GCE_FIELDS | Graphic control extension packed fields.
GCE_FLD_DISPOSAL_METHOD | Disposal method.
GCE_FLD_TRANSPARENT | Transparent color flag.
GCE_FLD_USER_INPUT | User input flag.
GCE_TRANSPARENT_COLOR | Transparent color index.
GLOBAL_COLOR_TABLE | Global color table.
GRAPHIC_CONTROL_EXT | Graphic control extension.
HDR_SIGNATURE | Identifies the GIF Data Stream.
HDR_VERSION | Version number.
HEADER | GIF header.
IMAGE_DESCRIPTOR | Image descriptor.
IMG_FIELDS | Image descriptor packed field.
IMG_FLD_INTERLACE | Interlace flag.
IMG_FLD_LOC_COLOR_TABLE | Local color table flag.
IMG_FLD_SIZE | Local color table size.
IMG_FLD_SORT | Sort flag.
IMG_IMAGE_HEIGHT | Image height.
IMG_IMAGE_WIDTH | Image width.
IMG_LEFT_POSITION | Image left position.
IMG_TOP_POSITION | Image top position.
LOCAL_COLOR_TABLE | Local color table.
PLAIN_TEXT_EXTENSION | Plain text extension.
SCR_ASPECT_RATIO | Pixel aspect ratio.
SCR_BACKGROUND_COLOR | Background color index.
SCR_FIELDS | Logical screen packed fields.
SCR_FLD_COLOR_RES | Color resolution.
SCR_FLD_GL_COLOR_TABLE | Global color table flag.
SCR_FLD_SIZE | Global color table size.
SCR_FLD_SORT | Sort flag.
SCR_SCREEN_HEIGHT | Logical screen height.
SCR_SCREEN_WIDTH | Logical screen width.
SCREEN_DESCRIPTOR | Logical screen descriptor.
TXT_BACKGROUND_COLOR | Text background color index.
TXT_CELL_HEIGHT | Character cell height.
TXT_CELL_WIDTH | Character cell width.
TXT_FOREGROUND_COLOR | Text foreground color index.
TXT_GRID_HEIGHT | Text grid height.
TXT_GRID_LEFT | Text grid left position.
TXT_GRID_TOP | Text grid top position.
TXT_GRID_WIDTH | Text grid width.
TXT_TEXT_DATA | Plain text data.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearGIFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearHDPhotoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearHDPhotoTagIDs Enumeration

Glossary Item Box

Lists all HD Photo tag identifiers.

Members

Member | Description
ALPHABYTECOUNT | Alpha byte count.
ALPHADATADISCARD | Alpha data discard.
ALPHAOFFSET | Alpha offset.
BIMIPTC | IPTC metadata.
BIMIPTCPSTRING | IPTC metadata.
BIMIPTCSUB | IPTC subtree.
FORMAT | HD Photo metadata format identifier.
HEIGHTRES | Height resolution.
IMAGEBYTECOUNT | Image byte count.
IMAGEDATADISCARD | Image data discard.
IMAGEOFFSET | Image offset.
IMAGETYPE | Image type.
IMAGEWIDTH | Image width.
IMAGHEIGHT | Image height.
PIXELFORMAT | Pixel format.
RATING | Rating info.
SIMPLERATING | Simple rating.
TRANSFORMATION | Transformation to be applied when decoding the image to present the desired representation.
UNCOMPRESSED | Specifies that the image data is uncompressed.
WIDHTRES | Width resolution.
XMP | XMP metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearHDPhotoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearICATagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearICATagIDs Enumeration

Glossary Item Box

Lists all ICA tag identifiers.

This enumeration lists all IOCA tag identifiers.

Members

Member | Description
BASE | Size units value.
BITORDER | Bit order.
COMPRESSION | Image compression.
DEPTH | Image depth.
FILLORDER | Fill order.
FORMAT | IOCA metadata format identifier.
HEIGHT | Image height.
WIDTH | Image width.
XDPI | Horizontal image resolution.
YDPI | Vertical image resolution.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearICATagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearICOTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearICOTagIDs Enumeration

Glossary Item Box

Lists all ICO tag identifiers.

Members

Member | Description
COUNT | Images count in the file.
DOCUMENT_METADATA | Document metadata.
FORMAT | ICO metadata format identifier.
PAGE_METADATA | Page metadata.
TYPE | Resource type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearICOTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIFFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearIFFTagIDs Enumeration

Glossary Item Box

Lists all IFF tag identifiers.

Members

Member | Description
COMPRESSION | Image compression.
FORMAT | IFF metadata format identifier.
HIGH | Image height.
MASK | Mask info.
PAGE_H | Page height.
PAGE_W | Page width.
PLANES | Color map planes.
TRAN_ASPT | Tran aspt.
TRANSP_COLOR | Transp color.
VIEW_MODE | View mode.
WIDE | Image width.
X_ASPECT | X aspect resolution.
XORG | Image X origin.
Y_ASPECT | Y aspect resolution.
YORG | Image Y origin.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIFFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIMGTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearIMGTagIDs Enumeration

Glossary Item Box

Lists all IMG tag identifiers.

Members

Member | Description
FORMAT | IMG metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIMGTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIMTTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearIMTTagIDs Enumeration

Glossary Item Box

Lists all IMT tag identifiers.

Members

Member | Description
BITSWAP | Swap bits.
FMT | File format.
FORMAT | IMT metadata format identifier.
HEIGHT | Image height.
INVERT | Invert pixel values flag.
RESOLUTION | Image resolution.
SWAB | Swap byte.
TYPE | IMT file type.
WIDTH | Image Width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIMTTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCAppObjAttrTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCAppObjAttrTags Enumeration

Glossary Item Box

Lists IPTC Application Object Attributes.

Members

Member | Description
ANALYSIS | The object contains data and conclusions drawn by a journalist who has researched the story in depth.
ARCHIVE_MATERIAL | The object contains material distributed previously that has been selected from the originatorï¿½s archives.
BACKGROUND | The object provides some scene-setting and explanation for the event being reported.
CURRENT | Object content is about events taking place at the time of the report.
FEATURE | The object content is about a particular event or individual that may not be significant to current breaking news.
FORECAST | The object contains opinion as to the outcome of a future event.
HISTORY | The object content is based on previous rather than current events.
OBITUARY | The object contains a narrative about an individualï¿½s life and achievements for publication after his or her death.
OPINION | The object contains an editorial comment that reflects the views of the author.
POLLS_SURVEYS | The object contains numeric or other information produced as a result of questionnaires or interviews.
PROFILE | The object contains a description of the life or activity of a news subject (often a living individual).
RES_LISTINGS_TABLES | The object contains alphanumeric data suitable for presentation in tabular form.
SIDE_BAR_SUPPORTING_INFO | The object contains a related story that provides additional insight into the news event being reported.
SUMMARY | The object is a collection of synopses on news items (generally unrelated).
TRANSCRIPT_VERBATIM | The object contains a word-for-word report of a discussion or briefing without significant journalistic intervention.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCAppObjAttrTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCAppObjTypeTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCAppObjTypeTags Enumeration

Glossary Item Box

Lists IPTC Application Object Types.

Members

Member | Description
ADVISORY | Object type is Advisory (content provider messages, generally not published).
DATA | Object type is Data (intended for tables such as statistics or lists, as opposed to narrative text).
NEWS | Object type is News (default).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCAppObjTypeTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord1EnvDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord1EnvDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 1 (Envelope) DataSet tags.

Members

Member | Description
ARM_IDENTIFIER | ARM identifier.
ARM_VERSION | ARM version.
CODED_CHARACTER_SET | Coded character set.
DATE_SENT | Date sent.
DESTINATION | Destination information (additional routing information.
ENVELOPE_NUMBER | Envelope number.
ENVELOPE_PRIORITY | Envelope priority.
FILE_FORMAT | File format.
FILE_FORMAT_VERSION | File format version.
FORMAT | IPTC_EnvDataset metadata format identifier.
MODEL_VERSION | Model version.
PRODUCT_ID | Product ID.
SERVICE_IDENTIFIER | Service identifier.
TIME_SENT | Time sent.
UNO | Unique Name of Object.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord1EnvDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord2AppDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord2AppDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 2 (Application) DataSet tags.

Members

Member | Description
ACTION_ADVISED | Action advised.
AUDIO_DURATION | Audio duration.
AUDIO_OUTCUE | Audio outcue.
AUDIO_SAMPLING_RATE | Audio sampling rate.
AUDIO_SAMPLING_RESOLUTION | Audio sampling resolution.
AUDIO_TYPE | Audio type.
BY_LINE | By-line information.
BY_LINE_TITLE | By-line title.
CAPTION_ABSTRACT | Caption / Abstract.
CATEGORY | Category that identifies the subject of the object in the opinion of the image provider.
CITY | City information.
CONTACT | Contact information.
CONTENT_LOCATION_CODE | Content location code.
CONTENT_LOCATION_NAME | Content location name.
COPYRIGHT_NOTICE | Copyright notice.
COUNTRY_PRIMARY_LOC_CODE | Country/Primary location code.
COUNTRY_PRIMARY_LOC_NAME | Country/Primary location name.
CREDIT | Credit information.
DATE_CREATED | Date created.
DIGITAL_CREATION_DATE | Digital creation date.
DIGITAL_CREATION_TIME | Digital creation time.
EDIT_STATUS | Edit status.
EDITORIAL_UPDATE | Editorial update.
EXPIRATION_DATE | Expiration date.
EXPIRATION_TIME | Expiration time.
FIXTURE_IDENTIFIER | Fixture identifier.
FORMAT | IPTC_AppDataset metadata format identifier.
HEADLINE | Synopsis of the subject matter.
IMAGE_ORIENTATION | Image orientation.
IMAGE_TYPE | Image type.
KEYWORDS | Keywords to description.
LANGUAGE_IDENTIFIER | Language identifier.
OBJ_ATTRIBUTE_REF | Object attribute reference.
OBJ_DATA_PREV_DATA | Object data preview data.
OBJ_DATA_PREV_FILE_FORMAT | Object data preview file format.
OBJ_DATA_PREV_FILE_FORMAT_VER | Object data preview file format version.
OBJ_NAME | Object name.
OBJ_TYPE_REF | Object type reference.
OBJECT_CYCLE | Object cycle.
ORIGINAL_TRANSM_REF | Original transmission reference.
ORIGINATING_PROGRAM | Originating program.
PROGRAM_VERSION | Program version.
PROVINCE_STATE | Province / State.
RASTERIZED_CAPTION | Rasterized caption.
RECORD_VERSION | Record version.
REFERENCE_DATE | Reference date.
REFERENCE_NUMBER | Reference number.
REFERENCE_SERVICE | Reference service.
RELEASE_DATE | Release date.
RELEASE_TIME | Release time.
SOURCE | Source that identifies the original owner / creator.
SPECIAL_INSTRUCTIONS | Special instructions.
SUBJECT_REFERENCE | Subject reference.
SUBLOCATION | Sub-location information.
SUPPLEMENTAL_CATEGORY | Supplemental category.
TIME_CREATED | Time created.
URGENCY | Editorial urgency.
WRITER_EDITOR | Writer / Editor.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord2AppDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord3PhotoDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord3PhotoDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 3 (Digital Newsphoto Parameter) DataSet tags.

Members

Member | Description
BITS_PER_COMPONENT | Bits per component.
COLOUR_MATRIX_TABLE | Colour calibration matrix table.
COLOUR_PALETTE | Colour palette.
COLOUR_REPRESENTATION | Colour representation.
COLOUR_SEQUENCE | Colour sequence.
DATA_COMPRESSION_METHOD | Data compression method.
END_POINTS | End points.
EXCURSION_TOLERANCE | Excursion tolerance.
FORMAT | IPTC_PhotoDataset metadata format identifier.
GAMMA_COMPENSATED_VALUE | Gamma compensated value.
ICC_INPUT_COLOUR_PROFILE | ICC input colour profile.
IMAGE_ROTATION | Image rotation.
INTERCHANGE_COLOUR_SPACE | Interchange colour space.
LOOKUP_TABLE | Lookup table.
MAXIMUM_DENSITY_RANGE | Maximum density range.
NUMBER_OF_BITS_PER_SAMPLE | Number of bits per sample.
NUMBER_OF_INDEX_ENTRIES | Number of index entries.
NUMBER_OF_LINE | Number of line.
PICTURE_NUMBER | Picture number.
PIXEL_SIZE_PERP_DIR | Pixel size perpendicular to scanning direction.
PIXEL_SIZE_SCAN_DIR | Pixel size in scanning direction.
PIXELS_PER_LINE | Pixels per line.
QUANTISATION_METHOD | Quantisation method.
RECORD_VERSION | Record version.
SAMPLING_STRUCTURE | Sampling structure.
SCANNING_DIRECTION | Scanning direction.
SUPPLEMENT_TYPE | Supplement type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord3PhotoDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord7PreObjDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord7PreObjDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 7 (Pre-Object) DataSet tags.

Members

Member | Description
FORMAT | IPTC_PreObjDataset metadata format identifier.
MAX_OBJ_DATA_SIZE | Maximum object data size.
MAX_SUBFILE_SIZE | Max subfile size.
OBJ_DATA_SIZE_ANN | Object data size announced.
SIZE_MODE | Size mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord7PreObjDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord8ObjDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord8ObjDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 8 (Object) DataSet tags.

Members

Member | Description
FORMAT | IPTC_ObjDataset metadata format identifier.
SUBFILE | IPTC ObjectData subfile.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord8ObjDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecord9PostObjDatasetTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecord9PostObjDatasetTags Enumeration

Glossary Item Box

Lists all IPTC Record 9 (Post-Object) DataSet tags.

Members

Member | Description
CONFIRMED_OBJ_DATA_SIZE | Confirmed object data size.
FORMAT | IPTC_PostObjDataset metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecord9PostObjDatasetTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCRecordTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCRecordTags Enumeration

Glossary Item Box

Lists all IPTC Record tags.

Members

Member | Description
APPLICATION_RECORD | Application record.
DIG_NEWS_PHOTO_PAR_RECORD | Digital Newsphoto Pararameter record.
ENVELOPE_RECORD | Envelope record.
FORMAT | IPTC_Record metadata format identifier.
OBJECT_RECORD | Object record.
POSTOBJ_DESC_RECORD | Post-object record.
PREOBJ_DESC_RECORD | Pre-object record.
UNDEFINED | Undefined record.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCRecordTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearIPTCTags Enumeration
com.accusoft.imagegear.formats Package : ImGearIPTCTags Enumeration

Glossary Item Box

Lists all general IPTC tags.

Members

Member | Description
IPTC_FORMAT | IPTC metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearIPTCTags

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearJPEGTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearJPEGTagIDs Enumeration

Glossary Item Box

Lists all JPEG tag identifiers.

Members

Member | Description
APP1 | Application marker - first.
APP10 | Application marker - 10.
APP11 | Application marker - 11.
APP12 | Application marker - 12.
APP13 | Application marker - 13.
APP14 | Application marker - 14.
APP15 | Application marker - last.
APP2 | Application marker - 2.
APP3 | Application marker - 3.
APP4 | Application marker - 4.
APP5 | Application marker - 5.
APP6 | Application marker - 6.
APP7 | Application marker - 7.
APP8 | Application marker - 8.
APP9 | Application marker - 9.
BINARY_DATA | Segment binary data.
CHUNKNUMBER | Chunk number.
COM | Comment value.
COMMENT | Comment value.
DAC | DAC - Define Arithmetic coding Conditioning.
DHP | Define hierarchical progression.
DHT | Huffman tables.
DNL | Define number of lines.
DQT | Quantization tables.
DRI | Restart Interval.
EOI | End of Image.
EXIF_ID | EXIF ID tag.
EXP | Expand reference image.
FORMAT | JPEG metadata format identifier.
FRAME_COMPONENT_HV_SAMPLING | SOF Component HV Sampling.
FRAME_COMPONENT_ID | SOF Component ID.
FRAME_COMPONENT_QUANT_SELECTOR | SOF Component quantization table selector.
FRAME_COMPONENT_SPEC | SOF Component specification.
FRAME_LINES | SOF Lines.
FRAME_NUMBER_OF_COMPONENTS | SOF Number of components.
FRAME_PRECISION | SOF Precision.
FRAME_SAMPLES_PER_LINE | SOF Samples Per Line.
HUFFMAN_TABLE | Huffman table.
HUFFMAN_TABLE_DESCRIPTOR | Huffman table descriptor.
HUFFMAN_TABLE_LENGTHS | Huffman table lengths.
HUFFMAN_TABLE_VALUES | Huffman table values.
ICCPROFILEDATA | ICC Profile data.
IDENTIFIER | Segment identifier.
JFIF | Application marker - JFIF header (APP0).
JFIF_ID | JFIF ID value.
JFIF_THUMB_HEIGHT | JFIF thumbnail height.
JFIF_THUMB_WIDTH | JFIF thumbnail width.
JFIF_UNITS | JFIF resolution unit.
JFIF_VERSION | JFIF version.
JFIF_X_RES | JFIF X resolution.
JFIF_Y_RES | JFIF Y resolution.
JPG | Reserved for JPEG extensions.
PHOTOSHOP_ID | Photoshop ID.
PHOTOSHOP_RESOURCES | Photoshop Resources.
QUANT_TABLE | Quantization table.
QUANT_TABLE_DESCRIPTOR | Quantization table descriptor.
QUANT_TABLE_ELEMENTS | Quantization table elements.
RESTART_INTERVAL | Restart interval.
RST0 | Restart marker.
RST1 | Restart marker.
RST2 | Restart marker.
RST3 | Restart marker.
RST4 | Restart marker.
RST5 | Restart marker.
RST6 | Restart marker.
RST7 | Restart marker.
SCAN_AH_AL | Scan AH, AL.
SCAN_COMPONENT | Scan component.
SCAN_COMPONENT_NUMBER | Scan component number.
SCAN_DC_AC | Scan AC, DC.
SCAN_SELECTOR | Scan selector.
SCAN_SP_END | Scan spectral end.
SCAN_SP_START | Scan spectral start.
SOF0 | Baseline DCT.
SOF1 | Extended sequential DCT.
SOF10 | Progressive DCT - arithmetic encoding.
SOF11 | Lossless sequential - arithmetic encoding.
SOF13 | Differential sequential DCT - arithmetic encoding.
SOF14 | Differential progressive DCT - arithmetic encoding.
SOF15 | Differential lossless - arithmetic encoding.
SOF2 | Progressive DCT.
SOF3 | Lossless (sequential).
SOF5 | Differential sequential DCT.
SOF6 | Differential progressive DCT.
SOF7 | Differential lossless.
SOF9 | Extended sequential DCT - arithmetic encoding.
SOI | Start of Image.
SOS | Start of Segment.
TEM | TEM marker.
XMP | XML packet containing XMP metadata.
XMP_IDENTIFIER | XMP identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearJPEGTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearKFXTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearKFXTagIDs Enumeration

Glossary Item Box

Lists all KFX tag identifiers.

Members

Member | Description
BIT_SEX | Bit sex info.
BITS_PER_PIX | Bits per pixel.
COLOR | Color info.
COM_LEN | Com length.
COM_OFFSET | Com offset.
DATA_LEN | Data length.
DATA_OFFSET | Data offset.
DATE_ACC | Access date.
DATE_CRT | Creation date.
DATE_MOD | Modification date.
FORMAT | KFX metadata format identifier.
HDR_SIZE | Header size.
HDR_VER | Header version.
ID | Image identifier.
IDX_LEN | Index length.
IDX_OFFSET | Index offset.
IMAGE_ID | Image ID value.
KFX_FORMAT | KFX format.
LENGTH | Image length.
PAPER_SIZE | Paper size.
PLANES | Planes info.
USER_LEN | User length.
USER_OFFSET | User Offset.
WIDTH | Image width.
XRES | Horizontal image resolution.
YRES | Vertical image resolution.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearKFXTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearLVTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearLVTagIDs Enumeration

Glossary Item Box

Lists all LV tag identifiers.

Members

Member | Description
BITSPIX | Bits per pixel.
BLOCKLENGTH | Block length.
BYTEFORMAT | Byte format.
COMPRESSION | Image compression.
COMPVERSION | Comp version.
DISPLAYMETHOD | Display method.
FORMAT | LV metadata format identifier.
LINES | Number of lines.
NBLOCKTYPE | N Block type.
PIXELS | Number of columns.
TEXT | Text info.
XAXIS | X axis info.
XORIGIN | Image X origin.
XSEPERATION | X separation.
YAXIS | Y axis info.
YORIGIN | Image Y origin.
YSEPERATION | Y separation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearLVTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusApplicationModeIFD2TagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusApplicationModeIFD2TagIDs Enumeration

Glossary Item Box

Lists all Olympus application mode IFD 2 MakerNote types.

Members

Member | Description
FORMAT | Olympus application mode IFD 2 MakerNote metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusApplicationModeIFD2TagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusApplicationModeIFDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusApplicationModeIFDTagIDs Enumeration

Glossary Item Box

Lists all Olympus application mode IFD MakerNote types.

Members

Member | Description
FORMAT | Olympus application mode IFD MakerNote metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusApplicationModeIFDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusCameraModeIFDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusCameraModeIFDTagIDs Enumeration

Glossary Item Box

Lists all Olympus camera mode IFD MakerNote types.

Members

Member | Description
FORMAT | Olympus camera mode IFD MakerNote metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusCameraModeIFDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusCSerieSettingsTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusCSerieSettingsTagIDs Enumeration

Glossary Item Box

Lists all Olympus C-models serie settings IFD MakerNote types.

Members

Member | Description
FORMAT | Olympus C-models serie settings IFD MakerNote metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusCSerieSettingsTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusDebugIFDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusDebugIFDTagIDs Enumeration

Glossary Item Box

Lists all Olympus debug IFD MakerNote types.

Members

Member | Description
FORMAT | Olympus debug IFD MakerNote metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusDebugIFDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusHardwareIFDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusHardwareIFDTagIDs Enumeration

Glossary Item Box

Lists all Olympus hardware IFD MakerNote types.

Members

Member | Description
BODYFIRMWARE | Body firmware.
CAMERATYPE2 | Camera type.
EXTENSION | Hardware extension.
EXTENSIONfIRMWARE | Extension firmware.
EXTENSIONID | Extension ID.
EXTENSIONSERIALNUMBER | Extension serial number.
FLASHFIRMWARE | Flash firmware.
FLASHMODEL | Flash model.
FLASHSERIALNUMBER | Flash serial number.
FLASHTYPE | Flash type.
FOCUSPLANEDIAGONAL2 | Focus plane diagonal.
FORMAT | Olympus hardware IFD MakerNote metadata format identifier.
HARDWAREIFDVERSION | Hardware IFD version.
LENS | Lens setting.
LENSfEATURES | Lens features.
LENSFIRMWARE | Lens firmware.
LENSID | Lens ID value.
LENSMAXAPERTUREATCURRENTFOCAL | Lens max aperture at current focal.
LENSSERIALNUMBER | Lens serial number.
LENSTELEAPERTURE | Lens tele aperture.
LENSTELEFOCALlENGTH | Lens tele focal length.
LENSWIDEAPERTURE | Lens wide aperture.
LENSWIDEFOCALlENGTH | Lens wide focal length.
MCS | MCS setting.
SERIALNUMBER | Serial number.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusHardwareIFDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMakerNoteOlympusImageProcessorTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMakerNoteOlympusImageProcessorTagIDs Enumeration

Glossary Item Box

Lists all Olympus image processor IFD MakerNote types.

Members

Member | Description
BLACKLEVEL2 | Black level 2.
CHROMASUPPLESS_5_0601 | Chroma suppless 5_0601.
CHROMASUPPLESS_5_0602 | Chroma suppless 5_0602.
CHROMASUPPLESS_5_0603 | Chroma suppless 5_0603.
CHROMASUPPLESS_5_0604 | Chroma suppless 5_0604.
COLORMATRICES | Color Matrices.
COLORMATRICES_ADOBERGB1 | Color Matrices Adobe RGB.
COLORMATRICES_ADOBERGB2 | Color Matrices Adobe RGB.
COLORMATRICES_ADOBERGB3 | Color Matrices Adobe RGB.
COLORMATRICES_PROPHOTORGB1 | Color Matrices ProPhoto RGB.
COLORMATRICES_PROPHOTORGB2 | Color Matrices ProPhoto RGB.
COLORMATRICES_PROPHOTORGB3 | Color Matrices ProPhoto RGB.
COLORMATRICES_sRGB1 | Color Matrices sRGB.
COLORMATRICES_sRGB2 | Color Matrices sRGB.
COLORMATRICES_sRGB3 | Color Matrices sRGB.
COLORMATRICESADOBERGB0 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB1 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB10 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB11 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB12 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB2 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB3 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB4 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB5 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB6 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB7 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB8 | Color Matrice Adobe RGB.
COLORMATRICESADOBERGB9 | Color Matrice Adobe RGB.
COLORMATRICESPROPHOTORGB0 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB1 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB10 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB11 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB12 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB2 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB3 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB4 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB5 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB6 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB7 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB8 | Color Matrice ProPhoto RGB.
COLORMATRICESPROPHOTORGB9 | Color Matrice ProPhoto RGB.
COLORMATRICESSRGB0 | Color Matrice sRGB.
COLORMATRICESSRGB1 | Color Matrice sRGB.
COLORMATRICESSRGB10 | Color Matrice sRGB.
COLORMATRICESSRGB11 | Color Matrice sRGB.
COLORMATRICESSRGB12 | Color Matrice sRGB.
COLORMATRICESSRGB2 | Color Matrice sRGB.
COLORMATRICESSRGB3 | Color Matrice sRGB.
COLORMATRICESSRGB4 | Color Matrice sRGB.
COLORMATRICESSRGB5 | Color Matrice sRGB.
COLORMATRICESSRGB6 | Color Matrice sRGB.
COLORMATRICESSRGB7 | Color Matrice sRGB.
COLORMATRICESSRGB8 | Color Matrice sRGB.
COLORMATRICESSRGB9 | Color Matrice sRGB.
COLORMATRIX_1 | Color matrix.
COLORMATRIX_2 | Color matrix.
COLORMATRIX2 | Color Matrix 2.
CORINGVALUES | Coring values.
EDITDISTORTIONCORRECTION | Edit distortion correction.
EDITNOISEREDUCTION | Edit noise reduction.
EDITSHADINGCOMPENSATION | Edit shading compensation.
ENHANCERVALUES | Enhancer values.
FACEAREA | Face area.
FACEDETECT | Face detect.
FINALHEIGHT | Final height.
FINALWIDTH | Final width.
FORMAT | Olympus image processor IFD MakerNote metadata format identifier.
GAINBASE | GainBase setting.
GREENBIAS3000K | Green bias 3000K.
GREENBIAS3300K | Green bias 3300K.
GREENBIAS3600K | Green bias 3600K.
GREENBIAS3900K | Green bias 3900K.
GREENBIAS4000K | Green bias 4000K.
GREENBIAS4300K | Green bias 4300K.
GREENBIAS4500K | Green bias 4500K.
GREENBIAS4800K | Green bias 4800K.
GREENBIAS5300K | Green bias 5300K.
GREENBIAS6000K | Green bias 6000K.
GREENBIAS6600K | Green bias 6600K.
GREENBIAS7500K | Green bias 7500K.
GREENBIASASSHOT | Green bias as shot.
IMAGEPROCESSORIFDVERSION | Image processor IFD version.
LENSDISTORTIONPARAMS | Lens distortion params.
LENSSHADINGPARAMS | Lens shading params.
REDBLUEBIAS3000K | Red blue bias 3000K.
REDBLUEBIAS3300K | Red blue bias 3300K.
REDBLUEBIAS3600K | Red blue bias 3600K.
REDBLUEBIAS3900K | Red blue bias 3900K.
REDBLUEBIAS4000K | Red blue bias 4000K.
REDBLUEBIAS4300K | Red blue bias 4300K.
REDBLUEBIAS4500K | Red blue bias 4500K.
REDBLUEBIAS4800K | Red blue bias 4800K.
REDBLUEBIAS5300K | Red blue bias 5300K.
REDBLUEBIAS6000K | Red blue bias 6000K.
REDBLUEBIAS6600K | Red blue bias 6600K.
REDBLUEBIAS7500K | Red blue bias 7500K.
REDBLUEBIASASSHOT | Red blue bias as shot.
REDBLUEBIASCWB1 | Red blue bias CWB1.
REDBLUEBIASCWB2 | Red blue bias CWB2.
REDBLUEBIASCWB3 | Red blue bias CWB3.
REDBLUEBIASCWB4 | Red blue bias CWB4.
STARTOFFSETX | Start offset X.
STARTOFFSETY | Start offset Y.
VALIDBitsPerPixel2 | Valid bits per pixel 2.
VALUEOfCORING2 | Value of coring 2.
VALUEOfENHANCER2 | Value of enhancer 2.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMakerNoteOlympusImageProcessorTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMetadataFormats Enumeration
com.accusoft.imagegear.formats Package : ImGearMetadataFormats Enumeration

Glossary Item Box

Lists all ImageGear supported metadata formats.

This enumeration lists all formats that are used for storing file format metadata. Most of the members of this enum correspond to members of ImGearFormats. However, some file formats allow storing complex metadata, or metadata structures of various types. ImGearMetadataFormats enum has special members for such metadata structures.

For example, a TIFF image can have metadata of ImGearMetadataFormats.TIF, which in turn can have a subtree with metadata of type ImGearMetadataFormats.EXIF

Members

Member | Description
BMP | BMP metadata.
BTR | BTR metadata.
CAL | CALS metadata.
CIFF | CIFF metadata.
CIFFAFInfo | CIFF AF Info metadata.
CIFFCanonCameraSettings | CIFF Canon Camera Settings metadata.
CIFFFocalLength | CIFF Focal Length metadata.
CIFFImageInfo | CIFF Image Info metadata.
CIFFShotInfo | CIFF Shot Info metadata.
CLP | CLP metadata.
Common | Used internally.
CUT | CUT metadata.
DCRAW | Digital Camera RAW Formats metadata.
DCX | DCX metadata.
DICOM | DICOM metadata.
DisplayInfo | Photoshop Display info metadata.
EXIF | EXIF metadata. Can only exist as a subtree within EXIF or JPEG metadata.
EXIF_FPXR | EXIF FPX Ready metadata. Can only exist as a subtree within EXIF metadata.
EXIF_GPS | EXIF GPS metadata. Can only exist as a subtree within EXIF metadata.
EXIF_InterOp | EXIF Interoperability metadata. Can only exist as a subtree within EXIF metadata.
EXIF_MakerNote | EXIF Makernote metadata. Can only exist as a subtree within EXIF metadata.
EXIF_MakerNote_Fuji | Fujifilm EXIF Makernote metadata.
EXIF_MakerNote_NikonType1 | Nikon EXIF Makernote Type 1 metadata.
EXIF_MakerNote_NikonType2 | Nikon EXIF Makernote Type 2 metadata.
EXIF_MakerNote_Olympus | Olympus EXIF Makernote metadata.
EXIF_MakerNote_Pentax | Pentax EXIF Makernote metadata.
GEM | GEM metadata.
GIF | GIF metadata.
HDPHOTO | HDPhoto metadata.
ICA | ICA metadata.
ICO | ICO metadata.
IFF | IFF metadata.
IMG | IMG metadata.
IMR | IMR metadata.
IMT | IMT metadata.
IPTC | General IPTC metadata.
IPTC_AppDataset | IPTC Record 2 (Application) metadata.
IPTC_EnvDataset | IPTC Record 1 (Envelope) metadata.
IPTC_ObjDataset | IPTC Record 8 (Object) metadata.
IPTC_PhotoDataset | IPTC Record 3 (Digital Newsphoto Parameter) metadata.
IPTC_PostObjDataset | IPTC Record 9 (Post-Object) metadata.
IPTC_PreObjDataset | IPTC Record 7 (Pre-Object) metadata.
IPTC_Record | IPTC Record metadata.
JP2 | JPEG 2000 metadata.
JP2Codestream | JP2 Codestream Metadata.
JP2FileFormat | JP2 File Format Metadata.
JPG | JPEG metadata.
JPX | JPX metadata.
KFX | KFX metadata.
LV | LV metadata.
MakerNote_Olympus_ApplicationModeIFD | Olympus application mode IFD Makernote metadata.
MakerNote_Olympus_ApplicationModeIFD2 | Olympus application mode IFD 2 Makernote metadata.
MakerNote_Olympus_CameraModeIFD | Olympus camera mode IFD Makernote metadata.
MakerNote_Olympus_CSerieSettings | Olympus C-models serie settings IFD Makernote metadata.
MakerNote_Olympus_DebugIFD | Olympus debug IFD Makernote metadata.
MakerNote_Olympus_HardwareIFD | Olympus hardware IFD Makernote metadata.
MakerNote_Olympus_ImageProcessorIFD | Olympus image processor IFD Makernote metadata.
MJ2 | MJ2 metadata.
MODCA | MODCA metadata.
MSP | MSP metadata.
NCR | NCR metadata.
PBM | PBM metadata.
PCD | PhotoCD metadata.
PCX | PCX metadata.
PDF | PDF metadata.
PhotoshopAdditionalLayerInfo | Photoshop Additional LayerInfo metadata.
PhotoshopLayerInfo | Photoshop Layer Info metadata.
PhotoshopLayerMaskInfo | Photoshop Layer MaskI nfo metadata.
PhotoshopResourceGeneric | Photoshop Resource Generic metadata.
PhotoshopResources | Photoshop Resources metadata.
PhotoshopVersionInfo | Photoshop Version Info metadata.
PNG | PNG metadata.
PS | PostScript metadata.
PSB | PSB metadata.
PSD | PSD metadata.
PTOCA | PTOCA metadata.
RAS | RAS metadata.
RAWFileFormat | RAW File Format Metadata.
Rectangle | Photoshop Rectangle Info metadata.
ResolutionInfo | Photoshop Resolution Info metadata.
SCI | Scitex CT metadata.
SGI | SGI metadata.
TGA | TGA metadata.
ThumbnailInfo | Photoshop Thumbnail Info metadata.
TIF | TIFF metadata.
UNKNOWN | Unknown metadata.
WBMP | Wireless Bitmap metadata.
WPG | WPG metadata.
XBM | XBM metadata.
XMP | XMP Metadata.
XPM | XPM metadata.
XPS | XPS metadata.
XWD | XWD metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMetadataFormats

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMJ2TagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMJ2TagIDs Enumeration

Glossary Item Box

Lists all MJ2 tag identifiers.

Members

Member | Description
ALPHA_1 | Alpha channel 1 info.
ALPHA_2 | Alpha channel 2 info.
ALPHA_3 | Alpha channel 3 info.
ALPHA_CHANNELS | Alpha channels.
ALPHA_MAPPING | Alpha mapping.
COMPRESSION | Image compression.
FORMAT | MJ2 metadata format identifier.
IPR | Intellectual property rights.
TYPE | File format type.
XML | XML metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMJ2TagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearMSPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearMSPTagIDs Enumeration

Glossary Item Box

Lists all MSP tag identifiers.

Members

Member | Description
CHECKSUM | Checksum of previous 24 bytes.
FORMAT | MSP metadata format identifier.
HEIGHT | Height of the bitmap in pixels.
KEY1 | Magic number.
KEY2 | Magic number.
PADDING | Unused padding.
PRINTERHEIGHT | Height of the printer in pixels.
PRINTERWIDTH | Width of the printer in pixels.
WIDTH | Width of the bitmap in pixels.
XARBITMAP | X Aspect ratio of the bitmap.
XARPRINTER | X Aspect ratio of the printer.
XASPECTCORR | X aspect correction (unused).
YARBITMAP | Y Aspect ratio of the bitmap.
YARPRINTER | Y Aspect ratio of the printer.
YASPECTCORR | Y aspect correction (unused).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearMSPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearNativeDataTypes Enumeration
com.accusoft.imagegear.formats Package : ImGearNativeDataTypes Enumeration

Glossary Item Box

Specifies the data types that file formats use to store metadata values.

Members

Member | Description
BOOL | Boolean data type.
DOUBLE | 64-bit IEEE floating point number.
FLOAT | 32-bit IEEE floating point number.
INT16 | 16-bit signed integer.
INT32 | 32-bit signed integer.
INT64 | 64-bit signed integer.
INT8 | 8-bit signed integer.
RATIONAL_INT32 | A pair of 32-bit signed integers: Numerator and Denominator of a rational number.
RATIONAL_UINT32 | A pair of 32-bit unsigned integers: Numerator and Denominator of a rational number.
RAW_DATA | Byte array.
STRING | ASCII string.
UINT16 | 16-bit unsigned integer.
UINT32 | 32-bit unsigned integer.
UINT64 | 64-bit unsigned integer.
UINT8 | 8-bit unsigned integer.
UNKNOWN | Data type is unknown.
VARIABLE_UINT | This value is for internal use only.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearNativeDataTypes

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearNCRTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearNCRTagIDs Enumeration

Glossary Item Box

Lists all NCR tag identifiers.

Members

Member | Description
AUTH_MAC | Authentication Mac info.
AUTHENTICATION | Authentication info.
DATA_ENDIAN | Data endian.
DATA_FORMAT | Data format.
DATA_SIZE | Data size.
ENCRYPTION | Encryption info.
ERROR | Error info.
FILL_ORDER | Fill order.
FORMAT | NCR metadata format identifier.
GRANULARITY | Granularity info.
MAX_PIX_VALUE | Max pix value.
MIN_PIX_VALUE | Min pix value.
OPTIONS | Options info.
ORIENT | Orientation setting.
PMI | Invert pixels flag.
REAL_BPP | Real bpp value.
REAL_HEIGHT | Real height.
REAL_WIDTH | Real width.
RES_UNIT | Resolution unit.
STORE_BPP | Store bpp.
STORE_HEIGHT | Store height.
STORE_WIDTH | Store width.
X_RES | Horizontal resolution.
Y_RES | Vertical resolution.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearNCRTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPBMTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPBMTagIDs Enumeration

Glossary Item Box

Lists all PBM tag identifiers.

Members

Member | Description
BITCOUNT | Bit count.
COMMENTS | Comments string.
FORMAT | PBM metadata format identifier.
HEIGHT | Image height.
MAXCOLOR | Max color value.
TYPE | File type.
WIDTH | Image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPBMTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPCDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPCDTagIDs Enumeration

Glossary Item Box

Lists all PCD tag identifiers.

Members

Member | Description
FORMAT | PCD metadata format identifier.
IPI_COPYRIGHT_FILENAME | IPI copyright filename.
IPI_COPYRIGHT_STATUS | IPI copyright status.
IPI_EQUIPMENT_MANUFACTURER | IPI equipment manufacturer.
IPI_IMAGE_MAG_DESCRIPTION | IPI image mag description.
IPI_IMAGE_SCAN_TIME | IPI image scan time.
IPI_LAST_MODIFICATION_DATE | IPI last modification date.
IPI_MED_ORIGINAL_RECORDING | IPI med original recording.
IPI_PHOTONAME | IPI photoname.
IPI_PHOTONAME_CHAR_SET | IPI photoname char set.
IPI_PHOTONAME_ESC_SEQ | IPI photoname esc seq.
IPI_SBA_DATA | IPI SBA data.
IPI_SCANNER_FIRMWARE_DATE | IPI scanner firmware date.
IPI_SCANNER_FIRMWARE_LEVEL | IPI scanner firmware level.
IPI_SCANNER_PIXEL_SIZE | IPI scanner pixel size.
IPI_SCANNER_PRODUCT | IPI scanner product.
IPI_SCANNER_SERIAL_NUMBER | IPI scanner serial number.
IPI_SCANNER_VENDOR | IPI scanner vendor.
IPI_SIGNATURE | IPI signature.
IPI_SOFTWARE_RELEASE | IPI software release.
IPI_TYPE_ORIGINAL_RECORDING | IPI type original recording.
IPI_VERSION_NUMBER | IPI version number.
IPICA_BASE16_STOP_OFFSET | IPICA base16 stop offset.
IPICA_BASE4_STOP_OFFSET | IPICA base4 stop offset.
IPICA_IMAGE_PACK_PARAMS | IPICA image pack params.
IPICA_IP_INTERLEAVE_RATIO | IPICA IP interleave ratio.
IPICA_IPE_STOP_OFFSET | IPICA IPE stop offset.
IPICA_RESERVED | IPICA reserved.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPCDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPCXTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPCXTagIDs Enumeration

Glossary Item Box

Lists all PCX tag identifiers.

Members

Member | Description
BIT_PER_PLANE | Bit per plane.
BYTES_PER_LINE | Bytes per line.
ENCODE | Encoding type.
EXTRA | Extra data length.
FORMAT | PCX metadata format identifier.
H_RES | Horizontal Resolution of creating device.
MANUFACTURER | Manufacturer magic value.
NUM_OF_PLANES | Num of planes.
PALETTE_INFO | Palette info.
PALETTE_TABLE | Palette table.
SCANNER_H_RES | Scanner H_Res.
SCANNER_V_RES | Scanner V_Res.
V_RES | Vertical Resolution of creating device.
VERSION_INFO | Version info.
VIDEO_MODE | Video mode.
X1 | Left image coordinate to display.
X2 | RIght image coordinate to display.
Y1 | Top image coordinate to display.
Y2 | Bottom image coordinate to display.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPCXTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPDFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPDFTagIDs Enumeration

Glossary Item Box

Lists all PDF tag identifiers.

Members

Member | Description
FORMAT | PDF metadata format identifier.
XMP | XML packet containing XMP metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPDFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPhotoshopAdditionalLayerInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Additional Layer Info tag identifiers.

Members

Member | Description
Data | Photoshop additional layer data.
FORMAT | Photoshop additional layer info metadata format identifier.
Key | Photoshop additional layer key.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPhotoshopAdditionalLayerInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPhotoshopLayerInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPhotoshopLayerInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Layer Info tag identifiers.

Members

Member | Description
BlendingRanges | Photoshop layer blending ranges.
BlendModeKey | Photoshop layer blend mode key.
BlendModeSignature | Photoshop layer blend mode signature.
ChannelCount | Photoshop layer channel count.
ChannelID | Photoshop layer channel ID.
Clipping | Photoshop layer clipping.
ExtraData | Photoshop layer extra data.
Flags | Photoshop layer flags.
FORMAT | Photoshop layer info metadata format identifier.
MaskData | Photoshop layer mask data.
Name | Photoshop layer Name.
Opacity | Photoshop layer opacity.
Rectangle | Photoshop layer rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPhotoshopLayerInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPhotoshopLayerMaskInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPhotoshopLayerMaskInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Layer Mask Info tag identifiers.

Members

Member | Description
DefaultColor | Photoshop layer mask default color.
Flags | Photoshop layer mask flags.
FORMAT | Photoshop layer mask info metadata format identifier.
RealFlags | Photoshop layer mask real flags.
RealUserMaskBg | Photoshop layer mask real user mask bg.
Rectangle | Photoshop layer mask rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPhotoshopLayerMaskInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPhotoshopResourceGenericTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPhotoshopResourceGenericTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Resource Generic tag identifiers.

Members

Member | Description
DATA | Photoshop resource generic data.
FORMAT | Photoshop resource generic metadata format identifier.
ID | Photoshop resource generic ID.
NAME | Photoshop resource generic name.
SIGNATURE | Photoshop resource generic signature.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPhotoshopResourceGenericTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPHOTOSHOPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPHOTOSHOPTagIDs Enumeration

Glossary Item Box

Lists all Photoshop tag identifiers.

This enumeration lists all general Photoshop tag identifiers.

Members

Member | Description
AlphaIdentifiers | Alpha identifiers.
AlphaNames | Alpha names.
Caption | The caption.
COMMENT | Resource block comment.
DisplayInfo | Display info.
FORMAT | PhotoshopResource metadata format identifier.
HEADER | Header data section.
ICCProfile | ICC profile.
IPTC | IPTC-NAA record.
ResolutionInfo | Resolution info.
RESOURCE | Resource block.
RESOURCE_SIZE | Resource size.
SEGMENTDATA | Segment data.
Thumbnail | Thumbnail resource.
ThumbnailLegacy | Thumbnail legacy.
TransparencyIndex | Transparency index.
UnicodeAlphaNames | Unicode alpha names.
VersionInfo | Version info.
XMP | XML packet containing XMP metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPHOTOSHOPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPhotoshopVersionInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPhotoshopVersionInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Version Info tag identifiers.

Members

Member | Description
FileVersion | File version.
FORMAT | Photoshop version info metadata format identifier.
hasRealMergedData | Has real merged data.
ReaderName | Reader name.
Version | Photoshop version.
WriteName | Write name.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPhotoshopVersionInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPNGCompLevel Enumeration
com.accusoft.imagegear.formats Package : ImGearPNGCompLevel Enumeration

Glossary Item Box

Lists all PNG compression levels.

Members

Member | Description
DEFAULT_COMPRESSION | Default compression.
MAX_COMPRESSION | Maximum compression.
MIN_COMPRESSION | Minimum compression.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPNGCompLevel

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPNGStrip Enumeration
com.accusoft.imagegear.formats Package : ImGearPNGStrip Enumeration

Glossary Item Box

Lists all PNG strip modes.

Members

Member | Description
STRIP_FIXED_BUFFER | Fixed buffer.
STRIP_FIXED_COUNT | Fixed strip count.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPNGStrip

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPNGTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPNGTagIDs Enumeration

Glossary Item Box

Lists all PNG tag identifiers.

Members

Member | Description
BACKGROUND | Background information.
CALIBRATION | Calibration information.
CHRM_BLUE | Chromaticities blue.
CHRM_GREEN | Chromaticities green.
CHRM_RED | Chromaticities red.
CHRM_WHITE | White point.
CHRM_X | Chromaticities X.
CHRM_Y | Chromaticities Y.
CHROMATICITIES | Chromaticities information.
COMPRESSED_TEXT | Compressed textual data information.
CTXT_COMPR_METHOD | Compression method.
CTXT_KEYWORD | Compressed textual data chunk keyword that indicates the type of information represented by the text string.
CTXT_TEXT | Compressed textual data chunk text.
FORMAT | PNG metadata format identifier.
FRACTAL_PARAMETERS | Fractal parameters information.
GAMMA | Gamma information.
GIF_APP_EXT | GIF application extension information.
GIF_CONTROL | GIF contro information.
GIF_TEXT_EXT | Gif text extension information.
GIFG_DELAY_TIME | Delay time.
GIFG_DISPOSAL_METHOD | Disposal method.
GIFG_USER_INPUT_FLAG | User Input flag.
GIFX_APP_DATA | Application data.
GIFX_APP_ID | Application identifier.
GIFX_AUTHENTICATION | Authentication code.
HEADER | Header information.
HISTOGRAM | Histogram information.
ICC_PROFILE | ICC profile information.
ICCP_DATA | Profile data.
ICCP_NAME | Profile name.
IHDR_BIT_DEPTH | Image bit depth.
IHDR_COLOR_TYPE | Color type.
IHDR_COMPRESSION | Compression type.
IHDR_FILTER_TYPE | Filter type.
IHDR_HEIGHT | Image height.
IHDR_INTERLACE_TYPE | Interlace type.
IHDR_WIDTH | Image width.
IMAGE_OFFSET | Image offset.
INTERNATIONAL_TEXT | International textual data information.
ITXT_COMPR_FLAG | Compression flag.
ITXT_COMPR_METHOD | Compression method.
ITXT_KEYWORD | International textual data chunk keyword that indicates the type of information represented by the text string.
ITXT_LANGUAGE | Language tag.
ITXT_TEXT | International textual data chunk text.
ITXT_TRANSL_KEYWORD | Translated keyword.
OFFS_UNIT | Unit specifier.
OFFS_X_POSITION | X position.
OFFS_Y_POSITION | Y position.
PCAL_EQUATION | Equation type.
PCAL_NAME | Calibration name.
PCAL_PAR_COUNT | Number of parameters.
PCAL_PARAMETER | Calibration parameter.
PCAL_UNIT | Unit name.
PCAL_X0 | Original zero(x0).
PCAL_X1 | Original Max(x1).
PHYS_UNIT | Unit specifier.
PHYS_X_AXIS | Intended pixel size or aspect ratio by X axis for display .
PHYS_Y_AXIS | Intended pixel size or aspect ratio by Y axis for display.
PHYSICAL_SCALE | Physical scale information.
RESOLUTION | Resolution information.
SCAL_HEIGHT | Pixel height.
SCAL_UNIT | Unit specifier.
SCAL_WIDTH | Pixel width.
SIGNIFICANT_BITS | Significant bits information.
SPLT_ALPHA | Suggested palette alpha entry value.
SPLT_BLUE | Suggested palette blue entry value.
SPLT_DEPTH | Sample depth.
SPLT_ENTRY | Suggested palette entry.
SPLT_ENTRY_COUNT | Suggested palette entry count.
SPLT_FREQUENCY | Suggested palette frequency entry value.
SPLT_GREEN | Suggested palette green entry value.
SPLT_NAME | Palette name.
SPLT_RED | Suggested palette red entry value.
SRGB | Standard RGB information.
SUGGESTED_PALETTE | Suggested palette information.
TEXT | Text data information.
TEXT_KEYWORD | Textual data chunk keyword that indicates the type of information represented by the text string.
TEXT_TEXT | Textual data chunk text.
TIME | Time image last modification information.
TIME_DAY | Image last-modification time day value.
TIME_HOUR | Image last-modification time hour value.
TIME_MINUTE | Image last-modification time minute value.
TIME_MONTH | Image last-modification time month value.
TIME_SECOND | Image last-modification time second value.
TIME_YEAR | Image last-modification time year value.
TRANSPARENCY | Transparency information.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPNGTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPSDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPSDTagIDs Enumeration

Glossary Item Box

Lists all PSD tag identifiers.

Members

Member | Description
CHANNELS | Number of image channels.
COLOR_DATA | Color data.
COLS | The width of the image in pixels.
COMPRESSION | Image data compression.
DEPTH | The number of bits per channel.
EXTRA_LAYERS_DATA | Extra layers data.
FILE_HDR | File header.
FORMAT | PSD metadata format identifier.
HEADER | Header data section.
IPTC_NAA | IPTC NAA data section.
LAYER_COUNT | Layer count.
LAYERS | Layers data.
MODE | Color mode.
MODE_LEN | Color mode data length.
PHOTOSHOP_RESOURCES | Photoshop resources.
PSD_RESOURCE_XMP_Pocket | PSD_RESOURCE_XMP_Pocket = 0x0424 to avoid forvalue(0x0424) return null
RESERVED_HDR | Reserved HDR.
ROWS | The height of the image in pixels.
SIGNATURE | File type identifier.
VERSION | Version number.
XMP | XMP data section.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPSDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPSTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPSTagIDs Enumeration

Glossary Item Box

Lists all PostScript tag identifiers.

Members

Member | Description
FORMAT | PS metadata format identifier.
XMP | XML packet containing XMP metadata.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPSTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearPTOCATagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearPTOCATagIDs Enumeration

Glossary Item Box

Lists all PTOCA tag identifiers.

Members

Member | Description
FORMAT | PTOCA metadata format identifier.
HEIGHT | Image height.
WIDTH | Image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearPTOCATagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearRASTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearRASTagIDs Enumeration

Glossary Item Box

Lists all RAS tag identifiers.

Members

Member | Description
COLOR_MAP_LENGTH | Color map length.
COLOR_MAP_TYPE | Color map type.
DEPTH | Image depth.
FORMAT | RAS metadata format identifier.
HEIGHT | Image height.
LENGTH | Length of the image data (which is the length of the file minus the length of the header and colormap).
MAGIC | RAS magic value.
TYPE | RAS format type.
WIDTH | Image width.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearRASTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearRasterConversionModes Enumeration
com.accusoft.imagegear.formats Package : ImGearRasterConversionModes Enumeration

Glossary Item Box

Lists all raster conversion modes for image saving.

Members

Member | Description
ANY | Allow any conversion supported by ImageGear.
DIRECT_MATCH | Allow saving only unchanged pixel data.
NO_QUALITY_LOSS | Only allow pixel data conversion that does not degrade image quality.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearRasterConversionModes

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearRawAlignment Enumeration
com.accusoft.imagegear.formats Package : ImGearRawAlignment Enumeration

Glossary Item Box

Represents alignment of bytes in raster line.

Members

Member | Description
Byte | Raster lines are byte aligned.
DoubleWord | Raster lines are double word aligned.
Word | Raster lines are word aligned.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearRawAlignment

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearRectangleInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearRectangleInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Rectangle Info tag ids.

Members

Member | Description
Bottom | Rectangle bottom coordinate.
FORMAT | Rectangle metadata format identifier.
Left | Rectangle left coordinate.
Right | Rectangle right coordinate.
Top | Rectangle top coordinate.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearRectangleInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearResolutionInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearResolutionInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Resolution Info tag ids.

Members

Member | Description
FORMAT | Resolution info metadata format identifier.
H_RESOLUTION | Horizontal resolution.
H_RESOLUTION_UNIT | Horizontal unit.
HEIGHT_UNIT | Height unit.
V_RESOLUTION | Vertical resolution.
V_RESOLUTION_UNIT | Vertical unit.
WIDTH_UNIT | Width unit.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearResolutionInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearSavingFormats Enumeration
com.accusoft.imagegear.formats Package : ImGearSavingFormats Enumeration

Glossary Item Box

Lists all ImageGear saving formats.

Each saving format is a combination of a file format and a compression (e.g., TIF_G4 specifies TIF file format and CCITT Group4 compression). ImGearCompressions.AUTO specifies default compression for the format.

Members

Member | Description
BMP_RLE | BMP RLE format.
BMP_UNCOMP | BMP Uncompressed.
BTR | BTR CCITT Group 3.
BTR_G3_2D | BTR CCITT Group 3 2D.
CAL | CAL CCITT Group 4.
CGM | CGM (vector).
CLP | CLP Uncompressed.
CLP_RLE | CLP RLE format.
CUR | CUR Uncompressed.
CUT_RLE | CUT RLE format.
DCX | DCX RLE format.
DICOM | DICOM (Control parameters define compression).
DICOM_JPEG | DICOM JPEG.
DICOM_JPEG2K | DICOM JPEG2K.
DICOM_RLE | DICOM RLE format.
DICOM_UNCOMP | DICOM Uncompressed.
DWF | DWF (vector).
DWG | DWG (vector).
DXF | DXF (vector).
GIF | GIF LZW format.
HDPHOTO | HD PHOTO format.
ICA_G3 | ICA CCITT Group 3.
ICA_G4 | ICA CCITT Group 4.
ICA_MMR | ICA IBM MMR.
ICO | ICO Uncompressed.
IFF | IFF Uncompressed.
IFF_RLE | IFF RLE format.
JP2 | JP2 JPEG2K.
JPG | JPG JPEG format.
JPX | JPX JPEG2K.
MJ2 | MJ2 JPEG2K.
MODCA_G3 | MODCA CCITT Group 3.
MODCA_G4 | MODCA CCITT Group 4.
MODCA_MMR | MODCA IBM MMR.
NCR | NCR CCITT Group 4.
PBM_ASCII | PBM ASCII.
PBM_RAW | PBM RAW format.
PCX | PCX RLE format.
PDF | PDF Uncompressed.
PDF_DEFLATE | PDF Deflate.
PDF_G3 | PDF CCITT Group 3.
PDF_G3_2D | PDF CCITT Group 3 2D.
PDF_G4 | PDF CCITT Group 4.
PDF_JPEG2K | PDF JPEG2K.
PDF_JPG | PDF JPEG format.
PDF_LZW | PDF LZW format.
PDF_RLE | PDF RLE format.
PDF_UNCOMP | PDF Uncompressed.
PNG | PNG Deflate.
PS | PS Uncompressed.
PS_DEFLATE | PS Deflate.
PS_G3 | PS Group3 format
PS_G3_2D | PS Group3_2D format
PS_G4 | PS Group4 format
PS_JPEG2K | PS JPEG2K.
PS_JPG | PS JPEG format
PS_LZW | PS LZW format.
PS_RLE | PS RLE format.
PS_UNCOMP | PS Uncompressed.
PSB_PACKED | PSB RLE format.
PSB_UNCOMP | PSB Uncompressed.
PSD_PACKED | PSD RLE format.
PSD_UNCOMP | PSD Uncompressed.
RAS | RAS Uncompressed.
RAS_RLE | RAS RLE format.
SCI | SCI Uncompressed.
SGI | SGI Uncompressed.
SGI_RLE | SGI RLE format.
SVG | SVG (Vector).
TGA_RLE | TGA RLE format.
TGA_UNCOMP | TGA Uncompressed.
TIF_DEFLATE | TIFF Deflate.
TIF_G3 | TIFF CCITT Group 3.
TIF_G3_2D | TIFF CCITT Group 3 2D.
TIF_G4 | TIFF CCITT Group 4.
TIF_HUFFMAN | TIFF Huffman.
TIF_JPG | TIFF JPEG format.
TIF_LZW | TIFF LZW format.
TIF_PACKED | TIFF PackBits.
TIF_UNCOMP | TIFF Uncompressed.
U3D | U3D (Vector).
UNKNOWN | Unknown format. Specifying it on saving tells ImageGear to use file name extension to determine the saving format.
WBMP | WBMP Uncompressed.
XBM | XBM Uncompressed.
XPM | XPM Uncompressed.
XPS | XPS (Vector).
XWD | XWD Uncompressed.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearSavingFormats

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearSavingModes Enumeration
com.accusoft.imagegear.formats Package : ImGearSavingModes Enumeration

Glossary Item Box

Lists all saving modes.

This enumeration specifies available saving modes, such as overwrite image, insert page, etc.

Members

Member | Description
APPEND | New pages are appended to existing image. Any time ImGearSavingModes method is used with ImGearSavingModes.APPEND, the stream must be at the beginning of the file to be appended to.
INSERT | New pages are inserted into existing image.
OVERWRITE | A new image is created during saving. If old image exists, it is overwritten.
REPLACE | New pages replace existing pages in the image.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearSavingModes

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearSCITagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearSCITagIDs Enumeration

Glossary Item Box

Lists all SCI tag identifiers.

This enumeration lists all Scitex CT tag identifiers.

Members

Member | Description
BLOCKSIZE | Block size.
FORMAT | SCI metadata format identifier.
PRM_HEIGHT_IN_PIXELS | PRM height in pixels.
PRM_HEIGHT_IN_UNITS | PRM height in units.
PRM_NUM_COLOR_SEPARATIONS | PRM num color separations.
PRM_SCAN_DIRECTION | PRM scan direction.
PRM_SEPARATIONS_BIT_MASK | PRM separations bit mask.
PRM_UNITS_OF_MEASUREMENT | PRM units of measurement.
PRM_WIDTH_IN_PIXELS | PRM width in pixels.
PRM_WIDTH_IN_UNITS | PRM width in units.
TYPE | File type identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearSCITagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearSGITagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearSGITagIDs Enumeration

Glossary Item Box

Lists all SGI tag identifiers.

Members

Member | Description
BPC | Number of bytes per pixel channel.
COLOR_MAP | Color map.
DIMENSION | Number of dimensions.
DUMMY1 | Dummy 1 value.
DUMMY2 | Dummy 2 value.
FORMAT | SGI metadata format identifier.
IMAGE_NAME | Image name.
MAGIC | IRIS image file magic number.
PIX_MAX | Maximum pixel value.
PIX_MIN | Minimum pixel value.
STORAGE | Storage format.
X_SIZE | X size in pixels.
Y_SIZE | Y size in pixels.
Z_SIZE | Number of channels.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearSGITagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearTGATagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearTGATagIDs Enumeration

Glossary Item Box

Lists all TGA tag identifiers.

Members

Member | Description
EXT | Extension data section.
EXT_ATTRIBUTESTYPE | Attributes type.
EXT_AUTHORCOMMENT | Author comment.
EXT_AUTHORNAME | Author name.
EXT_COLOROFFSET | Color offset.
EXT_GAMMADENOMINATOR | Gamma denominator.
EXT_GAMMANUMERATOR | Gamma numerator.
EXT_JOBHOUR | Job hour value.
EXT_JOBMINUTE | Job minute value.
EXT_JOBNAME | Job name .
EXT_JOBSECOND | Job second value.
EXT_KEYCOLOR | Key color.
EXT_PIXELDENOMINATOR | Pixel denominator.
EXT_PIXELNUMERATOR | Pixel numerator.
EXT_SCANOFFSET | Scan offset.
EXT_SIZE | Extension size.
EXT_SOFTWAREID | Software ID.
EXT_STAMPDAY | Stamp day.
EXT_STAMPHOUR | Stamp hour.
EXT_STAMPMINUTE | Stamp minute.
EXT_STAMPMONTH | Stamp month.
EXT_STAMPOFFSET | Stamp offset.
EXT_STAMPSECOND | Stamp second.
EXT_STAMPYEAR | Stamp year.
EXT_VERSIONLETTER | Version letter.
EXT_VERSIONNUMBER | Version number.
FOOT | Footer data section.
FOOT_DEVELOPER_OFFSET | Developer offset.
FOOT_EXTENSION_OFFSET | Extension offset.
FOOT_SIGNATURE | Signature string.
FORMAT | TGA metadata format identifier.
HEAD | Header data section.
HEAD_CMAPDEPTH | CMap depth.
HEAD_CMAPLENGTH | CMap length.
HEAD_CMAPSTART | CMap start.
HEAD_COLORMAPTYPE | Color map type.
HEAD_HEIGHT | Image height.
HEAD_IDLENGTH | ID length.
HEAD_IMAGEDESCRIPTOR | Image descriptor.
HEAD_IMAGETYPE | Image type.
HEAD_PIXELDEPTH | Pixel depth.
HEAD_WIDTH | Image width.
HEAD_XOFFSET | Absolute horizontal coordinate for the lower left corner of the image as it is positioned on a display device having an origin at the lower left of the screen.
HEAD_YOFFSET | Absolute vertical coordinate for the lower left corner of the image as it is positioned on a display device having an origin at the lower left of the screen.
IMAGE_ID | Image ID tag.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearTGATagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearThumbnailInfoTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearThumbnailInfoTagIDs Enumeration

Glossary Item Box

Lists all Photoshop Thumbnail Info tag identifiers.

Members

Member | Description
BITS_PER_PIXEL | Bits per pixel.
FORMAT | Thumbnail info metadata format identifier.
HEIGHT | Thumbnail height.
IMG_FORMAT | Image format.
OFFSET | Thumbnail offset.
PLANES | Thumbnail planes.
SIZE_COMPRESSED | Size compressed.
SIZE_TOTAL | Size total.
WIDTH | Thumbnail width.
WIDTHBYTES | Width bytes.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearThumbnailInfoTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearTIFTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearTIFTagIDs Enumeration

Glossary Item Box

Lists all TIF tag identifiers.

Members

Member | Description
ACTIVE_AREA | Active area.
ANALOG_BALANCE | Analog balance.
ANTI_ALIAS_STRENGTH | Anti alias strength.
APERTURE_VALUE | Aperture value.
ART_DATA | ART annotation data (ImageGear tag).
ARTIST | Person who created the image.
AS_SHOT_NEUTRAL | As shot neutral.
AS_SHOT_WHITEXY | As shot white XY.
ASSHOT_ICC_PROFILE | As shot ICC profile.
ASSHOT_PRE_PROFILE_MATRIX | As shot pre profile matrix.
BASELINE_EXPOSURE | Baseline exposure.
BASELINE_NOISE | Baseline noise.
BASELINE_SHARPNESS | Baseline sharpness.
BATTERY_LEVEL | Battery level.
BAYER_GREEN_SPLIT | Bayer green split.
BEST_QUALITY_SCALE | Best quality scale.
BITS_PER_SAMPLE | Bits per sample.
BLACK_LEVEL | Black level.
BLACK_LEVEL_DELTAH | Black level delta H.
BLACK_LEVEL_DELTAV | Black level delta V.
BLACK_LEVELREPEAT_DIM | Black level repeat dim.
BRIGHTNESS_VALUE | Brightness value.
BYTE_ORDER | Byte order.
CALIBRATION_ILLUMINANT1 | Calibration illuminant 1.
CALIBRATION_ILLUMINANT2 | Calibration illuminant 2.
CAMERA_CALIBRATION1 | Camera calibration 1.
CAMERA_CALIBRATION2 | Camera calibration 2.
CAMERA_SERIAL_NUMBER | Camera serial number.
CELL_HEIGHT | Cell height.
CELL_WIDTH | Cell width.
CFA_LAYOUT | CFA layout.
CFA_PATTERN | CFA pattern.
CFA_PlANECOLOR | CFA plane color.
CFA_REPEAT_PATTERN_DIM | CFA repeat pattern dim.
CHROMA_BLUR_RADIUS | Chroma blur radius.
COLOR_MAP | Color map.
COLOR_MATRIX1 | Color matrix 1.
COLOR_MATRIX2 | Color matrix 2.
COMPRESSEDBITSPERPIXEL | Compressed bits per pixel.
COMPRESSION | Image data compression type.
COPYRIGHT | Copyright notice.
CURRENT_ICC_PROFILE | Current ICC profile.
CURRENT_PRE_PROFILE_MATRIX | Current pre profile matrix.
DATE_TIME | Date time.
DATETIMEORIGINAL | Date time original.
DEFAULT_CROP_ORIGIN | Default crop origin.
DEFAULT_CROP_SIZE | Default crop size.
DEFAULT_SCALE | Default scale.
DESCRIPTION | Image description.
DNG_BACKWARDVERSION | DNG backward version.
DNG_PRIVATE_DATA | DNG private data.
DNG_VERSION | DNG version.
DOC_NAME | Document name.
DOT_RANGE | Dot range.
EXIF_IFDPOINTER | Exif IFD pointer.
EXPOSURE_BIAS_VALUE | Exposure bias value.
EXPOSURE_INDEX | Exposure index.
EXPOSURE_PROGRAM | Exposure program.
EXPOSURE_TIME | Exposure time.
EXTRA_SAMPLES | Extra samples.
FILL_ORDER | Fill order.
FLASH | Indicates weither or not flash used when the image was captured.
FLASHENERGY | Flash energy.
FNUMBER | Actual lens f-number used when the image was captured.
FOCAL_LENGTH | Focal length.
FOCAL_PLANE_RESOLUTION_UNIT | Focal plane resolution unit.
FOCAL_PLANE_XRESOLUTION | Focal plane xresolution.
FOCAL_PLANE_YRESOLUTION | Focal plane yresolution.
FORMAT | TIF metadata format identifier.
FREE_BYTE_COUNTS | Free byte counts.
FREE_OFFSETS | Free offsets.
GPSINFOIFDPOINTER | Exif IFD pointer.
GRAY_RESPONSE_CURVE | Gray response curve.
GRAY_RESPONSE_UNIT | Gray response unit.
HALFTONE_HINTS | Halftone hints.
HOST_COMPUTER | Host computer.
ICC_PROFILE | ICC color profile.
IDENTIFIER | TIFF format Identifier.
IMAGE_HEIGHT | Image height.
IMAGE_HISTORY | Image history.
IMAGE_NUMBER | Image number.
IMAGE_WIDTH | Image width.
INK_NAMES | Ink names.
INK_SET | The set of inks used.
INTERLACE | Indicates the field number of multifield images.
IPTC_NAA | IPTC / NAA.
ISOSPEEDRAITINGS | ISO speed raitings.
JPEG_AC_TABLES | JPEG AC tables.
JPEG_DC_TABLES | JPEG DC tables.
JPEG_INTERCHANGE | JPEG interchange format.
JPEG_INTERCHANGE_LEN | JPEG interchange format length.
JPEG_LOSSLESS_PREDICTOR | JPEG lossless predictors.
JPEG_POINT_TRANSFORMS | JPEG point transforms.
JPEG_PROC | JPEG proc.
JPEG_Q_TABLES | JPEG Q tables.
JPEG_RESTART_INTERVAL | JPEG restart interval.
JPEG_TABLES | JPEG tables.
LENS_INFO | Lens info.
LIGHT_SOURCE | Light source.
LINEAR_RESPONSE_LIMIT | Linear response limit.
LINEARIZATION_TABLE | Linearization table.
LOCALIZED_CAMERAMODEL | Localized camera model.
MAKE | Manufacturer of equipment used to generate the image.
MAKER_NOTE_SAFETY | Maker note safety.
MASKED_AREAS | Masked areas.
MAX_SAMPLE_VAL | Max sample value.
MAXAPERTURE_VALUE | Max aperture value.
METERING_MODE | Metering mode.
MICROSOFT_PHOTO_RATING | Microsoft photo rating.
MIN_SAMPLE_VAL | Min sample value.
MODEL | The model name of equipment used to generate the image.
NEW_SUBFILE_TYPE | New subfile type.
NOISE | Noise measurement values.
NUMBER_OF_INKS | Number of inks.
OECF | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524.
ORIENTATION | Image orientation.
ORIGINAL_RAW_FILE_DATA | Original raw file data.
ORIGINAL_RAW_FILE_NAME | Original raw file name.
PAGE_NAME | Page name.
PAGE_NUMBER | Page number.
PHOTO_INTERP | Photometric interpretation.
PHOTOSHOP_RESOURCES | Photoshop resources.
PLANAR_CONFIG | Planar configuration.
PREDICTOR | Mathematical operator that is applied to the image data before an encoding scheme is applied.
PRIMARY_CHROMA | Primary chromaticities.
RATING | Image rating.
RAW_DATA_UNIQUE_ID | Raw data unique ID.
REDUCTION_MATRIX1 | Reduction matrix 1.
REDUCTION_MATRIX2 | Reduction matrix 2.
REFERENCE_BLACK_WHITE | Reference black white.
RES_UNIT | Resolution unit.
ROWS_PER_STRIP | Rows per strip.
SAMPLE_FORMAT | Sample format.
SAMPLES_PER_PIXEL | Samples per pixel.
SECURITY_CLASSIFICATION | Security classification.
SELFTIMER_MODE | Self timer mode.
SENSING_METHOD | Sensing method.
SHADOW_SCALE | Shadow scale.
SHUTTERSPEED_VALUE | Shutter speed value.
SMAX_SAMPLE_VAL | S max sample value.
SMIN_SAMPLE_VAL | S min sample value.
SOFTWARE | Name and version number of the software package(s) used to create the image.
SPATIAL_FREQUENCY_RESPONSE | Spatial frequency response.
SPECTRAL_SENSITIVITY | Spectral sensitivity.
STRIP_BYTE_COUNT | Strip byte counts.
STRIP_OFFSETS | Strip offsets.
SUB_IFDS | Child IFDs offsets.
SUBFILE_TYPE | Subfile type.
SUBJECT_LOCATION | Subject location.
SUBJECTDISTANCE | Subject distance.
T4_OPTIONS | T4 options.
T6_OPTIONS | T6 options.
TARGET_PRINTER | Target printer.
THRESHOLDING | The technique used to convert from gray to black and white pixels.
TIFFEP_STANDARDID | TIFF/EP standard ID.
TILE_BYTE_COUNT | Tile byte counts.
TILE_HEIGHT | Tile height.
TILE_OFFSETS | Tile offsets.
TILE_WIDTH | Tile width.
TIMEZONE_OFFSET | Time zone offset.
TRANSFER_FUNC | Transfer function.
TRANSFER_RANGE | Transfer range.
UNIQUE_CAMERAMODEL | Unique camera model.
WHITE_LEVEL | White level.
WHITE_POINT | White point.
X_POS | X position.
X_RES | X resolution.
XMP | XML packet containing XMP metadata.
Y_POS | Y position.
Y_RES | Y resolution.
YCBCR_COEFFICIENTS | YCbCr coefficients.
YCBCR_POS | YCbCr positioning.
YCBCR_SUBSAMPLING | YCbCr sub sampling.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearTIFTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearWBMPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearWBMPTagIDs Enumeration

Glossary Item Box

Lists all WBMP tag identifiers.

Members

Member | Description
FORMAT | WBMP metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearWBMPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearWPGTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearWPGTagIDs Enumeration

Glossary Item Box

Lists all WPG tag identifiers.

Members

Member | Description
FORMAT | WPG metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearWPGTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearXBMTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearXBMTagIDs Enumeration

Glossary Item Box

Lists all XBM tag identifiers.

Members

Member | Description
FORMAT | XBM metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearXBMTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearXMPTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearXMPTagIDs Enumeration

Glossary Item Box

Lists all XMP tag identifiers.

These identifiers represent structural types of XMP metadata, such as Value, Sequence, Bag, Qualifier, etc. ImageGear does not provide enumerations for particilar properties of XMP schemes.

Members

Member | Description
About | About attribute value.
Alt | Alternative array of values tree.
Bag | Bag of values (unordered array) tree.
Description | XMP Schema tree.
FORMAT | XMP Metadata Format identifier.
Item | Array item tree.
Lang | Language alternative tree.
Namespace | Namespace tree.
Prefix | Namespace prefix value.
Properties | Properties tree.
Property | Property tree.
Qualifier | Qualifier tree.
Qualifiers | Qualifiers tree.
Seq | Sequence of values (ordered array) tree.
Struct | Structure tree.
URI | Namespace URI value.
Value | Property value.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearXMPTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearXPMTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearXPMTagIDs Enumeration

Glossary Item Box

Lists all XPM tag identifiers.

Members

Member | Description
FORMAT | XPM metadata format identifier.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearXPMTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearXPSTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearXPSTagIDs Enumeration

Glossary Item Box

Lists all XPS tag identifiers.

Members

Member | Description
CATEGORY | The category of the content that is contained in the file.
CONTENT_STATUS | Example ContentStatus values include "Draft", "Reviewed", and "Final".
CONTENT_TYPE | Example ContentType values include "Whitepaper", "Security Bulletin", and "Exam".
CREATED | The date and time the file was initially created.
CREATOR | The individual or entity that created the file and its content.
DESCRIPTION | The Description may include, but is not limited to: an abstract, table of contents, reference to a graphical representation of content, or a free-text account of the content.
FORMAT | XPS metadata format identifier.
IDENTIFIER | A value that unambiguously identifies the file and its content.
KEYWORDS | A delimited set of keywords to support searching and indexing the Package and content. The Keywords property typically contains a list of terms that are not available elsewhere in file metadata.
LANGUAGE | A value that identifies the file content language.
LAST_MODIFIED_BY | The user who last modified the file content.
LAST_PRINTED | The date and time the file content was last printed.
MODIFIED | The date and time the file was last changed.
REVISION | The revision number of the file. The Revision property indicates the number of changed saves or revisions. The application is responsible for updating the Revision property value after each revision.
SUBJECT | The topic of the file content.
TITLE | The name given to the file and its content.
VERSION | The version number of the file.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearXPSTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

ImGearXWDTagIDs Enumeration
com.accusoft.imagegear.formats Package : ImGearXWDTagIDs Enumeration

Glossary Item Box

Lists all XWD tag identifiers.

Members

Member | Description
FILE_VERSION | File version.
FORMAT | XWD metadata format identifier.
HEADER_SIZE | Header size.
X11_BITMAP_BIT_ORDER | Bitmap bit order (MSBFirst, LSBFirst).
X11_BITMAP_PAD | Bitmap scanline pad.
X11_BITMAP_UNIT | Bitmap unit.
X11_BITS_PER_PIXEL | Bits per pixel.
X11_BITS_PER_RGB | Log2 of distinct color values.
X11_BLUE_MASK | Blue mask.
X11_BYTE_ORDER | Byte order.
X11_BYTES_PER_LINE | Bytes per scanline.
X11_COLOR_MAP_ENTRIES | Color map entries.
X11_GREEN_MASK | Green mask.
X11_NUMBER_OF_COLORS | Colors number.
X11_PIXMAP_DEPTH | Pixmap depth.
X11_PIXMAP_FORMAT | Pixmap format.
X11_PIXMAP_HEIGHT | Pixmap height.
X11_PIXMAP_WIDTH | Pixmap width.
X11_RED_MASK | Red mask.
X11_VISUAL_CLASS | Class of colormap.
X11_WINDOW_BORDER_WIDTH | Window border width.
X11_WINDOW_HEIGHT | Window height.
X11_WINDOW_WIDTH | Window width.
X11_WINDOW_X | Window upper left X coordinate.
X11_WINDOW_Y | Window upper left Y coordinate.
X11_X_OFFSET | Bitmap x offset.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.ImGearXWDTagIDs

See Also

Reference

com.accusoft.imagegear.formats Package


%%PageItemTitle%%

IImGearFormat Interface
See Also Members Send Feedback
com.accusoft.imagegear.formats Package : IImGearFormat Interface

Glossary Item Box

Base interface for all file format filters.

This interface provides access to format filters' settings.

Syntax

public interface IImGearFormat

See Also

Reference

IImGearFormat Members
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearFormat Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats Package : IImGearFormat Interface

Glossary Item Box

The following tables list the members exposed by IImGearFormat.

Public Methods

 | Name | Description
Method | getDefaultExtension | Gets the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format). String containing format extension. This value specifies the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format). This value is used when populating the filter for the SaveFileDialog on Win32.
Method | getFullName | Gets the full name of the format. String containing the format's name.
Method | getID | Gets the ID of the format. Any member of the ImGearFormats enumeration except ImGearFormats.UNKNOWN. ImGearFormats
Method | getMIMEType | Gets the MIME Media Type associated with the format. String containing the format's MIME Type. This value provides the MIME Media Type associated with the format, such as "image/jpeg", "image/tiff", etc.
Method | getName | Gets the short name of the format. String containing the format's name.
Method | getParameters | Gets format's control parameters. An instance of the class for managing format's control parameters. This value provides access to format's control parameters. ImGearFormatParameters
Method | isDetectionEnabled | Gets a value indicating whether the format should be used in the image detection process. Boolean value. Detection is enabled for all formats by default.
Method | setDetectionEnabled | Sets a value indicating whether the format should be used in the image detection process. Boolean value. Detection is enabled for all formats by default. Use this method to exclude a format from detection.
Top

See Also

Reference

IImGearFormat Interface
com.accusoft.imagegear.formats Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearFormat Interface Methods
See Also Send Feedback
com.accusoft.imagegear.formats Package : IImGearFormat Interface

Glossary Item Box

For a list of all members of this type, see IImGearFormat members.

Public Methods

 | Name | Description
Method | getDefaultExtension | Gets the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format). String containing format extension. This value specifies the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format). This value is used when populating the filter for the SaveFileDialog on Win32.
Method | getFullName | Gets the full name of the format. String containing the format's name.
Method | getID | Gets the ID of the format. Any member of the ImGearFormats enumeration except ImGearFormats.UNKNOWN. ImGearFormats
Method | getMIMEType | Gets the MIME Media Type associated with the format. String containing the format's MIME Type. This value provides the MIME Media Type associated with the format, such as "image/jpeg", "image/tiff", etc.
Method | getName | Gets the short name of the format. String containing the format's name.
Method | getParameters | Gets format's control parameters. An instance of the class for managing format's control parameters. This value provides access to format's control parameters. ImGearFormatParameters
Method | isDetectionEnabled | Gets a value indicating whether the format should be used in the image detection process. Boolean value. Detection is enabled for all formats by default.
Method | setDetectionEnabled | Sets a value indicating whether the format should be used in the image detection process. Boolean value. Detection is enabled for all formats by default. Use this method to exclude a format from detection.
Top

See Also

Reference

IImGearFormat Interface
com.accusoft.imagegear.formats Package


%%PageItemTitle%%

getDefaultExtension Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getDefaultExtension Method

Glossary Item Box

Gets the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format).

String containing format extension.

This value specifies the default extension used when naming files containing images in this format (e.g., "*.bmp" for the BMP format).

This value is used when populating the filter for the SaveFileDialog on Win32.

Syntax

java.lang.String getDefaultExtension()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

getFullName Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getFullName Method

Glossary Item Box

Gets the full name of the format.

String containing the format's name.

Syntax

java.lang.String getFullName()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

getID Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getID Method

Glossary Item Box

Gets the ID of the format.

Any member of the ImGearFormats enumeration except ImGearFormats.UNKNOWN. ImGearFormats

Syntax

ImGearFormats getID()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

getMIMEType Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getMIMEType Method

Glossary Item Box

Gets the MIME Media Type associated with the format.

String containing the format's MIME Type.

This value provides the MIME Media Type associated with the format, such as "image/jpeg", "image/tiff", etc.

Syntax

java.lang.String getMIMEType()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getName Method

Glossary Item Box

Gets the short name of the format.

String containing the format's name.

Syntax

java.lang.String getName()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

getParameters Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : getParameters Method

Glossary Item Box

Gets format's control parameters.

An instance of the class for managing format's control parameters.

This value provides access to format's control parameters.

ImGearFormatParameters

Syntax

ImGearFormatParameters getParameters()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

isDetectionEnabled Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : isDetectionEnabled Method

Glossary Item Box

Gets a value indicating whether the format should be used in the image detection process.

Boolean value.

Detection is enabled for all formats by default.

Syntax

boolean isDetectionEnabled()

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%PageItemTitle%%

setDetectionEnabled Method
com.accusoft.imagegear.formats Package > IImGearFormat Interface : setDetectionEnabled Method
value

Glossary Item Box

Sets a value indicating whether the format should be used in the image detection process.

Boolean value.

Detection is enabled for all formats by default. Use this method to exclude a format from detection.

Syntax

void setDetectionEnabled(
   boolean value
)

Parameters

value

See Also

Reference

IImGearFormat Interface
IImGearFormat Members


%%ItemTitle%%

com.accusoft.imagegear.formats.dicom Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides features that are used with medical and DICOM images.

Classes

Class | Description
ImGearDICOM | Provides DICOM specific features, such as DICOM Presentation State support.
ImGearDICOMDisplaySettings | Provides the means to display medical images with proper contrast.
ImGearDICOMTagsIDs | Specifies DICOM tag identifiers.
ImGearLinearTransform | Encapsulates coefficients for a linear floating-point one-dimensional transform. Result of the transform is calculated as: y = x * Slope + Intercept This class can be used to hold DICOM Modality Rescale coefficients.
ImGearModalityTransform | Implements DICOM Modality transform.
ImGearPresStateOptions | Encapsulates options for loading and saving presentation state objects.
ImGearVOITransform | Implements DICOM Value Of Interest (VOI) transform.
ImGearVOIWindow | Encapsulates linear DICOM VOI transform. This class contains following methods: getCenter and getWidth. This transform tells which contrast range of an image shall be mapped to contrast range of the display device.

Enumerations

Enumeration | Description
ImGearDICOMPhotoInterpretations | Specifies DICOM Photometric Interpretations.
ImGearDICOMPixelRepresenations | Specifies DICOM Pixel Representations.
ImGearDICOMPlanarConfigurations | Specifies DICOM Planar Configurations.
ImGearDICOMServiceObjectPairs | Specifies DICOM Service Object Pair (SOP) constants.
ImGearDICOMTransferSyntaxes | Specifies DICOM Transfer Syntaxes.
ImGearDICOMValueRepresentations | Specifies DICOM Value Representations. Value Representation specifies type and format of the value(s) contained in data element.
ImGearPseudocolorSchemes | Specifies predefined pseudocoloring schemes.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.dicom Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.dicom.ImGearDICOM
com.accusoft.imagegear.formats.dicom.ImGearDICOMTagsIDs
com.accusoft.imagegear.formats.dicom.ImGearLinearTransform
com.accusoft.imagegear.formats.dicom.ImGearModalityTransform
com.accusoft.imagegear.formats.dicom.ImGearPresStateOptions
com.accusoft.imagegear.formats.dicom.ImGearVOITransform
com.accusoft.imagegear.formats.dicom.ImGearVOIWindow

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearDICOM Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOM Class

Glossary Item Box

Provides DICOM specific features, such as DICOM Presentation State support.

Object Model

ImGearDICOM ClassImGearFullLUT ClassIImGearFormat InterfaceImGearARTPage ClassImGearMetadataHead ClassImGearMetadataHead Class

Syntax

public sealed class ImGearDICOM
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearDICOM

See Also

Reference

ImGearDICOM Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDICOM Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOM Class

Glossary Item Box

The following tables list the members exposed by ImGearDICOM.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | buildColorLimitsLUT | Builds a LUT that highlights image extremes.
static (Shared in Visual Basic) | buildPseudocolorLUT | Builds a pseudocolor LUT.
static (Shared in Visual Basic) | buildStandardDisplayLUT | Builds Standard Display LUT.
static (Shared in Visual Basic) | createDICOMFormat | Creates an instance of DICOM format.
static (Shared in Visual Basic) | loadOverlay | Overloaded. Loads overlay planes from DICOM metadata of the specified page.
static (Shared in Visual Basic) | loadPresState | Loads Presentation State object and applies it to an image.
static (Shared in Visual Basic) | preparePresStateMetadata | Prepares Presentation State metadata based on current image display settings and annotations.
static (Shared in Visual Basic) | saveOverlay | Saves ART marks into DICOM dataset as overlay planes.
static (Shared in Visual Basic) | savePresState | Saves Presentation State metadata to a Presentation State object.
Top

See Also

Reference

ImGearDICOM Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDICOM Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOM Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOM members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | buildColorLimitsLUT | Builds a LUT that highlights image extremes.
static (Shared in Visual Basic) | buildPseudocolorLUT | Builds a pseudocolor LUT.
static (Shared in Visual Basic) | buildStandardDisplayLUT | Builds Standard Display LUT.
static (Shared in Visual Basic) | createDICOMFormat | Creates an instance of DICOM format.
static (Shared in Visual Basic) | loadOverlay | Overloaded. Loads overlay planes from DICOM metadata of the specified page.
static (Shared in Visual Basic) | loadPresState | Loads Presentation State object and applies it to an image.
static (Shared in Visual Basic) | preparePresStateMetadata | Prepares Presentation State metadata based on current image display settings and annotations.
static (Shared in Visual Basic) | saveOverlay | Saves ART marks into DICOM dataset as overlay planes.
static (Shared in Visual Basic) | savePresState | Saves Presentation State metadata to a Presentation State object.
Top

See Also

Reference

ImGearDICOM Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

buildColorLimitsLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : buildColorLimitsLUT Method
lowThreshold
Lower pixel value limit. All pixels at or below this value will be pseudocolored.
lowFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or smaller than lowThreshold.
highThreshold
Higher pixel value limit. All pixels at or above this value will be pseudocolored.
highFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or greater than highThreshold.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

This method fills the lookup table (LUT) so that it highlights the brightest and darkest pixels in a grayscale image. Use this method to initialize com.accusoft.imagegear.display.ImGearPageDisplay.getLUT method. This is typically used to clearly see pixel values that are over-saturated (255 and up) or under-saturated (0 and below). However, this method lets you to customize the settings for the upper and lower pixel value limits with lowThreshold and highThreshold.

com.accusoft.imagegear.display.ImGearPageDisplay.getLUT value is used on the last stage of display processing, after that all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

com.accusoft.imagegear.core.ImGearPixel com.accusoft.imagegear.core.ImGearRGBLUT

Glossary Item Box

Builds a LUT that highlights image extremes.

Syntax

public static void buildColorLimitsLUT(
   int lowThreshold,
   ImGearPixel lowFillColor,
   int highThreshold,
   ImGearPixel highFillColor,
   ImGearRGBLUT lookupTable
)

Parameters

lowThreshold
Lower pixel value limit. All pixels at or below this value will be pseudocolored.
lowFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or smaller than lowThreshold.
highThreshold
Higher pixel value limit. All pixels at or above this value will be pseudocolored.
highFillColor
An RGB value that will be used to fill (i.e. pseudocolor) the pixels with intensities equal or greater than highThreshold.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

This method fills the lookup table (LUT) so that it highlights the brightest and darkest pixels in a grayscale image. Use this method to initialize com.accusoft.imagegear.display.ImGearPageDisplay.getLUT method. This is typically used to clearly see pixel values that are over-saturated (255 and up) or under-saturated (0 and below). However, this method lets you to customize the settings for the upper and lower pixel value limits with lowThreshold and highThreshold.

com.accusoft.imagegear.display.ImGearPageDisplay.getLUT value is used on the last stage of display processing, after that all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

com.accusoft.imagegear.core.ImGearPixel com.accusoft.imagegear.core.ImGearRGBLUT

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

buildPseudocolorLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : buildPseudocolorLUT Method
scheme
Predefined pseudocoloring scheme.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

This method fills a lookup table (LUT) according to one of the predefined 24-bit RGB to 24-bit RGB pseudocoloring schemes. Use this method to initialize method com.accusoft.imagegear.display.ImGearPageDisplay.getLUT.

Value, passed to com.accusoft.imagegear.display.ImGearPageDisplay.getLUT method is used on the last stage of display processing, when all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

com.accusoft.imagegear.core.ImGearRGBLUT ImGearPseudocolorSchemes

Glossary Item Box

Builds a pseudocolor LUT.

Syntax

public static void buildPseudocolorLUT(
   ImGearPseudocolorSchemes scheme,
   ImGearRGBLUT lookupTable
)

Parameters

scheme
Predefined pseudocoloring scheme.
lookupTable
Lookup table to fill. It should contain three single-channel LUTs with input and output depths set to 8.

This method fills a lookup table (LUT) according to one of the predefined 24-bit RGB to 24-bit RGB pseudocoloring schemes. Use this method to initialize method com.accusoft.imagegear.display.ImGearPageDisplay.getLUT.

Value, passed to com.accusoft.imagegear.display.ImGearPageDisplay.getLUT method is used on the last stage of display processing, when all geometric, color space and depth conversions have been done. This allows you to use a 24-bit RGB to 24-bit RGB lookup table for displaying images of any color space and depth.

com.accusoft.imagegear.core.ImGearRGBLUT ImGearPseudocolorSchemes

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

buildStandardDisplayLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : buildStandardDisplayLUT Method
inputDepth
Input depth of the LUT. inputDepth = 12 is the typical value, sufficient for most medical images.
outputDepth
Output depth of the LUT. Set to 8 for a monitor that can display 256 shades of gray.
characteristicCurve
Characteristic curve of the display device.

Glossary Item Box

Builds Standard Display LUT.

Syntax

public static ImGearFullLUT buildStandardDisplayLUT(
   int inputDepth,
   int outputDepth,
   double[] characteristicCurve
)

Parameters

inputDepth
Input depth of the LUT. inputDepth = 12 is the typical value, sufficient for most medical images.
outputDepth
Output depth of the LUT. Set to 8 for a monitor that can display 256 shades of gray.
characteristicCurve
Characteristic curve of the display device.

Return Value

New instance of com.accusoft.imagegear.core.ImGearFullLUT class object, containing the Standard Display LUT, based on the provided characteristic curve.

This method builds a lookup table that maps pixel intensities from DICOM Presentation space (P-Values) into pixel intensities of the display device. Use this lookup table to initialize ImGearDICOMDisplaySettings class.

The source data for this method is a characteristic curve - an array that lists luminosities of display device corresponding to each pixel intensity.

com.accusoft.imagegear.core.ImGearFullLUT

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

createDICOMFormat Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : createDICOMFormat Method

Glossary Item Box

Creates an instance of DICOM format.

Syntax

public static IImGearFormat createDICOMFormat()

Return Value

An instance of DICOM format. com.accusoft.imagegear.formats.IImGearFormat

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

loadOverlay Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : loadOverlay Method

Glossary Item Box

Loads overlay planes from DICOM metadata of the specified page.

Overload List

Overload | Description
loadOverlay(ImGearPage) | Loads overlay planes from DICOM metadata of the specified page.
loadOverlay(ImGearPage,boolean) | Loads overlay planes from DICOM metadata of the specified page, taking into account useLegacyMarks flag.

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

loadOverlay(ImGearPage) Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class > loadOverlay Method : loadOverlay(ImGearPage) Method
source
Page from which to load overlay planes.

Glossary Item Box

Loads overlay planes from DICOM metadata of the specified page.

Syntax

public static ImGearARTPage loadOverlay(
   ImGearPage source
)

Parameters

source
Page from which to load overlay planes.

Return Value

New com.accusoft.imagegear.art.ImGearARTPage class with annotations loaded from overlay.

Loads overlay planes from DICOM metadata (DataSet), attached to the image, and creates ART marks of type com.accusoft.imagegear.art.ImGearARTImageEmb class for each overlay plane. Each mark is placed in a separate ART group.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet. By default ImageGear uses yellow color to display overlays. The application can change overlay color by going through all marks in the com.accusoft.imagegear.art.ImGearARTPage class and changing palette of com.accusoft.imagegear.art.ImGearARTImageEmb class marks.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.art.ImGearARTImageEmb

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
Overload List


%%PageItemTitle%%

loadOverlay(ImGearPage,boolean) Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class > loadOverlay Method : loadOverlay(ImGearPage,boolean) Method
source
Page from which to load overlay planes.
useLegacyMarks
Specifies whether to create overlays using legacy com.accusoft.imagegear.art.ImGearARTImageEmb or new com.accusoft.imagegear.art.ImGearARTImage mark.

Glossary Item Box

Loads overlay planes from DICOM metadata of the specified page, taking into account useLegacyMarks flag.

Syntax

public static ImGearARTPage loadOverlay(
   ImGearPage source,
   boolean useLegacyMarks
)

Parameters

source
Page from which to load overlay planes.
useLegacyMarks
Specifies whether to create overlays using legacy com.accusoft.imagegear.art.ImGearARTImageEmb or new com.accusoft.imagegear.art.ImGearARTImage mark.

Return Value

New com.accusoft.imagegear.art.ImGearARTPage class with annotations loaded from overlay data.

Loads overlay planes from DICOM metadata (DataSet), attached to the image, and creates ART marks of type either com.accusoft.imagegear.art.ImGearARTImage or com.accusoft.imagegear.art.ImGearARTImageEmb class for each overlay plane. Each mark is placed in a separate ART group.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet. By default ImageGear uses yellow color to display overlays. The application can change overlay color by going through all marks in the com.accusoft.imagegear.art.ImGearARTPage class and changing palette of either com.accusoft.imagegear.art.ImGearARTImage or com.accusoft.imagegear.art.ImGearARTImageEmb class marks.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.art.ImGearARTImage com.accusoft.imagegear.art.ImGearARTImageEmb

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members
Overload List


%%PageItemTitle%%

loadPresState Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : loadPresState Method
strm
Stream, containing presentation state object.
page
Page to apply Presentation State to.
pageDisplay
PageDisplay to apply Presentation State to.
options
Options structure, tells which settings need to be applied.

Glossary Item Box

Loads Presentation State object and applies it to an image.

Syntax

public static ImGearMetadataHead loadPresState(
   ImGearStream strm,
   ImGearRasterPage page,
   IImGearPageDisplay pageDisplay,
   ImGearPresStateOptions options
)

Parameters

strm
Stream, containing presentation state object.
page
Page to apply Presentation State to.
pageDisplay
PageDisplay to apply Presentation State to.
options
Options structure, tells which settings need to be applied.

Return Value

New instance of com.accusoft.imagegear.core.ImGearMetadataHead class object, containing metadata loaded from the Presentation State object.

This method loads Presentation State object from a stream and applies settings, found in this object, to the page and to the pageDisplay. Specifically:

  • Adjusts page's ImGearDICOMDisplaySettings class member using VOI, Modality and Presentation LUTs, found in the Presentation State DataSet.
  • Sets image rectangle and orientation of the pageDisplay;
  • Adds annotation objects to the pageDisplay.

All previous settings and annotations of the page and pageDisplay are discarded.

This method also returns all metadata found in the Presentation State object.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.display.IImGearPageDisplay

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

preparePresStateMetadata Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : preparePresStateMetadata Method
page
Page from which presentation state settings shall be extracted.
pageDisplay
PageDisplay from which presentation state settings shall be extracted.
userMetadata
User supplied metadata.
options
Options structure telling which settings shall be extracted to the presentation state metadata.

Glossary Item Box

Prepares Presentation State metadata based on current image display settings and annotations.

Syntax

public static ImGearMetadataHead preparePresStateMetadata(
   ImGearRasterPage page,
   IImGearPageDisplay pageDisplay,
   ImGearMetadataHead userMetadata,
   ImGearPresStateOptions options
)

Parameters

page
Page from which presentation state settings shall be extracted.
pageDisplay
PageDisplay from which presentation state settings shall be extracted.
userMetadata
User supplied metadata.
options
Options structure telling which settings shall be extracted to the presentation state metadata.

Return Value

New instance of com.accusoft.imagegear.core.ImGearMetadataTree class object, containing presentation state metadata.

This method prepares metadata for a presentation state object, based on page's DICOMDisplaySettings member, on pageDisplay settings, and on annotations that are attached to image, if any.

After that presentation state metadata has been prepared, application may add or edit it, and then save as presentation state object using method.

The following features of the ImGearDICOMDisplaySettings class are saved to presentation state metadata:

  • VOI LUT
  • Modality LUT
  • Presentation LUT

The following settings of pageDisplay are saved to presentation state metadata:

  • Orientation
  • Image rectangle

The following annotations are saved to saved to presentation state metadata: Text, Callout, Polygon, Polyline, Point, Curve, Ellipse.

This method takes user metadata as a parameter. If this parameter is not null and contains a DICOM metadata tree, the method will use it as a base for building output metadata.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.formats.dicom.ImGearPresStateOptionsT:com.accusoft.imagegear.core.ImGearMetadataTree

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

saveOverlay Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : saveOverlay Method
artPage
ART page with marks to save to overlay.
page
Page to which to save annotations.

Each ART group is saved into a separate overlay plane.

Since overlay planes do not support any types of graphic objects other than bitonal bitmaps, all ART marks from a group are converted into a bitmap before saving into an overlay.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.art.ImGearARTImage

Glossary Item Box

Saves ART marks into DICOM dataset as overlay planes.

Syntax

public static void saveOverlay(
   ImGearARTPage artPage,
   ImGearRasterPage page
)

Parameters

artPage
ART page with marks to save to overlay.
page
Page to which to save annotations.

Each ART group is saved into a separate overlay plane.

Since overlay planes do not support any types of graphic objects other than bitonal bitmaps, all ART marks from a group are converted into a bitmap before saving into an overlay.

Overlay planes do not support specifying the colors (even black or white). An overlay pixel can only be visible or invisible. All visible overlay pixels are displayed with the same color, which is specified by the application and not stored in the DICOM DataSet.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.art.ImGearARTImage

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

savePresState Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOM Class : savePresState Method
stream
Stream to save presentation state to.
metadata
Presentation state metadata.

Use method to extract presentation state settings from page and pageDisplay and build metadata for presentation state.

This method expects DICOM metadata tree in the metadata parameter:

  • Preamble (optional)
  • MetaInfoHeader (optional)
  • DataSet (required)

com.accusoft.imagegear.core.ImGearMetadataHead

Glossary Item Box

Saves Presentation State metadata to a Presentation State object.

Syntax

public static void savePresState(
   ImGearStream stream,
   ImGearMetadataHead metadata
)

Parameters

stream
Stream to save presentation state to.
metadata
Presentation state metadata.

Use method to extract presentation state settings from page and pageDisplay and build metadata for presentation state.

This method expects DICOM metadata tree in the metadata parameter:

  • Preamble (optional)
  • MetaInfoHeader (optional)
  • DataSet (required)

com.accusoft.imagegear.core.ImGearMetadataHead

See Also

Reference

ImGearDICOM Class
ImGearDICOM Members


%%PageItemTitle%%

ImGearDICOMDisplaySettings Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMDisplaySettings Class

Glossary Item Box

Provides the means to display medical images with proper contrast.

Object Model

ImGearDICOMDisplaySettings ClassImGearLUT ClassImGearDICOMDisplaySettings ClassImGearLUT Class

Syntax

public class ImGearDICOMDisplaySettings
    extends com.accusoft.imagegear.callbackinterfaces.AbstractPropertiesPosessor
    implements com.accusoft.imagegear.core.IImGearDICOMDisplaySettings

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

See Also

Reference

ImGearDICOMDisplaySettings Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDICOMDisplaySettings Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMDisplaySettings Class

Glossary Item Box

The following tables list the members exposed by ImGearDICOMDisplaySettings.

Public Constructors

 | Name | Description
public Constructor | ImGearDICOMDisplaySettings Constructor | Initializes a new instance of the ImGearDICOMDisplaySettings class object.
Top

Public Fields

 | Name | Description
public Field | displaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
public Field | modality | Provides access to Modality transform. ImGearModalityTransform class object. The default value is null. ImGearModalityTransform
public Field | presentationLUT | Provides access to Presentation LUT. com.accusoft.imagegear.core.ImGearFullLUT class object. The default value is null. com.accusoft.imagegear.core.ImGearFullLUT
public Field | standardDisplayLUT | Provides access to Standard Display LUT. com.accusoft.imagegear.core.ImGearFullLUT class object. The default value is null. com.accusoft.imagegear.core.ImGearFullLUT
public Field | voi | Provides access to VOI transform. ImGearVOITransform class object. This member provides access to DICOM Value Of Interest (VOI) transform. The default value is null. ImGearVOITransform
Top

Public Methods

Name | Description
public Method | buildSummaryLUT | Builds a standalone com.accusoft.imagegear.core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
public Method | clone | Creates a deep copy of the ImGearDICOMDisplaySettings class object.
public Method getDisplaySummaryLUT Returns summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This value concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

public Method isInverted Returns a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

public Method | setAutoVOITransform | Automatically calculates VOI transform based on image's contrast range.
public Method setDisplaySummaryLUT Sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This method concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

public Method setInverted Sets a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

public Method | updateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.
public Method | updateFromMetadata | Updates the object from DICOM metadata.
public Method | updateFromPresStateMetadata | Updates the object from DICOM Presentation State metadata.
Top

Protected Methods

 | Name | Description
protected Method | onDisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
protected Method | onPropertyChanged | Called by subclasses when their properties change.
Top

See Also

Reference

ImGearDICOMDisplaySettings Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMDisplaySettings Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : ImGearDICOMDisplaySettings Constructor

Glossary Item Box

Initializes a new instance of the ImGearDICOMDisplaySettings class object.

Syntax

public ImGearDICOMDisplaySettings()

Return Value

The new instance of ImGearDICOMDisplaySettings class object.

This constructor creates new instance of ImGearDICOMDisplaySettings class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDICOMDisplaySettings Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMDisplaySettings Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Methods

Name | Description
public Method | buildSummaryLUT | Builds a standalone com.accusoft.imagegear.core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.
public Method | clone | Creates a deep copy of the ImGearDICOMDisplaySettings class object.
public Method getDisplaySummaryLUT Returns summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This value concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

public Method isInverted Returns a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

public Method | setAutoVOITransform | Automatically calculates VOI transform based on image's contrast range.
public Method setDisplaySummaryLUT Sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This method concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

public Method setInverted Sets a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

public Method | updateDisplaySummaryLUT | Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.
public Method | updateFromMetadata | Updates the object from DICOM metadata.
public Method | updateFromPresStateMetadata | Updates the object from DICOM Presentation State metadata.
Top

Protected Methods

 | Name | Description
protected Method | onDisplaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
protected Method | onPropertyChanged | Called by subclasses when their properties change.
Top

See Also

Reference

ImGearDICOMDisplaySettings Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

buildSummaryLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : buildSummaryLUT Method
dib
DIB for which the DisplaySummaryLUT is to be built.

Glossary Item Box

Builds a standalone com.accusoft.imagegear.core.ImGearLUT class object based on the transforms that are present in the ImGearDICOMDisplaySettings class object.

Syntax

public ImGearLUT buildSummaryLUT(
   ImGearDIB dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

Return Value

ImGearLUT object.

Transforms are applied in the following order:

  1. Modality
  2. VOI
  3. Inverted
  4. Presentation LUT
  5. Standard Display LUT

Resulting com.accusoft.imagegear.core.ImGearLUT class object has input and output depths equal to bit depth of the first image channel. Use this method to build a LUT that will not change image bit depths after being applied to the image.

com.accusoft.imagegear.core.ImGearDIB com.accusoft.imagegear.core.ImGearLUT

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : clone Method

Glossary Item Box

Creates a deep copy of the ImGearDICOMDisplaySettings class object.

Syntax

public ImGearDICOMDisplaySettings clone()

Return Value

The new instance of ImGearDICOMDisplaySettings class object.

This method creates a deep copy of the ImGearDICOMDisplaySettings class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

clonePropertyChangeListeners Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : clonePropertyChangeListeners Method
from

Glossary Item Box

Syntax

protected void clonePropertyChangeListeners(
   AbstractPropertiesPosessor from
)

Parameters

from

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

getDisplaySummaryLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : getDisplaySummaryLUT Method

Glossary Item Box

Returns summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This value concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

Syntax

public ImGearLUT getDisplaySummaryLUT()

Return Value

com.accusoft.imagegear.core.ImGearLUT class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

isInverted Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : isInverted Method

Glossary Item Box

Returns a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

Syntax

public boolean isInverted()

Return Value

Boolean value.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

onDisplaySummaryLUTUpdated Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : onDisplaySummaryLUTUpdated Method
e
Event arguments.

Glossary Item Box

Occurs when the display summary LUT is changed.

Syntax

protected void onDisplaySummaryLUTUpdated(
   ImGearEventArgs e
)

Parameters

e
Event arguments.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

onPropertyChanged Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : onPropertyChanged Method
name
The name of the property.

Glossary Item Box

Called by subclasses when their properties change.

Syntax

protected void onPropertyChanged(
   java.lang.String name
)

Parameters

name
The name of the property.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

propertyChanged Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : propertyChanged Method
name

Glossary Item Box

Syntax

protected void propertyChanged(
   java.lang.String name
)

Parameters

name

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

setAutoVOITransform Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : setAutoVOITransform Method
page
Page which minimum and maximum values are obtained to build the transform.

This method automatically calculates the linear VOI transform coefficients (Window Center and Width) based on image minimum and maximum values. It takes image's ROI (Region Of Interest) into account.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Automatically calculates VOI transform based on image's contrast range.

Syntax

public void setAutoVOITransform(
   ImGearRasterPage page
)

Parameters

page
Page which minimum and maximum values are obtained to build the transform.

This method automatically calculates the linear VOI transform coefficients (Window Center and Width) based on image minimum and maximum values. It takes image's ROI (Region Of Interest) into account.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

setDisplaySummaryLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : setDisplaySummaryLUT Method
value
com.accusoft.imagegear.core.ImGearLUT class object.

Glossary Item Box

Sets summary LUT based on all settings of the ImGearDICOMDisplaySettings class object.

This method concatenates all transforms that are present in the ImGearDICOMDisplaySettings class object and builds a summary LUT. Display code does not check any other transforms of the ImGearDICOMDisplaySettings class, but uses this LUT to display medical images with proper contrast.

If the application changes any members of ImGearDICOMDisplaySettings class, it will call UpdateDisplaySummaryLUT method to allow display make use of the changed settings.

com.accusoft.imagegear.core.ImGearLUT

Syntax

public void setDisplaySummaryLUT(
   ImGearLUT value
)

Parameters

value
com.accusoft.imagegear.core.ImGearLUT class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

setInverted Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : setInverted Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether image contrast is inverted.

This value tells whether the image shall be displayed with inverted contrast. ImageGear sets this value to true for images that have Photometric Interpretation set to MONOCHROME1, or Presentation LUT set to INVERSE.

UpdateDisplaySummaryLUT method takes this value into account when it builds the summary LUT.

The default value is false.

Syntax

public void setInverted(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

subscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : subscribeToPropertyChangeNotifications Method
listener
The implementation for Image Gear for Java to call when a property changes.

Glossary Item Box

Allows clients to add their listener implementation to be notified of changes.

Syntax

public void subscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The implementation for Image Gear for Java to call when a property changes.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

unsubscribeToPropertyChangeNotifications Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : unsubscribeToPropertyChangeNotifications Method
listener
The instance of the listener to remove.

Glossary Item Box

Allows clients to remove their listeners.

Syntax

public void unsubscribeToPropertyChangeNotifications(
   IImGearPropertyChangedListener listener
)

Parameters

listener
The instance of the listener to remove.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

updateDisplaySummaryLUT Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : updateDisplaySummaryLUT Method
dib
DIB for which the DisplaySummaryLUT is to be built.

This method updates UpdateDisplaySummaryLUT setting based on the transforms that are present in the ImGearDICOMDisplaySettings class object.

Transforms are applied in the following order:

Modality

VOIInvertedPresentation LUTStandard Display LUT

Resulting UpdateDisplaySummaryLUT setting has input depth equal to image bit depth and output depth equal to grayscale depth of the display device (8).

com.accusoft.imagegear.core.ImGearDIB

Glossary Item Box

Updates DisplaySummaryLUT with current settings of the ImGearDICOMDisplaySettings class members.

Syntax

public void updateDisplaySummaryLUT(
   ImGearDIB dib
)

Parameters

dib
DIB for which the DisplaySummaryLUT is to be built.

This method updates UpdateDisplaySummaryLUT setting based on the transforms that are present in the ImGearDICOMDisplaySettings class object.

Transforms are applied in the following order:

Modality

VOIInvertedPresentation LUTStandard Display LUT

Resulting UpdateDisplaySummaryLUT setting has input depth equal to image bit depth and output depth equal to grayscale depth of the display device (8).

com.accusoft.imagegear.core.ImGearDIB

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

updateFromMetadata Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : updateFromMetadata Method
metadata
DICOM Metadata, from which display settings shall be obtained.

This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted

Presentation State metadata uses a different structure than metadata of a DICOM image. To update ImGearDICOMDisplaySettings class from presentation state metadata, use updateFromPresStateMetadata(ImGearMetadataHead) method.

NOTE:

This method does not update DisplaySummaryLUT setting. Use updateDisplaySummaryLUT method for this.

com.accusoft.imagegear.core.ImGearMetadataHead

Glossary Item Box

Updates the object from DICOM metadata.

Syntax

public void updateFromMetadata(
   ImGearMetadataHead metadata
)

Parameters

metadata
DICOM Metadata, from which display settings shall be obtained.

This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted

Presentation State metadata uses a different structure than metadata of a DICOM image. To update ImGearDICOMDisplaySettings class from presentation state metadata, use updateFromPresStateMetadata(ImGearMetadataHead) method.

NOTE:

This method does not update DisplaySummaryLUT setting. Use updateDisplaySummaryLUT method for this.

com.accusoft.imagegear.core.ImGearMetadataHead

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

updateFromPresStateMetadata Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : updateFromPresStateMetadata Method
metadata
Presentation State metadata from which display settings shall be obtained.

This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted
  • Presentation LUT

com.accusoft.imagegear.core.ImGearMetadataHead

Glossary Item Box

Updates the object from DICOM Presentation State metadata.

Syntax

public void updateFromPresStateMetadata(
   ImGearMetadataHead metadata
)

Parameters

metadata
Presentation State metadata from which display settings shall be obtained.

This method updates ImGearDICOMDisplaySettings class object from DICOM metadata. It sets the following members:

  • Modality
  • VOI
  • Inverted
  • Presentation LUT

com.accusoft.imagegear.core.ImGearMetadataHead

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDICOMDisplaySettings Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMDisplaySettings Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMDisplaySettings members.

Public Fields

 | Name | Description
public Field | displaySummaryLUTUpdated | Occurs when the display summary LUT is changed.
public Field | modality | Provides access to Modality transform. ImGearModalityTransform class object. The default value is null. ImGearModalityTransform
public Field | presentationLUT | Provides access to Presentation LUT. com.accusoft.imagegear.core.ImGearFullLUT class object. The default value is null. com.accusoft.imagegear.core.ImGearFullLUT
public Field | standardDisplayLUT | Provides access to Standard Display LUT. com.accusoft.imagegear.core.ImGearFullLUT class object. The default value is null. com.accusoft.imagegear.core.ImGearFullLUT
public Field | voi | Provides access to VOI transform. ImGearVOITransform class object. This member provides access to DICOM Value Of Interest (VOI) transform. The default value is null. ImGearVOITransform
Top

See Also

Reference

ImGearDICOMDisplaySettings Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

displaySummaryLUTUpdated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : displaySummaryLUTUpdated Field

Glossary Item Box

Occurs when the display summary LUT is changed.

Syntax

public com.accusoft.imagegear.utility.events.IImGearEvent<ImGearEventArgs> displaySummaryLUTUpdated

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

modality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : modality Field

Glossary Item Box

Provides access to Modality transform.

ImGearModalityTransform class object.

The default value is null.

ImGearModalityTransform

Syntax

public ImGearModalityTransform modality

Return Value

ImGearModalityTransform class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

presentationLUT Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : presentationLUT Field

Glossary Item Box

Provides access to Presentation LUT.

com.accusoft.imagegear.core.ImGearFullLUT class object.

The default value is null.

com.accusoft.imagegear.core.ImGearFullLUT

Syntax

public ImGearFullLUT presentationLUT

Return Value

com.accusoft.imagegear.core.ImGearFullLUT class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

propertyChangedHelper Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : propertyChangedHelper Field

Glossary Item Box

Syntax

protected NotifyPropertyChangedHelper propertyChangedHelper

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

standardDisplayLUT Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : standardDisplayLUT Field

Glossary Item Box

Provides access to Standard Display LUT.

com.accusoft.imagegear.core.ImGearFullLUT class object.

The default value is null.

com.accusoft.imagegear.core.ImGearFullLUT

Syntax

public ImGearFullLUT standardDisplayLUT

Return Value

com.accusoft.imagegear.core.ImGearFullLUT class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

voi Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMDisplaySettings Class : voi Field

Glossary Item Box

Provides access to VOI transform.

ImGearVOITransform class object.

This member provides access to DICOM Value Of Interest (VOI) transform.

The default value is null.

ImGearVOITransform

Syntax

public ImGearVOITransform voi

Return Value

ImGearVOITransform class object.

See Also

Reference

ImGearDICOMDisplaySettings Class
ImGearDICOMDisplaySettings Members


%%PageItemTitle%%

ImGearDICOMTagsIDs Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMTagsIDs Class

Glossary Item Box

Specifies DICOM tag identifiers.

Object Model

ImGearDICOMTagsIDs ClassImGearDICOMTagsIDs Class

Syntax

public class ImGearDICOMTagsIDs
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearDICOMTagsIDs

See Also

Reference

ImGearDICOMTagsIDs Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDICOMTagsIDs Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMTagsIDs Class

Glossary Item Box

The following tables list the members exposed by ImGearDICOMTagsIDs.

Public Constructors

 | Name | Description
public Constructor | ImGearDICOMTagsIDs Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | AbsoluteChannelDisplayScale | Absolute Channel Display Scale.
public Field | AbstractPriorCodeSequence | Abstract Prior Code Sequence.
public Field | AbstractPriorValue | Abstract Prior Value.
public Field | AccessionNumber | Accession Number.
public Field | AccessoryCode | Accessory Code.
public Field | AcquiredImageAreaDoseProduct | Acquired Image Area Dose Product.
public Field | AcquisitionComments | Acquisition Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionContextDescription | Acquisition Context Description.
public Field | AcquisitionContextSequence | Acquisition Context Sequence.
public Field | AcquisitionContrast | Acquisition Contrast.
public Field | AcquisitionDate | Acquisition Date.
public Field | AcquisitionDateTime | Acquisition DateTime.
public Field | AcquisitionDeviceProcessingCode | Acquisition Device Processing Code.
public Field | AcquisitionDeviceProcessingDescription | Acquisition Device Processing Description.
public Field | AcquisitionDeviceTypeCodeSequence | Acquisition Device Type Code Sequence.
public Field | AcquisitionDuration | Acquisition Duration.
public Field | AcquisitionIndex | Acquisition Index.
public Field | AcquisitionMatrix | Acquisition Matrix.
public Field | AcquisitionNumber | Acquisition Number.
public Field | AcquisitionProtocolDescription | Acquisition Protocol Description.
public Field | AcquisitionProtocolName | Acquisition Protocol Name.
public Field | AcquisitionsInSeries | Acquisitions in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionsInStudy | Acquisitions in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionStartCondition | Acquisition Start Condition.
public Field | AcquisitionStartConditionData | Acquisition Start Condition Data.
public Field | AcquisitionTerminationCondition | Acquisition Termination Condition.
public Field | AcquisitionTerminationConditionData | Acquisition Termination Condition Data.
public Field | AcquisitionTime | Acquisition Time.
public Field | AcquisitionTimeSynchronized | Acquisition Time Synchronized.
public Field | AcquisitionType | Acquisition Type.
public Field | AcrossScanSpatialResolution | Across-scan Spatial Resolution.
public Field | ActionTypeID | Action Type ID.
public Field | ActiveSourceDiameter | Active Source Diameter.
public Field | ActiveSourceLength | Active Source Length.
public Field | ActualCardiacTriggerDelayTime | Actual Cardiac Trigger Delay Time.
public Field | ActualFrameDuration | Actual Frame Duration.
public Field | ActualHumanPerformersSequence | Actual Human Performers Sequence.
public Field | ActualRespiratoryTriggerDelayTime | Actual Respiratory Trigger Delay Time.
public Field | AdaptiveMapFormat | Adaptive Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddGrayScale | Add Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddIntermediateSequence | Add Intermediate Sequence.
public Field | AdditionalDrugSequence | Additional Drug Sequence.
public Field | AdditionalPatientHistory | Additional Patient History.
public Field | AddNearSequence | Add Near Sequence.
public Field | AddOtherSequence | Add Other Sequence.
public Field | AddPower | Add Power.
public Field | Address | Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddressTrial | Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AdministrationRouteCodeSequence | Administration Route Code Sequence.
public Field | AdmissionID | Admission ID.
public Field | AdmittingDate | Admitting Date.
public Field | AdmittingDiagnosesCodeSequence | Admitting Diagnoses Code Sequence.
public Field | AdmittingDiagnosesDescription | Admitting Diagnoses Description.
public Field | AdmittingTime | Admitting Time.
public Field | AffectedSOPClassUID | Affected SOP Class UID.
public Field | AffectedSOPInstanceUID | Affected SOP Instance UID.
public Field | AlertCodeSequence | Alert Code Sequence.
public Field | AlgorithmDescription | Algorithm Description.
public Field | AlgorithmFamilyCodeSequence | Algorithm Family Code Sequence.
public Field | AlgorithmName | Algorithm Name.
public Field | AlgorithmNameCodeSequence | Algorithm Name Code Sequence.
public Field | AlgorithmParameters | Algorithm Parameters.
public Field | AlgorithmType | Algorithm Type.
public Field | AlgorithmVersion | Algorithm Version.
public Field | AliasedDataType | Aliased Data Type.
public Field | Allergies | Allergies value.
public Field | AllowLossyCompression | Allow Lossy Compression.
public Field | AllowMediaSplitting | Allow Media Splitting.
public Field | AlongScanSpatialResolution | Along-scan Spatial Resolution.
public Field | AlphaLUTTransferFunction | Alpha LUT Transfer Function.
public Field | AlphaPaletteColorLookupTableData | Alpha Palette Color Lookup Table Data.
public Field | AlphaPaletteColorLookupTableDescriptor | Alpha Palette Color Lookup Table Descriptor.
public Field | AlternateContainerIdentifierSequence | Alternate Container Identifier Sequence.
public Field | AlternateContentDescriptionSequence | Alternate Content Description Sequence.
public Field | AlternateRepresentationSequence | Alternate Representation Sequence.
public Field | AnatomicalOrientationType | Anatomical Orientation Type.
public Field | AnatomicApproachDirectionCodeSequence | Anatomic Approach Direction Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicLocationOfExaminingInstrumentCodeSequence | Anatomic Location Of Examining Instrument Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicLocationOfExaminingInstrumentDescription | Anatomic Location Of Examining Instrument Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPerspectiveCodeSequence | Anatomic Perspective Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPerspectiveDescription | Anatomic Perspective Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPortalOfEntranceCodeSequence | Anatomic Portal Of Entrance Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicRegionModifierSequence | Anatomic Region Modifier Sequence.
public Field | AnatomicRegionSequence | Anatomic Region Sequence.
public Field | AnatomicStructure | Anatomic Structure.
public Field | AnatomicStructureSpaceOrRegionCodeSequence | Anatomic Structure Space Or Region Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicStructureSpaceOrRegionModifierCodeSequence | Anatomic Structure Space Or Region Modifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicStructureSpaceOrRegionSequence | Anatomic Structure, Space or Region Sequence.
public Field | AnchorPoint | Anchor Point.
public Field | AnchorPointAnnotationUnits | Anchor Point Annotation Units.
public Field | AnchorPointVisibility | Anchor Point Visibility.
public Field | AngioFlag | Angio Flag.
public Field | AngleNumber | Angle Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AngularPosition | Angular Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AngularStep | Angular Step.
public Field | AngularViewVector | Angular View Vector.
public Field | AnnotationContentSequence | Annotation Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnnotationDisplayFormatID | Annotation Display Format ID.
public Field | AnnotationFlag | Annotation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnnotationGroupNumber | Annotation Group Number.
public Field | AnnotationPosition | Annotation Position.
public Field | AnodeTargetMaterial | Anode Target Material.
public Field | ApexPosition | Apex Position.
public Field | ApplicableFrameRange | Applicable Frame Range.
public Field | ApplicableSafetyStandardAgency | Applicable Safety Standard Agency.
public Field | ApplicableSafetyStandardDescription | Applicable Safety Standard Description.
public Field | ApplicationManufacturer | Application Manufacturer.
public Field | ApplicationMaximumRepaintTime | Application Maximum Repaint Time.
public Field | ApplicationName | Application Name.
public Field | ApplicationSetupCheck | Application Setup Check.
public Field | ApplicationSetupManufacturer | Application Setup Manufacturer.
public Field | ApplicationSetupName | Application Setup Name.
public Field | ApplicationSetupNumber | Application Setup Number.
public Field | ApplicationSetupSequence | Application Setup Sequence.
public Field | ApplicationSetupType | Application Setup Type.
public Field | ApplicationVersion | Application Version.
public Field | ApplicatorDescription | Applicator Description.
public Field | ApplicatorID | Applicator ID.
public Field | ApplicatorSequence | Applicator Sequence.
public Field | ApplicatorType | Applicator Type.
public Field | ApprovalStatus | Approval Status.
public Field | ApprovalStatusDateTime | Approval Status DateTime.
public Field | ApprovalStatusFurtherDescription | Approval Status Further Description.
public Field | Arbitrary | Arbitrary. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ArchiveRequested | Archive Requested.
public Field | AssigningAgencyOrDepartmentCodeSequence | Assigning Agency or Department Code Sequence.
public Field | AssigningFacilitySequence | Assigning Facility Sequence.
public Field | AssigningJurisdictionCodeSequence | Assigning Jurisdiction Code Sequence.
public Field | AttachedContours | Attached Contours.
public Field | AttenuationCorrected | Attenuation Corrected.
public Field | AttenuationCorrectionMethod | Attenuation Correction Method.
public Field | AttenuationCorrectionSource | Attenuation Correction Source.
public Field | AttenuationCorrectionTemporalRelationship | Attenuation Correction Temporal Relationship.
public Field | AttributeIdentifierList | Attribute Identifier List.
public Field | AttributeItemSelector | Attribute Item Selector.
public Field | AttributeModificationDateTime | Attribute Modification DateTime.
public Field | AttributeOccurrencePointer | Attribute Occurrence Pointer.
public Field | AttributeOccurrencePrivateCreator | Attribute Occurrence Private Creator.
public Field | AttributeOccurrenceSequence | Attribute Occurrence Sequence.
public Field | AudioComments | Audio Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioSampleData | Audio Sample Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioSampleFormat | Audio Sample Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioType | Audio Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AuthorizationEquipmentCertificationNumber | Authorization Equipment Certification Number.
public Field | AuthorObserverSequence | Author Observer Sequence.
public Field | AutorefractionLeftEyeSequence | Autorefraction Left Eye Sequence.
public Field | AutorefractionRightEyeSequence | Autorefraction Right Eye Sequence.
public Field | AveragePulseWidth | Average Pulse Width.
public Field | AxialAcceptance | Axial Acceptance.
public Field | AxialDetectorDimension | Axial Detector Dimension.
public Field | AxialLengthOfTheEye | Axial Length of the Eye.
public Field | AxialMash | Axial Mash.
public Field | AxisLabels | Axis Labels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AxisOfRotation | Axis of Rotation.
public Field | AxisUnits | Axis Units. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BackgroundColor | Background Color.
public Field | BarcodeSymbology | Barcode Symbology.
public Field | BarcodeValue | Barcode Value.
public Field | BaselineCorrection | Baseline Correction.
public Field | BasicColorImageSequence | Basic Color Image Sequence.
public Field | BasicGrayscaleImageSequence | Basic Grayscale Image Sequence.
public Field | BeamAngle | Beam Angle.
public Field | BeamCurrentModulationID | Beam Current Modulation ID.
public Field | BeamDescription | Beam Description.
public Field | BeamDose | Beam Dose.
public Field | BeamDosePointDepth | Beam Dose Point Depth.
public Field | BeamDosePointEquivalentDepth | Beam Dose Point Equivalent Depth.
public Field | BeamDosePointSSD | Beam Dose Point SSD.
public Field | BeamDoseSpecificationPoint | Beam Dose Specification Point.
public Field | BeamLimitingDeviceAngle | Beam Limiting Device Angle.
public Field | BeamLimitingDeviceAngleTolerance | Beam Limiting Device Angle Tolerance.
public Field | BeamLimitingDeviceLeafPairsSequence | Beam Limiting Device Leaf Pairs Sequence.
public Field | BeamLimitingDevicePositionSequence | Beam Limiting Device Position Sequence.
public Field | BeamLimitingDevicePositionTolerance | Beam Limiting Device Position Tolerance.
public Field | BeamLimitingDeviceRotationDirection | Beam Limiting Device Rotation Direction.
public Field | BeamLimitingDeviceSequence | Beam Limiting Device Sequence.
public Field | BeamLimitingDeviceToleranceSequence | Beam Limiting Device Tolerance Sequence.
public Field | BeamMeterset | Beam Meterset.
public Field | BeamName | Beam Name.
public Field | BeamNumber | Beam Number.
public Field | BeamOrderIndex | Beam Order Index.
public Field | BeamSequence | Beam Sequence.
public Field | BeamStopperPosition | Beam Stopper Position.
public Field | BeamTaskSequence | Beam Task Sequence.
public Field | BeamTaskType | Beam Task Type.
public Field | BeamType | Beam Type.
public Field | BeatRejectionFlag | Beat Rejection Flag.
public Field | BillingItemSequence | Billing Item Sequence.
public Field | BillingProcedureStepSequence | Billing Procedure Step Sequence.
public Field | BillingSuppliesAndDevicesSequence | Billing Supplies and Devices Sequence.
public Field | BiPlaneAcquisitionSequence | Bi-Plane Acquisition Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsAllocated | Bits Allocated.
public Field | BitsForCodeWord | Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsGrouped | Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsMappedToColorLookupTable | Bits Mapped to Color Lookup Table.
public Field | BitsStored | Bits Stored.
public Field | BlendingLookupTableData | Blending Lookup Table Data.
public Field | BlendingLookupTableDescriptor | Blending Lookup Table Descriptor.
public Field | BlendingLUT1Sequence | Blending LUT 1 Sequence.
public Field | BlendingLUT1TransferFunction | Blending LUT 1 Transfer Function.
public Field | BlendingLUT2Sequence | Blending LUT 2 Sequence.
public Field | BlendingLUT2TransferFunction | Blending LUT 2 Transfer Function.
public Field | BlendingOperationType | Blending Operation Type.
public Field | BlendingPosition | Blending Position.
public Field | BlendingSequence | Blending Sequence.
public Field | BlendingWeightConstant | Blending Weight Constant.
public Field | BlockColumns | Block Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockData | Block Data.
public Field | BlockDivergence | Block Divergence.
public Field | BlockedPixels | Blocked Pixels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockMountingPosition | Block Mounting Position.
public Field | BlockName | Block Name.
public Field | BlockNumber | Block Number.
public Field | BlockNumberOfPoints | Block Number of Points.
public Field | BlockRows | Block Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockSequence | Block Sequence.
public Field | BlockThickness | Block Thickness.
public Field | BlockTransmission | Block Transmission.
public Field | BlockTrayID | Block Tray ID.
public Field | BlockType | Block Type.
public Field | BloodSignalNulling | Blood Signal Nulling.
public Field | BluePaletteColorLookupTableData | Blue Palette Color Lookup Table Data.
public Field | BluePaletteColorLookupTableDescriptor | Blue Palette Color Lookup Table Descriptor.
public Field | BodyPartExamined | Body Part Examined.
public Field | BodyPartThickness | Body Part Thickness.
public Field | BolusDescription | Bolus Description.
public Field | BolusID | Bolus Identifier.
public Field | BoneThermalIndex | Bone Thermal Index.
public Field | BorderDensity | Border Density.
public Field | Borders | Borders. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BoundingBoxAnnotationUnits | Bounding Box Annotation Units.
public Field | BoundingBoxBottomRightHandCorner | Bounding Box Bottom Right Hand Corner.
public Field | BoundingBoxTextHorizontalJustification | Bounding Box Text Horizontal Justification.
public Field | BoundingBoxTopLeftHandCorner | Bounding Box Top Left Hand Corner.
public Field | BrachyAccessoryDeviceID | Brachy Accessory Device ID.
public Field | BrachyAccessoryDeviceName | Brachy Accessory Device Name.
public Field | BrachyAccessoryDeviceNominalThickness | Brachy Accessory Device Nominal Thickness.
public Field | BrachyAccessoryDeviceNominalTransmission | Brachy Accessory Device Nominal Transmission.
public Field | BrachyAccessoryDeviceNumber | Brachy Accessory Device Number.
public Field | BrachyAccessoryDeviceSequence | Brachy Accessory Device Sequence.
public Field | BrachyAccessoryDeviceType | Brachy Accessory Device Type.
public Field | BrachyApplicationSetupDose | Brachy Application Setup Dose.
public Field | BrachyApplicationSetupDoseSpecificationPoint | Brachy Application Setup Dose Specification Point.
public Field | BrachyControlPointDeliveredSequence | Brachy Control Point Delivered Sequence.
public Field | BrachyControlPointSequence | Brachy Control Point Sequence.
public Field | BrachyReferencedDoseReferenceSequence | Brachy Referenced Dose Reference Sequence.
public Field | BrachyTreatmentTechnique | Brachy Treatment Technique.
public Field | BrachyTreatmentType | Brachy Treatment Type.
public Field | BranchOfService | Branch of Service.
public Field | BreastImplantPresent | Breast Implant Present.
public Field | BreedRegistrationNumber | Breed Registration Number.
public Field | BreedRegistrationSequence | Breed Registration Sequence.
public Field | BreedRegistryCodeSequence | Breed Registry Code Sequence.
public Field | BulkMotionCompensationTechnique | Bulk Motion Compensation Technique.
public Field | BulkMotionSignalSource | Bulk Motion Signal Source.
public Field | BulkMotionStatus | Bulk Motion Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BurnedInAnnotation | Burned In Annotation.
public Field | CalciumScoringMassFactorDevice | Calcium Scoring Mass Factor Device.
public Field | CalciumScoringMassFactorPatient | Calcium Scoring Mass Factor Patient.
public Field | CalculatedAnatomyThickness | Calculated Anatomy Thickness.
public Field | CalculatedDoseReferenceDescription | Calculated Dose Reference Description.
public Field | CalculatedDoseReferenceDoseValue | Calculated Dose Reference Dose Value.
public Field | CalculatedDoseReferenceNumber | Calculated Dose Reference Number.
public Field | CalculatedDoseReferenceSequence | Calculated Dose Reference Sequence.
public Field | CalculatedFrameList | Calculated Frame List.
public Field | CalibrationDataSequence | Calibration Data Sequence.
public Field | CalibrationImage | Calibration Image.
public Field | CalibrationSequence | Calibration Sequence.
public Field | CardiacBeatRejectionTechnique | Cardiac Beat Rejection Technique.
public Field | CardiacCyclePosition | Cardiac Cycle Position.
public Field | CardiacFramingType | Cardiac Framing Type.
public Field | CardiacNumberOfImages | Cardiac Number of Images.
public Field | CardiacRRintervalSpecified | Cardiac R-R Interval Specified.
public Field | CardiacSignalSource | Cardiac Signal Source.
public Field | CardiacSynchronizationSequence | Cardiac Synchronization Sequence.
public Field | CardiacSynchronizationTechnique | Cardiac Synchronization Technique.
public Field | CarmPositionerTabletopRelationship | C-arm Positioner Tabletop Relationship.
public Field | CassetteID | Cassette ID.
public Field | CassetteOrientation | Cassette Orientation.
public Field | CassetteSize | Cassette Size.
public Field | CenterOfCircularCollimator | Center of Circular Collimator.
public Field | CenterofCircularExposureControlSensingRegion | Center of Circular Exposure Control Sensing Region.
public Field | CenterOfCircularShutter | Center of Circular Shutter.
public Field | CenterOfRotation | Center of Rotation.
public Field | CenterOfRotationOffset | Center of Rotation Offset.
public Field | CertificateOfSigner | Certificate of Signer.
public Field | CertificateType | Certificate Type.
public Field | CertifiedTimestamp | Certified Timestamp.
public Field | CertifiedTimestampType | Certified Timestamp Type.
public Field | ChannelBaseline | Channel Baseline.
public Field | ChannelDefinitionSequence | Channel Definition Sequence.
public Field | ChannelDerivationDescription | Channel Derivation Description.
public Field | ChannelDescriptionCodeSequence | Channel Description Code Sequence.
public Field | ChannelDisplaySequence | Channel Display Sequence.
public Field | ChannelIdentificationCode | Channel Identification Code.
public Field | ChannelLabel | Channel Label.
public Field | ChannelLength | Channel Length.
public Field | ChannelMaximumValue | Channel Maximum Value.
public Field | ChannelMinimumValue | Channel Minimum Value.
public Field | ChannelMode | Channel Mode.
public Field | ChannelNumber | Channel Number.
public Field | ChannelOffset | Channel Offset.
public Field | ChannelPosition | Channel Position.
public Field | ChannelRecommendedDisplayCIELabValue | Channel Recommended Display CIELab Value.
public Field | ChannelSampleSkew | Channel Sample Skew.
public Field | ChannelSensitivity | Channel Sensitivity.
public Field | ChannelSensitivityCorrectionFactor | Channel Sensitivity Correction Factor.
public Field | ChannelSensitivityUnitsSequence | Channel Sensitivity Units Sequence.
public Field | ChannelSequence | Channel Sequence.
public Field | ChannelShieldID | Channel Shield ID.
public Field | ChannelShieldName | Channel Shield Name.
public Field | ChannelShieldNominalThickness | Channel Shield Nominal Thickness.
public Field | ChannelShieldNominalTransmission | Channel Shield Nominal Transmission.
public Field | ChannelShieldNumber | Channel Shield Number.
public Field | ChannelShieldSequence | Channel Shield Sequence.
public Field | ChannelSourceModifiersSequence | Channel Source Modifiers Sequence.
public Field | ChannelSourceSequence | Channel Source Sequence.
public Field | ChannelStatus | Channel Status.
public Field | ChannelTimeSkew | Channel Time Skew.
public Field | ChannelTotalTime | Channel Total Time.
public Field | ChannelWidth | Channel Width.
public Field | ChemicalShiftMaximumIntegrationLimitInppm | Chemical Shift Maximum Integration Limit in ppm.
public Field | ChemicalShiftMinimumIntegrationLimitInppm | Chemical Shift Minimum Integration Limit in ppm.
public Field | ChemicalShiftReference | Chemical Shift Reference.
public Field | ChemicalShiftSequence | Chemical Shift Sequence.
public Field | ChemicalShiftsMaximumIntegrationLimitInHz | Chemical Shifts Maximum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ChemicalShiftsMinimumIntegrationLimitInHz | Chemical Shifts Minimum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CineRate | Cine Rate.
public Field | CineRelativetoRealTime | Cine Relative to Real-Time.
public Field | ClinicalTrialCoordinatingCenterName | Clinical Trial Coordinating Center Name.
public Field | ClinicalTrialProtocolEthicsCommitteeApprovalNumber | Clinical Trial Protocol Ethics Committee Approval Number.
public Field | ClinicalTrialProtocolEthicsCommitteeName | Clinical Trial Protocol Ethics Committee Name.
public Field | ClinicalTrialProtocolID | Clinical Trial Protocol ID.
public Field | ClinicalTrialProtocolName | Clinical Trial Protocol Name.
public Field | ClinicalTrialSeriesDescription | Clinical Trial Series Description.
public Field | ClinicalTrialSeriesID | Clinical Trial Series ID.
public Field | ClinicalTrialSiteID | Clinical Trial Site ID.
public Field | ClinicalTrialSiteName | Clinical Trial Site Name.
public Field | ClinicalTrialSponsorName | Clinical Trial Sponsor Name.
public Field | ClinicalTrialSubjectID | Clinical Trial Subject ID.
public Field | ClinicalTrialSubjectReadingID | Clinical Trial Subject Reading ID.
public Field | ClinicalTrialTimePointDescription | Clinical Trial Time Point Description.
public Field | ClinicalTrialTimePointID | Clinical Trial Time Point ID.
public Field | CodeLabel | Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeMeaning | Code Meaning.
public Field | CodeNumberFormat | Code Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeTableLocation | Code Table Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeValue | Code Value.
public Field | CodingSchemeDesignator | Coding Scheme Designator.
public Field | CodingSchemeExternalID | Coding Scheme External ID.
public Field | CodingSchemeIdentificationSequence | Coding Scheme Identification Sequence.
public Field | CodingSchemeName | Coding Scheme Name.
public Field | CodingSchemeRegistry | Coding Scheme Registry.
public Field | CodingSchemeResponsibleOrganization | Coding Scheme Responsible Organization.
public Field | CodingSchemeUID | Coding Scheme UID.
public Field | CodingSchemeVersion | Coding Scheme Version.
public Field | CoefficientCoding | Coefficient Coding. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientCodingPointers | Coefficient Coding Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDDN | Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDHN | Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDVN | Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoincidenceWindowWidth | Coincidence Window Width.
public Field | CollationFlag | Collation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CollimatorGridName | Collimator/grid Name.
public Field | CollimatorLeftVerticalEdge | Collimator Left Vertical Edge.
public Field | CollimatorLowerHorizontalEdge | Collimator Lower Horizontal Edge.
public Field | CollimatorRightVerticalEdge | Collimator Right Vertical Edge.
public Field | CollimatorShape | Collimator Shape.
public Field | CollimatorShapeSequence | Collimator Shape Sequence.
public Field | CollimatorType | Collimator Type.
public Field | CollimatorUpperHorizontalEdge | Collimator Upper Horizontal Edge.
public Field | ColorImagePrintingFlag | Color Image Printing Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ColumnAngulation | Column Angulation.
public Field | ColumnAngulationPatient | Column Angulation (Patient).
public Field | ColumnOverlap | Column Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Columns | Columns. Width of the DICOM image.
public Field | ColumnsForNthOrderCoefficients | Columns For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CommandField | Command Field.
public Field | CommandGroupLength | Command Group Length.
public Field | CommandLengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CommentsOnRadiationDose | Comments on Radiation Dose.
public Field | CommentsOnThePerformedProcedureStep | Comments on the Performed Procedure Step.
public Field | CommentsOnTheScheduledProcedureStep | Comments on the Scheduled Procedure Step.
public Field | CompensatorColumnOffset | Compensator Column Offset.
public Field | CompensatorColumns | Compensator Columns.
public Field | CompensatorDescription | Compensator Description.
public Field | CompensatorDivergence | Compensator Divergence.
public Field | CompensatorID | Compensator ID.
public Field | CompensatorMillingToolDiameter | Compensator Milling Tool Diameter.
public Field | CompensatorMountingPosition | Compensator Mounting Position.
public Field | CompensatorNumber | Compensator Number.
public Field | CompensatorPixelSpacing | Compensator Pixel Spacing.
public Field | CompensatorPosition | Compensator Position.
public Field | CompensatorRelativeStoppingPowerRatio | Compensator Relative Stopping Power Ratio.
public Field | CompensatorRows | Compensator Rows.
public Field | CompensatorSequence | Compensator Sequence.
public Field | CompensatorThicknessData | Compensator Thickness Data.
public Field | CompensatorTransmissionData | Compensator Transmission Data.
public Field | CompensatorType | Compensator Type.
public Field | CompletionFlag | Completion Flag.
public Field | CompletionFlagDescription | Completion Flag Description.
public Field | ComplexImageComponent | Complex Image Component.
public Field | CompressionCode | Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionDescription | Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionForce | Compression Force.
public Field | CompressionLabel | Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionOriginator | Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionRecognitionCode | Compression Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionSequence | Compression Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionStepPointers | Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ConcatenationFrameOffsetNumber | Concatenation Frame Offset Number.
public Field | ConcatenationUID | Concatenation UID.
public Field | ConceptCodeSequence | Concept Code Sequence.
public Field | ConceptNameCodeSequence | Concept Name Code Sequence.
public Field | ConfidentialityCode | Confidentiality Code.
public Field | ConfidentialityConstraint | Confidentiality Constraint on Patient Data Description.
public Field | ConfidentialityConstraintOnPatientDataDescription | Confidentiality Constraint on Patient Data Description.
public Field | ConfigurationInformation | Configuration Information.
public Field | ConfigurationInformationDescription | Configuration Information Description.
public Field | ConsentForClinicalTrialUseSequence | Consent for Clinical Trial Use Sequence.
public Field | ConsentForDistributionFlag | Consent for Distribution Flag.
public Field | ConstantVolumeFlag | Constant Volume Flag.
public Field | ConstraintWeight | Constraint Weight.
public Field | ContactDisplayName | Contact Display Name.
public Field | ContactURI | Contact URI.
public Field | ContainerComponentDescription | Container Component Description.
public Field | ContainerComponentDiameter | Container Component Diameter.
public Field | ContainerComponentID | Container Component ID.
public Field | ContainerComponentLength | Container Component Length.
public Field | ContainerComponentMaterial | Container Component Material.
public Field | ContainerComponentSequence | Container Component Sequence.
public Field | ContainerComponentThickness | Container Component Thickness.
public Field | ContainerComponentTypeCodeSequence | Container Component Type Code Sequence.
public Field | ContainerComponentWidth | Container Component Width.
public Field | ContainerDescription | Container Description.
public Field | ContainerIdentifier | Container Identifier.
public Field | ContainerTypeCodeSequence | Container Type Code Sequence.
public Field | ContentCreatorsIdentificationCodeSequence | Content Creator's Identification Code Sequence.
public Field | ContentCreatorsName | Content Creator's Name.
public Field | ContentDate | Content Date.
public Field | ContentDescription | Content Description.
public Field | ContentItemModifierSequence | Content Item Modifier Sequence.
public Field | ContentLabel | Content Label.
public Field | ContentQualification | Content Qualification.
public Field | ContentSequence | Content Sequence.
public Field | ContentTemplateSequence | Content Template Sequence.
public Field | ContentTime | Content Time.
public Field | ContextGroupExtensionCreatorUID | Context Group Extension Creator UID.
public Field | ContextGroupExtensionFlag | Context Group Extension Flag.
public Field | ContextGroupLocalVersion | Context Group Local Version.
public Field | ContextGroupVersion | Context Group Version.
public Field | ContextIdentifier | Context Identifier.
public Field | ContextUID | Context UID.
public Field | ContinuityOfContent | Continuity Of Content.
public Field | ContourData | Contour Data.
public Field | ContourGeometricType | Contour Geometric Type.
public Field | ContourImageSequence | Contour Image Sequence.
public Field | ContourNumber | Contour Number.
public Field | ContourOffsetVector | Contour Offset Vector.
public Field | ContourSequence | Contour Sequence.
public Field | ContourSlabThickness | Contour Slab Thickness.
public Field | ContourUncertaintyRadius | Contour Uncertainty Radius.
public Field | ContrastAdministrationProfileSequence | Contrast Administration Profile Sequence.
public Field | ContrastBolusAdministrationRouteSequence | Contrast/Bolus Administration Route Sequence.
public Field | ContrastBolusAgent | Contrast/Bolus Agent.
public Field | ContrastBolusAgentAdministered | Contrast/Bolus Agent Administered.
public Field | ContrastBolusAgentDetected | Contrast/Bolus Agent Detected.
public Field | ContrastBolusAgentNumber | Contrast/Bolus Agent Number.
public Field | ContrastBolusAgentPhase | Contrast/Bolus Agent Phase.
public Field | ContrastBolusAgentSequence | Contrast/Bolus Agent Sequence.
public Field | ContrastBolusIngredient | Contrast/Bolus Ingredient.
public Field | ContrastBolusIngredientCodeSequence | Contrast/Bolus Ingredient Code Sequence.
public Field | ContrastBolusIngredientConcentration | Contrast/Bolus Ingredient Concentration.
public Field | ContrastBolusIngredientOpaque | Contrast/Bolus Ingredient Opaque.
public Field | ContrastBolusRoute | Contrast/Bolus Route.
public Field | ContrastBolusStartTime | Contrast/Bolus Start Time.
public Field | ContrastBolusStopTime | Contrast/Bolus Stop Time.
public Field | ContrastBolusTotalDose | Contrast/Bolus Total Dose.
public Field | ContrastBolusUsageSequence | Contrast/Bolus Usage Sequence.
public Field | ContrastBolusVolume | Contrast/Bolus Volume.
public Field | ContrastFlowDuration | Contrast Flow Duration.
public Field | ContrastFlowRate | Contrast Flow Rate.
public Field | ContrastFrameAveraging | Contrast Frame Averaging.
public Field | ContributingEquipmentSequence | Contributing Equipment Sequence.
public Field | ContributingSOPInstancesReferenceSequence | Contributing SOP Instances Reference Sequence.
public Field | ContributingSourcesSequence | Contributing Sources Sequence.
public Field | ContributionDateTime | Contribution Date Time.
public Field | ContributionDescription | Contribution Description.
public Field | ControlPoint3dPosition | Control Point 3D Position.
public Field | ControlPointDeliverySequence | Control Point Delivery Sequence.
public Field | ControlPointIndex | Control Point Index.
public Field | ControlPointOrientation | Control Point Orientation.
public Field | ControlPointRelativePosition | Control Point Relative Position.
public Field | ControlPointSequence | Control Point Sequence.
public Field | ConventionalControlPointVerificationSequence | Conventional Control Point Verification Sequence.
public Field | ConventionalMachineVerificationSequence | Conventional Machine Verification Sequence.
public Field | ConversionType | Conversion Type.
public Field | ConvolutionKernel | Convolution Kernel.
public Field | ConvolutionKernelGroup | Convolution Kernel Group.
public Field | CoordinateGeometricType | Coordinate Geometric Type.
public Field | CoordinateStartValue | Coordinate Start Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoordinateStepValue | Coordinate Step Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoordinateSystemAxisCodeSequence | Coordinate System Axis Code Sequence.
public Field | Copies | Copies. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CornealSize | Corneal Size.
public Field | CorrectedImage | Corrected Image.
public Field | CorrectedParameterSequence | Corrected Parameter Sequence.
public Field | CorrectionValue | Correction Value.
public Field | CountLossNormalizationCorrected | Count Loss Normalization Corrected.
public Field | CountRate | Count Rate.
public Field | CountryOfResidence | Country of Residence.
public Field | CountsAccumulated | Counts Accumulated.
public Field | CountsIncluded | Counts Included. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CountsSource | Counts Source.
public Field | CoverageOfKspace | Coverage of k-Space.
public Field | CranialThermalIndex | Cranial Thermal Index.
public Field | CreationDate | Creation Date.
public Field | CreationTime | Creation Time.
public Field | CreatorVersionUID | Creator Version UID.
public Field | CTAcquisitionDetailsSequence | CT Acquisition Details Sequence.
public Field | CTAcquisitionTypeSequence | CT Acquisition Type Sequence.
public Field | CTAdditionalXRaySourceSequence | CT Additional X-Ray Source Sequence.
public Field | CTDIPhantomTypeCodeSequence | CTDI Phantom Type Code Sequence.
public Field | CTDIvol | The CTDIvol.
public Field | CTExposureSequence | CT Exposure Sequence.
public Field | CTGeometrySequence | CT Geometry Sequence.
public Field | CTImageFrameTypeSequence | CT Image Frame Type Sequence.
public Field | CTPositionSequence | CT Position Sequence.
public Field | CTReconstructionSequence | CT Reconstruction Sequence.
public Field | CTTableDynamicsSequence | CT Table Dynamics Sequence.
public Field | CTXRayDetailsSequence | CT X-Ray Details Sequence.
public Field | CumulativeDoseReferenceCoefficient | Cumulative Dose Reference Coefficient.
public Field | CumulativeDoseToDoseReference | Cumulative Dose to Dose Reference.
public Field | CumulativeMetersetWeight | Cumulative Meterset Weight.
public Field | CumulativeTimeWeight | Cumulative Time Weight.
public Field | CurrentFractionNumber | Current Fraction Number.
public Field | CurrentPatientLocation | Current Patient Location.
public Field | CurrentRequestedProcedureEvidenceSequence | Current Requested Procedure Evidence Sequence.
public Field | CurrentTreatmentStatus | Current Treatment Status.
public Field | CurveActivationLayer | Curve Activation Layer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveData | Curve Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDataDescriptor | Curve Data Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDate | Curve Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDescription | Curve Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDimensions | Curve Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveLabel | Curve Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveNumber | Curve Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveRange | Curve Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveReferencedOverlayGroup | Curve Referenced Overlay Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveReferencedOverlaySequence | Curve Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveTime | Curve Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CustodialOrganizationSequence | Custodial Organization Sequence.
public Field | CylinderAxis | Cylinder Axis.
public Field | CylinderLensPower | Cylinder Lens Power.
public Field | CylinderPower | Cylinder Power.
public Field | CylinderSequence | Cylinder Sequence.
public Field | DataBlock | Data Block. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataBlockDescription | Data Block Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataCollectionCenterPatient | Data Collection Center (Patient).
public Field | DataCollectionDiameter | Data Collection Diameter.
public Field | DataElementsSigned | Data Elements Signed.
public Field | DataFrameAssignmentSequence | Data Frame Assignment Sequence.
public Field | DataInformationSequence | Data Information Sequence.
public Field | DataPathAssignment | Data Path Assignment.
public Field | DataPathID | Data Path ID.
public Field | DataPointColumns | Data Point Columns.
public Field | DataPointRows | Data Point Rows.
public Field | DataRepresentation | Data Representation.
public Field | DataSet | DICOM dataset.
public Field | DataSetSubtype | Data Set Subtype. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataSetTrailingPadding | Data Set Trailing Padding.
public Field | DataSetType | Data Set Type.
public Field | DataStreamEncodingFragment | Data Stream Encoding Fragment.
public Field | DataType | Data Type.
public Field | DataValueRepresentation | Data Value Representation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Date | Date value.
public Field | DateOfLastCalibration | Date of Last Calibration.
public Field | DateOfLastDetectorCalibration | Date of Last Detector Calibration.
public Field | DateOfSecondaryCapture | Date of Secondary Capture.
public Field | DateTime | DateTime value.
public Field | DbDt | The dB/dt.
public Field | DCTLabel | DCT Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DeadTimeCorrected | Dead Time Corrected.
public Field | DeadTimeCorrectionFlag | Dead Time Correction Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DeadTimeFactor | Dead Time Factor.
public Field | DecayCorrected | Decay Corrected.
public Field | DecayCorrection | Decay Correction.
public Field | DecayCorrectionDateTime | Decay Correction DateTime.
public Field | DecayFactor | Decay Factor.
public Field | DecimalVisualAcuity | Decimal Visual Acuity.
public Field | DecimateCropResult | Decimate/Crop Result.
public Field | DecoupledNucleus | De-coupled Nucleus.
public Field | Decoupling | De-coupling value.
public Field | DecouplingChemicalShiftReference | De-coupling Chemical Shift Reference.
public Field | DecouplingFrequency | De-coupling Frequency.
public Field | DecouplingMethod | De-coupling Method.
public Field | DefaultMagnificationType | Default Magnification Type.
public Field | DefaultPrinterResolutionID | Default Printer Resolution ID.
public Field | DefaultSmoothingType | Default Smoothing Type.
public Field | DeformableRegistrationGridSequence | Deformable Registration Grid Sequence.
public Field | DeformableRegistrationSequence | Deformable Registration Sequence.
public Field | DegreeofDilation | Degree of Dilation.
public Field | DeidentificationMethod | De-identification Method.
public Field | DeidentificationMethodCodeSequence | De-identification Method Code Sequence.
public Field | DeletionLock | Deletion Lock.
public Field | DeliveredChannelTotalTime | Delivered Channel Total Time.
public Field | DeliveredMeterset | Delivered Meterset.
public Field | DeliveredNumberofPulses | Delivered Number of Pulses.
public Field | DeliveredPrimaryMeterset | Delivered Primary Meterset.
public Field | DeliveredPulseRepetitionInterval | Delivered Pulse Repetition Interval.
public Field | DeliveredSecondaryMeterset | Delivered Secondary Meterset.
public Field | DeliveredTreatmentTime | Delivered Treatment Time.
public Field | DeliveryMaximumDose | Delivery Maximum Dose.
public Field | DeliveryVerificationImageSequence | Delivery Verification Image Sequence.
public Field | DeliveryWarningDose | Delivery Warning Dose.
public Field | DepthOfScanField | Depth of Scan Field.
public Field | DepthOfTransverseImage | Depth of Transverse Image.
public Field | DepthsOfFocus | Depth(s) of Focus.
public Field | DepthSpatialResolution | Depth Spatial Resolution.
public Field | DerivationCodeSequence | Derivation Code Sequence.
public Field | DerivationDescription | Derivation Description.
public Field | DerivationImageSequence | Derivation Image Sequence.
public Field | DestinationAe | Destination AE. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DetailsOfCoefficients | Details of Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DetectorActivationOffsetFromExposure | Detector Activation Offset From Exposure.
public Field | DetectorActiveDimensions | Detector Active Dimension(s).
public Field | DetectorActiveOrigin | Detector Active Origin.
public Field | DetectorActiveShape | Detector Active Shape.
public Field | DetectorActiveTime | Detector Active Time.
public Field | DetectorBinning | Detector Binning.
public Field | DetectorConditionsNominalFlag | Detector Conditions Nominal Flag.
public Field | DetectorConfiguration | Detector Configuration.
public Field | DetectorDescription | Detector Description.
public Field | DetectorElementPhysicalSize | Detector Element Physical Size.
public Field | DetectorElementSize | Detector Element Size.
public Field | DetectorElementSpacing | Detector Element Spacing.
public Field | DetectorGeometry | Detector Geometry.
public Field | DetectorID | Detector ID.
public Field | DetectorInformationSequence | Detector Information Sequence.
public Field | DetectorLinesOfResponseUsed | Detector Lines of Response Used.
public Field | DetectorManufacturerName | Detector Manufacturer Name.
public Field | DetectorManufacturersModelName | Detector Manufacturers Model Name.
public Field | DetectorMode | Detector Mode.
public Field | DetectorNormalizationCorrection | Detector Normalization Correction.
public Field | DetectorPrimaryAngle | Detector Primary Angle.
public Field | DetectorSecondaryAngle | Detector Secondary Angle.
public Field | DetectorTemperature | Detector Temperature.
public Field | DetectorTimeSinceLastExposure | Detector Time Since Last Exposure.
public Field | DetectorType | Detector Type.
public Field | DetectorVector | Detector Vector.
public Field | DeviceDescription | Device Description.
public Field | DeviceDiameter | Device Diameter.
public Field | DeviceDiameterUnits | Device Diameter Units.
public Field | DeviceID | Device ID.
public Field | DeviceLength | Device Length.
public Field | DeviceSequence | Device Sequence.
public Field | DeviceSerialNumber | Device Serial Number.
public Field | DeviceUID | Device UID.
public Field | DeviceVolume | Device Volume.
public Field | DIALOGReceiver | DIALOG Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DiaphragmPosition | Diaphragm Position.
public Field | DifferentialWaveformSourceModifiers | Differential Waveform Source Modifiers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DiffusionAnisotropyType | Diffusion Anisotropy Type.
public Field | DiffusionBMatrixSequence | Diffusion b-matrix Sequence.
public Field | DiffusionBvalue | Diffusion b-value.
public Field | DiffusionBValueXX | Diffusion b-value XX.
public Field | DiffusionBValueXY | Diffusion b-value XY.
public Field | DiffusionBValueXZ | Diffusion b-value XZ.
public Field | DiffusionBValueYY | Diffusion b-value YY.
public Field | DiffusionBValueYZ | Diffusion b-value YZ.
public Field | DiffusionBValueZZ | Diffusion b-value ZZ.
public Field | DiffusionDirectionality | Diffusion Directionality.
public Field | DiffusionGradientDirectionSequence | Diffusion Gradient Direction Sequence.
public Field | DiffusionGradientOrientation | Diffusion Gradient Orientation.
public Field | DigitalImageFormatAcquired | Digital Image Format Acquired.
public Field | DigitalSignatureDateTime | Digital Signature DateTime.
public Field | DigitalSignaturePurposeCodeSequence | Digital Signature Purpose Code Sequence.
public Field | DigitalSignaturesSequence | Digital Signatures Sequence.
public Field | DigitalSignatureUID | Digital Signature UID.
public Field | DigitizingDeviceTransportDirection | Digitizing Device Transport Direction.
public Field | DimensionDescriptionLabel | Dimension Description Label.
public Field | DimensionIndexPointer | Dimension Index Pointer.
public Field | DimensionIndexPrivateCreator | Dimension Index Private Creator.
public Field | DimensionIndexSequence | Dimension Index Sequence.
public Field | DimensionIndexValues | Dimension Index Values.
public Field | DimensionOrganizationSequence | Dimension Organization Sequence.
public Field | DimensionOrganizationType | Dimension Organization Type.
public Field | DimensionOrganizationUID | Dimension Organization UID.
public Field | DirectoryRecordSequence | Directory Record Sequence.
public Field | DirectoryRecordType | Directory Record Type.
public Field | DischargeDate | Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeDiagnosisCodeSequence | Discharge Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeDiagnosisDescription | Discharge Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeTime | Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayedAreaBottomRightHandCorner | Displayed Area Bottom Right Hand Corner.
public Field | DisplayedAreaBottomRightHandCornerTrial | Displayed Area Bottom Right Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayedAreaSelectionSequence | Displayed Area Selection Sequence.
public Field | DisplayedAreaTopLeftHandCorner | Displayed Area Top Left Hand Corner.
public Field | DisplayedAreaTopLeftHandCornerTrial | Displayed Area Top Left Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayEnvironmentSpatialPosition | Display Environment Spatial Position.
public Field | DisplayFilterPercentage | Display Filter Percentage.
public Field | DisplayFormat | Display Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplaySetHorizontalJustification | Display Set Horizontal Justification.
public Field | DisplaySetLabel | Display Set Label.
public Field | DisplaySetNumber | Display Set Number.
public Field | DisplaySetPatientOrientation | Display Set Patient Orientation.
public Field | DisplaySetPresentationGroup | Display Set Presentation Group.
public Field | DisplaySetPresentationGroupDescription | Display Set Presentation Group Description.
public Field | DisplaySetScrollingGroup | Display Set Scrolling Group.
public Field | DisplaySetsSequence | Display Sets Sequence.
public Field | DisplaySetVerticalJustification | Display Set Vertical Justification.
public Field | DisplayShadingFlag | Display Shading Flag.
public Field | DisplayWindowLabelVector | Display Window Label Vector.
public Field | DistanceObjecttoTableTop | Distance Object to Table Top.
public Field | DistancePupillaryDistance | Distance Pupillary Distance.
public Field | DistanceReceptorPlanetoDetectorHousing | Distance Receptor Plane to Detector Housing.
public Field | DistanceSourcetoDataCollectionCenter | Distance Source to Data Collection Center.
public Field | DistanceSourceToDetector | Distance Source to Detector.
public Field | DistanceSourceToEntrance | Distance Source to Entrance.
public Field | DistanceSourcetoIsocenter | Distance Source to Isocenter.
public Field | DistanceSourceToPatient | Distance Source to Patient.
public Field | DistanceSourcetoSupport | Distance Source to Support. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionAddress | Distribution Address. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionName | Distribution Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionType | Distribution Type.
public Field | DocumentTitle | Document Title.
public Field | DopplerCorrectionAngle | Doppler Correction Angle.
public Field | DopplerSampleVolumeXPosition | Doppler Sample Volume X Position.
public Field | DopplerSampleVolumeXPositionRetired | Doppler Sample Volume X Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DopplerSampleVolumeYPosition | Doppler Sample Volume Y Position.
public Field | DopplerSampleVolumeYPositionRetired | Doppler Sample Volume Y Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DoseCalibrationFactor | Dose Calibration Factor.
public Field | DoseComment | Dose Comment.
public Field | DoseGridScaling | Dose Grid Scaling.
public Field | DoseRateDelivered | Dose Rate Delivered.
public Field | DoseRateSet | Dose Rate Set.
public Field | DoseReferenceDescription | Dose Reference Description.
public Field | DoseReferenceNumber | Dose Reference Number.
public Field | DoseReferencePointCoordinates | Dose Reference Point Coordinates.
public Field | DoseReferenceSequence | Dose Reference Sequence.
public Field | DoseReferenceStructureType | Dose Reference Structure Type.
public Field | DoseReferenceType | Dose Reference Type.
public Field | DoseReferenceUID | Dose Reference UID.
public Field | DoseSummationType | Dose Summation Type.
public Field | DoseType | Dose Type.
public Field | DoseUnits | Dose Units.
public Field | DoseValue | Dose Value.
public Field | DoubleExposureFieldDelta | Double Exposure Field Delta.
public Field | DoubleExposureFlag | Double Exposure Flag.
public Field | DoubleExposureMeterset | Double Exposure Meterset.
public Field | DoubleExposureOrdering | Double Exposure Ordering.
public Field | DvhData | The DVH Data.
public Field | DvhDoseScaling | DVH Dose Scaling.
public Field | DvhMaximumDose | DVH Maximum Dose.
public Field | DvhMeanDose | DVH Mean Dose.
public Field | DvhMinimumDose | DVH Minimum Dose.
public Field | DvhNormalizationDoseValue | DVH Normalization Dose Value.
public Field | DvhNormalizationPoint | DVH Normalization Point.
public Field | DvhNumberOfBins | DVH Number of Bins.
public Field | DvhReferencedRoiSequence | DVH Referenced ROI Sequence.
public Field | DvhRoiContributionType | DVH ROI Contribution Type.
public Field | DvhSequence | DVH Sequence.
public Field | DvhType | DVH (Dose-volume histogram) Type.
public Field | DvhVolumeUnits | DVH Volume Units.
public Field | DynamicRange | Dynamic Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EchoNumbers | Echo Number(s).
public Field | EchoPlanarPulseSequence | Echo Planar Pulse Sequence.
public Field | EchoPulseSequence | Echo Pulse Sequence.
public Field | EchoTime | Echo Time.
public Field | EchoTrainLength | Echo Train Length.
public Field | EdgePointIndexList | Edge Point Index List.
public Field | EffectiveDuration | Effective Duration.
public Field | EffectiveEchoTime | Effective Echo Time.
public Field | EmmetropicMagnification | Emmetropic Magnification.
public Field | EmptyImageBoxCIELabValue | Empty Image Box CIELab Value.
public Field | EmptyImageDensity | Empty Image Density.
public Field | EncapsulatedDocument | Encapsulated Document.
public Field | EncryptedAttributesSequence | Encrypted Attributes Sequence.
public Field | EncryptedContent | Encrypted Content.
public Field | EncryptedContentTransferSyntaxUID | Encrypted Content Transfer Syntax UID.
public Field | EndAcquisitionDateTime | End Acquisition DateTime.
public Field | EndCumulativeMetersetWeight | End Cumulative Meterset Weight.
public Field | EndingRespiratoryAmplitude | Ending Respiratory Amplitude.
public Field | EndingRespiratoryPhase | Ending Respiratory Phase.
public Field | EndMessageID | End Message ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EndMeterset | End Meterset.
public Field | EnergyWeightingFactor | Energy Weighting Factor.
public Field | EnergyWindowCenterline | Energy Window Centerline. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EnergyWindowInformationSequence | Energy Window Information Sequence.
public Field | EnergyWindowLowerLimit | Energy Window Lower Limit.
public Field | EnergyWindowName | Energy Window Name.
public Field | EnergyWindowNumber | Energy Window Number.
public Field | EnergyWindowRangeSequence | Energy Window Range Sequence.
public Field | EnergyWindowTotalWidth | Energy Window Total Width. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EnergyWindowUpperLimit | Energy Window Upper Limit.
public Field | EnergyWindowVector | Energy Window Vector.
public Field | EnhancedPaletteColorLookupTableSequence | Enhanced Palette Color Lookup Table Sequence.
public Field | EntranceDose | Entrance Dose.
public Field | EntranceDoseInmGy | Entrance Dose in mGy.
public Field | EquipmentCoordinateSystemIdentification | Equipment Coordinate System Identification.
public Field | EquivalentCDADocumentSequence | Equivalent CDA Document Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Erase | Erase. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ErrorComment | Error Comment.
public Field | ErrorID | Error Identifier.
public Field | EscapeTriplet | Escape Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EstimatedDoseSaving | Estimated Dose Saving.
public Field | EstimatedRadiographicMagnificationFactor | Estimated Radiographic Magnification Factor.
public Field | EthnicGroup | Ethnic Group.
public Field | EventCodeSequence | Event Code Sequence.
public Field | EventElapsedTimes | Event Elapsed Time(s).
public Field | EventTimeOffset | Event Time Offset.
public Field | EventTimerNames | Event Timer Name(s).
public Field | EventTimerSequence | Event Timer Sequence.
public Field | EventTypeID | Event Type ID.
public Field | ExaminedBodyThickness | Examined Body Thickness.
public Field | ExcludedIntervalsSequence | Excluded Intervals Sequence.
public Field | ExclusionDuration | Exclusion Duration.
public Field | ExclusionStartDatetime | Exclusion Start Datetime.
public Field | ExecutionStatus | Execution Status.
public Field | ExecutionStatusInfo | Execution Status Info.
public Field | ExpectedCompletionDateTime | Expected Completion Date Time.
public Field | ExposedArea | Exposed Area.
public Field | Exposure | Exposure value.
public Field | ExposureControlMode | Exposure Control Mode.
public Field | ExposureControlModeDescription | Exposure Control Mode Description.
public Field | ExposureControlSensingRegionLeftVerticalEdge | Exposure Control Sensing Region Left Vertical Edge.
public Field | ExposureControlSensingRegionLowerHorizontalEdge | Exposure Control Sensing Region Lower Horizontal Edge.
public Field | ExposureControlSensingRegionRightVerticalEdge | Exposure Control Sensing Region Right Vertical Edge.
public Field | ExposureControlSensingRegionShape | Exposure Control Sensing Region Shape.
public Field | ExposureControlSensingRegionsSequence | Exposure Control Sensing Regions Sequence.
public Field | ExposureControlSensingRegionUpperHorizontalEdge | Exposure Control Sensing Region Upper Horizontal Edge.
public Field | ExposureDoseSequence | Exposure Dose Sequence.
public Field | ExposureinmAs | Exposure in mAs.
public Field | ExposureInMicroAs | Exposure in micro As.
public Field | ExposureModulationType | Exposure Modulation Type.
public Field | ExposureSequence | Exposure Sequence.
public Field | ExposuresOnDetectorSinceLastCalibration | Exposures on Detector Since Last Calibration.
public Field | ExposuresOnDetectorSinceManufactured | Exposures on Detector Since Manufactured.
public Field | ExposuresOnPlate | Exposures on Plate.
public Field | ExposureStatus | Exposure Status.
public Field | ExposureTime | Exposure Time.
public Field | ExposureTimeinms | Exposure Time in ms.
public Field | ExposureTimeInuS | Exposure Time in micro S.
public Field | FacetSequence | Facet Sequence.
public Field | FailedAttributesSequence | Failed Attributes Sequence.
public Field | FailedSOPInstanceUIDList | Failed SOP Instance UID List.
public Field | FailedSOPSequence | Failed SOP Sequence.
public Field | FailureAttributes | Failure Attributes.
public Field | FailureReason | Failure Reason.
public Field | FiducialDescription | Fiducial Description.
public Field | FiducialIdentifier | Fiducial Identifier.
public Field | FiducialIdentifierCodeSequence | Fiducial Identifier Code Sequence.
public Field | FiducialSequence | Fiducial Sequence.
public Field | FiducialSetSequence | Fiducial Set Sequence.
public Field | FiducialUID | Fiducial UID.
public Field | FieldofViewDescription | Field of View Description.
public Field | FieldOfViewDimensions | Field of View Dimension(s).
public Field | FieldofViewDimensionsInFloat | Field of View Dimension(s) in Float.
public Field | FieldOfViewHorizontalFlip | Field of View Horizontal Flip.
public Field | FieldOfViewOrigin | Field of View Origin.
public Field | FieldOfViewRotation | Field of View Rotation.
public Field | FieldofViewSequence | Field of View Sequence.
public Field | FieldOfViewShape | Field of View Shape.
public Field | FileMetaInformationGroupLength | File Meta Information Group Length.
public Field | FileMetaInformationVersion | File Meta Information Version.
public Field | FilesetConsistencyFlag | File-set Consistency Flag.
public Field | FilesetDescriptorFileID | File-set Descriptor File ID.
public Field | FilesetID | File-set ID.
public Field | FillerOrderNumberImagingServiceRequest | Filler Order Number / Imaging Service Request.
public Field | FillerOrderNumberImagingServiceRequestRetired | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FillerOrderNumberProcedure | Filler Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FilmBoxContentSequence | Film Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FilmConsumptionSequence | Film Consumption Sequence.
public Field | FilmDestination | Film Destination.
public Field | FilmOrientation | Film Orientation.
public Field | FilmSessionLabel | Film Session Label.
public Field | FilmSizeID | Film Size ID.
public Field | FilterBeamPathLengthMaximum | Filter Beam Path Length Maximum.
public Field | FilterBeamPathLengthMinimum | Filter Beam Path Length Minimum.
public Field | FilterbyAttributePresence | Filter-by Attribute Presence.
public Field | FilterbyCategory | Filter-by Category.
public Field | FilterbyOperator | Filter-by Operator.
public Field | FilterHighFrequency | Filter High Frequency.
public Field | FilterLowFrequency | Filter Low Frequency.
public Field | FilterMaterial | Filter Material.
public Field | FilterOperationsSequence | Filter Operations Sequence.
public Field | FilterThicknessMaximum | Filter Thickness Maximum.
public Field | FilterThicknessMinimum | Filter Thickness Minimum.
public Field | FilterType | Filter Type.
public Field | FinalCumulativeMetersetWeight | Final Cumulative Meterset Weight.
public Field | FinalCumulativeTimeWeight | Final Cumulative Time Weight.
public Field | FindLocation | Find Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FiniteVolume | Finite Volume.
public Field | FirstOrderPhaseCorrection | First Order Phase Correction.
public Field | FirstOrderPhaseCorrectionAngle | First Order Phase Correction Angle.
public Field | FirstTreatmentDate | First Treatment Date.
public Field | FixationDeviceDescription | Fixation Device Description.
public Field | FixationDeviceLabel | Fixation Device Label.
public Field | FixationDevicePitchAngle | Fixation Device Pitch Angle.
public Field | FixationDevicePosition | Fixation Device Position.
public Field | FixationDeviceRollAngle | Fixation Device Roll Angle.
public Field | FixationDeviceSequence | Fixation Device Sequence.
public Field | FixationDeviceType | Fixation Device Type.
public Field | FixationLightAzimuthalAngle | Fixation Light Azimuthal Angle.
public Field | FixationLightPolarAngle | Fixation Light Polar Angle.
public Field | FlatKeratometricAxisSequence | Flat Keratometric Axis Sequence.
public Field | FlipAngle | Flip Angle.
public Field | FlowCompensation | Flow Compensation.
public Field | FlowCompensationDirection | Flow Compensation Direction.
public Field | FluenceDataScale | Fluence Data Scale.
public Field | FluenceDataSource | Fluence Data Source.
public Field | FluenceMapSequence | Fluence Map Sequence.
public Field | FluenceMode | Fluence Mode.
public Field | FluenceModeID | Fluence Mode ID.
public Field | FluoroscopyFlag | Fluoroscopy Flag.
public Field | FocalDistance | Focal Distance.
public Field | FocalSpots | Focal Spot(s).
public Field | FocusDepth | Focus Depth.
public Field | FORMAT | DICOM format marker.
public Field | FractionalChannelDisplayScale | Fractional Channel Display Scale.
public Field | FractionGroupDescription | Fraction Group Description.
public Field | FractionGroupNumber | Fraction Group Number.
public Field | FractionGroupSequence | Fraction Group Sequence.
public Field | FractionGroupSummarySequence | Fraction Group Summary Sequence.
public Field | FractionGroupType | Fraction Group Type.
public Field | FractionNumber | Fraction Number.
public Field | FractionPattern | Fraction Pattern.
public Field | FractionStatusSummarySequence | Fraction Status Summary Sequence.
public Field | FrameAcquisitionDateTime | Frame Acquisition DateTime.
public Field | FrameAcquisitionDuration | Frame Acquisition Duration.
public Field | FrameAcquisitionNumber | Frame Acquisition Number.
public Field | FrameAcquisitionSequence | Frame Acquisition Sequence.
public Field | FrameAnatomySequence | Frame Anatomy Sequence.
public Field | FrameComments | Frame Comments.
public Field | FrameContentSequence | Frame Content Sequence.
public Field | FrameDelay | Frame Delay.
public Field | FrameDetectorParametersSequence | Frame Detector Parameters Sequence.
public Field | FrameDimensionPointer | Frame Dimension Pointer.
public Field | FrameDisplaySequence | Frame Display Sequence.
public Field | FrameDisplayShutterSequence | Frame Display Shutter Sequence.
public Field | FrameExtractionSequence | Frame Extraction Sequence.
public Field | FrameIncrementPointer | Frame Increment Pointer.
public Field | FrameLabel | Frame Label.
public Field | FrameLabelVector | Frame Label Vector.
public Field | FrameLaterality | Frame Laterality.
public Field | FrameNumbersOfInterest | Frame Numbers of Interest (FOI).
public Field | FrameOfInterestDescription | Frame of Interest Description.
public Field | FrameofInterestType | Frame of Interest Type.
public Field | FrameOfReferenceRelationshipSequence | Frame of Reference Relationship Sequence.
public Field | FrameOfReferenceTransformationComment | Frame of Reference Transformation Comment.
public Field | FrameOfReferenceTransformationMatrix | Frame of Reference Transformation Matrix.
public Field | FrameofReferenceTransformationMatrixType | Frame of Reference Transformation Matrix Type.
public Field | FrameOfReferenceTransformationType | Frame of Reference Transformation Type.
public Field | FrameOfReferenceUID | Frame of Reference UID.
public Field | FramePixelDataPropertiesSequence | Frame Pixel Data Properties Sequence.
public Field | FramePixelShiftSequence | Frame Pixel Shift Sequence.
public Field | FramePrimaryAngleVector | Frame Primary Angle Vector.
public Field | FrameReferenceDateTime | Frame Reference DateTime.
public Field | FrameReferenceTime | Frame Reference Time.
public Field | FrameSecondaryAngleVector | Frame Secondary Angle Vector.
public Field | FrameTime | Frame Time.
public Field | FrameTimeVector | Frame Time Vector.
public Field | FrameType | Frame Type.
public Field | FrameVoiLutSequence | Frame VOI LUT Sequence.
public Field | FrequencyCorrection | Frequency Correction.
public Field | FunctionalGroupPointer | Functional Group Pointer.
public Field | FunctionalGroupPrivateCreator | Functional Group Private Creator.
public Field | GantryAngle | Gantry Angle.
public Field | GantryAngleTolerance | Gantry Angle Tolerance.
public Field | GantryDetectorSlew | Gantry/Detector Slew.
public Field | GantryDetectorTilt | Gantry/Detector Tilt.
public Field | GantryID | Gantry ID.
public Field | GantryMotionCorrected | Gantry Motion Corrected.
public Field | GantryPitchAngle | Gantry Pitch Angle.
public Field | GantryPitchAngleTolerance | Gantry Pitch Angle Tolerance.
public Field | GantryPitchRotationDirection | Gantry Pitch Rotation Direction.
public Field | GantryRotationDirection | Gantry Rotation Direction.
public Field | GatedInformationSequence | Gated Information Sequence.
public Field | GeneralAccessoryDescription | General Accessory Description.
public Field | GeneralAccessoryID | General Accessory ID.
public Field | GeneralAccessoryNumber | General Accessory Number.
public Field | GeneralAccessorySequence | General Accessory Sequence.
public Field | GeneralAccessoryType | General Accessory Type.
public Field | GeneralMachineVerificationSequence | General Machine Verification Sequence.
public Field | GeneralPurposePerformedProcedureStepStatus | General Purpose Performed Procedure Step Status.
public Field | GeneralPurposeScheduledProcedureStepPriority | General Purpose Scheduled Procedure Step Priority.
public Field | GeneralPurposeScheduledProcedureStepStatus | General Purpose Scheduled Procedure Step Status.
public Field | GeneratorID | Generator ID.
public Field | GeneratorPower | Generator Power.
public Field | GeometricalProperties | Geometrical Properties.
public Field | GeometricMaximumDistortion | Geometric Maximum Distortion.
public Field | GeometryOfKspaceTraversal | Geometry of k-Space Traversal.
public Field | GradientEchoTrainLength | Gradient Echo Train Length.
public Field | GradientOutput | Gradient Output.
public Field | GradientOutputType | Gradient Output Type.
public Field | GraphicAnnotationSequence | Graphic Annotation Sequence.
public Field | GraphicAnnotationUnits | Graphic Annotation Units.
public Field | GraphicCoordinatesDataSequence | Graphic Coordinates Data Sequence.
public Field | GraphicData | Graphic Data.
public Field | GraphicDimensions | Graphic Dimensions.
public Field | GraphicFilled | Graphic Filled.
public Field | GraphicLayer | Graphic Layer.
public Field | GraphicLayerDescription | Graphic Layer Description.
public Field | GraphicLayerOrder | Graphic Layer Order.
public Field | GraphicLayerRecommendedDisplayCIELabValue | Graphic Layer Recommended Display CIELab Value.
public Field | GraphicLayerRecommendedDisplayGrayscaleValue | Graphic Layer Recommended Display Grayscale Value.
public Field | GraphicLayerRecommendedDisplayRGBValue | Graphic Layer Recommended Display RGB Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GraphicLayerSequence | Graphic Layer Sequence.
public Field | GraphicObjectSequence | Graphic Object Sequence.
public Field | GraphicType | Graphic Type.
public Field | GrayLookupTableData | Gray Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GrayLookupTableDescriptor | Gray Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GrayScale | Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GreenPaletteColorLookupTableData | Green Palette Color Lookup Table Data.
public Field | GreenPaletteColorLookupTableDescriptor | Green Palette Color Lookup Table Descriptor.
public Field | Grid | Grid value.
public Field | GridAbsorbingMaterial | Grid Absorbing Material.
public Field | GridAspectRatio | Grid Aspect Ratio.
public Field | GridDimensions | Grid Dimensions.
public Field | GridFocalDistance | Grid Focal Distance.
public Field | GridFrameOffsetVector | Grid Frame Offset Vector.
public Field | GridID | Grid Identifier.
public Field | GridPeriod | Grid Period.
public Field | GridPitch | Grid Pitch.
public Field | GridResolution | Grid Resolution.
public Field | GridSpacingMaterial | Grid Spacing Material.
public Field | GridThickness | Grid Thickness.
public Field | Group0000LengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0004Length | Group 0004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0008Length | Group 0008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0008LengthToEnd | Group 0008 Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0010Length | Group 0010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0012Length | Group 0012 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0018Length | Group 0018 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0020Length | Group 0020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0022Length | Group 0022 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0028Length | Group 0028 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0032Length | Group 0032 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0038Length | Group 0038 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group003ALength | Group 003A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0040Length | Group 0040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0042Length | Group 0042 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0044Length | Group 0044 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0046Length | Group 0046 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0050Length | Group 0050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0054Length | Group 0054 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0060Length | Group 0060 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0062Length | Group 0062 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0064Length | Group 0064 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0066Length | Group 0066 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0070Length | Group 0070 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0072Length | Group 0072 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0074Length | Group 0074 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0088Length | Group 0088 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0100Length | Group 0100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0400Length | Group 0400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group1000Length | Group 1000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group1010Length | Group 1010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2000Length | Group 2000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2010Length | Group 2010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2020Length | Group 2020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2030Length | Group 2030 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2040Length | Group 2040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2050Length | Group 2050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2100Length | Group 2100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2110Length | Group 2110 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2120Length | Group 2120 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2130Length | Group 2130 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2200Length | Group 2200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3002Length | Group 3002 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3004Length | Group 3004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3006Length | Group 3006 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3008Length | Group 3008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300ALength | Group 300A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300CLength | Group 300C Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300ELength | Group 300E Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4000Length | Group 4000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4008Length | Group 4008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4FFELength | Group 4FFE Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group50xxLength | Group 50xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5200Length | Group 5200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5400Length | Group 5400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5600Length | Group 5600 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group60xxLength | Group 60xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group7FE0Length | Group 7FE0 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group7FFFLength | Group 7FFF Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HalfValueLayer | Half Value Layer.
public Field | HangingProtocolCreationDateTime | Hanging Protocol Creation DateTime.
public Field | HangingProtocolCreator | Hanging Protocol Creator.
public Field | HangingProtocolDefinitionSequence | Hanging Protocol Definition Sequence.
public Field | HangingProtocolDescription | Hanging Protocol Description.
public Field | HangingProtocolLevel | Hanging Protocol Level.
public Field | HangingProtocolName | Hanging Protocol Name.
public Field | HangingProtocolUserGroupName | Hanging Protocol User Group Name.
public Field | HangingProtocolUserIdentificationCodeSequence | Hanging Protocol User Identification Code Sequence.
public Field | HardcopyCreationDeviceID | Hardcopy Creation Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceManufacturer | Hardcopy Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceManufacturersModelName | Hardcopy Device Manufacturer's Model Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceSoftwareVersion | Hardcopy Device Software Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HeadFixationAngle | Head Fixation Angle.
public Field | HeartRate | Heart Rate.
public Field | HighBit | Image High Bit.
public Field | HighDoseTechniqueType | High-Dose Technique Type.
public Field | HighRrValue | High R-R Value.
public Field | HistogramBinWidth | Histogram Bin Width.
public Field | HistogramData | Histogram Data.
public Field | HistogramExplanation | Histogram Explanation.
public Field | HistogramFirstBinValue | Histogram First Bin Value.
public Field | HistogramLastBinValue | Histogram Last Bin Value.
public Field | HistogramNumberOfBins | Histogram Number of Bins.
public Field | HistogramSequence | Histogram Sequence.
public Field | HL7DocumentEffectiveTime | HL7 Document Effective Time.
public Field | HL7DocumentTypeCodeSequence | HL7 Document Type Code Sequence.
public Field | HL7InstanceIdentifier | HL7 Instance Identifier.
public Field | HL7StructuredDocumentReferenceSequence | HL7 Structured Document Reference Sequence.
public Field | HorizontalFieldofView | Horizontal Field of View.
public Field | HorizontalPrismBase | Horizontal Prism Base.
public Field | HorizontalPrismPower | Horizontal Prism Power.
public Field | HuffmanTableSize | Huffman Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HuffmanTableTriplet | Huffman Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HumanPerformerCodeSequence | Human Performer Code Sequence.
public Field | HumanPerformerName | Human Performer's Name.
public Field | HumanPerformerOrganization | Human Performer's Organization.
public Field | ICCProfile | ICC Profile.
public Field | IconImageSequence | Icon Image Sequence.
public Field | IdenticalDocumentsSequence | Identical Documents Sequence.
public Field | IdentifierTypeCode | Identifier Type Code.
public Field | IdentifyingComments | Identifying Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Illumination | Illumination value.
public Field | IlluminationBandwidth | Illumination Bandwidth.
public Field | IlluminationPower | Illumination Power.
public Field | IlluminationTypeCodeSequence | Illumination Type Code Sequence.
public Field | IlluminationWaveLength | Illumination Wave Length.
public Field | ImageAndFluoroscopyAreaDoseProduct | Image and Fluoroscopy Area Dose Product.
public Field | ImageBoxContentSequence | Image Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageBoxesSequence | Image Boxes Sequence.
public Field | ImageBoxLargeScrollAmount | Image Box Large Scroll Amount.
public Field | ImageBoxLargeScrollType | Image Box Large Scroll Type.
public Field | ImageBoxLayoutType | Image Box Layout Type.
public Field | ImageBoxNumber | Image Box Number.
public Field | ImageBoxOverlapPriority | Image Box Overlap Priority.
public Field | ImageBoxPosition | Image Box Position.
public Field | ImageBoxPresentationLUTFlag | Image Box Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageBoxScrollDirection | Image Box Scroll Direction.
public Field | ImageBoxSmallScrollAmount | Image Box Small Scroll Amount.
public Field | ImageBoxSmallScrollType | Image Box Small Scroll Type.
public Field | ImageBoxSynchronizationSequence | Image Box Synchronization Sequence.
public Field | ImageBoxTileHorizontalDimension | Image Box Tile Horizontal Dimension.
public Field | ImageBoxTileVerticalDimension | Image Box Tile Vertical Dimension.
public Field | ImageCenterPointCoordinatesSequence | Image Center Point Coordinates Sequence.
public Field | ImageComments | Image Comments.
public Field | ImageDataLocation | Image Data Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageDataTypeSequence | Image Data Type Sequence.
public Field | ImageDimensions | Image Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageDisplayFormat | Image Display Format.
public Field | ImagedNucleus | Imaged Nucleus.
public Field | ImageFilter | Image Filter.
public Field | ImageFormat | Image Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageFrameOrigin | Image Frame Origin.
public Field | ImageGeometryType | Image Geometry Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageHorizontalFlip | Image Horizontal Flip.
public Field | ImageID | Image Identifier.
public Field | ImageIndex | Image Index.
public Field | ImageLaterality | Image Laterality.
public Field | ImageLocation | Image Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOrientation | Image Orientation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOrientationPatient | Image Orientation (Patient).
public Field | ImageOrientationVolume | Image Orientation (Volume).
public Field | ImageOverlayBoxContentSequence | Image Overlay Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOverlayFlag | Image Overlay Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagePathFilterPassBand | Image Path Filter Pass Band.
public Field | ImagePathFilterPassThroughWavelength | Image Path Filter Pass-Through Wavelength.
public Field | ImagePathFilterTypeStackCodeSequence | Image Path Filter Type Stack Code Sequence.
public Field | ImagePlanePixelSpacing | Image Plane Pixel Spacing.
public Field | ImagePosition | Image Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagePositionPatient | Image Position (Patient).
public Field | ImagePositionVolume | Image Position (Volume).
public Field | ImagePresentationComments | Image Presentation Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageProcessingApplied | Image Processing Applied.
public Field | ImageRotation | Image Rotation.
public Field | ImageRotationRetired | Image Rotation (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagerPixelSpacing | Imager Pixel Spacing.
public Field | ImageSetLabel | Image Set Label.
public Field | ImageSetNumber | Image Set Number.
public Field | ImageSetSelectorCategory | Image Set Selector Category.
public Field | ImageSetSelectorSequence | Image Set Selector Sequence.
public Field | ImageSetSelectorUsageFlag | Image Set Selector Usage Flag.
public Field | ImageSetsSequence | Image Sets Sequence.
public Field | ImagesInAcquisition | Images in Acquisition.
public Field | ImagesInSeries | Images in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagesInStudy | Images in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageToEquipmentMappingMatrix | Image to Equipment Mapping Matrix.
public Field | ImageTransformationMatrix | Image Transformation Matrix. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageTranslationVector | Image Translation Vector. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageTriggerDelay | Image Trigger Delay.
public Field | ImageType | Image Type.
public Field | ImagingDeviceSpecificAcquisitionParameters | Imaging Device-Specific Acquisition Parameters.
public Field | ImagingFrequency | Imaging Frequency.
public Field | ImagingServiceRequestComments | Imaging Service Request Comments.
public Field | ImagingServiceRequestFillerOrderNum | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagingServiceRequestPlacerOrderNum | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImplementationClassUID | Implementation Class UID.
public Field | ImplementationVersionName | Implementation Version Name.
public Field | Impressions | Impressions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IncludeDisplayApplication | Include Display Application.
public Field | IncludeNonDICOMObjects | Include Non-DICOM Objects.
public Field | InConcatenationNumber | In-concatenation Number.
public Field | InConcatenationTotalNumber | In-concatenation Total Number.
public Field | InitialCineRunState | Initial Cine Run State.
public Field | InPlanePhaseEncodingDirection | In-plane Phase Encoding Direction.
public Field | InputAvailabilityFlag | Input Availability Flag.
public Field | InputInformationSequence | Input Information Sequence.
public Field | InStackPositionNumber | In-Stack Position Number.
public Field | InstanceAvailability | Instance Availability.
public Field | InstanceCreationDate | Instance Creation Date.
public Field | InstanceCreationTime | Instance Creation Time.
public Field | InstanceCreatorUID | Instance Creator UID.
public Field | InstanceNumber | Instance Number.
public Field | InstitutionAddress | Institution Address.
public Field | InstitutionalDepartmentName | Institutional Department Name.
public Field | InstitutionCodeSequence | Institution Code Sequence.
public Field | InstitutionName | Institution Name.
public Field | InsurancePlanIdentification | Insurance Plan Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntendedRecipientsOfResultsIdentificationSequence | Intended Recipients of Results Identification Sequence.
public Field | IntensifierActiveDimensions | Intensifier Active Dimension(s).
public Field | IntensifierActiveShape | Intensifier Active Shape.
public Field | IntensifierSize | Intensifier Size.
public Field | InterMarkerDistance | Inter-Marker Distance.
public Field | IntermediatePupillaryDistance | Intermediate Pupillary Distance.
public Field | InterpretationApprovalDate | Interpretation Approval Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationApprovalTime | Interpretation Approval Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationApproverSequence | Interpretation Approver Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationAuthor | Interpretation Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationDiagnosisCodeSequence | Interpretation Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationDiagnosisDescription | Interpretation Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationID | Interpretation ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationIDIssuer | Interpretation ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecordedDate | Interpretation Recorded Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecordedTime | Interpretation Recorded Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecorder | Interpretation Recorder. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationStatusID | Interpretation Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationText | Interpretation Text. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriber | Interpretation Transcriber. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriptionDate | Interpretation Transcription Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriptionTime | Interpretation Transcription Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTypeID | Interpretation Type ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntervalNumber | Interval Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntervalsAcquired | Intervals Acquired.
public Field | IntervalsRejected | Intervals Rejected.
public Field | InterventionDescription | Intervention Description.
public Field | InterventionDrugCodeSequence | Intervention Drug Code Sequence.
public Field | InterventionDrugDose | Intervention Drug Dose.
public Field | InterventionDrugInformationSequence | Intervention Drug Information Sequence.
public Field | InterventionDrugName | Intervention Drug Name.
public Field | InterventionDrugStartTime | Intervention Drug Start Time.
public Field | InterventionDrugStopTime | Intervention Drug Stop Time.
public Field | InterventionSequence | Intervention Sequence.
public Field | InterventionStatus | Intervention Status.
public Field | IntraOcularPressure | Intra Ocular Pressure.
public Field | InversionRecovery | Inversion Recovery.
public Field | InversionTime | Inversion Time.
public Field | InversionTimes | Inversion Times.
public Field | IonBeamLimitingDeviceSequence | Ion Beam Limiting Device Sequence.
public Field | IonBeamSequence | Ion Beam Sequence.
public Field | IonBlockSequence | Ion Block Sequence.
public Field | IonControlPointDeliverySequence | Ion Control Point Delivery Sequence.
public Field | IonControlPointSequence | Ion Control Point Sequence.
public Field | IonControlPointVerificationSequence | Ion Control Point Verification Sequence.
public Field | IonMachineVerificationSequence | Ion Machine Verification Sequence.
public Field | IonRangeCompensatorSequence | Ion Range Compensator Sequence.
public Field | IonToleranceTableSequence | Ion Tolerance Table Sequence.
public Field | IonWedgePositionSequence | Ion Wedge Position Sequence.
public Field | IonWedgeSequence | Ion Wedge Sequence.
public Field | IrradiationEventIdentificationSequence | Irradiation Event Identification Sequence.
public Field | IrradiationEventUID | Irradiation Event UID.
public Field | IsocenterPosition | Isocenter Position.
public Field | IsocenterReferenceSystemSequence | Isocenter Reference System Sequence.
public Field | IsocentertoBeamLimitingDeviceDistance | Isocenter to Beam Limiting Device Distance.
public Field | IsocentertoBlockTrayDistance | Isocenter to Block Tray Distance.
public Field | IsocentertoCompensatorDistances | Isocenter to Compensator Distances.
public Field | IsocentertoCompensatorTrayDistance | Isocenter to Compensator Tray Distance.
public Field | IsocentertoLateralSpreadingDeviceDistance | Isocenter to Lateral Spreading Device Distance.
public Field | IsocentertoRangeModulatorDistance | Isocenter to Range Modulator Distance.
public Field | IsocentertoRangeShifterDistance | Isocenter to Range Shifter Distance.
public Field | IsocentertoWedgeTrayDistance | Isocenter to Wedge Tray Distance.
public Field | IsotopeNumber | Isotope Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssueDateOfImagingServiceRequest | Issue Date of Imaging Service Request.
public Field | IssuerOfAccessionNumberSequence | Issuer of Accession Number Sequence.
public Field | IssuerOfAdmissionID | Issuer of Admission ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssuerOfAdmissionIDSequence | Issuer of Admission ID Sequence.
public Field | IssuerOfPatientID | Issuer of Patient ID.
public Field | IssuerOfPatientIDQualifiersSequence | Issuer of Patient ID Qualifiers Sequence.
public Field | IssuerOfServiceEpisodeID | Issuer of Service Episode ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssuerOfServiceEpisodeIDSequence | Issuer of Service Episode ID Sequence.
public Field | IssuerOfTheContainerIdentifierSequence | Issuer of the Container Identifier Sequence.
public Field | IssuerOfTheSpecimenIdentifierSequence | Issuer of the Specimen Identifier Sequence.
public Field | IssueTimeOfImagingServiceRequest | Issue Time of Imaging Service Request.
public Field | Item | Item marker.
public Field | ItemDelimitationItem | Item Delimitation Item.
public Field | ItemNumber | Item Number.
public Field | IterativeReconstructionMethod | Iterative Reconstruction Method.
public Field | IvusAcquisition | IVUS Acquisition.
public Field | IvusGatedRate | IVUS Gated Rate.
public Field | IvusPullbackRate | IVUS Pullback Rate.
public Field | IvusPullbackStartFrameNumber | IVUS Pullback Start Frame Number.
public Field | IvusPullbackStopFrameNumber | IVUS Pullback Stop Frame Number.
public Field | KeratometricAxis | Keratometric Axis.
public Field | KeratometricPower | Keratometric Power.
public Field | KeratometryLeftEyeSequence | Keratometry Left Eye Sequence.
public Field | KeratometryRightEyeSequence | Keratometry Right Eye Sequence.
public Field | KspaceFiltering | K-space Filtering.
public Field | Kvp | KVP (kilovolts peak).
public Field | LabelStyleSelection | Label Style Selection.
public Field | LabelText | Label Text.
public Field | LabelUsingInformationExtractedFromInstances | Label Using Information Extracted From Instances.
public Field | LanguageCodeSequence | Language Code Sequence.
public Field | LargeBluePaletteColorLookupTableData | Large Blue Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeBluePaletteColorLookupTableDescriptor | Large Blue Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeGreenPaletteColorLookupTableData | Large Green Palette Color Lookup Table Data(RET). See DICOM specification for alternatives.
public Field | LargeGreenPaletteColorLookupTableDescriptor | Large Green Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargePaletteColorLookupTableUID | Large Palette Color Lookup Table UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeRedPaletteColorLookupTableData | Large Red Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeRedPaletteColorLookupTableDescriptor | Large Red Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestImagePixelValue | Largest Image Pixel Value.
public Field | LargestImagePixelValueInPlane | Largest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestMonochromePixelValue | Largest Monochrome Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestPixelValueInSeries | Largest Pixel Value in Series.
public Field | LargestValidPixelValue | Largest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LastMenstrualDate | Last Menstrual Date.
public Field | Laterality | The Laterality.
public Field | LateralSpreadingDeviceDescription | Lateral Spreading Device Description.
public Field | LateralSpreadingDeviceID | Lateral Spreading Device ID.
public Field | LateralSpreadingDeviceNumber | Lateral Spreading Device Number.
public Field | LateralSpreadingDeviceSequence | Lateral Spreading Device Sequence.
public Field | LateralSpreadingDeviceSetting | Lateral Spreading Device Setting.
public Field | LateralSpreadingDeviceSettingsSequence | Lateral Spreading Device Settings Sequence.
public Field | LateralSpreadingDeviceType | Lateral Spreading Device Type.
public Field | LateralSpreadingDeviceWaterEquivalentThickness | Lateral Spreading Device Water Equivalent Thickness.
public Field | LeafJawPosition | Leaf/Jaw Positions.
public Field | LeafJawPositions | Leaf/Jaw Positions.
public Field | LeafPositionBoundaries | Leaf Position Boundaries.
public Field | LeftImageSequence | Left Image Sequence.
public Field | LeftLensSequence | Left Lens Sequence.
public Field | LengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LensDescription | Lens Description.
public Field | LensesCodeSequence | Lenses Code Sequence.
public Field | LensSegmentType | Lens Segment Type.
public Field | LesionNumber | Lesion Number.
public Field | LightPathFilterPassBand | Light Path Filter Pass Band.
public Field | LightPathFilterPassThroughWavelength | Light Path Filter Pass-Through Wavelength.
public Field | LightPathFilterTypeStackCodeSequence | Light Path Filter Type Stack Code Sequence.
public Field | LineSequence | Line Sequence.
public Field | ListOfMIMETypes | List of MIME Types.
public Field | LocalNamespaceEntityID | Local Namespace Entity ID.
public Field | Location | Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LookupTableNumber | Lookup Table Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LossyImageCompression | Lossy Image Compression.
public Field | LossyImageCompressionMethod | Lossy Image Compression Method.
public Field | LossyImageCompressionRatio | Lossy Image Compression Ratio.
public Field | LossyImageCompressionRetired | Lossy Image Compression (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LowRrValue | Low R-R Value.
public Field | LUTData | LUT (Lookup Table) Data.
public Field | LUTDescriptor | LUT Descriptor.
public Field | LUTExplanation | LUT Explanation.
public Field | LUTFrameRange | LUT Frame Range.
public Field | LUTFunction | LUT Function.
public Field | LutLabel | LUT Label.
public Field | LUTNumber | LUT Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MAC | MAC (Message Authentication Code).
public Field | MacAlgorithm | MAC Algorithm.
public Field | MacCalculationTransferSyntaxUID | MAC Calculation Transfer Syntax UID.
public Field | MacIDNumber | MAC ID Number.
public Field | MacParametersSequence | MAC Parameters Sequence.
public Field | MagneticFieldStrength | Magnetic Field Strength.
public Field | MagnetizationTransfer | Magnetization Transfer.
public Field | MagnificationType | Magnification Type.
public Field | MagnifytoNumberofColumns | Magnify to Number of Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Manifold | Manifold tag.
public Field | ManipulatedImage | Manipulated Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Manufacturer | The Manufacturer.
public Field | ManufacturersModelName | Manufacturer's Model Name.
public Field | MappingResource | Mapping Resource.
public Field | MaskFrameNumbers | Mask Frame Numbers.
public Field | MaskingImage | Masking Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaskOperation | Mask Operation.
public Field | MaskOperationExplanation | Mask Operation Explanation.
public Field | MaskPointers | Mask Pointer(s). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaskSelectionMode | Mask Selection Mode.
public Field | MaskSubpixelShift | Mask Sub-pixel Shift.
public Field | MaskSubtractionSequence | Mask Subtraction Sequence.
public Field | MaskVisibilityPercentage | Mask Visibility Percentage.
public Field | MaterialID | Material ID.
public Field | MatrixRegistrationSequence | Matrix Registration Sequence.
public Field | MatrixSequence | Matrix Sequence.
public Field | MaxDensity | Max Density.
public Field | MaximumAcrossScanDistortion | Maximum Across-scan Distortion.
public Field | MaximumAlongScanDistortion | Maximum Along-scan Distortion.
public Field | MaximumCollatedFilms | Maximum Collated Films.
public Field | MaximumCoordinateValue | Maximum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaximumDepthDistortion | Maximum Depth Distortion.
public Field | MaximumFractionalValue | Maximum Fractional Value.
public Field | MaximumMemoryAllocation | Maximum Memory Allocation.
public Field | MaximumPointDistance | Maximum Point Distance.
public Field | MeanPointDistance | Mean Point Distance.
public Field | MeasuredDoseDescription | Measured Dose Description.
public Field | MeasuredDoseReferenceNumber | Measured Dose Reference Number.
public Field | MeasuredDoseReferenceSequence | Measured Dose Reference Sequence.
public Field | MeasuredDoseType | Measured Dose Type.
public Field | MeasuredDoseValue | Measured Dose Value.
public Field | MeasuredValueSequence | Measured Value Sequence.
public Field | MeasurementUnitsCodeSequence | Measurement Units Code Sequence.
public Field | MeasuringUnitsSequence | Measuring Units Sequence.
public Field | MechanicalIndex | Mechanical Index.
public Field | MediaDisposition | Media Disposition.
public Field | MediaInstalledSequence | Media Installed Sequence.
public Field | MediaStorageSOPClassUID | Media Storage SOP Class UID.
public Field | MediaStorageSOPInstanceUID | Media Storage SOP Instance UID.
public Field | MedicalAlerts | Medical Alerts.
public Field | MedicalRecordLocator | Medical Record Locator.
public Field | MediumType | Medium Type.
public Field | MemoryAllocation | Memory Allocation.
public Field | MemoryBitDepth | Memory Bit Depth.
public Field | MessageID | Message ID.
public Field | MessageIDBeingRespondedTo | Message ID Being Responded To.
public Field | MessageSetID | Message Set ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MetaboliteMapCodeSequence | Metabolite Map Code Sequence.
public Field | MetaboliteMapDescription | Metabolite Map Description.
public Field | MetaInfoHeader | DICOM meta information header.
public Field | MetersetExposure | Meterset Exposure.
public Field | MetersetRate | Meterset Rate.
public Field | MetersetRateDelivered | Meterset Rate Delivered.
public Field | MetersetRateSet | Meterset Rate Set.
public Field | MidSlabPosition | Mid Slab Position.
public Field | MilitaryRank | Military Rank.
public Field | MIMETypeofEncapsulatedDocument | MIME Type of Encapsulated Document.
public Field | MinDensity | Min Density.
public Field | MinimumCoordinateValue | Minimum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModalitiesInStudy | Modalities in Study.
public Field | Modality | Modality value.
public Field | ModalityLUTSequence | Modality LUT Sequence.
public Field | ModalityLUTType | Modality LUT Type.
public Field | ModifiedAttributesSequence | Modified Attributes Sequence.
public Field | ModifiedImageDate | Modified Image Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageDescription | Modified Image Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageID | Modified Image ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageTime | Modified Image Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifierCodeSequence | Modifier Code Sequence.
public Field | ModifyingDeviceID | Modifying Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifyingDeviceManufacturer | Modifying Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifyingSystem | Modifying System.
public Field | MostRecentTreatmentDate | Most Recent Treatment Date.
public Field | MotionSynchronizationSequence | Motion Synchronization Sequence.
public Field | MoveDestination | Move Destination.
public Field | MoveOriginatorApplicationEntityTitle | Move Originator Application Entity Title.
public Field | MoveOriginatorMessageID | Move Originator Message ID.
public Field | MRAcquisitionFrequencyEncodingSteps | MR Acquisition Frequency Encoding Steps.
public Field | MRAcquisitionPhaseEncodingStepsInPlane | MR Acquisition Phase Encoding Steps in-plane.
public Field | MRAcquisitionPhaseEncodingStepsOutOfPlane | MR Acquisition Phase Encoding Steps out-of-plane.
public Field | MrAcquisitionType | MR Acquisition Type.
public Field | MrAveragesSequence | MR Averages Sequence.
public Field | MrDiffusionSequence | MR Diffusion Sequence.
public Field | MRDRDirectoryRecordOffset | MRDR Directory Record Offset. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MrEchoSequence | MR Echo Sequence.
public Field | MrFovGeometrySequence | MR FOV/Geometry Sequence.
public Field | MrImageFrameTypeSequence | MR Image Frame Type Sequence.
public Field | MrImagingModifierSequence | MR Imaging Modifier Sequence.
public Field | MrMetaboliteMapSequence | MR Metabolite Map Sequence.
public Field | MrModifierSequence | MR Modifier Sequence.
public Field | MrReceiveCoilSequence | MR Receive Coil Sequence.
public Field | MrSpatialSaturationSequence | MR Spatial Saturation Sequence.
public Field | MRSpectroscopyAcquisitionType | MR Spectroscopy Acquisition Type.
public Field | MrSpectroscopyFovGeometrySequence | MR Spectroscopy FOV/Geometry Sequence.
public Field | MrSpectroscopyFrameTypeSequence | MR Spectroscopy Frame Type Sequence.
public Field | MrTimingAndRelatedParametersSequence | MR Timing and Related Parameters Sequence.
public Field | MrTransmitCoilSequence | MR Transmit Coil Sequence.
public Field | MrVelocityEncodingSequence | MR Velocity Encoding Sequence.
public Field | MultiCoilConfiguration | Multi-Coil Configuration.
public Field | MultiCoilDefinitionSequence | Multi-Coil Definition Sequence.
public Field | MultiCoilElementName | Multi-Coil Element Name.
public Field | MultiCoilElementUsed | Multi-Coil Element Used.
public Field | MultiFramePresentationSequence | Multi-frame Presentation Sequence.
public Field | MultiFrameSourceSOPInstanceUID | Multi-Frame Source SOP Instance UID.
public Field | MultiPlanarExcitation | Multi-planar Excitation.
public Field | MultipleCopiesFlag | Multiple Copies Flag.
public Field | MultipleSpinEcho | Multiple Spin Echo.
public Field | MultiplexedAudioChannelsDescriptionCodeSequence | Multiplexed Audio Channels Description Code Sequence.
public Field | MultiplexGroupLabel | Multiplex Group Label.
public Field | MultiplexGroupTimeOffset | Multiplex Group Time Offset.
public Field | MydriaticAgentCodeSequence | Mydriatic Agent Code Sequence.
public Field | MydriaticAgentConcentration | Mydriatic Agent Concentration.
public Field | MydriaticAgentConcentrationUnitsSequence | Mydriatic Agent Concentration Units Sequence.
public Field | MydriaticAgentSequence | Mydriatic Agent Sequence.
public Field | NameOfPhysiciansReadingStudy | Name of Physician(s) Reading Study.
public Field | NamesOfIntendedRecipientsOfResults | Names of Intended Recipients of Results.
public Field | NavigationDisplaySet | Navigation Display Set.
public Field | NavigationIndicatorSequence | Navigation Indicator Sequence.
public Field | NearPupillaryDistance | Near Pupillary Distance.
public Field | NetworkID | Network ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NominalBeamEnergy | Nominal Beam Energy.
public Field | NominalBeamEnergyUnit | Nominal Beam Energy Unit.
public Field | NominalCardiacTriggerDelayTime | Nominal Cardiac Trigger Delay Time.
public Field | NominalInterval | Nominal Interval.
public Field | NominalPercentageOfCardiacPhase | Nominal Percentage of Cardiac Phase.
public Field | NominalPercentageOfRespiratoryPhase | Nominal Percentage of Respiratory Phase.
public Field | NominalPriorDose | Nominal Prior Dose.
public Field | NominalRespiratoryTriggerDelayTime | Nominal Respiratory Trigger Delay Time.
public Field | NominalScannedPixelSpacing | Nominal Scanned Pixel Spacing.
public Field | NominalScreenDefinitionSequence | Nominal Screen Definition Sequence.
public Field | NonDICOMOutputCodeSequence | Non-DICOM Output Code Sequence.
public Field | NonUniformRadialSamplingCorrected | Non-uniform Radial Sampling Corrected.
public Field | NormalizationFactorFormat | Normalization Factor Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NormalizationPoint | Normalization Point.
public Field | NormalReverse | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NorRev | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NotchFilterBandwidth | Notch Filter Bandwidth.
public Field | NotchFilterFrequency | Notch Filter Frequency.
public Field | NTPSourceAddress | NTP Source Address.
public Field | NuclearMedicineSeriesType | Nuclear Medicine Series Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfAverages | Number of Averages.
public Field | NumberOfBeams | Number of Beams.
public Field | NumberOfBlocks | Number of Blocks.
public Field | NumberOfBoli | Number of Boli.
public Field | NumberOfBrachyApplicationSetups | Number of Brachy Application Setups.
public Field | NumberOfChannels | Number of Channels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfCompensators | Number of Compensators.
public Field | NumberOfCompletedSuboperations | Number of Completed Sub-operations.
public Field | NumberOfContourPoints | Number of Contour Points.
public Field | NumberOfControlPoints | Number of Control Points.
public Field | NumberOfCopies | Number of Copies.
public Field | NumberOfDetectors | Number of Detectors.
public Field | NumberOfEnergyWindows | Number of Energy Windows.
public Field | NumberOfEventTimers | Number of Event Timers.
public Field | NumberOfFailedSuboperations | Number of Failed Sub-operations.
public Field | NumberOfFilms | Number of Films.
public Field | NumberOfFractionPatternDigitsPerDay | Number of Fraction Pattern Digits Per Day.
public Field | NumberOfFractionsDelivered | Number of Fractions Delivered.
public Field | NumberOfFractionsPlanned | Number of Fractions Planned.
public Field | NumberOfFrames | Number of Frames.
public Field | NumberOfFramesInOverlay | Number of Frames in Overlay.
public Field | NumberOfFramesInPhase | Number of Frames in Phase.
public Field | NumberOfFramesInRotation | Number of Frames in Rotation.
public Field | NumberOfGraphicPoints | Number of Graphic Points.
public Field | NumberofHorizontalPixels | Number of Horizontal Pixels.
public Field | NumberOfIterations | Number of Iterations.
public Field | NumberOfKspaceTrajectories | Number of k-Space Trajectories.
public Field | NumberofLateralSpreadingDevices | Number of Lateral Spreading Devices.
public Field | NumberOfLeafJawPairs | Number of Leaf/Jaw Pairs.
public Field | NumberOfMatches | Number of Matches. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofPaintings | Number of Paintings.
public Field | NumberOfPatientRelatedInstances | Number of Patient Related Instances.
public Field | NumberOfPatientRelatedSeries | Number of Patient Related Series.
public Field | NumberOfPatientRelatedStudies | Number of Patient Related Studies.
public Field | NumberOfPhaseEncodingSteps | Number of Phase Encoding Steps.
public Field | NumberOfPhases | Number of Phases.
public Field | NumberOfPoints | Number of Points. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofPriorsReferenced | Number of Priors Referenced.
public Field | NumberOfPulses | Number of Pulses.
public Field | NumberofRangeModulators | Number of Range Modulators.
public Field | NumberofRangeShifters | Number of Range Shifters.
public Field | NumberOfReferences | Number of References. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfRemainingSuboperations | Number of Remaining Sub-operations.
public Field | NumberOfRotations | Number of Rotations.
public Field | NumberOfRrIntervals | Number of R-R Intervals.
public Field | NumberOfSamples | Number of Samples. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofScanSpotPositions | Number of Scan Spot Positions.
public Field | NumberofScreens | Number of Screens.
public Field | NumberOfSeriesRelatedInstances | Number of Series Related Instances.
public Field | NumberOfSlices | Number of Slices.
public Field | NumberOfStages | Number of Stages.
public Field | NumberOfStudyRelatedInstances | Number of Study Related Instances.
public Field | NumberOfStudyRelatedSeries | Number of Study Related Series.
public Field | NumberOfSubsets | Number of Subsets.
public Field | NumberOfSurfacePoints | Number of Surface Points.
public Field | NumberOfSurfaces | Number of Surfaces.
public Field | NumberOfTable | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTableBreakPoints | Number of Table Break Points.
public Field | NumberOfTableEntries | Number of Table Entries.
public Field | NumberOfTables | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTemporalPositions | Number of Temporal Positions.
public Field | NumberOfTimeSlices | Number of Time Slices.
public Field | NumberOfTimeSlots | Number of Time Slots.
public Field | NumberOfTomosynthesisSourceImages | Number of Tomosynthesis Source Images.
public Field | NumberOfTransformSteps | Number of Transform Steps. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTriggersInPhase | Number of Triggers in Phase.
public Field | NumberOfVectors | Number of Vectors.
public Field | NumberofVerticalPixels | Number of Vertical Pixels.
public Field | NumberOfViewsInStage | Number of Views in Stage.
public Field | NumberOfWarningSuboperations | Number of Warning Sub-operations.
public Field | NumberOfWaveformChannels | Number of Waveform Channels.
public Field | NumberOfWaveformSamples | Number of Waveform Samples.
public Field | NumberOfWedges | Number of Wedges.
public Field | NumberOfZeroFills | Number of Zero fills.
public Field | NumericValue | Numeric Value.
public Field | NumericValueQualifierCodeSequence | Numeric Value Qualifier Code Sequence.
public Field | ObjectPixelSpacinginCenterofBeam | Object Pixel Spacing in Center of Beam.
public Field | ObjectThicknessSequence | Object Thickness Sequence.
public Field | ObservationDateTime | Observation Date Time.
public Field | ObservationNumber | Observation Number.
public Field | ObserverType | Observer Type.
public Field | Occupation | Patient's Occupation.
public Field | OffendingElement | Offending Element.
public Field | OffsetOfReferencedLowerLevelDirectoryEntity | Offset of Referenced Lower-Level Directory Entity.
public Field | OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | Offset of the First Directory Record of the Root Directory Entity.
public Field | OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | Offset of the Last Directory Record of the Root Directory Entity.
public Field | OffsetOfTheNextDirectoryRecord | Offset of the Next Directory Record.
public Field | OnAxisBackgroundAnatomicStructureCodeSequence | OnAxis Background Anatomic Structure Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OperatingMode | Operating Mode.
public Field | OperatingModeSequence | Operating Mode Sequence.
public Field | OperatingModeType | Operating Mode Type.
public Field | OperatorIdentificationSequence | Operator Identification Sequence.
public Field | OperatorsName | Operators' Name.
public Field | OphthalmicFrameLocationSequence | Ophthalmic Frame Location Sequence.
public Field | OphthalmicImageOrientation | Ophthalmic Image Orientation.
public Field | OpticalTransmittance | Optical Transmittance.
public Field | Optotype | Optotype tag.
public Field | OptotypeDetailedDefinition | Optotype Detailed Definition.
public Field | OptotypePresentation | Optotype Presentation.
public Field | OrderCallbackPhoneNumber | Order Callback Phone Number.
public Field | OrderEnteredBy | Order Entered By.
public Field | OrderEnterersLocation | Order Enterer's Location.
public Field | OrderFillerIdentifierSequence | Order Filler Identifier Sequence.
public Field | OrderPlacerIdentifierSequence | Order Placer Identifier Sequence.
public Field | OrganAtRiskFullVolumeDose | Organ at Risk Full-volume Dose.
public Field | OrganAtRiskLimitDose | Organ at Risk Limit Dose.
public Field | OrganAtRiskMaximumDose | Organ at Risk Maximum Dose.
public Field | OrganAtRiskOverdoseVolumeFraction | Organ at Risk Overdose Volume Fraction.
public Field | OrganDose | Organ Dose.
public Field | OrganExposed | Organ Exposed.
public Field | OriginalAttributesSequence | Original Attributes Sequence.
public Field | OriginalImageIdentification | Original Image Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalImageIdentificationNomenclature | Original Image Identification Nomenclature. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalImageSequence | Original Image Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalSpecializedSOPClassUID | Original Specialized SOP Class UID.
public Field | Originator | The Originator.
public Field | OtherMagnificationTypesAvailable | Other Magnification Types Available.
public Field | OtherMediaAvailableSequence | Other Media Available Sequence.
public Field | OtherPatientIDs | Other Patient IDs.
public Field | OtherPatientIDsSequence | Other Patient IDs Sequence.
public Field | OtherPatientNames | Other Patient Names.
public Field | OtherPupillaryDistance | Other Pupillary Distance.
public Field | OtherSmoothingTypesAvailable | Other Smoothing Types Available.
public Field | OtherStudyNumbers | Other Study Numbers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OutputInformationSequence | Output Information Sequence.
public Field | OutputPower | Output Power.
public Field | OverlayActivationLayer | Overlay Activation Layer.
public Field | OverlayBackgroundDensity | Overlay Background Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayBitPosition | Overlay Bit Position.
public Field | OverlayBitsAllocated | Overlay Bits Allocated.
public Field | OverlayBitsForCodeWord | Overlay Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayBitsGrouped | Overlay Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCodeLabel | Overlay Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCodeTableLocation | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayColumns | Overlay Columns.
public Field | OverlayComments | Overlay Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionCode | Overlay Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionDescription | Overlay Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionLabel | Overlay Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionOriginator | Overlay Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionStepPointers | Overlay Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayData | Overlay Data.
public Field | OverlayDate | Overlay Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescription | Overlay Description.
public Field | OverlayDescriptorBlue | Overlay Descriptor - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorGray | Overlay Descriptor - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorGreen | Overlay Descriptor - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorRed | Overlay Descriptor - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayForegroundDensity | Overlay Foreground Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayFormat | Overlay Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayLabel | Overlay Label.
public Field | OverlayLocation | Overlay Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayMagnificationType | Overlay Magnification Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayMode | Overlay Mode. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayNumber | Overlay Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayNumberOfTables | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayOrigin | Overlay Origin.
public Field | OverlayorImageMagnification | Overlay or Image Magnification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPixelDataSequence | Overlay Pixel Data Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPlaneOrigin | Overlay Plane Origin. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPlanes | Overlay Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayRepeatInterval | Overlay Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayRows | Overlay Rows.
public Field | Overlays | Overlays. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysBlue | Overlays - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysGray | Overlays - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysGreen | Overlays - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaySmoothingType | Overlay Smoothing Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysRed | Overlays - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaySubtype | Overlay Subtype.
public Field | OverlayTime | Overlay Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayType | Overlay Type.
public Field | OverriddenAttributesSequence | Overridden Attributes Sequence.
public Field | OverrideParameterPointer | Override Parameter Pointer.
public Field | OverrideReason | Override Reason.
public Field | OverrideSequence | Override Sequence.
public Field | OverSamplingPhase | Oversampling Phase.
public Field | OwnerID | Owner Identifier.
public Field | PageNumberVector | Page Number Vector.
public Field | PagePositionID | Page Position ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PaletteColorLookupTableUID | Palette Color Lookup Table UID.
public Field | ParallelAcquisition | Parallel Acquisition.
public Field | ParallelAcquisitionTechnique | Parallel Acquisition Technique.
public Field | ParallelReductionFactorInPlane | Parallel Reduction Factor In-plane.
public Field | ParallelReductionFactorInPlaneRetired | Parallel Reduction Factor In-plane (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ParallelReductionFactorOutOfPlane | Parallel Reduction Factor out-of-plane.
public Field | ParallelReductionFactorSecondInPlane | Parallel Reduction Factor Second In-plane.
public Field | ParameterItemIndex | Parameter Item Index.
public Field | ParameterPointer | Parameter Pointer.
public Field | ParameterSequencePointer | Parameter Sequence Pointer.
public Field | PartialDataDisplayHandling | Partial Data Display Handling.
public Field | PartialFourier | Partial Fourier.
public Field | PartialFourierDirection | Partial Fourier Direction.
public Field | PartialView | Partial View.
public Field | PartialViewCodeSequence | Partial View Code Sequence.
public Field | PartialViewDescription | Partial View Description.
public Field | ParticipantSequence | Participant Sequence.
public Field | ParticipationDateTime | Participation DateTime.
public Field | ParticipationType | Participation Type.
public Field | PatientAdditionalPosition | Patient Additional Position.
public Field | PatientAddress | Patient's Address.
public Field | PatientAge | Patient's Age.
public Field | PatientBirthDate | Patient's Birth Date.
public Field | PatientBirthName | Patient's Birth Name.
public Field | PatientBirthTime | Patient's Birth Time.
public Field | PatientBreedCodeSequence | Patient Breed Code Sequence.
public Field | PatientBreedDescription | Patient Breed Description.
public Field | PatientClinicalTrialParticipationSequence | Patient Clinical Trial Participation Sequence.
public Field | PatientComments | Patient Comments.
public Field | PatientEyeMovementCommandCodeSequence | Patient Eye Movement Command Code Sequence.
public Field | PatientEyeMovementCommanded | Patient Eye Movement Commanded.
public Field | PatientFrameOfReferenceSource | Patient Frame of Reference Source.
public Field | PatientGantryRelationshipCodeSequence | Patient Gantry Relationship Code Sequence.
public Field | PatientID | Patient ID.
public Field | PatientIdentityRemoved | Patient Identity Removed.
public Field | PatientInsurancePlanCodeSequence | Patient's Insurance Plan Code Sequence.
public Field | PatientMotherBirthName | Patient's Mother's Birth Name.
public Field | PatientMotionCorrected | Patient Motion Corrected.
public Field | PatientName | Patient's Name.
public Field | PatientOrientation | Patient Orientation.
public Field | PatientOrientationCodeSequence | Patient Orientation Code Sequence.
public Field | PatientOrientationinFrameSequence | Patient Orientation in Frame Sequence.
public Field | PatientOrientationModifierCodeSequence | Patient Orientation Modifier Code Sequence.
public Field | PatientPhysiologicalStateCodeSequence | Patient Physiological State Code Sequence.
public Field | PatientPhysiologicalStateSequence | Patient Physiological State Sequence.
public Field | PatientPosition | Patient Position.
public Field | PatientPrimaryLanguageCodeSequence | Patient's Primary Language Code Sequence.
public Field | PatientPrimaryLanguageModifierCodeSequence | Patient's Primary Language Modifier Code Sequence.
public Field | PatientReligiousPreference | Patient's Religious Preference.
public Field | PatientSetupLabel | Patient Setup Label.
public Field | PatientSetupNumber | Patient Setup Number.
public Field | PatientSetupSequence | Patient Setup Sequence.
public Field | PatientSex | Patient's Sex.
public Field | PatientSexNeutered | Patient's Sex Neutered.
public Field | PatientsInstitutionResidence | Patient's Institution Residence.
public Field | PatientSize | Patient's Size.
public Field | PatientSpeciesCodeSequence | Patient Species Code Sequence.
public Field | PatientSpeciesDescription | Patient Species Description.
public Field | PatientState | Patient State.
public Field | PatientSupportAccessoryCode | Patient Support Accessory Code.
public Field | PatientSupportAngle | Patient Support Angle.
public Field | PatientSupportAngleTolerance | Patient Support Angle Tolerance.
public Field | PatientSupportID | Patient Support ID.
public Field | PatientSupportRotationDirection | Patient Support Rotation Direction.
public Field | PatientSupportType | Patient Support Type.
public Field | PatientTelephoneNumbers | Patient's Telephone Numbers.
public Field | PatientTransportArrangements | Patient Transport Arrangements.
public Field | PatientWeight | Patient's Weight.
public Field | PauseBetweenFrames | Pause Between Frames.
public Field | PercentPhaseFieldOfView | Percent Phase Field of View.
public Field | PercentSampling | Percent Sampling.
public Field | PerformedLocation | Performed Location.
public Field | PerformedProcedureCodeSequence | Performed Procedure Code Sequence.
public Field | PerformedProcedureStepDescription | Performed Procedure Step Description.
public Field | PerformedProcedureStepDiscontinuationReasonCodeSequence | Performed Procedure Step Discontinuation Reason Code Sequence.
public Field | PerformedProcedureStepEndDate | Performed Procedure Step End Date.
public Field | PerformedProcedureStepEndTime | Performed Procedure Step End Time.
public Field | PerformedProcedureStepID | Performed Procedure Step ID.
public Field | PerformedProcedureStepStartDate | Performed Procedure Step Start Date.
public Field | PerformedProcedureStepStartTime | Performed Procedure Step Start Time.
public Field | PerformedProcedureStepStatus | Performed Procedure Step Status.
public Field | PerformedProcedureTypeDescription | Performed Procedure Type Description.
public Field | PerformedProcessingApplicationsCodeSequence | Performed Processing Applications Code Sequence.
public Field | PerformedProcessingParametersSequence | Performed Processing Parameters Sequence.
public Field | PerformedProtocolCodeSequence | Performed Protocol Code Sequence.
public Field | PerformedProtocolType | Performed Protocol Type.
public Field | PerformedSeriesSequence | Performed Series Sequence.
public Field | PerformedStationAeTitle | Performed Station AE Title.
public Field | PerformedStationClassCodeSequence | Performed Station Class Code Sequence.
public Field | PerformedStationGeographicLocationCodeSequence | Performed Station Geographic Location Code Sequence.
public Field | PerformedStationName | Performed Station Name.
public Field | PerformedStationNameCodeSequence | Performed Station Name Code Sequence.
public Field | PerformedWorkitemCodeSequence | Performed Workitem Code Sequence.
public Field | PerformingPhysicianIdentificationSequence | Performing Physician Identification Sequence.
public Field | PerformingPhysiciansName | Performing Physician's Name.
public Field | PerFrameFunctionalGroupsSequence | Per-frame Functional Groups Sequence.
public Field | PerimeterTable | Perimeter Table. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PerimeterValue | Perimeter Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PerProjectionAcquisitionSequence | Per Projection Acquisition Sequence.
public Field | PersonIdentificationCodeSequence | Person Identification Code Sequence.
public Field | PersonName | Person Name.
public Field | PersonsAddress | Person's Address.
public Field | PersonsTelephoneNumbers | Person's Telephone Numbers.
public Field | PertinentDocumentsSequence | Pertinent Documents Sequence.
public Field | PertinentOtherEvidenceSequence | Pertinent Other Evidence Sequence.
public Field | PETDetectorMotionDetailsSequence | PET Detector Motion Details Sequence.
public Field | PETFrameAcquisitionSequence | PET Frame Acquisition Sequence.
public Field | PETFrameCorrectionFactorsSequence | PET Frame Correction Factors Sequence.
public Field | PETFrameTypeSequence | PET Frame Type Sequence.
public Field | PETPositionSequence | PET Position Sequence.
public Field | PETReconstructionSequence | PET Reconstruction Sequence.
public Field | PETTableDynamicsSequence | PET Table Dynamics Sequence.
public Field | PhaseContrast | Phase Contrast.
public Field | PhaseDelay | Phase Delay.
public Field | PhaseDescription | Phase Description.
public Field | PhaseInformationSequence | Phase Information Sequence.
public Field | PhaseNumber | Phase Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PhaseVector | Phase Vector.
public Field | PhosphorType | Phosphor Type.
public Field | PhotometricInterpretation | Photometric Interpretation.
public Field | PhototimerSetting | Phototimer Setting.
public Field | PhysicalDeltaX | Physical Delta X.
public Field | PhysicalDeltaY | Physical Delta Y.
public Field | PhysicalDetectorSize | Physical Detector Size.
public Field | PhysicalUnitsXDirection | Physical Units X Direction.
public Field | PhysicalUnitsYDirection | Physical Units Y Direction.
public Field | PhysicianApprovingInterpretation | Physician Approving Interpretation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PhysiciansOfRecord | Physician(s) of Record.
public Field | PhysiciansOfRecordIdentificationSequence | Physician(s) of Record Identification Sequence.
public Field | PhysiciansReadingStudyIdentificationSequence | Physician(s) Reading Study Identification Sequence.
public Field | PixelAspectRatio | Pixel Aspect Ratio.
public Field | PixelBandwidth | Pixel Bandwidth.
public Field | PixelComponentDataType | Pixel Component Data Type.
public Field | PixelComponentMask | Pixel Component Mask.
public Field | PixelComponentOrganization | Pixel Component Organization.
public Field | PixelComponentPhysicalUnits | Pixel Component Physical Units.
public Field | PixelComponentRangeStart | Pixel Component Range Start.
public Field | PixelComponentRangeStop | Pixel Component Range Stop.
public Field | PixelCoordinateSet | Pixel Coordinate Set.
public Field | PixelData | Pixel Data.
public Field | PixelDataProviderURL | Pixel Data Provider URL.
public Field | PixelIntensityRelationship | Pixel Intensity Relationship.
public Field | PixelIntensityRelationshipLUTSequence | Pixel Intensity Relationship LUT Sequence.
public Field | PixelIntensityRelationshipSign | Pixel Intensity Relationship Sign.
public Field | PixelMeasuresSequence | Pixel Measures Sequence.
public Field | PixelPaddingRangeLimit | Pixel Padding Range Limit.
public Field | PixelPaddingValue | Pixel Padding Value.
public Field | PixelPresentation | Pixel Presentation.
public Field | PixelRepresentation | Pixel Representation.
public Field | PixelShiftFrameRange | Pixel Shift Frame Range.
public Field | PixelShiftSequence | Pixel Shift Sequence.
public Field | PixelSpacing | Pixel Spacing.
public Field | PixelSpacingCalibrationDescription | Pixel Spacing Calibration Description.
public Field | PixelSpacingCalibrationType | Pixel Spacing Calibration Type.
public Field | PixelSpacingSequence | Pixel Spacing Sequence.
public Field | PixelValueMappingCodeSequence | Pixel Value Mapping Code Sequence.
public Field | PixelValueTransformationSequence | Pixel Value Transformation Sequence.
public Field | PlacerOrderNumberImagingServiceRequest | Placer Order Number / Imaging Service Request.
public Field | PlacerOrderNumberImagingServiceRequestRetired | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlacerOrderNumberProcedure | Placer Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlanarConfiguration | Planar Configuration.
public Field | PlaneIdentification | Plane Identification.
public Field | PlaneOrientationSequence | Plane Orientation Sequence.
public Field | PlaneOrientationVolumeSequence | Plane Orientation (Volume) Sequence.
public Field | PlanePositionSequence | Plane Position Sequence.
public Field | PlanePositionVolumeSequence | Plane Position (Volume) Sequence.
public Field | Planes | Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlanIntent | Plan Intent.
public Field | PlannedVerificationImageSequence | Planned Verification Image Sequence.
public Field | PlateID | Plate Identifier.
public Field | PlateType | Plate Type.
public Field | PointCoordinatesData | Point Coordinates Data.
public Field | PointPositionAccuracy | Point Position Accuracy.
public Field | PointsBoundingBoxCoordinates | Points Bounding Box Coordinates.
public Field | Polarity | Image Polarity.
public Field | PositionerIsocenterDetectorRotationAngle | Positioner Isocenter Detector Rotation Angle.
public Field | PositionerIsocenterPrimaryAngle | Positioner Isocenter Primary Angle.
public Field | PositionerIsocenterSecondaryAngle | Positioner Isocenter Secondary Angle.
public Field | PositionerMotion | Positioner Motion.
public Field | PositionerPositionSequence | Positioner Position Sequence.
public Field | PositionerPrimaryAngle | Positioner Primary Angle.
public Field | PositionerPrimaryAngleIncrement | Positioner Primary Angle Increment.
public Field | PositionerSecondaryAngle | Positioner Secondary Angle.
public Field | PositionerSecondaryAngleIncrement | Positioner Secondary Angle Increment.
public Field | PositionerType | Positioner Type.
public Field | PositionMeasuringDeviceUsed | Position Measuring Device Used.
public Field | PositionofIsocenterProjection | Position of Isocenter Projection.
public Field | PositionReferenceIndicator | Position Reference Indicator.
public Field | PostDeformationMatrixRegistrationSequence | Post Deformation Matrix Registration Sequence.
public Field | PostprocessingFunction | Postprocessing Function. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Preamble | DICOM preamble.
public Field | PredecessorDocumentsSequence | Predecessor Documents Sequence.
public Field | PreDeformationMatrixRegistrationSequence | Pre Deformation Matrix Registration Sequence.
public Field | PredictorColumns | Predictor Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PredictorConstants | Predictor Constants. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PredictorRows | Predictor Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PreferredPlaybackSequencing | Preferred Playback Sequencing.
public Field | PregnancyStatus | Pregnancy Status.
public Field | PreliminaryFlag | Preliminary Flag.
public Field | PreMedication | Pre Medication.
public Field | PrescriptionDescription | Prescription Description.
public Field | PresentationCreationDate | Presentation Creation Date.
public Field | PresentationCreationTime | Presentation Creation Time.
public Field | PresentationGroupNumber | Presentation Group Number.
public Field | PresentationIntentType | Presentation Intent Type.
public Field | PresentationLutContentSequence | Presentation LUT Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PresentationLutFlag | Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PresentationLutSequence | Presentation LUT Sequence.
public Field | PresentationLutShape | Presentation LUT Shape.
public Field | PresentationPixelAspectRatio | Presentation Pixel Aspect Ratio.
public Field | PresentationPixelMagnificationRatio | Presentation Pixel Magnification Ratio.
public Field | PresentationPixelSpacing | Presentation Pixel Spacing.
public Field | PresentationSizeMode | Presentation Size Mode.
public Field | PreserveCompositeInstancesAfterMediaCreation | Preserve Composite Instances After Media Creation.
public Field | PrimaryAnatomicStructureModifierSequence | Primary Anatomic Structure Modifier Sequence.
public Field | PrimaryAnatomicStructureSequence | Primary Anatomic Structure Sequence.
public Field | PrimaryDosimeterUnit | Primary Dosimeter Unit.
public Field | PrimaryFluenceModeSequence | Primary Fluence Mode Sequence.
public Field | PrimaryPositionerIncrement | Primary Positioner Increment.
public Field | PrimaryPositionerScanArc | Primary Positioner Scan Arc.
public Field | PrimaryPositionerScanStartAngle | Primary Positioner Scan Start Angle.
public Field | PrimaryPromptsCountsAccumulated | Primary (Prompts) Counts Accumulated.
public Field | PrimitivePointIndexList | Primitive Point Index List.
public Field | Print | Print. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrinterCharacteristicsSequence | Printer Characteristics Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrinterConfigurationSequence | Printer Configuration Sequence.
public Field | PrinterName | Printer Name.
public Field | PrinterPixelSpacing | Printer Pixel Spacing.
public Field | PrinterResolutionID | Printer Resolution ID.
public Field | PrinterStatus | Printer Status.
public Field | PrinterStatusInfo | Printer Status Info.
public Field | PrintingBitDepth | Printing Bit Depth.
public Field | PrintJobDescriptionSequence | Print Job Description Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintJobID | Print Job ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintManagementCapabilitiesSequence | Print Management Capabilities Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintPriority | Print Priority.
public Field | PrintQueueID | Print Queue ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Priority | Operation Priority.
public Field | PrismSequence | Prism Sequence.
public Field | PrivateInformation | Private Information.
public Field | PrivateInformationCreatorUID | Private Information Creator UID.
public Field | PrivateRecordUID | Private Record UID.
public Field | ProcedureCodeSequence | Procedure Code Sequence.
public Field | ProcedureStepLabel | Procedure Step Label.
public Field | ProcedureStepRelationshipType | Procedure Step Relationship Type.
public Field | ProcessingFunction | Processing Function.
public Field | ProductDescription | Product Description.
public Field | ProductExpirationDateTime | Product Expiration DateTime.
public Field | ProductLotIdentifier | Product Lot Identifier.
public Field | ProductName | Product Name.
public Field | ProductPackageIdentifier | Product Package Identifier.
public Field | ProductParameterSequence | Product Parameter Sequence.
public Field | ProductTypeCodeSequence | Product Type Code Sequence.
public Field | ProjectionEponymousNameCodeSequence | Projection Eponymous Name Code Sequence.
public Field | ProjectionPixelCalibrationSequence | Projection Pixel Calibration Sequence.
public Field | ProposedStudySequence | Proposed Study Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ProtocolContextSequence | Protocol Context Sequence.
public Field | ProtocolName | Protocol Name.
public Field | PseudocolorType | Pseudo-color Type.
public Field | PulseRepetitionFrequency | Pulse Repetition Frequency.
public Field | PulseRepetitionInterval | Pulse Repetition Interval.
public Field | PulseSequenceName | Pulse Sequence Name.
public Field | PupilDilated | Pupil Dilated.
public Field | PupilSize | Pupil Size.
public Field | PurposeOfReferenceCodeSequence | Purpose of Reference Code Sequence.
public Field | PvcRejection | PVC Rejection.
public Field | QuadratureReceiveCoil | Quadrature Receive Coil.
public Field | QualityControlImage | Quality Control Image.
public Field | Quantity | Quantity value.
public Field | QuantitySequence | Quantity Sequence.
public Field | QueryRetrieveLevel | Query/Retrieve Level.
public Field | QueueStatus | Queue Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RadialPosition | Radial Position.
public Field | RadiationAtomicNumber | Radiation Atomic Number.
public Field | RadiationChargeState | Radiation Charge State.
public Field | RadiationMachineName | Radiation Machine Name.
public Field | RadiationMachineSad | Radiation Machine SAD.
public Field | RadiationMachineSsd | Radiation Machine SSD.
public Field | RadiationMassNumber | Radiation Mass Number.
public Field | RadiationMode | Radiation Mode.
public Field | RadiationSetting | Radiation Setting.
public Field | RadiationType | Radiation Type.
public Field | Radionuclide | Radionuclide. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RadionuclideCodeSequence | Radionuclide Code Sequence.
public Field | RadionuclideHalfLife | Radionuclide Half Life.
public Field | RadionuclidePositronFraction | Radionuclide Positron Fraction.
public Field | RadionuclideTotalDose | Radionuclide Total Dose.
public Field | Radiopharmaceutical | Radiopharmaceutical value.
public Field | RadiopharmaceuticalAgentNumber | Radiopharmaceutical Agent Number.
public Field | RadiopharmaceuticalCodeSequence | Radiopharmaceutical Code Sequence.
public Field | RadiopharmaceuticalInformationSequence | Radiopharmaceutical Information Sequence.
public Field | RadiopharmaceuticalRoute | Radiopharmaceutical Route.
public Field | RadiopharmaceuticalSpecificActivity | Radiopharmaceutical Specific Activity.
public Field | RadiopharmaceuticalStartDateTime | Radiopharmaceutical Start DateTime.
public Field | RadiopharmaceuticalStartTime | Radiopharmaceutical Start Time.
public Field | RadiopharmaceuticalStopDateTime | Radiopharmaceutical Stop DateTime.
public Field | RadiopharmaceuticalStopTime | Radiopharmaceutical Stop Time.
public Field | RadiopharmaceuticalUsageSequence | Radiopharmaceutical Usage Sequence.
public Field | RadiopharmaceuticalVolume | Radiopharmaceutical Volume.
public Field | RadiusOfCircularCollimator | Radius of Circular Collimator.
public Field | RadiusofCircularExposureControlSensingRegion | Radius of Circular Exposure Control Sensing Region.
public Field | RadiusOfCircularShutter | Radius of Circular Shutter.
public Field | RadiusOfCurvature | Radius of Curvature.
public Field | RandomsCorrected | Randoms Corrected.
public Field | RandomsCorrectionMethod | Randoms Correction Method.
public Field | RangeModulatorDescription | Range Modulator Description.
public Field | RangeModulatorGatingStartValue | Range Modulator Gating Start Value.
public Field | RangeModulatorGatingStartWaterEquivalentThickness | Range Modulator Gating Start Water Equivalent Thickness.
public Field | RangeModulatorGatingStopValue | Range Modulator Gating Stop Value.
public Field | RangeModulatorGatingStopWaterEquivalentThickness | Range Modulator Gating Stop Water Equivalent Thickness.
public Field | RangeModulatorID | Range Modulator ID.
public Field | RangeModulatorNumber | Range Modulator Number.
public Field | RangeModulatorSequence | Range Modulator Sequence.
public Field | RangeModulatorSettingsSequence | Range Modulator Settings Sequence.
public Field | RangeModulatorType | Range Modulator Type.
public Field | RangeShifterDescription | Range Shifter Description.
public Field | RangeShifterID | Range Shifter ID.
public Field | RangeShifterNumber | Range Shifter Number.
public Field | RangeShifterSequence | Range Shifter Sequence.
public Field | RangeShifterSetting | Range Shifter Setting.
public Field | RangeShifterSettingsSequence | Range Shifter Settings Sequence.
public Field | RangeShifterType | Range Shifter Type.
public Field | RangeShifterWaterEquivalentThickness | Range Shifter Water Equivalent Thickness.
public Field | RawDataHandling | Raw Data Handling.
public Field | RealWorldValueFirstValueMapped | Real World Value First Value Mapped.
public Field | RealWorldValueIntercept | Real World Value Intercept.
public Field | RealWorldValueLastValueMapped | Real World Value Last Value Mapped.
public Field | RealWorldValueLUTData | Real World Value LUT Data.
public Field | RealWorldValueMappingSequence | Real World Value Mapping Sequence.
public Field | RealWorldValueSlope | Real World Value Slope.
public Field | ReasonForCancellation | Reason for Cancellation.
public Field | ReasonForPerformedProcedureCodeSequence | Reason For Performed Procedure Code Sequence.
public Field | ReasonforRequestedProcedureCodeSequence | Reason for Requested Procedure Code Sequence.
public Field | ReasonForStudy | Reason for Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReasonForTheAttributeModification | Reason for the Attribute Modification.
public Field | ReasonForTheImagingServiceRequest | Reason for the Imaging Service Request. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReasonForTheRequestedProcedure | Reason for the Requested Procedure.
public Field | ReceiveCoilManufacturerName | Receive Coil Manufacturer Name.
public Field | ReceiveCoilName | Receive Coil Name.
public Field | ReceiveCoilType | Receive Coil Type.
public Field | ReceiverAeTitle | Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReceivingAE | Receiving AE.
public Field | RecognitionCode | Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RecognitionCodeRetired | Recognition Code (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RecommendedDisplayCIELabValue | Recommended Display CIELab Value.
public Field | RecommendedDisplayFrameRate | Recommended Display Frame Rate.
public Field | RecommendedDisplayFrameRateinFloat | Recommended Display Frame Rate in Float.
public Field | RecommendedDisplayGrayscaleValue | Recommended Display Grayscale Value.
public Field | RecommendedPresentationOpacity | Recommended Presentation Opacity.
public Field | RecommendedPresentationType | Recommended Presentation Type.
public Field | RecommendedViewingMode | Recommended Viewing Mode.
public Field | ReconstructionAlgorithm | Reconstruction Algorithm.
public Field | ReconstructionAngle | Reconstruction Angle.
public Field | ReconstructionDescription | Reconstruction Description.
public Field | ReconstructionDiameter | Reconstruction Diameter.
public Field | ReconstructionFieldofView | Reconstruction Field of View.
public Field | ReconstructionIndex | Reconstruction Index.
public Field | ReconstructionMethod | Reconstruction Method.
public Field | ReconstructionPixelSpacing | Reconstruction Pixel Spacing.
public Field | ReconstructionTargetCenterPatient | Reconstruction Target Center (Patient).
public Field | ReconstructionType | Reconstruction Type.
public Field | RecordedBlockSequence | Recorded Block Sequence.
public Field | RecordedBrachyAccessoryDeviceSequence | Recorded Brachy Accessory Device Sequence.
public Field | RecordedChannelSequence | Recorded Channel Sequence.
public Field | RecordedChannelShieldSequence | Recorded Channel Shield Sequence.
public Field | RecordedCompensatorSequence | Recorded Compensator Sequence.
public Field | RecordedLateralSpreadingDeviceSequence | Recorded Lateral Spreading Device Sequence.
public Field | RecordedRangeModulatorSequence | Recorded Range Modulator Sequence.
public Field | RecordedRangeShifterSequence | Recorded Range Shifter Sequence.
public Field | RecordedSnoutSequence | Recorded Snout Sequence.
public Field | RecordedSourceApplicatorSequence | Recorded Source Applicator Sequence.
public Field | RecordedSourceSequence | Recorded Source Sequence.
public Field | RecordedWedgeSequence | Recorded Wedge Sequence.
public Field | RecordInUseFlag | Record In-use Flag.
public Field | RectificationType | Rectification Type.
public Field | RectilinearPhaseEncodeReordering | Rectilinear Phase Encode Reordering.
public Field | RedPaletteColorLookupTableData | Red Palette Color Lookup Table Data.
public Field | RedPaletteColorLookupTableDescriptor | Red Palette Color Lookup Table Descriptor.
public Field | Reference | Reference. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferenceAirKermaRate | Reference Air Kerma Rate.
public Field | ReferenceCoordinates | Reference Coordinates.
public Field | ReferencedBasicAnnotationBoxSequence | Referenced Basic Annotation Box Sequence.
public Field | ReferencedBeamNumber | Referenced Beam Number.
public Field | ReferencedBeamSequence | Referenced Beam Sequence.
public Field | ReferencedBlockNumber | Referenced Block Number.
public Field | ReferencedBolusSequence | Referenced Bolus Sequence.
public Field | ReferencedBrachyAccessoryDeviceNumber | Referenced Brachy Accessory Device Number.
public Field | ReferencedBrachyApplicationSetupNumber | Referenced Brachy Application Setup Number.
public Field | ReferencedBrachyApplicationSetupSequence | Referenced Brachy Application Setup Sequence.
public Field | ReferencedCalculatedDoseReferenceNumber | Referenced Calculated Dose Reference Number.
public Field | ReferencedCalculatedDoseReferenceSequence | Referenced Calculated Dose Reference Sequence.
public Field | ReferencedChannelShieldNumber | Referenced Channel Shield Number.
public Field | ReferencedCompensatorNumber | Referenced Compensator Number.
public Field | ReferencedContentItemIdentifier | Referenced Content Item Identifier.
public Field | ReferencedControlPointIndex | Referenced Control Point Index.
public Field | ReferencedControlPointSequence | Referenced Control Point Sequence.
public Field | ReferencedCurveSequence | Referenced Curve Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedDateTime | Referenced DateTime.
public Field | ReferencedDigitalSignatureSequence | Referenced Digital Signature Sequence.
public Field | ReferencedDoseReferenceNumber | Referenced Dose Reference Number.
public Field | ReferencedDoseReferenceSequence | Referenced Dose Reference Sequence.
public Field | ReferencedDoseSequence | Referenced Dose Sequence.
public Field | ReferencedFileID | Referenced File ID.
public Field | ReferencedFileXferSynUID | Referenced Transfer Syntax UID in File.
public Field | ReferencedFilmBoxSequence | Referenced Film Box Sequence.
public Field | ReferencedFilmSessionSequence | Referenced Film Session Sequence.
public Field | ReferencedFirstFrameSequence | Referenced First Frame Sequence.
public Field | ReferencedFractionGroupNumber | Referenced Fraction Group Number.
public Field | ReferencedFractionGroupSequence | Referenced Fraction Group Sequence.
public Field | ReferencedFractionNumber | Referenced Fraction Number.
public Field | ReferencedFrameNumber | Referenced Frame Number.
public Field | ReferencedFrameNumbers | Referenced Frame Numbers.
public Field | ReferencedFrameOfReferenceSequence | Referenced Frame of Reference Sequence.
public Field | ReferencedFrameOfReferenceUID | Referenced Frame of Reference UID.
public Field | ReferencedGeneralPurposeScheduledProcedureStepSequence | Referenced General Purpose Scheduled Procedure Step Sequence.
public Field | ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | Referenced General Purpose Scheduled Procedure Step Transaction UID.
public Field | ReferencedImageBoxSequence | Referenced Image Box Sequence.
public Field | ReferencedImageBoxSequenceRetired | Referenced Image Box Sequence (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedImageEvidenceSequence | Referenced Image Evidence Sequence.
public Field | ReferencedImageOverlayBoxSequence | Referenced Image Overlay Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedImageRealWorldValueMappingSequence | Referenced Image Real World Value Mapping Sequence.
public Field | ReferencedImageSequence | Referenced Image Sequence.
public Field | ReferencedInstanceSequence | Referenced Instance Sequence.
public Field | ReferencedInterpretationSequence | Referenced Interpretation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferenceDisplaySets | Reference Display Sets.
public Field | ReferencedLateralSpreadingDeviceNumber | Referenced Lateral Spreading Device Number.
public Field | ReferencedMeasuredDoseReferenceNumber | Referenced Measured Dose Reference Number.
public Field | ReferencedMeasuredDoseReferenceSequence | Referenced Measured Dose Reference Sequence.
public Field | ReferencedNonImageCompositeSOPInstanceSequence | Referenced Non-Image Composite SOP Instance Sequence.
public Field | ReferencedOtherPlaneSequence | Referenced Other Plane Sequence.
public Field | ReferencedOverlayPlaneGroups | Referenced Overlay Plane Groups. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedOverlayPlaneSequence | Referenced Overlay Plane Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedOverlaySequence | Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedPatientAliasSequence | Referenced Patient Alias Sequence.
public Field | ReferencedPatientSequence | Referenced Patient Sequence.
public Field | ReferencedPatientSetupNumber | Referenced Patient Setup Number.
public Field | ReferencedPerformedProcedureStepSequence | Referenced Performed Procedure Step Sequence.
public Field | ReferencedPresentationLutSequence | Referenced Presentation LUT Sequence.
public Field | ReferencedPresentationStateSequence | Referenced Presentation State Sequence.
public Field | ReferencedPreviousWaveform | Referenced Previous Waveform.
public Field | ReferencedPrintJobSequence | Referenced Print Job Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedPrintJobSequencePullStoredPrint | Referenced Print Job Sequence (Pull Stored Print). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedProcedureStepSequence | Referenced Procedure Step Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedRangeModulatorNumber | Referenced Range Modulator Number.
public Field | ReferencedRangeShifterNumber | Referenced Range Shifter Number.
public Field | ReferencedRawDataSequence | Referenced Raw Data Sequence.
public Field | ReferencedRealWorldValueMappingInstanceSequence | Referenced Real World Value Mapping Instance Sequence.
public Field | ReferencedReferenceImageNumber | Referenced Reference Image Number.
public Field | ReferencedReferenceImageSequence | Referenced Reference Image Sequence.
public Field | ReferencedRefractiveMeasurementsSequence | Referenced Refractive Measurements Sequence.
public Field | ReferencedRelatedGeneralSOPClassUIDinFile | Referenced Related General SOP Class UID in File.
public Field | ReferencedRequestSequence | Referenced Request Sequence.
public Field | ReferencedResultsSequence | Referenced Results Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedRoiNumber | Referenced ROI Number.
public Field | ReferencedRtPlanSequence | Referenced RT Plan Sequence.
public Field | ReferencedSamplePositions | Referenced Sample Positions.
public Field | ReferencedSegmentNumber | Referenced Segment Number.
public Field | ReferencedSeriesSequence | Referenced Series Sequence.
public Field | ReferencedSetupImageSequence | Referenced Setup Image Sequence.
public Field | ReferencedSOPClassUID | Referenced SOP Class UID.
public Field | ReferencedSOPClassUIDInFile | Referenced SOP Class UID in File.
public Field | ReferencedSOPInstanceMACSequence | Referenced SOP Instance MAC Sequence.
public Field | ReferencedSOPInstanceUID | Referenced SOP Instance UID.
public Field | ReferencedSOPInstanceUIDInFile | Referenced SOP Instance UID in File.
public Field | ReferencedSOPSequence | Referenced SOP Sequence.
public Field | ReferencedSourceApplicatorNumber | Referenced Source Applicator Number.
public Field | ReferencedSourceNumber | Referenced Source Number.
public Field | ReferencedSpatialRegistrationSequence | Referenced Spatial Registration Sequence.
public Field | ReferencedStartControlPointIndex | Referenced Start Control Point Index.
public Field | ReferencedStereometricInstanceSequence | Referenced Stereometric Instance Sequence.
public Field | ReferencedStopControlPointIndex | Referenced Stop Control Point Index.
public Field | ReferencedStorageMediaSequence | Referenced Storage Media Sequence.
public Field | ReferencedStoredPrintSequence | Referenced Stored Print Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedStructureSetSequence | Referenced Structure Set Sequence.
public Field | ReferencedStudySequence | Referenced Study Sequence.
public Field | ReferencedSubsequentWaveform | Referenced Subsequent Waveform. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedSurfaceNumber | Referenced Surface Number.
public Field | ReferencedSurfaceSequence | Referenced Surface Sequence.
public Field | ReferencedTimeOffsets | Referenced Time Offsets.
public Field | ReferencedToleranceTableNumber | Referenced Tolerance Table Number.
public Field | ReferencedTransferSyntaxUIDInFile | Referenced Transfer Syntax UID in File.
public Field | ReferencedTreatmentRecordSequence | Referenced Treatment Record Sequence.
public Field | ReferencedTypeofData | Referenced Type of Data.
public Field | ReferencedVerificationImageSequence | Referenced Verification Image Sequence.
public Field | ReferencedVisitSequence | Referenced Visit Sequence.
public Field | ReferencedVOILUTBoxSequence | Referenced VOI LUT Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedWaveformChannels | Referenced Waveform Channels.
public Field | ReferencedWaveformSequence | Referenced Waveform Sequence.
public Field | ReferencedWedgeNumber | Referenced Wedge Number.
public Field | ReferenceImageNumber | Reference Image Number.
public Field | ReferencePixelPhysicalValueX | Reference Pixel Physical Value X.
public Field | ReferencePixelPhysicalValueY | Reference Pixel Physical Value Y.
public Field | ReferencePixelX0 | Reference Pixel X0.
public Field | ReferencePixelY0 | Reference Pixel Y0.
public Field | ReferencetoRecordedSound | Reference to Recorded Sound. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferringPhysicianAddress | Referring Physician's Address.
public Field | ReferringPhysicianIdentificationSequence | Referring Physician Identification Sequence.
public Field | ReferringPhysicianName | Referring Physician's Name.
public Field | ReferringPhysicianTelephoneNumbers | Referring Physician's Telephone Numbers.
public Field | ReflectedAmbientLight | Reflected Ambient Light.
public Field | ReformattingInterval | Reformatting Interval.
public Field | ReformattingOperationInitialViewDirection | Reformatting Operation Initial View Direction.
public Field | ReformattingOperationType | Reformatting Operation Type.
public Field | ReformattingThickness | Reformatting Thickness.
public Field | RefractiveStateSequence | Refractive State Sequence.
public Field | RegionDataType | Region Data Type.
public Field | RegionFlags | Region Flags.
public Field | RegionLocationMaxX1 | Region Location Max X1.
public Field | RegionLocationMaxY1 | Region Location Max Y1.
public Field | RegionLocationMinX0 | Region Location Min X0.
public Field | RegionLocationMinY0 | Region Location Min Y0.
public Field | RegionOfResidence | Region of Residence.
public Field | RegionPixelShiftSequence | Region Pixel Shift Sequence.
public Field | RegionSpatialFormat | Region Spatial Format.
public Field | RegistrationSequence | Registration Sequence.
public Field | RegistrationTypeCodeSequence | Registration Type Code Sequence.
public Field | RelatedFrameOfReferenceUID | Related Frame of Reference UID.
public Field | RelatedGeneralSOPClassUID | Related General SOP Class UID.
public Field | RelatedProcedureStepSequence | Related Procedure Step Sequence.
public Field | RelatedReferenceRTImageSequence | Related Reference RT Image Sequence.
public Field | RelatedRtRoiObservationsSequence | Related RT ROI Observations Sequence.
public Field | RelatedSeriesSequence | Related Series Sequence.
public Field | RelationshipType | Relationship Type.
public Field | RelationshipTypeCodeSequence | Relationship Type Code Sequence.
public Field | RelativeImagePositionCodeSequence | Relative Image Position Code Sequence.
public Field | RelativeOpacity | Relative Opacity.
public Field | RelativeTime | Relative Time.
public Field | RelativeTimeUnits | Relative Time Units.
public Field | RelativeXRayExposure | Relative X-Ray Exposure.
public Field | RelevantInformationSequence | Relevant Information Sequence.
public Field | RenderingType3D | 3D Rendering Type.
public Field | RepeatFractionCycleLength | Repeat Fraction Cycle Length.
public Field | RepeatInterval | Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RepetitionTime | Repetition Time.
public Field | ReportedValuesOrigin | Reported Values Origin.
public Field | ReportingPriority | Reporting Priority.
public Field | RepresentativeFrameNumber | Representative Frame Number.
public Field | ReprojectionMethod | Reprojection Method.
public Field | RequestAttributesSequence | Request Attributes Sequence.
public Field | RequestedContrastAgent | Requested Contrast Agent.
public Field | RequestedDecimateCropBehavior | Requested Decimate/Crop Behavior.
public Field | RequestedImageSize | Requested Image Size.
public Field | RequestedImageSizeFlag | Requested Image Size Flag.
public Field | RequestedMediaApplicationProfile | Requested Media Application Profile.
public Field | RequestedProcedureCodeSequence | Requested Procedure Code Sequence.
public Field | RequestedProcedureComments | Requested Procedure Comments.
public Field | RequestedProcedureDescription | Requested Procedure Description.
public Field | RequestedProcedureID | Requested Procedure ID.
public Field | RequestedProcedureLocation | Requested Procedure Location.
public Field | RequestedProcedurePriority | Requested Procedure Priority.
public Field | RequestedResolutionID | Requested Resolution ID.
public Field | RequestedSOPClassUID | Requested SOP Class UID.
public Field | RequestedSOPInstanceUID | Requested SOP Instance UID.
public Field | RequestedSubsequentWorkitemCodeSequence | Requested Subsequent Workitem Code Sequence.
public Field | RequestingAE | Requesting AE.
public Field | RequestingPhysician | Requesting Physician.
public Field | RequestingPhysicianIdentificationSequence | Requesting Physician Identification Sequence.
public Field | RequestingService | Requesting Service.
public Field | RequestingServiceCodeSequence | Requesting Service Code Sequence.
public Field | RequestPriority | Request Priority.
public Field | RescaleIntercept | Rescale Intercept.
public Field | RescaleSlope | Rescale Slope.
public Field | RescaleType | Rescale Type.
public Field | ResidualSyringeCounts | Residual Syringe Counts.
public Field | ResonantNucleus | Resonant Nucleus.
public Field | RespiratoryCyclePosition | Respiratory Cycle Position.
public Field | RespiratoryIntervalTime | Respiratory Interval Time.
public Field | RespiratoryMotionCompensationTechnique | Respiratory Motion Compensation Technique.
public Field | RespiratoryMotionCompensationTechniqueDescription | Respiratory Motion Compensation Technique Description.
public Field | RespiratorySignalSource | Respiratory Signal Source.
public Field | RespiratorySignalSourceID | Respiratory Signal Source ID.
public Field | RespiratorySynchronizationSequence | Respiratory Synchronization Sequence.
public Field | RespiratoryTriggerDelayThreshold | Respiratory Trigger Delay Threshold.
public Field | RespiratoryTriggerType | Respiratory Trigger Type.
public Field | ResponseSequenceNumber | Response Sequence Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResponsibleOrganization | Responsible Organization.
public Field | ResponsiblePerson | Responsible Person.
public Field | ResponsiblePersonRole | Responsible Person Role.
public Field | ResultingGeneralPurposePerformedProcedureStepsSequence | Resulting General Purpose Performed Procedure Steps Sequence.
public Field | ResultsComments | Results Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsDistributionListSequence | Results Distribution List Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsID | Results ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsIDIssuer | Results ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RET | RET. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RetrieveAETitle | Retrieve AE Title.
public Field | RetrieveLocationUID | Retrieve Location UID.
public Field | RetrieveURI | Retrieve URI.
public Field | ReviewDate | Review Date.
public Field | ReviewerName | Reviewer Name.
public Field | ReviewTime | Review Time.
public Field | RevolutionTime | Revolution Time.
public Field | RFEchoTrainLength | RF Echo Train Length.
public Field | RGBLUTTransferFunction | RGB LUT Transfer Function.
public Field | RightImageSequence | Right Image Sequence.
public Field | RightLensSequence | Right Lens Sequence.
public Field | RoiArea | The ROI Area.
public Field | RoiContourSequence | ROI Contour Sequence.
public Field | RoiDescription | ROI Description.
public Field | RoiDisplayColor | ROI Display Color.
public Field | ROIElementalCompositionAtomicMassFraction | ROI Elemental Composition Atomic Mass Fraction.
public Field | ROIElementalCompositionAtomicNumber | ROI Elemental Composition Atomic Number.
public Field | ROIElementalCompositionSequence | ROI Elemental Composition Sequence.
public Field | RoiGenerationAlgorithm | ROI Generation Algorithm.
public Field | RoiGenerationDescription | ROI Generation Description.
public Field | RoiInterpreter | ROI Interpreter.
public Field | RoiMean | The ROI Mean.
public Field | RoiName | ROI (Region of Interest) Name.
public Field | RoiNumber | ROI Number.
public Field | RoiObservationDescription | ROI Observation Description.
public Field | RoiObservationLabel | ROI Observation Label.
public Field | ROIPhysicalPropertiesSequence | ROI Physical Properties Sequence.
public Field | RoiPhysicalProperty | ROI Physical Property.
public Field | RoiPhysicalPropertyValue | ROI Physical Property Value.
public Field | RoiStandardDeviation | ROI Standard Deviation.
public Field | RoiVolume | ROI Volume.
public Field | RotationDirection | Rotation Direction.
public Field | RotationInformationSequence | Rotation Information Sequence.
public Field | RotationOffset | Rotation Offset.
public Field | RotationOfScannedFilm | Rotation of Scanned Film.
public Field | RotationVector | Rotation Vector.
public Field | RouteOfAdmissions | Route of Admissions.
public Field | RowOverlap | Row Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Rows | Rows. Height of the DICOM image.
public Field | RowsForNthOrderCoefficients | Rows For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RRIntervalTimeNominal | R - R Interval Time Nominal.
public Field | RrIntervalVector | R-R Interval Vector.
public Field | RtBeamLimitingDeviceType | RT Beam Limiting Device Type.
public Field | RtDoseRoiSequence | RT Dose ROI Sequence.
public Field | RtImageDescription | RT Image Description.
public Field | RtImageLabel | RT Image Label.
public Field | RtImageName | RT Image Name.
public Field | RtImageOrientation | RT Image Orientation.
public Field | RtImagePlane | RT Image Plane.
public Field | RtImagePosition | RT Image Position.
public Field | RtImageSid | RT Image SID.
public Field | RtPlanDate | RT Plan Date.
public Field | RtPlanDescription | RT Plan Description.
public Field | RtPlanGeometry | RT Plan Geometry.
public Field | RtPlanLabel | RT Plan Label.
public Field | RtPlanName | RT Plan Name.
public Field | RtPlanRelationship | RT Plan Relationship.
public Field | RtPlanTime | RT Plan Time.
public Field | RtReferencedSeriesSequence | RT Referenced Series Sequence.
public Field | RtReferencedStudySequence | RT Referenced Study Sequence.
public Field | RtRelatedRoiSequence | RT Related ROI Sequence.
public Field | RtRoiIdentificationCodeSequence | RT ROI Identification Code Sequence.
public Field | RtRoiInterpretedType | RT ROI Interpreted Type.
public Field | RtRoiObservationsSequence | RT ROI Observations Sequence.
public Field | RtRoiRelationship | RT ROI Relationship.
public Field | RunLengthTriplet | Run Length Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RWavePointer | R Wave Pointer.
public Field | RWaveTimeVector | R Wave Time Vector.
public Field | SafePositionExitDate | Safe Position Exit Date.
public Field | SafePositionExitTime | Safe Position Exit Time.
public Field | SafePositionReturnDate | Safe Position Return Date.
public Field | SafePositionReturnTime | Safe Position Return Time.
public Field | SampleRate | Sample Rate. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SamplesPerPixel | Samples per Pixel.
public Field | SamplesperPixelUsed | Samples per Pixel Used.
public Field | SamplingFrequency | Sampling Frequency.
public Field | Sar | SAR (specific absorption rate).
public Field | SaturationRecovery | Saturation Recovery.
public Field | ScanArc | Scan Arc value.
public Field | ScanLength | Scan Length.
public Field | ScanMode | Scan Mode.
public Field | ScanningSequence | Scanning Sequence.
public Field | ScanningSpotSize | Scanning Spot Size.
public Field | ScanOptions | Scan Options.
public Field | ScanSpotMetersetsDelivered | Scan Spot Metersets Delivered.
public Field | ScanSpotMetersetWeights | Scan Spot Meterset Weights.
public Field | ScanSpotPositionMap | Scan Spot Position Map.
public Field | ScanSpotTuneID | Scan Spot Tune ID.
public Field | ScanVelocity | Scan Velocity.
public Field | ScatterCorrected | Scatter Corrected.
public Field | ScatterCorrectionMethod | Scatter Correction Method.
public Field | ScatterFractionFactor | Scatter Fraction Factor.
public Field | ScheduledAdmissionDate | Scheduled Admission Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledAdmissionTime | Scheduled Admission Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledDischargeDate | Scheduled Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledDischargeTime | Scheduled Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledHumanPerformersSequence | Scheduled Human Performers Sequence.
public Field | ScheduledPatientInstitutionResidence | Scheduled Patient Institution Residence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledPerformingPhysicianIdentificationSequence | Scheduled Performing Physician Identification Sequence.
public Field | ScheduledPerformingPhysiciansName | Scheduled Performing Physician's Name.
public Field | ScheduledProcedureStepDescription | Scheduled Procedure Step Description.
public Field | ScheduledProcedureStepEndDate | Scheduled Procedure Step End Date.
public Field | ScheduledProcedureStepEndTime | Scheduled Procedure Step End Time.
public Field | ScheduledProcedureStepID | Scheduled Procedure Step ID.
public Field | ScheduledProcedureStepLocation | Scheduled Procedure Step Location.
public Field | ScheduledProcedureStepModificationDateTime | Scheduled Procedure Step Modification Date Time.
public Field | ScheduledProcedureStepPriority | Scheduled Procedure Step Priority.
public Field | ScheduledProcedureStepSequence | Scheduled Procedure Step Sequence.
public Field | ScheduledProcedureStepStartDate | Scheduled Procedure Step Start Date.
public Field | ScheduledProcedureStepStartDateTime | Scheduled Procedure Step Start Date Time.
public Field | ScheduledProcedureStepStartTime | Scheduled Procedure Step Start Time.
public Field | ScheduledProcedureStepStatus | Scheduled Procedure Step Status.
public Field | ScheduledProcessingApplicationsCodeSequence | Scheduled Processing Applications Code Sequence.
public Field | ScheduledProcessingParametersSequence | Scheduled Processing Parameters Sequence.
public Field | ScheduledProtocolCodeSequence | Scheduled Protocol Code Sequence.
public Field | ScheduledSpecimenSequence | Scheduled Specimen Sequence.
public Field | ScheduledStationAeTitle | Scheduled Station AE Title.
public Field | ScheduledStationClassCodeSequence | Scheduled Station Class Code Sequence.
public Field | ScheduledStationGeographicLocationCodeSequence | Scheduled Station Geographic Location Code Sequence.
public Field | ScheduledStationName | Scheduled Station Name.
public Field | ScheduledStationNameCodeSequence | Scheduled Station Name Code Sequence.
public Field | ScheduledStepAttributesSequence | Scheduled Step Attributes Sequence.
public Field | ScheduledStudyLocation | Scheduled Study Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyLocationAeTitles | Scheduled Study Location AE Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStartDate | Scheduled Study Start Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStartTime | Scheduled Study Start Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStopDate | Scheduled Study Stop Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStopTime | Scheduled Study Stop Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledWorkitemCodeSequence | Scheduled Workitem Code Sequence.
public Field | SCPStatus | SCP Status.
public Field | ScreenMinimumColorBitDepth | Screen Minimum Color Bit Depth.
public Field | ScreenMinimumGrayscaleBitDepth | Screen Minimum Grayscale Bit Depth.
public Field | SecondaryCaptureDeviceID | Secondary Capture Device ID.
public Field | SecondaryCaptureDeviceManufacturer | Secondary Capture Device Manufacturer.
public Field | SecondaryCaptureDeviceManufacturersModelName | Secondary Capture Device Manufacturer's Model Name.
public Field | SecondaryCaptureDeviceSoftwareVersions | Secondary Capture Device Software Version(s).
public Field | SecondaryCountsAccumulated | Secondary Counts Accumulated.
public Field | SecondaryCountsType | Secondary Counts Type.
public Field | SecondaryPositionerIncrement | Secondary Positioner Increment.
public Field | SecondaryPositionerScanArc | Secondary Positioner Scan Arc.
public Field | SecondaryPositionerScanStartAngle | Secondary Positioner Scan Start Angle.
public Field | SegmentAlgorithmName | Segment Algorithm Name.
public Field | SegmentAlgorithmType | Segment Algorithm Type.
public Field | SegmentationFractionalType | Segmentation Fractional Type.
public Field | SegmentationType | Segmentation Type.
public Field | SegmentDescription | Segment Description.
public Field | SegmentedBluePaletteColorLookupTableData | Segmented Blue Palette Color Lookup Table Data.
public Field | SegmentedGreenPaletteColorLookupTableData | Segmented Green Palette Color Lookup Table Data.
public Field | SegmentedKspaceTraversal | Segmented k-Space Traversal.
public Field | SegmentedPropertyCategoryCodeSequence | Segmented Property Category Code Sequence.
public Field | SegmentedPropertyTypeCodeSequence | Segmented Property Type Code Sequence.
public Field | SegmentedRedPaletteColorLookupTableData | Segmented Red Palette Color Lookup Table Data.
public Field | SegmentIdentificationSequence | Segment Identification Sequence.
public Field | SegmentLabel | Segment Label.
public Field | SegmentNumber | Segment Number.
public Field | SegmentSequence | Segment Sequence.
public Field | SegmentSurfaceGenerationAlgorithmIdentificationSequence | Segment Surface Generation Algorithm Identification Sequence.
public Field | SegmentSurfaceSourceInstanceSequence | Segment Surface Source Instance Sequence.
public Field | SelectorAttribute | Selector Attribute.
public Field | SelectorAttributePrivateCreator | Selector Attribute Private Creator.
public Field | SelectorAttributeVR | Selector Attribute VR.
public Field | SelectorATValue | Selector AT Value.
public Field | SelectorCodeSequenceValue | Selector Code Sequence Value.
public Field | SelectorCSValue | Selector CS Value.
public Field | SelectorDSValue | Selector DS Value.
public Field | SelectorFDValue | Selector FD Value.
public Field | SelectorFLValue | Selector FL Value.
public Field | SelectorISValue | Selector IS Value.
public Field | SelectorLOValue | Selector LO Value.
public Field | SelectorLTValue | Selector LT Value.
public Field | SelectorPNValue | Selector PN Value.
public Field | SelectorSequencePointer | Selector Sequence Pointer.
public Field | SelectorSequencePointerPrivateCreator | Selector Sequence Pointer Private Creator.
public Field | SelectorSHValue | Selector SH Value.
public Field | SelectorSLValue | Selector SL Value.
public Field | SelectorSSValue | Selector SS Value.
public Field | SelectorSTValue | Selector ST Value.
public Field | SelectorULValue | Selector UL Value.
public Field | SelectorUSValue | Selector US Value.
public Field | SelectorUTValue | Selector UT Value.
public Field | SelectorValueNumber | Selector Value Number.
public Field | SenderAeTitle | Initiator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Sensitivity | Sensitivity value.
public Field | SensitivityCalibrated | Sensitivity Calibrated.
public Field | SequenceDelimitationItem | Sequence Delimitation Item.
public Field | SequenceName | Sequence Name.
public Field | SequenceOfCompressedData | Sequence of Compressed Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SequenceOfUltrasoundRegions | Sequence of Ultrasound Regions.
public Field | SequenceVariant | Sequence Variant.
public Field | SeriesDate | Series Date.
public Field | SeriesDescription | Series Description.
public Field | SeriesDescriptionCodeSequence | Series Description Code Sequence.
public Field | SeriesInstanceUID | Series Instance UID.
public Field | SeriesInStudy | Series in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SeriesNumber | Series Number.
public Field | SeriesTime | Series Time.
public Field | SeriesType | Series Type.
public Field | ServiceEpisodeDescription | Service Episode Description.
public Field | ServiceEpisodeID | Service Episode ID.
public Field | SetupDeviceDescription | Setup Device Description.
public Field | SetupDeviceLabel | Setup Device Label.
public Field | SetupDeviceParameter | Setup Device Parameter.
public Field | SetupDeviceSequence | Setup Device Sequence.
public Field | SetupDeviceType | Setup Device Type.
public Field | SetupImageComment | Setup Image Comment.
public Field | SetupReferenceDescription | Setup Reference Description.
public Field | SetupTechnique | Setup Technique.
public Field | SetupTechniqueDescription | Setup Technique Description.
public Field | ShapeType | Shape Type.
public Field | SharedFunctionalGroupsSequence | Shared Functional Groups Sequence.
public Field | ShieldingDeviceDescription | Shielding Device Description.
public Field | ShieldingDeviceLabel | Shielding Device Label.
public Field | ShieldingDevicePosition | Shielding Device Position.
public Field | ShieldingDeviceSequence | Shielding Device Sequence.
public Field | ShieldingDeviceType | Shielding Device Type.
public Field | ShiftTableSize | Shift Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ShiftTableTriplet | Shift Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ShowAcquisitionTechniquesFlag | Show Acquisition Techniques Flag.
public Field | ShowGraphicAnnotationFlag | Show Graphic Annotation Flag.
public Field | ShowGrayscaleInverted | Show Grayscale Inverted.
public Field | ShowImageTrueSizeFlag | Show Image True Size Flag.
public Field | ShowPatientDemographicsFlag | Show Patient Demographics Flag.
public Field | ShutterLeftVerticalEdge | Shutter Left Vertical Edge.
public Field | ShutterLowerHorizontalEdge | Shutter Lower Horizontal Edge.
public Field | ShutterOverlayGroup | Shutter Overlay Group.
public Field | ShutterPresentationColorCIELabValue | Shutter Presentation Color CIELab Value.
public Field | ShutterPresentationValue | Shutter Presentation Value.
public Field | ShutterRightVerticalEdge | Shutter Right Vertical Edge.
public Field | ShutterShape | Shutter Shape.
public Field | ShutterUpperHorizontalEdge | Shutter Upper Horizontal Edge.
public Field | SignalDomainColumns | Signal Domain Columns.
public Field | SignalDomainRows | Signal Domain Rows.
public Field | Signature | The Signature.
public Field | SimpleFrameList | Simple Frame List.
public Field | SingleCollimationWidth | Single Collimation Width.
public Field | SkipBeats | Skip Beats.
public Field | SkipFrameRangeFlag | Skip Frame Range Flag.
public Field | SlabOrientation | Slab Orientation.
public Field | SlabThickness | Slab Thickness.
public Field | SliceLocation | Slice Location.
public Field | SliceLocationVector | Slice Location Vector.
public Field | SliceProgressionDirection | Slice Progression Direction.
public Field | SliceSensitivityFactor | Slice Sensitivity Factor.
public Field | SliceThickness | Slice Thickness.
public Field | SliceVector | Slice Vector.
public Field | SlideIdentifier | Slide Identifier. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmallestImagePixelValue | Smallest Image Pixel Value.
public Field | SmallestImagePixelValueInPlane | Smallest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmallestPixelValueInSeries | Smallest Pixel Value in Series.
public Field | SmallestValidPixelValue | Smallest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmokingStatus | Smoking Status.
public Field | SmoothingType | Smoothing Type.
public Field | SnoutID | Snout Identifier.
public Field | SnoutPosition | Snout Position.
public Field | SnoutPositionTolerance | Snout Position Tolerance.
public Field | SnoutSequence | Snout Sequence.
public Field | SoftcopyVOILUTSequence | Softcopy VOI LUT Sequence.
public Field | SoftTissueFocusThermalIndex | Soft Tissue-focus Thermal Index.
public Field | SoftTissueSurfaceThermalIndex | Soft Tissue-surface Thermal Index.
public Field | SoftTissueThermalIndex | Soft Tissue Thermal Index.
public Field | SoftwareVersions | Software Version(s).
public Field | SOPAuthorizationComment | SOP Authorization Comment.
public Field | SOPAuthorizationDateTime | SOP Authorization Date Time.
public Field | SOPClassesInStudy | SOP Classes In Study.
public Field | SOPClassesSupported | SOP Classes Supported.
public Field | SOPClassUID | SOP Class UID.
public Field | SOPInstanceStatus | SOP Instance Status.
public Field | SOPInstanceUID | SOP Instance UID.
public Field | SOPInstanceUIDOfConcatenationSource | SOP Instance UID of Concatenation Source.
public Field | SortbyCategory | Sort-by Category.
public Field | SortingDirection | Sorting Direction.
public Field | SortingOperationsSequence | Sorting Operations Sequence.
public Field | SourceApplicationEntityTitle | Source Application Entity Title.
public Field | SourceApplicatorID | Source Applicator ID.
public Field | SourceApplicatorLength | Source Applicator Length.
public Field | SourceApplicatorManufacturer | Source Applicator Manufacturer.
public Field | SourceApplicatorName | Source Applicator Name.
public Field | SourceApplicatorNumber | Source Applicator Number.
public Field | SourceApplicatorStepSize | Source Applicator Step Size.
public Field | SourceApplicatorType | Source Applicator Type.
public Field | SourceApplicatorWallNominalThickness | Source Applicator Wall Nominal Thickness.
public Field | SourceApplicatorWallNominalTransmission | Source Applicator Wall Nominal Transmission.
public Field | SourceAxisDistance | Source-Axis Distance.
public Field | SourceEncapsulationNominalThickness | Source Encapsulation Nominal Thickness.
public Field | SourceEncapsulationNominalTransmission | Source Encapsulation Nominal Transmission.
public Field | SourceFrameOfReferenceUID | Source Frame of Reference UID.
public Field | SourceHangingProtocolSequence | Source Hanging Protocol Sequence.
public Field | SourceImageEvidenceSequence | Source Image Evidence Sequence.
public Field | SourceImageIDs | Source Image IDs. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SourceImageSequence | Source Image Sequence.
public Field | SourceInstanceSequence | Source Instance Sequence.
public Field | SourceIsotopeHalfLife | Source Isotope Half Life.
public Field | SourceIsotopeName | Source Isotope Name.
public Field | SourceManufacturer | Source Manufacturer.
public Field | SourceMovementType | Source Movement Type.
public Field | SourceNumber | Source Number.
public Field | SourceOfPreviousValues | Source of Previous Values.
public Field | SourceSequence | Source Sequence.
public Field | SourceSerialNumber | Source Serial Number.
public Field | SourceStrength | Source Strength.
public Field | SourceStrengthReferenceDate | Source Strength Reference Date.
public Field | SourceStrengthReferenceTime | Source Strength Reference Time.
public Field | SourceStrengthUnits | Source Strength Units.
public Field | SourceToBeamLimitingDeviceDistance | Source to Beam Limiting Device Distance.
public Field | SourceToBlockTrayDistance | Source to Block Tray Distance.
public Field | SourceToCompensatorDistance | Source to Compensator Distance.
public Field | SourceToCompensatorTrayDistance | Source to Compensator Tray Distance.
public Field | SourceToReferenceObjectDistance | Source to Reference Object Distance.
public Field | SourceToSurfaceDistance | Source to Surface Distance.
public Field | SourceToWedgeTrayDistance | Source to Wedge Tray Distance.
public Field | SourceType | Source Type.
public Field | SourceWaveformSequence | Source Waveform Sequence.
public Field | SpacingBetweenSlices | Spacing Between Slices.
public Field | SpatialLocationsPreserved | Spatial Locations Preserved.
public Field | SpatialPresaturation | Spatial Pre-saturation.
public Field | SpatialResolution | Spatial Resolution.
public Field | SpecialNeeds | Special Needs.
public Field | SpecificAbsorptionRateDefinition | Specific Absorption Rate Definition.
public Field | SpecificAbsorptionRateSequence | Specific Absorption Rate Sequence.
public Field | SpecificAbsorptionRateValue | Specific Absorption Rate Value.
public Field | SpecificCharacterSet | Specific Character Set.
public Field | SpecificCharacterSetOfFilesetDescriptorFile | Specific Character Set of File-set Descriptor File.
public Field | SpecifiedChannelTotalTime | Specified Channel Total Time.
public Field | SpecifiedMeterset | Specified Meterset.
public Field | SpecifiedNumberofPulses | Specified Number of Pulses.
public Field | SpecifiedPrimaryMeterset | Specified Primary Meterset.
public Field | SpecifiedPulseRepetitionInterval | Specified Pulse Repetition Interval.
public Field | SpecifiedSecondaryMeterset | Specified Secondary Meterset.
public Field | SpecifiedTreatmentTime | Specified Treatment Time.
public Field | SpecimenAccessionNumber | Specimen Accession Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescription | Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescriptionSequence | Specimen Description Sequence.
public Field | SpecimenDescriptionSequenceTrial | Specimen Description Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescriptionTrial | Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDetailedDescription | Specimen Detailed Description.
public Field | SpecimenIdentifier | Specimen Identifier.
public Field | SpecimenLocalizationContentItemSequence | Specimen Localization Content Item Sequence.
public Field | SpecimenPreparationSequence | Specimen Preparation Sequence.
public Field | SpecimenPreparationStepContentItemSequence | Specimen Preparation Step Content Item Sequence.
public Field | SpecimenSequence | Specimen Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenShortDescription | Specimen Short Description.
public Field | SpecimenTypeCodeSequence | Specimen Type Code Sequence.
public Field | SpecimenUID | Specimen UID.
public Field | SpectrallySelectedExcitation | Spectrally Selected Excitation.
public Field | SpectrallySelectedSuppression | Spectrally Selected Suppression.
public Field | SpectralWidth | Spectral Width.
public Field | SpectroscopyAcquisitionDataColumns | Spectroscopy Acquisition Data Columns.
public Field | SpectroscopyAcquisitionOutOfPlanePhaseSteps | Spectroscopy Acquisition Out-of-plane Phase Steps.
public Field | SpectroscopyAcquisitionPhaseColumns | Spectroscopy Acquisition Phase Columns.
public Field | SpectroscopyAcquisitionPhaseRows | Spectroscopy Acquisition Phase Rows.
public Field | SpectroscopyData | Spectroscopy Data.
public Field | SpherePower | Sphere Power.
public Field | SphericalLensPower | Spherical Lens Power.
public Field | SpiralPitchFactor | Spiral Pitch Factor.
public Field | Spoiling | Spoiling value.
public Field | StackID | Stack Identifier.
public Field | StageCodeSequence | Stage Code Sequence.
public Field | StageName | Stage Name.
public Field | StageNumber | Stage Number.
public Field | StartAcquisitionDateTime | Start Acquisition DateTime.
public Field | StartAngle | Start Angle.
public Field | StartCardiacTriggerCountThreshold | Start Cardiac Trigger Count Threshold.
public Field | StartCumulativeMetersetWeight | Start Cumulative Meterset Weight.
public Field | StartDensityThreshold | Start Density Threshold.
public Field | StartingRespiratoryAmplitude | Starting Respiratory Amplitude.
public Field | StartingRespiratoryPhase | Starting Respiratory Phase.
public Field | StartMeterset | Start Meterset.
public Field | StartRelativeDensityDifferenceThreshold | Start Relative Density Difference Threshold.
public Field | StartRespiratoryTriggerCountThreshold | Start Respiratory Trigger Count Threshold.
public Field | StartTrim | Start Trim.
public Field | StationName | Station Name.
public Field | Status | Operation Status.
public Field | SteadyStatePulseSequence | Steady State Pulse Sequence.
public Field | SteepKeratometricAxisSequence | Steep Keratometric Axis Sequence.
public Field | SteeringAngle | Steering Angle.
public Field | StereoBaselineAngle | Stereo Baseline Angle.
public Field | StereoBaselineDisplacement | Stereo Baseline Displacement.
public Field | StereoHorizontalPixelOffset | Stereo Horizontal Pixel Offset.
public Field | StereoPairsSequence | Stereo Pairs Sequence.
public Field | StereoRotation | Stereo Rotation.
public Field | StereoVerticalPixelOffset | Stereo Vertical Pixel Offset.
public Field | StopTrim | Stop Trim.
public Field | StorageMediaFilesetID | Storage Media File-set ID.
public Field | StorageMediaFilesetUID | Storage Media File-set UID.
public Field | StructuredDisplayBackgroundCIELabValue | Structured Display Background CIELab Value.
public Field | StructuredDisplayImageBoxSequence | Structured Display Image Box Sequence.
public Field | StructuredDisplayTextBoxSequence | Structured Display Text Box Sequence.
public Field | StructureSetDate | Structure Set Date.
public Field | StructureSetDescription | Structure Set Description.
public Field | StructureSetLabel | Structure Set Label.
public Field | StructureSetName | Structure Set Name.
public Field | StructureSetRoiSequence | Structure Set ROI Sequence.
public Field | StructureSetTime | Structure Set Time.
public Field | StudiesContainingOtherReferencedInstancesSequence | Studies Containing Other Referenced Instances Sequence.
public Field | StudyArrivalDate | Study Arrival Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyArrivalTime | Study Arrival Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyComments | Study Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyCompletionDate | Study Completion Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyCompletionTime | Study Completion Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyComponentStatusID | Study Component Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyDate | Study Date.
public Field | StudyDescription | Study Description.
public Field | StudyID | Study Identifier.
public Field | StudyIDIssuer | Study ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyInstanceUID | Study Instance UID.
public Field | StudyPriorityID | Study Priority ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyReadDate | Study Read Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyReadTime | Study Read Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyStatusID | Study Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyTime | Study Time.
public Field | StudyVerifiedDate | Study Verified Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyVerifiedTime | Study Verified Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SubjectiveRefractionLeftEyeSequence | Subjective Refraction Left Eye Sequence.
public Field | SubjectiveRefractionRightEyeSequence | Subjective Refraction Right Eye Sequence.
public Field | SubscriptionListStatus | Subscription List Status.
public Field | SubstanceAdministrationApproval | Substance Administration Approval.
public Field | SubstanceAdministrationDateTime | Substance Administration DateTime.
public Field | SubstanceAdministrationDeviceID | Substance Administration Device ID.
public Field | SubstanceAdministrationNotes | Substance Administration Notes.
public Field | SubstanceAdministrationParameterSequence | Substance Administration Parameter Sequence.
public Field | SubtractionItemID | Subtraction Item ID.
public Field | SupportedImageDisplayFormatsSequence | Supported Image Display Formats Sequence.
public Field | SurfaceComments | Surface Comments.
public Field | SurfaceCount | Surface Count.
public Field | SurfaceEntryPoint | Surface Entry Point.
public Field | SurfaceMeshPrimitivesSequence | Surface Mesh Primitives Sequence.
public Field | SurfaceNumber | Surface Number.
public Field | SurfacePointsNormalsSequence | Surface Points Normals Sequence.
public Field | SurfacePointsSequence | Surface Points Sequence.
public Field | SurfaceProcessing | Surface Processing.
public Field | SurfaceProcessingAlgorithmIdentificationSequence | Surface Processing Algorithm Identification Sequence.
public Field | SurfaceProcessingDescription | Surface Processing Description.
public Field | SurfaceProcessingRatio | Surface Processing Ratio.
public Field | SurfaceSequence | Surface Sequence.
public Field | SynchronizationChannel | Synchronization Channel.
public Field | SynchronizationFrameOfReferenceUID | Synchronization Frame of Reference UID.
public Field | SynchronizationTrigger | Synchronization Trigger.
public Field | SynchronizedImageBoxList | Synchronized Image Box List.
public Field | SynchronizedScrollingSequence | Synchronized Scrolling Sequence.
public Field | SyringeCounts | Syringe Counts.
public Field | T2Preparation | T2 Preparation.
public Field | TableAngle | Table Angle.
public Field | TableCradleTiltAngle | Table Cradle Tilt Angle.
public Field | TableFeedperRotation | Table Feed per Rotation.
public Field | TableFrameOfReferenceUID | Table Frame of Reference UID.
public Field | TableHeadTiltAngle | Table Head Tilt Angle.
public Field | TableHeight | Table Height.
public Field | TableHorizontalRotationAngle | Table Horizontal Rotation Angle.
public Field | TableLateralIncrement | Table Lateral Increment.
public Field | TableLongitudinalIncrement | Table Longitudinal Increment.
public Field | TableMotion | Table Motion.
public Field | TableOfParameterValues | Table of Parameter Values.
public Field | TableOfPixelValues | Table of Pixel Values.
public Field | TableOfXBreakPoints | Table of X Break Points.
public Field | TableOfYBreakPoints | Table of Y Break Points.
public Field | TablePosition | Table Position.
public Field | TablePositionSequence | Table Position Sequence.
public Field | TableSpeed | Table Speed.
public Field | TableTopEccentricAngle | Table Top Eccentric Angle.
public Field | TableTopEccentricAngleTolerance | Table Top Eccentric Angle Tolerance.
public Field | TableTopEccentricAxisDistance | Table Top Eccentric Axis Distance.
public Field | TableTopEccentricRotationDirection | Table Top Eccentric Rotation Direction.
public Field | TableTopLateralPosition | Table Top Lateral Position.
public Field | TableTopLateralPositionTolerance | Table Top Lateral Position Tolerance.
public Field | TableTopLateralSetupDisplacement | Table Top Lateral Setup Displacement.
public Field | TableTopLongitudinalPosition | Table Top Longitudinal Position.
public Field | TableTopLongitudinalPositionTolerance | Table Top Longitudinal Position Tolerance.
public Field | TableTopLongitudinalSetupDisplacement | Table Top Longitudinal Setup Displacement.
public Field | TableTopPitchAngle | Table Top Pitch Angle.
public Field | TableTopPitchAngleTolerance | Table Top Pitch Angle Tolerance.
public Field | TableTopPitchRotationDirection | Table Top Pitch Rotation Direction.
public Field | TableTopRollAngle | Table Top Roll Angle.
public Field | TableTopRollAngleTolerance | Table Top Roll Angle Tolerance.
public Field | TableTopRollRotationDirection | Table Top Roll Rotation Direction.
public Field | TableTopVerticalPosition | Table Top Vertical Position.
public Field | TableTopVerticalPositionTolerance | Table Top Vertical Position Tolerance.
public Field | TableTopVerticalSetupDisplacement | Table Top Vertical Setup Displacement.
public Field | TableTraverse | Table Traverse.
public Field | TableType | Table Type.
public Field | TableVerticalIncrement | Table Vertical Increment.
public Field | TableXPositiontoIsocenter | Table X Position to Isocenter.
public Field | TableYPositiontoIsocenter | Table Y Position to Isocenter.
public Field | TableZPositiontoIsocenter | Table Z Position to Isocenter.
public Field | TagAngleFirstAxis | Tag Angle First Axis.
public Field | TagAngleSecondAxis | Tag Angle Second Axis.
public Field | Tagging | Tagging value.
public Field | TaggingDelay | Tagging Delay.
public Field | TagSpacingFirstDimension | Tag Spacing First Dimension.
public Field | TagSpacingSecondDimension | Tag Spacing Second Dimension.
public Field | TagThickness | Tag Thickness.
public Field | TargetMaximumDose | Target Maximum Dose.
public Field | TargetMinimumDose | Target Minimum Dose.
public Field | TargetPrescriptionDose | Target Prescription Dose.
public Field | TargetUnderdoseVolumeFraction | Target Underdose Volume Fraction.
public Field | TelephoneNumber | Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TelephoneNumberTrial | Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionCreatorUID | Template Extension Creator UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionFlag | Template Extension Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionOrganizationUID | Template Extension Organization UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateIdentifier | Template Identifier.
public Field | TemplateLocalVersion | Template Local Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateName | Template Name.
public Field | TemplateNumber | Template Number.
public Field | TemplateType | Template Type.
public Field | TemplateVersion | Template Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemporalPositionIdentifier | Temporal Position Identifier.
public Field | TemporalPositionIndex | Temporal Position Index.
public Field | TemporalPositionSequence | Temporal Position Sequence.
public Field | TemporalPositionTimeOffset | Temporal Position Time Offset.
public Field | TemporalRangeType | Temporal Range Type.
public Field | TemporalResolution | Temporal Resolution.
public Field | TerminalType | Terminal Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TerminationCardiacTriggerCountThreshold | Termination Cardiac Trigger Count Threshold.
public Field | TerminationCountsThreshold | Termination Counts Threshold.
public Field | TerminationDensityThreshold | Termination Density Threshold.
public Field | TerminationRelativeDensityThreshold | Termination Relative Density Threshold.
public Field | TerminationRespiratoryTriggerCountThreshold | Termination Respiratory Trigger Count Threshold.
public Field | TerminationTimeThreshold | Termination Time Threshold.
public Field | TextComments | Text Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TextFormatID | Text Format ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TextObjectSequence | Text Object Sequence.
public Field | TextString | Text String.
public Field | TextValue | Text Value.
public Field | TherapyDescription | Therapy Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TherapyType | Therapy Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ThresholdDensity | Threshold Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TidOffset | TID Offset.
public Field | Time | Time value.
public Field | TimeBasedImageSetsSequence | Time Based Image Sets Sequence.
public Field | TimeDistributionProtocol | Time Distribution Protocol.
public Field | TimeDomainFiltering | Time Domain Filtering.
public Field | TimeOfFlightContrast | Time of Flight Contrast.
public Field | TimeOfFlightInformationUsed | Time of Flight Information Used.
public Field | TimeOfLastCalibration | Time of Last Calibration.
public Field | TimeOfLastDetectorCalibration | Time of Last Detector Calibration.
public Field | TimeOfSecondaryCapture | Time of Secondary Capture.
public Field | TimeRange | Time Range.
public Field | TimeSliceVector | Time Slice Vector.
public Field | TimeSlotInformationSequence | Time Slot Information Sequence.
public Field | TimeSlotNumber | Time Slot Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TimeSlotTime | Time Slot Time.
public Field | TimeSlotVector | Time Slot Vector.
public Field | TimeSource | Time Source.
public Field | TimezoneOffsetFromUTC | Timezone Offset From UTC.
public Field | TissueHeterogeneityCorrection | Tissue Heterogeneity Correction.
public Field | TmLinePositionX0 | TM-Line Position X0.
public Field | TMLinePositionX0Retired | TM-Line Position X0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionX1 | TM-Line Position X1.
public Field | TMLinePositionX1Retired | TM-Line Position X1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionY0 | TM-Line Position Y0.
public Field | TMLinePositionY0Retired | TM-Line Position Y0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionY1 | TM-Line Position Y1.
public Field | TMLinePositionY1Retired | TM-Line Position Y1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ToleranceTableLabel | Tolerance Table Label.
public Field | ToleranceTableNumber | Tolerance Table Number.
public Field | ToleranceTableSequence | Tolerance Table Sequence.
public Field | TomoAngle | Tomo Angle.
public Field | TomoClass | Tomo Class.
public Field | TomoLayerHeight | Tomo Layer Height.
public Field | TomoTime | Tomo Time.
public Field | TomoType | Tomo Type.
public Field | TopicAuthor | Topic Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicKeywords | Topic Keywords. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicSubject | Topic Subject. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicTitle | Topic Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalBlockTrayFactor | Total Block Tray Factor.
public Field | TotalBlockTrayWaterEquivalentThickness | Total Block Tray Water-Equivalent Thickness.
public Field | TotalCollimationWidth | Total Collimation Width.
public Field | TotalCompensatorTrayFactor | Total Compensator Tray Factor.
public Field | TotalCompensatorTrayWaterEquivalentThickness | Total Compensator Tray Water-Equivalent Thickness.
public Field | TotalGain | Total Gain. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalNumberofExposures | Total Number of Exposures.
public Field | TotalNumberofPiecesofMediaCreated | Total Number of Pieces of Media Created.
public Field | TotalReferenceAirKerma | Total Reference Air Kerma.
public Field | TotalTime | Total Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalTimeofFluoroscopy | Total Time of Fluoroscopy.
public Field | TotalWedgeTrayWaterEquivalentThickness | Total Wedge Tray Water-Equivalent Thickness.
public Field | TransactionUID | Transaction UID.
public Field | TransducerApplicationCodeSequence | Transducer Application Code Sequence.
public Field | TransducerBeamSteeringCodeSequence | Transducer Beam Steering Code Sequence.
public Field | TransducerData | Transducer Data.
public Field | TransducerFrequency | Transducer Frequency.
public Field | TransducerGeometryCodeSequence | Transducer Geometry Code Sequence.
public Field | TransducerOrientation | Transducer Orientation.
public Field | TransducerOrientationModifierSequence | Transducer Orientation Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerOrientationSequence | Transducer Orientation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerPosition | Transducer Position.
public Field | TransducerPositionModifierSequence | Transducer Position Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerPositionSequence | Transducer Position Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerScanPatternCodeSequence | Transducer Scan Pattern Code Sequence.
public Field | TransducerType | Transducer Type.
public Field | TransferSyntaxUID | Transfer Syntax UID. This tells whether the DICOM file uses big or little endian format, which compression is used, if any, and whether the file uses Implicit or Explicit Value Representation syntax.
public Field | TransferTubeLength | Transfer Tube Length.
public Field | TransferTubeNumber | Transfer Tube Number.
public Field | TransformLabel | Transform Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransformVersionNumber | Transform Version Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransmitCoilManufacturerName | Transmit Coil Manufacturer Name.
public Field | TransmitCoilName | Transmit Coil Name.
public Field | TransmitCoilType | Transmit Coil Type.
public Field | TransmitterFrequency | Transmitter Frequency.
public Field | TransverseDetectorSeparation | Transverse Detector Separation.
public Field | TransverseMash | Transverse Mash.
public Field | TreatmentControlPointDate | Treatment Control Point Date.
public Field | TreatmentControlPointTime | Treatment Control Point Time.
public Field | TreatmentDate | Treatment Date.
public Field | TreatmentDeliveryType | Treatment Delivery Type.
public Field | TreatmentMachineName | Treatment Machine Name.
public Field | TreatmentMachineSequence | Treatment Machine Sequence.
public Field | TreatmentProtocols | Treatment Protocols.
public Field | TreatmentSessionApplicationSetupSequence | Treatment Session Application Setup Sequence.
public Field | TreatmentSessionBeamSequence | Treatment Session Beam Sequence.
public Field | TreatmentSessionIonBeamSequence | Treatment Session Ion Beam Sequence.
public Field | TreatmentSites | Treatment Sites.
public Field | TreatmentStatusComment | Treatment Status Comment.
public Field | TreatmentSummaryCalculatedDoseReferenceSequence | Treatment Summary Calculated Dose Reference Sequence.
public Field | TreatmentSummaryMeasuredDoseReferenceSequence | Treatment Summary Measured Dose Reference Sequence.
public Field | TreatmentTerminationCode | Treatment Termination Code.
public Field | TreatmentTerminationStatus | Treatment Termination Status.
public Field | TreatmentTime | Treatment Time.
public Field | TreatmentVerificationStatus | Treatment Verification Status.
public Field | TriangleFanSequence | Triangle Fan Sequence.
public Field | TrianglePointIndexList | Triangle Point Index List.
public Field | TriangleStripSequence | Triangle Strip Sequence.
public Field | TriggerSamplePosition | Trigger Sample Position.
public Field | TriggerSourceorType | Trigger Source or Type.
public Field | TriggerTime | Trigger Time.
public Field | TriggerTimeOffset | Trigger Time Offset.
public Field | TriggerVector | Trigger Vector.
public Field | TriggerWindow | Trigger Window.
public Field | Trim | Trim value.
public Field | TubeAngle | Tube Angle.
public Field | TypeOfData | Type of Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TypeOfDetectorMotion | Type of Detector Motion.
public Field | TypeOfFilters | Type of Filters.
public Field | TypeOfPatientID | Type of Patient ID.
public Field | TypeOfSynchronization | Type of Synchronization.
public Field | UID | UID (unique identifier).
public Field | UltrasoundAcquisitionGeometry | Ultrasound Acquisition Geometry.
public Field | UltrasoundColorDataPresent | Ultrasound Color Data Present.
public Field | UnformattedTextValue | Unformatted Text Value.
public Field | UnifiedProcedureStepCommunicationsURISequence | Unified Procedure Step Communications URI Sequence.
public Field | UnifiedProcedureStepDiscontinuationReasonCodeSequence | Unified Procedure Step Discontinuation Reason Code Sequence.
public Field | UnifiedProcedureStepListStatus | Unified Procedure Step List Status.
public Field | UnifiedProcedureStepPerformedProcedureSequence | Unified Procedure Step Performed Procedure Sequence.
public Field | UnifiedProcedureStepProgress | Unified Procedure Step Progress.
public Field | UnifiedProcedureStepProgressDescription | Unified Procedure Step Progress Description.
public Field | UnifiedProcedureStepProgressInformationSequence | Unified Procedure Step Progress Information Sequence.
public Field | UnifiedProcedureStepState | Unified Procedure Step State.
public Field | Units | The Units.
public Field | UniversalEntityID | Universal Entity ID.
public Field | UniversalEntityIDType | Universal Entity ID Type.
public Field | UNKNOWN | Tag not found in the dictionary.
public Field | UnspecifiedLateralityLensSequence | Unspecified Laterality Lens Sequence.
public Field | UpperLowerPixelValues | Upper/Lower Pixel Values. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | UsedFiducialsSequence | Used Fiducials Sequence.
public Field | USImageDescriptionSequence | US Image Description Sequence.
public Field | ValueType | Value Type.
public Field | VariableCoefficientsSDDN | Variable Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableCoefficientsSDHN | Variable Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableCoefficientsSDVN | Variable Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableFlipAngleFlag | Variable Flip Angle Flag.
public Field | VariableNextDataGroup | Variable Next Data Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariablePixelData | Variable Pixel Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VectorAccuracy | Vector Accuracy.
public Field | VectorCoordinateData | Vector Coordinate Data.
public Field | VectorDimensionality | Vector Dimensionality.
public Field | VectorGridData | Vector Grid Data.
public Field | VelocityEncodingDirection | Velocity Encoding Direction.
public Field | VelocityEncodingMaximumValue | Velocity Encoding Maximum Value.
public Field | VelocityEncodingMinimumValue | Velocity Encoding Minimum Value.
public Field | VerificationDateTime | Verification Date Time.
public Field | VerificationFlag | Verification Flag.
public Field | VerificationImageTiming | Verification Image Timing.
public Field | VerifyingObserverIdentificationCodeSequence | Verifying Observer Identification Code Sequence.
public Field | VerifyingObserverName | Verifying Observer Name.
public Field | VerifyingObserverSequence | Verifying Observer Sequence.
public Field | VerifyingOrganization | Verifying Organization.
public Field | VertexPointIndexList | Vertex Point Index List.
public Field | VerticalPrismBase | Vertical Prism Base.
public Field | VerticalPrismPower | Vertical Prism Power.
public Field | VerticesOfThePolygonalCollimator | Vertices of the Polygonal Collimator.
public Field | VerticesOfThePolygonalExposureControlSensingRegion | Vertices of the Polygonal Exposure Control Sensing Region.
public Field | VerticesOfThePolygonalShutter | Vertices of the Polygonal Shutter.
public Field | VerticesOfTheRegion | Vertices of the Region.
public Field | VideoImageFormatAcquired | Video Image Format Acquired.
public Field | ViewCodeSequence | View Code Sequence.
public Field | ViewingDistance | Viewing Distance.
public Field | ViewingDistanceType | Viewing Distance Type.
public Field | ViewModifierCodeSequence | View Modifier Code Sequence.
public Field | ViewName | View Name.
public Field | ViewNumber | View Number.
public Field | ViewPosition | View Position.
public Field | VirtualSourceAxisDistances | Virtual Source-Axis Distances.
public Field | VisitComments | Visit Comments.
public Field | VisitStatusID | Visit Status ID.
public Field | VisualAcuityBothEyesOpenSequence | Visual Acuity Both Eyes Open Sequence.
public Field | VisualAcuityLeftEyeSequence | Visual Acuity Left Eye Sequence.
public Field | VisualAcuityModifiers | Visual Acuity Modifiers.
public Field | VisualAcuityRightEyeSequence | Visual Acuity Right Eye Sequence.
public Field | VisualAcuityTypeCodeSequence | Visual Acuity Type Code Sequence.
public Field | VitalStainCodeSequence | Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VitalStainCodeSequenceTrial | Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VOILUTFunction | VOI LUT Function.
public Field | VOILUTSequence | VOI LUT Sequence.
public Field | VOIType | VOI (Value Of Interest) Type.
public Field | VolumeBasedCalculationTechnique | Volume Based Calculation Technique.
public Field | VolumeFrameOfReferenceUID | Volume Frame of Reference UID.
public Field | VolumeLocalizationSequence | Volume Localization Sequence.
public Field | VolumeLocalizationTechnique | Volume Localization Technique.
public Field | VolumeToTableMappingMatrix | Volume to Table Mapping Matrix.
public Field | VolumeToTransducerMappingMatrix | Volume to Transducer Mapping Matrix.
public Field | VolumetricProperties | Volumetric Properties.
public Field | WaterReferencedPhaseCorrection | Water Referenced Phase Correction.
public Field | WaveformAnnotationSequence | Waveform Annotation Sequence.
public Field | WaveformBitsAllocated | Waveform Bits Allocated.
public Field | WaveformBitsStored | Waveform Bits Stored.
public Field | WaveformChannelNumber | Waveform Channel Number.
public Field | WaveformData | Waveform Data.
public Field | WaveformDataDisplayScale | Waveform Data Display Scale.
public Field | WaveformDisplayBackgroundCIELabValue | Waveform Display Background CIELab Value.
public Field | WaveformOriginality | Waveform Originality.
public Field | WaveformPaddingValue | Waveform Padding Value.
public Field | WaveformPresentationGroupSequence | Waveform Presentation Group Sequence.
public Field | WaveformSampleInterpretation | Waveform Sample Interpretation.
public Field | WaveformSampleValueRepresentation | Waveform Sample Value Representation.
public Field | WaveformSequence | Waveform Sequence.
public Field | WedgeAngle | Wedge Angle.
public Field | WedgeFactor | Wedge Factor.
public Field | WedgeID | Wedge Identifier.
public Field | WedgeNumber | Wedge Number.
public Field | WedgeOrientation | Wedge Orientation.
public Field | WedgePosition | Wedge Position.
public Field | WedgePositionSequence | Wedge Position Sequence.
public Field | WedgeSequence | Wedge Sequence.
public Field | WedgeThinEdgePosition | Wedge Thin Edge Position.
public Field | WedgeType | Wedge Type.
public Field | WholeBodyTechnique | Whole Body Technique.
public Field | WindowCenter | Window Center.
public Field | WindowCenterAndWidthExplanation | Window Center and Width Explanation.
public Field | WindowWidth | Window Width.
public Field | WorklistLabel | Worklist Label.
public Field | XA_XRFFrameCharacteristicsSequence | XA/XRF Frame Characteristics Sequence.
public Field | XFocusCenter | X Focus Center.
public Field | XOffsetInSlideCoordinateSystem | X offset in Slide Coordinate System.
public Field | XRay3DAcquisitionSequence | X-Ray 3D Acquisition Sequence.
public Field | XRay3DFrameTypeSequence | X-Ray 3D Frame Type Sequence.
public Field | XRay3DReconstructionSequence | X-Ray 3D Reconstruction Sequence.
public Field | XRayGeometrySequence | X-Ray Geometry Sequence.
public Field | XrayImageReceptorAngle | X-Ray Image Receptor Angle.
public Field | XRayImageReceptorTranslation | X-Ray Image Receptor Translation.
public Field | XrayOutput | X-Ray Output.
public Field | XRayReceptorType | X-Ray Receptor Type.
public Field | XRayTubeCurrent | X-Ray Tube Current.
public Field | XRayTubeCurrentInMilliA | X-Ray Tube Current in mA.
public Field | XRayTubeCurrentInuA | X-Ray Tube Current in micro A.
public Field | YFocusCenter | Y Focus Center.
public Field | YOffsetInSlideCoordinateSystem | Y offset in Slide Coordinate System.
public Field | ZOffsetInSlideCoordinateSystem | Z offset in Slide Coordinate System.
public Field | ZonalMap | Zonal Map. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapFormat | Zonal Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapLocation | Zonal Map Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapNumberFormat | Zonal Map Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZoomCenter | Zoom Center.
public Field | ZoomFactor | Zoom Factor.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | forValue | Creates enum object from integer value
public Method | getValue | Creates gets int value of enum
static (Shared in Visual Basic) | values | Returns list of all DICOM tags
Top

See Also

Reference

ImGearDICOMTagsIDs Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMTagsIDs Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImGearDICOMTagsIDs Constructor
value

Glossary Item Box

Default constructor

Syntax

public ImGearDICOMTagsIDs(
   int value
)

Parameters

value

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDICOMTagsIDs Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMTagsIDs Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMTagsIDs members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | forValue | Creates enum object from integer value
public Method | getValue | Creates gets int value of enum
static (Shared in Visual Basic) | values | Returns list of all DICOM tags
Top

See Also

Reference

ImGearDICOMTagsIDs Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

forValue Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : forValue Method
value

Glossary Item Box

Creates enum object from integer value

Syntax

public static ImGearDICOMTagsIDs forValue(
   int value
)

Parameters

value

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : getValue Method

Glossary Item Box

Creates gets int value of enum

Syntax

public int getValue()

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

values Method
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : values Method

Glossary Item Box

Returns list of all DICOM tags

Syntax

public static java.util.ArrayList<ImGearDICOMTagsIDs> values()

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDICOMTagsIDs Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMTagsIDs Class

Glossary Item Box

For a list of all members of this type, see ImGearDICOMTagsIDs members.

Public Fields

 | Name | Description
public Field | AbsoluteChannelDisplayScale | Absolute Channel Display Scale.
public Field | AbstractPriorCodeSequence | Abstract Prior Code Sequence.
public Field | AbstractPriorValue | Abstract Prior Value.
public Field | AccessionNumber | Accession Number.
public Field | AccessoryCode | Accessory Code.
public Field | AcquiredImageAreaDoseProduct | Acquired Image Area Dose Product.
public Field | AcquisitionComments | Acquisition Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionContextDescription | Acquisition Context Description.
public Field | AcquisitionContextSequence | Acquisition Context Sequence.
public Field | AcquisitionContrast | Acquisition Contrast.
public Field | AcquisitionDate | Acquisition Date.
public Field | AcquisitionDateTime | Acquisition DateTime.
public Field | AcquisitionDeviceProcessingCode | Acquisition Device Processing Code.
public Field | AcquisitionDeviceProcessingDescription | Acquisition Device Processing Description.
public Field | AcquisitionDeviceTypeCodeSequence | Acquisition Device Type Code Sequence.
public Field | AcquisitionDuration | Acquisition Duration.
public Field | AcquisitionIndex | Acquisition Index.
public Field | AcquisitionMatrix | Acquisition Matrix.
public Field | AcquisitionNumber | Acquisition Number.
public Field | AcquisitionProtocolDescription | Acquisition Protocol Description.
public Field | AcquisitionProtocolName | Acquisition Protocol Name.
public Field | AcquisitionsInSeries | Acquisitions in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionsInStudy | Acquisitions in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AcquisitionStartCondition | Acquisition Start Condition.
public Field | AcquisitionStartConditionData | Acquisition Start Condition Data.
public Field | AcquisitionTerminationCondition | Acquisition Termination Condition.
public Field | AcquisitionTerminationConditionData | Acquisition Termination Condition Data.
public Field | AcquisitionTime | Acquisition Time.
public Field | AcquisitionTimeSynchronized | Acquisition Time Synchronized.
public Field | AcquisitionType | Acquisition Type.
public Field | AcrossScanSpatialResolution | Across-scan Spatial Resolution.
public Field | ActionTypeID | Action Type ID.
public Field | ActiveSourceDiameter | Active Source Diameter.
public Field | ActiveSourceLength | Active Source Length.
public Field | ActualCardiacTriggerDelayTime | Actual Cardiac Trigger Delay Time.
public Field | ActualFrameDuration | Actual Frame Duration.
public Field | ActualHumanPerformersSequence | Actual Human Performers Sequence.
public Field | ActualRespiratoryTriggerDelayTime | Actual Respiratory Trigger Delay Time.
public Field | AdaptiveMapFormat | Adaptive Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddGrayScale | Add Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddIntermediateSequence | Add Intermediate Sequence.
public Field | AdditionalDrugSequence | Additional Drug Sequence.
public Field | AdditionalPatientHistory | Additional Patient History.
public Field | AddNearSequence | Add Near Sequence.
public Field | AddOtherSequence | Add Other Sequence.
public Field | AddPower | Add Power.
public Field | Address | Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AddressTrial | Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AdministrationRouteCodeSequence | Administration Route Code Sequence.
public Field | AdmissionID | Admission ID.
public Field | AdmittingDate | Admitting Date.
public Field | AdmittingDiagnosesCodeSequence | Admitting Diagnoses Code Sequence.
public Field | AdmittingDiagnosesDescription | Admitting Diagnoses Description.
public Field | AdmittingTime | Admitting Time.
public Field | AffectedSOPClassUID | Affected SOP Class UID.
public Field | AffectedSOPInstanceUID | Affected SOP Instance UID.
public Field | AlertCodeSequence | Alert Code Sequence.
public Field | AlgorithmDescription | Algorithm Description.
public Field | AlgorithmFamilyCodeSequence | Algorithm Family Code Sequence.
public Field | AlgorithmName | Algorithm Name.
public Field | AlgorithmNameCodeSequence | Algorithm Name Code Sequence.
public Field | AlgorithmParameters | Algorithm Parameters.
public Field | AlgorithmType | Algorithm Type.
public Field | AlgorithmVersion | Algorithm Version.
public Field | AliasedDataType | Aliased Data Type.
public Field | Allergies | Allergies value.
public Field | AllowLossyCompression | Allow Lossy Compression.
public Field | AllowMediaSplitting | Allow Media Splitting.
public Field | AlongScanSpatialResolution | Along-scan Spatial Resolution.
public Field | AlphaLUTTransferFunction | Alpha LUT Transfer Function.
public Field | AlphaPaletteColorLookupTableData | Alpha Palette Color Lookup Table Data.
public Field | AlphaPaletteColorLookupTableDescriptor | Alpha Palette Color Lookup Table Descriptor.
public Field | AlternateContainerIdentifierSequence | Alternate Container Identifier Sequence.
public Field | AlternateContentDescriptionSequence | Alternate Content Description Sequence.
public Field | AlternateRepresentationSequence | Alternate Representation Sequence.
public Field | AnatomicalOrientationType | Anatomical Orientation Type.
public Field | AnatomicApproachDirectionCodeSequence | Anatomic Approach Direction Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicLocationOfExaminingInstrumentCodeSequence | Anatomic Location Of Examining Instrument Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicLocationOfExaminingInstrumentDescription | Anatomic Location Of Examining Instrument Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPerspectiveCodeSequence | Anatomic Perspective Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPerspectiveDescription | Anatomic Perspective Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicPortalOfEntranceCodeSequence | Anatomic Portal Of Entrance Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicRegionModifierSequence | Anatomic Region Modifier Sequence.
public Field | AnatomicRegionSequence | Anatomic Region Sequence.
public Field | AnatomicStructure | Anatomic Structure.
public Field | AnatomicStructureSpaceOrRegionCodeSequence | Anatomic Structure Space Or Region Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicStructureSpaceOrRegionModifierCodeSequence | Anatomic Structure Space Or Region Modifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnatomicStructureSpaceOrRegionSequence | Anatomic Structure, Space or Region Sequence.
public Field | AnchorPoint | Anchor Point.
public Field | AnchorPointAnnotationUnits | Anchor Point Annotation Units.
public Field | AnchorPointVisibility | Anchor Point Visibility.
public Field | AngioFlag | Angio Flag.
public Field | AngleNumber | Angle Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AngularPosition | Angular Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AngularStep | Angular Step.
public Field | AngularViewVector | Angular View Vector.
public Field | AnnotationContentSequence | Annotation Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnnotationDisplayFormatID | Annotation Display Format ID.
public Field | AnnotationFlag | Annotation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AnnotationGroupNumber | Annotation Group Number.
public Field | AnnotationPosition | Annotation Position.
public Field | AnodeTargetMaterial | Anode Target Material.
public Field | ApexPosition | Apex Position.
public Field | ApplicableFrameRange | Applicable Frame Range.
public Field | ApplicableSafetyStandardAgency | Applicable Safety Standard Agency.
public Field | ApplicableSafetyStandardDescription | Applicable Safety Standard Description.
public Field | ApplicationManufacturer | Application Manufacturer.
public Field | ApplicationMaximumRepaintTime | Application Maximum Repaint Time.
public Field | ApplicationName | Application Name.
public Field | ApplicationSetupCheck | Application Setup Check.
public Field | ApplicationSetupManufacturer | Application Setup Manufacturer.
public Field | ApplicationSetupName | Application Setup Name.
public Field | ApplicationSetupNumber | Application Setup Number.
public Field | ApplicationSetupSequence | Application Setup Sequence.
public Field | ApplicationSetupType | Application Setup Type.
public Field | ApplicationVersion | Application Version.
public Field | ApplicatorDescription | Applicator Description.
public Field | ApplicatorID | Applicator ID.
public Field | ApplicatorSequence | Applicator Sequence.
public Field | ApplicatorType | Applicator Type.
public Field | ApprovalStatus | Approval Status.
public Field | ApprovalStatusDateTime | Approval Status DateTime.
public Field | ApprovalStatusFurtherDescription | Approval Status Further Description.
public Field | Arbitrary | Arbitrary. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ArchiveRequested | Archive Requested.
public Field | AssigningAgencyOrDepartmentCodeSequence | Assigning Agency or Department Code Sequence.
public Field | AssigningFacilitySequence | Assigning Facility Sequence.
public Field | AssigningJurisdictionCodeSequence | Assigning Jurisdiction Code Sequence.
public Field | AttachedContours | Attached Contours.
public Field | AttenuationCorrected | Attenuation Corrected.
public Field | AttenuationCorrectionMethod | Attenuation Correction Method.
public Field | AttenuationCorrectionSource | Attenuation Correction Source.
public Field | AttenuationCorrectionTemporalRelationship | Attenuation Correction Temporal Relationship.
public Field | AttributeIdentifierList | Attribute Identifier List.
public Field | AttributeItemSelector | Attribute Item Selector.
public Field | AttributeModificationDateTime | Attribute Modification DateTime.
public Field | AttributeOccurrencePointer | Attribute Occurrence Pointer.
public Field | AttributeOccurrencePrivateCreator | Attribute Occurrence Private Creator.
public Field | AttributeOccurrenceSequence | Attribute Occurrence Sequence.
public Field | AudioComments | Audio Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioSampleData | Audio Sample Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioSampleFormat | Audio Sample Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AudioType | Audio Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AuthorizationEquipmentCertificationNumber | Authorization Equipment Certification Number.
public Field | AuthorObserverSequence | Author Observer Sequence.
public Field | AutorefractionLeftEyeSequence | Autorefraction Left Eye Sequence.
public Field | AutorefractionRightEyeSequence | Autorefraction Right Eye Sequence.
public Field | AveragePulseWidth | Average Pulse Width.
public Field | AxialAcceptance | Axial Acceptance.
public Field | AxialDetectorDimension | Axial Detector Dimension.
public Field | AxialLengthOfTheEye | Axial Length of the Eye.
public Field | AxialMash | Axial Mash.
public Field | AxisLabels | Axis Labels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | AxisOfRotation | Axis of Rotation.
public Field | AxisUnits | Axis Units. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BackgroundColor | Background Color.
public Field | BarcodeSymbology | Barcode Symbology.
public Field | BarcodeValue | Barcode Value.
public Field | BaselineCorrection | Baseline Correction.
public Field | BasicColorImageSequence | Basic Color Image Sequence.
public Field | BasicGrayscaleImageSequence | Basic Grayscale Image Sequence.
public Field | BeamAngle | Beam Angle.
public Field | BeamCurrentModulationID | Beam Current Modulation ID.
public Field | BeamDescription | Beam Description.
public Field | BeamDose | Beam Dose.
public Field | BeamDosePointDepth | Beam Dose Point Depth.
public Field | BeamDosePointEquivalentDepth | Beam Dose Point Equivalent Depth.
public Field | BeamDosePointSSD | Beam Dose Point SSD.
public Field | BeamDoseSpecificationPoint | Beam Dose Specification Point.
public Field | BeamLimitingDeviceAngle | Beam Limiting Device Angle.
public Field | BeamLimitingDeviceAngleTolerance | Beam Limiting Device Angle Tolerance.
public Field | BeamLimitingDeviceLeafPairsSequence | Beam Limiting Device Leaf Pairs Sequence.
public Field | BeamLimitingDevicePositionSequence | Beam Limiting Device Position Sequence.
public Field | BeamLimitingDevicePositionTolerance | Beam Limiting Device Position Tolerance.
public Field | BeamLimitingDeviceRotationDirection | Beam Limiting Device Rotation Direction.
public Field | BeamLimitingDeviceSequence | Beam Limiting Device Sequence.
public Field | BeamLimitingDeviceToleranceSequence | Beam Limiting Device Tolerance Sequence.
public Field | BeamMeterset | Beam Meterset.
public Field | BeamName | Beam Name.
public Field | BeamNumber | Beam Number.
public Field | BeamOrderIndex | Beam Order Index.
public Field | BeamSequence | Beam Sequence.
public Field | BeamStopperPosition | Beam Stopper Position.
public Field | BeamTaskSequence | Beam Task Sequence.
public Field | BeamTaskType | Beam Task Type.
public Field | BeamType | Beam Type.
public Field | BeatRejectionFlag | Beat Rejection Flag.
public Field | BillingItemSequence | Billing Item Sequence.
public Field | BillingProcedureStepSequence | Billing Procedure Step Sequence.
public Field | BillingSuppliesAndDevicesSequence | Billing Supplies and Devices Sequence.
public Field | BiPlaneAcquisitionSequence | Bi-Plane Acquisition Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsAllocated | Bits Allocated.
public Field | BitsForCodeWord | Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsGrouped | Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BitsMappedToColorLookupTable | Bits Mapped to Color Lookup Table.
public Field | BitsStored | Bits Stored.
public Field | BlendingLookupTableData | Blending Lookup Table Data.
public Field | BlendingLookupTableDescriptor | Blending Lookup Table Descriptor.
public Field | BlendingLUT1Sequence | Blending LUT 1 Sequence.
public Field | BlendingLUT1TransferFunction | Blending LUT 1 Transfer Function.
public Field | BlendingLUT2Sequence | Blending LUT 2 Sequence.
public Field | BlendingLUT2TransferFunction | Blending LUT 2 Transfer Function.
public Field | BlendingOperationType | Blending Operation Type.
public Field | BlendingPosition | Blending Position.
public Field | BlendingSequence | Blending Sequence.
public Field | BlendingWeightConstant | Blending Weight Constant.
public Field | BlockColumns | Block Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockData | Block Data.
public Field | BlockDivergence | Block Divergence.
public Field | BlockedPixels | Blocked Pixels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockMountingPosition | Block Mounting Position.
public Field | BlockName | Block Name.
public Field | BlockNumber | Block Number.
public Field | BlockNumberOfPoints | Block Number of Points.
public Field | BlockRows | Block Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BlockSequence | Block Sequence.
public Field | BlockThickness | Block Thickness.
public Field | BlockTransmission | Block Transmission.
public Field | BlockTrayID | Block Tray ID.
public Field | BlockType | Block Type.
public Field | BloodSignalNulling | Blood Signal Nulling.
public Field | BluePaletteColorLookupTableData | Blue Palette Color Lookup Table Data.
public Field | BluePaletteColorLookupTableDescriptor | Blue Palette Color Lookup Table Descriptor.
public Field | BodyPartExamined | Body Part Examined.
public Field | BodyPartThickness | Body Part Thickness.
public Field | BolusDescription | Bolus Description.
public Field | BolusID | Bolus Identifier.
public Field | BoneThermalIndex | Bone Thermal Index.
public Field | BorderDensity | Border Density.
public Field | Borders | Borders. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BoundingBoxAnnotationUnits | Bounding Box Annotation Units.
public Field | BoundingBoxBottomRightHandCorner | Bounding Box Bottom Right Hand Corner.
public Field | BoundingBoxTextHorizontalJustification | Bounding Box Text Horizontal Justification.
public Field | BoundingBoxTopLeftHandCorner | Bounding Box Top Left Hand Corner.
public Field | BrachyAccessoryDeviceID | Brachy Accessory Device ID.
public Field | BrachyAccessoryDeviceName | Brachy Accessory Device Name.
public Field | BrachyAccessoryDeviceNominalThickness | Brachy Accessory Device Nominal Thickness.
public Field | BrachyAccessoryDeviceNominalTransmission | Brachy Accessory Device Nominal Transmission.
public Field | BrachyAccessoryDeviceNumber | Brachy Accessory Device Number.
public Field | BrachyAccessoryDeviceSequence | Brachy Accessory Device Sequence.
public Field | BrachyAccessoryDeviceType | Brachy Accessory Device Type.
public Field | BrachyApplicationSetupDose | Brachy Application Setup Dose.
public Field | BrachyApplicationSetupDoseSpecificationPoint | Brachy Application Setup Dose Specification Point.
public Field | BrachyControlPointDeliveredSequence | Brachy Control Point Delivered Sequence.
public Field | BrachyControlPointSequence | Brachy Control Point Sequence.
public Field | BrachyReferencedDoseReferenceSequence | Brachy Referenced Dose Reference Sequence.
public Field | BrachyTreatmentTechnique | Brachy Treatment Technique.
public Field | BrachyTreatmentType | Brachy Treatment Type.
public Field | BranchOfService | Branch of Service.
public Field | BreastImplantPresent | Breast Implant Present.
public Field | BreedRegistrationNumber | Breed Registration Number.
public Field | BreedRegistrationSequence | Breed Registration Sequence.
public Field | BreedRegistryCodeSequence | Breed Registry Code Sequence.
public Field | BulkMotionCompensationTechnique | Bulk Motion Compensation Technique.
public Field | BulkMotionSignalSource | Bulk Motion Signal Source.
public Field | BulkMotionStatus | Bulk Motion Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | BurnedInAnnotation | Burned In Annotation.
public Field | CalciumScoringMassFactorDevice | Calcium Scoring Mass Factor Device.
public Field | CalciumScoringMassFactorPatient | Calcium Scoring Mass Factor Patient.
public Field | CalculatedAnatomyThickness | Calculated Anatomy Thickness.
public Field | CalculatedDoseReferenceDescription | Calculated Dose Reference Description.
public Field | CalculatedDoseReferenceDoseValue | Calculated Dose Reference Dose Value.
public Field | CalculatedDoseReferenceNumber | Calculated Dose Reference Number.
public Field | CalculatedDoseReferenceSequence | Calculated Dose Reference Sequence.
public Field | CalculatedFrameList | Calculated Frame List.
public Field | CalibrationDataSequence | Calibration Data Sequence.
public Field | CalibrationImage | Calibration Image.
public Field | CalibrationSequence | Calibration Sequence.
public Field | CardiacBeatRejectionTechnique | Cardiac Beat Rejection Technique.
public Field | CardiacCyclePosition | Cardiac Cycle Position.
public Field | CardiacFramingType | Cardiac Framing Type.
public Field | CardiacNumberOfImages | Cardiac Number of Images.
public Field | CardiacRRintervalSpecified | Cardiac R-R Interval Specified.
public Field | CardiacSignalSource | Cardiac Signal Source.
public Field | CardiacSynchronizationSequence | Cardiac Synchronization Sequence.
public Field | CardiacSynchronizationTechnique | Cardiac Synchronization Technique.
public Field | CarmPositionerTabletopRelationship | C-arm Positioner Tabletop Relationship.
public Field | CassetteID | Cassette ID.
public Field | CassetteOrientation | Cassette Orientation.
public Field | CassetteSize | Cassette Size.
public Field | CenterOfCircularCollimator | Center of Circular Collimator.
public Field | CenterofCircularExposureControlSensingRegion | Center of Circular Exposure Control Sensing Region.
public Field | CenterOfCircularShutter | Center of Circular Shutter.
public Field | CenterOfRotation | Center of Rotation.
public Field | CenterOfRotationOffset | Center of Rotation Offset.
public Field | CertificateOfSigner | Certificate of Signer.
public Field | CertificateType | Certificate Type.
public Field | CertifiedTimestamp | Certified Timestamp.
public Field | CertifiedTimestampType | Certified Timestamp Type.
public Field | ChannelBaseline | Channel Baseline.
public Field | ChannelDefinitionSequence | Channel Definition Sequence.
public Field | ChannelDerivationDescription | Channel Derivation Description.
public Field | ChannelDescriptionCodeSequence | Channel Description Code Sequence.
public Field | ChannelDisplaySequence | Channel Display Sequence.
public Field | ChannelIdentificationCode | Channel Identification Code.
public Field | ChannelLabel | Channel Label.
public Field | ChannelLength | Channel Length.
public Field | ChannelMaximumValue | Channel Maximum Value.
public Field | ChannelMinimumValue | Channel Minimum Value.
public Field | ChannelMode | Channel Mode.
public Field | ChannelNumber | Channel Number.
public Field | ChannelOffset | Channel Offset.
public Field | ChannelPosition | Channel Position.
public Field | ChannelRecommendedDisplayCIELabValue | Channel Recommended Display CIELab Value.
public Field | ChannelSampleSkew | Channel Sample Skew.
public Field | ChannelSensitivity | Channel Sensitivity.
public Field | ChannelSensitivityCorrectionFactor | Channel Sensitivity Correction Factor.
public Field | ChannelSensitivityUnitsSequence | Channel Sensitivity Units Sequence.
public Field | ChannelSequence | Channel Sequence.
public Field | ChannelShieldID | Channel Shield ID.
public Field | ChannelShieldName | Channel Shield Name.
public Field | ChannelShieldNominalThickness | Channel Shield Nominal Thickness.
public Field | ChannelShieldNominalTransmission | Channel Shield Nominal Transmission.
public Field | ChannelShieldNumber | Channel Shield Number.
public Field | ChannelShieldSequence | Channel Shield Sequence.
public Field | ChannelSourceModifiersSequence | Channel Source Modifiers Sequence.
public Field | ChannelSourceSequence | Channel Source Sequence.
public Field | ChannelStatus | Channel Status.
public Field | ChannelTimeSkew | Channel Time Skew.
public Field | ChannelTotalTime | Channel Total Time.
public Field | ChannelWidth | Channel Width.
public Field | ChemicalShiftMaximumIntegrationLimitInppm | Chemical Shift Maximum Integration Limit in ppm.
public Field | ChemicalShiftMinimumIntegrationLimitInppm | Chemical Shift Minimum Integration Limit in ppm.
public Field | ChemicalShiftReference | Chemical Shift Reference.
public Field | ChemicalShiftSequence | Chemical Shift Sequence.
public Field | ChemicalShiftsMaximumIntegrationLimitInHz | Chemical Shifts Maximum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ChemicalShiftsMinimumIntegrationLimitInHz | Chemical Shifts Minimum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CineRate | Cine Rate.
public Field | CineRelativetoRealTime | Cine Relative to Real-Time.
public Field | ClinicalTrialCoordinatingCenterName | Clinical Trial Coordinating Center Name.
public Field | ClinicalTrialProtocolEthicsCommitteeApprovalNumber | Clinical Trial Protocol Ethics Committee Approval Number.
public Field | ClinicalTrialProtocolEthicsCommitteeName | Clinical Trial Protocol Ethics Committee Name.
public Field | ClinicalTrialProtocolID | Clinical Trial Protocol ID.
public Field | ClinicalTrialProtocolName | Clinical Trial Protocol Name.
public Field | ClinicalTrialSeriesDescription | Clinical Trial Series Description.
public Field | ClinicalTrialSeriesID | Clinical Trial Series ID.
public Field | ClinicalTrialSiteID | Clinical Trial Site ID.
public Field | ClinicalTrialSiteName | Clinical Trial Site Name.
public Field | ClinicalTrialSponsorName | Clinical Trial Sponsor Name.
public Field | ClinicalTrialSubjectID | Clinical Trial Subject ID.
public Field | ClinicalTrialSubjectReadingID | Clinical Trial Subject Reading ID.
public Field | ClinicalTrialTimePointDescription | Clinical Trial Time Point Description.
public Field | ClinicalTrialTimePointID | Clinical Trial Time Point ID.
public Field | CodeLabel | Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeMeaning | Code Meaning.
public Field | CodeNumberFormat | Code Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeTableLocation | Code Table Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CodeValue | Code Value.
public Field | CodingSchemeDesignator | Coding Scheme Designator.
public Field | CodingSchemeExternalID | Coding Scheme External ID.
public Field | CodingSchemeIdentificationSequence | Coding Scheme Identification Sequence.
public Field | CodingSchemeName | Coding Scheme Name.
public Field | CodingSchemeRegistry | Coding Scheme Registry.
public Field | CodingSchemeResponsibleOrganization | Coding Scheme Responsible Organization.
public Field | CodingSchemeUID | Coding Scheme UID.
public Field | CodingSchemeVersion | Coding Scheme Version.
public Field | CoefficientCoding | Coefficient Coding. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientCodingPointers | Coefficient Coding Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDDN | Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDHN | Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoefficientsSDVN | Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoincidenceWindowWidth | Coincidence Window Width.
public Field | CollationFlag | Collation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CollimatorGridName | Collimator/grid Name.
public Field | CollimatorLeftVerticalEdge | Collimator Left Vertical Edge.
public Field | CollimatorLowerHorizontalEdge | Collimator Lower Horizontal Edge.
public Field | CollimatorRightVerticalEdge | Collimator Right Vertical Edge.
public Field | CollimatorShape | Collimator Shape.
public Field | CollimatorShapeSequence | Collimator Shape Sequence.
public Field | CollimatorType | Collimator Type.
public Field | CollimatorUpperHorizontalEdge | Collimator Upper Horizontal Edge.
public Field | ColorImagePrintingFlag | Color Image Printing Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ColumnAngulation | Column Angulation.
public Field | ColumnAngulationPatient | Column Angulation (Patient).
public Field | ColumnOverlap | Column Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Columns | Columns. Width of the DICOM image.
public Field | ColumnsForNthOrderCoefficients | Columns For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CommandField | Command Field.
public Field | CommandGroupLength | Command Group Length.
public Field | CommandLengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CommentsOnRadiationDose | Comments on Radiation Dose.
public Field | CommentsOnThePerformedProcedureStep | Comments on the Performed Procedure Step.
public Field | CommentsOnTheScheduledProcedureStep | Comments on the Scheduled Procedure Step.
public Field | CompensatorColumnOffset | Compensator Column Offset.
public Field | CompensatorColumns | Compensator Columns.
public Field | CompensatorDescription | Compensator Description.
public Field | CompensatorDivergence | Compensator Divergence.
public Field | CompensatorID | Compensator ID.
public Field | CompensatorMillingToolDiameter | Compensator Milling Tool Diameter.
public Field | CompensatorMountingPosition | Compensator Mounting Position.
public Field | CompensatorNumber | Compensator Number.
public Field | CompensatorPixelSpacing | Compensator Pixel Spacing.
public Field | CompensatorPosition | Compensator Position.
public Field | CompensatorRelativeStoppingPowerRatio | Compensator Relative Stopping Power Ratio.
public Field | CompensatorRows | Compensator Rows.
public Field | CompensatorSequence | Compensator Sequence.
public Field | CompensatorThicknessData | Compensator Thickness Data.
public Field | CompensatorTransmissionData | Compensator Transmission Data.
public Field | CompensatorType | Compensator Type.
public Field | CompletionFlag | Completion Flag.
public Field | CompletionFlagDescription | Completion Flag Description.
public Field | ComplexImageComponent | Complex Image Component.
public Field | CompressionCode | Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionDescription | Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionForce | Compression Force.
public Field | CompressionLabel | Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionOriginator | Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionRecognitionCode | Compression Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionSequence | Compression Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CompressionStepPointers | Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ConcatenationFrameOffsetNumber | Concatenation Frame Offset Number.
public Field | ConcatenationUID | Concatenation UID.
public Field | ConceptCodeSequence | Concept Code Sequence.
public Field | ConceptNameCodeSequence | Concept Name Code Sequence.
public Field | ConfidentialityCode | Confidentiality Code.
public Field | ConfidentialityConstraint | Confidentiality Constraint on Patient Data Description.
public Field | ConfidentialityConstraintOnPatientDataDescription | Confidentiality Constraint on Patient Data Description.
public Field | ConfigurationInformation | Configuration Information.
public Field | ConfigurationInformationDescription | Configuration Information Description.
public Field | ConsentForClinicalTrialUseSequence | Consent for Clinical Trial Use Sequence.
public Field | ConsentForDistributionFlag | Consent for Distribution Flag.
public Field | ConstantVolumeFlag | Constant Volume Flag.
public Field | ConstraintWeight | Constraint Weight.
public Field | ContactDisplayName | Contact Display Name.
public Field | ContactURI | Contact URI.
public Field | ContainerComponentDescription | Container Component Description.
public Field | ContainerComponentDiameter | Container Component Diameter.
public Field | ContainerComponentID | Container Component ID.
public Field | ContainerComponentLength | Container Component Length.
public Field | ContainerComponentMaterial | Container Component Material.
public Field | ContainerComponentSequence | Container Component Sequence.
public Field | ContainerComponentThickness | Container Component Thickness.
public Field | ContainerComponentTypeCodeSequence | Container Component Type Code Sequence.
public Field | ContainerComponentWidth | Container Component Width.
public Field | ContainerDescription | Container Description.
public Field | ContainerIdentifier | Container Identifier.
public Field | ContainerTypeCodeSequence | Container Type Code Sequence.
public Field | ContentCreatorsIdentificationCodeSequence | Content Creator's Identification Code Sequence.
public Field | ContentCreatorsName | Content Creator's Name.
public Field | ContentDate | Content Date.
public Field | ContentDescription | Content Description.
public Field | ContentItemModifierSequence | Content Item Modifier Sequence.
public Field | ContentLabel | Content Label.
public Field | ContentQualification | Content Qualification.
public Field | ContentSequence | Content Sequence.
public Field | ContentTemplateSequence | Content Template Sequence.
public Field | ContentTime | Content Time.
public Field | ContextGroupExtensionCreatorUID | Context Group Extension Creator UID.
public Field | ContextGroupExtensionFlag | Context Group Extension Flag.
public Field | ContextGroupLocalVersion | Context Group Local Version.
public Field | ContextGroupVersion | Context Group Version.
public Field | ContextIdentifier | Context Identifier.
public Field | ContextUID | Context UID.
public Field | ContinuityOfContent | Continuity Of Content.
public Field | ContourData | Contour Data.
public Field | ContourGeometricType | Contour Geometric Type.
public Field | ContourImageSequence | Contour Image Sequence.
public Field | ContourNumber | Contour Number.
public Field | ContourOffsetVector | Contour Offset Vector.
public Field | ContourSequence | Contour Sequence.
public Field | ContourSlabThickness | Contour Slab Thickness.
public Field | ContourUncertaintyRadius | Contour Uncertainty Radius.
public Field | ContrastAdministrationProfileSequence | Contrast Administration Profile Sequence.
public Field | ContrastBolusAdministrationRouteSequence | Contrast/Bolus Administration Route Sequence.
public Field | ContrastBolusAgent | Contrast/Bolus Agent.
public Field | ContrastBolusAgentAdministered | Contrast/Bolus Agent Administered.
public Field | ContrastBolusAgentDetected | Contrast/Bolus Agent Detected.
public Field | ContrastBolusAgentNumber | Contrast/Bolus Agent Number.
public Field | ContrastBolusAgentPhase | Contrast/Bolus Agent Phase.
public Field | ContrastBolusAgentSequence | Contrast/Bolus Agent Sequence.
public Field | ContrastBolusIngredient | Contrast/Bolus Ingredient.
public Field | ContrastBolusIngredientCodeSequence | Contrast/Bolus Ingredient Code Sequence.
public Field | ContrastBolusIngredientConcentration | Contrast/Bolus Ingredient Concentration.
public Field | ContrastBolusIngredientOpaque | Contrast/Bolus Ingredient Opaque.
public Field | ContrastBolusRoute | Contrast/Bolus Route.
public Field | ContrastBolusStartTime | Contrast/Bolus Start Time.
public Field | ContrastBolusStopTime | Contrast/Bolus Stop Time.
public Field | ContrastBolusTotalDose | Contrast/Bolus Total Dose.
public Field | ContrastBolusUsageSequence | Contrast/Bolus Usage Sequence.
public Field | ContrastBolusVolume | Contrast/Bolus Volume.
public Field | ContrastFlowDuration | Contrast Flow Duration.
public Field | ContrastFlowRate | Contrast Flow Rate.
public Field | ContrastFrameAveraging | Contrast Frame Averaging.
public Field | ContributingEquipmentSequence | Contributing Equipment Sequence.
public Field | ContributingSOPInstancesReferenceSequence | Contributing SOP Instances Reference Sequence.
public Field | ContributingSourcesSequence | Contributing Sources Sequence.
public Field | ContributionDateTime | Contribution Date Time.
public Field | ContributionDescription | Contribution Description.
public Field | ControlPoint3dPosition | Control Point 3D Position.
public Field | ControlPointDeliverySequence | Control Point Delivery Sequence.
public Field | ControlPointIndex | Control Point Index.
public Field | ControlPointOrientation | Control Point Orientation.
public Field | ControlPointRelativePosition | Control Point Relative Position.
public Field | ControlPointSequence | Control Point Sequence.
public Field | ConventionalControlPointVerificationSequence | Conventional Control Point Verification Sequence.
public Field | ConventionalMachineVerificationSequence | Conventional Machine Verification Sequence.
public Field | ConversionType | Conversion Type.
public Field | ConvolutionKernel | Convolution Kernel.
public Field | ConvolutionKernelGroup | Convolution Kernel Group.
public Field | CoordinateGeometricType | Coordinate Geometric Type.
public Field | CoordinateStartValue | Coordinate Start Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoordinateStepValue | Coordinate Step Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CoordinateSystemAxisCodeSequence | Coordinate System Axis Code Sequence.
public Field | Copies | Copies. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CornealSize | Corneal Size.
public Field | CorrectedImage | Corrected Image.
public Field | CorrectedParameterSequence | Corrected Parameter Sequence.
public Field | CorrectionValue | Correction Value.
public Field | CountLossNormalizationCorrected | Count Loss Normalization Corrected.
public Field | CountRate | Count Rate.
public Field | CountryOfResidence | Country of Residence.
public Field | CountsAccumulated | Counts Accumulated.
public Field | CountsIncluded | Counts Included. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CountsSource | Counts Source.
public Field | CoverageOfKspace | Coverage of k-Space.
public Field | CranialThermalIndex | Cranial Thermal Index.
public Field | CreationDate | Creation Date.
public Field | CreationTime | Creation Time.
public Field | CreatorVersionUID | Creator Version UID.
public Field | CTAcquisitionDetailsSequence | CT Acquisition Details Sequence.
public Field | CTAcquisitionTypeSequence | CT Acquisition Type Sequence.
public Field | CTAdditionalXRaySourceSequence | CT Additional X-Ray Source Sequence.
public Field | CTDIPhantomTypeCodeSequence | CTDI Phantom Type Code Sequence.
public Field | CTDIvol | The CTDIvol.
public Field | CTExposureSequence | CT Exposure Sequence.
public Field | CTGeometrySequence | CT Geometry Sequence.
public Field | CTImageFrameTypeSequence | CT Image Frame Type Sequence.
public Field | CTPositionSequence | CT Position Sequence.
public Field | CTReconstructionSequence | CT Reconstruction Sequence.
public Field | CTTableDynamicsSequence | CT Table Dynamics Sequence.
public Field | CTXRayDetailsSequence | CT X-Ray Details Sequence.
public Field | CumulativeDoseReferenceCoefficient | Cumulative Dose Reference Coefficient.
public Field | CumulativeDoseToDoseReference | Cumulative Dose to Dose Reference.
public Field | CumulativeMetersetWeight | Cumulative Meterset Weight.
public Field | CumulativeTimeWeight | Cumulative Time Weight.
public Field | CurrentFractionNumber | Current Fraction Number.
public Field | CurrentPatientLocation | Current Patient Location.
public Field | CurrentRequestedProcedureEvidenceSequence | Current Requested Procedure Evidence Sequence.
public Field | CurrentTreatmentStatus | Current Treatment Status.
public Field | CurveActivationLayer | Curve Activation Layer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveData | Curve Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDataDescriptor | Curve Data Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDate | Curve Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDescription | Curve Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveDimensions | Curve Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveLabel | Curve Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveNumber | Curve Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveRange | Curve Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveReferencedOverlayGroup | Curve Referenced Overlay Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveReferencedOverlaySequence | Curve Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CurveTime | Curve Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | CustodialOrganizationSequence | Custodial Organization Sequence.
public Field | CylinderAxis | Cylinder Axis.
public Field | CylinderLensPower | Cylinder Lens Power.
public Field | CylinderPower | Cylinder Power.
public Field | CylinderSequence | Cylinder Sequence.
public Field | DataBlock | Data Block. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataBlockDescription | Data Block Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataCollectionCenterPatient | Data Collection Center (Patient).
public Field | DataCollectionDiameter | Data Collection Diameter.
public Field | DataElementsSigned | Data Elements Signed.
public Field | DataFrameAssignmentSequence | Data Frame Assignment Sequence.
public Field | DataInformationSequence | Data Information Sequence.
public Field | DataPathAssignment | Data Path Assignment.
public Field | DataPathID | Data Path ID.
public Field | DataPointColumns | Data Point Columns.
public Field | DataPointRows | Data Point Rows.
public Field | DataRepresentation | Data Representation.
public Field | DataSet | DICOM dataset.
public Field | DataSetSubtype | Data Set Subtype. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DataSetTrailingPadding | Data Set Trailing Padding.
public Field | DataSetType | Data Set Type.
public Field | DataStreamEncodingFragment | Data Stream Encoding Fragment.
public Field | DataType | Data Type.
public Field | DataValueRepresentation | Data Value Representation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Date | Date value.
public Field | DateOfLastCalibration | Date of Last Calibration.
public Field | DateOfLastDetectorCalibration | Date of Last Detector Calibration.
public Field | DateOfSecondaryCapture | Date of Secondary Capture.
public Field | DateTime | DateTime value.
public Field | DbDt | The dB/dt.
public Field | DCTLabel | DCT Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DeadTimeCorrected | Dead Time Corrected.
public Field | DeadTimeCorrectionFlag | Dead Time Correction Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DeadTimeFactor | Dead Time Factor.
public Field | DecayCorrected | Decay Corrected.
public Field | DecayCorrection | Decay Correction.
public Field | DecayCorrectionDateTime | Decay Correction DateTime.
public Field | DecayFactor | Decay Factor.
public Field | DecimalVisualAcuity | Decimal Visual Acuity.
public Field | DecimateCropResult | Decimate/Crop Result.
public Field | DecoupledNucleus | De-coupled Nucleus.
public Field | Decoupling | De-coupling value.
public Field | DecouplingChemicalShiftReference | De-coupling Chemical Shift Reference.
public Field | DecouplingFrequency | De-coupling Frequency.
public Field | DecouplingMethod | De-coupling Method.
public Field | DefaultMagnificationType | Default Magnification Type.
public Field | DefaultPrinterResolutionID | Default Printer Resolution ID.
public Field | DefaultSmoothingType | Default Smoothing Type.
public Field | DeformableRegistrationGridSequence | Deformable Registration Grid Sequence.
public Field | DeformableRegistrationSequence | Deformable Registration Sequence.
public Field | DegreeofDilation | Degree of Dilation.
public Field | DeidentificationMethod | De-identification Method.
public Field | DeidentificationMethodCodeSequence | De-identification Method Code Sequence.
public Field | DeletionLock | Deletion Lock.
public Field | DeliveredChannelTotalTime | Delivered Channel Total Time.
public Field | DeliveredMeterset | Delivered Meterset.
public Field | DeliveredNumberofPulses | Delivered Number of Pulses.
public Field | DeliveredPrimaryMeterset | Delivered Primary Meterset.
public Field | DeliveredPulseRepetitionInterval | Delivered Pulse Repetition Interval.
public Field | DeliveredSecondaryMeterset | Delivered Secondary Meterset.
public Field | DeliveredTreatmentTime | Delivered Treatment Time.
public Field | DeliveryMaximumDose | Delivery Maximum Dose.
public Field | DeliveryVerificationImageSequence | Delivery Verification Image Sequence.
public Field | DeliveryWarningDose | Delivery Warning Dose.
public Field | DepthOfScanField | Depth of Scan Field.
public Field | DepthOfTransverseImage | Depth of Transverse Image.
public Field | DepthsOfFocus | Depth(s) of Focus.
public Field | DepthSpatialResolution | Depth Spatial Resolution.
public Field | DerivationCodeSequence | Derivation Code Sequence.
public Field | DerivationDescription | Derivation Description.
public Field | DerivationImageSequence | Derivation Image Sequence.
public Field | DestinationAe | Destination AE. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DetailsOfCoefficients | Details of Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DetectorActivationOffsetFromExposure | Detector Activation Offset From Exposure.
public Field | DetectorActiveDimensions | Detector Active Dimension(s).
public Field | DetectorActiveOrigin | Detector Active Origin.
public Field | DetectorActiveShape | Detector Active Shape.
public Field | DetectorActiveTime | Detector Active Time.
public Field | DetectorBinning | Detector Binning.
public Field | DetectorConditionsNominalFlag | Detector Conditions Nominal Flag.
public Field | DetectorConfiguration | Detector Configuration.
public Field | DetectorDescription | Detector Description.
public Field | DetectorElementPhysicalSize | Detector Element Physical Size.
public Field | DetectorElementSize | Detector Element Size.
public Field | DetectorElementSpacing | Detector Element Spacing.
public Field | DetectorGeometry | Detector Geometry.
public Field | DetectorID | Detector ID.
public Field | DetectorInformationSequence | Detector Information Sequence.
public Field | DetectorLinesOfResponseUsed | Detector Lines of Response Used.
public Field | DetectorManufacturerName | Detector Manufacturer Name.
public Field | DetectorManufacturersModelName | Detector Manufacturers Model Name.
public Field | DetectorMode | Detector Mode.
public Field | DetectorNormalizationCorrection | Detector Normalization Correction.
public Field | DetectorPrimaryAngle | Detector Primary Angle.
public Field | DetectorSecondaryAngle | Detector Secondary Angle.
public Field | DetectorTemperature | Detector Temperature.
public Field | DetectorTimeSinceLastExposure | Detector Time Since Last Exposure.
public Field | DetectorType | Detector Type.
public Field | DetectorVector | Detector Vector.
public Field | DeviceDescription | Device Description.
public Field | DeviceDiameter | Device Diameter.
public Field | DeviceDiameterUnits | Device Diameter Units.
public Field | DeviceID | Device ID.
public Field | DeviceLength | Device Length.
public Field | DeviceSequence | Device Sequence.
public Field | DeviceSerialNumber | Device Serial Number.
public Field | DeviceUID | Device UID.
public Field | DeviceVolume | Device Volume.
public Field | DIALOGReceiver | DIALOG Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DiaphragmPosition | Diaphragm Position.
public Field | DifferentialWaveformSourceModifiers | Differential Waveform Source Modifiers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DiffusionAnisotropyType | Diffusion Anisotropy Type.
public Field | DiffusionBMatrixSequence | Diffusion b-matrix Sequence.
public Field | DiffusionBvalue | Diffusion b-value.
public Field | DiffusionBValueXX | Diffusion b-value XX.
public Field | DiffusionBValueXY | Diffusion b-value XY.
public Field | DiffusionBValueXZ | Diffusion b-value XZ.
public Field | DiffusionBValueYY | Diffusion b-value YY.
public Field | DiffusionBValueYZ | Diffusion b-value YZ.
public Field | DiffusionBValueZZ | Diffusion b-value ZZ.
public Field | DiffusionDirectionality | Diffusion Directionality.
public Field | DiffusionGradientDirectionSequence | Diffusion Gradient Direction Sequence.
public Field | DiffusionGradientOrientation | Diffusion Gradient Orientation.
public Field | DigitalImageFormatAcquired | Digital Image Format Acquired.
public Field | DigitalSignatureDateTime | Digital Signature DateTime.
public Field | DigitalSignaturePurposeCodeSequence | Digital Signature Purpose Code Sequence.
public Field | DigitalSignaturesSequence | Digital Signatures Sequence.
public Field | DigitalSignatureUID | Digital Signature UID.
public Field | DigitizingDeviceTransportDirection | Digitizing Device Transport Direction.
public Field | DimensionDescriptionLabel | Dimension Description Label.
public Field | DimensionIndexPointer | Dimension Index Pointer.
public Field | DimensionIndexPrivateCreator | Dimension Index Private Creator.
public Field | DimensionIndexSequence | Dimension Index Sequence.
public Field | DimensionIndexValues | Dimension Index Values.
public Field | DimensionOrganizationSequence | Dimension Organization Sequence.
public Field | DimensionOrganizationType | Dimension Organization Type.
public Field | DimensionOrganizationUID | Dimension Organization UID.
public Field | DirectoryRecordSequence | Directory Record Sequence.
public Field | DirectoryRecordType | Directory Record Type.
public Field | DischargeDate | Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeDiagnosisCodeSequence | Discharge Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeDiagnosisDescription | Discharge Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DischargeTime | Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayedAreaBottomRightHandCorner | Displayed Area Bottom Right Hand Corner.
public Field | DisplayedAreaBottomRightHandCornerTrial | Displayed Area Bottom Right Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayedAreaSelectionSequence | Displayed Area Selection Sequence.
public Field | DisplayedAreaTopLeftHandCorner | Displayed Area Top Left Hand Corner.
public Field | DisplayedAreaTopLeftHandCornerTrial | Displayed Area Top Left Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplayEnvironmentSpatialPosition | Display Environment Spatial Position.
public Field | DisplayFilterPercentage | Display Filter Percentage.
public Field | DisplayFormat | Display Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DisplaySetHorizontalJustification | Display Set Horizontal Justification.
public Field | DisplaySetLabel | Display Set Label.
public Field | DisplaySetNumber | Display Set Number.
public Field | DisplaySetPatientOrientation | Display Set Patient Orientation.
public Field | DisplaySetPresentationGroup | Display Set Presentation Group.
public Field | DisplaySetPresentationGroupDescription | Display Set Presentation Group Description.
public Field | DisplaySetScrollingGroup | Display Set Scrolling Group.
public Field | DisplaySetsSequence | Display Sets Sequence.
public Field | DisplaySetVerticalJustification | Display Set Vertical Justification.
public Field | DisplayShadingFlag | Display Shading Flag.
public Field | DisplayWindowLabelVector | Display Window Label Vector.
public Field | DistanceObjecttoTableTop | Distance Object to Table Top.
public Field | DistancePupillaryDistance | Distance Pupillary Distance.
public Field | DistanceReceptorPlanetoDetectorHousing | Distance Receptor Plane to Detector Housing.
public Field | DistanceSourcetoDataCollectionCenter | Distance Source to Data Collection Center.
public Field | DistanceSourceToDetector | Distance Source to Detector.
public Field | DistanceSourceToEntrance | Distance Source to Entrance.
public Field | DistanceSourcetoIsocenter | Distance Source to Isocenter.
public Field | DistanceSourceToPatient | Distance Source to Patient.
public Field | DistanceSourcetoSupport | Distance Source to Support. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionAddress | Distribution Address. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionName | Distribution Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DistributionType | Distribution Type.
public Field | DocumentTitle | Document Title.
public Field | DopplerCorrectionAngle | Doppler Correction Angle.
public Field | DopplerSampleVolumeXPosition | Doppler Sample Volume X Position.
public Field | DopplerSampleVolumeXPositionRetired | Doppler Sample Volume X Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DopplerSampleVolumeYPosition | Doppler Sample Volume Y Position.
public Field | DopplerSampleVolumeYPositionRetired | Doppler Sample Volume Y Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | DoseCalibrationFactor | Dose Calibration Factor.
public Field | DoseComment | Dose Comment.
public Field | DoseGridScaling | Dose Grid Scaling.
public Field | DoseRateDelivered | Dose Rate Delivered.
public Field | DoseRateSet | Dose Rate Set.
public Field | DoseReferenceDescription | Dose Reference Description.
public Field | DoseReferenceNumber | Dose Reference Number.
public Field | DoseReferencePointCoordinates | Dose Reference Point Coordinates.
public Field | DoseReferenceSequence | Dose Reference Sequence.
public Field | DoseReferenceStructureType | Dose Reference Structure Type.
public Field | DoseReferenceType | Dose Reference Type.
public Field | DoseReferenceUID | Dose Reference UID.
public Field | DoseSummationType | Dose Summation Type.
public Field | DoseType | Dose Type.
public Field | DoseUnits | Dose Units.
public Field | DoseValue | Dose Value.
public Field | DoubleExposureFieldDelta | Double Exposure Field Delta.
public Field | DoubleExposureFlag | Double Exposure Flag.
public Field | DoubleExposureMeterset | Double Exposure Meterset.
public Field | DoubleExposureOrdering | Double Exposure Ordering.
public Field | DvhData | The DVH Data.
public Field | DvhDoseScaling | DVH Dose Scaling.
public Field | DvhMaximumDose | DVH Maximum Dose.
public Field | DvhMeanDose | DVH Mean Dose.
public Field | DvhMinimumDose | DVH Minimum Dose.
public Field | DvhNormalizationDoseValue | DVH Normalization Dose Value.
public Field | DvhNormalizationPoint | DVH Normalization Point.
public Field | DvhNumberOfBins | DVH Number of Bins.
public Field | DvhReferencedRoiSequence | DVH Referenced ROI Sequence.
public Field | DvhRoiContributionType | DVH ROI Contribution Type.
public Field | DvhSequence | DVH Sequence.
public Field | DvhType | DVH (Dose-volume histogram) Type.
public Field | DvhVolumeUnits | DVH Volume Units.
public Field | DynamicRange | Dynamic Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EchoNumbers | Echo Number(s).
public Field | EchoPlanarPulseSequence | Echo Planar Pulse Sequence.
public Field | EchoPulseSequence | Echo Pulse Sequence.
public Field | EchoTime | Echo Time.
public Field | EchoTrainLength | Echo Train Length.
public Field | EdgePointIndexList | Edge Point Index List.
public Field | EffectiveDuration | Effective Duration.
public Field | EffectiveEchoTime | Effective Echo Time.
public Field | EmmetropicMagnification | Emmetropic Magnification.
public Field | EmptyImageBoxCIELabValue | Empty Image Box CIELab Value.
public Field | EmptyImageDensity | Empty Image Density.
public Field | EncapsulatedDocument | Encapsulated Document.
public Field | EncryptedAttributesSequence | Encrypted Attributes Sequence.
public Field | EncryptedContent | Encrypted Content.
public Field | EncryptedContentTransferSyntaxUID | Encrypted Content Transfer Syntax UID.
public Field | EndAcquisitionDateTime | End Acquisition DateTime.
public Field | EndCumulativeMetersetWeight | End Cumulative Meterset Weight.
public Field | EndingRespiratoryAmplitude | Ending Respiratory Amplitude.
public Field | EndingRespiratoryPhase | Ending Respiratory Phase.
public Field | EndMessageID | End Message ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EndMeterset | End Meterset.
public Field | EnergyWeightingFactor | Energy Weighting Factor.
public Field | EnergyWindowCenterline | Energy Window Centerline. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EnergyWindowInformationSequence | Energy Window Information Sequence.
public Field | EnergyWindowLowerLimit | Energy Window Lower Limit.
public Field | EnergyWindowName | Energy Window Name.
public Field | EnergyWindowNumber | Energy Window Number.
public Field | EnergyWindowRangeSequence | Energy Window Range Sequence.
public Field | EnergyWindowTotalWidth | Energy Window Total Width. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EnergyWindowUpperLimit | Energy Window Upper Limit.
public Field | EnergyWindowVector | Energy Window Vector.
public Field | EnhancedPaletteColorLookupTableSequence | Enhanced Palette Color Lookup Table Sequence.
public Field | EntranceDose | Entrance Dose.
public Field | EntranceDoseInmGy | Entrance Dose in mGy.
public Field | EquipmentCoordinateSystemIdentification | Equipment Coordinate System Identification.
public Field | EquivalentCDADocumentSequence | Equivalent CDA Document Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Erase | Erase. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ErrorComment | Error Comment.
public Field | ErrorID | Error Identifier.
public Field | EscapeTriplet | Escape Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | EstimatedDoseSaving | Estimated Dose Saving.
public Field | EstimatedRadiographicMagnificationFactor | Estimated Radiographic Magnification Factor.
public Field | EthnicGroup | Ethnic Group.
public Field | EventCodeSequence | Event Code Sequence.
public Field | EventElapsedTimes | Event Elapsed Time(s).
public Field | EventTimeOffset | Event Time Offset.
public Field | EventTimerNames | Event Timer Name(s).
public Field | EventTimerSequence | Event Timer Sequence.
public Field | EventTypeID | Event Type ID.
public Field | ExaminedBodyThickness | Examined Body Thickness.
public Field | ExcludedIntervalsSequence | Excluded Intervals Sequence.
public Field | ExclusionDuration | Exclusion Duration.
public Field | ExclusionStartDatetime | Exclusion Start Datetime.
public Field | ExecutionStatus | Execution Status.
public Field | ExecutionStatusInfo | Execution Status Info.
public Field | ExpectedCompletionDateTime | Expected Completion Date Time.
public Field | ExposedArea | Exposed Area.
public Field | Exposure | Exposure value.
public Field | ExposureControlMode | Exposure Control Mode.
public Field | ExposureControlModeDescription | Exposure Control Mode Description.
public Field | ExposureControlSensingRegionLeftVerticalEdge | Exposure Control Sensing Region Left Vertical Edge.
public Field | ExposureControlSensingRegionLowerHorizontalEdge | Exposure Control Sensing Region Lower Horizontal Edge.
public Field | ExposureControlSensingRegionRightVerticalEdge | Exposure Control Sensing Region Right Vertical Edge.
public Field | ExposureControlSensingRegionShape | Exposure Control Sensing Region Shape.
public Field | ExposureControlSensingRegionsSequence | Exposure Control Sensing Regions Sequence.
public Field | ExposureControlSensingRegionUpperHorizontalEdge | Exposure Control Sensing Region Upper Horizontal Edge.
public Field | ExposureDoseSequence | Exposure Dose Sequence.
public Field | ExposureinmAs | Exposure in mAs.
public Field | ExposureInMicroAs | Exposure in micro As.
public Field | ExposureModulationType | Exposure Modulation Type.
public Field | ExposureSequence | Exposure Sequence.
public Field | ExposuresOnDetectorSinceLastCalibration | Exposures on Detector Since Last Calibration.
public Field | ExposuresOnDetectorSinceManufactured | Exposures on Detector Since Manufactured.
public Field | ExposuresOnPlate | Exposures on Plate.
public Field | ExposureStatus | Exposure Status.
public Field | ExposureTime | Exposure Time.
public Field | ExposureTimeinms | Exposure Time in ms.
public Field | ExposureTimeInuS | Exposure Time in micro S.
public Field | FacetSequence | Facet Sequence.
public Field | FailedAttributesSequence | Failed Attributes Sequence.
public Field | FailedSOPInstanceUIDList | Failed SOP Instance UID List.
public Field | FailedSOPSequence | Failed SOP Sequence.
public Field | FailureAttributes | Failure Attributes.
public Field | FailureReason | Failure Reason.
public Field | FiducialDescription | Fiducial Description.
public Field | FiducialIdentifier | Fiducial Identifier.
public Field | FiducialIdentifierCodeSequence | Fiducial Identifier Code Sequence.
public Field | FiducialSequence | Fiducial Sequence.
public Field | FiducialSetSequence | Fiducial Set Sequence.
public Field | FiducialUID | Fiducial UID.
public Field | FieldofViewDescription | Field of View Description.
public Field | FieldOfViewDimensions | Field of View Dimension(s).
public Field | FieldofViewDimensionsInFloat | Field of View Dimension(s) in Float.
public Field | FieldOfViewHorizontalFlip | Field of View Horizontal Flip.
public Field | FieldOfViewOrigin | Field of View Origin.
public Field | FieldOfViewRotation | Field of View Rotation.
public Field | FieldofViewSequence | Field of View Sequence.
public Field | FieldOfViewShape | Field of View Shape.
public Field | FileMetaInformationGroupLength | File Meta Information Group Length.
public Field | FileMetaInformationVersion | File Meta Information Version.
public Field | FilesetConsistencyFlag | File-set Consistency Flag.
public Field | FilesetDescriptorFileID | File-set Descriptor File ID.
public Field | FilesetID | File-set ID.
public Field | FillerOrderNumberImagingServiceRequest | Filler Order Number / Imaging Service Request.
public Field | FillerOrderNumberImagingServiceRequestRetired | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FillerOrderNumberProcedure | Filler Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FilmBoxContentSequence | Film Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FilmConsumptionSequence | Film Consumption Sequence.
public Field | FilmDestination | Film Destination.
public Field | FilmOrientation | Film Orientation.
public Field | FilmSessionLabel | Film Session Label.
public Field | FilmSizeID | Film Size ID.
public Field | FilterBeamPathLengthMaximum | Filter Beam Path Length Maximum.
public Field | FilterBeamPathLengthMinimum | Filter Beam Path Length Minimum.
public Field | FilterbyAttributePresence | Filter-by Attribute Presence.
public Field | FilterbyCategory | Filter-by Category.
public Field | FilterbyOperator | Filter-by Operator.
public Field | FilterHighFrequency | Filter High Frequency.
public Field | FilterLowFrequency | Filter Low Frequency.
public Field | FilterMaterial | Filter Material.
public Field | FilterOperationsSequence | Filter Operations Sequence.
public Field | FilterThicknessMaximum | Filter Thickness Maximum.
public Field | FilterThicknessMinimum | Filter Thickness Minimum.
public Field | FilterType | Filter Type.
public Field | FinalCumulativeMetersetWeight | Final Cumulative Meterset Weight.
public Field | FinalCumulativeTimeWeight | Final Cumulative Time Weight.
public Field | FindLocation | Find Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | FiniteVolume | Finite Volume.
public Field | FirstOrderPhaseCorrection | First Order Phase Correction.
public Field | FirstOrderPhaseCorrectionAngle | First Order Phase Correction Angle.
public Field | FirstTreatmentDate | First Treatment Date.
public Field | FixationDeviceDescription | Fixation Device Description.
public Field | FixationDeviceLabel | Fixation Device Label.
public Field | FixationDevicePitchAngle | Fixation Device Pitch Angle.
public Field | FixationDevicePosition | Fixation Device Position.
public Field | FixationDeviceRollAngle | Fixation Device Roll Angle.
public Field | FixationDeviceSequence | Fixation Device Sequence.
public Field | FixationDeviceType | Fixation Device Type.
public Field | FixationLightAzimuthalAngle | Fixation Light Azimuthal Angle.
public Field | FixationLightPolarAngle | Fixation Light Polar Angle.
public Field | FlatKeratometricAxisSequence | Flat Keratometric Axis Sequence.
public Field | FlipAngle | Flip Angle.
public Field | FlowCompensation | Flow Compensation.
public Field | FlowCompensationDirection | Flow Compensation Direction.
public Field | FluenceDataScale | Fluence Data Scale.
public Field | FluenceDataSource | Fluence Data Source.
public Field | FluenceMapSequence | Fluence Map Sequence.
public Field | FluenceMode | Fluence Mode.
public Field | FluenceModeID | Fluence Mode ID.
public Field | FluoroscopyFlag | Fluoroscopy Flag.
public Field | FocalDistance | Focal Distance.
public Field | FocalSpots | Focal Spot(s).
public Field | FocusDepth | Focus Depth.
public Field | FORMAT | DICOM format marker.
public Field | FractionalChannelDisplayScale | Fractional Channel Display Scale.
public Field | FractionGroupDescription | Fraction Group Description.
public Field | FractionGroupNumber | Fraction Group Number.
public Field | FractionGroupSequence | Fraction Group Sequence.
public Field | FractionGroupSummarySequence | Fraction Group Summary Sequence.
public Field | FractionGroupType | Fraction Group Type.
public Field | FractionNumber | Fraction Number.
public Field | FractionPattern | Fraction Pattern.
public Field | FractionStatusSummarySequence | Fraction Status Summary Sequence.
public Field | FrameAcquisitionDateTime | Frame Acquisition DateTime.
public Field | FrameAcquisitionDuration | Frame Acquisition Duration.
public Field | FrameAcquisitionNumber | Frame Acquisition Number.
public Field | FrameAcquisitionSequence | Frame Acquisition Sequence.
public Field | FrameAnatomySequence | Frame Anatomy Sequence.
public Field | FrameComments | Frame Comments.
public Field | FrameContentSequence | Frame Content Sequence.
public Field | FrameDelay | Frame Delay.
public Field | FrameDetectorParametersSequence | Frame Detector Parameters Sequence.
public Field | FrameDimensionPointer | Frame Dimension Pointer.
public Field | FrameDisplaySequence | Frame Display Sequence.
public Field | FrameDisplayShutterSequence | Frame Display Shutter Sequence.
public Field | FrameExtractionSequence | Frame Extraction Sequence.
public Field | FrameIncrementPointer | Frame Increment Pointer.
public Field | FrameLabel | Frame Label.
public Field | FrameLabelVector | Frame Label Vector.
public Field | FrameLaterality | Frame Laterality.
public Field | FrameNumbersOfInterest | Frame Numbers of Interest (FOI).
public Field | FrameOfInterestDescription | Frame of Interest Description.
public Field | FrameofInterestType | Frame of Interest Type.
public Field | FrameOfReferenceRelationshipSequence | Frame of Reference Relationship Sequence.
public Field | FrameOfReferenceTransformationComment | Frame of Reference Transformation Comment.
public Field | FrameOfReferenceTransformationMatrix | Frame of Reference Transformation Matrix.
public Field | FrameofReferenceTransformationMatrixType | Frame of Reference Transformation Matrix Type.
public Field | FrameOfReferenceTransformationType | Frame of Reference Transformation Type.
public Field | FrameOfReferenceUID | Frame of Reference UID.
public Field | FramePixelDataPropertiesSequence | Frame Pixel Data Properties Sequence.
public Field | FramePixelShiftSequence | Frame Pixel Shift Sequence.
public Field | FramePrimaryAngleVector | Frame Primary Angle Vector.
public Field | FrameReferenceDateTime | Frame Reference DateTime.
public Field | FrameReferenceTime | Frame Reference Time.
public Field | FrameSecondaryAngleVector | Frame Secondary Angle Vector.
public Field | FrameTime | Frame Time.
public Field | FrameTimeVector | Frame Time Vector.
public Field | FrameType | Frame Type.
public Field | FrameVoiLutSequence | Frame VOI LUT Sequence.
public Field | FrequencyCorrection | Frequency Correction.
public Field | FunctionalGroupPointer | Functional Group Pointer.
public Field | FunctionalGroupPrivateCreator | Functional Group Private Creator.
public Field | GantryAngle | Gantry Angle.
public Field | GantryAngleTolerance | Gantry Angle Tolerance.
public Field | GantryDetectorSlew | Gantry/Detector Slew.
public Field | GantryDetectorTilt | Gantry/Detector Tilt.
public Field | GantryID | Gantry ID.
public Field | GantryMotionCorrected | Gantry Motion Corrected.
public Field | GantryPitchAngle | Gantry Pitch Angle.
public Field | GantryPitchAngleTolerance | Gantry Pitch Angle Tolerance.
public Field | GantryPitchRotationDirection | Gantry Pitch Rotation Direction.
public Field | GantryRotationDirection | Gantry Rotation Direction.
public Field | GatedInformationSequence | Gated Information Sequence.
public Field | GeneralAccessoryDescription | General Accessory Description.
public Field | GeneralAccessoryID | General Accessory ID.
public Field | GeneralAccessoryNumber | General Accessory Number.
public Field | GeneralAccessorySequence | General Accessory Sequence.
public Field | GeneralAccessoryType | General Accessory Type.
public Field | GeneralMachineVerificationSequence | General Machine Verification Sequence.
public Field | GeneralPurposePerformedProcedureStepStatus | General Purpose Performed Procedure Step Status.
public Field | GeneralPurposeScheduledProcedureStepPriority | General Purpose Scheduled Procedure Step Priority.
public Field | GeneralPurposeScheduledProcedureStepStatus | General Purpose Scheduled Procedure Step Status.
public Field | GeneratorID | Generator ID.
public Field | GeneratorPower | Generator Power.
public Field | GeometricalProperties | Geometrical Properties.
public Field | GeometricMaximumDistortion | Geometric Maximum Distortion.
public Field | GeometryOfKspaceTraversal | Geometry of k-Space Traversal.
public Field | GradientEchoTrainLength | Gradient Echo Train Length.
public Field | GradientOutput | Gradient Output.
public Field | GradientOutputType | Gradient Output Type.
public Field | GraphicAnnotationSequence | Graphic Annotation Sequence.
public Field | GraphicAnnotationUnits | Graphic Annotation Units.
public Field | GraphicCoordinatesDataSequence | Graphic Coordinates Data Sequence.
public Field | GraphicData | Graphic Data.
public Field | GraphicDimensions | Graphic Dimensions.
public Field | GraphicFilled | Graphic Filled.
public Field | GraphicLayer | Graphic Layer.
public Field | GraphicLayerDescription | Graphic Layer Description.
public Field | GraphicLayerOrder | Graphic Layer Order.
public Field | GraphicLayerRecommendedDisplayCIELabValue | Graphic Layer Recommended Display CIELab Value.
public Field | GraphicLayerRecommendedDisplayGrayscaleValue | Graphic Layer Recommended Display Grayscale Value.
public Field | GraphicLayerRecommendedDisplayRGBValue | Graphic Layer Recommended Display RGB Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GraphicLayerSequence | Graphic Layer Sequence.
public Field | GraphicObjectSequence | Graphic Object Sequence.
public Field | GraphicType | Graphic Type.
public Field | GrayLookupTableData | Gray Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GrayLookupTableDescriptor | Gray Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GrayScale | Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | GreenPaletteColorLookupTableData | Green Palette Color Lookup Table Data.
public Field | GreenPaletteColorLookupTableDescriptor | Green Palette Color Lookup Table Descriptor.
public Field | Grid | Grid value.
public Field | GridAbsorbingMaterial | Grid Absorbing Material.
public Field | GridAspectRatio | Grid Aspect Ratio.
public Field | GridDimensions | Grid Dimensions.
public Field | GridFocalDistance | Grid Focal Distance.
public Field | GridFrameOffsetVector | Grid Frame Offset Vector.
public Field | GridID | Grid Identifier.
public Field | GridPeriod | Grid Period.
public Field | GridPitch | Grid Pitch.
public Field | GridResolution | Grid Resolution.
public Field | GridSpacingMaterial | Grid Spacing Material.
public Field | GridThickness | Grid Thickness.
public Field | Group0000LengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0004Length | Group 0004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0008Length | Group 0008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0008LengthToEnd | Group 0008 Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0010Length | Group 0010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0012Length | Group 0012 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0018Length | Group 0018 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0020Length | Group 0020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0022Length | Group 0022 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0028Length | Group 0028 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0032Length | Group 0032 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0038Length | Group 0038 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group003ALength | Group 003A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0040Length | Group 0040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0042Length | Group 0042 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0044Length | Group 0044 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0046Length | Group 0046 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0050Length | Group 0050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0054Length | Group 0054 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0060Length | Group 0060 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0062Length | Group 0062 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0064Length | Group 0064 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0066Length | Group 0066 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0070Length | Group 0070 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0072Length | Group 0072 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0074Length | Group 0074 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0088Length | Group 0088 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0100Length | Group 0100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group0400Length | Group 0400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group1000Length | Group 1000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group1010Length | Group 1010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2000Length | Group 2000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2010Length | Group 2010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2020Length | Group 2020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2030Length | Group 2030 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2040Length | Group 2040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2050Length | Group 2050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2100Length | Group 2100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2110Length | Group 2110 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2120Length | Group 2120 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2130Length | Group 2130 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group2200Length | Group 2200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3002Length | Group 3002 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3004Length | Group 3004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3006Length | Group 3006 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group3008Length | Group 3008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300ALength | Group 300A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300CLength | Group 300C Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group300ELength | Group 300E Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4000Length | Group 4000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4008Length | Group 4008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group4FFELength | Group 4FFE Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group50xxLength | Group 50xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5200Length | Group 5200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5400Length | Group 5400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group5600Length | Group 5600 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group60xxLength | Group 60xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group7FE0Length | Group 7FE0 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Group7FFFLength | Group 7FFF Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HalfValueLayer | Half Value Layer.
public Field | HangingProtocolCreationDateTime | Hanging Protocol Creation DateTime.
public Field | HangingProtocolCreator | Hanging Protocol Creator.
public Field | HangingProtocolDefinitionSequence | Hanging Protocol Definition Sequence.
public Field | HangingProtocolDescription | Hanging Protocol Description.
public Field | HangingProtocolLevel | Hanging Protocol Level.
public Field | HangingProtocolName | Hanging Protocol Name.
public Field | HangingProtocolUserGroupName | Hanging Protocol User Group Name.
public Field | HangingProtocolUserIdentificationCodeSequence | Hanging Protocol User Identification Code Sequence.
public Field | HardcopyCreationDeviceID | Hardcopy Creation Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceManufacturer | Hardcopy Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceManufacturersModelName | Hardcopy Device Manufacturer's Model Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HardcopyDeviceSoftwareVersion | Hardcopy Device Software Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HeadFixationAngle | Head Fixation Angle.
public Field | HeartRate | Heart Rate.
public Field | HighBit | Image High Bit.
public Field | HighDoseTechniqueType | High-Dose Technique Type.
public Field | HighRrValue | High R-R Value.
public Field | HistogramBinWidth | Histogram Bin Width.
public Field | HistogramData | Histogram Data.
public Field | HistogramExplanation | Histogram Explanation.
public Field | HistogramFirstBinValue | Histogram First Bin Value.
public Field | HistogramLastBinValue | Histogram Last Bin Value.
public Field | HistogramNumberOfBins | Histogram Number of Bins.
public Field | HistogramSequence | Histogram Sequence.
public Field | HL7DocumentEffectiveTime | HL7 Document Effective Time.
public Field | HL7DocumentTypeCodeSequence | HL7 Document Type Code Sequence.
public Field | HL7InstanceIdentifier | HL7 Instance Identifier.
public Field | HL7StructuredDocumentReferenceSequence | HL7 Structured Document Reference Sequence.
public Field | HorizontalFieldofView | Horizontal Field of View.
public Field | HorizontalPrismBase | Horizontal Prism Base.
public Field | HorizontalPrismPower | Horizontal Prism Power.
public Field | HuffmanTableSize | Huffman Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HuffmanTableTriplet | Huffman Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | HumanPerformerCodeSequence | Human Performer Code Sequence.
public Field | HumanPerformerName | Human Performer's Name.
public Field | HumanPerformerOrganization | Human Performer's Organization.
public Field | ICCProfile | ICC Profile.
public Field | IconImageSequence | Icon Image Sequence.
public Field | IdenticalDocumentsSequence | Identical Documents Sequence.
public Field | IdentifierTypeCode | Identifier Type Code.
public Field | IdentifyingComments | Identifying Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Illumination | Illumination value.
public Field | IlluminationBandwidth | Illumination Bandwidth.
public Field | IlluminationPower | Illumination Power.
public Field | IlluminationTypeCodeSequence | Illumination Type Code Sequence.
public Field | IlluminationWaveLength | Illumination Wave Length.
public Field | ImageAndFluoroscopyAreaDoseProduct | Image and Fluoroscopy Area Dose Product.
public Field | ImageBoxContentSequence | Image Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageBoxesSequence | Image Boxes Sequence.
public Field | ImageBoxLargeScrollAmount | Image Box Large Scroll Amount.
public Field | ImageBoxLargeScrollType | Image Box Large Scroll Type.
public Field | ImageBoxLayoutType | Image Box Layout Type.
public Field | ImageBoxNumber | Image Box Number.
public Field | ImageBoxOverlapPriority | Image Box Overlap Priority.
public Field | ImageBoxPosition | Image Box Position.
public Field | ImageBoxPresentationLUTFlag | Image Box Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageBoxScrollDirection | Image Box Scroll Direction.
public Field | ImageBoxSmallScrollAmount | Image Box Small Scroll Amount.
public Field | ImageBoxSmallScrollType | Image Box Small Scroll Type.
public Field | ImageBoxSynchronizationSequence | Image Box Synchronization Sequence.
public Field | ImageBoxTileHorizontalDimension | Image Box Tile Horizontal Dimension.
public Field | ImageBoxTileVerticalDimension | Image Box Tile Vertical Dimension.
public Field | ImageCenterPointCoordinatesSequence | Image Center Point Coordinates Sequence.
public Field | ImageComments | Image Comments.
public Field | ImageDataLocation | Image Data Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageDataTypeSequence | Image Data Type Sequence.
public Field | ImageDimensions | Image Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageDisplayFormat | Image Display Format.
public Field | ImagedNucleus | Imaged Nucleus.
public Field | ImageFilter | Image Filter.
public Field | ImageFormat | Image Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageFrameOrigin | Image Frame Origin.
public Field | ImageGeometryType | Image Geometry Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageHorizontalFlip | Image Horizontal Flip.
public Field | ImageID | Image Identifier.
public Field | ImageIndex | Image Index.
public Field | ImageLaterality | Image Laterality.
public Field | ImageLocation | Image Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOrientation | Image Orientation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOrientationPatient | Image Orientation (Patient).
public Field | ImageOrientationVolume | Image Orientation (Volume).
public Field | ImageOverlayBoxContentSequence | Image Overlay Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageOverlayFlag | Image Overlay Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagePathFilterPassBand | Image Path Filter Pass Band.
public Field | ImagePathFilterPassThroughWavelength | Image Path Filter Pass-Through Wavelength.
public Field | ImagePathFilterTypeStackCodeSequence | Image Path Filter Type Stack Code Sequence.
public Field | ImagePlanePixelSpacing | Image Plane Pixel Spacing.
public Field | ImagePosition | Image Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagePositionPatient | Image Position (Patient).
public Field | ImagePositionVolume | Image Position (Volume).
public Field | ImagePresentationComments | Image Presentation Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageProcessingApplied | Image Processing Applied.
public Field | ImageRotation | Image Rotation.
public Field | ImageRotationRetired | Image Rotation (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagerPixelSpacing | Imager Pixel Spacing.
public Field | ImageSetLabel | Image Set Label.
public Field | ImageSetNumber | Image Set Number.
public Field | ImageSetSelectorCategory | Image Set Selector Category.
public Field | ImageSetSelectorSequence | Image Set Selector Sequence.
public Field | ImageSetSelectorUsageFlag | Image Set Selector Usage Flag.
public Field | ImageSetsSequence | Image Sets Sequence.
public Field | ImagesInAcquisition | Images in Acquisition.
public Field | ImagesInSeries | Images in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagesInStudy | Images in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageToEquipmentMappingMatrix | Image to Equipment Mapping Matrix.
public Field | ImageTransformationMatrix | Image Transformation Matrix. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageTranslationVector | Image Translation Vector. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImageTriggerDelay | Image Trigger Delay.
public Field | ImageType | Image Type.
public Field | ImagingDeviceSpecificAcquisitionParameters | Imaging Device-Specific Acquisition Parameters.
public Field | ImagingFrequency | Imaging Frequency.
public Field | ImagingServiceRequestComments | Imaging Service Request Comments.
public Field | ImagingServiceRequestFillerOrderNum | Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImagingServiceRequestPlacerOrderNum | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ImplementationClassUID | Implementation Class UID.
public Field | ImplementationVersionName | Implementation Version Name.
public Field | Impressions | Impressions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IncludeDisplayApplication | Include Display Application.
public Field | IncludeNonDICOMObjects | Include Non-DICOM Objects.
public Field | InConcatenationNumber | In-concatenation Number.
public Field | InConcatenationTotalNumber | In-concatenation Total Number.
public Field | InitialCineRunState | Initial Cine Run State.
public Field | InPlanePhaseEncodingDirection | In-plane Phase Encoding Direction.
public Field | InputAvailabilityFlag | Input Availability Flag.
public Field | InputInformationSequence | Input Information Sequence.
public Field | InStackPositionNumber | In-Stack Position Number.
public Field | InstanceAvailability | Instance Availability.
public Field | InstanceCreationDate | Instance Creation Date.
public Field | InstanceCreationTime | Instance Creation Time.
public Field | InstanceCreatorUID | Instance Creator UID.
public Field | InstanceNumber | Instance Number.
public Field | InstitutionAddress | Institution Address.
public Field | InstitutionalDepartmentName | Institutional Department Name.
public Field | InstitutionCodeSequence | Institution Code Sequence.
public Field | InstitutionName | Institution Name.
public Field | InsurancePlanIdentification | Insurance Plan Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntendedRecipientsOfResultsIdentificationSequence | Intended Recipients of Results Identification Sequence.
public Field | IntensifierActiveDimensions | Intensifier Active Dimension(s).
public Field | IntensifierActiveShape | Intensifier Active Shape.
public Field | IntensifierSize | Intensifier Size.
public Field | InterMarkerDistance | Inter-Marker Distance.
public Field | IntermediatePupillaryDistance | Intermediate Pupillary Distance.
public Field | InterpretationApprovalDate | Interpretation Approval Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationApprovalTime | Interpretation Approval Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationApproverSequence | Interpretation Approver Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationAuthor | Interpretation Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationDiagnosisCodeSequence | Interpretation Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationDiagnosisDescription | Interpretation Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationID | Interpretation ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationIDIssuer | Interpretation ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecordedDate | Interpretation Recorded Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecordedTime | Interpretation Recorded Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationRecorder | Interpretation Recorder. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationStatusID | Interpretation Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationText | Interpretation Text. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriber | Interpretation Transcriber. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriptionDate | Interpretation Transcription Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTranscriptionTime | Interpretation Transcription Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | InterpretationTypeID | Interpretation Type ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntervalNumber | Interval Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IntervalsAcquired | Intervals Acquired.
public Field | IntervalsRejected | Intervals Rejected.
public Field | InterventionDescription | Intervention Description.
public Field | InterventionDrugCodeSequence | Intervention Drug Code Sequence.
public Field | InterventionDrugDose | Intervention Drug Dose.
public Field | InterventionDrugInformationSequence | Intervention Drug Information Sequence.
public Field | InterventionDrugName | Intervention Drug Name.
public Field | InterventionDrugStartTime | Intervention Drug Start Time.
public Field | InterventionDrugStopTime | Intervention Drug Stop Time.
public Field | InterventionSequence | Intervention Sequence.
public Field | InterventionStatus | Intervention Status.
public Field | IntraOcularPressure | Intra Ocular Pressure.
public Field | InversionRecovery | Inversion Recovery.
public Field | InversionTime | Inversion Time.
public Field | InversionTimes | Inversion Times.
public Field | IonBeamLimitingDeviceSequence | Ion Beam Limiting Device Sequence.
public Field | IonBeamSequence | Ion Beam Sequence.
public Field | IonBlockSequence | Ion Block Sequence.
public Field | IonControlPointDeliverySequence | Ion Control Point Delivery Sequence.
public Field | IonControlPointSequence | Ion Control Point Sequence.
public Field | IonControlPointVerificationSequence | Ion Control Point Verification Sequence.
public Field | IonMachineVerificationSequence | Ion Machine Verification Sequence.
public Field | IonRangeCompensatorSequence | Ion Range Compensator Sequence.
public Field | IonToleranceTableSequence | Ion Tolerance Table Sequence.
public Field | IonWedgePositionSequence | Ion Wedge Position Sequence.
public Field | IonWedgeSequence | Ion Wedge Sequence.
public Field | IrradiationEventIdentificationSequence | Irradiation Event Identification Sequence.
public Field | IrradiationEventUID | Irradiation Event UID.
public Field | IsocenterPosition | Isocenter Position.
public Field | IsocenterReferenceSystemSequence | Isocenter Reference System Sequence.
public Field | IsocentertoBeamLimitingDeviceDistance | Isocenter to Beam Limiting Device Distance.
public Field | IsocentertoBlockTrayDistance | Isocenter to Block Tray Distance.
public Field | IsocentertoCompensatorDistances | Isocenter to Compensator Distances.
public Field | IsocentertoCompensatorTrayDistance | Isocenter to Compensator Tray Distance.
public Field | IsocentertoLateralSpreadingDeviceDistance | Isocenter to Lateral Spreading Device Distance.
public Field | IsocentertoRangeModulatorDistance | Isocenter to Range Modulator Distance.
public Field | IsocentertoRangeShifterDistance | Isocenter to Range Shifter Distance.
public Field | IsocentertoWedgeTrayDistance | Isocenter to Wedge Tray Distance.
public Field | IsotopeNumber | Isotope Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssueDateOfImagingServiceRequest | Issue Date of Imaging Service Request.
public Field | IssuerOfAccessionNumberSequence | Issuer of Accession Number Sequence.
public Field | IssuerOfAdmissionID | Issuer of Admission ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssuerOfAdmissionIDSequence | Issuer of Admission ID Sequence.
public Field | IssuerOfPatientID | Issuer of Patient ID.
public Field | IssuerOfPatientIDQualifiersSequence | Issuer of Patient ID Qualifiers Sequence.
public Field | IssuerOfServiceEpisodeID | Issuer of Service Episode ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | IssuerOfServiceEpisodeIDSequence | Issuer of Service Episode ID Sequence.
public Field | IssuerOfTheContainerIdentifierSequence | Issuer of the Container Identifier Sequence.
public Field | IssuerOfTheSpecimenIdentifierSequence | Issuer of the Specimen Identifier Sequence.
public Field | IssueTimeOfImagingServiceRequest | Issue Time of Imaging Service Request.
public Field | Item | Item marker.
public Field | ItemDelimitationItem | Item Delimitation Item.
public Field | ItemNumber | Item Number.
public Field | IterativeReconstructionMethod | Iterative Reconstruction Method.
public Field | IvusAcquisition | IVUS Acquisition.
public Field | IvusGatedRate | IVUS Gated Rate.
public Field | IvusPullbackRate | IVUS Pullback Rate.
public Field | IvusPullbackStartFrameNumber | IVUS Pullback Start Frame Number.
public Field | IvusPullbackStopFrameNumber | IVUS Pullback Stop Frame Number.
public Field | KeratometricAxis | Keratometric Axis.
public Field | KeratometricPower | Keratometric Power.
public Field | KeratometryLeftEyeSequence | Keratometry Left Eye Sequence.
public Field | KeratometryRightEyeSequence | Keratometry Right Eye Sequence.
public Field | KspaceFiltering | K-space Filtering.
public Field | Kvp | KVP (kilovolts peak).
public Field | LabelStyleSelection | Label Style Selection.
public Field | LabelText | Label Text.
public Field | LabelUsingInformationExtractedFromInstances | Label Using Information Extracted From Instances.
public Field | LanguageCodeSequence | Language Code Sequence.
public Field | LargeBluePaletteColorLookupTableData | Large Blue Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeBluePaletteColorLookupTableDescriptor | Large Blue Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeGreenPaletteColorLookupTableData | Large Green Palette Color Lookup Table Data(RET). See DICOM specification for alternatives.
public Field | LargeGreenPaletteColorLookupTableDescriptor | Large Green Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargePaletteColorLookupTableUID | Large Palette Color Lookup Table UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeRedPaletteColorLookupTableData | Large Red Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargeRedPaletteColorLookupTableDescriptor | Large Red Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestImagePixelValue | Largest Image Pixel Value.
public Field | LargestImagePixelValueInPlane | Largest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestMonochromePixelValue | Largest Monochrome Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LargestPixelValueInSeries | Largest Pixel Value in Series.
public Field | LargestValidPixelValue | Largest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LastMenstrualDate | Last Menstrual Date.
public Field | Laterality | The Laterality.
public Field | LateralSpreadingDeviceDescription | Lateral Spreading Device Description.
public Field | LateralSpreadingDeviceID | Lateral Spreading Device ID.
public Field | LateralSpreadingDeviceNumber | Lateral Spreading Device Number.
public Field | LateralSpreadingDeviceSequence | Lateral Spreading Device Sequence.
public Field | LateralSpreadingDeviceSetting | Lateral Spreading Device Setting.
public Field | LateralSpreadingDeviceSettingsSequence | Lateral Spreading Device Settings Sequence.
public Field | LateralSpreadingDeviceType | Lateral Spreading Device Type.
public Field | LateralSpreadingDeviceWaterEquivalentThickness | Lateral Spreading Device Water Equivalent Thickness.
public Field | LeafJawPosition | Leaf/Jaw Positions.
public Field | LeafJawPositions | Leaf/Jaw Positions.
public Field | LeafPositionBoundaries | Leaf Position Boundaries.
public Field | LeftImageSequence | Left Image Sequence.
public Field | LeftLensSequence | Left Lens Sequence.
public Field | LengthToEnd | Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LensDescription | Lens Description.
public Field | LensesCodeSequence | Lenses Code Sequence.
public Field | LensSegmentType | Lens Segment Type.
public Field | LesionNumber | Lesion Number.
public Field | LightPathFilterPassBand | Light Path Filter Pass Band.
public Field | LightPathFilterPassThroughWavelength | Light Path Filter Pass-Through Wavelength.
public Field | LightPathFilterTypeStackCodeSequence | Light Path Filter Type Stack Code Sequence.
public Field | LineSequence | Line Sequence.
public Field | ListOfMIMETypes | List of MIME Types.
public Field | LocalNamespaceEntityID | Local Namespace Entity ID.
public Field | Location | Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LookupTableNumber | Lookup Table Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LossyImageCompression | Lossy Image Compression.
public Field | LossyImageCompressionMethod | Lossy Image Compression Method.
public Field | LossyImageCompressionRatio | Lossy Image Compression Ratio.
public Field | LossyImageCompressionRetired | Lossy Image Compression (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | LowRrValue | Low R-R Value.
public Field | LUTData | LUT (Lookup Table) Data.
public Field | LUTDescriptor | LUT Descriptor.
public Field | LUTExplanation | LUT Explanation.
public Field | LUTFrameRange | LUT Frame Range.
public Field | LUTFunction | LUT Function.
public Field | LutLabel | LUT Label.
public Field | LUTNumber | LUT Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MAC | MAC (Message Authentication Code).
public Field | MacAlgorithm | MAC Algorithm.
public Field | MacCalculationTransferSyntaxUID | MAC Calculation Transfer Syntax UID.
public Field | MacIDNumber | MAC ID Number.
public Field | MacParametersSequence | MAC Parameters Sequence.
public Field | MagneticFieldStrength | Magnetic Field Strength.
public Field | MagnetizationTransfer | Magnetization Transfer.
public Field | MagnificationType | Magnification Type.
public Field | MagnifytoNumberofColumns | Magnify to Number of Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Manifold | Manifold tag.
public Field | ManipulatedImage | Manipulated Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Manufacturer | The Manufacturer.
public Field | ManufacturersModelName | Manufacturer's Model Name.
public Field | MappingResource | Mapping Resource.
public Field | MaskFrameNumbers | Mask Frame Numbers.
public Field | MaskingImage | Masking Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaskOperation | Mask Operation.
public Field | MaskOperationExplanation | Mask Operation Explanation.
public Field | MaskPointers | Mask Pointer(s). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaskSelectionMode | Mask Selection Mode.
public Field | MaskSubpixelShift | Mask Sub-pixel Shift.
public Field | MaskSubtractionSequence | Mask Subtraction Sequence.
public Field | MaskVisibilityPercentage | Mask Visibility Percentage.
public Field | MaterialID | Material ID.
public Field | MatrixRegistrationSequence | Matrix Registration Sequence.
public Field | MatrixSequence | Matrix Sequence.
public Field | MaxDensity | Max Density.
public Field | MaximumAcrossScanDistortion | Maximum Across-scan Distortion.
public Field | MaximumAlongScanDistortion | Maximum Along-scan Distortion.
public Field | MaximumCollatedFilms | Maximum Collated Films.
public Field | MaximumCoordinateValue | Maximum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MaximumDepthDistortion | Maximum Depth Distortion.
public Field | MaximumFractionalValue | Maximum Fractional Value.
public Field | MaximumMemoryAllocation | Maximum Memory Allocation.
public Field | MaximumPointDistance | Maximum Point Distance.
public Field | MeanPointDistance | Mean Point Distance.
public Field | MeasuredDoseDescription | Measured Dose Description.
public Field | MeasuredDoseReferenceNumber | Measured Dose Reference Number.
public Field | MeasuredDoseReferenceSequence | Measured Dose Reference Sequence.
public Field | MeasuredDoseType | Measured Dose Type.
public Field | MeasuredDoseValue | Measured Dose Value.
public Field | MeasuredValueSequence | Measured Value Sequence.
public Field | MeasurementUnitsCodeSequence | Measurement Units Code Sequence.
public Field | MeasuringUnitsSequence | Measuring Units Sequence.
public Field | MechanicalIndex | Mechanical Index.
public Field | MediaDisposition | Media Disposition.
public Field | MediaInstalledSequence | Media Installed Sequence.
public Field | MediaStorageSOPClassUID | Media Storage SOP Class UID.
public Field | MediaStorageSOPInstanceUID | Media Storage SOP Instance UID.
public Field | MedicalAlerts | Medical Alerts.
public Field | MedicalRecordLocator | Medical Record Locator.
public Field | MediumType | Medium Type.
public Field | MemoryAllocation | Memory Allocation.
public Field | MemoryBitDepth | Memory Bit Depth.
public Field | MessageID | Message ID.
public Field | MessageIDBeingRespondedTo | Message ID Being Responded To.
public Field | MessageSetID | Message Set ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MetaboliteMapCodeSequence | Metabolite Map Code Sequence.
public Field | MetaboliteMapDescription | Metabolite Map Description.
public Field | MetaInfoHeader | DICOM meta information header.
public Field | MetersetExposure | Meterset Exposure.
public Field | MetersetRate | Meterset Rate.
public Field | MetersetRateDelivered | Meterset Rate Delivered.
public Field | MetersetRateSet | Meterset Rate Set.
public Field | MidSlabPosition | Mid Slab Position.
public Field | MilitaryRank | Military Rank.
public Field | MIMETypeofEncapsulatedDocument | MIME Type of Encapsulated Document.
public Field | MinDensity | Min Density.
public Field | MinimumCoordinateValue | Minimum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModalitiesInStudy | Modalities in Study.
public Field | Modality | Modality value.
public Field | ModalityLUTSequence | Modality LUT Sequence.
public Field | ModalityLUTType | Modality LUT Type.
public Field | ModifiedAttributesSequence | Modified Attributes Sequence.
public Field | ModifiedImageDate | Modified Image Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageDescription | Modified Image Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageID | Modified Image ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifiedImageTime | Modified Image Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifierCodeSequence | Modifier Code Sequence.
public Field | ModifyingDeviceID | Modifying Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifyingDeviceManufacturer | Modifying Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ModifyingSystem | Modifying System.
public Field | MostRecentTreatmentDate | Most Recent Treatment Date.
public Field | MotionSynchronizationSequence | Motion Synchronization Sequence.
public Field | MoveDestination | Move Destination.
public Field | MoveOriginatorApplicationEntityTitle | Move Originator Application Entity Title.
public Field | MoveOriginatorMessageID | Move Originator Message ID.
public Field | MRAcquisitionFrequencyEncodingSteps | MR Acquisition Frequency Encoding Steps.
public Field | MRAcquisitionPhaseEncodingStepsInPlane | MR Acquisition Phase Encoding Steps in-plane.
public Field | MRAcquisitionPhaseEncodingStepsOutOfPlane | MR Acquisition Phase Encoding Steps out-of-plane.
public Field | MrAcquisitionType | MR Acquisition Type.
public Field | MrAveragesSequence | MR Averages Sequence.
public Field | MrDiffusionSequence | MR Diffusion Sequence.
public Field | MRDRDirectoryRecordOffset | MRDR Directory Record Offset. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | MrEchoSequence | MR Echo Sequence.
public Field | MrFovGeometrySequence | MR FOV/Geometry Sequence.
public Field | MrImageFrameTypeSequence | MR Image Frame Type Sequence.
public Field | MrImagingModifierSequence | MR Imaging Modifier Sequence.
public Field | MrMetaboliteMapSequence | MR Metabolite Map Sequence.
public Field | MrModifierSequence | MR Modifier Sequence.
public Field | MrReceiveCoilSequence | MR Receive Coil Sequence.
public Field | MrSpatialSaturationSequence | MR Spatial Saturation Sequence.
public Field | MRSpectroscopyAcquisitionType | MR Spectroscopy Acquisition Type.
public Field | MrSpectroscopyFovGeometrySequence | MR Spectroscopy FOV/Geometry Sequence.
public Field | MrSpectroscopyFrameTypeSequence | MR Spectroscopy Frame Type Sequence.
public Field | MrTimingAndRelatedParametersSequence | MR Timing and Related Parameters Sequence.
public Field | MrTransmitCoilSequence | MR Transmit Coil Sequence.
public Field | MrVelocityEncodingSequence | MR Velocity Encoding Sequence.
public Field | MultiCoilConfiguration | Multi-Coil Configuration.
public Field | MultiCoilDefinitionSequence | Multi-Coil Definition Sequence.
public Field | MultiCoilElementName | Multi-Coil Element Name.
public Field | MultiCoilElementUsed | Multi-Coil Element Used.
public Field | MultiFramePresentationSequence | Multi-frame Presentation Sequence.
public Field | MultiFrameSourceSOPInstanceUID | Multi-Frame Source SOP Instance UID.
public Field | MultiPlanarExcitation | Multi-planar Excitation.
public Field | MultipleCopiesFlag | Multiple Copies Flag.
public Field | MultipleSpinEcho | Multiple Spin Echo.
public Field | MultiplexedAudioChannelsDescriptionCodeSequence | Multiplexed Audio Channels Description Code Sequence.
public Field | MultiplexGroupLabel | Multiplex Group Label.
public Field | MultiplexGroupTimeOffset | Multiplex Group Time Offset.
public Field | MydriaticAgentCodeSequence | Mydriatic Agent Code Sequence.
public Field | MydriaticAgentConcentration | Mydriatic Agent Concentration.
public Field | MydriaticAgentConcentrationUnitsSequence | Mydriatic Agent Concentration Units Sequence.
public Field | MydriaticAgentSequence | Mydriatic Agent Sequence.
public Field | NameOfPhysiciansReadingStudy | Name of Physician(s) Reading Study.
public Field | NamesOfIntendedRecipientsOfResults | Names of Intended Recipients of Results.
public Field | NavigationDisplaySet | Navigation Display Set.
public Field | NavigationIndicatorSequence | Navigation Indicator Sequence.
public Field | NearPupillaryDistance | Near Pupillary Distance.
public Field | NetworkID | Network ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NominalBeamEnergy | Nominal Beam Energy.
public Field | NominalBeamEnergyUnit | Nominal Beam Energy Unit.
public Field | NominalCardiacTriggerDelayTime | Nominal Cardiac Trigger Delay Time.
public Field | NominalInterval | Nominal Interval.
public Field | NominalPercentageOfCardiacPhase | Nominal Percentage of Cardiac Phase.
public Field | NominalPercentageOfRespiratoryPhase | Nominal Percentage of Respiratory Phase.
public Field | NominalPriorDose | Nominal Prior Dose.
public Field | NominalRespiratoryTriggerDelayTime | Nominal Respiratory Trigger Delay Time.
public Field | NominalScannedPixelSpacing | Nominal Scanned Pixel Spacing.
public Field | NominalScreenDefinitionSequence | Nominal Screen Definition Sequence.
public Field | NonDICOMOutputCodeSequence | Non-DICOM Output Code Sequence.
public Field | NonUniformRadialSamplingCorrected | Non-uniform Radial Sampling Corrected.
public Field | NormalizationFactorFormat | Normalization Factor Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NormalizationPoint | Normalization Point.
public Field | NormalReverse | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NorRev | Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NotchFilterBandwidth | Notch Filter Bandwidth.
public Field | NotchFilterFrequency | Notch Filter Frequency.
public Field | NTPSourceAddress | NTP Source Address.
public Field | NuclearMedicineSeriesType | Nuclear Medicine Series Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfAverages | Number of Averages.
public Field | NumberOfBeams | Number of Beams.
public Field | NumberOfBlocks | Number of Blocks.
public Field | NumberOfBoli | Number of Boli.
public Field | NumberOfBrachyApplicationSetups | Number of Brachy Application Setups.
public Field | NumberOfChannels | Number of Channels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfCompensators | Number of Compensators.
public Field | NumberOfCompletedSuboperations | Number of Completed Sub-operations.
public Field | NumberOfContourPoints | Number of Contour Points.
public Field | NumberOfControlPoints | Number of Control Points.
public Field | NumberOfCopies | Number of Copies.
public Field | NumberOfDetectors | Number of Detectors.
public Field | NumberOfEnergyWindows | Number of Energy Windows.
public Field | NumberOfEventTimers | Number of Event Timers.
public Field | NumberOfFailedSuboperations | Number of Failed Sub-operations.
public Field | NumberOfFilms | Number of Films.
public Field | NumberOfFractionPatternDigitsPerDay | Number of Fraction Pattern Digits Per Day.
public Field | NumberOfFractionsDelivered | Number of Fractions Delivered.
public Field | NumberOfFractionsPlanned | Number of Fractions Planned.
public Field | NumberOfFrames | Number of Frames.
public Field | NumberOfFramesInOverlay | Number of Frames in Overlay.
public Field | NumberOfFramesInPhase | Number of Frames in Phase.
public Field | NumberOfFramesInRotation | Number of Frames in Rotation.
public Field | NumberOfGraphicPoints | Number of Graphic Points.
public Field | NumberofHorizontalPixels | Number of Horizontal Pixels.
public Field | NumberOfIterations | Number of Iterations.
public Field | NumberOfKspaceTrajectories | Number of k-Space Trajectories.
public Field | NumberofLateralSpreadingDevices | Number of Lateral Spreading Devices.
public Field | NumberOfLeafJawPairs | Number of Leaf/Jaw Pairs.
public Field | NumberOfMatches | Number of Matches. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofPaintings | Number of Paintings.
public Field | NumberOfPatientRelatedInstances | Number of Patient Related Instances.
public Field | NumberOfPatientRelatedSeries | Number of Patient Related Series.
public Field | NumberOfPatientRelatedStudies | Number of Patient Related Studies.
public Field | NumberOfPhaseEncodingSteps | Number of Phase Encoding Steps.
public Field | NumberOfPhases | Number of Phases.
public Field | NumberOfPoints | Number of Points. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofPriorsReferenced | Number of Priors Referenced.
public Field | NumberOfPulses | Number of Pulses.
public Field | NumberofRangeModulators | Number of Range Modulators.
public Field | NumberofRangeShifters | Number of Range Shifters.
public Field | NumberOfReferences | Number of References. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfRemainingSuboperations | Number of Remaining Sub-operations.
public Field | NumberOfRotations | Number of Rotations.
public Field | NumberOfRrIntervals | Number of R-R Intervals.
public Field | NumberOfSamples | Number of Samples. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberofScanSpotPositions | Number of Scan Spot Positions.
public Field | NumberofScreens | Number of Screens.
public Field | NumberOfSeriesRelatedInstances | Number of Series Related Instances.
public Field | NumberOfSlices | Number of Slices.
public Field | NumberOfStages | Number of Stages.
public Field | NumberOfStudyRelatedInstances | Number of Study Related Instances.
public Field | NumberOfStudyRelatedSeries | Number of Study Related Series.
public Field | NumberOfSubsets | Number of Subsets.
public Field | NumberOfSurfacePoints | Number of Surface Points.
public Field | NumberOfSurfaces | Number of Surfaces.
public Field | NumberOfTable | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTableBreakPoints | Number of Table Break Points.
public Field | NumberOfTableEntries | Number of Table Entries.
public Field | NumberOfTables | Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTemporalPositions | Number of Temporal Positions.
public Field | NumberOfTimeSlices | Number of Time Slices.
public Field | NumberOfTimeSlots | Number of Time Slots.
public Field | NumberOfTomosynthesisSourceImages | Number of Tomosynthesis Source Images.
public Field | NumberOfTransformSteps | Number of Transform Steps. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | NumberOfTriggersInPhase | Number of Triggers in Phase.
public Field | NumberOfVectors | Number of Vectors.
public Field | NumberofVerticalPixels | Number of Vertical Pixels.
public Field | NumberOfViewsInStage | Number of Views in Stage.
public Field | NumberOfWarningSuboperations | Number of Warning Sub-operations.
public Field | NumberOfWaveformChannels | Number of Waveform Channels.
public Field | NumberOfWaveformSamples | Number of Waveform Samples.
public Field | NumberOfWedges | Number of Wedges.
public Field | NumberOfZeroFills | Number of Zero fills.
public Field | NumericValue | Numeric Value.
public Field | NumericValueQualifierCodeSequence | Numeric Value Qualifier Code Sequence.
public Field | ObjectPixelSpacinginCenterofBeam | Object Pixel Spacing in Center of Beam.
public Field | ObjectThicknessSequence | Object Thickness Sequence.
public Field | ObservationDateTime | Observation Date Time.
public Field | ObservationNumber | Observation Number.
public Field | ObserverType | Observer Type.
public Field | Occupation | Patient's Occupation.
public Field | OffendingElement | Offending Element.
public Field | OffsetOfReferencedLowerLevelDirectoryEntity | Offset of Referenced Lower-Level Directory Entity.
public Field | OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity | Offset of the First Directory Record of the Root Directory Entity.
public Field | OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity | Offset of the Last Directory Record of the Root Directory Entity.
public Field | OffsetOfTheNextDirectoryRecord | Offset of the Next Directory Record.
public Field | OnAxisBackgroundAnatomicStructureCodeSequence | OnAxis Background Anatomic Structure Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OperatingMode | Operating Mode.
public Field | OperatingModeSequence | Operating Mode Sequence.
public Field | OperatingModeType | Operating Mode Type.
public Field | OperatorIdentificationSequence | Operator Identification Sequence.
public Field | OperatorsName | Operators' Name.
public Field | OphthalmicFrameLocationSequence | Ophthalmic Frame Location Sequence.
public Field | OphthalmicImageOrientation | Ophthalmic Image Orientation.
public Field | OpticalTransmittance | Optical Transmittance.
public Field | Optotype | Optotype tag.
public Field | OptotypeDetailedDefinition | Optotype Detailed Definition.
public Field | OptotypePresentation | Optotype Presentation.
public Field | OrderCallbackPhoneNumber | Order Callback Phone Number.
public Field | OrderEnteredBy | Order Entered By.
public Field | OrderEnterersLocation | Order Enterer's Location.
public Field | OrderFillerIdentifierSequence | Order Filler Identifier Sequence.
public Field | OrderPlacerIdentifierSequence | Order Placer Identifier Sequence.
public Field | OrganAtRiskFullVolumeDose | Organ at Risk Full-volume Dose.
public Field | OrganAtRiskLimitDose | Organ at Risk Limit Dose.
public Field | OrganAtRiskMaximumDose | Organ at Risk Maximum Dose.
public Field | OrganAtRiskOverdoseVolumeFraction | Organ at Risk Overdose Volume Fraction.
public Field | OrganDose | Organ Dose.
public Field | OrganExposed | Organ Exposed.
public Field | OriginalAttributesSequence | Original Attributes Sequence.
public Field | OriginalImageIdentification | Original Image Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalImageIdentificationNomenclature | Original Image Identification Nomenclature. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalImageSequence | Original Image Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OriginalSpecializedSOPClassUID | Original Specialized SOP Class UID.
public Field | Originator | The Originator.
public Field | OtherMagnificationTypesAvailable | Other Magnification Types Available.
public Field | OtherMediaAvailableSequence | Other Media Available Sequence.
public Field | OtherPatientIDs | Other Patient IDs.
public Field | OtherPatientIDsSequence | Other Patient IDs Sequence.
public Field | OtherPatientNames | Other Patient Names.
public Field | OtherPupillaryDistance | Other Pupillary Distance.
public Field | OtherSmoothingTypesAvailable | Other Smoothing Types Available.
public Field | OtherStudyNumbers | Other Study Numbers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OutputInformationSequence | Output Information Sequence.
public Field | OutputPower | Output Power.
public Field | OverlayActivationLayer | Overlay Activation Layer.
public Field | OverlayBackgroundDensity | Overlay Background Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayBitPosition | Overlay Bit Position.
public Field | OverlayBitsAllocated | Overlay Bits Allocated.
public Field | OverlayBitsForCodeWord | Overlay Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayBitsGrouped | Overlay Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCodeLabel | Overlay Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCodeTableLocation | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayColumns | Overlay Columns.
public Field | OverlayComments | Overlay Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionCode | Overlay Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionDescription | Overlay Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionLabel | Overlay Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionOriginator | Overlay Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayCompressionStepPointers | Overlay Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayData | Overlay Data.
public Field | OverlayDate | Overlay Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescription | Overlay Description.
public Field | OverlayDescriptorBlue | Overlay Descriptor - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorGray | Overlay Descriptor - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorGreen | Overlay Descriptor - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayDescriptorRed | Overlay Descriptor - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayForegroundDensity | Overlay Foreground Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayFormat | Overlay Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayLabel | Overlay Label.
public Field | OverlayLocation | Overlay Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayMagnificationType | Overlay Magnification Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayMode | Overlay Mode. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayNumber | Overlay Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayNumberOfTables | Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayOrigin | Overlay Origin.
public Field | OverlayorImageMagnification | Overlay or Image Magnification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPixelDataSequence | Overlay Pixel Data Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPlaneOrigin | Overlay Plane Origin. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayPlanes | Overlay Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayRepeatInterval | Overlay Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayRows | Overlay Rows.
public Field | Overlays | Overlays. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysBlue | Overlays - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysGray | Overlays - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysGreen | Overlays - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaySmoothingType | Overlay Smoothing Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaysRed | Overlays - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlaySubtype | Overlay Subtype.
public Field | OverlayTime | Overlay Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | OverlayType | Overlay Type.
public Field | OverriddenAttributesSequence | Overridden Attributes Sequence.
public Field | OverrideParameterPointer | Override Parameter Pointer.
public Field | OverrideReason | Override Reason.
public Field | OverrideSequence | Override Sequence.
public Field | OverSamplingPhase | Oversampling Phase.
public Field | OwnerID | Owner Identifier.
public Field | PageNumberVector | Page Number Vector.
public Field | PagePositionID | Page Position ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PaletteColorLookupTableUID | Palette Color Lookup Table UID.
public Field | ParallelAcquisition | Parallel Acquisition.
public Field | ParallelAcquisitionTechnique | Parallel Acquisition Technique.
public Field | ParallelReductionFactorInPlane | Parallel Reduction Factor In-plane.
public Field | ParallelReductionFactorInPlaneRetired | Parallel Reduction Factor In-plane (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ParallelReductionFactorOutOfPlane | Parallel Reduction Factor out-of-plane.
public Field | ParallelReductionFactorSecondInPlane | Parallel Reduction Factor Second In-plane.
public Field | ParameterItemIndex | Parameter Item Index.
public Field | ParameterPointer | Parameter Pointer.
public Field | ParameterSequencePointer | Parameter Sequence Pointer.
public Field | PartialDataDisplayHandling | Partial Data Display Handling.
public Field | PartialFourier | Partial Fourier.
public Field | PartialFourierDirection | Partial Fourier Direction.
public Field | PartialView | Partial View.
public Field | PartialViewCodeSequence | Partial View Code Sequence.
public Field | PartialViewDescription | Partial View Description.
public Field | ParticipantSequence | Participant Sequence.
public Field | ParticipationDateTime | Participation DateTime.
public Field | ParticipationType | Participation Type.
public Field | PatientAdditionalPosition | Patient Additional Position.
public Field | PatientAddress | Patient's Address.
public Field | PatientAge | Patient's Age.
public Field | PatientBirthDate | Patient's Birth Date.
public Field | PatientBirthName | Patient's Birth Name.
public Field | PatientBirthTime | Patient's Birth Time.
public Field | PatientBreedCodeSequence | Patient Breed Code Sequence.
public Field | PatientBreedDescription | Patient Breed Description.
public Field | PatientClinicalTrialParticipationSequence | Patient Clinical Trial Participation Sequence.
public Field | PatientComments | Patient Comments.
public Field | PatientEyeMovementCommandCodeSequence | Patient Eye Movement Command Code Sequence.
public Field | PatientEyeMovementCommanded | Patient Eye Movement Commanded.
public Field | PatientFrameOfReferenceSource | Patient Frame of Reference Source.
public Field | PatientGantryRelationshipCodeSequence | Patient Gantry Relationship Code Sequence.
public Field | PatientID | Patient ID.
public Field | PatientIdentityRemoved | Patient Identity Removed.
public Field | PatientInsurancePlanCodeSequence | Patient's Insurance Plan Code Sequence.
public Field | PatientMotherBirthName | Patient's Mother's Birth Name.
public Field | PatientMotionCorrected | Patient Motion Corrected.
public Field | PatientName | Patient's Name.
public Field | PatientOrientation | Patient Orientation.
public Field | PatientOrientationCodeSequence | Patient Orientation Code Sequence.
public Field | PatientOrientationinFrameSequence | Patient Orientation in Frame Sequence.
public Field | PatientOrientationModifierCodeSequence | Patient Orientation Modifier Code Sequence.
public Field | PatientPhysiologicalStateCodeSequence | Patient Physiological State Code Sequence.
public Field | PatientPhysiologicalStateSequence | Patient Physiological State Sequence.
public Field | PatientPosition | Patient Position.
public Field | PatientPrimaryLanguageCodeSequence | Patient's Primary Language Code Sequence.
public Field | PatientPrimaryLanguageModifierCodeSequence | Patient's Primary Language Modifier Code Sequence.
public Field | PatientReligiousPreference | Patient's Religious Preference.
public Field | PatientSetupLabel | Patient Setup Label.
public Field | PatientSetupNumber | Patient Setup Number.
public Field | PatientSetupSequence | Patient Setup Sequence.
public Field | PatientSex | Patient's Sex.
public Field | PatientSexNeutered | Patient's Sex Neutered.
public Field | PatientsInstitutionResidence | Patient's Institution Residence.
public Field | PatientSize | Patient's Size.
public Field | PatientSpeciesCodeSequence | Patient Species Code Sequence.
public Field | PatientSpeciesDescription | Patient Species Description.
public Field | PatientState | Patient State.
public Field | PatientSupportAccessoryCode | Patient Support Accessory Code.
public Field | PatientSupportAngle | Patient Support Angle.
public Field | PatientSupportAngleTolerance | Patient Support Angle Tolerance.
public Field | PatientSupportID | Patient Support ID.
public Field | PatientSupportRotationDirection | Patient Support Rotation Direction.
public Field | PatientSupportType | Patient Support Type.
public Field | PatientTelephoneNumbers | Patient's Telephone Numbers.
public Field | PatientTransportArrangements | Patient Transport Arrangements.
public Field | PatientWeight | Patient's Weight.
public Field | PauseBetweenFrames | Pause Between Frames.
public Field | PercentPhaseFieldOfView | Percent Phase Field of View.
public Field | PercentSampling | Percent Sampling.
public Field | PerformedLocation | Performed Location.
public Field | PerformedProcedureCodeSequence | Performed Procedure Code Sequence.
public Field | PerformedProcedureStepDescription | Performed Procedure Step Description.
public Field | PerformedProcedureStepDiscontinuationReasonCodeSequence | Performed Procedure Step Discontinuation Reason Code Sequence.
public Field | PerformedProcedureStepEndDate | Performed Procedure Step End Date.
public Field | PerformedProcedureStepEndTime | Performed Procedure Step End Time.
public Field | PerformedProcedureStepID | Performed Procedure Step ID.
public Field | PerformedProcedureStepStartDate | Performed Procedure Step Start Date.
public Field | PerformedProcedureStepStartTime | Performed Procedure Step Start Time.
public Field | PerformedProcedureStepStatus | Performed Procedure Step Status.
public Field | PerformedProcedureTypeDescription | Performed Procedure Type Description.
public Field | PerformedProcessingApplicationsCodeSequence | Performed Processing Applications Code Sequence.
public Field | PerformedProcessingParametersSequence | Performed Processing Parameters Sequence.
public Field | PerformedProtocolCodeSequence | Performed Protocol Code Sequence.
public Field | PerformedProtocolType | Performed Protocol Type.
public Field | PerformedSeriesSequence | Performed Series Sequence.
public Field | PerformedStationAeTitle | Performed Station AE Title.
public Field | PerformedStationClassCodeSequence | Performed Station Class Code Sequence.
public Field | PerformedStationGeographicLocationCodeSequence | Performed Station Geographic Location Code Sequence.
public Field | PerformedStationName | Performed Station Name.
public Field | PerformedStationNameCodeSequence | Performed Station Name Code Sequence.
public Field | PerformedWorkitemCodeSequence | Performed Workitem Code Sequence.
public Field | PerformingPhysicianIdentificationSequence | Performing Physician Identification Sequence.
public Field | PerformingPhysiciansName | Performing Physician's Name.
public Field | PerFrameFunctionalGroupsSequence | Per-frame Functional Groups Sequence.
public Field | PerimeterTable | Perimeter Table. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PerimeterValue | Perimeter Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PerProjectionAcquisitionSequence | Per Projection Acquisition Sequence.
public Field | PersonIdentificationCodeSequence | Person Identification Code Sequence.
public Field | PersonName | Person Name.
public Field | PersonsAddress | Person's Address.
public Field | PersonsTelephoneNumbers | Person's Telephone Numbers.
public Field | PertinentDocumentsSequence | Pertinent Documents Sequence.
public Field | PertinentOtherEvidenceSequence | Pertinent Other Evidence Sequence.
public Field | PETDetectorMotionDetailsSequence | PET Detector Motion Details Sequence.
public Field | PETFrameAcquisitionSequence | PET Frame Acquisition Sequence.
public Field | PETFrameCorrectionFactorsSequence | PET Frame Correction Factors Sequence.
public Field | PETFrameTypeSequence | PET Frame Type Sequence.
public Field | PETPositionSequence | PET Position Sequence.
public Field | PETReconstructionSequence | PET Reconstruction Sequence.
public Field | PETTableDynamicsSequence | PET Table Dynamics Sequence.
public Field | PhaseContrast | Phase Contrast.
public Field | PhaseDelay | Phase Delay.
public Field | PhaseDescription | Phase Description.
public Field | PhaseInformationSequence | Phase Information Sequence.
public Field | PhaseNumber | Phase Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PhaseVector | Phase Vector.
public Field | PhosphorType | Phosphor Type.
public Field | PhotometricInterpretation | Photometric Interpretation.
public Field | PhototimerSetting | Phototimer Setting.
public Field | PhysicalDeltaX | Physical Delta X.
public Field | PhysicalDeltaY | Physical Delta Y.
public Field | PhysicalDetectorSize | Physical Detector Size.
public Field | PhysicalUnitsXDirection | Physical Units X Direction.
public Field | PhysicalUnitsYDirection | Physical Units Y Direction.
public Field | PhysicianApprovingInterpretation | Physician Approving Interpretation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PhysiciansOfRecord | Physician(s) of Record.
public Field | PhysiciansOfRecordIdentificationSequence | Physician(s) of Record Identification Sequence.
public Field | PhysiciansReadingStudyIdentificationSequence | Physician(s) Reading Study Identification Sequence.
public Field | PixelAspectRatio | Pixel Aspect Ratio.
public Field | PixelBandwidth | Pixel Bandwidth.
public Field | PixelComponentDataType | Pixel Component Data Type.
public Field | PixelComponentMask | Pixel Component Mask.
public Field | PixelComponentOrganization | Pixel Component Organization.
public Field | PixelComponentPhysicalUnits | Pixel Component Physical Units.
public Field | PixelComponentRangeStart | Pixel Component Range Start.
public Field | PixelComponentRangeStop | Pixel Component Range Stop.
public Field | PixelCoordinateSet | Pixel Coordinate Set.
public Field | PixelData | Pixel Data.
public Field | PixelDataProviderURL | Pixel Data Provider URL.
public Field | PixelIntensityRelationship | Pixel Intensity Relationship.
public Field | PixelIntensityRelationshipLUTSequence | Pixel Intensity Relationship LUT Sequence.
public Field | PixelIntensityRelationshipSign | Pixel Intensity Relationship Sign.
public Field | PixelMeasuresSequence | Pixel Measures Sequence.
public Field | PixelPaddingRangeLimit | Pixel Padding Range Limit.
public Field | PixelPaddingValue | Pixel Padding Value.
public Field | PixelPresentation | Pixel Presentation.
public Field | PixelRepresentation | Pixel Representation.
public Field | PixelShiftFrameRange | Pixel Shift Frame Range.
public Field | PixelShiftSequence | Pixel Shift Sequence.
public Field | PixelSpacing | Pixel Spacing.
public Field | PixelSpacingCalibrationDescription | Pixel Spacing Calibration Description.
public Field | PixelSpacingCalibrationType | Pixel Spacing Calibration Type.
public Field | PixelSpacingSequence | Pixel Spacing Sequence.
public Field | PixelValueMappingCodeSequence | Pixel Value Mapping Code Sequence.
public Field | PixelValueTransformationSequence | Pixel Value Transformation Sequence.
public Field | PlacerOrderNumberImagingServiceRequest | Placer Order Number / Imaging Service Request.
public Field | PlacerOrderNumberImagingServiceRequestRetired | Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlacerOrderNumberProcedure | Placer Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlanarConfiguration | Planar Configuration.
public Field | PlaneIdentification | Plane Identification.
public Field | PlaneOrientationSequence | Plane Orientation Sequence.
public Field | PlaneOrientationVolumeSequence | Plane Orientation (Volume) Sequence.
public Field | PlanePositionSequence | Plane Position Sequence.
public Field | PlanePositionVolumeSequence | Plane Position (Volume) Sequence.
public Field | Planes | Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PlanIntent | Plan Intent.
public Field | PlannedVerificationImageSequence | Planned Verification Image Sequence.
public Field | PlateID | Plate Identifier.
public Field | PlateType | Plate Type.
public Field | PointCoordinatesData | Point Coordinates Data.
public Field | PointPositionAccuracy | Point Position Accuracy.
public Field | PointsBoundingBoxCoordinates | Points Bounding Box Coordinates.
public Field | Polarity | Image Polarity.
public Field | PositionerIsocenterDetectorRotationAngle | Positioner Isocenter Detector Rotation Angle.
public Field | PositionerIsocenterPrimaryAngle | Positioner Isocenter Primary Angle.
public Field | PositionerIsocenterSecondaryAngle | Positioner Isocenter Secondary Angle.
public Field | PositionerMotion | Positioner Motion.
public Field | PositionerPositionSequence | Positioner Position Sequence.
public Field | PositionerPrimaryAngle | Positioner Primary Angle.
public Field | PositionerPrimaryAngleIncrement | Positioner Primary Angle Increment.
public Field | PositionerSecondaryAngle | Positioner Secondary Angle.
public Field | PositionerSecondaryAngleIncrement | Positioner Secondary Angle Increment.
public Field | PositionerType | Positioner Type.
public Field | PositionMeasuringDeviceUsed | Position Measuring Device Used.
public Field | PositionofIsocenterProjection | Position of Isocenter Projection.
public Field | PositionReferenceIndicator | Position Reference Indicator.
public Field | PostDeformationMatrixRegistrationSequence | Post Deformation Matrix Registration Sequence.
public Field | PostprocessingFunction | Postprocessing Function. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Preamble | DICOM preamble.
public Field | PredecessorDocumentsSequence | Predecessor Documents Sequence.
public Field | PreDeformationMatrixRegistrationSequence | Pre Deformation Matrix Registration Sequence.
public Field | PredictorColumns | Predictor Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PredictorConstants | Predictor Constants. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PredictorRows | Predictor Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PreferredPlaybackSequencing | Preferred Playback Sequencing.
public Field | PregnancyStatus | Pregnancy Status.
public Field | PreliminaryFlag | Preliminary Flag.
public Field | PreMedication | Pre Medication.
public Field | PrescriptionDescription | Prescription Description.
public Field | PresentationCreationDate | Presentation Creation Date.
public Field | PresentationCreationTime | Presentation Creation Time.
public Field | PresentationGroupNumber | Presentation Group Number.
public Field | PresentationIntentType | Presentation Intent Type.
public Field | PresentationLutContentSequence | Presentation LUT Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PresentationLutFlag | Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PresentationLutSequence | Presentation LUT Sequence.
public Field | PresentationLutShape | Presentation LUT Shape.
public Field | PresentationPixelAspectRatio | Presentation Pixel Aspect Ratio.
public Field | PresentationPixelMagnificationRatio | Presentation Pixel Magnification Ratio.
public Field | PresentationPixelSpacing | Presentation Pixel Spacing.
public Field | PresentationSizeMode | Presentation Size Mode.
public Field | PreserveCompositeInstancesAfterMediaCreation | Preserve Composite Instances After Media Creation.
public Field | PrimaryAnatomicStructureModifierSequence | Primary Anatomic Structure Modifier Sequence.
public Field | PrimaryAnatomicStructureSequence | Primary Anatomic Structure Sequence.
public Field | PrimaryDosimeterUnit | Primary Dosimeter Unit.
public Field | PrimaryFluenceModeSequence | Primary Fluence Mode Sequence.
public Field | PrimaryPositionerIncrement | Primary Positioner Increment.
public Field | PrimaryPositionerScanArc | Primary Positioner Scan Arc.
public Field | PrimaryPositionerScanStartAngle | Primary Positioner Scan Start Angle.
public Field | PrimaryPromptsCountsAccumulated | Primary (Prompts) Counts Accumulated.
public Field | PrimitivePointIndexList | Primitive Point Index List.
public Field | Print | Print. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrinterCharacteristicsSequence | Printer Characteristics Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrinterConfigurationSequence | Printer Configuration Sequence.
public Field | PrinterName | Printer Name.
public Field | PrinterPixelSpacing | Printer Pixel Spacing.
public Field | PrinterResolutionID | Printer Resolution ID.
public Field | PrinterStatus | Printer Status.
public Field | PrinterStatusInfo | Printer Status Info.
public Field | PrintingBitDepth | Printing Bit Depth.
public Field | PrintJobDescriptionSequence | Print Job Description Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintJobID | Print Job ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintManagementCapabilitiesSequence | Print Management Capabilities Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | PrintPriority | Print Priority.
public Field | PrintQueueID | Print Queue ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Priority | Operation Priority.
public Field | PrismSequence | Prism Sequence.
public Field | PrivateInformation | Private Information.
public Field | PrivateInformationCreatorUID | Private Information Creator UID.
public Field | PrivateRecordUID | Private Record UID.
public Field | ProcedureCodeSequence | Procedure Code Sequence.
public Field | ProcedureStepLabel | Procedure Step Label.
public Field | ProcedureStepRelationshipType | Procedure Step Relationship Type.
public Field | ProcessingFunction | Processing Function.
public Field | ProductDescription | Product Description.
public Field | ProductExpirationDateTime | Product Expiration DateTime.
public Field | ProductLotIdentifier | Product Lot Identifier.
public Field | ProductName | Product Name.
public Field | ProductPackageIdentifier | Product Package Identifier.
public Field | ProductParameterSequence | Product Parameter Sequence.
public Field | ProductTypeCodeSequence | Product Type Code Sequence.
public Field | ProjectionEponymousNameCodeSequence | Projection Eponymous Name Code Sequence.
public Field | ProjectionPixelCalibrationSequence | Projection Pixel Calibration Sequence.
public Field | ProposedStudySequence | Proposed Study Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ProtocolContextSequence | Protocol Context Sequence.
public Field | ProtocolName | Protocol Name.
public Field | PseudocolorType | Pseudo-color Type.
public Field | PulseRepetitionFrequency | Pulse Repetition Frequency.
public Field | PulseRepetitionInterval | Pulse Repetition Interval.
public Field | PulseSequenceName | Pulse Sequence Name.
public Field | PupilDilated | Pupil Dilated.
public Field | PupilSize | Pupil Size.
public Field | PurposeOfReferenceCodeSequence | Purpose of Reference Code Sequence.
public Field | PvcRejection | PVC Rejection.
public Field | QuadratureReceiveCoil | Quadrature Receive Coil.
public Field | QualityControlImage | Quality Control Image.
public Field | Quantity | Quantity value.
public Field | QuantitySequence | Quantity Sequence.
public Field | QueryRetrieveLevel | Query/Retrieve Level.
public Field | QueueStatus | Queue Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RadialPosition | Radial Position.
public Field | RadiationAtomicNumber | Radiation Atomic Number.
public Field | RadiationChargeState | Radiation Charge State.
public Field | RadiationMachineName | Radiation Machine Name.
public Field | RadiationMachineSad | Radiation Machine SAD.
public Field | RadiationMachineSsd | Radiation Machine SSD.
public Field | RadiationMassNumber | Radiation Mass Number.
public Field | RadiationMode | Radiation Mode.
public Field | RadiationSetting | Radiation Setting.
public Field | RadiationType | Radiation Type.
public Field | Radionuclide | Radionuclide. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RadionuclideCodeSequence | Radionuclide Code Sequence.
public Field | RadionuclideHalfLife | Radionuclide Half Life.
public Field | RadionuclidePositronFraction | Radionuclide Positron Fraction.
public Field | RadionuclideTotalDose | Radionuclide Total Dose.
public Field | Radiopharmaceutical | Radiopharmaceutical value.
public Field | RadiopharmaceuticalAgentNumber | Radiopharmaceutical Agent Number.
public Field | RadiopharmaceuticalCodeSequence | Radiopharmaceutical Code Sequence.
public Field | RadiopharmaceuticalInformationSequence | Radiopharmaceutical Information Sequence.
public Field | RadiopharmaceuticalRoute | Radiopharmaceutical Route.
public Field | RadiopharmaceuticalSpecificActivity | Radiopharmaceutical Specific Activity.
public Field | RadiopharmaceuticalStartDateTime | Radiopharmaceutical Start DateTime.
public Field | RadiopharmaceuticalStartTime | Radiopharmaceutical Start Time.
public Field | RadiopharmaceuticalStopDateTime | Radiopharmaceutical Stop DateTime.
public Field | RadiopharmaceuticalStopTime | Radiopharmaceutical Stop Time.
public Field | RadiopharmaceuticalUsageSequence | Radiopharmaceutical Usage Sequence.
public Field | RadiopharmaceuticalVolume | Radiopharmaceutical Volume.
public Field | RadiusOfCircularCollimator | Radius of Circular Collimator.
public Field | RadiusofCircularExposureControlSensingRegion | Radius of Circular Exposure Control Sensing Region.
public Field | RadiusOfCircularShutter | Radius of Circular Shutter.
public Field | RadiusOfCurvature | Radius of Curvature.
public Field | RandomsCorrected | Randoms Corrected.
public Field | RandomsCorrectionMethod | Randoms Correction Method.
public Field | RangeModulatorDescription | Range Modulator Description.
public Field | RangeModulatorGatingStartValue | Range Modulator Gating Start Value.
public Field | RangeModulatorGatingStartWaterEquivalentThickness | Range Modulator Gating Start Water Equivalent Thickness.
public Field | RangeModulatorGatingStopValue | Range Modulator Gating Stop Value.
public Field | RangeModulatorGatingStopWaterEquivalentThickness | Range Modulator Gating Stop Water Equivalent Thickness.
public Field | RangeModulatorID | Range Modulator ID.
public Field | RangeModulatorNumber | Range Modulator Number.
public Field | RangeModulatorSequence | Range Modulator Sequence.
public Field | RangeModulatorSettingsSequence | Range Modulator Settings Sequence.
public Field | RangeModulatorType | Range Modulator Type.
public Field | RangeShifterDescription | Range Shifter Description.
public Field | RangeShifterID | Range Shifter ID.
public Field | RangeShifterNumber | Range Shifter Number.
public Field | RangeShifterSequence | Range Shifter Sequence.
public Field | RangeShifterSetting | Range Shifter Setting.
public Field | RangeShifterSettingsSequence | Range Shifter Settings Sequence.
public Field | RangeShifterType | Range Shifter Type.
public Field | RangeShifterWaterEquivalentThickness | Range Shifter Water Equivalent Thickness.
public Field | RawDataHandling | Raw Data Handling.
public Field | RealWorldValueFirstValueMapped | Real World Value First Value Mapped.
public Field | RealWorldValueIntercept | Real World Value Intercept.
public Field | RealWorldValueLastValueMapped | Real World Value Last Value Mapped.
public Field | RealWorldValueLUTData | Real World Value LUT Data.
public Field | RealWorldValueMappingSequence | Real World Value Mapping Sequence.
public Field | RealWorldValueSlope | Real World Value Slope.
public Field | ReasonForCancellation | Reason for Cancellation.
public Field | ReasonForPerformedProcedureCodeSequence | Reason For Performed Procedure Code Sequence.
public Field | ReasonforRequestedProcedureCodeSequence | Reason for Requested Procedure Code Sequence.
public Field | ReasonForStudy | Reason for Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReasonForTheAttributeModification | Reason for the Attribute Modification.
public Field | ReasonForTheImagingServiceRequest | Reason for the Imaging Service Request. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReasonForTheRequestedProcedure | Reason for the Requested Procedure.
public Field | ReceiveCoilManufacturerName | Receive Coil Manufacturer Name.
public Field | ReceiveCoilName | Receive Coil Name.
public Field | ReceiveCoilType | Receive Coil Type.
public Field | ReceiverAeTitle | Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReceivingAE | Receiving AE.
public Field | RecognitionCode | Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RecognitionCodeRetired | Recognition Code (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RecommendedDisplayCIELabValue | Recommended Display CIELab Value.
public Field | RecommendedDisplayFrameRate | Recommended Display Frame Rate.
public Field | RecommendedDisplayFrameRateinFloat | Recommended Display Frame Rate in Float.
public Field | RecommendedDisplayGrayscaleValue | Recommended Display Grayscale Value.
public Field | RecommendedPresentationOpacity | Recommended Presentation Opacity.
public Field | RecommendedPresentationType | Recommended Presentation Type.
public Field | RecommendedViewingMode | Recommended Viewing Mode.
public Field | ReconstructionAlgorithm | Reconstruction Algorithm.
public Field | ReconstructionAngle | Reconstruction Angle.
public Field | ReconstructionDescription | Reconstruction Description.
public Field | ReconstructionDiameter | Reconstruction Diameter.
public Field | ReconstructionFieldofView | Reconstruction Field of View.
public Field | ReconstructionIndex | Reconstruction Index.
public Field | ReconstructionMethod | Reconstruction Method.
public Field | ReconstructionPixelSpacing | Reconstruction Pixel Spacing.
public Field | ReconstructionTargetCenterPatient | Reconstruction Target Center (Patient).
public Field | ReconstructionType | Reconstruction Type.
public Field | RecordedBlockSequence | Recorded Block Sequence.
public Field | RecordedBrachyAccessoryDeviceSequence | Recorded Brachy Accessory Device Sequence.
public Field | RecordedChannelSequence | Recorded Channel Sequence.
public Field | RecordedChannelShieldSequence | Recorded Channel Shield Sequence.
public Field | RecordedCompensatorSequence | Recorded Compensator Sequence.
public Field | RecordedLateralSpreadingDeviceSequence | Recorded Lateral Spreading Device Sequence.
public Field | RecordedRangeModulatorSequence | Recorded Range Modulator Sequence.
public Field | RecordedRangeShifterSequence | Recorded Range Shifter Sequence.
public Field | RecordedSnoutSequence | Recorded Snout Sequence.
public Field | RecordedSourceApplicatorSequence | Recorded Source Applicator Sequence.
public Field | RecordedSourceSequence | Recorded Source Sequence.
public Field | RecordedWedgeSequence | Recorded Wedge Sequence.
public Field | RecordInUseFlag | Record In-use Flag.
public Field | RectificationType | Rectification Type.
public Field | RectilinearPhaseEncodeReordering | Rectilinear Phase Encode Reordering.
public Field | RedPaletteColorLookupTableData | Red Palette Color Lookup Table Data.
public Field | RedPaletteColorLookupTableDescriptor | Red Palette Color Lookup Table Descriptor.
public Field | Reference | Reference. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferenceAirKermaRate | Reference Air Kerma Rate.
public Field | ReferenceCoordinates | Reference Coordinates.
public Field | ReferencedBasicAnnotationBoxSequence | Referenced Basic Annotation Box Sequence.
public Field | ReferencedBeamNumber | Referenced Beam Number.
public Field | ReferencedBeamSequence | Referenced Beam Sequence.
public Field | ReferencedBlockNumber | Referenced Block Number.
public Field | ReferencedBolusSequence | Referenced Bolus Sequence.
public Field | ReferencedBrachyAccessoryDeviceNumber | Referenced Brachy Accessory Device Number.
public Field | ReferencedBrachyApplicationSetupNumber | Referenced Brachy Application Setup Number.
public Field | ReferencedBrachyApplicationSetupSequence | Referenced Brachy Application Setup Sequence.
public Field | ReferencedCalculatedDoseReferenceNumber | Referenced Calculated Dose Reference Number.
public Field | ReferencedCalculatedDoseReferenceSequence | Referenced Calculated Dose Reference Sequence.
public Field | ReferencedChannelShieldNumber | Referenced Channel Shield Number.
public Field | ReferencedCompensatorNumber | Referenced Compensator Number.
public Field | ReferencedContentItemIdentifier | Referenced Content Item Identifier.
public Field | ReferencedControlPointIndex | Referenced Control Point Index.
public Field | ReferencedControlPointSequence | Referenced Control Point Sequence.
public Field | ReferencedCurveSequence | Referenced Curve Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedDateTime | Referenced DateTime.
public Field | ReferencedDigitalSignatureSequence | Referenced Digital Signature Sequence.
public Field | ReferencedDoseReferenceNumber | Referenced Dose Reference Number.
public Field | ReferencedDoseReferenceSequence | Referenced Dose Reference Sequence.
public Field | ReferencedDoseSequence | Referenced Dose Sequence.
public Field | ReferencedFileID | Referenced File ID.
public Field | ReferencedFileXferSynUID | Referenced Transfer Syntax UID in File.
public Field | ReferencedFilmBoxSequence | Referenced Film Box Sequence.
public Field | ReferencedFilmSessionSequence | Referenced Film Session Sequence.
public Field | ReferencedFirstFrameSequence | Referenced First Frame Sequence.
public Field | ReferencedFractionGroupNumber | Referenced Fraction Group Number.
public Field | ReferencedFractionGroupSequence | Referenced Fraction Group Sequence.
public Field | ReferencedFractionNumber | Referenced Fraction Number.
public Field | ReferencedFrameNumber | Referenced Frame Number.
public Field | ReferencedFrameNumbers | Referenced Frame Numbers.
public Field | ReferencedFrameOfReferenceSequence | Referenced Frame of Reference Sequence.
public Field | ReferencedFrameOfReferenceUID | Referenced Frame of Reference UID.
public Field | ReferencedGeneralPurposeScheduledProcedureStepSequence | Referenced General Purpose Scheduled Procedure Step Sequence.
public Field | ReferencedGeneralPurposeScheduledProcedureStepTransactionUID | Referenced General Purpose Scheduled Procedure Step Transaction UID.
public Field | ReferencedImageBoxSequence | Referenced Image Box Sequence.
public Field | ReferencedImageBoxSequenceRetired | Referenced Image Box Sequence (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedImageEvidenceSequence | Referenced Image Evidence Sequence.
public Field | ReferencedImageOverlayBoxSequence | Referenced Image Overlay Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedImageRealWorldValueMappingSequence | Referenced Image Real World Value Mapping Sequence.
public Field | ReferencedImageSequence | Referenced Image Sequence.
public Field | ReferencedInstanceSequence | Referenced Instance Sequence.
public Field | ReferencedInterpretationSequence | Referenced Interpretation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferenceDisplaySets | Reference Display Sets.
public Field | ReferencedLateralSpreadingDeviceNumber | Referenced Lateral Spreading Device Number.
public Field | ReferencedMeasuredDoseReferenceNumber | Referenced Measured Dose Reference Number.
public Field | ReferencedMeasuredDoseReferenceSequence | Referenced Measured Dose Reference Sequence.
public Field | ReferencedNonImageCompositeSOPInstanceSequence | Referenced Non-Image Composite SOP Instance Sequence.
public Field | ReferencedOtherPlaneSequence | Referenced Other Plane Sequence.
public Field | ReferencedOverlayPlaneGroups | Referenced Overlay Plane Groups. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedOverlayPlaneSequence | Referenced Overlay Plane Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedOverlaySequence | Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedPatientAliasSequence | Referenced Patient Alias Sequence.
public Field | ReferencedPatientSequence | Referenced Patient Sequence.
public Field | ReferencedPatientSetupNumber | Referenced Patient Setup Number.
public Field | ReferencedPerformedProcedureStepSequence | Referenced Performed Procedure Step Sequence.
public Field | ReferencedPresentationLutSequence | Referenced Presentation LUT Sequence.
public Field | ReferencedPresentationStateSequence | Referenced Presentation State Sequence.
public Field | ReferencedPreviousWaveform | Referenced Previous Waveform.
public Field | ReferencedPrintJobSequence | Referenced Print Job Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedPrintJobSequencePullStoredPrint | Referenced Print Job Sequence (Pull Stored Print). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedProcedureStepSequence | Referenced Procedure Step Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedRangeModulatorNumber | Referenced Range Modulator Number.
public Field | ReferencedRangeShifterNumber | Referenced Range Shifter Number.
public Field | ReferencedRawDataSequence | Referenced Raw Data Sequence.
public Field | ReferencedRealWorldValueMappingInstanceSequence | Referenced Real World Value Mapping Instance Sequence.
public Field | ReferencedReferenceImageNumber | Referenced Reference Image Number.
public Field | ReferencedReferenceImageSequence | Referenced Reference Image Sequence.
public Field | ReferencedRefractiveMeasurementsSequence | Referenced Refractive Measurements Sequence.
public Field | ReferencedRelatedGeneralSOPClassUIDinFile | Referenced Related General SOP Class UID in File.
public Field | ReferencedRequestSequence | Referenced Request Sequence.
public Field | ReferencedResultsSequence | Referenced Results Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedRoiNumber | Referenced ROI Number.
public Field | ReferencedRtPlanSequence | Referenced RT Plan Sequence.
public Field | ReferencedSamplePositions | Referenced Sample Positions.
public Field | ReferencedSegmentNumber | Referenced Segment Number.
public Field | ReferencedSeriesSequence | Referenced Series Sequence.
public Field | ReferencedSetupImageSequence | Referenced Setup Image Sequence.
public Field | ReferencedSOPClassUID | Referenced SOP Class UID.
public Field | ReferencedSOPClassUIDInFile | Referenced SOP Class UID in File.
public Field | ReferencedSOPInstanceMACSequence | Referenced SOP Instance MAC Sequence.
public Field | ReferencedSOPInstanceUID | Referenced SOP Instance UID.
public Field | ReferencedSOPInstanceUIDInFile | Referenced SOP Instance UID in File.
public Field | ReferencedSOPSequence | Referenced SOP Sequence.
public Field | ReferencedSourceApplicatorNumber | Referenced Source Applicator Number.
public Field | ReferencedSourceNumber | Referenced Source Number.
public Field | ReferencedSpatialRegistrationSequence | Referenced Spatial Registration Sequence.
public Field | ReferencedStartControlPointIndex | Referenced Start Control Point Index.
public Field | ReferencedStereometricInstanceSequence | Referenced Stereometric Instance Sequence.
public Field | ReferencedStopControlPointIndex | Referenced Stop Control Point Index.
public Field | ReferencedStorageMediaSequence | Referenced Storage Media Sequence.
public Field | ReferencedStoredPrintSequence | Referenced Stored Print Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedStructureSetSequence | Referenced Structure Set Sequence.
public Field | ReferencedStudySequence | Referenced Study Sequence.
public Field | ReferencedSubsequentWaveform | Referenced Subsequent Waveform. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedSurfaceNumber | Referenced Surface Number.
public Field | ReferencedSurfaceSequence | Referenced Surface Sequence.
public Field | ReferencedTimeOffsets | Referenced Time Offsets.
public Field | ReferencedToleranceTableNumber | Referenced Tolerance Table Number.
public Field | ReferencedTransferSyntaxUIDInFile | Referenced Transfer Syntax UID in File.
public Field | ReferencedTreatmentRecordSequence | Referenced Treatment Record Sequence.
public Field | ReferencedTypeofData | Referenced Type of Data.
public Field | ReferencedVerificationImageSequence | Referenced Verification Image Sequence.
public Field | ReferencedVisitSequence | Referenced Visit Sequence.
public Field | ReferencedVOILUTBoxSequence | Referenced VOI LUT Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferencedWaveformChannels | Referenced Waveform Channels.
public Field | ReferencedWaveformSequence | Referenced Waveform Sequence.
public Field | ReferencedWedgeNumber | Referenced Wedge Number.
public Field | ReferenceImageNumber | Reference Image Number.
public Field | ReferencePixelPhysicalValueX | Reference Pixel Physical Value X.
public Field | ReferencePixelPhysicalValueY | Reference Pixel Physical Value Y.
public Field | ReferencePixelX0 | Reference Pixel X0.
public Field | ReferencePixelY0 | Reference Pixel Y0.
public Field | ReferencetoRecordedSound | Reference to Recorded Sound. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ReferringPhysicianAddress | Referring Physician's Address.
public Field | ReferringPhysicianIdentificationSequence | Referring Physician Identification Sequence.
public Field | ReferringPhysicianName | Referring Physician's Name.
public Field | ReferringPhysicianTelephoneNumbers | Referring Physician's Telephone Numbers.
public Field | ReflectedAmbientLight | Reflected Ambient Light.
public Field | ReformattingInterval | Reformatting Interval.
public Field | ReformattingOperationInitialViewDirection | Reformatting Operation Initial View Direction.
public Field | ReformattingOperationType | Reformatting Operation Type.
public Field | ReformattingThickness | Reformatting Thickness.
public Field | RefractiveStateSequence | Refractive State Sequence.
public Field | RegionDataType | Region Data Type.
public Field | RegionFlags | Region Flags.
public Field | RegionLocationMaxX1 | Region Location Max X1.
public Field | RegionLocationMaxY1 | Region Location Max Y1.
public Field | RegionLocationMinX0 | Region Location Min X0.
public Field | RegionLocationMinY0 | Region Location Min Y0.
public Field | RegionOfResidence | Region of Residence.
public Field | RegionPixelShiftSequence | Region Pixel Shift Sequence.
public Field | RegionSpatialFormat | Region Spatial Format.
public Field | RegistrationSequence | Registration Sequence.
public Field | RegistrationTypeCodeSequence | Registration Type Code Sequence.
public Field | RelatedFrameOfReferenceUID | Related Frame of Reference UID.
public Field | RelatedGeneralSOPClassUID | Related General SOP Class UID.
public Field | RelatedProcedureStepSequence | Related Procedure Step Sequence.
public Field | RelatedReferenceRTImageSequence | Related Reference RT Image Sequence.
public Field | RelatedRtRoiObservationsSequence | Related RT ROI Observations Sequence.
public Field | RelatedSeriesSequence | Related Series Sequence.
public Field | RelationshipType | Relationship Type.
public Field | RelationshipTypeCodeSequence | Relationship Type Code Sequence.
public Field | RelativeImagePositionCodeSequence | Relative Image Position Code Sequence.
public Field | RelativeOpacity | Relative Opacity.
public Field | RelativeTime | Relative Time.
public Field | RelativeTimeUnits | Relative Time Units.
public Field | RelativeXRayExposure | Relative X-Ray Exposure.
public Field | RelevantInformationSequence | Relevant Information Sequence.
public Field | RenderingType3D | 3D Rendering Type.
public Field | RepeatFractionCycleLength | Repeat Fraction Cycle Length.
public Field | RepeatInterval | Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RepetitionTime | Repetition Time.
public Field | ReportedValuesOrigin | Reported Values Origin.
public Field | ReportingPriority | Reporting Priority.
public Field | RepresentativeFrameNumber | Representative Frame Number.
public Field | ReprojectionMethod | Reprojection Method.
public Field | RequestAttributesSequence | Request Attributes Sequence.
public Field | RequestedContrastAgent | Requested Contrast Agent.
public Field | RequestedDecimateCropBehavior | Requested Decimate/Crop Behavior.
public Field | RequestedImageSize | Requested Image Size.
public Field | RequestedImageSizeFlag | Requested Image Size Flag.
public Field | RequestedMediaApplicationProfile | Requested Media Application Profile.
public Field | RequestedProcedureCodeSequence | Requested Procedure Code Sequence.
public Field | RequestedProcedureComments | Requested Procedure Comments.
public Field | RequestedProcedureDescription | Requested Procedure Description.
public Field | RequestedProcedureID | Requested Procedure ID.
public Field | RequestedProcedureLocation | Requested Procedure Location.
public Field | RequestedProcedurePriority | Requested Procedure Priority.
public Field | RequestedResolutionID | Requested Resolution ID.
public Field | RequestedSOPClassUID | Requested SOP Class UID.
public Field | RequestedSOPInstanceUID | Requested SOP Instance UID.
public Field | RequestedSubsequentWorkitemCodeSequence | Requested Subsequent Workitem Code Sequence.
public Field | RequestingAE | Requesting AE.
public Field | RequestingPhysician | Requesting Physician.
public Field | RequestingPhysicianIdentificationSequence | Requesting Physician Identification Sequence.
public Field | RequestingService | Requesting Service.
public Field | RequestingServiceCodeSequence | Requesting Service Code Sequence.
public Field | RequestPriority | Request Priority.
public Field | RescaleIntercept | Rescale Intercept.
public Field | RescaleSlope | Rescale Slope.
public Field | RescaleType | Rescale Type.
public Field | ResidualSyringeCounts | Residual Syringe Counts.
public Field | ResonantNucleus | Resonant Nucleus.
public Field | RespiratoryCyclePosition | Respiratory Cycle Position.
public Field | RespiratoryIntervalTime | Respiratory Interval Time.
public Field | RespiratoryMotionCompensationTechnique | Respiratory Motion Compensation Technique.
public Field | RespiratoryMotionCompensationTechniqueDescription | Respiratory Motion Compensation Technique Description.
public Field | RespiratorySignalSource | Respiratory Signal Source.
public Field | RespiratorySignalSourceID | Respiratory Signal Source ID.
public Field | RespiratorySynchronizationSequence | Respiratory Synchronization Sequence.
public Field | RespiratoryTriggerDelayThreshold | Respiratory Trigger Delay Threshold.
public Field | RespiratoryTriggerType | Respiratory Trigger Type.
public Field | ResponseSequenceNumber | Response Sequence Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResponsibleOrganization | Responsible Organization.
public Field | ResponsiblePerson | Responsible Person.
public Field | ResponsiblePersonRole | Responsible Person Role.
public Field | ResultingGeneralPurposePerformedProcedureStepsSequence | Resulting General Purpose Performed Procedure Steps Sequence.
public Field | ResultsComments | Results Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsDistributionListSequence | Results Distribution List Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsID | Results ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ResultsIDIssuer | Results ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RET | RET. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RetrieveAETitle | Retrieve AE Title.
public Field | RetrieveLocationUID | Retrieve Location UID.
public Field | RetrieveURI | Retrieve URI.
public Field | ReviewDate | Review Date.
public Field | ReviewerName | Reviewer Name.
public Field | ReviewTime | Review Time.
public Field | RevolutionTime | Revolution Time.
public Field | RFEchoTrainLength | RF Echo Train Length.
public Field | RGBLUTTransferFunction | RGB LUT Transfer Function.
public Field | RightImageSequence | Right Image Sequence.
public Field | RightLensSequence | Right Lens Sequence.
public Field | RoiArea | The ROI Area.
public Field | RoiContourSequence | ROI Contour Sequence.
public Field | RoiDescription | ROI Description.
public Field | RoiDisplayColor | ROI Display Color.
public Field | ROIElementalCompositionAtomicMassFraction | ROI Elemental Composition Atomic Mass Fraction.
public Field | ROIElementalCompositionAtomicNumber | ROI Elemental Composition Atomic Number.
public Field | ROIElementalCompositionSequence | ROI Elemental Composition Sequence.
public Field | RoiGenerationAlgorithm | ROI Generation Algorithm.
public Field | RoiGenerationDescription | ROI Generation Description.
public Field | RoiInterpreter | ROI Interpreter.
public Field | RoiMean | The ROI Mean.
public Field | RoiName | ROI (Region of Interest) Name.
public Field | RoiNumber | ROI Number.
public Field | RoiObservationDescription | ROI Observation Description.
public Field | RoiObservationLabel | ROI Observation Label.
public Field | ROIPhysicalPropertiesSequence | ROI Physical Properties Sequence.
public Field | RoiPhysicalProperty | ROI Physical Property.
public Field | RoiPhysicalPropertyValue | ROI Physical Property Value.
public Field | RoiStandardDeviation | ROI Standard Deviation.
public Field | RoiVolume | ROI Volume.
public Field | RotationDirection | Rotation Direction.
public Field | RotationInformationSequence | Rotation Information Sequence.
public Field | RotationOffset | Rotation Offset.
public Field | RotationOfScannedFilm | Rotation of Scanned Film.
public Field | RotationVector | Rotation Vector.
public Field | RouteOfAdmissions | Route of Admissions.
public Field | RowOverlap | Row Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Rows | Rows. Height of the DICOM image.
public Field | RowsForNthOrderCoefficients | Rows For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RRIntervalTimeNominal | R - R Interval Time Nominal.
public Field | RrIntervalVector | R-R Interval Vector.
public Field | RtBeamLimitingDeviceType | RT Beam Limiting Device Type.
public Field | RtDoseRoiSequence | RT Dose ROI Sequence.
public Field | RtImageDescription | RT Image Description.
public Field | RtImageLabel | RT Image Label.
public Field | RtImageName | RT Image Name.
public Field | RtImageOrientation | RT Image Orientation.
public Field | RtImagePlane | RT Image Plane.
public Field | RtImagePosition | RT Image Position.
public Field | RtImageSid | RT Image SID.
public Field | RtPlanDate | RT Plan Date.
public Field | RtPlanDescription | RT Plan Description.
public Field | RtPlanGeometry | RT Plan Geometry.
public Field | RtPlanLabel | RT Plan Label.
public Field | RtPlanName | RT Plan Name.
public Field | RtPlanRelationship | RT Plan Relationship.
public Field | RtPlanTime | RT Plan Time.
public Field | RtReferencedSeriesSequence | RT Referenced Series Sequence.
public Field | RtReferencedStudySequence | RT Referenced Study Sequence.
public Field | RtRelatedRoiSequence | RT Related ROI Sequence.
public Field | RtRoiIdentificationCodeSequence | RT ROI Identification Code Sequence.
public Field | RtRoiInterpretedType | RT ROI Interpreted Type.
public Field | RtRoiObservationsSequence | RT ROI Observations Sequence.
public Field | RtRoiRelationship | RT ROI Relationship.
public Field | RunLengthTriplet | Run Length Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | RWavePointer | R Wave Pointer.
public Field | RWaveTimeVector | R Wave Time Vector.
public Field | SafePositionExitDate | Safe Position Exit Date.
public Field | SafePositionExitTime | Safe Position Exit Time.
public Field | SafePositionReturnDate | Safe Position Return Date.
public Field | SafePositionReturnTime | Safe Position Return Time.
public Field | SampleRate | Sample Rate. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SamplesPerPixel | Samples per Pixel.
public Field | SamplesperPixelUsed | Samples per Pixel Used.
public Field | SamplingFrequency | Sampling Frequency.
public Field | Sar | SAR (specific absorption rate).
public Field | SaturationRecovery | Saturation Recovery.
public Field | ScanArc | Scan Arc value.
public Field | ScanLength | Scan Length.
public Field | ScanMode | Scan Mode.
public Field | ScanningSequence | Scanning Sequence.
public Field | ScanningSpotSize | Scanning Spot Size.
public Field | ScanOptions | Scan Options.
public Field | ScanSpotMetersetsDelivered | Scan Spot Metersets Delivered.
public Field | ScanSpotMetersetWeights | Scan Spot Meterset Weights.
public Field | ScanSpotPositionMap | Scan Spot Position Map.
public Field | ScanSpotTuneID | Scan Spot Tune ID.
public Field | ScanVelocity | Scan Velocity.
public Field | ScatterCorrected | Scatter Corrected.
public Field | ScatterCorrectionMethod | Scatter Correction Method.
public Field | ScatterFractionFactor | Scatter Fraction Factor.
public Field | ScheduledAdmissionDate | Scheduled Admission Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledAdmissionTime | Scheduled Admission Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledDischargeDate | Scheduled Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledDischargeTime | Scheduled Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledHumanPerformersSequence | Scheduled Human Performers Sequence.
public Field | ScheduledPatientInstitutionResidence | Scheduled Patient Institution Residence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledPerformingPhysicianIdentificationSequence | Scheduled Performing Physician Identification Sequence.
public Field | ScheduledPerformingPhysiciansName | Scheduled Performing Physician's Name.
public Field | ScheduledProcedureStepDescription | Scheduled Procedure Step Description.
public Field | ScheduledProcedureStepEndDate | Scheduled Procedure Step End Date.
public Field | ScheduledProcedureStepEndTime | Scheduled Procedure Step End Time.
public Field | ScheduledProcedureStepID | Scheduled Procedure Step ID.
public Field | ScheduledProcedureStepLocation | Scheduled Procedure Step Location.
public Field | ScheduledProcedureStepModificationDateTime | Scheduled Procedure Step Modification Date Time.
public Field | ScheduledProcedureStepPriority | Scheduled Procedure Step Priority.
public Field | ScheduledProcedureStepSequence | Scheduled Procedure Step Sequence.
public Field | ScheduledProcedureStepStartDate | Scheduled Procedure Step Start Date.
public Field | ScheduledProcedureStepStartDateTime | Scheduled Procedure Step Start Date Time.
public Field | ScheduledProcedureStepStartTime | Scheduled Procedure Step Start Time.
public Field | ScheduledProcedureStepStatus | Scheduled Procedure Step Status.
public Field | ScheduledProcessingApplicationsCodeSequence | Scheduled Processing Applications Code Sequence.
public Field | ScheduledProcessingParametersSequence | Scheduled Processing Parameters Sequence.
public Field | ScheduledProtocolCodeSequence | Scheduled Protocol Code Sequence.
public Field | ScheduledSpecimenSequence | Scheduled Specimen Sequence.
public Field | ScheduledStationAeTitle | Scheduled Station AE Title.
public Field | ScheduledStationClassCodeSequence | Scheduled Station Class Code Sequence.
public Field | ScheduledStationGeographicLocationCodeSequence | Scheduled Station Geographic Location Code Sequence.
public Field | ScheduledStationName | Scheduled Station Name.
public Field | ScheduledStationNameCodeSequence | Scheduled Station Name Code Sequence.
public Field | ScheduledStepAttributesSequence | Scheduled Step Attributes Sequence.
public Field | ScheduledStudyLocation | Scheduled Study Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyLocationAeTitles | Scheduled Study Location AE Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStartDate | Scheduled Study Start Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStartTime | Scheduled Study Start Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStopDate | Scheduled Study Stop Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledStudyStopTime | Scheduled Study Stop Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ScheduledWorkitemCodeSequence | Scheduled Workitem Code Sequence.
public Field | SCPStatus | SCP Status.
public Field | ScreenMinimumColorBitDepth | Screen Minimum Color Bit Depth.
public Field | ScreenMinimumGrayscaleBitDepth | Screen Minimum Grayscale Bit Depth.
public Field | SecondaryCaptureDeviceID | Secondary Capture Device ID.
public Field | SecondaryCaptureDeviceManufacturer | Secondary Capture Device Manufacturer.
public Field | SecondaryCaptureDeviceManufacturersModelName | Secondary Capture Device Manufacturer's Model Name.
public Field | SecondaryCaptureDeviceSoftwareVersions | Secondary Capture Device Software Version(s).
public Field | SecondaryCountsAccumulated | Secondary Counts Accumulated.
public Field | SecondaryCountsType | Secondary Counts Type.
public Field | SecondaryPositionerIncrement | Secondary Positioner Increment.
public Field | SecondaryPositionerScanArc | Secondary Positioner Scan Arc.
public Field | SecondaryPositionerScanStartAngle | Secondary Positioner Scan Start Angle.
public Field | SegmentAlgorithmName | Segment Algorithm Name.
public Field | SegmentAlgorithmType | Segment Algorithm Type.
public Field | SegmentationFractionalType | Segmentation Fractional Type.
public Field | SegmentationType | Segmentation Type.
public Field | SegmentDescription | Segment Description.
public Field | SegmentedBluePaletteColorLookupTableData | Segmented Blue Palette Color Lookup Table Data.
public Field | SegmentedGreenPaletteColorLookupTableData | Segmented Green Palette Color Lookup Table Data.
public Field | SegmentedKspaceTraversal | Segmented k-Space Traversal.
public Field | SegmentedPropertyCategoryCodeSequence | Segmented Property Category Code Sequence.
public Field | SegmentedPropertyTypeCodeSequence | Segmented Property Type Code Sequence.
public Field | SegmentedRedPaletteColorLookupTableData | Segmented Red Palette Color Lookup Table Data.
public Field | SegmentIdentificationSequence | Segment Identification Sequence.
public Field | SegmentLabel | Segment Label.
public Field | SegmentNumber | Segment Number.
public Field | SegmentSequence | Segment Sequence.
public Field | SegmentSurfaceGenerationAlgorithmIdentificationSequence | Segment Surface Generation Algorithm Identification Sequence.
public Field | SegmentSurfaceSourceInstanceSequence | Segment Surface Source Instance Sequence.
public Field | SelectorAttribute | Selector Attribute.
public Field | SelectorAttributePrivateCreator | Selector Attribute Private Creator.
public Field | SelectorAttributeVR | Selector Attribute VR.
public Field | SelectorATValue | Selector AT Value.
public Field | SelectorCodeSequenceValue | Selector Code Sequence Value.
public Field | SelectorCSValue | Selector CS Value.
public Field | SelectorDSValue | Selector DS Value.
public Field | SelectorFDValue | Selector FD Value.
public Field | SelectorFLValue | Selector FL Value.
public Field | SelectorISValue | Selector IS Value.
public Field | SelectorLOValue | Selector LO Value.
public Field | SelectorLTValue | Selector LT Value.
public Field | SelectorPNValue | Selector PN Value.
public Field | SelectorSequencePointer | Selector Sequence Pointer.
public Field | SelectorSequencePointerPrivateCreator | Selector Sequence Pointer Private Creator.
public Field | SelectorSHValue | Selector SH Value.
public Field | SelectorSLValue | Selector SL Value.
public Field | SelectorSSValue | Selector SS Value.
public Field | SelectorSTValue | Selector ST Value.
public Field | SelectorULValue | Selector UL Value.
public Field | SelectorUSValue | Selector US Value.
public Field | SelectorUTValue | Selector UT Value.
public Field | SelectorValueNumber | Selector Value Number.
public Field | SenderAeTitle | Initiator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | Sensitivity | Sensitivity value.
public Field | SensitivityCalibrated | Sensitivity Calibrated.
public Field | SequenceDelimitationItem | Sequence Delimitation Item.
public Field | SequenceName | Sequence Name.
public Field | SequenceOfCompressedData | Sequence of Compressed Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SequenceOfUltrasoundRegions | Sequence of Ultrasound Regions.
public Field | SequenceVariant | Sequence Variant.
public Field | SeriesDate | Series Date.
public Field | SeriesDescription | Series Description.
public Field | SeriesDescriptionCodeSequence | Series Description Code Sequence.
public Field | SeriesInstanceUID | Series Instance UID.
public Field | SeriesInStudy | Series in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SeriesNumber | Series Number.
public Field | SeriesTime | Series Time.
public Field | SeriesType | Series Type.
public Field | ServiceEpisodeDescription | Service Episode Description.
public Field | ServiceEpisodeID | Service Episode ID.
public Field | SetupDeviceDescription | Setup Device Description.
public Field | SetupDeviceLabel | Setup Device Label.
public Field | SetupDeviceParameter | Setup Device Parameter.
public Field | SetupDeviceSequence | Setup Device Sequence.
public Field | SetupDeviceType | Setup Device Type.
public Field | SetupImageComment | Setup Image Comment.
public Field | SetupReferenceDescription | Setup Reference Description.
public Field | SetupTechnique | Setup Technique.
public Field | SetupTechniqueDescription | Setup Technique Description.
public Field | ShapeType | Shape Type.
public Field | SharedFunctionalGroupsSequence | Shared Functional Groups Sequence.
public Field | ShieldingDeviceDescription | Shielding Device Description.
public Field | ShieldingDeviceLabel | Shielding Device Label.
public Field | ShieldingDevicePosition | Shielding Device Position.
public Field | ShieldingDeviceSequence | Shielding Device Sequence.
public Field | ShieldingDeviceType | Shielding Device Type.
public Field | ShiftTableSize | Shift Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ShiftTableTriplet | Shift Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ShowAcquisitionTechniquesFlag | Show Acquisition Techniques Flag.
public Field | ShowGraphicAnnotationFlag | Show Graphic Annotation Flag.
public Field | ShowGrayscaleInverted | Show Grayscale Inverted.
public Field | ShowImageTrueSizeFlag | Show Image True Size Flag.
public Field | ShowPatientDemographicsFlag | Show Patient Demographics Flag.
public Field | ShutterLeftVerticalEdge | Shutter Left Vertical Edge.
public Field | ShutterLowerHorizontalEdge | Shutter Lower Horizontal Edge.
public Field | ShutterOverlayGroup | Shutter Overlay Group.
public Field | ShutterPresentationColorCIELabValue | Shutter Presentation Color CIELab Value.
public Field | ShutterPresentationValue | Shutter Presentation Value.
public Field | ShutterRightVerticalEdge | Shutter Right Vertical Edge.
public Field | ShutterShape | Shutter Shape.
public Field | ShutterUpperHorizontalEdge | Shutter Upper Horizontal Edge.
public Field | SignalDomainColumns | Signal Domain Columns.
public Field | SignalDomainRows | Signal Domain Rows.
public Field | Signature | The Signature.
public Field | SimpleFrameList | Simple Frame List.
public Field | SingleCollimationWidth | Single Collimation Width.
public Field | SkipBeats | Skip Beats.
public Field | SkipFrameRangeFlag | Skip Frame Range Flag.
public Field | SlabOrientation | Slab Orientation.
public Field | SlabThickness | Slab Thickness.
public Field | SliceLocation | Slice Location.
public Field | SliceLocationVector | Slice Location Vector.
public Field | SliceProgressionDirection | Slice Progression Direction.
public Field | SliceSensitivityFactor | Slice Sensitivity Factor.
public Field | SliceThickness | Slice Thickness.
public Field | SliceVector | Slice Vector.
public Field | SlideIdentifier | Slide Identifier. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmallestImagePixelValue | Smallest Image Pixel Value.
public Field | SmallestImagePixelValueInPlane | Smallest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmallestPixelValueInSeries | Smallest Pixel Value in Series.
public Field | SmallestValidPixelValue | Smallest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SmokingStatus | Smoking Status.
public Field | SmoothingType | Smoothing Type.
public Field | SnoutID | Snout Identifier.
public Field | SnoutPosition | Snout Position.
public Field | SnoutPositionTolerance | Snout Position Tolerance.
public Field | SnoutSequence | Snout Sequence.
public Field | SoftcopyVOILUTSequence | Softcopy VOI LUT Sequence.
public Field | SoftTissueFocusThermalIndex | Soft Tissue-focus Thermal Index.
public Field | SoftTissueSurfaceThermalIndex | Soft Tissue-surface Thermal Index.
public Field | SoftTissueThermalIndex | Soft Tissue Thermal Index.
public Field | SoftwareVersions | Software Version(s).
public Field | SOPAuthorizationComment | SOP Authorization Comment.
public Field | SOPAuthorizationDateTime | SOP Authorization Date Time.
public Field | SOPClassesInStudy | SOP Classes In Study.
public Field | SOPClassesSupported | SOP Classes Supported.
public Field | SOPClassUID | SOP Class UID.
public Field | SOPInstanceStatus | SOP Instance Status.
public Field | SOPInstanceUID | SOP Instance UID.
public Field | SOPInstanceUIDOfConcatenationSource | SOP Instance UID of Concatenation Source.
public Field | SortbyCategory | Sort-by Category.
public Field | SortingDirection | Sorting Direction.
public Field | SortingOperationsSequence | Sorting Operations Sequence.
public Field | SourceApplicationEntityTitle | Source Application Entity Title.
public Field | SourceApplicatorID | Source Applicator ID.
public Field | SourceApplicatorLength | Source Applicator Length.
public Field | SourceApplicatorManufacturer | Source Applicator Manufacturer.
public Field | SourceApplicatorName | Source Applicator Name.
public Field | SourceApplicatorNumber | Source Applicator Number.
public Field | SourceApplicatorStepSize | Source Applicator Step Size.
public Field | SourceApplicatorType | Source Applicator Type.
public Field | SourceApplicatorWallNominalThickness | Source Applicator Wall Nominal Thickness.
public Field | SourceApplicatorWallNominalTransmission | Source Applicator Wall Nominal Transmission.
public Field | SourceAxisDistance | Source-Axis Distance.
public Field | SourceEncapsulationNominalThickness | Source Encapsulation Nominal Thickness.
public Field | SourceEncapsulationNominalTransmission | Source Encapsulation Nominal Transmission.
public Field | SourceFrameOfReferenceUID | Source Frame of Reference UID.
public Field | SourceHangingProtocolSequence | Source Hanging Protocol Sequence.
public Field | SourceImageEvidenceSequence | Source Image Evidence Sequence.
public Field | SourceImageIDs | Source Image IDs. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SourceImageSequence | Source Image Sequence.
public Field | SourceInstanceSequence | Source Instance Sequence.
public Field | SourceIsotopeHalfLife | Source Isotope Half Life.
public Field | SourceIsotopeName | Source Isotope Name.
public Field | SourceManufacturer | Source Manufacturer.
public Field | SourceMovementType | Source Movement Type.
public Field | SourceNumber | Source Number.
public Field | SourceOfPreviousValues | Source of Previous Values.
public Field | SourceSequence | Source Sequence.
public Field | SourceSerialNumber | Source Serial Number.
public Field | SourceStrength | Source Strength.
public Field | SourceStrengthReferenceDate | Source Strength Reference Date.
public Field | SourceStrengthReferenceTime | Source Strength Reference Time.
public Field | SourceStrengthUnits | Source Strength Units.
public Field | SourceToBeamLimitingDeviceDistance | Source to Beam Limiting Device Distance.
public Field | SourceToBlockTrayDistance | Source to Block Tray Distance.
public Field | SourceToCompensatorDistance | Source to Compensator Distance.
public Field | SourceToCompensatorTrayDistance | Source to Compensator Tray Distance.
public Field | SourceToReferenceObjectDistance | Source to Reference Object Distance.
public Field | SourceToSurfaceDistance | Source to Surface Distance.
public Field | SourceToWedgeTrayDistance | Source to Wedge Tray Distance.
public Field | SourceType | Source Type.
public Field | SourceWaveformSequence | Source Waveform Sequence.
public Field | SpacingBetweenSlices | Spacing Between Slices.
public Field | SpatialLocationsPreserved | Spatial Locations Preserved.
public Field | SpatialPresaturation | Spatial Pre-saturation.
public Field | SpatialResolution | Spatial Resolution.
public Field | SpecialNeeds | Special Needs.
public Field | SpecificAbsorptionRateDefinition | Specific Absorption Rate Definition.
public Field | SpecificAbsorptionRateSequence | Specific Absorption Rate Sequence.
public Field | SpecificAbsorptionRateValue | Specific Absorption Rate Value.
public Field | SpecificCharacterSet | Specific Character Set.
public Field | SpecificCharacterSetOfFilesetDescriptorFile | Specific Character Set of File-set Descriptor File.
public Field | SpecifiedChannelTotalTime | Specified Channel Total Time.
public Field | SpecifiedMeterset | Specified Meterset.
public Field | SpecifiedNumberofPulses | Specified Number of Pulses.
public Field | SpecifiedPrimaryMeterset | Specified Primary Meterset.
public Field | SpecifiedPulseRepetitionInterval | Specified Pulse Repetition Interval.
public Field | SpecifiedSecondaryMeterset | Specified Secondary Meterset.
public Field | SpecifiedTreatmentTime | Specified Treatment Time.
public Field | SpecimenAccessionNumber | Specimen Accession Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescription | Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescriptionSequence | Specimen Description Sequence.
public Field | SpecimenDescriptionSequenceTrial | Specimen Description Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDescriptionTrial | Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenDetailedDescription | Specimen Detailed Description.
public Field | SpecimenIdentifier | Specimen Identifier.
public Field | SpecimenLocalizationContentItemSequence | Specimen Localization Content Item Sequence.
public Field | SpecimenPreparationSequence | Specimen Preparation Sequence.
public Field | SpecimenPreparationStepContentItemSequence | Specimen Preparation Step Content Item Sequence.
public Field | SpecimenSequence | Specimen Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SpecimenShortDescription | Specimen Short Description.
public Field | SpecimenTypeCodeSequence | Specimen Type Code Sequence.
public Field | SpecimenUID | Specimen UID.
public Field | SpectrallySelectedExcitation | Spectrally Selected Excitation.
public Field | SpectrallySelectedSuppression | Spectrally Selected Suppression.
public Field | SpectralWidth | Spectral Width.
public Field | SpectroscopyAcquisitionDataColumns | Spectroscopy Acquisition Data Columns.
public Field | SpectroscopyAcquisitionOutOfPlanePhaseSteps | Spectroscopy Acquisition Out-of-plane Phase Steps.
public Field | SpectroscopyAcquisitionPhaseColumns | Spectroscopy Acquisition Phase Columns.
public Field | SpectroscopyAcquisitionPhaseRows | Spectroscopy Acquisition Phase Rows.
public Field | SpectroscopyData | Spectroscopy Data.
public Field | SpherePower | Sphere Power.
public Field | SphericalLensPower | Spherical Lens Power.
public Field | SpiralPitchFactor | Spiral Pitch Factor.
public Field | Spoiling | Spoiling value.
public Field | StackID | Stack Identifier.
public Field | StageCodeSequence | Stage Code Sequence.
public Field | StageName | Stage Name.
public Field | StageNumber | Stage Number.
public Field | StartAcquisitionDateTime | Start Acquisition DateTime.
public Field | StartAngle | Start Angle.
public Field | StartCardiacTriggerCountThreshold | Start Cardiac Trigger Count Threshold.
public Field | StartCumulativeMetersetWeight | Start Cumulative Meterset Weight.
public Field | StartDensityThreshold | Start Density Threshold.
public Field | StartingRespiratoryAmplitude | Starting Respiratory Amplitude.
public Field | StartingRespiratoryPhase | Starting Respiratory Phase.
public Field | StartMeterset | Start Meterset.
public Field | StartRelativeDensityDifferenceThreshold | Start Relative Density Difference Threshold.
public Field | StartRespiratoryTriggerCountThreshold | Start Respiratory Trigger Count Threshold.
public Field | StartTrim | Start Trim.
public Field | StationName | Station Name.
public Field | Status | Operation Status.
public Field | SteadyStatePulseSequence | Steady State Pulse Sequence.
public Field | SteepKeratometricAxisSequence | Steep Keratometric Axis Sequence.
public Field | SteeringAngle | Steering Angle.
public Field | StereoBaselineAngle | Stereo Baseline Angle.
public Field | StereoBaselineDisplacement | Stereo Baseline Displacement.
public Field | StereoHorizontalPixelOffset | Stereo Horizontal Pixel Offset.
public Field | StereoPairsSequence | Stereo Pairs Sequence.
public Field | StereoRotation | Stereo Rotation.
public Field | StereoVerticalPixelOffset | Stereo Vertical Pixel Offset.
public Field | StopTrim | Stop Trim.
public Field | StorageMediaFilesetID | Storage Media File-set ID.
public Field | StorageMediaFilesetUID | Storage Media File-set UID.
public Field | StructuredDisplayBackgroundCIELabValue | Structured Display Background CIELab Value.
public Field | StructuredDisplayImageBoxSequence | Structured Display Image Box Sequence.
public Field | StructuredDisplayTextBoxSequence | Structured Display Text Box Sequence.
public Field | StructureSetDate | Structure Set Date.
public Field | StructureSetDescription | Structure Set Description.
public Field | StructureSetLabel | Structure Set Label.
public Field | StructureSetName | Structure Set Name.
public Field | StructureSetRoiSequence | Structure Set ROI Sequence.
public Field | StructureSetTime | Structure Set Time.
public Field | StudiesContainingOtherReferencedInstancesSequence | Studies Containing Other Referenced Instances Sequence.
public Field | StudyArrivalDate | Study Arrival Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyArrivalTime | Study Arrival Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyComments | Study Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyCompletionDate | Study Completion Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyCompletionTime | Study Completion Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyComponentStatusID | Study Component Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyDate | Study Date.
public Field | StudyDescription | Study Description.
public Field | StudyID | Study Identifier.
public Field | StudyIDIssuer | Study ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyInstanceUID | Study Instance UID.
public Field | StudyPriorityID | Study Priority ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyReadDate | Study Read Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyReadTime | Study Read Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyStatusID | Study Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyTime | Study Time.
public Field | StudyVerifiedDate | Study Verified Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | StudyVerifiedTime | Study Verified Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | SubjectiveRefractionLeftEyeSequence | Subjective Refraction Left Eye Sequence.
public Field | SubjectiveRefractionRightEyeSequence | Subjective Refraction Right Eye Sequence.
public Field | SubscriptionListStatus | Subscription List Status.
public Field | SubstanceAdministrationApproval | Substance Administration Approval.
public Field | SubstanceAdministrationDateTime | Substance Administration DateTime.
public Field | SubstanceAdministrationDeviceID | Substance Administration Device ID.
public Field | SubstanceAdministrationNotes | Substance Administration Notes.
public Field | SubstanceAdministrationParameterSequence | Substance Administration Parameter Sequence.
public Field | SubtractionItemID | Subtraction Item ID.
public Field | SupportedImageDisplayFormatsSequence | Supported Image Display Formats Sequence.
public Field | SurfaceComments | Surface Comments.
public Field | SurfaceCount | Surface Count.
public Field | SurfaceEntryPoint | Surface Entry Point.
public Field | SurfaceMeshPrimitivesSequence | Surface Mesh Primitives Sequence.
public Field | SurfaceNumber | Surface Number.
public Field | SurfacePointsNormalsSequence | Surface Points Normals Sequence.
public Field | SurfacePointsSequence | Surface Points Sequence.
public Field | SurfaceProcessing | Surface Processing.
public Field | SurfaceProcessingAlgorithmIdentificationSequence | Surface Processing Algorithm Identification Sequence.
public Field | SurfaceProcessingDescription | Surface Processing Description.
public Field | SurfaceProcessingRatio | Surface Processing Ratio.
public Field | SurfaceSequence | Surface Sequence.
public Field | SynchronizationChannel | Synchronization Channel.
public Field | SynchronizationFrameOfReferenceUID | Synchronization Frame of Reference UID.
public Field | SynchronizationTrigger | Synchronization Trigger.
public Field | SynchronizedImageBoxList | Synchronized Image Box List.
public Field | SynchronizedScrollingSequence | Synchronized Scrolling Sequence.
public Field | SyringeCounts | Syringe Counts.
public Field | T2Preparation | T2 Preparation.
public Field | TableAngle | Table Angle.
public Field | TableCradleTiltAngle | Table Cradle Tilt Angle.
public Field | TableFeedperRotation | Table Feed per Rotation.
public Field | TableFrameOfReferenceUID | Table Frame of Reference UID.
public Field | TableHeadTiltAngle | Table Head Tilt Angle.
public Field | TableHeight | Table Height.
public Field | TableHorizontalRotationAngle | Table Horizontal Rotation Angle.
public Field | TableLateralIncrement | Table Lateral Increment.
public Field | TableLongitudinalIncrement | Table Longitudinal Increment.
public Field | TableMotion | Table Motion.
public Field | TableOfParameterValues | Table of Parameter Values.
public Field | TableOfPixelValues | Table of Pixel Values.
public Field | TableOfXBreakPoints | Table of X Break Points.
public Field | TableOfYBreakPoints | Table of Y Break Points.
public Field | TablePosition | Table Position.
public Field | TablePositionSequence | Table Position Sequence.
public Field | TableSpeed | Table Speed.
public Field | TableTopEccentricAngle | Table Top Eccentric Angle.
public Field | TableTopEccentricAngleTolerance | Table Top Eccentric Angle Tolerance.
public Field | TableTopEccentricAxisDistance | Table Top Eccentric Axis Distance.
public Field | TableTopEccentricRotationDirection | Table Top Eccentric Rotation Direction.
public Field | TableTopLateralPosition | Table Top Lateral Position.
public Field | TableTopLateralPositionTolerance | Table Top Lateral Position Tolerance.
public Field | TableTopLateralSetupDisplacement | Table Top Lateral Setup Displacement.
public Field | TableTopLongitudinalPosition | Table Top Longitudinal Position.
public Field | TableTopLongitudinalPositionTolerance | Table Top Longitudinal Position Tolerance.
public Field | TableTopLongitudinalSetupDisplacement | Table Top Longitudinal Setup Displacement.
public Field | TableTopPitchAngle | Table Top Pitch Angle.
public Field | TableTopPitchAngleTolerance | Table Top Pitch Angle Tolerance.
public Field | TableTopPitchRotationDirection | Table Top Pitch Rotation Direction.
public Field | TableTopRollAngle | Table Top Roll Angle.
public Field | TableTopRollAngleTolerance | Table Top Roll Angle Tolerance.
public Field | TableTopRollRotationDirection | Table Top Roll Rotation Direction.
public Field | TableTopVerticalPosition | Table Top Vertical Position.
public Field | TableTopVerticalPositionTolerance | Table Top Vertical Position Tolerance.
public Field | TableTopVerticalSetupDisplacement | Table Top Vertical Setup Displacement.
public Field | TableTraverse | Table Traverse.
public Field | TableType | Table Type.
public Field | TableVerticalIncrement | Table Vertical Increment.
public Field | TableXPositiontoIsocenter | Table X Position to Isocenter.
public Field | TableYPositiontoIsocenter | Table Y Position to Isocenter.
public Field | TableZPositiontoIsocenter | Table Z Position to Isocenter.
public Field | TagAngleFirstAxis | Tag Angle First Axis.
public Field | TagAngleSecondAxis | Tag Angle Second Axis.
public Field | Tagging | Tagging value.
public Field | TaggingDelay | Tagging Delay.
public Field | TagSpacingFirstDimension | Tag Spacing First Dimension.
public Field | TagSpacingSecondDimension | Tag Spacing Second Dimension.
public Field | TagThickness | Tag Thickness.
public Field | TargetMaximumDose | Target Maximum Dose.
public Field | TargetMinimumDose | Target Minimum Dose.
public Field | TargetPrescriptionDose | Target Prescription Dose.
public Field | TargetUnderdoseVolumeFraction | Target Underdose Volume Fraction.
public Field | TelephoneNumber | Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TelephoneNumberTrial | Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionCreatorUID | Template Extension Creator UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionFlag | Template Extension Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateExtensionOrganizationUID | Template Extension Organization UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateIdentifier | Template Identifier.
public Field | TemplateLocalVersion | Template Local Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemplateName | Template Name.
public Field | TemplateNumber | Template Number.
public Field | TemplateType | Template Type.
public Field | TemplateVersion | Template Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TemporalPositionIdentifier | Temporal Position Identifier.
public Field | TemporalPositionIndex | Temporal Position Index.
public Field | TemporalPositionSequence | Temporal Position Sequence.
public Field | TemporalPositionTimeOffset | Temporal Position Time Offset.
public Field | TemporalRangeType | Temporal Range Type.
public Field | TemporalResolution | Temporal Resolution.
public Field | TerminalType | Terminal Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TerminationCardiacTriggerCountThreshold | Termination Cardiac Trigger Count Threshold.
public Field | TerminationCountsThreshold | Termination Counts Threshold.
public Field | TerminationDensityThreshold | Termination Density Threshold.
public Field | TerminationRelativeDensityThreshold | Termination Relative Density Threshold.
public Field | TerminationRespiratoryTriggerCountThreshold | Termination Respiratory Trigger Count Threshold.
public Field | TerminationTimeThreshold | Termination Time Threshold.
public Field | TextComments | Text Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TextFormatID | Text Format ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TextObjectSequence | Text Object Sequence.
public Field | TextString | Text String.
public Field | TextValue | Text Value.
public Field | TherapyDescription | Therapy Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TherapyType | Therapy Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ThresholdDensity | Threshold Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TidOffset | TID Offset.
public Field | Time | Time value.
public Field | TimeBasedImageSetsSequence | Time Based Image Sets Sequence.
public Field | TimeDistributionProtocol | Time Distribution Protocol.
public Field | TimeDomainFiltering | Time Domain Filtering.
public Field | TimeOfFlightContrast | Time of Flight Contrast.
public Field | TimeOfFlightInformationUsed | Time of Flight Information Used.
public Field | TimeOfLastCalibration | Time of Last Calibration.
public Field | TimeOfLastDetectorCalibration | Time of Last Detector Calibration.
public Field | TimeOfSecondaryCapture | Time of Secondary Capture.
public Field | TimeRange | Time Range.
public Field | TimeSliceVector | Time Slice Vector.
public Field | TimeSlotInformationSequence | Time Slot Information Sequence.
public Field | TimeSlotNumber | Time Slot Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TimeSlotTime | Time Slot Time.
public Field | TimeSlotVector | Time Slot Vector.
public Field | TimeSource | Time Source.
public Field | TimezoneOffsetFromUTC | Timezone Offset From UTC.
public Field | TissueHeterogeneityCorrection | Tissue Heterogeneity Correction.
public Field | TmLinePositionX0 | TM-Line Position X0.
public Field | TMLinePositionX0Retired | TM-Line Position X0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionX1 | TM-Line Position X1.
public Field | TMLinePositionX1Retired | TM-Line Position X1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionY0 | TM-Line Position Y0.
public Field | TMLinePositionY0Retired | TM-Line Position Y0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TmLinePositionY1 | TM-Line Position Y1.
public Field | TMLinePositionY1Retired | TM-Line Position Y1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ToleranceTableLabel | Tolerance Table Label.
public Field | ToleranceTableNumber | Tolerance Table Number.
public Field | ToleranceTableSequence | Tolerance Table Sequence.
public Field | TomoAngle | Tomo Angle.
public Field | TomoClass | Tomo Class.
public Field | TomoLayerHeight | Tomo Layer Height.
public Field | TomoTime | Tomo Time.
public Field | TomoType | Tomo Type.
public Field | TopicAuthor | Topic Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicKeywords | Topic Keywords. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicSubject | Topic Subject. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TopicTitle | Topic Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalBlockTrayFactor | Total Block Tray Factor.
public Field | TotalBlockTrayWaterEquivalentThickness | Total Block Tray Water-Equivalent Thickness.
public Field | TotalCollimationWidth | Total Collimation Width.
public Field | TotalCompensatorTrayFactor | Total Compensator Tray Factor.
public Field | TotalCompensatorTrayWaterEquivalentThickness | Total Compensator Tray Water-Equivalent Thickness.
public Field | TotalGain | Total Gain. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalNumberofExposures | Total Number of Exposures.
public Field | TotalNumberofPiecesofMediaCreated | Total Number of Pieces of Media Created.
public Field | TotalReferenceAirKerma | Total Reference Air Kerma.
public Field | TotalTime | Total Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TotalTimeofFluoroscopy | Total Time of Fluoroscopy.
public Field | TotalWedgeTrayWaterEquivalentThickness | Total Wedge Tray Water-Equivalent Thickness.
public Field | TransactionUID | Transaction UID.
public Field | TransducerApplicationCodeSequence | Transducer Application Code Sequence.
public Field | TransducerBeamSteeringCodeSequence | Transducer Beam Steering Code Sequence.
public Field | TransducerData | Transducer Data.
public Field | TransducerFrequency | Transducer Frequency.
public Field | TransducerGeometryCodeSequence | Transducer Geometry Code Sequence.
public Field | TransducerOrientation | Transducer Orientation.
public Field | TransducerOrientationModifierSequence | Transducer Orientation Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerOrientationSequence | Transducer Orientation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerPosition | Transducer Position.
public Field | TransducerPositionModifierSequence | Transducer Position Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerPositionSequence | Transducer Position Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransducerScanPatternCodeSequence | Transducer Scan Pattern Code Sequence.
public Field | TransducerType | Transducer Type.
public Field | TransferSyntaxUID | Transfer Syntax UID. This tells whether the DICOM file uses big or little endian format, which compression is used, if any, and whether the file uses Implicit or Explicit Value Representation syntax.
public Field | TransferTubeLength | Transfer Tube Length.
public Field | TransferTubeNumber | Transfer Tube Number.
public Field | TransformLabel | Transform Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransformVersionNumber | Transform Version Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TransmitCoilManufacturerName | Transmit Coil Manufacturer Name.
public Field | TransmitCoilName | Transmit Coil Name.
public Field | TransmitCoilType | Transmit Coil Type.
public Field | TransmitterFrequency | Transmitter Frequency.
public Field | TransverseDetectorSeparation | Transverse Detector Separation.
public Field | TransverseMash | Transverse Mash.
public Field | TreatmentControlPointDate | Treatment Control Point Date.
public Field | TreatmentControlPointTime | Treatment Control Point Time.
public Field | TreatmentDate | Treatment Date.
public Field | TreatmentDeliveryType | Treatment Delivery Type.
public Field | TreatmentMachineName | Treatment Machine Name.
public Field | TreatmentMachineSequence | Treatment Machine Sequence.
public Field | TreatmentProtocols | Treatment Protocols.
public Field | TreatmentSessionApplicationSetupSequence | Treatment Session Application Setup Sequence.
public Field | TreatmentSessionBeamSequence | Treatment Session Beam Sequence.
public Field | TreatmentSessionIonBeamSequence | Treatment Session Ion Beam Sequence.
public Field | TreatmentSites | Treatment Sites.
public Field | TreatmentStatusComment | Treatment Status Comment.
public Field | TreatmentSummaryCalculatedDoseReferenceSequence | Treatment Summary Calculated Dose Reference Sequence.
public Field | TreatmentSummaryMeasuredDoseReferenceSequence | Treatment Summary Measured Dose Reference Sequence.
public Field | TreatmentTerminationCode | Treatment Termination Code.
public Field | TreatmentTerminationStatus | Treatment Termination Status.
public Field | TreatmentTime | Treatment Time.
public Field | TreatmentVerificationStatus | Treatment Verification Status.
public Field | TriangleFanSequence | Triangle Fan Sequence.
public Field | TrianglePointIndexList | Triangle Point Index List.
public Field | TriangleStripSequence | Triangle Strip Sequence.
public Field | TriggerSamplePosition | Trigger Sample Position.
public Field | TriggerSourceorType | Trigger Source or Type.
public Field | TriggerTime | Trigger Time.
public Field | TriggerTimeOffset | Trigger Time Offset.
public Field | TriggerVector | Trigger Vector.
public Field | TriggerWindow | Trigger Window.
public Field | Trim | Trim value.
public Field | TubeAngle | Tube Angle.
public Field | TypeOfData | Type of Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | TypeOfDetectorMotion | Type of Detector Motion.
public Field | TypeOfFilters | Type of Filters.
public Field | TypeOfPatientID | Type of Patient ID.
public Field | TypeOfSynchronization | Type of Synchronization.
public Field | UID | UID (unique identifier).
public Field | UltrasoundAcquisitionGeometry | Ultrasound Acquisition Geometry.
public Field | UltrasoundColorDataPresent | Ultrasound Color Data Present.
public Field | UnformattedTextValue | Unformatted Text Value.
public Field | UnifiedProcedureStepCommunicationsURISequence | Unified Procedure Step Communications URI Sequence.
public Field | UnifiedProcedureStepDiscontinuationReasonCodeSequence | Unified Procedure Step Discontinuation Reason Code Sequence.
public Field | UnifiedProcedureStepListStatus | Unified Procedure Step List Status.
public Field | UnifiedProcedureStepPerformedProcedureSequence | Unified Procedure Step Performed Procedure Sequence.
public Field | UnifiedProcedureStepProgress | Unified Procedure Step Progress.
public Field | UnifiedProcedureStepProgressDescription | Unified Procedure Step Progress Description.
public Field | UnifiedProcedureStepProgressInformationSequence | Unified Procedure Step Progress Information Sequence.
public Field | UnifiedProcedureStepState | Unified Procedure Step State.
public Field | Units | The Units.
public Field | UniversalEntityID | Universal Entity ID.
public Field | UniversalEntityIDType | Universal Entity ID Type.
public Field | UNKNOWN | Tag not found in the dictionary.
public Field | UnspecifiedLateralityLensSequence | Unspecified Laterality Lens Sequence.
public Field | UpperLowerPixelValues | Upper/Lower Pixel Values. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | UsedFiducialsSequence | Used Fiducials Sequence.
public Field | USImageDescriptionSequence | US Image Description Sequence.
public Field | ValueType | Value Type.
public Field | VariableCoefficientsSDDN | Variable Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableCoefficientsSDHN | Variable Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableCoefficientsSDVN | Variable Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariableFlipAngleFlag | Variable Flip Angle Flag.
public Field | VariableNextDataGroup | Variable Next Data Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VariablePixelData | Variable Pixel Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VectorAccuracy | Vector Accuracy.
public Field | VectorCoordinateData | Vector Coordinate Data.
public Field | VectorDimensionality | Vector Dimensionality.
public Field | VectorGridData | Vector Grid Data.
public Field | VelocityEncodingDirection | Velocity Encoding Direction.
public Field | VelocityEncodingMaximumValue | Velocity Encoding Maximum Value.
public Field | VelocityEncodingMinimumValue | Velocity Encoding Minimum Value.
public Field | VerificationDateTime | Verification Date Time.
public Field | VerificationFlag | Verification Flag.
public Field | VerificationImageTiming | Verification Image Timing.
public Field | VerifyingObserverIdentificationCodeSequence | Verifying Observer Identification Code Sequence.
public Field | VerifyingObserverName | Verifying Observer Name.
public Field | VerifyingObserverSequence | Verifying Observer Sequence.
public Field | VerifyingOrganization | Verifying Organization.
public Field | VertexPointIndexList | Vertex Point Index List.
public Field | VerticalPrismBase | Vertical Prism Base.
public Field | VerticalPrismPower | Vertical Prism Power.
public Field | VerticesOfThePolygonalCollimator | Vertices of the Polygonal Collimator.
public Field | VerticesOfThePolygonalExposureControlSensingRegion | Vertices of the Polygonal Exposure Control Sensing Region.
public Field | VerticesOfThePolygonalShutter | Vertices of the Polygonal Shutter.
public Field | VerticesOfTheRegion | Vertices of the Region.
public Field | VideoImageFormatAcquired | Video Image Format Acquired.
public Field | ViewCodeSequence | View Code Sequence.
public Field | ViewingDistance | Viewing Distance.
public Field | ViewingDistanceType | Viewing Distance Type.
public Field | ViewModifierCodeSequence | View Modifier Code Sequence.
public Field | ViewName | View Name.
public Field | ViewNumber | View Number.
public Field | ViewPosition | View Position.
public Field | VirtualSourceAxisDistances | Virtual Source-Axis Distances.
public Field | VisitComments | Visit Comments.
public Field | VisitStatusID | Visit Status ID.
public Field | VisualAcuityBothEyesOpenSequence | Visual Acuity Both Eyes Open Sequence.
public Field | VisualAcuityLeftEyeSequence | Visual Acuity Left Eye Sequence.
public Field | VisualAcuityModifiers | Visual Acuity Modifiers.
public Field | VisualAcuityRightEyeSequence | Visual Acuity Right Eye Sequence.
public Field | VisualAcuityTypeCodeSequence | Visual Acuity Type Code Sequence.
public Field | VitalStainCodeSequence | Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VitalStainCodeSequenceTrial | Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | VOILUTFunction | VOI LUT Function.
public Field | VOILUTSequence | VOI LUT Sequence.
public Field | VOIType | VOI (Value Of Interest) Type.
public Field | VolumeBasedCalculationTechnique | Volume Based Calculation Technique.
public Field | VolumeFrameOfReferenceUID | Volume Frame of Reference UID.
public Field | VolumeLocalizationSequence | Volume Localization Sequence.
public Field | VolumeLocalizationTechnique | Volume Localization Technique.
public Field | VolumeToTableMappingMatrix | Volume to Table Mapping Matrix.
public Field | VolumeToTransducerMappingMatrix | Volume to Transducer Mapping Matrix.
public Field | VolumetricProperties | Volumetric Properties.
public Field | WaterReferencedPhaseCorrection | Water Referenced Phase Correction.
public Field | WaveformAnnotationSequence | Waveform Annotation Sequence.
public Field | WaveformBitsAllocated | Waveform Bits Allocated.
public Field | WaveformBitsStored | Waveform Bits Stored.
public Field | WaveformChannelNumber | Waveform Channel Number.
public Field | WaveformData | Waveform Data.
public Field | WaveformDataDisplayScale | Waveform Data Display Scale.
public Field | WaveformDisplayBackgroundCIELabValue | Waveform Display Background CIELab Value.
public Field | WaveformOriginality | Waveform Originality.
public Field | WaveformPaddingValue | Waveform Padding Value.
public Field | WaveformPresentationGroupSequence | Waveform Presentation Group Sequence.
public Field | WaveformSampleInterpretation | Waveform Sample Interpretation.
public Field | WaveformSampleValueRepresentation | Waveform Sample Value Representation.
public Field | WaveformSequence | Waveform Sequence.
public Field | WedgeAngle | Wedge Angle.
public Field | WedgeFactor | Wedge Factor.
public Field | WedgeID | Wedge Identifier.
public Field | WedgeNumber | Wedge Number.
public Field | WedgeOrientation | Wedge Orientation.
public Field | WedgePosition | Wedge Position.
public Field | WedgePositionSequence | Wedge Position Sequence.
public Field | WedgeSequence | Wedge Sequence.
public Field | WedgeThinEdgePosition | Wedge Thin Edge Position.
public Field | WedgeType | Wedge Type.
public Field | WholeBodyTechnique | Whole Body Technique.
public Field | WindowCenter | Window Center.
public Field | WindowCenterAndWidthExplanation | Window Center and Width Explanation.
public Field | WindowWidth | Window Width.
public Field | WorklistLabel | Worklist Label.
public Field | XA_XRFFrameCharacteristicsSequence | XA/XRF Frame Characteristics Sequence.
public Field | XFocusCenter | X Focus Center.
public Field | XOffsetInSlideCoordinateSystem | X offset in Slide Coordinate System.
public Field | XRay3DAcquisitionSequence | X-Ray 3D Acquisition Sequence.
public Field | XRay3DFrameTypeSequence | X-Ray 3D Frame Type Sequence.
public Field | XRay3DReconstructionSequence | X-Ray 3D Reconstruction Sequence.
public Field | XRayGeometrySequence | X-Ray Geometry Sequence.
public Field | XrayImageReceptorAngle | X-Ray Image Receptor Angle.
public Field | XRayImageReceptorTranslation | X-Ray Image Receptor Translation.
public Field | XrayOutput | X-Ray Output.
public Field | XRayReceptorType | X-Ray Receptor Type.
public Field | XRayTubeCurrent | X-Ray Tube Current.
public Field | XRayTubeCurrentInMilliA | X-Ray Tube Current in mA.
public Field | XRayTubeCurrentInuA | X-Ray Tube Current in micro A.
public Field | YFocusCenter | Y Focus Center.
public Field | YOffsetInSlideCoordinateSystem | Y offset in Slide Coordinate System.
public Field | ZOffsetInSlideCoordinateSystem | Z offset in Slide Coordinate System.
public Field | ZonalMap | Zonal Map. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapFormat | Zonal Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapLocation | Zonal Map Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZonalMapNumberFormat | Zonal Map Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.
public Field | ZoomCenter | Zoom Center.
public Field | ZoomFactor | Zoom Factor.
Top

See Also

Reference

ImGearDICOMTagsIDs Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

AbsoluteChannelDisplayScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AbsoluteChannelDisplayScale Field

Glossary Item Box

Absolute Channel Display Scale.

Syntax

public int AbsoluteChannelDisplayScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AbstractPriorCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AbstractPriorCodeSequence Field

Glossary Item Box

Abstract Prior Code Sequence.

Syntax

public int AbstractPriorCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AbstractPriorValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AbstractPriorValue Field

Glossary Item Box

Abstract Prior Value.

Syntax

public int AbstractPriorValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AccessionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AccessionNumber Field

Glossary Item Box

Accession Number.

Syntax

public int AccessionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AccessoryCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AccessoryCode Field

Glossary Item Box

Accessory Code.

Syntax

public int AccessoryCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquiredImageAreaDoseProduct Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquiredImageAreaDoseProduct Field

Glossary Item Box

Acquired Image Area Dose Product.

Syntax

public int AcquiredImageAreaDoseProduct

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionComments Field

Glossary Item Box

Acquisition Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AcquisitionComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionContextDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionContextDescription Field

Glossary Item Box

Acquisition Context Description.

Syntax

public int AcquisitionContextDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionContextSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionContextSequence Field

Glossary Item Box

Acquisition Context Sequence.

Syntax

public int AcquisitionContextSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionContrast Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionContrast Field

Glossary Item Box

Acquisition Contrast.

Syntax

public int AcquisitionContrast

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDate Field

Glossary Item Box

Acquisition Date.

Syntax

public int AcquisitionDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDateTime Field

Glossary Item Box

Acquisition DateTime.

Syntax

public int AcquisitionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDeviceProcessingCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDeviceProcessingCode Field

Glossary Item Box

Acquisition Device Processing Code.

Syntax

public int AcquisitionDeviceProcessingCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDeviceProcessingDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDeviceProcessingDescription Field

Glossary Item Box

Acquisition Device Processing Description.

Syntax

public int AcquisitionDeviceProcessingDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDeviceTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDeviceTypeCodeSequence Field

Glossary Item Box

Acquisition Device Type Code Sequence.

Syntax

public int AcquisitionDeviceTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionDuration Field

Glossary Item Box

Acquisition Duration.

Syntax

public int AcquisitionDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionIndex Field

Glossary Item Box

Acquisition Index.

Syntax

public int AcquisitionIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionMatrix Field

Glossary Item Box

Acquisition Matrix.

Syntax

public int AcquisitionMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionNumber Field

Glossary Item Box

Acquisition Number.

Syntax

public int AcquisitionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionProtocolDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionProtocolDescription Field

Glossary Item Box

Acquisition Protocol Description.

Syntax

public int AcquisitionProtocolDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionProtocolName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionProtocolName Field

Glossary Item Box

Acquisition Protocol Name.

Syntax

public int AcquisitionProtocolName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionsInSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionsInSeries Field

Glossary Item Box

Acquisitions in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AcquisitionsInSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionsInStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionsInStudy Field

Glossary Item Box

Acquisitions in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AcquisitionsInStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionStartCondition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionStartCondition Field

Glossary Item Box

Acquisition Start Condition.

Syntax

public int AcquisitionStartCondition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionStartConditionData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionStartConditionData Field

Glossary Item Box

Acquisition Start Condition Data.

Syntax

public int AcquisitionStartConditionData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionTerminationCondition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionTerminationCondition Field

Glossary Item Box

Acquisition Termination Condition.

Syntax

public int AcquisitionTerminationCondition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionTerminationConditionData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionTerminationConditionData Field

Glossary Item Box

Acquisition Termination Condition Data.

Syntax

public int AcquisitionTerminationConditionData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionTime Field

Glossary Item Box

Acquisition Time.

Syntax

public int AcquisitionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionTimeSynchronized Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionTimeSynchronized Field

Glossary Item Box

Acquisition Time Synchronized.

Syntax

public int AcquisitionTimeSynchronized

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcquisitionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcquisitionType Field

Glossary Item Box

Acquisition Type.

Syntax

public int AcquisitionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AcrossScanSpatialResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AcrossScanSpatialResolution Field

Glossary Item Box

Across-scan Spatial Resolution.

Syntax

public int AcrossScanSpatialResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActionTypeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActionTypeID Field

Glossary Item Box

Action Type ID.

Syntax

public int ActionTypeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActiveSourceDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActiveSourceDiameter Field

Glossary Item Box

Active Source Diameter.

Syntax

public int ActiveSourceDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActiveSourceLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActiveSourceLength Field

Glossary Item Box

Active Source Length.

Syntax

public int ActiveSourceLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActualCardiacTriggerDelayTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActualCardiacTriggerDelayTime Field

Glossary Item Box

Actual Cardiac Trigger Delay Time.

Syntax

public int ActualCardiacTriggerDelayTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActualFrameDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActualFrameDuration Field

Glossary Item Box

Actual Frame Duration.

Syntax

public int ActualFrameDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActualHumanPerformersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActualHumanPerformersSequence Field

Glossary Item Box

Actual Human Performers Sequence.

Syntax

public int ActualHumanPerformersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ActualRespiratoryTriggerDelayTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ActualRespiratoryTriggerDelayTime Field

Glossary Item Box

Actual Respiratory Trigger Delay Time.

Syntax

public int ActualRespiratoryTriggerDelayTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdaptiveMapFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdaptiveMapFormat Field

Glossary Item Box

Adaptive Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AdaptiveMapFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddGrayScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddGrayScale Field

Glossary Item Box

Add Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AddGrayScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddIntermediateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddIntermediateSequence Field

Glossary Item Box

Add Intermediate Sequence.

Syntax

public int AddIntermediateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdditionalDrugSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdditionalDrugSequence Field

Glossary Item Box

Additional Drug Sequence.

Syntax

public int AdditionalDrugSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdditionalPatientHistory Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdditionalPatientHistory Field

Glossary Item Box

Additional Patient History.

Syntax

public int AdditionalPatientHistory

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddNearSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddNearSequence Field

Glossary Item Box

Add Near Sequence.

Syntax

public int AddNearSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddOtherSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddOtherSequence Field

Glossary Item Box

Add Other Sequence.

Syntax

public int AddOtherSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddPower Field

Glossary Item Box

Add Power.

Syntax

public int AddPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Address Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Address Field

Glossary Item Box

Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Address

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AddressTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AddressTrial Field

Glossary Item Box

Address - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AddressTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdministrationRouteCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdministrationRouteCodeSequence Field

Glossary Item Box

Administration Route Code Sequence.

Syntax

public int AdministrationRouteCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdmissionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdmissionID Field

Glossary Item Box

Admission ID.

Syntax

public int AdmissionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdmittingDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdmittingDate Field

Glossary Item Box

Admitting Date.

Syntax

public int AdmittingDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdmittingDiagnosesCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdmittingDiagnosesCodeSequence Field

Glossary Item Box

Admitting Diagnoses Code Sequence.

Syntax

public int AdmittingDiagnosesCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdmittingDiagnosesDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdmittingDiagnosesDescription Field

Glossary Item Box

Admitting Diagnoses Description.

Syntax

public int AdmittingDiagnosesDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AdmittingTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AdmittingTime Field

Glossary Item Box

Admitting Time.

Syntax

public int AdmittingTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AffectedSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AffectedSOPClassUID Field

Glossary Item Box

Affected SOP Class UID.

Syntax

public int AffectedSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AffectedSOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AffectedSOPInstanceUID Field

Glossary Item Box

Affected SOP Instance UID.

Syntax

public int AffectedSOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlertCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlertCodeSequence Field

Glossary Item Box

Alert Code Sequence.

Syntax

public int AlertCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmDescription Field

Glossary Item Box

Algorithm Description.

Syntax

public int AlgorithmDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmFamilyCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmFamilyCodeSequence Field

Glossary Item Box

Algorithm Family Code Sequence.

Syntax

public int AlgorithmFamilyCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmName Field

Glossary Item Box

Algorithm Name.

Syntax

public int AlgorithmName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmNameCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmNameCodeSequence Field

Glossary Item Box

Algorithm Name Code Sequence.

Syntax

public int AlgorithmNameCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmParameters Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmParameters Field

Glossary Item Box

Algorithm Parameters.

Syntax

public int AlgorithmParameters

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmType Field

Glossary Item Box

Algorithm Type.

Syntax

public int AlgorithmType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlgorithmVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlgorithmVersion Field

Glossary Item Box

Algorithm Version.

Syntax

public int AlgorithmVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AliasedDataType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AliasedDataType Field

Glossary Item Box

Aliased Data Type.

Syntax

public int AliasedDataType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Allergies Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Allergies Field

Glossary Item Box

Allergies value.

Syntax

public int Allergies

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AllowLossyCompression Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AllowLossyCompression Field

Glossary Item Box

Allow Lossy Compression.

Syntax

public int AllowLossyCompression

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AllowMediaSplitting Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AllowMediaSplitting Field

Glossary Item Box

Allow Media Splitting.

Syntax

public int AllowMediaSplitting

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlongScanSpatialResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlongScanSpatialResolution Field

Glossary Item Box

Along-scan Spatial Resolution.

Syntax

public int AlongScanSpatialResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlphaLUTTransferFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlphaLUTTransferFunction Field

Glossary Item Box

Alpha LUT Transfer Function.

Syntax

public int AlphaLUTTransferFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlphaPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlphaPaletteColorLookupTableData Field

Glossary Item Box

Alpha Palette Color Lookup Table Data.

Syntax

public int AlphaPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlphaPaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlphaPaletteColorLookupTableDescriptor Field

Glossary Item Box

Alpha Palette Color Lookup Table Descriptor.

Syntax

public int AlphaPaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlternateContainerIdentifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlternateContainerIdentifierSequence Field

Glossary Item Box

Alternate Container Identifier Sequence.

Syntax

public int AlternateContainerIdentifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlternateContentDescriptionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlternateContentDescriptionSequence Field

Glossary Item Box

Alternate Content Description Sequence.

Syntax

public int AlternateContentDescriptionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AlternateRepresentationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AlternateRepresentationSequence Field

Glossary Item Box

Alternate Representation Sequence.

Syntax

public int AlternateRepresentationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicalOrientationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicalOrientationType Field

Glossary Item Box

Anatomical Orientation Type.

Syntax

public int AnatomicalOrientationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicApproachDirectionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicApproachDirectionCodeSequence Field

Glossary Item Box

Anatomic Approach Direction Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicApproachDirectionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicLocationOfExaminingInstrumentCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicLocationOfExaminingInstrumentCodeSequence Field

Glossary Item Box

Anatomic Location Of Examining Instrument Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicLocationOfExaminingInstrumentCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicLocationOfExaminingInstrumentDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicLocationOfExaminingInstrumentDescription Field

Glossary Item Box

Anatomic Location Of Examining Instrument Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicLocationOfExaminingInstrumentDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicPerspectiveCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicPerspectiveCodeSequence Field

Glossary Item Box

Anatomic Perspective Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicPerspectiveCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicPerspectiveDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicPerspectiveDescription Field

Glossary Item Box

Anatomic Perspective Description (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicPerspectiveDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicPortalOfEntranceCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicPortalOfEntranceCodeSequence Field

Glossary Item Box

Anatomic Portal Of Entrance Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicPortalOfEntranceCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicRegionModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicRegionModifierSequence Field

Glossary Item Box

Anatomic Region Modifier Sequence.

Syntax

public int AnatomicRegionModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicRegionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicRegionSequence Field

Glossary Item Box

Anatomic Region Sequence.

Syntax

public int AnatomicRegionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicStructure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicStructure Field

Glossary Item Box

Anatomic Structure.

Syntax

public int AnatomicStructure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicStructureSpaceOrRegionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicStructureSpaceOrRegionCodeSequence Field

Glossary Item Box

Anatomic Structure Space Or Region Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicStructureSpaceOrRegionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicStructureSpaceOrRegionModifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicStructureSpaceOrRegionModifierCodeSequence Field

Glossary Item Box

Anatomic Structure Space Or Region Modifier Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnatomicStructureSpaceOrRegionModifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnatomicStructureSpaceOrRegionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnatomicStructureSpaceOrRegionSequence Field

Glossary Item Box

Anatomic Structure, Space or Region Sequence.

Syntax

public int AnatomicStructureSpaceOrRegionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnchorPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnchorPoint Field

Glossary Item Box

Anchor Point.

Syntax

public int AnchorPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnchorPointAnnotationUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnchorPointAnnotationUnits Field

Glossary Item Box

Anchor Point Annotation Units.

Syntax

public int AnchorPointAnnotationUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnchorPointVisibility Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnchorPointVisibility Field

Glossary Item Box

Anchor Point Visibility.

Syntax

public int AnchorPointVisibility

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AngioFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AngioFlag Field

Glossary Item Box

Angio Flag.

Syntax

public int AngioFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AngleNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AngleNumber Field

Glossary Item Box

Angle Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AngleNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AngularPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AngularPosition Field

Glossary Item Box

Angular Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AngularPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AngularStep Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AngularStep Field

Glossary Item Box

Angular Step.

Syntax

public int AngularStep

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AngularViewVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AngularViewVector Field

Glossary Item Box

Angular View Vector.

Syntax

public int AngularViewVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnnotationContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnnotationContentSequence Field

Glossary Item Box

Annotation Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnnotationContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnnotationDisplayFormatID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnnotationDisplayFormatID Field

Glossary Item Box

Annotation Display Format ID.

Syntax

public int AnnotationDisplayFormatID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnnotationFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnnotationFlag Field

Glossary Item Box

Annotation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AnnotationFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnnotationGroupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnnotationGroupNumber Field

Glossary Item Box

Annotation Group Number.

Syntax

public int AnnotationGroupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnnotationPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnnotationPosition Field

Glossary Item Box

Annotation Position.

Syntax

public int AnnotationPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AnodeTargetMaterial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AnodeTargetMaterial Field

Glossary Item Box

Anode Target Material.

Syntax

public int AnodeTargetMaterial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApexPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApexPosition Field

Glossary Item Box

Apex Position.

Syntax

public int ApexPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicableFrameRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicableFrameRange Field

Glossary Item Box

Applicable Frame Range.

Syntax

public int ApplicableFrameRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicableSafetyStandardAgency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicableSafetyStandardAgency Field

Glossary Item Box

Applicable Safety Standard Agency.

Syntax

public int ApplicableSafetyStandardAgency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicableSafetyStandardDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicableSafetyStandardDescription Field

Glossary Item Box

Applicable Safety Standard Description.

Syntax

public int ApplicableSafetyStandardDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationManufacturer Field

Glossary Item Box

Application Manufacturer.

Syntax

public int ApplicationManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationMaximumRepaintTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationMaximumRepaintTime Field

Glossary Item Box

Application Maximum Repaint Time.

Syntax

public int ApplicationMaximumRepaintTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationName Field

Glossary Item Box

Application Name.

Syntax

public int ApplicationName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupCheck Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupCheck Field

Glossary Item Box

Application Setup Check.

Syntax

public int ApplicationSetupCheck

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupManufacturer Field

Glossary Item Box

Application Setup Manufacturer.

Syntax

public int ApplicationSetupManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupName Field

Glossary Item Box

Application Setup Name.

Syntax

public int ApplicationSetupName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupNumber Field

Glossary Item Box

Application Setup Number.

Syntax

public int ApplicationSetupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupSequence Field

Glossary Item Box

Application Setup Sequence.

Syntax

public int ApplicationSetupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationSetupType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationSetupType Field

Glossary Item Box

Application Setup Type.

Syntax

public int ApplicationSetupType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicationVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicationVersion Field

Glossary Item Box

Application Version.

Syntax

public int ApplicationVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicatorDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicatorDescription Field

Glossary Item Box

Applicator Description.

Syntax

public int ApplicatorDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicatorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicatorID Field

Glossary Item Box

Applicator ID.

Syntax

public int ApplicatorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicatorSequence Field

Glossary Item Box

Applicator Sequence.

Syntax

public int ApplicatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApplicatorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApplicatorType Field

Glossary Item Box

Applicator Type.

Syntax

public int ApplicatorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApprovalStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApprovalStatus Field

Glossary Item Box

Approval Status.

Syntax

public int ApprovalStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApprovalStatusDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApprovalStatusDateTime Field

Glossary Item Box

Approval Status DateTime.

Syntax

public int ApprovalStatusDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ApprovalStatusFurtherDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ApprovalStatusFurtherDescription Field

Glossary Item Box

Approval Status Further Description.

Syntax

public int ApprovalStatusFurtherDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Arbitrary Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Arbitrary Field

Glossary Item Box

Arbitrary. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Arbitrary

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ArchiveRequested Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ArchiveRequested Field

Glossary Item Box

Archive Requested.

Syntax

public int ArchiveRequested

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AssigningAgencyOrDepartmentCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AssigningAgencyOrDepartmentCodeSequence Field

Glossary Item Box

Assigning Agency or Department Code Sequence.

Syntax

public int AssigningAgencyOrDepartmentCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AssigningFacilitySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AssigningFacilitySequence Field

Glossary Item Box

Assigning Facility Sequence.

Syntax

public int AssigningFacilitySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AssigningJurisdictionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AssigningJurisdictionCodeSequence Field

Glossary Item Box

Assigning Jurisdiction Code Sequence.

Syntax

public int AssigningJurisdictionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttachedContours Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttachedContours Field

Glossary Item Box

Attached Contours.

Syntax

public int AttachedContours

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttenuationCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttenuationCorrected Field

Glossary Item Box

Attenuation Corrected.

Syntax

public int AttenuationCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttenuationCorrectionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttenuationCorrectionMethod Field

Glossary Item Box

Attenuation Correction Method.

Syntax

public int AttenuationCorrectionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttenuationCorrectionSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttenuationCorrectionSource Field

Glossary Item Box

Attenuation Correction Source.

Syntax

public int AttenuationCorrectionSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttenuationCorrectionTemporalRelationship Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttenuationCorrectionTemporalRelationship Field

Glossary Item Box

Attenuation Correction Temporal Relationship.

Syntax

public int AttenuationCorrectionTemporalRelationship

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeIdentifierList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeIdentifierList Field

Glossary Item Box

Attribute Identifier List.

Syntax

public int AttributeIdentifierList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeItemSelector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeItemSelector Field

Glossary Item Box

Attribute Item Selector.

Syntax

public int AttributeItemSelector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeModificationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeModificationDateTime Field

Glossary Item Box

Attribute Modification DateTime.

Syntax

public int AttributeModificationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeOccurrencePointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeOccurrencePointer Field

Glossary Item Box

Attribute Occurrence Pointer.

Syntax

public int AttributeOccurrencePointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeOccurrencePrivateCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeOccurrencePrivateCreator Field

Glossary Item Box

Attribute Occurrence Private Creator.

Syntax

public int AttributeOccurrencePrivateCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AttributeOccurrenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AttributeOccurrenceSequence Field

Glossary Item Box

Attribute Occurrence Sequence.

Syntax

public int AttributeOccurrenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AudioComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AudioComments Field

Glossary Item Box

Audio Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AudioComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AudioSampleData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AudioSampleData Field

Glossary Item Box

Audio Sample Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AudioSampleData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AudioSampleFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AudioSampleFormat Field

Glossary Item Box

Audio Sample Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AudioSampleFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AudioType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AudioType Field

Glossary Item Box

Audio Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AudioType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AuthorizationEquipmentCertificationNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AuthorizationEquipmentCertificationNumber Field

Glossary Item Box

Authorization Equipment Certification Number.

Syntax

public int AuthorizationEquipmentCertificationNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AuthorObserverSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AuthorObserverSequence Field

Glossary Item Box

Author Observer Sequence.

Syntax

public int AuthorObserverSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AutorefractionLeftEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AutorefractionLeftEyeSequence Field

Glossary Item Box

Autorefraction Left Eye Sequence.

Syntax

public int AutorefractionLeftEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AutorefractionRightEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AutorefractionRightEyeSequence Field

Glossary Item Box

Autorefraction Right Eye Sequence.

Syntax

public int AutorefractionRightEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AveragePulseWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AveragePulseWidth Field

Glossary Item Box

Average Pulse Width.

Syntax

public int AveragePulseWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxialAcceptance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxialAcceptance Field

Glossary Item Box

Axial Acceptance.

Syntax

public int AxialAcceptance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxialDetectorDimension Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxialDetectorDimension Field

Glossary Item Box

Axial Detector Dimension.

Syntax

public int AxialDetectorDimension

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxialLengthOfTheEye Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxialLengthOfTheEye Field

Glossary Item Box

Axial Length of the Eye.

Syntax

public int AxialLengthOfTheEye

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxialMash Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxialMash Field

Glossary Item Box

Axial Mash.

Syntax

public int AxialMash

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxisLabels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxisLabels Field

Glossary Item Box

Axis Labels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AxisLabels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxisOfRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxisOfRotation Field

Glossary Item Box

Axis of Rotation.

Syntax

public int AxisOfRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

AxisUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : AxisUnits Field

Glossary Item Box

Axis Units. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int AxisUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BackgroundColor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BackgroundColor Field

Glossary Item Box

Background Color.

Syntax

public int BackgroundColor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BarcodeSymbology Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BarcodeSymbology Field

Glossary Item Box

Barcode Symbology.

Syntax

public int BarcodeSymbology

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BarcodeValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BarcodeValue Field

Glossary Item Box

Barcode Value.

Syntax

public int BarcodeValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BaselineCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BaselineCorrection Field

Glossary Item Box

Baseline Correction.

Syntax

public int BaselineCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BasicColorImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BasicColorImageSequence Field

Glossary Item Box

Basic Color Image Sequence.

Syntax

public int BasicColorImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BasicGrayscaleImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BasicGrayscaleImageSequence Field

Glossary Item Box

Basic Grayscale Image Sequence.

Syntax

public int BasicGrayscaleImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamAngle Field

Glossary Item Box

Beam Angle.

Syntax

public int BeamAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamCurrentModulationID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamCurrentModulationID Field

Glossary Item Box

Beam Current Modulation ID.

Syntax

public int BeamCurrentModulationID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDescription Field

Glossary Item Box

Beam Description.

Syntax

public int BeamDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDose Field

Glossary Item Box

Beam Dose.

Syntax

public int BeamDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDosePointDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDosePointDepth Field

Glossary Item Box

Beam Dose Point Depth.

Syntax

public int BeamDosePointDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDosePointEquivalentDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDosePointEquivalentDepth Field

Glossary Item Box

Beam Dose Point Equivalent Depth.

Syntax

public int BeamDosePointEquivalentDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDosePointSSD Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDosePointSSD Field

Glossary Item Box

Beam Dose Point SSD.

Syntax

public int BeamDosePointSSD

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamDoseSpecificationPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamDoseSpecificationPoint Field

Glossary Item Box

Beam Dose Specification Point.

Syntax

public int BeamDoseSpecificationPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceAngle Field

Glossary Item Box

Beam Limiting Device Angle.

Syntax

public int BeamLimitingDeviceAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceAngleTolerance Field

Glossary Item Box

Beam Limiting Device Angle Tolerance.

Syntax

public int BeamLimitingDeviceAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceLeafPairsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceLeafPairsSequence Field

Glossary Item Box

Beam Limiting Device Leaf Pairs Sequence.

Syntax

public int BeamLimitingDeviceLeafPairsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDevicePositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDevicePositionSequence Field

Glossary Item Box

Beam Limiting Device Position Sequence.

Syntax

public int BeamLimitingDevicePositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDevicePositionTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDevicePositionTolerance Field

Glossary Item Box

Beam Limiting Device Position Tolerance.

Syntax

public int BeamLimitingDevicePositionTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceRotationDirection Field

Glossary Item Box

Beam Limiting Device Rotation Direction.

Syntax

public int BeamLimitingDeviceRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceSequence Field

Glossary Item Box

Beam Limiting Device Sequence.

Syntax

public int BeamLimitingDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamLimitingDeviceToleranceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamLimitingDeviceToleranceSequence Field

Glossary Item Box

Beam Limiting Device Tolerance Sequence.

Syntax

public int BeamLimitingDeviceToleranceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamMeterset Field

Glossary Item Box

Beam Meterset.

Syntax

public int BeamMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamName Field

Glossary Item Box

Beam Name.

Syntax

public int BeamName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamNumber Field

Glossary Item Box

Beam Number.

Syntax

public int BeamNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamOrderIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamOrderIndex Field

Glossary Item Box

Beam Order Index.

Syntax

public int BeamOrderIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamSequence Field

Glossary Item Box

Beam Sequence.

Syntax

public int BeamSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamStopperPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamStopperPosition Field

Glossary Item Box

Beam Stopper Position.

Syntax

public int BeamStopperPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamTaskSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamTaskSequence Field

Glossary Item Box

Beam Task Sequence.

Syntax

public int BeamTaskSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamTaskType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamTaskType Field

Glossary Item Box

Beam Task Type.

Syntax

public int BeamTaskType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeamType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeamType Field

Glossary Item Box

Beam Type.

Syntax

public int BeamType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BeatRejectionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BeatRejectionFlag Field

Glossary Item Box

Beat Rejection Flag.

Syntax

public int BeatRejectionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BillingItemSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BillingItemSequence Field

Glossary Item Box

Billing Item Sequence.

Syntax

public int BillingItemSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BillingProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BillingProcedureStepSequence Field

Glossary Item Box

Billing Procedure Step Sequence.

Syntax

public int BillingProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BillingSuppliesAndDevicesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BillingSuppliesAndDevicesSequence Field

Glossary Item Box

Billing Supplies and Devices Sequence.

Syntax

public int BillingSuppliesAndDevicesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BiPlaneAcquisitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BiPlaneAcquisitionSequence Field

Glossary Item Box

Bi-Plane Acquisition Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BiPlaneAcquisitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BitsAllocated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BitsAllocated Field

Glossary Item Box

Bits Allocated.

Syntax

public int BitsAllocated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BitsForCodeWord Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BitsForCodeWord Field

Glossary Item Box

Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BitsForCodeWord

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BitsGrouped Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BitsGrouped Field

Glossary Item Box

Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BitsGrouped

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BitsMappedToColorLookupTable Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BitsMappedToColorLookupTable Field

Glossary Item Box

Bits Mapped to Color Lookup Table.

Syntax

public int BitsMappedToColorLookupTable

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BitsStored Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BitsStored Field

Glossary Item Box

Bits Stored.

Syntax

public int BitsStored

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLookupTableData Field

Glossary Item Box

Blending Lookup Table Data.

Syntax

public int BlendingLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLookupTableDescriptor Field

Glossary Item Box

Blending Lookup Table Descriptor.

Syntax

public int BlendingLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLUT1Sequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLUT1Sequence Field

Glossary Item Box

Blending LUT 1 Sequence.

Syntax

public int BlendingLUT1Sequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLUT1TransferFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLUT1TransferFunction Field

Glossary Item Box

Blending LUT 1 Transfer Function.

Syntax

public int BlendingLUT1TransferFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLUT2Sequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLUT2Sequence Field

Glossary Item Box

Blending LUT 2 Sequence.

Syntax

public int BlendingLUT2Sequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingLUT2TransferFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingLUT2TransferFunction Field

Glossary Item Box

Blending LUT 2 Transfer Function.

Syntax

public int BlendingLUT2TransferFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingOperationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingOperationType Field

Glossary Item Box

Blending Operation Type.

Syntax

public int BlendingOperationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingPosition Field

Glossary Item Box

Blending Position.

Syntax

public int BlendingPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingSequence Field

Glossary Item Box

Blending Sequence.

Syntax

public int BlendingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlendingWeightConstant Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlendingWeightConstant Field

Glossary Item Box

Blending Weight Constant.

Syntax

public int BlendingWeightConstant

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockColumns Field

Glossary Item Box

Block Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BlockColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockData Field

Glossary Item Box

Block Data.

Syntax

public int BlockData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockDivergence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockDivergence Field

Glossary Item Box

Block Divergence.

Syntax

public int BlockDivergence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockedPixels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockedPixels Field

Glossary Item Box

Blocked Pixels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BlockedPixels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockMountingPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockMountingPosition Field

Glossary Item Box

Block Mounting Position.

Syntax

public int BlockMountingPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockName Field

Glossary Item Box

Block Name.

Syntax

public int BlockName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockNumber Field

Glossary Item Box

Block Number.

Syntax

public int BlockNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockNumberOfPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockNumberOfPoints Field

Glossary Item Box

Block Number of Points.

Syntax

public int BlockNumberOfPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockRows Field

Glossary Item Box

Block Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BlockRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockSequence Field

Glossary Item Box

Block Sequence.

Syntax

public int BlockSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockThickness Field

Glossary Item Box

Block Thickness.

Syntax

public int BlockThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockTransmission Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockTransmission Field

Glossary Item Box

Block Transmission.

Syntax

public int BlockTransmission

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockTrayID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockTrayID Field

Glossary Item Box

Block Tray ID.

Syntax

public int BlockTrayID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BlockType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BlockType Field

Glossary Item Box

Block Type.

Syntax

public int BlockType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BloodSignalNulling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BloodSignalNulling Field

Glossary Item Box

Blood Signal Nulling.

Syntax

public int BloodSignalNulling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BluePaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BluePaletteColorLookupTableData Field

Glossary Item Box

Blue Palette Color Lookup Table Data.

Syntax

public int BluePaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BluePaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BluePaletteColorLookupTableDescriptor Field

Glossary Item Box

Blue Palette Color Lookup Table Descriptor.

Syntax

public int BluePaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BodyPartExamined Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BodyPartExamined Field

Glossary Item Box

Body Part Examined.

Syntax

public int BodyPartExamined

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BodyPartThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BodyPartThickness Field

Glossary Item Box

Body Part Thickness.

Syntax

public int BodyPartThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BolusDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BolusDescription Field

Glossary Item Box

Bolus Description.

Syntax

public int BolusDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BolusID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BolusID Field

Glossary Item Box

Bolus Identifier.

Syntax

public int BolusID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BoneThermalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BoneThermalIndex Field

Glossary Item Box

Bone Thermal Index.

Syntax

public int BoneThermalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BorderDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BorderDensity Field

Glossary Item Box

Border Density.

Syntax

public int BorderDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Borders Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Borders Field

Glossary Item Box

Borders. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Borders

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BoundingBoxAnnotationUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BoundingBoxAnnotationUnits Field

Glossary Item Box

Bounding Box Annotation Units.

Syntax

public int BoundingBoxAnnotationUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BoundingBoxBottomRightHandCorner Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BoundingBoxBottomRightHandCorner Field

Glossary Item Box

Bounding Box Bottom Right Hand Corner.

Syntax

public int BoundingBoxBottomRightHandCorner

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BoundingBoxTextHorizontalJustification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BoundingBoxTextHorizontalJustification Field

Glossary Item Box

Bounding Box Text Horizontal Justification.

Syntax

public int BoundingBoxTextHorizontalJustification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BoundingBoxTopLeftHandCorner Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BoundingBoxTopLeftHandCorner Field

Glossary Item Box

Bounding Box Top Left Hand Corner.

Syntax

public int BoundingBoxTopLeftHandCorner

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceID Field

Glossary Item Box

Brachy Accessory Device ID.

Syntax

public int BrachyAccessoryDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceName Field

Glossary Item Box

Brachy Accessory Device Name.

Syntax

public int BrachyAccessoryDeviceName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceNominalThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceNominalThickness Field

Glossary Item Box

Brachy Accessory Device Nominal Thickness.

Syntax

public int BrachyAccessoryDeviceNominalThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceNominalTransmission Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceNominalTransmission Field

Glossary Item Box

Brachy Accessory Device Nominal Transmission.

Syntax

public int BrachyAccessoryDeviceNominalTransmission

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceNumber Field

Glossary Item Box

Brachy Accessory Device Number.

Syntax

public int BrachyAccessoryDeviceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceSequence Field

Glossary Item Box

Brachy Accessory Device Sequence.

Syntax

public int BrachyAccessoryDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyAccessoryDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyAccessoryDeviceType Field

Glossary Item Box

Brachy Accessory Device Type.

Syntax

public int BrachyAccessoryDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyApplicationSetupDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyApplicationSetupDose Field

Glossary Item Box

Brachy Application Setup Dose.

Syntax

public int BrachyApplicationSetupDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyApplicationSetupDoseSpecificationPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyApplicationSetupDoseSpecificationPoint Field

Glossary Item Box

Brachy Application Setup Dose Specification Point.

Syntax

public int BrachyApplicationSetupDoseSpecificationPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyControlPointDeliveredSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyControlPointDeliveredSequence Field

Glossary Item Box

Brachy Control Point Delivered Sequence.

Syntax

public int BrachyControlPointDeliveredSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyControlPointSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyControlPointSequence Field

Glossary Item Box

Brachy Control Point Sequence.

Syntax

public int BrachyControlPointSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyReferencedDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyReferencedDoseReferenceSequence Field

Glossary Item Box

Brachy Referenced Dose Reference Sequence.

Syntax

public int BrachyReferencedDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyTreatmentTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyTreatmentTechnique Field

Glossary Item Box

Brachy Treatment Technique.

Syntax

public int BrachyTreatmentTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BrachyTreatmentType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BrachyTreatmentType Field

Glossary Item Box

Brachy Treatment Type.

Syntax

public int BrachyTreatmentType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BranchOfService Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BranchOfService Field

Glossary Item Box

Branch of Service.

Syntax

public int BranchOfService

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BreastImplantPresent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BreastImplantPresent Field

Glossary Item Box

Breast Implant Present.

Syntax

public int BreastImplantPresent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BreedRegistrationNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BreedRegistrationNumber Field

Glossary Item Box

Breed Registration Number.

Syntax

public int BreedRegistrationNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BreedRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BreedRegistrationSequence Field

Glossary Item Box

Breed Registration Sequence.

Syntax

public int BreedRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BreedRegistryCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BreedRegistryCodeSequence Field

Glossary Item Box

Breed Registry Code Sequence.

Syntax

public int BreedRegistryCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BulkMotionCompensationTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BulkMotionCompensationTechnique Field

Glossary Item Box

Bulk Motion Compensation Technique.

Syntax

public int BulkMotionCompensationTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BulkMotionSignalSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BulkMotionSignalSource Field

Glossary Item Box

Bulk Motion Signal Source.

Syntax

public int BulkMotionSignalSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BulkMotionStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BulkMotionStatus Field

Glossary Item Box

Bulk Motion Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int BulkMotionStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

BurnedInAnnotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : BurnedInAnnotation Field

Glossary Item Box

Burned In Annotation.

Syntax

public int BurnedInAnnotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalciumScoringMassFactorDevice Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalciumScoringMassFactorDevice Field

Glossary Item Box

Calcium Scoring Mass Factor Device.

Syntax

public int CalciumScoringMassFactorDevice

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalciumScoringMassFactorPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalciumScoringMassFactorPatient Field

Glossary Item Box

Calcium Scoring Mass Factor Patient.

Syntax

public int CalciumScoringMassFactorPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedAnatomyThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedAnatomyThickness Field

Glossary Item Box

Calculated Anatomy Thickness.

Syntax

public int CalculatedAnatomyThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedDoseReferenceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedDoseReferenceDescription Field

Glossary Item Box

Calculated Dose Reference Description.

Syntax

public int CalculatedDoseReferenceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedDoseReferenceDoseValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedDoseReferenceDoseValue Field

Glossary Item Box

Calculated Dose Reference Dose Value.

Syntax

public int CalculatedDoseReferenceDoseValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedDoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedDoseReferenceNumber Field

Glossary Item Box

Calculated Dose Reference Number.

Syntax

public int CalculatedDoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedDoseReferenceSequence Field

Glossary Item Box

Calculated Dose Reference Sequence.

Syntax

public int CalculatedDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalculatedFrameList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalculatedFrameList Field

Glossary Item Box

Calculated Frame List.

Syntax

public int CalculatedFrameList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalibrationDataSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalibrationDataSequence Field

Glossary Item Box

Calibration Data Sequence.

Syntax

public int CalibrationDataSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalibrationImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalibrationImage Field

Glossary Item Box

Calibration Image.

Syntax

public int CalibrationImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CalibrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CalibrationSequence Field

Glossary Item Box

Calibration Sequence.

Syntax

public int CalibrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacBeatRejectionTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacBeatRejectionTechnique Field

Glossary Item Box

Cardiac Beat Rejection Technique.

Syntax

public int CardiacBeatRejectionTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacCyclePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacCyclePosition Field

Glossary Item Box

Cardiac Cycle Position.

Syntax

public int CardiacCyclePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacFramingType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacFramingType Field

Glossary Item Box

Cardiac Framing Type.

Syntax

public int CardiacFramingType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacNumberOfImages Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacNumberOfImages Field

Glossary Item Box

Cardiac Number of Images.

Syntax

public int CardiacNumberOfImages

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacRRintervalSpecified Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacRRintervalSpecified Field

Glossary Item Box

Cardiac R-R Interval Specified.

Syntax

public int CardiacRRintervalSpecified

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacSignalSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacSignalSource Field

Glossary Item Box

Cardiac Signal Source.

Syntax

public int CardiacSignalSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacSynchronizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacSynchronizationSequence Field

Glossary Item Box

Cardiac Synchronization Sequence.

Syntax

public int CardiacSynchronizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CardiacSynchronizationTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CardiacSynchronizationTechnique Field

Glossary Item Box

Cardiac Synchronization Technique.

Syntax

public int CardiacSynchronizationTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CarmPositionerTabletopRelationship Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CarmPositionerTabletopRelationship Field

Glossary Item Box

C-arm Positioner Tabletop Relationship.

Syntax

public int CarmPositionerTabletopRelationship

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CassetteID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CassetteID Field

Glossary Item Box

Cassette ID.

Syntax

public int CassetteID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CassetteOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CassetteOrientation Field

Glossary Item Box

Cassette Orientation.

Syntax

public int CassetteOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CassetteSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CassetteSize Field

Glossary Item Box

Cassette Size.

Syntax

public int CassetteSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CenterOfCircularCollimator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CenterOfCircularCollimator Field

Glossary Item Box

Center of Circular Collimator.

Syntax

public int CenterOfCircularCollimator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CenterofCircularExposureControlSensingRegion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CenterofCircularExposureControlSensingRegion Field

Glossary Item Box

Center of Circular Exposure Control Sensing Region.

Syntax

public int CenterofCircularExposureControlSensingRegion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CenterOfCircularShutter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CenterOfCircularShutter Field

Glossary Item Box

Center of Circular Shutter.

Syntax

public int CenterOfCircularShutter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CenterOfRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CenterOfRotation Field

Glossary Item Box

Center of Rotation.

Syntax

public int CenterOfRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CenterOfRotationOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CenterOfRotationOffset Field

Glossary Item Box

Center of Rotation Offset.

Syntax

public int CenterOfRotationOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CertificateOfSigner Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CertificateOfSigner Field

Glossary Item Box

Certificate of Signer.

Syntax

public int CertificateOfSigner

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CertificateType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CertificateType Field

Glossary Item Box

Certificate Type.

Syntax

public int CertificateType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CertifiedTimestamp Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CertifiedTimestamp Field

Glossary Item Box

Certified Timestamp.

Syntax

public int CertifiedTimestamp

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CertifiedTimestampType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CertifiedTimestampType Field

Glossary Item Box

Certified Timestamp Type.

Syntax

public int CertifiedTimestampType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelBaseline Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelBaseline Field

Glossary Item Box

Channel Baseline.

Syntax

public int ChannelBaseline

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelDefinitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelDefinitionSequence Field

Glossary Item Box

Channel Definition Sequence.

Syntax

public int ChannelDefinitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelDerivationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelDerivationDescription Field

Glossary Item Box

Channel Derivation Description.

Syntax

public int ChannelDerivationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelDescriptionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelDescriptionCodeSequence Field

Glossary Item Box

Channel Description Code Sequence.

Syntax

public int ChannelDescriptionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelDisplaySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelDisplaySequence Field

Glossary Item Box

Channel Display Sequence.

Syntax

public int ChannelDisplaySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelIdentificationCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelIdentificationCode Field

Glossary Item Box

Channel Identification Code.

Syntax

public int ChannelIdentificationCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelLabel Field

Glossary Item Box

Channel Label.

Syntax

public int ChannelLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelLength Field

Glossary Item Box

Channel Length.

Syntax

public int ChannelLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelMaximumValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelMaximumValue Field

Glossary Item Box

Channel Maximum Value.

Syntax

public int ChannelMaximumValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelMinimumValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelMinimumValue Field

Glossary Item Box

Channel Minimum Value.

Syntax

public int ChannelMinimumValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelMode Field

Glossary Item Box

Channel Mode.

Syntax

public int ChannelMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelNumber Field

Glossary Item Box

Channel Number.

Syntax

public int ChannelNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelOffset Field

Glossary Item Box

Channel Offset.

Syntax

public int ChannelOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelPosition Field

Glossary Item Box

Channel Position.

Syntax

public int ChannelPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelRecommendedDisplayCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelRecommendedDisplayCIELabValue Field

Glossary Item Box

Channel Recommended Display CIELab Value.

Syntax

public int ChannelRecommendedDisplayCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSampleSkew Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSampleSkew Field

Glossary Item Box

Channel Sample Skew.

Syntax

public int ChannelSampleSkew

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSensitivity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSensitivity Field

Glossary Item Box

Channel Sensitivity.

Syntax

public int ChannelSensitivity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSensitivityCorrectionFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSensitivityCorrectionFactor Field

Glossary Item Box

Channel Sensitivity Correction Factor.

Syntax

public int ChannelSensitivityCorrectionFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSensitivityUnitsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSensitivityUnitsSequence Field

Glossary Item Box

Channel Sensitivity Units Sequence.

Syntax

public int ChannelSensitivityUnitsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSequence Field

Glossary Item Box

Channel Sequence.

Syntax

public int ChannelSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldID Field

Glossary Item Box

Channel Shield ID.

Syntax

public int ChannelShieldID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldName Field

Glossary Item Box

Channel Shield Name.

Syntax

public int ChannelShieldName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldNominalThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldNominalThickness Field

Glossary Item Box

Channel Shield Nominal Thickness.

Syntax

public int ChannelShieldNominalThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldNominalTransmission Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldNominalTransmission Field

Glossary Item Box

Channel Shield Nominal Transmission.

Syntax

public int ChannelShieldNominalTransmission

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldNumber Field

Glossary Item Box

Channel Shield Number.

Syntax

public int ChannelShieldNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelShieldSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelShieldSequence Field

Glossary Item Box

Channel Shield Sequence.

Syntax

public int ChannelShieldSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSourceModifiersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSourceModifiersSequence Field

Glossary Item Box

Channel Source Modifiers Sequence.

Syntax

public int ChannelSourceModifiersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelSourceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelSourceSequence Field

Glossary Item Box

Channel Source Sequence.

Syntax

public int ChannelSourceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelStatus Field

Glossary Item Box

Channel Status.

Syntax

public int ChannelStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelTimeSkew Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelTimeSkew Field

Glossary Item Box

Channel Time Skew.

Syntax

public int ChannelTimeSkew

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelTotalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelTotalTime Field

Glossary Item Box

Channel Total Time.

Syntax

public int ChannelTotalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChannelWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChannelWidth Field

Glossary Item Box

Channel Width.

Syntax

public int ChannelWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftMaximumIntegrationLimitInppm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftMaximumIntegrationLimitInppm Field

Glossary Item Box

Chemical Shift Maximum Integration Limit in ppm.

Syntax

public int ChemicalShiftMaximumIntegrationLimitInppm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftMinimumIntegrationLimitInppm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftMinimumIntegrationLimitInppm Field

Glossary Item Box

Chemical Shift Minimum Integration Limit in ppm.

Syntax

public int ChemicalShiftMinimumIntegrationLimitInppm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftReference Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftReference Field

Glossary Item Box

Chemical Shift Reference.

Syntax

public int ChemicalShiftReference

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftSequence Field

Glossary Item Box

Chemical Shift Sequence.

Syntax

public int ChemicalShiftSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftsMaximumIntegrationLimitInHz Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftsMaximumIntegrationLimitInHz Field

Glossary Item Box

Chemical Shifts Maximum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ChemicalShiftsMaximumIntegrationLimitInHz

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ChemicalShiftsMinimumIntegrationLimitInHz Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ChemicalShiftsMinimumIntegrationLimitInHz Field

Glossary Item Box

Chemical Shifts Minimum Integration Limit in Hz. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ChemicalShiftsMinimumIntegrationLimitInHz

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CineRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CineRate Field

Glossary Item Box

Cine Rate.

Syntax

public int CineRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CineRelativetoRealTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CineRelativetoRealTime Field

Glossary Item Box

Cine Relative to Real-Time.

Syntax

public int CineRelativetoRealTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialCoordinatingCenterName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialCoordinatingCenterName Field

Glossary Item Box

Clinical Trial Coordinating Center Name.

Syntax

public int ClinicalTrialCoordinatingCenterName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialProtocolEthicsCommitteeApprovalNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialProtocolEthicsCommitteeApprovalNumber Field

Glossary Item Box

Clinical Trial Protocol Ethics Committee Approval Number.

Syntax

public int ClinicalTrialProtocolEthicsCommitteeApprovalNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialProtocolEthicsCommitteeName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialProtocolEthicsCommitteeName Field

Glossary Item Box

Clinical Trial Protocol Ethics Committee Name.

Syntax

public int ClinicalTrialProtocolEthicsCommitteeName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialProtocolID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialProtocolID Field

Glossary Item Box

Clinical Trial Protocol ID.

Syntax

public int ClinicalTrialProtocolID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialProtocolName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialProtocolName Field

Glossary Item Box

Clinical Trial Protocol Name.

Syntax

public int ClinicalTrialProtocolName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSeriesDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSeriesDescription Field

Glossary Item Box

Clinical Trial Series Description.

Syntax

public int ClinicalTrialSeriesDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSeriesID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSeriesID Field

Glossary Item Box

Clinical Trial Series ID.

Syntax

public int ClinicalTrialSeriesID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSiteID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSiteID Field

Glossary Item Box

Clinical Trial Site ID.

Syntax

public int ClinicalTrialSiteID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSiteName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSiteName Field

Glossary Item Box

Clinical Trial Site Name.

Syntax

public int ClinicalTrialSiteName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSponsorName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSponsorName Field

Glossary Item Box

Clinical Trial Sponsor Name.

Syntax

public int ClinicalTrialSponsorName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSubjectID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSubjectID Field

Glossary Item Box

Clinical Trial Subject ID.

Syntax

public int ClinicalTrialSubjectID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialSubjectReadingID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialSubjectReadingID Field

Glossary Item Box

Clinical Trial Subject Reading ID.

Syntax

public int ClinicalTrialSubjectReadingID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialTimePointDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialTimePointDescription Field

Glossary Item Box

Clinical Trial Time Point Description.

Syntax

public int ClinicalTrialTimePointDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ClinicalTrialTimePointID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ClinicalTrialTimePointID Field

Glossary Item Box

Clinical Trial Time Point ID.

Syntax

public int ClinicalTrialTimePointID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodeLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodeLabel Field

Glossary Item Box

Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CodeLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodeMeaning Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodeMeaning Field

Glossary Item Box

Code Meaning.

Syntax

public int CodeMeaning

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodeNumberFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodeNumberFormat Field

Glossary Item Box

Code Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CodeNumberFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodeTableLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodeTableLocation Field

Glossary Item Box

Code Table Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CodeTableLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodeValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodeValue Field

Glossary Item Box

Code Value.

Syntax

public int CodeValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeDesignator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeDesignator Field

Glossary Item Box

Coding Scheme Designator.

Syntax

public int CodingSchemeDesignator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeExternalID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeExternalID Field

Glossary Item Box

Coding Scheme External ID.

Syntax

public int CodingSchemeExternalID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeIdentificationSequence Field

Glossary Item Box

Coding Scheme Identification Sequence.

Syntax

public int CodingSchemeIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeName Field

Glossary Item Box

Coding Scheme Name.

Syntax

public int CodingSchemeName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeRegistry Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeRegistry Field

Glossary Item Box

Coding Scheme Registry.

Syntax

public int CodingSchemeRegistry

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeResponsibleOrganization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeResponsibleOrganization Field

Glossary Item Box

Coding Scheme Responsible Organization.

Syntax

public int CodingSchemeResponsibleOrganization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeUID Field

Glossary Item Box

Coding Scheme UID.

Syntax

public int CodingSchemeUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CodingSchemeVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CodingSchemeVersion Field

Glossary Item Box

Coding Scheme Version.

Syntax

public int CodingSchemeVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoefficientCoding Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoefficientCoding Field

Glossary Item Box

Coefficient Coding. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoefficientCoding

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoefficientCodingPointers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoefficientCodingPointers Field

Glossary Item Box

Coefficient Coding Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoefficientCodingPointers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoefficientsSDDN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoefficientsSDDN Field

Glossary Item Box

Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoefficientsSDDN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoefficientsSDHN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoefficientsSDHN Field

Glossary Item Box

Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoefficientsSDHN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoefficientsSDVN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoefficientsSDVN Field

Glossary Item Box

Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoefficientsSDVN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoincidenceWindowWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoincidenceWindowWidth Field

Glossary Item Box

Coincidence Window Width.

Syntax

public int CoincidenceWindowWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollationFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollationFlag Field

Glossary Item Box

Collation Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CollationFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorGridName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorGridName Field

Glossary Item Box

Collimator/grid Name.

Syntax

public int CollimatorGridName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorLeftVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorLeftVerticalEdge Field

Glossary Item Box

Collimator Left Vertical Edge.

Syntax

public int CollimatorLeftVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorLowerHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorLowerHorizontalEdge Field

Glossary Item Box

Collimator Lower Horizontal Edge.

Syntax

public int CollimatorLowerHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorRightVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorRightVerticalEdge Field

Glossary Item Box

Collimator Right Vertical Edge.

Syntax

public int CollimatorRightVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorShape Field

Glossary Item Box

Collimator Shape.

Syntax

public int CollimatorShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorShapeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorShapeSequence Field

Glossary Item Box

Collimator Shape Sequence.

Syntax

public int CollimatorShapeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorType Field

Glossary Item Box

Collimator Type.

Syntax

public int CollimatorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CollimatorUpperHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CollimatorUpperHorizontalEdge Field

Glossary Item Box

Collimator Upper Horizontal Edge.

Syntax

public int CollimatorUpperHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ColorImagePrintingFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ColorImagePrintingFlag Field

Glossary Item Box

Color Image Printing Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ColorImagePrintingFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ColumnAngulation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ColumnAngulation Field

Glossary Item Box

Column Angulation.

Syntax

public int ColumnAngulation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ColumnAngulationPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ColumnAngulationPatient Field

Glossary Item Box

Column Angulation (Patient).

Syntax

public int ColumnAngulationPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ColumnOverlap Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ColumnOverlap Field

Glossary Item Box

Column Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ColumnOverlap

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Columns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Columns Field

Glossary Item Box

Columns. Width of the DICOM image.

Syntax

public int Columns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ColumnsForNthOrderCoefficients Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ColumnsForNthOrderCoefficients Field

Glossary Item Box

Columns For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ColumnsForNthOrderCoefficients

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommandField Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommandField Field

Glossary Item Box

Command Field.

Syntax

public int CommandField

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommandGroupLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommandGroupLength Field

Glossary Item Box

Command Group Length.

Syntax

public int CommandGroupLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommandLengthToEnd Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommandLengthToEnd Field

Glossary Item Box

Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CommandLengthToEnd

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommentsOnRadiationDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommentsOnRadiationDose Field

Glossary Item Box

Comments on Radiation Dose.

Syntax

public int CommentsOnRadiationDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommentsOnThePerformedProcedureStep Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommentsOnThePerformedProcedureStep Field

Glossary Item Box

Comments on the Performed Procedure Step.

Syntax

public int CommentsOnThePerformedProcedureStep

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CommentsOnTheScheduledProcedureStep Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CommentsOnTheScheduledProcedureStep Field

Glossary Item Box

Comments on the Scheduled Procedure Step.

Syntax

public int CommentsOnTheScheduledProcedureStep

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorColumnOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorColumnOffset Field

Glossary Item Box

Compensator Column Offset.

Syntax

public int CompensatorColumnOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorColumns Field

Glossary Item Box

Compensator Columns.

Syntax

public int CompensatorColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorDescription Field

Glossary Item Box

Compensator Description.

Syntax

public int CompensatorDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorDivergence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorDivergence Field

Glossary Item Box

Compensator Divergence.

Syntax

public int CompensatorDivergence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorID Field

Glossary Item Box

Compensator ID.

Syntax

public int CompensatorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorMillingToolDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorMillingToolDiameter Field

Glossary Item Box

Compensator Milling Tool Diameter.

Syntax

public int CompensatorMillingToolDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorMountingPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorMountingPosition Field

Glossary Item Box

Compensator Mounting Position.

Syntax

public int CompensatorMountingPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorNumber Field

Glossary Item Box

Compensator Number.

Syntax

public int CompensatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorPixelSpacing Field

Glossary Item Box

Compensator Pixel Spacing.

Syntax

public int CompensatorPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorPosition Field

Glossary Item Box

Compensator Position.

Syntax

public int CompensatorPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorRelativeStoppingPowerRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorRelativeStoppingPowerRatio Field

Glossary Item Box

Compensator Relative Stopping Power Ratio.

Syntax

public int CompensatorRelativeStoppingPowerRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorRows Field

Glossary Item Box

Compensator Rows.

Syntax

public int CompensatorRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorSequence Field

Glossary Item Box

Compensator Sequence.

Syntax

public int CompensatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorThicknessData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorThicknessData Field

Glossary Item Box

Compensator Thickness Data.

Syntax

public int CompensatorThicknessData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorTransmissionData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorTransmissionData Field

Glossary Item Box

Compensator Transmission Data.

Syntax

public int CompensatorTransmissionData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompensatorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompensatorType Field

Glossary Item Box

Compensator Type.

Syntax

public int CompensatorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompletionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompletionFlag Field

Glossary Item Box

Completion Flag.

Syntax

public int CompletionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompletionFlagDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompletionFlagDescription Field

Glossary Item Box

Completion Flag Description.

Syntax

public int CompletionFlagDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ComplexImageComponent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ComplexImageComponent Field

Glossary Item Box

Complex Image Component.

Syntax

public int ComplexImageComponent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionCode Field

Glossary Item Box

Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionDescription Field

Glossary Item Box

Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionForce Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionForce Field

Glossary Item Box

Compression Force.

Syntax

public int CompressionForce

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionLabel Field

Glossary Item Box

Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionOriginator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionOriginator Field

Glossary Item Box

Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionOriginator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionRecognitionCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionRecognitionCode Field

Glossary Item Box

Compression Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionRecognitionCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionSequence Field

Glossary Item Box

Compression Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CompressionStepPointers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CompressionStepPointers Field

Glossary Item Box

Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CompressionStepPointers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConcatenationFrameOffsetNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConcatenationFrameOffsetNumber Field

Glossary Item Box

Concatenation Frame Offset Number.

Syntax

public int ConcatenationFrameOffsetNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConcatenationUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConcatenationUID Field

Glossary Item Box

Concatenation UID.

Syntax

public int ConcatenationUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConceptCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConceptCodeSequence Field

Glossary Item Box

Concept Code Sequence.

Syntax

public int ConceptCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConceptNameCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConceptNameCodeSequence Field

Glossary Item Box

Concept Name Code Sequence.

Syntax

public int ConceptNameCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConfidentialityCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConfidentialityCode Field

Glossary Item Box

Confidentiality Code.

Syntax

public int ConfidentialityCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConfidentialityConstraint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConfidentialityConstraint Field

Glossary Item Box

Confidentiality Constraint on Patient Data Description.

Syntax

public int ConfidentialityConstraint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConfidentialityConstraintOnPatientDataDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConfidentialityConstraintOnPatientDataDescription Field

Glossary Item Box

Confidentiality Constraint on Patient Data Description.

Syntax

public int ConfidentialityConstraintOnPatientDataDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConfigurationInformation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConfigurationInformation Field

Glossary Item Box

Configuration Information.

Syntax

public int ConfigurationInformation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConfigurationInformationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConfigurationInformationDescription Field

Glossary Item Box

Configuration Information Description.

Syntax

public int ConfigurationInformationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConsentForClinicalTrialUseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConsentForClinicalTrialUseSequence Field

Glossary Item Box

Consent for Clinical Trial Use Sequence.

Syntax

public int ConsentForClinicalTrialUseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConsentForDistributionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConsentForDistributionFlag Field

Glossary Item Box

Consent for Distribution Flag.

Syntax

public int ConsentForDistributionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConstantVolumeFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConstantVolumeFlag Field

Glossary Item Box

Constant Volume Flag.

Syntax

public int ConstantVolumeFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConstraintWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConstraintWeight Field

Glossary Item Box

Constraint Weight.

Syntax

public int ConstraintWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContactDisplayName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContactDisplayName Field

Glossary Item Box

Contact Display Name.

Syntax

public int ContactDisplayName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContactURI Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContactURI Field

Glossary Item Box

Contact URI.

Syntax

public int ContactURI

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentDescription Field

Glossary Item Box

Container Component Description.

Syntax

public int ContainerComponentDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentDiameter Field

Glossary Item Box

Container Component Diameter.

Syntax

public int ContainerComponentDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentID Field

Glossary Item Box

Container Component ID.

Syntax

public int ContainerComponentID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentLength Field

Glossary Item Box

Container Component Length.

Syntax

public int ContainerComponentLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentMaterial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentMaterial Field

Glossary Item Box

Container Component Material.

Syntax

public int ContainerComponentMaterial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentSequence Field

Glossary Item Box

Container Component Sequence.

Syntax

public int ContainerComponentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentThickness Field

Glossary Item Box

Container Component Thickness.

Syntax

public int ContainerComponentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentTypeCodeSequence Field

Glossary Item Box

Container Component Type Code Sequence.

Syntax

public int ContainerComponentTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerComponentWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerComponentWidth Field

Glossary Item Box

Container Component Width.

Syntax

public int ContainerComponentWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerDescription Field

Glossary Item Box

Container Description.

Syntax

public int ContainerDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerIdentifier Field

Glossary Item Box

Container Identifier.

Syntax

public int ContainerIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContainerTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContainerTypeCodeSequence Field

Glossary Item Box

Container Type Code Sequence.

Syntax

public int ContainerTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentCreatorsIdentificationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentCreatorsIdentificationCodeSequence Field

Glossary Item Box

Content Creator's Identification Code Sequence.

Syntax

public int ContentCreatorsIdentificationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentCreatorsName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentCreatorsName Field

Glossary Item Box

Content Creator's Name.

Syntax

public int ContentCreatorsName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentDate Field

Glossary Item Box

Content Date.

Syntax

public int ContentDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentDescription Field

Glossary Item Box

Content Description.

Syntax

public int ContentDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentItemModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentItemModifierSequence Field

Glossary Item Box

Content Item Modifier Sequence.

Syntax

public int ContentItemModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentLabel Field

Glossary Item Box

Content Label.

Syntax

public int ContentLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentQualification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentQualification Field

Glossary Item Box

Content Qualification.

Syntax

public int ContentQualification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentSequence Field

Glossary Item Box

Content Sequence.

Syntax

public int ContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentTemplateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentTemplateSequence Field

Glossary Item Box

Content Template Sequence.

Syntax

public int ContentTemplateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContentTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContentTime Field

Glossary Item Box

Content Time.

Syntax

public int ContentTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextGroupExtensionCreatorUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextGroupExtensionCreatorUID Field

Glossary Item Box

Context Group Extension Creator UID.

Syntax

public int ContextGroupExtensionCreatorUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextGroupExtensionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextGroupExtensionFlag Field

Glossary Item Box

Context Group Extension Flag.

Syntax

public int ContextGroupExtensionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextGroupLocalVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextGroupLocalVersion Field

Glossary Item Box

Context Group Local Version.

Syntax

public int ContextGroupLocalVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextGroupVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextGroupVersion Field

Glossary Item Box

Context Group Version.

Syntax

public int ContextGroupVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextIdentifier Field

Glossary Item Box

Context Identifier.

Syntax

public int ContextIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContextUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContextUID Field

Glossary Item Box

Context UID.

Syntax

public int ContextUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContinuityOfContent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContinuityOfContent Field

Glossary Item Box

Continuity Of Content.

Syntax

public int ContinuityOfContent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourData Field

Glossary Item Box

Contour Data.

Syntax

public int ContourData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourGeometricType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourGeometricType Field

Glossary Item Box

Contour Geometric Type.

Syntax

public int ContourGeometricType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourImageSequence Field

Glossary Item Box

Contour Image Sequence.

Syntax

public int ContourImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourNumber Field

Glossary Item Box

Contour Number.

Syntax

public int ContourNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourOffsetVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourOffsetVector Field

Glossary Item Box

Contour Offset Vector.

Syntax

public int ContourOffsetVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourSequence Field

Glossary Item Box

Contour Sequence.

Syntax

public int ContourSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourSlabThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourSlabThickness Field

Glossary Item Box

Contour Slab Thickness.

Syntax

public int ContourSlabThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContourUncertaintyRadius Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContourUncertaintyRadius Field

Glossary Item Box

Contour Uncertainty Radius.

Syntax

public int ContourUncertaintyRadius

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastAdministrationProfileSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastAdministrationProfileSequence Field

Glossary Item Box

Contrast Administration Profile Sequence.

Syntax

public int ContrastAdministrationProfileSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAdministrationRouteSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAdministrationRouteSequence Field

Glossary Item Box

Contrast/Bolus Administration Route Sequence.

Syntax

public int ContrastBolusAdministrationRouteSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgent Field

Glossary Item Box

Contrast/Bolus Agent.

Syntax

public int ContrastBolusAgent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgentAdministered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgentAdministered Field

Glossary Item Box

Contrast/Bolus Agent Administered.

Syntax

public int ContrastBolusAgentAdministered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgentDetected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgentDetected Field

Glossary Item Box

Contrast/Bolus Agent Detected.

Syntax

public int ContrastBolusAgentDetected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgentNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgentNumber Field

Glossary Item Box

Contrast/Bolus Agent Number.

Syntax

public int ContrastBolusAgentNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgentPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgentPhase Field

Glossary Item Box

Contrast/Bolus Agent Phase.

Syntax

public int ContrastBolusAgentPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusAgentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusAgentSequence Field

Glossary Item Box

Contrast/Bolus Agent Sequence.

Syntax

public int ContrastBolusAgentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusIngredient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusIngredient Field

Glossary Item Box

Contrast/Bolus Ingredient.

Syntax

public int ContrastBolusIngredient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusIngredientCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusIngredientCodeSequence Field

Glossary Item Box

Contrast/Bolus Ingredient Code Sequence.

Syntax

public int ContrastBolusIngredientCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusIngredientConcentration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusIngredientConcentration Field

Glossary Item Box

Contrast/Bolus Ingredient Concentration.

Syntax

public int ContrastBolusIngredientConcentration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusIngredientOpaque Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusIngredientOpaque Field

Glossary Item Box

Contrast/Bolus Ingredient Opaque.

Syntax

public int ContrastBolusIngredientOpaque

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusRoute Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusRoute Field

Glossary Item Box

Contrast/Bolus Route.

Syntax

public int ContrastBolusRoute

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusStartTime Field

Glossary Item Box

Contrast/Bolus Start Time.

Syntax

public int ContrastBolusStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusStopTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusStopTime Field

Glossary Item Box

Contrast/Bolus Stop Time.

Syntax

public int ContrastBolusStopTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusTotalDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusTotalDose Field

Glossary Item Box

Contrast/Bolus Total Dose.

Syntax

public int ContrastBolusTotalDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusUsageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusUsageSequence Field

Glossary Item Box

Contrast/Bolus Usage Sequence.

Syntax

public int ContrastBolusUsageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastBolusVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastBolusVolume Field

Glossary Item Box

Contrast/Bolus Volume.

Syntax

public int ContrastBolusVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastFlowDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastFlowDuration Field

Glossary Item Box

Contrast Flow Duration.

Syntax

public int ContrastFlowDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastFlowRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastFlowRate Field

Glossary Item Box

Contrast Flow Rate.

Syntax

public int ContrastFlowRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContrastFrameAveraging Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContrastFrameAveraging Field

Glossary Item Box

Contrast Frame Averaging.

Syntax

public int ContrastFrameAveraging

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContributingEquipmentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContributingEquipmentSequence Field

Glossary Item Box

Contributing Equipment Sequence.

Syntax

public int ContributingEquipmentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContributingSOPInstancesReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContributingSOPInstancesReferenceSequence Field

Glossary Item Box

Contributing SOP Instances Reference Sequence.

Syntax

public int ContributingSOPInstancesReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContributingSourcesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContributingSourcesSequence Field

Glossary Item Box

Contributing Sources Sequence.

Syntax

public int ContributingSourcesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContributionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContributionDateTime Field

Glossary Item Box

Contribution Date Time.

Syntax

public int ContributionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ContributionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ContributionDescription Field

Glossary Item Box

Contribution Description.

Syntax

public int ContributionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPoint3dPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPoint3dPosition Field

Glossary Item Box

Control Point 3D Position.

Syntax

public int ControlPoint3dPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPointDeliverySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPointDeliverySequence Field

Glossary Item Box

Control Point Delivery Sequence.

Syntax

public int ControlPointDeliverySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPointIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPointIndex Field

Glossary Item Box

Control Point Index.

Syntax

public int ControlPointIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPointOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPointOrientation Field

Glossary Item Box

Control Point Orientation.

Syntax

public int ControlPointOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPointRelativePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPointRelativePosition Field

Glossary Item Box

Control Point Relative Position.

Syntax

public int ControlPointRelativePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ControlPointSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ControlPointSequence Field

Glossary Item Box

Control Point Sequence.

Syntax

public int ControlPointSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConventionalControlPointVerificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConventionalControlPointVerificationSequence Field

Glossary Item Box

Conventional Control Point Verification Sequence.

Syntax

public int ConventionalControlPointVerificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConventionalMachineVerificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConventionalMachineVerificationSequence Field

Glossary Item Box

Conventional Machine Verification Sequence.

Syntax

public int ConventionalMachineVerificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConversionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConversionType Field

Glossary Item Box

Conversion Type.

Syntax

public int ConversionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConvolutionKernel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConvolutionKernel Field

Glossary Item Box

Convolution Kernel.

Syntax

public int ConvolutionKernel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ConvolutionKernelGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ConvolutionKernelGroup Field

Glossary Item Box

Convolution Kernel Group.

Syntax

public int ConvolutionKernelGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoordinateGeometricType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoordinateGeometricType Field

Glossary Item Box

Coordinate Geometric Type.

Syntax

public int CoordinateGeometricType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoordinateStartValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoordinateStartValue Field

Glossary Item Box

Coordinate Start Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoordinateStartValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoordinateStepValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoordinateStepValue Field

Glossary Item Box

Coordinate Step Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CoordinateStepValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoordinateSystemAxisCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoordinateSystemAxisCodeSequence Field

Glossary Item Box

Coordinate System Axis Code Sequence.

Syntax

public int CoordinateSystemAxisCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Copies Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Copies Field

Glossary Item Box

Copies. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Copies

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CornealSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CornealSize Field

Glossary Item Box

Corneal Size.

Syntax

public int CornealSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CorrectedImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CorrectedImage Field

Glossary Item Box

Corrected Image.

Syntax

public int CorrectedImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CorrectedParameterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CorrectedParameterSequence Field

Glossary Item Box

Corrected Parameter Sequence.

Syntax

public int CorrectedParameterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CorrectionValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CorrectionValue Field

Glossary Item Box

Correction Value.

Syntax

public int CorrectionValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountLossNormalizationCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountLossNormalizationCorrected Field

Glossary Item Box

Count Loss Normalization Corrected.

Syntax

public int CountLossNormalizationCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountRate Field

Glossary Item Box

Count Rate.

Syntax

public int CountRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountryOfResidence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountryOfResidence Field

Glossary Item Box

Country of Residence.

Syntax

public int CountryOfResidence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountsAccumulated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountsAccumulated Field

Glossary Item Box

Counts Accumulated.

Syntax

public int CountsAccumulated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountsIncluded Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountsIncluded Field

Glossary Item Box

Counts Included. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CountsIncluded

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CountsSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CountsSource Field

Glossary Item Box

Counts Source.

Syntax

public int CountsSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CoverageOfKspace Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CoverageOfKspace Field

Glossary Item Box

Coverage of k-Space.

Syntax

public int CoverageOfKspace

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CranialThermalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CranialThermalIndex Field

Glossary Item Box

Cranial Thermal Index.

Syntax

public int CranialThermalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CreationDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CreationDate Field

Glossary Item Box

Creation Date.

Syntax

public int CreationDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CreationTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CreationTime Field

Glossary Item Box

Creation Time.

Syntax

public int CreationTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CreatorVersionUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CreatorVersionUID Field

Glossary Item Box

Creator Version UID.

Syntax

public int CreatorVersionUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTAcquisitionDetailsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTAcquisitionDetailsSequence Field

Glossary Item Box

CT Acquisition Details Sequence.

Syntax

public int CTAcquisitionDetailsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTAcquisitionTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTAcquisitionTypeSequence Field

Glossary Item Box

CT Acquisition Type Sequence.

Syntax

public int CTAcquisitionTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTAdditionalXRaySourceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTAdditionalXRaySourceSequence Field

Glossary Item Box

CT Additional X-Ray Source Sequence.

Syntax

public int CTAdditionalXRaySourceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTDIPhantomTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTDIPhantomTypeCodeSequence Field

Glossary Item Box

CTDI Phantom Type Code Sequence.

Syntax

public int CTDIPhantomTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTDIvol Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTDIvol Field

Glossary Item Box

The CTDIvol.

Syntax

public int CTDIvol

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTExposureSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTExposureSequence Field

Glossary Item Box

CT Exposure Sequence.

Syntax

public int CTExposureSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTGeometrySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTGeometrySequence Field

Glossary Item Box

CT Geometry Sequence.

Syntax

public int CTGeometrySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTImageFrameTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTImageFrameTypeSequence Field

Glossary Item Box

CT Image Frame Type Sequence.

Syntax

public int CTImageFrameTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTPositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTPositionSequence Field

Glossary Item Box

CT Position Sequence.

Syntax

public int CTPositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTReconstructionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTReconstructionSequence Field

Glossary Item Box

CT Reconstruction Sequence.

Syntax

public int CTReconstructionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTTableDynamicsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTTableDynamicsSequence Field

Glossary Item Box

CT Table Dynamics Sequence.

Syntax

public int CTTableDynamicsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CTXRayDetailsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CTXRayDetailsSequence Field

Glossary Item Box

CT X-Ray Details Sequence.

Syntax

public int CTXRayDetailsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CumulativeDoseReferenceCoefficient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CumulativeDoseReferenceCoefficient Field

Glossary Item Box

Cumulative Dose Reference Coefficient.

Syntax

public int CumulativeDoseReferenceCoefficient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CumulativeDoseToDoseReference Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CumulativeDoseToDoseReference Field

Glossary Item Box

Cumulative Dose to Dose Reference.

Syntax

public int CumulativeDoseToDoseReference

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CumulativeMetersetWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CumulativeMetersetWeight Field

Glossary Item Box

Cumulative Meterset Weight.

Syntax

public int CumulativeMetersetWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CumulativeTimeWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CumulativeTimeWeight Field

Glossary Item Box

Cumulative Time Weight.

Syntax

public int CumulativeTimeWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurrentFractionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurrentFractionNumber Field

Glossary Item Box

Current Fraction Number.

Syntax

public int CurrentFractionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurrentPatientLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurrentPatientLocation Field

Glossary Item Box

Current Patient Location.

Syntax

public int CurrentPatientLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurrentRequestedProcedureEvidenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurrentRequestedProcedureEvidenceSequence Field

Glossary Item Box

Current Requested Procedure Evidence Sequence.

Syntax

public int CurrentRequestedProcedureEvidenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurrentTreatmentStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurrentTreatmentStatus Field

Glossary Item Box

Current Treatment Status.

Syntax

public int CurrentTreatmentStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveActivationLayer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveActivationLayer Field

Glossary Item Box

Curve Activation Layer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveActivationLayer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveData Field

Glossary Item Box

Curve Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveDataDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveDataDescriptor Field

Glossary Item Box

Curve Data Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveDataDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveDate Field

Glossary Item Box

Curve Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveDescription Field

Glossary Item Box

Curve Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveDimensions Field

Glossary Item Box

Curve Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveLabel Field

Glossary Item Box

Curve Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveNumber Field

Glossary Item Box

Curve Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveRange Field

Glossary Item Box

Curve Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveReferencedOverlayGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveReferencedOverlayGroup Field

Glossary Item Box

Curve Referenced Overlay Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveReferencedOverlayGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveReferencedOverlaySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveReferencedOverlaySequence Field

Glossary Item Box

Curve Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveReferencedOverlaySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CurveTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CurveTime Field

Glossary Item Box

Curve Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int CurveTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CustodialOrganizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CustodialOrganizationSequence Field

Glossary Item Box

Custodial Organization Sequence.

Syntax

public int CustodialOrganizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CylinderAxis Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CylinderAxis Field

Glossary Item Box

Cylinder Axis.

Syntax

public int CylinderAxis

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CylinderLensPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CylinderLensPower Field

Glossary Item Box

Cylinder Lens Power.

Syntax

public int CylinderLensPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CylinderPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CylinderPower Field

Glossary Item Box

Cylinder Power.

Syntax

public int CylinderPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

CylinderSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : CylinderSequence Field

Glossary Item Box

Cylinder Sequence.

Syntax

public int CylinderSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataBlock Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataBlock Field

Glossary Item Box

Data Block. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DataBlock

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataBlockDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataBlockDescription Field

Glossary Item Box

Data Block Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DataBlockDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataCollectionCenterPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataCollectionCenterPatient Field

Glossary Item Box

Data Collection Center (Patient).

Syntax

public int DataCollectionCenterPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataCollectionDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataCollectionDiameter Field

Glossary Item Box

Data Collection Diameter.

Syntax

public int DataCollectionDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataElementsSigned Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataElementsSigned Field

Glossary Item Box

Data Elements Signed.

Syntax

public int DataElementsSigned

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataFrameAssignmentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataFrameAssignmentSequence Field

Glossary Item Box

Data Frame Assignment Sequence.

Syntax

public int DataFrameAssignmentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataInformationSequence Field

Glossary Item Box

Data Information Sequence.

Syntax

public int DataInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataPathAssignment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataPathAssignment Field

Glossary Item Box

Data Path Assignment.

Syntax

public int DataPathAssignment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataPathID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataPathID Field

Glossary Item Box

Data Path ID.

Syntax

public int DataPathID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataPointColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataPointColumns Field

Glossary Item Box

Data Point Columns.

Syntax

public int DataPointColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataPointRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataPointRows Field

Glossary Item Box

Data Point Rows.

Syntax

public int DataPointRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataRepresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataRepresentation Field

Glossary Item Box

Data Representation.

Syntax

public int DataRepresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataSet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataSet Field

Glossary Item Box

DICOM dataset.

Syntax

public int DataSet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataSetSubtype Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataSetSubtype Field

Glossary Item Box

Data Set Subtype. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DataSetSubtype

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataSetTrailingPadding Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataSetTrailingPadding Field

Glossary Item Box

Data Set Trailing Padding.

Syntax

public int DataSetTrailingPadding

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataSetType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataSetType Field

Glossary Item Box

Data Set Type.

Syntax

public int DataSetType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataStreamEncodingFragment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataStreamEncodingFragment Field

Glossary Item Box

Data Stream Encoding Fragment.

Syntax

public int DataStreamEncodingFragment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataType Field

Glossary Item Box

Data Type.

Syntax

public int DataType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DataValueRepresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DataValueRepresentation Field

Glossary Item Box

Data Value Representation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DataValueRepresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Date Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Date Field

Glossary Item Box

Date value.

Syntax

public int Date

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DateOfLastCalibration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DateOfLastCalibration Field

Glossary Item Box

Date of Last Calibration.

Syntax

public int DateOfLastCalibration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DateOfLastDetectorCalibration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DateOfLastDetectorCalibration Field

Glossary Item Box

Date of Last Detector Calibration.

Syntax

public int DateOfLastDetectorCalibration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DateOfSecondaryCapture Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DateOfSecondaryCapture Field

Glossary Item Box

Date of Secondary Capture.

Syntax

public int DateOfSecondaryCapture

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DateTime Field

Glossary Item Box

DateTime value.

Syntax

public int DateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DbDt Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DbDt Field

Glossary Item Box

The dB/dt.

Syntax

public int DbDt

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DCTLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DCTLabel Field

Glossary Item Box

DCT Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DCTLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeadTimeCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeadTimeCorrected Field

Glossary Item Box

Dead Time Corrected.

Syntax

public int DeadTimeCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeadTimeCorrectionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeadTimeCorrectionFlag Field

Glossary Item Box

Dead Time Correction Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DeadTimeCorrectionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeadTimeFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeadTimeFactor Field

Glossary Item Box

Dead Time Factor.

Syntax

public int DeadTimeFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecayCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecayCorrected Field

Glossary Item Box

Decay Corrected.

Syntax

public int DecayCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecayCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecayCorrection Field

Glossary Item Box

Decay Correction.

Syntax

public int DecayCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecayCorrectionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecayCorrectionDateTime Field

Glossary Item Box

Decay Correction DateTime.

Syntax

public int DecayCorrectionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecayFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecayFactor Field

Glossary Item Box

Decay Factor.

Syntax

public int DecayFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecimalVisualAcuity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecimalVisualAcuity Field

Glossary Item Box

Decimal Visual Acuity.

Syntax

public int DecimalVisualAcuity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecimateCropResult Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecimateCropResult Field

Glossary Item Box

Decimate/Crop Result.

Syntax

public int DecimateCropResult

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecoupledNucleus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecoupledNucleus Field

Glossary Item Box

De-coupled Nucleus.

Syntax

public int DecoupledNucleus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Decoupling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Decoupling Field

Glossary Item Box

De-coupling value.

Syntax

public int Decoupling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecouplingChemicalShiftReference Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecouplingChemicalShiftReference Field

Glossary Item Box

De-coupling Chemical Shift Reference.

Syntax

public int DecouplingChemicalShiftReference

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecouplingFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecouplingFrequency Field

Glossary Item Box

De-coupling Frequency.

Syntax

public int DecouplingFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DecouplingMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DecouplingMethod Field

Glossary Item Box

De-coupling Method.

Syntax

public int DecouplingMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DefaultMagnificationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DefaultMagnificationType Field

Glossary Item Box

Default Magnification Type.

Syntax

public int DefaultMagnificationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DefaultPrinterResolutionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DefaultPrinterResolutionID Field

Glossary Item Box

Default Printer Resolution ID.

Syntax

public int DefaultPrinterResolutionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DefaultSmoothingType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DefaultSmoothingType Field

Glossary Item Box

Default Smoothing Type.

Syntax

public int DefaultSmoothingType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeformableRegistrationGridSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeformableRegistrationGridSequence Field

Glossary Item Box

Deformable Registration Grid Sequence.

Syntax

public int DeformableRegistrationGridSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeformableRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeformableRegistrationSequence Field

Glossary Item Box

Deformable Registration Sequence.

Syntax

public int DeformableRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DegreeofDilation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DegreeofDilation Field

Glossary Item Box

Degree of Dilation.

Syntax

public int DegreeofDilation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeidentificationMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeidentificationMethod Field

Glossary Item Box

De-identification Method.

Syntax

public int DeidentificationMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeidentificationMethodCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeidentificationMethodCodeSequence Field

Glossary Item Box

De-identification Method Code Sequence.

Syntax

public int DeidentificationMethodCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeletionLock Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeletionLock Field

Glossary Item Box

Deletion Lock.

Syntax

public int DeletionLock

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredChannelTotalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredChannelTotalTime Field

Glossary Item Box

Delivered Channel Total Time.

Syntax

public int DeliveredChannelTotalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredMeterset Field

Glossary Item Box

Delivered Meterset.

Syntax

public int DeliveredMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredNumberofPulses Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredNumberofPulses Field

Glossary Item Box

Delivered Number of Pulses.

Syntax

public int DeliveredNumberofPulses

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredPrimaryMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredPrimaryMeterset Field

Glossary Item Box

Delivered Primary Meterset.

Syntax

public int DeliveredPrimaryMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredPulseRepetitionInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredPulseRepetitionInterval Field

Glossary Item Box

Delivered Pulse Repetition Interval.

Syntax

public int DeliveredPulseRepetitionInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredSecondaryMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredSecondaryMeterset Field

Glossary Item Box

Delivered Secondary Meterset.

Syntax

public int DeliveredSecondaryMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveredTreatmentTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveredTreatmentTime Field

Glossary Item Box

Delivered Treatment Time.

Syntax

public int DeliveredTreatmentTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveryMaximumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveryMaximumDose Field

Glossary Item Box

Delivery Maximum Dose.

Syntax

public int DeliveryMaximumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveryVerificationImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveryVerificationImageSequence Field

Glossary Item Box

Delivery Verification Image Sequence.

Syntax

public int DeliveryVerificationImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeliveryWarningDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeliveryWarningDose Field

Glossary Item Box

Delivery Warning Dose.

Syntax

public int DeliveryWarningDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DepthOfScanField Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DepthOfScanField Field

Glossary Item Box

Depth of Scan Field.

Syntax

public int DepthOfScanField

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DepthOfTransverseImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DepthOfTransverseImage Field

Glossary Item Box

Depth of Transverse Image.

Syntax

public int DepthOfTransverseImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DepthsOfFocus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DepthsOfFocus Field

Glossary Item Box

Depth(s) of Focus.

Syntax

public int DepthsOfFocus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DepthSpatialResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DepthSpatialResolution Field

Glossary Item Box

Depth Spatial Resolution.

Syntax

public int DepthSpatialResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DerivationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DerivationCodeSequence Field

Glossary Item Box

Derivation Code Sequence.

Syntax

public int DerivationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DerivationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DerivationDescription Field

Glossary Item Box

Derivation Description.

Syntax

public int DerivationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DerivationImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DerivationImageSequence Field

Glossary Item Box

Derivation Image Sequence.

Syntax

public int DerivationImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DestinationAe Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DestinationAe Field

Glossary Item Box

Destination AE. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DestinationAe

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetailsOfCoefficients Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetailsOfCoefficients Field

Glossary Item Box

Details of Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DetailsOfCoefficients

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorActivationOffsetFromExposure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorActivationOffsetFromExposure Field

Glossary Item Box

Detector Activation Offset From Exposure.

Syntax

public int DetectorActivationOffsetFromExposure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorActiveDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorActiveDimensions Field

Glossary Item Box

Detector Active Dimension(s).

Syntax

public int DetectorActiveDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorActiveOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorActiveOrigin Field

Glossary Item Box

Detector Active Origin.

Syntax

public int DetectorActiveOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorActiveShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorActiveShape Field

Glossary Item Box

Detector Active Shape.

Syntax

public int DetectorActiveShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorActiveTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorActiveTime Field

Glossary Item Box

Detector Active Time.

Syntax

public int DetectorActiveTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorBinning Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorBinning Field

Glossary Item Box

Detector Binning.

Syntax

public int DetectorBinning

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorConditionsNominalFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorConditionsNominalFlag Field

Glossary Item Box

Detector Conditions Nominal Flag.

Syntax

public int DetectorConditionsNominalFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorConfiguration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorConfiguration Field

Glossary Item Box

Detector Configuration.

Syntax

public int DetectorConfiguration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorDescription Field

Glossary Item Box

Detector Description.

Syntax

public int DetectorDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorElementPhysicalSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorElementPhysicalSize Field

Glossary Item Box

Detector Element Physical Size.

Syntax

public int DetectorElementPhysicalSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorElementSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorElementSize Field

Glossary Item Box

Detector Element Size.

Syntax

public int DetectorElementSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorElementSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorElementSpacing Field

Glossary Item Box

Detector Element Spacing.

Syntax

public int DetectorElementSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorGeometry Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorGeometry Field

Glossary Item Box

Detector Geometry.

Syntax

public int DetectorGeometry

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorID Field

Glossary Item Box

Detector ID.

Syntax

public int DetectorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorInformationSequence Field

Glossary Item Box

Detector Information Sequence.

Syntax

public int DetectorInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorLinesOfResponseUsed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorLinesOfResponseUsed Field

Glossary Item Box

Detector Lines of Response Used.

Syntax

public int DetectorLinesOfResponseUsed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorManufacturerName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorManufacturerName Field

Glossary Item Box

Detector Manufacturer Name.

Syntax

public int DetectorManufacturerName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorManufacturersModelName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorManufacturersModelName Field

Glossary Item Box

Detector Manufacturers Model Name.

Syntax

public int DetectorManufacturersModelName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorMode Field

Glossary Item Box

Detector Mode.

Syntax

public int DetectorMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorNormalizationCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorNormalizationCorrection Field

Glossary Item Box

Detector Normalization Correction.

Syntax

public int DetectorNormalizationCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorPrimaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorPrimaryAngle Field

Glossary Item Box

Detector Primary Angle.

Syntax

public int DetectorPrimaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorSecondaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorSecondaryAngle Field

Glossary Item Box

Detector Secondary Angle.

Syntax

public int DetectorSecondaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorTemperature Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorTemperature Field

Glossary Item Box

Detector Temperature.

Syntax

public int DetectorTemperature

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorTimeSinceLastExposure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorTimeSinceLastExposure Field

Glossary Item Box

Detector Time Since Last Exposure.

Syntax

public int DetectorTimeSinceLastExposure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorType Field

Glossary Item Box

Detector Type.

Syntax

public int DetectorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DetectorVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DetectorVector Field

Glossary Item Box

Detector Vector.

Syntax

public int DetectorVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceDescription Field

Glossary Item Box

Device Description.

Syntax

public int DeviceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceDiameter Field

Glossary Item Box

Device Diameter.

Syntax

public int DeviceDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceDiameterUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceDiameterUnits Field

Glossary Item Box

Device Diameter Units.

Syntax

public int DeviceDiameterUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceID Field

Glossary Item Box

Device ID.

Syntax

public int DeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceLength Field

Glossary Item Box

Device Length.

Syntax

public int DeviceLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceSequence Field

Glossary Item Box

Device Sequence.

Syntax

public int DeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceSerialNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceSerialNumber Field

Glossary Item Box

Device Serial Number.

Syntax

public int DeviceSerialNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceUID Field

Glossary Item Box

Device UID.

Syntax

public int DeviceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DeviceVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DeviceVolume Field

Glossary Item Box

Device Volume.

Syntax

public int DeviceVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DIALOGReceiver Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DIALOGReceiver Field

Glossary Item Box

DIALOG Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DIALOGReceiver

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiaphragmPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiaphragmPosition Field

Glossary Item Box

Diaphragm Position.

Syntax

public int DiaphragmPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DifferentialWaveformSourceModifiers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DifferentialWaveformSourceModifiers Field

Glossary Item Box

Differential Waveform Source Modifiers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DifferentialWaveformSourceModifiers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionAnisotropyType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionAnisotropyType Field

Glossary Item Box

Diffusion Anisotropy Type.

Syntax

public int DiffusionAnisotropyType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBMatrixSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBMatrixSequence Field

Glossary Item Box

Diffusion b-matrix Sequence.

Syntax

public int DiffusionBMatrixSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBvalue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBvalue Field

Glossary Item Box

Diffusion b-value.

Syntax

public int DiffusionBvalue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueXX Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueXX Field

Glossary Item Box

Diffusion b-value XX.

Syntax

public int DiffusionBValueXX

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueXY Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueXY Field

Glossary Item Box

Diffusion b-value XY.

Syntax

public int DiffusionBValueXY

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueXZ Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueXZ Field

Glossary Item Box

Diffusion b-value XZ.

Syntax

public int DiffusionBValueXZ

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueYY Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueYY Field

Glossary Item Box

Diffusion b-value YY.

Syntax

public int DiffusionBValueYY

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueYZ Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueYZ Field

Glossary Item Box

Diffusion b-value YZ.

Syntax

public int DiffusionBValueYZ

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionBValueZZ Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionBValueZZ Field

Glossary Item Box

Diffusion b-value ZZ.

Syntax

public int DiffusionBValueZZ

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionDirectionality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionDirectionality Field

Glossary Item Box

Diffusion Directionality.

Syntax

public int DiffusionDirectionality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionGradientDirectionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionGradientDirectionSequence Field

Glossary Item Box

Diffusion Gradient Direction Sequence.

Syntax

public int DiffusionGradientDirectionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DiffusionGradientOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DiffusionGradientOrientation Field

Glossary Item Box

Diffusion Gradient Orientation.

Syntax

public int DiffusionGradientOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitalImageFormatAcquired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitalImageFormatAcquired Field

Glossary Item Box

Digital Image Format Acquired.

Syntax

public int DigitalImageFormatAcquired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitalSignatureDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitalSignatureDateTime Field

Glossary Item Box

Digital Signature DateTime.

Syntax

public int DigitalSignatureDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitalSignaturePurposeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitalSignaturePurposeCodeSequence Field

Glossary Item Box

Digital Signature Purpose Code Sequence.

Syntax

public int DigitalSignaturePurposeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitalSignaturesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitalSignaturesSequence Field

Glossary Item Box

Digital Signatures Sequence.

Syntax

public int DigitalSignaturesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitalSignatureUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitalSignatureUID Field

Glossary Item Box

Digital Signature UID.

Syntax

public int DigitalSignatureUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DigitizingDeviceTransportDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DigitizingDeviceTransportDirection Field

Glossary Item Box

Digitizing Device Transport Direction.

Syntax

public int DigitizingDeviceTransportDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionDescriptionLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionDescriptionLabel Field

Glossary Item Box

Dimension Description Label.

Syntax

public int DimensionDescriptionLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionIndexPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionIndexPointer Field

Glossary Item Box

Dimension Index Pointer.

Syntax

public int DimensionIndexPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionIndexPrivateCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionIndexPrivateCreator Field

Glossary Item Box

Dimension Index Private Creator.

Syntax

public int DimensionIndexPrivateCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionIndexSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionIndexSequence Field

Glossary Item Box

Dimension Index Sequence.

Syntax

public int DimensionIndexSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionIndexValues Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionIndexValues Field

Glossary Item Box

Dimension Index Values.

Syntax

public int DimensionIndexValues

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionOrganizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionOrganizationSequence Field

Glossary Item Box

Dimension Organization Sequence.

Syntax

public int DimensionOrganizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionOrganizationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionOrganizationType Field

Glossary Item Box

Dimension Organization Type.

Syntax

public int DimensionOrganizationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DimensionOrganizationUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DimensionOrganizationUID Field

Glossary Item Box

Dimension Organization UID.

Syntax

public int DimensionOrganizationUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DirectoryRecordSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DirectoryRecordSequence Field

Glossary Item Box

Directory Record Sequence.

Syntax

public int DirectoryRecordSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DirectoryRecordType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DirectoryRecordType Field

Glossary Item Box

Directory Record Type.

Syntax

public int DirectoryRecordType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DischargeDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DischargeDate Field

Glossary Item Box

Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DischargeDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DischargeDiagnosisCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DischargeDiagnosisCodeSequence Field

Glossary Item Box

Discharge Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DischargeDiagnosisCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DischargeDiagnosisDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DischargeDiagnosisDescription Field

Glossary Item Box

Discharge Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DischargeDiagnosisDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DischargeTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DischargeTime Field

Glossary Item Box

Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DischargeTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayedAreaBottomRightHandCorner Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayedAreaBottomRightHandCorner Field

Glossary Item Box

Displayed Area Bottom Right Hand Corner.

Syntax

public int DisplayedAreaBottomRightHandCorner

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayedAreaBottomRightHandCornerTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayedAreaBottomRightHandCornerTrial Field

Glossary Item Box

Displayed Area Bottom Right Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DisplayedAreaBottomRightHandCornerTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayedAreaSelectionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayedAreaSelectionSequence Field

Glossary Item Box

Displayed Area Selection Sequence.

Syntax

public int DisplayedAreaSelectionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayedAreaTopLeftHandCorner Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayedAreaTopLeftHandCorner Field

Glossary Item Box

Displayed Area Top Left Hand Corner.

Syntax

public int DisplayedAreaTopLeftHandCorner

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayedAreaTopLeftHandCornerTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayedAreaTopLeftHandCornerTrial Field

Glossary Item Box

Displayed Area Top Left Hand Corner (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DisplayedAreaTopLeftHandCornerTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayEnvironmentSpatialPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayEnvironmentSpatialPosition Field

Glossary Item Box

Display Environment Spatial Position.

Syntax

public int DisplayEnvironmentSpatialPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayFilterPercentage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayFilterPercentage Field

Glossary Item Box

Display Filter Percentage.

Syntax

public int DisplayFilterPercentage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayFormat Field

Glossary Item Box

Display Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DisplayFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetHorizontalJustification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetHorizontalJustification Field

Glossary Item Box

Display Set Horizontal Justification.

Syntax

public int DisplaySetHorizontalJustification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetLabel Field

Glossary Item Box

Display Set Label.

Syntax

public int DisplaySetLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetNumber Field

Glossary Item Box

Display Set Number.

Syntax

public int DisplaySetNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetPatientOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetPatientOrientation Field

Glossary Item Box

Display Set Patient Orientation.

Syntax

public int DisplaySetPatientOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetPresentationGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetPresentationGroup Field

Glossary Item Box

Display Set Presentation Group.

Syntax

public int DisplaySetPresentationGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetPresentationGroupDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetPresentationGroupDescription Field

Glossary Item Box

Display Set Presentation Group Description.

Syntax

public int DisplaySetPresentationGroupDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetScrollingGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetScrollingGroup Field

Glossary Item Box

Display Set Scrolling Group.

Syntax

public int DisplaySetScrollingGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetsSequence Field

Glossary Item Box

Display Sets Sequence.

Syntax

public int DisplaySetsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplaySetVerticalJustification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplaySetVerticalJustification Field

Glossary Item Box

Display Set Vertical Justification.

Syntax

public int DisplaySetVerticalJustification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayShadingFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayShadingFlag Field

Glossary Item Box

Display Shading Flag.

Syntax

public int DisplayShadingFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DisplayWindowLabelVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DisplayWindowLabelVector Field

Glossary Item Box

Display Window Label Vector.

Syntax

public int DisplayWindowLabelVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceObjecttoTableTop Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceObjecttoTableTop Field

Glossary Item Box

Distance Object to Table Top.

Syntax

public int DistanceObjecttoTableTop

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistancePupillaryDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistancePupillaryDistance Field

Glossary Item Box

Distance Pupillary Distance.

Syntax

public int DistancePupillaryDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceReceptorPlanetoDetectorHousing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceReceptorPlanetoDetectorHousing Field

Glossary Item Box

Distance Receptor Plane to Detector Housing.

Syntax

public int DistanceReceptorPlanetoDetectorHousing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourcetoDataCollectionCenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourcetoDataCollectionCenter Field

Glossary Item Box

Distance Source to Data Collection Center.

Syntax

public int DistanceSourcetoDataCollectionCenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourceToDetector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourceToDetector Field

Glossary Item Box

Distance Source to Detector.

Syntax

public int DistanceSourceToDetector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourceToEntrance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourceToEntrance Field

Glossary Item Box

Distance Source to Entrance.

Syntax

public int DistanceSourceToEntrance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourcetoIsocenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourcetoIsocenter Field

Glossary Item Box

Distance Source to Isocenter.

Syntax

public int DistanceSourcetoIsocenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourceToPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourceToPatient Field

Glossary Item Box

Distance Source to Patient.

Syntax

public int DistanceSourceToPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistanceSourcetoSupport Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistanceSourcetoSupport Field

Glossary Item Box

Distance Source to Support. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DistanceSourcetoSupport

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistributionAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistributionAddress Field

Glossary Item Box

Distribution Address. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DistributionAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistributionName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistributionName Field

Glossary Item Box

Distribution Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DistributionName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DistributionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DistributionType Field

Glossary Item Box

Distribution Type.

Syntax

public int DistributionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DocumentTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DocumentTitle Field

Glossary Item Box

Document Title.

Syntax

public int DocumentTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DopplerCorrectionAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DopplerCorrectionAngle Field

Glossary Item Box

Doppler Correction Angle.

Syntax

public int DopplerCorrectionAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DopplerSampleVolumeXPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DopplerSampleVolumeXPosition Field

Glossary Item Box

Doppler Sample Volume X Position.

Syntax

public int DopplerSampleVolumeXPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DopplerSampleVolumeXPositionRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DopplerSampleVolumeXPositionRetired Field

Glossary Item Box

Doppler Sample Volume X Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DopplerSampleVolumeXPositionRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DopplerSampleVolumeYPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DopplerSampleVolumeYPosition Field

Glossary Item Box

Doppler Sample Volume Y Position.

Syntax

public int DopplerSampleVolumeYPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DopplerSampleVolumeYPositionRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DopplerSampleVolumeYPositionRetired Field

Glossary Item Box

Doppler Sample Volume Y Position (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DopplerSampleVolumeYPositionRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseCalibrationFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseCalibrationFactor Field

Glossary Item Box

Dose Calibration Factor.

Syntax

public int DoseCalibrationFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseComment Field

Glossary Item Box

Dose Comment.

Syntax

public int DoseComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseGridScaling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseGridScaling Field

Glossary Item Box

Dose Grid Scaling.

Syntax

public int DoseGridScaling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseRateDelivered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseRateDelivered Field

Glossary Item Box

Dose Rate Delivered.

Syntax

public int DoseRateDelivered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseRateSet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseRateSet Field

Glossary Item Box

Dose Rate Set.

Syntax

public int DoseRateSet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceDescription Field

Glossary Item Box

Dose Reference Description.

Syntax

public int DoseReferenceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceNumber Field

Glossary Item Box

Dose Reference Number.

Syntax

public int DoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferencePointCoordinates Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferencePointCoordinates Field

Glossary Item Box

Dose Reference Point Coordinates.

Syntax

public int DoseReferencePointCoordinates

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceSequence Field

Glossary Item Box

Dose Reference Sequence.

Syntax

public int DoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceStructureType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceStructureType Field

Glossary Item Box

Dose Reference Structure Type.

Syntax

public int DoseReferenceStructureType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceType Field

Glossary Item Box

Dose Reference Type.

Syntax

public int DoseReferenceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseReferenceUID Field

Glossary Item Box

Dose Reference UID.

Syntax

public int DoseReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseSummationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseSummationType Field

Glossary Item Box

Dose Summation Type.

Syntax

public int DoseSummationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseType Field

Glossary Item Box

Dose Type.

Syntax

public int DoseType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseUnits Field

Glossary Item Box

Dose Units.

Syntax

public int DoseUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoseValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoseValue Field

Glossary Item Box

Dose Value.

Syntax

public int DoseValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoubleExposureFieldDelta Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoubleExposureFieldDelta Field

Glossary Item Box

Double Exposure Field Delta.

Syntax

public int DoubleExposureFieldDelta

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoubleExposureFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoubleExposureFlag Field

Glossary Item Box

Double Exposure Flag.

Syntax

public int DoubleExposureFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoubleExposureMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoubleExposureMeterset Field

Glossary Item Box

Double Exposure Meterset.

Syntax

public int DoubleExposureMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DoubleExposureOrdering Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DoubleExposureOrdering Field

Glossary Item Box

Double Exposure Ordering.

Syntax

public int DoubleExposureOrdering

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhData Field

Glossary Item Box

The DVH Data.

Syntax

public int DvhData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhDoseScaling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhDoseScaling Field

Glossary Item Box

DVH Dose Scaling.

Syntax

public int DvhDoseScaling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhMaximumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhMaximumDose Field

Glossary Item Box

DVH Maximum Dose.

Syntax

public int DvhMaximumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhMeanDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhMeanDose Field

Glossary Item Box

DVH Mean Dose.

Syntax

public int DvhMeanDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhMinimumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhMinimumDose Field

Glossary Item Box

DVH Minimum Dose.

Syntax

public int DvhMinimumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhNormalizationDoseValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhNormalizationDoseValue Field

Glossary Item Box

DVH Normalization Dose Value.

Syntax

public int DvhNormalizationDoseValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhNormalizationPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhNormalizationPoint Field

Glossary Item Box

DVH Normalization Point.

Syntax

public int DvhNormalizationPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhNumberOfBins Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhNumberOfBins Field

Glossary Item Box

DVH Number of Bins.

Syntax

public int DvhNumberOfBins

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhReferencedRoiSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhReferencedRoiSequence Field

Glossary Item Box

DVH Referenced ROI Sequence.

Syntax

public int DvhReferencedRoiSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhRoiContributionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhRoiContributionType Field

Glossary Item Box

DVH ROI Contribution Type.

Syntax

public int DvhRoiContributionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhSequence Field

Glossary Item Box

DVH Sequence.

Syntax

public int DvhSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhType Field

Glossary Item Box

DVH (Dose-volume histogram) Type.

Syntax

public int DvhType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DvhVolumeUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DvhVolumeUnits Field

Glossary Item Box

DVH Volume Units.

Syntax

public int DvhVolumeUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

DynamicRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : DynamicRange Field

Glossary Item Box

Dynamic Range. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int DynamicRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EchoNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EchoNumbers Field

Glossary Item Box

Echo Number(s).

Syntax

public int EchoNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EchoPlanarPulseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EchoPlanarPulseSequence Field

Glossary Item Box

Echo Planar Pulse Sequence.

Syntax

public int EchoPlanarPulseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EchoPulseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EchoPulseSequence Field

Glossary Item Box

Echo Pulse Sequence.

Syntax

public int EchoPulseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EchoTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EchoTime Field

Glossary Item Box

Echo Time.

Syntax

public int EchoTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EchoTrainLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EchoTrainLength Field

Glossary Item Box

Echo Train Length.

Syntax

public int EchoTrainLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EdgePointIndexList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EdgePointIndexList Field

Glossary Item Box

Edge Point Index List.

Syntax

public int EdgePointIndexList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EffectiveDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EffectiveDuration Field

Glossary Item Box

Effective Duration.

Syntax

public int EffectiveDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EffectiveEchoTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EffectiveEchoTime Field

Glossary Item Box

Effective Echo Time.

Syntax

public int EffectiveEchoTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EmmetropicMagnification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EmmetropicMagnification Field

Glossary Item Box

Emmetropic Magnification.

Syntax

public int EmmetropicMagnification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EmptyImageBoxCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EmptyImageBoxCIELabValue Field

Glossary Item Box

Empty Image Box CIELab Value.

Syntax

public int EmptyImageBoxCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EmptyImageDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EmptyImageDensity Field

Glossary Item Box

Empty Image Density.

Syntax

public int EmptyImageDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EncapsulatedDocument Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EncapsulatedDocument Field

Glossary Item Box

Encapsulated Document.

Syntax

public int EncapsulatedDocument

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EncryptedAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EncryptedAttributesSequence Field

Glossary Item Box

Encrypted Attributes Sequence.

Syntax

public int EncryptedAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EncryptedContent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EncryptedContent Field

Glossary Item Box

Encrypted Content.

Syntax

public int EncryptedContent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EncryptedContentTransferSyntaxUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EncryptedContentTransferSyntaxUID Field

Glossary Item Box

Encrypted Content Transfer Syntax UID.

Syntax

public int EncryptedContentTransferSyntaxUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndAcquisitionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndAcquisitionDateTime Field

Glossary Item Box

End Acquisition DateTime.

Syntax

public int EndAcquisitionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndCumulativeMetersetWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndCumulativeMetersetWeight Field

Glossary Item Box

End Cumulative Meterset Weight.

Syntax

public int EndCumulativeMetersetWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndingRespiratoryAmplitude Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndingRespiratoryAmplitude Field

Glossary Item Box

Ending Respiratory Amplitude.

Syntax

public int EndingRespiratoryAmplitude

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndingRespiratoryPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndingRespiratoryPhase Field

Glossary Item Box

Ending Respiratory Phase.

Syntax

public int EndingRespiratoryPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndMessageID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndMessageID Field

Glossary Item Box

End Message ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int EndMessageID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EndMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EndMeterset Field

Glossary Item Box

End Meterset.

Syntax

public int EndMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWeightingFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWeightingFactor Field

Glossary Item Box

Energy Weighting Factor.

Syntax

public int EnergyWeightingFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowCenterline Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowCenterline Field

Glossary Item Box

Energy Window Centerline. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int EnergyWindowCenterline

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowInformationSequence Field

Glossary Item Box

Energy Window Information Sequence.

Syntax

public int EnergyWindowInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowLowerLimit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowLowerLimit Field

Glossary Item Box

Energy Window Lower Limit.

Syntax

public int EnergyWindowLowerLimit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowName Field

Glossary Item Box

Energy Window Name.

Syntax

public int EnergyWindowName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowNumber Field

Glossary Item Box

Energy Window Number.

Syntax

public int EnergyWindowNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowRangeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowRangeSequence Field

Glossary Item Box

Energy Window Range Sequence.

Syntax

public int EnergyWindowRangeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowTotalWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowTotalWidth Field

Glossary Item Box

Energy Window Total Width. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int EnergyWindowTotalWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowUpperLimit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowUpperLimit Field

Glossary Item Box

Energy Window Upper Limit.

Syntax

public int EnergyWindowUpperLimit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnergyWindowVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnergyWindowVector Field

Glossary Item Box

Energy Window Vector.

Syntax

public int EnergyWindowVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EnhancedPaletteColorLookupTableSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EnhancedPaletteColorLookupTableSequence Field

Glossary Item Box

Enhanced Palette Color Lookup Table Sequence.

Syntax

public int EnhancedPaletteColorLookupTableSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EntranceDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EntranceDose Field

Glossary Item Box

Entrance Dose.

Syntax

public int EntranceDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EntranceDoseInmGy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EntranceDoseInmGy Field

Glossary Item Box

Entrance Dose in mGy.

Syntax

public int EntranceDoseInmGy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EquipmentCoordinateSystemIdentification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EquipmentCoordinateSystemIdentification Field

Glossary Item Box

Equipment Coordinate System Identification.

Syntax

public int EquipmentCoordinateSystemIdentification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EquivalentCDADocumentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EquivalentCDADocumentSequence Field

Glossary Item Box

Equivalent CDA Document Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int EquivalentCDADocumentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Erase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Erase Field

Glossary Item Box

Erase. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Erase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ErrorComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ErrorComment Field

Glossary Item Box

Error Comment.

Syntax

public int ErrorComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ErrorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ErrorID Field

Glossary Item Box

Error Identifier.

Syntax

public int ErrorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EscapeTriplet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EscapeTriplet Field

Glossary Item Box

Escape Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int EscapeTriplet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EstimatedDoseSaving Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EstimatedDoseSaving Field

Glossary Item Box

Estimated Dose Saving.

Syntax

public int EstimatedDoseSaving

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EstimatedRadiographicMagnificationFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EstimatedRadiographicMagnificationFactor Field

Glossary Item Box

Estimated Radiographic Magnification Factor.

Syntax

public int EstimatedRadiographicMagnificationFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EthnicGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EthnicGroup Field

Glossary Item Box

Ethnic Group.

Syntax

public int EthnicGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventCodeSequence Field

Glossary Item Box

Event Code Sequence.

Syntax

public int EventCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventElapsedTimes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventElapsedTimes Field

Glossary Item Box

Event Elapsed Time(s).

Syntax

public int EventElapsedTimes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventTimeOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventTimeOffset Field

Glossary Item Box

Event Time Offset.

Syntax

public int EventTimeOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventTimerNames Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventTimerNames Field

Glossary Item Box

Event Timer Name(s).

Syntax

public int EventTimerNames

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventTimerSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventTimerSequence Field

Glossary Item Box

Event Timer Sequence.

Syntax

public int EventTimerSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

EventTypeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : EventTypeID Field

Glossary Item Box

Event Type ID.

Syntax

public int EventTypeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExaminedBodyThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExaminedBodyThickness Field

Glossary Item Box

Examined Body Thickness.

Syntax

public int ExaminedBodyThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExcludedIntervalsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExcludedIntervalsSequence Field

Glossary Item Box

Excluded Intervals Sequence.

Syntax

public int ExcludedIntervalsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExclusionDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExclusionDuration Field

Glossary Item Box

Exclusion Duration.

Syntax

public int ExclusionDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExclusionStartDatetime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExclusionStartDatetime Field

Glossary Item Box

Exclusion Start Datetime.

Syntax

public int ExclusionStartDatetime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExecutionStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExecutionStatus Field

Glossary Item Box

Execution Status.

Syntax

public int ExecutionStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExecutionStatusInfo Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExecutionStatusInfo Field

Glossary Item Box

Execution Status Info.

Syntax

public int ExecutionStatusInfo

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExpectedCompletionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExpectedCompletionDateTime Field

Glossary Item Box

Expected Completion Date Time.

Syntax

public int ExpectedCompletionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposedArea Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposedArea Field

Glossary Item Box

Exposed Area.

Syntax

public int ExposedArea

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Exposure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Exposure Field

Glossary Item Box

Exposure value.

Syntax

public int Exposure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlMode Field

Glossary Item Box

Exposure Control Mode.

Syntax

public int ExposureControlMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlModeDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlModeDescription Field

Glossary Item Box

Exposure Control Mode Description.

Syntax

public int ExposureControlModeDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionLeftVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionLeftVerticalEdge Field

Glossary Item Box

Exposure Control Sensing Region Left Vertical Edge.

Syntax

public int ExposureControlSensingRegionLeftVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionLowerHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionLowerHorizontalEdge Field

Glossary Item Box

Exposure Control Sensing Region Lower Horizontal Edge.

Syntax

public int ExposureControlSensingRegionLowerHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionRightVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionRightVerticalEdge Field

Glossary Item Box

Exposure Control Sensing Region Right Vertical Edge.

Syntax

public int ExposureControlSensingRegionRightVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionShape Field

Glossary Item Box

Exposure Control Sensing Region Shape.

Syntax

public int ExposureControlSensingRegionShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionsSequence Field

Glossary Item Box

Exposure Control Sensing Regions Sequence.

Syntax

public int ExposureControlSensingRegionsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureControlSensingRegionUpperHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureControlSensingRegionUpperHorizontalEdge Field

Glossary Item Box

Exposure Control Sensing Region Upper Horizontal Edge.

Syntax

public int ExposureControlSensingRegionUpperHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureDoseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureDoseSequence Field

Glossary Item Box

Exposure Dose Sequence.

Syntax

public int ExposureDoseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureinmAs Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureinmAs Field

Glossary Item Box

Exposure in mAs.

Syntax

public int ExposureinmAs

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureInMicroAs Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureInMicroAs Field

Glossary Item Box

Exposure in micro As.

Syntax

public int ExposureInMicroAs

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureModulationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureModulationType Field

Glossary Item Box

Exposure Modulation Type.

Syntax

public int ExposureModulationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureSequence Field

Glossary Item Box

Exposure Sequence.

Syntax

public int ExposureSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposuresOnDetectorSinceLastCalibration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposuresOnDetectorSinceLastCalibration Field

Glossary Item Box

Exposures on Detector Since Last Calibration.

Syntax

public int ExposuresOnDetectorSinceLastCalibration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposuresOnDetectorSinceManufactured Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposuresOnDetectorSinceManufactured Field

Glossary Item Box

Exposures on Detector Since Manufactured.

Syntax

public int ExposuresOnDetectorSinceManufactured

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposuresOnPlate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposuresOnPlate Field

Glossary Item Box

Exposures on Plate.

Syntax

public int ExposuresOnPlate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureStatus Field

Glossary Item Box

Exposure Status.

Syntax

public int ExposureStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureTime Field

Glossary Item Box

Exposure Time.

Syntax

public int ExposureTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureTimeinms Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureTimeinms Field

Glossary Item Box

Exposure Time in ms.

Syntax

public int ExposureTimeinms

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ExposureTimeInuS Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ExposureTimeInuS Field

Glossary Item Box

Exposure Time in micro S.

Syntax

public int ExposureTimeInuS

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FacetSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FacetSequence Field

Glossary Item Box

Facet Sequence.

Syntax

public int FacetSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FailedAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FailedAttributesSequence Field

Glossary Item Box

Failed Attributes Sequence.

Syntax

public int FailedAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FailedSOPInstanceUIDList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FailedSOPInstanceUIDList Field

Glossary Item Box

Failed SOP Instance UID List.

Syntax

public int FailedSOPInstanceUIDList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FailedSOPSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FailedSOPSequence Field

Glossary Item Box

Failed SOP Sequence.

Syntax

public int FailedSOPSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FailureAttributes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FailureAttributes Field

Glossary Item Box

Failure Attributes.

Syntax

public int FailureAttributes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FailureReason Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FailureReason Field

Glossary Item Box

Failure Reason.

Syntax

public int FailureReason

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialDescription Field

Glossary Item Box

Fiducial Description.

Syntax

public int FiducialDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialIdentifier Field

Glossary Item Box

Fiducial Identifier.

Syntax

public int FiducialIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialIdentifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialIdentifierCodeSequence Field

Glossary Item Box

Fiducial Identifier Code Sequence.

Syntax

public int FiducialIdentifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialSequence Field

Glossary Item Box

Fiducial Sequence.

Syntax

public int FiducialSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialSetSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialSetSequence Field

Glossary Item Box

Fiducial Set Sequence.

Syntax

public int FiducialSetSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiducialUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiducialUID Field

Glossary Item Box

Fiducial UID.

Syntax

public int FiducialUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldofViewDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldofViewDescription Field

Glossary Item Box

Field of View Description.

Syntax

public int FieldofViewDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldOfViewDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldOfViewDimensions Field

Glossary Item Box

Field of View Dimension(s).

Syntax

public int FieldOfViewDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldofViewDimensionsInFloat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldofViewDimensionsInFloat Field

Glossary Item Box

Field of View Dimension(s) in Float.

Syntax

public int FieldofViewDimensionsInFloat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldOfViewHorizontalFlip Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldOfViewHorizontalFlip Field

Glossary Item Box

Field of View Horizontal Flip.

Syntax

public int FieldOfViewHorizontalFlip

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldOfViewOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldOfViewOrigin Field

Glossary Item Box

Field of View Origin.

Syntax

public int FieldOfViewOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldOfViewRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldOfViewRotation Field

Glossary Item Box

Field of View Rotation.

Syntax

public int FieldOfViewRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldofViewSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldofViewSequence Field

Glossary Item Box

Field of View Sequence.

Syntax

public int FieldofViewSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FieldOfViewShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FieldOfViewShape Field

Glossary Item Box

Field of View Shape.

Syntax

public int FieldOfViewShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FileMetaInformationGroupLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FileMetaInformationGroupLength Field

Glossary Item Box

File Meta Information Group Length.

Syntax

public int FileMetaInformationGroupLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FileMetaInformationVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FileMetaInformationVersion Field

Glossary Item Box

File Meta Information Version.

Syntax

public int FileMetaInformationVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilesetConsistencyFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilesetConsistencyFlag Field

Glossary Item Box

File-set Consistency Flag.

Syntax

public int FilesetConsistencyFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilesetDescriptorFileID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilesetDescriptorFileID Field

Glossary Item Box

File-set Descriptor File ID.

Syntax

public int FilesetDescriptorFileID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilesetID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilesetID Field

Glossary Item Box

File-set ID.

Syntax

public int FilesetID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FillerOrderNumberImagingServiceRequest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FillerOrderNumberImagingServiceRequest Field

Glossary Item Box

Filler Order Number / Imaging Service Request.

Syntax

public int FillerOrderNumberImagingServiceRequest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FillerOrderNumberImagingServiceRequestRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FillerOrderNumberImagingServiceRequestRetired Field

Glossary Item Box

Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int FillerOrderNumberImagingServiceRequestRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FillerOrderNumberProcedure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FillerOrderNumberProcedure Field

Glossary Item Box

Filler Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int FillerOrderNumberProcedure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmBoxContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmBoxContentSequence Field

Glossary Item Box

Film Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int FilmBoxContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmConsumptionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmConsumptionSequence Field

Glossary Item Box

Film Consumption Sequence.

Syntax

public int FilmConsumptionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmDestination Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmDestination Field

Glossary Item Box

Film Destination.

Syntax

public int FilmDestination

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmOrientation Field

Glossary Item Box

Film Orientation.

Syntax

public int FilmOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmSessionLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmSessionLabel Field

Glossary Item Box

Film Session Label.

Syntax

public int FilmSessionLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilmSizeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilmSizeID Field

Glossary Item Box

Film Size ID.

Syntax

public int FilmSizeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterBeamPathLengthMaximum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterBeamPathLengthMaximum Field

Glossary Item Box

Filter Beam Path Length Maximum.

Syntax

public int FilterBeamPathLengthMaximum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterBeamPathLengthMinimum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterBeamPathLengthMinimum Field

Glossary Item Box

Filter Beam Path Length Minimum.

Syntax

public int FilterBeamPathLengthMinimum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterbyAttributePresence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterbyAttributePresence Field

Glossary Item Box

Filter-by Attribute Presence.

Syntax

public int FilterbyAttributePresence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterbyCategory Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterbyCategory Field

Glossary Item Box

Filter-by Category.

Syntax

public int FilterbyCategory

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterbyOperator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterbyOperator Field

Glossary Item Box

Filter-by Operator.

Syntax

public int FilterbyOperator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterHighFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterHighFrequency Field

Glossary Item Box

Filter High Frequency.

Syntax

public int FilterHighFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterLowFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterLowFrequency Field

Glossary Item Box

Filter Low Frequency.

Syntax

public int FilterLowFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterMaterial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterMaterial Field

Glossary Item Box

Filter Material.

Syntax

public int FilterMaterial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterOperationsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterOperationsSequence Field

Glossary Item Box

Filter Operations Sequence.

Syntax

public int FilterOperationsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterThicknessMaximum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterThicknessMaximum Field

Glossary Item Box

Filter Thickness Maximum.

Syntax

public int FilterThicknessMaximum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterThicknessMinimum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterThicknessMinimum Field

Glossary Item Box

Filter Thickness Minimum.

Syntax

public int FilterThicknessMinimum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FilterType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FilterType Field

Glossary Item Box

Filter Type.

Syntax

public int FilterType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FinalCumulativeMetersetWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FinalCumulativeMetersetWeight Field

Glossary Item Box

Final Cumulative Meterset Weight.

Syntax

public int FinalCumulativeMetersetWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FinalCumulativeTimeWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FinalCumulativeTimeWeight Field

Glossary Item Box

Final Cumulative Time Weight.

Syntax

public int FinalCumulativeTimeWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FindLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FindLocation Field

Glossary Item Box

Find Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int FindLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FiniteVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FiniteVolume Field

Glossary Item Box

Finite Volume.

Syntax

public int FiniteVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FirstOrderPhaseCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FirstOrderPhaseCorrection Field

Glossary Item Box

First Order Phase Correction.

Syntax

public int FirstOrderPhaseCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FirstOrderPhaseCorrectionAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FirstOrderPhaseCorrectionAngle Field

Glossary Item Box

First Order Phase Correction Angle.

Syntax

public int FirstOrderPhaseCorrectionAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FirstTreatmentDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FirstTreatmentDate Field

Glossary Item Box

First Treatment Date.

Syntax

public int FirstTreatmentDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDeviceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDeviceDescription Field

Glossary Item Box

Fixation Device Description.

Syntax

public int FixationDeviceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDeviceLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDeviceLabel Field

Glossary Item Box

Fixation Device Label.

Syntax

public int FixationDeviceLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDevicePitchAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDevicePitchAngle Field

Glossary Item Box

Fixation Device Pitch Angle.

Syntax

public int FixationDevicePitchAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDevicePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDevicePosition Field

Glossary Item Box

Fixation Device Position.

Syntax

public int FixationDevicePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDeviceRollAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDeviceRollAngle Field

Glossary Item Box

Fixation Device Roll Angle.

Syntax

public int FixationDeviceRollAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDeviceSequence Field

Glossary Item Box

Fixation Device Sequence.

Syntax

public int FixationDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationDeviceType Field

Glossary Item Box

Fixation Device Type.

Syntax

public int FixationDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationLightAzimuthalAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationLightAzimuthalAngle Field

Glossary Item Box

Fixation Light Azimuthal Angle.

Syntax

public int FixationLightAzimuthalAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FixationLightPolarAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FixationLightPolarAngle Field

Glossary Item Box

Fixation Light Polar Angle.

Syntax

public int FixationLightPolarAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FlatKeratometricAxisSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FlatKeratometricAxisSequence Field

Glossary Item Box

Flat Keratometric Axis Sequence.

Syntax

public int FlatKeratometricAxisSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FlipAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FlipAngle Field

Glossary Item Box

Flip Angle.

Syntax

public int FlipAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FlowCompensation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FlowCompensation Field

Glossary Item Box

Flow Compensation.

Syntax

public int FlowCompensation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FlowCompensationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FlowCompensationDirection Field

Glossary Item Box

Flow Compensation Direction.

Syntax

public int FlowCompensationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluenceDataScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluenceDataScale Field

Glossary Item Box

Fluence Data Scale.

Syntax

public int FluenceDataScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluenceDataSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluenceDataSource Field

Glossary Item Box

Fluence Data Source.

Syntax

public int FluenceDataSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluenceMapSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluenceMapSequence Field

Glossary Item Box

Fluence Map Sequence.

Syntax

public int FluenceMapSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluenceMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluenceMode Field

Glossary Item Box

Fluence Mode.

Syntax

public int FluenceMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluenceModeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluenceModeID Field

Glossary Item Box

Fluence Mode ID.

Syntax

public int FluenceModeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FluoroscopyFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FluoroscopyFlag Field

Glossary Item Box

Fluoroscopy Flag.

Syntax

public int FluoroscopyFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FocalDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FocalDistance Field

Glossary Item Box

Focal Distance.

Syntax

public int FocalDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FocalSpots Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FocalSpots Field

Glossary Item Box

Focal Spot(s).

Syntax

public int FocalSpots

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FocusDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FocusDepth Field

Glossary Item Box

Focus Depth.

Syntax

public int FocusDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FORMAT Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FORMAT Field

Glossary Item Box

DICOM format marker.

Syntax

public int FORMAT

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionalChannelDisplayScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionalChannelDisplayScale Field

Glossary Item Box

Fractional Channel Display Scale.

Syntax

public int FractionalChannelDisplayScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionGroupDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionGroupDescription Field

Glossary Item Box

Fraction Group Description.

Syntax

public int FractionGroupDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionGroupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionGroupNumber Field

Glossary Item Box

Fraction Group Number.

Syntax

public int FractionGroupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionGroupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionGroupSequence Field

Glossary Item Box

Fraction Group Sequence.

Syntax

public int FractionGroupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionGroupSummarySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionGroupSummarySequence Field

Glossary Item Box

Fraction Group Summary Sequence.

Syntax

public int FractionGroupSummarySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionGroupType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionGroupType Field

Glossary Item Box

Fraction Group Type.

Syntax

public int FractionGroupType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionNumber Field

Glossary Item Box

Fraction Number.

Syntax

public int FractionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionPattern Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionPattern Field

Glossary Item Box

Fraction Pattern.

Syntax

public int FractionPattern

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FractionStatusSummarySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FractionStatusSummarySequence Field

Glossary Item Box

Fraction Status Summary Sequence.

Syntax

public int FractionStatusSummarySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameAcquisitionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameAcquisitionDateTime Field

Glossary Item Box

Frame Acquisition DateTime.

Syntax

public int FrameAcquisitionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameAcquisitionDuration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameAcquisitionDuration Field

Glossary Item Box

Frame Acquisition Duration.

Syntax

public int FrameAcquisitionDuration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameAcquisitionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameAcquisitionNumber Field

Glossary Item Box

Frame Acquisition Number.

Syntax

public int FrameAcquisitionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameAcquisitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameAcquisitionSequence Field

Glossary Item Box

Frame Acquisition Sequence.

Syntax

public int FrameAcquisitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameAnatomySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameAnatomySequence Field

Glossary Item Box

Frame Anatomy Sequence.

Syntax

public int FrameAnatomySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameComments Field

Glossary Item Box

Frame Comments.

Syntax

public int FrameComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameContentSequence Field

Glossary Item Box

Frame Content Sequence.

Syntax

public int FrameContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameDelay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameDelay Field

Glossary Item Box

Frame Delay.

Syntax

public int FrameDelay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameDetectorParametersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameDetectorParametersSequence Field

Glossary Item Box

Frame Detector Parameters Sequence.

Syntax

public int FrameDetectorParametersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameDimensionPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameDimensionPointer Field

Glossary Item Box

Frame Dimension Pointer.

Syntax

public int FrameDimensionPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameDisplaySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameDisplaySequence Field

Glossary Item Box

Frame Display Sequence.

Syntax

public int FrameDisplaySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameDisplayShutterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameDisplayShutterSequence Field

Glossary Item Box

Frame Display Shutter Sequence.

Syntax

public int FrameDisplayShutterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameExtractionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameExtractionSequence Field

Glossary Item Box

Frame Extraction Sequence.

Syntax

public int FrameExtractionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameIncrementPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameIncrementPointer Field

Glossary Item Box

Frame Increment Pointer.

Syntax

public int FrameIncrementPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameLabel Field

Glossary Item Box

Frame Label.

Syntax

public int FrameLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameLabelVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameLabelVector Field

Glossary Item Box

Frame Label Vector.

Syntax

public int FrameLabelVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameLaterality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameLaterality Field

Glossary Item Box

Frame Laterality.

Syntax

public int FrameLaterality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameNumbersOfInterest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameNumbersOfInterest Field

Glossary Item Box

Frame Numbers of Interest (FOI).

Syntax

public int FrameNumbersOfInterest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfInterestDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfInterestDescription Field

Glossary Item Box

Frame of Interest Description.

Syntax

public int FrameOfInterestDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameofInterestType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameofInterestType Field

Glossary Item Box

Frame of Interest Type.

Syntax

public int FrameofInterestType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfReferenceRelationshipSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfReferenceRelationshipSequence Field

Glossary Item Box

Frame of Reference Relationship Sequence.

Syntax

public int FrameOfReferenceRelationshipSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfReferenceTransformationComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfReferenceTransformationComment Field

Glossary Item Box

Frame of Reference Transformation Comment.

Syntax

public int FrameOfReferenceTransformationComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfReferenceTransformationMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfReferenceTransformationMatrix Field

Glossary Item Box

Frame of Reference Transformation Matrix.

Syntax

public int FrameOfReferenceTransformationMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameofReferenceTransformationMatrixType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameofReferenceTransformationMatrixType Field

Glossary Item Box

Frame of Reference Transformation Matrix Type.

Syntax

public int FrameofReferenceTransformationMatrixType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfReferenceTransformationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfReferenceTransformationType Field

Glossary Item Box

Frame of Reference Transformation Type.

Syntax

public int FrameOfReferenceTransformationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameOfReferenceUID Field

Glossary Item Box

Frame of Reference UID.

Syntax

public int FrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FramePixelDataPropertiesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FramePixelDataPropertiesSequence Field

Glossary Item Box

Frame Pixel Data Properties Sequence.

Syntax

public int FramePixelDataPropertiesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FramePixelShiftSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FramePixelShiftSequence Field

Glossary Item Box

Frame Pixel Shift Sequence.

Syntax

public int FramePixelShiftSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FramePrimaryAngleVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FramePrimaryAngleVector Field

Glossary Item Box

Frame Primary Angle Vector.

Syntax

public int FramePrimaryAngleVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameReferenceDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameReferenceDateTime Field

Glossary Item Box

Frame Reference DateTime.

Syntax

public int FrameReferenceDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameReferenceTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameReferenceTime Field

Glossary Item Box

Frame Reference Time.

Syntax

public int FrameReferenceTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameSecondaryAngleVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameSecondaryAngleVector Field

Glossary Item Box

Frame Secondary Angle Vector.

Syntax

public int FrameSecondaryAngleVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameTime Field

Glossary Item Box

Frame Time.

Syntax

public int FrameTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameTimeVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameTimeVector Field

Glossary Item Box

Frame Time Vector.

Syntax

public int FrameTimeVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameType Field

Glossary Item Box

Frame Type.

Syntax

public int FrameType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrameVoiLutSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrameVoiLutSequence Field

Glossary Item Box

Frame VOI LUT Sequence.

Syntax

public int FrameVoiLutSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FrequencyCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FrequencyCorrection Field

Glossary Item Box

Frequency Correction.

Syntax

public int FrequencyCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FunctionalGroupPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FunctionalGroupPointer Field

Glossary Item Box

Functional Group Pointer.

Syntax

public int FunctionalGroupPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

FunctionalGroupPrivateCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : FunctionalGroupPrivateCreator Field

Glossary Item Box

Functional Group Private Creator.

Syntax

public int FunctionalGroupPrivateCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryAngle Field

Glossary Item Box

Gantry Angle.

Syntax

public int GantryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryAngleTolerance Field

Glossary Item Box

Gantry Angle Tolerance.

Syntax

public int GantryAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryDetectorSlew Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryDetectorSlew Field

Glossary Item Box

Gantry/Detector Slew.

Syntax

public int GantryDetectorSlew

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryDetectorTilt Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryDetectorTilt Field

Glossary Item Box

Gantry/Detector Tilt.

Syntax

public int GantryDetectorTilt

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryID Field

Glossary Item Box

Gantry ID.

Syntax

public int GantryID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryMotionCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryMotionCorrected Field

Glossary Item Box

Gantry Motion Corrected.

Syntax

public int GantryMotionCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryPitchAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryPitchAngle Field

Glossary Item Box

Gantry Pitch Angle.

Syntax

public int GantryPitchAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryPitchAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryPitchAngleTolerance Field

Glossary Item Box

Gantry Pitch Angle Tolerance.

Syntax

public int GantryPitchAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryPitchRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryPitchRotationDirection Field

Glossary Item Box

Gantry Pitch Rotation Direction.

Syntax

public int GantryPitchRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GantryRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GantryRotationDirection Field

Glossary Item Box

Gantry Rotation Direction.

Syntax

public int GantryRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GatedInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GatedInformationSequence Field

Glossary Item Box

Gated Information Sequence.

Syntax

public int GatedInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralAccessoryDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralAccessoryDescription Field

Glossary Item Box

General Accessory Description.

Syntax

public int GeneralAccessoryDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralAccessoryID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralAccessoryID Field

Glossary Item Box

General Accessory ID.

Syntax

public int GeneralAccessoryID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralAccessoryNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralAccessoryNumber Field

Glossary Item Box

General Accessory Number.

Syntax

public int GeneralAccessoryNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralAccessorySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralAccessorySequence Field

Glossary Item Box

General Accessory Sequence.

Syntax

public int GeneralAccessorySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralAccessoryType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralAccessoryType Field

Glossary Item Box

General Accessory Type.

Syntax

public int GeneralAccessoryType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralMachineVerificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralMachineVerificationSequence Field

Glossary Item Box

General Machine Verification Sequence.

Syntax

public int GeneralMachineVerificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralPurposePerformedProcedureStepStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralPurposePerformedProcedureStepStatus Field

Glossary Item Box

General Purpose Performed Procedure Step Status.

Syntax

public int GeneralPurposePerformedProcedureStepStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralPurposeScheduledProcedureStepPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralPurposeScheduledProcedureStepPriority Field

Glossary Item Box

General Purpose Scheduled Procedure Step Priority.

Syntax

public int GeneralPurposeScheduledProcedureStepPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneralPurposeScheduledProcedureStepStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneralPurposeScheduledProcedureStepStatus Field

Glossary Item Box

General Purpose Scheduled Procedure Step Status.

Syntax

public int GeneralPurposeScheduledProcedureStepStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneratorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneratorID Field

Glossary Item Box

Generator ID.

Syntax

public int GeneratorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeneratorPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeneratorPower Field

Glossary Item Box

Generator Power.

Syntax

public int GeneratorPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeometricalProperties Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeometricalProperties Field

Glossary Item Box

Geometrical Properties.

Syntax

public int GeometricalProperties

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeometricMaximumDistortion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeometricMaximumDistortion Field

Glossary Item Box

Geometric Maximum Distortion.

Syntax

public int GeometricMaximumDistortion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GeometryOfKspaceTraversal Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GeometryOfKspaceTraversal Field

Glossary Item Box

Geometry of k-Space Traversal.

Syntax

public int GeometryOfKspaceTraversal

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GradientEchoTrainLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GradientEchoTrainLength Field

Glossary Item Box

Gradient Echo Train Length.

Syntax

public int GradientEchoTrainLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GradientOutput Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GradientOutput Field

Glossary Item Box

Gradient Output.

Syntax

public int GradientOutput

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GradientOutputType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GradientOutputType Field

Glossary Item Box

Gradient Output Type.

Syntax

public int GradientOutputType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicAnnotationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicAnnotationSequence Field

Glossary Item Box

Graphic Annotation Sequence.

Syntax

public int GraphicAnnotationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicAnnotationUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicAnnotationUnits Field

Glossary Item Box

Graphic Annotation Units.

Syntax

public int GraphicAnnotationUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicCoordinatesDataSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicCoordinatesDataSequence Field

Glossary Item Box

Graphic Coordinates Data Sequence.

Syntax

public int GraphicCoordinatesDataSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicData Field

Glossary Item Box

Graphic Data.

Syntax

public int GraphicData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicDimensions Field

Glossary Item Box

Graphic Dimensions.

Syntax

public int GraphicDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicFilled Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicFilled Field

Glossary Item Box

Graphic Filled.

Syntax

public int GraphicFilled

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayer Field

Glossary Item Box

Graphic Layer.

Syntax

public int GraphicLayer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerDescription Field

Glossary Item Box

Graphic Layer Description.

Syntax

public int GraphicLayerDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerOrder Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerOrder Field

Glossary Item Box

Graphic Layer Order.

Syntax

public int GraphicLayerOrder

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerRecommendedDisplayCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerRecommendedDisplayCIELabValue Field

Glossary Item Box

Graphic Layer Recommended Display CIELab Value.

Syntax

public int GraphicLayerRecommendedDisplayCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerRecommendedDisplayGrayscaleValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerRecommendedDisplayGrayscaleValue Field

Glossary Item Box

Graphic Layer Recommended Display Grayscale Value.

Syntax

public int GraphicLayerRecommendedDisplayGrayscaleValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerRecommendedDisplayRGBValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerRecommendedDisplayRGBValue Field

Glossary Item Box

Graphic Layer Recommended Display RGB Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int GraphicLayerRecommendedDisplayRGBValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicLayerSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicLayerSequence Field

Glossary Item Box

Graphic Layer Sequence.

Syntax

public int GraphicLayerSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicObjectSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicObjectSequence Field

Glossary Item Box

Graphic Object Sequence.

Syntax

public int GraphicObjectSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GraphicType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GraphicType Field

Glossary Item Box

Graphic Type.

Syntax

public int GraphicType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GrayLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GrayLookupTableData Field

Glossary Item Box

Gray Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int GrayLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GrayLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GrayLookupTableDescriptor Field

Glossary Item Box

Gray Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int GrayLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GrayScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GrayScale Field

Glossary Item Box

Gray Scale. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int GrayScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GreenPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GreenPaletteColorLookupTableData Field

Glossary Item Box

Green Palette Color Lookup Table Data.

Syntax

public int GreenPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GreenPaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GreenPaletteColorLookupTableDescriptor Field

Glossary Item Box

Green Palette Color Lookup Table Descriptor.

Syntax

public int GreenPaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Grid Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Grid Field

Glossary Item Box

Grid value.

Syntax

public int Grid

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridAbsorbingMaterial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridAbsorbingMaterial Field

Glossary Item Box

Grid Absorbing Material.

Syntax

public int GridAbsorbingMaterial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridAspectRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridAspectRatio Field

Glossary Item Box

Grid Aspect Ratio.

Syntax

public int GridAspectRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridDimensions Field

Glossary Item Box

Grid Dimensions.

Syntax

public int GridDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridFocalDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridFocalDistance Field

Glossary Item Box

Grid Focal Distance.

Syntax

public int GridFocalDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridFrameOffsetVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridFrameOffsetVector Field

Glossary Item Box

Grid Frame Offset Vector.

Syntax

public int GridFrameOffsetVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridID Field

Glossary Item Box

Grid Identifier.

Syntax

public int GridID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridPeriod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridPeriod Field

Glossary Item Box

Grid Period.

Syntax

public int GridPeriod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridPitch Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridPitch Field

Glossary Item Box

Grid Pitch.

Syntax

public int GridPitch

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridResolution Field

Glossary Item Box

Grid Resolution.

Syntax

public int GridResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridSpacingMaterial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridSpacingMaterial Field

Glossary Item Box

Grid Spacing Material.

Syntax

public int GridSpacingMaterial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

GridThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : GridThickness Field

Glossary Item Box

Grid Thickness.

Syntax

public int GridThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0000LengthToEnd Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0000LengthToEnd Field

Glossary Item Box

Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0000LengthToEnd

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0004Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0004Length Field

Glossary Item Box

Group 0004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0004Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0008Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0008Length Field

Glossary Item Box

Group 0008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0008Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0008LengthToEnd Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0008LengthToEnd Field

Glossary Item Box

Group 0008 Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0008LengthToEnd

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0010Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0010Length Field

Glossary Item Box

Group 0010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0010Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0012Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0012Length Field

Glossary Item Box

Group 0012 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0012Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0018Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0018Length Field

Glossary Item Box

Group 0018 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0018Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0020Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0020Length Field

Glossary Item Box

Group 0020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0020Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0022Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0022Length Field

Glossary Item Box

Group 0022 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0022Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0028Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0028Length Field

Glossary Item Box

Group 0028 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0028Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0032Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0032Length Field

Glossary Item Box

Group 0032 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0032Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0038Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0038Length Field

Glossary Item Box

Group 0038 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0038Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group003ALength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group003ALength Field

Glossary Item Box

Group 003A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group003ALength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0040Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0040Length Field

Glossary Item Box

Group 0040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0040Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0042Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0042Length Field

Glossary Item Box

Group 0042 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0042Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0044Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0044Length Field

Glossary Item Box

Group 0044 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0044Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0046Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0046Length Field

Glossary Item Box

Group 0046 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0046Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0050Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0050Length Field

Glossary Item Box

Group 0050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0050Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0054Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0054Length Field

Glossary Item Box

Group 0054 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0054Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0060Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0060Length Field

Glossary Item Box

Group 0060 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0060Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0062Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0062Length Field

Glossary Item Box

Group 0062 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0062Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0064Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0064Length Field

Glossary Item Box

Group 0064 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0064Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0066Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0066Length Field

Glossary Item Box

Group 0066 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0066Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0070Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0070Length Field

Glossary Item Box

Group 0070 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0070Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0072Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0072Length Field

Glossary Item Box

Group 0072 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0072Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0074Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0074Length Field

Glossary Item Box

Group 0074 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0074Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0088Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0088Length Field

Glossary Item Box

Group 0088 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0088Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0100Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0100Length Field

Glossary Item Box

Group 0100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0100Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group0400Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group0400Length Field

Glossary Item Box

Group 0400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group0400Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group1000Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group1000Length Field

Glossary Item Box

Group 1000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group1000Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group1010Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group1010Length Field

Glossary Item Box

Group 1010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group1010Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2000Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2000Length Field

Glossary Item Box

Group 2000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2000Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2010Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2010Length Field

Glossary Item Box

Group 2010 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2010Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2020Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2020Length Field

Glossary Item Box

Group 2020 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2020Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2030Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2030Length Field

Glossary Item Box

Group 2030 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2030Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2040Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2040Length Field

Glossary Item Box

Group 2040 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2040Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2050Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2050Length Field

Glossary Item Box

Group 2050 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2050Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2100Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2100Length Field

Glossary Item Box

Group 2100 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2100Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2110Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2110Length Field

Glossary Item Box

Group 2110 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2110Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2120Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2120Length Field

Glossary Item Box

Group 2120 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2120Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2130Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2130Length Field

Glossary Item Box

Group 2130 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2130Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group2200Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group2200Length Field

Glossary Item Box

Group 2200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group2200Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group3002Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group3002Length Field

Glossary Item Box

Group 3002 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group3002Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group3004Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group3004Length Field

Glossary Item Box

Group 3004 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group3004Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group3006Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group3006Length Field

Glossary Item Box

Group 3006 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group3006Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group3008Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group3008Length Field

Glossary Item Box

Group 3008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group3008Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group300ALength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group300ALength Field

Glossary Item Box

Group 300A Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group300ALength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group300CLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group300CLength Field

Glossary Item Box

Group 300C Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group300CLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group300ELength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group300ELength Field

Glossary Item Box

Group 300E Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group300ELength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group4000Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group4000Length Field

Glossary Item Box

Group 4000 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group4000Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group4008Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group4008Length Field

Glossary Item Box

Group 4008 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group4008Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group4FFELength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group4FFELength Field

Glossary Item Box

Group 4FFE Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group4FFELength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group50xxLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group50xxLength Field

Glossary Item Box

Group 50xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group50xxLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group5200Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group5200Length Field

Glossary Item Box

Group 5200 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group5200Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group5400Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group5400Length Field

Glossary Item Box

Group 5400 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group5400Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group5600Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group5600Length Field

Glossary Item Box

Group 5600 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group5600Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group60xxLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group60xxLength Field

Glossary Item Box

Group 60xx Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group60xxLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group7FE0Length Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group7FE0Length Field

Glossary Item Box

Group 7FE0 Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group7FE0Length

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Group7FFFLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Group7FFFLength Field

Glossary Item Box

Group 7FFF Length. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Group7FFFLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HalfValueLayer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HalfValueLayer Field

Glossary Item Box

Half Value Layer.

Syntax

public int HalfValueLayer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolCreationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolCreationDateTime Field

Glossary Item Box

Hanging Protocol Creation DateTime.

Syntax

public int HangingProtocolCreationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolCreator Field

Glossary Item Box

Hanging Protocol Creator.

Syntax

public int HangingProtocolCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolDefinitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolDefinitionSequence Field

Glossary Item Box

Hanging Protocol Definition Sequence.

Syntax

public int HangingProtocolDefinitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolDescription Field

Glossary Item Box

Hanging Protocol Description.

Syntax

public int HangingProtocolDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolLevel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolLevel Field

Glossary Item Box

Hanging Protocol Level.

Syntax

public int HangingProtocolLevel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolName Field

Glossary Item Box

Hanging Protocol Name.

Syntax

public int HangingProtocolName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolUserGroupName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolUserGroupName Field

Glossary Item Box

Hanging Protocol User Group Name.

Syntax

public int HangingProtocolUserGroupName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HangingProtocolUserIdentificationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HangingProtocolUserIdentificationCodeSequence Field

Glossary Item Box

Hanging Protocol User Identification Code Sequence.

Syntax

public int HangingProtocolUserIdentificationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HardcopyCreationDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HardcopyCreationDeviceID Field

Glossary Item Box

Hardcopy Creation Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HardcopyCreationDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HardcopyDeviceManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HardcopyDeviceManufacturer Field

Glossary Item Box

Hardcopy Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HardcopyDeviceManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HardcopyDeviceManufacturersModelName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HardcopyDeviceManufacturersModelName Field

Glossary Item Box

Hardcopy Device Manufacturer's Model Name. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HardcopyDeviceManufacturersModelName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HardcopyDeviceSoftwareVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HardcopyDeviceSoftwareVersion Field

Glossary Item Box

Hardcopy Device Software Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HardcopyDeviceSoftwareVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HeadFixationAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HeadFixationAngle Field

Glossary Item Box

Head Fixation Angle.

Syntax

public int HeadFixationAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HeartRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HeartRate Field

Glossary Item Box

Heart Rate.

Syntax

public int HeartRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HighBit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HighBit Field

Glossary Item Box

Image High Bit.

Syntax

public int HighBit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HighDoseTechniqueType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HighDoseTechniqueType Field

Glossary Item Box

High-Dose Technique Type.

Syntax

public int HighDoseTechniqueType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HighRrValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HighRrValue Field

Glossary Item Box

High R-R Value.

Syntax

public int HighRrValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramBinWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramBinWidth Field

Glossary Item Box

Histogram Bin Width.

Syntax

public int HistogramBinWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramData Field

Glossary Item Box

Histogram Data.

Syntax

public int HistogramData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramExplanation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramExplanation Field

Glossary Item Box

Histogram Explanation.

Syntax

public int HistogramExplanation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramFirstBinValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramFirstBinValue Field

Glossary Item Box

Histogram First Bin Value.

Syntax

public int HistogramFirstBinValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramLastBinValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramLastBinValue Field

Glossary Item Box

Histogram Last Bin Value.

Syntax

public int HistogramLastBinValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramNumberOfBins Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramNumberOfBins Field

Glossary Item Box

Histogram Number of Bins.

Syntax

public int HistogramNumberOfBins

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HistogramSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HistogramSequence Field

Glossary Item Box

Histogram Sequence.

Syntax

public int HistogramSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HL7DocumentEffectiveTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HL7DocumentEffectiveTime Field

Glossary Item Box

HL7 Document Effective Time.

Syntax

public int HL7DocumentEffectiveTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HL7DocumentTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HL7DocumentTypeCodeSequence Field

Glossary Item Box

HL7 Document Type Code Sequence.

Syntax

public int HL7DocumentTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HL7InstanceIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HL7InstanceIdentifier Field

Glossary Item Box

HL7 Instance Identifier.

Syntax

public int HL7InstanceIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HL7StructuredDocumentReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HL7StructuredDocumentReferenceSequence Field

Glossary Item Box

HL7 Structured Document Reference Sequence.

Syntax

public int HL7StructuredDocumentReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HorizontalFieldofView Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HorizontalFieldofView Field

Glossary Item Box

Horizontal Field of View.

Syntax

public int HorizontalFieldofView

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HorizontalPrismBase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HorizontalPrismBase Field

Glossary Item Box

Horizontal Prism Base.

Syntax

public int HorizontalPrismBase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HorizontalPrismPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HorizontalPrismPower Field

Glossary Item Box

Horizontal Prism Power.

Syntax

public int HorizontalPrismPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HuffmanTableSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HuffmanTableSize Field

Glossary Item Box

Huffman Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HuffmanTableSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HuffmanTableTriplet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HuffmanTableTriplet Field

Glossary Item Box

Huffman Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int HuffmanTableTriplet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HumanPerformerCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HumanPerformerCodeSequence Field

Glossary Item Box

Human Performer Code Sequence.

Syntax

public int HumanPerformerCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HumanPerformerName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HumanPerformerName Field

Glossary Item Box

Human Performer's Name.

Syntax

public int HumanPerformerName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

HumanPerformerOrganization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : HumanPerformerOrganization Field

Glossary Item Box

Human Performer's Organization.

Syntax

public int HumanPerformerOrganization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ICCProfile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ICCProfile Field

Glossary Item Box

ICC Profile.

Syntax

public int ICCProfile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IconImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IconImageSequence Field

Glossary Item Box

Icon Image Sequence.

Syntax

public int IconImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IdenticalDocumentsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IdenticalDocumentsSequence Field

Glossary Item Box

Identical Documents Sequence.

Syntax

public int IdenticalDocumentsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IdentifierTypeCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IdentifierTypeCode Field

Glossary Item Box

Identifier Type Code.

Syntax

public int IdentifierTypeCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IdentifyingComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IdentifyingComments Field

Glossary Item Box

Identifying Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int IdentifyingComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Illumination Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Illumination Field

Glossary Item Box

Illumination value.

Syntax

public int Illumination

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IlluminationBandwidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IlluminationBandwidth Field

Glossary Item Box

Illumination Bandwidth.

Syntax

public int IlluminationBandwidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IlluminationPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IlluminationPower Field

Glossary Item Box

Illumination Power.

Syntax

public int IlluminationPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IlluminationTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IlluminationTypeCodeSequence Field

Glossary Item Box

Illumination Type Code Sequence.

Syntax

public int IlluminationTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IlluminationWaveLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IlluminationWaveLength Field

Glossary Item Box

Illumination Wave Length.

Syntax

public int IlluminationWaveLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageAndFluoroscopyAreaDoseProduct Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageAndFluoroscopyAreaDoseProduct Field

Glossary Item Box

Image and Fluoroscopy Area Dose Product.

Syntax

public int ImageAndFluoroscopyAreaDoseProduct

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxContentSequence Field

Glossary Item Box

Image Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageBoxContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxesSequence Field

Glossary Item Box

Image Boxes Sequence.

Syntax

public int ImageBoxesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxLargeScrollAmount Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxLargeScrollAmount Field

Glossary Item Box

Image Box Large Scroll Amount.

Syntax

public int ImageBoxLargeScrollAmount

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxLargeScrollType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxLargeScrollType Field

Glossary Item Box

Image Box Large Scroll Type.

Syntax

public int ImageBoxLargeScrollType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxLayoutType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxLayoutType Field

Glossary Item Box

Image Box Layout Type.

Syntax

public int ImageBoxLayoutType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxNumber Field

Glossary Item Box

Image Box Number.

Syntax

public int ImageBoxNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxOverlapPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxOverlapPriority Field

Glossary Item Box

Image Box Overlap Priority.

Syntax

public int ImageBoxOverlapPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxPosition Field

Glossary Item Box

Image Box Position.

Syntax

public int ImageBoxPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxPresentationLUTFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxPresentationLUTFlag Field

Glossary Item Box

Image Box Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageBoxPresentationLUTFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxScrollDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxScrollDirection Field

Glossary Item Box

Image Box Scroll Direction.

Syntax

public int ImageBoxScrollDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxSmallScrollAmount Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxSmallScrollAmount Field

Glossary Item Box

Image Box Small Scroll Amount.

Syntax

public int ImageBoxSmallScrollAmount

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxSmallScrollType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxSmallScrollType Field

Glossary Item Box

Image Box Small Scroll Type.

Syntax

public int ImageBoxSmallScrollType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxSynchronizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxSynchronizationSequence Field

Glossary Item Box

Image Box Synchronization Sequence.

Syntax

public int ImageBoxSynchronizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxTileHorizontalDimension Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxTileHorizontalDimension Field

Glossary Item Box

Image Box Tile Horizontal Dimension.

Syntax

public int ImageBoxTileHorizontalDimension

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageBoxTileVerticalDimension Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageBoxTileVerticalDimension Field

Glossary Item Box

Image Box Tile Vertical Dimension.

Syntax

public int ImageBoxTileVerticalDimension

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageCenterPointCoordinatesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageCenterPointCoordinatesSequence Field

Glossary Item Box

Image Center Point Coordinates Sequence.

Syntax

public int ImageCenterPointCoordinatesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageComments Field

Glossary Item Box

Image Comments.

Syntax

public int ImageComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageDataLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageDataLocation Field

Glossary Item Box

Image Data Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageDataLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageDataTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageDataTypeSequence Field

Glossary Item Box

Image Data Type Sequence.

Syntax

public int ImageDataTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageDimensions Field

Glossary Item Box

Image Dimensions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageDisplayFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageDisplayFormat Field

Glossary Item Box

Image Display Format.

Syntax

public int ImageDisplayFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagedNucleus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagedNucleus Field

Glossary Item Box

Imaged Nucleus.

Syntax

public int ImagedNucleus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageFilter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageFilter Field

Glossary Item Box

Image Filter.

Syntax

public int ImageFilter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageFormat Field

Glossary Item Box

Image Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageFrameOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageFrameOrigin Field

Glossary Item Box

Image Frame Origin.

Syntax

public int ImageFrameOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageGeometryType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageGeometryType Field

Glossary Item Box

Image Geometry Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageGeometryType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageHorizontalFlip Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageHorizontalFlip Field

Glossary Item Box

Image Horizontal Flip.

Syntax

public int ImageHorizontalFlip

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageID Field

Glossary Item Box

Image Identifier.

Syntax

public int ImageID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageIndex Field

Glossary Item Box

Image Index.

Syntax

public int ImageIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageLaterality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageLaterality Field

Glossary Item Box

Image Laterality.

Syntax

public int ImageLaterality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageLocation Field

Glossary Item Box

Image Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageOrientation Field

Glossary Item Box

Image Orientation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageOrientationPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageOrientationPatient Field

Glossary Item Box

Image Orientation (Patient).

Syntax

public int ImageOrientationPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageOrientationVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageOrientationVolume Field

Glossary Item Box

Image Orientation (Volume).

Syntax

public int ImageOrientationVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageOverlayBoxContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageOverlayBoxContentSequence Field

Glossary Item Box

Image Overlay Box Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageOverlayBoxContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageOverlayFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageOverlayFlag Field

Glossary Item Box

Image Overlay Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageOverlayFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePathFilterPassBand Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePathFilterPassBand Field

Glossary Item Box

Image Path Filter Pass Band.

Syntax

public int ImagePathFilterPassBand

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePathFilterPassThroughWavelength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePathFilterPassThroughWavelength Field

Glossary Item Box

Image Path Filter Pass-Through Wavelength.

Syntax

public int ImagePathFilterPassThroughWavelength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePathFilterTypeStackCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePathFilterTypeStackCodeSequence Field

Glossary Item Box

Image Path Filter Type Stack Code Sequence.

Syntax

public int ImagePathFilterTypeStackCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePlanePixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePlanePixelSpacing Field

Glossary Item Box

Image Plane Pixel Spacing.

Syntax

public int ImagePlanePixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePosition Field

Glossary Item Box

Image Position. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePositionPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePositionPatient Field

Glossary Item Box

Image Position (Patient).

Syntax

public int ImagePositionPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePositionVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePositionVolume Field

Glossary Item Box

Image Position (Volume).

Syntax

public int ImagePositionVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagePresentationComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagePresentationComments Field

Glossary Item Box

Image Presentation Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagePresentationComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageProcessingApplied Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageProcessingApplied Field

Glossary Item Box

Image Processing Applied.

Syntax

public int ImageProcessingApplied

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageRotation Field

Glossary Item Box

Image Rotation.

Syntax

public int ImageRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageRotationRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageRotationRetired Field

Glossary Item Box

Image Rotation (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageRotationRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagerPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagerPixelSpacing Field

Glossary Item Box

Imager Pixel Spacing.

Syntax

public int ImagerPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetLabel Field

Glossary Item Box

Image Set Label.

Syntax

public int ImageSetLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetNumber Field

Glossary Item Box

Image Set Number.

Syntax

public int ImageSetNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetSelectorCategory Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetSelectorCategory Field

Glossary Item Box

Image Set Selector Category.

Syntax

public int ImageSetSelectorCategory

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetSelectorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetSelectorSequence Field

Glossary Item Box

Image Set Selector Sequence.

Syntax

public int ImageSetSelectorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetSelectorUsageFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetSelectorUsageFlag Field

Glossary Item Box

Image Set Selector Usage Flag.

Syntax

public int ImageSetSelectorUsageFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageSetsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageSetsSequence Field

Glossary Item Box

Image Sets Sequence.

Syntax

public int ImageSetsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagesInAcquisition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagesInAcquisition Field

Glossary Item Box

Images in Acquisition.

Syntax

public int ImagesInAcquisition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagesInSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagesInSeries Field

Glossary Item Box

Images in Series. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagesInSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagesInStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagesInStudy Field

Glossary Item Box

Images in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagesInStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageToEquipmentMappingMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageToEquipmentMappingMatrix Field

Glossary Item Box

Image to Equipment Mapping Matrix.

Syntax

public int ImageToEquipmentMappingMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageTransformationMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageTransformationMatrix Field

Glossary Item Box

Image Transformation Matrix. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageTransformationMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageTranslationVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageTranslationVector Field

Glossary Item Box

Image Translation Vector. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImageTranslationVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageTriggerDelay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageTriggerDelay Field

Glossary Item Box

Image Trigger Delay.

Syntax

public int ImageTriggerDelay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImageType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImageType Field

Glossary Item Box

Image Type.

Syntax

public int ImageType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagingDeviceSpecificAcquisitionParameters Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagingDeviceSpecificAcquisitionParameters Field

Glossary Item Box

Imaging Device-Specific Acquisition Parameters.

Syntax

public int ImagingDeviceSpecificAcquisitionParameters

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagingFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagingFrequency Field

Glossary Item Box

Imaging Frequency.

Syntax

public int ImagingFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagingServiceRequestComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagingServiceRequestComments Field

Glossary Item Box

Imaging Service Request Comments.

Syntax

public int ImagingServiceRequestComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagingServiceRequestFillerOrderNum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagingServiceRequestFillerOrderNum Field

Glossary Item Box

Filler Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagingServiceRequestFillerOrderNum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImagingServiceRequestPlacerOrderNum Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImagingServiceRequestPlacerOrderNum Field

Glossary Item Box

Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ImagingServiceRequestPlacerOrderNum

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImplementationClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImplementationClassUID Field

Glossary Item Box

Implementation Class UID.

Syntax

public int ImplementationClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImplementationVersionName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ImplementationVersionName Field

Glossary Item Box

Implementation Version Name.

Syntax

public int ImplementationVersionName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Impressions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Impressions Field

Glossary Item Box

Impressions. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Impressions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IncludeDisplayApplication Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IncludeDisplayApplication Field

Glossary Item Box

Include Display Application.

Syntax

public int IncludeDisplayApplication

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IncludeNonDICOMObjects Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IncludeNonDICOMObjects Field

Glossary Item Box

Include Non-DICOM Objects.

Syntax

public int IncludeNonDICOMObjects

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InConcatenationNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InConcatenationNumber Field

Glossary Item Box

In-concatenation Number.

Syntax

public int InConcatenationNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InConcatenationTotalNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InConcatenationTotalNumber Field

Glossary Item Box

In-concatenation Total Number.

Syntax

public int InConcatenationTotalNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InitialCineRunState Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InitialCineRunState Field

Glossary Item Box

Initial Cine Run State.

Syntax

public int InitialCineRunState

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InPlanePhaseEncodingDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InPlanePhaseEncodingDirection Field

Glossary Item Box

In-plane Phase Encoding Direction.

Syntax

public int InPlanePhaseEncodingDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InputAvailabilityFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InputAvailabilityFlag Field

Glossary Item Box

Input Availability Flag.

Syntax

public int InputAvailabilityFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InputInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InputInformationSequence Field

Glossary Item Box

Input Information Sequence.

Syntax

public int InputInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InStackPositionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InStackPositionNumber Field

Glossary Item Box

In-Stack Position Number.

Syntax

public int InStackPositionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstanceAvailability Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstanceAvailability Field

Glossary Item Box

Instance Availability.

Syntax

public int InstanceAvailability

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstanceCreationDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstanceCreationDate Field

Glossary Item Box

Instance Creation Date.

Syntax

public int InstanceCreationDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstanceCreationTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstanceCreationTime Field

Glossary Item Box

Instance Creation Time.

Syntax

public int InstanceCreationTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstanceCreatorUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstanceCreatorUID Field

Glossary Item Box

Instance Creator UID.

Syntax

public int InstanceCreatorUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstanceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstanceNumber Field

Glossary Item Box

Instance Number.

Syntax

public int InstanceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstitutionAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstitutionAddress Field

Glossary Item Box

Institution Address.

Syntax

public int InstitutionAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstitutionalDepartmentName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstitutionalDepartmentName Field

Glossary Item Box

Institutional Department Name.

Syntax

public int InstitutionalDepartmentName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstitutionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstitutionCodeSequence Field

Glossary Item Box

Institution Code Sequence.

Syntax

public int InstitutionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InstitutionName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InstitutionName Field

Glossary Item Box

Institution Name.

Syntax

public int InstitutionName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InsurancePlanIdentification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InsurancePlanIdentification Field

Glossary Item Box

Insurance Plan Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InsurancePlanIdentification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntendedRecipientsOfResultsIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntendedRecipientsOfResultsIdentificationSequence Field

Glossary Item Box

Intended Recipients of Results Identification Sequence.

Syntax

public int IntendedRecipientsOfResultsIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntensifierActiveDimensions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntensifierActiveDimensions Field

Glossary Item Box

Intensifier Active Dimension(s).

Syntax

public int IntensifierActiveDimensions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntensifierActiveShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntensifierActiveShape Field

Glossary Item Box

Intensifier Active Shape.

Syntax

public int IntensifierActiveShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntensifierSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntensifierSize Field

Glossary Item Box

Intensifier Size.

Syntax

public int IntensifierSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterMarkerDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterMarkerDistance Field

Glossary Item Box

Inter-Marker Distance.

Syntax

public int InterMarkerDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntermediatePupillaryDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntermediatePupillaryDistance Field

Glossary Item Box

Intermediate Pupillary Distance.

Syntax

public int IntermediatePupillaryDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationApprovalDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationApprovalDate Field

Glossary Item Box

Interpretation Approval Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationApprovalDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationApprovalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationApprovalTime Field

Glossary Item Box

Interpretation Approval Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationApprovalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationApproverSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationApproverSequence Field

Glossary Item Box

Interpretation Approver Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationApproverSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationAuthor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationAuthor Field

Glossary Item Box

Interpretation Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationAuthor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationDiagnosisCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationDiagnosisCodeSequence Field

Glossary Item Box

Interpretation Diagnosis Code Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationDiagnosisCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationDiagnosisDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationDiagnosisDescription Field

Glossary Item Box

Interpretation Diagnosis Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationDiagnosisDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationID Field

Glossary Item Box

Interpretation ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationIDIssuer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationIDIssuer Field

Glossary Item Box

Interpretation ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationIDIssuer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationRecordedDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationRecordedDate Field

Glossary Item Box

Interpretation Recorded Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationRecordedDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationRecordedTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationRecordedTime Field

Glossary Item Box

Interpretation Recorded Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationRecordedTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationRecorder Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationRecorder Field

Glossary Item Box

Interpretation Recorder. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationRecorder

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationStatusID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationStatusID Field

Glossary Item Box

Interpretation Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationStatusID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationText Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationText Field

Glossary Item Box

Interpretation Text. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationText

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationTranscriber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationTranscriber Field

Glossary Item Box

Interpretation Transcriber. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationTranscriber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationTranscriptionDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationTranscriptionDate Field

Glossary Item Box

Interpretation Transcription Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationTranscriptionDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationTranscriptionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationTranscriptionTime Field

Glossary Item Box

Interpretation Transcription Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationTranscriptionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterpretationTypeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterpretationTypeID Field

Glossary Item Box

Interpretation Type ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int InterpretationTypeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntervalNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntervalNumber Field

Glossary Item Box

Interval Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int IntervalNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntervalsAcquired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntervalsAcquired Field

Glossary Item Box

Intervals Acquired.

Syntax

public int IntervalsAcquired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntervalsRejected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntervalsRejected Field

Glossary Item Box

Intervals Rejected.

Syntax

public int IntervalsRejected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDescription Field

Glossary Item Box

Intervention Description.

Syntax

public int InterventionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugCodeSequence Field

Glossary Item Box

Intervention Drug Code Sequence.

Syntax

public int InterventionDrugCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugDose Field

Glossary Item Box

Intervention Drug Dose.

Syntax

public int InterventionDrugDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugInformationSequence Field

Glossary Item Box

Intervention Drug Information Sequence.

Syntax

public int InterventionDrugInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugName Field

Glossary Item Box

Intervention Drug Name.

Syntax

public int InterventionDrugName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugStartTime Field

Glossary Item Box

Intervention Drug Start Time.

Syntax

public int InterventionDrugStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionDrugStopTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionDrugStopTime Field

Glossary Item Box

Intervention Drug Stop Time.

Syntax

public int InterventionDrugStopTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionSequence Field

Glossary Item Box

Intervention Sequence.

Syntax

public int InterventionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InterventionStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InterventionStatus Field

Glossary Item Box

Intervention Status.

Syntax

public int InterventionStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IntraOcularPressure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IntraOcularPressure Field

Glossary Item Box

Intra Ocular Pressure.

Syntax

public int IntraOcularPressure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InversionRecovery Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InversionRecovery Field

Glossary Item Box

Inversion Recovery.

Syntax

public int InversionRecovery

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InversionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InversionTime Field

Glossary Item Box

Inversion Time.

Syntax

public int InversionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

InversionTimes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : InversionTimes Field

Glossary Item Box

Inversion Times.

Syntax

public int InversionTimes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonBeamLimitingDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonBeamLimitingDeviceSequence Field

Glossary Item Box

Ion Beam Limiting Device Sequence.

Syntax

public int IonBeamLimitingDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonBeamSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonBeamSequence Field

Glossary Item Box

Ion Beam Sequence.

Syntax

public int IonBeamSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonBlockSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonBlockSequence Field

Glossary Item Box

Ion Block Sequence.

Syntax

public int IonBlockSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonControlPointDeliverySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonControlPointDeliverySequence Field

Glossary Item Box

Ion Control Point Delivery Sequence.

Syntax

public int IonControlPointDeliverySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonControlPointSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonControlPointSequence Field

Glossary Item Box

Ion Control Point Sequence.

Syntax

public int IonControlPointSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonControlPointVerificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonControlPointVerificationSequence Field

Glossary Item Box

Ion Control Point Verification Sequence.

Syntax

public int IonControlPointVerificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonMachineVerificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonMachineVerificationSequence Field

Glossary Item Box

Ion Machine Verification Sequence.

Syntax

public int IonMachineVerificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonRangeCompensatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonRangeCompensatorSequence Field

Glossary Item Box

Ion Range Compensator Sequence.

Syntax

public int IonRangeCompensatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonToleranceTableSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonToleranceTableSequence Field

Glossary Item Box

Ion Tolerance Table Sequence.

Syntax

public int IonToleranceTableSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonWedgePositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonWedgePositionSequence Field

Glossary Item Box

Ion Wedge Position Sequence.

Syntax

public int IonWedgePositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IonWedgeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IonWedgeSequence Field

Glossary Item Box

Ion Wedge Sequence.

Syntax

public int IonWedgeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IrradiationEventIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IrradiationEventIdentificationSequence Field

Glossary Item Box

Irradiation Event Identification Sequence.

Syntax

public int IrradiationEventIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IrradiationEventUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IrradiationEventUID Field

Glossary Item Box

Irradiation Event UID.

Syntax

public int IrradiationEventUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocenterPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocenterPosition Field

Glossary Item Box

Isocenter Position.

Syntax

public int IsocenterPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocenterReferenceSystemSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocenterReferenceSystemSequence Field

Glossary Item Box

Isocenter Reference System Sequence.

Syntax

public int IsocenterReferenceSystemSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoBeamLimitingDeviceDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoBeamLimitingDeviceDistance Field

Glossary Item Box

Isocenter to Beam Limiting Device Distance.

Syntax

public int IsocentertoBeamLimitingDeviceDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoBlockTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoBlockTrayDistance Field

Glossary Item Box

Isocenter to Block Tray Distance.

Syntax

public int IsocentertoBlockTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoCompensatorDistances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoCompensatorDistances Field

Glossary Item Box

Isocenter to Compensator Distances.

Syntax

public int IsocentertoCompensatorDistances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoCompensatorTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoCompensatorTrayDistance Field

Glossary Item Box

Isocenter to Compensator Tray Distance.

Syntax

public int IsocentertoCompensatorTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoLateralSpreadingDeviceDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoLateralSpreadingDeviceDistance Field

Glossary Item Box

Isocenter to Lateral Spreading Device Distance.

Syntax

public int IsocentertoLateralSpreadingDeviceDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoRangeModulatorDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoRangeModulatorDistance Field

Glossary Item Box

Isocenter to Range Modulator Distance.

Syntax

public int IsocentertoRangeModulatorDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoRangeShifterDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoRangeShifterDistance Field

Glossary Item Box

Isocenter to Range Shifter Distance.

Syntax

public int IsocentertoRangeShifterDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsocentertoWedgeTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsocentertoWedgeTrayDistance Field

Glossary Item Box

Isocenter to Wedge Tray Distance.

Syntax

public int IsocentertoWedgeTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IsotopeNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IsotopeNumber Field

Glossary Item Box

Isotope Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int IsotopeNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssueDateOfImagingServiceRequest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssueDateOfImagingServiceRequest Field

Glossary Item Box

Issue Date of Imaging Service Request.

Syntax

public int IssueDateOfImagingServiceRequest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfAccessionNumberSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfAccessionNumberSequence Field

Glossary Item Box

Issuer of Accession Number Sequence.

Syntax

public int IssuerOfAccessionNumberSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfAdmissionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfAdmissionID Field

Glossary Item Box

Issuer of Admission ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int IssuerOfAdmissionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfAdmissionIDSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfAdmissionIDSequence Field

Glossary Item Box

Issuer of Admission ID Sequence.

Syntax

public int IssuerOfAdmissionIDSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfPatientID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfPatientID Field

Glossary Item Box

Issuer of Patient ID.

Syntax

public int IssuerOfPatientID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfPatientIDQualifiersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfPatientIDQualifiersSequence Field

Glossary Item Box

Issuer of Patient ID Qualifiers Sequence.

Syntax

public int IssuerOfPatientIDQualifiersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfServiceEpisodeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfServiceEpisodeID Field

Glossary Item Box

Issuer of Service Episode ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int IssuerOfServiceEpisodeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfServiceEpisodeIDSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfServiceEpisodeIDSequence Field

Glossary Item Box

Issuer of Service Episode ID Sequence.

Syntax

public int IssuerOfServiceEpisodeIDSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfTheContainerIdentifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfTheContainerIdentifierSequence Field

Glossary Item Box

Issuer of the Container Identifier Sequence.

Syntax

public int IssuerOfTheContainerIdentifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssuerOfTheSpecimenIdentifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssuerOfTheSpecimenIdentifierSequence Field

Glossary Item Box

Issuer of the Specimen Identifier Sequence.

Syntax

public int IssuerOfTheSpecimenIdentifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IssueTimeOfImagingServiceRequest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IssueTimeOfImagingServiceRequest Field

Glossary Item Box

Issue Time of Imaging Service Request.

Syntax

public int IssueTimeOfImagingServiceRequest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Item Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Item Field

Glossary Item Box

Item marker.

Syntax

public int Item

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ItemDelimitationItem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ItemDelimitationItem Field

Glossary Item Box

Item Delimitation Item.

Syntax

public int ItemDelimitationItem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ItemNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ItemNumber Field

Glossary Item Box

Item Number.

Syntax

public int ItemNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IterativeReconstructionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IterativeReconstructionMethod Field

Glossary Item Box

Iterative Reconstruction Method.

Syntax

public int IterativeReconstructionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IvusAcquisition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IvusAcquisition Field

Glossary Item Box

IVUS Acquisition.

Syntax

public int IvusAcquisition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IvusGatedRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IvusGatedRate Field

Glossary Item Box

IVUS Gated Rate.

Syntax

public int IvusGatedRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IvusPullbackRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IvusPullbackRate Field

Glossary Item Box

IVUS Pullback Rate.

Syntax

public int IvusPullbackRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IvusPullbackStartFrameNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IvusPullbackStartFrameNumber Field

Glossary Item Box

IVUS Pullback Start Frame Number.

Syntax

public int IvusPullbackStartFrameNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

IvusPullbackStopFrameNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : IvusPullbackStopFrameNumber Field

Glossary Item Box

IVUS Pullback Stop Frame Number.

Syntax

public int IvusPullbackStopFrameNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

KeratometricAxis Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : KeratometricAxis Field

Glossary Item Box

Keratometric Axis.

Syntax

public int KeratometricAxis

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

KeratometricPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : KeratometricPower Field

Glossary Item Box

Keratometric Power.

Syntax

public int KeratometricPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

KeratometryLeftEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : KeratometryLeftEyeSequence Field

Glossary Item Box

Keratometry Left Eye Sequence.

Syntax

public int KeratometryLeftEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

KeratometryRightEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : KeratometryRightEyeSequence Field

Glossary Item Box

Keratometry Right Eye Sequence.

Syntax

public int KeratometryRightEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

KspaceFiltering Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : KspaceFiltering Field

Glossary Item Box

K-space Filtering.

Syntax

public int KspaceFiltering

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Kvp Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Kvp Field

Glossary Item Box

KVP (kilovolts peak).

Syntax

public int Kvp

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LabelStyleSelection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LabelStyleSelection Field

Glossary Item Box

Label Style Selection.

Syntax

public int LabelStyleSelection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LabelText Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LabelText Field

Glossary Item Box

Label Text.

Syntax

public int LabelText

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LabelUsingInformationExtractedFromInstances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LabelUsingInformationExtractedFromInstances Field

Glossary Item Box

Label Using Information Extracted From Instances.

Syntax

public int LabelUsingInformationExtractedFromInstances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LanguageCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LanguageCodeSequence Field

Glossary Item Box

Language Code Sequence.

Syntax

public int LanguageCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeBluePaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeBluePaletteColorLookupTableData Field

Glossary Item Box

Large Blue Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargeBluePaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeBluePaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeBluePaletteColorLookupTableDescriptor Field

Glossary Item Box

Large Blue Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargeBluePaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeGreenPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeGreenPaletteColorLookupTableData Field

Glossary Item Box

Large Green Palette Color Lookup Table Data(RET). See DICOM specification for alternatives.

Syntax

public int LargeGreenPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeGreenPaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeGreenPaletteColorLookupTableDescriptor Field

Glossary Item Box

Large Green Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargeGreenPaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargePaletteColorLookupTableUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargePaletteColorLookupTableUID Field

Glossary Item Box

Large Palette Color Lookup Table UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargePaletteColorLookupTableUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeRedPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeRedPaletteColorLookupTableData Field

Glossary Item Box

Large Red Palette Color Lookup Table Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargeRedPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargeRedPaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargeRedPaletteColorLookupTableDescriptor Field

Glossary Item Box

Large Red Palette Color Lookup Table Descriptor. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargeRedPaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargestImagePixelValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargestImagePixelValue Field

Glossary Item Box

Largest Image Pixel Value.

Syntax

public int LargestImagePixelValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargestImagePixelValueInPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargestImagePixelValueInPlane Field

Glossary Item Box

Largest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargestImagePixelValueInPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargestMonochromePixelValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargestMonochromePixelValue Field

Glossary Item Box

Largest Monochrome Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargestMonochromePixelValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargestPixelValueInSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargestPixelValueInSeries Field

Glossary Item Box

Largest Pixel Value in Series.

Syntax

public int LargestPixelValueInSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LargestValidPixelValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LargestValidPixelValue Field

Glossary Item Box

Largest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LargestValidPixelValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LastMenstrualDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LastMenstrualDate Field

Glossary Item Box

Last Menstrual Date.

Syntax

public int LastMenstrualDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Laterality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Laterality Field

Glossary Item Box

The Laterality.

Syntax

public int Laterality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceDescription Field

Glossary Item Box

Lateral Spreading Device Description.

Syntax

public int LateralSpreadingDeviceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceID Field

Glossary Item Box

Lateral Spreading Device ID.

Syntax

public int LateralSpreadingDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceNumber Field

Glossary Item Box

Lateral Spreading Device Number.

Syntax

public int LateralSpreadingDeviceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceSequence Field

Glossary Item Box

Lateral Spreading Device Sequence.

Syntax

public int LateralSpreadingDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceSetting Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceSetting Field

Glossary Item Box

Lateral Spreading Device Setting.

Syntax

public int LateralSpreadingDeviceSetting

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceSettingsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceSettingsSequence Field

Glossary Item Box

Lateral Spreading Device Settings Sequence.

Syntax

public int LateralSpreadingDeviceSettingsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceType Field

Glossary Item Box

Lateral Spreading Device Type.

Syntax

public int LateralSpreadingDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LateralSpreadingDeviceWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LateralSpreadingDeviceWaterEquivalentThickness Field

Glossary Item Box

Lateral Spreading Device Water Equivalent Thickness.

Syntax

public int LateralSpreadingDeviceWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LeafJawPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LeafJawPosition Field

Glossary Item Box

Leaf/Jaw Positions.

Syntax

public int LeafJawPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LeafJawPositions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LeafJawPositions Field

Glossary Item Box

Leaf/Jaw Positions.

Syntax

public int LeafJawPositions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LeafPositionBoundaries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LeafPositionBoundaries Field

Glossary Item Box

Leaf Position Boundaries.

Syntax

public int LeafPositionBoundaries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LeftImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LeftImageSequence Field

Glossary Item Box

Left Image Sequence.

Syntax

public int LeftImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LeftLensSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LeftLensSequence Field

Glossary Item Box

Left Lens Sequence.

Syntax

public int LeftLensSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LengthToEnd Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LengthToEnd Field

Glossary Item Box

Command Length to End. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LengthToEnd

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LensDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LensDescription Field

Glossary Item Box

Lens Description.

Syntax

public int LensDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LensesCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LensesCodeSequence Field

Glossary Item Box

Lenses Code Sequence.

Syntax

public int LensesCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LensSegmentType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LensSegmentType Field

Glossary Item Box

Lens Segment Type.

Syntax

public int LensSegmentType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LesionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LesionNumber Field

Glossary Item Box

Lesion Number.

Syntax

public int LesionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LightPathFilterPassBand Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LightPathFilterPassBand Field

Glossary Item Box

Light Path Filter Pass Band.

Syntax

public int LightPathFilterPassBand

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LightPathFilterPassThroughWavelength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LightPathFilterPassThroughWavelength Field

Glossary Item Box

Light Path Filter Pass-Through Wavelength.

Syntax

public int LightPathFilterPassThroughWavelength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LightPathFilterTypeStackCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LightPathFilterTypeStackCodeSequence Field

Glossary Item Box

Light Path Filter Type Stack Code Sequence.

Syntax

public int LightPathFilterTypeStackCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LineSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LineSequence Field

Glossary Item Box

Line Sequence.

Syntax

public int LineSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ListOfMIMETypes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ListOfMIMETypes Field

Glossary Item Box

List of MIME Types.

Syntax

public int ListOfMIMETypes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LocalNamespaceEntityID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LocalNamespaceEntityID Field

Glossary Item Box

Local Namespace Entity ID.

Syntax

public int LocalNamespaceEntityID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Location Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Location Field

Glossary Item Box

Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Location

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LookupTableNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LookupTableNumber Field

Glossary Item Box

Lookup Table Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LookupTableNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LossyImageCompression Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LossyImageCompression Field

Glossary Item Box

Lossy Image Compression.

Syntax

public int LossyImageCompression

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LossyImageCompressionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LossyImageCompressionMethod Field

Glossary Item Box

Lossy Image Compression Method.

Syntax

public int LossyImageCompressionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LossyImageCompressionRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LossyImageCompressionRatio Field

Glossary Item Box

Lossy Image Compression Ratio.

Syntax

public int LossyImageCompressionRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LossyImageCompressionRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LossyImageCompressionRetired Field

Glossary Item Box

Lossy Image Compression (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LossyImageCompressionRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LowRrValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LowRrValue Field

Glossary Item Box

Low R-R Value.

Syntax

public int LowRrValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTData Field

Glossary Item Box

LUT (Lookup Table) Data.

Syntax

public int LUTData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTDescriptor Field

Glossary Item Box

LUT Descriptor.

Syntax

public int LUTDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTExplanation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTExplanation Field

Glossary Item Box

LUT Explanation.

Syntax

public int LUTExplanation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTFrameRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTFrameRange Field

Glossary Item Box

LUT Frame Range.

Syntax

public int LUTFrameRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTFunction Field

Glossary Item Box

LUT Function.

Syntax

public int LUTFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LutLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LutLabel Field

Glossary Item Box

LUT Label.

Syntax

public int LutLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

LUTNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : LUTNumber Field

Glossary Item Box

LUT Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int LUTNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MAC Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MAC Field

Glossary Item Box

MAC (Message Authentication Code).

Syntax

public int MAC

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MacAlgorithm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MacAlgorithm Field

Glossary Item Box

MAC Algorithm.

Syntax

public int MacAlgorithm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MacCalculationTransferSyntaxUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MacCalculationTransferSyntaxUID Field

Glossary Item Box

MAC Calculation Transfer Syntax UID.

Syntax

public int MacCalculationTransferSyntaxUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MacIDNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MacIDNumber Field

Glossary Item Box

MAC ID Number.

Syntax

public int MacIDNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MacParametersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MacParametersSequence Field

Glossary Item Box

MAC Parameters Sequence.

Syntax

public int MacParametersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MagneticFieldStrength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MagneticFieldStrength Field

Glossary Item Box

Magnetic Field Strength.

Syntax

public int MagneticFieldStrength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MagnetizationTransfer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MagnetizationTransfer Field

Glossary Item Box

Magnetization Transfer.

Syntax

public int MagnetizationTransfer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MagnificationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MagnificationType Field

Glossary Item Box

Magnification Type.

Syntax

public int MagnificationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MagnifytoNumberofColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MagnifytoNumberofColumns Field

Glossary Item Box

Magnify to Number of Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MagnifytoNumberofColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Manifold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Manifold Field

Glossary Item Box

Manifold tag.

Syntax

public int Manifold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ManipulatedImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ManipulatedImage Field

Glossary Item Box

Manipulated Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ManipulatedImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Manufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Manufacturer Field

Glossary Item Box

The Manufacturer.

Syntax

public int Manufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ManufacturersModelName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ManufacturersModelName Field

Glossary Item Box

Manufacturer's Model Name.

Syntax

public int ManufacturersModelName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MappingResource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MappingResource Field

Glossary Item Box

Mapping Resource.

Syntax

public int MappingResource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskFrameNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskFrameNumbers Field

Glossary Item Box

Mask Frame Numbers.

Syntax

public int MaskFrameNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskingImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskingImage Field

Glossary Item Box

Masking Image. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MaskingImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskOperation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskOperation Field

Glossary Item Box

Mask Operation.

Syntax

public int MaskOperation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskOperationExplanation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskOperationExplanation Field

Glossary Item Box

Mask Operation Explanation.

Syntax

public int MaskOperationExplanation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskPointers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskPointers Field

Glossary Item Box

Mask Pointer(s). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MaskPointers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskSelectionMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskSelectionMode Field

Glossary Item Box

Mask Selection Mode.

Syntax

public int MaskSelectionMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskSubpixelShift Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskSubpixelShift Field

Glossary Item Box

Mask Sub-pixel Shift.

Syntax

public int MaskSubpixelShift

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskSubtractionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskSubtractionSequence Field

Glossary Item Box

Mask Subtraction Sequence.

Syntax

public int MaskSubtractionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaskVisibilityPercentage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaskVisibilityPercentage Field

Glossary Item Box

Mask Visibility Percentage.

Syntax

public int MaskVisibilityPercentage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaterialID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaterialID Field

Glossary Item Box

Material ID.

Syntax

public int MaterialID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MatrixRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MatrixRegistrationSequence Field

Glossary Item Box

Matrix Registration Sequence.

Syntax

public int MatrixRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MatrixSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MatrixSequence Field

Glossary Item Box

Matrix Sequence.

Syntax

public int MatrixSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaxDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaxDensity Field

Glossary Item Box

Max Density.

Syntax

public int MaxDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumAcrossScanDistortion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumAcrossScanDistortion Field

Glossary Item Box

Maximum Across-scan Distortion.

Syntax

public int MaximumAcrossScanDistortion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumAlongScanDistortion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumAlongScanDistortion Field

Glossary Item Box

Maximum Along-scan Distortion.

Syntax

public int MaximumAlongScanDistortion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumCollatedFilms Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumCollatedFilms Field

Glossary Item Box

Maximum Collated Films.

Syntax

public int MaximumCollatedFilms

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumCoordinateValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumCoordinateValue Field

Glossary Item Box

Maximum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MaximumCoordinateValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumDepthDistortion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumDepthDistortion Field

Glossary Item Box

Maximum Depth Distortion.

Syntax

public int MaximumDepthDistortion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumFractionalValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumFractionalValue Field

Glossary Item Box

Maximum Fractional Value.

Syntax

public int MaximumFractionalValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumMemoryAllocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumMemoryAllocation Field

Glossary Item Box

Maximum Memory Allocation.

Syntax

public int MaximumMemoryAllocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MaximumPointDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MaximumPointDistance Field

Glossary Item Box

Maximum Point Distance.

Syntax

public int MaximumPointDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeanPointDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeanPointDistance Field

Glossary Item Box

Mean Point Distance.

Syntax

public int MeanPointDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredDoseDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredDoseDescription Field

Glossary Item Box

Measured Dose Description.

Syntax

public int MeasuredDoseDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredDoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredDoseReferenceNumber Field

Glossary Item Box

Measured Dose Reference Number.

Syntax

public int MeasuredDoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredDoseReferenceSequence Field

Glossary Item Box

Measured Dose Reference Sequence.

Syntax

public int MeasuredDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredDoseType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredDoseType Field

Glossary Item Box

Measured Dose Type.

Syntax

public int MeasuredDoseType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredDoseValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredDoseValue Field

Glossary Item Box

Measured Dose Value.

Syntax

public int MeasuredDoseValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuredValueSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuredValueSequence Field

Glossary Item Box

Measured Value Sequence.

Syntax

public int MeasuredValueSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasurementUnitsCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasurementUnitsCodeSequence Field

Glossary Item Box

Measurement Units Code Sequence.

Syntax

public int MeasurementUnitsCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MeasuringUnitsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MeasuringUnitsSequence Field

Glossary Item Box

Measuring Units Sequence.

Syntax

public int MeasuringUnitsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MechanicalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MechanicalIndex Field

Glossary Item Box

Mechanical Index.

Syntax

public int MechanicalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MediaDisposition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MediaDisposition Field

Glossary Item Box

Media Disposition.

Syntax

public int MediaDisposition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MediaInstalledSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MediaInstalledSequence Field

Glossary Item Box

Media Installed Sequence.

Syntax

public int MediaInstalledSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MediaStorageSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MediaStorageSOPClassUID Field

Glossary Item Box

Media Storage SOP Class UID.

Syntax

public int MediaStorageSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MediaStorageSOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MediaStorageSOPInstanceUID Field

Glossary Item Box

Media Storage SOP Instance UID.

Syntax

public int MediaStorageSOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MedicalAlerts Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MedicalAlerts Field

Glossary Item Box

Medical Alerts.

Syntax

public int MedicalAlerts

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MedicalRecordLocator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MedicalRecordLocator Field

Glossary Item Box

Medical Record Locator.

Syntax

public int MedicalRecordLocator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MediumType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MediumType Field

Glossary Item Box

Medium Type.

Syntax

public int MediumType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MemoryAllocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MemoryAllocation Field

Glossary Item Box

Memory Allocation.

Syntax

public int MemoryAllocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MemoryBitDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MemoryBitDepth Field

Glossary Item Box

Memory Bit Depth.

Syntax

public int MemoryBitDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MessageID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MessageID Field

Glossary Item Box

Message ID.

Syntax

public int MessageID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MessageIDBeingRespondedTo Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MessageIDBeingRespondedTo Field

Glossary Item Box

Message ID Being Responded To.

Syntax

public int MessageIDBeingRespondedTo

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MessageSetID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MessageSetID Field

Glossary Item Box

Message Set ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MessageSetID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetaboliteMapCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetaboliteMapCodeSequence Field

Glossary Item Box

Metabolite Map Code Sequence.

Syntax

public int MetaboliteMapCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetaboliteMapDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetaboliteMapDescription Field

Glossary Item Box

Metabolite Map Description.

Syntax

public int MetaboliteMapDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetaInfoHeader Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetaInfoHeader Field

Glossary Item Box

DICOM meta information header.

Syntax

public int MetaInfoHeader

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetersetExposure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetersetExposure Field

Glossary Item Box

Meterset Exposure.

Syntax

public int MetersetExposure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetersetRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetersetRate Field

Glossary Item Box

Meterset Rate.

Syntax

public int MetersetRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetersetRateDelivered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetersetRateDelivered Field

Glossary Item Box

Meterset Rate Delivered.

Syntax

public int MetersetRateDelivered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MetersetRateSet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MetersetRateSet Field

Glossary Item Box

Meterset Rate Set.

Syntax

public int MetersetRateSet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MidSlabPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MidSlabPosition Field

Glossary Item Box

Mid Slab Position.

Syntax

public int MidSlabPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MilitaryRank Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MilitaryRank Field

Glossary Item Box

Military Rank.

Syntax

public int MilitaryRank

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MIMETypeofEncapsulatedDocument Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MIMETypeofEncapsulatedDocument Field

Glossary Item Box

MIME Type of Encapsulated Document.

Syntax

public int MIMETypeofEncapsulatedDocument

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MinDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MinDensity Field

Glossary Item Box

Min Density.

Syntax

public int MinDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MinimumCoordinateValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MinimumCoordinateValue Field

Glossary Item Box

Minimum Coordinate Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MinimumCoordinateValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModalitiesInStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModalitiesInStudy Field

Glossary Item Box

Modalities in Study.

Syntax

public int ModalitiesInStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Modality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Modality Field

Glossary Item Box

Modality value.

Syntax

public int Modality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModalityLUTSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModalityLUTSequence Field

Glossary Item Box

Modality LUT Sequence.

Syntax

public int ModalityLUTSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModalityLUTType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModalityLUTType Field

Glossary Item Box

Modality LUT Type.

Syntax

public int ModalityLUTType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifiedAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifiedAttributesSequence Field

Glossary Item Box

Modified Attributes Sequence.

Syntax

public int ModifiedAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifiedImageDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifiedImageDate Field

Glossary Item Box

Modified Image Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifiedImageDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifiedImageDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifiedImageDescription Field

Glossary Item Box

Modified Image Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifiedImageDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifiedImageID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifiedImageID Field

Glossary Item Box

Modified Image ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifiedImageID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifiedImageTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifiedImageTime Field

Glossary Item Box

Modified Image Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifiedImageTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifierCodeSequence Field

Glossary Item Box

Modifier Code Sequence.

Syntax

public int ModifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifyingDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifyingDeviceID Field

Glossary Item Box

Modifying Device ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifyingDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifyingDeviceManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifyingDeviceManufacturer Field

Glossary Item Box

Modifying Device Manufacturer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ModifyingDeviceManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ModifyingSystem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ModifyingSystem Field

Glossary Item Box

Modifying System.

Syntax

public int ModifyingSystem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MostRecentTreatmentDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MostRecentTreatmentDate Field

Glossary Item Box

Most Recent Treatment Date.

Syntax

public int MostRecentTreatmentDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MotionSynchronizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MotionSynchronizationSequence Field

Glossary Item Box

Motion Synchronization Sequence.

Syntax

public int MotionSynchronizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MoveDestination Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MoveDestination Field

Glossary Item Box

Move Destination.

Syntax

public int MoveDestination

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MoveOriginatorApplicationEntityTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MoveOriginatorApplicationEntityTitle Field

Glossary Item Box

Move Originator Application Entity Title.

Syntax

public int MoveOriginatorApplicationEntityTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MoveOriginatorMessageID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MoveOriginatorMessageID Field

Glossary Item Box

Move Originator Message ID.

Syntax

public int MoveOriginatorMessageID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MRAcquisitionFrequencyEncodingSteps Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MRAcquisitionFrequencyEncodingSteps Field

Glossary Item Box

MR Acquisition Frequency Encoding Steps.

Syntax

public int MRAcquisitionFrequencyEncodingSteps

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MRAcquisitionPhaseEncodingStepsInPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MRAcquisitionPhaseEncodingStepsInPlane Field

Glossary Item Box

MR Acquisition Phase Encoding Steps in-plane.

Syntax

public int MRAcquisitionPhaseEncodingStepsInPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MRAcquisitionPhaseEncodingStepsOutOfPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MRAcquisitionPhaseEncodingStepsOutOfPlane Field

Glossary Item Box

MR Acquisition Phase Encoding Steps out-of-plane.

Syntax

public int MRAcquisitionPhaseEncodingStepsOutOfPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrAcquisitionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrAcquisitionType Field

Glossary Item Box

MR Acquisition Type.

Syntax

public int MrAcquisitionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrAveragesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrAveragesSequence Field

Glossary Item Box

MR Averages Sequence.

Syntax

public int MrAveragesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrDiffusionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrDiffusionSequence Field

Glossary Item Box

MR Diffusion Sequence.

Syntax

public int MrDiffusionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MRDRDirectoryRecordOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MRDRDirectoryRecordOffset Field

Glossary Item Box

MRDR Directory Record Offset. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int MRDRDirectoryRecordOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrEchoSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrEchoSequence Field

Glossary Item Box

MR Echo Sequence.

Syntax

public int MrEchoSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrFovGeometrySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrFovGeometrySequence Field

Glossary Item Box

MR FOV/Geometry Sequence.

Syntax

public int MrFovGeometrySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrImageFrameTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrImageFrameTypeSequence Field

Glossary Item Box

MR Image Frame Type Sequence.

Syntax

public int MrImageFrameTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrImagingModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrImagingModifierSequence Field

Glossary Item Box

MR Imaging Modifier Sequence.

Syntax

public int MrImagingModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrMetaboliteMapSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrMetaboliteMapSequence Field

Glossary Item Box

MR Metabolite Map Sequence.

Syntax

public int MrMetaboliteMapSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrModifierSequence Field

Glossary Item Box

MR Modifier Sequence.

Syntax

public int MrModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrReceiveCoilSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrReceiveCoilSequence Field

Glossary Item Box

MR Receive Coil Sequence.

Syntax

public int MrReceiveCoilSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrSpatialSaturationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrSpatialSaturationSequence Field

Glossary Item Box

MR Spatial Saturation Sequence.

Syntax

public int MrSpatialSaturationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MRSpectroscopyAcquisitionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MRSpectroscopyAcquisitionType Field

Glossary Item Box

MR Spectroscopy Acquisition Type.

Syntax

public int MRSpectroscopyAcquisitionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrSpectroscopyFovGeometrySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrSpectroscopyFovGeometrySequence Field

Glossary Item Box

MR Spectroscopy FOV/Geometry Sequence.

Syntax

public int MrSpectroscopyFovGeometrySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrSpectroscopyFrameTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrSpectroscopyFrameTypeSequence Field

Glossary Item Box

MR Spectroscopy Frame Type Sequence.

Syntax

public int MrSpectroscopyFrameTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrTimingAndRelatedParametersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrTimingAndRelatedParametersSequence Field

Glossary Item Box

MR Timing and Related Parameters Sequence.

Syntax

public int MrTimingAndRelatedParametersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrTransmitCoilSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrTransmitCoilSequence Field

Glossary Item Box

MR Transmit Coil Sequence.

Syntax

public int MrTransmitCoilSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MrVelocityEncodingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MrVelocityEncodingSequence Field

Glossary Item Box

MR Velocity Encoding Sequence.

Syntax

public int MrVelocityEncodingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiCoilConfiguration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiCoilConfiguration Field

Glossary Item Box

Multi-Coil Configuration.

Syntax

public int MultiCoilConfiguration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiCoilDefinitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiCoilDefinitionSequence Field

Glossary Item Box

Multi-Coil Definition Sequence.

Syntax

public int MultiCoilDefinitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiCoilElementName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiCoilElementName Field

Glossary Item Box

Multi-Coil Element Name.

Syntax

public int MultiCoilElementName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiCoilElementUsed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiCoilElementUsed Field

Glossary Item Box

Multi-Coil Element Used.

Syntax

public int MultiCoilElementUsed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiFramePresentationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiFramePresentationSequence Field

Glossary Item Box

Multi-frame Presentation Sequence.

Syntax

public int MultiFramePresentationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiFrameSourceSOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiFrameSourceSOPInstanceUID Field

Glossary Item Box

Multi-Frame Source SOP Instance UID.

Syntax

public int MultiFrameSourceSOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiPlanarExcitation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiPlanarExcitation Field

Glossary Item Box

Multi-planar Excitation.

Syntax

public int MultiPlanarExcitation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultipleCopiesFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultipleCopiesFlag Field

Glossary Item Box

Multiple Copies Flag.

Syntax

public int MultipleCopiesFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultipleSpinEcho Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultipleSpinEcho Field

Glossary Item Box

Multiple Spin Echo.

Syntax

public int MultipleSpinEcho

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiplexedAudioChannelsDescriptionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiplexedAudioChannelsDescriptionCodeSequence Field

Glossary Item Box

Multiplexed Audio Channels Description Code Sequence.

Syntax

public int MultiplexedAudioChannelsDescriptionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiplexGroupLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiplexGroupLabel Field

Glossary Item Box

Multiplex Group Label.

Syntax

public int MultiplexGroupLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MultiplexGroupTimeOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MultiplexGroupTimeOffset Field

Glossary Item Box

Multiplex Group Time Offset.

Syntax

public int MultiplexGroupTimeOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MydriaticAgentCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MydriaticAgentCodeSequence Field

Glossary Item Box

Mydriatic Agent Code Sequence.

Syntax

public int MydriaticAgentCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MydriaticAgentConcentration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MydriaticAgentConcentration Field

Glossary Item Box

Mydriatic Agent Concentration.

Syntax

public int MydriaticAgentConcentration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MydriaticAgentConcentrationUnitsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MydriaticAgentConcentrationUnitsSequence Field

Glossary Item Box

Mydriatic Agent Concentration Units Sequence.

Syntax

public int MydriaticAgentConcentrationUnitsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

MydriaticAgentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : MydriaticAgentSequence Field

Glossary Item Box

Mydriatic Agent Sequence.

Syntax

public int MydriaticAgentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NameOfPhysiciansReadingStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NameOfPhysiciansReadingStudy Field

Glossary Item Box

Name of Physician(s) Reading Study.

Syntax

public int NameOfPhysiciansReadingStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NamesOfIntendedRecipientsOfResults Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NamesOfIntendedRecipientsOfResults Field

Glossary Item Box

Names of Intended Recipients of Results.

Syntax

public int NamesOfIntendedRecipientsOfResults

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NavigationDisplaySet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NavigationDisplaySet Field

Glossary Item Box

Navigation Display Set.

Syntax

public int NavigationDisplaySet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NavigationIndicatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NavigationIndicatorSequence Field

Glossary Item Box

Navigation Indicator Sequence.

Syntax

public int NavigationIndicatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NearPupillaryDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NearPupillaryDistance Field

Glossary Item Box

Near Pupillary Distance.

Syntax

public int NearPupillaryDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NetworkID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NetworkID Field

Glossary Item Box

Network ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NetworkID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalBeamEnergy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalBeamEnergy Field

Glossary Item Box

Nominal Beam Energy.

Syntax

public int NominalBeamEnergy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalBeamEnergyUnit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalBeamEnergyUnit Field

Glossary Item Box

Nominal Beam Energy Unit.

Syntax

public int NominalBeamEnergyUnit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalCardiacTriggerDelayTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalCardiacTriggerDelayTime Field

Glossary Item Box

Nominal Cardiac Trigger Delay Time.

Syntax

public int NominalCardiacTriggerDelayTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalInterval Field

Glossary Item Box

Nominal Interval.

Syntax

public int NominalInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalPercentageOfCardiacPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalPercentageOfCardiacPhase Field

Glossary Item Box

Nominal Percentage of Cardiac Phase.

Syntax

public int NominalPercentageOfCardiacPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalPercentageOfRespiratoryPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalPercentageOfRespiratoryPhase Field

Glossary Item Box

Nominal Percentage of Respiratory Phase.

Syntax

public int NominalPercentageOfRespiratoryPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalPriorDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalPriorDose Field

Glossary Item Box

Nominal Prior Dose.

Syntax

public int NominalPriorDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalRespiratoryTriggerDelayTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalRespiratoryTriggerDelayTime Field

Glossary Item Box

Nominal Respiratory Trigger Delay Time.

Syntax

public int NominalRespiratoryTriggerDelayTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalScannedPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalScannedPixelSpacing Field

Glossary Item Box

Nominal Scanned Pixel Spacing.

Syntax

public int NominalScannedPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NominalScreenDefinitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NominalScreenDefinitionSequence Field

Glossary Item Box

Nominal Screen Definition Sequence.

Syntax

public int NominalScreenDefinitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NonDICOMOutputCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NonDICOMOutputCodeSequence Field

Glossary Item Box

Non-DICOM Output Code Sequence.

Syntax

public int NonDICOMOutputCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NonUniformRadialSamplingCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NonUniformRadialSamplingCorrected Field

Glossary Item Box

Non-uniform Radial Sampling Corrected.

Syntax

public int NonUniformRadialSamplingCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NormalizationFactorFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NormalizationFactorFormat Field

Glossary Item Box

Normalization Factor Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NormalizationFactorFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NormalizationPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NormalizationPoint Field

Glossary Item Box

Normalization Point.

Syntax

public int NormalizationPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NormalReverse Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NormalReverse Field

Glossary Item Box

Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NormalReverse

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NorRev Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NorRev Field

Glossary Item Box

Normal Reverse. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NorRev

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NotchFilterBandwidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NotchFilterBandwidth Field

Glossary Item Box

Notch Filter Bandwidth.

Syntax

public int NotchFilterBandwidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NotchFilterFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NotchFilterFrequency Field

Glossary Item Box

Notch Filter Frequency.

Syntax

public int NotchFilterFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NTPSourceAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NTPSourceAddress Field

Glossary Item Box

NTP Source Address.

Syntax

public int NTPSourceAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NuclearMedicineSeriesType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NuclearMedicineSeriesType Field

Glossary Item Box

Nuclear Medicine Series Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NuclearMedicineSeriesType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfAverages Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfAverages Field

Glossary Item Box

Number of Averages.

Syntax

public int NumberOfAverages

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfBeams Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfBeams Field

Glossary Item Box

Number of Beams.

Syntax

public int NumberOfBeams

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfBlocks Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfBlocks Field

Glossary Item Box

Number of Blocks.

Syntax

public int NumberOfBlocks

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfBoli Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfBoli Field

Glossary Item Box

Number of Boli.

Syntax

public int NumberOfBoli

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfBrachyApplicationSetups Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfBrachyApplicationSetups Field

Glossary Item Box

Number of Brachy Application Setups.

Syntax

public int NumberOfBrachyApplicationSetups

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfChannels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfChannels Field

Glossary Item Box

Number of Channels. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfChannels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfCompensators Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfCompensators Field

Glossary Item Box

Number of Compensators.

Syntax

public int NumberOfCompensators

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfCompletedSuboperations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfCompletedSuboperations Field

Glossary Item Box

Number of Completed Sub-operations.

Syntax

public int NumberOfCompletedSuboperations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfContourPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfContourPoints Field

Glossary Item Box

Number of Contour Points.

Syntax

public int NumberOfContourPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfControlPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfControlPoints Field

Glossary Item Box

Number of Control Points.

Syntax

public int NumberOfControlPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfCopies Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfCopies Field

Glossary Item Box

Number of Copies.

Syntax

public int NumberOfCopies

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfDetectors Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfDetectors Field

Glossary Item Box

Number of Detectors.

Syntax

public int NumberOfDetectors

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfEnergyWindows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfEnergyWindows Field

Glossary Item Box

Number of Energy Windows.

Syntax

public int NumberOfEnergyWindows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfEventTimers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfEventTimers Field

Glossary Item Box

Number of Event Timers.

Syntax

public int NumberOfEventTimers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFailedSuboperations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFailedSuboperations Field

Glossary Item Box

Number of Failed Sub-operations.

Syntax

public int NumberOfFailedSuboperations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFilms Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFilms Field

Glossary Item Box

Number of Films.

Syntax

public int NumberOfFilms

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFractionPatternDigitsPerDay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFractionPatternDigitsPerDay Field

Glossary Item Box

Number of Fraction Pattern Digits Per Day.

Syntax

public int NumberOfFractionPatternDigitsPerDay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFractionsDelivered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFractionsDelivered Field

Glossary Item Box

Number of Fractions Delivered.

Syntax

public int NumberOfFractionsDelivered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFractionsPlanned Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFractionsPlanned Field

Glossary Item Box

Number of Fractions Planned.

Syntax

public int NumberOfFractionsPlanned

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFrames Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFrames Field

Glossary Item Box

Number of Frames.

Syntax

public int NumberOfFrames

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFramesInOverlay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFramesInOverlay Field

Glossary Item Box

Number of Frames in Overlay.

Syntax

public int NumberOfFramesInOverlay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFramesInPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFramesInPhase Field

Glossary Item Box

Number of Frames in Phase.

Syntax

public int NumberOfFramesInPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfFramesInRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfFramesInRotation Field

Glossary Item Box

Number of Frames in Rotation.

Syntax

public int NumberOfFramesInRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfGraphicPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfGraphicPoints Field

Glossary Item Box

Number of Graphic Points.

Syntax

public int NumberOfGraphicPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofHorizontalPixels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofHorizontalPixels Field

Glossary Item Box

Number of Horizontal Pixels.

Syntax

public int NumberofHorizontalPixels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfIterations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfIterations Field

Glossary Item Box

Number of Iterations.

Syntax

public int NumberOfIterations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfKspaceTrajectories Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfKspaceTrajectories Field

Glossary Item Box

Number of k-Space Trajectories.

Syntax

public int NumberOfKspaceTrajectories

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofLateralSpreadingDevices Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofLateralSpreadingDevices Field

Glossary Item Box

Number of Lateral Spreading Devices.

Syntax

public int NumberofLateralSpreadingDevices

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfLeafJawPairs Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfLeafJawPairs Field

Glossary Item Box

Number of Leaf/Jaw Pairs.

Syntax

public int NumberOfLeafJawPairs

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfMatches Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfMatches Field

Glossary Item Box

Number of Matches. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfMatches

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofPaintings Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofPaintings Field

Glossary Item Box

Number of Paintings.

Syntax

public int NumberofPaintings

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPatientRelatedInstances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPatientRelatedInstances Field

Glossary Item Box

Number of Patient Related Instances.

Syntax

public int NumberOfPatientRelatedInstances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPatientRelatedSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPatientRelatedSeries Field

Glossary Item Box

Number of Patient Related Series.

Syntax

public int NumberOfPatientRelatedSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPatientRelatedStudies Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPatientRelatedStudies Field

Glossary Item Box

Number of Patient Related Studies.

Syntax

public int NumberOfPatientRelatedStudies

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPhaseEncodingSteps Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPhaseEncodingSteps Field

Glossary Item Box

Number of Phase Encoding Steps.

Syntax

public int NumberOfPhaseEncodingSteps

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPhases Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPhases Field

Glossary Item Box

Number of Phases.

Syntax

public int NumberOfPhases

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPoints Field

Glossary Item Box

Number of Points. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofPriorsReferenced Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofPriorsReferenced Field

Glossary Item Box

Number of Priors Referenced.

Syntax

public int NumberofPriorsReferenced

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfPulses Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfPulses Field

Glossary Item Box

Number of Pulses.

Syntax

public int NumberOfPulses

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofRangeModulators Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofRangeModulators Field

Glossary Item Box

Number of Range Modulators.

Syntax

public int NumberofRangeModulators

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofRangeShifters Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofRangeShifters Field

Glossary Item Box

Number of Range Shifters.

Syntax

public int NumberofRangeShifters

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfReferences Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfReferences Field

Glossary Item Box

Number of References. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfReferences

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfRemainingSuboperations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfRemainingSuboperations Field

Glossary Item Box

Number of Remaining Sub-operations.

Syntax

public int NumberOfRemainingSuboperations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfRotations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfRotations Field

Glossary Item Box

Number of Rotations.

Syntax

public int NumberOfRotations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfRrIntervals Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfRrIntervals Field

Glossary Item Box

Number of R-R Intervals.

Syntax

public int NumberOfRrIntervals

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSamples Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSamples Field

Glossary Item Box

Number of Samples. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfSamples

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofScanSpotPositions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofScanSpotPositions Field

Glossary Item Box

Number of Scan Spot Positions.

Syntax

public int NumberofScanSpotPositions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofScreens Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofScreens Field

Glossary Item Box

Number of Screens.

Syntax

public int NumberofScreens

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSeriesRelatedInstances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSeriesRelatedInstances Field

Glossary Item Box

Number of Series Related Instances.

Syntax

public int NumberOfSeriesRelatedInstances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSlices Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSlices Field

Glossary Item Box

Number of Slices.

Syntax

public int NumberOfSlices

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfStages Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfStages Field

Glossary Item Box

Number of Stages.

Syntax

public int NumberOfStages

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfStudyRelatedInstances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfStudyRelatedInstances Field

Glossary Item Box

Number of Study Related Instances.

Syntax

public int NumberOfStudyRelatedInstances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfStudyRelatedSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfStudyRelatedSeries Field

Glossary Item Box

Number of Study Related Series.

Syntax

public int NumberOfStudyRelatedSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSubsets Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSubsets Field

Glossary Item Box

Number of Subsets.

Syntax

public int NumberOfSubsets

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSurfacePoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSurfacePoints Field

Glossary Item Box

Number of Surface Points.

Syntax

public int NumberOfSurfacePoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfSurfaces Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfSurfaces Field

Glossary Item Box

Number of Surfaces.

Syntax

public int NumberOfSurfaces

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTable Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTable Field

Glossary Item Box

Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfTable

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTableBreakPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTableBreakPoints Field

Glossary Item Box

Number of Table Break Points.

Syntax

public int NumberOfTableBreakPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTableEntries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTableEntries Field

Glossary Item Box

Number of Table Entries.

Syntax

public int NumberOfTableEntries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTables Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTables Field

Glossary Item Box

Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfTables

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTemporalPositions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTemporalPositions Field

Glossary Item Box

Number of Temporal Positions.

Syntax

public int NumberOfTemporalPositions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTimeSlices Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTimeSlices Field

Glossary Item Box

Number of Time Slices.

Syntax

public int NumberOfTimeSlices

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTimeSlots Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTimeSlots Field

Glossary Item Box

Number of Time Slots.

Syntax

public int NumberOfTimeSlots

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTomosynthesisSourceImages Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTomosynthesisSourceImages Field

Glossary Item Box

Number of Tomosynthesis Source Images.

Syntax

public int NumberOfTomosynthesisSourceImages

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTransformSteps Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTransformSteps Field

Glossary Item Box

Number of Transform Steps. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int NumberOfTransformSteps

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfTriggersInPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfTriggersInPhase Field

Glossary Item Box

Number of Triggers in Phase.

Syntax

public int NumberOfTriggersInPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfVectors Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfVectors Field

Glossary Item Box

Number of Vectors.

Syntax

public int NumberOfVectors

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberofVerticalPixels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberofVerticalPixels Field

Glossary Item Box

Number of Vertical Pixels.

Syntax

public int NumberofVerticalPixels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfViewsInStage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfViewsInStage Field

Glossary Item Box

Number of Views in Stage.

Syntax

public int NumberOfViewsInStage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfWarningSuboperations Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfWarningSuboperations Field

Glossary Item Box

Number of Warning Sub-operations.

Syntax

public int NumberOfWarningSuboperations

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfWaveformChannels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfWaveformChannels Field

Glossary Item Box

Number of Waveform Channels.

Syntax

public int NumberOfWaveformChannels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfWaveformSamples Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfWaveformSamples Field

Glossary Item Box

Number of Waveform Samples.

Syntax

public int NumberOfWaveformSamples

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfWedges Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfWedges Field

Glossary Item Box

Number of Wedges.

Syntax

public int NumberOfWedges

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumberOfZeroFills Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumberOfZeroFills Field

Glossary Item Box

Number of Zero fills.

Syntax

public int NumberOfZeroFills

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumericValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumericValue Field

Glossary Item Box

Numeric Value.

Syntax

public int NumericValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

NumericValueQualifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : NumericValueQualifierCodeSequence Field

Glossary Item Box

Numeric Value Qualifier Code Sequence.

Syntax

public int NumericValueQualifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ObjectPixelSpacinginCenterofBeam Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ObjectPixelSpacinginCenterofBeam Field

Glossary Item Box

Object Pixel Spacing in Center of Beam.

Syntax

public int ObjectPixelSpacinginCenterofBeam

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ObjectThicknessSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ObjectThicknessSequence Field

Glossary Item Box

Object Thickness Sequence.

Syntax

public int ObjectThicknessSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ObservationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ObservationDateTime Field

Glossary Item Box

Observation Date Time.

Syntax

public int ObservationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ObservationNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ObservationNumber Field

Glossary Item Box

Observation Number.

Syntax

public int ObservationNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ObserverType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ObserverType Field

Glossary Item Box

Observer Type.

Syntax

public int ObserverType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Occupation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Occupation Field

Glossary Item Box

Patient's Occupation.

Syntax

public int Occupation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OffendingElement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OffendingElement Field

Glossary Item Box

Offending Element.

Syntax

public int OffendingElement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OffsetOfReferencedLowerLevelDirectoryEntity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OffsetOfReferencedLowerLevelDirectoryEntity Field

Glossary Item Box

Offset of Referenced Lower-Level Directory Entity.

Syntax

public int OffsetOfReferencedLowerLevelDirectoryEntity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity Field
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity Field

Glossary Item Box

Offset of the First Directory Record of the Root Directory Entity.

Syntax

public int OffsetOfTheFirstDirectoryRecordOfTheRootDirectoryEntity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity Field

Glossary Item Box

Offset of the Last Directory Record of the Root Directory Entity.

Syntax

public int OffsetOfTheLastDirectoryRecordOfTheRootDirectoryEntity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OffsetOfTheNextDirectoryRecord Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OffsetOfTheNextDirectoryRecord Field

Glossary Item Box

Offset of the Next Directory Record.

Syntax

public int OffsetOfTheNextDirectoryRecord

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OnAxisBackgroundAnatomicStructureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OnAxisBackgroundAnatomicStructureCodeSequence Field

Glossary Item Box

OnAxis Background Anatomic Structure Code Sequence (Trial). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OnAxisBackgroundAnatomicStructureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OperatingMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OperatingMode Field

Glossary Item Box

Operating Mode.

Syntax

public int OperatingMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OperatingModeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OperatingModeSequence Field

Glossary Item Box

Operating Mode Sequence.

Syntax

public int OperatingModeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OperatingModeType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OperatingModeType Field

Glossary Item Box

Operating Mode Type.

Syntax

public int OperatingModeType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OperatorIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OperatorIdentificationSequence Field

Glossary Item Box

Operator Identification Sequence.

Syntax

public int OperatorIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OperatorsName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OperatorsName Field

Glossary Item Box

Operators' Name.

Syntax

public int OperatorsName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OphthalmicFrameLocationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OphthalmicFrameLocationSequence Field

Glossary Item Box

Ophthalmic Frame Location Sequence.

Syntax

public int OphthalmicFrameLocationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OphthalmicImageOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OphthalmicImageOrientation Field

Glossary Item Box

Ophthalmic Image Orientation.

Syntax

public int OphthalmicImageOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OpticalTransmittance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OpticalTransmittance Field

Glossary Item Box

Optical Transmittance.

Syntax

public int OpticalTransmittance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Optotype Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Optotype Field

Glossary Item Box

Optotype tag.

Syntax

public int Optotype

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OptotypeDetailedDefinition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OptotypeDetailedDefinition Field

Glossary Item Box

Optotype Detailed Definition.

Syntax

public int OptotypeDetailedDefinition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OptotypePresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OptotypePresentation Field

Glossary Item Box

Optotype Presentation.

Syntax

public int OptotypePresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrderCallbackPhoneNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrderCallbackPhoneNumber Field

Glossary Item Box

Order Callback Phone Number.

Syntax

public int OrderCallbackPhoneNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrderEnteredBy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrderEnteredBy Field

Glossary Item Box

Order Entered By.

Syntax

public int OrderEnteredBy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrderEnterersLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrderEnterersLocation Field

Glossary Item Box

Order Enterer's Location.

Syntax

public int OrderEnterersLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrderFillerIdentifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrderFillerIdentifierSequence Field

Glossary Item Box

Order Filler Identifier Sequence.

Syntax

public int OrderFillerIdentifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrderPlacerIdentifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrderPlacerIdentifierSequence Field

Glossary Item Box

Order Placer Identifier Sequence.

Syntax

public int OrderPlacerIdentifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganAtRiskFullVolumeDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganAtRiskFullVolumeDose Field

Glossary Item Box

Organ at Risk Full-volume Dose.

Syntax

public int OrganAtRiskFullVolumeDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganAtRiskLimitDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganAtRiskLimitDose Field

Glossary Item Box

Organ at Risk Limit Dose.

Syntax

public int OrganAtRiskLimitDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganAtRiskMaximumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganAtRiskMaximumDose Field

Glossary Item Box

Organ at Risk Maximum Dose.

Syntax

public int OrganAtRiskMaximumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganAtRiskOverdoseVolumeFraction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganAtRiskOverdoseVolumeFraction Field

Glossary Item Box

Organ at Risk Overdose Volume Fraction.

Syntax

public int OrganAtRiskOverdoseVolumeFraction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganDose Field

Glossary Item Box

Organ Dose.

Syntax

public int OrganDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OrganExposed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OrganExposed Field

Glossary Item Box

Organ Exposed.

Syntax

public int OrganExposed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OriginalAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OriginalAttributesSequence Field

Glossary Item Box

Original Attributes Sequence.

Syntax

public int OriginalAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OriginalImageIdentification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OriginalImageIdentification Field

Glossary Item Box

Original Image Identification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OriginalImageIdentification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OriginalImageIdentificationNomenclature Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OriginalImageIdentificationNomenclature Field

Glossary Item Box

Original Image Identification Nomenclature. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OriginalImageIdentificationNomenclature

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OriginalImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OriginalImageSequence Field

Glossary Item Box

Original Image Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OriginalImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OriginalSpecializedSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OriginalSpecializedSOPClassUID Field

Glossary Item Box

Original Specialized SOP Class UID.

Syntax

public int OriginalSpecializedSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Originator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Originator Field

Glossary Item Box

The Originator.

Syntax

public int Originator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherMagnificationTypesAvailable Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherMagnificationTypesAvailable Field

Glossary Item Box

Other Magnification Types Available.

Syntax

public int OtherMagnificationTypesAvailable

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherMediaAvailableSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherMediaAvailableSequence Field

Glossary Item Box

Other Media Available Sequence.

Syntax

public int OtherMediaAvailableSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherPatientIDs Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherPatientIDs Field

Glossary Item Box

Other Patient IDs.

Syntax

public int OtherPatientIDs

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherPatientIDsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherPatientIDsSequence Field

Glossary Item Box

Other Patient IDs Sequence.

Syntax

public int OtherPatientIDsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherPatientNames Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherPatientNames Field

Glossary Item Box

Other Patient Names.

Syntax

public int OtherPatientNames

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherPupillaryDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherPupillaryDistance Field

Glossary Item Box

Other Pupillary Distance.

Syntax

public int OtherPupillaryDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherSmoothingTypesAvailable Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherSmoothingTypesAvailable Field

Glossary Item Box

Other Smoothing Types Available.

Syntax

public int OtherSmoothingTypesAvailable

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OtherStudyNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OtherStudyNumbers Field

Glossary Item Box

Other Study Numbers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OtherStudyNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OutputInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OutputInformationSequence Field

Glossary Item Box

Output Information Sequence.

Syntax

public int OutputInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OutputPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OutputPower Field

Glossary Item Box

Output Power.

Syntax

public int OutputPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayActivationLayer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayActivationLayer Field

Glossary Item Box

Overlay Activation Layer.

Syntax

public int OverlayActivationLayer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayBackgroundDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayBackgroundDensity Field

Glossary Item Box

Overlay Background Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayBackgroundDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayBitPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayBitPosition Field

Glossary Item Box

Overlay Bit Position.

Syntax

public int OverlayBitPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayBitsAllocated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayBitsAllocated Field

Glossary Item Box

Overlay Bits Allocated.

Syntax

public int OverlayBitsAllocated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayBitsForCodeWord Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayBitsForCodeWord Field

Glossary Item Box

Overlay Bits For Code Word. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayBitsForCodeWord

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayBitsGrouped Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayBitsGrouped Field

Glossary Item Box

Overlay Bits Grouped. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayBitsGrouped

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCodeLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCodeLabel Field

Glossary Item Box

Overlay Code Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCodeLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCodeTableLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCodeTableLocation Field

Glossary Item Box

Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCodeTableLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayColumns Field

Glossary Item Box

Overlay Columns.

Syntax

public int OverlayColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayComments Field

Glossary Item Box

Overlay Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCompressionCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCompressionCode Field

Glossary Item Box

Overlay Compression Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCompressionCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCompressionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCompressionDescription Field

Glossary Item Box

Overlay Compression Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCompressionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCompressionLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCompressionLabel Field

Glossary Item Box

Overlay Compression Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCompressionLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCompressionOriginator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCompressionOriginator Field

Glossary Item Box

Overlay Compression Originator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCompressionOriginator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayCompressionStepPointers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayCompressionStepPointers Field

Glossary Item Box

Overlay Compression Step Pointers. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayCompressionStepPointers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayData Field

Glossary Item Box

Overlay Data.

Syntax

public int OverlayData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDate Field

Glossary Item Box

Overlay Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDescription Field

Glossary Item Box

Overlay Description.

Syntax

public int OverlayDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDescriptorBlue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDescriptorBlue Field

Glossary Item Box

Overlay Descriptor - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayDescriptorBlue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDescriptorGray Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDescriptorGray Field

Glossary Item Box

Overlay Descriptor - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayDescriptorGray

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDescriptorGreen Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDescriptorGreen Field

Glossary Item Box

Overlay Descriptor - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayDescriptorGreen

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayDescriptorRed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayDescriptorRed Field

Glossary Item Box

Overlay Descriptor - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayDescriptorRed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayForegroundDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayForegroundDensity Field

Glossary Item Box

Overlay Foreground Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayForegroundDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayFormat Field

Glossary Item Box

Overlay Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayLabel Field

Glossary Item Box

Overlay Label.

Syntax

public int OverlayLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayLocation Field

Glossary Item Box

Overlay Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayMagnificationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayMagnificationType Field

Glossary Item Box

Overlay Magnification Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayMagnificationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayMode Field

Glossary Item Box

Overlay Mode. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayNumber Field

Glossary Item Box

Overlay Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayNumberOfTables Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayNumberOfTables Field

Glossary Item Box

Overlay Number of Tables. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayNumberOfTables

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayOrigin Field

Glossary Item Box

Overlay Origin.

Syntax

public int OverlayOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayorImageMagnification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayorImageMagnification Field

Glossary Item Box

Overlay or Image Magnification. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayorImageMagnification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayPixelDataSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayPixelDataSequence Field

Glossary Item Box

Overlay Pixel Data Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayPixelDataSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayPlaneOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayPlaneOrigin Field

Glossary Item Box

Overlay Plane Origin. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayPlaneOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayPlanes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayPlanes Field

Glossary Item Box

Overlay Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayPlanes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayRepeatInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayRepeatInterval Field

Glossary Item Box

Overlay Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayRepeatInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayRows Field

Glossary Item Box

Overlay Rows.

Syntax

public int OverlayRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Overlays Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Overlays Field

Glossary Item Box

Overlays. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Overlays

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaysBlue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaysBlue Field

Glossary Item Box

Overlays - Blue. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlaysBlue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaysGray Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaysGray Field

Glossary Item Box

Overlays - Gray. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlaysGray

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaysGreen Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaysGreen Field

Glossary Item Box

Overlays - Green. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlaysGreen

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaySmoothingType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaySmoothingType Field

Glossary Item Box

Overlay Smoothing Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlaySmoothingType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaysRed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaysRed Field

Glossary Item Box

Overlays - Red. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlaysRed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlaySubtype Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlaySubtype Field

Glossary Item Box

Overlay Subtype.

Syntax

public int OverlaySubtype

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayTime Field

Glossary Item Box

Overlay Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int OverlayTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverlayType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverlayType Field

Glossary Item Box

Overlay Type.

Syntax

public int OverlayType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverriddenAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverriddenAttributesSequence Field

Glossary Item Box

Overridden Attributes Sequence.

Syntax

public int OverriddenAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverrideParameterPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverrideParameterPointer Field

Glossary Item Box

Override Parameter Pointer.

Syntax

public int OverrideParameterPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverrideReason Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverrideReason Field

Glossary Item Box

Override Reason.

Syntax

public int OverrideReason

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverrideSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverrideSequence Field

Glossary Item Box

Override Sequence.

Syntax

public int OverrideSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OverSamplingPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OverSamplingPhase Field

Glossary Item Box

Oversampling Phase.

Syntax

public int OverSamplingPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

OwnerID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : OwnerID Field

Glossary Item Box

Owner Identifier.

Syntax

public int OwnerID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PageNumberVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PageNumberVector Field

Glossary Item Box

Page Number Vector.

Syntax

public int PageNumberVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PagePositionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PagePositionID Field

Glossary Item Box

Page Position ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PagePositionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PaletteColorLookupTableUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PaletteColorLookupTableUID Field

Glossary Item Box

Palette Color Lookup Table UID.

Syntax

public int PaletteColorLookupTableUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelAcquisition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelAcquisition Field

Glossary Item Box

Parallel Acquisition.

Syntax

public int ParallelAcquisition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelAcquisitionTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelAcquisitionTechnique Field

Glossary Item Box

Parallel Acquisition Technique.

Syntax

public int ParallelAcquisitionTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelReductionFactorInPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelReductionFactorInPlane Field

Glossary Item Box

Parallel Reduction Factor In-plane.

Syntax

public int ParallelReductionFactorInPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelReductionFactorInPlaneRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelReductionFactorInPlaneRetired Field

Glossary Item Box

Parallel Reduction Factor In-plane (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ParallelReductionFactorInPlaneRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelReductionFactorOutOfPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelReductionFactorOutOfPlane Field

Glossary Item Box

Parallel Reduction Factor out-of-plane.

Syntax

public int ParallelReductionFactorOutOfPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParallelReductionFactorSecondInPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParallelReductionFactorSecondInPlane Field

Glossary Item Box

Parallel Reduction Factor Second In-plane.

Syntax

public int ParallelReductionFactorSecondInPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParameterItemIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParameterItemIndex Field

Glossary Item Box

Parameter Item Index.

Syntax

public int ParameterItemIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParameterPointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParameterPointer Field

Glossary Item Box

Parameter Pointer.

Syntax

public int ParameterPointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParameterSequencePointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParameterSequencePointer Field

Glossary Item Box

Parameter Sequence Pointer.

Syntax

public int ParameterSequencePointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialDataDisplayHandling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialDataDisplayHandling Field

Glossary Item Box

Partial Data Display Handling.

Syntax

public int PartialDataDisplayHandling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialFourier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialFourier Field

Glossary Item Box

Partial Fourier.

Syntax

public int PartialFourier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialFourierDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialFourierDirection Field

Glossary Item Box

Partial Fourier Direction.

Syntax

public int PartialFourierDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialView Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialView Field

Glossary Item Box

Partial View.

Syntax

public int PartialView

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialViewCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialViewCodeSequence Field

Glossary Item Box

Partial View Code Sequence.

Syntax

public int PartialViewCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PartialViewDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PartialViewDescription Field

Glossary Item Box

Partial View Description.

Syntax

public int PartialViewDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParticipantSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParticipantSequence Field

Glossary Item Box

Participant Sequence.

Syntax

public int ParticipantSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParticipationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParticipationDateTime Field

Glossary Item Box

Participation DateTime.

Syntax

public int ParticipationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ParticipationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ParticipationType Field

Glossary Item Box

Participation Type.

Syntax

public int ParticipationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientAdditionalPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientAdditionalPosition Field

Glossary Item Box

Patient Additional Position.

Syntax

public int PatientAdditionalPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientAddress Field

Glossary Item Box

Patient's Address.

Syntax

public int PatientAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientAge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientAge Field

Glossary Item Box

Patient's Age.

Syntax

public int PatientAge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientBirthDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientBirthDate Field

Glossary Item Box

Patient's Birth Date.

Syntax

public int PatientBirthDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientBirthName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientBirthName Field

Glossary Item Box

Patient's Birth Name.

Syntax

public int PatientBirthName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientBirthTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientBirthTime Field

Glossary Item Box

Patient's Birth Time.

Syntax

public int PatientBirthTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientBreedCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientBreedCodeSequence Field

Glossary Item Box

Patient Breed Code Sequence.

Syntax

public int PatientBreedCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientBreedDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientBreedDescription Field

Glossary Item Box

Patient Breed Description.

Syntax

public int PatientBreedDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientClinicalTrialParticipationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientClinicalTrialParticipationSequence Field

Glossary Item Box

Patient Clinical Trial Participation Sequence.

Syntax

public int PatientClinicalTrialParticipationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientComments Field

Glossary Item Box

Patient Comments.

Syntax

public int PatientComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientEyeMovementCommandCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientEyeMovementCommandCodeSequence Field

Glossary Item Box

Patient Eye Movement Command Code Sequence.

Syntax

public int PatientEyeMovementCommandCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientEyeMovementCommanded Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientEyeMovementCommanded Field

Glossary Item Box

Patient Eye Movement Commanded.

Syntax

public int PatientEyeMovementCommanded

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientFrameOfReferenceSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientFrameOfReferenceSource Field

Glossary Item Box

Patient Frame of Reference Source.

Syntax

public int PatientFrameOfReferenceSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientGantryRelationshipCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientGantryRelationshipCodeSequence Field

Glossary Item Box

Patient Gantry Relationship Code Sequence.

Syntax

public int PatientGantryRelationshipCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientID Field

Glossary Item Box

Patient ID.

Syntax

public int PatientID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientIdentityRemoved Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientIdentityRemoved Field

Glossary Item Box

Patient Identity Removed.

Syntax

public int PatientIdentityRemoved

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientInsurancePlanCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientInsurancePlanCodeSequence Field

Glossary Item Box

Patient's Insurance Plan Code Sequence.

Syntax

public int PatientInsurancePlanCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientMotherBirthName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientMotherBirthName Field

Glossary Item Box

Patient's Mother's Birth Name.

Syntax

public int PatientMotherBirthName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientMotionCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientMotionCorrected Field

Glossary Item Box

Patient Motion Corrected.

Syntax

public int PatientMotionCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientName Field

Glossary Item Box

Patient's Name.

Syntax

public int PatientName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientOrientation Field

Glossary Item Box

Patient Orientation.

Syntax

public int PatientOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientOrientationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientOrientationCodeSequence Field

Glossary Item Box

Patient Orientation Code Sequence.

Syntax

public int PatientOrientationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientOrientationinFrameSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientOrientationinFrameSequence Field

Glossary Item Box

Patient Orientation in Frame Sequence.

Syntax

public int PatientOrientationinFrameSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientOrientationModifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientOrientationModifierCodeSequence Field

Glossary Item Box

Patient Orientation Modifier Code Sequence.

Syntax

public int PatientOrientationModifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientPhysiologicalStateCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientPhysiologicalStateCodeSequence Field

Glossary Item Box

Patient Physiological State Code Sequence.

Syntax

public int PatientPhysiologicalStateCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientPhysiologicalStateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientPhysiologicalStateSequence Field

Glossary Item Box

Patient Physiological State Sequence.

Syntax

public int PatientPhysiologicalStateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientPosition Field

Glossary Item Box

Patient Position.

Syntax

public int PatientPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientPrimaryLanguageCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientPrimaryLanguageCodeSequence Field

Glossary Item Box

Patient's Primary Language Code Sequence.

Syntax

public int PatientPrimaryLanguageCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientPrimaryLanguageModifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientPrimaryLanguageModifierCodeSequence Field

Glossary Item Box

Patient's Primary Language Modifier Code Sequence.

Syntax

public int PatientPrimaryLanguageModifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientReligiousPreference Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientReligiousPreference Field

Glossary Item Box

Patient's Religious Preference.

Syntax

public int PatientReligiousPreference

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSetupLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSetupLabel Field

Glossary Item Box

Patient Setup Label.

Syntax

public int PatientSetupLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSetupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSetupNumber Field

Glossary Item Box

Patient Setup Number.

Syntax

public int PatientSetupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSetupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSetupSequence Field

Glossary Item Box

Patient Setup Sequence.

Syntax

public int PatientSetupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSex Field

Glossary Item Box

Patient's Sex.

Syntax

public int PatientSex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSexNeutered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSexNeutered Field

Glossary Item Box

Patient's Sex Neutered.

Syntax

public int PatientSexNeutered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientsInstitutionResidence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientsInstitutionResidence Field

Glossary Item Box

Patient's Institution Residence.

Syntax

public int PatientsInstitutionResidence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSize Field

Glossary Item Box

Patient's Size.

Syntax

public int PatientSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSpeciesCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSpeciesCodeSequence Field

Glossary Item Box

Patient Species Code Sequence.

Syntax

public int PatientSpeciesCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSpeciesDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSpeciesDescription Field

Glossary Item Box

Patient Species Description.

Syntax

public int PatientSpeciesDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientState Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientState Field

Glossary Item Box

Patient State.

Syntax

public int PatientState

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportAccessoryCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportAccessoryCode Field

Glossary Item Box

Patient Support Accessory Code.

Syntax

public int PatientSupportAccessoryCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportAngle Field

Glossary Item Box

Patient Support Angle.

Syntax

public int PatientSupportAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportAngleTolerance Field

Glossary Item Box

Patient Support Angle Tolerance.

Syntax

public int PatientSupportAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportID Field

Glossary Item Box

Patient Support ID.

Syntax

public int PatientSupportID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportRotationDirection Field

Glossary Item Box

Patient Support Rotation Direction.

Syntax

public int PatientSupportRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientSupportType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientSupportType Field

Glossary Item Box

Patient Support Type.

Syntax

public int PatientSupportType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientTelephoneNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientTelephoneNumbers Field

Glossary Item Box

Patient's Telephone Numbers.

Syntax

public int PatientTelephoneNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientTransportArrangements Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientTransportArrangements Field

Glossary Item Box

Patient Transport Arrangements.

Syntax

public int PatientTransportArrangements

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PatientWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PatientWeight Field

Glossary Item Box

Patient's Weight.

Syntax

public int PatientWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PauseBetweenFrames Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PauseBetweenFrames Field

Glossary Item Box

Pause Between Frames.

Syntax

public int PauseBetweenFrames

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PercentPhaseFieldOfView Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PercentPhaseFieldOfView Field

Glossary Item Box

Percent Phase Field of View.

Syntax

public int PercentPhaseFieldOfView

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PercentSampling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PercentSampling Field

Glossary Item Box

Percent Sampling.

Syntax

public int PercentSampling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedLocation Field

Glossary Item Box

Performed Location.

Syntax

public int PerformedLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureCodeSequence Field

Glossary Item Box

Performed Procedure Code Sequence.

Syntax

public int PerformedProcedureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepDescription Field

Glossary Item Box

Performed Procedure Step Description.

Syntax

public int PerformedProcedureStepDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepDiscontinuationReasonCodeSequence Field
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepDiscontinuationReasonCodeSequence Field

Glossary Item Box

Performed Procedure Step Discontinuation Reason Code Sequence.

Syntax

public int PerformedProcedureStepDiscontinuationReasonCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepEndDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepEndDate Field

Glossary Item Box

Performed Procedure Step End Date.

Syntax

public int PerformedProcedureStepEndDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepEndTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepEndTime Field

Glossary Item Box

Performed Procedure Step End Time.

Syntax

public int PerformedProcedureStepEndTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepID Field

Glossary Item Box

Performed Procedure Step ID.

Syntax

public int PerformedProcedureStepID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepStartDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepStartDate Field

Glossary Item Box

Performed Procedure Step Start Date.

Syntax

public int PerformedProcedureStepStartDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepStartTime Field

Glossary Item Box

Performed Procedure Step Start Time.

Syntax

public int PerformedProcedureStepStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureStepStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureStepStatus Field

Glossary Item Box

Performed Procedure Step Status.

Syntax

public int PerformedProcedureStepStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcedureTypeDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcedureTypeDescription Field

Glossary Item Box

Performed Procedure Type Description.

Syntax

public int PerformedProcedureTypeDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcessingApplicationsCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcessingApplicationsCodeSequence Field

Glossary Item Box

Performed Processing Applications Code Sequence.

Syntax

public int PerformedProcessingApplicationsCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProcessingParametersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProcessingParametersSequence Field

Glossary Item Box

Performed Processing Parameters Sequence.

Syntax

public int PerformedProcessingParametersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProtocolCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProtocolCodeSequence Field

Glossary Item Box

Performed Protocol Code Sequence.

Syntax

public int PerformedProtocolCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedProtocolType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedProtocolType Field

Glossary Item Box

Performed Protocol Type.

Syntax

public int PerformedProtocolType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedSeriesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedSeriesSequence Field

Glossary Item Box

Performed Series Sequence.

Syntax

public int PerformedSeriesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedStationAeTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedStationAeTitle Field

Glossary Item Box

Performed Station AE Title.

Syntax

public int PerformedStationAeTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedStationClassCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedStationClassCodeSequence Field

Glossary Item Box

Performed Station Class Code Sequence.

Syntax

public int PerformedStationClassCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedStationGeographicLocationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedStationGeographicLocationCodeSequence Field

Glossary Item Box

Performed Station Geographic Location Code Sequence.

Syntax

public int PerformedStationGeographicLocationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedStationName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedStationName Field

Glossary Item Box

Performed Station Name.

Syntax

public int PerformedStationName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedStationNameCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedStationNameCodeSequence Field

Glossary Item Box

Performed Station Name Code Sequence.

Syntax

public int PerformedStationNameCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformedWorkitemCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformedWorkitemCodeSequence Field

Glossary Item Box

Performed Workitem Code Sequence.

Syntax

public int PerformedWorkitemCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformingPhysicianIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformingPhysicianIdentificationSequence Field

Glossary Item Box

Performing Physician Identification Sequence.

Syntax

public int PerformingPhysicianIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerformingPhysiciansName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerformingPhysiciansName Field

Glossary Item Box

Performing Physician's Name.

Syntax

public int PerformingPhysiciansName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerFrameFunctionalGroupsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerFrameFunctionalGroupsSequence Field

Glossary Item Box

Per-frame Functional Groups Sequence.

Syntax

public int PerFrameFunctionalGroupsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerimeterTable Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerimeterTable Field

Glossary Item Box

Perimeter Table. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PerimeterTable

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerimeterValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerimeterValue Field

Glossary Item Box

Perimeter Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PerimeterValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PerProjectionAcquisitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PerProjectionAcquisitionSequence Field

Glossary Item Box

Per Projection Acquisition Sequence.

Syntax

public int PerProjectionAcquisitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PersonIdentificationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PersonIdentificationCodeSequence Field

Glossary Item Box

Person Identification Code Sequence.

Syntax

public int PersonIdentificationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PersonName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PersonName Field

Glossary Item Box

Person Name.

Syntax

public int PersonName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PersonsAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PersonsAddress Field

Glossary Item Box

Person's Address.

Syntax

public int PersonsAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PersonsTelephoneNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PersonsTelephoneNumbers Field

Glossary Item Box

Person's Telephone Numbers.

Syntax

public int PersonsTelephoneNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PertinentDocumentsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PertinentDocumentsSequence Field

Glossary Item Box

Pertinent Documents Sequence.

Syntax

public int PertinentDocumentsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PertinentOtherEvidenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PertinentOtherEvidenceSequence Field

Glossary Item Box

Pertinent Other Evidence Sequence.

Syntax

public int PertinentOtherEvidenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETDetectorMotionDetailsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETDetectorMotionDetailsSequence Field

Glossary Item Box

PET Detector Motion Details Sequence.

Syntax

public int PETDetectorMotionDetailsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETFrameAcquisitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETFrameAcquisitionSequence Field

Glossary Item Box

PET Frame Acquisition Sequence.

Syntax

public int PETFrameAcquisitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETFrameCorrectionFactorsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETFrameCorrectionFactorsSequence Field

Glossary Item Box

PET Frame Correction Factors Sequence.

Syntax

public int PETFrameCorrectionFactorsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETFrameTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETFrameTypeSequence Field

Glossary Item Box

PET Frame Type Sequence.

Syntax

public int PETFrameTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETPositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETPositionSequence Field

Glossary Item Box

PET Position Sequence.

Syntax

public int PETPositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETReconstructionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETReconstructionSequence Field

Glossary Item Box

PET Reconstruction Sequence.

Syntax

public int PETReconstructionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PETTableDynamicsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PETTableDynamicsSequence Field

Glossary Item Box

PET Table Dynamics Sequence.

Syntax

public int PETTableDynamicsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseContrast Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseContrast Field

Glossary Item Box

Phase Contrast.

Syntax

public int PhaseContrast

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseDelay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseDelay Field

Glossary Item Box

Phase Delay.

Syntax

public int PhaseDelay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseDescription Field

Glossary Item Box

Phase Description.

Syntax

public int PhaseDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseInformationSequence Field

Glossary Item Box

Phase Information Sequence.

Syntax

public int PhaseInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseNumber Field

Glossary Item Box

Phase Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PhaseNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhaseVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhaseVector Field

Glossary Item Box

Phase Vector.

Syntax

public int PhaseVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhosphorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhosphorType Field

Glossary Item Box

Phosphor Type.

Syntax

public int PhosphorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhotometricInterpretation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhotometricInterpretation Field

Glossary Item Box

Photometric Interpretation.

Syntax

public int PhotometricInterpretation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhototimerSetting Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhototimerSetting Field

Glossary Item Box

Phototimer Setting.

Syntax

public int PhototimerSetting

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicalDeltaX Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicalDeltaX Field

Glossary Item Box

Physical Delta X.

Syntax

public int PhysicalDeltaX

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicalDeltaY Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicalDeltaY Field

Glossary Item Box

Physical Delta Y.

Syntax

public int PhysicalDeltaY

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicalDetectorSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicalDetectorSize Field

Glossary Item Box

Physical Detector Size.

Syntax

public int PhysicalDetectorSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicalUnitsXDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicalUnitsXDirection Field

Glossary Item Box

Physical Units X Direction.

Syntax

public int PhysicalUnitsXDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicalUnitsYDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicalUnitsYDirection Field

Glossary Item Box

Physical Units Y Direction.

Syntax

public int PhysicalUnitsYDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysicianApprovingInterpretation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysicianApprovingInterpretation Field

Glossary Item Box

Physician Approving Interpretation. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PhysicianApprovingInterpretation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysiciansOfRecord Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysiciansOfRecord Field

Glossary Item Box

Physician(s) of Record.

Syntax

public int PhysiciansOfRecord

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysiciansOfRecordIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysiciansOfRecordIdentificationSequence Field

Glossary Item Box

Physician(s) of Record Identification Sequence.

Syntax

public int PhysiciansOfRecordIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PhysiciansReadingStudyIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PhysiciansReadingStudyIdentificationSequence Field

Glossary Item Box

Physician(s) Reading Study Identification Sequence.

Syntax

public int PhysiciansReadingStudyIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelAspectRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelAspectRatio Field

Glossary Item Box

Pixel Aspect Ratio.

Syntax

public int PixelAspectRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelBandwidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelBandwidth Field

Glossary Item Box

Pixel Bandwidth.

Syntax

public int PixelBandwidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentDataType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentDataType Field

Glossary Item Box

Pixel Component Data Type.

Syntax

public int PixelComponentDataType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentMask Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentMask Field

Glossary Item Box

Pixel Component Mask.

Syntax

public int PixelComponentMask

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentOrganization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentOrganization Field

Glossary Item Box

Pixel Component Organization.

Syntax

public int PixelComponentOrganization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentPhysicalUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentPhysicalUnits Field

Glossary Item Box

Pixel Component Physical Units.

Syntax

public int PixelComponentPhysicalUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentRangeStart Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentRangeStart Field

Glossary Item Box

Pixel Component Range Start.

Syntax

public int PixelComponentRangeStart

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelComponentRangeStop Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelComponentRangeStop Field

Glossary Item Box

Pixel Component Range Stop.

Syntax

public int PixelComponentRangeStop

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelCoordinateSet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelCoordinateSet Field

Glossary Item Box

Pixel Coordinate Set.

Syntax

public int PixelCoordinateSet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelData Field

Glossary Item Box

Pixel Data.

Syntax

public int PixelData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelDataProviderURL Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelDataProviderURL Field

Glossary Item Box

Pixel Data Provider URL.

Syntax

public int PixelDataProviderURL

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelIntensityRelationship Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelIntensityRelationship Field

Glossary Item Box

Pixel Intensity Relationship.

Syntax

public int PixelIntensityRelationship

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelIntensityRelationshipLUTSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelIntensityRelationshipLUTSequence Field

Glossary Item Box

Pixel Intensity Relationship LUT Sequence.

Syntax

public int PixelIntensityRelationshipLUTSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelIntensityRelationshipSign Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelIntensityRelationshipSign Field

Glossary Item Box

Pixel Intensity Relationship Sign.

Syntax

public int PixelIntensityRelationshipSign

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelMeasuresSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelMeasuresSequence Field

Glossary Item Box

Pixel Measures Sequence.

Syntax

public int PixelMeasuresSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelPaddingRangeLimit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelPaddingRangeLimit Field

Glossary Item Box

Pixel Padding Range Limit.

Syntax

public int PixelPaddingRangeLimit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelPaddingValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelPaddingValue Field

Glossary Item Box

Pixel Padding Value.

Syntax

public int PixelPaddingValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelPresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelPresentation Field

Glossary Item Box

Pixel Presentation.

Syntax

public int PixelPresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelRepresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelRepresentation Field

Glossary Item Box

Pixel Representation.

Syntax

public int PixelRepresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelShiftFrameRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelShiftFrameRange Field

Glossary Item Box

Pixel Shift Frame Range.

Syntax

public int PixelShiftFrameRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelShiftSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelShiftSequence Field

Glossary Item Box

Pixel Shift Sequence.

Syntax

public int PixelShiftSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelSpacing Field

Glossary Item Box

Pixel Spacing.

Syntax

public int PixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelSpacingCalibrationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelSpacingCalibrationDescription Field

Glossary Item Box

Pixel Spacing Calibration Description.

Syntax

public int PixelSpacingCalibrationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelSpacingCalibrationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelSpacingCalibrationType Field

Glossary Item Box

Pixel Spacing Calibration Type.

Syntax

public int PixelSpacingCalibrationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelSpacingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelSpacingSequence Field

Glossary Item Box

Pixel Spacing Sequence.

Syntax

public int PixelSpacingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelValueMappingCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelValueMappingCodeSequence Field

Glossary Item Box

Pixel Value Mapping Code Sequence.

Syntax

public int PixelValueMappingCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PixelValueTransformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PixelValueTransformationSequence Field

Glossary Item Box

Pixel Value Transformation Sequence.

Syntax

public int PixelValueTransformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlacerOrderNumberImagingServiceRequest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlacerOrderNumberImagingServiceRequest Field

Glossary Item Box

Placer Order Number / Imaging Service Request.

Syntax

public int PlacerOrderNumberImagingServiceRequest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlacerOrderNumberImagingServiceRequestRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlacerOrderNumberImagingServiceRequestRetired Field

Glossary Item Box

Placer Order Number / Imaging Service Request (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PlacerOrderNumberImagingServiceRequestRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlacerOrderNumberProcedure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlacerOrderNumberProcedure Field

Glossary Item Box

Placer Order Number / Procedure. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PlacerOrderNumberProcedure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlanarConfiguration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlanarConfiguration Field

Glossary Item Box

Planar Configuration.

Syntax

public int PlanarConfiguration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlaneIdentification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlaneIdentification Field

Glossary Item Box

Plane Identification.

Syntax

public int PlaneIdentification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlaneOrientationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlaneOrientationSequence Field

Glossary Item Box

Plane Orientation Sequence.

Syntax

public int PlaneOrientationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlaneOrientationVolumeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlaneOrientationVolumeSequence Field

Glossary Item Box

Plane Orientation (Volume) Sequence.

Syntax

public int PlaneOrientationVolumeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlanePositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlanePositionSequence Field

Glossary Item Box

Plane Position Sequence.

Syntax

public int PlanePositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlanePositionVolumeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlanePositionVolumeSequence Field

Glossary Item Box

Plane Position (Volume) Sequence.

Syntax

public int PlanePositionVolumeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Planes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Planes Field

Glossary Item Box

Planes. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Planes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlanIntent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlanIntent Field

Glossary Item Box

Plan Intent.

Syntax

public int PlanIntent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlannedVerificationImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlannedVerificationImageSequence Field

Glossary Item Box

Planned Verification Image Sequence.

Syntax

public int PlannedVerificationImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlateID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlateID Field

Glossary Item Box

Plate Identifier.

Syntax

public int PlateID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PlateType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PlateType Field

Glossary Item Box

Plate Type.

Syntax

public int PlateType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PointCoordinatesData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PointCoordinatesData Field

Glossary Item Box

Point Coordinates Data.

Syntax

public int PointCoordinatesData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PointPositionAccuracy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PointPositionAccuracy Field

Glossary Item Box

Point Position Accuracy.

Syntax

public int PointPositionAccuracy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PointsBoundingBoxCoordinates Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PointsBoundingBoxCoordinates Field

Glossary Item Box

Points Bounding Box Coordinates.

Syntax

public int PointsBoundingBoxCoordinates

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Polarity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Polarity Field

Glossary Item Box

Image Polarity.

Syntax

public int Polarity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerIsocenterDetectorRotationAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerIsocenterDetectorRotationAngle Field

Glossary Item Box

Positioner Isocenter Detector Rotation Angle.

Syntax

public int PositionerIsocenterDetectorRotationAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerIsocenterPrimaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerIsocenterPrimaryAngle Field

Glossary Item Box

Positioner Isocenter Primary Angle.

Syntax

public int PositionerIsocenterPrimaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerIsocenterSecondaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerIsocenterSecondaryAngle Field

Glossary Item Box

Positioner Isocenter Secondary Angle.

Syntax

public int PositionerIsocenterSecondaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerMotion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerMotion Field

Glossary Item Box

Positioner Motion.

Syntax

public int PositionerMotion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerPositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerPositionSequence Field

Glossary Item Box

Positioner Position Sequence.

Syntax

public int PositionerPositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerPrimaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerPrimaryAngle Field

Glossary Item Box

Positioner Primary Angle.

Syntax

public int PositionerPrimaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerPrimaryAngleIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerPrimaryAngleIncrement Field

Glossary Item Box

Positioner Primary Angle Increment.

Syntax

public int PositionerPrimaryAngleIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerSecondaryAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerSecondaryAngle Field

Glossary Item Box

Positioner Secondary Angle.

Syntax

public int PositionerSecondaryAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerSecondaryAngleIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerSecondaryAngleIncrement Field

Glossary Item Box

Positioner Secondary Angle Increment.

Syntax

public int PositionerSecondaryAngleIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionerType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionerType Field

Glossary Item Box

Positioner Type.

Syntax

public int PositionerType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionMeasuringDeviceUsed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionMeasuringDeviceUsed Field

Glossary Item Box

Position Measuring Device Used.

Syntax

public int PositionMeasuringDeviceUsed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionofIsocenterProjection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionofIsocenterProjection Field

Glossary Item Box

Position of Isocenter Projection.

Syntax

public int PositionofIsocenterProjection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PositionReferenceIndicator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PositionReferenceIndicator Field

Glossary Item Box

Position Reference Indicator.

Syntax

public int PositionReferenceIndicator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PostDeformationMatrixRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PostDeformationMatrixRegistrationSequence Field

Glossary Item Box

Post Deformation Matrix Registration Sequence.

Syntax

public int PostDeformationMatrixRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PostprocessingFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PostprocessingFunction Field

Glossary Item Box

Postprocessing Function. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PostprocessingFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Preamble Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Preamble Field

Glossary Item Box

DICOM preamble.

Syntax

public int Preamble

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PredecessorDocumentsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PredecessorDocumentsSequence Field

Glossary Item Box

Predecessor Documents Sequence.

Syntax

public int PredecessorDocumentsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PreDeformationMatrixRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PreDeformationMatrixRegistrationSequence Field

Glossary Item Box

Pre Deformation Matrix Registration Sequence.

Syntax

public int PreDeformationMatrixRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PredictorColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PredictorColumns Field

Glossary Item Box

Predictor Columns. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PredictorColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PredictorConstants Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PredictorConstants Field

Glossary Item Box

Predictor Constants. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PredictorConstants

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PredictorRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PredictorRows Field

Glossary Item Box

Predictor Rows. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PredictorRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PreferredPlaybackSequencing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PreferredPlaybackSequencing Field

Glossary Item Box

Preferred Playback Sequencing.

Syntax

public int PreferredPlaybackSequencing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PregnancyStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PregnancyStatus Field

Glossary Item Box

Pregnancy Status.

Syntax

public int PregnancyStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PreliminaryFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PreliminaryFlag Field

Glossary Item Box

Preliminary Flag.

Syntax

public int PreliminaryFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PreMedication Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PreMedication Field

Glossary Item Box

Pre Medication.

Syntax

public int PreMedication

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrescriptionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrescriptionDescription Field

Glossary Item Box

Prescription Description.

Syntax

public int PrescriptionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationCreationDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationCreationDate Field

Glossary Item Box

Presentation Creation Date.

Syntax

public int PresentationCreationDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationCreationTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationCreationTime Field

Glossary Item Box

Presentation Creation Time.

Syntax

public int PresentationCreationTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationGroupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationGroupNumber Field

Glossary Item Box

Presentation Group Number.

Syntax

public int PresentationGroupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationIntentType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationIntentType Field

Glossary Item Box

Presentation Intent Type.

Syntax

public int PresentationIntentType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationLutContentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationLutContentSequence Field

Glossary Item Box

Presentation LUT Content Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PresentationLutContentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationLutFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationLutFlag Field

Glossary Item Box

Presentation LUT Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PresentationLutFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationLutSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationLutSequence Field

Glossary Item Box

Presentation LUT Sequence.

Syntax

public int PresentationLutSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationLutShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationLutShape Field

Glossary Item Box

Presentation LUT Shape.

Syntax

public int PresentationLutShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationPixelAspectRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationPixelAspectRatio Field

Glossary Item Box

Presentation Pixel Aspect Ratio.

Syntax

public int PresentationPixelAspectRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationPixelMagnificationRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationPixelMagnificationRatio Field

Glossary Item Box

Presentation Pixel Magnification Ratio.

Syntax

public int PresentationPixelMagnificationRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationPixelSpacing Field

Glossary Item Box

Presentation Pixel Spacing.

Syntax

public int PresentationPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PresentationSizeMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PresentationSizeMode Field

Glossary Item Box

Presentation Size Mode.

Syntax

public int PresentationSizeMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PreserveCompositeInstancesAfterMediaCreation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PreserveCompositeInstancesAfterMediaCreation Field

Glossary Item Box

Preserve Composite Instances After Media Creation.

Syntax

public int PreserveCompositeInstancesAfterMediaCreation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryAnatomicStructureModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryAnatomicStructureModifierSequence Field

Glossary Item Box

Primary Anatomic Structure Modifier Sequence.

Syntax

public int PrimaryAnatomicStructureModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryAnatomicStructureSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryAnatomicStructureSequence Field

Glossary Item Box

Primary Anatomic Structure Sequence.

Syntax

public int PrimaryAnatomicStructureSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryDosimeterUnit Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryDosimeterUnit Field

Glossary Item Box

Primary Dosimeter Unit.

Syntax

public int PrimaryDosimeterUnit

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryFluenceModeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryFluenceModeSequence Field

Glossary Item Box

Primary Fluence Mode Sequence.

Syntax

public int PrimaryFluenceModeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryPositionerIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryPositionerIncrement Field

Glossary Item Box

Primary Positioner Increment.

Syntax

public int PrimaryPositionerIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryPositionerScanArc Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryPositionerScanArc Field

Glossary Item Box

Primary Positioner Scan Arc.

Syntax

public int PrimaryPositionerScanArc

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryPositionerScanStartAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryPositionerScanStartAngle Field

Glossary Item Box

Primary Positioner Scan Start Angle.

Syntax

public int PrimaryPositionerScanStartAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimaryPromptsCountsAccumulated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimaryPromptsCountsAccumulated Field

Glossary Item Box

Primary (Prompts) Counts Accumulated.

Syntax

public int PrimaryPromptsCountsAccumulated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrimitivePointIndexList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrimitivePointIndexList Field

Glossary Item Box

Primitive Point Index List.

Syntax

public int PrimitivePointIndexList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Print Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Print Field

Glossary Item Box

Print. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Print

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterCharacteristicsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterCharacteristicsSequence Field

Glossary Item Box

Printer Characteristics Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PrinterCharacteristicsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterConfigurationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterConfigurationSequence Field

Glossary Item Box

Printer Configuration Sequence.

Syntax

public int PrinterConfigurationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterName Field

Glossary Item Box

Printer Name.

Syntax

public int PrinterName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterPixelSpacing Field

Glossary Item Box

Printer Pixel Spacing.

Syntax

public int PrinterPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterResolutionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterResolutionID Field

Glossary Item Box

Printer Resolution ID.

Syntax

public int PrinterResolutionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterStatus Field

Glossary Item Box

Printer Status.

Syntax

public int PrinterStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrinterStatusInfo Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrinterStatusInfo Field

Glossary Item Box

Printer Status Info.

Syntax

public int PrinterStatusInfo

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintingBitDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintingBitDepth Field

Glossary Item Box

Printing Bit Depth.

Syntax

public int PrintingBitDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintJobDescriptionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintJobDescriptionSequence Field

Glossary Item Box

Print Job Description Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PrintJobDescriptionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintJobID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintJobID Field

Glossary Item Box

Print Job ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PrintJobID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintManagementCapabilitiesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintManagementCapabilitiesSequence Field

Glossary Item Box

Print Management Capabilities Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PrintManagementCapabilitiesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintPriority Field

Glossary Item Box

Print Priority.

Syntax

public int PrintPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrintQueueID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrintQueueID Field

Glossary Item Box

Print Queue ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int PrintQueueID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Priority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Priority Field

Glossary Item Box

Operation Priority.

Syntax

public int Priority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrismSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrismSequence Field

Glossary Item Box

Prism Sequence.

Syntax

public int PrismSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrivateInformation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrivateInformation Field

Glossary Item Box

Private Information.

Syntax

public int PrivateInformation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrivateInformationCreatorUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrivateInformationCreatorUID Field

Glossary Item Box

Private Information Creator UID.

Syntax

public int PrivateInformationCreatorUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PrivateRecordUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PrivateRecordUID Field

Glossary Item Box

Private Record UID.

Syntax

public int PrivateRecordUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProcedureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProcedureCodeSequence Field

Glossary Item Box

Procedure Code Sequence.

Syntax

public int ProcedureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProcedureStepLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProcedureStepLabel Field

Glossary Item Box

Procedure Step Label.

Syntax

public int ProcedureStepLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProcedureStepRelationshipType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProcedureStepRelationshipType Field

Glossary Item Box

Procedure Step Relationship Type.

Syntax

public int ProcedureStepRelationshipType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProcessingFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProcessingFunction Field

Glossary Item Box

Processing Function.

Syntax

public int ProcessingFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductDescription Field

Glossary Item Box

Product Description.

Syntax

public int ProductDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductExpirationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductExpirationDateTime Field

Glossary Item Box

Product Expiration DateTime.

Syntax

public int ProductExpirationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductLotIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductLotIdentifier Field

Glossary Item Box

Product Lot Identifier.

Syntax

public int ProductLotIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductName Field

Glossary Item Box

Product Name.

Syntax

public int ProductName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductPackageIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductPackageIdentifier Field

Glossary Item Box

Product Package Identifier.

Syntax

public int ProductPackageIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductParameterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductParameterSequence Field

Glossary Item Box

Product Parameter Sequence.

Syntax

public int ProductParameterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProductTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProductTypeCodeSequence Field

Glossary Item Box

Product Type Code Sequence.

Syntax

public int ProductTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProjectionEponymousNameCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProjectionEponymousNameCodeSequence Field

Glossary Item Box

Projection Eponymous Name Code Sequence.

Syntax

public int ProjectionEponymousNameCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProjectionPixelCalibrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProjectionPixelCalibrationSequence Field

Glossary Item Box

Projection Pixel Calibration Sequence.

Syntax

public int ProjectionPixelCalibrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProposedStudySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProposedStudySequence Field

Glossary Item Box

Proposed Study Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ProposedStudySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProtocolContextSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProtocolContextSequence Field

Glossary Item Box

Protocol Context Sequence.

Syntax

public int ProtocolContextSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ProtocolName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ProtocolName Field

Glossary Item Box

Protocol Name.

Syntax

public int ProtocolName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PseudocolorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PseudocolorType Field

Glossary Item Box

Pseudo-color Type.

Syntax

public int PseudocolorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PulseRepetitionFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PulseRepetitionFrequency Field

Glossary Item Box

Pulse Repetition Frequency.

Syntax

public int PulseRepetitionFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PulseRepetitionInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PulseRepetitionInterval Field

Glossary Item Box

Pulse Repetition Interval.

Syntax

public int PulseRepetitionInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PulseSequenceName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PulseSequenceName Field

Glossary Item Box

Pulse Sequence Name.

Syntax

public int PulseSequenceName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PupilDilated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PupilDilated Field

Glossary Item Box

Pupil Dilated.

Syntax

public int PupilDilated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PupilSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PupilSize Field

Glossary Item Box

Pupil Size.

Syntax

public int PupilSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PurposeOfReferenceCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PurposeOfReferenceCodeSequence Field

Glossary Item Box

Purpose of Reference Code Sequence.

Syntax

public int PurposeOfReferenceCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

PvcRejection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : PvcRejection Field

Glossary Item Box

PVC Rejection.

Syntax

public int PvcRejection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

QuadratureReceiveCoil Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : QuadratureReceiveCoil Field

Glossary Item Box

Quadrature Receive Coil.

Syntax

public int QuadratureReceiveCoil

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

QualityControlImage Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : QualityControlImage Field

Glossary Item Box

Quality Control Image.

Syntax

public int QualityControlImage

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Quantity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Quantity Field

Glossary Item Box

Quantity value.

Syntax

public int Quantity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

QuantitySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : QuantitySequence Field

Glossary Item Box

Quantity Sequence.

Syntax

public int QuantitySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

QueryRetrieveLevel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : QueryRetrieveLevel Field

Glossary Item Box

Query/Retrieve Level.

Syntax

public int QueryRetrieveLevel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

QueueStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : QueueStatus Field

Glossary Item Box

Queue Status. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int QueueStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadialPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadialPosition Field

Glossary Item Box

Radial Position.

Syntax

public int RadialPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationAtomicNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationAtomicNumber Field

Glossary Item Box

Radiation Atomic Number.

Syntax

public int RadiationAtomicNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationChargeState Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationChargeState Field

Glossary Item Box

Radiation Charge State.

Syntax

public int RadiationChargeState

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationMachineName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationMachineName Field

Glossary Item Box

Radiation Machine Name.

Syntax

public int RadiationMachineName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationMachineSad Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationMachineSad Field

Glossary Item Box

Radiation Machine SAD.

Syntax

public int RadiationMachineSad

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationMachineSsd Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationMachineSsd Field

Glossary Item Box

Radiation Machine SSD.

Syntax

public int RadiationMachineSsd

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationMassNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationMassNumber Field

Glossary Item Box

Radiation Mass Number.

Syntax

public int RadiationMassNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationMode Field

Glossary Item Box

Radiation Mode.

Syntax

public int RadiationMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationSetting Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationSetting Field

Glossary Item Box

Radiation Setting.

Syntax

public int RadiationSetting

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiationType Field

Glossary Item Box

Radiation Type.

Syntax

public int RadiationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Radionuclide Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Radionuclide Field

Glossary Item Box

Radionuclide. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Radionuclide

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadionuclideCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadionuclideCodeSequence Field

Glossary Item Box

Radionuclide Code Sequence.

Syntax

public int RadionuclideCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadionuclideHalfLife Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadionuclideHalfLife Field

Glossary Item Box

Radionuclide Half Life.

Syntax

public int RadionuclideHalfLife

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadionuclidePositronFraction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadionuclidePositronFraction Field

Glossary Item Box

Radionuclide Positron Fraction.

Syntax

public int RadionuclidePositronFraction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadionuclideTotalDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadionuclideTotalDose Field

Glossary Item Box

Radionuclide Total Dose.

Syntax

public int RadionuclideTotalDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Radiopharmaceutical Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Radiopharmaceutical Field

Glossary Item Box

Radiopharmaceutical value.

Syntax

public int Radiopharmaceutical

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalAgentNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalAgentNumber Field

Glossary Item Box

Radiopharmaceutical Agent Number.

Syntax

public int RadiopharmaceuticalAgentNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalCodeSequence Field

Glossary Item Box

Radiopharmaceutical Code Sequence.

Syntax

public int RadiopharmaceuticalCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalInformationSequence Field

Glossary Item Box

Radiopharmaceutical Information Sequence.

Syntax

public int RadiopharmaceuticalInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalRoute Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalRoute Field

Glossary Item Box

Radiopharmaceutical Route.

Syntax

public int RadiopharmaceuticalRoute

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalSpecificActivity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalSpecificActivity Field

Glossary Item Box

Radiopharmaceutical Specific Activity.

Syntax

public int RadiopharmaceuticalSpecificActivity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalStartDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalStartDateTime Field

Glossary Item Box

Radiopharmaceutical Start DateTime.

Syntax

public int RadiopharmaceuticalStartDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalStartTime Field

Glossary Item Box

Radiopharmaceutical Start Time.

Syntax

public int RadiopharmaceuticalStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalStopDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalStopDateTime Field

Glossary Item Box

Radiopharmaceutical Stop DateTime.

Syntax

public int RadiopharmaceuticalStopDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalStopTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalStopTime Field

Glossary Item Box

Radiopharmaceutical Stop Time.

Syntax

public int RadiopharmaceuticalStopTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalUsageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalUsageSequence Field

Glossary Item Box

Radiopharmaceutical Usage Sequence.

Syntax

public int RadiopharmaceuticalUsageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiopharmaceuticalVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiopharmaceuticalVolume Field

Glossary Item Box

Radiopharmaceutical Volume.

Syntax

public int RadiopharmaceuticalVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiusOfCircularCollimator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiusOfCircularCollimator Field

Glossary Item Box

Radius of Circular Collimator.

Syntax

public int RadiusOfCircularCollimator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiusofCircularExposureControlSensingRegion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiusofCircularExposureControlSensingRegion Field

Glossary Item Box

Radius of Circular Exposure Control Sensing Region.

Syntax

public int RadiusofCircularExposureControlSensingRegion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiusOfCircularShutter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiusOfCircularShutter Field

Glossary Item Box

Radius of Circular Shutter.

Syntax

public int RadiusOfCircularShutter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RadiusOfCurvature Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RadiusOfCurvature Field

Glossary Item Box

Radius of Curvature.

Syntax

public int RadiusOfCurvature

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RandomsCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RandomsCorrected Field

Glossary Item Box

Randoms Corrected.

Syntax

public int RandomsCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RandomsCorrectionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RandomsCorrectionMethod Field

Glossary Item Box

Randoms Correction Method.

Syntax

public int RandomsCorrectionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorDescription Field

Glossary Item Box

Range Modulator Description.

Syntax

public int RangeModulatorDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorGatingStartValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorGatingStartValue Field

Glossary Item Box

Range Modulator Gating Start Value.

Syntax

public int RangeModulatorGatingStartValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorGatingStartWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorGatingStartWaterEquivalentThickness Field

Glossary Item Box

Range Modulator Gating Start Water Equivalent Thickness.

Syntax

public int RangeModulatorGatingStartWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorGatingStopValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorGatingStopValue Field

Glossary Item Box

Range Modulator Gating Stop Value.

Syntax

public int RangeModulatorGatingStopValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorGatingStopWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorGatingStopWaterEquivalentThickness Field

Glossary Item Box

Range Modulator Gating Stop Water Equivalent Thickness.

Syntax

public int RangeModulatorGatingStopWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorID Field

Glossary Item Box

Range Modulator ID.

Syntax

public int RangeModulatorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorNumber Field

Glossary Item Box

Range Modulator Number.

Syntax

public int RangeModulatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorSequence Field

Glossary Item Box

Range Modulator Sequence.

Syntax

public int RangeModulatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorSettingsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorSettingsSequence Field

Glossary Item Box

Range Modulator Settings Sequence.

Syntax

public int RangeModulatorSettingsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeModulatorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeModulatorType Field

Glossary Item Box

Range Modulator Type.

Syntax

public int RangeModulatorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterDescription Field

Glossary Item Box

Range Shifter Description.

Syntax

public int RangeShifterDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterID Field

Glossary Item Box

Range Shifter ID.

Syntax

public int RangeShifterID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterNumber Field

Glossary Item Box

Range Shifter Number.

Syntax

public int RangeShifterNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterSequence Field

Glossary Item Box

Range Shifter Sequence.

Syntax

public int RangeShifterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterSetting Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterSetting Field

Glossary Item Box

Range Shifter Setting.

Syntax

public int RangeShifterSetting

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterSettingsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterSettingsSequence Field

Glossary Item Box

Range Shifter Settings Sequence.

Syntax

public int RangeShifterSettingsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterType Field

Glossary Item Box

Range Shifter Type.

Syntax

public int RangeShifterType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RangeShifterWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RangeShifterWaterEquivalentThickness Field

Glossary Item Box

Range Shifter Water Equivalent Thickness.

Syntax

public int RangeShifterWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RawDataHandling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RawDataHandling Field

Glossary Item Box

Raw Data Handling.

Syntax

public int RawDataHandling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueFirstValueMapped Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueFirstValueMapped Field

Glossary Item Box

Real World Value First Value Mapped.

Syntax

public int RealWorldValueFirstValueMapped

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueIntercept Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueIntercept Field

Glossary Item Box

Real World Value Intercept.

Syntax

public int RealWorldValueIntercept

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueLastValueMapped Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueLastValueMapped Field

Glossary Item Box

Real World Value Last Value Mapped.

Syntax

public int RealWorldValueLastValueMapped

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueLUTData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueLUTData Field

Glossary Item Box

Real World Value LUT Data.

Syntax

public int RealWorldValueLUTData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueMappingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueMappingSequence Field

Glossary Item Box

Real World Value Mapping Sequence.

Syntax

public int RealWorldValueMappingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RealWorldValueSlope Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RealWorldValueSlope Field

Glossary Item Box

Real World Value Slope.

Syntax

public int RealWorldValueSlope

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForCancellation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForCancellation Field

Glossary Item Box

Reason for Cancellation.

Syntax

public int ReasonForCancellation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForPerformedProcedureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForPerformedProcedureCodeSequence Field

Glossary Item Box

Reason For Performed Procedure Code Sequence.

Syntax

public int ReasonForPerformedProcedureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonforRequestedProcedureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonforRequestedProcedureCodeSequence Field

Glossary Item Box

Reason for Requested Procedure Code Sequence.

Syntax

public int ReasonforRequestedProcedureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForStudy Field

Glossary Item Box

Reason for Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReasonForStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForTheAttributeModification Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForTheAttributeModification Field

Glossary Item Box

Reason for the Attribute Modification.

Syntax

public int ReasonForTheAttributeModification

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForTheImagingServiceRequest Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForTheImagingServiceRequest Field

Glossary Item Box

Reason for the Imaging Service Request. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReasonForTheImagingServiceRequest

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReasonForTheRequestedProcedure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReasonForTheRequestedProcedure Field

Glossary Item Box

Reason for the Requested Procedure.

Syntax

public int ReasonForTheRequestedProcedure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReceiveCoilManufacturerName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReceiveCoilManufacturerName Field

Glossary Item Box

Receive Coil Manufacturer Name.

Syntax

public int ReceiveCoilManufacturerName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReceiveCoilName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReceiveCoilName Field

Glossary Item Box

Receive Coil Name.

Syntax

public int ReceiveCoilName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReceiveCoilType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReceiveCoilType Field

Glossary Item Box

Receive Coil Type.

Syntax

public int ReceiveCoilType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReceiverAeTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReceiverAeTitle Field

Glossary Item Box

Receiver. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReceiverAeTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReceivingAE Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReceivingAE Field

Glossary Item Box

Receiving AE.

Syntax

public int ReceivingAE

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecognitionCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecognitionCode Field

Glossary Item Box

Recognition Code. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RecognitionCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecognitionCodeRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecognitionCodeRetired Field

Glossary Item Box

Recognition Code (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RecognitionCodeRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedDisplayCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedDisplayCIELabValue Field

Glossary Item Box

Recommended Display CIELab Value.

Syntax

public int RecommendedDisplayCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedDisplayFrameRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedDisplayFrameRate Field

Glossary Item Box

Recommended Display Frame Rate.

Syntax

public int RecommendedDisplayFrameRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedDisplayFrameRateinFloat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedDisplayFrameRateinFloat Field

Glossary Item Box

Recommended Display Frame Rate in Float.

Syntax

public int RecommendedDisplayFrameRateinFloat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedDisplayGrayscaleValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedDisplayGrayscaleValue Field

Glossary Item Box

Recommended Display Grayscale Value.

Syntax

public int RecommendedDisplayGrayscaleValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedPresentationOpacity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedPresentationOpacity Field

Glossary Item Box

Recommended Presentation Opacity.

Syntax

public int RecommendedPresentationOpacity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedPresentationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedPresentationType Field

Glossary Item Box

Recommended Presentation Type.

Syntax

public int RecommendedPresentationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecommendedViewingMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecommendedViewingMode Field

Glossary Item Box

Recommended Viewing Mode.

Syntax

public int RecommendedViewingMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionAlgorithm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionAlgorithm Field

Glossary Item Box

Reconstruction Algorithm.

Syntax

public int ReconstructionAlgorithm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionAngle Field

Glossary Item Box

Reconstruction Angle.

Syntax

public int ReconstructionAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionDescription Field

Glossary Item Box

Reconstruction Description.

Syntax

public int ReconstructionDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionDiameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionDiameter Field

Glossary Item Box

Reconstruction Diameter.

Syntax

public int ReconstructionDiameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionFieldofView Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionFieldofView Field

Glossary Item Box

Reconstruction Field of View.

Syntax

public int ReconstructionFieldofView

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionIndex Field

Glossary Item Box

Reconstruction Index.

Syntax

public int ReconstructionIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionMethod Field

Glossary Item Box

Reconstruction Method.

Syntax

public int ReconstructionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionPixelSpacing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionPixelSpacing Field

Glossary Item Box

Reconstruction Pixel Spacing.

Syntax

public int ReconstructionPixelSpacing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionTargetCenterPatient Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionTargetCenterPatient Field

Glossary Item Box

Reconstruction Target Center (Patient).

Syntax

public int ReconstructionTargetCenterPatient

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReconstructionType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReconstructionType Field

Glossary Item Box

Reconstruction Type.

Syntax

public int ReconstructionType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedBlockSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedBlockSequence Field

Glossary Item Box

Recorded Block Sequence.

Syntax

public int RecordedBlockSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedBrachyAccessoryDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedBrachyAccessoryDeviceSequence Field

Glossary Item Box

Recorded Brachy Accessory Device Sequence.

Syntax

public int RecordedBrachyAccessoryDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedChannelSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedChannelSequence Field

Glossary Item Box

Recorded Channel Sequence.

Syntax

public int RecordedChannelSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedChannelShieldSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedChannelShieldSequence Field

Glossary Item Box

Recorded Channel Shield Sequence.

Syntax

public int RecordedChannelShieldSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedCompensatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedCompensatorSequence Field

Glossary Item Box

Recorded Compensator Sequence.

Syntax

public int RecordedCompensatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedLateralSpreadingDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedLateralSpreadingDeviceSequence Field

Glossary Item Box

Recorded Lateral Spreading Device Sequence.

Syntax

public int RecordedLateralSpreadingDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedRangeModulatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedRangeModulatorSequence Field

Glossary Item Box

Recorded Range Modulator Sequence.

Syntax

public int RecordedRangeModulatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedRangeShifterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedRangeShifterSequence Field

Glossary Item Box

Recorded Range Shifter Sequence.

Syntax

public int RecordedRangeShifterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedSnoutSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedSnoutSequence Field

Glossary Item Box

Recorded Snout Sequence.

Syntax

public int RecordedSnoutSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedSourceApplicatorSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedSourceApplicatorSequence Field

Glossary Item Box

Recorded Source Applicator Sequence.

Syntax

public int RecordedSourceApplicatorSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedSourceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedSourceSequence Field

Glossary Item Box

Recorded Source Sequence.

Syntax

public int RecordedSourceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordedWedgeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordedWedgeSequence Field

Glossary Item Box

Recorded Wedge Sequence.

Syntax

public int RecordedWedgeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RecordInUseFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RecordInUseFlag Field

Glossary Item Box

Record In-use Flag.

Syntax

public int RecordInUseFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RectificationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RectificationType Field

Glossary Item Box

Rectification Type.

Syntax

public int RectificationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RectilinearPhaseEncodeReordering Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RectilinearPhaseEncodeReordering Field

Glossary Item Box

Rectilinear Phase Encode Reordering.

Syntax

public int RectilinearPhaseEncodeReordering

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RedPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RedPaletteColorLookupTableData Field

Glossary Item Box

Red Palette Color Lookup Table Data.

Syntax

public int RedPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RedPaletteColorLookupTableDescriptor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RedPaletteColorLookupTableDescriptor Field

Glossary Item Box

Red Palette Color Lookup Table Descriptor.

Syntax

public int RedPaletteColorLookupTableDescriptor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Reference Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Reference Field

Glossary Item Box

Reference. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int Reference

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferenceAirKermaRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferenceAirKermaRate Field

Glossary Item Box

Reference Air Kerma Rate.

Syntax

public int ReferenceAirKermaRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferenceCoordinates Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferenceCoordinates Field

Glossary Item Box

Reference Coordinates.

Syntax

public int ReferenceCoordinates

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBasicAnnotationBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBasicAnnotationBoxSequence Field

Glossary Item Box

Referenced Basic Annotation Box Sequence.

Syntax

public int ReferencedBasicAnnotationBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBeamNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBeamNumber Field

Glossary Item Box

Referenced Beam Number.

Syntax

public int ReferencedBeamNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBeamSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBeamSequence Field

Glossary Item Box

Referenced Beam Sequence.

Syntax

public int ReferencedBeamSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBlockNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBlockNumber Field

Glossary Item Box

Referenced Block Number.

Syntax

public int ReferencedBlockNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBolusSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBolusSequence Field

Glossary Item Box

Referenced Bolus Sequence.

Syntax

public int ReferencedBolusSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBrachyAccessoryDeviceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBrachyAccessoryDeviceNumber Field

Glossary Item Box

Referenced Brachy Accessory Device Number.

Syntax

public int ReferencedBrachyAccessoryDeviceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBrachyApplicationSetupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBrachyApplicationSetupNumber Field

Glossary Item Box

Referenced Brachy Application Setup Number.

Syntax

public int ReferencedBrachyApplicationSetupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedBrachyApplicationSetupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedBrachyApplicationSetupSequence Field

Glossary Item Box

Referenced Brachy Application Setup Sequence.

Syntax

public int ReferencedBrachyApplicationSetupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedCalculatedDoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedCalculatedDoseReferenceNumber Field

Glossary Item Box

Referenced Calculated Dose Reference Number.

Syntax

public int ReferencedCalculatedDoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedCalculatedDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedCalculatedDoseReferenceSequence Field

Glossary Item Box

Referenced Calculated Dose Reference Sequence.

Syntax

public int ReferencedCalculatedDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedChannelShieldNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedChannelShieldNumber Field

Glossary Item Box

Referenced Channel Shield Number.

Syntax

public int ReferencedChannelShieldNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedCompensatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedCompensatorNumber Field

Glossary Item Box

Referenced Compensator Number.

Syntax

public int ReferencedCompensatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedContentItemIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedContentItemIdentifier Field

Glossary Item Box

Referenced Content Item Identifier.

Syntax

public int ReferencedContentItemIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedControlPointIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedControlPointIndex Field

Glossary Item Box

Referenced Control Point Index.

Syntax

public int ReferencedControlPointIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedControlPointSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedControlPointSequence Field

Glossary Item Box

Referenced Control Point Sequence.

Syntax

public int ReferencedControlPointSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedCurveSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedCurveSequence Field

Glossary Item Box

Referenced Curve Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedCurveSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedDateTime Field

Glossary Item Box

Referenced DateTime.

Syntax

public int ReferencedDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedDigitalSignatureSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedDigitalSignatureSequence Field

Glossary Item Box

Referenced Digital Signature Sequence.

Syntax

public int ReferencedDigitalSignatureSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedDoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedDoseReferenceNumber Field

Glossary Item Box

Referenced Dose Reference Number.

Syntax

public int ReferencedDoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedDoseReferenceSequence Field

Glossary Item Box

Referenced Dose Reference Sequence.

Syntax

public int ReferencedDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedDoseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedDoseSequence Field

Glossary Item Box

Referenced Dose Sequence.

Syntax

public int ReferencedDoseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFileID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFileID Field

Glossary Item Box

Referenced File ID.

Syntax

public int ReferencedFileID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFileXferSynUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFileXferSynUID Field

Glossary Item Box

Referenced Transfer Syntax UID in File.

Syntax

public int ReferencedFileXferSynUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFilmBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFilmBoxSequence Field

Glossary Item Box

Referenced Film Box Sequence.

Syntax

public int ReferencedFilmBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFilmSessionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFilmSessionSequence Field

Glossary Item Box

Referenced Film Session Sequence.

Syntax

public int ReferencedFilmSessionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFirstFrameSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFirstFrameSequence Field

Glossary Item Box

Referenced First Frame Sequence.

Syntax

public int ReferencedFirstFrameSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFractionGroupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFractionGroupNumber Field

Glossary Item Box

Referenced Fraction Group Number.

Syntax

public int ReferencedFractionGroupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFractionGroupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFractionGroupSequence Field

Glossary Item Box

Referenced Fraction Group Sequence.

Syntax

public int ReferencedFractionGroupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFractionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFractionNumber Field

Glossary Item Box

Referenced Fraction Number.

Syntax

public int ReferencedFractionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFrameNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFrameNumber Field

Glossary Item Box

Referenced Frame Number.

Syntax

public int ReferencedFrameNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFrameNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFrameNumbers Field

Glossary Item Box

Referenced Frame Numbers.

Syntax

public int ReferencedFrameNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFrameOfReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFrameOfReferenceSequence Field

Glossary Item Box

Referenced Frame of Reference Sequence.

Syntax

public int ReferencedFrameOfReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedFrameOfReferenceUID Field

Glossary Item Box

Referenced Frame of Reference UID.

Syntax

public int ReferencedFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedGeneralPurposeScheduledProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedGeneralPurposeScheduledProcedureStepSequence Field

Glossary Item Box

Referenced General Purpose Scheduled Procedure Step Sequence.

Syntax

public int ReferencedGeneralPurposeScheduledProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedGeneralPurposeScheduledProcedureStepTransactionUID Field
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedGeneralPurposeScheduledProcedureStepTransactionUID Field

Glossary Item Box

Referenced General Purpose Scheduled Procedure Step Transaction UID.

Syntax

public int ReferencedGeneralPurposeScheduledProcedureStepTransactionUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageBoxSequence Field

Glossary Item Box

Referenced Image Box Sequence.

Syntax

public int ReferencedImageBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageBoxSequenceRetired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageBoxSequenceRetired Field

Glossary Item Box

Referenced Image Box Sequence (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedImageBoxSequenceRetired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageEvidenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageEvidenceSequence Field

Glossary Item Box

Referenced Image Evidence Sequence.

Syntax

public int ReferencedImageEvidenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageOverlayBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageOverlayBoxSequence Field

Glossary Item Box

Referenced Image Overlay Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedImageOverlayBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageRealWorldValueMappingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageRealWorldValueMappingSequence Field

Glossary Item Box

Referenced Image Real World Value Mapping Sequence.

Syntax

public int ReferencedImageRealWorldValueMappingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedImageSequence Field

Glossary Item Box

Referenced Image Sequence.

Syntax

public int ReferencedImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedInstanceSequence Field

Glossary Item Box

Referenced Instance Sequence.

Syntax

public int ReferencedInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedInterpretationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedInterpretationSequence Field

Glossary Item Box

Referenced Interpretation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedInterpretationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferenceDisplaySets Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferenceDisplaySets Field

Glossary Item Box

Reference Display Sets.

Syntax

public int ReferenceDisplaySets

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedLateralSpreadingDeviceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedLateralSpreadingDeviceNumber Field

Glossary Item Box

Referenced Lateral Spreading Device Number.

Syntax

public int ReferencedLateralSpreadingDeviceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedMeasuredDoseReferenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedMeasuredDoseReferenceNumber Field

Glossary Item Box

Referenced Measured Dose Reference Number.

Syntax

public int ReferencedMeasuredDoseReferenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedMeasuredDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedMeasuredDoseReferenceSequence Field

Glossary Item Box

Referenced Measured Dose Reference Sequence.

Syntax

public int ReferencedMeasuredDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedNonImageCompositeSOPInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedNonImageCompositeSOPInstanceSequence Field

Glossary Item Box

Referenced Non-Image Composite SOP Instance Sequence.

Syntax

public int ReferencedNonImageCompositeSOPInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedOtherPlaneSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedOtherPlaneSequence Field

Glossary Item Box

Referenced Other Plane Sequence.

Syntax

public int ReferencedOtherPlaneSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedOverlayPlaneGroups Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedOverlayPlaneGroups Field

Glossary Item Box

Referenced Overlay Plane Groups. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedOverlayPlaneGroups

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedOverlayPlaneSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedOverlayPlaneSequence Field

Glossary Item Box

Referenced Overlay Plane Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedOverlayPlaneSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedOverlaySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedOverlaySequence Field

Glossary Item Box

Referenced Overlay Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedOverlaySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPatientAliasSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPatientAliasSequence Field

Glossary Item Box

Referenced Patient Alias Sequence.

Syntax

public int ReferencedPatientAliasSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPatientSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPatientSequence Field

Glossary Item Box

Referenced Patient Sequence.

Syntax

public int ReferencedPatientSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPatientSetupNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPatientSetupNumber Field

Glossary Item Box

Referenced Patient Setup Number.

Syntax

public int ReferencedPatientSetupNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPerformedProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPerformedProcedureStepSequence Field

Glossary Item Box

Referenced Performed Procedure Step Sequence.

Syntax

public int ReferencedPerformedProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPresentationLutSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPresentationLutSequence Field

Glossary Item Box

Referenced Presentation LUT Sequence.

Syntax

public int ReferencedPresentationLutSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPresentationStateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPresentationStateSequence Field

Glossary Item Box

Referenced Presentation State Sequence.

Syntax

public int ReferencedPresentationStateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPreviousWaveform Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPreviousWaveform Field

Glossary Item Box

Referenced Previous Waveform.

Syntax

public int ReferencedPreviousWaveform

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPrintJobSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPrintJobSequence Field

Glossary Item Box

Referenced Print Job Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedPrintJobSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedPrintJobSequencePullStoredPrint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedPrintJobSequencePullStoredPrint Field

Glossary Item Box

Referenced Print Job Sequence (Pull Stored Print). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedPrintJobSequencePullStoredPrint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedProcedureStepSequence Field

Glossary Item Box

Referenced Procedure Step Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRangeModulatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRangeModulatorNumber Field

Glossary Item Box

Referenced Range Modulator Number.

Syntax

public int ReferencedRangeModulatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRangeShifterNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRangeShifterNumber Field

Glossary Item Box

Referenced Range Shifter Number.

Syntax

public int ReferencedRangeShifterNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRawDataSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRawDataSequence Field

Glossary Item Box

Referenced Raw Data Sequence.

Syntax

public int ReferencedRawDataSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRealWorldValueMappingInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRealWorldValueMappingInstanceSequence Field

Glossary Item Box

Referenced Real World Value Mapping Instance Sequence.

Syntax

public int ReferencedRealWorldValueMappingInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedReferenceImageNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedReferenceImageNumber Field

Glossary Item Box

Referenced Reference Image Number.

Syntax

public int ReferencedReferenceImageNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedReferenceImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedReferenceImageSequence Field

Glossary Item Box

Referenced Reference Image Sequence.

Syntax

public int ReferencedReferenceImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRefractiveMeasurementsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRefractiveMeasurementsSequence Field

Glossary Item Box

Referenced Refractive Measurements Sequence.

Syntax

public int ReferencedRefractiveMeasurementsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRelatedGeneralSOPClassUIDinFile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRelatedGeneralSOPClassUIDinFile Field

Glossary Item Box

Referenced Related General SOP Class UID in File.

Syntax

public int ReferencedRelatedGeneralSOPClassUIDinFile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRequestSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRequestSequence Field

Glossary Item Box

Referenced Request Sequence.

Syntax

public int ReferencedRequestSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedResultsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedResultsSequence Field

Glossary Item Box

Referenced Results Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedResultsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRoiNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRoiNumber Field

Glossary Item Box

Referenced ROI Number.

Syntax

public int ReferencedRoiNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedRtPlanSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedRtPlanSequence Field

Glossary Item Box

Referenced RT Plan Sequence.

Syntax

public int ReferencedRtPlanSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSamplePositions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSamplePositions Field

Glossary Item Box

Referenced Sample Positions.

Syntax

public int ReferencedSamplePositions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSegmentNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSegmentNumber Field

Glossary Item Box

Referenced Segment Number.

Syntax

public int ReferencedSegmentNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSeriesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSeriesSequence Field

Glossary Item Box

Referenced Series Sequence.

Syntax

public int ReferencedSeriesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSetupImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSetupImageSequence Field

Glossary Item Box

Referenced Setup Image Sequence.

Syntax

public int ReferencedSetupImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPClassUID Field

Glossary Item Box

Referenced SOP Class UID.

Syntax

public int ReferencedSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPClassUIDInFile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPClassUIDInFile Field

Glossary Item Box

Referenced SOP Class UID in File.

Syntax

public int ReferencedSOPClassUIDInFile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPInstanceMACSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPInstanceMACSequence Field

Glossary Item Box

Referenced SOP Instance MAC Sequence.

Syntax

public int ReferencedSOPInstanceMACSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPInstanceUID Field

Glossary Item Box

Referenced SOP Instance UID.

Syntax

public int ReferencedSOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPInstanceUIDInFile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPInstanceUIDInFile Field

Glossary Item Box

Referenced SOP Instance UID in File.

Syntax

public int ReferencedSOPInstanceUIDInFile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSOPSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSOPSequence Field

Glossary Item Box

Referenced SOP Sequence.

Syntax

public int ReferencedSOPSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSourceApplicatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSourceApplicatorNumber Field

Glossary Item Box

Referenced Source Applicator Number.

Syntax

public int ReferencedSourceApplicatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSourceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSourceNumber Field

Glossary Item Box

Referenced Source Number.

Syntax

public int ReferencedSourceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSpatialRegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSpatialRegistrationSequence Field

Glossary Item Box

Referenced Spatial Registration Sequence.

Syntax

public int ReferencedSpatialRegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStartControlPointIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStartControlPointIndex Field

Glossary Item Box

Referenced Start Control Point Index.

Syntax

public int ReferencedStartControlPointIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStereometricInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStereometricInstanceSequence Field

Glossary Item Box

Referenced Stereometric Instance Sequence.

Syntax

public int ReferencedStereometricInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStopControlPointIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStopControlPointIndex Field

Glossary Item Box

Referenced Stop Control Point Index.

Syntax

public int ReferencedStopControlPointIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStorageMediaSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStorageMediaSequence Field

Glossary Item Box

Referenced Storage Media Sequence.

Syntax

public int ReferencedStorageMediaSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStoredPrintSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStoredPrintSequence Field

Glossary Item Box

Referenced Stored Print Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedStoredPrintSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStructureSetSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStructureSetSequence Field

Glossary Item Box

Referenced Structure Set Sequence.

Syntax

public int ReferencedStructureSetSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedStudySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedStudySequence Field

Glossary Item Box

Referenced Study Sequence.

Syntax

public int ReferencedStudySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSubsequentWaveform Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSubsequentWaveform Field

Glossary Item Box

Referenced Subsequent Waveform. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedSubsequentWaveform

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSurfaceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSurfaceNumber Field

Glossary Item Box

Referenced Surface Number.

Syntax

public int ReferencedSurfaceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedSurfaceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedSurfaceSequence Field

Glossary Item Box

Referenced Surface Sequence.

Syntax

public int ReferencedSurfaceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedTimeOffsets Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedTimeOffsets Field

Glossary Item Box

Referenced Time Offsets.

Syntax

public int ReferencedTimeOffsets

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedToleranceTableNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedToleranceTableNumber Field

Glossary Item Box

Referenced Tolerance Table Number.

Syntax

public int ReferencedToleranceTableNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedTransferSyntaxUIDInFile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedTransferSyntaxUIDInFile Field

Glossary Item Box

Referenced Transfer Syntax UID in File.

Syntax

public int ReferencedTransferSyntaxUIDInFile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedTreatmentRecordSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedTreatmentRecordSequence Field

Glossary Item Box

Referenced Treatment Record Sequence.

Syntax

public int ReferencedTreatmentRecordSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedTypeofData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedTypeofData Field

Glossary Item Box

Referenced Type of Data.

Syntax

public int ReferencedTypeofData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedVerificationImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedVerificationImageSequence Field

Glossary Item Box

Referenced Verification Image Sequence.

Syntax

public int ReferencedVerificationImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedVisitSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedVisitSequence Field

Glossary Item Box

Referenced Visit Sequence.

Syntax

public int ReferencedVisitSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedVOILUTBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedVOILUTBoxSequence Field

Glossary Item Box

Referenced VOI LUT Box Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencedVOILUTBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedWaveformChannels Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedWaveformChannels Field

Glossary Item Box

Referenced Waveform Channels.

Syntax

public int ReferencedWaveformChannels

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedWaveformSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedWaveformSequence Field

Glossary Item Box

Referenced Waveform Sequence.

Syntax

public int ReferencedWaveformSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencedWedgeNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencedWedgeNumber Field

Glossary Item Box

Referenced Wedge Number.

Syntax

public int ReferencedWedgeNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferenceImageNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferenceImageNumber Field

Glossary Item Box

Reference Image Number.

Syntax

public int ReferenceImageNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencePixelPhysicalValueX Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencePixelPhysicalValueX Field

Glossary Item Box

Reference Pixel Physical Value X.

Syntax

public int ReferencePixelPhysicalValueX

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencePixelPhysicalValueY Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencePixelPhysicalValueY Field

Glossary Item Box

Reference Pixel Physical Value Y.

Syntax

public int ReferencePixelPhysicalValueY

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencePixelX0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencePixelX0 Field

Glossary Item Box

Reference Pixel X0.

Syntax

public int ReferencePixelX0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencePixelY0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencePixelY0 Field

Glossary Item Box

Reference Pixel Y0.

Syntax

public int ReferencePixelY0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferencetoRecordedSound Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferencetoRecordedSound Field

Glossary Item Box

Reference to Recorded Sound. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ReferencetoRecordedSound

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferringPhysicianAddress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferringPhysicianAddress Field

Glossary Item Box

Referring Physician's Address.

Syntax

public int ReferringPhysicianAddress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferringPhysicianIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferringPhysicianIdentificationSequence Field

Glossary Item Box

Referring Physician Identification Sequence.

Syntax

public int ReferringPhysicianIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferringPhysicianName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferringPhysicianName Field

Glossary Item Box

Referring Physician's Name.

Syntax

public int ReferringPhysicianName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReferringPhysicianTelephoneNumbers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReferringPhysicianTelephoneNumbers Field

Glossary Item Box

Referring Physician's Telephone Numbers.

Syntax

public int ReferringPhysicianTelephoneNumbers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReflectedAmbientLight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReflectedAmbientLight Field

Glossary Item Box

Reflected Ambient Light.

Syntax

public int ReflectedAmbientLight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReformattingInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReformattingInterval Field

Glossary Item Box

Reformatting Interval.

Syntax

public int ReformattingInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReformattingOperationInitialViewDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReformattingOperationInitialViewDirection Field

Glossary Item Box

Reformatting Operation Initial View Direction.

Syntax

public int ReformattingOperationInitialViewDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReformattingOperationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReformattingOperationType Field

Glossary Item Box

Reformatting Operation Type.

Syntax

public int ReformattingOperationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReformattingThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReformattingThickness Field

Glossary Item Box

Reformatting Thickness.

Syntax

public int ReformattingThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RefractiveStateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RefractiveStateSequence Field

Glossary Item Box

Refractive State Sequence.

Syntax

public int RefractiveStateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionDataType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionDataType Field

Glossary Item Box

Region Data Type.

Syntax

public int RegionDataType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionFlags Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionFlags Field

Glossary Item Box

Region Flags.

Syntax

public int RegionFlags

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionLocationMaxX1 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionLocationMaxX1 Field

Glossary Item Box

Region Location Max X1.

Syntax

public int RegionLocationMaxX1

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionLocationMaxY1 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionLocationMaxY1 Field

Glossary Item Box

Region Location Max Y1.

Syntax

public int RegionLocationMaxY1

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionLocationMinX0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionLocationMinX0 Field

Glossary Item Box

Region Location Min X0.

Syntax

public int RegionLocationMinX0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionLocationMinY0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionLocationMinY0 Field

Glossary Item Box

Region Location Min Y0.

Syntax

public int RegionLocationMinY0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionOfResidence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionOfResidence Field

Glossary Item Box

Region of Residence.

Syntax

public int RegionOfResidence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionPixelShiftSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionPixelShiftSequence Field

Glossary Item Box

Region Pixel Shift Sequence.

Syntax

public int RegionPixelShiftSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegionSpatialFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegionSpatialFormat Field

Glossary Item Box

Region Spatial Format.

Syntax

public int RegionSpatialFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegistrationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegistrationSequence Field

Glossary Item Box

Registration Sequence.

Syntax

public int RegistrationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RegistrationTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RegistrationTypeCodeSequence Field

Glossary Item Box

Registration Type Code Sequence.

Syntax

public int RegistrationTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedFrameOfReferenceUID Field

Glossary Item Box

Related Frame of Reference UID.

Syntax

public int RelatedFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedGeneralSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedGeneralSOPClassUID Field

Glossary Item Box

Related General SOP Class UID.

Syntax

public int RelatedGeneralSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedProcedureStepSequence Field

Glossary Item Box

Related Procedure Step Sequence.

Syntax

public int RelatedProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedReferenceRTImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedReferenceRTImageSequence Field

Glossary Item Box

Related Reference RT Image Sequence.

Syntax

public int RelatedReferenceRTImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedRtRoiObservationsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedRtRoiObservationsSequence Field

Glossary Item Box

Related RT ROI Observations Sequence.

Syntax

public int RelatedRtRoiObservationsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelatedSeriesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelatedSeriesSequence Field

Glossary Item Box

Related Series Sequence.

Syntax

public int RelatedSeriesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelationshipType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelationshipType Field

Glossary Item Box

Relationship Type.

Syntax

public int RelationshipType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelationshipTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelationshipTypeCodeSequence Field

Glossary Item Box

Relationship Type Code Sequence.

Syntax

public int RelationshipTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelativeImagePositionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelativeImagePositionCodeSequence Field

Glossary Item Box

Relative Image Position Code Sequence.

Syntax

public int RelativeImagePositionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelativeOpacity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelativeOpacity Field

Glossary Item Box

Relative Opacity.

Syntax

public int RelativeOpacity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelativeTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelativeTime Field

Glossary Item Box

Relative Time.

Syntax

public int RelativeTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelativeTimeUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelativeTimeUnits Field

Glossary Item Box

Relative Time Units.

Syntax

public int RelativeTimeUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelativeXRayExposure Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelativeXRayExposure Field

Glossary Item Box

Relative X-Ray Exposure.

Syntax

public int RelativeXRayExposure

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RelevantInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RelevantInformationSequence Field

Glossary Item Box

Relevant Information Sequence.

Syntax

public int RelevantInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RenderingType3D Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RenderingType3D Field

Glossary Item Box

3D Rendering Type.

Syntax

public int RenderingType3D

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RepeatFractionCycleLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RepeatFractionCycleLength Field

Glossary Item Box

Repeat Fraction Cycle Length.

Syntax

public int RepeatFractionCycleLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RepeatInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RepeatInterval Field

Glossary Item Box

Repeat Interval. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RepeatInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RepetitionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RepetitionTime Field

Glossary Item Box

Repetition Time.

Syntax

public int RepetitionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReportedValuesOrigin Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReportedValuesOrigin Field

Glossary Item Box

Reported Values Origin.

Syntax

public int ReportedValuesOrigin

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReportingPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReportingPriority Field

Glossary Item Box

Reporting Priority.

Syntax

public int ReportingPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RepresentativeFrameNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RepresentativeFrameNumber Field

Glossary Item Box

Representative Frame Number.

Syntax

public int RepresentativeFrameNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReprojectionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReprojectionMethod Field

Glossary Item Box

Reprojection Method.

Syntax

public int ReprojectionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestAttributesSequence Field

Glossary Item Box

Request Attributes Sequence.

Syntax

public int RequestAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedContrastAgent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedContrastAgent Field

Glossary Item Box

Requested Contrast Agent.

Syntax

public int RequestedContrastAgent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedDecimateCropBehavior Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedDecimateCropBehavior Field

Glossary Item Box

Requested Decimate/Crop Behavior.

Syntax

public int RequestedDecimateCropBehavior

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedImageSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedImageSize Field

Glossary Item Box

Requested Image Size.

Syntax

public int RequestedImageSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedImageSizeFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedImageSizeFlag Field

Glossary Item Box

Requested Image Size Flag.

Syntax

public int RequestedImageSizeFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedMediaApplicationProfile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedMediaApplicationProfile Field

Glossary Item Box

Requested Media Application Profile.

Syntax

public int RequestedMediaApplicationProfile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedureCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedureCodeSequence Field

Glossary Item Box

Requested Procedure Code Sequence.

Syntax

public int RequestedProcedureCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedureComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedureComments Field

Glossary Item Box

Requested Procedure Comments.

Syntax

public int RequestedProcedureComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedureDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedureDescription Field

Glossary Item Box

Requested Procedure Description.

Syntax

public int RequestedProcedureDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedureID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedureID Field

Glossary Item Box

Requested Procedure ID.

Syntax

public int RequestedProcedureID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedureLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedureLocation Field

Glossary Item Box

Requested Procedure Location.

Syntax

public int RequestedProcedureLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedProcedurePriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedProcedurePriority Field

Glossary Item Box

Requested Procedure Priority.

Syntax

public int RequestedProcedurePriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedResolutionID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedResolutionID Field

Glossary Item Box

Requested Resolution ID.

Syntax

public int RequestedResolutionID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedSOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedSOPClassUID Field

Glossary Item Box

Requested SOP Class UID.

Syntax

public int RequestedSOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedSOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedSOPInstanceUID Field

Glossary Item Box

Requested SOP Instance UID.

Syntax

public int RequestedSOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestedSubsequentWorkitemCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestedSubsequentWorkitemCodeSequence Field

Glossary Item Box

Requested Subsequent Workitem Code Sequence.

Syntax

public int RequestedSubsequentWorkitemCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestingAE Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestingAE Field

Glossary Item Box

Requesting AE.

Syntax

public int RequestingAE

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestingPhysician Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestingPhysician Field

Glossary Item Box

Requesting Physician.

Syntax

public int RequestingPhysician

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestingPhysicianIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestingPhysicianIdentificationSequence Field

Glossary Item Box

Requesting Physician Identification Sequence.

Syntax

public int RequestingPhysicianIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestingService Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestingService Field

Glossary Item Box

Requesting Service.

Syntax

public int RequestingService

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestingServiceCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestingServiceCodeSequence Field

Glossary Item Box

Requesting Service Code Sequence.

Syntax

public int RequestingServiceCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RequestPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RequestPriority Field

Glossary Item Box

Request Priority.

Syntax

public int RequestPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RescaleIntercept Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RescaleIntercept Field

Glossary Item Box

Rescale Intercept.

Syntax

public int RescaleIntercept

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RescaleSlope Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RescaleSlope Field

Glossary Item Box

Rescale Slope.

Syntax

public int RescaleSlope

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RescaleType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RescaleType Field

Glossary Item Box

Rescale Type.

Syntax

public int RescaleType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResidualSyringeCounts Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResidualSyringeCounts Field

Glossary Item Box

Residual Syringe Counts.

Syntax

public int ResidualSyringeCounts

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResonantNucleus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResonantNucleus Field

Glossary Item Box

Resonant Nucleus.

Syntax

public int ResonantNucleus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryCyclePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryCyclePosition Field

Glossary Item Box

Respiratory Cycle Position.

Syntax

public int RespiratoryCyclePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryIntervalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryIntervalTime Field

Glossary Item Box

Respiratory Interval Time.

Syntax

public int RespiratoryIntervalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryMotionCompensationTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryMotionCompensationTechnique Field

Glossary Item Box

Respiratory Motion Compensation Technique.

Syntax

public int RespiratoryMotionCompensationTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryMotionCompensationTechniqueDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryMotionCompensationTechniqueDescription Field

Glossary Item Box

Respiratory Motion Compensation Technique Description.

Syntax

public int RespiratoryMotionCompensationTechniqueDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratorySignalSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratorySignalSource Field

Glossary Item Box

Respiratory Signal Source.

Syntax

public int RespiratorySignalSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratorySignalSourceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratorySignalSourceID Field

Glossary Item Box

Respiratory Signal Source ID.

Syntax

public int RespiratorySignalSourceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratorySynchronizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratorySynchronizationSequence Field

Glossary Item Box

Respiratory Synchronization Sequence.

Syntax

public int RespiratorySynchronizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryTriggerDelayThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryTriggerDelayThreshold Field

Glossary Item Box

Respiratory Trigger Delay Threshold.

Syntax

public int RespiratoryTriggerDelayThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RespiratoryTriggerType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RespiratoryTriggerType Field

Glossary Item Box

Respiratory Trigger Type.

Syntax

public int RespiratoryTriggerType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResponseSequenceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResponseSequenceNumber Field

Glossary Item Box

Response Sequence Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ResponseSequenceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResponsibleOrganization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResponsibleOrganization Field

Glossary Item Box

Responsible Organization.

Syntax

public int ResponsibleOrganization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResponsiblePerson Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResponsiblePerson Field

Glossary Item Box

Responsible Person.

Syntax

public int ResponsiblePerson

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResponsiblePersonRole Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResponsiblePersonRole Field

Glossary Item Box

Responsible Person Role.

Syntax

public int ResponsiblePersonRole

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResultingGeneralPurposePerformedProcedureStepsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResultingGeneralPurposePerformedProcedureStepsSequence Field

Glossary Item Box

Resulting General Purpose Performed Procedure Steps Sequence.

Syntax

public int ResultingGeneralPurposePerformedProcedureStepsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResultsComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResultsComments Field

Glossary Item Box

Results Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ResultsComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResultsDistributionListSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResultsDistributionListSequence Field

Glossary Item Box

Results Distribution List Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ResultsDistributionListSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResultsID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResultsID Field

Glossary Item Box

Results ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ResultsID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ResultsIDIssuer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ResultsIDIssuer Field

Glossary Item Box

Results ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ResultsIDIssuer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RET Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RET Field

Glossary Item Box

RET. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RET

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RetrieveAETitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RetrieveAETitle Field

Glossary Item Box

Retrieve AE Title.

Syntax

public int RetrieveAETitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RetrieveLocationUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RetrieveLocationUID Field

Glossary Item Box

Retrieve Location UID.

Syntax

public int RetrieveLocationUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RetrieveURI Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RetrieveURI Field

Glossary Item Box

Retrieve URI.

Syntax

public int RetrieveURI

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReviewDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReviewDate Field

Glossary Item Box

Review Date.

Syntax

public int ReviewDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReviewerName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReviewerName Field

Glossary Item Box

Reviewer Name.

Syntax

public int ReviewerName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ReviewTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ReviewTime Field

Glossary Item Box

Review Time.

Syntax

public int ReviewTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RevolutionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RevolutionTime Field

Glossary Item Box

Revolution Time.

Syntax

public int RevolutionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RFEchoTrainLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RFEchoTrainLength Field

Glossary Item Box

RF Echo Train Length.

Syntax

public int RFEchoTrainLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RGBLUTTransferFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RGBLUTTransferFunction Field

Glossary Item Box

RGB LUT Transfer Function.

Syntax

public int RGBLUTTransferFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RightImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RightImageSequence Field

Glossary Item Box

Right Image Sequence.

Syntax

public int RightImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RightLensSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RightLensSequence Field

Glossary Item Box

Right Lens Sequence.

Syntax

public int RightLensSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiArea Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiArea Field

Glossary Item Box

The ROI Area.

Syntax

public int RoiArea

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiContourSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiContourSequence Field

Glossary Item Box

ROI Contour Sequence.

Syntax

public int RoiContourSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiDescription Field

Glossary Item Box

ROI Description.

Syntax

public int RoiDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiDisplayColor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiDisplayColor Field

Glossary Item Box

ROI Display Color.

Syntax

public int RoiDisplayColor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ROIElementalCompositionAtomicMassFraction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ROIElementalCompositionAtomicMassFraction Field

Glossary Item Box

ROI Elemental Composition Atomic Mass Fraction.

Syntax

public int ROIElementalCompositionAtomicMassFraction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ROIElementalCompositionAtomicNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ROIElementalCompositionAtomicNumber Field

Glossary Item Box

ROI Elemental Composition Atomic Number.

Syntax

public int ROIElementalCompositionAtomicNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ROIElementalCompositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ROIElementalCompositionSequence Field

Glossary Item Box

ROI Elemental Composition Sequence.

Syntax

public int ROIElementalCompositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiGenerationAlgorithm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiGenerationAlgorithm Field

Glossary Item Box

ROI Generation Algorithm.

Syntax

public int RoiGenerationAlgorithm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiGenerationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiGenerationDescription Field

Glossary Item Box

ROI Generation Description.

Syntax

public int RoiGenerationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiInterpreter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiInterpreter Field

Glossary Item Box

ROI Interpreter.

Syntax

public int RoiInterpreter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiMean Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiMean Field

Glossary Item Box

The ROI Mean.

Syntax

public int RoiMean

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiName Field

Glossary Item Box

ROI (Region of Interest) Name.

Syntax

public int RoiName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiNumber Field

Glossary Item Box

ROI Number.

Syntax

public int RoiNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiObservationDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiObservationDescription Field

Glossary Item Box

ROI Observation Description.

Syntax

public int RoiObservationDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiObservationLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiObservationLabel Field

Glossary Item Box

ROI Observation Label.

Syntax

public int RoiObservationLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ROIPhysicalPropertiesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ROIPhysicalPropertiesSequence Field

Glossary Item Box

ROI Physical Properties Sequence.

Syntax

public int ROIPhysicalPropertiesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiPhysicalProperty Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiPhysicalProperty Field

Glossary Item Box

ROI Physical Property.

Syntax

public int RoiPhysicalProperty

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiPhysicalPropertyValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiPhysicalPropertyValue Field

Glossary Item Box

ROI Physical Property Value.

Syntax

public int RoiPhysicalPropertyValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiStandardDeviation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiStandardDeviation Field

Glossary Item Box

ROI Standard Deviation.

Syntax

public int RoiStandardDeviation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RoiVolume Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RoiVolume Field

Glossary Item Box

ROI Volume.

Syntax

public int RoiVolume

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RotationDirection Field

Glossary Item Box

Rotation Direction.

Syntax

public int RotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RotationInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RotationInformationSequence Field

Glossary Item Box

Rotation Information Sequence.

Syntax

public int RotationInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RotationOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RotationOffset Field

Glossary Item Box

Rotation Offset.

Syntax

public int RotationOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RotationOfScannedFilm Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RotationOfScannedFilm Field

Glossary Item Box

Rotation of Scanned Film.

Syntax

public int RotationOfScannedFilm

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RotationVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RotationVector Field

Glossary Item Box

Rotation Vector.

Syntax

public int RotationVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RouteOfAdmissions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RouteOfAdmissions Field

Glossary Item Box

Route of Admissions.

Syntax

public int RouteOfAdmissions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RowOverlap Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RowOverlap Field

Glossary Item Box

Row Overlap. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RowOverlap

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Rows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Rows Field

Glossary Item Box

Rows. Height of the DICOM image.

Syntax

public int Rows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RowsForNthOrderCoefficients Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RowsForNthOrderCoefficients Field

Glossary Item Box

Rows For Nth Order Coefficients. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RowsForNthOrderCoefficients

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RRIntervalTimeNominal Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RRIntervalTimeNominal Field

Glossary Item Box

R - R Interval Time Nominal.

Syntax

public int RRIntervalTimeNominal

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RrIntervalVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RrIntervalVector Field

Glossary Item Box

R-R Interval Vector.

Syntax

public int RrIntervalVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtBeamLimitingDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtBeamLimitingDeviceType Field

Glossary Item Box

RT Beam Limiting Device Type.

Syntax

public int RtBeamLimitingDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtDoseRoiSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtDoseRoiSequence Field

Glossary Item Box

RT Dose ROI Sequence.

Syntax

public int RtDoseRoiSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImageDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImageDescription Field

Glossary Item Box

RT Image Description.

Syntax

public int RtImageDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImageLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImageLabel Field

Glossary Item Box

RT Image Label.

Syntax

public int RtImageLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImageName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImageName Field

Glossary Item Box

RT Image Name.

Syntax

public int RtImageName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImageOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImageOrientation Field

Glossary Item Box

RT Image Orientation.

Syntax

public int RtImageOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImagePlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImagePlane Field

Glossary Item Box

RT Image Plane.

Syntax

public int RtImagePlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImagePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImagePosition Field

Glossary Item Box

RT Image Position.

Syntax

public int RtImagePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtImageSid Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtImageSid Field

Glossary Item Box

RT Image SID.

Syntax

public int RtImageSid

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanDate Field

Glossary Item Box

RT Plan Date.

Syntax

public int RtPlanDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanDescription Field

Glossary Item Box

RT Plan Description.

Syntax

public int RtPlanDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanGeometry Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanGeometry Field

Glossary Item Box

RT Plan Geometry.

Syntax

public int RtPlanGeometry

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanLabel Field

Glossary Item Box

RT Plan Label.

Syntax

public int RtPlanLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanName Field

Glossary Item Box

RT Plan Name.

Syntax

public int RtPlanName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanRelationship Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanRelationship Field

Glossary Item Box

RT Plan Relationship.

Syntax

public int RtPlanRelationship

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtPlanTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtPlanTime Field

Glossary Item Box

RT Plan Time.

Syntax

public int RtPlanTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtReferencedSeriesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtReferencedSeriesSequence Field

Glossary Item Box

RT Referenced Series Sequence.

Syntax

public int RtReferencedSeriesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtReferencedStudySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtReferencedStudySequence Field

Glossary Item Box

RT Referenced Study Sequence.

Syntax

public int RtReferencedStudySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtRelatedRoiSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtRelatedRoiSequence Field

Glossary Item Box

RT Related ROI Sequence.

Syntax

public int RtRelatedRoiSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtRoiIdentificationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtRoiIdentificationCodeSequence Field

Glossary Item Box

RT ROI Identification Code Sequence.

Syntax

public int RtRoiIdentificationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtRoiInterpretedType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtRoiInterpretedType Field

Glossary Item Box

RT ROI Interpreted Type.

Syntax

public int RtRoiInterpretedType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtRoiObservationsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtRoiObservationsSequence Field

Glossary Item Box

RT ROI Observations Sequence.

Syntax

public int RtRoiObservationsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RtRoiRelationship Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RtRoiRelationship Field

Glossary Item Box

RT ROI Relationship.

Syntax

public int RtRoiRelationship

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RunLengthTriplet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RunLengthTriplet Field

Glossary Item Box

Run Length Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int RunLengthTriplet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RWavePointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RWavePointer Field

Glossary Item Box

R Wave Pointer.

Syntax

public int RWavePointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

RWaveTimeVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : RWaveTimeVector Field

Glossary Item Box

R Wave Time Vector.

Syntax

public int RWaveTimeVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SafePositionExitDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SafePositionExitDate Field

Glossary Item Box

Safe Position Exit Date.

Syntax

public int SafePositionExitDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SafePositionExitTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SafePositionExitTime Field

Glossary Item Box

Safe Position Exit Time.

Syntax

public int SafePositionExitTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SafePositionReturnDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SafePositionReturnDate Field

Glossary Item Box

Safe Position Return Date.

Syntax

public int SafePositionReturnDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SafePositionReturnTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SafePositionReturnTime Field

Glossary Item Box

Safe Position Return Time.

Syntax

public int SafePositionReturnTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SampleRate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SampleRate Field

Glossary Item Box

Sample Rate. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SampleRate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SamplesPerPixel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SamplesPerPixel Field

Glossary Item Box

Samples per Pixel.

Syntax

public int SamplesPerPixel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SamplesperPixelUsed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SamplesperPixelUsed Field

Glossary Item Box

Samples per Pixel Used.

Syntax

public int SamplesperPixelUsed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SamplingFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SamplingFrequency Field

Glossary Item Box

Sampling Frequency.

Syntax

public int SamplingFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Sar Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Sar Field

Glossary Item Box

SAR (specific absorption rate).

Syntax

public int Sar

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SaturationRecovery Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SaturationRecovery Field

Glossary Item Box

Saturation Recovery.

Syntax

public int SaturationRecovery

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanArc Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanArc Field

Glossary Item Box

Scan Arc value.

Syntax

public int ScanArc

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanLength Field

Glossary Item Box

Scan Length.

Syntax

public int ScanLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanMode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanMode Field

Glossary Item Box

Scan Mode.

Syntax

public int ScanMode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanningSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanningSequence Field

Glossary Item Box

Scanning Sequence.

Syntax

public int ScanningSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanningSpotSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanningSpotSize Field

Glossary Item Box

Scanning Spot Size.

Syntax

public int ScanningSpotSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanOptions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanOptions Field

Glossary Item Box

Scan Options.

Syntax

public int ScanOptions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanSpotMetersetsDelivered Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanSpotMetersetsDelivered Field

Glossary Item Box

Scan Spot Metersets Delivered.

Syntax

public int ScanSpotMetersetsDelivered

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanSpotMetersetWeights Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanSpotMetersetWeights Field

Glossary Item Box

Scan Spot Meterset Weights.

Syntax

public int ScanSpotMetersetWeights

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanSpotPositionMap Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanSpotPositionMap Field

Glossary Item Box

Scan Spot Position Map.

Syntax

public int ScanSpotPositionMap

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanSpotTuneID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanSpotTuneID Field

Glossary Item Box

Scan Spot Tune ID.

Syntax

public int ScanSpotTuneID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScanVelocity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScanVelocity Field

Glossary Item Box

Scan Velocity.

Syntax

public int ScanVelocity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScatterCorrected Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScatterCorrected Field

Glossary Item Box

Scatter Corrected.

Syntax

public int ScatterCorrected

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScatterCorrectionMethod Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScatterCorrectionMethod Field

Glossary Item Box

Scatter Correction Method.

Syntax

public int ScatterCorrectionMethod

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScatterFractionFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScatterFractionFactor Field

Glossary Item Box

Scatter Fraction Factor.

Syntax

public int ScatterFractionFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledAdmissionDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledAdmissionDate Field

Glossary Item Box

Scheduled Admission Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledAdmissionDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledAdmissionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledAdmissionTime Field

Glossary Item Box

Scheduled Admission Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledAdmissionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledDischargeDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledDischargeDate Field

Glossary Item Box

Scheduled Discharge Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledDischargeDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledDischargeTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledDischargeTime Field

Glossary Item Box

Scheduled Discharge Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledDischargeTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledHumanPerformersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledHumanPerformersSequence Field

Glossary Item Box

Scheduled Human Performers Sequence.

Syntax

public int ScheduledHumanPerformersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledPatientInstitutionResidence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledPatientInstitutionResidence Field

Glossary Item Box

Scheduled Patient Institution Residence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledPatientInstitutionResidence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledPerformingPhysicianIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledPerformingPhysicianIdentificationSequence Field

Glossary Item Box

Scheduled Performing Physician Identification Sequence.

Syntax

public int ScheduledPerformingPhysicianIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledPerformingPhysiciansName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledPerformingPhysiciansName Field

Glossary Item Box

Scheduled Performing Physician's Name.

Syntax

public int ScheduledPerformingPhysiciansName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepDescription Field

Glossary Item Box

Scheduled Procedure Step Description.

Syntax

public int ScheduledProcedureStepDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepEndDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepEndDate Field

Glossary Item Box

Scheduled Procedure Step End Date.

Syntax

public int ScheduledProcedureStepEndDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepEndTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepEndTime Field

Glossary Item Box

Scheduled Procedure Step End Time.

Syntax

public int ScheduledProcedureStepEndTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepID Field

Glossary Item Box

Scheduled Procedure Step ID.

Syntax

public int ScheduledProcedureStepID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepLocation Field

Glossary Item Box

Scheduled Procedure Step Location.

Syntax

public int ScheduledProcedureStepLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepModificationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepModificationDateTime Field

Glossary Item Box

Scheduled Procedure Step Modification Date Time.

Syntax

public int ScheduledProcedureStepModificationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepPriority Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepPriority Field

Glossary Item Box

Scheduled Procedure Step Priority.

Syntax

public int ScheduledProcedureStepPriority

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepSequence Field

Glossary Item Box

Scheduled Procedure Step Sequence.

Syntax

public int ScheduledProcedureStepSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepStartDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepStartDate Field

Glossary Item Box

Scheduled Procedure Step Start Date.

Syntax

public int ScheduledProcedureStepStartDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepStartDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepStartDateTime Field

Glossary Item Box

Scheduled Procedure Step Start Date Time.

Syntax

public int ScheduledProcedureStepStartDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepStartTime Field

Glossary Item Box

Scheduled Procedure Step Start Time.

Syntax

public int ScheduledProcedureStepStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcedureStepStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcedureStepStatus Field

Glossary Item Box

Scheduled Procedure Step Status.

Syntax

public int ScheduledProcedureStepStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcessingApplicationsCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcessingApplicationsCodeSequence Field

Glossary Item Box

Scheduled Processing Applications Code Sequence.

Syntax

public int ScheduledProcessingApplicationsCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProcessingParametersSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProcessingParametersSequence Field

Glossary Item Box

Scheduled Processing Parameters Sequence.

Syntax

public int ScheduledProcessingParametersSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledProtocolCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledProtocolCodeSequence Field

Glossary Item Box

Scheduled Protocol Code Sequence.

Syntax

public int ScheduledProtocolCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledSpecimenSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledSpecimenSequence Field

Glossary Item Box

Scheduled Specimen Sequence.

Syntax

public int ScheduledSpecimenSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStationAeTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStationAeTitle Field

Glossary Item Box

Scheduled Station AE Title.

Syntax

public int ScheduledStationAeTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStationClassCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStationClassCodeSequence Field

Glossary Item Box

Scheduled Station Class Code Sequence.

Syntax

public int ScheduledStationClassCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStationGeographicLocationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStationGeographicLocationCodeSequence Field

Glossary Item Box

Scheduled Station Geographic Location Code Sequence.

Syntax

public int ScheduledStationGeographicLocationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStationName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStationName Field

Glossary Item Box

Scheduled Station Name.

Syntax

public int ScheduledStationName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStationNameCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStationNameCodeSequence Field

Glossary Item Box

Scheduled Station Name Code Sequence.

Syntax

public int ScheduledStationNameCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStepAttributesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStepAttributesSequence Field

Glossary Item Box

Scheduled Step Attributes Sequence.

Syntax

public int ScheduledStepAttributesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyLocation Field

Glossary Item Box

Scheduled Study Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyLocationAeTitles Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyLocationAeTitles Field

Glossary Item Box

Scheduled Study Location AE Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyLocationAeTitles

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyStartDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyStartDate Field

Glossary Item Box

Scheduled Study Start Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyStartDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyStartTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyStartTime Field

Glossary Item Box

Scheduled Study Start Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyStartTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyStopDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyStopDate Field

Glossary Item Box

Scheduled Study Stop Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyStopDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledStudyStopTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledStudyStopTime Field

Glossary Item Box

Scheduled Study Stop Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ScheduledStudyStopTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScheduledWorkitemCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScheduledWorkitemCodeSequence Field

Glossary Item Box

Scheduled Workitem Code Sequence.

Syntax

public int ScheduledWorkitemCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SCPStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SCPStatus Field

Glossary Item Box

SCP Status.

Syntax

public int SCPStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScreenMinimumColorBitDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScreenMinimumColorBitDepth Field

Glossary Item Box

Screen Minimum Color Bit Depth.

Syntax

public int ScreenMinimumColorBitDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ScreenMinimumGrayscaleBitDepth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ScreenMinimumGrayscaleBitDepth Field

Glossary Item Box

Screen Minimum Grayscale Bit Depth.

Syntax

public int ScreenMinimumGrayscaleBitDepth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCaptureDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCaptureDeviceID Field

Glossary Item Box

Secondary Capture Device ID.

Syntax

public int SecondaryCaptureDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCaptureDeviceManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCaptureDeviceManufacturer Field

Glossary Item Box

Secondary Capture Device Manufacturer.

Syntax

public int SecondaryCaptureDeviceManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCaptureDeviceManufacturersModelName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCaptureDeviceManufacturersModelName Field

Glossary Item Box

Secondary Capture Device Manufacturer's Model Name.

Syntax

public int SecondaryCaptureDeviceManufacturersModelName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCaptureDeviceSoftwareVersions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCaptureDeviceSoftwareVersions Field

Glossary Item Box

Secondary Capture Device Software Version(s).

Syntax

public int SecondaryCaptureDeviceSoftwareVersions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCountsAccumulated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCountsAccumulated Field

Glossary Item Box

Secondary Counts Accumulated.

Syntax

public int SecondaryCountsAccumulated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryCountsType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryCountsType Field

Glossary Item Box

Secondary Counts Type.

Syntax

public int SecondaryCountsType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryPositionerIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryPositionerIncrement Field

Glossary Item Box

Secondary Positioner Increment.

Syntax

public int SecondaryPositionerIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryPositionerScanArc Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryPositionerScanArc Field

Glossary Item Box

Secondary Positioner Scan Arc.

Syntax

public int SecondaryPositionerScanArc

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SecondaryPositionerScanStartAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SecondaryPositionerScanStartAngle Field

Glossary Item Box

Secondary Positioner Scan Start Angle.

Syntax

public int SecondaryPositionerScanStartAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentAlgorithmName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentAlgorithmName Field

Glossary Item Box

Segment Algorithm Name.

Syntax

public int SegmentAlgorithmName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentAlgorithmType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentAlgorithmType Field

Glossary Item Box

Segment Algorithm Type.

Syntax

public int SegmentAlgorithmType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentationFractionalType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentationFractionalType Field

Glossary Item Box

Segmentation Fractional Type.

Syntax

public int SegmentationFractionalType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentationType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentationType Field

Glossary Item Box

Segmentation Type.

Syntax

public int SegmentationType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentDescription Field

Glossary Item Box

Segment Description.

Syntax

public int SegmentDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedBluePaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedBluePaletteColorLookupTableData Field

Glossary Item Box

Segmented Blue Palette Color Lookup Table Data.

Syntax

public int SegmentedBluePaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedGreenPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedGreenPaletteColorLookupTableData Field

Glossary Item Box

Segmented Green Palette Color Lookup Table Data.

Syntax

public int SegmentedGreenPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedKspaceTraversal Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedKspaceTraversal Field

Glossary Item Box

Segmented k-Space Traversal.

Syntax

public int SegmentedKspaceTraversal

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedPropertyCategoryCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedPropertyCategoryCodeSequence Field

Glossary Item Box

Segmented Property Category Code Sequence.

Syntax

public int SegmentedPropertyCategoryCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedPropertyTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedPropertyTypeCodeSequence Field

Glossary Item Box

Segmented Property Type Code Sequence.

Syntax

public int SegmentedPropertyTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentedRedPaletteColorLookupTableData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentedRedPaletteColorLookupTableData Field

Glossary Item Box

Segmented Red Palette Color Lookup Table Data.

Syntax

public int SegmentedRedPaletteColorLookupTableData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentIdentificationSequence Field

Glossary Item Box

Segment Identification Sequence.

Syntax

public int SegmentIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentLabel Field

Glossary Item Box

Segment Label.

Syntax

public int SegmentLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentNumber Field

Glossary Item Box

Segment Number.

Syntax

public int SegmentNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentSequence Field

Glossary Item Box

Segment Sequence.

Syntax

public int SegmentSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentSurfaceGenerationAlgorithmIdentificationSequence Field
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentSurfaceGenerationAlgorithmIdentificationSequence Field

Glossary Item Box

Segment Surface Generation Algorithm Identification Sequence.

Syntax

public int SegmentSurfaceGenerationAlgorithmIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SegmentSurfaceSourceInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SegmentSurfaceSourceInstanceSequence Field

Glossary Item Box

Segment Surface Source Instance Sequence.

Syntax

public int SegmentSurfaceSourceInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorAttribute Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorAttribute Field

Glossary Item Box

Selector Attribute.

Syntax

public int SelectorAttribute

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorAttributePrivateCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorAttributePrivateCreator Field

Glossary Item Box

Selector Attribute Private Creator.

Syntax

public int SelectorAttributePrivateCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorAttributeVR Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorAttributeVR Field

Glossary Item Box

Selector Attribute VR.

Syntax

public int SelectorAttributeVR

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorATValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorATValue Field

Glossary Item Box

Selector AT Value.

Syntax

public int SelectorATValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorCodeSequenceValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorCodeSequenceValue Field

Glossary Item Box

Selector Code Sequence Value.

Syntax

public int SelectorCodeSequenceValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorCSValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorCSValue Field

Glossary Item Box

Selector CS Value.

Syntax

public int SelectorCSValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorDSValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorDSValue Field

Glossary Item Box

Selector DS Value.

Syntax

public int SelectorDSValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorFDValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorFDValue Field

Glossary Item Box

Selector FD Value.

Syntax

public int SelectorFDValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorFLValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorFLValue Field

Glossary Item Box

Selector FL Value.

Syntax

public int SelectorFLValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorISValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorISValue Field

Glossary Item Box

Selector IS Value.

Syntax

public int SelectorISValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorLOValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorLOValue Field

Glossary Item Box

Selector LO Value.

Syntax

public int SelectorLOValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorLTValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorLTValue Field

Glossary Item Box

Selector LT Value.

Syntax

public int SelectorLTValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorPNValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorPNValue Field

Glossary Item Box

Selector PN Value.

Syntax

public int SelectorPNValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSequencePointer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSequencePointer Field

Glossary Item Box

Selector Sequence Pointer.

Syntax

public int SelectorSequencePointer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSequencePointerPrivateCreator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSequencePointerPrivateCreator Field

Glossary Item Box

Selector Sequence Pointer Private Creator.

Syntax

public int SelectorSequencePointerPrivateCreator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSHValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSHValue Field

Glossary Item Box

Selector SH Value.

Syntax

public int SelectorSHValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSLValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSLValue Field

Glossary Item Box

Selector SL Value.

Syntax

public int SelectorSLValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSSValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSSValue Field

Glossary Item Box

Selector SS Value.

Syntax

public int SelectorSSValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorSTValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorSTValue Field

Glossary Item Box

Selector ST Value.

Syntax

public int SelectorSTValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorULValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorULValue Field

Glossary Item Box

Selector UL Value.

Syntax

public int SelectorULValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorUSValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorUSValue Field

Glossary Item Box

Selector US Value.

Syntax

public int SelectorUSValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorUTValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorUTValue Field

Glossary Item Box

Selector UT Value.

Syntax

public int SelectorUTValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SelectorValueNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SelectorValueNumber Field

Glossary Item Box

Selector Value Number.

Syntax

public int SelectorValueNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SenderAeTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SenderAeTitle Field

Glossary Item Box

Initiator. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SenderAeTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Sensitivity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Sensitivity Field

Glossary Item Box

Sensitivity value.

Syntax

public int Sensitivity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SensitivityCalibrated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SensitivityCalibrated Field

Glossary Item Box

Sensitivity Calibrated.

Syntax

public int SensitivityCalibrated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SequenceDelimitationItem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SequenceDelimitationItem Field

Glossary Item Box

Sequence Delimitation Item.

Syntax

public int SequenceDelimitationItem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SequenceName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SequenceName Field

Glossary Item Box

Sequence Name.

Syntax

public int SequenceName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SequenceOfCompressedData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SequenceOfCompressedData Field

Glossary Item Box

Sequence of Compressed Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SequenceOfCompressedData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SequenceOfUltrasoundRegions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SequenceOfUltrasoundRegions Field

Glossary Item Box

Sequence of Ultrasound Regions.

Syntax

public int SequenceOfUltrasoundRegions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SequenceVariant Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SequenceVariant Field

Glossary Item Box

Sequence Variant.

Syntax

public int SequenceVariant

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesDate Field

Glossary Item Box

Series Date.

Syntax

public int SeriesDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesDescription Field

Glossary Item Box

Series Description.

Syntax

public int SeriesDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesDescriptionCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesDescriptionCodeSequence Field

Glossary Item Box

Series Description Code Sequence.

Syntax

public int SeriesDescriptionCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesInstanceUID Field

Glossary Item Box

Series Instance UID.

Syntax

public int SeriesInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesInStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesInStudy Field

Glossary Item Box

Series in Study. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SeriesInStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesNumber Field

Glossary Item Box

Series Number.

Syntax

public int SeriesNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesTime Field

Glossary Item Box

Series Time.

Syntax

public int SeriesTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SeriesType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SeriesType Field

Glossary Item Box

Series Type.

Syntax

public int SeriesType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ServiceEpisodeDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ServiceEpisodeDescription Field

Glossary Item Box

Service Episode Description.

Syntax

public int ServiceEpisodeDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ServiceEpisodeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ServiceEpisodeID Field

Glossary Item Box

Service Episode ID.

Syntax

public int ServiceEpisodeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupDeviceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupDeviceDescription Field

Glossary Item Box

Setup Device Description.

Syntax

public int SetupDeviceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupDeviceLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupDeviceLabel Field

Glossary Item Box

Setup Device Label.

Syntax

public int SetupDeviceLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupDeviceParameter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupDeviceParameter Field

Glossary Item Box

Setup Device Parameter.

Syntax

public int SetupDeviceParameter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupDeviceSequence Field

Glossary Item Box

Setup Device Sequence.

Syntax

public int SetupDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupDeviceType Field

Glossary Item Box

Setup Device Type.

Syntax

public int SetupDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupImageComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupImageComment Field

Glossary Item Box

Setup Image Comment.

Syntax

public int SetupImageComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupReferenceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupReferenceDescription Field

Glossary Item Box

Setup Reference Description.

Syntax

public int SetupReferenceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupTechnique Field

Glossary Item Box

Setup Technique.

Syntax

public int SetupTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SetupTechniqueDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SetupTechniqueDescription Field

Glossary Item Box

Setup Technique Description.

Syntax

public int SetupTechniqueDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShapeType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShapeType Field

Glossary Item Box

Shape Type.

Syntax

public int ShapeType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SharedFunctionalGroupsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SharedFunctionalGroupsSequence Field

Glossary Item Box

Shared Functional Groups Sequence.

Syntax

public int SharedFunctionalGroupsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShieldingDeviceDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShieldingDeviceDescription Field

Glossary Item Box

Shielding Device Description.

Syntax

public int ShieldingDeviceDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShieldingDeviceLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShieldingDeviceLabel Field

Glossary Item Box

Shielding Device Label.

Syntax

public int ShieldingDeviceLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShieldingDevicePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShieldingDevicePosition Field

Glossary Item Box

Shielding Device Position.

Syntax

public int ShieldingDevicePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShieldingDeviceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShieldingDeviceSequence Field

Glossary Item Box

Shielding Device Sequence.

Syntax

public int ShieldingDeviceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShieldingDeviceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShieldingDeviceType Field

Glossary Item Box

Shielding Device Type.

Syntax

public int ShieldingDeviceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShiftTableSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShiftTableSize Field

Glossary Item Box

Shift Table Size. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ShiftTableSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShiftTableTriplet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShiftTableTriplet Field

Glossary Item Box

Shift Table Triplet. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ShiftTableTriplet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShowAcquisitionTechniquesFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShowAcquisitionTechniquesFlag Field

Glossary Item Box

Show Acquisition Techniques Flag.

Syntax

public int ShowAcquisitionTechniquesFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShowGraphicAnnotationFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShowGraphicAnnotationFlag Field

Glossary Item Box

Show Graphic Annotation Flag.

Syntax

public int ShowGraphicAnnotationFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShowGrayscaleInverted Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShowGrayscaleInverted Field

Glossary Item Box

Show Grayscale Inverted.

Syntax

public int ShowGrayscaleInverted

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShowImageTrueSizeFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShowImageTrueSizeFlag Field

Glossary Item Box

Show Image True Size Flag.

Syntax

public int ShowImageTrueSizeFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShowPatientDemographicsFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShowPatientDemographicsFlag Field

Glossary Item Box

Show Patient Demographics Flag.

Syntax

public int ShowPatientDemographicsFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterLeftVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterLeftVerticalEdge Field

Glossary Item Box

Shutter Left Vertical Edge.

Syntax

public int ShutterLeftVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterLowerHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterLowerHorizontalEdge Field

Glossary Item Box

Shutter Lower Horizontal Edge.

Syntax

public int ShutterLowerHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterOverlayGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterOverlayGroup Field

Glossary Item Box

Shutter Overlay Group.

Syntax

public int ShutterOverlayGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterPresentationColorCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterPresentationColorCIELabValue Field

Glossary Item Box

Shutter Presentation Color CIELab Value.

Syntax

public int ShutterPresentationColorCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterPresentationValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterPresentationValue Field

Glossary Item Box

Shutter Presentation Value.

Syntax

public int ShutterPresentationValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterRightVerticalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterRightVerticalEdge Field

Glossary Item Box

Shutter Right Vertical Edge.

Syntax

public int ShutterRightVerticalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterShape Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterShape Field

Glossary Item Box

Shutter Shape.

Syntax

public int ShutterShape

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ShutterUpperHorizontalEdge Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ShutterUpperHorizontalEdge Field

Glossary Item Box

Shutter Upper Horizontal Edge.

Syntax

public int ShutterUpperHorizontalEdge

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SignalDomainColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SignalDomainColumns Field

Glossary Item Box

Signal Domain Columns.

Syntax

public int SignalDomainColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SignalDomainRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SignalDomainRows Field

Glossary Item Box

Signal Domain Rows.

Syntax

public int SignalDomainRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Signature Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Signature Field

Glossary Item Box

The Signature.

Syntax

public int Signature

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SimpleFrameList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SimpleFrameList Field

Glossary Item Box

Simple Frame List.

Syntax

public int SimpleFrameList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SingleCollimationWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SingleCollimationWidth Field

Glossary Item Box

Single Collimation Width.

Syntax

public int SingleCollimationWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SkipBeats Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SkipBeats Field

Glossary Item Box

Skip Beats.

Syntax

public int SkipBeats

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SkipFrameRangeFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SkipFrameRangeFlag Field

Glossary Item Box

Skip Frame Range Flag.

Syntax

public int SkipFrameRangeFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SlabOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SlabOrientation Field

Glossary Item Box

Slab Orientation.

Syntax

public int SlabOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SlabThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SlabThickness Field

Glossary Item Box

Slab Thickness.

Syntax

public int SlabThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceLocation Field

Glossary Item Box

Slice Location.

Syntax

public int SliceLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceLocationVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceLocationVector Field

Glossary Item Box

Slice Location Vector.

Syntax

public int SliceLocationVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceProgressionDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceProgressionDirection Field

Glossary Item Box

Slice Progression Direction.

Syntax

public int SliceProgressionDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceSensitivityFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceSensitivityFactor Field

Glossary Item Box

Slice Sensitivity Factor.

Syntax

public int SliceSensitivityFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceThickness Field

Glossary Item Box

Slice Thickness.

Syntax

public int SliceThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SliceVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SliceVector Field

Glossary Item Box

Slice Vector.

Syntax

public int SliceVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SlideIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SlideIdentifier Field

Glossary Item Box

Slide Identifier. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SlideIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmallestImagePixelValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmallestImagePixelValue Field

Glossary Item Box

Smallest Image Pixel Value.

Syntax

public int SmallestImagePixelValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmallestImagePixelValueInPlane Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmallestImagePixelValueInPlane Field

Glossary Item Box

Smallest Image Pixel Value in Plane. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SmallestImagePixelValueInPlane

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmallestPixelValueInSeries Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmallestPixelValueInSeries Field

Glossary Item Box

Smallest Pixel Value in Series.

Syntax

public int SmallestPixelValueInSeries

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmallestValidPixelValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmallestValidPixelValue Field

Glossary Item Box

Smallest Valid Pixel Value. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SmallestValidPixelValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmokingStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmokingStatus Field

Glossary Item Box

Smoking Status.

Syntax

public int SmokingStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SmoothingType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SmoothingType Field

Glossary Item Box

Smoothing Type.

Syntax

public int SmoothingType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SnoutID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SnoutID Field

Glossary Item Box

Snout Identifier.

Syntax

public int SnoutID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SnoutPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SnoutPosition Field

Glossary Item Box

Snout Position.

Syntax

public int SnoutPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SnoutPositionTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SnoutPositionTolerance Field

Glossary Item Box

Snout Position Tolerance.

Syntax

public int SnoutPositionTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SnoutSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SnoutSequence Field

Glossary Item Box

Snout Sequence.

Syntax

public int SnoutSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SoftcopyVOILUTSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SoftcopyVOILUTSequence Field

Glossary Item Box

Softcopy VOI LUT Sequence.

Syntax

public int SoftcopyVOILUTSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SoftTissueFocusThermalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SoftTissueFocusThermalIndex Field

Glossary Item Box

Soft Tissue-focus Thermal Index.

Syntax

public int SoftTissueFocusThermalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SoftTissueSurfaceThermalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SoftTissueSurfaceThermalIndex Field

Glossary Item Box

Soft Tissue-surface Thermal Index.

Syntax

public int SoftTissueSurfaceThermalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SoftTissueThermalIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SoftTissueThermalIndex Field

Glossary Item Box

Soft Tissue Thermal Index.

Syntax

public int SoftTissueThermalIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SoftwareVersions Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SoftwareVersions Field

Glossary Item Box

Software Version(s).

Syntax

public int SoftwareVersions

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPAuthorizationComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPAuthorizationComment Field

Glossary Item Box

SOP Authorization Comment.

Syntax

public int SOPAuthorizationComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPAuthorizationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPAuthorizationDateTime Field

Glossary Item Box

SOP Authorization Date Time.

Syntax

public int SOPAuthorizationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPClassesInStudy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPClassesInStudy Field

Glossary Item Box

SOP Classes In Study.

Syntax

public int SOPClassesInStudy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPClassesSupported Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPClassesSupported Field

Glossary Item Box

SOP Classes Supported.

Syntax

public int SOPClassesSupported

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPClassUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPClassUID Field

Glossary Item Box

SOP Class UID.

Syntax

public int SOPClassUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPInstanceStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPInstanceStatus Field

Glossary Item Box

SOP Instance Status.

Syntax

public int SOPInstanceStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPInstanceUID Field

Glossary Item Box

SOP Instance UID.

Syntax

public int SOPInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SOPInstanceUIDOfConcatenationSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SOPInstanceUIDOfConcatenationSource Field

Glossary Item Box

SOP Instance UID of Concatenation Source.

Syntax

public int SOPInstanceUIDOfConcatenationSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SortbyCategory Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SortbyCategory Field

Glossary Item Box

Sort-by Category.

Syntax

public int SortbyCategory

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SortingDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SortingDirection Field

Glossary Item Box

Sorting Direction.

Syntax

public int SortingDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SortingOperationsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SortingOperationsSequence Field

Glossary Item Box

Sorting Operations Sequence.

Syntax

public int SortingOperationsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicationEntityTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicationEntityTitle Field

Glossary Item Box

Source Application Entity Title.

Syntax

public int SourceApplicationEntityTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorID Field

Glossary Item Box

Source Applicator ID.

Syntax

public int SourceApplicatorID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorLength Field

Glossary Item Box

Source Applicator Length.

Syntax

public int SourceApplicatorLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorManufacturer Field

Glossary Item Box

Source Applicator Manufacturer.

Syntax

public int SourceApplicatorManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorName Field

Glossary Item Box

Source Applicator Name.

Syntax

public int SourceApplicatorName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorNumber Field

Glossary Item Box

Source Applicator Number.

Syntax

public int SourceApplicatorNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorStepSize Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorStepSize Field

Glossary Item Box

Source Applicator Step Size.

Syntax

public int SourceApplicatorStepSize

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorType Field

Glossary Item Box

Source Applicator Type.

Syntax

public int SourceApplicatorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorWallNominalThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorWallNominalThickness Field

Glossary Item Box

Source Applicator Wall Nominal Thickness.

Syntax

public int SourceApplicatorWallNominalThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceApplicatorWallNominalTransmission Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceApplicatorWallNominalTransmission Field

Glossary Item Box

Source Applicator Wall Nominal Transmission.

Syntax

public int SourceApplicatorWallNominalTransmission

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceAxisDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceAxisDistance Field

Glossary Item Box

Source-Axis Distance.

Syntax

public int SourceAxisDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceEncapsulationNominalThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceEncapsulationNominalThickness Field

Glossary Item Box

Source Encapsulation Nominal Thickness.

Syntax

public int SourceEncapsulationNominalThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceEncapsulationNominalTransmission Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceEncapsulationNominalTransmission Field

Glossary Item Box

Source Encapsulation Nominal Transmission.

Syntax

public int SourceEncapsulationNominalTransmission

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceFrameOfReferenceUID Field

Glossary Item Box

Source Frame of Reference UID.

Syntax

public int SourceFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceHangingProtocolSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceHangingProtocolSequence Field

Glossary Item Box

Source Hanging Protocol Sequence.

Syntax

public int SourceHangingProtocolSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceImageEvidenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceImageEvidenceSequence Field

Glossary Item Box

Source Image Evidence Sequence.

Syntax

public int SourceImageEvidenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceImageIDs Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceImageIDs Field

Glossary Item Box

Source Image IDs. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SourceImageIDs

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceImageSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceImageSequence Field

Glossary Item Box

Source Image Sequence.

Syntax

public int SourceImageSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceInstanceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceInstanceSequence Field

Glossary Item Box

Source Instance Sequence.

Syntax

public int SourceInstanceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceIsotopeHalfLife Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceIsotopeHalfLife Field

Glossary Item Box

Source Isotope Half Life.

Syntax

public int SourceIsotopeHalfLife

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceIsotopeName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceIsotopeName Field

Glossary Item Box

Source Isotope Name.

Syntax

public int SourceIsotopeName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceManufacturer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceManufacturer Field

Glossary Item Box

Source Manufacturer.

Syntax

public int SourceManufacturer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceMovementType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceMovementType Field

Glossary Item Box

Source Movement Type.

Syntax

public int SourceMovementType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceNumber Field

Glossary Item Box

Source Number.

Syntax

public int SourceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceOfPreviousValues Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceOfPreviousValues Field

Glossary Item Box

Source of Previous Values.

Syntax

public int SourceOfPreviousValues

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceSequence Field

Glossary Item Box

Source Sequence.

Syntax

public int SourceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceSerialNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceSerialNumber Field

Glossary Item Box

Source Serial Number.

Syntax

public int SourceSerialNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceStrength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceStrength Field

Glossary Item Box

Source Strength.

Syntax

public int SourceStrength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceStrengthReferenceDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceStrengthReferenceDate Field

Glossary Item Box

Source Strength Reference Date.

Syntax

public int SourceStrengthReferenceDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceStrengthReferenceTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceStrengthReferenceTime Field

Glossary Item Box

Source Strength Reference Time.

Syntax

public int SourceStrengthReferenceTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceStrengthUnits Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceStrengthUnits Field

Glossary Item Box

Source Strength Units.

Syntax

public int SourceStrengthUnits

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToBeamLimitingDeviceDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToBeamLimitingDeviceDistance Field

Glossary Item Box

Source to Beam Limiting Device Distance.

Syntax

public int SourceToBeamLimitingDeviceDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToBlockTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToBlockTrayDistance Field

Glossary Item Box

Source to Block Tray Distance.

Syntax

public int SourceToBlockTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToCompensatorDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToCompensatorDistance Field

Glossary Item Box

Source to Compensator Distance.

Syntax

public int SourceToCompensatorDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToCompensatorTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToCompensatorTrayDistance Field

Glossary Item Box

Source to Compensator Tray Distance.

Syntax

public int SourceToCompensatorTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToReferenceObjectDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToReferenceObjectDistance Field

Glossary Item Box

Source to Reference Object Distance.

Syntax

public int SourceToReferenceObjectDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToSurfaceDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToSurfaceDistance Field

Glossary Item Box

Source to Surface Distance.

Syntax

public int SourceToSurfaceDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceToWedgeTrayDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceToWedgeTrayDistance Field

Glossary Item Box

Source to Wedge Tray Distance.

Syntax

public int SourceToWedgeTrayDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceType Field

Glossary Item Box

Source Type.

Syntax

public int SourceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SourceWaveformSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SourceWaveformSequence Field

Glossary Item Box

Source Waveform Sequence.

Syntax

public int SourceWaveformSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpacingBetweenSlices Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpacingBetweenSlices Field

Glossary Item Box

Spacing Between Slices.

Syntax

public int SpacingBetweenSlices

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpatialLocationsPreserved Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpatialLocationsPreserved Field

Glossary Item Box

Spatial Locations Preserved.

Syntax

public int SpatialLocationsPreserved

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpatialPresaturation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpatialPresaturation Field

Glossary Item Box

Spatial Pre-saturation.

Syntax

public int SpatialPresaturation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpatialResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpatialResolution Field

Glossary Item Box

Spatial Resolution.

Syntax

public int SpatialResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecialNeeds Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecialNeeds Field

Glossary Item Box

Special Needs.

Syntax

public int SpecialNeeds

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecificAbsorptionRateDefinition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecificAbsorptionRateDefinition Field

Glossary Item Box

Specific Absorption Rate Definition.

Syntax

public int SpecificAbsorptionRateDefinition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecificAbsorptionRateSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecificAbsorptionRateSequence Field

Glossary Item Box

Specific Absorption Rate Sequence.

Syntax

public int SpecificAbsorptionRateSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecificAbsorptionRateValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecificAbsorptionRateValue Field

Glossary Item Box

Specific Absorption Rate Value.

Syntax

public int SpecificAbsorptionRateValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecificCharacterSet Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecificCharacterSet Field

Glossary Item Box

Specific Character Set.

Syntax

public int SpecificCharacterSet

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecificCharacterSetOfFilesetDescriptorFile Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecificCharacterSetOfFilesetDescriptorFile Field

Glossary Item Box

Specific Character Set of File-set Descriptor File.

Syntax

public int SpecificCharacterSetOfFilesetDescriptorFile

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedChannelTotalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedChannelTotalTime Field

Glossary Item Box

Specified Channel Total Time.

Syntax

public int SpecifiedChannelTotalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedMeterset Field

Glossary Item Box

Specified Meterset.

Syntax

public int SpecifiedMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedNumberofPulses Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedNumberofPulses Field

Glossary Item Box

Specified Number of Pulses.

Syntax

public int SpecifiedNumberofPulses

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedPrimaryMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedPrimaryMeterset Field

Glossary Item Box

Specified Primary Meterset.

Syntax

public int SpecifiedPrimaryMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedPulseRepetitionInterval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedPulseRepetitionInterval Field

Glossary Item Box

Specified Pulse Repetition Interval.

Syntax

public int SpecifiedPulseRepetitionInterval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedSecondaryMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedSecondaryMeterset Field

Glossary Item Box

Specified Secondary Meterset.

Syntax

public int SpecifiedSecondaryMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecifiedTreatmentTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecifiedTreatmentTime Field

Glossary Item Box

Specified Treatment Time.

Syntax

public int SpecifiedTreatmentTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenAccessionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenAccessionNumber Field

Glossary Item Box

Specimen Accession Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SpecimenAccessionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenDescription Field

Glossary Item Box

Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SpecimenDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenDescriptionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenDescriptionSequence Field

Glossary Item Box

Specimen Description Sequence.

Syntax

public int SpecimenDescriptionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenDescriptionSequenceTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenDescriptionSequenceTrial Field

Glossary Item Box

Specimen Description Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SpecimenDescriptionSequenceTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenDescriptionTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenDescriptionTrial Field

Glossary Item Box

Specimen Description - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SpecimenDescriptionTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenDetailedDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenDetailedDescription Field

Glossary Item Box

Specimen Detailed Description.

Syntax

public int SpecimenDetailedDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenIdentifier Field

Glossary Item Box

Specimen Identifier.

Syntax

public int SpecimenIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenLocalizationContentItemSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenLocalizationContentItemSequence Field

Glossary Item Box

Specimen Localization Content Item Sequence.

Syntax

public int SpecimenLocalizationContentItemSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenPreparationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenPreparationSequence Field

Glossary Item Box

Specimen Preparation Sequence.

Syntax

public int SpecimenPreparationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenPreparationStepContentItemSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenPreparationStepContentItemSequence Field

Glossary Item Box

Specimen Preparation Step Content Item Sequence.

Syntax

public int SpecimenPreparationStepContentItemSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenSequence Field

Glossary Item Box

Specimen Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int SpecimenSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenShortDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenShortDescription Field

Glossary Item Box

Specimen Short Description.

Syntax

public int SpecimenShortDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenTypeCodeSequence Field

Glossary Item Box

Specimen Type Code Sequence.

Syntax

public int SpecimenTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpecimenUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpecimenUID Field

Glossary Item Box

Specimen UID.

Syntax

public int SpecimenUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectrallySelectedExcitation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectrallySelectedExcitation Field

Glossary Item Box

Spectrally Selected Excitation.

Syntax

public int SpectrallySelectedExcitation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectrallySelectedSuppression Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectrallySelectedSuppression Field

Glossary Item Box

Spectrally Selected Suppression.

Syntax

public int SpectrallySelectedSuppression

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectralWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectralWidth Field

Glossary Item Box

Spectral Width.

Syntax

public int SpectralWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectroscopyAcquisitionDataColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectroscopyAcquisitionDataColumns Field

Glossary Item Box

Spectroscopy Acquisition Data Columns.

Syntax

public int SpectroscopyAcquisitionDataColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectroscopyAcquisitionOutOfPlanePhaseSteps Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectroscopyAcquisitionOutOfPlanePhaseSteps Field

Glossary Item Box

Spectroscopy Acquisition Out-of-plane Phase Steps.

Syntax

public int SpectroscopyAcquisitionOutOfPlanePhaseSteps

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectroscopyAcquisitionPhaseColumns Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectroscopyAcquisitionPhaseColumns Field

Glossary Item Box

Spectroscopy Acquisition Phase Columns.

Syntax

public int SpectroscopyAcquisitionPhaseColumns

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectroscopyAcquisitionPhaseRows Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectroscopyAcquisitionPhaseRows Field

Glossary Item Box

Spectroscopy Acquisition Phase Rows.

Syntax

public int SpectroscopyAcquisitionPhaseRows

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpectroscopyData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpectroscopyData Field

Glossary Item Box

Spectroscopy Data.

Syntax

public int SpectroscopyData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpherePower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpherePower Field

Glossary Item Box

Sphere Power.

Syntax

public int SpherePower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SphericalLensPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SphericalLensPower Field

Glossary Item Box

Spherical Lens Power.

Syntax

public int SphericalLensPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SpiralPitchFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SpiralPitchFactor Field

Glossary Item Box

Spiral Pitch Factor.

Syntax

public int SpiralPitchFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Spoiling Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Spoiling Field

Glossary Item Box

Spoiling value.

Syntax

public int Spoiling

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StackID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StackID Field

Glossary Item Box

Stack Identifier.

Syntax

public int StackID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StageCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StageCodeSequence Field

Glossary Item Box

Stage Code Sequence.

Syntax

public int StageCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StageName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StageName Field

Glossary Item Box

Stage Name.

Syntax

public int StageName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StageNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StageNumber Field

Glossary Item Box

Stage Number.

Syntax

public int StageNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartAcquisitionDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartAcquisitionDateTime Field

Glossary Item Box

Start Acquisition DateTime.

Syntax

public int StartAcquisitionDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartAngle Field

Glossary Item Box

Start Angle.

Syntax

public int StartAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartCardiacTriggerCountThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartCardiacTriggerCountThreshold Field

Glossary Item Box

Start Cardiac Trigger Count Threshold.

Syntax

public int StartCardiacTriggerCountThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartCumulativeMetersetWeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartCumulativeMetersetWeight Field

Glossary Item Box

Start Cumulative Meterset Weight.

Syntax

public int StartCumulativeMetersetWeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartDensityThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartDensityThreshold Field

Glossary Item Box

Start Density Threshold.

Syntax

public int StartDensityThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartingRespiratoryAmplitude Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartingRespiratoryAmplitude Field

Glossary Item Box

Starting Respiratory Amplitude.

Syntax

public int StartingRespiratoryAmplitude

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartingRespiratoryPhase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartingRespiratoryPhase Field

Glossary Item Box

Starting Respiratory Phase.

Syntax

public int StartingRespiratoryPhase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartMeterset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartMeterset Field

Glossary Item Box

Start Meterset.

Syntax

public int StartMeterset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartRelativeDensityDifferenceThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartRelativeDensityDifferenceThreshold Field

Glossary Item Box

Start Relative Density Difference Threshold.

Syntax

public int StartRelativeDensityDifferenceThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartRespiratoryTriggerCountThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartRespiratoryTriggerCountThreshold Field

Glossary Item Box

Start Respiratory Trigger Count Threshold.

Syntax

public int StartRespiratoryTriggerCountThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StartTrim Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StartTrim Field

Glossary Item Box

Start Trim.

Syntax

public int StartTrim

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StationName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StationName Field

Glossary Item Box

Station Name.

Syntax

public int StationName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Status Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Status Field

Glossary Item Box

Operation Status.

Syntax

public int Status

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SteadyStatePulseSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SteadyStatePulseSequence Field

Glossary Item Box

Steady State Pulse Sequence.

Syntax

public int SteadyStatePulseSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SteepKeratometricAxisSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SteepKeratometricAxisSequence Field

Glossary Item Box

Steep Keratometric Axis Sequence.

Syntax

public int SteepKeratometricAxisSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SteeringAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SteeringAngle Field

Glossary Item Box

Steering Angle.

Syntax

public int SteeringAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoBaselineAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoBaselineAngle Field

Glossary Item Box

Stereo Baseline Angle.

Syntax

public int StereoBaselineAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoBaselineDisplacement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoBaselineDisplacement Field

Glossary Item Box

Stereo Baseline Displacement.

Syntax

public int StereoBaselineDisplacement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoHorizontalPixelOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoHorizontalPixelOffset Field

Glossary Item Box

Stereo Horizontal Pixel Offset.

Syntax

public int StereoHorizontalPixelOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoPairsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoPairsSequence Field

Glossary Item Box

Stereo Pairs Sequence.

Syntax

public int StereoPairsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoRotation Field

Glossary Item Box

Stereo Rotation.

Syntax

public int StereoRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StereoVerticalPixelOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StereoVerticalPixelOffset Field

Glossary Item Box

Stereo Vertical Pixel Offset.

Syntax

public int StereoVerticalPixelOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StopTrim Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StopTrim Field

Glossary Item Box

Stop Trim.

Syntax

public int StopTrim

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StorageMediaFilesetID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StorageMediaFilesetID Field

Glossary Item Box

Storage Media File-set ID.

Syntax

public int StorageMediaFilesetID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StorageMediaFilesetUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StorageMediaFilesetUID Field

Glossary Item Box

Storage Media File-set UID.

Syntax

public int StorageMediaFilesetUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructuredDisplayBackgroundCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructuredDisplayBackgroundCIELabValue Field

Glossary Item Box

Structured Display Background CIELab Value.

Syntax

public int StructuredDisplayBackgroundCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructuredDisplayImageBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructuredDisplayImageBoxSequence Field

Glossary Item Box

Structured Display Image Box Sequence.

Syntax

public int StructuredDisplayImageBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructuredDisplayTextBoxSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructuredDisplayTextBoxSequence Field

Glossary Item Box

Structured Display Text Box Sequence.

Syntax

public int StructuredDisplayTextBoxSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetDate Field

Glossary Item Box

Structure Set Date.

Syntax

public int StructureSetDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetDescription Field

Glossary Item Box

Structure Set Description.

Syntax

public int StructureSetDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetLabel Field

Glossary Item Box

Structure Set Label.

Syntax

public int StructureSetLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetName Field

Glossary Item Box

Structure Set Name.

Syntax

public int StructureSetName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetRoiSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetRoiSequence Field

Glossary Item Box

Structure Set ROI Sequence.

Syntax

public int StructureSetRoiSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StructureSetTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StructureSetTime Field

Glossary Item Box

Structure Set Time.

Syntax

public int StructureSetTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudiesContainingOtherReferencedInstancesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudiesContainingOtherReferencedInstancesSequence Field

Glossary Item Box

Studies Containing Other Referenced Instances Sequence.

Syntax

public int StudiesContainingOtherReferencedInstancesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyArrivalDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyArrivalDate Field

Glossary Item Box

Study Arrival Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyArrivalDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyArrivalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyArrivalTime Field

Glossary Item Box

Study Arrival Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyArrivalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyComments Field

Glossary Item Box

Study Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyCompletionDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyCompletionDate Field

Glossary Item Box

Study Completion Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyCompletionDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyCompletionTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyCompletionTime Field

Glossary Item Box

Study Completion Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyCompletionTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyComponentStatusID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyComponentStatusID Field

Glossary Item Box

Study Component Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyComponentStatusID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyDate Field

Glossary Item Box

Study Date.

Syntax

public int StudyDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyDescription Field

Glossary Item Box

Study Description.

Syntax

public int StudyDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyID Field

Glossary Item Box

Study Identifier.

Syntax

public int StudyID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyIDIssuer Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyIDIssuer Field

Glossary Item Box

Study ID Issuer. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyIDIssuer

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyInstanceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyInstanceUID Field

Glossary Item Box

Study Instance UID.

Syntax

public int StudyInstanceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyPriorityID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyPriorityID Field

Glossary Item Box

Study Priority ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyPriorityID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyReadDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyReadDate Field

Glossary Item Box

Study Read Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyReadDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyReadTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyReadTime Field

Glossary Item Box

Study Read Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyReadTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyStatusID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyStatusID Field

Glossary Item Box

Study Status ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyStatusID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyTime Field

Glossary Item Box

Study Time.

Syntax

public int StudyTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyVerifiedDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyVerifiedDate Field

Glossary Item Box

Study Verified Date. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyVerifiedDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

StudyVerifiedTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : StudyVerifiedTime Field

Glossary Item Box

Study Verified Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int StudyVerifiedTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubjectiveRefractionLeftEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubjectiveRefractionLeftEyeSequence Field

Glossary Item Box

Subjective Refraction Left Eye Sequence.

Syntax

public int SubjectiveRefractionLeftEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubjectiveRefractionRightEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubjectiveRefractionRightEyeSequence Field

Glossary Item Box

Subjective Refraction Right Eye Sequence.

Syntax

public int SubjectiveRefractionRightEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubscriptionListStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubscriptionListStatus Field

Glossary Item Box

Subscription List Status.

Syntax

public int SubscriptionListStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubstanceAdministrationApproval Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubstanceAdministrationApproval Field

Glossary Item Box

Substance Administration Approval.

Syntax

public int SubstanceAdministrationApproval

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubstanceAdministrationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubstanceAdministrationDateTime Field

Glossary Item Box

Substance Administration DateTime.

Syntax

public int SubstanceAdministrationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubstanceAdministrationDeviceID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubstanceAdministrationDeviceID Field

Glossary Item Box

Substance Administration Device ID.

Syntax

public int SubstanceAdministrationDeviceID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubstanceAdministrationNotes Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubstanceAdministrationNotes Field

Glossary Item Box

Substance Administration Notes.

Syntax

public int SubstanceAdministrationNotes

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubstanceAdministrationParameterSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubstanceAdministrationParameterSequence Field

Glossary Item Box

Substance Administration Parameter Sequence.

Syntax

public int SubstanceAdministrationParameterSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SubtractionItemID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SubtractionItemID Field

Glossary Item Box

Subtraction Item ID.

Syntax

public int SubtractionItemID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SupportedImageDisplayFormatsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SupportedImageDisplayFormatsSequence Field

Glossary Item Box

Supported Image Display Formats Sequence.

Syntax

public int SupportedImageDisplayFormatsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceComments Field

Glossary Item Box

Surface Comments.

Syntax

public int SurfaceComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceCount Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceCount Field

Glossary Item Box

Surface Count.

Syntax

public int SurfaceCount

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceEntryPoint Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceEntryPoint Field

Glossary Item Box

Surface Entry Point.

Syntax

public int SurfaceEntryPoint

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceMeshPrimitivesSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceMeshPrimitivesSequence Field

Glossary Item Box

Surface Mesh Primitives Sequence.

Syntax

public int SurfaceMeshPrimitivesSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceNumber Field

Glossary Item Box

Surface Number.

Syntax

public int SurfaceNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfacePointsNormalsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfacePointsNormalsSequence Field

Glossary Item Box

Surface Points Normals Sequence.

Syntax

public int SurfacePointsNormalsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfacePointsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfacePointsSequence Field

Glossary Item Box

Surface Points Sequence.

Syntax

public int SurfacePointsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceProcessing Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceProcessing Field

Glossary Item Box

Surface Processing.

Syntax

public int SurfaceProcessing

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceProcessingAlgorithmIdentificationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceProcessingAlgorithmIdentificationSequence Field

Glossary Item Box

Surface Processing Algorithm Identification Sequence.

Syntax

public int SurfaceProcessingAlgorithmIdentificationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceProcessingDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceProcessingDescription Field

Glossary Item Box

Surface Processing Description.

Syntax

public int SurfaceProcessingDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceProcessingRatio Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceProcessingRatio Field

Glossary Item Box

Surface Processing Ratio.

Syntax

public int SurfaceProcessingRatio

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SurfaceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SurfaceSequence Field

Glossary Item Box

Surface Sequence.

Syntax

public int SurfaceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SynchronizationChannel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SynchronizationChannel Field

Glossary Item Box

Synchronization Channel.

Syntax

public int SynchronizationChannel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SynchronizationFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SynchronizationFrameOfReferenceUID Field

Glossary Item Box

Synchronization Frame of Reference UID.

Syntax

public int SynchronizationFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SynchronizationTrigger Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SynchronizationTrigger Field

Glossary Item Box

Synchronization Trigger.

Syntax

public int SynchronizationTrigger

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SynchronizedImageBoxList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SynchronizedImageBoxList Field

Glossary Item Box

Synchronized Image Box List.

Syntax

public int SynchronizedImageBoxList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SynchronizedScrollingSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SynchronizedScrollingSequence Field

Glossary Item Box

Synchronized Scrolling Sequence.

Syntax

public int SynchronizedScrollingSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

SyringeCounts Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : SyringeCounts Field

Glossary Item Box

Syringe Counts.

Syntax

public int SyringeCounts

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

T2Preparation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : T2Preparation Field

Glossary Item Box

T2 Preparation.

Syntax

public int T2Preparation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableAngle Field

Glossary Item Box

Table Angle.

Syntax

public int TableAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableCradleTiltAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableCradleTiltAngle Field

Glossary Item Box

Table Cradle Tilt Angle.

Syntax

public int TableCradleTiltAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableFeedperRotation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableFeedperRotation Field

Glossary Item Box

Table Feed per Rotation.

Syntax

public int TableFeedperRotation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableFrameOfReferenceUID Field

Glossary Item Box

Table Frame of Reference UID.

Syntax

public int TableFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableHeadTiltAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableHeadTiltAngle Field

Glossary Item Box

Table Head Tilt Angle.

Syntax

public int TableHeadTiltAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableHeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableHeight Field

Glossary Item Box

Table Height.

Syntax

public int TableHeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableHorizontalRotationAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableHorizontalRotationAngle Field

Glossary Item Box

Table Horizontal Rotation Angle.

Syntax

public int TableHorizontalRotationAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableLateralIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableLateralIncrement Field

Glossary Item Box

Table Lateral Increment.

Syntax

public int TableLateralIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableLongitudinalIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableLongitudinalIncrement Field

Glossary Item Box

Table Longitudinal Increment.

Syntax

public int TableLongitudinalIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableMotion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableMotion Field

Glossary Item Box

Table Motion.

Syntax

public int TableMotion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableOfParameterValues Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableOfParameterValues Field

Glossary Item Box

Table of Parameter Values.

Syntax

public int TableOfParameterValues

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableOfPixelValues Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableOfPixelValues Field

Glossary Item Box

Table of Pixel Values.

Syntax

public int TableOfPixelValues

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableOfXBreakPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableOfXBreakPoints Field

Glossary Item Box

Table of X Break Points.

Syntax

public int TableOfXBreakPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableOfYBreakPoints Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableOfYBreakPoints Field

Glossary Item Box

Table of Y Break Points.

Syntax

public int TableOfYBreakPoints

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TablePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TablePosition Field

Glossary Item Box

Table Position.

Syntax

public int TablePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TablePositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TablePositionSequence Field

Glossary Item Box

Table Position Sequence.

Syntax

public int TablePositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableSpeed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableSpeed Field

Glossary Item Box

Table Speed.

Syntax

public int TableSpeed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopEccentricAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopEccentricAngle Field

Glossary Item Box

Table Top Eccentric Angle.

Syntax

public int TableTopEccentricAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopEccentricAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopEccentricAngleTolerance Field

Glossary Item Box

Table Top Eccentric Angle Tolerance.

Syntax

public int TableTopEccentricAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopEccentricAxisDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopEccentricAxisDistance Field

Glossary Item Box

Table Top Eccentric Axis Distance.

Syntax

public int TableTopEccentricAxisDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopEccentricRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopEccentricRotationDirection Field

Glossary Item Box

Table Top Eccentric Rotation Direction.

Syntax

public int TableTopEccentricRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLateralPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLateralPosition Field

Glossary Item Box

Table Top Lateral Position.

Syntax

public int TableTopLateralPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLateralPositionTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLateralPositionTolerance Field

Glossary Item Box

Table Top Lateral Position Tolerance.

Syntax

public int TableTopLateralPositionTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLateralSetupDisplacement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLateralSetupDisplacement Field

Glossary Item Box

Table Top Lateral Setup Displacement.

Syntax

public int TableTopLateralSetupDisplacement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLongitudinalPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLongitudinalPosition Field

Glossary Item Box

Table Top Longitudinal Position.

Syntax

public int TableTopLongitudinalPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLongitudinalPositionTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLongitudinalPositionTolerance Field

Glossary Item Box

Table Top Longitudinal Position Tolerance.

Syntax

public int TableTopLongitudinalPositionTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopLongitudinalSetupDisplacement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopLongitudinalSetupDisplacement Field

Glossary Item Box

Table Top Longitudinal Setup Displacement.

Syntax

public int TableTopLongitudinalSetupDisplacement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopPitchAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopPitchAngle Field

Glossary Item Box

Table Top Pitch Angle.

Syntax

public int TableTopPitchAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopPitchAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopPitchAngleTolerance Field

Glossary Item Box

Table Top Pitch Angle Tolerance.

Syntax

public int TableTopPitchAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopPitchRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopPitchRotationDirection Field

Glossary Item Box

Table Top Pitch Rotation Direction.

Syntax

public int TableTopPitchRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopRollAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopRollAngle Field

Glossary Item Box

Table Top Roll Angle.

Syntax

public int TableTopRollAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopRollAngleTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopRollAngleTolerance Field

Glossary Item Box

Table Top Roll Angle Tolerance.

Syntax

public int TableTopRollAngleTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopRollRotationDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopRollRotationDirection Field

Glossary Item Box

Table Top Roll Rotation Direction.

Syntax

public int TableTopRollRotationDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopVerticalPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopVerticalPosition Field

Glossary Item Box

Table Top Vertical Position.

Syntax

public int TableTopVerticalPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopVerticalPositionTolerance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopVerticalPositionTolerance Field

Glossary Item Box

Table Top Vertical Position Tolerance.

Syntax

public int TableTopVerticalPositionTolerance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTopVerticalSetupDisplacement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTopVerticalSetupDisplacement Field

Glossary Item Box

Table Top Vertical Setup Displacement.

Syntax

public int TableTopVerticalSetupDisplacement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableTraverse Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableTraverse Field

Glossary Item Box

Table Traverse.

Syntax

public int TableTraverse

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableType Field

Glossary Item Box

Table Type.

Syntax

public int TableType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableVerticalIncrement Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableVerticalIncrement Field

Glossary Item Box

Table Vertical Increment.

Syntax

public int TableVerticalIncrement

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableXPositiontoIsocenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableXPositiontoIsocenter Field

Glossary Item Box

Table X Position to Isocenter.

Syntax

public int TableXPositiontoIsocenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableYPositiontoIsocenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableYPositiontoIsocenter Field

Glossary Item Box

Table Y Position to Isocenter.

Syntax

public int TableYPositiontoIsocenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TableZPositiontoIsocenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TableZPositiontoIsocenter Field

Glossary Item Box

Table Z Position to Isocenter.

Syntax

public int TableZPositiontoIsocenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TagAngleFirstAxis Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TagAngleFirstAxis Field

Glossary Item Box

Tag Angle First Axis.

Syntax

public int TagAngleFirstAxis

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TagAngleSecondAxis Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TagAngleSecondAxis Field

Glossary Item Box

Tag Angle Second Axis.

Syntax

public int TagAngleSecondAxis

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Tagging Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Tagging Field

Glossary Item Box

Tagging value.

Syntax

public int Tagging

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TaggingDelay Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TaggingDelay Field

Glossary Item Box

Tagging Delay.

Syntax

public int TaggingDelay

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TagSpacingFirstDimension Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TagSpacingFirstDimension Field

Glossary Item Box

Tag Spacing First Dimension.

Syntax

public int TagSpacingFirstDimension

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TagSpacingSecondDimension Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TagSpacingSecondDimension Field

Glossary Item Box

Tag Spacing Second Dimension.

Syntax

public int TagSpacingSecondDimension

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TagThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TagThickness Field

Glossary Item Box

Tag Thickness.

Syntax

public int TagThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TargetMaximumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TargetMaximumDose Field

Glossary Item Box

Target Maximum Dose.

Syntax

public int TargetMaximumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TargetMinimumDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TargetMinimumDose Field

Glossary Item Box

Target Minimum Dose.

Syntax

public int TargetMinimumDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TargetPrescriptionDose Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TargetPrescriptionDose Field

Glossary Item Box

Target Prescription Dose.

Syntax

public int TargetPrescriptionDose

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TargetUnderdoseVolumeFraction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TargetUnderdoseVolumeFraction Field

Glossary Item Box

Target Underdose Volume Fraction.

Syntax

public int TargetUnderdoseVolumeFraction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TelephoneNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TelephoneNumber Field

Glossary Item Box

Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TelephoneNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TelephoneNumberTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TelephoneNumberTrial Field

Glossary Item Box

Telephone Number - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TelephoneNumberTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateExtensionCreatorUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateExtensionCreatorUID Field

Glossary Item Box

Template Extension Creator UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TemplateExtensionCreatorUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateExtensionFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateExtensionFlag Field

Glossary Item Box

Template Extension Flag. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TemplateExtensionFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateExtensionOrganizationUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateExtensionOrganizationUID Field

Glossary Item Box

Template Extension Organization UID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TemplateExtensionOrganizationUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateIdentifier Field

Glossary Item Box

Template Identifier.

Syntax

public int TemplateIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateLocalVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateLocalVersion Field

Glossary Item Box

Template Local Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TemplateLocalVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateName Field

Glossary Item Box

Template Name.

Syntax

public int TemplateName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateNumber Field

Glossary Item Box

Template Number.

Syntax

public int TemplateNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateType Field

Glossary Item Box

Template Type.

Syntax

public int TemplateType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemplateVersion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemplateVersion Field

Glossary Item Box

Template Version. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TemplateVersion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalPositionIdentifier Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalPositionIdentifier Field

Glossary Item Box

Temporal Position Identifier.

Syntax

public int TemporalPositionIdentifier

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalPositionIndex Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalPositionIndex Field

Glossary Item Box

Temporal Position Index.

Syntax

public int TemporalPositionIndex

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalPositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalPositionSequence Field

Glossary Item Box

Temporal Position Sequence.

Syntax

public int TemporalPositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalPositionTimeOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalPositionTimeOffset Field

Glossary Item Box

Temporal Position Time Offset.

Syntax

public int TemporalPositionTimeOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalRangeType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalRangeType Field

Glossary Item Box

Temporal Range Type.

Syntax

public int TemporalRangeType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TemporalResolution Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TemporalResolution Field

Glossary Item Box

Temporal Resolution.

Syntax

public int TemporalResolution

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminalType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminalType Field

Glossary Item Box

Terminal Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TerminalType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationCardiacTriggerCountThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationCardiacTriggerCountThreshold Field

Glossary Item Box

Termination Cardiac Trigger Count Threshold.

Syntax

public int TerminationCardiacTriggerCountThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationCountsThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationCountsThreshold Field

Glossary Item Box

Termination Counts Threshold.

Syntax

public int TerminationCountsThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationDensityThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationDensityThreshold Field

Glossary Item Box

Termination Density Threshold.

Syntax

public int TerminationDensityThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationRelativeDensityThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationRelativeDensityThreshold Field

Glossary Item Box

Termination Relative Density Threshold.

Syntax

public int TerminationRelativeDensityThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationRespiratoryTriggerCountThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationRespiratoryTriggerCountThreshold Field

Glossary Item Box

Termination Respiratory Trigger Count Threshold.

Syntax

public int TerminationRespiratoryTriggerCountThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TerminationTimeThreshold Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TerminationTimeThreshold Field

Glossary Item Box

Termination Time Threshold.

Syntax

public int TerminationTimeThreshold

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TextComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TextComments Field

Glossary Item Box

Text Comments. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TextComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TextFormatID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TextFormatID Field

Glossary Item Box

Text Format ID. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TextFormatID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TextObjectSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TextObjectSequence Field

Glossary Item Box

Text Object Sequence.

Syntax

public int TextObjectSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TextString Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TextString Field

Glossary Item Box

Text String.

Syntax

public int TextString

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TextValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TextValue Field

Glossary Item Box

Text Value.

Syntax

public int TextValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TherapyDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TherapyDescription Field

Glossary Item Box

Therapy Description. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TherapyDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TherapyType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TherapyType Field

Glossary Item Box

Therapy Type. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TherapyType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ThresholdDensity Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ThresholdDensity Field

Glossary Item Box

Threshold Density. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ThresholdDensity

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TidOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TidOffset Field

Glossary Item Box

TID Offset.

Syntax

public int TidOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Time Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Time Field

Glossary Item Box

Time value.

Syntax

public int Time

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeBasedImageSetsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeBasedImageSetsSequence Field

Glossary Item Box

Time Based Image Sets Sequence.

Syntax

public int TimeBasedImageSetsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeDistributionProtocol Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeDistributionProtocol Field

Glossary Item Box

Time Distribution Protocol.

Syntax

public int TimeDistributionProtocol

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeDomainFiltering Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeDomainFiltering Field

Glossary Item Box

Time Domain Filtering.

Syntax

public int TimeDomainFiltering

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeOfFlightContrast Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeOfFlightContrast Field

Glossary Item Box

Time of Flight Contrast.

Syntax

public int TimeOfFlightContrast

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeOfFlightInformationUsed Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeOfFlightInformationUsed Field

Glossary Item Box

Time of Flight Information Used.

Syntax

public int TimeOfFlightInformationUsed

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeOfLastCalibration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeOfLastCalibration Field

Glossary Item Box

Time of Last Calibration.

Syntax

public int TimeOfLastCalibration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeOfLastDetectorCalibration Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeOfLastDetectorCalibration Field

Glossary Item Box

Time of Last Detector Calibration.

Syntax

public int TimeOfLastDetectorCalibration

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeOfSecondaryCapture Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeOfSecondaryCapture Field

Glossary Item Box

Time of Secondary Capture.

Syntax

public int TimeOfSecondaryCapture

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeRange Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeRange Field

Glossary Item Box

Time Range.

Syntax

public int TimeRange

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSliceVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSliceVector Field

Glossary Item Box

Time Slice Vector.

Syntax

public int TimeSliceVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSlotInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSlotInformationSequence Field

Glossary Item Box

Time Slot Information Sequence.

Syntax

public int TimeSlotInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSlotNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSlotNumber Field

Glossary Item Box

Time Slot Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TimeSlotNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSlotTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSlotTime Field

Glossary Item Box

Time Slot Time.

Syntax

public int TimeSlotTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSlotVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSlotVector Field

Glossary Item Box

Time Slot Vector.

Syntax

public int TimeSlotVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimeSource Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimeSource Field

Glossary Item Box

Time Source.

Syntax

public int TimeSource

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TimezoneOffsetFromUTC Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TimezoneOffsetFromUTC Field

Glossary Item Box

Timezone Offset From UTC.

Syntax

public int TimezoneOffsetFromUTC

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TissueHeterogeneityCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TissueHeterogeneityCorrection Field

Glossary Item Box

Tissue Heterogeneity Correction.

Syntax

public int TissueHeterogeneityCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TmLinePositionX0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TmLinePositionX0 Field

Glossary Item Box

TM-Line Position X0.

Syntax

public int TmLinePositionX0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TMLinePositionX0Retired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TMLinePositionX0Retired Field

Glossary Item Box

TM-Line Position X0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TMLinePositionX0Retired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TmLinePositionX1 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TmLinePositionX1 Field

Glossary Item Box

TM-Line Position X1.

Syntax

public int TmLinePositionX1

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TMLinePositionX1Retired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TMLinePositionX1Retired Field

Glossary Item Box

TM-Line Position X1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TMLinePositionX1Retired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TmLinePositionY0 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TmLinePositionY0 Field

Glossary Item Box

TM-Line Position Y0.

Syntax

public int TmLinePositionY0

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TMLinePositionY0Retired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TMLinePositionY0Retired Field

Glossary Item Box

TM-Line Position Y0 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TMLinePositionY0Retired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TmLinePositionY1 Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TmLinePositionY1 Field

Glossary Item Box

TM-Line Position Y1.

Syntax

public int TmLinePositionY1

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TMLinePositionY1Retired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TMLinePositionY1Retired Field

Glossary Item Box

TM-Line Position Y1 (Retired). This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TMLinePositionY1Retired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ToleranceTableLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ToleranceTableLabel Field

Glossary Item Box

Tolerance Table Label.

Syntax

public int ToleranceTableLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ToleranceTableNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ToleranceTableNumber Field

Glossary Item Box

Tolerance Table Number.

Syntax

public int ToleranceTableNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ToleranceTableSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ToleranceTableSequence Field

Glossary Item Box

Tolerance Table Sequence.

Syntax

public int ToleranceTableSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TomoAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TomoAngle Field

Glossary Item Box

Tomo Angle.

Syntax

public int TomoAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TomoClass Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TomoClass Field

Glossary Item Box

Tomo Class.

Syntax

public int TomoClass

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TomoLayerHeight Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TomoLayerHeight Field

Glossary Item Box

Tomo Layer Height.

Syntax

public int TomoLayerHeight

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TomoTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TomoTime Field

Glossary Item Box

Tomo Time.

Syntax

public int TomoTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TomoType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TomoType Field

Glossary Item Box

Tomo Type.

Syntax

public int TomoType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TopicAuthor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TopicAuthor Field

Glossary Item Box

Topic Author. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TopicAuthor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TopicKeywords Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TopicKeywords Field

Glossary Item Box

Topic Keywords. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TopicKeywords

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TopicSubject Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TopicSubject Field

Glossary Item Box

Topic Subject. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TopicSubject

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TopicTitle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TopicTitle Field

Glossary Item Box

Topic Title. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TopicTitle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalBlockTrayFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalBlockTrayFactor Field

Glossary Item Box

Total Block Tray Factor.

Syntax

public int TotalBlockTrayFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalBlockTrayWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalBlockTrayWaterEquivalentThickness Field

Glossary Item Box

Total Block Tray Water-Equivalent Thickness.

Syntax

public int TotalBlockTrayWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalCollimationWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalCollimationWidth Field

Glossary Item Box

Total Collimation Width.

Syntax

public int TotalCollimationWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalCompensatorTrayFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalCompensatorTrayFactor Field

Glossary Item Box

Total Compensator Tray Factor.

Syntax

public int TotalCompensatorTrayFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalCompensatorTrayWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalCompensatorTrayWaterEquivalentThickness Field

Glossary Item Box

Total Compensator Tray Water-Equivalent Thickness.

Syntax

public int TotalCompensatorTrayWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalGain Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalGain Field

Glossary Item Box

Total Gain. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TotalGain

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalNumberofExposures Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalNumberofExposures Field

Glossary Item Box

Total Number of Exposures.

Syntax

public int TotalNumberofExposures

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalNumberofPiecesofMediaCreated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalNumberofPiecesofMediaCreated Field

Glossary Item Box

Total Number of Pieces of Media Created.

Syntax

public int TotalNumberofPiecesofMediaCreated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalReferenceAirKerma Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalReferenceAirKerma Field

Glossary Item Box

Total Reference Air Kerma.

Syntax

public int TotalReferenceAirKerma

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalTime Field

Glossary Item Box

Total Time. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TotalTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalTimeofFluoroscopy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalTimeofFluoroscopy Field

Glossary Item Box

Total Time of Fluoroscopy.

Syntax

public int TotalTimeofFluoroscopy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TotalWedgeTrayWaterEquivalentThickness Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TotalWedgeTrayWaterEquivalentThickness Field

Glossary Item Box

Total Wedge Tray Water-Equivalent Thickness.

Syntax

public int TotalWedgeTrayWaterEquivalentThickness

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransactionUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransactionUID Field

Glossary Item Box

Transaction UID.

Syntax

public int TransactionUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerApplicationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerApplicationCodeSequence Field

Glossary Item Box

Transducer Application Code Sequence.

Syntax

public int TransducerApplicationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerBeamSteeringCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerBeamSteeringCodeSequence Field

Glossary Item Box

Transducer Beam Steering Code Sequence.

Syntax

public int TransducerBeamSteeringCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerData Field

Glossary Item Box

Transducer Data.

Syntax

public int TransducerData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerFrequency Field

Glossary Item Box

Transducer Frequency.

Syntax

public int TransducerFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerGeometryCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerGeometryCodeSequence Field

Glossary Item Box

Transducer Geometry Code Sequence.

Syntax

public int TransducerGeometryCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerOrientation Field

Glossary Item Box

Transducer Orientation.

Syntax

public int TransducerOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerOrientationModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerOrientationModifierSequence Field

Glossary Item Box

Transducer Orientation Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransducerOrientationModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerOrientationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerOrientationSequence Field

Glossary Item Box

Transducer Orientation Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransducerOrientationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerPosition Field

Glossary Item Box

Transducer Position.

Syntax

public int TransducerPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerPositionModifierSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerPositionModifierSequence Field

Glossary Item Box

Transducer Position Modifier Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransducerPositionModifierSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerPositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerPositionSequence Field

Glossary Item Box

Transducer Position Sequence. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransducerPositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerScanPatternCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerScanPatternCodeSequence Field

Glossary Item Box

Transducer Scan Pattern Code Sequence.

Syntax

public int TransducerScanPatternCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransducerType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransducerType Field

Glossary Item Box

Transducer Type.

Syntax

public int TransducerType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransferSyntaxUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransferSyntaxUID Field

Glossary Item Box

Transfer Syntax UID. This tells whether the DICOM file uses big or little endian format, which compression is used, if any, and whether the file uses Implicit or Explicit Value Representation syntax.

Syntax

public int TransferSyntaxUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransferTubeLength Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransferTubeLength Field

Glossary Item Box

Transfer Tube Length.

Syntax

public int TransferTubeLength

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransferTubeNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransferTubeNumber Field

Glossary Item Box

Transfer Tube Number.

Syntax

public int TransferTubeNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransformLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransformLabel Field

Glossary Item Box

Transform Label. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransformLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransformVersionNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransformVersionNumber Field

Glossary Item Box

Transform Version Number. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TransformVersionNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransmitCoilManufacturerName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransmitCoilManufacturerName Field

Glossary Item Box

Transmit Coil Manufacturer Name.

Syntax

public int TransmitCoilManufacturerName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransmitCoilName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransmitCoilName Field

Glossary Item Box

Transmit Coil Name.

Syntax

public int TransmitCoilName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransmitCoilType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransmitCoilType Field

Glossary Item Box

Transmit Coil Type.

Syntax

public int TransmitCoilType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransmitterFrequency Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransmitterFrequency Field

Glossary Item Box

Transmitter Frequency.

Syntax

public int TransmitterFrequency

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransverseDetectorSeparation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransverseDetectorSeparation Field

Glossary Item Box

Transverse Detector Separation.

Syntax

public int TransverseDetectorSeparation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TransverseMash Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TransverseMash Field

Glossary Item Box

Transverse Mash.

Syntax

public int TransverseMash

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentControlPointDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentControlPointDate Field

Glossary Item Box

Treatment Control Point Date.

Syntax

public int TreatmentControlPointDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentControlPointTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentControlPointTime Field

Glossary Item Box

Treatment Control Point Time.

Syntax

public int TreatmentControlPointTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentDate Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentDate Field

Glossary Item Box

Treatment Date.

Syntax

public int TreatmentDate

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentDeliveryType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentDeliveryType Field

Glossary Item Box

Treatment Delivery Type.

Syntax

public int TreatmentDeliveryType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentMachineName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentMachineName Field

Glossary Item Box

Treatment Machine Name.

Syntax

public int TreatmentMachineName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentMachineSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentMachineSequence Field

Glossary Item Box

Treatment Machine Sequence.

Syntax

public int TreatmentMachineSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentProtocols Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentProtocols Field

Glossary Item Box

Treatment Protocols.

Syntax

public int TreatmentProtocols

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSessionApplicationSetupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSessionApplicationSetupSequence Field

Glossary Item Box

Treatment Session Application Setup Sequence.

Syntax

public int TreatmentSessionApplicationSetupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSessionBeamSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSessionBeamSequence Field

Glossary Item Box

Treatment Session Beam Sequence.

Syntax

public int TreatmentSessionBeamSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSessionIonBeamSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSessionIonBeamSequence Field

Glossary Item Box

Treatment Session Ion Beam Sequence.

Syntax

public int TreatmentSessionIonBeamSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSites Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSites Field

Glossary Item Box

Treatment Sites.

Syntax

public int TreatmentSites

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentStatusComment Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentStatusComment Field

Glossary Item Box

Treatment Status Comment.

Syntax

public int TreatmentStatusComment

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSummaryCalculatedDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSummaryCalculatedDoseReferenceSequence Field

Glossary Item Box

Treatment Summary Calculated Dose Reference Sequence.

Syntax

public int TreatmentSummaryCalculatedDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentSummaryMeasuredDoseReferenceSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentSummaryMeasuredDoseReferenceSequence Field

Glossary Item Box

Treatment Summary Measured Dose Reference Sequence.

Syntax

public int TreatmentSummaryMeasuredDoseReferenceSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentTerminationCode Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentTerminationCode Field

Glossary Item Box

Treatment Termination Code.

Syntax

public int TreatmentTerminationCode

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentTerminationStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentTerminationStatus Field

Glossary Item Box

Treatment Termination Status.

Syntax

public int TreatmentTerminationStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentTime Field

Glossary Item Box

Treatment Time.

Syntax

public int TreatmentTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TreatmentVerificationStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TreatmentVerificationStatus Field

Glossary Item Box

Treatment Verification Status.

Syntax

public int TreatmentVerificationStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriangleFanSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriangleFanSequence Field

Glossary Item Box

Triangle Fan Sequence.

Syntax

public int TriangleFanSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TrianglePointIndexList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TrianglePointIndexList Field

Glossary Item Box

Triangle Point Index List.

Syntax

public int TrianglePointIndexList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriangleStripSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriangleStripSequence Field

Glossary Item Box

Triangle Strip Sequence.

Syntax

public int TriangleStripSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerSamplePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerSamplePosition Field

Glossary Item Box

Trigger Sample Position.

Syntax

public int TriggerSamplePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerSourceorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerSourceorType Field

Glossary Item Box

Trigger Source or Type.

Syntax

public int TriggerSourceorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerTime Field

Glossary Item Box

Trigger Time.

Syntax

public int TriggerTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerTimeOffset Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerTimeOffset Field

Glossary Item Box

Trigger Time Offset.

Syntax

public int TriggerTimeOffset

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerVector Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerVector Field

Glossary Item Box

Trigger Vector.

Syntax

public int TriggerVector

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TriggerWindow Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TriggerWindow Field

Glossary Item Box

Trigger Window.

Syntax

public int TriggerWindow

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Trim Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Trim Field

Glossary Item Box

Trim value.

Syntax

public int Trim

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TubeAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TubeAngle Field

Glossary Item Box

Tube Angle.

Syntax

public int TubeAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TypeOfData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TypeOfData Field

Glossary Item Box

Type of Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int TypeOfData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TypeOfDetectorMotion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TypeOfDetectorMotion Field

Glossary Item Box

Type of Detector Motion.

Syntax

public int TypeOfDetectorMotion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TypeOfFilters Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TypeOfFilters Field

Glossary Item Box

Type of Filters.

Syntax

public int TypeOfFilters

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TypeOfPatientID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TypeOfPatientID Field

Glossary Item Box

Type of Patient ID.

Syntax

public int TypeOfPatientID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

TypeOfSynchronization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : TypeOfSynchronization Field

Glossary Item Box

Type of Synchronization.

Syntax

public int TypeOfSynchronization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UID Field

Glossary Item Box

UID (unique identifier).

Syntax

public int UID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UltrasoundAcquisitionGeometry Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UltrasoundAcquisitionGeometry Field

Glossary Item Box

Ultrasound Acquisition Geometry.

Syntax

public int UltrasoundAcquisitionGeometry

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UltrasoundColorDataPresent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UltrasoundColorDataPresent Field

Glossary Item Box

Ultrasound Color Data Present.

Syntax

public int UltrasoundColorDataPresent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnformattedTextValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnformattedTextValue Field

Glossary Item Box

Unformatted Text Value.

Syntax

public int UnformattedTextValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepCommunicationsURISequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepCommunicationsURISequence Field

Glossary Item Box

Unified Procedure Step Communications URI Sequence.

Syntax

public int UnifiedProcedureStepCommunicationsURISequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepDiscontinuationReasonCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepDiscontinuationReasonCodeSequence Field

Glossary Item Box

Unified Procedure Step Discontinuation Reason Code Sequence.

Syntax

public int UnifiedProcedureStepDiscontinuationReasonCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepListStatus Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepListStatus Field

Glossary Item Box

Unified Procedure Step List Status.

Syntax

public int UnifiedProcedureStepListStatus

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepPerformedProcedureSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepPerformedProcedureSequence Field

Glossary Item Box

Unified Procedure Step Performed Procedure Sequence.

Syntax

public int UnifiedProcedureStepPerformedProcedureSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepProgress Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepProgress Field

Glossary Item Box

Unified Procedure Step Progress.

Syntax

public int UnifiedProcedureStepProgress

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepProgressDescription Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepProgressDescription Field

Glossary Item Box

Unified Procedure Step Progress Description.

Syntax

public int UnifiedProcedureStepProgressDescription

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepProgressInformationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepProgressInformationSequence Field

Glossary Item Box

Unified Procedure Step Progress Information Sequence.

Syntax

public int UnifiedProcedureStepProgressInformationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnifiedProcedureStepState Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnifiedProcedureStepState Field

Glossary Item Box

Unified Procedure Step State.

Syntax

public int UnifiedProcedureStepState

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

Units Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : Units Field

Glossary Item Box

The Units.

Syntax

public int Units

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UniversalEntityID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UniversalEntityID Field

Glossary Item Box

Universal Entity ID.

Syntax

public int UniversalEntityID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UniversalEntityIDType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UniversalEntityIDType Field

Glossary Item Box

Universal Entity ID Type.

Syntax

public int UniversalEntityIDType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UNKNOWN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UNKNOWN Field

Glossary Item Box

Tag not found in the dictionary.

Syntax

public int UNKNOWN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UnspecifiedLateralityLensSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UnspecifiedLateralityLensSequence Field

Glossary Item Box

Unspecified Laterality Lens Sequence.

Syntax

public int UnspecifiedLateralityLensSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UpperLowerPixelValues Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UpperLowerPixelValues Field

Glossary Item Box

Upper/Lower Pixel Values. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int UpperLowerPixelValues

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

UsedFiducialsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : UsedFiducialsSequence Field

Glossary Item Box

Used Fiducials Sequence.

Syntax

public int UsedFiducialsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

USImageDescriptionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : USImageDescriptionSequence Field

Glossary Item Box

US Image Description Sequence.

Syntax

public int USImageDescriptionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ValueType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ValueType Field

Glossary Item Box

Value Type.

Syntax

public int ValueType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariableCoefficientsSDDN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariableCoefficientsSDDN Field

Glossary Item Box

Variable Coefficients SDDN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VariableCoefficientsSDDN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariableCoefficientsSDHN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariableCoefficientsSDHN Field

Glossary Item Box

Variable Coefficients SDHN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VariableCoefficientsSDHN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariableCoefficientsSDVN Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariableCoefficientsSDVN Field

Glossary Item Box

Variable Coefficients SDVN. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VariableCoefficientsSDVN

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariableFlipAngleFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariableFlipAngleFlag Field

Glossary Item Box

Variable Flip Angle Flag.

Syntax

public int VariableFlipAngleFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariableNextDataGroup Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariableNextDataGroup Field

Glossary Item Box

Variable Next Data Group. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VariableNextDataGroup

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VariablePixelData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VariablePixelData Field

Glossary Item Box

Variable Pixel Data. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VariablePixelData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VectorAccuracy Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VectorAccuracy Field

Glossary Item Box

Vector Accuracy.

Syntax

public int VectorAccuracy

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VectorCoordinateData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VectorCoordinateData Field

Glossary Item Box

Vector Coordinate Data.

Syntax

public int VectorCoordinateData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VectorDimensionality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VectorDimensionality Field

Glossary Item Box

Vector Dimensionality.

Syntax

public int VectorDimensionality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VectorGridData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VectorGridData Field

Glossary Item Box

Vector Grid Data.

Syntax

public int VectorGridData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VelocityEncodingDirection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VelocityEncodingDirection Field

Glossary Item Box

Velocity Encoding Direction.

Syntax

public int VelocityEncodingDirection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VelocityEncodingMaximumValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VelocityEncodingMaximumValue Field

Glossary Item Box

Velocity Encoding Maximum Value.

Syntax

public int VelocityEncodingMaximumValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VelocityEncodingMinimumValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VelocityEncodingMinimumValue Field

Glossary Item Box

Velocity Encoding Minimum Value.

Syntax

public int VelocityEncodingMinimumValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerificationDateTime Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerificationDateTime Field

Glossary Item Box

Verification Date Time.

Syntax

public int VerificationDateTime

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerificationFlag Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerificationFlag Field

Glossary Item Box

Verification Flag.

Syntax

public int VerificationFlag

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerificationImageTiming Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerificationImageTiming Field

Glossary Item Box

Verification Image Timing.

Syntax

public int VerificationImageTiming

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerifyingObserverIdentificationCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerifyingObserverIdentificationCodeSequence Field

Glossary Item Box

Verifying Observer Identification Code Sequence.

Syntax

public int VerifyingObserverIdentificationCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerifyingObserverName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerifyingObserverName Field

Glossary Item Box

Verifying Observer Name.

Syntax

public int VerifyingObserverName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerifyingObserverSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerifyingObserverSequence Field

Glossary Item Box

Verifying Observer Sequence.

Syntax

public int VerifyingObserverSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerifyingOrganization Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerifyingOrganization Field

Glossary Item Box

Verifying Organization.

Syntax

public int VerifyingOrganization

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VertexPointIndexList Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VertexPointIndexList Field

Glossary Item Box

Vertex Point Index List.

Syntax

public int VertexPointIndexList

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticalPrismBase Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticalPrismBase Field

Glossary Item Box

Vertical Prism Base.

Syntax

public int VerticalPrismBase

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticalPrismPower Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticalPrismPower Field

Glossary Item Box

Vertical Prism Power.

Syntax

public int VerticalPrismPower

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticesOfThePolygonalCollimator Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticesOfThePolygonalCollimator Field

Glossary Item Box

Vertices of the Polygonal Collimator.

Syntax

public int VerticesOfThePolygonalCollimator

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticesOfThePolygonalExposureControlSensingRegion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticesOfThePolygonalExposureControlSensingRegion Field

Glossary Item Box

Vertices of the Polygonal Exposure Control Sensing Region.

Syntax

public int VerticesOfThePolygonalExposureControlSensingRegion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticesOfThePolygonalShutter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticesOfThePolygonalShutter Field

Glossary Item Box

Vertices of the Polygonal Shutter.

Syntax

public int VerticesOfThePolygonalShutter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VerticesOfTheRegion Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VerticesOfTheRegion Field

Glossary Item Box

Vertices of the Region.

Syntax

public int VerticesOfTheRegion

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VideoImageFormatAcquired Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VideoImageFormatAcquired Field

Glossary Item Box

Video Image Format Acquired.

Syntax

public int VideoImageFormatAcquired

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewCodeSequence Field

Glossary Item Box

View Code Sequence.

Syntax

public int ViewCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewingDistance Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewingDistance Field

Glossary Item Box

Viewing Distance.

Syntax

public int ViewingDistance

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewingDistanceType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewingDistanceType Field

Glossary Item Box

Viewing Distance Type.

Syntax

public int ViewingDistanceType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewModifierCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewModifierCodeSequence Field

Glossary Item Box

View Modifier Code Sequence.

Syntax

public int ViewModifierCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewName Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewName Field

Glossary Item Box

View Name.

Syntax

public int ViewName

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewNumber Field

Glossary Item Box

View Number.

Syntax

public int ViewNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ViewPosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ViewPosition Field

Glossary Item Box

View Position.

Syntax

public int ViewPosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VirtualSourceAxisDistances Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VirtualSourceAxisDistances Field

Glossary Item Box

Virtual Source-Axis Distances.

Syntax

public int VirtualSourceAxisDistances

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisitComments Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisitComments Field

Glossary Item Box

Visit Comments.

Syntax

public int VisitComments

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisitStatusID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisitStatusID Field

Glossary Item Box

Visit Status ID.

Syntax

public int VisitStatusID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisualAcuityBothEyesOpenSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisualAcuityBothEyesOpenSequence Field

Glossary Item Box

Visual Acuity Both Eyes Open Sequence.

Syntax

public int VisualAcuityBothEyesOpenSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisualAcuityLeftEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisualAcuityLeftEyeSequence Field

Glossary Item Box

Visual Acuity Left Eye Sequence.

Syntax

public int VisualAcuityLeftEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisualAcuityModifiers Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisualAcuityModifiers Field

Glossary Item Box

Visual Acuity Modifiers.

Syntax

public int VisualAcuityModifiers

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisualAcuityRightEyeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisualAcuityRightEyeSequence Field

Glossary Item Box

Visual Acuity Right Eye Sequence.

Syntax

public int VisualAcuityRightEyeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VisualAcuityTypeCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VisualAcuityTypeCodeSequence Field

Glossary Item Box

Visual Acuity Type Code Sequence.

Syntax

public int VisualAcuityTypeCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VitalStainCodeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VitalStainCodeSequence Field

Glossary Item Box

Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VitalStainCodeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VitalStainCodeSequenceTrial Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VitalStainCodeSequenceTrial Field

Glossary Item Box

Vital Stain Code Sequence - Trial. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int VitalStainCodeSequenceTrial

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VOILUTFunction Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VOILUTFunction Field

Glossary Item Box

VOI LUT Function.

Syntax

public int VOILUTFunction

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VOILUTSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VOILUTSequence Field

Glossary Item Box

VOI LUT Sequence.

Syntax

public int VOILUTSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VOIType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VOIType Field

Glossary Item Box

VOI (Value Of Interest) Type.

Syntax

public int VOIType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeBasedCalculationTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeBasedCalculationTechnique Field

Glossary Item Box

Volume Based Calculation Technique.

Syntax

public int VolumeBasedCalculationTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeFrameOfReferenceUID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeFrameOfReferenceUID Field

Glossary Item Box

Volume Frame of Reference UID.

Syntax

public int VolumeFrameOfReferenceUID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeLocalizationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeLocalizationSequence Field

Glossary Item Box

Volume Localization Sequence.

Syntax

public int VolumeLocalizationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeLocalizationTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeLocalizationTechnique Field

Glossary Item Box

Volume Localization Technique.

Syntax

public int VolumeLocalizationTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeToTableMappingMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeToTableMappingMatrix Field

Glossary Item Box

Volume to Table Mapping Matrix.

Syntax

public int VolumeToTableMappingMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumeToTransducerMappingMatrix Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumeToTransducerMappingMatrix Field

Glossary Item Box

Volume to Transducer Mapping Matrix.

Syntax

public int VolumeToTransducerMappingMatrix

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

VolumetricProperties Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : VolumetricProperties Field

Glossary Item Box

Volumetric Properties.

Syntax

public int VolumetricProperties

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaterReferencedPhaseCorrection Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaterReferencedPhaseCorrection Field

Glossary Item Box

Water Referenced Phase Correction.

Syntax

public int WaterReferencedPhaseCorrection

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformAnnotationSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformAnnotationSequence Field

Glossary Item Box

Waveform Annotation Sequence.

Syntax

public int WaveformAnnotationSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformBitsAllocated Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformBitsAllocated Field

Glossary Item Box

Waveform Bits Allocated.

Syntax

public int WaveformBitsAllocated

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformBitsStored Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformBitsStored Field

Glossary Item Box

Waveform Bits Stored.

Syntax

public int WaveformBitsStored

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformChannelNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformChannelNumber Field

Glossary Item Box

Waveform Channel Number.

Syntax

public int WaveformChannelNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformData Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformData Field

Glossary Item Box

Waveform Data.

Syntax

public int WaveformData

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformDataDisplayScale Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformDataDisplayScale Field

Glossary Item Box

Waveform Data Display Scale.

Syntax

public int WaveformDataDisplayScale

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformDisplayBackgroundCIELabValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformDisplayBackgroundCIELabValue Field

Glossary Item Box

Waveform Display Background CIELab Value.

Syntax

public int WaveformDisplayBackgroundCIELabValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformOriginality Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformOriginality Field

Glossary Item Box

Waveform Originality.

Syntax

public int WaveformOriginality

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformPaddingValue Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformPaddingValue Field

Glossary Item Box

Waveform Padding Value.

Syntax

public int WaveformPaddingValue

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformPresentationGroupSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformPresentationGroupSequence Field

Glossary Item Box

Waveform Presentation Group Sequence.

Syntax

public int WaveformPresentationGroupSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformSampleInterpretation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformSampleInterpretation Field

Glossary Item Box

Waveform Sample Interpretation.

Syntax

public int WaveformSampleInterpretation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformSampleValueRepresentation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformSampleValueRepresentation Field

Glossary Item Box

Waveform Sample Value Representation.

Syntax

public int WaveformSampleValueRepresentation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WaveformSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WaveformSequence Field

Glossary Item Box

Waveform Sequence.

Syntax

public int WaveformSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeAngle Field

Glossary Item Box

Wedge Angle.

Syntax

public int WedgeAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeFactor Field

Glossary Item Box

Wedge Factor.

Syntax

public int WedgeFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeID Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeID Field

Glossary Item Box

Wedge Identifier.

Syntax

public int WedgeID

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeNumber Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeNumber Field

Glossary Item Box

Wedge Number.

Syntax

public int WedgeNumber

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeOrientation Field

Glossary Item Box

Wedge Orientation.

Syntax

public int WedgeOrientation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgePosition Field

Glossary Item Box

Wedge Position.

Syntax

public int WedgePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgePositionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgePositionSequence Field

Glossary Item Box

Wedge Position Sequence.

Syntax

public int WedgePositionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeSequence Field

Glossary Item Box

Wedge Sequence.

Syntax

public int WedgeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeThinEdgePosition Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeThinEdgePosition Field

Glossary Item Box

Wedge Thin Edge Position.

Syntax

public int WedgeThinEdgePosition

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WedgeType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WedgeType Field

Glossary Item Box

Wedge Type.

Syntax

public int WedgeType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WholeBodyTechnique Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WholeBodyTechnique Field

Glossary Item Box

Whole Body Technique.

Syntax

public int WholeBodyTechnique

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WindowCenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WindowCenter Field

Glossary Item Box

Window Center.

Syntax

public int WindowCenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WindowCenterAndWidthExplanation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WindowCenterAndWidthExplanation Field

Glossary Item Box

Window Center and Width Explanation.

Syntax

public int WindowCenterAndWidthExplanation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WindowWidth Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WindowWidth Field

Glossary Item Box

Window Width.

Syntax

public int WindowWidth

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

WorklistLabel Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : WorklistLabel Field

Glossary Item Box

Worklist Label.

Syntax

public int WorklistLabel

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XA_XRFFrameCharacteristicsSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XA_XRFFrameCharacteristicsSequence Field

Glossary Item Box

XA/XRF Frame Characteristics Sequence.

Syntax

public int XA_XRFFrameCharacteristicsSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XFocusCenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XFocusCenter Field

Glossary Item Box

X Focus Center.

Syntax

public int XFocusCenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XOffsetInSlideCoordinateSystem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XOffsetInSlideCoordinateSystem Field

Glossary Item Box

X offset in Slide Coordinate System.

Syntax

public int XOffsetInSlideCoordinateSystem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRay3DAcquisitionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRay3DAcquisitionSequence Field

Glossary Item Box

X-Ray 3D Acquisition Sequence.

Syntax

public int XRay3DAcquisitionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRay3DFrameTypeSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRay3DFrameTypeSequence Field

Glossary Item Box

X-Ray 3D Frame Type Sequence.

Syntax

public int XRay3DFrameTypeSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRay3DReconstructionSequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRay3DReconstructionSequence Field

Glossary Item Box

X-Ray 3D Reconstruction Sequence.

Syntax

public int XRay3DReconstructionSequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayGeometrySequence Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayGeometrySequence Field

Glossary Item Box

X-Ray Geometry Sequence.

Syntax

public int XRayGeometrySequence

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XrayImageReceptorAngle Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XrayImageReceptorAngle Field

Glossary Item Box

X-Ray Image Receptor Angle.

Syntax

public int XrayImageReceptorAngle

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayImageReceptorTranslation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayImageReceptorTranslation Field

Glossary Item Box

X-Ray Image Receptor Translation.

Syntax

public int XRayImageReceptorTranslation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XrayOutput Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XrayOutput Field

Glossary Item Box

X-Ray Output.

Syntax

public int XrayOutput

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayReceptorType Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayReceptorType Field

Glossary Item Box

X-Ray Receptor Type.

Syntax

public int XRayReceptorType

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayTubeCurrent Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayTubeCurrent Field

Glossary Item Box

X-Ray Tube Current.

Syntax

public int XRayTubeCurrent

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayTubeCurrentInMilliA Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayTubeCurrentInMilliA Field

Glossary Item Box

X-Ray Tube Current in mA.

Syntax

public int XRayTubeCurrentInMilliA

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

XRayTubeCurrentInuA Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : XRayTubeCurrentInuA Field

Glossary Item Box

X-Ray Tube Current in micro A.

Syntax

public int XRayTubeCurrentInuA

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

YFocusCenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : YFocusCenter Field

Glossary Item Box

Y Focus Center.

Syntax

public int YFocusCenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

YOffsetInSlideCoordinateSystem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : YOffsetInSlideCoordinateSystem Field

Glossary Item Box

Y offset in Slide Coordinate System.

Syntax

public int YOffsetInSlideCoordinateSystem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZOffsetInSlideCoordinateSystem Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZOffsetInSlideCoordinateSystem Field

Glossary Item Box

Z offset in Slide Coordinate System.

Syntax

public int ZOffsetInSlideCoordinateSystem

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZonalMap Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZonalMap Field

Glossary Item Box

Zonal Map. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ZonalMap

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZonalMapFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZonalMapFormat Field

Glossary Item Box

Zonal Map Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ZonalMapFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZonalMapLocation Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZonalMapLocation Field

Glossary Item Box

Zonal Map Location. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ZonalMapLocation

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZonalMapNumberFormat Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZonalMapNumberFormat Field

Glossary Item Box

Zonal Map Number Format. This tag is marked as retired in DICOM specification. See DICOM specification for alternatives.

Syntax

public int ZonalMapNumberFormat

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZoomCenter Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZoomCenter Field

Glossary Item Box

Zoom Center.

Syntax

public int ZoomCenter

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ZoomFactor Field
com.accusoft.imagegear.formats.dicom Package > ImGearDICOMTagsIDs Class : ZoomFactor Field

Glossary Item Box

Zoom Factor.

Syntax

public int ZoomFactor

See Also

Reference

ImGearDICOMTagsIDs Class
ImGearDICOMTagsIDs Members


%%PageItemTitle%%

ImGearLinearTransform Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearLinearTransform Class

Glossary Item Box

Encapsulates coefficients for a linear floating-point one-dimensional transform.

Result of the transform is calculated as:

y = x * Slope + Intercept

This class can be used to hold DICOM Modality Rescale coefficients.

Object Model

ImGearLinearTransform ClassImGearLinearTransform ClassImGearLinearTransform Class

Syntax

public sealed class ImGearLinearTransform
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearLinearTransform

See Also

Reference

ImGearLinearTransform Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLinearTransform Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearLinearTransform Class

Glossary Item Box

The following tables list the members exposed by ImGearLinearTransform.

Public Constructors

 | Name | Description
public Constructor | ImGearLinearTransform Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | intercept | Intercept coefficient. Any double value. This property specifies Intercept coefficient of the transform. The default value is 0.0.
public Field | slope | Slope coefficient. Any double value. This value specifies Slope coefficient of the transform. The default value is 1.0.
Top

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | createIdentity | Creates an identity transform.
Top

See Also

Reference

ImGearLinearTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearLinearTransform Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class : ImGearLinearTransform Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearLinearTransform Constructor(double,double) | Initializes a new instance of the ImGearLinearTransform struct.
ImGearLinearTransform Constructor() | Default constructor.

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members


%%PageItemTitle%%

ImGearLinearTransform Constructor(double,double)
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class > ImGearLinearTransform Constructor : ImGearLinearTransform Constructor(double,double)
slope
Slope coefficient.
intercept
Intercept coefficient.

Glossary Item Box

Initializes a new instance of the ImGearLinearTransform struct.

Syntax

public ImGearLinearTransform(
   double slope,
   double intercept
)

Parameters

slope
Slope coefficient.
intercept
Intercept coefficient.

Return Value

The new instance of ImGearLinearTransform structure object.

This constructor creates new instance of ImGearLinearTransform structure object.

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members
Overload List


%%PageItemTitle%%

ImGearLinearTransform Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class > ImGearLinearTransform Constructor : ImGearLinearTransform Constructor()

Glossary Item Box

Default constructor.

Syntax

public ImGearLinearTransform()

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLinearTransform Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearLinearTransform Class

Glossary Item Box

For a list of all members of this type, see ImGearLinearTransform members.

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | createIdentity | Creates an identity transform.
Top

See Also

Reference

ImGearLinearTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearLinearTransform clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members
java.lang.Cloneable


%%PageItemTitle%%

createIdentity Method
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class : createIdentity Method

Glossary Item Box

Creates an identity transform.

Syntax

public static ImGearLinearTransform createIdentity()

Return Value

ImGearLinearTransform structure object.

This method creates an identity transform, using

Slope = 1.0;

Intercept = 0.0;

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearLinearTransform Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearLinearTransform Class

Glossary Item Box

For a list of all members of this type, see ImGearLinearTransform members.

Public Fields

 | Name | Description
public Field | intercept | Intercept coefficient. Any double value. This property specifies Intercept coefficient of the transform. The default value is 0.0.
public Field | slope | Slope coefficient. Any double value. This value specifies Slope coefficient of the transform. The default value is 1.0.
Top

See Also

Reference

ImGearLinearTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

intercept Field
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class : intercept Field

Glossary Item Box

Intercept coefficient.

Any double value.

This property specifies Intercept coefficient of the transform.

The default value is 0.0.

Syntax

public double intercept

Return Value

Any double value.

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members


%%PageItemTitle%%

slope Field
com.accusoft.imagegear.formats.dicom Package > ImGearLinearTransform Class : slope Field

Glossary Item Box

Slope coefficient.

Any double value.

This value specifies Slope coefficient of the transform.

The default value is 1.0.

Syntax

public double slope

Return Value

Any double value.

See Also

Reference

ImGearLinearTransform Class
ImGearLinearTransform Members


%%PageItemTitle%%

ImGearModalityTransform Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearModalityTransform Class

Glossary Item Box

Implements DICOM Modality transform.

Object Model

ImGearModalityTransform ClassImGearModalityTransform Class

Syntax

public class ImGearModalityTransform
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearModalityTransform

See Also

Reference

ImGearModalityTransform Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearModalityTransform Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearModalityTransform Class

Glossary Item Box

The following tables list the members exposed by ImGearModalityTransform.

Public Constructors

 | Name | Description
public Constructor | ImGearModalityTransform Constructor | Initializes a new instance of the ImGearModalityTransform class.
Top

Public Fields

 | Name | Description
public Field | lut | Specifies non-linear lookup table (LUT). The default value is null.
public Field | rescale | Specifies linear modality transform. ImGearLinearTransform structure object. This transform corresponds to RescaleSlope and RescaleIntercept DICOM tags. ImGearLinearTransform
Top

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
Top

See Also

Reference

ImGearModalityTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearModalityTransform Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearModalityTransform Class : ImGearModalityTransform Constructor

Glossary Item Box

Initializes a new instance of the ImGearModalityTransform class.

Syntax

public ImGearModalityTransform()

Return Value

The new instance of ImGearModalityTransform class object.

This constructor creates new instance of ImGearModalityTransform class object.

See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearModalityTransform Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearModalityTransform Class

Glossary Item Box

For a list of all members of this type, see ImGearModalityTransform members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
Top

See Also

Reference

ImGearModalityTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearModalityTransform Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public ImGearModalityTransform clone()

Return Value

The new instance of ImGearModalityTransform class object.

This method makes a deep copy of the ImGearModalityTransform class object.

See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearModalityTransform Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearModalityTransform Class

Glossary Item Box

For a list of all members of this type, see ImGearModalityTransform members.

Public Fields

 | Name | Description
public Field | lut | Specifies non-linear lookup table (LUT). The default value is null.
public Field | rescale | Specifies linear modality transform. ImGearLinearTransform structure object. This transform corresponds to RescaleSlope and RescaleIntercept DICOM tags. ImGearLinearTransform
Top

See Also

Reference

ImGearModalityTransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

lut Field
com.accusoft.imagegear.formats.dicom Package > ImGearModalityTransform Class : lut Field

Glossary Item Box

Specifies non-linear lookup table (LUT).

The default value is null.

Syntax

public ImGearLUT lut

See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%%

rescale Field
com.accusoft.imagegear.formats.dicom Package > ImGearModalityTransform Class : rescale Field

Glossary Item Box

Specifies linear modality transform.

ImGearLinearTransform structure object.

This transform corresponds to RescaleSlope and RescaleIntercept DICOM tags.

ImGearLinearTransform

Syntax

public ImGearLinearTransform rescale

Return Value

ImGearLinearTransform structure object.

See Also

Reference

ImGearModalityTransform Class
ImGearModalityTransform Members


%%PageItemTitle%%

ImGearPresStateOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearPresStateOptions Class

Glossary Item Box

Encapsulates options for loading and saving presentation state objects.

Object Model

ImGearPresStateOptions ClassImGearPresStateOptions Class

Syntax

public sealed class ImGearPresStateOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearPresStateOptions

See Also

Reference

ImGearPresStateOptions Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPresStateOptions Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearPresStateOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearPresStateOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearPresStateOptions Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | useAnnotations | Tells whether to use or ignore annotations. Boolean value This value tells whether to use or ignore annotations when loading or saving a presentation state object. The default value is true.
public Field | useDisplayedArea | Tells whether to use or ignore displayed area. Boolean value This value tells whether to use or ignore displayed area setting when loading or saving a presentation state object. The default value is true.
public Field | useModalityLUT | Tells whether to use or ignore Modality LUT. Boolean value This value tells whether to use or ignore Modality LUT when loading or saving a presentation state object. The default value is true.
public Field | useOrientation | Tells whether to use or ignore orientation. Boolean value This value tells whether to use or ignore orientation setting when loading or saving a presentation state object. The default value is true.
public Field | usePresentationLUT | Tells whether to use or ignore Presentation LUT. Boolean value This value tells whether to use or ignore Presentation LUT when loading or saving a presentation state object. The default value is true.
public Field | useVOILUT | Tells whether to use or ignore VOI LUT. Boolean value This value tells whether to use or ignore VOI LUT when loading or saving a presentation state object. The default value is true.
Top

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Top

See Also

Reference

ImGearPresStateOptions Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearPresStateOptions Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : ImGearPresStateOptions Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearPresStateOptions()

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPresStateOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearPresStateOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPresStateOptions members.

Public Methods

Name Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Top

See Also

Reference

ImGearPresStateOptions Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearPresStateOptions clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members
java.lang.Cloneable


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPresStateOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearPresStateOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPresStateOptions members.

Public Fields

 | Name | Description
public Field | useAnnotations | Tells whether to use or ignore annotations. Boolean value This value tells whether to use or ignore annotations when loading or saving a presentation state object. The default value is true.
public Field | useDisplayedArea | Tells whether to use or ignore displayed area. Boolean value This value tells whether to use or ignore displayed area setting when loading or saving a presentation state object. The default value is true.
public Field | useModalityLUT | Tells whether to use or ignore Modality LUT. Boolean value This value tells whether to use or ignore Modality LUT when loading or saving a presentation state object. The default value is true.
public Field | useOrientation | Tells whether to use or ignore orientation. Boolean value This value tells whether to use or ignore orientation setting when loading or saving a presentation state object. The default value is true.
public Field | usePresentationLUT | Tells whether to use or ignore Presentation LUT. Boolean value This value tells whether to use or ignore Presentation LUT when loading or saving a presentation state object. The default value is true.
public Field | useVOILUT | Tells whether to use or ignore VOI LUT. Boolean value This value tells whether to use or ignore VOI LUT when loading or saving a presentation state object. The default value is true.
Top

See Also

Reference

ImGearPresStateOptions Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

useAnnotations Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : useAnnotations Field

Glossary Item Box

Tells whether to use or ignore annotations.

Boolean value

This value tells whether to use or ignore annotations when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean useAnnotations

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

useDisplayedArea Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : useDisplayedArea Field

Glossary Item Box

Tells whether to use or ignore displayed area.

Boolean value

This value tells whether to use or ignore displayed area setting when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean useDisplayedArea

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

useModalityLUT Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : useModalityLUT Field

Glossary Item Box

Tells whether to use or ignore Modality LUT.

Boolean value

This value tells whether to use or ignore Modality LUT when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean useModalityLUT

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

useOrientation Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : useOrientation Field

Glossary Item Box

Tells whether to use or ignore orientation.

Boolean value

This value tells whether to use or ignore orientation setting when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean useOrientation

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

usePresentationLUT Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : usePresentationLUT Field

Glossary Item Box

Tells whether to use or ignore Presentation LUT.

Boolean value

This value tells whether to use or ignore Presentation LUT when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean usePresentationLUT

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

useVOILUT Field
com.accusoft.imagegear.formats.dicom Package > ImGearPresStateOptions Class : useVOILUT Field

Glossary Item Box

Tells whether to use or ignore VOI LUT.

Boolean value

This value tells whether to use or ignore VOI LUT when loading or saving a presentation state object.

The default value is true.

Syntax

public boolean useVOILUT

Return Value

Boolean value

See Also

Reference

ImGearPresStateOptions Class
ImGearPresStateOptions Members


%%PageItemTitle%%

ImGearVOITransform Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOITransform Class

Glossary Item Box

Implements DICOM Value Of Interest (VOI) transform.

Object Model

ImGearVOITransform ClassImGearVOITransform Class

Syntax

public class ImGearVOITransform
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearVOITransform

See Also

Reference

ImGearVOITransform Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearVOITransform Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOITransform Class

Glossary Item Box

The following tables list the members exposed by ImGearVOITransform.

Public Constructors

 | Name | Description
public Constructor | ImGearVOITransform Constructor | Initializes a new instance of the ImGearVOITransform class.
Top

Public Fields

 | Name | Description
public Field | lut | Specifies non-linear lookup table (LUT). The default value is null.
public Field | window | Specifies linear VOI transform. ImGearVOIWindow structure object. This corresponds to WindowCenter and WindowWidth DICOM tags. ImGearVOIWindow
Top

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
Top

See Also

Reference

ImGearVOITransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearVOITransform Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearVOITransform Class : ImGearVOITransform Constructor

Glossary Item Box

Initializes a new instance of the ImGearVOITransform class.

Syntax

public ImGearVOITransform()

See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearVOITransform Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOITransform Class

Glossary Item Box

For a list of all members of this type, see ImGearVOITransform members.

Public Methods

 | Name | Description
public Method | clone | Creates a deep copy of the object.
Top

See Also

Reference

ImGearVOITransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOITransform Class : clone Method

Glossary Item Box

Creates a deep copy of the object.

Syntax

public ImGearVOITransform clone()

Return Value

The new instance of ImGearVOITransform class object.

This method creates a deep copy of the ImGearVOITransform class object.

See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearVOITransform Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOITransform Class

Glossary Item Box

For a list of all members of this type, see ImGearVOITransform members.

Public Fields

 | Name | Description
public Field | lut | Specifies non-linear lookup table (LUT). The default value is null.
public Field | window | Specifies linear VOI transform. ImGearVOIWindow structure object. This corresponds to WindowCenter and WindowWidth DICOM tags. ImGearVOIWindow
Top

See Also

Reference

ImGearVOITransform Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

lut Field
com.accusoft.imagegear.formats.dicom Package > ImGearVOITransform Class : lut Field

Glossary Item Box

Specifies non-linear lookup table (LUT).

The default value is null.

Syntax

public ImGearLUT lut

See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%%

window Field
com.accusoft.imagegear.formats.dicom Package > ImGearVOITransform Class : window Field

Glossary Item Box

Specifies linear VOI transform.

ImGearVOIWindow structure object.

This corresponds to WindowCenter and WindowWidth DICOM tags.

ImGearVOIWindow

Syntax

public ImGearVOIWindow window

Return Value

ImGearVOIWindow structure object.

See Also

Reference

ImGearVOITransform Class
ImGearVOITransform Members


%%PageItemTitle%%

ImGearVOIWindow Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOIWindow Class

Glossary Item Box

Encapsulates linear DICOM VOI transform.

This class contains following methods: getCenter and getWidth. This transform tells which contrast range of an image shall be mapped to contrast range of the display device.

Object Model

ImGearVOIWindow ClassImGearVOIWindow ClassImGearVOIWindow ClassImGearVOIWindow ClassImGearVOIWindow ClassImGearVOIWindow Class

Syntax

public sealed class ImGearVOIWindow
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.dicom.ImGearVOIWindow

See Also

Reference

ImGearVOIWindow Members
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearVOIWindow Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOIWindow Class

Glossary Item Box

The following tables list the members exposed by ImGearVOIWindow.

Public Constructors

 | Name | Description
public Constructor | ImGearVOIWindow Constructor | Overloaded.
Top

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | createDefault | Creates default VOI Window transform.
static (Shared in Visual Basic) | createFromChannelSpec | Creates a VOI Window transform based on channel depth and signed attribute.
static (Shared in Visual Basic) | createFromMinMax | Creates Window transform from Window minimum and maximum values.
static (Shared in Visual Basic) | createFromMinMax64 | Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.
public Method getCenter Returns Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method getCenter64 Returns Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

public Method getMax Gets Window Maximum value.

Any integer number.

This method returns maximum window value as a 32-bit integer. Please use getMax64 method if you are working with 17-32 bit per channel images..

public Method getMax64 Gets Window Maximum value as 64 bit integer.

Any long integer number.

public Method getMin Gets Window Minimum value.

Any integer number.

This method returns minimum window value as a 32-bit integer. Please use getMin64 method if you are working with 17-32 bit per channel images.

public Method getMin64 Gets Window Minimum value as 64 bit integer.

Any long integer number.

public Method getWidth Returns Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 method if you are working with 17-32 bit per channel images.

The default value is 0.

public Method getWidth64 Returns Window Width value as 64 bit integer.

This value provides access to Window Width value as 64 bit integer.

The default value is 0.

public Method setCenter Sets Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method setCenter64 Sets Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

public Method setWidth Sets Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method setWidth64 Sets Window Width value as 64 bit integer.

This method provides access to Window Width value as 64 bit integer.

The default value is 0.

Top

See Also

Reference

ImGearVOIWindow Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearVOIWindow Constructor
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : ImGearVOIWindow Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearVOIWindow Constructor(int,int) | Initializes a new instance of the ImGearVOIWindow struct.
ImGearVOIWindow Constructor(long,long) | Initializes a new instance of the ImGearVOIWindow struct.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

ImGearVOIWindow Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class > ImGearVOIWindow Constructor : ImGearVOIWindow Constructor(int,int)
center
Window Center.
width
Window Width.

Glossary Item Box

Initializes a new instance of the ImGearVOIWindow struct.

Syntax

public ImGearVOIWindow(
   int center,
   int width
)

Parameters

center
Window Center.
width
Window Width.

Return Value

The new instance of ImGearVOIWindow structure object.

This constructor creates new instance of ImGearVOIWindow structure object, using the specified 32-bit values for window center and width.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members
Overload List


%%PageItemTitle%%

ImGearVOIWindow Constructor(long,long)
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class > ImGearVOIWindow Constructor : ImGearVOIWindow Constructor(long,long)
center
Window Center.
width
Window Width.

Glossary Item Box

Initializes a new instance of the ImGearVOIWindow struct.

Syntax

public ImGearVOIWindow(
   long center,
   long width
)

Parameters

center
Window Center.
width
Window Width.

Return Value

The new instance of ImGearVOIWindow structure object.

This constructor creates new instance of ImGearVOIWindow structure object, using the specified 64-bit values for window center and width.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearVOIWindow Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.dicom Package : ImGearVOIWindow Class

Glossary Item Box

For a list of all members of this type, see ImGearVOIWindow members.

Public Methods

Name | Description
public Method clone Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

static (Shared in Visual Basic) | createDefault | Creates default VOI Window transform.
static (Shared in Visual Basic) | createFromChannelSpec | Creates a VOI Window transform based on channel depth and signed attribute.
static (Shared in Visual Basic) | createFromMinMax | Creates Window transform from Window minimum and maximum values.
static (Shared in Visual Basic) | createFromMinMax64 | Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.
public Method getCenter Returns Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method getCenter64 Returns Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

public Method getMax Gets Window Maximum value.

Any integer number.

This method returns maximum window value as a 32-bit integer. Please use getMax64 method if you are working with 17-32 bit per channel images..

public Method getMax64 Gets Window Maximum value as 64 bit integer.

Any long integer number.

public Method getMin Gets Window Minimum value.

Any integer number.

This method returns minimum window value as a 32-bit integer. Please use getMin64 method if you are working with 17-32 bit per channel images.

public Method getMin64 Gets Window Minimum value as 64 bit integer.

Any long integer number.

public Method getWidth Returns Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 method if you are working with 17-32 bit per channel images.

The default value is 0.

public Method getWidth64 Returns Window Width value as 64 bit integer.

This value provides access to Window Width value as 64 bit integer.

The default value is 0.

public Method setCenter Sets Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method setCenter64 Sets Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

public Method setWidth Sets Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 value if you are working with 17-32 bit per channel images.

The default value is 0.

public Method setWidth64 Sets Window Width value as 64 bit integer.

This method provides access to Window Width value as 64 bit integer.

The default value is 0.

Top

See Also

Reference

ImGearVOIWindow Class
com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : clone Method

Glossary Item Box

Creates and returns a copy of this object. The precise meaning of "copy" may depend on the class of the object. The general intent is that, for any object x, the expression:
 x.clone() != x
will be true, and that the expression:
 x.clone().getClass() == x.getClass()
will be true, but these are not absolute requirements. While it is typically the case that:
 x.clone().equals(x)
will be true, this is not an absolute requirement.

By convention, the returned object should be obtained by calling super.clone. If a class and all of its superclasses (except Object) obey this convention, it will be the case that x.clone().getClass() == x.getClass().

By convention, the object returned by this method should be independent of this object (which is being cloned). To achieve this independence, it may be necessary to modify one or more fields of the object returned by super.clone before returning it. Typically, this means copying any mutable objects that comprise the internal "deep structure" of the object being cloned and replacing the references to these objects with references to the copies. If a class contains only primitive fields or references to immutable objects, then it is usually the case that no fields in the object returned by super.clone need to be modified.

The method clone for class Object performs a specific cloning operation. First, if the class of this object does not implement the interface Cloneable, then a CloneNotSupportedException is thrown. Note that all arrays are considered to implement the interface Cloneable. Otherwise, this method creates a new instance of the class of this object and initializes all its fields with exactly the contents of the corresponding fields of this object, as if by assignment; the contents of the fields are not themselves cloned. Thus, this method performs a "shallow copy" of this object, not a "deep copy" operation.

The class Object does not itself implement the interface Cloneable, so calling the clone method on an object whose class is Object will result in throwing an exception at run time.

Syntax

public ImGearVOIWindow clone()

Return Value

a clone of this instance.

Exceptions

Exception | Description
java.lang.CloneNotSupportedException |

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members
java.lang.Cloneable


%%PageItemTitle%%

createDefault Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : createDefault Method

Glossary Item Box

Creates default VOI Window transform.

Syntax

public static ImGearVOIWindow createDefault()

Return Value

ImGearVOIWindow structure object.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

createFromChannelSpec Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : createFromChannelSpec Method
inputDepth
Depth of an image to which the Window transform will be applied.
isSigned
Signed attribute of an image to which the Window transform will be applied.

Glossary Item Box

Creates a VOI Window transform based on channel depth and signed attribute.

Syntax

public static ImGearVOIWindow createFromChannelSpec(
   int inputDepth,
   boolean isSigned
)

Parameters

inputDepth
Depth of an image to which the Window transform will be applied.
isSigned
Signed attribute of an image to which the Window transform will be applied.

Return Value

ImGearVOIWindow structure object.

Transform is initialized according to minimum and maximum possible values of a signed or unsigned pixel.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

createFromMinMax Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : createFromMinMax Method
min
Window Minimum.
max
Window Maximum.

Glossary Item Box

Creates Window transform from Window minimum and maximum values.

Syntax

public static ImGearVOIWindow createFromMinMax(
   int min,
   int max
)

Parameters

min
Window Minimum.
max
Window Maximum.

Return Value

ImGearVOIWindow structure object.

This method creates Window transform from 32-bit integer Minimum and Maximum values. Please use createFromMinMax method if you are working with 17-32 bit per channel images.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

createFromMinMax64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : createFromMinMax64 Method
min
Window Minimum.
max
Window Maximum.

Glossary Item Box

Creates Window transform from Window minimum (64 bit) and maximum (64 bit) values.

Syntax

public static ImGearVOIWindow createFromMinMax64(
   long min,
   long max
)

Parameters

min
Window Minimum.
max
Window Maximum.

Return Value

ImGearVOIWindow structure object.

This method creates Window transform from Minimum and Maximum 64 bit values.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getCenter Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getCenter Method

Glossary Item Box

Returns Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

Syntax

public int getCenter()

Return Value

Any integer value.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getCenter64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getCenter64 Method

Glossary Item Box

Returns Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

Syntax

public long getCenter64()

Return Value

Any long integer value.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getMax Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getMax Method

Glossary Item Box

Gets Window Maximum value.

Any integer number.

This method returns maximum window value as a 32-bit integer. Please use getMax64 method if you are working with 17-32 bit per channel images..

Syntax

public int getMax()

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getMax64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getMax64 Method

Glossary Item Box

Gets Window Maximum value as 64 bit integer.

Any long integer number.

Syntax

public long getMax64()

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getMin Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getMin Method

Glossary Item Box

Gets Window Minimum value.

Any integer number.

This method returns minimum window value as a 32-bit integer. Please use getMin64 method if you are working with 17-32 bit per channel images.

Syntax

public int getMin()

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getMin64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getMin64 Method

Glossary Item Box

Gets Window Minimum value as 64 bit integer.

Any long integer number.

Syntax

public long getMin64()

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getWidth Method

Glossary Item Box

Returns Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 method if you are working with 17-32 bit per channel images.

The default value is 0.

Syntax

public int getWidth()

Return Value

Any integer number.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

getWidth64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : getWidth64 Method

Glossary Item Box

Returns Window Width value as 64 bit integer.

This value provides access to Window Width value as 64 bit integer.

The default value is 0.

Syntax

public long getWidth64()

Return Value

Any long integer number.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

setCenter Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : setCenter Method
value
Any integer value.

Glossary Item Box

Sets Window Center value.

This value provides access to Window Center value as a 32-bit integer. Please use getCenter64 value if you are working with 17-32 bit per channel images.

The default value is 0.

Syntax

public void setCenter(
   int value
)

Parameters

value
Any integer value.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

setCenter64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : setCenter64 Method
value
Any long integer value.

Glossary Item Box

Sets Window Center value as 64 bit integer.

This value provides access to Window Center value as 64 bit integer.

The default value is 0.

Syntax

public void setCenter64(
   long value
)

Parameters

value
Any long integer value.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : setWidth Method
value
Any integer number.

Glossary Item Box

Sets Window Width value.

This value provides access to Window Width value as a 32-bit integer. Please use getWidth64 value if you are working with 17-32 bit per channel images.

The default value is 0.

Syntax

public void setWidth(
   int value
)

Parameters

value
Any integer number.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

setWidth64 Method
com.accusoft.imagegear.formats.dicom Package > ImGearVOIWindow Class : setWidth64 Method
value
Any long integer number.

Glossary Item Box

Sets Window Width value as 64 bit integer.

This method provides access to Window Width value as 64 bit integer.

The default value is 0.

Syntax

public void setWidth64(
   long value
)

Parameters

value
Any long integer number.

See Also

Reference

ImGearVOIWindow Class
ImGearVOIWindow Members


%%PageItemTitle%%

ImGearDICOMPhotoInterpretations Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMPhotoInterpretations Enumeration

Glossary Item Box

Specifies DICOM Photometric Interpretations.

Members

Member | Description
ARGB | Retired in DICOM standard.
CMYK | Retired in DICOM standard.
HSV | Retired in DICOM standard.
MONOCHROME1 | Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as white.
MONOCHROME2 | Pixel data represent a single monochrome image plane. The minimum sample value is intended to be displayed as black.
PALETTE_COLOR | Pixel data describe a color image with a single sample per pixel (single image plane). The pixel value is used as an index into each of the Red, Blue, and Green Palette Color Lookup Tables.
RGB | Pixel data represent a color image described by red, green, and blue image planes.
UNKNOWN | Photometric interpretation is unknown.
YBR_FULL | Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr).
YBR_FULL_422 | The same as YBR_FULL except that the Cb and Cr values are sampled horizontally at half the Y rate and as a result there are half as many Cb and Cr values as Y values.
YBR_ICT | Irreversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.
YBR_PARTIAL_422 | The same as YBR_FULL_422 with certain limitations. See DICOM specification PS 3.3 for more detail.
YBR_RCT | Reversible Color Transformation. Pixel data represent a color image described by one luminance (Y) and two chrominance planes (Cb and Cr). Used with JPEG 2000 transfer syntax.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMPhotoInterpretations

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMPixelRepresenations Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMPixelRepresenations Enumeration

Glossary Item Box

Specifies DICOM Pixel Representations.

Members

Member | Description
COMPLEMENT_2S | Pixels are signed, encoded in 2's complement form.
UNKNOWN | Unknown pixel representation.
UNSIGNED | Pixels are unsigned.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMPixelRepresenations

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMPlanarConfigurations Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMPlanarConfigurations Enumeration

Glossary Item Box

Specifies DICOM Planar Configurations.

Members

Member | Description
PIXEL_BY_PIXEL | Pixel by pixel (interleaved by color channel. RGB, RGB, RGB).
PLANE_BY_PLANE | Plane by plane (not interleaved by color channel. RRR, GGG, BBB).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMPlanarConfigurations

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMServiceObjectPairs Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMServiceObjectPairs Enumeration

Glossary Item Box

Specifies DICOM Service Object Pair (SOP) constants.

Members

Member | Description
AMBULATORY_ECG_WAVEFORM_STORAGE | Ambulatory ECG Waveform Storage.
ARTERIAL_PULSE_WAVEFORM_STORAGE | Arterial Pulse Waveform Storage.
AUTOREFRACTION_MEASUREMENTS_STORAGE | Autorefraction Measurements Storage.
BASIC_ANNOTATION_BOX | Basic Annotation Box SOP Class.
BASIC_COLOR_IMG_BOX | Basic Color Image Box SOP Class.
BASIC_COLOR_PRINT_MGMT_META | Basic Color Print Management Meta SOP Class.
BASIC_FILM_BOX | Basic Film Box SOP Class.
BASIC_FILM_SESSION | Basic Film Session SOP Class.
BASIC_GRAY_IMG_BOX | Basic Grayscale Image Box SOP Class.
BASIC_GRAY_PRINT_MGMT_META | Basic Grayscale Print Management Meta SOP Class.
BASIC_PRINT_IMAGE_OVERLAY_BOX | Basic Print Image Overlay Box SOP Class (Retired). /*RET
BASIC_STRUCTURED_DISPLAY_STORAGE | Basic Structured Display Storage.
BASIC_STUDY_CONTENT_NOTIFICATION | Basic Study Content Notification SOP Class (Retired). /*RET
BASIC_VOICE_AUDIO_WAVEFORM_STORAGE | Basic Voice Audio Waveform Storage.
BLENDING_SOFTCOPY_PRES_STATE_STORAGE | Blending Softcopy Presentation State Storage SOP Class.
BREAST_IMAGING_RELEVANT_PATIENT_INFORMATION_QUERY | Breast Imaging Relevant Patient Information Query.
BREAST_TOMOSYNTHESIS_IMAGE_STORAGE | Breast Tomosynthesis Image Storage.
CARDIAC_ELECTROPHYSIOLOGY_WAVEFORM_STORAGE | Cardiac Electrophysiology Waveform Storage.
CARDIAC_RELEVANT_PATIENT_INFORMATION_QUERY | Cardiac Relevant Patient Information Query.
COLON_CAD_SR_STORAGE | Colon CAD SR Storage.
COLOR_PALETTE_INFORMATION_MODEL_FIND | Color Palette Information Model ï¿½ FIND.
COLOR_PALETTE_INFORMATION_MODEL_GET | Color Palette Information Model ï¿½ GET.
COLOR_PALETTE_INFORMATION_MODEL_MOVE | Color Palette Information Model ï¿½ MOVE.
COLOR_PALETTE_STORAGE | Color Palette Storage.
COLOR_SOFTCOPY_PRES_STATE_STORAGE | Color Softcopy Presentation State Storage SOP Class.
COMPOSITE_INSTANCE_RETRIEVE_WITHOUT_BULK_DATA_GET | Composite Instance Retrieve Without Bulk Data - GET.
COMPOSITE_INSTANCE_ROOT_RETRIEVE_GET | Composite Instance Root Retrieve - GET.
COMPOSITE_INSTANCE_ROOT_RETRIEVE_MOVE | Composite Instance Root Retrieve - MOVE.
CR_STORAGE | Computed Radiography Image Storage.
CT_ENHANCED_STORAGE | Enhanced CT Image Storage.
CT_STORAGE | CT Image storage.
CURVE_STORAGE | Standalone Curve Storage (Retired). /*RET
DEFORMABLE_SPATIAL_REGISTRATION_STORAGE | Deformable Spatial Registration Storage.
DICOM_APP_CONTEXT | DICOM Application Context Name.
DICOM_CONTROLLED_TERMINOLOGY | DICOM Controlled Terminology (Coding Scheme).
DICOM_UID_REGISTRY | DICOM UID Registry (DICOM UIDs as a Coding Scheme).
DIGI_INTRA_ORAL_PRES_IMG_STORAGE | Digital Intra-oral X-Ray Image Storage - For Presentation.
DIGI_INTRA_ORAL_PROC_IMG_STORAGE | Digital Intra-oral X-Ray Image Storage - For Processing.
DIGI_MAMMO_PRES_IMG_STORAGE | Digital Mammography X-Ray Image Storage - For Presentation.
DIGI_MAMMO_PROC_IMG_STORAGE | Digital Mammography X-Ray Image Storage - For Processing.
DIGI_XRAY_PRES_IMG_STORAGE | Digital X-Ray Image Storage - For Presentation.
DIGI_XRAY_PROC_IMG_STORAGE | Digital X-Ray Image Storage - For Processing.
ENCAPSULATED_CDA_STORAGE | Encapsulated CDA Storage.
ENCAPSULATED_PDF_STORAGE | Encapsulated PDF Storage.
ENHANCED_MR_COLOR_IMAGE_STORAGE | Enhanced MR Color Image Storage.
ENHANCED_PET_IMAGE_STORAGE | Enhanced PET Image Storage.
ENHANCED_US_VOLUME_STORAGE | Enhanced US Volume Storage.
ENHANCED_XRF_IMAGE_STORAGE | Enhanced XRF Image Storage.
GE_MACHINE_STORAGE | GE Machine Storage.
GE_PLAN_STORAGE | GE Plan Storage.
GEN_PERFORMED_PROC_STEP | General Purpose Performed Procedure Step.
GEN_SCHEDULED_PROC_STEP | General Purpose Scheduled Procedure Step.
GEN_WORKLIST_FIND | General Purpose Worklist Information Model - FIND.
GEN_WORKLIST_MANAGEMENT_META | General Purpose Worklist Management Meta SOP Class.
GENERAL_AUDIO_WAVEFORM_STORAGE | General Audio Waveform Storage.
GENERAL_RELEVANT_PATIENT_INFORMATION_QUERY | General Relevant Patient Information Query.
GRAY_SOFTCOPY_PRES_STATE_STORAGE | Grayscale Softcopy Presentation State Storage SOP Class.
HANGING_PROTOCOL_INFORMATION_MODEL_FIND | Hanging Protocol Information Model - FIND.
HANGING_PROTOCOL_INFORMATION_MODEL_GET | Hanging Protocol Information Model - GET.
HANGING_PROTOCOL_INFORMATION_MODEL_MOVE | Hanging Protocol Information Model - MOVE.
HANGING_PROTOCOL_STORAGE | Hanging Protocol Storage.
HARDCOPY_COLOR_STORAGE | Hardcopy Color Image Storage SOP Class (Retired). /*RET
HARDCOPY_GRAYSCALE_STORAGE | Hardcopy Grayscale Image Storage SOP Class (Retired). /*RET
HOT_IRON_COLOR_PALETTE_INSTANCE | Hot Iron Color Palette SOP Instance (Well-known).
HOT_METAL_BLUE_COLOR_PALETTE_INSTANCE | Hot Metal Blue Color Palette SOP Instance (Well-known).
IMG_OVLY_BOX | Image Overlay Box SOP Class (Retired). /*RET
INSTANCE_AVAILABILITY_NOTIFICATION | Instance Availability Notification SOP Class.
INTERP_MGMT_DET | Detached Interpretation Management SOP Class (Retired). /*RET
KERATOMETRY_MEASUREMENTS_STORAGE | Keratometry Measurements Storage.
KEY_OBJECT_SELECTION_DOCUMENT | Key Object Selection Document Storage.
LENSOMETRY_MEASUREMENTS_STORAGE | Lensometry Measurements Storage.
MACULAR_GRID_THICKNESS_AND_VOLUME_REPORT_STORAGE | Macular Grid Thickness and Volume Report Storage.
MEDIA_CREATION_MANAGEMENT_UID | Media Creation Management UID SOP Class.
MEDIA_STORAGE_DIR_STORAGE | Media Storage Directory Storage.
MOD_LUT_STORAGE | Standalone Modality LUT Storage (Retired). /*RET
MOD_PERF_PROC_STEP | Modality Performed Procedure Step SOP Class (Retired). /*RET
MOD_PERF_PROC_STEP_NOTIFY | Modality Performed Procedure Step Notification SOP Class.
MOD_PERF_PROC_STEP_RETRIEVE | Modality Performed Procedure Step Retrieve SOP Class.
MODALITY_WORKLIST_FIND | Modality Worklist Information Model - FIND.
MR_ENHANCED_IMAGE_STORAGE | Enhanced MR Image Storage.
MR_SPECTROSCOPY_STORAGE | MR Spectroscopy Storage.
MR_STORAGE | MR Image Storage.
MSICOM3_LZW_STORAGE | MsiCOM3 LZW storage.
NM_STORAGE | Nuclear Medicine Image storage.
NM_STORAGE__RET | Nuclear Medicine Image Storage (Retired). /*RET
NULL | Null class.
OPHTHALMIC_PHOTOGRAPHY_16_BIT_IMAGE_STORAGE | Ophthalmic Photography 16 Bit Image Storage.
OPHTHALMIC_PHOTOGRAPHY_8_BIT_IMAGE_STORAGE | Ophthalmic Photography 8 Bit Image Storage.
OPHTHALMIC_TOMOGRAPHY_IMAGE_STORAGE | Ophthalmic Tomography Image Storage.
OVERLAY_STORAGE | Standalone Overlay Storage (Retired). /*RET
PAT_MGMT_DET | Detached Patient Management SOP Class (Retired). /*RET
PAT_MGMT_META | Detached Patient Management Meta SOP Class (Retired). /*RET
PAT_ROOT_QR_FIND | Patient Root Query/Retrieve Information Model - FIND.
PAT_ROOT_QR_GET | Patient Root Query/Retrieve Information Model - GET.
PAT_ROOT_QR_MOVE | Patient Root Query/Retrieve Information Model - MOVE.
PAT_STUDY_ROOT_QR_FIND | Patient/Study Only Query/Retrieve Information Model - FIND (Retired). /*RET
PAT_STUDY_ROOT_QR_GET | Patient/Study Only Query/Retrieve Information Model - GET (Retired). /*RET
PAT_STUDY_ROOT_QR_MOVE | Patient/Study Only Query/Retrieve Information Model - MOVE (Retired). /*RET
PET_20_STEP_COLOR_PALETTE_INSTANCE | PET 20 Step Color Palette SOP Instance (Well-known).
PET_COLOR_PALETTE_INSTANCE | PET Color Palette SOP Instance (Well-known).
PET_CURVE_STORAGE | Standalone PET Curve Storage (Retired). /*RET
PET_STORAGE | Positron Emission Tomography Image Storage.
PRESENTATION_LUT | Presentation LUT SOP Class.
PRINT_JOB | Print Job SOP Class.
PRINT_QUEUE_INSTANCE | Print Queue SOP Instance (Well-known) (Retired). /*RET
PRINT_QUEUE_MGMT | Print Queue Management SOP Class (Retired). /*RET
PRINTER | Printer SOP Class.
PRINTER_CONFIGURATION_RETRIEVAL | Printer Configuration Retrieval SOP Class.
PRINTER_CONFIGURATION_RETRIEVAL_INSTANCE | Printer Configuration Retrieval SOP Instance (Well-known).
PRINTER_INSTANCE | Printer SOP Instance (Well-known).
PROCEDURAL_EVENT_LOGGING | Procedural Event Logging SOP Class.
PROCEDURAL_EVENT_LOGGING_INSTANCE | Procedural Event Logging SOP Instance (Well-known).
PROCEDURE_LOG | Procedure Log Storage.
PRODUCT_CHARACTERISTICS | Product Characteristics Query SOP Class.
PSEUDO_COLOR_SOFTCOPY_PRES_STATE_STORAGE | Pseudo-Color Softcopy Presentation State Storage SOP Class.
PULL_PRINT_REQUEST | Pull Print Request SOP Class (Retired). /*RET
PULL_STORED_PRINT_MGMT_META | Pull Stored Print Management Meta SOP Class (Retired). /*RET
RAW_DATA_STORAGE | RAW data storage.
REAL_WORLD_VALUE_MAPPING_STORAGE | Real World Value Mapping Storage.
REF_COLOR_PRINT_MGMT_META | Referenced Color Print Management Meta SOP class (Retired). /*RET
REF_GRAY_PRINT_MGMT_META | Referenced Grayscale Print Management Meta SOP Class (Retired). /*RET
REF_IMG_BOX | Reference Image Box SOP Class (Retired). /*RET
RESPIRATORY_WAVEFORM_STORAGE | Respiratory Waveform Storage.
RESULT_MGMT_DET | Detached Results Management SOP Class (Retired). /*RET
RESULT_MGMT_META | Detached Results Management Meta SOP Class.
RT_BEAMS_DELIVERY_INSTRUCTION_STORAGE | RT Beams Delivery Instruction Storage (Supplement 74 Frozen Draft).
RT_BEAMS_TREATMENT_RECORD_STORAGE | RT Beams Treatment Record Storage.
RT_BRACHY_TREATMENT_RECORD_STORAGE | RT Brachy Treatment Record Storage.
RT_CONVENTIONAL_MACHINE_VERIFICATION | RT Conventional Machine Verification (Supplement 74 Frozen Draft).
RT_DOSE_STORAGE | RT Dose Storage.
RT_IMG_STORAGE | RT image storage.
RT_ION_BEAMS_TREATMENT_RECORD_STORAGE | RT Ion Beams Treatment Record Storage.
RT_ION_MACHINE_VERIFICATION | RT Ion Machine Verification (Supplement 74 Frozen Draft).
RT_ION_PLAN_STORAGE | RT Ion Plan Storage.
RT_PLAN_STORAGE | RT Plan Storage.
RT_STRUCTURE_SET_STORAGE | RT Structure Set Storage.
RT_TREATMENT_RECORD_STORAGE | RT Beams Treatment Record Storage. /*ret
RT_TREATMENT_SUMMARY_RECORD_STORAGE | RT Treatment Summary Record Storage.
SC_MF_GRAYSCALE_BYTE_IMAGE_STORAGE | Multiframe Grayscale Byte Secondary Capture Image Storage.
SC_MF_GRAYSCALE_WORD_IMAGE_STORAGE | Multiframe Grayscale Word Secondary Capture Image Storage.
SC_MF_SINGLE_BIT_IMAGE_STORAGE | Multiframe Single Bit Secondary Capture Image Storage.
SC_MF_TRUE_COLOR_IMAGE_STORAGE | Multiframe True Color Secondary Capture Image Storage.
SC_STORAGE | Secondary Capture Image Storage.
SEGMENTATION_STORAGE | Segmentation Storage.
SPATIAL_FIDUCIALS_STORAGE | Spatial Fiducials Storage.
SPATIAL_REGISTRATION_STORAGE | Spatial Registration Storage.
SPECTACLE_PRESCRIPTION_REPORTS_STORAGE | Spectacle Prescription Reports Storage.
SR_AUDIO_STORAGE | Audio SR Storage - Trial (Retired). /*RET
SR_BASIC_TEXT | Basic Text SR Storage.
SR_CHEST_CAD | Chest CAD SR Storage.
SR_COMPREHENSIVE | Comprehensive SR Storage.
SR_COMPREHENSIVE_STORAGE | Comprehensive SR Storage - Trial (Retired). /*RET
SR_DETAIL_STORAGE | Detail SR Storage - Trial (Retired). /*RET
SR_ENHANCED | Enhanced SR Storage.
SR_MAMMO_CAD | Mammography CAD SR Storage.
SR_TEXT_STORAGE | Text SR Storage - Trial (Retired). /*RET
STEREOMETRIC_RELATIONSHIP_STORAGE | Stereometric Relationship Storage.
STORAGE_COMMITMENT_PULL_CLASS | Storage Commitment Pull Model SOP Class (Retired). /*RET
STORAGE_COMMITMENT_PULL_INSTANCE | Storage Commitment Pull Model SOP Instance (Well-known) (Retired). /*RET
STORAGE_COMMITMENT_PUSH_CLASS | Storage Commitment Push Model SOP Class.
STORAGE_COMMITMENT_PUSH_INSTANCE | Storage Commitment Push Model SOP Instance (Well-known).
STORAGE_SERVICE_CLASS | Storage Service Class.
STORED_PRINT_STORAGE | Stored Print Storage SOP Class (Retired). /*RET
STUDY_MGMT_COMP | Study Component Management SOP Class (Retired). /*RET
STUDY_MGMT_DET | Detached Study Management SOP Class (Retired). /*RET
STUDY_MGMT_META | Detached Study Management Meta SOP Class (Retired). /*RET
STUDY_ROOT_QR_FIND | Study Root Query/Retrieve Information Model - FIND.
STUDY_ROOT_QR_GET | Study Root Query/Retrieve Information Model - GET.
STUDY_ROOT_QR_MOVE | Study Root Query/Retrieve Information Model - MOVE.
SUBJECTIVE_REFRACTION_MEASUREMENTS_STORAGE | Subjective Refraction Measurements Storage.
SUBSTANCE_ADMINISTRATION_LOGGING | Substance Administration Logging SOP Class.
SUBSTANCE_ADMINISTRATION_LOGGING_INSTANCE | Substance Administration Logging SOP Instance (Well-known).
SUBSTANCE_APPROVAL_QUERY | Substance Approval Query SOP Class.
SURFACE_SEGMENTATION_STORAGE | Surface Segmentation Storage.
UNIFIED_PROC_STEP_EVENT | Unified Procedure Step - Event SOP Class.
UNIFIED_PROC_STEP_PULL | Unified Procedure Step - Pull SOP Class.
UNIFIED_PROC_STEP_PUSH | Unified Procedure Step - Push SOP Class.
UNIFIED_PROC_STEP_WATCH | Unified Procedure Step - Watch SOP Class.
UNIFIED_WORKLIST_PROC_STEP_INSTANCE | Unified Worklist and Procedure Step SOP Instance (Well-known).
UNIFIED_WORKLIST_PROC_STEP_SERVICE_CLASS | Unified Worklist and Procedure Step Service class.
US_STORAGE | Ultrasound Image Storage.
US_STORAGE__RET | Ultrasound Image Storage (Retired). /*RET
USMF_STORAGE | Ultrasound Multi-frame Image Storage.
USMF_STORAGE__RET | Ultrasound Multi-frame Image Storage (Retired). /*RET
VERIFICATION | Verification SOP Class.
VIDEO_ENDOSCOPIC_IMAGE_STORAGE | Video Endoscopic Image Storage.
VIDEO_MICROSCOPIC_IMAGE_STORAGE | Video Microscopic Image Storage.
VIDEO_PHOTOGRAPHIC_IMAGE_STORAGE | Video Photographic Image Storage.
VISIT_MGMT_DET | Detached Visit Management SOP Class (Retired). /*RET
VISUAL_ACUITY_MEASUREMENTS_STORAGE | Visual Acuity Measurements Storage.
VL_ENDO_IMG_STORAGE | VL Endoscopic Image Storage.
VL_IMG_STORAGE | VL Image Storage - Trial (Retired). /*RET
VL_MICRO_IMG_STORAGE | VL Microscopic Image Storage.
VL_MULTIFRAME_IMG_STORAGE | VL Multi-frame Image Storage - Trial (Retired). /*RET
VL_PHOTO_IMG_STORAGE | VL Photographic Image Storage.
VL_SLIDE_MICRO_IMG_STORAGE | VL Slide-Coordinates Microscopic Image Storage.
VOI_LUT_BOX | VOI LUT Box SOP Class.
VOI_LUT_STORAGE | Standalone VOI LUT Storage (Retired). /*RET
WAVEFORM_12_LEAD_ECG_STORAGE | 12-lead ECG Waveform Storage.
WAVEFORM_AUDIO_STORAGE | Waveform Audio Storage. /*ret
WAVEFORM_ECG_STORAGE | General ECG Waveform Storage. /*ret
WAVEFORM_GEN_ECG_STORAGE | General ECG Waveform Storage.
WAVEFORM_HEMO_STORAGE | Hemodynamic Waveform Storage.
WAVEFORM_STORAGE | Waveform Storage - Trial (Retired). /*RET
XA_XRF_GRAYSCALE_SOFTCOPY_PRES_STATE_STORAGE | XA/XRF Grayscale Softcopy Presentation State Storage SOP Class.
XRAY_3D_ANGIOGRAPHIC_STORAGE | X-Ray 3D Angiographic Image Storage.
XRAY_3D_CRANIOFACIAL_STORAGE | X-Ray 3D Craniofacial Image Storage.
XRAY_ANGIO_BI_PLANE_STORAGE | X-Ray Angiographic Bi-Plane Image storage (Retired). /*RET
XRAY_ANGIO_STORAGE | X-Ray Angiographic Image Storage.
XRAY_ENHANCED_XA_IMAGE_STORAGE | Enhanced XA Image Storage.
XRAY_RADIATION_DOSE_SR_STORAGE | X-Ray Radiation Dose SR Storage.
XRAY_RF_STORAGE | X-Ray Radiofluoroscopic Image Storage.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMServiceObjectPairs

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMTransferSyntaxes Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMTransferSyntaxes Enumeration

Glossary Item Box

Specifies DICOM Transfer Syntaxes.

Members

Member | Description
AUTODETECT | Autodetect. This value is used with DICOM LoadSyntax format option, to allow automatic detection of transfer syntax.
DEFAULT | DICOM default transfer syntax: Implicit VR Little Endian.
DEFLATED_EXPLICIT_VR_LE | Deflated Explicit VR Little Endian.
EXPLICIT_VR_BE | Explicit VR Big Endian (uncompressed).
EXPLICIT_VR_LE | Explicit VR Little Endian (uncompressed).
IMPLICIT_VR_LE | Implicit VR Little Endian: Default Transfer Syntax for DICOM (uncompressed).
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION | JPEG 2000 Part 2 Multi-component Image Compression.
JPEG_2000_PART_2_MULTI_COMPONENT_IMAGE_COMPRESSION_Lossless_Only | JPEG 2000 Part 2 Multi-component Image Compression (Lossless Only).
JPEG_2K | JPEG 2000 Image Compression.
JPEG_2K_LOSSLESS_ONLY | JPEG 2000 Image Compression (Lossless Only).
JPEG_BASELINE_PR_1 | JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
JPEG_EXTENDED_HIER_PR_16_18 | JPEG Extended, Hierarchical (Process 16 & 18) (Retired). /*RET
JPEG_EXTENDED_HIER_PR_17_19 | JPEG Extended, Hierarchical (Process 17 & 19) (Retired). /*RET
JPEG_EXTENDED_PR_2_4 | JPEG Extended (Process 2 & 4): Default Transfer Syntax for Lossy JPEG 12 Bit Image Compression (Process 4 only).
JPEG_EXTENDED_PR_3_5 | JPEG Extended (Process 3 & 5) (Retired). /*RET
JPEG_FULL_PROG_HIER_PR_24_26 | JPEG Full Progression, Hierarchical (Process 24 & 26) (Retired). /*RET
JPEG_FULL_PROG_HIER_PR_25_27 | JPEG Full Progression, Hierarchical (Process 25 & 27) (Retired). /*RET
JPEG_FULL_PROG_NONH_PR_10_12 | JPEG Full Progression, Non-Hierarchical (Process 10 & 12) (Retired). /*RET
JPEG_FULL_PROG_NONH_PR_11_13 | JPEG Full Progression, Non-Hierarchical (Process 11 & 13) (Retired). /*RET
JPEG_LOSSLESS | JPEG Lossless, Non-Hierarchical (Process 14).
JPEG_LOSSLESS_HIER_PR_28 | JPEG Lossless, Hierarchical (Process 28) (Retired). /*RET
JPEG_LOSSLESS_HIER_PR_29 | JPEG Lossless, Hierarchical (Process 29) (Retired). /*RET
JPEG_LOSSLESS_NONH_FIRSTORDER_PR_14 | JPEG Lossless, Non-Hierarchical, First-Order Prediction (Process 14 [Selection Value 1]): Default Transfer Syntax for Lossless JPEG Image Compression.
JPEG_LOSSLESS_NONH_PR_14 | JPEG Lossless, Non-Hierarchical (Process 14).
JPEG_LOSSLESS_NONH_PR_15 | JPEG Lossless, Non-Hierarchical (Process 15) (Retired). /*RET
JPEG_LOSSY | JPEG Baseline (Process 1): Default Transfer Syntax for Lossy JPEG 8 Bit Image Compression.
JPEG_LS_LOSSLESS | JPEG-LS Lossless Image Compression.
JPEG_LS_LOSSY | JPEG-LS Lossy (Near-Lossless) Image Compression.
JPEG_SPECTRAL_HIER_PR_20_22 | JPEG Spectral Selection, Hierarchical (Process 20 & 22) (Retired). /*RET
JPEG_SPECTRAL_HIER_PR_21_23 | JPEG Spectral Selection, Hierarchical (Process 21 & 23) (Retired). /*RET
JPEG_SPECTRAL_NONH_PR_6_8 | JPEG Spectral Selection, Non-Hierarchical (Process 6 & 8) (Retired). /*RET
JPEG_SPECTRAL_NONH_PR_7_9 | JPEG Spectral Selection, Non-Hierarchical (Process 7 & 9) (Retired). /*RET
JPIP_REFERENCED | JPIP Referenced.
JPIP_REFERENCED_DEFLATE | JPIP Referenced Deflate.
MPEG2_MAIN_PROFILE | MPEG2 Main Profile @ Main Level.
MPEG2_MAIN_PROFILE_HIGH_LEVEL | MPEG2 Main Profile @ High Level.
PART_10 | Autodetect. This value is used with DICOM LoadSyntax format option, to allow detection of DICOM Part10 compliant images.
RFC_2557_MIME_ENCAPSULATION | RFC 2557 MIME encapsulation.
RLE | RLE Lossless.
UNKNOWN | Unknown transfer syntax.
XML | XML Encoding.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMTransferSyntaxes

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearDICOMValueRepresentations Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearDICOMValueRepresentations Enumeration

Glossary Item Box

Specifies DICOM Value Representations.

Value Representation specifies type and format of the value(s) contained in data element.

Members

Member | Description
AgeString | Age String.
ApplicationEntity | Application Entity.
AttributeTag | Attribute Tag.
CodeString | Code String.
Date | Date (without time).
DateTime | Date Time.
DecimalString | Decimal String.
FloatingPointDouble | Floating Double Point.
FloatingPointSingle | Floating Single Point.
IntegerString | Integer String.
LongString | Long String.
LongText | Long Text.
None | None (unknown).
OtherByteString | Other Byte String.
OtherFloatString | Other Float String.
OtherWordString | Other Word String.
PersonName | Person Name.
SequenceOfItems | Sequence of Items.
ShortString | Short String.
ShortText | Short Text.
SignedLong | Signed Long.
SignedShort | Signed Short.
Time | Time (without date).
UniqueIdentifier | Unique Identifier.
Unknown | Unknown - supp 14.
UnlimitedText | Unlimited Text.
UnsignedLong | Unsigned Long.
UnsignedShort | Unsigned Short.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearDICOMValueRepresentations

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%PageItemTitle%%

ImGearPseudocolorSchemes Enumeration
com.accusoft.imagegear.formats.dicom Package : ImGearPseudocolorSchemes Enumeration

Glossary Item Box

Specifies predefined pseudocoloring schemes.

Members

Member | Description
BrightRainbow | Bright rainbow color scheme.
DarkBlueToBightRed | From DarkBlue to BrightRed color scheme.
Default | Default color scheme.
GreenToRed | GreenToRed color scheme.
OilFilm | OilFilm color scheme.
RedGreenBlue | RGB color scheme.
Thermal | Thermal color scheme.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.dicom.ImGearPseudocolorSchemes

See Also

Reference

com.accusoft.imagegear.formats.dicom Package


%%ItemTitle%%

com.accusoft.imagegear.formats.exif Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for operating with EXIF non-image data.

Classes

Class | Description
ImGearEXIFGPSMetadata | Provides simplified access to EXIF GPS metadata.
ImGearEXIFInteropMetadata | Provides simplified access to EXIF Interoperability metadata.
ImGearEXIFMetadata | Provides simplified access to EXIF metadata.

Enumerations

Enumeration | Description
ImGearEXIFColorSpace | Represents EXIF color spaces.
ImGearEXIFContrastMode | Represents EXIF contrast modes.
ImGearEXIFCustomRendered | Represents EXIF custom rendered modes.
ImGearEXIFExposureMode | Represents EXIF exposure modes.
ImGearEXIFExposureProgram | Represents EXIF exposure programs.
ImGearEXIFFileSource | Represents EXIF File Sources.
ImGearEXIFFlashMode | Represents EXIF flash mode.
ImGearEXIFFlashReturn | Represents EXIF flash return.
ImGearEXIFGainControl | Represents EXIF gain controls.
ImGearEXIFGPSAltitudeReference | Represents EXIF GPS altitude references.
ImGearEXIFGPSDifferential | Represents EXIF GPS differentials.
ImGearEXIFGPSDirectionReference | Represents EXIF GPS direction references.
ImGearEXIFGPSDistanceReference | Represents EXIF GPS distance references.
ImGearEXIFGPSLatitudeReference | Represents EXIF GPS latitude references.
ImGearEXIFGPSLongitudeReference | Represents EXIF GPS longitude references.
ImGearEXIFGPSMeasureMode | Represents EXIF GPS measure modes.
ImGearEXIFGPSSpeedReference | Represents EXIF GPS speed reference modes.
ImGearEXIFGPSStatus | Represents EXIF GPS statuses.
ImGearEXIFLightSource | Represents EXIF light sources.
ImGearEXIFMeteringMode | Represents EXIF Metering Modes.
ImGearEXIFSaturationMode | Represents EXIF saturation modes.
ImGearEXIFSceneCaptureType | Represents EXIF scene capture types.
ImGearEXIFSceneType | Represents EXIF scene types.
ImGearEXIFSensingMethod | Represents EXIF sensing methods.
ImGearEXIFSharpnessMode | Represents EXIF sharpness modes.
ImGearEXIFSubjectDistanceRange | Represents EXIF subject distance ranges.
ImGearEXIFWhiteBalanceMode | Represents EXIF white balance modes.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.exif Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFInteropMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearEXIFGPSMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSMetadata Class

Glossary Item Box

Provides simplified access to EXIF GPS metadata.

Object Model

ImGearEXIFGPSMetadata ClassImGearRationalUInt ClassImGearEXIFGPSAltitudeReference EnumerationImGearRationalUInt ClassImGearEXIFGPSDirectionReference EnumerationImGearRationalUInt ClassImGearEXIFGPSDistanceReference EnumerationImGearRationalUInt ClassImGearEXIFGPSLatitudeReference EnumerationImGearRationalUInt ClassImGearEXIFGPSLongitudeReference EnumerationImGearEXIFGPSDifferential EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearEXIFGPSDirectionReference EnumerationImGearRationalUInt ClassImGearEXIFGPSLatitudeReference EnumerationImGearRationalUInt ClassImGearEXIFGPSLongitudeReference EnumerationImGearEXIFGPSMeasureMode EnumerationImGearRationalUInt ClassImGearEXIFGPSSpeedReference EnumerationImGearEXIFGPSStatus EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearEXIFGPSDirectionReference Enumeration

Syntax

public class ImGearEXIFGPSMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSMetadata

See Also

Reference

ImGearEXIFGPSMetadata Members
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEXIFGPSMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearEXIFGPSMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearEXIFGPSMetadata Constructor | Initializes a new instance of the ImGearEXIFGPSMetadata class.
Top

Public Methods

Name Description
public Method getAltitude Returns Altitude Tag value.

Method returns the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

public Method getAltitudeReference Returns AltitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

public Method getAreaInformation Returns AreaInformation Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

public Method getDateStamp Returns DateStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

public Method getDestBearing Returns DestBearing Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

public Method getDestBearingReference Returns DestBearingReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

public Method getDestDistance Returns DestDistance Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

public Method getDestDistanceReference Returns DestDistanceReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

public Method getDestLatitude Returns DestLatitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method getDestLatitudeReference Returns DestLatitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

public Method getDestLongitude Returns DestLongitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method getDestLongitudeReference Returns DestLongitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

public Method getDifferential Returns Differential Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

public Method getDOP Returns DOP Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

public Method getImgDirection Returns ImgDirection Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

public Method getImgDirectionReference Returns ImgDirectionReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

public Method getLatitude Returns Latitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method getLatitudeReference Gets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

public Method getLongitude Returns Longitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method getLongitudeReference Gets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

public Method getMapDatum Returns MapDatum Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

public Method getMeasureMode Returns MeasureMode Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

public Method getProcessingMethod Returns ProcessingMethod Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

public Method getSatellites Returns Satellites Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

public Method getSpeed Returns Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

public Method getSpeedReference Returns SpeedReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

public Method getStatus Returns Status Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

public Method getTimeStamp Returns TimeStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

public Method getTrack Returns Track Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

public Method getTrackReference Returns TrackReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

public Method getVersionID Gets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

public Method setAltitude Sets Altitude Tag value.

Method replaces the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

public Method setAltitudeReference Sets AltitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

public Method setAreaInformation Sets AreaInformation Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

public Method setDateStamp Sets DateStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

public Method setDestBearing Sets DestBearing Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

public Method setDestBearingReference Sets DestBearingReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

public Method setDestDistance Sets DestDistance Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

public Method setDestDistanceReference Sets DestDistanceReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

public Method setDestLatitude Sets DestLatitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method setDestLatitudeReference Sets DestLatitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

public Method setDestLongitude Sets DestLongitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method setDestLongitudeReference Sets DestLongitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

public Method setDifferential Sets Differential Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

public Method setDOP Sets DOP Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

public Method setImgDirection Sets ImgDirection Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

public Method setImgDirectionReference Sets ImgDirectionReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

public Method setLatitude Sets Latitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method setLatitudeReference Sets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

public Method setLongitude Sets Longitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method setLongitudeReference Sets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

public Method setMapDatum Sets MapDatum Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

public Method setMeasureMode Sets MeasureMode Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

public Method setProcessingMethod Sets ProcessingMethod Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

public Method setSatellites Sets Satellites Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

public Method setSpeed Sets Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

public Method setSpeedReference Sets SpeedReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

public Method setStatus Sets Status Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

public Method setTimeStamp Sets TimeStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

public Method setTrack Sets Track Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

public Method setTrackReference Sets TrackReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

public Method setVersionID Sets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Top

See Also

Reference

ImGearEXIFGPSMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSMetadata Constructor
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : ImGearEXIFGPSMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearEXIFGPSMetadata class.

Syntax

public ImGearEXIFGPSMetadata()

Return Value

The new instance of ImGearEXIFGPSMetadata class.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEXIFGPSMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearEXIFGPSMetadata members.

Public Methods

Name Description
public Method getAltitude Returns Altitude Tag value.

Method returns the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

public Method getAltitudeReference Returns AltitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

public Method getAreaInformation Returns AreaInformation Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

public Method getDateStamp Returns DateStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

public Method getDestBearing Returns DestBearing Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

public Method getDestBearingReference Returns DestBearingReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

public Method getDestDistance Returns DestDistance Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

public Method getDestDistanceReference Returns DestDistanceReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

public Method getDestLatitude Returns DestLatitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method getDestLatitudeReference Returns DestLatitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

public Method getDestLongitude Returns DestLongitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method getDestLongitudeReference Returns DestLongitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

public Method getDifferential Returns Differential Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

public Method getDOP Returns DOP Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

public Method getImgDirection Returns ImgDirection Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

public Method getImgDirectionReference Returns ImgDirectionReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

public Method getLatitude Returns Latitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method getLatitudeReference Gets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

public Method getLongitude Returns Longitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method getLongitudeReference Gets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

public Method getMapDatum Returns MapDatum Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

public Method getMeasureMode Returns MeasureMode Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

public Method getProcessingMethod Returns ProcessingMethod Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

public Method getSatellites Returns Satellites Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

public Method getSpeed Returns Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

public Method getSpeedReference Returns SpeedReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

public Method getStatus Returns Status Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

public Method getTimeStamp Returns TimeStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

public Method getTrack Returns Track Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

public Method getTrackReference Returns TrackReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

public Method getVersionID Gets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

public Method setAltitude Sets Altitude Tag value.

Method replaces the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

public Method setAltitudeReference Sets AltitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

public Method setAreaInformation Sets AreaInformation Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

public Method setDateStamp Sets DateStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

public Method setDestBearing Sets DestBearing Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

public Method setDestBearingReference Sets DestBearingReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

public Method setDestDistance Sets DestDistance Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

public Method setDestDistanceReference Sets DestDistanceReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

public Method setDestLatitude Sets DestLatitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method setDestLatitudeReference Sets DestLatitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

public Method setDestLongitude Sets DestLongitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method setDestLongitudeReference Sets DestLongitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

public Method setDifferential Sets Differential Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

public Method setDOP Sets DOP Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

public Method setImgDirection Sets ImgDirection Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

public Method setImgDirectionReference Sets ImgDirectionReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

public Method setLatitude Sets Latitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

public Method setLatitudeReference Sets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

public Method setLongitude Sets Longitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

public Method setLongitudeReference Sets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

public Method setMapDatum Sets MapDatum Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

public Method setMeasureMode Sets MeasureMode Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

public Method setProcessingMethod Sets ProcessingMethod Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

public Method setSatellites Sets Satellites Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

public Method setSpeed Sets Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

public Method setSpeedReference Sets SpeedReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

public Method setStatus Sets Status Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

public Method setTimeStamp Sets TimeStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

public Method setTrack Sets Track Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

public Method setTrackReference Sets TrackReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

public Method setVersionID Sets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Top

See Also

Reference

ImGearEXIFGPSMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

getAltitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getAltitude Method

Glossary Item Box

Returns Altitude Tag value.

Method returns the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

Syntax

public ImGearRationalUInt getAltitude()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getAltitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getAltitudeReference Method

Glossary Item Box

Returns AltitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

Syntax

public ImGearEXIFGPSAltitudeReference getAltitudeReference()

Return Value

Nullable (boxed) ImGearEXIFGPSAltitudeReference enumeration value. *

ImGearEXIFGPSAltitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getAreaInformation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getAreaInformation Method

Glossary Item Box

Returns AreaInformation Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

Syntax

public byte[] getAreaInformation()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDateStamp Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDateStamp Method

Glossary Item Box

Returns DateStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

Syntax

public java.lang.String getDateStamp()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestBearing Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestBearing Method

Glossary Item Box

Returns DestBearing Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

Syntax

public ImGearRationalUInt getDestBearing()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestBearingReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestBearingReference Method

Glossary Item Box

Returns DestBearingReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

Syntax

public ImGearEXIFGPSDirectionReference getDestBearingReference()

Return Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestDistance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestDistance Method

Glossary Item Box

Returns DestDistance Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

Syntax

public ImGearRationalUInt getDestDistance()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestDistanceReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestDistanceReference Method

Glossary Item Box

Returns DestDistanceReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

Syntax

public ImGearEXIFGPSDistanceReference getDestDistanceReference()

Return Value

Nullable (boxed) ImGearEXIFGPSDistanceReference enumeration value. *

ImGearEXIFGPSDistanceReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestLatitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestLatitude Method

Glossary Item Box

Returns DestLatitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Syntax

public ImGearRationalUInt[] getDestLatitude()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestLatitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestLatitudeReference Method

Glossary Item Box

Returns DestLatitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

Syntax

public ImGearEXIFGPSLatitudeReference getDestLatitudeReference()

Return Value

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value. *

ImGearEXIFGPSLatitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestLongitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestLongitude Method

Glossary Item Box

Returns DestLongitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Syntax

public ImGearRationalUInt[] getDestLongitude()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDestLongitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDestLongitudeReference Method

Glossary Item Box

Returns DestLongitudeReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

Syntax

public ImGearEXIFGPSLongitudeReference getDestLongitudeReference()

Return Value

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value. *

ImGearEXIFGPSLongitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDifferential Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDifferential Method

Glossary Item Box

Returns Differential Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

Syntax

public ImGearEXIFGPSDifferential getDifferential()

Return Value

Nullable (boxed) ImGearEXIFGPSDifferential enumeration value. *

ImGearEXIFGPSDifferential

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getDOP Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getDOP Method

Glossary Item Box

Returns DOP Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

Syntax

public ImGearRationalUInt getDOP()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getImgDirection Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getImgDirection Method

Glossary Item Box

Returns ImgDirection Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

Syntax

public ImGearRationalUInt getImgDirection()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getImgDirectionReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getImgDirectionReference Method

Glossary Item Box

Returns ImgDirectionReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

Syntax

public ImGearEXIFGPSDirectionReference getImgDirectionReference()

Return Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getLatitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getLatitude Method

Glossary Item Box

Returns Latitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Syntax

public ImGearRationalUInt[] getLatitude()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getLatitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getLatitudeReference Method

Glossary Item Box

Gets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

Syntax

public ImGearEXIFGPSLatitudeReference getLatitudeReference()

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getLongitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getLongitude Method

Glossary Item Box

Returns Longitude Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Syntax

public ImGearRationalUInt[] getLongitude()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getLongitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getLongitudeReference Method

Glossary Item Box

Gets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

Syntax

public ImGearEXIFGPSLongitudeReference getLongitudeReference()

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getMapDatum Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getMapDatum Method

Glossary Item Box

Returns MapDatum Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

Syntax

public java.lang.String getMapDatum()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getMeasureMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getMeasureMode Method

Glossary Item Box

Returns MeasureMode Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

Syntax

public ImGearEXIFGPSMeasureMode getMeasureMode()

Return Value

Nullable (boxed) ImGearEXIFGPSMeasureMode enumeration value. *

ImGearEXIFGPSMeasureMode

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getProcessingMethod Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getProcessingMethod Method

Glossary Item Box

Returns ProcessingMethod Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

Syntax

public byte[] getProcessingMethod()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getSatellites Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getSatellites Method

Glossary Item Box

Returns Satellites Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

Syntax

public java.lang.String getSatellites()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getSpeed Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getSpeed Method

Glossary Item Box

Returns Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

Syntax

public ImGearRationalUInt getSpeed()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getSpeedReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getSpeedReference Method

Glossary Item Box

Returns SpeedReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

Syntax

public ImGearEXIFGPSSpeedReference getSpeedReference()

Return Value

Nullable (boxed) ImGearEXIFGPSSpeedReference enumeration value. *

ImGearEXIFGPSSpeedReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getStatus Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getStatus Method

Glossary Item Box

Returns Status Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

Syntax

public ImGearEXIFGPSStatus getStatus()

Return Value

Nullable (boxed) ImGearEXIFGPSStatus enumeration value. *

ImGearEXIFGPSStatus

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getTimeStamp Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getTimeStamp Method

Glossary Item Box

Returns TimeStamp Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

Syntax

public ImGearRationalUInt[] getTimeStamp()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getTrack Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getTrack Method

Glossary Item Box

Returns Track Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

Syntax

public ImGearRationalUInt getTrack()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getTrackReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getTrackReference Method

Glossary Item Box

Returns TrackReference Tag value.

Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

Syntax

public ImGearEXIFGPSDirectionReference getTrackReference()

Return Value

Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

getVersionID Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : getVersionID Method

Glossary Item Box

Gets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Syntax

public byte[] getVersionID()

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setAltitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setAltitude Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets Altitude Tag value.

Method replaces the tag value, if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitude tag. The tag indicates the altitude based on the reference in AltitudeReference. Altitude is expressed as one RATIONAL value. The reference unit is meters.

Syntax

public void setAltitude(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setAltitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setAltitudeReference Method
value
Nullable (boxed) ImGearEXIFGPSAltitudeReference enumeration value. *

ImGearEXIFGPSAltitudeReference

Glossary Item Box

Sets AltitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAltitudeRef tag. The tag indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag.

Syntax

public void setAltitudeReference(
   ImGearEXIFGPSAltitudeReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSAltitudeReference enumeration value. *

ImGearEXIFGPSAltitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setAreaInformation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setAreaInformation Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets AreaInformation Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSAreaInformation tag. The tag specifies a character string recording the name of the GPS area.

Syntax

public void setAreaInformation(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDateStamp Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDateStamp Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets DateStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDateStamp tag. The tag specifies a character string recording date and time information relative to UTC (Coordinated Universal Time). The format is "YYYY:MM:DD."

Syntax

public void setDateStamp(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestBearing Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestBearing Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DestBearing Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearing tag. The tag indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.

Syntax

public void setDestBearing(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestBearingReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestBearingReference Method
value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

Glossary Item Box

Sets DestBearingReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestBearingRef tag. The tag indicates the reference used for giving the bearing to the destination point.

Syntax

public void setDestBearingReference(
   ImGearEXIFGPSDirectionReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestDistance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestDistance Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DestDistance Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistance tag. The tag indicates the distance to the destination point.

Syntax

public void setDestDistance(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestDistanceReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestDistanceReference Method
value
Nullable (boxed) ImGearEXIFGPSDistanceReference enumeration value. *

ImGearEXIFGPSDistanceReference

Glossary Item Box

Sets DestDistanceReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestDistanceRef tag. The tag indicates the unit used to express the distance to the destination point.

Syntax

public void setDestDistanceReference(
   ImGearEXIFGPSDistanceReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSDistanceReference enumeration value. *

ImGearEXIFGPSDistanceReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestLatitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestLatitude Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DestLatitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitude tag. The tag indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Syntax

public void setDestLatitude(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestLatitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestLatitudeReference Method
value
Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value. *

ImGearEXIFGPSLatitudeReference

Glossary Item Box

Sets DestLatitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLatitudeRef tag. The tag indicates whether the latitude of the destination point is north or south latitude.

Syntax

public void setDestLatitudeReference(
   ImGearEXIFGPSLatitudeReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value. *

ImGearEXIFGPSLatitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestLongitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestLongitude Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DestLongitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitude tag. The tag indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Syntax

public void setDestLongitude(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDestLongitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDestLongitudeReference Method
value
Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value. *

ImGearEXIFGPSLongitudeReference

Glossary Item Box

Sets DestLongitudeReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDestLongitudeRef tag. The tag indicates whether the longitude of the destination point is east or west longitude.

Syntax

public void setDestLongitudeReference(
   ImGearEXIFGPSLongitudeReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value. *

ImGearEXIFGPSLongitudeReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDifferential Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDifferential Method
value
Nullable (boxed) ImGearEXIFGPSDifferential enumeration value. *

ImGearEXIFGPSDifferential

Glossary Item Box

Sets Differential Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDifferential tag. The tag indicates whether differential correction is applied to the GPS receiver.

Syntax

public void setDifferential(
   ImGearEXIFGPSDifferential value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSDifferential enumeration value. *

ImGearEXIFGPSDifferential

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setDOP Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setDOP Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DOP Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSDOP tag. The tag indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.

Syntax

public void setDOP(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setImgDirection Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setImgDirection Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ImgDirection Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirection tag. The tag indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.

Syntax

public void setImgDirection(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setImgDirectionReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setImgDirectionReference Method
value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

Glossary Item Box

Sets ImgDirectionReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSImgDirectionRef tag. The tag indicates the reference for giving the direction of the image when it is captured.

Syntax

public void setImgDirectionReference(
   ImGearEXIFGPSDirectionReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setLatitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setLatitude Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets Latitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLatitude tag. The tag indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes, and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.

Syntax

public void setLatitude(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setLatitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setLatitudeReference Method
value

Glossary Item Box

Sets LatitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLatitudeReference enumeration value.

This method accesses the GPSLatitudeRef tag. The tag indicates whether the latitude is north or south latitude.

ImGearEXIFGPSLatitudeReference

Syntax

public void setLatitudeReference(
   ImGearEXIFGPSLatitudeReference value
)

Parameters

value

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setLongitude Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setLongitude Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets Longitude Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSLongitude tag. The tag indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes, and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.

Syntax

public void setLongitude(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setLongitudeReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setLongitudeReference Method
value

Glossary Item Box

Sets LongitudeReference Tag value.

Nullable (boxed) ImGearEXIFGPSLongitudeReference enumeration value.

This method accesses the GPSLongitudeRef tag. The tag indicates whether the longitude is east or west longitude.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

ImGearEXIFGPSLongitudeReference

Syntax

public void setLongitudeReference(
   ImGearEXIFGPSLongitudeReference value
)

Parameters

value

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setMapDatum Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setMapDatum Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets MapDatum Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMapDatum tag. The tag indicates the geodetic survey data used by the GPS receiver.

Syntax

public void setMapDatum(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setMeasureMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setMeasureMode Method
value
Nullable (boxed) ImGearEXIFGPSMeasureMode enumeration value. *

ImGearEXIFGPSMeasureMode

Glossary Item Box

Sets MeasureMode Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSMeasureMode tag. The tag indicates the GPS measurement mode.

Syntax

public void setMeasureMode(
   ImGearEXIFGPSMeasureMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSMeasureMode enumeration value. *

ImGearEXIFGPSMeasureMode

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setProcessingMethod Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setProcessingMethod Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets ProcessingMethod Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSProcessingMethod tag. The tag contains a character string recording the name of the method used for location finding.

Syntax

public void setProcessingMethod(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setSatellites Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setSatellites Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets Satellites Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSatellites tag. The tag indicates the GPS satellites used for measurements.

Syntax

public void setSatellites(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setSpeed Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setSpeed Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value.

Glossary Item Box

Sets Speed Tag value.

This method accesses the GPSSpeed tag. The tag indicates the speed of GPS receiver movement.

com.accusoft.imagegear.core.ImGearRationalUInt

Syntax

public void setSpeed(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value.

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setSpeedReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setSpeedReference Method
value
Nullable (boxed) ImGearEXIFGPSSpeedReference enumeration value. *

ImGearEXIFGPSSpeedReference

Glossary Item Box

Sets SpeedReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSSpeedRef tag. The tag indicates the unit used to express the GPS receiver speed of movement.

Syntax

public void setSpeedReference(
   ImGearEXIFGPSSpeedReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSSpeedReference enumeration value. *

ImGearEXIFGPSSpeedReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setStatus Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setStatus Method
value
Nullable (boxed) ImGearEXIFGPSStatus enumeration value. *

ImGearEXIFGPSStatus

Glossary Item Box

Sets Status Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSStatus tag. The tag indicates the status of the GPS receiver when the image is recorded.

Syntax

public void setStatus(
   ImGearEXIFGPSStatus value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSStatus enumeration value. *

ImGearEXIFGPSStatus

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setTimeStamp Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setTimeStamp Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets TimeStamp Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTimeStamp tag. The tag indicates the time as UTC (Coordinated Universal Time). TimeStamp is expressed as three RATIONAL values giving the hour, minute, and second.

Syntax

public void setTimeStamp(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setTrack Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setTrack Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets Track Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrack tag. The tag indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.

Syntax

public void setTrack(
   ImGearRationalUInt value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setTrackReference Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setTrackReference Method
value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

Glossary Item Box

Sets TrackReference Tag value.

Method replaces the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GPSTrackRef tag. The tag indicates the reference for giving the direction of GPS receiver movement.

Syntax

public void setTrackReference(
   ImGearEXIFGPSDirectionReference value
)

Parameters

value
Nullable (boxed) ImGearEXIFGPSDirectionReference enumeration value. *

ImGearEXIFGPSDirectionReference

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

setVersionID Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFGPSMetadata Class : setVersionID Method
value

Glossary Item Box

Sets VersionID Tag value.

Array of bytes.

This method accesses the GPSVersionID tag. The tag indicates the version of GPSInfoIFD.

get accessor return the tag value if the tag is present in the metadata tree, or null otherwise.

Set accessor replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the EXIF 2.2 specification for tag usage details.

Syntax

public void setVersionID(
   byte[] value
)

Parameters

value

See Also

Reference

ImGearEXIFGPSMetadata Class
ImGearEXIFGPSMetadata Members


%%PageItemTitle%%

ImGearEXIFInteropMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFInteropMetadata Class

Glossary Item Box

Provides simplified access to EXIF Interoperability metadata.

Object Model

ImGearEXIFInteropMetadata Class

Syntax

public class ImGearEXIFInteropMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFInteropMetadata

See Also

Reference

ImGearEXIFInteropMetadata Members
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEXIFInteropMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFInteropMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearEXIFInteropMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearEXIFInteropMetadata Constructor | Initializes a new instance of the ImGearEXIFInteropMetadata class.
Top

Public Methods

 | Name | Description
public Method | getInteroperabilityIndex | Returns InteroperabilityIndex Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.
public Method | getInteroperabilityVersion | Returns InteroperabilityVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityVersion tag.
public Method | getRelatedImageFileFormat | Returns RelatedImageFileFormat Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageFileFormat tag.
public Method | getRelatedImageLength | Returns RelatedImageLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageLength tag.
public Method | getRelatedImageWidth | Returns RelatedImageWidth Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageWidth tag.
public Method | setInteroperabilityIndex | Sets InteroperabilityIndex Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.
public Method | setInteroperabilityVersion | Sets InteroperabilityVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityVersion tag.
public Method | setRelatedImageFileFormat | Sets RelatedImageFileFormat Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageFileFormat tag.
public Method | setRelatedImageLength | Sets RelatedImageLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageLength tag.
public Method | setRelatedImageWidth | Sets RelatedImageWidth Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageWidth tag.
Top

See Also

Reference

ImGearEXIFInteropMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFInteropMetadata Constructor
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : ImGearEXIFInteropMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearEXIFInteropMetadata class.

Syntax

public ImGearEXIFInteropMetadata()

Return Value

The new instance of ImGearEXIFInteropMetadata class.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEXIFInteropMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFInteropMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearEXIFInteropMetadata members.

Public Methods

 | Name | Description
public Method | getInteroperabilityIndex | Returns InteroperabilityIndex Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.
public Method | getInteroperabilityVersion | Returns InteroperabilityVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityVersion tag.
public Method | getRelatedImageFileFormat | Returns RelatedImageFileFormat Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageFileFormat tag.
public Method | getRelatedImageLength | Returns RelatedImageLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageLength tag.
public Method | getRelatedImageWidth | Returns RelatedImageWidth Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageWidth tag.
public Method | setInteroperabilityIndex | Sets InteroperabilityIndex Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.
public Method | setInteroperabilityVersion | Sets InteroperabilityVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InteroperabilityVersion tag.
public Method | setRelatedImageFileFormat | Sets RelatedImageFileFormat Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageFileFormat tag.
public Method | setRelatedImageLength | Sets RelatedImageLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageLength tag.
public Method | setRelatedImageWidth | Sets RelatedImageWidth Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedImageWidth tag.
Top

See Also

Reference

ImGearEXIFInteropMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

getInteroperabilityIndex Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : getInteroperabilityIndex Method

Glossary Item Box

Returns InteroperabilityIndex Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.

Syntax

public java.lang.String getInteroperabilityIndex()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

getInteroperabilityVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : getInteroperabilityVersion Method

Glossary Item Box

Returns InteroperabilityVersion Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InteroperabilityVersion tag.

Syntax

public byte[] getInteroperabilityVersion()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

getRelatedImageFileFormat Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : getRelatedImageFileFormat Method

Glossary Item Box

Returns RelatedImageFileFormat Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageFileFormat tag.

Syntax

public java.lang.String getRelatedImageFileFormat()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

getRelatedImageLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : getRelatedImageLength Method

Glossary Item Box

Returns RelatedImageLength Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageLength tag.

Syntax

public java.lang.int getRelatedImageLength()

Return Value

Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

getRelatedImageWidth Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : getRelatedImageWidth Method

Glossary Item Box

Returns RelatedImageWidth Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageWidth tag.

Syntax

public java.lang.short getRelatedImageWidth()

Return Value

Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

setInteroperabilityIndex Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : setInteroperabilityIndex Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets InteroperabilityIndex Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InteroperabilityIndex tag. The tag indicates the identification of the Interoperability rule.

Syntax

public void setInteroperabilityIndex(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

setInteroperabilityVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : setInteroperabilityVersion Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets InteroperabilityVersion Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InteroperabilityVersion tag.

Syntax

public void setInteroperabilityVersion(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

setRelatedImageFileFormat Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : setRelatedImageFileFormat Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets RelatedImageFileFormat Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageFileFormat tag.

Syntax

public void setRelatedImageFileFormat(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

setRelatedImageLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : setRelatedImageLength Method
value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets RelatedImageLength Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageLength tag.

Syntax

public void setRelatedImageLength(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

setRelatedImageWidth Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFInteropMetadata Class : setRelatedImageWidth Method
value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets RelatedImageWidth Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedImageWidth tag.

Syntax

public void setRelatedImageWidth(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFInteropMetadata Class
ImGearEXIFInteropMetadata Members


%%PageItemTitle%%

ImGearEXIFMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFMetadata Class

Glossary Item Box

Provides simplified access to EXIF metadata.

Object Model

ImGearEXIFMetadata ClassImGearRationalUInt ClassImGearRationalInt ClassImGearEXIFColorSpace EnumerationImGearRationalUInt ClassImGearTIFFCompression EnumerationImGearEXIFContrastMode EnumerationImGearEXIFCustomRendered EnumerationImGearRationalUInt ClassImGearRationalInt ClassImGearRationalUInt ClassImGearEXIFExposureMode EnumerationImGearEXIFExposureProgram EnumerationImGearRationalUInt ClassImGearEXIFFileSource EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt ClassImGearTIFFResolutionUnit EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearEXIFGainControl EnumerationImGearEXIFGPSMetadata ClassImGearEXIFInteropMetadata ClassImGearEXIFLightSource EnumerationImGearRationalUInt ClassImGearEXIFMeteringMode EnumerationImGearTIFFOrientation EnumerationImGearTIFFPhotoInterpretation EnumerationImGearTIFFPlanarConfig EnumerationImGearRationalUInt ClassImGearTIFFResolutionUnit EnumerationImGearEXIFSaturationMode EnumerationImGearEXIFSceneType EnumerationImGearEXIFSensingMethod EnumerationImGearEXIFSharpnessMode EnumerationImGearRationalInt ClassImGearRationalUInt ClassImGearEXIFSubjectDistanceRange EnumerationImGearEXIFWhiteBalanceMode EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt Class

Syntax

public class ImGearEXIFMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.exif.ImGearEXIFMetadata

See Also

Reference

ImGearEXIFMetadata Members
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEXIFMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearEXIFMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearEXIFMetadata Constructor | Initializes a new instance of the ImGearEXIFMetadata class.
Top

Public Methods

 | Name | Description
public Method | getApertureValue | Returns ApertureValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.
public Method | getArtist | Returns Artist Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Artist tag. The tag specifies the person who created the image.
public Method | getBitsPerSample | Returns BitsPerSample Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.
public Method | getBrightnessValue | Returns BrightnessValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.
public Method | getCFAPattern | Returns CFAPattern Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
public Method | getColorSpace | Returns ColorSpace Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ColorSpace tag. The tag specifies the color space information.
public Method | getComponentsConfiguration | Returns ComponentsConfiguration Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.
public Method | getCompressedBitsPerPixel | Returns CompressedBitsPerPixel Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | getCompression | Returns Compression Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.
public Method | getContrast | Returns Contrast Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.
public Method | getCopyright | Returns Copyright Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Copyright tag. The tag specifies the copyright notice.
public Method | getCustomRendered | Returns CustomRendered Tag value. This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. ImGearEXIFCustomRendered
public Method | getDateTime | Returns DateTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTime tag. The tag specifies the date and time of image creation.
public Method | getDateTimeDigitized | Returns DateTimeDigitized Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].
public Method | getDateTimeOriginal | Returns DateTimeOriginal Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.
public Method | getDeviceSettingDescription | Returns DeviceSettingDescription Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
public Method | getDigitalZoomRatio | Returns DigitalZoomRatio Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
public Method | getExifVersion | Returns ExifVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.
public Method | getExposureBiasValue | Returns ExposureBiasValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
public Method | getExposureIndex | Returns ExposureIndex Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.
public Method | getExposureMode | Returns ExposureMode Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.
public Method | getExposureProgram | Returns ExposureProgram Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.
public Method | getExposureTime | Returns ExposureTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.
public Method | getFileSource | Returns FileSource Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FileSource tag. The tag indicates the image source.
public Method | getFlash | Returns Flash Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.
public Method | getFlashEnergy | Returns FlashEnergy Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
public Method | getFlashPixVersion | Returns FlashPixVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.
public Method | getFNumber | Returns FNumber Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FNumber tag. The tag specifies the F number.
public Method | getFocalLength | Returns FocalLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
public Method | getFocalLengthIn35mmFilm | Returns FocalLengthIn35mmFilm Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | getFocalPlaneResolutionUnit | Returns FocalPlaneResolutionUnit Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.
public Method | getFocalPlaneXResolution | Returns FocalPlaneXResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | getFocalPlaneYResolution | Returns FocalPlaneYResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | getGainControl | Returns GainControl Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.
public Method | getGPS | Returns GPS Tag value. This method accesses the GPS IFD metadata. ImGearEXIFGPSMetadata
public Method | getImageDescription | Returns ImageDescription Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageDescription tag. The tag describes the subject of the image.
public Method | getImageLength | Returns ImageLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.
public Method | getImageWidth | Returns ImageWidth Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.
public Method | getInterColorProfile | Returns InterColorProfile Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.
public Method | getInteroperability | Returns Interoperability Tag value. This method provides access to the EXIF Interoperability IFD metadata. ImGearEXIFInteropMetadata
public Method | getISOSpeedRatings | Returns ISOSpeedRatings Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
public Method | getJPEGInterchangeFormat | Returns JPEGInterchangeFormat Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.
public Method | getJPEGInterchangeFormatLength | Returns JPEGInterchangeFormatLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.
public Method | getLightSource | Returns LightSource Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the LightSource tag. The tag specifies the kind of light source.
public Method | getMake | Returns Make Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.
public Method | getMaxApertureValue | Returns MaxApertureValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
public Method | getMeteringMode | Returns MeteringMode Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MeteringMode tag. The tag specifies the metering mode.
public Method | getModel | Returns Model Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.
public Method | getOECF | Returns OECF Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
public Method | getOrientation | Returns Orientation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.
public Method | getPhotometricInterpretation | Returns PhotometricInterpretation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.
public Method | getPixelXDimension | Returns PixelXDimension Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | getPixelYDimension | Returns PixelYDimension Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | getPlanarConfig | Returns PlanarConfig Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.
public Method | getPrimaryChromaticities | Returns PrimaryChromaticities Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.
public Method | getReferenceBlackWhite | Returns ReferenceBlackWhite Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.
public Method | getRelatedSoundFile | Returns RelatedSoundFile Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.
public Method | getResolutionUnit | Returns ResolutionUnit Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.
public Method | getRowsPerStrip | Returns RowsPerStrip Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.
public Method | getSamplesPerPixel | Returns SamplesPerPixel Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.
public Method | getSaturation | Returns Saturation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.
public Method | getSceneCaptureType | Returns SceneCaptureType Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.
public Method | getSceneType | Returns SceneType Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
public Method | getSensingMethod | Returns SensingMethod Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.
public Method | getSharpness | Returns Sharpness Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.
public Method | getShutterSpeedValue | Returns ShutterSpeedValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.
public Method | getSoftware | Returns Software Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.
public Method | getSpatialFrequencyResponse | Returns SpatialFrequencyResponse Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
public Method | getSpectralSensitivity | Returns SpectralSensitivity Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.
public Method | getStripByteCounts | Returns StripByteCounts Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.
public Method | getStripOffsets | Returns StripOffsets Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.
public Method | getSubjectArea | Returns SubjectArea Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.
public Method | getSubjectDistance | Returns SubjectDistance Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.
public Method | getSubjectDistanceRange | Returns SubjectDistanceRange Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.
public Method | getSubjectLocation | Returns SubjectLocation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
public Method | getSubSecTime | Returns SubSecTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.
public Method | getSubSecTimeDigitized | Returns SubSecTimeDigitized Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.
public Method | getSubSecTimeOriginal | Returns SubSecTimeOriginal Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.
public Method | getTransferFunction | Returns TransferFunction Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
public Method | getUserComment | Returns UserComment Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.
public Method | getWhiteBalance | Returns WhiteBalance Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.
public Method | getWhitePoint | Returns WhitePoint Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.
public Method | getXResolution | Returns XResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.
public Method | getYCbCrCoefficients | Returns YCbCrCoefficients Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.
public Method | getYCbCrPositioning | Returns YCbCrPositioning Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.
public Method | getYCbCrSubSampling | Returns YCbCrSubSampling Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.
public Method | getYResolution | Returns YResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.
public Method | setApertureValue | Sets ApertureValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.
public Method | setArtist | Sets Artist Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Artist tag. The tag specifies the person who created the image.
public Method | setBitsPerSample | Sets BitsPerSample Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.
public Method | setBrightnessValue | Sets BrightnessValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.
public Method | setCFAPattern | Sets CFAPattern Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
public Method | setColorSpace | Sets ColorSpace Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ColorSpace tag. The tag specifies the color space information.
public Method | setComponentsConfiguration | Sets ComponentsConfiguration Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.
public Method | setCompressedBitsPerPixel | Sets CompressedBitsPerPixel Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | setCompression | Sets Compression Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.
public Method | setContrast | Sets Contrast Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.
public Method | setCopyright | Sets Copyright Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Copyright tag. The tag specifies the copyright notice.
public Method | setCustomRendered | Sets CustomRendered Tag value. This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. ImGearEXIFCustomRendered
public Method | setDateTime | Sets DateTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTime tag. The tag specifies the date and time of image creation.
public Method | setDateTimeDigitized | Sets DateTimeDigitized Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].
public Method | setDateTimeOriginal | Sets DateTimeOriginal Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.
public Method | setDeviceSettingDescription | Sets DeviceSettingDescription Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
public Method | setDigitalZoomRatio | Sets DigitalZoomRatio Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
public Method | setExifVersion | Sets ExifVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.
public Method | setExposureBiasValue | Sets ExposureBiasValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
public Method | setExposureIndex | Sets ExposureIndex Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.
public Method | setExposureMode | Sets ExposureMode Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.
public Method | setExposureProgram | Sets ExposureProgram Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.
public Method | setExposureTime | Sets ExposureTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.
public Method | setFileSource | Sets FileSource Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FileSource tag. The tag indicates the image source.
public Method | setFlash | Sets Flash Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.
public Method | setFlashEnergy | Sets FlashEnergy Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
public Method | setFlashPixVersion | Sets FlashPixVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.
public Method | setFNumber | Sets FNumber Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FNumber tag. The tag specifies the F number.
public Method | setFocalLength | Sets FocalLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
public Method | setFocalLengthIn35mmFilm | Sets FocalLengthIn35mmFilm Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | setFocalPlaneResolutionUnit | Sets FocalPlaneResolutionUnit Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.
public Method | setFocalPlaneXResolution | Sets FocalPlaneXResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | setFocalPlaneYResolution | Sets FocalPlaneYResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | setGainControl | Sets GainControl Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.
public Method | setGPS | Sets GPS Tag value. This method accesses the GPS IFD metadata. ImGearEXIFGPSMetadata
public Method | setImageDescription | Sets ImageDescription Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageDescription tag. The tag describes the subject of the image.
public Method | setImageLength | Sets ImageLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.
public Method | setImageWidth | Sets ImageWidth Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.
public Method | setInterColorProfile | Sets InterColorProfile Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.
public Method | setInteroperability | Sets Interoperability Tag value. This method provides access to the EXIF Interoperability IFD metadata. ImGearEXIFInteropMetadata
public Method | setISOSpeedRatings | Sets ISOSpeedRatings Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
public Method | setJPEGInterchangeFormat | Sets JPEGInterchangeFormat Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.
public Method | setJPEGInterchangeFormatLength | Sets JPEGInterchangeFormatLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.
public Method | setLightSource | Sets LightSource Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the LightSource tag. The tag specifies the kind of light source.
public Method | setMake | Sets Make Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.
public Method | setMaxApertureValue | Sets MaxApertureValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
public Method | setMeteringMode | Sets MeteringMode Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MeteringMode tag. The tag specifies the metering mode.
public Method | setModel | Sets Model Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.
public Method | setOECF | Sets OECF Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
public Method | setOrientation | Sets Orientation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.
public Method | setPhotometricInterpretation | Sets PhotometricInterpretation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.
public Method | setPixelXDimension | Sets PixelXDimension Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | setPixelYDimension | Sets PixelYDimension Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | setPlanarConfig | Sets PlanarConfig Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.
public Method | setPrimaryChromaticities | Sets PrimaryChromaticities Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.
public Method | setReferenceBlackWhite | Sets ReferenceBlackWhite Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.
public Method | setRelatedSoundFile | Sets RelatedSoundFile Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.
public Method | setResolutionUnit | Sets ResolutionUnit Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.
public Method | setRowsPerStrip | Sets RowsPerStrip Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.
public Method | setSamplesPerPixel | Sets SamplesPerPixel Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.
public Method | setSaturation | Sets Saturation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.
public Method | setSceneCaptureType | Sets SceneCaptureType Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.
public Method | setSceneType | Sets SceneType Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
public Method | setSensingMethod | Sets SensingMethod Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.
public Method | setSharpness | Sets Sharpness Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.
public Method | setShutterSpeedValue | Sets ShutterSpeedValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.
public Method | setSoftware | Sets Software Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.
public Method | setSpatialFrequencyResponse | Sets SpatialFrequencyResponse Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
public Method | setSpectralSensitivity | Sets SpectralSensitivity Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.
public Method | setStripByteCounts | Sets StripByteCounts Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.
public Method | setStripOffsets | Sets StripOffsets Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.
public Method | setSubjectArea | Sets SubjectArea Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.
public Method | setSubjectDistance | Sets SubjectDistance Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.
public Method | setSubjectDistanceRange | Sets SubjectDistanceRange Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.
public Method | setSubjectLocation | Sets SubjectLocation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
public Method | setSubSecTime | Sets SubSecTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.
public Method | setSubSecTimeDigitized | Sets SubSecTimeDigitized Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.
public Method | setSubSecTimeOriginal | Sets SubSecTimeOriginal Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.
public Method | setTransferFunction | Sets TransferFunction Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
public Method | setUserComment | Sets UserComment Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.
public Method | setWhiteBalance | Sets WhiteBalance Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.
public Method | setWhitePoint | Sets WhitePoint Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.
public Method | setXResolution | Sets XResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.
public Method | setYCbCrCoefficients | Sets YCbCrCoefficients Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.
public Method | setYCbCrPositioning | Sets YCbCrPositioning Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.
public Method | setYCbCrSubSampling | Sets YCbCrSubSampling Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.
public Method | setYResolution | Sets YResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.
Top

See Also

Reference

ImGearEXIFMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFMetadata Constructor
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : ImGearEXIFMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearEXIFMetadata class.

Syntax

public ImGearEXIFMetadata()

Return Value

The new instance of ImGearEXIFMetadata class.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEXIFMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.exif Package : ImGearEXIFMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearEXIFMetadata members.

Public Methods

 | Name | Description
public Method | getApertureValue | Returns ApertureValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.
public Method | getArtist | Returns Artist Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Artist tag. The tag specifies the person who created the image.
public Method | getBitsPerSample | Returns BitsPerSample Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.
public Method | getBrightnessValue | Returns BrightnessValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.
public Method | getCFAPattern | Returns CFAPattern Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
public Method | getColorSpace | Returns ColorSpace Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ColorSpace tag. The tag specifies the color space information.
public Method | getComponentsConfiguration | Returns ComponentsConfiguration Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.
public Method | getCompressedBitsPerPixel | Returns CompressedBitsPerPixel Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | getCompression | Returns Compression Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.
public Method | getContrast | Returns Contrast Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.
public Method | getCopyright | Returns Copyright Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Copyright tag. The tag specifies the copyright notice.
public Method | getCustomRendered | Returns CustomRendered Tag value. This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. ImGearEXIFCustomRendered
public Method | getDateTime | Returns DateTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTime tag. The tag specifies the date and time of image creation.
public Method | getDateTimeDigitized | Returns DateTimeDigitized Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].
public Method | getDateTimeOriginal | Returns DateTimeOriginal Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.
public Method | getDeviceSettingDescription | Returns DeviceSettingDescription Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
public Method | getDigitalZoomRatio | Returns DigitalZoomRatio Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
public Method | getExifVersion | Returns ExifVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.
public Method | getExposureBiasValue | Returns ExposureBiasValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
public Method | getExposureIndex | Returns ExposureIndex Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.
public Method | getExposureMode | Returns ExposureMode Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.
public Method | getExposureProgram | Returns ExposureProgram Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.
public Method | getExposureTime | Returns ExposureTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.
public Method | getFileSource | Returns FileSource Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FileSource tag. The tag indicates the image source.
public Method | getFlash | Returns Flash Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.
public Method | getFlashEnergy | Returns FlashEnergy Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
public Method | getFlashPixVersion | Returns FlashPixVersion Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.
public Method | getFNumber | Returns FNumber Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FNumber tag. The tag specifies the F number.
public Method | getFocalLength | Returns FocalLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
public Method | getFocalLengthIn35mmFilm | Returns FocalLengthIn35mmFilm Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | getFocalPlaneResolutionUnit | Returns FocalPlaneResolutionUnit Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.
public Method | getFocalPlaneXResolution | Returns FocalPlaneXResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | getFocalPlaneYResolution | Returns FocalPlaneYResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | getGainControl | Returns GainControl Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.
public Method | getGPS | Returns GPS Tag value. This method accesses the GPS IFD metadata. ImGearEXIFGPSMetadata
public Method | getImageDescription | Returns ImageDescription Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageDescription tag. The tag describes the subject of the image.
public Method | getImageLength | Returns ImageLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.
public Method | getImageWidth | Returns ImageWidth Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.
public Method | getInterColorProfile | Returns InterColorProfile Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.
public Method | getInteroperability | Returns Interoperability Tag value. This method provides access to the EXIF Interoperability IFD metadata. ImGearEXIFInteropMetadata
public Method | getISOSpeedRatings | Returns ISOSpeedRatings Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
public Method | getJPEGInterchangeFormat | Returns JPEGInterchangeFormat Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.
public Method | getJPEGInterchangeFormatLength | Returns JPEGInterchangeFormatLength Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.
public Method | getLightSource | Returns LightSource Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the LightSource tag. The tag specifies the kind of light source.
public Method | getMake | Returns Make Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.
public Method | getMaxApertureValue | Returns MaxApertureValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
public Method | getMeteringMode | Returns MeteringMode Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MeteringMode tag. The tag specifies the metering mode.
public Method | getModel | Returns Model Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.
public Method | getOECF | Returns OECF Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
public Method | getOrientation | Returns Orientation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.
public Method | getPhotometricInterpretation | Returns PhotometricInterpretation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.
public Method | getPixelXDimension | Returns PixelXDimension Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | getPixelYDimension | Returns PixelYDimension Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | getPlanarConfig | Returns PlanarConfig Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.
public Method | getPrimaryChromaticities | Returns PrimaryChromaticities Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.
public Method | getReferenceBlackWhite | Returns ReferenceBlackWhite Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.
public Method | getRelatedSoundFile | Returns RelatedSoundFile Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.
public Method | getResolutionUnit | Returns ResolutionUnit Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.
public Method | getRowsPerStrip | Returns RowsPerStrip Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.
public Method | getSamplesPerPixel | Returns SamplesPerPixel Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.
public Method | getSaturation | Returns Saturation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.
public Method | getSceneCaptureType | Returns SceneCaptureType Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.
public Method | getSceneType | Returns SceneType Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
public Method | getSensingMethod | Returns SensingMethod Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.
public Method | getSharpness | Returns Sharpness Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.
public Method | getShutterSpeedValue | Returns ShutterSpeedValue Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.
public Method | getSoftware | Returns Software Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.
public Method | getSpatialFrequencyResponse | Returns SpatialFrequencyResponse Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
public Method | getSpectralSensitivity | Returns SpectralSensitivity Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.
public Method | getStripByteCounts | Returns StripByteCounts Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.
public Method | getStripOffsets | Returns StripOffsets Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.
public Method | getSubjectArea | Returns SubjectArea Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.
public Method | getSubjectDistance | Returns SubjectDistance Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.
public Method | getSubjectDistanceRange | Returns SubjectDistanceRange Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.
public Method | getSubjectLocation | Returns SubjectLocation Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
public Method | getSubSecTime | Returns SubSecTime Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.
public Method | getSubSecTimeDigitized | Returns SubSecTimeDigitized Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.
public Method | getSubSecTimeOriginal | Returns SubSecTimeOriginal Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.
public Method | getTransferFunction | Returns TransferFunction Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
public Method | getUserComment | Returns UserComment Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.
public Method | getWhiteBalance | Returns WhiteBalance Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.
public Method | getWhitePoint | Returns WhitePoint Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.
public Method | getXResolution | Returns XResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.
public Method | getYCbCrCoefficients | Returns YCbCrCoefficients Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.
public Method | getYCbCrPositioning | Returns YCbCrPositioning Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.
public Method | getYCbCrSubSampling | Returns YCbCrSubSampling Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.
public Method | getYResolution | Returns YResolution Tag value. Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.
public Method | setApertureValue | Sets ApertureValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.
public Method | setArtist | Sets Artist Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Artist tag. The tag specifies the person who created the image.
public Method | setBitsPerSample | Sets BitsPerSample Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.
public Method | setBrightnessValue | Sets BrightnessValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.
public Method | setCFAPattern | Sets CFAPattern Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
public Method | setColorSpace | Sets ColorSpace Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ColorSpace tag. The tag specifies the color space information.
public Method | setComponentsConfiguration | Sets ComponentsConfiguration Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.
public Method | setCompressedBitsPerPixel | Sets CompressedBitsPerPixel Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | setCompression | Sets Compression Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.
public Method | setContrast | Sets Contrast Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.
public Method | setCopyright | Sets Copyright Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Copyright tag. The tag specifies the copyright notice.
public Method | setCustomRendered | Sets CustomRendered Tag value. This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing. ImGearEXIFCustomRendered
public Method | setDateTime | Sets DateTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTime tag. The tag specifies the date and time of image creation.
public Method | setDateTimeDigitized | Sets DateTimeDigitized Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].
public Method | setDateTimeOriginal | Sets DateTimeOriginal Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.
public Method | setDeviceSettingDescription | Sets DeviceSettingDescription Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.
public Method | setDigitalZoomRatio | Sets DigitalZoomRatio Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
public Method | setExifVersion | Sets ExifVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.
public Method | setExposureBiasValue | Sets ExposureBiasValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.
public Method | setExposureIndex | Sets ExposureIndex Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.
public Method | setExposureMode | Sets ExposureMode Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.
public Method | setExposureProgram | Sets ExposureProgram Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.
public Method | setExposureTime | Sets ExposureTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.
public Method | setFileSource | Sets FileSource Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FileSource tag. The tag indicates the image source.
public Method | setFlash | Sets Flash Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.
public Method | setFlashEnergy | Sets FlashEnergy Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
public Method | setFlashPixVersion | Sets FlashPixVersion Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.
public Method | setFNumber | Sets FNumber Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FNumber tag. The tag specifies the F number.
public Method | setFocalLength | Sets FocalLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.
public Method | setFocalLengthIn35mmFilm | Sets FocalLengthIn35mmFilm Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | setFocalPlaneResolutionUnit | Sets FocalPlaneResolutionUnit Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.
public Method | setFocalPlaneXResolution | Sets FocalPlaneXResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | setFocalPlaneYResolution | Sets FocalPlaneYResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
public Method | setGainControl | Sets GainControl Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.
public Method | setGPS | Sets GPS Tag value. This method accesses the GPS IFD metadata. ImGearEXIFGPSMetadata
public Method | setImageDescription | Sets ImageDescription Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageDescription tag. The tag describes the subject of the image.
public Method | setImageLength | Sets ImageLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.
public Method | setImageWidth | Sets ImageWidth Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.
public Method | setInterColorProfile | Sets InterColorProfile Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.
public Method | setInteroperability | Sets Interoperability Tag value. This method provides access to the EXIF Interoperability IFD metadata. ImGearEXIFInteropMetadata
public Method | setISOSpeedRatings | Sets ISOSpeedRatings Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
public Method | setJPEGInterchangeFormat | Sets JPEGInterchangeFormat Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.
public Method | setJPEGInterchangeFormatLength | Sets JPEGInterchangeFormatLength Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.
public Method | setLightSource | Sets LightSource Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the LightSource tag. The tag specifies the kind of light source.
public Method | setMake | Sets Make Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.
public Method | setMaxApertureValue | Sets MaxApertureValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
public Method | setMeteringMode | Sets MeteringMode Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the MeteringMode tag. The tag specifies the metering mode.
public Method | setModel | Sets Model Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.
public Method | setOECF | Sets OECF Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
public Method | setOrientation | Sets Orientation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.
public Method | setPhotometricInterpretation | Sets PhotometricInterpretation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.
public Method | setPixelXDimension | Sets PixelXDimension Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | setPixelYDimension | Sets PixelYDimension Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.
public Method | setPlanarConfig | Sets PlanarConfig Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.
public Method | setPrimaryChromaticities | Sets PrimaryChromaticities Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.
public Method | setReferenceBlackWhite | Sets ReferenceBlackWhite Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.
public Method | setRelatedSoundFile | Sets RelatedSoundFile Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.
public Method | setResolutionUnit | Sets ResolutionUnit Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.
public Method | setRowsPerStrip | Sets RowsPerStrip Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.
public Method | setSamplesPerPixel | Sets SamplesPerPixel Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.
public Method | setSaturation | Sets Saturation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.
public Method | setSceneCaptureType | Sets SceneCaptureType Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.
public Method | setSceneType | Sets SceneType Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
public Method | setSensingMethod | Sets SensingMethod Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.
public Method | setSharpness | Sets Sharpness Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.
public Method | setShutterSpeedValue | Sets ShutterSpeedValue Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.
public Method | setSoftware | Sets Software Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.
public Method | setSpatialFrequencyResponse | Sets SpatialFrequencyResponse Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
public Method | setSpectralSensitivity | Sets SpectralSensitivity Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.
public Method | setStripByteCounts | Sets StripByteCounts Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.
public Method | setStripOffsets | Sets StripOffsets Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.
public Method | setSubjectArea | Sets SubjectArea Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.
public Method | setSubjectDistance | Sets SubjectDistance Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.
public Method | setSubjectDistanceRange | Sets SubjectDistanceRange Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.
public Method | setSubjectLocation | Sets SubjectLocation Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.
public Method | setSubSecTime | Sets SubSecTime Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.
public Method | setSubSecTimeDigitized | Sets SubSecTimeDigitized Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.
public Method | setSubSecTimeOriginal | Sets SubSecTimeOriginal Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.
public Method | setTransferFunction | Sets TransferFunction Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
public Method | setUserComment | Sets UserComment Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.
public Method | setWhiteBalance | Sets WhiteBalance Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.
public Method | setWhitePoint | Sets WhitePoint Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.
public Method | setXResolution | Sets XResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.
public Method | setYCbCrCoefficients | Sets YCbCrCoefficients Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.
public Method | setYCbCrPositioning | Sets YCbCrPositioning Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.
public Method | setYCbCrSubSampling | Sets YCbCrSubSampling Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.
public Method | setYResolution | Sets YResolution Tag value. Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise. This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.
Top

See Also

Reference

ImGearEXIFMetadata Class
com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

getApertureValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getApertureValue Method

Glossary Item Box

Returns ApertureValue Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.

Syntax

public ImGearRationalUInt getApertureValue()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getArtist Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getArtist Method

Glossary Item Box

Returns Artist Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

Syntax

public java.lang.String getArtist()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getBitsPerSample Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getBitsPerSample Method

Glossary Item Box

Returns BitsPerSample Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.

Syntax

public int[] getBitsPerSample()

Return Value

Unsigned short array. *

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getBrightnessValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getBrightnessValue Method

Glossary Item Box

Returns BrightnessValue Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.

Syntax

public ImGearRationalInt getBrightnessValue()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getCFAPattern Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getCFAPattern Method

Glossary Item Box

Returns CFAPattern Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.

Syntax

public byte[] getCFAPattern()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getColorSpace Method

Glossary Item Box

Returns ColorSpace Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorSpace tag. The tag specifies the color space information.

Syntax

public ImGearEXIFColorSpace getColorSpace()

Return Value

Nullable (boxed) ImGearEXIFColorSpace enumeration value. *

ImGearEXIFColorSpace

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getComponentsConfiguration Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getComponentsConfiguration Method

Glossary Item Box

Returns ComponentsConfiguration Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.

Syntax

public byte[] getComponentsConfiguration()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getCompressedBitsPerPixel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getCompressedBitsPerPixel Method

Glossary Item Box

Returns CompressedBitsPerPixel Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.

Syntax

public ImGearRationalUInt getCompressedBitsPerPixel()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getCompression Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getCompression Method

Glossary Item Box

Returns Compression Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Syntax

public ImGearTIFFCompression getCompression()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFCompression enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFCompression

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getContrast Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getContrast Method

Glossary Item Box

Returns Contrast Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.

Syntax

public ImGearEXIFContrastMode getContrast()

Return Value

Nullable (boxed) ImGearEXIFContrastMode enumeration value. *

ImGearEXIFContrastMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getCopyright Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getCopyright Method

Glossary Item Box

Returns Copyright Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice.

Syntax

public java.lang.String getCopyright()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getCustomRendered Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getCustomRendered Method

Glossary Item Box

Returns CustomRendered Tag value.

This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing.

ImGearEXIFCustomRendered

Syntax

public ImGearEXIFCustomRendered getCustomRendered()

Return Value

Nullable (boxed) ImGearEXIFCustomRendered enumeration value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getDateTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getDateTime Method

Glossary Item Box

Returns DateTime Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTime tag. The tag specifies the date and time of image creation.

Syntax

public java.lang.String getDateTime()

Return Value

String value. *

See TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getDateTimeDigitized Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getDateTimeDigitized Method

Glossary Item Box

Returns DateTimeDigitized Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].

Syntax

public java.lang.String getDateTimeDigitized()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getDateTimeOriginal Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getDateTimeOriginal Method

Glossary Item Box

Returns DateTimeOriginal Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.

Syntax

public java.lang.String getDateTimeOriginal()

Return Value

System.DateTime value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getDeviceSettingDescription Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getDeviceSettingDescription Method

Glossary Item Box

Returns DeviceSettingDescription Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.

Syntax

public byte[] getDeviceSettingDescription()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getDigitalZoomRatio Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getDigitalZoomRatio Method

Glossary Item Box

Returns DigitalZoomRatio Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.

Syntax

public ImGearRationalUInt getDigitalZoomRatio()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExifVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExifVersion Method

Glossary Item Box

Returns ExifVersion Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.

Syntax

public byte[] getExifVersion()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExposureBiasValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExposureBiasValue Method

Glossary Item Box

Returns ExposureBiasValue Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.

Syntax

public ImGearRationalInt getExposureBiasValue()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExposureIndex Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExposureIndex Method

Glossary Item Box

Returns ExposureIndex Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.

Syntax

public ImGearRationalUInt getExposureIndex()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExposureMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExposureMode Method

Glossary Item Box

Returns ExposureMode Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.

Syntax

public ImGearEXIFExposureMode getExposureMode()

Return Value

Nullable (boxed) ImGearEXIFExposureMode enumeration value. *

ImGearEXIFExposureMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExposureProgram Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExposureProgram Method

Glossary Item Box

Returns ExposureProgram Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.

Syntax

public ImGearEXIFExposureProgram getExposureProgram()

Return Value

Nullable (boxed) ImGearEXIFExposureProgram enumeration value. *

ImGearEXIFExposureProgram

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getExposureTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getExposureTime Method

Glossary Item Box

Returns ExposureTime Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.

Syntax

public ImGearRationalUInt getExposureTime()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFileSource Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFileSource Method

Glossary Item Box

Returns FileSource Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FileSource tag. The tag indicates the image source.

Syntax

public ImGearEXIFFileSource getFileSource()

Return Value

Nullable (boxed) ImGearEXIFFileSource enumeration value. *

ImGearEXIFFileSource

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFlash Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFlash Method

Glossary Item Box

Returns Flash Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.

Syntax

public java.lang.int getFlash()

Return Value

Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFlashEnergy Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFlashEnergy Method

Glossary Item Box

Returns FlashEnergy Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).

Syntax

public ImGearRationalUInt getFlashEnergy()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFlashPixVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFlashPixVersion Method

Glossary Item Box

Returns FlashPixVersion Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.

Syntax

public byte[] getFlashPixVersion()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFNumber Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFNumber Method

Glossary Item Box

Returns FNumber Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FNumber tag. The tag specifies the F number.

Syntax

public ImGearRationalUInt getFNumber()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFocalLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFocalLength Method

Glossary Item Box

Returns FocalLength Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.

Syntax

public ImGearRationalUInt getFocalLength()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFocalLengthIn35mmFilm Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFocalLengthIn35mmFilm Method

Glossary Item Box

Returns FocalLengthIn35mmFilm Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Syntax

public java.lang.int getFocalLengthIn35mmFilm()

Return Value

Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFocalPlaneResolutionUnit Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFocalPlaneResolutionUnit Method

Glossary Item Box

Returns FocalPlaneResolutionUnit Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.

Syntax

public ImGearTIFFResolutionUnit getFocalPlaneResolutionUnit()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFocalPlaneXResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFocalPlaneXResolution Method

Glossary Item Box

Returns FocalPlaneXResolution Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.

Syntax

public ImGearRationalUInt getFocalPlaneXResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getFocalPlaneYResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getFocalPlaneYResolution Method

Glossary Item Box

Returns FocalPlaneYResolution Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.

Syntax

public ImGearRationalUInt getFocalPlaneYResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getGainControl Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getGainControl Method

Glossary Item Box

Returns GainControl Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.

Syntax

public ImGearEXIFGainControl getGainControl()

Return Value

Nullable (boxed) ImGearEXIFGainControl enumeration value. *

ImGearEXIFGainControl

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getGPS Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getGPS Method

Glossary Item Box

Returns GPS Tag value.

This method accesses the GPS IFD metadata.

ImGearEXIFGPSMetadata

Syntax

public ImGearEXIFGPSMetadata getGPS()

Return Value

ImGearEXIFGPSMetadata class value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getImageDescription Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getImageDescription Method

Glossary Item Box

Returns ImageDescription Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

Syntax

public java.lang.String getImageDescription()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getImageLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getImageLength Method

Glossary Item Box

Returns ImageLength Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Syntax

public java.lang.long getImageLength()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getImageWidth Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getImageWidth Method

Glossary Item Box

Returns ImageWidth Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.

Syntax

public java.lang.long getImageWidth()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getInterColorProfile Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getInterColorProfile Method

Glossary Item Box

Returns InterColorProfile Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Syntax

public byte[] getInterColorProfile()

Return Value

Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getInteroperability Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getInteroperability Method

Glossary Item Box

Returns Interoperability Tag value.

This method provides access to the EXIF Interoperability IFD metadata.

ImGearEXIFInteropMetadata

Syntax

public ImGearEXIFInteropMetadata getInteroperability()

Return Value

ImGearEXIFInteropMetadata class value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getISOSpeedRatings Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getISOSpeedRatings Method

Glossary Item Box

Returns ISOSpeedRatings Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.

Syntax

public int[] getISOSpeedRatings()

Return Value

Array of ushort values. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getJPEGInterchangeFormat Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getJPEGInterchangeFormat Method

Glossary Item Box

Returns JPEGInterchangeFormat Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Syntax

public java.lang.long getJPEGInterchangeFormat()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getJPEGInterchangeFormatLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getJPEGInterchangeFormatLength Method

Glossary Item Box

Returns JPEGInterchangeFormatLength Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Syntax

public java.lang.long getJPEGInterchangeFormatLength()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getLightSource Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getLightSource Method

Glossary Item Box

Returns LightSource Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LightSource tag. The tag specifies the kind of light source.

Syntax

public ImGearEXIFLightSource getLightSource()

Return Value

Nullable (boxed) ImGearEXIFLightSource enumeration value. *

ImGearEXIFLightSource

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getMake Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getMake Method

Glossary Item Box

Returns Make Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Syntax

public java.lang.String getMake()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getMaxApertureValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getMaxApertureValue Method

Glossary Item Box

Returns MaxApertureValue Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.

Syntax

public ImGearRationalUInt getMaxApertureValue()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getMeteringMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getMeteringMode Method

Glossary Item Box

Returns MeteringMode Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MeteringMode tag. The tag specifies the metering mode.

Syntax

public ImGearEXIFMeteringMode getMeteringMode()

Return Value

Nullable (boxed) ImGearEXIFMeteringMode enumeration value. *

ImGearEXIFMeteringMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getModel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getModel Method

Glossary Item Box

Returns Model Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Syntax

public java.lang.String getModel()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getOECF Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getOECF Method

Glossary Item Box

Returns OECF Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.

Syntax

public byte[] getOECF()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getOrientation Method

Glossary Item Box

Returns Orientation Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Syntax

public ImGearTIFFOrientation getOrientation()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getPhotometricInterpretation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getPhotometricInterpretation Method

Glossary Item Box

Returns PhotometricInterpretation Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Syntax

public ImGearTIFFPhotoInterpretation getPhotometricInterpretation()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getPixelXDimension Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getPixelXDimension Method

Glossary Item Box

Returns PixelXDimension Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Syntax

public java.lang.long getPixelXDimension()

Return Value

Nullable (boxed) uint value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getPixelYDimension Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getPixelYDimension Method

Glossary Item Box

Returns PixelYDimension Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Syntax

public java.lang.long getPixelYDimension()

Return Value

Nullable (boxed) UInt value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getPlanarConfig Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getPlanarConfig Method

Glossary Item Box

Returns PlanarConfig Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Syntax

public ImGearTIFFPlanarConfig getPlanarConfig()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getPrimaryChromaticities Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getPrimaryChromaticities Method

Glossary Item Box

Returns PrimaryChromaticities Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.

Syntax

public ImGearRationalUInt[] getPrimaryChromaticities()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getReferenceBlackWhite Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getReferenceBlackWhite Method

Glossary Item Box

Returns ReferenceBlackWhite Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Syntax

public long[] getReferenceBlackWhite()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getRelatedSoundFile Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getRelatedSoundFile Method

Glossary Item Box

Returns RelatedSoundFile Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.

Syntax

public java.lang.String getRelatedSoundFile()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getResolutionUnit Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getResolutionUnit Method

Glossary Item Box

Returns ResolutionUnit Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Syntax

public ImGearTIFFResolutionUnit getResolutionUnit()

Return Value

Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getRowsPerStrip Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getRowsPerStrip Method

Glossary Item Box

Returns RowsPerStrip Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Syntax

public java.lang.long getRowsPerStrip()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSamplesPerPixel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSamplesPerPixel Method

Glossary Item Box

Returns SamplesPerPixel Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Syntax

public java.lang.int getSamplesPerPixel()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSaturation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSaturation Method

Glossary Item Box

Returns Saturation Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.

Syntax

public ImGearEXIFSaturationMode getSaturation()

Return Value

Nullable (boxed) ImGearEXIFSaturationMode enumeration value. *

ImGearEXIFSaturationMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSceneCaptureType Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSceneCaptureType Method

Glossary Item Box

Returns SceneCaptureType Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.

Syntax

public java.lang.int getSceneCaptureType()

Return Value

Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSceneType Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSceneType Method

Glossary Item Box

Returns SceneType Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.

Syntax

public ImGearEXIFSceneType getSceneType()

Return Value

Nullable (boxed) ImGearEXIFSceneType enumeration value. *

ImGearEXIFSceneType

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSensingMethod Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSensingMethod Method

Glossary Item Box

Returns SensingMethod Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.

Syntax

public ImGearEXIFSensingMethod getSensingMethod()

Return Value

Nullable (boxed) ImGearEXIFSensingMethod enumeration value. *

ImGearEXIFSensingMethod

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSharpness Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSharpness Method

Glossary Item Box

Returns Sharpness Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.

Syntax

public ImGearEXIFSharpnessMode getSharpness()

Return Value

Nullable (boxed) ImGearEXIFSharpnessMode enumeration value. *

ImGearEXIFSharpnessMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getShutterSpeedValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getShutterSpeedValue Method

Glossary Item Box

Returns ShutterSpeedValue Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.

Syntax

public ImGearRationalInt getShutterSpeedValue()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSoftware Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSoftware Method

Glossary Item Box

Returns Software Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Syntax

public java.lang.String getSoftware()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSpatialFrequencyResponse Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSpatialFrequencyResponse Method

Glossary Item Box

Returns SpatialFrequencyResponse Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.

Syntax

public byte[] getSpatialFrequencyResponse()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSpectralSensitivity Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSpectralSensitivity Method

Glossary Item Box

Returns SpectralSensitivity Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.

Syntax

public java.lang.String getSpectralSensitivity()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getStripByteCounts Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getStripByteCounts Method

Glossary Item Box

Returns StripByteCounts Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

Syntax

public long[] getStripByteCounts()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getStripOffsets Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getStripOffsets Method

Glossary Item Box

Returns StripOffsets Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Syntax

public long[] getStripOffsets()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubjectArea Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubjectArea Method

Glossary Item Box

Returns SubjectArea Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.

Syntax

public int[] getSubjectArea()

Return Value

Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubjectDistance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubjectDistance Method

Glossary Item Box

Returns SubjectDistance Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.

Syntax

public ImGearRationalUInt getSubjectDistance()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubjectDistanceRange Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubjectDistanceRange Method

Glossary Item Box

Returns SubjectDistanceRange Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.

Syntax

public ImGearEXIFSubjectDistanceRange getSubjectDistanceRange()

Return Value

Nullable (boxed) ImGearEXIFSubjectDistanceRange enumeration value. *

ImGearEXIFSubjectDistanceRange

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubjectLocation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubjectLocation Method

Glossary Item Box

Returns SubjectLocation Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.

Syntax

public int[] getSubjectLocation()

Return Value

Unsigned short] array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubSecTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubSecTime Method

Glossary Item Box

Returns SubSecTime Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.

Syntax

public java.lang.String getSubSecTime()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubSecTimeDigitized Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubSecTimeDigitized Method

Glossary Item Box

Returns SubSecTimeDigitized Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.

Syntax

public java.lang.String getSubSecTimeDigitized()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getSubSecTimeOriginal Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getSubSecTimeOriginal Method

Glossary Item Box

Returns SubSecTimeOriginal Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.

Syntax

public java.lang.String getSubSecTimeOriginal()

Return Value

String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getTransferFunction Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getTransferFunction Method

Glossary Item Box

Returns TransferFunction Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).

Syntax

public int[] getTransferFunction()

Return Value

Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getUserComment Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getUserComment Method

Glossary Item Box

Returns UserComment Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.

Syntax

public byte[] getUserComment()

Return Value

Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getWhiteBalance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getWhiteBalance Method

Glossary Item Box

Returns WhiteBalance Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.

Syntax

public ImGearEXIFWhiteBalanceMode getWhiteBalance()

Return Value

Nullable (boxed) ImGearEXIFWhiteBalanceMode enumeration value. *

ImGearEXIFWhiteBalanceMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getWhitePoint Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getWhitePoint Method

Glossary Item Box

Returns WhitePoint Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Syntax

public ImGearRationalUInt[] getWhitePoint()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getXResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getXResolution Method

Glossary Item Box

Returns XResolution Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Syntax

public ImGearRationalUInt getXResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getYCbCrCoefficients Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getYCbCrCoefficients Method

Glossary Item Box

Returns YCbCrCoefficients Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.

Syntax

public ImGearRationalUInt[] getYCbCrCoefficients()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getYCbCrPositioning Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getYCbCrPositioning Method

Glossary Item Box

Returns YCbCrPositioning Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Syntax

public java.lang.int getYCbCrPositioning()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getYCbCrSubSampling Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getYCbCrSubSampling Method

Glossary Item Box

Returns YCbCrSubSampling Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

Syntax

public int[] getYCbCrSubSampling()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

getYResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : getYResolution Method

Glossary Item Box

Returns YResolution Tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Syntax

public ImGearRationalUInt getYResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setApertureValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setApertureValue Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ApertureValue Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ApertureValue tag. The tag specifies the lens aperture. The unit is the APEX value.

Syntax

public void setApertureValue(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setArtist Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setArtist Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Artist Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

Syntax

public void setArtist(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setBitsPerSample Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setBitsPerSample Method
value
Unsigned short array. *

Glossary Item Box

Sets BitsPerSample Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BitsPerSample tag. The tag specifies the number of bits per component.

Syntax

public void setBitsPerSample(
   int[] value
)

Parameters

value
Unsigned short array. *

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setBrightnessValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setBrightnessValue Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets BrightnessValue Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BrightnessValue tag. The tag specifies the value of brightness. The unit is the APEX value.

Syntax

public void setBrightnessValue(
   ImGearRationalInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setCFAPattern Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setCFAPattern Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets CFAPattern Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CFAPAttern tag. The tag indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.

Syntax

public void setCFAPattern(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setColorSpace Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setColorSpace Method
value
Nullable (boxed) ImGearEXIFColorSpace enumeration value. *

ImGearEXIFColorSpace

Glossary Item Box

Sets ColorSpace Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorSpace tag. The tag specifies the color space information.

Syntax

public void setColorSpace(
   ImGearEXIFColorSpace value
)

Parameters

value
Nullable (boxed) ImGearEXIFColorSpace enumeration value. *

ImGearEXIFColorSpace

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setComponentsConfiguration Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setComponentsConfiguration Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets ComponentsConfiguration Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ComponentsConfiguration tag. The tag specifies information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data, the data arrangement is given in the PhotometricInterpretation tag. However, since PhotometricInterpretation can only express the order of Y, Cb, and Cr, this tag is provided for cases when compressed data uses components other than Y, Cb, and Cr and to enable support of other sequences.

Syntax

public void setComponentsConfiguration(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setCompressedBitsPerPixel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setCompressedBitsPerPixel Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets CompressedBitsPerPixel Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CompressedBitsPerPixel tag. The tag specifies information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.

Syntax

public void setCompressedBitsPerPixel(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setCompression Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setCompression Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFCompression enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFCompression

Glossary Item Box

Sets Compression Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Syntax

public void setCompression(
   ImGearTIFFCompression value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFCompression enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFCompression

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setContrast Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setContrast Method
value
Nullable (boxed) ImGearEXIFContrastMode enumeration value. *

ImGearEXIFContrastMode

Glossary Item Box

Sets Contrast Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contrast tag. The tag indicates the direction of contrast processing applied by the camera when the image was shot.

Syntax

public void setContrast(
   ImGearEXIFContrastMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFContrastMode enumeration value. *

ImGearEXIFContrastMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setCopyright Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setCopyright Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Copyright Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice.

Syntax

public void setCopyright(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setCustomRendered Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setCustomRendered Method
value
Nullable (boxed) ImGearEXIFCustomRendered enumeration value.

Glossary Item Box

Sets CustomRendered Tag value.

This method accesses the CustomRendered tag. This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing.

ImGearEXIFCustomRendered

Syntax

public void setCustomRendered(
   ImGearEXIFCustomRendered value
)

Parameters

value
Nullable (boxed) ImGearEXIFCustomRendered enumeration value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setDateTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setDateTime Method
value
String value. *

See TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets DateTime Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTime tag. The tag specifies the date and time of image creation.

Syntax

public void setDateTime(
   java.lang.String value
)

Parameters

value
String value. *

See TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setDateTimeDigitized Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setDateTimeDigitized Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets DateTimeDigitized Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTimeDigitized tag. The tag specifies the date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H].

Syntax

public void setDateTimeDigitized(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setDateTimeOriginal Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setDateTimeOriginal Method
value
System.DateTime value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets DateTimeOriginal Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateTimeOriginal tag. The tag specifies the date and time when the original image data was generated. For a DSC, the date and time the picture was taken are recorded. The format is "YYYY:MM:DD HH:MM:SS" with time shown in 24-hour format, and the date and time separated by one blank character [20.H]. When the date and time are unknown, all the character spaces except colons (":") may be filled with blank characters, or else the Interoperability field may be filled with blank characters.

Syntax

public void setDateTimeOriginal(
   java.lang.String value
)

Parameters

value
System.DateTime value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setDeviceSettingDescription Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setDeviceSettingDescription Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets DeviceSettingDescription Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DeviceSettingDescription tag. This tag indicates information on the picture-taking conditions of a particular camera model. The tag is used only to indicate the picture-taking conditions in the reader.

Syntax

public void setDeviceSettingDescription(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setDigitalZoomRatio Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setDigitalZoomRatio Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets DigitalZoomRatio Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalZoomRatio tag. This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.

Syntax

public void setDigitalZoomRatio(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExifVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExifVersion Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets ExifVersion Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExifVersion tag. The tag specifies the version of this standard supported.

Syntax

public void setExifVersion(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExposureBiasValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExposureBiasValue Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ExposureBiasValue Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureBiasValue tag. The tag specifies the exposure bias. The unit is the APEX value. Ordinarily it is given in the range of -99.99 to 99.99.

Syntax

public void setExposureBiasValue(
   ImGearRationalInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExposureIndex Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExposureIndex Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ExposureIndex Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureIndex tag. The tag indicates the exposure index selected on the camera or input device at the time the image is captured.

Syntax

public void setExposureIndex(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExposureMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExposureMode Method
value
Nullable (boxed) ImGearEXIFExposureMode enumeration value. *

ImGearEXIFExposureMode

Glossary Item Box

Sets ExposureMode Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureMode tag. This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.

Syntax

public void setExposureMode(
   ImGearEXIFExposureMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFExposureMode enumeration value. *

ImGearEXIFExposureMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExposureProgram Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExposureProgram Method
value
Nullable (boxed) ImGearEXIFExposureProgram enumeration value. *

ImGearEXIFExposureProgram

Glossary Item Box

Sets ExposureProgram Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureProgram tag. The tag specifies the class of the program used by the camera to set exposure when the picture is taken.

Syntax

public void setExposureProgram(
   ImGearEXIFExposureProgram value
)

Parameters

value
Nullable (boxed) ImGearEXIFExposureProgram enumeration value. *

ImGearEXIFExposureProgram

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setExposureTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setExposureTime Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ExposureTime Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExposureTime tag. The tag specifies exposure time, given in seconds.

Syntax

public void setExposureTime(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFileSource Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFileSource Method
value
Nullable (boxed) ImGearEXIFFileSource enumeration value. *

ImGearEXIFFileSource

Glossary Item Box

Sets FileSource Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FileSource tag. The tag indicates the image source.

Syntax

public void setFileSource(
   ImGearEXIFFileSource value
)

Parameters

value
Nullable (boxed) ImGearEXIFFileSource enumeration value. *

ImGearEXIFFileSource

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFlash Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFlash Method
value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets Flash Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Flash tag. This tag indicates the status of the flash when the image was shot.

Syntax

public void setFlash(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFlashEnergy Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFlashEnergy Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets FlashEnergy Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FlashEnergy tag. The tag indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).

Syntax

public void setFlashEnergy(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFlashPixVersion Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFlashPixVersion Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets FlashPixVersion Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FlashpixVersion tag. The tag specifies the Flashpix format version supported by a FPXR file.

Syntax

public void setFlashPixVersion(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFNumber Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFNumber Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets FNumber Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FNumber tag. The tag specifies the F number.

Syntax

public void setFNumber(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFocalLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFocalLength Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets FocalLength Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalLength tag. The tag specifies the actual focal length of the lens, in mm. Conversion is not made to the focal length of a 35 mm film camera.

Syntax

public void setFocalLength(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFocalLengthIn35mmFilm Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFocalLengthIn35mmFilm Method
value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets FocalLengthIn35mmFilm Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalLengthIn35mmFilm tag. This tag indicates the equivalent focal length, assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Syntax

public void setFocalLengthIn35mmFilm(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFocalPlaneResolutionUnit Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFocalPlaneResolutionUnit Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

Glossary Item Box

Sets FocalPlaneResolutionUnit Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneResolutionUnit tag. The tag indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution.

Syntax

public void setFocalPlaneResolutionUnit(
   ImGearTIFFResolutionUnit value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFocalPlaneXResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFocalPlaneXResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets FocalPlaneXResolution Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneXResolution tag. The tag indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.

Syntax

public void setFocalPlaneXResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setFocalPlaneYResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setFocalPlaneYResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets FocalPlaneYResolution Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FocalPlaneYResolution tag. The tag indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.

Syntax

public void setFocalPlaneYResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setGainControl Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setGainControl Method
value
Nullable (boxed) ImGearEXIFGainControl enumeration value. *

ImGearEXIFGainControl

Glossary Item Box

Sets GainControl Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GainControl tag. This tag indicates the degree of overall image gain adjustment.

Syntax

public void setGainControl(
   ImGearEXIFGainControl value
)

Parameters

value
Nullable (boxed) ImGearEXIFGainControl enumeration value. *

ImGearEXIFGainControl

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setGPS Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setGPS Method
value
ImGearEXIFGPSMetadata class value.

Glossary Item Box

Sets GPS Tag value.

This method accesses the GPS IFD metadata.

ImGearEXIFGPSMetadata

Syntax

public void setGPS(
   ImGearEXIFGPSMetadata value
)

Parameters

value
ImGearEXIFGPSMetadata class value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setImageDescription Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setImageDescription Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageDescription Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

Syntax

public void setImageDescription(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setImageLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setImageLength Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageLength Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Syntax

public void setImageLength(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setImageWidth Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setImageWidth Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageWidth Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of pixels per row.

Syntax

public void setImageWidth(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setInterColorProfile Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setInterColorProfile Method
value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets InterColorProfile Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Syntax

public void setInterColorProfile(
   byte[] value
)

Parameters

value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setInteroperability Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setInteroperability Method
value
ImGearEXIFInteropMetadata class value.

Glossary Item Box

Sets Interoperability Tag value.

This method provides access to the EXIF Interoperability IFD metadata.

ImGearEXIFInteropMetadata

Syntax

public void setInteroperability(
   ImGearEXIFInteropMetadata value
)

Parameters

value
ImGearEXIFInteropMetadata class value.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setISOSpeedRatings Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setISOSpeedRatings Method
value
Array of ushort values. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets ISOSpeedRatings Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ISOSpeedRatings tag. The tag indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.

Syntax

public void setISOSpeedRatings(
   int[] value
)

Parameters

value
Array of ushort values. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setJPEGInterchangeFormat Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setJPEGInterchangeFormat Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGInterchangeFormat Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Syntax

public void setJPEGInterchangeFormat(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setJPEGInterchangeFormatLength Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setJPEGInterchangeFormatLength Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGInterchangeFormatLength Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Syntax

public void setJPEGInterchangeFormatLength(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setLightSource Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setLightSource Method
value
Nullable (boxed) ImGearEXIFLightSource enumeration value. *

ImGearEXIFLightSource

Glossary Item Box

Sets LightSource Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LightSource tag. The tag specifies the kind of light source.

Syntax

public void setLightSource(
   ImGearEXIFLightSource value
)

Parameters

value
Nullable (boxed) ImGearEXIFLightSource enumeration value. *

ImGearEXIFLightSource

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setMake Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setMake Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Make Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Syntax

public void setMake(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setMaxApertureValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setMaxApertureValue Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets MaxApertureValue Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxApertureValue tag. The tag specifies the smallest F number of the lens. The unit is the APEX value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.

Syntax

public void setMaxApertureValue(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setMeteringMode Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setMeteringMode Method
value
Nullable (boxed) ImGearEXIFMeteringMode enumeration value. *

ImGearEXIFMeteringMode

Glossary Item Box

Sets MeteringMode Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MeteringMode tag. The tag specifies the metering mode.

Syntax

public void setMeteringMode(
   ImGearEXIFMeteringMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFMeteringMode enumeration value. *

ImGearEXIFMeteringMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setModel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setModel Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Model Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Syntax

public void setModel(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setOECF Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setOECF Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets OECF Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the OECF tag. The tag indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.

Syntax

public void setOECF(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setOrientation Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation

Glossary Item Box

Sets Orientation Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Syntax

public void setOrientation(
   ImGearTIFFOrientation value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setPhotometricInterpretation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setPhotometricInterpretation Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation

Glossary Item Box

Sets PhotometricInterpretation Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Syntax

public void setPhotometricInterpretation(
   ImGearTIFFPhotoInterpretation value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setPixelXDimension Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setPixelXDimension Method
value
Nullable (boxed) uint value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets PixelXDimension Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PixelXDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Syntax

public void setPixelXDimension(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setPixelYDimension Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setPixelYDimension Method
value
Nullable (boxed) UInt value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets PixelYDimension Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PixelYDimension tag. The tag specifies information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker.

Syntax

public void setPixelYDimension(
   java.lang.int value
)

Parameters

value
Nullable (boxed) UInt value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setPlanarConfig Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setPlanarConfig Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig

Glossary Item Box

Sets PlanarConfig Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Syntax

public void setPlanarConfig(
   ImGearTIFFPlanarConfig value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setPrimaryChromaticities Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setPrimaryChromaticities Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets PrimaryChromaticities Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies the chromaticities of the primaries of the image.

Syntax

public void setPrimaryChromaticities(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setReferenceBlackWhite Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setReferenceBlackWhite Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ReferenceBlackWhite Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Syntax

public void setReferenceBlackWhite(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setRelatedSoundFile Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setRelatedSoundFile Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets RelatedSoundFile Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RelatedSoundFile tag. This tag is used to record the name of an audio file related to the image data.

Syntax

public void setRelatedSoundFile(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setResolutionUnit Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setResolutionUnit Method
value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

Glossary Item Box

Sets ResolutionUnit Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Syntax

public void setResolutionUnit(
   ImGearTIFFResolutionUnit value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit enumeration value. *

com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setRowsPerStrip Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setRowsPerStrip Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets RowsPerStrip Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Syntax

public void setRowsPerStrip(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSamplesPerPixel Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSamplesPerPixel Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets SamplesPerPixel Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Syntax

public void setSamplesPerPixel(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSaturation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSaturation Method
value
Nullable (boxed) ImGearEXIFSaturationMode enumeration value. *

ImGearEXIFSaturationMode

Glossary Item Box

Sets Saturation Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Saturation tag. This tag indicates the direction of saturation processing applied by the camera when the image was shot.

Syntax

public void setSaturation(
   ImGearEXIFSaturationMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFSaturationMode enumeration value. *

ImGearEXIFSaturationMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSceneCaptureType Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSceneCaptureType Method
value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SceneCaptureType Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SceneCaptureType tag. This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.

Syntax

public void setSceneCaptureType(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSceneType Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSceneType Method
value
Nullable (boxed) ImGearEXIFSceneType enumeration value. *

ImGearEXIFSceneType

Glossary Item Box

Sets SceneType Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SceneType tag. The tag indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.

Syntax

public void setSceneType(
   ImGearEXIFSceneType value
)

Parameters

value
Nullable (boxed) ImGearEXIFSceneType enumeration value. *

ImGearEXIFSceneType

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSensingMethod Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSensingMethod Method
value
Nullable (boxed) ImGearEXIFSensingMethod enumeration value. *

ImGearEXIFSensingMethod

Glossary Item Box

Sets SensingMethod Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SensingMethod tag. The tag Indicates the image sensor type on the camera or input device.

Syntax

public void setSensingMethod(
   ImGearEXIFSensingMethod value
)

Parameters

value
Nullable (boxed) ImGearEXIFSensingMethod enumeration value. *

ImGearEXIFSensingMethod

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSharpness Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSharpness Method
value
Nullable (boxed) ImGearEXIFSharpnessMode enumeration value. *

ImGearEXIFSharpnessMode

Glossary Item Box

Sets Sharpness Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sharpness tag. This tag indicates the direction of sharpness processing applied by the camera when the image was shot.

Syntax

public void setSharpness(
   ImGearEXIFSharpnessMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFSharpnessMode enumeration value. *

ImGearEXIFSharpnessMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setShutterSpeedValue Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setShutterSpeedValue Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets ShutterSpeedValue Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ShutterSpeedValue tag. The tag specifies the shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.

Syntax

public void setShutterSpeedValue(
   ImGearRationalInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSoftware Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSoftware Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Software Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Syntax

public void setSoftware(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSpatialFrequencyResponse Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSpatialFrequencyResponse Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SpatialFrequencyResponse Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SpatialFrequencyResponse tag. The tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.

Syntax

public void setSpatialFrequencyResponse(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSpectralSensitivity Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSpectralSensitivity Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SpectralSensitivity Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SpectralSensitivity tag. This tag indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.

Syntax

public void setSpectralSensitivity(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setStripByteCounts Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setStripByteCounts Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets StripByteCounts Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

Syntax

public void setStripByteCounts(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setStripOffsets Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setStripOffsets Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets StripOffsets Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Syntax

public void setStripOffsets(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubjectArea Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubjectArea Method
value
Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SubjectArea Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectArea tag. This tag indicates the location and area of the main subject in the overall scene.

Syntax

public void setSubjectArea(
   int[] value
)

Parameters

value
Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubjectDistance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubjectDistance Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets SubjectDistance Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectDistance tag. The tag specifies the distance to the subject, given in meters. Note that if the numerator of the recorded value is FFFFFFFF.H, Infinity shall be indicated; and if the numerator is 0, Distance unknown shall be indicated.

Syntax

public void setSubjectDistance(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubjectDistanceRange Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubjectDistanceRange Method
value
Nullable (boxed) ImGearEXIFSubjectDistanceRange enumeration value. *

ImGearEXIFSubjectDistanceRange

Glossary Item Box

Sets SubjectDistanceRange Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectDistanceRange tag. The tag indicates the distance to the subject.

Syntax

public void setSubjectDistanceRange(
   ImGearEXIFSubjectDistanceRange value
)

Parameters

value
Nullable (boxed) ImGearEXIFSubjectDistanceRange enumeration value. *

ImGearEXIFSubjectDistanceRange

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubjectLocation Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubjectLocation Method
value
Unsigned short] array. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SubjectLocation Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubjectLocation tag. The tag indicates the location of the main subject in the scene. The value of this tag represents the pixel at the center of the main subject relative to the left edge, prior to rotation processing as per the Rotation tag. The first value indicates the X column number and second indicates the Y row number.

Syntax

public void setSubjectLocation(
   int[] value
)

Parameters

value
Unsigned short] array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubSecTime Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubSecTime Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SubSecTime Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTime tag. The tag is used to record fractions of seconds for the DateTime tag.

Syntax

public void setSubSecTime(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubSecTimeDigitized Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubSecTimeDigitized Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SubSecTimeDigitized Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTimeDigitized tag. The tag is used to record fractions of seconds for the DateTimeDigitized tag.

Syntax

public void setSubSecTimeDigitized(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setSubSecTimeOriginal Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setSubSecTimeOriginal Method
value
String value. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets SubSecTimeOriginal Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubsecTimeOriginal tag. The tag is used to record fractions of seconds for the DateTimeOriginal tag.

Syntax

public void setSubSecTimeOriginal(
   java.lang.String value
)

Parameters

value
String value. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setTransferFunction Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setTransferFunction Method
value
Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets TransferFunction Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferFunction tag. The tag specifies a transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).

Syntax

public void setTransferFunction(
   int[] value
)

Parameters

value
Unsigned short array. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setUserComment Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setUserComment Method
value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

Glossary Item Box

Sets UserComment Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UserComment tag. The tag contains keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.

Syntax

public void setUserComment(
   byte[] value
)

Parameters

value
Array of bytes. *

See the EXIF 2.2 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setWhiteBalance Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setWhiteBalance Method
value
Nullable (boxed) ImGearEXIFWhiteBalanceMode enumeration value. *

ImGearEXIFWhiteBalanceMode

Glossary Item Box

Sets WhiteBalance Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhiteBalance tag. The tag indicates the white balance mode set when the image was shot.

Syntax

public void setWhiteBalance(
   ImGearEXIFWhiteBalanceMode value
)

Parameters

value
Nullable (boxed) ImGearEXIFWhiteBalanceMode enumeration value. *

ImGearEXIFWhiteBalanceMode

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setWhitePoint Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setWhitePoint Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets WhitePoint Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Syntax

public void setWhitePoint(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setXResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setXResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets XResolution Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Syntax

public void setXResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setYCbCrCoefficients Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setYCbCrCoefficients Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets YCbCrCoefficients Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrCoefficients tag. The tag specifies the transformation from RGB to YCbCr image data.

Syntax

public void setYCbCrCoefficients(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setYCbCrPositioning Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setYCbCrPositioning Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets YCbCrPositioning Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Syntax

public void setYCbCrPositioning(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setYCbCrSubSampling Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setYCbCrSubSampling Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets YCbCrSubSampling Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

Syntax

public void setYCbCrSubSampling(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

setYResolution Method
com.accusoft.imagegear.formats.exif Package > ImGearEXIFMetadata Class : setYResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets YResolution Tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Syntax

public void setYResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearEXIFMetadata Class
ImGearEXIFMetadata Members


%%PageItemTitle%%

ImGearEXIFColorSpace Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFColorSpace Enumeration

Glossary Item Box

Represents EXIF color spaces.

Members

Member | Description
SRGB | Color space is sRGB.
Uncalibrated | Color space other than sRGB is used.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFColorSpace

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFContrastMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFContrastMode Enumeration

Glossary Item Box

Represents EXIF contrast modes.

Members

Member | Description
Hard | Hard mode.
Normal | Normal mode.
Soft | Soft mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFContrastMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFCustomRendered Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFCustomRendered Enumeration

Glossary Item Box

Represents EXIF custom rendered modes.

Members

Member | Description
CustomProcess | Custom process.
NormalProcess | Normal process.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFCustomRendered

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFExposureMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFExposureMode Enumeration

Glossary Item Box

Represents EXIF exposure modes.

Members

Member | Description
AutoBracket | Auto bracket.
AutoExposure | Auto exposure.
ManualExposure | Manual exposure.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFExposureMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFExposureProgram Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFExposureProgram Enumeration

Glossary Item Box

Represents EXIF exposure programs.

Members

Member | Description
ActionProgram | Action program (biased toward fast shutter speed).
AperturePriority | Aperture priority.
CreativeProgram | Creative program (biased toward depth of field).
LandscapeMode | Landscape mode (for landscape photos with the background in focus).
Manual | Manual program.
NormalProgram | Normal program.
PortraitMode | Portrait mode (for closeup photos with the background out of focus).
ShutterPriority | Shutter program.
Undefined | Undefined program.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFExposureProgram

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFFileSource Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFFileSource Enumeration

Glossary Item Box

Represents EXIF File Sources.

Members

Member | Description
DSC | Digital still camera.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFFileSource

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFFlashMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFFlashMode Enumeration

Glossary Item Box

Represents EXIF flash mode.

Members

Member | Description
AutoMode | Auto mode.
CompulsoryFlashFiring | Compulsory flash firing.
CompulsoryFlashSuppression | Compulsory flash suppression.
Unknown | Unknown mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFFlashMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFFlashReturn Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFFlashReturn Enumeration

Glossary Item Box

Represents EXIF flash return.

Members

Member | Description
NoStrobeReturnDetection | No strobe return detection.
StrobeReturnLightDetected | Strobe return light detected.
StrobeReturnLightNotDetected | Strobe return light not detected.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFFlashReturn

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGainControl Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGainControl Enumeration

Glossary Item Box

Represents EXIF gain controls.

Members

Member | Description
HighGainDown | High gain down.
HighGainUp | High gain up.
LowGainDown | Low gain down.
LowGainUp | Low gain up.
None | No gain control.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGainControl

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSAltitudeReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSAltitudeReference Enumeration

Glossary Item Box

Represents EXIF GPS altitude references.

Members

Member | Description
SeaLevel | The altitude reference is sea level.
SeaLevelReference | The altitude is below sea level.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSAltitudeReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSDifferential Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSDifferential Enumeration

Glossary Item Box

Represents EXIF GPS differentials.

Members

Member | Description
DifferentialCorrectionApplied | Differential correction applied.
WithoutDifferentialCorrection | Measurement without differential correction.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDifferential

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSDirectionReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSDirectionReference Enumeration

Glossary Item Box

Represents EXIF GPS direction references.

Members

Member | Description
Magnetic | Magnetic direction.
True | True direction.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDirectionReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSDistanceReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSDistanceReference Enumeration

Glossary Item Box

Represents EXIF GPS distance references.

Members

Member | Description
Kilometers | Kilometers distance reference.
Knots | Knots distance reference.
Miles | Miles distance reference.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDistanceReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSLatitudeReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSLatitudeReference Enumeration

Glossary Item Box

Represents EXIF GPS latitude references.

Members

Member | Description
North | North latitude reference.
South | South latitude reference.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSLatitudeReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSLongitudeReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSLongitudeReference Enumeration

Glossary Item Box

Represents EXIF GPS longitude references.

Members

Member | Description
East | East longitude reference.
West | West longitude reference.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSLongitudeReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSMeasureMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSMeasureMode Enumeration

Glossary Item Box

Represents EXIF GPS measure modes.

Members

Member | Description
Mode2D | Two-dimensional measurement.
Mode3D | Three-dimensional measurement.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSMeasureMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSSpeedReference Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSSpeedReference Enumeration

Glossary Item Box

Represents EXIF GPS speed reference modes.

Members

Member | Description
KilometersPerHour | Kilometers per hour.
Knots | Knots (1.87 km/h).
MilesPerHour | Miles per hour.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSSpeedReference

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFGPSStatus Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFGPSStatus Enumeration

Glossary Item Box

Represents EXIF GPS statuses.

Members

Member | Description
InProgress | Measurement is in progress.
Interoperability | Measurement is interoperability.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFGPSStatus

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFLightSource Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFLightSource Enumeration

Glossary Item Box

Represents EXIF light sources.

Members

Member | Description
CloudyWeather | Cloudy weather.
CoolWhiteFluorescent | Cool white fluorescent.
D50 | D50 source.
D55 | D55 source.
D65 | D65 source.
D75 | D75 source.
Daylight | Daylight source.
DaylightFluorescent | Daylight fluorescent.
DayWhiteFluorescent | Day white fluorescent.
FineWeather | Fine weather.
Flash | Flash source.
Fluorescent | Fluorescent source.
ISOStudioTungsten | ISO studio tungsten.
Other | Other light source.
Shade | Shade source.
StandardLightA | Standard light A.
StandardLightB | Standard light B.
StandardLightC | Standard light C.
Tungsten | Tungsten source.
Unknown | Unknown light source.
WhiteFluorescent | White fluorescent.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFLightSource

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFMeteringMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFMeteringMode Enumeration

Glossary Item Box

Represents EXIF Metering Modes.

Members

Member | Description
Average | Average metering mode.
CenterWeightedAverage | Center weighted average metering mode.
MultiSpot | MultiSpot metering mode.
Other | Other metering mode.
Partial | Partial metering mode.
Pattern | Pattern metering mode.
Spot | Spot metering mode.
Unknown | Unknown metering mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFMeteringMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSaturationMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSaturationMode Enumeration

Glossary Item Box

Represents EXIF saturation modes.

Members

Member | Description
High | High saturation mode.
Low | Low saturation mode.
Normal | Normal saturation mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSaturationMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSceneCaptureType Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSceneCaptureType Enumeration

Glossary Item Box

Represents EXIF scene capture types.

Members

Member | Description
Landscape | Landscape scene capture type.
NightScene | Night scene capture type.
Portrait | Portrait scene capture type.
Standard | Standard scene capture type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSceneCaptureType

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSceneType Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSceneType Enumeration

Glossary Item Box

Represents EXIF scene types.

Members

Member | Description
DirectlyPhotographedImage | Directly photographed image.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSceneType

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSensingMethod Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSensingMethod Enumeration

Glossary Item Box

Represents EXIF sensing methods.

Members

Member | Description
ColorSequentialAreaSensor | Color sequential area sensor.
ColorSequentialLinearSensor | Color sequential linear sensor.
OneChipColorAreaSensor | One chip color area sensor.
ThreeChipColorAreaSensor | Three chip color area sensor.
TrilinearSensor | Trilinear sensor.
TwoChipColorAreaSensor | Two chip color area sensor.
Undefined | Undefined sensing method.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSensingMethod

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSharpnessMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSharpnessMode Enumeration

Glossary Item Box

Represents EXIF sharpness modes.

Members

Member | Description
Hard | Hard mode.
Normal | Normal mode.
Soft | Soft mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSharpnessMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFSubjectDistanceRange Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFSubjectDistanceRange Enumeration

Glossary Item Box

Represents EXIF subject distance ranges.

Members

Member | Description
CloseView | Close view.
DistantView | Distant view.
Macro | Macro distance.
Unknown | Unknown distance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFSubjectDistanceRange

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%PageItemTitle%%

ImGearEXIFWhiteBalanceMode Enumeration
com.accusoft.imagegear.formats.exif Package : ImGearEXIFWhiteBalanceMode Enumeration

Glossary Item Box

Represents EXIF white balance modes.

Members

Member | Description
Auto | Auto mode.
Manual | Manual mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.exif.ImGearEXIFWhiteBalanceMode

See Also

Reference

com.accusoft.imagegear.formats.exif Package


%%ItemTitle%%

com.accusoft.imagegear.formats.iptc Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package contains classes, structures, and enumerations that provide simplified access to IPTC metadata.

Classes

Class | Description
ImGearIPTCAudioType | Represents IPTC Audio Type structure. This structure represents IPTC Audio Type structure, used in Audio Type DataSet (2:150).
ImGearIPTCColourRepresentation | Represents IPTC Colour Representation structure. This structure represents IPTC Colour Representation structure, used in Colour Representation DataSet (3:60).
ImGearIPTCImageType | Represents IPTC Image Type structure. This structure represents IPTC Image Type structure, used in Image Type DataSet (2:130).
ImGearIPTCMetadata | Provides simplified access to IPTC metadata.
ImGearIPTCObjectAttributeReference | Represents IPTC Object Attribute Reference structure. This structure represents IPTC Object Attribute Reference structure, used in the Object Attribute Reference DataSet (2:04).
ImGearIPTCObjectTypeReference | Represents IPTC Object Type Reference structure. This structure represents IPTC Object Type Reference structure, used in the Object Type Reference DataSet (2:03). The Object Type is used to distinguish between different types of objects within the IIM.
ImGearIPTCPictureNumber | Represents IPTC Picture Number structure. This structure represents IPTC Picture Number structure, used in the Picture Number DataSet (3:10). The picture number provides a universally unique reference to an image. For example, color images, when split with color components into multiple objects, i.e., envelopes, would carry the same Picture Number.
ImGearIPTCSubjectReference | Represents IPTC Subject Reference structure. This structure represents IPTC Subject Reference structure, used in the Subject Reference DataSet (2:12). The Subject Reference is a structured definition of the subject matter.
ImGearIPTCUNO | Represents IPTC UNO structure. This structure represents UNO structure, used in the UNO DataSet (1:100). The UNO (Unique Name of Object) provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Enumerations

Enumeration | Description
ImGearIPTCActionAdvised | Represents IPTC Advised Actions.
ImGearIPTCAudioChannelMode | Represents IPTC Audio Channel Modes.
ImGearIPTCAudioContentType | Represents IPTC Audio Content Types.
ImGearIPTCDataCompressionMethod | Represents IPTC Data Compression Methods.
ImGearIPTCExcursionTolerance | Represents IPTC Excursion Tolerance modes.
ImGearIPTCFileFormatID | Represents IPTC File Format IDs.
ImGearIPTCImageBuildUpStructure | Represents IPTC Image Build Up Structures.
ImGearIPTCImageColourMode | Represents IPTC Image Colour Modes.
ImGearIPTCImageComponentMode | Represents IPTC Image Component Modes.
ImGearIPTCImageOrientation | Represents IPTC Image Orientations.
ImGearIPTCImageRotation | Represents IPTC Image Rotations.
ImGearIPTCInterchangeColourSpace | Represents IPTC Interchange Colour Spaces.
ImGearIPTCObjectAttributeNumber | Represents IPTC Object Attribute Numbers.
ImGearIPTCObjectCycle | Represents IPTC Object Cycles.
ImGearIPTCObjectTypeNumber | Represents IPTC Object Type Numbers.
ImGearIPTCQuantisationMethod | Represents IPTC Quantisation Methods.
ImGearIPTCSamplingStructure | Represents IPTC Sampling Structures.
ImGearIPTCScanningDirection | Represents IPTC Scanning Directions.
ImGearIPTCSizeMode | Represents IPTC Size Modes.
ImGearIPTCSubjectReferenceNumber | Represents IPTC Subject Reference Numbers.
ImGearIPTCSupplementType | Represents IPTC Supplement Types.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.iptc Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata
com.accusoft.imagegear.formats.iptc.ImGearIPTCAudioType
com.accusoft.imagegear.formats.iptc.ImGearIPTCColourRepresentation
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageType
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectAttributeReference
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectTypeReference
com.accusoft.imagegear.formats.iptc.ImGearIPTCPictureNumber
com.accusoft.imagegear.formats.iptc.ImGearIPTCSubjectReference
com.accusoft.imagegear.formats.iptc.ImGearIPTCUNO

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearIPTCAudioType Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioType Class

Glossary Item Box

Represents IPTC Audio Type structure.

This structure represents IPTC Audio Type structure, used in Audio Type DataSet (2:150).

Object Model

ImGearIPTCAudioType ClassImGearIPTCAudioType Class

Syntax

public sealed class ImGearIPTCAudioType
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCAudioType

See Also

Reference

ImGearIPTCAudioType Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCAudioType Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioType Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCAudioType.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCAudioType Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | channelMode | Indicates the number of channels. ImGearIPTCAudioChannelMode enumeration value. This value indicates the number of channels in the objectdata. ImGearIPTCAudioChannelMode
public Field | contentType | Indicates exact type of audio contained in the current objectdata. ImGearIPTCAudioContentType enumeration value. This value indicates the exact type of audio contained in the current objectdata. ImGearIPTCAudioContentType
Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCAudioType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCAudioType Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCAudioType Class : ImGearIPTCAudioType Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCAudioType()

See Also

Reference

ImGearIPTCAudioType Class
ImGearIPTCAudioType Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCAudioType Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioType Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCAudioType members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCAudioType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCAudioType Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCAudioType clone()

See Also

Reference

ImGearIPTCAudioType Class
ImGearIPTCAudioType Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCAudioType Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCAudioType Class
ImGearIPTCAudioType Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCAudioType Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioType Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCAudioType members.

Public Fields

 | Name | Description
public Field | channelMode | Indicates the number of channels. ImGearIPTCAudioChannelMode enumeration value. This value indicates the number of channels in the objectdata. ImGearIPTCAudioChannelMode
public Field | contentType | Indicates exact type of audio contained in the current objectdata. ImGearIPTCAudioContentType enumeration value. This value indicates the exact type of audio contained in the current objectdata. ImGearIPTCAudioContentType
Top

See Also

Reference

ImGearIPTCAudioType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

channelMode Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCAudioType Class : channelMode Field

Glossary Item Box

Indicates the number of channels.

ImGearIPTCAudioChannelMode enumeration value.

This value indicates the number of channels in the objectdata.

ImGearIPTCAudioChannelMode

Syntax

public ImGearIPTCAudioChannelMode channelMode

Return Value

ImGearIPTCAudioChannelMode enumeration value.

See Also

Reference

ImGearIPTCAudioType Class
ImGearIPTCAudioType Members


%%PageItemTitle%%

contentType Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCAudioType Class : contentType Field

Glossary Item Box

Indicates exact type of audio contained in the current objectdata.

ImGearIPTCAudioContentType enumeration value.

This value indicates the exact type of audio contained in the current objectdata.

ImGearIPTCAudioContentType

Syntax

public ImGearIPTCAudioContentType contentType

Return Value

ImGearIPTCAudioContentType enumeration value.

See Also

Reference

ImGearIPTCAudioType Class
ImGearIPTCAudioType Members


%%PageItemTitle%%

ImGearIPTCColourRepresentation Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCColourRepresentation Class

Glossary Item Box

Represents IPTC Colour Representation structure.

This structure represents IPTC Colour Representation structure, used in Colour Representation DataSet (3:60).

Object Model

ImGearIPTCColourRepresentation ClassImGearIPTCColourRepresentation Class

Syntax

public sealed class ImGearIPTCColourRepresentation
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCColourRepresentation

See Also

Reference

ImGearIPTCColourRepresentation Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCColourRepresentation Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCColourRepresentation Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCColourRepresentation.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCColourRepresentation Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | buildUpStructure | Gives the build-up structure of the image. ImGearIPTCImageBuildUpStructure enumeration value. ImGearIPTCImageBuildUpStructure
public Field | numberOfComponents | Specifies the number of components. int value. This value specifies the number of components in the image. Allowed values are as follows: 0 - No Image 1 - Monochrome 3 - Three components 4 - Four components
Top

Public Methods

 | Name | Description
public Method | clone |
Top

See Also

Reference

ImGearIPTCColourRepresentation Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCColourRepresentation Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCColourRepresentation Class : ImGearIPTCColourRepresentation Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCColourRepresentation()

See Also

Reference

ImGearIPTCColourRepresentation Class
ImGearIPTCColourRepresentation Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCColourRepresentation Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCColourRepresentation Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCColourRepresentation members.

Public Methods

 | Name | Description
public Method | clone |
Top

See Also

Reference

ImGearIPTCColourRepresentation Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCColourRepresentation Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCColourRepresentation clone()

See Also

Reference

ImGearIPTCColourRepresentation Class
ImGearIPTCColourRepresentation Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCColourRepresentation Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCColourRepresentation Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCColourRepresentation members.

Public Fields

 | Name | Description
public Field | buildUpStructure | Gives the build-up structure of the image. ImGearIPTCImageBuildUpStructure enumeration value. ImGearIPTCImageBuildUpStructure
public Field | numberOfComponents | Specifies the number of components. int value. This value specifies the number of components in the image. Allowed values are as follows: 0 - No Image 1 - Monochrome 3 - Three components 4 - Four components
Top

See Also

Reference

ImGearIPTCColourRepresentation Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

buildUpStructure Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCColourRepresentation Class : buildUpStructure Field

Glossary Item Box

Gives the build-up structure of the image.

ImGearIPTCImageBuildUpStructure enumeration value. ImGearIPTCImageBuildUpStructure

Syntax

public ImGearIPTCImageBuildUpStructure buildUpStructure

Return Value

ImGearIPTCImageBuildUpStructure enumeration value.

See Also

Reference

ImGearIPTCColourRepresentation Class
ImGearIPTCColourRepresentation Members


%%PageItemTitle%%

numberOfComponents Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCColourRepresentation Class : numberOfComponents Field

Glossary Item Box

Specifies the number of components.

int value.

This value specifies the number of components in the image.

Allowed values are as follows:

0 - No Image

1 - Monochrome

3 - Three components

4 - Four components

Syntax

public int numberOfComponents

Return Value

int value.

See Also

Reference

ImGearIPTCColourRepresentation Class
ImGearIPTCColourRepresentation Members


%%PageItemTitle%%

ImGearIPTCImageType Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageType Class

Glossary Item Box

Represents IPTC Image Type structure.

This structure represents IPTC Image Type structure, used in Image Type DataSet (2:130).

Object Model

ImGearIPTCImageType ClassImGearIPTCImageType Class

Syntax

public sealed class ImGearIPTCImageType
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageType

See Also

Reference

ImGearIPTCImageType Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCImageType Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageType Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCImageType.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCImageType Constructor | Default constructor
Top

Public Fields

Name Description
public Field colour Indicates the exact content of the current objectdata in terms of colour composition.

ImGearIPTCImageColourMode enumeration value. ImGearIPTCImageColourMode

public Field component Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.

ImGearIPTCImageComponentMode enumeration value.

This value indicates one of the following:

  • Record 2 caption for a specific image
  • Number of components in an image, in single or multiple envelopes
  • The objectdata contains supplementary data to an image (as defined in the Digital Newsphoto Parameter Record DataSet 3:55).

ImGearIPTCImageComponentMode

Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCImageType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageType Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCImageType Class : ImGearIPTCImageType Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCImageType()

See Also

Reference

ImGearIPTCImageType Class
ImGearIPTCImageType Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCImageType Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageType Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCImageType members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCImageType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCImageType Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCImageType clone()

See Also

Reference

ImGearIPTCImageType Class
ImGearIPTCImageType Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCImageType Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCImageType Class
ImGearIPTCImageType Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCImageType Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageType Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCImageType members.

Public Fields

Name Description
public Field colour Indicates the exact content of the current objectdata in terms of colour composition.

ImGearIPTCImageColourMode enumeration value. ImGearIPTCImageColourMode

public Field component Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.

ImGearIPTCImageComponentMode enumeration value.

This value indicates one of the following:

  • Record 2 caption for a specific image
  • Number of components in an image, in single or multiple envelopes
  • The objectdata contains supplementary data to an image (as defined in the Digital Newsphoto Parameter Record DataSet 3:55).

ImGearIPTCImageComponentMode

Top

See Also

Reference

ImGearIPTCImageType Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

colour Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCImageType Class : colour Field

Glossary Item Box

Indicates the exact content of the current objectdata in terms of colour composition.

ImGearIPTCImageColourMode enumeration value. ImGearIPTCImageColourMode

Syntax

public ImGearIPTCImageColourMode colour

Return Value

ImGearIPTCImageColourMode enumeration value.

See Also

Reference

ImGearIPTCImageType Class
ImGearIPTCImageType Members


%%PageItemTitle%%

component Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCImageType Class : component Field

Glossary Item Box

Indicates the number of components in the image, or that the objectdata contains supplementary data or Record 2 caption.

ImGearIPTCImageComponentMode enumeration value.

This value indicates one of the following:

  • Record 2 caption for a specific image
  • Number of components in an image, in single or multiple envelopes
  • The objectdata contains supplementary data to an image (as defined in the Digital Newsphoto Parameter Record DataSet 3:55).

ImGearIPTCImageComponentMode

Syntax

public ImGearIPTCImageComponentMode component

Return Value

ImGearIPTCImageComponentMode enumeration value.

See Also

Reference

ImGearIPTCImageType Class
ImGearIPTCImageType Members


%%PageItemTitle%%

ImGearIPTCMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCMetadata Class

Glossary Item Box

Provides simplified access to IPTC metadata.

Object Model

ImGearIPTCMetadata ClassImGearIPTCActionAdvised EnumerationImGearIPTCAudioType ClassImGearIPTCColourRepresentation ClassImGearIPTCDataCompressionMethod EnumerationImGearIPTCExcursionTolerance EnumerationImGearIPTCFileFormatID EnumerationImGearIPTCImageOrientation EnumerationImGearIPTCImageRotation EnumerationImGearIPTCImageType ClassImGearIPTCInterchangeColourSpace EnumerationImGearIPTCObjectAttributeReference ClassImGearIPTCObjectCycle EnumerationImGearIPTCFileFormatID EnumerationImGearIPTCObjectTypeReference ClassImGearIPTCPictureNumber ClassImGearIPTCQuantisationMethod EnumerationImGearIPTCSamplingStructure EnumerationImGearIPTCScanningDirection EnumerationImGearIPTCSizeMode EnumerationImGearIPTCSubjectReference ClassImGearIPTCSupplementType EnumerationImGearIPTCUNO Class

Syntax

public class ImGearIPTCMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.iptc.ImGearIPTCMetadata

See Also

Reference

ImGearIPTCMetadata Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCMetadata Constructor | Initializes a new instance of the ImGearIPTCMetadata class.
Top

Public Methods

Name Description
public Method getActionAdvised Returns Action Advised IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

public Method getARMIdentifier Returns ARM Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

public Method getARMVersion Returns ARM Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

public Method getAudioDuration Returns Audio Duration IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

public Method getAudioOutcue Returns Audio Outcue IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getAudioSamplingRate Returns Audio Sampling Rate IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

public Method getAudioSamplingResolution Returns Audio Sampling Resolution IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

public Method getAudioType Returns Audio Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

public Method getBitsPerComponent Returns Bits Per Component IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

public Method getByLine Returns By Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getByLineTitle Returns By Line Title IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getCaption_Abstract Returns Caption/Abstract IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

public Method getCategory Returns Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

public Method getCity Returns City IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getCodedCharacterSet Returns Coded Character Set IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

public Method getColourCalibrationMatrixTable Returns Colour Calibration Matrix Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

public Method getColourPalette Returns Colour Palette IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

public Method getColourRepresentation Returns Colour Representation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

public Method getColourSequence Returns Colour Sequence IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

public Method getConfirmedObjectDataSize Returns Confirmed Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

public Method getContact Returns Contact IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method getContentLocationCode Returns Content Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

public Method getContentLocationName Returns Content Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getCopyrightNotice Returns Copyright Notice IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method getCountryPrimaryLocationCode Returns Country Primary Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

public Method getCountryPrimaryLocationName Returns Country Primary Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getCredit Returns Credit IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getDataCompressionMethod Returns Data Compression method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

public Method getDateCreated Returns Date Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

public Method getDateSent Returns Date Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

public Method getDestination Returns Destination IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

public Method getDigitalCreationDate Returns Digital Creation Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

public Method getDigitalCreationTime Returns Digital Creation Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method getEditorialUpdate Returns Editorial Update IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

public Method getEditStatus Returns Edit Status IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getEndPoints Returns End Points IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

public Method getEnvelopeNumber Returns Envelope Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

public Method getEnvelopePriority Returns Envelope Priority IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

public Method getExcursionTolerance Returns Excursion Tolerance IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

public Method getExpirationDate Returns Expiration Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

public Method getExpirationTime Returns Expiration Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

public Method getFileFormat Returns File Format IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

public Method getFileFormatVersion Returns File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

public Method getFixtureIdentifier Returns Fixture Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

public Method getGammaCompensatedValue Returns Gamma Compensated Value IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

public Method getHeadline Returns Headline IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

public Method getICCInputColourProfile Returns ICC Input Colour Profile IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

public Method getImageOrientation Returns Image Orientation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

public Method getImageRotation Returns Image Rotation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

public Method getImageType Returns Image Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

public Method getInterchangeColourSpace Returns Interchange Colour Space IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

public Method getKeywords Returns Keywords IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getLanguageIdentifier Returns Language Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

public Method getLookupTable Returns Lookup Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

public Method getMaximumDensityRange Returns Maximum Density Range IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

public Method getMaximumObjectDataSize Returns Maximum Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

public Method getMaxSubfileSize Returns Max Subfile Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

public Method getModelVersion Returns Model Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

public Method getNumberOfBitsPerSample Returns Number Of Bits Per Sample IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

public Method getNumberOfIndexEntries Returns Number Of Index Entries IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

public Method getNumberOfLines Returns Number Of Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

public Method getObjectAttributeReference Returns Object Attribute Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

public Method getObjectCycle Returns Object Cycle IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

public Method getObjectDataPreviewData Returns Object Data Preview Data IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

public Method getObjectDataPreviewFileFormat Returns ObjectData Preview File Format DataSet (2:200).

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

public Method getObjectDataPreviewFileFormatVersion Returns Object Data Preview File Format Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

public Method getObjectDataSizeAnnounced Returns Object Data Size Announced IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

public Method getObjectName Returns Object Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getObjectTypeReference Returns Object Type Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

public Method getOriginalTransmissionReference Returns Original Transmission Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getOriginatingProgram Returns Originating Program IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getPictureNumber Returns Picture Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

public Method getPixelSizeInScanningDirection Returns Pixel Size In Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

public Method getPixelSizePerpendicularToScanningDirection Returns Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

public Method getPixelsPerLine Returns Pixels Per Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

public Method getProductID Returns ProductID IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

public Method getProgramVersion Returns Program Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

public Method getProvinceState Returns Province State IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getQuantisationMethod Returns Quantisation method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

public Method getRasterizedCaption Returns Rasterized Caption IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

public Method getRecord2Version Returns Record2 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

public Method getRecord3Version Returns Record3 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

public Method getReferenceDate Returns Reference Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

public Method getReferenceNumber Returns Reference Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

public Method getReferenceService Returns Reference Service IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

public Method getReleaseDate Returns Release Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

public Method getReleaseTime Returns Release Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method getSamplingStructure Returns Sampling structure IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

public Method getScanningDirection Returns Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

public Method getServiceIdentifier Returns Service Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

public Method getSizeMode Returns Size Mode IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

public Method getSource Returns Source IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getSpecialInstructions Returns Special Instructions IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

public Method getSubjectReference Returns Subject Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

public Method getSublocation Returns Sublocation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getSupplementalCategory Returns Supplemental Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getSupplementType Returns Supplement Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

public Method getTimeCreated Returns Time Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

public Method getTimeSent Returns Time Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

public Method getUNO Returns UNO IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

public Method getUrgency Returns Urgency IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

public Method getWriter_Editor Returns Writer/Editor IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setActionAdvised Sets Action Advised IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

public Method setARMIdentifier Sets ARM Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

public Method setARMVersion Sets ARM Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

public Method setAudioDuration Sets Audio Duration IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

public Method setAudioOutcue Sets Audio Outcue IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setAudioSamplingRate Sets Audio Sampling Rate IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

public Method setAudioSamplingResolution Sets Audio Sampling Resolution IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

public Method setAudioType Sets Audio Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

public Method setBitsPerComponent Sets Bits Per Component IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

public Method setByLine Sets By Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setByLineTitle Sets By Line Title IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setCaption_Abstract Sets Caption/Abstract IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

public Method setCategory Sets Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

public Method setCity Sets City IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setCodedCharacterSet Sets Coded Character Set IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

public Method setColourCalibrationMatrixTable Sets Colour Calibration Matrix Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

public Method setColourPalette Sets Colour Palette IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

public Method setColourRepresentation Sets Colour Representation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

public Method setColourSequence Sets Colour Sequence IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

public Method setConfirmedObjectDataSize Sets Confirmed Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

public Method setContact Sets Contact IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method setContentLocationCode Sets Content Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

public Method setContentLocationName Sets Content Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setCopyrightNotice Sets Copyright Notice IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method setCountryPrimaryLocationCode Sets Country Primary Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

public Method setCountryPrimaryLocationName Sets Country Primary Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setCredit Sets Credit IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setDataCompressionMethod Sets Data Compression method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

public Method setDateCreated Sets Date Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

public Method setDateSent Sets Date Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

public Method setDestination Sets Destination IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

public Method setDigitalCreationDate Sets Digital Creation Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

public Method setDigitalCreationTime Sets Digital Creation Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method setEditorialUpdate Sets Editorial Update IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

public Method setEditStatus Sets Edit Status IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setEndPoints Sets End Points IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

public Method setEnvelopeNumber Sets Envelope Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

public Method setEnvelopePriority Sets Envelope Priority IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

public Method setExcursionTolerance Sets Excursion Tolerance IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

public Method setExpirationDate Sets Expiration Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

public Method setExpirationTime Sets Expiration Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

public Method setFileFormat Sets File Format IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

public Method setFileFormatVersion Sets File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

public Method setFixtureIdentifier Sets Fixture Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

public Method setGammaCompensatedValue Sets Gamma Compensated Value IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

public Method setHeadline Sets Headline IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

public Method setICCInputColourProfile Sets ICC Input Colour Profile IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

public Method setImageOrientation Sets Image Orientation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

public Method setImageRotation Sets Image Rotation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

public Method setImageType Sets Image Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

public Method setInterchangeColourSpace Sets Interchange Colour Space IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

public Method setKeywords Sets Keywords IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setLanguageIdentifier Sets Language Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

public Method setLookupTable Sets Lookup Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

public Method setMaximumDensityRange Sets Maximum Density Range IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

public Method setMaximumObjectDataSize Sets Maximum Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

public Method setMaxSubfileSize Sets Max Subfile Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

public Method setModelVersion Sets Model Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

public Method setNumberOfBitsPerSample Sets Number Of Bits Per Sample IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

public Method setNumberOfIndexEntries Sets Number Of Index Entries IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

public Method setNumberOfLines Sets Number Of Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

public Method setObjectAttributeReference Sets Object Attribute Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

public Method setObjectCycle Sets Object Cycle IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

public Method setObjectDataPreviewData Sets Object Data Preview Data IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

public Method setObjectDataPreviewFileFormat Sets ObjectData Preview File Format DataSet (2:200).

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

public Method setObjectDataPreviewFileFormatVersion Sets Object Data Preview File Format Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

public Method setObjectDataSizeAnnounced Sets Object Data Size Announced IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

public Method setObjectName Sets Object Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setObjectTypeReference Sets Object Type Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

public Method setOriginalTransmissionReference Sets Original Transmission Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setOriginatingProgram Sets Originating Program IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setPictureNumber Sets Picture Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

public Method setPixelSizeInScanningDirection Sets Pixel Size In Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

public Method setPixelSizePerpendicularToScanningDirection Sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

public Method setPixelsPerLine Sets Pixels Per Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

public Method setProductID Sets ProductID IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

public Method setProgramVersion Sets Program Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

public Method setProvinceState Sets Province State IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setQuantisationMethod Sets Quantisation method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

public Method setRasterizedCaption Sets Rasterized Caption IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

public Method setRecord2Version Sets Record2 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

public Method setRecord3Version Sets Record3 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

public Method setReferenceDate Sets Reference Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

public Method setReferenceNumber Sets Reference Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

public Method setReferenceService Sets Reference Service IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

public Method setReleaseDate Sets Release Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

public Method setReleaseTime Sets Release Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method setSamplingStructure Sets Sampling structure IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

public Method setScanningDirection Sets Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

public Method setServiceIdentifier Sets Service Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

public Method setSizeMode Sets Size Mode IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

public Method setSource Sets Source IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setSpecialInstructions Sets Special Instructions IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

public Method setSubjectReference Sets Subject Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

public Method setSublocation Sets Sublocation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setSupplementalCategory Sets Supplemental Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setSupplementType Sets Supplement Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

public Method setTimeCreated Sets Time Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

public Method setTimeSent Sets Time Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

public Method setUNO Sets UNO IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

public Method setUrgency Sets Urgency IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

public Method setWriter_Editor Sets Writer/Editor IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Top

See Also

Reference

ImGearIPTCMetadata Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCMetadata Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : ImGearIPTCMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearIPTCMetadata class.

Syntax

public ImGearIPTCMetadata()

Return Value

The new instance of ImGearIPTCMetadata class.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCMetadata members.

Public Methods

Name Description
public Method getActionAdvised Returns Action Advised IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

public Method getARMIdentifier Returns ARM Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

public Method getARMVersion Returns ARM Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

public Method getAudioDuration Returns Audio Duration IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

public Method getAudioOutcue Returns Audio Outcue IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getAudioSamplingRate Returns Audio Sampling Rate IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

public Method getAudioSamplingResolution Returns Audio Sampling Resolution IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

public Method getAudioType Returns Audio Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

public Method getBitsPerComponent Returns Bits Per Component IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

public Method getByLine Returns By Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getByLineTitle Returns By Line Title IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getCaption_Abstract Returns Caption/Abstract IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

public Method getCategory Returns Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

public Method getCity Returns City IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getCodedCharacterSet Returns Coded Character Set IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

public Method getColourCalibrationMatrixTable Returns Colour Calibration Matrix Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

public Method getColourPalette Returns Colour Palette IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

public Method getColourRepresentation Returns Colour Representation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

public Method getColourSequence Returns Colour Sequence IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

public Method getConfirmedObjectDataSize Returns Confirmed Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

public Method getContact Returns Contact IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method getContentLocationCode Returns Content Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

public Method getContentLocationName Returns Content Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getCopyrightNotice Returns Copyright Notice IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method getCountryPrimaryLocationCode Returns Country Primary Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

public Method getCountryPrimaryLocationName Returns Country Primary Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getCredit Returns Credit IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getDataCompressionMethod Returns Data Compression method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

public Method getDateCreated Returns Date Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

public Method getDateSent Returns Date Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

public Method getDestination Returns Destination IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

public Method getDigitalCreationDate Returns Digital Creation Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

public Method getDigitalCreationTime Returns Digital Creation Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method getEditorialUpdate Returns Editorial Update IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

public Method getEditStatus Returns Edit Status IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getEndPoints Returns End Points IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

public Method getEnvelopeNumber Returns Envelope Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

public Method getEnvelopePriority Returns Envelope Priority IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

public Method getExcursionTolerance Returns Excursion Tolerance IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

public Method getExpirationDate Returns Expiration Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

public Method getExpirationTime Returns Expiration Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

public Method getFileFormat Returns File Format IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

public Method getFileFormatVersion Returns File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

public Method getFixtureIdentifier Returns Fixture Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

public Method getGammaCompensatedValue Returns Gamma Compensated Value IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

public Method getHeadline Returns Headline IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

public Method getICCInputColourProfile Returns ICC Input Colour Profile IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

public Method getImageOrientation Returns Image Orientation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

public Method getImageRotation Returns Image Rotation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

public Method getImageType Returns Image Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

public Method getInterchangeColourSpace Returns Interchange Colour Space IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

public Method getKeywords Returns Keywords IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getLanguageIdentifier Returns Language Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

public Method getLookupTable Returns Lookup Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

public Method getMaximumDensityRange Returns Maximum Density Range IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

public Method getMaximumObjectDataSize Returns Maximum Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

public Method getMaxSubfileSize Returns Max Subfile Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

public Method getModelVersion Returns Model Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

public Method getNumberOfBitsPerSample Returns Number Of Bits Per Sample IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

public Method getNumberOfIndexEntries Returns Number Of Index Entries IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

public Method getNumberOfLines Returns Number Of Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

public Method getObjectAttributeReference Returns Object Attribute Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

public Method getObjectCycle Returns Object Cycle IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

public Method getObjectDataPreviewData Returns Object Data Preview Data IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

public Method getObjectDataPreviewFileFormat Returns ObjectData Preview File Format DataSet (2:200).

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

public Method getObjectDataPreviewFileFormatVersion Returns Object Data Preview File Format Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

public Method getObjectDataSizeAnnounced Returns Object Data Size Announced IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

public Method getObjectName Returns Object Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method getObjectTypeReference Returns Object Type Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

public Method getOriginalTransmissionReference Returns Original Transmission Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getOriginatingProgram Returns Originating Program IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getPictureNumber Returns Picture Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

public Method getPixelSizeInScanningDirection Returns Pixel Size In Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

public Method getPixelSizePerpendicularToScanningDirection Returns Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

public Method getPixelsPerLine Returns Pixels Per Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

public Method getProductID Returns ProductID IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

public Method getProgramVersion Returns Program Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

public Method getProvinceState Returns Province State IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getQuantisationMethod Returns Quantisation method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

public Method getRasterizedCaption Returns Rasterized Caption IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

public Method getRecord2Version Returns Record2 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

public Method getRecord3Version Returns Record3 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

public Method getReferenceDate Returns Reference Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

public Method getReferenceNumber Returns Reference Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

public Method getReferenceService Returns Reference Service IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

public Method getReleaseDate Returns Release Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

public Method getReleaseTime Returns Release Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method getSamplingStructure Returns Sampling structure IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

public Method getScanningDirection Returns Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

public Method getServiceIdentifier Returns Service Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

public Method getSizeMode Returns Size Mode IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

public Method getSource Returns Source IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method getSpecialInstructions Returns Special Instructions IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

public Method getSubjectReference Returns Subject Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

public Method getSublocation Returns Sublocation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getSupplementalCategory Returns Supplemental Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method getSupplementType Returns Supplement Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

public Method getTimeCreated Returns Time Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

public Method getTimeSent Returns Time Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

public Method getUNO Returns UNO IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

public Method getUrgency Returns Urgency IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

public Method getWriter_Editor Returns Writer/Editor IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setActionAdvised Sets Action Advised IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

public Method setARMIdentifier Sets ARM Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

public Method setARMVersion Sets ARM Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

public Method setAudioDuration Sets Audio Duration IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

public Method setAudioOutcue Sets Audio Outcue IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setAudioSamplingRate Sets Audio Sampling Rate IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

public Method setAudioSamplingResolution Sets Audio Sampling Resolution IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

public Method setAudioType Sets Audio Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

public Method setBitsPerComponent Sets Bits Per Component IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

public Method setByLine Sets By Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setByLineTitle Sets By Line Title IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setCaption_Abstract Sets Caption/Abstract IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

public Method setCategory Sets Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

public Method setCity Sets City IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setCodedCharacterSet Sets Coded Character Set IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

public Method setColourCalibrationMatrixTable Sets Colour Calibration Matrix Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

public Method setColourPalette Sets Colour Palette IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

public Method setColourRepresentation Sets Colour Representation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

public Method setColourSequence Sets Colour Sequence IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

public Method setConfirmedObjectDataSize Sets Confirmed Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

public Method setContact Sets Contact IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method setContentLocationCode Sets Content Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

public Method setContentLocationName Sets Content Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setCopyrightNotice Sets Copyright Notice IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

public Method setCountryPrimaryLocationCode Sets Country Primary Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

public Method setCountryPrimaryLocationName Sets Country Primary Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setCredit Sets Credit IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setDataCompressionMethod Sets Data Compression method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

public Method setDateCreated Sets Date Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

public Method setDateSent Sets Date Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

public Method setDestination Sets Destination IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

public Method setDigitalCreationDate Sets Digital Creation Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

public Method setDigitalCreationTime Sets Digital Creation Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method setEditorialUpdate Sets Editorial Update IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

public Method setEditStatus Sets Edit Status IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setEndPoints Sets End Points IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

public Method setEnvelopeNumber Sets Envelope Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

public Method setEnvelopePriority Sets Envelope Priority IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

public Method setExcursionTolerance Sets Excursion Tolerance IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

public Method setExpirationDate Sets Expiration Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

public Method setExpirationTime Sets Expiration Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

public Method setFileFormat Sets File Format IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

public Method setFileFormatVersion Sets File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

public Method setFixtureIdentifier Sets Fixture Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

public Method setGammaCompensatedValue Sets Gamma Compensated Value IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

public Method setHeadline Sets Headline IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

public Method setICCInputColourProfile Sets ICC Input Colour Profile IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

public Method setImageOrientation Sets Image Orientation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

public Method setImageRotation Sets Image Rotation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

public Method setImageType Sets Image Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

public Method setInterchangeColourSpace Sets Interchange Colour Space IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

public Method setKeywords Sets Keywords IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setLanguageIdentifier Sets Language Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

public Method setLookupTable Sets Lookup Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

public Method setMaximumDensityRange Sets Maximum Density Range IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

public Method setMaximumObjectDataSize Sets Maximum Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

public Method setMaxSubfileSize Sets Max Subfile Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

public Method setModelVersion Sets Model Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

public Method setNumberOfBitsPerSample Sets Number Of Bits Per Sample IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

public Method setNumberOfIndexEntries Sets Number Of Index Entries IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

public Method setNumberOfLines Sets Number Of Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

public Method setObjectAttributeReference Sets Object Attribute Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

public Method setObjectCycle Sets Object Cycle IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

public Method setObjectDataPreviewData Sets Object Data Preview Data IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

public Method setObjectDataPreviewFileFormat Sets ObjectData Preview File Format DataSet (2:200).

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

public Method setObjectDataPreviewFileFormatVersion Sets Object Data Preview File Format Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

public Method setObjectDataSizeAnnounced Sets Object Data Size Announced IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

public Method setObjectName Sets Object Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

public Method setObjectTypeReference Sets Object Type Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

public Method setOriginalTransmissionReference Sets Original Transmission Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setOriginatingProgram Sets Originating Program IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setPictureNumber Sets Picture Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

public Method setPixelSizeInScanningDirection Sets Pixel Size In Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

public Method setPixelSizePerpendicularToScanningDirection Sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

public Method setPixelsPerLine Sets Pixels Per Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

public Method setProductID Sets ProductID IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

public Method setProgramVersion Sets Program Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

public Method setProvinceState Sets Province State IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setQuantisationMethod Sets Quantisation method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

public Method setRasterizedCaption Sets Rasterized Caption IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

public Method setRecord2Version Sets Record2 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

public Method setRecord3Version Sets Record3 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

public Method setReferenceDate Sets Reference Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

public Method setReferenceNumber Sets Reference Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

public Method setReferenceService Sets Reference Service IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

public Method setReleaseDate Sets Release Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

public Method setReleaseTime Sets Release Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

public Method setSamplingStructure Sets Sampling structure IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

public Method setScanningDirection Sets Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

public Method setServiceIdentifier Sets Service Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

public Method setSizeMode Sets Size Mode IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

public Method setSource Sets Source IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

public Method setSpecialInstructions Sets Special Instructions IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

public Method setSubjectReference Sets Subject Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

public Method setSublocation Sets Sublocation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setSupplementalCategory Sets Supplemental Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

public Method setSupplementType Sets Supplement Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

public Method setTimeCreated Sets Time Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

public Method setTimeSent Sets Time Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

public Method setUNO Sets UNO IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

public Method setUrgency Sets Urgency IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

public Method setWriter_Editor Sets Writer/Editor IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Top

See Also

Reference

ImGearIPTCMetadata Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

getActionAdvised Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getActionAdvised Method

Glossary Item Box

Returns Action Advised IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

Syntax

public ImGearIPTCActionAdvised getActionAdvised()

Return Value

Nullable (boxed) ImGearIPTCActionAdvised enumeration value. *

ImGearIPTCActionAdvised

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getARMIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getARMIdentifier Method

Glossary Item Box

Returns ARM Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

Syntax

public java.lang.int getARMIdentifier()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getARMVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getARMVersion Method

Glossary Item Box

Returns ARM Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

Syntax

public java.lang.int getARMVersion()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getAudioDuration Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getAudioDuration Method

Glossary Item Box

Returns Audio Duration IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

Syntax

public java.lang.String getAudioDuration()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getAudioOutcue Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getAudioOutcue Method

Glossary Item Box

Returns Audio Outcue IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getAudioOutcue()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getAudioSamplingRate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getAudioSamplingRate Method

Glossary Item Box

Returns Audio Sampling Rate IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

Syntax

public java.lang.String getAudioSamplingRate()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getAudioSamplingResolution Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getAudioSamplingResolution Method

Glossary Item Box

Returns Audio Sampling Resolution IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

Syntax

public java.lang.String getAudioSamplingResolution()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getAudioType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getAudioType Method

Glossary Item Box

Returns Audio Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

Syntax

public ImGearIPTCAudioType getAudioType()

Return Value

Nullable (boxed) ImGearIPTCAudioType structure value. *

ImGearIPTCAudioType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getBitsPerComponent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getBitsPerComponent Method

Glossary Item Box

Returns Bits Per Component IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

Syntax

public java.lang.byte getBitsPerComponent()

Return Value

Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getByLine Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getByLine Method

Glossary Item Box

Returns By Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getByLine()

Return Value

String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getByLineTitle Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getByLineTitle Method

Glossary Item Box

Returns By Line Title IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getByLineTitle()

Return Value

String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCaption_Abstract Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCaption_Abstract Method

Glossary Item Box

Returns Caption/Abstract IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

Syntax

public java.lang.String getCaption_Abstract()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCategory Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCategory Method

Glossary Item Box

Returns Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

Syntax

public java.lang.String getCategory()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCity Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCity Method

Glossary Item Box

Returns City IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getCity()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCodedCharacterSet Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCodedCharacterSet Method

Glossary Item Box

Returns Coded Character Set IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

Syntax

public java.lang.String getCodedCharacterSet()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getColourCalibrationMatrixTable Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getColourCalibrationMatrixTable Method

Glossary Item Box

Returns Colour Calibration Matrix Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

Syntax

public byte[] getColourCalibrationMatrixTable()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getColourPalette Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getColourPalette Method

Glossary Item Box

Returns Colour Palette IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

Syntax

public byte[] getColourPalette()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getColourRepresentation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getColourRepresentation Method

Glossary Item Box

Returns Colour Representation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

Syntax

public ImGearIPTCColourRepresentation getColourRepresentation()

Return Value

Nullable (boxed) ImGearIPTCColourRepresentation structure value. *

ImGearIPTCColourRepresentation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getColourSequence Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getColourSequence Method

Glossary Item Box

Returns Colour Sequence IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

Syntax

public byte[] getColourSequence()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getConfirmedObjectDataSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getConfirmedObjectDataSize Method

Glossary Item Box

Returns Confirmed Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

Syntax

public java.lang.long getConfirmedObjectDataSize()

Return Value

Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getContact Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getContact Method

Glossary Item Box

Returns Contact IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getContact()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getContentLocationCode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getContentLocationCode Method

Glossary Item Box

Returns Content Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

Syntax

public java.lang.String[] getContentLocationCode()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getContentLocationName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getContentLocationName Method

Glossary Item Box

Returns Content Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getContentLocationName()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCopyrightNotice Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCopyrightNotice Method

Glossary Item Box

Returns Copyright Notice IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getCopyrightNotice()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCountryPrimaryLocationCode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCountryPrimaryLocationCode Method

Glossary Item Box

Returns Country Primary Location Code IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

Syntax

public java.lang.String[] getCountryPrimaryLocationCode()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCountryPrimaryLocationName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCountryPrimaryLocationName Method

Glossary Item Box

Returns Country Primary Location Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getCountryPrimaryLocationName()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getCredit Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getCredit Method

Glossary Item Box

Returns Credit IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getCredit()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDataCompressionMethod Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDataCompressionMethod Method

Glossary Item Box

Returns Data Compression method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

Syntax

public ImGearIPTCDataCompressionMethod getDataCompressionMethod()

Return Value

Nullable (boxed) ImGearIPTCDataCompressionMethod enumeration value. *

ImGearIPTCDataCompressionMethod

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDateCreated Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDateCreated Method

Glossary Item Box

Returns Date Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getDateCreated()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDateSent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDateSent Method

Glossary Item Box

Returns Date Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getDateSent()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDestination Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDestination Method

Glossary Item Box

Returns Destination IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

Syntax

public java.lang.String[] getDestination()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDigitalCreationDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDigitalCreationDate Method

Glossary Item Box

Returns Digital Creation Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getDigitalCreationDate()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getDigitalCreationTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getDigitalCreationTime Method

Glossary Item Box

Returns Digital Creation Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Syntax

public java.lang.String getDigitalCreationTime()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getEditorialUpdate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getEditorialUpdate Method

Glossary Item Box

Returns Editorial Update IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

Syntax

public java.lang.String getEditorialUpdate()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getEditStatus Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getEditStatus Method

Glossary Item Box

Returns Edit Status IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getEditStatus()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getEndPoints Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getEndPoints Method

Glossary Item Box

Returns End Points IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

Syntax

public byte[] getEndPoints()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getEnvelopeNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getEnvelopeNumber Method

Glossary Item Box

Returns Envelope Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getEnvelopeNumber()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getEnvelopePriority Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getEnvelopePriority Method

Glossary Item Box

Returns Envelope Priority IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

Syntax

public java.lang.String getEnvelopePriority()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getExcursionTolerance Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getExcursionTolerance Method

Glossary Item Box

Returns Excursion Tolerance IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

Syntax

public ImGearIPTCExcursionTolerance getExcursionTolerance()

Return Value

Nullable (boxed) ImGearIPTCExcursionTolerance enumeration value. *

ImGearIPTCExcursionTolerance

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getExpirationDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getExpirationDate Method

Glossary Item Box

Returns Expiration Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getExpirationDate()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getExpirationTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getExpirationTime Method

Glossary Item Box

Returns Expiration Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

Syntax

public java.lang.String getExpirationTime()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getFileFormat Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getFileFormat Method

Glossary Item Box

Returns File Format IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

Syntax

public ImGearIPTCFileFormatID getFileFormat()

Return Value

Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

ImGearIPTCFileFormatID

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getFileFormatVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getFileFormatVersion Method

Glossary Item Box

Returns File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Syntax

public java.lang.int getFileFormatVersion()

Return Value

Nullable (boxed) ushort value.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getFixtureIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getFixtureIdentifier Method

Glossary Item Box

Returns Fixture Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

Syntax

public java.lang.String getFixtureIdentifier()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getGammaCompensatedValue Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getGammaCompensatedValue Method

Glossary Item Box

Returns Gamma Compensated Value IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

Syntax

public java.lang.int getGammaCompensatedValue()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getHeadline Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getHeadline Method

Glossary Item Box

Returns Headline IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getHeadline()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getICCInputColourProfile Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getICCInputColourProfile Method

Glossary Item Box

Returns ICC Input Colour Profile IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

Syntax

public byte[] getICCInputColourProfile()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getImageOrientation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getImageOrientation Method

Glossary Item Box

Returns Image Orientation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

Syntax

public ImGearIPTCImageOrientation getImageOrientation()

Return Value

Nullable (boxed) ImGearIPTCImageOrientation enumeration value. *

ImGearIPTCImageOrientation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getImageRotation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getImageRotation Method

Glossary Item Box

Returns Image Rotation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

Syntax

public ImGearIPTCImageRotation getImageRotation()

Return Value

Nullable (boxed) ImGearIPTCImageRotation enumeration value. *

ImGearIPTCImageRotation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getImageType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getImageType Method

Glossary Item Box

Returns Image Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

Syntax

public ImGearIPTCImageType getImageType()

Return Value

Nullable (boxed) ImGearIPTCImageType structure value. *

ImGearIPTCImageType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getInterchangeColourSpace Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getInterchangeColourSpace Method

Glossary Item Box

Returns Interchange Colour Space IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

Syntax

public ImGearIPTCInterchangeColourSpace getInterchangeColourSpace()

Return Value

Nullable (boxed) ImGearIPTCInterchangeColourSpace enumeration value. *

ImGearIPTCInterchangeColourSpace

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getKeywords Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getKeywords Method

Glossary Item Box

Returns Keywords IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getKeywords()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getLanguageIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getLanguageIdentifier Method

Glossary Item Box

Returns Language Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

Syntax

public java.lang.String getLanguageIdentifier()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getLookupTable Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getLookupTable Method

Glossary Item Box

Returns Lookup Table IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

Syntax

public byte[] getLookupTable()

Return Value

Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getMaximumDensityRange Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getMaximumDensityRange Method

Glossary Item Box

Returns Maximum Density Range IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

Syntax

public java.lang.int getMaximumDensityRange()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getMaximumObjectDataSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getMaximumObjectDataSize Method

Glossary Item Box

Returns Maximum Object Data Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

Syntax

public java.lang.long getMaximumObjectDataSize()

Return Value

Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getMaxSubfileSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getMaxSubfileSize Method

Glossary Item Box

Returns Max Subfile Size IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

Syntax

public java.lang.long getMaxSubfileSize()

Return Value

Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getModelVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getModelVersion Method

Glossary Item Box

Returns Model Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

Syntax

public java.lang.int getModelVersion()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getNumberOfBitsPerSample Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getNumberOfBitsPerSample Method

Glossary Item Box

Returns Number Of Bits Per Sample IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

Syntax

public java.lang.byte getNumberOfBitsPerSample()

Return Value

Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getNumberOfIndexEntries Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getNumberOfIndexEntries Method

Glossary Item Box

Returns Number Of Index Entries IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

Syntax

public java.lang.int getNumberOfIndexEntries()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getNumberOfLines Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getNumberOfLines Method

Glossary Item Box

Returns Number Of Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

Syntax

public java.lang.int getNumberOfLines()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectAttributeReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectAttributeReference Method

Glossary Item Box

Returns Object Attribute Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

Syntax

public ImGearIPTCObjectAttributeReference[] getObjectAttributeReference()

Return Value

ImGearIPTCObjectAttributeReference structure[] array. *

ImGearIPTCObjectAttributeReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectCycle Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectCycle Method

Glossary Item Box

Returns Object Cycle IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

Syntax

public ImGearIPTCObjectCycle getObjectCycle()

Return Value

Nullable (boxed) ImGearIPTCObjectCycle enumeration value. *

ImGearIPTCObjectCycle

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectDataPreviewData Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectDataPreviewData Method

Glossary Item Box

Returns Object Data Preview Data IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

Syntax

public byte[] getObjectDataPreviewData()

Return Value

Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectDataPreviewFileFormat Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectDataPreviewFileFormat Method

Glossary Item Box

Returns ObjectData Preview File Format DataSet (2:200).

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

Syntax

public ImGearIPTCFileFormatID getObjectDataPreviewFileFormat()

Return Value

Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectDataPreviewFileFormatVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectDataPreviewFileFormatVersion Method

Glossary Item Box

Returns Object Data Preview File Format Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

Syntax

public java.lang.int getObjectDataPreviewFileFormatVersion()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectDataSizeAnnounced Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectDataSizeAnnounced Method

Glossary Item Box

Returns Object Data Size Announced IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

Syntax

public java.lang.long getObjectDataSizeAnnounced()

Return Value

Nullable (boxed) ulong value. *

ImGearIPTCMetadata

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectName Method

Glossary Item Box

Returns Object Name IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getObjectName()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getObjectTypeReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getObjectTypeReference Method

Glossary Item Box

Returns Object Type Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

Syntax

public ImGearIPTCObjectTypeReference getObjectTypeReference()

Return Value

Nullable (boxed) ImGearIPTCObjectTypeReference structure value. *

ImGearIPTCObjectTypeReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getOriginalTransmissionReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getOriginalTransmissionReference Method

Glossary Item Box

Returns Original Transmission Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getOriginalTransmissionReference()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getOriginatingProgram Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getOriginatingProgram Method

Glossary Item Box

Returns Originating Program IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getOriginatingProgram()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getPictureNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getPictureNumber Method

Glossary Item Box

Returns Picture Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

Syntax

public ImGearIPTCPictureNumber getPictureNumber()

Return Value

Nullable (boxed) ImGearIPTCPictureNumber structure value. *

ImGearIPTCPictureNumber

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getPixelSizeInScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getPixelSizeInScanningDirection Method

Glossary Item Box

Returns Pixel Size In Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

Syntax

public java.lang.int getPixelSizeInScanningDirection()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getPixelSizePerpendicularToScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getPixelSizePerpendicularToScanningDirection Method

Glossary Item Box

Returns Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

Syntax

public java.lang.int getPixelSizePerpendicularToScanningDirection()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getPixelsPerLine Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getPixelsPerLine Method

Glossary Item Box

Returns Pixels Per Line IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

Syntax

public java.lang.int getPixelsPerLine()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getProductID Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getProductID Method

Glossary Item Box

Returns ProductID IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

Syntax

public java.lang.String[] getProductID()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getProgramVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getProgramVersion Method

Glossary Item Box

Returns Program Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getProgramVersion()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getProvinceState Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getProvinceState Method

Glossary Item Box

Returns Province State IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getProvinceState()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getQuantisationMethod Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getQuantisationMethod Method

Glossary Item Box

Returns Quantisation method IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

Syntax

public ImGearIPTCQuantisationMethod getQuantisationMethod()

Return Value

Nullable (boxed) ImGearIPTCQuantisationMethod enumeration value. *

ImGearIPTCQuantisationMethod

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getRasterizedCaption Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getRasterizedCaption Method

Glossary Item Box

Returns Rasterized Caption IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

Syntax

public byte[] getRasterizedCaption()

Return Value

Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getRecord2Version Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getRecord2Version Method

Glossary Item Box

Returns Record2 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

Syntax

public java.lang.int getRecord2Version()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getRecord3Version Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getRecord3Version Method

Glossary Item Box

Returns Record3 Version IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

Syntax

public java.lang.int getRecord3Version()

Return Value

Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getReferenceDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getReferenceDate Method

Glossary Item Box

Returns Reference Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

Syntax

public java.lang.String[] getReferenceDate()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getReferenceNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getReferenceNumber Method

Glossary Item Box

Returns Reference Number IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

Syntax

public java.lang.String[] getReferenceNumber()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getReferenceService Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getReferenceService Method

Glossary Item Box

Returns Reference Service IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

Syntax

public java.lang.String[] getReferenceService()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getReleaseDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getReleaseDate Method

Glossary Item Box

Returns Release Date IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

Syntax

public java.lang.String getReleaseDate()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getReleaseTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getReleaseTime Method

Glossary Item Box

Returns Release Time IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Syntax

public java.lang.String getReleaseTime()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSamplingStructure Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSamplingStructure Method

Glossary Item Box

Returns Sampling structure IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

Syntax

public ImGearIPTCSamplingStructure getSamplingStructure()

Return Value

Nullable (boxed) ImGearIPTCSamplingStructure enumeration value. *

ImGearIPTCSamplingStructure

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getScanningDirection Method

Glossary Item Box

Returns Scanning Direction IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

Syntax

public ImGearIPTCScanningDirection getScanningDirection()

Return Value

Nullable (boxed) ImGearIPTCScanningDirection enumeration value. *

ImGearIPTCScanningDirection

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getServiceIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getServiceIdentifier Method

Glossary Item Box

Returns Service Identifier IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

Syntax

public java.lang.String getServiceIdentifier()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSizeMode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSizeMode Method

Glossary Item Box

Returns Size Mode IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

Syntax

public ImGearIPTCSizeMode getSizeMode()

Return Value

Nullable (boxed) ImGearIPTCSizeMode enumeration value. *

ImGearIPTCSizeMode

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSource Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSource Method

Glossary Item Box

Returns Source IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getSource()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSpecialInstructions Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSpecialInstructions Method

Glossary Item Box

Returns Special Instructions IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getSpecialInstructions()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSubjectReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSubjectReference Method

Glossary Item Box

Returns Subject Reference IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

Syntax

public ImGearIPTCSubjectReference[] getSubjectReference()

Return Value

ImGearIPTCSubjectReference structure[] array. *

ImGearIPTCSubjectReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSublocation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSublocation Method

Glossary Item Box

Returns Sublocation IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String getSublocation()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSupplementalCategory Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSupplementalCategory Method

Glossary Item Box

Returns Supplemental Category IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getSupplementalCategory()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getSupplementType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getSupplementType Method

Glossary Item Box

Returns Supplement Type IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

Syntax

public ImGearIPTCSupplementType getSupplementType()

Return Value

Nullable (boxed) ImGearIPTCSupplementType enumeration value. *

ImGearIPTCSupplementType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getTimeCreated Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getTimeCreated Method

Glossary Item Box

Returns Time Created IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

Syntax

public java.lang.String getTimeCreated()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getTimeSent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getTimeSent Method

Glossary Item Box

Returns Time Sent IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

Syntax

public java.lang.String getTimeSent()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getUNO Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getUNO Method

Glossary Item Box

Returns UNO IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Syntax

public ImGearIPTCUNO getUNO()

Return Value

Nullable (boxed) ImGearIPTCUNO structure object. *

ImGearIPTCUNO

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getUrgency Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getUrgency Method

Glossary Item Box

Returns Urgency IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

Syntax

public java.lang.String getUrgency()

Return Value

String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

getWriter_Editor Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : getWriter_Editor Method

Glossary Item Box

Returns Writer/Editor IPTC dataset.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public java.lang.String[] getWriter_Editor()

Return Value

Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setActionAdvised Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setActionAdvised Method
value
Nullable (boxed) ImGearIPTCActionAdvised enumeration value. *

ImGearIPTCActionAdvised

Glossary Item Box

Sets Action Advised IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Action Advised IPTC DataSet (2:42). The dataset indicates the type of action that this object provides to a previous object.

Syntax

public void setActionAdvised(
   ImGearIPTCActionAdvised value
)

Parameters

value
Nullable (boxed) ImGearIPTCActionAdvised enumeration value. *

ImGearIPTCActionAdvised

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setARMIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setARMIdentifier Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets ARM Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Identifier IPTC DataSet (1:120). The DataSet identifies the Abstract Relationship method (ARM), which is described in a document registered by the originator of the ARM with the IPTC and NAA.

Syntax

public void setARMIdentifier(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setARMVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setARMVersion Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets ARM Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ARM Version IPTC DataSet (1:122). The DataSet represents the particular version of the ARM specified in DataSet 1:120.

Syntax

public void setARMVersion(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setAudioDuration Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setAudioDuration Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Audio Duration IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Duration IPTC DataSet (2:153). The DataSet designates in the form HHMMSS the running time of an audio object data when played back at the speed at which it was recorded.

Contains six bytes, consisting of numeric characters.

Syntax

public void setAudioDuration(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setAudioOutcue Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setAudioOutcue Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Audio Outcue IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Outcue IPTC DataSet (2:154). The DataSet identifies the content of the end of an audio objectdata, according to guidelines established by the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setAudioOutcue(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setAudioSamplingRate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setAudioSamplingRate Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Audio Sampling Rate IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Rate DataSet (2:151). The DataSet represents the sampling rate in hertz (Hz).

Six bytes with leading zero(s), consisting of numeric characters.

Syntax

public void setAudioSamplingRate(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setAudioSamplingResolution Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setAudioSamplingResolution Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Audio Sampling Resolution IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Sampling Resolution DataSet (2:152). The DataSet represents the number of bits in each audio sample.

Contains two bytes with leading zero(s), consisting of numeric characters.

Syntax

public void setAudioSamplingResolution(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setAudioType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setAudioType Method
value
Nullable (boxed) ImGearIPTCAudioType structure value. *

ImGearIPTCAudioType

Glossary Item Box

Sets Audio Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Audio Type DataSet (2:150). The DataSet represents the number of audio channels and the exact type of audio contained in the current objectdata.

Syntax

public void setAudioType(
   ImGearIPTCAudioType value
)

Parameters

value
Nullable (boxed) ImGearIPTCAudioType structure value. *

ImGearIPTCAudioType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setBitsPerComponent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setBitsPerComponent Method
value
Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Bits Per Component IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Bits Per Component DataSet (3:135). The DataSet contains a sequence of one or more bytes describing the number of bits used to encode each component. The sequence is specified by the order of components in DataSet 3:65.

Syntax

public void setBitsPerComponent(
   java.lang.byte value
)

Parameters

value
Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setByLine Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setByLine Method
value
String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets By Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line DataSet (2:80). The DataSet contains the name of the creator of the objectdata, e.g., writer, photographer, or graphic artist.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setByLine(
   java.lang.String[] value
)

Parameters

value
String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setByLineTitle Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setByLineTitle Method
value
String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets By Line Title IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the By-line Title DataSet (2:85). The DataSet specifies the title of the creator or creators of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setByLineTitle(
   java.lang.String[] value
)

Parameters

value
String array. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCaption_Abstract Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCaption_Abstract Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Caption/Abstract IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Caption/Abstract DataSet (2:120). The DataSet contains a textual description of the objectdata, particularly used where the object is not text.

Maximum of 2000 bytes, consisting of graphic characters plus carriage-returns, linefeeds, and spaces.

Syntax

public void setCaption_Abstract(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCategory Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCategory Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Category DataSet (2:15). The DataSet identifies the subject of the objectdata in the opinion of the provider.

Maximum three bytes, consisting of alphabetic characters.

Syntax

public void setCategory(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCity Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCity Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets City IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the City DataSet (2:90). The DataSet identifies the city of objectdata origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setCity(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCodedCharacterSet Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCodedCharacterSet Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Coded Character Set IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Coded Character Set DataSet (1:90). The DataSet consists of one or more control functions used for the announcement, invocation, or designation of coded character sets. The control functions follow the ISO 2022 standard and may consist of the escape control character and one or more graphic characters.

Contains up to 32 bytes.

Syntax

public void setCodedCharacterSet(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setColourCalibrationMatrixTable Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setColourCalibrationMatrixTable Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Colour Calibration Matrix Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Calibration Matrix Table DataSet (3:70). The DataSet is no longer required as its contents have been rendered obsolete by the introduction of DataSet P3:66 (ICC Input Colour Profile).

Syntax

public void setColourCalibrationMatrixTable(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setColourPalette Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setColourPalette Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Colour Palette IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Palette DataSet (3:85). The purpose of the Colour Palette is to act as a lookup table mapping the pixel values into the Colour Space defined in Interchange Colour Space DataSet (3:64).

Contains up to 524,288 (4 x 65536 x 2) bytes.

A number of default palettes may be held to be selected according to the device identifier component of the Picture Number 3:10.

Syntax

public void setColourPalette(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setColourRepresentation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setColourRepresentation Method
value
Nullable (boxed) ImGearIPTCColourRepresentation structure value. *

ImGearIPTCColourRepresentation

Glossary Item Box

Sets Colour Representation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Representation DataSet (3:60). The DataSet specifies the number of image components and the build-up structure of the image.

Syntax

public void setColourRepresentation(
   ImGearIPTCColourRepresentation value
)

Parameters

value
Nullable (boxed) ImGearIPTCColourRepresentation structure value. *

ImGearIPTCColourRepresentation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setColourSequence Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setColourSequence Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Colour Sequence IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Colour Sequence DataSet (3:65). The DataSet specifies the sequence of the components as they appear in the objectdata.

Syntax

public void setColourSequence(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setConfirmedObjectDataSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setConfirmedObjectDataSize Method
value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Confirmed Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ConfirmedObjectDataSize DataSet (9:10). The DataSet specifies total size of the objectdata, in bytes, without tags.

Syntax

public void setConfirmedObjectDataSize(
   java.lang.long value
)

Parameters

value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setContact Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setContact Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Contact IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Contact DataSet (2:118). The DataSet identifies the person or organization that can provide further background information on the objectdata.

Repeatable (array items represent repeated values), maximum of 128 bytes, consisting of graphic characters plus spaces.

Syntax

public void setContact(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setContentLocationCode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setContentLocationCode Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Content Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationCode DataSet (2:26). The DataSet indicates the code of a country/geographical location referenced by the content of the object.

Repeatable (array items represent repeated values), 3 bytes consisting of alphabetic characters.

Syntax

public void setContentLocationCode(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setContentLocationName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setContentLocationName Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Content Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ContentLocationName DataSet (2:27). The DataSet provides a full, publishable name of a country/geographical location referenced by the content of the object, according to guidelines of the provider.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setContentLocationName(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCopyrightNotice Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCopyrightNotice Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Copyright Notice IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CopyrightNotice DataSet (2:116). The DataSet contains any necessary copyright notice.

Contains maximum of 128 bytes, consisting of graphic characters plus spaces.

Syntax

public void setCopyrightNotice(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCountryPrimaryLocationCode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCountryPrimaryLocationCode Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Country Primary Location Code IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationCode DataSet (2:100). The DataSet indicates the code of the country/primary location where the intellectual property of the objectdata was created, e.g., a photo was taken, an event occured.

Contains three bytes consisting of alphabetic characters.

Syntax

public void setCountryPrimaryLocationCode(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCountryPrimaryLocationName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCountryPrimaryLocationName Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Country Primary Location Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Country/PrimaryLocationName DataSet (2:101). The DataSet provides the full, publishable name of the country/primary location where the intellectual property of the objectdata was created, according to guidelines of the provider.

Contains maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setCountryPrimaryLocationName(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setCredit Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setCredit Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Credit IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Credit DataSet (2:110). The DataSet identifies the provider of the objectdata, not necessarily the owner/creator.

Contains maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setCredit(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDataCompressionMethod Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDataCompressionMethod Method
value
Nullable (boxed) ImGearIPTCDataCompressionMethod enumeration value. *

ImGearIPTCDataCompressionMethod

Glossary Item Box

Sets Data Compression method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Data Compression method DataSet (3:110). The DataSet specifies the provider/owner, type, and version of the compression algorithm.

Syntax

public void setDataCompressionMethod(
   ImGearIPTCDataCompressionMethod value
)

Parameters

value
Nullable (boxed) ImGearIPTCDataCompressionMethod enumeration value. *

ImGearIPTCDataCompressionMethod

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDateCreated Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDateCreated Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Date Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DateCreated DataSet (2:55). The DataSet represented in the form CCYYMMDD to designate the date the intellectual content of the objectdata was created rather than the date of the creation of the physical representation.

Contains eight bytes, consisting of numeric characters.

Syntax

public void setDateCreated(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDateSent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDateSent Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Date Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date Sent DataSet (1:70). The DataSet uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the service sent the material.

Contains eight bytes, consisting of numeric characters.

Syntax

public void setDateSent(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDestination Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDestination Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Destination IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Destination DataSet (1:05). The DataSet is to accommodate some providers who require routing information above the appropriate OSI layers.

Repeatable (array items represent repeated values), maximum 1024 bytes, consisting of sequentially contiguous graphic characters.

Syntax

public void setDestination(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDigitalCreationDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDigitalCreationDate Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Digital Creation Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationDate DataSet (2:62). The DataSet represented in the form CCYYMMDD to designate the date the digital representation of the objectdata was created.

Contains eight bytes, consisting of numeric characters.

Syntax

public void setDigitalCreationDate(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setDigitalCreationTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setDigitalCreationTime Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Digital Creation Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DigitalCreationTime DataSet (2:63). The DataSet is represented in the form HHMMSS-HHMM to designate the time the digital representation of the objectdata was created. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Syntax

public void setDigitalCreationTime(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setEditorialUpdate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setEditorialUpdate Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Editorial Update IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EditorialUpdate DataSet (2:08). The DataSet indicates the type of update that this object provides to a previous object.

Contains 2 bytes, consisting of numeric characters.

Syntax

public void setEditorialUpdate(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setEditStatus Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setEditStatus Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Edit Status IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Edit Status DataSet (2:07). The DataSet specifies the status of the objectdata, according to the practice of the provider.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setEditStatus(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setEndPoints Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setEndPoints Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets End Points IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EndPoints DataSet (3:125). The DataSet contains the values representing minimum and maximum density for each component.

Syntax

public void setEndPoints(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setEnvelopeNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setEnvelopeNumber Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Envelope Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopeNumber DataSet (1:40). Characters of the DataSet form a number that will be unique for the date specified in 1:70 and for the Service Identifier specified in 1:30.

Contains eight bytes, consisting of numeric characters.

Syntax

public void setEnvelopeNumber(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setEnvelopePriority Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setEnvelopePriority Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Envelope Priority IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the EnvelopePriority DataSet (1:60). The DataSet specifies the envelope handling priority and not the editorial urgency (see 2:10, Urgency). '1' indicates the most urgent, '5' the normal urgency, and '8' the least urgent copy. The numeral '9' indicates a User Defined Priority. The numeral '0' is reserved for future use.

Contains a single byte, consisting of a numeric character.

Syntax

public void setEnvelopePriority(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setExcursionTolerance Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setExcursionTolerance Method
value
Nullable (boxed) ImGearIPTCExcursionTolerance enumeration value. *

ImGearIPTCExcursionTolerance

Glossary Item Box

Sets Excursion Tolerance IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExcursionTolerance DataSet (3:130). The DataSet indicates if values outside the range defined by the end points in DataSet 3:125 may occur.

Syntax

public void setExcursionTolerance(
   ImGearIPTCExcursionTolerance value
)

Parameters

value
Nullable (boxed) ImGearIPTCExcursionTolerance enumeration value. *

ImGearIPTCExcursionTolerance

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setExpirationDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setExpirationDate Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Expiration Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationDate DataSet (2:37). The DataSet designates in the form CCYYMMDD the latest date the provider or owner intends the objectdata to be used.

Contains eight bytes, consisting of numeric characters.

Syntax

public void setExpirationDate(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setExpirationTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setExpirationTime Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Expiration Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExpirationTime DataSet (2:38). The DataSet designates in the form HHMMSS-HHMM the latest time the provider or owner intends the objectdata to be used.

Contains 11 bytes, consisting of graphic characters.

Syntax

public void setExpirationTime(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setFileFormat Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setFileFormat Method
value
Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

ImGearIPTCFileFormatID

Glossary Item Box

Sets File Format IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the File Format DataSet (1:20). The DataSet represents the file format. The file format must be registered with IPTC or NAA with a unique number. The information is used to route the data to the appropriate system and to allow the receiving system to perform the appropriate actions thereto.

Syntax

public void setFileFormat(
   ImGearIPTCFileFormatID value
)

Parameters

value
Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

ImGearIPTCFileFormatID

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setFileFormatVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setFileFormatVersion Method
value
Nullable (boxed) ushort value.

Glossary Item Box

Sets File Format Version IPTC dataset. This method accesses the File Format Version DataSet (1:22). The DataSet contains a binary number representing the particular version of the File Format specified in 1:20. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Syntax

public void setFileFormatVersion(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setFixtureIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setFixtureIdentifier Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Fixture Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Fixture Identifier DataSet (2:22). The DataSet identifies objectdata that recurs often and predictably. Enables users to immediately find or recall such an object.

Contains maximum 32 bytes, consisting of graphic characters.

Syntax

public void setFixtureIdentifier(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setGammaCompensatedValue Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setGammaCompensatedValue Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Gamma Compensated Value IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GammaCompensatedValue DataSet (3:145). The DataSet specifies the value of gamma for the device multiplied by 100. If this DataSet is omitted, receiving equipment should assume that a gamma value of 2.22 applies.

Syntax

public void setGammaCompensatedValue(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setHeadline Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setHeadline Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Headline IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Headline DataSet (2:105). The DataSet contains a publishable entry providing a synopsis of the contents of the objectdata.

Contains maximum of 256 bytes, consisting of graphic characters plus spaces.

Syntax

public void setHeadline(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setICCInputColourProfile Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setICCInputColourProfile Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets ICC Input Colour Profile IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ICC InputColourProfile DataSet (3:66). The DataSet specifies the International Color Consortium profile for the scanning/source device used to generate the digital image files.

Syntax

public void setICCInputColourProfile(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setImageOrientation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setImageOrientation Method
value
Nullable (boxed) ImGearIPTCImageOrientation enumeration value. *

ImGearIPTCImageOrientation

Glossary Item Box

Sets Image Orientation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageOrientation DataSet (2:131). The DataSet indicates the layout of the image area.

Syntax

public void setImageOrientation(
   ImGearIPTCImageOrientation value
)

Parameters

value
Nullable (boxed) ImGearIPTCImageOrientation enumeration value. *

ImGearIPTCImageOrientation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setImageRotation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setImageRotation Method
value
Nullable (boxed) ImGearIPTCImageRotation enumeration value. *

ImGearIPTCImageRotation

Glossary Item Box

Sets Image Rotation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageRotation DataSet (3:102). The DataSet indicates the clockwise rotation applied to the image for presentation.

Syntax

public void setImageRotation(
   ImGearIPTCImageRotation value
)

Parameters

value
Nullable (boxed) ImGearIPTCImageRotation enumeration value. *

ImGearIPTCImageRotation

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setImageType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setImageType Method
value
Nullable (boxed) ImGearIPTCImageType structure value. *

ImGearIPTCImageType

Glossary Item Box

Sets Image Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Image Type DataSet (2:130). The DataSet specifies whether the objectdata contains an image or a supplemental object, number of channels in the image and exact content of the objectdata in terms of colour composition.

Syntax

public void setImageType(
   ImGearIPTCImageType value
)

Parameters

value
Nullable (boxed) ImGearIPTCImageType structure value. *

ImGearIPTCImageType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setInterchangeColourSpace Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setInterchangeColourSpace Method
value
Nullable (boxed) ImGearIPTCInterchangeColourSpace enumeration value. *

ImGearIPTCInterchangeColourSpace

Glossary Item Box

Sets Interchange Colour Space IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterchangeColourSpace DataSet (3:64). The DataSet indicates the colour space in which the pixel values are expressed for each component in the image.

Syntax

public void setInterchangeColourSpace(
   ImGearIPTCInterchangeColourSpace value
)

Parameters

value
Nullable (boxed) ImGearIPTCInterchangeColourSpace enumeration value. *

ImGearIPTCInterchangeColourSpace

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setKeywords Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setKeywords Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Keywords IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Keywords DataSet (2:25). The DataSet indicates specific information retrieval words.

Repeatable (array items represent repeated values), maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setKeywords(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setLanguageIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setLanguageIdentifier Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Language Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Language Identifier DataSet (2:135). The DataSet describes the major national language of the object, according to the 2-letter codes of ISO 639:1988.

Contains two or three bytes, consisting of alphabetic characters.

Syntax

public void setLanguageIdentifier(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setLookupTable Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setLookupTable Method
value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Lookup Table IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the LookupTable DataSet (3:80). The DataSet consists of one, three or four one-dimensional lookup tables (LUT).The LUT relates to the image data in the colour space defined in DataSet 3:64 and specifies the correction to apply to the pixel values before display or printing of the image.

Syntax

public void setLookupTable(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setMaximumDensityRange Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setMaximumDensityRange Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Maximum Density Range IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumDensityRange DataSet (3:140). The DataSet represents the difference between the lowest density and the highest density points that can be encoded by the originating system.

Syntax

public void setMaximumDensityRange(
   java.lang.int value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setMaximumObjectDataSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setMaximumObjectDataSize Method
value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Maximum Object Data Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaximumObjectDataSize DataSet (7:95). When objectdata size is not known, the DataSet indicates the largest size, expressed in bytes, that the objectdata can possibly have, not including tags.

Syntax

public void setMaximumObjectDataSize(
   java.lang.long value
)

Parameters

value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setMaxSubfileSize Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setMaxSubfileSize Method
value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Max Subfile Size IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Max SubfileSize DataSet (7:20). The DataSet indicates the maximum size for the following Subfile DataSet(s).

Syntax

public void setMaxSubfileSize(
   java.lang.long value
)

Parameters

value
Nullable (boxed) ulong value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setModelVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setModelVersion Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Model Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model Version DataSet (1:00). The DataSet identifies the version of the Information Interchange Model, Part I, utilized by the provider.

Syntax

public void setModelVersion(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setNumberOfBitsPerSample Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setNumberOfBitsPerSample Method
value
Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Number Of Bits Per Sample IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Bits per Sample DataSet (3:86). The DataSet indicates the number of bits per pixel value used as entries in the Colour Palette.

Syntax

public void setNumberOfBitsPerSample(
   java.lang.byte value
)

Parameters

value
Nullable (boxed) byte value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setNumberOfIndexEntries Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setNumberOfIndexEntries Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Number Of Index Entries IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Index Entries DataSet (3:84). The DataSet represents the number of index entries in the DataSet 3:85 (Colour Palette).

Syntax

public void setNumberOfIndexEntries(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setNumberOfLines Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setNumberOfLines Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Number Of Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Number of Lines DataSet (3:30). The DataSet represents the number of scan lines comprising the image for the component with the highest resolution.

Syntax

public void setNumberOfLines(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectAttributeReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectAttributeReference Method
value
ImGearIPTCObjectAttributeReference structure[] array. *

ImGearIPTCObjectAttributeReference

Glossary Item Box

Sets Object Attribute Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectAttributeReference DataSet (2:04). The DataSet defines the nature of the object independent of the Subject.

Repeatable (array items represent repeated values).

Syntax

public void setObjectAttributeReference(
   ImGearIPTCObjectAttributeReference[] value
)

Parameters

value
ImGearIPTCObjectAttributeReference structure[] array. *

ImGearIPTCObjectAttributeReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectCycle Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectCycle Method
value
Nullable (boxed) ImGearIPTCObjectCycle enumeration value. *

ImGearIPTCObjectCycle

Glossary Item Box

Sets Object Cycle IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Cycle DataSet (2:75). The DataSet represents object cycle, virtually only used in North America.

Syntax

public void setObjectCycle(
   ImGearIPTCObjectCycle value
)

Parameters

value
Nullable (boxed) ImGearIPTCObjectCycle enumeration value. *

ImGearIPTCObjectCycle

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectDataPreviewData Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectDataPreviewData Method
value
Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Object Data Preview Data IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview Data DataSet (2:202).

Maximum size: 256000 bytes.

Syntax

public void setObjectDataPreviewData(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectDataPreviewFileFormat Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectDataPreviewFileFormat Method
value
Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets ObjectData Preview File Format DataSet (2:200).

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format DataSet (2:200). The DataSet represents the file format of the ObjectData Preview.

Syntax

public void setObjectDataPreviewFileFormat(
   ImGearIPTCFileFormatID value
)

Parameters

value
Nullable (boxed) ImGearIPTCFileFormatID enumeration value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectDataPreviewFileFormatVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectDataPreviewFileFormatVersion Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Object Data Preview File Format Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Preview File Format Version DataSet (2:201). The DataSet represents the particular version of the ObjectData Preview File Format specified in 2:200.

Syntax

public void setObjectDataPreviewFileFormatVersion(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectDataSizeAnnounced Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectDataSizeAnnounced Method
value
Nullable (boxed) ulong value. *

ImGearIPTCMetadata

Glossary Item Box

Sets Object Data Size Announced IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ObjectData Size Announced DataSet (7:90). The DataSet represents the overall size of the objectdata, expressed in bytes, not including tags, if that size is known when transfer commences.

Syntax

public void setObjectDataSizeAnnounced(
   java.lang.long value
)

Parameters

value
Nullable (boxed) ulong value. *

ImGearIPTCMetadata

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectName Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectName Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Object Name IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Name DataSet (2:05). The DataSet used as a shorthand reference for the object.

Maximum 64 bytes, consisting of graphic characters plus spaces.

Syntax

public void setObjectName(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setObjectTypeReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setObjectTypeReference Method
value
Nullable (boxed) ImGearIPTCObjectTypeReference structure value. *

ImGearIPTCObjectTypeReference

Glossary Item Box

Sets Object Type Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Object Type Reference DataSet (2:03). The DataSet is used to distinguish between different types of objects within the IIM.

Syntax

public void setObjectTypeReference(
   ImGearIPTCObjectTypeReference value
)

Parameters

value
Nullable (boxed) ImGearIPTCObjectTypeReference structure value. *

ImGearIPTCObjectTypeReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setOriginalTransmissionReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setOriginalTransmissionReference Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Original Transmission Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Original Transmission Reference DataSet (2:103). The DataSet represents the location of original transmission according to practices of the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setOriginalTransmissionReference(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setOriginatingProgram Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setOriginatingProgram Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Originating Program IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Originating Program DataSet (2:65). The DataSet identifies the type of program used to originate the objectdata.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setOriginatingProgram(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setPictureNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setPictureNumber Method
value
Nullable (boxed) ImGearIPTCPictureNumber structure value. *

ImGearIPTCPictureNumber

Glossary Item Box

Sets Picture Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Picture Number DataSet (3:10). The DataSet provides a universally unique reference to an image.

Syntax

public void setPictureNumber(
   ImGearIPTCPictureNumber value
)

Parameters

value
Nullable (boxed) ImGearIPTCPictureNumber structure value. *

ImGearIPTCPictureNumber

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setPixelSizeInScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setPixelSizeInScanningDirection Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Pixel Size In Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size In Scanning Direction DataSet (3:40). The DataSet indicates the number of pixels per unit length in the scanning direction.

Syntax

public void setPixelSizeInScanningDirection(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setPixelSizePerpendicularToScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setPixelSizePerpendicularToScanningDirection Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Pixel Size Perpendicular To Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixel Size Perpendicular To Scanning Direction DataSet (3:50). The DataSet indicates the number of pixels per unit length perpendicular to the scanning direction.

Syntax

public void setPixelSizePerpendicularToScanningDirection(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setPixelsPerLine Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setPixelsPerLine Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Pixels Per Line IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Pixels Per Line DataSet (3:20). The DataSet represents the number of pixels in a scan line for the component with the highest resolution.

Syntax

public void setPixelsPerLine(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setProductID Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setProductID Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets ProductID IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Product I.D. DataSet (1:50). The DataSet allows a provider to identify subsets of its overall service. Used to provide receiving organization data on which to select, route, or otherwise handle data.

Repeatable (array items represent repeated values). Up to 32 bytes, consisting of graphic characters.

Syntax

public void setProductID(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setProgramVersion Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setProgramVersion Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Program Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Program Version DataSet (2:70). The DataSet identifies the version of the program mentioned in Originating Program DataSet (2:65). Invalid if 2:65 is not present.

Maximum of 10 bytes, consisting of graphic characters plus spaces.

Syntax

public void setProgramVersion(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setProvinceState Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setProvinceState Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Province State IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Province/State DataSet (2:95). The DataSet identifies Province/State of origin according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setProvinceState(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setQuantisationMethod Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setQuantisationMethod Method
value
Nullable (boxed) ImGearIPTCQuantisationMethod enumeration value. *

ImGearIPTCQuantisationMethod

Glossary Item Box

Sets Quantisation method IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Quantisation method DataSet (3:120). The DataSet identifies the quantisation law. The relations between different quantisation methods are described in DNPR Guideline 1.

Syntax

public void setQuantisationMethod(
   ImGearIPTCQuantisationMethod value
)

Parameters

value
Nullable (boxed) ImGearIPTCQuantisationMethod enumeration value. *

ImGearIPTCQuantisationMethod

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setRasterizedCaption Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setRasterizedCaption Method
value
Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Rasterized Caption IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Rasterized Caption DataSet (2:125). The DataSet contains the rasterized objectdata description and is used where characters that have not been coded are required for the caption.

Contains 7360 bytes, consisting of binary data, one bit per pixel, two value bitmap where 1 (one) represents black and 0 (zero) represents white. Image width 460 pixels and image height 128 pixels. Scanning direction bottom to top, left to right.

Syntax

public void setRasterizedCaption(
   byte[] value
)

Parameters

value
Array of bytes. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setRecord2Version Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setRecord2Version Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Record2 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record II Version DataSet (2:00). The DataSet identifies the version of the Information Interchange Model, Part II (Record 2:xx), utilised by the provider. Version numbers are assigned by IPTC and NAA.

Syntax

public void setRecord2Version(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setRecord3Version Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setRecord3Version Method
value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

Glossary Item Box

Sets Record3 Version IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Record Version DataSet (3:00). The DataSet represents the version of the Digital Newsphoto Parameter Record utilized by the provider. Version numbers are assigned by IPTC and NAA.

Syntax

public void setRecord3Version(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the IPTC - NAA Digital Newsphoto Parameter Record ver.4 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setReferenceDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setReferenceDate Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Reference Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Date DataSet (2:47). The DataSet identifies the date of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values). Uses the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month and day.

Syntax

public void setReferenceDate(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setReferenceNumber Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setReferenceNumber Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Reference Number IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Number DataSet (2:50). The DataSet identifies the Envelope Number of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), eight bytes, consisting of numeric characters.

Syntax

public void setReferenceNumber(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setReferenceService Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setReferenceService Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Reference Service IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Reference Service DataSet (2:45). The DataSet identifies the Service Identifier of a prior envelope to which the current object refers.

Repeatable (array items represent repeated values), up to 10 bytes, consisting of graphic characters.

Syntax

public void setReferenceService(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setReleaseDate Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setReleaseDate Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Release Date IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Date DataSet (2:30). The DataSet designates in the form CCYYMMDD the earliest date the provider intends the object to be used. Follows ISO 8601 standard.

Eight bytes, consisting of numeric characters.

Syntax

public void setReleaseDate(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setReleaseTime Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setReleaseTime Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Release Time IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Release Time DataSet (2:35). The DataSet designates in the form HHMMSS-HHMM the earliest time the provider intends the object to be used. Follows ISO 8601 standard.

Contains 11 bytes, consisting of graphic characters.

Syntax

public void setReleaseTime(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSamplingStructure Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSamplingStructure Method
value
Nullable (boxed) ImGearIPTCSamplingStructure enumeration value. *

ImGearIPTCSamplingStructure

Glossary Item Box

Sets Sampling structure IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sampling structure DataSet (3:90). The DataSet defines the spatial and temporal relationship between pixels.

Syntax

public void setSamplingStructure(
   ImGearIPTCSamplingStructure value
)

Parameters

value
Nullable (boxed) ImGearIPTCSamplingStructure enumeration value. *

ImGearIPTCSamplingStructure

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setScanningDirection Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setScanningDirection Method
value
Nullable (boxed) ImGearIPTCScanningDirection enumeration value. *

ImGearIPTCScanningDirection

Glossary Item Box

Sets Scanning Direction IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Scanning Direction DataSet (3:100). The DataSet indicates the correct relative two dimensional order of the pixels in the objectdata.

Syntax

public void setScanningDirection(
   ImGearIPTCScanningDirection value
)

Parameters

value
Nullable (boxed) ImGearIPTCScanningDirection enumeration value. *

ImGearIPTCScanningDirection

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setServiceIdentifier Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setServiceIdentifier Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Service Identifier IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Service Identifier DataSet (1:30). The DataSet identifies the provider and product.

Contains up to 10 bytes, consisting of graphic characters.

Syntax

public void setServiceIdentifier(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSizeMode Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSizeMode Method
value
Nullable (boxed) ImGearIPTCSizeMode enumeration value. *

ImGearIPTCSizeMode

Glossary Item Box

Sets Size Mode IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Size Mode DataSet (7:10). The DataSet indicates whether the size of the objectdata is known at the beginning of transfer.

Syntax

public void setSizeMode(
   ImGearIPTCSizeMode value
)

Parameters

value
Nullable (boxed) ImGearIPTCSizeMode enumeration value. *

ImGearIPTCSizeMode

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSource Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSource Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Source IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Source DataSet (2:115). The DataSet identifies the original owner of the intellectual content of the objectdata. This could be an agency, a member of an agency or an individual.

Maximum of 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setSource(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSpecialInstructions Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSpecialInstructions Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Special Instructions IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Special Instructions DataSet (2:40). The DataSet contains other editorial instructions concerning the use of the objectdata, such as embargoes and warnings.

Maximum 256 bytes, consisting of graphic characters plus spaces.

Syntax

public void setSpecialInstructions(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSubjectReference Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSubjectReference Method
value
ImGearIPTCSubjectReference structure[] array. *

ImGearIPTCSubjectReference

Glossary Item Box

Sets Subject Reference IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Subject Reference DataSet (2:12). The DataSet represents a structured definition of the subject matter.

Repeatable (array items represent repeated values).

Syntax

public void setSubjectReference(
   ImGearIPTCSubjectReference[] value
)

Parameters

value
ImGearIPTCSubjectReference structure[] array. *

ImGearIPTCSubjectReference

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSublocation Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSublocation Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Sublocation IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Sublocation DataSet (2:92). The DataSet identifies the location within a city from which the objectdata originates, according to guidelines established by the provider.

Maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setSublocation(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSupplementalCategory Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSupplementalCategory Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Supplemental Category IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplemental Category DataSet (2:20). The DataSet further refines the subject of an objectdata.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setSupplementalCategory(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setSupplementType Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setSupplementType Method
value
Nullable (boxed) ImGearIPTCSupplementType enumeration value. *

ImGearIPTCSupplementType

Glossary Item Box

Sets Supplement Type IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Supplement Type. DataSet (3:55). The DataSet indicates the image content.

Syntax

public void setSupplementType(
   ImGearIPTCSupplementType value
)

Parameters

value
Nullable (boxed) ImGearIPTCSupplementType enumeration value. *

ImGearIPTCSupplementType

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setTimeCreated Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setTimeCreated Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Time Created IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Created DataSet (2:60). The DataSet designates the time the intellectual content of the objectdata current source material was created rather than the creation of the physical representation.

Contains 11 bytes, consisting of graphic characters. Represented in the form HHMMSS-HHMM. Follows ISO 8601 standard.

Syntax

public void setTimeCreated(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setTimeSent Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setTimeSent Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Time Sent IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Time Sent DataSet (1:80). The DataSet indicates the time the service sent the material.

Contains 11 bytes, consisting of graphic characters. Uses the format HHMMSS-HHMM where HHMMSS refers to local hour, minute, and seconds and HHMM refers to hours and minutes ahead (+) or behind (-) Universal Coordinated Time as described in ISO 8601.

Syntax

public void setTimeSent(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setUNO Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setUNO Method
value
Nullable (boxed) ImGearIPTCUNO structure object. *

ImGearIPTCUNO

Glossary Item Box

Sets UNO IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the UNO DataSet (1:100). The UNO (Unique Name of Object) DataSet provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Syntax

public void setUNO(
   ImGearIPTCUNO value
)

Parameters

value
Nullable (boxed) ImGearIPTCUNO structure object. *

ImGearIPTCUNO

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setUrgency Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setUrgency Method
value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Urgency IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Urgency DataSet (2:10). The DataSet Specifies the editorial urgency of content and not necessarily the envelope handling priority.

Syntax

public void setUrgency(
   java.lang.String value
)

Parameters

value
String value. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

setWriter_Editor Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCMetadata Class : setWriter_Editor Method
value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

Glossary Item Box

Sets Writer/Editor IPTC dataset.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Writer/Editor DataSet (2:122). The DataSet contains identification of the name of the person involved in the writing, editing, or correcting the objectdata or caption/abstract.

Repeatable (array items represent repeated values), maximum 32 bytes, consisting of graphic characters plus spaces.

Syntax

public void setWriter_Editor(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the IPTC - NAA Information Interchange Model ver. 4.1 specification for tag usage details.

See Also

Reference

ImGearIPTCMetadata Class
ImGearIPTCMetadata Members


%%PageItemTitle%%

ImGearIPTCObjectAttributeReference Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectAttributeReference Class

Glossary Item Box

Represents IPTC Object Attribute Reference structure.

This structure represents IPTC Object Attribute Reference structure, used in the Object Attribute Reference DataSet (2:04).

Object Model

ImGearIPTCObjectAttributeReference ClassImGearIPTCObjectAttributeReference Class

Syntax

public sealed class ImGearIPTCObjectAttributeReference
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectAttributeReference

See Also

Reference

ImGearIPTCObjectAttributeReference Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCObjectAttributeReference Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectAttributeReference Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCObjectAttributeReference.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCObjectAttributeReference Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | name | Object Attribute Name. string value. This value represents an optional text representation of the Object Attribute Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | number | Object Attribute Number. ImGearIPTCObjectAttributeNumber enumeration value. This value represents a language independent international reference to an Object Attribute. ImGearIPTCObjectAttributeNumber
Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCObjectAttributeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCObjectAttributeReference Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectAttributeReference Class : ImGearIPTCObjectAttributeReference Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCObjectAttributeReference()

See Also

Reference

ImGearIPTCObjectAttributeReference Class
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCObjectAttributeReference Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectAttributeReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCObjectAttributeReference members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCObjectAttributeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectAttributeReference Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCObjectAttributeReference clone()

See Also

Reference

ImGearIPTCObjectAttributeReference Class
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectAttributeReference Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCObjectAttributeReference Class
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCObjectAttributeReference Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectAttributeReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCObjectAttributeReference members.

Public Fields

 | Name | Description
public Field | name | Object Attribute Name. string value. This value represents an optional text representation of the Object Attribute Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | number | Object Attribute Number. ImGearIPTCObjectAttributeNumber enumeration value. This value represents a language independent international reference to an Object Attribute. ImGearIPTCObjectAttributeNumber
Top

See Also

Reference

ImGearIPTCObjectAttributeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

name Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectAttributeReference Class : name Field

Glossary Item Box

Object Attribute Name.

string value.

This value represents an optional text representation of the Object Attribute Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Syntax

public java.lang.String name

Return Value

string value.

See Also

Reference

ImGearIPTCObjectAttributeReference Class
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%%

number Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectAttributeReference Class : number Field

Glossary Item Box

Object Attribute Number.

ImGearIPTCObjectAttributeNumber enumeration value.

This value represents a language independent international reference to an Object Attribute.

ImGearIPTCObjectAttributeNumber

Syntax

public ImGearIPTCObjectAttributeNumber number

Return Value

ImGearIPTCObjectAttributeNumber enumeration value.

See Also

Reference

ImGearIPTCObjectAttributeReference Class
ImGearIPTCObjectAttributeReference Members


%%PageItemTitle%%

ImGearIPTCObjectTypeReference Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectTypeReference Class

Glossary Item Box

Represents IPTC Object Type Reference structure.

This structure represents IPTC Object Type Reference structure, used in the Object Type Reference DataSet (2:03). The Object Type is used to distinguish between different types of objects within the IIM.

Object Model

ImGearIPTCObjectTypeReference ClassImGearIPTCObjectTypeReference Class

Syntax

public sealed class ImGearIPTCObjectTypeReference
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectTypeReference

See Also

Reference

ImGearIPTCObjectTypeReference Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCObjectTypeReference Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectTypeReference Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCObjectTypeReference.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCObjectTypeReference Constructor | Default constructor.
Top

Public Fields

 | Name | Description
public Field | name | Object Type Name. string value. This value represents an optional text representation of the Object Type Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | number | Object Type Number. ImGearIPTCObjectTypeNumber enumeration value. This value represents a language independent international reference to an Object Type. ImGearIPTCObjectTypeNumber
Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCObjectTypeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCObjectTypeReference Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectTypeReference Class : ImGearIPTCObjectTypeReference Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearIPTCObjectTypeReference()

See Also

Reference

ImGearIPTCObjectTypeReference Class
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCObjectTypeReference Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectTypeReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCObjectTypeReference members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCObjectTypeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectTypeReference Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCObjectTypeReference clone()

See Also

Reference

ImGearIPTCObjectTypeReference Class
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectTypeReference Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCObjectTypeReference Class
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCObjectTypeReference Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectTypeReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCObjectTypeReference members.

Public Fields

 | Name | Description
public Field | name | Object Type Name. string value. This value represents an optional text representation of the Object Type Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | number | Object Type Number. ImGearIPTCObjectTypeNumber enumeration value. This value represents a language independent international reference to an Object Type. ImGearIPTCObjectTypeNumber
Top

See Also

Reference

ImGearIPTCObjectTypeReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

name Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectTypeReference Class : name Field

Glossary Item Box

Object Type Name.

string value.

This value represents an optional text representation of the Object Type Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Syntax

public java.lang.String name

Return Value

string value.

See Also

Reference

ImGearIPTCObjectTypeReference Class
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%%

number Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCObjectTypeReference Class : number Field

Glossary Item Box

Object Type Number.

ImGearIPTCObjectTypeNumber enumeration value.

This value represents a language independent international reference to an Object Type.

ImGearIPTCObjectTypeNumber

Syntax

public ImGearIPTCObjectTypeNumber number

Return Value

ImGearIPTCObjectTypeNumber enumeration value.

See Also

Reference

ImGearIPTCObjectTypeReference Class
ImGearIPTCObjectTypeReference Members


%%PageItemTitle%%

ImGearIPTCPictureNumber Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCPictureNumber Class

Glossary Item Box

Represents IPTC Picture Number structure.

This structure represents IPTC Picture Number structure, used in the Picture Number DataSet (3:10). The picture number provides a universally unique reference to an image. For example, color images, when split with color components into multiple objects, i.e., envelopes, would carry the same Picture Number.

Object Model

ImGearIPTCPictureNumber ClassImGearIPTCPictureNumber Class

Syntax

public sealed class ImGearIPTCPictureNumber
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCPictureNumber

See Also

Reference

ImGearIPTCPictureNumber Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCPictureNumber Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCPictureNumber Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCPictureNumber.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCPictureNumber Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | dateIdentifier | Indicates the date the picture number was generated. string value. This value represents eight numeric characters using the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the picture number was generated.
public Field | deviceIdentifier | Identifies the device that has generated the picture number. int value. This value represents a binary number identifying the device that has generated the picture number.
public Field | numericIdentifier | A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet. int value. This value represents a binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCPictureNumber Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCPictureNumber Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : ImGearIPTCPictureNumber Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCPictureNumber()

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCPictureNumber Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCPictureNumber Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCPictureNumber members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCPictureNumber Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCPictureNumber clone()

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCPictureNumber Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCPictureNumber Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCPictureNumber members.

Public Fields

 | Name | Description
public Field | dateIdentifier | Indicates the date the picture number was generated. string value. This value represents eight numeric characters using the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the picture number was generated.
public Field | deviceIdentifier | Identifies the device that has generated the picture number. int value. This value represents a binary number identifying the device that has generated the picture number.
public Field | numericIdentifier | A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet. int value. This value represents a binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.
Top

See Also

Reference

ImGearIPTCPictureNumber Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

dateIdentifier Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : dateIdentifier Field

Glossary Item Box

Indicates the date the picture number was generated.

string value.

This value represents eight numeric characters using the format CCYYMMDD (century, year, month, day) as defined in ISO 8601 to indicate year, month, and day the picture number was generated.

Syntax

public java.lang.String dateIdentifier

Return Value

string value.

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%%

deviceIdentifier Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : deviceIdentifier Field

Glossary Item Box

Identifies the device that has generated the picture number.

int value.

This value represents a binary number identifying the device that has generated the picture number.

Syntax

public int deviceIdentifier

Return Value

int value.

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%%

numericIdentifier Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCPictureNumber Class : numericIdentifier Field

Glossary Item Box

A binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.

int value.

This value represents a binary number generated each time a picture number is created and being unique for the same device and for the date contained in this DataSet.

Syntax

public int numericIdentifier

Return Value

int value.

See Also

Reference

ImGearIPTCPictureNumber Class
ImGearIPTCPictureNumber Members


%%PageItemTitle%%

ImGearIPTCSubjectReference Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSubjectReference Class

Glossary Item Box

Represents IPTC Subject Reference structure.

This structure represents IPTC Subject Reference structure, used in the Subject Reference DataSet (2:12). The Subject Reference is a structured definition of the subject matter.

Object Model

ImGearIPTCSubjectReference ClassImGearIPTCSubjectReference Class

Syntax

public sealed class ImGearIPTCSubjectReference
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCSubjectReference

See Also

Reference

ImGearIPTCSubjectReference Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCSubjectReference Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSubjectReference Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCSubjectReference.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCSubjectReference Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | ipr | Information Provider Reference. string value. A name, registered with the IPTC/NAA, identifying the provider that provides an indicator of the SDR content. The default value for the IPR is "IPTC" and is mandatory if the Subject Reference exists in the IPTC coding scheme. Contains 1-32 bytes.
public Field | subjectDetailName | Subject Detail Name. string value. This value represents a text representation of the Subject Detail Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectMatterName | Subject Matter Name. string value. This value represents a text representation of the Subject Matter Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectName | Subject Name. string value. This value represents a text representation of the Subject Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectReferenceNumber | Subject Reference Number. ImGearIPTCSubjectReferenceNumber enumeration value. This member variable provides a numeric code to indicate the Subject Name plus optional Subject Matter and Subject Detail Names in the language of the service. ImGearIPTCSubjectReferenceNumber
Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCSubjectReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCSubjectReference Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : ImGearIPTCSubjectReference Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearIPTCSubjectReference()

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCSubjectReference Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSubjectReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCSubjectReference members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCSubjectReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCSubjectReference clone()

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCSubjectReference Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSubjectReference Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCSubjectReference members.

Public Fields

 | Name | Description
public Field | ipr | Information Provider Reference. string value. A name, registered with the IPTC/NAA, identifying the provider that provides an indicator of the SDR content. The default value for the IPR is "IPTC" and is mandatory if the Subject Reference exists in the IPTC coding scheme. Contains 1-32 bytes.
public Field | subjectDetailName | Subject Detail Name. string value. This value represents a text representation of the Subject Detail Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectMatterName | Subject Matter Name. string value. This value represents a text representation of the Subject Matter Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectName | Subject Name. string value. This value represents a text representation of the Subject Number. Contains a maximum of 64 bytes consisting of graphic characters plus spaces.
public Field | subjectReferenceNumber | Subject Reference Number. ImGearIPTCSubjectReferenceNumber enumeration value. This member variable provides a numeric code to indicate the Subject Name plus optional Subject Matter and Subject Detail Names in the language of the service. ImGearIPTCSubjectReferenceNumber
Top

See Also

Reference

ImGearIPTCSubjectReference Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ipr Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : ipr Field

Glossary Item Box

Information Provider Reference.

string value.

A name, registered with the IPTC/NAA, identifying the provider that provides an indicator of the SDR content. The default value for the IPR is "IPTC" and is mandatory if the Subject Reference exists in the IPTC coding scheme.

Contains 1-32 bytes.

Syntax

public java.lang.String ipr

Return Value

string value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

subjectDetailName Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : subjectDetailName Field

Glossary Item Box

Subject Detail Name.

string value.

This value represents a text representation of the Subject Detail Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Syntax

public java.lang.String subjectDetailName

Return Value

string value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

subjectMatterName Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : subjectMatterName Field

Glossary Item Box

Subject Matter Name.

string value.

This value represents a text representation of the Subject Matter Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Syntax

public java.lang.String subjectMatterName

Return Value

string value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

subjectName Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : subjectName Field

Glossary Item Box

Subject Name.

string value.

This value represents a text representation of the Subject Number.

Contains a maximum of 64 bytes consisting of graphic characters plus spaces.

Syntax

public java.lang.String subjectName

Return Value

string value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

subjectReferenceNumber Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCSubjectReference Class : subjectReferenceNumber Field

Glossary Item Box

Subject Reference Number.

ImGearIPTCSubjectReferenceNumber enumeration value.

This member variable provides a numeric code to indicate the Subject Name plus optional Subject Matter and Subject Detail Names in the language of the service.

ImGearIPTCSubjectReferenceNumber

Syntax

public ImGearIPTCSubjectReferenceNumber subjectReferenceNumber

Return Value

ImGearIPTCSubjectReferenceNumber enumeration value.

See Also

Reference

ImGearIPTCSubjectReference Class
ImGearIPTCSubjectReference Members


%%PageItemTitle%%

ImGearIPTCUNO Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCUNO Class

Glossary Item Box

Represents IPTC UNO structure.

This structure represents UNO structure, used in the UNO DataSet (1:100). The UNO (Unique Name of Object) provides eternal, globally unique identification for objects as specified in the IIM, independent of provider and for any media form. The provider must ensure the UNO is unique. Objects with the same UNO are identical.

Object Model

ImGearIPTCUNO ClassImGearIPTCUNO Class

Syntax

public sealed class ImGearIPTCUNO
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.iptc.ImGearIPTCUNO

See Also

Reference

ImGearIPTCUNO Members
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTCUNO Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCUNO Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTCUNO.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTCUNO Constructor | Default constructor.
Top

Public Fields

Name Description
public Field ipr Information Provider Reference (IPR).

string value.

This value represents the IPR element of IPTC UNO structure. The IPR (Information Provider Reference) specifies a name, registered with the IPTC/NAA, identifying the provider that guarantees the uniqueness of the UNO. It may assist in locating an object source.

Contains a minimum of one and a maximum of 32 bytes. A string of graphic characters, except colon ':' solidus '/', asterisk '*' and question mark '?', registered with, and approved by, the IPTC.

public Field ode Object Descriptor Element (ODE).

string value.

This value represents the ODE element of IPTC UNO structure. The ODE (Object Descriptor Element), in conjunction with the UCD and the IPR, ensures the uniqueness of the UNO. The provider may structure the element by use of a solidus '/' character.

Contains a minimum of one and a maximum of 60 minus the number of IPR bytes, consisting of graphic characters, except colon ':' asterisk '*' and question mark '?'.

public Field ovi Object Variant Indicator (OVI).

string value.

This value represents the OVI element of IPTC UNO structure. The OVI (Object Variant Indicator) indicates technical variants of the object such as partial objects, or changes of file formats, and coded character sets.

Contains a minimum of one and a maximum of 9 bytes, consisting of graphic characters, except colon ':', asterisk '*' and question mark '?'.

public Field ucd UNO Creation Date (UCD).

string value.

This value represents the UCD element of IPTC UNO structure. The UCD (UNO Creation Date) specifies a 24 hour period in which the further elements of the UNO have to be unique. It also provides a search facility.

Contains 8 bytes in ISO 8601 date format (CCYYMMDD), consisting of numeric characters.

Top

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCUNO Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCUNO Constructor
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : ImGearIPTCUNO Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearIPTCUNO()

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTCUNO Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCUNO Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCUNO members.

Public Methods

 | Name | Description
public Method | clone |
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearIPTCUNO Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : clone Method

Glossary Item Box

Syntax

public ImGearIPTCUNO clone()

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearIPTCUNO Class Fields
See Also Send Feedback
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCUNO Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTCUNO members.

Public Fields

Name Description
public Field ipr Information Provider Reference (IPR).

string value.

This value represents the IPR element of IPTC UNO structure. The IPR (Information Provider Reference) specifies a name, registered with the IPTC/NAA, identifying the provider that guarantees the uniqueness of the UNO. It may assist in locating an object source.

Contains a minimum of one and a maximum of 32 bytes. A string of graphic characters, except colon ':' solidus '/', asterisk '*' and question mark '?', registered with, and approved by, the IPTC.

public Field ode Object Descriptor Element (ODE).

string value.

This value represents the ODE element of IPTC UNO structure. The ODE (Object Descriptor Element), in conjunction with the UCD and the IPR, ensures the uniqueness of the UNO. The provider may structure the element by use of a solidus '/' character.

Contains a minimum of one and a maximum of 60 minus the number of IPR bytes, consisting of graphic characters, except colon ':' asterisk '*' and question mark '?'.

public Field ovi Object Variant Indicator (OVI).

string value.

This value represents the OVI element of IPTC UNO structure. The OVI (Object Variant Indicator) indicates technical variants of the object such as partial objects, or changes of file formats, and coded character sets.

Contains a minimum of one and a maximum of 9 bytes, consisting of graphic characters, except colon ':', asterisk '*' and question mark '?'.

public Field ucd UNO Creation Date (UCD).

string value.

This value represents the UCD element of IPTC UNO structure. The UCD (UNO Creation Date) specifies a 24 hour period in which the further elements of the UNO have to be unique. It also provides a search facility.

Contains 8 bytes in ISO 8601 date format (CCYYMMDD), consisting of numeric characters.

Top

See Also

Reference

ImGearIPTCUNO Class
com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ipr Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : ipr Field

Glossary Item Box

Information Provider Reference (IPR).

string value.

This value represents the IPR element of IPTC UNO structure. The IPR (Information Provider Reference) specifies a name, registered with the IPTC/NAA, identifying the provider that guarantees the uniqueness of the UNO. It may assist in locating an object source.

Contains a minimum of one and a maximum of 32 bytes. A string of graphic characters, except colon ':' solidus '/', asterisk '*' and question mark '?', registered with, and approved by, the IPTC.

Syntax

public java.lang.String ipr

Return Value

string value.

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%%

ode Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : ode Field

Glossary Item Box

Object Descriptor Element (ODE).

string value.

This value represents the ODE element of IPTC UNO structure. The ODE (Object Descriptor Element), in conjunction with the UCD and the IPR, ensures the uniqueness of the UNO. The provider may structure the element by use of a solidus '/' character.

Contains a minimum of one and a maximum of 60 minus the number of IPR bytes, consisting of graphic characters, except colon ':' asterisk '*' and question mark '?'.

Syntax

public java.lang.String ode

Return Value

string value.

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%%

ovi Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : ovi Field

Glossary Item Box

Object Variant Indicator (OVI).

string value.

This value represents the OVI element of IPTC UNO structure. The OVI (Object Variant Indicator) indicates technical variants of the object such as partial objects, or changes of file formats, and coded character sets.

Contains a minimum of one and a maximum of 9 bytes, consisting of graphic characters, except colon ':', asterisk '*' and question mark '?'.

Syntax

public java.lang.String ovi

Return Value

string value.

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%%

ucd Field
com.accusoft.imagegear.formats.iptc Package > ImGearIPTCUNO Class : ucd Field

Glossary Item Box

UNO Creation Date (UCD).

string value.

This value represents the UCD element of IPTC UNO structure. The UCD (UNO Creation Date) specifies a 24 hour period in which the further elements of the UNO have to be unique. It also provides a search facility.

Contains 8 bytes in ISO 8601 date format (CCYYMMDD), consisting of numeric characters.

Syntax

public java.lang.String ucd

Return Value

string value.

See Also

Reference

ImGearIPTCUNO Class
ImGearIPTCUNO Members


%%PageItemTitle%%

ImGearIPTCActionAdvised Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCActionAdvised Enumeration

Glossary Item Box

Represents IPTC Advised Actions.

Members

Member | Description
ObjectAppend | Object Append.
ObjectKill | Object Kill.
ObjectReference | Object Reference.
ObjectReplace | Object Replace.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCActionAdvised

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCAudioChannelMode Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioChannelMode Enumeration

Glossary Item Box

Represents IPTC Audio Channel Modes.

Members

Member | Description
Monaural | Monaural (1 channel) audio.
NoObjectdata | No object data.
Stereo | Stereo (2 channel) audio.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCAudioChannelMode

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCAudioContentType Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCAudioContentType Enumeration

Glossary Item Box

Represents IPTC Audio Content Types.

Members

Member | Description
Actuality | Actuality content type.
MusicTransmittedByItself | Music, transmitted by itself content type.
QuestionAndAnswerSession | Question and answer session content type.
RawSound | Raw sound content type.
ResponseToAQuestion | Response to a question content type.
Scener | Scener content type.
TextOnly | Text only content type.
Voicer | Voicer content type.
Wrap | Wrap content type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCAudioContentType

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCDataCompressionMethod Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCDataCompressionMethod Enumeration

Glossary Item Box

Represents IPTC Data Compression Methods.

Members

Member | Description
Hasselblad_2 | Hasselblad type 2.
Hasselblad_3 | Hasselblad type 3.
JFIF_1_01 | JFIF 1.01.
JFIF_1_02 | JFIF 1.02.
JPEG | JPEG ITU-T Rec T.81 /ISO/IEC 10918-1.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCDataCompressionMethod

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCExcursionTolerance Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCExcursionTolerance Enumeration

Glossary Item Box

Represents IPTC Excursion Tolerance modes.

Members

Member | Description
MayOccur | May occur.
NotAllowed | Not allowed.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCExcursionTolerance

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCFileFormatID Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCFileFormatID Enumeration

Glossary Item Box

Represents IPTC File Format IDs.

Members

Member | Description
AIFF | Audio Interchange File Format AIFF (Apple Computer Inc).
AppleSingle | AppleSingle (Apple Computer Inc).
AVI | Audio plus Moving Video [*.AVI] (Microsoft).
BMP | Microsoft Bit Mapped CSGraphics File [*.BMP].
CorelDraw | Corel draw [*.CDR].
Executable | PC DOS/Windows Executable Files [*.COM][*.EXE].
Freehand | Freehand (Macromedia/Aldus).
HTML | Hypertext Markup Language "HTML" (The Internet Society).
Illustrator | Illustrator (Adobe CSGraphics data).
IPTC7901RecommendedMessageFormat | IPTC7901 Recommended Message Format.
IPTCNAADigitalNewsphotoParameterRecord | IPTC-NAA Digital Newsphoto Parameter Record.
JFIF | JPEG File Interchange (JFIF).
MacBinaryII | MacBinary II.
MPEG2AudioLayer2 | MPEG 2 Audio Layer 2 (Musicom).
MPEG2AudioLayer3 | MPEG 2 Audio Layer 3.
NAA_89_3_ANPA_1312 | NAA 89-3 (ANPA 1312) file format.
NITF | News Industry Text Format (NITF).
NoObjectData | No object data.
PDF | Portable Document File (*.PDF) Adobe.
PhotoCD | Photo-CD Image-Pac (Eastman Kodak).
RBNITF | Ritzaus Bureau NITF version (RBNITF DTD).
RIFFWave | RIFF Wave (Microsoft Corporation).
TAR | Tape Archive (*.TAR).
TIFF | Tagged Image File Format (Adobe/Aldus Image data).
TTNITF | Tidningarnas Telegrambyr? NITF version (TTNITF DTD).
UCOFF | IPTC Unstructured Character Oriented File Format (UCOFF).
UPI_ANPA_1312_Variant | United Press International ANPA 1312 variant.
UPIDownLoadMessage | United Press International Down-Load Message.
WAV | Digital Audio File [*.WAV] (Microsoft and Creative Labs).
ZIP | Compressed Binary File [*.ZIP] (PKWare Inc).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCFileFormatID

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageBuildUpStructure Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageBuildUpStructure Enumeration

Glossary Item Box

Represents IPTC Image Build Up Structures.

Members

Member | Description
FrameSequentialInMultipleObjects | Frame Sequential In Multiple Objects.
FrameSequentialInOneObject | Frame Sequential In One Object.
LineSequential | Line Sequential.
PixelSequential | Pixel Sequential.
SingleFrame | Single Frame.
SpecialInterleavingStructure | Special Interleaving structure.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageBuildUpStructure

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageColourMode Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageColourMode Enumeration

Glossary Item Box

Represents IPTC Image Colour Modes.

Members

Member | Description
BlackComponent | Black Component.
BlueComponent | Blue Component.
CyanComponent | Cyan Component.
FullColourCompositeFrameSequential | Full Colour Composite Frame Sequential.
FullColourCompositeLineSequential | Full Colour Composite Line Sequential.
FullColourCompositePixelSequential | Full Colour Composite Pixel Sequential.
FullColourCompositeSpecialInterleaving | Full Colour Composite Special Interleaving.
GreenComponent | Green Component.
MagentaComponent | Magenta Component.
Monochrome | Monochrome mode.
RedComponent | Red Component.
TextOnly | Text Only.
YellowComponent | Yellow Component.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageColourMode

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageComponentMode Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageComponentMode Enumeration

Glossary Item Box

Represents IPTC Image Component Modes.

Members

Member | Description
MultiComponent2 | Two components.
MultiComponent3 | Three components.
MultiComponent4 | Four components.
NoObjectData | No object data.
SingleComponent | Single component.
SupplementalObjects | Supplemental objects.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageComponentMode

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageOrientation Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageOrientation Enumeration

Glossary Item Box

Represents IPTC Image Orientations.

Members

Member | Description
Landscape | Landscape orientation.
Portrait | Portrait orientation.
Square | Square orientation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageOrientation

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCImageRotation Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCImageRotation Enumeration

Glossary Item Box

Represents IPTC Image Rotations.

Members

Member | Description
NoRotation | No rotation.
Rotation180Degrees | 180 degrees rotation.
Rotation270Degrees | 270 degrees rotation.
Rotation90Degrees | 90 degrees rotation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCImageRotation

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCInterchangeColourSpace Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCInterchangeColourSpace Enumeration

Glossary Item Box

Represents IPTC Interchange Colour Spaces.

Members

Member | Description
CIELab_K | L*a*b* (K) CIE colour space (default illuminant D50).
CIEXYZ | X,Y,Z CIE colour space (default illuminant D50).
DeviceDependentCMYK | CMY(K) device dependent.
DeviceDependentRGB | RGB device dependent.
SMPTERGB | RGB SMPTE colour space.
sRGB | Colour space is sRGB.
YCbCr | Colour space is YCbCr.
YUV_K | Y,U,V (K) (default illuminant D65).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCInterchangeColourSpace

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCObjectAttributeNumber Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectAttributeNumber Enumeration

Glossary Item Box

Represents IPTC Object Attribute Numbers.

Members

Member | Description
Analysis | Analysis attribute number.
ArchiveMaterial | Archive Material attribute number.
Background | Background attribute number.
Current | Current attribute number.
Feature | Feature attribute number.
Forecast | Forecast attribute number.
FromTheScene | From The Scene attribute number.
History | History attribute number.
Interview | Interview attribute number.
Obituary | Obituary attribute number.
Opinion | Opinion attribute number.
PollsAndSurveys | Polls And Surveys attribute number.
PressRelease | Press Release attribute number.
Profile | Profile attribute number.
ResultsListingsAndTables | Results Listings and Tables attribute number.
Retrospective | Retrospective attribute number.
SideBarAndSupportingInformation | Side Bar and Supporting Information attribute number.
Statistics | Statistics attribute number.
Summary | Summary attribute number.
TranscriptAndVerbatim | Transcript and Verbatim attribute number.
Update | Update attribute number.
WrapUp | Wrap Up attribute number.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectAttributeNumber

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCObjectCycle Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectCycle Enumeration

Glossary Item Box

Represents IPTC Object Cycles.

Members

Member | Description
Both | Both cycles.
Evening | Evening cycle.
Morning | Morning cycle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectCycle

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCObjectTypeNumber Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCObjectTypeNumber Enumeration

Glossary Item Box

Represents IPTC Object Type Numbers.

Members

Member | Description
Advisory | Advisory type number.
Data | Data type number.
News | News type number.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCObjectTypeNumber

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCQuantisationMethod Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCQuantisationMethod Enumeration

Glossary Item Box

Represents IPTC Quantisation Methods.

Members

Member | Description
APDomesticAnalogue | AP Domestic Analogue.
ColourSpaceSpecific | Colour Space Specific.
CompressionMethodSpecific | Compression method Specific.
GammaCompensated | Gamma Compensated.
IPTCRefB | IPTC Ref B.
LinearDensity | Linear Density.
LinearDotPercent | Linear Dot Percent.
LinearReflectance_Transmittance | Linear Reflectance/Transmittance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCQuantisationMethod

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCSamplingStructure Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSamplingStructure Enumeration

Glossary Item Box

Represents IPTC Sampling Structures.

Members

Member | Description
DefinedWithinCompressionProcess | Defined within the compression process.
Orthogonal | Orthogonal with the same relative sampling frequencies on each component.
Orthogonal_422_4 | Orthogonal with the sampling frequencies in the ratio of 4:2:2:(4) as described in Appendix G. This structure can only be used with the YUV(K) or LAB(K) colour spaces.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCSamplingStructure

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCScanningDirection Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCScanningDirection Enumeration

Glossary Item Box

Represents IPTC Scanning Directions.

Members

Member | Description
BottomToTop_LeftToRight | Bottom To Top, Left To Right.
BottomToTop_RightToLeft | Bottom To Top, Right To Left.
LeftToRight_BottomToTop | Left To Right, Bottom To Top.
LeftToRight_TopToBottom | Left To Right, Top To Bottom.
RightToLeft_BottomToTop | Right To Left, Bottom To Top.
RightToLeft_TopToBottom | Right To Left, Top To Bottom.
TopToBottom_LeftToRight | Top To Bottom, Left To Right.
TopToBottom_RightToLeft | Top To Bottom, Right To Left.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCScanningDirection

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCSizeMode Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSizeMode Enumeration

Glossary Item Box

Represents IPTC Size Modes.

Members

Member | Description
Known | Size is known.
NotKnown | Size is not known.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCSizeMode

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCSubjectReferenceNumber Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSubjectReferenceNumber Enumeration

Glossary Item Box

Represents IPTC Subject Reference Numbers.

Members

Member | Description
AccountancyAndAuditing | Accountancy and Auditing subject reference number.
ActsOfTerror | Acts of terror subject reference number.
Addiction | Addiction subject reference number.
AdultEducation | Adult Education subject reference number.
Advertising | Advertising subject reference number.
AeroAndAviationSports | Aero and Aviation Sports subject reference number.
Aerospace | Aerospace subject reference number.
Agriculture | Agriculture subject reference number.
AirTransport | Air Transport subject reference number.
AlcoholicDrinks | Alcoholic Drinks subject reference number.
AlpineSkiing | Alpine Skiing subject reference number.
AlternativeEnergy | Alternative Energy subject reference number.
AlternativeEnergy_EnergyAndResources | Alternative energy subject reference number.
AmericanFootball | American Football subject reference number.
Animals | Animals subject reference number.
AppliedSciences | Applied Sciences subject reference number.
Apprentices | Apprentices subject reference number.
ArableFarming | Arable Farming subject reference number.
Archaeology | Archaeology subject reference number.
Archery | Archery subject reference number.
Architecture | Architecture subject reference number.
ArmedConflict | Armed conflict subject reference number.
ArtsCultureEntertainment | Arts, Culture and Entertainment subject reference number.
AthleticsTrackField | Athletics, Track and field subject reference number.
AutomotiveEquipment | Automotive Equipment subject reference number.
Badminton | Badminton subject reference number.
Banking | Banking subject reference number.
Baseball | Baseball subject reference number.
Basketball | Basketball subject reference number.
Biathlon | Biathlon subject reference number.
BilliardsSnookerPool | Billiards, Snooker and Pool subject reference number.
Biotechnology | Biotechnology subject reference number.
Bobsleigh | Bobsleigh subject reference number.
Books | Books subject reference number.
Bowling | Bowling subject reference number.
BowlsAndPetanque | Bowls and Petanque subject reference number.
Boxing | Boxing subject reference number.
BuildingMaterials | Building materials subject reference number.
Bullfighting | Bullfighting subject reference number.
CanoeingAndKayaking | Canoeing and Kayaking subject reference number.
Carnival | Carnival subject reference number.
CasinosAndGambling | Casinos and Gambling subject reference number.
CentralBanks | Central Banks subject reference number.
Charity | Charity subject reference number.
Chemicals | Chemicals subject reference number.
Cinema | Cinema subject reference number.
Cinema_Media | Cinema subject reference number.
CivilUnrest | Civil unrest subject reference number.
Climbing | Climbing subject reference number.
Clothing | Clothing subject reference number.
Coal | Coal subject reference number.
CollectiveContracts | Collective contracts subject reference number.
ComputingAndInformationTechnology | Computing and Information Technology subject reference number.
Conservation | Conservation subject reference number.
ConstructionAndProperty | Construction and property subject reference number.
ConsultancyServices | Consultancy Services subject reference number.
ConsumerIssues | Consumer Issues subject reference number.
CoupDEtat | Coup d'Etat subject reference number.
Cricket | Cricket subject reference number.
Crime | Crime subject reference number.
CrimeLawJustice | Crime, Law and Justice subject reference number.
CultsAndSects | Cults and sects subject reference number.
Curiosities | Curiosities subject reference number.
Curling | Curling subject reference number.
Cycling | Cycling subject reference number.
Dance | Dance subject reference number.
Dancing | Dancing subject reference number.
DebtMarkets | Debt Markets subject reference number.
Defence | Defence subject reference number.
DefenceEquipment | Defence Equipment subject reference number.
Demographics | Demographics subject reference number.
DepartmentStores | Department stores subject reference number.
Diplomacy | Diplomacy subject reference number.
Disabled | Disabled subject reference number.
DisastersAccidents | Disasters and Accidents subject reference number.
Diseases | Diseases subject reference number.
Diving | Diving subject reference number.
Drought | Drought subject reference number.
Earthquake | Earthquake subject reference number.
EconomicIndicators | Economic Indicators subject reference number.
EconomyBusinessFinance | Economy, Business and Finance subject reference number.
Education | Education subject reference number.
Elections | Elections subject reference number.
ElectricalAppliances | Electrical Appliances subject reference number.
ElectricityProductionAndDistribution | Electricity Production and Distribution subject reference number.
EmergingMarketsDebt | Emerging Markets Debt subject reference number.
Employment | Employment subject reference number.
EmploymentAgencies | Employment Agencies subject reference number.
Energy | Energy subject reference number.
EnergyAndResources | Energy and Resources subject reference number.
EnergySavings | Energy Savings subject reference number.
Engineering | Engineering subject reference number.
EnvironmentalIssues | Environmental Issues subject reference number.
EnvironmentalPolitics | Environmental Politics subject reference number.
EnvironmentalPollution | Environmental pollution subject reference number.
EpidemicAndPlague | Epidemic and Plague subject reference number.
Equestrian | Equestrian subject reference number.
EspionageAndIntelligence | Espionage and Intelligence subject reference number.
Euthanasia | Euthanasia subject reference number.
Faith | Faith subject reference number.
Family | Family subject reference number.
FamilyPlanning | Family planning subject reference number.
Famine | Famine subject reference number.
Fashion | Fashion subject reference number.
Fencing | Fencing subject reference number.
Fertilisers | Fertilisers subject reference number.
FieldHockey | Field Hockey subject reference number.
FigureSkating | Figure Skating subject reference number.
FinancialAndBusinessServices | Financial and Business Services subject reference number.
Fire | Fire subject reference number.
FishingIndustry | Fishing Industry subject reference number.
Flood | Flood subject reference number.
Food | Food subject reference number.
Forecasts | Forecasts subject reference number.
ForeignAid | Foreign Aid subject reference number.
ForeignExchangeMarkets | Foreign Exchange Markets subject reference number.
ForestryAndTimber | Forestry and Timber subject reference number.
FreeMasonry | Free masonry subject reference number.
FreestyleSkiing | Freestyle Skiing subject reference number.
FurnishingsAndFurniture | Furnishings and Furniture subject reference number.
FurtherEducation | Further Education subject reference number.
Games | Games subject reference number.
GamingAndLotteries | Gaming and Lotteries subject reference number.
Gastronomy | Gastronomy subject reference number.
GlobalChange | Global change subject reference number.
GoldAndPreciousMaterials | Gold and Precious Materials subject reference number.
Golf | Golf subject reference number.
GoodsDistribution | Goods Distribution subject reference number.
Government | Government subject reference number.
GovernmentAid | Government Aid subject reference number.
GovernmentDebt | Government Debt subject reference number.
GuerrillaActivities | Guerrilla activities subject reference number.
Gymnastics | Gymnastics subject reference number.
Handball_Team | Handball (Team) subject reference number.
Hardware | Hardware subject reference number.
Health | Health subject reference number.
HealthAndBeautyProducts | Health and Beauty products subject reference number.
HealthcareProviders | Healthcare Providers subject reference number.
HealthInsurance | Health insurance subject reference number.
HealthOrganisations | Health organisations subject reference number.
HealthTreatment | Health treatment subject reference number.
HeavyConstruction | Heavy construction subject reference number.
HeavyEngineering | Heavy engineering subject reference number.
Hobbies | Hobbies subject reference number.
HolidaysAndVacations | Holidays or vacations subject reference number.
Homelessness | Homelessness subject reference number.
HorseRacingAndHarnessRacing | Horse Racing, Harness Racing subject reference number.
HotelsAndAccommodation | Hotels and accommodation subject reference number.
HouseBuilding | House building subject reference number.
HumanInterest | Human Interest subject reference number.
HumanRights | Human Rights subject reference number.
HumanSciences | Human Sciences subject reference number.
IceHockey | Ice Hockey subject reference number.
IndustrialAccident | Industrial accident subject reference number.
IndustrialComponents | Industrial components subject reference number.
InorganicChemicals | Inorganic chemicals subject reference number.
InstrumentEngineering | Instrument engineering subject reference number.
Insurance | Insurance subject reference number.
InterestRates | Interest Rates subject reference number.
InternationalEconomicInstitutions | International Economic Institutions subject reference number.
InternationalTradeIssues | International Trade Issues subject reference number.
IronAndSteel | Iron and Steel subject reference number.
JaiAlai_Pelota | Jai Alai (Pelota) subject reference number.
Judiciary | Judiciary subject reference number.
Judo | Judo subject reference number.
Karate | Karate subject reference number.
Labour | Labour subject reference number.
LabourDispute | Labour dispute subject reference number.
LabourLegislation | Labour legislation subject reference number.
Lacrosse | Lacrosse subject reference number.
Language | Language subject reference number.
LegalServices | Legal services subject reference number.
LibrariesAndMuseums | Libraries and Museums subject reference number.
LifestyleAndLeisure | Lifestyle and Leisure subject reference number.
Literature | Literature subject reference number.
LivestockFarming | Livestock Farming subject reference number.
LoanMarkets | Loan Markets subject reference number.
LocalAuthorities | Local authorities subject reference number.
Luge | Luge subject reference number.
MacroEconomics | Macro Economics subject reference number.
MailOrder | Mail Order subject reference number.
Marathon | Marathon subject reference number.
MarketResearch | Market research subject reference number.
Markets | Markets subject reference number.
Massacre | Massacre subject reference number.
Media | Media subject reference number.
MedicalResearch | Medical research subject reference number.
MedicalStaff | Medical staff subject reference number.
Medicines | Medicines subject reference number.
MetalGoodsAndEngineering | Metal Goods and Engineering subject reference number.
Metals | Metals subject reference number.
MetalsAndMinerals | Metals and Minerals subject reference number.
MeteorologicalDisaster | Meteorological disaster subject reference number.
MinorityGroups | Minority groups subject reference number.
ModernPentathlon | Modern Pentathlon subject reference number.
Motorcycling | Motorcycling subject reference number.
MotorRacing | Motor Racing subject reference number.
MotorRallying | Motor Rallying subject reference number.
Music | Music subject reference number.
NaturalResources | Natural resources subject reference number.
NaturalSciences | Natural Sciences subject reference number.
Nature | Nature subject reference number.
Netball | Netball subject reference number.
Networking | Networking subject reference number.
NewsAgencies | News Agencies subject reference number.
NewspaperAndMagazines | Newspaper and Magazines subject reference number.
NonFerrousMetals | Non ferrous metals subject reference number.
NordicSkiing | Nordic Skiing subject reference number.
NuclearAccident | Nuclear accident subject reference number.
NuclearPower | Nuclear power subject reference number.
OilGasDownstreamActivities | Oil and Gas - Downstream activities subject reference number.
OilGasUpstreamActivities | Oil and Gas - Upstream activities subject reference number.
Online | Online subject reference number.
OrganicChemicals | Organic chemicals subject reference number.
Orienteering | Orienteering subject reference number.
Painting | Painting subject reference number.
PaperAndPackagingProducts | Paper and packaging products subject reference number.
ParentOrganisations | Parent Organisations subject reference number.
Parliament | Parliament subject reference number.
Parties | Parties subject reference number.
People | People subject reference number.
Pharmaceuticals | Pharmaceuticals subject reference number.
PhilosophicalSciences | Philosophical Sciences subject reference number.
Photography | Photography subject reference number.
Police | Police subject reference number.
Politics | Politics subject reference number.
Pollution | Pollution subject reference number.
Polo | Polo subject reference number.
Population | Population subject reference number.
Pornography | Pornography subject reference number.
Poverty | Poverty subject reference number.
PowerBoating | Power Boating subject reference number.
Preschooling | Preschooling subject reference number.
PreventativeMedicine | Preventative medicine subject reference number.
Prison | Prison subject reference number.
ProcessIndustries | Process Industries subject reference number.
Prostitution | Prostitution subject reference number.
PublicRelations | Public Relations subject reference number.
Punishment | Punishment subject reference number.
Racism | Racism subject reference number.
Radio | Radio subject reference number.
Radio_Media | Radio subject reference number.
Railway | Railway subject reference number.
RealEstate | Real Estate subject reference number.
RecreationalAndSportsGoods | Recreational and Sports goods subject reference number.
Refugees | Refugees subject reference number.
RegionalAuthorities | Regional authorities subject reference number.
ReligionAndBelief | Religion and Belief subject reference number.
ReligiousInstitutions | Religious institutions subject reference number.
Reports | Reports subject reference number.
Research | Research subject reference number.
RestaurantsAndCatering | Restaurants and catering subject reference number.
Retail | Retail subject reference number.
Retirement | Retirement subject reference number.
Retraining | Retraining subject reference number.
Riots | Riots subject reference number.
RoadTransport | Road Transport subject reference number.
Rowing | Rowing subject reference number.
RubberProducts | Rubber products subject reference number.
RugbyLeague | Rugby League subject reference number.
RugbyUnion | Rugby Union subject reference number.
Sailing | Sailing subject reference number.
SatelliteAndCableServices | Satellite and Cable Services subject reference number.
SatelliteTechnology | Satellite technology subject reference number.
Schools | Schools subject reference number.
ScienceAndTechnology | Science and Technology subject reference number.
ScientificExploration | Scientific exploration subject reference number.
Sculpture | Sculpture subject reference number.
Securities | Securities subject reference number.
SemiconductorsAndActiveComponents | Semiconductors and active components subject reference number.
Shipbuilding | Shipbuilding subject reference number.
Shooting | Shooting subject reference number.
SkiJumping | Ski Jumping subject reference number.
SnowBoarding | Snow Boarding subject reference number.
Soccer | Soccer subject reference number.
SocialIssues | Social Issues subject reference number.
Softball | Softball subject reference number.
SoftCommodities | Soft Commodities subject reference number.
SoftDrinks | Soft Drinks subject reference number.
Software | Software subject reference number.
SpaceProgrammes | Space programs subject reference number.
SpecialityStores | Speciality stores subject reference number.
SpeedSkating | Speed Skating subject reference number.
Speedway | Speedway subject reference number.
Sport | Sport subject reference number.
SportsOrganisations | Sports Organisations subject reference number.
Squash | Squash subject reference number.
StateBudget | State Budget subject reference number.
Statistics | Statistics subject reference number.
StockBroking | Stock broking subject reference number.
Strike | Strike subject reference number.
SumoWrestling | Sumo Wrestling subject reference number.
Surfing | Surfing subject reference number.
Swimming | Swimming subject reference number.
SyntheticsAndPlastics | Synthetics and Plastics subject reference number.
TableTennis | Table Tennis subject reference number.
TaekwonDo | Taekwon-Do subject reference number.
TeachersUnions | Teachers Unions subject reference number.
TelecommunicationsEquipment | Telecommunications Equipment subject reference number.
TelecommunicationsServices | Telecommunications Services subject reference number.
Television | Television subject reference number.
Television_Media | Television subject reference number.
Tennis | Tennis subject reference number.
TextilesAndClothing | Textiles and Clothing subject reference number.
Theatre | Theatre subject reference number.
Tobacco | Tobacco subject reference number.
Tourism | Tourism subject reference number.
TourismAndLeisure | Tourism and Leisure subject reference number.
TourOperators | Tour operators subject reference number.
Transport | Transport subject reference number.
TransportAccident | Transport accident subject reference number.
TreatiesAndOrganisations | Treaties and Organisations subject reference number.
Triathlon | Triathlon subject reference number.
Unemployment | Unemployment subject reference number.
Unions | Unions subject reference number.
University | University subject reference number.
UnrestConflictsWar | Unrest, Conflicts and War subject reference number.
ViolentDemonstrations | Violent demonstrations subject reference number.
VolcanicEruption | Volcanic eruption subject reference number.
Volleyball | Volleyball subject reference number.
WagesAndPensions | Wages and Pensions subject reference number.
War | War subject reference number.
Warnings | Warnings subject reference number.
Waste | Waste subject reference number.
WasteManagementAndPollutionControl | Waste Management and Pollution Control subject reference number.
WaterPolo | Water Polo subject reference number.
WaterSkiing | Water Skiing subject reference number.
WaterSupplies | Water Supplies subject reference number.
WaterSupply | Water Supply subject reference number.
WaterwayAndMaritimeTransport | Waterway and Maritime Transport subject reference number.
Weather | Weather subject reference number.
Weightlifting | Weightlifting subject reference number.
Welfare | Welfare subject reference number.
Wholesale | Wholesale subject reference number.
Windsurfing | Windsurfing subject reference number.
WorkRelations | Work Relations subject reference number.
Wrestling | Wrestling subject reference number.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCSubjectReferenceNumber

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%PageItemTitle%%

ImGearIPTCSupplementType Enumeration
com.accusoft.imagegear.formats.iptc Package : ImGearIPTCSupplementType Enumeration

Glossary Item Box

Represents IPTC Supplement Types.

Members

Member | Description
Logo | Logo type.
NotSupplement | Not a supplement.
RasterizedCaption | Rasterized caption.
ReducedResolutionImage | Reduced resolution image.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.iptc.ImGearIPTCSupplementType

See Also

Reference

com.accusoft.imagegear.formats.iptc Package


%%ItemTitle%%

com.accusoft.imagegear.formats.jpg Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides enumerations values for JPEG format filter control parameters.

Enumerations

Enumeration Description
ImGearDecimationTypes This enumeration lists all possible JPEG decimation values.

The format of these ImageGear decimation constants is: Decim_(H1)x(V1)_(H2)x(V2)_(H3)x(V3),

where Hi, Vi = horizontal and vertical decimation values for the i-channel.

The following is a simple example of decimation. For a more detailed definition, please see the JPEG Specification.

A decimation setting of Decim_4x2_1x1_1x1 would yield the following results:

As shown, 8 Y components in the source image have yielded one Cb and one Cr component. In general, this setting will reduce the quality of the compression, unless the image has many continuous tone areas.

Maximum quality can be reached using a value of Decim_1x1_1x1_1x1.

Maximum compression ratio can be reached with a value of Decim_4x4_2x2_2x2.

The ImageGear default decimation value is: Decim_2x2_1x1_1x1.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.jpg Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearDecimationTypes Enumeration
com.accusoft.imagegear.formats.jpg Package : ImGearDecimationTypes Enumeration

Glossary Item Box

This enumeration lists all possible JPEG decimation values.

The format of these ImageGear decimation constants is: Decim_(H1)x(V1)_(H2)x(V2)_(H3)x(V3),

where Hi, Vi = horizontal and vertical decimation values for the i-channel.

The following is a simple example of decimation. For a more detailed definition, please see the JPEG Specification.

A decimation setting of Decim_4x2_1x1_1x1 would yield the following results:

As shown, 8 Y components in the source image have yielded one Cb and one Cr component. In general, this setting will reduce the quality of the compression, unless the image has many continuous tone areas.

Maximum quality can be reached using a value of Decim_1x1_1x1_1x1.

Maximum compression ratio can be reached with a value of Decim_4x4_2x2_2x2.

The ImageGear default decimation value is: Decim_2x2_1x1_1x1.

Members

Member | Description
Decim_1x1_1x1_1x1 | For each Y sample, one Cb sample and one Cr sample are stored.
Decim_1x2_1x1_1x1 | For each vertical pair of Y samples, one Cb sample and one Cr sample are stored.
Decim_1x4_1x1_1x1 | For each four vertical Y samples, one Cb sample and one Cr sample are stored.
Decim_1x4_1x2_1x2 | For each four vertical Y samples, two vertical Cb samples and two vertical Cr samples are stored.
Decim_2x1_1x1_1x1 | For each horizontal pair of Y samples, one Cb sample and one Cr sample are stored.
Decim_2x2_1x1_1x1 | For each four (two horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_2x2_2x1_2x1 | For each four (two horizontal by two vertical) Y samples, two horizontal Cb samples and two horizontal Cr samples are stored.
Decim_2x4_1x1_1x1 | For each eight (two horizontal by four vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_4x1_1x1_1x1 | For each four horizontal Y samples, one Cb sample and one Cr sample are stored.
Decim_4x1_2x1_2x1 | For each four horizontal Y samples, two horizontal Cb samples and two horizontal Cr samples are stored.
Decim_4x2_1x1_1x1 | For each eight (four horizontal by two vertical) Y samples, one Cb sample and one Cr sample are stored.
Decim_4x4_2x2_2x2 | For each 16 (four horizontal by four vertical) Y samples, four (two horizontal by two vertical) Cb samples and four (two horizontal by two vertical) Cr samples are stored.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.jpg.ImGearDecimationTypes

See Also

Reference

com.accusoft.imagegear.formats.jpg Package


%%ItemTitle%%

com.accusoft.imagegear.formats.tif Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides public API for TIFF format metadata operating and for TIFF filter control parameters.

Classes

Class Description
ImGearTIFFMetadata Provides simplified access to TIFF metadata.

This class provides simplified read/write access to TIFF metadata of an ImGearPage. Properties of this class represent specific TIFF tags.

The following file formats may contain TIFF metadata:

- TIFF

- JPEG with EXIF metadata (EXIF specification uses TIFF structure and a subset of TIFF tags).

ImGearTIFFMetadata class provides access to data stored in the general metadata tree. It does not store its own copy of the data.

Types of properties of the class represent TIFF tag types, e.g., string, byte[ ], etc. Instead of value types, ImageGear uses corresponding Nullable types.

If a specific tag is not present in the metadata, corresponding method returns null. Similarly, to remove a specific tag from metadata, set the corresponding value to null.

Enumerations

Enumeration | Description
ImGearPhotoInterpretations | This enumeration specifies all the supported types of TIFF photometric interpretations.
ImGearStripModes | This enumeration specifies all the supported strip and tile modes for TIFF image writing.
ImGearTIFFBitonalPaletteMode | Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.
ImGearTIFFCompression | Represents TIFF compressions.
ImGearTIFFFillOrder | Represents TIFF fill orders.
ImGearTIFFNewSubFileTypeMasks | Represents TIFF New Subfile Type masks.
ImGearTIFFOrientation | Represents TIFF orientations.
ImGearTIFFPhotoInterpretation | Represents TIFF photometric interpretations.
ImGearTIFFPlanarConfig | Represents TIFF planar configurations.
ImGearTIFFPredictorType | Represents TIFF predictor types.
ImGearTIFFResolutionUnit | Represents TIFF resolution units.
ImGearTIFFSubFileType | Represents TIFF subfile types.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.tif Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearTIFFMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.tif Package : ImGearTIFFMetadata Class

Glossary Item Box

Provides simplified access to TIFF metadata.

This class provides simplified read/write access to TIFF metadata of an ImGearPage. Properties of this class represent specific TIFF tags.

The following file formats may contain TIFF metadata:

- TIFF

- JPEG with EXIF metadata (EXIF specification uses TIFF structure and a subset of TIFF tags).

ImGearTIFFMetadata class provides access to data stored in the general metadata tree. It does not store its own copy of the data.

Types of properties of the class represent TIFF tag types, e.g., string, byte[ ], etc. Instead of value types, ImageGear uses corresponding Nullable types.

If a specific tag is not present in the metadata, corresponding method returns null. Similarly, to remove a specific tag from metadata, set the corresponding value to null.

Object Model

ImGearTIFFMetadata ClassImGearTIFFCompression EnumerationImGearTIFFFillOrder EnumerationImGearTIFFNewSubFileTypeMasks EnumerationImGearTIFFOrientation EnumerationImGearTIFFPhotoInterpretation EnumerationImGearTIFFPlanarConfig EnumerationImGearTIFFPredictorType EnumerationImGearRationalUInt ClassImGearTIFFResolutionUnit EnumerationImGearTIFFSubFileType EnumerationImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt ClassImGearRationalUInt Class

Syntax

public class ImGearTIFFMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.tif.ImGearTIFFMetadata

See Also

Reference

ImGearTIFFMetadata Members
com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearTIFFMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.tif Package : ImGearTIFFMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearTIFFMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearTIFFMetadata Constructor | Initializes a new instance of the ImGearTIFFMetadata class.
Top

Public Methods

Name Description
public Method getArtist Returns Artist tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

public Method getBitsPerSample Gets BitsPerSample tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getCellLength Returns CellLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method getCellWidth Returns CellWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method getColorMap Returns ColorMap tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

public Method getCompression Returns Compression tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

public Method getCopyright Returns Copyright tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

public Method getDateTime Returns Date tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

public Method getDocumentName Returns DocumentName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

public Method getDotRange Returns DotRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

public Method getExtraSamples Returns ExtraSamples tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

public Method getFillOrder Returns FillOrder tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

public Method getFreeByteCounts Returns FreeByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

public Method getFreeOffsets Returns FreeOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

public Method getGrayResponseCurve Returns GrayResponseCurve tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

public Method getGrayResponseUnit Returns GrayResponseUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

public Method getHalftoneHints Returns HalftoneHints tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

public Method getHostComputer Returns HostComputer tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

public Method getImageDescription Returns ImageDescription tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

public Method getImageLength Returns ImageLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

public Method getImageWidth Returns ImageWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

public Method getInkNames Returns InkNames tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

public Method getInkSet Returns InkSet tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

public Method getInterColorProfile Returns InterColorProfile tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

public Method getJPEGACTables Returns JPEGACTables tag.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

public Method getJPEGDCTables Returns JPEGDCTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

public Method getJPEGInterchangeFormat Returns JPEGInterchangeFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

public Method getJPEGInterchangeFormatLength Returns JPEGInterchangeFormatLngth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

public Method getJPEGLosslessPredictors Returns JPEGLosslessPredictors tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

public Method getJPEGPointTransforms Returns JPEGPointTransforms tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

public Method getJPEGProc Gets JPEGProc tag value.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getJPEGQTables Returns JPEGQTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

public Method getJPEGRestartInterval Returns JPEGRestartInterval tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

public Method getMake Returns Make tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

public Method getMaxSampleValue Returns MaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

public Method getMinSampleValue Returns MinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

public Method getModel Returns Model tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

public Method getNewSubfileType Returns NewSubfileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

public Method getNumberOfInks Returns NumberOfInks tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

public Method getOrientation Returns Orientation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

public Method getPageName Returns PageName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

public Method getPageNumber Returns PageNumber tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

public Method getPhotometricInterpretation Returns PhotometricInterpretation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

public Method getPlanarConfig Returns PlanarConfig tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

public Method getPredictorType Returns PredictorType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

public Method getPrimaryChromaticities Returns PrimaryChromaticities tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

public Method getReferenceBlackWhite Returns ReferenceBlackWhite tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

public Method getResolutionUnit Returns ResolutionUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

public Method getRowsPerStrip Returns RowsPerStrip tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

public Method getSampleFormat Returns SampleFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

public Method getSamplesPerPixel Returns SamplesPerPixel tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

public Method getSMaxSampleValue Returns SMaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

public Method getSMinSampleValue Returns SMinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

public Method getSoftware Returns Software tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

public Method getStripByteCounts Gets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getStripOffsets Returns StripOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

public Method getSubFileType Returns SubFileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The getNewSubfileType method should be used instead.

public Method getT4Options Returns T4Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

public Method getT6Options Returns T6Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

public Method getTargetPrinter Returns TargetPrinter tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

public Method getThreshholding Returns Threshholding tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

public Method getTileByteCounts Returns TileByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

public Method getTileLength Returns TileLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

public Method getTileOffsets Returns TileOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

public Method getTileWidth Returns TileWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

public Method getTransferFunction Gets TransferFunction tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

public Method getTransferRange Returns TransferRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

public Method getWhitePoint Returns WhitePoint tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

public Method getXPosition Returns XPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

public Method getXResolution Returns XResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

public Method getYCbCrCoefficients Gets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method getYCbCrPositioning Returns YCbCrPositioning tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

public Method getYCbCrSubSampling Gets YCbCrSubSampling tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise. if it was not present, or deletes the tag if a null value is passed.

This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method getYPosition Returns YPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

public Method getYResolution Returns YResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

public Method setArtist Sets Artist tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

public Method setBitsPerSample Sets BitsPerSample tag value. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setCellLength Sets CellLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method setCellWidth Sets CellWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method setColorMap Sets ColorMap tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

public Method setCompression Sets Compression tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

public Method setCopyright Sets Copyright tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

public Method setDateTime Sets Date tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

public Method setDocumentName Sets DocumentName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

public Method setDotRange Sets DotRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

public Method setExtraSamples Sets ExtraSamples tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

public Method setFillOrder Sets FillOrder tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

public Method setFreeByteCounts Sets FreeByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

public Method setFreeOffsets Sets FreeOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

public Method setGrayResponseCurve Sets GrayResponseCurve tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

public Method setGrayResponseUnit Sets GrayResponseUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

public Method setHalftoneHints Sets HalftoneHints tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

public Method setHostComputer Sets HostComputer tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

public Method setImageDescription Sets ImageDescription tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

public Method setImageLength Sets ImageLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

public Method setImageWidth Sets ImageWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

public Method setInkNames Sets InkNames tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

public Method setInkSet Sets InkSet tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

public Method setInterColorProfile Sets InterColorProfile tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

public Method setJPEGACTables Sets JPEGACTables tag.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

public Method setJPEGDCTables Sets JPEGDCTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

public Method setJPEGInterchangeFormat Sets JPEGInterchangeFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

public Method setJPEGInterchangeFormatLength Sets JPEGInterchangeFormatLngth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

public Method setJPEGLosslessPredictors Sets JPEGLosslessPredictors tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

public Method setJPEGPointTransforms Sets JPEGPointTransforms tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

public Method setJPEGProc Sets JPEGProc tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setJPEGQTables Sets JPEGQTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

public Method setJPEGRestartInterval Sets JPEGRestartInterval tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

public Method setMake Sets Make tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

public Method setMaxSampleValue Sets MaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

public Method setMinSampleValue Sets MinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

public Method setModel Sets Model tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

public Method setNewSubfileType Sets NewSubfileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

public Method setNumberOfInks Sets NumberOfInks tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

public Method setOrientation Sets Orientation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

public Method setPageName Sets PageName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

public Method setPageNumber Sets PageNumber tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

public Method setPhotometricInterpretation Sets PhotometricInterpretation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

public Method setPlanarConfig Sets PlanarConfig tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

public Method setPredictorType Sets PredictorType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

public Method setPrimaryChromaticities Sets PrimaryChromaticities tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

public Method setReferenceBlackWhite Sets ReferenceBlackWhite tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

public Method setResolutionUnit Sets ResolutionUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

public Method setRowsPerStrip Sets RowsPerStrip tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

public Method setSampleFormat Sets SampleFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

public Method setSamplesPerPixel Sets SamplesPerPixel tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

public Method setSMaxSampleValue Sets SMaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

public Method setSMinSampleValue Sets SMinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

public Method setSoftware Sets Software tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

public Method setStripByteCounts Sets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setStripOffsets Sets StripOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

public Method setSubFileType Sets SubFileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The setNewSubfileType method should be used instead.

public Method setT4Options Sets T4Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

public Method setT6Options Sets T6Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

public Method setTargetPrinter Sets TargetPrinter tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

public Method setThreshholding Sets Threshholding tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

public Method setTileByteCounts Sets TileByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

public Method setTileLength Sets TileLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

public Method setTileOffsets Sets TileOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

public Method setTileWidth Sets TileWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

public Method setTransferFunction Sets TransferFunction tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

public Method setTransferRange Sets TransferRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

public Method setWhitePoint Sets WhitePoint tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

public Method setXPosition Sets XPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

public Method setXResolution Sets XResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

public Method setYCbCrCoefficients Sets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method setYCbCrPositioning Sets YCbCrPositioning tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

public Method setYCbCrSubSampling Sets YCbCrSubSampling tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

\This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method setYPosition Sets YPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

public Method setYResolution Sets YResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Top

See Also

Reference

ImGearTIFFMetadata Class
com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFMetadata Constructor
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : ImGearTIFFMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearTIFFMetadata class.

Syntax

public ImGearTIFFMetadata()

Return Value

The new instance of ImGearTIFFMetadata class.

This constructor creates and initializes an instance of ImGearTIFFMetadata class.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearTIFFMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.tif Package : ImGearTIFFMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearTIFFMetadata members.

Public Methods

Name Description
public Method getArtist Returns Artist tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

public Method getBitsPerSample Gets BitsPerSample tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getCellLength Returns CellLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method getCellWidth Returns CellWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method getColorMap Returns ColorMap tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

public Method getCompression Returns Compression tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

public Method getCopyright Returns Copyright tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

public Method getDateTime Returns Date tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

public Method getDocumentName Returns DocumentName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

public Method getDotRange Returns DotRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

public Method getExtraSamples Returns ExtraSamples tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

public Method getFillOrder Returns FillOrder tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

public Method getFreeByteCounts Returns FreeByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

public Method getFreeOffsets Returns FreeOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

public Method getGrayResponseCurve Returns GrayResponseCurve tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

public Method getGrayResponseUnit Returns GrayResponseUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

public Method getHalftoneHints Returns HalftoneHints tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

public Method getHostComputer Returns HostComputer tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

public Method getImageDescription Returns ImageDescription tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

public Method getImageLength Returns ImageLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

public Method getImageWidth Returns ImageWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

public Method getInkNames Returns InkNames tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

public Method getInkSet Returns InkSet tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

public Method getInterColorProfile Returns InterColorProfile tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

public Method getJPEGACTables Returns JPEGACTables tag.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

public Method getJPEGDCTables Returns JPEGDCTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

public Method getJPEGInterchangeFormat Returns JPEGInterchangeFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

public Method getJPEGInterchangeFormatLength Returns JPEGInterchangeFormatLngth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

public Method getJPEGLosslessPredictors Returns JPEGLosslessPredictors tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

public Method getJPEGPointTransforms Returns JPEGPointTransforms tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

public Method getJPEGProc Gets JPEGProc tag value.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getJPEGQTables Returns JPEGQTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

public Method getJPEGRestartInterval Returns JPEGRestartInterval tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

public Method getMake Returns Make tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

public Method getMaxSampleValue Returns MaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

public Method getMinSampleValue Returns MinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

public Method getModel Returns Model tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

public Method getNewSubfileType Returns NewSubfileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

public Method getNumberOfInks Returns NumberOfInks tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

public Method getOrientation Returns Orientation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

public Method getPageName Returns PageName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

public Method getPageNumber Returns PageNumber tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

public Method getPhotometricInterpretation Returns PhotometricInterpretation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

public Method getPlanarConfig Returns PlanarConfig tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

public Method getPredictorType Returns PredictorType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

public Method getPrimaryChromaticities Returns PrimaryChromaticities tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

public Method getReferenceBlackWhite Returns ReferenceBlackWhite tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

public Method getResolutionUnit Returns ResolutionUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

public Method getRowsPerStrip Returns RowsPerStrip tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

public Method getSampleFormat Returns SampleFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

public Method getSamplesPerPixel Returns SamplesPerPixel tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

public Method getSMaxSampleValue Returns SMaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

public Method getSMinSampleValue Returns SMinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

public Method getSoftware Returns Software tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

public Method getStripByteCounts Gets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method getStripOffsets Returns StripOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

public Method getSubFileType Returns SubFileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The getNewSubfileType method should be used instead.

public Method getT4Options Returns T4Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

public Method getT6Options Returns T6Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

public Method getTargetPrinter Returns TargetPrinter tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

public Method getThreshholding Returns Threshholding tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

public Method getTileByteCounts Returns TileByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

public Method getTileLength Returns TileLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

public Method getTileOffsets Returns TileOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

public Method getTileWidth Returns TileWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

public Method getTransferFunction Gets TransferFunction tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

public Method getTransferRange Returns TransferRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

public Method getWhitePoint Returns WhitePoint tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

public Method getXPosition Returns XPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

public Method getXResolution Returns XResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

public Method getYCbCrCoefficients Gets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method getYCbCrPositioning Returns YCbCrPositioning tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

public Method getYCbCrSubSampling Gets YCbCrSubSampling tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise. if it was not present, or deletes the tag if a null value is passed.

This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method getYPosition Returns YPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

public Method getYResolution Returns YResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

public Method setArtist Sets Artist tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

public Method setBitsPerSample Sets BitsPerSample tag value. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setCellLength Sets CellLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method setCellWidth Sets CellWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

public Method setColorMap Sets ColorMap tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

public Method setCompression Sets Compression tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

public Method setCopyright Sets Copyright tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

public Method setDateTime Sets Date tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

public Method setDocumentName Sets DocumentName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

public Method setDotRange Sets DotRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

public Method setExtraSamples Sets ExtraSamples tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

public Method setFillOrder Sets FillOrder tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

public Method setFreeByteCounts Sets FreeByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

public Method setFreeOffsets Sets FreeOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

public Method setGrayResponseCurve Sets GrayResponseCurve tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

public Method setGrayResponseUnit Sets GrayResponseUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

public Method setHalftoneHints Sets HalftoneHints tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

public Method setHostComputer Sets HostComputer tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

public Method setImageDescription Sets ImageDescription tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

public Method setImageLength Sets ImageLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

public Method setImageWidth Sets ImageWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

public Method setInkNames Sets InkNames tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

public Method setInkSet Sets InkSet tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

public Method setInterColorProfile Sets InterColorProfile tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

public Method setJPEGACTables Sets JPEGACTables tag.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

public Method setJPEGDCTables Sets JPEGDCTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

public Method setJPEGInterchangeFormat Sets JPEGInterchangeFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

public Method setJPEGInterchangeFormatLength Sets JPEGInterchangeFormatLngth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

public Method setJPEGLosslessPredictors Sets JPEGLosslessPredictors tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

public Method setJPEGPointTransforms Sets JPEGPointTransforms tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

public Method setJPEGProc Sets JPEGProc tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setJPEGQTables Sets JPEGQTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

public Method setJPEGRestartInterval Sets JPEGRestartInterval tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

public Method setMake Sets Make tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

public Method setMaxSampleValue Sets MaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

public Method setMinSampleValue Sets MinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

public Method setModel Sets Model tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

public Method setNewSubfileType Sets NewSubfileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

public Method setNumberOfInks Sets NumberOfInks tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

public Method setOrientation Sets Orientation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

public Method setPageName Sets PageName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

public Method setPageNumber Sets PageNumber tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

public Method setPhotometricInterpretation Sets PhotometricInterpretation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

public Method setPlanarConfig Sets PlanarConfig tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

public Method setPredictorType Sets PredictorType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

public Method setPrimaryChromaticities Sets PrimaryChromaticities tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

public Method setReferenceBlackWhite Sets ReferenceBlackWhite tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

public Method setResolutionUnit Sets ResolutionUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

public Method setRowsPerStrip Sets RowsPerStrip tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

public Method setSampleFormat Sets SampleFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

public Method setSamplesPerPixel Sets SamplesPerPixel tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

public Method setSMaxSampleValue Sets SMaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

public Method setSMinSampleValue Sets SMinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

public Method setSoftware Sets Software tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

public Method setStripByteCounts Sets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

public Method setStripOffsets Sets StripOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

public Method setSubFileType Sets SubFileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The setNewSubfileType method should be used instead.

public Method setT4Options Sets T4Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

public Method setT6Options Sets T6Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

public Method setTargetPrinter Sets TargetPrinter tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

public Method setThreshholding Sets Threshholding tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

public Method setTileByteCounts Sets TileByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

public Method setTileLength Sets TileLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

public Method setTileOffsets Sets TileOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

public Method setTileWidth Sets TileWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

public Method setTransferFunction Sets TransferFunction tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

public Method setTransferRange Sets TransferRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

public Method setWhitePoint Sets WhitePoint tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

public Method setXPosition Sets XPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

public Method setXResolution Sets XResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

public Method setYCbCrCoefficients Sets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method setYCbCrPositioning Sets YCbCrPositioning tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

public Method setYCbCrSubSampling Sets YCbCrSubSampling tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

\This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

public Method setYPosition Sets YPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

public Method setYResolution Sets YResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Top

See Also

Reference

ImGearTIFFMetadata Class
com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

getArtist Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getArtist Method

Glossary Item Box

Returns Artist tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

Syntax

public java.lang.String getArtist()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getBitsPerSample Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getBitsPerSample Method

Glossary Item Box

Gets BitsPerSample tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public int[] getBitsPerSample()

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getCellLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getCellLength Method

Glossary Item Box

Returns CellLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Syntax

public java.lang.int getCellLength()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getCellWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getCellWidth Method

Glossary Item Box

Returns CellWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Syntax

public java.lang.int getCellWidth()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getColorMap Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getColorMap Method

Glossary Item Box

Returns ColorMap tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

Syntax

public int[] getColorMap()

Return Value

Ushort array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getCompression Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getCompression Method

Glossary Item Box

Returns Compression tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Syntax

public ImGearTIFFCompression getCompression()

Return Value

Nullable (boxed) ImGearTIFFCompression enumeration value. *

ImGearTIFFCompression

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getCopyright Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getCopyright Method

Glossary Item Box

Returns Copyright tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

Syntax

public java.lang.String getCopyright()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getDateTime Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getDateTime Method

Glossary Item Box

Returns Date tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

Syntax

public java.lang.String getDateTime()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getDocumentName Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getDocumentName Method

Glossary Item Box

Returns DocumentName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

Syntax

public java.lang.String getDocumentName()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getDotRange Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getDotRange Method

Glossary Item Box

Returns DotRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

Syntax

public int[] getDotRange()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getExtraSamples Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getExtraSamples Method

Glossary Item Box

Returns ExtraSamples tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

Syntax

public byte[] getExtraSamples()

Return Value

Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getFillOrder Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getFillOrder Method

Glossary Item Box

Returns FillOrder tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

Syntax

public ImGearTIFFFillOrder getFillOrder()

Return Value

Nullable (boxed) ImGearTIFFFillOrder enumeration value. *

ImGearTIFFFillOrder

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getFreeByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getFreeByteCounts Method

Glossary Item Box

Returns FreeByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

Syntax

public long[] getFreeByteCounts()

Return Value

Array of uint. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getFreeOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getFreeOffsets Method

Glossary Item Box

Returns FreeOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

Syntax

public long[] getFreeOffsets()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getGrayResponseCurve Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getGrayResponseCurve Method

Glossary Item Box

Returns GrayResponseCurve tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

Syntax

public int[] getGrayResponseCurve()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getGrayResponseUnit Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getGrayResponseUnit Method

Glossary Item Box

Returns GrayResponseUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

Syntax

public java.lang.int getGrayResponseUnit()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getHalftoneHints Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getHalftoneHints Method

Glossary Item Box

Returns HalftoneHints tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

Syntax

public int[] getHalftoneHints()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getHostComputer Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getHostComputer Method

Glossary Item Box

Returns HostComputer tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

Syntax

public java.lang.String getHostComputer()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getImageDescription Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getImageDescription Method

Glossary Item Box

Returns ImageDescription tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

Syntax

public java.lang.String getImageDescription()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getImageLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getImageLength Method

Glossary Item Box

Returns ImageLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Syntax

public java.lang.long getImageLength()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getImageWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getImageWidth Method

Glossary Item Box

Returns ImageWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

Syntax

public java.lang.long getImageWidth()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getInkNames Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getInkNames Method

Glossary Item Box

Returns InkNames tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

Syntax

public java.lang.String[] getInkNames()

Return Value

Array of strings. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getInkSet Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getInkSet Method

Glossary Item Box

Returns InkSet tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

Syntax

public java.lang.int getInkSet()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getInterColorProfile Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getInterColorProfile Method

Glossary Item Box

Returns InterColorProfile tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Syntax

public byte[] getInterColorProfile()

Return Value

Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGACTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGACTables Method

Glossary Item Box

Returns JPEGACTables tag.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

Syntax

public long[] getJPEGACTables()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGDCTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGDCTables Method

Glossary Item Box

Returns JPEGDCTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

Syntax

public long[] getJPEGDCTables()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGInterchangeFormat Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGInterchangeFormat Method

Glossary Item Box

Returns JPEGInterchangeFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Syntax

public java.lang.long getJPEGInterchangeFormat()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGInterchangeFormatLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGInterchangeFormatLength Method

Glossary Item Box

Returns JPEGInterchangeFormatLngth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Syntax

public java.lang.long getJPEGInterchangeFormatLength()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGLosslessPredictors Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGLosslessPredictors Method

Glossary Item Box

Returns JPEGLosslessPredictors tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

Syntax

public java.lang.int getJPEGLosslessPredictors()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGPointTransforms Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGPointTransforms Method

Glossary Item Box

Returns JPEGPointTransforms tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

Syntax

public java.lang.int getJPEGPointTransforms()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGProc Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGProc Method

Glossary Item Box

Gets JPEGProc tag value.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public java.lang.int getJPEGProc()

Return Value

Nullable (boxed) ushort value.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGQTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGQTables Method

Glossary Item Box

Returns JPEGQTables tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

Syntax

public long[] getJPEGQTables()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getJPEGRestartInterval Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getJPEGRestartInterval Method

Glossary Item Box

Returns JPEGRestartInterval tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

Syntax

public java.lang.int getJPEGRestartInterval()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getMake Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getMake Method

Glossary Item Box

Returns Make tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Syntax

public java.lang.String getMake()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getMaxSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getMaxSampleValue Method

Glossary Item Box

Returns MaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

Syntax

public int[] getMaxSampleValue()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getMinSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getMinSampleValue Method

Glossary Item Box

Returns MinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

Syntax

public int[] getMinSampleValue()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getModel Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getModel Method

Glossary Item Box

Returns Model tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Syntax

public java.lang.String getModel()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getNewSubfileType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getNewSubfileType Method

Glossary Item Box

Returns NewSubfileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

Syntax

public ImGearTIFFNewSubFileTypeMasks getNewSubfileType()

Return Value

Nullable (boxed) ImGearTIFFNewSubFileTypeMasks enumeration value. *

ImGearTIFFNewSubFileTypeMasks

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getNumberOfInks Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getNumberOfInks Method

Glossary Item Box

Returns NumberOfInks tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

Syntax

public java.lang.int getNumberOfInks()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getOrientation Method

Glossary Item Box

Returns Orientation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Syntax

public ImGearTIFFOrientation getOrientation()

Return Value

Nullable (boxed) ImGearTIFFOrientation enumeration value. *

ImGearTIFFOrientation

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPageName Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPageName Method

Glossary Item Box

Returns PageName tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

Syntax

public java.lang.String getPageName()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPageNumber Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPageNumber Method

Glossary Item Box

Returns PageNumber tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

Syntax

public int[] getPageNumber()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPhotometricInterpretation Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPhotometricInterpretation Method

Glossary Item Box

Returns PhotometricInterpretation tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Syntax

public ImGearTIFFPhotoInterpretation getPhotometricInterpretation()

Return Value

Nullable (boxed) ImGearTIFFPhotoInterpretation enumeration value. *

ImGearTIFFPhotoInterpretation

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPlanarConfig Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPlanarConfig Method

Glossary Item Box

Returns PlanarConfig tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Syntax

public ImGearTIFFPlanarConfig getPlanarConfig()

Return Value

Nullable (boxed) ImGearTIFFPlanarConfig enumeration value. *

ImGearTIFFPlanarConfig

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPredictorType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPredictorType Method

Glossary Item Box

Returns PredictorType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

Syntax

public ImGearTIFFPredictorType getPredictorType()

Return Value

Nullable (boxed) ImGearTIFFPredictorType enumeration value. *

ImGearTIFFPredictorType

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getPrimaryChromaticities Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getPrimaryChromaticities Method

Glossary Item Box

Returns PrimaryChromaticities tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

Syntax

public ImGearRationalUInt[] getPrimaryChromaticities()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getReferenceBlackWhite Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getReferenceBlackWhite Method

Glossary Item Box

Returns ReferenceBlackWhite tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Syntax

public long[] getReferenceBlackWhite()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getResolutionUnit Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getResolutionUnit Method

Glossary Item Box

Returns ResolutionUnit tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Syntax

public ImGearTIFFResolutionUnit getResolutionUnit()

Return Value

Nullable (boxed) ImGearTIFFResolutionUnit enumeration value. *

ImGearTIFFResolutionUnit

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getRowsPerStrip Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getRowsPerStrip Method

Glossary Item Box

Returns RowsPerStrip tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Syntax

public java.lang.long getRowsPerStrip()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSampleFormat Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSampleFormat Method

Glossary Item Box

Returns SampleFormat tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

Syntax

public int[] getSampleFormat()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSamplesPerPixel Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSamplesPerPixel Method

Glossary Item Box

Returns SamplesPerPixel tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Syntax

public java.lang.int getSamplesPerPixel()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSMaxSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSMaxSampleValue Method

Glossary Item Box

Returns SMaxSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

Syntax

public long[] getSMaxSampleValue()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSMinSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSMinSampleValue Method

Glossary Item Box

Returns SMinSampleValue tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

Syntax

public long[] getSMinSampleValue()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSoftware Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSoftware Method

Glossary Item Box

Returns Software tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Syntax

public java.lang.String getSoftware()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getStripByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getStripByteCounts Method

Glossary Item Box

Gets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public long[] getStripByteCounts()

Return Value

The tag value if the tag is present in the metadata tree, or null otherwise.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getStripOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getStripOffsets Method

Glossary Item Box

Returns StripOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Syntax

public long[] getStripOffsets()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getSubFileType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getSubFileType Method

Glossary Item Box

Returns SubFileType tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The getNewSubfileType method should be used instead.

Syntax

public ImGearTIFFSubFileType getSubFileType()

Return Value

Nullable (boxed) ImGearTIFFSubFileType enumeration value. *

ImGearTIFFSubFileType

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getT4Options Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getT4Options Method

Glossary Item Box

Returns T4Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

Syntax

public java.lang.long getT4Options()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getT6Options Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getT6Options Method

Glossary Item Box

Returns T6Options tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

Syntax

public java.lang.long getT6Options()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTargetPrinter Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTargetPrinter Method

Glossary Item Box

Returns TargetPrinter tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

Syntax

public java.lang.String getTargetPrinter()

Return Value

String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getThreshholding Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getThreshholding Method

Glossary Item Box

Returns Threshholding tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

Syntax

public java.lang.int getThreshholding()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTileByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTileByteCounts Method

Glossary Item Box

Returns TileByteCounts tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

Syntax

public long[] getTileByteCounts()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTileLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTileLength Method

Glossary Item Box

Returns TileLength tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

Syntax

public java.lang.long getTileLength()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTileOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTileOffsets Method

Glossary Item Box

Returns TileOffsets tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

Syntax

public long[] getTileOffsets()

Return Value

Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTileWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTileWidth Method

Glossary Item Box

Returns TileWidth tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

Syntax

public java.lang.long getTileWidth()

Return Value

Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTransferFunction Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTransferFunction Method

Glossary Item Box

Gets TransferFunction tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

Syntax

public int[] getTransferFunction()

Return Value

Unsigned short array.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getTransferRange Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getTransferRange Method

Glossary Item Box

Returns TransferRange tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

Syntax

public int[] getTransferRange()

Return Value

Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getWhitePoint Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getWhitePoint Method

Glossary Item Box

Returns WhitePoint tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Syntax

public ImGearRationalUInt[] getWhitePoint()

Return Value

com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getXPosition Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getXPosition Method

Glossary Item Box

Returns XPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

Syntax

public ImGearRationalUInt getXPosition()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getXResolution Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getXResolution Method

Glossary Item Box

Returns XResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Syntax

public ImGearRationalUInt getXResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getYCbCrCoefficients Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getYCbCrCoefficients Method

Glossary Item Box

Gets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

Syntax

public ImGearRationalUInt[] getYCbCrCoefficients()

Return Value

The tag value if the tag is present in the metadata tree, or null otherwise.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getYCbCrPositioning Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getYCbCrPositioning Method

Glossary Item Box

Returns YCbCrPositioning tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Syntax

public java.lang.int getYCbCrPositioning()

Return Value

Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getYCbCrSubSampling Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getYCbCrSubSampling Method

Glossary Item Box

Gets YCbCrSubSampling tag value. Method returns the tag value if the tag is present in the metadata tree, or null otherwise. if it was not present, or deletes the tag if a null value is passed.

This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

Syntax

public int[] getYCbCrSubSampling()

Return Value

Unsigned short array.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getYPosition Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getYPosition Method

Glossary Item Box

Returns YPosition tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

Syntax

public ImGearRationalUInt getYPosition()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

getYResolution Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : getYResolution Method

Glossary Item Box

Returns YResolution tag value.

Method returnsthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Syntax

public ImGearRationalUInt getYResolution()

Return Value

Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setArtist Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setArtist Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Artist tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Artist tag. The tag specifies the person who created the image.

Syntax

public void setArtist(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setBitsPerSample Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setBitsPerSample Method
value
Unsigned short array.

Glossary Item Box

Sets BitsPerSample tag value. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the BitsPerSample tag. The tag specifies number of bits per image component.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setBitsPerSample(
   int[] value
)

Parameters

value
Unsigned short array.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setCellLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setCellLength Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets CellLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellLength tag. The tag specifies the length of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Syntax

public void setCellLength(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setCellWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setCellWidth Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets CellWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the CellWidth tag. The tag specifies the width of the dithering or halftoning matrix used to create a dithered or halftoned bilevel file.

Syntax

public void setCellWidth(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setColorMap Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setColorMap Method
value
Ushort array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ColorMap tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ColorMap tag. The tag specifies a color map for palette color images.

Syntax

public void setColorMap(
   int[] value
)

Parameters

value
Ushort array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setCompression Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setCompression Method
value
Nullable (boxed) ImGearTIFFCompression enumeration value. *

ImGearTIFFCompression

Glossary Item Box

Sets Compression tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Compression tag. The tag specifies the compression scheme used on the image data.

Syntax

public void setCompression(
   ImGearTIFFCompression value
)

Parameters

value
Nullable (boxed) ImGearTIFFCompression enumeration value. *

ImGearTIFFCompression

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setCopyright Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setCopyright Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Copyright tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Copyright tag. The tag specifies the copyright notice for the image.

Syntax

public void setCopyright(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setDateTime Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setDateTime Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Date tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Date tag. The tag specifies the date and time of image creation.

Syntax

public void setDateTime(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setDocumentName Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setDocumentName Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets DocumentName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DocumentName tag. The tag specifies the name of the document from which this image was scanned.

Syntax

public void setDocumentName(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setDotRange Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setDotRange Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets DotRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the DotRange tag. The tag specifies the component values that correspond to a 0% dot and 100% dot. DotRange[0] corresponds to a 0% dot, and DotRange[1] corresponds to a 100% dot.

Syntax

public void setDotRange(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setExtraSamples Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setExtraSamples Method
value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ExtraSamples tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ExtraSamples tag. The tag describes the usage of the image's extra components.

Syntax

public void setExtraSamples(
   byte[] value
)

Parameters

value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setFillOrder Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setFillOrder Method
value
Nullable (boxed) ImGearTIFFFillOrder enumeration value. *

ImGearTIFFFillOrder

Glossary Item Box

Sets FillOrder tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FillOrder tag. The tag specifies the logical order of bits within a byte.

Syntax

public void setFillOrder(
   ImGearTIFFFillOrder value
)

Parameters

value
Nullable (boxed) ImGearTIFFFillOrder enumeration value. *

ImGearTIFFFillOrder

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setFreeByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setFreeByteCounts Method
value
Array of uint. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets FreeByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeByteCounts tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies the number of bytes in the string.

Syntax

public void setFreeByteCounts(
   long[] value
)

Parameters

value
Array of uint. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setFreeOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setFreeOffsets Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets FreeOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the FreeOffsets tag. For each string of contiguous unused bytes in a TIFF file, the tag specifies byte offset of the string.

Syntax

public void setFreeOffsets(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setGrayResponseCurve Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setGrayResponseCurve Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets GrayResponseCurve tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseCurve tag. For grayscale data, the tag specifies optical density of each possible pixel value.

Syntax

public void setGrayResponseCurve(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setGrayResponseUnit Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setGrayResponseUnit Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets GrayResponseUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the GrayResponseUnit tag. The tag specifies the precision of the information contained in the GrayResponseCurve.

Syntax

public void setGrayResponseUnit(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setHalftoneHints Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setHalftoneHints Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets HalftoneHints tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HalftoneHints tag. The purpose of the HalftoneHints tag is to convey to the halftone function the range of gray levels within a colorimetrically-specified image that should retain tonal detail.

Syntax

public void setHalftoneHints(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setHostComputer Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setHostComputer Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets HostComputer tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the HostComputer tag. The tag specifies the computer and/or operating system in use at the time of image creation.

Syntax

public void setHostComputer(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setImageDescription Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setImageDescription Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageDescription tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageDescription tag. The tag describes the subject of the image.

Syntax

public void setImageDescription(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setImageLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setImageLength Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageLength tag. The tag specifies the number of rows of pixels in the image.

Syntax

public void setImageLength(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setImageWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setImageWidth Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ImageWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ImageWidth tag. The tag specifies the number of columns in the image, i.e., the number of pixels per row.

Syntax

public void setImageWidth(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setInkNames Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setInkNames Method
value
Array of strings. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets InkNames tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkNames tag. The tag specifies the name of each ink used in a separated (PhotometricInterpretation=5) image.

Syntax

public void setInkNames(
   java.lang.String[] value
)

Parameters

value
Array of strings. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setInkSet Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setInkSet Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets InkSet tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InkSet tag. The tag specifies the set of inks used in a separated (PhotometricInterpretation=5) image.

Syntax

public void setInkSet(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setInterColorProfile Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setInterColorProfile Method
value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets InterColorProfile tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the InterColorProfile tag. The tag encodes an embedded InterColor (ICC) device profile relating to the camera color characterization.

Syntax

public void setInterColorProfile(
   byte[] value
)

Parameters

value
Array of bytes. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGACTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGACTables Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGACTables tag.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGACTables tag value. The tag specifies the list of offsets to the Huffman AC tables, one per component.

Syntax

public void setJPEGACTables(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGDCTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGDCTables Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGDCTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This field points to a list of offsets to the DC Huffman tables or the lossless Huffman tables, one per component.

Syntax

public void setJPEGDCTables(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGInterchangeFormat Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGInterchangeFormat Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGInterchangeFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormat tag. This field indicates whether a JPEG interchange format bitstream is present in the TIFF file. If a JPEG interchange format bitstream is present, then this tag points to the Start of Image (SOI) marker code.

Syntax

public void setJPEGInterchangeFormat(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGInterchangeFormatLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGInterchangeFormatLength Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGInterchangeFormatLngth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGInterchangeFormatLength tag. This tag indicates the length in bytes of the JPEG interchange format bitstream.

Syntax

public void setJPEGInterchangeFormatLength(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGLosslessPredictors Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGLosslessPredictors Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGLosslessPredictors tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGLosslessPredictors tag. This tag points to a list of lossless predictor-selection values, one per component.

Syntax

public void setJPEGLosslessPredictors(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGPointTransforms Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGPointTransforms Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGPointTransforms tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGPointTransforms tag. This field points to a list of point transform values, one per component. This field is relevant only for lossless processes.

Syntax

public void setJPEGPointTransforms(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGProc Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGProc Method
value
Nullable (boxed) ushort value.

Glossary Item Box

Sets JPEGProc tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the JPEGProc tag. This Tag indicates the JPEG process used to produce the compressed data. The values for this field are defined to be consistent with the numbering convention used in ISO DIS 10918-2. get accessor returns the tag value if the tag is present in the metadata tree, or null otherwise.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setJPEGProc(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGQTables Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGQTables Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGQTables tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGQTables tag. The tag points to a list of offsets to the quantization tables, one per component. Each table consists of 64 BYTES (one for each DCT coefficient in the 8x8 block).

Syntax

public void setJPEGQTables(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setJPEGRestartInterval Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setJPEGRestartInterval Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets JPEGRestartInterval tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the JPEGRestartInterval tag. This field indicates the length of the restart interval used in the compressed image data.

Syntax

public void setJPEGRestartInterval(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setMake Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setMake Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Make tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Make tag. The tag specifies the scanner or digital camera manufacturer.

Syntax

public void setMake(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setMaxSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setMaxSampleValue Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets MaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MaxSampleValue tag. The tag specifies the maximum component value used in the image.

Syntax

public void setMaxSampleValue(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setMinSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setMinSampleValue Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets MinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the MinSampleValue tag. The tag specifies the minimum component value used in the image.

Syntax

public void setMinSampleValue(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setModel Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setModel Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Model tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Model tag. The tag specifies the scanner or digital camera model name or number.

Syntax

public void setModel(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setNewSubfileType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setNewSubfileType Method
value
Nullable (boxed) ImGearTIFFNewSubFileTypeMasks enumeration value. *

ImGearTIFFNewSubFileTypeMasks

Glossary Item Box

Sets NewSubfileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NewSubfileType tag. The tag provides a general indication of the kind of data contained in this subfile.

The value is composed as a bitmask, using the members of ImGearTIFFNewSubFileTypeMasks enumeration.

Syntax

public void setNewSubfileType(
   ImGearTIFFNewSubFileTypeMasks value
)

Parameters

value
Nullable (boxed) ImGearTIFFNewSubFileTypeMasks enumeration value. *

ImGearTIFFNewSubFileTypeMasks

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setNumberOfInks Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setNumberOfInks Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets NumberOfInks tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the NumberOfInks tag. The tag specifies the number of inks. Usually equal to SamplesPerPixel, unless there are extra samples.

Syntax

public void setNumberOfInks(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setOrientation Method
value
Nullable (boxed) ImGearTIFFOrientation enumeration value. *

ImGearTIFFOrientation

Glossary Item Box

Sets Orientation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Orientation tag. The tag specifies the orientation of the image with respect to the rows and columns.

Syntax

public void setOrientation(
   ImGearTIFFOrientation value
)

Parameters

value
Nullable (boxed) ImGearTIFFOrientation enumeration value. *

ImGearTIFFOrientation

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPageName Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPageName Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets PageName tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageName tag. The tag specifies the name of the page from which this image was scanned.

Syntax

public void setPageName(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPageNumber Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPageNumber Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets PageNumber tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PageNumber tag. The tag specifies the page number of the page from which this image was scanned. PageNumber[0] is the page number; PageNumber[1] is the total number of pages in the document. If PageNumber[1] is 0, the total number of pages in the document is not available.

Syntax

public void setPageNumber(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPhotometricInterpretation Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPhotometricInterpretation Method
value
Nullable (boxed) ImGearTIFFPhotoInterpretation enumeration value. *

ImGearTIFFPhotoInterpretation

Glossary Item Box

Sets PhotometricInterpretation tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PhotometricInterpretation tag. This tag indicates the color space of the image.

Syntax

public void setPhotometricInterpretation(
   ImGearTIFFPhotoInterpretation value
)

Parameters

value
Nullable (boxed) ImGearTIFFPhotoInterpretation enumeration value. *

ImGearTIFFPhotoInterpretation

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPlanarConfig Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPlanarConfig Method
value
Nullable (boxed) ImGearTIFFPlanarConfig enumeration value. *

ImGearTIFFPlanarConfig

Glossary Item Box

Sets PlanarConfig tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PlanarConfig tag. The tag specifies how the components of each pixel are stored.

Syntax

public void setPlanarConfig(
   ImGearTIFFPlanarConfig value
)

Parameters

value
Nullable (boxed) ImGearTIFFPlanarConfig enumeration value. *

ImGearTIFFPlanarConfig

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPredictorType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPredictorType Method
value
Nullable (boxed) ImGearTIFFPredictorType enumeration value. *

ImGearTIFFPredictorType

Glossary Item Box

Sets PredictorType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PredictorType tag. Predictor is a mathematical operator that is applied to the image data before an encoding scheme is applied. It greatly improves compression ratios for some images.

Syntax

public void setPredictorType(
   ImGearTIFFPredictorType value
)

Parameters

value
Nullable (boxed) ImGearTIFFPredictorType enumeration value. *

ImGearTIFFPredictorType

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setPrimaryChromaticities Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setPrimaryChromaticities Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets PrimaryChromaticities tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the PrimaryChromaticities tag. The tag specifies chromaticities of the primaries of the image.

Syntax

public void setPrimaryChromaticities(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setReferenceBlackWhite Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setReferenceBlackWhite Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets ReferenceBlackWhite tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ReferenceBlackWhite tag. The tag specifies a pair of headroom and footroom image data values (codes) for each pixel component. The first component code within a pair is associated with ReferenceBlack, and the second is associated with ReferenceWhite.

Syntax

public void setReferenceBlackWhite(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setResolutionUnit Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setResolutionUnit Method
value
Nullable (boxed) ImGearTIFFResolutionUnit enumeration value. *

ImGearTIFFResolutionUnit

Glossary Item Box

Sets ResolutionUnit tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the ResolutionUnit tag. The tag specifies the unit of measurement for XResolution and YResolution.

Syntax

public void setResolutionUnit(
   ImGearTIFFResolutionUnit value
)

Parameters

value
Nullable (boxed) ImGearTIFFResolutionUnit enumeration value. *

ImGearTIFFResolutionUnit

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setRowsPerStrip Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setRowsPerStrip Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets RowsPerStrip tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the RowsPerStrip tag. The tag specifies the number of rows per strip.

Syntax

public void setRowsPerStrip(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSampleFormat Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSampleFormat Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets SampleFormat tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SampleFormat tag. The tag specifies how to interpret each data sample in a pixel.

Syntax

public void setSampleFormat(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSamplesPerPixel Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSamplesPerPixel Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets SamplesPerPixel tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SamplesPerPixel tag. The tag specifies the number of components per pixel.

Syntax

public void setSamplesPerPixel(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSMaxSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSMaxSampleValue Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets SMaxSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMaxSampleValue tag. The tag specifies the maximum sample value.

Syntax

public void setSMaxSampleValue(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSMinSampleValue Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSMinSampleValue Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets SMinSampleValue tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SMinSampleValue tag. The tag specifies the minimum sample value.

Syntax

public void setSMinSampleValue(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSoftware Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSoftware Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Software tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Software tag. The tag specifies the name and version number of the software package(s) used to create the image.

Syntax

public void setSoftware(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setStripByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setStripByteCounts Method
value
Replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

Glossary Item Box

Sets StripByteCounts tag value.

This property accesses the StripByteCounts tag. The tag specifies the number of bytes after any compression, for each strip.

ImageGear ignores the value of this tag during image saving, and saves a value that corresponds to the saved image DIB's parameters.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setStripByteCounts(
   long[] value
)

Parameters

value
Replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setStripOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setStripOffsets Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets StripOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the StripOffsets tag. The tag specifies the byte offset for each strip.

Syntax

public void setStripOffsets(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setSubFileType Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setSubFileType Method
value
Nullable (boxed) ImGearTIFFSubFileType enumeration value. *

ImGearTIFFSubFileType

Glossary Item Box

Sets SubFileType tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the SubFileType tag. The tag specifies general indication of the kind of data contained in this subfile.

This tag is deprecated. The setNewSubfileType method should be used instead.

Syntax

public void setSubFileType(
   ImGearTIFFSubFileType value
)

Parameters

value
Nullable (boxed) ImGearTIFFSubFileType enumeration value. *

ImGearTIFFSubFileType

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setT4Options Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setT4Options Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets T4Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T4Options tag. The tag specifies options for CCITT Group 3 compression.

Syntax

public void setT4Options(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setT6Options Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setT6Options Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets T6Options tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the T6Options tag. The tag specifies options for CCITT Group 4 compression.

Syntax

public void setT6Options(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTargetPrinter Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTargetPrinter Method
value
String value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TargetPrinter tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TargetPrinter tag. The tag specifies a description of the printing environment for which this separation is intended.

Syntax

public void setTargetPrinter(
   java.lang.String value
)

Parameters

value
String value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setThreshholding Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setThreshholding Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets Threshholding tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the Threshholding tag. For black and white TIFF files that represent shades of gray, this tag specifies the technique used to convert from gray to black and white pixels.

Syntax

public void setThreshholding(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTileByteCounts Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTileByteCounts Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TileByteCounts tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileByteCounts tag. The tag specifies the number of (compressed) bytes in the tile, for each image tile.

Syntax

public void setTileByteCounts(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTileLength Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTileLength Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TileLength tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileLength tag. The tag specifies the number of rows in each tile.

Syntax

public void setTileLength(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTileOffsets Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTileOffsets Method
value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TileOffsets tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileOffsets tag. The tag specifies the byte offsets of all image tiles, as compressed and stored on disk. The offset is specified with respect to the beginning of the TIFF file.

Syntax

public void setTileOffsets(
   long[] value
)

Parameters

value
Unsigned int array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTileWidth Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTileWidth Method
value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TileWidth tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TileWidth tag. The tag specifies the number of columns in each tile.

Syntax

public void setTileWidth(
   java.lang.int value
)

Parameters

value
Nullable (boxed) uint value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTransferFunction Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTransferFunction Method
value
Unsigned short array.

Glossary Item Box

Sets TransferFunction tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

This method accesses the TransferFunction tag. The tag describes a transfer function for the image in tabular style.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setTransferFunction(
   int[] value
)

Parameters

value
Unsigned short array.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setTransferRange Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setTransferRange Method
value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets TransferRange tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the TransferRange tag. The tag expands the range of the TransferFunction.

Syntax

public void setTransferRange(
   int[] value
)

Parameters

value
Unsigned short array. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setWhitePoint Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setWhitePoint Method
value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets WhitePoint tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the WhitePoint tag. The tag specifies the chromaticity of the white point of the image.

Syntax

public void setWhitePoint(
   ImGearRationalUInt[] value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalUInt structure[] array. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setXPosition Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setXPosition Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets XPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XPosition tag. The tag specifies x position of the image.

Syntax

public void setXPosition(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setXResolution Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setXResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets XResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the XResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageWidth (typically, horizontal - see Orientation) direction.

Syntax

public void setXResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setYCbCrCoefficients Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setYCbCrCoefficients Method
value
Replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

Glossary Item Box

Sets YCbCrSubSampling tag value.

This property accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setYCbCrCoefficients(
   ImGearRationalUInt[] value
)

Parameters

value
Replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setYCbCrPositioning Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setYCbCrPositioning Method
value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

Glossary Item Box

Sets YCbCrPositioning tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YCbCrPositioning tag. The tag specifies the positioning of subsampled chrominance components relative to luminance samples.

Syntax

public void setYCbCrPositioning(
   java.lang.short value
)

Parameters

value
Nullable (boxed) ushort value. *

See the TIFF 6.0 specification for tag usage details.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setYCbCrSubSampling Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setYCbCrSubSampling Method
value
Unsigned short array.

Glossary Item Box

Sets YCbCrSubSampling tag value. Method replaces the current tag value if the tag is present in the metadata tree, adds the tag if it was not present, or deletes the tag if a null value is passed.

\This method accesses the YCbCrSubSampling tag. The tag specifies the subsampling factors used for the chrominance components of a YCbCr image.

See the TIFF 6.0 specification for tag usage details.

Syntax

public void setYCbCrSubSampling(
   int[] value
)

Parameters

value
Unsigned short array.

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setYPosition Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setYPosition Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets YPosition tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YPosition tag. The tag specifies Y offset in ResolutionUnits of the top of the image, with respect to the top of the page. In the TIFF coordinate scheme, the positive Y direction is down, so that YPosition is always positive.

Syntax

public void setYPosition(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

setYResolution Method
com.accusoft.imagegear.formats.tif Package > ImGearTIFFMetadata Class : setYResolution Method
value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

Glossary Item Box

Sets YResolution tag value.

Method replacesthe tag value if the tag is present in the metadata tree, or null otherwise.

This method accesses the YResolution tag. The tag specifies the number of pixels per ResolutionUnit in the ImageLength (typically, vertical) direction.

Syntax

public void setYResolution(
   ImGearRationalUInt value
)

Parameters

value
Nullable (boxed) com.accusoft.imagegear.core.ImGearRationalUInt structure value. *

com.accusoft.imagegear.core.ImGearRationalUInt

See Also

Reference

ImGearTIFFMetadata Class
ImGearTIFFMetadata Members


%%PageItemTitle%%

ImGearPhotoInterpretations Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearPhotoInterpretations Enumeration

Glossary Item Box

This enumeration specifies all the supported types of TIFF photometric interpretations.

Members

Member | Description
BLACKZERO | Black is zero. For bilevel and grayscale images: 0 is imaged as black. 2**BitsPerSample-1 is imaged as white.
CFA | Color Filter Array photometric interpretation.
CIELAB | CIE Lab (using TIFF format for storing a and b values).
CMYK | CMYK photometric interpretation.
ICC_CIELAB | CIE Lab (using ICC format for storing a and b values).
PALETTE | Palette color photometric interpretation.
RGB | RGB photometric interpretation.
TRANSPARENCY | Transparency photometric interpretation.
WHITEZERO | White is zero. For bilevel and grayscale images: 0 is imaged as white. 2**BitsPerSample-1 is imaged as black.
YCBCR | YCbCr photometric interpretation.
YUV | YUV photometric interpretation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearPhotoInterpretations

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearStripModes Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearStripModes Enumeration

Glossary Item Box

This enumeration specifies all the supported strip and tile modes for TIFF image writing.

Members

Member | Description
FIXED_BUFFER | Save image using strips not exceeding specified size.
FIXED_COUNT | Save image using specified number of strips.
TILED_FIXED_COUNT | Save image using specified number of tiles vertically and horizontally.
TILED_FIXED_SIZE | Save image using tiles of specified size.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearStripModes

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFBitonalPaletteMode Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFBitonalPaletteMode Enumeration

Glossary Item Box

Specifies whether ImageGear shall fix strange looking palettes when reading bitonal TIFF images.

Members

Member | Description
FIX | Fix strange looking palettes, as follows: if (R0+G0+B0)/3 <, (R1+G1+B1)/3 change palette to (black, white). Otherwise, change palette to (white, black). Specifically, constant palettes (all-black, all-white) are replaced with (white, black) palette.
KEEP_AS_IS | Keep palette as is, even if it is all-black or red-green. If photometric interpretation is PALETTE_COLOR, but COLORMAP tag is absent, assume all-black palette.
LEGACY | Keep ImageGear 16.0 behavior: read all 1-bit palettes as is. If palette is missing, assume increasing (blackzero) palette.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFBitonalPaletteMode

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFCompression Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFCompression Enumeration

Glossary Item Box

Represents TIFF compressions.

Members

Member | Description
ABIC_BW | ABIC b/w image.
ABIC_Concatenated | ABIC concatenated image.
ABIC_GRAY | ABIC gray image.
ABIC_IOCA | ABIC IOCA image.
CCITT_1D | CCITT 1D compression.
Deflate | Deflate compression.
DeflateObsolete | Legacy constant for Deflate compression.
GROUP_3 | CCITT Group 3 compression.
GROUP_4 | CCITT Group 4 compression.
JBIG | JBIG compression.
JPEG | JPEG (using TIFF 6.0 specification).
JPEG_2 | JPEG (using TIFF Technical Note 2 specification).
LZW | Lempel-Ziv and Welch compression.
Packbits | Packed Bits.
Thunderscan | Thunderscan RLE compression.
Uncompressed | Uncompressed (no compression).

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFCompression

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFFillOrder Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFFillOrder Enumeration

Glossary Item Box

Represents TIFF fill orders.

Members

Member | Description
LeastSignificantBitFirst | Pixels are arranged within a byte such that pixels with lower column values are stored in the lower-order bits of the byte.
MostSignificantBitFirst | Pixels are arranged within a byte such that pixels with lower column values are stored in the higher-order bits of the byte.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFFillOrder

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFNewSubFileTypeMasks Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFNewSubFileTypeMasks Enumeration

Glossary Item Box

Represents TIFF New Subfile Type masks.

Members

Member | Description
Alpha | The image defines a transparency mask for another image in this TIFF file.
PageOfMultipageImage | The image is a single page of a multi-page image.
Thumbnail | The image is a reduced-resolution version of another image in this TIFF file.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFNewSubFileTypeMasks

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFOrientation Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFOrientation Enumeration

Glossary Item Box

Represents TIFF orientations.

Members

Member | Description
BottomLeft | The 0th row represents the visual bottom of the image, and the 0th column represents the visual left-hand side. Row0=Bottom Col0=Left flip-V.
BottomRight | The 0th row represents the visual bottom of the image, and the 0th column represents the visual right-hand side. Row0=Bottom Col0=Right rotate 180.
LeftBottom | The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual bottom. Row0=Left Col0=Bottom rotate 90 CC (landscape).
LeftTop | The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual top. Row0=Left Col0=Top rotate 90 CC and flip V.
RightBottom | The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual bottom. Row0=Right Col0=Bottom rotate 90 C and flip V.
RightTop | The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual top. Row0=Right Col0=Top rotate 90 C (landscape).
TopLeft | The 0th row represents the visual top of the image, and the 0th column represents the visual left-hand side. Row0=Top Col0=Left Normal (Portrait).
TopRight | The 0th row represents the visual top of the image, and the 0th column represents the visual right-hand side. Row0=Top Col0=Right flip-H.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFPhotoInterpretation Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFPhotoInterpretation Enumeration

Glossary Item Box

Represents TIFF photometric interpretations.

Members

Member | Description
Blackzero | Black is zero. For bilevel and grayscale images: 0 is imaged as black. 2**BitsPerSample-1 is imaged as white.
CFA | Color Filter Array.
CIELab | CIE Lab (using TIFF format for storing a and b values).
CMYK | CMYK photometric interpretation.
ICC_CIELab | CIE Lab (using ICC format for storing a and b values).
Palette | Palette color.
RGB | RGB photometric interpretation.
Transparency | Transparency photometric interpretation.
Whitezero | White is zero. For bilevel and grayscale images: 0 is imaged as white. 2**BitsPerSample-1 is imaged as black.
YCbCb | YCbCr photometric interpretation.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFPlanarConfig Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFPlanarConfig Enumeration

Glossary Item Box

Represents TIFF planar configurations.

Members

Member | Description
Chunky | Chunky format. The component values for each pixel are stored contiguously.
Planar | Planar format. The components are stored in separate "component planes".

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFPredictorType Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFPredictorType Enumeration

Glossary Item Box

Represents TIFF predictor types.

Members

Member | Description
HORIZ_DIFF | Horizontal differencing.
NONE | No prediction scheme used before coding.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFPredictorType

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFResolutionUnit Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFResolutionUnit Enumeration

Glossary Item Box

Represents TIFF resolution units.

Members

Member | Description
Centimeter | Centimeter resolution unit.
Inch | Inch resolution unit.
NoAbsoluteUnit | No absolute unit of measurement. Used for images that may have a non-square aspect ratio but no meaningful absolute dimensions.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%PageItemTitle%%

ImGearTIFFSubFileType Enumeration
com.accusoft.imagegear.formats.tif Package : ImGearTIFFSubFileType Enumeration

Glossary Item Box

Represents TIFF subfile types.

Members

Member | Description
FullResolutionImage | Full resolution image.
PageOfMultipageImage | Page of a multipage image.
Thumbnail | Thumbnail type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.tif.ImGearTIFFSubFileType

See Also

Reference

com.accusoft.imagegear.formats.tif Package


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP format.

Classes

Class | Description
ImGearXMPAlt<T> | Represents an array of XMP properties. This class represents an array of XMP properties, one of which should be chosen by the application or by the user. First item in the array is considered to be the default one. ImGearXMPValue type.
ImGearXMPArray<T> | Represents baseline features of an array of XMP properties. ImGearXMPValue type.
ImGearXMPBag<T> | Represents an unordered array of XMP properties. ImGearXMPValue type.
ImGearXMPBoolean | Represents a boolean XMP metadata value.
ImGearXMPColorant | Represents an XMP colorant structure. This structure contains the characteristics of a colorant (swatch) used in a document. See XMP specification for structure usage details.
ImGearXMPDate | Represents a Date XMP metadata type.
ImGearXMPDimensions | Represents an XMP Dimensions structure. This structure contains dimensions of a drawn object. See XMP specification for structure usage details.
ImGearXMPEnum<T> | Represents an enumeration (closed choice of integer) XMP metadata value.
ImGearXMPFont | Represents an XMP Font structure. This structure contains the characteristics of a font used in a document. See XMP specification for structure usage details.
ImGearXMPFormatMetadata | The base for XMP schema accessor classes. This class serves as the base for XMP schema accessor classes.
ImGearXMPInteger | Represents an integer XMP metadata value.
ImGearXMPLangAlt | Represents a language alternative. This class represents a language alternative. It contains the same logical text in multiple languages. The text in each specific language is available through properties of the ImGearXMPLangAlt object. If text in a specific language is does not exist in the object, corresponding method returns null. ImGearXMPLangAlt.getDefault() method represents the default value for the language alternative.
ImGearXMPMetadataRoot | Provides simplified access to XMP metadata. Properties of this class represent XMP schemas that are known to ImageGear.
ImGearXMPRational | Represents a rational XMP metadata value.
ImGearXMPReal | Represents a floating point XMP metadata value. This value has an optional qualifier that provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as: std size,endian,hexadecimal_value - std is the standard name ("IEEE754") - size is S for 32-bit and D for 64-bit - endian is L for little-endian, B for big-endian. For example: "IEEE754D,L,3A4901F387D31108"
ImGearXMPSeq<T> | Represents an ordered array of XMP properties. ImGearXMPValue type.
ImGearXMPString | Represents a string XMP metadata value.
ImGearXMPStructure | Specifies baseline features for XMP structures. This abstract class specifies baseline features for XMP structures, such as ImGearXMPFont class, ImGearXMPColorant class, etc.
ImGearXMPThumbnail | Represents an XMP Thumbnail structure. This class is not implemented yet.
ImGearXMPValue | Specifies baseline features for an XMP value. This abstract class specifies baseline features for an XMP property value.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot
com.accusoft.imagegear.formats.xmp.ImGearXMPArray<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt
com.accusoft.imagegear.formats.xmp.ImGearXMPReal
com.accusoft.imagegear.formats.xmp.ImGearXMPValue

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

T
ImGearXMPValue type.
ImageGear for Java
ImGearXMPAlt<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPAlt<T> Class

Glossary Item Box

Represents an array of XMP properties.

This class represents an array of XMP properties, one of which should be chosen by the application or by the user. First item in the array is considered to be the default one.

ImGearXMPValue type.

Object Model

ImGearXMPAlt<T> Class

Syntax

public sealed class ImGearXMPAlt<T>
    extends ImGearXMPArray<T>

Type Parameters

T
ImGearXMPValue type.

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPArray<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<T>

See Also

Reference

ImGearXMPAlt<T> Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPAlt<T> Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPAlt<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPAlt<T>.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPAlt<T> Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getEnumerator | Returns an enumerator that iterates through the ImGearXMPAlt<T>.
Top

See Also

Reference

ImGearXMPAlt<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPAlt<T> Class : ImGearXMPAlt<T> Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPAlt<T> Constructor() | Initializes a new instance of the ImGearXMPAlt<T> class.
ImGearXMPAlt<T> Constructor(String[],Class<T>) | Initializes a new instance of the ImGearXMPAlt<T> class with values from the string array.

See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPAlt<T> Class > ImGearXMPAlt<T> Constructor : ImGearXMPAlt<T> Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPAlt<T> class.

Syntax

public ImGearXMPAlt<T>()

Return Value

New instance of ImGearXMPAlt<T> generic class object.

This constructor creates an empty instance of ImGearXMPAlt<T> generic class.

See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPAlt<T> Constructor(String[],Class<T>)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPAlt<T> Class > ImGearXMPAlt<T> Constructor : ImGearXMPAlt<T> Constructor(String[],Class<T>)
value
String array.
classType

Glossary Item Box

Initializes a new instance of the ImGearXMPAlt<T> class with values from the string array.

Syntax

public ImGearXMPAlt<T>(
   java.lang.String[] value,
   java.lang.Class<T> classType
)

Parameters

value
String array.
classType

Return Value

New instance of ImGearXMPAlt<T> generic class object.

This constructor creates an instance of ImGearXMPAlt<T> generic class and initializes it with values from the string array.

See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPAlt<T> Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPAlt<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPAlt<T> members.

Public Methods

 | Name | Description
public Method | getEnumerator | Returns an enumerator that iterates through the ImGearXMPAlt<T>.
Top

See Also

Reference

ImGearXMPAlt<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getEnumerator Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPAlt<T> Class : getEnumerator Method

Glossary Item Box

Returns an enumerator that iterates through the ImGearXMPAlt<T>.

Syntax

public java.util.Iterator<T> getEnumerator()

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPAlt<T>.

See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members


%%PageItemTitle%%

toStringArray Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPAlt<T> Class : toStringArray Method

Glossary Item Box

Syntax

public java.lang.String[] toStringArray()

See Also

Reference

ImGearXMPAlt<T> Class
ImGearXMPAlt<T> Members


%%PageItemTitle%%

T
ImGearXMPValue type.
ImageGear for Java
ImGearXMPArray<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPArray<T> Class

Glossary Item Box

Represents baseline features of an array of XMP properties.

ImGearXMPValue type.

Object Model

ImGearXMPArray<T> Class

Syntax

public class ImGearXMPArray<T>
    extends Object
    implements java.lang.Iterable

Type Parameters

T
ImGearXMPValue type.

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPArray<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T>

See Also

Reference

ImGearXMPArray<T> Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPArray<T> Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPArray<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPArray<T>.

Protected Constructors

 | Name | Description
protected Constructor | ImGearXMPArray<T> Constructor | Initializes a new instance of the ImGearXMPArray<T> class.
Top

Public Methods

 | Name | Description
public Method | add | Adds an object to the end of the ImGearXMPArray<T>.
public Method | clear | Removes all elements from the ImGearXMPArray<T>.
public Method | contains | Determines whether an element is in the ImGearXMPArray<T>.
public Method | copyTo | Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.
public Method | getCount | Gets the number of elements actually contained in the ImGearXMPArray<T>.
public Method | getItem | Gets the element at the specified index.
public Method | indexOf | Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.
public Method | insert | Inserts an element into the ImGearXMPArray<T> at the specified index.
public Method | isReadOnly | Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.
public Method | iterator | Returns an iterator that iterates through the ImGearXMPArray<T>.
public Method | remove | Removes the first occurrence of a specific object from the ImGearXMPArray<T>.
public Method | removeAt | Removes the element at the specified index of the ImGearXMPArray<T>.
public Method | setItem | Sets the element at the specified index.
public Method | toString | Returns a System.String that represents the current ImGearXMPArray<T>.
Top

See Also

Reference

ImGearXMPArray<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPArray<T> Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : ImGearXMPArray<T> Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPArray<T> class.

Syntax

protected ImGearXMPArray<T>()

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPArray<T> Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPArray<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPArray<T> members.

Public Methods

 | Name | Description
public Method | add | Adds an object to the end of the ImGearXMPArray<T>.
public Method | clear | Removes all elements from the ImGearXMPArray<T>.
public Method | contains | Determines whether an element is in the ImGearXMPArray<T>.
public Method | copyTo | Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.
public Method | getCount | Gets the number of elements actually contained in the ImGearXMPArray<T>.
public Method | getItem | Gets the element at the specified index.
public Method | indexOf | Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.
public Method | insert | Inserts an element into the ImGearXMPArray<T> at the specified index.
public Method | isReadOnly | Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.
public Method | iterator | Returns an iterator that iterates through the ImGearXMPArray<T>.
public Method | remove | Removes the first occurrence of a specific object from the ImGearXMPArray<T>.
public Method | removeAt | Removes the element at the specified index of the ImGearXMPArray<T>.
public Method | setItem | Sets the element at the specified index.
public Method | toString | Returns a System.String that represents the current ImGearXMPArray<T>.
Top

See Also

Reference

ImGearXMPArray<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : add Method
item
The object to be added to the end of the ImGearXMPArray<T>.

Glossary Item Box

Adds an object to the end of the ImGearXMPArray<T>.

Syntax

public void add(
   T item
)

Parameters

item
The object to be added to the end of the ImGearXMPArray<T>.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

clear Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : clear Method

Glossary Item Box

Removes all elements from the ImGearXMPArray<T>.

Syntax

public void clear()

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : contains Method
item
The object to locate in the ImGearXMPArray<T>.

Glossary Item Box

Determines whether an element is in the ImGearXMPArray<T>.

Syntax

public boolean contains(
   T item
)

Parameters

item
The object to locate in the ImGearXMPArray<T>.

Return Value

true if item is found in the ImGearXMPArray<T>; otherwise - false.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

copyTo Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : copyTo Method
array
The one-dimensional System.Array that is the destination of the elements copied from ImGearXMPArray<T>. The System.Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Glossary Item Box

Copies the entire ImGearXMPArray<T> to a compatible one-dimensional array, starting at the specified index of the target array.

Syntax

public void copyTo(
   T[] array,
   int arrayIndex
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from ImGearXMPArray<T>. The System.Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

getCount Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : getCount Method

Glossary Item Box

Gets the number of elements actually contained in the ImGearXMPArray<T>.

Syntax

public int getCount()

Return Value

The number of elements actually contained in the ImGearXMPArray<T>.

Integer value.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

getItem Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : getItem Method
index
The zero-based index of the element to get or set.

Glossary Item Box

Gets the element at the specified index.

Syntax

public T getItem(
   int index
)

Parameters

index
The zero-based index of the element to get or set.

Return Value

The element at the specified index.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

indexOf Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : indexOf Method
item
The object to locate in the ImGearXMPArray<T>.

Glossary Item Box

Searches for the specified item and returns the zero-based index of the first occurrence within ImGearXMPArray<T>.

Syntax

public int indexOf(
   T item
)

Parameters

item
The object to locate in the ImGearXMPArray<T>.

Return Value

The zero-based index of the first occurrence of item within the entire ImGearXMPArray<T>, if found; otherwise, -1.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

insert Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : insert Method
index
The zero-based index at which item should be inserted.
item
The object to insert.

Glossary Item Box

Inserts an element into the ImGearXMPArray<T> at the specified index.

Syntax

public void insert(
   int index,
   T item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

isReadOnly Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : isReadOnly Method

Glossary Item Box

Gets a value indicating whether the object of ImGearXMPArray<T> is readonly.

Syntax

public boolean isReadOnly()

Return Value

false Boolean value.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : iterator Method

Glossary Item Box

Returns an iterator that iterates through the ImGearXMPArray<T>.

Syntax

public java.util.Iterator<T> iterator()

Return Value

A java.util.Iterator<E> object for the ImGearXMPArray<T>.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : remove Method
item
The object to remove from the ImGearXMPArray<T>.

Glossary Item Box

Removes the first occurrence of a specific object from the ImGearXMPArray<T>.

Syntax

public boolean remove(
   T item
)

Parameters

item
The object to remove from the ImGearXMPArray<T>.

Return Value

If item was successfully removed, returns true, otherwise - false. This method also returns false if item was not found in the ImGearXMPArray<T>.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

removeAt Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : removeAt Method
index
The zero-based index of the element to remove.

Glossary Item Box

Removes the element at the specified index of the ImGearXMPArray<T>.

Syntax

public void removeAt(
   int index
)

Parameters

index
The zero-based index of the element to remove.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

setItem Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : setItem Method
index
The zero-based index of the element to get or set.
value
The element to set at the specified index.

Glossary Item Box

Sets the element at the specified index.

Syntax

public void setItem(
   int index,
   T value
)

Parameters

index
The zero-based index of the element to get or set.
value
The element to set at the specified index.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPArray<T> Class : toString Method

Glossary Item Box

Returns a System.String that represents the current ImGearXMPArray<T>.

Syntax

public java.lang.String toString()

Return Value

A System.String that represents the current object.

See Also

Reference

ImGearXMPArray<T> Class
ImGearXMPArray<T> Members


%%PageItemTitle%%

T
ImGearXMPValue type.
ImageGear for Java
ImGearXMPBag<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBag<T> Class

Glossary Item Box

Represents an unordered array of XMP properties.

ImGearXMPValue type.

Object Model

ImGearXMPBag<T> Class

Syntax

public sealed class ImGearXMPBag<T>
    extends ImGearXMPArray<T>

Type Parameters

T
ImGearXMPValue type.

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPArray<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T>

See Also

Reference

ImGearXMPBag<T> Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPBag<T> Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBag<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPBag<T>.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPBag<T> Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getEnumerator | Returns an enumerator that iterates through the ImGearXMPBag<T>.
Top

See Also

Reference

ImGearXMPBag<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPBag<T> Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBag<T> Class : ImGearXMPBag<T> Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPBag<T> Constructor() | Initializes a new instance of the ImGearXMPBag<T> class.
ImGearXMPBag<T> Constructor(String[],Class<T>) | Initializes a new instance of the ImGearXMPBag<T> class and initializes it with values from the string array.

See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members


%%PageItemTitle%%

ImGearXMPBag<T> Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBag<T> Class > ImGearXMPBag<T> Constructor : ImGearXMPBag<T> Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPBag<T> class.

Syntax

public ImGearXMPBag<T>()

Return Value

New instance of ImGearXMPBag<T> generic class object.

This constructor creates an empty instance of ImGearXMPBag<T> generic class.

See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPBag<T> Constructor(String[],Class<T>)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBag<T> Class > ImGearXMPBag<T> Constructor : ImGearXMPBag<T> Constructor(String[],Class<T>)
value
String array.
clazz

Glossary Item Box

Initializes a new instance of the ImGearXMPBag<T> class and initializes it with values from the string array.

Syntax

public ImGearXMPBag<T>(
   java.lang.String[] value,
   java.lang.Class<T> clazz
)

Parameters

value
String array.
clazz

Return Value

New instance of ImGearXMPBag<T> generic class object.

This constructor creates an instance of ImGearXMPBag<T> generic class and initializes it with values from the string array.

See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPBag<T> Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBag<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPBag<T> members.

Public Methods

 | Name | Description
public Method | getEnumerator | Returns an enumerator that iterates through the ImGearXMPBag<T>.
Top

See Also

Reference

ImGearXMPBag<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getEnumerator Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBag<T> Class : getEnumerator Method

Glossary Item Box

Returns an enumerator that iterates through the ImGearXMPBag<T>.

Syntax

public java.util.Iterator<T> getEnumerator()

Return Value

A System.Collections.Generic.IEnumerator object for the ImGearXMPBag<T>.

See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members


%%PageItemTitle%%

toStringArray Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBag<T> Class : toStringArray Method

Glossary Item Box

Syntax

public java.lang.String[] toStringArray()

See Also

Reference

ImGearXMPBag<T> Class
ImGearXMPBag<T> Members


%%PageItemTitle%%

ImGearXMPBoolean Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBoolean Class

Glossary Item Box

Represents a boolean XMP metadata value.

Object Model

ImGearXMPBoolean Class

Syntax

public class ImGearXMPBoolean
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean

See Also

Reference

ImGearXMPBoolean Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPBoolean Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBoolean Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPBoolean.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPBoolean Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets a value indicating whether boolean value is true or false. Boolean value.
Top

See Also

Reference

ImGearXMPBoolean Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPBoolean Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBoolean Class : ImGearXMPBoolean Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPBoolean Constructor(boolean) | Initializes a new instance of the ImGearXMPBoolean class with a bool value.
ImGearXMPBoolean Constructor() | Initializes a new instance of the ImGearXMPBoolean class with a default value.

See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members


%%PageItemTitle%%

ImGearXMPBoolean Constructor(boolean)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBoolean Class > ImGearXMPBoolean Constructor : ImGearXMPBoolean Constructor(boolean)
value
Boolean value.

Glossary Item Box

Initializes a new instance of the ImGearXMPBoolean class with a bool value.

Syntax

public ImGearXMPBoolean(
   boolean value
)

Parameters

value
Boolean value.

Return Value

New instance of ImGearXMPBoolean class object.

This constructor creates and initializes an instance of ImGearXMPBoolean class by using a bool value.

See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members
Overload List


%%PageItemTitle%%

ImGearXMPBoolean Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBoolean Class > ImGearXMPBoolean Constructor : ImGearXMPBoolean Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPBoolean class with a default value.

Syntax

public ImGearXMPBoolean()

Return Value

New instance of ImGearXMPBoolean class object.

This constructor creates an instance of ImGearXMPBoolean class and initializes it with a default value (false).

See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPBoolean Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPBoolean Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPBoolean members.

Public Methods

 | Name | Description
public Method | getValue | Gets a value indicating whether boolean value is true or false. Boolean value.
Top

See Also

Reference

ImGearXMPBoolean Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPBoolean Class : getValue Method

Glossary Item Box

Gets a value indicating whether boolean value is true or false.

Boolean value.

Syntax

public boolean getValue()

See Also

Reference

ImGearXMPBoolean Class
ImGearXMPBoolean Members


%%PageItemTitle%%

ImGearXMPColorant Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPColorant Class

Glossary Item Box

Represents an XMP colorant structure.

This structure contains the characteristics of a colorant (swatch) used in a document.

See XMP specification for structure usage details.

Object Model

ImGearXMPColorant ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPInteger ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPString ClassImGearXMPReal Class

Syntax

public class ImGearXMPColorant
    extends ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPColorant

See Also

Reference

ImGearXMPColorant Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPColorant Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPColorant Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPColorant.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPColorant Constructor | Initializes a new instance of the ImGearXMPColorant class.
Top

Public Methods

 | Name | Description
public Method | getA | Returns A value when the mode is LAB. Valid range is -128..127.
public Method | getB | Returns B value when the mode is LAB. Valid range is -128..127.
public Method | getBlack | Returns black value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getBlue | Returns blue value when the mode is RGB. Valid range is 0..255.
public Method | getCyan | Returns cyan value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getGreen | Returns green value when the mode is RGB. Valid range is 0..255.
public Method | getL | Returns L value when the mode is LAB. Valid range is 0..100.
public Method | getMagenta | Returns magenta value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getMode | Returns the color space in which the color is defined.
public Method | getRed | Returns red value when the mode is RGB. Valid range is 0..255.
public Method | getSwatchName | Returns name of the swatch.
public Method | getType | Returns the type of color, one of PROCESS or SPOT.
public Method | getYellow | Returns yellow value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setA | Sets A value when the mode is LAB. Valid range is -128..127.
public Method | setB | Sets B value when the mode is LAB. Valid range is -128..127.
public Method | setBlack | Sets black value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setBlue | Sets blue value when the mode is RGB. Valid range is 0..255.
public Method | setCyan | Sets cyan value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setGreen | Sets green value when the mode is RGB. Valid range is 0..255.
public Method | setL | Sets L value when the mode is LAB. Valid range is 0..100.
public Method | setMagenta | Sets magenta value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setMode | Sets the color space in which the color is defined.
public Method | setRed | Sets red value when the mode is RGB. Valid range is 0..255.
public Method | setSwatchName | Sets name of the swatch.
public Method | setType | Sets the type of color, one of PROCESS or SPOT.
public Method | setYellow | Sets yellow value when the mode is CMYK. Valid range is 0 ... 100.
Top

See Also

Reference

ImGearXMPColorant Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPColorant Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : ImGearXMPColorant Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPColorant class.

Syntax

public ImGearXMPColorant()

Return Value

New instance of ImGearXMPColorant class object.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPColorant Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPColorant Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPColorant members.

Public Methods

 | Name | Description
public Method | getA | Returns A value when the mode is LAB. Valid range is -128..127.
public Method | getB | Returns B value when the mode is LAB. Valid range is -128..127.
public Method | getBlack | Returns black value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getBlue | Returns blue value when the mode is RGB. Valid range is 0..255.
public Method | getCyan | Returns cyan value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getGreen | Returns green value when the mode is RGB. Valid range is 0..255.
public Method | getL | Returns L value when the mode is LAB. Valid range is 0..100.
public Method | getMagenta | Returns magenta value when the mode is CMYK. Valid range is 0 ... 100.
public Method | getMode | Returns the color space in which the color is defined.
public Method | getRed | Returns red value when the mode is RGB. Valid range is 0..255.
public Method | getSwatchName | Returns name of the swatch.
public Method | getType | Returns the type of color, one of PROCESS or SPOT.
public Method | getYellow | Returns yellow value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setA | Sets A value when the mode is LAB. Valid range is -128..127.
public Method | setB | Sets B value when the mode is LAB. Valid range is -128..127.
public Method | setBlack | Sets black value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setBlue | Sets blue value when the mode is RGB. Valid range is 0..255.
public Method | setCyan | Sets cyan value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setGreen | Sets green value when the mode is RGB. Valid range is 0..255.
public Method | setL | Sets L value when the mode is LAB. Valid range is 0..100.
public Method | setMagenta | Sets magenta value when the mode is CMYK. Valid range is 0 ... 100.
public Method | setMode | Sets the color space in which the color is defined.
public Method | setRed | Sets red value when the mode is RGB. Valid range is 0..255.
public Method | setSwatchName | Sets name of the swatch.
public Method | setType | Sets the type of color, one of PROCESS or SPOT.
public Method | setYellow | Sets yellow value when the mode is CMYK. Valid range is 0 ... 100.
Top

See Also

Reference

ImGearXMPColorant Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getA Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getA Method

Glossary Item Box

Returns A value when the mode is LAB.

Valid range is -128..127.

Syntax

public ImGearXMPInteger getA()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getB Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getB Method

Glossary Item Box

Returns B value when the mode is LAB.

Valid range is -128..127.

Syntax

public ImGearXMPInteger getB()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getBlack Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getBlack Method

Glossary Item Box

Returns black value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public ImGearXMPReal getBlack()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getBlue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getBlue Method

Glossary Item Box

Returns blue value when the mode is RGB.

Valid range is 0..255.

Syntax

public ImGearXMPInteger getBlue()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getCyan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getCyan Method

Glossary Item Box

Returns cyan value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public ImGearXMPReal getCyan()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getGreen Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getGreen Method

Glossary Item Box

Returns green value when the mode is RGB.

Valid range is 0..255.

Syntax

public ImGearXMPInteger getGreen()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getL Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getL Method

Glossary Item Box

Returns L value when the mode is LAB.

Valid range is 0..100.

Syntax

public ImGearXMPReal getL()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getMagenta Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getMagenta Method

Glossary Item Box

Returns magenta value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public ImGearXMPReal getMagenta()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getMode Method

Glossary Item Box

Returns the color space in which the color is defined.

Syntax

public ImGearXMPString getMode()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getRed Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getRed Method

Glossary Item Box

Returns red value when the mode is RGB.

Valid range is 0..255.

Syntax

public ImGearXMPInteger getRed()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getSwatchName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getSwatchName Method

Glossary Item Box

Returns name of the swatch.

Syntax

public ImGearXMPString getSwatchName()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getType Method

Glossary Item Box

Returns the type of color, one of PROCESS or SPOT.

Syntax

public ImGearXMPString getType()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

getYellow Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : getYellow Method

Glossary Item Box

Returns yellow value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public ImGearXMPReal getYellow()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setA Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setA Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets A value when the mode is LAB.

Valid range is -128..127.

Syntax

public void setA(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setB Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setB Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets B value when the mode is LAB.

Valid range is -128..127.

Syntax

public void setB(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setBlack Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setBlack Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets black value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public void setBlack(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setBlue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setBlue Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets blue value when the mode is RGB.

Valid range is 0..255.

Syntax

public void setBlue(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setCyan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setCyan Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets cyan value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public void setCyan(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setGreen Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setGreen Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets green value when the mode is RGB.

Valid range is 0..255.

Syntax

public void setGreen(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setL Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setL Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets L value when the mode is LAB.

Valid range is 0..100.

Syntax

public void setL(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setMagenta Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setMagenta Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets magenta value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public void setMagenta(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setMode Method
value
ImGearXMPString class value.

Glossary Item Box

Sets the color space in which the color is defined.

Syntax

public void setMode(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setRed Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setRed Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets red value when the mode is RGB.

Valid range is 0..255.

Syntax

public void setRed(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setSwatchName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setSwatchName Method
value
ImGearXMPString class value.

Glossary Item Box

Sets name of the swatch.

Syntax

public void setSwatchName(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setType Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setType Method
value
ImGearXMPString class value.

Glossary Item Box

Sets the type of color, one of PROCESS or SPOT.

Syntax

public void setType(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

setYellow Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPColorant Class : setYellow Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets yellow value when the mode is CMYK.

Valid range is 0 ... 100.

Syntax

public void setYellow(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPColorant Class
ImGearXMPColorant Members


%%PageItemTitle%%

ImGearXMPDate Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDate Class

Glossary Item Box

Represents a Date XMP metadata type.

Object Model

ImGearXMPDate ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger Class

Syntax

public class ImGearXMPDate
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPDate

See Also

Reference

ImGearXMPDate Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPDate Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDate Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPDate.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPDate Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getDateTime | Gets the System.DateTime value.
public Method | getDay | Returns Day value. Valid range is 0..31.
public Method | getFraction | Returns fraction of a second value. The value must be positive.
public Method | getHour | Returns Hour value. Valid range is 0..23.
public Method | getMinute | Returns Minute value. Valid range is 0..59.
public Method | getMonth | Returns Month value. Valid range is 1..12.
public Method | getSecond | Returns Second value. Valid range is 0..59.
public Method | getYear | Returns Year value. Valid range is 0..9999.
public Method | getZoneOffsetHour | Returns Zone Offset Hour value. Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.
public Method | getZoneOffsetMinute | Returns Zone Offset Minute value. Valid range is 0..59.
public Method | setDay | Sets Day value. Valid range is 0..31.
public Method | setFraction | Sets fraction of a second value. The value must be positive.
public Method | setHour | Sets Hour value. Valid range is 0..23.
public Method | setMinute | Sets Minute value. Valid range is 0..59.
public Method | setMonth | Sets Month value. Valid range is 1..12.
public Method | setSecond | Sets Second value. Valid range is 0..59.
public Method | setYear | Sets Year value. Valid range is 0..9999.
public Method | setZoneOffsetHour | Sets Zone Offset Hour value. Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.
public Method | setZoneOffsetMinute | Sets Zone Offset Minute value. Valid range is 0..59.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPDate Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPDate Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : ImGearXMPDate Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPDate Constructor() | Initializes a new instance of the ImGearXMPDate class.
ImGearXMPDate Constructor(Date) | Initializes a new instance of the ImGearXMPDate class.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

ImGearXMPDate Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class > ImGearXMPDate Constructor : ImGearXMPDate Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPDate class.

Syntax

public ImGearXMPDate()

Return Value

New instance of the ImGearXMPDate class object.

This constructor creates an instance of the ImGearXMPDate class and initializes its members to default values.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members
Overload List


%%PageItemTitle%%

ImGearXMPDate Constructor(Date)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class > ImGearXMPDate Constructor : ImGearXMPDate Constructor(Date)
dateTime
Date and time.

Glossary Item Box

Initializes a new instance of the ImGearXMPDate class.

Syntax

public ImGearXMPDate(
   java.util.Date dateTime
)

Parameters

dateTime
Date and time.

Return Value

New instance of the ImGearXMPDate class object.

This constructor creates and initializes an instance of the ImGearXMPDate class from a System.DateTime value. If the kind of DateTime value is Unspecified, the time zone offset (hour and minute) of the ImGearXMPDate class instance are left uninitialized. If the kind of DateTime value is UTC, the time zone offset (hour and minute) ImGearXMPDate class instance are initialized with zeroes. If the kind of DateTime value is Local, the time zone offset (hour and minute) ImGearXMPDate class instance are initialized with local time zone offset.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPDate Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDate Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPDate members.

Public Methods

 | Name | Description
public Method | getDateTime | Gets the System.DateTime value.
public Method | getDay | Returns Day value. Valid range is 0..31.
public Method | getFraction | Returns fraction of a second value. The value must be positive.
public Method | getHour | Returns Hour value. Valid range is 0..23.
public Method | getMinute | Returns Minute value. Valid range is 0..59.
public Method | getMonth | Returns Month value. Valid range is 1..12.
public Method | getSecond | Returns Second value. Valid range is 0..59.
public Method | getYear | Returns Year value. Valid range is 0..9999.
public Method | getZoneOffsetHour | Returns Zone Offset Hour value. Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.
public Method | getZoneOffsetMinute | Returns Zone Offset Minute value. Valid range is 0..59.
public Method | setDay | Sets Day value. Valid range is 0..31.
public Method | setFraction | Sets fraction of a second value. The value must be positive.
public Method | setHour | Sets Hour value. Valid range is 0..23.
public Method | setMinute | Sets Minute value. Valid range is 0..59.
public Method | setMonth | Sets Month value. Valid range is 1..12.
public Method | setSecond | Sets Second value. Valid range is 0..59.
public Method | setYear | Sets Year value. Valid range is 0..9999.
public Method | setZoneOffsetHour | Sets Zone Offset Hour value. Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.
public Method | setZoneOffsetMinute | Sets Zone Offset Minute value. Valid range is 0..59.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPDate Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getDateTime Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getDateTime Method

Glossary Item Box

Gets the System.DateTime value.

Syntax

public java.util.Date getDateTime()

Return Value

System.DateTime value.

This method gets the System.DateTime value corresponding to the ImGearXMPDate class. If the XMP date does not contain time zone designator, the method returns an DateTime value of an unspecified kind. If the XMP date contains time zone designator, the method returns an DateTime value of UTC kind.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getDay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getDay Method

Glossary Item Box

Returns Day value.

Valid range is 0..31.

Syntax

public ImGearXMPInteger getDay()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getFraction Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getFraction Method

Glossary Item Box

Returns fraction of a second value.

The value must be positive.

Syntax

public ImGearXMPInteger getFraction()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getHour Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getHour Method

Glossary Item Box

Returns Hour value.

Valid range is 0..23.

Syntax

public ImGearXMPInteger getHour()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getMinute Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getMinute Method

Glossary Item Box

Returns Minute value.

Valid range is 0..59.

Syntax

public ImGearXMPInteger getMinute()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getMonth Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getMonth Method

Glossary Item Box

Returns Month value.

Valid range is 1..12.

Syntax

public ImGearXMPInteger getMonth()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getSecond Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getSecond Method

Glossary Item Box

Returns Second value.

Valid range is 0..59.

Syntax

public ImGearXMPInteger getSecond()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getYear Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getYear Method

Glossary Item Box

Returns Year value.

Valid range is 0..9999.

Syntax

public ImGearXMPInteger getYear()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getZoneOffsetHour Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getZoneOffsetHour Method

Glossary Item Box

Returns Zone Offset Hour value.

Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.

Syntax

public ImGearXMPInteger getZoneOffsetHour()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

getZoneOffsetMinute Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : getZoneOffsetMinute Method

Glossary Item Box

Returns Zone Offset Minute value.

Valid range is 0..59.

Syntax

public ImGearXMPInteger getZoneOffsetMinute()

Return Value

ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setDay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setDay Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Day value.

Valid range is 0..31.

Syntax

public void setDay(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setFraction Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setFraction Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets fraction of a second value.

The value must be positive.

Syntax

public void setFraction(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setHour Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setHour Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Hour value.

Valid range is 0..23.

Syntax

public void setHour(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setMinute Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setMinute Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Minute value.

Valid range is 0..59.

Syntax

public void setMinute(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setMonth Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setMonth Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Month value.

Valid range is 1..12.

Syntax

public void setMonth(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setSecond Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setSecond Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Second value.

Valid range is 0..59.

Syntax

public void setSecond(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setYear Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setYear Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Year value.

Valid range is 0..9999.

Syntax

public void setYear(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setZoneOffsetHour Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setZoneOffsetHour Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Zone Offset Hour value.

Represents the Hour value of the Time Zone Offset. Valid range is -23..23. Negative values correspond to local time which is behind the Universal Coordinated Time (UTC); Positive values correspond to local time which is ahead of the UTC.

Syntax

public void setZoneOffsetHour(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

setZoneOffsetMinute Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : setZoneOffsetMinute Method
value
ImGearXMPInteger class value.

Glossary Item Box

Sets Zone Offset Minute value.

Valid range is 0..59.

Syntax

public void setZoneOffsetMinute(
   ImGearXMPInteger value
)

Parameters

value
ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDate Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearXMPDate Class
ImGearXMPDate Members


%%PageItemTitle%%

ImGearXMPDimensions Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDimensions Class

Glossary Item Box

Represents an XMP Dimensions structure.

This structure contains dimensions of a drawn object.

See XMP specification for structure usage details.

Object Model

ImGearXMPDimensions ClassImGearXMPReal ClassImGearXMPString ClassImGearXMPReal Class

Syntax

public class ImGearXMPDimensions
    extends ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions

See Also

Reference

ImGearXMPDimensions Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPDimensions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDimensions Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPDimensions.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPDimensions Constructor | Initializes a new instance of the ImGearXMPDimensions class.
Top

Public Methods

 | Name | Description
public Method | getHeight | Returns height.
public Method | getUnit | Returns units. For example: inch, mm, pixel, pica, point.
public Method | getWidth | Returns width.
public Method | setHeight | Sets height.
public Method | setUnit | Sets units. For example: inch, mm, pixel, pica, point.
public Method | setWidth | Sets width.
Top

See Also

Reference

ImGearXMPDimensions Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPDimensions Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : ImGearXMPDimensions Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPDimensions class.

Syntax

public ImGearXMPDimensions()

Return Value

New instance of the ImGearXMPDimensions class object.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPDimensions Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPDimensions Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPDimensions members.

Public Methods

 | Name | Description
public Method | getHeight | Returns height.
public Method | getUnit | Returns units. For example: inch, mm, pixel, pica, point.
public Method | getWidth | Returns width.
public Method | setHeight | Sets height.
public Method | setUnit | Sets units. For example: inch, mm, pixel, pica, point.
public Method | setWidth | Sets width.
Top

See Also

Reference

ImGearXMPDimensions Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : getHeight Method

Glossary Item Box

Returns height.

Syntax

public ImGearXMPReal getHeight()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

getUnit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : getUnit Method

Glossary Item Box

Returns units.

For example: inch, mm, pixel, pica, point.

Syntax

public ImGearXMPString getUnit()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : getWidth Method

Glossary Item Box

Returns width.

Syntax

public ImGearXMPReal getWidth()

Return Value

ImGearXMPReal class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : setHeight Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets height.

Syntax

public void setHeight(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

setUnit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : setUnit Method
value
ImGearXMPString class value.

Glossary Item Box

Sets units.

For example: inch, mm, pixel, pica, point.

Syntax

public void setUnit(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPDimensions Class : setWidth Method
value
ImGearXMPReal class value.

Glossary Item Box

Sets width.

Syntax

public void setWidth(
   ImGearXMPReal value
)

Parameters

value
ImGearXMPReal class value.

See Also

Reference

ImGearXMPDimensions Class
ImGearXMPDimensions Members


%%PageItemTitle%%

T
ImGearXMPEnum<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPEnum<T> Class

Glossary Item Box

Represents an enumeration (closed choice of integer) XMP metadata value.

Object Model

ImGearXMPEnum<T> Class

Syntax

public class ImGearXMPEnum<T>
    extends ImGearXMPValue

Type Parameters

T

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T>

See Also

Reference

ImGearXMPEnum<T> Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPEnum<T> Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPEnum<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPEnum<T>.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPEnum<T> Constructor | Initializes a new instance of the ImGearXMPEnum<T> class.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets the enum value. Template value. This value gets the enumeration value of the ImGearXMPEnum<T> generic class object.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPEnum<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPEnum<T> Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPEnum<T> Class : ImGearXMPEnum<T> Constructor
value
Enum value.
clazz

Glossary Item Box

Initializes a new instance of the ImGearXMPEnum<T> class.

Syntax

public ImGearXMPEnum<T>(
   T value,
   java.lang.Class<T> clazz
)

Parameters

value
Enum value.
clazz

Return Value

New instance of the ImGearXMPEnum<T> generic class object.

This constructor creates and initializes an instance of ImGearXMPEnum<T> generic class by using an enumeration value.

See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPEnum<T> Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPEnum<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPEnum<T> members.

Public Methods

 | Name | Description
public Method | getValue | Gets the enum value. Template value. This value gets the enumeration value of the ImGearXMPEnum<T> generic class object.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPEnum<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPEnum<T> Class : getValue Method

Glossary Item Box

Gets the enum value.

Template value.

This value gets the enumeration value of the ImGearXMPEnum<T> generic class object.

Syntax

public T getValue()

See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPEnum<T> Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearXMPEnum<T> Class
ImGearXMPEnum<T> Members


%%PageItemTitle%%

ImGearXMPFont Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPFont Class

Glossary Item Box

Represents an XMP Font structure.

This structure contains the characteristics of a font used in a document.

See XMP specification for structure usage details.

Object Model

ImGearXMPFont ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPFont
    extends ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPFont

See Also

Reference

ImGearXMPFont Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPFont Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPFont Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPFont.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPFont Constructor | Initializes a new instance of the ImGearXMPFont class.
Top

Public Methods

 | Name | Description
public Method | getChildFontFiles | Returns list of file names for the fonts that make up a composite font.
public Method | getComposite | Returns a flag if composite font is specified.
public Method | getFontFace | Returns font face name.
public Method | getFontFamily | Returns font family name.
public Method | getFontFileName | Returns font file name (not a complete path).
public Method | getFontName | Returns postscript name of the font.
public Method | getFontType | Returns font type.
public Method | getVersionString | Returns version string.
public Method | setChildFontFiles | Sets list of file names for the fonts that make up a composite font.
public Method | setComposite | Sets a flag if composite font is specified.
public Method | setFontFace | Sets font face name.
public Method | setFontFamily | Sets font family name.
public Method | setFontFileName | Sets font file name (not a complete path).
public Method | setFontName | Sets postscript name of the font.
public Method | setFontType | Sets font type.
public Method | setVersionString | Sets version string.
Top

See Also

Reference

ImGearXMPFont Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPFont Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : ImGearXMPFont Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPFont class.

Syntax

public ImGearXMPFont()

Return Value

New instance of the ImGearXMPFont class object.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPFont Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPFont Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPFont members.

Public Methods

 | Name | Description
public Method | getChildFontFiles | Returns list of file names for the fonts that make up a composite font.
public Method | getComposite | Returns a flag if composite font is specified.
public Method | getFontFace | Returns font face name.
public Method | getFontFamily | Returns font family name.
public Method | getFontFileName | Returns font file name (not a complete path).
public Method | getFontName | Returns postscript name of the font.
public Method | getFontType | Returns font type.
public Method | getVersionString | Returns version string.
public Method | setChildFontFiles | Sets list of file names for the fonts that make up a composite font.
public Method | setComposite | Sets a flag if composite font is specified.
public Method | setFontFace | Sets font face name.
public Method | setFontFamily | Sets font family name.
public Method | setFontFileName | Sets font file name (not a complete path).
public Method | setFontName | Sets postscript name of the font.
public Method | setFontType | Sets font type.
public Method | setVersionString | Sets version string.
Top

See Also

Reference

ImGearXMPFont Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getChildFontFiles Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getChildFontFiles Method

Glossary Item Box

Returns list of file names for the fonts that make up a composite font.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getChildFontFiles()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getComposite Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getComposite Method

Glossary Item Box

Returns a flag if composite font is specified.

Syntax

public ImGearXMPBoolean getComposite()

Return Value

ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getFontFace Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getFontFace Method

Glossary Item Box

Returns font face name.

Syntax

public ImGearXMPString getFontFace()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getFontFamily Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getFontFamily Method

Glossary Item Box

Returns font family name.

Syntax

public ImGearXMPString getFontFamily()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getFontFileName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getFontFileName Method

Glossary Item Box

Returns font file name (not a complete path).

Syntax

public ImGearXMPString getFontFileName()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getFontName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getFontName Method

Glossary Item Box

Returns postscript name of the font.

Syntax

public ImGearXMPString getFontName()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getFontType Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getFontType Method

Glossary Item Box

Returns font type.

Syntax

public ImGearXMPString getFontType()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

getVersionString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : getVersionString Method

Glossary Item Box

Returns version string.

Syntax

public ImGearXMPString getVersionString()

Return Value

ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setChildFontFiles Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setChildFontFiles Method
value
ImGearXMPString class value.

Glossary Item Box

Sets list of file names for the fonts that make up a composite font.

Syntax

public void setChildFontFiles(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setComposite Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setComposite Method
value
ImGearXMPBoolean class value.

Glossary Item Box

Sets a flag if composite font is specified.

Syntax

public void setComposite(
   ImGearXMPBoolean value
)

Parameters

value
ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setFontFace Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setFontFace Method
value
ImGearXMPString class value.

Glossary Item Box

Sets font face name.

Syntax

public void setFontFace(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setFontFamily Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setFontFamily Method
value
ImGearXMPString class value.

Glossary Item Box

Sets font family name.

Syntax

public void setFontFamily(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setFontFileName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setFontFileName Method
value
ImGearXMPString class value.

Glossary Item Box

Sets font file name (not a complete path).

Syntax

public void setFontFileName(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setFontName Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setFontName Method
value
ImGearXMPString class value.

Glossary Item Box

Sets postscript name of the font.

Syntax

public void setFontName(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setFontType Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setFontType Method
value
ImGearXMPString class value.

Glossary Item Box

Sets font type.

Syntax

public void setFontType(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

setVersionString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPFont Class : setVersionString Method
value
ImGearXMPString class value.

Glossary Item Box

Sets version string.

Syntax

public void setVersionString(
   ImGearXMPString value
)

Parameters

value
ImGearXMPString class value.

See Also

Reference

ImGearXMPFont Class
ImGearXMPFont Members


%%PageItemTitle%%

ImGearXMPFormatMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPFormatMetadata Class

Glossary Item Box

The base for XMP schema accessor classes.

This class serves as the base for XMP schema accessor classes.

Object Model

ImGearXMPFormatMetadata Class

Syntax

public abstract class ImGearXMPFormatMetadata
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata
com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata
com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata
com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata
com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata
com.accusoft.imagegear.formats.xmp.microsoftphoto.ImGearMicrosoftPhotoXMPMetadata
com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata
com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata
com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata
com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata

See Also

Reference

ImGearXMPFormatMetadata Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPFormatMetadata Class Members
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPFormatMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPFormatMetadata.

See Also

Reference

ImGearXMPFormatMetadata Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPInteger Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPInteger Class

Glossary Item Box

Represents an integer XMP metadata value.

Object Model

ImGearXMPInteger Class

Syntax

public class ImGearXMPInteger
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger

See Also

Reference

ImGearXMPInteger Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPInteger Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPInteger Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPInteger.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPInteger Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets the integer value. Integer value. This method gets the integer value of the ImGearXMPInteger class object.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPInteger Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPInteger Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPInteger Class : ImGearXMPInteger Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPInteger Constructor() | Initializes a new instance of the ImGearXMPInteger class.
ImGearXMPInteger Constructor(int) | Initializes a new instance of the ImGearXMPInteger class.

See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%%

ImGearXMPInteger Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPInteger Class > ImGearXMPInteger Constructor : ImGearXMPInteger Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPInteger class.

Syntax

public ImGearXMPInteger()

Return Value

New instance of the ImGearXMPInteger class object.

See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members
Overload List


%%PageItemTitle%%

ImGearXMPInteger Constructor(int)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPInteger Class > ImGearXMPInteger Constructor : ImGearXMPInteger Constructor(int)
value
Integer value.

Glossary Item Box

Initializes a new instance of the ImGearXMPInteger class.

Syntax

public ImGearXMPInteger(
   int value
)

Parameters

value
Integer value.

Return Value

New instance of the ImGearXMPInteger class object.

This constructor creates and initializes an instance of ImGearXMPInteger class by using an integer value.

See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPInteger Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPInteger Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPInteger members.

Public Methods

 | Name | Description
public Method | getValue | Gets the integer value. Integer value. This method gets the integer value of the ImGearXMPInteger class object.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPInteger Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPInteger Class : getValue Method

Glossary Item Box

Gets the integer value.

Integer value.

This method gets the integer value of the ImGearXMPInteger class object.

Syntax

public int getValue()

See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPInteger Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearXMPInteger Class
ImGearXMPInteger Members


%%PageItemTitle%%

ImGearXMPLangAlt Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPLangAlt Class

Glossary Item Box

Represents a language alternative.

This class represents a language alternative. It contains the same logical text in multiple languages. The text in each specific language is available through properties of the ImGearXMPLangAlt object. If text in a specific language is does not exist in the object, corresponding method returns null. ImGearXMPLangAlt.getDefault() method represents the default value for the language alternative.

Object Model

ImGearXMPLangAlt Class

Syntax

public class ImGearXMPLangAlt
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt

See Also

Reference

ImGearXMPLangAlt Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPLangAlt Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPLangAlt Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPLangAlt.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPLangAlt Constructor | Initializes a new instance of the ImGearXMPLangAlt class.
Top

Public Methods

 | Name | Description
public Method | getAfrikaans | Returns Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAlbanian | Returns Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicAlgeria | Returns Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicBahrain | Returns Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicEgypt | Returns Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicIraq | Returns Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicJordan | Returns Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicKuwait | Returns Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicLebanon | Returns Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicLibya | Returns Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicMorocco | Returns Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicOman | Returns Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicQatar | Returns Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicSaudiArabia | Returns Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicSyria | Returns Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicTunisia | Returns Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicUnitedArabEmirates | Returns Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicYemen | Returns Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArmenian | Returns Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAzeriCyrillic | Returns Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAzeriLatin | Returns Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBasque | Returns Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBelarusian | Returns Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBulgarian | Returns Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCatalan | Returns Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseChina | Returns Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseHongKongSAR | Returns Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseMacauSAR | Returns Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseSingapore | Returns Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseTaiwan | Returns Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCroatian | Returns Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCzech | Returns Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDanish | Returns Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDefault | Returns default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDutchBelgium | Returns Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDutchNetherlands | Returns Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishAustralia | Returns English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishBelize | Returns English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishCanada | Returns English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishCaribbean | Returns English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishIreland | Returns English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishJamaica | Returns English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishNewZealand | Returns English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishPhillippines | Returns English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishSouthAfrica | Returns English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishTrinidad | Returns English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishUnitedKingdom | Returns English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishUnitedStates | Returns English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEstonian | Returns Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFaroese | Returns Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFarsi | Returns Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFinnish | Returns Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchBelgium | Returns French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchCanada | Returns French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchFrance | Returns French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchLuxembourg | Returns French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchSwitzerland | Returns French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGaelicIreland | Returns Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGaelicScotland | Returns Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanAustria | Returns German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanGermany | Returns German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanLiechtenstein | Returns German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanLuxembourg | Returns German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanSwitzerland | Returns German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGreek | Returns Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHebrew | Returns Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHindi | Returns Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHungarian | Returns Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getIcelandic | Returns Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getIndonesian | Returns Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getItalianItaly | Returns Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getItalianSwitzerland | Returns Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getJapanese | Returns Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getKorean | Returns Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getLatvian | Returns Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getLithuanian | Returns Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMacedonianFYROM | Returns Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMalayBrunei | Returns Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMalayMalaysia | Returns Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMaltese | Returns Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMarathi | Returns Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getNorwegianBokml | Returns Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getNorwegianNynorsk | Returns Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPolish | Returns Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPortugueseBrazil | Returns Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPortuguesePortugal | Returns Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRaetoRomance | Returns Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRomanianMoldova | Returns Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRomanianRomania | Returns Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRussian | Returns Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRussianMoldova | Returns Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSanskrit | Returns Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSerbianCyrillic | Returns Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSerbianLatin | Returns Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSetsuana | Returns Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSlovak | Returns Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSlovenian | Returns Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSorbian | Returns Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSouthernSotho | Returns Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishArgentina | Returns Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishBolivia | Returns Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishChile | Returns Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishColombia | Returns Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishCosta | Returns Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishDominican | Returns Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishEcuador | Returns Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishElSalvador | Returns Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishGuatemala | Returns Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishHonduras | Returns Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishMexico | Returns Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishNicaragua | Returns Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPanama | Returns Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishParaguay | Returns Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPeru | Returns Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPuertoRico | Returns Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishSpain | Returns Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishUruguay | Returns Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishVenezuela | Returns Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwahili | Returns Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwedishFinland | Returns Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwedishSweden | Returns Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTamil | Returns Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTatar | Returns Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getThai | Returns Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTsonga | Returns Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTurkish | Returns Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUkrainian | Returns Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUrdu | Returns Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUzbekCyrillic | Returns Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUzbekLatin | Returns Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getVietnamese | Returns Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getXhosa | Returns Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getYiddish | Returns Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getZulu | Returns Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAfrikaans | Sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAlbanian | Sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicAlgeria | Sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicBahrain | Sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicEgypt | Sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicIraq | Sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicJordan | Sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicKuwait | Sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicLebanon | Sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicLibya | Sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicMorocco | Sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicOman | Sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicQatar | Sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicSaudiArabia | Sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicSyria | Sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicTunisia | Sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicUnitedArabEmirates | Sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicYemen | Sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArmenian | Sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAzeriCyrillic | Sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAzeriLatin | Sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBasque | Sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBelarusian | Sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBulgarian | Sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCatalan | Sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseChina | Sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseHongKongSAR | Sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseMacauSAR | Sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseSingapore | Sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseTaiwan | Sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCroatian | Sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCzech | Sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDanish | Sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDefault | Sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDutchBelgium | Sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDutchNetherlands | Sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishAustralia | Sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishBelize | Sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishCanada | Sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishCaribbean | Sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishIreland | Sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishJamaica | Sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishNewZealand | Sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishPhillippines | Sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishSouthAfrica | Sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishTrinidad | Sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishUnitedKingdom | Sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishUnitedStates | Sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEstonian | Sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFaroese | Sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFarsi | Sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFinnish | Sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchBelgium | Sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchCanada | Sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchFrance | Sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchLuxembourg | Sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchSwitzerland | Sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGaelicIreland | Sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGaelicScotland | Sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanAustria | Sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanGermany | Sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanLiechtenstein | Sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanLuxembourg | Sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanSwitzerland | Sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGreek | Sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHebrew | Sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHindi | Sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHungarian | Sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setIcelandic | Sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setIndonesian | Sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setItalianItaly | Sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setItalianSwitzerland | Sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setJapanese | Sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setKorean | Sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setLatvian | Sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setLithuanian | Sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMacedonianFYROM | Sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMalayBrunei | Sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMalayMalaysia | Sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMaltese | Sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMarathi | Sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setNorwegianBokml | Sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setNorwegianNynorsk | Sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPolish | Sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPortugueseBrazil | Sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPortuguesePortugal | Sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRaetoRomance | Sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRomanianMoldova | Sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRomanianRomania | Sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRussian | Sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRussianMoldova | Sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSanskrit | Sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSerbianCyrillic | Sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSerbianLatin | Sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSetsuana | Sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSlovak | Sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSlovenian | Sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSorbian | Sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSouthernSotho | Sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishArgentina | Sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishBolivia | Sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishChile | Sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishColombia | Sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishCosta | Sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishDominican | Sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishEcuador | Sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishElSalvador | Sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishGuatemala | Sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishHonduras | Sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishMexico | Sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishNicaragua | Sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPanama | Sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishParaguay | Sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPeru | Sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPuertoRico | Sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishSpain | Sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishUruguay | Sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishVenezuela | Sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwahili | Sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwedishFinland | Sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwedishSweden | Sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTamil | Sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTatar | Sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setThai | Sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTsonga | Sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTurkish | Sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUkrainian | Sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUrdu | Sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUzbekCyrillic | Sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUzbekLatin | Sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setVietnamese | Sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setXhosa | Sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setYiddish | Sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setZulu | Sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Top

See Also

Reference

ImGearXMPLangAlt Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPLangAlt Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : ImGearXMPLangAlt Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPLangAlt class.

Syntax

public ImGearXMPLangAlt()

Return Value

New instance of ImGearXMPLangAlt class object.

This constructor creates an empty instance of ImGearXMPLangAlt class. Use properties of the class to add language alternatives to the new object.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPLangAlt Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPLangAlt Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPLangAlt members.

Public Methods

 | Name | Description
public Method | getAfrikaans | Returns Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAlbanian | Returns Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicAlgeria | Returns Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicBahrain | Returns Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicEgypt | Returns Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicIraq | Returns Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicJordan | Returns Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicKuwait | Returns Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicLebanon | Returns Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicLibya | Returns Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicMorocco | Returns Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicOman | Returns Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicQatar | Returns Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicSaudiArabia | Returns Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicSyria | Returns Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicTunisia | Returns Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicUnitedArabEmirates | Returns Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArabicYemen | Returns Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getArmenian | Returns Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAzeriCyrillic | Returns Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getAzeriLatin | Returns Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBasque | Returns Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBelarusian | Returns Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getBulgarian | Returns Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCatalan | Returns Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseChina | Returns Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseHongKongSAR | Returns Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseMacauSAR | Returns Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseSingapore | Returns Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getChineseTaiwan | Returns Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCroatian | Returns Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getCzech | Returns Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDanish | Returns Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDefault | Returns default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDutchBelgium | Returns Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getDutchNetherlands | Returns Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishAustralia | Returns English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishBelize | Returns English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishCanada | Returns English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishCaribbean | Returns English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishIreland | Returns English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishJamaica | Returns English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishNewZealand | Returns English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishPhillippines | Returns English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishSouthAfrica | Returns English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishTrinidad | Returns English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishUnitedKingdom | Returns English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEnglishUnitedStates | Returns English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getEstonian | Returns Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFaroese | Returns Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFarsi | Returns Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFinnish | Returns Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchBelgium | Returns French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchCanada | Returns French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchFrance | Returns French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchLuxembourg | Returns French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getFrenchSwitzerland | Returns French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGaelicIreland | Returns Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGaelicScotland | Returns Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanAustria | Returns German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanGermany | Returns German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanLiechtenstein | Returns German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanLuxembourg | Returns German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGermanSwitzerland | Returns German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getGreek | Returns Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHebrew | Returns Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHindi | Returns Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getHungarian | Returns Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getIcelandic | Returns Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getIndonesian | Returns Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getItalianItaly | Returns Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getItalianSwitzerland | Returns Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getJapanese | Returns Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getKorean | Returns Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getLatvian | Returns Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getLithuanian | Returns Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMacedonianFYROM | Returns Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMalayBrunei | Returns Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMalayMalaysia | Returns Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMaltese | Returns Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getMarathi | Returns Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getNorwegianBokml | Returns Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getNorwegianNynorsk | Returns Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPolish | Returns Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPortugueseBrazil | Returns Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getPortuguesePortugal | Returns Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRaetoRomance | Returns Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRomanianMoldova | Returns Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRomanianRomania | Returns Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRussian | Returns Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getRussianMoldova | Returns Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSanskrit | Returns Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSerbianCyrillic | Returns Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSerbianLatin | Returns Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSetsuana | Returns Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSlovak | Returns Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSlovenian | Returns Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSorbian | Returns Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSouthernSotho | Returns Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishArgentina | Returns Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishBolivia | Returns Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishChile | Returns Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishColombia | Returns Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishCosta | Returns Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishDominican | Returns Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishEcuador | Returns Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishElSalvador | Returns Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishGuatemala | Returns Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishHonduras | Returns Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishMexico | Returns Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishNicaragua | Returns Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPanama | Returns Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishParaguay | Returns Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPeru | Returns Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishPuertoRico | Returns Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishSpain | Returns Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishUruguay | Returns Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSpanishVenezuela | Returns Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwahili | Returns Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwedishFinland | Returns Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getSwedishSweden | Returns Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTamil | Returns Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTatar | Returns Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getThai | Returns Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTsonga | Returns Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getTurkish | Returns Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUkrainian | Returns Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUrdu | Returns Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUzbekCyrillic | Returns Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getUzbekLatin | Returns Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getVietnamese | Returns Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getXhosa | Returns Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getYiddish | Returns Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | getZulu | Returns Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAfrikaans | Sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAlbanian | Sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicAlgeria | Sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicBahrain | Sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicEgypt | Sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicIraq | Sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicJordan | Sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicKuwait | Sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicLebanon | Sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicLibya | Sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicMorocco | Sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicOman | Sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicQatar | Sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicSaudiArabia | Sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicSyria | Sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicTunisia | Sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicUnitedArabEmirates | Sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArabicYemen | Sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setArmenian | Sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAzeriCyrillic | Sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setAzeriLatin | Sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBasque | Sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBelarusian | Sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setBulgarian | Sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCatalan | Sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseChina | Sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseHongKongSAR | Sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseMacauSAR | Sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseSingapore | Sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setChineseTaiwan | Sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCroatian | Sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setCzech | Sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDanish | Sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDefault | Sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDutchBelgium | Sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setDutchNetherlands | Sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishAustralia | Sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishBelize | Sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishCanada | Sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishCaribbean | Sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishIreland | Sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishJamaica | Sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishNewZealand | Sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishPhillippines | Sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishSouthAfrica | Sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishTrinidad | Sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishUnitedKingdom | Sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEnglishUnitedStates | Sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setEstonian | Sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFaroese | Sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFarsi | Sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFinnish | Sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchBelgium | Sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchCanada | Sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchFrance | Sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchLuxembourg | Sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setFrenchSwitzerland | Sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGaelicIreland | Sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGaelicScotland | Sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanAustria | Sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanGermany | Sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanLiechtenstein | Sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanLuxembourg | Sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGermanSwitzerland | Sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setGreek | Sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHebrew | Sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHindi | Sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setHungarian | Sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setIcelandic | Sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setIndonesian | Sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setItalianItaly | Sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setItalianSwitzerland | Sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setJapanese | Sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setKorean | Sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setLatvian | Sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setLithuanian | Sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMacedonianFYROM | Sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMalayBrunei | Sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMalayMalaysia | Sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMaltese | Sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setMarathi | Sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setNorwegianBokml | Sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setNorwegianNynorsk | Sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPolish | Sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPortugueseBrazil | Sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setPortuguesePortugal | Sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRaetoRomance | Sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRomanianMoldova | Sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRomanianRomania | Sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRussian | Sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setRussianMoldova | Sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSanskrit | Sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSerbianCyrillic | Sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSerbianLatin | Sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSetsuana | Sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSlovak | Sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSlovenian | Sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSorbian | Sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSouthernSotho | Sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishArgentina | Sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishBolivia | Sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishChile | Sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishColombia | Sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishCosta | Sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishDominican | Sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishEcuador | Sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishElSalvador | Sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishGuatemala | Sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishHonduras | Sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishMexico | Sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishNicaragua | Sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPanama | Sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishParaguay | Sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPeru | Sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishPuertoRico | Sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishSpain | Sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishUruguay | Sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSpanishVenezuela | Sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwahili | Sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwedishFinland | Sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setSwedishSweden | Sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTamil | Sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTatar | Sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setThai | Sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTsonga | Sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setTurkish | Sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUkrainian | Sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUrdu | Sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUzbekCyrillic | Sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setUzbekLatin | Sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setVietnamese | Sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setXhosa | Sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setYiddish | Sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
public Method | setZulu | Sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.
Top

See Also

Reference

ImGearXMPLangAlt Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getAfrikaans Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getAfrikaans Method

Glossary Item Box

Returns Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getAfrikaans()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getAlbanian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getAlbanian Method

Glossary Item Box

Returns Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getAlbanian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicAlgeria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicAlgeria Method

Glossary Item Box

Returns Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicAlgeria()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicBahrain Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicBahrain Method

Glossary Item Box

Returns Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicBahrain()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicEgypt Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicEgypt Method

Glossary Item Box

Returns Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicEgypt()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicIraq Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicIraq Method

Glossary Item Box

Returns Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicIraq()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicJordan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicJordan Method

Glossary Item Box

Returns Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicJordan()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicKuwait Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicKuwait Method

Glossary Item Box

Returns Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicKuwait()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicLebanon Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicLebanon Method

Glossary Item Box

Returns Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicLebanon()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicLibya Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicLibya Method

Glossary Item Box

Returns Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicLibya()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicMorocco Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicMorocco Method

Glossary Item Box

Returns Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicMorocco()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicOman Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicOman Method

Glossary Item Box

Returns Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicOman()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicQatar Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicQatar Method

Glossary Item Box

Returns Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicQatar()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicSaudiArabia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicSaudiArabia Method

Glossary Item Box

Returns Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicSaudiArabia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicSyria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicSyria Method

Glossary Item Box

Returns Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicSyria()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicTunisia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicTunisia Method

Glossary Item Box

Returns Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicTunisia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicUnitedArabEmirates Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicUnitedArabEmirates Method

Glossary Item Box

Returns Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicUnitedArabEmirates()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArabicYemen Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArabicYemen Method

Glossary Item Box

Returns Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArabicYemen()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getArmenian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getArmenian Method

Glossary Item Box

Returns Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getArmenian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getAzeriCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getAzeriCyrillic Method

Glossary Item Box

Returns Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getAzeriCyrillic()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getAzeriLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getAzeriLatin Method

Glossary Item Box

Returns Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getAzeriLatin()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getBasque Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getBasque Method

Glossary Item Box

Returns Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getBasque()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getBelarusian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getBelarusian Method

Glossary Item Box

Returns Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getBelarusian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getBulgarian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getBulgarian Method

Glossary Item Box

Returns Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getBulgarian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getCatalan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getCatalan Method

Glossary Item Box

Returns Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getCatalan()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getChineseChina Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getChineseChina Method

Glossary Item Box

Returns Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getChineseChina()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getChineseHongKongSAR Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getChineseHongKongSAR Method

Glossary Item Box

Returns Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getChineseHongKongSAR()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getChineseMacauSAR Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getChineseMacauSAR Method

Glossary Item Box

Returns Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getChineseMacauSAR()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getChineseSingapore Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getChineseSingapore Method

Glossary Item Box

Returns Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getChineseSingapore()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getChineseTaiwan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getChineseTaiwan Method

Glossary Item Box

Returns Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getChineseTaiwan()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getCroatian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getCroatian Method

Glossary Item Box

Returns Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getCroatian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getCzech Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getCzech Method

Glossary Item Box

Returns Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getCzech()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getDanish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getDanish Method

Glossary Item Box

Returns Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getDanish()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getDefault Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getDefault Method

Glossary Item Box

Returns default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getDefault()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getDutchBelgium Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getDutchBelgium Method

Glossary Item Box

Returns Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getDutchBelgium()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getDutchNetherlands Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getDutchNetherlands Method

Glossary Item Box

Returns Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getDutchNetherlands()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishAustralia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishAustralia Method

Glossary Item Box

Returns English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishAustralia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishBelize Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishBelize Method

Glossary Item Box

Returns English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishBelize()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishCanada Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishCanada Method

Glossary Item Box

Returns English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishCanada()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishCaribbean Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishCaribbean Method

Glossary Item Box

Returns English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishCaribbean()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishIreland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishIreland Method

Glossary Item Box

Returns English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishIreland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishJamaica Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishJamaica Method

Glossary Item Box

Returns English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishJamaica()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishNewZealand Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishNewZealand Method

Glossary Item Box

Returns English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishNewZealand()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishPhillippines Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishPhillippines Method

Glossary Item Box

Returns English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishPhillippines()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishSouthAfrica Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishSouthAfrica Method

Glossary Item Box

Returns English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishSouthAfrica()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishTrinidad Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishTrinidad Method

Glossary Item Box

Returns English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishTrinidad()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishUnitedKingdom Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishUnitedKingdom Method

Glossary Item Box

Returns English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishUnitedKingdom()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEnglishUnitedStates Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEnglishUnitedStates Method

Glossary Item Box

Returns English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEnglishUnitedStates()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getEstonian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getEstonian Method

Glossary Item Box

Returns Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getEstonian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFaroese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFaroese Method

Glossary Item Box

Returns Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFaroese()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFarsi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFarsi Method

Glossary Item Box

Returns Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFarsi()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFinnish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFinnish Method

Glossary Item Box

Returns Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFinnish()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFrenchBelgium Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFrenchBelgium Method

Glossary Item Box

Returns French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFrenchBelgium()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFrenchCanada Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFrenchCanada Method

Glossary Item Box

Returns French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFrenchCanada()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFrenchFrance Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFrenchFrance Method

Glossary Item Box

Returns French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFrenchFrance()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFrenchLuxembourg Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFrenchLuxembourg Method

Glossary Item Box

Returns French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFrenchLuxembourg()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getFrenchSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getFrenchSwitzerland Method

Glossary Item Box

Returns French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getFrenchSwitzerland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGaelicIreland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGaelicIreland Method

Glossary Item Box

Returns Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGaelicIreland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGaelicScotland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGaelicScotland Method

Glossary Item Box

Returns Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGaelicScotland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGermanAustria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGermanAustria Method

Glossary Item Box

Returns German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGermanAustria()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGermanGermany Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGermanGermany Method

Glossary Item Box

Returns German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGermanGermany()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGermanLiechtenstein Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGermanLiechtenstein Method

Glossary Item Box

Returns German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGermanLiechtenstein()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGermanLuxembourg Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGermanLuxembourg Method

Glossary Item Box

Returns German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGermanLuxembourg()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGermanSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGermanSwitzerland Method

Glossary Item Box

Returns German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGermanSwitzerland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getGreek Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getGreek Method

Glossary Item Box

Returns Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getGreek()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getHebrew Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getHebrew Method

Glossary Item Box

Returns Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getHebrew()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getHindi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getHindi Method

Glossary Item Box

Returns Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getHindi()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getHungarian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getHungarian Method

Glossary Item Box

Returns Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getHungarian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getIcelandic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getIcelandic Method

Glossary Item Box

Returns Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getIcelandic()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getIndonesian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getIndonesian Method

Glossary Item Box

Returns Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getIndonesian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getItalianItaly Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getItalianItaly Method

Glossary Item Box

Returns Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getItalianItaly()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getItalianSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getItalianSwitzerland Method

Glossary Item Box

Returns Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getItalianSwitzerland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getJapanese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getJapanese Method

Glossary Item Box

Returns Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getJapanese()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getKorean Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getKorean Method

Glossary Item Box

Returns Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getKorean()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getLatvian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getLatvian Method

Glossary Item Box

Returns Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getLatvian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getLithuanian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getLithuanian Method

Glossary Item Box

Returns Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getLithuanian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getMacedonianFYROM Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getMacedonianFYROM Method

Glossary Item Box

Returns Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getMacedonianFYROM()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getMalayBrunei Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getMalayBrunei Method

Glossary Item Box

Returns Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getMalayBrunei()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getMalayMalaysia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getMalayMalaysia Method

Glossary Item Box

Returns Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getMalayMalaysia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getMaltese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getMaltese Method

Glossary Item Box

Returns Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getMaltese()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getMarathi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getMarathi Method

Glossary Item Box

Returns Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getMarathi()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getNorwegianBokml Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getNorwegianBokml Method

Glossary Item Box

Returns Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getNorwegianBokml()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getNorwegianNynorsk Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getNorwegianNynorsk Method

Glossary Item Box

Returns Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getNorwegianNynorsk()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getPolish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getPolish Method

Glossary Item Box

Returns Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getPolish()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getPortugueseBrazil Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getPortugueseBrazil Method

Glossary Item Box

Returns Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getPortugueseBrazil()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getPortuguesePortugal Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getPortuguesePortugal Method

Glossary Item Box

Returns Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getPortuguesePortugal()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getRaetoRomance Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getRaetoRomance Method

Glossary Item Box

Returns Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getRaetoRomance()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getRomanianMoldova Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getRomanianMoldova Method

Glossary Item Box

Returns Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getRomanianMoldova()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getRomanianRomania Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getRomanianRomania Method

Glossary Item Box

Returns Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getRomanianRomania()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getRussian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getRussian Method

Glossary Item Box

Returns Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getRussian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getRussianMoldova Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getRussianMoldova Method

Glossary Item Box

Returns Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getRussianMoldova()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSanskrit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSanskrit Method

Glossary Item Box

Returns Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSanskrit()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSerbianCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSerbianCyrillic Method

Glossary Item Box

Returns Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSerbianCyrillic()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSerbianLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSerbianLatin Method

Glossary Item Box

Returns Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSerbianLatin()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSetsuana Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSetsuana Method

Glossary Item Box

Returns Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSetsuana()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSlovak Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSlovak Method

Glossary Item Box

Returns Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSlovak()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSlovenian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSlovenian Method

Glossary Item Box

Returns Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSlovenian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSorbian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSorbian Method

Glossary Item Box

Returns Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSorbian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSouthernSotho Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSouthernSotho Method

Glossary Item Box

Returns Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSouthernSotho()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishArgentina Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishArgentina Method

Glossary Item Box

Returns Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishArgentina()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishBolivia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishBolivia Method

Glossary Item Box

Returns Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishBolivia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishChile Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishChile Method

Glossary Item Box

Returns Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishChile()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishColombia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishColombia Method

Glossary Item Box

Returns Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishColombia()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishCosta Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishCosta Method

Glossary Item Box

Returns Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishCosta()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishDominican Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishDominican Method

Glossary Item Box

Returns Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishDominican()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishEcuador Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishEcuador Method

Glossary Item Box

Returns Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishEcuador()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishElSalvador Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishElSalvador Method

Glossary Item Box

Returns Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishElSalvador()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishGuatemala Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishGuatemala Method

Glossary Item Box

Returns Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishGuatemala()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishHonduras Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishHonduras Method

Glossary Item Box

Returns Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishHonduras()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishMexico Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishMexico Method

Glossary Item Box

Returns Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishMexico()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishNicaragua Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishNicaragua Method

Glossary Item Box

Returns Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishNicaragua()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishPanama Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishPanama Method

Glossary Item Box

Returns Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishPanama()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishParaguay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishParaguay Method

Glossary Item Box

Returns Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishParaguay()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishPeru Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishPeru Method

Glossary Item Box

Returns Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishPeru()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishPuertoRico Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishPuertoRico Method

Glossary Item Box

Returns Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishPuertoRico()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishSpain Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishSpain Method

Glossary Item Box

Returns Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishSpain()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishUruguay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishUruguay Method

Glossary Item Box

Returns Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishUruguay()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSpanishVenezuela Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSpanishVenezuela Method

Glossary Item Box

Returns Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSpanishVenezuela()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSwahili Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSwahili Method

Glossary Item Box

Returns Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSwahili()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSwedishFinland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSwedishFinland Method

Glossary Item Box

Returns Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSwedishFinland()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getSwedishSweden Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getSwedishSweden Method

Glossary Item Box

Returns Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getSwedishSweden()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getTamil Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getTamil Method

Glossary Item Box

Returns Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getTamil()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getTatar Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getTatar Method

Glossary Item Box

Returns Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getTatar()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getThai Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getThai Method

Glossary Item Box

Returns Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getThai()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getTsonga Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getTsonga Method

Glossary Item Box

Returns Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getTsonga()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getTurkish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getTurkish Method

Glossary Item Box

Returns Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getTurkish()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getUkrainian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getUkrainian Method

Glossary Item Box

Returns Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getUkrainian()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getUrdu Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getUrdu Method

Glossary Item Box

Returns Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getUrdu()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getUzbekCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getUzbekCyrillic Method

Glossary Item Box

Returns Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getUzbekCyrillic()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getUzbekLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getUzbekLatin Method

Glossary Item Box

Returns Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getUzbekLatin()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getVietnamese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getVietnamese Method

Glossary Item Box

Returns Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getVietnamese()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getXhosa Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getXhosa Method

Glossary Item Box

Returns Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getXhosa()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getYiddish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getYiddish Method

Glossary Item Box

Returns Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getYiddish()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

getZulu Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : getZulu Method

Glossary Item Box

Returns Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public java.lang.String getZulu()

Return Value

String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setAfrikaans Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setAfrikaans Method
value
String value.

Glossary Item Box

Sets Afrikaans text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setAfrikaans(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setAlbanian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setAlbanian Method
value
String value.

Glossary Item Box

Sets Albanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setAlbanian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicAlgeria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicAlgeria Method
value
String value.

Glossary Item Box

Sets Arabic - Algeria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicAlgeria(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicBahrain Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicBahrain Method
value
String value.

Glossary Item Box

Sets Arabic - Bahrain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicBahrain(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicEgypt Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicEgypt Method
value
String value.

Glossary Item Box

Sets Arabic - Egypt text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicEgypt(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicIraq Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicIraq Method
value
String value.

Glossary Item Box

Sets Arabic - Iraq text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicIraq(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicJordan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicJordan Method
value
String value.

Glossary Item Box

Sets Arabic - Jordan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicJordan(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicKuwait Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicKuwait Method
value
String value.

Glossary Item Box

Sets Arabic - Kuwait text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicKuwait(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicLebanon Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicLebanon Method
value
String value.

Glossary Item Box

Sets Arabic - Lebanon text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicLebanon(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicLibya Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicLibya Method
value
String value.

Glossary Item Box

Sets Arabic - Libya text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicLibya(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicMorocco Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicMorocco Method
value
String value.

Glossary Item Box

Sets Arabic - Morocco text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicMorocco(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicOman Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicOman Method
value
String value.

Glossary Item Box

Sets Arabic - Oman text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicOman(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicQatar Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicQatar Method
value
String value.

Glossary Item Box

Sets Arabic - Qatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicQatar(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicSaudiArabia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicSaudiArabia Method
value
String value.

Glossary Item Box

Sets Arabic - Saudi Arabia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicSaudiArabia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicSyria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicSyria Method
value
String value.

Glossary Item Box

Sets Arabic - Syria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicSyria(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicTunisia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicTunisia Method
value
String value.

Glossary Item Box

Sets Arabic - Tunisia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicTunisia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicUnitedArabEmirates Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicUnitedArabEmirates Method
value
String value.

Glossary Item Box

Sets Arabic - United Arab Emirates text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicUnitedArabEmirates(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArabicYemen Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArabicYemen Method
value
String value.

Glossary Item Box

Sets Arabic - Yemen text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArabicYemen(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setArmenian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setArmenian Method
value
String value.

Glossary Item Box

Sets Armenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setArmenian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setAzeriCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setAzeriCyrillic Method
value
String value.

Glossary Item Box

Sets Azeri - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setAzeriCyrillic(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setAzeriLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setAzeriLatin Method
value
String value.

Glossary Item Box

Sets Azeri - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setAzeriLatin(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setBasque Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setBasque Method
value
String value.

Glossary Item Box

Sets Basque text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setBasque(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setBelarusian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setBelarusian Method
value
String value.

Glossary Item Box

Sets Belarusian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setBelarusian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setBulgarian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setBulgarian Method
value
String value.

Glossary Item Box

Sets Bulgarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setBulgarian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setCatalan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setCatalan Method
value
String value.

Glossary Item Box

Sets Catalan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setCatalan(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setChineseChina Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setChineseChina Method
value
String value.

Glossary Item Box

Sets Chinese - China text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setChineseChina(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setChineseHongKongSAR Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setChineseHongKongSAR Method
value
String value.

Glossary Item Box

Sets Chinese - Hong Kong SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setChineseHongKongSAR(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setChineseMacauSAR Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setChineseMacauSAR Method
value
String value.

Glossary Item Box

Sets Chinese - Macau SAR text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setChineseMacauSAR(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setChineseSingapore Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setChineseSingapore Method
value
String value.

Glossary Item Box

Sets Chinese - Singapore text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setChineseSingapore(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setChineseTaiwan Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setChineseTaiwan Method
value
String value.

Glossary Item Box

Sets Chinese - Taiwan text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setChineseTaiwan(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setCroatian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setCroatian Method
value
String value.

Glossary Item Box

Sets Croatian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setCroatian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setCzech Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setCzech Method
value
String value.

Glossary Item Box

Sets Czech text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setCzech(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setDanish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setDanish Method
value
String value.

Glossary Item Box

Sets Danish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setDanish(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setDefault Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setDefault Method
value
String value.

Glossary Item Box

Sets default text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setDefault(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setDutchBelgium Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setDutchBelgium Method
value
String value.

Glossary Item Box

Sets Dutch - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setDutchBelgium(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setDutchNetherlands Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setDutchNetherlands Method
value
String value.

Glossary Item Box

Sets Dutch - Netherlands text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setDutchNetherlands(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishAustralia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishAustralia Method
value
String value.

Glossary Item Box

Sets English - Australia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishAustralia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishBelize Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishBelize Method
value
String value.

Glossary Item Box

Sets English - Belize text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishBelize(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishCanada Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishCanada Method
value
String value.

Glossary Item Box

Sets English - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishCanada(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishCaribbean Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishCaribbean Method
value
String value.

Glossary Item Box

Sets English - Caribbean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishCaribbean(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishIreland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishIreland Method
value
String value.

Glossary Item Box

Sets English - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishIreland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishJamaica Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishJamaica Method
value
String value.

Glossary Item Box

Sets English - Jamaica text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishJamaica(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishNewZealand Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishNewZealand Method
value
String value.

Glossary Item Box

Sets English - New Zealand text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishNewZealand(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishPhillippines Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishPhillippines Method
value
String value.

Glossary Item Box

Sets English - Philippines text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishPhillippines(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishSouthAfrica Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishSouthAfrica Method
value
String value.

Glossary Item Box

Sets English - South Africa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishSouthAfrica(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishTrinidad Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishTrinidad Method
value
String value.

Glossary Item Box

Sets English - Trinidad text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishTrinidad(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishUnitedKingdom Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishUnitedKingdom Method
value
String value.

Glossary Item Box

Sets English - United Kingdom text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishUnitedKingdom(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEnglishUnitedStates Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEnglishUnitedStates Method
value
String value.

Glossary Item Box

Sets English - United States text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEnglishUnitedStates(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setEstonian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setEstonian Method
value
String value.

Glossary Item Box

Sets Estonian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setEstonian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFaroese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFaroese Method
value
String value.

Glossary Item Box

Sets Faroese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFaroese(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFarsi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFarsi Method
value
String value.

Glossary Item Box

Sets Farsi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFarsi(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFinnish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFinnish Method
value
String value.

Glossary Item Box

Sets Finnish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFinnish(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFrenchBelgium Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFrenchBelgium Method
value
String value.

Glossary Item Box

Sets French - Belgium text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFrenchBelgium(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFrenchCanada Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFrenchCanada Method
value
String value.

Glossary Item Box

Sets French - Canada text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFrenchCanada(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFrenchFrance Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFrenchFrance Method
value
String value.

Glossary Item Box

Sets French - France text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFrenchFrance(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFrenchLuxembourg Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFrenchLuxembourg Method
value
String value.

Glossary Item Box

Sets French - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFrenchLuxembourg(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setFrenchSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setFrenchSwitzerland Method
value
String value.

Glossary Item Box

Sets French - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setFrenchSwitzerland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGaelicIreland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGaelicIreland Method
value
String value.

Glossary Item Box

Sets Gaelic - Ireland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGaelicIreland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGaelicScotland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGaelicScotland Method
value
String value.

Glossary Item Box

Sets Gaelic - Scotland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGaelicScotland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGermanAustria Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGermanAustria Method
value
String value.

Glossary Item Box

Sets German - Austria text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGermanAustria(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGermanGermany Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGermanGermany Method
value
String value.

Glossary Item Box

Sets German - Germany text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGermanGermany(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGermanLiechtenstein Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGermanLiechtenstein Method
value
String value.

Glossary Item Box

Sets German - Liechtenstein text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGermanLiechtenstein(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGermanLuxembourg Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGermanLuxembourg Method
value
String value.

Glossary Item Box

Sets German - Luxembourg text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGermanLuxembourg(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGermanSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGermanSwitzerland Method
value
String value.

Glossary Item Box

Sets German - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGermanSwitzerland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setGreek Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setGreek Method
value
String value.

Glossary Item Box

Sets Greek text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setGreek(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setHebrew Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setHebrew Method
value
String value.

Glossary Item Box

Sets Hebrew text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setHebrew(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setHindi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setHindi Method
value
String value.

Glossary Item Box

Sets Hindi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setHindi(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setHungarian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setHungarian Method
value
String value.

Glossary Item Box

Sets Hungarian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setHungarian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setIcelandic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setIcelandic Method
value
String value.

Glossary Item Box

Sets Icelandic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setIcelandic(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setIndonesian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setIndonesian Method
value
String value.

Glossary Item Box

Sets Indonesian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setIndonesian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setItalianItaly Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setItalianItaly Method
value
String value.

Glossary Item Box

Sets Italian - Italy text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setItalianItaly(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setItalianSwitzerland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setItalianSwitzerland Method
value
String value.

Glossary Item Box

Sets Italian - Switzerland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setItalianSwitzerland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setJapanese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setJapanese Method
value
String value.

Glossary Item Box

Sets Japanese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setJapanese(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setKorean Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setKorean Method
value
String value.

Glossary Item Box

Sets Korean text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setKorean(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setLatvian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setLatvian Method
value
String value.

Glossary Item Box

Sets Latvian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setLatvian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setLithuanian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setLithuanian Method
value
String value.

Glossary Item Box

Sets Lithuanian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setLithuanian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setMacedonianFYROM Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setMacedonianFYROM Method
value
String value.

Glossary Item Box

Sets Macedonian - FYROM text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setMacedonianFYROM(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setMalayBrunei Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setMalayBrunei Method
value
String value.

Glossary Item Box

Sets Malay - Brunei text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setMalayBrunei(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setMalayMalaysia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setMalayMalaysia Method
value
String value.

Glossary Item Box

Sets Malay - Malaysia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setMalayMalaysia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setMaltese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setMaltese Method
value
String value.

Glossary Item Box

Sets Maltese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setMaltese(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setMarathi Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setMarathi Method
value
String value.

Glossary Item Box

Sets Marathi text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setMarathi(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setNorwegianBokml Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setNorwegianBokml Method
value
String value.

Glossary Item Box

Sets Norwegian - Bokml text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setNorwegianBokml(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setNorwegianNynorsk Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setNorwegianNynorsk Method
value
String value.

Glossary Item Box

Sets Norwegian - Nynorsk text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setNorwegianNynorsk(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setPolish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setPolish Method
value
String value.

Glossary Item Box

Sets Polish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setPolish(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setPortugueseBrazil Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setPortugueseBrazil Method
value
String value.

Glossary Item Box

Sets Portuguese - Brazil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setPortugueseBrazil(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setPortuguesePortugal Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setPortuguesePortugal Method
value
String value.

Glossary Item Box

Sets Portuguese - Portugal text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setPortuguesePortugal(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setRaetoRomance Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setRaetoRomance Method
value
String value.

Glossary Item Box

Sets Raeto - Romance text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setRaetoRomance(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setRomanianMoldova Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setRomanianMoldova Method
value
String value.

Glossary Item Box

Sets Romanian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setRomanianMoldova(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setRomanianRomania Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setRomanianRomania Method
value
String value.

Glossary Item Box

Sets Romanian - Romania text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setRomanianRomania(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setRussian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setRussian Method
value
String value.

Glossary Item Box

Sets Russian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setRussian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setRussianMoldova Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setRussianMoldova Method
value
String value.

Glossary Item Box

Sets Russian - Moldova text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setRussianMoldova(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSanskrit Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSanskrit Method
value
String value.

Glossary Item Box

Sets Sanskrit text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSanskrit(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSerbianCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSerbianCyrillic Method
value
String value.

Glossary Item Box

Sets Serbian - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSerbianCyrillic(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSerbianLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSerbianLatin Method
value
String value.

Glossary Item Box

Sets Serbian - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSerbianLatin(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSetsuana Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSetsuana Method
value
String value.

Glossary Item Box

Sets Setsuana text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSetsuana(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSlovak Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSlovak Method
value
String value.

Glossary Item Box

Sets Slovak text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSlovak(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSlovenian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSlovenian Method
value
String value.

Glossary Item Box

Sets Slovenian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSlovenian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSorbian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSorbian Method
value
String value.

Glossary Item Box

Sets Sorbian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSorbian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSouthernSotho Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSouthernSotho Method
value
String value.

Glossary Item Box

Sets Southern Sotho text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSouthernSotho(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishArgentina Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishArgentina Method
value
String value.

Glossary Item Box

Sets Spanish - Argentina text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishArgentina(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishBolivia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishBolivia Method
value
String value.

Glossary Item Box

Sets Spanish - Bolivia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishBolivia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishChile Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishChile Method
value
String value.

Glossary Item Box

Sets Spanish - Chile text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishChile(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishColombia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishColombia Method
value
String value.

Glossary Item Box

Sets Spanish - Colombia text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishColombia(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishCosta Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishCosta Method
value
String value.

Glossary Item Box

Sets Spanish - Costa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishCosta(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishDominican Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishDominican Method
value
String value.

Glossary Item Box

Sets Spanish - Dominican text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishDominican(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishEcuador Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishEcuador Method
value
String value.

Glossary Item Box

Sets Spanish - Ecuador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishEcuador(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishElSalvador Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishElSalvador Method
value
String value.

Glossary Item Box

Sets Spanish - El Salvador text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishElSalvador(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishGuatemala Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishGuatemala Method
value
String value.

Glossary Item Box

Sets Spanish - Guatemala text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishGuatemala(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishHonduras Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishHonduras Method
value
String value.

Glossary Item Box

Sets Spanish - Honduras text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishHonduras(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishMexico Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishMexico Method
value
String value.

Glossary Item Box

Sets Spanish - Mexico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishMexico(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishNicaragua Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishNicaragua Method
value
String value.

Glossary Item Box

Sets Spanish - Nicaragua text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishNicaragua(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishPanama Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishPanama Method
value
String value.

Glossary Item Box

Sets Spanish - Panama text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishPanama(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishParaguay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishParaguay Method
value
String value.

Glossary Item Box

Sets Spanish - Paraguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishParaguay(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishPeru Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishPeru Method
value
String value.

Glossary Item Box

Sets Spanish - Peru text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishPeru(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishPuertoRico Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishPuertoRico Method
value
String value.

Glossary Item Box

Sets Spanish - Puerto Rico text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishPuertoRico(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishSpain Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishSpain Method
value
String value.

Glossary Item Box

Sets Spanish - Spain text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishSpain(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishUruguay Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishUruguay Method
value
String value.

Glossary Item Box

Sets Spanish - Uruguay text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishUruguay(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSpanishVenezuela Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSpanishVenezuela Method
value
String value.

Glossary Item Box

Sets Spanish - Venezuela text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSpanishVenezuela(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSwahili Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSwahili Method
value
String value.

Glossary Item Box

Sets Swahili text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSwahili(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSwedishFinland Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSwedishFinland Method
value
String value.

Glossary Item Box

Sets Swedish - Finland text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSwedishFinland(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setSwedishSweden Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setSwedishSweden Method
value
String value.

Glossary Item Box

Sets Swedish - Sweden text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setSwedishSweden(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setTamil Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setTamil Method
value
String value.

Glossary Item Box

Sets Tamil text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setTamil(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setTatar Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setTatar Method
value
String value.

Glossary Item Box

Sets Tatar text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setTatar(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setThai Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setThai Method
value
String value.

Glossary Item Box

Sets Thai text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setThai(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setTsonga Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setTsonga Method
value
String value.

Glossary Item Box

Sets Tsonga text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setTsonga(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setTurkish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setTurkish Method
value
String value.

Glossary Item Box

Sets Turkish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setTurkish(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setUkrainian Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setUkrainian Method
value
String value.

Glossary Item Box

Sets Ukrainian text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setUkrainian(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setUrdu Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setUrdu Method
value
String value.

Glossary Item Box

Sets Urdu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setUrdu(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setUzbekCyrillic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setUzbekCyrillic Method
value
String value.

Glossary Item Box

Sets Uzbek - Cyrillic text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setUzbekCyrillic(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setUzbekLatin Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setUzbekLatin Method
value
String value.

Glossary Item Box

Sets Uzbek - Latin text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setUzbekLatin(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setVietnamese Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setVietnamese Method
value
String value.

Glossary Item Box

Sets Vietnamese text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setVietnamese(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setXhosa Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setXhosa Method
value
String value.

Glossary Item Box

Sets Xhosa text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setXhosa(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setYiddish Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setYiddish Method
value
String value.

Glossary Item Box

Sets Yiddish text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setYiddish(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

setZulu Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPLangAlt Class : setZulu Method
value
String value.

Glossary Item Box

Sets Zulu text alternative. Returns null if this alternative is not present. Set to null to remove this alternative from the object.

Syntax

public void setZulu(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearXMPLangAlt Class
ImGearXMPLangAlt Members


%%PageItemTitle%%

ImGearXMPMetadataRoot Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPMetadataRoot Class

Glossary Item Box

Provides simplified access to XMP metadata.

Properties of this class represent XMP schemas that are known to ImageGear.

Object Model

ImGearXMPMetadataRoot ClassImGearAdobePDFXMPMetadata ClassImGearBasicXMPMetadata ClassImGearBasicJobTicketXMPMetadata ClassImGearDublinCoreXMPMetadata ClassImGearDynamicMediaXMPMetadata ClassImGearEXIFXMPMetadata ClassImGearEXIFAuxXMPMetadata ClassImGearIPTC4XMPCoreMetadata ClassImGearMediaManagementXMPMetadata ClassImGearPagedTextXMPMetadata ClassImGearPhotoshopXMPMetadata ClassImGearRightsManagementXMPMetadata ClassImGearTIFFXMPMetadata Class

Syntax

public class ImGearXMPMetadataRoot
    extends com.accusoft.imagegear.formats.ImGearFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPMetadataRoot

See Also

Reference

ImGearXMPMetadataRoot Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPMetadataRoot Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPMetadataRoot Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPMetadataRoot.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPMetadataRoot Constructor | Initializes a new instance of the ImGearXMPMetadataRoot class.
Top

Public Methods

Name Description
public Method getAdobePDF Returns Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

public Method getBasic Returns Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

public Method getBasicJobTicket Returns Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

public Method getDublinCore Returns Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

public Method getDynamicMedia Returns Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

public Method getEXIF Returns EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

public Method getEXIFAux Returns EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

public Method getIPTC Returns IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

public Method getMediaManagement Returns Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

public Method getPagedText Returns Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

public Method getPhotoshop Returns Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

public Method getRightsManagement Returns Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

public Method getTIFF Returns TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

public Method setAdobePDF Sets Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

public Method setBasic Sets Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

public Method setBasicJobTicket Sets Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

public Method setDublinCore Sets Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

public Method setDynamicMedia Sets Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

public Method setEXIF Sets EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

public Method setEXIFAux Sets EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

public Method setIPTC Sets IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

public Method setMediaManagement Sets Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

public Method setPagedText Sets Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

public Method setPhotoshop Sets Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

public Method setRightsManagement Sets Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

If you need to remove Rights Management XMP schema properties from the metadata, set this property to null.

public Method setTIFF Sets TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

Top

See Also

Reference

ImGearXMPMetadataRoot Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPMetadataRoot Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : ImGearXMPMetadataRoot Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPMetadataRoot class.

Syntax

public ImGearXMPMetadataRoot()

Return Value

New instance of the ImGearXMPMetadataRoot class object.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPMetadataRoot Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPMetadataRoot Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPMetadataRoot members.

Public Methods

Name Description
public Method getAdobePDF Returns Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

public Method getBasic Returns Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

public Method getBasicJobTicket Returns Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

public Method getDublinCore Returns Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

public Method getDynamicMedia Returns Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

public Method getEXIF Returns EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

public Method getEXIFAux Returns EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

public Method getIPTC Returns IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

public Method getMediaManagement Returns Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

public Method getPagedText Returns Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

public Method getPhotoshop Returns Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

public Method getRightsManagement Returns Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

public Method getTIFF Returns TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

public Method setAdobePDF Sets Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

public Method setBasic Sets Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

public Method setBasicJobTicket Sets Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

public Method setDublinCore Sets Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

public Method setDynamicMedia Sets Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

public Method setEXIF Sets EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

public Method setEXIFAux Sets EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

public Method setIPTC Sets IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

public Method setMediaManagement Sets Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

public Method setPagedText Sets Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

public Method setPhotoshop Sets Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

public Method setRightsManagement Sets Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

If you need to remove Rights Management XMP schema properties from the metadata, set this property to null.

public Method setTIFF Sets TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

Top

See Also

Reference

ImGearXMPMetadataRoot Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getAdobePDF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getAdobePDF Method

Glossary Item Box

Returns Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearAdobePDFXMPMetadata getAdobePDF()

Return Value

com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getBasic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getBasic Method

Glossary Item Box

Returns Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearBasicXMPMetadata getBasic()

Return Value

com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getBasicJobTicket Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getBasicJobTicket Method

Glossary Item Box

Returns Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearBasicJobTicketXMPMetadata getBasicJobTicket()

Return Value

com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getDublinCore Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getDublinCore Method

Glossary Item Box

Returns Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearDublinCoreXMPMetadata getDublinCore()

Return Value

com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getDynamicMedia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getDynamicMedia Method

Glossary Item Box

Returns Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearDynamicMediaXMPMetadata getDynamicMedia()

Return Value

com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getEXIF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getEXIF Method

Glossary Item Box

Returns EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearEXIFXMPMetadata getEXIF()

Return Value

com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getEXIFAux Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getEXIFAux Method

Glossary Item Box

Returns EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearEXIFAuxXMPMetadata getEXIFAux()

Return Value

com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getIPTC Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getIPTC Method

Glossary Item Box

Returns IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearIPTC4XMPCoreMetadata getIPTC()

Return Value

com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getMediaManagement Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getMediaManagement Method

Glossary Item Box

Returns Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearMediaManagementXMPMetadata getMediaManagement()

Return Value

com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getPagedText Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getPagedText Method

Glossary Item Box

Returns Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearPagedTextXMPMetadata getPagedText()

Return Value

com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getPhotoshop Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getPhotoshop Method

Glossary Item Box

Returns Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearPhotoshopXMPMetadata getPhotoshop()

Return Value

com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getRightsManagement Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getRightsManagement Method

Glossary Item Box

Returns Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

Syntax

public ImGearRightsManagementXMPMetadata getRightsManagement()

Return Value

com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

getTIFF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : getTIFF Method

Glossary Item Box

Returns TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

Syntax

public ImGearTIFFXMPMetadata getTIFF()

Return Value

com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setAdobePDF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setAdobePDF Method
value
com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class value.

Glossary Item Box

Sets Adobe PDF XMP schema properties.

If metadata does not contain XMP properties belonging to the Adobe XMP scheme, the method returns null.

If the metadata does not have Adobe PDF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class.

If you need to remove Adobe PDF XMP schema properties from the metadata, set this value to null.

Syntax

public void setAdobePDF(
   ImGearAdobePDFXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setBasic Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setBasic Method
value
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class value.

Glossary Item Box

Sets Basic XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic scheme, the method returns null.

If the metadata does not have Basic XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class.

If you need to remove Basic XMP schema properties from the metadata, set this value to null.

Syntax

public void setBasic(
   ImGearBasicXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setBasicJobTicket Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setBasicJobTicket Method
value
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class value.

Glossary Item Box

Sets Basic Job Ticket XMP schema properties.

If metadata does not contain XMP properties belonging to the Basic Job Ticket scheme, the method returns null.

If the metadata does not have Basic Job Ticket XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class.

If you need to remove Basic Job Ticket XMP schema properties from the metadata, set this value to null.

Syntax

public void setBasicJobTicket(
   ImGearBasicJobTicketXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setDublinCore Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setDublinCore Method
value
com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class value.

Glossary Item Box

Sets Dublin Core XMP schema properties.

If metadata does not contain XMP properties belonging to the Dublin Core scheme, the method returns null.

If the metadata does not have Dublin Core XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class.

If you need to remove Dublin Core XMP schema properties from the metadata, set this value to null.

Syntax

public void setDublinCore(
   ImGearDublinCoreXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setDynamicMedia Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setDynamicMedia Method
value
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class value.

Glossary Item Box

Sets Dynamic Media XMP schema properties.

If metadata does not contain XMP properties belonging to the Dynamic Media scheme, the method returns null.

If the metadata does not have Dynamic Media XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove Dynamic Media XMP schema properties from the metadata, set this value to null.

Syntax

public void setDynamicMedia(
   ImGearDynamicMediaXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setEXIF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setEXIF Method
value
com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata class value.

Glossary Item Box

Sets EXIF XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIF scheme, the method returns null.

If the metadata does not have EXIF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata class.

If you need to remove EXIF XMP schema properties from the metadata, set this value to null.

Syntax

public void setEXIF(
   ImGearEXIFXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setEXIFAux Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setEXIFAux Method
value
com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class value.

Glossary Item Box

Sets EXIF Auxiliary XMP schema properties.

If metadata does not contain XMP properties belonging to the EXIFAux scheme, the method returns null.

If the metadata does not have EXIF Auxiliary XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class.

If you need to remove EXIF Auxiliary XMP schema properties from the metadata, set this value to null.

Syntax

public void setEXIFAux(
   ImGearEXIFAuxXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setIPTC Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setIPTC Method
value
com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class value.

Glossary Item Box

Sets IPTC4XMPCore XMP schema properties.

If metadata does not contain XMP properties belonging to the IPTC4XMPCore scheme, the method returns null.

If the metadata does not have IPTC4XMPCore XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class.

If you need to remove IPTC4XMPCore XMP schema properties from the metadata, set this value to null.

Syntax

public void setIPTC(
   ImGearIPTC4XMPCoreMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setMediaManagement Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setMediaManagement Method
value
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class value.

Glossary Item Box

Sets Media Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Media Management scheme, the method returns null.

If the metadata does not have Media Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class, pass it to this method, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class.

If you need to remove Media Management XMP schema properties from the metadata, set this value to null.

Syntax

public void setMediaManagement(
   ImGearMediaManagementXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setPagedText Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setPagedText Method
value
com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class value.

Glossary Item Box

Sets Paged Text XMP schema properties.

If metadata does not contain XMP properties belonging to the Paged Text scheme, the method returns null.

If the metadata does not have Paged Text XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class.

If you need to remove Paged Text XMP schema properties from the metadata, set this value to null.

Syntax

public void setPagedText(
   ImGearPagedTextXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setPhotoshop Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setPhotoshop Method
value
com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class value.

Glossary Item Box

Sets Photoshop XMP schema properties.

If metadata does not contain XMP properties belonging to the Photoshop scheme, the method returns null.

If the metadata does not have Photoshop XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class.

If you need to remove Photoshop XMP schema properties from the metadata, set this value to null.

Syntax

public void setPhotoshop(
   ImGearPhotoshopXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setRightsManagement Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setRightsManagement Method
value
com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class value.

Glossary Item Box

Sets Rights Management XMP schema properties.

If metadata does not contain XMP properties belonging to the Rights Management scheme, the method returns null.

If the metadata does not have Rights Management XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class, assign it to this property, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class.

If you need to remove Rights Management XMP schema properties from the metadata, set this property to null.

Syntax

public void setRightsManagement(
   ImGearRightsManagementXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

setTIFF Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPMetadataRoot Class : setTIFF Method
value
com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class value.

Glossary Item Box

Sets TIFF XMP schema properties.

If metadata does not contain XMP properties belonging to the TIFF scheme, the method returns null.

If the metadata does not have TIFF XMP properties, and you need to add such properties, create a new instance of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class, assign it using corresponding setter, and then add XMP properties using corresponding properties of the com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class.

If you need to remove TIFF XMP schema properties from the metadata, set this value to null.

Syntax

public void setTIFF(
   ImGearTIFFXMPMetadata value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata class value.

See Also

Reference

ImGearXMPMetadataRoot Class
ImGearXMPMetadataRoot Members


%%PageItemTitle%%

ImGearXMPRational Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPRational Class

Glossary Item Box

Represents a rational XMP metadata value.

Object Model

ImGearXMPRational ClassImGearRationalInt Class

Syntax

public class ImGearXMPRational
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPRational

See Also

Reference

ImGearXMPRational Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPRational Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPRational Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPRational.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPRational Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets the rational value of the ImGearXMPRational class object. com.accusoft.imagegear.core.ImGearRationalInt structure value.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPRational Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPRational Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPRational Class : ImGearXMPRational Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPRational Constructor() | Initializes a new instance of the ImGearXMPRational class.
ImGearXMPRational Constructor(ImGearRationalInt) | Initializes a new instance of the ImGearXMPRational class.

See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%%

ImGearXMPRational Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPRational Class > ImGearXMPRational Constructor : ImGearXMPRational Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPRational class.

Syntax

public ImGearXMPRational()

Return Value

New instance of ImGearXMPRational class object.

This constructor creates an instance of ImGearXMPRational class and initializes it with a default value.

See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members
Overload List


%%PageItemTitle%%

ImGearXMPRational Constructor(ImGearRationalInt)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPRational Class > ImGearXMPRational Constructor : ImGearXMPRational Constructor(ImGearRationalInt)
value
com.accusoft.imagegear.core.ImGearRationalInt structure value.

Glossary Item Box

Initializes a new instance of the ImGearXMPRational class.

Syntax

public ImGearXMPRational(
   ImGearRationalInt value
)

Parameters

value
com.accusoft.imagegear.core.ImGearRationalInt structure value.

Return Value

New instance of ImGearXMPRational class object.

This constructor creates and initializes an instance of ImGearXMPRational class by using a com.accusoft.imagegear.core.ImGearRationalInt structure value.

See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPRational Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPRational Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPRational members.

Public Methods

 | Name | Description
public Method | getValue | Gets the rational value of the ImGearXMPRational class object. com.accusoft.imagegear.core.ImGearRationalInt structure value.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPRational Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPRational Class : getValue Method

Glossary Item Box

Gets the rational value of the ImGearXMPRational class object.

com.accusoft.imagegear.core.ImGearRationalInt structure value.

Syntax

public ImGearRationalInt getValue()

See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPRational Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearXMPRational Class
ImGearXMPRational Members


%%PageItemTitle%%

ImGearXMPReal Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPReal Class

Glossary Item Box

Represents a floating point XMP metadata value.

This value has an optional qualifier that provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108"

Object Model

ImGearXMPReal Class

Syntax

public class ImGearXMPReal
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPReal

See Also

Reference

ImGearXMPReal Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPReal Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPReal Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPReal.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPReal Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getBinRepQualifier | Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as: std size,endian,hexadecimal_value - std is the standard name ("IEEE754") - size is S for 32-bit and D for 64-bit - endian is L for little-endian, B for big-endian. For example: "IEEE754D,L,3A4901F387D31108". String value.
public Method | getValue | Gets the double value of the ImGearXMPReal class object. Double value.
Top

See Also

Reference

ImGearXMPReal Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPReal Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPReal Class : ImGearXMPReal Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPReal Constructor(double) | Initializes a new instance of the ImGearXMPReal class.
ImGearXMPReal Constructor(double,String) | Initializes a new instance of the ImGearXMPReal class.

See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


%%PageItemTitle%%

ImGearXMPReal Constructor(double)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPReal Class > ImGearXMPReal Constructor : ImGearXMPReal Constructor(double)
value
Double value.

Glossary Item Box

Initializes a new instance of the ImGearXMPReal class.

Syntax

public ImGearXMPReal(
   double value
)

Parameters

value
Double value.

Return Value

New instance of ImGearXMPReal class object.

This constructor creates and initializes an instance of ImGearXMPReal class by using a double value.

See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members
Overload List


%%PageItemTitle%%

ImGearXMPReal Constructor(double,String)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPReal Class > ImGearXMPReal Constructor : ImGearXMPReal Constructor(double,String)
value
Double value.
binRep
Binary representation qualifier value.

Glossary Item Box

Initializes a new instance of the ImGearXMPReal class.

Syntax

public ImGearXMPReal(
   double value,
   java.lang.String binRep
)

Parameters

value
Double value.
binRep
Binary representation qualifier value.

Return Value

New instance of ImGearXMPReal class object.

This constructor creates and initializes an instance of ImGearXMPReal class by using a double value and a binary representation qualifier.

See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPReal Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPReal Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPReal members.

Public Methods

 | Name | Description
public Method | getBinRepQualifier | Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as: std size,endian,hexadecimal_value - std is the standard name ("IEEE754") - size is S for 32-bit and D for 64-bit - endian is L for little-endian, B for big-endian. For example: "IEEE754D,L,3A4901F387D31108". String value.
public Method | getValue | Gets the double value of the ImGearXMPReal class object. Double value.
Top

See Also

Reference

ImGearXMPReal Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getBinRepQualifier Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPReal Class : getBinRepQualifier Method

Glossary Item Box

Gets the optional Binary Representation qualifier. The qualifier provides binary representation of the floating point value when an exact value is needed. The text of the qualifier is interpreted as:

std size,endian,hexadecimal_value

- std is the standard name ("IEEE754")

- size is S for 32-bit and D for 64-bit

- endian is L for little-endian, B for big-endian.

For example: "IEEE754D,L,3A4901F387D31108".

String value.

Syntax

public java.lang.String getBinRepQualifier()

See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPReal Class : getValue Method

Glossary Item Box

Gets the double value of the ImGearXMPReal class object.

Double value.

Syntax

public double getValue()

See Also

Reference

ImGearXMPReal Class
ImGearXMPReal Members


%%PageItemTitle%%

T
ImGearXMPValue type.
ImageGear for Java
ImGearXMPSeq<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPSeq<T> Class

Glossary Item Box

Represents an ordered array of XMP properties.

ImGearXMPValue type.

Object Model

ImGearXMPSeq<T> Class

Syntax

public sealed class ImGearXMPSeq<T>
    extends ImGearXMPArray<T>

Type Parameters

T
ImGearXMPValue type.

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPArray<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T>

See Also

Reference

ImGearXMPSeq<T> Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPSeq<T> Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPSeq<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPSeq<T>.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPSeq<T> Constructor | Overloaded.
Top

See Also

Reference

ImGearXMPSeq<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPSeq<T> Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPSeq<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPSeq<T> members.

See Also

Reference

ImGearXMPSeq<T> Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPSeq<T> Class : ImGearXMPSeq<T> Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPSeq<T> Constructor() | Initializes a new instance of the ImGearXMPSeq<T> class.
ImGearXMPSeq<T> Constructor(String[],Class<T>) | Initializes a new instance of the ImGearXMPSeq<T> class.

See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPSeq<T> Class > ImGearXMPSeq<T> Constructor : ImGearXMPSeq<T> Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPSeq<T> class.

Syntax

public ImGearXMPSeq<T>()

Return Value

New instance of the ImGearXMPSeq<T> generic class object.

This constructor creates an empty instance of ImGearXMPSeq<T> generic class.

See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members
Overload List


%%PageItemTitle%%

ImGearXMPSeq<T> Constructor(String[],Class<T>)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPSeq<T> Class > ImGearXMPSeq<T> Constructor : ImGearXMPSeq<T> Constructor(String[],Class<T>)
value
String array.
clazz

Glossary Item Box

Initializes a new instance of the ImGearXMPSeq<T> class.

Syntax

public ImGearXMPSeq<T>(
   java.lang.String[] value,
   java.lang.Class<T> clazz
)

Parameters

value
String array.
clazz

Return Value

New instance of the ImGearXMPSeq<T> generic class object.

This constructor creates an instance of ImGearXMPSeq<T> generic class generic class and initializes it with values from the string array.

See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members
Overload List


%%PageItemTitle%%

toStringArray Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPSeq<T> Class : toStringArray Method

Glossary Item Box

Syntax

public java.lang.String[] toStringArray()

See Also

Reference

ImGearXMPSeq<T> Class
ImGearXMPSeq<T> Members


%%PageItemTitle%%

ImGearXMPString Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPString Class

Glossary Item Box

Represents a string XMP metadata value.

Object Model

ImGearXMPString Class

Syntax

public class ImGearXMPString
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPString
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPIdentifier

See Also

Reference

ImGearXMPString Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPString Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPString Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPString.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPString Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets the string value of the ImGearXMPString class object. String value.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPString Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPString Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPString Class : ImGearXMPString Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPString Constructor() | Initializes a new instance of the ImGearXMPString class.
ImGearXMPString Constructor(String) | Initializes a new instance of the ImGearXMPString class.

See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%%

ImGearXMPString Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPString Class > ImGearXMPString Constructor : ImGearXMPString Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPString class.

Syntax

public ImGearXMPString()

Return Value

New instance of the ImGearXMPString class object.

This constructor creates an instance of ImGearXMPString class and initializes it with a default value.

See Also

Reference

ImGearXMPString Class
ImGearXMPString Members
Overload List


%%PageItemTitle%%

ImGearXMPString Constructor(String)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPString Class > ImGearXMPString Constructor : ImGearXMPString Constructor(String)
value
String value.

Glossary Item Box

Initializes a new instance of the ImGearXMPString class.

Syntax

public ImGearXMPString(
   java.lang.String value
)

Parameters

value
String value.

Return Value

New instance of the ImGearXMPString class object.

This constructor creates and initializes an instance of ImGearXMPString class by using a string value.

See Also

Reference

ImGearXMPString Class
ImGearXMPString Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPString Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPString Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPString members.

Public Methods

 | Name | Description
public Method | getValue | Gets the string value of the ImGearXMPString class object. String value.
public Method | toString | Converts value to string.
Top

See Also

Reference

ImGearXMPString Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPString Class : getValue Method

Glossary Item Box

Gets the string value of the ImGearXMPString class object.

String value.

Syntax

public java.lang.String getValue()

See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%%

toString Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPString Class : toString Method

Glossary Item Box

Converts value to string.

Syntax

public java.lang.String toString()

Return Value

String value.

See Also

Reference

ImGearXMPString Class
ImGearXMPString Members


%%PageItemTitle%%

ImGearXMPStructure Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPStructure Class

Glossary Item Box

Specifies baseline features for XMP structures.

This abstract class specifies baseline features for XMP structures, such as ImGearXMPFont class, ImGearXMPColorant class, etc.

Object Model

ImGearXMPStructure Class

Syntax

public abstract class ImGearXMPStructure
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearXMPJob
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPBeatSpliceStretch
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMarker
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMedia
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPProjectLink
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTime
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimecode
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimeScaleStretch
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPCFAPattern
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPDeviceSettings
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPFlash
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPOECFSFR
com.accusoft.imagegear.formats.xmp.ImGearXMPColorant
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions
com.accusoft.imagegear.formats.xmp.ImGearXMPFont
com.accusoft.imagegear.formats.xmp.iptc.ImGearXMPContactInfo
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceEvent
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceReference
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPVersion

See Also

Reference

ImGearXMPStructure Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPStructure Class Members
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPStructure Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPStructure.

See Also

Reference

ImGearXMPStructure Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPThumbnail Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPThumbnail Class

Glossary Item Box

Represents an XMP Thumbnail structure.

This class is not implemented yet.

Object Model

ImGearXMPThumbnail ClassImGearPage Class

Syntax

public class ImGearXMPThumbnail
    extends ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPThumbnail

See Also

Reference

ImGearXMPThumbnail Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPThumbnail Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPThumbnail Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPThumbnail.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPThumbnail Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getValue | Gets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object. This method is not implemented yet. Method always returns null.
public Method | setValue | Sets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object. This method is not implemented yet.
Top

See Also

Reference

ImGearXMPThumbnail Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

ImGearXMPThumbnail Constructor
com.accusoft.imagegear.formats.xmp Package > ImGearXMPThumbnail Class : ImGearXMPThumbnail Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearXMPThumbnail Constructor() | Initializes a new instance of the ImGearXMPThumbnail class.
ImGearXMPThumbnail Constructor(ImGearPage) | Initializes a new instance of the ImGearXMPThumbnail class.

See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members


%%PageItemTitle%%

ImGearXMPThumbnail Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPThumbnail Class > ImGearXMPThumbnail Constructor : ImGearXMPThumbnail Constructor()

Glossary Item Box

Initializes a new instance of the ImGearXMPThumbnail class.

Syntax

public ImGearXMPThumbnail()

Return Value

New instance of the ImGearXMPThumbnail class object.

This constructor creates an empty instance of ImGearXMPThumbnail class.

See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members
Overload List


%%PageItemTitle%%

ImGearXMPThumbnail Constructor(ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package > ImGearXMPThumbnail Class > ImGearXMPThumbnail Constructor : ImGearXMPThumbnail Constructor(ImGearPage)
page
ImGearPage object.

Glossary Item Box

Initializes a new instance of the ImGearXMPThumbnail class.

Syntax

public ImGearXMPThumbnail(
   ImGearPage page
)

Parameters

page
ImGearPage object.

Return Value

New instance of the ImGearXMPThumbnail class object.

This constructor creates and initializes an instance of ImGearXMPThumbnail class by using an com.accusoft.imagegear.core.ImGearPage class object.

See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPThumbnail Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPThumbnail Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPThumbnail members.

Public Methods

 | Name | Description
public Method | getValue | Gets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object. This method is not implemented yet. Method always returns null.
public Method | setValue | Sets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object. This method is not implemented yet.
Top

See Also

Reference

ImGearXMPThumbnail Class
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPThumbnail Class : getValue Method

Glossary Item Box

Gets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object.

This method is not implemented yet. Method always returns null.

Syntax

public ImGearPage getValue()

Return Value

com.accusoft.imagegear.core.ImGearPage class object.

See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.formats.xmp Package > ImGearXMPThumbnail Class : setValue Method
value
com.accusoft.imagegear.core.ImGearPage class object.

Glossary Item Box

Sets thumbnail image as an com.accusoft.imagegear.core.ImGearPage class object.

This method is not implemented yet.

Syntax

public void setValue(
   ImGearPage value
)

Parameters

value
com.accusoft.imagegear.core.ImGearPage class object.

See Also

Reference

ImGearXMPThumbnail Class
ImGearXMPThumbnail Members


%%PageItemTitle%%

ImGearXMPValue Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPValue Class

Glossary Item Box

Specifies baseline features for an XMP value.

This abstract class specifies baseline features for an XMP property value.

Object Model

ImGearXMPValue Class

Syntax

public abstract class ImGearXMPValue
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPGPSCoordinate
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean
com.accusoft.imagegear.formats.xmp.ImGearXMPDate
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T>
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger
com.accusoft.imagegear.formats.xmp.ImGearXMPRational
com.accusoft.imagegear.formats.xmp.ImGearXMPString
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPThumbnail

See Also

Reference

ImGearXMPValue Members
com.accusoft.imagegear.formats.xmp Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPValue Class Members
See Also Send Feedback
com.accusoft.imagegear.formats.xmp Package : ImGearXMPValue Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPValue.

See Also

Reference

ImGearXMPValue Class
com.accusoft.imagegear.formats.xmp Package


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.adobepdf Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP AdobePDF format.

Classes

Class | Description
ImGearAdobePDFXMPMetadata | Provides simplified access to Adobe PDF XMP metadata scheme.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.adobepdf Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearAdobePDFXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.adobepdf Package : ImGearAdobePDFXMPMetadata Class

Glossary Item Box

Provides simplified access to Adobe PDF XMP metadata scheme.

Object Model

ImGearAdobePDFXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearAdobePDFXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.adobepdf.ImGearAdobePDFXMPMetadata

See Also

Reference

ImGearAdobePDFXMPMetadata Members
com.accusoft.imagegear.formats.xmp.adobepdf Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearAdobePDFXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.adobepdf Package : ImGearAdobePDFXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearAdobePDFXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearAdobePDFXMPMetadata Constructor | Initializes a new instance of the ImGearAdobePDFXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getKeywords | Returns Keywords value of the AdobePDF XMP schema.
public Method | getPDFVersion | Returns PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).
public Method | getProducer | Returns Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.
public Method | setKeywords | Sets Keywords value of the AdobePDF XMP schema.
public Method | setPDFVersion | Sets PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).
public Method | setProducer | Sets Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.
Top

Protected Methods

 | Name | Description
protected Method | getDefaultNamespacePrefix |
protected Method | getNamespaceURI |
Top

See Also

Reference

ImGearAdobePDFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.adobepdf Package


%%PageItemTitle%%

ImGearAdobePDFXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : ImGearAdobePDFXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearAdobePDFXMPMetadata class.

Syntax

public ImGearAdobePDFXMPMetadata()

Return Value

New instance of the ImGearAdobePDFXMPMetadata class object.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearAdobePDFXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.adobepdf Package : ImGearAdobePDFXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearAdobePDFXMPMetadata members.

Public Methods

 | Name | Description
public Method | getKeywords | Returns Keywords value of the AdobePDF XMP schema.
public Method | getPDFVersion | Returns PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).
public Method | getProducer | Returns Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.
public Method | setKeywords | Sets Keywords value of the AdobePDF XMP schema.
public Method | setPDFVersion | Sets PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).
public Method | setProducer | Sets Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.
Top

Protected Methods

 | Name | Description
protected Method | getDefaultNamespacePrefix |
protected Method | getNamespaceURI |
Top

See Also

Reference

ImGearAdobePDFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.adobepdf Package


%%PageItemTitle%%

getDefaultNamespacePrefix Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : getDefaultNamespacePrefix Method

Glossary Item Box

Syntax

protected java.lang.String getDefaultNamespacePrefix()

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

getKeywords Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : getKeywords Method

Glossary Item Box

Returns Keywords value of the AdobePDF XMP schema.

Syntax

public ImGearXMPString getKeywords()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

getNamespaceURI Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : getNamespaceURI Method

Glossary Item Box

Syntax

protected java.lang.String getNamespaceURI()

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

getPDFVersion Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : getPDFVersion Method

Glossary Item Box

Returns PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).

Syntax

public ImGearXMPString getPDFVersion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

getProducer Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : getProducer Method

Glossary Item Box

Returns Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.

Syntax

public ImGearXMPString getProducer()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

setKeywords Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : setKeywords Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Keywords value of the AdobePDF XMP schema.

Syntax

public void setKeywords(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

setPDFVersion Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : setPDFVersion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets PDFVersion value of the AdobePDF XMP schema. This XMP value specifies the PDF file version (for example: 1.0, 1.3, and so on).

Syntax

public void setPDFVersion(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%PageItemTitle%%

setProducer Method
com.accusoft.imagegear.formats.xmp.adobepdf Package > ImGearAdobePDFXMPMetadata Class : setProducer Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Producer value of the AdobePDF XMP schema. This XMP value specifies the name of the tool that created the PDF document.

Syntax

public void setProducer(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearAdobePDFXMPMetadata Class
ImGearAdobePDFXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.basic Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP Basic format.

Classes

Class | Description
ImGearBasicXMPIdentifier | Represents an Identifier value of the XMP Basic schema. This class contains a string qualified by an optional Schema qualifier.
ImGearBasicXMPMetadata | Provides simplified access to XMP Basic metadata scheme.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.basic Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPString
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPIdentifier

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearBasicXMPIdentifier Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPIdentifier Class

Glossary Item Box

Represents an Identifier value of the XMP Basic schema.

This class contains a string qualified by an optional Schema qualifier.

Object Model

ImGearBasicXMPIdentifier ClassImGearXMPString Class

Syntax

public class ImGearBasicXMPIdentifier
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPString

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPString
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPIdentifier

See Also

Reference

ImGearBasicXMPIdentifier Members
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBasicXMPIdentifier Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPIdentifier Class

Glossary Item Box

The following tables list the members exposed by ImGearBasicXMPIdentifier.

Public Constructors

 | Name | Description
public Constructor | ImGearBasicXMPIdentifier Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getSchemeQualifier | Returns the Scheme qualifier.
public Method | setSchemeQualifier | Sets the Scheme qualifier.
Top

See Also

Reference

ImGearBasicXMPIdentifier Class
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class : ImGearBasicXMPIdentifier Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearBasicXMPIdentifier Constructor(String,String) | Initializes a new instance of the ImGearBasicXMPIdentifier class.
ImGearBasicXMPIdentifier Constructor() | Initializes a new instance of the ImGearBasicXMPIdentifier class.
ImGearBasicXMPIdentifier Constructor(String) | Initializes a new instance of the ImGearBasicXMPIdentifier class.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor(String,String)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor(String,String)
value
String value.
schemeQualifier
Scheme qualifier.

Glossary Item Box

Initializes a new instance of the ImGearBasicXMPIdentifier class.

Syntax

public ImGearBasicXMPIdentifier(
   java.lang.String value,
   java.lang.String schemeQualifier
)

Parameters

value
String value.
schemeQualifier
Scheme qualifier.

Return Value

New instance of ImGearBasicXMPIdentifier class object.

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class, using the specified value and a scheme qualifier.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor()

Glossary Item Box

Initializes a new instance of the ImGearBasicXMPIdentifier class.

Syntax

public ImGearBasicXMPIdentifier()

Return Value

New instance of ImGearBasicXMPIdentifier class object.

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%%

ImGearBasicXMPIdentifier Constructor(String)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class > ImGearBasicXMPIdentifier Constructor : ImGearBasicXMPIdentifier Constructor(String)
value
String value.

Glossary Item Box

Initializes a new instance of the ImGearBasicXMPIdentifier class.

Syntax

public ImGearBasicXMPIdentifier(
   java.lang.String value
)

Parameters

value
String value.

Return Value

New instance of ImGearBasicXMPIdentifier class object.

This constructor creates and initializes an instance of ImGearBasicXMPIdentifier class, using a string value.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members
Overload List


%%PageItemTitle%%

fromString Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class : fromString Method
str

Glossary Item Box

Syntax

public static ImGearXMPString fromString(
   java.lang.String str
)

Parameters

str

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearBasicXMPIdentifier Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPIdentifier Class

Glossary Item Box

For a list of all members of this type, see ImGearBasicXMPIdentifier members.

Public Methods

 | Name | Description
public Method | getSchemeQualifier | Returns the Scheme qualifier.
public Method | setSchemeQualifier | Sets the Scheme qualifier.
Top

See Also

Reference

ImGearBasicXMPIdentifier Class
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%%

getSchemeQualifier Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class : getSchemeQualifier Method

Glossary Item Box

Returns the Scheme qualifier.

Syntax

public java.lang.String getSchemeQualifier()

Return Value

String value.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

initialize Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class : initialize Method
value

Glossary Item Box

Syntax

protected void initialize(
   java.lang.String value
)

Parameters

value

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

setSchemeQualifier Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPIdentifier Class : setSchemeQualifier Method
value
String value.

Glossary Item Box

Sets the Scheme qualifier.

Syntax

public void setSchemeQualifier(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearBasicXMPIdentifier Class
ImGearBasicXMPIdentifier Members


%%PageItemTitle%%

ImGearBasicXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPMetadata Class

Glossary Item Box

Provides simplified access to XMP Basic metadata scheme.

Object Model

ImGearBasicXMPMetadata ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPInteger Class

Syntax

public class ImGearBasicXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.basic.ImGearBasicXMPMetadata

See Also

Reference

ImGearBasicXMPMetadata Members
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBasicXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearBasicXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearBasicXMPMetadata Constructor | Initializes a new instance of the ImGearBasicXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getAdvisory | Returns Advisory value of the XMP Basic schema. This XMP value contains an unordered array specifying properties that were edited outside the authoring application.
public Method | getBaseURL | Returns BaseURL value of the XMP Basic schema. This XMP value specifies the base URL for relative URLs in the document content.
public Method | getCreateDate | Returns CreateDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was originally created.
public Method | getCreatorTool | Returns CreatorTool value of the XMP Basic schema. This XMP value specifies name of the first known tool used to create the resource.
public Method | getIdentifier | Returns Identifier value of the XMP Basic schema. This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.
public Method | getLabel | Returns Label value of the XMP Basic schema. This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.
public Method | getMetadataDate | Returns MetadataDate value of the XMP Basic schema. This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.
public Method | getModifyDate | Returns ModifyDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was last modified.
public Method | getNickname | Returns Nickname value of the XMP Basic schema. This XMP value specifies a short informal name for the resource.
public Method | getRating | Returns Rating value of the XMP Basic schema. This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.
public Method | getThumbnails | Gets Thumbnails value of the XMP Basic schema.
public Method | setAdvisory | Sets Advisory value of the XMP Basic schema. This XMP value contains an unordered array specifying properties that were edited outside the authoring application.
public Method | setBaseURL | Sets BaseURL value of the XMP Basic schema. This XMP value specifies the base URL for relative URLs in the document content.
public Method | setCreateDate | Sets CreateDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was originally created.
public Method | setCreatorTool | Sets CreatorTool value of the XMP Basic schema. This XMP value specifies name of the first known tool used to create the resource.
public Method | setIdentifier | Sets Identifier value of the XMP Basic schema. This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.
public Method | setLabel | Sets Label value of the XMP Basic schema. This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.
public Method | setMetadataDate | Sets MetadataDate value of the XMP Basic schema. This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.
public Method | setModifyDate | Sets ModifyDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was last modified.
public Method | setNickname | Sets Nickname value of the XMP Basic schema. This XMP value specifies a short informal name for the resource.
public Method | setRating | Sets Rating value of the XMP Basic schema. This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.
public Method | setThumbnails | Sets Thumbnails value of the XMP Basic schema.
Top

See Also

Reference

ImGearBasicXMPMetadata Class
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%%

ImGearBasicXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : ImGearBasicXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearBasicXMPMetadata class.

Syntax

public ImGearBasicXMPMetadata()

Return Value

New instance of the ImGearBasicXMPMetadata class object.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearBasicXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basic Package : ImGearBasicXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearBasicXMPMetadata members.

Public Methods

 | Name | Description
public Method | getAdvisory | Returns Advisory value of the XMP Basic schema. This XMP value contains an unordered array specifying properties that were edited outside the authoring application.
public Method | getBaseURL | Returns BaseURL value of the XMP Basic schema. This XMP value specifies the base URL for relative URLs in the document content.
public Method | getCreateDate | Returns CreateDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was originally created.
public Method | getCreatorTool | Returns CreatorTool value of the XMP Basic schema. This XMP value specifies name of the first known tool used to create the resource.
public Method | getIdentifier | Returns Identifier value of the XMP Basic schema. This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.
public Method | getLabel | Returns Label value of the XMP Basic schema. This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.
public Method | getMetadataDate | Returns MetadataDate value of the XMP Basic schema. This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.
public Method | getModifyDate | Returns ModifyDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was last modified.
public Method | getNickname | Returns Nickname value of the XMP Basic schema. This XMP value specifies a short informal name for the resource.
public Method | getRating | Returns Rating value of the XMP Basic schema. This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.
public Method | getThumbnails | Gets Thumbnails value of the XMP Basic schema.
public Method | setAdvisory | Sets Advisory value of the XMP Basic schema. This XMP value contains an unordered array specifying properties that were edited outside the authoring application.
public Method | setBaseURL | Sets BaseURL value of the XMP Basic schema. This XMP value specifies the base URL for relative URLs in the document content.
public Method | setCreateDate | Sets CreateDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was originally created.
public Method | setCreatorTool | Sets CreatorTool value of the XMP Basic schema. This XMP value specifies name of the first known tool used to create the resource.
public Method | setIdentifier | Sets Identifier value of the XMP Basic schema. This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.
public Method | setLabel | Sets Label value of the XMP Basic schema. This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.
public Method | setMetadataDate | Sets MetadataDate value of the XMP Basic schema. This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.
public Method | setModifyDate | Sets ModifyDate value of the XMP Basic schema. This XMP value specifies the date and time the resource was last modified.
public Method | setNickname | Sets Nickname value of the XMP Basic schema. This XMP value specifies a short informal name for the resource.
public Method | setRating | Sets Rating value of the XMP Basic schema. This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.
public Method | setThumbnails | Sets Thumbnails value of the XMP Basic schema.
Top

See Also

Reference

ImGearBasicXMPMetadata Class
com.accusoft.imagegear.formats.xmp.basic Package


%%PageItemTitle%%

getAdvisory Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getAdvisory Method

Glossary Item Box

Returns Advisory value of the XMP Basic schema.

This XMP value contains an unordered array specifying properties that were edited outside the authoring application.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getAdvisory()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getBaseURL Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getBaseURL Method

Glossary Item Box

Returns BaseURL value of the XMP Basic schema.

This XMP value specifies the base URL for relative URLs in the document content.

Syntax

public ImGearXMPString getBaseURL()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getCreateDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getCreateDate Method

Glossary Item Box

Returns CreateDate value of the XMP Basic schema.

This XMP value specifies the date and time the resource was originally created.

Syntax

public ImGearXMPDate getCreateDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getCreatorTool Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getCreatorTool Method

Glossary Item Box

Returns CreatorTool value of the XMP Basic schema.

This XMP value specifies name of the first known tool used to create the resource.

Syntax

public ImGearXMPString getCreatorTool()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getIdentifier Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getIdentifier Method

Glossary Item Box

Returns Identifier value of the XMP Basic schema.

This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearBasicXMPIdentifier> getIdentifier()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearBasicXMPIdentifier type parameter.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getLabel Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getLabel Method

Glossary Item Box

Returns Label value of the XMP Basic schema.

This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.

Syntax

public ImGearXMPString getLabel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getMetadataDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getMetadataDate Method

Glossary Item Box

Returns MetadataDate value of the XMP Basic schema.

This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.

Syntax

public ImGearXMPDate getMetadataDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getModifyDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getModifyDate Method

Glossary Item Box

Returns ModifyDate value of the XMP Basic schema.

This XMP value specifies the date and time the resource was last modified.

Syntax

public ImGearXMPDate getModifyDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getNickname Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getNickname Method

Glossary Item Box

Returns Nickname value of the XMP Basic schema.

This XMP value specifies a short informal name for the resource.

Syntax

public ImGearXMPString getNickname()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getRating Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getRating Method

Glossary Item Box

Returns Rating value of the XMP Basic schema.

This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.

Syntax

public ImGearXMPInteger getRating()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

getThumbnails Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : getThumbnails Method

Glossary Item Box

Gets Thumbnails value of the XMP Basic schema.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<ImGearXMPThumbnail> getThumbnails()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPThumbnail type parameter.

This XMP value specifies an alternative array of thumbnail images for a file, which can differ in characteristics such as size or image encoding.

This method is not implemented yet. Method always returns null.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setAdvisory Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setAdvisory Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Advisory value of the XMP Basic schema.

This XMP value contains an unordered array specifying properties that were edited outside the authoring application.

Syntax

public void setAdvisory(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setBaseURL Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setBaseURL Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets BaseURL value of the XMP Basic schema.

This XMP value specifies the base URL for relative URLs in the document content.

Syntax

public void setBaseURL(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setCreateDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setCreateDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets CreateDate value of the XMP Basic schema.

This XMP value specifies the date and time the resource was originally created.

Syntax

public void setCreateDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setCreatorTool Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setCreatorTool Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets CreatorTool value of the XMP Basic schema.

This XMP value specifies name of the first known tool used to create the resource.

Syntax

public void setCreatorTool(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setIdentifier Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setIdentifier Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearBasicXMPIdentifier type parameter.

Glossary Item Box

Sets Identifier value of the XMP Basic schema.

This XMP value specifies an unordered array of text strings that unambiguously identify the resource within a given context. An array item may be qualified a Scheme qualifier to denote the formal identification system to which that identifier conforms.

Syntax

public void setIdentifier(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearBasicXMPIdentifier> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearBasicXMPIdentifier type parameter.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setLabel Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setLabel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Label value of the XMP Basic schema.

This XMP value specifies a word or short phrase that identifies a document as a member of a user-defined collection.

Syntax

public void setLabel(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setMetadataDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setMetadataDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets MetadataDate value of the XMP Basic schema.

This XMP value specifies the date and time that any metadata for this resource was last changed. It should be the same as or more recent than ModifyDate.

Syntax

public void setMetadataDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setModifyDate Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setModifyDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets ModifyDate value of the XMP Basic schema.

This XMP value specifies the date and time the resource was last modified.

Syntax

public void setModifyDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setNickname Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setNickname Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Nickname value of the XMP Basic schema.

This XMP value specifies a short informal name for the resource.

Syntax

public void setNickname(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setRating Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setRating Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets Rating value of the XMP Basic schema.

This XMP value specifies a number that indicates a document's status relative to other documents, used to organize documents in a file browser. Values are user-defined within an application defined range.

Syntax

public void setRating(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%PageItemTitle%%

setThumbnails Method
com.accusoft.imagegear.formats.xmp.basic Package > ImGearBasicXMPMetadata Class : setThumbnails Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPThumbnail type parameter. This XMP value specifies an alternative array of thumbnail images for a file, which can differ in characteristics such as size or image encoding.

This method is not implemented yet.

Glossary Item Box

Sets Thumbnails value of the XMP Basic schema.

Syntax

public void setThumbnails(
   com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<ImGearXMPThumbnail> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPAlt<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPThumbnail type parameter. This XMP value specifies an alternative array of thumbnail images for a file, which can differ in characteristics such as size or image encoding.

This method is not implemented yet.

See Also

Reference

ImGearBasicXMPMetadata Class
ImGearBasicXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.basicjobticket Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP BasicJobTicket format.

Classes

Class | Description
ImGearBasicJobTicketXMPMetadata | Provides simplified access to XMP Basic Job Ticket metadata scheme.
ImGearXMPJob | Represents an XMP Job structure. This structure describes a job for a job-management system. See XMP specification for structure usage details.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.basicjobticket Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearXMPJob

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearBasicJobTicketXMPMetadata Class

Glossary Item Box

Provides simplified access to XMP Basic Job Ticket metadata scheme.

Object Model

ImGearBasicJobTicketXMPMetadata Class

Syntax

public class ImGearBasicJobTicketXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearBasicJobTicketXMPMetadata

See Also

Reference

ImGearBasicJobTicketXMPMetadata Members
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBasicJobTicketXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearBasicJobTicketXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearBasicJobTicketXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearBasicJobTicketXMPMetadata Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getJobRef | Returns JobRef value of the XMP Basic schema. This XMP value references an external job management file for a job process in which the document is being used.
public Method | setJobRef | Sets JobRef value of the XMP Basic schema. This XMP value references an external job management file for a job process in which the document is being used.
Top

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearBasicJobTicketXMPMetadata Class : ImGearBasicJobTicketXMPMetadata Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearBasicJobTicketXMPMetadata Constructor(ImGearMetadataTree) | Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.
ImGearBasicJobTicketXMPMetadata Constructor() | Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Constructor(ImGearMetadataTree)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearBasicJobTicketXMPMetadata Class > ImGearBasicJobTicketXMPMetadata Constructor : ImGearBasicJobTicketXMPMetadata Constructor(ImGearMetadataTree)
root

Glossary Item Box

Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.

Syntax

public ImGearBasicJobTicketXMPMetadata(
   ImGearMetadataTree root
)

Parameters

root

Return Value

New instance of the ImGearBasicJobTicketXMPMetadata class object.

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members
Overload List


%%PageItemTitle%%

ImGearBasicJobTicketXMPMetadata Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearBasicJobTicketXMPMetadata Class > ImGearBasicJobTicketXMPMetadata Constructor : ImGearBasicJobTicketXMPMetadata Constructor()

Glossary Item Box

Initializes a new instance of the ImGearBasicJobTicketXMPMetadata class.

Syntax

public ImGearBasicJobTicketXMPMetadata()

Return Value

New instance of the ImGearBasicJobTicketXMPMetadata class object.

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearBasicJobTicketXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearBasicJobTicketXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearBasicJobTicketXMPMetadata members.

Public Methods

 | Name | Description
public Method | getJobRef | Returns JobRef value of the XMP Basic schema. This XMP value references an external job management file for a job process in which the document is being used.
public Method | setJobRef | Sets JobRef value of the XMP Basic schema. This XMP value references an external job management file for a job process in which the document is being used.
Top

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%%

getJobRef Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearBasicJobTicketXMPMetadata Class : getJobRef Method

Glossary Item Box

Returns JobRef value of the XMP Basic schema.

This XMP value references an external job management file for a job process in which the document is being used.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPJob> getJobRef()

Return Value

generic class value with ImGearXMPJob type parameter.

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


%%PageItemTitle%%

setJobRef Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearBasicJobTicketXMPMetadata Class : setJobRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearXMPJob type parameter.

Glossary Item Box

Sets JobRef value of the XMP Basic schema.

This XMP value references an external job management file for a job process in which the document is being used.

Syntax

public void setJobRef(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPJob> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearXMPJob type parameter.

See Also

Reference

ImGearBasicJobTicketXMPMetadata Class
ImGearBasicJobTicketXMPMetadata Members


%%PageItemTitle%%

ImGearXMPJob Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearXMPJob Class

Glossary Item Box

Represents an XMP Job structure.

This structure describes a job for a job-management system. See XMP specification for structure usage details.

Object Model

ImGearXMPJob ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPJob
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.basicjobticket.ImGearXMPJob

See Also

Reference

ImGearXMPJob Members
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPJob Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearXMPJob Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPJob.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPJob Constructor | Initializes a new instance of the ImGearXMPJob class.
Top

Public Methods

 | Name | Description
public Method | getId | Returns unique ID for the job. This field is a reference into some external job management system.
public Method | getName | Returns informal name of the job. This name is for user display and informal systems.
public Method | getURL | Returns a file URL referencing an external job management file.
public Method | setId | Sets unique ID for the job. This field is a reference into some external job management system.
public Method | setName | Sets informal name of the job. This name is for user display and informal systems.
public Method | setURL | Sets a file URL referencing an external job management file.
Top

See Also

Reference

ImGearXMPJob Class
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%%

ImGearXMPJob Constructor
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : ImGearXMPJob Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPJob class.

Syntax

public ImGearXMPJob()

Return Value

New instance of the ImGearXMPJob class object.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPJob Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.basicjobticket Package : ImGearXMPJob Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPJob members.

Public Methods

 | Name | Description
public Method | getId | Returns unique ID for the job. This field is a reference into some external job management system.
public Method | getName | Returns informal name of the job. This name is for user display and informal systems.
public Method | getURL | Returns a file URL referencing an external job management file.
public Method | setId | Sets unique ID for the job. This field is a reference into some external job management system.
public Method | setName | Sets informal name of the job. This name is for user display and informal systems.
public Method | setURL | Sets a file URL referencing an external job management file.
Top

See Also

Reference

ImGearXMPJob Class
com.accusoft.imagegear.formats.xmp.basicjobticket Package


%%PageItemTitle%%

getId Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : getId Method

Glossary Item Box

Returns unique ID for the job. This field is a reference into some external job management system.

Syntax

public ImGearXMPString getId()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : getName Method

Glossary Item Box

Returns informal name of the job. This name is for user display and informal systems.

Syntax

public ImGearXMPString getName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

getURL Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : getURL Method

Glossary Item Box

Returns a file URL referencing an external job management file.

Syntax

public ImGearXMPString getURL()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

setId Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : setId Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets unique ID for the job. This field is a reference into some external job management system.

Syntax

public void setId(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : setName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets informal name of the job. This name is for user display and informal systems.

Syntax

public void setName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%PageItemTitle%%

setURL Method
com.accusoft.imagegear.formats.xmp.basicjobticket Package > ImGearXMPJob Class : setURL Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets a file URL referencing an external job management file.

Syntax

public void setURL(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPJob Class
ImGearXMPJob Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.dublincore Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP DublinCore format.

Classes

Class | Description
ImGearDublinCoreXMPMetadata | Provides simplified access to XMP Dublin Core metadata scheme.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.dublincore Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dublincore Package : ImGearDublinCoreXMPMetadata Class

Glossary Item Box

Provides simplified access to XMP Dublin Core metadata scheme.

Object Model

ImGearDublinCoreXMPMetadata ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPLangAlt Class

Syntax

public class ImGearDublinCoreXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.dublincore.ImGearDublinCoreXMPMetadata

See Also

Reference

ImGearDublinCoreXMPMetadata Members
com.accusoft.imagegear.formats.xmp.dublincore Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDublinCoreXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dublincore Package : ImGearDublinCoreXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearDublinCoreXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearDublinCoreXMPMetadata Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getContributor | Returns Contributor value of the XMP Dublin Core schema. This XMP value specifies contributors to the resource (other than the authors).
public Method | getCoverage | Returns Coverage value of the XMP Dublin Core schema. This XMP value specifies the extent or scope of the resource.
public Method | getCreator | Returns Creator value of the XMP Dublin Core schema. This XMP value specifies the authors of the resource (listed in order of precedence, if significant).
public Method | getDate | Returns Date value of the XMP Dublin Core schema. This XMP value specifies date(s) that something interesting happened to the resource.
public Method | getDescription | Returns Description value of the XMP Dublin Core schema. This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.
public Method | getFormat | Returns Format value of the XMP Dublin Core schema. This XMP value specifies the file format used when saving the resource. Tools and applications should set this value to the save format of the data.
public Method | getIdentifier | Returns Identifier value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the resource.
public Method | getLanguage | Returns Language value of the XMP Dublin Core schema. This XMP value specifies an unordered array specifying the languages used in the resource.
public Method | getPublisher | Returns Publisher value of the XMP Dublin Core schema. This XMP value specifies external Publishers.
public Method | getRelation | Returns Relation value of the XMP Dublin Core schema. This XMP value specifies relationships to other documents.
public Method | getRights | Returns Rights value of the XMP Dublin Core schema. This XMP value specifies informal rights statement, selected by language.
public Method | getSource | Returns Source value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the work from which this resource was derived.
public Method | getSubject | Returns Subject value of the XMP Dublin Core schema. This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.
public Method | getTitle | Returns Title value of the XMP Dublin Core schema. This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.
public Method | getType | Returns Type value of the XMP Dublin Core schema. This XMP value specifies a document type; for example, novel, poem, or working paper.
public Method | setContributor | Sets Contributor value of the XMP Dublin Core schema. This XMP value specifies contributors to the resource (other than the authors).
public Method | setCoverage | Sets Coverage value of the XMP Dublin Core schema. This XMP value specifies the extent or scope of the resource.
public Method | setCreator | Sets Creator value of the XMP Dublin Core schema. This XMP value specifies the authors of the resource (listed in order of precedence, if significant).
public Method | setDate | Sets Date value of the XMP Dublin Core schema. This XMP value specifies date(s) that something interesting happened to the resource.
public Method | setDescription | Sets Description value of the XMP Dublin Core schema. This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.
public Method | setFormat | Sets Format value of the XMP Dublin Core schema. This XMP value specifies the file format used when saving the resource. Tools and applications should use this method to the save format of the data.
public Method | setIdentifier | Sets Identifier value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the resource.
public Method | setLanguage | Sets Language value of the XMP Dublin Core schema. This XMP value specifies an unordered array specifying the languages used in the resource.
public Method | setPublisher | Sets Publisher value of the XMP Dublin Core schema. This XMP value specifies external Publishers.
public Method | setRelation | Sets Relation value of the XMP Dublin Core schema. This XMP value specifies relationships to other documents.
public Method | setRights | Sets Rights value of the XMP Dublin Core schema. This XMP value specifies informal rights statement, selected by language.
public Method | setSource | Sets Source value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the work from which this resource was derived.
public Method | setSubject | Sets Subject value of the XMP Dublin Core schema. This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.
public Method | setTitle | Sets Title value of the XMP Dublin Core schema. This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.
public Method | setType | Sets Type value of the XMP Dublin Core schema. This XMP value specifies a document type; for example, novel, poem, or working paper.
Top

See Also

Reference

ImGearDublinCoreXMPMetadata Class
com.accusoft.imagegear.formats.xmp.dublincore Package


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : ImGearDublinCoreXMPMetadata Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearDublinCoreXMPMetadata Constructor(ImGearMetadataTree) | Initializes a new instance of the ImGearDublinCoreXMPMetadata class.
ImGearDublinCoreXMPMetadata Constructor() | Initializes a new instance of the ImGearDublinCoreXMPMetadata class.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Constructor(ImGearMetadataTree)
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class > ImGearDublinCoreXMPMetadata Constructor : ImGearDublinCoreXMPMetadata Constructor(ImGearMetadataTree)
root

Glossary Item Box

Initializes a new instance of the ImGearDublinCoreXMPMetadata class.

Syntax

public ImGearDublinCoreXMPMetadata(
   ImGearMetadataTree root
)

Parameters

root

Return Value

New instance of the ImGearDublinCoreXMPMetadata class object.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members
Overload List


%%PageItemTitle%%

ImGearDublinCoreXMPMetadata Constructor()
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class > ImGearDublinCoreXMPMetadata Constructor : ImGearDublinCoreXMPMetadata Constructor()

Glossary Item Box

Initializes a new instance of the ImGearDublinCoreXMPMetadata class.

Syntax

public ImGearDublinCoreXMPMetadata()

Return Value

New instance of the ImGearDublinCoreXMPMetadata class object.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDublinCoreXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dublincore Package : ImGearDublinCoreXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearDublinCoreXMPMetadata members.

Public Methods

 | Name | Description
public Method | getContributor | Returns Contributor value of the XMP Dublin Core schema. This XMP value specifies contributors to the resource (other than the authors).
public Method | getCoverage | Returns Coverage value of the XMP Dublin Core schema. This XMP value specifies the extent or scope of the resource.
public Method | getCreator | Returns Creator value of the XMP Dublin Core schema. This XMP value specifies the authors of the resource (listed in order of precedence, if significant).
public Method | getDate | Returns Date value of the XMP Dublin Core schema. This XMP value specifies date(s) that something interesting happened to the resource.
public Method | getDescription | Returns Description value of the XMP Dublin Core schema. This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.
public Method | getFormat | Returns Format value of the XMP Dublin Core schema. This XMP value specifies the file format used when saving the resource. Tools and applications should set this value to the save format of the data.
public Method | getIdentifier | Returns Identifier value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the resource.
public Method | getLanguage | Returns Language value of the XMP Dublin Core schema. This XMP value specifies an unordered array specifying the languages used in the resource.
public Method | getPublisher | Returns Publisher value of the XMP Dublin Core schema. This XMP value specifies external Publishers.
public Method | getRelation | Returns Relation value of the XMP Dublin Core schema. This XMP value specifies relationships to other documents.
public Method | getRights | Returns Rights value of the XMP Dublin Core schema. This XMP value specifies informal rights statement, selected by language.
public Method | getSource | Returns Source value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the work from which this resource was derived.
public Method | getSubject | Returns Subject value of the XMP Dublin Core schema. This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.
public Method | getTitle | Returns Title value of the XMP Dublin Core schema. This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.
public Method | getType | Returns Type value of the XMP Dublin Core schema. This XMP value specifies a document type; for example, novel, poem, or working paper.
public Method | setContributor | Sets Contributor value of the XMP Dublin Core schema. This XMP value specifies contributors to the resource (other than the authors).
public Method | setCoverage | Sets Coverage value of the XMP Dublin Core schema. This XMP value specifies the extent or scope of the resource.
public Method | setCreator | Sets Creator value of the XMP Dublin Core schema. This XMP value specifies the authors of the resource (listed in order of precedence, if significant).
public Method | setDate | Sets Date value of the XMP Dublin Core schema. This XMP value specifies date(s) that something interesting happened to the resource.
public Method | setDescription | Sets Description value of the XMP Dublin Core schema. This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.
public Method | setFormat | Sets Format value of the XMP Dublin Core schema. This XMP value specifies the file format used when saving the resource. Tools and applications should use this method to the save format of the data.
public Method | setIdentifier | Sets Identifier value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the resource.
public Method | setLanguage | Sets Language value of the XMP Dublin Core schema. This XMP value specifies an unordered array specifying the languages used in the resource.
public Method | setPublisher | Sets Publisher value of the XMP Dublin Core schema. This XMP value specifies external Publishers.
public Method | setRelation | Sets Relation value of the XMP Dublin Core schema. This XMP value specifies relationships to other documents.
public Method | setRights | Sets Rights value of the XMP Dublin Core schema. This XMP value specifies informal rights statement, selected by language.
public Method | setSource | Sets Source value of the XMP Dublin Core schema. This XMP value specifies unique identifier of the work from which this resource was derived.
public Method | setSubject | Sets Subject value of the XMP Dublin Core schema. This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.
public Method | setTitle | Sets Title value of the XMP Dublin Core schema. This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.
public Method | setType | Sets Type value of the XMP Dublin Core schema. This XMP value specifies a document type; for example, novel, poem, or working paper.
Top

See Also

Reference

ImGearDublinCoreXMPMetadata Class
com.accusoft.imagegear.formats.xmp.dublincore Package


%%PageItemTitle%%

getContributor Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getContributor Method

Glossary Item Box

Returns Contributor value of the XMP Dublin Core schema.

This XMP value specifies contributors to the resource (other than the authors).

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getContributor()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getCoverage Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getCoverage Method

Glossary Item Box

Returns Coverage value of the XMP Dublin Core schema.

This XMP value specifies the extent or scope of the resource.

Syntax

public ImGearXMPString getCoverage()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getCreator Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getCreator Method

Glossary Item Box

Returns Creator value of the XMP Dublin Core schema.

This XMP value specifies the authors of the resource (listed in order of precedence, if significant).

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getCreator()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

GetDate Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : GetDate Method
propName

Glossary Item Box

Syntax

protected ImGearXMPDate GetDate(
   java.lang.String propName
)

Parameters

propName

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getDescription Method

Glossary Item Box

Returns Description value of the XMP Dublin Core schema.

This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.

Syntax

public ImGearXMPLangAlt getDescription()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getFormat Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getFormat Method

Glossary Item Box

Returns Format value of the XMP Dublin Core schema.

This XMP value specifies the file format used when saving the resource. Tools and applications should set this value to the save format of the data.

Syntax

public ImGearXMPString getFormat()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getIdentifier Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getIdentifier Method

Glossary Item Box

Returns Identifier value of the XMP Dublin Core schema.

This XMP value specifies unique identifier of the resource.

Syntax

public ImGearXMPString getIdentifier()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getLanguage Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getLanguage Method

Glossary Item Box

Returns Language value of the XMP Dublin Core schema.

This XMP value specifies an unordered array specifying the languages used in the resource.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getLanguage()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getPublisher Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getPublisher Method

Glossary Item Box

Returns Publisher value of the XMP Dublin Core schema.

This XMP value specifies external Publishers.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getPublisher()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getRelation Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getRelation Method

Glossary Item Box

Returns Relation value of the XMP Dublin Core schema.

This XMP value specifies relationships to other documents.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getRelation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getRights Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getRights Method

Glossary Item Box

Returns Rights value of the XMP Dublin Core schema.

This XMP value specifies informal rights statement, selected by language.

Syntax

public ImGearXMPLangAlt getRights()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getSource Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getSource Method

Glossary Item Box

Returns Source value of the XMP Dublin Core schema.

This XMP value specifies unique identifier of the work from which this resource was derived.

Syntax

public ImGearXMPString getSource()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getSubject Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getSubject Method

Glossary Item Box

Returns Subject value of the XMP Dublin Core schema.

This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getSubject()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getTitle Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getTitle Method

Glossary Item Box

Returns Title value of the XMP Dublin Core schema.

This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.

Syntax

public ImGearXMPLangAlt getTitle()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : getType Method

Glossary Item Box

Returns Type value of the XMP Dublin Core schema.

This XMP value specifies a document type; for example, novel, poem, or working paper.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setContributor Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setContributor Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Contributor value of the XMP Dublin Core schema.

This XMP value specifies contributors to the resource (other than the authors).

Syntax

public void setContributor(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setCoverage Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setCoverage Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Coverage value of the XMP Dublin Core schema.

This XMP value specifies the extent or scope of the resource.

Syntax

public void setCoverage(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setCreator Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setCreator Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Creator value of the XMP Dublin Core schema.

This XMP value specifies the authors of the resource (listed in order of precedence, if significant).

Syntax

public void setCreator(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

SetDate Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : SetDate Method
propName
value

Glossary Item Box

Syntax

protected void SetDate(
   java.lang.String propName,
   ImGearXMPDate value
)

Parameters

propName
value

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setDescription Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setDescription Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Description value of the XMP Dublin Core schema.

This XMP value specifies a textual description of the content of the resource. Multiple values may be present for different languages.

Syntax

public void setDescription(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setFormat Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setFormat Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Format value of the XMP Dublin Core schema.

This XMP value specifies the file format used when saving the resource. Tools and applications should use this method to the save format of the data.

Syntax

public void setFormat(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setIdentifier Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setIdentifier Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Identifier value of the XMP Dublin Core schema.

This XMP value specifies unique identifier of the resource.

Syntax

public void setIdentifier(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setLanguage Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setLanguage Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Language value of the XMP Dublin Core schema.

This XMP value specifies an unordered array specifying the languages used in the resource.

Syntax

public void setLanguage(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setPublisher Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setPublisher Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Publisher value of the XMP Dublin Core schema.

This XMP value specifies external Publishers.

Syntax

public void setPublisher(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setRelation Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setRelation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Relation value of the XMP Dublin Core schema.

This XMP value specifies relationships to other documents.

Syntax

public void setRelation(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setRights Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setRights Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Rights value of the XMP Dublin Core schema.

This XMP value specifies informal rights statement, selected by language.

Syntax

public void setRights(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setSource Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setSource Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Source value of the XMP Dublin Core schema.

This XMP value specifies unique identifier of the work from which this resource was derived.

Syntax

public void setSource(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setSubject Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setSubject Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Subject value of the XMP Dublin Core schema.

This XMP value specifies an unordered array of descriptive phrases or keywords that specify the topic of the content of the resource.

Syntax

public void setSubject(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setTitle Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setTitle Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Title value of the XMP Dublin Core schema.

This XMP value specifies the title of the document, or the name given to the resource. Typically, it will be a name by which the resource is formally known.

Syntax

public void setTitle(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%PageItemTitle%%

setType Method
com.accusoft.imagegear.formats.xmp.dublincore Package > ImGearDublinCoreXMPMetadata Class : setType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Type value of the XMP Dublin Core schema.

This XMP value specifies a document type; for example, novel, poem, or working paper.

Syntax

public void setType(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearDublinCoreXMPMetadata Class
ImGearDublinCoreXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.dynamicmedia Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP DynamicMedia format.

Classes

Class | Description
ImGearDynamicMediaXMPMetadata | Provides simplified access to Dynamic Media XMP metadata scheme.
ImGearXMPBeatSpliceStretch | Represents an XMP BeatSpliceStretch structure. This class contains a set of parameters used when stretching audio using the Beat Splice stretch mode.
ImGearXMPMarker | Represents an XMP Marker structure. This class is used to desribe an important location in a video sequence.
ImGearXMPMedia | Represents an XMP Media structure. This class specifies a reference to a media asset.
ImGearXMPProjectLink | Represents an XMP ProjectLink structure. This class specifies the type of a video file and path of the project that created it.
ImGearXMPTime | Represents an XMP Time structure. This class provides a representation of a time value in seconds.
ImGearXMPTimecode | Represents an XMP Timecode structure. This class represents a time value in video.
ImGearXMPTimeScaleStretch | Represents an XMP TimeScaleStretch structure. This class contains a set of parameters used when stretching audio using the Time-Scale stretch mode.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.dynamicmedia Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPBeatSpliceStretch
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMarker
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMedia
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPProjectLink
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTime
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimecode
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimeScaleStretch

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearDynamicMediaXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearDynamicMediaXMPMetadata Class

Glossary Item Box

Provides simplified access to Dynamic Media XMP metadata scheme.

Object Model

ImGearDynamicMediaXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPBeatSpliceStretch ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString ClassImGearXMPBoolean ClassImGearXMPDate ClassImGearXMPReal ClassImGearXMPTime ClassImGearXMPProjectLink ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPReal ClassImGearXMPTimeScaleStretch ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPColorant ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDimensions ClassImGearXMPDate ClassImGearXMPRational ClassImGearXMPString Class

Syntax

public class ImGearDynamicMediaXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearDynamicMediaXMPMetadata

See Also

Reference

ImGearDynamicMediaXMPMetadata Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDynamicMediaXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearDynamicMediaXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearDynamicMediaXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearDynamicMediaXMPMetadata Constructor | Initializes a new instance of the ImGearDynamicMediaXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getAbsPeakAudioFilePath | Returns AbsPeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.
public Method | getAlbum | Returns Album value of the Dynamic Media XMP schema. This XMP value specifies name of the album.
public Method | getAltTapeName | Returns AltTapeName value of the Dynamic Media XMP schema. This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.
public Method | getArtist | Returns Artist value of the Dynamic Media XMP schema. This XMP value specifies name of the artist or artists.
public Method | getAudioChannelType | Returns AudioChannelType value of the Dynamic Media XMP schema. This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.
public Method | getAudioCompressor | Returns AudioCompressor value of the Dynamic Media XMP schema. This XMP value specifies audio compression used. For example, MP3.
public Method | getAudioModDate | Returns AudioModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the audio was last modified.
public Method | getAudioSampleRate | Returns AudioSampleRate value of the Dynamic Media XMP schema. This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.
public Method | getAudioSampleType | Returns AudioSampleType value of the Dynamic Media XMP schema. This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.
public Method | getBeatSpliceParams | Returns BeatSpliceParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Beat Splice stretch mode.
public Method | getComposer | Returns Composer value of the Dynamic Media XMP schema. This XMP value specifies composer's name.
public Method | getContributedMedia | Returns ContributedMedia value of the Dynamic Media XMP schema. This XMP value specifies unordered list of all media used to create this media.
public Method | getCopyright | Returns Copyright value of the Dynamic Media XMP schema. This XMP value specifies copyright information.
public Method | getDuration | Returns Duration value of the Dynamic Media XMP schema. This XMP value specifies duration of the media file.
public Method | getEngineer | Returns Engineer value of the Dynamic Media XMP schema. This XMP value specifies engineer's name.
public Method | getFileDataRate | Returns FileDataRate value of the Dynamic Media XMP schema. This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.
public Method | getGenre | Returns Genre value of the Dynamic Media XMP schema. This XMP value specifies name of the genre.
public Method | getInstrument | Returns Instrument value of the Dynamic Media XMP schema. This XMP value specifies musical instrument.
public Method | getIntroTime | Returns IntroTime value of the Dynamic Media XMP schema. This XMP value specifies duration of lead time for queuing music.
public Method | getKey | Returns Key value of the Dynamic Media XMP schema. This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.
public Method | getLogComment | Returns LogComment value of the Dynamic Media XMP schema. This XMP value specifies log comments.
public Method | getLoop | Returns Loop value of the Dynamic Media XMP schema. This XMP value specifies true, the clip can be looped seemlessly.
public Method | getMarkers | Returns Markers value of the Dynamic Media XMP schema. This XMP value specifies ordered list of markers.
public Method | getMetadataModDate | Returns MetadataModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the metadata was last modified.
public Method | getNumberOfBeats | Returns NumberOfBeats value of the Dynamic Media XMP schema. This XMP value specifies number of beats.
public Method | getOutCue | Returns OutCue value of the Dynamic Media XMP schema. This XMP value specifies time at which to fade out.
public Method | getProjectRef | Returns ProjectRef value of the Dynamic Media XMP schema. This XMP value specifies reference to the project that created this file.
public Method | getPullDown | Returns PullDown value of the Dynamic Media XMP schema. This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.
public Method | getRelativePeakAudioFilePath | Returns RelativePeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.
public Method | getRelativeTimeStamp | Returns RelativeTimestamp value of the Dynamic Media XMP schema. This XMP value specifies start time of the media inside the audio project.
public Method | getReleaseDate | Returns ReleaseDate value of the Dynamic Media XMP schema. This XMP value specifies date the title was released.
public Method | getResampleParams | Returns ResampleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Resample stretch mode.
public Method | getScaleType | Returns ScaleType value of the Dynamic Media XMP schema. This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.
public Method | getScene | Returns Scene value of the Dynamic Media XMP schema. This XMP value specifies name of the scene.
public Method | getShotDate | Returns ShotDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was shot.
public Method | getShotlocation | Returns ShotLocation value of the Dynamic Media XMP schema. This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.
public Method | getShotName | Returns ShotName value of the Dynamic Media XMP schema. This XMP value specifies name of the shot or take.
public Method | getSpeakerPlacement | Returns SpeakerPlacement value of the Dynamic Media XMP schema. This XMP value specifies description of the speaker angles.
public Method | getStretchMode | Returns StretchMode value of the Dynamic Media XMP schema. This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.
public Method | getTapeName | Returns TapeName value of the Dynamic Media XMP schema. This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.
public Method | getTempo | Returns Tempo value of the Dynamic Media XMP schema. This XMP value specifies audio's tempo.
public Method | getTimeScaleParams | Returns TimeScaleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Time-Scale stretch mode.
public Method | getTimeSignature | Returns TimeSignature value of the Dynamic Media XMP schema. This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.
public Method | getTrackNumber | Returns TrackNumber value of the Dynamic Media XMP schema. This XMP value specifies numeric value indicating the order of the audio file within its original recording.
public Method | getVideoAlphaMode | Returns VideoAlphaMode value of the Dynamic Media XMP schema. This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.
public Method | getVideoAlphaPremultipleColor | Returns VideoAlphaPremultipleColor value of the Dynamic Media XMP schema. This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.
public Method | getVideoAlphaUnityIsTransparent | Returns VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema. This XMP value specifies true, unity is clear, when false, it is opaque.
public Method | getVideoColorSpace | Returns VideoColorSpace value of the Dynamic Media XMP schema. This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).
public Method | getVideoCompressor | Returns VideoCompressor value of the Dynamic Media XMP schema. This XMP value specifies compression used. For example, jpeg.
public Method | getVideoFieldOrder | Returns VideoFieldOrder value of the Dynamic Media XMP schema. This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.
public Method | getVideoFrameRate | Returns VideoFrameRate value of the Dynamic Media XMP schema. This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.
public Method | getVideoFrameSize | Returns VideoFrameSize value of the Dynamic Media XMP schema. This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.
public Method | getVideoModDate | Returns VideoModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was last modified.
public Method | getVideoPixelAspectRatio | Returns VideoPixelAspectRatio value of the Dynamic Media XMP schema. This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.
public Method | getVideoPixelDepth | Returns VideoPixelDepth value of the Dynamic Media XMP schema. This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.
public Method | setAbsPeakAudioFilePath | Sets AbsPeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.
public Method | setAlbum | Sets Album value of the Dynamic Media XMP schema. This XMP value specifies name of the album.
public Method | setAltTapeName | Sets AltTapeName value of the Dynamic Media XMP schema. This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.
public Method | setArtist | Sets Artist value of the Dynamic Media XMP schema. This XMP value specifies name of the artist or artists.
public Method | setAudioChannelType | Sets AudioChannelType value of the Dynamic Media XMP schema. This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.
public Method | setAudioCompressor | Sets AudioCompressor value of the Dynamic Media XMP schema. This XMP value specifies audio compression used. For example, MP3.
public Method | setAudioModDate | Sets AudioModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the audio was last modified.
public Method | setAudioSampleRate | Sets AudioSampleRate value of the Dynamic Media XMP schema. This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.
public Method | setAudioSampleType | Sets AudioSampleType value of the Dynamic Media XMP schema. This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.
public Method | setBeatSpliceParams | Sets BeatSpliceParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Beat Splice stretch mode.
public Method | setComposer | Sets Composer value of the Dynamic Media XMP schema. This XMP value specifies composer's name.
public Method | setContributedMedia | Sets ContributedMedia value of the Dynamic Media XMP schema. This XMP value specifies unordered list of all media used to create this media.
public Method | setCopyright | Sets Copyright value of the Dynamic Media XMP schema. This XMP value specifies copyright information.
public Method | setDuration | Sets Duration value of the Dynamic Media XMP schema. This XMP value specifies duration of the media file.
public Method | setEngineer | Sets Engineer value of the Dynamic Media XMP schema. This XMP value specifies engineer's name.
public Method | setFileDataRate | Sets FileDataRate value of the Dynamic Media XMP schema. This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.
public Method | setGenre | Sets Genre value of the Dynamic Media XMP schema. This XMP value specifies name of the genre.
public Method | setInstrument | Sets Instrument value of the Dynamic Media XMP schema. This XMP value specifies musical instrument.
public Method | setIntroTime | Sets IntroTime value of the Dynamic Media XMP schema. This XMP value specifies duration of lead time for queuing music.
public Method | setKey | Sets Key value of the Dynamic Media XMP schema. This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.
public Method | setLogComment | Sets LogComment value of the Dynamic Media XMP schema. This XMP value specifies log comments.
public Method | setLoop | Sets Loop value of the Dynamic Media XMP schema. This XMP value specifies true, the clip can be looped seemlessly.
public Method | setMarkers | Sets Markers value of the Dynamic Media XMP schema. This XMP value specifies ordered list of markers.
public Method | setMetadataModDate | Sets MetadataModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the metadata was last modified.
public Method | setNumberOfBeats | Sets NumberOfBeats value of the Dynamic Media XMP schema. This XMP value specifies number of beats.
public Method | setOutCue | Sets OutCue value of the Dynamic Media XMP schema. This XMP value specifies time at which to fade out.
public Method | setProjectRef | Sets ProjectRef value of the Dynamic Media XMP schema. This XMP value specifies reference to the project that created this file.
public Method | setPullDown | Sets PullDown value of the Dynamic Media XMP schema. This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.
public Method | setRelativePeakAudioFilePath | Sets RelativePeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.
public Method | setRelativeTimeStamp | Sets RelativeTimestamp value of the Dynamic Media XMP schema. This XMP value specifies start time of the media inside the audio project.
public Method | setReleaseDate | Sets ReleaseDate value of the Dynamic Media XMP schema. This XMP value specifies date the title was released.
public Method | setResampleParams | Sets ResampleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Resample stretch mode.
public Method | setScaleType | Sets ScaleType value of the Dynamic Media XMP schema. This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.
public Method | setScene | Sets Scene value of the Dynamic Media XMP schema. This XMP value specifies name of the scene.
public Method | setShotDate | Sets ShotDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was shot.
public Method | setShotlocation | Sets ShotLocation value of the Dynamic Media XMP schema. This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.
public Method | setShotName | Sets ShotName value of the Dynamic Media XMP schema. This XMP value specifies name of the shot or take.
public Method | setSpeakerPlacement | Sets SpeakerPlacement value of the Dynamic Media XMP schema. This XMP value specifies description of the speaker angles.
public Method | setStretchMode | Sets StretchMode value of the Dynamic Media XMP schema. This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.
public Method | setTapeName | Sets TapeName value of the Dynamic Media XMP schema. This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.
public Method | setTempo | Sets Tempo value of the Dynamic Media XMP schema. This XMP value specifies audio's tempo.
public Method | setTimeScaleParams | Sets TimeScaleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Time-Scale stretch mode.
public Method | setTimeSignature | Sets TimeSignature value of the Dynamic Media XMP schema. This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.
public Method | setTrackNumber | Sets TrackNumber value of the Dynamic Media XMP schema. This XMP value specifies numeric value indicating the order of the audio file within its original recording.
public Method | setVideoAlphaMode | Sets VideoAlphaMode value of the Dynamic Media XMP schema. This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.
public Method | setVideoAlphaPremultipleColor | Sets VideoAlphaPremultipleColor value of the Dynamic Media XMP schema. This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.
public Method | setVideoAlphaUnityIsTransparent | Sets VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema. This XMP value specifies true, unity is clear, when false, it is opaque.
public Method | setVideoColorSpace | Sets VideoColorSpace value of the Dynamic Media XMP schema. This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).
public Method | setVideoCompressor | Sets VideoCompressor value of the Dynamic Media XMP schema. This XMP value specifies compression used. For example, jpeg.
public Method | setVideoFieldOrder | Sets VideoFieldOrder value of the Dynamic Media XMP schema. This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.
public Method | setVideoFrameRate | Sets VideoFrameRate value of the Dynamic Media XMP schema. This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.
public Method | setVideoFrameSize | Sets VideoFrameSize value of the Dynamic Media XMP schema. This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.
public Method | setVideoModDate | Sets VideoModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was last modified.
public Method | setVideoPixelAspectRatio | Sets VideoPixelAspectRatio value of the Dynamic Media XMP schema. This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.
public Method | setVideoPixelDepth | Sets VideoPixelDepth value of the Dynamic Media XMP schema. This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.
Top

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearDynamicMediaXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : ImGearDynamicMediaXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearDynamicMediaXMPMetadata class.

Syntax

public ImGearDynamicMediaXMPMetadata()

Return Value

New instance of the ImGearDynamicMediaXMPMetadata class object.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDynamicMediaXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearDynamicMediaXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearDynamicMediaXMPMetadata members.

Public Methods

 | Name | Description
public Method | getAbsPeakAudioFilePath | Returns AbsPeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.
public Method | getAlbum | Returns Album value of the Dynamic Media XMP schema. This XMP value specifies name of the album.
public Method | getAltTapeName | Returns AltTapeName value of the Dynamic Media XMP schema. This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.
public Method | getArtist | Returns Artist value of the Dynamic Media XMP schema. This XMP value specifies name of the artist or artists.
public Method | getAudioChannelType | Returns AudioChannelType value of the Dynamic Media XMP schema. This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.
public Method | getAudioCompressor | Returns AudioCompressor value of the Dynamic Media XMP schema. This XMP value specifies audio compression used. For example, MP3.
public Method | getAudioModDate | Returns AudioModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the audio was last modified.
public Method | getAudioSampleRate | Returns AudioSampleRate value of the Dynamic Media XMP schema. This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.
public Method | getAudioSampleType | Returns AudioSampleType value of the Dynamic Media XMP schema. This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.
public Method | getBeatSpliceParams | Returns BeatSpliceParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Beat Splice stretch mode.
public Method | getComposer | Returns Composer value of the Dynamic Media XMP schema. This XMP value specifies composer's name.
public Method | getContributedMedia | Returns ContributedMedia value of the Dynamic Media XMP schema. This XMP value specifies unordered list of all media used to create this media.
public Method | getCopyright | Returns Copyright value of the Dynamic Media XMP schema. This XMP value specifies copyright information.
public Method | getDuration | Returns Duration value of the Dynamic Media XMP schema. This XMP value specifies duration of the media file.
public Method | getEngineer | Returns Engineer value of the Dynamic Media XMP schema. This XMP value specifies engineer's name.
public Method | getFileDataRate | Returns FileDataRate value of the Dynamic Media XMP schema. This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.
public Method | getGenre | Returns Genre value of the Dynamic Media XMP schema. This XMP value specifies name of the genre.
public Method | getInstrument | Returns Instrument value of the Dynamic Media XMP schema. This XMP value specifies musical instrument.
public Method | getIntroTime | Returns IntroTime value of the Dynamic Media XMP schema. This XMP value specifies duration of lead time for queuing music.
public Method | getKey | Returns Key value of the Dynamic Media XMP schema. This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.
public Method | getLogComment | Returns LogComment value of the Dynamic Media XMP schema. This XMP value specifies log comments.
public Method | getLoop | Returns Loop value of the Dynamic Media XMP schema. This XMP value specifies true, the clip can be looped seemlessly.
public Method | getMarkers | Returns Markers value of the Dynamic Media XMP schema. This XMP value specifies ordered list of markers.
public Method | getMetadataModDate | Returns MetadataModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the metadata was last modified.
public Method | getNumberOfBeats | Returns NumberOfBeats value of the Dynamic Media XMP schema. This XMP value specifies number of beats.
public Method | getOutCue | Returns OutCue value of the Dynamic Media XMP schema. This XMP value specifies time at which to fade out.
public Method | getProjectRef | Returns ProjectRef value of the Dynamic Media XMP schema. This XMP value specifies reference to the project that created this file.
public Method | getPullDown | Returns PullDown value of the Dynamic Media XMP schema. This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.
public Method | getRelativePeakAudioFilePath | Returns RelativePeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.
public Method | getRelativeTimeStamp | Returns RelativeTimestamp value of the Dynamic Media XMP schema. This XMP value specifies start time of the media inside the audio project.
public Method | getReleaseDate | Returns ReleaseDate value of the Dynamic Media XMP schema. This XMP value specifies date the title was released.
public Method | getResampleParams | Returns ResampleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Resample stretch mode.
public Method | getScaleType | Returns ScaleType value of the Dynamic Media XMP schema. This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.
public Method | getScene | Returns Scene value of the Dynamic Media XMP schema. This XMP value specifies name of the scene.
public Method | getShotDate | Returns ShotDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was shot.
public Method | getShotlocation | Returns ShotLocation value of the Dynamic Media XMP schema. This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.
public Method | getShotName | Returns ShotName value of the Dynamic Media XMP schema. This XMP value specifies name of the shot or take.
public Method | getSpeakerPlacement | Returns SpeakerPlacement value of the Dynamic Media XMP schema. This XMP value specifies description of the speaker angles.
public Method | getStretchMode | Returns StretchMode value of the Dynamic Media XMP schema. This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.
public Method | getTapeName | Returns TapeName value of the Dynamic Media XMP schema. This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.
public Method | getTempo | Returns Tempo value of the Dynamic Media XMP schema. This XMP value specifies audio's tempo.
public Method | getTimeScaleParams | Returns TimeScaleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Time-Scale stretch mode.
public Method | getTimeSignature | Returns TimeSignature value of the Dynamic Media XMP schema. This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.
public Method | getTrackNumber | Returns TrackNumber value of the Dynamic Media XMP schema. This XMP value specifies numeric value indicating the order of the audio file within its original recording.
public Method | getVideoAlphaMode | Returns VideoAlphaMode value of the Dynamic Media XMP schema. This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.
public Method | getVideoAlphaPremultipleColor | Returns VideoAlphaPremultipleColor value of the Dynamic Media XMP schema. This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.
public Method | getVideoAlphaUnityIsTransparent | Returns VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema. This XMP value specifies true, unity is clear, when false, it is opaque.
public Method | getVideoColorSpace | Returns VideoColorSpace value of the Dynamic Media XMP schema. This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).
public Method | getVideoCompressor | Returns VideoCompressor value of the Dynamic Media XMP schema. This XMP value specifies compression used. For example, jpeg.
public Method | getVideoFieldOrder | Returns VideoFieldOrder value of the Dynamic Media XMP schema. This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.
public Method | getVideoFrameRate | Returns VideoFrameRate value of the Dynamic Media XMP schema. This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.
public Method | getVideoFrameSize | Returns VideoFrameSize value of the Dynamic Media XMP schema. This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.
public Method | getVideoModDate | Returns VideoModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was last modified.
public Method | getVideoPixelAspectRatio | Returns VideoPixelAspectRatio value of the Dynamic Media XMP schema. This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.
public Method | getVideoPixelDepth | Returns VideoPixelDepth value of the Dynamic Media XMP schema. This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.
public Method | setAbsPeakAudioFilePath | Sets AbsPeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.
public Method | setAlbum | Sets Album value of the Dynamic Media XMP schema. This XMP value specifies name of the album.
public Method | setAltTapeName | Sets AltTapeName value of the Dynamic Media XMP schema. This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.
public Method | setArtist | Sets Artist value of the Dynamic Media XMP schema. This XMP value specifies name of the artist or artists.
public Method | setAudioChannelType | Sets AudioChannelType value of the Dynamic Media XMP schema. This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.
public Method | setAudioCompressor | Sets AudioCompressor value of the Dynamic Media XMP schema. This XMP value specifies audio compression used. For example, MP3.
public Method | setAudioModDate | Sets AudioModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the audio was last modified.
public Method | setAudioSampleRate | Sets AudioSampleRate value of the Dynamic Media XMP schema. This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.
public Method | setAudioSampleType | Sets AudioSampleType value of the Dynamic Media XMP schema. This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.
public Method | setBeatSpliceParams | Sets BeatSpliceParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Beat Splice stretch mode.
public Method | setComposer | Sets Composer value of the Dynamic Media XMP schema. This XMP value specifies composer's name.
public Method | setContributedMedia | Sets ContributedMedia value of the Dynamic Media XMP schema. This XMP value specifies unordered list of all media used to create this media.
public Method | setCopyright | Sets Copyright value of the Dynamic Media XMP schema. This XMP value specifies copyright information.
public Method | setDuration | Sets Duration value of the Dynamic Media XMP schema. This XMP value specifies duration of the media file.
public Method | setEngineer | Sets Engineer value of the Dynamic Media XMP schema. This XMP value specifies engineer's name.
public Method | setFileDataRate | Sets FileDataRate value of the Dynamic Media XMP schema. This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.
public Method | setGenre | Sets Genre value of the Dynamic Media XMP schema. This XMP value specifies name of the genre.
public Method | setInstrument | Sets Instrument value of the Dynamic Media XMP schema. This XMP value specifies musical instrument.
public Method | setIntroTime | Sets IntroTime value of the Dynamic Media XMP schema. This XMP value specifies duration of lead time for queuing music.
public Method | setKey | Sets Key value of the Dynamic Media XMP schema. This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.
public Method | setLogComment | Sets LogComment value of the Dynamic Media XMP schema. This XMP value specifies log comments.
public Method | setLoop | Sets Loop value of the Dynamic Media XMP schema. This XMP value specifies true, the clip can be looped seemlessly.
public Method | setMarkers | Sets Markers value of the Dynamic Media XMP schema. This XMP value specifies ordered list of markers.
public Method | setMetadataModDate | Sets MetadataModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the metadata was last modified.
public Method | setNumberOfBeats | Sets NumberOfBeats value of the Dynamic Media XMP schema. This XMP value specifies number of beats.
public Method | setOutCue | Sets OutCue value of the Dynamic Media XMP schema. This XMP value specifies time at which to fade out.
public Method | setProjectRef | Sets ProjectRef value of the Dynamic Media XMP schema. This XMP value specifies reference to the project that created this file.
public Method | setPullDown | Sets PullDown value of the Dynamic Media XMP schema. This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.
public Method | setRelativePeakAudioFilePath | Sets RelativePeakAudioFilePath value of the Dynamic Media XMP schema. This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.
public Method | setRelativeTimeStamp | Sets RelativeTimestamp value of the Dynamic Media XMP schema. This XMP value specifies start time of the media inside the audio project.
public Method | setReleaseDate | Sets ReleaseDate value of the Dynamic Media XMP schema. This XMP value specifies date the title was released.
public Method | setResampleParams | Sets ResampleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Resample stretch mode.
public Method | setScaleType | Sets ScaleType value of the Dynamic Media XMP schema. This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.
public Method | setScene | Sets Scene value of the Dynamic Media XMP schema. This XMP value specifies name of the scene.
public Method | setShotDate | Sets ShotDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was shot.
public Method | setShotlocation | Sets ShotLocation value of the Dynamic Media XMP schema. This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.
public Method | setShotName | Sets ShotName value of the Dynamic Media XMP schema. This XMP value specifies name of the shot or take.
public Method | setSpeakerPlacement | Sets SpeakerPlacement value of the Dynamic Media XMP schema. This XMP value specifies description of the speaker angles.
public Method | setStretchMode | Sets StretchMode value of the Dynamic Media XMP schema. This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.
public Method | setTapeName | Sets TapeName value of the Dynamic Media XMP schema. This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.
public Method | setTempo | Sets Tempo value of the Dynamic Media XMP schema. This XMP value specifies audio's tempo.
public Method | setTimeScaleParams | Sets TimeScaleParams value of the Dynamic Media XMP schema. This XMP value specifies parameters for Time-Scale stretch mode.
public Method | setTimeSignature | Sets TimeSignature value of the Dynamic Media XMP schema. This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.
public Method | setTrackNumber | Sets TrackNumber value of the Dynamic Media XMP schema. This XMP value specifies numeric value indicating the order of the audio file within its original recording.
public Method | setVideoAlphaMode | Sets VideoAlphaMode value of the Dynamic Media XMP schema. This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.
public Method | setVideoAlphaPremultipleColor | Sets VideoAlphaPremultipleColor value of the Dynamic Media XMP schema. This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.
public Method | setVideoAlphaUnityIsTransparent | Sets VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema. This XMP value specifies true, unity is clear, when false, it is opaque.
public Method | setVideoColorSpace | Sets VideoColorSpace value of the Dynamic Media XMP schema. This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).
public Method | setVideoCompressor | Sets VideoCompressor value of the Dynamic Media XMP schema. This XMP value specifies compression used. For example, jpeg.
public Method | setVideoFieldOrder | Sets VideoFieldOrder value of the Dynamic Media XMP schema. This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.
public Method | setVideoFrameRate | Sets VideoFrameRate value of the Dynamic Media XMP schema. This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.
public Method | setVideoFrameSize | Sets VideoFrameSize value of the Dynamic Media XMP schema. This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.
public Method | setVideoModDate | Sets VideoModDate value of the Dynamic Media XMP schema. This XMP value specifies date and time when the video was last modified.
public Method | setVideoPixelAspectRatio | Sets VideoPixelAspectRatio value of the Dynamic Media XMP schema. This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.
public Method | setVideoPixelDepth | Sets VideoPixelDepth value of the Dynamic Media XMP schema. This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.
Top

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getAbsPeakAudioFilePath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAbsPeakAudioFilePath Method

Glossary Item Box

Returns AbsPeakAudioFilePath value of the Dynamic Media XMP schema.

This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.

Syntax

public ImGearXMPString getAbsPeakAudioFilePath()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAlbum Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAlbum Method

Glossary Item Box

Returns Album value of the Dynamic Media XMP schema.

This XMP value specifies name of the album.

Syntax

public ImGearXMPString getAlbum()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAltTapeName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAltTapeName Method

Glossary Item Box

Returns AltTapeName value of the Dynamic Media XMP schema.

This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.

Syntax

public ImGearXMPString getAltTapeName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getArtist Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getArtist Method

Glossary Item Box

Returns Artist value of the Dynamic Media XMP schema.

This XMP value specifies name of the artist or artists.

Syntax

public ImGearXMPString getArtist()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAudioChannelType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAudioChannelType Method

Glossary Item Box

Returns AudioChannelType value of the Dynamic Media XMP schema.

This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.

Syntax

public ImGearXMPString getAudioChannelType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAudioCompressor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAudioCompressor Method

Glossary Item Box

Returns AudioCompressor value of the Dynamic Media XMP schema.

This XMP value specifies audio compression used. For example, MP3.

Syntax

public ImGearXMPString getAudioCompressor()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAudioModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAudioModDate Method

Glossary Item Box

Returns AudioModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the audio was last modified.

Syntax

public ImGearXMPDate getAudioModDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAudioSampleRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAudioSampleRate Method

Glossary Item Box

Returns AudioSampleRate value of the Dynamic Media XMP schema.

This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.

Syntax

public ImGearXMPInteger getAudioSampleRate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getAudioSampleType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getAudioSampleType Method

Glossary Item Box

Returns AudioSampleType value of the Dynamic Media XMP schema.

This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.

Syntax

public ImGearXMPString getAudioSampleType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getBeatSpliceParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getBeatSpliceParams Method

Glossary Item Box

Returns BeatSpliceParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Beat Splice stretch mode.

Syntax

public ImGearXMPBeatSpliceStretch getBeatSpliceParams()

Return Value

ImGearXMPBeatSpliceStretch class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getComposer Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getComposer Method

Glossary Item Box

Returns Composer value of the Dynamic Media XMP schema.

This XMP value specifies composer's name.

Syntax

public ImGearXMPString getComposer()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getContributedMedia Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getContributedMedia Method

Glossary Item Box

Returns ContributedMedia value of the Dynamic Media XMP schema.

This XMP value specifies unordered list of all media used to create this media.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPMedia> getContributedMedia()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearXMPMedia type parameter.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getCopyright Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getCopyright Method

Glossary Item Box

Returns Copyright value of the Dynamic Media XMP schema.

This XMP value specifies copyright information.

Syntax

public ImGearXMPString getCopyright()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getDuration Method

Glossary Item Box

Returns Duration value of the Dynamic Media XMP schema.

This XMP value specifies duration of the media file.

Syntax

public ImGearXMPTime getDuration()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getEngineer Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getEngineer Method

Glossary Item Box

Returns Engineer value of the Dynamic Media XMP schema.

This XMP value specifies engineer's name.

Syntax

public ImGearXMPString getEngineer()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getFileDataRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getFileDataRate Method

Glossary Item Box

Returns FileDataRate value of the Dynamic Media XMP schema.

This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.

Syntax

public ImGearXMPRational getFileDataRate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getGenre Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getGenre Method

Glossary Item Box

Returns Genre value of the Dynamic Media XMP schema.

This XMP value specifies name of the genre.

Syntax

public ImGearXMPString getGenre()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getInstrument Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getInstrument Method

Glossary Item Box

Returns Instrument value of the Dynamic Media XMP schema.

This XMP value specifies musical instrument.

Syntax

public ImGearXMPString getInstrument()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getIntroTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getIntroTime Method

Glossary Item Box

Returns IntroTime value of the Dynamic Media XMP schema.

This XMP value specifies duration of lead time for queuing music.

Syntax

public ImGearXMPTime getIntroTime()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getKey Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getKey Method

Glossary Item Box

Returns Key value of the Dynamic Media XMP schema.

This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.

Syntax

public ImGearXMPString getKey()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getLogComment Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getLogComment Method

Glossary Item Box

Returns LogComment value of the Dynamic Media XMP schema.

This XMP value specifies log comments.

Syntax

public ImGearXMPString getLogComment()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getLoop Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getLoop Method

Glossary Item Box

Returns Loop value of the Dynamic Media XMP schema.

This XMP value specifies true, the clip can be looped seemlessly.

Syntax

public ImGearXMPBoolean getLoop()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getMarkers Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getMarkers Method

Glossary Item Box

Returns Markers value of the Dynamic Media XMP schema.

This XMP value specifies ordered list of markers.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPMarker> getMarkers()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPMarker type parameter.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getMetadataModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getMetadataModDate Method

Glossary Item Box

Returns MetadataModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the metadata was last modified.

Syntax

public ImGearXMPDate getMetadataModDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getNumberOfBeats Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getNumberOfBeats Method

Glossary Item Box

Returns NumberOfBeats value of the Dynamic Media XMP schema.

This XMP value specifies number of beats.

Syntax

public ImGearXMPReal getNumberOfBeats()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getOutCue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getOutCue Method

Glossary Item Box

Returns OutCue value of the Dynamic Media XMP schema.

This XMP value specifies time at which to fade out.

Syntax

public ImGearXMPTime getOutCue()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getProjectRef Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getProjectRef Method

Glossary Item Box

Returns ProjectRef value of the Dynamic Media XMP schema.

This XMP value specifies reference to the project that created this file.

Syntax

public ImGearXMPProjectLink getProjectRef()

Return Value

ImGearXMPProjectLink class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getPullDown Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getPullDown Method

Glossary Item Box

Returns PullDown value of the Dynamic Media XMP schema.

This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.

Syntax

public ImGearXMPString getPullDown()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getRelativePeakAudioFilePath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getRelativePeakAudioFilePath Method

Glossary Item Box

Returns RelativePeakAudioFilePath value of the Dynamic Media XMP schema.

This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.

Syntax

public ImGearXMPString getRelativePeakAudioFilePath()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getRelativeTimeStamp Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getRelativeTimeStamp Method

Glossary Item Box

Returns RelativeTimestamp value of the Dynamic Media XMP schema.

This XMP value specifies start time of the media inside the audio project.

Syntax

public ImGearXMPTime getRelativeTimeStamp()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getReleaseDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getReleaseDate Method

Glossary Item Box

Returns ReleaseDate value of the Dynamic Media XMP schema.

This XMP value specifies date the title was released.

Syntax

public ImGearXMPDate getReleaseDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getResampleParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getResampleParams Method

Glossary Item Box

Returns ResampleParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Resample stretch mode.

Syntax

public ImGearXMPString getResampleParams()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getScaleType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getScaleType Method

Glossary Item Box

Returns ScaleType value of the Dynamic Media XMP schema.

This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.

Syntax

public ImGearXMPString getScaleType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getScene Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getScene Method

Glossary Item Box

Returns Scene value of the Dynamic Media XMP schema.

This XMP value specifies name of the scene.

Syntax

public ImGearXMPString getScene()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getShotDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getShotDate Method

Glossary Item Box

Returns ShotDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the video was shot.

Syntax

public ImGearXMPDate getShotDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getShotlocation Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getShotlocation Method

Glossary Item Box

Returns ShotLocation value of the Dynamic Media XMP schema.

This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.

Syntax

public ImGearXMPString getShotlocation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getShotName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getShotName Method

Glossary Item Box

Returns ShotName value of the Dynamic Media XMP schema.

This XMP value specifies name of the shot or take.

Syntax

public ImGearXMPString getShotName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getSpeakerPlacement Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getSpeakerPlacement Method

Glossary Item Box

Returns SpeakerPlacement value of the Dynamic Media XMP schema.

This XMP value specifies description of the speaker angles.

Syntax

public ImGearXMPString getSpeakerPlacement()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getStretchMode Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getStretchMode Method

Glossary Item Box

Returns StretchMode value of the Dynamic Media XMP schema.

This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.

Syntax

public ImGearXMPString getStretchMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getTapeName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getTapeName Method

Glossary Item Box

Returns TapeName value of the Dynamic Media XMP schema.

This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.

Syntax

public ImGearXMPString getTapeName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getTempo Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getTempo Method

Glossary Item Box

Returns Tempo value of the Dynamic Media XMP schema.

This XMP value specifies audio's tempo.

Syntax

public ImGearXMPReal getTempo()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getTimeScaleParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getTimeScaleParams Method

Glossary Item Box

Returns TimeScaleParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Time-Scale stretch mode.

Syntax

public ImGearXMPTimeScaleStretch getTimeScaleParams()

Return Value

ImGearXMPTimeScaleStretch class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getTimeSignature Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getTimeSignature Method

Glossary Item Box

Returns TimeSignature value of the Dynamic Media XMP schema.

This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.

Syntax

public ImGearXMPString getTimeSignature()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getTrackNumber Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getTrackNumber Method

Glossary Item Box

Returns TrackNumber value of the Dynamic Media XMP schema.

This XMP value specifies numeric value indicating the order of the audio file within its original recording.

Syntax

public ImGearXMPInteger getTrackNumber()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoAlphaMode Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoAlphaMode Method

Glossary Item Box

Returns VideoAlphaMode value of the Dynamic Media XMP schema.

This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.

Syntax

public ImGearXMPString getVideoAlphaMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoAlphaPremultipleColor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoAlphaPremultipleColor Method

Glossary Item Box

Returns VideoAlphaPremultipleColor value of the Dynamic Media XMP schema.

This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.

Syntax

public ImGearXMPColorant getVideoAlphaPremultipleColor()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPColorant class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoAlphaUnityIsTransparent Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoAlphaUnityIsTransparent Method

Glossary Item Box

Returns VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema.

This XMP value specifies true, unity is clear, when false, it is opaque.

Syntax

public ImGearXMPBoolean getVideoAlphaUnityIsTransparent()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoColorSpace Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoColorSpace Method

Glossary Item Box

Returns VideoColorSpace value of the Dynamic Media XMP schema.

This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).

Syntax

public ImGearXMPString getVideoColorSpace()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoCompressor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoCompressor Method

Glossary Item Box

Returns VideoCompressor value of the Dynamic Media XMP schema.

This XMP value specifies compression used. For example, jpeg.

Syntax

public ImGearXMPString getVideoCompressor()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoFieldOrder Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoFieldOrder Method

Glossary Item Box

Returns VideoFieldOrder value of the Dynamic Media XMP schema.

This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.

Syntax

public ImGearXMPString getVideoFieldOrder()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoFrameRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoFrameRate Method

Glossary Item Box

Returns VideoFrameRate value of the Dynamic Media XMP schema.

This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.

Syntax

public ImGearXMPString getVideoFrameRate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoFrameSize Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoFrameSize Method

Glossary Item Box

Returns VideoFrameSize value of the Dynamic Media XMP schema.

This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.

Syntax

public ImGearXMPDimensions getVideoFrameSize()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoModDate Method

Glossary Item Box

Returns VideoModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the video was last modified.

Syntax

public ImGearXMPDate getVideoModDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoPixelAspectRatio Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoPixelAspectRatio Method

Glossary Item Box

Returns VideoPixelAspectRatio value of the Dynamic Media XMP schema.

This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.

Syntax

public ImGearXMPRational getVideoPixelAspectRatio()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

getVideoPixelDepth Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : getVideoPixelDepth Method

Glossary Item Box

Returns VideoPixelDepth value of the Dynamic Media XMP schema.

This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.

Syntax

public ImGearXMPString getVideoPixelDepth()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAbsPeakAudioFilePath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAbsPeakAudioFilePath Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AbsPeakAudioFilePath value of the Dynamic Media XMP schema.

This XMP value specifies absolute path to the file's peak audio file. If empty, no peak file exists.

Syntax

public void setAbsPeakAudioFilePath(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAlbum Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAlbum Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Album value of the Dynamic Media XMP schema.

This XMP value specifies name of the album.

Syntax

public void setAlbum(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAltTapeName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAltTapeName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AltTapeName value of the Dynamic Media XMP schema.

This XMP value specifies alternative tape name, set via the project window or timecode dialog in Premiere. If an alternative name has been set and has not been reverted, that name is displayed.

Syntax

public void setAltTapeName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setArtist Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setArtist Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Artist value of the Dynamic Media XMP schema.

This XMP value specifies name of the artist or artists.

Syntax

public void setArtist(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAudioChannelType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAudioChannelType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AudioChannelType value of the Dynamic Media XMP schema.

This XMP value specifies audio channel type. Allowed values are: 'Mono', 'Stereo', '5.1', '7.1'.

Syntax

public void setAudioChannelType(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAudioCompressor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAudioCompressor Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AudioCompressor value of the Dynamic Media XMP schema.

This XMP value specifies audio compression used. For example, MP3.

Syntax

public void setAudioCompressor(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAudioModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAudioModDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets AudioModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the audio was last modified.

Syntax

public void setAudioModDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAudioSampleRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAudioSampleRate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets AudioSampleRate value of the Dynamic Media XMP schema.

This XMP value specifies audio sample rate. Can be any value, but commonly 32000, 41100, or 48000.

Syntax

public void setAudioSampleRate(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setAudioSampleType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setAudioSampleType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AudioSampleType value of the Dynamic Media XMP schema.

This XMP value specifies audio sample type. Allowed values are: '8Int', '16Int', '32Int', '32Float'.

Syntax

public void setAudioSampleType(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setBeatSpliceParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setBeatSpliceParams Method
value
ImGearXMPBeatSpliceStretch class value.

Glossary Item Box

Sets BeatSpliceParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Beat Splice stretch mode.

Syntax

public void setBeatSpliceParams(
   ImGearXMPBeatSpliceStretch value
)

Parameters

value
ImGearXMPBeatSpliceStretch class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setComposer Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setComposer Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Composer value of the Dynamic Media XMP schema.

This XMP value specifies composer's name.

Syntax

public void setComposer(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setContributedMedia Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setContributedMedia Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearXMPMedia type parameter.

Glossary Item Box

Sets ContributedMedia value of the Dynamic Media XMP schema.

This XMP value specifies unordered list of all media used to create this media.

Syntax

public void setContributedMedia(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPMedia> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with ImGearXMPMedia type parameter.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setCopyright Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setCopyright Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Copyright value of the Dynamic Media XMP schema.

This XMP value specifies copyright information.

Syntax

public void setCopyright(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setDuration Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets Duration value of the Dynamic Media XMP schema.

This XMP value specifies duration of the media file.

Syntax

public void setDuration(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setEngineer Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setEngineer Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Engineer value of the Dynamic Media XMP schema.

This XMP value specifies engineer's name.

Syntax

public void setEngineer(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setFileDataRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setFileDataRate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FileDataRate value of the Dynamic Media XMP schema.

This XMP value specifies file data rate in megabytes per second. For example: '36/10' = 3.6 MB/sec.

Syntax

public void setFileDataRate(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setGenre Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setGenre Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Genre value of the Dynamic Media XMP schema.

This XMP value specifies name of the genre.

Syntax

public void setGenre(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setInstrument Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setInstrument Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Instrument value of the Dynamic Media XMP schema.

This XMP value specifies musical instrument.

Syntax

public void setInstrument(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setIntroTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setIntroTime Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets IntroTime value of the Dynamic Media XMP schema.

This XMP value specifies duration of lead time for queuing music.

Syntax

public void setIntroTime(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setKey Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setKey Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Key value of the Dynamic Media XMP schema.

This XMP value specifies audio's musical key. Allowed values are: 'C', 'C#', 'D', 'D#', 'E', 'F', 'F#', 'G', 'G#', 'A', 'A#', 'B'.

Syntax

public void setKey(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setLogComment Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setLogComment Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets LogComment value of the Dynamic Media XMP schema.

This XMP value specifies log comments.

Syntax

public void setLogComment(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setLoop Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setLoop Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets Loop value of the Dynamic Media XMP schema.

This XMP value specifies true, the clip can be looped seemlessly.

Syntax

public void setLoop(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setMarkers Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setMarkers Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPMarker type parameter.

Glossary Item Box

Sets Markers value of the Dynamic Media XMP schema.

This XMP value specifies ordered list of markers.

Syntax

public void setMarkers(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPMarker> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPMarker type parameter.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setMetadataModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setMetadataModDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets MetadataModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the metadata was last modified.

Syntax

public void setMetadataModDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setNumberOfBeats Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setNumberOfBeats Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

Glossary Item Box

Sets NumberOfBeats value of the Dynamic Media XMP schema.

This XMP value specifies number of beats.

Syntax

public void setNumberOfBeats(
   ImGearXMPReal value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setOutCue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setOutCue Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets OutCue value of the Dynamic Media XMP schema.

This XMP value specifies time at which to fade out.

Syntax

public void setOutCue(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setProjectRef Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setProjectRef Method
value
ImGearXMPProjectLink class value.

Glossary Item Box

Sets ProjectRef value of the Dynamic Media XMP schema.

This XMP value specifies reference to the project that created this file.

Syntax

public void setProjectRef(
   ImGearXMPProjectLink value
)

Parameters

value
ImGearXMPProjectLink class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setPullDown Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setPullDown Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets PullDown value of the Dynamic Media XMP schema.

This XMP value specifies sampling phase of film to be converted to video (pull-down). Allowed values are: 'WSSWW', 'SSWWW', 'SWWWS', 'WWWSS', 'WWSSW', 'WSSWW_24p', 'SSWWW_24p', 'SWWWS_24p', 'WWWSS_24p', 'WWSSW_24p'.

Syntax

public void setPullDown(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setRelativePeakAudioFilePath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setRelativePeakAudioFilePath Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets RelativePeakAudioFilePath value of the Dynamic Media XMP schema.

This XMP value specifies relative path to the file's peak audio file. If empty, no peak file exists.

Syntax

public void setRelativePeakAudioFilePath(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setRelativeTimeStamp Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setRelativeTimeStamp Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets RelativeTimestamp value of the Dynamic Media XMP schema.

This XMP value specifies start time of the media inside the audio project.

Syntax

public void setRelativeTimeStamp(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setReleaseDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setReleaseDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets ReleaseDate value of the Dynamic Media XMP schema.

This XMP value specifies date the title was released.

Syntax

public void setReleaseDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setResampleParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setResampleParams Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ResampleParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Resample stretch mode.

Syntax

public void setResampleParams(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setScaleType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setScaleType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ScaleType value of the Dynamic Media XMP schema.

This XMP value specifies musical scale used in the music. Allowed values are: 'Major', 'Minor', 'Both', 'Neither'.

Syntax

public void setScaleType(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setScene Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setScene Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Scene value of the Dynamic Media XMP schema.

This XMP value specifies name of the scene.

Syntax

public void setScene(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setShotDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setShotDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets ShotDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the video was shot.

Syntax

public void setShotDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setShotlocation Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setShotlocation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ShotLocation value of the Dynamic Media XMP schema.

This XMP value specifies name of the location where the video was shot. For example: 'Oktoberfest, Munich Germany'. For more accurate positioning, use the EXIF GPS values.

Syntax

public void setShotlocation(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setShotName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setShotName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ShotName value of the Dynamic Media XMP schema.

This XMP value specifies name of the shot or take.

Syntax

public void setShotName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setSpeakerPlacement Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setSpeakerPlacement Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets SpeakerPlacement value of the Dynamic Media XMP schema.

This XMP value specifies description of the speaker angles.

Syntax

public void setSpeakerPlacement(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setStretchMode Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setStretchMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets StretchMode value of the Dynamic Media XMP schema.

This XMP value specifies audio stretch mode. Allowed values are: 'Fixed length', 'Time-Scale', 'Resample', 'Beat Splice', 'Hybrid'.

Syntax

public void setStretchMode(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setTapeName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setTapeName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets TapeName value of the Dynamic Media XMP schema.

This XMP value specifies name of the tape from which the clip was captured, as set during the capture process.

Syntax

public void setTapeName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setTempo Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setTempo Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

Glossary Item Box

Sets Tempo value of the Dynamic Media XMP schema.

This XMP value specifies audio's tempo.

Syntax

public void setTempo(
   ImGearXMPReal value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setTimeScaleParams Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setTimeScaleParams Method
value
ImGearXMPTimeScaleStretch class value.

Glossary Item Box

Sets TimeScaleParams value of the Dynamic Media XMP schema.

This XMP value specifies parameters for Time-Scale stretch mode.

Syntax

public void setTimeScaleParams(
   ImGearXMPTimeScaleStretch value
)

Parameters

value
ImGearXMPTimeScaleStretch class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setTimeSignature Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setTimeSignature Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets TimeSignature value of the Dynamic Media XMP schema.

This XMP value specifies time signature of the music. Allowed values are: One of: '2/4', '3/4', '4/4', '5/4', '7/4', '6/8', '9/8', '12/8', 'other'.

Syntax

public void setTimeSignature(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setTrackNumber Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setTrackNumber Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets TrackNumber value of the Dynamic Media XMP schema.

This XMP value specifies numeric value indicating the order of the audio file within its original recording.

Syntax

public void setTrackNumber(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoAlphaMode Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoAlphaMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoAlphaMode value of the Dynamic Media XMP schema.

This XMP value specifies alpha mode. Allowed values are: 'straight', 'pre-multiplied'.

Syntax

public void setVideoAlphaMode(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoAlphaPremultipleColor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoAlphaPremultipleColor Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPColorant class value.

Glossary Item Box

Sets VideoAlphaPremultipleColor value of the Dynamic Media XMP schema.

This XMP value specifies a color in CMYK or RGB to be used as the pre-multiple color when alpha mode is pre-multiplied.

Syntax

public void setVideoAlphaPremultipleColor(
   ImGearXMPColorant value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPColorant class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoAlphaUnityIsTransparent Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoAlphaUnityIsTransparent Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets VideoAlphaUnityIsTransparent value of the Dynamic Media XMP schema.

This XMP value specifies true, unity is clear, when false, it is opaque.

Syntax

public void setVideoAlphaUnityIsTransparent(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoColorSpace Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoColorSpace Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoColorSpace value of the Dynamic Media XMP schema.

This XMP value specifies choice of The color space. Allowed values are: 'sRGB' (used by Photoshop), 'CCIR-601" (used for NTSC), 'CCIR-709' (used for HD).

Syntax

public void setVideoColorSpace(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoCompressor Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoCompressor Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoCompressor value of the Dynamic Media XMP schema.

This XMP value specifies compression used. For example, jpeg.

Syntax

public void setVideoCompressor(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoFieldOrder Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoFieldOrder Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoFieldOrder value of the Dynamic Media XMP schema.

This XMP value specifies field order for video. One of: 'Upper', 'Lower', 'Progressive'.

Syntax

public void setVideoFieldOrder(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoFrameRate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoFrameRate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoFrameRate value of the Dynamic Media XMP schema.

This XMP value specifies choice of the video frame rate. One of: '24', 'NTSC', 'PAL'.

Syntax

public void setVideoFrameRate(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoFrameSize Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoFrameSize Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

Glossary Item Box

Sets VideoFrameSize value of the Dynamic Media XMP schema.

This XMP value specifies frame size. For example: w:720, h: 480, unit:pixels.

Syntax

public void setVideoFrameSize(
   ImGearXMPDimensions value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoModDate Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoModDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets VideoModDate value of the Dynamic Media XMP schema.

This XMP value specifies date and time when the video was last modified.

Syntax

public void setVideoModDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoPixelAspectRatio Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoPixelAspectRatio Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets VideoPixelAspectRatio value of the Dynamic Media XMP schema.

This XMP value specifies aspect ratio, expressed as ht/wd. For example: '648/720' = 0.9.

Syntax

public void setVideoPixelAspectRatio(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

setVideoPixelDepth Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearDynamicMediaXMPMetadata Class : setVideoPixelDepth Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VideoPixelDepth value of the Dynamic Media XMP schema.

This XMP value specifies choice of The size in bits of each color component of a pixel. Standard Windows 32-bit pixels have 8 bits per component. Allowed values are: '8Int', '16Int', '32Int', '32Float.

Syntax

public void setVideoPixelDepth(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearDynamicMediaXMPMetadata Class
ImGearDynamicMediaXMPMetadata Members


%%PageItemTitle%%

ImGearXMPBeatSpliceStretch Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPBeatSpliceStretch Class

Glossary Item Box

Represents an XMP BeatSpliceStretch structure.

This class contains a set of parameters used when stretching audio using the Beat Splice stretch mode.

Object Model

ImGearXMPBeatSpliceStretch ClassImGearXMPReal ClassImGearXMPTime ClassImGearXMPBoolean Class

Syntax

public class ImGearXMPBeatSpliceStretch
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPBeatSpliceStretch

See Also

Reference

ImGearXMPBeatSpliceStretch Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPBeatSpliceStretch Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPBeatSpliceStretch Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPBeatSpliceStretch.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPBeatSpliceStretch Constructor | Initializes a new instance of the ImGearXMPBeatSpliceStretch class.
Top

Public Methods

 | Name | Description
public Method | getRiseInDecibel | Returns the amount sound must increase in amplitude to detect a beat.
public Method | getRiseInTimeDuration | Returns the duration of the sampling window used to measure the audio increase for locating beats.
public Method | getUseFileBeatsMarker | Returns condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
public Method | setRiseInDecibel | Sets the amount sound must increase in amplitude to detect a beat.
public Method | setRiseInTimeDuration | Sets the duration of the sampling window used to measure the audio increase for locating beats.
public Method | setUseFileBeatsMarker | Sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
Top

See Also

Reference

ImGearXMPBeatSpliceStretch Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPBeatSpliceStretch Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : ImGearXMPBeatSpliceStretch Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPBeatSpliceStretch class.

Syntax

public ImGearXMPBeatSpliceStretch()

Return Value

New instance of the ImGearXMPBeatSpliceStretch class object.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPBeatSpliceStretch Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPBeatSpliceStretch Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPBeatSpliceStretch members.

Public Methods

 | Name | Description
public Method | getRiseInDecibel | Returns the amount sound must increase in amplitude to detect a beat.
public Method | getRiseInTimeDuration | Returns the duration of the sampling window used to measure the audio increase for locating beats.
public Method | getUseFileBeatsMarker | Returns condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
public Method | setRiseInDecibel | Sets the amount sound must increase in amplitude to detect a beat.
public Method | setRiseInTimeDuration | Sets the duration of the sampling window used to measure the audio increase for locating beats.
public Method | setUseFileBeatsMarker | Sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.
Top

See Also

Reference

ImGearXMPBeatSpliceStretch Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getRiseInDecibel Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : getRiseInDecibel Method

Glossary Item Box

Returns the amount sound must increase in amplitude to detect a beat.

Syntax

public ImGearXMPReal getRiseInDecibel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

getRiseInTimeDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : getRiseInTimeDuration Method

Glossary Item Box

Returns the duration of the sampling window used to measure the audio increase for locating beats.

Syntax

public ImGearXMPTime getRiseInTimeDuration()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

getUseFileBeatsMarker Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : getUseFileBeatsMarker Method

Glossary Item Box

Returns condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.

Syntax

public ImGearXMPBoolean getUseFileBeatsMarker()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

setRiseInDecibel Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : setRiseInDecibel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

Glossary Item Box

Sets the amount sound must increase in amplitude to detect a beat.

Syntax

public void setRiseInDecibel(
   ImGearXMPReal value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

setRiseInTimeDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : setRiseInTimeDuration Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets the duration of the sampling window used to measure the audio increase for locating beats.

Syntax

public void setRiseInTimeDuration(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

setUseFileBeatsMarker Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPBeatSpliceStretch Class : setUseFileBeatsMarker Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets condition if the file beat markers are used for stretching. Otherwise the rise and duration fields are used to automatically locate the beats.

Syntax

public void setUseFileBeatsMarker(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPBeatSpliceStretch Class
ImGearXMPBeatSpliceStretch Members


%%PageItemTitle%%

ImGearXMPMarker Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMarker Class

Glossary Item Box

Represents an XMP Marker structure.

This class is used to desribe an important location in a video sequence.

Object Model

ImGearXMPMarker ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPMarker
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMarker

See Also

Reference

ImGearXMPMarker Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPMarker Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMarker Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPMarker.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPMarker Constructor | Initializes a new instance of the ImGearXMPMarker class.
Top

Public Methods

 | Name | Description
public Method | getComment | Returns a descriptive comment.
public Method | getDuration | Returns the duration of the marker.
public Method | getLocation | Returns the URL of the location to jump to.
public Method | getName | Returns the name of the marker. This becomes, for example, the name of a chapter in a DVD.
public Method | getStartTime | Returns the timeline position of the marker.
public Method | getTarget | Returns the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
public Method | getType | Returns the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
public Method | setComment | Sets a descriptive comment.
public Method | setDuration | Sets the duration of the marker.
public Method | setLocation | Sets the URL of the location to jump to.
public Method | setName | Sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.
public Method | setStartTime | Sets the timeline position of the marker.
public Method | setTarget | Sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
public Method | setType | Sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
Top

See Also

Reference

ImGearXMPMarker Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPMarker Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : ImGearXMPMarker Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPMarker class.

Syntax

public ImGearXMPMarker()

Return Value

New instance of the ImGearXMPMarker class object.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPMarker Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMarker Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPMarker members.

Public Methods

 | Name | Description
public Method | getComment | Returns a descriptive comment.
public Method | getDuration | Returns the duration of the marker.
public Method | getLocation | Returns the URL of the location to jump to.
public Method | getName | Returns the name of the marker. This becomes, for example, the name of a chapter in a DVD.
public Method | getStartTime | Returns the timeline position of the marker.
public Method | getTarget | Returns the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
public Method | getType | Returns the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
public Method | setComment | Sets a descriptive comment.
public Method | setDuration | Sets the duration of the marker.
public Method | setLocation | Sets the URL of the location to jump to.
public Method | setName | Sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.
public Method | setStartTime | Sets the timeline position of the marker.
public Method | setTarget | Sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.
public Method | setType | Sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".
Top

See Also

Reference

ImGearXMPMarker Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getComment Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getComment Method

Glossary Item Box

Returns a descriptive comment.

Syntax

public ImGearXMPString getComment()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getDuration Method

Glossary Item Box

Returns the duration of the marker.

Syntax

public ImGearXMPTime getDuration()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getLocation Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getLocation Method

Glossary Item Box

Returns the URL of the location to jump to.

Syntax

public ImGearXMPString getLocation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getName Method

Glossary Item Box

Returns the name of the marker. This becomes, for example, the name of a chapter in a DVD.

Syntax

public ImGearXMPString getName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getStartTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getStartTime Method

Glossary Item Box

Returns the timeline position of the marker.

Syntax

public ImGearXMPTime getStartTime()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getTarget Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getTarget Method

Glossary Item Box

Returns the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.

Syntax

public ImGearXMPString getTarget()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : getType Method

Glossary Item Box

Returns the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".

Syntax

public ImGearXMPString getType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setComment Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setComment Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets a descriptive comment.

Syntax

public void setComment(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setDuration Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets the duration of the marker.

Syntax

public void setDuration(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setLocation Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setLocation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the URL of the location to jump to.

Syntax

public void setLocation(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the name of the marker. This becomes, for example, the name of a chapter in a DVD.

Syntax

public void setName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setStartTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setStartTime Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets the timeline position of the marker.

Syntax

public void setStartTime(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setTarget Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setTarget Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the part of the URL following the # sign. For example, in the URL http://ns.adobe.com/xmp#Start, the value is Start.

Syntax

public void setTarget(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

setType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMarker Class : setType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the marker type. Allowed values are: "Chapter", "Cue", "Beat", "Track", "Index".

Syntax

public void setType(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMarker Class
ImGearXMPMarker Members


%%PageItemTitle%%

ImGearXMPMedia Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMedia Class

Glossary Item Box

Represents an XMP Media structure.

This class specifies a reference to a media asset.

Object Model

ImGearXMPMedia ClassImGearXMPTime ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPTime ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPMedia
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPMedia

See Also

Reference

ImGearXMPMedia Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPMedia Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMedia Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPMedia.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPMedia Constructor | Initializes a new instance of the ImGearXMPMedia class.
Top

Public Methods

 | Name | Description
public Method | getDuration | Returns the duration of the media in the timeline.
public Method | getManaged | Returns a rights-managed resource.
public Method | getPath | Returns the location of the media.
public Method | getStartTime | Returns the timeline position of the start of the media. This can be used to locate the media with a track.
public Method | getTrack | Returns an identifier for the track that contained this media. Could be a track name or a number.
public Method | getWebStatement | Returns the location of a web page describing the owner and/or rights statement for this resource.
public Method | setDuration | Sets the duration of the media in the timeline.
public Method | setManaged | Sets a rights-managed resource.
public Method | setPath | Sets the location of the media.
public Method | setStartTime | Sets the timeline position of the start of the media. This can be used to locate the media with a track.
public Method | setTrack | Sets an identifier for the track that contained this media. Could be a track name or a number.
public Method | setWebStatement | Sets the location of a web page describing the owner and/or rights statement for this resource.
Top

See Also

Reference

ImGearXMPMedia Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPMedia Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : ImGearXMPMedia Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPMedia class.

Syntax

public ImGearXMPMedia()

Return Value

New instance of the ImGearXMPMedia class object.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPMedia Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPMedia Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPMedia members.

Public Methods

 | Name | Description
public Method | getDuration | Returns the duration of the media in the timeline.
public Method | getManaged | Returns a rights-managed resource.
public Method | getPath | Returns the location of the media.
public Method | getStartTime | Returns the timeline position of the start of the media. This can be used to locate the media with a track.
public Method | getTrack | Returns an identifier for the track that contained this media. Could be a track name or a number.
public Method | getWebStatement | Returns the location of a web page describing the owner and/or rights statement for this resource.
public Method | setDuration | Sets the duration of the media in the timeline.
public Method | setManaged | Sets a rights-managed resource.
public Method | setPath | Sets the location of the media.
public Method | setStartTime | Sets the timeline position of the start of the media. This can be used to locate the media with a track.
public Method | setTrack | Sets an identifier for the track that contained this media. Could be a track name or a number.
public Method | setWebStatement | Sets the location of a web page describing the owner and/or rights statement for this resource.
Top

See Also

Reference

ImGearXMPMedia Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getDuration Method

Glossary Item Box

Returns the duration of the media in the timeline.

Syntax

public ImGearXMPTime getDuration()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

getManaged Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getManaged Method

Glossary Item Box

Returns a rights-managed resource.

Syntax

public ImGearXMPBoolean getManaged()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

getPath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getPath Method

Glossary Item Box

Returns the location of the media.

Syntax

public ImGearXMPString getPath()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

getStartTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getStartTime Method

Glossary Item Box

Returns the timeline position of the start of the media. This can be used to locate the media with a track.

Syntax

public ImGearXMPTime getStartTime()

Return Value

ImGearXMPTime class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

getTrack Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getTrack Method

Glossary Item Box

Returns an identifier for the track that contained this media. Could be a track name or a number.

Syntax

public ImGearXMPString getTrack()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

getWebStatement Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : getWebStatement Method

Glossary Item Box

Returns the location of a web page describing the owner and/or rights statement for this resource.

Syntax

public ImGearXMPString getWebStatement()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setDuration Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setDuration Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets the duration of the media in the timeline.

Syntax

public void setDuration(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setManaged Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setManaged Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets a rights-managed resource.

Syntax

public void setManaged(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setPath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setPath Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the location of the media.

Syntax

public void setPath(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setStartTime Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setStartTime Method
value
ImGearXMPTime class value.

Glossary Item Box

Sets the timeline position of the start of the media. This can be used to locate the media with a track.

Syntax

public void setStartTime(
   ImGearXMPTime value
)

Parameters

value
ImGearXMPTime class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setTrack Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setTrack Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets an identifier for the track that contained this media. Could be a track name or a number.

Syntax

public void setTrack(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

setWebStatement Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPMedia Class : setWebStatement Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the location of a web page describing the owner and/or rights statement for this resource.

Syntax

public void setWebStatement(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPMedia Class
ImGearXMPMedia Members


%%PageItemTitle%%

ImGearXMPProjectLink Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPProjectLink Class

Glossary Item Box

Represents an XMP ProjectLink structure.

This class specifies the type of a video file and path of the project that created it.

Object Model

ImGearXMPProjectLink ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPProjectLink
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPProjectLink

See Also

Reference

ImGearXMPProjectLink Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPProjectLink Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPProjectLink Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPProjectLink.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPProjectLink Constructor | Initializes a new instance of the ImGearXMPProjectLink class.
Top

Public Methods

 | Name | Description
public Method | getPath | Returns the full path to the project that created this file.
public Method | getType | Returns the file type. Allowed values are: "movie", "still", "audio", "custom".
public Method | setPath | Sets the full path to the project that created this file.
public Method | setType | Sets the file type. Allowed values are: "movie", "still", "audio", "custom".
Top

See Also

Reference

ImGearXMPProjectLink Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPProjectLink Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : ImGearXMPProjectLink Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPProjectLink class.

Syntax

public ImGearXMPProjectLink()

Return Value

New instance of the ImGearXMPProjectLink class object.

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPProjectLink Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPProjectLink Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPProjectLink members.

Public Methods

 | Name | Description
public Method | getPath | Returns the full path to the project that created this file.
public Method | getType | Returns the file type. Allowed values are: "movie", "still", "audio", "custom".
public Method | setPath | Sets the full path to the project that created this file.
public Method | setType | Sets the file type. Allowed values are: "movie", "still", "audio", "custom".
Top

See Also

Reference

ImGearXMPProjectLink Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getPath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : getPath Method

Glossary Item Box

Returns the full path to the project that created this file.

Syntax

public ImGearXMPString getPath()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : getType Method

Glossary Item Box

Returns the file type. Allowed values are: "movie", "still", "audio", "custom".

Syntax

public ImGearXMPString getType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

setPath Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : setPath Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the full path to the project that created this file.

Syntax

public void setPath(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

setType Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPProjectLink Class : setType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the file type. Allowed values are: "movie", "still", "audio", "custom".

Syntax

public void setType(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPProjectLink Class
ImGearXMPProjectLink Members


%%PageItemTitle%%

ImGearXMPTime Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTime Class

Glossary Item Box

Represents an XMP Time structure.

This class provides a representation of a time value in seconds.

Object Model

ImGearXMPTime ClassImGearXMPRational ClassImGearXMPInteger Class

Syntax

public class ImGearXMPTime
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTime

See Also

Reference

ImGearXMPTime Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPTime Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTime Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPTime.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPTime Constructor | Initializes a new instance of the ImGearXMPTime class.
Top

Public Methods

 | Name | Description
public Method | getScale | Returns the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
public Method | getValue | Returns the time value in the specified scale.
public Method | setScale | Sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
public Method | setValue | Sets the time value in the specified scale.
Top

See Also

Reference

ImGearXMPTime Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPTime Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : ImGearXMPTime Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPTime class.

Syntax

public ImGearXMPTime()

Return Value

New instance of the ImGearXMPTime class object.

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPTime Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTime Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPTime members.

Public Methods

 | Name | Description
public Method | getScale | Returns the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
public Method | getValue | Returns the time value in the specified scale.
public Method | setScale | Sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.
public Method | setValue | Sets the time value in the specified scale.
Top

See Also

Reference

ImGearXMPTime Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getScale Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : getScale Method

Glossary Item Box

Returns the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.

Syntax

public ImGearXMPRational getScale()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

getValue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : getValue Method

Glossary Item Box

Returns the time value in the specified scale.

Syntax

public ImGearXMPInteger getValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

setScale Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : setScale Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets the scale for the time value. For NTSC, use 1001/30000, or the less accurate 100/2997. For PAL, use 1/25.

Syntax

public void setScale(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

setValue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTime Class : setValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the time value in the specified scale.

Syntax

public void setValue(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPTime Class
ImGearXMPTime Members


%%PageItemTitle%%

ImGearXMPTimecode Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimecode Class

Glossary Item Box

Represents an XMP Timecode structure.

This class represents a time value in video.

Object Model

ImGearXMPTimecode ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPTimecode
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimecode

See Also

Reference

ImGearXMPTimecode Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPTimecode Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimecode Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPTimecode.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPTimecode Constructor | Initializes a new instance of the ImGearXMPTimecode class.
Top

Public Methods

 | Name | Description
public Method | getTimeFormat | Returns the format used in the TimeValue. Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.
public Method | getTimeValue | Returns a time value in the specified format. Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.
public Method | setTimeFormat | Sets the format used in the TimeValue. Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.
public Method | setTimeValue | Sets a time value in the specified format. Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.
Top

See Also

Reference

ImGearXMPTimecode Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPTimecode Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : ImGearXMPTimecode Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPTimecode class.

Syntax

public ImGearXMPTimecode()

Return Value

New instance of the ImGearXMPTimecode class object.

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPTimecode Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimecode Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPTimecode members.

Public Methods

 | Name | Description
public Method | getTimeFormat | Returns the format used in the TimeValue. Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.
public Method | getTimeValue | Returns a time value in the specified format. Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.
public Method | setTimeFormat | Sets the format used in the TimeValue. Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.
public Method | setTimeValue | Sets a time value in the specified format. Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.
Top

See Also

Reference

ImGearXMPTimecode Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getTimeFormat Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : getTimeFormat Method

Glossary Item Box

Returns the format used in the TimeValue.

Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.

Syntax

public ImGearXMPString getTimeFormat()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

getTimeValue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : getTimeValue Method

Glossary Item Box

Returns a time value in the specified format.

Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.

Syntax

public ImGearXMPString getTimeValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

setTimeFormat Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : setTimeFormat Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the format used in the TimeValue.

Allowed values are: '24Timecode', '25Timecode', '2997DropTimecode' (semicolon delimiter), '2997NonDropTimecode', '30Timecode', '50Timecode', '5994DropTimecode', '5994NonDropTimecode', '60Timecode', '23976Timecode'.

Syntax

public void setTimeFormat(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

setTimeValue Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimecode Class : setTimeValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets a time value in the specified format.

Time values use a colon delimiter in all formats except 2997drop, which uses a semicolon. The four fields indicate hours, minutes, seconds, and frames: hh:mm:ss:ff. The actual duration in seconds depends on the format.

Syntax

public void setTimeValue(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimecode Class
ImGearXMPTimecode Members


%%PageItemTitle%%

ImGearXMPTimeScaleStretch Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimeScaleStretch Class

Glossary Item Box

Represents an XMP TimeScaleStretch structure.

This class contains a set of parameters used when stretching audio using the Time-Scale stretch mode.

Object Model

ImGearXMPTimeScaleStretch ClassImGearXMPReal ClassImGearXMPReal ClassImGearXMPString Class

Syntax

public class ImGearXMPTimeScaleStretch
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.dynamicmedia.ImGearXMPTimeScaleStretch

See Also

Reference

ImGearXMPTimeScaleStretch Members
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPTimeScaleStretch Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimeScaleStretch Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPTimeScaleStretch.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPTimeScaleStretch Constructor | Initializes a new instance of the ImGearXMPTimeScaleStretch class.
Top

Public Methods

 | Name | Description
public Method | getFrameOverlappingPercentage | Returns the percentage of overlap between frames.
public Method | getFrameSize | Returns the number of splices per beat.
public Method | getQuality | Returns the stretch quality. Allowed values are: "High", "Medium", "Low".
public Method | setFrameOverlappingPercentage | Sets the percentage of overlap between frames.
public Method | setFrameSize | Sets the number of splices per beat.
public Method | setQuality | Sets the stretch quality. Allowed values are: "High", "Medium", "Low".
Top

See Also

Reference

ImGearXMPTimeScaleStretch Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

ImGearXMPTimeScaleStretch Constructor
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : ImGearXMPTimeScaleStretch Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPTimeScaleStretch class.

Syntax

public ImGearXMPTimeScaleStretch()

Return Value

New instance of the ImGearXMPTimeScaleStretch class object.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPTimeScaleStretch Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.dynamicmedia Package : ImGearXMPTimeScaleStretch Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPTimeScaleStretch members.

Public Methods

 | Name | Description
public Method | getFrameOverlappingPercentage | Returns the percentage of overlap between frames.
public Method | getFrameSize | Returns the number of splices per beat.
public Method | getQuality | Returns the stretch quality. Allowed values are: "High", "Medium", "Low".
public Method | setFrameOverlappingPercentage | Sets the percentage of overlap between frames.
public Method | setFrameSize | Sets the number of splices per beat.
public Method | setQuality | Sets the stretch quality. Allowed values are: "High", "Medium", "Low".
Top

See Also

Reference

ImGearXMPTimeScaleStretch Class
com.accusoft.imagegear.formats.xmp.dynamicmedia Package


%%PageItemTitle%%

getFrameOverlappingPercentage Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : getFrameOverlappingPercentage Method

Glossary Item Box

Returns the percentage of overlap between frames.

Syntax

public ImGearXMPReal getFrameOverlappingPercentage()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

getFrameSize Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : getFrameSize Method

Glossary Item Box

Returns the number of splices per beat.

Syntax

public ImGearXMPReal getFrameSize()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

getQuality Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : getQuality Method

Glossary Item Box

Returns the stretch quality. Allowed values are: "High", "Medium", "Low".

Syntax

public ImGearXMPString getQuality()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

setFrameOverlappingPercentage Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : setFrameOverlappingPercentage Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

Glossary Item Box

Sets the percentage of overlap between frames.

Syntax

public void setFrameOverlappingPercentage(
   ImGearXMPReal value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

setFrameSize Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : setFrameSize Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

Glossary Item Box

Sets the number of splices per beat.

Syntax

public void setFrameSize(
   ImGearXMPReal value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPReal class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%PageItemTitle%%

setQuality Method
com.accusoft.imagegear.formats.xmp.dynamicmedia Package > ImGearXMPTimeScaleStretch Class : setQuality Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the stretch quality. Allowed values are: "High", "Medium", "Low".

Syntax

public void setQuality(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPTimeScaleStretch Class
ImGearXMPTimeScaleStretch Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.exif Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP EXIF format.

Classes

Class | Description
ImGearEXIFXMPMetadata | Provides simplified access to EXIF XMP metadata schema. This class provides simplified access to EXIF XMP metadata schema. It includes the properties defined solely by the EXIF standard. See also TIFF and EXIFAux namespaces.
ImGearXMPCFAPattern | Represents an XMP CFAPattern structure.
ImGearXMPDeviceSettings | Represents an XMP DeviceSettings structure.
ImGearXMPFlash | Represents an XMP Flash structure.
ImGearXMPGPSCoordinate | Represents an XMP GPSCoordinate structure. A GPS coordinate in XMP may use either Second or MinuteFraction field, but not both.
ImGearXMPOECFSFR | Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.

Enumerations

Enumeration | Description
ImGearXMPGPSDirection | Represents GPS directions, used in the EXIF XMP schema.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.exif Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPCFAPattern
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPDeviceSettings
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPFlash
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPOECFSFR
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPGPSCoordinate

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearEXIFXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearEXIFXMPMetadata Class

Glossary Item Box

Provides simplified access to EXIF XMP metadata schema.

This class provides simplified access to EXIF XMP metadata schema. It includes the properties defined solely by the EXIF standard.

See also TIFF and EXIFAux namespaces.

Object Model

ImGearEXIFXMPMetadata ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPCFAPattern ClassImGearXMPRational ClassImGearXMPDate ClassImGearXMPDate ClassImGearXMPDeviceSettings ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPFlash ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPInteger ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPRational ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPOECFSFR ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPOECFSFR ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPLangAlt Class

Syntax

public class ImGearEXIFXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.exif.ImGearEXIFXMPMetadata

See Also

Reference

ImGearEXIFXMPMetadata Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEXIFXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearEXIFXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearEXIFXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearEXIFXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getApertureValue | Returns ApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.
public Method | getBrightnessValue | Returns BrightnessValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.
public Method | getCFAPattern | Returns CFAPattern value of the EXIF XMP schema. This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.
public Method | getColorSpace | Returns ColorSpace value of the EXIF XMP schema. This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.
public Method | getComponentsConfiguration | Returns ComponentsConfiguration value of the EXIF XMP schema. This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.
public Method | getCompressedBitsPerPixel | Returns CompressedBitsPerPixel value of the EXIF XMP schema. This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | getContrast | Returns Contrast value of the EXIF XMP schema. This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.
public Method | getCustomRendered | Returns CustomRendered value of the EXIF XMP schema. This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.
public Method | getDateTimeDigitized | Returns DateTimeDigitized value of the EXIF XMP schema. This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.
public Method | getDateTimeOriginal | Returns DateTimeOriginal value of the EXIF XMP schema. This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.
public Method | getDeviceSettingDescription | Returns DeviceSettingDescription value of the EXIF XMP schema. This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.
public Method | getDigitalZoomRatio | Returns DigitalZoomRatio value of the EXIF XMP schema. This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.
public Method | getExifVersion | Returns ExifVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.
public Method | getExposureBiasValue | Returns ExposureBiasValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.
public Method | getExposureIndex | Returns ExposureIndex value of the EXIF XMP schema. This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.
public Method | getExposureMode | Returns ExposureMode value of the EXIF XMP schema. This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.
public Method | getExposureProgram | Returns ExposureProgram value of the EXIF XMP schema. This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.
public Method | getExposureTime | Returns ExposureTime value of the EXIF XMP schema. This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.
public Method | getFileSource | Returns FileSource value of the EXIF XMP schema. This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.
public Method | getFlash | Returns Flash value of the EXIF XMP schema. This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.
public Method | getFlashEnergy | Returns FlashEnergy value of the EXIF XMP schema. This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.
public Method | getFlashpixVersion | Returns FlashpixVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.
public Method | getFNumber | Returns FNumber value of the EXIF XMP schema. This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.
public Method | getFocalLength | Returns FocalLength value of the EXIF XMP schema. This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.
public Method | getFocalLengthIn35mmFilm | Returns FocalLengthIn35mmFilm value of the EXIF XMP schema. This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | getFocalPlaneResolutionUnit | Returns FocalPlaneResolutionUnit value of the EXIF XMP schema. This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.
public Method | getFocalPlaneXResolution | Returns FocalPlaneXResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.
public Method | getFocalPlaneYResolution | Returns FocalPlaneYResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.
public Method | getGainControl | Returns GainControl value of the EXIF XMP schema. This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.
public Method | getGPSAltitude | Returns GPSAltitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.
public Method | getGPSAltitudeRef | Returns GPSAltitudeRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.
public Method | getGPSAreaInformation | Returns GPSAreaInformation value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.
public Method | getGPSDestBearing | Returns GPSDestBearing value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.
public Method | getGPSDestBearingRef | Returns GPSDestBearingRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.
public Method | getGPSDestDistance | Returns GPSDestDistance value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.
public Method | getGPSDestDistanceRef | Returns GPSDestDistanceRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.
public Method | getGPSDestLatitude | Returns GPSDestLatitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.
public Method | getGPSDestLongitude | Returns GPSDestLongitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.
public Method | getGPSDifferential | Returns GPSDifferential value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.
public Method | getGPSDOP | Returns GPSDOP value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.
public Method | getGPSImgDirection | Returns GPSImgDirection value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.
public Method | getGPSImgDirectionRef | Returns GPSImgDirectionRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.
public Method | getGPSLatitude | Returns GPSLatitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.
public Method | getGPSLongitude | Returns GPSLongitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.
public Method | getGPSMapDatum | Returns GPSMapDatum value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.
public Method | getGPSMeasureMode | Returns GPSMeasureMode value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.
public Method | getGPSProcessingMethod | Returns GPSProcessingMethod value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.
public Method | getGPSSatellites | Returns GPSSatellites value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.
public Method | getGPSSpeed | Returns GPSSpeed value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.
public Method | getGPSSpeedRef | Returns GPSSpeedRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.
public Method | getGPSStatus | Returns GPSStatus value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.
public Method | getGPSTimeStamp | Returns GPSTimeStamp value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.
public Method | getGPSTrack | Returns GPSTrack value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.
public Method | getGPSTrackRef | Returns GPSTrackRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.
public Method | getGPSVersionID | Returns GPSVersionID value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.
public Method | getImageUniqueID | Returns ImageUniqueID value of the EXIF XMP schema. This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.
public Method | getISOSpeedRatings | Returns ISOSpeedRatings value of the EXIF XMP schema. This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.
public Method | getLightSource | Returns LightSource value of the EXIF XMP schema. This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.
public Method | getMaxApertureValue | Returns MaxApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.
public Method | getMeteringMode | Returns MeteringMode value of the EXIF XMP schema. This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.
public Method | getOECF | Returns OECF value of the EXIF XMP schema. This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.
public Method | getPixelXDimension | Returns PixelXDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.
public Method | getPixelYDimension | Returns PixelYDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.
public Method | getRelatedSoundFile | Returns RelatedSoundFile value of the EXIF XMP schema. This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.
public Method | getSaturation | Returns Saturation value of the EXIF XMP schema. This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.
public Method | getSceneCaptureType | Returns SceneCaptureType value of the EXIF XMP schema. This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.
public Method | getSceneType | Returns SceneType value of the EXIF XMP schema. This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.
public Method | getSensingMethod | Returns SensingMethod value of the EXIF XMP schema. This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.
public Method | getSharpness | Returns Sharpness value of the EXIF XMP schema. This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.
public Method | getShutterSpeedValue | Returns ShutterSpeedValue value of the EXIF XMP schema. This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.
public Method | getSpatialFrequencyResponse | Returns SpatialFrequencyResponse value of the EXIF XMP schema. This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.
public Method | getSpectralSensitivity | Returns SpectralSensitivity value of the EXIF XMP schema. This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.
public Method | getSubjectArea | Returns SubjectArea value of the EXIF XMP schema. This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.
public Method | getSubjectDistance | Returns SubjectDistance value of the EXIF XMP schema. This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.
public Method | getSubjectDistanceRange | Returns SubjectDistanceRange value of the EXIF XMP schema. This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.
public Method | getSubjectLocation | Returns SubjectLocation value of the EXIF XMP schema. This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.
public Method | getUserComment | Returns UserComment value of the EXIF XMP schema. This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.
public Method | getWhiteBalance | Returns WhiteBalance value of the EXIF XMP schema. This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.
public Method | setApertureValue | Sets ApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.
public Method | setBrightnessValue | Sets BrightnessValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.
public Method | setCFAPattern | Sets CFAPattern value of the EXIF XMP schema. This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.
public Method | setColorSpace | Sets ColorSpace value of the EXIF XMP schema. This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.
public Method | setComponentsConfiguration | Sets ComponentsConfiguration value of the EXIF XMP schema. This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.
public Method | setCompressedBitsPerPixel | Sets CompressedBitsPerPixel value of the EXIF XMP schema. This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | setContrast | Sets Contrast value of the EXIF XMP schema. This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.
public Method | setCustomRendered | Sets CustomRendered value of the EXIF XMP schema. This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.
public Method | setDateTimeDigitized | Sets DateTimeDigitized value of the EXIF XMP schema. This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.
public Method | setDateTimeOriginal | Sets DateTimeOriginal value of the EXIF XMP schema. This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.
public Method | setDeviceSettingDescription | Sets DeviceSettingDescription value of the EXIF XMP schema. This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.
public Method | setDigitalZoomRatio | Sets DigitalZoomRatio value of the EXIF XMP schema. This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.
public Method | setExifVersion | Sets ExifVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.
public Method | setExposureBiasValue | Sets ExposureBiasValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.
public Method | setExposureIndex | Sets ExposureIndex value of the EXIF XMP schema. This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.
public Method | setExposureMode | Sets ExposureMode value of the EXIF XMP schema. This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.
public Method | setExposureProgram | Sets ExposureProgram value of the EXIF XMP schema. This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.
public Method | setExposureTime | Sets ExposureTime value of the EXIF XMP schema. This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.
public Method | setFileSource | Sets FileSource value of the EXIF XMP schema. This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.
public Method | setFlash | Sets Flash value of the EXIF XMP schema. This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.
public Method | setFlashEnergy | Sets FlashEnergy value of the EXIF XMP schema. This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.
public Method | setFlashpixVersion | Sets FlashpixVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.
public Method | setFNumber | Sets FNumber value of the EXIF XMP schema. This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.
public Method | setFocalLength | Sets FocalLength value of the EXIF XMP schema. This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.
public Method | setFocalLengthIn35mmFilm | Sets FocalLengthIn35mmFilm value of the EXIF XMP schema. This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | setFocalPlaneResolutionUnit | Sets FocalPlaneResolutionUnit value of the EXIF XMP schema. This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.
public Method | setFocalPlaneXResolution | Sets FocalPlaneXResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.
public Method | setFocalPlaneYResolution | Sets FocalPlaneYResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.
public Method | setGainControl | Sets GainControl value of the EXIF XMP schema. This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.
public Method | setGPSAltitude | Sets GPSAltitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.
public Method | setGPSAltitudeRef | Sets GPSAltitudeRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.
public Method | setGPSAreaInformation | Sets GPSAreaInformation value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.
public Method | setGPSDestBearing | Sets GPSDestBearing value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.
public Method | setGPSDestBearingRef | Sets GPSDestBearingRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.
public Method | setGPSDestDistance | Sets GPSDestDistance value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.
public Method | setGPSDestDistanceRef | Sets GPSDestDistanceRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.
public Method | setGPSDestLatitude | Sets GPSDestLatitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.
public Method | setGPSDestLongitude | Sets GPSDestLongitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.
public Method | setGPSDifferential | Sets GPSDifferential value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.
public Method | setGPSDOP | Sets GPSDOP value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.
public Method | setGPSImgDirection | Sets GPSImgDirection value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.
public Method | setGPSImgDirectionRef | Sets GPSImgDirectionRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.
public Method | setGPSLatitude | Sets GPSLatitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.
public Method | setGPSLongitude | Sets GPSLongitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.
public Method | setGPSMapDatum | Sets GPSMapDatum value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.
public Method | setGPSMeasureMode | Sets GPSMeasureMode value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.
public Method | setGPSProcessingMethod | Sets GPSProcessingMethod value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.
public Method | setGPSSatellites | Sets GPSSatellites value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.
public Method | setGPSSpeed | Sets GPSSpeed value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.
public Method | setGPSSpeedRef | Sets GPSSpeedRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.
public Method | setGPSStatus | Sets GPSStatus value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.
public Method | setGPSTimeStamp | Sets GPSTimeStamp value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.
public Method | setGPSTrack | Sets GPSTrack value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.
public Method | setGPSTrackRef | Sets GPSTrackRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.
public Method | setGPSVersionID | Sets GPSVersionID value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.
public Method | setImageUniqueID | Sets ImageUniqueID value of the EXIF XMP schema. This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.
public Method | setISOSpeedRatings | Sets ISOSpeedRatings value of the EXIF XMP schema. This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.
public Method | setLightSource | Sets LightSource value of the EXIF XMP schema. This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.
public Method | setMaxApertureValue | Sets MaxApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.
public Method | setMeteringMode | Sets MeteringMode value of the EXIF XMP schema. This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.
public Method | setOECF | Sets OECF value of the EXIF XMP schema. This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.
public Method | setPixelXDimension | Sets PixelXDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.
public Method | setPixelYDimension | Sets PixelYDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.
public Method | setRelatedSoundFile | Sets RelatedSoundFile value of the EXIF XMP schema. This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.
public Method | setSaturation | Sets Saturation value of the EXIF XMP schema. This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.
public Method | setSceneCaptureType | Sets SceneCaptureType value of the EXIF XMP schema. This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.
public Method | setSceneType | Sets SceneType value of the EXIF XMP schema. This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.
public Method | setSensingMethod | Sets SensingMethod value of the EXIF XMP schema. This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.
public Method | setSharpness | Sets Sharpness value of the EXIF XMP schema. This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.
public Method | setShutterSpeedValue | Sets ShutterSpeedValue value of the EXIF XMP schema. This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.
public Method | setSpatialFrequencyResponse | Sets SpatialFrequencyResponse value of the EXIF XMP schema. This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.
public Method | setSpectralSensitivity | Sets SpectralSensitivity value of the EXIF XMP schema. This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.
public Method | setSubjectArea | Sets SubjectArea value of the EXIF XMP schema. This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.
public Method | setSubjectDistance | Sets SubjectDistance value of the EXIF XMP schema. This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.
public Method | setSubjectDistanceRange | Sets SubjectDistanceRange value of the EXIF XMP schema. This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.
public Method | setSubjectLocation | Sets SubjectLocation value of the EXIF XMP schema. This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.
public Method | setUserComment | Sets UserComment value of the EXIF XMP schema. This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.
public Method | setWhiteBalance | Sets WhiteBalance value of the EXIF XMP schema. This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.
Top

See Also

Reference

ImGearEXIFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearEXIFXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : ImGearEXIFXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearEXIFXMPMetadata class.

Syntax

public ImGearEXIFXMPMetadata()

Return Value

New instance of ImGearEXIFXMPMetadata class object.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEXIFXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearEXIFXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearEXIFXMPMetadata members.

Public Methods

 | Name | Description
public Method | getApertureValue | Returns ApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.
public Method | getBrightnessValue | Returns BrightnessValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.
public Method | getCFAPattern | Returns CFAPattern value of the EXIF XMP schema. This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.
public Method | getColorSpace | Returns ColorSpace value of the EXIF XMP schema. This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.
public Method | getComponentsConfiguration | Returns ComponentsConfiguration value of the EXIF XMP schema. This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.
public Method | getCompressedBitsPerPixel | Returns CompressedBitsPerPixel value of the EXIF XMP schema. This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | getContrast | Returns Contrast value of the EXIF XMP schema. This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.
public Method | getCustomRendered | Returns CustomRendered value of the EXIF XMP schema. This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.
public Method | getDateTimeDigitized | Returns DateTimeDigitized value of the EXIF XMP schema. This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.
public Method | getDateTimeOriginal | Returns DateTimeOriginal value of the EXIF XMP schema. This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.
public Method | getDeviceSettingDescription | Returns DeviceSettingDescription value of the EXIF XMP schema. This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.
public Method | getDigitalZoomRatio | Returns DigitalZoomRatio value of the EXIF XMP schema. This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.
public Method | getExifVersion | Returns ExifVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.
public Method | getExposureBiasValue | Returns ExposureBiasValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.
public Method | getExposureIndex | Returns ExposureIndex value of the EXIF XMP schema. This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.
public Method | getExposureMode | Returns ExposureMode value of the EXIF XMP schema. This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.
public Method | getExposureProgram | Returns ExposureProgram value of the EXIF XMP schema. This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.
public Method | getExposureTime | Returns ExposureTime value of the EXIF XMP schema. This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.
public Method | getFileSource | Returns FileSource value of the EXIF XMP schema. This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.
public Method | getFlash | Returns Flash value of the EXIF XMP schema. This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.
public Method | getFlashEnergy | Returns FlashEnergy value of the EXIF XMP schema. This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.
public Method | getFlashpixVersion | Returns FlashpixVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.
public Method | getFNumber | Returns FNumber value of the EXIF XMP schema. This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.
public Method | getFocalLength | Returns FocalLength value of the EXIF XMP schema. This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.
public Method | getFocalLengthIn35mmFilm | Returns FocalLengthIn35mmFilm value of the EXIF XMP schema. This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | getFocalPlaneResolutionUnit | Returns FocalPlaneResolutionUnit value of the EXIF XMP schema. This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.
public Method | getFocalPlaneXResolution | Returns FocalPlaneXResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.
public Method | getFocalPlaneYResolution | Returns FocalPlaneYResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.
public Method | getGainControl | Returns GainControl value of the EXIF XMP schema. This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.
public Method | getGPSAltitude | Returns GPSAltitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.
public Method | getGPSAltitudeRef | Returns GPSAltitudeRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.
public Method | getGPSAreaInformation | Returns GPSAreaInformation value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.
public Method | getGPSDestBearing | Returns GPSDestBearing value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.
public Method | getGPSDestBearingRef | Returns GPSDestBearingRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.
public Method | getGPSDestDistance | Returns GPSDestDistance value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.
public Method | getGPSDestDistanceRef | Returns GPSDestDistanceRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.
public Method | getGPSDestLatitude | Returns GPSDestLatitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.
public Method | getGPSDestLongitude | Returns GPSDestLongitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.
public Method | getGPSDifferential | Returns GPSDifferential value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.
public Method | getGPSDOP | Returns GPSDOP value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.
public Method | getGPSImgDirection | Returns GPSImgDirection value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.
public Method | getGPSImgDirectionRef | Returns GPSImgDirectionRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.
public Method | getGPSLatitude | Returns GPSLatitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.
public Method | getGPSLongitude | Returns GPSLongitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.
public Method | getGPSMapDatum | Returns GPSMapDatum value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.
public Method | getGPSMeasureMode | Returns GPSMeasureMode value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.
public Method | getGPSProcessingMethod | Returns GPSProcessingMethod value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.
public Method | getGPSSatellites | Returns GPSSatellites value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.
public Method | getGPSSpeed | Returns GPSSpeed value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.
public Method | getGPSSpeedRef | Returns GPSSpeedRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.
public Method | getGPSStatus | Returns GPSStatus value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.
public Method | getGPSTimeStamp | Returns GPSTimeStamp value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.
public Method | getGPSTrack | Returns GPSTrack value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.
public Method | getGPSTrackRef | Returns GPSTrackRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.
public Method | getGPSVersionID | Returns GPSVersionID value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.
public Method | getImageUniqueID | Returns ImageUniqueID value of the EXIF XMP schema. This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.
public Method | getISOSpeedRatings | Returns ISOSpeedRatings value of the EXIF XMP schema. This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.
public Method | getLightSource | Returns LightSource value of the EXIF XMP schema. This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.
public Method | getMaxApertureValue | Returns MaxApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.
public Method | getMeteringMode | Returns MeteringMode value of the EXIF XMP schema. This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.
public Method | getOECF | Returns OECF value of the EXIF XMP schema. This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.
public Method | getPixelXDimension | Returns PixelXDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.
public Method | getPixelYDimension | Returns PixelYDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.
public Method | getRelatedSoundFile | Returns RelatedSoundFile value of the EXIF XMP schema. This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.
public Method | getSaturation | Returns Saturation value of the EXIF XMP schema. This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.
public Method | getSceneCaptureType | Returns SceneCaptureType value of the EXIF XMP schema. This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.
public Method | getSceneType | Returns SceneType value of the EXIF XMP schema. This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.
public Method | getSensingMethod | Returns SensingMethod value of the EXIF XMP schema. This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.
public Method | getSharpness | Returns Sharpness value of the EXIF XMP schema. This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.
public Method | getShutterSpeedValue | Returns ShutterSpeedValue value of the EXIF XMP schema. This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.
public Method | getSpatialFrequencyResponse | Returns SpatialFrequencyResponse value of the EXIF XMP schema. This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.
public Method | getSpectralSensitivity | Returns SpectralSensitivity value of the EXIF XMP schema. This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.
public Method | getSubjectArea | Returns SubjectArea value of the EXIF XMP schema. This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.
public Method | getSubjectDistance | Returns SubjectDistance value of the EXIF XMP schema. This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.
public Method | getSubjectDistanceRange | Returns SubjectDistanceRange value of the EXIF XMP schema. This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.
public Method | getSubjectLocation | Returns SubjectLocation value of the EXIF XMP schema. This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.
public Method | getUserComment | Returns UserComment value of the EXIF XMP schema. This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.
public Method | getWhiteBalance | Returns WhiteBalance value of the EXIF XMP schema. This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.
public Method | setApertureValue | Sets ApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.
public Method | setBrightnessValue | Sets BrightnessValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.
public Method | setCFAPattern | Sets CFAPattern value of the EXIF XMP schema. This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.
public Method | setColorSpace | Sets ColorSpace value of the EXIF XMP schema. This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.
public Method | setComponentsConfiguration | Sets ComponentsConfiguration value of the EXIF XMP schema. This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.
public Method | setCompressedBitsPerPixel | Sets CompressedBitsPerPixel value of the EXIF XMP schema. This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.
public Method | setContrast | Sets Contrast value of the EXIF XMP schema. This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.
public Method | setCustomRendered | Sets CustomRendered value of the EXIF XMP schema. This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.
public Method | setDateTimeDigitized | Sets DateTimeDigitized value of the EXIF XMP schema. This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.
public Method | setDateTimeOriginal | Sets DateTimeOriginal value of the EXIF XMP schema. This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.
public Method | setDeviceSettingDescription | Sets DeviceSettingDescription value of the EXIF XMP schema. This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.
public Method | setDigitalZoomRatio | Sets DigitalZoomRatio value of the EXIF XMP schema. This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.
public Method | setExifVersion | Sets ExifVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.
public Method | setExposureBiasValue | Sets ExposureBiasValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.
public Method | setExposureIndex | Sets ExposureIndex value of the EXIF XMP schema. This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.
public Method | setExposureMode | Sets ExposureMode value of the EXIF XMP schema. This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.
public Method | setExposureProgram | Sets ExposureProgram value of the EXIF XMP schema. This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.
public Method | setExposureTime | Sets ExposureTime value of the EXIF XMP schema. This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.
public Method | setFileSource | Sets FileSource value of the EXIF XMP schema. This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.
public Method | setFlash | Sets Flash value of the EXIF XMP schema. This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.
public Method | setFlashEnergy | Sets FlashEnergy value of the EXIF XMP schema. This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.
public Method | setFlashpixVersion | Sets FlashpixVersion value of the EXIF XMP schema. This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.
public Method | setFNumber | Sets FNumber value of the EXIF XMP schema. This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.
public Method | setFocalLength | Sets FocalLength value of the EXIF XMP schema. This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.
public Method | setFocalLengthIn35mmFilm | Sets FocalLengthIn35mmFilm value of the EXIF XMP schema. This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
public Method | setFocalPlaneResolutionUnit | Sets FocalPlaneResolutionUnit value of the EXIF XMP schema. This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.
public Method | setFocalPlaneXResolution | Sets FocalPlaneXResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.
public Method | setFocalPlaneYResolution | Sets FocalPlaneYResolution value of the EXIF XMP schema. This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.
public Method | setGainControl | Sets GainControl value of the EXIF XMP schema. This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.
public Method | setGPSAltitude | Sets GPSAltitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.
public Method | setGPSAltitudeRef | Sets GPSAltitudeRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.
public Method | setGPSAreaInformation | Sets GPSAreaInformation value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.
public Method | setGPSDestBearing | Sets GPSDestBearing value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.
public Method | setGPSDestBearingRef | Sets GPSDestBearingRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.
public Method | setGPSDestDistance | Sets GPSDestDistance value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.
public Method | setGPSDestDistanceRef | Sets GPSDestDistanceRef value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.
public Method | setGPSDestLatitude | Sets GPSDestLatitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.
public Method | setGPSDestLongitude | Sets GPSDestLongitude value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.
public Method | setGPSDifferential | Sets GPSDifferential value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.
public Method | setGPSDOP | Sets GPSDOP value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.
public Method | setGPSImgDirection | Sets GPSImgDirection value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.
public Method | setGPSImgDirectionRef | Sets GPSImgDirectionRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.
public Method | setGPSLatitude | Sets GPSLatitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.
public Method | setGPSLongitude | Sets GPSLongitude value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.
public Method | setGPSMapDatum | Sets GPSMapDatum value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.
public Method | setGPSMeasureMode | Sets GPSMeasureMode value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.
public Method | setGPSProcessingMethod | Sets GPSProcessingMethod value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.
public Method | setGPSSatellites | Sets GPSSatellites value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.
public Method | setGPSSpeed | Sets GPSSpeed value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.
public Method | setGPSSpeedRef | Sets GPSSpeedRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.
public Method | setGPSStatus | Sets GPSStatus value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.
public Method | setGPSTimeStamp | Sets GPSTimeStamp value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.
public Method | setGPSTrack | Sets GPSTrack value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.
public Method | setGPSTrackRef | Sets GPSTrackRef value of the EXIF XMP schema. This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.
public Method | setGPSVersionID | Sets GPSVersionID value of the EXIF XMP schema. This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.
public Method | setImageUniqueID | Sets ImageUniqueID value of the EXIF XMP schema. This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.
public Method | setISOSpeedRatings | Sets ISOSpeedRatings value of the EXIF XMP schema. This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.
public Method | setLightSource | Sets LightSource value of the EXIF XMP schema. This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.
public Method | setMaxApertureValue | Sets MaxApertureValue value of the EXIF XMP schema. This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.
public Method | setMeteringMode | Sets MeteringMode value of the EXIF XMP schema. This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.
public Method | setOECF | Sets OECF value of the EXIF XMP schema. This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.
public Method | setPixelXDimension | Sets PixelXDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.
public Method | setPixelYDimension | Sets PixelYDimension value of the EXIF XMP schema. This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.
public Method | setRelatedSoundFile | Sets RelatedSoundFile value of the EXIF XMP schema. This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.
public Method | setSaturation | Sets Saturation value of the EXIF XMP schema. This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.
public Method | setSceneCaptureType | Sets SceneCaptureType value of the EXIF XMP schema. This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.
public Method | setSceneType | Sets SceneType value of the EXIF XMP schema. This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.
public Method | setSensingMethod | Sets SensingMethod value of the EXIF XMP schema. This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.
public Method | setSharpness | Sets Sharpness value of the EXIF XMP schema. This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.
public Method | setShutterSpeedValue | Sets ShutterSpeedValue value of the EXIF XMP schema. This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.
public Method | setSpatialFrequencyResponse | Sets SpatialFrequencyResponse value of the EXIF XMP schema. This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.
public Method | setSpectralSensitivity | Sets SpectralSensitivity value of the EXIF XMP schema. This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.
public Method | setSubjectArea | Sets SubjectArea value of the EXIF XMP schema. This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.
public Method | setSubjectDistance | Sets SubjectDistance value of the EXIF XMP schema. This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.
public Method | setSubjectDistanceRange | Sets SubjectDistanceRange value of the EXIF XMP schema. This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.
public Method | setSubjectLocation | Sets SubjectLocation value of the EXIF XMP schema. This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.
public Method | setUserComment | Sets UserComment value of the EXIF XMP schema. This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.
public Method | setWhiteBalance | Sets WhiteBalance value of the EXIF XMP schema. This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.
Top

See Also

Reference

ImGearEXIFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getApertureValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getApertureValue Method

Glossary Item Box

Returns ApertureValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.

Syntax

public ImGearXMPRational getApertureValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getBrightnessValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getBrightnessValue Method

Glossary Item Box

Returns BrightnessValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.

Syntax

public ImGearXMPRational getBrightnessValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getCFAPattern Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getCFAPattern Method

Glossary Item Box

Returns CFAPattern value of the EXIF XMP schema.

This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.

Syntax

public ImGearXMPCFAPattern getCFAPattern()

Return Value

ImGearXMPCFAPattern class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getColorSpace Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getColorSpace Method

Glossary Item Box

Returns ColorSpace value of the EXIF XMP schema.

This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFColorSpace> getColorSpace()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFColorSpace type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getComponentsConfiguration Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getComponentsConfiguration Method

Glossary Item Box

Returns ComponentsConfiguration value of the EXIF XMP schema.

This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getComponentsConfiguration()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getCompressedBitsPerPixel Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getCompressedBitsPerPixel Method

Glossary Item Box

Returns CompressedBitsPerPixel value of the EXIF XMP schema.

This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.

Syntax

public ImGearXMPRational getCompressedBitsPerPixel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getContrast Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getContrast Method

Glossary Item Box

Returns Contrast value of the EXIF XMP schema.

This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFContrastMode> getContrast()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFContrastMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getCustomRendered Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getCustomRendered Method

Glossary Item Box

Returns CustomRendered value of the EXIF XMP schema.

This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFCustomRendered> getCustomRendered()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFCustomRendered type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getDateTimeDigitized Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getDateTimeDigitized Method

Glossary Item Box

Returns DateTimeDigitized value of the EXIF XMP schema.

This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.

Syntax

public ImGearXMPDate getDateTimeDigitized()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getDateTimeOriginal Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getDateTimeOriginal Method

Glossary Item Box

Returns DateTimeOriginal value of the EXIF XMP schema.

This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.

Syntax

public ImGearXMPDate getDateTimeOriginal()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getDeviceSettingDescription Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getDeviceSettingDescription Method

Glossary Item Box

Returns DeviceSettingDescription value of the EXIF XMP schema.

This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.

Syntax

public ImGearXMPDeviceSettings getDeviceSettingDescription()

Return Value

ImGearXMPDeviceSettings class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getDigitalZoomRatio Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getDigitalZoomRatio Method

Glossary Item Box

Returns DigitalZoomRatio value of the EXIF XMP schema.

This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.

Syntax

public ImGearXMPRational getDigitalZoomRatio()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExifVersion Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExifVersion Method

Glossary Item Box

Returns ExifVersion value of the EXIF XMP schema.

This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.

Syntax

public ImGearXMPString getExifVersion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExposureBiasValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExposureBiasValue Method

Glossary Item Box

Returns ExposureBiasValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.

Syntax

public ImGearXMPRational getExposureBiasValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExposureIndex Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExposureIndex Method

Glossary Item Box

Returns ExposureIndex value of the EXIF XMP schema.

This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.

Syntax

public ImGearXMPRational getExposureIndex()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExposureMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExposureMode Method

Glossary Item Box

Returns ExposureMode value of the EXIF XMP schema.

This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFExposureMode> getExposureMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExposureProgram Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExposureProgram Method

Glossary Item Box

Returns ExposureProgram value of the EXIF XMP schema.

This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFExposureProgram> getExposureProgram()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureProgram type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getExposureTime Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getExposureTime Method

Glossary Item Box

Returns ExposureTime value of the EXIF XMP schema.

This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.

Syntax

public ImGearXMPRational getExposureTime()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFileSource Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFileSource Method

Glossary Item Box

Returns FileSource value of the EXIF XMP schema.

This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFileSource> getFileSource()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFileSource type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFlash Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFlash Method

Glossary Item Box

Returns Flash value of the EXIF XMP schema.

This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.

Syntax

public ImGearXMPFlash getFlash()

Return Value

ImGearXMPFlash class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFlashEnergy Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFlashEnergy Method

Glossary Item Box

Returns FlashEnergy value of the EXIF XMP schema.

This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.

Syntax

public ImGearXMPRational getFlashEnergy()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFlashpixVersion Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFlashpixVersion Method

Glossary Item Box

Returns FlashpixVersion value of the EXIF XMP schema.

This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.

Syntax

public ImGearXMPString getFlashpixVersion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFNumber Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFNumber Method

Glossary Item Box

Returns FNumber value of the EXIF XMP schema.

This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.

Syntax

public ImGearXMPRational getFNumber()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFocalLength Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFocalLength Method

Glossary Item Box

Returns FocalLength value of the EXIF XMP schema.

This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.

Syntax

public ImGearXMPRational getFocalLength()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFocalLengthIn35mmFilm Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFocalLengthIn35mmFilm Method

Glossary Item Box

Returns FocalLengthIn35mmFilm value of the EXIF XMP schema.

This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Syntax

public ImGearXMPInteger getFocalLengthIn35mmFilm()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFocalPlaneResolutionUnit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFocalPlaneResolutionUnit Method

Glossary Item Box

Returns FocalPlaneResolutionUnit value of the EXIF XMP schema.

This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFResolutionUnit> getFocalPlaneResolutionUnit()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFocalPlaneXResolution Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFocalPlaneXResolution Method

Glossary Item Box

Returns FocalPlaneXResolution value of the EXIF XMP schema.

This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.

Syntax

public ImGearXMPRational getFocalPlaneXResolution()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getFocalPlaneYResolution Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getFocalPlaneYResolution Method

Glossary Item Box

Returns FocalPlaneYResolution value of the EXIF XMP schema.

This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.

Syntax

public ImGearXMPRational getFocalPlaneYResolution()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGainControl Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGainControl Method

Glossary Item Box

Returns GainControl value of the EXIF XMP schema.

This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGainControl> getGainControl()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGainControl type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSAltitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSAltitude Method

Glossary Item Box

Returns GPSAltitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.

Syntax

public ImGearXMPRational getGPSAltitude()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSAltitudeRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSAltitudeRef Method

Glossary Item Box

Returns GPSAltitudeRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSAltitudeReference> getGPSAltitudeRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSAltitudeReference type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSAreaInformation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSAreaInformation Method

Glossary Item Box

Returns GPSAreaInformation value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.

Syntax

public ImGearXMPString getGPSAreaInformation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestBearing Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestBearing Method

Glossary Item Box

Returns GPSDestBearing value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.

Syntax

public ImGearXMPRational getGPSDestBearing()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestBearingRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestBearingRef Method

Glossary Item Box

Returns GPSDestBearingRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.

Syntax

public ImGearXMPString getGPSDestBearingRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestDistance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestDistance Method

Glossary Item Box

Returns GPSDestDistance value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.

Syntax

public ImGearXMPRational getGPSDestDistance()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestDistanceRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestDistanceRef Method

Glossary Item Box

Returns GPSDestDistanceRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.

Syntax

public ImGearXMPString getGPSDestDistanceRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestLatitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestLatitude Method

Glossary Item Box

Returns GPSDestLatitude value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.

Syntax

public ImGearXMPString getGPSDestLatitude()

Return Value

ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDestLongitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDestLongitude Method

Glossary Item Box

Returns GPSDestLongitude value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.

Syntax

public ImGearXMPString getGPSDestLongitude()

Return Value

ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDifferential Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDifferential Method

Glossary Item Box

Returns GPSDifferential value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSDifferential> getGPSDifferential()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDifferential type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSDOP Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSDOP Method

Glossary Item Box

Returns GPSDOP value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.

Syntax

public ImGearXMPRational getGPSDOP()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSImgDirection Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSImgDirection Method

Glossary Item Box

Returns GPSImgDirection value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.

Syntax

public ImGearXMPRational getGPSImgDirection()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSImgDirectionRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSImgDirectionRef Method

Glossary Item Box

Returns GPSImgDirectionRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSDirectionReference> getGPSImgDirectionRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDirectionReference type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSLatitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSLatitude Method

Glossary Item Box

Returns GPSLatitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.

Syntax

public ImGearXMPString getGPSLatitude()

Return Value

ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSLongitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSLongitude Method

Glossary Item Box

Returns GPSLongitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.

Syntax

public ImGearXMPString getGPSLongitude()

Return Value

ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSMapDatum Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSMapDatum Method

Glossary Item Box

Returns GPSMapDatum value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.

Syntax

public ImGearXMPString getGPSMapDatum()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSMeasureMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSMeasureMode Method

Glossary Item Box

Returns GPSMeasureMode value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.

Syntax

public ImGearXMPString getGPSMeasureMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSProcessingMethod Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSProcessingMethod Method

Glossary Item Box

Returns GPSProcessingMethod value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.

Syntax

public ImGearXMPString getGPSProcessingMethod()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSSatellites Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSSatellites Method

Glossary Item Box

Returns GPSSatellites value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.

Syntax

public ImGearXMPString getGPSSatellites()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSSpeed Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSSpeed Method

Glossary Item Box

Returns GPSSpeed value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.

Syntax

public ImGearXMPRational getGPSSpeed()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSSpeedRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSSpeedRef Method

Glossary Item Box

Returns GPSSpeedRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.

Syntax

public ImGearXMPString getGPSSpeedRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSStatus Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSStatus Method

Glossary Item Box

Returns GPSStatus value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.

Syntax

public ImGearXMPString getGPSStatus()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSTimeStamp Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSTimeStamp Method

Glossary Item Box

Returns GPSTimeStamp value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.

Syntax

public ImGearXMPDate getGPSTimeStamp()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSTrack Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSTrack Method

Glossary Item Box

Returns GPSTrack value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.

Syntax

public ImGearXMPRational getGPSTrack()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSTrackRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSTrackRef Method

Glossary Item Box

Returns GPSTrackRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.

Syntax

public ImGearXMPString getGPSTrackRef()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getGPSVersionID Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getGPSVersionID Method

Glossary Item Box

Returns GPSVersionID value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.

Syntax

public ImGearXMPString getGPSVersionID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getImageUniqueID Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getImageUniqueID Method

Glossary Item Box

Returns ImageUniqueID value of the EXIF XMP schema.

This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.

Syntax

public ImGearXMPString getImageUniqueID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getISOSpeedRatings Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getISOSpeedRatings Method

Glossary Item Box

Returns ISOSpeedRatings value of the EXIF XMP schema.

This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getISOSpeedRatings()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getLightSource Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getLightSource Method

Glossary Item Box

Returns LightSource value of the EXIF XMP schema.

This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFLightSource> getLightSource()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFLightSource type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getMaxApertureValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getMaxApertureValue Method

Glossary Item Box

Returns MaxApertureValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.

Syntax

public ImGearXMPRational getMaxApertureValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getMeteringMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getMeteringMode Method

Glossary Item Box

Returns MeteringMode value of the EXIF XMP schema.

This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFMeteringMode> getMeteringMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFMeteringMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getOECF Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getOECF Method

Glossary Item Box

Returns OECF value of the EXIF XMP schema.

This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.

Syntax

public ImGearXMPOECFSFR getOECF()

Return Value

ImGearXMPOECFSFR class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getPixelXDimension Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getPixelXDimension Method

Glossary Item Box

Returns PixelXDimension value of the EXIF XMP schema.

This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.

Syntax

public ImGearXMPInteger getPixelXDimension()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getPixelYDimension Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getPixelYDimension Method

Glossary Item Box

Returns PixelYDimension value of the EXIF XMP schema.

This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.

Syntax

public ImGearXMPInteger getPixelYDimension()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getRelatedSoundFile Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getRelatedSoundFile Method

Glossary Item Box

Returns RelatedSoundFile value of the EXIF XMP schema.

This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.

Syntax

public ImGearXMPString getRelatedSoundFile()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSaturation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSaturation Method

Glossary Item Box

Returns Saturation value of the EXIF XMP schema.

This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSaturationMode> getSaturation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSaturationMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSceneCaptureType Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSceneCaptureType Method

Glossary Item Box

Returns SceneCaptureType value of the EXIF XMP schema.

This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSceneCaptureType> getSceneCaptureType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneCaptureType type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSceneType Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSceneType Method

Glossary Item Box

Returns SceneType value of the EXIF XMP schema.

This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSceneType> getSceneType()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneType type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSensingMethod Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSensingMethod Method

Glossary Item Box

Returns SensingMethod value of the EXIF XMP schema.

This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSensingMethod> getSensingMethod()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSensingMethod type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSharpness Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSharpness Method

Glossary Item Box

Returns Sharpness value of the EXIF XMP schema.

This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSharpnessMode> getSharpness()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSharpnessMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getShutterSpeedValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getShutterSpeedValue Method

Glossary Item Box

Returns ShutterSpeedValue value of the EXIF XMP schema.

This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.

Syntax

public ImGearXMPRational getShutterSpeedValue()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSpatialFrequencyResponse Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSpatialFrequencyResponse Method

Glossary Item Box

Returns SpatialFrequencyResponse value of the EXIF XMP schema.

This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.

Syntax

public ImGearXMPOECFSFR getSpatialFrequencyResponse()

Return Value

ImGearXMPOECFSFR class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSpectralSensitivity Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSpectralSensitivity Method

Glossary Item Box

Returns SpectralSensitivity value of the EXIF XMP schema.

This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.

Syntax

public ImGearXMPString getSpectralSensitivity()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSubjectArea Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSubjectArea Method

Glossary Item Box

Returns SubjectArea value of the EXIF XMP schema.

This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getSubjectArea()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSubjectDistance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSubjectDistance Method

Glossary Item Box

Returns SubjectDistance value of the EXIF XMP schema.

This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.

Syntax

public ImGearXMPRational getSubjectDistance()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSubjectDistanceRange Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSubjectDistanceRange Method

Glossary Item Box

Returns SubjectDistanceRange value of the EXIF XMP schema.

This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSubjectDistanceRange> getSubjectDistanceRange()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSubjectDistanceRange type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getSubjectLocation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getSubjectLocation Method

Glossary Item Box

Returns SubjectLocation value of the EXIF XMP schema.

This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getSubjectLocation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getUserComment Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getUserComment Method

Glossary Item Box

Returns UserComment value of the EXIF XMP schema.

This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.

Syntax

public ImGearXMPLangAlt getUserComment()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

getWhiteBalance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : getWhiteBalance Method

Glossary Item Box

Returns WhiteBalance value of the EXIF XMP schema.

This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFWhiteBalanceMode> getWhiteBalance()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFWhiteBalanceMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setApertureValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setApertureValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets ApertureValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37378 (0x9202) and specifies lens aperture in APEX units.

Syntax

public void setApertureValue(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setBrightnessValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setBrightnessValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets BrightnessValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37379 (0x9203) and specifies brightness, unit is APEX.

Syntax

public void setBrightnessValue(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setCFAPattern Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setCFAPattern Method
value
ImGearXMPCFAPattern class value.

Glossary Item Box

Sets CFAPattern value of the EXIF XMP schema.

This XMP method represents EXIF tag 41730 (0xA302) and specifies color filter array geometric pattern of the image sense.

Syntax

public void setCFAPattern(
   ImGearXMPCFAPattern value
)

Parameters

value
ImGearXMPCFAPattern class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setColorSpace Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setColorSpace Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFColorSpace type parameter.

Glossary Item Box

Sets ColorSpace value of the EXIF XMP schema.

This XMP method represents EXIF tag 40961 (0xA001) and specifies color space information.

Syntax

public void setColorSpace(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFColorSpace> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFColorSpace type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setComponentsConfiguration Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setComponentsConfiguration Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets ComponentsConfiguration value of the EXIF XMP schema.

This XMP method represents EXIF tag 37121 (0x9101) and specifies configuration of components in data.

Syntax

public void setComponentsConfiguration(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setCompressedBitsPerPixel Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setCompressedBitsPerPixel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets CompressedBitsPerPixel value of the EXIF XMP schema.

This XMP value represents EXIF tag 37122 (0x9102) and specifies compression mode used for a compressed image is indicated in unit bits per pixel.

Syntax

public void setCompressedBitsPerPixel(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setContrast Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setContrast Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFContrastMode type parameter.

Glossary Item Box

Sets Contrast value of the EXIF XMP schema.

This XMP method represents EXIF tag 41992 (0xA408) and indicates the direction of contrast processing applied by the camera.

Syntax

public void setContrast(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFContrastMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFContrastMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setCustomRendered Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setCustomRendered Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFCustomRendered type parameter.

Glossary Item Box

Sets CustomRendered value of the EXIF XMP schema.

This XMP value represents EXIF tag 41985 (0xA401) and indicates the use of special processing on image data.

Syntax

public void setCustomRendered(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFCustomRendered> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFCustomRendered type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setDateTimeDigitized Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setDateTimeDigitized Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateTimeDigitized value of the EXIF XMP schema.

This XMP value represents EXIF tag 36868, 0x9004 (primary) and 37522, 0x9292 (subseconds). It specifies date and time when image was stored as digital data, can be the same as DateTimeOriginal if originally stored in digital form.

Syntax

public void setDateTimeDigitized(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setDateTimeOriginal Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setDateTimeOriginal Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateTimeOriginal value of the EXIF XMP schema.

This XMP method represents EXIF tags 36867, 0x9003 (primary) and 37521, 0x9291 (subseconds). It specifies date and time when original image was generated.

Syntax

public void setDateTimeOriginal(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setDeviceSettingDescription Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setDeviceSettingDescription Method
value
ImGearXMPDeviceSettings class value.

Glossary Item Box

Sets DeviceSettingDescription value of the EXIF XMP schema.

This XMP method represents EXIF tag 41995 (0xA40B) and indicates information on the picture-taking conditions of a particular camera model.

Syntax

public void setDeviceSettingDescription(
   ImGearXMPDeviceSettings value
)

Parameters

value
ImGearXMPDeviceSettings class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setDigitalZoomRatio Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setDigitalZoomRatio Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets DigitalZoomRatio value of the EXIF XMP schema.

This XMP value represents EXIF tag 41988 (0xA404) and indicates the digital zoom ratio when the image was shot.

Syntax

public void setDigitalZoomRatio(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExifVersion Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExifVersion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ExifVersion value of the EXIF XMP schema.

This XMP method represents EXIF tag 36864 (0x9000) and specifies EXIF version number.

Syntax

public void setExifVersion(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExposureBiasValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExposureBiasValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets ExposureBiasValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37380 (0x9204) and specifies exposure bias, unit is APEX.

Syntax

public void setExposureBiasValue(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExposureIndex Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExposureIndex Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets ExposureIndex value of the EXIF XMP schema.

This XMP value represents EXIF tag 41493 (0xA215) and specifies exposure index of input device.

Syntax

public void setExposureIndex(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExposureMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExposureMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureMode type parameter.

Glossary Item Box

Sets ExposureMode value of the EXIF XMP schema.

This XMP value represents EXIF tag 41986 (0xA402) and indicates the exposure mode set when the image was shot.

Syntax

public void setExposureMode(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFExposureMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExposureProgram Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExposureProgram Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureProgram type parameter.

Glossary Item Box

Sets ExposureProgram value of the EXIF XMP schema.

This XMP value represents EXIF tag 34850 (0x8822) and specifies class of program used for exposure.

Syntax

public void setExposureProgram(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFExposureProgram> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFExposureProgram type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setExposureTime Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setExposureTime Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets ExposureTime value of the EXIF XMP schema.

This XMP method represents EXIF tag 33434 (0x829A) and specifies exposure time in seconds.

Syntax

public void setExposureTime(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFileSource Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFileSource Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFileSource type parameter.

Glossary Item Box

Sets FileSource value of the EXIF XMP schema.

This XMP method represents EXIF tag 41728 (0xA300) and indicates image source.

Syntax

public void setFileSource(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFileSource> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFileSource type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFlash Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFlash Method
value
ImGearXMPFlash class value.

Glossary Item Box

Sets Flash value of the EXIF XMP schema.

This XMP method represents EXIF tag 37385 (0x9209) and specifies strobe light (flash) source data.

Syntax

public void setFlash(
   ImGearXMPFlash value
)

Parameters

value
ImGearXMPFlash class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFlashEnergy Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFlashEnergy Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FlashEnergy value of the EXIF XMP schema.

This XMP method represents EXIF tag 41483 (0xA20B) and specifies strobe energy during image capture.

Syntax

public void setFlashEnergy(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFlashpixVersion Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFlashpixVersion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets FlashpixVersion value of the EXIF XMP schema.

This XMP method represents EXIF tag 40960 (0xA000) and specifies version of FlashPix.

Syntax

public void setFlashpixVersion(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFNumber Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFNumber Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FNumber value of the EXIF XMP schema.

This XMP method represents EXIF tag 33437 (0x829D) and specifies F number.

Syntax

public void setFNumber(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFocalLength Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFocalLength Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FocalLength value of the EXIF XMP schema.

This XMP method represents EXIF tag 37386 (0x920A) and specifies focal length of the lens, in millimeters.

Syntax

public void setFocalLength(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFocalLengthIn35mmFilm Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFocalLengthIn35mmFilm Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets FocalLengthIn35mmFilm value of the EXIF XMP schema.

This XMP value represents EXIF tag 41989 (0xA405) and indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.

Syntax

public void setFocalLengthIn35mmFilm(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFocalPlaneResolutionUnit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFocalPlaneResolutionUnit Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

Glossary Item Box

Sets FocalPlaneResolutionUnit value of the EXIF XMP schema.

This XMP value represents EXIF tag 41488 (0xA210) and specifies unit used for FocalPlaneXResolution and FocalPlaneYResolution.

Syntax

public void setFocalPlaneResolutionUnit(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFResolutionUnit> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFocalPlaneXResolution Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFocalPlaneXResolution Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FocalPlaneXResolution value of the EXIF XMP schema.

This XMP value represents EXIF tag 41486 (0xA20E) and specifies horizontal focal resolution, measured pixels per unit.

Syntax

public void setFocalPlaneXResolution(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setFocalPlaneYResolution Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setFocalPlaneYResolution Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets FocalPlaneYResolution value of the EXIF XMP schema.

This XMP value represents EXIF tag 41487 (0xA20F) and specifies vertical focal resolution, measured in pixels per unit.

Syntax

public void setFocalPlaneYResolution(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGainControl Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGainControl Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGainControl type parameter.

Glossary Item Box

Sets GainControl value of the EXIF XMP schema.

This XMP method represents EXIF tag 41991 (0xA407) and indicates the degree of overall image gain adjustment.

Syntax

public void setGainControl(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGainControl> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGainControl type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSAltitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSAltitude Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSAltitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 6 (0x06) and indicates altitude in meters.

Syntax

public void setGPSAltitude(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSAltitudeRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSAltitudeRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSAltitudeReference type parameter.

Glossary Item Box

Sets GPSAltitudeRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 5 (0x5) and indicates whether the altitude is above or below sea level.

Syntax

public void setGPSAltitudeRef(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSAltitudeReference> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSAltitudeReference type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSAreaInformation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSAreaInformation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSAreaInformation value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 28 (0x1C) and specifies a character string recording the name of the GPS area.

Syntax

public void setGPSAreaInformation(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestBearing Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestBearing Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSDestBearing value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 24 (0x18) and specifies destination bearing, values from 0 to 359.99.

Syntax

public void setGPSDestBearing(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestBearingRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestBearingRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSDestBearingRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 23 (0x17) and specifies reference for movement direction.

Syntax

public void setGPSDestBearingRef(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestDistance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestDistance Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSDestDistance value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 26 (0x1A) and specifies distance to destination.

Syntax

public void setGPSDestDistance(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestDistanceRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestDistanceRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSDestDistanceRef value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 25 (0x19) and specifies units used for speed measurement.

Syntax

public void setGPSDestDistanceRef(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestLatitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestLatitude Method
value
ImGearXMPGPSCoordinate class value.

Glossary Item Box

Sets GPSDestLatitude value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 20, 0x14 (position) and 19, 0x13 (North/South). Indicates destination latitude.

Syntax

public void setGPSDestLatitude(
   ImGearXMPString value
)

Parameters

value
ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDestLongitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDestLongitude Method
value
ImGearXMPGPSCoordinate class value.

Glossary Item Box

Sets GPSDestLongitude value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 22, 0x16 (position) and 21, 0x15 (East/West). Indicates destination longitude.

Syntax

public void setGPSDestLongitude(
   ImGearXMPString value
)

Parameters

value
ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDifferential Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDifferential Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDifferential type parameter.

Glossary Item Box

Sets GPSDifferential value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 30 (0x1E) and indicates whether differential correction is applied to the GPS receiver.

Syntax

public void setGPSDifferential(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSDifferential> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDifferential type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSDOP Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSDOP Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSDOP value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 11 (0x0B) and specifies degree of precision for GPS data.

Syntax

public void setGPSDOP(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSImgDirection Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSImgDirection Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSImgDirection value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 17 (0x11) and specifies direction of image when captured, values range from 0 to 359.99.

Syntax

public void setGPSImgDirection(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSImgDirectionRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSImgDirectionRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDirectionReference type parameter.

Glossary Item Box

Sets GPSImgDirectionRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 16 (0x10) and specifies reference for movement direction.

Syntax

public void setGPSImgDirectionRef(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFGPSDirectionReference> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFGPSDirectionReference type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSLatitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSLatitude Method
value
ImGearXMPGPSCoordinate class value.

Glossary Item Box

Sets GPSLatitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 2, 0x02 (position) and 1, 0x01 (North/South). Indicates latitude.

Syntax

public void setGPSLatitude(
   ImGearXMPString value
)

Parameters

value
ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSLongitude Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSLongitude Method
value
ImGearXMPGPSCoordinate class value.

Glossary Item Box

Sets GPSLongitude value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 4, 0x04 (position) and 3, 0x03 (East/West). Indicates longitude.

Syntax

public void setGPSLongitude(
   ImGearXMPString value
)

Parameters

value
ImGearXMPGPSCoordinate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSMapDatum Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSMapDatum Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSMapDatum value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 18 (0x12) and specifies geodetic survey data.

Syntax

public void setGPSMapDatum(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSMeasureMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSMeasureMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSMeasureMode value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 10 (0x0A) and specifies GPS measurement mode.

Syntax

public void setGPSMeasureMode(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSProcessingMethod Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSProcessingMethod Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSProcessingMethod value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 27 (0x1B) and specifies a character string recording the name of the method used for location finding.

Syntax

public void setGPSProcessingMethod(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSSatellites Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSSatellites Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSSatellites value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 8 (0x08) and specifies satellite information, format is unspecified.

Syntax

public void setGPSSatellites(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSSpeed Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSSpeed Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSSpeed value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 13 (0x0D) and specifies speed of GPS receiver movement.

Syntax

public void setGPSSpeed(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSSpeedRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSSpeedRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSSpeedRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 12 (0x0C) and specifies units used to speed measurement.

Syntax

public void setGPSSpeedRef(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSStatus Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSStatus Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSStatus value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 9 (0x09) and specifies status of GPS receiver at image creation time.

Syntax

public void setGPSStatus(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSTimeStamp Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSTimeStamp Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets GPSTimeStamp value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 29 (date), 0x1D, and, and GPS tag 7 (time) (0x07) and specifies time stamp of GPS data, in Coordinated Universal Time.

Syntax

public void setGPSTimeStamp(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSTrack Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSTrack Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets GPSTrack value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 15 (0x0F) and specifies direction of GPS movement, values range from 0 to 359.99.

Syntax

public void setGPSTrack(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSTrackRef Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSTrackRef Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSTrackRef value of the EXIF XMP schema.

This XMP method represents EXIF GPS tag 14 (0x0E) and specifies reference for movement direction.

Syntax

public void setGPSTrackRef(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setGPSVersionID Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setGPSVersionID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets GPSVersionID value of the EXIF XMP schema.

This XMP value represents EXIF GPS tag 0 (0x00) and specifies a decimal encoding of each of the four EXIF bytes with period separators. The current value is '2.0.0.0'.

Syntax

public void setGPSVersionID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setImageUniqueID Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setImageUniqueID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ImageUniqueID value of the EXIF XMP schema.

This XMP value represents EXIF tag 42016 (0xA420) and specifies an identifier assigned uniquely to each image. It is recorded as a 32 character ASCII string, equivalent to hexadecimal notation and 128-bit fixed length.

Syntax

public void setImageUniqueID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setISOSpeedRatings Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setISOSpeedRatings Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets ISOSpeedRatings value of the EXIF XMP schema.

This XMP method represents EXIF tag 34855 (0x8827) and specifies ISO Speed and ISO Latitude of the input device as specified in ISO 12232.

Syntax

public void setISOSpeedRatings(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setLightSource Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setLightSource Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFLightSource type parameter.

Glossary Item Box

Sets LightSource value of the EXIF XMP schema.

This XMP method represents EXIF tag 37384 (0x9208) and specifies light source.

Syntax

public void setLightSource(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFLightSource> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFLightSource type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setMaxApertureValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setMaxApertureValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets MaxApertureValue value of the EXIF XMP schema.

This XMP method represents EXIF tag 37381 (0x9205) and specifies smallest F number of lens, in APEX.

Syntax

public void setMaxApertureValue(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setMeteringMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setMeteringMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFMeteringMode type parameter.

Glossary Item Box

Sets MeteringMode value of the EXIF XMP schema.

This XMP method represents EXIF tag 37383 (0x9207) and specifies image metering mode.

Syntax

public void setMeteringMode(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFMeteringMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFMeteringMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setOECF Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setOECF Method
value
ImGearXMPOECFSFR class value.

Glossary Item Box

Sets OECF value of the EXIF XMP schema.

This XMP method represents EXIF tag 34856 (0x8828) and specifies Opto-Electronic Conversion Function as specified in ISO 14524.

Syntax

public void setOECF(
   ImGearXMPOECFSFR value
)

Parameters

value
ImGearXMPOECFSFR class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setPixelXDimension Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setPixelXDimension Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets PixelXDimension value of the EXIF XMP schema.

This XMP method represents EXIF tag 40962 (0xA002) and specifies valid image width, in pixels.

Syntax

public void setPixelXDimension(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setPixelYDimension Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setPixelYDimension Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets PixelYDimension value of the EXIF XMP schema.

This XMP method represents EXIF tag 40963 (0xA003) and specifies valid image height, in pixels.

Syntax

public void setPixelYDimension(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setRelatedSoundFile Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setRelatedSoundFile Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets RelatedSoundFile value of the EXIF XMP schema.

This XMP method represents EXIF tag 40964 (0xA004) and specifies an '8.3' file name for the related sound file.

Syntax

public void setRelatedSoundFile(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSaturation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSaturation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSaturationMode type parameter.

Glossary Item Box

Sets Saturation value of the EXIF XMP schema.

This XMP method represents EXIF tag 41993 (0xA409) and indicates the direction of saturation processing applied by the camera.

Syntax

public void setSaturation(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSaturationMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSaturationMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSceneCaptureType Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSceneCaptureType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneCaptureType type parameter.

Glossary Item Box

Sets SceneCaptureType value of the EXIF XMP schema.

This XMP method represents EXIF tag 41990 (0xA406) and indicates the type of scene that was shot.

Syntax

public void setSceneCaptureType(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSceneCaptureType> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneCaptureType type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSceneType Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSceneType Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneType type parameter.

Glossary Item Box

Sets SceneType value of the EXIF XMP schema.

This XMP method represents EXIF tag 41729 (0xA301) and indicates the type of scene.

Syntax

public void setSceneType(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSceneType> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSceneType type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSensingMethod Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSensingMethod Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSensingMethod type parameter.

Glossary Item Box

Sets SensingMethod value of the EXIF XMP schema.

This XMP value represents EXIF tag 41495 (0xA217) and specifies image sensor type on input device.

Syntax

public void setSensingMethod(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSensingMethod> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSensingMethod type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSharpness Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSharpness Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSharpnessMode type parameter.

Glossary Item Box

Sets Sharpness value of the EXIF XMP schema.

This XMP method represents EXIF tag 41994 (0xA40A) and indicates the direction of sharpness processing applied by the camera.

Syntax

public void setSharpness(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSharpnessMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSharpnessMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setShutterSpeedValue Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setShutterSpeedValue Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets ShutterSpeedValue value of the EXIF XMP schema.

This XMP value represents EXIF tag 37377 (0x9201) and specifies Shutter speed, unit is APEX. See Annex C of the EXIF specification.

Syntax

public void setShutterSpeedValue(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSpatialFrequencyResponse Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSpatialFrequencyResponse Method
value
ImGearXMPOECFSFR class value.

Glossary Item Box

Sets SpatialFrequencyResponse value of the EXIF XMP schema.

This XMP method represents EXIF tag 41484 (0xA20C) and specifies input device spatial frequency table and SFR values as specified in ISO 12233.

Syntax

public void setSpatialFrequencyResponse(
   ImGearXMPOECFSFR value
)

Parameters

value
ImGearXMPOECFSFR class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSpectralSensitivity Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSpectralSensitivity Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets SpectralSensitivity value of the EXIF XMP schema.

This XMP value represents EXIF tag 34852 (0x8824) and specifies spectral sensitivity of each channel.

Syntax

public void setSpectralSensitivity(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSubjectArea Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSubjectArea Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets SubjectArea value of the EXIF XMP schema.

This XMP method represents EXIF tag 37396 (0x9214) and specifies the location and area of the main subject in the overall scene.

Syntax

public void setSubjectArea(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSubjectDistance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSubjectDistance Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets SubjectDistance value of the EXIF XMP schema.

This XMP method represents EXIF tag 37382 (0x9206) and specifies distance to subject, in meters.

Syntax

public void setSubjectDistance(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSubjectDistanceRange Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSubjectDistanceRange Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSubjectDistanceRange type parameter.

Glossary Item Box

Sets SubjectDistanceRange value of the EXIF XMP schema.

This XMP method represents EXIF tag 41996 (0xA40C) and indicates the distance range to the subject.

Syntax

public void setSubjectDistanceRange(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFSubjectDistanceRange> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFSubjectDistanceRange type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setSubjectLocation Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setSubjectLocation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets SubjectLocation value of the EXIF XMP schema.

This XMP value represents EXIF tag 41492 (0xA214) and specifies location of the main subject of the scene. The first value is the horizontal pixel and the second value is the vertical pixel at which the main subject appears.

Syntax

public void setSubjectLocation(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setUserComment Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setUserComment Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets UserComment value of the EXIF XMP schema.

This XMP method represents EXIF tag 37510 (0x9286) and specifies comments from user.

Syntax

public void setUserComment(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

setWhiteBalance Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearEXIFXMPMetadata Class : setWhiteBalance Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFWhiteBalanceMode type parameter.

Glossary Item Box

Sets WhiteBalance value of the EXIF XMP schema.

This XMP value represents EXIF tag 41987 (0xA403) and indicates the white balance mode set when the image was shot.

Syntax

public void setWhiteBalance(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFWhiteBalanceMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFWhiteBalanceMode type parameter.

See Also

Reference

ImGearEXIFXMPMetadata Class
ImGearEXIFXMPMetadata Members


%%PageItemTitle%%

ImGearXMPCFAPattern Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPCFAPattern Class

Glossary Item Box

Represents an XMP CFAPattern structure.

Object Model

ImGearXMPCFAPattern ClassImGearXMPInteger ClassImGearXMPInteger Class

Syntax

public class ImGearXMPCFAPattern
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPCFAPattern

See Also

Reference

ImGearXMPCFAPattern Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPCFAPattern Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPCFAPattern Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPCFAPattern.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPCFAPattern Constructor | Initializes a new instance of the ImGearXMPCFAPattern class.
Top

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of columns, in the CFA pattern.
public Method | getRows | Returns the number of rows in the CFA pattern.
public Method | getValues | Returns CFA values. CFA values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
public Method | setColumns | Sets the number of columns, in the CFA pattern.
public Method | setRows | Sets the number of rows in the CFA pattern.
public Method | setValues | Sets CFA values. CFA values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
Top

See Also

Reference

ImGearXMPCFAPattern Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearXMPCFAPattern Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : ImGearXMPCFAPattern Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPCFAPattern class.

Syntax

public ImGearXMPCFAPattern()

Return Value

New instance of ImGearXMPCFAPattern class object.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPCFAPattern Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPCFAPattern Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPCFAPattern members.

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of columns, in the CFA pattern.
public Method | getRows | Returns the number of rows in the CFA pattern.
public Method | getValues | Returns CFA values. CFA values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
public Method | setColumns | Sets the number of columns, in the CFA pattern.
public Method | setRows | Sets the number of rows in the CFA pattern.
public Method | setValues | Sets CFA values. CFA values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
Top

See Also

Reference

ImGearXMPCFAPattern Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : getColumns Method

Glossary Item Box

Returns the number of columns, in the CFA pattern.

Syntax

public ImGearXMPInteger getColumns()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

getRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : getRows Method

Glossary Item Box

Returns the number of rows in the CFA pattern.

Syntax

public ImGearXMPInteger getRows()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

getValues Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : getValues Method

Glossary Item Box

Returns CFA values.

CFA values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getValues()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

setColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : setColumns Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of columns, in the CFA pattern.

Syntax

public void setColumns(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

setRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : setRows Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of rows in the CFA pattern.

Syntax

public void setRows(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

setValues Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPCFAPattern Class : setValues Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets CFA values.

CFA values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Syntax

public void setValues(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearXMPCFAPattern Class
ImGearXMPCFAPattern Members


%%PageItemTitle%%

ImGearXMPDeviceSettings Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPDeviceSettings Class

Glossary Item Box

Represents an XMP DeviceSettings structure.

Object Model

ImGearXMPDeviceSettings ClassImGearXMPInteger ClassImGearXMPInteger Class

Syntax

public class ImGearXMPDeviceSettings
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPDeviceSettings

See Also

Reference

ImGearXMPDeviceSettings Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPDeviceSettings Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPDeviceSettings Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPDeviceSettings.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPDeviceSettings Constructor | Initializes a new instance of the ImGearXMPDeviceSettings class.
Top

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of display columns.
public Method | getRows | Returns the number of display rows.
public Method | getSettings | Returns camera settings, in order.
public Method | setColumns | Sets the number of display columns.
public Method | setRows | Sets the number of display rows.
public Method | setSettings | Sets camera settings, in order.
Top

See Also

Reference

ImGearXMPDeviceSettings Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearXMPDeviceSettings Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : ImGearXMPDeviceSettings Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPDeviceSettings class.

Syntax

public ImGearXMPDeviceSettings()

Return Value

New instance of ImGearXMPDeviceSettings class object.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPDeviceSettings Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPDeviceSettings Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPDeviceSettings members.

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of display columns.
public Method | getRows | Returns the number of display rows.
public Method | getSettings | Returns camera settings, in order.
public Method | setColumns | Sets the number of display columns.
public Method | setRows | Sets the number of display rows.
public Method | setSettings | Sets camera settings, in order.
Top

See Also

Reference

ImGearXMPDeviceSettings Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : getColumns Method

Glossary Item Box

Returns the number of display columns.

Syntax

public ImGearXMPInteger getColumns()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

getRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : getRows Method

Glossary Item Box

Returns the number of display rows.

Syntax

public ImGearXMPInteger getRows()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

getSettings Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : getSettings Method

Glossary Item Box

Returns camera settings, in order.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getSettings()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

setColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : setColumns Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of display columns.

Syntax

public void setColumns(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

setRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : setRows Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of display rows.

Syntax

public void setRows(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

setSettings Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPDeviceSettings Class : setSettings Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets camera settings, in order.

Syntax

public void setSettings(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearXMPDeviceSettings Class
ImGearXMPDeviceSettings Members


%%PageItemTitle%%

ImGearXMPFlash Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPFlash Class

Glossary Item Box

Represents an XMP Flash structure.

Object Model

ImGearXMPFlash ClassImGearXMPBoolean ClassImGearXMPBoolean ClassImGearXMPBoolean Class

Syntax

public class ImGearXMPFlash
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPFlash

See Also

Reference

ImGearXMPFlash Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPFlash Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPFlash Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPFlash.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPFlash Constructor | Initializes a new instance of the ImGearXMPFlash class.
Top

Public Methods

 | Name | Description
public Method | getFields |
public Method | getFired | Returns flag if flash has fired.
public Method | getFunction | Returns if flash function is present. True means that flash function is NOT present.
public Method | getMode | Returns the flash mode.
public Method | getRedEyeMode | Returns if red-eye reduction is supported.
public Method | getReturn | Returns whether strobe return is supported and if supported, detected.
public Method | setFired | Sets flag if flash has fired.
public Method | setFunction | Sets if flash function is present. True means that flash function is NOT present.
public Method | setMode | Sets the flash mode.
public Method | setRedEyeMode | Sets if red-eye reduction is supported.
public Method | setReturn | Sets whether strobe return is supported and if supported, detected.
Top

See Also

Reference

ImGearXMPFlash Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearXMPFlash Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : ImGearXMPFlash Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPFlash class.

Syntax

public ImGearXMPFlash()

Return Value

New instance of ImGearXMPFlash class object.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPFlash Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPFlash Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPFlash members.

Public Methods

 | Name | Description
public Method | getFields |
public Method | getFired | Returns flag if flash has fired.
public Method | getFunction | Returns if flash function is present. True means that flash function is NOT present.
public Method | getMode | Returns the flash mode.
public Method | getRedEyeMode | Returns if red-eye reduction is supported.
public Method | getReturn | Returns whether strobe return is supported and if supported, detected.
public Method | setFired | Sets flag if flash has fired.
public Method | setFunction | Sets if flash function is present. True means that flash function is NOT present.
public Method | setMode | Sets the flash mode.
public Method | setRedEyeMode | Sets if red-eye reduction is supported.
public Method | setReturn | Sets whether strobe return is supported and if supported, detected.
Top

See Also

Reference

ImGearXMPFlash Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getFields Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getFields Method

Glossary Item Box

Syntax

public NameAndValue[] getFields()

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

getFired Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getFired Method

Glossary Item Box

Returns flag if flash has fired.

Syntax

public ImGearXMPBoolean getFired()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

getFunction Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getFunction Method

Glossary Item Box

Returns if flash function is present. True means that flash function is NOT present.

Syntax

public ImGearXMPBoolean getFunction()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

getMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getMode Method

Glossary Item Box

Returns the flash mode.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFlashMode> getMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashMode type parameter.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

getRedEyeMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getRedEyeMode Method

Glossary Item Box

Returns if red-eye reduction is supported.

Syntax

public ImGearXMPBoolean getRedEyeMode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

getReturn Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : getReturn Method

Glossary Item Box

Returns whether strobe return is supported and if supported, detected.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFlashReturn> getReturn()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashReturn type parameter.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

setFired Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : setFired Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets flag if flash has fired.

Syntax

public void setFired(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

setFunction Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : setFunction Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets if flash function is present. True means that flash function is NOT present.

Syntax

public void setFunction(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

setMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : setMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashMode type parameter.

Glossary Item Box

Sets the flash mode.

Syntax

public void setMode(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFlashMode> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashMode type parameter.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

setRedEyeMode Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : setRedEyeMode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets if red-eye reduction is supported.

Syntax

public void setRedEyeMode(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

setReturn Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPFlash Class : setReturn Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashReturn type parameter.

Glossary Item Box

Sets whether strobe return is supported and if supported, detected.

Syntax

public void setReturn(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearEXIFFlashReturn> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.exif.ImGearEXIFFlashReturn type parameter.

See Also

Reference

ImGearXMPFlash Class
ImGearXMPFlash Members


%%PageItemTitle%%

ImGearXMPGPSCoordinate Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPGPSCoordinate Class

Glossary Item Box

Represents an XMP GPSCoordinate structure.

A GPS coordinate in XMP may use either Second or MinuteFraction field, but not both.

Object Model

ImGearXMPGPSCoordinate ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPInteger Class

Syntax

public class ImGearXMPGPSCoordinate
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPValue

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPGPSCoordinate

See Also

Reference

ImGearXMPGPSCoordinate Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPGPSCoordinate Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPGPSCoordinate Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPGPSCoordinate.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPGPSCoordinate Constructor | Initializes a new instance of the ImGearXMPGPSCoordinate class.
Top

Public Methods

 | Name | Description
public Method | getDegree | Returns the Degree of GPS Coordinate.
public Method | getDirection | Returns the Direction of GPS Coordinate.
public Method | getMinute | Returns the Minute of GPS Coordinate.
public Method | getMinuteFraction | Returns the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.
public Method | getSecond | Returns the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.
public Method | setDegree | Sets the Degree of GPS Coordinate.
public Method | setDirection | Sets the Direction of GPS Coordinate.
public Method | setMinute | Sets the Minute of GPS Coordinate.
public Method | setMinuteFraction | Sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.
public Method | setSecond | Sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.
Top

See Also

Reference

ImGearXMPGPSCoordinate Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearXMPGPSCoordinate Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : ImGearXMPGPSCoordinate Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPGPSCoordinate class.

Syntax

public ImGearXMPGPSCoordinate()

Return Value

New instance of ImGearXMPGPSCoordinate class object.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPGPSCoordinate Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPGPSCoordinate Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPGPSCoordinate members.

Public Methods

 | Name | Description
public Method | getDegree | Returns the Degree of GPS Coordinate.
public Method | getDirection | Returns the Direction of GPS Coordinate.
public Method | getMinute | Returns the Minute of GPS Coordinate.
public Method | getMinuteFraction | Returns the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.
public Method | getSecond | Returns the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.
public Method | setDegree | Sets the Degree of GPS Coordinate.
public Method | setDirection | Sets the Direction of GPS Coordinate.
public Method | setMinute | Sets the Minute of GPS Coordinate.
public Method | setMinuteFraction | Sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.
public Method | setSecond | Sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.
Top

See Also

Reference

ImGearXMPGPSCoordinate Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getDegree Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : getDegree Method

Glossary Item Box

Returns the Degree of GPS Coordinate.

Syntax

public ImGearXMPInteger getDegree()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

getDirection Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : getDirection Method

Glossary Item Box

Returns the Direction of GPS Coordinate.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearXMPGPSDirection> getDirection()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with ImGearXMPGPSDirection type parameter.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

getMinute Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : getMinute Method

Glossary Item Box

Returns the Minute of GPS Coordinate.

Syntax

public ImGearXMPInteger getMinute()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

getMinuteFraction Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : getMinuteFraction Method

Glossary Item Box

Returns the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.

Syntax

public ImGearXMPInteger getMinuteFraction()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

getSecond Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : getSecond Method

Glossary Item Box

Returns the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.

Syntax

public ImGearXMPInteger getSecond()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

setDegree Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : setDegree Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the Degree of GPS Coordinate.

Syntax

public void setDegree(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

setDirection Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : setDirection Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with ImGearXMPGPSDirection type parameter.

Glossary Item Box

Sets the Direction of GPS Coordinate.

Syntax

public void setDirection(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearXMPGPSDirection> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with ImGearXMPGPSDirection type parameter.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

setMinute Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : setMinute Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the Minute of GPS Coordinate.

Syntax

public void setMinute(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

setMinuteFraction Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : setMinuteFraction Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the Fraction of minute of GPS Coordinate. If the GPS coordinate seconds instead of fraction of minutes, the method returns null.

Syntax

public void setMinuteFraction(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

setSecond Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPGPSCoordinate Class : setSecond Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the Second of GPS Coordinate. If the GPS coordinate uses fraction of minutes instead of seconds, the method returns null.

Syntax

public void setSecond(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPGPSCoordinate Class
ImGearXMPGPSCoordinate Members


%%PageItemTitle%%

ImGearXMPOECFSFR Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPOECFSFR Class

Glossary Item Box

Represents an XMP OECFSFR (Opto-Electronic Conversion Function / Spatial Frequancy Response) structure.

Object Model

ImGearXMPOECFSFR ClassImGearXMPInteger ClassImGearXMPInteger Class

Syntax

public class ImGearXMPOECFSFR
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPOECFSFR

See Also

Reference

ImGearXMPOECFSFR Members
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPOECFSFR Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPOECFSFR Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPOECFSFR.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPOECFSFR Constructor | Initializes a new instance of the ImGearXMPOECFSFR class.
Top

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of columns.
public Method | getNames | Returns column item names.
public Method | getRows | Returns the number of rows.
public Method | getValues | Returns OECF/SFR values. OECF/SFR values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
public Method | setColumns | Sets the number of columns.
public Method | setNames | Sets column item names.
public Method | setRows | Sets the number of rows.
public Method | setValues | Sets OECF/SFR values. OECF/SFR values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
Top

See Also

Reference

ImGearXMPOECFSFR Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

ImGearXMPOECFSFR Constructor
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : ImGearXMPOECFSFR Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPOECFSFR class.

Syntax

public ImGearXMPOECFSFR()

Return Value

New instance of ImGearXMPOECFSFR class object.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPOECFSFR Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPOECFSFR Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPOECFSFR members.

Public Methods

 | Name | Description
public Method | getColumns | Returns the number of columns.
public Method | getNames | Returns column item names.
public Method | getRows | Returns the number of rows.
public Method | getValues | Returns OECF/SFR values. OECF/SFR values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
public Method | setColumns | Sets the number of columns.
public Method | setNames | Sets column item names.
public Method | setRows | Sets the number of rows.
public Method | setValues | Sets OECF/SFR values. OECF/SFR values are ordered as follows: value [0,0] ... value [n - 1, 0] value [0, m - 1] ... value [n - 1, m - 1] where n is number of columns, and m is number of rows.
Top

See Also

Reference

ImGearXMPOECFSFR Class
com.accusoft.imagegear.formats.xmp.exif Package


%%PageItemTitle%%

getColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : getColumns Method

Glossary Item Box

Returns the number of columns.

Syntax

public ImGearXMPInteger getColumns()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

getNames Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : getNames Method

Glossary Item Box

Returns column item names.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getNames()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

getRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : getRows Method

Glossary Item Box

Returns the number of rows.

Syntax

public ImGearXMPInteger getRows()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

getValues Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : getValues Method

Glossary Item Box

Returns OECF/SFR values.

OECF/SFR values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> getValues()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

setColumns Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : setColumns Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of columns.

Syntax

public void setColumns(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

setNames Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : setNames Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets column item names.

Syntax

public void setNames(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

setRows Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : setRows Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets the number of rows.

Syntax

public void setRows(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

setValues Method
com.accusoft.imagegear.formats.xmp.exif Package > ImGearXMPOECFSFR Class : setValues Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

Glossary Item Box

Sets OECF/SFR values.

OECF/SFR values are ordered as follows:

value [0,0]

...

value [n - 1, 0]

value [0, m - 1]

...

value [n - 1, m - 1]

where n is number of columns, and m is number of rows.

Syntax

public void setValues(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearXMPOECFSFR Class
ImGearXMPOECFSFR Members


%%PageItemTitle%%

ImGearXMPGPSDirection Enumeration
com.accusoft.imagegear.formats.xmp.exif Package : ImGearXMPGPSDirection Enumeration

Glossary Item Box

Represents GPS directions, used in the EXIF XMP schema.

Members

Member | Description
East | East direction.
North | North direction.
South | South direction.
West | West direction.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.formats.xmp.exif.ImGearXMPGPSDirection

See Also

Reference

com.accusoft.imagegear.formats.xmp.exif Package


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.exifaux Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP EXIFAux format.

Classes

Class | Description
ImGearEXIFAuxXMPMetadata | Provides simplified access to EXIFAux XMP metadata schema. This class includes additional properties that describe the equipment used to produce EXIF data.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.exifaux Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearEXIFAuxXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.exifaux Package : ImGearEXIFAuxXMPMetadata Class

Glossary Item Box

Provides simplified access to EXIFAux XMP metadata schema.

This class includes additional properties that describe the equipment used to produce EXIF data.

Object Model

ImGearEXIFAuxXMPMetadata ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearEXIFAuxXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.exifaux.ImGearEXIFAuxXMPMetadata

See Also

Reference

ImGearEXIFAuxXMPMetadata Members
com.accusoft.imagegear.formats.xmp.exifaux Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEXIFAuxXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.exifaux Package : ImGearEXIFAuxXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearEXIFAuxXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearEXIFAuxXMPMetadata Constructor | Initializes a new instance of the ImGearEXIFAuxXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getLens | Returns Lens value of the EXIF Aux XMP schema. This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.
public Method | getSerialNumber | Returns SerialNumber value of the EXIF Aux XMP schema. This XMP method represents serial number of the camera or camera body used to take the photograph.
public Method | setLens | Sets Lens value of the EXIF Aux XMP schema. This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.
public Method | setSerialNumber | Sets SerialNumber value of the EXIF Aux XMP schema. This XMP method represents serial number of the camera or camera body used to take the photograph.
Top

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
com.accusoft.imagegear.formats.xmp.exifaux Package


%%PageItemTitle%%

ImGearEXIFAuxXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.exifaux Package > ImGearEXIFAuxXMPMetadata Class : ImGearEXIFAuxXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearEXIFAuxXMPMetadata class.

Syntax

public ImGearEXIFAuxXMPMetadata()

Return Value

New instance of ImGearEXIFAuxXMPMetadata class object.

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearEXIFAuxXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.exifaux Package : ImGearEXIFAuxXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearEXIFAuxXMPMetadata members.

Public Methods

 | Name | Description
public Method | getLens | Returns Lens value of the EXIF Aux XMP schema. This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.
public Method | getSerialNumber | Returns SerialNumber value of the EXIF Aux XMP schema. This XMP method represents serial number of the camera or camera body used to take the photograph.
public Method | setLens | Sets Lens value of the EXIF Aux XMP schema. This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.
public Method | setSerialNumber | Sets SerialNumber value of the EXIF Aux XMP schema. This XMP method represents serial number of the camera or camera body used to take the photograph.
Top

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
com.accusoft.imagegear.formats.xmp.exifaux Package


%%PageItemTitle%%

getLens Method
com.accusoft.imagegear.formats.xmp.exifaux Package > ImGearEXIFAuxXMPMetadata Class : getLens Method

Glossary Item Box

Returns Lens value of the EXIF Aux XMP schema.

This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.

Syntax

public ImGearXMPString getLens()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%PageItemTitle%%

getSerialNumber Method
com.accusoft.imagegear.formats.xmp.exifaux Package > ImGearEXIFAuxXMPMetadata Class : getSerialNumber Method

Glossary Item Box

Returns SerialNumber value of the EXIF Aux XMP schema.

This XMP method represents serial number of the camera or camera body used to take the photograph.

Syntax

public ImGearXMPString getSerialNumber()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%PageItemTitle%%

setLens Method
com.accusoft.imagegear.formats.xmp.exifaux Package > ImGearEXIFAuxXMPMetadata Class : setLens Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Lens value of the EXIF Aux XMP schema.

This XMP value represents description of the lens used to take the photograph. For example, '70-200 mm f/2.8-4.0'.

Syntax

public void setLens(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%PageItemTitle%%

setSerialNumber Method
com.accusoft.imagegear.formats.xmp.exifaux Package > ImGearEXIFAuxXMPMetadata Class : setSerialNumber Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets SerialNumber value of the EXIF Aux XMP schema.

This XMP method represents serial number of the camera or camera body used to take the photograph.

Syntax

public void setSerialNumber(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearEXIFAuxXMPMetadata Class
ImGearEXIFAuxXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.iptc Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP IPTC4XMPCore format.

Classes

Class | Description
ImGearIPTC4XMPCoreMetadata | Provides simplified access to IPTC4XMPCore XMP metadata schema. This class includes additional properties that describe the equipment used to produce EXIF data.
ImGearXMPContactInfo | Represents an XMP ContactInfo structure. This structure provides a basic set of information to get in contact with a person.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.iptc Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.iptc.ImGearXMPContactInfo

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearIPTC4XMPCoreMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearIPTC4XMPCoreMetadata Class

Glossary Item Box

Provides simplified access to IPTC4XMPCore XMP metadata schema.

This class includes additional properties that describe the equipment used to produce EXIF data.

Object Model

ImGearIPTC4XMPCoreMetadata ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPContactInfo ClassImGearXMPDate ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString ClassImGearXMPLangAlt Class

Syntax

public class ImGearIPTC4XMPCoreMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.iptc.ImGearIPTC4XMPCoreMetadata

See Also

Reference

ImGearIPTC4XMPCoreMetadata Members
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearIPTC4XMPCoreMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearIPTC4XMPCoreMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearIPTC4XMPCoreMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearIPTC4XMPCoreMetadata Constructor | Initializes a new instance of the ImGearIPTC4XMPCoreMetadata class.
Top

Public Methods

Name Description
public Method getCity Returns City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

public Method getCopyrightNotice Returns CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP property (dc:rights) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method getCountry Returns Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

public Method getCountryCode Returns CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

public Method getCreator Returns Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

public Method getCreatorContactInfo Returns CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-properties for proper addressing.

public Method getDateCreated Returns DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

public Method getDescription Returns Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method getDescriptionWriter Returns DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

public Method getHeadLine Returns HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

public Method getInstructions Returns Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

public Method getIntellectualGenre Returns IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value replaces ImGearIPTC4XMPCoreMetadata.IntellectuakGenre value which has been deprecated due to a misspelled name.

public Method getJobID Returns JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

public Method getJobTitle Returns CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

public Method getKeywords Returns Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

public Method getLocation Returns Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

public Method getProvider Returns Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

public Method getProvinceState Returns Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

public Method getRightsUsageTerms Returns RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

public Method getScene Returns Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

public Method getSource Returns Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

public Method getSubjectCode Returns SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

public Method getTitle Returns Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setCity Sets City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

public Method setCopyrightNotice Sets CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP value (dc:rights) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setCountry Sets Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

public Method setCountryCode Sets CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

public Method setCreator Sets Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

public Method setCreatorContactInfo Sets CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-valueies for proper addressing.

public Method setDateCreated Sets DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

public Method setDescription Sets Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setDescriptionWriter Sets DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

public Method setHeadLine Sets HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

public Method setInstructions Sets Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

public Method setIntellectualGenre Sets IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value method ImGearIPTC4XMPCoreMetadata.getIntellectuakGenre() value which has been deprecated due to a misspelled name.

public Method setJobID Sets JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

public Method setJobTitle Sets CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

public Method setKeywords Sets Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

public Method setLocation Sets Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

public Method setProvider Sets Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

public Method setProvinceState Sets Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

public Method setRightsUsageTerms Sets RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

public Method setScene Sets Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

public Method setSource Sets Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

public Method setSubjectCode Sets SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

public Method setTitle Sets Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Top

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%%

ImGearIPTC4XMPCoreMetadata Constructor
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : ImGearIPTC4XMPCoreMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearIPTC4XMPCoreMetadata class.

Syntax

public ImGearIPTC4XMPCoreMetadata()

Return Value

New instance of ImGearIPTC4XMPCoreMetadata class object.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearIPTC4XMPCoreMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearIPTC4XMPCoreMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearIPTC4XMPCoreMetadata members.

Public Methods

Name Description
public Method getCity Returns City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

public Method getCopyrightNotice Returns CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP property (dc:rights) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method getCountry Returns Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

public Method getCountryCode Returns CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

public Method getCreator Returns Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

public Method getCreatorContactInfo Returns CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-properties for proper addressing.

public Method getDateCreated Returns DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

public Method getDescription Returns Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method getDescriptionWriter Returns DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

public Method getHeadLine Returns HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

public Method getInstructions Returns Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

public Method getIntellectualGenre Returns IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value replaces ImGearIPTC4XMPCoreMetadata.IntellectuakGenre value which has been deprecated due to a misspelled name.

public Method getJobID Returns JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

public Method getJobTitle Returns CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

public Method getKeywords Returns Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

public Method getLocation Returns Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

public Method getProvider Returns Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

public Method getProvinceState Returns Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

public Method getRightsUsageTerms Returns RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

public Method getScene Returns Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

public Method getSource Returns Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

public Method getSubjectCode Returns SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

public Method getTitle Returns Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setCity Sets City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

public Method setCopyrightNotice Sets CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP value (dc:rights) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setCountry Sets Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

public Method setCountryCode Sets CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

public Method setCreator Sets Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

public Method setCreatorContactInfo Sets CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-valueies for proper addressing.

public Method setDateCreated Sets DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

public Method setDescription Sets Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

public Method setDescriptionWriter Sets DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

public Method setHeadLine Sets HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

public Method setInstructions Sets Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

public Method setIntellectualGenre Sets IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value method ImGearIPTC4XMPCoreMetadata.getIntellectuakGenre() value which has been deprecated due to a misspelled name.

public Method setJobID Sets JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

public Method setJobTitle Sets CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

public Method setKeywords Sets Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

public Method setLocation Sets Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

public Method setProvider Sets Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

public Method setProvinceState Sets Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

public Method setRightsUsageTerms Sets RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

public Method setScene Sets Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

public Method setSource Sets Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

public Method setSubjectCode Sets SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

public Method setTitle Sets Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Top

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%%

getCity Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCity Method

Glossary Item Box

Returns City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

Syntax

public ImGearXMPString getCity()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getCopyrightNotice Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCopyrightNotice Method

Glossary Item Box

Returns CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP property (dc:rights) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this property must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public ImGearXMPLangAlt getCopyrightNotice()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getCountry Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCountry Method

Glossary Item Box

Returns Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

Syntax

public ImGearXMPString getCountry()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getCountryCode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCountryCode Method

Glossary Item Box

Returns CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

Syntax

public ImGearXMPString getCountryCode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getCreator Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCreator Method

Glossary Item Box

Returns Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getCreator()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getCreatorContactInfo Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getCreatorContactInfo Method

Glossary Item Box

Returns CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-properties for proper addressing.

Syntax

public ImGearXMPContactInfo getCreatorContactInfo()

Return Value

ImGearXMPContactInfo class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getDateCreated Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getDateCreated Method

Glossary Item Box

Returns DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

Syntax

public ImGearXMPDate getDateCreated()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getDescription Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getDescription Method

Glossary Item Box

Returns Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public ImGearXMPLangAlt getDescription()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getDescriptionWriter Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getDescriptionWriter Method

Glossary Item Box

Returns DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

Syntax

public ImGearXMPString getDescriptionWriter()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getHeadLine Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getHeadLine Method

Glossary Item Box

Returns HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

Syntax

public ImGearXMPString getHeadLine()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getInstructions Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getInstructions Method

Glossary Item Box

Returns Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

Syntax

public ImGearXMPString getInstructions()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getIntellectualGenre Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getIntellectualGenre Method

Glossary Item Box

Returns IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value replaces ImGearIPTC4XMPCoreMetadata.IntellectuakGenre value which has been deprecated due to a misspelled name.

Syntax

public ImGearXMPString getIntellectualGenre()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getJobID Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getJobID Method

Glossary Item Box

Returns JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

Syntax

public ImGearXMPString getJobID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getJobTitle Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getJobTitle Method

Glossary Item Box

Returns CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

Syntax

public ImGearXMPString getJobTitle()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getKeywords Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getKeywords Method

Glossary Item Box

Returns Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getKeywords()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getLocation Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getLocation Method

Glossary Item Box

Returns Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

Syntax

public ImGearXMPString getLocation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getProvider Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getProvider Method

Glossary Item Box

Returns Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

Syntax

public ImGearXMPString getProvider()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getProvinceState Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getProvinceState Method

Glossary Item Box

Returns Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

Syntax

public ImGearXMPString getProvinceState()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getRightsUsageTerms Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getRightsUsageTerms Method

Glossary Item Box

Returns RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

Syntax

public ImGearXMPLangAlt getRightsUsageTerms()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getScene Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getScene Method

Glossary Item Box

Returns Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getScene()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getSource Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getSource Method

Glossary Item Box

Returns Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

Syntax

public ImGearXMPString getSource()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getSubjectCode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getSubjectCode Method

Glossary Item Box

Returns SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getSubjectCode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

getTitle Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : getTitle Method

Glossary Item Box

Returns Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public ImGearXMPLangAlt getTitle()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCity Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCity Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets City value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the place shown in visual media or referenced by text or audio media. This element is at the third level of a top-down geographical hierarchy.

Syntax

public void setCity(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCopyrightNotice Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCopyrightNotice Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets CopyrightNotice value of the IPTC4XMPCORE XMP schema.

This XMP value contains any necessary copyright notice for claiming the intellectual property for this news object and should identify the current owner of the copyright for the news object. Other entities like the creator of the news object may be added. Notes on usage rights should be provided in "Rights usage terms".

Note: the XMP value (dc:rights) which stores the value of this IPTC Core property is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public void setCopyrightNotice(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCountry Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCountry Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Country value of the IPTC4XMPCORE XMP schema.

This XMP value is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The full name should be expressed as a verbal name and not as a code, a code should go to the element "CountryCode".

Syntax

public void setCountry(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCountryCode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCountryCode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets CountryCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the code of the country. The content is focusing on - either the country shown in visual media or referenced in text or audio media. This element is at the top/first level of a top-down geographical hierarchy. The code should be taken from ISO 3166 two or three letter code.

Syntax

public void setCountryCode(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCreator Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCreator Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Creator value of the IPTC4XMPCORE XMP schema.

This XMP value contains preferably the name of the person who created the content of this news object, a photographer for photos, a graphic artist for graphics, or a writer for textual news. If it is not appropriate to add the name of a person the name of a company or organisation could be applied as well.

Aligning with IIM notions IPTC Core intents to have only one creator for this news object despite the underlying XMP value dc:creator allows for more than one item to be included. If there are more than one item in this array the first one should be considered as the IPTC Core Creator value.

Syntax

public void setCreator(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setCreatorContactInfo Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setCreatorContactInfo Method
value
ImGearXMPContactInfo class value.

Glossary Item Box

Sets CreatorContactInfo value of the IPTC4XMPCORE XMP schema.

This XMP value provides all necessary information to get in contact with the creator of this news object and comprises a set of sub-valueies for proper addressing.

Syntax

public void setCreatorContactInfo(
   ImGearXMPContactInfo value
)

Parameters

value
ImGearXMPContactInfo class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setDateCreated Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setDateCreated Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateCreated value of the IPTC4XMPCORE XMP schema.

This XMP value designates the date and optionally the time the intellectual content of the news object was created rather than the date of the creation of the physical representation. If no time is given the value should default to 00:00:00.

Note: Any content of the IIM dataset 2:60, Time Created, should be merged to this element.

Note: Implementers are encouraged to provide the creation date and time from the EXIF data of a digital camera to the user for entering this date for the first time.

Syntax

public void setDateCreated(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setDescription Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setDescription Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Description value of the IPTC4XMPCORE XMP schema.

This XMP value is a textual description, including captions, of the news object's content, particularly used where the object is not text.

Note: The XMP value (dc:description) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public void setDescription(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setDescriptionWriter Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setDescriptionWriter Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets DescriptionWriter value of the IPTC4XMPCORE XMP schema.

This XMP value is an identifier or the name of the person involved in writing, editing or correcting the description of the news object.

Syntax

public void setDescriptionWriter(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setHeadLine Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setHeadLine Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets HeadLine value of the IPTC4XMPCORE XMP schema.

This XMP value is a publishable entry providing a synopsis of the contents of the news object. Headline is not the same as Title.

Syntax

public void setHeadLine(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setInstructions Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setInstructions Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Instructions value of the IPTC4XMPCORE XMP schema.

This XMP value is any of a number of instructions from the provider or creator to the receiver of the news object which might include any of the following: embargoes (NewsMagazines OUT) and other restrictions not covered by the "Rights Usage Terms" field; information regarding the original means of capture (scanning notes, colourspace info) or other specific text information that the user may need for accurate reproduction; additional permissions or credits required when publishing.

Syntax

public void setInstructions(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setIntellectualGenre Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setIntellectualGenre Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets IntellectualGenre value of the IPTC4XMPCORE XMP schema.

This XMP value describes the nature, intellectual or journalistic characteristic of a news object, not specifically its content.

This value method ImGearIPTC4XMPCoreMetadata.getIntellectuakGenre() value which has been deprecated due to a misspelled name.

Syntax

public void setIntellectualGenre(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setJobID Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setJobID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets JobID value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the number or identifier for the purpose of improved workflow handling. This ID should be added by the creator or provider for transmission and routing purposes only and should have no significance for archiving.

Note: As this identifier references a job of the receiver's workflow it has first to be issued by the receiver, then be transmitted to the creator or provider of the news object and finally added by him to this field.

Syntax

public void setJobID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setJobTitle Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setJobTitle Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets CreatorJobtitle value of the IPTC4XMPCORE XMP schema.

This XMP value contains the job title of the person who created the content of this news object. As this is sort of a qualifier the Creator element has to be filled in as mandatory prerequisite for using Creator's Jobtitle.

Syntax

public void setJobTitle(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setKeywords Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setKeywords Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Keywords value of the IPTC4XMPCORE XMP schema.

This XMP value specifies keywords to express the subject of the content. Keywords may be free text and don't have to be taken from a controlled vocabulary. Values from the controlled vocabulary IPTC Subject Codes must go to the "Subject Code" element.

Syntax

public void setKeywords(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setLocation Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setLocation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Location value of the IPTC4XMPCORE XMP schema.

This XMP value specifies the name of a location the content is focusing on - either the location shown in visual media or referenced by text or audio media. This location name could either be the name of a sublocation to a city or the name of a well known location or (natural) monument outside a city. In the sense of a sub-location to a city this element is at the fourth level of a top-down geographical hierarchy.

Syntax

public void setLocation(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setProvider Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setProvider Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Provider value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the provider of the news object, who is not necessarily the owner/creator.

Syntax

public void setProvider(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setProvinceState Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setProvinceState Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Province-State value of the IPTC4XMPCORE XMP schema.

This XMP value is a name of the subregion of a country - either called province or state or anything else - the content is focussing on - either the subregion shown in visual media or referenced by text or audio media. This element is at the second level of a top-down geographical hierarchy.

Syntax

public void setProvinceState(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setRightsUsageTerms Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setRightsUsageTerms Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets RightsUsageTerms value of the IPTC4XMPCORE XMP schema.

This XMP value is a free text instructions on how this news object can be legally used.

Syntax

public void setRightsUsageTerms(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setScene Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setScene Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets Scene value of the IPTC4XMPCORE XMP schema.

This XMP value describes the scene of a photo content. It specifies one or more terms from the IPTC "Scene-NewsCodes". Each Scene is represented as a string of 6 digits in an unordered list.

This value replaces ImGearIPTC4XMPCoreMetadata. getScene property, which has been deprecated due to incorrect return type.

Syntax

public void setScene(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setSource Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setSource Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Source value of the IPTC4XMPCORE XMP schema.

This XMP value identifies the original owner of the copyright for the intellectual content of the news object. This could be an agency, a member of an agency or an individual. Source could be different from Creator and from the entities in the CopyrightNotice.

As the orginal owner cannot change the content of this value should never be changed or deleted after the information is entered following the news object's inital creation.

Syntax

public void setSource(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setSubjectCode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setSubjectCode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets SubjectCode value of the IPTC4XMPCORE XMP schema.

This XMP value specifies one or more Subjects from the IPTC "Subject-NewsCodes" taxonomy to categorize the content. Each Subject is represented as a string of 8 digits in an unordered list.

Syntax

public void setSubjectCode(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

setTitle Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearIPTC4XMPCoreMetadata Class : setTitle Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Title value of the IPTC4XMPCORE XMP schema.

This XMP value is a shorthand reference for the news object. While a technical identifer goes to an identifier element, Title holds a short verbal and human readable name. Title is not the same as Headline.

Note: This element aligns with the use of Dublin Core's "Title" element.

Note: The XMP value (dc:title) which stores the value of this IPTC Core value is of type Lang Alt. Hence any software agent dealing with this value must abide to the processing rules for Lang Alt value type as specified by the XMP specifications.

Syntax

public void setTitle(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearIPTC4XMPCoreMetadata Class
ImGearIPTC4XMPCoreMetadata Members


%%PageItemTitle%%

ImGearXMPContactInfo Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearXMPContactInfo Class

Glossary Item Box

Represents an XMP ContactInfo structure.

This structure provides a basic set of information to get in contact with a person.

Object Model

ImGearXMPContactInfo ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPContactInfo
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.iptc.ImGearXMPContactInfo

See Also

Reference

ImGearXMPContactInfo Members
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPContactInfo Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearXMPContactInfo Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPContactInfo.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPContactInfo Constructor | Initializes a new instance of the ImGearXMPContactInfo class.
Top

Public Methods

 | Name | Description
public Method | getCiAdrCity | Returns the contact information city part.
public Method | getCiAdrCtry | Returns the the contact information county part.
public Method | getCiAdrExtadr | Returns the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
public Method | getCiAdrPcode | Returns the contact information part denoting the local postal code.
public Method | getCiAdrRegion | Returns the contact information part denoting regional information like state or province.
public Method | getCiEmailWork | Returns the contact information email address part. Multiple email addresses can be given, separated by a comma.
public Method | getCiTelWork | Returns the contact information phone number part. Multiple numbers can be given, separated by a comma.
public Method | getCiURLWork | Returns the contact information web address part. Multiple addresses can be given, separated by a comma.
public Method | setCiAdrCity | Sets the contact information city part.
public Method | setCiAdrCtry | Sets the the contact information county part.
public Method | setCiAdrExtadr | Sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
public Method | setCiAdrPcode | Sets the contact information part denoting the local postal code.
public Method | setCiAdrRegion | Sets the contact information part denoting regional information like state or province.
public Method | setCiEmailWork | Sets the contact information email address part. Multiple email addresses can be given, separated by a comma.
public Method | setCiTelWork | Sets the contact information phone number part. Multiple numbers can be given, separated by a comma.
public Method | setCiURLWork | Sets the contact information web address part. Multiple addresses can be given, separated by a comma.
Top

See Also

Reference

ImGearXMPContactInfo Class
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%%

ImGearXMPContactInfo Constructor
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : ImGearXMPContactInfo Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPContactInfo class.

Syntax

public ImGearXMPContactInfo()

Return Value

New instance of ImGearXMPContactInfo class object.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPContactInfo Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.iptc Package : ImGearXMPContactInfo Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPContactInfo members.

Public Methods

 | Name | Description
public Method | getCiAdrCity | Returns the contact information city part.
public Method | getCiAdrCtry | Returns the the contact information county part.
public Method | getCiAdrExtadr | Returns the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
public Method | getCiAdrPcode | Returns the contact information part denoting the local postal code.
public Method | getCiAdrRegion | Returns the contact information part denoting regional information like state or province.
public Method | getCiEmailWork | Returns the contact information email address part. Multiple email addresses can be given, separated by a comma.
public Method | getCiTelWork | Returns the contact information phone number part. Multiple numbers can be given, separated by a comma.
public Method | getCiURLWork | Returns the contact information web address part. Multiple addresses can be given, separated by a comma.
public Method | setCiAdrCity | Sets the contact information city part.
public Method | setCiAdrCtry | Sets the the contact information county part.
public Method | setCiAdrExtadr | Sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.
public Method | setCiAdrPcode | Sets the contact information part denoting the local postal code.
public Method | setCiAdrRegion | Sets the contact information part denoting regional information like state or province.
public Method | setCiEmailWork | Sets the contact information email address part. Multiple email addresses can be given, separated by a comma.
public Method | setCiTelWork | Sets the contact information phone number part. Multiple numbers can be given, separated by a comma.
public Method | setCiURLWork | Sets the contact information web address part. Multiple addresses can be given, separated by a comma.
Top

See Also

Reference

ImGearXMPContactInfo Class
com.accusoft.imagegear.formats.xmp.iptc Package


%%PageItemTitle%%

getCiAdrCity Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiAdrCity Method

Glossary Item Box

Returns the contact information city part.

Syntax

public ImGearXMPString getCiAdrCity()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiAdrCtry Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiAdrCtry Method

Glossary Item Box

Returns the the contact information county part.

Syntax

public ImGearXMPString getCiAdrCtry()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiAdrExtadr Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiAdrExtadr Method

Glossary Item Box

Returns the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.

Syntax

public ImGearXMPString getCiAdrExtadr()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiAdrPcode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiAdrPcode Method

Glossary Item Box

Returns the contact information part denoting the local postal code.

Syntax

public ImGearXMPString getCiAdrPcode()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiAdrRegion Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiAdrRegion Method

Glossary Item Box

Returns the contact information part denoting regional information like state or province.

Syntax

public ImGearXMPString getCiAdrRegion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiEmailWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiEmailWork Method

Glossary Item Box

Returns the contact information email address part. Multiple email addresses can be given, separated by a comma.

Syntax

public ImGearXMPString getCiEmailWork()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiTelWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiTelWork Method

Glossary Item Box

Returns the contact information phone number part. Multiple numbers can be given, separated by a comma.

Syntax

public ImGearXMPString getCiTelWork()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

getCiURLWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : getCiURLWork Method

Glossary Item Box

Returns the contact information web address part. Multiple addresses can be given, separated by a comma.

Syntax

public ImGearXMPString getCiURLWork()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiAdrCity Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiAdrCity Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information city part.

Syntax

public void setCiAdrCity(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiAdrCtry Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiAdrCtry Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the the contact information county part.

Syntax

public void setCiAdrCtry(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiAdrExtadr Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiAdrExtadr Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information address part. It comprises an optional company name and all required information to locate the building or postbox to which mail should be sent. To that end, the address is a multiline field.

Syntax

public void setCiAdrExtadr(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiAdrPcode Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiAdrPcode Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information part denoting the local postal code.

Syntax

public void setCiAdrPcode(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiAdrRegion Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiAdrRegion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information part denoting regional information like state or province.

Syntax

public void setCiAdrRegion(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiEmailWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiEmailWork Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information email address part. Multiple email addresses can be given, separated by a comma.

Syntax

public void setCiEmailWork(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiTelWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiTelWork Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information phone number part. Multiple numbers can be given, separated by a comma.

Syntax

public void setCiTelWork(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%PageItemTitle%%

setCiURLWork Method
com.accusoft.imagegear.formats.xmp.iptc Package > ImGearXMPContactInfo Class : setCiURLWork Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the contact information web address part. Multiple addresses can be given, separated by a comma.

Syntax

public void setCiURLWork(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPContactInfo Class
ImGearXMPContactInfo Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.mediamanagement Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP MediaManagement format.

Classes

Class Description
ImGearMediaManagementXMPMetadata Provides simplified access to XMP Media Management metadata schema.

This schema is primarily used by digital asset management (DAM) systems.

The following properties are 'owned' by the DAM system and should be set by applications under their direction; they should not be used by unmanaged files: ManagedFrom, Manager, ManageTo, ManageUI, ManagerVariant.

The following properties are owned by the DAM system for managed files, but can also be used by applications for unmanaged files: DerivedFrom, DocumentID, RenditionClass, RenditionParams, VersionID, Versions.

The History value is always owned by the application.

ImGearXMPResourceEvent Represents an XMP ResourceEvent structure.

The structure specifies a high level event that occurred in the processing of this document.

ImGearXMPResourceReference Represents an XMP ResourceRef structure.

The fields present in any specific reference depend on usage and on whether the referenced resource is managed. Except for instanceID, the fields are all properties from the referenced resource's Media Management schema.

ImGearXMPVersion Represents an XMP Version structure.

The structure describes one version of a document.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.mediamanagement Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceEvent
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceReference
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPVersion

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearMediaManagementXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearMediaManagementXMPMetadata Class

Glossary Item Box

Provides simplified access to XMP Media Management metadata schema.

This schema is primarily used by digital asset management (DAM) systems.

The following properties are 'owned' by the DAM system and should be set by applications under their direction; they should not be used by unmanaged files: ManagedFrom, Manager, ManageTo, ManageUI, ManagerVariant.

The following properties are owned by the DAM system for managed files, but can also be used by applications for unmanaged files: DerivedFrom, DocumentID, RenditionClass, RenditionParams, VersionID, Versions.

The History value is always owned by the application.

Object Model

ImGearMediaManagementXMPMetadata ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString Class

Syntax

public class ImGearMediaManagementXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearMediaManagementXMPMetadata

See Also

Reference

ImGearMediaManagementXMPMetadata Members
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMediaManagementXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearMediaManagementXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearMediaManagementXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearMediaManagementXMPMetadata Constructor | Initializes a new instance of the ImGearMediaManagementXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getDerivedFrom | Returns DerivedFrom value of the Media Management XMP schema. This value specifies reference to the original document from which this one is derived.
public Method | getDocumentID | Returns DocumentID value of the Media Management XMP schema. This value specifies common identifier for all versions and renditions of a document.
public Method | getHistory | Returns History value of the Media Management XMP schema. This value specifies ordered array of high-level user actions that resulted in this resource.
public Method | getInstanceID | Returns InstanceID value of the Media Management XMP schema. This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.
public Method | getLastURL | Returns LastURL value of the Media Management XMP schema. This value is deprecated in XMP specification for privacy protection.
public Method | getManagedFrom | Returns ManagedFrom value of the Media Management XMP schema. This value specifies reference to the document as it was prior to becoming managed.
public Method | getManager | Returns Manager value of the Media Management XMP schema. This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.
public Method | getManagerVariant | Returns ManagerVariant value of the Media Management XMP schema. This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.
public Method | getManageTo | Returns ManageTo value of the Media Management XMP schema. This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.
public Method | getManageUI | Returns ManageUI value of the Media Management XMP schema. This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.
public Method | getRenditionClass | Returns RenditionClass value of the Media Management XMP schema. This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.
public Method | getRenditionOf | Returns RenditionOf value of the Media Management XMP schema. This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.
public Method | getRenditionParams | Returns RenditionParams value of the Media Management XMP schema. This property is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.
public Method | getSaveID | Returns SaveID value of the Media Management XMP schema. This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.
public Method | getVersion | Returns Version value of the Media Management XMP schema. This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.
public Method | getVersionID | Returns VersionID value of the Media Management XMP schema. This value specifies document version identifier for this resource.
public Method | setDerivedFrom | Sets DerivedFrom value of the Media Management XMP schema. This value specifies reference to the original document from which this one is derived.
public Method | setDocumentID | Sets DocumentID value of the Media Management XMP schema. This value specifies common identifier for all versions and renditions of a document.
public Method | setHistory | Sets History value of the Media Management XMP schema. This value specifies ordered array of high-level user actions that resulted in this resource.
public Method | setInstanceID | Sets InstanceID value of the Media Management XMP schema. This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.
public Method | setLastURL | Sets LastURL value of the Media Management XMP schema. This value is deprecated in XMP specification for privacy protection.
public Method | setManagedFrom | Sets ManagedFrom value of the Media Management XMP schema. This value specifies reference to the document as it was prior to becoming managed.
public Method | setManager | Sets Manager value of the Media Management XMP schema. This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.
public Method | setManagerVariant | Sets ManagerVariant value of the Media Management XMP schema. This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.
public Method | setManageTo | Sets ManageTo value of the Media Management XMP schema. This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.
public Method | setManageUI | Sets ManageUI value of the Media Management XMP schema. This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.
public Method | setRenditionClass | Sets RenditionClass value of the Media Management XMP schema. This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.
public Method | setRenditionOf | Sets RenditionOf value of the Media Management XMP schema. This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.
public Method | setRenditionParams | Sets RenditionParams value of the Media Management XMP schema. This value is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.
public Method | setSaveID | Sets SaveID value of the Media Management XMP schema. This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.
public Method | setVersion | Sets Version value of the Media Management XMP schema. This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.
public Method | setVersionID | Sets VersionID value of the Media Management XMP schema. This value specifies document version identifier for this resource.
Top

See Also

Reference

ImGearMediaManagementXMPMetadata Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

ImGearMediaManagementXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : ImGearMediaManagementXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearMediaManagementXMPMetadata class.

Syntax

public ImGearMediaManagementXMPMetadata()

Return Value

New instance of ImGearMediaManagementXMPMetadata class object.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMediaManagementXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearMediaManagementXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearMediaManagementXMPMetadata members.

Public Methods

 | Name | Description
public Method | getDerivedFrom | Returns DerivedFrom value of the Media Management XMP schema. This value specifies reference to the original document from which this one is derived.
public Method | getDocumentID | Returns DocumentID value of the Media Management XMP schema. This value specifies common identifier for all versions and renditions of a document.
public Method | getHistory | Returns History value of the Media Management XMP schema. This value specifies ordered array of high-level user actions that resulted in this resource.
public Method | getInstanceID | Returns InstanceID value of the Media Management XMP schema. This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.
public Method | getLastURL | Returns LastURL value of the Media Management XMP schema. This value is deprecated in XMP specification for privacy protection.
public Method | getManagedFrom | Returns ManagedFrom value of the Media Management XMP schema. This value specifies reference to the document as it was prior to becoming managed.
public Method | getManager | Returns Manager value of the Media Management XMP schema. This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.
public Method | getManagerVariant | Returns ManagerVariant value of the Media Management XMP schema. This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.
public Method | getManageTo | Returns ManageTo value of the Media Management XMP schema. This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.
public Method | getManageUI | Returns ManageUI value of the Media Management XMP schema. This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.
public Method | getRenditionClass | Returns RenditionClass value of the Media Management XMP schema. This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.
public Method | getRenditionOf | Returns RenditionOf value of the Media Management XMP schema. This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.
public Method | getRenditionParams | Returns RenditionParams value of the Media Management XMP schema. This property is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.
public Method | getSaveID | Returns SaveID value of the Media Management XMP schema. This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.
public Method | getVersion | Returns Version value of the Media Management XMP schema. This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.
public Method | getVersionID | Returns VersionID value of the Media Management XMP schema. This value specifies document version identifier for this resource.
public Method | setDerivedFrom | Sets DerivedFrom value of the Media Management XMP schema. This value specifies reference to the original document from which this one is derived.
public Method | setDocumentID | Sets DocumentID value of the Media Management XMP schema. This value specifies common identifier for all versions and renditions of a document.
public Method | setHistory | Sets History value of the Media Management XMP schema. This value specifies ordered array of high-level user actions that resulted in this resource.
public Method | setInstanceID | Sets InstanceID value of the Media Management XMP schema. This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.
public Method | setLastURL | Sets LastURL value of the Media Management XMP schema. This value is deprecated in XMP specification for privacy protection.
public Method | setManagedFrom | Sets ManagedFrom value of the Media Management XMP schema. This value specifies reference to the document as it was prior to becoming managed.
public Method | setManager | Sets Manager value of the Media Management XMP schema. This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.
public Method | setManagerVariant | Sets ManagerVariant value of the Media Management XMP schema. This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.
public Method | setManageTo | Sets ManageTo value of the Media Management XMP schema. This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.
public Method | setManageUI | Sets ManageUI value of the Media Management XMP schema. This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.
public Method | setRenditionClass | Sets RenditionClass value of the Media Management XMP schema. This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.
public Method | setRenditionOf | Sets RenditionOf value of the Media Management XMP schema. This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.
public Method | setRenditionParams | Sets RenditionParams value of the Media Management XMP schema. This value is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.
public Method | setSaveID | Sets SaveID value of the Media Management XMP schema. This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.
public Method | setVersion | Sets Version value of the Media Management XMP schema. This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.
public Method | setVersionID | Sets VersionID value of the Media Management XMP schema. This value specifies document version identifier for this resource.
Top

See Also

Reference

ImGearMediaManagementXMPMetadata Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

getDerivedFrom Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getDerivedFrom Method

Glossary Item Box

Returns DerivedFrom value of the Media Management XMP schema.

This value specifies reference to the original document from which this one is derived.

Syntax

public ImGearXMPResourceReference getDerivedFrom()

Return Value

ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getDocumentID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getDocumentID Method

Glossary Item Box

Returns DocumentID value of the Media Management XMP schema.

This value specifies common identifier for all versions and renditions of a document.

Syntax

public ImGearXMPString getDocumentID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getHistory Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getHistory Method

Glossary Item Box

Returns History value of the Media Management XMP schema.

This value specifies ordered array of high-level user actions that resulted in this resource.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPResourceEvent> getHistory()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPResourceEvent type parameter.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getInstanceID Method

Glossary Item Box

Returns InstanceID value of the Media Management XMP schema.

This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.

Syntax

public ImGearXMPString getInstanceID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getLastURL Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getLastURL Method

Glossary Item Box

Returns LastURL value of the Media Management XMP schema.

This value is deprecated in XMP specification for privacy protection.

Syntax

public ImGearXMPString getLastURL()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getManagedFrom Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getManagedFrom Method

Glossary Item Box

Returns ManagedFrom value of the Media Management XMP schema.

This value specifies reference to the document as it was prior to becoming managed.

Syntax

public ImGearXMPResourceReference getManagedFrom()

Return Value

ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getManager Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getManager Method

Glossary Item Box

Returns Manager value of the Media Management XMP schema.

This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.

Syntax

public ImGearXMPString getManager()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getManagerVariant Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getManagerVariant Method

Glossary Item Box

Returns ManagerVariant value of the Media Management XMP schema.

This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.

Syntax

public ImGearXMPString getManagerVariant()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getManageTo Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getManageTo Method

Glossary Item Box

Returns ManageTo value of the Media Management XMP schema.

This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.

Syntax

public ImGearXMPString getManageTo()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getManageUI Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getManageUI Method

Glossary Item Box

Returns ManageUI value of the Media Management XMP schema.

This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.

Syntax

public ImGearXMPString getManageUI()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getRenditionClass Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getRenditionClass Method

Glossary Item Box

Returns RenditionClass value of the Media Management XMP schema.

This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.

Syntax

public ImGearXMPString getRenditionClass()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getRenditionOf Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getRenditionOf Method

Glossary Item Box

Returns RenditionOf value of the Media Management XMP schema.

This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.

Syntax

public ImGearXMPResourceReference getRenditionOf()

Return Value

ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getRenditionParams Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getRenditionParams Method

Glossary Item Box

Returns RenditionParams value of the Media Management XMP schema.

This property is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.

Syntax

public ImGearXMPString getRenditionParams()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getSaveID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getSaveID Method

Glossary Item Box

Returns SaveID value of the Media Management XMP schema.

This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.

Syntax

public ImGearXMPInteger getSaveID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getVersion Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getVersion Method

Glossary Item Box

Returns Version value of the Media Management XMP schema.

This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPVersion> getVersion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPVersion type parameter.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

getVersionID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : getVersionID Method

Glossary Item Box

Returns VersionID value of the Media Management XMP schema.

This value specifies document version identifier for this resource.

Syntax

public ImGearXMPString getVersionID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setDerivedFrom Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setDerivedFrom Method
value
ImGearXMPResourceReference class value.

Glossary Item Box

Sets DerivedFrom value of the Media Management XMP schema.

This value specifies reference to the original document from which this one is derived.

Syntax

public void setDerivedFrom(
   ImGearXMPResourceReference value
)

Parameters

value
ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setDocumentID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setDocumentID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets DocumentID value of the Media Management XMP schema.

This value specifies common identifier for all versions and renditions of a document.

Syntax

public void setDocumentID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setHistory Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setHistory Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPResourceEvent type parameter.

Glossary Item Box

Sets History value of the Media Management XMP schema.

This value specifies ordered array of high-level user actions that resulted in this resource.

Syntax

public void setHistory(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPResourceEvent> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPResourceEvent type parameter.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setInstanceID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets InstanceID value of the Media Management XMP schema.

This value specifies identifier for a specific incarnation of a document, updated each time a file is saved.

Syntax

public void setInstanceID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setLastURL Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setLastURL Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets LastURL value of the Media Management XMP schema.

This value is deprecated in XMP specification for privacy protection.

Syntax

public void setLastURL(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setManagedFrom Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setManagedFrom Method
value
ImGearXMPResourceReference class value.

Glossary Item Box

Sets ManagedFrom value of the Media Management XMP schema.

This value specifies reference to the document as it was prior to becoming managed.

Syntax

public void setManagedFrom(
   ImGearXMPResourceReference value
)

Parameters

value
ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setManager Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setManager Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Manager value of the Media Management XMP schema.

This value specifies name of the asset management system that manages this resource. The suggested convention is 'vendor app version' - for example 'Adobe Acrobat Distiller 5.0'.

Syntax

public void setManager(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setManagerVariant Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setManagerVariant Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ManagerVariant value of the Media Management XMP schema.

This value specifies a particular variant of the asset management system. The format of this value is private to the specific asset management system.

Syntax

public void setManagerVariant(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setManageTo Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setManageTo Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ManageTo value of the Media Management XMP schema.

This value specifies URI identifying the managed resource to the asset management system; the presence of this property is the formal indication that this resource is managed. The form and content of this URI is private to the asset management system.

Syntax

public void setManageTo(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setManageUI Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setManageUI Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ManageUI value of the Media Management XMP schema.

This value specifies URI that can be used to access information about the managed resource through a web browser. It might require a custom browser plugin.

Syntax

public void setManageUI(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setRenditionClass Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setRenditionClass Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets RenditionClass value of the Media Management XMP schema.

This value specifies rendition class name for this resource. See XMP specification for more details regarding this value.

Syntax

public void setRenditionClass(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setRenditionOf Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setRenditionOf Method
value
ImGearXMPResourceReference class value.

Glossary Item Box

Sets RenditionOf value of the Media Management XMP schema.

This value is deprecated in XMP specification in favor of xmpMM:DerivedFrom.A reference to the document of which this is a rendition.

Syntax

public void setRenditionOf(
   ImGearXMPResourceReference value
)

Parameters

value
ImGearXMPResourceReference class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setRenditionParams Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setRenditionParams Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets RenditionParams value of the Media Management XMP schema.

This value is used to provide additional rendition parameters that are too complex or verbose to encode in RenditionClass.

Syntax

public void setRenditionParams(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setSaveID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setSaveID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets SaveID value of the Media Management XMP schema.

This value is deprecated in XMP specification. Previously used only to support the xmpMM:LastURL property.

Syntax

public void setSaveID(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setVersion Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setVersion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPVersion type parameter.

Glossary Item Box

Sets Version value of the Media Management XMP schema.

This value specifies version history associated with this resource. First entry is the oldest known version for this document, last entry is the most recent version.

Syntax

public void setVersion(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPVersion> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with ImGearXMPVersion type parameter.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

setVersionID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearMediaManagementXMPMetadata Class : setVersionID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets VersionID value of the Media Management XMP schema.

This value specifies document version identifier for this resource.

Syntax

public void setVersionID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMediaManagementXMPMetadata Class
ImGearMediaManagementXMPMetadata Members


%%PageItemTitle%%

ImGearXMPResourceEvent Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceEvent Class

Glossary Item Box

Represents an XMP ResourceEvent structure.

The structure specifies a high level event that occurred in the processing of this document.

Object Model

ImGearXMPResourceEvent ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate Class

Syntax

public class ImGearXMPResourceEvent
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceEvent

See Also

Reference

ImGearXMPResourceEvent Members
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPResourceEvent Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceEvent Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPResourceEvent.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPResourceEvent Constructor | Initializes a new instance of the ImGearXMPResourceEvent class.
Top

Public Methods

 | Name | Description
public Method | getAction | Returns the action that occurred. See XMP specification for defined values and usage details.
public Method | getInstanceID | Returns the instance ID of the modified resource.
public Method | getParameters | Returns additional description of the action.
public Method | getSoftwareAgent | Returns the software agent that performed the action.
public Method | getWhen | Returns optional timestamp of when the action occurred.
public Method | setAction | Sets the action that occurred. See XMP specification for defined values and usage details.
public Method | setInstanceID | Sets the instance ID of the modified resource.
public Method | setParameters | Sets additional description of the action.
public Method | setSoftwareAgent | Sets the software agent that performed the action.
public Method | setWhen | Sets optional timestamp of when the action occurred.
Top

See Also

Reference

ImGearXMPResourceEvent Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

ImGearXMPResourceEvent Constructor
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : ImGearXMPResourceEvent Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPResourceEvent class.

Syntax

public ImGearXMPResourceEvent()

Return Value

New instance of ImGearXMPResourceEvent class object.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPResourceEvent Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceEvent Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPResourceEvent members.

Public Methods

 | Name | Description
public Method | getAction | Returns the action that occurred. See XMP specification for defined values and usage details.
public Method | getInstanceID | Returns the instance ID of the modified resource.
public Method | getParameters | Returns additional description of the action.
public Method | getSoftwareAgent | Returns the software agent that performed the action.
public Method | getWhen | Returns optional timestamp of when the action occurred.
public Method | setAction | Sets the action that occurred. See XMP specification for defined values and usage details.
public Method | setInstanceID | Sets the instance ID of the modified resource.
public Method | setParameters | Sets additional description of the action.
public Method | setSoftwareAgent | Sets the software agent that performed the action.
public Method | setWhen | Sets optional timestamp of when the action occurred.
Top

See Also

Reference

ImGearXMPResourceEvent Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

getAction Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : getAction Method

Glossary Item Box

Returns the action that occurred. See XMP specification for defined values and usage details.

Syntax

public ImGearXMPString getAction()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

getInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : getInstanceID Method

Glossary Item Box

Returns the instance ID of the modified resource.

Syntax

public ImGearXMPString getInstanceID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

getParameters Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : getParameters Method

Glossary Item Box

Returns additional description of the action.

Syntax

public ImGearXMPString getParameters()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

getSoftwareAgent Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : getSoftwareAgent Method

Glossary Item Box

Returns the software agent that performed the action.

Syntax

public ImGearXMPString getSoftwareAgent()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

getWhen Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : getWhen Method

Glossary Item Box

Returns optional timestamp of when the action occurred.

Syntax

public ImGearXMPDate getWhen()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

setAction Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : setAction Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the action that occurred. See XMP specification for defined values and usage details.

Syntax

public void setAction(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

setInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : setInstanceID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the instance ID of the modified resource.

Syntax

public void setInstanceID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

setParameters Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : setParameters Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets additional description of the action.

Syntax

public void setParameters(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

setSoftwareAgent Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : setSoftwareAgent Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the software agent that performed the action.

Syntax

public void setSoftwareAgent(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

setWhen Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceEvent Class : setWhen Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets optional timestamp of when the action occurred.

Syntax

public void setWhen(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearXMPResourceEvent Class
ImGearXMPResourceEvent Members


%%PageItemTitle%%

ImGearXMPResourceReference Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceReference Class

Glossary Item Box

Represents an XMP ResourceRef structure.

The fields present in any specific reference depend on usage and on whether the referenced resource is managed. Except for instanceID, the fields are all properties from the referenced resource's Media Management schema.

Object Model

ImGearXMPResourceReference ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString Class

Syntax

public class ImGearXMPResourceReference
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPResourceReference

See Also

Reference

ImGearXMPResourceReference Members
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPResourceReference Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceReference Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPResourceReference.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPResourceReference Constructor | Initializes a new instance of the ImGearXMPResourceReference class.
Top

Public Methods

 | Name | Description
public Method | getDocumentID | Returns the referenced resource's xmpMM:DocumentID.
public Method | getInstanceID | Returns the referenced resource's instance ID.
public Method | getManager | Returns the referenced resource's xmpMM:Manager.
public Method | getManagerVariant | Returns the referenced resource's xmpMM: ManagerVariant.
public Method | getManageTo | Returns the referenced resource's xmpMM:ManageTo.
public Method | getManageUI | Returns the referenced resource's xmpMM:ManageUI.
public Method | getRenditionClass | Returns the referenced resource's xmpMM: RenditionClass.
public Method | getRenditionParams | Returns the referenced resource's xmpMM: RenditionParams.
public Method | getVersionID | Returns the referenced resource's xmpMM:VersionID.
public Method | setDocumentID | Sets the referenced resource's xmpMM:DocumentID.
public Method | setInstanceID | Sets the referenced resource's instance ID.
public Method | setManager | Sets the referenced resource's xmpMM:Manager.
public Method | setManagerVariant | Sets the referenced resource's xmpMM: ManagerVariant.
public Method | setManageTo | Sets the referenced resource's xmpMM:ManageTo.
public Method | setManageUI | Sets the referenced resource's xmpMM:ManageUI.
public Method | setRenditionClass | Sets the referenced resource's xmpMM: RenditionClass.
public Method | setRenditionParams | Sets the referenced resource's xmpMM: RenditionParams.
public Method | setVersionID | Sets the referenced resource's xmpMM:VersionID.
Top

See Also

Reference

ImGearXMPResourceReference Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

ImGearXMPResourceReference Constructor
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : ImGearXMPResourceReference Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPResourceReference class.

Syntax

public ImGearXMPResourceReference()

Return Value

New instance of ImGearXMPResourceReference class object.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPResourceReference Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPResourceReference Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPResourceReference members.

Public Methods

 | Name | Description
public Method | getDocumentID | Returns the referenced resource's xmpMM:DocumentID.
public Method | getInstanceID | Returns the referenced resource's instance ID.
public Method | getManager | Returns the referenced resource's xmpMM:Manager.
public Method | getManagerVariant | Returns the referenced resource's xmpMM: ManagerVariant.
public Method | getManageTo | Returns the referenced resource's xmpMM:ManageTo.
public Method | getManageUI | Returns the referenced resource's xmpMM:ManageUI.
public Method | getRenditionClass | Returns the referenced resource's xmpMM: RenditionClass.
public Method | getRenditionParams | Returns the referenced resource's xmpMM: RenditionParams.
public Method | getVersionID | Returns the referenced resource's xmpMM:VersionID.
public Method | setDocumentID | Sets the referenced resource's xmpMM:DocumentID.
public Method | setInstanceID | Sets the referenced resource's instance ID.
public Method | setManager | Sets the referenced resource's xmpMM:Manager.
public Method | setManagerVariant | Sets the referenced resource's xmpMM: ManagerVariant.
public Method | setManageTo | Sets the referenced resource's xmpMM:ManageTo.
public Method | setManageUI | Sets the referenced resource's xmpMM:ManageUI.
public Method | setRenditionClass | Sets the referenced resource's xmpMM: RenditionClass.
public Method | setRenditionParams | Sets the referenced resource's xmpMM: RenditionParams.
public Method | setVersionID | Sets the referenced resource's xmpMM:VersionID.
Top

See Also

Reference

ImGearXMPResourceReference Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

getDocumentID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getDocumentID Method

Glossary Item Box

Returns the referenced resource's xmpMM:DocumentID.

Syntax

public ImGearXMPString getDocumentID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getInstanceID Method

Glossary Item Box

Returns the referenced resource's instance ID.

Syntax

public ImGearXMPString getInstanceID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getManager Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getManager Method

Glossary Item Box

Returns the referenced resource's xmpMM:Manager.

Syntax

public ImGearXMPString getManager()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getManagerVariant Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getManagerVariant Method

Glossary Item Box

Returns the referenced resource's xmpMM: ManagerVariant.

Syntax

public ImGearXMPString getManagerVariant()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getManageTo Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getManageTo Method

Glossary Item Box

Returns the referenced resource's xmpMM:ManageTo.

Syntax

public ImGearXMPString getManageTo()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getManageUI Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getManageUI Method

Glossary Item Box

Returns the referenced resource's xmpMM:ManageUI.

Syntax

public ImGearXMPString getManageUI()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getRenditionClass Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getRenditionClass Method

Glossary Item Box

Returns the referenced resource's xmpMM: RenditionClass.

Syntax

public ImGearXMPString getRenditionClass()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getRenditionParams Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getRenditionParams Method

Glossary Item Box

Returns the referenced resource's xmpMM: RenditionParams.

Syntax

public ImGearXMPString getRenditionParams()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

getVersionID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : getVersionID Method

Glossary Item Box

Returns the referenced resource's xmpMM:VersionID.

Syntax

public ImGearXMPString getVersionID()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setDocumentID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setDocumentID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM:DocumentID.

Syntax

public void setDocumentID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setInstanceID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setInstanceID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's instance ID.

Syntax

public void setInstanceID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setManager Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setManager Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM:Manager.

Syntax

public void setManager(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setManagerVariant Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setManagerVariant Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM: ManagerVariant.

Syntax

public void setManagerVariant(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setManageTo Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setManageTo Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM:ManageTo.

Syntax

public void setManageTo(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setManageUI Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setManageUI Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM:ManageUI.

Syntax

public void setManageUI(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setRenditionClass Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setRenditionClass Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM: RenditionClass.

Syntax

public void setRenditionClass(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setRenditionParams Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setRenditionParams Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM: RenditionParams.

Syntax

public void setRenditionParams(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

setVersionID Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPResourceReference Class : setVersionID Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the referenced resource's xmpMM:VersionID.

Syntax

public void setVersionID(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPResourceReference Class
ImGearXMPResourceReference Members


%%PageItemTitle%%

ImGearXMPVersion Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPVersion Class

Glossary Item Box

Represents an XMP Version structure.

The structure describes one version of a document.

Object Model

ImGearXMPVersion ClassImGearXMPString ClassImGearXMPResourceEvent ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString Class

Syntax

public class ImGearXMPVersion
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPStructure

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPValue
com.accusoft.imagegear.formats.xmp.ImGearXMPStructure
com.accusoft.imagegear.formats.xmp.mediamanagement.ImGearXMPVersion

See Also

Reference

ImGearXMPVersion Members
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearXMPVersion Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPVersion Class

Glossary Item Box

The following tables list the members exposed by ImGearXMPVersion.

Public Constructors

 | Name | Description
public Constructor | ImGearXMPVersion Constructor | Initializes a new instance of the ImGearXMPVersion class.
Top

Public Methods

 | Name | Description
public Method | getComments | Returns comments concerning what was changed.
public Method | getEvent | Returns high level, formal description of what operation the user performed.
public Method | getModifier | Returns the person who modified this version.
public Method | getModifyDate | Returns the date on which this version was checked in.
public Method | getVersion | Returns the new version number.
public Method | setComments | Sets comments concerning what was changed.
public Method | setEvent | Sets high level, formal description of what operation the user performed.
public Method | setModifier | Sets the person who modified this version.
public Method | setModifyDate | Sets the date on which this version was checked in.
public Method | setVersion | Sets the new version number.
Top

See Also

Reference

ImGearXMPVersion Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

ImGearXMPVersion Constructor
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : ImGearXMPVersion Constructor

Glossary Item Box

Initializes a new instance of the ImGearXMPVersion class.

Syntax

public ImGearXMPVersion()

Return Value

New instance of ImGearXMPVersion class object.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearXMPVersion Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.mediamanagement Package : ImGearXMPVersion Class

Glossary Item Box

For a list of all members of this type, see ImGearXMPVersion members.

Public Methods

 | Name | Description
public Method | getComments | Returns comments concerning what was changed.
public Method | getEvent | Returns high level, formal description of what operation the user performed.
public Method | getModifier | Returns the person who modified this version.
public Method | getModifyDate | Returns the date on which this version was checked in.
public Method | getVersion | Returns the new version number.
public Method | setComments | Sets comments concerning what was changed.
public Method | setEvent | Sets high level, formal description of what operation the user performed.
public Method | setModifier | Sets the person who modified this version.
public Method | setModifyDate | Sets the date on which this version was checked in.
public Method | setVersion | Sets the new version number.
Top

See Also

Reference

ImGearXMPVersion Class
com.accusoft.imagegear.formats.xmp.mediamanagement Package


%%PageItemTitle%%

getComments Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : getComments Method

Glossary Item Box

Returns comments concerning what was changed.

Syntax

public ImGearXMPString getComments()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

getEvent Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : getEvent Method

Glossary Item Box

Returns high level, formal description of what operation the user performed.

Syntax

public ImGearXMPResourceEvent getEvent()

Return Value

ImGearXMPResourceEvent class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

getModifier Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : getModifier Method

Glossary Item Box

Returns the person who modified this version.

Syntax

public ImGearXMPString getModifier()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

getModifyDate Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : getModifyDate Method

Glossary Item Box

Returns the date on which this version was checked in.

Syntax

public ImGearXMPDate getModifyDate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

getVersion Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : getVersion Method

Glossary Item Box

Returns the new version number.

Syntax

public ImGearXMPString getVersion()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

hiddenConstructorInit Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : hiddenConstructorInit Method
fields

Glossary Item Box

Syntax

protected void hiddenConstructorInit(
   NameAndValue[] fields
)

Parameters

fields

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

setComments Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : setComments Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets comments concerning what was changed.

Syntax

public void setComments(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

setEvent Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : setEvent Method
value
ImGearXMPResourceEvent class value.

Glossary Item Box

Sets high level, formal description of what operation the user performed.

Syntax

public void setEvent(
   ImGearXMPResourceEvent value
)

Parameters

value
ImGearXMPResourceEvent class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

setModifier Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : setModifier Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the person who modified this version.

Syntax

public void setModifier(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

setModifyDate Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : setModifyDate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets the date on which this version was checked in.

Syntax

public void setModifyDate(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%PageItemTitle%%

setVersion Method
com.accusoft.imagegear.formats.xmp.mediamanagement Package > ImGearXMPVersion Class : setVersion Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets the new version number.

Syntax

public void setVersion(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearXMPVersion Class
ImGearXMPVersion Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.microsoftphoto Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP MicrosoftPhoto format.

Classes

Class | Description
ImGearMicrosoftPhotoXMPMetadata | Provides simplified access to MicrosoftPhoto XMP metadata schema.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.microsoftphoto Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.microsoftphoto.ImGearMicrosoftPhotoXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearMicrosoftPhotoXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.microsoftphoto Package : ImGearMicrosoftPhotoXMPMetadata Class

Glossary Item Box

Provides simplified access to MicrosoftPhoto XMP metadata schema.

Object Model

ImGearMicrosoftPhotoXMPMetadata ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger Class

Syntax

public class ImGearMicrosoftPhotoXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.microsoftphoto.ImGearMicrosoftPhotoXMPMetadata

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Members
com.accusoft.imagegear.formats.xmp.microsoftphoto Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMicrosoftPhotoXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.microsoftphoto Package : ImGearMicrosoftPhotoXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearMicrosoftPhotoXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearMicrosoftPhotoXMPMetadata Constructor | Initializes a new instance of the ImGearMicrosoftPhotoXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getCameraSerialNumber | Returns CameraSerialNumber value of theMicrosoftPhoto XMP schema.
public Method | getDateAcquired | Returns DateAcquired value of theMicrosoftPhoto XMP schema.
public Method | getFlashManufacturer | Returns FlashManufacturer value of theMicrosoftPhoto XMP schema.
public Method | getFlashModel | Returns FlashModel value of theMicrosoftPhoto XMP schema.
public Method | getLastKeywordIPTC | Returns LastKeywordIPTC value of theMicrosoftPhoto XMP schema.
public Method | getLastKeywordXMP | Returns LastKeywordXMP value of theMicrosoftPhoto XMP schema.
public Method | getLensManufacturer | Returns LensManufacturer value of theMicrosoftPhoto XMP schema.
public Method | getLensModel | Returns LensModel value of theMicrosoftPhoto XMP schema.
public Method | getRating | Returns Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
public Method | setCameraSerialNumber | Sets CameraSerialNumber value of theMicrosoftPhoto XMP schema.
public Method | setDateAcquired | Sets DateAcquired value of theMicrosoftPhoto XMP schema.
public Method | setFlashManufacturer | Sets FlashManufacturer value of theMicrosoftPhoto XMP schema.
public Method | setFlashModel | Sets FlashModel value of theMicrosoftPhoto XMP schema.
public Method | setLastKeywordIPTC | Sets LastKeywordIPTC value of theMicrosoftPhoto XMP schema.
public Method | setLastKeywordXMP | Sets LastKeywordXMP value of theMicrosoftPhoto XMP schema.
public Method | setLensManufacturer | Sets LensManufacturer value of theMicrosoftPhoto XMP schema.
public Method | setLensModel | Sets LensModel value of theMicrosoftPhoto XMP schema.
public Method | setRating | Sets Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
Top

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
com.accusoft.imagegear.formats.xmp.microsoftphoto Package


%%PageItemTitle%%

ImGearMicrosoftPhotoXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : ImGearMicrosoftPhotoXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearMicrosoftPhotoXMPMetadata class.

Syntax

public ImGearMicrosoftPhotoXMPMetadata()

Return Value

New instance of ImGearMicrosoftPhotoXMPMetadata class object.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearMicrosoftPhotoXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.microsoftphoto Package : ImGearMicrosoftPhotoXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearMicrosoftPhotoXMPMetadata members.

Public Methods

 | Name | Description
public Method | getCameraSerialNumber | Returns CameraSerialNumber value of theMicrosoftPhoto XMP schema.
public Method | getDateAcquired | Returns DateAcquired value of theMicrosoftPhoto XMP schema.
public Method | getFlashManufacturer | Returns FlashManufacturer value of theMicrosoftPhoto XMP schema.
public Method | getFlashModel | Returns FlashModel value of theMicrosoftPhoto XMP schema.
public Method | getLastKeywordIPTC | Returns LastKeywordIPTC value of theMicrosoftPhoto XMP schema.
public Method | getLastKeywordXMP | Returns LastKeywordXMP value of theMicrosoftPhoto XMP schema.
public Method | getLensManufacturer | Returns LensManufacturer value of theMicrosoftPhoto XMP schema.
public Method | getLensModel | Returns LensModel value of theMicrosoftPhoto XMP schema.
public Method | getRating | Returns Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
public Method | setCameraSerialNumber | Sets CameraSerialNumber value of theMicrosoftPhoto XMP schema.
public Method | setDateAcquired | Sets DateAcquired value of theMicrosoftPhoto XMP schema.
public Method | setFlashManufacturer | Sets FlashManufacturer value of theMicrosoftPhoto XMP schema.
public Method | setFlashModel | Sets FlashModel value of theMicrosoftPhoto XMP schema.
public Method | setLastKeywordIPTC | Sets LastKeywordIPTC value of theMicrosoftPhoto XMP schema.
public Method | setLastKeywordXMP | Sets LastKeywordXMP value of theMicrosoftPhoto XMP schema.
public Method | setLensManufacturer | Sets LensManufacturer value of theMicrosoftPhoto XMP schema.
public Method | setLensModel | Sets LensModel value of theMicrosoftPhoto XMP schema.
public Method | setRating | Sets Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.
Top

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
com.accusoft.imagegear.formats.xmp.microsoftphoto Package


%%PageItemTitle%%

getCameraSerialNumber Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getCameraSerialNumber Method

Glossary Item Box

Returns CameraSerialNumber value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPString getCameraSerialNumber()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getDateAcquired Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getDateAcquired Method

Glossary Item Box

Returns DateAcquired value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPDate getDateAcquired()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getFlashManufacturer Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getFlashManufacturer Method

Glossary Item Box

Returns FlashManufacturer value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPString getFlashManufacturer()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getFlashModel Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getFlashModel Method

Glossary Item Box

Returns FlashModel value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPString getFlashModel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getLastKeywordIPTC Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getLastKeywordIPTC Method

Glossary Item Box

Returns LastKeywordIPTC value of theMicrosoftPhoto XMP schema.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getLastKeywordIPTC()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getLastKeywordXMP Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getLastKeywordXMP Method

Glossary Item Box

Returns LastKeywordXMP value of theMicrosoftPhoto XMP schema.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getLastKeywordXMP()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getLensManufacturer Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getLensManufacturer Method

Glossary Item Box

Returns LensManufacturer value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPString getLensManufacturer()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getLensModel Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getLensModel Method

Glossary Item Box

Returns LensModel value of theMicrosoftPhoto XMP schema.

Syntax

public ImGearXMPString getLensModel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

getRating Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : getRating Method

Glossary Item Box

Returns Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.

Syntax

public ImGearXMPInteger getRating()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setCameraSerialNumber Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setCameraSerialNumber Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets CameraSerialNumber value of theMicrosoftPhoto XMP schema.

Syntax

public void setCameraSerialNumber(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setDateAcquired Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setDateAcquired Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateAcquired value of theMicrosoftPhoto XMP schema.

Syntax

public void setDateAcquired(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setFlashManufacturer Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setFlashManufacturer Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets FlashManufacturer value of theMicrosoftPhoto XMP schema.

Syntax

public void setFlashManufacturer(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setFlashModel Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setFlashModel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets FlashModel value of theMicrosoftPhoto XMP schema.

Syntax

public void setFlashModel(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setLastKeywordIPTC Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setLastKeywordIPTC Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets LastKeywordIPTC value of theMicrosoftPhoto XMP schema.

Syntax

public void setLastKeywordIPTC(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setLastKeywordXMP Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setLastKeywordXMP Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets LastKeywordXMP value of theMicrosoftPhoto XMP schema.

Syntax

public void setLastKeywordXMP(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setLensManufacturer Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setLensManufacturer Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets LensManufacturer value of theMicrosoftPhoto XMP schema.

Syntax

public void setLensManufacturer(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setLensModel Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setLensModel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets LensModel value of theMicrosoftPhoto XMP schema.

Syntax

public void setLensModel(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%PageItemTitle%%

setRating Method
com.accusoft.imagegear.formats.xmp.microsoftphoto Package > ImGearMicrosoftPhotoXMPMetadata Class : setRating Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets Rating value of theMicrosoftPhoto XMP schema. XMP Basic Rating values of 1,2,3,4 and 5 stars correspond to MicrosoftPhoto Rating values of 1,25,50,75 and 99 respectively.

Syntax

public void setRating(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearMicrosoftPhotoXMPMetadata Class
ImGearMicrosoftPhotoXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.pagedtext Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP PagedText format.

Classes

Class | Description
ImGearPagedTextXMPMetadata | Provides simplified access to XMP Paged Text metadata schema. This schema is used for text appearing on a page in a document.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.pagedtext Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearPagedTextXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.pagedtext Package : ImGearPagedTextXMPMetadata Class

Glossary Item Box

Provides simplified access to XMP Paged Text metadata schema.

This schema is used for text appearing on a page in a document.

Object Model

ImGearPagedTextXMPMetadata ClassImGearXMPDimensions ClassImGearXMPInteger Class

Syntax

public class ImGearPagedTextXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.pagedtext.ImGearPagedTextXMPMetadata

See Also

Reference

ImGearPagedTextXMPMetadata Members
com.accusoft.imagegear.formats.xmp.pagedtext Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPagedTextXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.pagedtext Package : ImGearPagedTextXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearPagedTextXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearPagedTextXMPMetadata Constructor | Initializes a new instance of the ImGearPagedTextXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getColorants | Returns Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
public Method | getFonts | Returns Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).
public Method | getMaxPageSize | Returns MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).
public Method | getNPages | Returns NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).
public Method | getPlateNames | Returns PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).
public Method | setColorants | Sets Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
public Method | setFonts | Sets Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).
public Method | setMaxPageSize | Sets MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).
public Method | setNPages | Sets NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).
public Method | setPlateNames | Sets PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).
Top

See Also

Reference

ImGearPagedTextXMPMetadata Class
com.accusoft.imagegear.formats.xmp.pagedtext Package


%%PageItemTitle%%

ImGearPagedTextXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : ImGearPagedTextXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearPagedTextXMPMetadata class.

Syntax

public ImGearPagedTextXMPMetadata()

Return Value

New instance of ImGearPagedTextXMPMetadata class object.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPagedTextXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.pagedtext Package : ImGearPagedTextXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearPagedTextXMPMetadata members.

Public Methods

 | Name | Description
public Method | getColorants | Returns Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
public Method | getFonts | Returns Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).
public Method | getMaxPageSize | Returns MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).
public Method | getNPages | Returns NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).
public Method | getPlateNames | Returns PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).
public Method | setColorants | Sets Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).
public Method | setFonts | Sets Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).
public Method | setMaxPageSize | Sets MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).
public Method | setNPages | Sets NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).
public Method | setPlateNames | Sets PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).
Top

See Also

Reference

ImGearPagedTextXMPMetadata Class
com.accusoft.imagegear.formats.xmp.pagedtext Package


%%PageItemTitle%%

getColorants Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : getColorants Method

Glossary Item Box

Returns Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPColorant> getColorants()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPColorant type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

getFonts Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : getFonts Method

Glossary Item Box

Returns Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPFont> getFonts()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPFont type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

getMaxPageSize Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : getMaxPageSize Method

Glossary Item Box

Returns MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).

Syntax

public ImGearXMPDimensions getMaxPageSize()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

getNPages Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : getNPages Method

Glossary Item Box

Returns NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).

Syntax

public ImGearXMPInteger getNPages()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

getPlateNames Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : getPlateNames Method

Glossary Item Box

Returns PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> getPlateNames()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

setColorants Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : setColorants Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPColorant type parameter.

Glossary Item Box

Sets Colorants value of the Paged Text XMP schema. This XMP value specifies ordered array of colorants (swatches) that are used in the document (including any in contained documents).

Syntax

public void setColorants(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPColorant> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPColorant type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

setFonts Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : setFonts Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPFont type parameter.

Glossary Item Box

Sets Fonts value of the Paged Text XMP schema. This XMP value specifies unordered array of fonts that are used in the document (including any in contained documents).

Syntax

public void setFonts(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPFont> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPFont type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

setMaxPageSize Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : setMaxPageSize Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

Glossary Item Box

Sets MaxPageSize value of the Paged Text XMP schema. This XMP value specifies size of the largest page in the document (including any in contained documents).

Syntax

public void setMaxPageSize(
   ImGearXMPDimensions value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDimensions class value.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

setNPages Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : setNPages Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets NPages value of the Paged Text XMP schema. This XMP value specifies number of pages in the document (including any in contained documents).

Syntax

public void setNPages(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%PageItemTitle%%

setPlateNames Method
com.accusoft.imagegear.formats.xmp.pagedtext Package > ImGearPagedTextXMPMetadata Class : setPlateNames Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets PlateNames value of the Paged Text XMP schema. This XMP value specifies ordered array of plate names that are needed to print the document (including any in contained documents).

Syntax

public void setPlateNames(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearPagedTextXMPMetadata Class
ImGearPagedTextXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.photoshop Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP Photoshop format.

Classes

Class | Description
ImGearPhotoshopXMPMetadata | Provides simplified access to Photoshop XMP metadata schema. This schema specifies properties used by Adobe Photoshop.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.photoshop Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearPhotoshopXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.photoshop Package : ImGearPhotoshopXMPMetadata Class

Glossary Item Box

Provides simplified access to Photoshop XMP metadata schema.

This schema specifies properties used by Adobe Photoshop.

Object Model

ImGearPhotoshopXMPMetadata ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPDate ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger Class

Syntax

public class ImGearPhotoshopXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.photoshop.ImGearPhotoshopXMPMetadata

See Also

Reference

ImGearPhotoshopXMPMetadata Members
com.accusoft.imagegear.formats.xmp.photoshop Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPhotoshopXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.photoshop Package : ImGearPhotoshopXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearPhotoshopXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearPhotoshopXMPMetadata Constructor | Initializes a new instance of the ImGearPhotoshopXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getAuthorsPosition | Returns AuthorsPosition value of the Photoshop XMP schema. This XMP value specifies by-line title.
public Method | getCaptionWriter | Returns CaptionWriter value of the Photoshop XMP schema.
public Method | getCategory | Returns Category value of the Photoshop XMP schema. It is limited to 3 7-bit ASCII characters.
public Method | getCity | Returns City value of the Photoshop XMP schema.
public Method | getCountry | Returns Country value of the Photoshop XMP schema.
public Method | getCredit | Returns Credit value of the Photoshop XMP schema.
public Method | getDateCreated | Returns DateCreated value of the Photoshop XMP schema. This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.
public Method | getHeadline | Returns Headline value of the Photoshop XMP schema.
public Method | getInstructions | Returns Instructions value of the Photoshop XMP schema.
public Method | getSource | Returns Source value of the Photoshop XMP schema.
public Method | getState | Returns State value of the Photoshop XMP schema.
public Method | getSupplementalCategories | Returns SupplementalCategories value of the Photoshop XMP schema.
public Method | getTransmissionReference | Returns TransmissionReference value of the Photoshop XMP schema.
public Method | getUrgency | Returns Urgency value of the Photoshop XMP schema. Valid range is 1-8.
public Method | setAuthorsPosition | Sets AuthorsPosition value of the Photoshop XMP schema. This XMP value specifies by-line title.
public Method | setCaptionWriter | Sets CaptionWriter value of the Photoshop XMP schema.
public Method | setCategory | Sets Category value of the Photoshop XMP schema. It is limited to 3 7-bit ASCII characters.
public Method | setCity | Sets City value of the Photoshop XMP schema.
public Method | setCountry | Sets Country value of the Photoshop XMP schema.
public Method | setCredit | Sets Credit value of the Photoshop XMP schema.
public Method | setDateCreated | Sets DateCreated value of the Photoshop XMP schema. This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.
public Method | setHeadline | Sets Headline value of the Photoshop XMP schema.
public Method | setInstructions | Sets Instructions value of the Photoshop XMP schema.
public Method | setSource | Sets Source value of the Photoshop XMP schema.
public Method | setState | Sets State value of the Photoshop XMP schema.
public Method | setSupplementalCategories | Sets SupplementalCategories value of the Photoshop XMP schema.
public Method | setTransmissionReference | Sets TransmissionReference value of the Photoshop XMP schema.
public Method | setUrgency | Sets Urgency value of the Photoshop XMP schema. Valid range is 1-8.
Top

Protected Methods

 | Name | Description
protected Method | getDefaultNamespacePrefix |
protected Method | getNamespaceURI |
Top

See Also

Reference

ImGearPhotoshopXMPMetadata Class
com.accusoft.imagegear.formats.xmp.photoshop Package


%%PageItemTitle%%

ImGearPhotoshopXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : ImGearPhotoshopXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearPhotoshopXMPMetadata class.

Syntax

public ImGearPhotoshopXMPMetadata()

Return Value

New instance of ImGearPhotoshopXMPMetadata class object.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPhotoshopXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.photoshop Package : ImGearPhotoshopXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearPhotoshopXMPMetadata members.

Public Methods

 | Name | Description
public Method | getAuthorsPosition | Returns AuthorsPosition value of the Photoshop XMP schema. This XMP value specifies by-line title.
public Method | getCaptionWriter | Returns CaptionWriter value of the Photoshop XMP schema.
public Method | getCategory | Returns Category value of the Photoshop XMP schema. It is limited to 3 7-bit ASCII characters.
public Method | getCity | Returns City value of the Photoshop XMP schema.
public Method | getCountry | Returns Country value of the Photoshop XMP schema.
public Method | getCredit | Returns Credit value of the Photoshop XMP schema.
public Method | getDateCreated | Returns DateCreated value of the Photoshop XMP schema. This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.
public Method | getHeadline | Returns Headline value of the Photoshop XMP schema.
public Method | getInstructions | Returns Instructions value of the Photoshop XMP schema.
public Method | getSource | Returns Source value of the Photoshop XMP schema.
public Method | getState | Returns State value of the Photoshop XMP schema.
public Method | getSupplementalCategories | Returns SupplementalCategories value of the Photoshop XMP schema.
public Method | getTransmissionReference | Returns TransmissionReference value of the Photoshop XMP schema.
public Method | getUrgency | Returns Urgency value of the Photoshop XMP schema. Valid range is 1-8.
public Method | setAuthorsPosition | Sets AuthorsPosition value of the Photoshop XMP schema. This XMP value specifies by-line title.
public Method | setCaptionWriter | Sets CaptionWriter value of the Photoshop XMP schema.
public Method | setCategory | Sets Category value of the Photoshop XMP schema. It is limited to 3 7-bit ASCII characters.
public Method | setCity | Sets City value of the Photoshop XMP schema.
public Method | setCountry | Sets Country value of the Photoshop XMP schema.
public Method | setCredit | Sets Credit value of the Photoshop XMP schema.
public Method | setDateCreated | Sets DateCreated value of the Photoshop XMP schema. This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.
public Method | setHeadline | Sets Headline value of the Photoshop XMP schema.
public Method | setInstructions | Sets Instructions value of the Photoshop XMP schema.
public Method | setSource | Sets Source value of the Photoshop XMP schema.
public Method | setState | Sets State value of the Photoshop XMP schema.
public Method | setSupplementalCategories | Sets SupplementalCategories value of the Photoshop XMP schema.
public Method | setTransmissionReference | Sets TransmissionReference value of the Photoshop XMP schema.
public Method | setUrgency | Sets Urgency value of the Photoshop XMP schema. Valid range is 1-8.
Top

Protected Methods

 | Name | Description
protected Method | getDefaultNamespacePrefix |
protected Method | getNamespaceURI |
Top

See Also

Reference

ImGearPhotoshopXMPMetadata Class
com.accusoft.imagegear.formats.xmp.photoshop Package


%%PageItemTitle%%

getAuthorsPosition Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getAuthorsPosition Method

Glossary Item Box

Returns AuthorsPosition value of the Photoshop XMP schema.

This XMP value specifies by-line title.

Syntax

public ImGearXMPString getAuthorsPosition()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getCaptionWriter Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getCaptionWriter Method

Glossary Item Box

Returns CaptionWriter value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getCaptionWriter()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getCategory Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getCategory Method

Glossary Item Box

Returns Category value of the Photoshop XMP schema.

It is limited to 3 7-bit ASCII characters.

Syntax

public ImGearXMPString getCategory()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getCity Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getCity Method

Glossary Item Box

Returns City value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getCity()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getCountry Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getCountry Method

Glossary Item Box

Returns Country value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getCountry()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getCredit Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getCredit Method

Glossary Item Box

Returns Credit value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getCredit()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getDateCreated Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getDateCreated Method

Glossary Item Box

Returns DateCreated value of the Photoshop XMP schema.

This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.

Syntax

public ImGearXMPDate getDateCreated()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getDefaultNamespacePrefix Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getDefaultNamespacePrefix Method

Glossary Item Box

Syntax

protected java.lang.String getDefaultNamespacePrefix()

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getHeadline Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getHeadline Method

Glossary Item Box

Returns Headline value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getHeadline()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getInstructions Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getInstructions Method

Glossary Item Box

Returns Instructions value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getInstructions()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getNamespaceURI Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getNamespaceURI Method

Glossary Item Box

Syntax

protected java.lang.String getNamespaceURI()

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getSource Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getSource Method

Glossary Item Box

Returns Source value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getSource()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getState Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getState Method

Glossary Item Box

Returns State value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getState()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getSupplementalCategories Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getSupplementalCategories Method

Glossary Item Box

Returns SupplementalCategories value of the Photoshop XMP schema.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> getSupplementalCategories()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getTransmissionReference Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getTransmissionReference Method

Glossary Item Box

Returns TransmissionReference value of the Photoshop XMP schema.

Syntax

public ImGearXMPString getTransmissionReference()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

getUrgency Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : getUrgency Method

Glossary Item Box

Returns Urgency value of the Photoshop XMP schema.

Valid range is 1-8.

Syntax

public ImGearXMPInteger getUrgency()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setAuthorsPosition Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setAuthorsPosition Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets AuthorsPosition value of the Photoshop XMP schema.

This XMP value specifies by-line title.

Syntax

public void setAuthorsPosition(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setCaptionWriter Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setCaptionWriter Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets CaptionWriter value of the Photoshop XMP schema.

Syntax

public void setCaptionWriter(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setCategory Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setCategory Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Category value of the Photoshop XMP schema.

It is limited to 3 7-bit ASCII characters.

Syntax

public void setCategory(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setCity Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setCity Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets City value of the Photoshop XMP schema.

Syntax

public void setCity(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setCountry Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setCountry Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Country value of the Photoshop XMP schema.

Syntax

public void setCountry(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setCredit Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setCredit Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Credit value of the Photoshop XMP schema.

Syntax

public void setCredit(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setDateCreated Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setDateCreated Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateCreated value of the Photoshop XMP schema.

This XMP value specifies the date the intellectual content of the document was created (rather than the creation date of the physical representation), following IIM conventions. For example, a photo taken during the American Civil War would have a creation date during that epoch (1861-1865) rather than the date the photo was digitized for archiving.

Syntax

public void setDateCreated(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setHeadline Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setHeadline Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Headline value of the Photoshop XMP schema.

Syntax

public void setHeadline(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setInstructions Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setInstructions Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Instructions value of the Photoshop XMP schema.

Syntax

public void setInstructions(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setSource Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setSource Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Source value of the Photoshop XMP schema.

Syntax

public void setSource(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setState Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setState Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets State value of the Photoshop XMP schema.

Syntax

public void setState(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setSupplementalCategories Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setSupplementalCategories Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

Glossary Item Box

Sets SupplementalCategories value of the Photoshop XMP schema.

Syntax

public void setSupplementalCategories(
   com.accusoft.imagegear.formats.xmp.ImGearXMPBag<ImGearXMPString> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBag<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPString type parameter.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setTransmissionReference Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setTransmissionReference Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets TransmissionReference value of the Photoshop XMP schema.

Syntax

public void setTransmissionReference(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%PageItemTitle%%

setUrgency Method
com.accusoft.imagegear.formats.xmp.photoshop Package > ImGearPhotoshopXMPMetadata Class : setUrgency Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets Urgency value of the Photoshop XMP schema.

Valid range is 1-8.

Syntax

public void setUrgency(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearPhotoshopXMPMetadata Class
ImGearPhotoshopXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.rightsmanagement Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP RightsManagement format.

Classes

Class | Description
ImGearRightsManagementXMPMetadata | Provides simplified access to Rights Management XMP metadata schema. This class includes properties related to rights management. These properties specify information regarding the legal restrictions associated with a resource.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.rightsmanagement Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearRightsManagementXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.rightsmanagement Package : ImGearRightsManagementXMPMetadata Class

Glossary Item Box

Provides simplified access to Rights Management XMP metadata schema.

This class includes properties related to rights management. These properties specify information regarding the legal restrictions associated with a resource.

Object Model

ImGearRightsManagementXMPMetadata ClassImGearXMPString ClassImGearXMPBoolean ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPString Class

Syntax

public class ImGearRightsManagementXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.rightsmanagement.ImGearRightsManagementXMPMetadata

See Also

Reference

ImGearRightsManagementXMPMetadata Members
com.accusoft.imagegear.formats.xmp.rightsmanagement Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRightsManagementXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.rightsmanagement Package : ImGearRightsManagementXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearRightsManagementXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearRightsManagementXMPMetadata Constructor | Initializes a new instance of the ImGearRightsManagementXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getCertificate | Returns Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.
public Method | getMarked | Returns Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.
public Method | getProperName | Returns ProperName value of the XMP Rights Management schema.
public Method | getUsageTerms | Returns UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.
public Method | getWebStatement | Returns WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.
public Method | setCertificate | Sets Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.
public Method | setMarked | Sets Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.
public Method | setProperName | Sets ProperName value of the XMP Rights Management schema.
public Method | setUsageTerms | Sets UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.
public Method | setWebStatement | Sets WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.
Top

See Also

Reference

ImGearRightsManagementXMPMetadata Class
com.accusoft.imagegear.formats.xmp.rightsmanagement Package


%%PageItemTitle%%

ImGearRightsManagementXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : ImGearRightsManagementXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearRightsManagementXMPMetadata class.

Syntax

public ImGearRightsManagementXMPMetadata()

Return Value

New instance of ImGearRightsManagementXMPMetadata class object.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRightsManagementXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.rightsmanagement Package : ImGearRightsManagementXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearRightsManagementXMPMetadata members.

Public Methods

 | Name | Description
public Method | getCertificate | Returns Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.
public Method | getMarked | Returns Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.
public Method | getProperName | Returns ProperName value of the XMP Rights Management schema.
public Method | getUsageTerms | Returns UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.
public Method | getWebStatement | Returns WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.
public Method | setCertificate | Sets Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.
public Method | setMarked | Sets Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.
public Method | setProperName | Sets ProperName value of the XMP Rights Management schema.
public Method | setUsageTerms | Sets UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.
public Method | setWebStatement | Sets WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.
Top

See Also

Reference

ImGearRightsManagementXMPMetadata Class
com.accusoft.imagegear.formats.xmp.rightsmanagement Package


%%PageItemTitle%%

getCertificate Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : getCertificate Method

Glossary Item Box

Returns Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.

Syntax

public ImGearXMPString getCertificate()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

getMarked Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : getMarked Method

Glossary Item Box

Returns Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.

Syntax

public ImGearXMPBoolean getMarked()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

getProperName Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : getProperName Method

Glossary Item Box

Returns ProperName value of the XMP Rights Management schema.

Syntax

public ImGearXMPString getProperName()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

getUsageTerms Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : getUsageTerms Method

Glossary Item Box

Returns UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.

Syntax

public ImGearXMPLangAlt getUsageTerms()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

getWebStatement Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : getWebStatement Method

Glossary Item Box

Returns WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.

Syntax

public ImGearXMPString getWebStatement()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

setCertificate Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : setCertificate Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Certificate value of the XMP Rights Management schema. This XMP value specifies online rights management certificate.

Syntax

public void setCertificate(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

setMarked Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : setMarked Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

Glossary Item Box

Sets Marked value of the XMP Rights Management schema. This XMP value indicates that this is a rights-managed resource.

Syntax

public void setMarked(
   ImGearXMPBoolean value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPBoolean class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

setProperName Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : setProperName Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets ProperName value of the XMP Rights Management schema.

Syntax

public void setProperName(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

setUsageTerms Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : setUsageTerms Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets UsageTerms value of the XMP Rights Management schema. This XMP value specifies instructions on how a resource can be legally used.

Syntax

public void setUsageTerms(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%PageItemTitle%%

setWebStatement Method
com.accusoft.imagegear.formats.xmp.rightsmanagement Package > ImGearRightsManagementXMPMetadata Class : setWebStatement Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets WebStatement value of the XMP Rights Management schema. This XMP value specifies location of a web page describing the owner and/or rights statement for this resource.

Syntax

public void setWebStatement(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearRightsManagementXMPMetadata Class
ImGearRightsManagementXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.formats.xmp.tiff Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides the API for XMP TIFF format.

Classes

Class | Description
ImGearTIFFXMPMetadata | Provides simplified access to TIFF XMP metadata schema. This class includes TIFF-derived data. Only those TIFF properties that are mentioned in the EXIF 2.2 specification are included in this schema.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.formats.xmp.tiff Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearTIFFXMPMetadata Class
See Also Members Send Feedback
com.accusoft.imagegear.formats.xmp.tiff Package : ImGearTIFFXMPMetadata Class

Glossary Item Box

Provides simplified access to TIFF XMP metadata schema.

This class includes TIFF-derived data. Only those TIFF properties that are mentioned in the EXIF 2.2 specification are included in this schema.

Object Model

ImGearTIFFXMPMetadata ClassImGearXMPString ClassImGearXMPLangAlt ClassImGearXMPDate ClassImGearXMPLangAlt ClassImGearXMPInteger ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPString ClassImGearXMPInteger ClassImGearXMPString ClassImGearXMPRational ClassImGearXMPInteger ClassImGearXMPRational Class

Syntax

public class ImGearTIFFXMPMetadata
    extends com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.formats.ImGearFormatMetadata
com.accusoft.imagegear.formats.xmp.ImGearXMPFormatMetadata
com.accusoft.imagegear.formats.xmp.tiff.ImGearTIFFXMPMetadata

See Also

Reference

ImGearTIFFXMPMetadata Members
com.accusoft.imagegear.formats.xmp.tiff Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearTIFFXMPMetadata Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.formats.xmp.tiff Package : ImGearTIFFXMPMetadata Class

Glossary Item Box

The following tables list the members exposed by ImGearTIFFXMPMetadata.

Public Constructors

 | Name | Description
public Constructor | ImGearTIFFXMPMetadata Constructor | Initializes a new instance of the ImGearTIFFXMPMetadata class.
Top

Public Methods

 | Name | Description
public Method | getArtist | Returns Artist value of the TIFF XMP schema. This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator. Note: This value is stored in XMP as the first item in the dc:creator array.
public Method | getBitsPerSample | Returns BitsPerSample value of the TIFF XMP schema. This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.
public Method | getCompression | Returns Compression value of the TIFF XMP schema. This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.
public Method | getCopyright | Returns Copyright value of the TIFF XMP schema. This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information. Note: This value is stored in XMP as dc:rights.
public Method | getDateTime | Returns DateTime value of the TIFF XMP schema. This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds). Note: This value is stored in XMP as xmp:ModifyDate.
public Method | getImageDescription | Returns ImageDescription value of the TIFF XMP schema. This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image. Note: This value is stored in XMP as dc:description.
public Method | getImageLength | Returns ImageLength value of the TIFF XMP schema. This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.
public Method | getImageWidth | Returns ImageWidth value of the TIFF XMP schema. This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.
public Method | getMake | Returns Make value of the TIFF XMP schema. This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.
public Method | getModel | Returns Model value of the TIFF XMP schema. This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.
public Method | getOrientation | Returns Orientation value of the TIFF XMP schema. This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.
public Method | getPhotometricInterpretation | Returns PhotometricInterpretation value of the TIFF XMP schema. This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.
public Method | getPlanarConfiguration | Returns PlanarConfiguration value of the TIFF XMP schema. This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.
public Method | getPrimaryCromaticities | Returns PrimaryCromaticities value of the TIFF XMP schema. This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.
public Method | getReferenceBlackWhite | Returns ReferenceBlackWhite value of the TIFF XMP schema. This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.
public Method | getResolutionUnit | Returns ResolutionUnit value of the TIFF XMP schema. This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.
public Method | getSamplesPerPixel | Returns SamplesPerPixel value of the TIFF XMP schema. This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.
public Method | getSoftware | Returns Software value of the TIFF XMP schema. This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image. Note: This value is stored in XMP as xmp:CreatorTool.
public Method | getTransferFunction | Returns TransferFunction value of the TIFF XMP schema. This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.
public Method | getWhitePoint | Returns WhitePoint value of the TIFF XMP schema. This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.
public Method | getXResolution | Returns XResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.
public Method | getYCbCrCoefficients | Returns YCbCrCoefficients value of the TIFF XMP schema. This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.
public Method | getYCbCrPositioning | Returns YCbCrPositioning value of the TIFF XMP schema. This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.
public Method | getYCbCrSubSampling | Returns YCbCrSubSampling value of the TIFF XMP schema. This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.
public Method | getYResolution | Returns YResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.
public Method | setArtist | Sets Artist value of the TIFF XMP schema. This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator. Note: This value is stored in XMP as the first item in the dc:creator array.
public Method | setBitsPerSample | Sets BitsPerSample value of the TIFF XMP schema. This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.
public Method | setCompression | Sets Compression value of the TIFF XMP schema. This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.
public Method | setCopyright | Sets Copyright value of the TIFF XMP schema. This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information. Note: This value is stored in XMP as dc:rights.
public Method | setDateTime | Sets DateTime value of the TIFF XMP schema. This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds). Note: This value is stored in XMP as xmp:ModifyDate.
public Method | setImageDescription | Sets ImageDescription value of the TIFF XMP schema. This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image. Note: This value is stored in XMP as dc:description.
public Method | setImageLength | Sets ImageLength value of the TIFF XMP schema. This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.
public Method | setImageWidth | Sets ImageWidth value of the TIFF XMP schema. This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.
public Method | setMake | Sets Make value of the TIFF XMP schema. This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.
public Method | setModel | Sets Model value of the TIFF XMP schema. This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.
public Method | setOrientation | Sets Orientation value of the TIFF XMP schema. This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.
public Method | setPhotometricInterpretation | Sets PhotometricInterpretation value of the TIFF XMP schema. This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.
public Method | setPlanarConfiguration | Sets PlanarConfiguration value of the TIFF XMP schema. This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.
public Method | setPrimaryCromaticities | Sets PrimaryCromaticities value of the TIFF XMP schema. This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.
public Method | setReferenceBlackWhite | Sets ReferenceBlackWhite value of the TIFF XMP schema. This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.
public Method | setResolutionUnit | Sets ResolutionUnit value of the TIFF XMP schema. This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.
public Method | setSamplesPerPixel | Sets SamplesPerPixel value of the TIFF XMP schema. This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.
public Method | setSoftware | Sets Software value of the TIFF XMP schema. This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image. Note: This value is stored in XMP as xmp:CreatorTool.
public Method | setTransferFunction | Sets TransferFunction value of the TIFF XMP schema. This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.
public Method | setWhitePoint | Sets WhitePoint value of the TIFF XMP schema. This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.
public Method | setXResolution | Sets XResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.
public Method | setYCbCrCoefficients | Sets YCbCrCoefficients value of the TIFF XMP schema. This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.
public Method | setYCbCrPositioning | Sets YCbCrPositioning value of the TIFF XMP schema. This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.
public Method | setYCbCrSubSampling | Sets YCbCrSubSampling value of the TIFF XMP schema. This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.
public Method | setYResolution | Sets YResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.
Top

See Also

Reference

ImGearTIFFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.tiff Package


%%PageItemTitle%%

ImGearTIFFXMPMetadata Constructor
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : ImGearTIFFXMPMetadata Constructor

Glossary Item Box

Initializes a new instance of the ImGearTIFFXMPMetadata class.

Syntax

public ImGearTIFFXMPMetadata()

Return Value

New instance of ImGearTIFFXMPMetadata class object.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearTIFFXMPMetadata Class Methods
See Also Send Feedback
com.accusoft.imagegear.formats.xmp.tiff Package : ImGearTIFFXMPMetadata Class

Glossary Item Box

For a list of all members of this type, see ImGearTIFFXMPMetadata members.

Public Methods

 | Name | Description
public Method | getArtist | Returns Artist value of the TIFF XMP schema. This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator. Note: This value is stored in XMP as the first item in the dc:creator array.
public Method | getBitsPerSample | Returns BitsPerSample value of the TIFF XMP schema. This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.
public Method | getCompression | Returns Compression value of the TIFF XMP schema. This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.
public Method | getCopyright | Returns Copyright value of the TIFF XMP schema. This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information. Note: This value is stored in XMP as dc:rights.
public Method | getDateTime | Returns DateTime value of the TIFF XMP schema. This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds). Note: This value is stored in XMP as xmp:ModifyDate.
public Method | getImageDescription | Returns ImageDescription value of the TIFF XMP schema. This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image. Note: This value is stored in XMP as dc:description.
public Method | getImageLength | Returns ImageLength value of the TIFF XMP schema. This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.
public Method | getImageWidth | Returns ImageWidth value of the TIFF XMP schema. This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.
public Method | getMake | Returns Make value of the TIFF XMP schema. This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.
public Method | getModel | Returns Model value of the TIFF XMP schema. This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.
public Method | getOrientation | Returns Orientation value of the TIFF XMP schema. This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.
public Method | getPhotometricInterpretation | Returns PhotometricInterpretation value of the TIFF XMP schema. This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.
public Method | getPlanarConfiguration | Returns PlanarConfiguration value of the TIFF XMP schema. This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.
public Method | getPrimaryCromaticities | Returns PrimaryCromaticities value of the TIFF XMP schema. This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.
public Method | getReferenceBlackWhite | Returns ReferenceBlackWhite value of the TIFF XMP schema. This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.
public Method | getResolutionUnit | Returns ResolutionUnit value of the TIFF XMP schema. This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.
public Method | getSamplesPerPixel | Returns SamplesPerPixel value of the TIFF XMP schema. This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.
public Method | getSoftware | Returns Software value of the TIFF XMP schema. This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image. Note: This value is stored in XMP as xmp:CreatorTool.
public Method | getTransferFunction | Returns TransferFunction value of the TIFF XMP schema. This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.
public Method | getWhitePoint | Returns WhitePoint value of the TIFF XMP schema. This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.
public Method | getXResolution | Returns XResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.
public Method | getYCbCrCoefficients | Returns YCbCrCoefficients value of the TIFF XMP schema. This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.
public Method | getYCbCrPositioning | Returns YCbCrPositioning value of the TIFF XMP schema. This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.
public Method | getYCbCrSubSampling | Returns YCbCrSubSampling value of the TIFF XMP schema. This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.
public Method | getYResolution | Returns YResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.
public Method | setArtist | Sets Artist value of the TIFF XMP schema. This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator. Note: This value is stored in XMP as the first item in the dc:creator array.
public Method | setBitsPerSample | Sets BitsPerSample value of the TIFF XMP schema. This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.
public Method | setCompression | Sets Compression value of the TIFF XMP schema. This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.
public Method | setCopyright | Sets Copyright value of the TIFF XMP schema. This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information. Note: This value is stored in XMP as dc:rights.
public Method | setDateTime | Sets DateTime value of the TIFF XMP schema. This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds). Note: This value is stored in XMP as xmp:ModifyDate.
public Method | setImageDescription | Sets ImageDescription value of the TIFF XMP schema. This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image. Note: This value is stored in XMP as dc:description.
public Method | setImageLength | Sets ImageLength value of the TIFF XMP schema. This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.
public Method | setImageWidth | Sets ImageWidth value of the TIFF XMP schema. This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.
public Method | setMake | Sets Make value of the TIFF XMP schema. This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.
public Method | setModel | Sets Model value of the TIFF XMP schema. This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.
public Method | setOrientation | Sets Orientation value of the TIFF XMP schema. This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.
public Method | setPhotometricInterpretation | Sets PhotometricInterpretation value of the TIFF XMP schema. This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.
public Method | setPlanarConfiguration | Sets PlanarConfiguration value of the TIFF XMP schema. This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.
public Method | setPrimaryCromaticities | Sets PrimaryCromaticities value of the TIFF XMP schema. This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.
public Method | setReferenceBlackWhite | Sets ReferenceBlackWhite value of the TIFF XMP schema. This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.
public Method | setResolutionUnit | Sets ResolutionUnit value of the TIFF XMP schema. This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.
public Method | setSamplesPerPixel | Sets SamplesPerPixel value of the TIFF XMP schema. This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.
public Method | setSoftware | Sets Software value of the TIFF XMP schema. This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image. Note: This value is stored in XMP as xmp:CreatorTool.
public Method | setTransferFunction | Sets TransferFunction value of the TIFF XMP schema. This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.
public Method | setWhitePoint | Sets WhitePoint value of the TIFF XMP schema. This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.
public Method | setXResolution | Sets XResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.
public Method | setYCbCrCoefficients | Sets YCbCrCoefficients value of the TIFF XMP schema. This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.
public Method | setYCbCrPositioning | Sets YCbCrPositioning value of the TIFF XMP schema. This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.
public Method | setYCbCrSubSampling | Sets YCbCrSubSampling value of the TIFF XMP schema. This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.
public Method | setYResolution | Sets YResolution value of the TIFF XMP schema. This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.
Top

See Also

Reference

ImGearTIFFXMPMetadata Class
com.accusoft.imagegear.formats.xmp.tiff Package


%%PageItemTitle%%

getArtist Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getArtist Method

Glossary Item Box

Returns Artist value of the TIFF XMP schema.

This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator.

Note: This value is stored in XMP as the first item in the dc:creator array.

Syntax

public ImGearXMPString getArtist()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getBitsPerSample Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getBitsPerSample Method

Glossary Item Box

Returns BitsPerSample value of the TIFF XMP schema.

This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getBitsPerSample()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getCompression Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getCompression Method

Glossary Item Box

Returns Compression value of the TIFF XMP schema.

This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFCompression> getCompression()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFCompression type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getCopyright Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getCopyright Method

Glossary Item Box

Returns Copyright value of the TIFF XMP schema.

This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information.

Note: This value is stored in XMP as dc:rights.

Syntax

public ImGearXMPLangAlt getCopyright()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getDateTime Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getDateTime Method

Glossary Item Box

Returns DateTime value of the TIFF XMP schema.

This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds).

Note: This value is stored in XMP as xmp:ModifyDate.

Syntax

public ImGearXMPDate getDateTime()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getImageDescription Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getImageDescription Method

Glossary Item Box

Returns ImageDescription value of the TIFF XMP schema.

This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image.

Note: This value is stored in XMP as dc:description.

Syntax

public ImGearXMPLangAlt getImageDescription()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getImageLength Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getImageLength Method

Glossary Item Box

Returns ImageLength value of the TIFF XMP schema.

This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.

Syntax

public ImGearXMPInteger getImageLength()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getImageWidth Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getImageWidth Method

Glossary Item Box

Returns ImageWidth value of the TIFF XMP schema.

This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.

Syntax

public ImGearXMPInteger getImageWidth()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getMake Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getMake Method

Glossary Item Box

Returns Make value of the TIFF XMP schema.

This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.

Syntax

public ImGearXMPString getMake()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getModel Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getModel Method

Glossary Item Box

Returns Model value of the TIFF XMP schema.

This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.

Syntax

public ImGearXMPString getModel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getOrientation Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getOrientation Method

Glossary Item Box

Returns Orientation value of the TIFF XMP schema.

This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFOrientation> getOrientation()

Return Value

com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getPhotometricInterpretation Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getPhotometricInterpretation Method

Glossary Item Box

Returns PhotometricInterpretation value of the TIFF XMP schema.

This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFPhotoInterpretation> getPhotometricInterpretation()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getPlanarConfiguration Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getPlanarConfiguration Method

Glossary Item Box

Returns PlanarConfiguration value of the TIFF XMP schema.

This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFPlanarConfig> getPlanarConfiguration()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getPrimaryCromaticities Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getPrimaryCromaticities Method

Glossary Item Box

Returns PrimaryCromaticities value of the TIFF XMP schema.

This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> getPrimaryCromaticities()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getReferenceBlackWhite Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getReferenceBlackWhite Method

Glossary Item Box

Returns ReferenceBlackWhite value of the TIFF XMP schema.

This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> getReferenceBlackWhite()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getResolutionUnit Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getResolutionUnit Method

Glossary Item Box

Returns ResolutionUnit value of the TIFF XMP schema.

This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFResolutionUnit> getResolutionUnit()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getSamplesPerPixel Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getSamplesPerPixel Method

Glossary Item Box

Returns SamplesPerPixel value of the TIFF XMP schema.

This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.

Syntax

public ImGearXMPInteger getSamplesPerPixel()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getSoftware Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getSoftware Method

Glossary Item Box

Returns Software value of the TIFF XMP schema.

This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image.

Note: This value is stored in XMP as xmp:CreatorTool.

Syntax

public ImGearXMPString getSoftware()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getTransferFunction Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getTransferFunction Method

Glossary Item Box

Returns TransferFunction value of the TIFF XMP schema.

This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getTransferFunction()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getWhitePoint Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getWhitePoint Method

Glossary Item Box

Returns WhitePoint value of the TIFF XMP schema.

This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> getWhitePoint()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getXResolution Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getXResolution Method

Glossary Item Box

Returns XResolution value of the TIFF XMP schema.

This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.

Syntax

public ImGearXMPRational getXResolution()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getYCbCrCoefficients Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getYCbCrCoefficients Method

Glossary Item Box

Returns YCbCrCoefficients value of the TIFF XMP schema.

This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> getYCbCrCoefficients()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getYCbCrPositioning Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getYCbCrPositioning Method

Glossary Item Box

Returns YCbCrPositioning value of the TIFF XMP schema.

This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.

Syntax

public ImGearXMPInteger getYCbCrPositioning()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getYCbCrSubSampling Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getYCbCrSubSampling Method

Glossary Item Box

Returns YCbCrSubSampling value of the TIFF XMP schema.

This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.

Syntax

public com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> getYCbCrSubSampling()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

getYResolution Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : getYResolution Method

Glossary Item Box

Returns YResolution value of the TIFF XMP schema.

This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.

Syntax

public ImGearXMPRational getYResolution()

Return Value

com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setArtist Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setArtist Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Artist value of the TIFF XMP schema.

This XMP method represents TIFF tag 315 (x13B) and specifies camera owner, photographer or image creator.

Note: This value is stored in XMP as the first item in the dc:creator array.

Syntax

public void setArtist(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setBitsPerSample Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setBitsPerSample Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets BitsPerSample value of the TIFF XMP schema.

This XMP method represents TIFF tag 258 (0x102) and specifies number of bits per component in each channel.

Syntax

public void setBitsPerSample(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setCompression Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setCompression Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFCompression type parameter.

Glossary Item Box

Sets Compression value of the TIFF XMP schema.

This XMP method represents TIFF tag 259 (0x103) and specifies compression scheme: 1 = uncompressed; 6 = JPEG.

Syntax

public void setCompression(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFCompression> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFCompression type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setCopyright Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setCopyright Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets Copyright value of the TIFF XMP schema.

This XMP method represents TIFF tag 33432 (0x8298) and specifies copyright information.

Note: This value is stored in XMP as dc:rights.

Syntax

public void setCopyright(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setDateTime Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setDateTime Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

Glossary Item Box

Sets DateTime value of the TIFF XMP schema.

This XMP method represents TIFF tag 306, 0x132 (primary) and EXIF tag 37520, 0x9290 (subseconds).

Note: This value is stored in XMP as xmp:ModifyDate.

Syntax

public void setDateTime(
   ImGearXMPDate value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPDate class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setImageDescription Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setImageDescription Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

Glossary Item Box

Sets ImageDescription value of the TIFF XMP schema.

This XMP value represents TIFF tag 270 (0x10E) and specifies description of the image.

Note: This value is stored in XMP as dc:description.

Syntax

public void setImageDescription(
   ImGearXMPLangAlt value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPLangAlt class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setImageLength Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setImageLength Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets ImageLength value of the TIFF XMP schema.

This XMP method represents TIFF tag 257 (0x101) and specifies image height in pixels.

Syntax

public void setImageLength(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setImageWidth Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setImageWidth Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets ImageWidth value of the TIFF XMP schema.

This XMP method represents TIFF tag 256 (0x100) and specifies image width in pixels.

Syntax

public void setImageWidth(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setMake Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setMake Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Make value of the TIFF XMP schema.

This XMP method represents TIFF tag 271 (0x10F) and specifies manufacturer of recording equipment.

Syntax

public void setMake(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setModel Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setModel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Model value of the TIFF XMP schema.

This XMP method represents TIFF tag 272 (0x110) and specifies model name or number of equipment.

Syntax

public void setModel(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setOrientation Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setOrientation Method
value
com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation type parameter.

Glossary Item Box

Sets Orientation value of the TIFF XMP schema.

This XMP method represents TIFF tag 274 (0x112) and specifies image orientation.

Syntax

public void setOrientation(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFOrientation> value
)

Parameters

value
com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFOrientation type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setPhotometricInterpretation Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setPhotometricInterpretation Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation type parameter.

Glossary Item Box

Sets PhotometricInterpretation value of the TIFF XMP schema.

This XMP method represents TIFF tag 262 (0x106) and specifies pixel composition.

Syntax

public void setPhotometricInterpretation(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFPhotoInterpretation> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPhotoInterpretation type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setPlanarConfiguration Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setPlanarConfiguration Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig type parameter.

Glossary Item Box

Sets PlanarConfiguration value of the TIFF XMP schema.

This XMP method represents TIFF tag 284 (0x11C) and specifies data layout.

Syntax

public void setPlanarConfiguration(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFPlanarConfig> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFPlanarConfig type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setPrimaryCromaticities Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setPrimaryCromaticities Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

Glossary Item Box

Sets PrimaryCromaticities value of the TIFF XMP schema.

This XMP method represents TIFF tag 319 (0x13F) and specifies chromaticity of the three primary colors.

Syntax

public void setPrimaryCromaticities(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setReferenceBlackWhite Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setReferenceBlackWhite Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

Glossary Item Box

Sets ReferenceBlackWhite value of the TIFF XMP schema.

This XMP method represents TIFF tag 532 (0x214) and specifies reference black and white point values.

Syntax

public void setReferenceBlackWhite(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setResolutionUnit Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setResolutionUnit Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

Glossary Item Box

Sets ResolutionUnit value of the TIFF XMP schema.

This XMP method represents TIFF tag 296 (0x128) and specifies the unit used for XResolution and YResolution.

Syntax

public void setResolutionUnit(
   com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<ImGearTIFFResolutionUnit> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPEnum<T> generic class value with com.accusoft.imagegear.formats.tif.ImGearTIFFResolutionUnit type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setSamplesPerPixel Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setSamplesPerPixel Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets SamplesPerPixel value of the TIFF XMP schema.

This XMP method represents TIFF tag 277 (0x115) and specifies number of components per pixel.

Syntax

public void setSamplesPerPixel(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setSoftware Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setSoftware Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets Software value of the TIFF XMP schema.

This XMP method represents TIFF tag 305 (0x131) and specifies software or firmware used to generate image.

Note: This value is stored in XMP as xmp:CreatorTool.

Syntax

public void setSoftware(
   ImGearXMPString value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setTransferFunction Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setTransferFunction Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets TransferFunction value of the TIFF XMP schema.

This XMP method represents TIFF tag 301 (0x12D) and specifies transfer function for image described in tabular style with 3 * 256 entries.

Syntax

public void setTransferFunction(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setWhitePoint Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setWhitePoint Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

Glossary Item Box

Sets WhitePoint value of the TIFF XMP schema.

This XMP method represents TIFF tag 318 (0x13E) and specifies chromaticity of white point.

Syntax

public void setWhitePoint(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPString class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setXResolution Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setXResolution Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets XResolution value of the TIFF XMP schema.

This XMP method represents TIFF tag 282 (0x11A) and specifies horizontal resolution in pixels per unit.

Syntax

public void setXResolution(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setYCbCrCoefficients Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setYCbCrCoefficients Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

Glossary Item Box

Sets YCbCrCoefficients value of the TIFF XMP schema.

This XMP method represents TIFF tag 529 (0x211) and specifies matrix coefficients for RGB to YCbCr transformation.

Syntax

public void setYCbCrCoefficients(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPRational> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPRational type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setYCbCrPositioning Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setYCbCrPositioning Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

Glossary Item Box

Sets YCbCrPositioning value of the TIFF XMP schema.

This XMP method represents TIFF tag 531 (0x213) and specifies position of chrominance vs. luminance components: 1 = centered; 2 = co-sited.

Syntax

public void setYCbCrPositioning(
   ImGearXMPInteger value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPInteger class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setYCbCrSubSampling Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setYCbCrSubSampling Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

Glossary Item Box

Sets YCbCrSubSampling value of the TIFF XMP schema.

This XMP method represents TIFF tag 530 (0x212) and specifies sampling ratio of chrominance components: [2, 1] = YCbCr4:2:2 [2, 2] = YCbCr4:2:0.

Syntax

public void setYCbCrSubSampling(
   com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<ImGearXMPInteger> value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPSeq<T> generic class value with com.accusoft.imagegear.formats.xmp.ImGearXMPInteger type parameter.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%PageItemTitle%%

setYResolution Method
com.accusoft.imagegear.formats.xmp.tiff Package > ImGearTIFFXMPMetadata Class : setYResolution Method
value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

Glossary Item Box

Sets YResolution value of the TIFF XMP schema.

This XMP method represents TIFF tag 283 (0x11B) and specifies vertical resolution in pixels per unit.

Syntax

public void setYResolution(
   ImGearXMPRational value
)

Parameters

value
com.accusoft.imagegear.formats.xmp.ImGearXMPRational class value.

See Also

Reference

ImGearTIFFXMPMetadata Class
ImGearTIFFXMPMetadata Members


%%ItemTitle%%

com.accusoft.imagegear.processing Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package represents the image and color processing API that allows you to promote or reduce colors using different interpolation algorithms. This API also allows you to rotate, flip, resize, and crop images and provides image transformation methods, such as, remove red eye, perspective, solarize, warp, wave, etc.

Classes

Class | Description
ImGearAverageInterpolationOptions Represents options for average interpolation.

This class has no public fields and methods and is used to identify average interpolation by itself in image processing functions.

ImGearInterpolationOptions

ImGearBayerReductionOptions Defines reduction options for Bayer reduction.

A Bayer dithering algorithm is used to reduce the number of colors (or shades of gray) in the image. Note that setting the output channel depth to 1 will reduce the image to monochrome or black-and-white. Also, the output channel depth must be less than the input channel depth, or an error will result.

ImGearBicubicInterpolationOptions Represents options for bicubic interpolation.

ImGearBilinearInterpolationOptions

ImGearBilinearInterpolationOptions Represents options for bilinear interpolation.

ImGearBicubicInterpolationOptions

ImGearBitonalReductionOptions Defines reduction options for bitonal reduction.

Bitonal reduction reduces an image to black and white by comparing each pixel to a threshold value. Several modes, defined in ImGearBitonalReductionModes, are available for determining how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to ImGearBitonalReductionModes.WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight."

Setting Mode to ImGearBitonalReductionModes.GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of ImGearBitonalReductionModes.AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Use the Threshold option to set the threshold value for converting pixels to black or white. If the value, as calculated by one of the above reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white.

ImGearChannelRef | Represents pixel channel in com.accusoft.imagegear.core.ImGearPage.
ImGearChannelStatistics | Stores statistics for an image channel.
ImGearColorInterpolationOptions Represents color interpolation options.

ImGearInterpolationOptions

ImGearContrastOptions | Represents contrast options.
ImGearDiffuseReductionOptions Defines reduction options for diffuse reduction.

Diffuse reduction reduces an image to either black and white or 4bpp color by performing dithering according to a threshold. The type of dithering used is known as error diffusion, which attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image.

A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

When reducing to 4bpp, a palette containing colors to use for the output image can optionally be specified. If this palette is not supplied, a default palette will be used.

ImGearDoubleMatrix | Represents class to matrix store and matrix operations.
ImGearGrayScaleInterpolationOptions Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions class.

This class defines interpolation options for scale-to-gray interpolation.

ImGearInterpolationOptions

ImGearHalftoneReductionOptions Defines reduction options for halftone reduction.

Halftone reduction reduces an image to black and white in such a way that it is suitable for half-toning. The resulting image will consist of small squares of varying sizes that will give the appearance of varying shades of gray.

ImGearInterpolationOptions Base class for all interpolation options passed to ImGearProcessing.resize and ImGearProcessing.createThumbnail methods.

Use the base class for interpolation modes that do not need additional options. Use derived classes to pass specific options. If a base class is passed for a mode that has a derived class, the default option values are used.

ImGearMedianCutReductionOptions Defines reduction options for median cut reduction.

Median cut reduction reduces an image to 8bpp by dividing it into a number of equally sized squares. The number of squares is equal to the number of desired output colors. The colors of the pixels in each square will be averaged to produce a resulting color. The resulting image will contain only these colors.

ImGearNearestNeighborInterpolationOptions Represents options for nearest neighbor interpolation.

This class has no public fields and methods and is used to identify nearest neighborhood interpolation by itself in image processing functions.

ImGearInterpolationOptions

ImGearNoneInterpolationOptions Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.

This class has no public fields and methods and is used to identify interpolation by itself in image processing functions.

ImGearInterpolationOptions

ImGearOctreeReductionOptions Defines options for octree reduction.

Octree reduction reduces an image to 4bpp or 8bpp by repeatedly subdividing cubic representations of the RGB color space according to image content.

ImGearPixelProcessorRedEyeRGB | Processes the RGB pixel using red-eye removal algorithm.
ImGearPopularityReductionOptions Defines options for popularity reduction.

Popularity reduction reduces an image to 8bpp while retaining its most popular, or prevalent, colors. Use the maxColors field option to specify the maximum number of colors wanted in the result.

ImGearPreserveBlackInterpolationOptions Represents options for PreserveWhite interpolation.

ImGearInterpolationOptions

ImGearPreserveWhiteInterpolationOptions Represents options for PreserveWhite interpolation.

ImGearInterpolationOptions

ImGearProcessing Provides image processing methods that can be applied to both Raster and Vector images.

This class does not have a public constructor because all its functionality is implemented through static members.

ImGearProcessingVerifier

ImGearProcessingVerifier Contains static methods that check whether particular ImGearProcessing operations are applicable to the page.

These methods should be used to distinguish a sub-set of pages for which a particular filter is applicable.

ImGearProcessing

ImGearRasterProcessing Contains IG raster processing methods.

This is the main class for all image raster processing operations.

ImGearRasterProcessingVerifier Contains static methods that check whether particular ImGearRasterProcessing operations are applicable to the page.

Note: These methods should be used to distinguish a sub-set of pages for which particular filter is applicable; e.g., canApplyGaussianBlur method returns true only if incoming page image is not binary, that is BitDepth > 1. Parameters of all IP functions are checked separately.

ImGearReductionOptions Specifies options for performing color reduction using the ImGearRasterProcessing.reduce method.

The only options used by the ImGearRasterProcessing.reduce method are the ones which correspond to the type of reduction as specified by the reductionMethod parameter of the ImGearRasterProcessing.reduce method.

ImGearScaleReductionOptions Defines reduction options for scale reduction.

This class defines reduction options for scale reduction. Scale reduction can be performed on an image whose color space is anything but indexed. The output image will always have the same color space as the input image. It works by linearly scaling the component values for each pixel to the desired output depths. For example, you could reduce a 24bpp (8-8-8) RGB image to 16bpp (5-6-5) RGB. Simply specify the desired output channel depths (and color space) in the parameters for the reduce method.

Note: You can set dontScalePixels option to true to avoid scaling the pixel values. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different.

ImGearWhiteBalance | Represents white balance as a pair of color temperature and tint.

Interfaces

Interface | Description
IImGearPixelProcessor | An implementation of this interface is passed to ProcessArea method. This interface declares one method processPixel which must be implemented by the user.

Enumerations

Enumeration | Description
ImGearBitonalReductionModes | Specifies modes for the bitonal color reduction method. Please, see ImGearBitonalReductionOptions class reference.
ImGearBrushType | Specifies brush types for Pointillist effect.
ImGearCFAColor | Specifies the available colors for Color Filter Array encoded images.
ImGearChannelGroups | Specifies groups of DIB channels. These values are passed to the com.accusoft.imagegear.core.ImGearChannelRange structure constructor.
ImGearContrastModes | Specifies contrast processing modes.
ImGearConvolutionResults | Specifies types of convolution result.
ImGearDirection | Defines a direction of a shadow effect (location of the light source).
ImGearEdgeDetectionMethods | Defines the edge detection methods supported by ImageGear.
ImGearEdgeMapMethods | Specifies types of edge map operation.
ImGearHalftoneReductionModes | Specifies mode of halftone color reduction method. See ImGearHalftoneReductionOptions class description for more details.
ImGearIlluminant | Lists standard illuminants.
ImGearInterpolations | Specifies type of interpolation method.
ImGearLensFlareType | Specifies types of lens flare effects.
ImGearMergeModes | Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge. For example, if you set ARITH_ADD merge method, the resulting pixel values (of those pixels that intersected from the two images) equal the sum of the value of the pixel in the original image and the value of pixel in the image being merged.
ImGearMosaicType | Defines a type of Mosaic effect.
ImGearNightVisionPresets | Specifies Night Vision effects supported by ImageGear.
ImGearPixelateCellType | Defines cell types for Pixelate operation.
ImGearPixelateFillMethod | Defines fill methods for Pixelate operation.
ImGearReductionMethods | Specifies ImageGear color reduction methods.
ImGearRipplePattern | Specifies predefined patterns for the Ripple effect.
ImGearRotationModes | Specifies ImageGear rotation mode.
ImGearShearFillStyle | Specifies fill styles for the Shear effect.
ImGearWhiteBalancePreset | Lists constants for preset white balance values.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.processing Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.processing.ImGearBayerReductionOptions
com.accusoft.imagegear.processing.ImGearBitonalReductionOptions
com.accusoft.imagegear.processing.ImGearChannelRef
com.accusoft.imagegear.processing.ImGearChannelStatistics
com.accusoft.imagegear.processing.ImGearContrastOptions
com.accusoft.imagegear.processing.ImGearDiffuseReductionOptions
com.accusoft.imagegear.processing.ImGearDoubleMatrix
com.accusoft.imagegear.processing.ImGearHalftoneReductionOptions
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearMedianCutReductionOptions
com.accusoft.imagegear.processing.ImGearOctreeReductionOptions
com.accusoft.imagegear.processing.ImGearPixelProcessorRedEyeRGB
com.accusoft.imagegear.processing.ImGearPopularityReductionOptions
com.accusoft.imagegear.processing.ImGearProcessing
com.accusoft.imagegear.processing.ImGearProcessingVerifier
com.accusoft.imagegear.processing.ImGearRasterProcessing
com.accusoft.imagegear.processing.ImGearRasterProcessingVerifier
com.accusoft.imagegear.processing.ImGearReductionOptions
com.accusoft.imagegear.processing.ImGearScaleReductionOptions
com.accusoft.imagegear.processing.ImGearWhiteBalance

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearAverageInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearAverageInterpolationOptions Class

Glossary Item Box

Represents options for average interpolation.

This class has no public fields and methods and is used to identify average interpolation by itself in image processing functions.

ImGearInterpolationOptions

Object Model

ImGearAverageInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearAverageInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearAverageInterpolationOptions

See Also

Reference

ImGearAverageInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearAverageInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearAverageInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearAverageInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearAverageInterpolationOptions Constructor | Initializes a new instance of the ImGearAverageInterpolationOptions class. ImGearAverageInterpolationOptions
Top

See Also

Reference

ImGearAverageInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearAverageInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearAverageInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearAverageInterpolationOptions members.

See Also

Reference

ImGearAverageInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearAverageInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearAverageInterpolationOptions Class : ImGearAverageInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearAverageInterpolationOptions class.

ImGearAverageInterpolationOptions

Syntax

public ImGearAverageInterpolationOptions()

See Also

Reference

ImGearAverageInterpolationOptions Class
ImGearAverageInterpolationOptions Members


%%PageItemTitle%%

ImGearBayerReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearBayerReductionOptions Class

Glossary Item Box

Defines reduction options for Bayer reduction.

A Bayer dithering algorithm is used to reduce the number of colors (or shades of gray) in the image. Note that setting the output channel depth to 1 will reduce the image to monochrome or black-and-white. Also, the output channel depth must be less than the input channel depth, or an error will result.

Object Model

ImGearBayerReductionOptions Class

Syntax

public class ImGearBayerReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearBayerReductionOptions

See Also

Reference

ImGearBayerReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBayerReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearBayerReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearBayerReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearBayerReductionOptions Constructor | Default constructor
Top

Public Fields

 | Name | Description
public Field | palette | Palette to use for the output. A 16-color palette or null. This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used. com.accusoft.imagegear.core.ImGearRGBQuad
Top

See Also

Reference

ImGearBayerReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearBayerReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearBayerReductionOptions Class : ImGearBayerReductionOptions Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearBayerReductionOptions()

See Also

Reference

ImGearBayerReductionOptions Class
ImGearBayerReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearBayerReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearBayerReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearBayerReductionOptions members.

Public Fields

 | Name | Description
public Field | palette | Palette to use for the output. A 16-color palette or null. This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used. com.accusoft.imagegear.core.ImGearRGBQuad
Top

See Also

Reference

ImGearBayerReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

palette Field
com.accusoft.imagegear.processing Package > ImGearBayerReductionOptions Class : palette Field

Glossary Item Box

Palette to use for the output.

A 16-color palette or null.

This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used.

com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public ImGearRGBQuad[] palette

Return Value

A 16-color palette or null.

See Also

Reference

ImGearBayerReductionOptions Class
ImGearBayerReductionOptions Members


%%PageItemTitle%%

ImGearBicubicInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearBicubicInterpolationOptions Class

Glossary Item Box

Represents options for bicubic interpolation.

ImGearBilinearInterpolationOptions

Object Model

ImGearBicubicInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearBicubicInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearBicubicInterpolationOptions

See Also

Reference

ImGearBicubicInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBicubicInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearBicubicInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearBicubicInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearBicubicInterpolationOptions Constructor | Initializes a new instance of the ImGearBicubicInterpolationOptions class. ImGearBicubicInterpolationOptions
Top

Public Methods

 | Name | Description
public Method | getSharpness | Returns the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
public Method | setSharpness | Sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top

See Also

Reference

ImGearBicubicInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearBicubicInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearBicubicInterpolationOptions Class : ImGearBicubicInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearBicubicInterpolationOptions class.

ImGearBicubicInterpolationOptions

Syntax

public ImGearBicubicInterpolationOptions()

See Also

Reference

ImGearBicubicInterpolationOptions Class
ImGearBicubicInterpolationOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearBicubicInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearBicubicInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearBicubicInterpolationOptions members.

Public Methods

 | Name | Description
public Method | getSharpness | Returns the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
public Method | setSharpness | Sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top

See Also

Reference

ImGearBicubicInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

getSharpness Method
com.accusoft.imagegear.processing Package > ImGearBicubicInterpolationOptions Class : getSharpness Method

Glossary Item Box

Returns the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image.

Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Syntax

public double getSharpness()

Return Value

Any positive value.

See Also

Reference

ImGearBicubicInterpolationOptions Class
ImGearBicubicInterpolationOptions Members


%%PageItemTitle%%

setSharpness Method
com.accusoft.imagegear.processing Package > ImGearBicubicInterpolationOptions Class : setSharpness Method
value
Any positive value.

Glossary Item Box

Sets the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image.

Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Syntax

public void setSharpness(
   double value
)

Parameters

value
Any positive value.

See Also

Reference

ImGearBicubicInterpolationOptions Class
ImGearBicubicInterpolationOptions Members


%%PageItemTitle%%

ImGearBilinearInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearBilinearInterpolationOptions Class

Glossary Item Box

Represents options for bilinear interpolation.

ImGearBicubicInterpolationOptions

Object Model

ImGearBilinearInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearBilinearInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearBilinearInterpolationOptions

See Also

Reference

ImGearBilinearInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBilinearInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearBilinearInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearBilinearInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearBilinearInterpolationOptions Constructor | Initializes a new instance of the ImGearBilinearInterpolationOptions class. ImGearBilinearInterpolationOptions
Top

Public Methods

 | Name | Description
public Method | getSharpness | Returns the sharpness of the resized image if the image is being scaled down. This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
public Method | setSharpness | Sets the sharpness of the resized image if the image is being scaled down. This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top

See Also

Reference

ImGearBilinearInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearBilinearInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearBilinearInterpolationOptions Class : ImGearBilinearInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearBilinearInterpolationOptions class.

ImGearBilinearInterpolationOptions

Syntax

public ImGearBilinearInterpolationOptions()

See Also

Reference

ImGearBilinearInterpolationOptions Class
ImGearBilinearInterpolationOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearBilinearInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearBilinearInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearBilinearInterpolationOptions members.

Public Methods

 | Name | Description
public Method | getSharpness | Returns the sharpness of the resized image if the image is being scaled down. This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
public Method | setSharpness | Sets the sharpness of the resized image if the image is being scaled down. This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.
Top

See Also

Reference

ImGearBilinearInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

getSharpness Method
com.accusoft.imagegear.processing Package > ImGearBilinearInterpolationOptions Class : getSharpness Method

Glossary Item Box

Returns the sharpness of the resized image if the image is being scaled down.

This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Syntax

public double getSharpness()

Return Value

Any positive value.

See Also

Reference

ImGearBilinearInterpolationOptions Class
ImGearBilinearInterpolationOptions Members


%%PageItemTitle%%

setSharpness Method
com.accusoft.imagegear.processing Package > ImGearBilinearInterpolationOptions Class : setSharpness Method
value
Any positive value.

Glossary Item Box

Sets the sharpness of the resized image if the image is being scaled down.

This value affects the sharpness of the resized image if the image is being scaled down. Larger values result in a sharper image. Note: A specific sharpness value (such as 1.0) does not necessarily yield the same sharpness when performing the same operation with bilinear versus bicubic interpolation.

Syntax

public void setSharpness(
   double value
)

Parameters

value
Any positive value.

See Also

Reference

ImGearBilinearInterpolationOptions Class
ImGearBilinearInterpolationOptions Members


%%PageItemTitle%%

ImGearBitonalReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearBitonalReductionOptions Class

Glossary Item Box

Defines reduction options for bitonal reduction.

Bitonal reduction reduces an image to black and white by comparing each pixel to a threshold value. Several modes, defined in ImGearBitonalReductionModes, are available for determining how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to ImGearBitonalReductionModes.WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight."

Setting Mode to ImGearBitonalReductionModes.GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of ImGearBitonalReductionModes.AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Use the Threshold option to set the threshold value for converting pixels to black or white. If the value, as calculated by one of the above reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white.

Object Model

ImGearBitonalReductionOptions Class

Syntax

public class ImGearBitonalReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearBitonalReductionOptions

See Also

Reference

ImGearBitonalReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearBitonalReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearBitonalReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearBitonalReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearBitonalReductionOptions Constructor | Default constructor
Top

Public Fields

Name Description
public Field mode Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight".

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Value from ImGearBitonalReductionModes enumeration.

public Field threshold This option sets the threshold value for converting pixels to black or white.

If the value of a pixel, as calculated by one of the reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white. So, a smaller value for Threshold will make the output appear more black, while a larger value will make the output appear more white.

Integer in the range 0-255.

public Field weight1 This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

public Field weight2 This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used, if mode field is set to WEIGHTED.

Integer in the range 0-255.

public Field weight3 This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

Top

See Also

Reference

ImGearBitonalReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearBitonalReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : ImGearBitonalReductionOptions Constructor

Glossary Item Box

Default constructor

Syntax

public ImGearBitonalReductionOptions()

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearBitonalReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearBitonalReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearBitonalReductionOptions members.

Public Fields

Name Description
public Field mode Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight".

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Value from ImGearBitonalReductionModes enumeration.

public Field threshold This option sets the threshold value for converting pixels to black or white.

If the value of a pixel, as calculated by one of the reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white. So, a smaller value for Threshold will make the output appear more black, while a larger value will make the output appear more white.

Integer in the range 0-255.

public Field weight1 This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

public Field weight2 This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used, if mode field is set to WEIGHTED.

Integer in the range 0-255.

public Field weight3 This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

Top

See Also

Reference

ImGearBitonalReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

mode Field
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : mode Field

Glossary Item Box

Determines how the red, green, and blue color components of a pixel contribute to its brightness when compared to the threshold value.

If you set Mode to WEIGHTED, you may also set the values of Weight1, Weight2, and Weight3. These "weights" are used to determine how much influence the values of the red, green, or blue pixels will have on the reduction. For example, if Weight1 (red) = 255, Weight2 (green) = 0, Weight3 (blue) = 0, the whole reduction will depend on the value of the red pixels. The green and blue pixel values will have "no weight".

Setting Mode to GRAYSCALE gives the most weight to the value of green. This optimizes for the perception of the human eye, in which blue is the hardest color to see, and therefore requires the least weight.

A Mode of AVERAGE gives equal weight to all three pixel values.

Here are the formulas used by the three different reduction methods:

  • GRAYSCALE: value = (red*77 + green*151 + blue*28)/256;
  • AVERAGE: value = (red + green + blue)/3;
  • WEIGHTED: value = (red*w1 + green*w2 + blue*w3)/(w1 + w2 + w3);

Value from ImGearBitonalReductionModes enumeration.

Syntax

public ImGearBitonalReductionModes mode

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

threshold Field
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : threshold Field

Glossary Item Box

This option sets the threshold value for converting pixels to black or white.

If the value of a pixel, as calculated by one of the reduction methods, is less than Threshold, the pixels will be set to black; if it is greater than or equal to Threshold, the pixels will be set to white. So, a smaller value for Threshold will make the output appear more black, while a larger value will make the output appear more white.

Integer in the range 0-255.

Syntax

public int threshold

Return Value

Integer in the range 0-255.

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

weight1 Field
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : weight1 Field

Glossary Item Box

This option specifies the weight given to the red color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

Syntax

public int weight1

Return Value

Integer in the range 0-255.

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

weight2 Field
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : weight2 Field

Glossary Item Box

This option specifies the weight given to the green color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used, if mode field is set to WEIGHTED.

Integer in the range 0-255.

Syntax

public int weight2

Return Value

Integer in the range 0-255.

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

weight3 Field
com.accusoft.imagegear.processing Package > ImGearBitonalReductionOptions Class : weight3 Field

Glossary Item Box

This option specifies the weight given to the blue color component when considering the value of an input pixel for comparison to the threshold field value.

This option is only used if mode field is set to WEIGHTED.

Integer in the range 0-255.

Syntax

public int weight3

Return Value

Integer in the range 0-255.

See Also

Reference

ImGearBitonalReductionOptions Class
ImGearBitonalReductionOptions Members


%%PageItemTitle%%

ImGearChannelRef Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelRef Class

Glossary Item Box

Represents pixel channel in com.accusoft.imagegear.core.ImGearPage.

Object Model

ImGearChannelRef Class

Syntax

public sealed class ImGearChannelRef
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearChannelRef

See Also

Reference

ImGearChannelRef Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearChannelRef Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelRef Class

Glossary Item Box

The following tables list the members exposed by ImGearChannelRef.

Public Constructors

 | Name | Description
public Constructor | ImGearChannelRef Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | content | Gets or sets a reference to the raster page.
public Field | number | Gets or sets an index of a pixel channel in the associated raster page. Integer value.
Top

See Also

Reference

ImGearChannelRef Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearChannelRef Constructor
com.accusoft.imagegear.processing Package > ImGearChannelRef Class : ImGearChannelRef Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearChannelRef Constructor(ImGearRasterPage) | Initializes a new instance of the ImGearChannelRef structure. This constructor sets the Number property to 0.
ImGearChannelRef Constructor(ImGearRasterPage,int) | Initializes a new instance of the ImGearChannelRef structure.

See Also

Reference

ImGearChannelRef Class
ImGearChannelRef Members


%%PageItemTitle%%

ImGearChannelRef Constructor(ImGearRasterPage)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearChannelRef Class > ImGearChannelRef Constructor : ImGearChannelRef Constructor(ImGearRasterPage)
cntnt
Reference to page whose image contains channel data.

Glossary Item Box

Initializes a new instance of the ImGearChannelRef structure.

This constructor sets the Number property to 0.

Syntax

public ImGearChannelRef(
   ImGearRasterPage cntnt
)

Parameters

cntnt
Reference to page whose image contains channel data.

See Also

Reference

ImGearChannelRef Class
ImGearChannelRef Members
Overload List
ImGearChannelRef Class
ImGearRasterPage Class


%%PageItemTitle%%

ImGearChannelRef Constructor(ImGearRasterPage,int)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearChannelRef Class > ImGearChannelRef Constructor : ImGearChannelRef Constructor(ImGearRasterPage,int)
cntnt
Reference to the raster page.
nmbr
Index of a pixel channel in the raster page.

Glossary Item Box

Initializes a new instance of the ImGearChannelRef structure.

Syntax

public ImGearChannelRef(
   ImGearRasterPage cntnt,
   int nmbr
)

Parameters

cntnt
Reference to the raster page.
nmbr
Index of a pixel channel in the raster page.

See Also

Reference

ImGearChannelRef Class
ImGearChannelRef Members
Overload List
ImGearChannelRef Class
ImGearRasterPage Class


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearChannelRef Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelRef Class

Glossary Item Box

For a list of all members of this type, see ImGearChannelRef members.

Public Fields

 | Name | Description
public Field | content | Gets or sets a reference to the raster page.
public Field | number | Gets or sets an index of a pixel channel in the associated raster page. Integer value.
Top

See Also

Reference

ImGearChannelRef Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

content Field
com.accusoft.imagegear.processing Package > ImGearChannelRef Class : content Field

Glossary Item Box

Gets or sets a reference to the raster page.

Syntax

public ImGearRasterPage content

See Also

Reference

ImGearChannelRef Class
ImGearChannelRef Members
ImGearRasterPage Class
ImGearChannelRef Class


%%PageItemTitle%%

number Field
com.accusoft.imagegear.processing Package > ImGearChannelRef Class : number Field

Glossary Item Box

Gets or sets an index of a pixel channel in the associated raster page.

Integer value.

Syntax

public int number

See Also

Reference

ImGearChannelRef Class
ImGearChannelRef Members
ImGearChannelRef Class


%%PageItemTitle%%

ImGearChannelStatistics Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelStatistics Class

Glossary Item Box

Stores statistics for an image channel.

Object Model

ImGearChannelStatistics Class

Syntax

public sealed class ImGearChannelStatistics
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearChannelStatistics

See Also

Reference

ImGearChannelStatistics Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearChannelStatistics Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelStatistics Class

Glossary Item Box

The following tables list the members exposed by ImGearChannelStatistics.

Public Constructors

 | Name | Description
public Constructor | ImGearChannelStatistics Constructor | Default constructor.
Top

Public Methods

 | Name | Description
public Method | getAverage | Returns average value of the image channel.
public Method | getMax | Returns a 32-bit integer, representing max value of the channel. This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the getMax() method throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use getMax64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | getMax64 | Returns a 64-bit integer, representing maximum value of the image channel.
public Method | getMin | Returns a 32-bit integer, representing min value of the channel. Use getMin64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | getMin64 | Returns a 64-bit integer, representing minimum value of the image channel.
public Method | setAverage | Sets average value of the image channel.
public Method | setMax | Sets a 32-bit integer, representing max value of the channel. This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the Max property throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use setMax64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | setMax64 | Sets a 64-bit integer, representing maximum value of the image channel.
public Method | setMin | Sets a 32-bit integer, representing min value of the channel. This value represents the 32-bit integer minimum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the setMin() value throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use getMin64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | setMin64 | Sets a 64-bit integer, representing minimum value of the image channel.
Top

See Also

Reference

ImGearChannelStatistics Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearChannelStatistics Constructor
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : ImGearChannelStatistics Constructor

Glossary Item Box

Default constructor.

Syntax

public ImGearChannelStatistics()

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearChannelStatistics Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearChannelStatistics Class

Glossary Item Box

For a list of all members of this type, see ImGearChannelStatistics members.

Public Methods

 | Name | Description
public Method | getAverage | Returns average value of the image channel.
public Method | getMax | Returns a 32-bit integer, representing max value of the channel. This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the getMax() method throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use getMax64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | getMax64 | Returns a 64-bit integer, representing maximum value of the image channel.
public Method | getMin | Returns a 32-bit integer, representing min value of the channel. Use getMin64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | getMin64 | Returns a 64-bit integer, representing minimum value of the image channel.
public Method | setAverage | Sets average value of the image channel.
public Method | setMax | Sets a 32-bit integer, representing max value of the channel. This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the Max property throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use setMax64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | setMax64 | Sets a 64-bit integer, representing maximum value of the image channel.
public Method | setMin | Sets a 32-bit integer, representing min value of the channel. This value represents the 32-bit integer minimum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the setMin() value throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception. Use getMin64 method if you are working with 32-bit per channel images. com.accusoft.imagegear.core.ImGearErrorCodes
public Method | setMin64 | Sets a 64-bit integer, representing minimum value of the image channel.
Top

See Also

Reference

ImGearChannelStatistics Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

getAverage Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : getAverage Method

Glossary Item Box

Returns average value of the image channel.

Syntax

public double getAverage()

Return Value

Any double value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

getMax Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : getMax Method

Glossary Item Box

Returns a 32-bit integer, representing max value of the channel.

This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the getMax() method throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

Use getMax64 method if you are working with 32-bit per channel images.

com.accusoft.imagegear.core.ImGearErrorCodes

Syntax

public int getMax()

Return Value

32-bit Integer number.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

getMax64 Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : getMax64 Method

Glossary Item Box

Returns a 64-bit integer, representing maximum value of the image channel.

Syntax

public long getMax64()

Return Value

64-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

getMin Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : getMin Method

Glossary Item Box

Returns a 32-bit integer, representing min value of the channel.

Use getMin64 method if you are working with 32-bit per channel images.

com.accusoft.imagegear.core.ImGearErrorCodes

Syntax

public int getMin()

Return Value

32-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

getMin64 Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : getMin64 Method

Glossary Item Box

Returns a 64-bit integer, representing minimum value of the image channel.

Syntax

public long getMin64()

Return Value

64-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

setAverage Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : setAverage Method
value
Any double value.

Glossary Item Box

Sets average value of the image channel.

Syntax

public void setAverage(
   double value
)

Parameters

value
Any double value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

setMax Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : setMax Method
value
32-bit Integer number.

Glossary Item Box

Sets a 32-bit integer, representing max value of the channel.

This value represents the 32-bit integer maximum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the Max property throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

Use setMax64 method if you are working with 32-bit per channel images.

com.accusoft.imagegear.core.ImGearErrorCodes

Syntax

public void setMax(
   int value
)

Parameters

value
32-bit Integer number.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

setMax64 Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : setMax64 Method
value
64-bit Integer value.

Glossary Item Box

Sets a 64-bit integer, representing maximum value of the image channel.

Syntax

public void setMax64(
   long value
)

Parameters

value
64-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

setMin Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : setMin Method
value
32-bit Integer value.

Glossary Item Box

Sets a 32-bit integer, representing min value of the channel.

This value represents the 32-bit integer minimum value of the image channel. Internal value is stored as a 64-bit integer. If the stored number exceeds the 32-bit integer range, an attempt to get the setMin() value throws com.accusoft.imagegear.core.ImGearErrorCodes.PARAMETER_HAS_INVALID_VALUE exception.

Use getMin64 method if you are working with 32-bit per channel images.

com.accusoft.imagegear.core.ImGearErrorCodes

Syntax

public void setMin(
   int value
)

Parameters

value
32-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

setMin64 Method
com.accusoft.imagegear.processing Package > ImGearChannelStatistics Class : setMin64 Method
value
64-bit Integer value.

Glossary Item Box

Sets a 64-bit integer, representing minimum value of the image channel.

Syntax

public void setMin64(
   long value
)

Parameters

value
64-bit Integer value.

See Also

Reference

ImGearChannelStatistics Class
ImGearChannelStatistics Members


%%PageItemTitle%%

ImGearColorInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearColorInterpolationOptions Class

Glossary Item Box

Represents color interpolation options.

ImGearInterpolationOptions

Object Model

ImGearColorInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearColorInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearColorInterpolationOptions

See Also

Reference

ImGearColorInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearColorInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearColorInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearColorInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearColorInterpolationOptions Constructor | Initializes a new instance of the ImGearColorInterpolationOptions class. ImGearColorInterpolationOptions
Top

See Also

Reference

ImGearColorInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearColorInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearColorInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearColorInterpolationOptions members.

See Also

Reference

ImGearColorInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearColorInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearColorInterpolationOptions Class : ImGearColorInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearColorInterpolationOptions class.

ImGearColorInterpolationOptions

Syntax

public ImGearColorInterpolationOptions()

See Also

Reference

ImGearColorInterpolationOptions Class
ImGearColorInterpolationOptions Members


%%PageItemTitle%%

ImGearContrastOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearContrastOptions Class

Glossary Item Box

Represents contrast options.

Object Model

ImGearContrastOptions Class

Syntax

public class ImGearContrastOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearContrastOptions

See Also

Reference

ImGearContrastOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearContrastOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearContrastOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearContrastOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearContrastOptions Constructor | Initializes a new instance of the ImGearContrastOptions class. ImGearContrastOptions
Top

Public Fields

 | Name | Description
public Field | ignoreDICOMDisplaySettings | Determines whether to ignore DICOM display settings in contrast processing operations. Boolean value. com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings
Top

See Also

Reference

ImGearContrastOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearContrastOptions Constructor
com.accusoft.imagegear.processing Package > ImGearContrastOptions Class : ImGearContrastOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearContrastOptions class.

ImGearContrastOptions

Syntax

public ImGearContrastOptions()

See Also

Reference

ImGearContrastOptions Class
ImGearContrastOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearContrastOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearContrastOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearContrastOptions members.

Public Fields

 | Name | Description
public Field | ignoreDICOMDisplaySettings | Determines whether to ignore DICOM display settings in contrast processing operations. Boolean value. com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings
Top

See Also

Reference

ImGearContrastOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ignoreDICOMDisplaySettings Field
com.accusoft.imagegear.processing Package > ImGearContrastOptions Class : ignoreDICOMDisplaySettings Field

Glossary Item Box

Determines whether to ignore DICOM display settings in contrast processing operations.

Boolean value. com.accusoft.imagegear.formats.dicom.ImGearDICOMDisplaySettings

Syntax

public boolean ignoreDICOMDisplaySettings

Return Value

Boolean value.

See Also

Reference

ImGearContrastOptions Class
ImGearContrastOptions Members


%%PageItemTitle%%

ImGearDiffuseReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearDiffuseReductionOptions Class

Glossary Item Box

Defines reduction options for diffuse reduction.

Diffuse reduction reduces an image to either black and white or 4bpp color by performing dithering according to a threshold. The type of dithering used is known as error diffusion, which attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image.

A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

When reducing to 4bpp, a palette containing colors to use for the output image can optionally be specified. If this palette is not supplied, a default palette will be used.

Object Model

ImGearDiffuseReductionOptions Class

Syntax

public class ImGearDiffuseReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearDiffuseReductionOptions

See Also

Reference

ImGearDiffuseReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDiffuseReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearDiffuseReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearDiffuseReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearDiffuseReductionOptions Constructor | Initializes a new instance of the ImGearDiffuseReductionOptions class object.
Top

Public Fields

 | Name | Description
public Field | palette | Palette to use for output. A 16-color palette, or null. This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used. com.accusoft.imagegear.core.ImGearRGBQuad
public Field | threshold | Threshold value for dithering, 0-255. Integer in the range 0-255. A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.
Top

See Also

Reference

ImGearDiffuseReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearDiffuseReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearDiffuseReductionOptions Class : ImGearDiffuseReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearDiffuseReductionOptions class object.

Syntax

public ImGearDiffuseReductionOptions()

See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearDiffuseReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearDiffuseReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearDiffuseReductionOptions members.

Public Fields

 | Name | Description
public Field | palette | Palette to use for output. A 16-color palette, or null. This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used. com.accusoft.imagegear.core.ImGearRGBQuad
public Field | threshold | Threshold value for dithering, 0-255. Integer in the range 0-255. A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.
Top

See Also

Reference

ImGearDiffuseReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

palette Field
com.accusoft.imagegear.processing Package > ImGearDiffuseReductionOptions Class : palette Field

Glossary Item Box

Palette to use for output.

A 16-color palette, or null.

This option lets you specify a palette containing the colors to use for the output image. Itï¿½s only used when the output channel depth is 4. If no palette is specified, a default palette is used.

com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public ImGearRGBQuad[] palette

Return Value

A 16-color palette, or null.

See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members


%%PageItemTitle%%

threshold Field
com.accusoft.imagegear.processing Package > ImGearDiffuseReductionOptions Class : threshold Field

Glossary Item Box

Threshold value for dithering, 0-255.

Integer in the range 0-255.

A threshold value of 128 will produce an output image in which black and white are in equal proportion. A value greater than 128 would mean more bright than dark, and a value less than 128 would mean more dark than bright.

Syntax

public int threshold

Return Value

Integer in the range 0-255.

See Also

Reference

ImGearDiffuseReductionOptions Class
ImGearDiffuseReductionOptions Members


%%PageItemTitle%%

ImGearDoubleMatrix Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearDoubleMatrix Class

Glossary Item Box

Represents class to matrix store and matrix operations.

Object Model

ImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix ClassImGearDoubleMatrix Class

Syntax

public class ImGearDoubleMatrix
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearDoubleMatrix

See Also

Reference

ImGearDoubleMatrix Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearDoubleMatrix Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearDoubleMatrix Class

Glossary Item Box

The following tables list the members exposed by ImGearDoubleMatrix.

Public Constructors

 | Name | Description
public Constructor | ImGearDoubleMatrix Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | clone | Clone ImGearDoubleMatrix object.
static (Shared in Visual Basic) | create | Overloaded. Returns a new ImGearDoubleMatrix class object.
static (Shared in Visual Basic) | createDefault | Returns a new ImGearDoubleMatrix class object.
public Method | createIdentity | Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.
public Method | getColCount | Gets the count of columns in the matrix.
public Method | getElem | Gets matrix element according to matrix column and row coordinate.
public Method | getRowCount | Gets matrix rows count.
public Method | getValues | get matrix element as double values two dimentioned array.
public Method | inverse | Inverse ImGearDoubleMatrix square matrix.
public Method | leftMultiply | Multiplies vector by ImGearDoubleMatrix matrix (vector * matrix).
public Method | multiplyByVector | Overloaded. Multiplies matrix by vector.
public Method | multiplyByVectorWithCast | Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.
static (Shared in Visual Basic) | opAddition | Adds one ImGearDoubleMatrix matrix to another (matrixA + matrixB).
static (Shared in Visual Basic) | opMultiply | Overloaded. Returns copy of ImGearDoubleMatrix matrix scaled to value.
public Method | pseudoInverse | Returns pseudo inverse ImGearDoubleMatrix matrix object.
public Method | scale | Scale matrix values (matrixA * scaleValue).
public Method | setElem | Sets matrix element value.
public Method | transpose | Transpose the matrix.
Top

See Also

Reference

ImGearDoubleMatrix Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearDoubleMatrix Constructor
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : ImGearDoubleMatrix Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearDoubleMatrix Constructor(double[,]) | Initializes a new instance of the ImGearDoubleMatrix class.
ImGearDoubleMatrix Constructor(int,int) | Initializes a new instance of the ImGearDoubleMatrix class.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

ImGearDoubleMatrix Constructor(double[,])
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > ImGearDoubleMatrix Constructor : ImGearDoubleMatrix Constructor(double[,])
values
Two dimentions array of doubles.

Glossary Item Box

Initializes a new instance of the ImGearDoubleMatrix class.

Syntax

public ImGearDoubleMatrix(
   double[][] values
)

Parameters

values
Two dimentions array of doubles.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

ImGearDoubleMatrix Constructor(int,int)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > ImGearDoubleMatrix Constructor : ImGearDoubleMatrix Constructor(int,int)
rowCount
Matrix rows count.
columnCount
Matrix columns count.

Glossary Item Box

Initializes a new instance of the ImGearDoubleMatrix class.

Syntax

public ImGearDoubleMatrix(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearDoubleMatrix Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearDoubleMatrix Class

Glossary Item Box

For a list of all members of this type, see ImGearDoubleMatrix members.

Public Methods

 | Name | Description
public Method | clone | Clone ImGearDoubleMatrix object.
static (Shared in Visual Basic) | create | Overloaded. Returns a new ImGearDoubleMatrix class object.
static (Shared in Visual Basic) | createDefault | Returns a new ImGearDoubleMatrix class object.
public Method | createIdentity | Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.
public Method | getColCount | Gets the count of columns in the matrix.
public Method | getElem | Gets matrix element according to matrix column and row coordinate.
public Method | getRowCount | Gets matrix rows count.
public Method | getValues | get matrix element as double values two dimentioned array.
public Method | inverse | Inverse ImGearDoubleMatrix square matrix.
public Method | leftMultiply | Multiplies vector by ImGearDoubleMatrix matrix (vector * matrix).
public Method | multiplyByVector | Overloaded. Multiplies matrix by vector.
public Method | multiplyByVectorWithCast | Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.
static (Shared in Visual Basic) | opAddition | Adds one ImGearDoubleMatrix matrix to another (matrixA + matrixB).
static (Shared in Visual Basic) | opMultiply | Overloaded. Returns copy of ImGearDoubleMatrix matrix scaled to value.
public Method | pseudoInverse | Returns pseudo inverse ImGearDoubleMatrix matrix object.
public Method | scale | Scale matrix values (matrixA * scaleValue).
public Method | setElem | Sets matrix element value.
public Method | transpose | Transpose the matrix.
Top

See Also

Reference

ImGearDoubleMatrix Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : clone Method

Glossary Item Box

Clone ImGearDoubleMatrix object.

Syntax

public ImGearDoubleMatrix clone()

Return Value

ImGearDoubleMatrix object value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

create Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : create Method

Glossary Item Box

Returns a new ImGearDoubleMatrix class object.

Overload List

Overload | Description
create(int,int) | Returns a new ImGearDoubleMatrix class object.
create(double[,]) | Returns a new ImGearDoubleMatrix class object.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

create(int,int) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > create Method : create(int,int) Method
rowCount
Matrix rows count.
columnCount
Matrix columns count.

Glossary Item Box

Returns a new ImGearDoubleMatrix class object.

Syntax

public static ImGearDoubleMatrix create(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.

Return Value

ImGearDoubleMatrix class object with zero initialized elements values.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

create(double[,]) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > create Method : create(double[,]) Method
values
Double values array.

Glossary Item Box

Returns a new ImGearDoubleMatrix class object.

Syntax

public static ImGearDoubleMatrix create(
   double[][] values
)

Parameters

values
Double values array.

Return Value

ImGearDoubleMatrix class object with zero initialized elements values.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

createDefault Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : createDefault Method
rowCount
Matrix rows count.
columnCount
Matrix columns count.

Glossary Item Box

Returns a new ImGearDoubleMatrix class object.

Syntax

public static ImGearDoubleMatrix createDefault(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix rows count.
columnCount
Matrix columns count.

Return Value

ImGearDoubleMatrix class object with zero initialized elements values.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

createIdentity Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : createIdentity Method
rowCount
Matrix row count.
columnCount
Matrix column count.

Glossary Item Box

Creates identity diagonal matrix with 0 values initialized and diagonal values are 1.

Syntax

public ImGearDoubleMatrix createIdentity(
   int rowCount,
   int columnCount
)

Parameters

rowCount
Matrix row count.
columnCount
Matrix column count.

Return Value

ImGearDoubleMatrix class object.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

getColCount Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : getColCount Method

Glossary Item Box

Gets the count of columns in the matrix.

Syntax

public int getColCount()

Return Value

Integer value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

getElem Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : getElem Method
row
Row coordinate of the matrix element.
column
Column coordinate of the matrix element.

Glossary Item Box

Gets matrix element according to matrix column and row coordinate.

Syntax

public double getElem(
   int row,
   int column
)

Parameters

row
Row coordinate of the matrix element.
column
Column coordinate of the matrix element.

Return Value

Double value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

getRowCount Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : getRowCount Method

Glossary Item Box

Gets matrix rows count.

Syntax

public int getRowCount()

Return Value

Integer value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

getValues Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : getValues Method

Glossary Item Box

get matrix element as double values two dimentioned array.

Syntax

public double[] getValues()

Return Value

Two dimention array of doubles.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

inverse Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : inverse Method

Glossary Item Box

Inverse ImGearDoubleMatrix square matrix.

Syntax

public ImGearDoubleMatrix inverse()

Return Value

ImGearDoubleMatrix result matrix.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

leftMultiply Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : leftMultiply Method
vector
Vector value.

Glossary Item Box

Multiplies vector by ImGearDoubleMatrix matrix (vector * matrix).

Syntax

public double[] leftMultiply(
   double[] vector
)

Parameters

vector
Vector value.

Return Value

Result vector value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

multiplyByVector Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : multiplyByVector Method

Glossary Item Box

Multiplies matrix by vector.

Overload List

Overload | Description
multiplyByVector(int[],int[]) | Multiplies matrix by vector.
multiplyByVector(short[],int) | Multiplies matrix by vector found in vectorContent array at the specified offset and stores result in the same place.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

multiplyByVector(int[],int[]) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > multiplyByVector Method : multiplyByVector(int[],int[]) Method
vectorToMultiply
Vector value.
resultVector
Result vector value. Result vector should has length same as matrix row count.

Glossary Item Box

Multiplies matrix by vector.

Syntax

public void multiplyByVector(
   int[] vectorToMultiply,
   int[] resultVector
)

Parameters

vectorToMultiply
Vector value.
resultVector
Result vector value. Result vector should has length same as matrix row count.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

multiplyByVector(short[],int) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > multiplyByVector Method : multiplyByVector(short[],int) Method
vectorContent
Array containing vector coordinates.
vectorOffset
Offset to vector to multiply the matrix with.

Glossary Item Box

Multiplies matrix by vector found in vectorContent array at the specified offset and stores result in the same place.

Syntax

public void multiplyByVector(
   short[] vectorContent,
   int vectorOffset
)

Parameters

vectorContent
Array containing vector coordinates.
vectorOffset
Offset to vector to multiply the matrix with.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

multiplyByVectorWithCast Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : multiplyByVectorWithCast Method
vectorContent
Vector value.
vectorOffset
Start offset to vectorToMultiply vector. Result vector values are set to 65535 if operation result exceed 65535.

Glossary Item Box

Multiplies matrix by vector found in vectorContent array at the specified offset, truncating result values, and stores result in the same place.

Syntax

public void multiplyByVectorWithCast(
   short[] vectorContent,
   int vectorOffset
)

Parameters

vectorContent
Vector value.
vectorOffset
Start offset to vectorToMultiply vector. Result vector values are set to 65535 if operation result exceed 65535.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

opAddition Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : opAddition Method
matrix1
ImGearDoubleMatrix matrix 1.
matrix2
ImGearDoubleMatrix matrix 2.

Glossary Item Box

Adds one ImGearDoubleMatrix matrix to another (matrixA + matrixB).

Syntax

public static ImGearDoubleMatrix opAddition(
   ImGearDoubleMatrix matrix1,
   ImGearDoubleMatrix matrix2
)

Parameters

matrix1
ImGearDoubleMatrix matrix 1.
matrix2
ImGearDoubleMatrix matrix 2.

Return Value

ImGearDoubleMatrix result matrix.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

opMultiply Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : opMultiply Method

Glossary Item Box

Returns copy of ImGearDoubleMatrix matrix scaled to value.

Overload List

Overload | Description
opMultiply(ImGearDoubleMatrix,double) | Returns copy of ImGearDoubleMatrix matrix scaled to value.
opMultiply(ImGearDoubleMatrix,double[]) | Multiplies ImGearDoubleMatrix matrix by vector (matrix * vector).
opMultiply(ImGearDoubleMatrix,ImGearDoubleMatrix) | Multiplies two ImGearDoubleMatrix matrix (matrixA * matrixB).

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

opMultiply(ImGearDoubleMatrix,double) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > opMultiply Method : opMultiply(ImGearDoubleMatrix,double) Method
matrix
ImGearDoubleMatrix matrix value.
value
Scale value.

Glossary Item Box

Returns copy of ImGearDoubleMatrix matrix scaled to value.

Syntax

public static ImGearDoubleMatrix opMultiply(
   ImGearDoubleMatrix matrix,
   double value
)

Parameters

matrix
ImGearDoubleMatrix matrix value.
value
Scale value.

Return Value

ImGearDoubleMatrix class object with scaled elements.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

opMultiply(ImGearDoubleMatrix,double[]) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > opMultiply Method : opMultiply(ImGearDoubleMatrix,double[]) Method
matrix
ImGearDoubleMatrix matrix.
vector
Vector value.

Glossary Item Box

Multiplies ImGearDoubleMatrix matrix by vector (matrix * vector).

Syntax

public static double[] opMultiply(
   ImGearDoubleMatrix matrix,
   double[] vector
)

Parameters

matrix
ImGearDoubleMatrix matrix.
vector
Vector value.

Return Value

Result operation vector.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

opMultiply(ImGearDoubleMatrix,ImGearDoubleMatrix) Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class > opMultiply Method : opMultiply(ImGearDoubleMatrix,ImGearDoubleMatrix) Method
matrix1
ImGearDoubleMatrix matrix 1.
matrix2
ImGearDoubleMatrix matrix 2.

Glossary Item Box

Multiplies two ImGearDoubleMatrix matrix (matrixA * matrixB).

Syntax

public static ImGearDoubleMatrix opMultiply(
   ImGearDoubleMatrix matrix1,
   ImGearDoubleMatrix matrix2
)

Parameters

matrix1
ImGearDoubleMatrix matrix 1.
matrix2
ImGearDoubleMatrix matrix 2.

Return Value

ImGearDoubleMatrix result matrix object.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members
Overload List


%%PageItemTitle%%

pseudoInverse Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : pseudoInverse Method

Glossary Item Box

Returns pseudo inverse ImGearDoubleMatrix matrix object.

Syntax

public ImGearDoubleMatrix pseudoInverse()

Return Value

Operation makes: Ax = Inverse(At*A)*At Where A is the matrix and At is transpose of A.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

scale Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : scale Method
value
Double value to scale each matrix value.

Glossary Item Box

Scale matrix values (matrixA * scaleValue).

Syntax

public void scale(
   double value
)

Parameters

value
Double value to scale each matrix value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

setElem Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : setElem Method
row
Row coordinate of the matrix element to set.
column
Column coordinate of the matrix element to set.
value
Double value.

Glossary Item Box

Sets matrix element value.

Syntax

public void setElem(
   int row,
   int column,
   double value
)

Parameters

row
Row coordinate of the matrix element to set.
column
Column coordinate of the matrix element to set.
value
Double value.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

transpose Method
com.accusoft.imagegear.processing Package > ImGearDoubleMatrix Class : transpose Method

Glossary Item Box

Transpose the matrix.

Syntax

public ImGearDoubleMatrix transpose()

Return Value

ImGearDoubleMatrix with transposed values.

See Also

Reference

ImGearDoubleMatrix Class
ImGearDoubleMatrix Members


%%PageItemTitle%%

ImGearGrayScaleInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearGrayScaleInterpolationOptions Class

Glossary Item Box

Interpolation options class that defines a threshold of ScaleToGray interpolation. Derived from ImGearInterpolationOptions class.

This class defines interpolation options for scale-to-gray interpolation.

ImGearInterpolationOptions

Object Model

ImGearGrayScaleInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearGrayScaleInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearGrayScaleInterpolationOptions

See Also

Reference

ImGearGrayScaleInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearGrayScaleInterpolationOptions Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearGrayScaleInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearGrayScaleInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearGrayScaleInterpolationOptions Constructor | Initializes a new instance of the ImGearGrayScaleInterpolationOptions class.
Top

Public Fields

 | Name | Description
public Field | threshold | ScaleToGray threshold in percents. Integer in the range 0-100.
Top

See Also

Reference

ImGearGrayScaleInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearGrayScaleInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearGrayScaleInterpolationOptions Class : ImGearGrayScaleInterpolationOptions Constructor
thrsh
Interpolation threshold. ImGearGrayScaleInterpolationOptions

Glossary Item Box

Initializes a new instance of the ImGearGrayScaleInterpolationOptions class.

Syntax

public ImGearGrayScaleInterpolationOptions(
   int thrsh
)

Parameters

thrsh
Interpolation threshold. ImGearGrayScaleInterpolationOptions

See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImGearGrayScaleInterpolationOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearGrayScaleInterpolationOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearGrayScaleInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearGrayScaleInterpolationOptions members.

Public Fields

 | Name | Description
public Field | threshold | ScaleToGray threshold in percents. Integer in the range 0-100.
Top

See Also

Reference

ImGearGrayScaleInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearGrayScaleInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearGrayScaleInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearGrayScaleInterpolationOptions members.

See Also

Reference

ImGearGrayScaleInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

threshold Field
com.accusoft.imagegear.processing Package > ImGearGrayScaleInterpolationOptions Class : threshold Field

Glossary Item Box

ScaleToGray threshold in percents.

Integer in the range 0-100.

Syntax

public int threshold

Return Value

Integer in the range 0-100.

See Also

Reference

ImGearGrayScaleInterpolationOptions Class
ImGearGrayScaleInterpolationOptions Members


%%PageItemTitle%%

ImGearHalftoneReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearHalftoneReductionOptions Class

Glossary Item Box

Defines reduction options for halftone reduction.

Halftone reduction reduces an image to black and white in such a way that it is suitable for half-toning. The resulting image will consist of small squares of varying sizes that will give the appearance of varying shades of gray.

Object Model

ImGearHalftoneReductionOptions Class

Syntax

public class ImGearHalftoneReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearHalftoneReductionOptions

See Also

Reference

ImGearHalftoneReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearHalftoneReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearHalftoneReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearHalftoneReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearHalftoneReductionOptions Constructor | Initializes a new instance of the ImGearHalftoneReductionOptions class object.
Top

Public Fields

 | Name | Description
public Field | mode | Mode to use for halftone reduction. Value from ImGearHalftoneReductionModes enumeration This option lets you specify a mode to use for halftone reduction. Possible modes are listed in the ImGearHalftoneReductionModes enumeration. Currently the only available mode is SQUARES. ImGearHalftoneReductionModes
Top

See Also

Reference

ImGearHalftoneReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearHalftoneReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearHalftoneReductionOptions Class : ImGearHalftoneReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearHalftoneReductionOptions class object.

Syntax

public ImGearHalftoneReductionOptions()

See Also

Reference

ImGearHalftoneReductionOptions Class
ImGearHalftoneReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearHalftoneReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearHalftoneReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearHalftoneReductionOptions members.

Public Fields

 | Name | Description
public Field | mode | Mode to use for halftone reduction. Value from ImGearHalftoneReductionModes enumeration This option lets you specify a mode to use for halftone reduction. Possible modes are listed in the ImGearHalftoneReductionModes enumeration. Currently the only available mode is SQUARES. ImGearHalftoneReductionModes
Top

See Also

Reference

ImGearHalftoneReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

mode Field
com.accusoft.imagegear.processing Package > ImGearHalftoneReductionOptions Class : mode Field

Glossary Item Box

Mode to use for halftone reduction.

Value from ImGearHalftoneReductionModes enumeration

This option lets you specify a mode to use for halftone reduction. Possible modes are listed in the ImGearHalftoneReductionModes enumeration. Currently the only available mode is SQUARES.

ImGearHalftoneReductionModes

Syntax

public ImGearHalftoneReductionModes mode

Return Value

Value from ImGearHalftoneReductionModes enumeration

See Also

Reference

ImGearHalftoneReductionOptions Class
ImGearHalftoneReductionOptions Members


%%PageItemTitle%%

ImGearInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearInterpolationOptions Class

Glossary Item Box

Base class for all interpolation options passed to ImGearProcessing.resize and ImGearProcessing.createThumbnail methods.

Use the base class for interpolation modes that do not need additional options. Use derived classes to pass specific options. If a base class is passed for a mode that has a derived class, the default option values are used.

Object Model

ImGearInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearInterpolationOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearAverageInterpolationOptions
com.accusoft.imagegear.processing.ImGearBicubicInterpolationOptions
com.accusoft.imagegear.processing.ImGearBilinearInterpolationOptions
com.accusoft.imagegear.processing.ImGearColorInterpolationOptions
com.accusoft.imagegear.processing.ImGearGrayScaleInterpolationOptions
com.accusoft.imagegear.processing.ImGearNearestNeighborInterpolationOptions
com.accusoft.imagegear.processing.ImGearNoneInterpolationOptions
com.accusoft.imagegear.processing.ImGearPreserveBlackInterpolationOptions
com.accusoft.imagegear.processing.ImGearPreserveWhiteInterpolationOptions

See Also

Reference

ImGearInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearInterpolationOptions.

Protected Constructors

 | Name | Description
protected Constructor | ImGearInterpolationOptions Constructor | Initializes a new instance of the ImGearInterpolationOptions class.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getDefault | Instance of ImGearInterpolationOptions class.
Top

See Also

Reference

ImGearInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearInterpolationOptions Class : ImGearInterpolationOptions Constructor
interpolationType
Interpolation method. ImGearInterpolationOptions ImGearInterpolations

Glossary Item Box

Initializes a new instance of the ImGearInterpolationOptions class.

Syntax

protected ImGearInterpolationOptions(
   ImGearInterpolations interpolationType
)

Parameters

interpolationType
Interpolation method. ImGearInterpolationOptions ImGearInterpolations

See Also

Reference

ImGearInterpolationOptions Class
ImGearInterpolationOptions Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearInterpolationOptions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | getDefault | Instance of ImGearInterpolationOptions class.
Top

See Also

Reference

ImGearInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

getDefault Method
com.accusoft.imagegear.processing Package > ImGearInterpolationOptions Class : getDefault Method
interpolationType
Interpolation method.

Glossary Item Box

Instance of ImGearInterpolationOptions class.

Syntax

public static ImGearInterpolationOptions getDefault(
   ImGearInterpolations interpolationType
)

Parameters

interpolationType
Interpolation method.

Return Value

ImGearInterpolationOptions class object.

Returns instance of options with most commonly used attributes for specified type of interpolation.

ImGearInterpolationOptions ImGearInterpolations

See Also

Reference

ImGearInterpolationOptions Class
ImGearInterpolationOptions Members


%%PageItemTitle%%

ImGearMedianCutReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearMedianCutReductionOptions Class

Glossary Item Box

Defines reduction options for median cut reduction.

Median cut reduction reduces an image to 8bpp by dividing it into a number of equally sized squares. The number of squares is equal to the number of desired output colors. The colors of the pixels in each square will be averaged to produce a resulting color. The resulting image will contain only these colors.

Object Model

ImGearMedianCutReductionOptions Class

Syntax

public class ImGearMedianCutReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearMedianCutReductionOptions

See Also

Reference

ImGearMedianCutReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearMedianCutReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearMedianCutReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearMedianCutReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearMedianCutReductionOptions Constructor | Initializes a new instance of the ImGearMedianCutReductionOptions class object.
Top

Public Fields

 | Name | Description
public Field | fastRemap | Specifies whether to optimize for speed or quality. Set to true to optimize for speed; set to false to optimize for quality.
public Field | maxColors | Maximum number of colors used by the output image. Integer value in range [16...256] The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
Top

See Also

Reference

ImGearMedianCutReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearMedianCutReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearMedianCutReductionOptions Class : ImGearMedianCutReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearMedianCutReductionOptions class object.

Syntax

public ImGearMedianCutReductionOptions()

See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearMedianCutReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearMedianCutReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearMedianCutReductionOptions members.

Public Fields

 | Name | Description
public Field | fastRemap | Specifies whether to optimize for speed or quality. Set to true to optimize for speed; set to false to optimize for quality.
public Field | maxColors | Maximum number of colors used by the output image. Integer value in range [16...256] The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
Top

See Also

Reference

ImGearMedianCutReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

fastRemap Field
com.accusoft.imagegear.processing Package > ImGearMedianCutReductionOptions Class : fastRemap Field

Glossary Item Box

Specifies whether to optimize for speed or quality.

Set to true to optimize for speed; set to false to optimize for quality.

Syntax

public boolean fastRemap

Return Value

Set to true to optimize for speed; set to false to optimize for quality.

See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


%%PageItemTitle%%

maxColors Field
com.accusoft.imagegear.processing Package > ImGearMedianCutReductionOptions Class : maxColors Field

Glossary Item Box

Maximum number of colors used by the output image.

Integer value in range [16...256]

The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.

Syntax

public int maxColors

Return Value

Integer value in range [16...256]

See Also

Reference

ImGearMedianCutReductionOptions Class
ImGearMedianCutReductionOptions Members


%%PageItemTitle%%

ImGearNearestNeighborInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearNearestNeighborInterpolationOptions Class

Glossary Item Box

Represents options for nearest neighbor interpolation.

This class has no public fields and methods and is used to identify nearest neighborhood interpolation by itself in image processing functions.

ImGearInterpolationOptions

Object Model

ImGearNearestNeighborInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearNearestNeighborInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearNearestNeighborInterpolationOptions

See Also

Reference

ImGearNearestNeighborInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearNearestNeighborInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearNearestNeighborInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearNearestNeighborInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearNearestNeighborInterpolationOptions Constructor | Initializes a new instance of the ImGearNearestNeighborInterpolationOptions class. ImGearNearestNeighborInterpolationOptions
Top

See Also

Reference

ImGearNearestNeighborInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearNearestNeighborInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearNearestNeighborInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearNearestNeighborInterpolationOptions members.

See Also

Reference

ImGearNearestNeighborInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearNearestNeighborInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearNearestNeighborInterpolationOptions Class : ImGearNearestNeighborInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearNearestNeighborInterpolationOptions class.

ImGearNearestNeighborInterpolationOptions

Syntax

public ImGearNearestNeighborInterpolationOptions()

See Also

Reference

ImGearNearestNeighborInterpolationOptions Class
ImGearNearestNeighborInterpolationOptions Members


%%PageItemTitle%%

ImGearNoneInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearNoneInterpolationOptions Class

Glossary Item Box

Implements ImGearNoneInterpolationOptions interface for the case when interpolation is not needed.

This class has no public fields and methods and is used to identify interpolation by itself in image processing functions.

ImGearInterpolationOptions

Object Model

ImGearNoneInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearNoneInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearNoneInterpolationOptions

See Also

Reference

ImGearNoneInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearNoneInterpolationOptions Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearNoneInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearNoneInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearNoneInterpolationOptions Constructor | Initializes a new instance of the ImGearNoneInterpolationOptions class. ImGearNoneInterpolationOptions
Top

See Also

Reference

ImGearNoneInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearNoneInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearNoneInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearNoneInterpolationOptions members.

See Also

Reference

ImGearNoneInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearNoneInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearNoneInterpolationOptions Class : ImGearNoneInterpolationOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearNoneInterpolationOptions class.

ImGearNoneInterpolationOptions

Syntax

public ImGearNoneInterpolationOptions()

See Also

Reference

ImGearNoneInterpolationOptions Class
ImGearNoneInterpolationOptions Members


%%PageItemTitle%%

ImGearOctreeReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearOctreeReductionOptions Class

Glossary Item Box

Defines options for octree reduction.

Octree reduction reduces an image to 4bpp or 8bpp by repeatedly subdividing cubic representations of the RGB color space according to image content.

Object Model

ImGearOctreeReductionOptions Class

Syntax

public class ImGearOctreeReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearOctreeReductionOptions

See Also

Reference

ImGearOctreeReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearOctreeReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearOctreeReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearOctreeReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearOctreeReductionOptions Constructor | Initializes a new instance of the ImGearOctreeReductionOptions class object.
Top

Public Fields

Name Description
public Field errorDiffusion Specifies whether to improve accuracy using error diffusion.

Boolean value.

Error diffusion attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image. It increases overall accuracy, but can give the image a more speckled or dithered appearance. It also decreases the effectiveness of most compression algorithms since adjacent pixels are less likely to be the same color. Using octree reduction without error diffusion is sometimes known as ?nearest color? reduction.

public Field fastRemap Specifies whether to optimize for speed or quality.

Set to true to optimize for speed; set to false to optimize for quality.

public Field maxColors Maximum number of colors used by the output image.

Integer value in range [8...256].

Note: If 16 or less colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.

public Field palette Palette to use for output.

A 16-256 color palette or null.

This option lets you specify a palette containing the colors to use for the output image. If no palette is specified, an optimized palette is constructed based on the contents of the image.

com.accusoft.imagegear.core.ImGearRGBQuad

public Field paletteSize Number of colors present in specified palette.

Integer in range [8...256]. If palette field is non-null, this must less than or equal to the number of colors in palette field, and greater than or equal to maxColors field.

If no palette is specified ( palette field is null), this option is ignored and an optimized palette is automatically generated.

Top

See Also

Reference

ImGearOctreeReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearOctreeReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : ImGearOctreeReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearOctreeReductionOptions class object.

Syntax

public ImGearOctreeReductionOptions()

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearOctreeReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearOctreeReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearOctreeReductionOptions members.

Public Fields

Name Description
public Field errorDiffusion Specifies whether to improve accuracy using error diffusion.

Boolean value.

Error diffusion attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image. It increases overall accuracy, but can give the image a more speckled or dithered appearance. It also decreases the effectiveness of most compression algorithms since adjacent pixels are less likely to be the same color. Using octree reduction without error diffusion is sometimes known as ?nearest color? reduction.

public Field fastRemap Specifies whether to optimize for speed or quality.

Set to true to optimize for speed; set to false to optimize for quality.

public Field maxColors Maximum number of colors used by the output image.

Integer value in range [8...256].

Note: If 16 or less colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.

public Field palette Palette to use for output.

A 16-256 color palette or null.

This option lets you specify a palette containing the colors to use for the output image. If no palette is specified, an optimized palette is constructed based on the contents of the image.

com.accusoft.imagegear.core.ImGearRGBQuad

public Field paletteSize Number of colors present in specified palette.

Integer in range [8...256]. If palette field is non-null, this must less than or equal to the number of colors in palette field, and greater than or equal to maxColors field.

If no palette is specified ( palette field is null), this option is ignored and an optimized palette is automatically generated.

Top

See Also

Reference

ImGearOctreeReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

errorDiffusion Field
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : errorDiffusion Field

Glossary Item Box

Specifies whether to improve accuracy using error diffusion.

Boolean value.

Error diffusion attempts to spread out error (the difference in color between input and output pixels) across a two dimensional space in the output image. It increases overall accuracy, but can give the image a more speckled or dithered appearance. It also decreases the effectiveness of most compression algorithms since adjacent pixels are less likely to be the same color. Using octree reduction without error diffusion is sometimes known as ?nearest color? reduction.

Syntax

public boolean errorDiffusion

Return Value

Boolean value.

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

fastRemap Field
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : fastRemap Field

Glossary Item Box

Specifies whether to optimize for speed or quality.

Set to true to optimize for speed; set to false to optimize for quality.

Syntax

public boolean fastRemap

Return Value

Set to true to optimize for speed; set to false to optimize for quality.

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

maxColors Field
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : maxColors Field

Glossary Item Box

Maximum number of colors used by the output image.

Integer value in range [8...256].

Note: If 16 or less colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.

Syntax

public int maxColors

Return Value

Integer value in range [8...256].

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

palette Field
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : palette Field

Glossary Item Box

Palette to use for output.

A 16-256 color palette or null.

This option lets you specify a palette containing the colors to use for the output image. If no palette is specified, an optimized palette is constructed based on the contents of the image.

com.accusoft.imagegear.core.ImGearRGBQuad

Syntax

public ImGearRGBQuad[] palette

Return Value

A 16-256 color palette or null.

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

paletteSize Field
com.accusoft.imagegear.processing Package > ImGearOctreeReductionOptions Class : paletteSize Field

Glossary Item Box

Number of colors present in specified palette.

Integer in range [8...256]. If palette field is non-null, this must less than or equal to the number of colors in palette field, and greater than or equal to maxColors field.

If no palette is specified ( palette field is null), this option is ignored and an optimized palette is automatically generated.

Syntax

public int paletteSize

Return Value

Integer in range [8...256]. If palette field is non-null, this must less than or equal to the number of colors in palette field, and greater than or equal to maxColors field.

See Also

Reference

ImGearOctreeReductionOptions Class
ImGearOctreeReductionOptions Members


%%PageItemTitle%%

ImGearPixelProcessorRedEyeRGB Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearPixelProcessorRedEyeRGB Class

Glossary Item Box

Processes the RGB pixel using red-eye removal algorithm.

Object Model

ImGearPixelProcessorRedEyeRGB ClassImGearPixel Class

Syntax

public class ImGearPixelProcessorRedEyeRGB
    extends Object
    implements IImGearPixelProcessor

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearPixelProcessorRedEyeRGB

See Also

Reference

ImGearPixelProcessorRedEyeRGB Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPixelProcessorRedEyeRGB Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearPixelProcessorRedEyeRGB Class

Glossary Item Box

The following tables list the members exposed by ImGearPixelProcessorRedEyeRGB.

Public Constructors

 | Name | Description
public Constructor | ImGearPixelProcessorRedEyeRGB Constructor | Initializes a new instance of the class.
Top

Public Methods

 | Name | Description
public Method | processPixel | Returns the new pixel after processing.
Top

See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPixelProcessorRedEyeRGB Constructor
com.accusoft.imagegear.processing Package > ImGearPixelProcessorRedEyeRGB Class : ImGearPixelProcessorRedEyeRGB Constructor
dib
DIB the pixel belongs to.
threshold
A value in the range 0.5..2 that specifies a part of the red component in the pixel color.
brightness
Brightness of the pixel after processing. The range is -1...1. com.accusoft.imagegear.core.ImGearDIB

Glossary Item Box

Initializes a new instance of the class.

Syntax

public ImGearPixelProcessorRedEyeRGB(
   ImGearDIB dib,
   double threshold,
   double brightness
)

Parameters

dib
DIB the pixel belongs to.
threshold
A value in the range 0.5..2 that specifies a part of the red component in the pixel color.
brightness
Brightness of the pixel after processing. The range is -1...1. com.accusoft.imagegear.core.ImGearDIB

See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImGearPixelProcessorRedEyeRGB Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPixelProcessorRedEyeRGB Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPixelProcessorRedEyeRGB Class

Glossary Item Box

For a list of all members of this type, see ImGearPixelProcessorRedEyeRGB members.

Public Methods

 | Name | Description
public Method | processPixel | Returns the new pixel after processing.
Top

See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

processPixel Method
com.accusoft.imagegear.processing Package > ImGearPixelProcessorRedEyeRGB Class : processPixel Method
pixel
com.accusoft.imagegear.core.ImGearPixel class object representing pixel to be processed.

Glossary Item Box

Returns the new pixel after processing.

Syntax

public ImGearPixel processPixel(
   ImGearPixel pixel
)

Parameters

pixel
com.accusoft.imagegear.core.ImGearPixel class object representing pixel to be processed.

Return Value

com.accusoft.imagegear.core.ImGearPixel class object. com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

ImGearPixelProcessorRedEyeRGB Class
ImGearPixelProcessorRedEyeRGB Members


%%PageItemTitle%%

ImGearPopularityReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearPopularityReductionOptions Class

Glossary Item Box

Defines options for popularity reduction.

Popularity reduction reduces an image to 8bpp while retaining its most popular, or prevalent, colors. Use the maxColors field option to specify the maximum number of colors wanted in the result.

Object Model

ImGearPopularityReductionOptions Class

Syntax

public class ImGearPopularityReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearPopularityReductionOptions

See Also

Reference

ImGearPopularityReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPopularityReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearPopularityReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearPopularityReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearPopularityReductionOptions Constructor | Initializes a new instance of the ImGearPopularityReductionOptions class object.
Top

Public Fields

 | Name | Description
public Field | maxColors | Maximum number of colors used by the output image. Integer in range [8...256]. The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
Top

See Also

Reference

ImGearPopularityReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPopularityReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearPopularityReductionOptions Class : ImGearPopularityReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearPopularityReductionOptions class object.

Syntax

public ImGearPopularityReductionOptions()

See Also

Reference

ImGearPopularityReductionOptions Class
ImGearPopularityReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPopularityReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPopularityReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPopularityReductionOptions members.

Public Fields

 | Name | Description
public Field | maxColors | Maximum number of colors used by the output image. Integer in range [8...256]. The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.
Top

See Also

Reference

ImGearPopularityReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

maxColors Field
com.accusoft.imagegear.processing Package > ImGearPopularityReductionOptions Class : maxColors Field

Glossary Item Box

Maximum number of colors used by the output image.

Integer in range [8...256].

The default value is 256. Note: If 16 colors are specified, output image will be 4 bpp indexed; otherwise it will be 8 bpp indexed.

Syntax

public int maxColors

Return Value

Integer in range [8...256].

See Also

Reference

ImGearPopularityReductionOptions Class
ImGearPopularityReductionOptions Members


%%PageItemTitle%%

ImGearPreserveBlackInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveBlackInterpolationOptions Class

Glossary Item Box

Represents options for PreserveWhite interpolation.

ImGearInterpolationOptions

Object Model

ImGearPreserveBlackInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearPreserveBlackInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearPreserveBlackInterpolationOptions

See Also

Reference

ImGearPreserveBlackInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPreserveBlackInterpolationOptions Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveBlackInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearPreserveBlackInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearPreserveBlackInterpolationOptions Constructor | Initializes a new instance of the ImGearPreserveBlackInterpolationOptions class.
Top

Public Fields

 | Name | Description
public Field | threshold | Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image. Any integer value. ImGearPreserveBlackInterpolationOptions
Top

See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPreserveBlackInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearPreserveBlackInterpolationOptions Class : ImGearPreserveBlackInterpolationOptions Constructor
thresh
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

Glossary Item Box

Initializes a new instance of the ImGearPreserveBlackInterpolationOptions class.

Syntax

public ImGearPreserveBlackInterpolationOptions(
   int thresh
)

Parameters

thresh
Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImGearPreserveBlackInterpolationOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPreserveBlackInterpolationOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveBlackInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPreserveBlackInterpolationOptions members.

Public Fields

 | Name | Description
public Field | threshold | Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image. Any integer value. ImGearPreserveBlackInterpolationOptions
Top

See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPreserveBlackInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveBlackInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPreserveBlackInterpolationOptions members.

See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

threshold Field
com.accusoft.imagegear.processing Package > ImGearPreserveBlackInterpolationOptions Class : threshold Field

Glossary Item Box

Specifies limit value for the quantity of black pixels that will be transfered to black pixel of interpolated image.

Any integer value. ImGearPreserveBlackInterpolationOptions

Syntax

public int threshold

Return Value

Any integer value.

See Also

Reference

ImGearPreserveBlackInterpolationOptions Class
ImGearPreserveBlackInterpolationOptions Members


%%PageItemTitle%%

ImGearPreserveWhiteInterpolationOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveWhiteInterpolationOptions Class

Glossary Item Box

Represents options for PreserveWhite interpolation.

ImGearInterpolationOptions

Object Model

ImGearPreserveWhiteInterpolationOptions ClassImGearInterpolationOptions Class

Syntax

public class ImGearPreserveWhiteInterpolationOptions
    extends ImGearInterpolationOptions

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearInterpolationOptions
com.accusoft.imagegear.processing.ImGearPreserveWhiteInterpolationOptions

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearPreserveWhiteInterpolationOptions Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveWhiteInterpolationOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearPreserveWhiteInterpolationOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearPreserveWhiteInterpolationOptions Constructor | Initializes a new instance of the ImGearPreserveWhiteInterpolationOptions class.
Top

Public Fields

 | Name | Description
public Field | threshold | Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image. Any integer value. ImGearPreserveWhiteInterpolationOptions
Top

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPreserveWhiteInterpolationOptions Constructor
com.accusoft.imagegear.processing Package > ImGearPreserveWhiteInterpolationOptions Class : ImGearPreserveWhiteInterpolationOptions Constructor
thresh
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

Glossary Item Box

Initializes a new instance of the ImGearPreserveWhiteInterpolationOptions class.

Syntax

public ImGearPreserveWhiteInterpolationOptions(
   int thresh
)

Parameters

thresh
Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImGearPreserveWhiteInterpolationOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearPreserveWhiteInterpolationOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveWhiteInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPreserveWhiteInterpolationOptions members.

Public Fields

 | Name | Description
public Field | threshold | Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image. Any integer value. ImGearPreserveWhiteInterpolationOptions
Top

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearPreserveWhiteInterpolationOptions Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearPreserveWhiteInterpolationOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearPreserveWhiteInterpolationOptions members.

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

threshold Field
com.accusoft.imagegear.processing Package > ImGearPreserveWhiteInterpolationOptions Class : threshold Field

Glossary Item Box

Specifies limit value for the quantity of white pixels that will be transfered to white pixel of interpolated image.

Any integer value. ImGearPreserveWhiteInterpolationOptions

Syntax

public int threshold

Return Value

Any integer value.

See Also

Reference

ImGearPreserveWhiteInterpolationOptions Class
ImGearPreserveWhiteInterpolationOptions Members


%%PageItemTitle%%

ImGearProcessing Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessing Class

Glossary Item Box

Provides image processing methods that can be applied to both Raster and Vector images.

This class does not have a public constructor because all its functionality is implemented through static members.

ImGearProcessingVerifier

Object Model

ImGearProcessing ClassImGearPage ClassImGearProcessingVerifier Class

Syntax

public sealed class ImGearProcessing
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearProcessing

See Also

Reference

ImGearProcessing Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearProcessing Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessing Class

Glossary Item Box

The following tables list the members exposed by ImGearProcessing.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | createThumbnail | Creates a thumbnail image according to the specified dimensions.
static (Shared in Visual Basic) | crop | Crops an image according to the specified offsets and dimensions.
static (Shared in Visual Basic) | flip | Flips an image in vertical or horizontal direction.
static (Shared in Visual Basic) | getVerifier | Gets ImGearProcessingVerifier class object. ImGearProcessingVerifier class object. ImGearProcessingVerifier
static (Shared in Visual Basic) | resize | Resizes an image according to the specified dimensions.
static (Shared in Visual Basic) | resizeCanvas | This method changes the dimensions of the com.accusoft.imagegear.core.ImGearPage class object.
static (Shared in Visual Basic) | rotate | Overloaded. Rotates an image.
Top

See Also

Reference

ImGearProcessing Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearProcessing Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessing Class

Glossary Item Box

For a list of all members of this type, see ImGearProcessing members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | createThumbnail | Creates a thumbnail image according to the specified dimensions.
static (Shared in Visual Basic) | crop | Crops an image according to the specified offsets and dimensions.
static (Shared in Visual Basic) | flip | Flips an image in vertical or horizontal direction.
static (Shared in Visual Basic) | getVerifier | Gets ImGearProcessingVerifier class object. ImGearProcessingVerifier class object. ImGearProcessingVerifier
static (Shared in Visual Basic) | resize | Resizes an image according to the specified dimensions.
static (Shared in Visual Basic) | resizeCanvas | This method changes the dimensions of the com.accusoft.imagegear.core.ImGearPage class object.
static (Shared in Visual Basic) | rotate | Overloaded. Rotates an image.
Top

See Also

Reference

ImGearProcessing Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

createThumbnail Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : createThumbnail Method
page
Source image from which the thumbnail is created.
width
Width of the thumbnail.
height
Height of the thumbnail.
options
Interpolation options.

Glossary Item Box

Creates a thumbnail image according to the specified dimensions.

Syntax

public static ImGearPage createThumbnail(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)

Parameters

page
Source image from which the thumbnail is created.
width
Width of the thumbnail.
height
Height of the thumbnail.
options
Interpolation options.

Return Value

New thumbnail image.

This method processes all channels of the image.

Interpolation options depend on the color space and bit depth of the image. Grayscale, PreserveBlack and PreserveWhite interpolations are applicable only to 1 bit images.

Average and Bilinear interpolations are not applicable to 1 bit images nor to images having a non-gray palette. Also, Bilinear interpolation cannot be applied to the images if one of the dimensions is decreased.

Use ImGearProcessingVerifier.canApplyCreateThumbnail method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

crop Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : crop Method
page
Image to crop.
left
Left border of the new image.
top
Top border of the new image.
width
Width of the new image.
height
Height of the new image.

This method processes all channels of the image. It may shift reference point of image's ROI, if it exists, but does not crop it.

ImGearProcessingVerifier.canApplyCrop method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

Crops an image according to the specified offsets and dimensions.

Syntax

public static void crop(
   ImGearPage page,
   int left,
   int top,
   int width,
   int height
)

Parameters

page
Image to crop.
left
Left border of the new image.
top
Top border of the new image.
width
Width of the new image.
height
Height of the new image.

This method processes all channels of the image. It may shift reference point of image's ROI, if it exists, but does not crop it.

ImGearProcessingVerifier.canApplyCrop method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

flip Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : flip Method
page
Image to flip.
mode
Constant defining flip direction. Possible values are com.accusoft.imagegear.core.ImGearFlipModes.HORIZONTAL and com.accusoft.imagegear.core.ImGearFlipModes.VERTICAL.

This method processes all channels of the image as well as image's ROI, if it exists.

ImGearProcessingVerifier.canApplyFlip method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.ImGearFlipModes

Glossary Item Box

Flips an image in vertical or horizontal direction.

Syntax

public static void flip(
   ImGearPage page,
   ImGearFlipModes mode
)

Parameters

page
Image to flip.
mode
Constant defining flip direction. Possible values are com.accusoft.imagegear.core.ImGearFlipModes.HORIZONTAL and com.accusoft.imagegear.core.ImGearFlipModes.VERTICAL.

This method processes all channels of the image as well as image's ROI, if it exists.

ImGearProcessingVerifier.canApplyFlip method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.ImGearFlipModes

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

getVerifier Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : getVerifier Method

Glossary Item Box

Gets ImGearProcessingVerifier class object.

ImGearProcessingVerifier class object. ImGearProcessingVerifier

Syntax

public static ImGearProcessingVerifier getVerifier()

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

resize Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : resize Method
page
Image to resize.
width
New image width.
height
New image height.
options
Interpolation options.

This method processes all channels of the image as well as the image's ROI, if it exists.

Interpolation options are ignored when resizing vector images.

Applicability of interpolation options to raster images depend on the color space and bit depth of the image. The following table specifies applicability of interpolation options to different types of raster images.

ImGearInterpolations | Bitonal images | Non-bitonal images
NONE | Yes | Yes
AVERAGE | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
BILINEAR | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
NEAREST_NEIGHBOR | Yes | Yes
GRAYSCALE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_WHITE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_BLACK | Only if both new width and height are not greater than original width and height. | No
BICUBIC | No | Yes, except indexed images where palette is not grayscale or inverted grayscale.

ImGearProcessingVerifier.canApplyResize method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

Resizes an image according to the specified dimensions.

Syntax

public static void resize(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)

Parameters

page
Image to resize.
width
New image width.
height
New image height.
options
Interpolation options.

This method processes all channels of the image as well as the image's ROI, if it exists.

Interpolation options are ignored when resizing vector images.

Applicability of interpolation options to raster images depend on the color space and bit depth of the image. The following table specifies applicability of interpolation options to different types of raster images.

ImGearInterpolations | Bitonal images | Non-bitonal images
NONE | Yes | Yes
AVERAGE | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
BILINEAR | Only if both new width and height are not smaller than original width and height. | Yes, except indexed images where palette is not grayscale or inverted grayscale.
NEAREST_NEIGHBOR | Yes | Yes
GRAYSCALE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_WHITE | Only if both new width and height are not greater than original width and height. | No
PRESERVE_BLACK | Only if both new width and height are not greater than original width and height. | No
BICUBIC | No | Yes, except indexed images where palette is not grayscale or inverted grayscale.

ImGearProcessingVerifier.canApplyResize method can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

resizeCanvas Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : resizeCanvas Method
page
Image to resize.
width
New image width.
height
New image height.
offsetX
X offset at which to put left top corner of the image after resize.
offsetY
Y offset at which to put left top corner of the image after resize.
background
Background color to fill the out of picture area; null ( Nothing in VB NET) results in black background.

The image data in the bitmap is not stretched or compressed, but copied to the specified offset in the new image.

Use ImGearProcessingVerifier.canApplyResizeCanvas method to check whether the operation can be performed on the specified image.

com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

This method changes the dimensions of the com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public static void resizeCanvas(
   ImGearPage page,
   int width,
   int height,
   int offsetX,
   int offsetY,
   ImGearPixel background
)

Parameters

page
Image to resize.
width
New image width.
height
New image height.
offsetX
X offset at which to put left top corner of the image after resize.
offsetY
Y offset at which to put left top corner of the image after resize.
background
Background color to fill the out of picture area; null ( Nothing in VB NET) results in black background.

The image data in the bitmap is not stretched or compressed, but copied to the specified offset in the new image.

Use ImGearProcessingVerifier.canApplyResizeCanvas method to check whether the operation can be performed on the specified image.

com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

rotate Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class : rotate Method

Glossary Item Box

Rotates an image.

Overload List

Overload | Description
rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel) | Rotates an image.
rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) | Rotates an image using interpolation.
rotate(ImGearPage,ImGearRotationValues) | Rotates an image on 90, 180, or 270 degrees.

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members


%%PageItemTitle%%

rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearProcessing Class > rotate Method : rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel) Method
page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode. ImGearRotationModes.CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut. ImGearRotationModes.EXPAND changes the image size according to the new picture boundary.
background

Glossary Item Box

Rotates an image.

Syntax

public static void rotate(
   ImGearPage page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel background
)

Parameters

page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode. ImGearRotationModes.CLIP means that the image size is not changed during rotation and the part of picture out of image boundary is cut. ImGearRotationModes.EXPAND changes the image size according to the new picture boundary.
background

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List


%%PageItemTitle%%

rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearProcessing Class > rotate Method : rotate(ImGearPage,double,ImGearRotationModes,ImGearPixel,ImGearInterpolations) Method
page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode (clip or expand).
background
Background color to fill the out of picture area; null ( Nothing in VB NET) results in black background.
interpolation
Interpolation to use for rotation.

This method processes all channels of the image as well as image's ROI, if it exists.

Background should be in the same color space as the Page, including Alpha and Extra channels. Background must have the same channel count and bit depth as a DIB?s color space.

Supported interpolations are BILINEAR and BICUBIC. Interpolation is supported for non-indexed images, and for indexed images with grayscale palette. It is not supported for 1bpp images.

com.accusoft.imagegear.core.ImGearPageT:com.accusoft.imagegear.core.ImGearPixel ImGearInterpolations

Glossary Item Box

Rotates an image using interpolation.

Syntax

public static void rotate(
   ImGearPage page,
   double angle,
   ImGearRotationModes mode,
   ImGearPixel background,
   ImGearInterpolations interpolation
)

Parameters

page
Image to rotate.
angle
Rotation angle in degrees.
mode
Rotation mode (clip or expand).
background
Background color to fill the out of picture area; null ( Nothing in VB NET) results in black background.
interpolation
Interpolation to use for rotation.

This method processes all channels of the image as well as image's ROI, if it exists.

Background should be in the same color space as the Page, including Alpha and Extra channels. Background must have the same channel count and bit depth as a DIB?s color space.

Supported interpolations are BILINEAR and BICUBIC. Interpolation is supported for non-indexed images, and for indexed images with grayscale palette. It is not supported for 1bpp images.

com.accusoft.imagegear.core.ImGearPageT:com.accusoft.imagegear.core.ImGearPixel ImGearInterpolations

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List


%%PageItemTitle%%

rotate(ImGearPage,ImGearRotationValues) Method
com.accusoft.imagegear.processing Package > ImGearProcessing Class > rotate Method : rotate(ImGearPage,ImGearRotationValues) Method
page
Image to rotate.
rotationValue

Glossary Item Box

Rotates an image on 90, 180, or 270 degrees.

Syntax

public static void rotate(
   ImGearPage page,
   ImGearRotationValues rotationValue
)

Parameters

page
Image to rotate.
rotationValue

See Also

Reference

ImGearProcessing Class
ImGearProcessing Members
Overload List


%%PageItemTitle%%

ImGearProcessingVerifier Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessingVerifier Class

Glossary Item Box

Contains static methods that check whether particular ImGearProcessing operations are applicable to the page.

These methods should be used to distinguish a sub-set of pages for which a particular filter is applicable.

ImGearProcessing

Object Model

ImGearProcessingVerifier Class

Syntax

public sealed class ImGearProcessingVerifier
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearProcessingVerifier

See Also

Reference

ImGearProcessingVerifier Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearProcessingVerifier Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessingVerifier Class

Glossary Item Box

The following tables list the members exposed by ImGearProcessingVerifier.

Public Methods

 | Name | Description
public Method | canApplyCreateThumbnail | Returns true if ImGearProcessing.createThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.
public Method | canApplyCrop | Returns true if ImGearProcessing.crop method can be applied to the specified page, false otherwise.
public Method | canApplyFlip | Returns true if ImGearProcessing.flip method can be applied to the specified page, false otherwise.
public Method | canApplyResize | Verifies if ImGearProcessing.resize method can be applied to the Page.
public Method | canApplyResizeCanvas | Returns true if ImGearProcessing.resizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.
public Method | canApplyRotate | Overloaded. Returns true if the rotate method can be applied to the specified Page, false otherwise.
Top

See Also

Reference

ImGearProcessingVerifier Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearProcessingVerifier Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearProcessingVerifier Class

Glossary Item Box

For a list of all members of this type, see ImGearProcessingVerifier members.

Public Methods

 | Name | Description
public Method | canApplyCreateThumbnail | Returns true if ImGearProcessing.createThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.
public Method | canApplyCrop | Returns true if ImGearProcessing.crop method can be applied to the specified page, false otherwise.
public Method | canApplyFlip | Returns true if ImGearProcessing.flip method can be applied to the specified page, false otherwise.
public Method | canApplyResize | Verifies if ImGearProcessing.resize method can be applied to the Page.
public Method | canApplyResizeCanvas | Returns true if ImGearProcessing.resizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.
public Method | canApplyRotate | Overloaded. Returns true if the rotate method can be applied to the specified Page, false otherwise.
Top

See Also

Reference

ImGearProcessingVerifier Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

canApplyCreateThumbnail Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyCreateThumbnail Method
page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Glossary Item Box

Returns true if ImGearProcessing.createThumbnail method can be applied to the specified Page, with the specified dimensions and interpolation, false otherwise.

Syntax

public boolean canApplyCreateThumbnail(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Return Value

Boolean value. com.accusoft.imagegear.processing.ImGearProcessing.createThumbnail(com.accusoft.imagegear.core.ImGearPage,int,int,com.accusoft.imagegear.processing.ImGearInterpolationOptions)T:com.accusoft.imagegear.processing.ImGearInterpolationOptions

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyCrop Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyCrop Method
page
Page to verify.

Glossary Item Box

Returns true if ImGearProcessing.crop method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyCrop(
   ImGearPage page
)

Parameters

page
Page to verify.

Return Value

Boolean value. ImGearProcessing.crop } com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyFlip Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyFlip Method
page
Page to verify.

Glossary Item Box

Returns true if ImGearProcessing.flip method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyFlip(
   ImGearPage page
)

Parameters

page
Page to verify.

Return Value

Boolean value. ImGearProcessing.flip com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyResize Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyResize Method
page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Glossary Item Box

Verifies if ImGearProcessing.resize method can be applied to the Page.

Syntax

public boolean canApplyResize(
   ImGearPage page,
   int width,
   int height,
   ImGearInterpolationOptions options
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.
options
Interpolation options.

Return Value

Boolean value.

Returns true if ImGearProcessing.resize method can be applied to the specified page, with the specified dimensions and interpolation, false otherwise.

com.accusoft.imagegear.processing.ImGearProcessing.resize(com.accusoft.imagegear.core.ImGearPage,int,int,com.accusoft.imagegear.processing.ImGearInterpolationOptions)T:com.accusoft.imagegear.processing.ImGearInterpolationOptions

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyResizeCanvas Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyResizeCanvas Method
page
Page to verify.
width
Page width.
height
Page height.

Glossary Item Box

Returns true if ImGearProcessing.resizeCanvas method can be applied to the specified page, with the specified dimensions, false otherwise.

Syntax

public boolean canApplyResizeCanvas(
   ImGearPage page,
   int width,
   int height
)

Parameters

page
Page to verify.
width
Page width.
height
Page height.

Return Value

Boolean value. ImGearProcessing.resizeCanvas com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyRotate Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class : canApplyRotate Method

Glossary Item Box

Returns true if the rotate method can be applied to the specified Page, false otherwise.

Overload List

Overload | Description
canApplyRotate(ImGearPage,ImGearRotationModes) | Returns true if the rotate method can be applied to the specified Page, false otherwise.
canApplyRotate(ImGearPage,ImGearInterpolations) | Returns true if rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.
canApplyRotate(ImGearPage,ImGearRotationValues) | Returns true if the rotate Method can be applied to the specified page, with the specified rotationValue, false otherwise.

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members


%%PageItemTitle%%

canApplyRotate(ImGearPage,ImGearRotationModes) Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class > canApplyRotate Method : canApplyRotate(ImGearPage,ImGearRotationModes) Method
page
Page to verify.
rotationMode
Rotation mode.

Glossary Item Box

Returns true if the rotate method can be applied to the specified Page, false otherwise.

Syntax

public boolean canApplyRotate(
   ImGearPage page,
   ImGearRotationModes rotationMode
)

Parameters

page
Page to verify.
rotationMode
Rotation mode.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyRotate(ImGearPage,ImGearInterpolations) Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class > canApplyRotate Method : canApplyRotate(ImGearPage,ImGearInterpolations) Method
page
Page to verify.
interpolation
Specified interpolation.

Glossary Item Box

Returns true if rotate Method can be applied to the specified page, with the specified interpolation, false otherwise.

Syntax

public boolean canApplyRotate(
   ImGearPage page,
   ImGearInterpolations interpolation
)

Parameters

page
Page to verify.
interpolation
Specified interpolation.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearPage ImGearInterpolations

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyRotate(ImGearPage,ImGearRotationValues) Method
com.accusoft.imagegear.processing Package > ImGearProcessingVerifier Class > canApplyRotate Method : canApplyRotate(ImGearPage,ImGearRotationValues) Method
page
Page to verify.
rotationValue
Rotation value.

Glossary Item Box

Returns true if the rotate Method can be applied to the specified page, with the specified rotationValue, false otherwise.

Syntax

public boolean canApplyRotate(
   ImGearPage page,
   ImGearRotationValues rotationValue
)

Parameters

page
Page to verify.
rotationValue
Rotation value.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearPage com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

ImGearProcessingVerifier Class
ImGearProcessingVerifier Members
Overload List


%%PageItemTitle%%

ImGearRasterProcessing Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessing Class

Glossary Item Box

Contains IG raster processing methods.

This is the main class for all image raster processing operations.

Object Model

ImGearRasterProcessing ClassImGearChannelStatistics ClassImGearRasterPage ClassImGearRasterPage ClassImGearRasterProcessingVerifier ClassImGearChannelRef Class

Syntax

public sealed class ImGearRasterProcessing
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearRasterProcessing

See Also

Reference

ImGearRasterProcessing Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRasterProcessing Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessing Class

Glossary Item Box

The following tables list the members exposed by ImGearRasterProcessing.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | addTilt | Adds a specified plane to the input image to correct for a tilt in the image luminance.
static (Shared in Visual Basic) | adjustContrast | Overloaded. Adjusts contrast, brightness, and gamma.
static (Shared in Visual Basic) | blend | Overloaded. Blends two images based on percentage.
static (Shared in Visual Basic) | blendWithAlpha | Blends two images with alpha.
static (Shared in Visual Basic) | calculateStatistics | Calculates statistics for all channels of the image, separately for each channel.
static (Shared in Visual Basic) | changeChannelDepths | Overloaded. Changes bit depths of image channels.
static (Shared in Visual Basic) | close | Applies closing effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | combineChannels | Combines image channels according to the specified color space.
static (Shared in Visual Basic) | convertColorSpace | Overloaded. Converts page to new color space. Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,]) com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace
static (Shared in Visual Basic) | convertPixelFormat | Overloaded. Converts a single pixel to color space and channel depths of the specified com.accusoft.imagegear.core.ImGearPage class object.
static (Shared in Visual Basic) | convolve | Provides filtering on the base of 2-dimensional convolution matrix.
static (Shared in Visual Basic) | createChannelCopy | Overloaded. Copies a channel to a new page.
static (Shared in Visual Basic) | decrypt | Decrypts a raster page.
static (Shared in Visual Basic) | deskew | Deskews an image page.
static (Shared in Visual Basic) | despeckle | Removes color noise from a binary (1-bit) image.
static (Shared in Visual Basic) | dilate | Applies dilation effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | encrypt | Encrypts a raster page.
static (Shared in Visual Basic) | enhanceLocal | Enhances an image using the local standard deviation and mean.
static (Shared in Visual Basic) | equalizeContrast | Overloaded. Equalizes image contrast.
static (Shared in Visual Basic) | erode | Applies erosion effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | export | Overloaded. Exports content of raster page to a BufferedImage.
static (Shared in Visual Basic) | filterWithMedian | Overloaded. Removes color noise from the image.
static (Shared in Visual Basic) | filterWithUnsharpMask | Overloaded. Provides UnsharpMask filtering.
static (Shared in Visual Basic) | findSkewAngle | Determines skew angle.
static (Shared in Visual Basic) | findTilt | Computes the least-squares best fit plane for an image.
static (Shared in Visual Basic) | gaussianBlur | Overloaded. Blurs an image using Gaussian transform.
static (Shared in Visual Basic) | geomDespeckle | Reduces speckle noise from an image by using the Crimmins algorithm.
static (Shared in Visual Basic) | getVerifier | Gets ImGearRasterProcessingVerifier class object. ImGearRasterProcessingVerifier class object.
static (Shared in Visual Basic) | imageIsGray | Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.
static (Shared in Visual Basic) | insertChannel | Inserts a channel to the page's DIB and changes page's color space.
static (Shared in Visual Basic) | invertContrast | Overloaded. Inverts image contrast.
static (Shared in Visual Basic) | merge | Overloaded. Merges two images according to the specified merge mode.
static (Shared in Visual Basic) | open | Applies opening effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | reduce | Reduces bit depth of an image using the specified reduction method.
static (Shared in Visual Basic) | removeChannel | Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.
static (Shared in Visual Basic) | removeTilt | This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
static (Shared in Visual Basic) | separateChannels | Creates an array of pages, where each page contains one channel with color space set to grayscale.
static (Shared in Visual Basic) | sharpen | Overloaded. Sharpens an image according to the specified sharpen factor.
static (Shared in Visual Basic) | smooth | Overloaded. Provides smooth filtering.
static (Shared in Visual Basic) | stretchContrast | Overloaded. Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
static (Shared in Visual Basic) | swapChannels | Swaps two channels in page's DIB.
static (Shared in Visual Basic) | tabulateHistogram | Tabulates histograms for all image channels.
static (Shared in Visual Basic) | transformWithLUT | Applies lookup tables to each channel of the image, optionally changing channel depths.
static (Shared in Visual Basic) | updateChannelFrom | Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.
Top

See Also

Reference

ImGearRasterProcessing Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRasterProcessing Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessing Class

Glossary Item Box

For a list of all members of this type, see ImGearRasterProcessing members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | addTilt | Adds a specified plane to the input image to correct for a tilt in the image luminance.
static (Shared in Visual Basic) | adjustContrast | Overloaded. Adjusts contrast, brightness, and gamma.
static (Shared in Visual Basic) | blend | Overloaded. Blends two images based on percentage.
static (Shared in Visual Basic) | blendWithAlpha | Blends two images with alpha.
static (Shared in Visual Basic) | calculateStatistics | Calculates statistics for all channels of the image, separately for each channel.
static (Shared in Visual Basic) | changeChannelDepths | Overloaded. Changes bit depths of image channels.
static (Shared in Visual Basic) | close | Applies closing effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | combineChannels | Combines image channels according to the specified color space.
static (Shared in Visual Basic) | convertColorSpace | Overloaded. Converts page to new color space. Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,]) com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace
static (Shared in Visual Basic) | convertPixelFormat | Overloaded. Converts a single pixel to color space and channel depths of the specified com.accusoft.imagegear.core.ImGearPage class object.
static (Shared in Visual Basic) | convolve | Provides filtering on the base of 2-dimensional convolution matrix.
static (Shared in Visual Basic) | createChannelCopy | Overloaded. Copies a channel to a new page.
static (Shared in Visual Basic) | decrypt | Decrypts a raster page.
static (Shared in Visual Basic) | deskew | Deskews an image page.
static (Shared in Visual Basic) | despeckle | Removes color noise from a binary (1-bit) image.
static (Shared in Visual Basic) | dilate | Applies dilation effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | encrypt | Encrypts a raster page.
static (Shared in Visual Basic) | enhanceLocal | Enhances an image using the local standard deviation and mean.
static (Shared in Visual Basic) | equalizeContrast | Overloaded. Equalizes image contrast.
static (Shared in Visual Basic) | erode | Applies erosion effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | export | Overloaded. Exports content of raster page to a BufferedImage.
static (Shared in Visual Basic) | filterWithMedian | Overloaded. Removes color noise from the image.
static (Shared in Visual Basic) | filterWithUnsharpMask | Overloaded. Provides UnsharpMask filtering.
static (Shared in Visual Basic) | findSkewAngle | Determines skew angle.
static (Shared in Visual Basic) | findTilt | Computes the least-squares best fit plane for an image.
static (Shared in Visual Basic) | gaussianBlur | Overloaded. Blurs an image using Gaussian transform.
static (Shared in Visual Basic) | geomDespeckle | Reduces speckle noise from an image by using the Crimmins algorithm.
static (Shared in Visual Basic) | getVerifier | Gets ImGearRasterProcessingVerifier class object. ImGearRasterProcessingVerifier class object.
static (Shared in Visual Basic) | imageIsGray | Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.
static (Shared in Visual Basic) | insertChannel | Inserts a channel to the page's DIB and changes page's color space.
static (Shared in Visual Basic) | invertContrast | Overloaded. Inverts image contrast.
static (Shared in Visual Basic) | merge | Overloaded. Merges two images according to the specified merge mode.
static (Shared in Visual Basic) | open | Applies opening effect to provided raster page using the specified structure element.
static (Shared in Visual Basic) | reduce | Reduces bit depth of an image using the specified reduction method.
static (Shared in Visual Basic) | removeChannel | Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.
static (Shared in Visual Basic) | removeTilt | This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.
static (Shared in Visual Basic) | separateChannels | Creates an array of pages, where each page contains one channel with color space set to grayscale.
static (Shared in Visual Basic) | sharpen | Overloaded. Sharpens an image according to the specified sharpen factor.
static (Shared in Visual Basic) | smooth | Overloaded. Provides smooth filtering.
static (Shared in Visual Basic) | stretchContrast | Overloaded. Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
static (Shared in Visual Basic) | swapChannels | Swaps two channels in page's DIB.
static (Shared in Visual Basic) | tabulateHistogram | Tabulates histograms for all image channels.
static (Shared in Visual Basic) | transformWithLUT | Applies lookup tables to each channel of the image, optionally changing channel depths.
static (Shared in Visual Basic) | updateChannelFrom | Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.
Top

See Also

Reference

ImGearRasterProcessing Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

addTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : addTilt Method
page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
slopeX
Specifies the slope of the plane in X direction, in units per pixel.
slopeY
Specifies the slope of the plane in Y direction, in units per pixel.

This method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with dSlopeX and dSlopeY as specified in the arguments.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Adds a specified plane to the input image to correct for a tilt in the image luminance.

Syntax

public static void addTilt(
   ImGearRasterPage page,
   double slopeX,
   double slopeY
)

Parameters

page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
slopeX
Specifies the slope of the plane in X direction, in units per pixel.
slopeY
Specifies the slope of the plane in Y direction, in units per pixel.

This method adds a specified plane to the input image to correct for a tilt in the image luminance. The plane has X and Y zero crossing at the center of the input image with dSlopeX and dSlopeY as specified in the arguments.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

adjustContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : adjustContrast Method

Glossary Item Box

Adjusts contrast, brightness, and gamma.

Overload List

Overload | Description
adjustContrast(ImGearRasterPage,double,double,double) | Adjusts contrast, brightness, and gamma.
adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange) | This method adjusts contrast, brightness, and gamma.
adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) | This method adjusts contrast, brightness, and gamma.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

adjustContrast(ImGearRasterPage,double,double,double) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > adjustContrast Method : adjustContrast(ImGearRasterPage,double,double,double) Method
page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.

If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. Processes only color channels. Contrast mode is ImGearContrastModes.AUTO.

Average parameter range:

  • Contrast: -2 ... +2 (negative means contrast inversion. In case of 1 no changes)
  • Brightness: -128...+128
  • Gamma: 0...10

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier.CanApplyAdjustContrast (ImGearPage page) can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Adjusts contrast, brightness, and gamma.

Syntax

public static void adjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.

If the image is indexed and not grayscale, it modifies the image's palette, otherwise it modifies the image's pixels. Processes only color channels. Contrast mode is ImGearContrastModes.AUTO.

Average parameter range:

  • Contrast: -2 ... +2 (negative means contrast inversion. In case of 1 no changes)
  • Brightness: -128...+128
  • Gamma: 0...10

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

Method ImGearRasterProcessing.Verifier.CanApplyAdjustContrast (ImGearPage page) can be called to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > adjustContrast Method : adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange) Method
page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have a palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines the channel range to process.

Processes the specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.processing.ImGearContrastOptionsT:com.accusoft.imagegear.core.ImGearChannelRange com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

This method adjusts contrast, brightness, and gamma.

Syntax

public static void adjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have a palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines the channel range to process.

Processes the specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.processing.ImGearContrastOptionsT:com.accusoft.imagegear.core.ImGearChannelRange com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > adjustContrast Method : adjustContrast(ImGearRasterPage,double,double,double,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines channel range to process.
options
ImGearContrastOptions class object.

Processes the specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use method ImGearRasterProcessingVerifier.canApplyAdjustContrast method to check whether the operation can be performed.

com.accusoft.imagegear.processing.ImGearContrastOptionsT:com.accusoft.imagegear.processing.ImGearContrastModes com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

This method adjusts contrast, brightness, and gamma.

Syntax

public static void adjustContrast(
   ImGearRasterPage page,
   double contrast,
   double brightness,
   double gamma,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions options
)

Parameters

page
Image to adjust contrast.
contrast
Contrast value.
brightness
Brightness value.
gamma
Gamma value.
mode
One of the following values: ImGearContrastModes.PALETTE - image palette is adjusted. If the image does not have palette then an exception will be generated ImGearContrastModes.PIXEL - image pixels are adjusted ImGearContrastModes.AUTO - adjust mode depends on the image color space.
channels
Structure that defines channel range to process.
options
ImGearContrastOptions class object.

Processes the specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use method ImGearRasterProcessingVerifier.canApplyAdjustContrast method to check whether the operation can be performed.

com.accusoft.imagegear.processing.ImGearContrastOptionsT:com.accusoft.imagegear.processing.ImGearContrastModes com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

blend Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : blend Method

Glossary Item Box

Blends two images based on percentage.

Overload List

Overload | Description
blend(ImGearRasterPage,int,int,ImGearRasterPage,double) | Blends two images based on percentage.
blend(ImGearRasterPage,int,int,ImGearRasterPage,double,ImGearChannelRange) | Blends two images based on percentage.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

blend(ImGearRasterPage,int,int,ImGearRasterPage,double) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > blend Method : blend(ImGearRasterPage,int,int,ImGearRasterPage,double) Method
page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Source image to be blend with page.
weight
A value from 0 to 100 defining the % weight of the image to be blended.

This method does not provide any special handling for an Alpha channel. It processes the specified group of channels.

blendWithAlpha com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Blends two images based on percentage.

Syntax

public static void blend(
   ImGearRasterPage page,
   int left,
   int top,
   ImGearRasterPage pageToBlendWith,
   double weight
)

Parameters

page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Source image to be blend with page.
weight
A value from 0 to 100 defining the % weight of the image to be blended.

This method does not provide any special handling for an Alpha channel. It processes the specified group of channels.

blendWithAlpha com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

blend(ImGearRasterPage,int,int,ImGearRasterPage,double,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > blend Method : blend(ImGearRasterPage,int,int,ImGearRasterPage,double,ImGearChannelRange) Method
page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Source image to be blended with page.
weight
A value from 0 to 100 defining the % weight of the image to be blended.
channelsRange
Channel range structure.

This method does not provide any special handling for an Alpha channel. It processes color channels only.

com.accusoft.imagegear.processing.ImGearRasterProcessing.blendWithAlpha(com.accusoft.imagegear.core.ImGearRasterPage,int,int,com.accusoft.imagegear.core.ImGearRasterPage)T:com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Blends two images based on percentage.

Syntax

public static void blend(
   ImGearRasterPage page,
   int left,
   int top,
   ImGearRasterPage pageToBlendWith,
   double weight,
   ImGearChannelRange channelsRange
)

Parameters

page
Page to process.
left
Left margin of blended image.
top
Top margin of blended image.
pageToBlendWith
Source image to be blended with page.
weight
A value from 0 to 100 defining the % weight of the image to be blended.
channelsRange
Channel range structure.

This method does not provide any special handling for an Alpha channel. It processes color channels only.

com.accusoft.imagegear.processing.ImGearRasterProcessing.blendWithAlpha(com.accusoft.imagegear.core.ImGearRasterPage,int,int,com.accusoft.imagegear.core.ImGearRasterPage)T:com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

blendWithAlpha Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : blendWithAlpha Method
page1
Page to blend with .
left
Left margin of blended image.
top
Top margin of blended image.
page2
Second page.

This method blends page2 over page1 and stores result in page1.

Page2 should contain an Alpha channel, otherwise, an error is returned.

If page1 does not contain an Alpha channel, page2 is composited over it using page1 as the background. The resulting image does not contain an Alpha channel. The following formulas are used:

If page2 is not pre-multiplied,

I1 = I2 * A2 + I1 (1-A2)

If page2 is pre-multiplied,

I1 = I2 + I1 (1-A2)

If page2 contains an Alpha channel, page1 and page2 are blended together. The resulting image contains an alpha channel. Blending two images, both of which contain an Alpha channel, can be interpreted as placing one semi-transparent film over another semi-transparent film. The result of applying such combined images to some background is the same as applying one image over background and then applying another image to the result. Using pseudocode,

              BlendWithAlpha(page1, page2)
              BlendWithAlpha(BackPage, page1)

produces the same result as

              BlendWithAlpha(BackPage, page1)
              BlendWithAlpha(BackPage, page2)

The following formulas are used:

if (A1=A2=0)

I1 = 0; A1 = 0;

else

If both page1 and page2 are not pre-multiplied,

I1 = (I2*A2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is not pre-multiplied, and page2 is pre-multiplied:

I1 = (I2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is pre-multiplied, and page2 is not:

I1 = I2*A2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

If both page1 and page2 are pre-multiplied:

I1 = I2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

Alpha values are mapped to a float value between 0.0 and 1.0, where 0.0 means full transparency and 1.0 means full opaquity. Alpha value of 0 corresponds to float value of 0.0 and alpha value of 2^n-1 (where n is alpha channel's bit depth) corresponds to float value of 1.0. Any ChannelDepths are allowed for color channels.

This method does not process Extra Channels.

blend(ImGearRasterPage,int,int,ImGearRasterPage,double) com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Blends two images with alpha.

Syntax

public static void blendWithAlpha(
   ImGearRasterPage page1,
   int left,
   int top,
   ImGearRasterPage page2
)

Parameters

page1
Page to blend with .
left
Left margin of blended image.
top
Top margin of blended image.
page2
Second page.

This method blends page2 over page1 and stores result in page1.

Page2 should contain an Alpha channel, otherwise, an error is returned.

If page1 does not contain an Alpha channel, page2 is composited over it using page1 as the background. The resulting image does not contain an Alpha channel. The following formulas are used:

If page2 is not pre-multiplied,

I1 = I2 * A2 + I1 (1-A2)

If page2 is pre-multiplied,

I1 = I2 + I1 (1-A2)

If page2 contains an Alpha channel, page1 and page2 are blended together. The resulting image contains an alpha channel. Blending two images, both of which contain an Alpha channel, can be interpreted as placing one semi-transparent film over another semi-transparent film. The result of applying such combined images to some background is the same as applying one image over background and then applying another image to the result. Using pseudocode,

              BlendWithAlpha(page1, page2)
              BlendWithAlpha(BackPage, page1)

produces the same result as

              BlendWithAlpha(BackPage, page1)
              BlendWithAlpha(BackPage, page2)

The following formulas are used:

if (A1=A2=0)

I1 = 0; A1 = 0;

else

If both page1 and page2 are not pre-multiplied,

I1 = (I2*A2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is not pre-multiplied, and page2 is pre-multiplied:

I1 = (I2 + I1*A1*(1-A2)) / (A1 + A2 - A1*A2)

A1 = A1 + A2 - A1*A2

Result is not pre-multiplied

If page1 is pre-multiplied, and page2 is not:

I1 = I2*A2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

If both page1 and page2 are pre-multiplied:

I1 = I2 + I1*(1-A2)

A1 = A1 + A2 - A1*A2

Result is pre-multiplied

Alpha values are mapped to a float value between 0.0 and 1.0, where 0.0 means full transparency and 1.0 means full opaquity. Alpha value of 0 corresponds to float value of 0.0 and alpha value of 2^n-1 (where n is alpha channel's bit depth) corresponds to float value of 1.0. Any ChannelDepths are allowed for color channels.

This method does not process Extra Channels.

blend(ImGearRasterPage,int,int,ImGearRasterPage,double) com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

calculateStatistics Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : calculateStatistics Method
page
Raster page object process.

Glossary Item Box

Calculates statistics for all channels of the image, separately for each channel.

Syntax

public static ImGearChannelStatistics[] calculateStatistics(
   ImGearRasterPage page
)

Parameters

page
Raster page object process.

Return Value

ImGearChannelStatistics structure.

This method takes image's Region of Interest (ROI) into account.

com.accusoft.imagegear.core.ImGearROIT:com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

changeChannelDepths Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : changeChannelDepths Method

Glossary Item Box

Changes bit depths of image channels.

Overload List

Overload | Description
changeChannelDepths(ImGearRasterPage,int[]) | Changes bit depths of image channels.
changeChannelDepths(ImGearRasterPage,int[],boolean) | Changes bit depth of image channels.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

changeChannelDepths(ImGearRasterPage,int[]) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > changeChannelDepths Method : changeChannelDepths(ImGearRasterPage,int[]) Method
page
Page to process.
newChannelDepths
Array containing new channels depths. com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Changes bit depths of image channels.

Syntax

public static void changeChannelDepths(
   ImGearRasterPage page,
   int[] newChannelDepths
)

Parameters

page
Page to process.
newChannelDepths
Array containing new channels depths. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

changeChannelDepths(ImGearRasterPage,int[],boolean) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > changeChannelDepths Method : changeChannelDepths(ImGearRasterPage,int[],boolean) Method
page
Page to process.
newChannelDepths
Array containing new channels depths.
doNotScalePixels
Flags indicating whether to scale pixel values according to the new channel depth.

This method does not change an image's color space, and can be applied to all colorspaces except indexed.

If dontScalePixels is false (default), pixel values are scaled according to new channel depth. Unused gaps should be filled with 0 when channel is reduced.

If dontScalePixels is true, channel depth is changed, but pixel values are not scaled. If the channel depth is increased, the pixel data is not changed. If the channel depth is decreased, the pixel value is not changed in the case when it can be accommodated within the new depth. Otherwise, it is set to the maximum value allowed by the new depth (0x0...01...1).

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Changes bit depth of image channels.

Syntax

public static void changeChannelDepths(
   ImGearRasterPage page,
   int[] newChannelDepths,
   boolean doNotScalePixels
)

Parameters

page
Page to process.
newChannelDepths
Array containing new channels depths.
doNotScalePixels
Flags indicating whether to scale pixel values according to the new channel depth.

This method does not change an image's color space, and can be applied to all colorspaces except indexed.

If dontScalePixels is false (default), pixel values are scaled according to new channel depth. Unused gaps should be filled with 0 when channel is reduced.

If dontScalePixels is true, channel depth is changed, but pixel values are not scaled. If the channel depth is increased, the pixel data is not changed. If the channel depth is decreased, the pixel value is not changed in the case when it can be accommodated within the new depth. Otherwise, it is set to the maximum value allowed by the new depth (0x0...01...1).

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

close Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : close Method
page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Applies closing effect to provided raster page using the specified structure element.

Syntax

public static void close(
   ImGearRasterPage page,
   int[][] matrix
)

Parameters

page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

combineChannels Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : combineChannels Method
space
Color space of the resulting multichannel page.
channels
Array of channels reference to combine to multichannel page.

Glossary Item Box

Combines image channels according to the specified color space.

Syntax

public static ImGearRasterPage combineChannels(
   ImGearColorSpace space,
   ImGearChannelRef[] channels
)

Parameters

space
Color space of the resulting multichannel page.
channels
Array of channels reference to combine to multichannel page.

Return Value

com.accusoft.imagegear.core.ImGearRasterPage class.

This method puts together image channels according to the destination color space specified by the space parameter. This function does not do any color space or pixel conversions, it merely merges pixel data from different channels together. The number of channel pages should be compatible with the destination color space. Each Page in ChannelPages array must have exactly one channel. All pages must have the same BitsPerChannel and dimensions.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearChannelRef

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

convertColorSpace Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : convertColorSpace Method

Glossary Item Box

Converts page to new color space.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,])

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

Overload List

Overload Description
convertColorSpace(ImGearRasterPage,ImGearColorSpace) Converts page to new color space.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,])

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean) Converts a page to new color space.

This method Converts page to the newColorSpace. This method works in two modes:

If dontScalePixels is false (default), the image's pixels are recalculated.

If the new color space differs from the old color space only by an alpha channel (add, remove, set to pre-multiplied/non-pre-multiplied), ChannelDepths of color channels are preserved. For example, 5-6-5-8 RGBA will be converted to 5-6-5 RGB. Otherwise, ChannelDepths of color channels are set to maximum of original channel depths. For example, 3-5-4 RGB will be converted to 5-5-5-5 CMYK.

Any conversions are supported, except for conversion into Indexed color space.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels and newColorSpace contains extra channels, the method does not change them.

If dontScalePixels is true, the page's color space property is changed, but the pixels are not modified. The number of channels of newColorSpace should be the same as that of the original image. When converting from Indexed to Grayscale, the palette is removed. When converting from Grayscale to Indexed, a default palette is created. Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean)

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) Converts a page to new color space.

If conversion removes the alpha channel from the image, the image is composited over a solid background specified by BackColor. Background should be in the same color space as the original image, but without the Alpha channel. For example, if the original image is in RGBA color space and newColorSpace is CMYK, background should have an RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,])

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean,ImGearPixel) Converts a page to new color space.

If conversion removes the alpha channel from an image, the image is composited over a solid background specified by BackColor. BackColor should be in the same color space as the original image, but without the Alpha channel. For example, if original image is in RGBA color space and newColorSpace is CMYK, BackColor should have RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

  • If Page is not pre-multiplied: I = I * A + B (1-A)
  • If Page is pre-multiplied: I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearPixel

convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,]) Converts an image's color space using the specified matrix.

Converts an image to a new color space using a conversion matrix. Destination pixels are calculated as Dst = M * Src, where M is conversion matrix. Number of channels after conversion will be equal to first of the conversionMatrix. Second dimension of conversionMatrix should be equal to number of channels in the source page.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearWhiteBalance

convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) Converts an image's color space using the specified color profiles and rendering intent.

The image's pixel data is modified to conform to the new color space. This method does not concern itself with any of the settings of com.accusoft.imagegear.core.ImGearColorProfileManager class. Instead, it allows immediate and explicit specification of color profiles to use for the conversion.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearColorProfile com.accusoft.imagegear.core.ImGearRenderingIntents

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace) Method
page
Image to convert color space.
newColorSpace
New color space.

Glossary Item Box

Converts page to new color space.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,])

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace
)

Parameters

page
Image to convert color space.
newColorSpace
New color space.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean) Method
page
Image to convert.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.

Glossary Item Box

Converts a page to new color space.

This method Converts page to the newColorSpace. This method works in two modes:

If dontScalePixels is false (default), the image's pixels are recalculated.

If the new color space differs from the old color space only by an alpha channel (add, remove, set to pre-multiplied/non-pre-multiplied), ChannelDepths of color channels are preserved. For example, 5-6-5-8 RGBA will be converted to 5-6-5 RGB. Otherwise, ChannelDepths of color channels are set to maximum of original channel depths. For example, 3-5-4 RGB will be converted to 5-5-5-5 CMYK.

Any conversions are supported, except for conversion into Indexed color space.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels and newColorSpace contains extra channels, the method does not change them.

If dontScalePixels is true, the page's color space property is changed, but the pixels are not modified. The number of channels of newColorSpace should be the same as that of the original image. When converting from Indexed to Grayscale, the palette is removed. When converting from Grayscale to Indexed, a default palette is created. Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean)

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   boolean doNotScalePixels
)

Parameters

page
Image to convert.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearPixel) Method
page
Image to change color space.
newColorSpace
New color space.
backgroundColor
Background to composite the image over when removing alpha channel.

Glossary Item Box

Converts a page to new color space.

If conversion removes the alpha channel from the image, the image is composited over a solid background specified by BackColor. Background should be in the same color space as the original image, but without the Alpha channel. For example, if the original image is in RGBA color space and newColorSpace is CMYK, background should have an RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

If Page is not pre-multiplied:

I = I * A + B (1-A)

If Page is pre-multiplied:

I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255. If you need to convert an image to Grayscale using equal weights for Red, Green and Blue, or any other weights, use convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,])

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   ImGearPixel backgroundColor
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
backgroundColor
Background to composite the image over when removing alpha channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean,ImGearPixel) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace,boolean,ImGearPixel) Method
page
Image to change color space.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.
backgroundColor
Background to composite the image over when removing alpha channel.

Glossary Item Box

Converts a page to new color space.

If conversion removes the alpha channel from an image, the image is composited over a solid background specified by BackColor. BackColor should be in the same color space as the original image, but without the Alpha channel. For example, if original image is in RGBA color space and newColorSpace is CMYK, BackColor should have RGB color space. The method will first transform the image into RGB and then to CMYK.

The following formula is used to burn alpha (i.e., to convert from RGBA/P to RGB):

  • If Page is not pre-multiplied: I = I * A + B (1-A)
  • If Page is pre-multiplied: I = I + B (1-A)

If the image contains extra channels, and newColorSpace contains extra channels, the method does not change them.

Note: Conversion to Grayscale colorspace takes into account the human eye's sensitivity to different parts of the light spectrum. ImageGear uses the following formula when converting from RGB to Grayscale: Gray = Gray = Red * 77 / 255 + Green * 151 / 255 + Blue * 28 / 255.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearPixel

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   boolean doNotScalePixels,
   ImGearPixel backgroundColor
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
doNotScalePixels
Flag indicating whether to change pixel values according to the new color space.
backgroundColor
Background to composite the image over when removing alpha channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,]) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace,double[,]) Method
page
Image to change color space.
newColorSpace
New color space.
conversionMatrix
Conversion matrix.

Glossary Item Box

Converts an image's color space using the specified matrix.

Converts an image to a new color space using a conversion matrix. Destination pixels are calculated as Dst = M * Src, where M is conversion matrix. Number of channels after conversion will be equal to first of the conversionMatrix. Second dimension of conversionMatrix should be equal to number of channels in the source page.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearWhiteBalance

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   double[][] conversionMatrix
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
conversionMatrix
Conversion matrix.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertColorSpace Method : convertColorSpace(ImGearRasterPage,ImGearColorSpace,ImGearColorProfile,ImGearColorProfile,ImGearRenderingIntents) Method
page
Image to change color space.
newColorSpace
New color space.
sourceProfile
Initial color space profile.
destinationProfile
The new color space profile.
renderingIntent
Rendering intent.

Glossary Item Box

Converts an image's color space using the specified color profiles and rendering intent.

The image's pixel data is modified to conform to the new color space. This method does not concern itself with any of the settings of com.accusoft.imagegear.core.ImGearColorProfileManager class. Instead, it allows immediate and explicit specification of color profiles to use for the conversion.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearColorProfile com.accusoft.imagegear.core.ImGearRenderingIntents

Syntax

public static void convertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace newColorSpace,
   ImGearColorProfile sourceProfile,
   ImGearColorProfile destinationProfile,
   ImGearRenderingIntents renderingIntent
)

Parameters

page
Image to change color space.
newColorSpace
New color space.
sourceProfile
Initial color space profile.
destinationProfile
The new color space profile.
renderingIntent
Rendering intent.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertPixelFormat Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : convertPixelFormat Method

Glossary Item Box

Converts a single pixel to color space and channel depths of the specified com.accusoft.imagegear.core.ImGearPage class object.

Overload List

Overload | Description
convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearPage) | Converts a single pixel to color space and channel depths of the specified com.accusoft.imagegear.core.ImGearPage class object.
convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearColorSpace,int[],ImGearRGBQuad[]) | Converts a single pixel to new color space and channel depths.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearPage) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertPixelFormat Method : convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearPage) Method
pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the channel depths array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
pageToConvertFormatTo
Page whose colorspace, channel depths, and palette will be used for destination format when converting the pixel.

Note: Using this method in a cycle for large array of pixels could be inefficient. Consider creating a temporary com.accusoft.imagegear.core.ImGearPage class object and converting its colorspace and channel depths in this case.

Glossary Item Box

Converts a single pixel to color space and channel depths of the specified com.accusoft.imagegear.core.ImGearPage class object.

Syntax

public static void convertPixelFormat(
   ImGearPixel pixel,
   ImGearColorSpace sourceColorSpace,
   int[] sourceChannelDepths,
   ImGearRGBQuad[] sourcePalette,
   ImGearPage pageToConvertFormatTo
)

Parameters

pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the channel depths array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
pageToConvertFormatTo
Page whose colorspace, channel depths, and palette will be used for destination format when converting the pixel.

Note: Using this method in a cycle for large array of pixels could be inefficient. Consider creating a temporary com.accusoft.imagegear.core.ImGearPage class object and converting its colorspace and channel depths in this case.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearColorSpace,int[],ImGearRGBQuad[]) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > convertPixelFormat Method : convertPixelFormat(ImGearPixel,ImGearColorSpace,int[],ImGearRGBQuad[],ImGearColorSpace,int[],ImGearRGBQuad[]) Method
pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
destinationColorSpace
Colorspace to convert the pixel to.
destinationChannelDepths
New channel depths for the pixel. Length of the array should correspond to the dstColorSpace parameter.
destinationPalette
Destination palette for the pixel, if destination colorspace is Indexed, or null otherwise.

Note: Using this function in a cycle for a large array of pixels could be inefficient. Consider creating a temporary com.accusoft.imagegear.core.ImGearPage class and converting its colorspace and channel depths in this case.

Glossary Item Box

Converts a single pixel to new color space and channel depths.

Syntax

public static void convertPixelFormat(
   ImGearPixel pixel,
   ImGearColorSpace sourceColorSpace,
   int[] sourceChannelDepths,
   ImGearRGBQuad[] sourcePalette,
   ImGearColorSpace destinationColorSpace,
   int[] destinationChannelDepths,
   ImGearRGBQuad[] destinationPalette
)

Parameters

pixel
Pixel to convert to the new format.
sourceColorSpace
Source colorspace of the pixel.
sourceChannelDepths
Source channel depths of the pixel. Length of the array should correspond to the srcColorSpace parameter.
sourcePalette
Source palette used by the pixel, if its colorspace is Indexed, or null otherwise.
destinationColorSpace
Colorspace to convert the pixel to.
destinationChannelDepths
New channel depths for the pixel. Length of the array should correspond to the dstColorSpace parameter.
destinationPalette
Destination palette for the pixel, if destination colorspace is Indexed, or null otherwise.

Note: Using this function in a cycle for a large array of pixels could be inefficient. Consider creating a temporary com.accusoft.imagegear.core.ImGearPage class and converting its colorspace and channel depths in this case.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

convolve Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : convolve Method
page
Image to convolve.
matrix
Two-dimensional convolution matrix.
normalizer
Normalizer (i.e., denominator for every color component value).
resultMode
Mode that defines how the resulting color component value interacts with the source:
  • ImGearConvolutionResults.RAW - the new color component replaces the old one. If the new value is negative then 0 is applied.
  • ImGearConvolutionResults.ABS the new color component replaces the old one. If the new color component is negative then its absolute value is applied.
  • ImGearConvolutionResults.SIGNED - the new color component replaces the old one. If the new color component is negative then it is added to the maximum value of the component range.
  • ImGearConvolutionResults.CENTERED - the new color component is added to the component range center and replaces the old one.
addResultToOriginalPixels
If this flag is true then the calculated values are added to the original ones.
channels
Range of the channels to convolve.

The method processes specified range of channels. It does not provide any special handling for Alpha channel.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.processing.ImGearConvolutionResultsT:com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Provides filtering on the base of 2-dimensional convolution matrix.

Syntax

public static void convolve(
   ImGearRasterPage page,
   int[][] matrix,
   double normalizer,
   ImGearConvolutionResults resultMode,
   boolean addResultToOriginalPixels,
   ImGearChannelRange channels
)

Parameters

page
Image to convolve.
matrix
Two-dimensional convolution matrix.
normalizer
Normalizer (i.e., denominator for every color component value).
resultMode
Mode that defines how the resulting color component value interacts with the source:
  • ImGearConvolutionResults.RAW - the new color component replaces the old one. If the new value is negative then 0 is applied.
  • ImGearConvolutionResults.ABS the new color component replaces the old one. If the new color component is negative then its absolute value is applied.
  • ImGearConvolutionResults.SIGNED - the new color component replaces the old one. If the new color component is negative then it is added to the maximum value of the component range.
  • ImGearConvolutionResults.CENTERED - the new color component is added to the component range center and replaces the old one.
addResultToOriginalPixels
If this flag is true then the calculated values are added to the original ones.
channels
Range of the channels to convolve.

The method processes specified range of channels. It does not provide any special handling for Alpha channel.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.processing.ImGearConvolutionResultsT:com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

createChannelCopy Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : createChannelCopy Method

Glossary Item Box

Copies a channel to a new page.

Overload List

Overload | Description
createChannelCopy(ImGearRasterPage,int) | Copies a channel to a new page.
createChannelCopy(ImGearChannelRef) | Returns a copy of a page's image channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

createChannelCopy(ImGearRasterPage,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > createChannelCopy Method : createChannelCopy(ImGearRasterPage,int) Method
page
Page from which the channel is obtained.
channelNumber
Channel number.

Glossary Item Box

Copies a channel to a new page.

Syntax

public static ImGearRasterPage createChannelCopy(
   ImGearRasterPage page,
   int channelNumber
)

Parameters

page
Page from which the channel is obtained.
channelNumber
Channel number.

Return Value

com.accusoft.imagegear.core.ImGearRasterPage class containing a copy of the channel.

ChannelNumber can be within the [ 0..getChannelCount-1] range.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

createChannelCopy(ImGearChannelRef) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > createChannelCopy Method : createChannelCopy(ImGearChannelRef) Method
channel
Channel to copy.

Glossary Item Box

Returns a copy of a page's image channel.

Syntax

public static ImGearChannelRef createChannelCopy(
   ImGearChannelRef channel
)

Parameters

channel
Channel to copy.

Return Value

The copy of ImGearChannelRef structure.

Content of returned ImGearChannelRef instance represents a standalone instance of com.accusoft.imagegear.core.ImGearRasterPage class with grayscaled color space.

ImGearChannelRef com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

decrypt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : decrypt Method
page
Page to decrypt.
password
Decryption password. encrypt com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Decrypts a raster page.

Syntax

public static void decrypt(
   ImGearRasterPage page,
   java.lang.String password
)

Parameters

page
Page to decrypt.
password
Decryption password. encrypt com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

deskew Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : deskew Method
page
Image to deskew.
angleThresh
Deskew angle.
mode
Deskew mode.
backgroundColor
Background color. com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearPixel

Glossary Item Box

Deskews an image page.

Syntax

public static void deskew(
   ImGearRasterPage page,
   double angleThresh,
   ImGearRotationModes mode,
   ImGearPixel backgroundColor
)

Parameters

page
Image to deskew.
angleThresh
Deskew angle.
mode
Deskew mode.
backgroundColor
Background color. com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

despeckle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : despeckle Method
page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.

Despeckle is used to help reduce the amount of noise in the image. Single pixels and pixel spurs on letters and graphics are removed while leaving the solid areas alone. It is typically used on 1-bit document images.

The despeckle operation performs a median filter on the image. For each pixel in the original image, a single pixel is produced in the output image. The output pixel is the median of the pixel values in the neighborhood area defined by neighborhoodWidth and neighborhoodHeight parameters.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Removes color noise from a binary (1-bit) image.

Syntax

public static void despeckle(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.

Despeckle is used to help reduce the amount of noise in the image. Single pixels and pixel spurs on letters and graphics are removed while leaving the solid areas alone. It is typically used on 1-bit document images.

The despeckle operation performs a median filter on the image. For each pixel in the original image, a single pixel is produced in the output image. The output pixel is the median of the pixel values in the neighborhood area defined by neighborhoodWidth and neighborhoodHeight parameters.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

dilate Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : dilate Method
page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearColorSpaceIDs com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Applies dilation effect to provided raster page using the specified structure element.

Syntax

public static void dilate(
   ImGearRasterPage page,
   int[][] matrix
)

Parameters

page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearColorSpaceIDs com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

encrypt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : encrypt Method
page
Page to encrypt.
password
Encryption password. com.accusoft.imagegear.core.ImGearRasterPage decrypt

Glossary Item Box

Encrypts a raster page.

Syntax

public static void encrypt(
   ImGearRasterPage page,
   java.lang.String password
)

Parameters

page
Page to encrypt.
password
Encryption password. com.accusoft.imagegear.core.ImGearRasterPage decrypt

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

enhanceLocal Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : enhanceLocal Method
page
An com.accusoft.imagegear.core.ImGearRasterPage class object to enhance.
windowWidth
Width of the local window.
windowHeight
Height of the local window.
scaleFactor
Scaling factor.
minStandardDeviation
Minimum allowed standard deviation.

This method transforms the input image f(x, y) to a new image g(x, y) based on the following formula:

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8bit grayscale images with one channel.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Enhances an image using the local standard deviation and mean.

Syntax

public static void enhanceLocal(
   ImGearRasterPage page,
   int windowWidth,
   int windowHeight,
   double scaleFactor,
   double minStandardDeviation
)

Parameters

page
An com.accusoft.imagegear.core.ImGearRasterPage class object to enhance.
windowWidth
Width of the local window.
windowHeight
Height of the local window.
scaleFactor
Scaling factor.
minStandardDeviation
Minimum allowed standard deviation.

This method transforms the input image f(x, y) to a new image g(x, y) based on the following formula:

g(x, y) = A(x, y) * [f(x, y) - m(x, y)] + m(x, y)

where A(x, y) = k * M / sigma(x, y), with k being a scaling factor within the range [0, 1], m(x, y) and sigma(x, y) being the local mean and local standard deviation, and M being the global mean of the input image.

To avoid the problem of spikes caused by too small local standard deviation, a check against the minimum allowed standard deviation is performed. If the local standard deviation is too small, the minimum allowed instead will be used in the calculation.

Can be applied only to 8bit grayscale images with one channel.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

equalizeContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : equalizeContrast Method

Glossary Item Box

Equalizes image contrast.

Overload List

Overload | Description
equalizeContrast(ImGearRasterPage) | Equalizes image contrast.
equalizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Equalizes image contrast.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

equalizeContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > equalizeContrast Method : equalizeContrast(ImGearRasterPage) Method
page

Glossary Item Box

Equalizes image contrast.

Syntax

public static void equalizeContrast(
   ImGearRasterPage page
)

Parameters

page

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

equalizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > equalizeContrast Method : equalizeContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
page
Page to equalize.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to apply EqualizeContrast.

If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.

It can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyEqualizeContrast method to check whether the operation can be performed.

Glossary Item Box

Equalizes image contrast.

Syntax

public static void equalizeContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Page to equalize.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to apply EqualizeContrast.

If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.

It can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyEqualizeContrast method to check whether the operation can be performed.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

erode Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : erode Method
page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearColorSpaceIDs com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Applies erosion effect to provided raster page using the specified structure element.

Syntax

public static void erode(
   ImGearRasterPage page,
   int[][] matrix
)

Parameters

page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearColorSpaceIDs com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

export Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : export Method

Glossary Item Box

Exports content of raster page to a BufferedImage.

Overload List

Overload | Description
export(ImGearRasterPage,int,int) | Exports content of raster page to a BufferedImage.
export(ImGearRasterPage,ImGearRGBQuad,int,int) | Exports content of raster page to a BufferedImage.
export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,int,int) | Exports content of raster page to a BufferedImage.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

export(ImGearRasterPage,int,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > export Method : export(ImGearRasterPage,int,int) Method
page
Raster page to be exported.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Glossary Item Box

Exports content of raster page to a BufferedImage.

Syntax

public static java.awt.image.BufferedImage export(
   ImGearRasterPage page,
   int ppmX,
   int ppmY
)

Parameters

page
Raster page to be exported.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

An instance of BufferedImage class.

Since BufferedImage stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

export(ImGearRasterPage,ImGearRGBQuad,int,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > export Method : export(ImGearRasterPage,ImGearRGBQuad,int,int) Method
page
Page to be exported.
backgroundColor
Background pixel to blend exporting page with. It's used only if given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Glossary Item Box

Exports content of raster page to a BufferedImage.

Syntax

public static java.awt.image.BufferedImage export(
   ImGearRasterPage page,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)

Parameters

page
Page to be exported.
backgroundColor
Background pixel to blend exporting page with. It's used only if given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

An instance of BufferedImage class.

Exports an image of the given page to a BufferedImage. If the incoming page contains an alpha or a premultiplied alpha channel, background pixel is used to blend the image with.

Since BufferedImage stores pixels in RGB or Indexed format only, color space conversion is used to transfer image data.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,int,int) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > export Method : export(ImGearRasterPage,ImGearRectangle,ImGearRectangle,ImGearRectangle,ImGearInterpolationOptions,ImGearRGBQuad,int,int) Method
page
Page to be exported.
imageRect
Part of image to export.
deviceRect
Output area onto which exported image part will be scaled.
clipRect
Interested part of device rectangle.
interpolationOptions
Interpolation method used to resize from image rectangle to device.
backgroundColor
Background pixel to blend exporting page with. It's used only if the given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Glossary Item Box

Exports content of raster page to a BufferedImage.

Syntax

public static java.awt.image.BufferedImage export(
   ImGearRasterPage page,
   ImGearRectangle imageRect,
   ImGearRectangle deviceRect,
   ImGearRectangle clipRect,
   ImGearInterpolationOptions interpolationOptions,
   ImGearRGBQuad backgroundColor,
   int ppmX,
   int ppmY
)

Parameters

page
Page to be exported.
imageRect
Part of image to export.
deviceRect
Output area onto which exported image part will be scaled.
clipRect
Interested part of device rectangle.
interpolationOptions
Interpolation method used to resize from image rectangle to device.
backgroundColor
Background pixel to blend exporting page with. It's used only if the given page contains alpha or premultiplied alpha channel.
ppmX
Specifies horizontal resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.
ppmY
Specifies vertical resolution of resulting image object. Measurement unit is PPM, i.e., pixels per meter.

Return Value

Instance of BufferedImage class.

Exports an image of the page to a BufferedImage with the ability to specify the rectangular part of the image being exported and the interpolation method that should be used to resize the specified image part to device rectangle.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearInterpolationOptions com.accusoft.imagegear.core.ImGearRGBQuad

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

filterWithMedian Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : filterWithMedian Method

Glossary Item Box

Removes color noise from the image.

Overload List

Overload | Description
filterWithMedian(ImGearRasterPage,int,int) | Removes color noise from the image.
filterWithMedian(ImGearRasterPage,int,int,ImGearChannelRange) | Removes color noise from the image.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

filterWithMedian(ImGearRasterPage,int,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > filterWithMedian Method : filterWithMedian(ImGearRasterPage,int,int) Method
page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.

This method looks for an average color value inside the square area near the pixel and replaces the pixel with this value. Processes color channels only.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Removes color noise from the image.

Syntax

public static void filterWithMedian(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.

This method looks for an average color value inside the square area near the pixel and replaces the pixel with this value. Processes color channels only.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

filterWithMedian(ImGearRasterPage,int,int,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > filterWithMedian Method : filterWithMedian(ImGearRasterPage,int,int,ImGearChannelRange) Method
page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.
channels
Channel range.

This method looks for an average color value inside the square area near the pixel and replaces the pixels with this value. Processes a specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Removes color noise from the image.

Syntax

public static void filterWithMedian(
   ImGearRasterPage page,
   int neighborhoodWidth,
   int neighborhoodHeight,
   ImGearChannelRange channels
)

Parameters

page
Image to filter.
neighborhoodWidth
Width of the square area.
neighborhoodHeight
Height of the square area.
channels
Channel range.

This method looks for an average color value inside the square area near the pixel and replaces the pixels with this value. Processes a specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

filterWithUnsharpMask Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : filterWithUnsharpMask Method

Glossary Item Box

Provides UnsharpMask filtering.

Overload List

Overload | Description
filterWithUnsharpMask(ImGearRasterPage,double,int,int) | Provides UnsharpMask filtering.
filterWithUnsharpMask(ImGearRasterPage,double,int,int,ImGearChannelRange) | Provides UnsharpMask filtering.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

filterWithUnsharpMask(ImGearRasterPage,double,int,int) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > filterWithUnsharpMask Method : filterWithUnsharpMask(ImGearRasterPage,double,int,int) Method
page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.

This method processes color channels only.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Provides UnsharpMask filtering.

Syntax

public static void filterWithUnsharpMask(
   ImGearRasterPage page,
   double radius,
   int amount,
   int threshold
)

Parameters

page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.

This method processes color channels only.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

filterWithUnsharpMask(ImGearRasterPage,double,int,int,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > filterWithUnsharpMask Method : filterWithUnsharpMask(ImGearRasterPage,double,int,int,ImGearChannelRange) Method
page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.
channels
Channel range.

This method processes a specified range of channels.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Provides UnsharpMask filtering.

Syntax

public static void filterWithUnsharpMask(
   ImGearRasterPage page,
   double radius,
   int amount,
   int threshold,
   ImGearChannelRange channels
)

Parameters

page
Page to filter.
radius
Radius of unsharp mask.
amount
Amount of unsharpening.
threshold
Unsharpening threshold.
channels
Channel range.

This method processes a specified range of channels.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

findSkewAngle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : findSkewAngle Method
page
Page to deskew.

Glossary Item Box

Determines skew angle.

Syntax

public static double findSkewAngle(
   ImGearRasterPage page
)

Parameters

page
Page to deskew.

Return Value

com.accusoft.imagegear.core.ImGearRasterPage class object.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

findTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : findTilt Method
page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
slopeX
Returns the slope in the X direction of the tilt plane.
slopeY
Returns the slope in the Y direction of the tilt plane.
piston
Returns the piston of the tilt plane.

This method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.

Can be applied only to 8, 16 or 32bit grayscale images with one channel.

Glossary Item Box

Computes the least-squares best fit plane for an image.

Syntax

public static void findTilt(
   ImGearRasterPage page,
   com.accusoft.imagegear.utility.ImGearRefObject<double> slopeX,
   com.accusoft.imagegear.utility.ImGearRefObject<double> slopeY,
   com.accusoft.imagegear.utility.ImGearRefObject<double> piston
)

Parameters

page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
slopeX
Returns the slope in the X direction of the tilt plane.
slopeY
Returns the slope in the Y direction of the tilt plane.
piston
Returns the piston of the tilt plane.

This method computes the least-squares best fit plane for an image. The plane will be given by formula:

f(x, y) = SlopeX * x + SlopeY * y + Piston.

Can be applied only to 8, 16 or 32bit grayscale images with one channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

gaussianBlur Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : gaussianBlur Method

Glossary Item Box

Blurs an image using Gaussian transform.

Overload List

Overload | Description
gaussianBlur(ImGearRasterPage,double) | Blurs an image using Gaussian transform.
gaussianBlur(ImGearRasterPage,double,ImGearChannelRange) | Blurs an image using Gaussian transform.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

gaussianBlur(ImGearRasterPage,double) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > gaussianBlur Method : gaussianBlur(ImGearRasterPage,double) Method
page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.

This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method only blurs color channels of the image. If the image contains Alpha or Extra channels, the method does not blur them.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Blurs an image using Gaussian transform.

Syntax

public static void gaussianBlur(
   ImGearRasterPage page,
   double radius
)

Parameters

page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.

This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method only blurs color channels of the image. If the image contains Alpha or Extra channels, the method does not blur them.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

gaussianBlur(ImGearRasterPage,double,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > gaussianBlur Method : gaussianBlur(ImGearRasterPage,double,ImGearChannelRange) Method
page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.
channels
Defines image channels to apply the transform to.

This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method allows to specify the range of channels to blur.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Blurs an image using Gaussian transform.

Syntax

public static void gaussianBlur(
   ImGearRasterPage page,
   double radius,
   ImGearChannelRange channels
)

Parameters

page
Page to process.
radius
Defines the neighborhood to be considered for each pixel.
channels
Defines image channels to apply the transform to.

This method makes images look softer and out of focus.

The radius parameter corresponds to the Standard Deviation (Sigma) in Gaussian transform. It can range from 0.1 to 500. Typical values for high-resolution images range from 1.0 to 2.0. Larger values will cause greater softening. On the other hand, smaller values are faster. The width of the area considered for each pixel is approximately 6 * radius.

The method allows to specify the range of channels to blur.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

geomDespeckle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : geomDespeckle Method
page
An com.accusoft.imagegear.core.ImGearRasterPage class object on which algorithm will be performed.
iterations
Number of iterations to apply the despeckle filter.

This method reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique.

The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image.

Can be applied only to 8bit grayscale images with one channel.

Glossary Item Box

Reduces speckle noise from an image by using the Crimmins algorithm.

Syntax

public static void geomDespeckle(
   ImGearRasterPage page,
   int iterations
)

Parameters

page
An com.accusoft.imagegear.core.ImGearRasterPage class object on which algorithm will be performed.
iterations
Number of iterations to apply the despeckle filter.

This method reduces the speckle index of an image by sending the image through a geometric filter, which uses the complementary hulling technique.

The method has the effect of reducing the undesired speckle noise while preserving the edges of the original image.

Can be applied only to 8bit grayscale images with one channel.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

getVerifier Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : getVerifier Method

Glossary Item Box

Gets ImGearRasterProcessingVerifier class object.

ImGearRasterProcessingVerifier class object.

Syntax

public static ImGearRasterProcessingVerifier getVerifier()

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

imageIsGray Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : imageIsGray Method
page
Image to test.

Glossary Item Box

Returns true if either the image has GrayScale color space or its palette is gray or inverted gray.

Syntax

public static boolean imageIsGray(
   ImGearRasterPage page
)

Parameters

page
Image to test.

Return Value

Boolean value.

This method returns true if either of the two conditions are met:

  • Image has grayscale color space.
  • Image has indexed color space, and palette is either linear gray, or inverted gray.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

insertChannel Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : insertChannel Method
page
Page to insert channel to.
newChannelPos
Position of the channel in the page.
channel
Reference to the channel to be inserted. com.accusoft.imagegear.core.ImGearRasterPage ImGearChannelRef

Glossary Item Box

Inserts a channel to the page's DIB and changes page's color space.

Syntax

public static void insertChannel(
   ImGearRasterPage page,
   int newChannelPos,
   ImGearChannelRef channel
)

Parameters

page
Page to insert channel to.
newChannelPos
Position of the channel in the page.
channel
Reference to the channel to be inserted. com.accusoft.imagegear.core.ImGearRasterPage ImGearChannelRef

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

invertContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : invertContrast Method

Glossary Item Box

Inverts image contrast.

Overload List

Overload | Description
invertContrast(ImGearRasterPage) | Inverts image contrast.
invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Inverts image contrast.
invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) | Inverts image contrast.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

invertContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > invertContrast Method : invertContrast(ImGearRasterPage) Method
page
Image to invert contrast.

If the image is indexed and the palette is not grayscale, this method modifies image's palette, otherwise it modifies image's pixels. The method processes only color channels.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast )} method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Inverts image contrast.

Syntax

public static void invertContrast(
   ImGearRasterPage page
)

Parameters

page
Image to invert contrast.

If the image is indexed and the palette is not grayscale, this method modifies image's palette, otherwise it modifies image's pixels. The method processes only color channels.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast )} method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > invertContrast Method : invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.

Processes specified range of channels.

If mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Inverts image contrast.

Syntax

public static void invertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.

Processes specified range of channels.

If mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > invertContrast Method : invertContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange,ImGearContrastOptions) Method
page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.
options
Contrast options. See ImGearContrastOptions class.

Processes specified range of channels.

If Mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange ImGearContrastOptions

Glossary Item Box

Inverts image contrast.

Syntax

public static void invertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels,
   ImGearContrastOptions options
)

Parameters

page
Image to invert contrast.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to invert contrast.
options
Contrast options. See ImGearContrastOptions class.

Processes specified range of channels.

If Mode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyInvertContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange ImGearContrastOptions

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

merge Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : merge Method

Glossary Item Box

Merges two images according to the specified merge mode.

Overload List

Overload | Description
merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes) | Merges two images according to the specified merge mode.
merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes,ImGearChannelRange) | Merges two images according to the specified merge mode.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > merge Method : merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes) Method
page
First image to merge. It will contain result image after merging.
pageToMergeWith
Second image to merge.
left
Left position ot the source image on the destination one.
top
Top position ot the source image on the destination one.
mode
Merge mode constant. See ImGearMergeModes enumeration.

Processes color channels only.

DIBs or both pages must have the same color space.

Use ImGearRasterProcessingVerifier.canApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

com.accusoft.imagegear.core.ImGearRasterPage ImGearMergeModes

Glossary Item Box

Merges two images according to the specified merge mode.

Syntax

public static void merge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode
)

Parameters

page
First image to merge. It will contain result image after merging.
pageToMergeWith
Second image to merge.
left
Left position ot the source image on the destination one.
top
Top position ot the source image on the destination one.
mode
Merge mode constant. See ImGearMergeModes enumeration.

Processes color channels only.

DIBs or both pages must have the same color space.

Use ImGearRasterProcessingVerifier.canApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

com.accusoft.imagegear.core.ImGearRasterPage ImGearMergeModes

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > merge Method : merge(ImGearRasterPage,ImGearRasterPage,int,int,ImGearMergeModes,ImGearChannelRange) Method
page
First image to merge. It will contain resultant image after merging.
pageToMergeWith
Second image to merge.
left
Left position of the source image on the destination one.
top
Top position of the source image on the destination one.
mode
Merge mode.
channels
Range of channels.

Processes specified range of channels.

Both page DIBs must have the same color space.

Use ImGearRasterProcessingVerifier.canApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Merges two images according to the specified merge mode.

Syntax

public static void merge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith,
   int left,
   int top,
   ImGearMergeModes mode,
   ImGearChannelRange channels
)

Parameters

page
First image to merge. It will contain resultant image after merging.
pageToMergeWith
Second image to merge.
left
Left position of the source image on the destination one.
top
Top position of the source image on the destination one.
mode
Merge mode.
channels
Range of channels.

Processes specified range of channels.

Both page DIBs must have the same color space.

Use ImGearRasterProcessingVerifier.canApplyMerge method to check whether the operation can be performed.

If the images are paletted, the arithmetic operation is applied to the pixel values (indexes) rather than to the palette entries. This may result in unexpected effect with certain palettes, for example if the palette is reversed. In such cases, consider converting the image to a non-indexed colorspace, such as Grayscale or RGB, before applying the operation.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

open Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : open Method
page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Applies opening effect to provided raster page using the specified structure element.

Syntax

public static void open(
   ImGearRasterPage page,
   int[][] matrix
)

Parameters

page
Page class object to apply effect to.
matrix
Matrix specifying a structuring element for the operation.

This method is applicable to any grayscale images (images with com.accusoft.imagegear.core.ImGearColorSpaceIDs.Gy color space).

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

reduce Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : reduce Method
page
Image to reduce bit depth.
colorSpace
Color space to reduce image to.
channelDepths
Channel depths to reduce image to.
reductionMethod
Method to use for reducing bit depth.
options
Options to use for reduction, or set to null to use defaults.

All methods except for ImGearReductionMethods.SCALE change the color space of the image to Indexed. ImGearReductionMethods.SCALE does not change the image's color space, but only scales the channel depths. Different reduction methods have their own options, which can be set using the options parameter.

For more information about a particular method, see its options. The following reduction methods are available in ImGearReductionMethods:

Method | Input color spaces and bit depths | Output color spaces and bit depths | Options
BAYER | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearBayerReductionOptions
BITONAL | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearBitonalReductionOptions
DIFFUSE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearDiffuseReductionOptions
HALFTONE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearHalftoneReductionOptions
MEDIAN | RGB (24)Grayscale (8) | Indexed (8) | ImGearMedianCutReductionOptions
OCTREE | RGB (24)Grayscale (8) | Indexed (4 or 8) | ImGearOctreeReductionOptions
POPULARITY | RGB (24)Grayscale (8) | Indexed (8) | ImGearPopularityReductionOptions
SCALE | Any color space except Indexed | Same color space as input | ImGearScaleReductionOptions

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearReductionOptions ImGearReductionMethods

Glossary Item Box

Reduces bit depth of an image using the specified reduction method.

Syntax

public static void reduce(
   ImGearRasterPage page,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   ImGearReductionMethods reductionMethod,
   ImGearReductionOptions options
)

Parameters

page
Image to reduce bit depth.
colorSpace
Color space to reduce image to.
channelDepths
Channel depths to reduce image to.
reductionMethod
Method to use for reducing bit depth.
options
Options to use for reduction, or set to null to use defaults.

All methods except for ImGearReductionMethods.SCALE change the color space of the image to Indexed. ImGearReductionMethods.SCALE does not change the image's color space, but only scales the channel depths. Different reduction methods have their own options, which can be set using the options parameter.

For more information about a particular method, see its options. The following reduction methods are available in ImGearReductionMethods:

Method | Input color spaces and bit depths | Output color spaces and bit depths | Options
BAYER | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearBayerReductionOptions
BITONAL | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearBitonalReductionOptions
DIFFUSE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1 or 4) | ImGearDiffuseReductionOptions
HALFTONE | RGB (24)Grayscale (8)Indexed (>1) | Indexed (1) | ImGearHalftoneReductionOptions
MEDIAN | RGB (24)Grayscale (8) | Indexed (8) | ImGearMedianCutReductionOptions
OCTREE | RGB (24)Grayscale (8) | Indexed (4 or 8) | ImGearOctreeReductionOptions
POPULARITY | RGB (24)Grayscale (8) | Indexed (8) | ImGearPopularityReductionOptions
SCALE | Any color space except Indexed | Same color space as input | ImGearScaleReductionOptions

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearReductionOptions ImGearReductionMethods

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

removeChannel Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : removeChannel Method
page
Page to remove channel.
channelNumber
Position of the channel to be removed.

channelNumber can be within the [0..getChannelCount-1] range.

Color Space is changed as follows:

  • If page has more than one Extra channel, color space is unchanged.
  • If page has one Extra channel, ExtraMask is cleared.
  • If page has Alpha channel and no Extra channels, AlphaMask and PremultAlphaMask are cleared.
  • If page has only color channels, color space is changed to Unknown, and all remaining channels are considered Extra channels.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Removes the specified channel from the page's DIB and shifts remaining channels without transforming pixel data.

Syntax

public static void removeChannel(
   ImGearRasterPage page,
   int channelNumber
)

Parameters

page
Page to remove channel.
channelNumber
Position of the channel to be removed.

channelNumber can be within the [0..getChannelCount-1] range.

Color Space is changed as follows:

  • If page has more than one Extra channel, color space is unchanged.
  • If page has one Extra channel, ExtraMask is cleared.
  • If page has Alpha channel and no Extra channels, AlphaMask and PremultAlphaMask are cleared.
  • If page has only color channels, color space is changed to Unknown, and all remaining channels are considered Extra channels.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

removeTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : removeTilt Method
page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
removeMean
Flag to indicate whether to remove the mean from the de-tilted image, giving it zero-mean statistics.

This method is very handy for correcting illumination gradients in a poorly digitized image.

If removeMean argument is set to true, then global mean is removed from the image as well.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

This method computes the best-fit plane for an image, and then subtracts that plane from the image to produce the output.

Syntax

public static void removeTilt(
   ImGearRasterPage page,
   boolean removeMean
)

Parameters

page
An com.accusoft.imagegear.core.ImGearRasterPage class object to process.
removeMean
Flag to indicate whether to remove the mean from the de-tilted image, giving it zero-mean statistics.

This method is very handy for correcting illumination gradients in a poorly digitized image.

If removeMean argument is set to true, then global mean is removed from the image as well.

Can be applied only to 8, 16 or 32-bpp grayscale images with one channel.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

separateChannels Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : separateChannels Method
page
Multichannel page to separate.

Glossary Item Box

Creates an array of pages, where each page contains one channel with color space set to grayscale.

Syntax

public static ImGearChannelRef[] separateChannels(
   ImGearRasterPage page
)

Parameters

page
Multichannel page to separate.

Return Value

An array of channels reference - ImGearChannelRef structure.

This method does not do any of the color space or pixel conversions.

ImGearChannelRef com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

sharpen Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : sharpen Method

Glossary Item Box

Sharpens an image according to the specified sharpen factor.

Overload List

Overload | Description
sharpen(ImGearRasterPage,int) | Sharpens an image according to the specified sharpen factor.
sharpen(ImGearRasterPage,int,ImGearChannelRange) | Sharpens an image according to the specified sharpen factor.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

sharpen(ImGearRasterPage,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > sharpen Method : sharpen(ImGearRasterPage,int) Method
page
Image to sharpen.
factor
Sharpen factor.

Processes color channels only.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Sharpens an image according to the specified sharpen factor.

Syntax

public static void sharpen(
   ImGearRasterPage page,
   int factor
)

Parameters

page
Image to sharpen.
factor
Sharpen factor.

Processes color channels only.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

sharpen(ImGearRasterPage,int,ImGearChannelRange) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > sharpen Method : sharpen(ImGearRasterPage,int,ImGearChannelRange) Method
page
Image to sharpen.
factor
Sharpen factor.
channels
Channel range to sharpen.

This method processes a specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Sharpens an image according to the specified sharpen factor.

Syntax

public static void sharpen(
   ImGearRasterPage page,
   int factor,
   ImGearChannelRange channels
)

Parameters

page
Image to sharpen.
factor
Sharpen factor.
channels
Channel range to sharpen.

This method processes a specified range of channels.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

smooth Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : smooth Method

Glossary Item Box

Provides smooth filtering.

Overload List

Overload | Description
smooth(ImGearRasterPage,int) | Provides smooth filtering.
smooth(ImGearRasterPage,int,ImGearChannelRange) | Provides smooth filtering.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

smooth(ImGearRasterPage,int) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > smooth Method : smooth(ImGearRasterPage,int) Method
page
Page to process.
factor
Smooth factor.

This method processes color channels only.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Provides smooth filtering.

Syntax

public static void smooth(
   ImGearRasterPage page,
   int factor
)

Parameters

page
Page to process.
factor
Smooth factor.

This method processes color channels only.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

smooth(ImGearRasterPage,int,ImGearChannelRange) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > smooth Method : smooth(ImGearRasterPage,int,ImGearChannelRange) Method
page
Image to process.
factor
Smooth factor.
channels
Channel range to process.

Processes specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Provides smooth filtering.

Syntax

public static void smooth(
   ImGearRasterPage page,
   int factor,
   ImGearChannelRange channels
)

Parameters

page
Image to process.
factor
Smooth factor.
channels
Channel range to process.

Processes specified range of channels.

Can be applied only to the raster pages with standard (non Run-Ends) DIB.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

stretchContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : stretchContrast Method

Glossary Item Box

Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.

Overload List

Overload | Description
stretchContrast(ImGearRasterPage) | Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.
stretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) | Stretches image contrast. Processes specified range of channels.

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

stretchContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > stretchContrast Method : stretchContrast(ImGearRasterPage) Method
page

Glossary Item Box

Stretches image contrast. If image is Indexed and not grayscale, modifies image's palette, otherwise modifies image's pixels. Processes only color channels.

Syntax

public static void stretchContrast(
   ImGearRasterPage page
)

Parameters

page

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

stretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class > stretchContrast Method : stretchContrast(ImGearRasterPage,ImGearContrastModes,ImGearChannelRange) Method
page
Image to process.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to process.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyStretchContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Stretches image contrast. Processes specified range of channels.

Syntax

public static void stretchContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode,
   ImGearChannelRange channels
)

Parameters

page
Image to process.
mode
One of the contrast processing modes: ImGearContrastModes.PALETTE, ImGearContrastModes.PIXEL, ImGearContrastModes.AUTO.
channels
Channel range to process.

Can be applied only to raster pages with standard (non Run-Ends) DIB.

If ContrastMode is equal to ImGearContrastModes.PALETTE, DIB must have a palette.

Use ImGearRasterProcessingVerifier.canApplyStretchContrast method to check whether the operation can be performed.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members
Overload List


%%PageItemTitle%%

swapChannels Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : swapChannels Method
page
Page to swap the channels.
channelIndex1
Index of the first channel to be swapped.
channelIndex2
Index of the second channel to be swapped. com.accusoft.imagegear.core.ImGearRasterPage

Glossary Item Box

Swaps two channels in page's DIB.

Syntax

public static void swapChannels(
   ImGearRasterPage page,
   int channelIndex1,
   int channelIndex2
)

Parameters

page
Page to swap the channels.
channelIndex1
Index of the first channel to be swapped.
channelIndex2
Index of the second channel to be swapped. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

tabulateHistogram Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : tabulateHistogram Method
page
Page for which to tabulate histogram.
histogram
Two dimensional array that is filled with histogram data. It must be allocated prior to calling the function. First dimension corresponds to channel number, second dimension corresponds to histogram bin number.
channels
Specifies image channels for which histogram shall be tabulated.

This method tabulates histograms for all image channels.

This method supports images with channel depths ranging from 2 to 16.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

Glossary Item Box

Tabulates histograms for all image channels.

Syntax

public static void tabulateHistogram(
   ImGearRasterPage page,
   int[][] histogram,
   ImGearChannelRange channels
)

Parameters

page
Page for which to tabulate histogram.
histogram
Two dimensional array that is filled with histogram data. It must be allocated prior to calling the function. First dimension corresponds to channel number, second dimension corresponds to histogram bin number.
channels
Specifies image channels for which histogram shall be tabulated.

This method tabulates histograms for all image channels.

This method supports images with channel depths ranging from 2 to 16.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearChannelRange

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

transformWithLUT Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : transformWithLUT Method
page
Page to apply the LUT to.
LUT
Multichannel LUT that shall be applied.

This method applies a multichannel lookup table to each channel of the image, optionally changing channel depths.

Number of single-channel LUTs in the multichannel LUT must match number of image channels. Input depth of each single-channel LUT must match the depth of corresponding channel. Depths of image channels after transform are determined by output depths of the coresponding single-channel LUTs.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearMultichannelLUT

Glossary Item Box

Applies lookup tables to each channel of the image, optionally changing channel depths.

Syntax

public static void transformWithLUT(
   ImGearRasterPage page,
   ImGearMultichannelLUT LUT
)

Parameters

page
Page to apply the LUT to.
LUT
Multichannel LUT that shall be applied.

This method applies a multichannel lookup table to each channel of the image, optionally changing channel depths.

Number of single-channel LUTs in the multichannel LUT must match number of image channels. Input depth of each single-channel LUT must match the depth of corresponding channel. Depths of image channels after transform are determined by output depths of the coresponding single-channel LUTs.

com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearMultichannelLUT

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

updateChannelFrom Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessing Class : updateChannelFrom Method
channelToUpdate
Destination channel.
channelUpdateWith
Source channel. ImGearChannelRef

Glossary Item Box

Copies channel from channel referenced by channelUpdateWith to the channel referenced by channelToUpdate. The pages containing both channels must have the same width and height.

Syntax

public static void updateChannelFrom(
   ImGearChannelRef channelToUpdate,
   ImGearChannelRef channelUpdateWith
)

Parameters

channelToUpdate
Destination channel.
channelUpdateWith
Source channel. ImGearChannelRef

See Also

Reference

ImGearRasterProcessing Class
ImGearRasterProcessing Members


%%PageItemTitle%%

ImGearRasterProcessingVerifier Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessingVerifier Class

Glossary Item Box

Contains static methods that check whether particular ImGearRasterProcessing operations are applicable to the page.

Note: These methods should be used to distinguish a sub-set of pages for which particular filter is applicable; e.g., canApplyGaussianBlur method returns true only if incoming page image is not binary, that is BitDepth > 1. Parameters of all IP functions are checked separately.

Object Model

ImGearRasterProcessingVerifier Class

Syntax

public sealed class ImGearRasterProcessingVerifier
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearRasterProcessingVerifier

See Also

Reference

ImGearRasterProcessingVerifier Members
com.accusoft.imagegear.processing Package
ImGearRasterProcessing Class


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRasterProcessingVerifier Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessingVerifier Class

Glossary Item Box

The following tables list the members exposed by ImGearRasterProcessingVerifier.

Public Methods

 | Name | Description
public Method | canApplyAddTilt | Returns true if addTilt method can be applied to the specified page.
public Method | canApplyAdjustContrast | Overloaded. Returns true if ImGearRasterProcessing.adjustContrast } method can be applied to the specified page, false otherwise.
public Method | canApplyBlend | Returns true if ImGearRasterProcessing.blend method can be applied to the specified page, false otherwise.
public Method | canApplyBlendWithAlpha | Returns true if ImGearRasterProcessing.blendWithAlpha method can be applied to the specified page, false otherwise.
public Method | canApplyCalculateStatistics | Returns true if ImGearRasterProcessing.calculateStatistics method can be applied to the specified page, false otherwise.
public Method | canApplyClose | Checks if ImGearRasterProcessing.close method can be applied to the specified raster page.
public Method | canApplyConvertColorSpace | Returns true if ImGearRasterProcessing.convertColorSpace} method can be applied to the specified page, false otherwise.
public Method | canApplyConvolve | Returns true if ImGearRasterProcessing.convolve method can be applied to the specified page, false otherwise.
public Method | canApplyCrypt | Returns true if ImGearRasterProcessing.encrypt and ImGearRasterProcessing.decrypt methods can be applied to the specified page, false otherwise.
public Method | canApplyDeskew | Returns true if ImGearRasterProcessing.deskew method can be applied to the specified page, false otherwise.
public Method | canApplyDespeckle | Returns true if ImGearRasterProcessing.despeckle method can be applied to the specified page, false otherwise.
public Method | canApplyDilate | Checks if ImGearRasterProcessing.dilate method can be applied to the specified raster page.
public Method | canApplyEnhanceLocal | Returns true if enhanceLocal method can be applied to the specified page, false otherwise.
public Method | canApplyEqualizeContrast | Overloaded. Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page, false otherwise.
public Method | canApplyErode | Checks if ImGearRasterProcessing.erode method can be applied to the specified raster page.
public Method | canApplyFilterWithMedian | Returns true if filterWithMedian method can be applied to the specified page, false otherwise.
public Method | canApplyFilterWithUnsharpMask | Returns true if filterWithUnsharpMask method can be applied to the specified page, false otherwise.
public Method | canApplyFindSkewAngle | Returns true if ImGearRasterProcessing.findSkewAngle method can be applied to the specified page, false otherwise.
public Method | canApplyFindTilt | Returns true if ImGearRasterProcessing.findTilt method can be applied to the specified page, false otherwise.
public Method | canApplyGaussianBlur | Returns true if Gaussian Method can be applied to the specified page, false otherwise.
public Method | canApplyGeomDespeckle | Returns true if geomDespeckle method can be applied to the specified page, false otherwise.
public Method | canApplyInvertContrast | Overloaded. Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page, false otherwise.
public Method | canApplyMerge | Returns true if ImGearRasterProcessing.merge} method can be applied to the specified page, false otherwise.
public Method | canApplyOpen | Checks if ImGearRasterProcessing.open method can be applied to the specified raster page.
public Method | canApplyReduce | Returns true if ImGearRasterProcessing.reduce method can be applied to the specified page, using specified reduction method, false otherwise.
public Method | canApplyRemoveTilt | Returns true if ImGearRasterProcessing.removeTilt method can be applied to the specified page, false otherwise.
public Method | canApplySharpen | Returns true if sharpen method can be applied to the specified page, false otherwise.
public Method | canApplySmooth | Verifies if smooth method can be applied to the specified Page.
public Method | canApplyStretchContrast | Overloaded. Returns true if ImGearRasterProcessing.stretchContrast method can be applied to the specified page, false otherwise.
public Method | canApplyTabulateHistogram | Checks whether ImGearRasterProcessing.tabulateHistogram method can be applied to the page.
public Method | canApplyTransformWithLUT | Checks whether method can be applied to the page.
Top

See Also

Reference

ImGearRasterProcessingVerifier Class
com.accusoft.imagegear.processing Package
ImGearRasterProcessing Class


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRasterProcessingVerifier Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearRasterProcessingVerifier Class

Glossary Item Box

For a list of all members of this type, see ImGearRasterProcessingVerifier members.

Public Methods

 | Name | Description
public Method | canApplyAddTilt | Returns true if addTilt method can be applied to the specified page.
public Method | canApplyAdjustContrast | Overloaded. Returns true if ImGearRasterProcessing.adjustContrast } method can be applied to the specified page, false otherwise.
public Method | canApplyBlend | Returns true if ImGearRasterProcessing.blend method can be applied to the specified page, false otherwise.
public Method | canApplyBlendWithAlpha | Returns true if ImGearRasterProcessing.blendWithAlpha method can be applied to the specified page, false otherwise.
public Method | canApplyCalculateStatistics | Returns true if ImGearRasterProcessing.calculateStatistics method can be applied to the specified page, false otherwise.
public Method | canApplyClose | Checks if ImGearRasterProcessing.close method can be applied to the specified raster page.
public Method | canApplyConvertColorSpace | Returns true if ImGearRasterProcessing.convertColorSpace} method can be applied to the specified page, false otherwise.
public Method | canApplyConvolve | Returns true if ImGearRasterProcessing.convolve method can be applied to the specified page, false otherwise.
public Method | canApplyCrypt | Returns true if ImGearRasterProcessing.encrypt and ImGearRasterProcessing.decrypt methods can be applied to the specified page, false otherwise.
public Method | canApplyDeskew | Returns true if ImGearRasterProcessing.deskew method can be applied to the specified page, false otherwise.
public Method | canApplyDespeckle | Returns true if ImGearRasterProcessing.despeckle method can be applied to the specified page, false otherwise.
public Method | canApplyDilate | Checks if ImGearRasterProcessing.dilate method can be applied to the specified raster page.
public Method | canApplyEnhanceLocal | Returns true if enhanceLocal method can be applied to the specified page, false otherwise.
public Method | canApplyEqualizeContrast | Overloaded. Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page, false otherwise.
public Method | canApplyErode | Checks if ImGearRasterProcessing.erode method can be applied to the specified raster page.
public Method | canApplyFilterWithMedian | Returns true if filterWithMedian method can be applied to the specified page, false otherwise.
public Method | canApplyFilterWithUnsharpMask | Returns true if filterWithUnsharpMask method can be applied to the specified page, false otherwise.
public Method | canApplyFindSkewAngle | Returns true if ImGearRasterProcessing.findSkewAngle method can be applied to the specified page, false otherwise.
public Method | canApplyFindTilt | Returns true if ImGearRasterProcessing.findTilt method can be applied to the specified page, false otherwise.
public Method | canApplyGaussianBlur | Returns true if Gaussian Method can be applied to the specified page, false otherwise.
public Method | canApplyGeomDespeckle | Returns true if geomDespeckle method can be applied to the specified page, false otherwise.
public Method | canApplyInvertContrast | Overloaded. Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page, false otherwise.
public Method | canApplyMerge | Returns true if ImGearRasterProcessing.merge} method can be applied to the specified page, false otherwise.
public Method | canApplyOpen | Checks if ImGearRasterProcessing.open method can be applied to the specified raster page.
public Method | canApplyReduce | Returns true if ImGearRasterProcessing.reduce method can be applied to the specified page, using specified reduction method, false otherwise.
public Method | canApplyRemoveTilt | Returns true if ImGearRasterProcessing.removeTilt method can be applied to the specified page, false otherwise.
public Method | canApplySharpen | Returns true if sharpen method can be applied to the specified page, false otherwise.
public Method | canApplySmooth | Verifies if smooth method can be applied to the specified Page.
public Method | canApplyStretchContrast | Overloaded. Returns true if ImGearRasterProcessing.stretchContrast method can be applied to the specified page, false otherwise.
public Method | canApplyTabulateHistogram | Checks whether ImGearRasterProcessing.tabulateHistogram method can be applied to the page.
public Method | canApplyTransformWithLUT | Checks whether method can be applied to the page.
Top

See Also

Reference

ImGearRasterProcessingVerifier Class
com.accusoft.imagegear.processing Package
ImGearRasterProcessing Class


%%PageItemTitle%%

canApplyAddTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyAddTilt Method
page
Raster page object to verify.

Glossary Item Box

Returns true if addTilt method can be applied to the specified page.

Syntax

public boolean canApplyAddTilt(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyAdjustContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyAdjustContrast Method

Glossary Item Box

Returns true if ImGearRasterProcessing.adjustContrast } method can be applied to the specified page, false otherwise.

Overload List

Overload | Description
canApplyAdjustContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.adjustContrast } method can be applied to the specified page, false otherwise.
canApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.adjustContrast method can be applied to the specified page with the specified contrast mode, false otherwise.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyAdjustContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyAdjustContrast Method : canApplyAdjustContrast(ImGearRasterPage) Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.adjustContrast } method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyAdjustContrast(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. with ImGearContrastModes.AUTO argument value com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyAdjustContrast Method : canApplyAdjustContrast(ImGearRasterPage,ImGearContrastModes) Method
page
Raster page object to verify.
mode
Contrast mode.

Glossary Item Box

Returns true if ImGearRasterProcessing.adjustContrast method can be applied to the specified page with the specified contrast mode, false otherwise.

Syntax

public boolean canApplyAdjustContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value.

com.accusoft.imagegear.core.ImGearRasterPage ImGearContrastModes

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyBlend Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyBlend Method
page
Raster page object to verify.
pageToBlendWith
Page to blend with.

Glossary Item Box

Returns true if blend(ImGearRasterPage,int,int,ImGearRasterPage,double) method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyBlend(
   ImGearRasterPage page,
   ImGearRasterPage pageToBlendWith
)

Parameters

page
Raster page object to verify.
pageToBlendWith
Page to blend with.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyBlendWithAlpha Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyBlendWithAlpha Method
page
Raster page object to verify.
alpha
Page to blend with.

Glossary Item Box

Returns true if blendWithAlpha method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyBlendWithAlpha(
   ImGearRasterPage page,
   ImGearRasterPage alpha
)

Parameters

page
Raster page object to verify.
alpha
Page to blend with.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage blendWithAlpha

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyCalculateStatistics Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyCalculateStatistics Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.calculateStatistics method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyCalculateStatistics(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.calculateStatistics

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyClose Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyClose Method
page
Raster page object to verify.

Glossary Item Box

Checks if ImGearRasterProcessing.close method can be applied to the specified raster page.

Syntax

public boolean canApplyClose(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.close

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyConvertColorSpace Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyConvertColorSpace Method
page
Raster page object to verify.
space
Color space.

Glossary Item Box

Returns true if ImGearRasterProcessing.convertColorSpace} method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyConvertColorSpace(
   ImGearRasterPage page,
   ImGearColorSpace space
)

Parameters

page
Raster page object to verify.
space
Color space.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage com.accusoft.imagegear.core.ImGearColorSpace

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyConvolve Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyConvolve Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.convolve method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyConvolve(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.convolve

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyCrypt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyCrypt Method
page
Raster page object to verify.
password
Password to Encrypt/Decrypt the image with.

Glossary Item Box

Returns true if encrypt and decrypt methods can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyCrypt(
   ImGearRasterPage page,
   java.lang.String password
)

Parameters

page
Raster page object to verify.
password
Password to Encrypt/Decrypt the image with.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPageM:com.accusoft.imagegear.processing.ImGearRasterProcessing.encrypt(com.accusoft.imagegear.core.ImGearRasterPage,java.lang.String)

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyDeskew Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyDeskew Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.deskew method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyDeskew(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessingVerifier

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyDespeckle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyDespeckle Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.despeckle method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyDespeckle(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.despeckle

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyDilate Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyDilate Method
page
Raster page object to verify.

Glossary Item Box

Checks if ImGearRasterProcessing.dilate method can be applied to the specified raster page.

Syntax

public boolean canApplyDilate(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.dilate

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyEnhanceLocal Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyEnhanceLocal Method
page
Raster page object to verify.

Glossary Item Box

Returns true if enhanceLocal method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyEnhanceLocal(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyEqualizeContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyEqualizeContrast Method

Glossary Item Box

Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page, false otherwise.

Overload List

Overload | Description
canApplyEqualizeContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page, false otherwise.
canApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page and contrast mode, false otherwise.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyEqualizeContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyEqualizeContrast Method : canApplyEqualizeContrast(ImGearRasterPage) Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyEqualizeContrast(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. This method works in the same way as canApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyEqualizeContrast Method : canApplyEqualizeContrast(ImGearRasterPage,ImGearContrastModes) Method
page
Raster page object to verify.
mode
Contrast mode.

Glossary Item Box

Returns true if ImGearRasterProcessing.equalizeContrast method can be applied to the specified page and contrast mode, false otherwise.

Syntax

public boolean canApplyEqualizeContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearContrastModes

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyErode Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyErode Method
page
Raster page object to verify.

Glossary Item Box

Checks if ImGearRasterProcessing.erode method can be applied to the specified raster page.

Syntax

public boolean canApplyErode(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.erode

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyFilterWithMedian Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyFilterWithMedian Method
page
Raster page object to verify.

Glossary Item Box

Returns true if filterWithMedian method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyFilterWithMedian(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyFilterWithUnsharpMask Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyFilterWithUnsharpMask Method
page
Raster page object to verify.

Glossary Item Box

Returns true if filterWithUnsharpMask method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyFilterWithUnsharpMask(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyFindSkewAngle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyFindSkewAngle Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.findSkewAngle method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyFindSkewAngle(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.findSkewAngle

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyFindTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyFindTilt Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.findTilt method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyFindTilt(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyGaussianBlur Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyGaussianBlur Method
page
Raster page object to verify.

Glossary Item Box

Returns true if Gaussian Method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyGaussianBlur(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyGeomDespeckle Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyGeomDespeckle Method
page
Raster page object to verify.

Glossary Item Box

Returns true if geomDespeckle method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyGeomDespeckle(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyInvertContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyInvertContrast Method

Glossary Item Box

Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page, false otherwise.

Overload List

Overload | Description
canApplyInvertContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page, false otherwise.
canApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) | Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page and specified contrast mode, false otherwise.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyInvertContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyInvertContrast Method : canApplyInvertContrast(ImGearRasterPage) Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyInvertContrast(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. This method works in the same way as canApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) with ImGearContrastModes.AUTO argument value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyInvertContrast Method : canApplyInvertContrast(ImGearRasterPage,ImGearContrastModes) Method
page
Raster page object to verify.
mode
Contrast mode.

Glossary Item Box

Returns true if ImGearRasterProcessing.invertContrast method can be applied to the specified page and specified contrast mode, false otherwise.

Syntax

public boolean canApplyInvertContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearContrastModes

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyMerge Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyMerge Method
page
Raster page object to verify.
pageToMergeWith
Page to merge.

Glossary Item Box

Returns true if ImGearRasterProcessing.merge} method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyMerge(
   ImGearRasterPage page,
   ImGearRasterPage pageToMergeWith
)

Parameters

page
Raster page object to verify.
pageToMergeWith
Page to merge.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyOpen Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyOpen Method
page
Raster page object to verify.

Glossary Item Box

Checks if ImGearRasterProcessing.open method can be applied to the specified raster page.

Syntax

public boolean canApplyOpen(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.open

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyReduce Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyReduce Method
page
Raster page to verify.
reductionMethod
Reduction method.

Glossary Item Box

Returns true if ImGearRasterProcessing.reduce method can be applied to the specified page, using specified reduction method, false otherwise.

Syntax

public boolean canApplyReduce(
   ImGearRasterPage page,
   ImGearReductionMethods reductionMethod
)

Parameters

page
Raster page to verify.
reductionMethod
Reduction method.

Return Value

Boolean value.

com.accusoft.imagegear.core.ImGearRasterPageT:com.accusoft.imagegear.processing.ImGearReductionMethods

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyRemoveTilt Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyRemoveTilt Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.removeTilt method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyRemoveTilt(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplySharpen Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplySharpen Method
page
Raster page object to verify.

Glossary Item Box

Returns true if sharpen method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplySharpen(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplySmooth Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplySmooth Method
page
Raster page object to verify.

Glossary Item Box

Verifies if smooth method can be applied to the specified Page.

Syntax

public boolean canApplySmooth(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyStretchContrast Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyStretchContrast Method

Glossary Item Box

Returns true if ImGearRasterProcessing.stretchContrast method can be applied to the specified page, false otherwise.

Overload List

Overload | Description
canApplyStretchContrast(ImGearRasterPage) | Returns true if ImGearRasterProcessing.stretchContrast method can be applied to the specified page, false otherwise.
canApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) | Returns true, if ImGearRasterProcessing.stretchContrast method can be applied to the specified page with the specified contrast mode, false otherwise.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyStretchContrast(ImGearRasterPage) Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyStretchContrast Method : canApplyStretchContrast(ImGearRasterPage) Method
page
Raster page object to verify.

Glossary Item Box

Returns true if ImGearRasterProcessing.stretchContrast method can be applied to the specified page, false otherwise.

Syntax

public boolean canApplyStretchContrast(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value.

with ImGearContrastModes.AUTO argument value.

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) Method
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class > canApplyStretchContrast Method : canApplyStretchContrast(ImGearRasterPage,ImGearContrastModes) Method
page
Raster page object to verify.
mode
Contrast mode.

Glossary Item Box

Returns true, if ImGearRasterProcessing.stretchContrast method can be applied to the specified page with the specified contrast mode, false otherwise.

Syntax

public boolean canApplyStretchContrast(
   ImGearRasterPage page,
   ImGearContrastModes mode
)

Parameters

page
Raster page object to verify.
mode
Contrast mode.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearContrastModes

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members
Overload List


%%PageItemTitle%%

canApplyTabulateHistogram Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyTabulateHistogram Method
page
Raster page object to verify.

Glossary Item Box

Checks whether ImGearRasterProcessing.tabulateHistogram method can be applied to the page.

Syntax

public boolean canApplyTabulateHistogram(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.tabulateHistogram

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

canApplyTransformWithLUT Method
com.accusoft.imagegear.processing Package > ImGearRasterProcessingVerifier Class : canApplyTransformWithLUT Method
page
Raster page object to verify.

Glossary Item Box

Checks whether method can be applied to the page.

Syntax

public boolean canApplyTransformWithLUT(
   ImGearRasterPage page
)

Parameters

page
Raster page object to verify.

Return Value

Boolean value. com.accusoft.imagegear.core.ImGearRasterPage ImGearRasterProcessing.transformWithLUT

See Also

Reference

ImGearRasterProcessingVerifier Class
ImGearRasterProcessingVerifier Members


%%PageItemTitle%%

ImGearReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearReductionOptions Class

Glossary Item Box

Specifies options for performing color reduction using the ImGearRasterProcessing.reduce method.

The only options used by the ImGearRasterProcessing.reduce method are the ones which correspond to the type of reduction as specified by the reductionMethod parameter of the ImGearRasterProcessing.reduce method.

Object Model

ImGearReductionOptions Class

Syntax

public class ImGearReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearReductionOptions

See Also

Reference

ImGearReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearReductionOptions Constructor | Initializes a new instance of the ImGearReductionOptions class object. ImGearReductionOptions
Top

Public Fields

 | Name | Description
public Field | bayer | Specifies ImGearBayerReductionOptions class options for color reduction. ImGearBayerReductionOptions class object.
public Field | bitonal | Specifies ImGearBitonalReductionOptions class options for color reduction. ImGearBitonalReductionOptions class object.
public Field | diffuse | Specifies ImGearDiffuseReductionOptions class options for color reduction. ImGearDiffuseReductionOptions class object.
public Field | halftone | Specifies ImGearHalftoneReductionOptions class options for color reduction. ImGearHalftoneReductionOptions class object.
public Field | median | Specifies ImGearMedianCutReductionOptions class options for color reduction. ImGearMedianCutReductionOptions class object.
public Field | octree | Specifies ImGearOctreeReductionOptions class options for color reduction. ImGearOctreeReductionOptions class object.
public Field | popularity | Specifies ImGearPopularityReductionOptions class options for color reduction. ImGearPopularityReductionOptions class object.
public Field | scale | Specifies ImGearScaleReductionOptions class options for color reduction. ImGearScaleReductionOptions class object.
Top

See Also

Reference

ImGearReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : ImGearReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearReductionOptions class object.

ImGearReductionOptions

Syntax

public ImGearReductionOptions()

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearReductionOptions members.

Public Fields

 | Name | Description
public Field | bayer | Specifies ImGearBayerReductionOptions class options for color reduction. ImGearBayerReductionOptions class object.
public Field | bitonal | Specifies ImGearBitonalReductionOptions class options for color reduction. ImGearBitonalReductionOptions class object.
public Field | diffuse | Specifies ImGearDiffuseReductionOptions class options for color reduction. ImGearDiffuseReductionOptions class object.
public Field | halftone | Specifies ImGearHalftoneReductionOptions class options for color reduction. ImGearHalftoneReductionOptions class object.
public Field | median | Specifies ImGearMedianCutReductionOptions class options for color reduction. ImGearMedianCutReductionOptions class object.
public Field | octree | Specifies ImGearOctreeReductionOptions class options for color reduction. ImGearOctreeReductionOptions class object.
public Field | popularity | Specifies ImGearPopularityReductionOptions class options for color reduction. ImGearPopularityReductionOptions class object.
public Field | scale | Specifies ImGearScaleReductionOptions class options for color reduction. ImGearScaleReductionOptions class object.
Top

See Also

Reference

ImGearReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

bayer Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : bayer Field

Glossary Item Box

Specifies ImGearBayerReductionOptions class options for color reduction.

ImGearBayerReductionOptions class object.

Syntax

public ImGearBayerReductionOptions bayer

Return Value

ImGearBayerReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

bitonal Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : bitonal Field

Glossary Item Box

Specifies ImGearBitonalReductionOptions class options for color reduction.

ImGearBitonalReductionOptions class object.

Syntax

public ImGearBitonalReductionOptions bitonal

Return Value

ImGearBitonalReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

diffuse Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : diffuse Field

Glossary Item Box

Specifies ImGearDiffuseReductionOptions class options for color reduction.

ImGearDiffuseReductionOptions class object.

Syntax

public ImGearDiffuseReductionOptions diffuse

Return Value

ImGearDiffuseReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

halftone Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : halftone Field

Glossary Item Box

Specifies ImGearHalftoneReductionOptions class options for color reduction.

ImGearHalftoneReductionOptions class object.

Syntax

public ImGearHalftoneReductionOptions halftone

Return Value

ImGearHalftoneReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

median Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : median Field

Glossary Item Box

Specifies ImGearMedianCutReductionOptions class options for color reduction.

ImGearMedianCutReductionOptions class object.

Syntax

public ImGearMedianCutReductionOptions median

Return Value

ImGearMedianCutReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

octree Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : octree Field

Glossary Item Box

Specifies ImGearOctreeReductionOptions class options for color reduction.

ImGearOctreeReductionOptions class object.

Syntax

public ImGearOctreeReductionOptions octree

Return Value

ImGearOctreeReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

popularity Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : popularity Field

Glossary Item Box

Specifies ImGearPopularityReductionOptions class options for color reduction.

ImGearPopularityReductionOptions class object.

Syntax

public ImGearPopularityReductionOptions popularity

Return Value

ImGearPopularityReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

scale Field
com.accusoft.imagegear.processing Package > ImGearReductionOptions Class : scale Field

Glossary Item Box

Specifies ImGearScaleReductionOptions class options for color reduction.

ImGearScaleReductionOptions class object.

Syntax

public ImGearScaleReductionOptions scale

Return Value

ImGearScaleReductionOptions class object.

See Also

Reference

ImGearReductionOptions Class
ImGearReductionOptions Members


%%PageItemTitle%%

ImGearScaleReductionOptions Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearScaleReductionOptions Class

Glossary Item Box

Defines reduction options for scale reduction.

This class defines reduction options for scale reduction. Scale reduction can be performed on an image whose color space is anything but indexed. The output image will always have the same color space as the input image. It works by linearly scaling the component values for each pixel to the desired output depths. For example, you could reduce a 24bpp (8-8-8) RGB image to 16bpp (5-6-5) RGB. Simply specify the desired output channel depths (and color space) in the parameters for the reduce method.

Note: You can set dontScalePixels option to true to avoid scaling the pixel values. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different.

Object Model

ImGearScaleReductionOptions Class

Syntax

public class ImGearScaleReductionOptions
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearScaleReductionOptions

See Also

Reference

ImGearScaleReductionOptions Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearScaleReductionOptions Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.processing Package : ImGearScaleReductionOptions Class

Glossary Item Box

The following tables list the members exposed by ImGearScaleReductionOptions.

Public Constructors

 | Name | Description
public Constructor | ImGearScaleReductionOptions Constructor | Initializes a new instance of the ImGearScaleReductionOptions class object.
Top

Public Fields

 | Name | Description
public Field | dontScalePixels | Set to true to avoid scaling the pixel values. Boolean value. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different. For example, if you have a 16bpp grayscale image but each pixel value actually only ranges from 0-255, and you want 0 to represent black and 255 to represent white, it makes sense to set this option to true and avoid scaling the values. If scaling were used in such a case, the image would appear black since the brightest possible value (255) would be scaled down to almost nothing: (255/65535) * 255 = 1.
Top

See Also

Reference

ImGearScaleReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearScaleReductionOptions Constructor
com.accusoft.imagegear.processing Package > ImGearScaleReductionOptions Class : ImGearScaleReductionOptions Constructor

Glossary Item Box

Initializes a new instance of the ImGearScaleReductionOptions class object.

Syntax

public ImGearScaleReductionOptions()

See Also

Reference

ImGearScaleReductionOptions Class
ImGearScaleReductionOptions Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearScaleReductionOptions Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearScaleReductionOptions Class

Glossary Item Box

For a list of all members of this type, see ImGearScaleReductionOptions members.

Public Fields

 | Name | Description
public Field | dontScalePixels | Set to true to avoid scaling the pixel values. Boolean value. In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different. For example, if you have a 16bpp grayscale image but each pixel value actually only ranges from 0-255, and you want 0 to represent black and 255 to represent white, it makes sense to set this option to true and avoid scaling the values. If scaling were used in such a case, the image would appear black since the brightest possible value (255) would be scaled down to almost nothing: (255/65535) * 255 = 1.
Top

See Also

Reference

ImGearScaleReductionOptions Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

dontScalePixels Field
com.accusoft.imagegear.processing Package > ImGearScaleReductionOptions Class : dontScalePixels Field

Glossary Item Box

Set to true to avoid scaling the pixel values.

Boolean value.

In this case, the component values of each pixel will be preserved (within the limits of precision) even though their effective ranges may be different. For example, if you have a 16bpp grayscale image but each pixel value actually only ranges from 0-255, and you want 0 to represent black and 255 to represent white, it makes sense to set this option to true and avoid scaling the values. If scaling were used in such a case, the image would appear black since the brightest possible value (255) would be scaled down to almost nothing: (255/65535) * 255 = 1.

Syntax

public boolean dontScalePixels

Return Value

Boolean value.

See Also

Reference

ImGearScaleReductionOptions Class
ImGearScaleReductionOptions Members


%%PageItemTitle%%

ImGearWhiteBalance Class
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : ImGearWhiteBalance Class

Glossary Item Box

Represents white balance as a pair of color temperature and tint.

Object Model

ImGearWhiteBalance ClassImGearDoublePoint Class

Syntax

public sealed class ImGearWhiteBalance
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.ImGearWhiteBalance

See Also

Reference

ImGearWhiteBalance Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearWhiteBalance Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : ImGearWhiteBalance Class

Glossary Item Box

The following tables list the members exposed by ImGearWhiteBalance.

Public Constructors

 | Name | Description
public Constructor | ImGearWhiteBalance Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | getTemperature | Returns the color temperature. ImGearWhiteBalancePreset
public Method | getTint | Returns the tint. ImGearWhiteBalancePreset
public Method | getWhiteXY | Returns XY coordinates of white point, corresponding to the color temperature.
public Method | setTemperature | Sets the color temperature. ImGearWhiteBalancePreset
public Method | setTint | Sets the tint. ImGearWhiteBalancePreset
Top

See Also

Reference

ImGearWhiteBalance Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearWhiteBalance Constructor
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : ImGearWhiteBalance Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearWhiteBalance Constructor(double,double) | Initializes a new instance of the ImGearWhiteBalancePreset class.
ImGearWhiteBalance Constructor(ImGearDoublePoint) | Initializes a new instance of the ImGearWhiteBalancePreset class from XY coordinates of a white point.
ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset) | Initializes a new instance of the ImGearWhiteBalancePreset class using preset values.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

ImGearWhiteBalance Constructor(double,double)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(double,double)
temperature
Color temperature in Kelvins.
tint
Tint value.

Setting a greater temperature for an image results in more yellow color; lower temperature results in more blue color. Useful range for Temperature is between 2000 and 10000.

Setting a greater tint value for an image results in a more magenta color, lower tint values result in a greener color. Useful range for Tint is between -50 and 50.

ImGearWhiteBalancePreset

Glossary Item Box

Initializes a new instance of the ImGearWhiteBalancePreset class.

Syntax

public ImGearWhiteBalance(
   double temperature,
   double tint
)

Parameters

temperature
Color temperature in Kelvins.
tint
Tint value.

Setting a greater temperature for an image results in more yellow color; lower temperature results in more blue color. Useful range for Temperature is between 2000 and 10000.

Setting a greater tint value for an image results in a more magenta color, lower tint values result in a greener color. Useful range for Tint is between -50 and 50.

ImGearWhiteBalancePreset

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List


%%PageItemTitle%%

ImGearWhiteBalance Constructor(ImGearDoublePoint)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(ImGearDoublePoint)
whitePoint
Coordinates of a white point. ImGearWhiteBalancePreset com.accusoft.imagegear.core.shapes.ImGearDoublePoint

Glossary Item Box

Initializes a new instance of the ImGearWhiteBalancePreset class from XY coordinates of a white point.

Syntax

public ImGearWhiteBalance(
   ImGearDoublePoint whitePoint
)

Parameters

whitePoint
Coordinates of a white point. ImGearWhiteBalancePreset com.accusoft.imagegear.core.shapes.ImGearDoublePoint

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List


%%PageItemTitle%%

ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset)
See Also Send Feedback
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class > ImGearWhiteBalance Constructor : ImGearWhiteBalance Constructor(ImGearWhiteBalancePreset)
preset
Preset white balance identifier. ImGearWhiteBalancePreset ImGearWhiteBalancePreset

Glossary Item Box

Initializes a new instance of the ImGearWhiteBalancePreset class using preset values.

Syntax

public ImGearWhiteBalance(
   ImGearWhiteBalancePreset preset
)

Parameters

preset
Preset white balance identifier. ImGearWhiteBalancePreset ImGearWhiteBalancePreset

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearWhiteBalance Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : ImGearWhiteBalance Class

Glossary Item Box

For a list of all members of this type, see ImGearWhiteBalance members.

Public Methods

 | Name | Description
public Method | getTemperature | Returns the color temperature. ImGearWhiteBalancePreset
public Method | getTint | Returns the tint. ImGearWhiteBalancePreset
public Method | getWhiteXY | Returns XY coordinates of white point, corresponding to the color temperature.
public Method | setTemperature | Sets the color temperature. ImGearWhiteBalancePreset
public Method | setTint | Sets the tint. ImGearWhiteBalancePreset
Top

See Also

Reference

ImGearWhiteBalance Class
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

getTemperature Method
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : getTemperature Method

Glossary Item Box

Returns the color temperature.

ImGearWhiteBalancePreset

Syntax

public double getTemperature()

Return Value

Double value.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

getTint Method
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : getTint Method

Glossary Item Box

Returns the tint.

ImGearWhiteBalancePreset

Syntax

public double getTint()

Return Value

Double value.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

getWhiteXY Method
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : getWhiteXY Method

Glossary Item Box

Returns XY coordinates of white point, corresponding to the color temperature.

Syntax

public ImGearDoublePoint getWhiteXY()

Return Value

com.accusoft.imagegear.core.shapes.ImGearDoublePoint structure. com.accusoft.imagegear.core.shapes.ImGearDoublePoint ImGearWhiteBalancePreset

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

setTemperature Method
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : setTemperature Method
value
Double value.

Glossary Item Box

Sets the color temperature.

ImGearWhiteBalancePreset

Syntax

public void setTemperature(
   double value
)

Parameters

value
Double value.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

setTint Method
com.accusoft.imagegear.processing Package > ImGearWhiteBalance Class : setTint Method
value
Double value.

Glossary Item Box

Sets the tint.

ImGearWhiteBalancePreset

Syntax

public void setTint(
   double value
)

Parameters

value
Double value.

See Also

Reference

ImGearWhiteBalance Class
ImGearWhiteBalance Members


%%PageItemTitle%%

ImGearBitonalReductionModes Enumeration
com.accusoft.imagegear.processing Package : ImGearBitonalReductionModes Enumeration

Glossary Item Box

Specifies modes for the bitonal color reduction method.

Please, see ImGearBitonalReductionOptions class reference.

Members

Member | Description
AVERAGE | Average mode.
GRAYSCALE | Grayscale mode.
WEIGHTED | Weighted mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearBitonalReductionModes

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearBrushType Enumeration
com.accusoft.imagegear.processing Package : ImGearBrushType Enumeration

Glossary Item Box

Specifies brush types for Pointillist effect.

Members

Member | Description
Points | Each point is a randomly shaped polygon whose shape imitates a paint brush contacting the canvas.
Sticker | Each point is a circle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearBrushType

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearCFAColor Enumeration
com.accusoft.imagegear.processing Package : ImGearCFAColor Enumeration

Glossary Item Box

Specifies the available colors for Color Filter Array encoded images.

Members

Member | Description
Blue | Blue color.
Cyan | Cyan color.
Green | Green color.
Magenta | Magenta color.
Red | Red color.
White | White color.
Yellow | Yellow color.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearCFAColor

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearChannelGroups Enumeration
com.accusoft.imagegear.processing Package : ImGearChannelGroups Enumeration

Glossary Item Box

Specifies groups of DIB channels.

These values are passed to the com.accusoft.imagegear.core.ImGearChannelRange structure constructor.

Members

Member | Description
ALL | All channels.
ALPHA | Alpha channel.
ALPHA_EXTRA | Alpha and extra channels.
COLOR | Color channels.
COLOR_ALPHA | Color and alpha channels.
EXTRA | Extra channels.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearChannelGroups

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearContrastModes Enumeration
com.accusoft.imagegear.processing Package : ImGearContrastModes Enumeration

Glossary Item Box

Specifies contrast processing modes.

Members

Member | Description
AUTO | If image is Indexed and its palette is not grayscale, applies contrast on palette; otherwise applies contrast on pixels.
PALETTE | Applies contrast on image palette. If the image does not have a palette, an exception is generated.
PIXEL | Applies contrast on image pixels.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearContrastModes

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearConvolutionResults Enumeration
com.accusoft.imagegear.processing Package : ImGearConvolutionResults Enumeration

Glossary Item Box

Specifies types of convolution result.

Members

Member | Description
ABS | Absolute value of the signed result is stored.
CENTERED | Result is stored as 8-bit signed, but 0 is equal to 0x7F. Positive numbers are from 0x7E to 0x00. Negative numbers are from 0x80 to 0xFF. This is used for images that are to be used as background tiles or watermarks.
RAW | Result is stored as is.
SIGNED | Result is stored as 8-bit signed values.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearConvolutionResults

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearDirection Enumeration
com.accusoft.imagegear.processing Package : ImGearDirection Enumeration

Glossary Item Box

Defines a direction of a shadow effect (location of the light source).

Members

Member | Description
East | East location.
North | North location.
NorthEast | NorthEast location.
NorthWest | NorthWest location.
South | South location.
SouthEast | SouthEast location.
SouthWest | SouthWest location.
West | West location.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearDirection

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearEdgeDetectionMethods Enumeration
com.accusoft.imagegear.processing Package : ImGearEdgeDetectionMethods Enumeration

Glossary Item Box

Defines the edge detection methods supported by ImageGear.

Members

Member | Description
DIFF_RECURSIVE | Edge detection using an optimal difference recursive filter.
MAXGRADIENT | Edge detection using the maxima of gradient, i.e., maxima of the first order derivative.
ZEROXC_DERIV2ND | Edge detection using the zero-crossings of second order derivative along the gradient.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearEdgeDetectionMethods

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearEdgeMapMethods Enumeration
com.accusoft.imagegear.processing Package : ImGearEdgeMapMethods Enumeration

Glossary Item Box

Specifies types of edge map operation.

Members

Member | Description
DIAG_NEG_45 | Diagonal negative edge map.
DIAG_POS_45 | Diagonal positive edge map.
HORIZONTAL | Horizontal edge map.
LAPLACIAN | Laplacian edge map.
LOG | Laplacian of Gaussian edge map.
PREWITT | Prewitt edge map.
ROBERTS | Roberts edge map.
SOBEL | Sobel edge map.
VERTICAL | Vertical edge map.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearEdgeMapMethods

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearHalftoneReductionModes Enumeration
com.accusoft.imagegear.processing Package : ImGearHalftoneReductionModes Enumeration

Glossary Item Box

Specifies mode of halftone color reduction method.

See ImGearHalftoneReductionOptions class description for more details.

Members

Member | Description
SQUARES | Squares mode.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearHalftoneReductionModes

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearIlluminant Enumeration
com.accusoft.imagegear.processing Package : ImGearIlluminant Enumeration

Glossary Item Box

Lists standard illuminants.

Members

Member | Description
CloudyWeather | CloudyWeather illuminant.
CoolWhiteFluorescent | CoolWhiteFluorescent illuminant.
D50 | D50 illuminant.
D55 | D55 illuminant.
D65 | D65 illuminant.
D75 | D75 illuminant.
Daylight | Daylight illuminant.
DaylightFluorescent | DaylightFluorescent illuminant.
DayWhiteFluorescent | DayWhiteFluorescent illuminant.
FineWeather | FineWeather illuminant.
Flash | Flash illuminant.
Fluorescent | Fluorescent illuminant.
ISOStudioTungsten | ISOStudioTungsten illuminant.
Other | Other illuminant.
Shade | Shade illuminant.
StandardA | StandardA illuminant.
StandardB | StandardB illuminant.
StandardC | StandardC illuminant.
Tungsten | Tungsten illuminant.
Unknown | Unknown illuminant.
WhiteFluorescent | WhiteFluorescent illuminant.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearIlluminant

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearInterpolations Enumeration
com.accusoft.imagegear.processing Package : ImGearInterpolations Enumeration

Glossary Item Box

Specifies type of interpolation method.

Members

Member | Description
AVERAGE | Average value interpolation.
BICUBIC | Bicubic interpolation.
BILINEAR | Bilinear interpolation.
GRAYSCALE | Grayscale interpolation.
NEAREST_NEIGHBOR | Nearest neighborhood interpolation.
NONE | No interpolation.
PRESERVE_BLACK | Interpolation method that preserves black pixels.
PRESERVE_WHITE | Interpolation method that preserves white pixels.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearInterpolations

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearLensFlareType Enumeration
com.accusoft.imagegear.processing Package : ImGearLensFlareType Enumeration

Glossary Item Box

Specifies types of lens flare effects.

Members

Member | Description
Digital | Digital camera lens.
Prime35mm | 35mm prime lens.
Rainbow | Rainbow halo effect.
Zoom50_300 | 50-300mm zoom lens.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearLensFlareType

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearMergeModes Enumeration
com.accusoft.imagegear.processing Package : ImGearMergeModes Enumeration

Glossary Item Box

Identifies the type of arithmetic operation (merge method) that is performed on the values of all intersecting pixels resulting from the merge.

For example, if you set ARITH_ADD merge method, the resulting pixel values (of those pixels that intersected from the two images) equal the sum of the value of the pixel in the original image and the value of pixel in the image being merged.

Members

Member | Description
ADD | Img1 = Img1 + Img2..
ADD_SIGN_CENTERED | Img1 = Img1+ SC_Img2.
AND | Img1 = Img1 & Img2.
DIVIDE | Img1 = Img1 / Img2.
MULT | Img1 = Img1 * Img2.
NOT | Img1 = ~Img1.
OR | Img1 = Img1 | Img2.
OVER | Img1 = Img2.
SUB | Img1 = Img1 - Img2.
XOR | Img1 = Img1 ^ Img2.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearMergeModes

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearMosaicType Enumeration
com.accusoft.imagegear.processing Package : ImGearMosaicType Enumeration

Glossary Item Box

Defines a type of Mosaic effect.

Members

Member | Description
Cartesian | Mosaic is drawn in Cartesian coordinate system.
Polar | Mosaic is drawn in Polar coordinate system.
Spiderweb | Mosaic is drawn in Polar coordinate system, but segments of circles between radial lines are straight.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearMosaicType

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearNightVisionPresets Enumeration
com.accusoft.imagegear.processing Package : ImGearNightVisionPresets Enumeration

Glossary Item Box

Specifies Night Vision effects supported by ImageGear.

Members

Member | Description
Binoculars | Night vision goggles effect.
Camera | General night vision camera effect.
Martian | Martian view effect.
Moonlight | Moon view effect.
Sniper | Night vision weapon sight effect.
SpyPhoto | Spy camera effect.
Television | Old television effect.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearNightVisionPresets

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPixelateCellType Enumeration
com.accusoft.imagegear.processing Package : ImGearPixelateCellType Enumeration

Glossary Item Box

Defines cell types for Pixelate operation.

Members

Member | Description
Circle | The cell is a circle.
Rectangle | The cell is rounded or non-rounded rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearPixelateCellType

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearPixelateFillMethod Enumeration
com.accusoft.imagegear.processing Package : ImGearPixelateFillMethod Enumeration

Glossary Item Box

Defines fill methods for Pixelate operation.

Members

Member | Description
Average | The cell is filled with an average color of the cell rectangle.
Center | The cell is filled with a color on the center of the cell rectangle.
Color | Every cell is filled with a specified color.
Maximum | The cell is filled with a maximum color of the cell rectangle.
Minimum | The cell is filled with a minimum color of the cell rectangle.
Random | The cell is filled with a randomly chosen color of the cell rectangle.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearPixelateFillMethod

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearReductionMethods Enumeration
com.accusoft.imagegear.processing Package : ImGearReductionMethods Enumeration

Glossary Item Box

Specifies ImageGear color reduction methods.

Members

Member | Description
BAYER | Bayer color reduction method.
BITONAL | Bitonal color reduction method.
DIFFUSE | Diffuse color reduction method.
HALFTONE | Halftone color reduction method.
MEDIAN | Median color reduction method.
OCTREE | Octree color reduction method.
POPULARITY | Popularity color reduction method.
SCALE | Scale color reduction method.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearReductionMethods

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearRipplePattern Enumeration
com.accusoft.imagegear.processing Package : ImGearRipplePattern Enumeration

Glossary Item Box

Specifies predefined patterns for the Ripple effect.

Members

Member | Description
Pattern0 | Ripple pattern 0.
Pattern1 | Ripple pattern 1.
Pattern2 | Ripple pattern 2.
Pattern3 | Ripple pattern 3.
Pattern4 | Ripple pattern 4.
Pattern5 | Ripple pattern 5.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearRipplePattern

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearRotationModes Enumeration
com.accusoft.imagegear.processing Package : ImGearRotationModes Enumeration

Glossary Item Box

Specifies ImageGear rotation mode.

Members

Member | Description
CLIP | Clips rotated image to keep the image dimensions unchanged.
EXPAND | Expands the size of the bitmap if necessary to retain the entire rotated image.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearRotationModes

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearShearFillStyle Enumeration
com.accusoft.imagegear.processing Package : ImGearShearFillStyle Enumeration

Glossary Item Box

Specifies fill styles for the Shear effect.

Members

Member | Description
FillColor | Empty area is filled with the specified color.
NoChange | Empty area remains unchanged.
RepeatEdge | Empty area is filled with the first or last raster color.
RepeatRaster | The raster is repeated periodically across the empty area.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearShearFillStyle

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

ImGearWhiteBalancePreset Enumeration
com.accusoft.imagegear.processing Package : ImGearWhiteBalancePreset Enumeration

Glossary Item Box

Lists constants for preset white balance values.

Members

Member | Description
Cloudy | Cloudy balance.
Daylight | Daylight balance.
Flash | Flash balance.
Fluorescent | Fluorescent balance.
Shade | Shade balance.
Tungsten | Tungsten balance.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.ImGearWhiteBalancePreset

See Also

Reference

com.accusoft.imagegear.processing Package


%%PageItemTitle%%

IImGearPixelProcessor Interface
See Also Members Send Feedback
com.accusoft.imagegear.processing Package : IImGearPixelProcessor Interface

Glossary Item Box

An implementation of this interface is passed to ProcessArea method.

This interface declares one method processPixel which must be implemented by the user.

Syntax

public interface IImGearPixelProcessor

See Also

Reference

IImGearPixelProcessor Members
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearPixelProcessor Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing Package : IImGearPixelProcessor Interface

Glossary Item Box

The following tables list the members exposed by IImGearPixelProcessor.

Public Methods

 | Name | Description
Method | processPixel | The method must return the new pixel after processing.
Top

See Also

Reference

IImGearPixelProcessor Interface
com.accusoft.imagegear.processing Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearPixelProcessor Interface Methods
See Also Send Feedback
com.accusoft.imagegear.processing Package : IImGearPixelProcessor Interface

Glossary Item Box

For a list of all members of this type, see IImGearPixelProcessor members.

Public Methods

 | Name | Description
Method | processPixel | The method must return the new pixel after processing.
Top

See Also

Reference

IImGearPixelProcessor Interface
com.accusoft.imagegear.processing Package


%%PageItemTitle%%

processPixel Method
com.accusoft.imagegear.processing Package > IImGearPixelProcessor Interface : processPixel Method
pixel
The pixel to be processed.

Glossary Item Box

The method must return the new pixel after processing.

Syntax

ImGearPixel processPixel(
   ImGearPixel pixel
)

Parameters

pixel
The pixel to be processed.

Return Value

com.accusoft.imagegear.core.ImGearPixel class object. com.accusoft.imagegear.core.ImGearPixel

See Also

Reference

IImGearPixelProcessor Interface
IImGearPixelProcessor Members


%%ItemTitle%%

com.accusoft.imagegear.processing.layers Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This package provides an API for creating and editing image layers. It also introduces a new type of ImGearLayeredPage class, which consists of two parts: raster composition image and array of layers.

Classes

Class | Description
ImGearImageLayer | Represents image layer and its attributes. Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.
ImGearLayer | Represents generic layer and its attributes. Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.
ImGearLayerArray | Defines composition of layers. The composition of layers from a Adobe PSD image is stored in the array of layers associated with the ImGearLayeredPage. Users can manipulate the composition by creating new layers, editing and deleting the existing ones using this class.
ImGearLayeredPage | Represents a page with image layers. Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.

Enumerations

Enumeration | Description
ImGearLayerType | Supported layer types.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.processing.layers Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.core.ImGearRasterPage
com.accusoft.imagegear.core.ImGearPage
com.accusoft.imagegear.processing.layers.ImGearLayeredPage
com.accusoft.imagegear.processing.layers.ImGearLayer
com.accusoft.imagegear.processing.layers.ImGearLayerArray

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearImageLayer Class
See Also Members Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearImageLayer Class

Glossary Item Box

Represents image layer and its attributes.

Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.

Object Model

ImGearImageLayer ClassImGearLayer ClassImGearPage ClassImGearPoint ClassImGearLayerType Enumeration

Syntax

public class ImGearImageLayer
    extends ImGearLayer

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.layers.ImGearLayer
com.accusoft.imagegear.processing.layers.ImGearImageLayer

See Also

Reference

ImGearImageLayer Members
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearImageLayer Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearImageLayer Class

Glossary Item Box

The following tables list the members exposed by ImGearImageLayer.

Public Constructors

 | Name | Description
public Constructor | ImGearImageLayer Constructor | Initializes a new instance of the ImGearImageLayer class from the specified raster page.
Top

Protected Fields

 | Name | Description
protected Field | opacity | Level of opacity for the image layer. Integer value.
protected Field | point | Rectangle specifying the location of the image layer. com.accusoft.imagegear.core.shapes.ImGearPoint structure.
Top

Public Methods

 | Name | Description
public Method | getImage | Gets image specifying the layer. com.accusoft.imagegear.core.ImGearPage class object. This method returns the image to put in the layer.
public Method | getLocation | Returns rectangle specifying the location of the image layer.
public Method | getOpacity | Returns level of opacity for the image layer.
public Method | getType | Image layer type. ImGearLayerType value.
public Method | setLocation | Sets rectangle specifying the location of the image layer.
public Method | setOpacity | Sets level of opacity for the image layer.
Top

See Also

Reference

ImGearImageLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

ImGearImageLayer Constructor
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : ImGearImageLayer Constructor
page
Raster page to create layer from. com.accusoft.imagegear.core.ImGearPage

Glossary Item Box

Initializes a new instance of the ImGearImageLayer class from the specified raster page.

Syntax

public ImGearImageLayer(
   ImGearPage page
)

Parameters

page
Raster page to create layer from. com.accusoft.imagegear.core.ImGearPage

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearImageLayer Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearImageLayer Class

Glossary Item Box

For a list of all members of this type, see ImGearImageLayer members.

Public Methods

 | Name | Description
public Method | getImage | Gets image specifying the layer. com.accusoft.imagegear.core.ImGearPage class object. This method returns the image to put in the layer.
public Method | getLocation | Returns rectangle specifying the location of the image layer.
public Method | getOpacity | Returns level of opacity for the image layer.
public Method | getType | Image layer type. ImGearLayerType value.
public Method | setLocation | Sets rectangle specifying the location of the image layer.
public Method | setOpacity | Sets level of opacity for the image layer.
Top

See Also

Reference

ImGearImageLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

getImage Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : getImage Method

Glossary Item Box

Gets image specifying the layer.

com.accusoft.imagegear.core.ImGearPage class object.

This method returns the image to put in the layer.

Syntax

public ImGearPage getImage()

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

getLocation Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : getLocation Method

Glossary Item Box

Returns rectangle specifying the location of the image layer.

Syntax

public ImGearPoint getLocation()

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

getOpacity Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : getOpacity Method

Glossary Item Box

Returns level of opacity for the image layer.

Syntax

public int getOpacity()

Return Value

Integer value.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : getType Method

Glossary Item Box

Image layer type.

ImGearLayerType value.

Syntax

public ImGearLayerType getType()

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

setLocation Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : setLocation Method
value
com.accusoft.imagegear.core.shapes.ImGearPoint structure.

Glossary Item Box

Sets rectangle specifying the location of the image layer.

Syntax

public void setLocation(
   ImGearPoint value
)

Parameters

value
com.accusoft.imagegear.core.shapes.ImGearPoint structure.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

setOpacity Method
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : setOpacity Method
value
Integer value.

Glossary Item Box

Sets level of opacity for the image layer.

Syntax

public void setOpacity(
   int value
)

Parameters

value
Integer value.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearImageLayer Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearImageLayer Class

Glossary Item Box

For a list of all members of this type, see ImGearImageLayer members.

Protected Fields

 | Name | Description
protected Field | opacity | Level of opacity for the image layer. Integer value.
protected Field | point | Rectangle specifying the location of the image layer. com.accusoft.imagegear.core.shapes.ImGearPoint structure.
Top

See Also

Reference

ImGearImageLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

opacity Field
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : opacity Field

Glossary Item Box

Level of opacity for the image layer.

Integer value.

Syntax

protected int opacity

Return Value

Integer value.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

point Field
com.accusoft.imagegear.processing.layers Package > ImGearImageLayer Class : point Field

Glossary Item Box

Rectangle specifying the location of the image layer.

com.accusoft.imagegear.core.shapes.ImGearPoint structure.

Syntax

protected ImGearPoint point

Return Value

com.accusoft.imagegear.core.shapes.ImGearPoint structure.

See Also

Reference

ImGearImageLayer Class
ImGearImageLayer Members


%%PageItemTitle%%

ImGearLayer Class
See Also Members Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayer Class

Glossary Item Box

Represents generic layer and its attributes.

Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.

Object Model

ImGearLayer ClassImGearLayer ClassImGearLayerType Enumeration

Syntax

public class ImGearLayer
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.layers.ImGearLayer
com.accusoft.imagegear.processing.layers.ImGearImageLayer

See Also

Reference

ImGearLayer Members
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLayer Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayer Class

Glossary Item Box

The following tables list the members exposed by ImGearLayer.

Protected Fields

 | Name | Description
protected Field | name | Specifies name of the layer. String value.
protected Field | visible | Specifies visibility state of the layer. Boolean value.
Top

Public Methods

 | Name | Description
public Method | clone | Clones the layer.
public Method | getName | Returns the name of the layer.
public Method | getType | Gets the type of the layer. ImGearLayerType enumeration value.
public Method | isVisible | Returns a value indicating whether the layer is visible.
public Method | setName | Sets the name of the layer.
public Method | setVisibility | Sets a value indicating whether the layer is visible.
Top

See Also

Reference

ImGearLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLayer Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayer Class

Glossary Item Box

For a list of all members of this type, see ImGearLayer members.

Public Methods

 | Name | Description
public Method | clone | Clones the layer.
public Method | getName | Returns the name of the layer.
public Method | getType | Gets the type of the layer. ImGearLayerType enumeration value.
public Method | isVisible | Returns a value indicating whether the layer is visible.
public Method | setName | Sets the name of the layer.
public Method | setVisibility | Sets a value indicating whether the layer is visible.
Top

See Also

Reference

ImGearLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : clone Method

Glossary Item Box

Clones the layer.

Syntax

public ImGearLayer clone()

Return Value

Returns a copy of the layer. ImGearLayer

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

getName Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : getName Method

Glossary Item Box

Returns the name of the layer.

Syntax

public java.lang.String getName()

Return Value

String value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

getType Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : getType Method

Glossary Item Box

Gets the type of the layer.

ImGearLayerType enumeration value.

Syntax

public ImGearLayerType getType()

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

isVisible Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : isVisible Method

Glossary Item Box

Returns a value indicating whether the layer is visible.

Syntax

public boolean isVisible()

Return Value

Boolean value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

setName Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : setName Method
value
String value.

Glossary Item Box

Sets the name of the layer.

Syntax

public void setName(
   java.lang.String value
)

Parameters

value
String value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

setVisibility Method
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : setVisibility Method
value
Boolean value.

Glossary Item Box

Sets a value indicating whether the layer is visible.

Syntax

public void setVisibility(
   boolean value
)

Parameters

value
Boolean value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearLayer Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayer Class

Glossary Item Box

For a list of all members of this type, see ImGearLayer members.

Protected Fields

 | Name | Description
protected Field | name | Specifies name of the layer. String value.
protected Field | visible | Specifies visibility state of the layer. Boolean value.
Top

See Also

Reference

ImGearLayer Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

name Field
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : name Field

Glossary Item Box

Specifies name of the layer.

String value.

Syntax

protected java.lang.String name

Return Value

String value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

visible Field
com.accusoft.imagegear.processing.layers Package > ImGearLayer Class : visible Field

Glossary Item Box

Specifies visibility state of the layer.

Boolean value.

Syntax

protected boolean visible

Return Value

Boolean value.

See Also

Reference

ImGearLayer Class
ImGearLayer Members


%%PageItemTitle%%

ImGearLayerArray Class
See Also Members Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayerArray Class

Glossary Item Box

Defines composition of layers.

The composition of layers from a Adobe PSD image is stored in the array of layers associated with the ImGearLayeredPage. Users can manipulate the composition by creating new layers, editing and deleting the existing ones using this class.

Object Model

ImGearLayerArray ClassImGearLayerArray ClassImGearLayer ClassImGearLayer Class

Syntax

public class ImGearLayerArray
    extends Object
    implements java.util.List

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.processing.layers.ImGearLayerArray

See Also

Reference

ImGearLayerArray Members
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLayerArray Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayerArray Class

Glossary Item Box

The following tables list the members exposed by ImGearLayerArray.

Public Constructors

 | Name | Description
public Constructor | ImGearLayerArray Constructor | Initializes a new instance of the ImGearLayerArray class. Created layer array is empty.
Top

Public Methods

Name | Description
public Method | add | Overloaded. Adds a new layer to the array.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | clear | Removes all of the layers from the array.
public Method | clone | Clones the array of layers.
public Method | contains | Checks if the array contains the specified layer. ImGearLayer
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | copyTo | Copies the current array of layers into the specified array at specified position.
public Method | get | Specifies a reference to the indexed element of array.
public Method | indexOf | Gets the index of the specified layer.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | remove | Overloaded. Removes the specified layer from the array.
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Sets the page at the specified index.
public Method | size | Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Top

See Also

Reference

ImGearLayerArray Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

ImGearLayerArray Constructor
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : ImGearLayerArray Constructor

Glossary Item Box

Initializes a new instance of the ImGearLayerArray class. Created layer array is empty.

Syntax

public ImGearLayerArray()

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLayerArray Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayerArray Class

Glossary Item Box

For a list of all members of this type, see ImGearLayerArray members.

Public Methods

Name | Description
public Method | add | Overloaded. Adds a new layer to the array.
public Method | addAll | Overloaded. Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
public Method | clear | Removes all of the layers from the array.
public Method | clone | Clones the array of layers.
public Method | contains | Checks if the array contains the specified layer. ImGearLayer
public Method | containsAll | Returns true if this list contains all of the elements of the specified collection.
public Method | copyTo | Copies the current array of layers into the specified array at specified position.
public Method | get | Specifies a reference to the indexed element of array.
public Method | indexOf | Gets the index of the specified layer.
public Method | isEmpty | Returns true if this list contains no elements.
public Method | iterator | Returns an iterator over the elements in this list in proper sequence.
public Method | lastIndexOf | Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.
public Method | listIterator | Overloaded. Returns a list iterator over the elements in this list (in proper sequence).
public Method | remove | Overloaded. Removes the specified layer from the array.
public Method | removeAll | Removes from this list all of its elements that are contained in the specified collection (optional operation).
public Method | retainAll | Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.
public Method | set | Sets the page at the specified index.
public Method | size | Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.
public Method subList Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

public Method toArray Overloaded. Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Top

See Also

Reference

ImGearLayerArray Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : add Method

Glossary Item Box

Adds a new layer to the array.

Overload List

Overload | Description
add(ImGearLayer) | Adds a new layer to the array.
add(int,ImGearLayer) | Insets the specified layer at the specified position in the array.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

add(ImGearLayer) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > add Method : add(ImGearLayer) Method
layer
New layer to add.

Glossary Item Box

Adds a new layer to the array.

Syntax

public boolean add(
   ImGearLayer layer
)

Parameters

layer
New layer to add.

Return Value

true

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

add(int,ImGearLayer) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > add Method : add(int,ImGearLayer) Method
index
Position in the current array to insert layer to.
layer
Layer to insert. ImGearLayer

Glossary Item Box

Insets the specified layer at the specified position in the array.

Syntax

public void add(
   int index,
   ImGearLayer layer
)

Parameters

index
Position in the current array to insert layer to.
layer
Layer to insert. ImGearLayer

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

addAll Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : addAll Method

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Overload List

Overload | Description
addAll(Collection<?>) | Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)
addAll(int,Collection<?>) | Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

addAll(Collection<?>) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > addAll Method : addAll(Collection<?>) Method
c
collection containing elements to be added to this list

Glossary Item Box

Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation). The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List
add(ImGearLayer) Method


%%PageItemTitle%%

addAll(int,Collection<?>) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > addAll Method : addAll(int,Collection<?>) Method
index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Glossary Item Box

Inserts all of the elements in the specified collection into this list at the specified position (optional operation). Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in this list in the order that they are returned by the specified collection's iterator. The behavior of this operation is undefined if the specified collection is modified while the operation is in progress. (Note that this will occur if the specified collection is this list, and it's nonempty.)

Syntax

public boolean addAll(
   int index,
   java.util.Collection<?> c
)

Parameters

index
index at which to insert the first element from the specified collection
c
collection containing elements to be added to this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |
java.lang.IllegalArgumentException |
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

clear Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : clear Method

Glossary Item Box

Removes all of the layers from the array.

Syntax

public void clear()

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : clone Method

Glossary Item Box

Clones the array of layers.

Syntax

public ImGearLayerArray clone()

Return Value

ImGearLayerArray class object.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

contains Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : contains Method
o

Glossary Item Box

Checks if the array contains the specified layer. ImGearLayer

Syntax

public boolean contains(
   java.lang.Object o
)

Parameters

o

Return Value

Boolean value.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

containsAll Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : containsAll Method
c
collection to be checked for containment in this list

Glossary Item Box

Returns true if this list contains all of the elements of the specified collection.

Syntax

public boolean containsAll(
   java.util.Collection<?> c
)

Parameters

c
collection to be checked for containment in this list

Return Value

true if this list contains all of the elements of the specified collection

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
contains Method


%%PageItemTitle%%

copyTo Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : copyTo Method
array
Destination array.
index
Position in the destination array to copy to.

Glossary Item Box

Copies the current array of layers into the specified array at specified position.

Syntax

public void copyTo(
   java.lang.Object[] array,
   int index
)

Parameters

array
Destination array.
index
Position in the destination array to copy to.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

get Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : get Method
index
The indexed element.

Glossary Item Box

Specifies a reference to the indexed element of array.

Syntax

public ImGearLayer get(
   int index
)

Parameters

index
The indexed element.

Return Value

ImGearLayer class object.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

indexOf Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : indexOf Method
o

Glossary Item Box

Gets the index of the specified layer.

Syntax

public int indexOf(
   java.lang.Object o
)

Parameters

o

Return Value

Integer value.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

isEmpty Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : isEmpty Method

Glossary Item Box

Returns true if this list contains no elements.

Syntax

public boolean isEmpty()

Return Value

true if this list contains no elements

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

iterator Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : iterator Method

Glossary Item Box

Returns an iterator over the elements in this list in proper sequence.

Syntax

public java.util.Iterator<ImGearLayer> iterator()

Return Value

an iterator over the elements in this list in proper sequence

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

lastIndexOf Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : lastIndexOf Method
o
element to search for

Glossary Item Box

Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element. More formally, returns the highest index i such that (o==null ? get(i)==null : o.equals(get(i))), or -1 if there is no such index.

Syntax

public int lastIndexOf(
   java.lang.Object o
)

Parameters

o
element to search for

Return Value

the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element

Exceptions

Exception | Description
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

listIterator Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : listIterator Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Overload List

Overload | Description
listIterator() | Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) | Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to next. An initial call to previous would return the element with the specified index minus one.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

listIterator() Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > listIterator Method : listIterator() Method

Glossary Item Box

Returns a list iterator over the elements in this list (in proper sequence).

Syntax

public java.util.ListIterator<ImGearLayer> listIterator()

Return Value

a list iterator over the elements in this list (in proper sequence)

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

listIterator(int) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > listIterator Method : listIterator(int) Method
index
index of first element to be returned from the list iterator (by a call to the next method)

Glossary Item Box

Returns a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list. The specified index indicates the first element that would be returned by an initial call to next. An initial call to previous would return the element with the specified index minus one.

Syntax

public java.util.ListIterator<ImGearLayer> listIterator(
   int index
)

Parameters

index
index of first element to be returned from the list iterator (by a call to the next method)

Return Value

a list iterator of the elements in this list (in proper sequence), starting at the specified position in this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : remove Method

Glossary Item Box

Removes the specified layer from the array.

Overload List

Overload | Description
remove(Object) | Removes the specified layer from the array.
remove(int) | Removes layer with the specified index from the array. ImGearLayer

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

remove(Object) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > remove Method : remove(Object) Method
value
Layer to remove from the array.

Glossary Item Box

Removes the specified layer from the array.

Syntax

public boolean remove(
   java.lang.Object value
)

Parameters

value
Layer to remove from the array.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

remove(int) Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > remove Method : remove(int) Method
index
Layer index to remove from the array.

Glossary Item Box

Removes layer with the specified index from the array.

ImGearLayer

Syntax

public ImGearLayer remove(
   int index
)

Parameters

index
Layer index to remove from the array.

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

removeAll Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : removeAll Method
c
collection containing elements to be removed from this list

Glossary Item Box

Removes from this list all of its elements that are contained in the specified collection (optional operation).

Syntax

public boolean removeAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be removed from this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
remove(Object) Method
contains Method


%%PageItemTitle%%

retainAll Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : retainAll Method
c
collection containing elements to be retained in this list

Glossary Item Box

Retains only the elements in this list that are contained in the specified collection (optional operation). In other words, removes from this list all the elements that are not contained in the specified collection.

Syntax

public boolean retainAll(
   java.util.Collection<?> c
)

Parameters

c
collection containing elements to be retained in this list

Return Value

true if this list changed as a result of the call

Exceptions

Exception | Description
java.lang.UnsupportedOperationException |
java.lang.ClassCastException |
java.lang.NullPointerException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
remove(Object) Method
contains Method


%%PageItemTitle%%

set Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : set Method
index
Index of the page to get or set.
element
Element to be stored at the specified position.

Glossary Item Box

Sets the page at the specified index.

Syntax

public ImGearLayer set(
   int index,
   ImGearLayer element
)

Parameters

index
Index of the page to get or set.
element
Element to be stored at the specified position.

Return Value

the element previously at the specified position

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

size Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : size Method

Glossary Item Box

Returns the number of elements in this list. If this list contains more than Integer.MAX_VALUE elements, returns Integer.MAX_VALUE.

Syntax

public int size()

Return Value

the number of elements in this list

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

subList Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : subList Method
fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Glossary Item Box

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive. (If fromIndex and toIndex are equal, the returned list is empty.) The returned list is backed by this list, so non-structural changes in the returned list are reflected in this list, and vice-versa. The returned list supports all of the optional list operations supported by this list.

This method eliminates the need for explicit range operations (of the sort that commonly exist for arrays). Any operation that expects a list can be used as a range operation by passing a subList view instead of a whole list. For example, the following idiom removes a range of elements from a list:

 list.subList(from, to).clear();
Similar idioms may be constructed for indexOf and lastIndexOf, and all of the algorithms in the Collections class can be applied to a subList.

The semantics of the list returned by this method become undefined if the backing list (i.e., this list) is structurally modified in any way other than via the returned list. (Structural modifications are those that change the size of this list, or otherwise perturb it in such a fashion that iterations in progress may yield incorrect results.)

Syntax

public java.util.List<ImGearLayer> subList(
   int fromIndex,
   int toIndex
)

Parameters

fromIndex
low endpoint (inclusive) of the subList
toIndex
high endpoint (exclusive) of the subList

Return Value

a view of the specified range within this list

Exceptions

Exception | Description
java.lang.IndexOutOfBoundsException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

toArray Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class : toArray Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Overload List

Overload Description
toArray() Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

toArray<T>(T[]) Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members


%%PageItemTitle%%

toArray() Method
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > toArray Method : toArray() Method

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element).

The returned array will be "safe" in that no references to it are maintained by this list. (In other words, this method must allocate a new array even if this list is backed by an array). The caller is thus free to modify the returned array.

This method acts as bridge between array-based and collection-based APIs.

Syntax

public java.lang.Object[] toArray()

Return Value

an array containing all of the elements in this list in proper sequence

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

T
toArray<T>(T[]) Method
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package > ImGearLayerArray Class > toArray Method : toArray<T>(T[]) Method
a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Glossary Item Box

Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array. If the list fits in the specified array, it is returned therein. Otherwise, a new array is allocated with the runtime type of the specified array and the size of this list.

If the list fits in the specified array with room to spare (i.e., the array has more elements than the list), the element in the array immediately following the end of the list is set to null. (This is useful in determining the length of the list only if the caller knows that the list does not contain any null elements.)

Like the toArray method, this method acts as bridge between array-based and collection-based APIs. Further, this method allows precise control over the runtime type of the output array, and may, under certain circumstances, be used to save allocation costs.

Suppose x is a list known to contain only strings. The following code can be used to dump the list into a newly allocated array of String:

 String[] y = x.toArray(new String[0]);
Note that toArray(new Object[0]) is identical in function to toArray().

Syntax

public <T> T[] toArray(
   T[] a
)

Parameters

a
the array into which the elements of this list are to be stored, if it is big enough; otherwise, a new array of the same runtime type is allocated for this purpose.

Type Parameters

T

Return Value

an array containing the elements of this list

Exceptions

Exception | Description
java.lang.ArrayStoreException |
java.lang.NullPointerException |

See Also

Reference

ImGearLayerArray Class
ImGearLayerArray Members
Overload List


%%PageItemTitle%%

ImGearLayeredPage Class
See Also Members Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayeredPage Class

Glossary Item Box

Represents a page with image layers.

Any Adobe PSD image can consist of multiple layers. ImageGear can only read, write and edit image layers, that is, layers represented by a raster image.

Object Model

ImGearLayeredPage ClassImGearLayeredPage ClassImGearRasterPage ClassImGearRasterPage ClassImGearRasterPage ClassImGearColorProfile ClassImGearPage ClassImGearColorSpace ClassImGearSize ClassImGearDIB ClassIImGearDICOMDisplaySettings InterfaceImGearDocument ClassImGearLayerArray ClassImGearLUT ClassImGearMetadataHead ClassImGearROI Class

Syntax

public class ImGearLayeredPage
    extends com.accusoft.imagegear.core.ImGearRasterPage

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.core.ImGearPage
com.accusoft.imagegear.core.ImGearRasterPage
com.accusoft.imagegear.processing.layers.ImGearLayeredPage

See Also

Reference

ImGearLayeredPage Members
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearLayeredPage Class Members
See Also Fields Methods Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayeredPage Class

Glossary Item Box

The following tables list the members exposed by ImGearLayeredPage.

Public Constructors

 | Name | Description
public Constructor | ImGearLayeredPage Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | clone | Clones the layered page object.
public Method | flatten | This method renders all the visible layers into the raster composition DIB. This method can be used to flatten the layered page into the raster page. As a result of this method, the base com.accusoft.imagegear.core.ImGearRasterPage class object is regenerated and can be used to access the result of the flattening operation. com.accusoft.imagegear.core.ImGearRasterPage
public Method | getComposition | Gets layered page composition. com.accusoft.imagegear.core.ImGearPage class object as layers composition. Method renders all the visible layers into the raster composition DIB.
public Method | getCompositionChanellDepths | Gets chanell depths composition.
public Method | getCompositionColorSpace | Returns raster composition com.accusoft.imagegear.core.ImGearColorSpace value.
public Method | getCompositionDimensions | Gets dimensions composition.
public Method | getLayers | Gets the array of layers from the layered page. ImGearLayerArray class object. ImGearLayerArray
public Method | setCompositionChanellDepths | Sets chanell depths composition.
public Method | setCompositionColorSpace | Sets raster composition com.accusoft.imagegear.core.ImGearColorSpace value.
public Method | setCompositionDimensions | Sets dimensions composition.
Top

See Also

Reference

ImGearLayeredPage Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearLayeredPage Class Fields
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayeredPage Class

Glossary Item Box

For a list of all members of this type, see ImGearLayeredPage members.

See Also

Reference

ImGearLayeredPage Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

ImGearLayeredPage Constructor
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : ImGearLayeredPage Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearLayeredPage Constructor(ImGearLayerArray) | Initializes a new instance of the ImGearLayeredPage class. Creates a blank layered page from the specified composition of layers.
ImGearLayeredPage Constructor(int,int,ImGearColorSpace,int[],boolean) | Initializes a new instance of the ImGearLayeredPage class.
ImGearLayeredPage Constructor(ImGearPage) | Initializes a new instance of the ImGearLayeredPage class.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

ImGearLayeredPage Constructor(ImGearLayerArray)
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(ImGearLayerArray)
layers
Composition of layers. ImGearLayerArray

Glossary Item Box

Initializes a new instance of the ImGearLayeredPage class.

Creates a blank layered page from the specified composition of layers.

Syntax

public ImGearLayeredPage(
   ImGearLayerArray layers
)

Parameters

layers
Composition of layers. ImGearLayerArray

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List


%%PageItemTitle%%

ImGearLayeredPage Constructor(int,int,ImGearColorSpace,int[],boolean)
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(int,int,ImGearColorSpace,int[],boolean)
width
Width of the page.
height
Height of the page.
colorSpace
Color space of the page.
channelDepths
Channel depths of the page.
allocatePixels
If true, allocate DIB pixels; false otherwise.

Creates a blank layered page from the specified attributes.

com.accusoft.imagegear.core.ImGearColorSpace

Glossary Item Box

Initializes a new instance of the ImGearLayeredPage class.

Syntax

public ImGearLayeredPage(
   int width,
   int height,
   ImGearColorSpace colorSpace,
   int[] channelDepths,
   boolean allocatePixels
)

Parameters

width
Width of the page.
height
Height of the page.
colorSpace
Color space of the page.
channelDepths
Channel depths of the page.
allocatePixels
If true, allocate DIB pixels; false otherwise.

Creates a blank layered page from the specified attributes.

com.accusoft.imagegear.core.ImGearColorSpace

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List


%%PageItemTitle%%

ImGearLayeredPage Constructor(ImGearPage)
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class > ImGearLayeredPage Constructor : ImGearLayeredPage Constructor(ImGearPage)
page
Page to copy DIB and Metadata from.

Creates a layered page from the specified com.accusoft.imagegear.core.ImGearPage, by copying its DIB and Metadata, and creating an empty array of layers.

Glossary Item Box

Initializes a new instance of the ImGearLayeredPage class.

Syntax

public ImGearLayeredPage(
   ImGearPage page
)

Parameters

page
Page to copy DIB and Metadata from.

Creates a layered page from the specified com.accusoft.imagegear.core.ImGearPage, by copying its DIB and Metadata, and creating an empty array of layers.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members
Overload List


%%PageItemTitle%%

BackgroundAllowed Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : BackgroundAllowed Method

Glossary Item Box

Syntax

public boolean BackgroundAllowed()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

CheckApplyDICOMDisplaySettings Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : CheckApplyDICOMDisplaySettings Method

Glossary Item Box

Syntax

public void CheckApplyDICOMDisplaySettings()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearLayeredPage Class Methods
See Also Send Feedback
com.accusoft.imagegear.processing.layers Package : ImGearLayeredPage Class

Glossary Item Box

For a list of all members of this type, see ImGearLayeredPage members.

Public Methods

 | Name | Description
public Method | clone | Clones the layered page object.
public Method | flatten | This method renders all the visible layers into the raster composition DIB. This method can be used to flatten the layered page into the raster page. As a result of this method, the base com.accusoft.imagegear.core.ImGearRasterPage class object is regenerated and can be used to access the result of the flattening operation. com.accusoft.imagegear.core.ImGearRasterPage
public Method | getComposition | Gets layered page composition. com.accusoft.imagegear.core.ImGearPage class object as layers composition. Method renders all the visible layers into the raster composition DIB.
public Method | getCompositionChanellDepths | Gets chanell depths composition.
public Method | getCompositionColorSpace | Returns raster composition com.accusoft.imagegear.core.ImGearColorSpace value.
public Method | getCompositionDimensions | Gets dimensions composition.
public Method | getLayers | Gets the array of layers from the layered page. ImGearLayerArray class object. ImGearLayerArray
public Method | setCompositionChanellDepths | Sets chanell depths composition.
public Method | setCompositionColorSpace | Sets raster composition com.accusoft.imagegear.core.ImGearColorSpace value.
public Method | setCompositionDimensions | Sets dimensions composition.
Top

See Also

Reference

ImGearLayeredPage Class
com.accusoft.imagegear.processing.layers Package


%%PageItemTitle%%

clone Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : clone Method

Glossary Item Box

Clones the layered page object.

Syntax

public ImGearLayeredPage clone()

Return Value

com.accusoft.imagegear.core.ImGearPage class object.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

flatten Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : flatten Method

Glossary Item Box

This method renders all the visible layers into the raster composition DIB.

This method can be used to flatten the layered page into the raster page. As a result of this method, the base com.accusoft.imagegear.core.ImGearRasterPage class object is regenerated and can be used to access the result of the flattening operation.

com.accusoft.imagegear.core.ImGearRasterPage

Syntax

public void flatten()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getComposition Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getComposition Method

Glossary Item Box

Gets layered page composition.

com.accusoft.imagegear.core.ImGearPage class object as layers composition. Method renders all the visible layers into the raster composition DIB.

Syntax

public ImGearPage getComposition()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getCompositionChanellDepths Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getCompositionChanellDepths Method

Glossary Item Box

Gets chanell depths composition.

Syntax

public int[] getCompositionChanellDepths()

Return Value

Array of integer.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getCompositionColorSpace Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getCompositionColorSpace Method

Glossary Item Box

Returns raster composition com.accusoft.imagegear.core.ImGearColorSpace value.

Syntax

public ImGearColorSpace getCompositionColorSpace()

Return Value

com.accusoft.imagegear.core.ImGearColorSpace value.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getCompositionDimensions Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getCompositionDimensions Method

Glossary Item Box

Gets dimensions composition.

Syntax

public ImGearSize getCompositionDimensions()

Return Value

com.accusoft.imagegear.core.ImGearSize class object.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getLayers Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getLayers Method

Glossary Item Box

Gets the array of layers from the layered page.

ImGearLayerArray class object. ImGearLayerArray

Syntax

public ImGearLayerArray getLayers()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

getLUT Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : getLUT Method

Glossary Item Box

Syntax

public ImGearLUT getLUT()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

MergeMasked Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : MergeMasked Method
srcPage

Glossary Item Box

Syntax

public void MergeMasked(
   ImGearRasterPage srcPage
)

Parameters

srcPage

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

OffscreenAllowed Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : OffscreenAllowed Method

Glossary Item Box

Syntax

public boolean OffscreenAllowed()

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

setCheckApplyDICOMDisplaySettingsStatic Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : setCheckApplyDICOMDisplaySettingsStatic Method
value

Glossary Item Box

Syntax

public static void setCheckApplyDICOMDisplaySettingsStatic(
   com.accusoft.imagegear.core.ImGearRasterPage.CheckApplyDICOMDisplaySettingsDelegate value
)

Parameters

value

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

setCompositionChanellDepths Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : setCompositionChanellDepths Method
value
Array of integer.

Glossary Item Box

Sets chanell depths composition.

Syntax

public void setCompositionChanellDepths(
   int[] value
)

Parameters

value
Array of integer.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

setCompositionColorSpace Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : setCompositionColorSpace Method
value
com.accusoft.imagegear.core.ImGearColorSpace value.

Glossary Item Box

Sets raster composition com.accusoft.imagegear.core.ImGearColorSpace value.

Syntax

public void setCompositionColorSpace(
   ImGearColorSpace value
)

Parameters

value
com.accusoft.imagegear.core.ImGearColorSpace value.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

setCompositionDimensions Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : setCompositionDimensions Method
value
com.accusoft.imagegear.core.ImGearSize class object.

Glossary Item Box

Sets dimensions composition.

Syntax

public void setCompositionDimensions(
   ImGearSize value
)

Parameters

value
com.accusoft.imagegear.core.ImGearSize class object.

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

setInternalDIB Method
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : setInternalDIB Method
value

Glossary Item Box

Syntax

public void setInternalDIB(
   ImGearDIB value
)

Parameters

value

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

Annotations Field
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : Annotations Field

Glossary Item Box

Syntax

public java.lang.Object Annotations

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

m_CheckApplyDICOMDisplaySettings Field
com.accusoft.imagegear.processing.layers Package > ImGearLayeredPage Class : m_CheckApplyDICOMDisplaySettings Field

Glossary Item Box

Syntax

public com.accusoft.imagegear.core.ImGearRasterPage.CheckApplyDICOMDisplaySettingsDelegate m_CheckApplyDICOMDisplaySettings

See Also

Reference

ImGearLayeredPage Class
ImGearLayeredPage Members


%%PageItemTitle%%

ImGearLayerType Enumeration
com.accusoft.imagegear.processing.layers Package : ImGearLayerType Enumeration

Glossary Item Box

Supported layer types.

Members

Member | Description
Image | Image layer type.
Unknown | Unknown (unrecognized by ImageGear) layer type.

Inheritance Hierarchy

java.lang.Object
java.lang.Enum
com.accusoft.imagegear.processing.layers.ImGearLayerType

See Also

Reference

com.accusoft.imagegear.processing.layers Package


%%ItemTitle%%

com.accusoft.imagegear.utility Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This is the package for infrastructure classes.

Classes

Class | Description
ImGearRectangleF | Rectangle of floats.
ImGearRefObject<T> This class is passed as arguments to methods that might reassign the argvalues to new instances of the type, T.

You might use it as follows:

 Mutable inVal = new Mutable();

 // create an ImGearRefObject below with an argvalue referring to inVal.

 ImGearRefObject<Mutable> refArg = new ImGearRefObject<Mutable>(inVal);

 // exchangeInOutArg() below may not only modify

 // (the internal state of) inVal, but may also reassign refArg.argvalue

 // to a new instance of Mutable.

 exchangeInOutArg(refArg);

 // now, perhaps refArg.argvalue != inVal.

 // assign the potentially new value to outVal below.

 Mutable outVal = refArg.argvalue;

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.utility Package Inheritance Hierarchy

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.utility.ImGearRectangleF
com.accusoft.imagegear.utility.ImGearRefObject<T>

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearRectangleF Class
See Also Members Send Feedback
com.accusoft.imagegear.utility Package : ImGearRectangleF Class

Glossary Item Box

Rectangle of floats.

Object Model

ImGearRectangleF ClassImGearRectangleF Class

Syntax

public class ImGearRectangleF
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.ImGearRectangleF

See Also

Reference

ImGearRectangleF Members
com.accusoft.imagegear.utility Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRectangleF Class Members
See Also Methods Send Feedback
com.accusoft.imagegear.utility Package : ImGearRectangleF Class

Glossary Item Box

The following tables list the members exposed by ImGearRectangleF.

Public Constructors

 | Name | Description
public Constructor | ImGearRectangleF Constructor | Overloaded.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | fromRectangle | Conversion utility.
public Method | getBottom | Accessor for bottom side.
public Method | getHeight | Accessor for top side.
public Method | getLeft | Accessor for left side.
public Method | getRight | Accessor for right side.
public Method | getTop | Accessor for top side.
public Method | getWidth | Accessor for width.
public Method | setHeight | Sets the height.
public Method | setWidth | Sets the width.
Top

See Also

Reference

ImGearRectangleF Class
com.accusoft.imagegear.utility Package


%%PageItemTitle%%

ImGearRectangleF Constructor
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : ImGearRectangleF Constructor

Glossary Item Box

Overload List

Overload | Description
ImGearRectangleF Constructor(int,int,float,float) | Constructor for integer values.
ImGearRectangleF Constructor(float,float,float,float) | Constructor for float values.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

ImGearRectangleF Constructor(int,int,float,float)
See Also Send Feedback
com.accusoft.imagegear.utility Package > ImGearRectangleF Class > ImGearRectangleF Constructor : ImGearRectangleF Constructor(int,int,float,float)
left
Left side.
top
Top.
width
Width.
height
Height.

Glossary Item Box

Constructor for integer values.

Syntax

public ImGearRectangleF(
   int left,
   int top,
   float width,
   float height
)

Parameters

left
Left side.
top
Top.
width
Width.
height
Height.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members
Overload List


%%PageItemTitle%%

ImGearRectangleF Constructor(float,float,float,float)
See Also Send Feedback
com.accusoft.imagegear.utility Package > ImGearRectangleF Class > ImGearRectangleF Constructor : ImGearRectangleF Constructor(float,float,float,float)
left
Left side.
top
Top.
width
Width.
height
Height.

Glossary Item Box

Constructor for float values.

Syntax

public ImGearRectangleF(
   float left,
   float top,
   float width,
   float height
)

Parameters

left
Left side.
top
Top.
width
Width.
height
Height.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
ImGearRectangleF Class Methods
See Also Send Feedback
com.accusoft.imagegear.utility Package : ImGearRectangleF Class

Glossary Item Box

For a list of all members of this type, see ImGearRectangleF members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | fromRectangle | Conversion utility.
public Method | getBottom | Accessor for bottom side.
public Method | getHeight | Accessor for top side.
public Method | getLeft | Accessor for left side.
public Method | getRight | Accessor for right side.
public Method | getTop | Accessor for top side.
public Method | getWidth | Accessor for width.
public Method | setHeight | Sets the height.
public Method | setWidth | Sets the width.
Top

See Also

Reference

ImGearRectangleF Class
com.accusoft.imagegear.utility Package


%%PageItemTitle%%

fromRectangle Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : fromRectangle Method
r
java.awt.Rectangle to convert from.

Glossary Item Box

Conversion utility.

Syntax

public static ImGearRectangleF fromRectangle(
   java.awt.Rectangle r
)

Parameters

r
java.awt.Rectangle to convert from.

Return Value

New instance of this class.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getBottom Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getBottom Method

Glossary Item Box

Accessor for bottom side.

Syntax

public float getBottom()

Return Value

Bottom side.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getHeight Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getHeight Method

Glossary Item Box

Accessor for top side.

Syntax

public float getHeight()

Return Value

Top side.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getLeft Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getLeft Method

Glossary Item Box

Accessor for left side.

Syntax

public float getLeft()

Return Value

Left side.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getRight Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getRight Method

Glossary Item Box

Accessor for right side.

Syntax

public float getRight()

Return Value

Right side.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getTop Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getTop Method

Glossary Item Box

Accessor for top side.

Syntax

public float getTop()

Return Value

Top side.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

getWidth Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : getWidth Method

Glossary Item Box

Accessor for width.

Syntax

public float getWidth()

Return Value

Width.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

setHeight Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : setHeight Method
v
The new height.

Glossary Item Box

Sets the height.

Syntax

public void setHeight(
   float v
)

Parameters

v
The new height.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

setWidth Method
com.accusoft.imagegear.utility Package > ImGearRectangleF Class : setWidth Method
v
The new width.

Glossary Item Box

Sets the width.

Syntax

public void setWidth(
   float v
)

Parameters

v
The new width.

See Also

Reference

ImGearRectangleF Class
ImGearRectangleF Members


%%PageItemTitle%%

T
the type of argument of potential reassignment
ImageGear for Java
ImGearRefObject<T> Class
See Also Members Send Feedback
com.accusoft.imagegear.utility Package : ImGearRefObject<T> Class

Glossary Item Box

This class is passed as arguments to methods that might reassign the argvalues to new instances of the type, T.

You might use it as follows:

 Mutable inVal = new Mutable();

 // create an ImGearRefObject below with an argvalue referring to inVal.

 ImGearRefObject<Mutable> refArg = new ImGearRefObject<Mutable>(inVal);

 // exchangeInOutArg() below may not only modify

 // (the internal state of) inVal, but may also reassign refArg.argvalue

 // to a new instance of Mutable.

 exchangeInOutArg(refArg);

 // now, perhaps refArg.argvalue != inVal.

 // assign the potentially new value to outVal below.

 Mutable outVal = refArg.argvalue;

Object Model

ImGearRefObject<T> Class

Syntax

public sealed class ImGearRefObject<T>
    extends Object

Type Parameters

T
the type of argument of potential reassignment

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.ImGearRefObject<T>

See Also

Reference

ImGearRefObject<T> Members
com.accusoft.imagegear.utility Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearRefObject<T> Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.utility Package : ImGearRefObject<T> Class

Glossary Item Box

The following tables list the members exposed by ImGearRefObject<T>.

Public Constructors

 | Name | Description
public Constructor | ImGearRefObject<T> Constructor | Only constructor.
Top

Public Fields

 | Name | Description
public Field | argvalue | The reference that the called method might change.
Top

See Also

Reference

ImGearRefObject<T> Class
com.accusoft.imagegear.utility Package


%%PageItemTitle%%

ImGearRefObject<T> Constructor
com.accusoft.imagegear.utility Package > ImGearRefObject<T> Class : ImGearRefObject<T> Constructor
refarg
to be assigned to .

Glossary Item Box

Only constructor.

Syntax

public ImGearRefObject<T>(
   T refarg
)

Parameters

refarg
to be assigned to .

See Also

Reference

ImGearRefObject<T> Class
ImGearRefObject<T> Members


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearRefObject<T> Class Fields
See Also Send Feedback
com.accusoft.imagegear.utility Package : ImGearRefObject<T> Class

Glossary Item Box

For a list of all members of this type, see ImGearRefObject<T> members.

Public Fields

 | Name | Description
public Field | argvalue | The reference that the called method might change.
Top

See Also

Reference

ImGearRefObject<T> Class
com.accusoft.imagegear.utility Package


%%PageItemTitle%%

argvalue Field
com.accusoft.imagegear.utility Package > ImGearRefObject<T> Class : argvalue Field

Glossary Item Box

The reference that the called method might change.

Syntax

public T argvalue

See Also

Reference

ImGearRefObject<T> Class
ImGearRefObject<T> Members


%%ItemTitle%%

com.accusoft.imagegear.utility.events Package
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

This is the package for event handling.

Classes

Class | Description
ImGearEventArgs | Base class for many event types passed to client handlers.

Interfaces

Interface | Description
IImGearEvent<T> | Implemented by SDK events to allow clients to add or remove their handlers. Clients must implement their IImGearEventHandler<T> with a supertype of the type, T that this event is declared with. When the SDK fires the event, it passes an argument of type T to all handlers.
IImGearEventHandler<T> | Interface to be implemented by clients to be notified of events.

See Also

Reference

ImageGear for Java Project


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

com.accusoft.imagegear.utility.events Package Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs

See Also

Reference

ImageGear for Java Project


%%PageItemTitle%%

ImGearEventArgs Class
See Also Members Send Feedback
com.accusoft.imagegear.utility.events Package : ImGearEventArgs Class

Glossary Item Box

Base class for many event types passed to client handlers.

Object Model

ImGearEventArgs Class

Syntax

public class ImGearEventArgs
    extends Object

Inheritance Hierarchy

java.lang.Object
com.accusoft.imagegear.utility.events.ImGearEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedAttributeEventArgs
com.accusoft.imagegear.art.ImGearARTDroppedMarkEventArgs
com.accusoft.imagegear.art.ImGearMarkEventArgs
com.accusoft.imagegear.art.ImGearMarkPointEventArgs

See Also

Reference

ImGearEventArgs Members
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
ImGearEventArgs Class Members
See Also Fields Send Feedback
com.accusoft.imagegear.utility.events Package : ImGearEventArgs Class

Glossary Item Box

The following tables list the members exposed by ImGearEventArgs.

Public Fields

 | Name | Description
public Field | EMPTY | Represents an event with no event data.
Top

See Also

Reference

ImGearEventArgs Class
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Fields$$

[image]
ImageGear for Java
ImGearEventArgs Class Fields
See Also Send Feedback
com.accusoft.imagegear.utility.events Package : ImGearEventArgs Class

Glossary Item Box

For a list of all members of this type, see ImGearEventArgs members.

Public Fields

 | Name | Description
public Field | EMPTY | Represents an event with no event data.
Top

See Also

Reference

ImGearEventArgs Class
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%%

EMPTY Field
com.accusoft.imagegear.utility.events Package > ImGearEventArgs Class : EMPTY Field

Glossary Item Box

Represents an event with no event data.

Syntax

public ImGearEventArgs EMPTY

See Also

Reference

ImGearEventArgs Class
ImGearEventArgs Members


%%PageItemTitle%%

T
IImGearEvent<T> Interface
See Also Members Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEvent<T> Interface

Glossary Item Box

Implemented by SDK events to allow clients to add or remove their handlers.

Clients must implement their IImGearEventHandler<T> with a supertype of the type, T that this event is declared with.
When the SDK fires the event, it passes an argument of type T to all handlers.

Syntax

public interface IImGearEvent<T>

Type Parameters

T

See Also

Reference

IImGearEvent<T> Members
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearEvent<T> Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEvent<T> Interface

Glossary Item Box

The following tables list the members exposed by IImGearEvent<T>.

Public Methods

 | Name | Description
Method | add | To add an event handler.
Method | remove | To remove an event handler.
Top

See Also

Reference

IImGearEvent<T> Interface
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearEvent<T> Interface Methods
See Also Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEvent<T> Interface

Glossary Item Box

For a list of all members of this type, see IImGearEvent<T> members.

Public Methods

 | Name | Description
Method | add | To add an event handler.
Method | remove | To remove an event handler.
Top

See Also

Reference

IImGearEvent<T> Interface
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%%

add Method
com.accusoft.imagegear.utility.events Package > IImGearEvent<T> Interface : add Method
handler
The event handler to add.

Glossary Item Box

To add an event handler.

Syntax

void add(
   com.accusoft.imagegear.utility.events.IImGearEventHandler<?> handler
)

Parameters

handler
The event handler to add.

See Also

Reference

IImGearEvent<T> Interface
IImGearEvent<T> Members


%%PageItemTitle%%

remove Method
com.accusoft.imagegear.utility.events Package > IImGearEvent<T> Interface : remove Method
handler
The event handler to remove.

Glossary Item Box

To remove an event handler.

Syntax

void remove(
   com.accusoft.imagegear.utility.events.IImGearEventHandler<?> handler
)

Parameters

handler
The event handler to remove.

See Also

Reference

IImGearEvent<T> Interface
IImGearEvent<T> Members


%%PageItemTitle%%

T
A supertype of the type of the argument containing the event information.
ImageGear for Java
IImGearEventHandler<T> Interface
See Also Members Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEventHandler<T> Interface

Glossary Item Box

Interface to be implemented by clients to be notified of events.

Syntax

public interface IImGearEventHandler<T>

Type Parameters

T
A supertype of the type of the argument containing the event information.

See Also

Reference

IImGearEventHandler<T> Members
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Members$$

[image]
ImageGear for Java
IImGearEventHandler<T> Interface Members
See Also Methods Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEventHandler<T> Interface

Glossary Item Box

The following tables list the members exposed by IImGearEventHandler<T>.

Public Methods

 | Name | Description
Method | onEvent | Callback invoked when event fires. Implemented by clients of the event and "registered" via IImGearEvent.add(IImGearEventHandler).
Top

See Also

Reference

IImGearEventHandler<T> Interface
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%% $$Methods$$

[image]
ImageGear for Java
IImGearEventHandler<T> Interface Methods
See Also Send Feedback
com.accusoft.imagegear.utility.events Package : IImGearEventHandler<T> Interface

Glossary Item Box

For a list of all members of this type, see IImGearEventHandler<T> members.

Public Methods

 | Name | Description
Method | onEvent | Callback invoked when event fires. Implemented by clients of the event and "registered" via IImGearEvent.add(IImGearEventHandler).
Top

See Also

Reference

IImGearEventHandler<T> Interface
com.accusoft.imagegear.utility.events Package


%%PageItemTitle%%

onEvent Method
com.accusoft.imagegear.utility.events Package > IImGearEventHandler<T> Interface : onEvent Method
sender
object firing the event.
arg
information about the event, passed by sender, a subtype of the declared type, T, of this.

Glossary Item Box

Callback invoked when event fires.

Implemented by clients of the event and "registered" via IImGearEvent.add(IImGearEventHandler).

Syntax

void onEvent(
   java.lang.Object sender,
   T arg
)

Parameters

sender
object firing the event.
arg
information about the event, passed by sender, a subtype of the declared type, T, of this.

See Also

Reference

IImGearEventHandler<T> Interface
IImGearEventHandler<T> Members